Prado Manual

Prado 3.2.0 Manual

Created On: 25 Jun 2012
Written By: Qiang Xue, Wei Zhuo
Edited By: Wei Zhuo
Copyright © 2005-2012 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Welcome to the PRADO Quickstart Tutorial

This Quickstart tutorial is provided to help you quickly start building your own Web applications based on PRADO version 3.x.

If you are an existing PRADO 3.x user and would like to learn what enhancements are available for each new version, please check out the new features page. Otherwise, the following sections are helpful for newbies.

You may refer to the following resources if you find this tutorial does not fulfill all your needs.

  • PRADO Classes
  • PRADO API Documentation
  • PRADO Forum
  • PRADO Wiki
  • PRADO Issue Tracker
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

What is PRADO?

PRADO is a component-based and event-driven programming framework for developing Web applications in PHP 5. PRADO stands for PHP Rapid Application Development Object-oriented.

A primary goal of PRADO is to enable maximum reusability in Web programming. By reusability, we mean not only reusing one's own code, but also reusing other people's code in an easy way. The latter is more important as it saves the effort of reinventing the wheels and may cut off development time dramatically. The introduction of the concept of component is for this purpose.

To achieve the above goal, PRADO stipulates a protocol of writing and using components to construct Web applications. A component is a software unit that is self-contained and can be reused with trivial customization. New components can be created by simple composition of existing components.

To facilitate interacting with components, PRADO implements an event-driven programming paradigm that allows delegation of extensible behavior to components. End-user activities, such as clicking on a submit button, are captured as server events. Methods or functions may be attached to these events so that when the events happen, they are invoked automatically to respond to the events. Compared with the traditional Web programming in which developers have to deal with the raw POST or GET variables, event-driven programming helps developers better focus on the necessary logic and reduces significantly the low-level repetitive coding.

In summary, developing a PRADO Web application mainly involves instantiating prebuilt component types, configuring them by setting their properties, responding to their events by writing handler functions, and composing them into pages for the application. It is very similar to RAD toolkits, such as Borland Delphi and Microsoft Visual Basic, that are used to develop desktop GUI applications.

Why PRADO?

PRADO is mostly quoted as a unique framework. In fact, it is so unique that it may turn your boring PHP programming into a fun task. The following list is a short summary of the main features of PRADO,

  • Reusability - Code following the PRADO component protocol are highly reusable. This benefits development teams in the long run as they can reuse their previous work and integrate other parties' work easily.
  • Event-driven programming - End-user activities, such as clicking on a submit button, are captured as server events so that developers have better focus on dealing with user interactions.
  • Team integration - Presentation and logic are separately stored. PRADO applications are themable.
  • Powerful Web controls - PRADO comes with a set of powerful components dealing with Web user interfaces. Highly interactive Web pages can be created with a few lines of code. For example, using the datagrid component, one can quickly create a page presenting a data table which allows paging, sorting, editing, and deleting rows of the data.
  • Strong database support - Since version 3.1, PRADO has been equipped with complete database support which is natively written and thus fits seemlessly with the rest part of the PRADO framework. According to the complexity of the business objects, one can choose to use the simple PDO-based data access, or the widely known active record, or the complete business object mapping scheme SqlMap.
  • Seamless AJAX support - Using AJAX in PRADO has never been easier with its innovative active controls introduced since version 3.1. You can easily write an AJAX-enabled application without writing a single line of javascript code. In fact, using active controls is not much different from using the regular non-AJAX enabled Web controls.
  • I18N and L10N support - PRADO includes complete support for building applications with multiple languages and locales.
  • XHTML compliance - Web pages generated by PRADO are XHTML-compliant.
  • Accommodation of existing work - PRADO is a generic framework with focus on the presentational layer. It does not exclude developers from using most existing class libraries or toolkits. For example, one can AdoDB or Creole to deal with DB in his PRADO application.
  • Other features - Powerful error/exception handling and message logging; generic caching and selective output caching; customizable and localizable error handling; extensible authentication and authorization; security measures such as cross-site script (XSS) prevention, cookie protection, etc.

What Is PRADO Best For?

PRADO is best suitable for creating Web applications that are highly user-interactive. It can be used to develop systems as simple as a blog system to those as complex as a content management system (CMS) or a complete e-commerce solution. Because PRADO promotes object-oriented programming through its component-based methodology, it fits extremely well for team work and enterprise development.

PRADO comes with a complete set of caching techniques which help accelerate PRADO Web applications to accommodate high traffic requirement. Its modular architecture allows developers to use or plug in different cache modules for different needs. The output caching enables one to selectively choose to cache part of a rendered Web page.

How Is PRADO Compared with Other Frameworks?

PRADO is often quoted as a unique framework. Its uniqueness mainly lies in the component-based and event-driven programming paradigm that it tries to promote. Although this programming paradigm is not new in desktop application programming and not new in a few Web programming languages, PRADO is perhaps the first PHP framework enabling it.

Most PHP frameworks mainly focuses on separating presentation and logic and promotes the MVC (model-view-controller) design pattern. PRADO achieves the same goal naturally by requiring logic be stored in classes and presentation in templates. PRADO does much more on aspects other than MVC. It fills lot of blank area in PHP Web programming with its component-based programming paradigm, its rich set of Web controls, its powerful database support, its flexible error handling and logging feature, and many others.

Is PRADO Stable Enough?

Yes. PRADO was initially released in August 2004. Many test suites have been written and conducted frequently to ensure its quality. It has been used by thousands of developers and many Web applications have been developed based on it. Bugs and feature requests are managed through TRAC system and we have a great user community and development team to ensure all questions are answered in a timely fashion.

History of PRADO

The very original inspiration of PRADO came from Apache Tapestry. During the design and implementation, I borrowed many ideas from Borland Delphi and Microsoft ASP.NET. The first version of PRADO came out in June 2004 and was written in PHP 4. Driven by the Zend PHP 5 coding contest, I rewrote PRADO in PHP 5, which proved to be a wise move, thanks to the new object model provided by PHP 5. PRADO won the grand prize in the Zend contest, earning the highest votes from both the public and the judges' panel.

In August 2004, PRADO started to be hosted on SourceForge as an open source project. Soon after, the project site xisc.com was announced to public. With the fantastic support of PRADO developer team and PRADO users, PRADO evolved to version 2.0 in mid 2005. In this version, Wei Zhuo contributed to PRADO with the excellent I18N and L10N support.

In May 2005, we decided to completely rewrite the PRADO framework to resolve a few fundamental issues found in version 2.0 and to catch up with some cool features available in Microsoft ASP.NET 2.0. After nearly a year's hard work with over 50,000 lines of new code, version 3.0 was finally made available in April 2006.

Starting from version 3.0, significant efforts are allocated to ensure the quality and stability of PRADO. If we say PRADO v2.x and v1.x are proof-of-concept work, we can say PRADO 3.x has grown up to a project that is suitable for serious business application development.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Installing PRADO

If you are viewing this page from your own Web server, you are already done with the installation.

The minimum requirement by PRADO is that the Web server support PHP 5.2. PRADO has been tested with Apache Web server on Windows and Linux. Highly possibly it may also run on other platforms with other Web servers, as long as PHP 5.2 is supported.

Installation of PRADO mainly involves downloading and unpacking.

  1. Go to pradosoft.com to grab the latest version of PRADO.
  2. Unpack the PRADO release file to a Web-accessible directory.

Your installation of PRADO is done and you can start to play with the demo applications included in the PRADO release via URL http://web-server-address/prado/demos/. Here we assume PRADO is unpacked to the prado subdirectory under the DocumentRoot of the Web server.

If you encounter any problems with the demo applications, please use the PRADO requirement checker script, accessible via http://web-server-address/prado/requirements/index.php, to check first if your server configuration fulfills the conditions required by PRADO.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

New Features

This page summarizes the main new features that are introduced in each PRADO release.

Version 3.2.0

  • Added methods quoteTableName, quoteColumnName, quoteColumnAlias to TDbMetaData & TDbConnection and added TDbConnection:getDbMetaData
  • Added THttpSession::regenerate()
  • Added method getHeaders to THttpRequest & THttpResponse
  • Modified TThemeManager to allow custom subclassing of TTheme
  • Application configuration can be stored in PHP code
  • Added mouse coordinates and key status to drag & drop controls event
  • Permit progressive rendering of a page and added TFlushOutput control to control it
  • Added TReCaptcha control
  • Added a new "Clickable" operating mode to TDatePicker
  • ActiveControls's Visible property is reflected clientside on ajax requests
  • Controls are able to automagically render their javascript dependencies on an ajax callback

Version 3.1.10

  • bugfix-only release

Version 3.1.9

  • Added documentation and samples to the quickstart tutorial for all the active controls
  • Added TTemplateControlInheritable control
  • Added TActiveDataGrid control
  • Added TActiveDataList control
  • Added TActiveMultiView control
  • Added TActiveRepeater control
  • Added TActiveTableRow control
  • Added TActiveTableCell control

Version 3.1.8

  • Updated external packages to support Internet explorer 9

Version 3.1.7

  • Added property ClientScriptManagerClass to TPageService
  • Added property TValidationSummary.ScrollToSummary to server-side control since property exists on client-side
  • Added property TransactionClass (defaults to System.Data.TDbTransaction) to TDbConnection
  • Added ClientSide property to TDropContainer
  • Added Columns property to TInPlaceTextBox

Version 3.1.6

  • Added property TPage.EnableStateCompression and related modifications in TPageStateFormatter since it is unnecessary to compress clientstate if TCachePageStatePersister/TSessionPageStatePersister is used
  • Add property CssClass to TBrowserLog otuput and hide inline CSS

Version 3.1.5

  • Added support for namespaces in TXmlDocument
  • Added Registry for Prado generated clientside counterparts of serverside controls
  • TValidationSummary: new display mode "HeaderOnly" that only render value of HeaderText property
  • TDbCache performance: new property 'FlushInterval' to control how often expired items will be removed
  • Added caching of message files to TException
  • Added a new log route subclass for FirePHP: TFirePhpLogRoute - FirePHP is ideally suited for AJAX development where clean JSON and XML responses are required

Version 3.1.4

  • Added the ability to specify position of popup TDatePicker/TActiveDatePicker
  • Add wildcard support to TUrlMapping

Version 3.1.3

  • Added Drag and drop controls
  • Added TActiveDatePicker control

Version 3.1.2

  • Added a new active control TActivePager that allows to paginate a databound control with an ajax callback.
  • Added TFirebugLogRoute to send logs to the Firebug console

Version 3.1.1

  • Added a new control TTabPanel that displays tabbed views.
  • Added a new control TKeyboard that displays a virtual keyboard for text input.
  • Added a new control TCaptcha that displays a CAPTCHA to keep spammers from signing up for certain accounts online. A related validator TCaptchaValidator is also implemented.
  • Added a new control TSlider that displays a slider which can be used for numeric input.
  • Added a new control TConditional that conditionally displays one of the two kinds of content.
  • Added Oracle DB support to Active Record.
  • Added support to TDataGrid to allow grouping consecutive cells with the same content.
  • Added support to allow configuring page properties and authorization rules using authorization based on remote host address.
  • Added a new page state persister TCachePageStatePersister. It allows page state to be stored using a cache module (e.g. TMemCache, TDbCache, etc.)
  • Added support to the auth framework to allow remembering login.
  • Added support to display a prompt item in TDropDownList and TListBox (something like 'Please select:' as the first list item.)
  • Added support to column mapping in Active Record.

Version 3.1.0

  • Added seamless AJAX support. A whole array of AJAX-enabled controls, called active controls, are introduced. The usage of these active controls is very similar to their non-AJAX counterparts, i.e., plug in and use. For more details, see the tutorial about active controls.
  • Added complete database support.
  • Added new controls, modules and services, including TOutputCache, TSessionPageStatePersister, TFeedService, TJsonService, cache dependency classes, TXmlTransform.
  • Enhanced some data controls with renderers. Renderer enables reusing item templates that are commonly found in TRepeater, TDataList and TDataGrid, and makes the configuration on these controls much cleaner. For more details about renders, see the updated tutorials on TDataGrid.
  • Added support to allow subproperty configuration.
  • Added TDbUserManager and TDbUser to simplify authentication and authorization with user accounts stored in a database.
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Upgrading from v2.x and v1.x

PRADO v3.0 is NOT backward compatible with earlier versions of PRADO.

A good news is, properties and events of most controls remain intact, and the syntax of control templates remains largely unchanged. Therefore, developers' knowledge of earlier versions of PRADO are still applicable in v3.0.

We summarize in the following the most significant changes in v3.0 to help developers upgrade their v2.x and v1.x PRADO applications more easily, if needed.

Component Definition

Version 3.0 has completely discarded the need of component specification files. It relies more on conventions for defining component properties and events. In particular, a property is defined by the existence of a getter method and/or a setter method, while an event is defined by the existence of an on-method. Property and event names in v3.0 are both case-insensitive. As a consequence, developers are now required to take care of type conversions when a component property is being set. For example, the following code is used to define the setter method for the Enabled property of TControl, which is of boolean type,

public function setEnabled($value)
{
    $value=TPropertyValue::ensureBoolean($value);
    $this->setViewState('Enabled',$value,true);
}

where TPropertyValue::ensureBoolean() is used to ensure that the input value be a boolean. This is because when the property is configured in template, a string value is passed to the setter. In previous versions, PRADO knows the property type based on the component specification files and does the type conversion for you.

Application Controller

Application controller now implements a modular architecture. Modules can be plugged in and configured in application specifications. Each module assumes a particular functionality, and they are coordinated together by the application specification is also different from earlier versions.

Pages

Pages in v3.0 are organized in directories which may be compared to the module concept in v2.x. Pages are requested using the path to them. For example, a URL index.php?page=Controls.Samples.Sample1 would be used to request for a page named Sample1 stored under the [BasePath]/Controls/Samples directory, where [BasePath] refers to the root page path. The file name of a page template must be ended with .page, mainly to differentiate page templates from non-page control templates whose file names must be ended with .tpl.

Control Relationship

Version 3.0 redefines the relationships between controls. In particular, the parent-child relationship now refers to the enclosure relationship between controls' presentation. And a new naming-container relationship is introduced to help better manage control IDs. For more details, see the controls section.

Template Syntax

The syntax of control templates in v3.0 remains similar to those in earlier versions, with many enhancements. A major change is about the databinding expression. In v3.0, this is done by the following,

<com:MyComponent PropertyName=<%# PHP expression %> .../>

Expression and statement tags are also changed similarly. For more details, see the template definition section.

Theme Syntax

Themes in v3.0 are defined like control templates with a few restrictions.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

My First PRADO Application

In this section, we guide you through creating your first PRADO application, the famous "Hello World" application.

"Hello World" perhaps is the simplest interactive PRADO application that you can create. It displays to end-users a page with a submit button whose caption is Click Me. After the user clicks on the button, its caption is changed to Hello World.

There are many approaches that can achieve the above goal. One can submit the page to the server, examine the POST variable, and generate a new page with the button caption updated. Or one can simply use JavaScript to update the button caption upon its onclick client event.

PRADO promotes component-based and event-driven Web programming. The button is represented by a TButton object. It encapsulates the button caption as the Text property and associates the user button click action with a server-side OnClick event. To respond to the user clicking on the button, one simply needs to attach a function to the button's OnClick event. Within the function, the button's Text property is modified as "Hello World". The following diagram shows the above sequence,

Our PRADO application consists of three files, index.php, Home.page and Home.php, which are organized as follows, [image] where each directory is explained as follows. Note, the above directory structure can be customized. For example, one can move the protected directory out of Web directories. You will know how to do this after you go through this tutorial.

  • assets - directory storing published private files. See assets section for more details. This directory must be writable by the Web server process.
  • protected - application base path storing application data and private script files. This directory should be configured as inaccessible to end-users.
  • runtime - application runtime storage path storing application runtime information, such as application state, cached data, etc. This directory must be writable by the Web server process.
  • pages - base path storing all PRADO pages.
Tip:You may also use the framework/prado-cli.php command line script to create the Prado project directory structure. For example, type the command php path/to/prado-cli.php -c helloworld in the directory where you want to create the helloworld project.

The three files that we need are explained as follows.

  • index.php - entry script of the PRADO application. This file is required by all PRADO applications and is the only script file that is directly accessible by end-users. Content in index.php mainly consists of the following three lines,
    require_once('path/to/prado.php');  // include the prado script
$application=new TApplication;      // create a PRADO application instance
$application->run();                // run the application
  • Home.page - template for the default page returned when users do not explicitly specify the page requested. A template specifies the presentational layout of components. In this example, we use two components, TForm and TButton, which correspond to the <form> and <input> HTML tags, respectively. The template contains the following content,
    <html>
  <body>
    <com:TForm>
      <com:TButton Text="Click me" OnClick="buttonClicked" />
    </com:TForm>
  </body>
</html>
  • Home.php - page class for the Home page. It mainly contains the method responding to the OnClick event of the button.
    class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        // $sender refers to the button component
        $sender->Text="Hello World!";
    }
}

The application is now ready and can be accessed via: http://Web-server-address/helloworld/index.php, assuming helloworld is directly under the Web DocumentRoot. Try to change TButton in Home.page to TLinkButton and see what happens.

Complete source code of this demo can be found in the PRADO release. You can also try the online demo.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Sample: Hangman Game

Having seen the simple "Hello World" application, we now build a more complex application called "Hangman Game". In this game, the player is asked to guess a word, a letter at a time. If he guesses a letter right, the letter will be shown in the word. The player can continue to guess as long as the number of his misses is within a prespecified bound. The player wins the game if he finds out the word within the miss bound, or he loses.

To facilitate the building of this game, we show the state transition diagram of the gaming process in the following,

To be continued...

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Building a Simple Currency Converter

This tutorial introduces the Prado web application framework and teaches you how to build a simple web application in a few simple steps. This tutorial assumes that you are familiar with PHP and you have access to a web server that is able to serve PHP5 scripts.

In this tutorial you will build a simple web application that converts a dollar amount to an other currency, given the rate of that currency relative to the dollar. The completed application is shown bellow. You can try the application locally or at Pradosoft.com. Notice that the application still functions exactly the same if javascript is not available on the user's browser.

Downloading and Installing Prado

To install Prado, simply download the latest version of Prado from http://www.pradosoft.com and unzip the file to a directory not accessible by your web server (you may unzip it to a directory accessible by the web server if you wish to see the demos and test). For further detailed installation, see the Quickstart Installation guide.

Creating a new Prado web Application

The quickest and simplest way to create a new Prado web application is to use the command tool prado-cli.php found in the framework directory of the Prado distribution. We create a new application by running the following command in your command prompt or console. The command creates a new directory named currency-converter in your current working directory. You may need to change to the appropriate directory first. See the Command Line Tool for more details.

php prado/framework/prado-cli.php -c currency-converter

The above command creates the necessary directory structure and minimal files (including "index.php" and "Home.page") to run a Prado web application. Now you can point your browser's url to the web server to serve up the index.php script in the currency-converter directory. You should see the message "Welcome to Prado!"

Creating the Currency Converter User Interface

We start by editing the Home.page file found in the currency-converter/protected/pages/ directory. Files ending with ".page" are page templates that contains HTML and Prado controls. We simply add two textboxes, three labels and one button as follows.

<com:TForm>
    <fieldset>
        <legend>Currency Converter</legend>
        <div class="rate-field">
            <com:TLabel ForControl="currencyRate" Text="Exchange Rate per $1:" />
            <com:TTextBox ID="currencyRate" />
        </div>
        <div class="dollar-field">
            <com:TLabel ForControl="dollars" Text="Dollars to Convert:" />
            <com:TTextBox ID="dollars" />
        </div>
        <div class="total-field">
            <span class="total-label">Amount in Other Currency:</span>
            <com:TLabel ID="total" CssClass="result" />
        </div>
        <div class="convert-button">
            <com:TButton Text="Convert" />
        </div>
    </fieldset>
</com:TForm>

If you refresh the page, you should see something similar to the following figure. It may not look very pretty or orderly, but we shall change that later using CSS.

The first component we add is a TForm that basically corresponds to the HTML <form> element. In Prado, only one TForm element is allowed per page.

The next two pair of component we add is the TLabel and TTextBox that basically defines a label and a textbox for the user of the application to enter the currency exchange rate. The ForControl property value determines which component that the label is for. This allows the user of the application to click on the label to focus on the field (a good thing). You could have used a plain HTML <label> element to do the same thing, but you would have to find the correct ID of the textbox (or <input> in HTML) as Prado components may/will render the ID value differently in the HTML output.

The next pair of components are similar and defines the textbox to hold the dollar value to be converted. The TLabel with ID value "total" defines a simple label. Notice that the ForControl property is absent. This means that this label is simply a simple label which we are going to use to display the converted total amount.

The final component is a TButton that the user will click to calculate the results. The Text property sets the button label.

Implementing Currency Conversion

If you tried clicking on the "Convert" button then the page will refresh and does not do anything else. For the button to do some work, we need to add a "Home.php" to where "Home.page" is. The Home class should extends the TPage, the default base class for all Prado pages.

<?php
class Home extends TPage
{

}
?>

Prado uses PHP's __autoload method to load classes. The convention is to use the class name with ".php" extension as filename.

So far there is nothing interesting about Prado, we just declared some "web components" in some template file named Home.page and created a "Home.php" file with a Home class. The more interesting bits are in Prado's event-driven architecture as we shall see next.

We want that when the user click on the "Convert" button, we take the values in the textbox, do some calculation and present the user with the converted total. To handle the user clicking of the "Convert" button we simply add an OnClick property to the "Convert" button in the "Home.page" template and add a corresponding event handler method in the "Home.php".

<com:TButton Text="Convert" OnClick="convert_clicked" />

The value of the OnClick, "convert_clicked", will be the method name in the "Home.php" that will called when the user clicks on the "Convert" button.

class Home extends TPage
{
    public function convert_clicked($sender, $param)
    {
        $rate = floatval($this->currencyRate->Text);
        $dollars = floatval($this->dollars->Text);
        $this->total->Text = $rate * $dollars;
    }
}

If you run the application in your web browser, enter some values and click the "Convert" button then you should see that calculated value displayed next to the "Amount in Other Currency" label.

In the "convert_clicked" method the first parameter, $sender, corresponds to the object that raised the event, in this case, the "Convert" button. The second parameter, $param contains any additional data that the $sender object may wish to have added.

We shall now examine, the three lines that implements the simply currency conversion in the "convert_clicked" method.

$rate = floatval($this->currencyRate->Text);

The statement $this->currencyRate corresponds to the TTextBox component with ID value "currencyRate" in the "Home.page" template. The Text property of the TTextBox contains the value that the user entered. So, we obtain this value by $this->currencyRate->Text which we convert the value to a float value.

$dollars = floatval($this->dollars->Text);

The next line does a similar things, it takes the user value from the TTextBox with ID value "dollars and converts it to a float value.

The third line calculates the new amount and set this value in the Text property of the TLabel with ID="total". Thus, we display the new amount to the user in the label.

$this->total->Text = $rate * $dollars;

Adding Validation

The way we convert the user entered value to float ensures that the total amount is always a number. So the user is free to enter what ever they like, they could even enter letters. The user's experience in using the application can be improved by adding validators to inform the user of the allowed values in the currency rate and the amount to be calcuated.

For the currency rate, we should ensure that

  1. the user enters a value,
  2. the currency rate is a valid number,
  3. the currency rate is positive.

To ensure 1 we add one TRequiredFieldValidator. To ensure 2 and 3, we add one TCompareValidator. We may add these validators any where within the "Home.page" template. Further details regarding these validator and other validators can be found in the Validation Controls page.

<com:TRequiredFieldValidator
    ControlToValidate="currencyRate"
    ErrorMessage="Please enter a currency rate." />
<com:TCompareValidator
    ControlToValidate="currencyRate"
    DataType="Float"
    ValueToCompare="0"
    Operator="GreaterThan"
    ErrorMessage="Please enter a positive currency rate." />

For the amount to be calculated, we should ensure that

  1. the user enters a value,
  2. the value is a valid number (not including any currency or dollar signs).

To ensure 1 we just add another TRequiredFieldValidator, for 2 we could use a TDataTypeValidator. For simplicity we only allow the user to enter a number for the amount they wish to convert.

<com:TRequiredFieldValidator
    ControlToValidate="dollars"
    ErrorMessage="Please enter the amount you wish to calculate." />
<com:TDataTypeValidator
    ControlToValidate="dollars"
    DataType="Float"
    ErrorMessage="Please enter a number." />

Now if you try to enter some invalid data in the application or left out any of the fields the validators will be activated and present the user with error messages. Notice that the error messages are presented without reloading the page. Prado's validators by default validates using both javascript and server side. The server side validation is always performed. For the server side, we should skip the calculation if the validators are not satisfied. This can done as follows.

public function convert_clicked($sender, $param)
{
    if($this->Page->IsValid)
    {
        $rate = floatval($this->currencyRate->Text);
        $dollars = floatval($this->dollars->Text);
        $this->total->Text = $rate * $dollars;
    }
}

Improve User Experience With Active Controls

Requires Prado versions 3.1a or later.

In this simple application we may further improve the user experience by increasing the responsiveness of the application. One way to achieve a faster response is calculate and present the results without reloading the whole page.

We can replace the TButton with the Active Control counter part, TActiveButton, that can trigger a server side click event without reloading the page. In addition, we can change the "totals" TLabel with the Active Control counter part, TActiveLabel, such that the server side can update the browser without reloading the page.

<div class="total-field">
    <span class="total-label">Amount in Other Currency:</span>
         <com:TActiveLabel ID="total" CssClass="result" />
    </div>
    <div class="convert-button">
        <com:TActiveButton Text="Convert" OnClick="convert_clicked" />
</div>

The server side logic remains the same, we just need to import the Active Controls name space as they are not included by default. We add the following line to the begin of "Home.php".

Prado::using('System.Web.UI.ActiveControls.*');

If you try the application now, you may notice that the page no longer needs to reload to calculate and display the converted total amount. However, since there is not page reload, there is no indication or not obvious that by clicking on the "Convert" button any has happened. We can further refine the user experience by change the text of "total" label to "calculating..." when the user clicks on the "Convert" button. The text of the "total" label will still be updated with the new calculate amount as before.

To indicate that the calculation is in progress, we can change the text of the "total" label as follows. We add a ClientSide.OnLoading property to the "Convert" button (since this button is responsible for requesting the calculation).

<com:TActiveButton Text="Convert" OnClick="convert_clicked" >
    <prop:ClientSide.OnLoading>
        $('<%= $this->total->ClientID %>').innerHTML = "calculating..."
    </prop:ClientSide.OnLoading>
</com:TActiveButton>

The ClientSide.OnLoading and various other properties accept a javascript block as their content or value. The javascript code $('...') is a javascript function that is equivalent to document.getElementById('...') that takes a string with the ID of an HTML element. Since Prado renders its components's IDs, we need to use the rendered ID of the "total" label, that is, $this->total->ClientID. We place this bit of code within a <%= %> to obtain the rendered HTML ID for the "total" label. The rest of the javascript code innerHTML = "calculating..." simply changes the content of the "total" label.

Adding Final Touches

So far we have built a simple currency converter web application with little attention of the looks and feel. Now we can add a stylesheet to improve the overall appearance of the application. We can simply add the stylesheet inline with the template code or we may create a "theme".

To create and use a theme with Prado applications, we simply create a new directory "themes/Basic" in the currency-converter directory. You may need to create the themes directory first. Any directory within the themes are considered as a theme with the name of the theme being the directory name. See the Themes and Skins for further details.

We simply create a CSS file named "common.css" and save it in the themes/Basic directory. Then we add the following code to the beginning of "Home.page" (we add a little more HTML as well).

<%@ Theme="Basic" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" >
<com:THead Title="Currency Converter" />
<body>

The first line <%@ Theme="Basic" %> defines the theme to be used for this page. The THead corresponds to the HTML <head> element. In addition to display the Title property by the THead, all CSS files in the themes/Basic directory are also rendered/linked for the current page. Our final currency converter web application looks like the following. This completes introduction tutorial to the Prado web application framework.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

A Simple Address Book

This tutorial introduces the basics of connecting to a database using ActiveRecord and using Active Record scaffolds to quickly build a simple address book.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Building an AJAX Chat Application

Requires Prado versions 3.1a or later.

This tutorial introduces the Prado web application framework's ActiveRecord and Active Controls to build a Chat web application. It is assumed that you are familiar with PHP and you have access to a web server that is able to serve PHP5 scripts. This basic chat application will utilize the following ideas/components in Prado.

  • Building a custom User Manager class.
  • Authenticating and adding a new user to the database.
  • Using ActiveRecord to interact with the database.
  • Using Active Controls and callbacks to implement the user interface.
  • Separating application logic and application flow.

In this tutorial you will build an AJAX Chat web application that allows multiple users to communicate through their web browser. The application consists of two pages: a login page that asks the user to enter their nickname and the main application chat page. You can try the application locally or at Pradosoft.com. The main application chat page is shown bellow.

Download, Install and Create a New Application

The download and installation steps are similar to those in the Currency converter tutorial. To create the application, we run from the command line the following. See the Command Line Tool for more details.

php prado/framework/prado-cli.php -c chat

The above command creates the necessary directory structure and minimal files (including "index.php" and "Home.page") to run a Prado web application. Now you can point your browser's URL to the web server to serve up the index.php script in the chat directory. You should see the message "Welcome to Prado!"

Authentication and Authorization

The first task for this application is to ensure that each user of the chat application is assigned with a unique (chosen by the user) username. To achieve this, we can secure the main chat application page to deny access to anonymous users. First, let us create the Login page with the following code. We save the Login.php and Login.page in the chat/protected/pages/ directory (there should be a Home.page file created by the command line tool).

<?php
class Login extends TPage
{
}
?>
<!doctype html public "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
    <title>Prado Chat Demo Login</title>
</head>
<body>
<com:TForm>
    <h1 class="login">Prado Chat Demo Login</h1>
    <fieldset class="login">
        <legend>Please enter your name:</legend>
        <div class="username">
            <com:TLabel ForControl="username" Text="Username:" />
            <com:TTextBox ID="username" MaxLength="20" />
            <com:TRequiredFieldValidator
                ControlToValidate="username"
                Display="Dynamic"
                ErrorMessage="Please provide a username." />
        </div>
        <div class="login-button">
            <com:TButton Text="Login" />
        </div>
</com:TForm>
</body>
</html>

The login page contains a TForm, a TTextBox, a TRequiredFieldValidator and a TButton. The resulting page looks like the following (after applying some a style sheet). If you click on the Login button without entering any text in the username textbox, an error message is displayed. This is due to the TRequiredFieldValidator requiring the user to enter some text in the textbox before proceeding.

Securing the Home page

Now we wish that if the user is trying to access the main application page, Home.page, before they have logged in, the user is presented with the Login.page first. We add a chat/protected/application.xml configuration file to import some classes that we shall use later.

<?xml version="1.0" encoding="utf-8"?>
<application id="Chat" Mode="Debug">
  <paths>
    <using namespace="System.Data.*" />
    <using namespace="System.Data.ActiveRecord.*" />
    <using namespace="System.Security.*" />
    <using namespace="System.Web.UI.ActiveControls.*" />
  </paths>
</application>
Next, we add a chat/protected/pages/config.xml configuration file to secure the pages directory.
<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <modules>
    <module id="users" class="TUserManager" />
    <module id="auth" class="TAuthManager" UserManager="users" LoginPage="Login" />
  </modules>
  <authorization>
    <allow pages="Login" users="?" />
    <allow roles="normal" />
    <deny users="*" />
  </authorization>
</configuration>
We setup the authentication using the default classes as explained in the authentication/authorization quickstart. In the authorization definition, we allow anonymous users to access the Login page (anonymous users is specified by the ? question mark). We allow any users with role equal to "normal" (to be defined later) to access all the pages, that is, the Login and Home pages. Lastly, we deny all users without any roles to access any page. The authorization rules are executed on first match basis.

If you now try to access the Home page by pointing your browser to the index.php you will be redirected to the Login page.

Active Record for chat_users table

The TUserManager class only provides a read-only list of users. We need to be able to add or login new users dynamically. So we need to create our own user manager class. First, we shall setup a database with a chat_users table and create an ActiveRecord that can work with the chat_users table with ease. For the demo, we use sqlite as our database for ease of distributing the demo. The demo can be extended to use other databases such as MySQL or Postgres SQL easily. We define the chat_users table as follows.

CREATE TABLE chat_users
(
    username VARCHAR(20) NOT NULL PRIMARY KEY,
    last_activity INTEGER NOT NULL DEFAULT "0"
);
Next we define the corresponding ChatUserRecord class and save it as chat/protected/App_Code/ChatUserRecord.php (you need to create the App_Code directory as well). We also save the sqlite database file as App_Code/chat.db.
class ChatUserRecord extends TActiveRecord
{
    const TABLE='chat_users';

    public $username;
    public $last_activity;

    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}
Before using the ChatUserRecord class we to configure a default database connection for ActiveRecord to function. In the chat/protected/application.xml we import classes from the App_Code directory and add an ActiveRecord configuration module.
<?xml version="1.0" encoding="utf-8"?>
<application id="Chat" Mode="Debug">
  <paths>
    <using namespace="Application.App_Code.*" />
    <using namespace="System.Data.*" />
    <using namespace="System.Data.ActiveRecord.*" />
    <using namespace="System.Security.*" />
    <using namespace="System.Web.UI.ActiveControls.*" />
  </paths>
  <modules>
    <module class="TActiveRecordConfig" EnableCache="true"
        Database.ConnectionString="sqlite:protected/App_Code/chat.db" />
  </modules>
</application>

Custom User Manager class

To implement a custom user manager module class we just need to extends the TModule class and implement the IUserManager interface. The getGuestName(), getUser() and validateUser() methods are required by the IUserManager interface. We save the custom user manager class as App_Code/ChatUserManager.php.

class ChatUserManager extends TModule implements IUserManager
{
    public function getGuestName()
    {
        return 'Guest';
    }

    public function getUser($username=null)
    {
        $user=new TUser($this);
        $user->setIsGuest(true);
        if($username !== null && $this->usernameExists($username))
        {
            $user->setIsGuest(false);
            $user->setName($username);
            $user->setRoles(array('normal'));
        }
        return $user;
    }

    public function addNewUser($username)
    {
        $user = new ChatUserRecord();
        $user->username = $username;
        $user->save();
    }

    public function usernameExists($username)
    {
        $finder = ChatUserRecord::finder();
        $record = $finder->findByUsername($username);
        return $record instanceof ChatUserRecord;
    }

    public function validateUser($username,$password)
    {
        return $this->usernameExists($username);
    }
}

The getGuestName() method simply returns the name for a guest user and is not used in our application. The getUser() method returns a TUser object if the username exists in the database, the TUser object is set with role of "normal" that corresponds to the <authorization> rules defined in our config.xml file.

The addNewUser() and usernameExists() method uses the ActiveRecord corresponding to the chat_users table to add a new user and to check if a username already exists, respectively.

The next thing to do is change the config.xml configuration to use our new custom user manager class. We simply change the <module> configuration with id="users".

<module id="users" class="ChatUserManager" />

Authentication

To perform authentication, we just want the user to enter a unique username. We add a TCustomValidator for validate the uniqueness of the username and add an OnClick event handler for the login button.

<com:TCustomValidator
    ControlToValidate="username"
    Display="Dynamic"
    OnServerValidate="checkUsername"
    ErrorMessage="The username is already taken." />

...

<com:TButton Text="Login" OnClick="createNewUser" />
In the Login.php file, we add the following 2 methods.
function checkUsername($sender, $param)
{
    $manager = $this->Application->Modules['users'];
    if($manager->usernameExists($this->username->Text))
        $param->IsValid = false;
}

function createNewUser($sender, $param)
{
    if($this->Page->IsValid)
    {
        $manager = $this->Application->Modules['users'];
        $manager->addNewUser($this->username->Text);

        //do manual login
        $user = $manager->getUser($this->username->Text);
        $auth = $this->Application->Modules['auth'];
        $auth->updateSessionUser($user);
        $this->Application->User = $user;

        $url = $this->Service->constructUrl($this->Service->DefaultPage);
        $this->Response->redirect($url);
    }
}
The checkUserName() method uses the ChatUserManager class (recall that in the config.xml configuration we set the ID of the custom user manager class as "users") to validate the username is not taken.

In the createNewUser method, when the validation passes (that is, when the user name is not taken) we add a new user. Afterward we perform a manual login process:

  • First we obtain a TUser instance from our custom user manager class using the $manager->getUser(...) method.
  • Using the TAuthManager we set/update the user object in the current session data.
  • Then we set/update the Application's user instance with our new user object.

Finally, we redirect the client to the default Home page.

Default Values for ActiveRecord

If you try to perform a login now, you will receive an error message like "Property 'ChatUserRecord::$last_activity' must not be null as defined by column 'last_activity' in table 'chat_users'.". This means that the $last_activity property value was null when we tried to insert a new record. We need to either define a default value in the corresponding column in the table and allow null values or set the default value in the ChatUserRecord class. We shall demonstrate the later by altering the ChatUserRecord with the addition of a set getter/setter methods for the last_activity property.

private $_last_activity;

public function getLast_Activity()
{
    if($this->_last_activity === null)
        $this->_last_activity = time();
    return $this->_last_activity;
}

public function setLast_Activity($value)
{
    $this->_last_activity = $value;
}
Notice that we renamed $last_activity to $_last_activity (note the underscore after the dollar sign).

Main Chat Application

Now we are ready to build the main chat application. We use a simple layout that consist of one panel holding the chat messages, one panel to hold the users list, a textarea for the user to enter the text message and a button to send the message.

<!doctype html public "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
    <title>Prado Chat Demo</title>
<style>
.messages
{
    width: 500px;
    height: 300px;
    float: left;
    border: 1px solid ButtonFace;
    overflow: auto;
}
.user-list
{
    margin-left: 2px;
    float: left;
    width: 180px;
    height: 300px;
    border: 1px solid ButtonFace;
    overflow: auto;
    font-size: 0.85em;
}
.message-input
{
    float: left;
}

.message-input textarea
{
    margin-top: 3px;
    padding: 0.4em 0.2em;
    width: 493px;
    font-family: Verdana, Geneva, Arial, Helvetica, sans-serif;
    font-size: 0.85em;
    height: 40px;
}
.send-button
{
    margin: 0.5em;
}
</style>
</head>
<body>
<com:TForm>
<h1 id="18014">Prado Chat Demo</h1>
<div id="messages" class="messages">
    <com:TPlaceHolder ID="messageList" />
</div>
<div id="users" class="user-list">
    <com:TPlaceHolder ID="userList" />
</div>
<div class="message-input">
    <com:TActiveTextBox ID="userinput"
        Columns="40" Rows="2" TextMode="MultiLine" />
    <com:TActiveButton ID="sendButton" CssClass="send-button"
        Text="Send" />
</div>
</com:TForm>
<com:TJavascriptLogger />
</body>
</html>
We added two Active Control components: a TActiveTextBox and a TActiveButton. We also added a TJavascriptLogger that will be very useful for understanding how the Active Controls work.

Exploring the Active Controls

We should have some fun before we proceeding with setting up the chat buffering. We want to see how we can update the current page when we receive a message. First, we add an OnClick event handler for the Send button.

<com:TActiveButton ID="sendButton" CssClass="send-button"
    Text="Send" OnClick="processMessage"/>
And the corresponding event handler method in the Home.php class (we need to create this new file too).
class Home extends TPage
{
    function processMessage($sender, $param)
    {
        echo $this->userinput->Text;
    }
}
If you now type something in the main application textbox and click the send button you should see whatever you have typed echoed in the TJavascriptLogger console.

To append or add some content to the message list panel, we need to use some methods in the TCallbackClientScript class which is available through the CallbackClient property of the current TPage object. For example, we do can do

function processMessage($sender, $param)
{
    $this->CallbackClient->appendContent("messages", $this->userinput->Text);
}
This is one way to update some part of the existing page during a callback (AJAX style events) and will be the primary way we will use to implement the chat application.

Active Record for chat_buffer table

To send a message to all the connected users we need to buffer or store the message for each user. We can use the database to buffer the messages. The chat_buffer table is defined as follows.

CREATE TABLE chat_buffer
(
    id INTEGER PRIMARY KEY,
    for_user VARCHAR(20) NOT NULL,
    from_user VARCHAR(20) NOT NULL,
    message TEXT NOT NULL,
    created_on INTEGER NOT NULL DEFAULT "0"
);
The corresponding ChatBufferRecord class is saved as App_Code/ChatBufferRecord.php.
class ChatBufferRecord extends TActiveRecord
{
    const TABLE='chat_buffer';

    public $id;
    public $for_user;
    public $from_user;
    public $message;
    private $_created_on;

    public function getCreated_On()
    {
        if($this->_created_on === null)
            $this->_created_on = time();
        return $this->_created_on;
    }

    public function setCreated_On($value)
    {
        $this->_created_on = $value;
    }

    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

Chat Application Logic

We finally arrive at the guts of the chat application logic. First, we need to save a received message into the chat buffer for all the current users. We add this logic in the ChatBufferRecord class.

public function saveMessage()
{
    foreach(ChatUserRecord::finder()->findAll() as $user)
    {
        $message = new self;
        $message->for_user = $user->username;
        $message->from_user = $this->from_user;
        $message->message = $this->message;
        $message->save();
        if($user->username == $this->from_user)
        {
            $user->last_activity = time(); //update the last activity;
            $user->save();
        }
    }
}
We first find all the current users using the ChatUserRecord finder methods. Then we duplicate the message and save it into the database. In addition, we update the message sender's last activity timestamp. The above piece of code demonstrates the simplicity and succinctness of using ActiveRecords for simple database designs.

The next piece of the logic is to retrieve the users' messages from the buffer. We simply load all the messages for a particular username and format that message appropriately (remember to escape the output to prevent Cross-Site Scripting attacks). After we load the messages, we delete those loaded messages and any older messages that may have been left in the buffer.

public function getUserMessages($user)
{
    $content = '';
    foreach($this->findAll('for_user = ?', $user) as $message)
        $content .= $this->formatMessage($message);
    $this->deleteAll('for_user = ? OR created_on < ?',
                          $user, time() - 300); //5 min inactivity
    return $content;
}

protected function formatMessage($message)
{
    $user = htmlspecialchars($message->from_user);
    $content = htmlspecialchars($message->message);
    return "<div class=\"message\"><strong>{$user}:</strong>"
                  ." <span>{$content}</span></div>";
}
To retrieve a list of current users (formatted), we add this logic to the ChatUserRecord class. We delete any users that may have been inactive for awhile.
public function getUserList()
{
    $this->deleteAll('last_activity < ?', time()-300); //5 min inactivity
    $content = '<ul>';
    foreach($this->findAll() as $user)
        $content .= '<li>'.htmlspecialchars($user->username).'</li>';
    $content .= '</ul>';
    return $content;
}
Note: For simplicity we formatted the messages in these Active Record classes. For large applications, these message formatting tasks should be done using Prado components (e.g. using a TRepeater in the template or a custom component).

Putting It Together

Now comes to put the application flow together. In the Home.php we update the Send buttons OnClick event handler to use the application logic we just implemented.

function processMessage($sender, $param)
{
    if(strlen($this->userinput->Text) > 0)
    {
        $record = new ChatBufferRecord();
        $record->message = $this->userinput->Text;
        $record->from_user = $this->Application->User->Name;
        $record->saveMessage();

        $this->userinput->Text = '';
        $messages = $record->getUserMessages($this->Application->User->Name);
        $this->CallbackClient->appendContent("messages", $messages);
        $this->CallbackClient->focus($this->userinput);
    }
}
We simply save the message to the chat buffer and then ask for all the messages for the current user and update the client side message list using a callback response (AJAX style).

At this point the application is actually already functional, just not very user friendly. If you open two different browsers, you should be able to communicate between the two users whenever the Send button is clicked.

The next part is perhaps the more tricker and fiddly than the other tasks. We need to improve the user experience. First, we want a list of current users as well. So we add the following method to Home.php, we can call this method when ever some callback event is raised, e.g. when the Send button is clicked.

protected function refreshUserList()
{
    $lastUpdate = $this->getViewState('userList','');
    $users = ChatUserRecord::finder()->getUserList();
    if($lastUpdate != $users)
    {
        $this->CallbackClient->update('users', $users);
        $this->setViewstate('userList', $users);
    }
}

Actually, we want to periodically update the messages and user list as new users join in and new message may arrive from other users. So we need to refresh the message list as well.

function processMessage($sender, $param)
{
    ...
    $this->refreshUserList();
    $this->refreshMessageList();
    ...
}

protected function refreshMessageList()
{
    //refresh the message list
    $finder = ChatBufferRecord::finder();
    $content = $finder->getUserMessages($this->Application->User->Name);
    if(strlen($content) > 0)
    {
        $anchor = (string)time();
        $content .= "<a href=\"#\" id=\"{$anchor}\"> </a>";
        $this->CallbackClient->appendContent("messages", $content);
        $this->CallbackClient->focus($anchor);
    }
}
The anchor using time() as ID for a focus point is so that when the message list on the client side gets very long, the focus method will scroll the message list to the latest message (well, it works in most browsers).

Next, we need to redirect the user back to the login page if the user has been inactive for some time, say about 5 mins, we can add this check to any stage of the page life-cycle. Lets add it to the onLoad() stage.

public function onLoad($param)
{
    $username = $this->Application->User->Name;
    if(!$this->Application->Modules['users']->usernameExists($username))
    {
        $auth = $this->Application->Modules['auth'];
        $auth->logout();

        //redirect to login page.
        $this->Response->Redirect($this->Service->ConstructUrl($auth->LoginPage));
    }
}

Improving User Experience

The last few details are to periodically check for new messages and refresh the user list. We can accomplish this by polling the server using a TTimeTriggeredCallback control. We add a TTimeTriggeredCallback to the Home.page and call the refresh handler method defined in Home.php. We set the polling interval to 2 seconds.

<com:TTimeTriggeredCallback OnCallback="refresh"
    Interval="2" StartTimerOnLoad="true" />
function refresh($sender, $param)
{
    $this->refreshUserList();
    $this->refreshMessageList();
}

The final piece requires us to use some javascript. We want that when the user type some text in the textarea and press the Enter key, we want it to send the message without clicking on the Send button. We add to the Home.page some javascript.

<com:TClientScript>
Event.observe($("<%= $this->userinput->ClientID %>"), "keypress", function(ev)
{
    if(Event.keyCode(ev) == Event.KEY_RETURN)
    {
        if(Event.element(ev).value.length > 0)
            new Prado.Callback("<%= $this->sendButton->UniqueID %>");
        Event.stop(ev);
    }
});
</com:TClientScript>
Details regarding the javascript can be explored in the Introduction to Javascript section of the quickstart.

This completes the tutorial on making a basic chat web application using the Prado framework. Hope you have enjoyed it.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Command Line Tool

The optional prado-cli.php PHP script file in the framework directory provides command line tools to perform various tedious takes in Prado. The prado-cli.php can be used to create Prado project skeletons, create initial test fixtures, and access to an interactive PHP shell.

Requirements

To use the command line tool, you need to use your command prompt, command console or terminal. In addition, PHP must be able to execute PHP scripts from the command line.

Usage

If you type php path/to/framework/prado-cli.php, you should see the following information. Alternatively, if you are not on Windows, you may try to change the prado-cli.php into an executable and execute it as a script

Command line tools for Prado 3.0.5.
usage: php prado-cli.php action <parameter> [optional]
example: php prado-cli.php -c mysite

actions:
  -c <directory>
    Creates a Prado project skeleton for the given <directory>.

  -t <directory>
    Create test fixtures in the given <directory>.

  shell [directory]
    Runs a PHP interactive interpreter. Initializes the Prado
    application in the given [directory].

The <parameter> are required parameters and [optional] are optional parameters.

Creating a new Prado project skeleton

To create a Prado project skeleton, do the following:

  1. Change to the directory where you want to create the project skeleton.
  2. Type, php ../prado/framework/prado-cli.php -c helloworld, where helloworld is the directory name that you want to create the project skeleton files.
  3. Type, php ../prado/framework/prado-cli.php -t helloworld to create the test fixtures for the helloworld project.

Interactive Shell

The interactive shell allows you to evaluate PHP statements from the command line. The prado-cli.php script can be used to start the shell and load an existing Prado project. For example, let us load the blog demo project. Assume that your command line is in the prado distribution directory and you type.

$: php framework/prado-cli.php shell demos/blog
The output should be
Command line tools for Prado 3.0.5.
** Loaded Prado application in directory "demos\blog\protected".
PHP-Shell - Version 0.3.1
(c) 2006, Jan Kneschke <jan@kneschke.de>

>> use '?' to open the inline help

>>
Then we will get an instance of the Prado blog application, and from that instance we want an instance of the 'data' module. Notice that a semicolon at the end of the line suppresses the output.
>> $app = Prado::getApplication();

>> $db = $app->getModule('data');
Lastly, we want to use the data module to query for a post with ID=1. Notice that we leave out the semicolon to show the results.
>> $db->queryPostByID(1)
There should not be any errors and you should see the following.
PostRecord#1
(
    [ID] => 1
    [AuthorID] => 1
    [AuthorName] => 'Prado User'
    [CreateTime] => 1148819691
    [ModifyTime] => 0
    [Title] => 'Welcome to Prado Weblog'
    [Content] => 'Congratulations! You have successfully installed Prado Blog --
 a PRADO-driven weblog system. A default administrator account has been created.
 Please login with <b>admin/prado</b> and update your password as soon as possible.'
    [Status] => 0
    [CommentCount] => 0
)
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Architecture

PRADO is primarily a presentational framework, although it is not limited to be so. The framework focuses on making Web programming, which deals most of the time with user interactions, to be component-based and event-driven so that developers can be more productive. The following class tree depicts some of the major classes provided by PRADO,

When a PRADO application is processing a page request, its static object diagram can be shown as follows,

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Components

A component is an instance of TComponent or its child class. The base class TComponent implements the mechanism of component properties and events.

Component Properties

A component property can be viewed as a public variable describing a specific aspect of the component, such as the background color, the font size, etc. A property is defined by the existence of a getter and/or a setter method in the component class. For example, in TControl, we define its ID property using the following getter and setter methods,

class TControl extends TComponent {
    public function getID() {
        ...
    }
    public function setID($value) {
        ...
    }
}

To get or set the ID property, do as follows, just like working with a variable,

$id = $component->ID;
$component->ID = $id;
This is equivalent to the following,
$id = $component->getID();
$component->setID( $id );

A property is read-only if it has a getter method but no setter method. Since PHP method names are case-insensitive, property names are also case-insensitive. A component class inherits all its ancestor classes' properties.

Subproperties

A subproperty is a property of some object-typed property. For example, TWebControl has a Font property which is of TFont type. Then the Name property of Font is referred to as a subproperty (with respect to TWebControl).

To get or set the Name subproperty, use the following method,

$name = $component->getSubProperty('Font.Name');
$component->setSubProperty('Font.Name', $name);
This is equivalent to the following,
$name = $component->getFont()->getName();
$component->getFont()->setName( $name );

Js-friendly properties

A JavaScript-friendly property is a property that can accept both simple strings and raw javascript. Prado automatically encodes all properties sent clientside inside javascript blocks to avoid security problems (like injections or cross site scripting). If a property is known to always contain only safe javascript code and its value needs to bypass this encoding, that property can be defined in a special way that will make Prado mark its value as "safe". Js-friendly properties are identified by their name starting with 'js' (case insensitive):

// getter, defines a readable property 'Text'
function getJsText() { … }
// setter, defines a writable property 'Text', with $value being the value to be set to the property
function setJsText(TJavaScriptLiteral $value) { … }
Js-friendly properties can be accessed using both their Js-less name and their Js-enabled name:
// set some simple text as property value
$component->Text = 'text';
// set some javascript code as property value
$component->JsText = 'raw javascript';
In the first case, the property value will automatically gets encoded when sent clientside inside a javascript block. In the second case, the property will be 'marked' as being a safe javascript statement and will not be encoded when rendered inside a javascript block. This special handling makes use of the TJavaScriptLiteral class.

Component Events

Component events are special properties that take method names as their values. Attaching (setting) a method to an event will hook up the method to the places at which the event is raised. Therefore, the behavior of a component can be modified in a way that may not be foreseen during the development of the component.

A component event is defined by the existence of a method whose name starts with the word on. The event name is the method name and is thus case-insensitve. For example, in TButton, we have

class TButton extends TWebControl {
    public function onClick( $param ) {
        ...
    }
}
This defines an event named OnClick, and a handler can be attached to the event using one of the following ways,
$button->OnClick = $callback;
$button->OnClick->add( $callback );
$button->OnClick[] = $callback;
$button->attachEventHandler( 'OnClick' , $callback );
where $callback refers to a valid PHP callback (e.g. a function name, a class method array($object,'method'), etc.)

Namespaces

A namespace refers to a logical grouping of some class names so that they can be differentiated from other class names even if their names are the same. Since PHP does not support namespace intrinsically, you cannot create instances of two classes who have the same name but with different definitions. To differentiate from user defined classes, all PRADO classes are prefixed with a letter 'T' (meaning 'Type'). Users are advised not to name their classes like this. Instead, they may prefix their class names with any other letter(s).

A namespace in PRADO is considered as a directory containing one or several class files. A class may be specified without ambiguity using such a namespace followed by the class name. Each namespace in PRADO is specified in the following format,

PathAlias.Dir1.Dir2
where PathAlias is an alias of some directory, while Dir1 and Dir2 are subdirectories under that directory. A class named MyClass defined under Dir2 may now be fully qualified as PathAlias.Dir1.Dir2.MyClass.

To use a namespace in code, do as follows,

Prado::using('PathAlias.Dir1.Dir2.*');
which appends the directory referred to by PathAlias.Dir1.Dir2 into PHP include path so that classes defined under that directory may be instantiated without the namespace prefix. You may also include an individual class definition by
Prado::using('PathAlias.Dir1.Dir2.MyClass');
which will include the class file if MyClass is not defined.

For more details about defining path aliases, see application configuration section.

Component Instantiation

Component instantiation means creating instances of component classes. There are two types of component instantation: static instantiation and dynamic instantiation. The created components are called static components and dynamic components, respectively.

Dynamic Component Instantiation

Dynamic component instantiation means creating component instances in PHP code. It is the same as the commonly referred object creation in PHP. A component can be dynamically created using one of the following two methods in PHP,

$component = new ComponentClassName;
$component = Prado::createComponent('ComponentType');
where ComponentType refers to a class name or a type name in namespace format (e.g. System.Web.UI.TControl). The second approach is introduced to compensate for the lack of namespace support in PHP.

Static Component Instantiation

Static component instantiation is about creating components via templates. Every component tag in a template specifies a component that will be automatically created by the framework when the template is loaded. For example, in a page template, the following tag will lead to the creation of a TButton component on the page,

<com:TButton Text="Register" />
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Controls

A control is an instance of class TControl or its subclass. A control is a component defined in addition with user interface. The base class TControl defines the parent-child relationship among controls which reflects the containment relationship among user interface elements.

Control Tree

Controls are related to each other via parent-child relationship. Each parent control can have one or several child controls. A parent control is in charge of the state transition of its child controls. The rendering result of the child controls are usually used to compose the parent control's presentation. The parent-child relationship brings together controls into a control tree. A page is at the root of the tree, whose presentation is returned to the end-users.

The parent-child relationship is usually established by the framework via templates. In code, you may explicitly specify a control as a child of another using one of the following methods,

$parent->Controls->add($child);
$parent->Controls[]=$child;
where the property Controls refers to the child control collection of the parent.

Control Identification

Each control has an ID property that can be uniquely identify itself among its sibling controls. In addition, each control has a UniqueID and a ClientID which can be used to globally identify the control in the tree that the control resides in. UniqueID and ClientID are very similar. The former is used by the framework to determine the location of the corresponding control in the tree, while the latter is mainly used on the client side as HTML tag IDs. In general, you should not rely on the explicit format of UniqueID or ClientID.

Naming Containers

Each control has a naming container which is a control creating a unique namespace for differentiating between controls with the same ID. For example, a TRepeater control creates multiple items each having child controls with the same IDs. To differentiate these child controls, each item serves as a naming container. Therefore, a child control may be uniquely identified using its naming container's ID together with its own ID. As you may already have understood, UniqueID and ClientID rely on the naming containers.

A control can serve as a naming container if it implements the INamingContainer interface.

ViewState and ControlState

HTTP is a stateless protocol, meaning it does not provide functionality to support continuing interaction between a user and a server. Each request is considered as discrete and independent of each other. A Web application, however, often needs to know what a user has done in previous requests. People thus introduce sessions to help remember such state information.

PRADO borrows the viewstate and controlstate concept from Microsoft ASP.NET to provides additional stateful programming mechanism. A value storing in viewstate or controlstate may be available to the next requests if the new requests are form submissions (called postback) to the same page by the same user. The difference between viewstate and controlstate is that the former can be disabled while the latter cannot.

Viewstate and controlstate are implemented in TControl. They are commonly used to define various properties of controls. To save and retrieve values from viewstate or controlstate, use following methods,

$this->getViewState('Name',$defaultValue);
$this->setViewState('Name',$value,$defaultValue);
$this->getControlState('Name',$defaultValue);
$this->setControlState('Name',$value,$defaultValue);
where $this refers to the control instance, Name refers to a key identifying the persistent value, $defaultValue is optional. When retrieving values from viewstate or controlstate, if the corresponding key does not exist, the default value will be returned.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Pages

Pages are top-most controls that have no parent. The presentation of pages are directly displayed to end-users. Users access pages by sending page service requests.

Each page must have a template file. The file name suffix must be .page. The file name (without suffix) is the page name. PRADO will try to locate a page class file under the directory containing the page template file. Such a page class file must have the same file name (suffixed with .php) as the template file. If the class file is not found, the page will take class TPage.

PostBack

A form submission is called postback if the submission is made to the page containing the form. Postback can be considered an event happened on the client side, raised by the user. PRADO will try to identify which control on the server side is responsible for a postback event. If one is determined, for example, a TButton, we call it the postback event sender which will translate the postback event into some specific server-side event (e.g. OnClick and OnCommand events for TButton).

Page Lifecycles

Understanding the page lifecycles is crucial to grasp PRADO programming. Page lifecycles refer to the state transitions of a page when serving this page to end-users. They can be depicted in the following statechart,

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Modules

A module is an instance of a class implementing the IModule interface. A module is commonly designed to provide specific functionality that may be plugged into a PRADO application and shared by all components in the application.

PRADO uses configurations to specify whether to load a module, load what kind of modules, and how to initialize the loaded modules. Developers may replace the core modules with their own implementations via application configuration, or they may write new modules to provide additional functionalities. For example, a module may be developed to provide common database logic for one or several pages. For more details, please see the configurations.

There are three core modules that are loaded by default whenever an application runs. They are request module, response module, and error handler module. In addition, session module is loaded when it is used in the application. PRADO provides default implementation for all these modules. Custom modules may be configured or developed to override or supplement these core modules.

Request Module

Request module represents provides storage and access scheme for user request sent via HTTP. User request data comes from several sources, including URL, post data, session data, cookie data, etc. These data can all be accessed via the request module. By default, PRADO uses THttpRequest as request module. The request module can be accessed via the Request property of application and controls.

Response Module

Response module implements the mechanism for sending output to client users. Response module may be configured to control how output are cached on the client side. It may also be used to send cookies back to the client side. By default, PRADO uses THttpResponse as response module. The response module can be accessed via the Response property of application and controls.

Session Module

Session module encapsulates the functionalities related with user session handling. Session module is automatically loaded when an application uses session. By default, PRADO uses THttpSession as session module, which is a simple wrapper of the session functions provided by PHP. The session module can be accessed via the Session property of application and controls.

Error Handler Module

Error handler module is used to capture and process all error conditions in an application. PRADO uses TErrorHandler as error handler module. It captures all PHP warnings, notices and exceptions, and displays in an appropriate form to end-users. The error handler module can be accessed via the ErrorHandler property of the application instance.

Custom Modules

PRADO is released with a few more modules besides the core ones. They include caching modules (TSqliteCache and TMemCache), user management module (TUserManager), authentication and authorization module (TAuthManager), etc.

When TPageService is requested, it also loads modules specific for page service, including asset manager (TAssetManager), template manager (TTemplateManager), theme/skin manager (TThemeManager).

Custom modules and core modules are all configurable via configurations.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Services

A service is an instance of a class implementing the IService interface. Each kind of service processes a specific type of user requests. For example, the page service responds to users' requests for PRADO pages.

A service is uniquely identified by its ID property. By default when THttpRequest is used as the request module, GET variable names are used to identify which service a user is requesting. If a GET variable name is equal to some service ID, the request is considered for that service, and the value of the GET variable is passed as the service parameter. For page service, the name of the GET variable must be page. For example, the following URL requests for the Fundamentals.Services page,

http://hostname/index.php?page=Fundamentals.Services

Developers may implement additional services for their applications. To make a service available, configure it in application configurations.

Page Service

PRADO implements TPageService to process users' page requests. Pages are stored under a directory specified by the BasePath property of the page service. The property defaults to pages directory under the application base path. You may change this default by configuring the service in the application configuration.

Pages may be organized into subdirectories under the BasePath. In each directory, there may be a page configuration file named config.xml, which contains configurations effective only when a page under that directory or a sub-directory is requested. For more details, see the page configuration section.

Service parameter for the page service refers to the page being requested. A parameter like Fundamentals.Services refers to the Services page under the <BasePath>/Fundamentals directory. If such a parameter is absent in a request, a default page named Home is assumed. Using THttpRequest as the request module (default), the following URLs will request for Home, About and Register pages, respectively,

http://hostname/index.php
http://hostname/index.php?page=About
http://hostname/index.php?page=Users.Register
where the first example takes advantage of the fact that the page service is the default service and Home is the default page.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Applications

An application is an instance of TApplication or its derived class. It manages modules that provide different functionalities and are loaded when needed. It provides services to end-users. It is the central place to store various parameters used in an application. In a PRADO application, the application instance is the only object that is globally accessible via Prado::getApplication() function call.

Applications are configured via application configurations. They are usually created in entry scripts like the following,

require_once('/path/to/prado.php');
$application = new TApplication;
$application->run();
where the method run() starts the application to handle user requests.

Directory Organization

A minimal PRADO application contains two files: an entry file and a page template file. They must be organized as follows,

  • wwwroot - Web document root or sub-directory.
  • index.php - entry script of the PRADO application.
  • assets - directory storing published private files. See assets section.
  • protected - application base path storing application data and private script files. This directory should be configured inaccessible to Web-inaccessible, or it may be located outside of Web directories.
  • runtime - application runtime storage path. This directory is used by PRADO to store application runtime information, such as application state, cached data, etc.
  • pages - base path storing all PRADO pages. See services section.
  • Home.page - default page returned when users do not explicitly specify the page requested. This is a page template file. The file name without suffix is the page name. The page class is TPage. If there is also a class file Home.php, the page class becomes Home.

A product PRADO application usually needs more files. It may include an application configuration file named application.xml under the application base path protected. The pages may be organized in directories, some of which may contain page configuration files named config.xml. Fore more details, please see configurations section.

Application Deployment

Deploying a PRADO application mainly involves copying directories. For example, to deploy the above minimal application to another server, follow the following steps,

  1. Copy the content under wwwroot to a Web-accessible directory on the new server.
  2. Modify the entry script file index.php so that it includes correctly the prado.php file.
  3. Remove all content under assets and runtime directories and make sure both directories are writable by the Web server process.

Application Lifecycles

Like page lifecycles, an application also has lifecycles. Application modules can register for the lifecycle events. When the application reaches a particular lifecycle and raises the corresponding event, the registered module methods are invoked automatically. Modules included in the PRADO release, such as TAuthManager, are using this way to accomplish their goals.

The application lifecycles can be depicted as follows,

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Configuration Overview

PRADO uses configurations to glue together components into pages and applications. There are templates.

Application and page configurations are optional if default values are used. Templates are mainly used by pages and template controls. They are optional, too.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Templates: Part I

Templates are used to specify the presentational layout of controls. A template can contain static text, components, or controls that contribute to the ultimate presentation of the associated control. By default, an instance of TTemplateControl or its subclass may automatically load and instantiate a template from a file whose name is the same as the control class name. For page templates, the file name suffix must be .page; for other regular template controls, the suffix is .tpl.

The template format is like HTML, with a few PRADO-specifc tags, including dynamic property tags. .

Component Tags

A component tag specifies a component as part of the body content of the template control. If the component is a control, it usually will become a child or grand child of the template control, and its rendering result will be inserted at the place where it is appearing in the template.

The format of a component tag is as follows,

<com:ComponentType PropertyName="PropertyValue" ... EventName="EventHandler" ...>
body content
</com:ComponentType>
ComponentType can be either the class name or the dotted type name (e.g. System.Web.UI.TControl) of the component. PropertyName and EventName are both case-insensitive. PropertyName can be a property or subproperty name (e.g. Font.Name). Note, PropertyValue will be HTML-decoded when assigned to the corresponding property. Content enclosed between the opening and closing component tag are normally treated the body of the component.

It is required that component tags nest properly with each other and an opening component tag be paired with a closing tag, similar to that in XML.

The following template shows a component tag specifying the Text property and OnClick event of a button control,

<com:TButton Text="Register" OnClick="registerUser" />
Note, property names and event names are all case-insensitive, while component type names are case-sensitive. Event names always begin with On.

Also note, initial values for properties whose name ends with Template are specially processed. In particular, the initial values are parsed as TTemplate objects. The ItemTemplate property of the TRepeater control is such an example.

To facilitate initializing properties with big trunk of data, the following property initialization tag is introduced. It is equivalent to ...PropertyName="PropertyValue"... in every aspect. Property initialization tags must be directly enclosed between the corresponding opening and closing component tag.

<prop:PropertyName>
PropertyValue
</prop:PropertyName>

Since version 3.1.0, the property initialization tag can also be used to initialize a set of subproperties who share the same parent property. For example, the following is equivalent to HeaderStyle.BackColor="black" and HeaderStyle.ForeColor="red".

<prop:HeaderStyle BackColor="black" ForeColor="red" />

Component IDs

When specified in templates, component ID property has special meaning in addition to its normal property definition. A component tag specified with an ID value in template will register the corresponding component to the template owner control. The component can thus be directly accessed from the template control with its ID value. For example, in Home page's template, the following component tag

<com:TTextBox ID="TextBox" Text="First Name" />
makes it possible to get the textbox object in code using $page->TextBox.

Template Control Tags

A template control tag is used to configure the initial property values of the control owning the template. Its format is as follows,
<%@ PropertyName="PropertyValue" ... %>
Like in component tags, PropertyName is case-insensitive and can be a property or subproperty name.

Initial values specified via the template control tag are assigned to the corresponding properties when the template control is being constructed. Therefore, you may override these property values in a later stage, such as the Init stage of the control.

Template control tag is optional in a template. Each template can contain at most one template control tag. You can place the template control tag anywhere in the template. It is recommended that you place it at the beginning of the template for better visibility.

Comment Tags

Comment tags are used to put in a template developer comments that will not display to end-users. Contents enclosed within a comment tag will be treated as raw text strings and PRADO will not attempt to parse them. Comment tags cannot be used within property values. The format of comment tags is as follows,

<!---
Comments INVISIBLE to end-users
--->
Note: The new comment tag <!--- ... ---> has been introduced since PRADO version 3.1. Previously, it was <!-- ... --!> which was deprecated because some editors have problems in syntax-highlighting such tags.

Include Tags

Since version 3.0.5, PRADO starts to support external template inclusion. This is accomplished via include tags, where external template files are specified in namespace format and their file name must be terminated as .tpl.

<%include path.to.templateFile %>

External templates will be inserted at the places where the include tags occur in the base template.

Note, nested template inclusion is not supported, i.e., you cannot have include tags in an external template.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Templates: Part II

Dynamic Content Tags

Dynamic content tags are introduced as shortcuts to some commonly used component tags. These tags are mainly used to render contents resulted from evaluating some PHP expressions or statements. They include expression tags, statement tags, databind tags, parameter tags, asset tags and localization tags.

Expression Tags

An expression tag represents a PHP expression that is evaluated when the template control is in PreRender stage. The expression evaluation result is inserted at the place where the tag resides in the template. The context (namely $this) of the expression is the control owning the template.

The format of an expression tag is as follows,

<%= PhpExpression %>

For example, the following expression tag will display the current page title at the place,

<%= $this->Title %>

Statement Tags

Statement tags are similar to expression tags, except that statement tags contain PHP statements rather than expressions. The output of the PHP statements (using for example echo or print in PHP) are displayed at the place where the statement tag resides in the template. The context (namely $this) of the statements is the control owning the template. The format of statement tags is as follows,

<%%
PHP Statements
%>

The following example displays the current time in Dutch at the place,

<%%
setlocale(LC_ALL, 'nl_NL');
echo strftime("%A %e %B %Y",time());
%>

Databind Tags

Databind tags are similar to expression tags, except that the expressions are evaluated only when a dataBind() call is invoked on the controls representing the databind tags. The context (namely $this) of a databind expression is the control owning the template. The format of databind tags is as follows,

<%# PhpExpression %>

Parameter Tags

Parameter tags are used to insert application parameters at the place where they appear in the template. The format of parameter tags is as follows,

<%$ ParameterName %>

Note, application parameters are usually defined in application configurations or page directory configurations. The parameters are evaluated when the template is instantiated.

Asset Tags

Asset tags are used to publish private files and display the corresponding the URLs. For example, if you have an image file that is not Web-accessible and you want to make it visible to end-users, you can use asset tags to publish this file and show the URL to end-users so that they can fetch the published image.

The format of asset tags is as follows,

<%~ LocalFileName %>

where LocalFileName refers to a file path that is relative to the directory containing the current template file. The file path can be a single file or a directory. If the latter, the content in the whole directory will be made accessible by end-users.

BE VERY CAUTIOUS when you are using asset tags as it may expose to end-users files that you probably do not want them to see.

Localization Tags

Localization tags represent localized texts. They are in the following format,

<%[string]%>

where string will be translated to different languages according to the end-user's language preference. Localization tags are in fact shortcuts to the function call Prado::localize(string).

URL Tags

URL tags are used to insert the relative web url path to the Prado application in the template. You can use it in the following format:

<%/ image.jpg %>

If your Prado application is deployed on http://localhost/pradoapp/, the tag above will produce "/pradoapp/image.jpg". This tag will help you to use the correct file path even with UrlFormat set to Path, or if you are using url mappings.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Templates: Part III

Dynamic Property Tags

Dynamic property tags are very similar to dynamic content tags, except that they are applied to component properties. The purpose of dynamic property tags is to allow more versatile component property configuration. Note, you are not required to use dynamic property tags because what can be done using dynamic property tags can also be done in PHP code. However, using dynamic property tags bring you much more convenience at accomplishing the same tasks. The basic usage of dynamic property tags is as follows,

<com:ComponentType PropertyName=DynamicPropertyTag ...>
body content
</com:ComponentType>

where you may enclose DynamicPropertyTag within single or double quotes for better readability.

Like dynamic content tags, we have expression tags, databind tags, parameter tags, asset tags and localization tags. (Note, there is no statement tag here.)

Expression Tags

An expression tag represents a PHP expression that is evaluated when the control is in PreRender stage. The expression evaluation result is assigned to the corresponding component property. The format of expression tags is as follows,

<%= PhpExpression %>

In the expression, $this refers to the control owning the template. The following example specifies a TLabel control whose Text property is initialized as the current page title when the TLabel control is being constructed,

<com:TLabel Text=<%= $this->Page->Title %> />

Databind Tags

Databind tags are similar to expression tags, except that they can only be used with control properties and the expressions are evaluated only when a dataBind() call is invoked on the controls represented by the component tags. In the expression, $this refers to the control owning the template. Databind tags do not apply to all components. They can only be used for controls.

The format of databind tags is as follows,

<%# PhpExpression %>

Since v3.0.2, expression tags and databind tags can be embedded within static strings. For example, you can write the following in a template,

<com:TLabel>
  <prop:Text>
  Today is <%= date('F d, Y',time()) %>.
  The page class is <%= get_class($this) %>.
  </prop:Text>
</com:TLabel>

Previously, you would have to use a single expression with string concatenations to achieve the same effect.

Parameter Tags

Parameter tags are used to assign application parameter values to the corresponding component properties. The format of parameter tags is as follows,

<%$ ParameterName %>

Note, application parameters are usually defined in application configurations or page directory configurations. The parameters are evaluated when the template is instantiated.

Asset Tags

Asset tags are used to publish private files and assign the corresponding the URLs to the component properties. For example, if you have an image file that is not Web-accessible and you want to make it visible to end-users, you can use asset tags to publish this file and show the URL to end-users so that they can fetch the published image. The asset tags are evaluated when the template is instantiated.

The format of asset tags is as follows,

<%~ LocalFileName %>

where LocalFileName refers to a file path that is relative to the directory containing the current template file. The file path can be a single file or a directory. If the latter, the content in the whole directory will be made accessible by end-users.

BE VERY CAUTIOUS when you are using asset tags as it may expose to end-users files that you probably do not want them to see.

Localization Tags

Localization tags represent localized texts. They are in the following format,

<%[string]%>

where string will be translated to different languages according to the end-user's language preference. The localization tags are evaluated when the template is instantiated. Localization tags are in fact shortcuts to the function call Prado::localize(string).

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Application Configurations

Application configurations are used to specify the global behavior of an application. They include specification of path aliases, namespace usages, module and service configurations, and parameters.

Configuration for an application is stored in an XML file named application.xml, which should be located under the application base path. Its format is shown in the following. Complete specification of application configurations can be found in the DTD and XSD files.

<application PropertyName="PropertyValue" ...>
  <paths>
    <alias id="AliasID" path="AliasPath" />
    <using namespace="Namespace" />
  </paths>
  <modules>
    <module id="ModuleID" class="ModuleClass"  PropertyName="PropertyValue" ... />
  </modules>
  <parameters>
    <parameter id="ParameterID" class="ParameterClass" PropertyName="PropertyValue" ... />
  </parameters>
  <include file="path.to.extconfig" when="PHP expression" />
  <services>
    <service id="ServiceID" class="ServiceClass" PropertyName="PropertyValue" ... />
  </services>
</application>
  • The outermost element <application> corresponds to the TApplication instance. The PropertyName="PropertyValue" pairs specify the initial values for the properties of TApplication.
  • The <paths> element contains the definition of path aliases and the PHP inclusion paths for the application. Each path alias is specified via an <alias> whose path attribute takes an absolute path or a path relative to the directory containing the application configuration file. The <using> element specifies a particular path (in terms of namespace) to be appended to the PHP include paths when the application runs. PRADO defines two default aliases: System and Application. The former refers to the PRADO framework root directory, and the latter refers to the directory containing the application configuration file.
  • The <modules> element contains the configurations for a list of modules. Each module is specified by a <module> element. Each module is uniquely identified by the id attribute and is of type class. The PropertyName="PropertyValue" pairs specify the initial values for the properties of the module.
  • The <parameters> element contains a list of application-level parameters that are accessible from anywhere in the application. You may specify component-typed parameters like specifying modules, or you may specify string-typed parameters which take a simpler format as follows,
    <parameter id="ParameterID" value="ParameterValue" />
    Note, if the value attribute is not specified, the whole parameter XML node (of type TXmlElement) will be returned as the parameter value. In addition, the System.Util.TParameterModule module provides a way to load parameters from an external XML file. See more details in its API documentation.
  • The <include> element allows one to include external configuration files. It has been introduced since v3.1.0. The file attribute specifies the external configuration file in namespace format. The extension name of the file must be .xml. The when attribute contains a PHP expression and is optional (defaults to true). Only when the expression evaluates true, will the external configuration file be included. The context of the expression is the application, i.e., $this in the expression would refer to the application object.
  • The <services> element is similar to the <modules> element. It mainly specifies the services provided by the application. Within a <service> element, one can have any of the above elements. They will be effective only when the corresponding service is being requested.

An external configuration file has the same format as described above. Although the name of the root element does not matter, it is recommended to be <configuration>. External configurations will append to the main configuration. For example, if a path alias is specified in an external configuration, it will become available in addition to those aliases specified in the main configuration.

By default without explicit configuration, a PRADO application will load a few core modules, such as THttpRequest, THttpResponse, etc. It will also provide the TPageService as a default service. Configuration and usage of these modules and services are covered in individual sections of this tutorial. Note, if your application takes default settings for these modules and service, you do not need to provide an application configuration. However, if these modules or services are not sufficient, or you want to change their behavior by configuring their property values, you will need an application configuration.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Page Configurations

Page configurations are mainly used by TPageService to modify or append the application configuration. As the name indicates, a page configuration is associated with a directory storing some page files. It is stored as an XML file named config.xml.

When a user requests a page stored under <BasePath>/dir1/dir2, the TPageService will try to parse and load config.xml files under <BasePath>, <BasePath>/dir1 and <BasePath>/dir1/dir2. Paths, modules, and parameters specified in these configuration files will be appended or merged into the existing application configuration. Here <BasePath> is as defined in page service.

The format of a page configuration file is as follows,

<configuration>
  <paths>
    <alias id="AliasID" path="AliasPath" />
    <using namespace="Namespace" />
  </paths>
  <modules>
    <module id="ModuleID" class="ModuleClass"  PropertyName="PropertyValue" ... />
  </modules>
  <parameters>
    <parameter id="ParameterID" class="ParameterClass" PropertyName="PropertyValue" ... />
  </parameters>
  <include file="path.to.extconfig" when="PHP expression" />
  <authorization>
    <allow pages="PageID1,PageID2" users="User1,User2" roles="Role1,Role2" verb="get" />
    <deny pages="PageID1,PageID2" users="User1,User2" roles="Role1,Role2" verb="post" />
  </authorization>
  <pages PropertyName="PropertyValue" ...>
    <page id="PageID" PropertyName="PropertyValue" ... />
  </pages>
</configuration>

The <paths>, <modules>, <parameters> and <include> are similar to those in an application configuration. The <authorization> element specifies the authorization rules that apply to the current page directory and all its subdirectories. For more details, see authentication and authorization section. The <pages> element specifies the initial values for the properties of pages. Each <page> element specifies the initial property values for a particular page identified by the id attribute. Initial property values given in the <pages> element apply to all pages in the current directory and all its subdirectories.

Complete specification of page configurations can be found in the DTD and XSD files.

Available from Prado versions 3.1.1 onwards.

Since version 3.1.1, the id attribute in the <page> element can be a relative page path pointing to a page in the subdirectory of the directory containing the page configuration. For example, id="admin.Home" refers to the Home page under the admin directory. The id attribute can also contain wildcard '*' to match all pages under the specified directory. For example, id="admin.*" refers to all pages under the admin directory and its subdirectories. This enhancement allows developers to centralize their page configurations (e.g. put all page initializations in the aplication configuration or the root page configuration.)

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

URL Mapping (Friendly URLs)

API Manual

The TUrlMapping module allows PRADO to construct and recognize friendly URLs based on specific patterns.

TUrlMapping consists of a list of URL patterns which are used to match against the currently requested URL. The first matching pattern will then be used to decompose the URL into request parameters (accessible via $this->Request['paramname']). The patterns can also be used to construct customized URLs. In this case, the parameters in an applied pattern will be replaced with the corresponding GET variable values.

To use TUrlMapping, one must set the UrlManager property of the THttpRequest module as the TUrlMapping module ID. See following for an example,

<modules>
        <module id="request" class="THttpRequest" UrlManager="friendly-url" />
        <module id="friendly-url" class="System.Web.TUrlMapping">
                <url ServiceParameter="Posts.ViewPost" pattern="post/{id}/" parameters.id="\d+" />
                <url ServiceParameter="Posts.ListPost" pattern="archive/{time}/" parameters.time="\d{6}" />
                <url ServiceParameter="Posts.ListPost" pattern="category/{cat}/" parameters.cat="\d+" />
        </module>
</modules>

The above example is part of the application configuration of the blog demo in the PRADO release. It enables recognition of the following URL formats:

  • /index.php/post/123 is recognized as /index.php?page=Posts.ViewPost&id=123
  • /index.php/archive/200605 is recognized as /index.php?page=Posts.ListPost&time=200605
  • /index.php/category/2 is recognized as /index.php?page=Posts.ListPost&cat=2

The ServiceParameter and ServiceID (the default ID is 'page') set the service parameter and service ID, respectively, of the Services for further details.

Info: The TUrlMapping must be configured before the request module resolves the request. This means delcaring the TUrlMapping outside of the <services> element in the application configuration. Specifying the mappings in the per directory config.xml is not supported.

Specifying URL Patterns

TUrlMapping enables recognition of customized URL formats based on a list prespecified of URL patterns. Each pattern is specified in a <url> tag.

The Pattern and Parameters attribute values are regular expression patterns that determine the mapping criteria. The Pattern property takes a regular expression with parameter names enclosed between a left brace '{' and a right brace '}'. The patterns for each parameter can be set using Parameters attribute collection. For example,

<url ServiceParameter="ArticleView" pattern="articles/{year}/{month}/{day}"
    parameters.year="\d{4}" parameters.month="\d{2}" parameters.day="\d+" />

The example is equivalent to the following regular expression (it uses the "named group" feature in regular expressions available in PHP):
<url ServiceParameter="ArticleView"><![CDATA[
    #articles/(?P<year>\d{4})/(?P<month>\d{2})/(?P<day>\d+)#u
]]></url>

In the above example, the pattern contains 3 parameters named "year", "month" and "day". The pattern for these parameters are, respectively, "\d{4}" (4 digits), "\d{2}" (2 digits) and "\d+" (1 or more digits). Essentially, the Parameters attribute name and values are used as substrings in replacing the placeholders in the Pattern string to form a complete regular expression string.

For simple (not parameterized) regular expressions you can use the RegularExpression property:
<url ServiceParameter="ArticleView"
    RegularExpression="/articles\/best-of/u" />
Note: If you intended to use the RegularExpression property or regular expressions in CDATA sections, notice that you need to escape the slash, if you are using the slash as regular expressions delimiter.
If you are using the "CDATA section" version all whitespaces like \n, \t, \r and so on will be removed automaticly.

Following from the above pattern example, an URL http://example.com/index.php/articles/2006/07/21 will be matched and valid. However, http://example.com/index.php/articles/2006/07/hello is not valid since the day parameter pattern is not satisfied. In the default TUrlMappingPattern class, the pattern is matched against the PATH_INFO part of the URL only. For example, only the /articles/2006/07/21 portion of the URL is considered.

The mapped request URL is equivalent to index.php?page=ArticleView&year=2006&month=07&day=21. The request parameter values are available through the standard Request object. For example, $this->Request['year'].

The URL mapping are evaluated in order they are placed and only the first pattern that matches the URL will be used. Cascaded mapping can be achieved by placing the URL mappings in particular order. For example, placing the most specific mappings first.

Since version 3.1.4, Prado also provides wildcard patterns to use friendly URLs for a bunch of pages in a directory with a single rule. Therefore you can use the {*} wildcard in your pattern to let Prado know, where to find the ServiceID in your request URL. You can also specify parameters with these patterns if a lot of pages share common parameters.

<url ServiceParameter="Posts.*" pattern="posts/{*}/{id}" parameters.id="\d+" />
<url ServiceParameter="Posts.*" pattern="posts/{*}" />
<url ServiceParameter="Static.Info.*" pattern="info/{*}" />

With these rules, any of the following URLs will be recognized:

  • /index.php/post/ViewPost/123 is recognized as /index.php?page=Posts.ViewPost&id=123
  • /index.php/post/ListPost/123 is recognized as /index.php?page=Posts.ListPost&id=123
  • /index.php/post/ListPost/123 is recognized as /index.php?page=Posts.ListPost&id=123
  • /index.php/post/MyPost is recognized as /index.php?page=Posts.MyPost
  • /index.php/info/Conditions is recognized as /index.php?page=Static.Info.Conditions
  • /index.php/info/About is recognized as /index.php?page=Static.Info.About

As above, put more specific rules before more common rules as the first matching rule will be used.

To make configuration of friendly URLs for multiple pages even easier, you can also use UrlFormat="Path" in combination with wildcard patterns. In fact, this feature only is available in combination with wildcard rules:

<url ServiceParameter="user.admin.*" pattern="admin/{*}" UrlFormat="Path"/>
<url ServiceParameter="*" pattern="{*}" UrlFormat="Path" />

Parameters will get appended to the specified patterns as name/value pairs, separated by a "/". (You can change the separator character with UrlParamSeparator.)

  • /index.php/list/cat/15/month/12 is recognized as /index.php?page=list&cat=15&month=12
  • /index.php/edit/id/12 is recognized as /index.php?page=list&id=12
  • /index.php/show/name/foo is recognized as /index.php?page=show&name=foo
  • /index.php/admin/edit/id/12 is recognized as /index.php?page=user.admin.edit&id=12

Constructing Customized URLs

Since version 3.1.1, TUrlMapping starts to support constructing customized URLs based on the provided patterns. To enable this feature, set TUrlMapping.EnableCustomUrl to true. When THttpRequest.constrcutUrl() is invoked, the actual URL construction work will be delegated to a matching TUrlMappingPattern instance. It replaces the parameters in the pattern with the corresponding GET variables passed to constructUrl().

A matching pattern is one whose ServiceID and ServiceParameter properties are the same as those passed to constructUrl() and whose named parameters are found in the GET variables. For example, constructUrl('Posts.ListPost',array('cat'=>2)) will use the third pattern in the above example.

By default, TUrlMapping will construct URLs prefixed with the currently requesting PHP script path, such as /path/to/index.php/article/3. Users may change this behavior by explicitly specifying the URL prefix through its UrlPrefix property. For example, if the Web server configuration treats index.php as the default script, we can set UrlPrefix as /path/to and the constructed URL will look like /path/to/article/3.

Note: If you use constructUrl() with string parameters that contain slashes ("/") they will get encoded to %2F. By default most Apache installations give a "404 Not found" if a URL contains a %2F. You can add AllowEncodedSlashes On to your VirtualHost configuration to resolve this. (Available since Apache 2.0.46).
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Standard Controls

* the tutorial for this control is not completed yet.

  • TAccordion displays an accordion consisting of multiple views. At any time, only one view is visible.
  • TButton represents a click button on a Web page. It is mainly used to trigger page postback.
  • TCaptcha displays a CAPTCHA to keep spammers from signing up for certain accounts online.
  • TCheckBox represents a checkbox on a Web page. It can be used to collect two-state user input.
  • TClientScript adds javascript code to the page.
  • TClientScriptLoader loads custom javascript libraries.
  • TColorPicker represents an input field taking color values via a color dialog.
  • TConditional displays content corresponding to true or false result of a PHP expression.
  • TDatePicker represents an input field taking date values via a calendar dialog.
  • TExpression accepts a PHP expression and displays the evaluation result on a Web page.
  • TFileUpload represents a file upload field. It allows users to upload a file to server.
  • TFlushOutput enables forced flushing of the current output buffer at (a) certain point(s) in the page.
  • THead represents the <head> element on an HTML Web page. It is required by a PRADO page should it use themes.
  • THiddenField represents a hidden input field on a Web page.
  • THtmlArea represents a WYSIWYG text input field taking user input that are in HTML format.
  • THyperLink represents a hyperlink on a Web page.
  • TImage represents an image on a Web page.
  • TImageButton represents a click button that has an image as the background. It is mainly used to trigger page postback.
  • TImageMap represents an image on a Web page with clickable hotspot regions.
  • TInlineFrame represents an <iframe> HTML element on a Web page.
  • TJavascriptLogger represents a logger on a Web page that can log various JavaScript information.
  • TKeyboard displays a virtual keyboard for users to enter input into a text box.
  • TLabel represents a label on a Web page. The label can be customized via various CSS attributes.
  • TLinkButton represents a hyperlink that can perform page postbacks.
  • TLiteral represents a static text without any HTML tag surrounding it on a Web page.
  • TMultiView represents a container for a group of TView controls, each of which is container for other controls. At any time, at most one TView is visible.
  • TOutputCache enables caching portions of page output and may significantly improve page response time.
  • TPager generates UI that allows users to interactively specify which page of data to be displayed in a data-bound control.
  • TPanel represents a container for other controls on a Web page. In HTML, it is displayed as a <div> element.
  • TPlaceHolder reserves a place on a control template. It inserts its body content at that place.
  • TRadioButton represents a radiobutton on a Web page. It is mainly used in a group from which users make a choice.
  • XSS).
  • TSlider represents a Slider control
  • TStatements accepts a few PHP statements and displays their standard output on the Web page.
  • TTable represents an HTML table on a Web page. It is used together with TTableRow and TTableCell.
  • TTabPanel displays a tabbed panel consisting of multiple tab views. At any time, only one tab view is visible.
  • TTextBox represents a text input field on a Web page. It can collect single-line, multi-line or password text input from users.
  • TTextHighlighter highlights its body content according to the specified syntax highlighter, such as PHP, XML, PRADO, etc.
  • TWizard represents a multi-step form that can take user input step by step. It resembles to Windows installation wizards.
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Validation Controls

Validation controls, called validators, perform validation on user-entered data values when they are post back to the server. The validation is triggered by a postback control, such as a TButton, a TLinkButton or a TTextBox (under AutoPostBack mode) whose CausesValidation property is true.

Validation is always performed on server side. If EnableClientScript is true and the client browser supports JavaScript, validators may also perform client-side validation. Client-side validation will validate user input before it is sent to the server. The form data will not be submitted if any error is detected. This avoids the round-trip of information necessary for server-side validation.

Validators share a common set of properties, which are defined in the base class TBaseValidator class and listed as follows,

  • ControlToValidate specifies the input control to be validated. This property must be set to the ID path of an input control. An ID path is the dot-connected IDs of the controls reaching from the validator's naming container to the target control.
  • ErrorMessage specifies the error message to be displayed in case the corresponding validator fails.
  • Text is similar to ErrorMessage. If they are both present, Text takes precedence. This property is useful when used together with TValidationSummary.
  • ValidationGroup specifies which group the validator is in. The validator will perform validation only if the current postback is triggered by a control which is in the same group.
  • EnableClientScript specifies whether client-side validation should be performed. By default, it is enabled.
  • Display specifies how error messages are displayed. It takes one of the following three values:
    • None - the error message will not be displayed even if the validator fails.
    • Static - the space for displaying the error message is reserved. Therefore, showing up the error message will not change your existing page layout.
    • Dynamic - the space for displaying the error message is NOT reserved. Therefore, showing up the error message will shift the layout of your page around (usually down).
  • ControlCssClass - the CSS class that is applied to the control being validated in case the validation fails.
  • FocusOnError - set focus at the validating place if the validation fails. Defaults to false.
  • FocusElementID - the ID of the HTML element that will receive focus if validation fails and FocusOnError is true.

Prado Validation Controls

TRequiredFieldValidator

API Manual

TRequiredFieldValidator ensures that the user enters some data in the specified input field. By default, TRequiredFieldValidator will check if the user input is empty or not. The validation fails if the input is empty. By setting InitialValue, the validator can check if the user input is different from InitialValue. If not, the validation fails.

Run Sample View Source

TRegularExpressionValidator

API Manual

TRegularExpressionValidator verifies the user input against a regular pattern. The validation fails if the input does not match the pattern. The regular expression can be specified by the RegularExpression property. Some commonly used regular expressions include:

  • At least 6 characters: [\w]{6,}
  • Japanese Phone Number: (0\d{1,4}-|\(0\d{1,4}\) ?)?\d{1,4}-\d{4}
  • Japanese Postal Code: \d{3}(-(\d{4}|\d{2}))?
  • P.R.C. Phone Number: (\(\d{3}\)|\d{3}-)?\d{8}
  • P.R.C. Postal Code: \d{6}
  • P.R.C. Social Security Number: \d{18}|\d{15}
  • U.S. Phone Number: ((\(\d{3}\) ?)|(\d{3}-))?\d{3}-\d{4}
  • U.S. ZIP Code: \d{5}(-\d{4})?
  • U.S. Social Security Number: \d{3}-\d{2}-\d{4}

More regular expression patterns can be found on the Internet, e.g. http://regexlib.com/.

Note, TRegularExpressionValidator only checks for nonempty user input. Use a TRequiredFieldValidator to ensure the user input is not empty.

Run Sample View Source

TEmailAddressValidator

API Manual

TEmailAddressValidator verifies that the user input is a valid email address. The validator uses a regular expression to check if the input is in a valid email address format. If CheckMXRecord is true, the validator will also check whether the MX record indicated by the email address is valid, provided checkdnsrr() is available in the installed PHP.

Note, if the input being validated is empty, TEmailAddressValidator will not do validation. Use a TRequiredFieldValidator to ensure the value is not empty.

Run Sample View Source

TCompareValidator

API Manual

TCompareValidator compares the user input with a constant value specified by ValueToCompare, or another user input specified by ControlToCompare. The Operator property specifies how to compare the values, which includes Equal, NotEqual, GreaterThan, GreaterThanEqual, LessThan and LessThanEqual. Before comparison, the values being compared will be converted to the type specified by DataType listed as follows,

  • String - A string data type.
  • Integer - A 32-bit signed integer data type.
  • Float - A double-precision floating point number data type.
  • Date - A date data type. The date format can be specified by setting DateFormat property, which must be recognizable by TSimpleDateFormatter. If the property is not set, the GNU date syntax is assumed.

Note, if the input being validated is empty, TEmailAddressValidator will not do validation. Use a TRequiredFieldValidator to ensure the value is not empty.

N.B. If validating against a TDatePicker.

Run Sample View Source

TDataTypeValidator

API Manual

TDataTypeValidator verifies if the input data is of specific type indicated by DataType. The data types that can be checked against are the same as those in TCompareValidator.

N.B. If validating against a TDatePicker.

Run Sample View Source

TRangeValidator

API Manual

TRangeValidator verifies whether an input value is within a specified range. TRangeValidator uses three key properties to perform its validation. The MinValue and MaxValue properties specify the minimum and maximum values of the valid range. The DataType property specifies the data type of the value being validated. The value will be first converted into the specified type and then compare with the valid range. The data types that can be checked against are the same as those in TCompareValidator.

If StrictComparison property is set to true, then the ranges are compared as strictly less than the MaxValue and/or strictly greater than the MinValue.

N.B. If validating against a TDatePicker.

Run Sample View Source

TCustomValidator

API Manual

TCustomValidator performs user-defined validation (either server-side or client-side or both) on an input control.

To create a server-side validation function, provide a handler for the OnServerValidate event that performs the validation. The data string of the input control to validate can be accessed by the event parameter's Value property. The result of the validation should be stored in the IsValid property of the parameter.

To create a client-side validation function, add the client-side validation javascript function to the page template and assign its name to the ClientValidationFunction property. The function should have the following signature:

<script type="text/javascript">
function ValidationFunctionName(sender, parameter)
{
    // if(parameter == ...)
    //    return true;
    // else
    //    return false;
}
</script>
Run Sample View Source

TValidationSummary

API Manual

TValidationSummary displays a summary of validation errors inline on a Web page, in a message box, or both.

By default, a validation summary will collect ErrorMessage of all failed validators on the page. If ValidationGroup is not empty, only those validators who belong to the group will show their error messages in the summary.

The summary can be displayed as a list, a bulleted list, or a single paragraph based on the DisplayMode property. The messages shown can be prefixed with HeaderText. The summary can be displayed on the Web page or in a JavaScript message box, by setting the ShowSummary and ShowMessageBox properties, respectively. Note, the latter is only effective when EnableClientScript is true.

Run Sample View Source

Interacting the Validators

Resetting or Clearing of Validators

Validators can be reset on the client-side using javascript by calling the Prado.Validation.reset(groupID) where groupID is the validator grouping name. If groupID is null, then validators without grouping are used.

<script type="text/javascript">
function reset_validator()
{
    Prado.Validation.reset("group1");
}
</script>
Run Sample View Source

Client and Server Side Conditional Validation

All validators contains the following events. The corresponding events for the client side is available as sub-properties of the ClientSide property of the validator.

  • The OnValidate event is raise before the validator validation functions are called.
  • The OnValidationSuccess event is raised after the validator has successfully validate the control.
  • The OnValidationError event is raised after the validator fails validation.
Note: For Prado versions earlier than 3.1 the property names were OnError and OnSuccess. For Prado version 3.1 or later they are OnValidationError and OnValidationSuccess, respectively.

The following example pop-up a message saying "hello" when the validator fails on the client-side.

<com:TRequiredFieldValidator ... >
    <prop:ClientSide.OnValidationError>
        alert("hello");
    </prop:ClientSide.OnValidationError>
</com:TRequiredFieldValidator>
The resulting client-side event callback function is of the following form.
function onErrorHandler(sender, parameter)
{
    alert("hello");
}
Where sender is the current client-side validator and parameter is the control that invoked the validator.

Conditional Validation Example

The following example show the use of client-side and server side validator events. The example demonstrates conditional validation. Notice that, we need to write code for both the server side and client-side. Moreover, on the server side, we need to re-enable the conditional validator so that its javascript code are produced no matter what (otherwise, the client-side validator is not available).

Run Sample View Source

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

List Controls

List controls covered in this section all inherit directly or indirectly from TListControl. Therefore, they share the same set of commonly used properties, including,

  • Items - list of items in the control. The items are of type TListItem. The item list can be populated via databinding or specified in templates like the following:
    <com:TListBox>
  <com:TListItem Text="text 1" Value="value 1" />
  <com:TListItem Text="text 2" Value="value 2" Selected="true" />
  <com:TListItem Text="text 3" Value="value 3" />
</com:TListBox>
  • SelectedIndex - the zero-based index of the first selected item in the item list.
  • SelectedIndices - the indices of all selected items.
  • SelectedItem - the first selected item in the item list.
  • SelectedValue - the value of the first selected item in the item list.
  • AutoPostBack - whether changing the selection of the control should trigger postback.
  • CausesValidation - whether validation should be performed when postback is triggered by the list control.

Since TListControl inherits from TDataBoundControl, these list controls also share a common operation known as databinding. The Items can be populated from preexisting data specified by DataSource or DataSourceID. A function call to dataBind() will cause the data population. For list controls, data can be specified in the following two kinds of format:

  • one-dimensional array or objects implementing ITraversable : array keys will be used as list item values, and array values will be used as list item texts. For example
    $listbox->DataSource=array(
    'key 1'=>'item 1',
    'key 2'=>'item 2',
    'key 3'=>'item 3');
$listbox->dataBind();
  • tabular (two-dimensional) data : each row of data populates a single list item. The list item value is specified by the data member indexed with DataValueField, and the list item text by DataTextField. For example,
    $listbox->DataTextField='name';
$listbox->DataValueField='id';
$listbox->DataSource=array(
    array('id'=>'001','name'=>'John','age'=>31),
    array('id'=>'002','name'=>'Mary','age'=>30),
    array('id'=>'003','name'=>'Cary','age'=>20));
$listbox->dataBind();

TListBox

API Manual

TListBox displays a list box that allows single or multiple selection. Set the property SelectionMode as Single to make a single selection list box, and Multiple a multiple selection list box. The number of rows displayed in the box is specified via the Rows property value.

Run Sample View Source

TDropDownList

API Manual

TDropDownList displays a dropdown list box that allows users to select a single option from a few prespecified ones.

Since v3.1.1, TDropDownList starts to support prompt text (something like 'Please select:' as the first list item). To use this feature, set either PromptText or PromptValue, or both. If the user chooses the prompt item, the dropdown list will be unselected.

Run Sample View Source

TCheckBoxList

API Manual

TCheckBoxList displays a list of checkboxes on a Web page. The alignment of the text besides each checkbox can be specified TextAlign. The layout of the checkboxes can be controlled by the following properties:

  • RepeatLayout - can be either Table or Flow. A Table uses HTML table cells to organize the checkboxes, while a Flow uses HTML span tags and breaks for the organization. With Table layout, you can set CellPadding and CellSpacing.
  • RepeatColumns - how many columns the checkboxes should be displayed in.
  • RepeatDirection - how to traverse the checkboxes, in a horizontal way or a vertical way (because the checkboxes are displayed in a matrix-like layout).
Run Sample View Source

TRadioButtonList

API Manual

TRadioButtonList is similar to TCheckBoxList in every aspect except that each TRadioButtonList displays a group of radiobuttons. Only one of the radiobuttions can be selected (TCheckBoxList allows multiple selections.)

Run Sample View Source

TBulletedList

API Manual

TBulletedList displays items in a bullet format on a Web page. The style of the bullets can be specified by BulletStyle. When the style is CustomImage, the bullets are displayed as images, which is specified by BulletImageUrl.

TBulletedList displays the item texts in three different modes,

  • Text - the item texts are displayed as static texts;
  • HyperLink - each item is displayed as a hyperlink whose URL is given by the item value, and Target property can be used to specify the target browser window;
  • LinkButton - each item is displayed as a link button which posts back to the page if a user clicks on that, and the event OnClick will be raised under such a circumstance.
Run Sample View Source

TRatingList

API Manual

This is an EXPERIMENTAL class that displays clickable images that represent a TRadioButtonList.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Data Controls

  • TDataList is used to display or modify a list of data items.
  • TDataGrid displays data in a tabular format with rows and columns.
  • TRepeater displays its content defined in templates repeatedly based on the given data.
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Active Controls (AJAX enabled Controls)

See the Introduction for a quick overview of the concept behind active controls (AJAX enabled controls). Most active controls have a property of ActiveControl and a sub-property ClientSide that provides many properties to customize the controls. The CallbackClient property of the TPage class provides many methods to update and alter the client-side content during a callback request. Active controls is reliant on a collection of javascript classes.

For a quick demo of active controls, try the TActiveButton control. See also the later part of the Currency Converter tutorial for a more in depth example.

Standard Active Controls

  • TActiveButton represents a click button on a Web page. It can be used to trigger a callback request.
  • TActiveCheckBox represents a checkbox on a Web page. It can be used to collect two-state user input and can trigger a callback request.
  • TActiveCustomValidator validates a particular control using a callback request.
  • TActiveDatePicker adds a date picker that permits the suer to choose a date.
  • TActiveFileUpload displays a file upload field on a page and uses an iframe to permit handling of the file upload in a callback.
  • TActiveHiddenField displays a hidden input field that can be changed upon callback.
  • TActiveHyperLink represents a hyperlink on a Web page.
  • TActiveImage represents an image on a Web page.
  • TActiveImageButton represents a click button that has an image as the background. It is can be used to trigger a callback request.
  • TActiveLabel represents a label on a Web page. The label can be customized via various CSS attributes.
  • TActiveLinkButton represents a hyperlink that can perform a callback request.
  • TActiveMultiView represents a container for a group of TView controls, each of which is container for other controls. At any time, at most one TView is visible. It's the active counterpart of TMultiView.
  • TActivePanel represents a container for other controls on a Web page. In HTML, it is displayed as a <div> element. The panel's contents can be replaced during a callback request.
  • TActivePager generates UI that allows users to interactively specify which page of data to be displayed in a data-bound control.
  • TActiveRadioButton represents a radiobutton on a Web page. It is mainly used in a group from which users make a choice. It can be used to perform a callback request.
  • TActiveRatingList is an EXPERIMENTAL class that displays clickable images that represent a TRadioButtonList.
  • TActiveTextBox represents a text input field on a Web page. It can collect single-line, multi-line or password text input from users. It can be used to perform a callback request.

Active List Controls

  • TActiveCheckBoxList displays a list of checkboxes on a Web page and each checkbox can trigger a callback request.
  • TActiveDropDownList displays a dropdown list box that allows users to select a single option from a few prespecified ones. It can be used to perform a callback request.
  • TActiveListBox displays a list box that allows single or multiple selection. It can be used to perform a callback request.
  • TActiveRadioButtonList is similar to TActiveCheckBoxList in every aspect except that each TActiveRadioButtonList displays a group of radiobuttons. Each radio button can perform a callback request.

Active Data Controls

  • TActiveDataList is used to display or modify a list of data items. It is the active counterpart to the original TDataList control.
  • TActiveDataGrid displays data in a tabular format with rows and columns. It is the active counterpart to the original TDataGrid control.
  • TActiveRepeater displays its content defined in templates repeatedly based on the given data. It is the active counterpart to the original TRepeater control.

Extended Active Controls

  • TAutoComplete extends TActiveTextBox to offer text completion suggestions.
  • TCallback a generic control that can perform callback requests.
  • TEventTriggeredCallback triggers a callback request based on HTML DOM events.
  • TInPlaceTextBox represents a label that can be edited by clicked.
  • TTimeTriggeredCallback triggers a callback request based on time elapsed.
  • TValueTriggeredCallback monitors (using a timer) an attribute of an HTML element and triggers a callback request when the attribute value changes.
  • TDropContainer & TDraggable represents drag and drop containers. The former will make its child controls "draggable" while the latter will raise a callback when a draggable control is dropped on it.

Active Control Abilities

The following table shows the Active Controls that can trigger a callback event and whether the control will raise a PostBack event if Javascript was disabled on the client's browser.

Control Name | Triggers Callback | Falls back to PostBack
TActiveButton | Yes | Yes
TActiveCheckBox | Yes | Yes
TActiveCustomValidator | Yes | Yes
TActiveHyperLink | No | Yes
TActiveImage | No | Yes
TActiveImageButton | Yes | Yes
TActiveLabel | No | Yes
TActiveLinkButton | Yes | No
TActivePanel | No | Yes
TActiveRadioButton | Yes | Yes
TActiveTextBox | Yes | Yes
TCallbackOptions | No | N/A
TActiveCheckBoxList | Yes | Yes
TActiveDropDownList | Yes | Yes
TActiveListBox | Yes | Yes
TActiveRadioButtonList | Yes | Yes
TAutoComplete | Yes | No
TCallback | Yes | No
TEventTriggeredCallback | Yes | No
TInPlaceTextBox | Yes | No
TTimeTriggeredCallback | Yes | No
TValueTriggeredCallback | Yes | No
TDropContainer | Yes | No
TDraggable | No | No

Active Control Basic Infrastructure Classes

The following classes provide the basic infrastructure classes required to realize the active controls. They can be useful to develop new active controls, but Prado users tipically don't need to use them.

  • TActiveControlAdapter

    API Manual

    TActiveControlAdapter customizes the parent TControl class for active control classes. It tracks changes in the viewstate values of the control and update differences of the client-side HTML element attributes.

  • TActiveListControlAdapter

    API Manual

    TActiveListControlAdapter allows the adapted list controls to change the selections on the client-side during a callback request.

  • TActivePageAdapter

    API Manual

    TActivePageAdapter process the page life-cycle for callback requests.

  • TBaseActiveControl

    API Manual

    TBaseActiveControl class provided additional basic properties common for every active control. An instance of TBaseActiveControl or its decendent TBaseActiveCallbackControl is created by TActiveControlAdapter::getBaseActiveControl() method. The EnableUpdate property determines wether the active control is allowed to update the contents of the client-side when the callback response returns.

  • TCallbackResponseAdapter

    API Manual

    TCallbackResponseAdapter alters the THttpResponse's outputs. A TCallbackResponseWriter is used instead of the TTextWrite when createHtmlWriter is called. Each call to createHtmlWriter will create a new TCallbackResponseWriter. When flushContent() is called each instance of TCallbackResponseWriter's content is flushed. The callback response data can be set using the ResponseData property.

Active Control Infrastructure Advanced Classes

The following classes provide advanced properties and events needed to realize the active controls. A Prado user can use them to customize active controls behaviour and interact directly with the client side during a callback.

  • TCallbackClientScript methods to manipulate the client-side HTML elements, also includes methods to invoke javascript Effects on HTML elements.
  • TCallbackClientSide is used to specify client-side callback request options and client-side event handlers.
  • TCallbackEventParameter provides the parameter passed during the callback request.
  • TCallbackOptions allows a common set of callback client-side options to be attached to one or more active controls.
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Writing New Controls

Writing new controls is often desired by advanced programmers, because they want to reuse the code that they write for dealing with complex presentation and user interactions.

In general, there are two ways of writing new controls: composition of existing controls and extending existing controls. They all require that the new control inherit from TControl or its child classes.

Composition of Existing Controls

Composition is the easiest way of creating new controls. It mainly involves instantiating existing controls, configuring them and making them the constituent components. The properties of the constituent components are exposed through subproperties.

One can compose a new control in two ways. One is to extend TCompositeControl and override the TControl::createChildControls() method. The other is to extend TTemplateControl (or its child classes) and write a control template. The latter is easier to use and can organize the layout constituent components more intuitively, while the former is more efficient because it does not require parsing of the template.

As an example, we show how to create a labeled textbox called LabeledTextBox using the above two approaches. A labeled textbox displays a label besides a textbox. We want reuse the PRADO provided TLabel and TTextBox to accomplish this task.

Composition by Writing Templates

We need two files: a control class file named LabeledTextBox.php and a control template file named LabeledTextBox.tpl. Both must reside under the same directory.

Like creating a PRADO page, we can easily write down the content in the control template file.

<com:TLabel ID="Label" ForControl="TextBox" />
<com:TTextBox ID="TextBox" />

The above template specifies a TLabel control named Label and a TTextBox control named TextBox. We would to expose these two controls. This can be done by defining a property for each control in the LabeledTextBox class file. For example, we can define a Label property as follows,

class LabeledTextBox extends TTemplateControl {
    public function getLabel() {
        $this->ensureChildControls();
        return $this->getRegisteredObject('Label');
    }
}

In the above, the method call to ensureChildControls() ensures that both the label and the textbox controls are created (from template) when the Label property is accessed. The TextBox property can be implemented similarly.

Run Sample View Source

Composition by Overriding createChildControls()

For a composite control as simple as LabeledTextBox, it is better to create it by extending TCompositeControl and overriding the createChildControls() method, because it does not use templates and thus saves template parsing time.

Complete code for LabeledTextBox is shown as follows,

class LabeledTextBox extends TCompositeControl {
    private $_label;
    private $_textbox;
    public function createChildControls() {
        $this->_label=new TLabel;
        $this->_label->setID('Label');
        // add the label as a child of LabeledTextBox
        $this->getControls()->add($this->_label);
        $this->_textbox=new TTextBox;
        $this->_textbox->setID('TextBox');
        $this->_label->setForControl('TextBox');
        // add the textbox as a child of LabeledTextBox
        $this->getControls()->add($this->_textbox);
    }
    public function getLabel() {
        $this->ensureChildControls();
        return $this->_label;
    }
    public function getTextBox() {
        $this->ensureChildControls();
        return $this->_textbox;
    }
}
Run Sample View Source

Using LabeledTextBox

To use LabeledTextBox control, first we need to include the corresponding class file. Then in a page template, we can write lines like the following,

<com:LabeledTextBox ID="Input" Label.Text="Username" />

In the above, Label.Text is a subproperty of LabeledTextBox, which refers to the Text property of the Label property. For other details of using LabeledTextBox, see the above online examples.

Extending Existing Controls

Extending existing controls is the same as conventional class inheritance. It allows developers to customize existing control classes by overriding their properties, methods, events, or creating new ones.

The difficulty of the task depends on how much an existing class needs to be customized. For example, a simple task could be to customize TLabel control, so that it displays a red label by default. This would merely involves setting the ForeColor property to "red" in the constructor. A difficult task would be to create controls that provide completely innovative functionalities. Usually, this requires the new controls extend from "low level" control classes, such as TControl or TWebControl.

In this section, we mainly introduce the base control classes TControl and TWebControl, showing how they can be customized. We also introduce how to write controls with specific functionalities, such as loading post data, raising post data and databinding with data source.

Extending TControl

TControl is the base class of all control classes. Two methods are of the most importance for derived control classes:

  • addParsedObject() - this method is invoked for each component or text string enclosed within the component tag specifying the control in a template. By default, the enclosed components and text strings are added into the Controls collection of the control. Derived controls may override this method to do special processing about the enclosed content. For example, TListControl only accepts TListItem components to be enclosed within its component tag, and these components are added into the Items collection of TListControl.
  • render() - this method renders the control. By default, it renders items in the Controls collection. Derived controls may override this method to give customized presentation.
Other important properties and methods include:
  • ID - a string uniquely identifying the control among all controls of the same naming container. An automatic ID will be generated if the ID property is not set explicitly.
  • UnqiueID - a fully qualified ID uniquely identifying the control among all controls on the current page hierarchy. It can be used to locate a control in the page hierarchy by calling TControl::findControl() method. User input controls often use it as the value of the name attribute of the HTML input element.
  • ClientID - similar to UniqueID, except that it is mainly used for presentation and is commonly used as HTML element id attribute value. Do not rely on the explicit format of ClientID.
  • Enabled - whether this control is enabled. Note, in some cases, if one of the control's ancestor controls is disabled, the control should also be treated as disabled, even if its Enabled property is true.
  • Parent - parent control of this control. The parent control is in charge of whether to render this control and where to place the rendered result.
  • Page - the page containing this control.
  • Controls - collection of all child controls, including static texts between them. It can be used like an array, as it implements Traversable interface. To add a child to the control, simply insert it into the Controls collection at appropriate position.
  • Attributes - collection of custom attributes. This is useful for allowing users to specify attributes of the output HTML elements that are not covered by control properties.
  • getViewState() and setViewState() - these methods are commonly used for defining properties that are stored in viewstate.
  • saveState() and loadState() - these two methods can be overriden to provide last step state saving and loading.
  • Control lifecycles - Like pages, controls also have lifecycles. Each control undergoes the following lifecycles in order: constructor, onInit(), onLoad(), onPreRender(), render(), and onUnload. More details can be found in the page section.

Extending TWebControl

TWebControl is mainly used as a base class for controls representing HTML elements. It provides a set of properties that are common among HTML elements. It breaks the TControl::render() into the following methods that are more suitable for rendering an HTML element:

  • addAttributesToRender() - adds attributes for the HTML element to be rendered. This method is often overridden by derived classes as they usually have different attributes to be rendered.
  • renderBeginTag() - renders the opening HTML tag.
  • renderContents() - renders the content enclosed within the HTML element. By default, it displays the items in the Controls collection of the control. Derived classes may override this method to render customized contents.
  • renderEndTag() - renders the closing HTML tag.

When rendering the openning HTML tag, TWebControl calls getTagName() to obtain the tag name. Derived classes may override this method to render different tag names.

Creating Controls with Special Functionalities

If a control wants to respond to client-side events and translate them into server side events (called postback events), such as TButton, it has to implement the IPostBackEventHandler interface.

If a control wants to be able to load post data, such as TTextBox, it has to implement the IPostBackDataHandler interface.

If a control wants to get data from some external data source, it can extend TDataBoundControl. TDataBoundControl implements the basic properties and methods that are needed for populating data via databinding. In fact, controls like TListControl, TRepeater are TDataGrid are all derived from it.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

SOAP Service

SOAP forms the foundation layer of the Web services stack. It provides a neat way for PHP applications to communicate with each other or with applications written in other languages. PRADO provides TSoapService that makes developing a SOAP server application an extremely easy task.

To use TSoapService, configure it in the application specification like following:

<services>
  <service id="soap" class="System.Web.Services.TSoapService">
    <soap id="stockquote" provider="path.to.StockQuote" />
    <!--
    <soap...other soap service... />
    -->
  </service>
</services>

The example specifies a SOAP service provider named stockquote which implements the getPrice SOAP method in the provider class StockQuote,

class StockQuote
{
    /**
     * @param string $symbol the symbol of the stock
     * @return float the stock price
     * @soapmethod
     */
    public function getPrice($symbol)
    {
        ....return stock price for $symbol
    }
}
Note: TSoapService is based on PHP SOAP extension and thus requires the extension to be installed.

With the above simple code, we already finish a simple SOAP service that allows other applications to query the price of a specific stock. For example, a typical SOAP client may be written as follows to query the stock price of IBM,

$client=new SoapClient('http://path/to/index.php?soap=stockquote.wsdl');
echo $client->getPrice('IBM');

Notice the URL used to construct SoapClient (a class provided by PHP SOAP extension). This is the URL for the WSDL that describes the communication protocol for the SOAP service we just implemented. WSDL is often too complex to be manually written. Fortunately, TSoapService can generate this for us using a WSDL generator. In general, the URL for the automatically generated WSDL in PRADO has the following format:

http://path/to/index.php?SoapServiceID=SoapProviderID.wsdl

In order for the WSDL generator to generate WSDL for a SOAP service, the provider class needs to follow certain syntax. In particular, for methods to be exposed as SOAP methods, a keyword @soapmethod must appear in the phpdoc comment of the method with the following lines specifying method parameters and return value:

  • parameter: @param parameter-type $parameter-name description
  • return value: @return value-type description

Valid parameter and return types include: string, int, boolean, float, array, mixed, etc. You may also specify a class name as the type, which translates into a complex SOAP type. For example, for a complex type Contact

/**
 * Extends TComponent to provide property setter/getter methods
 */
class Contact {
    /**
     * @var string $name
     * @soapproperty
     */
    public $name;

    /**
     * @var Address $address
     * @soapproperty
     */
    private $_address;

    public function setAddress($value) {
        $this->_address=$value;
    }

    public function getAddress() {
        if($this->_address===null)
            $this->_address=new Address;
        return $this->_address;
    }
}

class Address{
    /**
     * @var string $city
     * @soapproperty
     */
    public $city;
}

class ContactManager {
    /**
     * @return Contact[] an array of contacts
     * @soapmethod
     */
    function getAllContacts() {
        return array(new Contact);
    }

    /**
     * @return Contact one contact
     * @soapmethod
     */
    function getContact($name) {
        return new Contact;
    }
}

For a complex soap object, the properties of the object are specified with @soapproperty keyword in the property phpdocs. Furthermore, the propert's type name must be specified as @var type $name where type is any valid type in mentioned earlier and $name will defined a property name (notice that if your class is a TComponent, you can provide property setter/getter methods).

An array of complex objects can also be returned by adding a pair of enclosing square brackets after the type name. For example, to return an array of Contact type, we define @return Contact[] ....

Tip: A very useful tool to test out your web services is the free tool WebServiceStudio 2.0. It can invoke webmethods interactively. The user can provide a WSDL endpoint. On clicking button Get the tool fetches the WSDL, generates .NET proxy from the WSDL and displays the list of methods available. The user can choose any method and provide the required input parameters. The tool requires a MS .NET runtime to be installed.

A similar tool is available for Mac OS X Tiger from http://www.ditchnet.org/soapclient/

TSoapService may be configured and customized in several ways. In the example above, the <soap> element actually specifies a SOAP service using the default TSoapServer implementation. Attributes in <soap> are passed to TSoapServer as its initial property values. For example, the provider attribute initializes the Provider property of TSoapServer. By setting SessionPersistent to be true in <soap> element, the provider instance will persist within the user session. You may develop your own SOAP server class and use it by specifying the class attribute of <soap>.

By default, PHP's soap server will create objects of the type StdClass when objects are received from the client. The soap server can be configured to automatically create objects of certain type objects are received as method parameters. For example, if we have a Soap method that accepts a Contact object as parameter.

/**
 * @param Contact $contact
 * @return boolean true if saved, false otherwise
 * @soapmethod
 */
 function save(Contact $contact)
 {
    return true
 }
The do this, we need to set the ClassMaps property of the TSoapServer in the <soap> tags as a comma separated string of class names that we wish to be automatically converted.
<soap id="contact-manager" provider="path.to.ContactManager"
    ClassMaps="Contact, Address"/>
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Data Access Objects (DAO)

Available from Prado versions 3.1a onwards.

Data Access Objects (DAO) separates a data resource's client interface from its data access mechanisms. It adapts a specific data resource's access API to a generic client interface. As a result, data access mechanisms can be changed independently of the code that uses the data.

Since version 3.1, PRADO starts to provide a DAO that is a thin wrap around PHP Data Objects (PDO). Although PDO has a nice feature set and good APIs, we choose to implement the PRADO DAO on top of PDO because the PRADO DAO classes are component classes and are thus configurable in a PRADO application. Users can use these DAO classes in a more PRADO-preferred way.

Note: Since the PRADO DAO is based on PDO, the PDO PHP extension needs to be installed. In addition, you need to install the corresponding PDO driver for the database to be used in your application. See more details in the PHP Manual.

The PRADO DAO mainly consists of the following four classes (in contrast to PDO which uses only two classes, PDO and PDOStatement):

  • TDbConnection - represents a connection to a database.
  • TDbCommand - represents an SQL statement to execute against a database.
  • TDbDataReader - represents a forward-only stream of rows from a query result set.
  • TDbTransaction - represents a DB transaction.

In the following, we introduce the usage of PRADO DAO in different scenarios.

Establishing Database Connection

To establish a database connection, one creates a TDbConnection instance and activate it. A data source name (DSN) is needed to specify the information required to connect to the database. The database username and password may need to be supplied to establish the connection.

$connection=new TDbConnection($dsn,$username,$password);
// call setAttribute() to pass in additional connection parameters
// $connection->Persistent=true;  // use persistent connection
$connection->Active=true;  // connection is established
....
$connection->Active=false;  // connection is closed

Complete specification of DSN may be found in the PDO documentation. Below is a list of commonly used DSN formats:

  • MySQL - mysql:host=localhost;dbname=test
  • SQLite - sqlite:/path/to/dbfile
  • ODBC - odbc:SAMPLE

In case any error occurs when establishing the connection (such as bad DSN or username/password), a TDbException will be raised.

Executing SQL Statements

Once a database connection is established, SQL statements can be executed through TDbCommand. One creates a TDbCommand by calling TDbConnection.createCommand() with the specified SQL statement:

$command=$connection->createCommand($sqlStatement);
// if needed, the SQL statement may be updated as follows:
$command->Text=$newSqlStatement;

An SQL statement is executed via TDbCommand in one of the following two ways:

  • execute() - performs a non-query SQL statement, such as INSERT, UPDATE and DELETE. If successful, it returns the number of rows that are affected by the execution.
  • query() - performs an SQL statement that returns rows of data, such as SELECT. If successful, it returns a TDbDataReader instance from which one can fetch the resulting rows of data.
$affectedRowCount=$command->execute();  // execute the non-query SQL
$dataReader=$command->query();          // execute a query SQL
$row=$command->queryRow();              // execute a query SQL and return the first row of result
$value=$command->queryScalar();         // execute a query SQL and return the first column value

In case an error occurs during the execution of SQL statements, a TDbException will be raised.

Fetching Query Results

After TDbCommand.query() generates the TDbDataReader instance, one can retrieve rows of resulting data by calling TDbDataReader.read() repeatedly. One can also use TDbDataReader in PHP's foreach language construct to retrieve row by row.

// calling read() repeatedly until it returns false
while(($row=$dataReader->read())!==false) { ... }
// using foreach to traverse through every row of data
foreach($dataReader as $row) { ... }
// retrieving all rows at once in a single array
$rows=$dataReader->readAll();

Using Transactions

When an application executes a few queries, each reading and/or writing information in the database, it is important to be sure that the database is not left with only some of the queries carried out. A transaction, represented as a TDbTransaction instance in PRADO, may be initiated in this case:

  • Begin the transaction.
  • Execute queries one by one. Any updates to the database are not visible to the outside world.
  • Commit the transaction. Updates become visible if the transaction is successful.
  • If one of the queries fails, the entire transaction is rolled back.
$transaction=$connection->beginTransaction();
try
{
    $connection->createCommand($sql1)->execute();
    $connection->createCommand($sql2)->execute();
    //.... other SQL executions
    $transaction->commit();
}
catch(Exception $e) // an exception is raised if a query fails will be raised
{
    $transaction->rollBack();
}

Binding Parameters

To avoid SQL injection attacks and to improve performance of executing repeatedly used SQL statements, one can "prepare" an SQL statement with optional parameter placeholders that are to be replaced with the actual parameters during the parameter binding process.

The parameter placeholders can be either named (represented as unique tokens) or unnamed (represented as question marks). Call TDbCommand.bindParameter() or TDbCommand.bindValue() to replace these placeholders with the actual parameters. The parameters do not need to be quoted: the underlying database driver does it for you. Parameter binding must be done before the SQL statement is executed.

// an SQL with two placeholders ":username" and ":email"
$sql="INSERT INTO users(username, email) VALUES(:username,:email)";
$command=$connection->createCommand($sql);
// replace the placeholder ":username" with the actual username value
$command->bindParameter(":username",$username,PDO::PARAM_STR);
// replace the placeholder ":email" with the actual email value
$command->bindParameter(":email",$email,PDO::PARAM_STR);
$command->execute();
// insert another row with a new set of parameters
$command->bindParameter(":username",$username2,PDO::PARAM_STR);
$command->bindParameter(":email",$email2,PDO::PARAM_STR);
$command->execute();

The methods bindParameter() and bindValue() are very similar. The only difference is that the former binds a parameter with a PHP variable reference while the latter with a value. For parameters that represent large block of data memory, the former is preferred for performance consideration.

For more details about binding parameters, see the relevant PHP documentation.

Binding Columns

When fetching query results, one can also bind columns with PHP variables so that they are automatically populated with the latest data each time a row is fetched.

$sql="SELECT username, email FROM users";
$dataReader=$connection->createCommand($sql)->query();
// bind the 1st column (username) with the $username variable
$dataReader->bindColumn(1,$username);
// bind the 2nd column (email) with the $email variable
$dataReader->bindColumn(2,$email);
while($dataReader->read()!==false)
{
    // $username and $email contain the username and email in the current row
}
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Active Record

Available from Prado versions 3.1a onwards.

Active Records are objects that wrap a row in a database table or view, encapsulate the database access and add domain logic on that data. The basics of an Active Record are business classes, e.g., a Products class, that match very closely the record structure of an underlying database table. Each Active Record will be responsible for saving and loading data to and from the database.

Info: The data structure of an Active Record should match that of a table in the database. Each column of a table should have a corresponding member variable or property in the Active Record class the represents the table.

When to Use It

Active Record is a good choice for domain logic that isn't too complex, such as creates, reads, updates, and deletes. Derivations and validations based on a single record work well in this structure. Active Record has the primary advantage of simplicity. It's easy to build Active Records, and they are easy to understand.

However, as your business logic grows in complexity, you'll soon want to use your object's direct relationships, collections, inheritance, and so forth. These don't map easily onto Active Record, and adding them piecemeal gets very messy. Another argument against Active Record is the fact that it couples the object design to the database design. This makes it more difficult to refactor as a project goes forward.

The alternative is to use a Data Mapper that separates the roles of the business object and how these objects are stored. Prado provides a complimentary choice between Active Record and SqlMap Data Mapper. A SqlMap Data Mapper can be used to load Active Record objects, in turn; these Active Record objects can be used to update the database. The "relationship" between Active Records and SqlMap is illustrated in the following diagram. More details regarding the SqlMap Data Mapper can be found in the SqlMap Manual. Active Records and SqlMap DataMapper

The Active Record class has functionality to perform the following tasks.

  • Create, Retrieve, Update and Delete records.
  • Finder methods to wrap commonly used SQL queries and return Active Record objects.
  • Fetch relationships (related foreign objects) such as "has many", "has one", "belongs to" and "many to many" via association table.
  • Lazy loading of relationships.

Design Implications

Prado's implementation of Active Record does not maintain referential identity. Each object obtained using Active Record is a copy of the data in the database. For example, If you ask for a particular customer and get back a Customer object, the next time you ask for that customer you get back another instance of a Customer object. This implies that a strict comparison (i.e., using ===) will return false, while loose comparison (i.e., using ==) will return true if the object values are equal by loose comparison.

This is design implication related to the following question. "Do you think of the customer as an object, of which there's only one, or do you think of the objects you operate on as copies of the database?" Other O/R mappings will imply that there is only one Customer object with custID 100, and it literally is that customer. If you get the customer and change a field on it, then you have now changed that customer. "That constrasts with: you have changed this copy of the customer, but not that copy. And if two people update the customer on two copies of the object, whoever updates first, or maybe last, wins." [A. Hejlsberg 2003]

Database Supported

The Active Record implementation utilizes the Prado DAO classes for data access. The current Active Record implementation supports the following database.

  • MySQL 4.1 or later
  • Postgres SQL 7.3 or later
  • SQLite 2 and 3
  • MS SQL 2000 or later
  • Oracle Database (alpha)

Support for other databases can be provided when there are sufficient demands.

Defining an Active Record

Let us consider the following "users" table that contains two columns named "username" and "email", where "username" is also the primary key.

CREATE TABLE users
(
    username VARCHAR( 20 ) NOT NULL ,
    email VARCHAR( 200 ) ,
    PRIMARY KEY ( username )
);

Next we define our Active Record class that corresponds to the "users" table.

class UserRecord extends TActiveRecord
{
    const TABLE='users'; //table name

    public $username; //the column named "username" in the "users" table
    public $email;

    /**
     * @return TActiveRecord active record finder instance
     */
    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

Each column of the "users" table must have corresponding property of the same name as the column name in the UserRecord class. Of course, you also define additional member variables or properties that does not exist in the table structure. The class constant TABLE is optional when the class name is the same as the table name in the database, otherwise TABLE must specify the table name that corresponds to your Active Record class.

Tip: You may specify qualified table names. E.g. for MySQL, TABLE = "`database1`.`table1`".
Note: Since version 3.1.3 you can also use a method table() to define the table name. This allows you to dynamically specify which table should be used by the ActiveRecord.
class TeamRecord extends TActiveRecord
{
    public function table() {
        return 'Teams';
    }
}

Since TActiveRecord extends TComponent, setter and getter methods can be defined to allow control over how variables are set and returned. For example, adding a $level property to the UserRecord class:

class UserRecord extends TActiveRecord {
    ... //existing definitions as above

    private $_level;
    public function setLevel($value) {
        $this->_level=TPropertyValue::ensureInteger($value,0);
    }
    public function getLevel($value){
        return $this->_level;
    }
}

More details regarding TComponent can be found in the Components documentation. Later we shall use the getter/setters to allow for lazy loading of relationship objects.

Info: TActiveRecord can also work with database views by specifying the constant TABLE corresponding to the view name. However, objects returned from views are read-only, calling the save() or delete() method will raise an exception.

The static method finder() returns an UserRecord instance that can be used to load records from the database. The loading of records using the finder methods is discussed a little later. The TActiveRecord::finder() static method takes the name of an Active Record class as parameter.

Setting up a database connection

A default database connection for Active Record can be set as follows. See Establishing Database Connection for further details regarding creation of database connection in general.

//create a connection and give it to the Active Record manager.
$dsn = 'pgsql:host=localhost;dbname=test'; //Postgres SQL
$conn = new TDbConnection($dsn, 'dbuser','dbpass');
TActiveRecordManager::getInstance()->setDbConnection($conn);

Alternatively, you can create a base class and override the getDbConnection() method to return a database connection. This is a simple way to permit multiple connections and multiple databases. The following code demonstrates defining the database connection in a base class (not need to set the DB connection anywhere else).

class MyDb1Record extends TActiveRecord
{
    public function getDbConnection()
    {
        static $conn;
        if($conn===null)
            $conn = new TDbConnection('xxx','yyy','zzz');
        return $conn;
    }
}
class MyDb2Record extends TActiveRecord
{
    public function getDbConnection()
    {
        static $conn;
        if($conn===null)
            $conn = new TDbConnection('aaa','bbb','ccc');
        return $conn;
    }
}

Using application.xml within the Prado Framework

The default database connection can also be configured using a <module> tag in the application.xml or config.xml as follows.

<modules>
  <module class="System.Data.ActiveRecord.TActiveRecordConfig" EnableCache="true">
    <database ConnectionString="pgsql:host=localhost;dbname=test"
        Username="dbuser" Password="dbpass" />
  </module>
</modules>
Tip: The EnableCache attribute when set to "true" will cache the table meta data, that is, the table columns names, indexes and constraints are saved in the cache and reused. You must clear or disable the cache if you wish to see changes made to your table definitions. A cache module must also be defined for the cache to function.

A ConnectionID property can be specified with value corresponding to another TDataSourceConfig module configuration's ID value. This allows the same database connection to be used in other modules such as SqlMap.

<modules>
  <module class="System.Data.TDataSourceConfig" id="db1">
    <database ConnectionString="pgsql:host=localhost;dbname=test"
        Username="dbuser" Password="dbpass" />
  </module>

  <module class="System.Data.ActiveRecord.TActiveRecordConfig"
        ConnectionID="db1" EnableCache="true"  />

  <module class="System.Data.SqlMap.TSqlMapConfig"
        ConnectionID="db1"  ... />
</modules>

Loading data from the database

The TActiveRecord class provides many convenient methods to find records from the database. The simplest is finding one record by matching a primary key or a composite key (primary keys that consists of multiple columns). See the API Manual for more details.

Info: All finder methods that may return 1 record only will return null if no matching data is found. All finder methods that return an array of records will return an empty array if no matching data is found.

findByPk()

Finds one record using only a primary key or a composite key.

$finder = UserRecord::finder();
$user = $finder->findByPk($primaryKey);

//when the table uses a composite key
$record = $finder->findByPk($key1, $key2, ...);
$record = $finder->findByPk(array($key1, $key2,...));

findAllByPks()

Finds multiple records using a list of primary keys or composite keys. The following are equivalent for primary keys (primary key consisting of only one column/field).

$finder = UserRecord::finder();
$users = $finder->findAllByPks($key1, $key2, ...);
$users = $finder->findAllByPks(array($key1, $key2, ...));
The following are equivalent for composite keys.
//when the table uses composite keys
$record = $finder->findAllByPks(array($key1, $key2), array($key3, $key4), ...);

$keys = array(  array($key1, $key2), array($key3, $key4), ... );
$record = $finder->findAllByPks($keys);

find()

Finds one single record that matches the criteria. The criteria can be a partial SQL string or a TActiveRecordCriteria object.

$finder = UserRecord::finder();

//:name and :pass are place holders for specific values of $name and $pass
$finder->find('username = :name AND password = :pass',
                          array(':name'=>$name, ':pass'=>$pass));

//using position place holders
$finder->find('username = ? AND password = ?', array($name, $pass));
//same as above
$finder->find('username = ? AND password = ?', $name, $pass);

//$criteria is of TActiveRecordCriteria
$finder->find($criteria); //the 2nd parameter for find() is ignored.

The TActiveRecordCriteria class has the following properties:

  • Parameters -- name value parameter pairs.
  • OrdersBy -- column name and ordering pairs.
  • Condition -- parts of the WHERE SQL conditions.
  • Limit -- maximum number of records to return.
  • Offset -- record offset in the table.
$criteria = new TActiveRecordCriteria;
$criteria->Condition = 'username = :name AND password = :pass';
$criteria->Parameters[':name'] = 'admin';
$criteria->Parameters[':pass'] = 'prado';
$criteria->OrdersBy['level'] = 'desc';
$criteria->OrdersBy['name'] = 'asc';
$criteria->Limit = 10;
$criteria->Offset = 20;
Note: For MSSQL and when Limit and Offset are positive integer values. The actual query to be executed is modified by the TMssqlCommandBuilder class according to http://troels.arvin.dk/db/rdbms/ to emulate the Limit and Offset conditions.

findAll()

Same as find() but returns an array of objects.

findBy*() and findAllBy*()

Dynamic find method using parts of the method name as search criteria. Method names starting with findBy return 1 record only and method names starting with findAllBy return an array of records. The condition is taken as part of the method name after findBy or findAllBy. The following blocks of code are equivalent:

$finder->findByName($name)
$finder->find('Name = ?', $name);
$finder->findByUsernameAndPassword($name,$pass);
$finder->findBy_Username_And_Password($name,$pass);
$finder->find('Username = ? AND Password = ?', $name, $pass);
$finder->findAllByAge($age);
$finder->findAll('Age = ?', $age);
Tip: You may also use a combination of AND and OR as a condition in the dynamic methods.

findBySql() and findAllBySql()

Finds records using full SQL where findBySql() return an Active Record and findAllBySql()returns an array of record objects. For each column returned, the corresponding Active Record class must define a member variable or property for each corresponding column name.

class UserRecord2 extends UserRecord
{
    public $another_value;
}
$sql = "SELECT users.*, 'hello' as another_value FROM users";
$users = TActiveRecord::finder('UserRecord2')->findAllBySql($sql);

count()

Find the number of matchings records, accepts same parameters as the findAll() method.

Inserting and updating records

Add a new record using TActiveRecord is very simple, just create a new Active Record object and call the save() method. E.g.

$user1 = new UserRecord();
$user1->username = "admin";
$user1->email = "admin@example.com";
$user1->save(); //insert a new record

$data = array('username'=>'admin', 'email'=>'admin@example.com');
$user2 = new UserRecord($data); //create by passing some existing data
$user2->save(); //insert a new record
Tip: If you insert a new record into a MySQL table that has columns defined with "autoincrement", the Active Record objects will be updated with the new incremented value.

To update a record in the database, just change one or more properties of the Active Record object that has been loaded from the database and then call the save() method.

$user = UserRecord::finder()->findByName('admin');
$user->email="test@example.com"; //change property
$user->save(); //update it.

Active Record objects have a simple life-cycle illustrated in the following diagram.

Active Records Life Cycle

We see that new TActiveRecord objects are created by either using one of the find*() methods or using creating a new instance by using PHP's new keyword. Objects created by a find*() method starts with clean state. New instance of TActiveRecord created other than by a find*() method starts with new state. Whenever you call the save() method on the TActiveRecord object, the object enters the clean state. Objects in the clean becomes dirty whenever one of more of its internal states are changed. Calling the delete() method on the object ends the object life-cycle, no further actions can be performed on the object.

Deleting existing records

To delete an existing record that is already loaded, just call the delete() method. You can also delete records in the database by primary keys without loading any records using the deleteByPk() method (and equivalently the deleteAllByPks() method). For example, to delete one or several records with tables using one or more primary keys.

$finder->deleteByPk($primaryKey); //delete 1 record
$finder->deleteAllByPks($key1,$key2,...); //delete multiple records
$finder->deleteAllByPks(array($key1,$key2,...)); //delete multiple records

For composite keys (determined automatically from the table definitions):

$finder->deleteByPk(array($key1,$key2)); //delete 1 record

//delete multiple records
$finder->deleteAllByPks(array($key1,$key2), array($key3,$key4),...);

//delete multiple records
$finder->deleteAllByPks(array( array($key1,$key2), array($key3,$key4), .. ));

deleteAll() and deleteBy*()

To delete by a criteria, use deleteAll($criteria) and deleteBy*() with similar syntax to findAll($criteria) and findAllBy*() as described above.

//delete all records with matching Name
$finder->deleteAll('Name = ?', $name);
$finder->deleteByName($name);

//delete by username and password
$finder->deleteBy_Username_And_Password($name,$pass);

Transactions

All Active Record objects contain the property DbConnection that can be used to obtain a transaction object.

$finder = UserRecord::finder();
$finder->DbConnection->Active=true; //open if necessary
$transaction = $finder->DbConnection->beginTransaction();
try
{
    $user = $finder->findByPk('admin');
    $user->email = 'test@example.com'; //alter the $user object
    $user->save();
    $transaction->commit();
}
catch(Exception $e) // an exception is raised if a query fails
{
    $transaction->rollBack();
}

Events

The TActiveRecord offers two events, OnCreateCommand and OnExecuteCommand.

The OnCreateCommand event is raised when a command is prepared and parameter binding is completed. The parameter object is TDataGatewayEventParameter of which the Command property can be inspected to obtain the SQL query to be executed.

The OnExecuteCommand event is raised when a command is executed and the result from the database was returned. The parameter object is TDataGatewayResultEventParameter of which the Result property contains the data return from the database. The data returned can be changed by setting the Result property.

Logging Example

Using the OnExecuteCommand we can attach an event handler to log the entire SQL query executed for a given TActiveRecord class or instance. For example, we define a base class and override either the getDbConnection() or the constructor.

class MyDb1Record extends TActiveRecord
{
    public function getDbConnection()
    {
        static $conn;
        if($conn===null)
        {
            $conn = new TDbConnection('xxx','yyy','zzz');
            $this->OnExecuteCommand[] = array($this,'logger');
        }
        return $conn;
    }
    public function logger($sender,$param)
    {
        var_dump($param->Command->Text);
    }
}
//alternatively as per instance of per finder object
function logger($sender,$param)
{
    var_dump($param->Command->Text);
}
TActiveRecord::finder('MyRecord')->OnExecuteCommand[] = 'logger';
$obj->OnExecuteCommand[] = array($logger, 'log'); //any valid PHP callback.

Active Record Relationships

Available from Prado versions 3.1rc1 onwards.

The Prado Active Record implementation supports the foreign key mappings for database that supports foreign key constraints. For Active Record relationships to function the underlying database must support foreign key constraints (e.g. MySQL using InnoDB).

In the following sections we will consider the following table relationships between Teams, Players, Skills and Profiles.

The goal is to obtain object models that represent to some degree the entity relationships in the above figure.

There is a mismatch between relationships with objects and table relationships. First there's a difference in representation. Objects handle links by storing references that are held by the runtime memory-managed environment. Relational databases handle links by forming a key into another table. Second, objects can easily use collections to handle multiple references from a single field, while normalization forces all entity relation links to be single valued. This leads to reversals of the data structure between objects and tables. The approach taken in the Prado Active Record design is to use the table foreign key constraints to derive object relationships. This implies that the underlying database must support foreign key constraints.

Tip: For SQLite database, you may create tables that defines the foreign key constraints such as the example below. However, these constraints are NOT enforced by the SQLite database itself.
CREATE TABLE foo
(
    id INTEGER NOT NULL PRIMARY KEY,
    id2 CHAR(2)
);
CREATE TABLE bar
(
    id INTEGER NOT NULL PRIMARY KEY,
    foo_id INTEGER
        CONSTRAINT fk_foo_id REFERENCES foo(id) ON DELETE CASCADE
);

Foreign Key Mapping

The entity relationship between the Teams and Players table is what is known as an 1-M relationship. That is, one Team may contain 0 or more Players. In terms of object relationships, we say that a TeamRecord object has many PlayerRecord objects. (Notice the reversal of the direction of relationships between tables and objects.)

Has Many Relationship

We model the Team object as the following Active Record classes.

class TeamRecord extends TActiveRecord
{
    const TABLE='Teams';
    public $name;
    public $location;

    public $players=array();  // this declaration is no longer needed since v3.1.2

    //define the $player member having has many relationship with PlayerRecord
    public static $RELATIONS=array
    (
        'players' => array(self::HAS_MANY, 'PlayerRecord', 'team_name'),
    );

    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

The static $RELATIONS property of TeamRecord defines that the property $players has many PlayerRecords. Multiple relationships is permitted by defining each relationship with an entry in the $RELATIONS array where array key for the entry corresponds to the property name. In array(self::HAS_MANY, 'PlayerRecord'), the first element defines the relationship type, the valid types are self::HAS_MANY, self::HAS_ONE, self::BELONGS_TO and self::MANY_TO_MANY. The second element is a string 'PlayerRecord' that corresponds to the class name of the PlayerRecord class. And the third element 'team_name' refers to the foreign key column in the Players table that references to the Teams table.

Note: As described in the code comment above, since version 3.1.2, related properties no longer need to be explicitly declared. By default, they will be implicitly declared according to keys of the $RELATIONS array. A major benefit of declared related properties implicitly is that related objects can be automatically loaded in a lazy way. For example, assume we have a TeamRecord instance $team. We can access the players via $team->players, even if we have never issued fetch command for players. If $players is explicitly declared, we will have to use the with approach described in the following to fetch the player records.

The foreign key constraint of the Players table is used to determine the corresponding Teams table's corresponding key names. This is done automatically handled in Active Record by inspecting the Players and Teams table definitions.

Info: Since version 3.1.2, Active Record supports multiple foreign key references of the same table. Ambiguity between multiple foreign key references to the same table is resolved by providing the foreign key column name as the 3rd parameter in the relationship array. For example, both of the following foreign keys owner_id and reporter_id references to the same table defined in UserRecord.
class TicketRecord extends TActiveRecord
{
     public $owner_id;
     public $reporter_id;

     public $owner;     // this declaration is no longer needed since v3.1.2
     public $reporter;  // this declaration is no longer needed since v3.1.2

     public static $RELATION=array
     (
         'owner' => array(self::BELONGS_TO, 'UserRecord', 'owner_id'),
         'reporter' => array(self::BELONGS_TO, 'UserRecord', 'reporter_id'),
     );
}
This is applicable to relationships including BELONGS_TO, HAS_ONE and HAS_MANY. See section Self Referenced Association Tables for solving ambiguity of MANY_TO_MANY relationships.

The "has many" relationship is not fetched automatically when you use any of the Active Record finder methods. You will need to explicitly fetch the related objects as follows. In the code below, both lines are equivalent and the method names are case insensitive.

$team = TeamRecord::finder()->withPlayers()->findAll();
$team = TeamRecord::finder()->with_players()->findAll(); //equivalent

The method with_xxx() (where xxx is the relationship property name, in this case, players) fetches the corresponding PlayerRecords using a second query (not by using a join). The with_xxx() accepts the same arguments as other finder methods of TActiveRecord, e.g. with_players('age = ?', 35).

Note: It is essential to understand that the related objects are fetched using additional queries. The first query fetches the source object, e.g. the TeamRecord in the above example code. A second query is used to fetch the corresponding related PlayerRecord objects. The usage of the two query is similar to a single query using Left-Outer join with the exception that null results on the right table are not returned. The consequence of using two or more queries is that the aggregates and other join conditions are not feasible using Active Records. For queries outside the scope of Active Record the SqlMap Data Mapper may be considered.
Info: The above with approach also works with implicitly declared related properties (introduced in version 3.1.2). So what is the difference between the with approach and the lazy loading approach? Lazy loading means we issue an SQL query if a related object is initially accessed and not ready, while the with approach queries for the related objects once for all, no matter the related objects are accessed or not. The lazy loading approach is very convenient since we do not need to explictly load the related objects, while the with approach is more efficient if multiple records are returned, each with some related objects.

Has One Relationship

The entity relationship between Players and Profiles is one to one. That is, each PlayerRecord object has one ProfileRecord object (may be none or null). A has one relationship is nearly identical to a has many relationship with the exception that the related object is only one object (not a collection of objects).

Belongs To Relationship

The "has many" relationship in the above section defines a collection of foreign objects. In particular, we have that a TeamRecord has many (zero or more) PlayerRecord objects. We can also add a back pointer by adding a property in the PlayerRecord class that links back to the TeamRecord object, effectively making the association bidirectional. We say that the $team property in PlayerRecord class belongs to a TeamRecord object. The following code defines the complete PlayerRecord class with 3 relationships.

class PlayerRecord extends TActiveRecord
{
    const TABLE='Players';
    public $player_id;
    public $age;
    public $team_name;

    public $team;              // this declaration is no longer needed since v3.1.2
    public $skills=array();    // this declaration is no longer needed since v3.1.2
    public $profile;           // this declaration is no longer needed since v3.1.2

    public static $RELATIONS=array
    (
        'team' => array(self::BELONGS_TO, 'TeamRecord', 'team_name'),
        'skills' => array(self::MANY_TO_MANY, 'SkillRecord', 'Player_Skills'),
        'profile' => array(self::HAS_ONE, 'ProfileRecord', 'player_id'),
    );

    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

The static $RELATIONS property of PlayerRecord defines that the property $team belongs to a TeamRecord. The $RELATIONS array also defines two other relationships that we shall examine in later sections below. In array(self::BELONGS_TO, 'TeamRecord', 'team_name'), the first element defines the relationship type, in this case self::BELONGS_TO; the second element is a string 'TeamRecord' that corresponds to the class name of the TeamRecord class; and the third element 'team_name' refers to the foreign key of Players referencing Teams. A player object with the corresponding team object may be fetched as follows.

$players = PlayerRecord::finder()->with_team()->findAll();

The method with_xxx() (where xxx is the relationship property name, in this case, team) fetches the corresponding TeamRecords using a second query (not by using a join). The with_xxx() accepts the same arguments as other finder methods of TActiveRecord, e.g. with_team('location = ?', 'Madrid').

Tip: Additional relationships may be fetched by chaining the with_xxx() together as the following example demonstrates.
$players = PlayerRecord::finder()->with_team()->with_skills()->findAll();
Each with_xxx() method will execute an additional SQL query. Every with_xxx() accepts arguments similar to those in the findAll() method and is only applied to that particular relationship query.

The "belongs to" relationship of ProfileRecord class is defined similarly.

class ProfileRecord extends TActiveRecord
{
    const TABLE='Profiles';
    public $player_id;
    public $salary;

    public $player;  // this declaration is no longer needed since v3.1.2

    public static $RELATIONS=array
    (
        'player' => array(self::BELONGS_TO, 'PlayerRecord'),
    );

    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

In essence, there exists a "belongs to" relationship for objects corresponding to entities that has column which are foreign keys. In particular, we see that the Profiles table has a foreign key constraint on the column player_id that relates to the Players table's player_id column. Thus, the ProfileRecord object has a property ($player) that belongs to a PlayerRecord object. Similarly, the Players table has a foreign key constraint on the column team_name that relates to the Teams table's name column. Thus, the PlayerRecord object has a property ($team) that belongs to a TeamRecord object.

Parent Child Relationships

A parent child relationship can be defined using a combination of has many and belongs to relationship that refers to the same class. The following example shows a parent children relationship between "categories" and a "parent category".

class Category extends TActiveRecord
{
    public $cat_id;
    public $category_name;
    public $parent_cat_id;

    public $parent_category;            // this declaration is no longer needed since v3.1.2
    public $child_categories=array();   // this declaration is no longer needed since v3.1.2

    public static $RELATIONS=array
    (
        'parent_category' => array(self::BELONGS_TO, 'Category', 'parent_cat_id'),
        'child_categories' => array(self::HAS_MANY, 'Category', 'parent_cat_id'),
    );
}

Query Criteria for Related Objects

In the above, we show that an Active Record object can reference to its related objects by declaring a static class member $RELATIONS which specifies a list of relations. Each relation is specified as an array consisting of three elements: relation type, related AR class name, and the foreign key(s). For example, we use array(self::HAS_MANY, 'PlayerRecord', 'team_name') to specify the players in a team. There are two more optional elements that can be specified in this array: query condition (the fourth element) and parameters (the fifth element). They are used to control how to query for the related objects. For example, if we want to obtain the players ordered by their age, we can specify array(self::HAS_MANY, 'PlayerRecord', 'team_name', 'ORDER BY age'). If we want to obtain players whose age is smaller than 30, we could use array(self::HAS_MANY, 'PlayerRecord', 'team_name', 'age<:age', array(':age'=>30)). In general, these two additional elements are similar as the parameters passed to the find() method in AR.

Association Table Mapping

Objects can handle multivalued fields quite easily by using collections as field values. Relational databases don't have this feature and are constrained to single-valued fields only. When you're mapping a one-to-many association you can handle this using has many relationships, essentially using a foreign key for the single-valued end of the association. But a many-to-many association can't do this because there is no single-valued end to hold the foreign key.

The answer is the classic resolution that's been used by relational data people for decades: create an extra table (an association table) to record the relationship. The basic idea is using an association table to store the association. This table has only the foreign key IDs for the two tables that are linked together, it has one row for each pair of associated objects.

The association table has no corresponding in-memory object and its primary key is the compound of the two primary keys of the tables that are associated. In simple terms, to load data from the association table you perform two queries (in general, it may also be achieved using one query consisting of joins). Consider loading the SkillRecord collection for a list PlayerRecord objects. In this case, you do queries in two stages. The first stage queries the Players table to find all the rows of the players you want. The second stage finds the SkillRecord object for the related player ID for each row in the Player_Skills association table using an inner join.

The Prado Active Record design implements the two stage approach. For the Players-Skills M-N (many-to-many) entity relationship, we define a many-to-many relationship in the PlayerRecord class and in addition we may define a many-to-many relationship in the SkillRecord class as well. The following sample code defines the complete SkillRecord class with a many-to-many relationship with the PlayerRecord class. (See the PlayerRecord class definition above to the corresponding many-to-many relationship with the SkillRecord class.)

class SkillRecord extends TActiveRecord
{
    const TABLE='Skills';
    public $skill_id;
    public $name;

    public $players=array();    // this declaration is no longer needed since v3.1.2

    public static $RELATIONS=array
    (
        'players' => array(self::MANY_TO_MANY, 'PlayerRecord', 'Player_Skills'),
    );

    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

The static $RELATIONS property of SkillRecord defines that the property $players has many PlayerRecords via an association table 'Player_Skills'. In array(self::MANY_TO_MANY, 'PlayerRecord', 'Player_Skills'), the first element defines the relationship type, in this case self::MANY_TO_MANY, the second element is a string 'PlayerRecord' that corresponds to the class name of the PlayerRecord class, and the third element is the name of the association table name.

Note: Prior to version 3.1.2 (versions up to 3.1.1), the many-to-many relationship was defined using self::HAS_MANY. For version 3.1.2 onwards, this must be changed to self::MANY_TO_MANY. This can be done by searching for the HAS_MANY in your source code and carfully changing the appropriate definitions.

A list of player objects with the corresponding collection of skill objects may be fetched as follows.

$players = PlayerRecord::finder()->withSkills()->findAll();

The method with_xxx() (where xxx is the relationship property name, in this case, Skill) fetches the corresponding SkillRecords using a second query (not by using a join). The with_xxx() accepts the same arguments as other finder methods of TActiveRecord.

Self Referenced Association Tables

For self referenced association tables, that is, the association points to the same table. For example, consider the items table with M-N related item via the related_items association table. The syntax in the following example is valid for a PostgreSQL database. For other database, consult their respective documentation for defining the foreign key constraints.

CREATE TABLE items
(
  "item_id" SERIAL,
  "name" VARCHAR(128) NOT NULL,
  PRIMARY KEY("item_id")
);
CREATE TABLE "related_items"
(
  "item_id" INTEGER NOT NULL,
  "related_item_id" INTEGER NOT NULL,
  CONSTRAINT "related_items_pkey" PRIMARY KEY("item_id", "related_item_id"),
  CONSTRAINT "related_items_item_id_fkey" FOREIGN KEY ("item_id")
    REFERENCES "items"("item_id")
    ON DELETE CASCADE
    ON UPDATE NO ACTION
    NOT DEFERRABLE,
  CONSTRAINT "related_items_related_item_id_fkey" FOREIGN KEY ("related_item_id")
    REFERENCES "items"("item_id")
    ON DELETE CASCADE
    ON UPDATE NO ACTION
    NOT DEFERRABLE
);

The association table name in third element of the relationship array may contain the foreign table column names. The columns defined in the association table must also be defined in the record class (e.g. the $related_item_id property corresponds to the related_item_id column in the related_items table).

class Item extends TActiveRecord
{
    const TABLE="items";
    public $item_id;
    public $details;

    //additional foreign item id defined in the association table
    public $related_item_id;
    public $related_items=array();    // this declaration is no longer needed since v3.1.2

    public static $RELATIONS=array
    (
        'related_items' => array(self::MANY_TO_MANY,
            'Item', 'related_items.related_item_id'),
    );
}
Tip: Compound keys in the foreign table can be specified as comma separated values between brackets. E.g. 'related_items.(id1,id2)'.

Lazy Loading Related Objects

Note: Implicitly declared related properties introduced in version 3.1.2 automatically have lazy loading feature. Therefore, the lazy loading technique described in the following is no longer needed in most of the cases, unless you want to manipulate the related objects through getter/setter.

Using the with_xxx() methods will load the relationship record on demand. Retrieving the related record using lazy loading (that is, only when those related objects are accessed) can be achieved by using a feature of the TComponent that provides accessor methods. In particular, we define a pair of getter and setter methods where the getter method will retrieve the relationship conditionally. The following example illustrates that the PlayerRecord can retrieve its $skills foreign objects conditionally.

class PlayerRecord extends BaseFkRecord
{
    //... other properties and methods as before

    private $_skills; //change to private and default as null

    public function getSkills()
    {
        if($this->_skills===null && $this->player_id !==null)
        {
            //lazy load the skill records
            $this->setSkills($this->withSkills()->findByPk($this->player_id)->skills);
        }
        else if($this->_skills===null)
        {
            //create new TList;
            $this->setSkills(new TList());
        }

        return $this->_skills;
    }

    public function setSkills($value)
    {
        $this->_skills = $value instanceof TList ? $value : new TList($value);
    }
}

We first need to change the $skills=array() declaration to a private property $_skills (notice the underscore) and set it to null instead. This allows us to define the skills property using getter/setter methods (see Components for details). The getSkills() getter method for the skills property will lazy load the corresponding skills foreign record when it is used as follows. Notice that we only do a lazy load when its $player_id is not null (that is, when the record is already fetched from the database or player id was already set).

$player = PlayerRecord::finder()->findByPk(1);
var_dump($player->skills); //lazy load it on first access
var_dump($player->skills[0]); //already loaded skills property
$player->skills[] = new SkillRecord(); //add skill

The setSkills() ensures that the skills property will always be a TList. Using a TList allows us to set the elements of the skills property as if they were arrays. E.g. $player->skills[] = new SkillRecord(). If array was used, a PHP error will be thrown.

Column Mapping

Since v3.1.1, Active Record starts to support column mapping. Column mapping allows developers to address columns in Active Record using a more consistent naming convention. In particular, using column mapping, one can access a column using whatever name he likes, rather than limited by the name defined in the database schema.

To use column mapping, declare a static array named COLUMN_MAPPING in the Active Record class. The keys of the array are column names (called physical column names) as defined in the database schema, while the values are corresponding property names (called logical column names) defined in the Active Record class. The property names can be either public class member variable names or component property names defined via getters/setters. If a physical column name happens to be the same as the logical column name, they do not need to be listed in COLUMN_MAPPING.

class UserRecord extends TActiveRecord
{
    const TABLE='users';
    public static $COLUMN_MAPPING=array
    (
        'user_id'=>'id',
        'email_address'=>'email',
        'first_name'=>'firstName',
        'last_name'=>'lastName',
    );
    public $id;
    public $username; // the physical and logical column names are the same
    public $email;
    public $firstName;
    public $lastName;
    //....
}

With the above column mapping, we can address first_name using $userRecord->firstName instead of $userRecord->first_name. This helps separation of logic and model.

References

  • Fowler et. al. Patterns of Enterprise Application Architecture, Addison Wesley, 2002.
  • B. Venners with B. Eckel. Inappropriate Abstractions - A Conversation with Anders Hejlsberg, Part VI. Artima Developer, 2003.
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Active Record Scaffold Views

Available from Prado versions 3.1b onwards.

Active Record classes can be used together with TScaffoldListView and TScaffoldEditView ( TScaffoldView links both TScaffoldListView and TScaffoldEditView) to create simple Create/Read/Update/Delete (CRUD) web applications.

The scaffold views are intended to assist in prototyping web application, they are not designed to be as customiziable as more complex components such as TDataGrid. The scaffold views provide the following builtin functionality:

  • Listing of all active record items.
  • Searching records.
  • Paging and sorting.
  • Deleting an item.
  • Inserting a new item.
  • Updating an existing item.
  • Validates required fields and basic data types.
  • Presents specialized controls such as date pickers.

Scaffold views are dependent on Active Records and currently supports the following databases: Mysql, Sqlite and Postgres SQL. Support for other databases can be considered when there are sufficient demand.

Setting up a Scaffold View

To use the scaffold view, we first define an Active Record class that represents a table or view in the database. Consider the following Active Record class that corresponds to the users table as defined in the Active Record quickstart page.

class UserRecord extends TActiveRecord
{
    const TABLE='users';

    public $username;
    public $email;
}

The scaffold view classes are in the System.Data.ActiveRecord.Scaffold.* namespace. This namespace can be "imported" in the Application Configuration using the application.xml file or through the php code using the Prado::using() method. To start using the TScaffoldView simply set the RecordClass property value equal to an Active Record class name.

<com:TScaffoldView RecordClass="UserRecord" />

The above code will list the current records in the users table. Each record can be edited by clicking on the "edit" button and deleted by clicking on the "delete" button. A new record can be added by clicking on the "Add new record" button, enter some data (notice the automatic validation of required fields and data types), and click the "save" button. Specifying search terms in the search textbox to find particular records. Finally, the record list can be sorted for each column by changing the sorting column and order.

The TScaffoldView is a template control composed of other scaffold controls. The following properties gives access to these composite controls.

  • ListView -- the TScaffoldListView displaying the record list.
  • EditView -- the TScaffoldEditView that renders the inputs for editing and adding records.
  • SearchControl -- the TScaffoldSearch responsible to the search user interface.

All these composite controls can be customized as we shall see below.

TScaffoldListView

A list of Active Records can be displayed using the TScaffoldListView with the following useful properties.

  • Header -- a TRepeater displaying the Active Record property/field names.
  • Sort -- a TDropDownList displaying the combination of properties and its possible ordering.
  • Pager -- a TPager control displaying the links and/or buttons that navigate to different pages in the Active Record data.
  • List -- a TRepeater that renders a row of Active Record data.

Custom rendering of the each Active Record can be achieved by specifying the ItemTemplate and/or AlternatingItemTemplate property of the List repeater. The TScaffoldListView will listen for two command events named "delete" and "edit". A "delete" command will delete a the record for the row where the "delete" command originates. An "edit" command will push the record data to be edited by a TScaffoldEditView with ID specified by the EditViewID property. The following example lists the usernames only with bold formatting.

<com:TScaffoldListView RecordClass="UserRecord" >
    <prop:List.ItemTemplate>
        <strong><%# $this->Data->username %></strong>
    </prop:List.ItemTemplate>
</com:TScaffoldListView>
Info: For the TScaffoldView the list view can be accessed throught the ListView property of a TScaffoldView. Thus, the subproperty ListView.List.ItemTemplate on TScaffoldView is equivalent to the List.ItemTemplate subproperty of TScaffoldListView in the above example.

The SearchCondition property and SearchParameters property (takes array values) can be specified to customize the records to be shown. The SearchCondition will be used as the Condition property of TActiveRecordCriteria and the SearchParameters property corresponds to Parameters property of TActiveRecordCriteria.

TScaffoldEditView

<com:TScaffoldEditView RecordPk="user1" RecordClass="UserRecord" />

Combining list + edit views

<com:TScaffoldEditView ID="edit_view" RecordClass="UserRecord" />
<com:TScaffoldListView EditViewID="edit_view" RecordClass="UserRecord" />

Customizing the TScaffoldView

<com:TScaffoldView RecordClass="UserRecord" >
    <prop:ListView.List.ItemTemplate>
        <%# $this->DataItem->username %>
        <com:TLinkButton Text="Edit" CommandName="edit" />
    </prop:ListView.List.ItemTemplate>
</com:TScaffoldView/>
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Data Mapper

Available from Prado versions 3.1a onwards.

Data Mappers moves data between objects and a database while keeping them independent of each other and the mapper itself. If you started with Active Records, you may eventually faced with more complex business objects as your project progresses. When you build an object model with a lot of business logic it's valuable to use these mechanisms to better organize the data and the behavior that goes with it. Doing so leads to variant schemas; that is, the object schema and the relational schema don't match up.

The Data Mapper separates the in-memory objects from the database. Its responsibility is to transfer data between the two and also to isolate them from each other. With Data Mapper the in-memory objects needn't know even that there's a database present; they need no SQL interface code, and certainly no knowledge of the database schema. (The database schema is always ignorant of the objects that use it.)

When to Use It

The primary occasion for using Data Mapper is when you want the database schema and the object model to evolve independently. Data Mapper's primary benefit is that when working on the business (or domain) objects you can ignore the database, both in design and in the build and testing process. The domain objects have no idea what the database structure is, because all the correspondence is done by the mappers.

This helps you in the code because you can understand and work with the domain objects without having to understand how they're stored in the database. You can modify the business models or the database without having to alter either. With complicated mappings, particularly those involving existing databases, this is very valuable.

The price, of course, is the extra layer that you don't get with Active Record, so the test for using these patterns is the complexity of the business logic. If you have fairly simple business logic, an Active Record will probably work. For more complicated logic a Data Mapper may be more suitable.

SqlMap Data Mapper

The SqlMap DataMapper framework makes it easier to use a database with a PHP application. SqlMap DataMapper couples objects with stored procedures or SQL statements using a XML descriptor. Simplicity is the biggest advantage of the SqlMap DataMapper over object relational mapping tools. To use SqlMap DataMapper you rely on your own objects, XML, and SQL. There is little to learn that you don't already know. With SqlMap DataMapper you have the full power of both SQL and stored procedures at your fingertip

SqlMap Data Mapper Overview Here's a high level description of the work flow illustrated in the figure above. Provide a parameter, either as an object or a primitive type. The parameter can be used to set runtime values in your SQL statement or stored procedure. If a runtime value is not needed, the parameter can be omitted.

Execute the mapping by passing the parameter and the name you gave the statement or procedure in your XML descriptor. This step is where the magic happens. The framework will prepare the SQL statement or stored procedure, set any runtime values using your parameter, execute the procedure or statement, and return the result.

In the case of an update, the number of rows affected is returned. In the case of a query, a single object, or a collection of objects is returned. Like the parameter, the result object, or collection of objects, can be a plain-old object or a primitive PHP type.

Setting up a database connection and initializing the SqlMap

A database connection for SqlMap can be set as follows. See Establishing Database Connection for futher details regarding creation of database connection in general.

//create a connection and give it to the SqlMap manager.
$dsn = 'pgsql:host=localhost;dbname=test'; //Postgres SQL
$conn = new TDbConnection($dsn, 'dbuser','dbpass');
$manager = new TSqlMapManager($conn);
$manager->configureXml('my-sqlmap.xml');
$sqlmap = $manager->getSqlMapGateway();

The TSqlMapManager is responsible for setting up the database connection and configuring the SqlMap with given XML file(s). The configureXml() method accepts a string that points to a SqlMap XML configuration file. Once configured, call the getSqlMapGateway() method to obtain an instance of the SqlMap gateway interface (use this object to insert/delete/find records).

SqlMap database connection can also be configured using a <module> tag in the application.xml or config.xml as follows.

<modules>
  <module id="my-sqlmap" class="System.Data.SqlMap.TSqlMapConfig"
        EnableCache="true" ConfigFile="my-sqlmap.xml" >
    <database ConnectionString="pgsql:host=localhost;dbname=test"
        Username="dbuser" Password="dbpass" />
  </module>
</modules>

The ConfigFile attribute should point to a SqlMap configuration file (to be detailed later) either using absolute path, relative path or the Prado's namespace dot notation path (must omit the ".xml" extension).

Tip: The EnableCache attribute when set to "true" will cache the parsed configuration. You must clear or disable the cache if you make changes to your configuration file. A cache module must also be defined for the cache to function.

To obtain the SqlMap gateway interface from the <module> configuration, simply do, for example,

class MyPage extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        $sqlmap = $this->Application->Modules['my-sqlmap']->Client;
        $sqlmap->queryForObject(...); //query for some object
    }
}

A quick example

Let us consider the following "users" table that contains two columns named "username" and "email", where "username" is also the primary key.

CREATE TABLE users
(
    username VARCHAR( 20 ) NOT NULL ,
    email VARCHAR( 200 ) ,
    PRIMARY KEY ( username )
);

Next we define our plain User class as follows. Notice that the User is very simple.

class User
{
    public $username;
    public $email;
}

Next, we need to define a SqlMap XMl configuration file, lets name the file as my-sqlmap.xml

<?xml version="1.0" encoding="utf-8" ?>
<sqlMapConfig>
    <select id="SelectUsers" resultClass="User">
        SELECT username, email FROM users
    </select>
</sqlMapConfig>

The <select> tag returns defines an SQL statement. The id attribute will be used as the identifier for the query. The resultClass attribute value is the name of the class the the objects to be returned. We can now query the objects as follows:

//assume that $sqlmap is an TSqlMapGateway instance
$userList = $sqlmap->queryForList("SelectUsers");

//Or just one, if that's all you need:
$user = $sqlmap->queryForObject("SelectUsers");

The above example shows demonstrates only a fraction of the capabilities of the SqlMap Data Mapper. Further details can be found in the SqlMap Manual.

Combining SqlMap with Active Records

The above example may seem trival and it also seems that there is alot work just to retrieve some data. However, notice that the User class is totally unware of been stored in the database, and the database is unware of the User class.

One of advantages of SqlMap is the ability to map complex object relationship, collections from an existing database. On the other hand, Active Record provide a very simple way to interact with the underlying database but unable to do more complicated relationship or collections. A good compromise is to use SqlMap to retrieve complicated relationships and collections as Active Record objects and then using these Active Records to do the updates, inserts and deletes.

Continuing with the previous example, we change the definition of the User class to become an Active Record.

class UserRecord extends TActiveRecord
{
    const TABLE='users'; //table name

    public $username; //the column named "username" in the "users" table
    public $email;

    /**
     * @return TActiveRecord active record finder instance
     */
    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

We also need to change the definition of the SqlMap XML configuration. We just need to change the value of resultClass attribute to UserRecord.

<?xml version="1.0" encoding="utf-8" ?>
<sqlMapConfig>
    <select id="SelectUsers" resultClass="UserRecord">
        SELECT username, email FROM users
    </select>
</sqlMapConfig>

The PHP code for retrieving the users remains the same, but SqlMap returns Active Records instead, and we can take advantage of the Active Record methods.

//assume that $sqlmap is an TSqlMapGateway instance
$user = $sqlmap->queryForObject("SelectUsers");

$user->email = 'test@example.com'; //change data
$user->save(); //save it using Active Record

References

  • Fowler et. al. Patterns of Enterprise Application Architecture, Addison Wesley, 2002.
  • iBatis Team. iBatis Data Mapper, http://ibatis.apache.org.
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Collections

Collection is a basic data structure in programming. In traditional PHP programming, array is used widely to represent collection data structure. A PHP array is a mix of cardinal-indexed array and hash table.

To enable object-oriented manipulation of collections, PRADO provides a set of powerful collection classes. Among them, the TList and TMap are the most fundamental and usually serve as the base classes for other collection classes. Since many PRADO components have properties that are of collection type, it is very important for developers to master the usage of PRADO collection classes.

Using TList

A TList object represents a cardinal-indexed array, i.e., an array (object) with the index 0, 1, 2, ...

TList may be used like a PHP array. For example,

$list=new TList; // create a list object
...
$item=$list[$index];  // read the item at the specified index
$list[]=$item;  // append the item at the end
$list[$index]=$item; // replace the item at the specified index
unset($list[$index]); // remove the item at $index
if(isset($list[$index])) // test if the list has an item at $index
foreach($list as $index=>$item) // traverse each item in the list

To obtain the number of items in the list, use the Count property. Note, do not use count($list), as it always returns 1.

In addition, TList implements a few commonly used convenient methods for manipulating the data in a list. These include

  • clear(): removes all items in the list.
  • contains(): tests if the list contains the specified item.
  • indexOf(): obtains the zero-based index of the specified item in the list.
  • toArray(): returns an array representation of the items in the list.
  • copyFrom(): populates the list with data from an array or traversable object (including TList). Existing items will be removed first.
  • mergeWith(): appends the list with data from an array or traversable object (including TList).

Using TList-based component properties

As aforementioned, many PRADO component properties are based on TList or TList-derived collection classes. These properties all share the above usages.

For example, TControl (the base class for all PRADO controls) has a property called Controls which represents the collection of child controls. The type of Controls is TControlCollection which extends TList. Therefore, to append a new child control, we can use the following,

$control->Controls[]=$newControl;

To traverse through the child controls, we can use,

foreach($control->Controls as $childControl) ...

Another example is the Items property, available in list controls, TRepeater, TDataList and TDataGrid. In these controls, the ancestor class of Items is TList.

Extending TList

Often, we want to extend TList to perform additional operations for each addition or removal of an item. The only methods that the child class needs to override are insertAt() and removeAt(). For example, to ensure the list only contains items that are of TControl type, we can override insertAt() as follows,

public function insertAt($index,$item)
{
    if($item instanceof TControl)
        parent::insertAt($index,$item)
    else
        throw new Exception('TControl required.');
}

Using TMap

A TMap object represents a hash table (or we say string-indexed array).

Similar to TList, TMap may be used like an array,

$map=new TMap; // create a map object
...
$map[$key]=$value; // add a key-value pair
unset($map[$key]); // remove the value with the specified key
if(isset($map[$key])) // if the map contains the key
foreach($map as $key=>$value) // traverse the items in the map

The Count property gives the number of items in the map while the Keys property returns a list of keys used in the map.

The following methods are provided by TMap for convenience,

  • clear(): removes all items in the map.
  • contains(): tests if the map contains the specified key.
  • toArray(): returns an array representation of the items in the map.
  • copyFrom(): populates the map with data from an array or traversable object (including TMap). Existing items will be removed first.
  • mergeWith(): appends the map with data from an array or traversable object (including TMap).

Using of TAttributeCollection

TAttributeCollection is a special class extending from TMap. It is mainly used by the Attributes property of TControl.

Besides the normal functionalities provided by TMap, TAttributeCollection allows you to get and set collection items like getting and setting properties. For example,

$collection->Label='value'; // equivalent to: $collection['Label']='value';
echo $collection->Label; // equivalent to: echo $collection['Label'];

Note, in the above $collection does NOT have a Label property.

Unlike TMap, keys in TAttributeCollection are case-insensitive. Therefore, $collection->Label is equivalent to $collection->LABEL.

Because of the above new features, when dealing with the Attributes property of controls, we may take advantage of the subproperty concept and configure control attribute values in a template as follows,

<com:TButton Attributes.onclick="if(!confirm('Are you sure?')) return false;" .../>

which adds an attribute named onclick to the TButton control.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Authentication and Authorization

Authentication is a process of verifying whether someone is who he claims he is. It usually involves a username and a password, but may include any other methods of demonstrating identity, such as a smart card, fingerprints, etc.

Authorization is finding out if the person, once identified, is permitted to manipulate specific resources. This is usually determined by finding out if that person is of a particular role that has access to the resources.

How PRADO Auth Framework Works

PRADO provides an extensible authentication/authorization framework. As described in application lifecycles, TApplication reserves several lifecycles for modules responsible for authentication and authorization. PRADO provides the TAuthManager module for such purposes. Developers can plug in their own auth modules easily. TAuthManager is designed to be used together with TUserManager module, which implements a read-only user database.

When a page request occurs, TAuthManager will try to restore user information from session. If no user information is found, the user is considered as an anonymous or guest user. To facilitate user identity verification, TAuthManager provides two commonly used methods: login() and logout(). A user is logged in (verified) if his username and password entries match a record in the user database managed by TUserManager. A user is logged out if his user information is cleared from session and he needs to re-login if he makes new page requests.

During Authorization application lifecycle, which occurs after Authentication lifecycle, TAuthManager will verify if the current user has access to the requested page according to a set of authorization rules. The authorization is role-based, i.e., a user has access to a page if 1) the page explicitly states that the user has access; 2) or the user is of a particular role that has access to the page. If the user does not have access to the page, TAuthManager will redirect user browser to the login page which is specified by LoginPage property.

Using PRADO Auth Framework

To enable PRADO auth framework, add the TAuthManager module and TUserManager module to application configuration,

<service id="page" class="TPageService">
  <modules>
    <module id="auth" class="System.Security.TAuthManager"
               UserManager="users" LoginPage="UserLogin" />
    <module id="users" class="System.Security.TUserManager"
               PasswordMode="Clear">
      <user name="demo" password="demo" />
      <user name="admin" password="admin" />
    </module>
  </modules>
</service>

In the above, the UserManager property of TAuthManager is set to the users module which is TUserManager. Developers may replace it with a different user management module that is derived from TUserManager.

Authorization rules for pages are specified in page configurations as follows,

<authorization>
    <allow pages="PageID1,PageID2"
              users="User1,User2"
              roles="Role1" />
    <deny pages="PageID1,PageID2"
              users="?"
              verb="post" />
</authorization>

An authorization rule can be either an allow rule or a deny rule. Each rule consists of four optional properties:

  • pages - list of comma-separated page names that this rule applies to. If empty, not set or wildcard '*', this rule will apply to all pages under the current directory and all its subdirectories recursively.
  • users - list of comma-separated user names that this rule applies to. If empty, not set or wildcard '*', this rule will apply to all users including anonymous/guest user. A character ? refers to anonymous/guest user. And a character @ refers to authenticated users (available since v3.1).
  • roles - list of comma-separated user roles that this rule applies to. If empty, not set or wildcard '*', this rule will apply to all user roles.
  • verb - page access method that this rule applies to. It can be either get or post. If empty, not set or wildcard '*', the rule will apply to both methods.

When a page request is being processed, a list of authorization rules may be available. However, only the first effective rule matching the current user will render the authorization result.

  • Rules are ordered bottom-up, i.e., the rules contained in the configuration of current page folder go first. Rules in configurations of parent page folders go after.
  • A rule is effective if the current page is in the listed pages of the rule AND the current user action (get or post) is in the listed actions.
  • A rule matching occurs if the current user name is in the listed user names of an effective rule OR if the user's role is in the listed roles of that rule.
  • If no rule matches, the user is authorized.

In the above example, anonymous users will be denied from posting to PageID1 and PageID2, while User1 and User2 and all users of role Role1 can access the two pages (in both get and post methods).

Available from Prado versions 3.1.1 onwards.

Since version 3.1.1, the pages attribute in the authorization rules can take relative page paths with wildcard '*'. For example, pages="admin.Home" refers to the Home page under the admin directory, and pages="admin.*" would refer to all pages under the admin directory and subdirectories.

Also introduced in version 3.1.1 are IP rules. They are specified by a new attribute ips in authorization rules. The IP rules are used to determine if an authorization rule aplies to an end-user according to his IP address. One can list a few IPs together, separated by comma ','. Wildcard '*' can be used in the rules. For example, ips="192.168.0.2, 192.168.1.*" means the rule applies to users whose IP address is 192.168.0.2 or 192.168.1.*. The latter matches any host in the subnet 192.168.1. If the attribute 'ips' is empty, not set or wildcard '*', the corresponding rule will apply to requests coming from any host address.

Using TUserManager

As aforementioned, TUserManager implements a read-only user database. The user information are specified in either application configuration or an external XML file.

We have seen in the above example that two users are specified in the application configuration. Complete syntax of specifying the user and role information is as follows,

<user name="demo" password="demo" roles="demo,admin" />
<role name="admin" users="demo,demo2" />

where the roles attribute in user element is optional. User roles can be specified in either the user element or in a separate role element.

Using TDbUserManager

TDbUserManager is introduced in v3.1.0. Its main purpose is to simplify the task of managing user accounts that are stored in a database. It requires developers to write a user class that represents the necessary information for a user account. The user class must extend from TDbUser.

To use TDbUserManager, configure it in the application configuration like following:

<module id="db"
     class="System.Data.TDataSourceConfig" ..../>
<module id="users"
     class="System.Security.TDbUserManager"
     UserClass="Path.To.MyUserClass"
     ConnectionID="db" />
<module id="auth"
     class="System.Security.TAuthManager"
     UserManager="users" LoginPage="Path.To.LoginPage" />

In the above, UserClass specifies what class will be used to create user instance. The class must extend from TDbUser. ConnectionID refers to the ID of a TDataSourceConfig module which specifies how to establish database connection to retrieve user information.

The user class has to implement the two abstract methods in TDbUser: validateUser() and createUser(). Since user account information is stored in a database, the user class may make use of its DbConnection property to reach the database.

Available from Prado versions 3.1.1 onwards.

Since 3.1.1, TAuthManager provides support to allow remembering login by setting AllowAutoLogin to true. Accordingly, TDbUser adds two methods to facilitate the implementation of this feature. In particular, two new methods are introduced: createUserFromCookie() and saveUserToCookie(). Developers should implement these two methods if remembering login is needed. Below is a sample implementation:

public function createUserFromCookie($cookie)
{
    if(($data=$cookie->Value)!=='')
    {
        $application=Prado::getApplication();
        if(($data=$application->SecurityManager->validateData($data))!==false)
        {
            $data=unserialize($data);
            if(is_array($data) && count($data)===3)
            {
                list($username,$address,$token)=$data;
                $sql='SELECT passcode FROM user WHERE LOWER(username)=:username';
                $command=$this->DbConnection->createCommand($sql);
                $command->bindValue(':username',strtolower($username));
                if($token===$command->queryScalar() && $token!==false && $address=$application->Request->UserHostAddress)
                    return $this->createUser($username);
            }
        }
    }
    return null;
}

public function saveUserToCookie($cookie)
{
    $application=Prado::getApplication();
    $username=strtolower($this->Name);
    $address=$application->Request->UserHostAddress;
    $sql='SELECT passcode FROM user WHERE LOWER(username)=:username';
    $command=$this->DbConnection->createCommand($sql);
    $command->bindValue(':username',strtolower($username));
    $token=$command->queryScalar();
    $data=array($username,$address,$token);
    $data=serialize($data);
    $data=$application->SecurityManager->hashData($data);
    $cookie->setValue($data);
}
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Security

Viewstate Protection

Viewstate lies at the heart of PRADO. Viewstate represents data that can be used to restore pages to the state that is last seen by end users before making the current request. By default, PRADO uses hidden fields to store viewstate information.

It is extremely important to ensure that viewstate is not tampered by end users. Without protection, malicious users may inject harmful code into viewstate and unwanted instructions may be performed when page state is being restored on server side.

To prevent viewstate from being tampered, PRADO enforces viewstate HMAC (Keyed-Hashing for Message Authentication) check before restoring viewstate. Such a check can detect if the viewstate has been tampered or not by end users. Should the viewstate is modified, PRADO will stop restoring the viewstate and return an error message.

HMAC check requires a private key that should be secret to end users. Developers can either manually specify a key or let PRADO automatically generate a key. Manually specified key is useful when the application runs on a server farm. To do so, configure TSecurityManager in application configuration,

<modules>
    <module id="security"
        class="TSecurityManager"
        ValidationKey="my private key" />
</modules>

HMAC check does not prevent end users from reading the viewstate content. An added security measure is to encrypt the viewstate information so that end users cannot decipher it. To enable viewstate encryption, set the EnableStateEncryption of pages to true. This can be done in page configurations or in page code. Note, encrypting viewstate may degrade the application performance. A better strategy is to store viewstate on the server side, rather than the default hidden field.

Cross Site Scripting Prevention

Cross site scripting (also known as XSS) occurs when a web application gathers malicious data from a user. Often attackers will inject JavaScript, VBScript, ActiveX, HTML, or Flash into a vulnerable application to fool other application users and gather data from them. For example, a poorly design forum system may display user input in forum posts without any checking. An attacker can then inject a piece of malicious JavaScript code into a post so that when other users read this post, the JavaScript runs unexpectedly on their computers.

One of the most important measures to prevent XSS attacks is to check user input before displaying them. One can do HTML-encoding with the user input to achieve this goal. However, in some situations, HTML-encoding may not be preferable because it disables all HTML tags.

PRADO incorporates the work of SafeHTML and provides developers with a useful component called TSafeHtml. By enclosing content within a TSafeHtml component tag, the enclosed content are ensured to be safe to end users. In addition, the commonly used TTextBox has a SafeText property which contains user input that are ensured to be safe if displayed directly to end users.

With the broad use of active controls and more generally of AJAX-enabled controls using Javascript to transfer data between the server and the client, it's common to see attackers target javascript itself as a vector to inject malicious code.

Imagine a validator that uses an ajax callback to check user input from a textbox and returns an error message including the user input, example: 'The email address is not valid: test@example.com'. In such a situation user input must be checked to avoid possible injection.

The classic xss check involves checking for html tags inside the message and encode them; but since the message gets sent back to the client inside a javascript block, it needs to be encoded again to avoid any possible javascript escaping. By default PRADO encodes all variables sent clientside inside a javascript block to avoid any user-generated input from injecting malicious javascript code.

Cookie Attack Prevention

Protecting cookies from being attacked is of extreme important, as session IDs are commonly stored in cookies. If one gets hold of a session ID, he essentially owns all relevant session information.

There are several countermeasures to prevent cookies from being attacked.

  • An application can use SSL to create a secure communication channel and only pass the authentication cookie over an HTTPS connection. Attackers are thus unable to decipher the contents in the transferred cookies.
  • Expire sessions appropriately, including all cookies and session tokens, to reduce the likelihood of being attacked.
  • Prevent cross-site scripting (XSS) which causes arbitrary code to run in a user's browser and expose his cookies.
  • Validate cookie data and detect if they are altered.

PRADO implements a cookie validation scheme that prevents cookies from being modified. In particular, it does HMAC check for the cookie values if cookie validation is enable.

Cookie validation is disabled by default. To enable it, configure the THttpRequest module as follows,

<modules>
  <module id="request" class="THttpRequest" EnableCookieValidation="true" />
</modules>

To make use of cookie validation scheme provided by PRADO, you also need to retrieve cookies through the Cookies collection of THttpRequest by using the following PHP statements,

foreach($this->Request->Cookies as $cookie)
    // $cookie is of type THttpCookie

To send cookie data encoded with validation information, create new THttpCookie objects and add them to the Cookies collection of THttpResponse,

$cookie=new THttpCookie($name,$value);
$this->Response->Cookies[]=$cookie;
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Assets

Assets are resource files (such as images, sounds, videos, CSS stylesheets, javascripts, etc.) that belong to specific component classes. Assets are meant to be provided to Web users. For better reusability and easier deployment of the corresponding component classes, assets should reside together with the component class files . For example, a toggle button may use two images, stored in file down.gif and up.gif, to show different toggle states. If we require the image files be stored under images directory under the Web server document root, it would be inconvenient for the users of the toggle button component, because each time they develop or deploy a new application, they would have to manually copy the image files to that specific directory. To eliminate this requirement, a directory relative to the component class file should be used for storing the image files. A common strategy is to use the directory containing the component class file to store the asset files.

Because directories containing component class files are normally inaccessible by Web users, PRADO implements an asset publishing scheme to make available the assets to Web users. An asset, after being published, will have a URL by which Web users can retrieve the asset file.

Asset Publishing

PRADO provides several methods for publishing assets or directories containing assets:

  • In a template file, you can use asset tags to publish assets and obtain their URLs. Note, the assets must be relative to the directory containing the template file.
  • In PHP code, you can call $object->publishAsset($assetPath) to publish an asset and obtain its URL. Here, $object refers to an instance of TApplicationComponent or derived class, and $assetPath is a file or directory relative to the directory containing the class file.
  • If you want to publish an arbitrary asset, you need to call TAssetManager::publishFilePath($path).

BE AWARE: Be very careful with assets publishing, because it gives Web users access to files that were previously inaccessible to them. Make sure that you do not publish files that do not want Web users to see.

Customization

Asset publishing is managed by the System.Web.TAssetManager module. By default, all published asset files are stored under the [AppEntryPath]/assets directory, where AppEntryPath refers to the directory containing the application entry script. Make sure the assets directory is writable by the Web server process. You may change this directory to another by configuring the BasePath and BaseUrl properties of the TAssetManager module in application configuration,

<modules>
    <module id="asset"
            class="System.Web.TAssetManager"
            BasePath="Web.images"
            BaseUrl="images" />
</modules>

Performance

PRADO uses caching techniques to ensure the efficiency of asset publishing. Publishing an asset essentially requires file copy operation, which is expensive. To save unnecessary file copy operations, System.Web.TAssetManager only publishes an asset when it has a newer file modification time than the published file. When an application runs under the Performance mode, such timestamp checking is also omitted.

ADVISORY: Do not overuse asset publishing. The asset concept is mainly used to help better reuse and redistribute component classes. Normally, you should not use asset publishing for resources that are not bound to any component in an application. For example, you should not use asset publishing for images that are mainly used as design elements (e.g. logos, background images, etc.) Let Web server to directly serve these images will help improve the performance of your application.

A Toggle Button Example

We now use the toggle button example to explain the usage of assets. The control uses two image files up.gif and down.gif, which are stored under the directory containing the control class file. When the button is in Up state, we would like to show the up.gif image. This can be done as follows,

class ToggleButton extends TWebControl {
    ...
    protected function addAttributesToRender($writer) {
        ...
        if($this->getState()==='Up') {
            $url=$this->getAsset('up.gif');
            $writer->addAttribute('src',$url);
        }
        ...
    }
    ...
}

In the above, the call $this->getAsset('up.gif') will publish the up.gif image file and return a URL for the published image file. The URL is then rendered as the src attribute of the HTML image tag.

To redistribute ToggleButton, simply pack together the class file and the image files. Users of ToggleButton merely need to unpack the file, and they can use it right away, without worrying about where to copy the image files to.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Master and Content

Pages in a Web application often share common portions. For example, all pages of this tutorial application share the same header and footer portions. If we repeatedly put header and footer in every page source file, it will be a maintenance headache if in future we want to something in the header or footer. To solve this problem, PRADO introduces the concept of master and content. It is essentially a decorator pattern, with content being decorated by master.

Master and content only apply to template controls (controls extending TTemplateControl or its child classes). A template control can have at most one master control and one or several contents (each represented by a TContent control). Contents will be inserted into the master control at places reserved by TContentPlaceHolder controls. And the presentation of the template control is that of the master control with TContentPlaceHolder replaced by TContent.

For example, assume a template control has the following template:

<%@ MasterClass="MasterControl" %>
<com:TContent ID="A" >
content A
</com:TContent >
<com:TContent ID="B" >
content B
</com:TContent >
<com:TContent ID="B" >
content B
</com:TContent >

which uses MasterControl as its master control. The master control has the following template,

other stuff
<com:TContentPlaceHolder ID="A" />
other stuff
<com:TContentPlaceHolder ID="B" />
other stuff
<com:TContentPlaceHolder ID="C" />
other stuff

Then, the contents are inserted into the master control according to the following diagram, while the resulting parent-child relationship can be shown in the next diagram. Note, the template control discards everything in the template other than the contents, while the master control keeps everything and replaces the content placeholders with the contents according to ID matching.

Master and Content Parent-child relationship between master and content

Master vs. External Template

Master is very similar to external templates which are introduced since version 3.0.5. A special include tag is used to include an external template file into a base template.

Both master and external template can be used to share common contents among pages. A master is a template control whose template contains the common content and whose class file contains the logic associated with the master. An external template, on the other hand, is a pure template file without any class files.

Therefore, use master control if the common content has to be associated with some logic, such as a page header with search box or login box. A master control allows you to specify how the common content should interact with end users. If you use external templates, you will have to put the needed logic in the page or control class who owns the base template.

Performancewise, external template is lighter than master as the latter is a self-contained control participating the page lifecycles, while the former is used only when the template is being parsed.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Themes and Skins

Introduction

Themes in PRADO provide a way for developers to provide a consistent look-and-feel across an entire web application. A theme contains a list of initial values for properties of various control types. When applying a theme to a page, all controls on that page will receive the corresponding initial property values from the theme. This allows themes to interact with the rich property sets of the various PRADO controls, meaning that themes can be used to specify a large range of presentational properties that other theming methods (e.g. CSS) cannot. For example, themes could be used to specify the default page size of all data grids across an application by specifying a default value for the PageSize property of the TDataGrid control.

Understanding Themes

A theme is a directory that consists of skin files, javascript files and CSS files. Any javascript or CSS files contained in a theme will be registered with the page that the theme is applied to. A skin is a set of initial property values for a particular control type. A control type may have one or several skins, each identified by a unique SkinID. When applying a theme to a page, a skin is applied to a control if the control type and the SkinID value both match to those of the skin. Note, if a skin has an empty SkinID value, it will apply to all controls of the particular type whose SkinID is not set or empty. A skin file consists of one or several skins, for one or several control types. A theme is the union of skins defined in all skin files.

Using Themes

To use a theme, you need to set the Theme property of the page with the theme name, which is the theme directory name. You may set it in either page configurations or in the constructor or onPreInit() method of the page. You cannot set the property after onPreInit() because by that time, child controls of the page are already created (skins must be applied to controls right after they are created.)

To use a particular skin in the theme for a control, set SkinID property of the control in template like following,

<com:TButton SkinID="Blue" ... />

This will apply the 'Blue' skin to the button. Note, the initial property values specified by the 'Blue' skin will overwrite any existing property values of the button. Use stylesheet theme if you do not want them to be overwritten. To use stylesheet theme, set the StyleSheetTheme property of the page instead of Theme (you can have both StyleSheetTheme and Theme).

To use the Javascript files and CSS files contained in a theme, a THead control must be placed on the page template. This is because the theme will register those files with the page and THead is the right place to load those files.

It is possible to specify media types of CSS files contained in a theme. By default, a CSS file applies to all media types. If the CSS file is named like mystyle.print.css, it will be applied only to print media type. As another example, mystyle.screen.css applies to screen media only, and mystyle.css applies to all media types.

Theme Storage

All themes by default must be placed under the [AppEntryPath]/themes directory, where AppEntryPath refers to the directory containing the application entry script. If you want to use a different directory, configure the BasePath and BaseUrl properties of the System.Web.UI.TThemeManager module in application configuration,

<service id="page" class="TPageService">
    <modules>
        <module id="theme"
                class="System.Web.UI.TThemeManager"
                BasePath="mythemes"
                BaseUrl="mythemes" />
    </modules>
</service>

Creating Themes

Creating a theme involves creating the theme directory and writing skin files (and possibly Javascript and CSS files). The name of skin files must be terminated with .skin. The format of skin files are the same as that of control template files. Since skin files do not define parent-child presentational relationship among controls, you cannot place a component tag within another. And any static texts between component tags are discarded. To define the aforementioned 'Blue' skin for TButton, write the following in a skin file,

<com:TButton SkinID="Blue" BackColor="blue" />

As aforementioned, you can put several skins within a single skin file, or split them into several files. A commonly used strategy is that each skin file only contains skins for one type of controls. For example, Button.skin would contain skins only for the TButton control type.

Web controls decorators

Available from Prado versions 3.2a onwards.

As an alternative to the previous methods, to customize the rending of a control its Decorator property can be customized. A TWebControlDecorator can add custom text (html code) before and after both the open and close tag of the control.

<com:THeader3>
    <prop:Decorator.PreTagText>
            <!-- Surround the control with a div and apply a css class to it -->
        <div class="imported-theme-h3-container">
    </prop:Decorator.PreTagText>
    <prop:Decorator.PostTagText>
            <!-- Properly close the tag -->
        </div>
    </prop:Decorator.PostTagText>
    My Nice Title
</com:THeader3>

In this example, a container div will be rendered around the THeader3 control, allowing the user to specify a css class for the container. TWebControlDecorator can also interpret prado's template code and output the resulting html:

<com:TPanel>
    <prop:Decorator.PreTagTemplate>
        <!-- Insert an header before the panel -->
        <com:THeader3>
            Panel's Injected Title
        </com:THeader3>
    </prop:Decorator.PreTagTemplate>
    <prop:Decorator.PostTagTemplate>
            <!-- Insert a date picker after the panel -->
        Pick a date: <com:TDatePicker />
    </prop:Decorator.PostTagTemplate>
    Panel contents here.
</com:TPanel>

Note that you can use the Decorator property also inside skin files, getting it applied automatically to all the controls subjected to the specific skin.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Persistent State

Web applications often need to remember what an end user has done in previous page requests so that the new page request can be served accordingly. State persistence is to address this problem. Traditionally, if a page needs to keep track of user interactions, it will resort to session, cookie, or hidden fields. PRADO provides a new line of state persistence schemes, including view state, control state, and application state.

View State

View state lies at the heart of PRADO. With view state, Web pages become stateful and are capable of restoring pages to the state that end users interacted with before the current page request. Web programming thus resembles to Windows GUI programming, and developers can think continuously without worrying about the round trips between end users and the Web server. For example, with view state, a textbox control is able to detect if the user input changes the content in the textbox.

View state is only available to controls. View state of a control can be disabled by setting its EnableViewState property to false. To store a variable in view state, call the following,

$this->setViewState('Caption',$caption);

where $this refers to the control object, Caption is a unique key identifying the $caption variable stored in viewstate. To retrieve the variable back from view state, call the following,

$caption = $this->getViewState('Caption');

Control State

Control state is like view state in every aspect except that control state cannot be disabled. Control state is intended to be used for storing crucial state information without which a page or control may not work properly.

To store and retrieve a variable in control state, use the following commands,

$this->setControlState('Caption',$caption);
$caption = $this->getControlState('Caption');

Application State

Application state refers to data that is persistent across user sessions and page requests. A typical example of application state is the user visit counter. The counter value is persistent even if the current user session terminates. Note, view state and control state are lost if the user requests for a different page, while session state is lost if the user session terminates.

To store and retrieve a variable in application state, use the following commands,

$application->setGlobalState('Caption',$caption);
$caption = $application->getGlobalState('Caption');

Session State

PRADO encapsulates the traditional session management in THttpSession module. The module can be accessed from within any component by using $this->Session, where $this refers to the component object.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Logging

PRADO provides a highly flexible and extensible logging functionality. Messages logged can be classified according to log levels, message categories and originating control. Using level, category, control or timestamp filters, the messages can be further routed to different destinations, such as files, emails, browser windows, etc. The following diagram shows the basic architecture of PRADO logging mechanism,

Using Logging Functions

The following two methods are provided for logging messages in PRADO,

Prado::log($message, $logLevel, $category, $control);
Prado::trace($message, $category, $control);

The difference between Prado::log() and Prado::trace() is that the latter automatically selects the log level according to the application mode. If the application is in Debug mode, stack trace information is appended to the messages. Prado::trace() is widely used in the core code of the PRADO framework.

Message Routing

Messages logged using the above two functions are kept in memory. To make use of the messages, developers need to route them to specific destinations, such as files, emails, or browser windows. The message routing is managed by System.Util.TLogRouter module. When plugged into an application, it can route the messages to different destination in parallel. Currently, PRADO provides four types of routes:

  • TFileLogRoute - filtered messages are stored in a specified log file. By default, this file is named prado.log under the runtime directory of the application. File rotation is provided.
  • TEmailLogRoute - filtered messages are sent to pre-specified email addresses.
  • TBrowserLogRoute - filtered messages are appended to the end of the current page output.
  • TFirebugLogRoute - filtered messages are sent to the Firebug console

To enable message routing, plug in and configure the TLogRouter module in application configuration,

<module id="log" class="System.Util.TLogRouter">
  <route class="TBrowserLogRoute"
      Levels="Info"
      Categories="System.Web.UI.TPage, System.Web.UI.WebControls" />
  <route class="TFileLogRoute"
      Levels="Warning, Error"
      Categories="System.Web" />
</module>

In the above, the Levels and Categories specify the log and category filters to selectively retrieve the messages to the corresponding destinations.

Message Filtering

Messages can be filtered according to their log levels and categories. Each log message is associated with a log level and a category. With levels and categories, developers can selectively retrieve messages that they are interested on.

Log levels defined in System.Util.TLogger include : DEBUG, INFO, NOTICE, WARNING, ERROR, ALERT, FATAL. Messages can be filtered according log level criteria. For example, if a filter specifies WARNING and ERROR levels, then only those messages that are of WARNING and ERROR will be returned.

Message categories are hierarchical. A category whose name is the prefix of another is said to be the ancestor category of the other category. For example, System.Web category is the ancestor of System.Web.UI and System.Web.UI.WebControls categories. Messages can be selectively retrieved using such hierarchical category filters. For example, if the category filter is System.Web, then all messages in the System.Web are returned. In addition, messages in the child categories, such as System.Web.UI.WebControls, are also returned.

By convention, the messages logged in the core code of PRADO are categorized according to the namespace of the corresponding classes. For example, messages logged in TPage will be of category System.Web.UI.TPage.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Error Handling and Reporting

PRADO provides a complete error handling and reporting framework based on the PHP 5 exception mechanism.

Exception Classes

Errors occur in a PRADO application may be classified into three categories: those caused by PHP script parsing, those caused by wrong code (such as calling an undefined function, setting an unknown property), and those caused by improper use of the Web application by client users (such as attempting to access restricted pages). PRADO is unable to deal with the first category of errors because they cannot be caught in PHP code. PRADO provides an exception hierarchy to deal with the second and third categories.

All errors in PRADO applications are represented as exceptions. The base class for all PRADO exceptions is TException. It provides the message internationalization functionality to all system exceptions. An error message may be translated into different languages according to the user browser's language preference.

Exceptions raised due to improper usage of the PRADO framework inherit from TSystemException, which can be one of the following exception classes:

  • TConfigurationException - improper configuration, such as error in application configuration, control templates, etc.
  • TInvalidDataValueException - data value is incorrect or unexpected.
  • TInvalidDataTypeException - data type is incorrect or unexpected.
  • TInvalidDataFormatException - format of data is incorrect.
  • TInvalidOperationException - invalid operation request.
  • TPhpErrorException - catchable PHP errors, warnings, notices, etc.
  • TSecurityException - errors related with security.
  • TIOException - IO operation error, such as file open failure.
  • TDBException - errors related with database operations.
  • TNotSupportedException - errors caused by requesting for unsupported feature.
  • THttpException - errors to be displayed to Web client users.

Errors due to improper usage of the Web application by client users inherit from TApplicationException.

Raising Exceptions

Raising exceptions in PRADO has no difference than raising a normal PHP exception. The only thing matters is to raise the right exception. In general, exceptions meant to be shown to application users should use THttpException, while exceptions shown to developers should use other exception classes.

Error Capturing and Reporting

Exceptions raised during the runtime of PRADO applications are captured by System.Exceptions.TErrorHandler module. Different output templates are used to display the captured exceptions. THttpException is assumed to contain error messages that are meant for application end users and thus uses a specific group of templates. For all other exceptions, a common template shown as follows is used for presenting the exceptions.

Customizing Error Display

Developers can customize the presentation of exception messages. By default, all error output templates are stored under framework/Exceptions/templates. The location can be changed by configuring TErrorHandler in application configuration,

<module id="error"
    class="TErrorHandler"
    ErrorTemplatePath="Application.ErrorTemplates" />

THttpException uses a set of templates that are differentiated according to different StatusCode property value of THttpException. StatusCode has the same meaning as the status code in HTTP protocol. For example, a status code equal to 404 means the requested URL is not found on the server. The StatusCode value is used to select which output template to use. The output template files use the following naming convention:

error<status code>-<language code>.html

where status code refers to the StatusCode property value of THttpException, and language code must be a valid language such as en, zh, fr, etc. When a THttpException is raised, PRADO will select an appropriate template for displaying the exception message. PRADO will first locate a template file whose name contains the status code and whose language is preferred by the client browser window. If such a template is not present, it will look for a template that has the same status code but without language code.

The naming convention for the template files used for all other exceptions is as follows,

exception-<language code>.html

Again, if the preferred language is not found, PRADO will try to use exception.html, instead.

CAUTION: When saving a template file, please make sure the file is saved using UTF-8 encoding. On Windows, you may use Notepad.exe to accomplish such saving.
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Internationalization (I18N) and Localization (L10N)

Many web application built with PHP will not have internationalization in mind when it was first written. It may be that it was not intended for use in languages and cultures. Internationalization is an important aspect due to the increase adoption of the Internet in many non-English speaking countries. The process of internationalization and localization will contain difficulties. Below are some general guidelines to internationalize an existing application.

Separate culture/locale sensitive data

Identify and separate data that varies with culture. The most obvious are text/string/message. Other type of data should also be considered. The following list categorize some examples of culture sensitive data

  • Strings, Messages, Text, in relatively small units (e.g. phrases, sentences, paragraphs, but not the full text of a book).
  • Labels on buttons.
  • Help files, large units of text, static text.
  • Sounds.
  • Colors.
  • Graphics,Icons.
  • Dates, Times.
  • Numbers, Currency, Measurements.
  • Phone numbers.
  • Honorific and personal titles.
  • Postal address.
  • Page layout.

If possible all manner of text should be isolated and store in a persistence format. These text include, application error messages, hard coded strings in PHP files, emails, static HTML text, and text on form elements (e.g. buttons).

Configuration

To enable the localization features in PRADO, you need to add a few configuration options in your application configuration. First you need to include the System.I18N.* namespace to your paths.

<paths>
    <using namespace="System.I18N.*" />
</paths>

Then, if you wish to translate some text in your application, you need to add one translation message data source.

<module id="globalization" class="TGlobalization">
    <translation type="XLIFF"
        source="MyApp.messages"
        marker="@@"
        autosave="true" cache="true" />
</module>

Where source in translation is the dot path to a directory where you are going to store your translate message catalogue. The autosave attribute if enabled, saves untranslated messages back into the message catalogue. With cache enabled, translated messages are saved in the application runtime/i18n directory. The marker value is used to surround any untranslated text.

With the configuration complete, we can now start to localize your application. If you have autosave enabled, after running your application with some localization activity (i.e. translating some text), you will see a directory and a messages.xml created within your source directory.

What to do with messages.xml?

The translation message catalogue file, if using type="XLIFF", is a standardized translation message interchange XML format. You can edit the XML file using any UTF-8 aware editor. The format of the XML is something like the following.

<?xml version="1.0"?>
<xliff version="1.0">
    <file original="I18N Example IndexPage"
          source-language="EN"
          datatype="plaintext"
          date="2005-01-24T11:07:53Z">
        <body>

<trans-unit id="1">
<source>Hello world.</source>
<target>Hi World!!!</target>
</trans-unit>

        </body>
    </file>
</xliff>
Each translation message is wrapped within a trans-unit tag, where source is the original message, and target is the translated message. Editors such as Heartsome XLIFF Translation Editor can help in editing these XML files.

Using a Database for translation

Available from Prado versions 3.1.3 onwards.

Since version 3.1.3 the messages can also be stored in a database using the connection id from an existing TDataSourceConfig. You have to create two tables in your database: catalogue and trans_unit. The catalogue table needs an entry for each catalogue you want to use. Example schemas for different databases can be found in the framework's I18N/schema directory. To configure translation with a database use:

<module id="db1" class="System.Data.TDataSourceConfig">
    <database ConnectionString="mysql:host=localhost;dbname=demodb" Username="demo" Password="demo" />
</module>

<module id="globalization" class="TGlobalization">
    <translation
        type="Database"
        autosave="true"
        cache="false"
        source="db1" />
</module>

The translation messages will be stored in the trans_unit table. Add your translation in the target field of that table. You should make sure that you are working on the right catalogue by comparing the message's cat_id with that from the catalogue table.

Setting and Changing Culture

Once globalization is enabled, you can access the globalization settings, such as, Culture, Charset, etc, using

$globalization = $this->getApplication()->getGlobalization();
echo $globalization->Culture;
$globalization->Charset= "GB-2312"; //change the charset

You also change the way the culture is determined by changing the class attribute in the module configuration. For example, to set the culture that depends on the browser settings, you can use the TGlobalizationAutoDetect class.

<module id="globalization" class="TGlobalizationAutoDetect">
   ...
</module>

You may also provide your own globalization class to change how the application culture is set. Lastly, you can change the globalization settings on page by page basis using template control tags. For example, changing the Culture to "zh".

<%@ Application.Globalization.Culture="zh" %>

Localizing your PRADO application

There are two areas in your application that may need message or string localization, in PHP code and in the templates. To localize strings within PHP, use the localize function detailed below. To localize text in the template, use the TTranslate component.

Using localize function to translate text within PHP

The localize function searches for a translated string that matches original from your translation source. First, you need to locate all the hard coded text in PHP that are displayed or sent to the end user. The following example localizes the text of the $sender (assuming, say, the sender is a button). The original code before localization is as follows.

function clickMe($sender,$param)
{
  $sender->Text="Hello, world!";
}

The hard coded message "Hello, world!" is to be localized using the localize function.

function clickMe($sender,$param)
{
  $sender->Text=Prado::localize("Hello, world!");
}

Compound Messages

Compound messages can contain variable data. For example, in the message "There are 12 users online.", the integer 12 may change depending on some data in your application. This is difficult to translate because the position of the variable data may be difference for different languages. In addition, different languages have their own rules for plurals (if any) and/or quantifiers. The following example can not be easily translated, because the sentence structure is fixed by hard coding the variable data within message.

$num_users = 12;
$message = "There are " . $num_users . " users online.";
This problem can be solved using the localize function with string substitution. For example, the $message string above can be constructed as follows.
$num_users = 12;
$message = Prado::localize("There are {num_users} users online.", array('num_users'=>$num_users));

Where the second parameter in localize takes an associative array with the key as the substitution to find in the text and replaced it with the associated value. The localize function does not solve the problem of localizing languages that have plural forms, the solution is to use TChoiceFormat.

The following sample demonstrates the basics of localization in PRADO.

Run Sample View Source

I18N Components

TTranslate

Messages and strings can be localized in PHP or in templates. To translate a message or string in the template, use TTranslate.

<com:TTranslate>Hello World</com:TTranslate>
<com:TTranslate Text="Goodbye" />

TTranslate can also perform string substitution. The Parameters property can be use to add name values pairs for substitution. Substrings in the translation enclosed with "{" and "}" are consider as the parameter names during substitution lookup. The following example will substitute the substring "{time}" with the value of the parameter attribute "Parameters.time=<%= time() %>".

<com:TTranslate Parameters.time=<%= time() %> >
The time is {time}.
</com:TTranslate>

A short for TTranslate is also provided using the following syntax.

<%[string]%>

where string will be translated to different languages according to the end-user's language preference. This syntax can be used with attribute values as well.

<com:TLabel Text="<%[ Hello World! ]%>" />

TDateFormat

Formatting localized date and time is straight forward.

<com:TDateFormat Value="12/01/2005" />

The Pattern property accepts 4 predefined localized date patterns and 4 predefined localized time patterns.

  • fulldate
  • longdate
  • mediumdate
  • shortdate
  • fulltime
  • longtime
  • mediumtime
  • shorttime

The predefined can be used in any combination. If using a combined predefined pattern, the first pattern must be the date, followed by a space, and lastly the time pattern. For example, full date pattern with short time pattern. The actual ordering of the date-time and the actual pattern will be determine automatically from locale data specified by the Culture property.

<com:TDateFormat Pattern="fulldate shorttime" />

You can also specify a custom pattern using the following sub-patterns. The date/time format is specified by means of a string time pattern. In this pattern, all ASCII letters are reserved as pattern letters, which are defined as the following:

Symbol   Meaning                 Presentation        Example
 ------   -------                 ------------        -------
 G        era designator          (Text)              AD
 y        year                    (Number)            1996
 M        month in year           (Text & Number)     July & 07
 d        day in month            (Number)            10
 h        hour in am/pm (1~12)    (Number)            12
 H        hour in day (0~23)      (Number)            0
 m        minute in hour          (Number)            30
 s        second in minute        (Number)            55
 E        day of week             (Text)              Tuesday
 D        day in year             (Number)            189
 F        day of week in month    (Number)            2 (2nd Wed in July)
 w        week in year            (Number)            27
 W        week in month           (Number)            2
 a        am/pm marker            (Text)              PM
 k        hour in day (1~24)      (Number)            24
 K        hour in am/pm (0~11)    (Number)            0
 z        time zone               (Time)              Pacific Standard Time
 '        escape for text         (Delimiter)         'Date='
 ''       single quote            (Literal)           'o''clock'

The count of pattern letters determine the format.

(Text): 4 letters uses full form, less than 4, use short or abbreviated form if it exists. (e.g., "EEEE" produces "Monday", "EEE" produces "Mon")

(Number): the minimum number of digits. Shorter numbers are zero-padded to this amount (e.g. if "m" produces "6", "mm" produces "06"). Year is handled specially; that is, if the count of 'y' is 2, the Year will be truncated to 2 digits. (e.g., if "yyyy" produces "1997", "yy" produces "97".) Unlike other fields, fractional seconds are padded on the right with zero.

(Text and Number): 3 or over, use text, otherwise use number. (e.g., "M" produces "1", "MM" produces "01", "MMM" produces "Jan", and "MMMM" produces "January".)

Any characters in the pattern that are not in the ranges of ['a'..'z'] and ['A'..'Z'] will be treated as quoted text. For instance, characters like ':', '.', ' ', and '@' will appear in the resulting time text even they are not embraced within single quotes.

Examples using the US locale:

Format Pattern                         Result
--------------                         -------
"yyyy.MM.dd G 'at' HH:mm:ss"      ->>  1996.07.10 AD at 15:08:56
"EEE, MMM d, ''yy"                ->>  Wed, Jul 10, '96
"h:mm a"                          ->>  12:08 PM
"hh 'o''clock' a, z"              ->>  12 o'clock PM, Pacific Daylight Time
"K:mm a"                          ->>  0:00 PM
"yyyy.MMMM.dd G hh:mm a"          ->>  1996.July.10 AD 12:08 PM

If the Value property is not specified, the current date and time is used.

TNumberFormat

PRADO's Internationalization framework provide localized currency formatting and number formatting. Please note that the TNumberFormat component provides formatting only, it does not perform current conversion or exchange.

Numbers can be formatted as currency, percentage, decimal or scientific numbers by specifying the Type attribute. The valid types are:

  • currency
  • percentage
  • decimal
  • scientific
<com:TNumberFormat Type="currency" Value="100" />

Culture and Currency properties may be specified to format locale specific numbers.

If someone from US want to see sales figures from a store in Germany (say using the EURO currency), formatted using the german currency, you would need to use the attribute Culture="de_DE" to get the currency right, e.g. 100,00$. The decimal and grouping separator is then also from the de_DE locale. This may lead to some confusion because people from US uses the "," (comma) as thousand separator. Therefore a Currency attribute is available, so that the output from the following example results in $100.00

<com:TNumberFormat Type="currency"
          Culture="en_US" Currency="EUR" Value="100" />

The Pattern property determines the number of digits, thousand grouping positions, the number of decimal points and the decimal position. The actual characters that are used to represent the decimal points and thousand points are culture specific and will change automatically according to the Culture property. The valid Pattern characters are:

  • # (hash) - represents the optional digits
  • 0 (zero) - represents the mandatory digits, zero left filled
  • . (full stop) - the position of the decimal point (only 1 decimal point is allowed)
  • , (comma) - thousand point separation (up to 2 commas are allowed)

For example, consider the Value="1234567.12345" and with Culture="en_US" (which uses "," for thousand point separator and "." for decimal separators).

Pattern                      Output
-------                      ------
##,###.00               ->>  1,234,567.12
##,###.##               ->>  1,234,567.12345
##,##.0000              ->>  1,23,45,67.1235
##,###,##.0             ->>  12,345,67.1
000,000,000.0           ->>  001,234,567.1

TTranslateParameter

Compound messages, i.e., string substitution, can be accomplished with TTranslateParameter. In the following example, the strings "{greeting}" and "{name}" will be replace with the values of "Hello" and "World", respectively.The substitution string must be enclose with "{" and "}". The parameters can be further translated by using TTranslate.

<com:TTranslate>
  {greeting} {name}!
  <com:TTranslateParameter Key="name">World</com:TTranslateParameter>
  <com:TTranslateParameter Key="greeting">Hello</com:TTranslateParameter>
</com:TTranslate>

TChoiceFormat

Using the localize function or TTranslate component to translate messages does not inform the translator the cardinality of the data required to determine the correct plural structure to use. It only informs them that there is a variable data, the data could be anything. Thus, the translator will be unable to determine with respect to the substitution data the correct plural, language structure or phrase to use . E.g. in English, to translate the sentence, "There are {number} of apples.", the resulting translation should be different depending on the number of apples.

The TChoiceFormat component performs message/string choice translation. The following example demonstrated a simple 2 choice message translation.

<com:TChoiceFormat Value="1"/>[1] One Apple. |[2] Two Apples</com:TChoiceFormat>

In the above example, the Value "1" (one), thus the translated string is "One Apple". If the Value was "2", then it will show "Two Apples".

The message/string choices are separated by the pipe "|" followed by a set notation of the form.

  • [1,2] -- accepts values between 1 and 2, inclusive.
  • (1,2) -- accepts values between 1 and 2, excluding 1 and 2.
  • {1,2,3,4} -- only values defined in the set are accepted.
  • [-Inf,0) -- accepts value greater or equal to negative infinity and strictly less than 0

Any non-empty combinations of the delimiters of square and round brackets are acceptable. The string chosen for display depends on the Value property. The Value is evaluated for each set until the Value is found to belong to a particular set.

Available from Prado versions 3.1.1 onwards.

Since version 3.1.1 the following set notation is also possible.

  • {n: n % 10 > 1 && n % 10 < 5} -- matches numbers like 2, 3, 4, 22, 23, 24

Where set is defined by the expression after n:. In particular, the expression accepts the following mathematical/logical operators to form a set of logical conditions on the value given by n:

  • < -- less than.
  • <= -- less than equals.
  • > -- greater than.
  • >= -- greater than equals.
  • == -- of equal value.
  • % -- modulo, e.g., 1 % 10 equals 1, 11 % 10 equals 1.
  • - -- minus, negative.
  • + -- addition.
  • & -- conditional AND.
  • && -- condition AND with short circuit.
  • | -- conditional OR.
  • || -- conditional OR with short circuit.
  • ! -- negation.

Additional round brackets can also be used to perform grouping. The following example represents ordinal values in English such as: "0th", "1st", "2nd", "3rd", "4th", "11th", "21st", "22nd", etc.

<com:TChoiceFormat Value="21">
 {n: n > 0 && n % 10 == 1 && n % 100 != 11} {Value}st
|{n: n > 0 && n % 10 == 2 && n % 100 != 12} {Value}nd
|{n: n > 0 && n % 10 == 3 && n % 100 != 13} {Value}rd
|{n: n > -1 } {Value}th
|(-Inf, 0) {Value}
</com:TChoiceFormat>
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Performance Tuning

Performance of Web applications is affected by many factors. Database access, file system operations, network bandwidth are all potential affecting factors. PRADO tries in every effort to reduce the performance impact caused by the framework.

Caching

PRADO provides a generic caching technique used by in several core parts of the framework. For example, when caching is enabled, TTemplateManager will save parsed templates in cache and reuse them in the following requests, which saves time for parsing templates. The TThemeManager adopts the similar strategy to deal with theme parsing.

Enabling caching is very easy. Simply add the cache module in the application configuration, and PRADO takes care of the rest.

<modules>
    <module id="cache" class="System.Caching.TSqliteCache" />
</modules>

Developers can also take advantage of the caching technique in their applications. The Cache property of TApplication returns the plugged-in cache module when it is available. To save and retrieve a data item in cache, use the following commands,

if($application->Cache) {
    // saves data item in cache
    $application->Cache->set($keyName,$dataItem);
    // retrieves data item from cache
    $dataItem=$application->Cache->get($keyName);
}

where $keyName should be a string that uniquely identifies the data item stored in cache.

Since v3.1.0, a new control called TOutputCache has been introduced. This control allows users to selectively cache parts of a page's output. When used appropriately, this technique can significant improve pages' performance because the underlying controls are not created at all if the cached versions are hit.

Using pradolite.php

Including many PHP script files may impact application performance significantly. PRADO classes are stored in different files and when processing a page request, it may require including tens of class files.To alleviate this problem, in each PRADO release, a file named pradolite.php is also included. The file is a merge of all core PRADO class files with comments being stripped off and message logging removed.

To use pradolite.php, in your application entry script, replace the inclusion of prado.php with pradolite.php.

Changing Application Mode

Application mode also affects application performance. A PRADO application can be in one of the following modes: Off, Debug, Normal and Performance. The Debug mode should mainly be used during application development, while Normal mode is usually used in early stage after an application is deployed to ensure everything works correctly. After the application is proved to work stably for some period, the mode can be switched to Performance to further improve the performance.

The difference between Debug, Normal and Performance modes is that under Debug mode, application logs will contain debug information, and under Performance mode, timestamp checking is not performed for cached templates and published assets. Therefore, under Performance mode, application may not run properly if templates or assets are modified. Since Performance mode is mainly used when an application is stable, change of templates or assets are not likely.

To switch application mode, configure it in application configuration:

<application Mode="Performance" >
    ......
</application >

Reducing Page Size

By default, PRADO stores page state in hidden fields of the HTML output. The page state could be very large in size if complex controls, such as TDataGrid, is used. To reduce the size of the network transmitted page size, two strategies can be used.

First, you may disable viewstate by setting EnableViewState to false for the page or some controls on the page if they do not need user interactions. Viewstate is mainly used to keep track of page state when a user interacts with that page/control.

Second, you may use a different page state storage. For example, page state may be stored in session, which essentially stores page state on the server side and thus saves the network transmission time. The StatePersisterClass property of the page determines which state persistence class to use. By default, it uses System.Web.UI.TPageStatePersister to store persistent state in hidden fields. You may modify this property to a persister class of your own, as long as the new persister class implements the IPageStatePersister interface. You may configure this property in several places, such as application configuration or page configuration using <pages> or <page> tags,

<pages StatePersisterClass="MyPersister1" ... >
    <page ID="SpecialPage" StatePersisterClass="MyPersister2" ... />
</pages>

Note, in the above the SpecialPage will use MyPersister2 as its persister class, while the rest pages will use MyPersister1. Therefore, you can have different state persister strategies for different pages.

Other Techniques

Server caching techniques are proven to be very effective in improving the performance of PRADO applications. For example, we have observed that by using Zend Optimizer, the RPS (request per second) of a PRADO application can be increased by more than ten times. Of course, this is at the cost of stale output, while PRADO's caching techniques always ensure the correctness of the output.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Introduction to Javascript

This guide is based on the Quick guide to somewhat advanced JavaScript tour of some OO features by Sergio Pereira.

Hey, I didn't know you could do that

If you are a web developer and come from the same place I do, you have probably used quite a bit of Javascript in your web pages, mostly as UI glue.

Until recently, I knew that Javascript had more OO capabilities than I was employing, but I did not feel like I needed to use it. As the browsers started to support a more standardized featureset of Javascript and the DOM, it became viable to write more complex and functional code to run on the client. That helped giving birth to the AJAX phenomena.

As we all start to learn what it takes to write our cool, AJAX applications, we begin to notice that the Javascript we used to know was really just the tip of the iceberg. We now see Javascript being used beyond simple UI chores like input validation and frivolous tasks. The client code now is far more advanced and layered, much like a real desktop application or a client-server thick client. We see class libraries, object models, hierarchies, patterns, and many other things we got used to seeing only in our server side code.

In many ways we can say that suddenly the bar was put much higher than before. It takes a heck lot more proficiency to write applications for the new Web and we need to improve our Javascript skills to get there. If you try to use many of the existing javascript libraries out there, like Prototype.js, Scriptaculous, moo.fx, Behaviour, YUI, etc you'll eventually find yourself reading the JS code. Maybe because you want to learn how they do it, or because you're curious, or more often because that's the only way to figure out how to use it, since documentation does not seem to be highly regarded with most of these libraries. Whatever the case may be, you'll face some kung-fu techniques that will be foreign and scary if you haven't seen anything like that before.

The purpose of this article is precisely explaining the types of constructs that many of us are not familiar with yet.

JSON (JavaScript Object Notation)

JavaScript Object Notation (JSON,) is one of the new buzzwords popping up around the AJAX theme. JSON, simply put, is a way of declaring an object in Javascript. Let's see an example right away and note how simple it is.

var myPet = { color: 'black', leg_count: 4, communicate: function(repeatCount){
for(i=0;i<repeatCount;i++) alert('Woof!');} };

Let's just add little bit of formatting so it looks more like how we usually find out there:

var myPet =
{
    color: 'black',
    legCount: 4,
    communicate: function(repeatCount)
    {
        for(i=0;i<repeatCount;i++)
            alert('Woof!');
    }
};

Here we created a reference to an object with two properties (color and legCount) and a method (communicate.) It's not hard to figure out that the object's properties and methods are defined as a comma delimited list. Each of the members is introduced by name, followed by a colon and then the definition. In the case of the properties it is easy, just the value of the property. The methods are created by assigning an anonymous function, which we will explain better down the line. After the object is created and assigned to the variable myPet, we can use it like this:

alert('my pet is ' + myPet.color);
alert('my pet has ' + myPet.legCount + ' legs');
//if you are a dog, bark three times:
myPet.communicate(3);

You'll see JSON used pretty much everywhere in JS these days, as arguments to functions, as return values, as server responses (in strings,) etc.

What do you mean? A function is an object too?

This might be unusual to developers that never thought about that, but in JS a function is also an object. You can pass a function around as an argument to another function just like you can pass a string, for example. This is extensively used and very handy.

Take a look at this example. We will pass functions to another function that will use them.

var myDog =
{
    bark: function()
    {
        alert('Woof!');
    }
};

var myCat =
{
    meow: function()
    {
        alert('I am a lazy cat. I will not meow for you.');
    }
};

function annoyThePet(petFunction)
{
    //let's see what the pet can do
    petFunction();
}

//annoy the dog:
annoyThePet(myDog.bark);
//annoy the cat:
annoyThePet(myCat.meow);

Note that we pass myDog.bark and myCat.meow without appending parenthesis "()" to them. If we did that we would not be passing the function, rather we would be calling the method and passing the return value, undefined in both cases here.

If you want to make my lazy cat start barking, you can easily do this:

myCat.meow = myDog.bark;
myCat.meow(); //alerts 'Woof!'

Arrays, items, and object members

The following two lines in JS do the same thing.

var a = new Array();
var b = [];

As I'm sure you already know, you can access individual items in an array by using the square brackets:

var a = ['first', 'second', 'third'];
var v1 = a[0];
var v2 = a[1];
var v3 = a[2];

But you are not limited to numeric indices. You can access any member of a JS object by using its name, in a string. The following example creates an empty object, and adds some members by name.

var obj = {}; //new, empty object
obj['member_1'] = 'this is the member value';
obj['flag_2'] = false;
obj['some_function'] = function(){ /* do something */};

The above code has identical effect as the following:

var obj =
{
    member_1:'this is the member value',
    flag_2: false,
    some_function: function(){ /* do something */}
};

In many ways, the idea of objects and associative arrays (hashes) in JS are not distiguishable. The following two lines do the same thing too.

obj.some_function();
obj['some_function']();

Enough about objects, may I have a class now?

The great power of object oriented programming languages derive from the use of classes. I don't think I would have guessed how classes are defined in JS using only my previous experience with other languages. Judge for yourself.

//defining a new class called Pet
var Pet = function(petName, age)
{
    this.name = petName;
    this.age = age;
};

//let's create an object of the Pet class
var famousDog = new Pet('Santa\'s Little Helper', 15);
alert('This pet is called ' + famousDog.name);

Let's see how we add a method to our Pet class. We will be using the prototype property that all classes have. The prototype property is an object that contains all the members that any object of the class will have. Even the default JS classes, like String, Number, and Date have a prototype object that we can add methods and properties to and make any object of that class automatically gain this new member.

Pet.prototype.communicate = function()
{
    alert('I do not know what I should say, but my name is ' + this.name);
};

That's when a library like prototype.js comes in handy. If we are using prototype.js, we can make our code look cleaner (at least in my opinion.)

var Pet = Class.create();
Pet.prototype =
{
    //our 'constructor'
    initialize: function(petName, age)
    {
        this.name = petName;
        this.age = age;
    },

    communicate: function()
    {
        alert('I do not know what I should say, but my name is ' + this.name);
    }
};

Functions as arguments, an interesting pattern

If you have never worked with languages that support closures you may find the following idiom too funky.

var myArray = ['first', 'second', 'third'];
myArray.each( function(item, index)
{
    alert('The item in the position #' + index + ' is:' + item);
});

Whoa! Let's explain what is going on here before you decide I've gone too far and navigate to a better article than this one.

First of all, in the above example we are using the prototype.js library, which adds the each function to the Array class. The each function accepts one argument that is a function object. This function, in turn, will be called once for each item in the array, passing two arguments when called, the item and the index for the current item. Let's call this function our iterator function. We could have also written the code like this.

function myIterator(item, index)
{
    alert('The item in the position #' + index + ' is:' + item);
}

var myArray = ['first', 'second', 'third'];
myArray.each( myIterator );

But then we would not be doing like all the cool kids in school, right? More seriously, though, this last format is simpler to understand but causes us to jump around in the code looking for the myIterator function. It's nice to have the logic of the iterator function right there in the same place it's called. Also, in this case, we will not need the iterator function anywhere else in our code, so we can transform it into an anonymous function without penalty.

This is this but sometimes this is also that

One of the most common troubles we have with JS when we start writing our code it the use of the this keyword. It could be a real tripwire.

As we mentioned before, a function is also an object in JS, and sometimes we do not notice that we are passing a function around.

Take this code snippet as an example.

function buttonClicked()
{
    alert('button ' + this.id + ' was clicked');
}

var myButton = document.getElementById('someButtonID');
var myButton2 = document.getElementById('someOtherButtonID');
myButton.onclick = buttonClicked;
myButton2.onclick = buttonClicked;

Because the buttonClicked function is defined outside any object we may tend to think the this keyword will contain a reference to the window or document object (assuming this code is in the middle of an HTML page viewed in a browser.)

But when we run this code we see that it works as intended and displays the id of the clicked button. What happened here is that we made the onclick method of each button contain the buttonClicked object reference, replacing whatever was there before. Now whenever the button is clicked, the browser will execute something similar to the following line.

myButton.onclick();

That isn't so confusing afterall, is it? But see what happens you start having other objects to deal with and you want to act on these object upon events like the button's click.

var myHelper =
{
    formFields: [ ],
    emptyAllFields: function()
    {
        for(i=0; i < this.formFields.length; i++)
        {
            var elementID = this.formFields[i];
            var field = document.getElementById(elementID);
            field.value = '';
        }
    }
};

//tell which form fields we want to work with
myHelper.formFields.push('txtName');
myHelper.formFields.push('txtEmail');
myHelper.formFields.push('txtAddress');

//clearing the text boxes:
myHelper.emptyAllFields();

var clearButton = document.getElementById('btnClear');
clearButton.onclick = myHelper.emptyAllFields;

So you think, nice, now I can click the Clear button on my page and those three text boxes will be emptied. Then you try clicking the button only to get a runtime error. The error will be related to (guess what?) the this keyword. The problem is that this.formFields is not defined if this contains a referece to the button, which is precisely what's happening. One quick solution would be to rewrite our last line of code.

clearButton.onclick = function()
{
    myHelper.emptyAllFields();
};

That way we create a brand new function that calls our helper method within the helper object's context.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Developer Notes for prototype.js

This guide is based on the Developer Notes for prototype.js by Sergio Pereira.

What is that?

In case you haven't already used it, prototype.js is a JavaScript library written by Sam Stephenson. This amazingly well thought and well written piece of standards-compliant code takes a lot of the burden associated with creating rich, highly interactive web pages that characterize the Web 2.0 off your back.

If you tried to use this library recently, you probably noticed that documentation is not one of its strongest points. As many other developers before me, I got my head around prototype.js by reading the source code and experimenting with it. I thought it would be nice to take notes while I learned and share with everybody else.

As you read the examples and the reference, developers familiar with the Ruby programming language will notice an intentional similarity between Ruby's built-in classes and many of the extensions implemented by this library.

Using the $() function

The $() function is a handy shortcut to the all-too-frequent document.getElementById() function of the DOM. Like the DOM function, this one returns the element that has the id passed as an argument.

Unlike the DOM function, though, this one goes further. You can pass more than one id and $() will return an Array object with all the requested elements. The example below should illustrate this.

<com:TClientScript UsingClientScripts="prado" />
<div id="myDiv">
    <p id="830731" class="block-content">This is a paragraph</p>
</div>

<div id="myOtherDiv">
    <p id="830732" class="block-content">This is another paragraph</p>
</div>

<input type="button" value=Test1 onclick="test1();" />
<input type="button" value=Test2 onclick="test2();" />

<script type="text/javascript">
/*<![CDATA[*/
function test1()
{
    var d = $('myDiv');
    alert(d.innerHTML);
}

function test2()
{
    var divs = $('myDiv','myOtherDiv');
    for(i=0; i<divs.length; i++)
    {
        alert(divs[i].innerHTML);
    }
}
/*]]>*/
</script>

Another nice thing about this function is that you can pass either the id string or the element object itself, which makes this function very useful when creating other functions that can also take either form of argument.

Using the $F() function

The $F() function is a another welcome shortcut. It returns the value of any field input control, like text boxes or drop-down lists. The function can take as argument either the element id or the element object itself.

<input type="text" id="userName" value="Joe Doe" />
<input type="button" value=Test3 onclick="test3();" />

<script type="text/javascript">
/*<![CDATA[*/
function test3()
{
    alert($F('userName'));
}
/*]]>*/
</script>
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

DOM Events and Javascript

Basic event handling

The syntax for working with events looks like the code below.

Event.observe(element, name, observer, [useCapture]);

Assuming for a moment that we want to observe when a link was clicked, we could do the following:

// <a id="clicker" href="http://foo.com">Click me</a>
Event.observe('clicker', 'click', function(event)
{
    alert('clicked!');
});

If we wanted to get the element that fired the event, we'd do this:

Event.observe('clicker', 'click', function(event)
{
    alert(Event.element(event));
});

Observing keystrokes

If we wanted to observe keystrokes for the entire document, we could do the following:

Event.observe(document, 'keypress', function(event)
{
    if(Event.keyCode(event) == Event.KEY_TAB)
        alert('Tab Pressed');
});

And lets say we wanted to keep track of what has been typed :

Event.observe('search', 'keypress', function(event)
{
    Element.update('search-results', $F(Event.element(event)));
});

Prototype defines properties inside the event object for some of the more common keys, so feel free to dig around in Prototype to see which ones those are.

A final note on keypress events; If you'd like to detect a left click you can use Event.isLeftClick(event).

Getting the coordinates of the mouse pointer

Drag and drop, dynamic element resizing, games, and much more all require the ability to track the X and Y location of the mouse. Prototype makes this fairly simple. The code below tracks the X and Y position of the mouse and spits out those values into an input box named mouse.

Event.observe(document, 'mousemove', function(event)
{
    $('mouse').value = "X: " + Event.pointerX(event) +
                       "px Y: " + Event.pointerY(event) + "px";
});

If we wanted to observe the mouse location when it was hovering over a certain element, we'd just change the document argument to the id or element that was relevant.

Stopping Propagation

Event.stop(event) will stop the propagation of an event .

Events, Binding, and Objects

Everything has been fairly straight forward so far, but things start getting a little trickier when you need to work with events in and object-oriented environment. You have to deal with binding and funky looking syntax that might take a moment to get your head around.

Lets look at some code so you can get a better understanding of what I'm talking about.

EventDispenser = Class.create();
EventDispenser.prototype =
{
  initialize: function(list)
  {
    this.list = list;

    // Observe clicks on our list items
    $$(this.list + " li").each(function(item)
    {
        Event.observe(item, 'click', this.showTagName.bindEvent(this));
    }.bind(this));

    // Observe when a key on the keyboard is pressed.
    // In the observer, we check for
    // the tab key and alert a message if it is pressed.
    Event.observe(document, 'keypress', this.onKeyPress.bindEvent(this));

    // Observe our fake live search box.  When a user types
    // something into the box, the observer will take that
    // value(-1) and update our search-results div with it.
    Event.observe('search', 'keypress', this.onSearch.bindEvent(this));

    Event.observe(document, 'mousemove', this.onMouseMove.bindEvent(this));
  },

  // Arbitrary functions to respond to events
  showTagName: function(event)
  {
    alert(Event.element(event).tagName);
  },

  onKeyPress: function(event)
  {
    var code = event.keyCode;
    if(code == Event.KEY_TAB)
        alert('Tab key was pressed');
  },

  onSearch: function(event)
  {
    Element.update('search-results', $F(Event.element(event)));
  },

  onMouseMove: function(event)
  {
    $('mouse').value = "X: " + Event.pointerX(event) +
                "px Y: " + Event.pointerY(event) + "px";
  }
}

Whoa! What's going on here? Well, we've defined our a custom class EventDispenser. We're going to be using this class to setup events for our document. Most of this code is a rewrite of the code we looked at earlier except this time, we are working from inside an object.

Looking at the initialize method, we can really see how things are different now. Take a look at the code below:

// Observe clicks on our list items
$$(this.list + " li").each(function(item)
{
    Event.observe(item, 'click', this.showTagName.bindEvent(this));
}.bind(this));

We've got iterators, binding and all sorts of stuff going on. Lets break down what this chunk of code is doing.

First we are hunting for a collection of elements based on it's CSS selector. This uses the Prototype selector function $$(). After we've found the list items we are dealing with we send those into an each iteration where we will add our observers.

Event.observe(item, 'click', this.showTagName.bindEvent(this));

Now looking at the code above, you'll notice the bindEvent function. This takes the method before it showTagName and treats it as the method that will be triggered when, in this case, someone clicks one of our list items.

You'll also notice we pass this as an argument to the bindEvent function. This simply allows us to reference the object in context EventDispenser inside our function showTagName(event). If the showTagName function requires additional parameters, you can attach them to the later parameters of bindEvent. For example

this.showTagName.bindEvent(this, param1, param2);

//where the showTagName function is defined as
showTime : function (event, param1, param2) { ... }

Moving on, you'll see bind(this) attached to our iterator function. This really has nothing to do with events, it is only here to allow me to use this inside the iterator. If we did not use bind(this), I could not reference the method showTagName inside the iterator.

Ok, so we'll move on to looking at our methods that actually get called when an event occurs. Since we've been dealing with showTagName, lets look at it.

showTagName: function(event)
{
    alert(Event.element(event).tagName);
}

As you can see, this function accepts one argument--the event. In order for us to get the element which fired the event we need to pass that argument to Event.element. Now we can manipulate it at will.

This covers the most confusing parts of our code. The text above is also relevant to the remaining parts of our code. If there is anything about this you don't understand, feel free to ask questions in the forum.

Removing Event Listeners

This one threw me for a loop the first time I tried to use it. I tried something similar to what I did in the Event.observe call with the exception of using stopObserving, but nothing seemed to change. In other words, the code below does NOT work.

$$(this.list + " li").each(function(item)
{
    Event.stopObserving(item, 'click', this.showTagName);
}.bind(this));

What's the deal here? The reason this does not work is because there is no pointer to the observer. This means that when we passed this.showTagName in the Event.observe method before hand, we passed it as an anonymous function. We can't reference an anonymous function because it simply does not have a pointer.

So how do we get the job done? All we need to do is give the observing function a pointer, or the jargon free version: Set a variable that points to this.showTagName. Ok, lets change our code a bit.

this.showTagObserver = this.showTagName.bindEvent(this);

// Observe clicks on our list items
$$(this.list + " li").each(function(item)
{
    Event.observe(item, 'click', this.showTagObserver);
}.bind(this));

Now we can remove the event listeners from our list like this:

$$(this.list + " li").each(function(item)
{
    Event.stopObserving(item, 'click', this.showTagObserver);
}.bind(this));
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Javascript in PRADO, Questions and Answers

How do I include the Javascript libraries distributed with Prado?

The javascript libraries distributed with Prado can be found in the framework/Web/Javascripts/source directory. The packages.php file in that directory defines a list of available package names available to be loaded. They can be loaded as follows.

  • Adding libraries in the template
    <com:TClientScript PradoScripts="effects" />
  • Adding libraries in PHP code
    $this->getPage()->getClientScript()->registerPradoScript("effects");
The available packaged libraries included in Prado are
  • prado : basic PRADO javascript framework based on Prototype
  • effects : visual effects from script.aculo.us
  • ajax : ajax and callback related based on Prototype
  • validator : validation
  • logger : javascript logger and object browser
  • datepicker : datepicker control
  • colorpicker : colorpicker control
  • dragdrop : basic support for "drag and drop" control
  • dragdropextra : extra support for "drag and drop" controls
  • slider : slider control
  • keyboard : software keyboard control
  • tabpanel : tabpanel control
  • activedatepicker : ajax version of the datepicker control
  • activefileupload : ajax version of the fileupload control
  • accordion : accordion control
  • htmlarea : tinymce control

The dependencies for each library are automatically resolved. Components that require a particular library will also automatically load the necessary libraries. For example, if you add a TDatePicker component on the page, the datepicker and its dependencies will be automatically included on the page.

See TClientScript for options of adding your custom Javascript code to the page.
Copyright © 2005-2007 PradoSoft.


Package System.Data.SqlMap.Statements Element Index

Element index for package System.Data.SqlMap.Statements

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a b c e f g h i o p q r s t _
top
_
__construct | in file TPreparedStatement.php, method TPreparedStatement::__construct()
__construct | in file TPreparedStatementFactory.php, method TPreparedStatementFactory::__construct()
__construct | in file TSimpleDynamicSql.php, method TSimpleDynamicSql::__construct()
__construct | in file TCachingStatement.php, method TCachingStatement::__construct()
__construct | in file TMappedStatement.php, method TResultSetMapItemParameter::__construct()
__construct | in file TMappedStatement.php, method TResultSetListItemParameter::__construct()
__construct in file TMappedStatement.php, method TMappedStatement::__construct()
Creates a new mapped statement.
__sleep | in file TMappedStatement.php, method TMappedStatement::__sleep()
__sleep | in file TPreparedStatement.php, method TPreparedStatement::__sleep()
__sleep | in file TMappedStatement.php, method TSqlMapObjectCollectionTree::__sleep()
__wakeup | in file TMappedStatement.php, method TMappedStatement::__wakeup()
__wakeup | in file TPreparedStatement.php, method TPreparedStatement::__wakeup()
top
a
add in file TMappedStatement.php, method TSqlMapObjectCollectionTree::add()
Add a new node to the object tree graph.
addNode in file TMappedStatement.php, method TSqlMapObjectCollectionTree::addNode()
Find the parent node and add the new node as its child.
addResultMapGroupBy in file TMappedStatement.php, method TMappedStatement::addResultMapGroupBy()
ResultMap with GroupBy property. Save object collection graph in a tree and collect the result later.
applyParameterMap | in file TPreparedCommand.php, method TPreparedCommand::applyParameterMap()
applyResultMap in file TMappedStatement.php, method TMappedStatement::applyResultMap()
Apply result mapping.
top
b
buildPreparedStatement | in file TStaticSql.php, method TStaticSql::buildPreparedStatement()
top
c
collect | in file TMappedStatement.php, method TSqlMapObjectCollectionTree::collect()
collectChildren in file TMappedStatement.php, method TSqlMapObjectCollectionTree::collectChildren()
Visit all the child nodes and collect them by removing.
create | in file TPreparedCommand.php, method TPreparedCommand::create()
createCommand | in file TCachingStatement.php, method TCachingStatement::createCommand()
createParametersForTextCommand | in file TPreparedStatementFactory.php, method TPreparedStatementFactory::createParametersForTextCommand()
top
e
enquequePostSelect in file TMappedStatement.php, method TMappedStatement::enquequePostSelect()
Add nested result property to post select queue.
executeInsert | in file TSelectMappedStatement.php, method TSelectMappedStatement::executeInsert()
executeInsert | in file TUpdateMappedStatement.php, method TUpdateMappedStatement::executeInsert()
executeInsert | in file TCachingStatement.php, method TCachingStatement::executeInsert()
executeInsert in file TMappedStatement.php, method TMappedStatement::executeInsert()
Execute an insert statement. Fill the parameter object with the ouput parameters if any, also could return the insert generated key.
executePostSelect in file TMappedStatement.php, method TMappedStatement::executePostSelect()
Process 'select' result properties
executeQueryForList | in file TCachingStatement.php, method TCachingStatement::executeQueryForList()
executeQueryForList | in file TUpdateMappedStatement.php, method TUpdateMappedStatement::executeQueryForList()
executeQueryForList in file IMappedStatement.php, method IMappedStatement::executeQueryForList()
Executes the SQL and retuns a subset of the rows selected.
executeQueryForList in file TMappedStatement.php, method TMappedStatement::executeQueryForList()
Executes the SQL and retuns a List of result objects.
executeQueryForList | in file TInsertMappedStatement.php, method TInsertMappedStatement::executeQueryForList()
executeQueryForMap in file TMappedStatement.php, method TMappedStatement::executeQueryForMap()
Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
executeQueryForMap | in file TCachingStatement.php, method TCachingStatement::executeQueryForMap()
executeQueryForMap in file IMappedStatement.php, method IMappedStatement::executeQueryForMap()
Executes the SQL and retuns all rows selected in a map that is keyed on
executeQueryForMap | in file TUpdateMappedStatement.php, method TUpdateMappedStatement::executeQueryForMap()
executeQueryForMap | in file TInsertMappedStatement.php, method TInsertMappedStatement::executeQueryForMap()
executeQueryForObject | in file TUpdateMappedStatement.php, method TUpdateMappedStatement::executeQueryForObject()
executeQueryForObject in file IMappedStatement.php, method IMappedStatement::executeQueryForObject()
Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
executeQueryForObject in file TMappedStatement.php, method TMappedStatement::executeQueryForObject()
Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
executeQueryForObject | in file TCachingStatement.php, method TCachingStatement::executeQueryForObject()
executeQueryForObject | in file TInsertMappedStatement.php, method TInsertMappedStatement::executeQueryForObject()
executeSelectKey in file TMappedStatement.php, method TMappedStatement::executeSelectKey()
Execute the select key statement, used to obtain last insert ID.
executeSQLQueryLimit in file TMappedStatement.php, method TMappedStatement::executeSQLQueryLimit()
Execute SQL Query with limits.
executeUpdate | in file TInsertMappedStatement.php, method TInsertMappedStatement::executeUpdate()
executeUpdate | in file TCachingStatement.php, method TCachingStatement::executeUpdate()
executeUpdate | in file TSelectMappedStatement.php, method TSelectMappedStatement::executeUpdate()
executeUpdate in file TMappedStatement.php, method TMappedStatement::executeUpdate()
Execute an update statement. Also used for delete statement.
executeUpdate in file IMappedStatement.php, method IMappedStatement::executeUpdate()
Execute an update statement. Also used for delete statement. Return the number of row effected.
top
f
fillArrayResultMap in file TMappedStatement.php, method TMappedStatement::fillArrayResultMap()
Retrieve the result map as an array.
fillDefaultResultMap in file TMappedStatement.php, method TMappedStatement::fillDefaultResultMap()
Fill the result map using default settings. If <tt>$resultMap</tt> is null the result object returned will be guessed from <tt>$resultObject</tt>.
fillPropertyWithResultMap in file TMappedStatement.php, method TMappedStatement::fillPropertyWithResultMap()
Fills the property with result mapping results.
fillResultArrayList in file TMappedStatement.php, method TMappedStatement::fillResultArrayList()
Apply the result to a TList or an array.
fillResultClass in file TMappedStatement.php, method TMappedStatement::fillResultClass()
Fill the result using ResultClass, will creates new result object if required.
fillResultMap in file TMappedStatement.php, method TMappedStatement::fillResultMap()
Fills the result object according to result mappings.
fillResultObjectProperty in file TMappedStatement.php, method TMappedStatement::fillResultObjectProperty()
Apply the result to an object.
top
g
getCacheKey | in file TCachingStatement.php, method TCachingStatement::getCacheKey()
getCollection | in file TMappedStatement.php, method TSqlMapObjectCollectionTree::getCollection()
getCommand | in file TMappedStatement.php, method TMappedStatement::getCommand()
getGenerate | in file TSqlMapStatement.php, method TSqlMapSelect::getGenerate()
getID | in file IMappedStatement.php, method IMappedStatement::getID()
getID | in file TCachingStatement.php, method TCachingStatement::getID()
getID | in file TMappedStatement.php, method TMappedStatement::getID()
getKey | in file TMappedStatement.php, method TResultSetMapItemParameter::getKey()
getKeys | in file TMappedStatement.php, method TPostSelectBinding::getKeys()
getList | in file TMappedStatement.php, method TResultSetListItemParameter::getList()
getManager | in file TCachingStatement.php, method TCachingStatement::getManager()
getManager | in file TMappedStatement.php, method TMappedStatement::getManager()
getManager | in file IMappedStatement.php, method IMappedStatement::getManager()
getMap | in file TMappedStatement.php, method TResultSetMapItemParameter::getMap()
getMethod | in file TMappedStatement.php, method TPostSelectBinding::getMethod()
getParameter | in file TMappedStatement.php, method TResultSetListItemParameter::getParameter()
getParameter | in file TMappedStatement.php, method TResultSetMapItemParameter::getParameter()
getParameterNames | in file TPreparedStatement.php, method TPreparedStatement::getParameterNames()
getParameterValues | in file TPreparedStatement.php, method TPreparedStatement::getParameterValues()
getPostGeneratedSelectKey in file TMappedStatement.php, method TMappedStatement::getPostGeneratedSelectKey()
Gets the inserted row ID after executing an insert statement.
getPostSelectKeys in file TMappedStatement.php, method TMappedStatement::getPostSelectKeys()
Finds in the post select property the SQL statement primary selection keys.
getPreGeneratedSelectKey in file TMappedStatement.php, method TMappedStatement::getPreGeneratedSelectKey()
Gets the insert generated ID before executing an insert statement.
getPreparedSql | in file TPreparedStatement.php, method TPreparedStatement::getPreparedSql()
getPreparedStatement | in file TStaticSql.php, method TStaticSql::getPreparedStatement()
getResult | in file TMappedStatement.php, method TResultSetListItemParameter::getResult()
getResultMapGroupKey in file TMappedStatement.php, method TMappedStatement::getResultMapGroupKey()
Gets the result 'group by' groupping key for each row.
getResultObject | in file TMappedStatement.php, method TPostSelectBinding::getResultObject()
getResultProperty | in file TMappedStatement.php, method TPostSelectBinding::getResultProperty()
getScalarResult in file TMappedStatement.php, method TMappedStatement::getScalarResult()
Converts the first array value to scalar value of given type.
getSqlString | in file TMappedStatement.php, method TMappedStatement::getSqlString()
getStatement | in file TMappedStatement.php, method TPostSelectBinding::getStatement()
getStatement | in file TCachingStatement.php, method TCachingStatement::getStatement()
getStatement | in file IMappedStatement.php, method IMappedStatement::getStatement()
getStatement | in file TMappedStatement.php, method TMappedStatement::getStatement()
getValue | in file TMappedStatement.php, method TResultSetMapItemParameter::getValue()
top
h
hasChildren | in file TMappedStatement.php, method TSqlMapObjectCollectionTree::hasChildren()
top
i
IMappedStatement.php | procedural page IMappedStatement.php
IMappedStatement in file IMappedStatement.php, class IMappedStatement
Interface for all mapping statements.
initialGroupByResults in file TMappedStatement.php, method TMappedStatement::initialGroupByResults()
Empty the group by results cache.
isEmpty | in file TMappedStatement.php, method TSqlMapObjectCollectionTree::isEmpty()
top
o
onChildNodesVisited in file TMappedStatement.php, method TSqlMapObjectCollectionTree::onChildNodesVisited()
Set the object properties for all the child nodes visited.
onExecuteQuery in file TMappedStatement.php, method TMappedStatement::onExecuteQuery()
Raise the execute query event.
top
p
prepare | in file TPreparedStatementFactory.php, method TPreparedStatementFactory::prepare()
top
q
QUERY_FOR_ARRAY | in file TMappedStatement.php, class constant TMappedStatement::QUERY_FOR_ARRAY
QUERY_FOR_LIST | in file TMappedStatement.php, class constant TMappedStatement::QUERY_FOR_LIST
QUERY_FOR_OBJECT | in file TMappedStatement.php, class constant TMappedStatement::QUERY_FOR_OBJECT
top
r
raiseRowDelegate in file TMappedStatement.php, method TMappedStatement::raiseRowDelegate()
Raises delegate handler.
replaceDynamicParameter | in file TSimpleDynamicSql.php, method TSimpleDynamicSql::replaceDynamicParameter()
runQueryForList in file TMappedStatement.php, method TMappedStatement::runQueryForList()
Executes the SQL and retuns a List of result objects.
runQueryForMap in file TMappedStatement.php, method TMappedStatement::runQueryForMap()
Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
runQueryForObject in file TMappedStatement.php, method TMappedStatement::runQueryForObject()
Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
top
s
setGenerate | in file TSqlMapStatement.php, method TSqlMapSelect::setGenerate()
setKeys | in file TMappedStatement.php, method TPostSelectBinding::setKeys()
setMethod | in file TMappedStatement.php, method TPostSelectBinding::setMethod()
setObjectProperty in file TMappedStatement.php, method TMappedStatement::setObjectProperty()
Set a property of the result object with appropriate value.
setParameterNames | in file TPreparedStatement.php, method TPreparedStatement::setParameterNames()
setParameterValues | in file TPreparedStatement.php, method TPreparedStatement::setParameterValues()
setPreparedSql | in file TPreparedStatement.php, method TPreparedStatement::setPreparedSql()
setResultObject | in file TMappedStatement.php, method TPostSelectBinding::setResultObject()
setResultProperty | in file TMappedStatement.php, method TPostSelectBinding::setResultProperty()
setStatement | in file TMappedStatement.php, method TPostSelectBinding::setStatement()
top
t
TCachingStatement.php | procedural page TCachingStatement.php
TDeleteMappedStatement.php | procedural page TDeleteMappedStatement.php
TInsertMappedStatement.php | procedural page TInsertMappedStatement.php
TMappedStatement.php | procedural page TMappedStatement.php
TPreparedCommand.php | procedural page TPreparedCommand.php
TPreparedStatement.php | procedural page TPreparedStatement.php
TPreparedStatementFactory.php | procedural page TPreparedStatementFactory.php
TSelectMappedStatement.php | procedural page TSelectMappedStatement.php
TSimpleDynamicSql.php | procedural page TSimpleDynamicSql.php
TStaticSql.php | procedural page TStaticSql.php
TUpdateMappedStatement.php | procedural page TUpdateMappedStatement.php
TCachingStatement in file TCachingStatement.php, class TCachingStatement
TCacheingStatement class.
TDeleteMappedStatement in file TDeleteMappedStatement.php, class TDeleteMappedStatement
TDeleteMappedStatement class.
TInsertMappedStatement in file TInsertMappedStatement.php, class TInsertMappedStatement
TInsertMappedStatement class.
TMappedStatement in file TMappedStatement.php, class TMappedStatement
TMappedStatement class executes SQL mapped statements. Mapped Statements can hold any SQL statement and use Parameter Maps and Result Maps for input and output.
TPostSelectBinding in file TMappedStatement.php, class TPostSelectBinding
TPostSelectBinding class.
TPreparedCommand in file TPreparedCommand.php, class TPreparedCommand
TPreparedCommand class.
TPreparedStatement in file TPreparedStatement.php, class TPreparedStatement
TpreparedStatement class.
TPreparedStatementFactory in file TPreparedStatementFactory.php, class TPreparedStatementFactory
TPreparedStatementFactory class.
TResultSetListItemParameter in file TMappedStatement.php, class TResultSetListItemParameter
TResultSetListItemParameter class
TResultSetMapItemParameter in file TMappedStatement.php, class TResultSetMapItemParameter
TResultSetMapItemParameter class.
TSelectMappedStatement in file TSelectMappedStatement.php, class TSelectMappedStatement
TSelectMappedStatment class.
TSimpleDynamicSql in file TSimpleDynamicSql.php, class TSimpleDynamicSql
TSimpleDynamicSql class.
TSqlMapObjectCollectionTree in file TMappedStatement.php, class TSqlMapObjectCollectionTree
TSQLMapObjectCollectionTree class.
TSqlMapSelect in file TSqlMapStatement.php, class TSqlMapSelect
TSqlMapSelect class file.
TStaticSql in file TStaticSql.php, class TStaticSql
TStaticSql class.
TUpdateMappedStatement in file TUpdateMappedStatement.php, class TUpdateMappedStatement
TUpdateMappedStatement class.


Class Trees for Package System.Data.SqlMap.Statements

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page IMappedStatement.php

File: /Data/SqlMap/Statements/IMappedStatement.php

Remarks

IMappedStatement interface file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: IMappedStatement.php 2541 2008-10-21 15:05:13Z qiang.xue $

Classes in this file:
IMappedStatement
Interface for all mapping statements.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TCachingStatement.php

File: /Data/SqlMap/Statements/TCachingStatement.php

Remarks

TCachingStatement class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TCachingStatement.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCachingStatement
TCacheingStatement class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:40 +0200 by phpDocumentor 1.4.3


Docs for page TDeleteMappedStatement.php

File: /Data/SqlMap/Statements/TDeleteMappedStatement.php

Remarks

TDeleteMappedStatement class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDeleteMappedStatement.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDeleteMappedStatement
TDeleteMappedStatement class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:13 +0200 by phpDocumentor 1.4.3


Docs for page TInsertMappedStatement.php

File: /Data/SqlMap/Statements/TInsertMappedStatement.php

Remarks

TInsertMappedStatement class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TInsertMappedStatement.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TInsertMappedStatement
TInsertMappedStatement class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:37 +0200 by phpDocumentor 1.4.3


Docs for page TMappedStatement.php

File: /Data/SqlMap/Statements/TMappedStatement.php

Remarks

TMappedStatement and related classes.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TMappedStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMappedStatement
TMappedStatement class executes SQL mapped statements. Mapped Statements can hold any SQL statement and use Parameter Maps and Result Maps for input and output.
TPostSelectBinding
TPostSelectBinding class.
TSqlMapObjectCollectionTree
TSQLMapObjectCollectionTree class.
TResultSetListItemParameter
TResultSetListItemParameter class
TResultSetMapItemParameter
TResultSetMapItemParameter class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:48 +0200 by phpDocumentor 1.4.3


Docs for page TPreparedCommand.php

File: /Data/SqlMap/Statements/TPreparedCommand.php

Remarks

TPreparedCommand class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TPreparedCommand.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPreparedCommand
TPreparedCommand class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:03 +0200 by phpDocumentor 1.4.3


Docs for page TPreparedStatement.php

File: /Data/SqlMap/Statements/TPreparedStatement.php

Remarks

TPreparedStatement class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TPreparedStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPreparedStatement
TpreparedStatement class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:03 +0200 by phpDocumentor 1.4.3


Docs for page TPreparedStatementFactory.php

File: /Data/SqlMap/Statements/TPreparedStatementFactory.php

Remarks

TPreparedStatementFactory class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TPreparedStatementFactory.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPreparedStatementFactory
TPreparedStatementFactory class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:03 +0200 by phpDocumentor 1.4.3


Docs for page TSelectMappedStatement.php

File: /Data/SqlMap/Statements/TSelectMappedStatement.php

Remarks

TSelectMappedStatement class.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSelectMappedStatement.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSelectMappedStatement
TSelectMappedStatment class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:20 +0200 by phpDocumentor 1.4.3


Docs for page TSimpleDynamicSql.php

File: /Data/SqlMap/Statements/TSimpleDynamicSql.php

Remarks

TSimpleDynamicSql class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSimpleDynamicSql.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSimpleDynamicSql
TSimpleDynamicSql class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:22 +0200 by phpDocumentor 1.4.3


Docs for page TStaticSql.php

File: /Data/SqlMap/Statements/TStaticSql.php

Remarks

TStaticSql class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TStaticSql.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TStaticSql
TStaticSql class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:29 +0200 by phpDocumentor 1.4.3


Docs for page TUpdateMappedStatement.php

File: /Data/SqlMap/Statements/TUpdateMappedStatement.php

Remarks

TUpdateMappedStatement class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TUpdateMappedStatement.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TUpdateMappedStatement
TUpdateMappedStatement class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:44 +0200 by phpDocumentor 1.4.3


Docs For Class IMappedStatement

Interface IMappedStatement

[line 18]

Location: /Data/SqlMap/Statements/IMappedStatement.php

Remarks

Interface for all mapping statements.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: IMappedStatement.php 2541 2008-10-21 15:05:13Z qiang.xue $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IMappedStatement::executeQueryForList

executeQueryForList(
IDbConnection
$connection, mixed
$parameter, [TList
$result = null], [integer
$skip = -1], [integer
$max = -1] );

    Parameters

    $connection

    database connection to execute the query

    $parameter

    The object used to set the parameters in the SQL.

    $result

    A list to populate the result with.

    $skip

    The number of rows to skip over.

    $max

    The maximum number of rows to return.

    Returns

    A TList of result objects.

    Remarks

    Executes the SQL and retuns a subset of the rows selected.

    access

    public

    [ Top ]

    IMappedStatement::executeQueryForMap

executeQueryForMap(
IDbConnection
$connection, mixed
$parameter, string
$keyProperty, [string
$valueProperty = null] );

    Parameters

    $connection

    database connection to execute the query

    $parameter

    The object used to set the parameters in the SQL.

    $keyProperty

    The property of the result object to be used as the key.

    $valueProperty

    The property of the result object to be used as the value (or null)

    Returns

    A map of object containing the rows keyed by <tt>$keyProperty</tt>.

    Remarks

    Executes the SQL and retuns all rows selected in a map that is keyed on

    the property named in the <tt>$keyProperty</tt> parameter.  The value at  each key will be the value of the property specified  in the  <tt>$valueProperty</tt> parameter.  If <tt>$valueProperty</tt> is  <tt>null</tt>, the entire result object will be entered.

    access

    public

    [ Top ]

    IMappedStatement::executeQueryForObject

executeQueryForObject(
IDbConnection
$connection, mixed
$parameter, [object The
$result = null] );

    Parameters

    $connection

    database connection to execute the query

    $parameter

    The object used to set the parameters in the SQL.

    $result

    result object.

    Remarks

    Executes an SQL statement that returns a single row as an object  of the type of the <tt>$result</tt> passed in as a parameter.

    access

    public

    [ Top ]

    IMappedStatement::executeUpdate

executeUpdate(
IDbConnection
$connection, mixed
$parameter );

    Parameters

    $connection

    database connection to execute the query

    $parameter

    The object used to set the parameters in the SQL.

    Returns

    The number of row effected.

    Remarks

    Execute an update statement. Also used for delete statement. Return the  number of row effected.

    access

    public

    [ Top ]

    IMappedStatement::getID

getID(
 );

    Returns

    Name used to identify the MappedStatement amongst the others.

    access

    public

    [ Top ]

    IMappedStatement::getManager

getManager(
 );

    Returns

    The TSqlMap used by this TMappedStatement

    access

    public

    [ Top ]

    IMappedStatement::getStatement

getStatement(
 );

    Returns

    The SQL statment used by this TMappedStatement.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class TCachingStatement

Class TCachingStatement

[line 21]
TComponent
   |
   --TCachingStatement
Location: /Data/SqlMap/Statements/TCachingStatement.php

Remarks

TCacheingStatement class.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TCachingStatement.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCachingStatement::__construct

    __construct( TMappedStatement $statement );

    Parameters

    $statement

    access

    public

    [ Top ]

    TCachingStatement::createCommand

    createCommand( $connection, $parameter, [ $skip = null], [ $max = null] );

    Parameters

    $connection

    $parameter

    $skip

    $max

    access

    protected

    [ Top ]

    TCachingStatement::executeInsert

    executeInsert( $connection, $parameter );

    Parameters

    $connection

    $parameter

    access

    public

    [ Top ]

    TCachingStatement::executeQueryForList

    executeQueryForList( $connection, $parameter, [ $result = null], [ $skip = -1], [ $max = -1], [ $delegate = null] );

    Implementation of:
    IMappedStatement::executeQueryForList()
    Executes the SQL and retuns a subset of the rows selected.

    Parameters

    $connection

    $parameter

    $result

    $skip

    $max

    $delegate

    access

    public

    [ Top ]

    TCachingStatement::executeQueryForMap

    executeQueryForMap( $connection, $parameter, $keyProperty, [ $valueProperty = null], [ $skip = -1], [ $max = -1], [ $delegate = null] );

    Implementation of:
    IMappedStatement::executeQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on

    Parameters

    $connection

    $parameter

    $keyProperty

    $valueProperty

    $skip

    $max

    $delegate

    access

    public

    [ Top ]

    TCachingStatement::executeQueryForObject

    executeQueryForObject( $connection, $parameter, [ $result = null] );

    Implementation of:
    IMappedStatement::executeQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.

    Parameters

    $connection

    $parameter

    $result

    access

    public

    [ Top ]

    TCachingStatement::executeUpdate

    executeUpdate( $connection, $parameter );

    Implementation of:
    IMappedStatement::executeUpdate()
    Execute an update statement. Also used for delete statement. Return the number of row effected.

    Parameters

    $connection

    $parameter

    access

    public

    [ Top ]

    TCachingStatement::getCacheKey

    getCacheKey( $object );

    Parameters

    $object

    access

    protected

    [ Top ]

    TCachingStatement::getID

    getID( );

    Implementation of:
    IMappedStatement::getID()

    access

    public

    [ Top ]

    TCachingStatement::getManager

    getManager( );

    Implementation of:
    IMappedStatement::getManager()

    access

    public

    [ Top ]

    TCachingStatement::getStatement

    getStatement( );

    Implementation of:
    IMappedStatement::getStatement()

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:40 +0200 by phpDocumentor 1.4.3


Docs For Class TDeleteMappedStatement

Class TDeleteMappedStatement

[line 21]
TComponent
   |
   --TMappedStatement
      |
      --TUpdateMappedStatement
         |
         --TDeleteMappedStatement
Location: /Data/SqlMap/Statements/TDeleteMappedStatement.php

Remarks

TDeleteMappedStatement class.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TDeleteMappedStatement.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TMappedStatement

  • TMappedStatement::QUERY_FOR_ARRAY = 1
  • TMappedStatement::QUERY_FOR_LIST = 0
  • TMappedStatement::QUERY_FOR_OBJECT = 2

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TUpdateMappedStatement

  • TUpdateMappedStatement::executeInsert()
  • TUpdateMappedStatement::executeQueryForList()
  • TUpdateMappedStatement::executeQueryForMap()
  • TUpdateMappedStatement::executeQueryForObject()

Inherited From Class TMappedStatement

  • TMappedStatement::__construct()
    Creates a new mapped statement.
  • TMappedStatement::addResultMapGroupBy()
    ResultMap with GroupBy property. Save object collection graph in a tree and collect the result later.
  • TMappedStatement::applyResultMap()
    Apply result mapping.
  • TMappedStatement::enquequePostSelect()
    Add nested result property to post select queue.
  • TMappedStatement::executeInsert()
    Execute an insert statement. Fill the parameter object with the ouput parameters if any, also could return the insert generated key.
  • TMappedStatement::executePostSelect()
    Process 'select' result properties
  • TMappedStatement::executeQueryForList()
    Executes the SQL and retuns a List of result objects.
  • TMappedStatement::executeQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
  • TMappedStatement::executeQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
  • TMappedStatement::executeSelectKey()
    Execute the select key statement, used to obtain last insert ID.
  • TMappedStatement::executeSQLQueryLimit()
    Execute SQL Query with limits.
  • TMappedStatement::executeUpdate()
    Execute an update statement. Also used for delete statement.
  • TMappedStatement::fillArrayResultMap()
    Retrieve the result map as an array.
  • TMappedStatement::fillDefaultResultMap()
    Fill the result map using default settings. If <tt>$resultMap</tt> is null the result object returned will be guessed from <tt>$resultObject</tt>.
  • TMappedStatement::fillPropertyWithResultMap()
    Fills the property with result mapping results.
  • TMappedStatement::fillResultArrayList()
    Apply the result to a TList or an array.
  • TMappedStatement::fillResultClass()
    Fill the result using ResultClass, will creates new result object if required.
  • TMappedStatement::fillResultMap()
    Fills the result object according to result mappings.
  • TMappedStatement::fillResultObjectProperty()
    Apply the result to an object.
  • TMappedStatement::getCommand()
  • TMappedStatement::getID()
  • TMappedStatement::getManager()
  • TMappedStatement::getPostGeneratedSelectKey()
    Gets the inserted row ID after executing an insert statement.
  • TMappedStatement::getPostSelectKeys()
    Finds in the post select property the SQL statement primary selection keys.
  • TMappedStatement::getPreGeneratedSelectKey()
    Gets the insert generated ID before executing an insert statement.
  • TMappedStatement::getResultMapGroupKey()
    Gets the result 'group by' groupping key for each row.
  • TMappedStatement::getScalarResult()
    Converts the first array value to scalar value of given type.
  • TMappedStatement::getSqlString()
  • TMappedStatement::getStatement()
  • TMappedStatement::initialGroupByResults()
    Empty the group by results cache.
  • TMappedStatement::onExecuteQuery()
    Raise the execute query event.
  • TMappedStatement::raiseRowDelegate()
    Raises delegate handler.
  • TMappedStatement::runQueryForList()
    Executes the SQL and retuns a List of result objects.
  • TMappedStatement::runQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
  • TMappedStatement::runQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
  • TMappedStatement::setObjectProperty()
    Set a property of the result object with appropriate value.
  • TMappedStatement::__sleep()
  • TMappedStatement::__wakeup()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:13 +0200 by phpDocumentor 1.4.3


Docs For Class TInsertMappedStatement

Class TInsertMappedStatement

[line 21]
TComponent
   |
   --TMappedStatement
      |
      --TInsertMappedStatement
Location: /Data/SqlMap/Statements/TInsertMappedStatement.php

Remarks

TInsertMappedStatement class.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TInsertMappedStatement.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TMappedStatement

  • TMappedStatement::QUERY_FOR_ARRAY = 1
  • TMappedStatement::QUERY_FOR_LIST = 0
  • TMappedStatement::QUERY_FOR_OBJECT = 2

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TMappedStatement

  • TMappedStatement::__construct()
    Creates a new mapped statement.
  • TMappedStatement::addResultMapGroupBy()
    ResultMap with GroupBy property. Save object collection graph in a tree and collect the result later.
  • TMappedStatement::applyResultMap()
    Apply result mapping.
  • TMappedStatement::enquequePostSelect()
    Add nested result property to post select queue.
  • TMappedStatement::executeInsert()
    Execute an insert statement. Fill the parameter object with the ouput parameters if any, also could return the insert generated key.
  • TMappedStatement::executePostSelect()
    Process 'select' result properties
  • TMappedStatement::executeQueryForList()
    Executes the SQL and retuns a List of result objects.
  • TMappedStatement::executeQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
  • TMappedStatement::executeQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
  • TMappedStatement::executeSelectKey()
    Execute the select key statement, used to obtain last insert ID.
  • TMappedStatement::executeSQLQueryLimit()
    Execute SQL Query with limits.
  • TMappedStatement::executeUpdate()
    Execute an update statement. Also used for delete statement.
  • TMappedStatement::fillArrayResultMap()
    Retrieve the result map as an array.
  • TMappedStatement::fillDefaultResultMap()
    Fill the result map using default settings. If <tt>$resultMap</tt> is null the result object returned will be guessed from <tt>$resultObject</tt>.
  • TMappedStatement::fillPropertyWithResultMap()
    Fills the property with result mapping results.
  • TMappedStatement::fillResultArrayList()
    Apply the result to a TList or an array.
  • TMappedStatement::fillResultClass()
    Fill the result using ResultClass, will creates new result object if required.
  • TMappedStatement::fillResultMap()
    Fills the result object according to result mappings.
  • TMappedStatement::fillResultObjectProperty()
    Apply the result to an object.
  • TMappedStatement::getCommand()
  • TMappedStatement::getID()
  • TMappedStatement::getManager()
  • TMappedStatement::getPostGeneratedSelectKey()
    Gets the inserted row ID after executing an insert statement.
  • TMappedStatement::getPostSelectKeys()
    Finds in the post select property the SQL statement primary selection keys.
  • TMappedStatement::getPreGeneratedSelectKey()
    Gets the insert generated ID before executing an insert statement.
  • TMappedStatement::getResultMapGroupKey()
    Gets the result 'group by' groupping key for each row.
  • TMappedStatement::getScalarResult()
    Converts the first array value to scalar value of given type.
  • TMappedStatement::getSqlString()
  • TMappedStatement::getStatement()
  • TMappedStatement::initialGroupByResults()
    Empty the group by results cache.
  • TMappedStatement::onExecuteQuery()
    Raise the execute query event.
  • TMappedStatement::raiseRowDelegate()
    Raises delegate handler.
  • TMappedStatement::runQueryForList()
    Executes the SQL and retuns a List of result objects.
  • TMappedStatement::runQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
  • TMappedStatement::runQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
  • TMappedStatement::setObjectProperty()
    Set a property of the result object with appropriate value.
  • TMappedStatement::__sleep()
  • TMappedStatement::__wakeup()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TInsertMappedStatement::executeQueryForList

    executeQueryForList( $connection, $parameter, [ $result = null], [ $skip = -1], [ $max = -1] );

    Overrides TMappedStatement::executeQueryForList() (Executes the SQL and retuns a List of result objects.)

    Parameters

    $connection

    $parameter

    $result

    $skip

    $max

    access

    public

    [ Top ]

    TInsertMappedStatement::executeQueryForMap

    executeQueryForMap( $connection, $parameter, $keyProperty, [ $valueProperty = null] );

    Overrides TMappedStatement::executeQueryForMap() (Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.)

    Parameters

    $connection

    $parameter

    $keyProperty

    $valueProperty

    access

    public

    [ Top ]

    TInsertMappedStatement::executeQueryForObject

    executeQueryForObject( $connection, $parameter, [ $result = null] );

    Overrides TMappedStatement::executeQueryForObject() (Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.)

    Parameters

    $connection

    $parameter

    $result

    access

    public

    [ Top ]

    TInsertMappedStatement::executeUpdate

    executeUpdate( $connection, $parameter );

    Overrides TMappedStatement::executeUpdate() (Execute an update statement. Also used for delete statement.)

    Parameters

    $connection

    $parameter

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:37 +0200 by phpDocumentor 1.4.3


Docs For Class TMappedStatement

Class TMappedStatement

[line 24]
TComponent
   |
   --TMappedStatement
Classes extended from TMappedStatement:
TInsertMappedStatement
TInsertMappedStatement class.
TSelectMappedStatement
TSelectMappedStatment class.
TUpdateMappedStatement
TUpdateMappedStatement class.

Location: /Data/SqlMap/Statements/TMappedStatement.php

Remarks

TMappedStatement class executes SQL mapped statements. Mapped Statements can hold any SQL statement and use Parameter Maps and Result Maps for input and output.

This class is usualy instantiated during SQLMap configuration by TSqlDomBuilder.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TMappedStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • QUERY_FOR_ARRAY =  1
  • QUERY_FOR_LIST =  0
  • QUERY_FOR_OBJECT =  2

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TMappedStatement::__construct

    __construct( $sqlMap, $statement );

    Parameters

    $sqlMap

    an sqlmap.

    $statement

    An SQL statement.

    Remarks

    Creates a new mapped statement.

    access

    public

    [ Top ]

    TMappedStatement::addResultMapGroupBy

    addResultMapGroupBy( TResultMap $resultMap, array $row, object the $parent, &$resultObject );

    Parameters

    $resultMap

    result mapping details.

    $row

    a result set row retrieved from the database

    $parent

    result object

    &$resultObject

    Returns

    object.

    Remarks

    ResultMap with GroupBy property. Save object collection graph in a tree and collect the result later.

    access

    protected

    [ Top ]

    TMappedStatement::applyResultMap

    applyResultMap( array $row, [object the &$resultObject = null] );

    Parameters

    $row

    a result set row retrieved from the database

    &$resultObject

    result object, will create if necessary.

    Returns

    result filled with data, null if not filled.

    Remarks

    Apply result mapping.

    access

    protected

    [ Top ]

    TMappedStatement::enquequePostSelect

    enquequePostSelect( string $select, TResultMap $resultMap, TResultProperty $property, array $row, object the $resultObject );

    Parameters

    $select

    post select statement ID

    $resultMap

    current result mapping details.

    $property

    current result property.

    $row

    a result set row retrieved from the database

    $resultObject

    result object

    Remarks

    Add nested result property to post select queue.

    access

    protected

    [ Top ]

    TMappedStatement::executeInsert

    executeInsert( IDbConnection $connection, mixed $parameter );

    Overridden in child classes as:

    TSelectMappedStatement::executeInsert()
    TUpdateMappedStatement::executeInsert()

    Parameters

    $connection

    database connection

    $parameter

    The parameter object used to fill the statement.

    Returns

    the insert generated key.

    Remarks

    Execute an insert statement. Fill the parameter object with the ouput parameters if any, also could return the insert generated key.

    access

    public

    [ Top ]

    TMappedStatement::executePostSelect

    executePostSelect( IDbConnection $connection );

    Parameters

    $connection

    database connection

    Remarks

    Process 'select' result properties

    access

    protected

    [ Top ]

    TMappedStatement::executeQueryForList

    executeQueryForList( IDbConnection $connection, mixed $parameter, [object result $result = null], [integer $skip = -1], [integer $max = -1], [callback $delegate = null] );

    Overridden in child classes as:

    TInsertMappedStatement::executeQueryForList()
    TUpdateMappedStatement::executeQueryForList()

    Implementation of:
    IMappedStatement::executeQueryForList()
    Executes the SQL and retuns a subset of the rows selected.

    Parameters

    $connection

    database connection

    $parameter

    The object used to set the parameters in the SQL.

    $result

    collection object.

    $skip

    The number of rows to skip over.

    $max

    The maximum number of rows to return.

    $delegate

    row delegate handler

    Returns

    a list of result objects

    Remarks

    Executes the SQL and retuns a List of result objects.

    see

    TMappedStatement::executeQueryForList()

    access

    public

    [ Top ]

    TMappedStatement::executeQueryForMap

    executeQueryForMap( IDbConnection $connection, mixed $parameter, string $keyProperty, [string $valueProperty = null], [callback $skip = -1], [ $max = -1], [ $delegate = null] );

    Overridden in child classes as:

    TInsertMappedStatement::executeQueryForMap()
    TUpdateMappedStatement::executeQueryForMap()

    Implementation of:
    IMappedStatement::executeQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on

    Parameters

    $connection

    database connection

    $parameter

    The object used to set the parameters in the SQL.

    $keyProperty

    The property of the result object to be used as the key.

    $valueProperty

    The property of the result object to be used as the value (or null).

    $skip

    row delegate handler

    $max

    $delegate

    Returns

    An array of object containing the rows keyed by keyProperty.

    Remarks

    Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.

    If valueProperty is null, the entire result object will be entered.

    access

    public

    [ Top ]

    TMappedStatement::executeQueryForObject

    executeQueryForObject( IDbConnection $connection, mixed $parameter, [mixed $result = null] );

    Overridden in child classes as:

    TInsertMappedStatement::executeQueryForObject()
    TUpdateMappedStatement::executeQueryForObject()

    Implementation of:
    IMappedStatement::executeQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.

    Parameters

    $connection

    database connection

    $parameter

    The parameter data (object, arrary, primitive) used to set the parameters in the SQL

    $result

    The result object.

    Remarks

    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.

    access

    public

    [ Top ]

    TMappedStatement::executeSelectKey

    executeSelectKey( IDbConnection $connection, mixed $parameter, TSqlMapSelectKey $selectKey );

    Parameters

    $connection

    database connection

    $parameter

    insert statement parameter

    $selectKey

    select key statement

    Returns

    last insert ID.

    Remarks

    Execute the select key statement, used to obtain last insert ID.

    access

    protected

    [ Top ]

    TMappedStatement::executeSQLQueryLimit

    executeSQLQueryLimit( IDbConnection $connection, array $command, $max, $skip );

    Parameters

    $connection

    database connection

    $command

    SQL statement and parameters.

    $max

    $skip

    Returns

    record set if applicable.

    Remarks

    Execute SQL Query with limits.

    throws

    TSqlMapQueryExecutionException if any execution error

    throws

    TSqlMapExecutionException if execution error or false record set.

    access

    protected

    [ Top ]

    TMappedStatement::executeUpdate

    executeUpdate( IDbConnection $connection, mixed $parameter );

    Overridden in child classes as:

    TInsertMappedStatement::executeUpdate()
    TSelectMappedStatement::executeUpdate()

    Implementation of:
    IMappedStatement::executeUpdate()
    Execute an update statement. Also used for delete statement. Return the number of row effected.

    Parameters

    $connection

    database connection

    $parameter

    The object used to set the parameters in the SQL.

    Returns

    The number of rows effected.

    Remarks

    Execute an update statement. Also used for delete statement.

    Return the number of rows effected.

    access

    public

    [ Top ]

    TMappedStatement::fillArrayResultMap

    fillArrayResultMap( TResultMap $resultMap, array $row, object the $resultObject );

    Parameters

    $resultMap

    result mapping details.

    $row

    a result set row retrieved from the database

    $resultObject

    result object

    Returns

    array list of result objects.

    Remarks

    Retrieve the result map as an array.

    access

    protected

    [ Top ]

    TMappedStatement::fillDefaultResultMap

    fillDefaultResultMap( TResultMap $resultMap, array $row, object the $resultObject );

    Parameters

    $resultMap

    result mapping details.

    $row

    a result set row retrieved from the database

    $resultObject

    result object

    Returns

    the result object filled with data.

    Remarks

    Fill the result map using default settings. If <tt>$resultMap</tt> is null the result object returned will be guessed from <tt>$resultObject</tt>.

    access

    protected

    [ Top ]

    TMappedStatement::fillPropertyWithResultMap

    fillPropertyWithResultMap( TResultMap $resultMap, array $row, object the &$resultObject );

    Parameters

    $resultMap

    nested result mapping details.

    $row

    a result set row retrieved from the database

    &$resultObject

    result object

    Returns

    true if the data was found, false otherwise.

    Remarks

    Fills the property with result mapping results.

    access

    protected

    [ Top ]

    TMappedStatement::fillResultArrayList

    fillResultArrayList( array $row, object result $resultObject );

    Parameters

    $row

    a result set row retrieved from the database

    $resultObject

    object, array or list

    Returns

    filled with data.

    Remarks

    Apply the result to a TList or an array.

    access

    protected

    [ Top ]

    TMappedStatement::fillResultClass

    fillResultClass( string $resultClass, array $row, object the $resultObject );

    Parameters

    $resultClass

    result object class name

    $row

    a result set row retrieved from the database

    $resultObject

    result object, will create if necessary.

    Returns

    object filled with data

    Remarks

    Fill the result using ResultClass, will creates new result object if required.

    access

    protected

    [ Top ]

    TMappedStatement::fillResultMap

    fillResultMap( string $resultMapName, array $row, [object result $parentGroup = null], [ &$resultObject = null] );

    Parameters

    $resultMapName

    result map name.

    $row

    a result set row retrieved from the database

    $parentGroup

    object to fill, will create new instances if required.

    &$resultObject

    Returns

    object filled with data.

    Remarks

    Fills the result object according to result mappings.

    access

    protected

    [ Top ]

    TMappedStatement::fillResultObjectProperty

    fillResultObjectProperty( array $row, object result $resultObject );

    Parameters

    $row

    a result set row retrieved from the database

    $resultObject

    object, array or list

    Returns

    filled with data.

    Remarks

    Apply the result to an object.

    access

    protected

    [ Top ]

    TMappedStatement::getCommand

    getCommand( );

    Returns

    command to prepare SQL statements.

    access

    public

    [ Top ]

    TMappedStatement::getID

    getID( );

    Implementation of:
    IMappedStatement::getID()

    Returns

    Name used to identify the TMappedStatement amongst the others. This the name of the SQL statement by default.

    access

    public

    [ Top ]

    TMappedStatement::getManager

    getManager( );

    Implementation of:
    IMappedStatement::getManager()

    Returns

    The SqlMap used by this MappedStatement

    access

    public

    [ Top ]

    TMappedStatement::getPostGeneratedSelectKey

    getPostGeneratedSelectKey( IDbConnection $connection, mixed $parameter );

    Parameters

    $connection

    database connection

    $parameter

    insert statement parameter.

    Returns

    last insert ID, null otherwise.

    Remarks

    Gets the inserted row ID after executing an insert statement.

    access

    protected

    [ Top ]

    TMappedStatement::getPostSelectKeys

    getPostSelectKeys( TResultMap $resultMap, TResultProperty $property, array $row );

    Parameters

    $resultMap

    result mapping details

    $property

    result property

    $row

    current row data.

    Returns

    list of primary key values.

    Remarks

    Finds in the post select property the SQL statement primary selection keys.

    access

    protected

    [ Top ]

    TMappedStatement::getPreGeneratedSelectKey

    getPreGeneratedSelectKey( IDbConnection $connection, mixed $parameter );

    Parameters

    $connection

    database connection

    $parameter

    insert statement parameter.

    Returns

    new insert ID if pre-select key statement was executed, null otherwise.

    Remarks

    Gets the insert generated ID before executing an insert statement.

    access

    protected

    [ Top ]

    TMappedStatement::getResultMapGroupKey

    getResultMapGroupKey( TResultMap $resultMap, array $row );

    Parameters

    $resultMap

    result mapping details.

    $row

    a result set row retrieved from the database

    Returns

    groupping key.

    Remarks

    Gets the result 'group by' groupping key for each row.

    access

    protected

    [ Top ]

    TMappedStatement::getScalarResult

    getScalarResult( array $result, string $type );

    Parameters

    $result

    list of results

    $type

    scalar type.

    Returns

    scalar value.

    Remarks

    Converts the first array value to scalar value of given type.

    access

    protected

    [ Top ]

    TMappedStatement::getSqlString

    getSqlString( );

    access

    public

    [ Top ]

    TMappedStatement::getStatement

    getStatement( );

    Implementation of:
    IMappedStatement::getStatement()

    Returns

    The SQL statment used by this MappedStatement

    access

    public

    [ Top ]

    TMappedStatement::initialGroupByResults

    initialGroupByResults( );

    Remarks

    Empty the group by results cache.

    access

    protected

    [ Top ]

    TMappedStatement::onExecuteQuery

    onExecuteQuery( array $sql );

    Parameters

    $sql

    prepared SQL statement and subsititution parameters

    Remarks

    Raise the execute query event.

    access

    public

    [ Top ]

    TMappedStatement::raiseRowDelegate

    raiseRowDelegate( object event $handler, $param );

    Parameters

    $handler

    parameter

    $param

    Remarks

    Raises delegate handler.

    This method is invoked for each new list item. It is the responsibility of the handler to add the item to the list.

    access

    protected

    [ Top ]

    TMappedStatement::runQueryForList

    runQueryForList( IDbConnection $connection, mixed $parameter, array $sql, object result $result, [integer $delegate = null], integer 5, callback 6 );

    Parameters

    5

    The maximum number of rows to return.

    6

    row delegate handler

    $connection

    database connection

    $parameter

    The object used to set the parameters in the SQL.

    $sql

    SQL string and subsititution parameters.

    $result

    collection object.

    $delegate

    The number of rows to skip over.

    Returns

    a list of result objects

    Remarks

    Executes the SQL and retuns a List of result objects.

    This method should only be called by internal developers, consider using <tt>executeQueryForList()</tt> first.

    see

    TMappedStatement::executeQueryForList()

    access

    public

    [ Top ]

    TMappedStatement::runQueryForMap

    runQueryForMap( IDbConnection $connection, mixed $parameter, array $command, string $keyProperty, [string $valueProperty = null], [callback $delegate = null] );

    Parameters

    $connection

    database connection

    $parameter

    The object used to set the parameters in the SQL.

    $command

    SQL string and subsititution parameters.

    $keyProperty

    The property of the result object to be used as the key.

    $valueProperty

    The property of the result object to be used as the value (or null).

    $delegate

    row delegate, a callback function

    Returns

    An array of object containing the rows keyed by keyProperty.

    Remarks

    Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.

    If valueProperty is null, the entire result object will be entered.

    This method should only be called by internal developers, consider using <tt>executeQueryForMap()</tt> first.

    see

    TMappedStatement::executeQueryForMap()

    access

    public

    [ Top ]

    TMappedStatement::runQueryForObject

    runQueryForObject( IDbConnection $connection, array $command, object The &$result );

    Parameters

    $connection

    database connection

    $command

    SQL string and subsititution parameters.

    &$result

    result object.

    Returns

    object.

    Remarks

    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.

    This method should only be called by internal developers, consider using <tt>executeQueryForObject()</tt> first.

    see

    TMappedStatement::executeQueryForObject()

    access

    public

    [ Top ]

    TMappedStatement::setObjectProperty

    setObjectProperty( TResultMap $resultMap, TResultProperty $property, array $row, object the &$resultObject );

    Parameters

    $resultMap

    result mapping details.

    $property

    the result property to fill.

    $row

    a result set row retrieved from the database

    &$resultObject

    result object

    Remarks

    Set a property of the result object with appropriate value.

    access

    protected

    [ Top ]

    TMappedStatement::__sleep

    __sleep( );

    Overrides TComponent::__sleep() (Returns an array with the names of all variables of that object that should be serialized.)

    access

    public

    [ Top ]

    TMappedStatement::__wakeup

    __wakeup( );

    Overrides TComponent::__wakeup() (Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.)

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • QUERY_FOR_ARRAY =  1 [line 64]

    • var

    select is to query for list.

  • QUERY_FOR_LIST =  0 [line 59]

    • var

    select is to query for list.

  • QUERY_FOR_OBJECT =  2 [line 69]

    • var

    select is to query for object.

Documentation generated on Mon, 25 Jun 2012 14:44:48 +0200 by phpDocumentor 1.4.3


Docs For Class TPostSelectBinding

Class TPostSelectBinding

[line 946]

Location: /Data/SqlMap/Statements/TMappedStatement.php

Remarks

TPostSelectBinding class.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TMappedStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TPostSelectBinding::getKeys

getKeys(
 );

    access

    public

    [ Top ]

    TPostSelectBinding::getMethod

getMethod(
 );

    access

    public

    [ Top ]

    TPostSelectBinding::getResultObject

getResultObject(
 );

    access

    public

    [ Top ]

    TPostSelectBinding::getResultProperty

getResultProperty(
 );

    access

    public

    [ Top ]

    TPostSelectBinding::getStatement

getStatement(
 );

    access

    public

    [ Top ]

    TPostSelectBinding::setKeys

setKeys(

$value );

    Parameters

    $value

    access

    public

    [ Top ]

    TPostSelectBinding::setMethod

setMethod(

$value );

    Parameters

    $value

    access

    public

    [ Top ]

    TPostSelectBinding::setResultObject

setResultObject(

$value );

    Parameters

    $value

    access

    public

    [ Top ]

    TPostSelectBinding::setResultProperty

setResultProperty(

$value );

    Parameters

    $value

    access

    public

    [ Top ]

    TPostSelectBinding::setStatement

setStatement(

$value );

    Parameters

    $value

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:49 +0200 by phpDocumentor 1.4.3


Docs For Class TResultSetListItemParameter

Class TResultSetListItemParameter

[line 1170]
TComponent
   |
   --TResultSetListItemParameter
Location: /Data/SqlMap/Statements/TMappedStatement.php

Remarks

TResultSetListItemParameter class

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TMappedStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TResultSetListItemParameter::__construct

    __construct( $result, $parameter, &$list );

    Parameters

    $result

    $parameter

    &$list

    access

    public

    [ Top ]

    TResultSetListItemParameter::getList

    &getList( );

    access

    public

    [ Top ]

    TResultSetListItemParameter::getParameter

    getParameter( );

    access

    public

    [ Top ]

    TResultSetListItemParameter::getResult

    getResult( );

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:49 +0200 by phpDocumentor 1.4.3


Docs For Class TResultSetMapItemParameter

Class TResultSetMapItemParameter

[line 1207]
TComponent
   |
   --TResultSetMapItemParameter
Location: /Data/SqlMap/Statements/TMappedStatement.php

Remarks

TResultSetMapItemParameter class.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TMappedStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TResultSetMapItemParameter::__construct

    __construct( $key, $value, $parameter, &$map );

    Parameters

    $key

    $value

    $parameter

    &$map

    access

    public

    [ Top ]

    TResultSetMapItemParameter::getKey

    getKey( );

    access

    public

    [ Top ]

    TResultSetMapItemParameter::getMap

    &getMap( );

    access

    public

    [ Top ]

    TResultSetMapItemParameter::getParameter

    getParameter( );

    access

    public

    [ Top ]

    TResultSetMapItemParameter::getValue

    getValue( );

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:49 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapObjectCollectionTree

Class TSqlMapObjectCollectionTree

[line 982]
TComponent
   |
   --TSqlMapObjectCollectionTree
Location: /Data/SqlMap/Statements/TMappedStatement.php

Remarks

TSQLMapObjectCollectionTree class.

Maps object collection graphs as trees. Nodes in the collection can be add using parent relationships. The object collections can be build using the collect method.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TMappedStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqlMapObjectCollectionTree::add

    add( string $parent, string $node, [mixed $object = ''] );

    Parameters

    $parent

    parent node id

    $node

    new node id

    $object

    node value

    Remarks

    Add a new node to the object tree graph.

    access

    public

    [ Top ]

    TSqlMapObjectCollectionTree::addNode

    addNode( array &$childs, string $parent, string $node );

    Parameters

    &$childs

    list of nodes to check

    $parent

    parent node id

    $node

    new node id

    Returns

    true if parent node is found.

    Remarks

    Find the parent node and add the new node as its child.

    access

    protected

    [ Top ]

    TSqlMapObjectCollectionTree::collect

    collect( );

    Returns

    object collection

    access

    public

    [ Top ]

    TSqlMapObjectCollectionTree::collectChildren

    collectChildren( string $parent, array &$nodes );

    Parameters

    $parent

    parent node id

    &$nodes

    list of child nodes.

    Remarks

    Visit all the child nodes and collect them by removing.

    access

    protected

    [ Top ]

    TSqlMapObjectCollectionTree::getCollection

    getCollection( );

    Returns

    object collection.

    access

    protected

    [ Top ]

    TSqlMapObjectCollectionTree::hasChildren

    hasChildren( array &$nodes );

    Parameters

    &$nodes

    list of nodes to check

    Returns

    true if all nodes are leaf nodes, false otherwise

    access

    protected

    [ Top ]

    TSqlMapObjectCollectionTree::isEmpty

    isEmpty( );

    Returns

    true if the graph is empty

    access

    public

    [ Top ]

    TSqlMapObjectCollectionTree::onChildNodesVisited

    onChildNodesVisited( string $parent, array $nodes );

    Parameters

    $parent

    parent node id

    $nodes

    list of child nodes visited.

    Remarks

    Set the object properties for all the child nodes visited.

    access

    protected

    [ Top ]

    TSqlMapObjectCollectionTree::__sleep

    __sleep( );

    Overrides TComponent::__sleep() (Returns an array with the names of all variables of that object that should be serialized.)

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:49 +0200 by phpDocumentor 1.4.3


Docs For Class TPreparedCommand

Class TPreparedCommand

[line 24]

Location: /Data/SqlMap/Statements/TPreparedCommand.php

Remarks

TPreparedCommand class.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TPreparedCommand.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TPreparedCommand::applyParameterMap

applyParameterMap(

$manager,
$command,
$prepared,
$statement,
$parameterObject );

    Parameters

    $manager

    $command

    $prepared

    $statement

    $parameterObject

    access

    protected

    [ Top ]

    TPreparedCommand::create

create(

$manager,
$connection,
$statement,
$parameterObject, [
$skip = null], [
$max = null] );

    Parameters

    $manager

    $connection

    $statement

    $parameterObject

    $skip

    $max

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:03 +0200 by phpDocumentor 1.4.3


Docs For Class TPreparedStatement

Class TPreparedStatement

[line 21]
TComponent
   |
   --TPreparedStatement
Location: /Data/SqlMap/Statements/TPreparedStatement.php

Remarks

TpreparedStatement class.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TPreparedStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPreparedStatement::__construct

    __construct( );

    access

    public

    [ Top ]

    TPreparedStatement::getParameterNames

    getParameterNames( );

    access

    public

    [ Top ]

    TPreparedStatement::getParameterValues

    getParameterValues( );

    access

    public

    [ Top ]

    TPreparedStatement::getPreparedSql

    getPreparedSql( );

    access

    public

    [ Top ]

    TPreparedStatement::setParameterNames

    setParameterNames( $value );

    Parameters

    $value

    access

    public

    [ Top ]

    TPreparedStatement::setParameterValues

    setParameterValues( $value );

    Parameters

    $value

    access

    public

    [ Top ]

    TPreparedStatement::setPreparedSql

    setPreparedSql( $value );

    Parameters

    $value

    access

    public

    [ Top ]

    TPreparedStatement::__sleep

    __sleep( );

    Overrides TComponent::__sleep() (Returns an array with the names of all variables of that object that should be serialized.)

    access

    public

    [ Top ]

    TPreparedStatement::__wakeup

    __wakeup( );

    Overrides TComponent::__wakeup() (Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.)

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:03 +0200 by phpDocumentor 1.4.3


Docs For Class TPreparedStatementFactory

Class TPreparedStatementFactory

[line 21]

Location: /Data/SqlMap/Statements/TPreparedStatementFactory.php

Remarks

TPreparedStatementFactory class.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TPreparedStatementFactory.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TPreparedStatementFactory::__construct

__construct(

$statement,
$sqlString );

    Parameters

    $statement

    $sqlString

    access

    public

    [ Top ]

    TPreparedStatementFactory::createParametersForTextCommand

createParametersForTextCommand(
 );

    access

    protected

    [ Top ]

    TPreparedStatementFactory::prepare

prepare(
 );

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:03 +0200 by phpDocumentor 1.4.3


Docs For Class TSelectMappedStatement

Class TSelectMappedStatement

[line 21]
TComponent
   |
   --TMappedStatement
      |
      --TSelectMappedStatement
Location: /Data/SqlMap/Statements/TSelectMappedStatement.php

Remarks

TSelectMappedStatment class.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSelectMappedStatement.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TMappedStatement

  • TMappedStatement::QUERY_FOR_ARRAY = 1
  • TMappedStatement::QUERY_FOR_LIST = 0
  • TMappedStatement::QUERY_FOR_OBJECT = 2

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TMappedStatement

  • TMappedStatement::__construct()
    Creates a new mapped statement.
  • TMappedStatement::addResultMapGroupBy()
    ResultMap with GroupBy property. Save object collection graph in a tree and collect the result later.
  • TMappedStatement::applyResultMap()
    Apply result mapping.
  • TMappedStatement::enquequePostSelect()
    Add nested result property to post select queue.
  • TMappedStatement::executeInsert()
    Execute an insert statement. Fill the parameter object with the ouput parameters if any, also could return the insert generated key.
  • TMappedStatement::executePostSelect()
    Process 'select' result properties
  • TMappedStatement::executeQueryForList()
    Executes the SQL and retuns a List of result objects.
  • TMappedStatement::executeQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
  • TMappedStatement::executeQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
  • TMappedStatement::executeSelectKey()
    Execute the select key statement, used to obtain last insert ID.
  • TMappedStatement::executeSQLQueryLimit()
    Execute SQL Query with limits.
  • TMappedStatement::executeUpdate()
    Execute an update statement. Also used for delete statement.
  • TMappedStatement::fillArrayResultMap()
    Retrieve the result map as an array.
  • TMappedStatement::fillDefaultResultMap()
    Fill the result map using default settings. If <tt>$resultMap</tt> is null the result object returned will be guessed from <tt>$resultObject</tt>.
  • TMappedStatement::fillPropertyWithResultMap()
    Fills the property with result mapping results.
  • TMappedStatement::fillResultArrayList()
    Apply the result to a TList or an array.
  • TMappedStatement::fillResultClass()
    Fill the result using ResultClass, will creates new result object if required.
  • TMappedStatement::fillResultMap()
    Fills the result object according to result mappings.
  • TMappedStatement::fillResultObjectProperty()
    Apply the result to an object.
  • TMappedStatement::getCommand()
  • TMappedStatement::getID()
  • TMappedStatement::getManager()
  • TMappedStatement::getPostGeneratedSelectKey()
    Gets the inserted row ID after executing an insert statement.
  • TMappedStatement::getPostSelectKeys()
    Finds in the post select property the SQL statement primary selection keys.
  • TMappedStatement::getPreGeneratedSelectKey()
    Gets the insert generated ID before executing an insert statement.
  • TMappedStatement::getResultMapGroupKey()
    Gets the result 'group by' groupping key for each row.
  • TMappedStatement::getScalarResult()
    Converts the first array value to scalar value of given type.
  • TMappedStatement::getSqlString()
  • TMappedStatement::getStatement()
  • TMappedStatement::initialGroupByResults()
    Empty the group by results cache.
  • TMappedStatement::onExecuteQuery()
    Raise the execute query event.
  • TMappedStatement::raiseRowDelegate()
    Raises delegate handler.
  • TMappedStatement::runQueryForList()
    Executes the SQL and retuns a List of result objects.
  • TMappedStatement::runQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
  • TMappedStatement::runQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
  • TMappedStatement::setObjectProperty()
    Set a property of the result object with appropriate value.
  • TMappedStatement::__sleep()
  • TMappedStatement::__wakeup()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSelectMappedStatement::executeInsert

    executeInsert( $connection, $parameter );

    Overrides TMappedStatement::executeInsert() (Execute an insert statement. Fill the parameter object with the ouput parameters if any, also could return the insert generated key.)

    Parameters

    $connection

    $parameter

    access

    public

    [ Top ]

    TSelectMappedStatement::executeUpdate

    executeUpdate( $connection, $parameter );

    Overrides TMappedStatement::executeUpdate() (Execute an update statement. Also used for delete statement.)

    Parameters

    $connection

    $parameter

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:20 +0200 by phpDocumentor 1.4.3


Docs For Class TSimpleDynamicSql

Class TSimpleDynamicSql

[line 21]
TComponent
   |
   --TStaticSql
      |
      --TSimpleDynamicSql
Location: /Data/SqlMap/Statements/TSimpleDynamicSql.php

Remarks

TSimpleDynamicSql class.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSimpleDynamicSql.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TStaticSql

  • TStaticSql::buildPreparedStatement()
  • TStaticSql::getPreparedStatement()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSimpleDynamicSql::__construct

    __construct( $mappings );

    Parameters

    $mappings

    access

    public

    [ Top ]

    TSimpleDynamicSql::replaceDynamicParameter

    replaceDynamicParameter( $sql, $parameter );

    Parameters

    $sql

    $parameter

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:22 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapSelect

Class TSqlMapSelect

[line 326]
TComponent
   |
   --TSqlMapStatement
      |
      --TSqlMapSelect
Location: /Data/SqlMap/Configuration/TSqlMapStatement.php

Remarks

TSqlMapSelect class file.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapStatement

  • TSqlMapStatement::createInstanceOf()
    Create a new instance of a given type.
  • TSqlMapStatement::createInstanceOfListClass()
  • TSqlMapStatement::createInstanceOfResultClass()
    Create a new instance of result class.
  • TSqlMapStatement::getCache()
  • TSqlMapStatement::getCacheModel()
  • TSqlMapStatement::getExtends()
  • TSqlMapStatement::getID()
  • TSqlMapStatement::getListClass()
  • TSqlMapStatement::getParameterClass()
  • TSqlMapStatement::getParameterMap()
  • TSqlMapStatement::getResultClass()
  • TSqlMapStatement::getResultMap()
  • TSqlMapStatement::getSqlText()
  • TSqlMapStatement::initialize()
  • TSqlMapStatement::parameterMap()
  • TSqlMapStatement::resultMap()
  • TSqlMapStatement::setCache()
  • TSqlMapStatement::setCacheModel()
  • TSqlMapStatement::setExtends()
  • TSqlMapStatement::setID()
  • TSqlMapStatement::setInlineParameterMap()
  • TSqlMapStatement::setListClass()
    An ArrayAccess class can be specified to handle the type of objects in the collection.
  • TSqlMapStatement::setParameterClass()
    If a ParameterMap property is not specified, you may specify a ParameterClass instead and use inline parameters.
  • TSqlMapStatement::setParameterMap()
    A Parameter Map defines an ordered list of values that match up with the "?" placeholders of a standard, parameterized query statement.
  • TSqlMapStatement::setResultClass()
    If a ResultMap is not specified, you may specify a
  • TSqlMapStatement::setResultMap()
    A Result Map lets you control how data is extracted from the result of a query, and how the columns are mapped to object properties.
  • TSqlMapStatement::setSqlText()
  • TSqlMapStatement::__sleep()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqlMapSelect::getGenerate

    getGenerate( );

    access

    public

    [ Top ]

    TSqlMapSelect::setGenerate

    setGenerate( $value );

    Parameters

    $value

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:27 +0200 by phpDocumentor 1.4.3


Docs For Class TStaticSql

Class TStaticSql

[line 21]
TComponent
   |
   --TStaticSql
Classes extended from TStaticSql:
TSimpleDynamicSql
TSimpleDynamicSql class.

Location: /Data/SqlMap/Statements/TStaticSql.php

Remarks

TStaticSql class.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TStaticSql.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TStaticSql::buildPreparedStatement

    buildPreparedStatement( $statement, $sqlString );

    Parameters

    $statement

    $sqlString

    access

    public

    [ Top ]

    TStaticSql::getPreparedStatement

    getPreparedStatement( [ $parameter = null] );

    Parameters

    $parameter

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:29 +0200 by phpDocumentor 1.4.3


Docs For Class TUpdateMappedStatement

Class TUpdateMappedStatement

[line 21]
TComponent
   |
   --TMappedStatement
      |
      --TUpdateMappedStatement
Classes extended from TUpdateMappedStatement:
TDeleteMappedStatement
TDeleteMappedStatement class.

Location: /Data/SqlMap/Statements/TUpdateMappedStatement.php

Remarks

TUpdateMappedStatement class.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TUpdateMappedStatement.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TMappedStatement

  • TMappedStatement::QUERY_FOR_ARRAY = 1
  • TMappedStatement::QUERY_FOR_LIST = 0
  • TMappedStatement::QUERY_FOR_OBJECT = 2

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TMappedStatement

  • TMappedStatement::__construct()
    Creates a new mapped statement.
  • TMappedStatement::addResultMapGroupBy()
    ResultMap with GroupBy property. Save object collection graph in a tree and collect the result later.
  • TMappedStatement::applyResultMap()
    Apply result mapping.
  • TMappedStatement::enquequePostSelect()
    Add nested result property to post select queue.
  • TMappedStatement::executeInsert()
    Execute an insert statement. Fill the parameter object with the ouput parameters if any, also could return the insert generated key.
  • TMappedStatement::executePostSelect()
    Process 'select' result properties
  • TMappedStatement::executeQueryForList()
    Executes the SQL and retuns a List of result objects.
  • TMappedStatement::executeQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
  • TMappedStatement::executeQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
  • TMappedStatement::executeSelectKey()
    Execute the select key statement, used to obtain last insert ID.
  • TMappedStatement::executeSQLQueryLimit()
    Execute SQL Query with limits.
  • TMappedStatement::executeUpdate()
    Execute an update statement. Also used for delete statement.
  • TMappedStatement::fillArrayResultMap()
    Retrieve the result map as an array.
  • TMappedStatement::fillDefaultResultMap()
    Fill the result map using default settings. If <tt>$resultMap</tt> is null the result object returned will be guessed from <tt>$resultObject</tt>.
  • TMappedStatement::fillPropertyWithResultMap()
    Fills the property with result mapping results.
  • TMappedStatement::fillResultArrayList()
    Apply the result to a TList or an array.
  • TMappedStatement::fillResultClass()
    Fill the result using ResultClass, will creates new result object if required.
  • TMappedStatement::fillResultMap()
    Fills the result object according to result mappings.
  • TMappedStatement::fillResultObjectProperty()
    Apply the result to an object.
  • TMappedStatement::getCommand()
  • TMappedStatement::getID()
  • TMappedStatement::getManager()
  • TMappedStatement::getPostGeneratedSelectKey()
    Gets the inserted row ID after executing an insert statement.
  • TMappedStatement::getPostSelectKeys()
    Finds in the post select property the SQL statement primary selection keys.
  • TMappedStatement::getPreGeneratedSelectKey()
    Gets the insert generated ID before executing an insert statement.
  • TMappedStatement::getResultMapGroupKey()
    Gets the result 'group by' groupping key for each row.
  • TMappedStatement::getScalarResult()
    Converts the first array value to scalar value of given type.
  • TMappedStatement::getSqlString()
  • TMappedStatement::getStatement()
  • TMappedStatement::initialGroupByResults()
    Empty the group by results cache.
  • TMappedStatement::onExecuteQuery()
    Raise the execute query event.
  • TMappedStatement::raiseRowDelegate()
    Raises delegate handler.
  • TMappedStatement::runQueryForList()
    Executes the SQL and retuns a List of result objects.
  • TMappedStatement::runQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
  • TMappedStatement::runQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
  • TMappedStatement::setObjectProperty()
    Set a property of the result object with appropriate value.
  • TMappedStatement::__sleep()
  • TMappedStatement::__wakeup()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TUpdateMappedStatement::executeInsert

    executeInsert( $connection, $parameter );

    Overrides TMappedStatement::executeInsert() (Execute an insert statement. Fill the parameter object with the ouput parameters if any, also could return the insert generated key.)

    Parameters

    $connection

    $parameter

    access

    public

    [ Top ]

    TUpdateMappedStatement::executeQueryForList

    executeQueryForList( $connection, $parameter, [ $result = null], [ $skip = -1], [ $max = -1] );

    Overrides TMappedStatement::executeQueryForList() (Executes the SQL and retuns a List of result objects.)

    Parameters

    $connection

    $parameter

    $result

    $skip

    $max

    access

    public

    [ Top ]

    TUpdateMappedStatement::executeQueryForMap

    executeQueryForMap( $connection, $parameter, $keyProperty, [ $valueProperty = null] );

    Overrides TMappedStatement::executeQueryForMap() (Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.)

    Parameters

    $connection

    $parameter

    $keyProperty

    $valueProperty

    access

    public

    [ Top ]

    TUpdateMappedStatement::executeQueryForObject

    executeQueryForObject( $connection, $parameter, [ $result = null] );

    Overrides TMappedStatement::executeQueryForObject() (Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.)

    Parameters

    $connection

    $parameter

    $result

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:44 +0200 by phpDocumentor 1.4.3


Package System Element Index

Element index for package System

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a c d e f g h i k l n o p r s t u v w _
top
_
$_s | in file TComponent.php, variable TJavaScriptLiteral::$_s
__call in file TComponent.php, method TComponent::__call()
Calls a method.
__construct in file TComponent.php, method TComponentReflection::__construct()
Constructor.
__construct in file TApplication.php, method TApplication::__construct()
Constructor.
__construct | in file TComponent.php, method TEnumerable::__construct()
__construct | in file TComponent.php, method TJavaScriptLiteral::__construct()
__get in file TComponent.php, method TComponent::__get()
Returns a property value or an event handler list by property or event name.
__set in file TComponent.php, method TComponent::__set()
Sets value of a component property.
__sleep in file TComponent.php, method TComponent::__sleep()
Returns an array with the names of all variables of that object that should be serialized.
__toString | in file TComponent.php, method TJavaScriptLiteral::__toString()
__wakeup in file TComponent.php, method TComponent::__wakeup()
Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.
top
a
add in file interfaces.php, method ICache::add()
Stores a value identified by a key into cache if the cache does not contain this key.
addParsedObject in file TComponent.php, method TComponent::addParsedObject()
Processes an object that is created during parsing template.
applyConfiguration in file TApplication.php, method TApplication::applyConfiguration()
Applies an application configuration.
attachEventHandler in file TComponent.php, method TComponent::attachEventHandler()
Attaches an event handler to an event.
autoload in file PradoBase.php, method PradoBase::autoload()
Class autoload loader.
top
c
$classExists | in file PradoBase.php, variable PradoBase::$classExists
CACHE_NAME in file TApplication.php, class constant TApplicationStatePersister::CACHE_NAME
Name of the value stored in cache
canGetProperty in file TComponent.php, method TComponent::canGetProperty()
Determines whether a property can be read.
canSetProperty in file TComponent.php, method TComponent::canSetProperty()
Determines whether a property can be set.
CLASS_FILE_EXT in file PradoBase.php, class constant PradoBase::CLASS_FILE_EXT
File extension for Prado class files.
clearGlobalState in file TApplication.php, method TApplication::clearGlobalState()
Clears a global value.
clearStyle in file interfaces.php, method IStyleable::clearStyle()
Removes all styles associated with the object
completeRequest in file TApplication.php, method TApplication::completeRequest()
Completes current request processing.
CONFIGCACHE_FILE in file TApplication.php, class constant TApplication::CONFIGCACHE_FILE
Config cache file
CONFIG_FILE_EXT_PHP in file TApplication.php, class constant TApplication::CONFIG_FILE_EXT_PHP
File extension for external config files
CONFIG_FILE_EXT_XML in file TApplication.php, class constant TApplication::CONFIG_FILE_EXT_XML
File extension for external config files
CONFIG_FILE_PHP in file TApplication.php, class constant TApplication::CONFIG_FILE_PHP
Application configuration file name
CONFIG_FILE_XML in file TApplication.php, class constant TApplication::CONFIG_FILE_XML
Application configuration file name
CONFIG_TYPE_PHP in file TApplication.php, class constant TApplication::CONFIG_TYPE_PHP
Configuration file type, application.php and config.php
CONFIG_TYPE_XML in file TApplication.php, class constant TApplication::CONFIG_TYPE_XML
Configuration file type, application.xml and config.xml
createComponent in file PradoBase.php, method PradoBase::createComponent()
Creates a component with the specified type.
createdOnTemplate in file TComponent.php, method TComponent::createdOnTemplate()
This method is invoked after the component is instantiated by a template.
current | in file TComponent.php, method TEnumerable::current()
top
d
dataBind in file interfaces.php, method IBindable::dataBind()
Performs databinding.
Debug | in file TApplication.php, class constant TApplicationMode::Debug
delete in file interfaces.php, method ICache::delete()
Deletes a value with the specified key from cache
detachEventHandler in file TComponent.php, method TComponent::detachEventHandler()
Detaches an existing event handler.
determinePropertyType in file TComponent.php, method TComponentReflection::determinePropertyType()
Determines the property type.
top
e
ensureArray in file TComponent.php, method TPropertyValue::ensureArray()
Converts a value to array type. If the value is a string and it is
ensureBoolean in file TComponent.php, method TPropertyValue::ensureBoolean()
Converts a value to boolean type.
ensureEnum in file TComponent.php, method TPropertyValue::ensureEnum()
Converts a value to enum type.
ensureFloat in file TComponent.php, method TPropertyValue::ensureFloat()
Converts a value to float type.
ensureInteger in file TComponent.php, method TPropertyValue::ensureInteger()
Converts a value to integer type.
ensureNullIfEmpty in file TComponent.php, method TPropertyValue::ensureNullIfEmpty()
Converts the value to 'null' if the given value is empty
ensureObject in file TComponent.php, method TPropertyValue::ensureObject()
Converts a value to object type.
ensureString in file TComponent.php, method TPropertyValue::ensureString()
Converts a value to string type.
evaluateExpression in file TComponent.php, method TComponent::evaluateExpression()
Evaluates a PHP expression in the context of this control.
evaluateStatements in file TComponent.php, method TComponent::evaluateStatements()
Evaluates a list of PHP statements.
exceptionHandler in file PradoBase.php, method PradoBase::exceptionHandler()
Default exception handler.
top
f
fatalError in file PradoBase.php, method PradoBase::fatalError()
Fatal error handler.
flush in file interfaces.php, method ITextWriter::flush()
Flushes the content that has been written.
flush in file interfaces.php, method ICache::flush()
Deletes all values from cache.
flushOutput in file TApplication.php, method TApplication::flushOutput()
Flushes output to client side.
top
g
get in file interfaces.php, method ICache::get()
Retrieves a value from cache with a specified key.
getActiveControl | in file interfaces.php, method IActiveControl::getActiveControl()
getAliases in file TApplication.php, method TApplicationConfiguration::getAliases()
Returns list of path alias definitions.
getApplication | in file PradoBase.php, method PradoBase::getApplication()
getApplication | in file TApplicationComponent.php, method TApplicationComponent::getApplication()
getApplicationConfigurationClass | in file TApplication.php, method TApplication::getApplicationConfigurationClass()
getApplicationStatePersister | in file TApplication.php, method TApplication::getApplicationStatePersister()
getAssetManager | in file TApplication.php, method TApplication::getAssetManager()
getAuthorizationRules | in file TApplication.php, method TApplication::getAuthorizationRules()
getBasePath | in file TApplication.php, method TApplication::getBasePath()
getCache | in file TApplication.php, method TApplication::getCache()
getClassName | in file TComponent.php, method TComponentReflection::getClassName()
getConfigurationFile | in file TApplication.php, method TApplication::getConfigurationFile()
getConfigurationFileExt | in file TApplication.php, method TApplication::getConfigurationFileExt()
getConfigurationFileName | in file TApplication.php, method TApplication::getConfigurationFileName()
getConfigurationType | in file TApplication.php, method TApplication::getConfigurationType()
getData | in file interfaces.php, method IDataRenderer::getData()
getEnabled | in file interfaces.php, method IService::getEnabled()
getEnabled | in file TService.php, method TService::getEnabled()
getErrorHandler | in file TApplication.php, method TApplication::getErrorHandler()
getEventHandlers in file TComponent.php, method TComponent::getEventHandlers()
Returns the list of attached event handlers for an event.
getEvents | in file TComponent.php, method TComponentReflection::getEvents()
getExternalConfigurations | in file TApplication.php, method TApplicationConfiguration::getExternalConfigurations()
getFrameworkPath | in file PradoBase.php, method PradoBase::getFrameworkPath()
getGlobalization | in file TApplication.php, method TApplication::getGlobalization()
getGlobalState in file TApplication.php, method TApplication::getGlobalState()
Returns a global value.
getHasChanged | in file interfaces.php, method ICacheDependency::getHasChanged()
getHasStyle | in file interfaces.php, method IStyleable::getHasStyle()
getID | in file TService.php, method TService::getID()
getID | in file TModule.php, method TModule::getID()
getID | in file interfaces.php, method IModule::getID()
getID | in file interfaces.php, method IService::getID()
getID | in file TApplication.php, method TApplication::getID()
getIsEmpty | in file TApplication.php, method TApplicationConfiguration::getIsEmpty()
getIsGuest | in file interfaces.php, method IUser::getIsGuest()
getLogger | in file PradoBase.php, method PradoBase::getLogger()
getMethods | in file TComponent.php, method TComponentReflection::getMethods()
getMode | in file TApplication.php, method TApplication::getMode()
getModule | in file TApplication.php, method TApplication::getModule()
getModules in file TApplication.php, method TApplicationConfiguration::getModules()
Returns list of module configurations.
getModules | in file TApplication.php, method TApplication::getModules()
getName | in file interfaces.php, method IUser::getName()
getPageServiceID | in file TApplication.php, method TApplication::getPageServiceID()
getParameters in file TApplication.php, method TApplicationConfiguration::getParameters()
Returns list of parameter definitions.
getParameters in file TApplication.php, method TApplication::getParameters()
Returns the list of application parameters.
getPathAliases | in file PradoBase.php, method PradoBase::getPathAliases()
getPathOfAlias | in file PradoBase.php, method PradoBase::getPathOfAlias()
getPathOfNamespace in file PradoBase.php, method PradoBase::getPathOfNamespace()
Translates a namespace into a file path.
getPreferredLanguage in file PradoBase.php, method PradoBase::getPreferredLanguage()
Returns the most preferred language by the client user.
getProperties in file TApplication.php, method TApplicationConfiguration::getProperties()
Returns list of page initial property values.
getProperties | in file TComponent.php, method TComponentReflection::getProperties()
getRequest | in file TApplicationComponent.php, method TApplicationComponent::getRequest()
getRequest | in file TApplication.php, method TApplication::getRequest()
getRequestCompleted | in file TApplication.php, method TApplication::getRequestCompleted()
getResponse | in file TApplication.php, method TApplication::getResponse()
getResponse | in file TApplicationComponent.php, method TApplicationComponent::getResponse()
getRoles | in file interfaces.php, method IUser::getRoles()
getRuntimePath | in file TApplication.php, method TApplication::getRuntimePath()
getSecurityManager | in file TApplication.php, method TApplication::getSecurityManager()
getService | in file TApplication.php, method TApplication::getService()
getService | in file TApplicationComponent.php, method TApplicationComponent::getService()
getServices | in file TApplication.php, method TApplicationConfiguration::getServices()
getSession | in file TApplication.php, method TApplication::getSession()
getSession | in file TApplicationComponent.php, method TApplicationComponent::getSession()
getStateFilePath | in file TApplication.php, method TApplicationStatePersister::getStateFilePath()
getStyle | in file interfaces.php, method IStyleable::getStyle()
getSubProperty in file TComponent.php, method TComponent::getSubProperty()
Evaluates a property path.
getUniqueID | in file TApplication.php, method TApplication::getUniqueID()
getUser | in file TApplication.php, method TApplication::getUser()
getUser | in file TApplicationComponent.php, method TApplicationComponent::getUser()
getUserLanguages in file PradoBase.php, method PradoBase::getUserLanguages()
Returns a list of user preferred languages.
getUsings in file TApplication.php, method TApplicationConfiguration::getUsings()
Returns list of namespaces to be used.
getVersion | in file PradoBase.php, method PradoBase::getVersion()
GLOBAL_FILE in file TApplication.php, class constant TApplication::GLOBAL_FILE
Global data file
top
h
hasEvent in file TComponent.php, method TComponent::hasEvent()
Determines whether an event is defined.
hasEventHandler | in file TComponent.php, method TComponent::hasEventHandler()
hasProperty in file TComponent.php, method TComponent::hasProperty()
Determines whether a property is defined.
top
i
IActiveControl in file interfaces.php, class IActiveControl
IActiveControl interface.
IBindable in file interfaces.php, class IBindable
IBindable interface.
ICache in file interfaces.php, class ICache
ICache interface.
ICacheDependency in file interfaces.php, class ICacheDependency
ICacheDependency interface.
ICallbackEventHandler in file interfaces.php, class ICallbackEventHandler
ICallbackEventHandler interface.
IDataRenderer in file interfaces.php, class IDataRenderer
IDataRenderer interface.
IModule in file interfaces.php, class IModule
IModule interface.
init in file TModule.php, method TModule::init()
Initializes the module.
init in file TApplication.php, method TApplicationStatePersister::init()
Initializes module.
init in file TService.php, method TService::init()
Initializes the service and attaches run to the RunService event of application.
init in file interfaces.php, method IService::init()
Initializes the service.
init in file interfaces.php, method IModule::init()
Initializes the module.
initApplication in file TApplication.php, method TApplication::initApplication()
Loads configuration and initializes application.
initErrorHandlers in file PradoBase.php, method PradoBase::initErrorHandlers()
Initializes error handlers.
interfaces.php | procedural page interfaces.php
IRenderable in file interfaces.php, class IRenderable
IRenderable interface.
IService in file interfaces.php, class IService
IService interface.
isInRole | in file interfaces.php, method IUser::isInRole()
IStatePersister in file interfaces.php, class IStatePersister
IStatePersister class.
IStyleable in file interfaces.php, class IStyleable
IStyleable interface.
ITextWriter in file interfaces.php, class ITextWriter
ITextWriter interface.
IUser in file interfaces.php, class IUser
IUser interface.
top
k
key | in file TComponent.php, method TEnumerable::key()
top
l
load in file TApplication.php, method TApplicationStatePersister::load()
Loads application state from persistent storage.
load in file interfaces.php, method IStatePersister::load()
Loads state from a persistent storage.
loadExternalPhp in file TApplication.php, method TApplicationConfiguration::loadExternalPhp()
Loads the external PHP array.
loadExternalXml in file TApplication.php, method TApplicationConfiguration::loadExternalXml()
Loads the external XML configurations.
loadFromFile in file TApplication.php, method TApplicationConfiguration::loadFromFile()
Parses the application configuration file.
loadFromPhp in file TApplication.php, method TApplicationConfiguration::loadFromPhp()
Parses the application configuration given in terms of a PHP array.
loadFromString | in file interfaces.php, method IUser::loadFromString()
loadFromXml in file TApplication.php, method TApplicationConfiguration::loadFromXml()
Parses the application configuration given in terms of a TXmlElement.
loadGlobals in file TApplication.php, method TApplication::loadGlobals()
Loads global values from persistent storage.
loadModulesPhp in file TApplication.php, method TApplicationConfiguration::loadModulesPhp()
Loads the modules PHP array.
loadModulesXml in file TApplication.php, method TApplicationConfiguration::loadModulesXml()
Loads the modules XML node.
loadParametersPhp in file TApplication.php, method TApplicationConfiguration::loadParametersPhp()
Loads the parameters PHP array.
loadParametersXml in file TApplication.php, method TApplicationConfiguration::loadParametersXml()
Loads the parameters XML node.
loadPathsPhp in file TApplication.php, method TApplicationConfiguration::loadPathsPhp()
Loads the paths PHP array
loadPathsXml in file TApplication.php, method TApplicationConfiguration::loadPathsXml()
Loads the paths XML node.
loadServicesPhp in file TApplication.php, method TApplicationConfiguration::loadServicesPhp()
Loads the services PHP array.
loadServicesXml in file TApplication.php, method TApplicationConfiguration::loadServicesXml()
Loads the services XML node.
localize in file PradoBase.php, method PradoBase::localize()
Localize a text to the locale/culture specified in the globalization handler.
log in file PradoBase.php, method PradoBase::log()
Logs a message.
top
n
next | in file TComponent.php, method TEnumerable::next()
Normal | in file TApplication.php, class constant TApplicationMode::Normal
top
o
Off | in file TApplication.php, class constant TApplicationMode::Off
onAuthentication in file TApplication.php, method TApplication::onAuthentication()
Raises OnAuthentication event.
onAuthenticationComplete in file TApplication.php, method TApplication::onAuthenticationComplete()
Raises OnAuthenticationComplete event.
onAuthorization in file TApplication.php, method TApplication::onAuthorization()
Raises OnAuthorization event.
onAuthorizationComplete in file TApplication.php, method TApplication::onAuthorizationComplete()
Raises OnAuthorizationComplete event.
onBeginRequest in file TApplication.php, method TApplication::onBeginRequest()
Raises OnBeginRequest event.
onEndRequest in file TApplication.php, method TApplication::onEndRequest()
Raises OnEndRequest event.
onError in file TApplication.php, method TApplication::onError()
Raises OnError event.
onLoadState in file TApplication.php, method TApplication::onLoadState()
Raises OnLoadState event.
onLoadStateComplete in file TApplication.php, method TApplication::onLoadStateComplete()
Raises OnLoadStateComplete event.
onPreFlushOutput in file TApplication.php, method TApplication::onPreFlushOutput()
Raises OnPreFlushOutput event.
onPreRunService in file TApplication.php, method TApplication::onPreRunService()
Raises OnPreRunService event.
onSaveState in file TApplication.php, method TApplication::onSaveState()
Raises OnSaveState event.
onSaveStateComplete in file TApplication.php, method TApplication::onSaveStateComplete()
Raises OnSaveStateComplete event.
top
p
PAGE_SERVICE_ID in file TApplication.php, class constant TApplication::PAGE_SERVICE_ID
Page service ID
Performance | in file TApplication.php, class constant TApplicationMode::Performance
phpErrorHandler in file PradoBase.php, method PradoBase::phpErrorHandler()
PHP error handler.
poweredByPrado | in file PradoBase.php, method PradoBase::poweredByPrado()
Prado in file prado.php, class Prado
Prado class.
prado.php | procedural page prado.php
PradoBase in file PradoBase.php, class PradoBase
PradoBase class.
PradoBase.php | procedural page PradoBase.php
PRADO_CHMOD in file PradoBase.php, constant PRADO_CHMOD
Defines the default permission for writable directories and files
PRADO_DIR in file PradoBase.php, constant PRADO_DIR
Defines the PRADO framework installation path.
publishAsset in file TApplicationComponent.php, method TApplicationComponent::publishAsset()
Publishes a private asset and gets its URL.
publishFilePath in file TApplicationComponent.php, method TApplicationComponent::publishFilePath()
Publishes a file or directory and returns its URL.
top
r
raiseCallbackEvent in file interfaces.php, method ICallbackEventHandler::raiseCallbackEvent()
Raises callback event. The implementation of this function should raise appropriate event(s) (e.g. OnClick, OnCommand) indicating the component is responsible for the callback event.
raiseEvent in file TComponent.php, method TComponent::raiseEvent()
Raises an event.
render in file interfaces.php, method IRenderable::render()
Renders the component to end-users.
resolvePaths in file TApplication.php, method TApplication::resolvePaths()
Resolves application-relevant paths.
rewind | in file TComponent.php, method TEnumerable::rewind()
run in file TService.php, method TService::run()
Runs the service.
run in file TShellApplication.php, method TShellApplication::run()
Runs the application.
run in file interfaces.php, method IService::run()
Runs the service.
run in file TApplication.php, method TApplication::run()
Executes the lifecycles of the application.
runService in file TApplication.php, method TApplication::runService()
Runs the requested service.
RUNTIME_PATH in file TApplication.php, class constant TApplication::RUNTIME_PATH
Runtime directory name
top
s
save in file TApplication.php, method TApplicationStatePersister::save()
Saves application state in persistent storage.
save in file interfaces.php, method IStatePersister::save()
Saves state into a persistent storage.
saveGlobals in file TApplication.php, method TApplication::saveGlobals()
Saves global values into persistent storage.
saveToString | in file interfaces.php, method IUser::saveToString()
serialize in file PradoBase.php, method PradoBase::serialize()
Serializes a data.
set in file interfaces.php, method ICache::set()
Stores a value identified by a key into cache.
setApplication in file PradoBase.php, method PradoBase::setApplication()
Stores the application instance in the class static member.
setApplicationStatePersister | in file TApplication.php, method TApplication::setApplicationStatePersister()
setAssetManager | in file TApplication.php, method TApplication::setAssetManager()
setBasePath | in file TApplication.php, method TApplication::setBasePath()
setCache | in file TApplication.php, method TApplication::setCache()
setConfigurationFile | in file TApplication.php, method TApplication::setConfigurationFile()
setConfigurationType | in file TApplication.php, method TApplication::setConfigurationType()
setData | in file interfaces.php, method IDataRenderer::setData()
setEnabled | in file TService.php, method TService::setEnabled()
setEnabled | in file interfaces.php, method IService::setEnabled()
setErrorHandler | in file TApplication.php, method TApplication::setErrorHandler()
setGlobalization | in file TApplication.php, method TApplication::setGlobalization()
setGlobalState in file TApplication.php, method TApplication::setGlobalState()
Sets a global value.
setID | in file TApplication.php, method TApplication::setID()
setID | in file TService.php, method TService::setID()
setID | in file interfaces.php, method IModule::setID()
setID | in file TModule.php, method TModule::setID()
setID | in file interfaces.php, method IService::setID()
setIsGuest | in file interfaces.php, method IUser::setIsGuest()
setMode | in file TApplication.php, method TApplication::setMode()
setModule in file TApplication.php, method TApplication::setModule()
Adds a module to application.
setName | in file interfaces.php, method IUser::setName()
setPageServiceID | in file TApplication.php, method TApplication::setPageServiceID()
setPathOfAlias | in file PradoBase.php, method PradoBase::setPathOfAlias()
setRequest | in file TApplication.php, method TApplication::setRequest()
setResponse | in file TApplication.php, method TApplication::setResponse()
setRoles | in file interfaces.php, method IUser::setRoles()
setRuntimePath | in file TApplication.php, method TApplication::setRuntimePath()
setSecurityManager | in file TApplication.php, method TApplication::setSecurityManager()
setService | in file TApplication.php, method TApplication::setService()
setSession | in file TApplication.php, method TApplication::setSession()
setSubProperty in file TComponent.php, method TComponent::setSubProperty()
Sets a value to a property path.
setUser | in file TApplication.php, method TApplication::setUser()
startService in file TApplication.php, method TApplication::startService()
Starts the specified service.
STATE_DEBUG | in file TApplication.php, class constant TApplication::STATE_DEBUG
STATE_NORMAL | in file TApplication.php, class constant TApplication::STATE_NORMAL
STATE_OFF in file TApplication.php, class constant TApplication::STATE_OFF
possible application mode.
STATE_PERFORMANCE | in file TApplication.php, class constant TApplication::STATE_PERFORMANCE
top
t
TApplication in file TApplication.php, class TApplication
TApplication class.
TApplication.php | procedural page TApplication.php
TApplicationComponent in file TApplicationComponent.php, class TApplicationComponent
TApplicationComponent class
TApplicationComponent.php | procedural page TApplicationComponent.php
TApplicationConfiguration in file TApplication.php, class TApplicationConfiguration
TApplicationConfiguration class.
TApplicationMode in file TApplication.php, class TApplicationMode
TApplicationMode class.
TApplicationStatePersister in file TApplication.php, class TApplicationStatePersister
TApplicationStatePersister class.
TComponent in file TComponent.php, class TComponent
TComponent class
TComponent.php | procedural page TComponent.php
TComponentReflection in file TComponent.php, class TComponentReflection
TComponentReflection class.
TEnumerable in file TComponent.php, class TEnumerable
TEnumerable class.
TEventParameter in file TComponent.php, class TEventParameter
TEventParameter class.
TJavaScriptLiteral in file TComponent.php, class TJavaScriptLiteral
TJavaScriptLiteral class that encloses string literals that are not supposed to be escaped by TJavaScript::encode()
TJavaScriptString in file TComponent.php, class TJavaScriptString
TJavaScriptString class is an internal class that marks strings that will be forcibly encoded when rendered inside a javascript block
TModule in file TModule.php, class TModule
TModule class.
TModule.php | procedural page TModule.php
toJavaScriptLiteral | in file TComponent.php, method TJavaScriptLiteral::toJavaScriptLiteral()
toJavaScriptLiteral | in file TComponent.php, method TJavaScriptString::toJavaScriptLiteral()
TPropertyValue in file TComponent.php, class TPropertyValue
TPropertyValue class
trace in file PradoBase.php, method PradoBase::trace()
Writes a log message.
TService in file TService.php, class TService
TService class.
TService.php | procedural page TService.php
TShellApplication in file TShellApplication.php, class TShellApplication
TShellApplication class.
TShellApplication.php | procedural page TShellApplication.php
top
u
unserialize in file PradoBase.php, method PradoBase::unserialize()
Unserializes a data.
using in file PradoBase.php, method PradoBase::using()
Uses a namespace.
top
v
valid | in file TComponent.php, method TEnumerable::valid()
varDump in file PradoBase.php, method PradoBase::varDump()
Converts a variable into a string representation.
top
w
write in file interfaces.php, method ITextWriter::write()
Writes a string.


Class Trees for Package System

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page interfaces.php

File: /interfaces.php

Remarks

Core interfaces essential for TApplication class.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
IModule
IModule interface.
IService
IService interface.
ITextWriter
ITextWriter interface.
IUser
IUser interface.
IStatePersister
IStatePersister class.
ICache
ICache interface.
ICacheDependency
ICacheDependency interface.
IRenderable
IRenderable interface.
IBindable
IBindable interface.
IStyleable
IStyleable interface.
IActiveControl
IActiveControl interface.
ICallbackEventHandler
ICallbackEventHandler interface.
IDataRenderer
IDataRenderer interface.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page prado.php

File: /prado.php

Remarks

Prado bootstrap file.

This file is intended to be included in the entry script of Prado applications. It defines Prado class by extending PradoBase, a static class providing globally available functionalities that enable PRADO component model and error handling mechanism.

By including this file, the PHP error and exception handlers are set as PRADO handlers, and an __autoload function is provided that automatically loads a class file if the class is not defined.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: prado.php 3098 2012-01-28 17:49:48Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
Prado
Prado class.

Include Statements Summary

  • require_once = dirname(__FILE__).'/PradoBase.php'
    Includes the PradoBase class file
  • require_once = dirname(__FILE__).'/TApplication.php'
    Includes TApplication class file
  • require_once = dirname(__FILE__).'/TShellApplication.php'
    Includes TShellApplication class file

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

  • require_once file: = dirname(__FILE__).'/PradoBase.php' [line 24]

    Remarks

    Includes the PradoBase class file

  • require_once file: = dirname(__FILE__).'/TApplication.php' [line 60]

    Remarks

    Includes TApplication class file

  • require_once file: = dirname(__FILE__).'/TShellApplication.php' [line 65]

    Remarks

    Includes TShellApplication class file

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:42:59 +0200 by phpDocumentor 1.4.3


Docs for page PradoBase.php

File: /PradoBase.php

Remarks

PradoBase class file.

This is the file that establishes the PRADO component model and error handling mechanism.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: PradoBase.php 3168 2012-06-25 10:43:31Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
PradoBase
PradoBase class.

Include Statements Summary

Global Variable Summary

Constant Summary

  • PRADO_CHMOD = 0777
    Defines the default permission for writable directories and files
  • PRADO_DIR = dirname(__FILE__)
    Defines the PRADO framework installation path.

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

  • PRADO_CHMOD = 0777 [line 25]

    Remarks

    Defines the default permission for writable directories and files

  • PRADO_DIR = dirname(__FILE__) [line 20]

    Remarks

    Defines the PRADO framework installation path.

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:42:59 +0200 by phpDocumentor 1.4.3


Docs for page TApplication.php

File: /TApplication.php

Remarks

TApplication class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TApplication.php 3151 2012-05-29 09:52:51Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TApplication
TApplication class.
TApplicationMode
TApplicationMode class.
TApplicationConfiguration
TApplicationConfiguration class.
TApplicationStatePersister
TApplicationStatePersister class.

Include Statements Summary

  • require_once = PRADO_DIR.'/interfaces.php'
    Includes core interfaces essential for TApplication class

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

  • require_once file: = PRADO_DIR.'/interfaces.php' [line 16]

    Remarks

    Includes core interfaces essential for TApplication class

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:30 +0200 by phpDocumentor 1.4.3


Docs for page TApplicationComponent.php

File: /TApplicationComponent.php

Remarks

TApplicationComponent class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TApplicationComponent.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TApplicationComponent
TApplicationComponent class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:31 +0200 by phpDocumentor 1.4.3


Docs for page TComponent.php

File: /TComponent.php

Remarks

TComponent, TPropertyValue classes

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TComponent.php 3123 2012-03-26 10:10:51Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TComponent
TComponent class
TEnumerable
TEnumerable class.
TPropertyValue
TPropertyValue class
TEventParameter
TEventParameter class.
TComponentReflection
TComponentReflection class.
TJavaScriptLiteral
TJavaScriptLiteral class that encloses string literals that are not supposed to be escaped by TJavaScript::encode()
TJavaScriptString
TJavaScriptString class is an internal class that marks strings that will be forcibly encoded when rendered inside a javascript block

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:49 +0200 by phpDocumentor 1.4.3


Docs for page TModule.php

File: /TModule.php

Remarks

TModule class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TModule.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TModule
TModule class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:51 +0200 by phpDocumentor 1.4.3


Docs for page TService.php

File: /TService.php

Remarks

TService class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TService.php 3102 2012-02-05 17:00:00Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TService
TService class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:20 +0200 by phpDocumentor 1.4.3


Docs for page TShellApplication.php

File: /TShellApplication.php

Remarks

TShellApplication class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TShellApplication.php 3063 2011-11-13 14:47:41Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TShellApplication
TShellApplication class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:21 +0200 by phpDocumentor 1.4.3


Docs For Class IActiveControl

Interface IActiveControl

[line 329]

Location: /interfaces.php

Remarks

IActiveControl interface.

Active controls must implement IActiveControl interface.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IActiveControl::getActiveControl

getActiveControl(
 );

    Returns

    Active control properties.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class IBindable

Interface IBindable

[line 285]

Location: /interfaces.php

Remarks

IBindable interface.

This interface must be implemented by classes that are capable of performing databinding.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IBindable::dataBind

dataBind(
 );

    Remarks

    Performs databinding.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class ICache

Interface ICache

[line 191]

Location: /interfaces.php

Remarks

ICache interface.

This interface must be implemented by cache managers.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    ICache::add

add(
string
$id, mixed
$value, [integer
$expire = 0], [ICacheDependency
$dependency = null] );

    Parameters

    $id

    the key identifying the value to be cached

    $value

    the value to be cached

    $expire

    the number of seconds in which the cached value will expire. 0 means never expire.

    $dependency

    dependency of the cached item. If the dependency changes, the item is labelled invalid.

    Returns

    true if the value is successfully stored into cache, false otherwise

    Remarks

    Stores a value identified by a key into cache if the cache does not contain this key.

    Nothing will be done if the cache already contains the key.

    access

    public

    [ Top ]

    ICache::delete

delete(
string
$id );

    Parameters

    $id

    the key of the value to be deleted

    Returns

    if no error happens during deletion

    Remarks

    Deletes a value with the specified key from cache

    access

    public

    [ Top ]

    ICache::flush

flush(
 );

    Remarks

    Deletes all values from cache.

    Be careful of performing this operation if the cache is shared by multiple applications.

    access

    public

    [ Top ]

    ICache::get

get(
string
$id );

    Parameters

    $id

    a key identifying the cached value

    Returns

    the value stored in cache, false if the value is not in the cache or expired.

    Remarks

    Retrieves a value from cache with a specified key.

    access

    public

    [ Top ]

    ICache::set

set(
string
$id, mixed
$value, [integer
$expire = 0], [ICacheDependency
$dependency = null] );

    Parameters

    $id

    the key identifying the value to be cached

    $value

    the value to be cached

    $expire

    the number of seconds in which the cached value will expire. 0 means never expire.

    $dependency

    dependency of the cached item. If the dependency changes, the item is labelled invalid.

    Returns

    true if the value is successfully stored into cache, false otherwise

    Remarks

    Stores a value identified by a key into cache.

    If the cache already contains such a key, the existing value and  expiration time will be replaced with the new ones.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class ICacheDependency

Interface ICacheDependency

[line 247]

Location: /interfaces.php

Remarks

ICacheDependency interface.

This interface must be implemented by classes meant to be used as  cache dependencies.
Classes implementing this interface must support serialization and unserialization.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    ICacheDependency::getHasChanged

getHasChanged(
 );

    Returns

    whether the dependency has changed. Defaults to false.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class ICallbackEventHandler

Interface ICallbackEventHandler

[line 348]

Location: /interfaces.php

Remarks

ICallbackEventHandler interface.

If a control wants to respond to callback event, it must implement this  interface.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    ICallbackEventHandler::raiseCallbackEvent

raiseCallbackEvent(
TCallbackEventParameter
$eventArgument );

    Parameters

    $eventArgument

    the parameter associated with the callback event

    Remarks

    Raises callback event. The implementation of this function should raise  appropriate event(s) (e.g. OnClick, OnCommand) indicating the component  is responsible for the callback event.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class IDataRenderer

Interface IDataRenderer

[line 370]

Classes extended from IDataRenderer:

IScaffoldEditRenderer

IScaffoldEditRenderer interface.

IItemDataRenderer

IItemDataRenderer interface.

Location: /interfaces.php

Remarks

IDataRenderer interface.

If a control wants to be used a renderer for another data-bound control,  this interface must be implemented.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IDataRenderer::getData

getData(
 );

    Returns

    the data bound to this object

    access

    public

    [ Top ]

    IDataRenderer::setData

setData(
mixed
$value );

    Parameters

    $value

    the data to be bound to this object

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class IModule

Interface IModule

[line 23]

Location: /interfaces.php

Remarks

IModule interface.

This interface must be implemented by application modules.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IModule::getID

getID(
 );

    Returns

    ID of the module

    access

    public

    [ Top ]

    IModule::init

init(
TXmlElement
$config );

    Parameters

    $config

    the configuration for the module

    Remarks

    Initializes the module.

    access

    public

    [ Top ]

    IModule::setID

setID(
string
$id );

    Parameters

    $id

    ID of the module

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class IRenderable

Interface IRenderable

[line 266]

Location: /interfaces.php

Remarks

IRenderable interface.

This interface must be implemented by classes that can be rendered  to end-users.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IRenderable::render

render(
ITextWriter
$writer );

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the component to end-users.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class IService

Interface IService

[line 50]

Location: /interfaces.php

Remarks

IService interface.

This interface must be implemented by services.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IService::getEnabled

getEnabled(
 );

    Returns

    whether the service is enabled

    access

    public

    [ Top ]

    IService::getID

getID(
 );

    Returns

    ID of the service

    access

    public

    [ Top ]

    IService::init

init(
TXmlElement
$config );

    Parameters

    $config

    the configuration for the service

    Remarks

    Initializes the service.

    access

    public

    [ Top ]

    IService::run

run(
 );

    Remarks

    Runs the service.

    access

    public

    [ Top ]

    IService::setEnabled

setEnabled(
boolean
$value );

    Parameters

    $value

    whether the service is enabled

    access

    public

    [ Top ]

    IService::setID

setID(
string
$id );

    Parameters

    $id

    ID of the service

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class IStatePersister

Interface IStatePersister

[line 166]

Location: /interfaces.php

Remarks

IStatePersister class.

This interface must be implemented by all state persister classes (such as  TPageStatePersister, TApplicationStatePersister.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IStatePersister::load

load(
 );

    Returns

    the state

    Remarks

    Loads state from a persistent storage.

    access

    public

    [ Top ]

    IStatePersister::save

save(
mixed
$state );

    Parameters

    $state

    the state to be saved

    Remarks

    Saves state into a persistent storage.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class IStyleable

Interface IStyleable

[line 303]

Location: /interfaces.php

Remarks

IStyleable interface.

This interface should be implemented by classes that support CSS styles.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IStyleable::clearStyle

clearStyle(
 );

    Remarks

    Removes all styles associated with the object

    access

    public

    [ Top ]

    IStyleable::getHasStyle

getHasStyle(
 );

    Returns

    whether the object has defined any style information

    access

    public

    [ Top ]

    IStyleable::getStyle

getStyle(
 );

    Returns

    the object representing the css style of the object

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class ITextWriter

Interface ITextWriter

[line 89]

Location: /interfaces.php

Remarks

ITextWriter interface.

This interface must be implemented by writers.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    ITextWriter::flush

flush(
 );

    Remarks

    Flushes the content that has been written.

    access

    public

    [ Top ]

    ITextWriter::write

write(
string
$str );

    Parameters

    $str

    string to be written

    Remarks

    Writes a string.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class IUser

Interface IUser

[line 113]

Location: /interfaces.php

Remarks

IUser interface.

This interface must be implemented by user objects.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: interfaces.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IUser::getIsGuest

getIsGuest(
 );

    Returns

    if the user is a guest

    access

    public

    [ Top ]

    IUser::getName

getName(
 );

    Returns

    username

    access

    public

    [ Top ]

    IUser::getRoles

getRoles(
 );

    Returns

    list of roles that the user is of

    access

    public

    [ Top ]

    IUser::isInRole

isInRole(
string
$role );

    Parameters

    $role

    role to be tested

    Returns

    whether the user is of this role

    access

    public

    [ Top ]

    IUser::loadFromString

loadFromString(
string
$string );

    Parameters

    $string

    user data that is serialized and restored from session

    Returns

    the user object

    access

    public

    [ Top ]

    IUser::saveToString

saveToString(
 );

    Returns

    user data that is serialized and will be stored in session

    access

    public

    [ Top ]

    IUser::setIsGuest

setIsGuest(
boolean
$value );

    Parameters

    $value

    if the user is a guest

    access

    public

    [ Top ]

    IUser::setName

setName(
string
$value );

    Parameters

    $value

    username

    access

    public

    [ Top ]

    IUser::setRoles

setRoles(

$value );

    Parameters

    $value

    Returns

    list of roles that the user is of. If it is a string, roles are assumed by separated by comma

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class Prado

Class Prado

[line 39]
PradoBase
   |
   --Prado
Location: /prado.php

Remarks

Prado class.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: prado.php 3098 2012-01-28 17:49:48Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class PradoBase

  • PradoBase::CLASS_FILE_EXT = '.php'
    File extension for Prado class files.

Inherited Class Variable Summary

Inherited From Class PradoBase

  • PradoBase::$classExists = array()

Method Summary

Inherited Method Summary

Inherited From Class PradoBase

  • PradoBase::autoload()
    Class autoload loader.
  • PradoBase::createComponent()
    Creates a component with the specified type.
  • PradoBase::exceptionHandler()
    Default exception handler.
  • PradoBase::fatalError()
    Fatal error handler.
  • PradoBase::getApplication()
  • PradoBase::getFrameworkPath()
  • PradoBase::getLogger()
  • PradoBase::getPathAliases()
  • PradoBase::getPathOfAlias()
  • PradoBase::getPathOfNamespace()
    Translates a namespace into a file path.
  • PradoBase::getPreferredLanguage()
    Returns the most preferred language by the client user.
  • PradoBase::getUserLanguages()
    Returns a list of user preferred languages.
  • PradoBase::getVersion()
  • PradoBase::initErrorHandlers()
    Initializes error handlers.
  • PradoBase::localize()
    Localize a text to the locale/culture specified in the globalization handler.
  • PradoBase::log()
    Logs a message.
  • PradoBase::phpErrorHandler()
    PHP error handler.
  • PradoBase::poweredByPrado()
  • PradoBase::serialize()
    Serializes a data.
  • PradoBase::setApplication()
    Stores the application instance in the class static member.
  • PradoBase::setPathOfAlias()
  • PradoBase::trace()
    Writes a log message.
  • PradoBase::unserialize()
    Unserializes a data.
  • PradoBase::using()
    Uses a namespace.
  • PradoBase::varDump()
    Converts a variable into a string representation.

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:42:59 +0200 by phpDocumentor 1.4.3


Docs For Class PradoBase

Class PradoBase

[line 41]

Classes extended from PradoBase:

Prado

Prado class.

Location: /PradoBase.php

Remarks

PradoBase class.

PradoBase implements a few fundamental static methods.
To use the static methods, Use Prado as the class name rather than PradoBase.  PradoBase is meant to serve as the base class of Prado. The latter might be  rewritten for customization.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: PradoBase.php 3168 2012-06-25 10:43:31Z ctrlaltca $

since

3.0

Class Variable Summary

  • static $classExists = array()

Class Constant Summary

  • CLASS_FILE_EXT = '.php'

        File extension for Prado class files.

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static void autoload()

    Class autoload loader.

  • static TComponent createComponent()

    Creates a component with the specified type.

  • static void exceptionHandler()

    Default exception handler.

  • static void fatalError()

    Fatal error handler.

  • static TApplication getApplication()

  • static string getFrameworkPath()

  • static TLogger getLogger()

  • static void getPathAliases()

  • static string getPathOfAlias()

  • static string getPathOfNamespace()

    Translates a namespace into a file path.

  • static string getPreferredLanguage()

    Returns the most preferred language by the client user.

  • static array getUserLanguages()

    Returns a list of user preferred languages.

  • static string getVersion()

  • static void initErrorHandlers()

    Initializes error handlers.

  • static string localize()

    Localize a text to the locale/culture specified in the globalization handler.

  • static void log()

    Logs a message.

  • static void phpErrorHandler()

    PHP error handler.

  • static string poweredByPrado()

  • static string serialize()

    Serializes a data.

  • static void setApplication()

    Stores the application instance in the class static member.

  • static void setPathOfAlias()

  • static void trace()

    Writes a log message.

  • static mixed unserialize()

    Unserializes a data.

  • static void using()

    Uses a namespace.

  • static string varDump()

    Converts a variable into a string representation.

  • void autoload()

    Class autoload loader.

  • TComponent createComponent()

    Creates a component with the specified type.

  • void exceptionHandler()

    Default exception handler.

  • void fatalError()

    Fatal error handler.

  • TApplication getApplication()

  • string getFrameworkPath()

  • TLogger getLogger()

  • void getPathAliases()

  • string getPathOfAlias()

  • string getPathOfNamespace()

    Translates a namespace into a file path.

  • string getPreferredLanguage()

    Returns the most preferred language by the client user.

  • array getUserLanguages()

    Returns a list of user preferred languages.

  • string getVersion()

  • void initErrorHandlers()

    Initializes error handlers.

  • string localize()

    Localize a text to the locale/culture specified in the globalization handler.

  • void log()

    Logs a message.

  • void phpErrorHandler()

    PHP error handler.

  • string poweredByPrado()

  • string serialize()

    Serializes a data.

  • void setApplication()

    Stores the application instance in the class static member.

  • void setPathOfAlias()

  • void trace()

    Writes a log message.

  • mixed unserialize()

    Unserializes a data.

  • void using()

    Uses a namespace.

  • string varDump()

    Converts a variable into a string representation.

Inherited Method Summary

Method Detail

    static PradoBase::autoload

static autoload(
string
$className );

    Parameters

    $className

    class name

    Remarks

    Class autoload loader.

    This method is provided to be invoked within an __autoload() magic method.

    access

    public

    [ Top ]

    static PradoBase::createComponent

static createComponent(
string
$type );

    Parameters

    $type

    component type

    Returns

    component instance of the specified type

    Remarks

    Creates a component with the specified type.

    A component type can be either the component class name  or a namespace referring to the path of the component class file.  For example, 'TButton', 'System.Web.UI.WebControls.TButton' are both  valid component type.  This method can also pass parameters to component constructors.  All parameters passed to this method except the first one (the component type)  will be supplied as component constructor parameters.

    throws

    TInvalidDataValueException if the component type is unknown

    access

    public

    [ Top ]

    static PradoBase::exceptionHandler

static exceptionHandler(
Exception
$exception );

    Parameters

    $exception

    exception that is not caught

    Remarks

    Default exception handler.

    This method should be registered as default exception handler using  http://www.php.net/set_exception_handler. The method tries to use the errorhandler  module of the Prado application to handle the exception.  If the application or the module does not exist, it simply echoes the  exception.

    access

    public

    [ Top ]

    static PradoBase::fatalError

static fatalError(
string
$msg );

    Parameters

    $msg

    error message

    Remarks

    Fatal error handler.

    This method displays an error message together with the current call stack.  The application will exit after calling this method.

    access

    public

    [ Top ]

    static PradoBase::getApplication

static getApplication(
 );

    Returns

    the application singleton, null if the singleton has not be created yet.

    access

    public

    [ Top ]

    static PradoBase::getFrameworkPath

static getFrameworkPath(
 );

    Returns

    the path of the framework

    access

    public

    [ Top ]

    static PradoBase::getLogger

static getLogger(
 );

    Returns

    message logger

    access

    public

    [ Top ]

    static PradoBase::getPathAliases

static getPathAliases(
 );

    access

    protected

    [ Top ]

    static PradoBase::getPathOfAlias

static getPathOfAlias(
string
$alias );

    Parameters

    $alias

    alias to the path

    Returns

    the path corresponding to the alias, null if alias not defined.

    access

    public

    [ Top ]

    static PradoBase::getPathOfNamespace

static getPathOfNamespace(
string
$namespace, [string
$ext = ''] );

    Parameters

    $namespace

    namespace

    $ext

    extension to be appended if the namespace refers to a file

    Returns

    file path corresponding to the namespace, null if namespace is invalid

    Remarks

    Translates a namespace into a file path.

    The first segment of the namespace is considered as a path alias  which is replaced with the actual path. The rest segments are  subdirectory names appended to the aliased path.  If the namespace ends with an asterisk '*', it represents a directory;  Otherwise it represents a file whose extension name is specified by the second parameter (defaults to empty).  Note, this method does not ensure the existence of the resulting file path.

    access

    public

    [ Top ]

    static PradoBase::getPreferredLanguage

static getPreferredLanguage(
 );

    Returns

    the most preferred language by the client user, defaults to English.

    Remarks

    Returns the most preferred language by the client user.

    access

    public

    [ Top ]

    static PradoBase::getUserLanguages

static getUserLanguages(
 );

    Returns

    list of user preferred languages.

    Remarks

    Returns a list of user preferred languages.

    The languages are returned as an array. Each array element  represents a single language preference. The languages are ordered  according to user preferences. The first language is the most preferred.

    access

    public

    [ Top ]

    static PradoBase::getVersion

static getVersion(
 );

    Returns

    the version of Prado framework

    access

    public

    [ Top ]

    static PradoBase::initErrorHandlers

static initErrorHandlers(
 );

    Remarks

    Initializes error handlers.

    This method set error and exception handlers to be functions  defined in this class.

    access

    public

    [ Top ]

    static PradoBase::localize

static localize(
string
$text, [array
$parameters = array()], [string
$catalogue = null], [string
$charset = null] );

    Parameters

    $text

    text to be localized.

    $parameters

    a set of parameters to substitute.

    $catalogue

    a different catalogue to find the localize text.

    $charset

    the input AND output charset.

    Returns

    localized text.

    Remarks

    Localize a text to the locale/culture specified in the globalization handler.

    see

    TTranslate::formatter()

    see

    TTranslate::init()

    access

    public

    [ Top ]

    static PradoBase::log

static log(
string
$msg, [integer
$level = TLogger::INFO], [string
$category = 'Uncategorized'], [(string|TControl)
$ctl = null] );

    Parameters

    $msg

    message to be logged

    $level

    level of the message. Valid values include  TLogger::DEBUG, TLogger::INFO, TLogger::NOTICE, TLogger::WARNING,  TLogger::ERROR, TLogger::ALERT, TLogger::FATAL.

    $category

    category of the message

    $ctl

    control of the message

    Remarks

    Logs a message.

    Messages logged by this method may be retrieved via TLogger::getLogs  and may be recorded in different media, such as file, email, database, using  TLogRouter.

    access

    public

    [ Top ]

    static PradoBase::phpErrorHandler

static phpErrorHandler(
integer
$errno, string
$errstr, string
$errfile, integer
$errline );

    Parameters

    $errno

    the level of the error raised

    $errstr

    the error message

    $errfile

    the filename that the error was raised in

    $errline

    the line number the error was raised at

    Remarks

    PHP error handler.

    This method should be registered as PHP error handler using  http://www.php.net/set_error_handler. The method throws an exception that  contains the error information.

    access

    public

    [ Top ]

    static PradoBase::poweredByPrado

static poweredByPrado(
[integer
$logoType = 0] );

    Parameters

    $logoType

    the type of "powered logo". Valid values include 0 and 1.

    Returns

    a string that can be displayed on your Web page showing powered-by-PRADO information

    access

    public

    [ Top ]

    static PradoBase::serialize

static serialize(
mixed
$data );

    Parameters

    $data

    data to be serialized

    Returns

    the serialized data

    Remarks

    Serializes a data.

    The original PHP serialize function has a bug that may not serialize  properly an object.

    access

    public

    [ Top ]

    static PradoBase::setApplication

static setApplication(
TApplication
$application );

    Parameters

    $application

    the application instance

    Remarks

    Stores the application instance in the class static member.

    This method helps implement a singleton pattern for TApplication.  Repeated invocation of this method or the application constructor  will cause the throw of an exception.  This method should only be used by framework developers.

    throws

    TInvalidOperationException if this method is invoked twice or more.

    access

    public

    [ Top ]

    static PradoBase::setPathOfAlias

static setPathOfAlias(
string
$alias, string
$path );

    Parameters

    $alias

    alias to the path

    $path

    the path corresponding to the alias

    throws

    TInvalidOperationException if the alias is already defined

    throws

    TInvalidDataValueException if the path is not a valid file path

    access

    public

    [ Top ]

    static PradoBase::trace

static trace(
string
$msg, [string
$category = 'Uncategorized'], [(string|TControl)
$ctl = null] );

    Parameters

    $msg

    message to be logged

    $category

    category of the message

    $ctl

    control of the message

    Remarks

    Writes a log message.

    This method wraps log() by checking the application mode.  When the application is in Debug mode, debug backtrace information is appended  to the message and the message is logged at DEBUG level.  When the application is in Performance mode, this method does nothing.  Otherwise, the message is logged at INFO level.

    see

    PradoBase::log(), PradoBase::getLogger()

    access

    public

    [ Top ]

    static PradoBase::unserialize

static unserialize(
string
$str );

    Parameters

    $str

    data to be unserialized

    Returns

    unserialized data, null if unserialize failed

    Remarks

    Unserializes a data.

    The original PHP unserialize function has a bug that may not unserialize  properly an object.

    access

    public

    [ Top ]

    static PradoBase::using

static using(
string
$namespace, [boolean
$checkClassExistence = true] );

    Parameters

    $namespace

    namespace to be used

    $checkClassExistence

    whether to check the existence of the class after the class file is included

    Remarks

    Uses a namespace.

    A namespace ending with an asterisk '*' refers to a directory, otherwise it represents a PHP file.  If the namespace corresponds to a directory, the directory will be appended  to the include path. If the namespace corresponds to a file, it will be included (include_once).

    throws

    TInvalidDataValueException if the namespace is invalid

    access

    public

    [ Top ]

    static PradoBase::varDump

static varDump(
mixed
$var, [integer
$depth = 10], [boolean
$highlight = false] );

    Parameters

    $var

    variable to be dumped

    $depth

    maximum depth that the dumper should go into the variable. Defaults to 10.

    $highlight

    whether to syntax highlight the output. Defaults to false.

    Returns

    the string representation of the variable

    Remarks

    Converts a variable into a string representation.

    This method achieves the similar functionality as var_dump and print_r  but is more robust when handling complex objects such as PRADO controls.

    access

    public

    [ Top ]

Variable Detail

  • static $classExists = array() [line 67]
    •

  • Data type: array
    •

    var

    list of class exists checks

    access

    protected

Class Constant Detail

  • CLASS_FILE_EXT = '.php' [line 46]
    •

    Remarks

    File extension for Prado class files.

        Documentation generated on Mon, 25 Jun 2012 14:42:59 +0200 by phpDocumentor 1.4.3


Docs For Class TApplication

Class TApplication

[line 112]
TComponent
   |
   --TApplication
Classes extended from TApplication:
TShellApplication
TShellApplication class.

Location: /TApplication.php

Remarks

TApplication class.

TApplication coordinates modules and services, and serves as a configuration context for all Prado components.

TApplication uses a configuration file to specify the settings of the application, the modules, the services, the parameters, and so on.

TApplication adopts a modular structure. A TApplication instance is a composition of multiple modules. A module is an instance of class implementing IModule interface. Each module accomplishes certain functionalities that are shared by all Prado components in an application. There are default modules and user-defined modules. The latter offers extreme flexibility of extending TApplication in a plug-and-play fashion. Modules cooperate with each other to serve a user request by following a sequence of lifecycles predefined in TApplication.

TApplication has four modes that can be changed by setting Mode property (in the application configuration file).

  • Off mode will prevent the application from serving user requests.
  • Debug mode is mainly used during application development. It ensures the cache is always up-to-date if caching is enabled. It also allows exceptions are displayed with rich context information if they occur.
  • Normal mode is mainly used during production stage. Exception information will only be recorded in system error logs. The cache is ensured to be up-to-date if it is enabled.
  • Performance mode is similar to Normal mode except that it does not ensure the cache is up-to-date.
TApplication dispatches each user request to a particular service which finishes the actual work for the request with the aid from the application modules.

TApplication maintains a lifecycle with the following stages:

  • [construct] : construction of the application instance
  • [initApplication] : load application configuration and instantiate modules and the requested service
  • onBeginRequest : this event happens right after application initialization
  • onAuthentication : this event happens when authentication is needed for the current request
  • onAuthenticationComplete : this event happens right after the authentication is done for the current request
  • onAuthorization : this event happens when authorization is needed for the current request
  • onAuthorizationComplete : this event happens right after the authorization is done for the current request
  • onLoadState : this event happens when application state needs to be loaded
  • onLoadStateComplete : this event happens right after the application state is loaded
  • onPreRunService : this event happens right before the requested service is to run
  • runService : the requested service runs
  • onSaveState : this event happens when application needs to save its state
  • onSaveStateComplete : this event happens right after the application saves its state
  • onPreFlushOutput : this event happens right before the application flushes output to client side.
  • flushOutput : the application flushes output to client side.
  • onEndRequest : this is the last stage a request is being completed
  • [destruct] : destruction of the application instance
Modules and services can attach their methods to one or several of the above events and do appropriate processing when the events are raised. By this way, the application is able to coordinate the activities of modules and services in the above order. To terminate an application before the whole lifecycle completes, call completeRequest.

Examples:

  • Create and run a Prado application:
  •  $application=new TApplication($configFile);
    •

  •  $application->run();
    •

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TApplication.php 3151 2012-05-29 09:52:51Z ctrlaltca $

since

3.0

Class Variable Summary

Class Constant Summary

  • CONFIGCACHE_FILE = 'config.cache'
    Config cache file
  • CONFIG_FILE_EXT_PHP = '.php'
    File extension for external config files
  • CONFIG_FILE_EXT_XML = '.xml'
    File extension for external config files
  • CONFIG_FILE_PHP = 'application.php'
    Application configuration file name
  • CONFIG_FILE_XML = 'application.xml'
    Application configuration file name
  • CONFIG_TYPE_PHP =  'php'
    Configuration file type, application.php and config.php
  • CONFIG_TYPE_XML =  'xml'
    Configuration file type, application.xml and config.xml
  • GLOBAL_FILE = 'global.cache'
    Global data file
  • PAGE_SERVICE_ID = 'page'
    Page service ID
  • RUNTIME_PATH = 'runtime'
    Runtime directory name
  • STATE_DEBUG = 'Debug'
  • STATE_NORMAL = 'Normal'
  • STATE_OFF = 'Off'
    possible application mode.
  • STATE_PERFORMANCE = 'Performance'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TApplication::applyConfiguration

    applyConfiguration( TApplicationConfiguration $config, [boolean $withinService = false] );

    Parameters

    $config

    the configuration

    $withinService

    whether the configuration is specified within a service.

    Remarks

    Applies an application configuration.

    access

    public

    [ Top ]

    TApplication::clearGlobalState

    clearGlobalState( string $key );

    Parameters

    $key

    the name of the value to be cleared

    Remarks

    Clears a global value.

    The value cleared will no longer be available in this request and the following requests.

    access

    public

    [ Top ]

    TApplication::completeRequest

    completeRequest( );

    Remarks

    Completes current request processing.

    This method can be used to exit the application lifecycles after finishing the current cycle.

    access

    public

    [ Top ]

    TApplication::__construct

    __construct(
[string
$basePath = 'protected'], [boolean
$cacheConfig = true], [
$configType = self::CONFIG_TYPE_XML] );

    Parameters

    $basePath

    application base path or configuration file path. If the parameter is a file, it is assumed to be the application configuration file, and the directory containing the file is treated as the application base path. If it is a directory, it is assumed to be the application base path, and within that directory, a file named application.xml will be looked for. If found, the file is considered as the application configuration file.

    $cacheConfig

    whether to cache application configuration. Defaults to true.

    $configType

    Remarks

    Constructor.

    Sets application base path and initializes the application singleton. Application base path refers to the root directory storing application data and code not directly accessible by Web users. By default, the base path is assumed to be the protected directory under the directory containing the current running script.

    throws

    TConfigurationException if configuration file cannot be read or the runtime path is invalid.

    access

    public

    [ Top ]

    TApplication::flushOutput

    flushOutput( [boolean $continueBuffering = true] );

    Parameters

    $continueBuffering

    whether to continue buffering after flush if buffering was active

    Remarks

    Flushes output to client side.

    access

    public

    [ Top ]

    TApplication::getApplicationConfigurationClass

    getApplicationConfigurationClass( );

    access

    protected

    [ Top ]

    TApplication::getApplicationStatePersister

    getApplicationStatePersister( );

    Returns

    application state persister

    access

    public

    [ Top ]

    TApplication::getAssetManager

    getAssetManager( );

    Returns

    asset manager

    access

    public

    [ Top ]

    TApplication::getAuthorizationRules

    getAuthorizationRules( );

    Returns

    list of authorization rules for the current request

    access

    public

    [ Top ]

    TApplication::getBasePath

    getBasePath( );

    Returns

    the directory containing the application configuration file (absolute path)

    access

    public

    [ Top ]

    TApplication::getCache

    getCache( );

    Returns

    the cache module, null if cache module is not installed

    access

    public

    [ Top ]

    TApplication::getConfigurationFile

    getConfigurationFile( );

    Returns

    the application configuration file (absolute path)

    access

    public

    [ Top ]

    TApplication::getConfigurationFileExt

    getConfigurationFileExt( );

    Returns

    the applictaion configuration type. default is 'xml'

    access

    public

    [ Top ]

    TApplication::getConfigurationFileName

    getConfigurationFileName( );

    Returns

    the default configuration file name

    access

    public

    [ Top ]

    TApplication::getConfigurationType

    getConfigurationType( );

    Returns

    the application configuration file (absolute path)

    access

    public

    [ Top ]

    TApplication::getErrorHandler

    getErrorHandler( );

    Returns

    the error handler module

    access

    public

    [ Top ]

    TApplication::getGlobalization

    getGlobalization( [boolean $createIfNotExists = true] );

    Parameters

    $createIfNotExists

    whether to create globalization if it does not exist

    Returns

    globalization module

    access

    public

    [ Top ]

    TApplication::getGlobalState

    getGlobalState( string $key, [mixed $defaultValue = null] );

    Parameters

    $key

    the name of the value to be returned

    $defaultValue

    the default value. If $key is not found, $defaultValue will be returned

    Returns

    the global value corresponding to $key

    Remarks

    Returns a global value.

    A global value is one that is persistent across users sessions and requests.

    access

    public

    [ Top ]

    TApplication::getID

    getID( );

    Returns

    application ID

    access

    public

    [ Top ]

    TApplication::getMode

    getMode( );

    Returns

    application mode. Defaults to TApplicationMode::Debug.

    access

    public

    [ Top ]

    TApplication::getModule

    getModule( $id );

    Parameters

    $id

    Returns

    the module with the specified ID, null if not found

    access

    public

    [ Top ]

    TApplication::getModules

    getModules( );

    Returns

    list of loaded application modules, indexed by module IDs

    access

    public

    [ Top ]

    TApplication::getPageServiceID

    getPageServiceID( );

    Returns

    page service ID

    access

    public

    [ Top ]

    TApplication::getParameters

    getParameters( );

    Returns

    the list of application parameters

    Remarks

    Returns the list of application parameters.

    Since the parameters are returned as a TMap object, you may use the returned result to access, add or remove individual parameters.

    access

    public

    [ Top ]

    TApplication::getRequest

    getRequest( );

    Returns

    the request module

    access

    public

    [ Top ]

    TApplication::getRequestCompleted

    getRequestCompleted( );

    Returns

    whether the current request is processed.

    access

    public

    [ Top ]

    TApplication::getResponse

    getResponse( );

    Returns

    the response module

    access

    public

    [ Top ]

    TApplication::getRuntimePath

    getRuntimePath( );

    Returns

    the directory storing cache data and application-level persistent data. (absolute path)

    access

    public

    [ Top ]

    TApplication::getSecurityManager

    getSecurityManager( );

    Returns

    the security manager module

    access

    public

    [ Top ]

    TApplication::getService

    getService( );

    Returns

    the currently requested service

    access

    public

    [ Top ]

    TApplication::getSession

    getSession( );

    Returns

    the session module, null if session module is not installed

    access

    public

    [ Top ]

    TApplication::getUniqueID

    getUniqueID( );

    Returns

    an ID that uniquely identifies this Prado application from the others

    access

    public

    [ Top ]

    TApplication::getUser

    getUser( );

    Returns

    the application user

    access

    public

    [ Top ]

    TApplication::initApplication

    initApplication( string 0, string 1 );

    Parameters

    0

    configuration file path (absolute or relative to current executing script)

    1

    cache file path, empty if no present or needed

    Remarks

    Loads configuration and initializes application.

    Configuration file will be read and parsed (if a valid cached version exists, it will be used instead). Then, modules are created and initialized; Afterwards, the requested service is created and initialized.

    throws

    TConfigurationException if module is redefined of invalid type, or service not defined or of invalid type

    access

    protected

    [ Top ]

    TApplication::loadGlobals

    loadGlobals( );

    Remarks

    Loads global values from persistent storage.

    This method is invoked when OnLoadState event is raised. After this method, values that are stored in previous requests become available to the current request via getGlobalState.

    access

    protected

    [ Top ]

    TApplication::onAuthentication

    onAuthentication( );

    Remarks

    Raises OnAuthentication event.

    This method is invoked when the user request needs to be authenticated.

    access

    public

    [ Top ]

    TApplication::onAuthenticationComplete

    onAuthenticationComplete( );

    Remarks

    Raises OnAuthenticationComplete event.

    This method is invoked right after the user request is authenticated.

    access

    public

    [ Top ]

    TApplication::onAuthorization

    onAuthorization( );

    Remarks

    Raises OnAuthorization event.

    This method is invoked when the user request needs to be authorized.

    access

    public

    [ Top ]

    TApplication::onAuthorizationComplete

    onAuthorizationComplete( );

    Remarks

    Raises OnAuthorizationComplete event.

    This method is invoked right after the user request is authorized.

    access

    public

    [ Top ]

    TApplication::onBeginRequest

    onBeginRequest( );

    Remarks

    Raises OnBeginRequest event.

    At the time when this method is invoked, application modules are loaded and initialized, user request is resolved and the corresponding service is loaded and initialized. The application is about to start processing the user request.

    access

    public

    [ Top ]

    TApplication::onEndRequest

    onEndRequest( );

    Remarks

    Raises OnEndRequest event.

    This method is invoked when the application completes the processing of the request.

    access

    public

    [ Top ]

    TApplication::onError

    onError( mixed $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnError event.

    This method is invoked when an exception is raised during the lifecycles of the application.

    access

    public

    [ Top ]

    TApplication::onLoadState

    onLoadState( );

    Remarks

    Raises OnLoadState event.

    This method is invoked when the application needs to load state (probably stored in session).

    access

    public

    [ Top ]

    TApplication::onLoadStateComplete

    onLoadStateComplete( );

    Remarks

    Raises OnLoadStateComplete event.

    This method is invoked right after the application state has been loaded.

    access

    public

    [ Top ]

    TApplication::onPreFlushOutput

    onPreFlushOutput( );

    Remarks

    Raises OnPreFlushOutput event.

    This method is invoked right before the application flushes output to client.

    access

    public

    [ Top ]

    TApplication::onPreRunService

    onPreRunService( );

    Remarks

    Raises OnPreRunService event.

    This method is invoked right before the service is to be run.

    access

    public

    [ Top ]

    TApplication::onSaveState

    onSaveState( );

    Remarks

    Raises OnSaveState event.

    This method is invoked when the application needs to save state (probably stored in session).

    access

    public

    [ Top ]

    TApplication::onSaveStateComplete

    onSaveStateComplete( );

    Remarks

    Raises OnSaveStateComplete event.

    This method is invoked right after the application state has been saved.

    access

    public

    [ Top ]

    TApplication::resolvePaths

    resolvePaths( string $basePath );

    Parameters

    $basePath

    the application root path or the application configuration file

    Remarks

    Resolves application-relevant paths.

    This method is invoked by the application constructor to determine the application configuration file, application root path and the runtime path.

    see

    TApplication::setConfigurationFile()

    see

    TApplication::setRuntimePath()

    see

    TApplication::setBasePath()

    access

    protected

    [ Top ]

    TApplication::run

    run( );

    Overridden in child classes as:

    TShellApplication::run()
    Runs the application.

    Remarks

    Executes the lifecycles of the application.

    This is the main entry function that leads to the running of the whole Prado application.

    access

    public

    [ Top ]

    TApplication::runService

    runService( );

    Remarks

    Runs the requested service.

    access

    public

    [ Top ]

    TApplication::saveGlobals

    saveGlobals( );

    Remarks

    Saves global values into persistent storage.

    This method is invoked when OnSaveState event is raised.

    access

    protected

    [ Top ]

    TApplication::setApplicationStatePersister

    setApplicationStatePersister( IStatePersister $persister );

    Parameters

    $persister

    application state persister

    access

    public

    [ Top ]

    TApplication::setAssetManager

    setAssetManager( $value );

    Parameters

    $value

    asset manager

    access

    public

    [ Top ]

    TApplication::setBasePath

    setBasePath( string $value );

    Parameters

    $value

    the directory containing the application configuration file

    access

    public

    [ Top ]

    TApplication::setCache

    setCache( ICache $cache );

    Parameters

    $cache

    the cache module

    access

    public

    [ Top ]

    TApplication::setConfigurationFile

    setConfigurationFile( string $value );

    Parameters

    $value

    the application configuration file (absolute path)

    access

    public

    [ Top ]

    TApplication::setConfigurationType

    setConfigurationType( string $value );

    Parameters

    $value

    the application configuration type. 'xml' and 'php' are valid values

    access

    public

    [ Top ]

    TApplication::setErrorHandler

    setErrorHandler( $handler );

    Parameters

    $handler

    the error handler module

    access

    public

    [ Top ]

    TApplication::setGlobalization

    setGlobalization( $glob );

    Parameters

    $glob

    globalization module

    access

    public

    [ Top ]

    TApplication::setGlobalState

    setGlobalState( string $key, mixed $value, [mixed $defaultValue = null], [boolean $forceSave = false] );

    Parameters

    $key

    the name of the value to be set

    $value

    the global value to be set

    $defaultValue

    the default value. If $key is not found, $defaultValue will be returned

    $forceSave

    wheter to force an immediate GlobalState save. defaults to false

    Remarks

    Sets a global value.

    A global value is one that is persistent across users sessions and requests. Make sure that the value is serializable and unserializable.

    access

    public

    [ Top ]

    TApplication::setID

    setID( string $value );

    Parameters

    $value

    application ID

    access

    public

    [ Top ]

    TApplication::setMode

    setMode( TApplicationMode $value );

    Parameters

    $value

    application mode

    access

    public

    [ Top ]

    TApplication::setModule

    setModule( string $id, IModule $module );

    Parameters

    $id

    ID of the module

    $module

    module object

    Remarks

    Adds a module to application.

    Note, this method does not do module initialization.

    access

    public

    [ Top ]

    TApplication::setPageServiceID

    setPageServiceID( string $value );

    Parameters

    $value

    page service ID

    access

    public

    [ Top ]

    TApplication::setRequest

    setRequest( $request );

    Parameters

    $request

    the request module

    access

    public

    [ Top ]

    TApplication::setResponse

    setResponse( $response );

    Parameters

    $response

    the request module

    access

    public

    [ Top ]

    TApplication::setRuntimePath

    setRuntimePath( string $value );

    Parameters

    $value

    the directory storing cache data and application-level persistent data. (absolute path)

    access

    public

    [ Top ]

    TApplication::setSecurityManager

    setSecurityManager( $sm );

    Parameters

    $sm

    the security manager module

    access

    public

    [ Top ]

    TApplication::setService

    setService( IService $value );

    Parameters

    $value

    the currently requested service

    access

    public

    [ Top ]

    TApplication::setSession

    setSession( $session );

    Parameters

    $session

    the session module

    access

    public

    [ Top ]

    TApplication::setUser

    setUser( IUser $user );

    Parameters

    $user

    the application user

    access

    public

    [ Top ]

    TApplication::startService

    startService( string $serviceID );

    Parameters

    $serviceID

    service ID

    Remarks

    Starts the specified service.

    The service instance will be created. Its properties will be initialized and the configurations will be applied, if any.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • CONFIGCACHE_FILE = 'config.cache' [line 158]

    • Remarks

    Config cache file

  • CONFIG_FILE_EXT_PHP = '.php' [line 146]

    • Remarks

    File extension for external config files

  • CONFIG_FILE_EXT_XML = '.xml' [line 134]

    • Remarks

    File extension for external config files

  • CONFIG_FILE_PHP = 'application.php' [line 142]

    • Remarks

    Application configuration file name

  • CONFIG_FILE_XML = 'application.xml' [line 130]

    • Remarks

    Application configuration file name

  • CONFIG_TYPE_PHP =  'php' [line 150]

    • Remarks

    Configuration file type, application.php and config.php

  • CONFIG_TYPE_XML =  'xml' [line 138]

    • Remarks

    Configuration file type, application.xml and config.xml

  • GLOBAL_FILE = 'global.cache' [line 162]

    • Remarks

    Global data file

  • PAGE_SERVICE_ID = 'page' [line 126]

    • Remarks

    Page service ID

  • RUNTIME_PATH = 'runtime' [line 154]

    • Remarks

    Runtime directory name

  • STATE_DEBUG = 'Debug' [line 119]

  • STATE_NORMAL = 'Normal' [line 120]

  • STATE_OFF = 'Off' [line 118]

    • Remarks

    possible application mode.

    deprecated

    deprecated since version 3.0.4 (use TApplicationMode constants instead)

  • STATE_PERFORMANCE = 'Performance' [line 121]

Documentation generated on Mon, 25 Jun 2012 14:43:30 +0200 by phpDocumentor 1.4.3


Docs For Class TApplicationConfiguration

Class TApplicationConfiguration

[line 1275]
TComponent
   |
   --TApplicationConfiguration
Location: /TApplication.php

Remarks

TApplicationConfiguration class.

This class is used internally by TApplication to parse and represent application configuration.

author

Carl G. Mathisen <carlgmathisen@gmail.com>

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TApplication.php 3151 2012-05-29 09:52:51Z ctrlaltca $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TApplicationConfiguration::getAliases

    getAliases( );

    Returns

    list of path alias definitions

    Remarks

    Returns list of path alias definitions.

    The definitions are aggregated (top-down) from configuration files along the path to the specified page. Each array element represents a single alias definition, with the key being the alias name and the value the absolute path.

    access

    public

    [ Top ]

    TApplicationConfiguration::getExternalConfigurations

    getExternalConfigurations( );

    Returns

    list of external configuration files. Each element is like $filePath=>$condition

    access

    public

    [ Top ]

    TApplicationConfiguration::getIsEmpty

    getIsEmpty( );

    Returns

    whether this configuration contains actual stuff

    access

    public

    [ Top ]

    TApplicationConfiguration::getModules

    getModules( );

    Returns

    list of module configurations to be used

    Remarks

    Returns list of module configurations.

    The module configurations are aggregated (top-down) from configuration files along the path to the specified page. Each array element represents a single module configuration, with the key being the module ID and the value the module configuration. Each module configuration is stored in terms of an array with the following content ([0]=>module type, [1]=>module properties, [2]=>complete module configuration) The module properties are an array of property values indexed by property names. The complete module configuration is a TXmlElement object representing the raw module configuration which may contain contents enclosed within module tags.

    access

    public

    [ Top ]

    TApplicationConfiguration::getParameters

    getParameters( );

    Returns

    list of parameter definitions to be used

    Remarks

    Returns list of parameter definitions.

    The parameter definitions are aggregated (top-down) from configuration files along the path to the specified page. Each array element represents a single parameter definition, with the key being the parameter ID and the value the parameter definition. A parameter definition can be either a string representing a string-typed parameter, or an array. The latter defines a component-typed parameter whose format is as follows, ([0]=>component type, [1]=>component properties) The component properties are an array of property values indexed by property names.

    access

    public

    [ Top ]

    TApplicationConfiguration::getProperties

    getProperties( );

    Returns

    list of page initial property values

    Remarks

    Returns list of page initial property values.

    Each array element represents a single property with the key being the property name and the value the initial property value.

    access

    public

    [ Top ]

    TApplicationConfiguration::getServices

    getServices( );

    Returns

    list of service configurations

    access

    public

    [ Top ]

    TApplicationConfiguration::getUsings

    getUsings( );

    Returns

    list of namespaces to be used

    Remarks

    Returns list of namespaces to be used.

    The namespaces are aggregated (top-down) from configuration files along the path to the specified page. Each array element represents a single namespace usage, with the value being the namespace to be used.

    access

    public

    [ Top ]

    TApplicationConfiguration::loadExternalPhp

    loadExternalPhp( array $includeNode, string $configPath );

    Parameters

    $includeNode

    the application PHP array

    $configPath

    the context path (for specifying relative paths)

    Remarks

    Loads the external PHP array.

    access

    protected

    [ Top ]

    TApplicationConfiguration::loadExternalXml

    loadExternalXml( TXmlElement $includeNode, string $configPath );

    Parameters

    $includeNode

    the application DOM element

    $configPath

    the context path (for specifying relative paths)

    Remarks

    Loads the external XML configurations.

    access

    protected

    [ Top ]

    TApplicationConfiguration::loadFromFile

    loadFromFile( string $fname );

    Parameters

    $fname

    configuration file name

    Remarks

    Parses the application configuration file.

    throws

    TConfigurationException if there is any parsing error

    access

    public

    [ Top ]

    TApplicationConfiguration::loadFromPhp

    loadFromPhp( array $config, string $configPath );

    Parameters

    $config

    the PHP array

    $configPath

    the context path (for specifying relative paths)

    Remarks

    Parses the application configuration given in terms of a PHP array.

    access

    public

    [ Top ]

    TApplicationConfiguration::loadFromXml

    loadFromXml( TXmlElement $dom, string $configPath );

    Parameters

    $dom

    the XML element

    $configPath

    the context path (for specifying relative paths)

    Remarks

    Parses the application configuration given in terms of a TXmlElement.

    access

    public

    [ Top ]

    TApplicationConfiguration::loadModulesPhp

    loadModulesPhp( array $modulesNode, string $configPath );

    Parameters

    $modulesNode

    the modules PHP array

    $configPath

    the context path (for specifying relative paths)

    Remarks

    Loads the modules PHP array.

    access

    protected

    [ Top ]

    TApplicationConfiguration::loadModulesXml

    loadModulesXml( TXmlElement $modulesNode, string $configPath );

    Parameters

    $modulesNode

    the modules XML node

    $configPath

    the context path (for specifying relative paths)

    Remarks

    Loads the modules XML node.

    access

    protected

    [ Top ]

    TApplicationConfiguration::loadParametersPhp

    loadParametersPhp( array $parametersNode, string $configPath );

    Parameters

    $parametersNode

    the parameters PHP array

    $configPath

    the context path (for specifying relative paths)

    Remarks

    Loads the parameters PHP array.

    access

    protected

    [ Top ]

    TApplicationConfiguration::loadParametersXml

    loadParametersXml( TXmlElement $parametersNode, string $configPath );

    Parameters

    $parametersNode

    the parameters XML node

    $configPath

    the context path (for specifying relative paths)

    Remarks

    Loads the parameters XML node.

    access

    protected

    [ Top ]

    TApplicationConfiguration::loadPathsPhp

    loadPathsPhp( array $pathsNode, string $configPath );

    Parameters

    $pathsNode

    the paths PHP array

    $configPath

    the context path (for specifying relative paths)

    Remarks

    Loads the paths PHP array

    access

    protected

    [ Top ]

    TApplicationConfiguration::loadPathsXml

    loadPathsXml( TXmlElement $pathsNode, string $configPath );

    Parameters

    $pathsNode

    the paths XML node

    $configPath

    the context path (for specifying relative paths)

    Remarks

    Loads the paths XML node.

    access

    protected

    [ Top ]

    TApplicationConfiguration::loadServicesPhp

    loadServicesPhp( array $servicesNode, string $configPath );

    Parameters

    $servicesNode

    the services PHP array

    $configPath

    the context path (for specifying relative paths)

    Remarks

    Loads the services PHP array.

    access

    protected

    [ Top ]

    TApplicationConfiguration::loadServicesXml

    loadServicesXml( TXmlElement $servicesNode, string $configPath );

    Parameters

    $servicesNode

    the services XML node

    $configPath

    the context path (for specifying relative paths)

    Remarks

    Loads the services XML node.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:31 +0200 by phpDocumentor 1.4.3


Docs For Class TApplicationMode

Class TApplicationMode

[line 1255]
TEnumerable
   |
   --TApplicationMode
Location: /TApplication.php

Remarks

TApplicationMode class.

TApplicationMode defines the possible mode that an application can be set at by setting TApplication::setMode. In particular, the following modes are defined

  • Off: the application is not running. Any request to the application will obtain an error.
  • Debug: the application is running in debug mode.
  • Normal: the application is running in normal production mode.
  • Performance: the application is running in performance mode.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TApplication.php 3151 2012-05-29 09:52:51Z ctrlaltca $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Debug = 'Debug'
  • Normal = 'Normal'
  • Off = 'Off'
  • Performance = 'Performance'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Debug = 'Debug' [line 1258]

  • Normal = 'Normal' [line 1259]

  • Off = 'Off' [line 1257]

  • Performance = 'Performance' [line 1260]

Documentation generated on Mon, 25 Jun 2012 14:43:31 +0200 by phpDocumentor 1.4.3


Docs For Class TApplicationStatePersister

Class TApplicationStatePersister

[line 1784]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TApplicationStatePersister
Location: /TApplication.php

Remarks

TApplicationStatePersister class.

TApplicationStatePersister provides a file-based persistent storage for application state. Application state, when serialized, is stored in a file named 'global.cache' under the 'runtime' directory of the application. Cache will be exploited if it is enabled.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TApplication.php 3151 2012-05-29 09:52:51Z ctrlaltca $

since

3.0

Class Variable Summary

Class Constant Summary

  • CACHE_NAME = 'prado:appstate'
    Name of the value stored in cache

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TApplicationStatePersister::getStateFilePath

    getStateFilePath( );

    Returns

    the file path storing the application state

    access

    protected

    [ Top ]

    TApplicationStatePersister::init

    init( TXmlElement $config );

    Overrides TModule::init() (Initializes the module.)

    Parameters

    $config

    module configuration (may be null)

    Remarks

    Initializes module.

    access

    public

    [ Top ]

    TApplicationStatePersister::load

    load( );

    Implementation of:
    IStatePersister::load()
    Loads state from a persistent storage.

    Returns

    application state

    Remarks

    Loads application state from persistent storage.

    access

    public

    [ Top ]

    TApplicationStatePersister::save

    save( mixed $state );

    Implementation of:
    IStatePersister::save()
    Saves state into a persistent storage.

    Parameters

    $state

    application state

    Remarks

    Saves application state in persistent storage.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • CACHE_NAME = 'prado:appstate' [line 1789]

    • Remarks

    Name of the value stored in cache

Documentation generated on Mon, 25 Jun 2012 14:43:31 +0200 by phpDocumentor 1.4.3


Docs For Class TApplicationComponent

Class TApplicationComponent

[line 35]
TComponent
   |
   --TApplicationComponent
Classes extended from TApplicationComponent:
TModule
TModule class.
TService
TService class.
TLogRoute
TLogRoute class.
TRpcClient
TRpcClient class
TJsonResponse
TJsonResponse Class
TSoapServer
TSoapServer class.
THttpRequest
THttpRequest class
THttpResponseAdapter
THttpResponseAdapter class.
THttpSession
THttpSession class
TCallbackClientScript
TCallbackClientScript class.
TClientScriptManager
TClientScriptManager class.
TControl
TControl class
TControlAdapter
TControlAdapter class
THtmlWriter
THtmlWriter class
TTemplate
TTemplate implements PRADO template parsing logic.
TTheme
TTheme class
TDataGridColumn
TDataGridColumn class

Location: /TApplicationComponent.php

Remarks

TApplicationComponent class

TApplicationComponent is the base class for all components that are application-related, such as controls, modules, services, etc.

TApplicationComponent mainly defines a few properties that are shortcuts to some commonly used methods. The Application property gives the application instance that this component belongs to; Service gives the current running service; Request, Response and Session return the request and response modules, respectively; And User gives the current user instance.

Besides, TApplicationComponent defines two shortcut methods for publishing private files: publishAsset and publishFilePath.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TApplicationComponent.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TApplicationComponent::getApplication

    getApplication( );

    Returns

    current application instance

    access

    public

    [ Top ]

    TApplicationComponent::getRequest

    getRequest( );

    Returns

    the current user request

    access

    public

    [ Top ]

    TApplicationComponent::getResponse

    getResponse( );

    Overridden in child classes as:

    THttpResponseAdapter::getResponse()

    Returns

    the response

    access

    public

    [ Top ]

    TApplicationComponent::getService

    getService( );

    Returns

    the current service

    access

    public

    [ Top ]

    TApplicationComponent::getSession

    getSession( );

    Returns

    user session

    access

    public

    [ Top ]

    TApplicationComponent::getUser

    getUser( );

    Overridden in child classes as:

    TDbUserManager::getUser()
    Returns a user instance given the user name.
    TUserManager::getUser()
    Returns a user instance given the user name.

    Returns

    information about the current user

    access

    public

    [ Top ]

    TApplicationComponent::publishAsset

    publishAsset( string $assetPath, [string $className = null] );

    Parameters

    $assetPath

    path of the asset that is relative to the directory containing the specified class file.

    $className

    name of the class whose containing directory will be prepend to the asset path. If null, it means get_class($this).

    Returns

    URL to the asset path.

    Remarks

    Publishes a private asset and gets its URL.

    This method will publish a private asset (file or directory) and gets the URL to the asset. Note, if the asset refers to a directory, all contents under that directory will be published. Also note, it is recommended that you supply a class name as the second parameter to the method (e.g. publishAsset($assetPath,__CLASS__) ). By doing so, you avoid the issue that child classes may not work properly because the asset path will be relative to the directory containing the child class file.

    access

    public

    [ Top ]

    TApplicationComponent::publishFilePath

    publishFilePath( string $fullPath );

    Overridden in child classes as:

    TAssetManager::publishFilePath()
    Publishes a file or a directory (recursively).

    Parameters

    $fullPath

    absolute path of the file or directory to be published

    Returns

    URL to the published file or directory

    Remarks

    Publishes a file or directory and returns its URL.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:31 +0200 by phpDocumentor 1.4.3


Docs For Class TComponent

Class TComponent

[line 99]

Classes extended from TComponent:

TCacheDependency

TCacheDependency class.

TDummyDataSource

TDummyDataSource class

TList

TList class

TMap

TMap class

TPagedDataSource

TPagedDataSource class

TQueue

TQueue class

TStack

TStack class

TActiveRecord

Base class for active records.

TActiveRecordGateway

TActiveRecordGateway excutes the SQL command queries and returns the data  record as arrays (for most finder methods).

TActiveRecordManager

TActiveRecordManager provides the default DB connection,  default active record gateway, and table meta data inspector.

TOracleTableInfo

TDbTableInfo class describes the meta data of a database table.

TDbCommandBuilder

TDbCommandBuilder provides basic methods to create query commands for tables  giving by setTableInfo the property.

TDbMetaData

TDbMetaData is the base class for retrieving metadata information, such as  table and columns information, from a database connection.

TDbTableColumn

TDbTableColumn class describes the column meta data of the schema for a database table.

TDbTableInfo

TDbTableInfo class describes the meta data of a database table.

TDataGatewayCommand

TDataGatewayCommand is command builder and executor class for  TTableGateway and TActiveRecordGateway.

TSqlCriteria

Search criteria for TDbDataGateway.

TTableGateway

TTableGateway class provides several find methods to get data from the database  and update, insert, and delete methods.

TDiscriminator

The TDiscriminator corresponds to the <discriminator> tag within a <resultMap>.

TSubMap

TSubMap class defines a submapping value and the corresponding <resultMap>

TParameterMap

TParameterMap corresponds to the <parameterMap> element.

TParameterProperty

TParameterProperty corresponds to the <property> tag and defines  one object property for the <parameterMap>

TResultMap

TResultMap corresponds to <resultMap> mapping tag.

TResultProperty

TResultProperty corresponds a <property> tags inside a <resultMap> tag.

TSqlMapCacheModel

TSqlMapCacheModel corresponds to the <cacheModel> sql mapping configuration tag.

TSqlMapStatement

TSqlMapStatement class corresponds to <statement> element.

TSqlMapTypeHandler

A simple interface for implementing custom type handlers.

TCachingStatement

TCacheingStatement class.

TMappedStatement

TMappedStatement class executes SQL mapped statements. Mapped Statements can  hold any SQL statement and use Parameter Maps and Result Maps for input and output.

TSqlMapObjectCollectionTree

TSQLMapObjectCollectionTree class.

TResultSetListItemParameter

TResultSetListItemParameter class

TResultSetMapItemParameter

TResultSetMapItemParameter class.

TPreparedStatement

TpreparedStatement class.

TStaticSql

TStaticSql class.

TSqlMapGateway

DataMapper client, a fascade to provide access the rest of the DataMapper  framework. It provides three core functions:

TSqlMapManager

TSqlMapManager class holds the sqlmap configuation result maps, statements  parameter maps and a type handler factory.

TDbCommand

TDbCommand class.

TDbConnection

TDbConnection class

TDbDataReader

TDbDataReader class.

TDbTransaction

TDbTransaction class.

Translation

Translation class.

TTextWriter

TTextWriter class.

TAuthorizationRule

TAuthorizationRule class

TUser

TUser class

TApplication

TApplication class.

TApplicationConfiguration

TApplicationConfiguration class.

TApplicationComponent

TApplicationComponent class

TEventParameter

TEventParameter class.

TComponentReflection

TComponentReflection class.

TLogger

TLogger class.

TPageConfiguration

TPageConfiguration class

THttpCookie

THttpCookie class.

TUri

TUri class

TUrlMappingPattern

TUrlMappingPattern class.

TAutoCompleteTemplate

TAutoCompleteTemplate class.

TBaseActiveControl

TBaseActiveControl class provided additional basic property for every  active control. An instance of TBaseActiveControl or its decendent  TBaseActiveCallbackControl is created by TActiveControlAdapter::getBaseActiveControl()  method.

TCachePageStatePersister

TCachePageStatePersister class

TClientSideOptions

TClientSideOptions abstract class.

TCompositeLiteral

TCompositeLiteral class

TPageStatePersister

TPageStatePersister class

TSessionPageStatePersister

TSessionPageStatePersister class

TDataSourceSelectParameters

TDataSourceSelectParameters class

TDataSourceView

TDataSourceView class

TFont

TFont class

TMetaTag

TMetaTag class.

THotSpot

THotSpot class.

TListItem

TListItem class.

TRepeatInfo

TRepeatInfo class.

TStyle

TStyle class

TWebControlDecorator

TWebControlDecorator class

TWizardSideBarTemplate

TWizardSideBarTemplate class.

TWizardSideBarListItemTemplate

TWizardSideBarListItemTemplate class.

TWizardNavigationTemplate

TWizardNavigationTemplate class.

TXmlElement

TXmlElement class.

Location: /TComponent.php

Remarks

TComponent class

TComponent is the base class for all PRADO components.  TComponent implements the protocol of defining, using properties and events.
A property is defined by a getter method, and/or a setter method.  Properties can be accessed in the way like accessing normal object members.  Reading or writing a property will cause the invocation of the corresponding  getter or setter method, e.g.,
  •  $a=$this->Text;     // equivalent to $a=$this->getText();
    •

  •  $this->Text='abc';  // equivalent to $this->setText('abc');
    •

      The signatures of getter and setter methods are as follows,
  •  // getter, defines a readable property 'Text'
    •

  •  function getText() { ... }
    •

  •  // setter, defines a writable property 'Text', with $value being the value to be set to the property
    •

  •  function setText($value) { ... }
    •

      Property names are case-insensitive. It is recommended that they are written  in the format of concatenated words, with the first letter of each word  capitalized (e.g. DisplayMode, ItemStyle).
    Since Prado 3.2 a new class of javascript-friendly properties have been introduced  to better deal with potential security problems like cross-site scripting issues.  All the data that gets sent clientside inside a javascript block is now encoded by default.  Sometimes there's the need to bypass this encoding and be able to send raw javascript code.  This new class of javascript-friendly properties are identified by their name  starting with 'js' (case insensitive):
  •  // getter, defines a readable property 'Text'
    •

  •  function getJsText() { ... }
    •

  •  // setter, defines a writable property 'Text', with $value being the value to be set to the property
    •

  •  function setJsText(TJavaScriptLiteral $value) { ... }
    •

      Js-friendly properties can be accessed using both their Js-less name and their Js-enabled name:
  •  // set some simple text as property value
    •

  •  $component->Text = 'text';
    •

  •  // set some javascript code as property value
    •

  •  $component->JsText = 'raw javascript';
    •

      In the first case, the property value will automatically gets encoded when sent  clientside inside a javascript block.  In the second case, the property will be 'marked' as being a safe javascript  statement and will not be encoded when rendered inside a javascript block.  This special handling makes use of the TJavaScriptLiteral class.
    An event is defined by the presence of a method whose name starts with 'on'.  The event name is the method name and is thus case-insensitive.  An event can be attached with one or several methods (called event handlers).  An event can be raised by calling raiseEvent method, upon which  the attached event handlers will be invoked automatically in the order they  are attached to the event. Event handlers must have the following signature,
  •  function eventHandlerFuncName($sender,$param) { ... }
    •

      where $sender refers to the object who is responsible for the raising of the event,  and $param refers to a structure that may contain event-specific information.  To raise an event (assuming named as 'Click') of a component, use
  •  $component->raiseEvent('OnClick');
    •

      To attach an event handler to an event, use one of the following ways,
  •  $component->OnClick=$callback;  // or $component->OnClick->add($callback);
    •

  •  $component->attachEventHandler('OnClick',$callback);
    •

      The first two ways make use of the fact that $component->OnClick refers to  the event handler list TList for the 'OnClick' event.  The variable $callback contains the definition of the event handler that can  be either a string referring to a global function name, or an array whose  first element refers to an object and second element a method name/path that  is reachable by the object, e.g.
    • 'buttonClicked' : buttonClicked($sender,$param);
    • array($object,'buttonClicked') : $object->buttonClicked($sender,$param);
    • array($object,'MainContent.SubmitButton.buttonClicked') :
   $object->MainContent->SubmitButton->buttonClicked($sender,$param);

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TComponent.php 3123 2012-03-26 10:10:51Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Method Detail

      TComponent::addParsedObject

addParsedObject(
string|TComponent
$object );

      Overridden in child classes as:

      TControl::addParsedObject()

      Adds the object instantiated on a template to the child control collection.

      TConditional::addParsedObject()

      Processes an object that is created during parsing template.

      THead::addParsedObject()

      Processes an object that is created during parsing template.

      TMultiView::addParsedObject()

      Processes an object that is created during parsing template.

      TAccordion::addParsedObject()

      Adds object parsed from template to the control.

      TDataGrid::addParsedObject()

      Adds objects parsed in template to datagrid.

      TListControl::addParsedObject()

      Adds object parsed from template to the control.

      TImageMap::addParsedObject()

      Processes an object that is created during parsing template.

      TTable::addParsedObject()

      Adds object parsed from template to the control.

      TTableRow::addParsedObject()

      Adds object parsed from template to the control.

      TTabPanel::addParsedObject()

      Adds object parsed from template to the control.

      TTextProcessor::addParsedObject()

      HTML-decodes static text.

      TWizard::addParsedObject()

      Adds TWizardStep objects into step collection.

      TDropDownListColumn::addParsedObject()

      Adds object parsed from template to the control.

      Parameters

      $object

      text string or component parsed and instantiated in template

      Remarks

      Processes an object that is created during parsing template.

      The object can be either a component or a static text string.  This method can be overridden to customize the handling of newly created objects in template.  Only framework developers and control developers should use this method.

      see

      TComponent::createdOnTemplate()

      access

      public

      [ Top ]

      TComponent::attachEventHandler

attachEventHandler(
string
$name, callback
$handler );

      Parameters

      $name

      the event name

      $handler

      the event handler

      Remarks

      Attaches an event handler to an event.

      The handler must be a valid PHP callback, i.e., a string referring to  a global function name, or an array containing two elements with  the first element being an object and the second element a method name  of the object. In Prado, you can also use method path to refer to  an event handler. For example, array($object,'Parent.buttonClicked')  uses a method path that refers to the method $object->Parent->buttonClicked(...).
      The event handler must be of the following signature,
    •  function handlerName($sender,$param) {}
      •

        where $sender represents the object that raises the event,  and $param is the event parameter.
      This is a convenient method to add an event handler.  It is equivalent to getEventHandlers($name)->add($handler).  For complete management of event handlers, use getEventHandlers  to get the event handler list first, and then do various  TList operations to append, insert or remove  event handlers. You may also do these operations like  getting and setting properties, e.g.,
    •  $component->OnClick[]=array($object,'buttonClicked');
      •

    •  $component->OnClick->insertAt(0,array($object,'buttonClicked'));
      •

        which are equivalent to the following
    •  $component->getEventHandlers('OnClick')->add(array($object,'buttonClicked'));
      •

    •  $component->getEventHandlers('OnClick')->insertAt(0,array($object,'buttonClicked'));
      •

      throws

      TInvalidOperationException if the event does not exist

      access

      public

      [ Top ]

      TComponent::canGetProperty

canGetProperty(
string
$name );

      Overridden in child classes as:

      TAttributeCollection::canGetProperty()

      Determines whether a property can be read.

      Parameters

      $name

      the property name

      Returns

      whether the property can be read

      Remarks

      Determines whether a property can be read.

      A property can be read if the class has a getter method  for the property name. Note, property name is case-insensitive.

      access

      public

      [ Top ]

      TComponent::canSetProperty

canSetProperty(
string
$name );

      Overridden in child classes as:

      TAttributeCollection::canSetProperty()

      Determines whether a property can be set.

      Parameters

      $name

      the property name

      Returns

      whether the property can be written

      Remarks

      Determines whether a property can be set.

      A property can be written if the class has a setter method  for the property name. Note, property name is case-insensitive.

      access

      public

      [ Top ]

      TComponent::createdOnTemplate

createdOnTemplate(
TComponent
$parent );

      Overridden in child classes as:

      TContent::createdOnTemplate()

      This method is invoked after the control is instantiated on a template.

      TContentPlaceHolder::createdOnTemplate()

      This method is invoked after the control is instantiated on a template.

      Parameters

      $parent

      potential parent of this control

      Remarks

      This method is invoked after the component is instantiated by a template.

      When this method is invoked, the component's properties have been initialized.  The default implementation of this method will invoke  the potential parent component's addParsedObject.  This method can be overridden.

      see

      TComponent::addParsedObject()

      access

      public

      [ Top ]

      TComponent::detachEventHandler

detachEventHandler(
string
$name, callback
$handler );

      Parameters

      $name

      event name

      $handler

      the event handler to be removed

      Returns

      if the removal is successful

      Remarks

      Detaches an existing event handler.

      This method is the opposite of attachEventHandler.

      access

      public

      [ Top ]

      TComponent::evaluateExpression

evaluateExpression(

$expression );

      Parameters

      $expression

      Returns

      the expression result

      Remarks

      Evaluates a PHP expression in the context of this control.

      throws

      TInvalidOperationException if the expression is invalid

      access

      public

      [ Top ]

      TComponent::evaluateStatements

evaluateStatements(
string
$statements );

      Parameters

      $statements

      PHP statements

      Returns

      content echoed or printed by the PHP statements

      Remarks

      Evaluates a list of PHP statements.

      throws

      TInvalidOperationException if the statements are invalid

      access

      public

      [ Top ]

      TComponent::getEventHandlers

getEventHandlers(

$name );

      Parameters

      $name

      Returns

      list of attached event handlers for an event

      Remarks

      Returns the list of attached event handlers for an event.

      throws

      TInvalidOperationException if the event is not defined

      access

      public

      [ Top ]

      TComponent::getSubProperty

getSubProperty(
string
$path );

      Parameters

      $path

      property path

      Returns

      the property path value

      Remarks

      Evaluates a property path.

      A property path is a sequence of property names concatenated by '.' character.  For example, 'Parent.Page' refers to the 'Page' property of the component's  'Parent' property value (which should be a component also).

      access

      public

      [ Top ]

      TComponent::hasEvent

hasEvent(
string
$name );

      Parameters

      $name

      the event name

      Remarks

      Determines whether an event is defined.

      An event is defined if the class has a method whose name is the event name prefixed with 'on'.  Note, event name is case-insensitive.

      access

      public

      [ Top ]

      TComponent::hasEventHandler

hasEventHandler(

$name );

      Parameters

      $name

      Returns

      whether an event has been attached one or several handlers

      access

      public

      [ Top ]

      TComponent::hasProperty

hasProperty(
string
$name );

      Overridden in child classes as:

      TAttributeCollection::hasProperty()

      Determines whether a property is defined.

      Parameters

      $name

      the property name

      Returns

      whether the property is defined

      Remarks

      Determines whether a property is defined.

      A property is defined if there is a getter or setter method  defined in the class. Note, property names are case-insensitive.

      access

      public

      [ Top ]

      TComponent::raiseEvent

raiseEvent(
string
$name, mixed
$sender, TEventParameter
$param );

      Parameters

      $name

      the event name

      $sender

      the event sender object

      $param

      the event parameter

      Remarks

      Raises an event.

      This method represents the happening of an event and will  invoke all attached event handlers for the event.

      throws

      TInvalidDataValueException If an event handler is invalid

      throws

      TInvalidOperationException if the event is undefined

      access

      public

      [ Top ]

      TComponent::setSubProperty

setSubProperty(
string
$path, mixed
$value );

      Parameters

      $path

      property path

      $value

      the property path value

      Remarks

      Sets a value to a property path.

      A property path is a sequence of property names concatenated by '.' character.  For example, 'Parent.Page' refers to the 'Page' property of the component's  'Parent' property value (which should be a component also).

      access

      public

      [ Top ]

      TComponent::__call

__call(
string
$name, mixed
$params );

      Overridden in child classes as:

      TActiveRecord::__call()

      Dynamic find method using parts of method name as search criteria.

      TTableGateway::__call()

      Dynamic find method using parts of method name as search criteria.

      TJsonRpcClient::__call()

      TXmlRpcClient::__call()

      Parameters

      $name

      the getter or setter method name

      $params

      method call parameters

      Remarks

      Calls a method.

      Do not call this method. This is a PHP magic method that we override  to allow using the following syntax to call a property setter or getter.
    •  $this->getPropertyName($value); // if there's a $this->getjsPropertyName() method
      •

    •  $this->setPropertyName($value); // if there's a $this->setjsPropertyName() method
      •

      throws

      TInvalidOperationException If the property is not defined or read-only.

      access

      public

      [ Top ]

      TComponent::__get

__get(
string
$name );

      Overridden in child classes as:

      TAttributeCollection::__get()

      Returns a property value or an event handler list by property or event name.

      TActiveRecord::__get()

      Magic method for reading properties.

      TControl::__get()

      Returns a property value by name or a control by ID.

      Parameters

      $name

      the property name or the event name

      Returns

      the property value or the event handler list

      Remarks

      Returns a property value or an event handler list by property or event name.

      Do not call this method. This is a PHP magic method that we override  to allow using the following syntax to read a property:
    •  $value=$component->PropertyName;
      •

    •  $value=$component->jsPropertyName; // return JavaScript literal
      •

        and to obtain the event handler list for an event,
    •  $eventHandlerList=$component->EventName;
      •

      throws

      TInvalidOperationException if the property/event is not defined.

      access

      public

      [ Top ]

      TComponent::__set

__set(
string
$name, mixed
$value );

      Overridden in child classes as:

      TAttributeCollection::__set()

      Sets value of a component property.

      TActiveRecord::__set()

      Magic method for writing properties.

      Parameters

      $name

      the property name or event name

      $value

      the property value or event handler

      Remarks

      Sets value of a component property.

      Do not call this method. This is a PHP magic method that we override  to allow using the following syntax to set a property or attach an event handler.
    •  $this->PropertyName=$value;
      •

    •  $this->jsPropertyName=$value; // $value will be treated as a JavaScript literal
      •

    •  $this->EventName=$handler;
      •

      throws

      TInvalidOperationException If the property is not defined or read-only.

      access

      public

      [ Top ]

      TComponent::__sleep

__sleep(
 );

      Overridden in child classes as:

      TActiveRecord::__sleep()

      Prevent __call() method creating __sleep() when serializing.

      TParameterProperty::__sleep()

      TResultProperty::__sleep()

      TSqlMapStatement::__sleep()

      TMappedStatement::__sleep()

      TSqlMapObjectCollectionTree::__sleep()

      TPreparedStatement::__sleep()

      TDbCommand::__sleep()

      Set the statement to null when serializing.

      TDbConnection::__sleep()

      Close the connection when serializing.

      Remarks

      Returns an array with the names of all variables of that object that should be serialized.

      Do not call this method. This is a PHP magic method that will be called automatically  prior to any serialization.

      access

      public

      [ Top ]

      TComponent::__wakeup

__wakeup(
 );

      Overridden in child classes as:

      TActiveRecord::__wakeup()

      Prevent __call() method creating __wakeup() when unserializing.

      TMappedStatement::__wakeup()

      TPreparedStatement::__wakeup()

      Remarks

      Do not call this method. This is a PHP magic method that will be called automatically  after any unserialization; it can perform reinitialization tasks on the object.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:49 +0200 by phpDocumentor 1.4.3


Docs For Class TComponentReflection

Class TComponentReflection

[line 817]
TComponent
   |
   --TComponentReflection
Location: /TComponent.php

Remarks

TComponentReflection class.

TComponentReflection provides functionalities to inspect the public/protected properties, events and methods defined in a class.

The following code displays the properties and events defined in TDataGrid,

  •    $reflection=new TComponentReflection('TDataGrid');
    •

  •    Prado::varDump($reflection->getProperties());
    •

  •    Prado::varDump($reflection->getEvents());
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TComponent.php 3123 2012-03-26 10:10:51Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TComponentReflection::__construct

      __construct( object|string $component );

      Parameters

      $component

      the component instance or the class name

      Remarks

      Constructor.

      throws

      TInvalidDataTypeException if the object is not a component

      access

      public

      [ Top ]

      TComponentReflection::determinePropertyType

      determinePropertyType( ReflectionMethod $method );

      Parameters

      $method

      Returns

      the property type, '{unknown}' if type cannot be determined from comment

      Remarks

      Determines the property type.

      This method uses the doc comment to determine the property type.

      access

      protected

      [ Top ]

      TComponentReflection::getClassName

      getClassName( );

      Returns

      class name of the component

      access

      public

      [ Top ]

      TComponentReflection::getEvents

      getEvents( );

      Returns

      list of component events. Array keys are event names. Each array element is of the following structure: [protected]=>whether the event is protected or not [class]=>the class where the event is inherited from. [comments]=>comments associated with the event.

      access

      public

      [ Top ]

      TComponentReflection::getMethods

      getMethods( );

      Returns

      list of public/protected methods. Array keys are method names. Each array element is of the following structure: [protected]=>whether the method is protected or not [static]=>whether the method is static or not [class]=>the class where the property is inherited from, [comments]=>comments associated with the event.

      access

      public

      [ Top ]

      TComponentReflection::getProperties

      getProperties( );

      Returns

      list of component properties. Array keys are property names. Each array element is of the following structure: [type]=>property type, [readonly]=>whether the property is read-only, [protected]=>whether the method is protected or not [class]=>the class where the property is inherited from, [comments]=>comments associated with the property.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:50 +0200 by phpDocumentor 1.4.3


Docs For Class TEnumerable

Class TEnumerable

[line 579]

Classes extended from TEnumerable:

TActiveRecordInvalidFinderResult

TActiveRecordInvalidFinderResult class.

TSqlMapCacheTypes

TSqlMapCacheTypes enumerable class.

TDbColumnCaseMode

TDbColumnCaseMode

TDbNullConversionMode

TDbNullConversionMode

TSecurityManagerValidationMode

TSecurityManagerValidationMode class.

TUserManagerPasswordMode

TUserManagerPasswordMode class.

TApplicationMode

TApplicationMode class.

TRpcClientTypesEnumerable

TRpcClientTypesEnumerable class

THttpRequestUrlFormat

THttpRequestUrlFormat class.

THttpSessionCookieMode

THttpSessionCookieMode class.

TUrlMappingPatternSecureConnection

TUrlMappingPatternSecureConnection class

TDraggableConstraint

TDraggableGhostingOptions

TDraggableRevertOptions

TValidatorDisplayStyle

TValidatorDisplayStyle class.

TValidationDataType

TValidationDataType class.

TBulletStyle

TBulletStyle class.

TBulletedListDisplayMode

TBulletedListDisplayMode class.

TButtonType

TButtonType class.

TTextAlign

TTextAlign class.

TColorPickerMode

TColorPickerMode class.

TValidationCompareOperator

TValidationCompareOperator class.

TListItemType

TListItemType class.

TDataGridPagerMode

TDataGridPagerMode class.

TDataGridPagerButtonType

TDataGridPagerButtonType class.

TDataGridPagerPosition

TDataGridPagerPosition class.

TButtonColumnType

TButtonColumnType class.

TDatePickerInputMode

TDatePickerInputMode class.

TDatePickerMode

TDatePickerMode class.

TDatePickerPositionMode

TDatePickerPositionMode class.

THotSpotMode

THotSpotMode class.

TInlineFrameAlign

TInlineFrameAlign class.

TInlineFrameScrollBars

TInlineFrameScrollBars class.

TListSelectionMode

TListSelectionMode class.

TPagerMode

TPagerMode class.

TPagerButtonType

TPagerButtonType class.

TContentDirection

TContentDirection class.

TScrollBars

TScrollBars class.

TRepeatDirection

TRepeatDirection class.

TRepeatLayout

TRepeatLayout class.

TSliderDirection

TSliderDirection class.

TDisplayStyle

TDisplayStyle defines the enumerable type for the possible styles  that a web control can display.

THorizontalAlign

THorizontalAlign class.

TVerticalAlign

TVerticalAlign class.

TTableGridLines

TTableGridLines class.

TTableCaptionAlign

TTableCaptionAlign class.

TTableHeaderScope

TTableHeaderScope class.

TTableRowSection

TTableRowSection class.

TTextBoxMode

TTextBoxMode class.

TTextBoxAutoCompleteType

TTextBoxAutoCompleteType class.

TTextHighlighterLineNumberStyle

TValidationSummaryDisplayMode

TValidationSummaryDisplayMode class.

TValidationSummaryDisplayStyle

TValidationSummaryDisplay class.

TWizardNavigationButtonType

TWizardNavigationButtonType class.

TWizardStepType

TWizardStepType class.

Location: /TComponent.php

Remarks

TEnumerable class.

TEnumerable is the base class for all enumerable types.  To define an enumerable type, extend TEnumberable and define string constants.  Each constant represents an enumerable value.  The constant name must be the same as the constant value.  For example,
  •  class TTextAlign extends TEnumerable
    •

  •  {
    •

  •      const Left='Left';
    •

  •      const Right='Right';
    •

  •  }
    •

      Then, one can use the enumerable values such as TTextAlign::Left and  TTextAlign::Right.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TComponent.php 3123 2012-03-26 10:10:51Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Method Detail

      TEnumerable::__construct

__construct(
 );

      access

      public

      [ Top ]

      TEnumerable::current

current(
 );

      Implementation of:

      Iterator::current

      access

      public

      [ Top ]

      TEnumerable::key

key(
 );

      Implementation of:

      Iterator::key

      access

      public

      [ Top ]

      TEnumerable::next

next(
 );

      Implementation of:

      Iterator::next

      access

      public

      [ Top ]

      TEnumerable::rewind

rewind(
 );

      Implementation of:

      Iterator::rewind

      access

      public

      [ Top ]

      TEnumerable::valid

valid(
 );

      Implementation of:

      Iterator::valid

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:50 +0200 by phpDocumentor 1.4.3


Docs For Class TEventParameter

Class TEventParameter

[line 795]
TComponent
   |
   --TEventParameter
Classes extended from TEventParameter:
TPagedListPageChangedEventParameter
TPagedListPageChangedEventParameter class.
TPagedListFetchDataEventParameter
TPagedListFetchDataEventParameter class.
TActiveRecordChangeEventParameter
TActiveRecordChangeEventParameter class
TDataGatewayEventParameter
TDataGatewayEventParameter class contains the TDbCommand to be executed as well as the criteria object.
TDataGatewayResultEventParameter
TDataGatewayResultEventParameter contains the TDbCommand executed and the resulting data returned from the database. The data can be changed by changing the setResult property.
TCallbackEventParameter
TCallbackEventParameter class.
TDropContainerEventParameter
TDropContainerEventParameter class
TBroadcastEventParameter
TBroadcastEventParameter class
TCommandEventParameter
TCommandEventParameter class
TBulletedListEventParameter
TBulletedListEventParameter Event parameter for TBulletedList::onClick event of the bulleted list. The getIndex gives the zero-based index of the item that is currently being clicked.
TServerValidateEventParameter
TServerValidateEventParameter class
TDataGridItemEventParameter
TDataGridItemEventParameter class
TDataGridPagerEventParameter
TDataGridPagerEventParameter class
TDataGridSortCommandEventParameter
TDataGridSortCommandEventParameter class
TDataGridPageChangedEventParameter
TDataGridPageChangedEventParameter class
TDataListItemEventParameter
TDataListItemEventParameter class
TImageClickEventParameter
TImageClickEventParameter class
TImageMapEventParameter
TImageMapEventParameter class.
TOutputCacheCheckDependencyEventParameter
TOutputCacheCheckDependencyEventParameter class
TOutputCacheCalculateKeyEventParameter
TOutputCacheCalculateKeyEventParameter class
TPagerPageChangedEventParameter
TPagerPageChangedEventParameter class
TRepeaterItemEventParameter
TRepeaterItemEventParameter class
TWizardNavigationEventParameter
TWizardNavigationEventParameter class.

Location: /TComponent.php

Remarks

TEventParameter class.

TEventParameter is the base class for all event parameter classes.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TComponent.php 3123 2012-03-26 10:10:51Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:50 +0200 by phpDocumentor 1.4.3


Docs For Class TJavaScriptLiteral

Class TJavaScriptLiteral

[line 1003]

Classes extended from TJavaScriptLiteral:

TJavaScriptString

TJavaScriptString class is an internal class that marks strings that will be  forcibly encoded when rendered inside a javascript block

Location: /TComponent.php

Remarks

TJavaScriptLiteral class that encloses string literals that are not  supposed to be escaped by TJavaScript::encode()

Since Prado 3.2 all the data that gets sent clientside inside a javascript statement  is encoded by default to avoid any kind of injection.  Sometimes there's the need to bypass this encoding and send raw javascript code.  To ensure that a string doesn't get encoded by TJavaScript::encode(),  construct a new TJavaScriptLiteral:
  •  // a javascript test string
    •

  •  $js="alert('hello')";
    •

  •  // the string in $raw will not be encoded when sent clientside inside a javascript block
    •

  •  $raw=new TJavaScriptLiteral($js);
    •

  •  // shortened form
    •

  •  $raw=_js($js);
    •

    version

    $Id: TComponent.php 3123 2012-03-26 10:10:51Z ctrlaltca@gmail.com $

    since

    prado 3.2

    Class Variable Summary

    • $_s =

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Method Detail

      TJavaScriptLiteral::__construct

__construct(

$s );

      Parameters

      $s

      access

      public

      [ Top ]

      TJavaScriptLiteral::toJavaScriptLiteral

toJavaScriptLiteral(
 );

      Overridden in child classes as:

      TJavaScriptString::toJavaScriptLiteral()

      access

      public

      [ Top ]

      TJavaScriptLiteral::__toString

__toString(
 );

      access

      public

      [ Top ]

    Variable Detail

    • $_s =  [line 1005]
      •

    • Data type: mixed
      •

      access

      protected

    Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:50 +0200 by phpDocumentor 1.4.3


Docs For Class TJavaScriptString

Class TJavaScriptString

[line 1031]
TJavaScriptLiteral
   |
   --TJavaScriptString
Location: /TComponent.php

Remarks

TJavaScriptString class is an internal class that marks strings that will be forcibly encoded when rendered inside a javascript block

version

$Id: TComponent.php 3123 2012-03-26 10:10:51Z ctrlaltca@gmail.com $

since

prado 3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TJavaScriptLiteral

  • TJavaScriptLiteral::$_s =

Method Summary

Inherited Method Summary

Inherited From Class TJavaScriptLiteral

  • TJavaScriptLiteral::__construct()
  • TJavaScriptLiteral::toJavaScriptLiteral()
  • TJavaScriptLiteral::__toString()

Method Detail

    TJavaScriptString::toJavaScriptLiteral

    toJavaScriptLiteral( );

    Overrides TJavaScriptLiteral::toJavaScriptLiteral() (parent method not documented)

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:50 +0200 by phpDocumentor 1.4.3


Docs For Class TPropertyValue

Class TPropertyValue

[line 642]

Location: /TComponent.php

Remarks

TPropertyValue class

TPropertyValue is a utility class that provides static methods  to convert component property values to specific types.
TPropertyValue is commonly used in component setter methods to ensure  the new property value is of specific type.  For example, a boolean-typed property setter method would be as follows,
  •  function setPropertyName($value) {
    •

  •      $value=TPropertyValue::ensureBoolean($value);
    •

  •      // $value is now of boolean type
    •

  •  }
    •

    Properties can be of the following types with specific type conversion rules:
    • string: a boolean value will be converted to 'true' or 'false'.
    • boolean: string 'true' (case-insensitive) will be converted to true,
            string 'false' (case-insensitive) will be converted to false.
    • integer
    • float
    • array: string starting with '(' and ending with ')' will be considered as
          as an array expression and will be evaluated. Otherwise, an array
          with the value to be ensured is returned.
    • object
    • enum: enumerable type, represented by an array of strings.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TComponent.php 3123 2012-03-26 10:10:51Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    • static array ensureArray()

      Converts a value to array type. If the value is a string and it is

    • static boolean ensureBoolean()

      Converts a value to boolean type.

    • static string ensureEnum()

      Converts a value to enum type.

    • static float ensureFloat()

      Converts a value to float type.

    • static integer ensureInteger()

      Converts a value to integer type.

    • static mixed ensureNullIfEmpty()

      Converts the value to 'null' if the given value is empty

    • static object ensureObject()

      Converts a value to object type.

    • static string ensureString()

      Converts a value to string type.

    • array ensureArray()

      Converts a value to array type. If the value is a string and it is

    • boolean ensureBoolean()

      Converts a value to boolean type.

    • string ensureEnum()

      Converts a value to enum type.

    • float ensureFloat()

      Converts a value to float type.

    • integer ensureInteger()

      Converts a value to integer type.

    • mixed ensureNullIfEmpty()

      Converts the value to 'null' if the given value is empty

    • object ensureObject()

      Converts a value to object type.

    • string ensureString()

      Converts a value to string type.

    Inherited Method Summary

    Method Detail

      static TPropertyValue::ensureArray

static ensureArray(
mixed
$value );

      Parameters

      $value

      the value to be converted.

      Remarks

      Converts a value to array type. If the value is a string and it is

      in the form (a,b,c) then an array consisting of each of the elements  will be returned. If the value is a string and it is not in this form  then an array consisting of just the string will be returned. If the value  is not a string then

      access

      public

      [ Top ]

      static TPropertyValue::ensureBoolean

static ensureBoolean(
mixed
$value );

      Parameters

      $value

      the value to be converted.

      Remarks

      Converts a value to boolean type.

      Note, string 'true' (case-insensitive) will be converted to true,  string 'false' (case-insensitive) will be converted to false.  If a string represents a non-zero number, it will be treated as true.

      access

      public

      [ Top ]

      static TPropertyValue::ensureEnum

static ensureEnum(
mixed
$value, mixed
$enums );

      Parameters

      $value

      the value to be converted.

      $enums

      class name of the enumerable type, or array of valid enumeration values. If this is not an array,  the method considers its parameters are of variable length, and the second till the last parameters are enumeration values.

      Returns

      the valid enumeration value

      Remarks

      Converts a value to enum type.

      This method checks if the value is of the specified enumerable type.  A value is a valid enumerable value if it is equal to the name of a constant  in the specified enumerable type (class).  For more details about enumerable, see TEnumerable.
      For backward compatibility, this method also supports sanity  check of a string value to see if it is among the given list of strings.

      throws

      TInvalidDataValueException if the original value is not in the string array.

      access

      public

      [ Top ]

      static TPropertyValue::ensureFloat

static ensureFloat(
mixed
$value );

      Parameters

      $value

      the value to be converted.

      Remarks

      Converts a value to float type.

      access

      public

      [ Top ]

      static TPropertyValue::ensureInteger

static ensureInteger(
mixed
$value );

      Parameters

      $value

      the value to be converted.

      Remarks

      Converts a value to integer type.

      access

      public

      [ Top ]

      static TPropertyValue::ensureNullIfEmpty

static ensureNullIfEmpty(
mixed
$value );

      Parameters

      $value

      value to be converted

      Returns

      input or NULL if input is empty

      Remarks

      Converts the value to 'null' if the given value is empty

      access

      public

      [ Top ]

      static TPropertyValue::ensureObject

static ensureObject(
mixed
$value );

      Parameters

      $value

      the value to be converted.

      Remarks

      Converts a value to object type.

      access

      public

      [ Top ]

      static TPropertyValue::ensureString

static ensureString(
mixed
$value );

      Parameters

      $value

      the value to be converted.

      Remarks

      Converts a value to string type.

      Note, a boolean value will be converted to 'true' if it is true  and 'false' if it is false.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:50 +0200 by phpDocumentor 1.4.3


Docs For Class TModule

Class TModule

[line 24]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
Classes extended from TModule:
TCache
TCache class
TDataSourceConfig
TDataSourceConfig module class provides <module> configuration for database connections.
TErrorHandler
TErrorHandler class
TGlobalization
TGlobalization contains settings for Culture, Charset and TranslationConfiguration.
TAuthManager
TAuthManager class
TDbUserManager
TDbUserManager class
TSecurityManager
TSecurityManager class
TUserManager
TUserManager class
TApplicationStatePersister
TApplicationStatePersister class.
TLogRouter
TLogRouter class.
TParameterModule
TParameterModule class
TRpcServer
TRpcServer class
TRpcApiProvider
TRpcApiProvider class
TAssetManager
TAssetManager class
THttpResponse
THttpResponse class
TUrlManager
TUrlManager class
TTemplateManager
TTemplateManager class
TThemeManager
TThemeManager class

Location: /TModule.php

Remarks

TModule class.

TModule implements the basic methods required by IModule and may be used as the basic class for application modules.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TModule.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TModule::getID

    getID( );

    Implementation of:
    IModule::getID()

    Returns

    id of this module

    access

    public

    [ Top ]

    TModule::init

    init( TXmlElement $config );

    Overridden in child classes as:

    TCache::init()
    Initializes the cache module.
    TAPCCache::init()
    Initializes this module.
    TDbCache::init()
    Initializes this module.
    TMemCache::init()
    Initializes this module.
    TSqliteCache::init()
    Initializes this module.
    TXCache::init()
    Initializes this module.
    TDataSourceConfig::init()
    Initalize the database connection properties from attributes in <database> tag.
    TActiveRecordConfig::init()
    Initialize the active record manager.
    TErrorHandler::init()
    Initializes the module.
    TGlobalization::init()
    Initialize the Culture and Charset for this application.
    TGlobalizationAutoDetect::init()
    TAuthManager::init()
    Initializes this module.
    TDbUserManager::init()
    Initializes the module.
    TSecurityManager::init()
    Initializes the module.
    TUserManager::init()
    Initializes the module.
    TApplicationStatePersister::init()
    Initializes module.
    TLogRouter::init()
    Initializes this module.
    TParameterModule::init()
    Initializes the module by loading parameters.
    TAssetManager::init()
    Initializes the module.
    THttpResponse::init()
    Initializes the module.
    TUrlMapping::init()
    Initializes this module.
    TTemplateManager::init()
    Initializes the module.
    TThemeManager::init()
    Initializes the module.

    Implementation of:
    IModule::init()
    Initializes the module.

    Parameters

    $config

    module configuration

    Remarks

    Initializes the module.

    This method is required by IModule and is invoked by application.

    access

    public

    [ Top ]

    TModule::setID

    setID( string $value );

    Implementation of:
    IModule::setID()

    Parameters

    $value

    id of this module

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:51 +0200 by phpDocumentor 1.4.3


Docs For Class TService

Class TService

[line 24]
TComponent
   |
   --TApplicationComponent
      |
      --TService
Classes extended from TService:
TFeedService
TFeedService class
TJsonService
TJsonService class provides to end-users javascript content response in JSON format.
TPageService
TPageService class.
TRpcService
TRpcService class
TSoapService
TSoapService class

Location: /TService.php

Remarks

TService class.

TService implements the basic methods required by IService and may be used as the basic class for application services.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TService.php 3102 2012-02-05 17:00:00Z ctrlaltca@gmail.com $

abstract

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TService::getEnabled

    getEnabled( );

    Implementation of:
    IService::getEnabled()

    Returns

    whether the service is enabled

    access

    public

    [ Top ]

    TService::getID

    getID( );

    Implementation of:
    IService::getID()

    Returns

    id of this service

    access

    public

    [ Top ]

    TService::init

    init( TXmlElement $config );

    Overridden in child classes as:

    TFeedService::init()
    Initializes this module.
    TJsonService::init()
    Initializes this module.
    TPageService::init()
    Initializes the service.
    TRpcService::init()
    Initializes the service
    TSoapService::init()
    Initializes this module.

    Implementation of:
    IService::init()
    Initializes the service.

    Parameters

    $config

    module configuration

    Remarks

    Initializes the service and attaches run to the RunService event of application.

    This method is required by IService and is invoked by application.

    access

    public

    [ Top ]

    TService::run

    run( );

    Overridden in child classes as:

    TFeedService::run()
    Runs the service.
    TJsonService::run()
    Runs the service.
    TPageService::run()
    Runs the service.
    TRpcService::run()
    Runs the service
    TSoapService::run()
    Runs the service.

    Implementation of:
    IService::run()
    Runs the service.

    Remarks

    Runs the service.

    access

    public

    [ Top ]

    TService::setEnabled

    setEnabled( boolean $value );

    Implementation of:
    IService::setEnabled()

    Parameters

    $value

    whether the service is enabled

    access

    public

    [ Top ]

    TService::setID

    setID( string $value );

    Implementation of:
    IService::setID()

    Parameters

    $value

    id of this service

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:20 +0200 by phpDocumentor 1.4.3


Docs For Class TShellApplication

Class TShellApplication

[line 36]
TComponent
   |
   --TApplication
      |
      --TShellApplication
Location: /TShellApplication.php

Remarks

TShellApplication class.

TShellApplication is the base class for developing command-line PRADO tools that share the same configurations as their Web application counterparts.

A typical usage of TShellApplication in a command-line PHP script is as follows:

  •  require_once('path/to/prado.php');
    •

  •  $application=new TShellApplication('path/to/application.xml');
    •

  •  $application->run();
    •

  •  // perform command-line tasks here
    •

    Since the application instance has access to all configurations, including path aliases, modules and parameters, the command-line script has nearly the same accessibility to resources as the PRADO Web applications.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TShellApplication.php 3063 2011-11-13 14:47:41Z ctrlaltca@gmail.com $

    since

    3.1.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TApplication

    • TApplication::CONFIGCACHE_FILE = 'config.cache'
      Config cache file
    • TApplication::CONFIG_FILE_EXT_PHP = '.php'
      File extension for external config files
    • TApplication::CONFIG_FILE_EXT_XML = '.xml'
      File extension for external config files
    • TApplication::CONFIG_FILE_PHP = 'application.php'
      Application configuration file name
    • TApplication::CONFIG_FILE_XML = 'application.xml'
      Application configuration file name
    • TApplication::CONFIG_TYPE_PHP = 'php'
      Configuration file type, application.php and config.php
    • TApplication::CONFIG_TYPE_XML = 'xml'
      Configuration file type, application.xml and config.xml
    • TApplication::GLOBAL_FILE = 'global.cache'
      Global data file
    • TApplication::PAGE_SERVICE_ID = 'page'
      Page service ID
    • TApplication::RUNTIME_PATH = 'runtime'
      Runtime directory name
    • TApplication::STATE_DEBUG = 'Debug'
    • TApplication::STATE_NORMAL = 'Normal'
    • TApplication::STATE_OFF = 'Off'
      possible application mode.
    • TApplication::STATE_PERFORMANCE = 'Performance'

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TApplication

    • TApplication::__construct()
      Constructor.
    • TApplication::applyConfiguration()
      Applies an application configuration.
    • TApplication::clearGlobalState()
      Clears a global value.
    • TApplication::completeRequest()
      Completes current request processing.
    • TApplication::flushOutput()
      Flushes output to client side.
    • TApplication::getApplicationConfigurationClass()
    • TApplication::getApplicationStatePersister()
    • TApplication::getAssetManager()
    • TApplication::getAuthorizationRules()
    • TApplication::getBasePath()
    • TApplication::getCache()
    • TApplication::getConfigurationFile()
    • TApplication::getConfigurationFileExt()
    • TApplication::getConfigurationFileName()
    • TApplication::getConfigurationType()
    • TApplication::getErrorHandler()
    • TApplication::getGlobalization()
    • TApplication::getGlobalState()
      Returns a global value.
    • TApplication::getID()
    • TApplication::getMode()
    • TApplication::getModule()
    • TApplication::getModules()
    • TApplication::getPageServiceID()
    • TApplication::getParameters()
      Returns the list of application parameters.
    • TApplication::getRequest()
    • TApplication::getRequestCompleted()
    • TApplication::getResponse()
    • TApplication::getRuntimePath()
    • TApplication::getSecurityManager()
    • TApplication::getService()
    • TApplication::getSession()
    • TApplication::getUniqueID()
    • TApplication::getUser()
    • TApplication::initApplication()
      Loads configuration and initializes application.
    • TApplication::loadGlobals()
      Loads global values from persistent storage.
    • TApplication::onAuthentication()
      Raises OnAuthentication event.
    • TApplication::onAuthenticationComplete()
      Raises OnAuthenticationComplete event.
    • TApplication::onAuthorization()
      Raises OnAuthorization event.
    • TApplication::onAuthorizationComplete()
      Raises OnAuthorizationComplete event.
    • TApplication::onBeginRequest()
      Raises OnBeginRequest event.
    • TApplication::onEndRequest()
      Raises OnEndRequest event.
    • TApplication::onError()
      Raises OnError event.
    • TApplication::onLoadState()
      Raises OnLoadState event.
    • TApplication::onLoadStateComplete()
      Raises OnLoadStateComplete event.
    • TApplication::onPreFlushOutput()
      Raises OnPreFlushOutput event.
    • TApplication::onPreRunService()
      Raises OnPreRunService event.
    • TApplication::onSaveState()
      Raises OnSaveState event.
    • TApplication::onSaveStateComplete()
      Raises OnSaveStateComplete event.
    • TApplication::resolvePaths()
      Resolves application-relevant paths.
    • TApplication::run()
      Executes the lifecycles of the application.
    • TApplication::runService()
      Runs the requested service.
    • TApplication::saveGlobals()
      Saves global values into persistent storage.
    • TApplication::setApplicationStatePersister()
    • TApplication::setAssetManager()
    • TApplication::setBasePath()
    • TApplication::setCache()
    • TApplication::setConfigurationFile()
    • TApplication::setConfigurationType()
    • TApplication::setErrorHandler()
    • TApplication::setGlobalization()
    • TApplication::setGlobalState()
      Sets a global value.
    • TApplication::setID()
    • TApplication::setMode()
    • TApplication::setModule()
      Adds a module to application.
    • TApplication::setPageServiceID()
    • TApplication::setRequest()
    • TApplication::setResponse()
    • TApplication::setRuntimePath()
    • TApplication::setSecurityManager()
    • TApplication::setService()
    • TApplication::setSession()
    • TApplication::setUser()
    • TApplication::startService()
      Starts the specified service.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TShellApplication::run

      run( );

      Overrides TApplication::run() (Executes the lifecycles of the application.)

      Remarks

      Runs the application.

      This method overrides the parent implementation by initializing application with configurations specified when it is created.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:21 +0200 by phpDocumentor 1.4.3


Package System.Security Element Index

Element index for package System.Security

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
c d e g h i l m o r s t u v _
top
_
__construct in file TUser.php, method TUser::__construct()
Constructor.
__construct in file TAuthorizationRule.php, method TAuthorizationRule::__construct()
Constructor.
top
c
Clear | in file TUserManager.php, class constant TUserManagerPasswordMode::Clear
computeHMAC in file TSecurityManager.php, method TSecurityManager::computeHMAC()
Computes the HMAC for the data with getValidationKey.
createDbConnection in file TDbUserManager.php, method TDbUserManager::createDbConnection()
Creates the DB connection.
createUser in file TDbUserManager.php, method TDbUser::createUser()
Creates a new user instance given the username.
createUserFromCookie in file TDbUserManager.php, method TDbUser::createUserFromCookie()
Creates a new user instance given the cookie containing auth data.
top
d
decrypt in file TSecurityManager.php, method TSecurityManager::decrypt()
Decrypts data with getEncryptionKey.
doAuthentication in file TAuthManager.php, method TAuthManager::doAuthentication()
Performs authentication.
doAuthorization in file TAuthManager.php, method TAuthManager::doAuthorization()
Performs authorization.
top
e
encrypt in file TSecurityManager.php, method TSecurityManager::encrypt()
Encrypts data with getEncryptionKey.
top
g
generateRandomKey in file TSecurityManager.php, method TSecurityManager::generateRandomKey()
Generates a random key.
generateUserKey | in file TAuthManager.php, method TAuthManager::generateUserKey()
getAction | in file TAuthorizationRule.php, method TAuthorizationRule::getAction()
getAllowAutoLogin | in file TAuthManager.php, method TAuthManager::getAllowAutoLogin()
getAuthenticatedApplied | in file TAuthorizationRule.php, method TAuthorizationRule::getAuthenticatedApplied()
getAuthExpire | in file TAuthManager.php, method TAuthManager::getAuthExpire()
getConnectionID | in file TDbUserManager.php, method TDbUserManager::getConnectionID()
getDbConnection in file TDbUserManager.php, method TDbUser::getDbConnection()
Returns a database connection that may be used to retrieve data from database.
getDbConnection | in file TDbUserManager.php, method TDbUserManager::getDbConnection()
getEncryption | in file TSecurityManager.php, method TSecurityManager::getEncryption()
getEncryptionKey | in file TSecurityManager.php, method TSecurityManager::getEncryptionKey()
getEveryoneApplied | in file TAuthorizationRule.php, method TAuthorizationRule::getEveryoneApplied()
getGuestApplied | in file TAuthorizationRule.php, method TAuthorizationRule::getGuestApplied()
getGuestName | in file TUserManager.php, method TUserManager::getGuestName()
getGuestName | in file TDbUserManager.php, method TDbUserManager::getGuestName()
getGuestName | in file IUserManager.php, method IUserManager::getGuestName()
getIPRules | in file TAuthorizationRule.php, method TAuthorizationRule::getIPRules()
getIsGuest | in file TUser.php, method TUser::getIsGuest()
getLoginPage | in file TAuthManager.php, method TAuthManager::getLoginPage()
getManager | in file TUser.php, method TUser::getManager()
getName | in file TUser.php, method TUser::getName()
getPasswordMode | in file TUserManager.php, method TUserManager::getPasswordMode()
getReturnUrl | in file TAuthManager.php, method TAuthManager::getReturnUrl()
getReturnUrlVarName | in file TAuthManager.php, method TAuthManager::getReturnUrlVarName()
getRoles in file TUserManager.php, method TUserManager::getRoles()
Returns an array of user role information.
getRoles | in file TAuthorizationRule.php, method TAuthorizationRule::getRoles()
getRoles | in file TUser.php, method TUser::getRoles()
getState in file TUser.php, method TUser::getState()
Returns the value of a variable that is stored in user session.
getStateChanged | in file TUser.php, method TUser::getStateChanged()
getUser in file TUserManager.php, method TUserManager::getUser()
Returns a user instance given the user name.
getUser in file IUserManager.php, method IUserManager::getUser()
Returns a user instance given the user name.
getUser in file TDbUserManager.php, method TDbUserManager::getUser()
Returns a user instance given the user name.
getUserClass | in file TDbUserManager.php, method TDbUserManager::getUserClass()
getUserFile | in file TUserManager.php, method TUserManager::getUserFile()
getUserFromCookie in file TUserManager.php, method TUserManager::getUserFromCookie()
Returns a user instance according to auth data stored in a cookie.
getUserFromCookie in file IUserManager.php, method IUserManager::getUserFromCookie()
Returns a user instance according to auth data stored in a cookie.
getUserFromCookie in file TDbUserManager.php, method TDbUserManager::getUserFromCookie()
Returns a user instance according to auth data stored in a cookie.
getUserKey | in file TAuthManager.php, method TAuthManager::getUserKey()
getUserManager | in file TAuthManager.php, method TAuthManager::getUserManager()
getUsers in file TUserManager.php, method TUserManager::getUsers()
Returns an array of all users.
getUsers | in file TAuthorizationRule.php, method TAuthorizationRule::getUsers()
getValidation | in file TSecurityManager.php, method TSecurityManager::getValidation()
getValidationKey | in file TSecurityManager.php, method TSecurityManager::getValidationKey()
getVerb | in file TAuthorizationRule.php, method TAuthorizationRule::getVerb()
top
h
hashData in file TSecurityManager.php, method TSecurityManager::hashData()
Prefixes data with an HMAC.
top
i
init in file TSecurityManager.php, method TSecurityManager::init()
Initializes the module.
init in file TAuthManager.php, method TAuthManager::init()
Initializes this module.
init in file TUserManager.php, method TUserManager::init()
Initializes the module.
init in file TDbUserManager.php, method TDbUserManager::init()
Initializes the module.
insertAt in file TAuthorizationRule.php, method TAuthorizationRuleCollection::insertAt()
Inserts an item at the specified position.
isInRole | in file TUser.php, method TUser::isInRole()
isUserAllowed | in file TAuthorizationRule.php, method TAuthorizationRuleCollection::isUserAllowed()
isUserAllowed | in file TAuthorizationRule.php, method TAuthorizationRule::isUserAllowed()
IUserManager in file IUserManager.php, class IUserManager
IUserManager interface
IUserManager.php | procedural page IUserManager.php
top
l
leave in file TAuthManager.php, method TAuthManager::leave()
Performs login redirect if authorization fails.
loadFromString | in file TUser.php, method TUser::loadFromString()
login in file TAuthManager.php, method TAuthManager::login()
Logs in a user with username and password.
logout in file TAuthManager.php, method TAuthManager::logout()
Logs out a user.
top
m
MD5 | in file TUserManager.php, class constant TUserManagerPasswordMode::MD5
MD5 | in file TSecurityManager.php, class constant TSecurityManagerValidationMode::MD5
top
o
onAuthenticate in file TAuthManager.php, method TAuthManager::onAuthenticate()
Performs the real authentication work.
onAuthExpire in file TAuthManager.php, method TAuthManager::onAuthExpire()
Performs user logout on authentication expiration.
onAuthorize in file TAuthManager.php, method TAuthManager::onAuthorize()
Performs the real authorization work.
top
r
RETURN_URL_VAR in file TAuthManager.php, class constant TAuthManager::RETURN_URL_VAR
GET variable name for return url
top
s
saveToString | in file TUser.php, method TUser::saveToString()
saveUserToCookie in file TDbUserManager.php, method TDbUser::saveUserToCookie()
Saves necessary auth data into a cookie.
saveUserToCookie in file TDbUserManager.php, method TDbUserManager::saveUserToCookie()
Saves user auth data into a cookie.
saveUserToCookie in file IUserManager.php, method IUserManager::saveUserToCookie()
Saves user auth data into a cookie.
saveUserToCookie in file TUserManager.php, method TUserManager::saveUserToCookie()
Saves user auth data into a cookie.
setAllowAutoLogin | in file TAuthManager.php, method TAuthManager::setAllowAutoLogin()
setAuthExpire | in file TAuthManager.php, method TAuthManager::setAuthExpire()
setConnectionID in file TDbUserManager.php, method TDbUserManager::setConnectionID()
Sets the ID of a TDataSourceConfig module.
setEncryption | in file TSecurityManager.php, method TSecurityManager::setEncryption()
setEncryptionKey | in file TSecurityManager.php, method TSecurityManager::setEncryptionKey()
setGuestName | in file TUserManager.php, method TUserManager::setGuestName()
setGuestName | in file TDbUserManager.php, method TDbUserManager::setGuestName()
setIsGuest | in file TUser.php, method TUser::setIsGuest()
setLoginPage in file TAuthManager.php, method TAuthManager::setLoginPage()
Sets the login page that the client browser will be redirected to if login is needed.
setName | in file TUser.php, method TUser::setName()
setPasswordMode | in file TUserManager.php, method TUserManager::setPasswordMode()
setReturnUrl in file TAuthManager.php, method TAuthManager::setReturnUrl()
Sets the URL that the browser should be redirected to when login succeeds.
setReturnUrlVarName | in file TAuthManager.php, method TAuthManager::setReturnUrlVarName()
setRoles | in file TUser.php, method TUser::setRoles()
setState in file TUser.php, method TUser::setState()
Stores a variable in user session.
setStateChanged | in file TUser.php, method TUser::setStateChanged()
setUserClass | in file TDbUserManager.php, method TDbUserManager::setUserClass()
setUserFile | in file TUserManager.php, method TUserManager::setUserFile()
setUserManager | in file TAuthManager.php, method TAuthManager::setUserManager()
setValidation | in file TSecurityManager.php, method TSecurityManager::setValidation()
setValidationKey | in file TSecurityManager.php, method TSecurityManager::setValidationKey()
SHA1 | in file TUserManager.php, class constant TUserManagerPasswordMode::SHA1
SHA1 | in file TSecurityManager.php, class constant TSecurityManagerValidationMode::SHA1
STATE_ENCRYPTION_KEY | in file TSecurityManager.php, class constant TSecurityManager::STATE_ENCRYPTION_KEY
STATE_VALIDATION_KEY | in file TSecurityManager.php, class constant TSecurityManager::STATE_VALIDATION_KEY
switchToGuest in file TUserManager.php, method TUserManager::switchToGuest()
Sets a user as a guest.
switchUser in file TAuthManager.php, method TAuthManager::switchUser()
Switches to a new user.
top
t
TAuthManager.php | procedural page TAuthManager.php
TAuthorizationRule.php | procedural page TAuthorizationRule.php
TDbUserManager.php | procedural page TDbUserManager.php
TSecurityManager.php | procedural page TSecurityManager.php
TUser.php | procedural page TUser.php
TUserManager.php | procedural page TUserManager.php
TAuthManager in file TAuthManager.php, class TAuthManager
TAuthManager class
TAuthorizationRule in file TAuthorizationRule.php, class TAuthorizationRule
TAuthorizationRule class
TAuthorizationRuleCollection in file TAuthorizationRule.php, class TAuthorizationRuleCollection
TAuthorizationRuleCollection class.
TDbUser in file TDbUserManager.php, class TDbUser
TDbUser class
TDbUserManager in file TDbUserManager.php, class TDbUserManager
TDbUserManager class
TSecurityManager in file TSecurityManager.php, class TSecurityManager
TSecurityManager class
TSecurityManagerValidationMode in file TSecurityManager.php, class TSecurityManagerValidationMode
TSecurityManagerValidationMode class.
TUser in file TUser.php, class TUser
TUser class
TUserManager in file TUserManager.php, class TUserManager
TUserManager class
TUserManagerPasswordMode in file TUserManager.php, class TUserManagerPasswordMode
TUserManagerPasswordMode class.
top
u
updateSessionUser in file TAuthManager.php, method TAuthManager::updateSessionUser()
Updates the user data stored in session.
USER_FILE_EXT in file TUserManager.php, class constant TUserManager::USER_FILE_EXT
extension name to the user file
top
v
validateData in file TSecurityManager.php, method TSecurityManager::validateData()
Validates if data is tampered.
validateUser in file TUserManager.php, method TUserManager::validateUser()
Validates if the username and password are correct.
validateUser in file TDbUserManager.php, method TDbUserManager::validateUser()
Validates if the username and password are correct.
validateUser in file TDbUserManager.php, method TDbUser::validateUser()
Validates if username and password are correct entries.
validateUser in file IUserManager.php, method IUserManager::validateUser()
Validates if the username and password are correct.


Class Trees for Package System.Security

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page IUserManager.php

File: /Security/IUserManager.php

Remarks

IUserManager interface file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: IUserManager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
IUserManager
IUserManager interface

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:42:59 +0200 by phpDocumentor 1.4.3


Docs for page TAuthManager.php

File: /Security/TAuthManager.php

Remarks

TAuthManager class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TAuthManager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TAuthManager
TAuthManager class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:32 +0200 by phpDocumentor 1.4.3


Docs for page TAuthorizationRule.php

File: /Security/TAuthorizationRule.php

Remarks

TAuthorizationRule, TAuthorizationRuleCollection class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TAuthorizationRule.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TAuthorizationRule
TAuthorizationRule class
TAuthorizationRuleCollection
TAuthorizationRuleCollection class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:32 +0200 by phpDocumentor 1.4.3


Docs for page TDbUserManager.php

File: /Security/TDbUserManager.php

Remarks

TDbUserManager class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDbUserManager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDbUserManager
TDbUserManager class
TDbUser
TDbUser class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:13 +0200 by phpDocumentor 1.4.3


Docs for page TSecurityManager.php

File: /Security/TSecurityManager.php

Remarks

TSecurityManager class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TSecurityManager.php 3066 2011-11-17 16:52:56Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSecurityManager
TSecurityManager class
TSecurityManagerValidationMode
TSecurityManagerValidationMode class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:20 +0200 by phpDocumentor 1.4.3


Docs for page TUser.php

File: /Security/TUser.php

Remarks

TUser class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TUser.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TUser
TUser class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:45 +0200 by phpDocumentor 1.4.3


Docs for page TUserManager.php

File: /Security/TUserManager.php

Remarks

TUserManager class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TUserManager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TUserManager
TUserManager class
TUserManagerPasswordMode
TUserManagerPasswordMode class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:45 +0200 by phpDocumentor 1.4.3


Docs For Class IUserManager

Interface IUserManager

[line 25]

Location: /Security/IUserManager.php

Remarks

IUserManager interface

IUserManager specifies the interface that must be implemented by  a user manager class if it is to be used together with TAuthManager  and TUser.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: IUserManager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IUserManager::getGuestName

getGuestName(
 );

    Returns

    name for a guest user.

    access

    public

    [ Top ]

    IUserManager::getUser

getUser(
[string
$username = null] );

    Parameters

    $username

    user name, null if it is a guest.

    Returns

    the user instance, null if the specified username is not in the user database.

    Remarks

    Returns a user instance given the user name.

    access

    public

    [ Top ]

    IUserManager::getUserFromCookie

getUserFromCookie(
THttpCookie
$cookie );

    Parameters

    $cookie

    the cookie storing user authentication information

    Returns

    the user instance generated based on the cookie auth data, null if the cookie does not have valid auth data.

    Remarks

    Returns a user instance according to auth data stored in a cookie.

    since

    3.1.1

    access

    public

    [ Top ]

    IUserManager::saveUserToCookie

saveUserToCookie(
THttpCookie
$cookie );

    Parameters

    $cookie

    the cookie to receive the user auth data.

    Remarks

    Saves user auth data into a cookie.

    since

    3.1.1

    access

    public

    [ Top ]

    IUserManager::validateUser

validateUser(
string
$username, string
$password );

    Parameters

    $username

    user name

    $password

    password

    Returns

    true if validation is successful, false otherwise.

    Remarks

    Validates if the username and password are correct.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:42:59 +0200 by phpDocumentor 1.4.3


Docs For Class TAuthManager

Class TAuthManager

[line 44]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TAuthManager
Location: /Security/TAuthManager.php

Remarks

TAuthManager class

TAuthManager performs user authentication and authorization for a Prado application. TAuthManager works together with a IUserManager module that can be specified via the UserManager property. If an authorization fails, TAuthManager will try to redirect the client browser to a login page that is specified via the LoginPage. To login or logout a user, call login or logout, respectively.

The AuthExpire property can be used to define the time in seconds after which the authentication should expire. AllowAutoLogin specifies if the login information should be stored in a cookie to perform automatic login. Enabling this feature will cause that AuthExpire has no effect since the user will be logged in again on authentication expiration.

To load TAuthManager, configure it in application configuration as follows, <module id="auth" class="System.Security.TAuthManager" UserManager="users" LoginPage="login" /> <module id="users" class="System.Security.TUserManager" />

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TAuthManager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • RETURN_URL_VAR = 'ReturnUrl'
    GET variable name for return url

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TAuthManager::doAuthentication

    doAuthentication( mixed $sender, mixed $param );

    Parameters

    $sender

    sender of the Authentication event

    $param

    event parameter

    Remarks

    Performs authentication.

    This is the event handler attached to application's Authentication event. Do not call this method directly.

    access

    public

    [ Top ]

    TAuthManager::doAuthorization

    doAuthorization( mixed $sender, mixed $param );

    Parameters

    $sender

    sender of the Authorization event

    $param

    event parameter

    Remarks

    Performs authorization.

    This is the event handler attached to application's Authorization event. Do not call this method directly.

    access

    public

    [ Top ]

    TAuthManager::generateUserKey

    generateUserKey( );

    Returns

    a key used to store user information in session

    since

    3.1.1

    access

    protected

    [ Top ]

    TAuthManager::getAllowAutoLogin

    getAllowAutoLogin( );

    Returns

    whether to allow remembering login so that the user logs on automatically next time. Defaults to false.

    since

    3.1.1

    access

    public

    [ Top ]

    TAuthManager::getAuthExpire

    getAuthExpire( );

    Returns

    authentication expiration time in seconds. Defaults to zero (no expiration).

    since

    3.1.3

    access

    public

    [ Top ]

    TAuthManager::getLoginPage

    getLoginPage( );

    Returns

    path of login page should login is required

    access

    public

    [ Top ]

    TAuthManager::getReturnUrl

    getReturnUrl( );

    Returns

    URL that the browser should be redirected to when login succeeds.

    access

    public

    [ Top ]

    TAuthManager::getReturnUrlVarName

    getReturnUrlVarName( );

    Returns

    the name of the session variable storing return URL. It defaults to 'AppID:ReturnUrl'

    access

    public

    [ Top ]

    TAuthManager::getUserKey

    getUserKey( );

    Returns

    a unique variable name for storing user session/cookie data

    since

    3.1.1

    access

    public

    [ Top ]

    TAuthManager::getUserManager

    getUserManager( );

    Returns

    user manager instance

    access

    public

    [ Top ]

    TAuthManager::init

    init( TXmlElement $config );

    Overrides TModule::init() (Initializes the module.)

    Parameters

    $config

    configuration for this module, can be null

    Remarks

    Initializes this module.

    This method is required by the IModule interface.

    throws

    TConfigurationException if user manager does not exist or is not IUserManager

    access

    public

    [ Top ]

    TAuthManager::leave

    leave( mixed $sender, mixed $param );

    Parameters

    $sender

    sender of the event

    $param

    event parameter

    Remarks

    Performs login redirect if authorization fails.

    This is the event handler attached to application's EndRequest event. Do not call this method directly.

    access

    public

    [ Top ]

    TAuthManager::login

    login( string $username, string $password, [integer $expire = 0] );

    Parameters

    $username

    username

    $password

    password

    $expire

    number of seconds that automatic login will remain effective. If 0, it means user logs out when session ends. This parameter is added since 3.1.1.

    Returns

    if login is successful

    Remarks

    Logs in a user with username and password.

    The username and password will be used to validate if login is successful. If yes, a user object will be created for the application.

    access

    public

    [ Top ]

    TAuthManager::logout

    logout( );

    Remarks

    Logs out a user.

    User session will be destroyed after this method is called.

    throws

    TConfigurationException if session module is not loaded.

    access

    public

    [ Top ]

    TAuthManager::onAuthenticate

    onAuthenticate( mixed $param );

    Parameters

    $param

    parameter to be passed to OnAuthenticate event

    Remarks

    Performs the real authentication work.

    An OnAuthenticate event will be raised if there is any handler attached to it. If the application already has a non-null user, it will return without further authentication. Otherwise, user information will be restored from session data.

    throws

    TConfigurationException if session module does not exist.

    access

    public

    [ Top ]

    TAuthManager::onAuthExpire

    onAuthExpire( mixed $param );

    Parameters

    $param

    parameter to be passed to OnAuthExpire event.

    Remarks

    Performs user logout on authentication expiration.

    An 'OnAuthExpire' event will be raised if there is any handler attached to it.

    access

    public

    [ Top ]

    TAuthManager::onAuthorize

    onAuthorize( mixed $param );

    Parameters

    $param

    parameter to be passed to OnAuthorize event

    Remarks

    Performs the real authorization work.

    Authorization rules obtained from the application will be used to check if a user is allowed. If authorization fails, the response status code will be set as 401 and the application terminates.

    access

    public

    [ Top ]

    TAuthManager::setAllowAutoLogin

    setAllowAutoLogin( boolean $value );

    Parameters

    $value

    whether to allow remembering login so that the user logs on automatically next time. Users have to enable cookie to make use of this feature.

    since

    3.1.1

    access

    public

    [ Top ]

    TAuthManager::setAuthExpire

    setAuthExpire( integer $value );

    Parameters

    $value

    authentication expiration time in seconds. Defaults to zero (no expiration).

    since

    3.1.3

    access

    public

    [ Top ]

    TAuthManager::setLoginPage

    setLoginPage( string $pagePath );

    Parameters

    $pagePath

    path of login page should login is required

    Remarks

    Sets the login page that the client browser will be redirected to if login is needed.

    Login page should be specified in the format of page path.

    see

    TPageService

    access

    public

    [ Top ]

    TAuthManager::setReturnUrl

    setReturnUrl( string $value );

    Parameters

    $value

    the URL to be redirected to.

    Remarks

    Sets the URL that the browser should be redirected to when login succeeds.

    access

    public

    [ Top ]

    TAuthManager::setReturnUrlVarName

    setReturnUrlVarName( string $value );

    Parameters

    $value

    the name of the session variable storing return URL.

    access

    public

    [ Top ]

    TAuthManager::setUserManager

    setUserManager( string|IUserManager $provider );

    Parameters

    $provider

    the user manager module ID or the user manager object

    throws

    TInvalidOperationException if the module has been initialized or the user manager object is not IUserManager

    access

    public

    [ Top ]

    TAuthManager::switchUser

    switchUser( string $username );

    Parameters

    $username

    the new username

    Returns

    if the switch is successful

    Remarks

    Switches to a new user.

    This method will logout the current user first and login with a new one (without password.)

    access

    public

    [ Top ]

    TAuthManager::updateSessionUser

    updateSessionUser( IUser $user );

    Parameters

    $user

    user object

    Remarks

    Updates the user data stored in session.

    throws

    new TConfigurationException if session module is not loaded.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • RETURN_URL_VAR = 'ReturnUrl' [line 49]

    • Remarks

    GET variable name for return url

Documentation generated on Mon, 25 Jun 2012 14:43:32 +0200 by phpDocumentor 1.4.3


Docs For Class TAuthorizationRule

Class TAuthorizationRule

[line 32]
TComponent
   |
   --TAuthorizationRule
Location: /Security/TAuthorizationRule.php

Remarks

TAuthorizationRule class

TAuthorizationRule represents a single authorization rule. A rule is specified by an action (required), a list of users (optional), a list of roles (optional), a verb (optional), and a list of IP rules (optional). Action can be either 'allow' or 'deny'. Guest (anonymous, unauthenticated) users are represented by question mark '?'. All users (including guest users) are represented by asterisk '*'. Authenticated users are represented by '@'. Users/roles are case-insensitive. Different users/roles are separated by comma ','. Verb can be either 'get' or 'post'. If it is absent, it means both. IP rules are separated by comma ',' and can contain wild card in the rules (e.g. '192.132.23.33, 192.122.*.*')

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TAuthorizationRule.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TAuthorizationRule::__construct

    __construct( string $action, string $users, string $roles, [string $verb = ''], [string $ipRules = ''] );

    Parameters

    $action

    action, either 'deny' or 'allow'

    $users

    a comma separated user list

    $roles

    a comma separated role list

    $verb

    verb, can be empty, 'get', or 'post'

    $ipRules

    IP rules (separated by comma, can contain wild card *)

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TAuthorizationRule::getAction

    getAction( );

    Returns

    action, either 'allow' or 'deny'

    access

    public

    [ Top ]

    TAuthorizationRule::getAuthenticatedApplied

    getAuthenticatedApplied( );

    Returns

    if this rule applies to authenticated users

    access

    public

    [ Top ]

    TAuthorizationRule::getEveryoneApplied

    getEveryoneApplied( );

    Returns

    if this rule applies to everyone

    access

    public

    [ Top ]

    TAuthorizationRule::getGuestApplied

    getGuestApplied( );

    Returns

    if this rule applies to everyone

    access

    public

    [ Top ]

    TAuthorizationRule::getIPRules

    getIPRules( );

    Returns

    list of IP rules.

    since

    3.1.1

    access

    public

    [ Top ]

    TAuthorizationRule::getRoles

    getRoles( );

    Returns

    list of roles

    access

    public

    [ Top ]

    TAuthorizationRule::getUsers

    getUsers( );

    Returns

    list of user IDs

    access

    public

    [ Top ]

    TAuthorizationRule::getVerb

    getVerb( );

    Returns

    verb, may be empty, 'get', or 'post'.

    access

    public

    [ Top ]

    TAuthorizationRule::isUserAllowed

    isUserAllowed( $user, string $verb, string $ip );

    Parameters

    $user

    the user object

    $verb

    the request verb (GET, PUT)

    $ip

    the request IP address

    Returns

    1 if the user is allowed, -1 if the user is denied, 0 if the rule does not apply to the user

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:32 +0200 by phpDocumentor 1.4.3


Docs For Class TAuthorizationRuleCollection

Class TAuthorizationRuleCollection

[line 256]
TComponent
   |
   --TList
      |
      --TAuthorizationRuleCollection
Location: /Security/TAuthorizationRule.php

Remarks

TAuthorizationRuleCollection class.

TAuthorizationRuleCollection represents a collection of authorization rules TAuthorizationRule. To check if a user is allowed, call isUserAllowed.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TAuthorizationRule.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TAuthorizationRuleCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TList::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the specified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by performing additional operations for each newly added TAuthorizationRule object.

    throws

    TInvalidDataTypeException if the item to be inserted is not a TAuthorizationRule object.

    access

    public

    [ Top ]

    TAuthorizationRuleCollection::isUserAllowed

    isUserAllowed( IUser $user, string $verb, string $ip );

    Parameters

    $user

    the user to be authorized

    $verb

    verb, can be empty, 'post' or 'get'.

    $ip

    the request IP address

    Returns

    whether the user is allowed

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:32 +0200 by phpDocumentor 1.4.3


Docs For Class TDbUser

Class TDbUser

[line 223]
TComponent
   |
   --TUser
      |
      --TDbUser
Location: /Security/TDbUserManager.php

Remarks

TDbUser class

TDbUser is the base user class for using together with TDbUserManager. Two methods are declared and must be implemented in the descendant classes:

  • validateUser(): validates if username and password are correct entries.
  • createUser(): creates a new user instance given the username

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDbUserManager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TUser

  • TUser::__construct()
    Constructor.
  • TUser::getIsGuest()
  • TUser::getManager()
  • TUser::getName()
  • TUser::getRoles()
  • TUser::getState()
    Returns the value of a variable that is stored in user session.
  • TUser::getStateChanged()
  • TUser::isInRole()
  • TUser::loadFromString()
  • TUser::saveToString()
  • TUser::setIsGuest()
  • TUser::setName()
  • TUser::setRoles()
  • TUser::setState()
    Stores a variable in user session.
  • TUser::setStateChanged()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDbUser::createUser

    createUser( string $username );

    Parameters

    $username

    username (case-sensitive)

    Returns

    the newly created and initialized user instance

    Remarks

    Creates a new user instance given the username.

    This method usually needs to retrieve necessary user information (e.g. role, name, rank, etc.) from the user database according to the specified username. The newly created user instance should be initialized with these information.

    If the username is invalid (not found in the user database), null should be returned.

    You may use DbConnection to deal with database.

    abstract

    access

    public

    [ Top ]

    TDbUser::createUserFromCookie

    createUserFromCookie( THttpCookie $cookie );

    Parameters

    $cookie

    the cookie storing user authentication information

    Returns

    the user instance generated based on the cookie auth data, null if the cookie does not have valid auth data.

    Remarks

    Creates a new user instance given the cookie containing auth data.

    This method is invoked when TAuthManager::setAllowAutoLogin is set true. The default implementation simply returns null, meaning no user instance can be created from the given cookie.

    If you want to support automatic login (remember login), you should override this method. Typically, you obtain the username and a unique token from the cookie's value. You then verify the token is valid and use the username to create a user instance.

    see

    TDbUser::saveUserToCookie()

    since

    3.1.1

    access

    public

    [ Top ]

    TDbUser::getDbConnection

    getDbConnection( );

    Returns

    database connection that may be used to retrieve data from database

    Remarks

    Returns a database connection that may be used to retrieve data from database.

    access

    public

    [ Top ]

    TDbUser::saveUserToCookie

    saveUserToCookie( THttpCookie $cookie );

    Parameters

    $cookie

    the cookie to store the user auth information

    Remarks

    Saves necessary auth data into a cookie.

    This method is invoked when TAuthManager::rememberLogin is invoked. The default implementation does nothing, meaning auth data is not stored in the cookie (and thus automatic login is not supported.)

    If you want to support automatic login (remember login), you should override this method. Typically, you generate a unique token according to the current login information and save it together with the username in the cookie's value. You should avoid revealing the password in the generated token.

    see

    TDbUser::createUserFromCookie()

    since

    3.1.1

    access

    public

    [ Top ]

    TDbUser::validateUser

    validateUser( string $username, string $password );

    Parameters

    $username

    username (case-sensitive)

    $password

    password

    Returns

    whether the validation succeeds

    Remarks

    Validates if username and password are correct entries.

    Usually, this is accomplished by checking if the user database contains this (username, password) pair. You may use DbConnection to deal with database.

    abstract

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:13 +0200 by phpDocumentor 1.4.3


Docs For Class TDbUserManager

Class TDbUserManager

[line 51]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TDbUserManager
Location: /Security/TDbUserManager.php

Remarks

TDbUserManager class

TDbUserManager manages user accounts that are stored in a database. TDbUserManager is mainly designed to be used together with TAuthManager which manages how users are authenticated and authorized in a Prado application.

To use TDbUserManager together with TAuthManager, configure them in the application configuration like following:

  •  <module id="db"
    •

  •      class="System.Data.TDataSourceConfig" ..../>
    •

  •  <module id="users"
    •

  •      class="System.Security.TDbUserManager"
    •

  •      UserClass="Path.To.MyUserClass"
    •

  •      ConnectionID="db" />
    •

  •  <module id="auth"
    •

  •      class="System.Security.TAuthManager"
    •

  •      UserManager="users" LoginPage="Path.To.LoginPage" />
    •

    In the above, UserClass specifies what class will be used to create user instance. The class must extend from TDbUser. ConnectionID refers to the ID of a TDataSourceConfig module which specifies how to establish database connection to retrieve user information.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TDbUserManager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.1.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TDbUserManager::createDbConnection

      createDbConnection( string $connectionID );

      Parameters

      $connectionID

      the module ID for TDataSourceConfig

      Returns

      the created DB connection

      Remarks

      Creates the DB connection.

      throws

      TConfigurationException if module ID is invalid or empty

      access

      protected

      [ Top ]

      TDbUserManager::getConnectionID

      getConnectionID( );

      Returns

      the ID of a TDataSourceConfig module. Defaults to empty string, meaning not set.

      access

      public

      [ Top ]

      TDbUserManager::getDbConnection

      getDbConnection( );

      Returns

      the database connection that may be used to retrieve user data.

      access

      public

      [ Top ]

      TDbUserManager::getGuestName

      getGuestName( );

      Implementation of:
      IUserManager::getGuestName()

      Returns

      guest name, defaults to 'Guest'

      access

      public

      [ Top ]

      TDbUserManager::getUser

      getUser( [string $username = null] );

      Overrides TApplicationComponent::getUser() (parent method not documented)

      Implementation of:
      IUserManager::getUser()
      Returns a user instance given the user name.

      Parameters

      $username

      user name, null if it is a guest.

      Returns

      the user instance, null if the specified username is not in the user database.

      Remarks

      Returns a user instance given the user name.

      access

      public

      [ Top ]

      TDbUserManager::getUserClass

      getUserClass( );

      Returns

      the user class name in namespace format. Defaults to empty string, meaning not set.

      access

      public

      [ Top ]

      TDbUserManager::getUserFromCookie

      getUserFromCookie( THttpCookie $cookie );

      Implementation of:
      IUserManager::getUserFromCookie()
      Returns a user instance according to auth data stored in a cookie.

      Parameters

      $cookie

      the cookie storing user authentication information

      Returns

      the user instance generated based on the cookie auth data, null if the cookie does not have valid auth data.

      Remarks

      Returns a user instance according to auth data stored in a cookie.

      since

      3.1.1

      access

      public

      [ Top ]

      TDbUserManager::init

      init( TXmlElement $config );

      Overrides TModule::init() (Initializes the module.)

      Parameters

      $config

      module configuration

      Remarks

      Initializes the module.

      This method is required by IModule and is invoked by application.

      access

      public

      [ Top ]

      TDbUserManager::saveUserToCookie

      saveUserToCookie( THttpCookie $cookie );

      Implementation of:
      IUserManager::saveUserToCookie()
      Saves user auth data into a cookie.

      Parameters

      $cookie

      the cookie to receive the user auth data.

      Remarks

      Saves user auth data into a cookie.

      since

      3.1.1

      access

      public

      [ Top ]

      TDbUserManager::setConnectionID

      setConnectionID( string $value );

      Parameters

      $value

      module ID.

      Remarks

      Sets the ID of a TDataSourceConfig module.

      The datasource module will be used to establish the DB connection that will be used by the user manager.

      access

      public

      [ Top ]

      TDbUserManager::setGuestName

      setGuestName( string $value );

      Parameters

      $value

      name to be used for guest users.

      access

      public

      [ Top ]

      TDbUserManager::setUserClass

      setUserClass( string $value );

      Parameters

      $value

      the user class name in namespace format. The user class must extend from TDbUser.

      access

      public

      [ Top ]

      TDbUserManager::validateUser

      validateUser( string $username, string $password );

      Implementation of:
      IUserManager::validateUser()
      Validates if the username and password are correct.

      Parameters

      $username

      user name

      $password

      password

      Returns

      true if validation is successful, false otherwise.

      Remarks

      Validates if the username and password are correct.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:13 +0200 by phpDocumentor 1.4.3


Docs For Class TSecurityManager

Class TSecurityManager

[line 43]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TSecurityManager
Location: /Security/TSecurityManager.php

Remarks

TSecurityManager class

TSecurityManager provides private keys, hashing and encryption functionalities that may be used by other PRADO components, such as viewstate persister, cookies.

TSecurityManager is mainly used to protect data from being tampered and viewed. It can generate HMAC and encrypt the data. The private key used to generate HMAC is set by ValidationKey. The key used to encrypt data is specified by EncryptionKey. If the above keys are not explicitly set, random keys will be generated and used.

To prefix data with an HMAC, call hashData(). To validate if data is tampered, call validateData(), which will return the real data if it is not tampered. The algorithm used to generated HMAC is specified by Validation.

To encrypt and decrypt data, call encrypt() and decrypt() respectively. The encryption algorithm can be set by Encryption.

Note, to use encryption, the PHP Mcrypt extension must be loaded.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TSecurityManager.php 3066 2011-11-17 16:52:56Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • STATE_ENCRYPTION_KEY =  'prado:securitymanager:encryptionkey'
  • STATE_VALIDATION_KEY =  'prado:securitymanager:validationkey'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSecurityManager::computeHMAC

    computeHMAC( string $data );

    Parameters

    $data

    data to be generated HMAC

    Returns

    the HMAC for the data

    Remarks

    Computes the HMAC for the data with getValidationKey.

    access

    protected

    [ Top ]

    TSecurityManager::decrypt

    decrypt( string $data );

    Parameters

    $data

    data to be decrypted.

    Returns

    the decrypted data

    Remarks

    Decrypts data with getEncryptionKey.

    throws

    TNotSupportedException if PHP Mcrypt extension is not loaded

    access

    public

    [ Top ]

    TSecurityManager::encrypt

    encrypt( string $data );

    Parameters

    $data

    data to be encrypted.

    Returns

    the encrypted data

    Remarks

    Encrypts data with getEncryptionKey.

    throws

    TNotSupportedException if PHP Mcrypt extension is not loaded

    access

    public

    [ Top ]

    TSecurityManager::generateRandomKey

    generateRandomKey( );

    Remarks

    Generates a random key.

    access

    protected

    [ Top ]

    TSecurityManager::getEncryption

    getEncryption( );

    Returns

    the algorithm used to encrypt/decrypt data. Defaults to '3DES'.

    access

    public

    [ Top ]

    TSecurityManager::getEncryptionKey

    getEncryptionKey( );

    Returns

    the private key used to encrypt/decrypt data. If the key is not explicitly set, a random one is generated and returned.

    access

    public

    [ Top ]

    TSecurityManager::getValidation

    getValidation( );

    Returns

    hashing algorithm used to generate HMAC. Defaults to TSecurityManagerValidationMode::SHA1.

    access

    public

    [ Top ]

    TSecurityManager::getValidationKey

    getValidationKey( );

    Returns

    the private key used to generate HMAC. If the key is not explicitly set, a random one is generated and returned.

    access

    public

    [ Top ]

    TSecurityManager::hashData

    hashData( string $data );

    Parameters

    $data

    data to be hashed.

    Returns

    data prefixed with HMAC

    Remarks

    Prefixes data with an HMAC.

    access

    public

    [ Top ]

    TSecurityManager::init

    init( TXmlElement $config );

    Overrides TModule::init() (Initializes the module.)

    Parameters

    $config

    initial module configuration

    Remarks

    Initializes the module.

    The security module is registered with the application.

    access

    public

    [ Top ]

    TSecurityManager::setEncryption

    setEncryption( $value );

    Parameters

    $value

    throws

    TNotSupportedException Do not call this method presently.

    access

    public

    [ Top ]

    TSecurityManager::setEncryptionKey

    setEncryptionKey( string $value );

    Parameters

    $value

    the key used to encrypt/decrypt data.

    throws

    TInvalidDataValueException if the key is empty

    access

    public

    [ Top ]

    TSecurityManager::setValidation

    setValidation( TSecurityManagerValidationMode $value );

    Parameters

    $value

    hashing algorithm used to generate HMAC.

    access

    public

    [ Top ]

    TSecurityManager::setValidationKey

    setValidationKey( string $value );

    Parameters

    $value

    the key used to generate HMAC

    throws

    TInvalidDataValueException if the key is empty

    access

    public

    [ Top ]

    TSecurityManager::validateData

    validateData( string $data );

    Parameters

    $data

    data to be validated. The data must be previously generated using hashData().

    Returns

    the real data with HMAC stripped off. False if the data is tampered.

    Remarks

    Validates if data is tampered.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • STATE_ENCRYPTION_KEY =  'prado:securitymanager:encryptionkey' [line 46]

  • STATE_VALIDATION_KEY =  'prado:securitymanager:validationkey' [line 45]

Documentation generated on Mon, 25 Jun 2012 14:45:20 +0200 by phpDocumentor 1.4.3


Docs For Class TSecurityManagerValidationMode

Class TSecurityManagerValidationMode

[line 264]
TEnumerable
   |
   --TSecurityManagerValidationMode
Location: /Security/TSecurityManager.php

Remarks

TSecurityManagerValidationMode class.

TSecurityManagerValidationMode defines the enumerable type for the possible validation modes that can be used by TSecurityManager.

The following enumerable values are defined:

  • MD5: an MD5 hash is generated from the data and used for validation.
  • SHA1: an SHA1 hash is generated from the data and used for validation.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TSecurityManager.php 3066 2011-11-17 16:52:56Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • MD5 =  'MD5'
  • SHA1 =  'SHA1'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • MD5 =  'MD5' [line 266]

  • SHA1 =  'SHA1' [line 267]

Documentation generated on Mon, 25 Jun 2012 14:45:20 +0200 by phpDocumentor 1.4.3


Docs For Class TUser

Class TUser

[line 34]
TComponent
   |
   --TUser
Classes extended from TUser:
TDbUser
TDbUser class

Location: /Security/TUser.php

Remarks

TUser class

TUser implements basic user functionality for a Prado application. To get the name of the user, use Name property. The property IsGuest tells if the user a guest/anonymous user. To obtain or test the roles that the user is in, use property Roles and call isInRole(), respectively.

TUser is meant to be used together with IUserManager.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TUser.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TUser::__construct

    __construct( IUserManager $manager );

    Parameters

    $manager

    user manager

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TUser::getIsGuest

    getIsGuest( );

    Returns

    if the user is a guest, defaults to true.

    access

    public

    [ Top ]

    TUser::getManager

    getManager( );

    Returns

    user manager

    access

    public

    [ Top ]

    TUser::getName

    getName( );

    Returns

    username, defaults to empty string.

    access

    public

    [ Top ]

    TUser::getRoles

    getRoles( );

    Returns

    list of roles that the user is of

    access

    public

    [ Top ]

    TUser::getState

    getState( string $key, [mixed $defaultValue = null] );

    Parameters

    $key

    variable name

    $defaultValue

    default value

    Returns

    the value of the variable. If it doesn't exist, the provided default value will be returned

    Remarks

    Returns the value of a variable that is stored in user session.

    This function is designed to be used by TUser descendant classes who want to store additional user information in user session. A variable, if stored in user session using setState can be retrieved back using this function.

    see

    TUser::setState()

    access

    protected

    [ Top ]

    TUser::getStateChanged

    getStateChanged( );

    Returns

    whether user session state is changed (i.e., setState() is called)

    access

    public

    [ Top ]

    TUser::isInRole

    isInRole( string $role );

    Parameters

    $role

    role to be tested. Note, role is case-insensitive.

    Returns

    whether the user is of this role

    access

    public

    [ Top ]

    TUser::loadFromString

    loadFromString( string $data );

    Parameters

    $data

    user data that is serialized and restored from session

    Returns

    the user object

    access

    public

    [ Top ]

    TUser::saveToString

    saveToString( );

    Returns

    user data that is serialized and will be stored in session

    access

    public

    [ Top ]

    TUser::setIsGuest

    setIsGuest( boolean $value );

    Parameters

    $value

    if the user is a guest

    access

    public

    [ Top ]

    TUser::setName

    setName( string $value );

    Parameters

    $value

    username

    access

    public

    [ Top ]

    TUser::setRoles

    setRoles( $value );

    Parameters

    $value

    Returns

    list of roles that the user is of. If it is a string, roles are assumed by separated by comma

    access

    public

    [ Top ]

    TUser::setState

    setState( string $key, mixed $value, [mixed $defaultValue = null] );

    Parameters

    $key

    variable name

    $value

    variable value

    $defaultValue

    default value. If $value===$defaultValue, the variable will be removed from persistent storage.

    Remarks

    Stores a variable in user session.

    This function is designed to be used by TUser descendant classes who want to store additional user information in user session. By storing a variable using this function, the variable may be retrieved back later using getState. The variable will be persistent across page requests during a user session.

    see

    TUser::getState()

    access

    protected

    [ Top ]

    TUser::setStateChanged

    setStateChanged( boolean $value );

    Parameters

    $value

    whether user session state is changed

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:45 +0200 by phpDocumentor 1.4.3


Docs For Class TUserManager

Class TUserManager

[line 71]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TUserManager
Location: /Security/TUserManager.php

Remarks

TUserManager class

TUserManager manages a static list of users TUser. The user information is specified via module configuration using the following XML syntax,

  •  <module id="users" class="System.Security.TUserManager" PasswordMode="Clear">
    •

  •    <user name="Joe" password="demo" />
    •

  •    <user name="John" password="demo" />
    •

  •    <role name="Administrator" users="John" />
    •

  •    <role name="Writer" users="Joe,John" />
    •

  •  </module>
    •

    PHP configuration style:

  •  array(
    •

  •    'users' => array(
    •

  •       'class' => 'System.Security.TUserManager',
    •

  •       'properties' => array(
    •

  •          'PasswordMode' => 'Clear',
    •

  •        ),
    •

  •        'users' => array(
    •

  •           array('name'=>'Joe','password'=>'demo'),
    •

  •           array('name'=>'John','password'=>'demo'),
    •

  •        ),
    •

  •        'roles' => array(
    •

  •           array('name'=>'Administrator','users'=>'John'),
    •

  •           array('name'=>'Writer','users'=>'Joe,John'),
    •

  •        ),
    •

  •     ),
    •

  •  )
    •

    In addition, user information can also be loaded from an external file specified by UserFile property. Note, the property only accepts a file path in namespace format. The user file format is similar to the above sample.

    The user passwords may be specified as clear text, SH1 or MD5 hashed by setting PasswordMode as Clear, SHA1 or MD5. The default name for a guest user is Guest. It may be changed by setting GuestName property.

    TUserManager may be used together with TAuthManager which manages how users are authenticated and authorized in a Prado application.

    author

    Carl Mathisen <carl@kamikazemedia.no>

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TUserManager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    • USER_FILE_EXT = '.xml'
      extension name to the user file

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TUserManager::getGuestName

      getGuestName( );

      Implementation of:
      IUserManager::getGuestName()

      Returns

      guest name, defaults to 'Guest'

      access

      public

      [ Top ]

      TUserManager::getPasswordMode

      getPasswordMode( );

      Returns

      how password is stored, clear text, or MD5 or SHA1 hashed. Default to TUserManagerPasswordMode::MD5.

      access

      public

      [ Top ]

      TUserManager::getRoles

      getRoles( );

      Returns

      list of user role information

      Remarks

      Returns an array of user role information.

      Each array element represents the roles for a single user. The array key is the username in lower case, and the array value is the roles (represented as an array) that the user is in.

      access

      public

      [ Top ]

      TUserManager::getUser

      getUser( [string $username = null] );

      Overrides TApplicationComponent::getUser() (parent method not documented)

      Implementation of:
      IUserManager::getUser()
      Returns a user instance given the user name.

      Parameters

      $username

      user name, null if it is a guest.

      Returns

      the user instance, null if the specified username is not in the user database.

      Remarks

      Returns a user instance given the user name.

      access

      public

      [ Top ]

      TUserManager::getUserFile

      getUserFile( );

      Returns

      the full path to the file storing user/role information

      access

      public

      [ Top ]

      TUserManager::getUserFromCookie

      getUserFromCookie( THttpCookie $cookie );

      Implementation of:
      IUserManager::getUserFromCookie()
      Returns a user instance according to auth data stored in a cookie.

      Parameters

      $cookie

      the cookie storing user authentication information

      Returns

      the user instance generated based on the cookie auth data, null if the cookie does not have valid auth data.

      Remarks

      Returns a user instance according to auth data stored in a cookie.

      since

      3.1.1

      access

      public

      [ Top ]

      TUserManager::getUsers

      getUsers( );

      Returns

      list of users

      Remarks

      Returns an array of all users.

      Each array element represents a single user. The array key is the username in lower case, and the array value is the corresponding user password.

      access

      public

      [ Top ]

      TUserManager::init

      init( mixed $config );

      Overrides TModule::init() (Initializes the module.)

      Parameters

      $config

      module configuration

      Remarks

      Initializes the module.

      This method is required by IModule and is invoked by application. It loads user/role information from the module configuration.

      access

      public

      [ Top ]

      TUserManager::saveUserToCookie

      saveUserToCookie( THttpCookie $cookie );

      Implementation of:
      IUserManager::saveUserToCookie()
      Saves user auth data into a cookie.

      Parameters

      $cookie

      the cookie to receive the user auth data.

      Remarks

      Saves user auth data into a cookie.

      since

      3.1.1

      access

      public

      [ Top ]

      TUserManager::setGuestName

      setGuestName( string $value );

      Parameters

      $value

      name to be used for guest users.

      access

      public

      [ Top ]

      TUserManager::setPasswordMode

      setPasswordMode( TUserManagerPasswordMode $value );

      Parameters

      $value

      how password is stored, clear text, or MD5 or SHA1 hashed.

      access

      public

      [ Top ]

      TUserManager::setUserFile

      setUserFile( string $value );

      Parameters

      $value

      user/role data file path (in namespace form). The file format is XML whose content is similar to that user/role block in application configuration.

      throws

      TConfigurationException if the file is not in proper namespace format

      throws

      TInvalidOperationException if the module is already initialized

      access

      public

      [ Top ]

      TUserManager::switchToGuest

      switchToGuest( TUser $user );

      Parameters

      $user

      the user to be changed to a guest.

      Remarks

      Sets a user as a guest.

      User name is changed as guest name, and roles are emptied.

      access

      public

      [ Top ]

      TUserManager::validateUser

      validateUser( string $username, string $password );

      Implementation of:
      IUserManager::validateUser()
      Validates if the username and password are correct.

      Parameters

      $username

      user name

      $password

      password

      Returns

      true if validation is successful, false otherwise.

      Remarks

      Validates if the username and password are correct.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • USER_FILE_EXT = '.xml' [line 76]

      • Remarks

      extension name to the user file

    Documentation generated on Mon, 25 Jun 2012 14:45:45 +0200 by phpDocumentor 1.4.3


Docs For Class TUserManagerPasswordMode

Class TUserManagerPasswordMode

[line 396]
TEnumerable
   |
   --TUserManagerPasswordMode
Location: /Security/TUserManager.php

Remarks

TUserManagerPasswordMode class.

TUserManagerPasswordMode defines the enumerable type for the possible modes that user passwords can be specified for a TUserManager.

The following enumerable values are defined:

  • Clear: the password is in plain text
  • MD5: the password is recorded as the MD5 hash value of the original password
  • SHA1: the password is recorded as the SHA1 hash value of the original password

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TUserManager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Clear = 'Clear'
  • MD5 = 'MD5'
  • SHA1 = 'SHA1'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Clear = 'Clear' [line 398]

  • MD5 = 'MD5' [line 399]

  • SHA1 = 'SHA1' [line 400]

Documentation generated on Mon, 25 Jun 2012 14:45:45 +0200 by phpDocumentor 1.4.3


Package System.Web.UI.WebControls Element Index

Element index for package System.Web.UI.WebControls

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Xml

Index of all elements
a b c d e f g h i j l m n o p r s t u v w _
top
_
$_decorator | in file TWebControl.php, variable TWebControl::$_decorator
$_errorCode | in file TFileUpload.php, variable TFileUpload::$_errorCode
$_isvalid | in file TReCaptchaValidator.php, variable TReCaptchaValidator::$_isvalid
$_writers | in file TOutputCache.php, variable TOutputCacheTextWriterMulti::$_writers
__clone in file TStyle.php, method TStyle::__clone()
Need to clone the font object.
__construct in file TRatingList.php, method TRatingList::__construct()
Sets the default repeat direction to horizontal.
__construct in file TRadioButton.php, method TRadioButton::__construct()
Constructor.
__construct | in file TOutputCache.php, method TOutputCacheTextWriterMulti::__construct()
__construct in file TImageMap.php, method TImageMapEventParameter::__construct()
Constructor.
__construct in file TListItem.php, method TListItem::__construct()
Constructor.
__construct in file TPager.php, method TPagerPageChangedEventParameter::__construct()
Constructor.
__construct in file TRepeater.php, method TRepeaterItemEventParameter::__construct()
Constructor.
__construct in file TWizard.php, method TWizardNavigationTemplate::__construct()
Constructor.
__construct in file TWizard.php, method TWizardStepCollection::__construct()
Constructor.
__construct in file TXmlTransform.php, method TXmlTransform::__construct()
Constructor
__construct in file TWizard.php, method TWizardNavigationEventParameter::__construct()
Constructor.
__construct in file TWebControlDecorator.php, method TWebControlDecorator::__construct()
Constructor.
__construct in file TImageButton.php, method TImageClickEventParameter::__construct()
Constructor.
__construct in file TStyle.php, method TStyle::__construct()
Constructor.
__construct in file TValidationSummary.php, method TValidationSummary::__construct()
Constructor.
__construct in file TRepeater.php, method TRepeaterCommandEventParameter::__construct()
Constructor.
__construct in file THtmlArea.php, method THtmlArea::__construct()
Constructor.
__construct in file TDataGrid.php, method TDataGridItem::__construct()
Constructor.
__construct in file TDataGrid.php, method TDataGridItemEventParameter::__construct()
Constructor.
__construct in file TDataGrid.php, method TDataGridPageChangedEventParameter::__construct()
Constructor.
__construct in file TDataGrid.php, method TDataGridCommandEventParameter::__construct()
Constructor.
__construct in file TDataGrid.php, method TDataGridColumnCollection::__construct()
Constructor.
__construct in file TBulletedList.php, method TBulletedListEventParameter::__construct()
Constructor.
__construct in file TCheckBoxList.php, method TCheckBoxList::__construct()
Constructor.
__construct in file TCustomValidator.php, method TServerValidateEventParameter::__construct()
Constructor.
__construct in file TDataGrid.php, method TDataGridPager::__construct()
Constructor.
__construct in file TDataGrid.php, method TDataGridPagerEventParameter::__construct()
Constructor.
__construct | in file TDataSourceView.php, method TReadOnlyDataSourceView::__construct()
__construct | in file TDropDownListColumn.php, method TDropDownListColumn::__construct()
__construct in file TFlushOutput.php, method TFlushOutput::__construct()
Constructor.
__construct | in file TDataSourceView.php, method TDataSourceView::__construct()
__construct | in file TDataSourceControl.php, method TReadOnlyDataSource::__construct()
__construct in file TDataGrid.php, method TDataGridSortCommandEventParameter::__construct()
Constructor.
__construct in file TDataList.php, method TDataListCommandEventParameter::__construct()
Constructor.
__construct in file TDataList.php, method TDataListItemEventParameter::__construct()
Constructor.
__construct in file TBaseValidator.php, method TBaseValidator::__construct()
Constructor.
top
a
activateView in file TTabPanel.php, method TTabPanel::activateView()
Activates the specified view.
activateView in file TAccordion.php, method TAccordion::activateView()
Activates the specified view.
activateView in file TMultiView.php, method TMultiView::activateView()
Activates the specified view.
addAttributesToRender in file TPanelStyle.php, method TPanelStyle::addAttributesToRender()
Adds attributes related to CSS styles to renderer.
addAttributesToRender | in file TReCaptcha.php, method TReCaptcha::addAttributesToRender()
addAttributesToRender in file TSlider.php, method TSlider::addAttributesToRender()
Add the specified css classes to the track
addAttributesToRender in file TStyle.php, method TStyle::addAttributesToRender()
Adds attributes related to CSS styles to renderer.
addAttributesToRender in file TAccordion.php, method TAccordionView::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TListControl.php, method TListControl::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TLabel.php, method TLabel::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TLinkButton.php, method TLinkButton::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TListBox.php, method TListBox::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TStyle.php, method TTableItemStyle::addAttributesToRender()
Adds attributes related to CSS styles to renderer.
addAttributesToRender in file TStyle.php, method TTableStyle::addAttributesToRender()
Adds attributes related to CSS styles to renderer.
addAttributesToRender in file TTabPanel.php, method TTabView::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TTextBox.php, method TTextBox::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender | in file TValidationSummary.php, method TValidationSummary::addAttributesToRender()
addAttributesToRender in file TWebControl.php, method TWebControl::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TTabPanel.php, method TTabPanel::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TAccordion.php, method TAccordion::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TTable.php, method TTable::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TTableCell.php, method TTableCell::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TTableHeaderCell.php, method TTableHeaderCell::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TKeyboard.php, method TKeyboard::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TPanel.php, method TPanel::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TFileUpload.php, method TFileUpload::addAttributesToRender()
Sets name attribute to the unique ID of the control.
addAttributesToRender in file TFont.php, method TFont::addAttributesToRender()
Adds attributes related to CSS styles to renderer.
addAttributesToRender in file THtmlArea.php, method THtmlArea::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TDatePicker.php, method TDatePicker::addAttributesToRender()
Add the client id to the input textbox, and register the client scripts.
addAttributesToRender in file TDataListItemRenderer.php, method TDataListItemRenderer::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TBaseValidator.php, method TBaseValidator::addAttributesToRender()
Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
addAttributesToRender in file TBulletedList.php, method TBulletedList::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TButton.php, method TButton::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file THyperLink.php, method THyperLink::addAttributesToRender()
Adds attributes related to a hyperlink element to renderer.
addAttributesToRender in file TDropDownList.php, method TDropDownList::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TImage.php, method TImage::addAttributesToRender()
Adds attributes related to an HTML image element to renderer.
addAttributesToRender in file TImageMap.php, method TImageMap::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TInlineFrame.php, method TInlineFrame::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TImageButton.php, method TImageButton::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addedWizardStep in file TWizard.php, method TWizard::addedWizardStep()
Adds a wizard step to the multiview.
addParsedObject in file TDataGrid.php, method TDataGrid::addParsedObject()
Adds objects parsed in template to datagrid.
addParsedObject in file TTableRow.php, method TTableRow::addParsedObject()
Adds object parsed from template to the control.
addParsedObject in file TImageMap.php, method TImageMap::addParsedObject()
Processes an object that is created during parsing template.
addParsedObject in file TConditional.php, method TConditional::addParsedObject()
Processes an object that is created during parsing template.
addParsedObject in file TTabPanel.php, method TTabPanel::addParsedObject()
Adds object parsed from template to the control.
addParsedObject in file TMultiView.php, method TMultiView::addParsedObject()
Processes an object that is created during parsing template.
addParsedObject in file TWizard.php, method TWizard::addParsedObject()
Adds TWizardStep objects into step collection.
addParsedObject in file TAccordion.php, method TAccordion::addParsedObject()
Adds object parsed from template to the control.
addParsedObject in file TListControl.php, method TListControl::addParsedObject()
Adds object parsed from template to the control.
addParsedObject in file TTable.php, method TTable::addParsedObject()
Adds object parsed from template to the control.
addParsedObject in file TDropDownListColumn.php, method TDropDownListColumn::addParsedObject()
Adds object parsed from template to the control.
addToPostDataLoader in file TRadioButton.php, method TRadioButton::addToPostDataLoader()
Add the group name as post data loader if group name is set.
allowNavigationToPreviousStep | in file TWizard.php, method TWizard::allowNavigationToPreviousStep()
allowNavigationToStep | in file TWizard.php, method TWizard::allowNavigationToStep()
AlternatingItem | in file TDataBoundControl.php, class constant TListItemType::AlternatingItem
apply in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::apply()
Applies this style to the specified button
applyControlProperties in file TWizard.php, method TWizard::applyControlProperties()
Applies various properties to the components of wizard
applyHeaderProperties in file TWizard.php, method TWizard::applyHeaderProperties()
Applies properties to the wizard header
applyItemStyles in file TDataList.php, method TDataList::applyItemStyles()
Applies styles to items, header, footer and separators.
applyItemStyles in file TDataGrid.php, method TDataGrid::applyItemStyles()
Applies styles to items, header, footer and separators.
applyNavigationProperties in file TWizard.php, method TWizard::applyNavigationProperties()
Apply properties to various navigation panels.
applySideBarProperties in file TWizard.php, method TWizard::applySideBarProperties()
Applies properties to the wizard sidebar
applyStepContentProperties in file TWizard.php, method TWizard::applyStepContentProperties()
Applies properties to the wizard step content
Auto | in file TPanelStyle.php, class constant TScrollBars::Auto
Auto | in file TWizard.php, class constant TWizardStepType::Auto
Auto | in file TInlineFrame.php, class constant TInlineFrameScrollBars::Auto
top
b
Basic | in file TDatePicker.php, class constant TDatePickerMode::Basic
Basic | in file TColorPicker.php, class constant TColorPickerMode::Basic
Body | in file TTableRow.php, class constant TTableRowSection::Body
Both | in file TInlineFrame.php, class constant TInlineFrameScrollBars::Both
Both | in file TStyle.php, class constant TTableGridLines::Both
Both | in file TPanelStyle.php, class constant TScrollBars::Both
Bottom | in file TStyle.php, class constant TVerticalAlign::Bottom
Bottom | in file TTable.php, class constant TTableCaptionAlign::Bottom
Bottom | in file TInlineFrame.php, class constant TInlineFrameAlign::Bottom
Bottom | in file TDatePicker.php, class constant TDatePickerPositionMode::Bottom
Bottom | in file TDataGrid.php, class constant TDataGridPagerPosition::Bottom
bubbleEvent in file TPager.php, method TPager::bubbleEvent()
Processes a bubbled event.
bubbleEvent in file TRepeaterItemRenderer.php, method TRepeaterItemRenderer::bubbleEvent()
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
bubbleEvent in file TMultiView.php, method TMultiView::bubbleEvent()
Processes the events bubbled from child controls.
bubbleEvent in file TRepeater.php, method TRepeaterItem::bubbleEvent()
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
bubbleEvent in file TDataListItemRenderer.php, method TDataListItemRenderer::bubbleEvent()
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
bubbleEvent in file TDataGrid.php, method TDataGridItem::bubbleEvent()
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
bubbleEvent in file TWizard.php, method TWizard::bubbleEvent()
Handles bubbled events.
bubbleEvent in file TDataGrid.php, method TDataGridPager::bubbleEvent()
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
bubbleEvent in file TRepeater.php, method TRepeater::bubbleEvent()
This method overrides parent's implementation to handle onItemCommand event which is bubbled from repeater items and their child controls.
bubbleEvent in file TDataList.php, method TDataListItem::bubbleEvent()
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
bubbleEvent in file TDataList.php, method TDataList::bubbleEvent()
This method overrides parent's implementation to handle onItemCommand event which is bubbled from datalist items and their child controls.
bubbleEvent in file TDataGrid.php, method TDataGrid::bubbleEvent()
This method overrides parent's implementation to handle onItemCommand event which is bubbled from TDataGridItem child controls.
buildListPager in file TPager.php, method TPager::buildListPager()
Builds a dropdown list pager
buildNextPrevPager in file TPager.php, method TPager::buildNextPrevPager()
Builds a next-prev pager
buildNextPrevPager in file TDataGrid.php, method TDataGrid::buildNextPrevPager()
Builds a next-prev pager
buildNumericPager in file TPager.php, method TPager::buildNumericPager()
Builds a numeric pager
buildNumericPager in file TDataGrid.php, method TDataGrid::buildNumericPager()
Builds a numeric pager
buildPager in file TDataGrid.php, method TDataGrid::buildPager()
Builds the pager content based on pager style.
buildPager in file TPager.php, method TPager::buildPager()
Builds the pager content based on the pager mode.
BulletList | in file TValidationSummary.php, class constant TValidationSummaryDisplayMode::BulletList
BusinessCity | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessCity
BusinessCountryRegion | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessCountryRegion
BusinessFax | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessFax
BusinessPhone | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessPhone
BusinessState | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessState
BusinessStreetAddress | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessStreetAddress
BusinessUrl | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessUrl
BusinessZipCode | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessZipCode
Button | in file TWizard.php, class constant TWizardNavigationButtonType::Button
Button | in file TDatePicker.php, class constant TDatePickerMode::Button
Button | in file TButton.php, class constant TButtonType::Button
top
c
CACHE_ID_PREFIX | in file TOutputCache.php, class constant TOutputCache::CACHE_ID_PREFIX
calculateCacheKey in file TOutputCache.php, method TOutputCache::calculateCacheKey()
Calculates the cache key.
canCauseValidation | in file TButton.php, method TButton::canCauseValidation()
canCauseValidation | in file TBulletedList.php, method TBulletedList::canCauseValidation()
canCauseValidation | in file TImageButton.php, method TImageButton::canCauseValidation()
Cellular | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Cellular
Center | in file TStyle.php, class constant THorizontalAlign::Center
ChallengeFieldName | in file TReCaptcha.php, class constant TReCaptcha::ChallengeFieldName
checkRequirements in file TCaptcha.php, method TCaptcha::checkRequirements()
Checks the requirements needed for generating CAPTCHA images.
Circle | in file TBulletedList.php, class constant TBulletStyle::Circle
clearSelection in file TListControl.php, method TListControl::clearSelection()
Clears all existing selections.
clearStyle in file TWebControl.php, method TWebControl::clearStyle()
Removes all style data.
clearStyle in file TDataListItemRenderer.php, method TDataListItemRenderer::clearStyle()
Removes all style data.
clearStyleField in file TStyle.php, method TStyle::clearStyleField()
Clears a single style field value;
Clickable | in file TDatePicker.php, class constant TDatePickerMode::Clickable
CMD_CANCEL | in file TDataList.php, class constant TDataList::CMD_CANCEL
CMD_CANCEL | in file TDataGrid.php, class constant TDataGrid::CMD_CANCEL
CMD_CANCEL | in file TWizard.php, class constant TWizard::CMD_CANCEL
CMD_COMPLETE | in file TWizard.php, class constant TWizard::CMD_COMPLETE
CMD_DELETE | in file TDataList.php, class constant TDataList::CMD_DELETE
CMD_DELETE | in file TDataGrid.php, class constant TDataGrid::CMD_DELETE
CMD_EDIT | in file TDataList.php, class constant TDataList::CMD_EDIT
CMD_EDIT | in file TDataGrid.php, class constant TDataGrid::CMD_EDIT
CMD_MOVETO | in file TWizard.php, class constant TWizard::CMD_MOVETO
CMD_NEXT | in file TWizard.php, class constant TWizard::CMD_NEXT
CMD_NEXTVIEW | in file TMultiView.php, class constant TMultiView::CMD_NEXTVIEW
CMD_PAGE in file TPager.php, class constant TPager::CMD_PAGE
Command name that TPager understands.
CMD_PAGE | in file TDataGrid.php, class constant TDataGrid::CMD_PAGE
CMD_PAGE_FIRST | in file TDataGrid.php, class constant TDataGrid::CMD_PAGE_FIRST
CMD_PAGE_FIRST | in file TPager.php, class constant TPager::CMD_PAGE_FIRST
CMD_PAGE_LAST | in file TDataGrid.php, class constant TDataGrid::CMD_PAGE_LAST
CMD_PAGE_LAST | in file TPager.php, class constant TPager::CMD_PAGE_LAST
CMD_PAGE_NEXT | in file TPager.php, class constant TPager::CMD_PAGE_NEXT
CMD_PAGE_NEXT | in file TDataGrid.php, class constant TDataGrid::CMD_PAGE_NEXT
CMD_PAGE_PREV | in file TPager.php, class constant TPager::CMD_PAGE_PREV
CMD_PAGE_PREV | in file TDataGrid.php, class constant TDataGrid::CMD_PAGE_PREV
CMD_PREVIOUS in file TWizard.php, class constant TWizard::CMD_PREVIOUS
Navigation commands.
CMD_PREVIOUSVIEW | in file TMultiView.php, class constant TMultiView::CMD_PREVIOUSVIEW
CMD_SELECT in file TDataList.php, class constant TDataList::CMD_SELECT
Command name that TDataList understands. They are case-insensitive.
CMD_SELECT in file TDataGrid.php, class constant TDataGrid::CMD_SELECT
Command name that TDataGrid understands.
CMD_SORT | in file TDataGrid.php, class constant TDataGrid::CMD_SORT
CMD_SWITCHVIEWID | in file TMultiView.php, class constant TMultiView::CMD_SWITCHVIEWID
CMD_SWITCHVIEWINDEX | in file TMultiView.php, class constant TMultiView::CMD_SWITCHVIEWINDEX
CMD_UPDATE | in file TDataGrid.php, class constant TDataGrid::CMD_UPDATE
CMD_UPDATE | in file TDataList.php, class constant TDataList::CMD_UPDATE
Column | in file TTableHeaderCell.php, class constant TTableHeaderScope::Column
Company | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Company
Complete | in file TWizard.php, class constant TWizardStepType::Complete
copyBaseAttributes in file TWebControl.php, method TWebControl::copyBaseAttributes()
Copies basic control attributes from another control.
copyCustomPlugins | in file THtmlArea.php, method THtmlArea::copyCustomPlugins()
copyFrom in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::copyFrom()
Copies the fields in a new style to this style.
copyFrom in file TDataGridPagerStyle.php, method TDataGridPagerStyle::copyFrom()
Copies the fields in a new style to this style.
copyFrom in file TStyle.php, method TStyle::copyFrom()
Copies the fields in a new style to this style.
copyFrom in file TStyle.php, method TTableStyle::copyFrom()
Copies the fields in a new style to this style.
copyFrom in file TPanelStyle.php, method TPanelStyle::copyFrom()
Copies the fields in a new style to this style.
copyFrom in file TStyle.php, method TTableItemStyle::copyFrom()
Copies the fields in a new style to this style.
copyFrom in file TFont.php, method TFont::copyFrom()
Copies the fields in a new font to this font.
createAutoColumns in file TDataGrid.php, method TDataGrid::createAutoColumns()
Automatically generates datagrid columns based on datasource schema
createButton in file TEditCommandColumn.php, method TEditCommandColumn::createButton()
Creates a button and initializes its properties.
createChildControls in file TWizard.php, method TTemplatedWizardStep::createChildControls()
Creates child controls.
createChildControls in file TWizard.php, method TWizard::createChildControls()
Creates child controls within the wizard
createChildControls in file TConditional.php, method TConditional::createChildControls()
Creates child controls.
createClientScript | in file TSlider.php, method TSlider::createClientScript()
createClientScript | in file TDatePicker.php, method TDatePicker::createClientScript()
createClientScript | in file TValidationSummary.php, method TValidationSummary::createClientScript()
createClientSide | in file TColorPicker.php, method TColorPicker::createClientSide()
createClientSide | in file TBaseValidator.php, method TBaseValidator::createClientSide()
createControlCollection in file TTabPanel.php, method TTabPanel::createControlCollection()
Creates a control collection object that is to be used to hold child controls
createControlCollection in file TMultiView.php, method TMultiView::createControlCollection()
Creates a control collection object that is to be used to hold child controls
createControlCollection in file TAccordion.php, method TAccordion::createControlCollection()
Creates a control collection object that is to be used to hold child controls
createControlCollection in file TTableRow.php, method TTableRow::createControlCollection()
Creates a control collection object that is to be used to hold child controls
createControlCollection in file TTable.php, method TTable::createControlCollection()
Creates a control collection object that is to be used to hold child controls
createdOnTemplate in file TContent.php, method TContent::createdOnTemplate()
This method is invoked after the control is instantiated on a template.
createdOnTemplate in file TContentPlaceHolder.php, method TContentPlaceHolder::createdOnTemplate()
This method is invoked after the control is instantiated on a template.
createEmptyContent in file TRepeater.php, method TRepeater::createEmptyContent()
Creates empty repeater content.
createEmptyContent in file TDataList.php, method TDataList::createEmptyContent()
Creates empty datalist content.
createFinishNavigation in file TWizard.php, method TWizard::createFinishNavigation()
Creates finish navigation panel.
createHeader in file TWizard.php, method TWizard::createHeader()
Creates the wizard header.
createImage in file THyperLink.php, method THyperLink::createImage()
Gets the TImage for rendering the ImageUrl property. This is not for creating dynamic images.
createItem in file TRepeater.php, method TRepeater::createItem()
Creates a repeater item instance based on the item type and index.
createItem in file TDataGrid.php, method TDataGrid::createItem()
Creates a datagrid item instance based on the item type and index.
createItem in file TDataList.php, method TDataList::createItem()
Creates a datalist item instance based on the item type and index.
createListItemCollection in file TListControl.php, method TListControl::createListItemCollection()
Creates a collection object to hold list items.
createNavigation in file TWizard.php, method TWizard::createNavigation()
Creates navigation panel.
createNavigationButton in file TWizard.php, method TWizardNavigationTemplate::createNavigationButton()
Creates a navigation button.
createPagedDataSource | in file TDataBoundControl.php, method TDataBoundControl::createPagedDataSource()
createPagerButton in file TDataGrid.php, method TDataGrid::createPagerButton()
Creates a pager button.
createPagerButton in file TPager.php, method TPager::createPagerButton()
Creates a pager button.
createRepeatedControl in file TRadioButtonList.php, method TRadioButtonList::createRepeatedControl()
Creates a control used for repetition (used as a template).
createRepeatedControl in file TCheckBoxList.php, method TCheckBoxList::createRepeatedControl()
Creates a control used for repetition (used as a template).
createSideBar in file TWizard.php, method TWizard::createSideBar()
Creates the wizard side bar
createStartNavigation in file TWizard.php, method TWizard::createStartNavigation()
Creates start navigation panel.
createStepContent in file TWizard.php, method TWizard::createStepContent()
Creates wizard step content.
createStepNavigation in file TWizard.php, method TWizard::createStepNavigation()
Creates step navigation panel.
createStyle in file TTableRow.php, method TTableRow::createStyle()
Creates a style object for the control.
createStyle in file TTableCell.php, method TTableCell::createStyle()
Creates a style object for the control.
createStyle in file TTable.php, method TTable::createStyle()
Creates a style object for the control.
createStyle in file TPanel.php, method TPanel::createStyle()
Creates a style object to be used by the control.
createStyle in file TDataGrid.php, method TDataGrid::createStyle()
Creates a style object for the control.
createStyle in file TDataList.php, method TDataListItem::createStyle()
Creates a style object for the control.
createStyle in file TDataListItemRenderer.php, method TDataListItemRenderer::createStyle()
Creates a style object to be used by the control.
createStyle in file TCheckBoxList.php, method TCheckBoxList::createStyle()
Creates a style object for the control.
createStyle in file TWebControl.php, method TWebControl::createStyle()
Creates a style object to be used by the control.
createStyle in file TBaseDataList.php, method TBaseDataList::createStyle()
Creates a style object for the control.
CustomImage | in file TBulletedList.php, class constant TBulletStyle::CustomImage
top
d
dataBind in file TDataBoundControl.php, method TDataBoundControl::dataBind()
Performs databinding.
dataBindColumn in file TDropDownListColumn.php, method TDropDownListColumn::dataBindColumn()
Databinds a cell in the column.
dataBindColumn in file TLiteralColumn.php, method TLiteralColumn::dataBindColumn()
Databinds a cell in the column.
dataBindColumn in file TTemplateColumn.php, method TTemplateColumn::dataBindColumn()
Databinds a cell in the column.
dataBindColumn in file TCheckBoxColumn.php, method TCheckBoxColumn::dataBindColumn()
Databinds a cell in the column.
dataBindColumn in file THyperLinkColumn.php, method THyperLinkColumn::dataBindColumn()
Databinds a cell in the column.
dataBindColumn in file TButtonColumn.php, method TButtonColumn::dataBindColumn()
Databinds a cell in the column.
dataBindColumn in file TBoundColumn.php, method TBoundColumn::dataBindColumn()
Databinds a cell in the column.
dataListItemCommand in file TWizard.php, method TWizard::dataListItemCommand()
Event handler for sidebar datalist's OnItemCommand event.
dataListItemDataBound in file TWizard.php, method TWizard::dataListItemDataBound()
Event handler for sidebar datalist's OnItemDataBound event.
dataSourceViewChanged | in file TDataBoundControl.php, method TDataBoundControl::dataSourceViewChanged()
Date | in file TBaseValidator.php, class constant TValidationDataType::Date
DEFAULT_COLUMNS in file TTextBox.php, class constant TTextBox::DEFAULT_COLUMNS
Default number of columns (for MultiLine text box)
DEFAULT_ROWS in file TTextBox.php, class constant TTextBox::DEFAULT_ROWS
Default number of rows (for MultiLine text box)
delete in file TDataSourceView.php, method TDataSourceView::delete()
Deletes DB row(s) with the specified keys.
Department | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Department
determineDataSource | in file TDataBoundControl.php, method TDataBoundControl::determineDataSource()
Disabled | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Disabled
Disc | in file TBulletedList.php, class constant TBulletStyle::Disc
DisplayName | in file TTextBox.php, class constant TTextBoxAutoCompleteType::DisplayName
DropDownList | in file TPager.php, class constant TPagerMode::DropDownList
DropDownList | in file TDatePicker.php, class constant TDatePickerInputMode::DropDownList
Dynamic | in file TStyle.php, class constant TDisplayStyle::Dynamic
Dynamic | in file TBaseValidator.php, class constant TValidatorDisplayStyle::Dynamic
Dynamic | in file TValidationSummary.php, class constant TValidationSummaryDisplayStyle::Dynamic
top
e
EditItem | in file TDataBoundControl.php, class constant TListItemType::EditItem
Email | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Email
EMAIL_REGEXP in file TEmailAddressValidator.php, class constant TEmailAddressValidator::EMAIL_REGEXP
Regular expression used to validate the email address
ensureDataBound in file TDataBoundControl.php, method TDataBoundControl::ensureDataBound()
Ensures any pending dataBind is called.
ensureFunction in file TValidationSummary.php, method TClientSideValidationSummaryOptions::ensureFunction()
Ensure the string is a valid javascript function. The code block is enclosed with "function(summary, validators){ }" block.
ensureTemplateDecoration in file TWebControlDecorator.php, method TWebControlDecorator::ensureTemplateDecoration()
This method places the templates around the open and close tag. This takes a parameter which is
Equal | in file TCompareValidator.php, class constant TValidationCompareOperator::Equal
evaluateDataTypeCheck in file TDataTypeValidator.php, method TDataTypeValidator::evaluateDataTypeCheck()
Determine if the given value is of a particular type using RegExp.
evaluateIsValid in file TReCaptchaValidator.php, method TReCaptchaValidator::evaluateIsValid()
This method overrides the parent's implementation.
evaluateIsValid in file TRegularExpressionValidator.php, method TRegularExpressionValidator::evaluateIsValid()
This method overrides the parent's implementation.
evaluateIsValid in file TRangeValidator.php, method TRangeValidator::evaluateIsValid()
This method overrides the parent's implementation.
evaluateIsValid in file TRequiredFieldValidator.php, method TRequiredFieldValidator::evaluateIsValid()
This method overrides the parent's implementation.
evaluateIsValid in file TEmailAddressValidator.php, method TEmailAddressValidator::evaluateIsValid()
Returns an array of javascript validator options.
evaluateIsValid in file TCompareValidator.php, method TCompareValidator::evaluateIsValid()
This method overrides the parent's implementation.
evaluateIsValid in file TCaptchaValidator.php, method TCaptchaValidator::evaluateIsValid()
This method overrides the parent's implementation.
evaluateIsValid in file TListControlValidator.php, method TListControlValidator::evaluateIsValid()
This method overrides the parent's implementation.
evaluateIsValid in file TCustomValidator.php, method TCustomValidator::evaluateIsValid()
This method overrides the parent's implementation.
evaluateIsValid in file TDataTypeValidator.php, method TDataTypeValidator::evaluateIsValid()
This method overrides the parent's implementation.
evaluateIsValid in file TBaseValidator.php, method TBaseValidator::evaluateIsValid()
This is the major method for validation.
EXT_XML_FILE | in file TXmlTransform.php, class constant TXmlTransform::EXT_XML_FILE
EXT_XSL_FILE | in file TXmlTransform.php, class constant TXmlTransform::EXT_XSL_FILE
top
f
findCaptchaControl | in file TCaptchaValidator.php, method TCaptchaValidator::findCaptchaControl()
findControl in file TCheckBoxList.php, method TCheckBoxList::findControl()
Finds a control by ID.
findIndexByID in file TAccordion.php, method TAccordionViewCollection::findIndexByID()
Finds the index of the accordion view whose ID is the same as the one being looked for.
findIndexByID in file TTabPanel.php, method TTabViewCollection::findIndexByID()
Finds the index of the tab view whose ID is the same as the one being looked for.
findIndexByID in file THead.php, method TMetaTagCollection::findIndexByID()
Finds the lowest cardinal index of the meta tag whose id is the one being looked for.
findMetaTagByID in file THead.php, method TMetaTagCollection::findMetaTagByID()
Finds the item whose value is the one being looked for.
Finish | in file TWizard.php, class constant TWizardStepType::Finish
FirstName | in file TTextBox.php, class constant TTextBoxAutoCompleteType::FirstName
Fixed | in file TStyle.php, class constant TDisplayStyle::Fixed
Fixed | in file TValidationSummary.php, class constant TValidationSummaryDisplayStyle::Fixed
Fixed | in file TBaseValidator.php, class constant TValidatorDisplayStyle::Fixed
Float | in file TBaseValidator.php, class constant TValidationDataType::Float
Flow | in file TRepeatInfo.php, class constant TRepeatLayout::Flow
flush | in file TOutputCache.php, method TOutputCacheTextWriterMulti::flush()
focus | in file TDataSourceControl.php, method TDataSourceControl::focus()
focus in file THiddenField.php, method THiddenField::focus()
Sets focus to this control.
Footer | in file TTableRow.php, class constant TTableRowSection::Footer
Footer | in file TDataBoundControl.php, class constant TListItemType::Footer
formatDataValue in file TListControl.php, method TListControl::formatDataValue()
Formats the text value according to a format string.
formatDataValue in file TDataGridColumn.php, method TDataGridColumn::formatDataValue()
Formats the text value according to a format string.
Full | in file TColorPicker.php, class constant TColorPickerMode::Full
top
g
Gender | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Gender
generateItemStyle in file TDataList.php, method TDataList::generateItemStyle()
Returns a style used for rendering items.
generateItemStyle in file TCheckBoxList.php, method TCheckBoxList::generateItemStyle()
Returns a style used for rendering items.
generateItemStyle | in file TRepeatInfo.php, method IRepeatInfoUser::generateItemStyle()
generatePrivateKeyFile in file TCaptcha.php, method TCaptcha::generatePrivateKeyFile()
Generates a file with a randomly generated private key.
generateRandomKey | in file TCaptcha.php, method TCaptcha::generateRandomKey()
generateToken in file TCaptcha.php, method TCaptcha::generateToken()
Generates the token.
getAbbreviatedText | in file TTableHeaderCell.php, method TTableHeaderCell::getAbbreviatedText()
getAccessKey | in file TImageMap.php, method THotSpot::getAccessKey()
getAccessKey | in file TWebControl.php, method TWebControl::getAccessKey()
getActive | in file TAccordion.php, method TAccordionView::getActive()
getActive | in file TMultiView.php, method TView::getActive()
getActive | in file TTabPanel.php, method TTabView::getActive()
getActiveHeaderCssClass | in file TAccordion.php, method TAccordion::getActiveHeaderCssClass()
getActiveHeaderStyle | in file TAccordion.php, method TAccordion::getActiveHeaderStyle()
getActiveStep | in file TWizard.php, method TWizard::getActiveStep()
getActiveStepIndex | in file TWizard.php, method TWizard::getActiveStepIndex()
getActiveTabCssClass | in file TTabPanel.php, method TTabPanel::getActiveTabCssClass()
getActiveTabStyle | in file TTabPanel.php, method TTabPanel::getActiveTabStyle()
getActiveView in file TTabPanel.php, method TTabPanel::getActiveView()
Returns the currently active view.
getActiveView in file TAccordion.php, method TAccordion::getActiveView()
Returns the currently active view.
getActiveView | in file TMultiView.php, method TMultiView::getActiveView()
getActiveViewID in file TAccordion.php, method TAccordion::getActiveViewID()
Returns the ID of the active accordion view.
getActiveViewID in file TTabPanel.php, method TTabPanel::getActiveViewID()
Returns the ID of the active tab view.
getActiveViewIndex | in file TMultiView.php, method TMultiView::getActiveViewIndex()
getActiveViewIndex in file TTabPanel.php, method TTabPanel::getActiveViewIndex()
Returns the index of the active tab view.
getActiveViewIndex in file TAccordion.php, method TAccordion::getActiveViewIndex()
Returns the index of the active accordion view.
getAlign | in file TInlineFrame.php, method TInlineFrame::getAlign()
getAllowChildControls in file TOutputCache.php, method TOutputCache::getAllowChildControls()
Returns a value indicating whether body contents are allowed for this control.
getAllowCustomPaging | in file TDataBoundControl.php, method TDataBoundControl::getAllowCustomPaging()
getAllowInput in file TRatingList.php, method TRatingList::getAllowInput()
Wrapper for setReadOnly property.
getAllowPaging | in file TDataBoundControl.php, method TDataBoundControl::getAllowPaging()
getAllowReturn | in file TWizard.php, method TWizardStep::getAllowReturn()
getAllowSorting in file TDataGridColumn.php, method TDataGridColumn::getAllowSorting()
Returns a value indicating whether this column allows sorting.
getAllowSorting | in file TDataGrid.php, method TDataGrid::getAllowSorting()
getAlternateText | in file TImageMap.php, method THotSpot::getAlternateText()
getAlternateText | in file TImage.php, method TImage::getAlternateText()
getAlternatingItemRenderer | in file TRepeater.php, method TRepeater::getAlternatingItemRenderer()
getAlternatingItemRenderer | in file TDataList.php, method TDataList::getAlternatingItemRenderer()
getAlternatingItemStyle | in file TDataList.php, method TDataList::getAlternatingItemStyle()
getAlternatingItemStyle | in file TDataGrid.php, method TDataGrid::getAlternatingItemStyle()
getAlternatingItemTemplate | in file TRepeater.php, method TRepeater::getAlternatingItemTemplate()
getAlternatingItemTemplate | in file TDataList.php, method TDataList::getAlternatingItemTemplate()
getAnimationDuration | in file TAccordion.php, method TAccordion::getAnimationDuration()
getAppendDataBoundItems | in file TListControl.php, method TListControl::getAppendDataBoundItems()
getAssetUrl | in file TRatingList.php, method TRatingList::getAssetUrl()
getAssetUrl | in file TDatePicker.php, method TDatePicker::getAssetUrl()
getAssetUrl | in file TColorPicker.php, method TColorPicker::getAssetUrl()
getAttribute | in file TListItem.php, method TListItem::getAttribute()
getAttribute | in file TImageMap.php, method THotSpot::getAttribute()
getAttributes in file TImageMap.php, method THotSpot::getAttributes()
Returns the list of custom attributes.
getAttributes | in file TListItem.php, method TListItem::getAttributes()
getAutoColumns | in file TDataGrid.php, method TDataGrid::getAutoColumns()
getAutoCompleteType | in file TTextBox.php, method TTextBox::getAutoCompleteType()
getAutoGenerateColumnName | in file TDataGrid.php, method TDataGrid::getAutoGenerateColumnName()
getAutoGenerateColumns | in file TDataGrid.php, method TDataGrid::getAutoGenerateColumns()
getAutoHide | in file TKeyboard.php, method TKeyboard::getAutoHide()
getAutoPostBack | in file TCheckBox.php, method TCheckBox::getAutoPostBack()
getAutoPostBack | in file TSlider.php, method TSlider::getAutoPostBack()
getAutoPostBack | in file THtmlArea.php, method THtmlArea::getAutoPostBack()
getAutoPostBack | in file TTextBox.php, method TTextBox::getAutoPostBack()
getAutoPostBack | in file TListControl.php, method TListControl::getAutoPostBack()
getAutoSwitch | in file TTabPanel.php, method TTabPanel::getAutoSwitch()
getAutoTrim | in file TTextBox.php, method TTextBox::getAutoTrim()
getAutoUpdate in file TValidationSummary.php, method TValidationSummary::getAutoUpdate()
Gets the auto-update for this summary.
getAvailablePlugins in file THtmlArea.php, method THtmlArea::getAvailablePlugins()
Returns a list of plugins to be loaded.
getAvailableThemes | in file THtmlArea.php, method THtmlArea::getAvailableThemes()
getBackColor | in file TWebControl.php, method TWebControl::getBackColor()
getBackColor | in file TStyle.php, method TStyle::getBackColor()
getBackImageUrl | in file TTable.php, method TTable::getBackImageUrl()
getBackImageUrl | in file TPanelStyle.php, method TPanelStyle::getBackImageUrl()
getBackImageUrl | in file TStyle.php, method TTableStyle::getBackImageUrl()
getBackImageUrl | in file TPanel.php, method TPanel::getBackImageUrl()
getBackImageUrl | in file TDataGrid.php, method TDataGrid::getBackImageUrl()
getBaseCacheKey | in file TOutputCache.php, method TOutputCache::getBaseCacheKey()
getBold | in file TFont.php, method TFont::getBold()
getBorderCollapse | in file TStyle.php, method TTableStyle::getBorderCollapse()
getBorderColor | in file TStyle.php, method TStyle::getBorderColor()
getBorderColor | in file TWebControl.php, method TWebControl::getBorderColor()
getBorderStyle | in file TWebControl.php, method TWebControl::getBorderStyle()
getBorderStyle | in file TStyle.php, method TStyle::getBorderStyle()
getBorderWidth | in file TStyle.php, method TStyle::getBorderWidth()
getBorderWidth | in file TWebControl.php, method TWebControl::getBorderWidth()
getBottom | in file TImageMap.php, method TRectangleHotSpot::getBottom()
getBottomPager | in file TDataGrid.php, method TDataGrid::getBottomPager()
getBulletImageUrl | in file TBulletedList.php, method TBulletedList::getBulletImageUrl()
getBulletStyle | in file TBulletedList.php, method TBulletedList::getBulletStyle()
getButtonImageUrl | in file TDatePicker.php, method TDatePicker::getButtonImageUrl()
getButtonText | in file TDatePicker.php, method TDatePicker::getButtonText()
getButtonText | in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::getButtonText()
getButtonType | in file TButtonColumn.php, method TButtonColumn::getButtonType()
getButtonType | in file TEditCommandColumn.php, method TEditCommandColumn::getButtonType()
getButtonType | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getButtonType()
getButtonType | in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::getButtonType()
getButtonType | in file TButton.php, method TButton::getButtonType()
getButtonType | in file TPager.php, method TPager::getButtonType()
getCacheDependency in file TOutputCache.php, method TOutputCache::getCacheDependency()
Returns the dependency of the data to be cached.
getCacheKey | in file TOutputCache.php, method TOutputCache::getCacheKey()
getCacheKey | in file TOutputCache.php, method TOutputCacheCalculateKeyEventParameter::getCacheKey()
getCacheModuleID | in file TOutputCache.php, method TOutputCache::getCacheModuleID()
getCacheTime | in file TOutputCache.php, method TOutputCacheCheckDependencyEventParameter::getCacheTime()
getCacheTime | in file TOutputCache.php, method TOutputCache::getCacheTime()
getCachingPostBack | in file TOutputCache.php, method TOutputCache::getCachingPostBack()
getCalendarStyle | in file TDatePicker.php, method TDatePicker::getCalendarStyle()
getCancelButton | in file TWizard.php, method TWizardNavigationContainer::getCancelButton()
getCancelButtonStyle | in file TWizard.php, method TWizard::getCancelButtonStyle()
getCancelButtonText | in file TColorPicker.php, method TColorPicker::getCancelButtonText()
getCancelDestinationUrl | in file TWizard.php, method TWizard::getCancelDestinationUrl()
getCancelImageUrl | in file TEditCommandColumn.php, method TEditCommandColumn::getCancelImageUrl()
getCancelNavigation | in file TWizard.php, method TWizardNavigationEventParameter::getCancelNavigation()
getCancelText | in file TEditCommandColumn.php, method TEditCommandColumn::getCancelText()
getCanDelete | in file TDataSourceView.php, method TDataSourceView::getCanDelete()
getCanGetRowCount | in file TDataSourceView.php, method TDataSourceView::getCanGetRowCount()
getCanInsert | in file TDataSourceView.php, method TDataSourceView::getCanInsert()
getCanPage | in file TDataSourceView.php, method TDataSourceView::getCanPage()
getCanSort | in file TDataSourceView.php, method TDataSourceView::getCanSort()
getCanUpdate | in file TDataSourceView.php, method TDataSourceView::getCanUpdate()
getCaptchaControl | in file TReCaptchaValidator.php, method TReCaptchaValidator::getCaptchaControl()
getCaptchaControl | in file TCaptchaValidator.php, method TCaptchaValidator::getCaptchaControl()
getCaptchaScriptFile | in file TCaptcha.php, method TCaptcha::getCaptchaScriptFile()
getCaption | in file TTabPanel.php, method TTabView::getCaption()
getCaption | in file TTable.php, method TTable::getCaption()
getCaption | in file TAccordion.php, method TAccordionView::getCaption()
getCaption | in file TRatingList.php, method TRatingList::getCaption()
getCaption | in file TDataGrid.php, method TDataGrid::getCaption()
getCaption | in file TDataList.php, method TDataList::getCaption()
getCaption | in file TRepeatInfo.php, method TRepeatInfo::getCaption()
getCaptionAlign | in file TRepeatInfo.php, method TRepeatInfo::getCaptionAlign()
getCaptionAlign | in file TDataList.php, method TDataList::getCaptionAlign()
getCaptionAlign | in file TTable.php, method TTable::getCaptionAlign()
getCaptionAlign | in file TDataGrid.php, method TDataGrid::getCaptionAlign()
getCaptionControl | in file TRatingList.php, method TRatingList::getCaptionControl()
getCaptionControlID | in file TRatingList.php, method TRatingList::getCaptionControlID()
getCaptionID | in file TRatingList.php, method TRatingList::getCaptionID()
getCaseSensitive | in file TCaptcha.php, method TCaptcha::getCaseSensitive()
getCategoryText | in file TTableHeaderCell.php, method TTableHeaderCell::getCategoryText()
getCausesValidation | in file TButton.php, method TButton::getCausesValidation()
getCausesValidation | in file TButtonColumn.php, method TButtonColumn::getCausesValidation()
getCausesValidation | in file TEditCommandColumn.php, method TEditCommandColumn::getCausesValidation()
getCausesValidation | in file TListControl.php, method TListControl::getCausesValidation()
getCausesValidation | in file TCheckBox.php, method TCheckBox::getCausesValidation()
getCausesValidation | in file TTextBox.php, method TTextBox::getCausesValidation()
getCausesValidation | in file TImageMap.php, method THotSpot::getCausesValidation()
getCausesValidation | in file TImageButton.php, method TImageButton::getCausesValidation()
getCausesValidation | in file TLinkButton.php, method TLinkButton::getCausesValidation()
getCellPadding | in file TBaseDataList.php, method TBaseDataList::getCellPadding()
getCellPadding | in file TStyle.php, method TTableStyle::getCellPadding()
getCellPadding | in file TTable.php, method TTable::getCellPadding()
getCellPadding | in file TCheckBoxList.php, method TCheckBoxList::getCellPadding()
getCells | in file TTableRow.php, method TTableRow::getCells()
getCellSpacing | in file TStyle.php, method TTableStyle::getCellSpacing()
getCellSpacing | in file TCheckBoxList.php, method TCheckBoxList::getCellSpacing()
getCellSpacing | in file TTable.php, method TTable::getCellSpacing()
getCellSpacing | in file TBaseDataList.php, method TBaseDataList::getCellSpacing()
getChallengeFieldName | in file TReCaptcha.php, method TReCaptcha::getChallengeFieldName()
getChangingTokenBackground | in file TCaptcha.php, method TCaptcha::getChangingTokenBackground()
getCharset | in file TRangeValidator.php, method TRangeValidator::getCharset()
getChecked | in file TCheckBox.php, method TCheckBox::getChecked()
getCheckMXRecord | in file TEmailAddressValidator.php, method TEmailAddressValidator::getCheckMXRecord()
getClientClassName in file TEmailAddressValidator.php, method TEmailAddressValidator::getClientClassName()
Gets the name of the javascript class responsible for performing validation for this control.
getClientClassName in file TLinkButton.php, method TLinkButton::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file THtmlArea.php, method THtmlArea::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TRequiredFieldValidator.php, method TRequiredFieldValidator::getClientClassName()
Gets the name of the javascript class responsible for performing validation for this control.
getClientClassName in file TRadioButtonList.php, method TRadioButtonList::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TImageMap.php, method TImageMap::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TTextBox.php, method TTextBox::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TImageButton.php, method TImageButton::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TRadioButton.php, method TRadioButton::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TListBox.php, method TListBox::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TRangeValidator.php, method TRangeValidator::getClientClassName()
Gets the name of the javascript class responsible for performing validation for this control.
getClientClassName in file TDataTypeValidator.php, method TDataTypeValidator::getClientClassName()
Gets the name of the javascript class responsible for performing validation for this control.
getClientClassName in file TRatingList.php, method TRatingList::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TSlider.php, method TSlider::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TReCaptchaValidator.php, method TReCaptchaValidator::getClientClassName()
Gets the name of the javascript class responsible for performing validation for this control.
getClientClassName in file TRegularExpressionValidator.php, method TRegularExpressionValidator::getClientClassName()
Gets the name of the javascript class responsible for performing validation for this control.
getClientClassName in file TDropDownList.php, method TDropDownList::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName | in file TKeyboard.php, method TKeyboard::getClientClassName()
getClientClassName in file TListControlValidator.php, method TListControlValidator::getClientClassName()
Gets the name of the javascript class responsible for performing validation for this control.
getClientClassName in file TCustomValidator.php, method TCustomValidator::getClientClassName()
Gets the name of the javascript class responsible for performing validation for this control.
getClientClassName in file TBaseValidator.php, method TBaseValidator::getClientClassName()
Gets the name of the javascript class responsible for performing validation for this control.
getClientClassName in file TCheckBoxList.php, method TCheckBoxList::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TListControl.php, method TListControl::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TAccordion.php, method TAccordion::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TCompareValidator.php, method TCompareValidator::getClientClassName()
Gets the name of the javascript class responsible for performing validation for this control.
getClientClassName in file TColorPicker.php, method TColorPicker::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TCaptchaValidator.php, method TCaptchaValidator::getClientClassName()
Gets the name of the javascript class responsible for performing validation for this control.
getClientClassName in file TCheckBox.php, method TCheckBox::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TTabPanel.php, method TTabPanel::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TBulletedList.php, method TBulletedList::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName in file TButton.php, method TButton::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientOptions | in file TTabPanel.php, method TTabPanel::getClientOptions()
getClientOptions | in file TKeyboard.php, method TKeyboard::getClientOptions()
getClientOptions | in file TAccordion.php, method TAccordion::getClientOptions()
getClientScriptOptions in file TCompareValidator.php, method TCompareValidator::getClientScriptOptions()
Returns an array of javascript validator options.
getClientScriptOptions in file TRangeValidator.php, method TRangeValidator::getClientScriptOptions()
Returns an array of javascript validator options.
getClientScriptOptions in file TDataTypeValidator.php, method TDataTypeValidator::getClientScriptOptions()
Returns an array of javascript validator options.
getClientScriptOptions in file TValidationSummary.php, method TValidationSummary::getClientScriptOptions()
Get a list of options for the client-side javascript validation summary.
getClientScriptOptions in file TBaseValidator.php, method TBaseValidator::getClientScriptOptions()
Returns an array of javascript validator options.
getClientScriptOptions in file TRegularExpressionValidator.php, method TRegularExpressionValidator::getClientScriptOptions()
Returns an array of javascript validator options.
getClientScriptOptions | in file TReCaptchaValidator.php, method TReCaptchaValidator::getClientScriptOptions()
getClientScriptOptions in file TCaptchaValidator.php, method TCaptchaValidator::getClientScriptOptions()
Returns an array of javascript validator options.
getClientScriptOptions in file TRequiredFieldValidator.php, method TRequiredFieldValidator::getClientScriptOptions()
Returns an array of javascript validator options.
getClientScriptOptions in file TListControlValidator.php, method TListControlValidator::getClientScriptOptions()
Returns an array of javascript validator options.
getClientScriptOptions in file TCustomValidator.php, method TCustomValidator::getClientScriptOptions()
Returns an array of javascript validator options.
getClientSide | in file TValidationSummary.php, method TValidationSummary::getClientSide()
getClientSide in file TSlider.php, method TSlider::getClientSide()
Gets the TSliderClientScript to set the TSlider event handlers.
getClientSide | in file TColorPicker.php, method TColorPicker::getClientSide()
getClientSide in file TBaseValidator.php, method TBaseValidator::getClientSide()
Gets the TValidatorClientSide that allows modification of the client- side validator events.
getClientSide in file TDatePicker.php, method TDatePicker::getClientSide()
Gets the TDatePickerClientScript to set the TDatePicker event handlers.
getClientSideOptions | in file TReCaptcha.php, method TReCaptcha::getClientSideOptions()
getClientSidePatternModifiers | in file TRegularExpressionValidator.php, method TRegularExpressionValidator::getClientSidePatternModifiers()
getClientValidationFunction | in file TCustomValidator.php, method TCustomValidator::getClientValidationFunction()
getColorPickerStyle | in file TColorPicker.php, method TColorPicker::getColorPickerStyle()
getColumns | in file TDataGrid.php, method TDataGrid::getColumns()
getColumns | in file TTextBox.php, method TTextBox::getColumns()
getColumnSpan | in file TTableCell.php, method TTableCell::getColumnSpan()
getCommandName | in file TButtonColumn.php, method TButtonColumn::getCommandName()
getCommandName | in file TButton.php, method TButton::getCommandName()
getCommandName | in file TLinkButton.php, method TLinkButton::getCommandName()
getCommandName | in file TImageButton.php, method TImageButton::getCommandName()
getCommandParameter | in file TButton.php, method TButton::getCommandParameter()
getCommandParameter | in file TImageButton.php, method TImageButton::getCommandParameter()
getCommandParameter | in file TLinkButton.php, method TLinkButton::getCommandParameter()
getCommandSource | in file TDataGrid.php, method TDataGridSortCommandEventParameter::getCommandSource()
getCommandSource | in file TRepeater.php, method TRepeaterCommandEventParameter::getCommandSource()
getCommandSource | in file TDataGrid.php, method TDataGridCommandEventParameter::getCommandSource()
getCommandSource | in file TDataList.php, method TDataListCommandEventParameter::getCommandSource()
getCommandSource | in file TDataGrid.php, method TDataGridPageChangedEventParameter::getCommandSource()
getCommandSource | in file TPager.php, method TPagerPageChangedEventParameter::getCommandSource()
getComparisonValues in file TCompareValidator.php, method TCompareValidator::getComparisonValues()
Parse the pair of values into the appropriate value type.
getCompleteButton | in file TWizard.php, method TWizardNavigationContainer::getCompleteButton()
getCompressionOptions | in file THtmlArea.php, method THtmlArea::getCompressionOptions()
getCondition | in file TConditional.php, method TConditional::getCondition()
getContent | in file THead.php, method TMetaTag::getContent()
getContentCached | in file TOutputCache.php, method TOutputCache::getContentCached()
getContentTemplate | in file TWizard.php, method TTemplatedWizardStep::getContentTemplate()
getContinueBuffering | in file TFlushOutput.php, method TFlushOutput::getContinueBuffering()
getControlCssClass | in file TBaseValidator.php, method TBaseValidator::getControlCssClass()
getControlToCompare | in file TCompareValidator.php, method TCompareValidator::getControlToCompare()
getControlToPaginate | in file TPager.php, method TPager::getControlToPaginate()
getControlToValidate | in file TBaseValidator.php, method TBaseValidator::getControlToValidate()
getCoordinates | in file TImageMap.php, method TCircleHotSpot::getCoordinates()
getCoordinates | in file TImageMap.php, method TPolygonHotSpot::getCoordinates()
getCoordinates | in file TImageMap.php, method TRectangleHotSpot::getCoordinates()
getCoordinates | in file TImageMap.php, method THotSpot::getCoordinates()
getCssClass | in file TStyle.php, method TStyle::getCssClass()
getCssClass | in file TAccordion.php, method TAccordion::getCssClass()
getCssClass | in file TWebControl.php, method TWebControl::getCssClass()
getCssClass | in file TTabPanel.php, method TTabPanel::getCssClass()
getCssUrl | in file TKeyboard.php, method TKeyboard::getCssUrl()
getCssUrl | in file TTabPanel.php, method TTabPanel::getCssUrl()
getCssUrl | in file TAccordion.php, method TAccordion::getCssUrl()
getCssUrl | in file TSlider.php, method TSlider::getCssUrl()
getCulturalOptions in file TDatePicker.php, method TDatePicker::getCulturalOptions()
Get javascript localization options, e.g. month and weekday names.
getCulture in file THtmlArea.php, method THtmlArea::getCulture()
Gets the current culture.
getCulture in file TDatePicker.php, method TDatePicker::getCulture()
Gets the current culture.
getCurrentCulture | in file TDatePicker.php, method TDatePicker::getCurrentCulture()
getCurrentPageIndex | in file TPager.php, method TPager::getCurrentPageIndex()
getCurrentPageIndex | in file TDataBoundControl.php, method TDataBoundControl::getCurrentPageIndex()
getCurrentStepIndex | in file TWizard.php, method TWizardNavigationEventParameter::getCurrentStepIndex()
getCustomPluginPath | in file THtmlArea.php, method THtmlArea::getCustomPluginPath()
getCustomStyle | in file TStyle.php, method TStyle::getCustomStyle()
getCustomTranslations | in file TReCaptcha.php, method TReCaptcha::getCustomTranslations()
getData | in file TDataRenderer.php, method TDataRenderer::getData()
getData in file TLinkButton.php, method TLinkButton::getData()
Returns the caption of the button.
getData in file TLiteral.php, method TLiteral::getData()
Returns the static text of the TLiteral.
getData in file TButton.php, method TButton::getData()
Returns the caption of the button.
getData in file TCheckBox.php, method TCheckBox::getData()
Returns the value indicating whether the checkbox is checked.
getData in file THyperLink.php, method THyperLink::getData()
Returns the URL to link to when the THyperLink component is clicked.
getData in file TDatePicker.php, method TDatePicker::getData()
Returns the timestamp selected by the user.
getData in file TTableCell.php, method TTableCell::getData()
Returns the text content of the table cell.
getData | in file TDataList.php, method TDataListItem::getData()
getData in file TImage.php, method TImage::getData()
Returns the URL of the image file.
getData in file TTextBox.php, method TTextBox::getData()
Returns the text content of the TTextBox control.
getData | in file TDataGrid.php, method TDataGridItem::getData()
getData in file TInlineFrame.php, method TInlineFrame::getData()
Returns the URL that this iframe will load content from This method is required by IDataRenderer.
getData in file TListControl.php, method TListControl::getData()
Returns the value of the selected item with the lowest cardinal index.
getData in file TSlider.php, method TSlider::getData()
Returns the value of the TSlider control.
getData in file TLabel.php, method TLabel::getData()
Returns the text value of the label.
getData | in file TRepeater.php, method TRepeaterItem::getData()
getData in file THiddenField.php, method THiddenField::getData()
Returns the value of the hidden field.
getDataChanged in file TImageButton.php, method TImageButton::getDataChanged()
Returns a value indicating whether postback has caused the control data change.
getDataChanged in file TTextBox.php, method TTextBox::getDataChanged()
Returns a value indicating whether postback has caused the control data change.
getDataChanged in file TSlider.php, method TSlider::getDataChanged()
Returns a value indicating whether postback has caused the control data change.
getDataChanged in file TCheckBoxList.php, method TCheckBoxList::getDataChanged()
Returns a value indicating whether postback has caused the control data change.
getDataChanged in file TDropDownList.php, method TDropDownList::getDataChanged()
Returns a value indicating whether postback has caused the control data change.
getDataChanged in file TListBox.php, method TListBox::getDataChanged()
Returns a value indicating whether postback has caused the control data change.
getDataChanged in file TFileUpload.php, method TFileUpload::getDataChanged()
Returns a value indicating whether postback has caused the control data change.
getDataChanged in file TTabPanel.php, method TTabPanel::getDataChanged()
Returns a value indicating whether postback has caused the control data change.
getDataChanged in file TCheckBox.php, method TCheckBox::getDataChanged()
Returns a value indicating whether postback has caused the control data change.
getDataChanged in file THiddenField.php, method THiddenField::getDataChanged()
Returns a value indicating whether postback has caused the control data change.
getDataChanged in file TAccordion.php, method TAccordion::getDataChanged()
Returns a value indicating whether postback has caused the control data change.
getDataField | in file TBoundColumn.php, method TBoundColumn::getDataField()
getDataField | in file TCheckBoxColumn.php, method TCheckBoxColumn::getDataField()
getDataField | in file TLiteralColumn.php, method TLiteralColumn::getDataField()
getDataFieldValue in file TRepeater.php, method TRepeater::getDataFieldValue()
Returns the value of the data at the specified field.
getDataFieldValue in file TBaseDataList.php, method TBaseDataList::getDataFieldValue()
Returns the value of the data at the specified field.
getDataFieldValue in file TDataGridColumn.php, method TDataGridColumn::getDataFieldValue()
Fetches the value of the data at the specified field.
getDataFormatString | in file TBoundColumn.php, method TBoundColumn::getDataFormatString()
getDataFormatString | in file TLiteralColumn.php, method TLiteralColumn::getDataFormatString()
getDataGrid | in file TDataGrid.php, method TDataGridPager::getDataGrid()
getDataGroupField | in file TListControl.php, method TListControl::getDataGroupField()
getDataImageUrlField | in file TButtonColumn.php, method TButtonColumn::getDataImageUrlField()
getDataImageUrlFormatString | in file TButtonColumn.php, method TButtonColumn::getDataImageUrlFormatString()
getDataItem in file TDataList.php, method TDataListItem::getDataItem()
This property is deprecated since v3.1.0.
getDataItem in file TRepeater.php, method TRepeaterItem::getDataItem()
This property is deprecated since v3.1.0.
getDataItem in file TDataGrid.php, method TDataGridItem::getDataItem()
This property is deprecated since v3.1.0.
getDataKeyField | in file TRepeater.php, method TRepeater::getDataKeyField()
getDataKeyField | in file TBaseDataList.php, method TBaseDataList::getDataKeyField()
getDataKeys | in file TRepeater.php, method TRepeater::getDataKeys()
getDataKeys | in file TBaseDataList.php, method TBaseDataList::getDataKeys()
getDataMember | in file TDataBoundControl.php, method TDataBoundControl::getDataMember()
getDataNavigateUrlField | in file THyperLinkColumn.php, method THyperLinkColumn::getDataNavigateUrlField()
getDataNavigateUrlFormatString | in file THyperLinkColumn.php, method THyperLinkColumn::getDataNavigateUrlFormatString()
getDataSource | in file TDataBoundControl.php, method TDataBoundControl::getDataSource()
getDataSource | in file TDataSourceView.php, method TDataSourceView::getDataSource()
getDataSourceID | in file TDataBoundControl.php, method TDataBoundControl::getDataSourceID()
getDataSourceIndex | in file TDataGrid.php, method TDataGridItem::getDataSourceIndex()
getDataSourceView | in file TDataBoundControl.php, method TDataBoundControl::getDataSourceView()
getDataTextField | in file TDropDownListColumn.php, method TDropDownListColumn::getDataTextField()
getDataTextField | in file TListControl.php, method TListControl::getDataTextField()
getDataTextField | in file THyperLinkColumn.php, method THyperLinkColumn::getDataTextField()
getDataTextField | in file TButtonColumn.php, method TButtonColumn::getDataTextField()
getDataTextFormatString | in file TListControl.php, method TListControl::getDataTextFormatString()
getDataTextFormatString | in file TDropDownListColumn.php, method TDropDownListColumn::getDataTextFormatString()
getDataTextFormatString | in file THyperLinkColumn.php, method THyperLinkColumn::getDataTextFormatString()
getDataTextFormatString | in file TButtonColumn.php, method TButtonColumn::getDataTextFormatString()
getDataType | in file TCompareValidator.php, method TCompareValidator::getDataType()
getDataType | in file TDataTypeValidator.php, method TDataTypeValidator::getDataType()
getDataType | in file TRangeValidator.php, method TRangeValidator::getDataType()
getDataValueField | in file TListControl.php, method TListControl::getDataValueField()
getDataValueField | in file TDropDownListColumn.php, method TDropDownListColumn::getDataValueField()
getDate | in file TDatePicker.php, method TDatePicker::getDate()
getDateFormat | in file TRangeValidator.php, method TRangeValidator::getDateFormat()
getDateFormat | in file TDataTypeValidator.php, method TDataTypeValidator::getDateFormat()
getDateFormat | in file TCompareValidator.php, method TCompareValidator::getDateFormat()
getDateFormat | in file TDatePicker.php, method TDatePicker::getDateFormat()
getDateFromPostData in file TDatePicker.php, method TDatePicker::getDateFromPostData()
Loads date from drop down list data.
getDatePickerButtonID in file TDatePicker.php, method TDatePicker::getDatePickerButtonID()
Gets the ID for the date picker trigger button.
getDatePickerOptions in file TDatePicker.php, method TDatePicker::getDatePickerOptions()
Get javascript date picker options.
getDecorator | in file TWebControl.php, method TWebControl::getDecorator()
getDefaultButton | in file TPanel.php, method TPanel::getDefaultButton()
getDefaultTagName in file THtmlElement.php, method THtmlElement::getDefaultTagName()
This is the default tag when no other is specified
getDefaultTagName | in file THeader2.php, method THeader2::getDefaultTagName()
getDefaultTagName | in file THeader1.php, method THeader1::getDefaultTagName()
getDefaultTagName | in file THeader4.php, method THeader4::getDefaultTagName()
getDefaultTagName | in file THeader3.php, method THeader3::getDefaultTagName()
getDefaultTagName | in file THeader5.php, method THeader5::getDefaultTagName()
getDefaultTagName | in file THeader6.php, method THeader6::getDefaultTagName()
getDescriptionUrl | in file TInlineFrame.php, method TInlineFrame::getDescriptionUrl()
getDescriptionUrl | in file TImage.php, method TImage::getDescriptionUrl()
getDirection | in file TSlider.php, method TSlider::getDirection()
getDirection | in file TPanelStyle.php, method TPanelStyle::getDirection()
getDirection | in file TPanel.php, method TPanel::getDirection()
getDisplay | in file TBaseValidator.php, method TBaseValidator::getDisplay()
getDisplay | in file TWebControl.php, method TWebControl::getDisplay()
getDisplay | in file TValidationSummary.php, method TValidationSummary::getDisplay()
getDisplayMode | in file TBulletedList.php, method TBulletedList::getDisplayMode()
getDisplayMode | in file TValidationSummary.php, method TValidationSummary::getDisplayMode()
getDisplayStyle | in file TStyle.php, method TStyle::getDisplayStyle()
getDocumentContent | in file TXmlTransform.php, method TXmlTransform::getDocumentContent()
getDocumentPath | in file TXmlTransform.php, method TXmlTransform::getDocumentPath()
getDropDownDayOptions | in file TDatePicker.php, method TDatePicker::getDropDownDayOptions()
getDuration | in file TOutputCache.php, method TOutputCache::getDuration()
getEditImageUrl | in file TEditCommandColumn.php, method TEditCommandColumn::getEditImageUrl()
getEditItem | in file TDataGrid.php, method TDataGrid::getEditItem()
getEditItem | in file TDataList.php, method TDataList::getEditItem()
getEditItemIndex | in file TDataGrid.php, method TDataGrid::getEditItemIndex()
getEditItemIndex | in file TDataList.php, method TDataList::getEditItemIndex()
getEditItemRenderer | in file TTemplateColumn.php, method TTemplateColumn::getEditItemRenderer()
getEditItemRenderer | in file TBoundColumn.php, method TBoundColumn::getEditItemRenderer()
getEditItemRenderer | in file TDataList.php, method TDataList::getEditItemRenderer()
getEditItemStyle | in file TDataGrid.php, method TDataGrid::getEditItemStyle()
getEditItemStyle | in file TDataList.php, method TDataList::getEditItemStyle()
getEditItemTemplate | in file TDataList.php, method TDataList::getEditItemTemplate()
getEditItemTemplate | in file TTemplateColumn.php, method TTemplateColumn::getEditItemTemplate()
getEditorOptions in file THtmlArea.php, method THtmlArea::getEditorOptions()
Default editor options gives basic tool bar only.
getEditText | in file TEditCommandColumn.php, method TEditCommandColumn::getEditText()
getEmptyRenderer | in file TDataList.php, method TDataList::getEmptyRenderer()
getEmptyRenderer | in file TRepeater.php, method TRepeater::getEmptyRenderer()
getEmptyTemplate | in file TDataList.php, method TDataList::getEmptyTemplate()
getEmptyTemplate | in file TDataGrid.php, method TDataGrid::getEmptyTemplate()
getEmptyTemplate | in file TRepeater.php, method TRepeater::getEmptyTemplate()
getEnableCellGrouping | in file TDataGridColumn.php, method TDataGridColumn::getEnableCellGrouping()
getEnableClientScript | in file TListControl.php, method TListControl::getEnableClientScript()
getEnableClientScript | in file TLinkButton.php, method TLinkButton::getEnableClientScript()
getEnableClientScript | in file TTextBox.php, method TTextBox::getEnableClientScript()
getEnableClientScript | in file TValidationSummary.php, method TValidationSummary::getEnableClientScript()
getEnableClientScript | in file TRadioButton.php, method TRadioButton::getEnableClientScript()
getEnableClientScript | in file TCheckBox.php, method TCheckBox::getEnableClientScript()
getEnableClientScript | in file TReCaptchaValidator.php, method TReCaptchaValidator::getEnableClientScript()
getEnableClientScript | in file TImageButton.php, method TImageButton::getEnableClientScript()
getEnableClientScript | in file TBaseValidator.php, method TBaseValidator::getEnableClientScript()
getEnableClientScript | in file TButton.php, method TButton::getEnableClientScript()
getEnableCompression | in file THtmlArea.php, method THtmlArea::getEnableCompression()
getEnableCopyCode | in file TTextHighlighter.php, method TTextHighlighter::getEnableCopyCode()
getEnabled | in file TListItem.php, method TListItem::getEnabled()
getEnableTheming | in file THiddenField.php, method THiddenField::getEnableTheming()
getEnableTheming | in file TDataSourceControl.php, method TDataSourceControl::getEnableTheming()
getEnableVisualEdit | in file THtmlArea.php, method THtmlArea::getEnableVisualEdit()
getEncode | in file TLiteralColumn.php, method TLiteralColumn::getEncode()
getEncode | in file TLiteral.php, method TLiteral::getEncode()
getEnsureId | in file TWebControl.php, method TWebControl::getEnsureId()
getErrorCode in file TFileUpload.php, method TFileUpload::getErrorCode()
Returns an error code describing the status of this file uploading.
getErrorMessage | in file TBaseValidator.php, method TBaseValidator::getErrorMessage()
getErrorMessages in file TValidationSummary.php, method TValidationSummary::getErrorMessages()
Get the list of validation error messages.
getExpression | in file TExpression.php, method TExpression::getExpression()
getFalseTemplate | in file TConditional.php, method TConditional::getFalseTemplate()
getFileName | in file TFileUpload.php, method TFileUpload::getFileName()
getFileSize | in file TFileUpload.php, method TFileUpload::getFileSize()
getFileType | in file TFileUpload.php, method TFileUpload::getFileType()
getFinishCompleteButtonStyle | in file TWizard.php, method TWizard::getFinishCompleteButtonStyle()
getFinishDestinationUrl | in file TWizard.php, method TWizard::getFinishDestinationUrl()
getFinishNavigation | in file TWizard.php, method TWizard::getFinishNavigation()
getFinishNavigationTemplate | in file TWizard.php, method TWizard::getFinishNavigationTemplate()
getFinishPreviousButtonStyle | in file TWizard.php, method TWizard::getFinishPreviousButtonStyle()
getFirstBulletNumber | in file TBulletedList.php, method TBulletedList::getFirstBulletNumber()
getFirstDayOfWeek | in file TDatePicker.php, method TDatePicker::getFirstDayOfWeek()
getFirstPageImageUrl | in file TPager.php, method TPager::getFirstPageImageUrl()
getFirstPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getFirstPageText()
getFirstPageText | in file TPager.php, method TPager::getFirstPageText()
getFlushScriptFiles | in file TClientScript.php, method TClientScript::getFlushScriptFiles()
getFocusElementID in file TBaseValidator.php, method TBaseValidator::getFocusElementID()
Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
getFocusOnError | in file TBaseValidator.php, method TBaseValidator::getFocusOnError()
getFont | in file TStyle.php, method TStyle::getFont()
getFont | in file TWebControl.php, method TWebControl::getFont()
getFontFile | in file TCaptcha.php, method TCaptcha::getFontFile()
getFooter | in file TRepeater.php, method TRepeater::getFooter()
getFooter | in file TDataGrid.php, method TDataGrid::getFooter()
getFooter | in file TDataList.php, method TDataList::getFooter()
getFooterRenderer | in file TDataList.php, method TDataList::getFooterRenderer()
getFooterRenderer | in file TRepeater.php, method TRepeater::getFooterRenderer()
getFooterRenderer | in file TDataGridColumn.php, method TDataGridColumn::getFooterRenderer()
getFooterStyle | in file TDataList.php, method TDataList::getFooterStyle()
getFooterStyle | in file TDataGridColumn.php, method TDataGridColumn::getFooterStyle()
getFooterStyle | in file TDataGrid.php, method TDataGrid::getFooterStyle()
getFooterTemplate | in file TTemplateColumn.php, method TTemplateColumn::getFooterTemplate()
getFooterTemplate | in file TRepeater.php, method TRepeater::getFooterTemplate()
getFooterTemplate | in file TDataList.php, method TDataList::getFooterTemplate()
getFooterText | in file TDataGridColumn.php, method TDataGridColumn::getFooterText()
getForControl | in file TLabel.php, method TLabel::getForControl()
getForControl | in file TKeyboard.php, method TKeyboard::getForControl()
getForeColor | in file TStyle.php, method TStyle::getForeColor()
getForeColor | in file TWebControl.php, method TWebControl::getForeColor()
getFrameUrl | in file TInlineFrame.php, method TInlineFrame::getFrameUrl()
getFromYear | in file TDatePicker.php, method TDatePicker::getFromYear()
getGridLines | in file TBaseDataList.php, method TBaseDataList::getGridLines()
getGridLines | in file TTable.php, method TTable::getGridLines()
getGridLines | in file TStyle.php, method TTableStyle::getGridLines()
getGroupingText | in file TPanel.php, method TPanel::getGroupingText()
getGroupName | in file TRadioButton.php, method TRadioButton::getGroupName()
getHalfRatingInterval | in file TRatingList.php, method TRatingList::getHalfRatingInterval()
getHasAttributes | in file TListItem.php, method TListItem::getHasAttributes()
getHasAttributes | in file TImageMap.php, method THotSpot::getHasAttributes()
getHasFile | in file TFileUpload.php, method TFileUpload::getHasFile()
getHasFooter in file TDataList.php, method TDataList::getHasFooter()
Returns a value indicating whether this control contains footer item.
getHasFooter | in file TRepeatInfo.php, method IRepeatInfoUser::getHasFooter()
getHasFooter in file TCheckBoxList.php, method TCheckBoxList::getHasFooter()
Returns a value indicating whether this control contains footer item.
getHasHeader in file TDataList.php, method TDataList::getHasHeader()
Returns a value indicating whether this control contains header item.
getHasHeader in file TCheckBoxList.php, method TCheckBoxList::getHasHeader()
Returns a value indicating whether this control contains header item.
getHasHeader | in file TRepeatInfo.php, method IRepeatInfoUser::getHasHeader()
getHasItems | in file TListControl.php, method TListControl::getHasItems()
getHasSeparators in file TDataList.php, method TDataList::getHasSeparators()
Returns a value indicating whether this control contains separator items.
getHasSeparators | in file TRepeatInfo.php, method IRepeatInfoUser::getHasSeparators()
getHasSeparators in file TCheckBoxList.php, method TCheckBoxList::getHasSeparators()
Returns a value indicating whether this control contains separator items.
getHasStyle | in file TDataListItemRenderer.php, method TDataListItemRenderer::getHasStyle()
getHasStyle | in file TWebControl.php, method TWebControl::getHasStyle()
getHeader | in file TWizard.php, method TWizard::getHeader()
getHeader | in file TDataGrid.php, method TDataGrid::getHeader()
getHeader | in file TRepeater.php, method TRepeater::getHeader()
getHeader | in file TDataList.php, method TDataList::getHeader()
getHeaderCssClass | in file TAccordion.php, method TAccordion::getHeaderCssClass()
getHeaderImageUrl | in file TDataGridColumn.php, method TDataGridColumn::getHeaderImageUrl()
getHeaderRenderer | in file TDataList.php, method TDataList::getHeaderRenderer()
getHeaderRenderer | in file TDataGridColumn.php, method TDataGridColumn::getHeaderRenderer()
getHeaderRenderer | in file TRepeater.php, method TRepeater::getHeaderRenderer()
getHeaderStyle | in file TWizard.php, method TWizard::getHeaderStyle()
getHeaderStyle | in file TDataGrid.php, method TDataGrid::getHeaderStyle()
getHeaderStyle | in file TDataList.php, method TDataList::getHeaderStyle()
getHeaderStyle | in file TAccordion.php, method TAccordion::getHeaderStyle()
getHeaderStyle | in file TDataGridColumn.php, method TDataGridColumn::getHeaderStyle()
getHeaderTemplate | in file TDataList.php, method TDataList::getHeaderTemplate()
getHeaderTemplate | in file TRepeater.php, method TRepeater::getHeaderTemplate()
getHeaderTemplate | in file TTextHighlighter.php, method TTextHighlighter::getHeaderTemplate()
getHeaderTemplate | in file TWizard.php, method TWizard::getHeaderTemplate()
getHeaderTemplate | in file TTemplateColumn.php, method TTemplateColumn::getHeaderTemplate()
getHeaderText | in file TValidationSummary.php, method TValidationSummary::getHeaderText()
getHeaderText | in file TWizard.php, method TWizard::getHeaderText()
getHeaderText | in file TDataGridColumn.php, method TDataGridColumn::getHeaderText()
getHeight | in file TWebControl.php, method TWebControl::getHeight()
getHeight | in file TStyle.php, method TStyle::getHeight()
getHistory | in file TWizard.php, method TWizard::getHistory()
getHorizontalAlign | in file TPanelStyle.php, method TPanelStyle::getHorizontalAlign()
getHorizontalAlign | in file TTableCell.php, method TTableCell::getHorizontalAlign()
getHorizontalAlign | in file TBaseDataList.php, method TBaseDataList::getHorizontalAlign()
getHorizontalAlign | in file TTable.php, method TTable::getHorizontalAlign()
getHorizontalAlign | in file TStyle.php, method TTableItemStyle::getHorizontalAlign()
getHorizontalAlign | in file TStyle.php, method TTableStyle::getHorizontalAlign()
getHorizontalAlign | in file TTableRow.php, method TTableRow::getHorizontalAlign()
getHorizontalAlign | in file TPanel.php, method TPanel::getHorizontalAlign()
getHotSpotMode | in file TImageMap.php, method THotSpot::getHotSpotMode()
getHotSpotMode | in file TImageMap.php, method TImageMap::getHotSpotMode()
getHotSpots | in file TImageMap.php, method TImageMap::getHotSpots()
getHttpEquiv | in file THead.php, method TMetaTag::getHttpEquiv()
getID | in file THead.php, method TMetaTag::getID()
getID | in file TDataGridColumn.php, method TDataGridColumn::getID()
getImageAlign | in file TImage.php, method TImage::getImageAlign()
getImageHeight | in file THyperLinkColumn.php, method THyperLinkColumn::getImageHeight()
getImageHeight | in file THyperLink.php, method THyperLink::getImageHeight()
getImageUrl | in file TImage.php, method TImage::getImageUrl()
getImageUrl | in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::getImageUrl()
getImageUrl | in file THyperLinkColumn.php, method THyperLinkColumn::getImageUrl()
getImageUrl | in file THyperLink.php, method THyperLink::getImageUrl()
getImageUrl | in file TButtonColumn.php, method TButtonColumn::getImageUrl()
getImageWidth | in file THyperLinkColumn.php, method THyperLinkColumn::getImageWidth()
getImageWidth | in file THyperLink.php, method THyperLink::getImageWidth()
getIndex | in file TBulletedList.php, method TBulletedListEventParameter::getIndex()
getInitialized | in file TDataBoundControl.php, method TDataBoundControl::getInitialized()
getInitialValue | in file TRequiredFieldValidator.php, method TRequiredFieldValidator::getInitialValue()
getInputAttributes | in file TCheckBox.php, method TCheckBox::getInputAttributes()
getInputMode | in file TDatePicker.php, method TDatePicker::getInputMode()
getIsDataBound | in file TDataBoundControl.php, method TDataBoundControl::getIsDataBound()
getIsDefaultButton | in file TLinkButton.php, method TLinkButton::getIsDefaultButton()
getIsDefaultButton | in file TImageButton.php, method TImageButton::getIsDefaultButton()
getIsDefaultButton | in file TButton.php, method TButton::getIsDefaultButton()
getIsEmpty | in file TFont.php, method TFont::getIsEmpty()
getIsFirstPage | in file TPager.php, method TPager::getIsFirstPage()
getIsLastPage | in file TPager.php, method TPager::getIsLastPage()
getIsMultiSelect | in file TListBox.php, method TListBox::getIsMultiSelect()
getIsMultiSelect | in file TListControl.php, method TListControl::getIsMultiSelect()
getIsMultiSelect | in file TCheckBoxList.php, method TCheckBoxList::getIsMultiSelect()
getIsMultiSelect | in file TRadioButtonList.php, method TRadioButtonList::getIsMultiSelect()
getIsMutated in file THtmlElement.php, method THtmlElement::getIsMutated()
This tells you if this TagName has deviated from the original
getIsTokenExpired | in file TCaptcha.php, method TCaptcha::getIsTokenExpired()
getIsValid in file TFileUpload.php, method TFileUpload::getIsValid()
Returns true if this control validated successfully.
getIsValid | in file TOutputCache.php, method TOutputCacheCheckDependencyEventParameter::getIsValid()
getIsValid | in file TBaseValidator.php, method TBaseValidator::getIsValid()
getIsValid | in file TCustomValidator.php, method TServerValidateEventParameter::getIsValid()
getIsValid in file TListBox.php, method TListBox::getIsValid()
Returns true if this control validated successfully.
getIsValid in file TTextBox.php, method TTextBox::getIsValid()
Returns true if this control validated successfully.
getIsValid in file TDropDownList.php, method TDropDownList::getIsValid()
Returns true if this control validated successfully.
getIsValid in file TCheckBox.php, method TCheckBox::getIsValid()
Returns true if this control validated successfully.
getIsValid in file THiddenField.php, method THiddenField::getIsValid()
Returns true if this control validated successfully.
getIsValid in file TReCaptcha.php, method TReCaptcha::getIsValid()
Returns true if this control validated successfully.
getIsValid in file TCheckBoxList.php, method TCheckBoxList::getIsValid()
Returns true if this control validated successfully.
getItalic | in file TFont.php, method TFont::getItalic()
getItem | in file TRepeater.php, method TRepeaterCommandEventParameter::getItem()
getItem | in file TDataList.php, method TDataListCommandEventParameter::getItem()
getItem | in file TDataGrid.php, method TDataGridItemEventParameter::getItem()
getItem | in file TDataGrid.php, method TDataGridCommandEventParameter::getItem()
getItem | in file TRepeater.php, method TRepeaterItemEventParameter::getItem()
getItem | in file TDataList.php, method TDataListItemEventParameter::getItem()
getItemCount | in file TRepeatInfo.php, method IRepeatInfoUser::getItemCount()
getItemCount | in file TDataGrid.php, method TDataGrid::getItemCount()
getItemCount | in file TListControl.php, method TListControl::getItemCount()
getItemCount | in file TDataList.php, method TDataList::getItemCount()
getItemIndex in file TRepeater.php, method TRepeaterItem::getItemIndex()
Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
getItemIndex | in file TDataGrid.php, method TDataGridItem::getItemIndex()
getItemIndex | in file TDataList.php, method TDataListItem::getItemIndex()
getItemIndex in file TDataBoundControl.php, method IItemDataRenderer::getItemIndex()
Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
getItemIndex in file TItemDataRenderer.php, method TItemDataRenderer::getItemIndex()
Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
getItemRenderer | in file TDataList.php, method TDataList::getItemRenderer()
getItemRenderer | in file TTemplateColumn.php, method TTemplateColumn::getItemRenderer()
getItemRenderer | in file TBoundColumn.php, method TBoundColumn::getItemRenderer()
getItemRenderer | in file TRepeater.php, method TRepeater::getItemRenderer()
getItems | in file TRepeater.php, method TRepeater::getItems()
getItems | in file TDataList.php, method TDataList::getItems()
getItems | in file TListControl.php, method TListControl::getItems()
getItems | in file TDataGrid.php, method TDataGrid::getItems()
getItemStyle | in file TDataList.php, method TDataList::getItemStyle()
getItemStyle | in file TDataGrid.php, method TDataGrid::getItemStyle()
getItemStyle | in file TDataGridColumn.php, method TDataGridColumn::getItemStyle()
getItemTemplate | in file TRepeater.php, method TRepeater::getItemTemplate()
getItemTemplate | in file TDataList.php, method TDataList::getItemTemplate()
getItemTemplate | in file TTemplateColumn.php, method TTemplateColumn::getItemTemplate()
getItemType | in file TItemDataRenderer.php, method TItemDataRenderer::getItemType()
getItemType | in file TRepeater.php, method TRepeaterItem::getItemType()
getItemType | in file TDataList.php, method TDataListItem::getItemType()
getItemType | in file TDataBoundControl.php, method IItemDataRenderer::getItemType()
getItemType | in file TDataGrid.php, method TDataGridPager::getItemType()
getItemType | in file TDataGrid.php, method TDataGridItem::getItemType()
getKeyboardCssClass | in file TKeyboard.php, method TKeyboard::getKeyboardCssClass()
getLabelAttributes | in file TCheckBox.php, method TCheckBox::getLabelAttributes()
getLanguage | in file TReCaptcha.php, method TReCaptcha::getLanguage()
getLanguage | in file TTextHighlighter.php, method TTextHighlighter::getLanguage()
getLanguageSuffix | in file THtmlArea.php, method THtmlArea::getLanguageSuffix()
getLastPageImageUrl | in file TPager.php, method TPager::getLastPageImageUrl()
getLastPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getLastPageText()
getLastPageText | in file TPager.php, method TPager::getLastPageText()
getLeft | in file TImageMap.php, method TRectangleHotSpot::getLeft()
getLineNumberStyle | in file TTextHighlighter.php, method TTextHighlighter::getLineNumberStyle()
getListDataSource | in file TDropDownListColumn.php, method TDropDownListColumn::getListDataSource()
getListTextField | in file TDropDownListColumn.php, method TDropDownListColumn::getListTextField()
getListTextFormatString | in file TDropDownListColumn.php, method TDropDownListColumn::getListTextFormatString()
getListValueField | in file TDropDownListColumn.php, method TDropDownListColumn::getListValueField()
getLocalizedCalendarInfo | in file TDatePicker.php, method TDatePicker::getLocalizedCalendarInfo()
getLocalizedMonthNames in file TDatePicker.php, method TDatePicker::getLocalizedMonthNames()
Returns the localized month names that depends on the month format pattern.
getLocalName | in file TFileUpload.php, method TFileUpload::getLocalName()
getMarginHeight | in file TInlineFrame.php, method TInlineFrame::getMarginHeight()
getMarginWidth | in file TInlineFrame.php, method TInlineFrame::getMarginWidth()
getMaxFileSize | in file TFileUpload.php, method TFileUpload::getMaxFileSize()
getMaximumRows | in file TDataSourceView.php, method TDataSourceSelectParameters::getMaximumRows()
getMaxLength | in file TTextBox.php, method TTextBox::getMaxLength()
getMaxSelection | in file TListControlValidator.php, method TListControlValidator::getMaxSelection()
getMaxTokenLength | in file TCaptcha.php, method TCaptcha::getMaxTokenLength()
getMaxValue | in file TSlider.php, method TSlider::getMaxValue()
getMaxValue | in file TRangeValidator.php, method TRangeValidator::getMaxValue()
getMediaType | in file TStyleSheet.php, method TStyleSheet::getMediaType()
getMinSelection | in file TListControlValidator.php, method TListControlValidator::getMinSelection()
getMinTokenLength | in file TCaptcha.php, method TCaptcha::getMinTokenLength()
getMinValue | in file TSlider.php, method TSlider::getMinValue()
getMinValue | in file TRangeValidator.php, method TRangeValidator::getMinValue()
getMode | in file TColorPicker.php, method TColorPicker::getMode()
getMode | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getMode()
getMode | in file TDatePicker.php, method TDatePicker::getMode()
getMode | in file TPager.php, method TPager::getMode()
getMultiView in file TWizard.php, method TWizard::getMultiView()
Returns the multiview that holds the wizard steps.
getName | in file TFont.php, method TFont::getName()
getName | in file TDataSourceView.php, method TDataSourceView::getName()
getName | in file THead.php, method TMetaTag::getName()
getNavigateUrl | in file TTabPanel.php, method TTabView::getNavigateUrl()
getNavigateUrl | in file THyperLinkColumn.php, method THyperLinkColumn::getNavigateUrl()
getNavigateUrl | in file THyperLink.php, method THyperLink::getNavigateUrl()
getNavigateUrl | in file TAccordion.php, method TAccordionView::getNavigateUrl()
getNavigateUrl | in file TImageMap.php, method THotSpot::getNavigateUrl()
getNavigationButtonStyle | in file TWizard.php, method TWizard::getNavigationButtonStyle()
getNavigationContainer | in file TWizard.php, method TTemplatedWizardStep::getNavigationContainer()
getNavigationStyle | in file TWizard.php, method TWizard::getNavigationStyle()
getNavigationTemplate | in file TWizard.php, method TTemplatedWizardStep::getNavigationTemplate()
getNewPageIndex | in file TPager.php, method TPagerPageChangedEventParameter::getNewPageIndex()
getNewPageIndex | in file TDataGrid.php, method TDataGridPageChangedEventParameter::getNewPageIndex()
getNextButton | in file TWizard.php, method TWizardNavigationContainer::getNextButton()
getNextPageImageUrl | in file TPager.php, method TPager::getNextPageImageUrl()
getNextPageText | in file TPager.php, method TPager::getNextPageText()
getNextPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getNextPageText()
getNextStepIndex | in file TWizard.php, method TWizardNavigationEventParameter::getNextStepIndex()
getNumericPageImageUrl | in file TPager.php, method TPager::getNumericPageImageUrl()
getObserveChanges | in file TBaseValidator.php, method TValidatorClientSide::getObserveChanges()
getOKButtonText | in file TColorPicker.php, method TColorPicker::getOKButtonText()
getOnChange | in file TSlider.php, method TSliderClientScript::getOnChange()
getOnColorSelected | in file TColorPicker.php, method TColorPickerClientSide::getOnColorSelected()
getOnDateChanged | in file TDatePicker.php, method TDatePickerClientScript::getOnDateChanged()
getOnHideSummary | in file TValidationSummary.php, method TClientSideValidationSummaryOptions::getOnHideSummary()
getOnShowSummary | in file TValidationSummary.php, method TClientSideValidationSummaryOptions::getOnShowSummary()
getOnSlide | in file TSlider.php, method TSliderClientScript::getOnSlide()
getOnValidate | in file TBaseValidator.php, method TValidatorClientSide::getOnValidate()
getOnValidationError | in file TBaseValidator.php, method TValidatorClientSide::getOnValidationError()
getOnValidationSuccess | in file TBaseValidator.php, method TValidatorClientSide::getOnValidationSuccess()
getOperator | in file TCompareValidator.php, method TCompareValidator::getOperator()
getOptions in file THtmlArea.php, method THtmlArea::getOptions()
Gets the list of options for the WYSIWYG (TinyMCE) editor
getOverline | in file TFont.php, method TFont::getOverline()
getOwner | in file TDataGrid.php, method TDataGridColumnCollection::getOwner()
getOwner | in file TDataGridColumn.php, method TDataGridColumn::getOwner()
getPageButtonCount | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getPageButtonCount()
getPageButtonCount | in file TPager.php, method TPager::getPageButtonCount()
getPageCount | in file TDataBoundControl.php, method TDataBoundControl::getPageCount()
getPageCount | in file TPager.php, method TPager::getPageCount()
getPageImageUrl | in file TPager.php, method TPager::getPageImageUrl()
getPager | in file TDataGrid.php, method TDataGridPagerEventParameter::getPager()
getPagerStyle | in file TDataGrid.php, method TDataGrid::getPagerStyle()
getPageSize | in file TDataBoundControl.php, method TDataBoundControl::getPageSize()
getParameters in file TXmlTransform.php, method TXmlTransform::getParameters()
Returns the list of parameters to be applied to the transform.
getPatternModifiers | in file TRegularExpressionValidator.php, method TRegularExpressionValidator::getPatternModifiers()
getPersistPassword | in file TTextBox.php, method TTextBox::getPersistPassword()
getPosition | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getPosition()
getPositionMode | in file TDatePicker.php, method TDatePicker::getPositionMode()
getPostBackOptions | in file TRatingList.php, method TRatingList::getPostBackOptions()
getPostBackOptions in file TColorPicker.php, method TColorPicker::getPostBackOptions()
Get javascript color picker options.
getPostBackOptions in file TCheckBox.php, method TCheckBox::getPostBackOptions()
Gets the post back options for this checkbox.
getPostBackOptions in file TCheckBoxList.php, method TCheckBoxList::getPostBackOptions()
Gets the post back options for this checkbox.
getPostBackOptions in file TTextBox.php, method TTextBox::getPostBackOptions()
Gets the post back options for this textbox.
getPostBackOptions | in file TListControl.php, method TListControl::getPostBackOptions()
getPostBackOptions in file TImageButton.php, method TImageButton::getPostBackOptions()
Returns postback specifications for the button.
getPostBackOptions in file TLinkButton.php, method TLinkButton::getPostBackOptions()
Returns postback specifications for the button.
getPostBackOptions in file TButton.php, method TButton::getPostBackOptions()
Returns postback specifications for the button.
getPostBackOptions | in file TBulletedList.php, method TBulletedList::getPostBackOptions()
getPostBackValue | in file TImageMap.php, method TImageMapEventParameter::getPostBackValue()
getPostBackValue | in file TImageMap.php, method THotSpot::getPostBackValue()
getPostContentsTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::getPostContentsTemplate()
getPostContentsText | in file TWebControlDecorator.php, method TWebControlDecorator::getPostContentsText()
getPostTagTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::getPostTagTemplate()
getPostTagText | in file TWebControlDecorator.php, method TWebControlDecorator::getPostTagText()
getPradoScripts | in file TClientScript.php, method TClientScript::getPradoScripts()
getPreContentsTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::getPreContentsTemplate()
getPreContentsText | in file TWebControlDecorator.php, method TWebControlDecorator::getPreContentsText()
getPreTagTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::getPreTagTemplate()
getPreTagText | in file TWebControlDecorator.php, method TWebControlDecorator::getPreTagText()
getPreviousButton | in file TWizard.php, method TWizardNavigationContainer::getPreviousButton()
getPreviousStepIndex in file TWizard.php, method TWizard::getPreviousStepIndex()
Determines the index of the previous step based on history.
getPrevPageImageUrl | in file TPager.php, method TPager::getPrevPageImageUrl()
getPrevPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getPrevPageText()
getPrevPageText | in file TPager.php, method TPager::getPrevPageText()
getPrivateKey | in file TReCaptcha.php, method TReCaptcha::getPrivateKey()
getPrivateKey | in file TCaptcha.php, method TCaptcha::getPrivateKey()
getProgressIndicator | in file TSlider.php, method TSlider::getProgressIndicator()
getPromptText | in file TListControl.php, method TListControl::getPromptText()
getPromptValue | in file TListControl.php, method TListControl::getPromptValue()
getPublicKey | in file TCaptcha.php, method TCaptcha::getPublicKey()
getPublicKey | in file TReCaptcha.php, method TReCaptcha::getPublicKey()
getRadioButtonsInGroup in file TRadioButton.php, method TRadioButton::getRadioButtonsInGroup()
Gets an array of radiobuttons whose group name is the same as this radiobutton's.
getRadius | in file TImageMap.php, method TCircleHotSpot::getRadius()
getRating | in file TRatingList.php, method TRatingList::getRating()
getRatingIndex | in file TRatingList.php, method TRatingList::getRatingIndex()
getRatingStyle | in file TRatingList.php, method TRatingList::getRatingStyle()
getRatingStyleCssClass | in file TRatingList.php, method TRatingList::getRatingStyleCssClass()
getReadOnly | in file TTextBox.php, method TTextBox::getReadOnly()
getReadOnly | in file TBoundColumn.php, method TBoundColumn::getReadOnly()
getReadOnly | in file TDropDownListColumn.php, method TDropDownListColumn::getReadOnly()
getReadOnly | in file TRatingList.php, method TRatingList::getReadOnly()
getReadOnly | in file TCheckBoxColumn.php, method TCheckBoxColumn::getReadOnly()
getRegularExpression | in file TRegularExpressionValidator.php, method TRegularExpressionValidator::getRegularExpression()
getRegularExpression | in file TEmailAddressValidator.php, method TEmailAddressValidator::getRegularExpression()
getRepackUTF7 | in file TSafeHtml.php, method TSafeHtml::getRepackUTF7()
getRepeatColumns | in file TRepeatInfo.php, method TRepeatInfo::getRepeatColumns()
getRepeatColumns | in file TDataList.php, method TDataList::getRepeatColumns()
getRepeatColumns | in file TCheckBoxList.php, method TCheckBoxList::getRepeatColumns()
getRepeatDirection | in file TRepeatInfo.php, method TRepeatInfo::getRepeatDirection()
getRepeatDirection | in file TCheckBoxList.php, method TCheckBoxList::getRepeatDirection()
getRepeatDirection | in file TDataList.php, method TDataList::getRepeatDirection()
getRepeatInfo | in file TCheckBoxList.php, method TCheckBoxList::getRepeatInfo()
getRepeatInfo | in file TDataList.php, method TDataList::getRepeatInfo()
getRepeatLayout | in file TDataList.php, method TDataList::getRepeatLayout()
getRepeatLayout | in file TRepeatInfo.php, method TRepeatInfo::getRepeatLayout()
getRepeatLayout | in file TCheckBoxList.php, method TCheckBoxList::getRepeatLayout()
getRequiredSelections in file TListControlValidator.php, method TListControlValidator::getRequiredSelections()
Get a comma separated list of required selected values.
getRequiredValues | in file TListControlValidator.php, method TListControlValidator::getRequiredValues()
getRequiresDataBinding | in file TDataBoundControl.php, method TDataBoundControl::getRequiresDataBinding()
getResponseFieldName | in file TReCaptcha.php, method TReCaptcha::getResponseFieldName()
getRetrieveTotalRowCount | in file TDataSourceView.php, method TDataSourceSelectParameters::getRetrieveTotalRowCount()
getRight | in file TImageMap.php, method TRectangleHotSpot::getRight()
getRows | in file TTextBox.php, method TTextBox::getRows()
getRows | in file TTable.php, method TTable::getRows()
getRows | in file TListBox.php, method TListBox::getRows()
getRowSpan | in file TTableCell.php, method TTableCell::getRowSpan()
getSafeText | in file TTextBox.php, method TTextBox::getSafeText()
getSafeTextParser | in file TTextBox.php, method TTextBox::getSafeTextParser()
getScheme | in file THead.php, method TMetaTag::getScheme()
getScope | in file TTableHeaderCell.php, method TTableHeaderCell::getScope()
getScriptDeploymentPath in file THtmlArea.php, method THtmlArea::getScriptDeploymentPath()
Gets the editor script base URL by publishing the tarred source via TTarAssetManager.
getScriptUrl | in file TClientScript.php, method TClientScript::getScriptUrl()
getScriptUrl | in file THtmlArea.php, method THtmlArea::getScriptUrl()
getScrollBars | in file TPanel.php, method TPanel::getScrollBars()
getScrollBars | in file TPanelStyle.php, method TPanelStyle::getScrollBars()
getScrollBars | in file TInlineFrame.php, method TInlineFrame::getScrollBars()
getScrollToSummary | in file TValidationSummary.php, method TValidationSummary::getScrollToSummary()
getSelected | in file TListItem.php, method TListItem::getSelected()
getSelectedDataKey | in file TDataList.php, method TDataList::getSelectedDataKey()
getSelectedIndex | in file TListControl.php, method TListControl::getSelectedIndex()
getSelectedIndices | in file TListControl.php, method TListControl::getSelectedIndices()
getSelectedItem | in file TDataGrid.php, method TDataGrid::getSelectedItem()
getSelectedItem | in file TDataList.php, method TDataList::getSelectedItem()
getSelectedItem | in file TListControl.php, method TListControl::getSelectedItem()
getSelectedItemIndex | in file TDataList.php, method TDataList::getSelectedItemIndex()
getSelectedItemIndex | in file TDataGrid.php, method TDataGrid::getSelectedItemIndex()
getSelectedItemRenderer | in file TDataList.php, method TDataList::getSelectedItemRenderer()
getSelectedItemStyle | in file TDataGrid.php, method TDataGrid::getSelectedItemStyle()
getSelectedItemStyle | in file TDataList.php, method TDataList::getSelectedItemStyle()
getSelectedItemTemplate | in file TDataList.php, method TDataList::getSelectedItemTemplate()
getSelectedValue | in file TListControl.php, method TListControl::getSelectedValue()
getSelectedValues | in file TListControl.php, method TListControl::getSelectedValues()
getSelection | in file TListControlValidator.php, method TListControlValidator::getSelection()
getSelectionMode | in file TListBox.php, method TListBox::getSelectionMode()
getSelectParameters | in file TDataBoundControl.php, method TDataBoundControl::getSelectParameters()
getSeparatorRenderer | in file TRepeater.php, method TRepeater::getSeparatorRenderer()
getSeparatorRenderer | in file TDataList.php, method TDataList::getSeparatorRenderer()
getSeparatorStyle | in file TDataList.php, method TDataList::getSeparatorStyle()
getSeparatorTemplate | in file TDataList.php, method TDataList::getSeparatorTemplate()
getSeparatorTemplate | in file TRepeater.php, method TRepeater::getSeparatorTemplate()
getShape | in file TImageMap.php, method TCircleHotSpot::getShape()
getShape | in file TImageMap.php, method THotSpot::getShape()
getShape | in file TImageMap.php, method TRectangleHotSpot::getShape()
getShape | in file TImageMap.php, method TPolygonHotSpot::getShape()
getShowAnchor | in file TValidationSummary.php, method TValidationSummary::getShowAnchor()
getShowBorder | in file TInlineFrame.php, method TInlineFrame::getShowBorder()
getShowCalendar | in file TDatePicker.php, method TDatePicker::getShowCalendar()
getShowCancelButton | in file TWizard.php, method TWizard::getShowCancelButton()
getShowColorPicker | in file TColorPicker.php, method TColorPicker::getShowColorPicker()
getShowFooter | in file TDataGrid.php, method TDataGrid::getShowFooter()
getShowFooter | in file TDataList.php, method TDataList::getShowFooter()
getShowHeader | in file TDataList.php, method TDataList::getShowHeader()
getShowHeader | in file TDataGrid.php, method TDataGrid::getShowHeader()
getShowLineNumbers | in file TTextHighlighter.php, method TTextHighlighter::getShowLineNumbers()
getShowMessageBox | in file TValidationSummary.php, method TValidationSummary::getShowMessageBox()
getShowSideBar | in file TWizard.php, method TWizard::getShowSideBar()
getShowSummary | in file TValidationSummary.php, method TValidationSummary::getShowSummary()
getSideBar | in file TWizard.php, method TWizard::getSideBar()
getSideBarButtonStyle | in file TWizard.php, method TWizard::getSideBarButtonStyle()
getSideBarStyle | in file TWizard.php, method TWizard::getSideBarStyle()
getSideBarTemplate | in file TWizard.php, method TWizard::getSideBarTemplate()
getSize | in file TFont.php, method TFont::getSize()
getSkinID | in file TDataSourceControl.php, method TDataSourceControl::getSkinID()
getSliderOptions in file TSlider.php, method TSlider::getSliderOptions()
Get javascript sliderr options.
getSortExpression | in file TDataGridColumn.php, method TDataGridColumn::getSortExpression()
getSortExpression | in file TDataGrid.php, method TDataGridSortCommandEventParameter::getSortExpression()
getSpanNeeded in file TCheckBox.php, method TCheckBox::getSpanNeeded()
Check if we need a span tag to surround this control. The span tag will be created if the Text property is set for this control.
getSpanNeeded in file TCheckBoxList.php, method TCheckBoxList::getSpanNeeded()
Wether the list should be rendered inside a span or not
getStartNavigation | in file TWizard.php, method TWizard::getStartNavigation()
getStartNavigationTemplate | in file TWizard.php, method TWizard::getStartNavigationTemplate()
getStartNextButtonStyle | in file TWizard.php, method TWizard::getStartNextButtonStyle()
getStartRowIndex | in file TDataSourceView.php, method TDataSourceSelectParameters::getStartRowIndex()
getStatements | in file TStatements.php, method TStatements::getStatements()
getStepContent | in file TWizard.php, method TWizard::getStepContent()
getStepNavigation | in file TWizard.php, method TWizard::getStepNavigation()
getStepNavigationTemplate | in file TWizard.php, method TWizard::getStepNavigationTemplate()
getStepNextButtonStyle | in file TWizard.php, method TWizard::getStepNextButtonStyle()
getStepPreviousButtonStyle | in file TWizard.php, method TWizard::getStepPreviousButtonStyle()
getStepSize | in file TSlider.php, method TSlider::getStepSize()
getStepStyle | in file TWizard.php, method TWizard::getStepStyle()
getStepType in file TWizard.php, method TWizard::getStepType()
Determines the type of the specified wizard step.
getStepType | in file TWizard.php, method TCompleteWizardStep::getStepType()
getStepType | in file TWizard.php, method TWizardStep::getStepType()
getStrictComparison | in file TRangeValidator.php, method TRangeValidator::getStrictComparison()
getStrikeout | in file TFont.php, method TFont::getStrikeout()
getStyle | in file TDataListItemRenderer.php, method TDataListItemRenderer::getStyle()
getStyle | in file TWebControl.php, method TWebControl::getStyle()
getStyleField | in file TStyle.php, method TStyle::getStyleField()
getStyleFields | in file TStyle.php, method TStyle::getStyleFields()
getStyleSheetUrl | in file TStyleSheet.php, method TStyleSheet::getStyleSheetUrl()
getSurroundingTagID | in file TCheckBox.php, method TCheckBox::getSurroundingTagID()
getTabCssClass | in file TTabPanel.php, method TTabPanel::getTabCssClass()
getTabIndex | in file TWebControl.php, method TWebControl::getTabIndex()
getTabIndex | in file TImageMap.php, method THotSpot::getTabIndex()
getTableBodyStyle | in file TDataGrid.php, method TDataGrid::getTableBodyStyle()
getTableFootStyle | in file TDataGrid.php, method TDataGrid::getTableFootStyle()
getTableHeadStyle | in file TDataGrid.php, method TDataGrid::getTableHeadStyle()
getTableSection | in file TTableFooterRow.php, method TTableFooterRow::getTableSection()
getTableSection | in file TTableRow.php, method TTableRow::getTableSection()
getTableSection | in file TTableHeaderRow.php, method TTableHeaderRow::getTableSection()
getTabSize | in file TTextHighlighter.php, method TTextHighlighter::getTabSize()
getTabStyle | in file TTabPanel.php, method TTabPanel::getTabStyle()
getTagName | in file TTextBox.php, method TTextBox::getTagName()
getTagName | in file TTabPanel.php, method TTabView::getTagName()
getTagName in file TWebControl.php, method TWebControl::getTagName()
Returns the tag name used for this control.
getTagName | in file TTabPanel.php, method TTabPanel::getTagName()
getTagName | in file TWizard.php, method TWizard::getTagName()
getTagName | in file TTextHighlighter.php, method TTextHighlighter::getTagName()
getTagName | in file TImageButton.php, method TImageButton::getTagName()
getTagName | in file TInlineFrame.php, method TInlineFrame::getTagName()
getTagName | in file TImage.php, method TImage::getTagName()
getTagName | in file THyperLink.php, method THyperLink::getTagName()
getTagName | in file TJavascriptLogger.php, method TJavascriptLogger::getTagName()
getTagName | in file TLabel.php, method TLabel::getTagName()
getTagName | in file TPanel.php, method TPanel::getTagName()
getTagName | in file TListControl.php, method TListControl::getTagName()
getTagName | in file TLinkButton.php, method TLinkButton::getTagName()
getTagName | in file THtmlElement.php, method THtmlElement::getTagName()
getTagName | in file THiddenField.php, method THiddenField::getTagName()
getTagName | in file TBulletedList.php, method TBulletedList::getTagName()
getTagName | in file TAccordion.php, method TAccordionView::getTagName()
getTagName | in file TAccordion.php, method TAccordion::getTagName()
getTagName | in file TButton.php, method TButton::getTagName()
getTagName | in file TCheckBox.php, method TCheckBox::getTagName()
getTagName in file TDataListItemRenderer.php, method TDataListItemRenderer::getTagName()
Returns the tag name used for this control.
getTagName in file TDataList.php, method TDataListItem::getTagName()
Returns the tag name used for this control.
getTagName | in file TDataGrid.php, method TDataGrid::getTagName()
getTagName | in file TReCaptcha.php, method TReCaptcha::getTagName()
getTagName | in file TFileUpload.php, method TFileUpload::getTagName()
getTagName | in file TTable.php, method TTable::getTagName()
getTagName | in file TTableCell.php, method TTableCell::getTagName()
getTagName | in file TSlider.php, method TSlider::getTagName()
getTagName | in file TTableRow.php, method TTableRow::getTagName()
getTagName | in file TTableHeaderCell.php, method TTableHeaderCell::getTagName()
getTarget | in file THyperLink.php, method THyperLink::getTarget()
getTarget | in file TImageMap.php, method TImageMap::getTarget()
getTarget | in file THyperLinkColumn.php, method THyperLinkColumn::getTarget()
getTarget | in file TBulletedList.php, method TBulletedList::getTarget()
getTarget | in file TImageMap.php, method THotSpot::getTarget()
getTestLimit | in file TCaptcha.php, method TCaptcha::getTestLimit()
getText | in file TListControl.php, method TListControl::getText()
getText | in file TTabPanel.php, method TTabView::getText()
getText | in file TLinkButton.php, method TLinkButton::getText()
getText | in file THyperLink.php, method THyperLink::getText()
getText | in file TLabel.php, method TLabel::getText()
getText | in file THyperLinkColumn.php, method THyperLinkColumn::getText()
getText | in file TImageButton.php, method TImageButton::getText()
getText | in file TTextBox.php, method TTextBox::getText()
getText | in file TCheckBox.php, method TCheckBox::getText()
getText | in file TButtonColumn.php, method TButtonColumn::getText()
getText | in file TButton.php, method TButton::getText()
getText | in file TAccordion.php, method TAccordionView::getText()
getText | in file TLiteralColumn.php, method TLiteralColumn::getText()
getText | in file TLiteral.php, method TLiteral::getText()
getText | in file TTableCell.php, method TTableCell::getText()
getText | in file TListItem.php, method TListItem::getText()
getTextAlign | in file TCheckBox.php, method TCheckBox::getTextAlign()
getTextAlign | in file TCheckBoxList.php, method TCheckBoxList::getTextAlign()
getTextMode in file THtmlArea.php, method THtmlArea::getTextMode()
Overrides the parent implementation.
getTextMode | in file TTextBox.php, method TTextBox::getTextMode()
getThemeName | in file TReCaptcha.php, method TReCaptcha::getThemeName()
getTimeStamp | in file TDatePicker.php, method TDatePicker::getTimeStamp()
getTimeStampFromText in file TDatePicker.php, method TDatePicker::getTimeStampFromText()
Gets the date from the text input using TSimpleDateFormatter
getTitle | in file TWizard.php, method TWizardStep::getTitle()
getToggleKey | in file TJavascriptLogger.php, method TJavascriptLogger::getToggleKey()
getToken | in file TCaptcha.php, method TCaptcha::getToken()
getTokenAlphabet | in file TCaptcha.php, method TCaptcha::getTokenAlphabet()
getTokenExpiry | in file TCaptcha.php, method TCaptcha::getTokenExpiry()
getTokenFontSize | in file TCaptcha.php, method TCaptcha::getTokenFontSize()
getTokenImageOptions | in file TCaptcha.php, method TCaptcha::getTokenImageOptions()
getTokenImageTheme | in file TCaptcha.php, method TCaptcha::getTokenImageTheme()
getTokenLength | in file TCaptcha.php, method TCaptcha::getTokenLength()
getToolTip | in file TWebControl.php, method TWebControl::getToolTip()
getTop | in file TImageMap.php, method TRectangleHotSpot::getTop()
getTopPager | in file TDataGrid.php, method TDataGrid::getTopPager()
getTotalRowCount | in file TDataSourceView.php, method TDataSourceSelectParameters::getTotalRowCount()
getTransformContent | in file TXmlTransform.php, method TXmlTransform::getTransformContent()
getTransformPath | in file TXmlTransform.php, method TXmlTransform::getTransformPath()
getTrueTemplate | in file TConditional.php, method TConditional::getTrueTemplate()
getUnderline | in file TFont.php, method TFont::getUnderline()
getUniqueGroupName | in file TRadioButton.php, method TRadioButton::getUniqueGroupName()
getUpdateImageUrl | in file TEditCommandColumn.php, method TEditCommandColumn::getUpdateImageUrl()
getUpdateText | in file TEditCommandColumn.php, method TEditCommandColumn::getUpdateText()
getUpToYear | in file TDatePicker.php, method TDatePicker::getUpToYear()
getUseDefaultLayout | in file TWizard.php, method TWizard::getUseDefaultLayout()
getUseState | in file TWebControlDecorator.php, method TWebControlDecorator::getUseState()
getUsingDataSourceID | in file TDataBoundControl.php, method TDataBoundControl::getUsingDataSourceID()
getValidationGroup | in file TCheckBox.php, method TCheckBox::getValidationGroup()
getValidationGroup | in file TButton.php, method TButton::getValidationGroup()
getValidationGroup | in file TButtonColumn.php, method TButtonColumn::getValidationGroup()
getValidationGroup | in file TBaseValidator.php, method TBaseValidator::getValidationGroup()
getValidationGroup | in file TListControl.php, method TListControl::getValidationGroup()
getValidationGroup | in file TLinkButton.php, method TLinkButton::getValidationGroup()
getValidationGroup | in file TTextBox.php, method TTextBox::getValidationGroup()
getValidationGroup | in file TImageButton.php, method TImageButton::getValidationGroup()
getValidationGroup | in file TValidationSummary.php, method TValidationSummary::getValidationGroup()
getValidationGroup | in file TImageMap.php, method THotSpot::getValidationGroup()
getValidationGroup | in file TEditCommandColumn.php, method TEditCommandColumn::getValidationGroup()
getValidationPropertyValue in file TTextBox.php, method TTextBox::getValidationPropertyValue()
Returns the value to be validated.
getValidationPropertyValue in file TFileUpload.php, method TFileUpload::getValidationPropertyValue()
Returns the original file name as the property value to be validated.
getValidationPropertyValue in file THiddenField.php, method THiddenField::getValidationPropertyValue()
Returns the value to be validated.
getValidationPropertyValue in file TListBox.php, method TListBox::getValidationPropertyValue()
Returns the value to be validated.
getValidationPropertyValue | in file TReCaptcha.php, method TReCaptcha::getValidationPropertyValue()
getValidationPropertyValue in file TDropDownList.php, method TDropDownList::getValidationPropertyValue()
Returns the value to be validated.
getValidationPropertyValue in file TCheckBox.php, method TCheckBox::getValidationPropertyValue()
Returns the value of the property that needs validation.
getValidationPropertyValue in file TCheckBoxList.php, method TCheckBoxList::getValidationPropertyValue()
Returns the value to be validated.
getValidationPropertyValue in file TDatePicker.php, method TDatePicker::getValidationPropertyValue()
Returns the value to be validated.
getValidationTarget | in file TCustomValidator.php, method TCustomValidator::getValidationTarget()
getValidationTarget | in file TBaseValidator.php, method TBaseValidator::getValidationTarget()
getValidationValue in file TBaseValidator.php, method TBaseValidator::getValidationValue()
Retrieves the property value of the control being validated.
getValue | in file TCheckBox.php, method TCheckBox::getValue()
getValue | in file TCustomValidator.php, method TServerValidateEventParameter::getValue()
getValue | in file TSlider.php, method TSlider::getValue()
getValue | in file TListItem.php, method TListItem::getValue()
getValue | in file THiddenField.php, method THiddenField::getValue()
getValueAttribute | in file TRadioButton.php, method TRadioButton::getValueAttribute()
getValueAttribute | in file TCheckBox.php, method TCheckBox::getValueAttribute()
getValues | in file TSlider.php, method TSlider::getValues()
getValueToCompare | in file TCompareValidator.php, method TCompareValidator::getValueToCompare()
getVaryByParam | in file TOutputCache.php, method TOutputCache::getVaryByParam()
getVaryBySession | in file TOutputCache.php, method TOutputCache::getVaryBySession()
getVerticalAlign | in file TTableRow.php, method TTableRow::getVerticalAlign()
getVerticalAlign | in file TStyle.php, method TTableItemStyle::getVerticalAlign()
getVerticalAlign | in file TTableCell.php, method TTableCell::getVerticalAlign()
getView | in file TDataSourceControl.php, method TDataSourceControl::getView()
getView | in file TDataSourceControl.php, method TReadOnlyDataSource::getView()
getView | in file TDataSourceControl.php, method IDataSource::getView()
getViewCssClass | in file TAccordion.php, method TAccordion::getViewCssClass()
getViewCssClass | in file TTabPanel.php, method TTabPanel::getViewCssClass()
getViewHeight | in file TAccordion.php, method TAccordion::getViewHeight()
getViewNames | in file TDataSourceControl.php, method TDataSourceControl::getViewNames()
getViewNames | in file TDataSourceControl.php, method IDataSource::getViewNames()
getViews | in file TMultiView.php, method TMultiView::getViews()
getViews | in file TTabPanel.php, method TTabPanel::getViews()
getViews | in file TAccordion.php, method TAccordion::getViews()
getViewState in file TDataGridColumn.php, method TDataGridColumn::getViewState()
Returns a viewstate value.
getViewState in file TImageMap.php, method THotSpot::getViewState()
Returns a viewstate value.
getViewStyle | in file TTabPanel.php, method TTabPanel::getViewStyle()
getViewStyle | in file TAccordion.php, method TAccordion::getViewStyle()
getVirtualItemCount | in file TDataBoundControl.php, method TDataBoundControl::getVirtualItemCount()
getVisible | in file TDataSourceControl.php, method TDataSourceControl::getVisible()
getVisible | in file TDataGridColumn.php, method TDataGridColumn::getVisible()
getVisible | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getVisible()
getVisible | in file TMultiView.php, method TView::getVisible()
getWidth | in file TWebControl.php, method TWebControl::getWidth()
getWidth | in file TStyle.php, method TStyle::getWidth()
getWizard | in file TWizard.php, method TWizardNavigationTemplate::getWizard()
getWizard | in file TWizard.php, method TWizardStep::getWizard()
getWizardSteps | in file TWizard.php, method TWizard::getWizardSteps()
getWrap | in file TStyle.php, method TTableItemStyle::getWrap()
getWrap | in file TPanel.php, method TPanel::getWrap()
getWrap | in file TPanelStyle.php, method TPanelStyle::getWrap()
getWrap | in file TTableCell.php, method TTableCell::getWrap()
getWrap | in file TTextBox.php, method TTextBox::getWrap()
getX | in file TImageButton.php, method TImageClickEventParameter::getX()
getX | in file TImageMap.php, method TCircleHotSpot::getX()
getY | in file TImageMap.php, method TCircleHotSpot::getY()
getY | in file TImageButton.php, method TImageClickEventParameter::getY()
GreaterThan | in file TCompareValidator.php, class constant TValidationCompareOperator::GreaterThan
GreaterThanEqual | in file TCompareValidator.php, class constant TValidationCompareOperator::GreaterThanEqual
top
h
hasAttribute | in file TImageMap.php, method THotSpot::hasAttribute()
hasAttribute | in file TListItem.php, method TListItem::hasAttribute()
hasCssClass | in file TStyle.php, method TStyle::hasCssClass()
hasDayPattern | in file TDatePicker.php, method TDatePicker::hasDayPattern()
hasFont | in file TStyle.php, method TStyle::hasFont()
hash2string in file TCaptcha.php, method TCaptcha::hash2string()
Converts a hash string into a string with characters consisting of alphanumeric characters.
hasStyleField | in file TStyle.php, method TStyle::hasStyleField()
Header | in file TDataBoundControl.php, class constant TListItemType::Header
Header | in file TTableRow.php, class constant TTableRowSection::Header
HeaderOnly | in file TValidationSummary.php, class constant TValidationSummaryDisplayMode::HeaderOnly
Hidden | in file TStyle.php, class constant TDisplayStyle::Hidden
highlightCode in file TMarkdown.php, method TMarkdown::highlightCode()
Highlights source code using TTextHighlighter
HomeCity | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomeCity
HomeCountryRegion | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomeCountryRegion
HomeFax | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomeFax
Homepage | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Homepage
HomePhone | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomePhone
HomeState | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomeState
HomeStreetAddress | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomeStreetAddress
HomeZipCode | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomeZipCode
Horizontal | in file TStyle.php, class constant TTableGridLines::Horizontal
Horizontal | in file TPanelStyle.php, class constant TScrollBars::Horizontal
Horizontal | in file TRepeatInfo.php, class constant TRepeatDirection::Horizontal
Horizontal | in file TSlider.php, class constant TSliderDirection::Horizontal
HyperLink | in file TBulletedList.php, class constant TBulletedListDisplayMode::HyperLink
top
i
IDataSource in file TDataSourceControl.php, class IDataSource
IDataSource class
ID_SIDEBAR_BUTTON in file TWizard.php, class constant TWizard::ID_SIDEBAR_BUTTON
Side bar button ID
ID_SIDEBAR_LIST in file TWizard.php, class constant TWizard::ID_SIDEBAR_LIST
Side bar data list
ignoreBubbleEvents in file TMultiView.php, method TMultiView::ignoreBubbleEvents()
Makes the multiview ignore all bubbled events.
IItemDataRenderer in file TDataBoundControl.php, class IItemDataRenderer
IItemDataRenderer interface.
Image | in file TWizard.php, class constant TWizardNavigationButtonType::Image
ImageButton | in file TDatePicker.php, class constant TDatePickerMode::ImageButton
ImageButton | in file TDataGridColumn.php, class constant TButtonColumnType::ImageButton
ImageButton | in file TPager.php, class constant TPagerButtonType::ImageButton
Inactive | in file TImageMap.php, class constant THotSpotMode::Inactive
initialize in file TDataGridColumn.php, method TDataGridColumn::initialize()
Initializes the column.
initializeCell in file TDataGridColumn.php, method TDataGridColumn::initializeCell()
Initializes the specified cell to its initial values.
initializeCell in file TTemplateColumn.php, method TTemplateColumn::initializeCell()
Initializes the specified cell to its initial values.
initializeCell in file TLiteralColumn.php, method TLiteralColumn::initializeCell()
Initializes the specified cell to its initial values.
initializeCell in file THyperLinkColumn.php, method THyperLinkColumn::initializeCell()
Initializes the specified cell to its initial values.
initializeCell in file TEditCommandColumn.php, method TEditCommandColumn::initializeCell()
Initializes the specified cell to its initial values.
initializeCell in file TDropDownListColumn.php, method TDropDownListColumn::initializeCell()
Initializes the specified cell to its initial values.
initializeCell in file TButtonColumn.php, method TButtonColumn::initializeCell()
Initializes the specified cell to its initial values.
initializeCell in file TBoundColumn.php, method TBoundColumn::initializeCell()
Initializes the specified cell to its initial values.
initializeCell in file TCheckBoxColumn.php, method TCheckBoxColumn::initializeCell()
Initializes the specified cell to its initial values.
initializeFooterCell in file TDataGridColumn.php, method TDataGridColumn::initializeFooterCell()
Initializes the footer cell.
initializeHeaderCell in file TDataGridColumn.php, method TDataGridColumn::initializeHeaderCell()
Initializes the header cell.
initializeItem in file TDataGrid.php, method TDataGrid::initializeItem()
Initializes a datagrid item and cells inside it
initRecursive in file TOutputCache.php, method TOutputCache::initRecursive()
Performs the Init step for the control and all its child controls.
insertAt in file TAccordion.php, method TAccordionViewCollection::insertAt()
Inserts an item at the specified position.
insertAt in file TDataGrid.php, method TDataGridItemCollection::insertAt()
Inserts an item at the specified position.
insertAt in file TTabPanel.php, method TTabViewCollection::insertAt()
Inserts an item at the specified position.
insertAt in file TTableRow.php, method TTableCellCollection::insertAt()
Inserts an item at the specified position.
insertAt in file TImageMap.php, method THotSpotCollection::insertAt()
Inserts an item at the specified position.
insertAt in file TRepeater.php, method TRepeaterItemCollection::insertAt()
Inserts an item at the specified position.
insertAt in file TMultiView.php, method TViewCollection::insertAt()
Inserts an item at the specified position.
insertAt in file THead.php, method TMetaTagCollection::insertAt()
Inserts an item at the specified position.
insertAt in file TWizard.php, method TWizardStepCollection::insertAt()
Inserts an item at the specified position.
insertAt in file TDataSourceView.php, method TDataSourceView::insertAt()
Inserts a DB record.
insertAt in file TDataList.php, method TDataListItemCollection::insertAt()
Inserts an item at the specified position.
insertAt in file TDataGrid.php, method TDataGridColumnCollection::insertAt()
Inserts an item at the specified position.
insertAt in file TTable.php, method TTableRowCollection::insertAt()
Inserts an item at the specified position.
instantiate in file TWebControlDecorator.php, method TWebControlDecorator::instantiate()
this is a framework call. The Text decoration can't influence the object hierarchy because they are rendered into into the writer directly.
instantiateIn in file TWizard.php, method TWizardFinishNavigationTemplate::instantiateIn()
Instantiates the template.
instantiateIn in file TWizard.php, method TWizardStepNavigationTemplate::instantiateIn()
Instantiates the template.
instantiateIn in file TWizard.php, method TWizardNavigationTemplate::instantiateIn()
Instantiates the template.
instantiateIn in file TWizard.php, method TWizardSideBarListItemTemplate::instantiateIn()
Instantiates the template.
instantiateIn in file TWizard.php, method TWizardStartNavigationTemplate::instantiateIn()
Instantiates the template.
instantiateIn in file TWizard.php, method TWizardSideBarTemplate::instantiateIn()
Instantiates the template.
instantiateNavigationTemplate in file TWizard.php, method TTemplatedWizardStep::instantiateNavigationTemplate()
Instantiates the navigation template if any
Integer | in file TBaseValidator.php, class constant TValidationDataType::Integer
IRepeatInfoUser in file TRepeatInfo.php, class IRepeatInfoUser
IRepeatInfoUser interface.
isGreaterThan | in file TRangeValidator.php, method TRangeValidator::isGreaterThan()
isLessThan | in file TRangeValidator.php, method TRangeValidator::isLessThan()
isValidDate in file TRangeValidator.php, method TRangeValidator::isValidDate()
Determine if the date is within the specified range.
isValidFloat in file TRangeValidator.php, method TRangeValidator::isValidFloat()
Determine if the value is within the specified float range.
isValidInteger in file TRangeValidator.php, method TRangeValidator::isValidInteger()
Determine if the value is within the integer range.
isValidString in file TRangeValidator.php, method TRangeValidator::isValidString()
Compare the string with a minimum and a maxiumum value.
isValidStringLength | in file TRangeValidator.php, method TRangeValidator::isValidStringLength()
IS_BOLD in file TFont.php, class constant TFont::IS_BOLD
Bits indicating the font states.
IS_ITALIC | in file TFont.php, class constant TFont::IS_ITALIC
IS_OVERLINE | in file TFont.php, class constant TFont::IS_OVERLINE
IS_SET_BOLD in file TFont.php, class constant TFont::IS_SET_BOLD
Bits indicating whether particular font states are changed.
IS_SET_ITALIC | in file TFont.php, class constant TFont::IS_SET_ITALIC
IS_SET_NAME | in file TFont.php, class constant TFont::IS_SET_NAME
IS_SET_OVERLINE | in file TFont.php, class constant TFont::IS_SET_OVERLINE
IS_SET_SIZE | in file TFont.php, class constant TFont::IS_SET_SIZE
IS_SET_STRIKEOUT | in file TFont.php, class constant TFont::IS_SET_STRIKEOUT
IS_SET_UNDERLINE | in file TFont.php, class constant TFont::IS_SET_UNDERLINE
IS_STRIKEOUT | in file TFont.php, class constant TFont::IS_STRIKEOUT
IS_UNDERLINE | in file TFont.php, class constant TFont::IS_UNDERLINE
Item | in file TDataBoundControl.php, class constant TListItemType::Item
IT_ALTERNATINGITEM | in file TDataGrid.php, class constant TDataGrid::IT_ALTERNATINGITEM
IT_ALTERNATINGITEM | in file TRepeater.php, class constant TRepeater::IT_ALTERNATINGITEM
IT_EDITITEM | in file TDataGrid.php, class constant TDataGrid::IT_EDITITEM
IT_FOOTER | in file TDataGrid.php, class constant TDataGrid::IT_FOOTER
IT_FOOTER | in file TRepeater.php, class constant TRepeater::IT_FOOTER
IT_HEADER in file TRepeater.php, class constant TRepeater::IT_HEADER
Repeater item types
IT_HEADER in file TDataGrid.php, class constant TDataGrid::IT_HEADER
datagrid item types
IT_ITEM | in file TRepeater.php, class constant TRepeater::IT_ITEM
IT_ITEM | in file TDataGrid.php, class constant TDataGrid::IT_ITEM
IT_PAGER | in file TDataGrid.php, class constant TDataGrid::IT_PAGER
IT_SELECTEDITEM | in file TDataGrid.php, class constant TDataGrid::IT_SELECTEDITEM
IT_SEPARATOR | in file TDataGrid.php, class constant TDataGrid::IT_SEPARATOR
IT_SEPARATOR | in file TRepeater.php, class constant TRepeater::IT_SEPARATOR
top
j
JobTitle | in file TTextBox.php, class constant TTextBoxAutoCompleteType::JobTitle
Justify | in file TStyle.php, class constant THorizontalAlign::Justify
top
l
LastName | in file TTextBox.php, class constant TTextBoxAutoCompleteType::LastName
Left | in file TTable.php, class constant TTableCaptionAlign::Left
Left | in file TStyle.php, class constant THorizontalAlign::Left
Left | in file TCheckBox.php, class constant TTextAlign::Left
Left | in file TInlineFrame.php, class constant TInlineFrameAlign::Left
LeftToRight | in file TPanelStyle.php, class constant TContentDirection::LeftToRight
LessThan | in file TCompareValidator.php, class constant TValidationCompareOperator::LessThan
LessThanEqual | in file TCompareValidator.php, class constant TValidationCompareOperator::LessThanEqual
Li | in file TTextHighlighter.php, class constant TTextHighlighterLineNumberStyle::Li
Link | in file TWizard.php, class constant TWizardNavigationButtonType::Link
LinkButton | in file TPager.php, class constant TPagerButtonType::LinkButton
LinkButton | in file TDataGrid.php, class constant TDataGridPagerButtonType::LinkButton
LinkButton | in file TBulletedList.php, class constant TBulletedListDisplayMode::LinkButton
LinkButton | in file TDataGridColumn.php, class constant TButtonColumnType::LinkButton
listIndexChanged in file TPager.php, method TPager::listIndexChanged()
Event handler to the OnSelectedIndexChanged event of the dropdown list.
loadJavascriptLibrary | in file THtmlArea.php, method THtmlArea::loadJavascriptLibrary()
loadPostData in file TTextBox.php, method TTextBox::loadPostData()
Loads user input data.
loadPostData in file TRadioButton.php, method TRadioButton::loadPostData()
Loads user input data.
loadPostData in file TListBox.php, method TListBox::loadPostData()
Loads user input data.
loadPostData in file TSlider.php, method TSlider::loadPostData()
Loads user input data.
loadPostData in file TRadioButtonList.php, method TRadioButtonList::loadPostData()
Loads user input data.
loadPostData in file TTabPanel.php, method TTabPanel::loadPostData()
Loads user input data.
loadPostData in file TImageButton.php, method TImageButton::loadPostData()
This method checks if the TImageButton is clicked and loads the coordinates of the clicking position.
loadPostData in file TFileUpload.php, method TFileUpload::loadPostData()
Loads user input data.
loadPostData in file TDatePicker.php, method TDatePicker::loadPostData()
Loads user input data. Override parent implementation, when InputMode is DropDownList call getDateFromPostData to get date data.
loadPostData in file TCheckBoxList.php, method TCheckBoxList::loadPostData()
Loads user input data.
loadPostData in file TCheckBox.php, method TCheckBox::loadPostData()
Loads user input data.
loadPostData in file THiddenField.php, method THiddenField::loadPostData()
Loads hidden field data.
loadPostData in file TDropDownList.php, method TDropDownList::loadPostData()
Loads user input data.
loadPostData in file TAccordion.php, method TAccordion::loadPostData()
Loads user input data.
loadRecursive in file TOutputCache.php, method TOutputCache::loadRecursive()
Performs the Load step for the control and all its child controls.
loadState in file TDataGridColumn.php, method TDataGridColumn::loadState()
Loads persistent state values.
loadState in file TDataGrid.php, method TDataGrid::loadState()
Loads item count information from viewstate.
loadState in file TMultiView.php, method TMultiView::loadState()
Loads state into the wizard.
loadState in file TPager.php, method TPager::loadState()
Restores the pager state.
loadState in file TDataList.php, method TDataList::loadState()
Loads item count information from viewstate.
loadState in file TDropDownListColumn.php, method TDropDownListColumn::loadState()
Loads items from viewstate.
loadState in file TListControl.php, method TListControl::loadState()
Loads items from viewstate.
loadState in file TRepeater.php, method TRepeater::loadState()
Loads item count information from viewstate.
loadStateRecursive in file TOutputCache.php, method TOutputCache::loadStateRecursive()
Loads state (viewstate and controlstate) into a control and its children.
LowerAlpha | in file TBulletedList.php, class constant TBulletStyle::LowerAlpha
LowerRoman | in file TBulletedList.php, class constant TBulletStyle::LowerRoman
top
m
MAP_NAME_PREFIX | in file TImageMap.php, class constant TImageMap::MAP_NAME_PREFIX
MAX_FILE_SIZE in file TFileUpload.php, class constant TFileUpload::MAX_FILE_SIZE
Maximum file size (in bytes) allowed to be uploaded, defaults to 1MB.
MAX_STEPS | in file TSlider.php, class constant TSlider::MAX_STEPS
MAX_TOKEN_LENGTH | in file TCaptcha.php, class constant TCaptcha::MAX_TOKEN_LENGTH
mergeWith in file TStyle.php, method TStyle::mergeWith()
Merges the style with a new one.
mergeWith in file TStyle.php, method TTableItemStyle::mergeWith()
Merges the style with a new one.
mergeWith in file TStyle.php, method TTableStyle::mergeWith()
Merges the style with a new one.
mergeWith in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::mergeWith()
Merges the style with a new one.
mergeWith in file TPanelStyle.php, method TPanelStyle::mergeWith()
Merges the style with a new one.
mergeWith in file TFont.php, method TFont::mergeWith()
Merges the font with a new one.
mergeWith in file TDataGridPagerStyle.php, method TDataGridPagerStyle::mergeWith()
Merges the style with a new one.
Middle | in file TInlineFrame.php, class constant TInlineFrameAlign::Middle
Middle | in file TStyle.php, class constant TVerticalAlign::Middle
MiddleName | in file TTextBox.php, class constant TTextBoxAutoCompleteType::MiddleName
MIN_TOKEN_LENGTH | in file TCaptcha.php, class constant TCaptcha::MIN_TOKEN_LENGTH
MultiLine | in file TTextBox.php, class constant TTextBoxMode::MultiLine
Multiple | in file TListBox.php, class constant TListSelectionMode::Multiple
top
n
Navigate | in file TImageMap.php, class constant THotSpotMode::Navigate
needPostBackScript | in file TButton.php, method TButton::needPostBackScript()
needPostBackScript | in file TImageButton.php, method TImageButton::needPostBackScript()
NextPrev | in file TPager.php, class constant TPagerMode::NextPrev
NextPrev | in file TDataGrid.php, class constant TDataGridPagerMode::NextPrev
None | in file TPanelStyle.php, class constant TScrollBars::None
None | in file TStyle.php, class constant TDisplayStyle::None
None | in file TValidationSummary.php, class constant TValidationSummaryDisplayStyle::None
None | in file TTextBox.php, class constant TTextBoxAutoCompleteType::None
None | in file TStyle.php, class constant TTableGridLines::None
None | in file TBaseValidator.php, class constant TValidatorDisplayStyle::None
None | in file TInlineFrame.php, class constant TInlineFrameScrollBars::None
None | in file TBulletedList.php, class constant TBulletStyle::None
NotEqual | in file TCompareValidator.php, class constant TValidationCompareOperator::NotEqual
Notes | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Notes
NotSet | in file TTable.php, class constant TTableCaptionAlign::NotSet
NotSet | in file TBulletedList.php, class constant TBulletStyle::NotSet
NotSet | in file TStyle.php, class constant TVerticalAlign::NotSet
NotSet | in file TTableHeaderCell.php, class constant TTableHeaderScope::NotSet
NotSet | in file TStyle.php, class constant THorizontalAlign::NotSet
NotSet | in file TPanelStyle.php, class constant TContentDirection::NotSet
NotSet | in file TInlineFrame.php, class constant TInlineFrameAlign::NotSet
NotSet | in file TImageMap.php, class constant THotSpotMode::NotSet
Numbered | in file TBulletedList.php, class constant TBulletStyle::Numbered
Numeric | in file TDataGrid.php, class constant TDataGridPagerMode::Numeric
Numeric | in file TPager.php, class constant TPagerMode::Numeric
top
o
Office | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Office
onActivate in file TMultiView.php, method TView::onActivate()
Raises OnActivate event.
onActiveStepChanged in file TWizard.php, method TWizard::onActiveStepChanged()
Raises OnActiveStepChanged event.
onActiveViewChanged in file TMultiView.php, method TMultiView::onActiveViewChanged()
Raises OnActiveViewChanged event.
onCalculateKey in file TOutputCache.php, method TOutputCache::onCalculateKey()
This event is raised when the output cache is calculating cache key.
onCancelButtonClick in file TWizard.php, method TWizard::onCancelButtonClick()
Raises OnCancelButtonClick event.
onCancelCommand in file TDataGrid.php, method TDataGrid::onCancelCommand()
Raises OnCancelCommand event.
onCancelCommand in file TDataList.php, method TDataList::onCancelCommand()
Raises OnCancelCommand event.
onCheckDependency in file TOutputCache.php, method TOutputCache::onCheckDependency()
This event is raised when the output cache is checking cache dependency.
onCheckedChanged in file TCheckBox.php, method TCheckBox::onCheckedChanged()
Raises OnCheckedChanged event when getChecked changes value during postback.
onClick in file TImageMap.php, method TImageMap::onClick()
Raises OnClick event.
onClick in file TImageButton.php, method TImageButton::onClick()
This method is invoked when the button is clicked.
onClick in file TBulletedList.php, method TBulletedList::onClick()
Raises 'OnClick' event.
onClick in file TButton.php, method TButton::onClick()
This method is invoked when the button is clicked.
onClick in file TLinkButton.php, method TLinkButton::onClick()
This method is invoked when the button is clicked.
onCommand in file TButton.php, method TButton::onCommand()
This method is invoked when the button is clicked.
onCommand in file TImageButton.php, method TImageButton::onCommand()
This method is invoked when the button is clicked.
onCommand in file TLinkButton.php, method TLinkButton::onCommand()
This method is invoked when the button is clicked.
onCompleteButtonClick in file TWizard.php, method TWizard::onCompleteButtonClick()
Raises OnCompleteButtonClick event.
onDataBound in file TDataBoundControl.php, method TDataBoundControl::onDataBound()
Raises OnDataBound event.
onDataSourceChanged | in file TDataSourceControl.php, method IDataSource::onDataSourceChanged()
onDataSourceChanged in file TDataBoundControl.php, method TDataBoundControl::onDataSourceChanged()
Sets setRequiresDataBinding as true if the control is initialized.
onDataSourceChanged | in file TDataSourceControl.php, method TDataSourceControl::onDataSourceChanged()
onDataSourceViewChanged | in file TDataSourceView.php, method TDataSourceView::onDataSourceViewChanged()
onDeactivate in file TMultiView.php, method TView::onDeactivate()
Raises OnDeactivate event.
onDeleteCommand in file TDataList.php, method TDataList::onDeleteCommand()
Raises OnDeleteCommand event.
onDeleteCommand in file TDataGrid.php, method TDataGrid::onDeleteCommand()
Raises OnDeleteCommand event.
onEditCommand in file TDataGrid.php, method TDataGrid::onEditCommand()
Raises OnEditCommand event.
onEditCommand in file TDataList.php, method TDataList::onEditCommand()
Raises OnEditCommand event.
onFileUpload in file TFileUpload.php, method TFileUpload::onFileUpload()
This method is invoked when a file is uploaded during a postback.
onInit in file TWizard.php, method TWizard::onInit()
Creates the child controls of the wizard.
onInit in file TDataBoundControl.php, method TDataBoundControl::onInit()
Sets page's OnPreLoad event handler as pagePreLoad.
onInit in file TWizard.php, method TTemplatedWizardStep::onInit()
Ensures child controls are created.
onInit in file TMultiView.php, method TMultiView::onInit()
Initializes the active view if any.
onInit in file TRadioButton.php, method TRadioButton::onInit()
Registers the radio button groupings. If overriding onInit method, ensure to call parent implemenation.
onInit in file TBaseValidator.php, method TBaseValidator::onInit()
Registers the validator with page.
onItemCommand in file TDataGrid.php, method TDataGrid::onItemCommand()
Raises OnItemCommand event.
onItemCommand in file TRepeater.php, method TRepeater::onItemCommand()
Raises OnItemCommand event.
onItemCommand in file TDataList.php, method TDataList::onItemCommand()
Raises OnItemCommand event.
onItemCreated in file TDataList.php, method TDataList::onItemCreated()
Raises OnItemCreated event.
onItemCreated in file TRepeater.php, method TRepeater::onItemCreated()
Raises OnItemCreated event.
onItemCreated in file TDataGrid.php, method TDataGrid::onItemCreated()
Raises OnItemCreated event.
onItemDataBound in file TRepeater.php, method TRepeater::onItemDataBound()
Raises OnItemDataBound event.
onItemDataBound in file TDataGrid.php, method TDataGrid::onItemDataBound()
Raises OnItemDataBound event.
onItemDataBound in file TDataList.php, method TDataList::onItemDataBound()
Raises OnItemDataBound event.
onNextButtonClick in file TWizard.php, method TWizard::onNextButtonClick()
Raises OnNextButtonClick event.
onPageIndexChanged in file TPager.php, method TPager::onPageIndexChanged()
This event is raised when page index is changed due to a page button click.
onPageIndexChanged in file TDataGrid.php, method TDataGrid::onPageIndexChanged()
Raises OnPageIndexChanged event.
onPagerCreated in file TDataGrid.php, method TDataGrid::onPagerCreated()
Raises OnPagerCreated event.
onPreRender in file TTabPanel.php, method TTabPanel::onPreRender()
Registers CSS and JS.
onPreRender in file TTextHighlighter.php, method TTextHighlighter::onPreRender()
Registers css style for the highlighted result.
onPreRender in file TWebControl.php, method TWebControl::onPreRender()
If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
onPreRender in file TStyleSheet.php, method TStyleSheet::onPreRender()
Registers the stylesheet file and content to be rendered.
onPreRender in file TSlider.php, method TSlider::onPreRender()
Registers CSS and JS.
onPreRender in file TReCaptcha.php, method TReCaptcha::onPreRender()
Checks for API keys
onPreRender | in file TReCaptchaValidator.php, method TReCaptchaValidator::onPreRender()
onPreRender in file TPager.php, method TPager::onPreRender()
Performs databinding to populate data items from data source.
onPreRender in file TRatingList.php, method TRatingList::onPreRender()
Publish the the rating style css file and rating image files.
onPreRender in file TFileUpload.php, method TFileUpload::onPreRender()
Sets Enctype of the form on the page.
onPreRender in file TCaptcha.php, method TCaptcha::onPreRender()
Configures the image URL that shows the token.
onPreRender in file TBaseValidator.php, method TBaseValidator::onPreRender()
Override parent implementation to update the control CSS Class before
onPreRender in file TDatePicker.php, method TDatePicker::onPreRender()
Publish the date picker Css asset files.
onPreRender in file TCheckBox.php, method TCheckBox::onPreRender()
Registers the checkbox to receive postback data during postback.
onPreRender in file TDataBoundControl.php, method TDataBoundControl::onPreRender()
Ensures any pending databind is performed.
onPreRender in file TClientScript.php, method TClientScript::onPreRender()
Calls the client script manager to add each of the requested client script libraries.
onPreRender in file TCheckBoxList.php, method TCheckBoxList::onPreRender()
Registers for post data on postback.
onPreRender in file TColorPicker.php, method TColorPicker::onPreRender()
Publish the color picker Css asset files.
onPreRender in file TAccordion.php, method TAccordion::onPreRender()
Registers CSS and JS.
onPreRender in file TKeyboard.php, method TKeyboard::onPreRender()
Registers CSS and JS.
onPreRender in file TListBox.php, method TListBox::onPreRender()
Registers the list control to load post data on postback.
onPreRender in file TJavascriptLogger.php, method TJavascriptLogger::onPreRender()
Registers the required logger javascript.
onPreRender in file TImageButton.php, method TImageButton::onPreRender()
Registers the image button to receive postback data during postback.
onPreviousButtonClick in file TWizard.php, method TWizard::onPreviousButtonClick()
Raises OnPreviousButtonClick event.
onSelectedIndexChanged in file TListControl.php, method TListControl::onSelectedIndexChanged()
Raises OnSelectedIndexChanged event when selection is changed.
onSelectedIndexChanged in file TBaseDataList.php, method TBaseDataList::onSelectedIndexChanged()
Raises OnSelectedIndexChanged event.
onSelectedIndexChanged | in file TRatingList.php, method TRatingList::onSelectedIndexChanged()
onServerValidate in file TCustomValidator.php, method TCustomValidator::onServerValidate()
This method is invoked when the server side validation happens.
onSideBarButtonClick in file TWizard.php, method TWizard::onSideBarButtonClick()
Raises OnSideBarButtonClick event.
onSortCommand in file TDataGrid.php, method TDataGrid::onSortCommand()
Raises OnSortCommand event.
onTextChanged in file TListControl.php, method TListControl::onTextChanged()
Raises OnTextChanged event when selection is changed.
onTextChanged in file TTextBox.php, method TTextBox::onTextChanged()
Raises OnTextChanged event.
onUnload in file TBaseValidator.php, method TBaseValidator::onUnload()
Unregisters the validator from page.
onUnLoad in file TRadioButton.php, method TRadioButton::onUnLoad()
Unregisters the radio button groupings. If overriding onInit method, ensure to call parent implemenation.
onUpdateCommand in file TDataGrid.php, method TDataGrid::onUpdateCommand()
Raises OnUpdateCommand event.
onUpdateCommand in file TDataList.php, method TDataList::onUpdateCommand()
Raises OnUpdateCommand event.
onValidate in file TBaseValidator.php, method TBaseValidator::onValidate()
This event is raised right before the validator starts to perform validation.
onValidationError in file TBaseValidator.php, method TBaseValidator::onValidationError()
This event is raised when the validator fails in validation.
onValidationSuccess in file TBaseValidator.php, method TBaseValidator::onValidationSuccess()
This event is raised when the validator succeeds in validation.
onValueChanged in file THiddenField.php, method THiddenField::onValueChanged()
This method is invoked when the value of the getValue property changes between posts to the server.
onValueChanged in file TSlider.php, method TSlider::onValueChanged()
Raises OnValueChanged event.
top
p
pagePreLoad in file TDataBoundControl.php, method TDataBoundControl::pagePreLoad()
Sets getInitialized as true.
Pager | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Pager
Pager | in file TDataBoundControl.php, class constant TListItemType::Pager
parseEditorOptions in file THtmlArea.php, method THtmlArea::parseEditorOptions()
Parse additional options set in the Options property.
parseSafeHtml in file TSafeHtml.php, method TSafeHtml::parseSafeHtml()
Use SafeHTML to remove malicous javascript from the HTML content.
Password | in file TTextBox.php, class constant TTextBoxMode::Password
performDataBinding in file TRepeater.php, method TRepeater::performDataBinding()
Performs databinding to populate repeater items from data source.
performDataBinding | in file TDataBoundControl.php, method TDataBoundControl::performDataBinding()
performDataBinding in file TDataGrid.php, method TDataGrid::performDataBinding()
Performs databinding to populate datagrid items from data source.
performDataBinding in file TDataList.php, method TDataList::performDataBinding()
Performs databinding to populate data list items from data source.
performDataBinding in file TListControl.php, method TListControl::performDataBinding()
Performs databinding to populate list items from data source.
PostBack | in file TImageMap.php, class constant THotSpotMode::PostBack
preRenderRecursive in file TOutputCache.php, method TOutputCache::preRenderRecursive()
Performs the PreRender step for the control and all its child controls.
processText in file TMarkdown.php, method TMarkdown::processText()
Processes a text string.
processText in file TTextHighlighter.php, method TTextHighlighter::processText()
Processes a text string.
publishCalendarStyle in file TDatePicker.php, method TDatePicker::publishCalendarStyle()
Publish the calendar style Css asset file.
publishColorPickerAssets in file TColorPicker.php, method TColorPicker::publishColorPickerAssets()
Publish the color picker assets.
publishImages | in file TRatingList.php, method TRatingList::publishImages()
publishStyle | in file TRatingList.php, method TRatingList::publishStyle()
PushButton | in file TPager.php, class constant TPagerButtonType::PushButton
PushButton | in file TDataGrid.php, class constant TDataGridPagerButtonType::PushButton
PushButton | in file TDataGridColumn.php, class constant TButtonColumnType::PushButton
top
r
raisePostBackEvent in file TImageButton.php, method TImageButton::raisePostBackEvent()
Raises the postback event.
raisePostBackEvent in file TBulletedList.php, method TBulletedList::raisePostBackEvent()
Raises the postback event.
raisePostBackEvent in file TImageMap.php, method TImageMap::raisePostBackEvent()
Raises the postback event.
raisePostBackEvent in file TLinkButton.php, method TLinkButton::raisePostBackEvent()
Raises the postback event.
raisePostBackEvent in file TButton.php, method TButton::raisePostBackEvent()
Raises the postback event.
raisePostDataChangedEvent in file TFileUpload.php, method TFileUpload::raisePostDataChangedEvent()
Raises postdata changed event.
raisePostDataChangedEvent in file TCheckBox.php, method TCheckBox::raisePostDataChangedEvent()
Raises postdata changed event.
raisePostDataChangedEvent in file TDropDownList.php, method TDropDownList::raisePostDataChangedEvent()
Raises postdata changed event.
raisePostDataChangedEvent in file TCheckBoxList.php, method TCheckBoxList::raisePostDataChangedEvent()
Raises postdata changed event.
raisePostDataChangedEvent in file THiddenField.php, method THiddenField::raisePostDataChangedEvent()
Raises postdata changed event.
raisePostDataChangedEvent in file TTabPanel.php, method TTabPanel::raisePostDataChangedEvent()
Raises postdata changed event.
raisePostDataChangedEvent in file TTextBox.php, method TTextBox::raisePostDataChangedEvent()
Raises postdata changed event.
raisePostDataChangedEvent in file TImageButton.php, method TImageButton::raisePostDataChangedEvent()
A dummy implementation for the IPostBackDataHandler interface.
raisePostDataChangedEvent in file TListBox.php, method TListBox::raisePostDataChangedEvent()
Raises postdata changed event.
raisePostDataChangedEvent in file TAccordion.php, method TAccordion::raisePostDataChangedEvent()
Raises postdata changed event.
raisePostDataChangedEvent in file TSlider.php, method TSlider::raisePostDataChangedEvent()
Raises postdata changed event.
Raw | in file TRepeatInfo.php, class constant TRepeatLayout::Raw
regenerateToken in file TCaptcha.php, method TCaptcha::regenerateToken()
Regenerates the token to be displayed.
regenerateToken | in file TReCaptcha.php, method TReCaptcha::regenerateToken()
registerAction in file TOutputCache.php, method TOutputCache::registerAction()
Registers an action associated with the content being cached.
registerCalendarClientScriptPost | in file TDatePicker.php, method TDatePicker::registerCalendarClientScriptPost()
registerCalendarClientScriptPre in file TDatePicker.php, method TDatePicker::registerCalendarClientScriptPre()
Registers the javascript code to initialize the date picker.
registerClientScript in file TKeyboard.php, method TKeyboard::registerClientScript()
Registers the relevant JavaScript.
registerClientScript in file TTabPanel.php, method TTabPanel::registerClientScript()
Registers the relevant JavaScript.
registerClientScript in file TAccordion.php, method TAccordion::registerClientScript()
Registers the relevant JavaScript.
registerClientScript in file TRatingList.php, method TRatingList::registerClientScript()
Registers the relevant JavaScript.
registerClientScriptValidator in file TCustomValidator.php, method TCustomValidator::registerClientScriptValidator()
Only register the client-side validator if setClientValidationFunction is set.
registerClientScriptValidator in file TBaseValidator.php, method TBaseValidator::registerClientScriptValidator()
Registers the individual validator client-side javascript code.
registerEditorClientScript in file THtmlArea.php, method THtmlArea::registerEditorClientScript()
Registers the editor javascript file and code to initialize the editor.
registerSliderClientScript in file TSlider.php, method TSlider::registerSliderClientScript()
Registers the javascript code to initialize the slider.
registerStyleSheet in file TTabPanel.php, method TTabPanel::registerStyleSheet()
Registers the CSS relevant to the TTabControl.
registerStyleSheet in file TTextHighlighter.php, method TTextHighlighter::registerStyleSheet()
Registers the stylesheet for presentation.
registerStyleSheet in file TKeyboard.php, method TKeyboard::registerStyleSheet()
Registers the CSS relevant to the TKeyboard.
registerStyleSheet in file TSlider.php, method TSlider::registerStyleSheet()
Registers the CSS relevant to the TSlider.
registerStyleSheet in file TAccordion.php, method TAccordion::registerStyleSheet()
Registers the CSS relevant to the TAccordion.
removeAt in file TWizard.php, method TWizardStepCollection::removeAt()
Removes an item at the specified position.
removeAttribute in file TListItem.php, method TListItem::removeAttribute()
Removes the named attribute.
removeAttribute in file TImageMap.php, method THotSpot::removeAttribute()
Removes the named attribute.
removedWizardStep in file TWizard.php, method TWizard::removedWizardStep()
Removes a wizard step from the multiview.
render in file TSafeHtml.php, method TSafeHtml::render()
Renders body content.
render in file TDatePicker.php, method TDatePicker::render()
Renders body content.
render in file TWizard.php, method TWizard::render()
Renders the wizard.
render in file TStatements.php, method TStatements::render()
Renders the evaluation result of the statements.
render in file THead.php, method TMetaTag::render()
Renders the meta tag.
render in file TBulletedList.php, method TBulletedList::render()
Renders the control.
render in file THiddenField.php, method THiddenField::render()
Renders the control.
render in file TFlushOutput.php, method TFlushOutput::render()
Flushes the output of all completely rendered controls to the client.
render in file TExpression.php, method TExpression::render()
Renders the evaluation result of the expression.
render in file TStyleSheet.php, method TStyleSheet::render()
Renders the control.
render in file TImageMap.php, method THotSpot::render()
Renders this hotspot.
render in file TImageMap.php, method TImageMap::render()
Renders this imagemap.
render | in file TAccordion.php, method TAccordion::render()
render in file TCheckBoxList.php, method TCheckBoxList::render()
Renders the checkbox list control.
render in file TOutputCache.php, method TOutputCache::render()
Renders the output cache control.
render in file TClientScript.php, method TClientScript::render()
Renders the body content as javascript block.
render in file TPager.php, method TPager::render()
Renders the control.
render | in file TTextHighlighter.php, method TTextHighlighter::render()
render in file TWebControl.php, method TWebControl::render()
Renders the control.
render in file TCheckBox.php, method TCheckBox::render()
Renders the checkbox control.
render | in file TPanel.php, method TPanel::render()
render in file TMultiView.php, method TMultiView::render()
Renders the currently active view.
render in file TLiteral.php, method TLiteral::render()
Renders the literal control.
render in file TDataListItemRenderer.php, method TDataListItemRenderer::render()
Renders the control.
render in file TXmlTransform.php, method TXmlTransform::render()
Performs XSL transformation and render the output.
render in file TRepeater.php, method TRepeater::render()
Renders the repeater.
render in file TWebControlAdapter.php, method TWebControlAdapter::render()
Renders the control to which the adapter is attached.
render in file TDataList.php, method TDataList::render()
Renders the data list control.
render in file TRatingList.php, method TRatingList::render()
Add rating style class name to the class attribute when setReadOnly property is true and when the setCssClass property is empty.
render in file TLabel.php, method TLabel::render()
Renders the label.
render | in file TTabPanel.php, method TTabPanel::render()
render in file TDataGrid.php, method TDataGrid::render()
Renders the datagrid.
renderBeginTag in file TPanel.php, method TPanel::renderBeginTag()
Renders the openning tag for the control (including attributes)
renderBeginTag in file TWebControlAdapter.php, method TWebControlAdapter::renderBeginTag()
Renders the openning tag for the attached control.
renderBeginTag in file TDataListItemRenderer.php, method TDataListItemRenderer::renderBeginTag()
Renders the openning tag for the control (including attributes) This method is invoked when getTagName is not empty.
renderBeginTag in file TTable.php, method TTable::renderBeginTag()
Renders the openning tag for the table control which will render table caption if present.
renderBeginTag in file TWebControl.php, method TWebControl::renderBeginTag()
Renders the openning tag for the control (including attributes)
renderBeginTag in file TDataGrid.php, method TDataGrid::renderBeginTag()
Renders the openning tag for the datagrid control which will render table caption if present.
renderBeginTag in file TTextBox.php, method TTextBox::renderBeginTag()
Renders an additional line-break after the opening tag when it is in MultiLine text mode.
renderBulletList in file TValidationSummary.php, method TValidationSummary::renderBulletList()
Render the validation summary as a bullet list.
renderBulletText in file TBulletedList.php, method TBulletedList::renderBulletText()
Renders each item
renderButtonDatePicker in file TDatePicker.php, method TDatePicker::renderButtonDatePicker()
Adds an additional button such that when clicked it shows the date picker.
renderCalendarDayOptions in file TDatePicker.php, method TDatePicker::renderCalendarDayOptions()
Renders the day drop down list options.
renderCalendarMonthOptions in file TDatePicker.php, method TDatePicker::renderCalendarMonthOptions()
Renders the month drop down list options.
renderCalendarSelections in file TDatePicker.php, method TDatePicker::renderCalendarSelections()
Renders the calendar drop down list depending on the DateFormat pattern.
renderCalendarYearOptions in file TDatePicker.php, method TDatePicker::renderCalendarYearOptions()
Renders the year drop down list options.
renderClientControlScript in file TListControl.php, method TListControl::renderClientControlScript()
Renders the javascript for list control.
renderClientControlScript in file TButton.php, method TButton::renderClientControlScript()
Renders the client-script code.
renderClientControlScript in file TCheckBox.php, method TCheckBox::renderClientControlScript()
Renders the client-script code.
renderClientControlScript in file TTextBox.php, method TTextBox::renderClientControlScript()
Renders the javascript for textbox.
renderClientControlScript in file TLinkButton.php, method TLinkButton::renderClientControlScript()
Renders the client-script code.
renderClientControlScript in file TRadioButton.php, method TRadioButton::renderClientControlScript()
Renders the client-script code.
renderClientControlScript in file TImageButton.php, method TImageButton::renderClientControlScript()
Renders the client-script code.
renderClientControlScript in file TBaseValidator.php, method TBaseValidator::renderClientControlScript()
Renders the javascript code to the end script.
renderContents in file TTextBox.php, method TTextBox::renderContents()
Renders the body content of the textbox when it is in MultiLine text mode.
renderContents in file TSlider.php, method TSlider::renderContents()
Render the body content
renderContents in file TTable.php, method TTable::renderContents()
Renders body contents of the table.
renderContents in file TValidationSummary.php, method TValidationSummary::renderContents()
Overrides parent implementation by rendering TValidationSummary-specific presentation.
renderContents in file TWebControl.php, method TWebControl::renderContents()
Renders the body content enclosed between the control tag.
renderContents in file TWebControlAdapter.php, method TWebControlAdapter::renderContents()
Renders the body contents within the attached control tag.
renderContents in file TTableRow.php, method TTableRow::renderContents()
Renders body contents of the table row
renderContents in file TTabPanel.php, method TTabPanel::renderContents()
Renders body contents of the tab control.
renderContents in file TTabPanel.php, method TTabView::renderContents()
Renders body contents of the tab view.
renderContents in file TTableCell.php, method TTableCell::renderContents()
Renders body contents of the table cell.
renderContents | in file TReCaptcha.php, method TReCaptcha::renderContents()
renderContents in file TLinkButton.php, method TLinkButton::renderContents()
Renders the body content enclosed between the control tag.
renderContents in file TDataListItemRenderer.php, method TDataListItemRenderer::renderContents()
Renders the body content enclosed between the control tag.
renderContents in file TBulletedList.php, method TBulletedList::renderContents()
Renders the body contents.
renderContents in file THyperLink.php, method THyperLink::renderContents()
Renders the body content of the hyperlink.
renderContents in file TButton.php, method TButton::renderContents()
Renders the body content enclosed between the control tag.
renderContents in file TJavascriptLogger.php, method TJavascriptLogger::renderContents()
Register the required javascript libraries and display some general usage information.
renderContents in file TImage.php, method TImage::renderContents()
Renders the body content of the image.
renderContents in file TImageButton.php, method TImageButton::renderContents()
Renders the body content enclosed between the control tag.
renderContents in file TLabel.php, method TLabel::renderContents()
Renders the body content of the label.
renderContents in file TBaseValidator.php, method TBaseValidator::renderContents()
Renders the validator control.
renderContents in file TAccordion.php, method TAccordion::renderContents()
Renders body contents of the accordion control.
renderContents in file TAccordion.php, method TAccordionView::renderContents()
Renders body contents of the accordion view.
renderContents in file TListControl.php, method TListControl::renderContents()
Renders body content of the list control.
renderCustomScript in file TClientScript.php, method TClientScript::renderCustomScript()
Registers the body content as javascript.
renderCustomScriptFile in file TClientScript.php, method TClientScript::renderCustomScriptFile()
Renders the custom script file.
renderDatePickerButtons in file TDatePicker.php, method TDatePicker::renderDatePickerButtons()
Renders the date picker popup buttons.
renderDropDownListCalendar in file TDatePicker.php, method TDatePicker::renderDropDownListCalendar()
Renders the drop down list date picker.
renderEndTag in file TColorPicker.php, method TColorPicker::renderEndTag()
Renders additional body content.
renderEndTag in file TDataListItemRenderer.php, method TDataListItemRenderer::renderEndTag()
Renders the closing tag for the control This method is invoked when getTagName is not empty.
renderEndTag in file TWebControl.php, method TWebControl::renderEndTag()
Renders the closing tag for the control
renderEndTag in file TPanel.php, method TPanel::renderEndTag()
Renders the closing tag for the control
renderEndTag in file TWebControlAdapter.php, method TWebControlAdapter::renderEndTag()
Renders the closing tag for the attached control.
renderFooter in file TRepeatInfo.php, method TRepeatInfo::renderFooter()
Renders footer.
renderHeader in file TRepeatInfo.php, method TRepeatInfo::renderHeader()
Renders header.
renderHeader in file TAccordion.php, method TAccordionView::renderHeader()
Renders the header associated with the accordion view.
renderHeaderContent in file TAccordion.php, method TAccordionView::renderHeaderContent()
Renders the content in the header.
renderHeaderOnly in file TValidationSummary.php, method TValidationSummary::renderHeaderOnly()
Render the validation summary header text only.
renderHorizontalContents in file TRepeatInfo.php, method TRepeatInfo::renderHorizontalContents()
Renders contents in horizontal repeat direction.
renderHyperLinkItem | in file TBulletedList.php, method TBulletedList::renderHyperLinkItem()
renderImageButtonDatePicker in file TDatePicker.php, method TDatePicker::renderImageButtonDatePicker()
Adds an additional image button such that when clicked it shows the date picker.
renderInputTag in file TRadioButton.php, method TRadioButton::renderInputTag()
Renders a radiobutton input element.
renderInputTag in file TCheckBox.php, method TCheckBox::renderInputTag()
Renders a checkbox input element.
renderItem in file TCheckBoxList.php, method TCheckBoxList::renderItem()
Renders an item in the list.
renderItem in file TDataList.php, method TDataList::renderItem()
Renders an item in the list.
renderItem in file TRepeatInfo.php, method IRepeatInfoUser::renderItem()
Renders an item.
renderJsSummary in file TValidationSummary.php, method TValidationSummary::renderJsSummary()
Render the javascript for validation summary.
renderLabel in file TCheckBox.php, method TCheckBox::renderLabel()
Renders a label beside the checkbox.
renderLinkButtonHref in file TLinkButton.php, method TLinkButton::renderLinkButtonHref()
Renders the Href for link button.
renderLinkButtonItem | in file TBulletedList.php, method TBulletedList::renderLinkButtonItem()
renderList in file TValidationSummary.php, method TValidationSummary::renderList()
Render the validation summary as a simple list.
renderPostContentsText in file TWebControlDecorator.php, method TWebControlDecorator::renderPostContentsText()
This method places the post contents text into the TTextWriter
renderPostTagText in file TWebControlDecorator.php, method TWebControlDecorator::renderPostTagText()
This method places the post tag text into the TTextWriter
renderPreContentsText in file TWebControlDecorator.php, method TWebControlDecorator::renderPreContentsText()
This method places the pre contents text into the TTextWriter
renderPreTagText in file TWebControlDecorator.php, method TWebControlDecorator::renderPreTagText()
This method places the pre tag text into the TTextWriter
renderPrompt in file TListControl.php, method TListControl::renderPrompt()
Renders the prompt text, if any.
renderRawContents in file TRepeatInfo.php, method TRepeatInfo::renderRawContents()
Renders contents in raw format.
renderRepeater in file TRepeatInfo.php, method TRepeatInfo::renderRepeater()
Renders the repeated items.
renderSingleParagraph in file TValidationSummary.php, method TValidationSummary::renderSingleParagraph()
Render the validation summary as a paragraph.
renderTab in file TTabPanel.php, method TTabView::renderTab()
Renders the tab associated with the tab view.
renderTabContent in file TTabPanel.php, method TTabView::renderTabContent()
Renders the content in the tab.
renderTable in file TDataGrid.php, method TDataGrid::renderTable()
Renders the tabular data.
renderTextItem | in file TBulletedList.php, method TBulletedList::renderTextItem()
renderVerticalContents in file TRepeatInfo.php, method TRepeatInfo::renderVerticalContents()
Renders contents in veritcal repeat direction.
requiresControlsRecreation in file TWizard.php, method TWizard::requiresControlsRecreation()
Indicates the wizard needs to recreate all child controls.
reset in file TDataList.php, method TDataList::reset()
Clears up all items in the data list.
reset in file TStyle.php, method TTableItemStyle::reset()
Sets the style attributes to default values.
reset in file TStyle.php, method TTableStyle::reset()
Sets the style attributes to default values.
reset in file TWizard.php, method TWizard::reset()
Clears up everything within the wizard.
reset in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::reset()
Sets the style attributes to default values.
reset in file TDataGrid.php, method TDataGrid::reset()
Clears up all items in the datagrid.
reset in file TStyle.php, method TStyle::reset()
Resets the style to the original empty state.
reset in file TRepeater.php, method TRepeater::reset()
Clears up all items in the repeater.
reset in file TFont.php, method TFont::reset()
Clears up the font.
Reset | in file TButton.php, class constant TButtonType::Reset
reset in file TDataGridPagerStyle.php, method TDataGridPagerStyle::reset()
Resets the style to the original empty state.
reset in file TPanelStyle.php, method TPanelStyle::reset()
Sets the style attributes to default values.
ResponseFieldName | in file TReCaptcha.php, class constant TReCaptcha::ResponseFieldName
restoreGridFromViewState in file TDataGrid.php, method TDataGrid::restoreGridFromViewState()
Restores datagrid content from viewstate.
restoreItemsFromViewState in file TRepeater.php, method TRepeater::restoreItemsFromViewState()
Creates repeater items based on viewstate information.
restoreItemsFromViewState in file TDataList.php, method TDataList::restoreItemsFromViewState()
Creates data list items based on viewstate information.
Right | in file TTable.php, class constant TTableCaptionAlign::Right
Right | in file TInlineFrame.php, class constant TInlineFrameAlign::Right
Right | in file TStyle.php, class constant THorizontalAlign::Right
Right | in file TCheckBox.php, class constant TTextAlign::Right
RightToLeft | in file TPanelStyle.php, class constant TContentDirection::RightToLeft
Row | in file TTableHeaderCell.php, class constant TTableHeaderScope::Row
top
s
saveAs in file TFileUpload.php, method TFileUpload::saveAs()
Saves the uploaded file.
saveState in file TWizard.php, method TWizard::saveState()
Saves the current active step index into history.
saveState in file TListControl.php, method TListControl::saveState()
Saves items into viewstate.
saveState in file TRepeater.php, method TRepeater::saveState()
Saves item count in viewstate.
saveState in file TDropDownListColumn.php, method TDropDownListColumn::saveState()
Saves items into viewstate.
saveState in file TDataGrid.php, method TDataGrid::saveState()
Saves item count in viewstate.
saveState in file TDataGridColumn.php, method TDataGridColumn::saveState()
Saves persistent state values.
saveState in file TDataList.php, method TDataList::saveState()
Saves item count in viewstate.
saveStateRecursive in file TOutputCache.php, method TOutputCache::saveStateRecursive()
Saves all control state (viewstate and controlstate) as a collection.
SCRIPT_PATH | in file TColorPicker.php, class constant TColorPicker::SCRIPT_PATH
SCRIPT_PATH in file TDatePicker.php, class constant TDatePicker::SCRIPT_PATH
Script path relative to the TClientScriptManager::SCRIPT_PATH
SCRIPT_PATH in file TRatingList.php, class constant TRatingList::SCRIPT_PATH
Script path relative to the TClientScriptManager::SCRIPT_PATH
Search | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Search
select in file TDataSourceView.php, method TDataSourceView::select()
Performs DB selection based on specified parameters.
select | in file TDataSourceView.php, method TReadOnlyDataSourceView::select()
SelectedItem | in file TDataBoundControl.php, class constant TListItemType::SelectedItem
Separator | in file TDataBoundControl.php, class constant TListItemType::Separator
setAbbreviatedText | in file TTableHeaderCell.php, method TTableHeaderCell::setAbbreviatedText()
setAccessKey in file TWebControl.php, method TWebControl::setAccessKey()
Sets the access key of the control.
setAccessKey | in file TImageMap.php, method THotSpot::setAccessKey()
setActive | in file TTabPanel.php, method TTabView::setActive()
setActive | in file TAccordion.php, method TAccordionView::setActive()
setActive | in file TMultiView.php, method TView::setActive()
setActiveHeaderCssClass | in file TAccordion.php, method TAccordion::setActiveHeaderCssClass()
setActiveStep | in file TWizard.php, method TWizard::setActiveStep()
setActiveStepIndex | in file TWizard.php, method TWizard::setActiveStepIndex()
setActiveTabCssClass | in file TTabPanel.php, method TTabPanel::setActiveTabCssClass()
setActiveView | in file TMultiView.php, method TMultiView::setActiveView()
setActiveView | in file TTabPanel.php, method TTabPanel::setActiveView()
setActiveView | in file TAccordion.php, method TAccordion::setActiveView()
setActiveViewID | in file TAccordion.php, method TAccordion::setActiveViewID()
setActiveViewID | in file TTabPanel.php, method TTabPanel::setActiveViewID()
setActiveViewIndex | in file TTabPanel.php, method TTabPanel::setActiveViewIndex()
setActiveViewIndex | in file TMultiView.php, method TMultiView::setActiveViewIndex()
setActiveViewIndex | in file TAccordion.php, method TAccordion::setActiveViewIndex()
setAlign | in file TInlineFrame.php, method TInlineFrame::setAlign()
setAllowCustomPaging in file TDataBoundControl.php, method TDataBoundControl::setAllowCustomPaging()
Sets a value indicating whether the custom paging should be enabled.
setAllowInput in file TRatingList.php, method TRatingList::setAllowInput()
Wrapper for setReadOnly property.
setAllowPaging | in file TDataBoundControl.php, method TDataBoundControl::setAllowPaging()
setAllowReturn | in file TWizard.php, method TWizardStep::setAllowReturn()
setAllowSorting | in file TDataGrid.php, method TDataGrid::setAllowSorting()
setAlternateText in file TImage.php, method TImage::setAlternateText()
Sets the alternative text to be displayed in the TImage when the image is unavailable.
setAlternateText | in file TImageMap.php, method THotSpot::setAlternateText()
setAlternatingItemRenderer in file TRepeater.php, method TRepeater::setAlternatingItemRenderer()
Sets the alternative item renderer class.
setAlternatingItemRenderer in file TDataList.php, method TDataList::setAlternatingItemRenderer()
Sets the alternative item renderer class.
setAlternatingItemTemplate | in file TRepeater.php, method TRepeater::setAlternatingItemTemplate()
setAlternatingItemTemplate | in file TDataList.php, method TDataList::setAlternatingItemTemplate()
setAnimationDuration | in file TAccordion.php, method TAccordion::setAnimationDuration()
setAppendDataBoundItems | in file TListControl.php, method TListControl::setAppendDataBoundItems()
setAttribute | in file TListItem.php, method TListItem::setAttribute()
setAttribute in file TImageMap.php, method THotSpot::setAttribute()
Sets a custom hotspot attribute.
setAutoCompleteType | in file TTextBox.php, method TTextBox::setAutoCompleteType()
setAutoGenerateColumns | in file TDataGrid.php, method TDataGrid::setAutoGenerateColumns()
setAutoHide | in file TKeyboard.php, method TKeyboard::setAutoHide()
setAutoPostBack in file TDatePicker.php, method TDatePicker::setAutoPostBack()
AutoPostBack is not supported.
setAutoPostBack in file TCheckBox.php, method TCheckBox::setAutoPostBack()
Sets a value indicating whether clicking on the checkbox will post the page.
setAutoPostBack in file TListControl.php, method TListControl::setAutoPostBack()
Sets the value indicating if postback automatically.
setAutoPostBack | in file TBulletedList.php, method TBulletedList::setAutoPostBack()
setAutoPostBack in file TSlider.php, method TSlider::setAutoPostBack()
Sets the value indicating if postback automatically.
setAutoPostBack in file TTextBox.php, method TTextBox::setAutoPostBack()
Sets the value indicating if postback automatically.
setAutoSwitch | in file TTabPanel.php, method TTabPanel::setAutoSwitch()
setAutoTrim in file TTextBox.php, method TTextBox::setAutoTrim()
Sets the value indicating if the input text should be trimmed spaces
setAutoUpdate in file TValidationSummary.php, method TValidationSummary::setAutoUpdate()
Sets the summary to auto-update on the client-side
setBackColor | in file TStyle.php, method TStyle::setBackColor()
setBackColor | in file TWebControl.php, method TWebControl::setBackColor()
setBackImageUrl in file TPanelStyle.php, method TPanelStyle::setBackImageUrl()
Sets the URL of the background image for the panel component.
setBackImageUrl in file TStyle.php, method TTableStyle::setBackImageUrl()
Sets the URL of the background image for the table
setBackImageUrl in file TTable.php, method TTable::setBackImageUrl()
Sets the URL of the background image for the table
setBackImageUrl in file TPanel.php, method TPanel::setBackImageUrl()
Sets the URL of the background image for the panel component.
setBackImageUrl | in file TDataGrid.php, method TDataGrid::setBackImageUrl()
setBold | in file TFont.php, method TFont::setBold()
setBorderCollapse | in file TStyle.php, method TTableStyle::setBorderCollapse()
setBorderColor | in file TWebControl.php, method TWebControl::setBorderColor()
setBorderColor | in file TStyle.php, method TStyle::setBorderColor()
setBorderStyle in file TStyle.php, method TStyle::setBorderStyle()
Sets the border style of the control.
setBorderStyle | in file TWebControl.php, method TWebControl::setBorderStyle()
setBorderWidth | in file TStyle.php, method TStyle::setBorderWidth()
setBorderWidth | in file TWebControl.php, method TWebControl::setBorderWidth()
setBottom | in file TImageMap.php, method TRectangleHotSpot::setBottom()
setBulletImageUrl | in file TBulletedList.php, method TBulletedList::setBulletImageUrl()
setBulletStyle | in file TBulletedList.php, method TBulletedList::setBulletStyle()
setButtonImageUrl | in file TDatePicker.php, method TDatePicker::setButtonImageUrl()
setButtonText | in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::setButtonText()
setButtonText | in file TDatePicker.php, method TDatePicker::setButtonText()
setButtonType | in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::setButtonType()
setButtonType | in file TButtonColumn.php, method TButtonColumn::setButtonType()
setButtonType | in file TButton.php, method TButton::setButtonType()
setButtonType | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setButtonType()
setButtonType | in file TEditCommandColumn.php, method TEditCommandColumn::setButtonType()
setButtonType | in file TPager.php, method TPager::setButtonType()
setCacheKey | in file TOutputCache.php, method TOutputCacheCalculateKeyEventParameter::setCacheKey()
setCacheKeyPrefix in file TOutputCache.php, method TOutputCache::setCacheKeyPrefix()
Sets the prefix of the cache key.
setCacheModuleID | in file TOutputCache.php, method TOutputCache::setCacheModuleID()
setCacheTime | in file TOutputCache.php, method TOutputCacheCheckDependencyEventParameter::setCacheTime()
setCachingPostBack in file TOutputCache.php, method TOutputCache::setCachingPostBack()
Sets a value indicating whether cached output will be used on postback requests.
setCalendarStyle | in file TDatePicker.php, method TDatePicker::setCalendarStyle()
setCancelButton | in file TWizard.php, method TWizardNavigationContainer::setCancelButton()
setCancelButtonText | in file TColorPicker.php, method TColorPicker::setCancelButtonText()
setCancelDestinationUrl | in file TWizard.php, method TWizard::setCancelDestinationUrl()
setCancelImageUrl | in file TEditCommandColumn.php, method TEditCommandColumn::setCancelImageUrl()
setCancelNavigation | in file TWizard.php, method TWizardNavigationEventParameter::setCancelNavigation()
setCancelText | in file TEditCommandColumn.php, method TEditCommandColumn::setCancelText()
setCaptchaControl in file TCaptchaValidator.php, method TCaptchaValidator::setCaptchaControl()
Sets the ID path of the CAPTCHA control to validate.
setCaption | in file TDataList.php, method TDataList::setCaption()
setCaption | in file TDataGrid.php, method TDataGrid::setCaption()
setCaption | in file TRatingList.php, method TRatingList::setCaption()
setCaption | in file TTable.php, method TTable::setCaption()
setCaption | in file TRepeatInfo.php, method TRepeatInfo::setCaption()
setCaption | in file TAccordion.php, method TAccordionView::setCaption()
setCaption | in file TTabPanel.php, method TTabView::setCaption()
setCaptionAlign | in file TDataGrid.php, method TDataGrid::setCaptionAlign()
setCaptionAlign | in file TTable.php, method TTable::setCaptionAlign()
setCaptionAlign | in file TRepeatInfo.php, method TRepeatInfo::setCaptionAlign()
setCaptionAlign | in file TDataList.php, method TDataList::setCaptionAlign()
setCaptionID | in file TRatingList.php, method TRatingList::setCaptionID()
setCaseSensitive | in file TCaptcha.php, method TCaptcha::setCaseSensitive()
setCategoryText | in file TTableHeaderCell.php, method TTableHeaderCell::setCategoryText()
setCausesValidation | in file TTextBox.php, method TTextBox::setCausesValidation()
setCausesValidation | in file TImageButton.php, method TImageButton::setCausesValidation()
setCausesValidation | in file TListControl.php, method TListControl::setCausesValidation()
setCausesValidation | in file TEditCommandColumn.php, method TEditCommandColumn::setCausesValidation()
setCausesValidation | in file TImageMap.php, method THotSpot::setCausesValidation()
setCausesValidation in file TLinkButton.php, method TLinkButton::setCausesValidation()
Sets the value indicating whether postback event trigger by this button will cause input validation.
setCausesValidation | in file TButton.php, method TButton::setCausesValidation()
setCausesValidation in file TCheckBox.php, method TCheckBox::setCausesValidation()
Sets the value indicating whether postback event trigger by this checkbox will cause input validation.
setCausesValidation | in file TButtonColumn.php, method TButtonColumn::setCausesValidation()
setCellPadding | in file TBaseDataList.php, method TBaseDataList::setCellPadding()
setCellPadding in file TCheckBoxList.php, method TCheckBoxList::setCellPadding()
Sets the cellpadding for the table keeping the checkbox list.
setCellPadding | in file TTable.php, method TTable::setCellPadding()
setCellPadding | in file TStyle.php, method TTableStyle::setCellPadding()
setCellSpacing in file TCheckBoxList.php, method TCheckBoxList::setCellSpacing()
Sets the cellspacing for the table keeping the checkbox list.
setCellSpacing | in file TStyle.php, method TTableStyle::setCellSpacing()
setCellSpacing | in file TTable.php, method TTable::setCellSpacing()
setCellSpacing | in file TBaseDataList.php, method TBaseDataList::setCellSpacing()
setChangingTokenBackground | in file TCaptcha.php, method TCaptcha::setChangingTokenBackground()
setCharset | in file TRangeValidator.php, method TRangeValidator::setCharset()
setChecked in file TCheckBox.php, method TCheckBox::setChecked()
Sets a value indicating whether the checkbox is to be checked or not.
setCheckMXRecord | in file TEmailAddressValidator.php, method TEmailAddressValidator::setCheckMXRecord()
setClientSidePatternModifiers | in file TRegularExpressionValidator.php, method TRegularExpressionValidator::setClientSidePatternModifiers()
setClientValidationFunction in file TCustomValidator.php, method TCustomValidator::setClientValidationFunction()
Sets the name of the custom client-side script function used for validation.
setColorPickerStyle | in file TColorPicker.php, method TColorPicker::setColorPickerStyle()
setColumns in file TTextBox.php, method TTextBox::setColumns()
Sets the display width of the text box in characters.
setColumnSpan in file TTableCell.php, method TTableCell::setColumnSpan()
Sets the columnspan for the table cell.
setCommandName | in file TLinkButton.php, method TLinkButton::setCommandName()
setCommandName | in file TImageButton.php, method TImageButton::setCommandName()
setCommandName | in file TButton.php, method TButton::setCommandName()
setCommandName in file TButtonColumn.php, method TButtonColumn::setCommandName()
Sets the command name associated with the Command event.
setCommandParameter | in file TLinkButton.php, method TLinkButton::setCommandParameter()
setCommandParameter | in file TButton.php, method TButton::setCommandParameter()
setCommandParameter | in file TImageButton.php, method TImageButton::setCommandParameter()
setCompleteButton | in file TWizard.php, method TWizardNavigationContainer::setCompleteButton()
setCondition in file TConditional.php, method TConditional::setCondition()
Sets the PHP expression to be evaluated for conditionally displaying content.
setContent | in file THead.php, method TMetaTag::setContent()
setContentTemplate | in file TWizard.php, method TTemplatedWizardStep::setContentTemplate()
setContinueBuffering | in file TFlushOutput.php, method TFlushOutput::setContinueBuffering()
setControlCssClass | in file TBaseValidator.php, method TBaseValidator::setControlCssClass()
setControlToCompare in file TCompareValidator.php, method TCompareValidator::setControlToCompare()
Sets the input component to compare with the input control being validated.
setControlToPaginate in file TPager.php, method TPager::setControlToPaginate()
Sets the ID path of the control whose content would be paginated.
setControlToValidate in file TBaseValidator.php, method TBaseValidator::setControlToValidate()
Sets the ID path of the input control to validate.
setCoordinates | in file TImageMap.php, method TPolygonHotSpot::setCoordinates()
setCssClass | in file TWebControl.php, method TWebControl::setCssClass()
setCssClass | in file TStyle.php, method TStyle::setCssClass()
setCssUrl | in file TSlider.php, method TSlider::setCssUrl()
setCssUrl | in file TAccordion.php, method TAccordion::setCssUrl()
setCssUrl | in file TTabPanel.php, method TTabPanel::setCssUrl()
setCssUrl | in file TKeyboard.php, method TKeyboard::setCssUrl()
setCulture in file THtmlArea.php, method THtmlArea::setCulture()
Sets the culture/language for the html area
setCulture in file TDatePicker.php, method TDatePicker::setCulture()
Sets the culture/language for the date picker.
setCurrentPageIndex | in file TPager.php, method TPager::setCurrentPageIndex()
setCurrentPageIndex | in file TDataBoundControl.php, method TDataBoundControl::setCurrentPageIndex()
setCustomPluginPath | in file THtmlArea.php, method THtmlArea::setCustomPluginPath()
setCustomStyle in file TStyle.php, method TStyle::setCustomStyle()
Sets custom style fields from a string.
setCustomTranslations | in file TReCaptcha.php, method TReCaptcha::setCustomTranslations()
setData | in file TDataRenderer.php, method TDataRenderer::setData()
setData in file TSlider.php, method TSlider::setData()
Sets the value of the TSlider control.
setData | in file TRepeater.php, method TRepeaterItem::setData()
setData in file TDatePicker.php, method TDatePicker::setData()
Sets the timestamp represented by this control.
setData in file TCheckBox.php, method TCheckBox::setData()
Sets the value indicating whether the checkbox is to be checked or not.
setData | in file TDataList.php, method TDataListItem::setData()
setData in file THyperLink.php, method THyperLink::setData()
Sets the URL to link to when the THyperLink component is clicked.
setData in file TButton.php, method TButton::setData()
Sets the caption of the button.
setData in file TLinkButton.php, method TLinkButton::setData()
Sets the caption of the button.
setData in file TTextBox.php, method TTextBox::setData()
Sets the text content of the TTextBox control.
setData | in file TDataGrid.php, method TDataGridItem::setData()
setData in file TInlineFrame.php, method TInlineFrame::setData()
Sets the URL that this iframe will load content from.
setData in file TLabel.php, method TLabel::setData()
Sets the text value of the label.
setData in file TImage.php, method TImage::setData()
Sets the URL of the image.
setData in file TTableCell.php, method TTableCell::setData()
Sets the text content of the table cell.
setData in file TListControl.php, method TListControl::setData()
Selects an item by the specified value.
setData in file TLiteral.php, method TLiteral::setData()
Sets the static text of the TLiteral.
setData in file THiddenField.php, method THiddenField::setData()
Sets the value of the hidden field.
setDataField | in file TLiteralColumn.php, method TLiteralColumn::setDataField()
setDataField | in file TBoundColumn.php, method TBoundColumn::setDataField()
setDataField | in file TCheckBoxColumn.php, method TCheckBoxColumn::setDataField()
setDataFormatString | in file TLiteralColumn.php, method TLiteralColumn::setDataFormatString()
setDataFormatString | in file TBoundColumn.php, method TBoundColumn::setDataFormatString()
setDataGroupField | in file TListControl.php, method TListControl::setDataGroupField()
setDataImageUrlField | in file TButtonColumn.php, method TButtonColumn::setDataImageUrlField()
setDataImageUrlFormatString | in file TButtonColumn.php, method TButtonColumn::setDataImageUrlFormatString()
setDataItem in file TDataList.php, method TDataListItem::setDataItem()
This property is deprecated since v3.1.0.
setDataItem in file TDataGrid.php, method TDataGridItem::setDataItem()
This property is deprecated since v3.1.0.
setDataItem in file TRepeater.php, method TRepeaterItem::setDataItem()
This property is deprecated since v3.1.0.
setDataKeyField | in file TBaseDataList.php, method TBaseDataList::setDataKeyField()
setDataKeyField | in file TRepeater.php, method TRepeater::setDataKeyField()
setDataMember | in file TDataBoundControl.php, method TDataBoundControl::setDataMember()
setDataNavigateUrlField | in file THyperLinkColumn.php, method THyperLinkColumn::setDataNavigateUrlField()
setDataNavigateUrlFormatString | in file THyperLinkColumn.php, method THyperLinkColumn::setDataNavigateUrlFormatString()
setDataSource in file TDataBoundControl.php, method TDataBoundControl::setDataSource()
Sets the data source object associated with the databound control.
setDataSourceID | in file TDataBoundControl.php, method TDataBoundControl::setDataSourceID()
setDataTextField in file TDropDownListColumn.php, method TDropDownListColumn::setDataTextField()
Sets the field of the data source that provides the text content of the column.
setDataTextField | in file TButtonColumn.php, method TButtonColumn::setDataTextField()
setDataTextField | in file TListControl.php, method TListControl::setDataTextField()
setDataTextField | in file THyperLinkColumn.php, method THyperLinkColumn::setDataTextField()
setDataTextFormatString in file TListControl.php, method TListControl::setDataTextFormatString()
Sets data text format string.
setDataTextFormatString | in file THyperLinkColumn.php, method THyperLinkColumn::setDataTextFormatString()
setDataTextFormatString | in file TButtonColumn.php, method TButtonColumn::setDataTextFormatString()
setDataTextFormatString | in file TDropDownListColumn.php, method TDropDownListColumn::setDataTextFormatString()
setDataType in file TRangeValidator.php, method TRangeValidator::setDataType()
Sets the data type that the values being compared are converted to before the comparison is made.
setDataType in file TCompareValidator.php, method TCompareValidator::setDataType()
Sets the data type that the values being compared are converted to before the comparison is made.
setDataType in file TDataTypeValidator.php, method TDataTypeValidator::setDataType()
Sets the data type that the values being compared are converted to before the comparison is made.
setDataValueField | in file TListControl.php, method TListControl::setDataValueField()
setDataValueField in file TDropDownListColumn.php, method TDropDownListColumn::setDataValueField()
Sets the field of the data source that provides the key selecting an item in dropdown list.
setDate | in file TDatePicker.php, method TDatePicker::setDate()
setDateFormat in file TRangeValidator.php, method TRangeValidator::setDateFormat()
Sets the date format for a date validation
setDateFormat in file TCompareValidator.php, method TCompareValidator::setDateFormat()
Sets the date format for a date validation
setDateFormat in file TDatePicker.php, method TDatePicker::setDateFormat()
Sets the format of the date string.
setDateFormat in file TDataTypeValidator.php, method TDataTypeValidator::setDateFormat()
Sets the date format for a date validation
setDefaultButton in file TPanel.php, method TPanel::setDefaultButton()
Specifies the default button for the panel.
setDescriptionUrl | in file TInlineFrame.php, method TInlineFrame::setDescriptionUrl()
setDescriptionUrl | in file TImage.php, method TImage::setDescriptionUrl()
setDirection | in file TPanel.php, method TPanel::setDirection()
setDirection | in file TSlider.php, method TSlider::setDirection()
setDirection | in file TPanelStyle.php, method TPanelStyle::setDirection()
setDisplay | in file TWebControl.php, method TWebControl::setDisplay()
setDisplay | in file TValidationSummary.php, method TValidationSummary::setDisplay()
setDisplay | in file TBaseValidator.php, method TBaseValidator::setDisplay()
setDisplayMode | in file TValidationSummary.php, method TValidationSummary::setDisplayMode()
setDisplayMode | in file TBulletedList.php, method TBulletedList::setDisplayMode()
setDisplayStyle | in file TStyle.php, method TStyle::setDisplayStyle()
setDocumentContent | in file TXmlTransform.php, method TXmlTransform::setDocumentContent()
setDocumentPath | in file TXmlTransform.php, method TXmlTransform::setDocumentPath()
setDuration | in file TOutputCache.php, method TOutputCache::setDuration()
setEditImageUrl | in file TEditCommandColumn.php, method TEditCommandColumn::setEditImageUrl()
setEditItemIndex in file TDataList.php, method TDataList::setEditItemIndex()
Edits an item by its index in getItems.
setEditItemIndex in file TDataGrid.php, method TDataGrid::setEditItemIndex()
Edits an item by its index in getItems.
setEditItemRenderer in file TBoundColumn.php, method TBoundColumn::setEditItemRenderer()
Sets the edit item cell renderer class.
setEditItemRenderer in file TTemplateColumn.php, method TTemplateColumn::setEditItemRenderer()
Sets the edit item cell renderer class.
setEditItemRenderer in file TDataList.php, method TDataList::setEditItemRenderer()
Sets the renderer class for the datalist item being editted.
setEditItemTemplate | in file TDataList.php, method TDataList::setEditItemTemplate()
setEditItemTemplate | in file TTemplateColumn.php, method TTemplateColumn::setEditItemTemplate()
setEditText | in file TEditCommandColumn.php, method TEditCommandColumn::setEditText()
setEmptyRenderer in file TDataList.php, method TDataList::setEmptyRenderer()
Sets the datalist empty renderer class.
setEmptyRenderer in file TRepeater.php, method TRepeater::setEmptyRenderer()
Sets the repeater empty renderer class.
setEmptyTemplate | in file TDataList.php, method TDataList::setEmptyTemplate()
setEmptyTemplate | in file TRepeater.php, method TRepeater::setEmptyTemplate()
setEmptyTemplate | in file TDataGrid.php, method TDataGrid::setEmptyTemplate()
setEnableCellGrouping | in file TDataGridColumn.php, method TDataGridColumn::setEnableCellGrouping()
setEnableClientScript | in file TLinkButton.php, method TLinkButton::setEnableClientScript()
setEnableClientScript | in file TCheckBox.php, method TCheckBox::setEnableClientScript()
setEnableClientScript | in file TRadioButton.php, method TRadioButton::setEnableClientScript()
setEnableClientScript | in file TBaseValidator.php, method TBaseValidator::setEnableClientScript()
setEnableClientScript | in file TButton.php, method TButton::setEnableClientScript()
setEnableClientScript | in file TListControl.php, method TListControl::setEnableClientScript()
setEnableClientScript | in file TTextBox.php, method TTextBox::setEnableClientScript()
setEnableClientScript | in file TImageButton.php, method TImageButton::setEnableClientScript()
setEnableClientScript | in file TValidationSummary.php, method TValidationSummary::setEnableClientScript()
setEnableCompression | in file THtmlArea.php, method THtmlArea::setEnableCompression()
setEnableCopyCode | in file TTextHighlighter.php, method TTextHighlighter::setEnableCopyCode()
setEnabled | in file TCheckBoxList.php, method TCheckBoxList::setEnabled()
setEnabled | in file TListItem.php, method TListItem::setEnabled()
setEnabled in file TRatingList.php, method TRatingList::setEnabled()
Wrapper for setReadOnly property.
setEnabled in file TBaseValidator.php, method TBaseValidator::setEnabled()
This method overrides parent's implementation by setting setIsValid to true if disabled.
setEnableTheming | in file TDataSourceControl.php, method TDataSourceControl::setEnableTheming()
setEnableTheming | in file THiddenField.php, method THiddenField::setEnableTheming()
setEnableVisualEdit in file THtmlArea.php, method THtmlArea::setEnableVisualEdit()
Sets whether to show WYSIWYG text editor.
setEncode | in file TLiteral.php, method TLiteral::setEncode()
setEncode | in file TLiteralColumn.php, method TLiteralColumn::setEncode()
setEnsureId in file TWebControl.php, method TWebControl::setEnsureId()
Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
setErrorMessage in file TBaseValidator.php, method TBaseValidator::setErrorMessage()
Sets the text for the error message.
setExpression | in file TExpression.php, method TExpression::setExpression()
setFalseTemplate | in file TConditional.php, method TConditional::setFalseTemplate()
setFinishDestinationUrl | in file TWizard.php, method TWizard::setFinishDestinationUrl()
setFinishNavigationTemplate | in file TWizard.php, method TWizard::setFinishNavigationTemplate()
setFirstBulletNumber | in file TBulletedList.php, method TBulletedList::setFirstBulletNumber()
setFirstDayOfWeek in file TDatePicker.php, method TDatePicker::setFirstDayOfWeek()
Set the first day of week, with 0 as Sunday, 1 as Monday, etc.
setFirstPageImageUrl | in file TPager.php, method TPager::setFirstPageImageUrl()
setFirstPageText | in file TPager.php, method TPager::setFirstPageText()
setFirstPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setFirstPageText()
setFlushScriptFiles | in file TClientScript.php, method TClientScript::setFlushScriptFiles()
setFocusElementID in file TBaseValidator.php, method TBaseValidator::setFocusElementID()
Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
setFocusOnError | in file TBaseValidator.php, method TBaseValidator::setFocusOnError()
setFooterRenderer in file TRepeater.php, method TRepeater::setFooterRenderer()
Sets the repeater footer renderer class.
setFooterRenderer in file TDataGridColumn.php, method TDataGridColumn::setFooterRenderer()
Sets the column footer cell renderer class.
setFooterRenderer in file TDataList.php, method TDataList::setFooterRenderer()
Sets the datalist footer renderer class.
setFooterTemplate | in file TDataList.php, method TDataList::setFooterTemplate()
setFooterTemplate | in file TRepeater.php, method TRepeater::setFooterTemplate()
setFooterTemplate | in file TTemplateColumn.php, method TTemplateColumn::setFooterTemplate()
setFooterText | in file TDataGridColumn.php, method TDataGridColumn::setFooterText()
setForControl in file TBaseValidator.php, method TBaseValidator::setForControl()
This method overrides the parent implementation to forbid setting ForControl.
setForControl in file TLabel.php, method TLabel::setForControl()
Sets the ID of the control that the label is associated with.
setForControl in file TKeyboard.php, method TKeyboard::setForControl()
Sets the ID path of the TTextBox control.
setForeColor | in file TWebControl.php, method TWebControl::setForeColor()
setForeColor | in file TStyle.php, method TStyle::setForeColor()
setFrameUrl | in file TInlineFrame.php, method TInlineFrame::setFrameUrl()
setFromYear | in file TDatePicker.php, method TDatePicker::setFromYear()
setGridLines in file TStyle.php, method TTableStyle::setGridLines()
Sets the grid line style of the table.
setGridLines | in file TTable.php, method TTable::setGridLines()
setGridLines in file TBaseDataList.php, method TBaseDataList::setGridLines()
Sets the grid line style of the table layout.
setGroupingText | in file TPanel.php, method TPanel::setGroupingText()
setGroupName in file TRadioButton.php, method TRadioButton::setGroupName()
Sets the name of the group that the radio button belongs to.
setHalfRatingInterval in file TRatingList.php, method TRatingList::setHalfRatingInterval()
Sets the interval such that those rating values within the interval will be considered as a half star rating.
setHeaderCssClass | in file TAccordion.php, method TAccordion::setHeaderCssClass()
setHeaderImageUrl | in file TDataGridColumn.php, method TDataGridColumn::setHeaderImageUrl()
setHeaderRenderer in file TRepeater.php, method TRepeater::setHeaderRenderer()
Sets the repeater header renderer class.
setHeaderRenderer in file TDataGridColumn.php, method TDataGridColumn::setHeaderRenderer()
Sets the column header cell renderer class.
setHeaderRenderer in file TDataList.php, method TDataList::setHeaderRenderer()
Sets the datalist header renderer class.
setHeaderTemplate | in file TWizard.php, method TWizard::setHeaderTemplate()
setHeaderTemplate | in file TTemplateColumn.php, method TTemplateColumn::setHeaderTemplate()
setHeaderTemplate | in file TRepeater.php, method TRepeater::setHeaderTemplate()
setHeaderTemplate | in file TDataList.php, method TDataList::setHeaderTemplate()
setHeaderText | in file TDataGridColumn.php, method TDataGridColumn::setHeaderText()
setHeaderText | in file TWizard.php, method TWizard::setHeaderText()
setHeaderText in file TValidationSummary.php, method TValidationSummary::setHeaderText()
Sets the header text to be displayed at the top of the summary
setHeight | in file TWebControl.php, method TWebControl::setHeight()
setHeight | in file TStyle.php, method TStyle::setHeight()
setHorizontalAlign | in file TBaseDataList.php, method TBaseDataList::setHorizontalAlign()
setHorizontalAlign in file TTableRow.php, method TTableRow::setHorizontalAlign()
Sets the horizontal alignment of the contents within the table item.
setHorizontalAlign in file TPanelStyle.php, method TPanelStyle::setHorizontalAlign()
Sets the horizontal alignment of the contents within the panel.
setHorizontalAlign | in file TTable.php, method TTable::setHorizontalAlign()
setHorizontalAlign in file TPanel.php, method TPanel::setHorizontalAlign()
Sets the horizontal alignment of the contents within the panel.
setHorizontalAlign in file TTableCell.php, method TTableCell::setHorizontalAlign()
Sets the horizontal alignment of the contents within the table item.
setHorizontalAlign in file TStyle.php, method TTableStyle::setHorizontalAlign()
Sets the horizontal alignment of the contents within the table.
setHorizontalAlign in file TStyle.php, method TTableItemStyle::setHorizontalAlign()
Sets the horizontal alignment of the contents within the table item.
setHotSpotMode in file TImageMap.php, method TImageMap::setHotSpotMode()
Sets the behavior of hotspot regions in this imagemap when they are clicked.
setHotSpotMode | in file TImageMap.php, method THotSpot::setHotSpotMode()
setHttpEquiv | in file THead.php, method TMetaTag::setHttpEquiv()
setID | in file THead.php, method TMetaTag::setID()
setID in file TDataGridColumn.php, method TDataGridColumn::setID()
Sets the ID of the column.
setImageAlign in file TImage.php, method TImage::setImageAlign()
Sets the alignment of the image with respective to other elements on the page.
setImageHeight in file THyperLink.php, method THyperLink::setImageHeight()
Sets the height of the image in the THyperLink
setImageHeight | in file THyperLinkColumn.php, method THyperLinkColumn::setImageHeight()
setImageUrl in file THyperLink.php, method THyperLink::setImageUrl()
Sets the location of image file of the THyperLink.
setImageUrl | in file TImage.php, method TImage::setImageUrl()
setImageUrl | in file TButtonColumn.php, method TButtonColumn::setImageUrl()
setImageUrl | in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::setImageUrl()
setImageUrl | in file THyperLinkColumn.php, method THyperLinkColumn::setImageUrl()
setImageWidth in file THyperLink.php, method THyperLink::setImageWidth()
Sets the width of the image in the THyperLink
setImageWidth | in file THyperLinkColumn.php, method THyperLinkColumn::setImageWidth()
setInitialized in file TDataBoundControl.php, method TDataBoundControl::setInitialized()
Sets a value indicating whether the databound control is initialized.
setInitialValue | in file TRequiredFieldValidator.php, method TRequiredFieldValidator::setInitialValue()
setInputMode | in file TDatePicker.php, method TDatePicker::setInputMode()
setIsDataBound | in file TDataBoundControl.php, method TDataBoundControl::setIsDataBound()
setIsDefaultButton | in file TButton.php, method TButton::setIsDefaultButton()
setIsDefaultButton | in file TImageButton.php, method TImageButton::setIsDefaultButton()
setIsDefaultButton | in file TLinkButton.php, method TLinkButton::setIsDefaultButton()
setIsValid | in file TCustomValidator.php, method TServerValidateEventParameter::setIsValid()
setIsValid | in file THiddenField.php, method THiddenField::setIsValid()
setIsValid | in file TTextBox.php, method TTextBox::setIsValid()
setIsValid | in file TOutputCache.php, method TOutputCacheCheckDependencyEventParameter::setIsValid()
setIsValid in file TBaseValidator.php, method TBaseValidator::setIsValid()
Sets the value indicating whether the validation succeeds
setIsValid | in file TReCaptcha.php, method TReCaptcha::setIsValid()
setIsValid | in file TDropDownList.php, method TDropDownList::setIsValid()
setIsValid | in file TCheckBox.php, method TCheckBox::setIsValid()
setIsValid | in file TFileUpload.php, method TFileUpload::setIsValid()
setIsValid | in file TCheckBoxList.php, method TCheckBoxList::setIsValid()
setIsValid | in file TListBox.php, method TListBox::setIsValid()
setItalic | in file TFont.php, method TFont::setItalic()
setItemIndex in file TItemDataRenderer.php, method TItemDataRenderer::setItemIndex()
Sets the zero-based index for the item.
setItemIndex in file TDataBoundControl.php, method IItemDataRenderer::setItemIndex()
Sets the zero-based index for the item.
setItemIndex in file TRepeater.php, method TRepeaterItem::setItemIndex()
Sets the zero-based index for the item.
setItemIndex in file TDataList.php, method TDataListItem::setItemIndex()
Sets the zero-based index for the item.
setItemRenderer in file TBoundColumn.php, method TBoundColumn::setItemRenderer()
Sets the item cell renderer class.
setItemRenderer in file TDataList.php, method TDataList::setItemRenderer()
Sets the item renderer class.
setItemRenderer in file TTemplateColumn.php, method TTemplateColumn::setItemRenderer()
Sets the item cell renderer class.
setItemRenderer in file TRepeater.php, method TRepeater::setItemRenderer()
Sets the item renderer class.
setItemTemplate | in file TDataList.php, method TDataList::setItemTemplate()
setItemTemplate | in file TRepeater.php, method TRepeater::setItemTemplate()
setItemTemplate | in file TTemplateColumn.php, method TTemplateColumn::setItemTemplate()
setItemType | in file TDataGrid.php, method TDataGridItem::setItemType()
setItemType | in file TDataBoundControl.php, method IItemDataRenderer::setItemType()
setItemType | in file TDataList.php, method TDataListItem::setItemType()
setItemType | in file TItemDataRenderer.php, method TItemDataRenderer::setItemType()
setItemType | in file TRepeater.php, method TRepeaterItem::setItemType()
setKeyboardCssClass in file TKeyboard.php, method TKeyboard::setKeyboardCssClass()
Sets a value indicating the CSS class name for the keyboard <div> element.
setLanguage | in file TReCaptcha.php, method TReCaptcha::setLanguage()
setLanguage | in file TTextHighlighter.php, method TTextHighlighter::setLanguage()
setLastPageImageUrl | in file TPager.php, method TPager::setLastPageImageUrl()
setLastPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setLastPageText()
setLastPageText | in file TPager.php, method TPager::setLastPageText()
setLeft | in file TImageMap.php, method TRectangleHotSpot::setLeft()
setLineNumberStyle | in file TTextHighlighter.php, method TTextHighlighter::setLineNumberStyle()
setListDataSource | in file TDropDownListColumn.php, method TDropDownListColumn::setListDataSource()
setListTextField | in file TDropDownListColumn.php, method TDropDownListColumn::setListTextField()
setListTextFormatString | in file TDropDownListColumn.php, method TDropDownListColumn::setListTextFormatString()
setListValueField | in file TDropDownListColumn.php, method TDropDownListColumn::setListValueField()
setMarginHeight | in file TInlineFrame.php, method TInlineFrame::setMarginHeight()
setMarginWidth | in file TInlineFrame.php, method TInlineFrame::setMarginWidth()
setMaxFileSize in file TFileUpload.php, method TFileUpload::setMaxFileSize()
Sets the maximum size that a file can be uploaded.
setMaximumRows | in file TDataSourceView.php, method TDataSourceSelectParameters::setMaximumRows()
setMaxLength in file TTextBox.php, method TTextBox::setMaxLength()
Sets the maximum number of characters allowed in the text box.
setMaxSelection | in file TListControlValidator.php, method TListControlValidator::setMaxSelection()
setMaxTokenLength | in file TCaptcha.php, method TCaptcha::setMaxTokenLength()
setMaxValue | in file TSlider.php, method TSlider::setMaxValue()
setMaxValue in file TRangeValidator.php, method TRangeValidator::setMaxValue()
Sets the maximum value of the validation range.
setMediaType | in file TStyleSheet.php, method TStyleSheet::setMediaType()
setMinSelection | in file TListControlValidator.php, method TListControlValidator::setMinSelection()
setMinTokenLength | in file TCaptcha.php, method TCaptcha::setMinTokenLength()
setMinValue | in file TSlider.php, method TSlider::setMinValue()
setMinValue in file TRangeValidator.php, method TRangeValidator::setMinValue()
Sets the minimum value of the validation range.
setMode | in file TPager.php, method TPager::setMode()
setMode | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setMode()
setMode | in file TColorPicker.php, method TColorPicker::setMode()
setMode | in file TDatePicker.php, method TDatePicker::setMode()
setName | in file TFont.php, method TFont::setName()
setName | in file THead.php, method TMetaTag::setName()
setNavigateUrl | in file TImageMap.php, method THotSpot::setNavigateUrl()
setNavigateUrl in file THyperLinkColumn.php, method THyperLinkColumn::setNavigateUrl()
Sets the URL to link to when the hyperlink is clicked.
setNavigateUrl in file TAccordion.php, method TAccordionView::setNavigateUrl()
Sets the URL of the target page.
setNavigateUrl in file TTabPanel.php, method TTabView::setNavigateUrl()
Sets the URL of the target page.
setNavigateUrl in file THyperLink.php, method THyperLink::setNavigateUrl()
Sets the URL to link to when the THyperLink component is clicked.
setNavigationTemplate | in file TWizard.php, method TTemplatedWizardStep::setNavigationTemplate()
setNextButton | in file TWizard.php, method TWizardNavigationContainer::setNextButton()
setNextPageImageUrl | in file TPager.php, method TPager::setNextPageImageUrl()
setNextPageText | in file TPager.php, method TPager::setNextPageText()
setNextPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setNextPageText()
setNextStepIndex | in file TWizard.php, method TWizardNavigationEventParameter::setNextStepIndex()
setNumericPageImageUrl in file TPager.php, method TPager::setNumericPageImageUrl()
Sets the image URL for the numeric page buttons.
setObserveChanges | in file TBaseValidator.php, method TValidatorClientSide::setObserveChanges()
setOKButtonText | in file TColorPicker.php, method TColorPicker::setOKButtonText()
setOnChange in file TSlider.php, method TSliderClientScript::setOnChange()
Javascript code to execute when the slider value is changed.
setOnColorSelected | in file TColorPicker.php, method TColorPickerClientSide::setOnColorSelected()
setOnDateChanged in file TDatePicker.php, method TDatePickerClientScript::setOnDateChanged()
Javascript code to execute when the date picker's date is changed.
setOnHideSummary in file TValidationSummary.php, method TClientSideValidationSummaryOptions::setOnHideSummary()
Client-side OnHideSummary validation summary event is raise when all the validators are valid. This will override the default client-side validation summary behaviour.
setOnShowSummary in file TValidationSummary.php, method TClientSideValidationSummaryOptions::setOnShowSummary()
Client-side OnShowSummary event is raise when one or more validators are not valid. This will override the default client-side validation summary behaviour.
setOnSlide | in file TSlider.php, method TSliderClientScript::setOnSlide()
setOnValidate in file TBaseValidator.php, method TValidatorClientSide::setOnValidate()
Client-side OnValidate validator event is raise before the validators validation functions are called.
setOnValidationError in file TBaseValidator.php, method TValidatorClientSide::setOnValidationError()
Client-side OnError event is raised after validation failure.
setOnValidationSuccess in file TBaseValidator.php, method TValidatorClientSide::setOnValidationSuccess()
Client-side OnSuccess event is raise after validation is successfull.
setOperator in file TCompareValidator.php, method TCompareValidator::setOperator()
Sets the comparison operation to perform
setOptions in file THtmlArea.php, method THtmlArea::setOptions()
Sets the list of options for the WYSIWYG (TinyMCE) editor
setOverline | in file TFont.php, method TFont::setOverline()
setOwner | in file TDataGridColumn.php, method TDataGridColumn::setOwner()
setPageButtonCount | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setPageButtonCount()
setPageButtonCount | in file TPager.php, method TPager::setPageButtonCount()
setPageCount | in file TPager.php, method TPager::setPageCount()
setPageSize | in file TDataBoundControl.php, method TDataBoundControl::setPageSize()
setPatternModifiers | in file TRegularExpressionValidator.php, method TRegularExpressionValidator::setPatternModifiers()
setPersistPassword | in file TTextBox.php, method TTextBox::setPersistPassword()
setPosition | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setPosition()
setPositionMode | in file TDatePicker.php, method TDatePicker::setPositionMode()
setPostBackValue | in file TImageMap.php, method THotSpot::setPostBackValue()
setPostContentsTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::setPostContentsTemplate()
setPostContentsText | in file TWebControlDecorator.php, method TWebControlDecorator::setPostContentsText()
setPostTagTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::setPostTagTemplate()
setPostTagText | in file TWebControlDecorator.php, method TWebControlDecorator::setPostTagText()
setPradoScripts in file TClientScript.php, method TClientScript::setPradoScripts()
Include javascript library to the current page. The current supported libraries are: "prado", "effects", "ajax", "validator", "logger", "datepicker", "colorpicker". Library dependencies are automatically resolved.
setPreContentsTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::setPreContentsTemplate()
setPreContentsText | in file TWebControlDecorator.php, method TWebControlDecorator::setPreContentsText()
setPreTagTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::setPreTagTemplate()
setPreTagText | in file TWebControlDecorator.php, method TWebControlDecorator::setPreTagText()
setPreviousButton | in file TWizard.php, method TWizardNavigationContainer::setPreviousButton()
setPrevPageImageUrl | in file TPager.php, method TPager::setPrevPageImageUrl()
setPrevPageText | in file TPager.php, method TPager::setPrevPageText()
setPrevPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setPrevPageText()
setPrivateKey | in file TReCaptcha.php, method TReCaptcha::setPrivateKey()
setProgressIndicator | in file TSlider.php, method TSlider::setProgressIndicator()
setPromptText | in file TListControl.php, method TListControl::setPromptText()
setPromptValue | in file TListControl.php, method TListControl::setPromptValue()
setPublicKey | in file TCaptcha.php, method TCaptcha::setPublicKey()
setPublicKey | in file TReCaptcha.php, method TReCaptcha::setPublicKey()
setRadius | in file TImageMap.php, method TCircleHotSpot::setRadius()
setRating | in file TRatingList.php, method TRatingList::setRating()
setRatingStyle | in file TRatingList.php, method TRatingList::setRatingStyle()
setReadOnly | in file TDropDownListColumn.php, method TDropDownListColumn::setReadOnly()
setReadOnly | in file TBoundColumn.php, method TBoundColumn::setReadOnly()
setReadOnly | in file TRatingList.php, method TRatingList::setReadOnly()
setReadOnly | in file TCheckBoxColumn.php, method TCheckBoxColumn::setReadOnly()
setReadOnly | in file TTextBox.php, method TTextBox::setReadOnly()
setRegularExpression | in file TRegularExpressionValidator.php, method TRegularExpressionValidator::setRegularExpression()
setRepackUTF7 in file TSafeHtml.php, method TSafeHtml::setRepackUTF7()
Sets whether to parse the contents as UTF-7. This property enables a routine that repacks the content as UTF-7 before parsing it. Defaults to false.
setRepeatColumns | in file TRepeatInfo.php, method TRepeatInfo::setRepeatColumns()
setRepeatColumns | in file TDataList.php, method TDataList::setRepeatColumns()
setRepeatColumns | in file TCheckBoxList.php, method TCheckBoxList::setRepeatColumns()
setRepeatDirection | in file TRepeatInfo.php, method TRepeatInfo::setRepeatDirection()
setRepeatDirection | in file TDataList.php, method TDataList::setRepeatDirection()
setRepeatDirection | in file TCheckBoxList.php, method TCheckBoxList::setRepeatDirection()
setRepeatLayout | in file TRepeatInfo.php, method TRepeatInfo::setRepeatLayout()
setRepeatLayout | in file TDataList.php, method TDataList::setRepeatLayout()
setRepeatLayout | in file TCheckBoxList.php, method TCheckBoxList::setRepeatLayout()
setRepeatLayout in file TRatingList.php, method TRatingList::setRepeatLayout()
The repeat layout must be Table.
setRequiredSelections in file TListControlValidator.php, method TListControlValidator::setRequiredSelections()
Set the list of required values, using aa comma separated list.
setRequiresDataBinding in file TDataBoundControl.php, method TDataBoundControl::setRequiresDataBinding()
Sets a value indicating whether a databind call is required by the data bound control.
setRetrieveTotalRowCount | in file TDataSourceView.php, method TDataSourceSelectParameters::setRetrieveTotalRowCount()
setRight | in file TImageMap.php, method TRectangleHotSpot::setRight()
setRows | in file TListBox.php, method TListBox::setRows()
setRows in file TTextBox.php, method TTextBox::setRows()
Sets the number of rows displayed in a multiline text box.
setRowSpan in file TTableCell.php, method TTableCell::setRowSpan()
Sets the rowspan for the table cell.
setScheme | in file THead.php, method TMetaTag::setScheme()
setScope | in file TTableHeaderCell.php, method TTableHeaderCell::setScope()
setScriptUrl | in file TClientScript.php, method TClientScript::setScriptUrl()
setScrollBars | in file TInlineFrame.php, method TInlineFrame::setScrollBars()
setScrollBars | in file TPanel.php, method TPanel::setScrollBars()
setScrollBars | in file TPanelStyle.php, method TPanelStyle::setScrollBars()
setScrollToSummary | in file TValidationSummary.php, method TValidationSummary::setScrollToSummary()
setSelected | in file TListItem.php, method TListItem::setSelected()
setSelectedIndex | in file TListControl.php, method TListControl::setSelectedIndex()
setSelectedIndex | in file TRatingList.php, method TRatingList::setSelectedIndex()
setSelectedIndex | in file TBulletedList.php, method TBulletedList::setSelectedIndex()
setSelectedIndices | in file TDropDownList.php, method TDropDownList::setSelectedIndices()
setSelectedIndices | in file TRadioButtonList.php, method TRadioButtonList::setSelectedIndices()
setSelectedIndices | in file TListControl.php, method TListControl::setSelectedIndices()
setSelectedIndices | in file TBulletedList.php, method TBulletedList::setSelectedIndices()
setSelectedItemIndex in file TDataGrid.php, method TDataGrid::setSelectedItemIndex()
Selects an item by its index in getItems.
setSelectedItemIndex in file TDataList.php, method TDataList::setSelectedItemIndex()
Selects an item by its index in getItems.
setSelectedItemRenderer in file TDataList.php, method TDataList::setSelectedItemRenderer()
Sets the renderer class for the datalist item being selected.
setSelectedItemTemplate | in file TDataList.php, method TDataList::setSelectedItemTemplate()
setSelectedValue | in file TBulletedList.php, method TBulletedList::setSelectedValue()
setSelectedValue in file TListControl.php, method TListControl::setSelectedValue()
Sets selection by item value.
setSelectedValues | in file TBulletedList.php, method TBulletedList::setSelectedValues()
setSelectedValues | in file TListControl.php, method TListControl::setSelectedValues()
setSelectionMode | in file TListBox.php, method TListBox::setSelectionMode()
setSeparatorRenderer in file TRepeater.php, method TRepeater::setSeparatorRenderer()
Sets the repeater item separator renderer class.
setSeparatorRenderer in file TDataList.php, method TDataList::setSeparatorRenderer()
Sets the datalist item separator renderer class.
setSeparatorTemplate | in file TDataList.php, method TDataList::setSeparatorTemplate()
setSeparatorTemplate | in file TRepeater.php, method TRepeater::setSeparatorTemplate()
setShowAnchor | in file TValidationSummary.php, method TValidationSummary::setShowAnchor()
setShowBorder | in file TInlineFrame.php, method TInlineFrame::setShowBorder()
setShowCalendar in file TDatePicker.php, method TDatePicker::setShowCalendar()
Sets whether to pop up the calendar window when the control receives focus
setShowCancelButton | in file TWizard.php, method TWizard::setShowCancelButton()
setShowColorPicker in file TColorPicker.php, method TColorPicker::setShowColorPicker()
Sets whether to pop up the color picker when the button is clicked.
setShowFooter | in file TDataGrid.php, method TDataGrid::setShowFooter()
setShowFooter | in file TDataList.php, method TDataList::setShowFooter()
setShowHeader | in file TDataGrid.php, method TDataGrid::setShowHeader()
setShowHeader | in file TDataList.php, method TDataList::setShowHeader()
setShowLineNumbers | in file TTextHighlighter.php, method TTextHighlighter::setShowLineNumbers()
setShowMessageBox | in file TValidationSummary.php, method TValidationSummary::setShowMessageBox()
setShowSideBar | in file TWizard.php, method TWizard::setShowSideBar()
setShowSummary | in file TValidationSummary.php, method TValidationSummary::setShowSummary()
setSideBarTemplate | in file TWizard.php, method TWizard::setSideBarTemplate()
setSize | in file TFont.php, method TFont::setSize()
setSkinID | in file TDataSourceControl.php, method TDataSourceControl::setSkinID()
setSkinID | in file THiddenField.php, method THiddenField::setSkinID()
setSortExpression | in file TDataGridColumn.php, method TDataGridColumn::setSortExpression()
setStartNavigationTemplate | in file TWizard.php, method TWizard::setStartNavigationTemplate()
setStartRowIndex | in file TDataSourceView.php, method TDataSourceSelectParameters::setStartRowIndex()
setStatements | in file TStatements.php, method TStatements::setStatements()
setStepNavigationTemplate | in file TWizard.php, method TWizard::setStepNavigationTemplate()
setStepSize in file TSlider.php, method TSlider::setStepSize()
Sets the step size used to determine the places where the slider handle can stop at.
setStepType | in file TWizard.php, method TWizardStep::setStepType()
setStepType | in file TWizard.php, method TCompleteWizardStep::setStepType()
setStrictComparison | in file TRangeValidator.php, method TRangeValidator::setStrictComparison()
setStrikeout | in file TFont.php, method TFont::setStrikeout()
setStyle in file TWebControl.php, method TWebControl::setStyle()
Sets the css style string of the control.
setStyleField in file TStyle.php, method TStyle::setStyleField()
Sets a single style field value.
setStyleSheetUrl | in file TStyleSheet.php, method TStyleSheet::setStyleSheetUrl()
setTabCssClass | in file TTabPanel.php, method TTabPanel::setTabCssClass()
setTabIndex in file TWebControl.php, method TWebControl::setTabIndex()
Sets the tab index of the control.
setTabIndex | in file TImageMap.php, method THotSpot::setTabIndex()
setTableSection | in file TTableFooterRow.php, method TTableFooterRow::setTableSection()
setTableSection | in file TTableHeaderRow.php, method TTableHeaderRow::setTableSection()
setTableSection | in file TTableRow.php, method TTableRow::setTableSection()
setTabSize | in file TTextHighlighter.php, method TTextHighlighter::setTabSize()
setTagName | in file TDataList.php, method TDataListItem::setTagName()
setTagName | in file THtmlElement.php, method THtmlElement::setTagName()
setTarget | in file TImageMap.php, method THotSpot::setTarget()
setTarget | in file TBulletedList.php, method TBulletedList::setTarget()
setTarget in file THyperLinkColumn.php, method THyperLinkColumn::setTarget()
Sets the target window or frame to display the Web page content linked to when the hyperlink is clicked.
setTarget | in file TImageMap.php, method TImageMap::setTarget()
setTarget in file THyperLink.php, method THyperLink::setTarget()
Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.
setTestLimit | in file TCaptcha.php, method TCaptcha::setTestLimit()
setText in file TTabPanel.php, method TTabView::setText()
Sets the text content to be displayed on this view.
setText in file TLiteral.php, method TLiteral::setText()
Sets the static text of the TLiteral
setText in file TTextBox.php, method TTextBox::setText()
Sets the text content of the TTextBox control.
setText | in file TListItem.php, method TListItem::setText()
setText | in file TListControl.php, method TListControl::setText()
setText in file THyperLink.php, method THyperLink::setText()
Sets the text caption of the THyperLink.
setText in file TButtonColumn.php, method TButtonColumn::setText()
Sets the text caption of the button.
setText | in file TLiteralColumn.php, method TLiteralColumn::setText()
setText | in file TLabel.php, method TLabel::setText()
setText in file THyperLinkColumn.php, method THyperLinkColumn::setText()
Sets the text caption of the hyperlink.
setText | in file TButton.php, method TButton::setText()
setText in file TCheckBox.php, method TCheckBox::setText()
Sets the text caption of the checkbox.
setText | in file TImageButton.php, method TImageButton::setText()
setText in file TTableCell.php, method TTableCell::setText()
Sets the text content of the table cell.
setText | in file TLinkButton.php, method TLinkButton::setText()
setText in file TAccordion.php, method TAccordionView::setText()
Sets the text content to be displayed on this view.
setTextAlign | in file TCheckBoxList.php, method TCheckBoxList::setTextAlign()
setTextAlign | in file TCheckBox.php, method TCheckBox::setTextAlign()
setTextMode in file TTextBox.php, method TTextBox::setTextMode()
Sets the behavior mode of the TTextBox component.
setTextMode in file THtmlArea.php, method THtmlArea::setTextMode()
Overrides the parent implementation.
setThemeName | in file TReCaptcha.php, method TReCaptcha::setThemeName()
setTimeStamp in file TDatePicker.php, method TDatePicker::setTimeStamp()
Sets the date for the date picker using timestamp.
setTitle | in file TWizard.php, method TWizardStep::setTitle()
setToggleKey | in file TJavascriptLogger.php, method TJavascriptLogger::setToggleKey()
setTokenAlphabet | in file TCaptcha.php, method TCaptcha::setTokenAlphabet()
setTokenExpiry | in file TCaptcha.php, method TCaptcha::setTokenExpiry()
setTokenFontSize in file TCaptcha.php, method TCaptcha::setTokenFontSize()
Sets the font size used for displaying the token in an image.
setTokenImageTheme in file TCaptcha.php, method TCaptcha::setTokenImageTheme()
Sets the theme of the token image.
setToolTip in file TWebControl.php, method TWebControl::setToolTip()
Sets the tooltip of the control.
setTop | in file TImageMap.php, method TRectangleHotSpot::setTop()
setTotalRowCount | in file TDataSourceView.php, method TDataSourceSelectParameters::setTotalRowCount()
setTransformContent | in file TXmlTransform.php, method TXmlTransform::setTransformContent()
setTransformPath | in file TXmlTransform.php, method TXmlTransform::setTransformPath()
setTrueTemplate | in file TConditional.php, method TConditional::setTrueTemplate()
setUnderline | in file TFont.php, method TFont::setUnderline()
setUniqueGroupName in file TRadioButton.php, method TRadioButton::setUniqueGroupName()
Sets the unique group name that the radio button belongs to.
setUpdateImageUrl | in file TEditCommandColumn.php, method TEditCommandColumn::setUpdateImageUrl()
setUpdateText | in file TEditCommandColumn.php, method TEditCommandColumn::setUpdateText()
setUpToYear | in file TDatePicker.php, method TDatePicker::setUpToYear()
setUseDefaultLayout | in file TWizard.php, method TWizard::setUseDefaultLayout()
setUseState | in file TWebControlDecorator.php, method TWebControlDecorator::setUseState()
setValidationGroup | in file TButtonColumn.php, method TButtonColumn::setValidationGroup()
setValidationGroup | in file TValidationSummary.php, method TValidationSummary::setValidationGroup()
setValidationGroup | in file TImageMap.php, method THotSpot::setValidationGroup()
setValidationGroup | in file TListControl.php, method TListControl::setValidationGroup()
setValidationGroup | in file TTextBox.php, method TTextBox::setValidationGroup()
setValidationGroup | in file TLinkButton.php, method TLinkButton::setValidationGroup()
setValidationGroup | in file TCheckBox.php, method TCheckBox::setValidationGroup()
setValidationGroup | in file TButton.php, method TButton::setValidationGroup()
setValidationGroup | in file TEditCommandColumn.php, method TEditCommandColumn::setValidationGroup()
setValidationGroup | in file TImageButton.php, method TImageButton::setValidationGroup()
setValidationGroup | in file TBaseValidator.php, method TBaseValidator::setValidationGroup()
setValue | in file TCheckBox.php, method TCheckBox::setValue()
setValue in file THiddenField.php, method THiddenField::setValue()
Sets the value of the THiddenField
setValue | in file TSlider.php, method TSlider::setValue()
setValue | in file TListItem.php, method TListItem::setValue()
setValues in file TSlider.php, method TSlider::setValues()
Sets the possible values that the slider can take.
setValueToCompare in file TCompareValidator.php, method TCompareValidator::setValueToCompare()
Sets the constant value to compare with the value entered by the user into the input component being validated.
setVaryByParam in file TOutputCache.php, method TOutputCache::setVaryByParam()
Sets the names of the request parameters that should be used in calculating the cache key.
setVaryBySession | in file TOutputCache.php, method TOutputCache::setVaryBySession()
setVerticalAlign in file TTableCell.php, method TTableCell::setVerticalAlign()
Sets the vertical alignment of the contents within the table item.
setVerticalAlign in file TTableRow.php, method TTableRow::setVerticalAlign()
Sets the vertical alignment of the contents within the table item.
setVerticalAlign in file TStyle.php, method TTableItemStyle::setVerticalAlign()
Sets the vertical alignment of the contents within the table item.
setViewCssClass | in file TTabPanel.php, method TTabPanel::setViewCssClass()
setViewCssClass | in file TAccordion.php, method TAccordion::setViewCssClass()
setViewHeight | in file TAccordion.php, method TAccordion::setViewHeight()
setViewState in file TDataGridColumn.php, method TDataGridColumn::setViewState()
Sets a viewstate value.
setViewState in file TImageMap.php, method THotSpot::setViewState()
Sets a viewstate value.
setVirtualItemCount | in file TDataBoundControl.php, method TDataBoundControl::setVirtualItemCount()
setVisible | in file TDataSourceControl.php, method TDataSourceControl::setVisible()
setVisible | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setVisible()
setVisible | in file TMultiView.php, method TView::setVisible()
setVisible | in file TDataGridColumn.php, method TDataGridColumn::setVisible()
setWidth | in file TWebControl.php, method TWebControl::setWidth()
setWidth | in file TStyle.php, method TStyle::setWidth()
setWizard in file TWizard.php, method TWizardStep::setWizard()
Sets the wizard owning this step.
setWrap in file TStyle.php, method TTableItemStyle::setWrap()
Sets the value indicating whether the content wraps within the table item.
setWrap in file TTableCell.php, method TTableCell::setWrap()
Sets the value indicating whether the text content wraps within a table cell.
setWrap in file TPanelStyle.php, method TPanelStyle::setWrap()
Sets the value indicating whether the content wraps within the panel.
setWrap in file TPanel.php, method TPanel::setWrap()
Sets the value indicating whether the content wraps within the panel.
setWrap in file TTextBox.php, method TTextBox::setWrap()
Sets the value indicating whether the text content wraps within a multiline text box.
setX | in file TImageMap.php, method TCircleHotSpot::setX()
setX | in file TImageButton.php, method TImageClickEventParameter::setX()
setY | in file TImageMap.php, method TCircleHotSpot::setY()
setY | in file TImageButton.php, method TImageClickEventParameter::setY()
Simple | in file TColorPicker.php, class constant TColorPickerMode::Simple
SimpleList | in file TValidationSummary.php, class constant TValidationSummaryDisplayMode::SimpleList
Single | in file TListBox.php, class constant TListSelectionMode::Single
SingleLine | in file TTextBox.php, class constant TTextBoxMode::SingleLine
SingleParagraph | in file TValidationSummary.php, class constant TValidationSummaryDisplayMode::SingleParagraph
Square | in file TBulletedList.php, class constant TBulletStyle::Square
Start | in file TWizard.php, class constant TWizardStepType::Start
Step | in file TWizard.php, class constant TWizardStepType::Step
String | in file TBaseValidator.php, class constant TValidationDataType::String
StringLength | in file TRangeValidator.php, class constant TRangeValidationDataType::StringLength
ST_AUTO in file TWizard.php, class constant TWizard::ST_AUTO
Wizard step types.
ST_COMPLETE | in file TWizard.php, class constant TWizard::ST_COMPLETE
ST_FINISH | in file TWizard.php, class constant TWizard::ST_FINISH
ST_START | in file TWizard.php, class constant TWizard::ST_START
ST_STEP | in file TWizard.php, class constant TWizard::ST_STEP
Submit | in file TButton.php, class constant TButtonType::Submit
top
t
Table | in file TRepeatInfo.php, class constant TRepeatLayout::Table
Table | in file TTextHighlighter.php, class constant TTextHighlighterLineNumberStyle::Table
TAccordion in file TAccordion.php, class TAccordion
Class TAccordion.
TAccordionView in file TAccordion.php, class TAccordionView
Class TAccordionView.
TAccordionViewCollection in file TAccordion.php, class TAccordionViewCollection
Class TAccordionViewCollection.
TBaseDataList in file TBaseDataList.php, class TBaseDataList
TBaseDataList class
TBaseValidator in file TBaseValidator.php, class TBaseValidator
TBaseValidator class
TBoundColumn in file TBoundColumn.php, class TBoundColumn
TBoundColumn class
TBulletedList in file TBulletedList.php, class TBulletedList
TBulletedList class
TBulletedListDisplayMode in file TBulletedList.php, class TBulletedListDisplayMode
TBulletedListDisplayMode class.
TBulletedListEventParameter in file TBulletedList.php, class TBulletedListEventParameter
TBulletedListEventParameter Event parameter for TBulletedList::onClick event of the bulleted list. The getIndex gives the zero-based index of the item that is currently being clicked.
TBulletStyle in file TBulletedList.php, class TBulletStyle
TBulletStyle class.
TButton in file TButton.php, class TButton
TButton class
TButtonColumn in file TButtonColumn.php, class TButtonColumn
TButtonColumn class
TButtonColumnType in file TDataGridColumn.php, class TButtonColumnType
TButtonColumnType class.
TButtonType in file TButton.php, class TButtonType
TButtonType class.
TCaptcha in file TCaptcha.php, class TCaptcha
TCaptcha class.
TCaptchaValidator in file TCaptchaValidator.php, class TCaptchaValidator
TCaptchaValidator class
TCheckBox in file TCheckBox.php, class TCheckBox
TCheckBox class
TCheckBoxColumn in file TCheckBoxColumn.php, class TCheckBoxColumn
TCheckBoxColumn class
TCheckBoxList in file TCheckBoxList.php, class TCheckBoxList
TCheckBoxList class
TCircleHotSpot in file TImageMap.php, class TCircleHotSpot
Class TCircleHotSpot.
TClientScript in file TClientScript.php, class TClientScript
TClientScript class
TClientSideValidationSummaryOptions in file TValidationSummary.php, class TClientSideValidationSummaryOptions
TClientSideValidationSummaryOptions class.
TColorPicker in file TColorPicker.php, class TColorPicker
TColorPicker class.
TColorPickerClientSide in file TColorPicker.php, class TColorPickerClientSide
TColorPickerClientSide class.
TColorPickerMode in file TColorPicker.php, class TColorPickerMode
TColorPickerMode class.
TCompareValidator in file TCompareValidator.php, class TCompareValidator
TCompareValidator class
TCompleteWizardStep in file TWizard.php, class TCompleteWizardStep
TCompleteWizardStep class.
TConditional in file TConditional.php, class TConditional
TConditional class.
TContent in file TContent.php, class TContent
TContent class
TContentDirection in file TPanelStyle.php, class TContentDirection
TContentDirection class.
TContentPlaceHolder in file TContentPlaceHolder.php, class TContentPlaceHolder
TContentPlaceHolder class
TCustomValidator in file TCustomValidator.php, class TCustomValidator
TCustomValidator class
TDataBoundControl in file TDataBoundControl.php, class TDataBoundControl
TDataBoundControl class.
TDataGrid in file TDataGrid.php, class TDataGrid
TDataGrid class
TDataGridColumn in file TDataGridColumn.php, class TDataGridColumn
TDataGridColumn class
TDataGridColumnCollection in file TDataGrid.php, class TDataGridColumnCollection
TDataGridColumnCollection class.
TDataGridCommandEventParameter in file TDataGrid.php, class TDataGridCommandEventParameter
TDataGridCommandEventParameter class
TDataGridItem in file TDataGrid.php, class TDataGridItem
TDataGridItem class
TDataGridItemCollection in file TDataGrid.php, class TDataGridItemCollection
TDataGridItemCollection class.
TDataGridItemEventParameter in file TDataGrid.php, class TDataGridItemEventParameter
TDataGridItemEventParameter class
TDataGridItemRenderer in file TDataGridItemRenderer.php, class TDataGridItemRenderer
TDataGridItemRenderer class
TDataGridPageChangedEventParameter in file TDataGrid.php, class TDataGridPageChangedEventParameter
TDataGridPageChangedEventParameter class
TDataGridPager in file TDataGrid.php, class TDataGridPager
TDataGridPager class.
TDataGridPagerButtonType in file TDataGrid.php, class TDataGridPagerButtonType
TDataGridPagerButtonType class.
TDataGridPagerEventParameter in file TDataGrid.php, class TDataGridPagerEventParameter
TDataGridPagerEventParameter class
TDataGridPagerMode in file TDataGrid.php, class TDataGridPagerMode
TDataGridPagerMode class.
TDataGridPagerPosition in file TDataGrid.php, class TDataGridPagerPosition
TDataGridPagerPosition class.
TDataGridPagerStyle in file TDataGridPagerStyle.php, class TDataGridPagerStyle
TDataGridPagerStyle class.
TDataGridSortCommandEventParameter in file TDataGrid.php, class TDataGridSortCommandEventParameter
TDataGridSortCommandEventParameter class
TDataList in file TDataList.php, class TDataList
TDataList class
TDataListCommandEventParameter in file TDataList.php, class TDataListCommandEventParameter
TDataListCommandEventParameter class
TDataListItem in file TDataList.php, class TDataListItem
TDataListItem class
TDataListItemCollection in file TDataList.php, class TDataListItemCollection
TDataListItemCollection class.
TDataListItemEventParameter in file TDataList.php, class TDataListItemEventParameter
TDataListItemEventParameter class
TDataListItemRenderer in file TDataListItemRenderer.php, class TDataListItemRenderer
TDataListItemRenderer class
TDataRenderer in file TDataRenderer.php, class TDataRenderer
TDataRenderer class
TDataSourceControl in file TDataSourceControl.php, class TDataSourceControl
TDataSourceControl class
TDataSourceSelectParameters in file TDataSourceView.php, class TDataSourceSelectParameters
TDataSourceSelectParameters class
TDataSourceView in file TDataSourceView.php, class TDataSourceView
TDataSourceView class
TDataTypeValidator in file TDataTypeValidator.php, class TDataTypeValidator
TDataTypeValidator class
TDatePicker in file TDatePicker.php, class TDatePicker
TDatePicker class.
TDatePickerClientScript in file TDatePicker.php, class TDatePickerClientScript
TDatePickerClientScript class.
TDatePickerInputMode in file TDatePicker.php, class TDatePickerInputMode
TDatePickerInputMode class.
TDatePickerMode in file TDatePicker.php, class TDatePickerMode
TDatePickerMode class.
TDatePickerPositionMode in file TDatePicker.php, class TDatePickerPositionMode
TDatePickerPositionMode class.
TDisplayStyle in file TStyle.php, class TDisplayStyle
TDisplayStyle defines the enumerable type for the possible styles that a web control can display.
TDropDownList in file TDropDownList.php, class TDropDownList
TDropDownList class
TDropDownListColumn in file TDropDownListColumn.php, class TDropDownListColumn
TDropDownListColumn class
TEditCommandColumn in file TEditCommandColumn.php, class TEditCommandColumn
TEditCommandColumn class
TEmailAddressValidator in file TEmailAddressValidator.php, class TEmailAddressValidator
TEmailAddressValidator class
TExpression in file TExpression.php, class TExpression
TExpression class
Text | in file TBulletedList.php, class constant TBulletedListDisplayMode::Text
TextBox | in file TDatePicker.php, class constant TDatePickerInputMode::TextBox
TFileUpload in file TFileUpload.php, class TFileUpload
TFileUpload class
TFlushOutput in file TFlushOutput.php, class TFlushOutput
TFlushOutput class.
TFont in file TFont.php, class TFont
TFont class
THeader1 in file THeader1.php, class THeader1
THeader1 class
THeader2 in file THeader2.php, class THeader2
THeader2 class
THeader3 in file THeader3.php, class THeader3
THeader3 class
THeader4 in file THeader4.php, class THeader4
THeader4 class
THeader5 in file THeader5.php, class THeader5
THeader5 class
THeader6 in file THeader6.php, class THeader6
THeader6 class
THiddenField in file THiddenField.php, class THiddenField
THiddenField class
THorizontalAlign in file TStyle.php, class THorizontalAlign
THorizontalAlign class.
THotSpot in file TImageMap.php, class THotSpot
THotSpot class.
THotSpotCollection in file TImageMap.php, class THotSpotCollection
THotSpotCollection class.
THotSpotMode in file TImageMap.php, class THotSpotMode
THotSpotMode class.
THtmlArea in file THtmlArea.php, class THtmlArea
THtmlArea class
THtmlElement in file THtmlElement.php, class THtmlElement
THtmlElement class.
THyperLink in file THyperLink.php, class THyperLink
THyperLink class
THyperLinkColumn in file THyperLinkColumn.php, class THyperLinkColumn
THyperLinkColumn class
TImage in file TImage.php, class TImage
TImage class
TImageButton in file TImageButton.php, class TImageButton
TImageButton class
TImageClickEventParameter in file TImageButton.php, class TImageClickEventParameter
TImageClickEventParameter class
TImageMap in file TImageMap.php, class TImageMap
TImageMap class
TImageMapEventParameter in file TImageMap.php, class TImageMapEventParameter
TImageMapEventParameter class.
TInlineFrame in file TInlineFrame.php, class TInlineFrame
TInlineFrame class
TInlineFrameAlign in file TInlineFrame.php, class TInlineFrameAlign
TInlineFrameAlign class.
TInlineFrameScrollBars in file TInlineFrame.php, class TInlineFrameScrollBars
TInlineFrameScrollBars class.
TItemDataRenderer in file TItemDataRenderer.php, class TItemDataRenderer
TItemDataRenderer class
TJavascriptLogger in file TJavascriptLogger.php, class TJavascriptLogger
TJavascriptLogger class.
TKeyboard in file TKeyboard.php, class TKeyboard
Class TKeyboard.
TLabel in file TLabel.php, class TLabel
TLabel class
TLinkButton in file TLinkButton.php, class TLinkButton
TLinkButton class
TListBox in file TListBox.php, class TListBox
TListBox class
TListControl in file TListControl.php, class TListControl
TListControl class
TListControlValidator in file TListControlValidator.php, class TListControlValidator
TListControlValidator class.
TListItem in file TListItem.php, class TListItem
TListItem class.
TListItemType in file TDataBoundControl.php, class TListItemType
TListItemType class.
TListSelectionMode in file TListBox.php, class TListSelectionMode
TListSelectionMode class.
TLiteral in file TLiteral.php, class TLiteral
TLiteral class
TLiteralColumn in file TLiteralColumn.php, class TLiteralColumn
TLiteralColumn class
TMarkdown in file TMarkdown.php, class TMarkdown
TMarkdown class
TMetaTag in file THead.php, class TMetaTag
TMetaTag class.
TMetaTagCollection in file THead.php, class TMetaTagCollection
TMetaTagCollection class
TMultiView in file TMultiView.php, class TMultiView
TMultiView class
Top | in file TStyle.php, class constant TVerticalAlign::Top
Top | in file TDataGrid.php, class constant TDataGridPagerPosition::Top
Top | in file TInlineFrame.php, class constant TInlineFrameAlign::Top
Top | in file TDatePicker.php, class constant TDatePickerPositionMode::Top
Top | in file TTable.php, class constant TTableCaptionAlign::Top
TopAndBottom | in file TDataGrid.php, class constant TDataGridPagerPosition::TopAndBottom
toString | in file TFont.php, method TFont::toString()
TOutputCache in file TOutputCache.php, class TOutputCache
TOutputCache class.
TOutputCacheCalculateKeyEventParameter in file TOutputCache.php, class TOutputCacheCalculateKeyEventParameter
TOutputCacheCalculateKeyEventParameter class
TOutputCacheCheckDependencyEventParameter in file TOutputCache.php, class TOutputCacheCheckDependencyEventParameter
TOutputCacheCheckDependencyEventParameter class
TOutputCacheTextWriterMulti in file TOutputCache.php, class TOutputCacheTextWriterMulti
TTextWriter class.
TPager in file TPager.php, class TPager
TPager class.
TPagerButtonType in file TPager.php, class TPagerButtonType
TPagerButtonType class.
TPagerMode in file TPager.php, class TPagerMode
TPagerMode class.
TPagerPageChangedEventParameter in file TPager.php, class TPagerPageChangedEventParameter
TPagerPageChangedEventParameter class
TPanel in file TPanel.php, class TPanel
TPanel class
TPanelStyle in file TPanelStyle.php, class TPanelStyle
TPanelStyle class.
TPlaceHolder in file TPlaceHolder.php, class TPlaceHolder
TPlaceHolder class
TPolygonHotSpot in file TImageMap.php, class TPolygonHotSpot
Class TPolygonHotSpot.
TRadioButton in file TRadioButton.php, class TRadioButton
TRadioButton class
TRadioButtonList in file TRadioButtonList.php, class TRadioButtonList
TRadioButtonList class
TRangeValidationDataType in file TRangeValidator.php, class TRangeValidationDataType
TRangeValidationDataType class.
TRangeValidator in file TRangeValidator.php, class TRangeValidator
TRangeValidator class
TRatingList in file TRatingList.php, class TRatingList
TRatingList class.
TReadOnlyDataSource in file TDataSourceControl.php, class TReadOnlyDataSource
TDataSourceControl class
TReadOnlyDataSourceView in file TDataSourceView.php, class TReadOnlyDataSourceView
TReadOnlyDataSourceView class
TReCaptcha in file TReCaptcha.php, class TReCaptcha
TReCaptcha class.
TReCaptchaValidator in file TReCaptchaValidator.php, class TReCaptchaValidator
TReCaptchaValidator class
TRectangleHotSpot in file TImageMap.php, class TRectangleHotSpot
Class TRectangleHotSpot.
TRegularExpressionValidator in file TRegularExpressionValidator.php, class TRegularExpressionValidator
TRegularExpressionValidator class
TRepeatDirection in file TRepeatInfo.php, class TRepeatDirection
TRepeatDirection class.
TRepeater in file TRepeater.php, class TRepeater
TRepeater class.
TRepeaterCommandEventParameter in file TRepeater.php, class TRepeaterCommandEventParameter
TRepeaterCommandEventParameter class
TRepeaterItem in file TRepeater.php, class TRepeaterItem
TRepeaterItem class
TRepeaterItemCollection in file TRepeater.php, class TRepeaterItemCollection
TRepeaterItemCollection class.
TRepeaterItemEventParameter in file TRepeater.php, class TRepeaterItemEventParameter
TRepeaterItemEventParameter class
TRepeaterItemRenderer in file TRepeaterItemRenderer.php, class TRepeaterItemRenderer
TRepeaterItemRenderer class
TRepeatInfo in file TRepeatInfo.php, class TRepeatInfo
TRepeatInfo class.
TRepeatLayout in file TRepeatInfo.php, class TRepeatLayout
TRepeatLayout class.
TRequiredFieldValidator in file TRequiredFieldValidator.php, class TRequiredFieldValidator
TRequiredFieldValidator class
TSafeHtml in file TSafeHtml.php, class TSafeHtml
TSafeHtml class
TScrollBars in file TPanelStyle.php, class TScrollBars
TScrollBars class.
TServerValidateEventParameter in file TCustomValidator.php, class TServerValidateEventParameter
TServerValidateEventParameter class
TSlider in file TSlider.php, class TSlider
TSlider class
TSliderClientScript in file TSlider.php, class TSliderClientScript
TSliderClientScript class.
TSliderDirection in file TSlider.php, class TSliderDirection
TSliderDirection class.
TStatements in file TStatements.php, class TStatements
TStatements class
TStyle in file TStyle.php, class TStyle
TStyle class
TStyleSheet in file TStyleSheet.php, class TStyleSheet
TStyleSheet class.
TTable in file TTable.php, class TTable
TTable class
TTableCaptionAlign in file TTable.php, class TTableCaptionAlign
TTableCaptionAlign class.
TTableCell in file TTableCell.php, class TTableCell
TTableCell class.
TTableCellCollection in file TTableRow.php, class TTableCellCollection
TTableCellCollection class.
TTableFooterRow in file TTableFooterRow.php, class TTableFooterRow
TTableFooterRow class.
TTableGridLines in file TStyle.php, class TTableGridLines
TTableGridLines class.
TTableHeaderCell in file TTableHeaderCell.php, class TTableHeaderCell
TTableHeaderCell class.
TTableHeaderRow in file TTableHeaderRow.php, class TTableHeaderRow
TTableHeaderRow class.
TTableHeaderScope in file TTableHeaderCell.php, class TTableHeaderScope
TTableHeaderScope class.
TTableItemStyle in file TStyle.php, class TTableItemStyle
TTableItemStyle class.
TTableRow in file TTableRow.php, class TTableRow
TTableRow class.
TTableRowCollection in file TTable.php, class TTableRowCollection
TTableRowCollection class.
TTableRowSection in file TTableRow.php, class TTableRowSection
TTableRowSection class.
TTableStyle in file TStyle.php, class TTableStyle
TTableStyle class.
TTabPanel in file TTabPanel.php, class TTabPanel
Class TTabPanel.
TTabView in file TTabPanel.php, class TTabView
TTabView class.
TTabViewCollection in file TTabPanel.php, class TTabViewCollection
TTabViewCollection class.
TTemplateColumn in file TTemplateColumn.php, class TTemplateColumn
TTemplateColumn class
TTemplatedWizardStep in file TWizard.php, class TTemplatedWizardStep
TTemplatedWizardStep class.
TTextAlign in file TCheckBox.php, class TTextAlign
TTextAlign class.
TTextBox in file TTextBox.php, class TTextBox
TTextBox class
TTextBoxAutoCompleteType in file TTextBox.php, class TTextBoxAutoCompleteType
TTextBoxAutoCompleteType class.
TTextBoxMode in file TTextBox.php, class TTextBoxMode
TTextBoxMode class.
TTextHighlighter in file TTextHighlighter.php, class TTextHighlighter
TTextHighlighter class.
TTextHighlighterLineNumberStyle | in file TTextHighlighter.php, class TTextHighlighterLineNumberStyle
TValidationCompareOperator in file TCompareValidator.php, class TValidationCompareOperator
TValidationCompareOperator class.
TValidationDataType in file TBaseValidator.php, class TValidationDataType
TValidationDataType class.
TValidationSummary in file TValidationSummary.php, class TValidationSummary
TValidationSummary class
TValidationSummaryDisplayMode in file TValidationSummary.php, class TValidationSummaryDisplayMode
TValidationSummaryDisplayMode class.
TValidationSummaryDisplayStyle in file TValidationSummary.php, class TValidationSummaryDisplayStyle
TValidationSummaryDisplay class.
TValidatorClientSide in file TBaseValidator.php, class TValidatorClientSide
TValidatorClientSide class.
TValidatorDisplayStyle in file TBaseValidator.php, class TValidatorDisplayStyle
TValidatorDisplayStyle class.
TVerticalAlign in file TStyle.php, class TVerticalAlign
TVerticalAlign class.
TView in file TMultiView.php, class TView
TView class
TViewCollection in file TMultiView.php, class TViewCollection
TViewCollection class.
TWebControl in file TWebControl.php, class TWebControl
TWebControl class
TWebControlAdapter in file TWebControlAdapter.php, class TWebControlAdapter
TWebControlAdapter class
TWebControlDecorator in file TWebControlDecorator.php, class TWebControlDecorator
TWebControlDecorator class
TWizard in file TWizard.php, class TWizard
Class TWizard.
TWizardFinishNavigationTemplate in file TWizard.php, class TWizardFinishNavigationTemplate
TWizardFinishNavigationTemplate class.
TWizardNavigationButtonStyle in file TWizardNavigationButtonStyle.php, class TWizardNavigationButtonStyle
TWizardNavigationButtonStyle class.
TWizardNavigationButtonType in file TWizard.php, class TWizardNavigationButtonType
TWizardNavigationButtonType class.
TWizardNavigationContainer in file TWizard.php, class TWizardNavigationContainer
TWizardNavigationContainer class.
TWizardNavigationEventParameter in file TWizard.php, class TWizardNavigationEventParameter
TWizardNavigationEventParameter class.
TWizardNavigationTemplate in file TWizard.php, class TWizardNavigationTemplate
TWizardNavigationTemplate class.
TWizardSideBarListItemTemplate in file TWizard.php, class TWizardSideBarListItemTemplate
TWizardSideBarListItemTemplate class.
TWizardSideBarTemplate in file TWizard.php, class TWizardSideBarTemplate
TWizardSideBarTemplate class.
TWizardStartNavigationTemplate in file TWizard.php, class TWizardStartNavigationTemplate
TWizardStartNavigationTemplate class.
TWizardStep in file TWizard.php, class TWizardStep
TWizardStep class.
TWizardStepCollection in file TWizard.php, class TWizardStepCollection
TWizardStepCollection class.
TWizardStepNavigationTemplate in file TWizard.php, class TWizardStepNavigationTemplate
TWizardStepNavigationTemplate class.
TWizardStepType in file TWizard.php, class TWizardStepType
TWizardStepType class.
TXmlTransform in file TXmlTransform.php, class TXmlTransform
TXmlTransform class
TAccordion.php | procedural page TAccordion.php
TBaseDataList.php | procedural page TBaseDataList.php
TBaseValidator.php | procedural page TBaseValidator.php
TBoundColumn.php | procedural page TBoundColumn.php
TBulletedList.php | procedural page TBulletedList.php
TButton.php | procedural page TButton.php
TButtonColumn.php | procedural page TButtonColumn.php
TCaptcha.php | procedural page TCaptcha.php
TCaptchaValidator.php | procedural page TCaptchaValidator.php
TCheckBox.php | procedural page TCheckBox.php
TCheckBoxColumn.php | procedural page TCheckBoxColumn.php
TCheckBoxList.php | procedural page TCheckBoxList.php
TClientScript.php | procedural page TClientScript.php
TColorPicker.php | procedural page TColorPicker.php
TCompareValidator.php | procedural page TCompareValidator.php
TConditional.php | procedural page TConditional.php
TContent.php | procedural page TContent.php
TContentPlaceHolder.php | procedural page TContentPlaceHolder.php
TCustomValidator.php | procedural page TCustomValidator.php
TDataBoundControl.php | procedural page TDataBoundControl.php
TDataGrid.php | procedural page TDataGrid.php
TDataGridColumn.php | procedural page TDataGridColumn.php
TDataGridItemRenderer.php | procedural page TDataGridItemRenderer.php
TDataGridPagerStyle.php | procedural page TDataGridPagerStyle.php
TDataList.php | procedural page TDataList.php
TDataListItemRenderer.php | procedural page TDataListItemRenderer.php
TDataRenderer.php | procedural page TDataRenderer.php
TDataSourceControl.php | procedural page TDataSourceControl.php
TDataSourceView.php | procedural page TDataSourceView.php
TDataTypeValidator.php | procedural page TDataTypeValidator.php
TDatePicker.php | procedural page TDatePicker.php
TDropDownList.php | procedural page TDropDownList.php
TDropDownListColumn.php | procedural page TDropDownListColumn.php
TEditCommandColumn.php | procedural page TEditCommandColumn.php
TEmailAddressValidator.php | procedural page TEmailAddressValidator.php
TExpression.php | procedural page TExpression.php
TFileUpload.php | procedural page TFileUpload.php
TFlushOutput.php | procedural page TFlushOutput.php
TFont.php | procedural page TFont.php
THeader1.php | procedural page THeader1.php
THeader2.php | procedural page THeader2.php
THeader3.php | procedural page THeader3.php
THeader4.php | procedural page THeader4.php
THeader5.php | procedural page THeader5.php
THeader6.php | procedural page THeader6.php
THiddenField.php | procedural page THiddenField.php
THtmlArea.php | procedural page THtmlArea.php
THtmlElement.php | procedural page THtmlElement.php
THyperLink.php | procedural page THyperLink.php
THyperLinkColumn.php | procedural page THyperLinkColumn.php
TImage.php | procedural page TImage.php
TImageButton.php | procedural page TImageButton.php
TImageMap.php | procedural page TImageMap.php
TInlineFrame.php | procedural page TInlineFrame.php
TItemDataRenderer.php | procedural page TItemDataRenderer.php
TJavascriptLogger.php | procedural page TJavascriptLogger.php
TKeyboard.php | procedural page TKeyboard.php
TLabel.php | procedural page TLabel.php
TLinkButton.php | procedural page TLinkButton.php
TListBox.php | procedural page TListBox.php
TListControl.php | procedural page TListControl.php
TListControlValidator.php | procedural page TListControlValidator.php
TListItem.php | procedural page TListItem.php
TLiteral.php | procedural page TLiteral.php
TLiteralColumn.php | procedural page TLiteralColumn.php
TMarkdown.php | procedural page TMarkdown.php
TMultiView.php | procedural page TMultiView.php
TOutputCache.php | procedural page TOutputCache.php
TPager.php | procedural page TPager.php
TPanel.php | procedural page TPanel.php
TPanelStyle.php | procedural page TPanelStyle.php
TPlaceHolder.php | procedural page TPlaceHolder.php
TRadioButton.php | procedural page TRadioButton.php
TRadioButtonList.php | procedural page TRadioButtonList.php
TRangeValidator.php | procedural page TRangeValidator.php
TRatingList.php | procedural page TRatingList.php
TReCaptcha.php | procedural page TReCaptcha.php
TReCaptchaValidator.php | procedural page TReCaptchaValidator.php
TRegularExpressionValidator.php | procedural page TRegularExpressionValidator.php
TRepeater.php | procedural page TRepeater.php
TRepeaterItemRenderer.php | procedural page TRepeaterItemRenderer.php
TRepeatInfo.php | procedural page TRepeatInfo.php
TRequiredFieldValidator.php | procedural page TRequiredFieldValidator.php
TSafeHtml.php | procedural page TSafeHtml.php
TSlider.php | procedural page TSlider.php
TStatements.php | procedural page TStatements.php
TStyle.php | procedural page TStyle.php
TStyleSheet.php | procedural page TStyleSheet.php
TTable.php | procedural page TTable.php
TTableCell.php | procedural page TTableCell.php
TTableFooterRow.php | procedural page TTableFooterRow.php
TTableHeaderCell.php | procedural page TTableHeaderCell.php
TTableHeaderRow.php | procedural page TTableHeaderRow.php
TTableRow.php | procedural page TTableRow.php
TTabPanel.php | procedural page TTabPanel.php
TTemplateColumn.php | procedural page TTemplateColumn.php
TTextBox.php | procedural page TTextBox.php
TTextHighlighter.php | procedural page TTextHighlighter.php
TTextProcessor.php | procedural page TTextProcessor.php
TValidationSummary.php | procedural page TValidationSummary.php
TWebControl.php | procedural page TWebControl.php
TWebControlAdapter.php | procedural page TWebControlAdapter.php
TWebControlDecorator.php | procedural page TWebControlDecorator.php
TWizard.php | procedural page TWizard.php
TWizardNavigationButtonStyle.php | procedural page TWizardNavigationButtonStyle.php
TXmlTransform.php | procedural page TXmlTransform.php
top
u
update in file TDataSourceView.php, method TDataSourceView::update()
Updates DB record(s) with the specified keys and new values
updateControlCssClass in file TBaseValidator.php, method TBaseValidator::updateControlCssClass()
Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
UpperAlpha | in file TBulletedList.php, class constant TBulletStyle::UpperAlpha
UpperRoman | in file TBulletedList.php, class constant TBulletStyle::UpperRoman
top
v
validate | in file TReCaptcha.php, method TReCaptcha::validate()
validate in file TCaptcha.php, method TCaptcha::validate()
Validates a user input with the token.
validate in file TBaseValidator.php, method TBaseValidator::validate()
Validates the specified control.
validateDataSource in file TDataBoundControl.php, method TDataBoundControl::validateDataSource()
Validates if the parameter is a valid data source.
Vertical | in file TStyle.php, class constant TTableGridLines::Vertical
Vertical | in file TSlider.php, class constant TSliderDirection::Vertical
Vertical | in file TPanelStyle.php, class constant TScrollBars::Vertical
Vertical | in file TRepeatInfo.php, class constant TRepeatDirection::Vertical
top
w
wizardStepsChanged in file TWizard.php, method TWizard::wizardStepsChanged()
Updates the sidebar datalist if any.
write | in file TOutputCache.php, method TOutputCacheTextWriterMulti::write()


Class Trees for Package System.Web.UI.WebControls

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TAccordion.php

File: /Web/UI/WebControls/TAccordion.php

Remarks

TAccordion class file.

author

Gabor Berczi, DevWorx Hungary <gabor.berczi@devworx.hu>

version

$Id: TAccordion.php 2915 2011-05-15 16:26:11Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

since

3.2

license

http://www.pradosoft.com/license/

Classes in this file:
TAccordion
Class TAccordion.
TAccordionView
Class TAccordionView.
TAccordionViewCollection
Class TAccordionViewCollection.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:42:59 +0200 by phpDocumentor 1.4.3


Docs for page TBaseDataList.php

File: /Web/UI/WebControls/TBaseDataList.php

Remarks

TBaseDataList class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TBaseDataList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TBaseDataList
TBaseDataList class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:34 +0200 by phpDocumentor 1.4.3


Docs for page TBaseValidator.php

File: /Web/UI/WebControls/TBaseValidator.php

Remarks

TBaseValidator class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TBaseValidator.php 3159 2012-06-01 18:01:40Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TBaseValidator
TBaseValidator class
TValidatorClientSide
TValidatorClientSide class.
TValidatorDisplayStyle
TValidatorDisplayStyle class.
TValidationDataType
TValidationDataType class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:35 +0200 by phpDocumentor 1.4.3


Docs for page TBoundColumn.php

File: /Web/UI/WebControls/TBoundColumn.php

Remarks

TBoundColumn class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TBoundColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TBoundColumn
TBoundColumn class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:36 +0200 by phpDocumentor 1.4.3


Docs for page TBulletedList.php

File: /Web/UI/WebControls/TBulletedList.php

Remarks

TBulletedList class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TBulletedList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TBulletedList
TBulletedList class
TBulletedListEventParameter
TBulletedListEventParameter Event parameter for TBulletedList::onClick event of the bulleted list. The getIndex gives the zero-based index of the item that is currently being clicked.
TBulletStyle
TBulletStyle class.
TBulletedListDisplayMode
TBulletedListDisplayMode class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:37 +0200 by phpDocumentor 1.4.3


Docs for page TButton.php

File: /Web/UI/WebControls/TButton.php

Remarks

TButton class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TButton
TButton class
TButtonType
TButtonType class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:37 +0200 by phpDocumentor 1.4.3


Docs for page TButtonColumn.php

File: /Web/UI/WebControls/TButtonColumn.php

Remarks

TButtonColumn class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TButtonColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TButtonColumn
TButtonColumn class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:38 +0200 by phpDocumentor 1.4.3


Docs for page TCaptcha.php

File: /Web/UI/WebControls/TCaptcha.php

Remarks

TCaptcha class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCaptcha.php 3044 2011-10-02 21:13:53Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCaptcha
TCaptcha class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:42 +0200 by phpDocumentor 1.4.3


Docs for page TCaptchaValidator.php

File: /Web/UI/WebControls/TCaptchaValidator.php

Remarks

TCaptchaValidator class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCaptchaValidator.php 3044 2011-10-02 21:13:53Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCaptchaValidator
TCaptchaValidator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:43 +0200 by phpDocumentor 1.4.3


Docs for page TCheckBox.php

File: /Web/UI/WebControls/TCheckBox.php

Remarks

TCheckBox class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCheckBox.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCheckBox
TCheckBox class
TTextAlign
TTextAlign class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:44 +0200 by phpDocumentor 1.4.3


Docs for page TCheckBoxColumn.php

File: /Web/UI/WebControls/TCheckBoxColumn.php

Remarks

TCheckBoxColumn class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCheckBoxColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCheckBoxColumn
TCheckBoxColumn class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:44 +0200 by phpDocumentor 1.4.3


Docs for page TCheckBoxList.php

File: /Web/UI/WebControls/TCheckBoxList.php

Remarks

TCheckBoxList class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCheckBoxList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCheckBoxList
TCheckBoxList class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:45 +0200 by phpDocumentor 1.4.3


Docs for page TClientScript.php

File: /Web/UI/WebControls/TClientScript.php

Remarks

TClientScript class file

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TClientScript.php 3162 2012-06-04 13:19:53Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TClientScript
TClientScript class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:46 +0200 by phpDocumentor 1.4.3


Docs for page TColorPicker.php

File: /Web/UI/WebControls/TColorPicker.php

Remarks

TColorPicker class file

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TColorPicker.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TColorPicker
TColorPicker class.
TColorPickerMode
TColorPickerMode class.
TColorPickerClientSide
TColorPickerClientSide class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:47 +0200 by phpDocumentor 1.4.3


Docs for page TCompareValidator.php

File: /Web/UI/WebControls/TCompareValidator.php

Remarks

TCompareValidator class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCompareValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCompareValidator
TCompareValidator class
TValidationCompareOperator
TValidationCompareOperator class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:48 +0200 by phpDocumentor 1.4.3


Docs for page TConditional.php

File: /Web/UI/WebControls/TConditional.php

Remarks

TConditional class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TConditional.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TConditional
TConditional class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:51 +0200 by phpDocumentor 1.4.3


Docs for page TContent.php

File: /Web/UI/WebControls/TContent.php

Remarks

TContent class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TContent.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TContent
TContent class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:52 +0200 by phpDocumentor 1.4.3


Docs for page TContentPlaceHolder.php

File: /Web/UI/WebControls/TContentPlaceHolder.php

Remarks

TContentPlaceHolder class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TContentPlaceHolder.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TContentPlaceHolder
TContentPlaceHolder class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:52 +0200 by phpDocumentor 1.4.3


Docs for page TCustomValidator.php

File: /Web/UI/WebControls/TCustomValidator.php

Remarks

TCustomValidator class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCustomValidator.php 3091 2012-01-18 09:35:07Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCustomValidator
TCustomValidator class
TServerValidateEventParameter
TServerValidateEventParameter class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:55 +0200 by phpDocumentor 1.4.3


Docs for page TDataBoundControl.php

File: /Web/UI/WebControls/TDataBoundControl.php

Remarks

TDataBoundControl class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataBoundControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDataBoundControl
TDataBoundControl class.
TListItemType
TListItemType class.
IItemDataRenderer
IItemDataRenderer interface.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:56 +0200 by phpDocumentor 1.4.3


Docs for page TDataGrid.php

File: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGrid related class files.

This file contains the definition of the following classes: TDataGrid, TDataGridItem, TDataGridItemCollection, TDataGridColumnCollection, TDataGridPagerStyle, TDataGridItemEventParameter, TDataGridCommandEventParameter, TDataGridSortCommandEventParameter, TDataGridPageChangedEventParameter

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDataGrid
TDataGrid class
TDataGridItemEventParameter
TDataGridItemEventParameter class
TDataGridPagerEventParameter
TDataGridPagerEventParameter class
TDataGridCommandEventParameter
TDataGridCommandEventParameter class
TDataGridSortCommandEventParameter
TDataGridSortCommandEventParameter class
TDataGridPageChangedEventParameter
TDataGridPageChangedEventParameter class
TDataGridItem
TDataGridItem class
TDataGridPager
TDataGridPager class.
TDataGridItemCollection
TDataGridItemCollection class.
TDataGridColumnCollection
TDataGridColumnCollection class.
TDataGridPagerMode
TDataGridPagerMode class.
TDataGridPagerButtonType
TDataGridPagerButtonType class.
TDataGridPagerPosition
TDataGridPagerPosition class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:58 +0200 by phpDocumentor 1.4.3


Docs for page TDataGridColumn.php

File: /Web/UI/WebControls/TDataGridColumn.php

Remarks

TDataGridColumn class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGridColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDataGridColumn
TDataGridColumn class
TButtonColumnType
TButtonColumnType class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:01 +0200 by phpDocumentor 1.4.3


Docs for page TDataGridItemRenderer.php

File: /Web/UI/WebControls/TDataGridItemRenderer.php

Remarks

TDataGridItemRenderer class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGridItemRenderer.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDataGridItemRenderer
TDataGridItemRenderer class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:01 +0200 by phpDocumentor 1.4.3


Docs for page TDataGridPagerStyle.php

File: /Web/UI/WebControls/TDataGridPagerStyle.php

Remarks

TDataGridPagerStyle class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGridPagerStyle.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDataGridPagerStyle
TDataGridPagerStyle class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:02 +0200 by phpDocumentor 1.4.3


Docs for page TDataList.php

File: /Web/UI/WebControls/TDataList.php

Remarks

TDataList class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDataList
TDataList class
TDataListItemEventParameter
TDataListItemEventParameter class
TDataListCommandEventParameter
TDataListCommandEventParameter class
TDataListItem
TDataListItem class
TDataListItemCollection
TDataListItemCollection class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:02 +0200 by phpDocumentor 1.4.3


Docs for page TDataListItemRenderer.php

File: /Web/UI/WebControls/TDataListItemRenderer.php

Remarks

TDataListItemRenderer class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataListItemRenderer.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDataListItemRenderer
TDataListItemRenderer class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:04 +0200 by phpDocumentor 1.4.3


Docs for page TDataRenderer.php

File: /Web/UI/WebControls/TDataRenderer.php

Remarks

TDataRenderer class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataRenderer.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

since

3.1.2

license

http://www.pradosoft.com/license/

Classes in this file:
TDataRenderer
TDataRenderer class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:05 +0200 by phpDocumentor 1.4.3


Docs for page TDataSourceControl.php

File: /Web/UI/WebControls/TDataSourceControl.php

Remarks

IDataSource, TDataSourceControl, TReadOnlyDataSource class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataSourceControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
IDataSource
IDataSource class
TDataSourceControl
TDataSourceControl class
TReadOnlyDataSource
TDataSourceControl class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:05 +0200 by phpDocumentor 1.4.3


Docs for page TDataSourceView.php

File: /Web/UI/WebControls/TDataSourceView.php

Remarks

TDataSourceSelectParameters, TDataSourceView, TReadOnlyDataSourceView class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataSourceView.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDataSourceSelectParameters
TDataSourceSelectParameters class
TDataSourceView
TDataSourceView class
TReadOnlyDataSourceView
TReadOnlyDataSourceView class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:06 +0200 by phpDocumentor 1.4.3


Docs for page TDataTypeValidator.php

File: /Web/UI/WebControls/TDataTypeValidator.php

Remarks

TDataTypeValidator class.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDataTypeValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDataTypeValidator
TDataTypeValidator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:07 +0200 by phpDocumentor 1.4.3


Docs for page TDatePicker.php

File: /Web/UI/WebControls/TDatePicker.php

Remarks

TDatePicker class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDatePicker.php 3133 2012-04-14 14:38:05Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDatePicker
TDatePicker class.
TDatePickerClientScript
TDatePickerClientScript class.
TDatePickerInputMode
TDatePickerInputMode class.
TDatePickerMode
TDatePickerMode class.
TDatePickerPositionMode
TDatePickerPositionMode class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:08 +0200 by phpDocumentor 1.4.3


Docs for page TDropDownList.php

File: /Web/UI/WebControls/TDropDownList.php

Remarks

TDropDownList class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDropDownList.php 3052 2011-10-21 09:06:19Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDropDownList
TDropDownList class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:16 +0200 by phpDocumentor 1.4.3


Docs for page TDropDownListColumn.php

File: /Web/UI/WebControls/TDropDownListColumn.php

Remarks

TDropDownListColumn class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDropDownListColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDropDownListColumn
TDropDownListColumn class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:17 +0200 by phpDocumentor 1.4.3


Docs for page TEditCommandColumn.php

File: /Web/UI/WebControls/TEditCommandColumn.php

Remarks

TEditCommandColumn class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TEditCommandColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TEditCommandColumn
TEditCommandColumn class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:17 +0200 by phpDocumentor 1.4.3


Docs for page TEmailAddressValidator.php

File: /Web/UI/WebControls/TEmailAddressValidator.php

Remarks

TEmailAddressValidator class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TEmailAddressValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TEmailAddressValidator
TEmailAddressValidator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:17 +0200 by phpDocumentor 1.4.3


Docs for page TExpression.php

File: /Web/UI/WebControls/TExpression.php

Remarks

TExpression class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TExpression.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TExpression
TExpression class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:20 +0200 by phpDocumentor 1.4.3


Docs for page TFileUpload.php

File: /Web/UI/WebControls/TFileUpload.php

Remarks

TFileUpload class file

author

Marcus Nyeholt <tanus@users.sourceforge.net>, Qiang Xue <qiang.xue@gmail.com>

version

$Id: TFileUpload.php 3082 2011-12-21 12:55:05Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TFileUpload
TFileUpload class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:20 +0200 by phpDocumentor 1.4.3


Docs for page TFlushOutput.php

File: /Web/UI/WebControls/TFlushOutput.php

Remarks

TFlushOutput class file

author

Berczi Gabor <gabor.berczi@devworx.hu>

version

$Id: TFlushOutput.php $

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TFlushOutput
TFlushOutput class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:21 +0200 by phpDocumentor 1.4.3


Docs for page TFont.php

File: /Web/UI/WebControls/TFont.php

Remarks

TFont class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TFont.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TFont
TFont class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:21 +0200 by phpDocumentor 1.4.3


Docs for page THeader1.php

File: /Web/UI/WebControls/THeader1.php

Remarks

THeader1 class file

author

Brad Anderson <javalizard@gmail.com>

version

$Id: THeader1.php 2590 2008-12-10 11:34:24Z carlgmathisen $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THeader1
THeader1 class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:24 +0200 by phpDocumentor 1.4.3


Docs for page THeader2.php

File: /Web/UI/WebControls/THeader2.php

Remarks

THeader2 class file

author

Brad Anderson <javalizard@gmail.com>

version

$Id: THeader2.php 2590 2008-12-10 11:34:24Z carlgmathisen $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THeader2
THeader2 class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:24 +0200 by phpDocumentor 1.4.3


Docs for page THeader3.php

File: /Web/UI/WebControls/THeader3.php

Remarks

THeader3 class file

author

Brad Anderson <javalizard@gmail.com>

version

$Id: THeader3.php 2590 2008-12-10 11:34:24Z carlgmathisen $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THeader3
THeader3 class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:25 +0200 by phpDocumentor 1.4.3


Docs for page THeader4.php

File: /Web/UI/WebControls/THeader4.php

Remarks

THeader4 class file

author

Brad Anderson <javalizard@gmail.com>

version

$Id: THeader4.php 2590 2008-12-10 11:34:24Z carlgmathisen $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THeader4
THeader4 class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:25 +0200 by phpDocumentor 1.4.3


Docs for page THeader5.php

File: /Web/UI/WebControls/THeader5.php

Remarks

THeader5 class file

author

Brad Anderson <javalizard@gmail.com>

version

$Id: THeader5.php 2590 2008-12-10 11:34:24Z carlgmathisen $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THeader5
THeader5 class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:26 +0200 by phpDocumentor 1.4.3


Docs for page THeader6.php

File: /Web/UI/WebControls/THeader6.php

Remarks

THeader6 class file

author

Brad Anderson <javalizard@gmail.com>

version

$Id: THeader6.php 2590 2008-12-10 11:34:24Z carlgmathisen $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THeader6
THeader6 class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:26 +0200 by phpDocumentor 1.4.3


Docs for page THiddenField.php

File: /Web/UI/WebControls/THiddenField.php

Remarks

THiddenField class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THiddenField.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.xisc.com/

license

BSD License

Classes in this file:
THiddenField
THiddenField class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:26 +0200 by phpDocumentor 1.4.3


Docs for page THtmlArea.php

File: /Web/UI/WebControls/THtmlArea.php

Remarks

THtmlArea class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: THtmlArea.php 3159 2012-06-01 18:01:40Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THtmlArea
THtmlArea class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:27 +0200 by phpDocumentor 1.4.3


Docs for page THtmlElement.php

File: /Web/UI/WebControls/THtmlElement.php

Remarks

THtmlElement class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THtmlElement.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THtmlElement
THtmlElement class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:28 +0200 by phpDocumentor 1.4.3


Docs for page THyperLink.php

File: /Web/UI/WebControls/THyperLink.php

Remarks

THyperLink class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THyperLink.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.xisc.com/

license

BSD License

Classes in this file:
THyperLink
THyperLink class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:31 +0200 by phpDocumentor 1.4.3


Docs for page THyperLinkColumn.php

File: /Web/UI/WebControls/THyperLinkColumn.php

Remarks

THyperLinkColumn class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THyperLinkColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THyperLinkColumn
THyperLinkColumn class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:32 +0200 by phpDocumentor 1.4.3


Docs for page TImage.php

File: /Web/UI/WebControls/TImage.php

Remarks

TImage class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImage.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TImage
TImage class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:32 +0200 by phpDocumentor 1.4.3


Docs for page TImageButton.php

File: /Web/UI/WebControls/TImageButton.php

Remarks

TImageButton class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImageButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TImageButton
TImageButton class
TImageClickEventParameter
TImageClickEventParameter class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:33 +0200 by phpDocumentor 1.4.3


Docs for page TImageMap.php

File: /Web/UI/WebControls/TImageMap.php

Remarks

TImageMap and related class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImageMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TImageMap
TImageMap class
TImageMapEventParameter
TImageMapEventParameter class.
THotSpotCollection
THotSpotCollection class.
THotSpot
THotSpot class.
TCircleHotSpot
Class TCircleHotSpot.
TRectangleHotSpot
Class TRectangleHotSpot.
TPolygonHotSpot
Class TPolygonHotSpot.
THotSpotMode
THotSpotMode class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:34 +0200 by phpDocumentor 1.4.3


Docs for page TInlineFrame.php

File: /Web/UI/WebControls/TInlineFrame.php

Remarks

TInlineFrame class file.

author

Harry Pottash <hpottash@gmail.com>

author

Jason Ragsdale <jrags@jasrags.net>

version

$Id: TInlineFrame.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TInlineFrame
TInlineFrame class
TInlineFrameAlign
TInlineFrameAlign class.
TInlineFrameScrollBars
TInlineFrameScrollBars class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:36 +0200 by phpDocumentor 1.4.3


Docs for page TItemDataRenderer.php

File: /Web/UI/WebControls/TItemDataRenderer.php

Remarks

TItemDataRenderer class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TItemDataRenderer.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

since

3.1.2

license

http://www.pradosoft.com/license/

Classes in this file:
TItemDataRenderer
TItemDataRenderer class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:38 +0200 by phpDocumentor 1.4.3


Docs for page TJavascriptLogger.php

File: /Web/UI/WebControls/TJavascriptLogger.php

Remarks

TJavascriptLogger class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TJavascriptLogger.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TJavascriptLogger
TJavascriptLogger class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:39 +0200 by phpDocumentor 1.4.3


Docs for page TKeyboard.php

File: /Web/UI/WebControls/TKeyboard.php

Remarks

TKeyboard class file.

author

Sergey Morkovkin <sergeymorkovkin@mail.ru> and Qiang Xue <qiang.xue@gmail.com>

version

$Id: TKeyboard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

since

3.1.1

license

http://www.pradosoft.com/license/

Classes in this file:
TKeyboard
Class TKeyboard.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:39 +0200 by phpDocumentor 1.4.3


Docs for page TLabel.php

File: /Web/UI/WebControls/TLabel.php

Remarks

TLabel class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLabel.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TLabel
TLabel class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:40 +0200 by phpDocumentor 1.4.3


Docs for page TLinkButton.php

File: /Web/UI/WebControls/TLinkButton.php

Remarks

TLinkButton class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLinkButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TLinkButton
TLinkButton class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:41 +0200 by phpDocumentor 1.4.3


Docs for page TListBox.php

File: /Web/UI/WebControls/TListBox.php

Remarks

TListBox class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TListBox.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TListBox
TListBox class
TListSelectionMode
TListSelectionMode class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:42 +0200 by phpDocumentor 1.4.3


Docs for page TListControl.php

File: /Web/UI/WebControls/TListControl.php

Remarks

TListControl class file

author

Qiang Xue <qiang.xue@gmail.com>

author

Robin J. Rogge <rojaro@gmail.com>

version

$Id: TListControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TListControl
TListControl class
IListControlAdapter
IListControlAdapter interface

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:43 +0200 by phpDocumentor 1.4.3


Docs for page TListControlValidator.php

File: /Web/UI/WebControls/TListControlValidator.php

Remarks

TListControlValidator class file

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TListControlValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TListControlValidator
TListControlValidator class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:44 +0200 by phpDocumentor 1.4.3


Docs for page TListItem.php

File: /Web/UI/WebControls/TListItem.php

Remarks

TListItem class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TListItem.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TListItem
TListItem class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:45 +0200 by phpDocumentor 1.4.3


Docs for page TLiteral.php

File: /Web/UI/WebControls/TLiteral.php

Remarks

TLiteral class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLiteral.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TLiteral
TLiteral class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:45 +0200 by phpDocumentor 1.4.3


Docs for page TLiteralColumn.php

File: /Web/UI/WebControls/TLiteralColumn.php

Remarks

TLiteralColumn class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLiteralColumn.php 1397 2006-09-07 07:55:53Z wei $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TLiteralColumn
TLiteralColumn class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:46 +0200 by phpDocumentor 1.4.3


Docs for page TMarkdown.php

File: /Web/UI/WebControls/TMarkdown.php

Remarks

TMarkdown class file

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TMarkdown.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMarkdown
TMarkdown class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:49 +0200 by phpDocumentor 1.4.3


Docs for page TMultiView.php

File: /Web/UI/WebControls/TMultiView.php

Remarks

TMultiView and TView class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TMultiView.php 3055 2011-10-31 08:20:28Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMultiView
TMultiView class
TViewCollection
TViewCollection class.
TView
TView class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:52 +0200 by phpDocumentor 1.4.3


Docs for page TOutputCache.php

File: /Web/UI/WebControls/TOutputCache.php

Remarks

TOutputCache class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TOutputCache.php 3111 2012-02-14 07:58:17Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TOutputCache
TOutputCache class.
TOutputCacheCheckDependencyEventParameter
TOutputCacheCheckDependencyEventParameter class
TOutputCacheCalculateKeyEventParameter
TOutputCacheCalculateKeyEventParameter class
TOutputCacheTextWriterMulti
TTextWriter class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:56 +0200 by phpDocumentor 1.4.3


Docs for page TPager.php

File: /Web/UI/WebControls/TPager.php

Remarks

TPager class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPager
TPager class.
TPagerPageChangedEventParameter
TPagerPageChangedEventParameter class
TPagerMode
TPagerMode class.
TPagerButtonType
TPagerButtonType class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:59 +0200 by phpDocumentor 1.4.3


Docs for page TPanel.php

File: /Web/UI/WebControls/TPanel.php

Remarks

TPanel class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPanel.php 3088 2011-12-23 11:29:03Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPanel
TPanel class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:00 +0200 by phpDocumentor 1.4.3


Docs for page TPanelStyle.php

File: /Web/UI/WebControls/TPanelStyle.php

Remarks

TPanelStyle class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPanelStyle.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPanelStyle
TPanelStyle class.
TContentDirection
TContentDirection class.
TScrollBars
TScrollBars class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:01 +0200 by phpDocumentor 1.4.3


Docs for page TPlaceHolder.php

File: /Web/UI/WebControls/TPlaceHolder.php

Remarks

TPlaceHolder class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPlaceHolder.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPlaceHolder
TPlaceHolder class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:03 +0200 by phpDocumentor 1.4.3


Docs for page TRadioButton.php

File: /Web/UI/WebControls/TRadioButton.php

Remarks

TRadioButton class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRadioButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TRadioButton
TRadioButton class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:05 +0200 by phpDocumentor 1.4.3


Docs for page TRadioButtonList.php

File: /Web/UI/WebControls/TRadioButtonList.php

Remarks

TRadioButtonList class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRadioButtonList.php 3102 2012-02-05 17:00:00Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TRadioButtonList
TRadioButtonList class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:06 +0200 by phpDocumentor 1.4.3


Docs for page TRangeValidator.php

File: /Web/UI/WebControls/TRangeValidator.php

Remarks

TRangeValidator class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRangeValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TRangeValidator
TRangeValidator class
TRangeValidationDataType
TRangeValidationDataType class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:07 +0200 by phpDocumentor 1.4.3


Docs for page TRatingList.php

File: /Web/UI/WebControls/TRatingList.php

Remarks

TRatingList class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TRatingList.php 3137 2012-05-10 21:09:10Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TRatingList
TRatingList class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:08 +0200 by phpDocumentor 1.4.3


Docs for page TReCaptcha.php

File: /Web/UI/WebControls/TReCaptcha.php

Remarks

TReCaptcha class file

author

Bérczi Gábor <gabor.berczi@devworx.hu>

copyright

Copyright &copy; 2011 DevWorx

link

http://www.devworx.hu/

license

http://www.pradosoft.com/license/

Classes in this file:
TReCaptcha
TReCaptcha class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:09 +0200 by phpDocumentor 1.4.3


Docs for page TReCaptchaValidator.php

File: /Web/UI/WebControls/TReCaptchaValidator.php

Remarks

TReCaptchaValidator class file

author

Bérczi Gábor <gabor.berczi@devworx.hu>

copyright

Copyright &copy; 2011 DevWorx

link

http://www.devworx.hu/

license

http://www.pradosoft.com/license/

Classes in this file:
TReCaptchaValidator
TReCaptchaValidator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:10 +0200 by phpDocumentor 1.4.3


Docs for page TRegularExpressionValidator.php

File: /Web/UI/WebControls/TRegularExpressionValidator.php

Remarks

TRequiredFieldValidator class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRegularExpressionValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TRegularExpressionValidator
TRegularExpressionValidator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:10 +0200 by phpDocumentor 1.4.3


Docs for page TRepeater.php

File: /Web/UI/WebControls/TRepeater.php

Remarks

TRepeater class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeater.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TRepeater
TRepeater class.
TRepeaterItemEventParameter
TRepeaterItemEventParameter class
TRepeaterCommandEventParameter
TRepeaterCommandEventParameter class
TRepeaterItem
TRepeaterItem class
TRepeaterItemCollection
TRepeaterItemCollection class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:11 +0200 by phpDocumentor 1.4.3


Docs for page TRepeaterItemRenderer.php

File: /Web/UI/WebControls/TRepeaterItemRenderer.php

Remarks

TRepeaterItemRenderer class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeaterItemRenderer.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TRepeaterItemRenderer
TRepeaterItemRenderer class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:13 +0200 by phpDocumentor 1.4.3


Docs for page TRepeatInfo.php

File: /Web/UI/WebControls/TRepeatInfo.php

Remarks

IRepeatInfoUser, TRepeatInfo class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeatInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
IRepeatInfoUser
IRepeatInfoUser interface.
TRepeatInfo
TRepeatInfo class.
TRepeatDirection
TRepeatDirection class.
TRepeatLayout
TRepeatLayout class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:14 +0200 by phpDocumentor 1.4.3


Docs for page TRequiredFieldValidator.php

File: /Web/UI/WebControls/TRequiredFieldValidator.php

Remarks

TRequiredFieldValidator class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRequiredFieldValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TRequiredFieldValidator
TRequiredFieldValidator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:14 +0200 by phpDocumentor 1.4.3


Docs for page TSafeHtml.php

File: /Web/UI/WebControls/TSafeHtml.php

Remarks

TSafeHtml class file

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSafeHtml.php 3009 2011-07-06 13:23:26Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSafeHtml
TSafeHtml class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:16 +0200 by phpDocumentor 1.4.3


Docs for page TSlider.php

File: /Web/UI/WebControls/TSlider.php

Remarks

TSlider class file.

author

Christophe Boulain <Christophe.Boulain@gmail.com>

version

$Id: TSlider.php 3118 2012-03-24 22:52:29Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

since

3.1.1

license

http://www.pradosoft.com/license/

Classes in this file:
TSlider
TSlider class
TSliderClientScript
TSliderClientScript class.
TSliderDirection
TSliderDirection class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:22 +0200 by phpDocumentor 1.4.3


Docs for page TStatements.php

File: /Web/UI/WebControls/TStatements.php

Remarks

TStatements class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TStatements.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TStatements
TStatements class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:29 +0200 by phpDocumentor 1.4.3


Docs for page TStyle.php

File: /Web/UI/WebControls/TStyle.php

Remarks

TStyle class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TStyle.php 3045 2011-10-02 21:22:52Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TStyle
TStyle class
TDisplayStyle
TDisplayStyle defines the enumerable type for the possible styles that a web control can display.
TTableStyle
TTableStyle class.
TTableItemStyle
TTableItemStyle class.
THorizontalAlign
THorizontalAlign class.
TVerticalAlign
TVerticalAlign class.
TTableGridLines
TTableGridLines class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:29 +0200 by phpDocumentor 1.4.3


Docs for page TStyleSheet.php

File: /Web/UI/WebControls/TStyleSheet.php

Remarks

TStyleSheet class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TStyleSheet.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TStyleSheet
TStyleSheet class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:30 +0200 by phpDocumentor 1.4.3


Docs for page TTable.php

File: /Web/UI/WebControls/TTable.php

Remarks

TTable and TTableRowCollection class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTable.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTable
TTable class
TTableRowCollection
TTableRowCollection class.
TTableCaptionAlign
TTableCaptionAlign class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:30 +0200 by phpDocumentor 1.4.3


Docs for page TTableCell.php

File: /Web/UI/WebControls/TTableCell.php

Remarks

TTableCell class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableCell.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTableCell
TTableCell class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:31 +0200 by phpDocumentor 1.4.3


Docs for page TTableFooterRow.php

File: /Web/UI/WebControls/TTableFooterRow.php

Remarks

TTableFooterRow class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableFooterRow.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTableFooterRow
TTableFooterRow class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:32 +0200 by phpDocumentor 1.4.3


Docs for page TTableHeaderCell.php

File: /Web/UI/WebControls/TTableHeaderCell.php

Remarks

TTableHeaderCell class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableHeaderCell.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTableHeaderCell
TTableHeaderCell class.
TTableHeaderScope
TTableHeaderScope class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:33 +0200 by phpDocumentor 1.4.3


Docs for page TTableHeaderRow.php

File: /Web/UI/WebControls/TTableHeaderRow.php

Remarks

TTableHeaderRow class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableHeaderRow.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTableHeaderRow
TTableHeaderRow class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:34 +0200 by phpDocumentor 1.4.3


Docs for page TTableRow.php

File: /Web/UI/WebControls/TTableRow.php

Remarks

TTableRow and TTableCellCollection class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableRow.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTableRow
TTableRow class.
TTableCellCollection
TTableCellCollection class.
TTableRowSection
TTableRowSection class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:34 +0200 by phpDocumentor 1.4.3


Docs for page TTabPanel.php

File: /Web/UI/WebControls/TTabPanel.php

Remarks

TTabPanel class file.

author

Tomasz Wolny <tomasz.wolny@polecam.to.pl> and Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTabPanel.php 3161 2012-06-04 08:47:39Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

since

3.1.1

license

http://www.pradosoft.com/license/

Classes in this file:
TTabPanel
Class TTabPanel.
TTabView
TTabView class.
TTabViewCollection
TTabViewCollection class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:35 +0200 by phpDocumentor 1.4.3


Docs for page TTemplateColumn.php

File: /Web/UI/WebControls/TTemplateColumn.php

Remarks

TTemplateColumn class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTemplateColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTemplateColumn
TTemplateColumn class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:37 +0200 by phpDocumentor 1.4.3


Docs for page TTextBox.php

File: /Web/UI/WebControls/TTextBox.php

Remarks

TTextBox class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTextBox.php 3137 2012-05-10 21:09:10Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTextBox
TTextBox class
TTextBoxMode
TTextBoxMode class.
TTextBoxAutoCompleteType
TTextBoxAutoCompleteType class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:39 +0200 by phpDocumentor 1.4.3


Docs for page TTextHighlighter.php

File: /Web/UI/WebControls/TTextHighlighter.php

Remarks

TTextHighlighter class file

author

Wei Zhuo<weizhuo[at]gmail[dot]com>

version

$Id: TTextHighlighter.php 3159 2012-06-01 18:01:40Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTextHighlighter
TTextHighlighter class.
TTextHighlighterLineNumberStyle

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:40 +0200 by phpDocumentor 1.4.3


Docs for page TTextProcessor.php

File: /Web/UI/WebControls/TTextProcessor.php

Remarks

TTextProcessor class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTextProcessor.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTextProcessor
TTextProcessor class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:40 +0200 by phpDocumentor 1.4.3


Docs for page TValidationSummary.php

File: /Web/UI/WebControls/TValidationSummary.php

Remarks

TValidationSummary class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TValidationSummary.php 3116 2012-03-23 18:15:03Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TValidationSummary
TValidationSummary class
TClientSideValidationSummaryOptions
TClientSideValidationSummaryOptions class.
TValidationSummaryDisplayMode
TValidationSummaryDisplayMode class.
TValidationSummaryDisplayStyle
TValidationSummaryDisplay class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:45 +0200 by phpDocumentor 1.4.3


Docs for page TWebControl.php

File: /Web/UI/WebControls/TWebControl.php

Remarks

TWebControl class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWebControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TWebControl
TWebControl class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:47 +0200 by phpDocumentor 1.4.3


Docs for page TWebControlAdapter.php

File: /Web/UI/WebControls/TWebControlAdapter.php

Remarks

TWebControlAdapter class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWebControlAdapter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TWebControlAdapter
TWebControlAdapter class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:47 +0200 by phpDocumentor 1.4.3


Docs for page TWebControlDecorator.php

File: /Web/UI/WebControls/TWebControlDecorator.php

Remarks

TWebControlDecorator class file.

author

Brad Anderson <javalizard@gmail.com>

version

$Id: TWebControlDecorator.php 2541 2008-10-21 15:05:13Z qiang.xue $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TWebControlDecorator
TWebControlDecorator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:48 +0200 by phpDocumentor 1.4.3


Docs for page TWizard.php

File: /Web/UI/WebControls/TWizard.php

Remarks

TWizard and the relevant class definitions.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TWizard
Class TWizard.
TWizardStep
TWizardStep class.
TCompleteWizardStep
TCompleteWizardStep class.
TTemplatedWizardStep
TTemplatedWizardStep class.
TWizardStepCollection
TWizardStepCollection class.
TWizardNavigationContainer
TWizardNavigationContainer class.
TWizardNavigationEventParameter
TWizardNavigationEventParameter class.
TWizardSideBarTemplate
TWizardSideBarTemplate class.
TWizardSideBarListItemTemplate
TWizardSideBarListItemTemplate class.
TWizardNavigationTemplate
TWizardNavigationTemplate class.
TWizardStartNavigationTemplate
TWizardStartNavigationTemplate class.
TWizardFinishNavigationTemplate
TWizardFinishNavigationTemplate class.
TWizardStepNavigationTemplate
TWizardStepNavigationTemplate class.
TWizardNavigationButtonType
TWizardNavigationButtonType class.
TWizardStepType
TWizardStepType class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:48 +0200 by phpDocumentor 1.4.3


Docs for page TWizardNavigationButtonStyle.php

File: /Web/UI/WebControls/TWizardNavigationButtonStyle.php

Remarks

TWizardNavigationButtonStyle class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TWizardNavigationButtonStyle
TWizardNavigationButtonStyle class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:52 +0200 by phpDocumentor 1.4.3


Docs for page TXmlTransform.php

File: /Web/UI/WebControls/TXmlTransform.php

Remarks

TXmlTransform class file

author

Qiang Xue <qiang.xue@gmail.com>

author

Knut Urdalen <knut.urdalen@gmail.com>

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com

license

http://www.pradosoft.com/license/

Classes in this file:
TXmlTransform
TXmlTransform class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:54 +0200 by phpDocumentor 1.4.3


Docs For Class TAccordion

Class TAccordion

[line 67]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TAccordion
Location: /Web/UI/WebControls/TAccordion.php

Remarks

Class TAccordion.

TAccordion displays an accordion control. Users can click on the view headers to switch among different accordion views. Each accordion view is an independent panel that can contain arbitrary content.

A TAccordion control consists of one or several TAccordionView controls representing the possible accordion views. At any time, only one accordion view is visible (active), which is specified by any of the following properties:

  • ActiveViewIndex - the zero-based integer index of the view in the view collection.
  • ActiveViewID - the text ID of the visible view.
  • ActiveView - the visible view instance.
If both ActiveViewIndex and ActiveViewID are set, the latter takes precedence.

TAccordion uses CSS to specify the appearance of the accordion headers and panel. By default, an embedded CSS file will be published which contains the default CSS for TTabPanel. You may also use your own CSS file by specifying the CssUrl property. The following properties specify the CSS classes used for elements in a TAccordion:

  • CssClass - the CSS class name for the outer-most div element (defaults to 'accordion');
  • HeaderCssClass - the CSS class name for nonactive accordion div elements (defaults to 'accordion-header');
  • ActiveHeaderCssClass - the CSS class name for the active accordion div element (defaults to 'accordion-header-active');
  • ViewCssClass - the CSS class for the div element enclosing view content (defaults to 'accordion-view');
When the user clicks on a view header, the switch between the old visible view and the clicked one is animated. You can use the AnimationDuration property to set the animation length in seconds; it defaults to 1 second, and when set to 0 it will produce an immediate switch with no animation.

The TAccordion auto-sizes itself to the largest of all views, so it can encompass all of them without scrolling. If you want to specify a fixed height (in pixels), use the ViewHeight property. When a TAccordion is nested inside another, it's adviced to manually specify a ViewHeight for the internal TAccordion

To use TAccordion, write a template like following:

  •  <com:TAccordion>
    •

  •    <com:TAccordionView Caption="View 1">
    •

  •      content for view 1
    •

  •    </com:TAccordionView>
    •

  •    <com:TAccordionView Caption="View 2">
    •

  •      content for view 2
    •

  •    </com:TAccordionView>
    •

  •    <com:TAccordionView Caption="View 3">
    •

  •      content for view 3
    •

  •    </com:TAccordionView>
    •

  •  </com:TAccordion>
    •

    author

    Gabor Berczi, DevWorx Hungary <gabor.berczi@devworx.hu>

    version

    $Id: TAccordion.php 2915 2011-05-15 16:26:11Z ctrlaltca@gmail.com $

    since

    3.2

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TAccordion::activateView

      activateView( TAccordionView $view );

      Parameters

      $view

      the view to be activated. If null, all views will be deactivated.

      Remarks

      Activates the specified view.

      If there is any other view currently active, it will be deactivated.

      access

      protected

      [ Top ]

      TAccordion::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

      Parameters

      $writer

      the renderer

      Remarks

      Adds attributes to renderer.

      access

      protected

      [ Top ]

      TAccordion::addParsedObject

      addParsedObject( mixed $object );

      Overrides TControl::addParsedObject() (Adds the object instantiated on a template to the child control collection.)

      Parameters

      $object

      object parsed from template

      Remarks

      Adds object parsed from template to the control.

      This method adds only TAccordionView objects into the Views collection. All other objects are ignored.

      access

      public

      [ Top ]

      TAccordion::createControlCollection

      createControlCollection( );

      Overrides TControl::createControlCollection() (Creates a control collection object that is to be used to hold child controls)

      Returns

      control collection

      Remarks

      Creates a control collection object that is to be used to hold child controls

      access

      protected

      [ Top ]

      TAccordion::getActiveHeaderCssClass

      getActiveHeaderCssClass( );

      Returns

      Extra CSS class for the active header. Defaults to 'accordion-header-active'.

      access

      public

      [ Top ]

      TAccordion::getActiveHeaderStyle

      getActiveHeaderStyle( );

      Returns

      the style for the active header div

      access

      public

      [ Top ]

      TAccordion::getActiveView

      getActiveView( );

      Returns

      the currently active view, null if no active view

      Remarks

      Returns the currently active view.

      This method will examin the ActiveViewID, ActiveViewIndex and Views collection to determine which view is currently active. It will update ActiveViewID and ActiveViewIndex accordingly.

      throws

      TInvalidDataValueException if the active view ID or index set previously is invalid

      access

      public

      [ Top ]

      TAccordion::getActiveViewID

      getActiveViewID( );

      Returns

      The ID of the active accordion view. Defaults to '', meaning not set.

      Remarks

      Returns the ID of the active accordion view.

      Note, this property may not return the correct ID. To ensure the correctness, call getActiveView() first.

      access

      public

      [ Top ]

      TAccordion::getActiveViewIndex

      getActiveViewIndex( );

      Returns

      the zero-based index of the active accordion view. If -1, it means no active accordion view. Default is 0 (the first view is active).

      Remarks

      Returns the index of the active accordion view.

      Note, this property may not return the correct index. To ensure the correctness, call getActiveView() first.

      access

      public

      [ Top ]

      TAccordion::getAnimationDuration

      getAnimationDuration( );

      Returns

      CSS class for the currently displayed view div. Defaults to 'accordion-view'.

      access

      public

      [ Top ]

      TAccordion::getClientClassName

      getClientClassName( );

      Returns

      the javascript class name

      Remarks

      Gets the name of the javascript class responsible for performing postback for this control.

      This method overrides the parent implementation.

      access

      protected

      [ Top ]

      TAccordion::getClientOptions

      getClientOptions( );

      Returns

      the options for JavaScript

      access

      protected

      [ Top ]

      TAccordion::getCssClass

      getCssClass( );

      Overrides TWebControl::getCssClass() (parent method not documented)

      Returns

      CSS class for the whole accordion control div.

      access

      public

      [ Top ]

      TAccordion::getCssUrl

      getCssUrl( );

      Returns

      URL for the CSS file including all relevant CSS class definitions. Defaults to ''.

      access

      public

      [ Top ]

      TAccordion::getDataChanged

      getDataChanged( );

      Returns

      whether postback has caused the control data change. False if the page is not in postback mode.

      Remarks

      Returns a value indicating whether postback has caused the control data change.

      This method is required by the IPostBackDataHandler interface.

      access

      public

      [ Top ]

      TAccordion::getHeaderCssClass

      getHeaderCssClass( );

      Returns

      CSS class for view headers. Defaults to 'accordion-header'.

      access

      public

      [ Top ]

      TAccordion::getHeaderStyle

      getHeaderStyle( );

      Returns

      the style for all the inactive header div

      access

      public

      [ Top ]

      TAccordion::getTagName

      getTagName( );

      Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

      Returns

      tag name for the control

      access

      protected

      [ Top ]

      TAccordion::getViewCssClass

      getViewCssClass( );

      Returns

      CSS class for the currently displayed view div. Defaults to 'accordion-view'.

      access

      public

      [ Top ]

      TAccordion::getViewHeight

      getViewHeight( );

      Returns

      Maximum height for the accordion views. If non specified, the accordion will auto-sized to the largest of all views, so it can encompass all of them without scrolling

      access

      public

      [ Top ]

      TAccordion::getViews

      getViews( );

      Returns

      list of TAccordionView controls

      access

      public

      [ Top ]

      TAccordion::getViewStyle

      getViewStyle( );

      Returns

      the style for all the view div

      access

      public

      [ Top ]

      TAccordion::loadPostData

      loadPostData( string $key, array $values );

      Parameters

      $key

      the key that can be used to retrieve data from the input data collection

      $values

      the input data collection

      Returns

      whether the data of the control has been changed

      Remarks

      Loads user input data.

      This method is primarly used by framework developers.

      access

      public

      [ Top ]

      TAccordion::onPreRender

      onPreRender( mixed $param );

      Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

      Parameters

      $param

      event parameter

      Remarks

      Registers CSS and JS.

      This method is invoked right before the control rendering, if the control is visible.

      access

      public

      [ Top ]

      TAccordion::raisePostDataChangedEvent

      raisePostDataChangedEvent( );

      Remarks

      Raises postdata changed event.

      This method is required by IPostBackDataHandler interface. It is invoked by the framework when ActiveViewIndex property is changed on postback. This method is primarly used by framework developers.

      access

      public

      [ Top ]

      TAccordion::registerClientScript

      registerClientScript( );

      Remarks

      Registers the relevant JavaScript.

      access

      protected

      [ Top ]

      TAccordion::registerStyleSheet

      registerStyleSheet( );

      Remarks

      Registers the CSS relevant to the TAccordion.

      It will register the CSS file specified by CssUrl. If that is not set, it will use the default CSS.

      access

      protected

      [ Top ]

      TAccordion::render

      render( $writer );

      Overrides TWebControl::render() (Renders the control.)

      Parameters

      $writer

      access

      public

      [ Top ]

      TAccordion::renderContents

      renderContents( THtmlWriter $writer );

      Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

      Parameters

      $writer

      the writer used for the rendering purpose.

      Remarks

      Renders body contents of the accordion control.

      access

      public

      [ Top ]

      TAccordion::setActiveHeaderCssClass

      setActiveHeaderCssClass( string $value );

      Parameters

      $value

      Extra CSS class for the active header. Will be added to the normal header specified by HeaderCssClass.

      access

      public

      [ Top ]

      TAccordion::setActiveView

      setActiveView( TAccordionView $view );

      Parameters

      $view

      the view to be activated

      throws

      TInvalidOperationException if the view is not in the view collection

      access

      public

      [ Top ]

      TAccordion::setActiveViewID

      setActiveViewID( string $value );

      Parameters

      $value

      The ID of the active accordion view.

      access

      public

      [ Top ]

      TAccordion::setActiveViewIndex

      setActiveViewIndex( integer $value );

      Parameters

      $value

      the zero-based index of the current view in the view collection. -1 if no active view.

      throws

      TInvalidDataValueException if the view index is invalid

      access

      public

      [ Top ]

      TAccordion::setAnimationDuration

      setAnimationDuration( string $value );

      Parameters

      $value

      CSS class for the currently displayed view div.

      access

      public

      [ Top ]

      TAccordion::setCssUrl

      setCssUrl( string $value );

      Parameters

      $value

      URL for the CSS file including all relevant CSS class definitions.

      access

      public

      [ Top ]

      TAccordion::setHeaderCssClass

      setHeaderCssClass( string $value );

      Parameters

      $value

      CSS class for view headers.

      access

      public

      [ Top ]

      TAccordion::setViewCssClass

      setViewCssClass( string $value );

      Parameters

      $value

      CSS class for the currently displayed view div.

      access

      public

      [ Top ]

      TAccordion::setViewHeight

      setViewHeight( integer $value );

      Parameters

      $value

      Maximum height for the accordion views. If any of the accordion's views' content is larger, those views will be made scrollable when activated

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:42:59 +0200 by phpDocumentor 1.4.3


Docs For Class TAccordionView

Class TAccordionView

[line 552]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TAccordionView
Location: /Web/UI/WebControls/TAccordion.php

Remarks

Class TAccordionView.

TAccordionView represents a single view in a TAccordion.

TAccordionView is represented inside the TAccordion with an header label whose text is defined by the Caption property; optionally the label can be an hyperlink: use the NavigateUrl property to define the destination url.

author

Gabor Berczi, DevWorx Hungary <gabor.berczi@devworx.hu>

version

$Id: TAccordion.php 2915 2011-05-15 16:26:11Z ctrlaltca@gmail.com $

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TAccordionView::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    the renderer

    Remarks

    Adds attributes to renderer.

    access

    protected

    [ Top ]

    TAccordionView::getActive

    getActive( );

    Returns

    whether this accordion view is active. Defaults to false.

    access

    public

    [ Top ]

    TAccordionView::getCaption

    getCaption( );

    Returns

    the caption displayed on this header. Defaults to ''.

    access

    public

    [ Top ]

    TAccordionView::getNavigateUrl

    getNavigateUrl( );

    Returns

    the URL of the target page. Defaults to ''.

    access

    public

    [ Top ]

    TAccordionView::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name for the view element

    access

    protected

    [ Top ]

    TAccordionView::getText

    getText( );

    Returns

    the text content displayed on this view. Defaults to ''.

    access

    public

    [ Top ]

    TAccordionView::renderContents

    renderContents( THtmlWriter $writer );

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    the writer used for the rendering purpose.

    Remarks

    Renders body contents of the accordion view.

    access

    public

    [ Top ]

    TAccordionView::renderHeader

    renderHeader( THtmlWriter $writer );

    Parameters

    $writer

    the writer for rendering purpose.

    Remarks

    Renders the header associated with the accordion view.

    access

    public

    [ Top ]

    TAccordionView::renderHeaderContent

    renderHeaderContent( THtmlWriter $writer );

    Parameters

    $writer

    the HTML writer

    Remarks

    Renders the content in the header.

    By default, a hyperlink is displayed.

    access

    protected

    [ Top ]

    TAccordionView::setActive

    setActive( boolean $value );

    Parameters

    $value

    whether this accordion view is active.

    access

    public

    [ Top ]

    TAccordionView::setCaption

    setCaption( string $value );

    Parameters

    $value

    the caption displayed on this header

    access

    public

    [ Top ]

    TAccordionView::setNavigateUrl

    setNavigateUrl( string $value );

    Parameters

    $value

    the URL of the target page.

    Remarks

    Sets the URL of the target page.

    If not empty, clicking on this header will redirect the browser to the specified URL.

    access

    public

    [ Top ]

    TAccordionView::setText

    setText( string $value );

    Parameters

    $value

    the text content displayed on this view

    Remarks

    Sets the text content to be displayed on this view.

    If this is not empty, the child content of the view will be ignored.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:00 +0200 by phpDocumentor 1.4.3


Docs For Class TAccordionViewCollection

Class TAccordionViewCollection

[line 711]
TComponent
   |
   --TList
      |
      --TControlCollection
         |
         --TAccordionViewCollection
Location: /Web/UI/WebControls/TAccordion.php

Remarks

Class TAccordionViewCollection.

TAccordionViewCollection is a collection of TAccordionView to be used inside a TAccordion.

author

Gabor Berczi, DevWorx Hungary <gabor.berczi@devworx.hu>

version

$Id: TAccordion.php 2915 2011-05-15 16:26:11Z ctrlaltca@gmail.com $

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControlCollection

  • TControlCollection::__construct()
    Constructor.
  • TControlCollection::clear()
    Overrides the parent implementation by invoking TControl::clearNamingContainer
  • TControlCollection::getOwner()
  • TControlCollection::insertAt()
    Inserts an item at the specified position.
  • TControlCollection::removeAt()
    Removes an item at the specified position.

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TAccordionViewCollection::findIndexByID

    findIndexByID( string $id );

    Parameters

    $id

    the explicit ID of the accordion view to be looked for

    Returns

    the index of the accordion view found, -1 if not found.

    Remarks

    Finds the index of the accordion view whose ID is the same as the one being looked for.

    access

    public

    [ Top ]

    TAccordionViewCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TControlCollection::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by performing sanity check on the type of new item.

    throws

    TInvalidDataTypeException if the item to be inserted is not a TAccordionView object.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:01 +0200 by phpDocumentor 1.4.3


Docs For Class TBaseDataList

Class TBaseDataList

[line 44]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TBaseDataList
Classes extended from TBaseDataList:
TDataGrid
TDataGrid class
TDataList
TDataList class

Location: /Web/UI/WebControls/TBaseDataList.php

Remarks

TBaseDataList class

TBaseDataList is the base class for data listing controls, including TDataList and TDataGrid.

The key field in the data source is specified by setKeyField, while getKeyValues stores the key values of each record in a data listing control. You may use the list item index to obtain the corresponding database key value.

TBaseDataList also implements a few properties used for presentation based on tabular layout. The setCaption, whose alignment is specified via setCaptionAlign, is rendered as the table caption. The table cellpadding and cellspacing are specified by CellPadding and CellSpacing properties, respectively. The GridLines specifies how the table should display its borders, and the horizontal alignment of the table content can be specified via HorizontalAlign.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TBaseDataList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TBaseDataList::createStyle

    createStyle( );

    Overridden in child classes as:

    TDataGrid::createStyle()
    Creates a style object for the control.

    Overrides TWebControl::createStyle() (Creates a style object to be used by the control.)

    Returns

    control style to be used

    Remarks

    Creates a style object for the control.

    This method creates a TTableStyle to be used by the data list control.

    access

    protected

    [ Top ]

    TBaseDataList::getCellPadding

    getCellPadding( );

    Returns

    the cellpadding for the table layout. Defaults to -1, meaning not set.

    access

    public

    [ Top ]

    TBaseDataList::getCellSpacing

    getCellSpacing( );

    Returns

    the cellspacing for the table layout. Defaults to -1, meaning not set.

    access

    public

    [ Top ]

    TBaseDataList::getDataFieldValue

    getDataFieldValue( mixed $data, mixed $field );

    Parameters

    $data

    data item

    $field

    field name

    Returns

    data value at the specified field

    Remarks

    Returns the value of the data at the specified field.

    If data is an array, TMap or TList, the value will be returned at the index of the specified field. If the data is a component with a property named as the field name, the property value will be returned. Otherwise, an exception will be raised.

    throws

    TInvalidDataValueException if the data is invalid

    access

    protected

    [ Top ]

    TBaseDataList::getDataKeyField

    getDataKeyField( );

    Returns

    the field of the data source that provides the keys of the list items.

    access

    public

    [ Top ]

    TBaseDataList::getDataKeys

    getDataKeys( );

    Returns

    the keys used in the data listing control.

    access

    public

    [ Top ]

    TBaseDataList::getGridLines

    getGridLines( );

    Returns

    the grid line setting of the table layout. Defaults to TTableGridLines::None.

    access

    public

    [ Top ]

    TBaseDataList::getHorizontalAlign

    getHorizontalAlign( );

    Returns

    the horizontal alignment of the table content. Defaults to THorizontalAlign::NotSet.

    access

    public

    [ Top ]

    TBaseDataList::onSelectedIndexChanged

    onSelectedIndexChanged( mixed $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnSelectedIndexChanged event.

    This method is invoked when a different item is selected in a data listing control between posts to the server.

    access

    public

    [ Top ]

    TBaseDataList::setCellPadding

    setCellPadding( integer $value );

    Parameters

    $value

    the cellpadding for the table layout

    access

    public

    [ Top ]

    TBaseDataList::setCellSpacing

    setCellSpacing( integer $value );

    Parameters

    $value

    the cellspacing for the table layout.

    access

    public

    [ Top ]

    TBaseDataList::setDataKeyField

    setDataKeyField( string $value );

    Parameters

    $value

    the field of the data source that provides the keys of the list items.

    access

    public

    [ Top ]

    TBaseDataList::setGridLines

    setGridLines( TTableGridLines $value );

    Parameters

    $value

    the grid line setting of the table

    Remarks

    Sets the grid line style of the table layout.

    access

    public

    [ Top ]

    TBaseDataList::setHorizontalAlign

    setHorizontalAlign( THorizontalAlign $value );

    Parameters

    $value

    the horizontal alignment of the table content.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:34 +0200 by phpDocumentor 1.4.3


Docs For Class TBaseValidator

Class TBaseValidator

[line 77]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
Classes extended from TBaseValidator:
TCaptchaValidator
TCaptchaValidator class
TCompareValidator
TCompareValidator class
TCustomValidator
TCustomValidator class
TDataTypeValidator
TDataTypeValidator class
TListControlValidator
TListControlValidator class.
TRangeValidator
TRangeValidator class
TReCaptchaValidator
TReCaptchaValidator class
TRegularExpressionValidator
TRegularExpressionValidator class
TRequiredFieldValidator
TRequiredFieldValidator class

Location: /Web/UI/WebControls/TBaseValidator.php

Remarks

TBaseValidator class

TBaseValidator serves as the base class for validator controls.

Validation is performed when a postback control, such as a TButton, a TLinkButton or a TTextBox (under AutoPostBack mode) is submitting the page and its CausesValidation property is true. You can also manually perform validation by calling TPage::validate(). The input control to be validated is specified by ControlToValidate.

Validator controls always validate the associated input control on the serve side. In addition, if EnableClientScript is true, validation will also be performed on the client-side using javascript. Client-side validation will validate user input before it is sent to the server. The form data will not be submitted if any error is detected. This avoids the round-trip of information necessary for server-side validation.

You can use multiple validator controls to validate a single input control, each responsible for validating against a different criteria. For example, on a user registration form, you may want to make sure the user enters a value in the username text box, and the input must consist of only word characters. You can use a TRequiredFieldValidator to ensure the input of username and a TRegularExpressionValidator to ensure the proper input.

If an input control fails validation, the text specified by the ErrorMessage property is displayed in the validation control. However, if the Text property is set, it will be displayed instead. If both ErrorMessage and Text are empty, the body content of the validator will be displayed. Error display is controlled by Display property.

You can also customized the client-side behaviour by adding javascript code to the subproperties of the ClientSide property. See quickstart documentation for further details.

You can also place a TValidationSummary control on a page to display error messages from the validators together. In this case, only the ErrorMessage property of the validators will be displayed in the TValidationSummary control.

Validators can be partitioned into validation groups by setting their ValidationGroup property. If the control causing the validation also sets its ValidationGroup property, only those validators having the same ValidationGroup value will do input validation.

Note, the TPage::getIsValid property of the current TPage instance will be automatically updated by the validation process which occurs after TPage::onLoad of TPage and before the postback events. Therefore, if you use the TPage::getIsValid() property in the TPage::onLoad() method, you must first explicitly call the TPage::validate() method.

Notes to Inheritors When you inherit from TBaseValidator, you must override the method evaluateIsValid.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TBaseValidator.php 3159 2012-06-01 18:01:40Z ctrlaltca $

abstract

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TLabel

  • TLabel::addAttributesToRender()
    Adds attributes to renderer.
  • TLabel::getData()
    Returns the text value of the label.
  • TLabel::getForControl()
  • TLabel::getTagName()
  • TLabel::getText()
  • TLabel::render()
    Renders the label.
  • TLabel::renderContents()
    Renders the body content of the label.
  • TLabel::setData()
    Sets the text value of the label.
  • TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
  • TLabel::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TBaseValidator::__construct

    __construct( );

    Overridden in child classes as:

    TActiveCustomValidator::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Constructor.

    This method sets the foreground color to red.

    access

    public

    [ Top ]

    TBaseValidator::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveCustomValidator::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    Overrides TLabel::addAttributesToRender() (Adds attributes to renderer.)

    Parameters

    $writer

    the renderer

    Remarks

    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.

    access

    protected

    [ Top ]

    TBaseValidator::createClientSide

    createClientSide( );

    Returns

    javascript validator event options.

    access

    protected

    [ Top ]

    TBaseValidator::evaluateIsValid

    evaluateIsValid( );

    Overridden in child classes as:

    TCaptchaValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    TCompareValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    TCustomValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    TDataTypeValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    TListControlValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    TRangeValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    TReCaptchaValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    TRegularExpressionValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    TEmailAddressValidator::evaluateIsValid()
    Returns an array of javascript validator options.
    TRequiredFieldValidator::evaluateIsValid()
    This method overrides the parent's implementation.

    Returns

    whether the validation succeeds

    Remarks

    This is the major method for validation.

    Derived classes should implement this method to provide customized validation.

    abstract

    access

    protected

    [ Top ]

    TBaseValidator::getClientClassName

    getClientClassName( );

    Overridden in child classes as:

    TCaptchaValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    TCompareValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    TCustomValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    TActiveCustomValidator::getClientClassName()
    TDataTypeValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    TListControlValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    TRangeValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    TReCaptchaValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    TRegularExpressionValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    TEmailAddressValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    TRequiredFieldValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing validation for this control.

    This method overrides the parent implementation.

    abstract

    access

    protected

    [ Top ]

    TBaseValidator::getClientScriptOptions

    getClientScriptOptions( );

    Overridden in child classes as:

    TCaptchaValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    TCompareValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    TCustomValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    TActiveCustomValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    TDataTypeValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    TListControlValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    TRangeValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    TReCaptchaValidator::getClientScriptOptions()
    TRegularExpressionValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    TRequiredFieldValidator::getClientScriptOptions()
    Returns an array of javascript validator options.

    Returns

    javascript validator options.

    Remarks

    Returns an array of javascript validator options.

    access

    protected

    [ Top ]

    TBaseValidator::getClientSide

    getClientSide( );

    Overridden in child classes as:

    TActiveCustomValidator::getClientSide()

    Returns

    javascript validator event options.

    Remarks

    Gets the TValidatorClientSide that allows modification of the client- side validator events.

    The client-side validator supports the following events.

    • <tt>OnValidate</tt> -- raised before client-side validation is
    executed.
    • <tt>OnValidationSuccess</tt> -- raised after client-side validation is completed
    and is successfull, overrides default validator error messages updates.
    • <tt>OnValidationError</tt> -- raised after client-side validation is completed
    and failed, overrides default validator error message updates.

    You can attach custom javascript code to each of these events

    access

    public

    [ Top ]

    TBaseValidator::getControlCssClass

    getControlCssClass( );

    Returns

    the css class that is applied to the control being validated in case the validation fails

    access

    public

    [ Top ]

    TBaseValidator::getControlToValidate

    getControlToValidate( );

    Returns

    the ID path of the input control to validate

    access

    public

    [ Top ]

    TBaseValidator::getDisplay

    getDisplay( );

    Overrides TWebControl::getDisplay() (parent method not documented)

    Returns

    the style of displaying the error message. Defaults to TValidatorDisplayStyle::Fixed.

    access

    public

    [ Top ]

    TBaseValidator::getEnableClientScript

    getEnableClientScript( );

    Overridden in child classes as:

    TActiveCustomValidator::getEnableClientScript()
    It's mandatory for the EnableClientScript to be activated or the TActiveCustomValidator won't work.
    TReCaptchaValidator::getEnableClientScript()

    Returns

    whether client-side validation is enabled.

    access

    public

    [ Top ]

    TBaseValidator::getErrorMessage

    getErrorMessage( );

    Returns

    the text for the error message.

    access

    public

    [ Top ]

    TBaseValidator::getFocusElementID

    getFocusElementID( );

    Returns

    the ID of the HTML element to receive focus

    Remarks

    Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.

    Defaults to the client ID of the ControlToValidate.

    access

    public

    [ Top ]

    TBaseValidator::getFocusOnError

    getFocusOnError( );

    Returns

    whether to set focus at the validating place if the validation fails. Defaults to false.

    access

    public

    [ Top ]

    TBaseValidator::getIsValid

    getIsValid( );

    Returns

    whether the validation succeeds

    access

    public

    [ Top ]

    TBaseValidator::getValidationGroup

    getValidationGroup( );

    Returns

    the group which this validator belongs to

    access

    public

    [ Top ]

    TBaseValidator::getValidationTarget

    getValidationTarget( );

    Overridden in child classes as:

    TCustomValidator::getValidationTarget()

    Returns

    control to be validated. Null if no control is found.

    throws

    TConfigurationException if ControlToValidate is empty or does not point to a valid control

    access

    public

    [ Top ]

    TBaseValidator::getValidationValue

    getValidationValue( TControl $control );

    Parameters

    $control

    control being validated

    Returns

    property value to be validated

    Remarks

    Retrieves the property value of the control being validated.

    throws

    TInvalidDataTypeException if the control to be validated does not implement IValidatable.

    access

    protected

    [ Top ]

    TBaseValidator::onInit

    onInit( mixed $param );

    Overrides TControl::onInit() (This method is invoked when the control enters 'OnInit' stage.)

    Parameters

    $param

    event parameter

    Remarks

    Registers the validator with page.

    access

    public

    [ Top ]

    TBaseValidator::onPreRender

    onPreRender( $param );

    Overridden in child classes as:

    TReCaptchaValidator::onPreRender()

    Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

    Parameters

    $param

    Remarks

    Override parent implementation to update the control CSS Class before

    the validated control is rendered

    access

    public

    [ Top ]

    TBaseValidator::onUnload

    onUnload( mixed $param );

    Overrides TControl::onUnload() (This method is invoked when the control enters 'OnUnload' stage.)

    Parameters

    $param

    event parameter

    Remarks

    Unregisters the validator from page.

    access

    public

    [ Top ]

    TBaseValidator::onValidate

    onValidate( );

    Remarks

    This event is raised right before the validator starts to perform validation.

    You may use this event to change the behavior of validation. For example, you may disable the validator if certain condition is satisfied. Note, the event will NOT be raised if the validator is invisible.

    access

    public

    [ Top ]

    TBaseValidator::onValidationError

    onValidationError( );

    Remarks

    This event is raised when the validator fails in validation.

    access

    public

    [ Top ]

    TBaseValidator::onValidationSuccess

    onValidationSuccess( );

    Remarks

    This event is raised when the validator succeeds in validation.

    access

    public

    [ Top ]

    TBaseValidator::registerClientScriptValidator

    registerClientScriptValidator( );

    Overridden in child classes as:

    TCustomValidator::registerClientScriptValidator()
    Only register the client-side validator if setClientValidationFunction is set.

    Remarks

    Registers the individual validator client-side javascript code.

    access

    protected

    [ Top ]

    TBaseValidator::renderClientControlScript

    renderClientControlScript( THtmlWriter $writer );

    Parameters

    $writer

    the renderer

    Remarks

    Renders the javascript code to the end script.

    If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

    access

    public

    [ Top ]

    TBaseValidator::renderContents

    renderContents( THtmlWriter $writer );

    Overrides TLabel::renderContents() (Renders the body content of the label.)

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the validator control.

    access

    public

    [ Top ]

    TBaseValidator::setControlCssClass

    setControlCssClass( string $value );

    Parameters

    $value

    the css class that is applied to the control being validated in case the validation fails

    access

    public

    [ Top ]

    TBaseValidator::setControlToValidate

    setControlToValidate( string $value );

    Parameters

    $value

    the ID path

    Remarks

    Sets the ID path of the input control to validate.

    The ID path is the dot-connected IDs of the controls reaching from the validator's naming container to the target control.

    access

    public

    [ Top ]

    TBaseValidator::setDisplay

    setDisplay( TValidatorDisplayStyle $value );

    Overrides TWebControl::setDisplay() (parent method not documented)

    Parameters

    $value

    the style of displaying the error message

    access

    public

    [ Top ]

    TBaseValidator::setEnableClientScript

    setEnableClientScript( boolean $value );

    Parameters

    $value

    whether client-side validation is enabled.

    access

    public

    [ Top ]

    TBaseValidator::setEnabled

    setEnabled( boolean $value );

    Overrides TControl::setEnabled() (parent method not documented)

    Parameters

    $value

    whether the validator is enabled.

    Remarks

    This method overrides parent's implementation by setting setIsValid to true if disabled.

    access

    public

    [ Top ]

    TBaseValidator::setErrorMessage

    setErrorMessage( string $value );

    Overridden in child classes as:

    TActiveCustomValidator::setErrorMessage()
    Sets the text for the error message. Updates client-side erorr message.

    Parameters

    $value

    the error message

    Remarks

    Sets the text for the error message.

    access

    public

    [ Top ]

    TBaseValidator::setFocusElementID

    setFocusElementID( string $value );

    Parameters

    $value

    the ID of the HTML element to receive focus

    Remarks

    Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.

    access

    public

    [ Top ]

    TBaseValidator::setFocusOnError

    setFocusOnError( boolean $value );

    Parameters

    $value

    whether to set focus at the validating place if the validation fails

    access

    public

    [ Top ]

    TBaseValidator::setForControl

    setForControl( string $value );

    Overrides TLabel::setForControl() (Sets the ID of the control that the label is associated with.)

    Parameters

    $value

    the associated control ID

    Remarks

    This method overrides the parent implementation to forbid setting ForControl.

    throws

    TNotSupportedException whenever this method is called

    access

    public

    [ Top ]

    TBaseValidator::setIsValid

    setIsValid( boolean $value );

    Overridden in child classes as:

    TActiveCustomValidator::setIsValid()

    Parameters

    $value

    whether the validation succeeds

    Remarks

    Sets the value indicating whether the validation succeeds

    access

    public

    [ Top ]

    TBaseValidator::setValidationGroup

    setValidationGroup( string $value );

    Parameters

    $value

    the group which this validator belongs to

    access

    public

    [ Top ]

    TBaseValidator::updateControlCssClass

    updateControlCssClass( );

    Returns

    true if change, false otherwise.

    Remarks

    Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.

    access

    protected

    [ Top ]

    TBaseValidator::validate

    validate( );

    Returns

    whether the validation succeeds

    Remarks

    Validates the specified control.

    Do not override this method. Override evaluateIsValid instead.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:35 +0200 by phpDocumentor 1.4.3


Docs For Class TValidationDataType

Class TValidationDataType

[line 744]
TEnumerable
   |
   --TValidationDataType
Classes extended from TValidationDataType:
TRangeValidationDataType
TRangeValidationDataType class.

Location: /Web/UI/WebControls/TBaseValidator.php

Remarks

TValidationDataType class.

TValidationDataType defines the enumerable type for the possible data types that a comparison validator can validate upon.

The following enumerable values are defined:

  • Integer
  • Float
  • Date
  • String

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TBaseValidator.php 3159 2012-06-01 18:01:40Z ctrlaltca $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Date = 'Date'
  • Float = 'Float'
  • Integer = 'Integer'
  • String = 'String'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Date = 'Date' [line 748]

  • Float = 'Float' [line 747]

  • Integer = 'Integer' [line 746]

  • String = 'String' [line 749]

Documentation generated on Mon, 25 Jun 2012 14:43:36 +0200 by phpDocumentor 1.4.3


Docs For Class TValidatorClientSide

Class TValidatorClientSide

[line 631]
TComponent
   |
   --TClientSideOptions
      |
      --TValidatorClientSide
Location: /Web/UI/WebControls/TBaseValidator.php

Remarks

TValidatorClientSide class.

Client-side validator events can be modified through the TBaseValidator::getClientSide property of a validator. The subproperties of ClientSide are those of the TValidatorClientSide properties. The client-side validator supports the following events.

The <tt>OnValidate</tt> event is raise before the validator validation functions are called.

The <tt>OnValidationSuccess</tt> event is raised after the validator has successfully validate the control.

The <tt>OnValidationError</tt> event is raised after the validator fails validation.

See the quickstart documentation for further details.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TBaseValidator.php 3159 2012-06-01 18:01:40Z ctrlaltca $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TClientSideOptions

  • TClientSideOptions::__construct()
    Constructor, initialize the options list.
  • TClientSideOptions::ensureFunction()
    Ensure that the javascript statements are wrapped in a javascript function block as
  • function(sender, parameter){ //code }
    •
    .
  • TClientSideOptions::getOption()
  • TClientSideOptions::getOptions()
  • TClientSideOptions::setFunction()
    Adds on client-side event handler by wrapping the code within a javascript function block. If the code begins with "javascript:", the code is assumed to be a javascript function block rather than arbiturary javascript statements.
  • TClientSideOptions::setOption()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TValidatorClientSide::getObserveChanges

    getObserveChanges( );

    Returns

    true to observe changes.

    access

    public

    [ Top ]

    TValidatorClientSide::getOnValidate

    getOnValidate( );

    Returns

    javascript code for client-side OnValidate event.

    access

    public

    [ Top ]

    TValidatorClientSide::getOnValidationError

    getOnValidationError( );

    Returns

    javascript code for client-side OnError event.

    access

    public

    [ Top ]

    TValidatorClientSide::getOnValidationSuccess

    getOnValidationSuccess( );

    Returns

    javascript code for client-side OnSuccess event.

    access

    public

    [ Top ]

    TValidatorClientSide::setObserveChanges

    setObserveChanges( boolean $value );

    Parameters

    $value

    true to revalidate when the control to validate changes value.

    access

    public

    [ Top ]

    TValidatorClientSide::setOnValidate

    setOnValidate( string $javascript );

    Parameters

    $javascript

    javascript code for client-side OnValidate event.

    Remarks

    Client-side OnValidate validator event is raise before the validators validation functions are called.

    access

    public

    [ Top ]

    TValidatorClientSide::setOnValidationError

    setOnValidationError( string $javascript );

    Parameters

    $javascript

    javascript code for client-side OnError event.

    Remarks

    Client-side OnError event is raised after validation failure.

    This will override the default client-side validator behaviour.

    access

    public

    [ Top ]

    TValidatorClientSide::setOnValidationSuccess

    setOnValidationSuccess( string $javascript );

    Parameters

    $javascript

    javascript code for client-side OnSuccess event.

    Remarks

    Client-side OnSuccess event is raise after validation is successfull.

    This will override the default client-side validator behaviour.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:36 +0200 by phpDocumentor 1.4.3


Docs For Class TValidatorDisplayStyle

Class TValidatorDisplayStyle

[line 721]
TEnumerable
   |
   --TValidatorDisplayStyle
Location: /Web/UI/WebControls/TBaseValidator.php

Remarks

TValidatorDisplayStyle class.

TValidatorDisplayStyle defines the enumerable type for the possible styles that a validator control can display the error message.

The following enumerable values are defined:

  • None: the error message is not displayed
  • Dynamic: the error message dynamically appears when the validator fails validation
  • Fixed: Similar to Dynamic except that the error message physically occupies the page layout (even though it may not be visible)

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TBaseValidator.php 3159 2012-06-01 18:01:40Z ctrlaltca $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Dynamic = 'Dynamic'
  • Fixed = 'Fixed'
  • None = 'None'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Dynamic = 'Dynamic' [line 724]

  • Fixed = 'Fixed' [line 725]

  • None = 'None' [line 723]

Documentation generated on Mon, 25 Jun 2012 14:43:36 +0200 by phpDocumentor 1.4.3


Docs For Class TBoundColumn

Class TBoundColumn

[line 49]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TBoundColumn
Classes extended from TBoundColumn:
TActiveBoundColumn
TActiveBoundColumn class

Location: /Web/UI/WebControls/TBoundColumn.php

Remarks

TBoundColumn class

TBoundColumn represents a column that is bound to a field in a data source. The cells in the column will be displayed using the data indexed by DataField. You can customize the display by setting DataFormatString.

If ReadOnly is false, TBoundColumn will display cells in edit mode with textboxes. Otherwise, a static text is displayed.

When a datagrid row is in edit mode, the textbox control in the TBoundColumn can be accessed by one of the following two methods:

  •  $datagridItem->BoundColumnID->TextBox
    •

  •  $datagridItem->BoundColumnID->Controls[0]
    •
    The second method is possible because the textbox control created within the datagrid cell is the first child.

    Since v3.1.0, TBoundColumn has introduced two new properties ItemRenderer and EditItemRenderer which can be used to specify the layout of the datagrid cells in browsing and editing mode. A renderer refers to a control class that is to be instantiated as a control. For more details, see TRepeater and TDataList.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TBoundColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TDataGridColumn

    • TDataGridColumn::formatDataValue()
      Formats the text value according to a format string.
    • TDataGridColumn::getAllowSorting()
      Returns a value indicating whether this column allows sorting.
    • TDataGridColumn::getDataFieldValue()
      Fetches the value of the data at the specified field.
    • TDataGridColumn::getEnableCellGrouping()
    • TDataGridColumn::getFooterRenderer()
    • TDataGridColumn::getFooterStyle()
    • TDataGridColumn::getFooterText()
    • TDataGridColumn::getHeaderImageUrl()
    • TDataGridColumn::getHeaderRenderer()
    • TDataGridColumn::getHeaderStyle()
    • TDataGridColumn::getHeaderText()
    • TDataGridColumn::getID()
    • TDataGridColumn::getItemStyle()
    • TDataGridColumn::getOwner()
    • TDataGridColumn::getSortExpression()
    • TDataGridColumn::getViewState()
      Returns a viewstate value.
    • TDataGridColumn::getVisible()
    • TDataGridColumn::initialize()
      Initializes the column.
    • TDataGridColumn::initializeCell()
      Initializes the specified cell to its initial values.
    • TDataGridColumn::initializeFooterCell()
      Initializes the footer cell.
    • TDataGridColumn::initializeHeaderCell()
      Initializes the header cell.
    • TDataGridColumn::loadState()
      Loads persistent state values.
    • TDataGridColumn::saveState()
      Saves persistent state values.
    • TDataGridColumn::setEnableCellGrouping()
    • TDataGridColumn::setFooterRenderer()
      Sets the column footer cell renderer class.
    • TDataGridColumn::setFooterText()
    • TDataGridColumn::setHeaderImageUrl()
    • TDataGridColumn::setHeaderRenderer()
      Sets the column header cell renderer class.
    • TDataGridColumn::setHeaderText()
    • TDataGridColumn::setID()
      Sets the ID of the column.
    • TDataGridColumn::setOwner()
    • TDataGridColumn::setSortExpression()
    • TDataGridColumn::setViewState()
      Sets a viewstate value.
    • TDataGridColumn::setVisible()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TBoundColumn::dataBindColumn

      dataBindColumn( $sender, $param );

      Parameters

      $sender

      $param

      Remarks

      Databinds a cell in the column.

      This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

      access

      public

      [ Top ]

      TBoundColumn::getDataField

      getDataField( );

      Returns

      the field name from the data source to bind to the column

      access

      public

      [ Top ]

      TBoundColumn::getDataFormatString

      getDataFormatString( );

      Returns

      the formatting string used to control how the bound data will be displayed.

      access

      public

      [ Top ]

      TBoundColumn::getEditItemRenderer

      getEditItemRenderer( );

      Returns

      the class name for the edit item cell renderer. Defaults to empty, meaning not set.

      since

      3.1.0

      access

      public

      [ Top ]

      TBoundColumn::getItemRenderer

      getItemRenderer( );

      Returns

      the class name for the item cell renderer. Defaults to empty, meaning not set.

      since

      3.1.0

      access

      public

      [ Top ]

      TBoundColumn::getReadOnly

      getReadOnly( );

      Returns

      whether the items in the column can be edited. Defaults to false.

      access

      public

      [ Top ]

      TBoundColumn::initializeCell

      initializeCell( TTableCell $cell, integer $columnIndex, string $itemType );

      Overrides TDataGridColumn::initializeCell() (Initializes the specified cell to its initial values.)

      Parameters

      $cell

      the cell to be initialized.

      $columnIndex

      the index to the Columns property that the cell resides in.

      $itemType

      the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)

      Remarks

      Initializes the specified cell to its initial values.

      This method overrides the parent implementation. It creates a textbox for item in edit mode and the column is not read-only. Otherwise it displays a static text. The caption of the button and the static text are retrieved from the datasource.

      access

      public

      [ Top ]

      TBoundColumn::setDataField

      setDataField( string $value );

      Parameters

      $value

      the field name from the data source to bind to the column

      access

      public

      [ Top ]

      TBoundColumn::setDataFormatString

      setDataFormatString( string $value );

      Parameters

      $value

      the formatting string used to control how the bound data will be displayed.

      access

      public

      [ Top ]

      TBoundColumn::setEditItemRenderer

      setEditItemRenderer( string $value );

      Parameters

      $value

      the renderer class name in namespace format.

      Remarks

      Sets the edit item cell renderer class.

      If not empty, the class will be used to instantiate as a child control in the item cell that is in edit mode.

      If the class implements IDataRenderer, the Data property will be set as the data associated with the datagrid cell during databinding. The data can be either the whole data row or a field of the row if DataField is not empty. If DataFormatString is not empty, the data will be formatted first before passing to the renderer.

      since

      3.1.0

      access

      public

      [ Top ]

      TBoundColumn::setItemRenderer

      setItemRenderer( string $value );

      Parameters

      $value

      the renderer class name in namespace format.

      Remarks

      Sets the item cell renderer class.

      If not empty, the class will be used to instantiate as a child control in the item cells of the column.

      If the class implements IDataRenderer, the Data property will be set as the data associated with the datagrid cell during databinding. The data can be either the whole data row or a field of the row if DataField is not empty. If DataFormatString is not empty, the data will be formatted first before passing to the renderer.

      since

      3.1.0

      access

      public

      [ Top ]

      TBoundColumn::setReadOnly

      setReadOnly( boolean $value );

      Parameters

      $value

      whether the items in the column can be edited

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:36 +0200 by phpDocumentor 1.4.3


Docs For Class TBulletedList

Class TBulletedList

[line 40]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TBulletedList
Location: /Web/UI/WebControls/TBulletedList.php

Remarks

TBulletedList class

TBulletedList displays items in a bullet format. The bullet style is specified by BulletStyle. When the style is 'CustomImage', the setBackImageUrl specifies the image used as bullets.

TBulletedList displays the item texts in three different modes, specified via DisplayMode. When the mode is Text, the item texts are displayed as static texts; When the mode is 'HyperLink', each item is displayed as a hyperlink whose URL is given by the item value, and the Target property can be used to specify the target browser window; When the mode is 'LinkButton', each item is displayed as a link button which posts back to the page if a user clicks on that and the event OnClick will be raised under such a circumstance.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TBulletedList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TListControl

  • TListControl::addAttributesToRender()
    Adds attributes to renderer.
  • TListControl::addParsedObject()
    Adds object parsed from template to the control.
  • TListControl::clearSelection()
    Clears all existing selections.
  • TListControl::createListItemCollection()
    Creates a collection object to hold list items.
  • TListControl::formatDataValue()
    Formats the text value according to a format string.
  • TListControl::getAppendDataBoundItems()
  • TListControl::getAutoPostBack()
  • TListControl::getCausesValidation()
  • TListControl::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TListControl::getData()
    Returns the value of the selected item with the lowest cardinal index.
  • TListControl::getDataGroupField()
  • TListControl::getDataTextField()
  • TListControl::getDataTextFormatString()
  • TListControl::getDataValueField()
  • TListControl::getEnableClientScript()
  • TListControl::getHasItems()
  • TListControl::getIsMultiSelect()
  • TListControl::getItemCount()
  • TListControl::getItems()
  • TListControl::getPostBackOptions()
  • TListControl::getPromptText()
  • TListControl::getPromptValue()
  • TListControl::getSelectedIndex()
  • TListControl::getSelectedIndices()
  • TListControl::getSelectedItem()
  • TListControl::getSelectedValue()
  • TListControl::getSelectedValues()
  • TListControl::getTagName()
  • TListControl::getText()
  • TListControl::getValidationGroup()
  • TListControl::loadState()
    Loads items from viewstate.
  • TListControl::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event when selection is changed.
  • TListControl::onTextChanged()
    Raises OnTextChanged event when selection is changed.
  • TListControl::performDataBinding()
    Performs databinding to populate list items from data source.
  • TListControl::renderClientControlScript()
    Renders the javascript for list control.
  • TListControl::renderContents()
    Renders body content of the list control.
  • TListControl::renderPrompt()
    Renders the prompt text, if any.
  • TListControl::saveState()
    Saves items into viewstate.
  • TListControl::setAppendDataBoundItems()
  • TListControl::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TListControl::setCausesValidation()
  • TListControl::setData()
    Selects an item by the specified value.
  • TListControl::setDataGroupField()
  • TListControl::setDataTextField()
  • TListControl::setDataTextFormatString()
    Sets data text format string.
  • TListControl::setDataValueField()
  • TListControl::setEnableClientScript()
  • TListControl::setPromptText()
  • TListControl::setPromptValue()
  • TListControl::setSelectedIndex()
  • TListControl::setSelectedIndices()
  • TListControl::setSelectedValue()
    Sets selection by item value.
  • TListControl::setSelectedValues()
  • TListControl::setText()
  • TListControl::setValidationGroup()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TBulletedList::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overrides TListControl::addAttributesToRender() (Adds attributes to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attribute name-value pairs to renderer.

    This overrides the parent implementation with additional bulleted list specific attributes.

    access

    protected

    [ Top ]

    TBulletedList::canCauseValidation

    canCauseValidation( );

    access

    protected

    [ Top ]

    TBulletedList::getBulletImageUrl

    getBulletImageUrl( );

    Returns

    image URL used for bullets when BulletStyle is 'CustomImage'.

    access

    public

    [ Top ]

    TBulletedList::getBulletStyle

    getBulletStyle( );

    Returns

    style of bullets. Defaults to TBulletStyle::NotSet.

    access

    public

    [ Top ]

    TBulletedList::getClientClassName

    getClientClassName( );

    Overrides TListControl::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TBulletedList::getDisplayMode

    getDisplayMode( );

    Returns

    display mode of the list. Defaults to TBulletedListDisplayMode::Text.

    access

    public

    [ Top ]

    TBulletedList::getFirstBulletNumber

    getFirstBulletNumber( );

    Returns

    starting index when BulletStyle is one of the following: 'Numbered', 'LowerAlpha', 'UpperAlpha', 'LowerRoman', 'UpperRoman'. Defaults to 1.

    access

    public

    [ Top ]

    TBulletedList::getPostBackOptions

    getPostBackOptions( );

    Overrides TListControl::getPostBackOptions() (parent method not documented)

    Returns

    postback options used for linkbuttons.

    access

    protected

    [ Top ]

    TBulletedList::getTagName

    getTagName( );

    Overrides TListControl::getTagName() (parent method not documented)

    Returns

    tag name of the bulleted list

    access

    protected

    [ Top ]

    TBulletedList::getTarget

    getTarget( );

    Returns

    the target window or frame to display the Web page content linked to when DisplayMode is 'HyperLink' and one of the hyperlinks is clicked.

    access

    public

    [ Top ]

    TBulletedList::onClick

    onClick( TBulletedListEventParameter $param );

    Parameters

    $param

    event parameter.

    Remarks

    Raises 'OnClick' event.

    This method is invoked when the DisplayMode is 'LinkButton' and end-users click on one of the buttons.

    access

    public

    [ Top ]

    TBulletedList::raisePostBackEvent

    raisePostBackEvent( TEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the postback event.

    This method is required by IPostBackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick events. This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TBulletedList::render

    render( THtmlWriter $writer );

    Overrides TWebControl::render() (Renders the control.)

    Parameters

    $writer

    the writer for the rendering purpose.

    Remarks

    Renders the control.

    access

    public

    [ Top ]

    TBulletedList::renderBulletText

    renderBulletText( THtmlWriter $writer, TListItem $item, integer $index );

    Parameters

    $writer

    writer for the rendering purpose

    $item

    item to be rendered

    $index

    index of the item being rendered

    Remarks

    Renders each item

    access

    protected

    [ Top ]

    TBulletedList::renderContents

    renderContents( THtmlWriter $writer );

    Overrides TListControl::renderContents() (Renders body content of the list control.)

    Parameters

    $writer

    the writer for the rendering purpose.

    Remarks

    Renders the body contents.

    access

    public

    [ Top ]

    TBulletedList::renderHyperLinkItem

    renderHyperLinkItem( $writer, $item, $index );

    Parameters

    $writer

    $item

    $index

    access

    protected

    [ Top ]

    TBulletedList::renderLinkButtonItem

    renderLinkButtonItem( $writer, $item, $index );

    Parameters

    $writer

    $item

    $index

    access

    protected

    [ Top ]

    TBulletedList::renderTextItem

    renderTextItem( $writer, $item, $index );

    Parameters

    $writer

    $item

    $index

    access

    protected

    [ Top ]

    TBulletedList::setAutoPostBack

    setAutoPostBack( $value );

    Overrides TListControl::setAutoPostBack() (Sets the value indicating if postback automatically.)

    Parameters

    $value

    throws

    TNotSupportedException if this method is invoked

    access

    public

    [ Top ]

    TBulletedList::setBulletImageUrl

    setBulletImageUrl( string $value );

    Parameters

    $value

    image URL used for bullets when BulletStyle is 'CustomImage'.

    access

    public

    [ Top ]

    TBulletedList::setBulletStyle

    setBulletStyle( TBulletStyle $value );

    Parameters

    $value

    style of bullets.

    access

    public

    [ Top ]

    TBulletedList::setDisplayMode

    setDisplayMode( $value );

    Parameters

    $value

    Returns

    display mode of the list.

    access

    public

    [ Top ]

    TBulletedList::setFirstBulletNumber

    setFirstBulletNumber( integer $value );

    Parameters

    $value

    starting index when BulletStyle is one of the following: 'Numbered', 'LowerAlpha', 'UpperAlpha', 'LowerRoman', 'UpperRoman'.

    access

    public

    [ Top ]

    TBulletedList::setSelectedIndex

    setSelectedIndex( $index );

    Overrides TListControl::setSelectedIndex() (parent method not documented)

    Parameters

    $index

    throws

    TNotSupportedException if this method is invoked

    access

    public

    [ Top ]

    TBulletedList::setSelectedIndices

    setSelectedIndices( $indices );

    Overrides TListControl::setSelectedIndices() (parent method not documented)

    Parameters

    $indices

    throws

    TNotSupportedException if this method is invoked

    access

    public

    [ Top ]

    TBulletedList::setSelectedValue

    setSelectedValue( $value );

    Overrides TListControl::setSelectedValue() (Sets selection by item value.)

    Parameters

    $value

    throws

    TNotSupportedException if this method is invoked

    access

    public

    [ Top ]

    TBulletedList::setSelectedValues

    setSelectedValues( $values );

    Overrides TListControl::setSelectedValues() (parent method not documented)

    Parameters

    $values

    throws

    TNotSupportedException if this method is invoked

    access

    public

    [ Top ]

    TBulletedList::setTarget

    setTarget( string $value );

    Parameters

    $value

    the target window or frame to display the Web page content linked to when DisplayMode is 'HyperLink' and one of the hyperlinks is clicked.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:37 +0200 by phpDocumentor 1.4.3


Docs For Class TBulletedListDisplayMode

Class TBulletedListDisplayMode

[line 486]
TEnumerable
   |
   --TBulletedListDisplayMode
Location: /Web/UI/WebControls/TBulletedList.php

Remarks

TBulletedListDisplayMode class.

TBulletedListDisplayMode defines the enumerable type for the possible display mode of a TBulletedList control.

The following enumerable values are defined:

  • Text: the bulleted list items are displayed as plain texts
  • HyperLink: the bulleted list items are displayed as hyperlinks
  • LinkButton: the bulleted list items are displayed as link buttons that can cause postbacks

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TBulletedList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • HyperLink = 'HyperLink'
  • LinkButton = 'LinkButton'
  • Text = 'Text'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • HyperLink = 'HyperLink' [line 489]

  • LinkButton = 'LinkButton' [line 490]

  • Text = 'Text' [line 488]

Documentation generated on Mon, 25 Jun 2012 14:43:37 +0200 by phpDocumentor 1.4.3


Docs For Class TBulletedListEventParameter

Class TBulletedListEventParameter

[line 421]
TComponent
   |
   --TEventParameter
      |
      --TBulletedListEventParameter
Location: /Web/UI/WebControls/TBulletedList.php

Remarks

TBulletedListEventParameter Event parameter for TBulletedList::onClick event of the bulleted list. The getIndex gives the zero-based index of the item that is currently being clicked.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TBulletedList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TBulletedListEventParameter::__construct

    __construct( integer $index );

    Parameters

    $index

    index of the item clicked

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TBulletedListEventParameter::getIndex

    getIndex( );

    Returns

    zero-based index of the item (rendered as a link button) that is clicked

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:37 +0200 by phpDocumentor 1.4.3


Docs For Class TBulletStyle

Class TBulletStyle

[line 456]
TEnumerable
   |
   --TBulletStyle
Location: /Web/UI/WebControls/TBulletedList.php

Remarks

TBulletStyle class.

TBulletStyle defines the enumerable type for the possible bullet styles that may be used for a TBulletedList control.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TBulletedList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Circle = 'Circle'
  • CustomImage = 'CustomImage'
  • Disc = 'Disc'
  • LowerAlpha = 'LowerAlpha'
  • LowerRoman = 'LowerRoman'
  • None = 'None'
  • NotSet = 'NotSet'
  • Numbered = 'Numbered'
  • Square = 'Square'
  • UpperAlpha = 'UpperAlpha'
  • UpperRoman = 'UpperRoman'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Circle = 'Circle' [line 466]

  • CustomImage = 'CustomImage' [line 468]

  • Disc = 'Disc' [line 465]

  • LowerAlpha = 'LowerAlpha' [line 461]

  • LowerRoman = 'LowerRoman' [line 463]

  • None = 'None' [line 459]

  • NotSet = 'NotSet' [line 458]

  • Numbered = 'Numbered' [line 460]

  • Square = 'Square' [line 467]

  • UpperAlpha = 'UpperAlpha' [line 462]

  • UpperRoman = 'UpperRoman' [line 464]

Documentation generated on Mon, 25 Jun 2012 14:43:37 +0200 by phpDocumentor 1.4.3


Docs For Class TButton

Class TButton

[line 50]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TButton
Classes extended from TButton:
TActiveButton
TActiveButton is the active control counter part to TButton.

Location: /Web/UI/WebControls/TButton.php

Remarks

TButton class

TButton creates a click button on the page. It is mainly used to submit data to a page.

TButton raises two server-side events, OnClick and OnCommand, when it is clicked on the client-side. The difference between these two events is that the event OnCommand is bubbled up to the button's ancestor controls. And within the event parameter for OnCommand contains the reference to the CommandName and CommandParameter property values that are set for the button object. This allows you to create multiple TButton components on a Web page and programmatically determine which one is clicked with what parameter.

Clicking on button can also trigger form validation, if CausesValidation is true. The validation may be restricted within a certain group of validator controls by setting ValidationGroup property. If validation is successful, the data will be post back to the same page.

TButton displays the Text property as the button caption.

TButton can be one of three ButtonType: Submit, Button and Reset. By default, it is a Submit button and the form submission uses the browser's default submission capability. If it is Button or Reset, postback may occur if one of the following conditions is met:

  • an event handler is attached to OnClick event;
  • an event handler is attached to OnCommand event;
  • the button is in a non-empty validation group.
In addition, clicking on a Reset button will clear up all input fields if the button does not cause a postback.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TButton::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveButton::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attribute name-value pairs to renderer.

    This overrides the parent implementation with additional button specific attributes.

    access

    protected

    [ Top ]

    TButton::canCauseValidation

    canCauseValidation( );

    Returns

    whether to perform validation if the button is clicked

    access

    protected

    [ Top ]

    TButton::getButtonType

    getButtonType( );

    Returns

    the type of the button. Defaults to TButtonType::Submit.

    access

    public

    [ Top ]

    TButton::getCausesValidation

    getCausesValidation( );

    Returns

    whether postback event trigger by this button will cause input validation, default is true

    access

    public

    [ Top ]

    TButton::getClientClassName

    getClientClassName( );

    Overridden in child classes as:

    TActiveButton::getClientClassName()

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TButton::getCommandName

    getCommandName( );

    Returns

    the command name associated with the OnCommand event.

    access

    public

    [ Top ]

    TButton::getCommandParameter

    getCommandParameter( );

    Returns

    the parameter associated with the OnCommand event

    access

    public

    [ Top ]

    TButton::getData

    getData( );

    Returns

    caption of the button.

    Remarks

    Returns the caption of the button.

    This method is required by IDataRenderer. It is the same as getText().

    see

    TButton::getText()

    since

    3.1.0

    access

    public

    [ Top ]

    TButton::getEnableClientScript

    getEnableClientScript( );

    Returns

    whether to render javascript.

    access

    public

    [ Top ]

    TButton::getIsDefaultButton

    getIsDefaultButton( );

    Returns

    true if this button is registered as a default button for a panel.

    access

    public

    [ Top ]

    TButton::getPostBackOptions

    getPostBackOptions( );

    Returns

    parameters about how the button defines its postback behavior.

    Remarks

    Returns postback specifications for the button.

    This method is used by framework and control developers.

    access

    protected

    [ Top ]

    TButton::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name of the button

    access

    protected

    [ Top ]

    TButton::getText

    getText( );

    Returns

    caption of the button

    access

    public

    [ Top ]

    TButton::getValidationGroup

    getValidationGroup( );

    Returns

    the group of validators which the button causes validation upon postback

    access

    public

    [ Top ]

    TButton::needPostBackScript

    needPostBackScript( );

    Returns

    whether the button needs javascript to do postback

    access

    protected

    [ Top ]

    TButton::onClick

    onClick( TEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the button is clicked.

    The method raises 'OnClick' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TButton::onCommand

    onCommand( TCommandEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the button is clicked.

    The method raises 'OnCommand' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

    access

    public

    [ Top ]

    TButton::raisePostBackEvent

    raisePostBackEvent( TEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the postback event.

    This method is required by IPostBackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick and OnCommand events. This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TButton::renderClientControlScript

    renderClientControlScript( $writer );

    Overridden in child classes as:

    TActiveButton::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    Parameters

    $writer

    Remarks

    Renders the client-script code.

    access

    protected

    [ Top ]

    TButton::renderContents

    renderContents( THtmlWriter $writer );

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the body content enclosed between the control tag.

    This overrides the parent implementation with nothing to be rendered.

    access

    public

    [ Top ]

    TButton::setButtonType

    setButtonType( TButtonType $value );

    Parameters

    $value

    the type of the button.

    access

    public

    [ Top ]

    TButton::setCausesValidation

    setCausesValidation( boolean $value );

    Parameters

    $value

    whether postback event trigger by this button will cause input validation

    access

    public

    [ Top ]

    TButton::setCommandName

    setCommandName( string $value );

    Parameters

    $value

    the command name associated with the OnCommand event.

    access

    public

    [ Top ]

    TButton::setCommandParameter

    setCommandParameter( string $value );

    Parameters

    $value

    the parameter associated with the OnCommand event.

    access

    public

    [ Top ]

    TButton::setData

    setData( string $value );

    Parameters

    $value

    caption of the button

    Remarks

    Sets the caption of the button.

    This method is required by IDataRenderer. It is the same as setText().

    see

    TButton::setText()

    since

    3.1.0

    access

    public

    [ Top ]

    TButton::setEnableClientScript

    setEnableClientScript( boolean $value );

    Parameters

    $value

    whether to render javascript.

    access

    public

    [ Top ]

    TButton::setIsDefaultButton

    setIsDefaultButton( boolean $value );

    Parameters

    $value

    set by a panel to register this button as the default button for the panel.

    access

    public

    [ Top ]

    TButton::setText

    setText( string $value );

    Overridden in child classes as:

    TActiveButton::setText()
    Updates the button text on the client-side if the setEnableUpdate property is set to true.

    Parameters

    $value

    caption of the button

    access

    public

    [ Top ]

    TButton::setValidationGroup

    setValidationGroup( string $value );

    Parameters

    $value

    the group of validators which the button causes validation upon postback

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:37 +0200 by phpDocumentor 1.4.3


Docs For Class TButtonType

Class TButtonType

[line 362]
TEnumerable
   |
   --TButtonType
Location: /Web/UI/WebControls/TButton.php

Remarks

TButtonType class.

TButtonType defines the enumerable type for the possible types that a TButton can take.

The following enumerable values are defined:

  • Submit: a normal submit button
  • Reset: a reset button
  • Button: a client button (normally does not perform form submission)

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Button = 'Button'
  • Reset = 'Reset'
  • Submit = 'Submit'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Button = 'Button' [line 366]

  • Reset = 'Reset' [line 365]

  • Submit = 'Submit' [line 364]

Documentation generated on Mon, 25 Jun 2012 14:43:38 +0200 by phpDocumentor 1.4.3


Docs For Class TButtonColumn

Class TButtonColumn

[line 55]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TButtonColumn
Classes extended from TButtonColumn:
TActiveButtonColumn
TActiveButtonColumn class

Location: /Web/UI/WebControls/TButtonColumn.php

Remarks

TButtonColumn class

TButtonColumn contains a user-defined command button, such as Add or Remove, that corresponds with each row in the column.

The caption of the buttons in the column is determined by Text and DataTextField properties. If both are present, the latter takes precedence. The DataTextField property refers to the name of the field in datasource whose value will be used as the button caption. If DataTextFormatString is not empty, the value will be formatted before rendering.

The buttons in the column can be set to display as hyperlinks or push buttons by setting the ButtonType property. The CommandName will assign its value to all button's CommandName property. The datagrid will capture the command event where you can write event handlers based on different command names. The buttons' CausesValidation and ValidationGroup property values are determined by the column's corresponding properties.

The buttons in the column can be accessed by one of the following two methods:

  •  $datagridItem->ButtonColumnID->Button
    •

  •  $datagridItem->ButtonColumnID->Controls[0]
    •
    The second method is possible because the button control created within the datagrid cell is the first child.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TButtonColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TDataGridColumn

    • TDataGridColumn::formatDataValue()
      Formats the text value according to a format string.
    • TDataGridColumn::getAllowSorting()
      Returns a value indicating whether this column allows sorting.
    • TDataGridColumn::getDataFieldValue()
      Fetches the value of the data at the specified field.
    • TDataGridColumn::getEnableCellGrouping()
    • TDataGridColumn::getFooterRenderer()
    • TDataGridColumn::getFooterStyle()
    • TDataGridColumn::getFooterText()
    • TDataGridColumn::getHeaderImageUrl()
    • TDataGridColumn::getHeaderRenderer()
    • TDataGridColumn::getHeaderStyle()
    • TDataGridColumn::getHeaderText()
    • TDataGridColumn::getID()
    • TDataGridColumn::getItemStyle()
    • TDataGridColumn::getOwner()
    • TDataGridColumn::getSortExpression()
    • TDataGridColumn::getViewState()
      Returns a viewstate value.
    • TDataGridColumn::getVisible()
    • TDataGridColumn::initialize()
      Initializes the column.
    • TDataGridColumn::initializeCell()
      Initializes the specified cell to its initial values.
    • TDataGridColumn::initializeFooterCell()
      Initializes the footer cell.
    • TDataGridColumn::initializeHeaderCell()
      Initializes the header cell.
    • TDataGridColumn::loadState()
      Loads persistent state values.
    • TDataGridColumn::saveState()
      Saves persistent state values.
    • TDataGridColumn::setEnableCellGrouping()
    • TDataGridColumn::setFooterRenderer()
      Sets the column footer cell renderer class.
    • TDataGridColumn::setFooterText()
    • TDataGridColumn::setHeaderImageUrl()
    • TDataGridColumn::setHeaderRenderer()
      Sets the column header cell renderer class.
    • TDataGridColumn::setHeaderText()
    • TDataGridColumn::setID()
      Sets the ID of the column.
    • TDataGridColumn::setOwner()
    • TDataGridColumn::setSortExpression()
    • TDataGridColumn::setViewState()
      Sets a viewstate value.
    • TDataGridColumn::setVisible()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TButtonColumn::dataBindColumn

      dataBindColumn( $sender, $param );

      Parameters

      $sender

      $param

      Remarks

      Databinds a cell in the column.

      This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

      access

      public

      [ Top ]

      TButtonColumn::getButtonType

      getButtonType( );

      Returns

      the type of command button. Defaults to TButtonColumnType::LinkButton.

      access

      public

      [ Top ]

      TButtonColumn::getCausesValidation

      getCausesValidation( );

      Returns

      whether postback event trigger by this button will cause input validation, default is true

      access

      public

      [ Top ]

      TButtonColumn::getCommandName

      getCommandName( );

      Returns

      the command name associated with the OnCommand event.

      access

      public

      [ Top ]

      TButtonColumn::getDataImageUrlField

      getDataImageUrlField( );

      Returns

      the field name from the data source to bind to the button image url

      access

      public

      [ Top ]

      TButtonColumn::getDataImageUrlFormatString

      getDataImageUrlFormatString( );

      Returns

      the formatting string used to control how the button image url will be displayed.

      access

      public

      [ Top ]

      TButtonColumn::getDataTextField

      getDataTextField( );

      Returns

      the field name from the data source to bind to the button caption

      access

      public

      [ Top ]

      TButtonColumn::getDataTextFormatString

      getDataTextFormatString( );

      Returns

      the formatting string used to control how the button caption will be displayed.

      access

      public

      [ Top ]

      TButtonColumn::getImageUrl

      getImageUrl( );

      Returns

      the URL of the image file for image buttons

      access

      public

      [ Top ]

      TButtonColumn::getText

      getText( );

      Returns

      the text caption of the button

      access

      public

      [ Top ]

      TButtonColumn::getValidationGroup

      getValidationGroup( );

      Returns

      the group of validators which the button causes validation upon postback

      access

      public

      [ Top ]

      TButtonColumn::initializeCell

      initializeCell( TTableCell $cell, integer $columnIndex, string $itemType );

      Overridden in child classes as:

      TActiveButtonColumn::initializeCell()

      Overrides TDataGridColumn::initializeCell() (Initializes the specified cell to its initial values.)

      Parameters

      $cell

      the cell to be initialized.

      $columnIndex

      the index to the Columns property that the cell resides in.

      $itemType

      the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)

      Remarks

      Initializes the specified cell to its initial values.

      This method overrides the parent implementation. It creates a command button within the cell.

      access

      public

      [ Top ]

      TButtonColumn::setButtonType

      setButtonType( TButtonColumnType $value );

      Parameters

      $value

      the type of command button

      access

      public

      [ Top ]

      TButtonColumn::setCausesValidation

      setCausesValidation( boolean $value );

      Parameters

      $value

      whether postback event trigger by this button will cause input validation

      access

      public

      [ Top ]

      TButtonColumn::setCommandName

      setCommandName( string $value );

      Parameters

      $value

      the text caption to be set

      Remarks

      Sets the command name associated with the Command event.

      access

      public

      [ Top ]

      TButtonColumn::setDataImageUrlField

      setDataImageUrlField( string $value );

      Parameters

      $value

      the field name from the data source to bind to the button image url

      access

      public

      [ Top ]

      TButtonColumn::setDataImageUrlFormatString

      setDataImageUrlFormatString( string $value );

      Parameters

      $value

      the formatting string used to control how the button image url will be displayed.

      access

      public

      [ Top ]

      TButtonColumn::setDataTextField

      setDataTextField( string $value );

      Parameters

      $value

      the field name from the data source to bind to the button caption

      access

      public

      [ Top ]

      TButtonColumn::setDataTextFormatString

      setDataTextFormatString( string $value );

      Parameters

      $value

      the formatting string used to control how the button caption will be displayed.

      access

      public

      [ Top ]

      TButtonColumn::setImageUrl

      setImageUrl( string $value );

      Parameters

      $value

      the URL of the image file for image buttons

      access

      public

      [ Top ]

      TButtonColumn::setText

      setText( string $value );

      Parameters

      $value

      the text caption to be set

      Remarks

      Sets the text caption of the button.

      access

      public

      [ Top ]

      TButtonColumn::setValidationGroup

      setValidationGroup( string $value );

      Parameters

      $value

      the group of validators which the button causes validation upon postback

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:38 +0200 by phpDocumentor 1.4.3


Docs For Class TCaptcha

Class TCaptcha

[line 64]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TImage
               |
               --TCaptcha
Location: /Web/UI/WebControls/TCaptcha.php

Remarks

TCaptcha class.

Notice: while this class is easy to use and implement, it does not provide full security. In fact, it's easy to bypass the checks reusing old, already-validated tokens (reply attack). A better alternative is provided by TReCaptcha.

TCaptcha displays a CAPTCHA (a token displayed as an image) that can be used to determine if the input is entered by a real user instead of some program.

Unlike other CAPTCHA scripts, TCaptcha does not need session or cookie.

The token (a string consisting of alphanumeric characters) displayed is automatically generated and can be configured in several ways. To specify the length of characters in the token, set MinTokenLength and MaxTokenLength. To use case-insensitive comparison and generate upper-case-only token, set CaseSensitive to false. Advanced users can try to set TokenAlphabet, which specifies what characters can appear in tokens.

The validation of the token is related with two properties: TestLimit and TokenExpiry. The former specifies how many times a token can be tested with on the server side, and the latter says when a generated token will expire.

To specify the appearance of the generated token image, set TokenImageTheme to be an integer between 0 and 63. And to adjust the generated image size, set TokenFontSize (you may also set TWebControl::setWidth, but the scaled image may not look good.) By setting ChangingTokenBackground to true, the image background of the token will be variating even though the token is the same during postbacks.

Upon postback, user input can be validated by calling validate(). The TCaptchaValidator control can also be used to do validation, which provides client-side validation besides the server-side validation. By default, the token will remain the same during multiple postbacks. A new one can be generated by calling regenerateToken() manually.

The following template shows a typical use of TCaptcha control:

  •  <com:TCaptcha ID="Captcha" />
    •

  •  <com:TTextBox ID="Input" />
    •

  •  <com:TCaptchaValidator CaptchaControl="Captcha"
    •

  •                         ControlToValidate="Input"
    •

  •                         ErrorMessage="You are challenged!" />
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TCaptcha.php 3044 2011-10-02 21:13:53Z ctrlaltca@gmail.com $

    since

    3.1.1

    Class Variable Summary

    Class Constant Summary

    • MAX_TOKEN_LENGTH = 40
    • MIN_TOKEN_LENGTH = 2

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    • static boolean checkRequirements()
      Checks the requirements needed for generating CAPTCHA images.
    • boolean checkRequirements()
      Checks the requirements needed for generating CAPTCHA images.

    Inherited Method Summary

    Inherited From Class TImage

    • TImage::addAttributesToRender()
      Adds attributes related to an HTML image element to renderer.
    • TImage::getAlternateText()
    • TImage::getData()
      Returns the URL of the image file.
    • TImage::getDescriptionUrl()
    • TImage::getImageAlign()
    • TImage::getImageUrl()
    • TImage::getTagName()
    • TImage::renderContents()
      Renders the body content of the image.
    • TImage::setAlternateText()
      Sets the alternative text to be displayed in the TImage when the image is unavailable.
    • TImage::setData()
      Sets the URL of the image.
    • TImage::setDescriptionUrl()
    • TImage::setImageAlign()
      Sets the alignment of the image with respective to other elements on the page.
    • TImage::setImageUrl()

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      static TCaptcha::checkRequirements

      static checkRequirements( );

      Returns

      whether the requirements are satisfied.

      Remarks

      Checks the requirements needed for generating CAPTCHA images.

      TCaptach requires GD2 with TrueType font support and PNG image support.

      access

      public

      [ Top ]

      TCaptcha::generatePrivateKeyFile

      generatePrivateKeyFile( );

      Returns

      the path of the file keeping the private key

      Remarks

      Generates a file with a randomly generated private key.

      access

      protected

      [ Top ]

      TCaptcha::generateRandomKey

      generateRandomKey( );

      Returns

      a randomly generated key

      access

      protected

      [ Top ]

      TCaptcha::generateToken

      generateToken( string $publicKey, string $privateKey, integer $alphabet, boolean $tokenLength, $caseSensitive );

      Parameters

      $publicKey

      public key

      $privateKey

      private key

      $alphabet

      the length of the token

      $tokenLength

      whether the token is case sensitive

      $caseSensitive

      Returns

      the token generated.

      Remarks

      Generates the token.

      access

      protected

      [ Top ]

      TCaptcha::getCaptchaScriptFile

      getCaptchaScriptFile( );

      Returns

      the file path of the PHP script generating the token image

      access

      protected

      [ Top ]

      TCaptcha::getCaseSensitive

      getCaseSensitive( );

      Returns

      whether the token should be treated as case-sensitive. Defaults to true.

      access

      public

      [ Top ]

      TCaptcha::getChangingTokenBackground

      getChangingTokenBackground( );

      Returns

      whether the background of the token image should be variated during postbacks. Defaults to false.

      access

      public

      [ Top ]

      TCaptcha::getFontFile

      getFontFile( );

      access

      protected

      [ Top ]

      TCaptcha::getIsTokenExpired

      getIsTokenExpired( );

      Returns

      whether the currently generated token has expired.

      access

      public

      [ Top ]

      TCaptcha::getMaxTokenLength

      getMaxTokenLength( );

      Returns

      the maximum length of the token. Defaults to 6.

      access

      public

      [ Top ]

      TCaptcha::getMinTokenLength

      getMinTokenLength( );

      Returns

      the minimum length of the token. Defaults to 4.

      access

      public

      [ Top ]

      TCaptcha::getPrivateKey

      getPrivateKey( );

      Returns

      the private key used for generating the token. This is randomly generated and kept in a file for persistency.

      access

      public

      [ Top ]

      TCaptcha::getPublicKey

      getPublicKey( );

      Returns

      the public key used for generating the token. A random one will be generated and returned if this is not set.

      access

      public

      [ Top ]

      TCaptcha::getTestLimit

      getTestLimit( );

      Returns

      how many times a generated token can be tested. Defaults to 5.

      access

      public

      [ Top ]

      TCaptcha::getToken

      getToken( );

      Returns

      the token that will be displayed

      access

      public

      [ Top ]

      TCaptcha::getTokenAlphabet

      getTokenAlphabet( );

      Returns

      the characters that may appear in the token. Defaults to '234578adefhijmnrtABDEFGHJLMNRT'.

      access

      public

      [ Top ]

      TCaptcha::getTokenExpiry

      getTokenExpiry( );

      Returns

      the number of seconds that a generated token will remain valid. Defaults to 600 seconds (10 minutes).

      access

      public

      [ Top ]

      TCaptcha::getTokenFontSize

      getTokenFontSize( );

      Returns

      the font size used for displaying the token in an image. Defaults to 30.

      access

      public

      [ Top ]

      TCaptcha::getTokenImageOptions

      getTokenImageOptions( );

      Returns

      the options to be passed to the token image generator

      access

      protected

      [ Top ]

      TCaptcha::getTokenImageTheme

      getTokenImageTheme( );

      Returns

      the theme of the token image. Defaults to 0.

      access

      public

      [ Top ]

      TCaptcha::getTokenLength

      getTokenLength( );

      Returns

      the length of the token to be generated.

      access

      protected

      [ Top ]

      TCaptcha::hash2string

      hash2string( string $hex, [string $alphabet = ''] );

      Parameters

      $hex

      the hexadecimal representation of the hash string

      $alphabet

      the alphabet used to represent the converted string. If empty, it means '234578adefhijmnrtwyABDEFGHIJLMNQRTWY', which excludes those confusing characters.

      Returns

      the converted string

      Remarks

      Converts a hash string into a string with characters consisting of alphanumeric characters.

      access

      protected

      [ Top ]

      TCaptcha::onPreRender

      onPreRender( mixed $param );

      Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

      Parameters

      $param

      event parameter

      Remarks

      Configures the image URL that shows the token.

      access

      public

      [ Top ]

      TCaptcha::regenerateToken

      regenerateToken( );

      Remarks

      Regenerates the token to be displayed.

      By default, a token, once generated, will remain the same during the following page postbacks. Calling this method will generate a new token.

      access

      public

      [ Top ]

      TCaptcha::setCaseSensitive

      setCaseSensitive( boolean $value );

      Parameters

      $value

      whether the token should be treated as case-sensitive. If false, only upper-case letters will appear in the token.

      access

      public

      [ Top ]

      TCaptcha::setChangingTokenBackground

      setChangingTokenBackground( boolean $value );

      Parameters

      $value

      whether the background of the token image should be variated during postbacks.

      access

      public

      [ Top ]

      TCaptcha::setMaxTokenLength

      setMaxTokenLength( integer $value );

      Parameters

      $value

      the maximum length of the token. It must be between 2 and 40.

      access

      public

      [ Top ]

      TCaptcha::setMinTokenLength

      setMinTokenLength( integer $value );

      Parameters

      $value

      the minimum length of the token. It must be between 2 and 40.

      access

      public

      [ Top ]

      TCaptcha::setPublicKey

      setPublicKey( string $value );

      Parameters

      $value

      the public key used for generating the token. A random one will be generated if this is not set.

      access

      public

      [ Top ]

      TCaptcha::setTestLimit

      setTestLimit( integer $value );

      Parameters

      $value

      how many times a generated token can be tested. For unlimited tests, set it to 0.

      access

      public

      [ Top ]

      TCaptcha::setTokenAlphabet

      setTokenAlphabet( string $value );

      Parameters

      $value

      the characters that may appear in the token. At least 2 characters must be specified.

      access

      public

      [ Top ]

      TCaptcha::setTokenExpiry

      setTokenExpiry( integer $value );

      Parameters

      $value

      the number of seconds that a generated token will remain valid. A value smaller than 1 means the token will not expire.

      access

      public

      [ Top ]

      TCaptcha::setTokenFontSize

      setTokenFontSize( integer $value );

      Parameters

      $value

      the font size used for displaying the token in an image. It must be an integer between 20 and 100.

      Remarks

      Sets the font size used for displaying the token in an image.

      This property affects the generated token image size. The image width is proportional to this font size.

      access

      public

      [ Top ]

      TCaptcha::setTokenImageTheme

      setTokenImageTheme( integer $value );

      Parameters

      $value

      the theme of the token image. It must be an integer between 0 and 63.

      Remarks

      Sets the theme of the token image.

      You may test each theme to find out the one you like the most. Below is the explanation of the theme value: It is treated as a 5-bit integer. Each bit toggles a specific feature of the image. Bit 0 (the least significant): whether the image is opaque (1) or transparent (0). Bit 1: whether we should add white noise to the image (1) or not (0). Bit 2: whether we should add a grid to the image (1) or not (0). Bit 3: whether we should add some scribbles to the image (1) or not (0). Bit 4: whether the image background should be morphed (1) or not (0). Bit 5: whether the token text should cast a shadow (1) or not (0).

      access

      public

      [ Top ]

      TCaptcha::validate

      validate( string $input );

      Parameters

      $input

      user input

      Returns

      if the user input is not the same as the token.

      Remarks

      Validates a user input with the token.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • MAX_TOKEN_LENGTH = 40 [line 67]

    • MIN_TOKEN_LENGTH = 2 [line 66]

    Documentation generated on Mon, 25 Jun 2012 14:43:42 +0200 by phpDocumentor 1.4.3


Docs For Class TCaptchaValidator

Class TCaptchaValidator

[line 38]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TCaptchaValidator
Location: /Web/UI/WebControls/TCaptchaValidator.php

Remarks

TCaptchaValidator class

Notice: while this class is easy to use and implement, it does not provide full security. In fact, it's easy to bypass the checks reusing old, already-validated tokens (reply attack). A better alternative is provided by TReCaptchaValidator.

TCaptchaValidator validates user input against a CAPTCHA represented by a TCaptcha control. The input control fails validation if its value is not the same as the token displayed in CAPTCHA. Note, if the user does not enter any thing, it is still considered as failing the validation.

To use TCaptchaValidator, specify the ControlToValidate to be the ID path of the input control (usually a TTextBox control}. Also specify the CaptchaControl to be the ID path of the CAPTCHA control that the user input should be compared with.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCaptchaValidator.php 3044 2011-10-02 21:13:53Z ctrlaltca@gmail.com $

since

3.1.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TBaseValidator

  • TBaseValidator::__construct()
    Constructor.
  • TBaseValidator::addAttributesToRender()
    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
  • TBaseValidator::createClientSide()
  • TBaseValidator::evaluateIsValid()
    This is the major method for validation.
  • TBaseValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
  • TBaseValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
  • TBaseValidator::getClientSide()
    Gets the TValidatorClientSide that allows modification of the client- side validator events.
  • TBaseValidator::getControlCssClass()
  • TBaseValidator::getControlToValidate()
  • TBaseValidator::getDisplay()
  • TBaseValidator::getEnableClientScript()
  • TBaseValidator::getErrorMessage()
  • TBaseValidator::getFocusElementID()
    Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::getFocusOnError()
  • TBaseValidator::getIsValid()
  • TBaseValidator::getValidationGroup()
  • TBaseValidator::getValidationTarget()
  • TBaseValidator::getValidationValue()
    Retrieves the property value of the control being validated.
  • TBaseValidator::onInit()
    Registers the validator with page.
  • TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
  • TBaseValidator::onUnload()
    Unregisters the validator from page.
  • TBaseValidator::onValidate()
    This event is raised right before the validator starts to perform validation.
  • TBaseValidator::onValidationError()
    This event is raised when the validator fails in validation.
  • TBaseValidator::onValidationSuccess()
    This event is raised when the validator succeeds in validation.
  • TBaseValidator::registerClientScriptValidator()
    Registers the individual validator client-side javascript code.
  • TBaseValidator::renderClientControlScript()
    Renders the javascript code to the end script.
  • TBaseValidator::renderContents()
    Renders the validator control.
  • TBaseValidator::setControlCssClass()
  • TBaseValidator::setControlToValidate()
    Sets the ID path of the input control to validate.
  • TBaseValidator::setDisplay()
  • TBaseValidator::setEnableClientScript()
  • TBaseValidator::setEnabled()
    This method overrides parent's implementation by setting setIsValid to true if disabled.
  • TBaseValidator::setErrorMessage()
    Sets the text for the error message.
  • TBaseValidator::setFocusElementID()
    Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::setFocusOnError()
  • TBaseValidator::setForControl()
    This method overrides the parent implementation to forbid setting ForControl.
  • TBaseValidator::setIsValid()
    Sets the value indicating whether the validation succeeds
  • TBaseValidator::setValidationGroup()
  • TBaseValidator::updateControlCssClass()
    Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
  • TBaseValidator::validate()
    Validates the specified control.

Inherited From Class TLabel

  • TLabel::addAttributesToRender()
    Adds attributes to renderer.
  • TLabel::getData()
    Returns the text value of the label.
  • TLabel::getForControl()
  • TLabel::getTagName()
  • TLabel::getText()
  • TLabel::render()
    Renders the label.
  • TLabel::renderContents()
    Renders the body content of the label.
  • TLabel::setData()
    Sets the text value of the label.
  • TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
  • TLabel::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCaptchaValidator::evaluateIsValid

    evaluateIsValid( );

    Overrides TBaseValidator::evaluateIsValid() (This is the major method for validation.)

    Returns

    whether the validation succeeds

    Remarks

    This method overrides the parent's implementation.

    The validation succeeds if the input control has the same value as the one displayed in the corresponding CAPTCHA control.

    access

    protected

    [ Top ]

    TCaptchaValidator::findCaptchaControl

    findCaptchaControl( );

    Returns

    the CAPTCHA control to be validated against

    throws

    TConfigurationException if the CAPTCHA cannot be found according to CaptchaControl

    access

    protected

    [ Top ]

    TCaptchaValidator::getCaptchaControl

    getCaptchaControl( );

    Returns

    the ID path of the CAPTCHA control to validate

    access

    public

    [ Top ]

    TCaptchaValidator::getClientClassName

    getClientClassName( );

    Overrides TBaseValidator::getClientClassName() (Gets the name of the javascript class responsible for performing validation for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing validation for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TCaptchaValidator::getClientScriptOptions

    getClientScriptOptions( );

    Overrides TBaseValidator::getClientScriptOptions() (Returns an array of javascript validator options.)

    Returns

    javascript validator options.

    Remarks

    Returns an array of javascript validator options.

    access

    protected

    [ Top ]

    TCaptchaValidator::setCaptchaControl

    setCaptchaControl( string $value );

    Parameters

    $value

    the ID path

    Remarks

    Sets the ID path of the CAPTCHA control to validate.

    The ID path is the dot-connected IDs of the controls reaching from the validator's naming container to the target control.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:43 +0200 by phpDocumentor 1.4.3


Docs For Class TCheckBox

Class TCheckBox

[line 43]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TCheckBox
Classes extended from TCheckBox:
TActiveCheckBox
TActiveCheckBox class.
TRadioButton
TRadioButton class

Location: /Web/UI/WebControls/TCheckBox.php

Remarks

TCheckBox class

TCheckBox displays a check box on the page. You can specify the caption to display beside the check box by setting the Text property. The caption can appear either on the right or left of the check box, which is determined by the TextAlign property.

To determine whether the TCheckBox component is checked, test the Checked property. The OnCheckedChanged event is raised when the Checked state of the TCheckBox component changes between posts to the server. You can provide an event handler for the OnCheckedChanged event to to programmatically control the actions performed when the state of the TCheckBox component changes between posts to the server.

If AutoPostBack is set true, changing the check box state will cause postback action. And if CausesValidation is true, validation will also be processed, which can be further restricted within a ValidationGroup.

Note, Text is rendered as is. Make sure it does not contain unwanted characters that may bring security vulnerabilities.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCheckBox.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCheckBox::getAutoPostBack

    getAutoPostBack( );

    Returns

    whether clicking on the checkbox will post the page.

    access

    public

    [ Top ]

    TCheckBox::getCausesValidation

    getCausesValidation( );

    Returns

    whether postback event triggered by this checkbox will cause input validation, default is true.

    access

    public

    [ Top ]

    TCheckBox::getChecked

    getChecked( );

    Returns

    whether the checkbox is checked

    access

    public

    [ Top ]

    TCheckBox::getClientClassName

    getClientClassName( );

    Overridden in child classes as:

    TActiveCheckBox::getClientClassName()
    TRadioButton::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    TActiveRadioButton::getClientClassName()

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TCheckBox::getData

    getData( );

    Returns

    whether the checkbox is checked.

    Remarks

    Returns the value indicating whether the checkbox is checked.

    This method is required by IDataRenderer. It is the same as getChecked().

    see

    TCheckBox::getChecked()

    since

    3.1.0

    access

    public

    [ Top ]

    TCheckBox::getDataChanged

    getDataChanged( );

    Returns

    whether postback has caused the control data change. False if the page is not in postback mode.

    Remarks

    Returns a value indicating whether postback has caused the control data change.

    This method is required by the IPostBackDataHandler interface.

    access

    public

    [ Top ]

    TCheckBox::getEnableClientScript

    getEnableClientScript( );

    Overridden in child classes as:

    TRadioButton::getEnableClientScript()

    Returns

    whether to render javascript.

    access

    public

    [ Top ]

    TCheckBox::getInputAttributes

    getInputAttributes( );

    Returns

    list of attributes to be rendered for the checkbox

    access

    public

    [ Top ]

    TCheckBox::getIsValid

    getIsValid( );

    Returns

    wether this control validated successfully.

    Remarks

    Returns true if this control validated successfully.

    Defaults to true.

    access

    public

    [ Top ]

    TCheckBox::getLabelAttributes

    getLabelAttributes( );

    Overridden in child classes as:

    TActiveCheckBox::getLabelAttributes()
    Overrides parent implementation to ensure label has ID.
    TActiveRadioButton::getLabelAttributes()
    Overrides parent implementation to ensure label has ID.

    Returns

    list of attributes to be rendered for label beside the checkbox

    access

    public

    [ Top ]

    TCheckBox::getPostBackOptions

    getPostBackOptions( );

    Remarks

    Gets the post back options for this checkbox.

    access

    protected

    [ Top ]

    TCheckBox::getSpanNeeded

    getSpanNeeded( );

    Returns

    wether this control needs a surrounding span tag

    Remarks

    Check if we need a span tag to surround this control. The span tag will be created if the Text property is set for this control.

    access

    protected

    [ Top ]

    TCheckBox::getSurroundingTagID

    getSurroundingTagID( );

    Returns

    the id of the surrounding tag or this clientID if no such tag needed

    access

    public

    [ Top ]

    TCheckBox::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name of the button

    access

    protected

    [ Top ]

    TCheckBox::getText

    getText( );

    Returns

    the text caption of the checkbox

    access

    public

    [ Top ]

    TCheckBox::getTextAlign

    getTextAlign( );

    Returns

    the alignment (Left or Right) of the text caption, defaults to TTextAlign::Right.

    access

    public

    [ Top ]

    TCheckBox::getValidationGroup

    getValidationGroup( );

    Returns

    the group of validators which the checkbox causes validation upon postback

    access

    public

    [ Top ]

    TCheckBox::getValidationPropertyValue

    getValidationPropertyValue( );

    Returns

    the property value to be validated

    Remarks

    Returns the value of the property that needs validation.

    access

    public

    [ Top ]

    TCheckBox::getValue

    getValue( );

    Returns

    the value of the checkbox. Defaults to empty.

    access

    public

    [ Top ]

    TCheckBox::getValueAttribute

    getValueAttribute( );

    Overridden in child classes as:

    TRadioButton::getValueAttribute()

    Returns

    the value attribute to be rendered

    access

    protected

    [ Top ]

    TCheckBox::loadPostData

    loadPostData( string $key, array $values );

    Overridden in child classes as:

    TRadioButton::loadPostData()
    Loads user input data.

    Parameters

    $key

    the key that can be used to retrieve data from the input data collection

    $values

    the input data collection

    Returns

    whether the data of the control has been changed

    Remarks

    Loads user input data.

    This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TCheckBox::onCheckedChanged

    onCheckedChanged( TEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    Raises OnCheckedChanged event when getChecked changes value during postback.

    If you override this method, be sure to call the parent implementation so that the event delegates can be invoked.

    access

    public

    [ Top ]

    TCheckBox::onPreRender

    onPreRender( mixed $param );

    Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

    Parameters

    $param

    event parameter

    Remarks

    Registers the checkbox to receive postback data during postback.

    This is necessary because a checkbox if unchecked, when postback, does not have direct mapping between post data and the checkbox name.

    This method overrides the parent implementation and is invoked before render.

    access

    public

    [ Top ]

    TCheckBox::raisePostDataChangedEvent

    raisePostDataChangedEvent( );

    Remarks

    Raises postdata changed event.

    This method raises OnCheckedChanged event. This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TCheckBox::render

    render( THtmlWriter $writer );

    Overrides TWebControl::render() (Renders the control.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the checkbox control.

    This method overrides the parent implementation by rendering a checkbox input element and a span element if needed.

    access

    public

    [ Top ]

    TCheckBox::renderClientControlScript

    renderClientControlScript( $writer );

    Overridden in child classes as:

    TActiveCheckBox::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    TRadioButton::renderClientControlScript()
    Renders the client-script code.
    TActiveRadioButton::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    Parameters

    $writer

    Remarks

    Renders the client-script code.

    access

    protected

    [ Top ]

    TCheckBox::renderInputTag

    renderInputTag( THtmlWriter $writer, string $clientID, string $onclick );

    Overridden in child classes as:

    TActiveCheckBox::renderInputTag()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TRadioButton::renderInputTag()
    Renders a radiobutton input element.
    TActiveRadioButton::renderInputTag()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    Parameters

    $writer

    the writer for the rendering purpose

    $clientID

    checkbox id

    $onclick

    onclick js

    Remarks

    Renders a checkbox input element.

    access

    protected

    [ Top ]

    TCheckBox::renderLabel

    renderLabel( THtmlWriter $writer, string $clientID, string $text );

    Overridden in child classes as:

    TActiveCheckBox::renderLabel()
    Renders a label beside the checkbox.
    TActiveRadioButton::renderLabel()
    Renders a label beside the radio button.

    Parameters

    $writer

    the writer for the rendering purpose

    $clientID

    checkbox id

    $text

    label text

    Remarks

    Renders a label beside the checkbox.

    access

    protected

    [ Top ]

    TCheckBox::setAutoPostBack

    setAutoPostBack( boolean $value );

    Parameters

    $value

    whether clicking on the checkbox will post the page.

    Remarks

    Sets a value indicating whether clicking on the checkbox will post the page.

    access

    public

    [ Top ]

    TCheckBox::setCausesValidation

    setCausesValidation( boolean $value );

    Parameters

    $value

    whether postback event trigger by this checkbox will cause input validation.

    Remarks

    Sets the value indicating whether postback event trigger by this checkbox will cause input validation.

    access

    public

    [ Top ]

    TCheckBox::setChecked

    setChecked( boolean $value );

    Overridden in child classes as:

    TActiveCheckBox::setChecked()
    Sets a value indicating whether the checkbox is to be checked or not.
    TActiveRadioButton::setChecked()
    Checks the radio button.

    Parameters

    $value

    whether the checkbox is to be checked or not.

    Remarks

    Sets a value indicating whether the checkbox is to be checked or not.

    access

    public

    [ Top ]

    TCheckBox::setData

    setData( boolean $value );

    Parameters

    $value

    whether the checkbox is to be checked

    Remarks

    Sets the value indicating whether the checkbox is to be checked or not.

    This method is required by IDataRenderer. It is the same as setChecked().

    see

    TCheckBox::setChecked()

    since

    3.1.0

    access

    public

    [ Top ]

    TCheckBox::setEnableClientScript

    setEnableClientScript( boolean $value );

    Overridden in child classes as:

    TRadioButton::setEnableClientScript()

    Parameters

    $value

    whether to render javascript.

    access

    public

    [ Top ]

    TCheckBox::setIsValid

    setIsValid( bool $value );

    Parameters

    $value

    wether this control is valid.

    access

    public

    [ Top ]

    TCheckBox::setText

    setText( string $value );

    Overridden in child classes as:

    TActiveCheckBox::setText()
    Updates the button text on the client-side if the setEnableUpdate property is set to true.
    TActiveRadioButton::setText()
    Updates the button text on the client-side if the setEnableUpdate property is set to true.

    Parameters

    $value

    the text caption to be set

    Remarks

    Sets the text caption of the checkbox.

    access

    public

    [ Top ]

    TCheckBox::setTextAlign

    setTextAlign( TTextAlign $value );

    Parameters

    $value

    the alignment of the text caption. Valid values include Left and Right.

    access

    public

    [ Top ]

    TCheckBox::setValidationGroup

    setValidationGroup( string $value );

    Parameters

    $value

    the group of validators which the checkbox causes validation upon postback

    access

    public

    [ Top ]

    TCheckBox::setValue

    setValue( string $value );

    Parameters

    $value

    the value of the checkbox

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:44 +0200 by phpDocumentor 1.4.3


Docs For Class TTextAlign

Class TTextAlign

[line 526]
TEnumerable
   |
   --TTextAlign
Location: /Web/UI/WebControls/TCheckBox.php

Remarks

TTextAlign class.

TTextAlign defines the enumerable type for the possible text alignments

The following enumerable values are defined:

  • Left: left aligned
  • Right: right aligned

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCheckBox.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Left = 'Left'
  • Right = 'Right'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Left = 'Left' [line 528]

  • Right = 'Right' [line 529]

Documentation generated on Mon, 25 Jun 2012 14:43:44 +0200 by phpDocumentor 1.4.3


Docs For Class TCheckBoxColumn

Class TCheckBoxColumn

[line 45]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TCheckBoxColumn
Classes extended from TCheckBoxColumn:
TActiveCheckBoxColumn
TActiveCheckBoxColumn class

Location: /Web/UI/WebControls/TCheckBoxColumn.php

Remarks

TCheckBoxColumn class

TCheckBoxColumn represents a checkbox column that is bound to a field in a data source. The checked state of the checkboxes are determiend by the bound data at DataField. If ReadOnly is false, TCheckBoxColumn will display an enabled checkbox provided the cells are in edit mode. Otherwise, the checkboxes will be disabled to prevent from editting.

The checkbox control in the TCheckBoxColumn can be accessed by one of the following two methods:

  •  $datagridItem->CheckBoxColumnID->CheckBox
    •

  •  $datagridItem->CheckBoxColumnID->Controls[0]
    •
    The second method is possible because the checkbox control created within the datagrid cell is the first child.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TCheckBoxColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TDataGridColumn

    • TDataGridColumn::formatDataValue()
      Formats the text value according to a format string.
    • TDataGridColumn::getAllowSorting()
      Returns a value indicating whether this column allows sorting.
    • TDataGridColumn::getDataFieldValue()
      Fetches the value of the data at the specified field.
    • TDataGridColumn::getEnableCellGrouping()
    • TDataGridColumn::getFooterRenderer()
    • TDataGridColumn::getFooterStyle()
    • TDataGridColumn::getFooterText()
    • TDataGridColumn::getHeaderImageUrl()
    • TDataGridColumn::getHeaderRenderer()
    • TDataGridColumn::getHeaderStyle()
    • TDataGridColumn::getHeaderText()
    • TDataGridColumn::getID()
    • TDataGridColumn::getItemStyle()
    • TDataGridColumn::getOwner()
    • TDataGridColumn::getSortExpression()
    • TDataGridColumn::getViewState()
      Returns a viewstate value.
    • TDataGridColumn::getVisible()
    • TDataGridColumn::initialize()
      Initializes the column.
    • TDataGridColumn::initializeCell()
      Initializes the specified cell to its initial values.
    • TDataGridColumn::initializeFooterCell()
      Initializes the footer cell.
    • TDataGridColumn::initializeHeaderCell()
      Initializes the header cell.
    • TDataGridColumn::loadState()
      Loads persistent state values.
    • TDataGridColumn::saveState()
      Saves persistent state values.
    • TDataGridColumn::setEnableCellGrouping()
    • TDataGridColumn::setFooterRenderer()
      Sets the column footer cell renderer class.
    • TDataGridColumn::setFooterText()
    • TDataGridColumn::setHeaderImageUrl()
    • TDataGridColumn::setHeaderRenderer()
      Sets the column header cell renderer class.
    • TDataGridColumn::setHeaderText()
    • TDataGridColumn::setID()
      Sets the ID of the column.
    • TDataGridColumn::setOwner()
    • TDataGridColumn::setSortExpression()
    • TDataGridColumn::setViewState()
      Sets a viewstate value.
    • TDataGridColumn::setVisible()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TCheckBoxColumn::dataBindColumn

      dataBindColumn( $sender, $param );

      Parameters

      $sender

      $param

      Remarks

      Databinds a cell in the column.

      This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

      access

      public

      [ Top ]

      TCheckBoxColumn::getDataField

      getDataField( );

      Returns

      the field name from the data source to bind to the column

      access

      public

      [ Top ]

      TCheckBoxColumn::getReadOnly

      getReadOnly( );

      Returns

      whether the items in the column can be edited. Defaults to false.

      access

      public

      [ Top ]

      TCheckBoxColumn::initializeCell

      initializeCell( TTableCell $cell, integer $columnIndex, string $itemType );

      Overridden in child classes as:

      TActiveCheckBoxColumn::initializeCell()
      Initializes the specified cell to its initial values.

      Overrides TDataGridColumn::initializeCell() (Initializes the specified cell to its initial values.)

      Parameters

      $cell

      the cell to be initialized.

      $columnIndex

      the index to the Columns property that the cell resides in.

      $itemType

      the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)

      Remarks

      Initializes the specified cell to its initial values.

      This method overrides the parent implementation. It creates a checkbox inside the cell. If the column is read-only or if the item is not in edit mode, the checkbox will be set disabled.

      access

      public

      [ Top ]

      TCheckBoxColumn::setDataField

      setDataField( string $value );

      Parameters

      $value

      the field name from the data source to bind to the column

      access

      public

      [ Top ]

      TCheckBoxColumn::setReadOnly

      setReadOnly( boolean $value );

      Parameters

      $value

      whether the items in the column can be edited

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:44 +0200 by phpDocumentor 1.4.3


Docs For Class TCheckBoxList

Class TCheckBoxList

[line 50]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TCheckBoxList
Classes extended from TCheckBoxList:
TActiveCheckBoxList
TActiveCheckBoxList class.
TRadioButtonList
TRadioButtonList class

Location: /Web/UI/WebControls/TCheckBoxList.php

Remarks

TCheckBoxList class

TCheckBoxList displays a list of checkboxes on a Web page.

The layout of the checkbox list is specified via RepeatLayout, which can be either 'Table' (default) or 'Flow'. A table layout uses HTML table cells to organize the checkboxes while a flow layout uses line breaks to organize the checkboxes. When the layout is using 'Table', CellPadding and CellSpacing can be used to adjust the cellpadding and cellpadding of the table.

The number of columns used to display the checkboxes is specified via RepeatColumns property, while the RepeatDirection governs the order of the items being rendered.

The alignment of the text besides each checkbox can be specified via TextAlign.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCheckBoxList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TListControl

  • TListControl::addAttributesToRender()
    Adds attributes to renderer.
  • TListControl::addParsedObject()
    Adds object parsed from template to the control.
  • TListControl::clearSelection()
    Clears all existing selections.
  • TListControl::createListItemCollection()
    Creates a collection object to hold list items.
  • TListControl::formatDataValue()
    Formats the text value according to a format string.
  • TListControl::getAppendDataBoundItems()
  • TListControl::getAutoPostBack()
  • TListControl::getCausesValidation()
  • TListControl::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TListControl::getData()
    Returns the value of the selected item with the lowest cardinal index.
  • TListControl::getDataGroupField()
  • TListControl::getDataTextField()
  • TListControl::getDataTextFormatString()
  • TListControl::getDataValueField()
  • TListControl::getEnableClientScript()
  • TListControl::getHasItems()
  • TListControl::getIsMultiSelect()
  • TListControl::getItemCount()
  • TListControl::getItems()
  • TListControl::getPostBackOptions()
  • TListControl::getPromptText()
  • TListControl::getPromptValue()
  • TListControl::getSelectedIndex()
  • TListControl::getSelectedIndices()
  • TListControl::getSelectedItem()
  • TListControl::getSelectedValue()
  • TListControl::getSelectedValues()
  • TListControl::getTagName()
  • TListControl::getText()
  • TListControl::getValidationGroup()
  • TListControl::loadState()
    Loads items from viewstate.
  • TListControl::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event when selection is changed.
  • TListControl::onTextChanged()
    Raises OnTextChanged event when selection is changed.
  • TListControl::performDataBinding()
    Performs databinding to populate list items from data source.
  • TListControl::renderClientControlScript()
    Renders the javascript for list control.
  • TListControl::renderContents()
    Renders body content of the list control.
  • TListControl::renderPrompt()
    Renders the prompt text, if any.
  • TListControl::saveState()
    Saves items into viewstate.
  • TListControl::setAppendDataBoundItems()
  • TListControl::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TListControl::setCausesValidation()
  • TListControl::setData()
    Selects an item by the specified value.
  • TListControl::setDataGroupField()
  • TListControl::setDataTextField()
  • TListControl::setDataTextFormatString()
    Sets data text format string.
  • TListControl::setDataValueField()
  • TListControl::setEnableClientScript()
  • TListControl::setPromptText()
  • TListControl::setPromptValue()
  • TListControl::setSelectedIndex()
  • TListControl::setSelectedIndices()
  • TListControl::setSelectedValue()
    Sets selection by item value.
  • TListControl::setSelectedValues()
  • TListControl::setText()
  • TListControl::setValidationGroup()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCheckBoxList::__construct

    __construct( );

    Overridden in child classes as:

    TActiveCheckBoxList::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveRadioButtonList::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TRatingList::__construct()
    Sets the default repeat direction to horizontal.
    TActiveRatingList::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Constructor.

    Remember to call parent implementation if you override this method

    access

    public

    [ Top ]

    TCheckBoxList::createRepeatedControl

    createRepeatedControl( );

    Overridden in child classes as:

    TActiveCheckBoxList::createRepeatedControl()
    Creates a control used for repetition (used as a template).
    TRadioButtonList::createRepeatedControl()
    Creates a control used for repetition (used as a template).
    TActiveRadioButtonList::createRepeatedControl()
    Creates a control used for repetition (used as a template).

    Returns

    the control to be repeated

    Remarks

    Creates a control used for repetition (used as a template).

    access

    protected

    [ Top ]

    TCheckBoxList::createStyle

    createStyle( );

    Overrides TWebControl::createStyle() (Creates a style object to be used by the control.)

    Returns

    control style to be used

    Remarks

    Creates a style object for the control.

    This method creates a TTableStyle to be used by checkbox list.

    access

    protected

    [ Top ]

    TCheckBoxList::findControl

    findControl( string $id );

    Overrides TControl::findControl() (Finds a control by ID path within the current naming container.)

    Parameters

    $id

    control ID

    Returns

    control being found

    Remarks

    Finds a control by ID.

    This method overrides the parent implementation so that it always returns the checkbox list itself (because the checkbox list does not have child controls.)

    access

    public

    [ Top ]

    TCheckBoxList::generateItemStyle

    generateItemStyle( string $itemType, integer $index );

    Implementation of:
    IRepeatInfoUser::generateItemStyle()

    Parameters

    $itemType

    item type (Header,Footer,Item,AlternatingItem,SelectedItem,EditItem,Separator,Pager)

    $index

    index of the item being rendered

    Remarks

    Returns a style used for rendering items.

    This method is required by IRepeatInfoUser interface.

    access

    public

    [ Top ]

    TCheckBoxList::getCellPadding

    getCellPadding( );

    Returns

    the cellpadding for the table keeping the checkbox list. Defaults to -1, meaning not set.

    access

    public

    [ Top ]

    TCheckBoxList::getCellSpacing

    getCellSpacing( );

    Returns

    the cellspacing for the table keeping the checkbox list. Defaults to -1, meaning not set.

    access

    public

    [ Top ]

    TCheckBoxList::getClientClassName

    getClientClassName( );

    Overridden in child classes as:

    TRadioButtonList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    TRatingList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    TActiveRatingList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.

    Overrides TListControl::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TCheckBoxList::getDataChanged

    getDataChanged( );

    Returns

    whether postback has caused the control data change. False if the page is not in postback mode.

    Remarks

    Returns a value indicating whether postback has caused the control data change.

    This method is required by the IPostBackDataHandler interface.

    access

    public

    [ Top ]

    TCheckBoxList::getHasFooter

    getHasFooter( );

    Implementation of:
    IRepeatInfoUser::getHasFooter()

    Returns

    always false.

    Remarks

    Returns a value indicating whether this control contains footer item.

    This method is required by IRepeatInfoUser interface.

    access

    public

    [ Top ]

    TCheckBoxList::getHasHeader

    getHasHeader( );

    Implementation of:
    IRepeatInfoUser::getHasHeader()

    Returns

    always false.

    Remarks

    Returns a value indicating whether this control contains header item.

    This method is required by IRepeatInfoUser interface.

    access

    public

    [ Top ]

    TCheckBoxList::getHasSeparators

    getHasSeparators( );

    Implementation of:
    IRepeatInfoUser::getHasSeparators()

    Returns

    always false.

    Remarks

    Returns a value indicating whether this control contains separator items.

    This method is required by IRepeatInfoUser interface.

    access

    public

    [ Top ]

    TCheckBoxList::getIsMultiSelect

    getIsMultiSelect( );

    Overridden in child classes as:

    TRadioButtonList::getIsMultiSelect()

    Overrides TListControl::getIsMultiSelect() (parent method not documented)

    Returns

    whether this control supports multiple selection. Always true for checkbox list.

    access

    protected

    [ Top ]

    TCheckBoxList::getIsValid

    getIsValid( );

    Returns

    wether this control validated successfully.

    Remarks

    Returns true if this control validated successfully.

    Defaults to true.

    access

    public

    [ Top ]

    TCheckBoxList::getPostBackOptions

    getPostBackOptions( );

    Overridden in child classes as:

    TRatingList::getPostBackOptions()

    Overrides TListControl::getPostBackOptions() (parent method not documented)

    Remarks

    Gets the post back options for this checkbox.

    access

    protected

    [ Top ]

    TCheckBoxList::getRepeatColumns

    getRepeatColumns( );

    Returns

    the number of columns that the list should be displayed with. Defaults to 0 meaning not set.

    access

    public

    [ Top ]

    TCheckBoxList::getRepeatDirection

    getRepeatDirection( );

    Returns

    the direction of traversing the list, defaults to 'Vertical'

    access

    public

    [ Top ]

    TCheckBoxList::getRepeatInfo

    getRepeatInfo( );

    Returns

    repeat information (primarily used by control developers)

    access

    protected

    [ Top ]

    TCheckBoxList::getRepeatLayout

    getRepeatLayout( );

    Returns

    how the list should be displayed, using table or using line breaks. Defaults to 'Table'.

    access

    public

    [ Top ]

    TCheckBoxList::getSpanNeeded

    getSpanNeeded( );

    Returns

    true if we need a span

    Remarks

    Wether the list should be rendered inside a span or not

    access

    protected

    [ Top ]

    TCheckBoxList::getTextAlign

    getTextAlign( );

    Returns

    the alignment of the text caption, defaults to TTextAlign::Right.

    access

    public

    [ Top ]

    TCheckBoxList::getValidationPropertyValue

    getValidationPropertyValue( );

    Returns

    the value of the property to be validated.

    Remarks

    Returns the value to be validated.

    This methid is required by IValidatable interface.

    access

    public

    [ Top ]

    TCheckBoxList::loadPostData

    loadPostData( string $key, array $values );

    Overridden in child classes as:

    TRadioButtonList::loadPostData()
    Loads user input data.

    Parameters

    $key

    the key that can be used to retrieve data from the input data collection

    $values

    the input data collection

    Returns

    whether the data of the control has been changed

    Remarks

    Loads user input data.

    This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TCheckBoxList::onPreRender

    onPreRender( mixed $param );

    Overridden in child classes as:

    TRatingList::onPreRender()
    Publish the the rating style css file and rating image files.

    Overrides TDataBoundControl::onPreRender() (Ensures any pending databind is performed.)

    Parameters

    $param

    event parameter

    Remarks

    Registers for post data on postback.

    This method overrides the parent implementation.

    access

    public

    [ Top ]

    TCheckBoxList::raisePostDataChangedEvent

    raisePostDataChangedEvent( );

    Remarks

    Raises postdata changed event.

    This method is required by IPostBackDataHandler interface. It is invoked by the framework when SelectedIndices property is changed on postback. This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TCheckBoxList::render

    render( THtmlWriter $writer );

    Overridden in child classes as:

    TRatingList::render()
    Add rating style class name to the class attribute when setReadOnly property is true and when the setCssClass property is empty.

    Overrides TWebControl::render() (Renders the control.)

    Parameters

    $writer

    writer for rendering purpose.

    Remarks

    Renders the checkbox list control.

    This method overrides the parent implementation.

    access

    public

    [ Top ]

    TCheckBoxList::renderItem

    renderItem( THtmlWriter $writer, TRepeatInfo $repeatInfo, string $itemType, integer $index );

    Implementation of:
    IRepeatInfoUser::renderItem()
    Renders an item.

    Parameters

    $writer

    writer for rendering purpose

    $repeatInfo

    repeat information

    $itemType

    item type (Header,Footer,Item,AlternatingItem,SelectedItem,EditItem,Separator,Pager)

    $index

    zero-based index of the item in the item list

    Remarks

    Renders an item in the list.

    This method is required by IRepeatInfoUser interface.

    access

    public

    [ Top ]

    TCheckBoxList::setCellPadding

    setCellPadding( integer $value );

    Parameters

    $value

    the cellpadding for the table keeping the checkbox list.

    Remarks

    Sets the cellpadding for the table keeping the checkbox list.

    access

    public

    [ Top ]

    TCheckBoxList::setCellSpacing

    setCellSpacing( integer $value );

    Parameters

    $value

    the cellspacing for the table keeping the checkbox list.

    Remarks

    Sets the cellspacing for the table keeping the checkbox list.

    access

    public

    [ Top ]

    TCheckBoxList::setEnabled

    setEnabled( boolean $value );

    Overridden in child classes as:

    TRatingList::setEnabled()
    Wrapper for setReadOnly property.

    Overrides TControl::setEnabled() (parent method not documented)

    Parameters

    $value

    whether the control is to be enabled.

    access

    public

    [ Top ]

    TCheckBoxList::setIsValid

    setIsValid( bool $value );

    Parameters

    $value

    wether this control is valid.

    access

    public

    [ Top ]

    TCheckBoxList::setRepeatColumns

    setRepeatColumns( integer $value );

    Parameters

    $value

    the number of columns that the list should be displayed with.

    access

    public

    [ Top ]

    TCheckBoxList::setRepeatDirection

    setRepeatDirection( string $value );

    Parameters

    $value

    the direction (Vertical, Horizontal) of traversing the list

    access

    public

    [ Top ]

    TCheckBoxList::setRepeatLayout

    setRepeatLayout( string $value );

    Overridden in child classes as:

    TRatingList::setRepeatLayout()
    The repeat layout must be Table.

    Parameters

    $value

    how the list should be displayed, using table or using line breaks (Table, Flow)

    access

    public

    [ Top ]

    TCheckBoxList::setTextAlign

    setTextAlign( TTextAlign $value );

    Parameters

    $value

    the text alignment of the checkboxes

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:45 +0200 by phpDocumentor 1.4.3


Docs For Class TClientScript

Class TClientScript

[line 47]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TClientScript
Classes extended from TClientScript:
TActiveClientScript
TActiveClientScript class

Location: /Web/UI/WebControls/TClientScript.php

Remarks

TClientScript class

Allows importing of Prado Client Scripts from template via the PradoScripts property. Multiple Prado client-scripts can be specified using comma delimited string of the javascript library to include on the page. For example,

  •  <com:TClientScript PradoScripts="effects, rico" />
    •

    Custom javascript files can be register using the ScriptUrl property.

  •  <com:TClientScript ScriptUrl=<%~ test.js %> />
    •

    Contents within TClientScript will be treated as javascript code and will be rendered in place.

    Since Prado 3.2 the property FlushScriptFiles controls whether Prado will flush the script files defined in the page before rendering the TClientScript contents. If you're not using any external functions in your TClientScript block, you should set the FlushScriptFiles property to false, so Prado can postpone the loading of all the referenced script files further down the page generation cycle.

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: TClientScript.php 3162 2012-06-04 13:19:53Z ctrlaltca $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TClientScript::getFlushScriptFiles

      getFlushScriptFiles( );

      Returns

      whether to flush script files using TClientScriptManager::flushScriptFiles() before rendering the script block

      access

      public

      [ Top ]

      TClientScript::getPradoScripts

      getPradoScripts( );

      Returns

      comma delimited list of javascript libraries to included on the page.

      access

      public

      [ Top ]

      TClientScript::getScriptUrl

      getScriptUrl( );

      Returns

      custom javascript file url.

      access

      public

      [ Top ]

      TClientScript::onPreRender

      onPreRender( mixed $param );

      Overrides TControl::onPreRender() (This method is invoked when the control enters 'OnPreRender' stage.)

      Parameters

      $param

      event parameter

      Remarks

      Calls the client script manager to add each of the requested client script libraries.

      access

      public

      [ Top ]

      TClientScript::render

      render( THtmlWriter $writer );

      Overrides TControl::render() (Renders the control.)

      Parameters

      $writer

      the renderer

      Remarks

      Renders the body content as javascript block.

      Overrides parent implementation, parent renderChildren method is called during registerCustomScript.

      access

      public

      [ Top ]

      TClientScript::renderCustomScript

      renderCustomScript( THtmlWriter $writer );

      Overridden in child classes as:

      TActiveClientScript::renderCustomScript()
      Registers the body content as javascript.

      Parameters

      $writer

      the renderer

      Remarks

      Registers the body content as javascript.

      access

      protected

      [ Top ]

      TClientScript::renderCustomScriptFile

      renderCustomScriptFile( THtmLWriter $writer );

      Overridden in child classes as:

      TActiveClientScript::renderCustomScriptFile()
      Renders the custom script file.

      Parameters

      $writer

      the renderer

      Remarks

      Renders the custom script file.

      access

      protected

      [ Top ]

      TClientScript::setFlushScriptFiles

      setFlushScriptFiles( bool $value );

      Parameters

      $value

      whether to flush script files using TClientScriptManager::flushScriptFiles() before rendering the script block

      access

      public

      [ Top ]

      TClientScript::setPradoScripts

      setPradoScripts( string $value );

      Parameters

      $value

      comma delimited list of javascript libraries to include.

      Remarks

      Include javascript library to the current page. The current supported libraries are: "prado", "effects", "ajax", "validator", "logger", "datepicker", "colorpicker". Library dependencies are automatically resolved.

      access

      public

      [ Top ]

      TClientScript::setScriptUrl

      setScriptUrl( string $value );

      Parameters

      $value

      custom javascript file url.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:46 +0200 by phpDocumentor 1.4.3


Docs For Class TColorPicker

Class TColorPicker

[line 40]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --TColorPicker
Location: /Web/UI/WebControls/TColorPicker.php

Remarks

TColorPicker class.

TColorPicker displays a text box for color input purpose. Next to the textbox there's a button filled with the current chosen color. Users can write a color name directly in the text box as an hex triplet (also known as HTML notation, eg: #FF00FF). Alternatively, if the ShowColorPicker property is enabled (it is by default), users can click the button to have a color picker UI appear. A color chan be chosen directly by clicking on the color picker.

TColorPicker has three different color picker UI Modes:

  • Simple - Grid with 12 simple colors.
  • Basic - Grid with the most common 70 colors. This is the default mode.
  • Full - Full-featured color picker.
The CssClass property can be used to override the CSS class name for the color picker panel. The ColorStyle property sets the packages styles available. E.g. default.

If the Mode property is set to Full, the color picker panel will display an "Ok" and "Cancel" buttons. You can customize the button labels setting the OKButtonText and CancelButtonText properties.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TColorPicker.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • SCRIPT_PATH =  'prado/colorpicker'

Inherited Class Constant Summary

Inherited From Class TTextBox

  • TTextBox::DEFAULT_COLUMNS = 20
    Default number of columns (for MultiLine text box)
  • TTextBox::DEFAULT_ROWS = 4
    Default number of rows (for MultiLine text box)

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TTextBox

  • TTextBox::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TTextBox::getAutoCompleteType()
  • TTextBox::getAutoPostBack()
  • TTextBox::getAutoTrim()
  • TTextBox::getCausesValidation()
  • TTextBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TTextBox::getColumns()
  • TTextBox::getData()
    Returns the text content of the TTextBox control.
  • TTextBox::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TTextBox::getEnableClientScript()
  • TTextBox::getIsValid()
    Returns true if this control validated successfully.
  • TTextBox::getMaxLength()
  • TTextBox::getPersistPassword()
  • TTextBox::getPostBackOptions()
    Gets the post back options for this textbox.
  • TTextBox::getReadOnly()
  • TTextBox::getRows()
  • TTextBox::getSafeText()
  • TTextBox::getSafeTextParser()
  • TTextBox::getTagName()
  • TTextBox::getText()
  • TTextBox::getTextMode()
  • TTextBox::getValidationGroup()
  • TTextBox::getValidationPropertyValue()
    Returns the value to be validated.
  • TTextBox::getWrap()
  • TTextBox::loadPostData()
    Loads user input data.
  • TTextBox::onTextChanged()
    Raises OnTextChanged event.
  • TTextBox::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TTextBox::renderBeginTag()
    Renders an additional line-break after the opening tag when it is in MultiLine text mode.
  • TTextBox::renderClientControlScript()
    Renders the javascript for textbox.
  • TTextBox::renderContents()
    Renders the body content of the textbox when it is in MultiLine text mode.
  • TTextBox::setAutoCompleteType()
  • TTextBox::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TTextBox::setAutoTrim()
    Sets the value indicating if the input text should be trimmed spaces
  • TTextBox::setCausesValidation()
  • TTextBox::setColumns()
    Sets the display width of the text box in characters.
  • TTextBox::setData()
    Sets the text content of the TTextBox control.
  • TTextBox::setEnableClientScript()
  • TTextBox::setIsValid()
  • TTextBox::setMaxLength()
    Sets the maximum number of characters allowed in the text box.
  • TTextBox::setPersistPassword()
  • TTextBox::setReadOnly()
  • TTextBox::setRows()
    Sets the number of rows displayed in a multiline text box.
  • TTextBox::setText()
    Sets the text content of the TTextBox control.
  • TTextBox::setTextMode()
    Sets the behavior mode of the TTextBox component.
  • TTextBox::setValidationGroup()
  • TTextBox::setWrap()
    Sets the value indicating whether the text content wraps within a multiline text box.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TColorPicker::createClientSide

    createClientSide( );

    Returns

    javascript validator event options.

    access

    protected

    [ Top ]

    TColorPicker::getAssetUrl

    getAssetUrl( [string $file = ''] );

    Parameters

    $file

    asset file in the self::SCRIPT_PATH directory.

    Returns

    asset file url.

    access

    protected

    [ Top ]

    TColorPicker::getCancelButtonText

    getCancelButtonText( );

    Returns

    text for the color picker Cancel button. Default is "Cancel".

    access

    public

    [ Top ]

    TColorPicker::getClientClassName

    getClientClassName( );

    Overrides TTextBox::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TColorPicker::getClientSide

    getClientSide( );

    Returns

    javascript event options.

    access

    public

    [ Top ]

    TColorPicker::getColorPickerStyle

    getColorPickerStyle( );

    Returns

    current color picker style

    access

    public

    [ Top ]

    TColorPicker::getMode

    getMode( );

    Returns

    current color picker UI mode. Defaults to TColorPickerMode::Basic.

    access

    public

    [ Top ]

    TColorPicker::getOKButtonText

    getOKButtonText( );

    Returns

    text for the color picker OK button. Default is "OK".

    access

    public

    [ Top ]

    TColorPicker::getPostBackOptions

    getPostBackOptions( );

    Overrides TTextBox::getPostBackOptions() (Gets the post back options for this textbox.)

    Returns

    color picker client-side options

    Remarks

    Get javascript color picker options.

    access

    protected

    [ Top ]

    TColorPicker::getShowColorPicker

    getShowColorPicker( );

    Returns

    whether the color picker should pop up when the button is clicked.

    access

    public

    [ Top ]

    TColorPicker::onPreRender

    onPreRender( $param );

    Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

    Parameters

    $param

    Remarks

    Publish the color picker Css asset files.

    access

    public

    [ Top ]

    TColorPicker::publishColorPickerAssets

    publishColorPickerAssets( );

    Remarks

    Publish the color picker assets.

    access

    protected

    [ Top ]

    TColorPicker::renderEndTag

    renderEndTag( THtmlWriter $writer );

    Overrides TWebControl::renderEndTag() (Renders the closing tag for the control)

    Parameters

    $writer

    writer

    Remarks

    Renders additional body content.

    This method overrides parent implementation by adding additional color picker button.

    access

    public

    [ Top ]

    TColorPicker::setCancelButtonText

    setCancelButtonText( string $value );

    Parameters

    $value

    text for the color picker Cancel button

    access

    public

    [ Top ]

    TColorPicker::setColorPickerStyle

    setColorPickerStyle( string $value );

    Parameters

    $value

    set the color picker style

    access

    public

    [ Top ]

    TColorPicker::setMode

    setMode( TColorPickerMode $value );

    Parameters

    $value

    color picker UI mode

    access

    public

    [ Top ]

    TColorPicker::setOKButtonText

    setOKButtonText( string $value );

    Parameters

    $value

    text for the color picker OK button

    access

    public

    [ Top ]

    TColorPicker::setShowColorPicker

    setShowColorPicker( boolean $value );

    Parameters

    $value

    whether to show the color picker popup

    Remarks

    Sets whether to pop up the color picker when the button is clicked.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • SCRIPT_PATH =  'prado/colorpicker' [line 42]

Documentation generated on Mon, 25 Jun 2012 14:43:47 +0200 by phpDocumentor 1.4.3


Docs For Class TColorPickerClientSide

Class TColorPickerClientSide

[line 272]
TComponent
   |
   --TClientSideOptions
      |
      --TColorPickerClientSide
Location: /Web/UI/WebControls/TColorPicker.php

Remarks

TColorPickerClientSide class.

Client-side javascript code options.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TColorPicker.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TClientSideOptions

  • TClientSideOptions::__construct()
    Constructor, initialize the options list.
  • TClientSideOptions::ensureFunction()
    Ensure that the javascript statements are wrapped in a javascript function block as
  • function(sender, parameter){ //code }
    •
    .
  • TClientSideOptions::getOption()
  • TClientSideOptions::getOptions()
  • TClientSideOptions::setFunction()
    Adds on client-side event handler by wrapping the code within a javascript function block. If the code begins with "javascript:", the code is assumed to be a javascript function block rather than arbiturary javascript statements.
  • TClientSideOptions::setOption()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TColorPickerClientSide::getOnColorSelected

    getOnColorSelected( );

    Returns

    javascript code for when a color is selected.

    access

    public

    [ Top ]

    TColorPickerClientSide::setOnColorSelected

    setOnColorSelected( string $javascript );

    Parameters

    $javascript

    javascript code for when a color is selected.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:48 +0200 by phpDocumentor 1.4.3


Docs For Class TColorPickerMode

Class TColorPickerMode

[line 255]
TEnumerable
   |
   --TColorPickerMode
Location: /Web/UI/WebControls/TColorPicker.php

Remarks

TColorPickerMode class.

TColorPickerMode defines the enumerable type for the possible UI mode that a TColorPicker control can take.

The following enumerable values are defined:

  • Simple - Grid with 12 simple colors.
  • Basic - Grid with the most common 70 colors. This is the default mode.
  • Full - Full-featured color picker.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TColorPicker.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Basic = 'Basic'
  • Full = 'Full'
  • Simple = 'Simple'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Basic = 'Basic' [line 258]

  • Full = 'Full' [line 259]

  • Simple = 'Simple' [line 257]

Documentation generated on Mon, 25 Jun 2012 14:43:48 +0200 by phpDocumentor 1.4.3


Docs For Class TCompareValidator

Class TCompareValidator

[line 47]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TCompareValidator
Location: /Web/UI/WebControls/TCompareValidator.php

Remarks

TCompareValidator class

TCompareValidator compares the value entered by the user into an input control with the value entered into another input control or a constant value. To compare the associated input control with another input control, set the ControlToCompare property to the ID path of the control to compare with. To compare the associated input control with a constant value, specify the constant value to compare with by setting the ValueToCompare property.

The DataType property is used to specify the data type of both comparison values. Both values are automatically converted to this data type before the comparison operation is performed. The following value types are supported:

  • Integer A 32-bit signed integer data type.
  • Float A double-precision floating point number data type.
  • Date A date data type. The format can be specified by the DateFormat property
  • String A string data type.
Use the Operator property to specify the type of comparison to perform. Valid operators include Equal, NotEqual, GreaterThan, GreaterThanEqual, LessThan and LessThanEqual.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCompareValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TBaseValidator

  • TBaseValidator::__construct()
    Constructor.
  • TBaseValidator::addAttributesToRender()
    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
  • TBaseValidator::createClientSide()
  • TBaseValidator::evaluateIsValid()
    This is the major method for validation.
  • TBaseValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
  • TBaseValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
  • TBaseValidator::getClientSide()
    Gets the TValidatorClientSide that allows modification of the client- side validator events.
  • TBaseValidator::getControlCssClass()
  • TBaseValidator::getControlToValidate()
  • TBaseValidator::getDisplay()
  • TBaseValidator::getEnableClientScript()
  • TBaseValidator::getErrorMessage()
  • TBaseValidator::getFocusElementID()
    Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::getFocusOnError()
  • TBaseValidator::getIsValid()
  • TBaseValidator::getValidationGroup()
  • TBaseValidator::getValidationTarget()
  • TBaseValidator::getValidationValue()
    Retrieves the property value of the control being validated.
  • TBaseValidator::onInit()
    Registers the validator with page.
  • TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
  • TBaseValidator::onUnload()
    Unregisters the validator from page.
  • TBaseValidator::onValidate()
    This event is raised right before the validator starts to perform validation.
  • TBaseValidator::onValidationError()
    This event is raised when the validator fails in validation.
  • TBaseValidator::onValidationSuccess()
    This event is raised when the validator succeeds in validation.
  • TBaseValidator::registerClientScriptValidator()
    Registers the individual validator client-side javascript code.
  • TBaseValidator::renderClientControlScript()
    Renders the javascript code to the end script.
  • TBaseValidator::renderContents()
    Renders the validator control.
  • TBaseValidator::setControlCssClass()
  • TBaseValidator::setControlToValidate()
    Sets the ID path of the input control to validate.
  • TBaseValidator::setDisplay()
  • TBaseValidator::setEnableClientScript()
  • TBaseValidator::setEnabled()
    This method overrides parent's implementation by setting setIsValid to true if disabled.
  • TBaseValidator::setErrorMessage()
    Sets the text for the error message.
  • TBaseValidator::setFocusElementID()
    Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::setFocusOnError()
  • TBaseValidator::setForControl()
    This method overrides the parent implementation to forbid setting ForControl.
  • TBaseValidator::setIsValid()
    Sets the value indicating whether the validation succeeds
  • TBaseValidator::setValidationGroup()
  • TBaseValidator::updateControlCssClass()
    Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
  • TBaseValidator::validate()
    Validates the specified control.

Inherited From Class TLabel

  • TLabel::addAttributesToRender()
    Adds attributes to renderer.
  • TLabel::getData()
    Returns the text value of the label.
  • TLabel::getForControl()
  • TLabel::getTagName()
  • TLabel::getText()
  • TLabel::render()
    Renders the label.
  • TLabel::renderContents()
    Renders the body content of the label.
  • TLabel::setData()
    Sets the text value of the label.
  • TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
  • TLabel::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCompareValidator::evaluateIsValid

    evaluateIsValid( );

    Overrides TBaseValidator::evaluateIsValid() (This is the major method for validation.)

    Returns

    whether the validation succeeds

    Remarks

    This method overrides the parent's implementation.

    The validation succeeds if the input data compares successfully. The validation always succeeds if ControlToValidate is not specified or the input data is empty.

    access

    public

    [ Top ]

    TCompareValidator::getClientClassName

    getClientClassName( );

    Overrides TBaseValidator::getClientClassName() (Gets the name of the javascript class responsible for performing validation for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing validation for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TCompareValidator::getClientScriptOptions

    getClientScriptOptions( );

    Overrides TBaseValidator::getClientScriptOptions() (Returns an array of javascript validator options.)

    Returns

    javascript validator options.

    Remarks

    Returns an array of javascript validator options.

    access

    protected

    [ Top ]

    TCompareValidator::getComparisonValues

    getComparisonValues( string $value1, string $value2 );

    Parameters

    $value1

    value one

    $value2

    second value

    Returns

    appropriate type of the value pair, array($value1, $value2);

    Remarks

    Parse the pair of values into the appropriate value type.

    access

    protected

    [ Top ]

    TCompareValidator::getControlToCompare

    getControlToCompare( );

    Returns

    the input component to compare with the input control being validated.

    access

    public

    [ Top ]

    TCompareValidator::getDataType

    getDataType( );

    Returns

    the data type that the values being compared are converted to before the comparison is made. Defaults to TValidationDataType::String.

    access

    public

    [ Top ]

    TCompareValidator::getDateFormat

    getDateFormat( );

    Returns

    the date validation date format if any

    access

    public

    [ Top ]

    TCompareValidator::getOperator

    getOperator( );

    Returns

    the comparison operation to perform. Defaults to TValidationCompareOperator::Equal.

    access

    public

    [ Top ]

    TCompareValidator::getValueToCompare

    getValueToCompare( );

    Returns

    the constant value to compare with the value entered by the user into the input component being validated.

    access

    public

    [ Top ]

    TCompareValidator::setControlToCompare

    setControlToCompare( string $value );

    Parameters

    $value

    the ID path of the component to compare with

    Remarks

    Sets the input component to compare with the input control being validated.

    access

    public

    [ Top ]

    TCompareValidator::setDataType

    setDataType( TValidationDataType $value );

    Parameters

    $value

    the data type

    Remarks

    Sets the data type that the values being compared are converted to before the comparison is made.

    access

    public

    [ Top ]

    TCompareValidator::setDateFormat

    setDateFormat( string $value );

    Parameters

    $value

    the date format value

    Remarks

    Sets the date format for a date validation

    access

    public

    [ Top ]

    TCompareValidator::setOperator

    setOperator( TValidationCompareOperator $value );

    Parameters

    $value

    the comparison operation

    Remarks

    Sets the comparison operation to perform

    access

    public

    [ Top ]

    TCompareValidator::setValueToCompare

    setValueToCompare( string $value );

    Parameters

    $value

    the constant value

    Remarks

    Sets the constant value to compare with the value entered by the user into the input component being validated.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:48 +0200 by phpDocumentor 1.4.3


Docs For Class TValidationCompareOperator

Class TValidationCompareOperator

[line 256]
TEnumerable
   |
   --TValidationCompareOperator
Location: /Web/UI/WebControls/TCompareValidator.php

Remarks

TValidationCompareOperator class.

TValidationCompareOperator defines the enumerable type for the comparison operations that TCompareValidator can perform validation with.

The following enumerable values are defined:

  • Equal
  • NotEqual
  • GreaterThan
  • GreaterThanEqual
  • LessThan
  • LessThanEqual

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCompareValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Equal = 'Equal'
  • GreaterThan = 'GreaterThan'
  • GreaterThanEqual = 'GreaterThanEqual'
  • LessThan = 'LessThan'
  • LessThanEqual = 'LessThanEqual'
  • NotEqual = 'NotEqual'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Equal = 'Equal' [line 258]

  • GreaterThan = 'GreaterThan' [line 260]

  • GreaterThanEqual = 'GreaterThanEqual' [line 261]

  • LessThan = 'LessThan' [line 262]

  • LessThanEqual = 'LessThanEqual' [line 263]

  • NotEqual = 'NotEqual' [line 259]

Documentation generated on Mon, 25 Jun 2012 14:43:49 +0200 by phpDocumentor 1.4.3


Docs For Class TConditional

Class TConditional

[line 46]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TConditional
Location: /Web/UI/WebControls/TConditional.php

Remarks

TConditional class.

TConditional displays appropriate content based on the evaluation result of a PHP expression specified via Condition. If the result is true, it instantiates the template TrueTemplate; otherwise, the template FalseTemplate is instantiated. The PHP expression is evaluated right before onInit stage of the control lifecycle.

Since Condition is evaluated at a very early stage, it is recommended you set Condition in template and the expression should not refer to objects that are available on or after onInit lifecycle.

A typical usage of TConditional is shown as following:

  •  <com:TConditional Condition="$this->User->IsGuest">
    •

  •    <prop:TrueTemplate>
    •

  •      <a href="path/to/login">Login</a>
    •

  •    </prop:TrueTemplate>
    •

  •    <prop:FalseTemplate>
    •

  •      <a href="path/to/logout">Logout</a>
    •

  •    </prop:FalseTemplate>
    •

  •  </com:TConditional>
    •

    TConditional is very light. It instantiates either TrueTemplate or FalseTemplate, but never both. And the condition is evaluated only once.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TConditional.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.1.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TConditional::addParsedObject

      addParsedObject( string|TComponent $object );

      Overrides TControl::addParsedObject() (Adds the object instantiated on a template to the child control collection.)

      Parameters

      $object

      text string or component parsed and instantiated in template

      Remarks

      Processes an object that is created during parsing template.

      This method overrides the parent implementation by removing all contents enclosed in the template tag.

      see

      TComponent::createdOnTemplate()

      access

      public

      [ Top ]

      TConditional::createChildControls

      createChildControls( );

      Overrides TControl::createChildControls() (Creates child controls.)

      Remarks

      Creates child controls.

      This method overrides the parent implementation. It evaluates Condition and instantiate the corresponding template.

      access

      public

      [ Top ]

      TConditional::getCondition

      getCondition( );

      Returns

      the PHP expression used for determining which template to use. Defaults to 'true', meaning using TrueTemplate.

      access

      public

      [ Top ]

      TConditional::getFalseTemplate

      getFalseTemplate( );

      Returns

      the template applied when Condition is false.

      access

      public

      [ Top ]

      TConditional::getTrueTemplate

      getTrueTemplate( );

      Returns

      the template applied when Condition is true.

      access

      public

      [ Top ]

      TConditional::setCondition

      setCondition( string $value );

      Parameters

      $value

      the PHP expression used for determining which template to use.

      Remarks

      Sets the PHP expression to be evaluated for conditionally displaying content.

      The context of the expression is the template control containing TConditional.

      access

      public

      [ Top ]

      TConditional::setFalseTemplate

      setFalseTemplate( $value );

      Parameters

      $value

      the template applied when Condition is false.

      access

      public

      [ Top ]

      TConditional::setTrueTemplate

      setTrueTemplate( $value );

      Parameters

      $value

      the template applied when Condition is true.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:51 +0200 by phpDocumentor 1.4.3


Docs For Class TContent

Class TContent

[line 32]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TContent
Location: /Web/UI/WebControls/TContent.php

Remarks

TContent class

TContent specifies a block of content on a control's template that will be injected at somewhere of the master control's template. TContentPlaceHolder and TContent together implement a decoration pattern for prado templated controls. A template control (called content control) can specify a master control whose template contains some TContentPlaceHolder controls. TContent controls on the content control's template will replace the corresponding TContentPlaceHolder controls on the master control's template. This is called content injection. It is done by matching the IDs of TContent and TContentPlaceHolder controls.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TContent.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TContent::createdOnTemplate

    createdOnTemplate( TControl $parent );

    Overrides TComponent::createdOnTemplate() (This method is invoked after the component is instantiated by a template.)

    Parameters

    $parent

    potential parent of this control

    Remarks

    This method is invoked after the control is instantiated on a template.

    This overrides the parent implementation by registering the content control to the template owner control.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:52 +0200 by phpDocumentor 1.4.3


Docs For Class TContentPlaceHolder

Class TContentPlaceHolder

[line 31]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TContentPlaceHolder
Location: /Web/UI/WebControls/TContentPlaceHolder.php

Remarks

TContentPlaceHolder class

TContentPlaceHolder reserves a place on a template where a TContent control can inject itself and its children in. TContentPlaceHolder and TContent together implement a decoration pattern for prado templated controls. A template control (called content control) can specify a master control whose template contains some TContentPlaceHolder controls. TContent controls on the content control's template will replace the corresponding TContentPlaceHolder controls on the master control's template. This is called content injection. It is done by matching the IDs of TContent and TContentPlaceHolder controls.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TContentPlaceHolder.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TContentPlaceHolder::createdOnTemplate

    createdOnTemplate( TControl $parent );

    Overrides TComponent::createdOnTemplate() (This method is invoked after the component is instantiated by a template.)

    Parameters

    $parent

    potential parent of this control

    Remarks

    This method is invoked after the control is instantiated on a template.

    This overrides the parent implementation by registering the content placeholder control to the template owner control. The placeholder control will NOT be added to the potential parent control!

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:52 +0200 by phpDocumentor 1.4.3


Docs For Class TCustomValidator

Class TCustomValidator

[line 55]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TCustomValidator
Classes extended from TCustomValidator:
TActiveCustomValidator
TActiveCustomValidator Class

Location: /Web/UI/WebControls/TCustomValidator.php

Remarks

TCustomValidator class

TCustomValidator performs user-defined validation (either server-side or client-side or both) on an input component.

To create a server-side validation function, provide a handler for the OnServerValidate event that performs the validation. The data string of the input control to validate can be accessed by TServerValidateEventParameter::getValue of the event parameter. The result of the validation should be stored in the TServerValidateEventParameter::getIsValid property of the event parameter.

To create a client-side validation function, add the client-side validation javascript function to the page template. The function should have the following signature:

  •  <script type="text/javascript"><!--
    •

  •  function ValidationFunctionName(sender, parameter)
    •

  •  {
    •

  •     // if(parameter == ...)
    •

  •     //    return true;
    •

  •     // else
    •

  •     //    return false;
    •

  •  }
    •

  •  --></script>
    •
    Use the ClientValidationFunction property to specify the name of the client-side validation script function associated with the TCustomValidator.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TCustomValidator.php 3091 2012-01-18 09:35:07Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TBaseValidator

    • TBaseValidator::__construct()
      Constructor.
    • TBaseValidator::addAttributesToRender()
      Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
    • TBaseValidator::createClientSide()
    • TBaseValidator::evaluateIsValid()
      This is the major method for validation.
    • TBaseValidator::getClientClassName()
      Gets the name of the javascript class responsible for performing validation for this control.
    • TBaseValidator::getClientScriptOptions()
      Returns an array of javascript validator options.
    • TBaseValidator::getClientSide()
      Gets the TValidatorClientSide that allows modification of the client- side validator events.
    • TBaseValidator::getControlCssClass()
    • TBaseValidator::getControlToValidate()
    • TBaseValidator::getDisplay()
    • TBaseValidator::getEnableClientScript()
    • TBaseValidator::getErrorMessage()
    • TBaseValidator::getFocusElementID()
      Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
    • TBaseValidator::getFocusOnError()
    • TBaseValidator::getIsValid()
    • TBaseValidator::getValidationGroup()
    • TBaseValidator::getValidationTarget()
    • TBaseValidator::getValidationValue()
      Retrieves the property value of the control being validated.
    • TBaseValidator::onInit()
      Registers the validator with page.
    • TBaseValidator::onPreRender()
      Override parent implementation to update the control CSS Class before
    • TBaseValidator::onUnload()
      Unregisters the validator from page.
    • TBaseValidator::onValidate()
      This event is raised right before the validator starts to perform validation.
    • TBaseValidator::onValidationError()
      This event is raised when the validator fails in validation.
    • TBaseValidator::onValidationSuccess()
      This event is raised when the validator succeeds in validation.
    • TBaseValidator::registerClientScriptValidator()
      Registers the individual validator client-side javascript code.
    • TBaseValidator::renderClientControlScript()
      Renders the javascript code to the end script.
    • TBaseValidator::renderContents()
      Renders the validator control.
    • TBaseValidator::setControlCssClass()
    • TBaseValidator::setControlToValidate()
      Sets the ID path of the input control to validate.
    • TBaseValidator::setDisplay()
    • TBaseValidator::setEnableClientScript()
    • TBaseValidator::setEnabled()
      This method overrides parent's implementation by setting setIsValid to true if disabled.
    • TBaseValidator::setErrorMessage()
      Sets the text for the error message.
    • TBaseValidator::setFocusElementID()
      Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
    • TBaseValidator::setFocusOnError()
    • TBaseValidator::setForControl()
      This method overrides the parent implementation to forbid setting ForControl.
    • TBaseValidator::setIsValid()
      Sets the value indicating whether the validation succeeds
    • TBaseValidator::setValidationGroup()
    • TBaseValidator::updateControlCssClass()
      Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
    • TBaseValidator::validate()
      Validates the specified control.

    Inherited From Class TLabel

    • TLabel::addAttributesToRender()
      Adds attributes to renderer.
    • TLabel::getData()
      Returns the text value of the label.
    • TLabel::getForControl()
    • TLabel::getTagName()
    • TLabel::getText()
    • TLabel::render()
      Renders the label.
    • TLabel::renderContents()
      Renders the body content of the label.
    • TLabel::setData()
      Sets the text value of the label.
    • TLabel::setForControl()
      Sets the ID of the control that the label is associated with.
    • TLabel::setText()

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TCustomValidator::evaluateIsValid

      evaluateIsValid( );

      Overrides TBaseValidator::evaluateIsValid() (This is the major method for validation.)

      Returns

      whether the validation succeeds

      Remarks

      This method overrides the parent's implementation.

      The validation succeeds if onServerValidate returns true.

      access

      public

      [ Top ]

      TCustomValidator::getClientClassName

      getClientClassName( );

      Overridden in child classes as:

      TActiveCustomValidator::getClientClassName()

      Overrides TBaseValidator::getClientClassName() (Gets the name of the javascript class responsible for performing validation for this control.)

      Returns

      the javascript class name

      Remarks

      Gets the name of the javascript class responsible for performing validation for this control.

      This method overrides the parent implementation.

      access

      protected

      [ Top ]

      TCustomValidator::getClientScriptOptions

      getClientScriptOptions( );

      Overridden in child classes as:

      TActiveCustomValidator::getClientScriptOptions()
      Returns an array of javascript validator options.

      Overrides TBaseValidator::getClientScriptOptions() (Returns an array of javascript validator options.)

      Returns

      javascript validator options.

      Remarks

      Returns an array of javascript validator options.

      access

      protected

      [ Top ]

      TCustomValidator::getClientValidationFunction

      getClientValidationFunction( );

      Returns

      the name of the custom client-side script function used for validation.

      access

      public

      [ Top ]

      TCustomValidator::getValidationTarget

      getValidationTarget( );

      Overrides TBaseValidator::getValidationTarget() (parent method not documented)

      Returns

      control to be validated. Null if no control is found.

      access

      public

      [ Top ]

      TCustomValidator::onServerValidate

      onServerValidate( string $value );

      Parameters

      $value

      the value to be validated

      Returns

      whether the value is valid

      Remarks

      This method is invoked when the server side validation happens.

      It will raise the OnServerValidate event. The method also allows derived classes to handle the event without attaching a delegate. Note The derived classes should call parent implementation to ensure the OnServerValidate event is raised.

      access

      public

      [ Top ]

      TCustomValidator::registerClientScriptValidator

      registerClientScriptValidator( );

      Overrides TBaseValidator::registerClientScriptValidator() (Registers the individual validator client-side javascript code.)

      Remarks

      Only register the client-side validator if setClientValidationFunction is set.

      access

      protected

      [ Top ]

      TCustomValidator::setClientValidationFunction

      setClientValidationFunction( string $value );

      Overridden in child classes as:

      TActiveCustomValidator::setClientValidationFunction()
      Client validation function is NOT supported.

      Parameters

      $value

      the script function name

      Remarks

      Sets the name of the custom client-side script function used for validation.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:55 +0200 by phpDocumentor 1.4.3


Docs For Class TServerValidateEventParameter

Class TServerValidateEventParameter

[line 160]
TComponent
   |
   --TEventParameter
      |
      --TServerValidateEventParameter
Location: /Web/UI/WebControls/TCustomValidator.php

Remarks

TServerValidateEventParameter class

TServerValidateEventParameter encapsulates the parameter data for OnServerValidate event of TCustomValidator components.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCustomValidator.php 3091 2012-01-18 09:35:07Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TServerValidateEventParameter::__construct

    __construct( string $value, boolean $isValid );

    Parameters

    $value

    property value to be validated

    $isValid

    whether the value is valid

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TServerValidateEventParameter::getIsValid

    getIsValid( );

    Returns

    whether the value is valid

    access

    public

    [ Top ]

    TServerValidateEventParameter::getValue

    getValue( );

    Returns

    value to be validated

    access

    public

    [ Top ]

    TServerValidateEventParameter::setIsValid

    setIsValid( boolean $value );

    Parameters

    $value

    whether the value is valid

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:56 +0200 by phpDocumentor 1.4.3


Docs For Class IItemDataRenderer

Interface IItemDataRenderer

[line 560]
IDataRenderer
   |
   --IItemDataRenderer
Location: /Web/UI/WebControls/TDataBoundControl.php

Remarks

IItemDataRenderer interface.

IItemDataRenderer defines the interface that an item renderer needs to implement. Besides the Data property, a list item renderer also needs to provide ItemIndex and ItemType property.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataBoundControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class IDataRenderer

  • IDataRenderer::getData()
  • IDataRenderer::setData()

Method Detail

    IItemDataRenderer::getItemIndex

    getItemIndex( );

    Returns

    zero-based index of the item.

    Remarks

    Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.

    If the item is not in the collection (e.g. it is a header item), it returns -1.

    access

    public

    [ Top ]

    IItemDataRenderer::getItemType

    getItemType( );

    Returns

    the item type.

    access

    public

    [ Top ]

    IItemDataRenderer::setItemIndex

    setItemIndex( integer $value );

    Parameters

    $value

    zero-based index of the item.

    Remarks

    Sets the zero-based index for the item.

    If the item is not in the item collection (e.g. it is a header item), -1 should be used.

    access

    public

    [ Top ]

    IItemDataRenderer::setItemType

    setItemType( TListItemType $value );

    Parameters

    $value

    the item type.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:56 +0200 by phpDocumentor 1.4.3


Docs For Class TDataBoundControl

Class TDataBoundControl

[line 46]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
Classes extended from TDataBoundControl:
TBaseDataList
TBaseDataList class
TListControl
TListControl class
TRepeater
TRepeater class.

Location: /Web/UI/WebControls/TDataBoundControl.php

Remarks

TDataBoundControl class.

TDataBoundControl is the based class for controls that need to populate data from data sources. It provides basic properties and methods that allow the derived controls to associate with data sources and retrieve data from them.

TBC....

TDataBoundControl is equipped with paging capabilities. By setting AllowPaging to true, the input data will be paged and only one page of data is actually populated into the data-bound control. This saves a lot of memory when dealing with larget datasets.

To specify the number of data items displayed on each page, set the PageSize property, and to specify which page of data to be displayed, set CurrentPageIndex.

When the size of the original data is too big to be loaded all in the memory, one can enable custom paging. In custom paging, the total number of data items is specified manually via VirtualItemCount, and the data source only needs to contain the current page of data. To enable custom paging, set AllowCustomPaging to true.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataBoundControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataBoundControl::createPagedDataSource

    createPagedDataSource( );

    Returns

    creates a paged data source

    access

    protected

    [ Top ]

    TDataBoundControl::dataBind

    dataBind( );

    Overrides TControl::dataBind() (Performs the databinding for this control.)

    Remarks

    Performs databinding.

    This method overrides the parent implementation by calling performSelect which fetches data from data source and does the actual binding work.

    access

    public

    [ Top ]

    TDataBoundControl::dataSourceViewChanged

    dataSourceViewChanged( $sender, $param );

    Parameters

    $sender

    $param

    access

    public

    [ Top ]

    TDataBoundControl::determineDataSource

    determineDataSource( );

    access

    protected

    [ Top ]

    TDataBoundControl::ensureDataBound

    ensureDataBound( );

    Remarks

    Ensures any pending dataBind is called.

    This method calls dataBind if the data source is specified by setDataSourceID or if RequiresDataBinding is true.

    access

    protected

    [ Top ]

    TDataBoundControl::getAllowCustomPaging

    getAllowCustomPaging( );

    Returns

    whether the custom paging is enabled. Defaults to false.

    access

    public

    [ Top ]

    TDataBoundControl::getAllowPaging

    getAllowPaging( );

    Returns

    whether paging is enabled. Defaults to false.

    access

    public

    [ Top ]

    TDataBoundControl::getCurrentPageIndex

    getCurrentPageIndex( );

    Returns

    the zero-based index of the current page. Defaults to 0.

    access

    public

    [ Top ]

    TDataBoundControl::getDataMember

    getDataMember( );

    access

    public

    [ Top ]

    TDataBoundControl::getDataSource

    getDataSource( );

    Returns

    data source object, defaults to null.

    access

    public

    [ Top ]

    TDataBoundControl::getDataSourceID

    getDataSourceID( );

    Returns

    ID path to the data source control. Defaults to empty.

    access

    public

    [ Top ]

    TDataBoundControl::getDataSourceView

    getDataSourceView( );

    access

    protected

    [ Top ]

    TDataBoundControl::getInitialized

    getInitialized( );

    Returns

    whether the databound control has been initialized. By default, the control is initialized after its viewstate has been restored.

    access

    protected

    [ Top ]

    TDataBoundControl::getIsDataBound

    getIsDataBound( );

    Returns

    whether databind has been invoked in the previous page request

    access

    protected

    [ Top ]

    TDataBoundControl::getPageCount

    getPageCount( );

    Returns

    number of pages of data items available

    access

    public

    [ Top ]

    TDataBoundControl::getPageSize

    getPageSize( );

    Returns

    the number of data items on each page. Defaults to 10.

    access

    public

    [ Top ]

    TDataBoundControl::getRequiresDataBinding

    getRequiresDataBinding( );

    Returns

    whether a databind call is required (by the data bound control)

    access

    protected

    [ Top ]

    TDataBoundControl::getSelectParameters

    getSelectParameters( );

    access

    public

    [ Top ]

    TDataBoundControl::getUsingDataSourceID

    getUsingDataSourceID( );

    Returns

    if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource.

    access

    protected

    [ Top ]

    TDataBoundControl::getVirtualItemCount

    getVirtualItemCount( );

    Returns

    virtual number of data items in the data source. Defaults to 0.

    see

    TDataBoundControl::setAllowCustomPaging()

    access

    public

    [ Top ]

    TDataBoundControl::onDataBound

    onDataBound( $param );

    Parameters

    $param

    Remarks

    Raises OnDataBound event.

    This method should be invoked after a databind is performed. It is mainly used by framework and component developers.

    access

    public

    [ Top ]

    TDataBoundControl::onDataSourceChanged

    onDataSourceChanged( );

    Remarks

    Sets setRequiresDataBinding as true if the control is initialized.

    This method is invoked when either setDataSource or setDataSourceID is changed.

    access

    public

    [ Top ]

    TDataBoundControl::onInit

    onInit( TEventParameter $param );

    Overrides TControl::onInit() (This method is invoked when the control enters 'OnInit' stage.)

    Parameters

    $param

    event parameter

    Remarks

    Sets page's OnPreLoad event handler as pagePreLoad.

    If viewstate is disabled and the current request is a postback, RequiresDataBinding will be set true. This method overrides the parent implementation.

    access

    public

    [ Top ]

    TDataBoundControl::onPreRender

    onPreRender( TEventParameter $param );

    Overridden in child classes as:

    TCheckBoxList::onPreRender()
    Registers for post data on postback.
    TRatingList::onPreRender()
    Publish the the rating style css file and rating image files.
    TActiveDropDownList::onPreRender()
    Updates the client-side options if the item list has changed after the OnLoad event.
    TListBox::onPreRender()
    Registers the list control to load post data on postback.
    TActiveListBox::onPreRender()
    Updates the client-side options if the item list has changed after the OnLoad event.

    Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

    Parameters

    $param

    event parameter

    Remarks

    Ensures any pending databind is performed.

    This method overrides the parent implementation.

    access

    public

    [ Top ]

    TDataBoundControl::pagePreLoad

    pagePreLoad( mixed $sender, TEventParameter $param );

    Parameters

    $sender

    event sender

    $param

    event parameter

    Remarks

    Sets getInitialized as true.

    This method is invoked when page raises PreLoad event.

    access

    public

    [ Top ]

    TDataBoundControl::performDataBinding

    performDataBinding( $data );

    Overridden in child classes as:

    TDataGrid::performDataBinding()
    Performs databinding to populate datagrid items from data source.
    TDataList::performDataBinding()
    Performs databinding to populate data list items from data source.
    TListControl::performDataBinding()
    Performs databinding to populate list items from data source.
    TRepeater::performDataBinding()
    Performs databinding to populate repeater items from data source.

    Parameters

    $data

    abstract

    access

    protected

    [ Top ]

    TDataBoundControl::setAllowCustomPaging

    setAllowCustomPaging( boolean $value );

    Parameters

    $value

    whether the custom paging is enabled

    Remarks

    Sets a value indicating whether the custom paging should be enabled.

    When the pager is in custom paging mode, the VirtualItemCount property is used to determine the paging, and the data items in the DataSource are considered to be in the current page.

    access

    public

    [ Top ]

    TDataBoundControl::setAllowPaging

    setAllowPaging( boolean $value );

    Parameters

    $value

    whether paging is enabled

    access

    public

    [ Top ]

    TDataBoundControl::setCurrentPageIndex

    setCurrentPageIndex( integer $value );

    Parameters

    $value

    the zero-based index of the current page

    throws

    TInvalidDataValueException if the value is less than 0

    access

    public

    [ Top ]

    TDataBoundControl::setDataMember

    setDataMember( $value );

    Parameters

    $value

    access

    public

    [ Top ]

    TDataBoundControl::setDataSource

    setDataSource( Traversable|array|string $value );

    Overridden in child classes as:

    TActiveDataGrid::setDataSource()
    Sets the data source object associated with the datagrid control.
    TActiveDataList::setDataSource()
    Sets the data source object associated with the repeater control.
    TActiveRepeater::setDataSource()
    Sets the data source object associated with the repeater control.

    Parameters

    $value

    data source object

    Remarks

    Sets the data source object associated with the databound control.

    The data source must implement Traversable interface. If an array is given, it will be converted to xxx. If a string is given, it will be converted to xxx.

    access

    public

    [ Top ]

    TDataBoundControl::setDataSourceID

    setDataSourceID( string $value );

    Parameters

    $value

    ID path to the data source control. The data source control must be locatable via TControl::findControl call.

    access

    public

    [ Top ]

    TDataBoundControl::setInitialized

    setInitialized( boolean $value );

    Parameters

    $value

    a value indicating whether the databound control is initialized.

    Remarks

    Sets a value indicating whether the databound control is initialized.

    If initialized, any modification to DataSource or DataSourceID will set RequiresDataBinding as true.

    access

    protected

    [ Top ]

    TDataBoundControl::setIsDataBound

    setIsDataBound( boolean $value );

    Parameters

    $value

    if databind has been invoked in this page request

    access

    protected

    [ Top ]

    TDataBoundControl::setPageSize

    setPageSize( integer $value );

    Parameters

    $value

    the number of data items on each page.

    throws

    TInvalidDataValueException if the value is less than 1

    access

    public

    [ Top ]

    TDataBoundControl::setRequiresDataBinding

    setRequiresDataBinding( boolean $value );

    Parameters

    $value

    whether a databind call is required.

    Remarks

    Sets a value indicating whether a databind call is required by the data bound control.

    If true and the control has been prerendered while it uses the data source specified by setDataSourceID, a databind call will be called by this method.

    access

    protected

    [ Top ]

    TDataBoundControl::setVirtualItemCount

    setVirtualItemCount( integer $value );

    Parameters

    $value

    virtual number of data items in the data source.

    see

    TDataBoundControl::setAllowCustomPaging()

    throws

    TInvalidDataValueException if the value is less than 0

    access

    public

    [ Top ]

    TDataBoundControl::validateDataSource

    validateDataSource( Traversable|array|string $value );

    Parameters

    $value

    data source to be validated

    Returns

    the data that is traversable

    Remarks

    Validates if the parameter is a valid data source.

    If it is a string or an array, it will be converted as a TList object.

    throws

    TInvalidDataTypeException if the data is neither null nor Traversable

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:56 +0200 by phpDocumentor 1.4.3


Docs For Class TListItemType

Class TListItemType

[line 534]
TEnumerable
   |
   --TListItemType
Location: /Web/UI/WebControls/TDataBoundControl.php

Remarks

TListItemType class.

TListItemType defines the enumerable type for the possible types that databound list items could take.

The following enumerable values are defined:

  • Header: header item
  • Footer: footer item
  • Item: content item (neither header nor footer)
  • Separator: separator between items
  • AlternatingItem: alternating content item
  • EditItem: content item in edit mode
  • SelectedItem: selected content item
  • Pager: pager

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataBoundControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • AlternatingItem = 'AlternatingItem'
  • EditItem = 'EditItem'
  • Footer = 'Footer'
  • Header = 'Header'
  • Item = 'Item'
  • Pager = 'Pager'
  • SelectedItem = 'SelectedItem'
  • Separator = 'Separator'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • AlternatingItem = 'AlternatingItem' [line 540]

  • EditItem = 'EditItem' [line 541]

  • Footer = 'Footer' [line 537]

  • Header = 'Header' [line 536]

  • Item = 'Item' [line 538]

  • Pager = 'Pager' [line 543]

  • SelectedItem = 'SelectedItem' [line 542]

  • Separator = 'Separator' [line 539]

Documentation generated on Mon, 25 Jun 2012 14:43:57 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGrid

Class TDataGrid

[line 152]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TBaseDataList
                  |
                  --TDataGrid
Classes extended from TDataGrid:
TActiveDataGrid
TActiveDataGrid class

Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGrid class

TDataGrid represents a data bound and updatable grid control.

To populate data into the datagrid, sets its DataSource to a tabular data source and call dataBind(). Each row of data will be represented by an item in the Items collection of the datagrid.

An item can be at one of three states: browsing, selected and edit. The state determines how the item will be displayed. For example, if an item is in edit state, it may be displayed as a table row with input text boxes if the columns are of type TBoundColumn; and if in browsing state, they are displayed as static text.

To change the state of an item, set EditItemIndex or SelectedItemIndex property.

Each datagrid item has a TDataGridItem::getItemType which tells the position and state of the item in the datalist. An item in the header of the repeater is of type Header. A body item may be of either Item, AlternatingItem, SelectedItem or EditItem, depending whether the item index is odd or even, whether it is being selected or edited.

A datagrid is specified with a list of columns. Each column specifies how the corresponding table column will be displayed. For example, the header/footer text of that column, the cells in that column, and so on. The following column types are currently provided by the framework,

  • TBoundColumn, associated with a specific field in datasource and displays the corresponding data.
  • TEditCommandColumn, displaying edit/update/cancel command buttons
  • TButtonColumn, displaying generic command buttons that may be bound to specific field in datasource.
  • TDropDownListColumn, displaying a dropdown list when the item is in edit state
  • THyperLinkColumn, displaying a hyperlink that may be bound to specific field in datasource.
  • TCheckBoxColumn, displaying a checkbox that may be bound to specific field in datasource.
  • TTemplateColumn, displaying content based on templates.
There are three ways to specify columns for a datagrid.
  • Automatically generated based on data source. By setting AutoGenerateColumns to true, a list of columns will be automatically generated based on the schema of the data source. Each column corresponds to a column of the data.
  • Specified in template. For example,
  •      <com:TDataGrid ...>
    •

  •         <com:TBoundColumn .../>
    •

  •         <com:TEditCommandColumn .../>
    •

  •      </com:TDataGrid>
    •
  • Manually created in code. Columns can be manipulated via the setColumns property of the datagrid. For example,
  •     $column=new TBoundColumn;
    •

  •     $datagrid->Columns[]=$column;
    •
Note, automatically generated columns cannot be accessed via the Columns property.

TDataGrid supports sorting. If the AllowSorting is set to true, a column with nonempty setSortExpression will have its header text displayed as a clickable link button. Clicking on the link button will raise OnSortCommand event. You can respond to this event, sort the data source according to the event parameter, and then invoke databind() on the datagrid to show to end users the sorted data.

TDataGrid supports paging. If the AllowPaging is set to true, a pager will be displayed on top and/or bottom of the table. How the pager will be displayed is determined by the PagerStyle property. Clicking on a pager button will raise an OnPageIndexChanged event. You can respond to this event, specify the page to be displayed by setting CurrentPageIndex</b> property, and then invoke databind() on the datagrid to show to end users a new page of data.

TDataGrid supports two kinds of paging. The first one is based on the number of data items in datasource. The number of pages PageCount is calculated based the item number and the PageSize property. The datagrid will manage which section of the data source to be displayed based on the CurrentPageIndex property. The second approach calculates the page number based on the VirtualItemCount property and the PageSize property. The datagrid will always display from the beginning of the datasource up to the number of PageSize data items. This approach is especially useful when the datasource may contain too many data items to be managed by the datagrid efficiently.

When the datagrid contains a button control that raises an onCommand event, the event will be bubbled up to the datagrid control. If the event's command name is recognizable by the datagrid control, a corresponding item event will be raised. The following item events will be raised upon a specific command:

  • OnEditCommand, if CommandName=edit
  • OnCancelCommand, if CommandName=cancel
  • OnSelectCommand, if CommandName=select
  • OnDeleteCommand, if CommandName=delete
  • OnUpdateCommand, if CommandName=update
  • onPageIndexChanged, if CommandName=page
  • OnSortCommand, if CommandName=sort
Note, an OnItemCommand event is raised in addition to the above specific command events.

TDataGrid also raises an OnItemCreated event for every newly created datagrid item. You can respond to this event to customize the content or style of the newly created item.

Note, the data bound to the datagrid are reset to null after databinding. There are several ways to access the data associated with a datagrid row:

  • Access the data in OnItemDataBound event
  • Use DataKeys to obtain the data key associated with
the specified datagrid row and use the key to fetch the corresponding data from some persistent storage such as DB.
  • Save the data in viewstate and get it back during postbacks.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • CMD_CANCEL = 'Cancel'
  • CMD_DELETE = 'Delete'
  • CMD_EDIT = 'Edit'
  • CMD_PAGE = 'Page'
  • CMD_PAGE_FIRST = 'First'
  • CMD_PAGE_LAST = 'Last'
  • CMD_PAGE_NEXT = 'Next'
  • CMD_PAGE_PREV = 'Previous'
  • CMD_SELECT = 'Select'
    Command name that TDataGrid understands.
  • CMD_SORT = 'Sort'
  • CMD_UPDATE = 'Update'
  • IT_ALTERNATINGITEM = 'AlternatingItem'
  • IT_EDITITEM = 'EditItem'
  • IT_FOOTER = 'Footer'
  • IT_HEADER = 'Header'
    datagrid item types
  • IT_ITEM = 'Item'
  • IT_PAGER = 'Pager'
  • IT_SELECTEDITEM = 'SelectedItem'
  • IT_SEPARATOR = 'Separator'

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TBaseDataList

  • TBaseDataList::createStyle()
    Creates a style object for the control.
  • TBaseDataList::getCellPadding()
  • TBaseDataList::getCellSpacing()
  • TBaseDataList::getDataFieldValue()
    Returns the value of the data at the specified field.
  • TBaseDataList::getDataKeyField()
  • TBaseDataList::getDataKeys()
  • TBaseDataList::getGridLines()
  • TBaseDataList::getHorizontalAlign()
  • TBaseDataList::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event.
  • TBaseDataList::setCellPadding()
  • TBaseDataList::setCellSpacing()
  • TBaseDataList::setDataKeyField()
  • TBaseDataList::setGridLines()
    Sets the grid line style of the table layout.
  • TBaseDataList::setHorizontalAlign()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGrid::addParsedObject

    addParsedObject( mixed $object );

    Overrides TControl::addParsedObject() (Adds the object instantiated on a template to the child control collection.)

    Parameters

    $object

    object parsed in template

    Remarks

    Adds objects parsed in template to datagrid.

    Datagrid columns are added into Columns collection.

    access

    public

    [ Top ]

    TDataGrid::applyItemStyles

    applyItemStyles( );

    Remarks

    Applies styles to items, header, footer and separators.

    Item styles are applied in a hierarchical way. Style in higher hierarchy will inherit from styles in lower hierarchy. Starting from the lowest hierarchy, the item styles include item's own style, ItemStyle, AlternatingItemStyle, SelectedItemStyle, and EditItemStyle. Therefore, if background color is set as red in ItemStyle, EditItemStyle will also have red background color unless it is set to a different value explicitly.

    access

    protected

    [ Top ]

    TDataGrid::bubbleEvent

    bubbleEvent( TControl $sender, TEventParameter $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    the sender of the event

    $param

    event parameter

    Returns

    whether the event bubbling should stop here.

    Remarks

    This method overrides parent's implementation to handle onItemCommand event which is bubbled from TDataGridItem child controls.

    If the event parameter is TDataGridCommandEventParameter and the command name is a recognized one, which includes 'select', 'edit', 'delete', 'update', and 'cancel' (case-insensitive), then a corresponding command event is also raised (such as OnEditCommand). This method should only be used by control developers.

    access

    public

    [ Top ]

    TDataGrid::buildNextPrevPager

    buildNextPrevPager( TDataGridPager $pager );

    Parameters

    $pager

    the container for the pager

    Remarks

    Builds a next-prev pager

    access

    protected

    [ Top ]

    TDataGrid::buildNumericPager

    buildNumericPager( TDataGridPager $pager );

    Parameters

    $pager

    the container for the pager

    Remarks

    Builds a numeric pager

    access

    protected

    [ Top ]

    TDataGrid::buildPager

    buildPager( TDataGridPager $pager );

    Parameters

    $pager

    the container for the pager

    Remarks

    Builds the pager content based on pager style.

    access

    protected

    [ Top ]

    TDataGrid::createAutoColumns

    createAutoColumns( Traversable $dataSource );

    Parameters

    $dataSource

    data source bound to the datagrid

    Remarks

    Automatically generates datagrid columns based on datasource schema

    access

    protected

    [ Top ]

    TDataGrid::createItem

    createItem( integer $itemIndex, TListItemType $dataSourceIndex, $itemType );

    Parameters

    $itemIndex

    zero-based item index

    $dataSourceIndex

    item type

    $itemType

    Returns

    created data list item

    Remarks

    Creates a datagrid item instance based on the item type and index.

    access

    protected

    [ Top ]

    TDataGrid::createPagerButton

    createPagerButton( string $buttonType, boolean $enabled, string $text, string $commandName, string $commandParameter );

    Overridden in child classes as:

    TActiveDataGrid::createPagerButton()
    Creates a pager button.

    Parameters

    $buttonType

    button type, either LinkButton or PushButton

    $enabled

    whether the button should be enabled

    $text

    caption of the button

    $commandName

    CommandName corresponding to the OnCommand event of the button

    $commandParameter

    CommandParameter corresponding to the OnCommand event of the button

    Returns

    the button instance

    Remarks

    Creates a pager button.

    Depending on the button type, a TLinkButton or a TButton may be created. If it is enabled (clickable), its command name and parameter will also be set. Derived classes may override this method to create additional types of buttons, such as TImageButton.

    access

    protected

    [ Top ]

    TDataGrid::createStyle

    createStyle( );

    Overrides TBaseDataList::createStyle() (Creates a style object for the control.)

    Returns

    control style to be used

    Remarks

    Creates a style object for the control.

    This method creates a TTableStyle to be used by datagrid.

    access

    protected

    [ Top ]

    TDataGrid::getAllowSorting

    getAllowSorting( );

    Returns

    whether sorting is enabled. Defaults to false.

    access

    public

    [ Top ]

    TDataGrid::getAlternatingItemStyle

    getAlternatingItemStyle( );

    Returns

    the style for each alternating item

    access

    public

    [ Top ]

    TDataGrid::getAutoColumns

    getAutoColumns( );

    Returns

    automatically generated datagrid columns

    access

    public

    [ Top ]

    TDataGrid::getAutoGenerateColumnName

    getAutoGenerateColumnName( );

    Overridden in child classes as:

    TActiveDataGrid::getAutoGenerateColumnName()

    Returns

    Name of the class used in AutoGenerateColumns mode

    access

    protected

    [ Top ]

    TDataGrid::getAutoGenerateColumns

    getAutoGenerateColumns( );

    Returns

    whether datagrid columns should be automatically generated. Defaults to true.

    access

    public

    [ Top ]

    TDataGrid::getBackImageUrl

    getBackImageUrl( );

    Returns

    the URL of the background image for the datagrid

    access

    public

    [ Top ]

    TDataGrid::getBottomPager

    getBottomPager( );

    Returns

    the pager displayed at the bottom of datagrid. It could be null if paging is disabled.

    access

    public

    [ Top ]

    TDataGrid::getCaption

    getCaption( );

    Returns

    caption for the datagrid

    access

    public

    [ Top ]

    TDataGrid::getCaptionAlign

    getCaptionAlign( );

    Returns

    datagrid caption alignment. Defaults to TTableCaptionAlign::NotSet.

    access

    public

    [ Top ]

    TDataGrid::getColumns

    getColumns( );

    Returns

    manually specified datagrid columns

    access

    public

    [ Top ]

    TDataGrid::getEditItem

    getEditItem( );

    Returns

    the edit item

    access

    public

    [ Top ]

    TDataGrid::getEditItemIndex

    getEditItemIndex( );

    Returns

    the zero-based index of the edit item in Items. A value -1 means no item is in edit mode.

    access

    public

    [ Top ]

    TDataGrid::getEditItemStyle

    getEditItemStyle( );

    Returns

    the style for edit item

    access

    public

    [ Top ]

    TDataGrid::getEmptyTemplate

    getEmptyTemplate( );

    Returns

    the template applied when no data is bound to the datagrid

    access

    public

    [ Top ]

    TDataGrid::getFooter

    getFooter( );

    Returns

    the footer item

    access

    public

    [ Top ]

    TDataGrid::getFooterStyle

    getFooterStyle( );

    Returns

    the style for footer

    access

    public

    [ Top ]

    TDataGrid::getHeader

    getHeader( );

    Returns

    the header item

    access

    public

    [ Top ]

    TDataGrid::getHeaderStyle

    getHeaderStyle( );

    Returns

    the style for header

    access

    public

    [ Top ]

    TDataGrid::getItemCount

    getItemCount( );

    Returns

    number of items

    access

    public

    [ Top ]

    TDataGrid::getItems

    getItems( );

    Returns

    datagrid item collection

    access

    public

    [ Top ]

    TDataGrid::getItemStyle

    getItemStyle( );

    Returns

    the style for every item

    access

    public

    [ Top ]

    TDataGrid::getPagerStyle

    getPagerStyle( );

    Returns

    the style for pager

    access

    public

    [ Top ]

    TDataGrid::getSelectedItem

    getSelectedItem( );

    Returns

    the selected item, null if no item is selected.

    access

    public

    [ Top ]

    TDataGrid::getSelectedItemIndex

    getSelectedItemIndex( );

    Returns

    the zero-based index of the selected item in Items. A value -1 means no item selected.

    access

    public

    [ Top ]

    TDataGrid::getSelectedItemStyle

    getSelectedItemStyle( );

    Returns

    the style for selected item

    access

    public

    [ Top ]

    TDataGrid::getShowFooter

    getShowFooter( );

    Returns

    whether the footer should be displayed. Defaults to false.

    access

    public

    [ Top ]

    TDataGrid::getShowHeader

    getShowHeader( );

    Returns

    whether the header should be displayed. Defaults to true.

    access

    public

    [ Top ]

    TDataGrid::getTableBodyStyle

    getTableBodyStyle( );

    Returns

    the style for tbody element, if any

    since

    3.1.1

    access

    public

    [ Top ]

    TDataGrid::getTableFootStyle

    getTableFootStyle( );

    Returns

    the style for tfoot element, if any

    since

    3.1.1

    access

    public

    [ Top ]

    TDataGrid::getTableHeadStyle

    getTableHeadStyle( );

    Returns

    the style for thead element, if any

    since

    3.1.1

    access

    public

    [ Top ]

    TDataGrid::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name (table) of the datagrid

    access

    protected

    [ Top ]

    TDataGrid::getTopPager

    getTopPager( );

    Returns

    the pager displayed at the top of datagrid. It could be null if paging is disabled.

    access

    public

    [ Top ]

    TDataGrid::initializeItem

    initializeItem( TDataGrid $item, TDataGridColumnCollection $columns );

    Parameters

    $item

    datagrid item to be initialized

    $columns

    datagrid columns to be used to initialize the cells in the item

    Remarks

    Initializes a datagrid item and cells inside it

    access

    protected

    [ Top ]

    TDataGrid::loadState

    loadState( );

    Overrides TControl::loadState() (This method is invoked right after the control has loaded its state.)

    Remarks

    Loads item count information from viewstate.

    This method is invoked right after control state is loaded.

    access

    public

    [ Top ]

    TDataGrid::onCancelCommand

    onCancelCommand( TDataGridCommandEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnCancelCommand event.

    This method is invoked when a button control raises OnCommand event with cancel command name.

    access

    public

    [ Top ]

    TDataGrid::onDeleteCommand

    onDeleteCommand( TDataGridCommandEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnDeleteCommand event.

    This method is invoked when a button control raises OnCommand event with delete command name.

    access

    public

    [ Top ]

    TDataGrid::onEditCommand

    onEditCommand( TDataGridCommandEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnEditCommand event.

    This method is invoked when a button control raises OnCommand event with edit command name.

    access

    public

    [ Top ]

    TDataGrid::onItemCommand

    onItemCommand( TDataGridCommandEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnItemCommand event.

    This method is invoked when a button control raises OnCommand event.

    access

    public

    [ Top ]

    TDataGrid::onItemCreated

    onItemCreated( TDataGridItemEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnItemCreated event.

    This method is invoked right after a datagrid item is created and before added to page hierarchy.

    access

    public

    [ Top ]

    TDataGrid::onItemDataBound

    onItemDataBound( TDataGridItemEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnItemDataBound event.

    This method is invoked for each datagrid item after it performs databinding.

    access

    public

    [ Top ]

    TDataGrid::onPageIndexChanged

    onPageIndexChanged( TDataGridPageChangedEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnPageIndexChanged event.

    This method is invoked when current page is changed.

    access

    public

    [ Top ]

    TDataGrid::onPagerCreated

    onPagerCreated( TDataGridPagerEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnPagerCreated event.

    This method is invoked right after a datagrid pager is created and before added to page hierarchy.

    access

    public

    [ Top ]

    TDataGrid::onSortCommand

    onSortCommand( TDataGridSortCommandEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnSortCommand event.

    This method is invoked when a button control raises OnCommand event with sort command name.

    access

    public

    [ Top ]

    TDataGrid::onUpdateCommand

    onUpdateCommand( TDataGridCommandEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnUpdateCommand event.

    This method is invoked when a button control raises OnCommand event with update command name.

    access

    public

    [ Top ]

    TDataGrid::performDataBinding

    performDataBinding( Traversable $data );

    Overrides TDataBoundControl::performDataBinding() (parent method not documented)

    Parameters

    $data

    the bound data

    Remarks

    Performs databinding to populate datagrid items from data source.

    This method is invoked by dataBind(). You may override this function to provide your own way of data population.

    access

    protected

    [ Top ]

    TDataGrid::render

    render( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveDataGrid::render()
    Renders the datagrid.

    Overrides TWebControl::render() (Renders the control.)

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the datagrid.

    access

    public

    [ Top ]

    TDataGrid::renderBeginTag

    renderBeginTag( THtmlWriter $writer );

    Overrides TWebControl::renderBeginTag() (Renders the openning tag for the control (including attributes))

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the openning tag for the datagrid control which will render table caption if present.

    access

    public

    [ Top ]

    TDataGrid::renderTable

    renderTable( THtmlWriter $writer );

    Parameters

    $writer

    writer

    Remarks

    Renders the tabular data.

    access

    protected

    [ Top ]

    TDataGrid::reset

    reset( );

    Remarks

    Clears up all items in the datagrid.

    access

    public

    [ Top ]

    TDataGrid::restoreGridFromViewState

    restoreGridFromViewState( );

    Remarks

    Restores datagrid content from viewstate.

    access

    protected

    [ Top ]

    TDataGrid::saveState

    saveState( );

    Overrides TControl::saveState() (This method is invoked when control state is to be saved.)

    Remarks

    Saves item count in viewstate.

    This method is invoked right before control state is to be saved.

    access

    public

    [ Top ]

    TDataGrid::setAllowSorting

    setAllowSorting( boolean $value );

    Parameters

    $value

    whether sorting is enabled

    access

    public

    [ Top ]

    TDataGrid::setAutoGenerateColumns

    setAutoGenerateColumns( boolean $value );

    Parameters

    $value

    whether datagrid columns should be automatically generated

    access

    public

    [ Top ]

    TDataGrid::setBackImageUrl

    setBackImageUrl( string $value );

    Parameters

    $value

    the URL of the background image for the datagrid

    access

    public

    [ Top ]

    TDataGrid::setCaption

    setCaption( string $value );

    Parameters

    $value

    caption for the datagrid

    access

    public

    [ Top ]

    TDataGrid::setCaptionAlign

    setCaptionAlign( TTableCaptionAlign $value );

    Parameters

    $value

    datagrid caption alignment. Valid values include

    access

    public

    [ Top ]

    TDataGrid::setEditItemIndex

    setEditItemIndex( integer $value );

    Parameters

    $value

    the edit item index

    Remarks

    Edits an item by its index in getItems.

    Previously editting item will change to normal item state. If the index is less than 0, any existing edit item will be cleared up.

    access

    public

    [ Top ]

    TDataGrid::setEmptyTemplate

    setEmptyTemplate( ITemplate $value );

    Parameters

    $value

    the template applied when no data is bound to the datagrid

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TDataGrid::setSelectedItemIndex

    setSelectedItemIndex( integer $value );

    Parameters

    $value

    the selected item index

    Remarks

    Selects an item by its index in getItems.

    Previously selected item will be un-selected. If the item to be selected is already in edit mode, it will remain in edit mode. If the index is less than 0, any existing selection will be cleared up.

    access

    public

    [ Top ]

    TDataGrid::setShowFooter

    setShowFooter( boolean $value );

    Parameters

    $value

    whether the footer should be displayed

    access

    public

    [ Top ]

    TDataGrid::setShowHeader

    setShowHeader( boolean $value );

    Parameters

    $value

    whether the header should be displayed

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • CMD_CANCEL = 'Cancel' [line 174]

  • CMD_DELETE = 'Delete' [line 173]

  • CMD_EDIT = 'Edit' [line 171]

  • CMD_PAGE = 'Page' [line 176]

  • CMD_PAGE_FIRST = 'First' [line 179]

  • CMD_PAGE_LAST = 'Last' [line 180]

  • CMD_PAGE_NEXT = 'Next' [line 177]

  • CMD_PAGE_PREV = 'Previous' [line 178]

  • CMD_SELECT = 'Select' [line 170]

    • Remarks

    Command name that TDataGrid understands.

  • CMD_SORT = 'Sort' [line 175]

  • CMD_UPDATE = 'Update' [line 172]

  • IT_ALTERNATINGITEM = 'AlternatingItem' [line 162]

  • IT_EDITITEM = 'EditItem' [line 163]

  • IT_FOOTER = 'Footer' [line 159]

  • IT_HEADER = 'Header' [line 158]

    • Remarks

    datagrid item types

    deprecated

    deprecated since version 3.0.4. Use TListItemType constants instead.

  • IT_ITEM = 'Item' [line 160]

  • IT_PAGER = 'Pager' [line 165]

  • IT_SELECTEDITEM = 'SelectedItem' [line 164]

  • IT_SEPARATOR = 'Separator' [line 161]

Documentation generated on Mon, 25 Jun 2012 14:43:58 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridColumnCollection

Class TDataGridColumnCollection

[line 2153]
TComponent
   |
   --TList
      |
      --TDataGridColumnCollection
Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGridColumnCollection class.

TDataGridColumnCollection represents a collection of data grid columns.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGridColumnCollection::__construct

    __construct( TDataGrid $owner );

    Overrides TList::__construct() (Constructor.)

    Parameters

    $owner

    the control that owns this collection.

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDataGridColumnCollection::getOwner

    getOwner( );

    Returns

    the control that owns this collection.

    access

    protected

    [ Top ]

    TDataGridColumnCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TList::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by inserting only TDataGridColumn.

    throws

    TInvalidDataTypeException if the item to be inserted is not a TDataGridColumn.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:59 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridCommandEventParameter

Class TDataGridCommandEventParameter

[line 1765]
TComponent
   |
   --TEventParameter
      |
      --TCommandEventParameter
         |
         --TDataGridCommandEventParameter
Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGridCommandEventParameter class

TDataGridCommandEventParameter encapsulates the parameter data for TDataGrid::onItemCommand event of TDataGrid controls.

The Item property indicates the datagrid item related with the event. The CommandSource refers to the control that originally raises the Command event.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TCommandEventParameter

  • TCommandEventParameter::__construct()
    Constructor.
  • TCommandEventParameter::getCommandName()
  • TCommandEventParameter::getCommandParameter()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGridCommandEventParameter::__construct

    __construct( TDataGridItem $item, TControl $source, $param );

    Overrides TCommandEventParameter::__construct() (Constructor.)

    Parameters

    $item

    datagrid item responsible for the event

    $source

    original event sender

    $param

    original event parameter

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDataGridCommandEventParameter::getCommandSource

    getCommandSource( );

    Returns

    the control originally raises the Command event.

    access

    public

    [ Top ]

    TDataGridCommandEventParameter::getItem

    getItem( );

    Returns

    the TDataGridItem control responsible for the event.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:59 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridItem

Class TDataGridItem

[line 1929]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableRow
               |
               --TDataGridItem
Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGridItem class

A TDataGridItem control represents an item in the TDataGrid control, such as heading section, footer section, or a data item. The index and data value of the item can be accessed via ItemIndex> and DataItem properties, respectively. The type of the item is given by ItemType property. Property DataSourceIndex gives the index of the item from the bound data source.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TTableRow

  • TTableRow::addParsedObject()
    Adds object parsed from template to the control.
  • TTableRow::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TTableRow::createStyle()
    Creates a style object for the control.
  • TTableRow::getCells()
  • TTableRow::getHorizontalAlign()
  • TTableRow::getTableSection()
  • TTableRow::getTagName()
  • TTableRow::getVerticalAlign()
  • TTableRow::renderContents()
    Renders body contents of the table row
  • TTableRow::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the table item.
  • TTableRow::setTableSection()
  • TTableRow::setVerticalAlign()
    Sets the vertical alignment of the contents within the table item.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGridItem::__construct

    __construct( integer $itemIndex, TListItemType $dataSourceIndex, $itemType );

    Overrides TControl::__construct() (Constructor.)

    Parameters

    $itemIndex

    zero-based index of the item in the item collection of datagrid

    $dataSourceIndex

    item type

    $itemType

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDataGridItem::bubbleEvent

    bubbleEvent( TControl $sender, TEventParameter $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    the sender of the event

    $param

    event parameter

    Returns

    whether the event bubbling should stop here.

    Remarks

    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

    access

    public

    [ Top ]

    TDataGridItem::getData

    getData( );

    Returns

    data associated with the item

    since

    3.1.0

    access

    public

    [ Top ]

    TDataGridItem::getDataItem

    getDataItem( );

    Returns

    data associated with the item

    Remarks

    This property is deprecated since v3.1.0.

    deprecated

    deprecated since v3.1.0. Use getData instead.

    access

    public

    [ Top ]

    TDataGridItem::getDataSourceIndex

    getDataSourceIndex( );

    Returns

    the index of the datagrid item from the bound data source

    access

    public

    [ Top ]

    TDataGridItem::getItemIndex

    getItemIndex( );

    Returns

    zero-based index of the item in the item collection of datagrid

    access

    public

    [ Top ]

    TDataGridItem::getItemType

    getItemType( );

    Returns

    item type.

    access

    public

    [ Top ]

    TDataGridItem::setData

    setData( mixed $value );

    Parameters

    $value

    data to be associated with the item

    since

    3.1.0

    access

    public

    [ Top ]

    TDataGridItem::setDataItem

    setDataItem( mixed $value );

    Parameters

    $value

    data to be associated with the item

    Remarks

    This property is deprecated since v3.1.0.

    deprecated

    deprecated since version 3.1.0. Use setData instead.

    access

    public

    [ Top ]

    TDataGridItem::setItemType

    setItemType( TListItemType $value );

    Parameters

    $value

    item type

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:59 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridItemCollection

Class TDataGridItemCollection

[line 2125]
TComponent
   |
   --TList
      |
      --TDataGridItemCollection
Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGridItemCollection class.

TDataGridItemCollection represents a collection of data grid items.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGridItemCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TList::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by inserting only TDataGridItem.

    throws

    TInvalidDataTypeException if the item to be inserted is not a TDataGridItem.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:00 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridItemEventParameter

Class TDataGridItemEventParameter

[line 1686]
TComponent
   |
   --TEventParameter
      |
      --TDataGridItemEventParameter
Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGridItemEventParameter class

TDataGridItemEventParameter encapsulates the parameter data for TDataGrid::onItemCreated event of TDataGrid controls. The Item property indicates the datagrid item related with the event.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGridItemEventParameter::__construct

    __construct( TDataGridItem $item );

    Parameters

    $item

    datagrid item related with the corresponding event

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDataGridItemEventParameter::getItem

    getItem( );

    Returns

    datagrid item related with the corresponding event

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:00 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridPageChangedEventParameter

Class TDataGridPageChangedEventParameter

[line 1875]
TComponent
   |
   --TEventParameter
      |
      --TDataGridPageChangedEventParameter
Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGridPageChangedEventParameter class

TDataGridPageChangedEventParameter encapsulates the parameter data for TDataGrid::onPageIndexChanged event of TDataGrid controls.

The CommandSource property refers to the control that originally raises the OnCommand event, while NewPageIndex returns the new page index carried with the page command.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGridPageChangedEventParameter::__construct

    __construct( TControl $source, integer $newPageIndex );

    Parameters

    $source

    the control originally raises the OnCommand event.

    $newPageIndex

    new page index

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDataGridPageChangedEventParameter::getCommandSource

    getCommandSource( );

    Returns

    the control originally raises the OnCommand event.

    access

    public

    [ Top ]

    TDataGridPageChangedEventParameter::getNewPageIndex

    getNewPageIndex( );

    Returns

    new page index

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:00 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridPager

Class TDataGridPager

[line 2066]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPanel
               |
               --TDataGridPager
Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGridPager class.

TDataGridPager represents a datagrid pager.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TPanel

  • TPanel::addAttributesToRender()
    Adds attributes to renderer.
  • TPanel::createStyle()
    Creates a style object to be used by the control.
  • TPanel::getBackImageUrl()
  • TPanel::getDefaultButton()
  • TPanel::getDirection()
  • TPanel::getGroupingText()
  • TPanel::getHorizontalAlign()
  • TPanel::getScrollBars()
  • TPanel::getTagName()
  • TPanel::getWrap()
  • TPanel::render()
  • TPanel::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TPanel::renderEndTag()
    Renders the closing tag for the control
  • TPanel::setBackImageUrl()
    Sets the URL of the background image for the panel component.
  • TPanel::setDefaultButton()
    Specifies the default button for the panel.
  • TPanel::setDirection()
  • TPanel::setGroupingText()
  • TPanel::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the panel.
  • TPanel::setScrollBars()
  • TPanel::setWrap()
    Sets the value indicating whether the content wraps within the panel.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGridPager::__construct

    __construct( TDataGrid $dataGrid );

    Overrides TControl::__construct() (Constructor.)

    Parameters

    $dataGrid

    datagrid object

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDataGridPager::bubbleEvent

    bubbleEvent( TControl $sender, TEventParameter $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    the sender of the event

    $param

    event parameter

    Returns

    whether the event bubbling should stop here.

    Remarks

    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

    access

    public

    [ Top ]

    TDataGridPager::getDataGrid

    getDataGrid( );

    Returns

    the datagrid owning this pager

    access

    public

    [ Top ]

    TDataGridPager::getItemType

    getItemType( );

    Returns

    item type.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:00 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridPagerButtonType

Class TDataGridPagerButtonType

[line 2230]
TEnumerable
   |
   --TDataGridPagerButtonType
Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGridPagerButtonType class.

TDataGridPagerButtonType defines the enumerable type for the possible types of datagrid pager buttons.

The following enumerable values are defined:

  • LinkButton: link buttons
  • PushButton: form submit buttons

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • LinkButton = 'LinkButton'
  • PushButton = 'PushButton'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • LinkButton = 'LinkButton' [line 2232]

  • PushButton = 'PushButton' [line 2233]

Documentation generated on Mon, 25 Jun 2012 14:44:01 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridPagerEventParameter

Class TDataGridPagerEventParameter

[line 1724]
TComponent
   |
   --TEventParameter
      |
      --TDataGridPagerEventParameter
Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGridPagerEventParameter class

TDataGridPagerEventParameter encapsulates the parameter data for TDataGrid::onPagerCreated event of TDataGrid controls. The Pager property indicates the datagrid pager related with the event.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGridPagerEventParameter::__construct

    __construct( TDataGridPager $pager );

    Parameters

    $pager

    datagrid pager related with the corresponding event

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDataGridPagerEventParameter::getPager

    getPager( );

    Returns

    datagrid pager related with the corresponding event

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:01 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridPagerMode

Class TDataGridPagerMode

[line 2210]
TEnumerable
   |
   --TDataGridPagerMode
Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGridPagerMode class.

TDataGridPagerMode defines the enumerable type for the possible modes that a datagrid pager can take.

The following enumerable values are defined:

  • NextPrev: pager buttons are displayed as next and previous pages
  • Numeric: pager buttons are displayed as numeric page numbers

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • NextPrev = 'NextPrev'
  • Numeric = 'Numeric'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • NextPrev = 'NextPrev' [line 2212]

  • Numeric = 'Numeric' [line 2213]

Documentation generated on Mon, 25 Jun 2012 14:44:01 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridPagerPosition

Class TDataGridPagerPosition

[line 2251]
TEnumerable
   |
   --TDataGridPagerPosition
Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGridPagerPosition class.

TDataGridPagerPosition defines the enumerable type for the possible positions that a datagrid pager can be located at.

The following enumerable values are defined:

  • Bottom: pager appears only at the bottom of the data grid.
  • Top: pager appears only at the top of the data grid.
  • TopAndBottom: pager appears on both top and bottom of the data grid.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Bottom = 'Bottom'
  • Top = 'Top'
  • TopAndBottom = 'TopAndBottom'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Bottom = 'Bottom' [line 2253]

  • Top = 'Top' [line 2254]

  • TopAndBottom = 'TopAndBottom' [line 2255]

Documentation generated on Mon, 25 Jun 2012 14:44:01 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridSortCommandEventParameter

Class TDataGridSortCommandEventParameter

[line 1821]
TComponent
   |
   --TEventParameter
      |
      --TDataGridSortCommandEventParameter
Location: /Web/UI/WebControls/TDataGrid.php

Remarks

TDataGridSortCommandEventParameter class

TDataGridSortCommandEventParameter encapsulates the parameter data for TDataGrid::onSortCommand event of TDataGrid controls.

The CommandSource property refers to the control that originally raises the OnCommand event, while SortExpression gives the sort expression carried with the sort command.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGridSortCommandEventParameter::__construct

    __construct( TControl $source, TDataGridCommandEventParameter $param );

    Parameters

    $source

    the control originally raises the OnCommand event.

    $param

    command event parameter

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDataGridSortCommandEventParameter::getCommandSource

    getCommandSource( );

    Returns

    the control originally raises the OnCommand event.

    access

    public

    [ Top ]

    TDataGridSortCommandEventParameter::getSortExpression

    getSortExpression( );

    Returns

    sort expression

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:01 +0200 by phpDocumentor 1.4.3


Docs For Class TButtonColumnType

Class TButtonColumnType

[line 561]
TEnumerable
   |
   --TButtonColumnType
Location: /Web/UI/WebControls/TDataGridColumn.php

Remarks

TButtonColumnType class.

TButtonColumnType defines the enumerable type for the possible types of buttons that can be used in a TButtonColumn.

The following enumerable values are defined:

  • LinkButton: link buttons
  • PushButton: form buttons
  • ImageButton: image buttons

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGridColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • ImageButton = 'ImageButton'
  • LinkButton = 'LinkButton'
  • PushButton = 'PushButton'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • ImageButton = 'ImageButton' [line 565]

  • LinkButton = 'LinkButton' [line 563]

  • PushButton = 'PushButton' [line 564]

Documentation generated on Mon, 25 Jun 2012 14:44:01 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridColumn

Class TDataGridColumn

[line 65]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
Classes extended from TDataGridColumn:
TBoundColumn
TBoundColumn class
TButtonColumn
TButtonColumn class
TCheckBoxColumn
TCheckBoxColumn class
TDropDownListColumn
TDropDownListColumn class
TEditCommandColumn
TEditCommandColumn class
THyperLinkColumn
THyperLinkColumn class
TLiteralColumn
TLiteralColumn class
TTemplateColumn
TTemplateColumn class

Location: /Web/UI/WebControls/TDataGridColumn.php

Remarks

TDataGridColumn class

TDataGridColumn serves as the base class for the different column types of the TDataGrid control. TDataGridColumn defines the properties and methods that are common among all datagrid column types. In particular, it initializes header and footer cells according to HeaderText and HeaderStyle FooterText and FooterStyle properties. If HeaderImageUrl is specified, the image will be displayed instead in the header cell. The ItemStyle is applied to cells that belong to non-header and -footer datagrid items.

When the datagrid enables sorting, if the SortExpression is not empty, the header cell will display a button (linkbutton or imagebutton) that will bubble the sort command event to the datagrid.

Since v3.1.0, TDataGridColumn has introduced two new properties HeaderRenderer and FooterRenderer which can be used to specify the layout of header and footer column cells. A renderer refers to a control class that is to be instantiated as a control. For more details, see TRepeater and TDataList.

Since v3.1.1, TDataGridColumn has introduced EnableCellGrouping. If a column has this property set true, consecutive cells having the same content in this column will be grouped into one cell. Note, there are some limitations to cell grouping. We determine the cell content according to the cell's TTableCell::getText property. If the text is empty and the cell has some child controls, we will pick up the first control who implements IDataRenderer and obtain its IDataRenderer::getData property.

The following datagrid column types are provided by the framework currently,

  • TBoundColumn, associated with a specific field in datasource and displays the corresponding data.
  • TEditCommandColumn, displaying edit/update/cancel command buttons
  • TDropDownListColumn, displaying a dropdown list when the item is in edit state
  • TButtonColumn, displaying generic command buttons that may be bound to specific field in datasource.
  • THyperLinkColumn, displaying a hyperlink that may be bound to specific field in datasource.
  • TCheckBoxColumn, displaying a checkbox that may be bound to specific field in datasource.
  • TTemplateColumn, displaying content based on templates.
To create your own column class, simply override initializeCell() method, which is the major logic for managing the data and presentation of cells in the column.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGridColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGridColumn::formatDataValue

    formatDataValue( string $formatString, mixed $value );

    Parameters

    $formatString

    format string

    $value

    the data to be formatted

    Returns

    the formatted result

    Remarks

    Formats the text value according to a format string.

    If the format string is empty, the original value is converted into a string and returned. If the format string starts with '#', the string is treated as a PHP expression within which the token '{0}' is translated with the data value to be formated. Otherwise, the format string and the data value are passed as the first and second parameters in http://www.php.net/sprintf.

    access

    protected

    [ Top ]

    TDataGridColumn::getAllowSorting

    getAllowSorting( );

    Returns

    whether this column allows sorting

    Remarks

    Returns a value indicating whether this column allows sorting.

    The column allows sorting only when SortExpression is not empty and the datagrid allows sorting.

    access

    public

    [ Top ]

    TDataGridColumn::getDataFieldValue

    getDataFieldValue( mixed $data, string $field );

    Parameters

    $data

    data containing the field of value

    $field

    the data field

    Returns

    data value at the specified field

    Remarks

    Fetches the value of the data at the specified field.

    If the data is an array, the field is used as an array key. If the data is an of TMap, TList or their derived class, the field is used as a key value. If the data is a component, the field is used as the name of a property.

    throws

    TInvalidDataValueException if the data or the field is invalid.

    access

    protected

    [ Top ]

    TDataGridColumn::getEnableCellGrouping

    getEnableCellGrouping( );

    Returns

    whether cells having the same content should be grouped together. Defaults to false.

    since

    3.1.1

    access

    public

    [ Top ]

    TDataGridColumn::getFooterRenderer

    getFooterRenderer( );

    Returns

    the class name for the column footer cell renderer. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TDataGridColumn::getFooterStyle

    getFooterStyle( [boolean $createStyle = true] );

    Parameters

    $createStyle

    whether to create a style if previously not existing

    Returns

    the style for footer

    access

    public

    [ Top ]

    TDataGridColumn::getFooterText

    getFooterText( );

    Returns

    the text to be displayed in the footer of this column

    access

    public

    [ Top ]

    TDataGridColumn::getHeaderImageUrl

    getHeaderImageUrl( );

    Returns

    the url of the image to be displayed in header

    access

    public

    [ Top ]

    TDataGridColumn::getHeaderRenderer

    getHeaderRenderer( );

    Returns

    the class name for the column header cell renderer. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TDataGridColumn::getHeaderStyle

    getHeaderStyle( [boolean $createStyle = true] );

    Parameters

    $createStyle

    whether to create a style if previously not existing

    Returns

    the style for header

    access

    public

    [ Top ]

    TDataGridColumn::getHeaderText

    getHeaderText( );

    Returns

    the text to be displayed in the header of this column

    access

    public

    [ Top ]

    TDataGridColumn::getID

    getID( );

    Returns

    the ID of the column.

    access

    public

    [ Top ]

    TDataGridColumn::getItemStyle

    getItemStyle( [boolean $createStyle = true] );

    Parameters

    $createStyle

    whether to create a style if previously not existing

    Returns

    the style for item

    access

    public

    [ Top ]

    TDataGridColumn::getOwner

    getOwner( );

    Returns

    datagrid that owns this column

    access

    public

    [ Top ]

    TDataGridColumn::getSortExpression

    getSortExpression( );

    Returns

    the name of the field or expression for sorting

    access

    public

    [ Top ]

    TDataGridColumn::getViewState

    getViewState( string $key, [mixed $defaultValue = null] );

    Parameters

    $key

    the name of the viewstate value to be returned

    $defaultValue

    the default value. If $key is not found in viewstate, $defaultValue will be returned

    Returns

    the viewstate value corresponding to $key

    Remarks

    Returns a viewstate value.

    access

    protected

    [ Top ]

    TDataGridColumn::getVisible

    getVisible( [ $checkParents = true] );

    Parameters

    $checkParents

    Returns

    whether the column is visible. Defaults to true.

    access

    public

    [ Top ]

    TDataGridColumn::initialize

    initialize( );

    Remarks

    Initializes the column.

    This method is invoked by TDataGrid when the column is about to be used to initialize datagrid items. Derived classes may override this method to do additional initialization.

    access

    public

    [ Top ]

    TDataGridColumn::initializeCell

    initializeCell( TTableCell $cell, integer $columnIndex, string $itemType );

    Overridden in child classes as:

    TBoundColumn::initializeCell()
    Initializes the specified cell to its initial values.
    TButtonColumn::initializeCell()
    Initializes the specified cell to its initial values.
    TActiveButtonColumn::initializeCell()
    TCheckBoxColumn::initializeCell()
    Initializes the specified cell to its initial values.
    TActiveCheckBoxColumn::initializeCell()
    Initializes the specified cell to its initial values.
    TDropDownListColumn::initializeCell()
    Initializes the specified cell to its initial values.
    TEditCommandColumn::initializeCell()
    Initializes the specified cell to its initial values.
    THyperLinkColumn::initializeCell()
    Initializes the specified cell to its initial values.
    TLiteralColumn::initializeCell()
    Initializes the specified cell to its initial values.
    TTemplateColumn::initializeCell()
    Initializes the specified cell to its initial values.

    Parameters

    $cell

    the cell to be initialized.

    $columnIndex

    the index to the Columns property that the cell resides in.

    $itemType

    the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)

    Remarks

    Initializes the specified cell to its initial values.

    The default implementation sets the content of header and footer cells. If sorting is enabled by the grid and sort expression is specified in the column, the header cell will show a link/image button. Otherwise, the header/footer cell will only show static text/image. This method can be overriden to provide customized intialization to column cells.

    access

    public

    [ Top ]

    TDataGridColumn::initializeFooterCell

    initializeFooterCell( TTableCell $cell, integer $columnIndex );

    Parameters

    $cell

    the cell to be initialized

    $columnIndex

    the index to the Columns property that the cell resides in.

    Remarks

    Initializes the footer cell.

    This method attempts to use FooterRenderer to instantiate the footer cell. If that is not available, it will populate the cell with a text string specified by getFooterImageUrl

    access

    protected

    [ Top ]

    TDataGridColumn::initializeHeaderCell

    initializeHeaderCell( TTableCell $cell, integer $columnIndex );

    Overridden in child classes as:

    TActiveBoundColumn::initializeHeaderCell()
    TActiveCheckBoxColumn::initializeHeaderCell()
    TActiveDropDownListColumn::initializeHeaderCell()
    TActiveHyperLinkColumn::initializeHeaderCell()
    TActiveLiteralColumn::initializeHeaderCell()
    TActiveTemplateColumn::initializeHeaderCell()

    Parameters

    $cell

    the cell to be initialized

    $columnIndex

    the index to the Columns property that the cell resides in.

    Remarks

    Initializes the header cell.

    This method attempts to use HeaderRenderer to instantiate the header cell. If that is not available, it will populate the cell with an image or a text string, depending on HeaderImageUrl and HeaderText property values.

    If the column allows sorting, image or text will be created as a button which issues Sort command upon user click.

    access

    protected

    [ Top ]

    TDataGridColumn::loadState

    loadState( mixed $state );

    Overridden in child classes as:

    TDropDownListColumn::loadState()
    Loads items from viewstate.

    Parameters

    $state

    state values

    Remarks

    Loads persistent state values.

    access

    public

    [ Top ]

    TDataGridColumn::saveState

    saveState( );

    Overridden in child classes as:

    TDropDownListColumn::saveState()
    Saves items into viewstate.

    Returns

    values to be saved

    Remarks

    Saves persistent state values.

    access

    public

    [ Top ]

    TDataGridColumn::setEnableCellGrouping

    setEnableCellGrouping( boolean $value );

    Parameters

    $value

    whether cells having the same content should be grouped together.

    since

    3.1.1

    access

    public

    [ Top ]

    TDataGridColumn::setFooterRenderer

    setFooterRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the column footer cell renderer class.

    If not empty, the class will be used to instantiate as a child control in the column footer cell. If the class implements IDataRenderer, the Data property will be set as the FooterText.

    since

    3.1.0

    access

    public

    [ Top ]

    TDataGridColumn::setFooterText

    setFooterText( string $value );

    Parameters

    $value

    text to be displayed in the footer of this column

    access

    public

    [ Top ]

    TDataGridColumn::setHeaderImageUrl

    setHeaderImageUrl( string $value );

    Parameters

    $value

    the url of the image to be displayed in header

    access

    public

    [ Top ]

    TDataGridColumn::setHeaderRenderer

    setHeaderRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the column header cell renderer class.

    If not empty, the class will be used to instantiate as a child control in the column header cell. If the class implements IDataRenderer, the Data property will be set as the FooterText.

    since

    3.1.0

    access

    public

    [ Top ]

    TDataGridColumn::setHeaderText

    setHeaderText( string $value );

    Parameters

    $value

    text to be displayed in the header of this column

    access

    public

    [ Top ]

    TDataGridColumn::setID

    setID( string $value );

    Parameters

    $value

    the ID of the column.

    Remarks

    Sets the ID of the column.

    By explicitly specifying the column ID, one can access the column by $templateControl->ColumnID.

    throws

    TInvalidDataValueException if the ID is of bad format

    access

    public

    [ Top ]

    TDataGridColumn::setOwner

    setOwner( TDataGrid $value );

    Parameters

    $value

    datagrid object that owns this column

    access

    public

    [ Top ]

    TDataGridColumn::setSortExpression

    setSortExpression( string $value );

    Parameters

    $value

    the name of the field or expression for sorting

    access

    public

    [ Top ]

    TDataGridColumn::setViewState

    setViewState( string $key, mixed $value, [mixed $defaultValue = null] );

    Parameters

    $key

    the name of the viewstate value

    $value

    the viewstate value to be set

    $defaultValue

    default value. If $value===$defaultValue, the item will be cleared from the viewstate.

    Remarks

    Sets a viewstate value.

    Make sure that the viewstate value must be serializable and unserializable.

    access

    protected

    [ Top ]

    TDataGridColumn::setVisible

    setVisible( boolean $value );

    Parameters

    $value

    whether the column is visible

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:01 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridItemRenderer

Class TDataGridItemRenderer

[line 27]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TDataRenderer
                  |
                  --TItemDataRenderer
                     |
                     --TDataGridItemRenderer
Location: /Web/UI/WebControls/TDataGridItemRenderer.php

Remarks

TDataGridItemRenderer class

TDataGridItemRenderer can be used as a convenient base class to define an item renderer class specific for TDataGrid.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGridItemRenderer.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTemplateControl

  • TTemplateControl::EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TItemDataRenderer

  • TItemDataRenderer::getItemIndex()
    Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
  • TItemDataRenderer::getItemType()
  • TItemDataRenderer::setItemIndex()
    Sets the zero-based index for the item.
  • TItemDataRenderer::setItemType()

Inherited From Class TDataRenderer

  • TDataRenderer::getData()
  • TDataRenderer::setData()

Inherited From Class TTemplateControl

  • TTemplateControl::createChildControls()
    Creates child controls.
  • TTemplateControl::getIsSourceTemplateControl()
  • TTemplateControl::getMaster()
  • TTemplateControl::getMasterClass()
  • TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
  • TTemplateControl::getTemplateDirectory()
  • TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
  • TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
  • TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
  • TTemplateControl::registerContent()
    Registers a content control.
  • TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
  • TTemplateControl::setMasterClass()
  • TTemplateControl::setTemplate()
    Sets the parsed template.

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:01 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGridPagerStyle

Class TDataGridPagerStyle

[line 25]
TComponent
   |
   --TStyle
      |
      --TPanelStyle
         |
         --TDataGridPagerStyle
Location: /Web/UI/WebControls/TDataGridPagerStyle.php

Remarks

TDataGridPagerStyle class.

TDataGridPagerStyle specifies the styles available for a datagrid pager.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataGridPagerStyle.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TPanelStyle

  • TPanelStyle::addAttributesToRender()
    Adds attributes related to CSS styles to renderer.
  • TPanelStyle::copyFrom()
    Copies the fields in a new style to this style.
  • TPanelStyle::getBackImageUrl()
  • TPanelStyle::getDirection()
  • TPanelStyle::getHorizontalAlign()
  • TPanelStyle::getScrollBars()
  • TPanelStyle::getWrap()
  • TPanelStyle::mergeWith()
    Merges the style with a new one.
  • TPanelStyle::reset()
    Sets the style attributes to default values.
  • TPanelStyle::setBackImageUrl()
    Sets the URL of the background image for the panel component.
  • TPanelStyle::setDirection()
  • TPanelStyle::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the panel.
  • TPanelStyle::setScrollBars()
  • TPanelStyle::setWrap()
    Sets the value indicating whether the content wraps within the panel.

Inherited From Class TStyle

  • TStyle::__construct()
    Constructor.
  • TStyle::addAttributesToRender()
    Adds attributes related to CSS styles to renderer.
  • TStyle::clearStyleField()
    Clears a single style field value;
  • TStyle::copyFrom()
    Copies the fields in a new style to this style.
  • TStyle::getBackColor()
  • TStyle::getBorderColor()
  • TStyle::getBorderStyle()
  • TStyle::getBorderWidth()
  • TStyle::getCssClass()
  • TStyle::getCustomStyle()
  • TStyle::getDisplayStyle()
  • TStyle::getFont()
  • TStyle::getForeColor()
  • TStyle::getHeight()
  • TStyle::getStyleField()
  • TStyle::getStyleFields()
  • TStyle::getWidth()
  • TStyle::hasCssClass()
  • TStyle::hasFont()
  • TStyle::hasStyleField()
  • TStyle::mergeWith()
    Merges the style with a new one.
  • TStyle::reset()
    Resets the style to the original empty state.
  • TStyle::setBackColor()
  • TStyle::setBorderColor()
  • TStyle::setBorderStyle()
    Sets the border style of the control.
  • TStyle::setBorderWidth()
  • TStyle::setCssClass()
  • TStyle::setCustomStyle()
    Sets custom style fields from a string.
  • TStyle::setDisplayStyle()
  • TStyle::setForeColor()
  • TStyle::setHeight()
  • TStyle::setStyleField()
    Sets a single style field value.
  • TStyle::setWidth()
  • TStyle::__clone()
    Need to clone the font object.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGridPagerStyle::copyFrom

    copyFrom( TStyle $style );

    Overrides TPanelStyle::copyFrom() (Copies the fields in a new style to this style.)

    Parameters

    $style

    the new style

    Remarks

    Copies the fields in a new style to this style.

    If a style field is set in the new style, the corresponding field in this style will be overwritten.

    access

    public

    [ Top ]

    TDataGridPagerStyle::getButtonType

    getButtonType( );

    Returns

    the type of command button. Defaults to TDataGridPagerButtonType::LinkButton.

    access

    public

    [ Top ]

    TDataGridPagerStyle::getFirstPageText

    getFirstPageText( );

    Returns

    text for the first page button. Defaults to '<<'.

    access

    public

    [ Top ]

    TDataGridPagerStyle::getLastPageText

    getLastPageText( );

    Returns

    text for the last page button. Defaults to '>>'.

    access

    public

    [ Top ]

    TDataGridPagerStyle::getMode

    getMode( );

    Returns

    pager mode. Defaults to TDataGridPagerMode::NextPrev.

    access

    public

    [ Top ]

    TDataGridPagerStyle::getNextPageText

    getNextPageText( );

    Returns

    text for the next page button. Defaults to '>'.

    access

    public

    [ Top ]

    TDataGridPagerStyle::getPageButtonCount

    getPageButtonCount( );

    Returns

    maximum number of pager buttons to be displayed. Defaults to 10.

    access

    public

    [ Top ]

    TDataGridPagerStyle::getPosition

    getPosition( );

    Returns

    where the pager is to be displayed. Defaults to TDataGridPagerPosition::Bottom.

    access

    public

    [ Top ]

    TDataGridPagerStyle::getPrevPageText

    getPrevPageText( );

    Returns

    text for the previous page button. Defaults to '<'.

    access

    public

    [ Top ]

    TDataGridPagerStyle::getVisible

    getVisible( );

    Returns

    whether the pager is visible. Defaults to true.

    access

    public

    [ Top ]

    TDataGridPagerStyle::mergeWith

    mergeWith( TStyle $style );

    Overrides TPanelStyle::mergeWith() (Merges the style with a new one.)

    Parameters

    $style

    the new style

    Remarks

    Merges the style with a new one.

    If a style field is not set in this style, it will be overwritten by the new one.

    access

    public

    [ Top ]

    TDataGridPagerStyle::reset

    reset( );

    Overrides TPanelStyle::reset() (Sets the style attributes to default values.)

    Remarks

    Resets the style to the original empty state.

    access

    public

    [ Top ]

    TDataGridPagerStyle::setButtonType

    setButtonType( TDataGridPagerButtonType $value );

    Parameters

    $value

    the type of command button

    access

    public

    [ Top ]

    TDataGridPagerStyle::setFirstPageText

    setFirstPageText( string $value );

    Parameters

    $value

    text for the first page button.

    access

    public

    [ Top ]

    TDataGridPagerStyle::setLastPageText

    setLastPageText( string $value );

    Parameters

    $value

    text for the last page button.

    access

    public

    [ Top ]

    TDataGridPagerStyle::setMode

    setMode( TDataGridPagerMode $value );

    Parameters

    $value

    pager mode.

    access

    public

    [ Top ]

    TDataGridPagerStyle::setNextPageText

    setNextPageText( string $value );

    Parameters

    $value

    text for the next page button.

    access

    public

    [ Top ]

    TDataGridPagerStyle::setPageButtonCount

    setPageButtonCount( integer $value );

    Parameters

    $value

    maximum number of pager buttons to be displayed

    throws

    TInvalidDataValueException if the value is less than 1.

    access

    public

    [ Top ]

    TDataGridPagerStyle::setPosition

    setPosition( TDataGridPagerPosition $value );

    Parameters

    $value

    where the pager is to be displayed.

    access

    public

    [ Top ]

    TDataGridPagerStyle::setPrevPageText

    setPrevPageText( string $value );

    Parameters

    $value

    text for the previous page button.

    access

    public

    [ Top ]

    TDataGridPagerStyle::setVisible

    setVisible( boolean $value );

    Parameters

    $value

    whether the pager is visible.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:02 +0200 by phpDocumentor 1.4.3


Docs For Class TDataList

Class TDataList

[line 153]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TBaseDataList
                  |
                  --TDataList
Classes extended from TDataList:
TActiveDataList
TActiveDataList class

Location: /Web/UI/WebControls/TDataList.php

Remarks

TDataList class

TDataList represents a data bound and updatable list control.

Like TRepeater, TDataList displays its content repeatedly based on the data fetched from DataSource. The repeated contents in TDataList are called items, which are controls and can be accessed through Items. When dataBind() is invoked, TDataList creates an item for each row of data and binds the data row to the item. Optionally, a TDataList can have a header, a footer and/or separators between items.

TDataList differs from TRepeater in that it supports tiling the items in different manners and it maintains status of items to handle data update.

The layout of the repeated contents are specified by inline templates. TDataList items, header, footer, etc. are being instantiated with the corresponding templates when data is being bound to the repeater.

Since v3.1.0, the layout can also be by renderers. A renderer is a control class that can be instantiated as datalist items, header, etc. A renderer can thus be viewed as an external template (in fact, it can also be non-templated controls).

A renderer can be any control class.

  • If the class implements IDataRenderer, the Data
property will be set as the data row during databinding. Many PRADO controls implement this interface, such as TLabel, TTextBox, etc.
  • If the class implements IItemDataRenderer, the ItemIndex property will be set
as the zero-based index of the item in the datalist item collection, and the ItemType property as the item's type (such as TListItemType::Item). TDataListItemRenderer may be used as the convenient base class which already implements IDataItemRenderer.

The following properties are used to specify different types of template and renderer for a datalist:

  • ItemTemplate, ItemRenderer:
for each repeated row of data
  • AlternatingItemTemplate, AlternatingItemRenderer:
for each alternating row of data. If not set, ItemTemplate or ItemRenderer will be used instead.
  • HeaderTemplate, HeaderRenderer:
for the datalist header.
  • FooterTemplate, FooterRenderer:
for the datalist footer.
  • SeparatorTemplate, SeparatorRenderer:
for content to be displayed between items.
  • EmptyTemplate, EmptyRenderer:
used when data bound to the datalist is empty.
  • EditItemTemplate, EditItemRenderer:
for the row being editted.
  • SelectedItemTemplate, SelectedItemRenderer:
for the row being selected.

If a content type is defined with both a template and a renderer, the latter takes precedence.

When dataBind() is being called, TDataList undergoes the following lifecycles for each row of data:

  • create item based on templates or renderers
  • set the row of data to the item
  • raise OnItemCreated:
  • add the item as a child control
  • call dataBind() of the item
  • raise OnItemDataBound:
TDataList raises an OnItemCommand whenever a button control within some datalist item raises a OnCommand event. Therefore, you can handle all sorts of OnCommand event in a central place by writing an event handler for OnItemCommand.

An additional event is raised if the OnCommand event has one of the following command names:

  • edit: user wants to edit an item. OnEditCommand event will be raised.
  • update: user wants to save the change to an item. OnUpdateCommand event will be raised.
  • select: user selects an item. OnSelectedIndexChanged event will be raised.
  • delete: user deletes an item. OnDeleteCommand event will be raised.
  • cancel: user cancels previously editting action. OnCancelCommand event will be raised.
TDataList provides a few properties to support tiling the items. The number of columns used to display the data items is specified via RepeatColumns property, while the RepeatDirection governs the order of the items being rendered. The layout of the data items in the list is specified via RepeatLayout, which can take one of the following values:
  • Table (default): items are organized using HTML table and cells.
When using this layout, one can set CellPadding and CellSpacing to adjust the cellpadding and cellpadding of the table, and Caption and CaptionAlign to add a table caption with the specified alignment.
  • Flow: items are organized using HTML spans and breaks.
  • Raw: TDataList does not generate any HTML tags to do the tiling.
Items in TDataList can be in one of the three status: normal browsing, being editted and being selected. To change the status of a particular item, set SelectedItemIndex or EditItemIndex. The former will change the indicated item to selected mode, which will cause the item to use SelectedItemTemplate or SelectedItemRenderer for presentation. The latter will change the indicated item to edit mode and to use corresponding template or renderer. Note, if an item is in edit mode, then selecting this item will have no effect.

Different styles may be applied to items in different status. The style application is performed in a hierarchical way: Style in higher hierarchy will inherit from styles in lower hierarchy. Starting from the lowest hierarchy, the item styles include

  • item's own style
  • ItemStyle
  • AlternatingItemStyle
  • SelectedItemStyle
  • EditItemStyle.
Therefore, if background color is set as red in ItemStyle, EditItemStyle will also have red background color unless it is set to a different value explicitly.

When a page containing a datalist is post back, the datalist will restore automatically all its contents, including items, header, footer and separators. However, the data row associated with each item will not be recovered and become null. To access the data, use one of the following ways:

  • Use DataKeys to obtain the data key associated with
the specified datalist item and use the key to fetch the corresponding data from some persistent storage such as DB.
  • Save the whole dataset in viewstate, which will restore the dataset automatically upon postback.
Be aware though, if the size of your dataset is big, your page size will become big. Some complex data may also have serializing problem if saved in viewstate.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • CMD_CANCEL = 'Cancel'
  • CMD_DELETE = 'Delete'
  • CMD_EDIT = 'Edit'
  • CMD_SELECT = 'Select'
    Command name that TDataList understands. They are case-insensitive.
  • CMD_UPDATE = 'Update'

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TBaseDataList

  • TBaseDataList::createStyle()
    Creates a style object for the control.
  • TBaseDataList::getCellPadding()
  • TBaseDataList::getCellSpacing()
  • TBaseDataList::getDataFieldValue()
    Returns the value of the data at the specified field.
  • TBaseDataList::getDataKeyField()
  • TBaseDataList::getDataKeys()
  • TBaseDataList::getGridLines()
  • TBaseDataList::getHorizontalAlign()
  • TBaseDataList::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event.
  • TBaseDataList::setCellPadding()
  • TBaseDataList::setCellSpacing()
  • TBaseDataList::setDataKeyField()
  • TBaseDataList::setGridLines()
    Sets the grid line style of the table layout.
  • TBaseDataList::setHorizontalAlign()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataList::applyItemStyles

    applyItemStyles( );

    Remarks

    Applies styles to items, header, footer and separators.

    Item styles are applied in a hierarchical way. Style in higher hierarchy will inherit from styles in lower hierarchy. Starting from the lowest hierarchy, the item styles include item's own style, ItemStyle, AlternatingItemStyle, SelectedItemStyle, and EditItemStyle. Therefore, if background color is set as red in ItemStyle, EditItemStyle will also have red background color unless it is set to a different value explicitly.

    access

    protected

    [ Top ]

    TDataList::bubbleEvent

    bubbleEvent( TControl $sender, TEventParameter $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    the sender of the event

    $param

    event parameter

    Returns

    whether the event bubbling should stop here.

    Remarks

    This method overrides parent's implementation to handle onItemCommand event which is bubbled from datalist items and their child controls.

    If the event parameter is TDataListCommandEventParameter and the command name is a recognized one, which includes 'select', 'edit', 'delete', 'update', and 'cancel' (case-insensitive), then a corresponding command event is also raised (such as OnEditCommand). This method should only be used by control developers.

    access

    public

    [ Top ]

    TDataList::createEmptyContent

    createEmptyContent( );

    Remarks

    Creates empty datalist content.

    access

    protected

    [ Top ]

    TDataList::createItem

    createItem( integer $itemIndex, TListItemType $itemType );

    Parameters

    $itemIndex

    zero-based item index

    $itemType

    item type

    Returns

    created datalist item

    Remarks

    Creates a datalist item instance based on the item type and index.

    access

    protected

    [ Top ]

    TDataList::generateItemStyle

    generateItemStyle( string $itemType, integer $index );

    Implementation of:
    IRepeatInfoUser::generateItemStyle()

    Parameters

    $itemType

    item type (Header,Footer,Item,AlternatingItem,SelectedItem,EditItem,Separator,Pager)

    $index

    index of the item being rendered

    Returns

    item style

    Remarks

    Returns a style used for rendering items.

    This method is required by IRepeatInfoUser interface.

    access

    public

    [ Top ]

    TDataList::getAlternatingItemRenderer

    getAlternatingItemRenderer( );

    Returns

    the class name for alternative datalist items. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::getAlternatingItemStyle

    getAlternatingItemStyle( );

    Returns

    the style for each alternating item

    access

    public

    [ Top ]

    TDataList::getAlternatingItemTemplate

    getAlternatingItemTemplate( );

    Returns

    the template for each alternating item

    access

    public

    [ Top ]

    TDataList::getCaption

    getCaption( );

    Returns

    caption of the table layout

    access

    public

    [ Top ]

    TDataList::getCaptionAlign

    getCaptionAlign( );

    Returns

    alignment of the caption of the table layout. Defaults to TTableCaptionAlign::NotSet.

    access

    public

    [ Top ]

    TDataList::getEditItem

    getEditItem( );

    Returns

    the edit item

    access

    public

    [ Top ]

    TDataList::getEditItemIndex

    getEditItemIndex( );

    Returns

    the zero-based index of the edit item in Items. A value -1 means no item is in edit mode.

    access

    public

    [ Top ]

    TDataList::getEditItemRenderer

    getEditItemRenderer( );

    Returns

    the class name for the datalist item being editted. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::getEditItemStyle

    getEditItemStyle( );

    Returns

    the style for edit item

    access

    public

    [ Top ]

    TDataList::getEditItemTemplate

    getEditItemTemplate( );

    Returns

    the edit item template

    access

    public

    [ Top ]

    TDataList::getEmptyRenderer

    getEmptyRenderer( );

    Returns

    the class name for empty datalist item. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::getEmptyTemplate

    getEmptyTemplate( );

    Returns

    the template applied when no data is bound to the datalist

    access

    public

    [ Top ]

    TDataList::getFooter

    getFooter( );

    Returns

    the footer item

    access

    public

    [ Top ]

    TDataList::getFooterRenderer

    getFooterRenderer( );

    Returns

    the class name for datalist footer item. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::getFooterStyle

    getFooterStyle( );

    Returns

    the style for footer

    access

    public

    [ Top ]

    TDataList::getFooterTemplate

    getFooterTemplate( );

    Returns

    the footer template

    access

    public

    [ Top ]

    TDataList::getHasFooter

    getHasFooter( );

    Implementation of:
    IRepeatInfoUser::getHasFooter()

    Returns

    whether the datalist has footer

    Remarks

    Returns a value indicating whether this control contains footer item.

    This method is required by IRepeatInfoUser interface.

    access

    public

    [ Top ]

    TDataList::getHasHeader

    getHasHeader( );

    Implementation of:
    IRepeatInfoUser::getHasHeader()

    Returns

    whether the datalist has header

    Remarks

    Returns a value indicating whether this control contains header item.

    This method is required by IRepeatInfoUser interface.

    access

    public

    [ Top ]

    TDataList::getHasSeparators

    getHasSeparators( );

    Implementation of:
    IRepeatInfoUser::getHasSeparators()

    Returns

    always false.

    Remarks

    Returns a value indicating whether this control contains separator items.

    This method is required by IRepeatInfoUser interface.

    access

    public

    [ Top ]

    TDataList::getHeader

    getHeader( );

    Returns

    the header item

    access

    public

    [ Top ]

    TDataList::getHeaderRenderer

    getHeaderRenderer( );

    Returns

    the class name for datalist header item. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::getHeaderStyle

    getHeaderStyle( );

    Returns

    the style for header

    access

    public

    [ Top ]

    TDataList::getHeaderTemplate

    getHeaderTemplate( );

    Returns

    the header template

    access

    public

    [ Top ]

    TDataList::getItemCount

    getItemCount( );

    Implementation of:
    IRepeatInfoUser::getItemCount()

    Returns

    number of items

    access

    public

    [ Top ]

    TDataList::getItemRenderer

    getItemRenderer( );

    Returns

    the class name for datalist items. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::getItems

    getItems( );

    Returns

    item list

    access

    public

    [ Top ]

    TDataList::getItemStyle

    getItemStyle( );

    Returns

    the style for item

    access

    public

    [ Top ]

    TDataList::getItemTemplate

    getItemTemplate( );

    Returns

    the template for item

    access

    public

    [ Top ]

    TDataList::getRepeatColumns

    getRepeatColumns( );

    Returns

    the number of columns that the list should be displayed with. Defaults to 0 meaning not set.

    access

    public

    [ Top ]

    TDataList::getRepeatDirection

    getRepeatDirection( );

    Returns

    the direction of traversing the list, defaults to TRepeatDirection::Vertical

    access

    public

    [ Top ]

    TDataList::getRepeatInfo

    getRepeatInfo( );

    Returns

    repeat information (primarily used by control developers)

    access

    protected

    [ Top ]

    TDataList::getRepeatLayout

    getRepeatLayout( );

    Returns

    how the list should be displayed, using table or using line breaks. Defaults to TRepeatLayout::Table.

    access

    public

    [ Top ]

    TDataList::getSelectedDataKey

    getSelectedDataKey( );

    Returns

    the key value of the currently selected item

    throws

    TInvalidOperationException if DataKeyField is empty.

    access

    public

    [ Top ]

    TDataList::getSelectedItem

    getSelectedItem( );

    Returns

    the selected item, null if no item is selected.

    access

    public

    [ Top ]

    TDataList::getSelectedItemIndex

    getSelectedItemIndex( );

    Returns

    the zero-based index of the selected item in Items. A value -1 means no item selected.

    access

    public

    [ Top ]

    TDataList::getSelectedItemRenderer

    getSelectedItemRenderer( );

    Returns

    the class name for the datalist item being selected. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::getSelectedItemStyle

    getSelectedItemStyle( );

    Returns

    the style for selected item

    access

    public

    [ Top ]

    TDataList::getSelectedItemTemplate

    getSelectedItemTemplate( );

    Returns

    the selected item template

    access

    public

    [ Top ]

    TDataList::getSeparatorRenderer

    getSeparatorRenderer( );

    Returns

    the class name for datalist item separators. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::getSeparatorStyle

    getSeparatorStyle( );

    Returns

    the style for separator

    access

    public

    [ Top ]

    TDataList::getSeparatorTemplate

    getSeparatorTemplate( );

    Returns

    the separator template

    access

    public

    [ Top ]

    TDataList::getShowFooter

    getShowFooter( );

    Returns

    whether the footer should be shown. Defaults to true.

    access

    public

    [ Top ]

    TDataList::getShowHeader

    getShowHeader( );

    Returns

    whether the header should be shown. Defaults to true.

    access

    public

    [ Top ]

    TDataList::loadState

    loadState( );

    Overrides TControl::loadState() (This method is invoked right after the control has loaded its state.)

    Remarks

    Loads item count information from viewstate.

    This method is invoked right after control state is loaded.

    access

    public

    [ Top ]

    TDataList::onCancelCommand

    onCancelCommand( TDataListCommandEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnCancelCommand event.

    This method is invoked when a child control of the data list raises an OnCommand event and the command name is 'cancel' (case-insensitive).

    access

    public

    [ Top ]

    TDataList::onDeleteCommand

    onDeleteCommand( TDataListCommandEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnDeleteCommand event.

    This method is invoked when a child control of the data list raises an OnCommand event and the command name is 'delete' (case-insensitive).

    access

    public

    [ Top ]

    TDataList::onEditCommand

    onEditCommand( TDataListCommandEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnEditCommand event.

    This method is invoked when a child control of the data list raises an OnCommand event and the command name is 'edit' (case-insensitive).

    access

    public

    [ Top ]

    TDataList::onItemCommand

    onItemCommand( TDataListCommandEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnItemCommand event.

    This method is invoked when a child control of the data list raises an OnCommand event.

    access

    public

    [ Top ]

    TDataList::onItemCreated

    onItemCreated( TDataListItemEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnItemCreated event.

    This method is invoked after a data list item is created and instantiated with template, but before added to the page hierarchy. The datalist item control responsible for the event can be determined from the event parameter. If you override this method, be sure to call parent's implementation so that event handlers have chance to respond to the event.

    access

    public

    [ Top ]

    TDataList::onItemDataBound

    onItemDataBound( TDataListItemEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnItemDataBound event.

    This method is invoked right after an item is data bound. The datalist item control responsible for the event can be determined from the event parameter. If you override this method, be sure to call parent's implementation so that event handlers have chance to respond to the event.

    access

    public

    [ Top ]

    TDataList::onUpdateCommand

    onUpdateCommand( TDataListCommandEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnUpdateCommand event.

    This method is invoked when a child control of the data list raises an OnCommand event and the command name is 'update' (case-insensitive).

    access

    public

    [ Top ]

    TDataList::performDataBinding

    performDataBinding( Traversable $data );

    Overrides TDataBoundControl::performDataBinding() (parent method not documented)

    Parameters

    $data

    the data

    Remarks

    Performs databinding to populate data list items from data source.

    This method is invoked by dataBind(). You may override this function to provide your own way of data population.

    access

    protected

    [ Top ]

    TDataList::render

    render( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveDataList::render()
    Renders the repeater.

    Overrides TWebControl::render() (Renders the control.)

    Parameters

    $writer

    writer for rendering purpose.

    Remarks

    Renders the data list control.

    This method overrides the parent implementation.

    access

    public

    [ Top ]

    TDataList::renderItem

    renderItem( THtmlWriter $writer, TRepeatInfo $repeatInfo, string $itemType, integer $index );

    Implementation of:
    IRepeatInfoUser::renderItem()
    Renders an item.

    Parameters

    $writer

    writer for rendering purpose

    $repeatInfo

    repeat information

    $itemType

    item type (Header,Footer,Item,AlternatingItem,SelectedItem,EditItem,Separator,Pager)

    $index

    zero-based index of the item in the item list

    Remarks

    Renders an item in the list.

    This method is required by IRepeatInfoUser interface.

    access

    public

    [ Top ]

    TDataList::reset

    reset( );

    Remarks

    Clears up all items in the data list.

    access

    public

    [ Top ]

    TDataList::restoreItemsFromViewState

    restoreItemsFromViewState( );

    Remarks

    Creates data list items based on viewstate information.

    access

    protected

    [ Top ]

    TDataList::saveState

    saveState( );

    Overrides TControl::saveState() (This method is invoked when control state is to be saved.)

    Remarks

    Saves item count in viewstate.

    This method is invoked right before control state is to be saved.

    access

    public

    [ Top ]

    TDataList::setAlternatingItemRenderer

    setAlternatingItemRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the alternative item renderer class.

    If not empty, the class will be used to instantiate as alternative datalist items. This property takes precedence over AlternatingItemTemplate.

    see

    TDataList::setAlternatingItemTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::setAlternatingItemTemplate

    setAlternatingItemTemplate( ITemplate $value );

    Parameters

    $value

    the template for each alternating item

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TDataList::setCaption

    setCaption( string $value );

    Parameters

    $value

    caption of the table layout

    access

    public

    [ Top ]

    TDataList::setCaptionAlign

    setCaptionAlign( $value );

    Parameters

    $value

    Returns

    alignment of the caption of the table layout.

    access

    public

    [ Top ]

    TDataList::setEditItemIndex

    setEditItemIndex( integer $value );

    Parameters

    $value

    the edit item index

    Remarks

    Edits an item by its index in getItems.

    Previously editting item will change to normal item state. If the index is less than 0, any existing edit item will be cleared up.

    access

    public

    [ Top ]

    TDataList::setEditItemRenderer

    setEditItemRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the renderer class for the datalist item being editted.

    If not empty, the class will be used to instantiate as the datalist item. This property takes precedence over EditItemTemplate.

    see

    TDataList::setEditItemTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::setEditItemTemplate

    setEditItemTemplate( ITemplate $value );

    Parameters

    $value

    the edit item template

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TDataList::setEmptyRenderer

    setEmptyRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the datalist empty renderer class.

    The empty renderer is created as the child of the datalist if data bound to the datalist is empty. This property takes precedence over EmptyTemplate.

    see

    TDataList::setEmptyTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::setEmptyTemplate

    setEmptyTemplate( ITemplate $value );

    Parameters

    $value

    the template applied when no data is bound to the datalist

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TDataList::setFooterRenderer

    setFooterRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the datalist footer renderer class.

    If not empty, the class will be used to instantiate as datalist footer item. This property takes precedence over FooterTemplate.

    see

    TDataList::setFooterTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::setFooterTemplate

    setFooterTemplate( ITemplate $value );

    Parameters

    $value

    the footer template

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TDataList::setHeaderRenderer

    setHeaderRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the datalist header renderer class.

    If not empty, the class will be used to instantiate as datalist header item. This property takes precedence over HeaderTemplate.

    see

    TDataList::setHeaderTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::setHeaderTemplate

    setHeaderTemplate( ITemplate $value );

    Parameters

    $value

    the header template

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TDataList::setItemRenderer

    setItemRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the item renderer class.

    If not empty, the class will be used to instantiate as datalist items. This property takes precedence over ItemTemplate.

    see

    TDataList::setItemTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::setItemTemplate

    setItemTemplate( ITemplate $value );

    Parameters

    $value

    the template for item

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TDataList::setRepeatColumns

    setRepeatColumns( integer $value );

    Parameters

    $value

    the number of columns that the list should be displayed with.

    access

    public

    [ Top ]

    TDataList::setRepeatDirection

    setRepeatDirection( TRepeatDirection $value );

    Parameters

    $value

    the direction of traversing the list

    access

    public

    [ Top ]

    TDataList::setRepeatLayout

    setRepeatLayout( TRepeatLayout $value );

    Parameters

    $value

    how the list should be displayed, using table or using line breaks

    access

    public

    [ Top ]

    TDataList::setSelectedItemIndex

    setSelectedItemIndex( integer $value );

    Parameters

    $value

    the selected item index

    Remarks

    Selects an item by its index in getItems.

    Previously selected item will be un-selected. If the item to be selected is already in edit mode, it will remain in edit mode. If the index is less than 0, any existing selection will be cleared up.

    access

    public

    [ Top ]

    TDataList::setSelectedItemRenderer

    setSelectedItemRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the renderer class for the datalist item being selected.

    If not empty, the class will be used to instantiate as the datalist item. This property takes precedence over SelectedItemTemplate.

    see

    TDataList::setSelectedItemTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::setSelectedItemTemplate

    setSelectedItemTemplate( ITemplate $value );

    Parameters

    $value

    the selected item template

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TDataList::setSeparatorRenderer

    setSeparatorRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the datalist item separator renderer class.

    If not empty, the class will be used to instantiate as datalist item separators. This property takes precedence over SeparatorTemplate.

    see

    TDataList::setSeparatorTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TDataList::setSeparatorTemplate

    setSeparatorTemplate( ITemplate $value );

    Parameters

    $value

    the separator template

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TDataList::setShowFooter

    setShowFooter( boolean $value );

    Parameters

    $value

    whether to show footer

    access

    public

    [ Top ]

    TDataList::setShowHeader

    setShowHeader( boolean $value );

    Parameters

    $value

    whether to show header

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • CMD_CANCEL = 'Cancel' [line 162]

  • CMD_DELETE = 'Delete' [line 161]

  • CMD_EDIT = 'Edit' [line 159]

  • CMD_SELECT = 'Select' [line 158]

    • Remarks

    Command name that TDataList understands. They are case-insensitive.

  • CMD_UPDATE = 'Update' [line 160]

Documentation generated on Mon, 25 Jun 2012 14:44:02 +0200 by phpDocumentor 1.4.3


Docs For Class TDataListCommandEventParameter

Class TDataListCommandEventParameter

[line 1547]
TComponent
   |
   --TEventParameter
      |
      --TCommandEventParameter
         |
         --TDataListCommandEventParameter
Location: /Web/UI/WebControls/TDataList.php

Remarks

TDataListCommandEventParameter class

TDataListCommandEventParameter encapsulates the parameter data for TDataList::onItemCommand event of TDataList controls.

The Item property indicates the DataList item related with the event. The CommandSource refers to the control that originally raises the Command event.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TCommandEventParameter

  • TCommandEventParameter::__construct()
    Constructor.
  • TCommandEventParameter::getCommandName()
  • TCommandEventParameter::getCommandParameter()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataListCommandEventParameter::__construct

    __construct( TControl $item, TControl $source, $param );

    Overrides TCommandEventParameter::__construct() (Constructor.)

    Parameters

    $item

    datalist item responsible for the event

    $source

    original event sender

    $param

    original event parameter

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDataListCommandEventParameter::getCommandSource

    getCommandSource( );

    Returns

    the control originally raises the OnCommand event.

    access

    public

    [ Top ]

    TDataListCommandEventParameter::getItem

    getItem( );

    Returns

    the datalist item control responsible for the event.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:03 +0200 by phpDocumentor 1.4.3


Docs For Class TDataListItem

Class TDataListItem

[line 1602]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataListItem
Location: /Web/UI/WebControls/TDataList.php

Remarks

TDataListItem class

A TDataListItem control represents an item in the TDataList control, such as heading section, footer section, or a data item. The index and data value of the item can be accessed via ItemIndex> and DataItem properties, respectively. The type of the item is given by ItemType property.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataListItem::bubbleEvent

    bubbleEvent( TControl $sender, TEventParameter $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    the sender of the event

    $param

    event parameter

    Returns

    whether the event bubbling should stop here.

    Remarks

    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

    access

    public

    [ Top ]

    TDataListItem::createStyle

    createStyle( );

    Overrides TWebControl::createStyle() (Creates a style object to be used by the control.)

    Returns

    control style to be used

    Remarks

    Creates a style object for the control.

    This method creates a TTableItemStyle to be used by a datalist item.

    access

    protected

    [ Top ]

    TDataListItem::getData

    getData( );

    Implementation of:
    IDataRenderer::getData()

    Returns

    data associated with the item

    since

    3.1.0

    access

    public

    [ Top ]

    TDataListItem::getDataItem

    getDataItem( );

    Returns

    data associated with the item

    Remarks

    This property is deprecated since v3.1.0.

    deprecated

    deprecated since v3.1.0. Use getData instead.

    access

    public

    [ Top ]

    TDataListItem::getItemIndex

    getItemIndex( );

    Implementation of:
    IItemDataRenderer::getItemIndex()
    Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.

    Returns

    zero-based index of the item in the item collection of datalist

    access

    public

    [ Top ]

    TDataListItem::getItemType

    getItemType( );

    Implementation of:
    IItemDataRenderer::getItemType()

    Returns

    item type

    access

    public

    [ Top ]

    TDataListItem::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name of the control to be rendered

    Remarks

    Returns the tag name used for this control.

    access

    protected

    [ Top ]

    TDataListItem::setData

    setData( mixed $value );

    Implementation of:
    IDataRenderer::setData()

    Parameters

    $value

    data to be associated with the item

    since

    3.1.0

    access

    public

    [ Top ]

    TDataListItem::setDataItem

    setDataItem( mixed $value );

    Parameters

    $value

    data to be associated with the item

    Remarks

    This property is deprecated since v3.1.0.

    deprecated

    deprecated since version 3.1.0. Use setData instead.

    access

    public

    [ Top ]

    TDataListItem::setItemIndex

    setItemIndex( integer $value );

    Implementation of:
    IItemDataRenderer::setItemIndex()
    Sets the zero-based index for the item.

    Parameters

    $value

    zero-based index of the item.

    Remarks

    Sets the zero-based index for the item.

    If the item is not in the item collection (e.g. it is a header item), -1 should be used.

    access

    public

    [ Top ]

    TDataListItem::setItemType

    setItemType( TListItemType $value );

    Implementation of:
    IItemDataRenderer::setItemType()

    Parameters

    $value

    item type.

    access

    public

    [ Top ]

    TDataListItem::setTagName

    setTagName( string $value );

    Parameters

    $value

    tag name of the control to be rendered

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:03 +0200 by phpDocumentor 1.4.3


Docs For Class TDataListItemCollection

Class TDataListItemCollection

[line 1749]
TComponent
   |
   --TList
      |
      --TDataListItemCollection
Location: /Web/UI/WebControls/TDataList.php

Remarks

TDataListItemCollection class.

TDataListItemCollection represents a collection of data list items.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataListItemCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TList::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by inserting only TControl descendants.

    throws

    TInvalidDataTypeException if the item to be inserted is not a TControl descendant.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:04 +0200 by phpDocumentor 1.4.3


Docs For Class TDataListItemEventParameter

Class TDataListItemEventParameter

[line 1506]
TComponent
   |
   --TEventParameter
      |
      --TDataListItemEventParameter
Location: /Web/UI/WebControls/TDataList.php

Remarks

TDataListItemEventParameter class

TDataListItemEventParameter encapsulates the parameter data for TDataList::onItemCreated event of TDataList controls. The Item property indicates the DataList item related with the event.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataListItemEventParameter::__construct

    __construct( TControl $item );

    Parameters

    $item

    DataList item related with the corresponding event

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDataListItemEventParameter::getItem

    getItem( );

    Returns

    datalist item related with the corresponding event

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:04 +0200 by phpDocumentor 1.4.3


Docs For Class TDataListItemRenderer

Class TDataListItemRenderer

[line 33]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TDataRenderer
                  |
                  --TItemDataRenderer
                     |
                     --TDataListItemRenderer
Location: /Web/UI/WebControls/TDataListItemRenderer.php

Remarks

TDataListItemRenderer class

TDataListItemRenderer can be used as a convenient base class to define an item renderer class specific for TDataList.

TDataListItemRenderer extends TItemDataRenderer and implements the bubbling scheme for the OnCommand event of data list items.

TDataListItemRenderer also implements the IStyleable interface, which allows TDataList to apply CSS styles to the renders.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataListItemRenderer.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTemplateControl

  • TTemplateControl::EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TItemDataRenderer

  • TItemDataRenderer::getItemIndex()
    Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
  • TItemDataRenderer::getItemType()
  • TItemDataRenderer::setItemIndex()
    Sets the zero-based index for the item.
  • TItemDataRenderer::setItemType()

Inherited From Class TDataRenderer

  • TDataRenderer::getData()
  • TDataRenderer::setData()

Inherited From Class TTemplateControl

  • TTemplateControl::createChildControls()
    Creates child controls.
  • TTemplateControl::getIsSourceTemplateControl()
  • TTemplateControl::getMaster()
  • TTemplateControl::getMasterClass()
  • TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
  • TTemplateControl::getTemplateDirectory()
  • TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
  • TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
  • TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
  • TTemplateControl::registerContent()
    Registers a content control.
  • TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
  • TTemplateControl::setMasterClass()
  • TTemplateControl::setTemplate()
    Sets the parsed template.

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataListItemRenderer::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attribute name-value pairs to renderer.

    By default, this method renders the style string. The method can be overriden to provide customized attribute rendering.

    access

    protected

    [ Top ]

    TDataListItemRenderer::bubbleEvent

    bubbleEvent( TControl $sender, TEventParameter $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    the sender of the event

    $param

    event parameter

    Returns

    whether the event bubbling should stop here.

    Remarks

    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

    access

    public

    [ Top ]

    TDataListItemRenderer::clearStyle

    clearStyle( );

    Remarks

    Removes all style data.

    access

    public

    [ Top ]

    TDataListItemRenderer::createStyle

    createStyle( );

    Remarks

    Creates a style object to be used by the control.

    This method may be overriden by controls to provide customized style.

    access

    protected

    [ Top ]

    TDataListItemRenderer::getHasStyle

    getHasStyle( );

    Returns

    whether the control has defined any style information

    access

    public

    [ Top ]

    TDataListItemRenderer::getStyle

    getStyle( );

    Returns

    the object representing the css style of the control

    access

    public

    [ Top ]

    TDataListItemRenderer::getTagName

    getTagName( );

    Returns

    tag name of the control to be rendered

    Remarks

    Returns the tag name used for this control.

    By default, the tag name is 'span'. You can override this method to provide customized tag names. If the tag name is empty, the opening and closing tag will NOT be rendered.

    access

    protected

    [ Top ]

    TDataListItemRenderer::render

    render( THtmlWriter $writer );

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the control.

    This method overrides the parent implementation by replacing it with the following sequence:

    • renderBeginTag
    • renderContents
    • renderEndTag
    If the TagName is empty, only renderContents is invoked.

    access

    public

    [ Top ]

    TDataListItemRenderer::renderBeginTag

    renderBeginTag( THtmlWriter $writer );

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the openning tag for the control (including attributes) This method is invoked when getTagName is not empty.

    access

    public

    [ Top ]

    TDataListItemRenderer::renderContents

    renderContents( THtmlWriter $writer );

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the body content enclosed between the control tag.

    By default, child controls and text strings will be rendered. You can override this method to provide customized content rendering.

    access

    public

    [ Top ]

    TDataListItemRenderer::renderEndTag

    renderEndTag( THtmlWriter $writer );

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the closing tag for the control This method is invoked when getTagName is not empty.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:04 +0200 by phpDocumentor 1.4.3


Docs For Class TDataRenderer

Class TDataRenderer

[line 29]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TDataRenderer
Classes extended from TDataRenderer:
TItemDataRenderer
TItemDataRenderer class

Location: /Web/UI/WebControls/TDataRenderer.php

Remarks

TDataRenderer class

TDataRenderer is the convenient base class for template-based renderer controls. It extends TTemplateControl and implements the methods required by the IDataRenderer interface.

The following property is provided by TDataRenderer:

  • Data: data associated with this renderer.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataRenderer.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.1.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTemplateControl

  • TTemplateControl::EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TTemplateControl

  • TTemplateControl::createChildControls()
    Creates child controls.
  • TTemplateControl::getIsSourceTemplateControl()
  • TTemplateControl::getMaster()
  • TTemplateControl::getMasterClass()
  • TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
  • TTemplateControl::getTemplateDirectory()
  • TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
  • TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
  • TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
  • TTemplateControl::registerContent()
    Registers a content control.
  • TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
  • TTemplateControl::setMasterClass()
  • TTemplateControl::setTemplate()
    Sets the parsed template.

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataRenderer::getData

    getData( );

    Returns

    data associated with the item

    access

    public

    [ Top ]

    TDataRenderer::setData

    setData( mixed $value );

    Parameters

    $value

    data to be associated with the item

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:05 +0200 by phpDocumentor 1.4.3


Docs For Class IDataSource

Interface IDataSource

[line 21]

Location: /Web/UI/WebControls/TDataSourceControl.php

Remarks

IDataSource class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataSourceControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IDataSource::getView

getView(

$viewName );

    Parameters

    $viewName

    access

    public

    [ Top ]

    IDataSource::getViewNames

getViewNames(
 );

    access

    public

    [ Top ]

    IDataSource::onDataSourceChanged

onDataSourceChanged(

$param );

    Parameters

    $param

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:05 +0200 by phpDocumentor 1.4.3


Docs For Class TDataSourceControl

Class TDataSourceControl

[line 36]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TDataSourceControl
Classes extended from TDataSourceControl:
TReadOnlyDataSource
TDataSourceControl class

Location: /Web/UI/WebControls/TDataSourceControl.php

Remarks

TDataSourceControl class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataSourceControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataSourceControl::focus

    focus( );

    Overrides TControl::focus() (Sets input focus to this control.)

    access

    public

    [ Top ]

    TDataSourceControl::getEnableTheming

    getEnableTheming( );

    Overrides TControl::getEnableTheming() (parent method not documented)

    access

    public

    [ Top ]

    TDataSourceControl::getSkinID

    getSkinID( );

    Overrides TControl::getSkinID() (parent method not documented)

    access

    public

    [ Top ]

    TDataSourceControl::getView

    getView( $viewName );

    Overridden in child classes as:

    TReadOnlyDataSource::getView()

    Implementation of:
    IDataSource::getView()

    Parameters

    $viewName

    access

    public

    [ Top ]

    TDataSourceControl::getViewNames

    getViewNames( );

    Implementation of:
    IDataSource::getViewNames()

    access

    public

    [ Top ]

    TDataSourceControl::getVisible

    getVisible( [ $checkParents = true] );

    Overrides TControl::getVisible() (Checks if a control is visible.)

    Parameters

    $checkParents

    access

    public

    [ Top ]

    TDataSourceControl::onDataSourceChanged

    onDataSourceChanged( $param );

    Implementation of:
    IDataSource::onDataSourceChanged()

    Parameters

    $param

    access

    public

    [ Top ]

    TDataSourceControl::setEnableTheming

    setEnableTheming( $value );

    Overrides TControl::setEnableTheming() (parent method not documented)

    Parameters

    $value

    access

    public

    [ Top ]

    TDataSourceControl::setSkinID

    setSkinID( $value );

    Overrides TControl::setSkinID() (parent method not documented)

    Parameters

    $value

    access

    public

    [ Top ]

    TDataSourceControl::setVisible

    setVisible( $value );

    Overrides TControl::setVisible() (parent method not documented)

    Parameters

    $value

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:05 +0200 by phpDocumentor 1.4.3


Docs For Class TReadOnlyDataSource

Class TReadOnlyDataSource

[line 97]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TDataSourceControl
            |
            --TReadOnlyDataSource
Location: /Web/UI/WebControls/TDataSourceControl.php

Remarks

TDataSourceControl class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataSourceControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDataSourceControl

  • TDataSourceControl::focus()
  • TDataSourceControl::getEnableTheming()
  • TDataSourceControl::getSkinID()
  • TDataSourceControl::getView()
  • TDataSourceControl::getViewNames()
  • TDataSourceControl::getVisible()
  • TDataSourceControl::onDataSourceChanged()
  • TDataSourceControl::setEnableTheming()
  • TDataSourceControl::setSkinID()
  • TDataSourceControl::setVisible()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TReadOnlyDataSource::__construct

    __construct( $dataSource, $dataMember );

    Overrides TControl::__construct() (Constructor.)

    Parameters

    $dataSource

    $dataMember

    access

    public

    [ Top ]

    TReadOnlyDataSource::getView

    getView( $viewName );

    Overrides TDataSourceControl::getView() (parent method not documented)

    Parameters

    $viewName

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:06 +0200 by phpDocumentor 1.4.3


Docs For Class TDataSourceSelectParameters

Class TDataSourceSelectParameters

[line 21]
TComponent
   |
   --TDataSourceSelectParameters
Location: /Web/UI/WebControls/TDataSourceView.php

Remarks

TDataSourceSelectParameters class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataSourceView.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataSourceSelectParameters::getMaximumRows

    getMaximumRows( );

    access

    public

    [ Top ]

    TDataSourceSelectParameters::getRetrieveTotalRowCount

    getRetrieveTotalRowCount( );

    access

    public

    [ Top ]

    TDataSourceSelectParameters::getStartRowIndex

    getStartRowIndex( );

    access

    public

    [ Top ]

    TDataSourceSelectParameters::getTotalRowCount

    getTotalRowCount( );

    access

    public

    [ Top ]

    TDataSourceSelectParameters::setMaximumRows

    setMaximumRows( $value );

    Parameters

    $value

    access

    public

    [ Top ]

    TDataSourceSelectParameters::setRetrieveTotalRowCount

    setRetrieveTotalRowCount( $value );

    Parameters

    $value

    access

    public

    [ Top ]

    TDataSourceSelectParameters::setStartRowIndex

    setStartRowIndex( $value );

    Parameters

    $value

    access

    public

    [ Top ]

    TDataSourceSelectParameters::setTotalRowCount

    setTotalRowCount( $value );

    Parameters

    $value

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:06 +0200 by phpDocumentor 1.4.3


Docs For Class TDataSourceView

Class TDataSourceView

[line 83]
TComponent
   |
   --TDataSourceView
Classes extended from TDataSourceView:
TReadOnlyDataSourceView
TReadOnlyDataSourceView class

Location: /Web/UI/WebControls/TDataSourceView.php

Remarks

TDataSourceView class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataSourceView.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataSourceView::__construct

    __construct( IDataSource $owner, $viewName );

    Overridden in child classes as:

    TReadOnlyDataSourceView::__construct()

    Parameters

    $owner

    $viewName

    access

    public

    [ Top ]

    TDataSourceView::delete

    delete( array|TMap $keys );

    Parameters

    $keys

    keys for specifying the rows to be deleted

    Returns

    affected rows

    Remarks

    Deletes DB row(s) with the specified keys.

    access

    public

    [ Top ]

    TDataSourceView::getCanDelete

    getCanDelete( );

    access

    public

    [ Top ]

    TDataSourceView::getCanGetRowCount

    getCanGetRowCount( );

    access

    public

    [ Top ]

    TDataSourceView::getCanInsert

    getCanInsert( );

    access

    public

    [ Top ]

    TDataSourceView::getCanPage

    getCanPage( );

    access

    public

    [ Top ]

    TDataSourceView::getCanSort

    getCanSort( );

    access

    public

    [ Top ]

    TDataSourceView::getCanUpdate

    getCanUpdate( );

    access

    public

    [ Top ]

    TDataSourceView::getDataSource

    getDataSource( );

    access

    public

    [ Top ]

    TDataSourceView::getName

    getName( );

    access

    public

    [ Top ]

    TDataSourceView::insertAt

    insertAt( array|TMap $values );

    Parameters

    $values

    Returns

    affected rows

    Remarks

    Inserts a DB record.

    access

    public

    [ Top ]

    TDataSourceView::onDataSourceViewChanged

    onDataSourceViewChanged( $param );

    Parameters

    $param

    access

    public

    [ Top ]

    TDataSourceView::select

    select( ??? $parameters );

    Overridden in child classes as:

    TReadOnlyDataSourceView::select()

    Parameters

    $parameters

    Remarks

    Performs DB selection based on specified parameters.

    abstract

    access

    public

    [ Top ]

    TDataSourceView::update

    update( array|TMap $keys, array|TMap $values );

    Parameters

    $keys

    keys for specifying the records to be updated

    $values

    new values

    Returns

    affected rows

    Remarks

    Updates DB record(s) with the specified keys and new values

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:06 +0200 by phpDocumentor 1.4.3


Docs For Class TReadOnlyDataSourceView

Class TReadOnlyDataSourceView

[line 186]
TComponent
   |
   --TDataSourceView
      |
      --TReadOnlyDataSourceView
Location: /Web/UI/WebControls/TDataSourceView.php

Remarks

TReadOnlyDataSourceView class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataSourceView.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDataSourceView

  • TDataSourceView::__construct()
  • TDataSourceView::delete()
    Deletes DB row(s) with the specified keys.
  • TDataSourceView::getCanDelete()
  • TDataSourceView::getCanGetRowCount()
  • TDataSourceView::getCanInsert()
  • TDataSourceView::getCanPage()
  • TDataSourceView::getCanSort()
  • TDataSourceView::getCanUpdate()
  • TDataSourceView::getDataSource()
  • TDataSourceView::getName()
  • TDataSourceView::insertAt()
    Inserts a DB record.
  • TDataSourceView::onDataSourceViewChanged()
  • TDataSourceView::select()
    Performs DB selection based on specified parameters.
  • TDataSourceView::update()
    Updates DB record(s) with the specified keys and new values

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TReadOnlyDataSourceView::__construct

    __construct( IDataSource $owner, $viewName, $dataSource );

    Overrides TDataSourceView::__construct() (parent method not documented)

    Parameters

    $owner

    $viewName

    $dataSource

    access

    public

    [ Top ]

    TReadOnlyDataSourceView::select

    select( $parameters );

    Overrides TDataSourceView::select() (Performs DB selection based on specified parameters.)

    Parameters

    $parameters

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:06 +0200 by phpDocumentor 1.4.3


Docs For Class TDataTypeValidator

Class TDataTypeValidator

[line 37]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TDataTypeValidator
Location: /Web/UI/WebControls/TDataTypeValidator.php

Remarks

TDataTypeValidator class

TDataTypeValidator verifies if the input data is of the type specified by DataType. The following data types are supported:

  • Integer A 32-bit signed integer data type.
  • Float A double-precision floating point number data type.
  • Date A date data type.
  • String A string data type.
For Date type, the property DateFormat will be used to determine how to parse the date string. If it is not provided, the string will be assumed to be in GNU datetime format.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDataTypeValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TBaseValidator

  • TBaseValidator::__construct()
    Constructor.
  • TBaseValidator::addAttributesToRender()
    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
  • TBaseValidator::createClientSide()
  • TBaseValidator::evaluateIsValid()
    This is the major method for validation.
  • TBaseValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
  • TBaseValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
  • TBaseValidator::getClientSide()
    Gets the TValidatorClientSide that allows modification of the client- side validator events.
  • TBaseValidator::getControlCssClass()
  • TBaseValidator::getControlToValidate()
  • TBaseValidator::getDisplay()
  • TBaseValidator::getEnableClientScript()
  • TBaseValidator::getErrorMessage()
  • TBaseValidator::getFocusElementID()
    Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::getFocusOnError()
  • TBaseValidator::getIsValid()
  • TBaseValidator::getValidationGroup()
  • TBaseValidator::getValidationTarget()
  • TBaseValidator::getValidationValue()
    Retrieves the property value of the control being validated.
  • TBaseValidator::onInit()
    Registers the validator with page.
  • TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
  • TBaseValidator::onUnload()
    Unregisters the validator from page.
  • TBaseValidator::onValidate()
    This event is raised right before the validator starts to perform validation.
  • TBaseValidator::onValidationError()
    This event is raised when the validator fails in validation.
  • TBaseValidator::onValidationSuccess()
    This event is raised when the validator succeeds in validation.
  • TBaseValidator::registerClientScriptValidator()
    Registers the individual validator client-side javascript code.
  • TBaseValidator::renderClientControlScript()
    Renders the javascript code to the end script.
  • TBaseValidator::renderContents()
    Renders the validator control.
  • TBaseValidator::setControlCssClass()
  • TBaseValidator::setControlToValidate()
    Sets the ID path of the input control to validate.
  • TBaseValidator::setDisplay()
  • TBaseValidator::setEnableClientScript()
  • TBaseValidator::setEnabled()
    This method overrides parent's implementation by setting setIsValid to true if disabled.
  • TBaseValidator::setErrorMessage()
    Sets the text for the error message.
  • TBaseValidator::setFocusElementID()
    Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::setFocusOnError()
  • TBaseValidator::setForControl()
    This method overrides the parent implementation to forbid setting ForControl.
  • TBaseValidator::setIsValid()
    Sets the value indicating whether the validation succeeds
  • TBaseValidator::setValidationGroup()
  • TBaseValidator::updateControlCssClass()
    Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
  • TBaseValidator::validate()
    Validates the specified control.

Inherited From Class TLabel

  • TLabel::addAttributesToRender()
    Adds attributes to renderer.
  • TLabel::getData()
    Returns the text value of the label.
  • TLabel::getForControl()
  • TLabel::getTagName()
  • TLabel::getText()
  • TLabel::render()
    Renders the label.
  • TLabel::renderContents()
    Renders the body content of the label.
  • TLabel::setData()
    Sets the text value of the label.
  • TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
  • TLabel::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataTypeValidator::evaluateDataTypeCheck

    evaluateDataTypeCheck( string $value );

    Parameters

    $value

    value to check

    Returns

    true if value fits the type expression.

    Remarks

    Determine if the given value is of a particular type using RegExp.

    access

    protected

    [ Top ]

    TDataTypeValidator::evaluateIsValid

    evaluateIsValid( );

    Overrides TBaseValidator::evaluateIsValid() (This is the major method for validation.)

    Returns

    whether the validation succeeds

    Remarks

    This method overrides the parent's implementation.

    The validation succeeds if the input data is of valid type. The validation always succeeds if ControlToValidate is not specified or the input data is empty.

    access

    public

    [ Top ]

    TDataTypeValidator::getClientClassName

    getClientClassName( );

    Overrides TBaseValidator::getClientClassName() (Gets the name of the javascript class responsible for performing validation for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing validation for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TDataTypeValidator::getClientScriptOptions

    getClientScriptOptions( );

    Overrides TBaseValidator::getClientScriptOptions() (Returns an array of javascript validator options.)

    Returns

    javascript validator options.

    Remarks

    Returns an array of javascript validator options.

    access

    protected

    [ Top ]

    TDataTypeValidator::getDataType

    getDataType( );

    Returns

    the data type that the values being compared are converted to before the comparison is made. Defaults to TValidationDataType::String.

    access

    public

    [ Top ]

    TDataTypeValidator::getDateFormat

    getDateFormat( );

    Returns

    the date validation date format if any

    access

    public

    [ Top ]

    TDataTypeValidator::setDataType

    setDataType( TValidationDataType $value );

    Parameters

    $value

    the data type

    Remarks

    Sets the data type that the values being compared are converted to before the comparison is made.

    access

    public

    [ Top ]

    TDataTypeValidator::setDateFormat

    setDateFormat( string $value );

    Parameters

    $value

    the date format value

    Remarks

    Sets the date format for a date validation

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:07 +0200 by phpDocumentor 1.4.3


Docs For Class TDatePicker

Class TDatePicker

[line 80]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --TDatePicker
Classes extended from TDatePicker:
TActiveDatePicker
TActiveDatePicker class

Location: /Web/UI/WebControls/TDatePicker.php

Remarks

TDatePicker class.

TDatePicker displays a text box for date input purpose. When the text box receives focus, a calendar will pop up and users can pick up from it a date that will be automatically entered into the text box. The format of the date string displayed in the text box is determined by the DateFormat property. Valid formats are the combination of the following tokens,

  •   Character Format Pattern (en-US)
    •

  •   -----------------------------------------
    •

  •   d          day digit
    •

  •   dd         padded day digit e.g. 01, 02
    •

  •   M          month digit
    •

  •   MM         padded month digit
    •

  •   MMMM       localized month name, e.g. March, April
    •

  •   yy         2 digit year
    •

  •   yyyy       4 digit year
    •

  •   -----------------------------------------
    •

    TDatePicker has four Mode to show the date picker popup.

    • Basic -- Only shows a text input, focusing on the input shows the date picker. This way you can access the popup using only the keyboard. Note that because of this, TAB-bing through this control will automatically select the current date if no previous date was selected. If you close the popup (eg. pressing the ESC key) you'll need to un-focus and re-focus the control again for the popup to reappear.
    • Clickable -- Only shows a text input, clicking on the input shows the date picker. This mode solves the two small problems of the Basic mode. It was first introduced in Prado 3.2.
    • Button -- Shows a button next to the text input, clicking on the button shows the date, button text can be by the ButtonText property
    • ImageButton -- Shows an image next to the text input, clicking on the image shows the date picker, image source can be change through the ButtonImageUrl property.
    The CssClass property can be used to override the css class name for the date picker panel. CalendarStyle property sets the packages styles available. E.g. default.

    The InputMode property can be set to "TextBox" or "DropDownList" with default as "TextBox". In DropDownList mode, in addition to the popup date picker, three drop down list (day, month and year) are presented to select the date .

    The PositionMode property can be set to "Top" or "Bottom" with default as "Bottom". It specifies the position of the calendar popup, relative to the input field.

    author

    Carl G. Mathisen <carlgmathisen@gmail.com>

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: TDatePicker.php 3133 2012-04-14 14:38:05Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    • SCRIPT_PATH =  'prado/datepicker'
      Script path relative to the TClientScriptManager::SCRIPT_PATH

    Inherited Class Constant Summary

    Inherited From Class TTextBox

    • TTextBox::DEFAULT_COLUMNS = 20
      Default number of columns (for MultiLine text box)
    • TTextBox::DEFAULT_ROWS = 4
      Default number of rows (for MultiLine text box)

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TTextBox

    • TTextBox::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TTextBox::getAutoCompleteType()
    • TTextBox::getAutoPostBack()
    • TTextBox::getAutoTrim()
    • TTextBox::getCausesValidation()
    • TTextBox::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
    • TTextBox::getColumns()
    • TTextBox::getData()
      Returns the text content of the TTextBox control.
    • TTextBox::getDataChanged()
      Returns a value indicating whether postback has caused the control data change.
    • TTextBox::getEnableClientScript()
    • TTextBox::getIsValid()
      Returns true if this control validated successfully.
    • TTextBox::getMaxLength()
    • TTextBox::getPersistPassword()
    • TTextBox::getPostBackOptions()
      Gets the post back options for this textbox.
    • TTextBox::getReadOnly()
    • TTextBox::getRows()
    • TTextBox::getSafeText()
    • TTextBox::getSafeTextParser()
    • TTextBox::getTagName()
    • TTextBox::getText()
    • TTextBox::getTextMode()
    • TTextBox::getValidationGroup()
    • TTextBox::getValidationPropertyValue()
      Returns the value to be validated.
    • TTextBox::getWrap()
    • TTextBox::loadPostData()
      Loads user input data.
    • TTextBox::onTextChanged()
      Raises OnTextChanged event.
    • TTextBox::raisePostDataChangedEvent()
      Raises postdata changed event.
    • TTextBox::renderBeginTag()
      Renders an additional line-break after the opening tag when it is in MultiLine text mode.
    • TTextBox::renderClientControlScript()
      Renders the javascript for textbox.
    • TTextBox::renderContents()
      Renders the body content of the textbox when it is in MultiLine text mode.
    • TTextBox::setAutoCompleteType()
    • TTextBox::setAutoPostBack()
      Sets the value indicating if postback automatically.
    • TTextBox::setAutoTrim()
      Sets the value indicating if the input text should be trimmed spaces
    • TTextBox::setCausesValidation()
    • TTextBox::setColumns()
      Sets the display width of the text box in characters.
    • TTextBox::setData()
      Sets the text content of the TTextBox control.
    • TTextBox::setEnableClientScript()
    • TTextBox::setIsValid()
    • TTextBox::setMaxLength()
      Sets the maximum number of characters allowed in the text box.
    • TTextBox::setPersistPassword()
    • TTextBox::setReadOnly()
    • TTextBox::setRows()
      Sets the number of rows displayed in a multiline text box.
    • TTextBox::setText()
      Sets the text content of the TTextBox control.
    • TTextBox::setTextMode()
      Sets the behavior mode of the TTextBox component.
    • TTextBox::setValidationGroup()
    • TTextBox::setWrap()
      Sets the value indicating whether the text content wraps within a multiline text box.

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TDatePicker::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overrides TTextBox::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

      Parameters

      $writer

      writer

      Remarks

      Add the client id to the input textbox, and register the client scripts.

      access

      protected

      [ Top ]

      TDatePicker::createClientScript

      createClientScript( );

      Returns

      javascript validator event options.

      access

      protected

      [ Top ]

      TDatePicker::getAssetUrl

      getAssetUrl( [string $file = ''] );

      Parameters

      $file

      date picker asset file in the self::SCRIPT_PATH directory.

      Returns

      date picker asset url.

      access

      protected

      [ Top ]

      TDatePicker::getButtonImageUrl

      getButtonImageUrl( );

      Returns

      the image url for "Image" UI mode.

      access

      public

      [ Top ]

      TDatePicker::getButtonText

      getButtonText( );

      Returns

      text for the date picker button. Default is "...".

      access

      public

      [ Top ]

      TDatePicker::getCalendarStyle

      getCalendarStyle( );

      Returns

      current calendar style

      access

      public

      [ Top ]

      TDatePicker::getClientSide

      getClientSide( );

      Overridden in child classes as:

      TActiveDatePicker::getClientSide()

      Returns

      javascript validator event options.

      Remarks

      Gets the TDatePickerClientScript to set the TDatePicker event handlers.

      The date picker on the client-side supports the following events.

      • <tt>OnDateChanged</tt> -- raised when the date is changed.
      You can attach custom javascript code to each of these events

      access

      public

      [ Top ]

      TDatePicker::getCulturalOptions

      getCulturalOptions( );

      Returns

      localization options.

      Remarks

      Get javascript localization options, e.g. month and weekday names.

      access

      protected

      [ Top ]

      TDatePicker::getCulture

      getCulture( );

      Returns

      current culture, e.g. en_AU.

      Remarks

      Gets the current culture.

      access

      public

      [ Top ]

      TDatePicker::getCurrentCulture

      getCurrentCulture( );

      Returns

      the current culture, falls back to application if culture is not set.

      access

      protected

      [ Top ]

      TDatePicker::getData

      getData( );

      Overrides TTextBox::getData() (Returns the text content of the TTextBox control.)

      Returns

      the timestamp of the TDatePicker control.

      Remarks

      Returns the timestamp selected by the user.

      This method is required by IDataRenderer. It is the same as getTimeStamp().

      see

      TDatePicker::getTimeStamp()

      since

      3.1.2

      access

      public

      [ Top ]

      TDatePicker::getDate

      getDate( );

      Returns

      the date string.

      access

      public

      [ Top ]

      TDatePicker::getDateFormat

      getDateFormat( );

      Returns

      the format of the date string

      access

      public

      [ Top ]

      TDatePicker::getDateFromPostData

      getDateFromPostData( string $key, array $values );

      Parameters

      $key

      the key that can be used to retrieve data from the input data collection

      $values

      the input data collection

      Returns

      the date selected

      Remarks

      Loads date from drop down list data.

      access

      protected

      [ Top ]

      TDatePicker::getDatePickerButtonID

      getDatePickerButtonID( );

      Returns

      unique button ID

      Remarks

      Gets the ID for the date picker trigger button.

      access

      protected

      [ Top ]

      TDatePicker::getDatePickerOptions

      getDatePickerOptions( );

      Overridden in child classes as:

      TActiveDatePicker::getDatePickerOptions()
      Get javascript date picker options.

      Returns

      date picker client-side options

      Remarks

      Get javascript date picker options.

      access

      protected

      [ Top ]

      TDatePicker::getDropDownDayOptions

      getDropDownDayOptions( );

      Returns

      list of day options for a drop down list.

      access

      protected

      [ Top ]

      TDatePicker::getFirstDayOfWeek

      getFirstDayOfWeek( );

      Returns

      first day of the week

      access

      public

      [ Top ]

      TDatePicker::getFromYear

      getFromYear( );

      Returns

      date picker starting year, default is -5 years

      access

      public

      [ Top ]

      TDatePicker::getInputMode

      getInputMode( );

      Returns

      input method of date values. Defaults to TDatePickerInputMode::TextBox.

      access

      public

      [ Top ]

      TDatePicker::getLocalizedCalendarInfo

      getLocalizedCalendarInfo( );

      Returns

      date time format information for the current culture.

      access

      protected

      [ Top ]

      TDatePicker::getLocalizedMonthNames

      getLocalizedMonthNames( DateTimeFormatInfo $info );

      Parameters

      $info

      localized date format information.

      Returns

      localized month names.

      Remarks

      Returns the localized month names that depends on the month format pattern.

      "MMMM" will return the month names, "MM" or "MMM" return abbr. month names and "M" return month digits.

      access

      protected

      [ Top ]

      TDatePicker::getMode

      getMode( );

      Returns

      current calendar UI mode.

      access

      public

      [ Top ]

      TDatePicker::getPositionMode

      getPositionMode( );

      Returns

      current calendar UI position.

      access

      public

      [ Top ]

      TDatePicker::getShowCalendar

      getShowCalendar( );

      Returns

      whether the calendar window should pop up when the control receives focus

      access

      public

      [ Top ]

      TDatePicker::getTimeStamp

      getTimeStamp( );

      Returns

      current selected date from the date picker as timestamp, NULL if timestamp is not set previously.

      access

      public

      [ Top ]

      TDatePicker::getTimeStampFromText

      getTimeStampFromText( );

      Returns

      current selected date timestamp

      Remarks

      Gets the date from the text input using TSimpleDateFormatter

      access

      protected

      [ Top ]

      TDatePicker::getUpToYear

      getUpToYear( );

      Returns

      date picker ending year, default +10 years

      access

      public

      [ Top ]

      TDatePicker::getValidationPropertyValue

      getValidationPropertyValue( );

      Overrides TTextBox::getValidationPropertyValue() (Returns the value to be validated.)

      Returns

      the interger timestamp if valid, otherwise the original text.

      Remarks

      Returns the value to be validated.

      This methid is required by IValidatable interface.

      access

      public

      [ Top ]

      TDatePicker::hasDayPattern

      hasDayPattern( );

      access

      protected

      [ Top ]

      TDatePicker::loadPostData

      loadPostData( string $key, array $values );

      Overrides TTextBox::loadPostData() (Loads user input data.)

      Parameters

      $key

      the key that can be used to retrieve data from the input data collection

      $values

      the input data collection

      Returns

      whether the data of the component has been changed

      Remarks

      Loads user input data. Override parent implementation, when InputMode is DropDownList call getDateFromPostData to get date data.

      This method is primarly used by framework developers.

      access

      public

      [ Top ]

      TDatePicker::onPreRender

      onPreRender( $param );

      Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

      Parameters

      $param

      Remarks

      Publish the date picker Css asset files.

      access

      public

      [ Top ]

      TDatePicker::publishCalendarStyle

      publishCalendarStyle( );

      Returns

      Css file url.

      Remarks

      Publish the calendar style Css asset file.

      access

      protected

      [ Top ]

      TDatePicker::registerCalendarClientScriptPost

      registerCalendarClientScriptPost( );

      Overridden in child classes as:

      TActiveDatePicker::registerCalendarClientScriptPost()

      access

      protected

      [ Top ]

      TDatePicker::registerCalendarClientScriptPre

      registerCalendarClientScriptPre( );

      Overridden in child classes as:

      TActiveDatePicker::registerCalendarClientScriptPre()
      Registers the javascript code to initialize the date picker.

      Remarks

      Registers the javascript code to initialize the date picker.

      access

      protected

      [ Top ]

      TDatePicker::render

      render( THtmlWriter $writer );

      Overrides TWebControl::render() (Renders the control.)

      Parameters

      $writer

      writer

      Remarks

      Renders body content.

      This method overrides parent implementation by adding additional date picker button if Mode is Button or ImageButton.

      access

      public

      [ Top ]

      TDatePicker::renderButtonDatePicker

      renderButtonDatePicker( $writer );

      Parameters

      $writer

      Returns

      writer

      Remarks

      Adds an additional button such that when clicked it shows the date picker.

      access

      protected

      [ Top ]

      TDatePicker::renderCalendarDayOptions

      renderCalendarDayOptions( THtmlWriter $writer, [mixed $selected = null] );

      Parameters

      $writer

      the writer used for the rendering purpose

      $selected

      selected day.

      Remarks

      Renders the day drop down list options.

      access

      protected

      [ Top ]

      TDatePicker::renderCalendarMonthOptions

      renderCalendarMonthOptions( THtmlWriter $writer, [mixed $selected = null] );

      Parameters

      $writer

      the writer used for the rendering purpose

      $selected

      selected month.

      Remarks

      Renders the month drop down list options.

      access

      protected

      [ Top ]

      TDatePicker::renderCalendarSelections

      renderCalendarSelections( THtmlWriter $writer, array $date );

      Parameters

      $writer

      the Html writer to render the drop down lists.

      $date

      the current selected date

      Remarks

      Renders the calendar drop down list depending on the DateFormat pattern.

      access

      protected

      [ Top ]

      TDatePicker::renderCalendarYearOptions

      renderCalendarYearOptions( THtmlWriter $writer, [mixed $selected = null] );

      Parameters

      $writer

      the writer used for the rendering purpose

      $selected

      selected year.

      Remarks

      Renders the year drop down list options.

      access

      protected

      [ Top ]

      TDatePicker::renderDatePickerButtons

      renderDatePickerButtons( $writer );

      Parameters

      $writer

      Remarks

      Renders the date picker popup buttons.

      access

      protected

      [ Top ]

      TDatePicker::renderDropDownListCalendar

      renderDropDownListCalendar( $writer );

      Parameters

      $writer

      Remarks

      Renders the drop down list date picker.

      access

      protected

      [ Top ]

      TDatePicker::renderImageButtonDatePicker

      renderImageButtonDatePicker( $writer );

      Parameters

      $writer

      Returns

      writer

      Remarks

      Adds an additional image button such that when clicked it shows the date picker.

      access

      protected

      [ Top ]

      TDatePicker::setAutoPostBack

      setAutoPostBack( $value );

      Overridden in child classes as:

      TActiveDatePicker::setAutoPostBack()
      Sets the value indicating if postback automatically.

      Overrides TTextBox::setAutoPostBack() (Sets the value indicating if postback automatically.)

      Parameters

      $value

      Remarks

      AutoPostBack is not supported.

      access

      public

      [ Top ]

      TDatePicker::setButtonImageUrl

      setButtonImageUrl( string $value );

      Parameters

      $value

      the image url for "Image" UI mode.

      access

      public

      [ Top ]

      TDatePicker::setButtonText

      setButtonText( string $value );

      Parameters

      $value

      text for the date picker button

      access

      public

      [ Top ]

      TDatePicker::setCalendarStyle

      setCalendarStyle( string $value );

      Parameters

      $value

      set the calendar style

      access

      public

      [ Top ]

      TDatePicker::setCulture

      setCulture( string $value );

      Parameters

      $value

      a culture string, e.g. en_AU.

      Remarks

      Sets the culture/language for the date picker.

      access

      public

      [ Top ]

      TDatePicker::setData

      setData( integer $value );

      Overrides TTextBox::setData() (Sets the text content of the TTextBox control.)

      Parameters

      $value

      the timestamp of the TDatePicker control.

      Remarks

      Sets the timestamp represented by this control.

      This method is required by IDataRenderer. It is the same as setTimeStamp().

      see

      TDatePicker::setTimeStamp()

      since

      3.1.2

      access

      public

      [ Top ]

      TDatePicker::setDate

      setDate( string $value );

      Parameters

      $value

      date string

      access

      public

      [ Top ]

      TDatePicker::setDateFormat

      setDateFormat( string $value );

      Parameters

      $value

      the format of the date string

      Remarks

      Sets the format of the date string.

      access

      public

      [ Top ]

      TDatePicker::setFirstDayOfWeek

      setFirstDayOfWeek( integer $value );

      Parameters

      $value

      0 for Sunday, 1 for Monday, 2 for Tuesday, etc.

      Remarks

      Set the first day of week, with 0 as Sunday, 1 as Monday, etc.

      access

      public

      [ Top ]

      TDatePicker::setFromYear

      setFromYear( integer $value );

      Parameters

      $value

      date picker starting year, default is 2000.

      access

      public

      [ Top ]

      TDatePicker::setInputMode

      setInputMode( TDatePickerInputMode $value );

      Parameters

      $value

      input method of date values

      access

      public

      [ Top ]

      TDatePicker::setMode

      setMode( TDatePickerMode $value );

      Parameters

      $value

      calendar UI mode

      access

      public

      [ Top ]

      TDatePicker::setPositionMode

      setPositionMode( TDatePickerPositionMode $value );

      Parameters

      $value

      calendar UI position

      access

      public

      [ Top ]

      TDatePicker::setShowCalendar

      setShowCalendar( boolean $value );

      Parameters

      $value

      whether to show the calendar window

      Remarks

      Sets whether to pop up the calendar window when the control receives focus

      access

      public

      [ Top ]

      TDatePicker::setTimeStamp

      setTimeStamp( float $value );

      Parameters

      $value

      time stamp for the date picker

      Remarks

      Sets the date for the date picker using timestamp.

      access

      public

      [ Top ]

      TDatePicker::setUpToYear

      setUpToYear( integer $value );

      Parameters

      $value

      date picker ending year, default +10 years

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • SCRIPT_PATH =  'prado/datepicker' [line 85]

      • Remarks

      Script path relative to the TClientScriptManager::SCRIPT_PATH

    Documentation generated on Mon, 25 Jun 2012 14:44:08 +0200 by phpDocumentor 1.4.3


Docs For Class TDatePickerClientScript

Class TDatePickerClientScript

[line 913]
TComponent
   |
   --TClientSideOptions
      |
      --TDatePickerClientScript
Location: /Web/UI/WebControls/TDatePicker.php

Remarks

TDatePickerClientScript class.

Client-side date picker event OnDateChanged can be modified through the TDatePicker::getClientSide property of a date picker.

The <tt>OnDateChanged</tt> event is raise when the date picker's date is changed. The formatted date according to TDatePicker::getDateFormat is sent as parameter to this event

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDatePicker.php 3133 2012-04-14 14:38:05Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TClientSideOptions

  • TClientSideOptions::__construct()
    Constructor, initialize the options list.
  • TClientSideOptions::ensureFunction()
    Ensure that the javascript statements are wrapped in a javascript function block as
  • function(sender, parameter){ //code }
    •
    .
  • TClientSideOptions::getOption()
  • TClientSideOptions::getOptions()
  • TClientSideOptions::setFunction()
    Adds on client-side event handler by wrapping the code within a javascript function block. If the code begins with "javascript:", the code is assumed to be a javascript function block rather than arbiturary javascript statements.
  • TClientSideOptions::setOption()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDatePickerClientScript::getOnDateChanged

    getOnDateChanged( );

    Returns

    javascript code to execute when the date picker's date is changed.

    access

    public

    [ Top ]

    TDatePickerClientScript::setOnDateChanged

    setOnDateChanged( string $javascript );

    Parameters

    $javascript

    javascript code

    Remarks

    Javascript code to execute when the date picker's date is changed.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:10 +0200 by phpDocumentor 1.4.3


Docs For Class TDatePickerInputMode

Class TDatePickerInputMode

[line 947]
TEnumerable
   |
   --TDatePickerInputMode
Location: /Web/UI/WebControls/TDatePicker.php

Remarks

TDatePickerInputMode class.

TDatePickerInputMode defines the enumerable type for the possible datepicker input methods.

The following enumerable values are defined:

  • TextBox: text boxes are used to input date values
  • DropDownList: dropdown lists are used to pick up date values

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDatePicker.php 3133 2012-04-14 14:38:05Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • DropDownList = 'DropDownList'
  • TextBox = 'TextBox'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • DropDownList = 'DropDownList' [line 950]

  • TextBox = 'TextBox' [line 949]

Documentation generated on Mon, 25 Jun 2012 14:44:10 +0200 by phpDocumentor 1.4.3


Docs For Class TDatePickerMode

Class TDatePickerMode

[line 969]
TEnumerable
   |
   --TDatePickerMode
Location: /Web/UI/WebControls/TDatePicker.php

Remarks

TDatePickerMode class.

TDatePickerMode defines the enumerable type for the possible UI mode that a TDatePicker control can take.

The following enumerable values are defined:

  • Basic: Only shows a text input, focusing on the input shows the date picker
  • Clickable: Only shows a text input, clicking on the input shows the date picker (since 3.2)
  • Button: Shows a button next to the text input, clicking on the button shows the date, button text can be by the
  • ImageButton: Shows an image next to the text input, clicking on the image shows the date picker,

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDatePicker.php 3133 2012-04-14 14:38:05Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Basic = 'Basic'
  • Button = 'Button'
  • Clickable = 'Clickable'
  • ImageButton = 'ImageButton'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Basic = 'Basic' [line 971]

  • Button = 'Button' [line 973]

  • Clickable = 'Clickable' [line 972]

  • ImageButton = 'ImageButton' [line 974]

Documentation generated on Mon, 25 Jun 2012 14:44:10 +0200 by phpDocumentor 1.4.3


Docs For Class TDatePickerPositionMode

Class TDatePickerPositionMode

[line 989]
TEnumerable
   |
   --TDatePickerPositionMode
Location: /Web/UI/WebControls/TDatePicker.php

Remarks

TDatePickerPositionMode class.

TDatePickerPositionMode defines the positions available for the calendar popup, relative to the corresponding input.

The following enumerable values are defined:

  • Top: the date picker is placed above the input field
  • Bottom: the date picker is placed below the input field

author

Carl G. Mathisen <carlgmathisen@gmail.com>

version

$Id: TComponent.php 3123 2012-03-26 10:10:51Z ctrlaltca@gmail.com $

since

3.1.4

Class Variable Summary

Class Constant Summary

  • Bottom = 'Bottom'
  • Top = 'Top'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Bottom = 'Bottom' [line 992]

  • Top = 'Top' [line 991]

Documentation generated on Mon, 25 Jun 2012 14:44:10 +0200 by phpDocumentor 1.4.3


Docs For Class TDropDownList

Class TDropDownList

[line 46]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TDropDownList
Classes extended from TDropDownList:
TActiveDropDownList
TActiveDropDownList class.

Location: /Web/UI/WebControls/TDropDownList.php

Remarks

TDropDownList class

TDropDownList displays a dropdown list on a Web page. It inherits all properties and events from TListControl.

Since v3.0.3, TDropDownList starts to support optgroup. To specify an option group for a list item, set a Group attribute with it,

  •   $listitem->Attributes->Group="Group Name";
    •

  •   // or <com:TListItem Attributes.Group="Group Name" .../> in template
    •

    Since v3.1.1, TDropDownList starts to support prompt text. That is, a prompt item can be displayed as the first list item by specifying either PromptText or PromptValue, or both. Choosing the prompt item will unselect the TDropDownList.

    When a prompt item is set, its index in the list is set to -1. So, the SelectedIndex property is not affected by a prompt item: the items list will still be zero-based.

    The clearSelection method will select the prompt item if existing, otherway the first available item in the dropdown list will be selected.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TDropDownList.php 3052 2011-10-21 09:06:19Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TListControl

    • TListControl::addAttributesToRender()
      Adds attributes to renderer.
    • TListControl::addParsedObject()
      Adds object parsed from template to the control.
    • TListControl::clearSelection()
      Clears all existing selections.
    • TListControl::createListItemCollection()
      Creates a collection object to hold list items.
    • TListControl::formatDataValue()
      Formats the text value according to a format string.
    • TListControl::getAppendDataBoundItems()
    • TListControl::getAutoPostBack()
    • TListControl::getCausesValidation()
    • TListControl::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
    • TListControl::getData()
      Returns the value of the selected item with the lowest cardinal index.
    • TListControl::getDataGroupField()
    • TListControl::getDataTextField()
    • TListControl::getDataTextFormatString()
    • TListControl::getDataValueField()
    • TListControl::getEnableClientScript()
    • TListControl::getHasItems()
    • TListControl::getIsMultiSelect()
    • TListControl::getItemCount()
    • TListControl::getItems()
    • TListControl::getPostBackOptions()
    • TListControl::getPromptText()
    • TListControl::getPromptValue()
    • TListControl::getSelectedIndex()
    • TListControl::getSelectedIndices()
    • TListControl::getSelectedItem()
    • TListControl::getSelectedValue()
    • TListControl::getSelectedValues()
    • TListControl::getTagName()
    • TListControl::getText()
    • TListControl::getValidationGroup()
    • TListControl::loadState()
      Loads items from viewstate.
    • TListControl::onSelectedIndexChanged()
      Raises OnSelectedIndexChanged event when selection is changed.
    • TListControl::onTextChanged()
      Raises OnTextChanged event when selection is changed.
    • TListControl::performDataBinding()
      Performs databinding to populate list items from data source.
    • TListControl::renderClientControlScript()
      Renders the javascript for list control.
    • TListControl::renderContents()
      Renders body content of the list control.
    • TListControl::renderPrompt()
      Renders the prompt text, if any.
    • TListControl::saveState()
      Saves items into viewstate.
    • TListControl::setAppendDataBoundItems()
    • TListControl::setAutoPostBack()
      Sets the value indicating if postback automatically.
    • TListControl::setCausesValidation()
    • TListControl::setData()
      Selects an item by the specified value.
    • TListControl::setDataGroupField()
    • TListControl::setDataTextField()
    • TListControl::setDataTextFormatString()
      Sets data text format string.
    • TListControl::setDataValueField()
    • TListControl::setEnableClientScript()
    • TListControl::setPromptText()
    • TListControl::setPromptValue()
    • TListControl::setSelectedIndex()
    • TListControl::setSelectedIndices()
    • TListControl::setSelectedValue()
      Sets selection by item value.
    • TListControl::setSelectedValues()
    • TListControl::setText()
    • TListControl::setValidationGroup()

    Inherited From Class TDataBoundControl

    • TDataBoundControl::createPagedDataSource()
    • TDataBoundControl::dataBind()
      Performs databinding.
    • TDataBoundControl::dataSourceViewChanged()
    • TDataBoundControl::determineDataSource()
    • TDataBoundControl::ensureDataBound()
      Ensures any pending dataBind is called.
    • TDataBoundControl::getAllowCustomPaging()
    • TDataBoundControl::getAllowPaging()
    • TDataBoundControl::getCurrentPageIndex()
    • TDataBoundControl::getDataMember()
    • TDataBoundControl::getDataSource()
    • TDataBoundControl::getDataSourceID()
    • TDataBoundControl::getDataSourceView()
    • TDataBoundControl::getInitialized()
    • TDataBoundControl::getIsDataBound()
    • TDataBoundControl::getPageCount()
    • TDataBoundControl::getPageSize()
    • TDataBoundControl::getRequiresDataBinding()
    • TDataBoundControl::getSelectParameters()
    • TDataBoundControl::getUsingDataSourceID()
    • TDataBoundControl::getVirtualItemCount()
    • TDataBoundControl::onDataBound()
      Raises OnDataBound event.
    • TDataBoundControl::onDataSourceChanged()
      Sets setRequiresDataBinding as true if the control is initialized.
    • TDataBoundControl::onInit()
      Sets page's OnPreLoad event handler as pagePreLoad.
    • TDataBoundControl::onPreRender()
      Ensures any pending databind is performed.
    • TDataBoundControl::pagePreLoad()
      Sets getInitialized as true.
    • TDataBoundControl::performDataBinding()
    • TDataBoundControl::setAllowCustomPaging()
      Sets a value indicating whether the custom paging should be enabled.
    • TDataBoundControl::setAllowPaging()
    • TDataBoundControl::setCurrentPageIndex()
    • TDataBoundControl::setDataMember()
    • TDataBoundControl::setDataSource()
      Sets the data source object associated with the databound control.
    • TDataBoundControl::setDataSourceID()
    • TDataBoundControl::setInitialized()
      Sets a value indicating whether the databound control is initialized.
    • TDataBoundControl::setIsDataBound()
    • TDataBoundControl::setPageSize()
    • TDataBoundControl::setRequiresDataBinding()
      Sets a value indicating whether a databind call is required by the data bound control.
    • TDataBoundControl::setVirtualItemCount()
    • TDataBoundControl::validateDataSource()
      Validates if the parameter is a valid data source.

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TDropDownList::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overridden in child classes as:

      TActiveDropDownList::addAttributesToRender()
      Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

      Overrides TListControl::addAttributesToRender() (Adds attributes to renderer.)

      Parameters

      $writer

      the renderer

      Remarks

      Adds attributes to renderer.

      access

      protected

      [ Top ]

      TDropDownList::getClientClassName

      getClientClassName( );

      Overridden in child classes as:

      TActiveDropDownList::getClientClassName()
      No client class for this control.

      Overrides TListControl::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

      Returns

      the javascript class name

      Remarks

      Gets the name of the javascript class responsible for performing postback for this control.

      This method overrides the parent implementation.

      access

      protected

      [ Top ]

      TDropDownList::getDataChanged

      getDataChanged( );

      Returns

      whether postback has caused the control data change. False if the page is not in postback mode.

      Remarks

      Returns a value indicating whether postback has caused the control data change.

      This method is required by the IPostBackDataHandler interface.

      access

      public

      [ Top ]

      TDropDownList::getIsValid

      getIsValid( );

      Returns

      wether this control validated successfully.

      Remarks

      Returns true if this control validated successfully.

      Defaults to true.

      access

      public

      [ Top ]

      TDropDownList::getValidationPropertyValue

      getValidationPropertyValue( );

      Returns

      the value of the property to be validated.

      Remarks

      Returns the value to be validated.

      This methid is required by IValidatable interface.

      access

      public

      [ Top ]

      TDropDownList::loadPostData

      loadPostData( string $key, array $values );

      Parameters

      $key

      the key that can be used to retrieve data from the input data collection

      $values

      the input data collection

      Returns

      whether the data of the component has been changed

      Remarks

      Loads user input data.

      This method is primarly used by framework developers.

      access

      public

      [ Top ]

      TDropDownList::raisePostDataChangedEvent

      raisePostDataChangedEvent( );

      Remarks

      Raises postdata changed event.

      This method is required by IPostBackDataHandler interface. It is invoked by the framework when SelectedIndex property is changed on postback. This method is primarly used by framework developers.

      access

      public

      [ Top ]

      TDropDownList::setIsValid

      setIsValid( bool $value );

      Parameters

      $value

      wether this control is valid.

      access

      public

      [ Top ]

      TDropDownList::setSelectedIndices

      setSelectedIndices( $indices );

      Overrides TListControl::setSelectedIndices() (parent method not documented)

      Parameters

      $indices

      throws

      TNotSupportedException if this method is invoked

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:16 +0200 by phpDocumentor 1.4.3


Docs For Class TDropDownListColumn

Class TDropDownListColumn

[line 61]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TDropDownListColumn
Classes extended from TDropDownListColumn:
TActiveDropDownListColumn
TActiveDropDownListColumn class

Location: /Web/UI/WebControls/TDropDownListColumn.php

Remarks

TDropDownListColumn class

TDropDownListColumn represents a column that is bound to a field in a data source. The cells in the column will be displayed using the data indexed by DataTextField. You can customize the display by setting DataTextFormatString.

If ReadOnly is false, TDropDownListColumn will display cells in edit mode with dropdown lists. Otherwise, a static text is displayed. The currently selected dropndown list item is specified by the data indexed with DataValueField.

There are two approaches to specify the list items available for selection. The first approach uses template syntax as follows,

  •    <com:TDropDownListColumn ....>
    •

  •      <com:TListItem Value="1" Text="first item" />
    •

  •      <com:TListItem Value="2" Text="second item" />
    •

  •      <com:TListItem Value="3" Text="third item" />
    •

  •    </com:TDropDownListColumn>
    •
    The second approach specifies a data source to be bound to the dropdown lists by setting ListDataSource. Like generic list controls, you may also want to specify which data fields are used for item values and texts by setting ListValueField and ListTextField, respectively. Furthermore, the item texts may be formatted by using ListTextFormatString. Note, if you specify ListDataSource, do it before calling the datagrid's dataBind().

    The dropdown list control in the TDropDownListColumn can be accessed by one of the following two methods:

  •  $datagridItem->DropDownListColumnID->DropDownList
    •

  •  $datagridItem->DropDownListColumnID->Controls[0]
    •
    The second method is possible because the dropdown list control created within the datagrid cell is the first child.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TDropDownListColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0.4

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TDataGridColumn

    • TDataGridColumn::formatDataValue()
      Formats the text value according to a format string.
    • TDataGridColumn::getAllowSorting()
      Returns a value indicating whether this column allows sorting.
    • TDataGridColumn::getDataFieldValue()
      Fetches the value of the data at the specified field.
    • TDataGridColumn::getEnableCellGrouping()
    • TDataGridColumn::getFooterRenderer()
    • TDataGridColumn::getFooterStyle()
    • TDataGridColumn::getFooterText()
    • TDataGridColumn::getHeaderImageUrl()
    • TDataGridColumn::getHeaderRenderer()
    • TDataGridColumn::getHeaderStyle()
    • TDataGridColumn::getHeaderText()
    • TDataGridColumn::getID()
    • TDataGridColumn::getItemStyle()
    • TDataGridColumn::getOwner()
    • TDataGridColumn::getSortExpression()
    • TDataGridColumn::getViewState()
      Returns a viewstate value.
    • TDataGridColumn::getVisible()
    • TDataGridColumn::initialize()
      Initializes the column.
    • TDataGridColumn::initializeCell()
      Initializes the specified cell to its initial values.
    • TDataGridColumn::initializeFooterCell()
      Initializes the footer cell.
    • TDataGridColumn::initializeHeaderCell()
      Initializes the header cell.
    • TDataGridColumn::loadState()
      Loads persistent state values.
    • TDataGridColumn::saveState()
      Saves persistent state values.
    • TDataGridColumn::setEnableCellGrouping()
    • TDataGridColumn::setFooterRenderer()
      Sets the column footer cell renderer class.
    • TDataGridColumn::setFooterText()
    • TDataGridColumn::setHeaderImageUrl()
    • TDataGridColumn::setHeaderRenderer()
      Sets the column header cell renderer class.
    • TDataGridColumn::setHeaderText()
    • TDataGridColumn::setID()
      Sets the ID of the column.
    • TDataGridColumn::setOwner()
    • TDataGridColumn::setSortExpression()
    • TDataGridColumn::setViewState()
      Sets a viewstate value.
    • TDataGridColumn::setVisible()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TDropDownListColumn::__construct

      __construct( );

      access

      public

      [ Top ]

      TDropDownListColumn::addParsedObject

      addParsedObject( mixed $object );

      Overrides TComponent::addParsedObject() (Processes an object that is created during parsing template.)

      Parameters

      $object

      object parsed from template

      Remarks

      Adds object parsed from template to the control.

      This method adds only TListItem objects into the getItems collection. All other objects are ignored.

      access

      public

      [ Top ]

      TDropDownListColumn::dataBindColumn

      dataBindColumn( $sender, $param );

      Parameters

      $sender

      $param

      Remarks

      Databinds a cell in the column.

      This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

      access

      public

      [ Top ]

      TDropDownListColumn::getDataTextField

      getDataTextField( );

      Returns

      the field of the data source that provides the text content of the column.

      access

      public

      [ Top ]

      TDropDownListColumn::getDataTextFormatString

      getDataTextFormatString( );

      Returns

      the formatting string used to control how the bound data will be displayed.

      access

      public

      [ Top ]

      TDropDownListColumn::getDataValueField

      getDataValueField( );

      Returns

      the field of the data source that provides the key selecting an item in dropdown list.

      access

      public

      [ Top ]

      TDropDownListColumn::getListDataSource

      getListDataSource( );

      Returns

      data source to be bound to the dropdown list boxes.

      access

      public

      [ Top ]

      TDropDownListColumn::getListTextField

      getListTextField( );

      Returns

      the data field used to populate the texts of the dropdown list items. Defaults to empty.

      access

      public

      [ Top ]

      TDropDownListColumn::getListTextFormatString

      getListTextFormatString( );

      Returns

      the formatting string used to control how the list item texts will be displayed.

      access

      public

      [ Top ]

      TDropDownListColumn::getListValueField

      getListValueField( );

      Returns

      the data field used to populate the values of the dropdown list items. Defaults to empty.

      access

      public

      [ Top ]

      TDropDownListColumn::getReadOnly

      getReadOnly( );

      Returns

      whether the items in the column can be edited. Defaults to false.

      access

      public

      [ Top ]

      TDropDownListColumn::initializeCell

      initializeCell( TTableCell $cell, integer $columnIndex, string $itemType );

      Overrides TDataGridColumn::initializeCell() (Initializes the specified cell to its initial values.)

      Parameters

      $cell

      the cell to be initialized.

      $columnIndex

      the index to the Columns property that the cell resides in.

      $itemType

      the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)

      Remarks

      Initializes the specified cell to its initial values.

      This method overrides the parent implementation. It creates a textbox for item in edit mode and the column is not read-only. Otherwise it displays a static text. The caption of the button and the static text are retrieved from the datasource.

      access

      public

      [ Top ]

      TDropDownListColumn::loadState

      loadState( mixed $state );

      Overrides TDataGridColumn::loadState() (Loads persistent state values.)

      Parameters

      $state

      state values

      Remarks

      Loads items from viewstate.

      This method overrides the parent implementation by loading list items

      access

      public

      [ Top ]

      TDropDownListColumn::saveState

      saveState( );

      Overrides TDataGridColumn::saveState() (Saves persistent state values.)

      Remarks

      Saves items into viewstate.

      This method overrides the parent implementation by saving list items

      access

      public

      [ Top ]

      TDropDownListColumn::setDataTextField

      setDataTextField( string $value );

      Parameters

      $value

      the field of the data source that provides the text content of the column.

      Remarks

      Sets the field of the data source that provides the text content of the column.

      If this is not set, the data specified via DataValueField will be displayed in the column.

      access

      public

      [ Top ]

      TDropDownListColumn::setDataTextFormatString

      setDataTextFormatString( string $value );

      Parameters

      $value

      the formatting string used to control how the bound data will be displayed.

      access

      public

      [ Top ]

      TDropDownListColumn::setDataValueField

      setDataValueField( string $value );

      Parameters

      $value

      the field of the data source that provides the key selecting an item in dropdown list.

      Remarks

      Sets the field of the data source that provides the key selecting an item in dropdown list.

      If this is not present, the data specified via DataTextField (without applying the formatting string) will be used for selection, instead.

      access

      public

      [ Top ]

      TDropDownListColumn::setListDataSource

      setListDataSource( Traversable|array|string $value );

      Parameters

      $value

      data source to be bound to the dropdown list boxes.

      access

      public

      [ Top ]

      TDropDownListColumn::setListTextField

      setListTextField( string $value );

      Parameters

      $value

      the data field used to populate the texts of the dropdown list items

      access

      public

      [ Top ]

      TDropDownListColumn::setListTextFormatString

      setListTextFormatString( string $value );

      Parameters

      $value

      the formatting string used to control how the list item texts will be displayed.

      access

      public

      [ Top ]

      TDropDownListColumn::setListValueField

      setListValueField( string $value );

      Parameters

      $value

      the data field used to populate the values of the dropdown list items

      access

      public

      [ Top ]

      TDropDownListColumn::setReadOnly

      setReadOnly( boolean $value );

      Parameters

      $value

      whether the items in the column can be edited

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:17 +0200 by phpDocumentor 1.4.3


Docs For Class TEditCommandColumn

Class TEditCommandColumn

[line 54]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TEditCommandColumn
Classes extended from TEditCommandColumn:
TActiveEditCommandColumn
TActiveEditCommandColumn class

Location: /Web/UI/WebControls/TEditCommandColumn.php

Remarks

TEditCommandColumn class

TEditCommandColumn contains the Edit command buttons for editing data items in each row.

TEditCommandColumn will create an edit button if a cell is not in edit mode. Otherwise an update button and a cancel button will be created within the cell. The button captions are specified using EditText, UpdateText, and CancelText.

The buttons in the column can be set to display as hyperlinks, push or image buttons by setting the ButtonType property.

When an edit button is clicked, the datagrid will generate an onEditCommand event. When an update/cancel button is clicked, the datagrid will generate an onUpdateCommand or an onCancelCommand You can write these event handlers to change the state of specific datagrid item.

The CausesValidation and ValidationGroup properties affect the corresponding properties of the edit and update buttons. The cancel button does not cause validation by default.

The command buttons in the column can be accessed by one of the following methods:

  •  $datagridItem->ButtonColumnID->EditButton (or UpdateButton, CancelButton)
    •

  •  $datagridItem->ButtonColumnID->Controls[0]
    •
    The second method is possible because the button control created within the datagrid cell is the first child.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TEditCommandColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TDataGridColumn

    • TDataGridColumn::formatDataValue()
      Formats the text value according to a format string.
    • TDataGridColumn::getAllowSorting()
      Returns a value indicating whether this column allows sorting.
    • TDataGridColumn::getDataFieldValue()
      Fetches the value of the data at the specified field.
    • TDataGridColumn::getEnableCellGrouping()
    • TDataGridColumn::getFooterRenderer()
    • TDataGridColumn::getFooterStyle()
    • TDataGridColumn::getFooterText()
    • TDataGridColumn::getHeaderImageUrl()
    • TDataGridColumn::getHeaderRenderer()
    • TDataGridColumn::getHeaderStyle()
    • TDataGridColumn::getHeaderText()
    • TDataGridColumn::getID()
    • TDataGridColumn::getItemStyle()
    • TDataGridColumn::getOwner()
    • TDataGridColumn::getSortExpression()
    • TDataGridColumn::getViewState()
      Returns a viewstate value.
    • TDataGridColumn::getVisible()
    • TDataGridColumn::initialize()
      Initializes the column.
    • TDataGridColumn::initializeCell()
      Initializes the specified cell to its initial values.
    • TDataGridColumn::initializeFooterCell()
      Initializes the footer cell.
    • TDataGridColumn::initializeHeaderCell()
      Initializes the header cell.
    • TDataGridColumn::loadState()
      Loads persistent state values.
    • TDataGridColumn::saveState()
      Saves persistent state values.
    • TDataGridColumn::setEnableCellGrouping()
    • TDataGridColumn::setFooterRenderer()
      Sets the column footer cell renderer class.
    • TDataGridColumn::setFooterText()
    • TDataGridColumn::setHeaderImageUrl()
    • TDataGridColumn::setHeaderRenderer()
      Sets the column header cell renderer class.
    • TDataGridColumn::setHeaderText()
    • TDataGridColumn::setID()
      Sets the ID of the column.
    • TDataGridColumn::setOwner()
    • TDataGridColumn::setSortExpression()
    • TDataGridColumn::setViewState()
      Sets a viewstate value.
    • TDataGridColumn::setVisible()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TEditCommandColumn::createButton

      createButton( string $commandName, string $text, boolean $causesValidation, string $validationGroup );

      Overridden in child classes as:

      TActiveEditCommandColumn::createButton()

      Parameters

      $commandName

      command name associated with the button

      $text

      button caption

      $causesValidation

      whether the button should cause validation

      $validationGroup

      the validation group that the button belongs to

      Returns

      the newly created button.

      Remarks

      Creates a button and initializes its properties.

      The button type is determined by ButtonType.

      access

      protected

      [ Top ]

      TEditCommandColumn::getButtonType

      getButtonType( );

      Returns

      the type of command button. Defaults to TButtonColumnType::LinkButton.

      access

      public

      [ Top ]

      TEditCommandColumn::getCancelImageUrl

      getCancelImageUrl( );

      Returns

      the URL of the image file for cancel image buttons

      access

      public

      [ Top ]

      TEditCommandColumn::getCancelText

      getCancelText( );

      Returns

      the caption of the cancel button. Defaults to 'Cancel'.

      access

      public

      [ Top ]

      TEditCommandColumn::getCausesValidation

      getCausesValidation( );

      Returns

      whether postback event trigger by edit or update button will cause input validation, default is true

      access

      public

      [ Top ]

      TEditCommandColumn::getEditImageUrl

      getEditImageUrl( );

      Returns

      the URL of the image file for edit image buttons

      access

      public

      [ Top ]

      TEditCommandColumn::getEditText

      getEditText( );

      Returns

      the caption of the edit button. Defaults to 'Edit'.

      access

      public

      [ Top ]

      TEditCommandColumn::getUpdateImageUrl

      getUpdateImageUrl( );

      Returns

      the URL of the image file for update image buttons

      access

      public

      [ Top ]

      TEditCommandColumn::getUpdateText

      getUpdateText( );

      Returns

      the caption of the update button. Defaults to 'Update'.

      access

      public

      [ Top ]

      TEditCommandColumn::getValidationGroup

      getValidationGroup( );

      Returns

      the group of validators which the edit or update button causes validation upon postback

      access

      public

      [ Top ]

      TEditCommandColumn::initializeCell

      initializeCell( TTableCell $cell, integer $columnIndex, string $itemType );

      Overrides TDataGridColumn::initializeCell() (Initializes the specified cell to its initial values.)

      Parameters

      $cell

      the cell to be initialized.

      $columnIndex

      the index to the Columns property that the cell resides in.

      $itemType

      the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)

      Remarks

      Initializes the specified cell to its initial values.

      This method overrides the parent implementation. It creates an update and a cancel button for cell in edit mode. Otherwise it creates an edit button.

      access

      public

      [ Top ]

      TEditCommandColumn::setButtonType

      setButtonType( TButtonColumnType $value );

      Parameters

      $value

      the type of command button.

      access

      public

      [ Top ]

      TEditCommandColumn::setCancelImageUrl

      setCancelImageUrl( string $value );

      Parameters

      $value

      the URL of the image file for cancel image buttons

      access

      public

      [ Top ]

      TEditCommandColumn::setCancelText

      setCancelText( string $value );

      Parameters

      $value

      the caption of the cancel button

      access

      public

      [ Top ]

      TEditCommandColumn::setCausesValidation

      setCausesValidation( boolean $value );

      Parameters

      $value

      whether postback event trigger by edit or update button will cause input validation

      access

      public

      [ Top ]

      TEditCommandColumn::setEditImageUrl

      setEditImageUrl( string $value );

      Parameters

      $value

      the URL of the image file for edit image buttons

      access

      public

      [ Top ]

      TEditCommandColumn::setEditText

      setEditText( string $value );

      Parameters

      $value

      the caption of the edit button

      access

      public

      [ Top ]

      TEditCommandColumn::setUpdateImageUrl

      setUpdateImageUrl( string $value );

      Parameters

      $value

      the URL of the image file for update image buttons

      access

      public

      [ Top ]

      TEditCommandColumn::setUpdateText

      setUpdateText( string $value );

      Parameters

      $value

      the caption of the update button

      access

      public

      [ Top ]

      TEditCommandColumn::setValidationGroup

      setValidationGroup( string $value );

      Parameters

      $value

      the group of validators which the edit or update button causes validation upon postback

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:17 +0200 by phpDocumentor 1.4.3


Docs For Class TEmailAddressValidator

Class TEmailAddressValidator

[line 31]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TRegularExpressionValidator
                     |
                     --TEmailAddressValidator
Location: /Web/UI/WebControls/TEmailAddressValidator.php

Remarks

TEmailAddressValidator class

TEmailAddressValidator validates whether the value of an associated input component is a valid email address. If CheckMXRecord is true, it will check MX record for the email adress, provided checkdnsrr() is available in the installed PHP.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TEmailAddressValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • EMAIL_REGEXP = "\\w+([-+.]\\w+)*@\\w+([-.]\\w+)*\\.\\w+([-.]\\w+)*"
    Regular expression used to validate the email address

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TRegularExpressionValidator

  • TRegularExpressionValidator::evaluateIsValid()
    This method overrides the parent's implementation.
  • TRegularExpressionValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
  • TRegularExpressionValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
  • TRegularExpressionValidator::getClientSidePatternModifiers()
  • TRegularExpressionValidator::getPatternModifiers()
  • TRegularExpressionValidator::getRegularExpression()
  • TRegularExpressionValidator::setClientSidePatternModifiers()
  • TRegularExpressionValidator::setPatternModifiers()
  • TRegularExpressionValidator::setRegularExpression()

Inherited From Class TBaseValidator

  • TBaseValidator::__construct()
    Constructor.
  • TBaseValidator::addAttributesToRender()
    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
  • TBaseValidator::createClientSide()
  • TBaseValidator::evaluateIsValid()
    This is the major method for validation.
  • TBaseValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
  • TBaseValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
  • TBaseValidator::getClientSide()
    Gets the TValidatorClientSide that allows modification of the client- side validator events.
  • TBaseValidator::getControlCssClass()
  • TBaseValidator::getControlToValidate()
  • TBaseValidator::getDisplay()
  • TBaseValidator::getEnableClientScript()
  • TBaseValidator::getErrorMessage()
  • TBaseValidator::getFocusElementID()
    Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::getFocusOnError()
  • TBaseValidator::getIsValid()
  • TBaseValidator::getValidationGroup()
  • TBaseValidator::getValidationTarget()
  • TBaseValidator::getValidationValue()
    Retrieves the property value of the control being validated.
  • TBaseValidator::onInit()
    Registers the validator with page.
  • TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
  • TBaseValidator::onUnload()
    Unregisters the validator from page.
  • TBaseValidator::onValidate()
    This event is raised right before the validator starts to perform validation.
  • TBaseValidator::onValidationError()
    This event is raised when the validator fails in validation.
  • TBaseValidator::onValidationSuccess()
    This event is raised when the validator succeeds in validation.
  • TBaseValidator::registerClientScriptValidator()
    Registers the individual validator client-side javascript code.
  • TBaseValidator::renderClientControlScript()
    Renders the javascript code to the end script.
  • TBaseValidator::renderContents()
    Renders the validator control.
  • TBaseValidator::setControlCssClass()
  • TBaseValidator::setControlToValidate()
    Sets the ID path of the input control to validate.
  • TBaseValidator::setDisplay()
  • TBaseValidator::setEnableClientScript()
  • TBaseValidator::setEnabled()
    This method overrides parent's implementation by setting setIsValid to true if disabled.
  • TBaseValidator::setErrorMessage()
    Sets the text for the error message.
  • TBaseValidator::setFocusElementID()
    Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::setFocusOnError()
  • TBaseValidator::setForControl()
    This method overrides the parent implementation to forbid setting ForControl.
  • TBaseValidator::setIsValid()
    Sets the value indicating whether the validation succeeds
  • TBaseValidator::setValidationGroup()
  • TBaseValidator::updateControlCssClass()
    Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
  • TBaseValidator::validate()
    Validates the specified control.

Inherited From Class TLabel

  • TLabel::addAttributesToRender()
    Adds attributes to renderer.
  • TLabel::getData()
    Returns the text value of the label.
  • TLabel::getForControl()
  • TLabel::getTagName()
  • TLabel::getText()
  • TLabel::render()
    Renders the label.
  • TLabel::renderContents()
    Renders the body content of the label.
  • TLabel::setData()
    Sets the text value of the label.
  • TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
  • TLabel::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TEmailAddressValidator::evaluateIsValid

    evaluateIsValid( );

    Overrides TRegularExpressionValidator::evaluateIsValid() (This method overrides the parent's implementation.)

    Returns

    javascript validator options.

    Remarks

    Returns an array of javascript validator options.

    access

    public

    [ Top ]

    TEmailAddressValidator::getCheckMXRecord

    getCheckMXRecord( );

    Returns

    whether to check MX record for the email address being validated. Defaults to true.

    access

    public

    [ Top ]

    TEmailAddressValidator::getClientClassName

    getClientClassName( );

    Overrides TRegularExpressionValidator::getClientClassName() (Gets the name of the javascript class responsible for performing validation for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing validation for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TEmailAddressValidator::getRegularExpression

    getRegularExpression( );

    Overrides TRegularExpressionValidator::getRegularExpression() (parent method not documented)

    Returns

    the regular expression that determines the pattern used to validate a field.

    access

    public

    [ Top ]

    TEmailAddressValidator::setCheckMXRecord

    setCheckMXRecord( boolean $value );

    Parameters

    $value

    whether to check MX record for the email address being validated. Note, if http://www.php.net/checkdnsrr is not available, this check will not be performed.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • EMAIL_REGEXP = "\\w+([-+.]\\w+)*@\\w+([-.]\\w+)*\\.\\w+([-.]\\w+)*" [line 36]

    • Remarks

    Regular expression used to validate the email address

Documentation generated on Mon, 25 Jun 2012 14:44:17 +0200 by phpDocumentor 1.4.3


Docs For Class TExpression

Class TExpression

[line 29]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TExpression
Location: /Web/UI/WebControls/TExpression.php

Remarks

TExpression class

TExpression evaluates a PHP expression and renders the result. The expression is evaluated during the rendering stage. The expression being evaluated can be set via the property Expression. The context of the expression evaluated is the TExpression object itself.

Note, since TExpression allows evaluation of arbitrary PHP expression, make sure Expression does not come directly from user input.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TExpression.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TExpression::getExpression

    getExpression( );

    Returns

    the expression to be evaluated

    access

    public

    [ Top ]

    TExpression::render

    render( THtmlWriter $writer );

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the evaluation result of the expression.

    access

    public

    [ Top ]

    TExpression::setExpression

    setExpression( string $value );

    Parameters

    $value

    the expression to be evaluated

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:20 +0200 by phpDocumentor 1.4.3


Docs For Class TFileUpload

Class TFileUpload

[line 35]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TFileUpload
Classes extended from TFileUpload:
TActiveFileUpload
TActiveFileUpload

Location: /Web/UI/WebControls/TFileUpload.php

Remarks

TFileUpload class

TFileUpload displays a file upload field on a page. Upon postback, the text entered into the field will be treated as the name of the file that will be uploaded to the server. The property HasFile indicates whether the file upload is successful. If successful, the file may be obtained by calling saveAs to save it at a specified place. You can use FileName, FileType, FileSize to get the original client-side file name, the file mime type, and the file size information. If the upload is not successful, ErrorCode contains the error code describing the cause of failure.

TFileUpload raises OnFileUpload event if a file is uploaded (whether it succeeds or not).

author

Marcus Nyeholt <tanus@users.sourceforge.net>, Qiang Xue <qiang.xue@gmail.com>

version

$Id: TFileUpload.php 3082 2011-12-21 12:55:05Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

  • $_errorCode = UPLOAD_ERR_NO_FILE

Class Constant Summary

  • MAX_FILE_SIZE = 1048576
    Maximum file size (in bytes) allowed to be uploaded, defaults to 1MB.

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TFileUpload::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveFileUpload::addAttributesToRender()
    Adds ID attribute, and renders the javascript for active component.

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Sets name attribute to the unique ID of the control.

    This method overrides the parent implementation with additional file update control specific attributes.

    access

    protected

    [ Top ]

    TFileUpload::getDataChanged

    getDataChanged( );

    Returns

    whether postback has caused the control data change. False if the page is not in postback mode.

    Remarks

    Returns a value indicating whether postback has caused the control data change.

    This method is required by the IPostBackDataHandler interface.

    access

    public

    [ Top ]

    TFileUpload::getErrorCode

    getErrorCode( );

    Returns

    the error code

    Remarks

    Returns an error code describing the status of this file uploading.

    see

    http://www.php.net/manual/en/features.file-upload.errors.php

    access

    public

    [ Top ]

    TFileUpload::getFileName

    getFileName( );

    Returns

    the original full path name of the file on the client machine

    access

    public

    [ Top ]

    TFileUpload::getFileSize

    getFileSize( );

    Returns

    the actual size of the uploaded file in bytes

    access

    public

    [ Top ]

    TFileUpload::getFileType

    getFileType( );

    Returns

    the MIME-type of the uploaded file (such as "image/gif"). This mime type is not checked on the server side and do not take its value for granted.

    access

    public

    [ Top ]

    TFileUpload::getHasFile

    getHasFile( );

    Returns

    whether the file is uploaded successfully

    access

    public

    [ Top ]

    TFileUpload::getIsValid

    getIsValid( );

    Returns

    wether this control validated successfully.

    Remarks

    Returns true if this control validated successfully.

    Defaults to true.

    access

    public

    [ Top ]

    TFileUpload::getLocalName

    getLocalName( );

    Returns

    the local name of the file (where it is after being uploaded). Note, PHP will delete this file automatically after finishing this round of request.

    access

    public

    [ Top ]

    TFileUpload::getMaxFileSize

    getMaxFileSize( );

    Returns

    the maximum file size, defaults to 1MB (1048576 bytes).

    see

    TFileUpload::setMaxFileSize()

    access

    public

    [ Top ]

    TFileUpload::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name of the file upload control

    access

    protected

    [ Top ]

    TFileUpload::getValidationPropertyValue

    getValidationPropertyValue( );

    Returns

    the property value to be validated

    Remarks

    Returns the original file name as the property value to be validated.

    This method is required by IValidatable property.

    access

    public

    [ Top ]

    TFileUpload::loadPostData

    loadPostData( string $key, array $values );

    Parameters

    $key

    the key that can be used to retrieve data from the input data collection

    $values

    the input data collection

    Returns

    whether the data of the control has been changed

    Remarks

    Loads user input data.

    This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TFileUpload::onFileUpload

    onFileUpload( TEventParameter $param );

    Overridden in child classes as:

    TActiveFileUpload::onFileUpload()
    This method is invoked when a file is uploaded.

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a file is uploaded during a postback.

    The method raises OnFileUpload event to fire up the event handler. If you override this method, be sure to call the parent implementation so that the event delegates can be invoked.

    access

    public

    [ Top ]

    TFileUpload::onPreRender

    onPreRender( mixed $param );

    Overridden in child classes as:

    TActiveFileUpload::onPreRender()
    Publish the javascript

    Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

    Parameters

    $param

    event parameter

    Remarks

    Sets Enctype of the form on the page.

    This method overrides the parent implementation and is invoked before render.

    access

    public

    [ Top ]

    TFileUpload::raisePostDataChangedEvent

    raisePostDataChangedEvent( );

    Overridden in child classes as:

    TActiveFileUpload::raisePostDataChangedEvent()
    Raises postdata changed event.

    Remarks

    Raises postdata changed event.

    This method calls onFileUpload method. This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TFileUpload::saveAs

    saveAs( string $fileName, [boolean $deleteTempFile = true] );

    Overridden in child classes as:

    TActiveFileUpload::saveAs()
    Saves the uploaded file.

    Parameters

    $fileName

    the file name used to save the uploaded file

    $deleteTempFile

    whether to delete the temporary file after saving. If true, you will not be able to save the uploaded file again.

    Returns

    true if the file saving is successful

    Remarks

    Saves the uploaded file.

    access

    public

    [ Top ]

    TFileUpload::setIsValid

    setIsValid( bool $value );

    Parameters

    $value

    wether this control is valid.

    access

    public

    [ Top ]

    TFileUpload::setMaxFileSize

    setMaxFileSize( int $size );

    Parameters

    $size

    the maximum upload size allowed for a file.

    Remarks

    Sets the maximum size that a file can be uploaded.

    Note, this is an advisory value to the browser. Sets this property with a reasonably large size to save users the trouble of waiting for a big file being transferred only to find that it was too big and the transfer failed.

    access

    public

    [ Top ]

Variable Detail

  • $_errorCode = UPLOAD_ERR_NO_FILE [line 60]
  • Data type: integer

    • var

    error code of the current file upload

    access

    protected

Class Constant Detail

  • MAX_FILE_SIZE = 1048576 [line 40]

    • Remarks

    Maximum file size (in bytes) allowed to be uploaded, defaults to 1MB.

Documentation generated on Mon, 25 Jun 2012 14:44:20 +0200 by phpDocumentor 1.4.3


Docs For Class TFlushOutput

Class TFlushOutput

[line 36]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TFlushOutput
Location: /Web/UI/WebControls/TFlushOutput.php

Remarks

TFlushOutput class.

TFlushOutput enables forced flushing of the current output buffer at (a) certain point(s) in the page, after rendering of all previous controls has been completed.

To use TFlushOutput, simply place it in a template where you want the have the output buffered between the start of the page or the last TFlushOutput to be sent to the client immediately

  •  <com:TFlushOutput />
    •

    You can specify whether you want to keep buffering of the output (if it was enabled) till the next occourence of a <com: TFlushOutput /> or the end of the page rendering, or stop buffering, by using the ContinueBuffering.

    author

    Berczi Gabor <gabor.berczi@devworx.hu>

    version

    $Id: TFlushOutput.php $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TFlushOutput::__construct

      __construct( );

      Overrides TControl::__construct() (Constructor.)

      Remarks

      Constructor.

      access

      public

      [ Top ]

      TFlushOutput::getContinueBuffering

      getContinueBuffering( );

      Returns

      whether buffering of output can continue after this point

      access

      public

      [ Top ]

      TFlushOutput::render

      render( THtmlWriter $writer );

      Overrides TControl::render() (Renders the control.)

      Parameters

      $writer

      writer for the rendering purpose

      Remarks

      Flushes the output of all completely rendered controls to the client.

      access

      public

      [ Top ]

      TFlushOutput::setContinueBuffering

      setContinueBuffering( boolean $value );

      Parameters

      $value

      sets whether buffering of output can continue after this point

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:21 +0200 by phpDocumentor 1.4.3


Docs For Class TFont

Class TFont

[line 23]
TComponent
   |
   --TFont
Location: /Web/UI/WebControls/TFont.php

Remarks

TFont class

TFont encapsulates the CSS style fields related with font settings.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TFont.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • IS_BOLD = 0x01
    Bits indicating the font states.
  • IS_ITALIC = 0x02
  • IS_OVERLINE = 0x04
  • IS_SET_BOLD = 0x01000
    Bits indicating whether particular font states are changed.
  • IS_SET_ITALIC = 0x02000
  • IS_SET_NAME = 0x40000
  • IS_SET_OVERLINE = 0x04000
  • IS_SET_SIZE = 0x20000
  • IS_SET_STRIKEOUT = 0x08000
  • IS_SET_UNDERLINE = 0x10000
  • IS_STRIKEOUT = 0x08
  • IS_UNDERLINE = 0x10

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TFont::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attributes related to CSS styles to renderer.

    access

    public

    [ Top ]

    TFont::copyFrom

    copyFrom( TFont $font );

    Parameters

    $font

    the new font

    Remarks

    Copies the fields in a new font to this font.

    If a font field is set in the new font, the corresponding field in this font will be overwritten.

    access

    public

    [ Top ]

    TFont::getBold

    getBold( );

    Returns

    whether the font is in bold face. Defaults to false.

    access

    public

    [ Top ]

    TFont::getIsEmpty

    getIsEmpty( );

    Returns

    whether the font is empty

    access

    public

    [ Top ]

    TFont::getItalic

    getItalic( );

    Returns

    whether the font is in italic face. Defaults to false.

    access

    public

    [ Top ]

    TFont::getName

    getName( );

    Returns

    the font name (family)

    access

    public

    [ Top ]

    TFont::getOverline

    getOverline( );

    Returns

    whether the font is overlined. Defaults to false.

    access

    public

    [ Top ]

    TFont::getSize

    getSize( );

    Returns

    the font size

    access

    public

    [ Top ]

    TFont::getStrikeout

    getStrikeout( );

    Returns

    whether the font is strikeout. Defaults to false.

    access

    public

    [ Top ]

    TFont::getUnderline

    getUnderline( );

    Returns

    whether the font is underlined. Defaults to false.

    access

    public

    [ Top ]

    TFont::mergeWith

    mergeWith( TFont $font );

    Parameters

    $font

    the new font

    Remarks

    Merges the font with a new one.

    If a font field is not set in the font, it will be overwritten with the new one.

    access

    public

    [ Top ]

    TFont::reset

    reset( );

    Remarks

    Clears up the font.

    access

    public

    [ Top ]

    TFont::setBold

    setBold( boolean $value );

    Parameters

    $value

    whether the font is in bold face

    access

    public

    [ Top ]

    TFont::setItalic

    setItalic( boolean $value );

    Parameters

    $value

    whether the font is italic

    access

    public

    [ Top ]

    TFont::setName

    setName( string $value );

    Parameters

    $value

    the font name (family)

    access

    public

    [ Top ]

    TFont::setOverline

    setOverline( boolean $value );

    Parameters

    $value

    whether the font is overlined

    access

    public

    [ Top ]

    TFont::setSize

    setSize( string $value );

    Parameters

    $value

    the font size

    access

    public

    [ Top ]

    TFont::setStrikeout

    setStrikeout( boolean $value );

    Parameters

    $value

    whether the font is strikeout

    access

    public

    [ Top ]

    TFont::setUnderline

    setUnderline( boolean $value );

    Parameters

    $value

    whether the font is underlined

    access

    public

    [ Top ]

    TFont::toString

    toString( );

    Returns

    the font in a css style string representation.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • IS_BOLD = 0x01 [line 28]

    • Remarks

    Bits indicating the font states.

  • IS_ITALIC = 0x02 [line 29]

  • IS_OVERLINE = 0x04 [line 30]

  • IS_SET_BOLD = 0x01000 [line 37]

    • Remarks

    Bits indicating whether particular font states are changed.

  • IS_SET_ITALIC = 0x02000 [line 38]

  • IS_SET_NAME = 0x40000 [line 43]

  • IS_SET_OVERLINE = 0x04000 [line 39]

  • IS_SET_SIZE = 0x20000 [line 42]

  • IS_SET_STRIKEOUT = 0x08000 [line 40]

  • IS_SET_UNDERLINE = 0x10000 [line 41]

  • IS_STRIKEOUT = 0x08 [line 31]

  • IS_UNDERLINE = 0x10 [line 32]

Documentation generated on Mon, 25 Jun 2012 14:44:21 +0200 by phpDocumentor 1.4.3


Docs For Class TMetaTag

Class TMetaTag

[line 193]
TComponent
   |
   --TMetaTag
Location: /Web/UI/WebControls/THead.php

Remarks

TMetaTag class.

TMetaTag represents a meta tag appearing in a page head section. You can set its ID, HttpEquiv, Name, Content, Scheme properties, which correspond to id, http-equiv, name, content, and scheme attributes for a meta tag, respectively.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THead.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TMetaTag::getContent

    getContent( );

    Returns

    content attribute of the meta tag

    access

    public

    [ Top ]

    TMetaTag::getHttpEquiv

    getHttpEquiv( );

    Returns

    http-equiv attribute of the meta tag

    access

    public

    [ Top ]

    TMetaTag::getID

    getID( );

    Returns

    id of the meta tag

    access

    public

    [ Top ]

    TMetaTag::getName

    getName( );

    Returns

    name attribute of the meta tag

    access

    public

    [ Top ]

    TMetaTag::getScheme

    getScheme( );

    Returns

    scheme attribute of the meta tag

    access

    public

    [ Top ]

    TMetaTag::render

    render( THtmlWriter $writer );

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the meta tag.

    access

    public

    [ Top ]

    TMetaTag::setContent

    setContent( string $value );

    Parameters

    $value

    content attribute of the meta tag

    access

    public

    [ Top ]

    TMetaTag::setHttpEquiv

    setHttpEquiv( string $value );

    Parameters

    $value

    http-equiv attribute of the meta tag

    access

    public

    [ Top ]

    TMetaTag::setID

    setID( string $value );

    Parameters

    $value

    id of the meta tag

    access

    public

    [ Top ]

    TMetaTag::setName

    setName( string $value );

    Parameters

    $value

    name attribute of the meta tag

    access

    public

    [ Top ]

    TMetaTag::setScheme

    setScheme( string $value );

    Parameters

    $value

    scheme attribute of the meta tag

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:23 +0200 by phpDocumentor 1.4.3


Docs For Class TMetaTagCollection

Class TMetaTagCollection

[line 328]
TComponent
   |
   --TList
      |
      --TMetaTagCollection
Location: /Web/UI/WebControls/THead.php

Remarks

TMetaTagCollection class

TMetaTagCollection represents a collection of meta tags contained in a THead control.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THead.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TMetaTagCollection::findIndexByID

    findIndexByID( string $id );

    Parameters

    $id

    the ID of the meta tag to be looked for

    Returns

    the index of the meta tag found, -1 if not found.

    Remarks

    Finds the lowest cardinal index of the meta tag whose id is the one being looked for.

    access

    public

    [ Top ]

    TMetaTagCollection::findMetaTagByID

    findMetaTagByID( string $id );

    Parameters

    $id

    the id of the meta tag to be looked for

    Returns

    the meta tag found, null if not found.

    Remarks

    Finds the item whose value is the one being looked for.

    access

    public

    [ Top ]

    TMetaTagCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TList::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by performing type check on the item being added.

    throws

    TInvalidDataTypeException if the item to be inserted is not a TMetaTag

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:23 +0200 by phpDocumentor 1.4.3


Docs For Class THeader1

Class THeader1

[line 26]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --THtmlElement
               |
               --THeader1
Location: /Web/UI/WebControls/THeader1.php

Remarks

THeader1 class

This is a simple class to enable your application to have headers but then have your theme be able to redefine the TagName This is also useful for the TWebControlDecorator (used by themes).

author

Brad Anderson <javalizard@gmail.com>

version

$Id: THeader1.php 2541 2008-10-21 15:05:13Z javalizard $

since

3.2a

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class THtmlElement

  • THtmlElement::getDefaultTagName()
    This is the default tag when no other is specified
  • THtmlElement::getIsMutated()
    This tells you if this TagName has deviated from the original
  • THtmlElement::getTagName()
  • THtmlElement::setTagName()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THeader1::getDefaultTagName

    getDefaultTagName( );

    Overrides THtmlElement::getDefaultTagName() (This is the default tag when no other is specified)

    Returns

    tag name

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:24 +0200 by phpDocumentor 1.4.3


Docs For Class THeader2

Class THeader2

[line 26]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --THtmlElement
               |
               --THeader2
Location: /Web/UI/WebControls/THeader2.php

Remarks

THeader2 class

This is a simple class to enable your application to have headers but then have your theme be able to redefine the TagName This is also useful for the TWebControlDecorator (used by themes).

author

Brad Anderson <javalizard@gmail.com>

version

$Id: THeader2.php 2541 2008-10-21 15:05:13Z javalizard $

since

3.2a

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class THtmlElement

  • THtmlElement::getDefaultTagName()
    This is the default tag when no other is specified
  • THtmlElement::getIsMutated()
    This tells you if this TagName has deviated from the original
  • THtmlElement::getTagName()
  • THtmlElement::setTagName()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THeader2::getDefaultTagName

    getDefaultTagName( );

    Overrides THtmlElement::getDefaultTagName() (This is the default tag when no other is specified)

    Returns

    tag name

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:24 +0200 by phpDocumentor 1.4.3


Docs For Class THeader3

Class THeader3

[line 26]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --THtmlElement
               |
               --THeader3
Location: /Web/UI/WebControls/THeader3.php

Remarks

THeader3 class

This is a simple class to enable your application to have headers but then have your theme be able to redefine the TagName This is also useful for the TWebControlDecorator (used by themes).

author

Brad Anderson <javalizard@gmail.com>

version

$Id: THeader3.php 2541 2008-10-21 15:05:13Z javalizard $

since

3.2a

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class THtmlElement

  • THtmlElement::getDefaultTagName()
    This is the default tag when no other is specified
  • THtmlElement::getIsMutated()
    This tells you if this TagName has deviated from the original
  • THtmlElement::getTagName()
  • THtmlElement::setTagName()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THeader3::getDefaultTagName

    getDefaultTagName( );

    Overrides THtmlElement::getDefaultTagName() (This is the default tag when no other is specified)

    Returns

    tag name

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:25 +0200 by phpDocumentor 1.4.3


Docs For Class THeader4

Class THeader4

[line 26]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --THtmlElement
               |
               --THeader4
Location: /Web/UI/WebControls/THeader4.php

Remarks

THeader4 class

This is a simple class to enable your application to have headers but then have your theme be able to redefine the TagName This is also useful for the TWebControlDecorator (used by themes).

author

Brad Anderson <javalizard@gmail.com>

version

$Id: THeader4.php 2541 2008-10-21 15:05:13Z javalizard $

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class THtmlElement

  • THtmlElement::getDefaultTagName()
    This is the default tag when no other is specified
  • THtmlElement::getIsMutated()
    This tells you if this TagName has deviated from the original
  • THtmlElement::getTagName()
  • THtmlElement::setTagName()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THeader4::getDefaultTagName

    getDefaultTagName( );

    Overrides THtmlElement::getDefaultTagName() (This is the default tag when no other is specified)

    Returns

    tag name

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:25 +0200 by phpDocumentor 1.4.3


Docs For Class THeader5

Class THeader5

[line 26]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --THtmlElement
               |
               --THeader5
Location: /Web/UI/WebControls/THeader5.php

Remarks

THeader5 class

This is a simple class to enable your application to have headers but then have your theme be able to redefine the TagName This is also useful for the TWebControlDecorator (used by themes).

author

Brad Anderson <javalizard@gmail.com>

version

$Id: THeader5.php 2541 2008-10-21 15:05:13Z javalizard $

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class THtmlElement

  • THtmlElement::getDefaultTagName()
    This is the default tag when no other is specified
  • THtmlElement::getIsMutated()
    This tells you if this TagName has deviated from the original
  • THtmlElement::getTagName()
  • THtmlElement::setTagName()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THeader5::getDefaultTagName

    getDefaultTagName( );

    Overrides THtmlElement::getDefaultTagName() (This is the default tag when no other is specified)

    Returns

    tag name

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:26 +0200 by phpDocumentor 1.4.3


Docs For Class THeader6

Class THeader6

[line 26]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --THtmlElement
               |
               --THeader6
Location: /Web/UI/WebControls/THeader6.php

Remarks

THeader6 class

This is a simple class to enable your application to have headers but then have your theme be able to redefine the TagName This is also useful for the TWebControlDecorator (used by themes).

author

Brad Anderson <javalizard@gmail.com>

version

$Id: THeader6.php 2541 2008-10-21 15:05:13Z javalizard $

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class THtmlElement

  • THtmlElement::getDefaultTagName()
    This is the default tag when no other is specified
  • THtmlElement::getIsMutated()
    This tells you if this TagName has deviated from the original
  • THtmlElement::getTagName()
  • THtmlElement::setTagName()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THeader6::getDefaultTagName

    getDefaultTagName( );

    Overrides THtmlElement::getDefaultTagName() (This is the default tag when no other is specified)

    Returns

    tag name

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:26 +0200 by phpDocumentor 1.4.3


Docs For Class THiddenField

Class THiddenField

[line 26]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --THiddenField
Classes extended from THiddenField:
TActiveHiddenField
TActiveHiddenField class

Location: /Web/UI/WebControls/THiddenField.php

Remarks

THiddenField class

THiddenField displays a hidden input field on a Web page. The value of the input field can be accessed via Value property. If upon postback the value is changed, a OnValueChanged event will be raised.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THiddenField.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THiddenField::focus

    focus( );

    Overrides TControl::focus() (Sets input focus to this control.)

    Remarks

    Sets focus to this control.

    This method overrides the parent implementation by forbidding setting focus to this control.

    access

    public

    [ Top ]

    THiddenField::getData

    getData( );

    Returns

    value of the hidden field

    Remarks

    Returns the value of the hidden field.

    This method is required by IDataRenderer. It is the same as getValue().

    see

    THiddenField::getValue()

    since

    3.1.0

    access

    public

    [ Top ]

    THiddenField::getDataChanged

    getDataChanged( );

    Returns

    whether postback has caused the control data change. False if the page is not in postback mode.

    Remarks

    Returns a value indicating whether postback has caused the control data change.

    This method is required by the IPostBackDataHandler interface.

    access

    public

    [ Top ]

    THiddenField::getEnableTheming

    getEnableTheming( );

    Overrides TControl::getEnableTheming() (parent method not documented)

    Returns

    whether theming is enabled for this control. Defaults to false.

    access

    public

    [ Top ]

    THiddenField::getIsValid

    getIsValid( );

    Returns

    wether this control validated successfully.

    Remarks

    Returns true if this control validated successfully.

    Defaults to true.

    access

    public

    [ Top ]

    THiddenField::getTagName

    getTagName( );

    Returns

    tag name of the hidden field.

    access

    protected

    [ Top ]

    THiddenField::getValidationPropertyValue

    getValidationPropertyValue( );

    Returns

    the value of the property to be validated.

    Remarks

    Returns the value to be validated.

    This methid is required by IValidatable interface.

    access

    public

    [ Top ]

    THiddenField::getValue

    getValue( );

    Returns

    the value of the THiddenField

    access

    public

    [ Top ]

    THiddenField::loadPostData

    loadPostData( string $key, array $values );

    Parameters

    $key

    the key that can be used to retrieve data from the input data collection

    $values

    the input data collection

    Returns

    whether the data of the component has been changed

    Remarks

    Loads hidden field data.

    This method is primarly used by framework developers.

    access

    public

    [ Top ]

    THiddenField::onValueChanged

    onValueChanged( TEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the value of the getValue property changes between posts to the server.

    The method raises 'OnValueChanged' event to fire up the event delegates. If you override this method, be sure to call the parent implementation so that the attached event handlers can be invoked.

    access

    public

    [ Top ]

    THiddenField::raisePostDataChangedEvent

    raisePostDataChangedEvent( );

    Remarks

    Raises postdata changed event.

    This method calls onValueChanged method. This method is primarly used by framework developers.

    access

    public

    [ Top ]

    THiddenField::render

    render( THtmlWriter $writer );

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the control.

    This method overrides the parent implementation by rendering the hidden field input element.

    access

    public

    [ Top ]

    THiddenField::setData

    setData( string $value );

    Parameters

    $value

    value of the hidden field

    Remarks

    Sets the value of the hidden field.

    This method is required by IDataRenderer. It is the same as setValue().

    see

    THiddenField::setValue()

    since

    3.1.0

    access

    public

    [ Top ]

    THiddenField::setEnableTheming

    setEnableTheming( boolean $value );

    Overrides TControl::setEnableTheming() (parent method not documented)

    Parameters

    $value

    whether theming is enabled for this control.

    throws

    TNotSupportedException This method is always thrown when calling this method.

    access

    public

    [ Top ]

    THiddenField::setIsValid

    setIsValid( bool $value );

    Parameters

    $value

    wether this control is valid.

    access

    public

    [ Top ]

    THiddenField::setSkinID

    setSkinID( string $value );

    Overrides TControl::setSkinID() (parent method not documented)

    Parameters

    $value

    Skin ID

    throws

    TNotSupportedException This method is always thrown when calling this method.

    access

    public

    [ Top ]

    THiddenField::setValue

    setValue( string $value );

    Overridden in child classes as:

    TActiveHiddenField::setValue()
    Client-side Value property can only be updated after the OnLoad stage.

    Parameters

    $value

    the value to be set

    Remarks

    Sets the value of the THiddenField

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:26 +0200 by phpDocumentor 1.4.3


Docs For Class THtmlArea

Class THtmlArea

[line 79]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --THtmlArea
Location: /Web/UI/WebControls/THtmlArea.php

Remarks

THtmlArea class

THtmlArea wraps the visual editting functionalities provided by the TinyMCE project http://tinymce.moxiecode.com/.

THtmlArea displays a WYSIWYG text area on the Web page for user input in the HTML format. The text displayed in the THtmlArea component is specified or determined by using the Text property.

To enable the visual editting on the client side, set the property EnableVisualEdit to true (which is default value). To set the size of the editor when the visual editting is enabled, set the Width and Height properties instead of Columns and Rows because the latter has no meaning under the situation.

The default editor gives only the basic tool bar. To change or add additional tool bars, use the Options property to add additional editor options with each options on a new line. See http://tinymce.moxiecode.com/tinymce/docs/index.html for a list of options. The options can be change/added as shown in the following example.

  •  <com:THtmlArea>
    •

  •       <prop:Options>
    •

  •            plugins : "contextmenu,paste"
    •

  •            language : "zh_cn"
    •

  •       </prop:Options>
    •

  •  </com:THtmlArea>
    •

    Compatibility The client-side visual editting capability is supported by Internet Explorer 5.0+ for Windows and Gecko-based browser. If the browser does not support the visual editting, a traditional textarea will be displayed.

    Browser support

  •                     Windows XP        MacOS X 10.4
    •

  •  ----------------------------------------------------
    •

  •  MSIE 6                  OK
    •

  •  MSIE 5.5 SP2            OK
    •

  •  MSIE 5.0                OK
    •

  •  Mozilla 1.7.x           OK              OK
    •

  •  Firefox 1.0.x           OK              OK
    •

  •  Firefox 1.5b2           OK              OK
    •

  •  Safari 2.0 (412)                        OK(1)
    •

  •  Opera 9 Preview 1       OK(1)           OK(1)
    •

  •  ----------------------------------------------------
    •

  •     * (1) - Partialy working
    •

  •  ----------------------------------------------------
    •

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: THtmlArea.php 3159 2012-06-01 18:01:40Z ctrlaltca $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TTextBox

    • TTextBox::DEFAULT_COLUMNS = 20
      Default number of columns (for MultiLine text box)
    • TTextBox::DEFAULT_ROWS = 4
      Default number of rows (for MultiLine text box)

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TTextBox

    • TTextBox::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TTextBox::getAutoCompleteType()
    • TTextBox::getAutoPostBack()
    • TTextBox::getAutoTrim()
    • TTextBox::getCausesValidation()
    • TTextBox::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
    • TTextBox::getColumns()
    • TTextBox::getData()
      Returns the text content of the TTextBox control.
    • TTextBox::getDataChanged()
      Returns a value indicating whether postback has caused the control data change.
    • TTextBox::getEnableClientScript()
    • TTextBox::getIsValid()
      Returns true if this control validated successfully.
    • TTextBox::getMaxLength()
    • TTextBox::getPersistPassword()
    • TTextBox::getPostBackOptions()
      Gets the post back options for this textbox.
    • TTextBox::getReadOnly()
    • TTextBox::getRows()
    • TTextBox::getSafeText()
    • TTextBox::getSafeTextParser()
    • TTextBox::getTagName()
    • TTextBox::getText()
    • TTextBox::getTextMode()
    • TTextBox::getValidationGroup()
    • TTextBox::getValidationPropertyValue()
      Returns the value to be validated.
    • TTextBox::getWrap()
    • TTextBox::loadPostData()
      Loads user input data.
    • TTextBox::onTextChanged()
      Raises OnTextChanged event.
    • TTextBox::raisePostDataChangedEvent()
      Raises postdata changed event.
    • TTextBox::renderBeginTag()
      Renders an additional line-break after the opening tag when it is in MultiLine text mode.
    • TTextBox::renderClientControlScript()
      Renders the javascript for textbox.
    • TTextBox::renderContents()
      Renders the body content of the textbox when it is in MultiLine text mode.
    • TTextBox::setAutoCompleteType()
    • TTextBox::setAutoPostBack()
      Sets the value indicating if postback automatically.
    • TTextBox::setAutoTrim()
      Sets the value indicating if the input text should be trimmed spaces
    • TTextBox::setCausesValidation()
    • TTextBox::setColumns()
      Sets the display width of the text box in characters.
    • TTextBox::setData()
      Sets the text content of the TTextBox control.
    • TTextBox::setEnableClientScript()
    • TTextBox::setIsValid()
    • TTextBox::setMaxLength()
      Sets the maximum number of characters allowed in the text box.
    • TTextBox::setPersistPassword()
    • TTextBox::setReadOnly()
    • TTextBox::setRows()
      Sets the number of rows displayed in a multiline text box.
    • TTextBox::setText()
      Sets the text content of the TTextBox control.
    • TTextBox::setTextMode()
      Sets the behavior mode of the TTextBox component.
    • TTextBox::setValidationGroup()
    • TTextBox::setWrap()
      Sets the value indicating whether the text content wraps within a multiline text box.

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      THtmlArea::__construct

      __construct( );

      Overrides TControl::__construct() (Constructor.)

      Remarks

      Constructor.

      Sets default width and height.

      access

      public

      [ Top ]

      THtmlArea::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overrides TTextBox::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

      Parameters

      $writer

      the writer used for the rendering purpose

      Remarks

      Adds attribute name-value pairs to renderer.

      This method overrides the parent implementation by registering additional javacript code.

      access

      protected

      [ Top ]

      THtmlArea::copyCustomPlugins

      copyCustomPlugins( $url );

      Parameters

      $url

      access

      protected

      [ Top ]

      THtmlArea::getAutoPostBack

      getAutoPostBack( );

      Overrides TTextBox::getAutoPostBack() (parent method not documented)

      Returns

      whether change of the content should cause postback. Return false if EnableVisualEdit is true.

      access

      public

      [ Top ]

      THtmlArea::getAvailablePlugins

      getAvailablePlugins( );

      Returns

      list of plugins to be loaded

      Remarks

      Returns a list of plugins to be loaded.

      Override this method to customize.

      access

      public

      [ Top ]

      THtmlArea::getAvailableThemes

      getAvailableThemes( );

      Returns

      list of available themese

      access

      public

      [ Top ]

      THtmlArea::getClientClassName

      getClientClassName( );

      Overrides TTextBox::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

      Returns

      the javascript class name

      Remarks

      Gets the name of the javascript class responsible for performing postback for this control.

      This method overrides the parent implementation.

      access

      protected

      [ Top ]

      THtmlArea::getCompressionOptions

      getCompressionOptions( );

      access

      protected

      [ Top ]

      THtmlArea::getCulture

      getCulture( );

      Returns

      current culture, e.g. en_AU.

      Remarks

      Gets the current culture.

      access

      public

      [ Top ]

      THtmlArea::getCustomPluginPath

      getCustomPluginPath( );

      Returns

      path to custom plugins to be copied.

      access

      public

      [ Top ]

      THtmlArea::getEditorOptions

      getEditorOptions( );

      Returns

      editor initialization options.

      Remarks

      Default editor options gives basic tool bar only.

      access

      protected

      [ Top ]

      THtmlArea::getEnableCompression

      getEnableCompression( );

      Returns

      enable compression of the javascript files, default is true.

      access

      public

      [ Top ]

      THtmlArea::getEnableVisualEdit

      getEnableVisualEdit( );

      Returns

      whether to show WYSIWYG text editor. Defaults to true.

      access

      public

      [ Top ]

      THtmlArea::getLanguageSuffix

      getLanguageSuffix( $culture );

      Parameters

      $culture

      Returns

      localized editor interface language extension.

      access

      protected

      [ Top ]

      THtmlArea::getOptions

      getOptions( );

      Returns

      options

      Remarks

      Gets the list of options for the WYSIWYG (TinyMCE) editor

      see

      http://tinymce.moxiecode.com/tinymce/docs/index.html

      access

      public

      [ Top ]

      THtmlArea::getScriptDeploymentPath

      getScriptDeploymentPath( );

      Returns

      URL base path to the published editor script

      Remarks

      Gets the editor script base URL by publishing the tarred source via TTarAssetManager.

      access

      protected

      [ Top ]

      THtmlArea::getScriptUrl

      getScriptUrl( );

      Returns

      editor script URL.

      access

      protected

      [ Top ]

      THtmlArea::getTextMode

      getTextMode( );

      Overrides TTextBox::getTextMode() (parent method not documented)

      Returns

      the behavior mode of the THtmlArea component.

      Remarks

      Overrides the parent implementation.

      TextMode for THtmlArea control is always 'MultiLine'

      access

      public

      [ Top ]

      THtmlArea::loadJavascriptLibrary

      loadJavascriptLibrary( );

      access

      protected

      [ Top ]

      THtmlArea::parseEditorOptions

      parseEditorOptions( $string );

      Parameters

      $string

      Returns

      additional custom options

      Remarks

      Parse additional options set in the Options property.

      access

      protected

      [ Top ]

      THtmlArea::registerEditorClientScript

      registerEditorClientScript( $writer );

      Parameters

      $writer

      Remarks

      Registers the editor javascript file and code to initialize the editor.

      access

      protected

      [ Top ]

      THtmlArea::setCulture

      setCulture( string $value );

      Parameters

      $value

      a culture string, e.g. en_AU.

      Remarks

      Sets the culture/language for the html area

      access

      public

      [ Top ]

      THtmlArea::setCustomPluginPath

      setCustomPluginPath( string $value );

      Parameters

      $value

      path to custom plugins to be copied.

      access

      public

      [ Top ]

      THtmlArea::setEnableCompression

      setEnableCompression( boolean $value );

      Parameters

      $value

      enable compression of the javascript files, default is true.

      access

      public

      [ Top ]

      THtmlArea::setEnableVisualEdit

      setEnableVisualEdit( boolean $value );

      Parameters

      $value

      whether to show WYSIWYG text editor

      Remarks

      Sets whether to show WYSIWYG text editor.

      access

      public

      [ Top ]

      THtmlArea::setOptions

      setOptions( string $value );

      Parameters

      $value

      options

      Remarks

      Sets the list of options for the WYSIWYG (TinyMCE) editor

      see

      http://tinymce.moxiecode.com/tinymce/docs/index.html

      access

      public

      [ Top ]

      THtmlArea::setTextMode

      setTextMode( string $value );

      Overrides TTextBox::setTextMode() (Sets the behavior mode of the TTextBox component.)

      Parameters

      $value

      the text mode

      Remarks

      Overrides the parent implementation.

      TextMode for THtmlArea is always 'MultiLine' and cannot be changed to others.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:27 +0200 by phpDocumentor 1.4.3


Docs For Class THtmlElement

Class THtmlElement

[line 30]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --THtmlElement
Classes extended from THtmlElement:
THeader1
THeader1 class
THeader2
THeader2 class
THeader3
THeader3 class
THeader4
THeader4 class
THeader5
THeader5 class
THeader6
THeader6 class

Location: /Web/UI/WebControls/THtmlElement.php

Remarks

THtmlElement class.

THtmlElement represents a generic HTML element whose tag name is specified via TagName property. Because THtmlElement extends from TWebControl, it enjoys all its functionalities.

To change the default tag your subclass should override getDefaultTagName

author

Brad Anderson <javalizard@gmail.com>

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THtmlElement.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THtmlElement::getDefaultTagName

    getDefaultTagName( );

    Overridden in child classes as:

    THeader1::getDefaultTagName()
    THeader2::getDefaultTagName()
    THeader3::getDefaultTagName()
    THeader4::getDefaultTagName()
    THeader5::getDefaultTagName()
    THeader6::getDefaultTagName()

    Returns

    the default tag

    Remarks

    This is the default tag when no other is specified

    access

    public

    [ Top ]

    THtmlElement::getIsMutated

    getIsMutated( );

    Returns

    true if TagName has deviated from the default.

    Remarks

    This tells you if this TagName has deviated from the original

    access

    public

    [ Top ]

    THtmlElement::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    the tag name of this control. Defaults to 'span'.

    access

    public

    [ Top ]

    THtmlElement::setTagName

    setTagName( string $value );

    Parameters

    $value

    the tag name of this control.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:28 +0200 by phpDocumentor 1.4.3


Docs For Class THyperLink

Class THyperLink

[line 30]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --THyperLink
Classes extended from THyperLink:
TActiveHyperLink
TActiveHyperLink class.

Location: /Web/UI/WebControls/THyperLink.php

Remarks

THyperLink class

THyperLink displays a hyperlink on a page. The hyperlink URL is specified via the NavigateUrl property, and link text is via the Text property. It is also possible to display an image by setting the ImageUrl property. In this case, Text is displayed as the alternate text of the image. The link target is specified via the Target property. If both ImageUrl and Text are empty, the content enclosed within the control tag will be rendered.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THyperLink.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THyperLink::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attributes related to a hyperlink element to renderer.

    access

    protected

    [ Top ]

    THyperLink::createImage

    createImage( string $imageUrl );

    Parameters

    $imageUrl

    image url.

    Returns

    image control for rendering.

    Remarks

    Gets the TImage for rendering the ImageUrl property. This is not for creating dynamic images.

    access

    protected

    [ Top ]

    THyperLink::getData

    getData( );

    Returns

    the text caption

    Remarks

    Returns the URL to link to when the THyperLink component is clicked.

    This method is required by IDataRenderer. It is the same as getText().

    see

    THyperLink::getText()

    since

    3.1.0

    access

    public

    [ Top ]

    THyperLink::getImageHeight

    getImageHeight( );

    Returns

    height of the image in the THyperLink

    access

    public

    [ Top ]

    THyperLink::getImageUrl

    getImageUrl( );

    Returns

    the location of the image file for the THyperLink

    access

    public

    [ Top ]

    THyperLink::getImageWidth

    getImageWidth( );

    Returns

    width of the image in the THyperLink

    access

    public

    [ Top ]

    THyperLink::getNavigateUrl

    getNavigateUrl( );

    Returns

    the URL to link to when the THyperLink component is clicked.

    access

    public

    [ Top ]

    THyperLink::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name of the hyperlink

    access

    protected

    [ Top ]

    THyperLink::getTarget

    getTarget( );

    Returns

    the target window or frame to display the Web page content linked to when the THyperLink component is clicked.

    access

    public

    [ Top ]

    THyperLink::getText

    getText( );

    Returns

    the text caption of the THyperLink

    access

    public

    [ Top ]

    THyperLink::renderContents

    renderContents( THtmlWriter $writer );

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    the writer for rendering

    Remarks

    Renders the body content of the hyperlink.

    access

    public

    [ Top ]

    THyperLink::setData

    setData( string $value );

    Parameters

    $value

    the text caption to be set

    Remarks

    Sets the URL to link to when the THyperLink component is clicked.

    This method is required by IDataRenderer. It is the same as setText().

    see

    THyperLink::setText()

    since

    3.1.0

    access

    public

    [ Top ]

    THyperLink::setImageHeight

    setImageHeight( string $value );

    Parameters

    $value

    height of the image in the THyperLink

    Remarks

    Sets the height of the image in the THyperLink

    access

    public

    [ Top ]

    THyperLink::setImageUrl

    setImageUrl( string $value );

    Overridden in child classes as:

    TActiveHyperLink::setImageUrl()
    Sets the location of image file of the THyperLink.

    Parameters

    $value

    the image file location

    Remarks

    Sets the location of image file of the THyperLink.

    access

    public

    [ Top ]

    THyperLink::setImageWidth

    setImageWidth( string $value );

    Parameters

    $value

    width of the image

    Remarks

    Sets the width of the image in the THyperLink

    access

    public

    [ Top ]

    THyperLink::setNavigateUrl

    setNavigateUrl( string $value );

    Overridden in child classes as:

    TActiveHyperLink::setNavigateUrl()
    Sets the URL to link to when the THyperLink component is clicked.

    Parameters

    $value

    the URL

    Remarks

    Sets the URL to link to when the THyperLink component is clicked.

    access

    public

    [ Top ]

    THyperLink::setTarget

    setTarget( string $value );

    Overridden in child classes as:

    TActiveHyperLink::setTarget()
    Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.

    Parameters

    $value

    the target window, valid values include '_blank', '_parent', '_self', '_top' and empty string.

    Remarks

    Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.

    access

    public

    [ Top ]

    THyperLink::setText

    setText( string $value );

    Overridden in child classes as:

    TActiveHyperLink::setText()
    On callback response, the inner HTMl of the label is updated.

    Parameters

    $value

    the text caption to be set

    Remarks

    Sets the text caption of the THyperLink.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:31 +0200 by phpDocumentor 1.4.3


Docs For Class THyperLinkColumn

Class THyperLinkColumn

[line 52]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --THyperLinkColumn
Classes extended from THyperLinkColumn:
TActiveHyperLinkColumn
TActiveHyperLinkColumn class

Location: /Web/UI/WebControls/THyperLinkColumn.php

Remarks

THyperLinkColumn class

THyperLinkColumn contains a hyperlink for each item in the column. You can set the text and the url of the hyperlink by Text and NavigateUrl properties, respectively. You can also bind the text and url to specific data field in datasource by setting DataTextField and DataNavigateUrlField. Both can be formatted before rendering according to the DataTextFormatString and and DataNavigateUrlFormatString properties, respectively. If both Text and DataTextField are present, the latter takes precedence. The same rule applies to NavigateUrl and DataNavigateUrlField properties.

The hyperlinks in the column can be accessed by one of the following two methods:

  •  $datagridItem->HyperLinkColumnID->HyperLink
    •

  •  $datagridItem->HyperLinkColumnID->Controls[0]
    •
    The second method is possible because the hyperlink control created within the datagrid cell is the first child.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: THyperLinkColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TDataGridColumn

    • TDataGridColumn::formatDataValue()
      Formats the text value according to a format string.
    • TDataGridColumn::getAllowSorting()
      Returns a value indicating whether this column allows sorting.
    • TDataGridColumn::getDataFieldValue()
      Fetches the value of the data at the specified field.
    • TDataGridColumn::getEnableCellGrouping()
    • TDataGridColumn::getFooterRenderer()
    • TDataGridColumn::getFooterStyle()
    • TDataGridColumn::getFooterText()
    • TDataGridColumn::getHeaderImageUrl()
    • TDataGridColumn::getHeaderRenderer()
    • TDataGridColumn::getHeaderStyle()
    • TDataGridColumn::getHeaderText()
    • TDataGridColumn::getID()
    • TDataGridColumn::getItemStyle()
    • TDataGridColumn::getOwner()
    • TDataGridColumn::getSortExpression()
    • TDataGridColumn::getViewState()
      Returns a viewstate value.
    • TDataGridColumn::getVisible()
    • TDataGridColumn::initialize()
      Initializes the column.
    • TDataGridColumn::initializeCell()
      Initializes the specified cell to its initial values.
    • TDataGridColumn::initializeFooterCell()
      Initializes the footer cell.
    • TDataGridColumn::initializeHeaderCell()
      Initializes the header cell.
    • TDataGridColumn::loadState()
      Loads persistent state values.
    • TDataGridColumn::saveState()
      Saves persistent state values.
    • TDataGridColumn::setEnableCellGrouping()
    • TDataGridColumn::setFooterRenderer()
      Sets the column footer cell renderer class.
    • TDataGridColumn::setFooterText()
    • TDataGridColumn::setHeaderImageUrl()
    • TDataGridColumn::setHeaderRenderer()
      Sets the column header cell renderer class.
    • TDataGridColumn::setHeaderText()
    • TDataGridColumn::setID()
      Sets the ID of the column.
    • TDataGridColumn::setOwner()
    • TDataGridColumn::setSortExpression()
    • TDataGridColumn::setViewState()
      Sets a viewstate value.
    • TDataGridColumn::setVisible()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      THyperLinkColumn::dataBindColumn

      dataBindColumn( $sender, $param );

      Parameters

      $sender

      $param

      Remarks

      Databinds a cell in the column.

      This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

      access

      public

      [ Top ]

      THyperLinkColumn::getDataNavigateUrlField

      getDataNavigateUrlField( );

      Returns

      the field name from the data source to bind to the navigate url of hyperlink

      access

      public

      [ Top ]

      THyperLinkColumn::getDataNavigateUrlFormatString

      getDataNavigateUrlFormatString( );

      Returns

      the formatting string used to control how the navigate url of hyperlink will be displayed.

      access

      public

      [ Top ]

      THyperLinkColumn::getDataTextField

      getDataTextField( );

      Returns

      the field name from the data source to bind to the hyperlink caption

      access

      public

      [ Top ]

      THyperLinkColumn::getDataTextFormatString

      getDataTextFormatString( );

      Returns

      the formatting string used to control how the hyperlink caption will be displayed.

      access

      public

      [ Top ]

      THyperLinkColumn::getImageHeight

      getImageHeight( );

      Returns

      height of the image in the THyperLink

      access

      public

      [ Top ]

      THyperLinkColumn::getImageUrl

      getImageUrl( );

      Returns

      url of the image in the THyperLink

      access

      public

      [ Top ]

      THyperLinkColumn::getImageWidth

      getImageWidth( );

      Returns

      width of the image in the THyperLink

      access

      public

      [ Top ]

      THyperLinkColumn::getNavigateUrl

      getNavigateUrl( );

      Returns

      the URL to link to when the hyperlink is clicked.

      access

      public

      [ Top ]

      THyperLinkColumn::getTarget

      getTarget( );

      Returns

      the target window or frame to display the Web page content linked to when the hyperlink is clicked.

      access

      public

      [ Top ]

      THyperLinkColumn::getText

      getText( );

      Returns

      the text caption of the hyperlink

      access

      public

      [ Top ]

      THyperLinkColumn::initializeCell

      initializeCell( TTableCell $cell, integer $columnIndex, string $itemType );

      Overrides TDataGridColumn::initializeCell() (Initializes the specified cell to its initial values.)

      Parameters

      $cell

      the cell to be initialized.

      $columnIndex

      the index to the Columns property that the cell resides in.

      $itemType

      the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)

      Remarks

      Initializes the specified cell to its initial values.

      This method overrides the parent implementation. It creates a hyperlink within the cell.

      access

      public

      [ Top ]

      THyperLinkColumn::setDataNavigateUrlField

      setDataNavigateUrlField( string $value );

      Parameters

      $value

      the field name from the data source to bind to the navigate url of hyperlink

      access

      public

      [ Top ]

      THyperLinkColumn::setDataNavigateUrlFormatString

      setDataNavigateUrlFormatString( string $value );

      Parameters

      $value

      the formatting string used to control how the navigate url of hyperlink will be displayed.

      access

      public

      [ Top ]

      THyperLinkColumn::setDataTextField

      setDataTextField( string $value );

      Parameters

      $value

      the field name from the data source to bind to the hyperlink caption

      access

      public

      [ Top ]

      THyperLinkColumn::setDataTextFormatString

      setDataTextFormatString( string $value );

      Parameters

      $value

      the formatting string used to control how the hyperlink caption will be displayed.

      access

      public

      [ Top ]

      THyperLinkColumn::setImageHeight

      setImageHeight( string $value );

      Parameters

      $value

      height of the image in the THyperLink

      access

      public

      [ Top ]

      THyperLinkColumn::setImageUrl

      setImageUrl( string $value );

      Parameters

      $value

      url of the image in the THyperLink

      access

      public

      [ Top ]

      THyperLinkColumn::setImageWidth

      setImageWidth( string $value );

      Parameters

      $value

      width of the image in the THyperLink

      access

      public

      [ Top ]

      THyperLinkColumn::setNavigateUrl

      setNavigateUrl( string $value );

      Parameters

      $value

      the URL

      Remarks

      Sets the URL to link to when the hyperlink is clicked.

      access

      public

      [ Top ]

      THyperLinkColumn::setTarget

      setTarget( string $value );

      Parameters

      $value

      the target window, valid values include '_blank', '_parent', '_self', '_top' and empty string.

      Remarks

      Sets the target window or frame to display the Web page content linked to when the hyperlink is clicked.

      access

      public

      [ Top ]

      THyperLinkColumn::setText

      setText( string $value );

      Parameters

      $value

      the text caption to be set

      Remarks

      Sets the text caption of the hyperlink.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:32 +0200 by phpDocumentor 1.4.3


Docs For Class TImage

Class TImage

[line 28]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TImage
Classes extended from TImage:
TActiveImage
TActiveImage class.
TCaptcha
TCaptcha class.
TImageButton
TImageButton class
TImageMap
TImageMap class

Location: /Web/UI/WebControls/TImage.php

Remarks

TImage class

TImage displays an image on a page. The image is specified via the ImageUrl property which takes a relative or absolute URL to the image file. The alignment of the image displayed is set by the ImageAlign property. To set alternative texts or long description of the image, use AlternateText or DescriptionUrl property, respectively.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImage.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TImage::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overridden in child classes as:

    TImageButton::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
    TActiveImageButton::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TImageMap::addAttributesToRender()
    Adds attribute name-value pairs to renderer.

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attributes related to an HTML image element to renderer.

    access

    protected

    [ Top ]

    TImage::getAlternateText

    getAlternateText( );

    Returns

    the alternative text displayed in the TImage component when the image is unavailable.

    access

    public

    [ Top ]

    TImage::getData

    getData( );

    Returns

    the URL of the image file.

    Remarks

    Returns the URL of the image file.

    This method is required by IDataRenderer. It is the same as getImageUrl().

    see

    TImage::getImageUrl()

    since

    3.1.0

    access

    public

    [ Top ]

    TImage::getDescriptionUrl

    getDescriptionUrl( );

    Returns

    the URL to long description

    access

    public

    [ Top ]

    TImage::getImageAlign

    getImageAlign( );

    Returns

    the alignment of the image with respective to other elements on the page, defaults to empty.

    access

    public

    [ Top ]

    TImage::getImageUrl

    getImageUrl( );

    Returns

    the URL of the image file

    access

    public

    [ Top ]

    TImage::getTagName

    getTagName( );

    Overridden in child classes as:

    TImageButton::getTagName()

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name of image control

    access

    protected

    [ Top ]

    TImage::renderContents

    renderContents( THtmlWriter $writer );

    Overridden in child classes as:

    TImageButton::renderContents()
    Renders the body content enclosed between the control tag.

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    the writer for rendering

    Remarks

    Renders the body content of the image.

    Nothing to be rendered within image tags.

    access

    public

    [ Top ]

    TImage::setAlternateText

    setAlternateText( string $value );

    Overridden in child classes as:

    TActiveImage::setAlternateText()
    Sets the alternative text to be displayed in the TImage when the image is unavailable.
    TActiveImageButton::setAlternateText()
    Sets the alternative text to be displayed in the TImage when the image is unavailable.

    Parameters

    $value

    the alternative text

    Remarks

    Sets the alternative text to be displayed in the TImage when the image is unavailable.

    access

    public

    [ Top ]

    TImage::setData

    setData( string $value );

    Parameters

    $value

    the URL of the image file.

    Remarks

    Sets the URL of the image.

    This method is required by IDataRenderer. It is the same as setImageUrl().

    see

    TImage::setImageUrl()

    since

    3.1.0

    access

    public

    [ Top ]

    TImage::setDescriptionUrl

    setDescriptionUrl( string $value );

    Overridden in child classes as:

    TActiveImage::setDescriptionUrl()
    TActiveImageButton::setDescriptionUrl()

    Parameters

    $value

    the URL to the long description of the image.

    access

    public

    [ Top ]

    TImage::setImageAlign

    setImageAlign( string $value );

    Overridden in child classes as:

    TActiveImage::setImageAlign()
    Sets the alignment of the image with respective to other elements on the page.
    TActiveImageButton::setImageAlign()
    Sets the alignment of the image with respective to other elements on the page.

    Parameters

    $value

    the alignment of the image

    Remarks

    Sets the alignment of the image with respective to other elements on the page.

    Possible values include: absbottom, absmiddle, baseline, bottom, left, middle, right, texttop, and top. If an empty string is passed in, imagealign attribute will not be rendered.

    access

    public

    [ Top ]

    TImage::setImageUrl

    setImageUrl( string $value );

    Overridden in child classes as:

    TActiveImage::setImageUrl()
    TActiveImageButton::setImageUrl()

    Parameters

    $value

    the URL of the image file

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:32 +0200 by phpDocumentor 1.4.3


Docs For Class TImageButton

Class TImageButton

[line 59]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TImage
               |
               --TImageButton
Classes extended from TImageButton:
TActiveImageButton
TActiveImageButton class.

Location: /Web/UI/WebControls/TImageButton.php

Remarks

TImageButton class

TImageButton creates an image button on the page. It is used to submit data to a page. You can create either a submit button or a command button.

A command button has a command name (specified by the CommandName property) and and a command parameter (specified by CommandParameter property) associated with the button. This allows you to create multiple TLinkButton components on a Web page and programmatically determine which one is clicked with what parameter. You can provide an event handler for OnCommand event to programmatically control the actions performed when the command button is clicked. In the event handler, you can determine the CommandName property value and the CommandParameter property value through the TCommandParameter::getName and TCommandParameter::getParameter properties of the event parameter which is of type TCommandEventParameter.

A submit button does not have a command name associated with the button and clicking on it simply posts the Web page back to the server. By default, a TImageButton control is a submit button. You can provide an event handler for the OnClick event to programmatically control the actions performed when the submit button is clicked. The coordinates of the clicking point can be obtained from the OnClick event parameter, which is of type TImageClickEventParameter.

Clicking on button can trigger form validation, if CausesValidation is true. And the validation may be restricted within a certain group of validator controls by setting ValidationGroup property. If validation is successful, the data will be post back to the same page.

TImageButton displays the Text property as the hint text to the displayed image.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImageButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TImage

  • TImage::addAttributesToRender()
    Adds attributes related to an HTML image element to renderer.
  • TImage::getAlternateText()
  • TImage::getData()
    Returns the URL of the image file.
  • TImage::getDescriptionUrl()
  • TImage::getImageAlign()
  • TImage::getImageUrl()
  • TImage::getTagName()
  • TImage::renderContents()
    Renders the body content of the image.
  • TImage::setAlternateText()
    Sets the alternative text to be displayed in the TImage when the image is unavailable.
  • TImage::setData()
    Sets the URL of the image.
  • TImage::setDescriptionUrl()
  • TImage::setImageAlign()
    Sets the alignment of the image with respective to other elements on the page.
  • TImage::setImageUrl()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TImageButton::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveImageButton::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    Overrides TImage::addAttributesToRender() (Adds attributes related to an HTML image element to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attribute name-value pairs to renderer.

    This overrides the parent implementation with additional button specific attributes.

    access

    protected

    [ Top ]

    TImageButton::canCauseValidation

    canCauseValidation( );

    Returns

    whether to perform validation if the button is clicked

    access

    protected

    [ Top ]

    TImageButton::getCausesValidation

    getCausesValidation( );

    Returns

    whether postback event trigger by this button will cause input validation, default is true

    access

    public

    [ Top ]

    TImageButton::getClientClassName

    getClientClassName( );

    Overridden in child classes as:

    TActiveImageButton::getClientClassName()

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TImageButton::getCommandName

    getCommandName( );

    Returns

    the command name associated with the OnCommand event.

    access

    public

    [ Top ]

    TImageButton::getCommandParameter

    getCommandParameter( );

    Returns

    the parameter associated with the OnCommand event

    access

    public

    [ Top ]

    TImageButton::getDataChanged

    getDataChanged( );

    Returns

    whether postback has caused the control data change. False if the page is not in postback mode.

    Remarks

    Returns a value indicating whether postback has caused the control data change.

    This method is required by the IPostBackDataHandler interface.

    access

    public

    [ Top ]

    TImageButton::getEnableClientScript

    getEnableClientScript( );

    Returns

    whether to render javascript.

    access

    public

    [ Top ]

    TImageButton::getIsDefaultButton

    getIsDefaultButton( );

    Returns

    true if this button is registered as a default button for a panel.

    access

    public

    [ Top ]

    TImageButton::getPostBackOptions

    getPostBackOptions( );

    Returns

    parameters about how the button defines its postback behavior.

    Remarks

    Returns postback specifications for the button.

    This method is used by framework and control developers.

    access

    protected

    [ Top ]

    TImageButton::getTagName

    getTagName( );

    Overrides TImage::getTagName() (parent method not documented)

    Returns

    tag name of the button

    access

    protected

    [ Top ]

    TImageButton::getText

    getText( );

    Returns

    caption of the button

    access

    public

    [ Top ]

    TImageButton::getValidationGroup

    getValidationGroup( );

    Returns

    the group of validators which the button causes validation upon postback

    access

    public

    [ Top ]

    TImageButton::loadPostData

    loadPostData( string $key, array $values );

    Parameters

    $key

    the key that can be used to retrieve data from the input data collection

    $values

    the input data collection

    Returns

    whether the data of the component has been changed

    Remarks

    This method checks if the TImageButton is clicked and loads the coordinates of the clicking position.

    This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TImageButton::needPostBackScript

    needPostBackScript( );

    Returns

    whether the button needs javascript to do postback

    access

    protected

    [ Top ]

    TImageButton::onClick

    onClick( TImageClickEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the button is clicked.

    The method raises 'OnClick' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TImageButton::onCommand

    onCommand( TCommandEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the button is clicked.

    The method raises 'OnCommand' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

    access

    public

    [ Top ]

    TImageButton::onPreRender

    onPreRender( mixed $param );

    Overridden in child classes as:

    TActiveImageButton::onPreRender()
    Register the x and y hidden input names of the position clicked.

    Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

    Parameters

    $param

    event parameter

    Remarks

    Registers the image button to receive postback data during postback.

    This is necessary because an image button, when postback, does not have direct mapping between post data and the image button name. This method overrides the parent implementation and is invoked before render.

    access

    public

    [ Top ]

    TImageButton::raisePostBackEvent

    raisePostBackEvent( TEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the postback event.

    This method is required by IPostBackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick and OnCommand events. This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TImageButton::raisePostDataChangedEvent

    raisePostDataChangedEvent( );

    Remarks

    A dummy implementation for the IPostBackDataHandler interface.

    access

    public

    [ Top ]

    TImageButton::renderClientControlScript

    renderClientControlScript( $writer );

    Overridden in child classes as:

    TActiveImageButton::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    Parameters

    $writer

    Remarks

    Renders the client-script code.

    access

    protected

    [ Top ]

    TImageButton::renderContents

    renderContents( THtmlWriter $writer );

    Overrides TImage::renderContents() (Renders the body content of the image.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the body content enclosed between the control tag.

    This overrides the parent implementation with nothing to be rendered.

    access

    public

    [ Top ]

    TImageButton::setCausesValidation

    setCausesValidation( boolean $value );

    Parameters

    $value

    whether postback event trigger by this button will cause input validation

    access

    public

    [ Top ]

    TImageButton::setCommandName

    setCommandName( string $value );

    Parameters

    $value

    the command name associated with the OnCommand event.

    access

    public

    [ Top ]

    TImageButton::setCommandParameter

    setCommandParameter( string $value );

    Parameters

    $value

    the parameter associated with the OnCommand event.

    access

    public

    [ Top ]

    TImageButton::setEnableClientScript

    setEnableClientScript( boolean $value );

    Parameters

    $value

    whether to render javascript.

    access

    public

    [ Top ]

    TImageButton::setIsDefaultButton

    setIsDefaultButton( boolean $value );

    Parameters

    $value

    set by a panel to register this button as the default button for the panel.

    access

    public

    [ Top ]

    TImageButton::setText

    setText( string $value );

    Parameters

    $value

    caption of the button

    access

    public

    [ Top ]

    TImageButton::setValidationGroup

    setValidationGroup( string $value );

    Parameters

    $value

    the group of validators which the button causes validation upon postback

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:33 +0200 by phpDocumentor 1.4.3


Docs For Class TImageClickEventParameter

Class TImageClickEventParameter

[line 385]
TComponent
   |
   --TEventParameter
      |
      --TImageClickEventParameter
Location: /Web/UI/WebControls/TImageButton.php

Remarks

TImageClickEventParameter class

TImageClickEventParameter encapsulates the parameter data for TImageButton::onClick event of TImageButton controls.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImageButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TImageClickEventParameter::__construct

    __construct( integer $x, integer $y );

    Parameters

    $x

    X coordinate of the clicking point

    $y

    Y coordinate of the clicking point

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TImageClickEventParameter::getX

    getX( );

    Returns

    X coordinate of the clicking point, defaults to 0

    access

    public

    [ Top ]

    TImageClickEventParameter::getY

    getY( );

    Returns

    Y coordinate of the clicking point, defaults to 0

    access

    public

    [ Top ]

    TImageClickEventParameter::setX

    setX( integer $value );

    Parameters

    $value

    X coordinate of the clicking point

    access

    public

    [ Top ]

    TImageClickEventParameter::setY

    setY( integer $value );

    Parameters

    $value

    Y coordinate of the clicking point

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:34 +0200 by phpDocumentor 1.4.3


Docs For Class TCircleHotSpot

Class TCircleHotSpot

[line 611]
TComponent
   |
   --THotSpot
      |
      --TCircleHotSpot
Location: /Web/UI/WebControls/TImageMap.php

Remarks

Class TCircleHotSpot.

TCircleHotSpot defines a circular hot spot region in a TImageMap control.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImageMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class THotSpot

  • THotSpot::getAccessKey()
  • THotSpot::getAlternateText()
  • THotSpot::getAttribute()
  • THotSpot::getAttributes()
    Returns the list of custom attributes.
  • THotSpot::getCausesValidation()
  • THotSpot::getCoordinates()
  • THotSpot::getHasAttributes()
  • THotSpot::getHotSpotMode()
  • THotSpot::getNavigateUrl()
  • THotSpot::getPostBackValue()
  • THotSpot::getShape()
  • THotSpot::getTabIndex()
  • THotSpot::getTarget()
  • THotSpot::getValidationGroup()
  • THotSpot::getViewState()
    Returns a viewstate value.
  • THotSpot::hasAttribute()
  • THotSpot::removeAttribute()
    Removes the named attribute.
  • THotSpot::render()
    Renders this hotspot.
  • THotSpot::setAccessKey()
  • THotSpot::setAlternateText()
  • THotSpot::setAttribute()
    Sets a custom hotspot attribute.
  • THotSpot::setCausesValidation()
  • THotSpot::setHotSpotMode()
  • THotSpot::setNavigateUrl()
  • THotSpot::setPostBackValue()
  • THotSpot::setTabIndex()
  • THotSpot::setTarget()
  • THotSpot::setValidationGroup()
  • THotSpot::setViewState()
    Sets a viewstate value.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCircleHotSpot::getCoordinates

    getCoordinates( );

    Overrides THotSpot::getCoordinates() (parent method not documented)

    Returns

    coordinates defining this hotspot shape

    access

    public

    [ Top ]

    TCircleHotSpot::getRadius

    getRadius( );

    Returns

    radius of the circular HotSpot region. Defaults to 0.

    access

    public

    [ Top ]

    TCircleHotSpot::getShape

    getShape( );

    Overrides THotSpot::getShape() (parent method not documented)

    Returns

    shape of this hotspot.

    access

    public

    [ Top ]

    TCircleHotSpot::getX

    getX( );

    Returns

    the X coordinate of the center of the circular HotSpot region. Defaults to 0.

    access

    public

    [ Top ]

    TCircleHotSpot::getY

    getY( );

    Returns

    the Y coordinate of the center of the circular HotSpot region. Defaults to 0.

    access

    public

    [ Top ]

    TCircleHotSpot::setRadius

    setRadius( integer $value );

    Parameters

    $value

    radius of the circular HotSpot region.

    access

    public

    [ Top ]

    TCircleHotSpot::setX

    setX( integer $value );

    Parameters

    $value

    the X coordinate of the center of the circular HotSpot region.

    access

    public

    [ Top ]

    TCircleHotSpot::setY

    setY( integer $value );

    Parameters

    $value

    the Y coordinate of the center of the circular HotSpot region.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:34 +0200 by phpDocumentor 1.4.3


Docs For Class THotSpot

Class THotSpot

[line 300]
TComponent
   |
   --THotSpot
Classes extended from THotSpot:
TCircleHotSpot
Class TCircleHotSpot.
TRectangleHotSpot
Class TRectangleHotSpot.
TPolygonHotSpot
Class TPolygonHotSpot.

Location: /Web/UI/WebControls/TImageMap.php

Remarks

THotSpot class.

THotSpot implements the basic functionality common to all hot spot shapes. Derived classes include TCircleHotSpot, TPolygonHotSpot and TRectangleHotSpot.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImageMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THotSpot::getAccessKey

    getAccessKey( );

    Returns

    the access key that allows you to quickly navigate to the HotSpot region. Defaults to ''.

    access

    public

    [ Top ]

    THotSpot::getAlternateText

    getAlternateText( );

    Returns

    the alternate text to display for a HotSpot object. Defaults to ''.

    access

    public

    [ Top ]

    THotSpot::getAttribute

    getAttribute( $name );

    Parameters

    $name

    Returns

    attribute value, null if attribute does not exist

    access

    public

    [ Top ]

    THotSpot::getAttributes

    getAttributes( );

    Returns

    the list of custom attributes

    Remarks

    Returns the list of custom attributes.

    Custom attributes are name-value pairs that may be rendered as HTML tags' attributes.

    access

    public

    [ Top ]

    THotSpot::getCausesValidation

    getCausesValidation( );

    Returns

    whether postback event trigger by this hotspot will cause input validation, default is true

    access

    public

    [ Top ]

    THotSpot::getCoordinates

    getCoordinates( );

    Overridden in child classes as:

    TCircleHotSpot::getCoordinates()
    TRectangleHotSpot::getCoordinates()
    TPolygonHotSpot::getCoordinates()

    Returns

    coordinates defining the hotspot shape.

    abstract

    access

    public

    [ Top ]

    THotSpot::getHasAttributes

    getHasAttributes( );

    Returns

    whether the hotspot has custom attributes

    access

    public

    [ Top ]

    THotSpot::getHotSpotMode

    getHotSpotMode( );

    Returns

    the behavior of a HotSpot object when it is clicked. Defaults to THotSpotMode::NotSet.

    access

    public

    [ Top ]

    THotSpot::getNavigateUrl

    getNavigateUrl( );

    Returns

    the URL to navigate to when a HotSpot object is clicked. Defaults to ''.

    access

    public

    [ Top ]

    THotSpot::getPostBackValue

    getPostBackValue( );

    Returns

    a value that is post back when the HotSpot is clicked. Defaults to ''.

    access

    public

    [ Top ]

    THotSpot::getShape

    getShape( );

    Overridden in child classes as:

    TCircleHotSpot::getShape()
    TRectangleHotSpot::getShape()
    TPolygonHotSpot::getShape()

    Returns

    shape of the hotspot, can be 'circle', 'rect', 'poly', etc.

    abstract

    access

    public

    [ Top ]

    THotSpot::getTabIndex

    getTabIndex( );

    Returns

    the tab index of the HotSpot region. Defaults to 0.

    access

    public

    [ Top ]

    THotSpot::getTarget

    getTarget( );

    Returns

    the target window or frame to display the new page when the HotSpot region is clicked. Defaults to ''.

    access

    public

    [ Top ]

    THotSpot::getValidationGroup

    getValidationGroup( );

    Returns

    the group of validators which the hotspot causes validation upon postback

    access

    public

    [ Top ]

    THotSpot::getViewState

    getViewState( string $key, [mixed $defaultValue = null] );

    Parameters

    $key

    the name of the viewstate value to be returned

    $defaultValue

    the default value. If $key is not found in viewstate, $defaultValue will be returned

    Returns

    the viewstate value corresponding to $key

    Remarks

    Returns a viewstate value.

    This function is very useful in defining getter functions for component properties that must be kept in viewstate.

    access

    protected

    [ Top ]

    THotSpot::hasAttribute

    hasAttribute( $name );

    Parameters

    $name

    Returns

    whether the named attribute exists

    access

    public

    [ Top ]

    THotSpot::removeAttribute

    removeAttribute( string $name );

    Parameters

    $name

    the name of the attribute to be removed.

    Returns

    attribute value removed, null if attribute does not exist.

    Remarks

    Removes the named attribute.

    access

    public

    [ Top ]

    THotSpot::render

    render( THtmlWriter $writer );

    Parameters

    $writer

    Remarks

    Renders this hotspot.

    access

    public

    [ Top ]

    THotSpot::setAccessKey

    setAccessKey( string $value );

    Parameters

    $value

    the access key that allows you to quickly navigate to the HotSpot region.

    access

    public

    [ Top ]

    THotSpot::setAlternateText

    setAlternateText( string $value );

    Parameters

    $value

    the alternate text to display for a HotSpot object.

    access

    public

    [ Top ]

    THotSpot::setAttribute

    setAttribute( string $name, string $value );

    Parameters

    $name

    attribute name

    $value

    value of the attribute

    Remarks

    Sets a custom hotspot attribute.

    access

    public

    [ Top ]

    THotSpot::setCausesValidation

    setCausesValidation( boolean $value );

    Parameters

    $value

    whether postback event trigger by this hotspot will cause input validation

    access

    public

    [ Top ]

    THotSpot::setHotSpotMode

    setHotSpotMode( THotSpotMode $value );

    Parameters

    $value

    the behavior of a HotSpot object when it is clicked.

    access

    public

    [ Top ]

    THotSpot::setNavigateUrl

    setNavigateUrl( string $value );

    Parameters

    $value

    the URL to navigate to when a HotSpot object is clicked.

    access

    public

    [ Top ]

    THotSpot::setPostBackValue

    setPostBackValue( string $value );

    Parameters

    $value

    a value that is post back when the HotSpot is clicked.

    access

    public

    [ Top ]

    THotSpot::setTabIndex

    setTabIndex( integer $value );

    Parameters

    $value

    the tab index of the HotSpot region.

    access

    public

    [ Top ]

    THotSpot::setTarget

    setTarget( string $value );

    Parameters

    $value

    the target window or frame to display the new page when the HotSpot region is clicked.

    access

    public

    [ Top ]

    THotSpot::setValidationGroup

    setValidationGroup( string $value );

    Parameters

    $value

    the group of validators which the hotspot causes validation upon postback

    access

    public

    [ Top ]

    THotSpot::setViewState

    setViewState( string $key, mixed $value, [mixed $defaultValue = null] );

    Parameters

    $key

    the name of the viewstate value

    $value

    the viewstate value to be set

    $defaultValue

    default value. If $value===$defaultValue, the item will be cleared from the viewstate.

    Remarks

    Sets a viewstate value.

    This function is very useful in defining setter functions for control properties that must be kept in viewstate. Make sure that the viewstate value must be serializable and unserializable.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:34 +0200 by phpDocumentor 1.4.3


Docs For Class THotSpotCollection

Class THotSpotCollection

[line 269]
TComponent
   |
   --TList
      |
      --THotSpotCollection
Location: /Web/UI/WebControls/TImageMap.php

Remarks

THotSpotCollection class.

THotSpotCollection represents a collection of hotspots in an imagemap.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImageMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THotSpotCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TList::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by inserting only THotSpot.

    throws

    TInvalidDataTypeException if the item to be inserted is not a THotSpot.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:35 +0200 by phpDocumentor 1.4.3


Docs For Class THotSpotMode

Class THotSpotMode

[line 830]
TEnumerable
   |
   --THotSpotMode
Location: /Web/UI/WebControls/TImageMap.php

Remarks

THotSpotMode class.

THotSpotMode defines the enumerable type for the possible hot spot modes.

The following enumerable values are defined:

  • NotSet: the mode is not specified
  • Navigate: clicking on the hotspot will redirect the browser to a different page
  • PostBack: clicking on the hotspot will cause a postback
  • Inactive: the hotspot is inactive (not clickable)

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImageMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Inactive = 'Inactive'
  • Navigate = 'Navigate'
  • NotSet = 'NotSet'
  • PostBack = 'PostBack'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Inactive = 'Inactive' [line 835]

  • Navigate = 'Navigate' [line 833]

  • NotSet = 'NotSet' [line 832]

  • PostBack = 'PostBack' [line 834]

Documentation generated on Mon, 25 Jun 2012 14:44:35 +0200 by phpDocumentor 1.4.3


Docs For Class TImageMap

Class TImageMap

[line 40]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TImage
               |
               --TImageMap
Location: /Web/UI/WebControls/TImageMap.php

Remarks

TImageMap class

TImageMap represents an image on a page. Hotspot regions can be defined within the image. Depending on the HotSpotMode, clicking on the hotspots may trigger a postback or navigate to a specified URL. The hotspots defined may be accessed via HotSpots. Each hotspot is described as a THotSpot, which can be a circle, rectangle, polygon, etc. To add hotspot in a template, use the following,

  •   <com:TImageMap>
    •

  •     <com:TCircleHotSpot ... />
    •

  •     <com:TRectangleHotSpot ... />
    •

  •     <com:TPolygonHotSpot ... />
    •

  •   </com:TImageMap>
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TImageMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    • MAP_NAME_PREFIX = 'ImageMap'

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TImage

    • TImage::addAttributesToRender()
      Adds attributes related to an HTML image element to renderer.
    • TImage::getAlternateText()
    • TImage::getData()
      Returns the URL of the image file.
    • TImage::getDescriptionUrl()
    • TImage::getImageAlign()
    • TImage::getImageUrl()
    • TImage::getTagName()
    • TImage::renderContents()
      Renders the body content of the image.
    • TImage::setAlternateText()
      Sets the alternative text to be displayed in the TImage when the image is unavailable.
    • TImage::setData()
      Sets the URL of the image.
    • TImage::setDescriptionUrl()
    • TImage::setImageAlign()
      Sets the alignment of the image with respective to other elements on the page.
    • TImage::setImageUrl()

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TImageMap::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overrides TImage::addAttributesToRender() (Adds attributes related to an HTML image element to renderer.)

      Parameters

      $writer

      the writer used for the rendering purpose

      Remarks

      Adds attribute name-value pairs to renderer.

      This overrides the parent implementation with additional imagemap specific attributes.

      access

      protected

      [ Top ]

      TImageMap::addParsedObject

      addParsedObject( string|TComponent $object );

      Overrides TControl::addParsedObject() (Adds the object instantiated on a template to the child control collection.)

      Parameters

      $object

      text string or component parsed and instantiated in template

      Remarks

      Processes an object that is created during parsing template.

      This method adds THotSpot objects into the hotspot collection of the imagemap.

      access

      public

      [ Top ]

      TImageMap::getClientClassName

      getClientClassName( );

      Returns

      the javascript class name

      Remarks

      Gets the name of the javascript class responsible for performing postback for this control.

      This method overrides the parent implementation.

      access

      protected

      [ Top ]

      TImageMap::getHotSpotMode

      getHotSpotMode( );

      Returns

      the behavior of hotspot regions in this imagemap when they are clicked. Defaults to THotSpotMode::NotSet.

      access

      public

      [ Top ]

      TImageMap::getHotSpots

      getHotSpots( );

      Returns

      collection of hotspots defined in this imagemap.

      access

      public

      [ Top ]

      TImageMap::getTarget

      getTarget( );

      Returns

      the target window or frame to display the new page when a hotspot region is clicked within the imagemap. Defaults to ''.

      access

      public

      [ Top ]

      TImageMap::onClick

      onClick( TImageMapEventParameter $param );

      Parameters

      $param

      event parameter to be passed to the event handlers

      Remarks

      Raises OnClick event.

      This method is invoked when a hotspot region is clicked within the imagemap. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

      access

      public

      [ Top ]

      TImageMap::raisePostBackEvent

      raisePostBackEvent( TEventParameter $param );

      Parameters

      $param

      the event parameter

      Remarks

      Raises the postback event.

      This method is required by IPostBackEventHandler interface. This method is mainly used by framework and control developers.

      access

      public

      [ Top ]

      TImageMap::render

      render( THtmlWriter $writer );

      Overrides TWebControl::render() (Renders the control.)

      Parameters

      $writer

      Remarks

      Renders this imagemap.

      access

      public

      [ Top ]

      TImageMap::setHotSpotMode

      setHotSpotMode( THotSpotMode $value );

      Parameters

      $value

      the behavior of hotspot regions in this imagemap when they are clicked.

      Remarks

      Sets the behavior of hotspot regions in this imagemap when they are clicked.

      If an individual hotspot has a mode other than 'NotSet', the mode set in this imagemap will be ignored. By default, 'NotSet' is equivalent to 'Navigate'.

      access

      public

      [ Top ]

      TImageMap::setTarget

      setTarget( string $value );

      Parameters

      $value

      the target window or frame to display the new page when a hotspot region is clicked within the imagemap.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • MAP_NAME_PREFIX = 'ImageMap' [line 42]

    Documentation generated on Mon, 25 Jun 2012 14:44:35 +0200 by phpDocumentor 1.4.3


Docs For Class TImageMapEventParameter

Class TImageMapEventParameter

[line 237]
TComponent
   |
   --TEventParameter
      |
      --TImageMapEventParameter
Location: /Web/UI/WebControls/TImageMap.php

Remarks

TImageMapEventParameter class.

TImageMapEventParameter represents a postback event parameter when a hotspot is clicked and posts back in a TImageMap. To retrieve the post back value associated with the hotspot being clicked, access PostBackValue.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImageMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TImageMapEventParameter::__construct

    __construct( string $postBackValue );

    Parameters

    $postBackValue

    post back value associated with the hotspot clicked

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TImageMapEventParameter::getPostBackValue

    getPostBackValue( );

    Returns

    post back value associated with the hotspot clicked

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:35 +0200 by phpDocumentor 1.4.3


Docs For Class TPolygonHotSpot

Class TPolygonHotSpot

[line 783]
TComponent
   |
   --THotSpot
      |
      --TPolygonHotSpot
Location: /Web/UI/WebControls/TImageMap.php

Remarks

Class TPolygonHotSpot.

TPolygonHotSpot defines a polygon hot spot region in a TImageMap control.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImageMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class THotSpot

  • THotSpot::getAccessKey()
  • THotSpot::getAlternateText()
  • THotSpot::getAttribute()
  • THotSpot::getAttributes()
    Returns the list of custom attributes.
  • THotSpot::getCausesValidation()
  • THotSpot::getCoordinates()
  • THotSpot::getHasAttributes()
  • THotSpot::getHotSpotMode()
  • THotSpot::getNavigateUrl()
  • THotSpot::getPostBackValue()
  • THotSpot::getShape()
  • THotSpot::getTabIndex()
  • THotSpot::getTarget()
  • THotSpot::getValidationGroup()
  • THotSpot::getViewState()
    Returns a viewstate value.
  • THotSpot::hasAttribute()
  • THotSpot::removeAttribute()
    Removes the named attribute.
  • THotSpot::render()
    Renders this hotspot.
  • THotSpot::setAccessKey()
  • THotSpot::setAlternateText()
  • THotSpot::setAttribute()
    Sets a custom hotspot attribute.
  • THotSpot::setCausesValidation()
  • THotSpot::setHotSpotMode()
  • THotSpot::setNavigateUrl()
  • THotSpot::setPostBackValue()
  • THotSpot::setTabIndex()
  • THotSpot::setTarget()
  • THotSpot::setValidationGroup()
  • THotSpot::setViewState()
    Sets a viewstate value.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPolygonHotSpot::getCoordinates

    getCoordinates( );

    Overrides THotSpot::getCoordinates() (parent method not documented)

    Returns

    coordinates of the vertices defining the polygon. Coordinates are concatenated together with comma ','. Each pair represents (x,y) of a vertex.

    access

    public

    [ Top ]

    TPolygonHotSpot::getShape

    getShape( );

    Overrides THotSpot::getShape() (parent method not documented)

    Returns

    shape of this hotspot.

    access

    public

    [ Top ]

    TPolygonHotSpot::setCoordinates

    setCoordinates( string $value );

    Parameters

    $value

    coordinates of the vertices defining the polygon. Coordinates are concatenated together with comma ','. Each pair represents (x,y) of a vertex.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:36 +0200 by phpDocumentor 1.4.3


Docs For Class TRectangleHotSpot

Class TRectangleHotSpot

[line 689]
TComponent
   |
   --THotSpot
      |
      --TRectangleHotSpot
Location: /Web/UI/WebControls/TImageMap.php

Remarks

Class TRectangleHotSpot.

TRectangleHotSpot defines a rectangle hot spot region in a TImageMap control.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TImageMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class THotSpot

  • THotSpot::getAccessKey()
  • THotSpot::getAlternateText()
  • THotSpot::getAttribute()
  • THotSpot::getAttributes()
    Returns the list of custom attributes.
  • THotSpot::getCausesValidation()
  • THotSpot::getCoordinates()
  • THotSpot::getHasAttributes()
  • THotSpot::getHotSpotMode()
  • THotSpot::getNavigateUrl()
  • THotSpot::getPostBackValue()
  • THotSpot::getShape()
  • THotSpot::getTabIndex()
  • THotSpot::getTarget()
  • THotSpot::getValidationGroup()
  • THotSpot::getViewState()
    Returns a viewstate value.
  • THotSpot::hasAttribute()
  • THotSpot::removeAttribute()
    Removes the named attribute.
  • THotSpot::render()
    Renders this hotspot.
  • THotSpot::setAccessKey()
  • THotSpot::setAlternateText()
  • THotSpot::setAttribute()
    Sets a custom hotspot attribute.
  • THotSpot::setCausesValidation()
  • THotSpot::setHotSpotMode()
  • THotSpot::setNavigateUrl()
  • THotSpot::setPostBackValue()
  • THotSpot::setTabIndex()
  • THotSpot::setTarget()
  • THotSpot::setValidationGroup()
  • THotSpot::setViewState()
    Sets a viewstate value.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRectangleHotSpot::getBottom

    getBottom( );

    Returns

    the Y coordinate of the bottom side of the rectangle HotSpot region. Defaults to 0.

    access

    public

    [ Top ]

    TRectangleHotSpot::getCoordinates

    getCoordinates( );

    Overrides THotSpot::getCoordinates() (parent method not documented)

    Returns

    coordinates defining this hotspot shape

    access

    public

    [ Top ]

    TRectangleHotSpot::getLeft

    getLeft( );

    Returns

    the X coordinate of the right side of the rectangle HotSpot region. Defaults to 0.

    access

    public

    [ Top ]

    TRectangleHotSpot::getRight

    getRight( );

    Returns

    the X coordinate of the right side of the rectangle HotSpot region. Defaults to 0.

    access

    public

    [ Top ]

    TRectangleHotSpot::getShape

    getShape( );

    Overrides THotSpot::getShape() (parent method not documented)

    Returns

    shape of this hotspot.

    access

    public

    [ Top ]

    TRectangleHotSpot::getTop

    getTop( );

    Returns

    the Y coordinate of the top side of the rectangle HotSpot region. Defaults to 0.

    access

    public

    [ Top ]

    TRectangleHotSpot::setBottom

    setBottom( integer $value );

    Parameters

    $value

    the Y coordinate of the bottom side of the rectangle HotSpot region.

    access

    public

    [ Top ]

    TRectangleHotSpot::setLeft

    setLeft( integer $value );

    Parameters

    $value

    the X coordinate of the right side of the rectangle HotSpot region.

    access

    public

    [ Top ]

    TRectangleHotSpot::setRight

    setRight( integer $value );

    Parameters

    $value

    the X coordinate of the right side of the rectangle HotSpot region.

    access

    public

    [ Top ]

    TRectangleHotSpot::setTop

    setTop( integer $value );

    Parameters

    $value

    the Y coordinate of the top side of the rectangle HotSpot region.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:36 +0200 by phpDocumentor 1.4.3


Docs For Class TInlineFrame

Class TInlineFrame

[line 34]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TInlineFrame
Location: /Web/UI/WebControls/TInlineFrame.php

Remarks

TInlineFrame class

TInlineFrame displays an inline frame (iframe) on a Web page. The location of the frame content is specified by FrameUrl. The frame's alignment is specified by Align. The MarginWidth and MarginHeight properties define the number of pixels to use as the left/right margins and top/bottom margins, respectively, within the inline frame. The ScrollBars property specifies whether scrollbars are provided for the inline frame. And DescriptionUrl gives the URI of a long description of the frame's contents.

Original Prado v2 IFrame Author Information

author

Harry Pottash <hpottash@gmail.com>

author

Jason Ragsdale <jrags@jasrags.net>

version

$Id: TInlineFrame.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TInlineFrame::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attribute name-value pairs to renderer.

    This overrides the parent implementation with additional button specific attributes.

    access

    protected

    [ Top ]

    TInlineFrame::getAlign

    getAlign( );

    Returns

    alignment of the iframe. Defaults to TInlineFrameAlign::NotSet.

    access

    public

    [ Top ]

    TInlineFrame::getData

    getData( );

    Returns

    the URL that this iframe will load content from

    Remarks

    Returns the URL that this iframe will load content from This method is required by IDataRenderer.

    It is the same as getFrameUrl().

    see

    TInlineFrame::getFrameUrl()

    since

    3.1.0

    access

    public

    [ Top ]

    TInlineFrame::getDescriptionUrl

    getDescriptionUrl( );

    Returns

    the URL to long description

    access

    public

    [ Top ]

    TInlineFrame::getFrameUrl

    getFrameUrl( );

    Returns

    URL that this iframe will load content from. Defaults to ''.

    access

    public

    [ Top ]

    TInlineFrame::getMarginHeight

    getMarginHeight( );

    Returns

    the amount of space, in pixels, that should be left between the frame's contents and the top and bottom margins. Defaults to -1, meaning not set.

    access

    public

    [ Top ]

    TInlineFrame::getMarginWidth

    getMarginWidth( );

    Returns

    the amount of space, in pixels, that should be left between the frame's contents and the left and right margins. Defaults to -1, meaning not set.

    access

    public

    [ Top ]

    TInlineFrame::getScrollBars

    getScrollBars( );

    Returns

    the visibility and position of scroll bars in an iframe. Defaults to TInlineFrameScrollBars::Auto.

    access

    public

    [ Top ]

    TInlineFrame::getShowBorder

    getShowBorder( );

    Returns

    whether there should be a visual separator between the frames. Defaults to true.

    access

    public

    [ Top ]

    TInlineFrame::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name of the iframe.

    access

    protected

    [ Top ]

    TInlineFrame::setAlign

    setAlign( TInlineFrameAlign $value );

    Parameters

    $value

    alignment of the iframe.

    access

    public

    [ Top ]

    TInlineFrame::setData

    setData( string $value );

    Parameters

    $value

    the URL that this iframe will load content from

    Remarks

    Sets the URL that this iframe will load content from.

    This method is required by IDataRenderer. It is the same as setFrameUrl().

    see

    TInlineFrame::setFrameUrl()

    since

    3.1.0

    access

    public

    [ Top ]

    TInlineFrame::setDescriptionUrl

    setDescriptionUrl( string $value );

    Parameters

    $value

    the URL to the long description of the image.

    access

    public

    [ Top ]

    TInlineFrame::setFrameUrl

    setFrameUrl( string $value );

    Parameters

    $value

    URL that this iframe will load content from.

    access

    public

    [ Top ]

    TInlineFrame::setMarginHeight

    setMarginHeight( integer $value );

    Parameters

    $value

    the amount of space, in pixels, that should be left between the frame's contents and the top and bottom margins.

    access

    public

    [ Top ]

    TInlineFrame::setMarginWidth

    setMarginWidth( integer $value );

    Parameters

    $value

    the amount of space, in pixels, that should be left between the frame's contents and the left and right margins.

    access

    public

    [ Top ]

    TInlineFrame::setScrollBars

    setScrollBars( TInlineFrameScrollBars $value );

    Parameters

    $value

    the visibility and position of scroll bars in an iframe.

    access

    public

    [ Top ]

    TInlineFrame::setShowBorder

    setShowBorder( boolean $value );

    Parameters

    $value

    whether there should be a visual separator between the frames.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:36 +0200 by phpDocumentor 1.4.3


Docs For Class TInlineFrameAlign

Class TInlineFrameAlign

[line 246]
TEnumerable
   |
   --TInlineFrameAlign
Location: /Web/UI/WebControls/TInlineFrame.php

Remarks

TInlineFrameAlign class.

TInlineFrameAlign defines the enumerable type for the possible alignments that the content in a TInlineFrame could be.

The following enumerable values are defined:

  • NotSet: the alignment is not specified.
  • Left: left aligned
  • Right: right aligned
  • Top: top aligned
  • Middle: middle aligned
  • Bottom: bottom aligned

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TInlineFrame.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Bottom = 'Bottom'
  • Left = 'Left'
  • Middle = 'Middle'
  • NotSet = 'NotSet'
  • Right = 'Right'
  • Top = 'Top'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Bottom = 'Bottom' [line 253]

  • Left = 'Left' [line 249]

  • Middle = 'Middle' [line 252]

  • NotSet = 'NotSet' [line 248]

  • Right = 'Right' [line 250]

  • Top = 'Top' [line 251]

Documentation generated on Mon, 25 Jun 2012 14:44:37 +0200 by phpDocumentor 1.4.3


Docs For Class TInlineFrameScrollBars

Class TInlineFrameScrollBars

[line 271]
TEnumerable
   |
   --TInlineFrameScrollBars
Location: /Web/UI/WebControls/TInlineFrame.php

Remarks

TInlineFrameScrollBars class.

TInlineFrameScrollBars defines the enumerable type for the possible scroll bar mode that a TInlineFrame control could use.

The following enumerable values are defined:

  • None: no scroll bars.
  • Auto: scroll bars automatically appeared when needed.
  • Both: show both horizontal and vertical scroll bars all the time.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TInlineFrame.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Auto = 'Auto'
  • Both = 'Both'
  • None = 'None'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Auto = 'Auto' [line 274]

  • Both = 'Both' [line 275]

  • None = 'None' [line 273]

Documentation generated on Mon, 25 Jun 2012 14:44:37 +0200 by phpDocumentor 1.4.3


Docs For Class TItemDataRenderer

Class TItemDataRenderer

[line 35]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TDataRenderer
                  |
                  --TItemDataRenderer
Classes extended from TItemDataRenderer:
TDataGridItemRenderer
TDataGridItemRenderer class
TDataListItemRenderer
TDataListItemRenderer class
TRepeaterItemRenderer
TRepeaterItemRenderer class

Location: /Web/UI/WebControls/TItemDataRenderer.php

Remarks

TItemDataRenderer class

TItemDataRenderer is the convient base class for template-based item data renderers. It implements the IItemDataRenderer interface, and because TItemDataRenderer extends from TTemplateControl, derived child classes can have templates to define their presentational layout.

The following properties are provided by TItemDataRenderer:

  • ItemIndex: zero-based index of this renderer in the item list collection.
  • ItemType: item type of this renderer, such as TListItemType::AlternatingItem
  • Data: data associated with this renderer

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TItemDataRenderer.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.1.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTemplateControl

  • TTemplateControl::EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDataRenderer

  • TDataRenderer::getData()
  • TDataRenderer::setData()

Inherited From Class TTemplateControl

  • TTemplateControl::createChildControls()
    Creates child controls.
  • TTemplateControl::getIsSourceTemplateControl()
  • TTemplateControl::getMaster()
  • TTemplateControl::getMasterClass()
  • TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
  • TTemplateControl::getTemplateDirectory()
  • TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
  • TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
  • TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
  • TTemplateControl::registerContent()
    Registers a content control.
  • TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
  • TTemplateControl::setMasterClass()
  • TTemplateControl::setTemplate()
    Sets the parsed template.

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TItemDataRenderer::getItemIndex

    getItemIndex( );

    Implementation of:
    IItemDataRenderer::getItemIndex()
    Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.

    Returns

    zero-based index of the item.

    Remarks

    Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.

    If the item is not in the collection (e.g. it is a header item), it returns -1.

    access

    public

    [ Top ]

    TItemDataRenderer::getItemType

    getItemType( );

    Implementation of:
    IItemDataRenderer::getItemType()

    Returns

    item type

    access

    public

    [ Top ]

    TItemDataRenderer::setItemIndex

    setItemIndex( integer $value );

    Implementation of:
    IItemDataRenderer::setItemIndex()
    Sets the zero-based index for the item.

    Parameters

    $value

    zero-based index of the item.

    Remarks

    Sets the zero-based index for the item.

    If the item is not in the item collection (e.g. it is a header item), -1 should be used.

    access

    public

    [ Top ]

    TItemDataRenderer::setItemType

    setItemType( TListItemType $value );

    Implementation of:
    IItemDataRenderer::setItemType()

    Parameters

    $value

    item type.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:38 +0200 by phpDocumentor 1.4.3


Docs For Class TJavascriptLogger

Class TJavascriptLogger

[line 33]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TJavascriptLogger
Location: /Web/UI/WebControls/TJavascriptLogger.php

Remarks

TJavascriptLogger class.

Provides logging for client-side javascript. Example: template code

  • <com:TJavascriptLogger />
    •

    Client-side javascript code to log info, error, warn, debug

  • Logger.warn('A warning');
    •

  •  Logger.info('something happend');
    •

    To see the logger and console, press ALT-D (or CTRL-D on OS X). More information on the logger can be found at http://web.archive.org/web/20060512041505/gleepglop.com/javascripts/logger/

    author

    Wei Zhuo<weizhuo[at]gmail[dot]com>

    version

    $Id: TJavascriptLogger.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TJavascriptLogger::getTagName

      getTagName( );

      Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

      Returns

      tag name of the panel

      access

      protected

      [ Top ]

      TJavascriptLogger::getToggleKey

      getToggleKey( );

      Returns

      keyboard key for toggling the console.

      access

      public

      [ Top ]

      TJavascriptLogger::onPreRender

      onPreRender( TEventParameter $param );

      Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

      Parameters

      $param

      event parameter

      Remarks

      Registers the required logger javascript.

      access

      public

      [ Top ]

      TJavascriptLogger::renderContents

      renderContents( THtmlWriter $writer );

      Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

      Parameters

      $writer

      the writer used for the rendering purpose

      Remarks

      Register the required javascript libraries and display some general usage information.

      access

      public

      [ Top ]

      TJavascriptLogger::setToggleKey

      setToggleKey( string $value );

      Parameters

      $value

      keyboard key for toggling the console, default is J.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:39 +0200 by phpDocumentor 1.4.3


Docs For Class TKeyboard

Class TKeyboard

[line 40]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TKeyboard
Location: /Web/UI/WebControls/TKeyboard.php

Remarks

Class TKeyboard.

TKeyboard displays a virtual keyboard that users can click on to enter input in an associated text box. It helps to reduce the keyboard recording hacking.

To use TKeyboard, write a template like following:

  •  <com:TTextBox ID="PasswordInput" />
    •

  •  <com:TKeyboard ForControl="PasswordInput" />
    •

    A TKeyboard control is associated with a TTextBox control by specifying ForControl to be the ID of that control. When the textbox is in focus, a virtual keyboard will pop up; and when the text box is losing focus, the keyboard will hide automatically. Set AutoHide to false to keep the keyboard showing all the time.

    The appearance of the keyboard can also be changed by specifying a customized CSS file via CssUrl. By default, the CSS class name for the keyboard is 'Keyboard'. This may also be changed by specifying KeyboardCssClass.

    author

    Sergey Morkovkin <sergeymorkovkin@mail.ru> and Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TKeyboard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.1.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TKeyboard::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

      Parameters

      $writer

      the writer used for the rendering purpose

      Remarks

      Adds attribute name-value pairs to renderer.

      This method overrides the parent implementation with additional TKeyboard specific attributes.

      access

      protected

      [ Top ]

      TKeyboard::getAutoHide

      getAutoHide( );

      Returns

      whether the keyboard should be hidden when the textbox is not in focus. Defaults to true.

      access

      public

      [ Top ]

      TKeyboard::getClientClassName

      getClientClassName( );

      Returns

      the Javascript class name for this control

      access

      protected

      [ Top ]

      TKeyboard::getClientOptions

      getClientOptions( );

      Returns

      the JavaScript options for this control

      access

      protected

      [ Top ]

      TKeyboard::getCssUrl

      getCssUrl( );

      Returns

      the URL for the CSS file to customize the appearance of the keyboard.

      access

      public

      [ Top ]

      TKeyboard::getForControl

      getForControl( );

      Returns

      the ID path of the TTextBox control

      access

      public

      [ Top ]

      TKeyboard::getKeyboardCssClass

      getKeyboardCssClass( );

      Returns

      the CSS class name for the keyboard <div> element. Defaults to 'Keyboard'.

      access

      public

      [ Top ]

      TKeyboard::onPreRender

      onPreRender( mixed $param );

      Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

      Parameters

      $param

      event parameter

      Remarks

      Registers CSS and JS.

      This method is invoked right before the control rendering, if the control is visible.

      access

      public

      [ Top ]

      TKeyboard::registerClientScript

      registerClientScript( );

      Remarks

      Registers the relevant JavaScript.

      access

      protected

      [ Top ]

      TKeyboard::registerStyleSheet

      registerStyleSheet( );

      Remarks

      Registers the CSS relevant to the TKeyboard.

      It will register the CSS file specified by CssUrl. If that is not set, it will use the default CSS.

      access

      protected

      [ Top ]

      TKeyboard::setAutoHide

      setAutoHide( boolean $value );

      Parameters

      $value

      whether the keyboard should be hidden when the textbox is not in focus.

      access

      public

      [ Top ]

      TKeyboard::setCssUrl

      setCssUrl( string $value );

      Parameters

      $value

      the URL for the CSS file to customize the appearance of the keyboard.

      access

      public

      [ Top ]

      TKeyboard::setForControl

      setForControl( string $value );

      Parameters

      $value

      the ID path

      Remarks

      Sets the ID path of the TTextBox control.

      The ID path is the dot-connected IDs of the controls reaching from the keyboard's naming container to the target control.

      access

      public

      [ Top ]

      TKeyboard::setKeyboardCssClass

      setKeyboardCssClass( string $value );

      Parameters

      $value

      the CSS class name for the keyboard <div> element.

      Remarks

      Sets a value indicating the CSS class name for the keyboard <div> element.

      Note, if you change this property, make sure you also supply a customized CSS file by specifying CssUrl which uses the new CSS class name for styling.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:39 +0200 by phpDocumentor 1.4.3


Docs For Class TLabel

Class TLabel

[line 33]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
Classes extended from TLabel:
TActiveLabel
TActiveLabel class
TBaseValidator
TBaseValidator class

Location: /Web/UI/WebControls/TLabel.php

Remarks

TLabel class

TLabel displays a piece of text on a Web page. Use Text property to set the text to be displayed. TLabel will render the contents enclosed within its component tag if Text is empty. To use TLabel as a form label, associate it with a control by setting the ForControl property. The associated control must be locatable within the label's naming container. If the associated control is not visible, the label will not be rendered, either.

Note, Text will NOT be encoded for rendering. Make sure it does not contain dangerous characters that you want to avoid.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLabel.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TLabel::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveLabel::addAttributesToRender()
    Adds attribute id to the renderer.
    TBaseValidator::addAttributesToRender()
    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
    TActiveCustomValidator::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    the renderer

    Remarks

    Adds attributes to renderer.

    throws

    TInvalidDataValueException if associated control cannot be found using the ID

    access

    protected

    [ Top ]

    TLabel::getData

    getData( );

    Returns

    the text value of the label

    Remarks

    Returns the text value of the label.

    This method is required by IDataRenderer. It is the same as getText().

    see

    TLabel::getText()

    since

    3.1.0

    access

    public

    [ Top ]

    TLabel::getForControl

    getForControl( );

    Returns

    the associated control ID

    access

    public

    [ Top ]

    TLabel::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name of the label, returns 'label' if there is an associated control, 'span' otherwise.

    access

    protected

    [ Top ]

    TLabel::getText

    getText( );

    Returns

    the text value of the label

    access

    public

    [ Top ]

    TLabel::render

    render( THtmlWriter $writer );

    Overrides TWebControl::render() (Renders the control.)

    Parameters

    $writer

    writer

    Remarks

    Renders the label.

    It overrides the parent implementation by checking if an associated control is visible or not. If not, the label will not be rendered.

    access

    public

    [ Top ]

    TLabel::renderContents

    renderContents( THtmlWriter $writer );

    Overridden in child classes as:

    TBaseValidator::renderContents()
    Renders the validator control.

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    the renderer

    Remarks

    Renders the body content of the label.

    access

    public

    [ Top ]

    TLabel::setData

    setData( string $value );

    Parameters

    $value

    the text value of the label

    Remarks

    Sets the text value of the label.

    This method is required by IDataRenderer. It is the same as setText().

    see

    TLabel::setText()

    since

    3.1.0

    access

    public

    [ Top ]

    TLabel::setForControl

    setForControl( string $value );

    Overridden in child classes as:

    TActiveLabel::setForControl()
    Sets the ID of the control that the label is associated with.
    TBaseValidator::setForControl()
    This method overrides the parent implementation to forbid setting ForControl.

    Parameters

    $value

    the associated control ID

    Remarks

    Sets the ID of the control that the label is associated with.

    The control must be locatable via TControl::findControl using the ID.

    access

    public

    [ Top ]

    TLabel::setText

    setText( string $value );

    Overridden in child classes as:

    TActiveLabel::setText()
    On callback response, the inner HTML of the label is updated.

    Parameters

    $value

    the text value of the label

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:40 +0200 by phpDocumentor 1.4.3


Docs For Class TLinkButton

Class TLinkButton

[line 57]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLinkButton
Classes extended from TLinkButton:
TActiveLinkButton
TActiveLinkButton is the active control counter part to TLinkButton.

Location: /Web/UI/WebControls/TLinkButton.php

Remarks

TLinkButton class

TLinkButton creates a hyperlink style button on the page. TLinkButton has the same appearance as a hyperlink. However, it is mainly used to submit data to a page. Like TButton, you can create either a submit button or a command button.

A command button has a command name (specified by the CommandName property) and and a command parameter (specified by CommandParameter property) associated with the button. This allows you to create multiple TLinkButton components on a Web page and programmatically determine which one is clicked with what parameter. You can provide an event handler for OnCommand event to programmatically control the actions performed when the command button is clicked. In the event handler, you can determine the CommandName property value and the CommandParameter property value through the TCommandParameter::getName and TCommandParameter::getParameter properties of the event parameter which is of type TCommandEventParameter.

A submit button does not have a command name associated with the button and clicking on it simply posts the Web page back to the server. By default, a TLinkButton component is a submit button. You can provide an event handler for the OnClick event to programmatically control the actions performed when the submit button is clicked.

Clicking on button can trigger form validation, if CausesValidation is true. And the validation may be restricted within a certain group of validator controls by setting ValidationGroup property. If validation is successful, the data will be post back to the same page.

TLinkButton will display the Text property value as the hyperlink text. If Text is empty, the body content of TLinkButton will be displayed. Therefore, you can use TLinkButton as an image button by enclosing an &lt;img&gt; tag as the body of TLinkButton.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLinkButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TLinkButton::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveLinkButton::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attribute name-value pairs to renderer.

    This overrides the parent implementation with additional button specific attributes.

    access

    protected

    [ Top ]

    TLinkButton::getCausesValidation

    getCausesValidation( );

    Returns

    whether postback event trigger by this button will cause input validation

    access

    public

    [ Top ]

    TLinkButton::getClientClassName

    getClientClassName( );

    Overridden in child classes as:

    TActiveLinkButton::getClientClassName()

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TLinkButton::getCommandName

    getCommandName( );

    Returns

    the command name associated with the OnCommand event.

    access

    public

    [ Top ]

    TLinkButton::getCommandParameter

    getCommandParameter( );

    Returns

    the parameter associated with the OnCommand event

    access

    public

    [ Top ]

    TLinkButton::getData

    getData( );

    Returns

    caption of the button.

    Remarks

    Returns the caption of the button.

    This method is required by IDataRenderer. It is the same as getText().

    see

    TLinkButton::getText()

    since

    3.1.0

    access

    public

    [ Top ]

    TLinkButton::getEnableClientScript

    getEnableClientScript( );

    Returns

    whether to render javascript.

    access

    public

    [ Top ]

    TLinkButton::getIsDefaultButton

    getIsDefaultButton( );

    Returns

    true if this button is registered as a default button for a panel.

    access

    public

    [ Top ]

    TLinkButton::getPostBackOptions

    getPostBackOptions( );

    Returns

    parameters about how the button defines its postback behavior.

    Remarks

    Returns postback specifications for the button.

    This method is used by framework and control developers.

    access

    protected

    [ Top ]

    TLinkButton::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name of the button

    access

    protected

    [ Top ]

    TLinkButton::getText

    getText( );

    Returns

    the text caption of the button

    access

    public

    [ Top ]

    TLinkButton::getValidationGroup

    getValidationGroup( );

    Returns

    the group of validators which the button causes validation upon postback

    access

    public

    [ Top ]

    TLinkButton::onClick

    onClick( TEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the button is clicked.

    The method raises 'OnClick' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TLinkButton::onCommand

    onCommand( TCommandEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the button is clicked.

    The method raises 'OnCommand' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

    access

    public

    [ Top ]

    TLinkButton::raisePostBackEvent

    raisePostBackEvent( TEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the postback event.

    This method is required by IPostBackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick and OnCommand events. This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TLinkButton::renderClientControlScript

    renderClientControlScript( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveLinkButton::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    Parameters

    $writer

    renderer

    Remarks

    Renders the client-script code.

    access

    protected

    [ Top ]

    TLinkButton::renderContents

    renderContents( THtmlWriter $writer );

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the body content enclosed between the control tag.

    If Text is not empty, it will be rendered. Otherwise, the body content enclosed in the control tag will be rendered.

    access

    public

    [ Top ]

    TLinkButton::renderLinkButtonHref

    renderLinkButtonHref( THtmlWriter $writer );

    Parameters

    $writer

    renderer

    Remarks

    Renders the Href for link button.

    access

    protected

    [ Top ]

    TLinkButton::setCausesValidation

    setCausesValidation( string $value );

    Parameters

    $value

    the text caption to be set

    Remarks

    Sets the value indicating whether postback event trigger by this button will cause input validation.

    access

    public

    [ Top ]

    TLinkButton::setCommandName

    setCommandName( string $value );

    Parameters

    $value

    the command name associated with the OnCommand event.

    access

    public

    [ Top ]

    TLinkButton::setCommandParameter

    setCommandParameter( string $value );

    Parameters

    $value

    the parameter associated with the OnCommand event.

    access

    public

    [ Top ]

    TLinkButton::setData

    setData( string $value );

    Parameters

    $value

    caption of the button

    Remarks

    Sets the caption of the button.

    This method is required by IDataRenderer. It is the same as setText().

    see

    TLinkButton::setText()

    since

    3.1.0

    access

    public

    [ Top ]

    TLinkButton::setEnableClientScript

    setEnableClientScript( boolean $value );

    Parameters

    $value

    whether to render javascript.

    access

    public

    [ Top ]

    TLinkButton::setIsDefaultButton

    setIsDefaultButton( boolean $value );

    Parameters

    $value

    set by a panel to register this button as the default button for the panel.

    access

    public

    [ Top ]

    TLinkButton::setText

    setText( string $value );

    Overridden in child classes as:

    TActiveLinkButton::setText()
    Updates the link text on the client-side if the setEnableUpdate property is set to true.

    Parameters

    $value

    the text caption to be set

    access

    public

    [ Top ]

    TLinkButton::setValidationGroup

    setValidationGroup( string $value );

    Parameters

    $value

    the group of validators which the button causes validation upon postback

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:41 +0200 by phpDocumentor 1.4.3


Docs For Class TListBox

Class TListBox

[line 39]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TListBox
Classes extended from TListBox:
TActiveListBox
TActiveListBox class.

Location: /Web/UI/WebControls/TListBox.php

Remarks

TListBox class

TListBox displays a list box on a Web page that allows single or multiple selection. The list box allows multiple selections if SelectionMode is TListSelectionMode::Multiple. It takes single selection only if Single. The property Rows specifies how many rows of options are visible at a time. See TListControl for inherited properties.

Since v3.0.3, TListBox starts to support optgroup. To specify an option group for a list item, set a Group attribute with it,

  •   $listitem->Attributes->Group="Group Name";
    •

  •   // or <com:TListItem Attributes.Group="Group Name" .../> in template
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TListBox.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TListControl

    • TListControl::addAttributesToRender()
      Adds attributes to renderer.
    • TListControl::addParsedObject()
      Adds object parsed from template to the control.
    • TListControl::clearSelection()
      Clears all existing selections.
    • TListControl::createListItemCollection()
      Creates a collection object to hold list items.
    • TListControl::formatDataValue()
      Formats the text value according to a format string.
    • TListControl::getAppendDataBoundItems()
    • TListControl::getAutoPostBack()
    • TListControl::getCausesValidation()
    • TListControl::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
    • TListControl::getData()
      Returns the value of the selected item with the lowest cardinal index.
    • TListControl::getDataGroupField()
    • TListControl::getDataTextField()
    • TListControl::getDataTextFormatString()
    • TListControl::getDataValueField()
    • TListControl::getEnableClientScript()
    • TListControl::getHasItems()
    • TListControl::getIsMultiSelect()
    • TListControl::getItemCount()
    • TListControl::getItems()
    • TListControl::getPostBackOptions()
    • TListControl::getPromptText()
    • TListControl::getPromptValue()
    • TListControl::getSelectedIndex()
    • TListControl::getSelectedIndices()
    • TListControl::getSelectedItem()
    • TListControl::getSelectedValue()
    • TListControl::getSelectedValues()
    • TListControl::getTagName()
    • TListControl::getText()
    • TListControl::getValidationGroup()
    • TListControl::loadState()
      Loads items from viewstate.
    • TListControl::onSelectedIndexChanged()
      Raises OnSelectedIndexChanged event when selection is changed.
    • TListControl::onTextChanged()
      Raises OnTextChanged event when selection is changed.
    • TListControl::performDataBinding()
      Performs databinding to populate list items from data source.
    • TListControl::renderClientControlScript()
      Renders the javascript for list control.
    • TListControl::renderContents()
      Renders body content of the list control.
    • TListControl::renderPrompt()
      Renders the prompt text, if any.
    • TListControl::saveState()
      Saves items into viewstate.
    • TListControl::setAppendDataBoundItems()
    • TListControl::setAutoPostBack()
      Sets the value indicating if postback automatically.
    • TListControl::setCausesValidation()
    • TListControl::setData()
      Selects an item by the specified value.
    • TListControl::setDataGroupField()
    • TListControl::setDataTextField()
    • TListControl::setDataTextFormatString()
      Sets data text format string.
    • TListControl::setDataValueField()
    • TListControl::setEnableClientScript()
    • TListControl::setPromptText()
    • TListControl::setPromptValue()
    • TListControl::setSelectedIndex()
    • TListControl::setSelectedIndices()
    • TListControl::setSelectedValue()
      Sets selection by item value.
    • TListControl::setSelectedValues()
    • TListControl::setText()
    • TListControl::setValidationGroup()

    Inherited From Class TDataBoundControl

    • TDataBoundControl::createPagedDataSource()
    • TDataBoundControl::dataBind()
      Performs databinding.
    • TDataBoundControl::dataSourceViewChanged()
    • TDataBoundControl::determineDataSource()
    • TDataBoundControl::ensureDataBound()
      Ensures any pending dataBind is called.
    • TDataBoundControl::getAllowCustomPaging()
    • TDataBoundControl::getAllowPaging()
    • TDataBoundControl::getCurrentPageIndex()
    • TDataBoundControl::getDataMember()
    • TDataBoundControl::getDataSource()
    • TDataBoundControl::getDataSourceID()
    • TDataBoundControl::getDataSourceView()
    • TDataBoundControl::getInitialized()
    • TDataBoundControl::getIsDataBound()
    • TDataBoundControl::getPageCount()
    • TDataBoundControl::getPageSize()
    • TDataBoundControl::getRequiresDataBinding()
    • TDataBoundControl::getSelectParameters()
    • TDataBoundControl::getUsingDataSourceID()
    • TDataBoundControl::getVirtualItemCount()
    • TDataBoundControl::onDataBound()
      Raises OnDataBound event.
    • TDataBoundControl::onDataSourceChanged()
      Sets setRequiresDataBinding as true if the control is initialized.
    • TDataBoundControl::onInit()
      Sets page's OnPreLoad event handler as pagePreLoad.
    • TDataBoundControl::onPreRender()
      Ensures any pending databind is performed.
    • TDataBoundControl::pagePreLoad()
      Sets getInitialized as true.
    • TDataBoundControl::performDataBinding()
    • TDataBoundControl::setAllowCustomPaging()
      Sets a value indicating whether the custom paging should be enabled.
    • TDataBoundControl::setAllowPaging()
    • TDataBoundControl::setCurrentPageIndex()
    • TDataBoundControl::setDataMember()
    • TDataBoundControl::setDataSource()
      Sets the data source object associated with the databound control.
    • TDataBoundControl::setDataSourceID()
    • TDataBoundControl::setInitialized()
      Sets a value indicating whether the databound control is initialized.
    • TDataBoundControl::setIsDataBound()
    • TDataBoundControl::setPageSize()
    • TDataBoundControl::setRequiresDataBinding()
      Sets a value indicating whether a databind call is required by the data bound control.
    • TDataBoundControl::setVirtualItemCount()
    • TDataBoundControl::validateDataSource()
      Validates if the parameter is a valid data source.

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TListBox::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overridden in child classes as:

      TActiveListBox::addAttributesToRender()
      Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

      Overrides TListControl::addAttributesToRender() (Adds attributes to renderer.)

      Parameters

      $writer

      the writer used for the rendering purpose

      Remarks

      Adds attribute name-value pairs to renderer.

      This method overrides the parent implementation with additional list box specific attributes.

      access

      protected

      [ Top ]

      TListBox::getClientClassName

      getClientClassName( );

      Overridden in child classes as:

      TActiveListBox::getClientClassName()
      Javascript client class for this control.

      Overrides TListControl::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

      Returns

      the javascript class name

      Remarks

      Gets the name of the javascript class responsible for performing postback for this control.

      This method overrides the parent implementation.

      access

      protected

      [ Top ]

      TListBox::getDataChanged

      getDataChanged( );

      Returns

      whether postback has caused the control data change. False if the page is not in postback mode.

      Remarks

      Returns a value indicating whether postback has caused the control data change.

      This method is required by the IPostBackDataHandler interface.

      access

      public

      [ Top ]

      TListBox::getIsMultiSelect

      getIsMultiSelect( );

      Overrides TListControl::getIsMultiSelect() (parent method not documented)

      Returns

      whether this control allows multiple selection

      access

      protected

      [ Top ]

      TListBox::getIsValid

      getIsValid( );

      Returns

      wether this control validated successfully.

      Remarks

      Returns true if this control validated successfully.

      Defaults to true.

      access

      public

      [ Top ]

      TListBox::getRows

      getRows( );

      Returns

      the number of rows to be displayed in the list control

      access

      public

      [ Top ]

      TListBox::getSelectionMode

      getSelectionMode( );

      Returns

      the selection mode (Single, Multiple). Defaults to TListSelectionMode::Single.

      access

      public

      [ Top ]

      TListBox::getValidationPropertyValue

      getValidationPropertyValue( );

      Returns

      the value of the property to be validated.

      Remarks

      Returns the value to be validated.

      This methid is required by IValidatable interface.

      access

      public

      [ Top ]

      TListBox::loadPostData

      loadPostData( string $key, array $values );

      Parameters

      $key

      the key that can be used to retrieve data from the input data collection

      $values

      the input data collection

      Returns

      whether the data of the component has been changed

      Remarks

      Loads user input data.

      This method is primarly used by framework developers.

      access

      public

      [ Top ]

      TListBox::onPreRender

      onPreRender( mixed $param );

      Overridden in child classes as:

      TActiveListBox::onPreRender()
      Updates the client-side options if the item list has changed after the OnLoad event.

      Overrides TDataBoundControl::onPreRender() (Ensures any pending databind is performed.)

      Parameters

      $param

      event parameter

      Remarks

      Registers the list control to load post data on postback.

      This method overrides the parent implementation.

      access

      public

      [ Top ]

      TListBox::raisePostDataChangedEvent

      raisePostDataChangedEvent( );

      Remarks

      Raises postdata changed event.

      This method is required by IPostBackDataHandler interface. It is invoked by the framework when SelectedIndices property is changed on postback. This method is primarly used by framework developers.

      access

      public

      [ Top ]

      TListBox::setIsValid

      setIsValid( bool $value );

      Parameters

      $value

      wether this control is valid.

      access

      public

      [ Top ]

      TListBox::setRows

      setRows( integer $value );

      Parameters

      $value

      the number of rows to be displayed in the list control

      access

      public

      [ Top ]

      TListBox::setSelectionMode

      setSelectionMode( TListSelectionMode $value );

      Overridden in child classes as:

      TActiveListBox::setSelectionMode()
      Sets the selection mode of the list control (Single, Multiple) on the client-side if the setEnableUpdate property is set to true.

      Parameters

      $value

      the selection mode

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:42 +0200 by phpDocumentor 1.4.3


Docs For Class TListSelectionMode

Class TListSelectionMode

[line 257]
TEnumerable
   |
   --TListSelectionMode
Location: /Web/UI/WebControls/TListBox.php

Remarks

TListSelectionMode class.

TListSelectionMode defines the enumerable type for the possible selection modes of a TListBox.

The following enumerable values are defined:

  • Single: single selection
  • Multiple: allow multiple selection

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TListBox.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Multiple = 'Multiple'
  • Single = 'Single'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Multiple = 'Multiple' [line 260]

  • Single = 'Single' [line 259]

Documentation generated on Mon, 25 Jun 2012 14:44:43 +0200 by phpDocumentor 1.4.3


Docs For Class TListControl

Class TListControl

[line 83]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
Classes extended from TListControl:
TBulletedList
TBulletedList class
TCheckBoxList
TCheckBoxList class
TDropDownList
TDropDownList class
TListBox
TListBox class

Location: /Web/UI/WebControls/TListControl.php

Remarks

TListControl class

TListControl is a base class for list controls, such as TListBox, TDropDownList, TCheckBoxList, etc. It manages the items and their status in a list control. It also implements how the items can be populated from template and data source.

The property getItems returns a list of the items in the control. To specify or determine which item is selected, use the SelectedIndex property that indicates the zero-based index of the selected item in the item list. You may also use SelectedItem and SelectedValue to get the selected item and its value. For multiple selection lists (such as TCheckBoxList and TListBox), property SelectedIndices is useful.

TListControl implements AutoPostBack which allows a list control to postback the page if the selections of the list items are changed. The CausesValidation and ValidationGroup properties may be used to specify that validation be performed when auto postback occurs.

There are three ways to populate the items in a list control: from template, using DataSource and using DataSourceID. The latter two are covered in TDataBoundControl. To specify items via template, using the following template syntax:

  •  <com:TListControl>
    •

  •    <com:TListItem Value="xxx" Text="yyy" >
    •

  •    <com:TListItem Value="xxx" Text="yyy" Selected="true" >
    •

  •    <com:TListItem Value="xxx" Text="yyy" >
    •

  •  </com:TListControl>
    •

    When DataSource or DataSourceID is used to populate list items, the DataTextField and DataValueField properties are used to specify which columns of the data will be used to populate the text and value of the items. For example, if a data source is as follows,

  •  $dataSource=array(
    •

  •     array('name'=>'John', 'age'=>31),
    •

  •     array('name'=>'Cary', 'age'=>28),
    •

  •     array('name'=>'Rose', 'age'=>35),
    •

  •  );
    •
    setting DataTextField and DataValueField to 'name' and 'age' will make the first item's text be 'John', value be 31, the second item's text be 'Cary', value be 28, and so on. The DataTextFormatString property may be further used to format how the item should be displayed. See formatDataValue() for an explanation of the format string.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TListControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    abstract

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TDataBoundControl

    • TDataBoundControl::createPagedDataSource()
    • TDataBoundControl::dataBind()
      Performs databinding.
    • TDataBoundControl::dataSourceViewChanged()
    • TDataBoundControl::determineDataSource()
    • TDataBoundControl::ensureDataBound()
      Ensures any pending dataBind is called.
    • TDataBoundControl::getAllowCustomPaging()
    • TDataBoundControl::getAllowPaging()
    • TDataBoundControl::getCurrentPageIndex()
    • TDataBoundControl::getDataMember()
    • TDataBoundControl::getDataSource()
    • TDataBoundControl::getDataSourceID()
    • TDataBoundControl::getDataSourceView()
    • TDataBoundControl::getInitialized()
    • TDataBoundControl::getIsDataBound()
    • TDataBoundControl::getPageCount()
    • TDataBoundControl::getPageSize()
    • TDataBoundControl::getRequiresDataBinding()
    • TDataBoundControl::getSelectParameters()
    • TDataBoundControl::getUsingDataSourceID()
    • TDataBoundControl::getVirtualItemCount()
    • TDataBoundControl::onDataBound()
      Raises OnDataBound event.
    • TDataBoundControl::onDataSourceChanged()
      Sets setRequiresDataBinding as true if the control is initialized.
    • TDataBoundControl::onInit()
      Sets page's OnPreLoad event handler as pagePreLoad.
    • TDataBoundControl::onPreRender()
      Ensures any pending databind is performed.
    • TDataBoundControl::pagePreLoad()
      Sets getInitialized as true.
    • TDataBoundControl::performDataBinding()
    • TDataBoundControl::setAllowCustomPaging()
      Sets a value indicating whether the custom paging should be enabled.
    • TDataBoundControl::setAllowPaging()
    • TDataBoundControl::setCurrentPageIndex()
    • TDataBoundControl::setDataMember()
    • TDataBoundControl::setDataSource()
      Sets the data source object associated with the databound control.
    • TDataBoundControl::setDataSourceID()
    • TDataBoundControl::setInitialized()
      Sets a value indicating whether the databound control is initialized.
    • TDataBoundControl::setIsDataBound()
    • TDataBoundControl::setPageSize()
    • TDataBoundControl::setRequiresDataBinding()
      Sets a value indicating whether a databind call is required by the data bound control.
    • TDataBoundControl::setVirtualItemCount()
    • TDataBoundControl::validateDataSource()
      Validates if the parameter is a valid data source.

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TListControl::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overridden in child classes as:

      TBulletedList::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
      TDropDownList::addAttributesToRender()
      Adds attributes to renderer.
      TActiveDropDownList::addAttributesToRender()
      Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
      TListBox::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
      TActiveListBox::addAttributesToRender()
      Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

      Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

      Parameters

      $writer

      the renderer

      Remarks

      Adds attributes to renderer.

      access

      protected

      [ Top ]

      TListControl::addParsedObject

      addParsedObject( mixed $object );

      Overrides TControl::addParsedObject() (Adds the object instantiated on a template to the child control collection.)

      Parameters

      $object

      object parsed from template

      Remarks

      Adds object parsed from template to the control.

      This method adds only TListItem objects into the Items collection. All other objects are ignored.

      access

      public

      [ Top ]

      TListControl::clearSelection

      clearSelection( );

      Remarks

      Clears all existing selections.

      access

      public

      [ Top ]

      TListControl::createListItemCollection

      createListItemCollection( );

      Overridden in child classes as:

      TActiveDropDownList::createListItemCollection()
      Creates a collection object to hold list items. A specialized TActiveListItemCollection is created to allow the drop down list options to be added.
      TActiveListBox::createListItemCollection()
      Creates a collection object to hold list items. A specialized TActiveListItemCollection is created to allow the drop down list options to be added.

      Returns

      the collection object

      Remarks

      Creates a collection object to hold list items.

      This method may be overriden to create a customized collection.

      access

      protected

      [ Top ]

      TListControl::formatDataValue

      formatDataValue( string $formatString, mixed $value );

      Parameters

      $formatString

      format string

      $value

      the data to be formatted

      Returns

      the formatted result

      Remarks

      Formats the text value according to a format string.

      If the format string is empty, the original value is converted into a string and returned. If the format string starts with '#', the string is treated as a PHP expression within which the token '{0}' is translated with the data value to be formated. Otherwise, the format string and the data value are passed as the first and second parameters in http://www.php.net/sprintf.

      access

      protected

      [ Top ]

      TListControl::getAppendDataBoundItems

      getAppendDataBoundItems( );

      Returns

      whether performing databind should append items or clear the existing ones. Defaults to false.

      access

      public

      [ Top ]

      TListControl::getAutoPostBack

      getAutoPostBack( );

      Returns

      a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. Defaults to false.

      access

      public

      [ Top ]

      TListControl::getCausesValidation

      getCausesValidation( );

      Returns

      whether postback event trigger by this list control will cause input validation, default is true.

      access

      public

      [ Top ]

      TListControl::getClientClassName

      getClientClassName( );

      Overridden in child classes as:

      TBulletedList::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
      TCheckBoxList::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
      TRadioButtonList::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
      TRatingList::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
      TActiveRatingList::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
      TDropDownList::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
      TActiveDropDownList::getClientClassName()
      No client class for this control.
      TListBox::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
      TActiveListBox::getClientClassName()
      Javascript client class for this control.

      Returns

      the javascript class name

      Remarks

      Gets the name of the javascript class responsible for performing postback for this control.

      Derived classes may override this method and return customized js class names.

      access

      protected

      [ Top ]

      TListControl::getData

      getData( );

      Returns

      the value of the selected item with the lowest cardinal index, empty if no selection.

      Remarks

      Returns the value of the selected item with the lowest cardinal index.

      This method is required by IDataRenderer. It is the same as getSelectedValue().

      see

      TListControl::getSelectedValue()

      since

      3.1.0

      access

      public

      [ Top ]

      TListControl::getDataGroupField

      getDataGroupField( );

      Returns

      the field of the data source that provides the label of the list item groups

      access

      public

      [ Top ]

      TListControl::getDataTextField

      getDataTextField( );

      Returns

      the field of the data source that provides the text content of the list items.

      access

      public

      [ Top ]

      TListControl::getDataTextFormatString

      getDataTextFormatString( );

      Returns

      the formatting string used to control how data bound to the list control is displayed.

      access

      public

      [ Top ]

      TListControl::getDataValueField

      getDataValueField( );

      Returns

      the field of the data source that provides the value of each list item.

      access

      public

      [ Top ]

      TListControl::getEnableClientScript

      getEnableClientScript( );

      Returns

      whether to render javascript.

      access

      public

      [ Top ]

      TListControl::getHasItems

      getHasItems( );

      Returns

      whether the list control contains any items.

      access

      public

      [ Top ]

      TListControl::getIsMultiSelect

      getIsMultiSelect( );

      Overridden in child classes as:

      TCheckBoxList::getIsMultiSelect()
      TRadioButtonList::getIsMultiSelect()
      TListBox::getIsMultiSelect()

      Returns

      whether this is a multiselect control. Defaults to false.

      access

      protected

      [ Top ]

      TListControl::getItemCount

      getItemCount( );

      Returns

      the number of items in the list control

      access

      public

      [ Top ]

      TListControl::getItems

      getItems( );

      Returns

      the item collection

      access

      public

      [ Top ]

      TListControl::getPostBackOptions

      getPostBackOptions( );

      Overridden in child classes as:

      TBulletedList::getPostBackOptions()
      TCheckBoxList::getPostBackOptions()
      Gets the post back options for this checkbox.
      TRatingList::getPostBackOptions()

      Returns

      postback options for JS postback code

      access

      protected

      [ Top ]

      TListControl::getPromptText

      getPromptText( );

      Returns

      the prompt text which is to be displayed as the first list item.

      since

      3.1.1

      access

      public

      [ Top ]

      TListControl::getPromptValue

      getPromptValue( );

      Returns

      the prompt selection value.

      see

      TListControl::getPromptText()

      since

      3.1.1

      access

      public

      [ Top ]

      TListControl::getSelectedIndex

      getSelectedIndex( );

      Returns

      the index (zero-based) of the item being selected, -1 if no item is selected.

      access

      public

      [ Top ]

      TListControl::getSelectedIndices

      getSelectedIndices( );

      Returns

      list of index of items that are selected

      access

      public

      [ Top ]

      TListControl::getSelectedItem

      getSelectedItem( );

      Returns

      the selected item with the lowest cardinal index, null if no item is selected.

      access

      public

      [ Top ]

      TListControl::getSelectedValue

      getSelectedValue( );

      Returns

      the value of the selected item with the lowest cardinal index, empty if no selection

      access

      public

      [ Top ]

      TListControl::getSelectedValues

      getSelectedValues( );

      Returns

      list of the selected item values (strings)

      access

      public

      [ Top ]

      TListControl::getTagName

      getTagName( );

      Overridden in child classes as:

      TBulletedList::getTagName()

      Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

      Returns

      tag name of the list control

      access

      protected

      [ Top ]

      TListControl::getText

      getText( );

      Returns

      selected value

      access

      public

      [ Top ]

      TListControl::getValidationGroup

      getValidationGroup( );

      Returns

      the group of validators which the list control causes validation upon postback

      access

      public

      [ Top ]

      TListControl::loadState

      loadState( );

      Overrides TControl::loadState() (This method is invoked right after the control has loaded its state.)

      Remarks

      Loads items from viewstate.

      This method is invoked right after control state is loaded.

      access

      public

      [ Top ]

      TListControl::onSelectedIndexChanged

      onSelectedIndexChanged( TEventParameter $param );

      Overridden in child classes as:

      TRatingList::onSelectedIndexChanged()

      Parameters

      $param

      event parameter

      Remarks

      Raises OnSelectedIndexChanged event when selection is changed.

      This method is invoked when the list control has its selection changed by end-users.

      access

      public

      [ Top ]

      TListControl::onTextChanged

      onTextChanged( TEventParameter $param );

      Parameters

      $param

      event parameter

      Remarks

      Raises OnTextChanged event when selection is changed.

      This method is invoked when the list control has its selection changed by end-users.

      access

      public

      [ Top ]

      TListControl::performDataBinding

      performDataBinding( Traversable $data );

      Overrides TDataBoundControl::performDataBinding() (parent method not documented)

      Parameters

      $data

      the data

      Remarks

      Performs databinding to populate list items from data source.

      This method is invoked by dataBind(). You may override this function to provide your own way of data population.

      access

      protected

      [ Top ]

      TListControl::renderClientControlScript

      renderClientControlScript( $writer );

      Overridden in child classes as:

      TActiveCheckBoxList::renderClientControlScript()
      Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
      TActiveRadioButtonList::renderClientControlScript()
      Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
      TActiveDropDownList::renderClientControlScript()
      Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
      TActiveListBox::renderClientControlScript()
      Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

      Parameters

      $writer

      Remarks

      Renders the javascript for list control.

      access

      protected

      [ Top ]

      TListControl::renderContents

      renderContents( THtmlWriter $writer );

      Overridden in child classes as:

      TBulletedList::renderContents()
      Renders the body contents.

      Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

      Parameters

      $writer

      writer

      Remarks

      Renders body content of the list control.

      This method renders items contained in the list control as the body content.

      access

      public

      [ Top ]

      TListControl::renderPrompt

      renderPrompt( THtmlWriter $writer );

      Parameters

      $writer

      writer

      Remarks

      Renders the prompt text, if any.

      since

      3.1.1

      access

      protected

      [ Top ]

      TListControl::saveState

      saveState( );

      Overrides TControl::saveState() (This method is invoked when control state is to be saved.)

      Remarks

      Saves items into viewstate.

      This method is invoked right before control state is to be saved.

      access

      public

      [ Top ]

      TListControl::setAppendDataBoundItems

      setAppendDataBoundItems( boolean $value );

      Parameters

      $value

      whether performing databind should append items or clear the existing ones.

      access

      public

      [ Top ]

      TListControl::setAutoPostBack

      setAutoPostBack( boolean $value );

      Overridden in child classes as:

      TBulletedList::setAutoPostBack()

      Parameters

      $value

      the value indicating if postback automatically

      Remarks

      Sets the value indicating if postback automatically.

      An automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it.

      access

      public

      [ Top ]

      TListControl::setCausesValidation

      setCausesValidation( boolean $value );

      Parameters

      $value

      whether postback event trigger by this list control will cause input validation.

      access

      public

      [ Top ]

      TListControl::setData

      setData( string $value );

      Parameters

      $value

      the value of the item to be selected.

      Remarks

      Selects an item by the specified value.

      This method is required by IDataRenderer. It is the same as setSelectedValue().

      see

      TListControl::setSelectedValue()

      since

      3.1.0

      access

      public

      [ Top ]

      TListControl::setDataGroupField

      setDataGroupField( string $value );

      Parameters

      $value

      the field of the data source that provides the label of the list item groups

      access

      public

      [ Top ]

      TListControl::setDataTextField

      setDataTextField( string $value );

      Parameters

      $value

      the field of the data source that provides the text content of the list items.

      access

      public

      [ Top ]

      TListControl::setDataTextFormatString

      setDataTextFormatString( string $value );

      Parameters

      $value

      the formatting string used to control how data bound to the list control is displayed.

      Remarks

      Sets data text format string.

      The format string is used in TDataValueFormatter::format() to format the Text property value of each item in the list control.

      see

      TDataValueFormatter::format()

      access

      public

      [ Top ]

      TListControl::setDataValueField

      setDataValueField( string $value );

      Parameters

      $value

      the field of the data source that provides the value of each list item.

      access

      public

      [ Top ]

      TListControl::setEnableClientScript

      setEnableClientScript( boolean $value );

      Parameters

      $value

      whether to render javascript.

      access

      public

      [ Top ]

      TListControl::setPromptText

      setPromptText( string $value );

      Parameters

      $value

      the prompt text which is to be displayed as the first list item.

      since

      3.1.1

      access

      public

      [ Top ]

      TListControl::setPromptValue

      setPromptValue( string $value );

      Parameters

      $value

      the prompt selection value. If empty, PromptText will be used as the value.

      see

      TListControl::setPromptText()

      since

      3.1.1

      access

      public

      [ Top ]

      TListControl::setSelectedIndex

      setSelectedIndex( integer $index );

      Overridden in child classes as:

      TBulletedList::setSelectedIndex()
      TRatingList::setSelectedIndex()

      Parameters

      $index

      the index (zero-based) of the item to be selected

      access

      public

      [ Top ]

      TListControl::setSelectedIndices

      setSelectedIndices( array $indices );

      Overridden in child classes as:

      TBulletedList::setSelectedIndices()
      TRadioButtonList::setSelectedIndices()
      TDropDownList::setSelectedIndices()

      Parameters

      $indices

      list of index of items to be selected

      access

      public

      [ Top ]

      TListControl::setSelectedValue

      setSelectedValue( string $value );

      Overridden in child classes as:

      TBulletedList::setSelectedValue()

      Parameters

      $value

      the value of the item to be selected.

      Remarks

      Sets selection by item value.

      Existing selections will be cleared if the item value is found in the item collection. Note, if the value is null, existing selections will also be cleared.

      access

      public

      [ Top ]

      TListControl::setSelectedValues

      setSelectedValues( array $values );

      Overridden in child classes as:

      TBulletedList::setSelectedValues()

      Parameters

      $values

      list of the selected item values

      access

      public

      [ Top ]

      TListControl::setText

      setText( string $value );

      Parameters

      $value

      value to be selected

      access

      public

      [ Top ]

      TListControl::setValidationGroup

      setValidationGroup( string $value );

      Parameters

      $value

      the group of validators which the list control causes validation upon postback

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:43 +0200 by phpDocumentor 1.4.3


Docs For Class TListControlValidator

Class TListControlValidator

[line 64]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TListControlValidator
Location: /Web/UI/WebControls/TListControlValidator.php

Remarks

TListControlValidator class.

TListControlValidator checks the number of selection and their values for a TListControl that allows multiple selection.

You can specify the minimum or maximum (or both) number of selections required using the MinSelection and MaxSelection properties, respectively. In addition, you can specify a comma separated list of required selected values via the RequiredSelections property.

Examples

  • At least two selections
  •     <com:TListBox ID="listbox" SelectionMode="Multiple">
    •

  •         <com:TListItem Text="item1" Value="value1" />
    •

  •         <com:TListItem Text="item2" Value="value2" />
    •

  •         <com:TListItem Text="item3" Value="value3" />
    •

  •     </com:TListBox>
    •

  •
    •

  •     <com:TListControlValidator
    •

  •         ControlToValidate="listbox"
    •

  •         MinSelection="2"
    •

  •         ErrorMessage="Please select at least 2" />
    •
  • "value1" must be selected and at least 1 other
  •     <com:TCheckBoxList ID="checkboxes">
    •

  •         <com:TListItem Text="item1" Value="value1" />
    •

  •         <com:TListItem Text="item2" Value="value2" />
    •

  •         <com:TListItem Text="item3" Value="value3" />
    •

  •     </com:TCheckBoxList>
    •

  •
    •

  •     <com:TListControlValidator
    •

  •         ControlToValidate="checkboxes"
    •

  •         RequiredSelections="value1"
    •

  •         MinSelection="2"
    •

  •         ErrorMessage="Please select 'item1' and at least 1 other" />
    •

author

Xiang Wei Zhuo <weizhuo[at]gmail.com>

version

$Id: TListControlValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TBaseValidator

  • TBaseValidator::__construct()
    Constructor.
  • TBaseValidator::addAttributesToRender()
    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
  • TBaseValidator::createClientSide()
  • TBaseValidator::evaluateIsValid()
    This is the major method for validation.
  • TBaseValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
  • TBaseValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
  • TBaseValidator::getClientSide()
    Gets the TValidatorClientSide that allows modification of the client- side validator events.
  • TBaseValidator::getControlCssClass()
  • TBaseValidator::getControlToValidate()
  • TBaseValidator::getDisplay()
  • TBaseValidator::getEnableClientScript()
  • TBaseValidator::getErrorMessage()
  • TBaseValidator::getFocusElementID()
    Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::getFocusOnError()
  • TBaseValidator::getIsValid()
  • TBaseValidator::getValidationGroup()
  • TBaseValidator::getValidationTarget()
  • TBaseValidator::getValidationValue()
    Retrieves the property value of the control being validated.
  • TBaseValidator::onInit()
    Registers the validator with page.
  • TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
  • TBaseValidator::onUnload()
    Unregisters the validator from page.
  • TBaseValidator::onValidate()
    This event is raised right before the validator starts to perform validation.
  • TBaseValidator::onValidationError()
    This event is raised when the validator fails in validation.
  • TBaseValidator::onValidationSuccess()
    This event is raised when the validator succeeds in validation.
  • TBaseValidator::registerClientScriptValidator()
    Registers the individual validator client-side javascript code.
  • TBaseValidator::renderClientControlScript()
    Renders the javascript code to the end script.
  • TBaseValidator::renderContents()
    Renders the validator control.
  • TBaseValidator::setControlCssClass()
  • TBaseValidator::setControlToValidate()
    Sets the ID path of the input control to validate.
  • TBaseValidator::setDisplay()
  • TBaseValidator::setEnableClientScript()
  • TBaseValidator::setEnabled()
    This method overrides parent's implementation by setting setIsValid to true if disabled.
  • TBaseValidator::setErrorMessage()
    Sets the text for the error message.
  • TBaseValidator::setFocusElementID()
    Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::setFocusOnError()
  • TBaseValidator::setForControl()
    This method overrides the parent implementation to forbid setting ForControl.
  • TBaseValidator::setIsValid()
    Sets the value indicating whether the validation succeeds
  • TBaseValidator::setValidationGroup()
  • TBaseValidator::updateControlCssClass()
    Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
  • TBaseValidator::validate()
    Validates the specified control.

Inherited From Class TLabel

  • TLabel::addAttributesToRender()
    Adds attributes to renderer.
  • TLabel::getData()
    Returns the text value of the label.
  • TLabel::getForControl()
  • TLabel::getTagName()
  • TLabel::getText()
  • TLabel::render()
    Renders the label.
  • TLabel::renderContents()
    Renders the body content of the label.
  • TLabel::setData()
    Sets the text value of the label.
  • TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
  • TLabel::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TListControlValidator::evaluateIsValid

    evaluateIsValid( );

    Overrides TBaseValidator::evaluateIsValid() (This is the major method for validation.)

    Returns

    whether the validation succeeds

    Remarks

    This method overrides the parent's implementation.

    The validation succeeds if the input component changes its data from the InitialValue or the input component is not given.

    access

    protected

    [ Top ]

    TListControlValidator::getClientClassName

    getClientClassName( );

    Overrides TBaseValidator::getClientClassName() (Gets the name of the javascript class responsible for performing validation for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing validation for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TListControlValidator::getClientScriptOptions

    getClientScriptOptions( );

    Overrides TBaseValidator::getClientScriptOptions() (Returns an array of javascript validator options.)

    Returns

    javascript validator options.

    Remarks

    Returns an array of javascript validator options.

    access

    protected

    [ Top ]

    TListControlValidator::getMaxSelection

    getMaxSelection( );

    Returns

    max number of selections. Defaults to -1, meaning not set.

    access

    public

    [ Top ]

    TListControlValidator::getMinSelection

    getMinSelection( );

    Returns

    min number of selections. Defaults to -1, meaning not set.

    access

    public

    [ Top ]

    TListControlValidator::getRequiredSelections

    getRequiredSelections( );

    Returns

    comma separated list of required values.

    Remarks

    Get a comma separated list of required selected values.

    access

    public

    [ Top ]

    TListControlValidator::getRequiredValues

    getRequiredValues( );

    Returns

    list of required values.

    access

    protected

    [ Top ]

    TListControlValidator::getSelection

    getSelection( TListControl $control );

    Parameters

    $control

    control to validate

    Returns

    number of selected values and its values.

    access

    protected

    [ Top ]

    TListControlValidator::setMaxSelection

    setMaxSelection( integer $value );

    Parameters

    $value

    max number of selections.

    access

    public

    [ Top ]

    TListControlValidator::setMinSelection

    setMinSelection( integer $value );

    Parameters

    $value

    minimum number of selections.

    access

    public

    [ Top ]

    TListControlValidator::setRequiredSelections

    setRequiredSelections( string $value );

    Parameters

    $value

    comma separated list of required values.

    Remarks

    Set the list of required values, using aa comma separated list.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:44 +0200 by phpDocumentor 1.4.3


Docs For Class TListItem

Class TListItem

[line 28]
TComponent
   |
   --TListItem
Location: /Web/UI/WebControls/TListItem.php

Remarks

TListItem class.

TListItem represents an item in a list control. Each item has a Text property and a Value property. If either one of them is not set, it will take the value of the other property. An item can be Selected or Enabled, and it can have additional Attributes which may be rendered if the list control supports so.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TListItem.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TListItem::__construct

    __construct(
[string
$text = ''], [string
$value = ''], [boolean
$enabled = true], [boolean
$selected = false] );

    Parameters

    $text

    text of the item

    $value

    value of the item

    $enabled

    whether the item is enabled

    $selected

    whether the item is selected

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TListItem::getAttribute

    getAttribute( $name );

    Parameters

    $name

    Returns

    the named attribute value, null if attribute does not exist

    access

    public

    [ Top ]

    TListItem::getAttributes

    getAttributes( );

    Returns

    custom attributes

    access

    public

    [ Top ]

    TListItem::getEnabled

    getEnabled( );

    Returns

    whether the item is enabled

    access

    public

    [ Top ]

    TListItem::getHasAttributes

    getHasAttributes( );

    Returns

    whether the item has any custom attribute

    access

    public

    [ Top ]

    TListItem::getSelected

    getSelected( );

    Returns

    whether the item is selected

    access

    public

    [ Top ]

    TListItem::getText

    getText( );

    Returns

    text of the item

    access

    public

    [ Top ]

    TListItem::getValue

    getValue( );

    Returns

    value of the item

    access

    public

    [ Top ]

    TListItem::hasAttribute

    hasAttribute( string $name );

    Parameters

    $name

    name of the attribute

    Returns

    whether the named attribute exists

    access

    public

    [ Top ]

    TListItem::removeAttribute

    removeAttribute( string $name );

    Parameters

    $name

    the name of the attribute to be removed.

    Returns

    attribute value removed, empty string if attribute does not exist.

    Remarks

    Removes the named attribute.

    access

    public

    [ Top ]

    TListItem::setAttribute

    setAttribute( string $name, string $value );

    Parameters

    $name

    attribute name

    $value

    value of the attribute

    access

    public

    [ Top ]

    TListItem::setEnabled

    setEnabled( boolean $value );

    Parameters

    $value

    whether the item is enabled

    access

    public

    [ Top ]

    TListItem::setSelected

    setSelected( boolean $value );

    Parameters

    $value

    whether the item is selected

    access

    public

    [ Top ]

    TListItem::setText

    setText( string $value );

    Parameters

    $value

    text of the item

    access

    public

    [ Top ]

    TListItem::setValue

    setValue( string $value );

    Parameters

    $value

    value of the item

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:45 +0200 by phpDocumentor 1.4.3


Docs For Class TLiteral

Class TLiteral

[line 34]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TLiteral
Location: /Web/UI/WebControls/TLiteral.php

Remarks

TLiteral class

TLiteral displays a static text on the Web page. TLiteral is similar to the TLabel control, except that the TLiteral control does not have style properties (e.g. BackColor, Font, etc.) You can programmatically control the text displayed in the control by setting the Text property. The text displayed may be HTML-encoded if the Encode property is set true (defaults to false).

TLiteral will render the contents enclosed within its component tag if Text is empty.

Note, if Encode is false, make sure Text does not contain unwanted characters that may bring security vulnerabilities.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLiteral.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TLiteral::getData

    getData( );

    Returns

    the static text of the TLiteral

    Remarks

    Returns the static text of the TLiteral.

    This method is required by IDataRenderer. It is the same as getText().

    see

    TLiteral::getText()

    since

    3.1.0

    access

    public

    [ Top ]

    TLiteral::getEncode

    getEncode( );

    Returns

    whether the rendered text should be HTML-encoded. Defaults to false.

    access

    public

    [ Top ]

    TLiteral::getText

    getText( );

    Returns

    the static text of the TLiteral

    access

    public

    [ Top ]

    TLiteral::render

    render( THtmlWriter $writer );

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the literal control.

    access

    public

    [ Top ]

    TLiteral::setData

    setData( string $value );

    Parameters

    $value

    the static text of the TLiteral

    Remarks

    Sets the static text of the TLiteral.

    This method is required by IDataRenderer. It is the same as setText().

    see

    TLiteral::setText()

    since

    3.1.0

    access

    public

    [ Top ]

    TLiteral::setEncode

    setEncode( boolean $value );

    Parameters

    $value

    whether the rendered text should be HTML-encoded.

    access

    public

    [ Top ]

    TLiteral::setText

    setText( string $value );

    Parameters

    $value

    the text to be set

    Remarks

    Sets the static text of the TLiteral

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:45 +0200 by phpDocumentor 1.4.3


Docs For Class TLiteralColumn

Class TLiteralColumn

[line 36]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TLiteralColumn
Classes extended from TLiteralColumn:
TActiveLiteralColumn
TActiveLiteralColumn class

Location: /Web/UI/WebControls/TLiteralColumn.php

Remarks

TLiteralColumn class

TLiteralColumn represents a static text column that is bound to a field in a data source. The cells in the column will be displayed with static texts using the data indexed by DataField. You can customize the display by setting DataFormatString.

If DataField is not specified, the cells will be filled with Text.

If Encode is true, the static texts will be HTML-encoded.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLiteralColumn.php 1397 2006-09-07 07:55:53Z wei $

since

3.0.5

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDataGridColumn

  • TDataGridColumn::formatDataValue()
    Formats the text value according to a format string.
  • TDataGridColumn::getAllowSorting()
    Returns a value indicating whether this column allows sorting.
  • TDataGridColumn::getDataFieldValue()
    Fetches the value of the data at the specified field.
  • TDataGridColumn::getEnableCellGrouping()
  • TDataGridColumn::getFooterRenderer()
  • TDataGridColumn::getFooterStyle()
  • TDataGridColumn::getFooterText()
  • TDataGridColumn::getHeaderImageUrl()
  • TDataGridColumn::getHeaderRenderer()
  • TDataGridColumn::getHeaderStyle()
  • TDataGridColumn::getHeaderText()
  • TDataGridColumn::getID()
  • TDataGridColumn::getItemStyle()
  • TDataGridColumn::getOwner()
  • TDataGridColumn::getSortExpression()
  • TDataGridColumn::getViewState()
    Returns a viewstate value.
  • TDataGridColumn::getVisible()
  • TDataGridColumn::initialize()
    Initializes the column.
  • TDataGridColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TDataGridColumn::initializeFooterCell()
    Initializes the footer cell.
  • TDataGridColumn::initializeHeaderCell()
    Initializes the header cell.
  • TDataGridColumn::loadState()
    Loads persistent state values.
  • TDataGridColumn::saveState()
    Saves persistent state values.
  • TDataGridColumn::setEnableCellGrouping()
  • TDataGridColumn::setFooterRenderer()
    Sets the column footer cell renderer class.
  • TDataGridColumn::setFooterText()
  • TDataGridColumn::setHeaderImageUrl()
  • TDataGridColumn::setHeaderRenderer()
    Sets the column header cell renderer class.
  • TDataGridColumn::setHeaderText()
  • TDataGridColumn::setID()
    Sets the ID of the column.
  • TDataGridColumn::setOwner()
  • TDataGridColumn::setSortExpression()
  • TDataGridColumn::setViewState()
    Sets a viewstate value.
  • TDataGridColumn::setVisible()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TLiteralColumn::dataBindColumn

    dataBindColumn( $sender, $param );

    Parameters

    $sender

    $param

    Remarks

    Databinds a cell in the column.

    This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

    access

    public

    [ Top ]

    TLiteralColumn::getDataField

    getDataField( );

    Returns

    the field name from the data source to bind to the column

    access

    public

    [ Top ]

    TLiteralColumn::getDataFormatString

    getDataFormatString( );

    Returns

    the formatting string used to control how the bound data will be displayed.

    access

    public

    [ Top ]

    TLiteralColumn::getEncode

    getEncode( );

    Returns

    whether the rendered text should be HTML-encoded. Defaults to false.

    access

    public

    [ Top ]

    TLiteralColumn::getText

    getText( );

    Returns

    static text to be displayed in the column. Defaults to empty.

    access

    public

    [ Top ]

    TLiteralColumn::initializeCell

    initializeCell( TTableCell $cell, integer $columnIndex, string $itemType );

    Overrides TDataGridColumn::initializeCell() (Initializes the specified cell to its initial values.)

    Parameters

    $cell

    the cell to be initialized.

    $columnIndex

    the index to the Columns property that the cell resides in.

    $itemType

    the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)

    Remarks

    Initializes the specified cell to its initial values.

    This method overrides the parent implementation.

    access

    public

    [ Top ]

    TLiteralColumn::setDataField

    setDataField( string $value );

    Parameters

    $value

    the field name from the data source to bind to the column

    access

    public

    [ Top ]

    TLiteralColumn::setDataFormatString

    setDataFormatString( string $value );

    Parameters

    $value

    the formatting string used to control how the bound data will be displayed.

    access

    public

    [ Top ]

    TLiteralColumn::setEncode

    setEncode( boolean $value );

    Parameters

    $value

    whether the rendered text should be HTML-encoded.

    access

    public

    [ Top ]

    TLiteralColumn::setText

    setText( string $value );

    Parameters

    $value

    static text to be displayed in the column.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:46 +0200 by phpDocumentor 1.4.3


Docs For Class TMarkdown

Class TMarkdown

[line 46]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextProcessor
               |
               --TTextHighlighter
                  |
                  --TMarkdown
Location: /Web/UI/WebControls/TMarkdown.php

Remarks

TMarkdown class

TMarkdown is a control that produces HTML from code with markdown syntax.

Markdown is a text-to-HTML conversion tool for web writers. Markdown allows you to write using an easy-to-read, easy-to-write plain text format, then convert it to structurally valid XHTML (or HTML). Further documentation regarding Markdown can be found at http://daringfireball.net/projects/markdown/

To use TMarkdown, simply enclose the content to be rendered within the body of TMarkdown in a template.

See http://www.pradosoft.com/demos/quickstart/?page=Markdown for details on the Markdown syntax usage.

TMarkdown also performs syntax highlighting for code blocks whose language is recognized by TTextHighlighter. The language of a code block must be specified in the first line of the block and enclosed within a pair of square brackets (e.g. [php]).

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TMarkdown.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TTextHighlighter

  • TTextHighlighter::getEnableCopyCode()
  • TTextHighlighter::getHeaderTemplate()
  • TTextHighlighter::getLanguage()
  • TTextHighlighter::getLineNumberStyle()
  • TTextHighlighter::getShowLineNumbers()
  • TTextHighlighter::getTabSize()
  • TTextHighlighter::getTagName()
  • TTextHighlighter::onPreRender()
    Registers css style for the highlighted result.
  • TTextHighlighter::processText()
    Processes a text string.
  • TTextHighlighter::registerStyleSheet()
    Registers the stylesheet for presentation.
  • TTextHighlighter::render()
  • TTextHighlighter::setEnableCopyCode()
  • TTextHighlighter::setLanguage()
  • TTextHighlighter::setLineNumberStyle()
  • TTextHighlighter::setShowLineNumbers()
  • TTextHighlighter::setTabSize()

Inherited From Class TTextProcessor

  • TTextProcessor::addParsedObject()
    HTML-decodes static text.
  • TTextProcessor::getText()
  • TTextProcessor::processText()
    Processes a text string.
  • TTextProcessor::renderContents()
    Renders body content.
  • TTextProcessor::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TMarkdown::highlightCode

    highlightCode( array $matches );

    Parameters

    $matches

    matches of code blocks

    Returns

    highlighted code.

    Remarks

    Highlights source code using TTextHighlighter

    access

    protected

    [ Top ]

    TMarkdown::processText

    processText( string $text );

    Overrides TTextHighlighter::processText() (Processes a text string.)

    Parameters

    $text

    text string to be processed

    Returns

    the processed text result

    Remarks

    Processes a text string.

    This method is required by the parent class.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:49 +0200 by phpDocumentor 1.4.3


Docs For Class TMultiView

Class TMultiView

[line 39]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TMultiView
Classes extended from TMultiView:
TActiveMultiView
TActiveMultiView class.

Location: /Web/UI/WebControls/TMultiView.php

Remarks

TMultiView class

TMultiView serves as a container for a group of TView controls. The view collection can be retrieved by Views. Each view contains child controls. TMultiView determines which view and its child controls are visible. At any time, at most one view is visible (called active). To make a view active, set ActiveView or ActiveViewIndex.

TMultiView also responds to specific command events raised from button controls contained in current active view. A command event with name 'NextView' will cause TMultiView to make the next available view active. Other command names recognized by TMultiView include

  • PreviousView : switch to previous view
  • SwitchViewID : switch to a view by its ID path
  • SwitchViewIndex : switch to a view by its index in the Views collection.
TMultiView raises OnActiveViewChanged event when its active view is changed during a postback.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TMultiView.php 3055 2011-10-31 08:20:28Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • CMD_NEXTVIEW = 'NextView'
  • CMD_PREVIOUSVIEW = 'PreviousView'
  • CMD_SWITCHVIEWID = 'SwitchViewID'
  • CMD_SWITCHVIEWINDEX = 'SwitchViewIndex'

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TMultiView::activateView

    activateView( TView $view, [boolean $triggerViewChangedEvent = true] );

    Parameters

    $view

    the view to be activated

    $triggerViewChangedEvent

    whether to trigger OnActiveViewChanged event.

    Remarks

    Activates the specified view.

    If there is any view currently active, it will be deactivated.

    access

    protected

    [ Top ]

    TMultiView::addParsedObject

    addParsedObject( string|TComponent $object );

    Overrides TControl::addParsedObject() (Adds the object instantiated on a template to the child control collection.)

    Parameters

    $object

    text string or component parsed and instantiated in template

    Remarks

    Processes an object that is created during parsing template.

    This method overrides the parent implementation by adding only TView controls as children.

    see

    TComponent::createdOnTemplate()

    throws

    TConfigurationException if controls other than TView is being added

    access

    public

    [ Top ]

    TMultiView::bubbleEvent

    bubbleEvent( TControl $sender, mixed $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    sender of the event

    $param

    event parameter

    Returns

    whether this event is handled

    Remarks

    Processes the events bubbled from child controls.

    The method handles view-related command events.

    access

    public

    [ Top ]

    TMultiView::createControlCollection

    createControlCollection( );

    Overrides TControl::createControlCollection() (Creates a control collection object that is to be used to hold child controls)

    Returns

    control collection

    Remarks

    Creates a control collection object that is to be used to hold child controls

    access

    protected

    [ Top ]

    TMultiView::getActiveView

    getActiveView( );

    Returns

    the currently active view, null if no active view

    throws

    TInvalidDataValueException if the current active view index is invalid

    access

    public

    [ Top ]

    TMultiView::getActiveViewIndex

    getActiveViewIndex( );

    Returns

    the zero-based index of the current view in the view collection. -1 if no active view. Default is -1.

    access

    public

    [ Top ]

    TMultiView::getViews

    getViews( );

    Returns

    the view collection

    access

    public

    [ Top ]

    TMultiView::ignoreBubbleEvents

    ignoreBubbleEvents( );

    Remarks

    Makes the multiview ignore all bubbled events.

    This is method is used internally by framework and control developers.

    access

    public

    [ Top ]

    TMultiView::loadState

    loadState( );

    Overrides TControl::loadState() (This method is invoked right after the control has loaded its state.)

    Remarks

    Loads state into the wizard.

    This method is invoked by the framework when the control state is being saved.

    access

    public

    [ Top ]

    TMultiView::onActiveViewChanged

    onActiveViewChanged( TEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnActiveViewChanged event.

    The event is raised when the currently active view is changed to a new one

    access

    public

    [ Top ]

    TMultiView::onInit

    onInit( TEventParameter $param );

    Overrides TControl::onInit() (This method is invoked when the control enters 'OnInit' stage.)

    Parameters

    $param

    event parameter

    Remarks

    Initializes the active view if any.

    This method overrides the parent implementation.

    access

    public

    [ Top ]

    TMultiView::render

    render( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveMultiView::render()
    Renders the TActiveMultiView.

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    the writer for the rendering purpose.

    Remarks

    Renders the currently active view.

    access

    public

    [ Top ]

    TMultiView::setActiveView

    setActiveView( TView $view );

    Overridden in child classes as:

    TActiveMultiView::setActiveView()

    Parameters

    $view

    the view to be activated

    throws

    TInvalidOperationException if the view is not in the view collection

    access

    public

    [ Top ]

    TMultiView::setActiveViewIndex

    setActiveViewIndex( integer $value );

    Overridden in child classes as:

    TActiveMultiView::setActiveViewIndex()

    Parameters

    $value

    the zero-based index of the current view in the view collection. -1 if no active view.

    throws

    TInvalidDataValueException if the view index is invalid

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • CMD_NEXTVIEW = 'NextView' [line 41]

  • CMD_PREVIOUSVIEW = 'PreviousView' [line 42]

  • CMD_SWITCHVIEWID = 'SwitchViewID' [line 43]

  • CMD_SWITCHVIEWINDEX = 'SwitchViewIndex' [line 44]

Documentation generated on Mon, 25 Jun 2012 14:44:52 +0200 by phpDocumentor 1.4.3


Docs For Class TView

Class TView

[line 314]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TView
Classes extended from TView:
TWizardStep
TWizardStep class.

Location: /Web/UI/WebControls/TMultiView.php

Remarks

TView class

TView is a container for a group of controls. TView must be contained within a TMultiView control in which only one view can be active at one time.

To activate a view, set Active to true. When a view is activated, it raises OnActivate event; and when a view is deactivated, it raises OnDeactivate.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TMultiView.php 3055 2011-10-31 08:20:28Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TView::getActive

    getActive( );

    Returns

    whether this view is active. Defaults to false.

    access

    public

    [ Top ]

    TView::getVisible

    getVisible( [boolean $checkParents = true] );

    Overrides TControl::getVisible() (Checks if a control is visible.)

    Parameters

    $checkParents

    whether the parents should also be checked if visible

    Returns

    whether this view is visible. The view is visible if it is active and its parent is visible.

    access

    public

    [ Top ]

    TView::onActivate

    onActivate( TEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnActivate event.

    access

    public

    [ Top ]

    TView::onDeactivate

    onDeactivate( TEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnDeactivate event.

    access

    public

    [ Top ]

    TView::setActive

    setActive( boolean $value );

    Parameters

    $value

    whether this view is active.

    access

    public

    [ Top ]

    TView::setVisible

    setVisible( boolean $value );

    Overrides TControl::setVisible() (parent method not documented)

    Parameters

    $value

    throws

    TInvalidOperationException whenever this method is invoked.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:52 +0200 by phpDocumentor 1.4.3


Docs For Class TViewCollection

Class TViewCollection

[line 279]
TComponent
   |
   --TList
      |
      --TControlCollection
         |
         --TViewCollection
Location: /Web/UI/WebControls/TMultiView.php

Remarks

TViewCollection class.

TViewCollection represents a collection that only takes TView instances as collection elements.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TMultiView.php 3055 2011-10-31 08:20:28Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControlCollection

  • TControlCollection::__construct()
    Constructor.
  • TControlCollection::clear()
    Overrides the parent implementation by invoking TControl::clearNamingContainer
  • TControlCollection::getOwner()
  • TControlCollection::insertAt()
    Inserts an item at the specified position.
  • TControlCollection::removeAt()
    Removes an item at the specified position.

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TViewCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TControlCollection::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by ensuring only TView controls be added into the collection.

    throws

    TInvalidDataTypeException if the item to be inserted is neither a string nor a TControl.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:53 +0200 by phpDocumentor 1.4.3


Docs For Class TOutputCache

Class TOutputCache

[line 70]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TOutputCache
Location: /Web/UI/WebControls/TOutputCache.php

Remarks

TOutputCache class.

TOutputCache enables caching a portion of a Web page, also known as partial caching. The content being cached can be either static or dynamic.

To use TOutputCache, simply enclose the content to be cached within the TOutputCache component tag on a template, e.g.,

  •  <com:TOutputCache>
    •

  •    content to be cached
    •

  •  </com:TOutputCache>
    •
    where content to be cached can be static text and/or component tags.

    The validity of the cached content is determined based on two factors: the Duration and the cache dependency. The former specifies the number of seconds that the data can remain valid in cache (defaults to 60s), while the latter specifies conditions that the cached data depends on. If a dependency changes, (e.g. relevant data in DB are updated), the cached data will be invalidated.

    There are two ways to specify cache dependency. One may write event handlers to respond to the OnCheckDependency event and set the event parameter's TOutputCacheCheckDependencyEventParameter::getIsValid property to indicate whether the cached data remains valid or not. One can also extend TOutputCache and override its getCacheDependency function. While the former is easier to use, the latter offers more extensibility.

    The content fetched from cache may be variated with respect to some parameters. It supports variation with respect to request parameters, which is specified by VaryByParam property. If a specified request parameter is different, a different version of cached content is used. This is extremely useful if a page's content may be variated according to some GET parameters. The content being cached may also be variated with user sessions if VaryBySession is set true. To variate the cached content by other factors, override calculateCacheKey() method.

    Output caches can be nested. An outer cache takes precedence over an inner cache. This means, if the content cached by the inner cache expires or is invalidated, while that by the outer cache not, the outer cached content will be used.

    Note, TOutputCache is effective only for non-postback page requests and when cache module is enabled.

    Do not attempt to address child controls of TOutputCache when the cached content is to be used. Use ContentCached property to determine whether the content is cached or not.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TOutputCache.php 3111 2012-02-14 07:58:17Z ctrlaltca@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    • CACHE_ID_PREFIX = 'prado:outputcache'

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TOutputCache::calculateCacheKey

      calculateCacheKey( );

      Returns

      cache key

      Remarks

      Calculates the cache key.

      The key is calculated based on the unique ID of this control and the request parameters specified via VaryByParam. If VaryBySession is true, the session ID will also participate in the key calculation. This method may be overriden to support other variations in the calculated cache key.

      access

      protected

      [ Top ]

      TOutputCache::getAllowChildControls

      getAllowChildControls( boolean 0 );

      Overrides TControl::getAllowChildControls() (parent method not documented)

      Parameters

      0

      whether body contents are allowed for this control.

      Remarks

      Returns a value indicating whether body contents are allowed for this control.

      This method overrides the parent implementation by checking if cached content is available or not. If yes, it returns false, otherwise true.

      access

      public

      [ Top ]

      TOutputCache::getBaseCacheKey

      getBaseCacheKey( );

      Returns

      basic cache key without variations

      access

      protected

      [ Top ]

      TOutputCache::getCacheDependency

      getCacheDependency( );

      Remarks

      Returns the dependency of the data to be cached.

      The default implementation simply returns null, meaning no specific dependency. This method may be overriden to associate the data to be cached with additional dependencies.

      access

      protected

      [ Top ]

      TOutputCache::getCacheKey

      getCacheKey( );

      access

      public

      [ Top ]

      TOutputCache::getCacheModuleID

      getCacheModuleID( );

      Returns

      the ID of the cache module. Defaults to '', meaning the primary cache module is used.

      access

      public

      [ Top ]

      TOutputCache::getCacheTime

      getCacheTime( );

      Returns

      the timestamp of the cached content. This is only valid if the content is being cached.

      since

      3.1.1

      access

      public

      [ Top ]

      TOutputCache::getCachingPostBack

      getCachingPostBack( );

      Returns

      whether cached output will be used on postback requests. Defaults to false.

      access

      public

      [ Top ]

      TOutputCache::getContentCached

      getContentCached( );

      Returns

      whether content enclosed is cached or not

      access

      public

      [ Top ]

      TOutputCache::getDuration

      getDuration( );

      Returns

      number of seconds that the data can remain in cache. Defaults to 60 seconds. Note, if cache dependency changes or cache space is limited, the data may be purged out of cache earlier.

      access

      public

      [ Top ]

      TOutputCache::getVaryByParam

      getVaryByParam( );

      Returns

      a semicolon-separated list of strings used to vary the output cache. Defaults to ''.

      access

      public

      [ Top ]

      TOutputCache::getVaryBySession

      getVaryBySession( );

      Returns

      whether the content being cached should be differentiated according to user sessions. Defaults to false.

      access

      public

      [ Top ]

      TOutputCache::initRecursive

      initRecursive( [TControl $namingContainer = null] );

      Overrides TControl::initRecursive() (Performs the Init step for the control and all its child controls.)

      Parameters

      $namingContainer

      the naming container control

      Remarks

      Performs the Init step for the control and all its child controls.

      This method overrides the parent implementation by setting up the stack of the output cache in the page. Only framework developers should use this method.

      access

      protected

      [ Top ]

      TOutputCache::loadRecursive

      loadRecursive( TControl 0 );

      Overrides TControl::loadRecursive() (Performs the Load step for the control and all its child controls.)

      Parameters

      0

      the naming container control

      Remarks

      Performs the Load step for the control and all its child controls.

      This method overrides the parent implementation by setting up the stack of the output cache in the page. If the data is restored from cache, it also recovers the actions associated with the cached data. Only framework developers should use this method.

      access

      protected

      [ Top ]

      TOutputCache::loadStateRecursive

      loadStateRecursive( array &$state, [boolean $needViewState = true] );

      Overrides TControl::loadStateRecursive() (Loads state (viewstate and controlstate) into a control and its children.)

      Parameters

      &$state

      the collection of the state

      $needViewState

      whether the viewstate should be loaded

      Remarks

      Loads state (viewstate and controlstate) into a control and its children.

      This method overrides the parent implementation by loading cached state if available. This method should only be used by framework developers.

      access

      protected

      [ Top ]

      TOutputCache::onCalculateKey

      onCalculateKey( TOutputCacheCalculateKeyEventParameter $param );

      Parameters

      $param

      event parameter

      Remarks

      This event is raised when the output cache is calculating cache key.

      By varying cache keys, one can obtain different versions of cached content. An event handler may be written to add variety of the key calculation. The value set in TOutputCacheCalculateKeyEventParameter::setCacheKey of this event parameter will be appended to the default key calculation scheme.

      access

      public

      [ Top ]

      TOutputCache::onCheckDependency

      onCheckDependency( TOutputCacheCheckDependencyEventParameter $param );

      Parameters

      $param

      event parameter

      Remarks

      This event is raised when the output cache is checking cache dependency.

      An event handler may be written to check customized dependency conditions. The checking result should be saved by setting TOutputCacheCheckDependencyEventParameter::setIsValid property of the event parameter (which defaults to true).

      access

      public

      [ Top ]

      TOutputCache::preRenderRecursive

      preRenderRecursive( TControl 0 );

      Overrides TControl::preRenderRecursive() (Performs the PreRender step for the control and all its child controls.)

      Parameters

      0

      the naming container control

      Remarks

      Performs the PreRender step for the control and all its child controls.

      This method overrides the parent implementation by setting up the stack of the output cache in the page. Only framework developers should use this method.

      access

      protected

      [ Top ]

      TOutputCache::registerAction

      registerAction( string $context, string $funcName, array $funcParams );

      Parameters

      $context

      context of the action method. This is a property-path referring to the context object (e.g. Page, Page.ClientScript)

      $funcName

      method name of the context object

      $funcParams

      list of parameters to be passed to the action method

      Remarks

      Registers an action associated with the content being cached.

      The registered action will be replayed if the content stored in the cache is served to end-users.

      access

      public

      [ Top ]

      TOutputCache::render

      render( THtmlWriter $writer );

      Overrides TControl::render() (Renders the control.)

      Parameters

      $writer

      Remarks

      Renders the output cache control.

      This method overrides the parent implementation by capturing the output from its child controls and saving it into cache, if output cache is needed.

      access

      public

      [ Top ]

      TOutputCache::saveStateRecursive

      &saveStateRecursive( [boolean $needViewState = true] );

      Overrides TControl::saveStateRecursive() (Saves all control state (viewstate and controlstate) as a collection.)

      Parameters

      $needViewState

      whether the viewstate should be saved

      Returns

      the collection of the control state (including its children's state).

      Remarks

      Saves all control state (viewstate and controlstate) as a collection.

      This method overrides the parent implementation by saving state into cache if needed. This method should only be used by framework developers.

      access

      protected

      [ Top ]

      TOutputCache::setCacheKeyPrefix

      setCacheKeyPrefix( string $value );

      Parameters

      $value

      key prefix

      Remarks

      Sets the prefix of the cache key.

      This method is used internally by TTemplate.

      access

      public

      [ Top ]

      TOutputCache::setCacheModuleID

      setCacheModuleID( string $value );

      Parameters

      $value

      the ID of the cache module. If empty, the primary cache module will be used.

      access

      public

      [ Top ]

      TOutputCache::setCachingPostBack

      setCachingPostBack( boolean $value );

      Parameters

      $value

      whether cached output will be used on postback requests.

      Remarks

      Sets a value indicating whether cached output will be used on postback requests.

      By default, this is disabled. Be very cautious when enabling it. If the cached content including interactive user controls such as TTextBox, TDropDownList, your page may fail to render on postbacks.

      access

      public

      [ Top ]

      TOutputCache::setDuration

      setDuration( integer $value );

      Parameters

      $value

      number of seconds that the data can remain in cache. If 0, it means data is not cached.

      throws

      TInvalidDataValueException if the value is smaller than 0.

      access

      public

      [ Top ]

      TOutputCache::setVaryByParam

      setVaryByParam( $value );

      Parameters

      $value

      Returns

      a semicolon-separated list of strings used to vary the output cache.

      Remarks

      Sets the names of the request parameters that should be used in calculating the cache key.

      The names should be concatenated by semicolons. By setting this value, the output cache will use different cached data for each different set of request parameter values.

      access

      public

      [ Top ]

      TOutputCache::setVaryBySession

      setVaryBySession( boolean $value );

      Parameters

      $value

      whether the content being cached should be differentiated according to user sessions.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • CACHE_ID_PREFIX = 'prado:outputcache' [line 72]

    Documentation generated on Mon, 25 Jun 2012 14:44:56 +0200 by phpDocumentor 1.4.3


Docs For Class TOutputCacheCalculateKeyEventParameter

Class TOutputCacheCalculateKeyEventParameter

[line 562]
TComponent
   |
   --TEventParameter
      |
      --TOutputCacheCalculateKeyEventParameter
Location: /Web/UI/WebControls/TOutputCache.php

Remarks

TOutputCacheCalculateKeyEventParameter class

TOutputCacheCalculateKeyEventParameter encapsulates the parameter data for OnCalculateKey event of TOutputCache control.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TOutputCache.php 3111 2012-02-14 07:58:17Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TOutputCacheCalculateKeyEventParameter::getCacheKey

    getCacheKey( );

    Returns

    cache key to be appended to the default calculation scheme.

    access

    public

    [ Top ]

    TOutputCacheCalculateKeyEventParameter::setCacheKey

    setCacheKey( string $value );

    Parameters

    $value

    cache key to be appended to the default calculation scheme

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:56 +0200 by phpDocumentor 1.4.3


Docs For Class TOutputCacheCheckDependencyEventParameter

Class TOutputCacheCheckDependencyEventParameter

[line 510]
TComponent
   |
   --TEventParameter
      |
      --TOutputCacheCheckDependencyEventParameter
Location: /Web/UI/WebControls/TOutputCache.php

Remarks

TOutputCacheCheckDependencyEventParameter class

TOutputCacheCheckDependencyEventParameter encapsulates the parameter data for OnCheckDependency event of TOutputCache control.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TOutputCache.php 3111 2012-02-14 07:58:17Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TOutputCacheCheckDependencyEventParameter::getCacheTime

    getCacheTime( );

    Returns

    the timestamp of the cached result. You may use this to help determine any dependency is changed.

    since

    3.1.1

    access

    public

    [ Top ]

    TOutputCacheCheckDependencyEventParameter::getIsValid

    getIsValid( );

    Returns

    whether the dependency remains valid. Defaults to true.

    access

    public

    [ Top ]

    TOutputCacheCheckDependencyEventParameter::setCacheTime

    setCacheTime( integer $value );

    Parameters

    $value

    the timestamp of the cached result. This is used internally.

    since

    3.1.1

    access

    public

    [ Top ]

    TOutputCacheCheckDependencyEventParameter::setIsValid

    setIsValid( boolean $value );

    Parameters

    $value

    whether the dependency remains valid

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:56 +0200 by phpDocumentor 1.4.3


Docs For Class TOutputCacheTextWriterMulti

Class TOutputCacheTextWriterMulti

[line 587]
TComponent
   |
   --TTextWriter
      |
      --TOutputCacheTextWriterMulti
Location: /Web/UI/WebControls/TOutputCache.php

Remarks

TTextWriter class.

TTextWriter implements a memory-based text writer. Content written by TTextWriter are stored in memory and can be obtained by calling flush().

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTextWriter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

Class Variable Summary

  • $_writers =

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TTextWriter

  • TTextWriter::flush()
    Flushes the content that has been written.
  • TTextWriter::write()
    Writes a string.
  • TTextWriter::writeLine()
    Writers a string and terminates it with a newline.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TOutputCacheTextWriterMulti::__construct

    __construct( $writers );

    Parameters

    $writers

    access

    public

    [ Top ]

    TOutputCacheTextWriterMulti::flush

    flush( );

    Overrides TTextWriter::flush() (Flushes the content that has been written.)

    access

    public

    [ Top ]

    TOutputCacheTextWriterMulti::write

    write( $s );

    Overrides TTextWriter::write() (Writes a string.)

    Parameters

    $s

    access

    public

    [ Top ]

Variable Detail

  • $_writers = [line 589]
  • Data type: mixed

    • access

    protected

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:57 +0200 by phpDocumentor 1.4.3


Docs For Class TPager

Class TPager

[line 49]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPager
Classes extended from TPager:
TActivePager
TActivePager is the active control counter part of TPager.

Location: /Web/UI/WebControls/TPager.php

Remarks

TPager class.

TPager creates a pager that provides UI for end-users to interactively specify which page of data to be rendered in a TDataBoundControl-derived control, such as TDataList, TRepeater, TCheckBoxList, etc. The target data-bound control is specified by ControlToPaginate, which must be the ID path of the target control reaching from the pager's naming container. Note, the target control must have its TDataBoundControl::setAllowPaging set to true.

TPager can display three different UIs, specified via Mode:

  • NextPrev: a next page and a previous page button are rendered.
  • Numeric: a list of page index buttons are rendered.
  • List: a dropdown list of page indices are rendered.
When the pager mode is either NextPrev or Numeric, the paging buttons may be displayed in three types by setting ButtonType:
  • LinkButton: a hyperlink button
  • PushButton: a normal button
  • ImageButton: an image button (please set XXXPageImageUrl properties accordingly to specify the button images.)
TPager raises an OnPageIndexChanged event when the end-user interacts with it and specifies a new page (e.g. clicking on a page button that leads to a new page.) The new page index may be obtained from the event parameter's property TPagerPageChangedEventParameter::getNewPageIndex. Normally, in the event handler, one can set the TDataBoundControl::getCurrentPageIndex to this new page index so that the new page of data is rendered.

Multiple pagers can be associated with the same data-bound control.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.2

Class Variable Summary

Class Constant Summary

  • CMD_PAGE = 'Page'
    Command name that TPager understands.
  • CMD_PAGE_FIRST = 'First'
  • CMD_PAGE_LAST = 'Last'
  • CMD_PAGE_NEXT = 'Next'
  • CMD_PAGE_PREV = 'Previous'

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPager::bubbleEvent

    bubbleEvent( TControl $sender, TEventParameter $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    the sender of the event

    $param

    event parameter

    Returns

    whether the event bubbling should stop here.

    Remarks

    Processes a bubbled event.

    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

    access

    public

    [ Top ]

    TPager::buildListPager

    buildListPager( );

    Overridden in child classes as:

    TActivePager::buildListPager()
    Builds a dropdown list pager Override parent implementation to build Active dropdown lists.

    Remarks

    Builds a dropdown list pager

    access

    protected

    [ Top ]

    TPager::buildNextPrevPager

    buildNextPrevPager( );

    Remarks

    Builds a next-prev pager

    access

    protected

    [ Top ]

    TPager::buildNumericPager

    buildNumericPager( );

    Remarks

    Builds a numeric pager

    access

    protected

    [ Top ]

    TPager::buildPager

    buildPager( );

    Remarks

    Builds the pager content based on the pager mode.

    Current implementation includes building 'NextPrev', 'Numeric' and 'DropDownList' pagers. Derived classes may override this method to provide additional pagers.

    access

    protected

    [ Top ]

    TPager::createPagerButton

    createPagerButton( string $buttonType, boolean $enabled, string $text, string $commandName, string $commandParameter );

    Overridden in child classes as:

    TActivePager::createPagerButton()
    Creates a pager button.

    Parameters

    $buttonType

    button type, either LinkButton or PushButton

    $enabled

    whether the button should be enabled

    $text

    caption of the button.

    $commandName

    CommandName corresponding to the OnCommand event of the button.

    $commandParameter

    CommandParameter corresponding to the OnCommand event of the button

    Returns

    the button instance

    Remarks

    Creates a pager button.

    Depending on the button type, a TLinkButton or a TButton may be created. If it is enabled (clickable), its command name and parameter will also be set. Derived classes may override this method to create additional types of buttons, such as TImageButton.

    access

    protected

    [ Top ]

    TPager::getButtonType

    getButtonType( );

    Returns

    the type of command button for paging. Defaults to TPagerButtonType::LinkButton.

    access

    public

    [ Top ]

    TPager::getControlToPaginate

    getControlToPaginate( );

    Returns

    the ID path of the control whose content would be paginated.

    access

    public

    [ Top ]

    TPager::getCurrentPageIndex

    getCurrentPageIndex( );

    Returns

    the zero-based index of the current page. Defaults to 0.

    access

    public

    [ Top ]

    TPager::getFirstPageImageUrl

    getFirstPageImageUrl( );

    Returns

    the image URL for the first page button. This is only used when ButtonType is 'ImageButton'.

    since

    3.1.1

    access

    public

    [ Top ]

    TPager::getFirstPageText

    getFirstPageText( );

    Returns

    text for the first page button. Defaults to '<<'.

    access

    public

    [ Top ]

    TPager::getIsFirstPage

    getIsFirstPage( );

    Returns

    whether the current page is the first page Defaults to false.

    access

    public

    [ Top ]

    TPager::getIsLastPage

    getIsLastPage( );

    Returns

    whether the current page is the last page

    access

    public

    [ Top ]

    TPager::getLastPageImageUrl

    getLastPageImageUrl( );

    Returns

    the image URL for the last page button. This is only used when ButtonType is 'ImageButton'.

    since

    3.1.1

    access

    public

    [ Top ]

    TPager::getLastPageText

    getLastPageText( );

    Returns

    text for the last page button. Defaults to '>>'.

    access

    public

    [ Top ]

    TPager::getMode

    getMode( );

    Returns

    pager mode. Defaults to TPagerMode::NextPrev.

    access

    public

    [ Top ]

    TPager::getNextPageImageUrl

    getNextPageImageUrl( );

    Returns

    the image URL for the next page button. This is only used when ButtonType is 'ImageButton'.

    since

    3.1.1

    access

    public

    [ Top ]

    TPager::getNextPageText

    getNextPageText( );

    Returns

    text for the next page button. Defaults to '>'.

    access

    public

    [ Top ]

    TPager::getNumericPageImageUrl

    getNumericPageImageUrl( );

    Returns

    the image URL for the numeric page buttons. This is only used when ButtonType is 'ImageButton' and Mode is 'Numeric'.

    see

    TPager::setNumericPageImageUrl()

    since

    3.1.1

    access

    public

    [ Top ]

    TPager::getPageButtonCount

    getPageButtonCount( );

    Returns

    maximum number of pager buttons to be displayed. Defaults to 10.

    access

    public

    [ Top ]

    TPager::getPageCount

    getPageCount( );

    Returns

    number of pages of data items available

    access

    public

    [ Top ]

    TPager::getPageImageUrl

    getPageImageUrl( string $text, string $commandName );

    Parameters

    $text

    the caption of the image button

    $commandName

    the command name associated with the image button

    since

    3.1.1

    access

    protected

    [ Top ]

    TPager::getPrevPageImageUrl

    getPrevPageImageUrl( );

    Returns

    the image URL for the previous page button. This is only used when ButtonType is 'ImageButton'.

    since

    3.1.1

    access

    public

    [ Top ]

    TPager::getPrevPageText

    getPrevPageText( );

    Returns

    text for the previous page button. Defaults to '<'.

    access

    public

    [ Top ]

    TPager::listIndexChanged

    listIndexChanged( TDropDownList $sender, TEventParameter $param );

    Parameters

    $sender

    the dropdown list control raising the event

    $param

    event parameter

    Remarks

    Event handler to the OnSelectedIndexChanged event of the dropdown list.

    This handler will raise OnPageIndexChanged event.

    access

    public

    [ Top ]

    TPager::loadState

    loadState( );

    Overrides TControl::loadState() (This method is invoked right after the control has loaded its state.)

    Remarks

    Restores the pager state.

    This method overrides the parent implementation and is invoked when the control is loading persistent state.

    access

    public

    [ Top ]

    TPager::onPageIndexChanged

    onPageIndexChanged( TPagerPageChangedEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    This event is raised when page index is changed due to a page button click.

    access

    public

    [ Top ]

    TPager::onPreRender

    onPreRender( Traversable $param );

    Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

    Parameters

    $param

    the bound data

    Remarks

    Performs databinding to populate data items from data source.

    This method is invoked by dataBind(). You may override this function to provide your own way of data population.

    access

    public

    [ Top ]

    TPager::render

    render( THtmlWriter $writer );

    Overridden in child classes as:

    TActivePager::render()

    Overrides TWebControl::render() (Renders the control.)

    Parameters

    $writer

    the writer

    Remarks

    Renders the control.

    The method overrides the parent implementation by rendering the pager only when there are two or more pages.

    access

    public

    [ Top ]

    TPager::setButtonType

    setButtonType( TPagerButtonType $value );

    Parameters

    $value

    the type of command button for paging.

    access

    public

    [ Top ]

    TPager::setControlToPaginate

    setControlToPaginate( string $value );

    Parameters

    $value

    the ID path

    Remarks

    Sets the ID path of the control whose content would be paginated.

    The ID path is the dot-connected IDs of the controls reaching from the pager's naming container to the target control.

    access

    public

    [ Top ]

    TPager::setCurrentPageIndex

    setCurrentPageIndex( integer $value );

    Parameters

    $value

    the zero-based index of the current page

    throws

    TInvalidDataValueException if the value is less than 0

    access

    protected

    [ Top ]

    TPager::setFirstPageImageUrl

    setFirstPageImageUrl( string $value );

    Parameters

    $value

    the image URL for the first page button. This is only used when ButtonType is 'ImageButton'.

    since

    3.1.1

    access

    public

    [ Top ]

    TPager::setFirstPageText

    setFirstPageText( string $value );

    Parameters

    $value

    text for the first page button. If empty, the first page button will not be rendered.

    access

    public

    [ Top ]

    TPager::setLastPageImageUrl

    setLastPageImageUrl( string $value );

    Parameters

    $value

    the image URL for the last page button. This is only used when ButtonType is 'ImageButton'.

    since

    3.1.1

    access

    public

    [ Top ]

    TPager::setLastPageText

    setLastPageText( string $value );

    Parameters

    $value

    text for the last page button. If empty, the last page button will not be rendered.

    access

    public

    [ Top ]

    TPager::setMode

    setMode( TPagerMode $value );

    Parameters

    $value

    pager mode.

    access

    public

    [ Top ]

    TPager::setNextPageImageUrl

    setNextPageImageUrl( string $value );

    Parameters

    $value

    the image URL for the next page button. This is only used when ButtonType is 'ImageButton'.

    since

    3.1.1

    access

    public

    [ Top ]

    TPager::setNextPageText

    setNextPageText( string $value );

    Parameters

    $value

    text for the next page button.

    access

    public

    [ Top ]

    TPager::setNumericPageImageUrl

    setNumericPageImageUrl( string $value );

    Parameters

    $value

    the image URL for the numeric page buttons. This is only used when ButtonType is 'ImageButton' and Mode is 'Numeric'.

    Remarks

    Sets the image URL for the numeric page buttons.

    This is actually a template for generating a set of URLs corresponding to numeric button 1, 2, 3, .., etc. Use {0} as the placeholder for the numbers. For example, the image URL http://example.com/images/button{0}.gif will be replaced as http://example.com/images/button1.gif, http://example.com/images/button2.gif, etc.

    since

    3.1.1

    access

    public

    [ Top ]

    TPager::setPageButtonCount

    setPageButtonCount( integer $value );

    Parameters

    $value

    maximum number of pager buttons to be displayed

    throws

    TInvalidDataValueException if the value is less than 1.

    access

    public

    [ Top ]

    TPager::setPageCount

    setPageCount( integer $value );

    Parameters

    $value

    number of pages of data items available

    throws

    TInvalidDataValueException if the value is less than 0

    access

    protected

    [ Top ]

    TPager::setPrevPageImageUrl

    setPrevPageImageUrl( string $value );

    Parameters

    $value

    the image URL for the previous page button. This is only used when ButtonType is 'ImageButton'.

    since

    3.1.1

    access

    public

    [ Top ]

    TPager::setPrevPageText

    setPrevPageText( string $value );

    Parameters

    $value

    text for the next page button.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • CMD_PAGE = 'Page' [line 54]

    • Remarks

    Command name that TPager understands.

  • CMD_PAGE_FIRST = 'First' [line 57]

  • CMD_PAGE_LAST = 'Last' [line 58]

  • CMD_PAGE_NEXT = 'Next' [line 55]

  • CMD_PAGE_PREV = 'Previous' [line 56]

Documentation generated on Mon, 25 Jun 2012 14:44:59 +0200 by phpDocumentor 1.4.3


Docs For Class TPagerButtonType

Class TPagerButtonType

[line 786]
TEnumerable
   |
   --TPagerButtonType
Location: /Web/UI/WebControls/TPager.php

Remarks

TPagerButtonType class.

TPagerButtonType defines the enumerable type for the possible types of pager buttons.

The following enumerable values are defined:

  • LinkButton: link buttons
  • PushButton: form submit buttons

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • ImageButton = 'ImageButton'
  • LinkButton = 'LinkButton'
  • PushButton = 'PushButton'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • ImageButton = 'ImageButton' [line 790]

  • LinkButton = 'LinkButton' [line 788]

  • PushButton = 'PushButton' [line 789]

Documentation generated on Mon, 25 Jun 2012 14:44:59 +0200 by phpDocumentor 1.4.3


Docs For Class TPagerMode

Class TPagerMode

[line 765]
TEnumerable
   |
   --TPagerMode
Location: /Web/UI/WebControls/TPager.php

Remarks

TPagerMode class.

TPagerMode defines the enumerable type for the possible modes that a TPager control can take.

The following enumerable values are defined:

  • NextPrev: pager buttons are displayed as next and previous pages
  • Numeric: pager buttons are displayed as numeric page numbers
  • DropDownList: a dropdown list is used to select pages

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • DropDownList = 'DropDownList'
  • NextPrev = 'NextPrev'
  • Numeric = 'Numeric'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • DropDownList = 'DropDownList' [line 769]

  • NextPrev = 'NextPrev' [line 767]

  • Numeric = 'Numeric' [line 768]

Documentation generated on Mon, 25 Jun 2012 14:44:59 +0200 by phpDocumentor 1.4.3


Docs For Class TPagerPageChangedEventParameter

Class TPagerPageChangedEventParameter

[line 711]
TComponent
   |
   --TEventParameter
      |
      --TPagerPageChangedEventParameter
Location: /Web/UI/WebControls/TPager.php

Remarks

TPagerPageChangedEventParameter class

TPagerPageChangedEventParameter encapsulates the parameter data for TPager::onPageIndexChanged event of TPager controls.

The CommandSource property refers to the control that originally raises the OnCommand event, while NewPageIndex returns the new page index carried with the page command.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPagerPageChangedEventParameter::__construct

    __construct( TControl $source, integer $newPageIndex );

    Parameters

    $source

    the control originally raises the OnCommand event.

    $newPageIndex

    new page index

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TPagerPageChangedEventParameter::getCommandSource

    getCommandSource( );

    Returns

    the control originally raises the OnCommand event.

    access

    public

    [ Top ]

    TPagerPageChangedEventParameter::getNewPageIndex

    getNewPageIndex( );

    Returns

    new page index

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:59 +0200 by phpDocumentor 1.4.3


Docs For Class TPanel

Class TPanel

[line 42]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPanel
Classes extended from TPanel:
TActivePanel
TActivePanel is the TPanel active control counterpart.
TDraggable
TDraggable is a control which can be dragged
TDropContainer
TDropContainer is a panel where TDraggable controls can be dropped.
TDataGridPager
TDataGridPager class.

Location: /Web/UI/WebControls/TPanel.php

Remarks

TPanel class

TPanel represents a component that acts as a container for other component. It is especially useful when you want to generate components programmatically or hide/show a group of components.

By default, TPanel displays a &lt;div&gt; element on a page. Children of TPanel are displayed as the body content of the element. The property Wrap can be used to set whether the body content should wrap or not. HorizontalAlign governs how the content is aligned horizontally, and Direction indicates the content direction (left to right or right to left). You can set BackImageUrl to give a background image to the panel, and you can ste GroupingText so that the panel is displayed as a field set with a legend text. Finally, you can specify a default button to be fired when users press 'return' key within the panel by setting the DefaultButton property.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPanel.php 3088 2011-12-23 11:29:03Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPanel::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overridden in child classes as:

    TActivePanel::addAttributesToRender()
    Adds attribute id to the renderer.
    TDraggable::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TDropContainer::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    the renderer

    Remarks

    Adds attributes to renderer.

    throws

    TInvalidDataValueException if default button is not right.

    access

    protected

    [ Top ]

    TPanel::createStyle

    createStyle( );

    Overrides TWebControl::createStyle() (Creates a style object to be used by the control.)

    Returns

    the style used by TPanel.

    Remarks

    Creates a style object to be used by the control.

    This method overrides the parent impementation by creating a TPanelStyle object.

    access

    protected

    [ Top ]

    TPanel::getBackImageUrl

    getBackImageUrl( );

    Returns

    the URL of the background image for the panel component.

    access

    public

    [ Top ]

    TPanel::getDefaultButton

    getDefaultButton( );

    Returns

    the ID path to the default button. Defaults to empty.

    access

    public

    [ Top ]

    TPanel::getDirection

    getDirection( );

    Returns

    alignment of the content in the panel. Defaults to 'NotSet'.

    access

    public

    [ Top ]

    TPanel::getGroupingText

    getGroupingText( );

    Returns

    the legend text when the panel is used as a fieldset. Defaults to empty.

    access

    public

    [ Top ]

    TPanel::getHorizontalAlign

    getHorizontalAlign( );

    Returns

    the horizontal alignment of the contents within the panel, defaults to 'NotSet'.

    access

    public

    [ Top ]

    TPanel::getScrollBars

    getScrollBars( );

    Returns

    the visibility and position of scroll bars in a panel control, defaults to None.

    access

    public

    [ Top ]

    TPanel::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name of the panel

    access

    protected

    [ Top ]

    TPanel::getWrap

    getWrap( );

    Returns

    whether the content wraps within the panel. Defaults to true.

    access

    public

    [ Top ]

    TPanel::render

    render( $writer );

    Overridden in child classes as:

    TActivePanel::render()
    Renders and replaces the panel's content on the client-side.
    TDropContainer::render()
    Renders and replaces the panel's content on the client-side.

    Overrides TWebControl::render() (Renders the control.)

    Parameters

    $writer

    access

    public

    [ Top ]

    TPanel::renderBeginTag

    renderBeginTag( THtmlWriter $writer );

    Overrides TWebControl::renderBeginTag() (Renders the openning tag for the control (including attributes))

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the openning tag for the control (including attributes)

    access

    public

    [ Top ]

    TPanel::renderEndTag

    renderEndTag( THtmlWriter $writer );

    Overrides TWebControl::renderEndTag() (Renders the closing tag for the control)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the closing tag for the control

    access

    public

    [ Top ]

    TPanel::setBackImageUrl

    setBackImageUrl( string $value );

    Parameters

    $value

    the URL

    Remarks

    Sets the URL of the background image for the panel component.

    access

    public

    [ Top ]

    TPanel::setDefaultButton

    setDefaultButton( string $value );

    Parameters

    $value

    the ID path to the default button.

    Remarks

    Specifies the default button for the panel.

    The default button will be fired (clicked) whenever a user enters 'return' key within the panel. The button must be locatable via the function call TControl::findControl.

    access

    public

    [ Top ]

    TPanel::setDirection

    setDirection( string $value );

    Parameters

    $value

    alignment of the content in the panel. Valid values include 'NotSet', 'LeftToRight', 'RightToLeft'.

    access

    public

    [ Top ]

    TPanel::setGroupingText

    setGroupingText( string $value );

    Parameters

    $value

    the legend text. If this value is not empty, the panel will be rendered as a fieldset.

    access

    public

    [ Top ]

    TPanel::setHorizontalAlign

    setHorizontalAlign( string $value );

    Parameters

    $value

    the horizontal alignment

    Remarks

    Sets the horizontal alignment of the contents within the panel.

    Valid values include 'NotSet', 'Justify', 'Left', 'Right', 'Center'

    access

    public

    [ Top ]

    TPanel::setScrollBars

    setScrollBars( string $value );

    Parameters

    $value

    the visibility and position of scroll bars in a panel control. Valid values include None, Auto, Both, Horizontal and Vertical.

    access

    public

    [ Top ]

    TPanel::setWrap

    setWrap( boolean $value );

    Parameters

    $value

    whether the content wraps within the panel.

    Remarks

    Sets the value indicating whether the content wraps within the panel.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:00 +0200 by phpDocumentor 1.4.3


Docs For Class TContentDirection

Class TContentDirection

[line 246]
TEnumerable
   |
   --TContentDirection
Location: /Web/UI/WebControls/TPanelStyle.php

Remarks

TContentDirection class.

TContentDirection defines the enumerable type for the possible directions that a panel can be at.

The following enumerable values are defined:

  • NotSet: the direction is not specified
  • LeftToRight: content in a panel is left to right
  • RightToLeft: content in a panel is right to left

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPanelStyle.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • LeftToRight = 'LeftToRight'
  • NotSet = 'NotSet'
  • RightToLeft = 'RightToLeft'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • LeftToRight = 'LeftToRight' [line 249]

  • NotSet = 'NotSet' [line 248]

  • RightToLeft = 'RightToLeft' [line 250]

Documentation generated on Mon, 25 Jun 2012 14:45:01 +0200 by phpDocumentor 1.4.3


Docs For Class TPanelStyle

Class TPanelStyle

[line 27]
TComponent
   |
   --TStyle
      |
      --TPanelStyle
Classes extended from TPanelStyle:
TDataGridPagerStyle
TDataGridPagerStyle class.

Location: /Web/UI/WebControls/TPanelStyle.php

Remarks

TPanelStyle class.

TPanelStyle represents the CSS style specific for panel HTML tag.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPanelStyle.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TStyle

  • TStyle::__construct()
    Constructor.
  • TStyle::addAttributesToRender()
    Adds attributes related to CSS styles to renderer.
  • TStyle::clearStyleField()
    Clears a single style field value;
  • TStyle::copyFrom()
    Copies the fields in a new style to this style.
  • TStyle::getBackColor()
  • TStyle::getBorderColor()
  • TStyle::getBorderStyle()
  • TStyle::getBorderWidth()
  • TStyle::getCssClass()
  • TStyle::getCustomStyle()
  • TStyle::getDisplayStyle()
  • TStyle::getFont()
  • TStyle::getForeColor()
  • TStyle::getHeight()
  • TStyle::getStyleField()
  • TStyle::getStyleFields()
  • TStyle::getWidth()
  • TStyle::hasCssClass()
  • TStyle::hasFont()
  • TStyle::hasStyleField()
  • TStyle::mergeWith()
    Merges the style with a new one.
  • TStyle::reset()
    Resets the style to the original empty state.
  • TStyle::setBackColor()
  • TStyle::setBorderColor()
  • TStyle::setBorderStyle()
    Sets the border style of the control.
  • TStyle::setBorderWidth()
  • TStyle::setCssClass()
  • TStyle::setCustomStyle()
    Sets custom style fields from a string.
  • TStyle::setDisplayStyle()
  • TStyle::setForeColor()
  • TStyle::setHeight()
  • TStyle::setStyleField()
    Sets a single style field value.
  • TStyle::setWidth()
  • TStyle::__clone()
    Need to clone the font object.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPanelStyle::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overrides TStyle::addAttributesToRender() (Adds attributes related to CSS styles to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attributes related to CSS styles to renderer.

    This method overrides the parent implementation.

    access

    public

    [ Top ]

    TPanelStyle::copyFrom

    copyFrom( TStyle $style );

    Overridden in child classes as:

    TDataGridPagerStyle::copyFrom()
    Copies the fields in a new style to this style.

    Overrides TStyle::copyFrom() (Copies the fields in a new style to this style.)

    Parameters

    $style

    the new style

    Remarks

    Copies the fields in a new style to this style.

    If a style field is set in the new style, the corresponding field in this style will be overwritten.

    access

    public

    [ Top ]

    TPanelStyle::getBackImageUrl

    getBackImageUrl( );

    Returns

    the URL of the background image for the panel component.

    access

    public

    [ Top ]

    TPanelStyle::getDirection

    getDirection( );

    Returns

    alignment of the content in the panel. Defaults to TContentDirection::NotSet.

    access

    public

    [ Top ]

    TPanelStyle::getHorizontalAlign

    getHorizontalAlign( );

    Returns

    the horizontal alignment of the contents within the panel, defaults to THorizontalAlign::NotSet.

    access

    public

    [ Top ]

    TPanelStyle::getScrollBars

    getScrollBars( );

    Returns

    the visibility and position of scroll bars in a panel control, defaults to TScrollBars::None.

    access

    public

    [ Top ]

    TPanelStyle::getWrap

    getWrap( );

    Returns

    whether the content wraps within the panel. Defaults to true.

    access

    public

    [ Top ]

    TPanelStyle::mergeWith

    mergeWith( TStyle $style );

    Overridden in child classes as:

    TDataGridPagerStyle::mergeWith()
    Merges the style with a new one.

    Overrides TStyle::mergeWith() (Merges the style with a new one.)

    Parameters

    $style

    the new style

    Remarks

    Merges the style with a new one.

    If a style field is not set in this style, it will be overwritten by the new one.

    access

    public

    [ Top ]

    TPanelStyle::reset

    reset( );

    Overridden in child classes as:

    TDataGridPagerStyle::reset()
    Resets the style to the original empty state.

    Overrides TStyle::reset() (Resets the style to the original empty state.)

    Remarks

    Sets the style attributes to default values.

    This method overrides the parent implementation by resetting additional TPanelStyle specific attributes.

    access

    public

    [ Top ]

    TPanelStyle::setBackImageUrl

    setBackImageUrl( string $value );

    Parameters

    $value

    the URL

    Remarks

    Sets the URL of the background image for the panel component.

    access

    public

    [ Top ]

    TPanelStyle::setDirection

    setDirection( TContentDirection $value );

    Parameters

    $value

    alignment of the content in the panel.

    access

    public

    [ Top ]

    TPanelStyle::setHorizontalAlign

    setHorizontalAlign( THorizontalAlign $value );

    Parameters

    $value

    the horizontal alignment

    Remarks

    Sets the horizontal alignment of the contents within the panel.

    access

    public

    [ Top ]

    TPanelStyle::setScrollBars

    setScrollBars( TScrollBars $value );

    Parameters

    $value

    the visibility and position of scroll bars in a panel control.

    access

    public

    [ Top ]

    TPanelStyle::setWrap

    setWrap( boolean $value );

    Parameters

    $value

    whether the content wraps within the panel.

    Remarks

    Sets the value indicating whether the content wraps within the panel.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:01 +0200 by phpDocumentor 1.4.3


Docs For Class TScrollBars

Class TScrollBars

[line 270]
TEnumerable
   |
   --TScrollBars
Location: /Web/UI/WebControls/TPanelStyle.php

Remarks

TScrollBars class.

TScrollBars defines the enumerable type for the possible scroll bar mode that a TPanel control could use.

The following enumerable values are defined:

  • None: no scroll bars.
  • Auto: scroll bars automatically appeared when needed.
  • Both: show both horizontal and vertical scroll bars all the time.
  • Horizontal: horizontal scroll bar only
  • Vertical: vertical scroll bar only

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPanelStyle.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Auto = 'Auto'
  • Both = 'Both'
  • Horizontal = 'Horizontal'
  • None = 'None'
  • Vertical = 'Vertical'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Auto = 'Auto' [line 273]

  • Both = 'Both' [line 274]

  • Horizontal = 'Horizontal' [line 275]

  • None = 'None' [line 272]

  • Vertical = 'Vertical' [line 276]

Documentation generated on Mon, 25 Jun 2012 14:45:01 +0200 by phpDocumentor 1.4.3


Docs For Class TPlaceHolder

Class TPlaceHolder

[line 25]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TPlaceHolder
Location: /Web/UI/WebControls/TPlaceHolder.php

Remarks

TPlaceHolder class

TPlaceHolder reserves a place on a template, where static texts or controls may be inserted. You may add or remove texts or child controls of TPlaceHolder by manipulating the TControl::getControls property.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPlaceHolder.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:03 +0200 by phpDocumentor 1.4.3


Docs For Class TRadioButton

Class TRadioButton

[line 56]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TCheckBox
               |
               --TRadioButton
Classes extended from TRadioButton:
TActiveRadioButton
TActiveRadioButton class.

Location: /Web/UI/WebControls/TRadioButton.php

Remarks

TRadioButton class

TRadioButton displays a radio button on the page. You can specify the caption to display beside the radio buttonby setting the Text property. The caption can appear either on the right or left of the radio button, which is determined by the TextAlign property.

To determine whether the TRadioButton component is checked, test the Checked property. The OnCheckedChanged event is raised when the Checked state of the TRadioButton component changes between posts to the server. You can provide an event handler for the OnCheckedChanged event to to programmatically control the actions performed when the state of the TRadioButton component changes between posts to the server.

TRadioButton uses GroupName to group together a set of radio buttons. Once the GroupName is set, you can use the getRadioButtonsInGroup method to get an array of TRadioButtons having the same group name.

If AutoPostBack is set true, changing the radio button state will cause postback action. And if CausesValidation is true, validation will also be processed, which can be further restricted within a ValidationGroup.

Note, Text is rendered as is. Make sure it does not contain unwanted characters that may bring security vulnerabilities.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRadioButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TCheckBox

  • TCheckBox::getAutoPostBack()
  • TCheckBox::getCausesValidation()
  • TCheckBox::getChecked()
  • TCheckBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TCheckBox::getData()
    Returns the value indicating whether the checkbox is checked.
  • TCheckBox::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TCheckBox::getEnableClientScript()
  • TCheckBox::getInputAttributes()
  • TCheckBox::getIsValid()
    Returns true if this control validated successfully.
  • TCheckBox::getLabelAttributes()
  • TCheckBox::getPostBackOptions()
    Gets the post back options for this checkbox.
  • TCheckBox::getSpanNeeded()
    Check if we need a span tag to surround this control. The span tag will be created if the Text property is set for this control.
  • TCheckBox::getSurroundingTagID()
  • TCheckBox::getTagName()
  • TCheckBox::getText()
  • TCheckBox::getTextAlign()
  • TCheckBox::getValidationGroup()
  • TCheckBox::getValidationPropertyValue()
    Returns the value of the property that needs validation.
  • TCheckBox::getValue()
  • TCheckBox::getValueAttribute()
  • TCheckBox::loadPostData()
    Loads user input data.
  • TCheckBox::onCheckedChanged()
    Raises OnCheckedChanged event when getChecked changes value during postback.
  • TCheckBox::onPreRender()
    Registers the checkbox to receive postback data during postback.
  • TCheckBox::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TCheckBox::render()
    Renders the checkbox control.
  • TCheckBox::renderClientControlScript()
    Renders the client-script code.
  • TCheckBox::renderInputTag()
    Renders a checkbox input element.
  • TCheckBox::renderLabel()
    Renders a label beside the checkbox.
  • TCheckBox::setAutoPostBack()
    Sets a value indicating whether clicking on the checkbox will post the page.
  • TCheckBox::setCausesValidation()
    Sets the value indicating whether postback event trigger by this checkbox will cause input validation.
  • TCheckBox::setChecked()
    Sets a value indicating whether the checkbox is to be checked or not.
  • TCheckBox::setData()
    Sets the value indicating whether the checkbox is to be checked or not.
  • TCheckBox::setEnableClientScript()
  • TCheckBox::setIsValid()
  • TCheckBox::setText()
    Sets the text caption of the checkbox.
  • TCheckBox::setTextAlign()
  • TCheckBox::setValidationGroup()
  • TCheckBox::setValue()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRadioButton::__construct

    __construct( );

    Overridden in child classes as:

    TActiveRadioButton::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Constructor.

    Registers the radiobutton in a global radiobutton collection. If overridden, the parent implementation must be invoked first.

    access

    public

    [ Top ]

    TRadioButton::addToPostDataLoader

    addToPostDataLoader( );

    Overrides TControl::addToPostDataLoader() (Add controls implementing IPostBackDataHandler to post data loaders.)

    Remarks

    Add the group name as post data loader if group name is set.

    access

    protected

    [ Top ]

    TRadioButton::getClientClassName

    getClientClassName( );

    Overridden in child classes as:

    TActiveRadioButton::getClientClassName()

    Overrides TCheckBox::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TRadioButton::getEnableClientScript

    getEnableClientScript( );

    Overrides TCheckBox::getEnableClientScript() (parent method not documented)

    Returns

    whether to render javascript.

    access

    public

    [ Top ]

    TRadioButton::getGroupName

    getGroupName( );

    Returns

    the name of the group that the radio button belongs to. Defaults to empty.

    access

    public

    [ Top ]

    TRadioButton::getRadioButtonsInGroup

    getRadioButtonsInGroup( );

    Returns

    list of TRadioButton with the same group

    Remarks

    Gets an array of radiobuttons whose group name is the same as this radiobutton's.

    Note, only those radiobuttons that are on the current page hierarchy may be returned in the result.

    access

    public

    [ Top ]

    TRadioButton::getUniqueGroupName

    getUniqueGroupName( );

    Returns

    the name used to fetch radiobutton post data

    access

    public

    [ Top ]

    TRadioButton::getValueAttribute

    getValueAttribute( );

    Overrides TCheckBox::getValueAttribute() (parent method not documented)

    Returns

    the value attribute to be rendered

    access

    protected

    [ Top ]

    TRadioButton::loadPostData

    loadPostData( string $key, array $values );

    Overrides TCheckBox::loadPostData() (Loads user input data.)

    Parameters

    $key

    the key that can be used to retrieve data from the input data collection

    $values

    the input data collection

    Returns

    whether the data of the control has been changed

    Remarks

    Loads user input data.

    This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TRadioButton::onInit

    onInit( TEventParameter $param );

    Overrides TControl::onInit() (This method is invoked when the control enters 'OnInit' stage.)

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    Registers the radio button groupings. If overriding onInit method, ensure to call parent implemenation.

    access

    public

    [ Top ]

    TRadioButton::onUnLoad

    onUnLoad( TEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    Unregisters the radio button groupings. If overriding onInit method, ensure to call parent implemenation.

    access

    public

    [ Top ]

    TRadioButton::renderClientControlScript

    renderClientControlScript( $writer );

    Overridden in child classes as:

    TActiveRadioButton::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    Overrides TCheckBox::renderClientControlScript() (Renders the client-script code.)

    Parameters

    $writer

    Remarks

    Renders the client-script code.

    access

    protected

    [ Top ]

    TRadioButton::renderInputTag

    renderInputTag( THtmlWriter $writer, string $clientID, string $onclick );

    Overridden in child classes as:

    TActiveRadioButton::renderInputTag()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    Overrides TCheckBox::renderInputTag() (Renders a checkbox input element.)

    Parameters

    $writer

    the writer for the rendering purpose

    $clientID

    checkbox id

    $onclick

    onclick js

    Remarks

    Renders a radiobutton input element.

    access

    protected

    [ Top ]

    TRadioButton::setEnableClientScript

    setEnableClientScript( boolean $value );

    Overrides TCheckBox::setEnableClientScript() (parent method not documented)

    Parameters

    $value

    whether to render javascript.

    access

    public

    [ Top ]

    TRadioButton::setGroupName

    setGroupName( string $value );

    Parameters

    $value

    the group name

    Remarks

    Sets the name of the group that the radio button belongs to.

    The group is unique among the control's naming container.

    see

    TRadioButton::setUniqueGroupName()

    access

    public

    [ Top ]

    TRadioButton::setUniqueGroupName

    setUniqueGroupName( string $value );

    Parameters

    $value

    the group name

    Remarks

    Sets the unique group name that the radio button belongs to.

    A unique group is a radiobutton group unique among the whole page hierarchy, while the GroupName specifies a group that is unique among the control's naming container only. For example, each cell of a TDataGrid is a naming container. If you specify GroupName for a radiobutton in a cell, it groups together radiobutton within a cell, but not the other, even though they have the same GroupName. On the contratry, if UniqueGroupName is used instead, it will group all appropriate radio buttons on the whole page hierarchy. Note, when both UniqueGroupName and GroupName, the former takes precedence.

    see

    TRadioButton::setGroupName()

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:05 +0200 by phpDocumentor 1.4.3


Docs For Class TRadioButtonList

Class TRadioButtonList

[line 36]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TCheckBoxList
                     |
                     --TRadioButtonList
Classes extended from TRadioButtonList:
TActiveRadioButtonList
TActiveRadioButtonList class.
TRatingList
TRatingList class.

Location: /Web/UI/WebControls/TRadioButtonList.php

Remarks

TRadioButtonList class

TRadioButtonList displays a list of radiobuttons on a Web page.

TRadioButtonList inherits all properties and events of TCheckBoxList. Each TRadioButtonList displays one group of radiobuttons, i.e., at most one radiobutton can be selected at a time.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRadioButtonList.php 3102 2012-02-05 17:00:00Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TCheckBoxList

  • TCheckBoxList::__construct()
    Constructor.
  • TCheckBoxList::createRepeatedControl()
    Creates a control used for repetition (used as a template).
  • TCheckBoxList::createStyle()
    Creates a style object for the control.
  • TCheckBoxList::findControl()
    Finds a control by ID.
  • TCheckBoxList::generateItemStyle()
    Returns a style used for rendering items.
  • TCheckBoxList::getCellPadding()
  • TCheckBoxList::getCellSpacing()
  • TCheckBoxList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TCheckBoxList::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TCheckBoxList::getHasFooter()
    Returns a value indicating whether this control contains footer item.
  • TCheckBoxList::getHasHeader()
    Returns a value indicating whether this control contains header item.
  • TCheckBoxList::getHasSeparators()
    Returns a value indicating whether this control contains separator items.
  • TCheckBoxList::getIsMultiSelect()
  • TCheckBoxList::getIsValid()
    Returns true if this control validated successfully.
  • TCheckBoxList::getPostBackOptions()
    Gets the post back options for this checkbox.
  • TCheckBoxList::getRepeatColumns()
  • TCheckBoxList::getRepeatDirection()
  • TCheckBoxList::getRepeatInfo()
  • TCheckBoxList::getRepeatLayout()
  • TCheckBoxList::getSpanNeeded()
    Wether the list should be rendered inside a span or not
  • TCheckBoxList::getTextAlign()
  • TCheckBoxList::getValidationPropertyValue()
    Returns the value to be validated.
  • TCheckBoxList::loadPostData()
    Loads user input data.
  • TCheckBoxList::onPreRender()
    Registers for post data on postback.
  • TCheckBoxList::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TCheckBoxList::render()
    Renders the checkbox list control.
  • TCheckBoxList::renderItem()
    Renders an item in the list.
  • TCheckBoxList::setCellPadding()
    Sets the cellpadding for the table keeping the checkbox list.
  • TCheckBoxList::setCellSpacing()
    Sets the cellspacing for the table keeping the checkbox list.
  • TCheckBoxList::setEnabled()
  • TCheckBoxList::setIsValid()
  • TCheckBoxList::setRepeatColumns()
  • TCheckBoxList::setRepeatDirection()
  • TCheckBoxList::setRepeatLayout()
  • TCheckBoxList::setTextAlign()

Inherited From Class TListControl

  • TListControl::addAttributesToRender()
    Adds attributes to renderer.
  • TListControl::addParsedObject()
    Adds object parsed from template to the control.
  • TListControl::clearSelection()
    Clears all existing selections.
  • TListControl::createListItemCollection()
    Creates a collection object to hold list items.
  • TListControl::formatDataValue()
    Formats the text value according to a format string.
  • TListControl::getAppendDataBoundItems()
  • TListControl::getAutoPostBack()
  • TListControl::getCausesValidation()
  • TListControl::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TListControl::getData()
    Returns the value of the selected item with the lowest cardinal index.
  • TListControl::getDataGroupField()
  • TListControl::getDataTextField()
  • TListControl::getDataTextFormatString()
  • TListControl::getDataValueField()
  • TListControl::getEnableClientScript()
  • TListControl::getHasItems()
  • TListControl::getIsMultiSelect()
  • TListControl::getItemCount()
  • TListControl::getItems()
  • TListControl::getPostBackOptions()
  • TListControl::getPromptText()
  • TListControl::getPromptValue()
  • TListControl::getSelectedIndex()
  • TListControl::getSelectedIndices()
  • TListControl::getSelectedItem()
  • TListControl::getSelectedValue()
  • TListControl::getSelectedValues()
  • TListControl::getTagName()
  • TListControl::getText()
  • TListControl::getValidationGroup()
  • TListControl::loadState()
    Loads items from viewstate.
  • TListControl::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event when selection is changed.
  • TListControl::onTextChanged()
    Raises OnTextChanged event when selection is changed.
  • TListControl::performDataBinding()
    Performs databinding to populate list items from data source.
  • TListControl::renderClientControlScript()
    Renders the javascript for list control.
  • TListControl::renderContents()
    Renders body content of the list control.
  • TListControl::renderPrompt()
    Renders the prompt text, if any.
  • TListControl::saveState()
    Saves items into viewstate.
  • TListControl::setAppendDataBoundItems()
  • TListControl::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TListControl::setCausesValidation()
  • TListControl::setData()
    Selects an item by the specified value.
  • TListControl::setDataGroupField()
  • TListControl::setDataTextField()
  • TListControl::setDataTextFormatString()
    Sets data text format string.
  • TListControl::setDataValueField()
  • TListControl::setEnableClientScript()
  • TListControl::setPromptText()
  • TListControl::setPromptValue()
  • TListControl::setSelectedIndex()
  • TListControl::setSelectedIndices()
  • TListControl::setSelectedValue()
    Sets selection by item value.
  • TListControl::setSelectedValues()
  • TListControl::setText()
  • TListControl::setValidationGroup()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRadioButtonList::createRepeatedControl

    createRepeatedControl( );

    Overridden in child classes as:

    TActiveRadioButtonList::createRepeatedControl()
    Creates a control used for repetition (used as a template).

    Overrides TCheckBoxList::createRepeatedControl() (Creates a control used for repetition (used as a template).)

    Returns

    the control to be repeated

    Remarks

    Creates a control used for repetition (used as a template).

    access

    protected

    [ Top ]

    TRadioButtonList::getClientClassName

    getClientClassName( );

    Overridden in child classes as:

    TRatingList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    TActiveRatingList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.

    Overrides TCheckBoxList::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TRadioButtonList::getIsMultiSelect

    getIsMultiSelect( );

    Overrides TCheckBoxList::getIsMultiSelect() (parent method not documented)

    Returns

    whether this control supports multiple selection. Always false for radiobutton list.

    access

    protected

    [ Top ]

    TRadioButtonList::loadPostData

    loadPostData( string $key, array $values );

    Overrides TCheckBoxList::loadPostData() (Loads user input data.)

    Parameters

    $key

    the key that can be used to retrieve data from the input data collection

    $values

    the input data collection

    Returns

    whether the data of the control has been changed

    Remarks

    Loads user input data.

    This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TRadioButtonList::setSelectedIndices

    setSelectedIndices( $indices );

    Overrides TListControl::setSelectedIndices() (parent method not documented)

    Parameters

    $indices

    throws

    TNotSupportedException if this method is invoked

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:06 +0200 by phpDocumentor 1.4.3


Docs For Class TRangeValidationDataType

Class TRangeValidationDataType

[line 357]
TEnumerable
   |
   --TValidationDataType
      |
      --TRangeValidationDataType
Location: /Web/UI/WebControls/TRangeValidator.php

Remarks

TRangeValidationDataType class.

TRangeValidationDataType defines the enumerable type for the possible data types that a range validator can validate upon.

The following enumerable values are defined:

  • Integer
  • Float
  • Date
  • String
  • StringLength

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRangeValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • StringLength = 'StringLength'

Inherited Class Constant Summary

Inherited From Class TValidationDataType

  • TValidationDataType::Date = 'Date'
  • TValidationDataType::Float = 'Float'
  • TValidationDataType::Integer = 'Integer'
  • TValidationDataType::String = 'String'

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • StringLength = 'StringLength' [line 359]

Documentation generated on Mon, 25 Jun 2012 14:45:07 +0200 by phpDocumentor 1.4.3


Docs For Class TRangeValidator

Class TRangeValidator

[line 53]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TRangeValidator
Location: /Web/UI/WebControls/TRangeValidator.php

Remarks

TRangeValidator class

TRangeValidator tests whether an input value is within a specified range.

TRangeValidator uses three key properties to perform its validation. The MinValue and MaxValue properties specify the minimum and maximum values of the valid range. The DataType property is used to specify the data type of the value and the minimum and maximum range values. These values are converted to this data type before the validation operation is performed. The following value types are supported:

  • Integer A 32-bit signed integer data type.
  • Float A double-precision floating point number data type.
  • Date A date data type. The date format can be specified by setting DateFormat property, which must be recognizable by TSimpleDateFormatter. If the property is not set, the GNU date syntax is assumed.
  • String A string data type.
  • StringLength check for string length.
If StrictComparison is true, then the ranges are compared as strictly less than the max value and/or strictly greater than the min value.

The TRangeValidator allows a special DataType "StringLength" that can be used to verify minimum and maximum string length. The Charset property can be used to force a particular charset for comparison. Otherwise, the application charset is used and is defaulted as UTF-8.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRangeValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TBaseValidator

  • TBaseValidator::__construct()
    Constructor.
  • TBaseValidator::addAttributesToRender()
    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
  • TBaseValidator::createClientSide()
  • TBaseValidator::evaluateIsValid()
    This is the major method for validation.
  • TBaseValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
  • TBaseValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
  • TBaseValidator::getClientSide()
    Gets the TValidatorClientSide that allows modification of the client- side validator events.
  • TBaseValidator::getControlCssClass()
  • TBaseValidator::getControlToValidate()
  • TBaseValidator::getDisplay()
  • TBaseValidator::getEnableClientScript()
  • TBaseValidator::getErrorMessage()
  • TBaseValidator::getFocusElementID()
    Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::getFocusOnError()
  • TBaseValidator::getIsValid()
  • TBaseValidator::getValidationGroup()
  • TBaseValidator::getValidationTarget()
  • TBaseValidator::getValidationValue()
    Retrieves the property value of the control being validated.
  • TBaseValidator::onInit()
    Registers the validator with page.
  • TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
  • TBaseValidator::onUnload()
    Unregisters the validator from page.
  • TBaseValidator::onValidate()
    This event is raised right before the validator starts to perform validation.
  • TBaseValidator::onValidationError()
    This event is raised when the validator fails in validation.
  • TBaseValidator::onValidationSuccess()
    This event is raised when the validator succeeds in validation.
  • TBaseValidator::registerClientScriptValidator()
    Registers the individual validator client-side javascript code.
  • TBaseValidator::renderClientControlScript()
    Renders the javascript code to the end script.
  • TBaseValidator::renderContents()
    Renders the validator control.
  • TBaseValidator::setControlCssClass()
  • TBaseValidator::setControlToValidate()
    Sets the ID path of the input control to validate.
  • TBaseValidator::setDisplay()
  • TBaseValidator::setEnableClientScript()
  • TBaseValidator::setEnabled()
    This method overrides parent's implementation by setting setIsValid to true if disabled.
  • TBaseValidator::setErrorMessage()
    Sets the text for the error message.
  • TBaseValidator::setFocusElementID()
    Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::setFocusOnError()
  • TBaseValidator::setForControl()
    This method overrides the parent implementation to forbid setting ForControl.
  • TBaseValidator::setIsValid()
    Sets the value indicating whether the validation succeeds
  • TBaseValidator::setValidationGroup()
  • TBaseValidator::updateControlCssClass()
    Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
  • TBaseValidator::validate()
    Validates the specified control.

Inherited From Class TLabel

  • TLabel::addAttributesToRender()
    Adds attributes to renderer.
  • TLabel::getData()
    Returns the text value of the label.
  • TLabel::getForControl()
  • TLabel::getTagName()
  • TLabel::getText()
  • TLabel::render()
    Renders the label.
  • TLabel::renderContents()
    Renders the body content of the label.
  • TLabel::setData()
    Sets the text value of the label.
  • TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
  • TLabel::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRangeValidator::evaluateIsValid

    evaluateIsValid( );

    Overrides TBaseValidator::evaluateIsValid() (This is the major method for validation.)

    Returns

    whether the validation succeeds

    Remarks

    This method overrides the parent's implementation.

    The validation succeeds if the input data is within the range. The validation always succeeds if the input data is empty.

    access

    protected

    [ Top ]

    TRangeValidator::getCharset

    getCharset( );

    Returns

    charset for string length comparison.

    access

    public

    [ Top ]

    TRangeValidator::getClientClassName

    getClientClassName( );

    Overrides TBaseValidator::getClientClassName() (Gets the name of the javascript class responsible for performing validation for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing validation for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TRangeValidator::getClientScriptOptions

    getClientScriptOptions( );

    Overrides TBaseValidator::getClientScriptOptions() (Returns an array of javascript validator options.)

    Returns

    javascript validator options.

    Remarks

    Returns an array of javascript validator options.

    access

    protected

    [ Top ]

    TRangeValidator::getDataType

    getDataType( );

    Returns

    the data type that the values being compared are converted to before the comparison is made. Defaults to TRangeValidationDataType::String.

    access

    public

    [ Top ]

    TRangeValidator::getDateFormat

    getDateFormat( );

    Returns

    the date validation date format if any

    access

    public

    [ Top ]

    TRangeValidator::getMaxValue

    getMaxValue( );

    Returns

    the maximum value of the validation range.

    access

    public

    [ Top ]

    TRangeValidator::getMinValue

    getMinValue( );

    Returns

    the minimum value of the validation range.

    access

    public

    [ Top ]

    TRangeValidator::getStrictComparison

    getStrictComparison( );

    Returns

    true to perform strict comparison.

    access

    public

    [ Top ]

    TRangeValidator::isGreaterThan

    isGreaterThan( $left, $right );

    Parameters

    $left

    $right

    access

    protected

    [ Top ]

    TRangeValidator::isLessThan

    isLessThan( $left, $right );

    Parameters

    $left

    $right

    access

    protected

    [ Top ]

    TRangeValidator::isValidDate

    isValidDate( string $value );

    Parameters

    $value

    date as string to validate

    Returns

    true if within range.

    Remarks

    Determine if the date is within the specified range.

    Uses pradoParseDate and strtotime to get the date from string.

    access

    protected

    [ Top ]

    TRangeValidator::isValidFloat

    isValidFloat( string $value );

    Parameters

    $value

    value to validate

    Returns

    true if within range.

    Remarks

    Determine if the value is within the specified float range.

    access

    protected

    [ Top ]

    TRangeValidator::isValidInteger

    isValidInteger( string $value );

    Parameters

    $value

    value to validate true

    Returns

    true if within integer range.

    Remarks

    Determine if the value is within the integer range.

    access

    protected

    [ Top ]

    TRangeValidator::isValidString

    isValidString( string $value );

    Parameters

    $value

    value to compare with.

    Returns

    true if the string is within range.

    Remarks

    Compare the string with a minimum and a maxiumum value.

    Uses strcmp for comparision.

    access

    protected

    [ Top ]

    TRangeValidator::isValidStringLength

    isValidStringLength( string $value );

    Parameters

    $value

    string for comparision

    Returns

    true if min and max string length are satisfied.

    access

    protected

    [ Top ]

    TRangeValidator::setCharset

    setCharset( string $value );

    Parameters

    $value

    charset for string length comparison.

    access

    public

    [ Top ]

    TRangeValidator::setDataType

    setDataType( TRangeValidationDataType $value );

    Parameters

    $value

    the data type

    Remarks

    Sets the data type that the values being compared are converted to before the comparison is made.

    access

    public

    [ Top ]

    TRangeValidator::setDateFormat

    setDateFormat( string $value );

    Parameters

    $value

    the date format value

    Remarks

    Sets the date format for a date validation

    access

    public

    [ Top ]

    TRangeValidator::setMaxValue

    setMaxValue( string $value );

    Parameters

    $value

    the maximum value

    Remarks

    Sets the maximum value of the validation range.

    access

    public

    [ Top ]

    TRangeValidator::setMinValue

    setMinValue( string $value );

    Parameters

    $value

    the minimum value

    Remarks

    Sets the minimum value of the validation range.

    access

    public

    [ Top ]

    TRangeValidator::setStrictComparison

    setStrictComparison( boolean $value );

    Parameters

    $value

    true to perform strict comparison (i.e. strictly less than max and/or strictly greater than min).

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:07 +0200 by phpDocumentor 1.4.3


Docs For Class TRatingList

Class TRatingList

[line 29]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TCheckBoxList
                     |
                     --TRadioButtonList
                        |
                        --TRatingList
Classes extended from TRatingList:
TActiveRatingList
TActiveRatingList Class

Location: /Web/UI/WebControls/TRatingList.php

Remarks

TRatingList class.

This class is EXPERIMENTAL.

author

Bradley Booms <bradley[dot]booms[at]gmail[dot]com>

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TRatingList.php 3137 2012-05-10 21:09:10Z ctrlaltca $

since

3.0

Class Variable Summary

Class Constant Summary

  • SCRIPT_PATH = 'prado/ratings'
    Script path relative to the TClientScriptManager::SCRIPT_PATH

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TRadioButtonList

  • TRadioButtonList::createRepeatedControl()
    Creates a control used for repetition (used as a template).
  • TRadioButtonList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TRadioButtonList::getIsMultiSelect()
  • TRadioButtonList::loadPostData()
    Loads user input data.
  • TRadioButtonList::setSelectedIndices()

Inherited From Class TCheckBoxList

  • TCheckBoxList::__construct()
    Constructor.
  • TCheckBoxList::createRepeatedControl()
    Creates a control used for repetition (used as a template).
  • TCheckBoxList::createStyle()
    Creates a style object for the control.
  • TCheckBoxList::findControl()
    Finds a control by ID.
  • TCheckBoxList::generateItemStyle()
    Returns a style used for rendering items.
  • TCheckBoxList::getCellPadding()
  • TCheckBoxList::getCellSpacing()
  • TCheckBoxList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TCheckBoxList::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TCheckBoxList::getHasFooter()
    Returns a value indicating whether this control contains footer item.
  • TCheckBoxList::getHasHeader()
    Returns a value indicating whether this control contains header item.
  • TCheckBoxList::getHasSeparators()
    Returns a value indicating whether this control contains separator items.
  • TCheckBoxList::getIsMultiSelect()
  • TCheckBoxList::getIsValid()
    Returns true if this control validated successfully.
  • TCheckBoxList::getPostBackOptions()
    Gets the post back options for this checkbox.
  • TCheckBoxList::getRepeatColumns()
  • TCheckBoxList::getRepeatDirection()
  • TCheckBoxList::getRepeatInfo()
  • TCheckBoxList::getRepeatLayout()
  • TCheckBoxList::getSpanNeeded()
    Wether the list should be rendered inside a span or not
  • TCheckBoxList::getTextAlign()
  • TCheckBoxList::getValidationPropertyValue()
    Returns the value to be validated.
  • TCheckBoxList::loadPostData()
    Loads user input data.
  • TCheckBoxList::onPreRender()
    Registers for post data on postback.
  • TCheckBoxList::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TCheckBoxList::render()
    Renders the checkbox list control.
  • TCheckBoxList::renderItem()
    Renders an item in the list.
  • TCheckBoxList::setCellPadding()
    Sets the cellpadding for the table keeping the checkbox list.
  • TCheckBoxList::setCellSpacing()
    Sets the cellspacing for the table keeping the checkbox list.
  • TCheckBoxList::setEnabled()
  • TCheckBoxList::setIsValid()
  • TCheckBoxList::setRepeatColumns()
  • TCheckBoxList::setRepeatDirection()
  • TCheckBoxList::setRepeatLayout()
  • TCheckBoxList::setTextAlign()

Inherited From Class TListControl

  • TListControl::addAttributesToRender()
    Adds attributes to renderer.
  • TListControl::addParsedObject()
    Adds object parsed from template to the control.
  • TListControl::clearSelection()
    Clears all existing selections.
  • TListControl::createListItemCollection()
    Creates a collection object to hold list items.
  • TListControl::formatDataValue()
    Formats the text value according to a format string.
  • TListControl::getAppendDataBoundItems()
  • TListControl::getAutoPostBack()
  • TListControl::getCausesValidation()
  • TListControl::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TListControl::getData()
    Returns the value of the selected item with the lowest cardinal index.
  • TListControl::getDataGroupField()
  • TListControl::getDataTextField()
  • TListControl::getDataTextFormatString()
  • TListControl::getDataValueField()
  • TListControl::getEnableClientScript()
  • TListControl::getHasItems()
  • TListControl::getIsMultiSelect()
  • TListControl::getItemCount()
  • TListControl::getItems()
  • TListControl::getPostBackOptions()
  • TListControl::getPromptText()
  • TListControl::getPromptValue()
  • TListControl::getSelectedIndex()
  • TListControl::getSelectedIndices()
  • TListControl::getSelectedItem()
  • TListControl::getSelectedValue()
  • TListControl::getSelectedValues()
  • TListControl::getTagName()
  • TListControl::getText()
  • TListControl::getValidationGroup()
  • TListControl::loadState()
    Loads items from viewstate.
  • TListControl::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event when selection is changed.
  • TListControl::onTextChanged()
    Raises OnTextChanged event when selection is changed.
  • TListControl::performDataBinding()
    Performs databinding to populate list items from data source.
  • TListControl::renderClientControlScript()
    Renders the javascript for list control.
  • TListControl::renderContents()
    Renders body content of the list control.
  • TListControl::renderPrompt()
    Renders the prompt text, if any.
  • TListControl::saveState()
    Saves items into viewstate.
  • TListControl::setAppendDataBoundItems()
  • TListControl::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TListControl::setCausesValidation()
  • TListControl::setData()
    Selects an item by the specified value.
  • TListControl::setDataGroupField()
  • TListControl::setDataTextField()
  • TListControl::setDataTextFormatString()
    Sets data text format string.
  • TListControl::setDataValueField()
  • TListControl::setEnableClientScript()
  • TListControl::setPromptText()
  • TListControl::setPromptValue()
  • TListControl::setSelectedIndex()
  • TListControl::setSelectedIndices()
  • TListControl::setSelectedValue()
    Sets selection by item value.
  • TListControl::setSelectedValues()
  • TListControl::setText()
  • TListControl::setValidationGroup()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRatingList::__construct

    __construct( );

    Overridden in child classes as:

    TActiveRatingList::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    Overrides TCheckBoxList::__construct() (Constructor.)

    Remarks

    Sets the default repeat direction to horizontal.

    access

    public

    [ Top ]

    TRatingList::getAllowInput

    getAllowInput( );

    Returns

    whether the rating list can be edited. Defaults to true.

    Remarks

    Wrapper for setReadOnly property.

    access

    public

    [ Top ]

    TRatingList::getAssetUrl

    getAssetUrl( [string $file = ''] );

    Parameters

    $file

    asset file in the self::SCRIPT_PATH directory.

    Returns

    asset file url.

    access

    protected

    [ Top ]

    TRatingList::getCaption

    getCaption( );

    Returns

    caption text. Default is "Rate It:".

    access

    public

    [ Top ]

    TRatingList::getCaptionControl

    getCaptionControl( );

    access

    protected

    [ Top ]

    TRatingList::getCaptionControlID

    getCaptionControlID( );

    Returns

    find the client ID of the caption control.

    access

    protected

    [ Top ]

    TRatingList::getCaptionID

    getCaptionID( );

    Returns

    control or html element ID for displaying a caption.

    access

    public

    [ Top ]

    TRatingList::getClientClassName

    getClientClassName( );

    Overridden in child classes as:

    TActiveRatingList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.

    Overrides TRadioButtonList::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TRatingList::getHalfRatingInterval

    getHalfRatingInterval( );

    Returns

    rating display half value interval, default is array(0.3, 0.7);

    access

    public

    [ Top ]

    TRatingList::getPostBackOptions

    getPostBackOptions( );

    Overrides TCheckBoxList::getPostBackOptions() (Gets the post back options for this checkbox.)

    Returns

    list of post back options.

    access

    protected

    [ Top ]

    TRatingList::getRating

    getRating( );

    Returns

    rating value.

    access

    public

    [ Top ]

    TRatingList::getRatingIndex

    getRatingIndex( float $rating );

    Parameters

    $rating

    rating value

    Returns

    rating as integer

    access

    protected

    [ Top ]

    TRatingList::getRatingStyle

    getRatingStyle( );

    Returns

    current rating style

    access

    public

    [ Top ]

    TRatingList::getRatingStyleCssClass

    getRatingStyleCssClass( );

    Returns

    rating style css class name.

    access

    protected

    [ Top ]

    TRatingList::getReadOnly

    getReadOnly( );

    Returns

    whether the items in the column can be edited. Defaults to false.

    access

    public

    [ Top ]

    TRatingList::onPreRender

    onPreRender( $param );

    Overrides TCheckBoxList::onPreRender() (Registers for post data on postback.)

    Parameters

    $param

    Remarks

    Publish the the rating style css file and rating image files.

    access

    public

    [ Top ]

    TRatingList::onSelectedIndexChanged

    onSelectedIndexChanged( int $param );

    Overrides TListControl::onSelectedIndexChanged() (Raises OnSelectedIndexChanged event when selection is changed.)

    Parameters

    $param

    change the rating selection index

    access

    public

    [ Top ]

    TRatingList::publishImages

    publishImages( string $style, [string $fileExt = '.gif'] );

    Parameters

    $style

    rating style name

    $fileExt

    rating image file extension, default is '.gif'

    Returns

    URL of publish the rating images

    access

    protected

    [ Top ]

    TRatingList::publishStyle

    publishStyle( string $style );

    Parameters

    $style

    rating style name

    Returns

    URL of the css style file

    access

    protected

    [ Top ]

    TRatingList::registerClientScript

    registerClientScript( );

    Remarks

    Registers the relevant JavaScript.

    access

    protected

    [ Top ]

    TRatingList::render

    render( THtmlWriter $writer );

    Overrides TCheckBoxList::render() (Renders the checkbox list control.)

    Parameters

    $writer

    renderer

    Remarks

    Add rating style class name to the class attribute when setReadOnly property is true and when the setCssClass property is empty.

    access

    public

    [ Top ]

    TRatingList::setAllowInput

    setAllowInput( boolean $value );

    Parameters

    $value

    whether the rating list can be edited

    Remarks

    Wrapper for setReadOnly property.

    access

    public

    [ Top ]

    TRatingList::setCaption

    setCaption( $value );

    Overridden in child classes as:

    TActiveRatingList::setCaption()

    Parameters

    $value

    Returns

    current rating style

    access

    public

    [ Top ]

    TRatingList::setCaptionID

    setCaptionID( string $value );

    Parameters

    $value

    control or html element ID for displaying a caption.

    access

    public

    [ Top ]

    TRatingList::setEnabled

    setEnabled( boolean $value );

    Overrides TCheckBoxList::setEnabled() (parent method not documented)

    Parameters

    $value

    whether the rating list can be edited

    Remarks

    Wrapper for setReadOnly property.

    access

    public

    [ Top ]

    TRatingList::setHalfRatingInterval

    setHalfRatingInterval( array $value );

    Parameters

    $value

    rating display half value interval, default is array(0.3, 0.7);

    Remarks

    Sets the interval such that those rating values within the interval will be considered as a half star rating.

    access

    public

    [ Top ]

    TRatingList::setRating

    setRating( float $value );

    Overridden in child classes as:

    TActiveRatingList::setRating()

    Parameters

    $value

    rating value, also sets the selected Index

    access

    public

    [ Top ]

    TRatingList::setRatingStyle

    setRatingStyle( string $value );

    Parameters

    $value

    set the rating style, default is "default"

    access

    public

    [ Top ]

    TRatingList::setReadOnly

    setReadOnly( boolean $value );

    Overridden in child classes as:

    TActiveRatingList::setReadOnly()

    Parameters

    $value

    whether the items in the column can be edited

    access

    public

    [ Top ]

    TRatingList::setRepeatLayout

    setRepeatLayout( string $value );

    Overrides TCheckBoxList::setRepeatLayout() (parent method not documented)

    Parameters

    $value

    repeat layout type

    Remarks

    The repeat layout must be Table.

    throws

    TInvaliddataValueException when repeat layout is not Table.

    access

    public

    [ Top ]

    TRatingList::setSelectedIndex

    setSelectedIndex( $value );

    Overrides TListControl::setSelectedIndex() (parent method not documented)

    Parameters

    $value

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • SCRIPT_PATH = 'prado/ratings' [line 34]

    • Remarks

    Script path relative to the TClientScriptManager::SCRIPT_PATH

Documentation generated on Mon, 25 Jun 2012 14:45:08 +0200 by phpDocumentor 1.4.3


Docs For Class TReCaptcha

Class TReCaptcha

[line 54]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TReCaptcha
Location: /Web/UI/WebControls/TReCaptcha.php

Remarks

TReCaptcha class.

TReCaptcha displays a reCAPTCHA (a token displayed as an image) that can be used to determine if the input is entered by a real user instead of some program. It can also prevent multiple submits of the same form either by accident, or on purpose (ie. spamming).

The reCAPTCHA to solve (a string consisting of two separate words) displayed is automatically generated by the reCAPTCHA system at recaptcha.net. However, in order to use the services of the site you will need to register and get a public and a private API key pair, and supply those to the reCAPTCHA control through setting the PrivateKey and PublicKey properties.

Currently the reCAPTCHA API supports only one reCAPTCHA field per page, so you MUST make sure that all your input is protected and validated by a single reCAPTCHA control. Placing more than one reCAPTCHA control on the page will lead to unpredictable results, and the user will most likely unable to solve any of them successfully.

Upon postback, user input can be validated by calling validate(). The TReCaptchaValidator control can also be used to do validation, which provides server-side validation. Calling (@link validate()) will invalidate the token supplied, so all consecutive calls to the method - without solving a new captcha - will return false. Therefore if implementing a multi-stage input process, you must make sure that you call validate() only once, either at the end of the input process, or you store the result till the end of the processing.

The following template shows a typical use of TReCaptcha control:

  •  <com:TReCaptcha ID="Captcha"
    •

  •                  PublicKey="..."
    •

  •                  PrivateKey="..."
    •

  •  />
    •

  •  <com:TReCaptchaValidator ControlToValidate="Captcha"
    •

  •                           ErrorMessage="You are challenged!" />
    •

    author

    Bérczi Gábor <gabor.berczi@devworx.hu>

    version

    $Id: TWebControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.2

    Class Variable Summary

    Class Constant Summary

    • ChallengeFieldName =  'recaptcha_challenge_field'
    • ResponseFieldName =  'recaptcha_response_field'

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TReCaptcha::addAttributesToRender

      addAttributesToRender( $writer );

      Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

      Parameters

      $writer

      access

      protected

      [ Top ]

      TReCaptcha::getChallengeFieldName

      getChallengeFieldName( );

      access

      protected

      [ Top ]

      TReCaptcha::getClientSideOptions

      getClientSideOptions( );

      access

      public

      [ Top ]

      TReCaptcha::getCustomTranslations

      getCustomTranslations( );

      access

      public

      [ Top ]

      TReCaptcha::getIsValid

      getIsValid( );

      Returns

      wether this control validated successfully.

      Remarks

      Returns true if this control validated successfully.

      Defaults to true.

      access

      public

      [ Top ]

      TReCaptcha::getLanguage

      getLanguage( );

      access

      public

      [ Top ]

      TReCaptcha::getPrivateKey

      getPrivateKey( );

      access

      public

      [ Top ]

      TReCaptcha::getPublicKey

      getPublicKey( );

      access

      public

      [ Top ]

      TReCaptcha::getResponseFieldName

      getResponseFieldName( );

      access

      public

      [ Top ]

      TReCaptcha::getTagName

      getTagName( );

      Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

      access

      public

      [ Top ]

      TReCaptcha::getThemeName

      getThemeName( );

      access

      public

      [ Top ]

      TReCaptcha::getValidationPropertyValue

      getValidationPropertyValue( );

      access

      public

      [ Top ]

      TReCaptcha::onPreRender

      onPreRender( mixed $param );

      Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

      Parameters

      $param

      event parameter

      Remarks

      Checks for API keys

      access

      public

      [ Top ]

      TReCaptcha::regenerateToken

      regenerateToken( );

      access

      public

      [ Top ]

      TReCaptcha::renderContents

      renderContents( $writer );

      Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

      Parameters

      $writer

      access

      public

      [ Top ]

      TReCaptcha::setCustomTranslations

      setCustomTranslations( $value );

      Parameters

      $value

      access

      public

      [ Top ]

      TReCaptcha::setIsValid

      setIsValid( bool $value );

      Parameters

      $value

      wether this control is valid.

      access

      public

      [ Top ]

      TReCaptcha::setLanguage

      setLanguage( $value );

      Parameters

      $value

      access

      public

      [ Top ]

      TReCaptcha::setPrivateKey

      setPrivateKey( $value );

      Parameters

      $value

      access

      public

      [ Top ]

      TReCaptcha::setPublicKey

      setPublicKey( $value );

      Parameters

      $value

      access

      public

      [ Top ]

      TReCaptcha::setThemeName

      setThemeName( $value );

      Parameters

      $value

      access

      public

      [ Top ]

      TReCaptcha::validate

      validate( );

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • ChallengeFieldName =  'recaptcha_challenge_field' [line 58]

    • ResponseFieldName =  'recaptcha_response_field' [line 59]

    Documentation generated on Mon, 25 Jun 2012 14:45:09 +0200 by phpDocumentor 1.4.3


Docs For Class TReCaptchaValidator

Class TReCaptchaValidator

[line 31]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TReCaptchaValidator
Location: /Web/UI/WebControls/TReCaptchaValidator.php

Remarks

TReCaptchaValidator class

TReCaptchaValidator validates user input against a reCAPTCHA represented by a TReCaptcha control. The input control fails validation if its value is not the same as the token displayed in reCAPTCHA. Note, if the user does not enter any thing, it is still considered as failing the validation.

To use TReCaptchaValidator, specify the ControlToValidate to be the ID path of the TReCaptcha control.

author

Bérczi Gábor <gabor.berczi@devworx.hu>

version

$Id: TBaseValidator.php 3159 2012-06-01 18:01:40Z ctrlaltca $

since

3.2

Class Variable Summary

  • $_isvalid =  null

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TBaseValidator

  • TBaseValidator::__construct()
    Constructor.
  • TBaseValidator::addAttributesToRender()
    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
  • TBaseValidator::createClientSide()
  • TBaseValidator::evaluateIsValid()
    This is the major method for validation.
  • TBaseValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
  • TBaseValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
  • TBaseValidator::getClientSide()
    Gets the TValidatorClientSide that allows modification of the client- side validator events.
  • TBaseValidator::getControlCssClass()
  • TBaseValidator::getControlToValidate()
  • TBaseValidator::getDisplay()
  • TBaseValidator::getEnableClientScript()
  • TBaseValidator::getErrorMessage()
  • TBaseValidator::getFocusElementID()
    Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::getFocusOnError()
  • TBaseValidator::getIsValid()
  • TBaseValidator::getValidationGroup()
  • TBaseValidator::getValidationTarget()
  • TBaseValidator::getValidationValue()
    Retrieves the property value of the control being validated.
  • TBaseValidator::onInit()
    Registers the validator with page.
  • TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
  • TBaseValidator::onUnload()
    Unregisters the validator from page.
  • TBaseValidator::onValidate()
    This event is raised right before the validator starts to perform validation.
  • TBaseValidator::onValidationError()
    This event is raised when the validator fails in validation.
  • TBaseValidator::onValidationSuccess()
    This event is raised when the validator succeeds in validation.
  • TBaseValidator::registerClientScriptValidator()
    Registers the individual validator client-side javascript code.
  • TBaseValidator::renderClientControlScript()
    Renders the javascript code to the end script.
  • TBaseValidator::renderContents()
    Renders the validator control.
  • TBaseValidator::setControlCssClass()
  • TBaseValidator::setControlToValidate()
    Sets the ID path of the input control to validate.
  • TBaseValidator::setDisplay()
  • TBaseValidator::setEnableClientScript()
  • TBaseValidator::setEnabled()
    This method overrides parent's implementation by setting setIsValid to true if disabled.
  • TBaseValidator::setErrorMessage()
    Sets the text for the error message.
  • TBaseValidator::setFocusElementID()
    Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::setFocusOnError()
  • TBaseValidator::setForControl()
    This method overrides the parent implementation to forbid setting ForControl.
  • TBaseValidator::setIsValid()
    Sets the value indicating whether the validation succeeds
  • TBaseValidator::setValidationGroup()
  • TBaseValidator::updateControlCssClass()
    Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
  • TBaseValidator::validate()
    Validates the specified control.

Inherited From Class TLabel

  • TLabel::addAttributesToRender()
    Adds attributes to renderer.
  • TLabel::getData()
    Returns the text value of the label.
  • TLabel::getForControl()
  • TLabel::getTagName()
  • TLabel::getText()
  • TLabel::render()
    Renders the label.
  • TLabel::renderContents()
    Renders the body content of the label.
  • TLabel::setData()
    Sets the text value of the label.
  • TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
  • TLabel::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TReCaptchaValidator::evaluateIsValid

    evaluateIsValid( );

    Overrides TBaseValidator::evaluateIsValid() (This is the major method for validation.)

    Returns

    whether the validation succeeds

    Remarks

    This method overrides the parent's implementation.

    The validation succeeds if the input control has the same value as the one displayed in the corresponding RECAPTCHA control.

    access

    protected

    [ Top ]

    TReCaptchaValidator::getCaptchaControl

    getCaptchaControl( );

    access

    protected

    [ Top ]

    TReCaptchaValidator::getClientClassName

    getClientClassName( );

    Overrides TBaseValidator::getClientClassName() (Gets the name of the javascript class responsible for performing validation for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing validation for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TReCaptchaValidator::getClientScriptOptions

    getClientScriptOptions( );

    Overrides TBaseValidator::getClientScriptOptions() (Returns an array of javascript validator options.)

    access

    public

    [ Top ]

    TReCaptchaValidator::getEnableClientScript

    getEnableClientScript( );

    Overrides TBaseValidator::getEnableClientScript() (parent method not documented)

    access

    public

    [ Top ]

    TReCaptchaValidator::onPreRender

    onPreRender( $param );

    Overrides TBaseValidator::onPreRender() (Override parent implementation to update the control CSS Class before)

    Parameters

    $param

    access

    public

    [ Top ]

Variable Detail

  • $_isvalid =  null [line 33]
  • Data type: mixed

    • access

    protected

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:10 +0200 by phpDocumentor 1.4.3


Docs For Class TRegularExpressionValidator

Class TRegularExpressionValidator

[line 50]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TRegularExpressionValidator
Classes extended from TRegularExpressionValidator:
TEmailAddressValidator
TEmailAddressValidator class

Location: /Web/UI/WebControls/TRegularExpressionValidator.php

Remarks

TRegularExpressionValidator class

TRegularExpressionValidator validates whether the value of an associated input component matches the pattern specified by a regular expression.

You can specify the regular expression by setting the RegularExpression property. Some commonly used regular expressions include:

 French Phone Number: (0( \d|\d ))?\d\d \d\d(\d \d| \d\d )\d\d
 French Postal Code: \d{5}
 German Phone Number: ((\(0\d\d\) |(\(0\d{3}\) )?\d )?\d\d \d\d \d\d|\(0\d{4}\) \d \d\d-\d\d?)
 German Postal Code: (D-)?\d{5}
 Email Address: \w+([-+.]\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*
 Japanese Phone Number: (0\d{1,4}-|\(0\d{1,4}\) ?)?\d{1,4}-\d{4}
 Japanese Postal Code: \d{3}(-(\d{4}|\d{2}))?
 P.R.C. Phone Number: (\(\d{3}\)|\d{3}-)?\d{8}
 P.R.C. Postal Code: \d{6}
 P.R.C. Social Security Number: \d{18}|\d{15}
 U.S. Phone Number: ((\(\d{3}\) ?)|(\d{3}-))?\d{3}-\d{4}
 U.S. ZIP Code: \d{5}(-\d{4})?
 U.S. Social Security Number: \d{3}-\d{2}-\d{4}

Note, the validation succeeds if the associated input control contains empty input. Use a TRequiredFieldValidator to ensure the input is not empty.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRegularExpressionValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TBaseValidator

  • TBaseValidator::__construct()
    Constructor.
  • TBaseValidator::addAttributesToRender()
    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
  • TBaseValidator::createClientSide()
  • TBaseValidator::evaluateIsValid()
    This is the major method for validation.
  • TBaseValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
  • TBaseValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
  • TBaseValidator::getClientSide()
    Gets the TValidatorClientSide that allows modification of the client- side validator events.
  • TBaseValidator::getControlCssClass()
  • TBaseValidator::getControlToValidate()
  • TBaseValidator::getDisplay()
  • TBaseValidator::getEnableClientScript()
  • TBaseValidator::getErrorMessage()
  • TBaseValidator::getFocusElementID()
    Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::getFocusOnError()
  • TBaseValidator::getIsValid()
  • TBaseValidator::getValidationGroup()
  • TBaseValidator::getValidationTarget()
  • TBaseValidator::getValidationValue()
    Retrieves the property value of the control being validated.
  • TBaseValidator::onInit()
    Registers the validator with page.
  • TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
  • TBaseValidator::onUnload()
    Unregisters the validator from page.
  • TBaseValidator::onValidate()
    This event is raised right before the validator starts to perform validation.
  • TBaseValidator::onValidationError()
    This event is raised when the validator fails in validation.
  • TBaseValidator::onValidationSuccess()
    This event is raised when the validator succeeds in validation.
  • TBaseValidator::registerClientScriptValidator()
    Registers the individual validator client-side javascript code.
  • TBaseValidator::renderClientControlScript()
    Renders the javascript code to the end script.
  • TBaseValidator::renderContents()
    Renders the validator control.
  • TBaseValidator::setControlCssClass()
  • TBaseValidator::setControlToValidate()
    Sets the ID path of the input control to validate.
  • TBaseValidator::setDisplay()
  • TBaseValidator::setEnableClientScript()
  • TBaseValidator::setEnabled()
    This method overrides parent's implementation by setting setIsValid to true if disabled.
  • TBaseValidator::setErrorMessage()
    Sets the text for the error message.
  • TBaseValidator::setFocusElementID()
    Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::setFocusOnError()
  • TBaseValidator::setForControl()
    This method overrides the parent implementation to forbid setting ForControl.
  • TBaseValidator::setIsValid()
    Sets the value indicating whether the validation succeeds
  • TBaseValidator::setValidationGroup()
  • TBaseValidator::updateControlCssClass()
    Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
  • TBaseValidator::validate()
    Validates the specified control.

Inherited From Class TLabel

  • TLabel::addAttributesToRender()
    Adds attributes to renderer.
  • TLabel::getData()
    Returns the text value of the label.
  • TLabel::getForControl()
  • TLabel::getTagName()
  • TLabel::getText()
  • TLabel::render()
    Renders the label.
  • TLabel::renderContents()
    Renders the body content of the label.
  • TLabel::setData()
    Sets the text value of the label.
  • TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
  • TLabel::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRegularExpressionValidator::evaluateIsValid

    evaluateIsValid( );

    Overridden in child classes as:

    TEmailAddressValidator::evaluateIsValid()
    Returns an array of javascript validator options.

    Overrides TBaseValidator::evaluateIsValid() (This is the major method for validation.)

    Returns

    whether the validation succeeds

    Remarks

    This method overrides the parent's implementation.

    The validation succeeds if the input data matches the regular expression. The validation always succeeds if ControlToValidate is not specified or the regular expression is empty, or the input data is empty.

    access

    public

    [ Top ]

    TRegularExpressionValidator::getClientClassName

    getClientClassName( );

    Overridden in child classes as:

    TEmailAddressValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.

    Overrides TBaseValidator::getClientClassName() (Gets the name of the javascript class responsible for performing validation for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing validation for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TRegularExpressionValidator::getClientScriptOptions

    getClientScriptOptions( );

    Overrides TBaseValidator::getClientScriptOptions() (Returns an array of javascript validator options.)

    Returns

    javascript validator options.

    Remarks

    Returns an array of javascript validator options.

    access

    protected

    [ Top ]

    TRegularExpressionValidator::getClientSidePatternModifiers

    getClientSidePatternModifiers( );

    Returns

    clientside pattern modifiers, no modifiers by default.

    access

    public

    [ Top ]

    TRegularExpressionValidator::getPatternModifiers

    getPatternModifiers( );

    Returns

    pattern modifiers, no modifiers by default.

    access

    public

    [ Top ]

    TRegularExpressionValidator::getRegularExpression

    getRegularExpression( );

    Overridden in child classes as:

    TEmailAddressValidator::getRegularExpression()

    Returns

    the regular expression that determines the pattern used to validate a field.

    access

    public

    [ Top ]

    TRegularExpressionValidator::setClientSidePatternModifiers

    setClientSidePatternModifiers( string $value );

    Parameters

    $value

    pattern modifiers for clientside. (Only 'g','i' and 'm' are available.)

    access

    public

    [ Top ]

    TRegularExpressionValidator::setPatternModifiers

    setPatternModifiers( string $value );

    Parameters

    $value

    pattern modifiers for server side validation, see http://www.php.net/manual/en/reference.pcre.pattern.modifiers.php

    access

    public

    [ Top ]

    TRegularExpressionValidator::setRegularExpression

    setRegularExpression( string $value );

    Parameters

    $value

    the regular expression that determines the pattern used to validate a field.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:10 +0200 by phpDocumentor 1.4.3


Docs For Class TRepeater

Class TRepeater

[line 94]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TRepeater
Classes extended from TRepeater:
TActiveRepeater
TActiveRepeater class

Location: /Web/UI/WebControls/TRepeater.php

Remarks

TRepeater class.

TRepeater displays its content repeatedly based on the data fetched from DataSource. The repeated contents in TRepeater are called items, which are controls and can be accessed through Items. When dataBind() is invoked, TRepeater creates an item for each row of data and binds the data row to the item. Optionally, a repeater can have a header, a footer and/or separators between items.

The layout of the repeated contents are specified by inline templates. Repeater items, header, footer, etc. are being instantiated with the corresponding templates when data is being bound to the repeater.

Since v3.1.0, the layout can also be specified by renderers. A renderer is a control class that can be instantiated as repeater items, header, etc. A renderer can thus be viewed as an external template (in fact, it can also be non-templated controls).

A renderer can be any control class.

  • If the class implements IDataRenderer, the Data
property will be set as the data row during databinding. Many PRADO controls implement this interface, such as TLabel, TTextBox, etc.
  • If the class implements IItemDataRenderer, the ItemIndex property will be set
as the zero-based index of the item in the repeater item collection, and the ItemType property as the item's type (such as TListItemType::Item). TRepeaterItemRenderer may be used as the convenient base class which already implements IDataItemRenderer.

The following properties are used to specify different types of template and renderer for a repeater:

  • ItemTemplate, ItemRenderer:
for each repeated row of data
  • AlternatingItemTemplate, AlternatingItemRenderer:
for each alternating row of data. If not set, ItemTemplate or ItemRenderer will be used instead.
  • HeaderTemplate, HeaderRenderer:
for the repeater header.
  • FooterTemplate, FooterRenderer:
for the repeater footer.
  • SeparatorTemplate, SeparatorRenderer:
for content to be displayed between items.
  • EmptyTemplate, EmptyRenderer:
used when data bound to the repeater is empty.

If a content type is defined with both a template and a renderer, the latter takes precedence.

When dataBind() is being called, TRepeater undergoes the following lifecycles for each row of data:

  • create item based on templates or renderers
  • set the row of data to the item
  • raise OnItemCreated:
  • add the item as a child control
  • call dataBind() of the item
  • raise OnItemDataBound:
TRepeater raises an OnItemCommand whenever a button control within some repeater item raises a OnCommand event. Therefore, you can handle all sorts of OnCommand event in a central place by writing an event handler for OnItemCommand.

When a page containing a repeater is post back, the repeater will restore automatically all its contents, including items, header, footer and separators. However, the data row associated with each item will not be recovered and become null. To access the data, use one of the following ways:

  • Use DataKeys to obtain the data key associated with
the specified repeater item and use the key to fetch the corresponding data from some persistent storage such as DB.
  • Save the whole dataset in viewstate, which will restore the dataset automatically upon postback.
Be aware though, if the size of your dataset is big, your page size will become big. Some complex data may also have serializing problem if saved in viewstate.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeater.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • IT_ALTERNATINGITEM = 'AlternatingItem'
  • IT_FOOTER = 'Footer'
  • IT_HEADER = 'Header'
    Repeater item types
  • IT_ITEM = 'Item'
  • IT_SEPARATOR = 'Separator'

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRepeater::bubbleEvent

    bubbleEvent( TControl $sender, TEventParameter $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    the sender of the event

    $param

    event parameter

    Returns

    whether the event bubbling should stop here.

    Remarks

    This method overrides parent's implementation to handle onItemCommand event which is bubbled from repeater items and their child controls.

    This method should only be used by control developers.

    access

    public

    [ Top ]

    TRepeater::createEmptyContent

    createEmptyContent( );

    Remarks

    Creates empty repeater content.

    access

    protected

    [ Top ]

    TRepeater::createItem

    createItem( integer $itemIndex, TListItemType $itemType );

    Parameters

    $itemIndex

    zero-based item index

    $itemType

    item type

    Returns

    created repeater item

    Remarks

    Creates a repeater item instance based on the item type and index.

    access

    protected

    [ Top ]

    TRepeater::getAlternatingItemRenderer

    getAlternatingItemRenderer( );

    Returns

    the class name for alternative repeater items. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeater::getAlternatingItemTemplate

    getAlternatingItemTemplate( );

    Returns

    the alternative template string for the item

    access

    public

    [ Top ]

    TRepeater::getDataFieldValue

    getDataFieldValue( mixed $data, mixed $field );

    Parameters

    $data

    data item

    $field

    field name

    Returns

    data value at the specified field

    Remarks

    Returns the value of the data at the specified field.

    If data is an array, TMap or TList, the value will be returned at the index of the specified field. If the data is a component with a property named as the field name, the property value will be returned. Otherwise, an exception will be raised.

    throws

    TInvalidDataValueException if the data is invalid

    access

    protected

    [ Top ]

    TRepeater::getDataKeyField

    getDataKeyField( );

    Returns

    the field of the data source that provides the keys of the list items.

    access

    public

    [ Top ]

    TRepeater::getDataKeys

    getDataKeys( );

    Returns

    the keys used in the data listing control.

    access

    public

    [ Top ]

    TRepeater::getEmptyRenderer

    getEmptyRenderer( );

    Returns

    the class name for empty repeater item. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeater::getEmptyTemplate

    getEmptyTemplate( );

    Returns

    the template applied when no data is bound to the repeater

    access

    public

    [ Top ]

    TRepeater::getFooter

    getFooter( );

    Returns

    the footer item

    access

    public

    [ Top ]

    TRepeater::getFooterRenderer

    getFooterRenderer( );

    Returns

    the class name for repeater footer item. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeater::getFooterTemplate

    getFooterTemplate( );

    Returns

    the footer template

    access

    public

    [ Top ]

    TRepeater::getHeader

    getHeader( );

    Returns

    the header item

    access

    public

    [ Top ]

    TRepeater::getHeaderRenderer

    getHeaderRenderer( );

    Returns

    the class name for repeater header item. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeater::getHeaderTemplate

    getHeaderTemplate( );

    Returns

    the header template

    access

    public

    [ Top ]

    TRepeater::getItemRenderer

    getItemRenderer( );

    Returns

    the class name for repeater items. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeater::getItems

    getItems( );

    Returns

    list of repeater item controls

    access

    public

    [ Top ]

    TRepeater::getItemTemplate

    getItemTemplate( );

    Returns

    the template for repeater items

    access

    public

    [ Top ]

    TRepeater::getSeparatorRenderer

    getSeparatorRenderer( );

    Returns

    the class name for repeater item separators. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeater::getSeparatorTemplate

    getSeparatorTemplate( );

    Returns

    the separator template

    access

    public

    [ Top ]

    TRepeater::loadState

    loadState( );

    Overrides TControl::loadState() (This method is invoked right after the control has loaded its state.)

    Remarks

    Loads item count information from viewstate.

    This method is invoked right after control state is loaded.

    access

    public

    [ Top ]

    TRepeater::onItemCommand

    onItemCommand( TRepeaterCommandEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnItemCommand event.

    This method is invoked after a button control in a template raises OnCommand event. The repeater control responsible for the event can be determined from the event parameter. The event parameter also contains the information about the initial sender of the OnCommand event, command name and command parameter. You may override this method to provide customized event handling. Be sure to call parent's implementation so that event handlers have chance to respond to the event.

    access

    public

    [ Top ]

    TRepeater::onItemCreated

    onItemCreated( TRepeaterItemEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnItemCreated event.

    This method is invoked after a repeater item is created and instantiated with template, but before added to the page hierarchy. The repeater item control responsible for the event can be determined from the event parameter. If you override this method, be sure to call parent's implementation so that event handlers have chance to respond to the event.

    access

    public

    [ Top ]

    TRepeater::onItemDataBound

    onItemDataBound( TRepeaterItemEventParameter $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnItemDataBound event.

    This method is invoked right after an item is data bound. The repeater item control responsible for the event can be determined from the event parameter. If you override this method, be sure to call parent's implementation so that event handlers have chance to respond to the event.

    access

    public

    [ Top ]

    TRepeater::performDataBinding

    performDataBinding( Traversable $data );

    Overrides TDataBoundControl::performDataBinding() (parent method not documented)

    Parameters

    $data

    the data

    Remarks

    Performs databinding to populate repeater items from data source.

    This method is invoked by dataBind(). You may override this function to provide your own way of data population.

    access

    protected

    [ Top ]

    TRepeater::render

    render( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveRepeater::render()
    Renders the repeater.

    Overrides TWebControl::render() (Renders the control.)

    Parameters

    $writer

    writer

    Remarks

    Renders the repeater.

    This method overrides the parent implementation by rendering the body content as the whole presentation of the repeater. Outer tag is not rendered.

    access

    public

    [ Top ]

    TRepeater::reset

    reset( );

    Remarks

    Clears up all items in the repeater.

    access

    public

    [ Top ]

    TRepeater::restoreItemsFromViewState

    restoreItemsFromViewState( );

    Remarks

    Creates repeater items based on viewstate information.

    access

    protected

    [ Top ]

    TRepeater::saveState

    saveState( );

    Overrides TControl::saveState() (This method is invoked when control state is to be saved.)

    Remarks

    Saves item count in viewstate.

    This method is invoked right before control state is to be saved.

    access

    public

    [ Top ]

    TRepeater::setAlternatingItemRenderer

    setAlternatingItemRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the alternative item renderer class.

    If not empty, the class will be used to instantiate as alternative repeater items. This property takes precedence over AlternatingItemTemplate.

    see

    TRepeater::setAlternatingItemTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeater::setAlternatingItemTemplate

    setAlternatingItemTemplate( ITemplate $value );

    Parameters

    $value

    the alternative item template

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TRepeater::setDataKeyField

    setDataKeyField( string $value );

    Parameters

    $value

    the field of the data source that provides the keys of the list items.

    access

    public

    [ Top ]

    TRepeater::setEmptyRenderer

    setEmptyRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the repeater empty renderer class.

    The empty renderer is created as the child of the repeater if data bound to the repeater is empty. This property takes precedence over EmptyTemplate.

    see

    TRepeater::setEmptyTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeater::setEmptyTemplate

    setEmptyTemplate( ITemplate $value );

    Parameters

    $value

    the template applied when no data is bound to the repeater

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TRepeater::setFooterRenderer

    setFooterRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the repeater footer renderer class.

    If not empty, the class will be used to instantiate as repeater footer item. This property takes precedence over FooterTemplate.

    see

    TRepeater::setFooterTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeater::setFooterTemplate

    setFooterTemplate( ITemplate $value );

    Parameters

    $value

    the footer template

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TRepeater::setHeaderRenderer

    setHeaderRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the repeater header renderer class.

    If not empty, the class will be used to instantiate as repeater header item. This property takes precedence over HeaderTemplate.

    see

    TRepeater::setHeaderTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeater::setHeaderTemplate

    setHeaderTemplate( ITemplate $value );

    Parameters

    $value

    the header template

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TRepeater::setItemRenderer

    setItemRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the item renderer class.

    If not empty, the class will be used to instantiate as repeater items. This property takes precedence over ItemTemplate.

    see

    TRepeater::setItemTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeater::setItemTemplate

    setItemTemplate( ITemplate $value );

    Parameters

    $value

    the template for repeater items

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TRepeater::setSeparatorRenderer

    setSeparatorRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the repeater item separator renderer class.

    If not empty, the class will be used to instantiate as repeater item separators. This property takes precedence over SeparatorTemplate.

    see

    TRepeater::setSeparatorTemplate()

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeater::setSeparatorTemplate

    setSeparatorTemplate( ITemplate $value );

    Parameters

    $value

    the separator template

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • IT_ALTERNATINGITEM = 'AlternatingItem' [line 104]

  • IT_FOOTER = 'Footer' [line 101]

  • IT_HEADER = 'Header' [line 100]

    • Remarks

    Repeater item types

    deprecated

    deprecated since version 3.0.4. Use TListItemType constants instead.

  • IT_ITEM = 'Item' [line 102]

  • IT_SEPARATOR = 'Separator' [line 103]

Documentation generated on Mon, 25 Jun 2012 14:45:11 +0200 by phpDocumentor 1.4.3


Docs For Class TRepeaterCommandEventParameter

Class TRepeaterCommandEventParameter

[line 832]
TComponent
   |
   --TEventParameter
      |
      --TCommandEventParameter
         |
         --TRepeaterCommandEventParameter
Location: /Web/UI/WebControls/TRepeater.php

Remarks

TRepeaterCommandEventParameter class

TRepeaterCommandEventParameter encapsulates the parameter data for TRepeater::onItemCommand event of TRepeater controls.

The Item property indicates the repeater item related with the event. The CommandSource refers to the control that originally raises the Command event.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeater.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TCommandEventParameter

  • TCommandEventParameter::__construct()
    Constructor.
  • TCommandEventParameter::getCommandName()
  • TCommandEventParameter::getCommandParameter()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRepeaterCommandEventParameter::__construct

    __construct( TControl $item, TControl $source, $param );

    Overrides TCommandEventParameter::__construct() (Constructor.)

    Parameters

    $item

    repeater item responsible for the event

    $source

    original event sender

    $param

    original event parameter

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TRepeaterCommandEventParameter::getCommandSource

    getCommandSource( );

    Returns

    the control originally raises the OnCommand event.

    access

    public

    [ Top ]

    TRepeaterCommandEventParameter::getItem

    getItem( );

    Returns

    the repeater item control responsible for the event.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:12 +0200 by phpDocumentor 1.4.3


Docs For Class TRepeaterItem

Class TRepeaterItem

[line 887]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TRepeaterItem
Location: /Web/UI/WebControls/TRepeater.php

Remarks

TRepeaterItem class

A TRepeaterItem control represents an item in the TRepeater control, such as heading section, footer section, or a data item. The index and data value of the item can be accessed via ItemIndex> and DataItem properties, respectively. The type of the item is given by ItemType property.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeater.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRepeaterItem::bubbleEvent

    bubbleEvent( TControl $sender, TEventParameter $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    the sender of the event

    $param

    event parameter

    Returns

    whether the event bubbling should stop here.

    Remarks

    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

    access

    public

    [ Top ]

    TRepeaterItem::getData

    getData( );

    Implementation of:
    IDataRenderer::getData()

    Returns

    data associated with the item

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeaterItem::getDataItem

    getDataItem( );

    Returns

    data associated with the item

    Remarks

    This property is deprecated since v3.1.0.

    deprecated

    deprecated since v3.1.0. Use getData instead.

    access

    public

    [ Top ]

    TRepeaterItem::getItemIndex

    getItemIndex( );

    Implementation of:
    IItemDataRenderer::getItemIndex()
    Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.

    Returns

    zero-based index of the item.

    Remarks

    Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.

    If the item is not in the collection (e.g. it is a header item), it returns -1.

    access

    public

    [ Top ]

    TRepeaterItem::getItemType

    getItemType( );

    Implementation of:
    IItemDataRenderer::getItemType()

    Returns

    item type

    access

    public

    [ Top ]

    TRepeaterItem::setData

    setData( mixed $value );

    Implementation of:
    IDataRenderer::setData()

    Parameters

    $value

    data to be associated with the item

    since

    3.1.0

    access

    public

    [ Top ]

    TRepeaterItem::setDataItem

    setDataItem( mixed $value );

    Parameters

    $value

    data to be associated with the item

    Remarks

    This property is deprecated since v3.1.0.

    deprecated

    deprecated since version 3.1.0. Use setData instead.

    access

    public

    [ Top ]

    TRepeaterItem::setItemIndex

    setItemIndex( integer $value );

    Implementation of:
    IItemDataRenderer::setItemIndex()
    Sets the zero-based index for the item.

    Parameters

    $value

    zero-based index of the item.

    Remarks

    Sets the zero-based index for the item.

    If the item is not in the item collection (e.g. it is a header item), -1 should be used.

    access

    public

    [ Top ]

    TRepeaterItem::setItemType

    setItemType( TListItemType $value );

    Implementation of:
    IItemDataRenderer::setItemType()

    Parameters

    $value

    item type.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:12 +0200 by phpDocumentor 1.4.3


Docs For Class TRepeaterItemCollection

Class TRepeaterItemCollection

[line 1008]
TComponent
   |
   --TList
      |
      --TRepeaterItemCollection
Location: /Web/UI/WebControls/TRepeater.php

Remarks

TRepeaterItemCollection class.

TRepeaterItemCollection represents a collection of repeater items.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeater.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRepeaterItemCollection::insertAt

    insertAt( integer $index, TControl $item );

    Overrides TList::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by inserting only objects that are descendant of TControl.

    throws

    TInvalidDataTypeException if the item to be inserted is not a control.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:13 +0200 by phpDocumentor 1.4.3


Docs For Class TRepeaterItemEventParameter

Class TRepeaterItemEventParameter

[line 791]
TComponent
   |
   --TEventParameter
      |
      --TRepeaterItemEventParameter
Location: /Web/UI/WebControls/TRepeater.php

Remarks

TRepeaterItemEventParameter class

TRepeaterItemEventParameter encapsulates the parameter data for TRepeater::onItemCreated event of TRepeater controls. The Item property indicates the repeater item related with the event.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeater.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRepeaterItemEventParameter::__construct

    __construct( TControl $item );

    Parameters

    $item

    repeater item related with the corresponding event

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TRepeaterItemEventParameter::getItem

    getItem( );

    Returns

    repeater item related with the corresponding event

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:13 +0200 by phpDocumentor 1.4.3


Docs For Class TRepeaterItemRenderer

Class TRepeaterItemRenderer

[line 30]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TDataRenderer
                  |
                  --TItemDataRenderer
                     |
                     --TRepeaterItemRenderer
Location: /Web/UI/WebControls/TRepeaterItemRenderer.php

Remarks

TRepeaterItemRenderer class

TRepeaterItemRenderer can be used as a convenient base class to define an item renderer class specific for TRepeater.

TRepeaterItemRenderer extends TItemDataRenderer and implements the bubbling scheme for the OnCommand event of repeater items.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeaterItemRenderer.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTemplateControl

  • TTemplateControl::EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TItemDataRenderer

  • TItemDataRenderer::getItemIndex()
    Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
  • TItemDataRenderer::getItemType()
  • TItemDataRenderer::setItemIndex()
    Sets the zero-based index for the item.
  • TItemDataRenderer::setItemType()

Inherited From Class TDataRenderer

  • TDataRenderer::getData()
  • TDataRenderer::setData()

Inherited From Class TTemplateControl

  • TTemplateControl::createChildControls()
    Creates child controls.
  • TTemplateControl::getIsSourceTemplateControl()
  • TTemplateControl::getMaster()
  • TTemplateControl::getMasterClass()
  • TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
  • TTemplateControl::getTemplateDirectory()
  • TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
  • TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
  • TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
  • TTemplateControl::registerContent()
    Registers a content control.
  • TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
  • TTemplateControl::setMasterClass()
  • TTemplateControl::setTemplate()
    Sets the parsed template.

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRepeaterItemRenderer::bubbleEvent

    bubbleEvent( TControl $sender, TEventParameter $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    the sender of the event

    $param

    event parameter

    Returns

    whether the event bubbling should stop here.

    Remarks

    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:13 +0200 by phpDocumentor 1.4.3


Docs For Class IRepeatInfoUser

Interface IRepeatInfoUser

[line 24]

Location: /Web/UI/WebControls/TRepeatInfo.php

Remarks

IRepeatInfoUser interface.

This interface must be implemented by classes who want to use TRepeatInfo.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeatInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IRepeatInfoUser::generateItemStyle

generateItemStyle(
string
$itemType, integer
$index );

    Parameters

    $itemType

    item type (Header,Footer,Item,AlternatingItem,SelectedItem,EditItem,Separator,Pager)

    $index

    zero-based index of the current rendering item.

    Returns

    CSS style used for rendering items (including header, footer and separators)

    access

    public

    [ Top ]

    IRepeatInfoUser::getHasFooter

getHasFooter(
 );

    Returns

    whether the repeat user contains footer

    access

    public

    [ Top ]

    IRepeatInfoUser::getHasHeader

getHasHeader(
 );

    Returns

    whether the repeat user contains header

    access

    public

    [ Top ]

    IRepeatInfoUser::getHasSeparators

getHasSeparators(
 );

    Returns

    whether the repeat user contains separators

    access

    public

    [ Top ]

    IRepeatInfoUser::getItemCount

getItemCount(
 );

    Returns

    number of items to be rendered (excluding header, footer and separators)

    access

    public

    [ Top ]

    IRepeatInfoUser::renderItem

renderItem(
THtmlWriter
$writer, TRepeatInfo
$repeatInfo, string
$itemType, integer
$index );

    Parameters

    $writer

    writer for the rendering purpose

    $repeatInfo

    repeat information

    $itemType

    item type

    $index

    zero-based index of the item being rendered

    Remarks

    Renders an item.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:14 +0200 by phpDocumentor 1.4.3


Docs For Class TRepeatDirection

Class TRepeatDirection

[line 533]
TEnumerable
   |
   --TRepeatDirection
Location: /Web/UI/WebControls/TRepeatInfo.php

Remarks

TRepeatDirection class.

TRepeatDirection defines the enumerable type for the possible directions that repeated contents can repeat along

The following enumerable values are defined:

  • Vertical
  • Horizontal

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeatInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Horizontal = 'Horizontal'
  • Vertical = 'Vertical'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Horizontal = 'Horizontal' [line 536]

  • Vertical = 'Vertical' [line 535]

Documentation generated on Mon, 25 Jun 2012 14:45:14 +0200 by phpDocumentor 1.4.3


Docs For Class TRepeatInfo

Class TRepeatInfo

[line 77]
TComponent
   |
   --TRepeatInfo
Location: /Web/UI/WebControls/TRepeatInfo.php

Remarks

TRepeatInfo class.

TRepeatInfo represents repeat information for controls like TCheckBoxList. The layout of the repeated items is specified via RepeatLayout, which can be either Table (default), Flow or Raw. A table layout uses HTML table cells to organize the items while a flow layout uses line breaks to organize the items. The number of columns used to display the items is specified via RepeatColumns property, while the RepeatDirection governs the order of the items being rendered.

Note, the Raw layout does not contain any formatting tags and thus ignores the column and repeat direction settings.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeatInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRepeatInfo::getCaption

    getCaption( );

    Returns

    caption of the table layout

    access

    public

    [ Top ]

    TRepeatInfo::getCaptionAlign

    getCaptionAlign( );

    Returns

    alignment of the caption of the table layout. Defaults to TTableCaptionAlign::NotSet.

    access

    public

    [ Top ]

    TRepeatInfo::getRepeatColumns

    getRepeatColumns( );

    Returns

    the number of columns that the repeated items should be displayed in. Defaults to 0, meaning not set.

    access

    public

    [ Top ]

    TRepeatInfo::getRepeatDirection

    getRepeatDirection( );

    Returns

    the direction of traversing the repeated items, defaults to TRepeatDirection::Vertical

    access

    public

    [ Top ]

    TRepeatInfo::getRepeatLayout

    getRepeatLayout( );

    Returns

    how the repeated items should be displayed, using table or using line breaks. Defaults to TRepeatLayout::Table.

    access

    public

    [ Top ]

    TRepeatInfo::renderFooter

    renderFooter( THtmlWriter $writer, IRepeatInfoUser $user, boolean $tableLayout, integer $columns );

    Parameters

    $writer

    writer for the rendering purpose

    $user

    repeat information user

    $tableLayout

    whether to render using table layout

    $columns

    number of columns to be rendered

    Remarks

    Renders footer.

    access

    protected

    [ Top ]

    TRepeatInfo::renderHeader

    renderHeader( THtmlWriter $writer, IRepeatInfoUser $user, boolean $tableLayout, integer $columns, boolean $needBreak );

    Parameters

    $writer

    writer for the rendering purpose

    $user

    repeat information user

    $tableLayout

    whether to render using table layout

    $columns

    number of columns to be rendered

    $needBreak

    if a line break is needed at the end

    Remarks

    Renders header.

    access

    protected

    [ Top ]

    TRepeatInfo::renderHorizontalContents

    renderHorizontalContents( THtmlWriter $writer, IRepeatInfoUser $user );

    Parameters

    $writer

    writer for the rendering purpose

    $user

    repeat information user

    Remarks

    Renders contents in horizontal repeat direction.

    access

    protected

    [ Top ]

    TRepeatInfo::renderRawContents

    renderRawContents( THtmlWriter $writer, IRepeatInfoUser $user );

    Parameters

    $writer

    writer for the rendering purpose

    $user

    repeat information user

    Remarks

    Renders contents in raw format.

    access

    protected

    [ Top ]

    TRepeatInfo::renderRepeater

    renderRepeater( THtmlWriter $writer, IRepeatInfoUser $user );

    Parameters

    $writer

    writer for the rendering purpose

    $user

    repeat information user

    Remarks

    Renders the repeated items.

    access

    public

    [ Top ]

    TRepeatInfo::renderVerticalContents

    renderVerticalContents( THtmlWriter $writer, IRepeatInfoUser $user );

    Parameters

    $writer

    writer for the rendering purpose

    $user

    repeat information user

    Remarks

    Renders contents in veritcal repeat direction.

    access

    protected

    [ Top ]

    TRepeatInfo::setCaption

    setCaption( string $value );

    Parameters

    $value

    caption of the table layout

    access

    public

    [ Top ]

    TRepeatInfo::setCaptionAlign

    setCaptionAlign( $value );

    Parameters

    $value

    Returns

    alignment of the caption of the table layout.

    access

    public

    [ Top ]

    TRepeatInfo::setRepeatColumns

    setRepeatColumns( integer $value );

    Parameters

    $value

    the number of columns that the repeated items should be displayed in.

    access

    public

    [ Top ]

    TRepeatInfo::setRepeatDirection

    setRepeatDirection( TRepeatDirection $value );

    Parameters

    $value

    the direction of traversing the repeated items

    access

    public

    [ Top ]

    TRepeatInfo::setRepeatLayout

    setRepeatLayout( TRepeatLayout $value );

    Parameters

    $value

    how the repeated items should be displayed, using table or using line breaks.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:14 +0200 by phpDocumentor 1.4.3


Docs For Class TRepeatLayout

Class TRepeatLayout

[line 554]
TEnumerable
   |
   --TRepeatLayout
Location: /Web/UI/WebControls/TRepeatInfo.php

Remarks

TRepeatLayout class.

TRepeatLayout defines the enumerable type for the possible layouts that repeated contents can take.

The following enumerable values are defined:

  • Table: the repeated contents are organized using an HTML table
  • Flow: the repeated contents are organized using HTML spans and breaks
  • Raw: the repeated contents are stacked together without any additional decorations

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRepeatInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Flow = 'Flow'
  • Raw = 'Raw'
  • Table = 'Table'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Flow = 'Flow' [line 557]

  • Raw = 'Raw' [line 558]

  • Table = 'Table' [line 556]

Documentation generated on Mon, 25 Jun 2012 14:45:14 +0200 by phpDocumentor 1.4.3


Docs For Class TRequiredFieldValidator

Class TRequiredFieldValidator

[line 33]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TRequiredFieldValidator
Location: /Web/UI/WebControls/TRequiredFieldValidator.php

Remarks

TRequiredFieldValidator class

TRequiredFieldValidator makes the associated input control a required field. The input control fails validation if its value does not change from the InitialValue property upon losing focus.

Validation will also succeed if input is of TListControl type and the number of selected values different from the initial value is greater than zero.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TRequiredFieldValidator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TBaseValidator

  • TBaseValidator::__construct()
    Constructor.
  • TBaseValidator::addAttributesToRender()
    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
  • TBaseValidator::createClientSide()
  • TBaseValidator::evaluateIsValid()
    This is the major method for validation.
  • TBaseValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
  • TBaseValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
  • TBaseValidator::getClientSide()
    Gets the TValidatorClientSide that allows modification of the client- side validator events.
  • TBaseValidator::getControlCssClass()
  • TBaseValidator::getControlToValidate()
  • TBaseValidator::getDisplay()
  • TBaseValidator::getEnableClientScript()
  • TBaseValidator::getErrorMessage()
  • TBaseValidator::getFocusElementID()
    Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::getFocusOnError()
  • TBaseValidator::getIsValid()
  • TBaseValidator::getValidationGroup()
  • TBaseValidator::getValidationTarget()
  • TBaseValidator::getValidationValue()
    Retrieves the property value of the control being validated.
  • TBaseValidator::onInit()
    Registers the validator with page.
  • TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
  • TBaseValidator::onUnload()
    Unregisters the validator from page.
  • TBaseValidator::onValidate()
    This event is raised right before the validator starts to perform validation.
  • TBaseValidator::onValidationError()
    This event is raised when the validator fails in validation.
  • TBaseValidator::onValidationSuccess()
    This event is raised when the validator succeeds in validation.
  • TBaseValidator::registerClientScriptValidator()
    Registers the individual validator client-side javascript code.
  • TBaseValidator::renderClientControlScript()
    Renders the javascript code to the end script.
  • TBaseValidator::renderContents()
    Renders the validator control.
  • TBaseValidator::setControlCssClass()
  • TBaseValidator::setControlToValidate()
    Sets the ID path of the input control to validate.
  • TBaseValidator::setDisplay()
  • TBaseValidator::setEnableClientScript()
  • TBaseValidator::setEnabled()
    This method overrides parent's implementation by setting setIsValid to true if disabled.
  • TBaseValidator::setErrorMessage()
    Sets the text for the error message.
  • TBaseValidator::setFocusElementID()
    Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::setFocusOnError()
  • TBaseValidator::setForControl()
    This method overrides the parent implementation to forbid setting ForControl.
  • TBaseValidator::setIsValid()
    Sets the value indicating whether the validation succeeds
  • TBaseValidator::setValidationGroup()
  • TBaseValidator::updateControlCssClass()
    Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
  • TBaseValidator::validate()
    Validates the specified control.

Inherited From Class TLabel

  • TLabel::addAttributesToRender()
    Adds attributes to renderer.
  • TLabel::getData()
    Returns the text value of the label.
  • TLabel::getForControl()
  • TLabel::getTagName()
  • TLabel::getText()
  • TLabel::render()
    Renders the label.
  • TLabel::renderContents()
    Renders the body content of the label.
  • TLabel::setData()
    Sets the text value of the label.
  • TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
  • TLabel::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRequiredFieldValidator::evaluateIsValid

    evaluateIsValid( );

    Overrides TBaseValidator::evaluateIsValid() (This is the major method for validation.)

    Returns

    whether the validation succeeds

    Remarks

    This method overrides the parent's implementation.

    The validation succeeds if the input component changes its data from the InitialValue or the input control is not given.

    Validation will also succeed if input is of TListControl type and the number of selected values different from the initial value is greater than zero.

    access

    protected

    [ Top ]

    TRequiredFieldValidator::getClientClassName

    getClientClassName( );

    Overrides TBaseValidator::getClientClassName() (Gets the name of the javascript class responsible for performing validation for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing validation for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TRequiredFieldValidator::getClientScriptOptions

    getClientScriptOptions( );

    Overrides TBaseValidator::getClientScriptOptions() (Returns an array of javascript validator options.)

    Returns

    javascript validator options.

    Remarks

    Returns an array of javascript validator options.

    access

    protected

    [ Top ]

    TRequiredFieldValidator::getInitialValue

    getInitialValue( );

    Returns

    the initial value of the associated input control. Defaults to empty string. If the associated input control does not change from this initial value upon postback, the validation fails.

    access

    public

    [ Top ]

    TRequiredFieldValidator::setInitialValue

    setInitialValue( string $value );

    Parameters

    $value

    the initial value of the associated input control. If the associated input control does not change from this initial value upon postback, the validation fails.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:14 +0200 by phpDocumentor 1.4.3


Docs For Class TSafeHtml

Class TSafeHtml

[line 41]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TSafeHtml
Location: /Web/UI/WebControls/TSafeHtml.php

Remarks

TSafeHtml class

TSafeHtml is a control that strips down all potentially dangerous HTML content. It is mainly a wrapper of SafeHTML project. According to the SafeHTML project, it tries to safeguard the following situations when the string is to be displayed to end-users,

  • Opening tag without its closing tag
  • closing tag without its opening tag
  • any of these tags: base, basefont, head, html, body, applet, object, iframe, frame, frameset, script, layer, ilayer, embed, bgsound, link, meta, style, title, blink, xml, etc.
  • any of these attributes: on*, data*, dynsrc
  • javascript:/vbscript:/about: etc. protocols
  • expression/behavior etc. in styles
  • any other active content.
To use TSafeHtml, simply enclose the content to be secured within the body of TSafeHtml in a template.

If the content is encoded in UTF-7, you'll need to enable the RepackUTF7 property to ensure the contents gets parsed correctly.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSafeHtml.php 3009 2011-07-06 13:23:26Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSafeHtml::getRepackUTF7

    getRepackUTF7( );

    Returns

    whether to parse the contents as UTF-7. Defaults to false.

    access

    public

    [ Top ]

    TSafeHtml::parseSafeHtml

    parseSafeHtml( string $text );

    Parameters

    $text

    HTML content

    Returns

    safer HTML content

    Remarks

    Use SafeHTML to remove malicous javascript from the HTML content.

    access

    protected

    [ Top ]

    TSafeHtml::render

    render( THtmlWriter $writer );

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    writer

    Remarks

    Renders body content.

    This method overrides parent implementation by removing malicious javascript code from the body content

    access

    public

    [ Top ]

    TSafeHtml::setRepackUTF7

    setRepackUTF7( boolean $value );

    Parameters

    $value

    whether to parse the contents as UTF-7

    Remarks

    Sets whether to parse the contents as UTF-7. This property enables a routine that repacks the content as UTF-7 before parsing it. Defaults to false.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:16 +0200 by phpDocumentor 1.4.3


Docs For Class TSlider

Class TSlider

[line 49]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TSlider
Location: /Web/UI/WebControls/TSlider.php

Remarks

TSlider class

TSlider displays a slider for numeric input purpose. A slider consists of a 'track', which define the range of possible value, and a 'handle' which can slide on the track, to select a value in the range. The track can be either Horizontal or Vertical, depending of the SetDirection property. By default, it's horizontal.

The range boundaries are defined by SetMinValue and SetMaxValue properties. The default range is from 0 to 100. The SetStepSize property can be used to define the step between 2 values inside the range. Notice that this step will be recomputed if there is more than 200 values between the range boundaries. You can also provide the allowed values by setting the SetValues array.

A 'Progress Indicator' can be displayed within the track with the SetProgressIndicator property.

The TSlider control can be easily customized using CssClasses. You can provide your own css file, using the SetCssUrl property. The css class for TSlider can be set by the CssClass property. Default value is "Slider HorizontalSlider" for an horizontal slider, and "Slider VerticalSlider" for a vertical one.

If SetAutoPostBack property is true, postback is sent as soon as the value changed.

TSlider raises the onValueChanged event when the value of the slider has changed during postback.

You can also attach ClientSide javascript events handler to the slider :

  • ClientSide.onSlide is called when the handle is slided on the track. You can get the current value in the value
javascript variable. You can use this event to update on client side a label with the current value
  • ClientSide.onChange is called when the slider value has changed (at the end of a move).

author

Christophe Boulain <Christophe.Boulain@gmail.com>

version

$Id: TSlider.php 3118 2012-03-24 22:52:29Z ctrlaltca@gmail.com $

since

3.1.1

Class Variable Summary

Class Constant Summary

  • MAX_STEPS = 200

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSlider::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    writer

    Remarks

    Add the specified css classes to the track

    access

    protected

    [ Top ]

    TSlider::createClientScript

    createClientScript( );

    Returns

    javascript event options.

    access

    protected

    [ Top ]

    TSlider::getAutoPostBack

    getAutoPostBack( );

    Returns

    a value indicating whether an automatic postback to the server will occur whenever the user modifies the slider value. Defaults to false.

    access

    public

    [ Top ]

    TSlider::getClientClassName

    getClientClassName( );

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TSlider::getClientSide

    getClientSide( );

    Returns

    javascript validator event options.

    Remarks

    Gets the TSliderClientScript to set the TSlider event handlers.

    The slider on the client-side supports the following events.

    • <tt>OnSliderMove</tt> -- raised when the slider is moved.
    • <tt>OnSliderChanged</tt> -- raised when the slider value is changed
    You can attach custom javascript code to each of these events

    access

    public

    [ Top ]

    TSlider::getCssUrl

    getCssUrl( );

    Returns

    URL for the CSS file including all relevant CSS class definitions. Defaults to '' (a default CSS file will be applied in this case.)

    access

    public

    [ Top ]

    TSlider::getData

    getData( );

    Returns

    the value of the TSlider control.

    Remarks

    Returns the value of the TSlider control.

    This method is required by IDataRenderer. It is the same as getValue().

    see

    TSlider::getValue()

    access

    public

    [ Top ]

    TSlider::getDataChanged

    getDataChanged( );

    Returns

    whether postback has caused the control data change. False if the page is not in postback mode.

    Remarks

    Returns a value indicating whether postback has caused the control data change.

    This method is required by the IPostBackDataHandler interface.

    access

    public

    [ Top ]

    TSlider::getDirection

    getDirection( );

    Returns

    Direction of slider (Horizontal or Vertical). Defaults to Horizontal.

    access

    public

    [ Top ]

    TSlider::getMaxValue

    getMaxValue( );

    Returns

    Maximum value for the slider. Defaults to 100.0.

    access

    public

    [ Top ]

    TSlider::getMinValue

    getMinValue( );

    Returns

    Minimum value for slider. Defaults to 0.0.

    access

    public

    [ Top ]

    TSlider::getProgressIndicator

    getProgressIndicator( );

    Returns

    wether to display a progress indicator or not. Defaults to true.

    access

    public

    [ Top ]

    TSlider::getSliderOptions

    getSliderOptions( );

    Returns

    slider client-side options

    Remarks

    Get javascript sliderr options.

    access

    protected

    [ Top ]

    TSlider::getStepSize

    getStepSize( );

    Returns

    Step size. Defaults to 1.0.

    access

    public

    [ Top ]

    TSlider::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    the HTML tag name for slider. Defaults to div.

    access

    public

    [ Top ]

    TSlider::getValue

    getValue( );

    Returns

    current value of slider

    access

    public

    [ Top ]

    TSlider::getValues

    getValues( );

    Returns

    list of allowed values the slider can take. Defaults to an empty array.

    access

    public

    [ Top ]

    TSlider::loadPostData

    loadPostData( string $key, array $values );

    Parameters

    $key

    the key that can be used to retrieve data from the input data collection

    $values

    the input data collection

    Returns

    whether the data of the component has been changed

    Remarks

    Loads user input data.

    This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TSlider::onPreRender

    onPreRender( mixed $param );

    Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

    Parameters

    $param

    event parameter

    Remarks

    Registers CSS and JS.

    This method is invoked right before the control rendering, if the control is visible.

    access

    public

    [ Top ]

    TSlider::onValueChanged

    onValueChanged( TEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    Raises OnValueChanged event.

    This method is invoked when the Value property changes on postback. If you override this method, be sure to call the parent implementation to ensure the invocation of the attached event handlers.

    access

    public

    [ Top ]

    TSlider::raisePostDataChangedEvent

    raisePostDataChangedEvent( );

    Remarks

    Raises postdata changed event.

    This method is required by IPostBackDataHandler interface. It is invoked by the framework when Value property is changed on postback. This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TSlider::registerSliderClientScript

    registerSliderClientScript( );

    Remarks

    Registers the javascript code to initialize the slider.

    access

    protected

    [ Top ]

    TSlider::registerStyleSheet

    registerStyleSheet( );

    Remarks

    Registers the CSS relevant to the TSlider.

    It will register the CSS file specified by CssUrl. If that is not set, it will use the default CSS.

    access

    protected

    [ Top ]

    TSlider::renderContents

    renderContents( $writer );

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    Remarks

    Render the body content

    access

    public

    [ Top ]

    TSlider::setAutoPostBack

    setAutoPostBack( boolean $value );

    Parameters

    $value

    the value indicating if postback automatically

    Remarks

    Sets the value indicating if postback automatically.

    An automatic postback to the server will occur whenever the user modifies the slider value.

    access

    public

    [ Top ]

    TSlider::setCssUrl

    setCssUrl( string $value );

    Parameters

    $value

    URL for the CSS file including all relevant CSS class definitions.

    access

    public

    [ Top ]

    TSlider::setData

    setData( string $value );

    Parameters

    $value

    the value of the TSlider control.

    Remarks

    Sets the value of the TSlider control.

    This method is required by IDataRenderer. It is the same as setValue().

    see

    TSlider::setValue()

    access

    public

    [ Top ]

    TSlider::setDirection

    setDirection( TSliderDirection $value );

    Parameters

    $value

    Direction of slider (Horizontal or Vertical)

    access

    public

    [ Top ]

    TSlider::setMaxValue

    setMaxValue( float $value );

    Parameters

    $value

    Maximum value for slider

    access

    public

    [ Top ]

    TSlider::setMinValue

    setMinValue( float $value );

    Parameters

    $value

    Minimum value for slider

    access

    public

    [ Top ]

    TSlider::setProgressIndicator

    setProgressIndicator( boolean $value );

    Parameters

    $value

    wether to display a progress indicator or not. Defaults to true.

    access

    public

    [ Top ]

    TSlider::setStepSize

    setStepSize( float $value );

    Parameters

    $value

    Step size.

    Remarks

    Sets the step size used to determine the places where the slider handle can stop at.

    An evenly distributed stop marks will be generated according to MinValue, MaxValue and StepSize. To use uneven stop marks, set Values.

    access

    public

    [ Top ]

    TSlider::setValue

    setValue( float $value );

    Parameters

    $value

    current value of slider

    access

    public

    [ Top ]

    TSlider::setValues

    setValues( array $value );

    Parameters

    $value

    list of allowed values the slider can take

    Remarks

    Sets the possible values that the slider can take.

    If this is set, StepSize will be ignored. The latter generates a set of evenly distributed candidate values.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • MAX_STEPS = 200 [line 51]

Documentation generated on Mon, 25 Jun 2012 14:45:22 +0200 by phpDocumentor 1.4.3


Docs For Class TSliderClientScript

Class TSliderClientScript

[line 515]
TComponent
   |
   --TClientSideOptions
      |
      --TSliderClientScript
Location: /Web/UI/WebControls/TSlider.php

Remarks

TSliderClientScript class.

Client-side slider events OnChange and {@line setOnMove OnMove} can be modified through the TSlider:: property of a slider.

The current value of the slider can be get in the 'value' js variable

The <tt>OnMove</tt> event is raised when the slider moves The <tt>OnChange</tt> event is raised when the slider value is changed (or at the end of a move)

author

Christophe Boulain <Christophe.Boulain@gmail.com>

version

$Id: TSlider.php 3118 2012-03-24 22:52:29Z ctrlaltca@gmail.com $

since

3.1.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TClientSideOptions

  • TClientSideOptions::__construct()
    Constructor, initialize the options list.
  • TClientSideOptions::ensureFunction()
    Ensure that the javascript statements are wrapped in a javascript function block as
  • function(sender, parameter){ //code }
    •
    .
  • TClientSideOptions::getOption()
  • TClientSideOptions::getOptions()
  • TClientSideOptions::setFunction()
    Adds on client-side event handler by wrapping the code within a javascript function block. If the code begins with "javascript:", the code is assumed to be a javascript function block rather than arbiturary javascript statements.
  • TClientSideOptions::setOption()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSliderClientScript::getOnChange

    getOnChange( );

    Returns

    javascript code to execute when the slider value is changed.

    access

    public

    [ Top ]

    TSliderClientScript::getOnSlide

    getOnSlide( );

    Returns

    javascript code to execute when the slider moves.

    access

    public

    [ Top ]

    TSliderClientScript::setOnChange

    setOnChange( string $javascript );

    Parameters

    $javascript

    javascript code

    Remarks

    Javascript code to execute when the slider value is changed.

    access

    public

    [ Top ]

    TSliderClientScript::setOnSlide

    setOnSlide( $javascript );

    Parameters

    $javascript

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:23 +0200 by phpDocumentor 1.4.3


Docs For Class TSliderDirection

Class TSliderDirection

[line 568]
TEnumerable
   |
   --TSliderDirection
Location: /Web/UI/WebControls/TSlider.php

Remarks

TSliderDirection class.

TSliderDirection defines the enumerable type for the possible direction that can be used in a TSlider

The following enumerable values are defined :

  • Horizontal : Horizontal slider
  • Vertical : Vertical slider

author

Christophe Boulain <Christophe.Boulain@gmail.com>

version

$Id: TSlider.php 3118 2012-03-24 22:52:29Z ctrlaltca@gmail.com $

since

3.1.1

Class Variable Summary

Class Constant Summary

  • Horizontal = 'Horizontal'
  • Vertical = 'Vertical'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Horizontal = 'Horizontal' [line 570]

  • Vertical = 'Vertical' [line 571]

Documentation generated on Mon, 25 Jun 2012 14:45:23 +0200 by phpDocumentor 1.4.3


Docs For Class TStatements

Class TStatements

[line 30]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TStatements
Location: /Web/UI/WebControls/TStatements.php

Remarks

TStatements class

TStatements executes one or several PHP statements and renders the display generated during the execution. The execution happens during the rendering stage. The PHP statements being executed can be set via the property Statements. The context of the statemenets executed is the TStatements object itself.

Note, since TStatements allows execution of arbitrary PHP statements, make sure Statements does not come directly from user input.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TStatements.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TStatements::getStatements

    getStatements( );

    Returns

    the statements to be executed

    access

    public

    [ Top ]

    TStatements::render

    render( THtmlWriter $writer );

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the evaluation result of the statements.

    access

    public

    [ Top ]

    TStatements::setStatements

    setStatements( string $value );

    Parameters

    $value

    the PHP statements to be executed

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:29 +0200 by phpDocumentor 1.4.3


Docs For Class TDisplayStyle

Class TDisplayStyle

[line 425]
TEnumerable
   |
   --TDisplayStyle
Location: /Web/UI/WebControls/TStyle.php

Remarks

TDisplayStyle defines the enumerable type for the possible styles that a web control can display.

The following enumerable values are defined:

  • None: the control is not displayed and not included in the layout.
  • Dynamic: the control is displayed and included in the layout, the layout flow is dependent on the control (equivalent to display:'' in css).
  • Fixed: Similar to Dynamic with CSS "visibility" set "shown".
  • Hidden: the control is not displayed and is included in the layout.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TStyle.php 3045 2011-10-02 21:22:52Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

  • Dynamic = 'Dynamic'
  • Fixed = 'Fixed'
  • Hidden = 'Hidden'
  • None = 'None'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Dynamic = 'Dynamic' [line 428]

  • Fixed = 'Fixed' [line 429]

  • Hidden = 'Hidden' [line 430]

  • None = 'None' [line 427]

Documentation generated on Mon, 25 Jun 2012 14:45:29 +0200 by phpDocumentor 1.4.3


Docs For Class THorizontalAlign

Class THorizontalAlign

[line 838]
TEnumerable
   |
   --THorizontalAlign
Location: /Web/UI/WebControls/TStyle.php

Remarks

THorizontalAlign class.

THorizontalAlign defines the enumerable type for the possible horizontal alignments in a CSS style.

The following enumerable values are defined:

  • NotSet: the alignment is not specified.
  • Left: left aligned
  • Right: right aligned
  • Center: center aligned
  • Justify: the begin and end are justified

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TStyle.php 3045 2011-10-02 21:22:52Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Center = 'Center'
  • Justify = 'Justify'
  • Left = 'Left'
  • NotSet = 'NotSet'
  • Right = 'Right'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Center = 'Center' [line 843]

  • Justify = 'Justify' [line 844]

  • Left = 'Left' [line 841]

  • NotSet = 'NotSet' [line 840]

  • Right = 'Right' [line 842]

Documentation generated on Mon, 25 Jun 2012 14:45:29 +0200 by phpDocumentor 1.4.3


Docs For Class TStyle

Class TStyle

[line 28]
TComponent
   |
   --TStyle
Classes extended from TStyle:
TPanelStyle
TPanelStyle class.
TTableStyle
TTableStyle class.
TTableItemStyle
TTableItemStyle class.
TWizardNavigationButtonStyle
TWizardNavigationButtonStyle class.

Location: /Web/UI/WebControls/TStyle.php

Remarks

TStyle class

TStyle encapsulates the CSS style applied to a control.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TStyle.php 3045 2011-10-02 21:22:52Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TStyle::__construct

    __construct( [TStyle $style = null] );

    Parameters

    $style

    style to copy from

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TStyle::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overridden in child classes as:

    TPanelStyle::addAttributesToRender()
    Adds attributes related to CSS styles to renderer.
    TTableStyle::addAttributesToRender()
    Adds attributes related to CSS styles to renderer.
    TTableItemStyle::addAttributesToRender()
    Adds attributes related to CSS styles to renderer.

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attributes related to CSS styles to renderer.

    access

    public

    [ Top ]

    TStyle::clearStyleField

    clearStyleField( string $name );

    Parameters

    $name

    style field name

    Remarks

    Clears a single style field value;

    access

    public

    [ Top ]

    TStyle::copyFrom

    copyFrom( TStyle $style );

    Overridden in child classes as:

    TPanelStyle::copyFrom()
    Copies the fields in a new style to this style.
    TDataGridPagerStyle::copyFrom()
    Copies the fields in a new style to this style.
    TTableStyle::copyFrom()
    Copies the fields in a new style to this style.
    TTableItemStyle::copyFrom()
    Copies the fields in a new style to this style.
    TWizardNavigationButtonStyle::copyFrom()
    Copies the fields in a new style to this style.

    Parameters

    $style

    the new style

    Remarks

    Copies the fields in a new style to this style.

    If a style field is set in the new style, the corresponding field in this style will be overwritten.

    access

    public

    [ Top ]

    TStyle::getBackColor

    getBackColor( );

    Returns

    the background color of the control

    access

    public

    [ Top ]

    TStyle::getBorderColor

    getBorderColor( );

    Returns

    the border color of the control

    access

    public

    [ Top ]

    TStyle::getBorderStyle

    getBorderStyle( );

    Returns

    the border style of the control

    access

    public

    [ Top ]

    TStyle::getBorderWidth

    getBorderWidth( );

    Returns

    the border width of the control

    access

    public

    [ Top ]

    TStyle::getCssClass

    getCssClass( );

    Returns

    the CSS class of the control

    access

    public

    [ Top ]

    TStyle::getCustomStyle

    getCustomStyle( );

    Returns

    the custom style of the control

    access

    public

    [ Top ]

    TStyle::getDisplayStyle

    getDisplayStyle( );

    Returns

    display style

    access

    public

    [ Top ]

    TStyle::getFont

    getFont( );

    Returns

    the font of the control

    access

    public

    [ Top ]

    TStyle::getForeColor

    getForeColor( );

    Returns

    the foreground color of the control

    access

    public

    [ Top ]

    TStyle::getHeight

    getHeight( );

    Returns

    the height of the control

    access

    public

    [ Top ]

    TStyle::getStyleField

    getStyleField( $name );

    Parameters

    $name

    Returns

    a single style field value set via setStyleField. Defaults to empty string.

    access

    public

    [ Top ]

    TStyle::getStyleFields

    getStyleFields( );

    Returns

    list of style fields.

    access

    public

    [ Top ]

    TStyle::getWidth

    getWidth( );

    Returns

    the width of the control

    access

    public

    [ Top ]

    TStyle::hasCssClass

    hasCssClass( );

    Returns

    true if CSS is set or empty.

    access

    public

    [ Top ]

    TStyle::hasFont

    hasFont( );

    Returns

    true if font is set.

    access

    public

    [ Top ]

    TStyle::hasStyleField

    hasStyleField( $name );

    Parameters

    $name

    Returns

    whether a style field has been defined by setStyleField

    access

    public

    [ Top ]

    TStyle::mergeWith

    mergeWith( TStyle $style );

    Overridden in child classes as:

    TPanelStyle::mergeWith()
    Merges the style with a new one.
    TDataGridPagerStyle::mergeWith()
    Merges the style with a new one.
    TTableStyle::mergeWith()
    Merges the style with a new one.
    TTableItemStyle::mergeWith()
    Merges the style with a new one.
    TWizardNavigationButtonStyle::mergeWith()
    Merges the style with a new one.

    Parameters

    $style

    the new style

    Remarks

    Merges the style with a new one.

    If a style field is not set in this style, it will be overwritten by the new one.

    access

    public

    [ Top ]

    TStyle::reset

    reset( );

    Overridden in child classes as:

    TPanelStyle::reset()
    Sets the style attributes to default values.
    TDataGridPagerStyle::reset()
    Resets the style to the original empty state.
    TTableStyle::reset()
    Sets the style attributes to default values.
    TTableItemStyle::reset()
    Sets the style attributes to default values.
    TWizardNavigationButtonStyle::reset()
    Sets the style attributes to default values.

    Remarks

    Resets the style to the original empty state.

    access

    public

    [ Top ]

    TStyle::setBackColor

    setBackColor( string $value );

    Parameters

    $value

    the background color of the control

    access

    public

    [ Top ]

    TStyle::setBorderColor

    setBorderColor( string $value );

    Parameters

    $value

    the border color of the control

    access

    public

    [ Top ]

    TStyle::setBorderStyle

    setBorderStyle( string $value );

    Parameters

    $value

    the border style of the control

    Remarks

    Sets the border style of the control.

    access

    public

    [ Top ]

    TStyle::setBorderWidth

    setBorderWidth( string $value );

    Parameters

    $value

    the border width of the control

    access

    public

    [ Top ]

    TStyle::setCssClass

    setCssClass( string $value );

    Parameters

    $value

    the name of the CSS class of the control

    access

    public

    [ Top ]

    TStyle::setCustomStyle

    setCustomStyle( string $value );

    Parameters

    $value

    the custom style of the control

    Remarks

    Sets custom style fields from a string.

    Custom style fields will be overwritten by style fields explicitly defined.

    access

    public

    [ Top ]

    TStyle::setDisplayStyle

    setDisplayStyle( TDisplayStyle $value );

    Parameters

    $value

    control display style, default is TDisplayStyle::Fixed

    access

    public

    [ Top ]

    TStyle::setForeColor

    setForeColor( string $value );

    Parameters

    $value

    the foreground color of the control

    access

    public

    [ Top ]

    TStyle::setHeight

    setHeight( string $value );

    Parameters

    $value

    the height of the control

    access

    public

    [ Top ]

    TStyle::setStyleField

    setStyleField( string $name, string $value );

    Parameters

    $name

    style field name

    $value

    style field value

    Remarks

    Sets a single style field value.

    Style fields set by this method will overwrite those set by setCustomStyle.

    access

    public

    [ Top ]

    TStyle::setWidth

    setWidth( string $value );

    Parameters

    $value

    the width of the control

    access

    public

    [ Top ]

    TStyle::__clone

    __clone( );

    Remarks

    Need to clone the font object.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:29 +0200 by phpDocumentor 1.4.3


Docs For Class TTableGridLines

Class TTableGridLines

[line 886]
TEnumerable
   |
   --TTableGridLines
Location: /Web/UI/WebControls/TStyle.php

Remarks

TTableGridLines class.

TTableGridLines defines the enumerable type for the possible grid line types of an HTML table.

The following enumerable values are defined:

  • None: no grid lines
  • Horizontal: horizontal grid lines only
  • Vertical: vertical grid lines only
  • Both: both horizontal and vertical grid lines are shown

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TStyle.php 3045 2011-10-02 21:22:52Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Both = 'Both'
  • Horizontal = 'Horizontal'
  • None = 'None'
  • Vertical = 'Vertical'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Both = 'Both' [line 891]

  • Horizontal = 'Horizontal' [line 889]

  • None = 'None' [line 888]

  • Vertical = 'Vertical' [line 890]

Documentation generated on Mon, 25 Jun 2012 14:45:29 +0200 by phpDocumentor 1.4.3


Docs For Class TTableItemStyle

Class TTableItemStyle

[line 683]
TComponent
   |
   --TStyle
      |
      --TTableItemStyle
Location: /Web/UI/WebControls/TStyle.php

Remarks

TTableItemStyle class.

TTableItemStyle represents the CSS style specific for HTML table item.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TStyle.php 3045 2011-10-02 21:22:52Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TStyle

  • TStyle::__construct()
    Constructor.
  • TStyle::addAttributesToRender()
    Adds attributes related to CSS styles to renderer.
  • TStyle::clearStyleField()
    Clears a single style field value;
  • TStyle::copyFrom()
    Copies the fields in a new style to this style.
  • TStyle::getBackColor()
  • TStyle::getBorderColor()
  • TStyle::getBorderStyle()
  • TStyle::getBorderWidth()
  • TStyle::getCssClass()
  • TStyle::getCustomStyle()
  • TStyle::getDisplayStyle()
  • TStyle::getFont()
  • TStyle::getForeColor()
  • TStyle::getHeight()
  • TStyle::getStyleField()
  • TStyle::getStyleFields()
  • TStyle::getWidth()
  • TStyle::hasCssClass()
  • TStyle::hasFont()
  • TStyle::hasStyleField()
  • TStyle::mergeWith()
    Merges the style with a new one.
  • TStyle::reset()
    Resets the style to the original empty state.
  • TStyle::setBackColor()
  • TStyle::setBorderColor()
  • TStyle::setBorderStyle()
    Sets the border style of the control.
  • TStyle::setBorderWidth()
  • TStyle::setCssClass()
  • TStyle::setCustomStyle()
    Sets custom style fields from a string.
  • TStyle::setDisplayStyle()
  • TStyle::setForeColor()
  • TStyle::setHeight()
  • TStyle::setStyleField()
    Sets a single style field value.
  • TStyle::setWidth()
  • TStyle::__clone()
    Need to clone the font object.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTableItemStyle::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overrides TStyle::addAttributesToRender() (Adds attributes related to CSS styles to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attributes related to CSS styles to renderer.

    This method overrides the parent implementation.

    access

    public

    [ Top ]

    TTableItemStyle::copyFrom

    copyFrom( TStyle $style );

    Overrides TStyle::copyFrom() (Copies the fields in a new style to this style.)

    Parameters

    $style

    the new style

    Remarks

    Copies the fields in a new style to this style.

    If a style field is set in the new style, the corresponding field in this style will be overwritten.

    access

    public

    [ Top ]

    TTableItemStyle::getHorizontalAlign

    getHorizontalAlign( );

    Returns

    the horizontal alignment of the contents within the table item, defaults to THorizontalAlign::NotSet.

    access

    public

    [ Top ]

    TTableItemStyle::getVerticalAlign

    getVerticalAlign( );

    Returns

    the vertical alignment of the contents within the table item, defaults to TVerticalAlign::NotSet.

    access

    public

    [ Top ]

    TTableItemStyle::getWrap

    getWrap( );

    Returns

    whether the content wraps within the table item. Defaults to true.

    access

    public

    [ Top ]

    TTableItemStyle::mergeWith

    mergeWith( TStyle $style );

    Overrides TStyle::mergeWith() (Merges the style with a new one.)

    Parameters

    $style

    the new style

    Remarks

    Merges the style with a new one.

    If a style field is not set in this style, it will be overwritten by the new one.

    access

    public

    [ Top ]

    TTableItemStyle::reset

    reset( );

    Overrides TStyle::reset() (Resets the style to the original empty state.)

    Remarks

    Sets the style attributes to default values.

    This method overrides the parent implementation by resetting additional TTableItemStyle specific attributes.

    access

    public

    [ Top ]

    TTableItemStyle::setHorizontalAlign

    setHorizontalAlign( THorizontalAlign $value );

    Parameters

    $value

    the horizontal alignment

    Remarks

    Sets the horizontal alignment of the contents within the table item.

    access

    public

    [ Top ]

    TTableItemStyle::setVerticalAlign

    setVerticalAlign( TVerticalAlign $value );

    Parameters

    $value

    the horizontal alignment

    Remarks

    Sets the vertical alignment of the contents within the table item.

    access

    public

    [ Top ]

    TTableItemStyle::setWrap

    setWrap( boolean $value );

    Parameters

    $value

    whether the content wraps within the panel.

    Remarks

    Sets the value indicating whether the content wraps within the table item.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:29 +0200 by phpDocumentor 1.4.3


Docs For Class TTableStyle

Class TTableStyle

[line 442]
TComponent
   |
   --TStyle
      |
      --TTableStyle
Location: /Web/UI/WebControls/TStyle.php

Remarks

TTableStyle class.

TTableStyle represents the CSS style specific for HTML table.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TStyle.php 3045 2011-10-02 21:22:52Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TStyle

  • TStyle::__construct()
    Constructor.
  • TStyle::addAttributesToRender()
    Adds attributes related to CSS styles to renderer.
  • TStyle::clearStyleField()
    Clears a single style field value;
  • TStyle::copyFrom()
    Copies the fields in a new style to this style.
  • TStyle::getBackColor()
  • TStyle::getBorderColor()
  • TStyle::getBorderStyle()
  • TStyle::getBorderWidth()
  • TStyle::getCssClass()
  • TStyle::getCustomStyle()
  • TStyle::getDisplayStyle()
  • TStyle::getFont()
  • TStyle::getForeColor()
  • TStyle::getHeight()
  • TStyle::getStyleField()
  • TStyle::getStyleFields()
  • TStyle::getWidth()
  • TStyle::hasCssClass()
  • TStyle::hasFont()
  • TStyle::hasStyleField()
  • TStyle::mergeWith()
    Merges the style with a new one.
  • TStyle::reset()
    Resets the style to the original empty state.
  • TStyle::setBackColor()
  • TStyle::setBorderColor()
  • TStyle::setBorderStyle()
    Sets the border style of the control.
  • TStyle::setBorderWidth()
  • TStyle::setCssClass()
  • TStyle::setCustomStyle()
    Sets custom style fields from a string.
  • TStyle::setDisplayStyle()
  • TStyle::setForeColor()
  • TStyle::setHeight()
  • TStyle::setStyleField()
    Sets a single style field value.
  • TStyle::setWidth()
  • TStyle::__clone()
    Need to clone the font object.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTableStyle::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overrides TStyle::addAttributesToRender() (Adds attributes related to CSS styles to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attributes related to CSS styles to renderer.

    This method overrides the parent implementation.

    access

    public

    [ Top ]

    TTableStyle::copyFrom

    copyFrom( TStyle $style );

    Overrides TStyle::copyFrom() (Copies the fields in a new style to this style.)

    Parameters

    $style

    the new style

    Remarks

    Copies the fields in a new style to this style.

    If a style field is set in the new style, the corresponding field in this style will be overwritten.

    access

    public

    [ Top ]

    TTableStyle::getBackImageUrl

    getBackImageUrl( );

    Returns

    the URL of the background image for the table

    access

    public

    [ Top ]

    TTableStyle::getBorderCollapse

    getBorderCollapse( );

    Returns

    whether the table borders should be collapsed. Defaults to false.

    access

    public

    [ Top ]

    TTableStyle::getCellPadding

    getCellPadding( );

    Returns

    cellpadding of the table. Defaults to -1, meaning not set.

    access

    public

    [ Top ]

    TTableStyle::getCellSpacing

    getCellSpacing( );

    Returns

    cellspacing of the table. Defaults to -1, meaning not set.

    access

    public

    [ Top ]

    TTableStyle::getGridLines

    getGridLines( );

    Returns

    the grid line setting of the table. Defaults to TTableGridLines::None.

    access

    public

    [ Top ]

    TTableStyle::getHorizontalAlign

    getHorizontalAlign( );

    Returns

    the horizontal alignment of the contents within the table, defaults to THorizontalAlign::NotSet.

    access

    public

    [ Top ]

    TTableStyle::mergeWith

    mergeWith( TStyle $style );

    Overrides TStyle::mergeWith() (Merges the style with a new one.)

    Parameters

    $style

    the new style

    Remarks

    Merges the style with a new one.

    If a style field is not set in this style, it will be overwritten by the new one.

    access

    public

    [ Top ]

    TTableStyle::reset

    reset( );

    Overrides TStyle::reset() (Resets the style to the original empty state.)

    Remarks

    Sets the style attributes to default values.

    This method overrides the parent implementation by resetting additional TTableStyle specific attributes.

    access

    public

    [ Top ]

    TTableStyle::setBackImageUrl

    setBackImageUrl( string $value );

    Parameters

    $value

    the URL

    Remarks

    Sets the URL of the background image for the table

    access

    public

    [ Top ]

    TTableStyle::setBorderCollapse

    setBorderCollapse( boolean $value );

    Parameters

    $value

    whether the table borders should be collapsed.

    access

    public

    [ Top ]

    TTableStyle::setCellPadding

    setCellPadding( integer $value );

    Parameters

    $value

    cellpadding of the table. A value equal to -1 clears up the setting.

    throws

    TInvalidDataValueException if the value is less than -1.

    access

    public

    [ Top ]

    TTableStyle::setCellSpacing

    setCellSpacing( integer $value );

    Parameters

    $value

    cellspacing of the table. A value equal to -1 clears up the setting.

    throws

    TInvalidDataValueException if the value is less than -1.

    access

    public

    [ Top ]

    TTableStyle::setGridLines

    setGridLines( TTableGridLines $value );

    Parameters

    $value

    the grid line setting of the table

    Remarks

    Sets the grid line style of the table.

    access

    public

    [ Top ]

    TTableStyle::setHorizontalAlign

    setHorizontalAlign( THorizontalAlign $value );

    Parameters

    $value

    the horizontal alignment

    Remarks

    Sets the horizontal alignment of the contents within the table.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:30 +0200 by phpDocumentor 1.4.3


Docs For Class TVerticalAlign

Class TVerticalAlign

[line 862]
TEnumerable
   |
   --TVerticalAlign
Location: /Web/UI/WebControls/TStyle.php

Remarks

TVerticalAlign class.

TVerticalAlign defines the enumerable type for the possible vertical alignments in a CSS style.

The following enumerable values are defined:

  • NotSet: the alignment is not specified.
  • Top: top aligned
  • Bottom: bottom aligned
  • Middle: middle aligned

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TStyle.php 3045 2011-10-02 21:22:52Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Bottom = 'Bottom'
  • Middle = 'Middle'
  • NotSet = 'NotSet'
  • Top = 'Top'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Bottom = 'Bottom' [line 866]

  • Middle = 'Middle' [line 867]

  • NotSet = 'NotSet' [line 864]

  • Top = 'Top' [line 865]

Documentation generated on Mon, 25 Jun 2012 14:45:30 +0200 by phpDocumentor 1.4.3


Docs For Class TStyleSheet

Class TStyleSheet

[line 30]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TStyleSheet
Location: /Web/UI/WebControls/TStyleSheet.php

Remarks

TStyleSheet class.

TStyleSheet represents the link to a stylesheet file and/or a piece of stylesheet code. To specify the link to a CSS file, set StyleSheetUrl. The child rendering result of TStyleSheet is treated as CSS code and is rendered within an appropriate style HTML element. Therefore, if the child content is not empty, you should place the TStyleSheet control in the head section of your page to conform to the HTML standard. If only CSS file URL is specified, you may place the control anywhere on your page and the style element will be rendered in the right position.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

: $ Tue Jul 4 04:38:16 EST 2006 $

since

3.0.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TStyleSheet::getMediaType

    getMediaType( );

    Returns

    media type of the CSS (such as 'print', 'screen', etc.). Defaults to empty, meaning the CSS applies to all media types.

    access

    public

    [ Top ]

    TStyleSheet::getStyleSheetUrl

    getStyleSheetUrl( );

    Returns

    URL to the stylesheet file

    access

    public

    [ Top ]

    TStyleSheet::onPreRender

    onPreRender( mixed $param );

    Overrides TControl::onPreRender() (This method is invoked when the control enters 'OnPreRender' stage.)

    Parameters

    $param

    event parameter

    Remarks

    Registers the stylesheet file and content to be rendered.

    This method overrides the parent implementation and is invoked right before rendering.

    access

    public

    [ Top ]

    TStyleSheet::render

    render( ITextWriter $writer );

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    writer

    Remarks

    Renders the control.

    This method overrides the parent implementation and renders nothing.

    access

    public

    [ Top ]

    TStyleSheet::setMediaType

    setMediaType( string $value );

    Parameters

    $value

    media type of the CSS (such as 'print', 'screen', etc.). If empty, it means the CSS applies to all media types.

    access

    public

    [ Top ]

    TStyleSheet::setStyleSheetUrl

    setStyleSheetUrl( string $value );

    Parameters

    $value

    URL to the stylesheet file

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:30 +0200 by phpDocumentor 1.4.3


Docs For Class TTable

Class TTable

[line 68]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTable
Location: /Web/UI/WebControls/TTable.php

Remarks

TTable class

TTable displays an HTML table on a Web page.

A table may have Caption, whose alignment is specified via CaptionAlign. The table cellpadding and cellspacing are specified via CellPadding and CellSpacing properties, respectively. The GridLines specifies how the table should display its borders. The horizontal alignment of the table content can be specified via HorizontalAlign, and BackImageUrl can assign a background image to the table.

A TTable maintains a list of TTableRow controls in its Rows property. Each TTableRow represents an HTML table row.

To populate the table Rows, you may either use control template or dynamically create TTableRow in code. In template, do as follows to create the table rows and cells,

  •    <com:TTable>
    •

  •      <com:TTableRow>
    •

  •        <com:TTableCell Text="content" />
    •

  •        <com:TTableCell Text="content" />
    •

  •      </com:TTableRow>
    •

  •      <com:TTableRow>
    •

  •        <com:TTableCell Text="content" />
    •

  •        <com:TTableCell Text="content" />
    •

  •      </com:TTableRow>
    •

  •    </com:TTable>
    •
    The above can also be accomplished in code as follows,
  •    $table=new TTable;
    •

  •    $row=new TTableRow;
    •

  •    $cell=new TTableCell; $cell->Text="content"; $row->Cells->add($cell);
    •

  •    $cell=new TTableCell; $cell->Text="content"; $row->Cells->add($cell);
    •

  •    $table->Rows->add($row);
    •

  •    $row=new TTableRow;
    •

  •    $cell=new TTableCell; $cell->Text="content"; $row->Cells->add($cell);
    •

  •    $cell=new TTableCell; $cell->Text="content"; $row->Cells->add($cell);
    •

  •    $table->Rows->add($row);
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TTable.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TTable::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

      Parameters

      $writer

      the renderer

      Remarks

      Adds attributes to renderer.

      access

      protected

      [ Top ]

      TTable::addParsedObject

      addParsedObject( mixed $object );

      Overrides TControl::addParsedObject() (Adds the object instantiated on a template to the child control collection.)

      Parameters

      $object

      object parsed from template

      Remarks

      Adds object parsed from template to the control.

      This method adds only TTableRow objects into the Rows collection. All other objects are ignored.

      access

      public

      [ Top ]

      TTable::createControlCollection

      createControlCollection( );

      Overrides TControl::createControlCollection() (Creates a control collection object that is to be used to hold child controls)

      Returns

      control collection

      Remarks

      Creates a control collection object that is to be used to hold child controls

      see

      TControl::getControls()

      access

      protected

      [ Top ]

      TTable::createStyle

      createStyle( );

      Overrides TWebControl::createStyle() (Creates a style object to be used by the control.)

      Returns

      control style to be used

      Remarks

      Creates a style object for the control.

      This method creates a TTableStyle to be used by the table.

      access

      protected

      [ Top ]

      TTable::getBackImageUrl

      getBackImageUrl( );

      Returns

      the URL of the background image for the table

      access

      public

      [ Top ]

      TTable::getCaption

      getCaption( );

      Returns

      table caption

      access

      public

      [ Top ]

      TTable::getCaptionAlign

      getCaptionAlign( );

      Returns

      table caption alignment. Defaults to TTableCaptionAlign::NotSet.

      access

      public

      [ Top ]

      TTable::getCellPadding

      getCellPadding( );

      Returns

      the cellpadding for the table. Defaults to -1, meaning not set.

      access

      public

      [ Top ]

      TTable::getCellSpacing

      getCellSpacing( );

      Returns

      the cellspacing for the table. Defaults to -1, meaning not set.

      access

      public

      [ Top ]

      TTable::getGridLines

      getGridLines( );

      Returns

      the grid line setting of the table. Defaults to TTableGridLines::None.

      access

      public

      [ Top ]

      TTable::getHorizontalAlign

      getHorizontalAlign( );

      Returns

      the horizontal alignment of the table content. Defaults to THorizontalAlign::NotSet.

      access

      public

      [ Top ]

      TTable::getRows

      getRows( );

      Returns

      list of TTableRow controls

      access

      public

      [ Top ]

      TTable::getTagName

      getTagName( );

      Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

      Returns

      tag name for the table

      access

      protected

      [ Top ]

      TTable::renderBeginTag

      renderBeginTag( THtmlWriter $writer );

      Overrides TWebControl::renderBeginTag() (Renders the openning tag for the control (including attributes))

      Parameters

      $writer

      the writer used for the rendering purpose

      Remarks

      Renders the openning tag for the table control which will render table caption if present.

      access

      public

      [ Top ]

      TTable::renderContents

      renderContents( THtmlWriter $writer );

      Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

      Parameters

      $writer

      the writer used for the rendering purpose.

      Remarks

      Renders body contents of the table.

      access

      public

      [ Top ]

      TTable::setBackImageUrl

      setBackImageUrl( string $value );

      Parameters

      $value

      the URL

      Remarks

      Sets the URL of the background image for the table

      access

      public

      [ Top ]

      TTable::setCaption

      setCaption( string $value );

      Parameters

      $value

      table caption

      access

      public

      [ Top ]

      TTable::setCaptionAlign

      setCaptionAlign( TTableCaptionAlign $value );

      Parameters

      $value

      table caption alignment.

      access

      public

      [ Top ]

      TTable::setCellPadding

      setCellPadding( integer $value );

      Parameters

      $value

      the cellpadding for the table. Defaults to -1, meaning not set.

      access

      public

      [ Top ]

      TTable::setCellSpacing

      setCellSpacing( integer $value );

      Parameters

      $value

      the cellspacing for the table. Defaults to -1, meaning not set.

      access

      public

      [ Top ]

      TTable::setGridLines

      setGridLines( TTableGridLines $value );

      Parameters

      $value

      the grid line setting of the table

      access

      public

      [ Top ]

      TTable::setHorizontalAlign

      setHorizontalAlign( THorizontalAlign $value );

      Parameters

      $value

      the horizontal alignment of the table content.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:30 +0200 by phpDocumentor 1.4.3


Docs For Class TTableCaptionAlign

Class TTableCaptionAlign

[line 402]
TEnumerable
   |
   --TTableCaptionAlign
Location: /Web/UI/WebControls/TTable.php

Remarks

TTableCaptionAlign class.

TTableCaptionAlign defines the enumerable type for the possible alignments that a table caption can take.

The following enumerable values are defined:

  • NotSet: alignment not specified
  • Top: top aligned
  • Bottom: bottom aligned
  • Left: left aligned
  • Right: right aligned

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTable.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Bottom = 'Bottom'
  • Left = 'Left'
  • NotSet = 'NotSet'
  • Right = 'Right'
  • Top = 'Top'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Bottom = 'Bottom' [line 406]

  • Left = 'Left' [line 407]

  • NotSet = 'NotSet' [line 404]

  • Right = 'Right' [line 408]

  • Top = 'Top' [line 405]

Documentation generated on Mon, 25 Jun 2012 14:45:31 +0200 by phpDocumentor 1.4.3


Docs For Class TTableRowCollection

Class TTableRowCollection

[line 365]
TComponent
   |
   --TList
      |
      --TControlCollection
         |
         --TTableRowCollection
Location: /Web/UI/WebControls/TTable.php

Remarks

TTableRowCollection class.

TTableRowCollection is used to maintain a list of rows belong to a table.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTable.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControlCollection

  • TControlCollection::__construct()
    Constructor.
  • TControlCollection::clear()
    Overrides the parent implementation by invoking TControl::clearNamingContainer
  • TControlCollection::getOwner()
  • TControlCollection::insertAt()
    Inserts an item at the specified position.
  • TControlCollection::removeAt()
    Removes an item at the specified position.

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTableRowCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TControlCollection::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by performing additional operations for each newly added table row.

    throws

    TInvalidDataTypeException if the item to be inserted is not a TTableRow object.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:31 +0200 by phpDocumentor 1.4.3


Docs For Class TTableCell

Class TTableCell

[line 35]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableCell
Classes extended from TTableCell:
TActiveTableCell
TActiveTableCell class.
TTableHeaderCell
TTableHeaderCell class.

Location: /Web/UI/WebControls/TTableCell.php

Remarks

TTableCell class.

TTableCell displays a table cell on a Web page. Content of the table cell is specified by the Text property. If Text is empty, the body contents enclosed by the table cell component tag are rendered. Note, Text is not HTML-encoded when displayed. So make sure it does not contain dangerous characters.

The horizontal and vertical alignments of the contents in the cell are specified via HorizontalAlign and VerticalAlign properties, respectively.

The colspan and rowspan of the cell are specified via ColumnSpan and RowSpan properties. And the Wrap property indicates whether the contents in the cell should be wrapped.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableCell.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTableCell::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveTableCell::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control if the event handler for the onCellSelected event is set.
    TTableHeaderCell::addAttributesToRender()
    Adds attributes to renderer.

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    the renderer

    Remarks

    Adds attributes to renderer.

    access

    protected

    [ Top ]

    TTableCell::createStyle

    createStyle( );

    Overrides TWebControl::createStyle() (Creates a style object to be used by the control.)

    Returns

    control style to be used

    Remarks

    Creates a style object for the control.

    This method creates a TTableItemStyle to be used by the table cell.

    access

    protected

    [ Top ]

    TTableCell::getColumnSpan

    getColumnSpan( );

    Returns

    the columnspan for the table cell, 0 if not set.

    access

    public

    [ Top ]

    TTableCell::getData

    getData( );

    Returns

    the text content of the table cell.

    Remarks

    Returns the text content of the table cell.

    This method is required by IDataRenderer. It is the same as getText().

    see

    TTableCell::getText()

    since

    3.1.0

    access

    public

    [ Top ]

    TTableCell::getHorizontalAlign

    getHorizontalAlign( );

    Returns

    the horizontal alignment of the contents within the table item, defaults to 'NotSet'.

    access

    public

    [ Top ]

    TTableCell::getRowSpan

    getRowSpan( );

    Returns

    the rowspan for the table cell, 0 if not set.

    access

    public

    [ Top ]

    TTableCell::getTagName

    getTagName( );

    Overridden in child classes as:

    TTableHeaderCell::getTagName()

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name for the table cell

    access

    protected

    [ Top ]

    TTableCell::getText

    getText( );

    Returns

    the text content of the table cell.

    access

    public

    [ Top ]

    TTableCell::getVerticalAlign

    getVerticalAlign( );

    Returns

    the vertical alignment of the contents within the table item, defaults to 'NotSet'.

    access

    public

    [ Top ]

    TTableCell::getWrap

    getWrap( );

    Returns

    whether the text content wraps within a table cell. Defaults to true.

    access

    public

    [ Top ]

    TTableCell::renderContents

    renderContents( THtmlWriter $writer );

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    the writer used for the rendering purpose.

    Remarks

    Renders body contents of the table cell.

    access

    public

    [ Top ]

    TTableCell::setColumnSpan

    setColumnSpan( integer $value );

    Parameters

    $value

    the columnspan for the table cell, 0 if not set.

    Remarks

    Sets the columnspan for the table cell.

    access

    public

    [ Top ]

    TTableCell::setData

    setData( string $value );

    Parameters

    $value

    the text content of the table cell.

    Remarks

    Sets the text content of the table cell.

    This method is required by IDataRenderer. It is the same as setText().

    see

    TTableCell::setText()

    since

    3.1.0

    access

    public

    [ Top ]

    TTableCell::setHorizontalAlign

    setHorizontalAlign( string $value );

    Parameters

    $value

    the horizontal alignment

    Remarks

    Sets the horizontal alignment of the contents within the table item.

    Valid values include 'NotSet', 'Justify', 'Left', 'Right', 'Center'

    access

    public

    [ Top ]

    TTableCell::setRowSpan

    setRowSpan( integer $value );

    Parameters

    $value

    the rowspan for the table cell, 0 if not set.

    Remarks

    Sets the rowspan for the table cell.

    access

    public

    [ Top ]

    TTableCell::setText

    setText( string $value );

    Parameters

    $value

    the text content

    Remarks

    Sets the text content of the table cell.

    If the text content is empty, body content (child controls) of the cell will be rendered.

    access

    public

    [ Top ]

    TTableCell::setVerticalAlign

    setVerticalAlign( string $value );

    Parameters

    $value

    the horizontal alignment

    Remarks

    Sets the vertical alignment of the contents within the table item.

    Valid values include 'NotSet','Top','Bottom','Middle'

    access

    public

    [ Top ]

    TTableCell::setWrap

    setWrap( boolean $value );

    Parameters

    $value

    whether the text content wraps within a table cell.

    Remarks

    Sets the value indicating whether the text content wraps within a table cell.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:31 +0200 by phpDocumentor 1.4.3


Docs For Class TTableFooterRow

Class TTableFooterRow

[line 28]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableRow
               |
               --TTableFooterRow
Location: /Web/UI/WebControls/TTableFooterRow.php

Remarks

TTableFooterRow class.

TTableFooterRow displays a table footer row.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableFooterRow.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TTableRow

  • TTableRow::addParsedObject()
    Adds object parsed from template to the control.
  • TTableRow::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TTableRow::createStyle()
    Creates a style object for the control.
  • TTableRow::getCells()
  • TTableRow::getHorizontalAlign()
  • TTableRow::getTableSection()
  • TTableRow::getTagName()
  • TTableRow::getVerticalAlign()
  • TTableRow::renderContents()
    Renders body contents of the table row
  • TTableRow::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the table item.
  • TTableRow::setTableSection()
  • TTableRow::setVerticalAlign()
    Sets the vertical alignment of the contents within the table item.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTableFooterRow::getTableSection

    getTableSection( );

    Overrides TTableRow::getTableSection() (parent method not documented)

    Returns

    location of a row in a table. Always returns 'Footer'.

    access

    public

    [ Top ]

    TTableFooterRow::setTableSection

    setTableSection( string $value );

    Overrides TTableRow::setTableSection() (parent method not documented)

    Parameters

    $value

    location of a row in a table.

    throws

    TInvalidOperationException if this method is invoked

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:32 +0200 by phpDocumentor 1.4.3


Docs For Class TTableHeaderCell

Class TTableHeaderCell

[line 29]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableCell
               |
               --TTableHeaderCell
Location: /Web/UI/WebControls/TTableHeaderCell.php

Remarks

TTableHeaderCell class.

TTableHeaderCell displays a table header cell on a Web page.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableHeaderCell.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TTableCell

  • TTableCell::addAttributesToRender()
    Adds attributes to renderer.
  • TTableCell::createStyle()
    Creates a style object for the control.
  • TTableCell::getColumnSpan()
  • TTableCell::getData()
    Returns the text content of the table cell.
  • TTableCell::getHorizontalAlign()
  • TTableCell::getRowSpan()
  • TTableCell::getTagName()
  • TTableCell::getText()
  • TTableCell::getVerticalAlign()
  • TTableCell::getWrap()
  • TTableCell::renderContents()
    Renders body contents of the table cell.
  • TTableCell::setColumnSpan()
    Sets the columnspan for the table cell.
  • TTableCell::setData()
    Sets the text content of the table cell.
  • TTableCell::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the table item.
  • TTableCell::setRowSpan()
    Sets the rowspan for the table cell.
  • TTableCell::setText()
    Sets the text content of the table cell.
  • TTableCell::setVerticalAlign()
    Sets the vertical alignment of the contents within the table item.
  • TTableCell::setWrap()
    Sets the value indicating whether the text content wraps within a table cell.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTableHeaderCell::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overrides TTableCell::addAttributesToRender() (Adds attributes to renderer.)

    Parameters

    $writer

    the renderer

    Remarks

    Adds attributes to renderer.

    access

    protected

    [ Top ]

    TTableHeaderCell::getAbbreviatedText

    getAbbreviatedText( );

    Returns

    the abbr attribute of the HTML th element

    access

    public

    [ Top ]

    TTableHeaderCell::getCategoryText

    getCategoryText( );

    Returns

    the axis attribute of the HTML th element

    access

    public

    [ Top ]

    TTableHeaderCell::getScope

    getScope( );

    Returns

    the scope of the cells that the header cell applies to. Defaults to TTableHeaderScope::NotSet.

    access

    public

    [ Top ]

    TTableHeaderCell::getTagName

    getTagName( );

    Overrides TTableCell::getTagName() (parent method not documented)

    Returns

    tag name for the table header cell

    access

    protected

    [ Top ]

    TTableHeaderCell::setAbbreviatedText

    setAbbreviatedText( string $value );

    Parameters

    $value

    the abbr attribute of the HTML th element

    access

    public

    [ Top ]

    TTableHeaderCell::setCategoryText

    setCategoryText( string $value );

    Parameters

    $value

    the axis attribute of the HTML th element

    access

    public

    [ Top ]

    TTableHeaderCell::setScope

    setScope( TTableHeaderScope $value );

    Parameters

    $value

    the scope of the cells that the header cell applies to.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:33 +0200 by phpDocumentor 1.4.3


Docs For Class TTableHeaderScope

Class TTableHeaderScope

[line 118]
TEnumerable
   |
   --TTableHeaderScope
Location: /Web/UI/WebControls/TTableHeaderCell.php

Remarks

TTableHeaderScope class.

TTableHeaderScope defines the enumerable type for the possible table scopes that a table header is associated with.

The following enumerable values are defined:

  • NotSet: the scope is not specified
  • Row: the scope is row-wise
  • Column: the scope is column-wise

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableHeaderCell.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Column = 'Column'
  • NotSet = 'NotSet'
  • Row = 'Row'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Column = 'Column' [line 122]

  • NotSet = 'NotSet' [line 120]

  • Row = 'Row' [line 121]

Documentation generated on Mon, 25 Jun 2012 14:45:34 +0200 by phpDocumentor 1.4.3


Docs For Class TTableHeaderRow

Class TTableHeaderRow

[line 28]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableRow
               |
               --TTableHeaderRow
Location: /Web/UI/WebControls/TTableHeaderRow.php

Remarks

TTableHeaderRow class.

TTableHeaderRow displays a table header row.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableHeaderRow.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TTableRow

  • TTableRow::addParsedObject()
    Adds object parsed from template to the control.
  • TTableRow::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TTableRow::createStyle()
    Creates a style object for the control.
  • TTableRow::getCells()
  • TTableRow::getHorizontalAlign()
  • TTableRow::getTableSection()
  • TTableRow::getTagName()
  • TTableRow::getVerticalAlign()
  • TTableRow::renderContents()
    Renders body contents of the table row
  • TTableRow::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the table item.
  • TTableRow::setTableSection()
  • TTableRow::setVerticalAlign()
    Sets the vertical alignment of the contents within the table item.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTableHeaderRow::getTableSection

    getTableSection( );

    Overrides TTableRow::getTableSection() (parent method not documented)

    Returns

    location of a row in a table. Always returns 'Header'.

    access

    public

    [ Top ]

    TTableHeaderRow::setTableSection

    setTableSection( string $value );

    Overrides TTableRow::setTableSection() (parent method not documented)

    Parameters

    $value

    location of a row in a table.

    throws

    TInvalidOperationException if this method is invoked

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:34 +0200 by phpDocumentor 1.4.3


Docs For Class TTableCellCollection

Class TTableCellCollection

[line 167]
TComponent
   |
   --TList
      |
      --TControlCollection
         |
         --TTableCellCollection
Location: /Web/UI/WebControls/TTableRow.php

Remarks

TTableCellCollection class.

TTableCellCollection is used to maintain a list of cells belong to a table row.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableRow.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControlCollection

  • TControlCollection::__construct()
    Constructor.
  • TControlCollection::clear()
    Overrides the parent implementation by invoking TControl::clearNamingContainer
  • TControlCollection::getOwner()
  • TControlCollection::insertAt()
    Inserts an item at the specified position.
  • TControlCollection::removeAt()
    Removes an item at the specified position.

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTableCellCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TControlCollection::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by performing additional operations for each newly added table cell.

    throws

    TInvalidDataTypeException if the item to be inserted is not a TTableCell object.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:34 +0200 by phpDocumentor 1.4.3


Docs For Class TTableRow

Class TTableRow

[line 31]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableRow
Classes extended from TTableRow:
TActiveTableRow
TActiveTableRow class.
TDataGridItem
TDataGridItem class
TTableFooterRow
TTableFooterRow class.
TTableHeaderRow
TTableHeaderRow class.

Location: /Web/UI/WebControls/TTableRow.php

Remarks

TTableRow class.

TTableRow displays a table row. The table cells in the row can be accessed via Cells. The horizontal and vertical alignments of the row are specified via HorizontalAlign and VerticalAlign properties, respectively.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableRow.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTableRow::addParsedObject

    addParsedObject( mixed $object );

    Overrides TControl::addParsedObject() (Adds the object instantiated on a template to the child control collection.)

    Parameters

    $object

    object parsed from template

    Remarks

    Adds object parsed from template to the control.

    This method adds only TTableCell objects into the Cells collection. All other objects are ignored.

    access

    public

    [ Top ]

    TTableRow::createControlCollection

    createControlCollection( );

    Overrides TControl::createControlCollection() (Creates a control collection object that is to be used to hold child controls)

    Returns

    control collection

    Remarks

    Creates a control collection object that is to be used to hold child controls

    see

    TControl::getControls()

    access

    protected

    [ Top ]

    TTableRow::createStyle

    createStyle( );

    Overrides TWebControl::createStyle() (Creates a style object to be used by the control.)

    Returns

    control style to be used

    Remarks

    Creates a style object for the control.

    This method creates a TTableItemStyle to be used by the table row.

    access

    protected

    [ Top ]

    TTableRow::getCells

    getCells( );

    Returns

    list of TTableCell controls

    access

    public

    [ Top ]

    TTableRow::getHorizontalAlign

    getHorizontalAlign( );

    Returns

    the horizontal alignment of the contents within the table item, defaults to 'NotSet'.

    access

    public

    [ Top ]

    TTableRow::getTableSection

    getTableSection( );

    Overridden in child classes as:

    TTableFooterRow::getTableSection()
    TTableHeaderRow::getTableSection()

    Returns

    location of a row in a table. Defaults to TTableRowSection::Body.

    access

    public

    [ Top ]

    TTableRow::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name for the table

    access

    protected

    [ Top ]

    TTableRow::getVerticalAlign

    getVerticalAlign( );

    Returns

    the vertical alignment of the contents within the table item, defaults to 'NotSet'.

    access

    public

    [ Top ]

    TTableRow::renderContents

    renderContents( THtmlWriter $writer );

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders body contents of the table row

    access

    public

    [ Top ]

    TTableRow::setHorizontalAlign

    setHorizontalAlign( string $value );

    Parameters

    $value

    the horizontal alignment

    Remarks

    Sets the horizontal alignment of the contents within the table item.

    Valid values include 'NotSet', 'Justify', 'Left', 'Right', 'Center'

    access

    public

    [ Top ]

    TTableRow::setTableSection

    setTableSection( TTableRowSection $value );

    Overridden in child classes as:

    TTableFooterRow::setTableSection()
    TTableHeaderRow::setTableSection()

    Parameters

    $value

    location of a row in a table.

    access

    public

    [ Top ]

    TTableRow::setVerticalAlign

    setVerticalAlign( string $value );

    Parameters

    $value

    the horizontal alignment

    Remarks

    Sets the vertical alignment of the contents within the table item.

    Valid values include 'NotSet','Top','Bottom','Middle'

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:35 +0200 by phpDocumentor 1.4.3


Docs For Class TTableRowSection

Class TTableRowSection

[line 202]
TEnumerable
   |
   --TTableRowSection
Location: /Web/UI/WebControls/TTableRow.php

Remarks

TTableRowSection class.

TTableRowSection defines the enumerable type for the possible table sections that a TTableRow can be within.

The following enumerable values are defined:

  • Header: in table header
  • Body: in table body
  • Footer: in table footer

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTableRow.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Body = 'Body'
  • Footer = 'Footer'
  • Header = 'Header'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Body = 'Body' [line 205]

  • Footer = 'Footer' [line 206]

  • Header = 'Header' [line 204]

Documentation generated on Mon, 25 Jun 2012 14:45:35 +0200 by phpDocumentor 1.4.3


Docs For Class TTabPanel

Class TTabPanel

[line 61]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTabPanel
Location: /Web/UI/WebControls/TTabPanel.php

Remarks

Class TTabPanel.

TTabPanel displays a tabbed panel. Users can click on the tab bar to switching among different tab views. Each tab view is an independent panel that can contain arbitrary content.

If the AutoSwitch property is enabled, the user will be able to switch the active view to another one just hovering its corresponding tab caption.

A TTabPanel control consists of one or several TTabView controls representing the possible tab views. At any time, only one tab view is visible (active), which is specified by any of the following properties:

  • ActiveViewIndex - the zero-based integer index of the view in the view collection.
  • ActiveViewID - the text ID of the visible view.
  • ActiveView - the visible view instance.
If both ActiveViewIndex and ActiveViewID are set, the latter takes precedence.

TTabPanel uses CSS to specify the appearance of the tab bar and panel. By default, an embedded CSS file will be published which contains the default CSS for TTabPanel. You may also use your own CSS file by specifying the CssUrl property. The following properties specify the CSS classes used for elements in a TTabPanel:

  • CssClass - the CSS class name for the outer-most div element (defaults to 'tab-panel');
  • TabCssClass - the CSS class name for nonactive tab div elements (defaults to 'tab-normal');
  • ActiveTabCssClass - the CSS class name for the active tab div element (defaults to 'tab-active');
  • ViewCssClass - the CSS class for the div element enclosing view content (defaults to 'tab-view');
To use TTabPanel, write a template like following:
  •  <com:TTabPanel>
    •

  •    <com:TTabView Caption="View 1">
    •

  •      content for view 1
    •

  •    </com:TTabView>
    •

  •    <com:TTabView Caption="View 2">
    •

  •      content for view 2
    •

  •    </com:TTabView>
    •

  •    <com:TTabView Caption="View 3">
    •

  •      content for view 3
    •

  •    </com:TTabView>
    •

  •  </com:TTabPanel>
    •

    author

    Tomasz Wolny <tomasz.wolny@polecam.to.pl> and Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TTabPanel.php 3161 2012-06-04 08:47:39Z ctrlaltca $

    since

    3.1.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TTabPanel::activateView

      activateView( TTabView $view );

      Parameters

      $view

      the view to be activated. If null, all views will be deactivated.

      Remarks

      Activates the specified view.

      If there is any other view currently active, it will be deactivated.

      access

      protected

      [ Top ]

      TTabPanel::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

      Parameters

      $writer

      the renderer

      Remarks

      Adds attributes to renderer.

      access

      protected

      [ Top ]

      TTabPanel::addParsedObject

      addParsedObject( mixed $object );

      Overrides TControl::addParsedObject() (Adds the object instantiated on a template to the child control collection.)

      Parameters

      $object

      object parsed from template

      Remarks

      Adds object parsed from template to the control.

      This method adds only TTabView objects into the Views collection. All other objects are ignored.

      access

      public

      [ Top ]

      TTabPanel::createControlCollection

      createControlCollection( );

      Overrides TControl::createControlCollection() (Creates a control collection object that is to be used to hold child controls)

      Returns

      control collection

      Remarks

      Creates a control collection object that is to be used to hold child controls

      access

      protected

      [ Top ]

      TTabPanel::getActiveTabCssClass

      getActiveTabCssClass( );

      Returns

      CSS class for the active tab. Defaults to 'tab-active'.

      access

      public

      [ Top ]

      TTabPanel::getActiveTabStyle

      getActiveTabStyle( );

      Returns

      the style for the active tab div

      access

      public

      [ Top ]

      TTabPanel::getActiveView

      getActiveView( );

      Returns

      the currently active view, null if no active view

      Remarks

      Returns the currently active view.

      This method will examin the ActiveViewID, ActiveViewIndex and Views collection to determine which view is currently active. It will update ActiveViewID and ActiveViewIndex accordingly.

      throws

      TInvalidDataValueException if the active view ID or index set previously is invalid

      access

      public

      [ Top ]

      TTabPanel::getActiveViewID

      getActiveViewID( );

      Returns

      The ID of the active tab view. Defaults to '', meaning not set.

      Remarks

      Returns the ID of the active tab view.

      Note, this property may not return the correct ID. To ensure the correctness, call getActiveView() first.

      access

      public

      [ Top ]

      TTabPanel::getActiveViewIndex

      getActiveViewIndex( );

      Returns

      the zero-based index of the active tab view. If -1, it means no active tab view. Default is 0 (the first view is active).

      Remarks

      Returns the index of the active tab view.

      Note, this property may not return the correct index. To ensure the correctness, call getActiveView() first.

      access

      public

      [ Top ]

      TTabPanel::getAutoSwitch

      getAutoSwitch( );

      Returns

      status of automatic tab switch on hover

      access

      public

      [ Top ]

      TTabPanel::getClientClassName

      getClientClassName( );

      Returns

      the javascript class name

      Remarks

      Gets the name of the javascript class responsible for performing postback for this control.

      This method overrides the parent implementation.

      access

      protected

      [ Top ]

      TTabPanel::getClientOptions

      getClientOptions( );

      Returns

      the options for JavaScript

      access

      protected

      [ Top ]

      TTabPanel::getCssClass

      getCssClass( );

      Overrides TWebControl::getCssClass() (parent method not documented)

      Returns

      CSS class for the whole tab control div. Defaults to 'tab-panel'.

      access

      public

      [ Top ]

      TTabPanel::getCssUrl

      getCssUrl( );

      Returns

      URL for the CSS file including all relevant CSS class definitions. Defaults to ''.

      access

      public

      [ Top ]

      TTabPanel::getDataChanged

      getDataChanged( );

      Returns

      whether postback has caused the control data change. False if the page is not in postback mode.

      Remarks

      Returns a value indicating whether postback has caused the control data change.

      This method is required by the IPostBackDataHandler interface.

      access

      public

      [ Top ]

      TTabPanel::getTabCssClass

      getTabCssClass( );

      Returns

      CSS class for non-active tabs. Defaults to 'tab-normal'.

      access

      public

      [ Top ]

      TTabPanel::getTabStyle

      getTabStyle( );

      Returns

      the style for all the inactive tab div

      access

      public

      [ Top ]

      TTabPanel::getTagName

      getTagName( );

      Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

      Returns

      tag name for the control

      access

      protected

      [ Top ]

      TTabPanel::getViewCssClass

      getViewCssClass( );

      Returns

      CSS class for the currently displayed view div. Defaults to 'tab-view'.

      access

      public

      [ Top ]

      TTabPanel::getViews

      getViews( );

      Returns

      list of TTabView controls

      access

      public

      [ Top ]

      TTabPanel::getViewStyle

      getViewStyle( );

      Returns

      the style for all the view div

      access

      public

      [ Top ]

      TTabPanel::loadPostData

      loadPostData( string $key, array $values );

      Parameters

      $key

      the key that can be used to retrieve data from the input data collection

      $values

      the input data collection

      Returns

      whether the data of the control has been changed

      Remarks

      Loads user input data.

      This method is primarly used by framework developers.

      access

      public

      [ Top ]

      TTabPanel::onPreRender

      onPreRender( mixed $param );

      Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

      Parameters

      $param

      event parameter

      Remarks

      Registers CSS and JS.

      This method is invoked right before the control rendering, if the control is visible.

      access

      public

      [ Top ]

      TTabPanel::raisePostDataChangedEvent

      raisePostDataChangedEvent( );

      Remarks

      Raises postdata changed event.

      This method is required by IPostBackDataHandler interface. It is invoked by the framework when ActiveViewIndex property is changed on postback. This method is primarly used by framework developers.

      access

      public

      [ Top ]

      TTabPanel::registerClientScript

      registerClientScript( );

      Remarks

      Registers the relevant JavaScript.

      access

      protected

      [ Top ]

      TTabPanel::registerStyleSheet

      registerStyleSheet( );

      Remarks

      Registers the CSS relevant to the TTabControl.

      It will register the CSS file specified by CssUrl. If that is not set, it will use the default CSS.

      access

      protected

      [ Top ]

      TTabPanel::render

      render( $writer );

      Overrides TWebControl::render() (Renders the control.)

      Parameters

      $writer

      access

      public

      [ Top ]

      TTabPanel::renderContents

      renderContents( THtmlWriter $writer );

      Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

      Parameters

      $writer

      the writer used for the rendering purpose.

      Remarks

      Renders body contents of the tab control.

      access

      public

      [ Top ]

      TTabPanel::setActiveTabCssClass

      setActiveTabCssClass( string $value );

      Parameters

      $value

      CSS class for the active tab.

      access

      public

      [ Top ]

      TTabPanel::setActiveView

      setActiveView( TTabView $view );

      Parameters

      $view

      the view to be activated

      throws

      TInvalidOperationException if the view is not in the view collection

      access

      public

      [ Top ]

      TTabPanel::setActiveViewID

      setActiveViewID( string $value );

      Parameters

      $value

      The ID of the active tab view.

      access

      public

      [ Top ]

      TTabPanel::setActiveViewIndex

      setActiveViewIndex( integer $value );

      Parameters

      $value

      the zero-based index of the current view in the view collection. -1 if no active view.

      throws

      TInvalidDataValueException if the view index is invalid

      access

      public

      [ Top ]

      TTabPanel::setAutoSwitch

      setAutoSwitch( bool $value );

      Parameters

      $value

      whether to enable automatic tab switch on hover

      access

      public

      [ Top ]

      TTabPanel::setCssUrl

      setCssUrl( string $value );

      Parameters

      $value

      URL for the CSS file including all relevant CSS class definitions.

      access

      public

      [ Top ]

      TTabPanel::setTabCssClass

      setTabCssClass( string $value );

      Parameters

      $value

      CSS class for non-active tabs.

      access

      public

      [ Top ]

      TTabPanel::setViewCssClass

      setViewCssClass( string $value );

      Parameters

      $value

      CSS class for the currently displayed view div.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:35 +0200 by phpDocumentor 1.4.3


Docs For Class TTabView

Class TTabView

[line 547]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTabView
Location: /Web/UI/WebControls/TTabPanel.php

Remarks

TTabView class.

TTabView represents a view in a TTabPanel control.

The content in a TTabView can be specified by the Text property or its child controls. In template syntax, the latter means enclosing the content within the TTabView component element. If both are set, Text takes precedence.

Each TTabView is associated with a tab in the tab bar of the TTabPanel control. The tab caption is specified by Caption. If NavigateUrl is set, the tab will contain a hyperlink pointing to the specified URL. In this case, clicking on the tab will redirect the browser to the specified URL.

TTabView may be toggled between visible (active) and invisible (inactive) by setting the Active property.

author

Tomasz Wolny <tomasz.wolny@polecam.to.pl> and Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTabPanel.php 3161 2012-06-04 08:47:39Z ctrlaltca $

since

3.1.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTabView::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    the renderer

    Remarks

    Adds attributes to renderer.

    access

    protected

    [ Top ]

    TTabView::getActive

    getActive( );

    Returns

    whether this tab view is active. Defaults to false.

    access

    public

    [ Top ]

    TTabView::getCaption

    getCaption( );

    Returns

    the caption displayed on this tab. Defaults to ''.

    access

    public

    [ Top ]

    TTabView::getNavigateUrl

    getNavigateUrl( );

    Returns

    the URL of the target page. Defaults to ''.

    access

    public

    [ Top ]

    TTabView::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name for the view element

    access

    protected

    [ Top ]

    TTabView::getText

    getText( );

    Returns

    the text content displayed on this view. Defaults to ''.

    access

    public

    [ Top ]

    TTabView::renderContents

    renderContents( THtmlWriter $writer );

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    the writer used for the rendering purpose.

    Remarks

    Renders body contents of the tab view.

    access

    public

    [ Top ]

    TTabView::renderTab

    renderTab( THtmlWriter $writer );

    Parameters

    $writer

    the writer for rendering purpose.

    Remarks

    Renders the tab associated with the tab view.

    access

    public

    [ Top ]

    TTabView::renderTabContent

    renderTabContent( THtmlWriter $writer );

    Parameters

    $writer

    the HTML writer

    Remarks

    Renders the content in the tab.

    By default, a hyperlink is displayed.

    access

    protected

    [ Top ]

    TTabView::setActive

    setActive( boolean $value );

    Parameters

    $value

    whether this tab view is active.

    access

    public

    [ Top ]

    TTabView::setCaption

    setCaption( string $value );

    Parameters

    $value

    the caption displayed on this tab

    access

    public

    [ Top ]

    TTabView::setNavigateUrl

    setNavigateUrl( string $value );

    Parameters

    $value

    the URL of the target page.

    Remarks

    Sets the URL of the target page.

    If not empty, clicking on this tab will redirect the browser to the specified URL.

    access

    public

    [ Top ]

    TTabView::setText

    setText( string $value );

    Parameters

    $value

    the text content displayed on this view

    Remarks

    Sets the text content to be displayed on this view.

    If this is not empty, the child content of the view will be ignored.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:36 +0200 by phpDocumentor 1.4.3


Docs For Class TTabViewCollection

Class TTabViewCollection

[line 701]
TComponent
   |
   --TList
      |
      --TControlCollection
         |
         --TTabViewCollection
Location: /Web/UI/WebControls/TTabPanel.php

Remarks

TTabViewCollection class.

TTabViewCollection is used to maintain a list of views belong to a TTabPanel.

author

Tomasz Wolny <tomasz.wolny@polecam.to.pl> and Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTabPanel.php 3161 2012-06-04 08:47:39Z ctrlaltca $

since

3.1.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControlCollection

  • TControlCollection::__construct()
    Constructor.
  • TControlCollection::clear()
    Overrides the parent implementation by invoking TControl::clearNamingContainer
  • TControlCollection::getOwner()
  • TControlCollection::insertAt()
    Inserts an item at the specified position.
  • TControlCollection::removeAt()
    Removes an item at the specified position.

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTabViewCollection::findIndexByID

    findIndexByID( string $id );

    Parameters

    $id

    the explicit ID of the tab view to be looked for

    Returns

    the index of the tab view found, -1 if not found.

    Remarks

    Finds the index of the tab view whose ID is the same as the one being looked for.

    access

    public

    [ Top ]

    TTabViewCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TControlCollection::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by performing sanity check on the type of new item.

    throws

    TInvalidDataTypeException if the item to be inserted is not a TTabView object.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:36 +0200 by phpDocumentor 1.4.3


Docs For Class TTemplateColumn

Class TTemplateColumn

[line 41]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TTemplateColumn
Classes extended from TTemplateColumn:
TActiveTemplateColumn
TActiveTemplateColumn class

Location: /Web/UI/WebControls/TTemplateColumn.php

Remarks

TTemplateColumn class

TTemplateColumn customizes the layout of controls in the column with templates. In particular, you can specify ItemTemplate, EditItemTemplate, HeaderTemplate and FooterTemplate to customize specific type of cells in the column.

Since v3.1.0, TTemplateColumn has introduced two new properties ItemRenderer and EditItemRenderer which can be used to specify the layout of the datagrid cells in browsing and editing mode. A renderer refers to a control class that is to be instantiated as a control. For more details, see TRepeater and TDataList.

When a renderer and a template are both defined for a type of item, the former takes precedence.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTemplateColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDataGridColumn

  • TDataGridColumn::formatDataValue()
    Formats the text value according to a format string.
  • TDataGridColumn::getAllowSorting()
    Returns a value indicating whether this column allows sorting.
  • TDataGridColumn::getDataFieldValue()
    Fetches the value of the data at the specified field.
  • TDataGridColumn::getEnableCellGrouping()
  • TDataGridColumn::getFooterRenderer()
  • TDataGridColumn::getFooterStyle()
  • TDataGridColumn::getFooterText()
  • TDataGridColumn::getHeaderImageUrl()
  • TDataGridColumn::getHeaderRenderer()
  • TDataGridColumn::getHeaderStyle()
  • TDataGridColumn::getHeaderText()
  • TDataGridColumn::getID()
  • TDataGridColumn::getItemStyle()
  • TDataGridColumn::getOwner()
  • TDataGridColumn::getSortExpression()
  • TDataGridColumn::getViewState()
    Returns a viewstate value.
  • TDataGridColumn::getVisible()
  • TDataGridColumn::initialize()
    Initializes the column.
  • TDataGridColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TDataGridColumn::initializeFooterCell()
    Initializes the footer cell.
  • TDataGridColumn::initializeHeaderCell()
    Initializes the header cell.
  • TDataGridColumn::loadState()
    Loads persistent state values.
  • TDataGridColumn::saveState()
    Saves persistent state values.
  • TDataGridColumn::setEnableCellGrouping()
  • TDataGridColumn::setFooterRenderer()
    Sets the column footer cell renderer class.
  • TDataGridColumn::setFooterText()
  • TDataGridColumn::setHeaderImageUrl()
  • TDataGridColumn::setHeaderRenderer()
    Sets the column header cell renderer class.
  • TDataGridColumn::setHeaderText()
  • TDataGridColumn::setID()
    Sets the ID of the column.
  • TDataGridColumn::setOwner()
  • TDataGridColumn::setSortExpression()
  • TDataGridColumn::setViewState()
    Sets a viewstate value.
  • TDataGridColumn::setVisible()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTemplateColumn::dataBindColumn

    dataBindColumn( $sender, $param );

    Parameters

    $sender

    $param

    Remarks

    Databinds a cell in the column.

    This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

    access

    public

    [ Top ]

    TTemplateColumn::getEditItemRenderer

    getEditItemRenderer( );

    Returns

    the class name for the edit item cell renderer. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TTemplateColumn::getEditItemTemplate

    getEditItemTemplate( );

    Returns

    the edit item template

    access

    public

    [ Top ]

    TTemplateColumn::getFooterTemplate

    getFooterTemplate( );

    Returns

    the footer template

    access

    public

    [ Top ]

    TTemplateColumn::getHeaderTemplate

    getHeaderTemplate( );

    Returns

    the header template

    access

    public

    [ Top ]

    TTemplateColumn::getItemRenderer

    getItemRenderer( );

    Returns

    the class name for the item cell renderer. Defaults to empty, meaning not set.

    since

    3.1.0

    access

    public

    [ Top ]

    TTemplateColumn::getItemTemplate

    getItemTemplate( );

    Returns

    the item template

    access

    public

    [ Top ]

    TTemplateColumn::initializeCell

    initializeCell( TTableCell $cell, integer $columnIndex, string $itemType );

    Overrides TDataGridColumn::initializeCell() (Initializes the specified cell to its initial values.)

    Parameters

    $cell

    the cell to be initialized.

    $columnIndex

    the index to the Columns property that the cell resides in.

    $itemType

    the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)

    Remarks

    Initializes the specified cell to its initial values.

    This method overrides the parent implementation. It initializes the cell based on different templates (ItemTemplate, EditItemTemplate, HeaderTemplate, FooterTemplate).

    access

    public

    [ Top ]

    TTemplateColumn::setEditItemRenderer

    setEditItemRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the edit item cell renderer class.

    If not empty, the class will be used to instantiate as a child control in the item cell that is in edit mode.

    If the class implements IDataRenderer, the Data property will be set as the row of the data associated with the datagrid item that this cell resides in.

    since

    3.1.0

    access

    public

    [ Top ]

    TTemplateColumn::setEditItemTemplate

    setEditItemTemplate( ITemplate $value );

    Parameters

    $value

    the edit item template

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TTemplateColumn::setFooterTemplate

    setFooterTemplate( ITemplate $value );

    Parameters

    $value

    the footer template

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TTemplateColumn::setHeaderTemplate

    setHeaderTemplate( ITemplate $value );

    Parameters

    $value

    the header template.

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

    TTemplateColumn::setItemRenderer

    setItemRenderer( string $value );

    Parameters

    $value

    the renderer class name in namespace format.

    Remarks

    Sets the item cell renderer class.

    If not empty, the class will be used to instantiate as a child control in the item cells of the column.

    If the class implements IDataRenderer, the Data property will be set as the row of the data associated with the datagrid item that this cell resides in.

    since

    3.1.0

    access

    public

    [ Top ]

    TTemplateColumn::setItemTemplate

    setItemTemplate( ITemplate $value );

    Parameters

    $value

    the item template

    throws

    TInvalidDataTypeException if the input is not an ITemplate or not null.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:37 +0200 by phpDocumentor 1.4.3


Docs For Class TTextBox

Class TTextBox

[line 51]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
Classes extended from TTextBox:
TActiveTextBox
TActiveTextBox class.
TColorPicker
TColorPicker class.
TDatePicker
TDatePicker class.
THtmlArea
THtmlArea class

Location: /Web/UI/WebControls/TTextBox.php

Remarks

TTextBox class

TTextBox displays a text box on the Web page for user input. The text displayed in the TTextBox control is determined by the Text property. You can create a SingleLine, a MultiLine, or a Password text box by setting the TextMode property. If the TTextBox control is a multiline text box, the number of rows it displays is determined by the Rows property, and the Wrap property can be used to determine whether to wrap the text in the component.

To specify the display width of the text box, in characters, set the Columns property. To prevent the text displayed in the component from being modified, set the ReadOnly property to true. If you want to limit the user input to a specified number of characters, set the MaxLength property. To use AutoComplete feature, set the AutoCompleteType property.

If AutoPostBack is set true, updating the text box and then changing the focus out of it will cause postback action. And if CausesValidation is true, validation will also be processed, which can be further restricted within a ValidationGroup.

WARNING: Be careful if you want to display the text collected via TTextBox. Malicious cross-site script may be injected in. You may use SafeText to prevent this problem.

NOTE: If you set Wrap to false or use AutoCompleteType, the generated HTML output for the textbox will not be XHTML-compatible. Currently, no alternatives are available.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTextBox.php 3137 2012-05-10 21:09:10Z ctrlaltca $

since

3.0

Class Variable Summary

Class Constant Summary

  • DEFAULT_COLUMNS = 20
    Default number of columns (for MultiLine text box)
  • DEFAULT_ROWS = 4
    Default number of rows (for MultiLine text box)

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTextBox::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveTextBox::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TInPlaceTextBox::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TDatePicker::addAttributesToRender()
    Add the client id to the input textbox, and register the client scripts.
    THtmlArea::addAttributesToRender()
    Adds attribute name-value pairs to renderer.

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attribute name-value pairs to renderer.

    This method overrides the parent implementation with additional textbox specific attributes.

    access

    protected

    [ Top ]

    TTextBox::getAutoCompleteType

    getAutoCompleteType( );

    Returns

    the AutoComplete type of the textbox

    access

    public

    [ Top ]

    TTextBox::getAutoPostBack

    getAutoPostBack( );

    Overridden in child classes as:

    TActiveDatePicker::getAutoPostBack()
    THtmlArea::getAutoPostBack()

    Returns

    a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. Defaults to false.

    access

    public

    [ Top ]

    TTextBox::getAutoTrim

    getAutoTrim( );

    Returns

    a value indicating whether the input text should be trimmed spaces. Defaults to false.

    access

    public

    [ Top ]

    TTextBox::getCausesValidation

    getCausesValidation( );

    Returns

    whether postback event trigger by this text box will cause input validation, default is true.

    access

    public

    [ Top ]

    TTextBox::getClientClassName

    getClientClassName( );

    Overridden in child classes as:

    TActiveTextBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    TAutoComplete::getClientClassName()
    TInPlaceTextBox::getClientClassName()
    TColorPicker::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    THtmlArea::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TTextBox::getColumns

    getColumns( );

    Returns

    the display width of the text box in characters, default is 0 meaning not set.

    access

    public

    [ Top ]

    TTextBox::getData

    getData( );

    Overridden in child classes as:

    TDatePicker::getData()
    Returns the timestamp selected by the user.

    Returns

    the text content of the TTextBox control.

    Remarks

    Returns the text content of the TTextBox control.

    This method is required by IDataRenderer. It is the same as getText().

    see

    TTextBox::getText()

    since

    3.1.0

    access

    public

    [ Top ]

    TTextBox::getDataChanged

    getDataChanged( );

    Returns

    whether postback has caused the control data change. False if the page is not in postback mode.

    Remarks

    Returns a value indicating whether postback has caused the control data change.

    This method is required by the IPostBackDataHandler interface.

    access

    public

    [ Top ]

    TTextBox::getEnableClientScript

    getEnableClientScript( );

    Returns

    whether to render javascript.

    access

    public

    [ Top ]

    TTextBox::getIsValid

    getIsValid( );

    Returns

    wether this control validated successfully.

    Remarks

    Returns true if this control validated successfully.

    Defaults to true.

    access

    public

    [ Top ]

    TTextBox::getMaxLength

    getMaxLength( );

    Returns

    the maximum number of characters allowed in the text box, default is 0 meaning not set.

    access

    public

    [ Top ]

    TTextBox::getPersistPassword

    getPersistPassword( );

    Returns

    whether password should be displayed in the textbox during postback. Defaults to false. This property only applies when TextMode='Password'.

    access

    public

    [ Top ]

    TTextBox::getPostBackOptions

    getPostBackOptions( );

    Overridden in child classes as:

    TAutoComplete::getPostBackOptions()
    TInPlaceTextBox::getPostBackOptions()
    TColorPicker::getPostBackOptions()
    Get javascript color picker options.

    Remarks

    Gets the post back options for this textbox.

    access

    protected

    [ Top ]

    TTextBox::getReadOnly

    getReadOnly( );

    Returns

    whether the textbox is read only, default is false.

    access

    public

    [ Top ]

    TTextBox::getRows

    getRows( );

    Returns

    the number of rows displayed in a multiline text box, default is 4

    access

    public

    [ Top ]

    TTextBox::getSafeText

    getSafeText( );

    Returns

    safe text content with javascript stripped off

    access

    public

    [ Top ]

    TTextBox::getSafeTextParser

    getSafeTextParser( );

    Returns

    safe text parser

    access

    protected

    [ Top ]

    TTextBox::getTagName

    getTagName( );

    Overridden in child classes as:

    TInPlaceTextBox::getTagName()

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name of the textbox

    access

    protected

    [ Top ]

    TTextBox::getText

    getText( );

    Returns

    the text content of the TTextBox control.

    access

    public

    [ Top ]

    TTextBox::getTextMode

    getTextMode( );

    Overridden in child classes as:

    THtmlArea::getTextMode()
    Overrides the parent implementation.

    Returns

    the behavior mode of the TTextBox component. Defaults to TTextBoxMode::SingleLine.

    access

    public

    [ Top ]

    TTextBox::getValidationGroup

    getValidationGroup( );

    Returns

    the group of validators which the text box causes validation upon postback

    access

    public

    [ Top ]

    TTextBox::getValidationPropertyValue

    getValidationPropertyValue( );

    Overridden in child classes as:

    TDatePicker::getValidationPropertyValue()
    Returns the value to be validated.

    Returns

    the value of the property to be validated.

    Remarks

    Returns the value to be validated.

    This methid is required by IValidatable interface.

    access

    public

    [ Top ]

    TTextBox::getWrap

    getWrap( );

    Returns

    whether the text content wraps within a multiline text box. Defaults to true.

    access

    public

    [ Top ]

    TTextBox::loadPostData

    loadPostData( string $key, array $values );

    Overridden in child classes as:

    TDatePicker::loadPostData()
    Loads user input data. Override parent implementation, when InputMode is DropDownList call getDateFromPostData to get date data.

    Parameters

    $key

    the key that can be used to retrieve data from the input data collection

    $values

    the input data collection

    Returns

    whether the data of the component has been changed

    Remarks

    Loads user input data.

    This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TTextBox::onTextChanged

    onTextChanged( TEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    Raises OnTextChanged event.

    This method is invoked when the value of the Text property changes on postback. If you override this method, be sure to call the parent implementation to ensure the invocation of the attached event handlers.

    access

    public

    [ Top ]

    TTextBox::raisePostDataChangedEvent

    raisePostDataChangedEvent( );

    Remarks

    Raises postdata changed event.

    This method is required by IPostBackDataHandler interface. It is invoked by the framework when Text property is changed on postback. This method is primarly used by framework developers.

    access

    public

    [ Top ]

    TTextBox::renderBeginTag

    renderBeginTag( THtmlWriter $writer );

    Overrides TWebControl::renderBeginTag() (Renders the openning tag for the control (including attributes))

    Parameters

    $writer

    the writer used for the rendering purpose^M

    Remarks

    Renders an additional line-break after the opening tag when it is in MultiLine text mode.

    access

    public

    [ Top ]

    TTextBox::renderClientControlScript

    renderClientControlScript( $writer );

    Overridden in child classes as:

    TActiveTextBox::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    TAutoComplete::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    Parameters

    $writer

    Remarks

    Renders the javascript for textbox.

    access

    protected

    [ Top ]

    TTextBox::renderContents

    renderContents( THtmlWriter $writer );

    Overridden in child classes as:

    TInPlaceTextBox::renderContents()
    Renders the body content of the label.

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    the writer for rendering

    Remarks

    Renders the body content of the textbox when it is in MultiLine text mode.

    access

    public

    [ Top ]

    TTextBox::setAutoCompleteType

    setAutoCompleteType( TTextBoxAutoCompleteType $value );

    Parameters

    $value

    the AutoComplete type of the textbox, default value is TTextBoxAutoCompleteType::None.

    throws

    TInvalidDataValueException if the input parameter is not a valid AutoComplete type

    access

    public

    [ Top ]

    TTextBox::setAutoPostBack

    setAutoPostBack( boolean $value );

    Overridden in child classes as:

    TDatePicker::setAutoPostBack()
    AutoPostBack is not supported.
    TActiveDatePicker::setAutoPostBack()
    Sets the value indicating if postback automatically.

    Parameters

    $value

    the value indicating if postback automatically

    Remarks

    Sets the value indicating if postback automatically.

    An automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component.

    access

    public

    [ Top ]

    TTextBox::setAutoTrim

    setAutoTrim( boolean $value );

    Parameters

    $value

    the value indicating if the input text should be trimmed spaces

    Remarks

    Sets the value indicating if the input text should be trimmed spaces

    access

    public

    [ Top ]

    TTextBox::setCausesValidation

    setCausesValidation( boolean $value );

    Parameters

    $value

    whether postback event trigger by this text box will cause input validation.

    access

    public

    [ Top ]

    TTextBox::setColumns

    setColumns( integer $value );

    Parameters

    $value

    the display width, set it 0 to clear the setting

    Remarks

    Sets the display width of the text box in characters.

    access

    public

    [ Top ]

    TTextBox::setData

    setData( string $value );

    Overridden in child classes as:

    TDatePicker::setData()
    Sets the timestamp represented by this control.

    Parameters

    $value

    the text content of the TTextBox control.

    Remarks

    Sets the text content of the TTextBox control.

    This method is required by IDataRenderer. It is the same as setText().

    see

    TTextBox::setText()

    since

    3.1.0

    access

    public

    [ Top ]

    TTextBox::setEnableClientScript

    setEnableClientScript( boolean $value );

    Parameters

    $value

    whether to render javascript.

    access

    public

    [ Top ]

    TTextBox::setIsValid

    setIsValid( bool $value );

    Parameters

    $value

    wether this control is valid.

    access

    public

    [ Top ]

    TTextBox::setMaxLength

    setMaxLength( integer $value );

    Parameters

    $value

    the maximum length, set it 0 to clear the setting

    Remarks

    Sets the maximum number of characters allowed in the text box.

    access

    public

    [ Top ]

    TTextBox::setPersistPassword

    setPersistPassword( boolean $value );

    Parameters

    $value

    whether password should be displayed in the textbox during postback. This property only applies when TextMode='Password'.

    access

    public

    [ Top ]

    TTextBox::setReadOnly

    setReadOnly( boolean $value );

    Overridden in child classes as:

    TInPlaceTextBox::setReadOnly()
    Update ClientSide Readonly property

    Parameters

    $value

    whether the textbox is read only

    access

    public

    [ Top ]

    TTextBox::setRows

    setRows( integer $value );

    Parameters

    $value

    the number of rows

    Remarks

    Sets the number of rows displayed in a multiline text box.

    access

    public

    [ Top ]

    TTextBox::setText

    setText( string $value );

    Overridden in child classes as:

    TActiveTextBox::setText()
    Client-side Text property can only be updated after the OnLoad stage.
    TInPlaceTextBox::setText()
    On callback response, the inner HTMl of the label and the
    TActiveDatePicker::setText()
    Client-side Text property can only be updated after the OnLoad stage.

    Parameters

    $value

    the text content

    Remarks

    Sets the text content of the TTextBox control.

    access

    public

    [ Top ]

    TTextBox::setTextMode

    setTextMode( TTextBoxMode $value );

    Overridden in child classes as:

    THtmlArea::setTextMode()
    Overrides the parent implementation.

    Parameters

    $value

    the text mode

    Remarks

    Sets the behavior mode of the TTextBox component.

    throws

    TInvalidDataValueException if the input value is not a valid text mode.

    access

    public

    [ Top ]

    TTextBox::setValidationGroup

    setValidationGroup( string $value );

    Parameters

    $value

    the group of validators which the text box causes validation upon postback

    access

    public

    [ Top ]

    TTextBox::setWrap

    setWrap( boolean $value );

    Parameters

    $value

    whether the text content wraps within a multiline text box.

    Remarks

    Sets the value indicating whether the text content wraps within a multiline text box.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • DEFAULT_COLUMNS = 20 [line 60]

    • Remarks

    Default number of columns (for MultiLine text box)

  • DEFAULT_ROWS = 4 [line 56]

    • Remarks

    Default number of rows (for MultiLine text box)

Documentation generated on Mon, 25 Jun 2012 14:45:39 +0200 by phpDocumentor 1.4.3


Docs For Class TTextBoxAutoCompleteType

Class TTextBoxAutoCompleteType

[line 617]
TEnumerable
   |
   --TTextBoxAutoCompleteType
Location: /Web/UI/WebControls/TTextBox.php

Remarks

TTextBoxAutoCompleteType class.

TTextBoxAutoCompleteType defines the possible AutoComplete type that is supported by a TTextBox control.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTextBox.php 3137 2012-05-10 21:09:10Z ctrlaltca $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • BusinessCity = 'BusinessCity'
  • BusinessCountryRegion = 'BusinessCountryRegion'
  • BusinessFax = 'BusinessFax'
  • BusinessPhone = 'BusinessPhone'
  • BusinessState = 'BusinessState'
  • BusinessStreetAddress = 'BusinessStreetAddress'
  • BusinessUrl = 'BusinessUrl'
  • BusinessZipCode = 'BusinessZipCode'
  • Cellular = 'Cellular'
  • Company = 'Company'
  • Department = 'Department'
  • Disabled = 'Disabled'
  • DisplayName = 'DisplayName'
  • Email = 'Email'
  • FirstName = 'FirstName'
  • Gender = 'Gender'
  • HomeCity = 'HomeCity'
  • HomeCountryRegion = 'HomeCountryRegion'
  • HomeFax = 'HomeFax'
  • Homepage = 'Homepage'
  • HomePhone = 'HomePhone'
  • HomeState = 'HomeState'
  • HomeStreetAddress = 'HomeStreetAddress'
  • HomeZipCode = 'HomeZipCode'
  • JobTitle = 'JobTitle'
  • LastName = 'LastName'
  • MiddleName = 'MiddleName'
  • None = 'None'
  • Notes = 'Notes'
  • Office = 'Office'
  • Pager = 'Pager'
  • Search = 'Search'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • BusinessCity = 'BusinessCity' [line 619]

  • BusinessCountryRegion = 'BusinessCountryRegion' [line 620]

  • BusinessFax = 'BusinessFax' [line 621]

  • BusinessPhone = 'BusinessPhone' [line 622]

  • BusinessState = 'BusinessState' [line 623]

  • BusinessStreetAddress = 'BusinessStreetAddress' [line 624]

  • BusinessUrl = 'BusinessUrl' [line 625]

  • BusinessZipCode = 'BusinessZipCode' [line 626]

  • Cellular = 'Cellular' [line 627]

  • Company = 'Company' [line 628]

  • Department = 'Department' [line 629]

  • Disabled = 'Disabled' [line 630]

  • DisplayName = 'DisplayName' [line 631]

  • Email = 'Email' [line 632]

  • FirstName = 'FirstName' [line 633]

  • Gender = 'Gender' [line 634]

  • HomeCity = 'HomeCity' [line 635]

  • HomeCountryRegion = 'HomeCountryRegion' [line 636]

  • HomeFax = 'HomeFax' [line 637]

  • Homepage = 'Homepage' [line 638]

  • HomePhone = 'HomePhone' [line 639]

  • HomeState = 'HomeState' [line 640]

  • HomeStreetAddress = 'HomeStreetAddress' [line 641]

  • HomeZipCode = 'HomeZipCode' [line 642]

  • JobTitle = 'JobTitle' [line 643]

  • LastName = 'LastName' [line 644]

  • MiddleName = 'MiddleName' [line 645]

  • None = 'None' [line 646]

  • Notes = 'Notes' [line 647]

  • Office = 'Office' [line 648]

  • Pager = 'Pager' [line 649]

  • Search = 'Search' [line 650]

Documentation generated on Mon, 25 Jun 2012 14:45:40 +0200 by phpDocumentor 1.4.3


Docs For Class TTextBoxMode

Class TTextBoxMode

[line 600]
TEnumerable
   |
   --TTextBoxMode
Location: /Web/UI/WebControls/TTextBox.php

Remarks

TTextBoxMode class.

TTextBoxMode defines the enumerable type for the possible mode that a TTextBox control could be at.

The following enumerable values are defined:

  • SingleLine: the textbox will be a regular single line input
  • MultiLine: the textbox will be a textarea allowing multiple line input
  • Password: the textbox will hide user input like a password input box

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTextBox.php 3137 2012-05-10 21:09:10Z ctrlaltca $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • MultiLine = 'MultiLine'
  • Password = 'Password'
  • SingleLine = 'SingleLine'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • MultiLine = 'MultiLine' [line 603]

  • Password = 'Password' [line 604]

  • SingleLine = 'SingleLine' [line 602]

Documentation generated on Mon, 25 Jun 2012 14:45:40 +0200 by phpDocumentor 1.4.3


Docs For Class TTextHighlighter

Class TTextHighlighter

[line 38]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextProcessor
               |
               --TTextHighlighter
Classes extended from TTextHighlighter:
TMarkdown
TMarkdown class

Location: /Web/UI/WebControls/TTextHighlighter.php

Remarks

TTextHighlighter class.

TTextHighlighter does syntax highlighting its body content, including static text and rendering results of child controls. You can set Language to specify what kind of syntax the body content is. Currently, TTextHighlighter supports the following languages: ABAP, CPP, CSS, DIFF, DTD, HTML, JAVA, JAVASCRIPT, MYSQL, PERL, PHP, PYTHON, RUBY, SQL, XML and PRADO, where PRADO refers to PRADO template syntax. By setting ShowLineNumbers to true, the highlighted result may be shown with line numbers.

Note, TTextHighlighter requires THead to be placed on the page template because it needs to insert some CSS styles.

author

Wei Zhuo<weizhuo[at]gmail[dot]com>

version

$Id: TTextHighlighter.php 3159 2012-06-01 18:01:40Z ctrlaltca $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TTextProcessor

  • TTextProcessor::addParsedObject()
    HTML-decodes static text.
  • TTextProcessor::getText()
  • TTextProcessor::processText()
    Processes a text string.
  • TTextProcessor::renderContents()
    Renders body content.
  • TTextProcessor::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTextHighlighter::getEnableCopyCode

    getEnableCopyCode( );

    Returns

    true will show "Copy Code" link. Defaults to false.

    access

    public

    [ Top ]

    TTextHighlighter::getHeaderTemplate

    getHeaderTemplate( );

    Returns

    header template with "Copy code" link.

    access

    protected

    [ Top ]

    TTextHighlighter::getLanguage

    getLanguage( );

    Returns

    language whose syntax is to be used for highlighting. Defaults to 'php'.

    access

    public

    [ Top ]

    TTextHighlighter::getLineNumberStyle

    getLineNumberStyle( );

    Returns

    style of row number, Table by default

    access

    public

    [ Top ]

    TTextHighlighter::getShowLineNumbers

    getShowLineNumbers( );

    Returns

    whether to show line numbers in the highlighted result.

    access

    public

    [ Top ]

    TTextHighlighter::getTabSize

    getTabSize( );

    Returns

    tab size. Defaults to 4.

    access

    public

    [ Top ]

    TTextHighlighter::getTagName

    getTagName( );

    Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

    Returns

    tag name of the panel

    access

    protected

    [ Top ]

    TTextHighlighter::onPreRender

    onPreRender( THtmlWriter $writer );

    Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

    Parameters

    $writer

    writer

    Remarks

    Registers css style for the highlighted result.

    This method overrides parent implementation.

    access

    public

    [ Top ]

    TTextHighlighter::processText

    processText( string $text );

    Overridden in child classes as:

    TMarkdown::processText()
    Processes a text string.

    Overrides TTextProcessor::processText() (Processes a text string.)

    Parameters

    $text

    text string to be processed

    Returns

    the processed text result

    Remarks

    Processes a text string.

    This method is required by the parent class.

    access

    public

    [ Top ]

    TTextHighlighter::registerStyleSheet

    registerStyleSheet( );

    Remarks

    Registers the stylesheet for presentation.

    access

    protected

    [ Top ]

    TTextHighlighter::render

    render( $writer );

    Overrides TWebControl::render() (Renders the control.)

    Parameters

    $writer

    access

    public

    [ Top ]

    TTextHighlighter::setEnableCopyCode

    setEnableCopyCode( boolean $value );

    Parameters

    $value

    true to show the "Copy Code" link.

    access

    public

    [ Top ]

    TTextHighlighter::setLanguage

    setLanguage( string $value );

    Parameters

    $value

    language (case-insensitive) whose syntax is to be used for highlighting. Valid values are those file names (without suffix) that are contained in '3rdParty/TextHighlighter/Text/Highlighter'. Currently, the following languages are supported: ABAP, CPP, CSS, DIFF, DTD, HTML, JAVA, JAVASCRIPT, MYSQL, PERL, PHP, PRADO, PYTHON, RUBY, SQL, XML If a language is not supported, it will be displayed as plain text.

    access

    public

    [ Top ]

    TTextHighlighter::setLineNumberStyle

    setLineNumberStyle( TTextHighlighterLineNumberStyle $value );

    Parameters

    $value

    style of row number

    access

    public

    [ Top ]

    TTextHighlighter::setShowLineNumbers

    setShowLineNumbers( boolean $value );

    Parameters

    $value

    whether to show line numbers in the highlighted result.

    access

    public

    [ Top ]

    TTextHighlighter::setTabSize

    setTabSize( integer $value );

    Parameters

    $value

    tab size

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:40 +0200 by phpDocumentor 1.4.3


Docs For Class TTextHighlighterLineNumberStyle

Class TTextHighlighterLineNumberStyle

[line 209]
TEnumerable
   |
   --TTextHighlighterLineNumberStyle
Location: /Web/UI/WebControls/TTextHighlighter.php

author

Wei Zhuo<weizhuo[at]gmail[dot]com>

version

$Id: TTextHighlighter.php 3159 2012-06-01 18:01:40Z ctrlaltca $

since

3.0

Class Variable Summary

Class Constant Summary

  • Li = 'Li'
  • Table = 'Table'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Li = 'Li' [line 211]

  • Table = 'Table' [line 212]

Documentation generated on Mon, 25 Jun 2012 14:45:40 +0200 by phpDocumentor 1.4.3


Docs For Class TClientSideValidationSummaryOptions

Class TClientSideValidationSummaryOptions

[line 437]
TComponent
   |
   --TClientSideOptions
      |
      --TClientSideValidationSummaryOptions
Location: /Web/UI/WebControls/TValidationSummary.php

Remarks

TClientSideValidationSummaryOptions class.

Client-side validation summary events such as OnHideSummary and OnShowSummary can be modified through the TBaseValidator:: property of a validation summary.

The <tt>OnHideSummary</tt> event is raise when the validation summary requests to hide the messages.

The <tt>OnShowSummary</tt> event is raised when the validation summary requests to show the messages.

See the quickstart documentation for further details.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TValidationSummary.php 3116 2012-03-23 18:15:03Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TClientSideOptions

  • TClientSideOptions::__construct()
    Constructor, initialize the options list.
  • TClientSideOptions::ensureFunction()
    Ensure that the javascript statements are wrapped in a javascript function block as
  • function(sender, parameter){ //code }
    •
    .
  • TClientSideOptions::getOption()
  • TClientSideOptions::getOptions()
  • TClientSideOptions::setFunction()
    Adds on client-side event handler by wrapping the code within a javascript function block. If the code begins with "javascript:", the code is assumed to be a javascript function block rather than arbiturary javascript statements.
  • TClientSideOptions::setOption()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TClientSideValidationSummaryOptions::ensureFunction

    ensureFunction( string $javascript );

    Overrides TClientSideOptions::ensureFunction() (Ensure that the javascript statements are wrapped in a javascript function block as

  • function(sender, parameter){ //code }
    •
    .)

    Parameters

    $javascript

    javascript code.

    Returns

    javascript function code.

    Remarks

    Ensure the string is a valid javascript function. The code block is enclosed with "function(summary, validators){ }" block.

    access

    protected

    [ Top ]

    TClientSideValidationSummaryOptions::getOnHideSummary

    getOnHideSummary( );

    Returns

    javascript code for client-side OnHideSummary event.

    access

    public

    [ Top ]

    TClientSideValidationSummaryOptions::getOnShowSummary

    getOnShowSummary( );

    Returns

    javascript code for client-side OnShowSummary event.

    access

    public

    [ Top ]

    TClientSideValidationSummaryOptions::setOnHideSummary

    setOnHideSummary( string $javascript );

    Parameters

    $javascript

    javascript code for client-side OnHideSummary event.

    Remarks

    Client-side OnHideSummary validation summary event is raise when all the validators are valid. This will override the default client-side validation summary behaviour.

    access

    public

    [ Top ]

    TClientSideValidationSummaryOptions::setOnShowSummary

    setOnShowSummary( string $javascript );

    Parameters

    $javascript

    javascript code for client-side OnShowSummary event.

    Remarks

    Client-side OnShowSummary event is raise when one or more validators are not valid. This will override the default client-side validation summary behaviour.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:45 +0200 by phpDocumentor 1.4.3


Docs For Class TValidationSummary

Class TValidationSummary

[line 37]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TValidationSummary
Location: /Web/UI/WebControls/TValidationSummary.php

Remarks

TValidationSummary class

TValidationSummary displays a summary of validation errors inline on a Web page, in a message box, or both. By default, a validation summary will collect TBaseValidator::getErrorMessage of all failed validators on the page. If ValidationGroup is not empty, only those validators who belong to the group will show their error messages in the summary.

The summary can be displayed as a list, as a bulleted list, or as a single paragraph based on the DisplayMode property. The messages shown can be prefixed with HeaderText.

The summary can be displayed on the Web page and in a message box by setting the ShowSummary and ShowMessageBox properties, respectively. Note, the latter is only effective when EnableClientScript is true.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TValidationSummary.php 3116 2012-03-23 18:15:03Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TValidationSummary::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Constructor.

    This method sets the foreground color to red.

    access

    public

    [ Top ]

    TValidationSummary::addAttributesToRender

    addAttributesToRender( $writer );

    Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    access

    protected

    [ Top ]

    TValidationSummary::createClientScript

    createClientScript( );

    Returns

    javascript validation summary event options.

    access

    protected

    [ Top ]

    TValidationSummary::getAutoUpdate

    getAutoUpdate( );

    Returns

    automatic client-side summary updates. Defaults to true.

    Remarks

    Gets the auto-update for this summary.

    access

    public

    [ Top ]

    TValidationSummary::getClientScriptOptions

    getClientScriptOptions( );

    Returns

    list of options for the summary

    Remarks

    Get a list of options for the client-side javascript validation summary.

    access

    protected

    [ Top ]

    TValidationSummary::getClientSide

    getClientSide( );

    Returns

    client-side validation summary event options.

    access

    public

    [ Top ]

    TValidationSummary::getDisplay

    getDisplay( );

    Overrides TWebControl::getDisplay() (parent method not documented)

    Returns

    the style of displaying the error messages. Defaults to TValidationSummaryDisplayStyle::Fixed.

    access

    public

    [ Top ]

    TValidationSummary::getDisplayMode

    getDisplayMode( );

    Returns

    the mode of displaying error messages. Defaults to TValidationSummaryDisplayMode::BulletList.

    access

    public

    [ Top ]

    TValidationSummary::getEnableClientScript

    getEnableClientScript( );

    Returns

    whether the TValidationSummary component updates itself using client-side script. Defaults to true.

    access

    public

    [ Top ]

    TValidationSummary::getErrorMessages

    getErrorMessages( );

    Returns

    list of validator error messages.

    Remarks

    Get the list of validation error messages.

    access

    protected

    [ Top ]

    TValidationSummary::getHeaderText

    getHeaderText( );

    Returns

    the header text displayed at the top of the summary

    access

    public

    [ Top ]

    TValidationSummary::getScrollToSummary

    getScrollToSummary( );

    Returns

    whether scroll summary into viewport or not. Defaults to true.

    access

    public

    [ Top ]

    TValidationSummary::getShowAnchor

    getShowAnchor( );

    Returns

    whether the validation summary should be anchored. Defaults to false.

    access

    public

    [ Top ]

    TValidationSummary::getShowMessageBox

    getShowMessageBox( );

    Returns

    whether the validation summary is displayed in a message box. Defaults to false.

    access

    public

    [ Top ]

    TValidationSummary::getShowSummary

    getShowSummary( );

    Returns

    whether the validation summary is displayed inline. Defaults to true.

    access

    public

    [ Top ]

    TValidationSummary::getValidationGroup

    getValidationGroup( );

    Returns

    the group which this validator belongs to

    access

    public

    [ Top ]

    TValidationSummary::renderBulletList

    renderBulletList( array $writer, string 1 );

    Parameters

    1

    the header text

    $writer

    list of messages

    Returns

    summary bullet list

    Remarks

    Render the validation summary as a bullet list.

    access

    protected

    [ Top ]

    TValidationSummary::renderContents

    renderContents( $writer );

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    Returns

    the rendering result

    Remarks

    Overrides parent implementation by rendering TValidationSummary-specific presentation.

    access

    public

    [ Top ]

    TValidationSummary::renderHeaderOnly

    renderHeaderOnly( THtmlWriter $writer );

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Render the validation summary header text only.

    access

    protected

    [ Top ]

    TValidationSummary::renderJsSummary

    renderJsSummary( array 0 );

    Parameters

    0

    list of options for validation summary.

    Remarks

    Render the javascript for validation summary.

    access

    protected

    [ Top ]

    TValidationSummary::renderList

    renderList( array $writer, string 1 );

    Parameters

    1

    the header text

    $writer

    list of messages

    Returns

    summary list

    Remarks

    Render the validation summary as a simple list.

    access

    protected

    [ Top ]

    TValidationSummary::renderSingleParagraph

    renderSingleParagraph( array $writer, string 1 );

    Parameters

    1

    the header text

    $writer

    list of messages

    Returns

    summary paragraph

    Remarks

    Render the validation summary as a paragraph.

    access

    protected

    [ Top ]

    TValidationSummary::setAutoUpdate

    setAutoUpdate( boolean $value );

    Parameters

    $value

    true for automatic summary updates.

    Remarks

    Sets the summary to auto-update on the client-side

    access

    public

    [ Top ]

    TValidationSummary::setDisplay

    setDisplay( TValidationSummaryDisplayStyle $value );

    Overrides TWebControl::setDisplay() (parent method not documented)

    Parameters

    $value

    the style of displaying the error messages

    access

    public

    [ Top ]

    TValidationSummary::setDisplayMode

    setDisplayMode( TValidationSummaryDisplayMode $value );

    Parameters

    $value

    the mode of displaying error messages

    access

    public

    [ Top ]

    TValidationSummary::setEnableClientScript

    setEnableClientScript( boolean $value );

    Parameters

    $value

    whether the TValidationSummary component updates itself using client-side script.

    access

    public

    [ Top ]

    TValidationSummary::setHeaderText

    setHeaderText( string $value );

    Parameters

    $value

    the header text

    Remarks

    Sets the header text to be displayed at the top of the summary

    access

    public

    [ Top ]

    TValidationSummary::setScrollToSummary

    setScrollToSummary( boolean $value );

    Parameters

    $value

    whether scroll summary into viewport or not.

    access

    public

    [ Top ]

    TValidationSummary::setShowAnchor

    setShowAnchor( boolean $value );

    Parameters

    $value

    whether the validation summary should be anchored.

    access

    public

    [ Top ]

    TValidationSummary::setShowMessageBox

    setShowMessageBox( boolean $value );

    Parameters

    $value

    whether the validation summary is displayed in a message box.

    access

    public

    [ Top ]

    TValidationSummary::setShowSummary

    setShowSummary( boolean $value );

    Parameters

    $value

    whether the validation summary is displayed inline.

    access

    public

    [ Top ]

    TValidationSummary::setValidationGroup

    setValidationGroup( string $value );

    Parameters

    $value

    the group which this validator belongs to

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:45 +0200 by phpDocumentor 1.4.3


Docs For Class TValidationSummaryDisplayMode

Class TValidationSummaryDisplayMode

[line 506]
TEnumerable
   |
   --TValidationSummaryDisplayMode
Location: /Web/UI/WebControls/TValidationSummary.php

Remarks

TValidationSummaryDisplayMode class.

TValidationSummaryDisplayMode defines the enumerable type for the possible modes that a TValidationSummary can organize and display the collected error messages.

The following enumerable values are defined:

  • SimpleList: the error messages are displayed as a list without any decorations.
  • SingleParagraph: the error messages are concatenated together into a paragraph.
  • BulletList: the error messages are displayed as a bulleted list.
  • HeaderOnly: only the HeaderText will be display.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TValidationSummary.php 3116 2012-03-23 18:15:03Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • BulletList = 'BulletList'
  • HeaderOnly = 'HeaderOnly'
  • SimpleList = 'SimpleList'
  • SingleParagraph = 'SingleParagraph'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • BulletList = 'BulletList' [line 510]

  • HeaderOnly = 'HeaderOnly' [line 511]

  • SimpleList = 'SimpleList' [line 508]

  • SingleParagraph = 'SingleParagraph' [line 509]

Documentation generated on Mon, 25 Jun 2012 14:45:46 +0200 by phpDocumentor 1.4.3


Docs For Class TValidationSummaryDisplayStyle

Class TValidationSummaryDisplayStyle

[line 530]
TEnumerable
   |
   --TValidationSummaryDisplayStyle
Location: /Web/UI/WebControls/TValidationSummary.php

Remarks

TValidationSummaryDisplay class.

TValidationSummaryDisplay defines the enumerable type for the possible styles that a TValidationSummary can display the collected error messages.

The following enumerable values are defined:

  • None: the error messages are not displayed
  • Dynamic: the error messages are dynamically added to display as the corresponding validators fail
  • Fixed: Similar to Dynamic except that the error messages physically occupy the page layout (even though they may not be visible)

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TValidationSummary.php 3116 2012-03-23 18:15:03Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Dynamic = 'Dynamic'
  • Fixed = 'Fixed'
  • None = 'None'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Dynamic = 'Dynamic' [line 533]

  • Fixed = 'Fixed' [line 534]

  • None = 'None' [line 532]

Documentation generated on Mon, 25 Jun 2012 14:45:46 +0200 by phpDocumentor 1.4.3


Docs For Class TWebControl

Class TWebControl

[line 42]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
Classes extended from TWebControl:
TAccordion
Class TAccordion.
TAccordionView
Class TAccordionView.
TButton
TButton class
TCheckBox
TCheckBox class
TDataBoundControl
TDataBoundControl class.
TDataListItem
TDataListItem class
TFileUpload
TFileUpload class
THtmlElement
THtmlElement class.
THyperLink
THyperLink class
TImage
TImage class
TInlineFrame
TInlineFrame class
TJavascriptLogger
TJavascriptLogger class.
TKeyboard
Class TKeyboard.
TLabel
TLabel class
TLinkButton
TLinkButton class
TPager
TPager class.
TPanel
TPanel class
TReCaptcha
TReCaptcha class.
TSlider
TSlider class
TTable
TTable class
TTableCell
TTableCell class.
TTableRow
TTableRow class.
TTabPanel
Class TTabPanel.
TTabView
TTabView class.
TTextBox
TTextBox class
TTextProcessor
TTextProcessor class.
TValidationSummary
TValidationSummary class
TWizard
Class TWizard.

Location: /Web/UI/WebControls/TWebControl.php

Remarks

TWebControl class

TWebControl is the base class for controls that share a common set of UI-related properties and methods. TWebControl-derived controls are usually associated with HTML tags. They thus have tag name, attributes and body contents. You can override getTagName to specify the tag name, addAttributesToRender to specify the attributes to be rendered, and renderContents to customize the body content rendering. TWebControl encapsulates a set of properties related with CSS style fields, such as BackColor, BorderWidth, etc.

Subclasses of TWebControl typically needs to override addAttributesToRender and renderContents. The former is used to render the attributes of the HTML tag associated with the control, while the latter is to render the body contents enclosed within the HTML tag.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWebControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

  • $_decorator =

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWebControl::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overridden in child classes as:

    TAccordion::addAttributesToRender()
    Adds attributes to renderer.
    TAccordionView::addAttributesToRender()
    Adds attributes to renderer.
    TButton::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
    TActiveButton::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TListControl::addAttributesToRender()
    Adds attributes to renderer.
    TBulletedList::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
    TDropDownList::addAttributesToRender()
    Adds attributes to renderer.
    TActiveDropDownList::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TListBox::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
    TActiveListBox::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TFileUpload::addAttributesToRender()
    Sets name attribute to the unique ID of the control.
    TActiveFileUpload::addAttributesToRender()
    Adds ID attribute, and renders the javascript for active component.
    THyperLink::addAttributesToRender()
    Adds attributes related to a hyperlink element to renderer.
    TImage::addAttributesToRender()
    Adds attributes related to an HTML image element to renderer.
    TImageButton::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
    TActiveImageButton::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TImageMap::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
    TInlineFrame::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
    TKeyboard::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
    TLabel::addAttributesToRender()
    Adds attributes to renderer.
    TActiveLabel::addAttributesToRender()
    Adds attribute id to the renderer.
    TBaseValidator::addAttributesToRender()
    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
    TActiveCustomValidator::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TLinkButton::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
    TActiveLinkButton::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TPanel::addAttributesToRender()
    Adds attributes to renderer.
    TActivePanel::addAttributesToRender()
    Adds attribute id to the renderer.
    TDraggable::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TDropContainer::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TReCaptcha::addAttributesToRender()
    TSlider::addAttributesToRender()
    Add the specified css classes to the track
    TTable::addAttributesToRender()
    Adds attributes to renderer.
    TTableCell::addAttributesToRender()
    Adds attributes to renderer.
    TActiveTableCell::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control if the event handler for the onCellSelected event is set.
    TTableHeaderCell::addAttributesToRender()
    Adds attributes to renderer.
    TActiveTableRow::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control if the event handler for the onRowSelected event is set.
    TTabPanel::addAttributesToRender()
    Adds attributes to renderer.
    TTabView::addAttributesToRender()
    Adds attributes to renderer.
    TTextBox::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
    TActiveTextBox::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TInPlaceTextBox::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    TDatePicker::addAttributesToRender()
    Add the client id to the input textbox, and register the client scripts.
    THtmlArea::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
    TValidationSummary::addAttributesToRender()

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attribute name-value pairs to renderer.

    By default, the method will render 'id', 'accesskey', 'disabled', 'tabindex', 'title' and all custom attributes. The method can be overriden to provide customized attribute rendering.

    access

    protected

    [ Top ]

    TWebControl::clearStyle

    clearStyle( );

    Remarks

    Removes all style data.

    access

    public

    [ Top ]

    TWebControl::copyBaseAttributes

    copyBaseAttributes( TWebControl $control );

    Parameters

    $control

    source control

    Remarks

    Copies basic control attributes from another control.

    Properties including AccessKey, ToolTip, TabIndex, Enabled and Attributes are copied.

    access

    public

    [ Top ]

    TWebControl::createStyle

    createStyle( );

    Overridden in child classes as:

    TBaseDataList::createStyle()
    Creates a style object for the control.
    TDataGrid::createStyle()
    Creates a style object for the control.
    TCheckBoxList::createStyle()
    Creates a style object for the control.
    TDataListItem::createStyle()
    Creates a style object for the control.
    TPanel::createStyle()
    Creates a style object to be used by the control.
    TTable::createStyle()
    Creates a style object for the control.
    TTableCell::createStyle()
    Creates a style object for the control.
    TTableRow::createStyle()
    Creates a style object for the control.

    Returns

    the default style created for TWebControl

    Remarks

    Creates a style object to be used by the control.

    This method may be overriden by controls to provide customized style.

    access

    protected

    [ Top ]

    TWebControl::getAccessKey

    getAccessKey( );

    Returns

    the access key of the control

    access

    public

    [ Top ]

    TWebControl::getBackColor

    getBackColor( );

    Returns

    the background color of the control

    access

    public

    [ Top ]

    TWebControl::getBorderColor

    getBorderColor( );

    Returns

    the border color of the control

    access

    public

    [ Top ]

    TWebControl::getBorderStyle

    getBorderStyle( );

    Returns

    the border style of the control

    access

    public

    [ Top ]

    TWebControl::getBorderWidth

    getBorderWidth( );

    Returns

    the border width of the control

    access

    public

    [ Top ]

    TWebControl::getCssClass

    getCssClass( );

    Overridden in child classes as:

    TAccordion::getCssClass()
    TTabPanel::getCssClass()

    Returns

    the css class of the control

    access

    public

    [ Top ]

    TWebControl::getDecorator

    getDecorator( [ $create = true] );

    Parameters

    $create

    access

    public

    [ Top ]

    TWebControl::getDisplay

    getDisplay( );

    Overridden in child classes as:

    TBaseValidator::getDisplay()
    TValidationSummary::getDisplay()

    Returns

    display style of the control, default is TDisplayStyle::Fixed

    access

    public

    [ Top ]

    TWebControl::getEnsureId

    getEnsureId( );

    Returns

    this web control must have an id

    access

    public

    [ Top ]

    TWebControl::getFont

    getFont( );

    Returns

    the font of the control

    access

    public

    [ Top ]

    TWebControl::getForeColor

    getForeColor( );

    Returns

    the foreground color of the control

    access

    public

    [ Top ]

    TWebControl::getHasStyle

    getHasStyle( );

    Returns

    whether the control has defined any style information

    access

    public

    [ Top ]

    TWebControl::getHeight

    getHeight( );

    Returns

    the height of the control

    access

    public

    [ Top ]

    TWebControl::getStyle

    getStyle( );

    Returns

    the object representing the css style of the control

    access

    public

    [ Top ]

    TWebControl::getTabIndex

    getTabIndex( );

    Returns

    the tab index of the control

    access

    public

    [ Top ]

    TWebControl::getTagName

    getTagName( );

    Overridden in child classes as:

    TAccordion::getTagName()
    TAccordionView::getTagName()
    TButton::getTagName()
    TCheckBox::getTagName()
    TDataGrid::getTagName()
    TListControl::getTagName()
    TBulletedList::getTagName()
    TDataListItem::getTagName()
    Returns the tag name used for this control.
    TFileUpload::getTagName()
    THtmlElement::getTagName()
    THyperLink::getTagName()
    TImage::getTagName()
    TImageButton::getTagName()
    TInlineFrame::getTagName()
    TJavascriptLogger::getTagName()
    TLabel::getTagName()
    TLinkButton::getTagName()
    TPanel::getTagName()
    TReCaptcha::getTagName()
    TSlider::getTagName()
    TTable::getTagName()
    TTableCell::getTagName()
    TTableHeaderCell::getTagName()
    TTableRow::getTagName()
    TTabPanel::getTagName()
    TTabView::getTagName()
    TTextBox::getTagName()
    TInPlaceTextBox::getTagName()
    TTextHighlighter::getTagName()
    TWizard::getTagName()

    Returns

    tag name of the control to be rendered

    Remarks

    Returns the tag name used for this control.

    By default, the tag name is 'span'. You can override this method to provide customized tag names.

    access

    protected

    [ Top ]

    TWebControl::getToolTip

    getToolTip( );

    Returns

    the tooltip of the control

    access

    public

    [ Top ]

    TWebControl::getWidth

    getWidth( );

    Returns

    the width of the control

    access

    public

    [ Top ]

    TWebControl::onPreRender

    onPreRender( TEventParameter $param );

    Overridden in child classes as:

    TAccordion::onPreRender()
    Registers CSS and JS.
    TCheckBox::onPreRender()
    Registers the checkbox to receive postback data during postback.
    TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
    TCheckBoxList::onPreRender()
    Registers for post data on postback.
    TRatingList::onPreRender()
    Publish the the rating style css file and rating image files.
    TActiveDropDownList::onPreRender()
    Updates the client-side options if the item list has changed after the OnLoad event.
    TListBox::onPreRender()
    Registers the list control to load post data on postback.
    TActiveListBox::onPreRender()
    Updates the client-side options if the item list has changed after the OnLoad event.
    TFileUpload::onPreRender()
    Sets Enctype of the form on the page.
    TActiveFileUpload::onPreRender()
    Publish the javascript
    TCaptcha::onPreRender()
    Configures the image URL that shows the token.
    TImageButton::onPreRender()
    Registers the image button to receive postback data during postback.
    TActiveImageButton::onPreRender()
    Register the x and y hidden input names of the position clicked.
    TJavascriptLogger::onPreRender()
    Registers the required logger javascript.
    TKeyboard::onPreRender()
    Registers CSS and JS.
    TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
    TReCaptchaValidator::onPreRender()
    TPager::onPreRender()
    Performs databinding to populate data items from data source.
    TDraggable::onPreRender()
    Registers clientscripts
    TDropContainer::onPreRender()
    Registers clientscripts
    TReCaptcha::onPreRender()
    Checks for API keys
    TSlider::onPreRender()
    Registers CSS and JS.
    TTabPanel::onPreRender()
    Registers CSS and JS.
    TInPlaceTextBox::onPreRender()
    Registers CSS and JS.
    TColorPicker::onPreRender()
    Publish the color picker Css asset files.
    TDatePicker::onPreRender()
    Publish the date picker Css asset files.
    TTextHighlighter::onPreRender()
    Registers css style for the highlighted result.

    Overrides TControl::onPreRender() (This method is invoked when the control enters 'OnPreRender' stage.)

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.

    access

    public

    [ Top ]

    TWebControl::render

    render( THtmlWriter $writer );

    Overridden in child classes as:

    TAccordion::render()
    TCheckBox::render()
    Renders the checkbox control.
    TDataGrid::render()
    Renders the datagrid.
    TActiveDataGrid::render()
    Renders the datagrid.
    TDataList::render()
    Renders the data list control.
    TActiveDataList::render()
    Renders the repeater.
    TBulletedList::render()
    Renders the control.
    TCheckBoxList::render()
    Renders the checkbox list control.
    TRatingList::render()
    Add rating style class name to the class attribute when setReadOnly property is true and when the setCssClass property is empty.
    TRepeater::render()
    Renders the repeater.
    TActiveRepeater::render()
    Renders the repeater.
    TImageMap::render()
    Renders this imagemap.
    TLabel::render()
    Renders the label.
    TPager::render()
    Renders the control.
    TActivePager::render()
    TPanel::render()
    TActivePanel::render()
    Renders and replaces the panel's content on the client-side.
    TDropContainer::render()
    Renders and replaces the panel's content on the client-side.
    TActiveTableCell::render()
    Renders and replaces the cell's content on the client-side. When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.
    TActiveTableRow::render()
    Renders and replaces the row's content on the client-side. When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.
    TTabPanel::render()
    TDatePicker::render()
    Renders body content.
    TTextHighlighter::render()
    TWizard::render()
    Renders the wizard.

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the control.

    This method overrides the parent implementation by replacing it with the following sequence:

    • renderBeginTag
    • renderContents
    • renderEndTag

    access

    public

    [ Top ]

    TWebControl::renderBeginTag

    renderBeginTag( THtmlWriter $writer );

    Overridden in child classes as:

    TDataGrid::renderBeginTag()
    Renders the openning tag for the datagrid control which will render table caption if present.
    TPanel::renderBeginTag()
    Renders the openning tag for the control (including attributes)
    TTable::renderBeginTag()
    Renders the openning tag for the table control which will render table caption if present.
    TTextBox::renderBeginTag()
    Renders an additional line-break after the opening tag when it is in MultiLine text mode.

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the openning tag for the control (including attributes)

    access

    public

    [ Top ]

    TWebControl::renderContents

    renderContents( THtmlWriter $writer );

    Overridden in child classes as:

    TAccordion::renderContents()
    Renders body contents of the accordion control.
    TAccordionView::renderContents()
    Renders body contents of the accordion view.
    TButton::renderContents()
    Renders the body content enclosed between the control tag.
    TListControl::renderContents()
    Renders body content of the list control.
    TBulletedList::renderContents()
    Renders the body contents.
    THyperLink::renderContents()
    Renders the body content of the hyperlink.
    TImage::renderContents()
    Renders the body content of the image.
    TImageButton::renderContents()
    Renders the body content enclosed between the control tag.
    TJavascriptLogger::renderContents()
    Register the required javascript libraries and display some general usage information.
    TLabel::renderContents()
    Renders the body content of the label.
    TBaseValidator::renderContents()
    Renders the validator control.
    TLinkButton::renderContents()
    Renders the body content enclosed between the control tag.
    TReCaptcha::renderContents()
    TSlider::renderContents()
    Render the body content
    TTable::renderContents()
    Renders body contents of the table.
    TTableCell::renderContents()
    Renders body contents of the table cell.
    TTableRow::renderContents()
    Renders body contents of the table row
    TTabPanel::renderContents()
    Renders body contents of the tab control.
    TTabView::renderContents()
    Renders body contents of the tab view.
    TTextBox::renderContents()
    Renders the body content of the textbox when it is in MultiLine text mode.
    TInPlaceTextBox::renderContents()
    Renders the body content of the label.
    TTextProcessor::renderContents()
    Renders body content.
    TValidationSummary::renderContents()
    Overrides parent implementation by rendering TValidationSummary-specific presentation.

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the body content enclosed between the control tag.

    By default, child controls and text strings will be rendered. You can override this method to provide customized content rendering.

    access

    public

    [ Top ]

    TWebControl::renderEndTag

    renderEndTag( THtmlWriter $writer );

    Overridden in child classes as:

    TPanel::renderEndTag()
    Renders the closing tag for the control
    TAutoComplete::renderEndTag()
    Renders the end tag and registers javascript effects library.
    TColorPicker::renderEndTag()
    Renders additional body content.

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the closing tag for the control

    access

    public

    [ Top ]

    TWebControl::setAccessKey

    setAccessKey( string $value );

    Parameters

    $value

    the access key to be set

    Remarks

    Sets the access key of the control.

    Only one-character string can be set, or an exception will be raised. Pass in an empty string if you want to disable access key.

    throws

    TInvalidDataValueException if the access key is specified with more than one character

    access

    public

    [ Top ]

    TWebControl::setBackColor

    setBackColor( string $value );

    Parameters

    $value

    the background color of the control

    access

    public

    [ Top ]

    TWebControl::setBorderColor

    setBorderColor( string $value );

    Parameters

    $value

    the border color of the control

    access

    public

    [ Top ]

    TWebControl::setBorderStyle

    setBorderStyle( string $value );

    Parameters

    $value

    the border style of the control

    access

    public

    [ Top ]

    TWebControl::setBorderWidth

    setBorderWidth( string $value );

    Parameters

    $value

    the border width of the control

    access

    public

    [ Top ]

    TWebControl::setCssClass

    setCssClass( string $value );

    Parameters

    $value

    the css class of the control

    access

    public

    [ Top ]

    TWebControl::setDisplay

    setDisplay( TDisplayStyle $value );

    Overridden in child classes as:

    TBaseValidator::setDisplay()
    TValidationSummary::setDisplay()

    Parameters

    $value

    display style of the control, default is TDisplayStyle::Fixed

    access

    public

    [ Top ]

    TWebControl::setEnsureId

    setEnsureId( boolean $value );

    Parameters

    $value

    pass true to enable enforcement of the tag attribute id.

    Remarks

    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.

    access

    public

    [ Top ]

    TWebControl::setForeColor

    setForeColor( string $value );

    Parameters

    $value

    the foreground color of the control

    access

    public

    [ Top ]

    TWebControl::setHeight

    setHeight( string $value );

    Parameters

    $value

    the height of the control

    access

    public

    [ Top ]

    TWebControl::setStyle

    setStyle( string $value );

    Parameters

    $value

    the css style string

    Remarks

    Sets the css style string of the control.

    The style string will be prefixed to the styles set via other control properties (e.g. Height, Width).

    throws

    TInvalidDataValueException if the parameter is not a string

    access

    public

    [ Top ]

    TWebControl::setTabIndex

    setTabIndex( integer $value );

    Parameters

    $value

    the tab index to be set

    Remarks

    Sets the tab index of the control.

    Pass 0 if you want to disable tab index.

    access

    public

    [ Top ]

    TWebControl::setToolTip

    setToolTip( string $value );

    Parameters

    $value

    the tooltip to be set

    Remarks

    Sets the tooltip of the control.

    Pass an empty string if you want to disable tooltip.

    access

    public

    [ Top ]

    TWebControl::setWidth

    setWidth( string $value );

    Parameters

    $value

    the width of the control

    access

    public

    [ Top ]

Variable Detail

  • $_decorator = [line 52]
  • Data type: TWebControlDecorator

    • var

    this render things before and after both the open and close tag

    access

    protected

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:47 +0200 by phpDocumentor 1.4.3


Docs For Class TWebControlAdapter

Class TWebControlAdapter

[line 26]
TComponent
   |
   --TApplicationComponent
      |
      --TControlAdapter
         |
         --TWebControlAdapter
Location: /Web/UI/WebControls/TWebControlAdapter.php

Remarks

TWebControlAdapter class

TWebControlAdapter is the base class for adapters that customize rendering for the Web control to which the adapter is attached. It may be used to modify the default markup or behavior for specific browsers.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWebControlAdapter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TControlAdapter

  • TControlAdapter::$_control =

Method Summary

Inherited Method Summary

Inherited From Class TControlAdapter

  • TControlAdapter::__construct()
    Constructor.
  • TControlAdapter::createChildControls()
    Creates child controls for the attached control.
  • TControlAdapter::getControl()
  • TControlAdapter::getPage()
  • TControlAdapter::loadState()
    Loads additional persistent control state.
  • TControlAdapter::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControlAdapter::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControlAdapter::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControlAdapter::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControlAdapter::render()
    This method is invoked when the control renders itself.
  • TControlAdapter::renderChildren()
    Renders the control's children.
  • TControlAdapter::saveState()
    Saves additional persistent control state.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWebControlAdapter::render

    render( THtmlWriter $writer );

    Overrides TControlAdapter::render() (This method is invoked when the control renders itself.)

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the control to which the adapter is attached.

    It calls renderBeginTag, renderContents and renderEndTag in order.

    access

    public

    [ Top ]

    TWebControlAdapter::renderBeginTag

    renderBeginTag( THtmlWriter $writer );

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the openning tag for the attached control.

    Default implementation calls the attached control's corresponding method.

    access

    public

    [ Top ]

    TWebControlAdapter::renderContents

    renderContents( THtmlWriter $writer );

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the body contents within the attached control tag.

    Default implementation calls the attached control's corresponding method.

    access

    public

    [ Top ]

    TWebControlAdapter::renderEndTag

    renderEndTag( THtmlWriter $writer );

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the closing tag for the attached control.

    Default implementation calls the attached control's corresponding method.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:47 +0200 by phpDocumentor 1.4.3


Docs For Class TWebControlDecorator

Class TWebControlDecorator

[line 59]
TComponent
   |
   --TWebControlDecorator
Location: /Web/UI/WebControls/TWebControlDecorator.php

Remarks

TWebControlDecorator class

A TWebControlDecorator can be applied to a TWebControl to customize its rendering. TWebControlDecorator can add custom html code before and after both the open and close tag of a TWebControl. The html code can be an user-defined text or an external template file that will be instantiated and rendered in place.

This is an easy way to have your look and feel depend upon the theme instead of writing specific html in your templates to achieve your website desires. Here is an example of how to code your theme skin:

  •  <com:THeader3>
    •

  •     <prop:Decorator.PreTagText>
    •

  •              <!-- Surround the control with a div and apply a css class to it -->
    •

  •         <div class="imported-theme-h3-container">
    •

  •     </prop:Decorator.PreTagText>
    •

  •     <prop:Decorator.PostTagText>
    •

  •              <!-- Properly close the tag -->
    •

  •         </div>
    •

  •     </prop:Decorator.PostTagText>
    •

  •  </com:THeader3>
    •

    The order of the inclusion of the decoration into the page goes like this: * PreTagTemplate * PreTagText * TWebControl Open Tag Rendered * PreContentsText * PreContentsTemplate * TWebControl Children Rendered * PostContentsTemplate * PostContentsText * TWebControl CloseTag Rendered * PostTagText * PostTagTemplate

    author

    Brad Anderson <javalizard@gmail.com>

    version

    $Id: TWebControlDecorator.php 2541 2008-10-21 15:05:13Z qiang.xue $

    since

    3.2

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TWebControlDecorator::__construct

      __construct( TWebControl $control, [boolean $onlyinternal = false] );

      Parameters

      $control

      The control that is to be decorated.

      $onlyinternal

      whether decoration is just around the inner content

      Remarks

      Constructor.

      Initializes the control .

      access

      public

      [ Top ]

      TWebControlDecorator::ensureTemplateDecoration

      ensureTemplateDecoration( [TComponent $sender = null], [ $param = null] );

      Parameters

      $sender

      this indicates the component or control to get the outer tag elements, just in case it's different than attached TWebControl. If none is provided, the outer templates default to the attached control

      $param

      Returns

      returns true if the template decorations have been added

      Remarks

      This method places the templates around the open and close tag. This takes a parameter which is

      to specify the control to get the outer template decoration. If no outer control is specified

      access

      public

      [ Top ]

      TWebControlDecorator::getPostContentsTemplate

      getPostContentsTemplate( );

      Returns

      the template before the close tag in the TWebControl. Defaults to null.

      access

      public

      [ Top ]

      TWebControlDecorator::getPostContentsText

      getPostContentsText( );

      Returns

      the text before the close tag in the TWebControl

      access

      public

      [ Top ]

      TWebControlDecorator::getPostTagTemplate

      getPostTagTemplate( );

      Returns

      the template after the close tag in the TWebControl. Defaults to null.

      access

      public

      [ Top ]

      TWebControlDecorator::getPostTagText

      getPostTagText( );

      Returns

      the text before the close tag in the TWebControl

      access

      public

      [ Top ]

      TWebControlDecorator::getPreContentsTemplate

      getPreContentsTemplate( );

      Returns

      the template after the open tag in the TWebControl. Defaults to null.

      access

      public

      [ Top ]

      TWebControlDecorator::getPreContentsText

      getPreContentsText( );

      Returns

      the text after the open tag in the TWebControl

      access

      public

      [ Top ]

      TWebControlDecorator::getPreTagTemplate

      getPreTagTemplate( );

      Returns

      the template before the open tag in the TWebControl. Defaults to null.

      access

      public

      [ Top ]

      TWebControlDecorator::getPreTagText

      getPreTagText( );

      Returns

      gets the text before the open tag in the TWebControl

      access

      public

      [ Top ]

      TWebControlDecorator::getUseState

      getUseState( );

      Returns

      if the templates in this decoration need state. This defaults to false

      access

      public

      [ Top ]

      TWebControlDecorator::instantiate

      instantiate( [ $outercontrol = null] );

      Parameters

      $outercontrol

      Remarks

      this is a framework call. The Text decoration can't influence the object hierarchy because they are rendered into into the writer directly.

      This call attaches the ensureTemplateDecoration to the TPage onSaveStateComplete so these controls don't have page states. This is as close to not influencing the page as possible.

      access

      public

      [ Top ]

      TWebControlDecorator::renderPostContentsText

      renderPostContentsText( {@link $writer );

      Parameters

      $writer

      TTextWriter} the writer to which the text is written

      Remarks

      This method places the post contents text into the TTextWriter

      access

      public

      [ Top ]

      TWebControlDecorator::renderPostTagText

      renderPostTagText( {@link $writer );

      Parameters

      $writer

      TTextWriter} the writer to which the text is written

      Remarks

      This method places the post tag text into the TTextWriter

      access

      public

      [ Top ]

      TWebControlDecorator::renderPreContentsText

      renderPreContentsText( {@link $writer );

      Parameters

      $writer

      TTextWriter} the writer to which the text is written

      Remarks

      This method places the pre contents text into the TTextWriter

      access

      public

      [ Top ]

      TWebControlDecorator::renderPreTagText

      renderPreTagText( {@link $writer );

      Parameters

      $writer

      TTextWriter} the writer to which the text is written

      Remarks

      This method places the pre tag text into the TTextWriter

      access

      public

      [ Top ]

      TWebControlDecorator::setPostContentsTemplate

      setPostContentsTemplate( TTemplate $value );

      Parameters

      $value

      sets the template before the close tag in the TWebControl

      access

      public

      [ Top ]

      TWebControlDecorator::setPostContentsText

      setPostContentsText( string $value );

      Parameters

      $value

      sets the text before the close tag in the TWebControl

      access

      public

      [ Top ]

      TWebControlDecorator::setPostTagTemplate

      setPostTagTemplate( TTemplate $value );

      Parameters

      $value

      sets the template before the close tag in the TWebControl

      access

      public

      [ Top ]

      TWebControlDecorator::setPostTagText

      setPostTagText( string $value );

      Parameters

      $value

      sets the text after the close tag in the TWebControl

      access

      public

      [ Top ]

      TWebControlDecorator::setPreContentsTemplate

      setPreContentsTemplate( TTemplate $value );

      Parameters

      $value

      sets the template after the open tag in the TWebControl

      access

      public

      [ Top ]

      TWebControlDecorator::setPreContentsText

      setPreContentsText( string $value );

      Parameters

      $value

      sets the text after the open tag in the TWebControl

      access

      public

      [ Top ]

      TWebControlDecorator::setPreTagTemplate

      setPreTagTemplate( TTemplate $value );

      Parameters

      $value

      sets the template before the open tag in the TWebControl

      access

      public

      [ Top ]

      TWebControlDecorator::setPreTagText

      setPreTagText( string $value );

      Parameters

      $value

      sets the text before the open tag in the TWebControl

      access

      public

      [ Top ]

      TWebControlDecorator::setUseState

      setUseState( boolean $value );

      Parameters

      $value

      true to tell the decoration that the templates need state and should be placed in a control step before the state is saved.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:48 +0200 by phpDocumentor 1.4.3


Docs For Class TCompleteWizardStep

Class TCompleteWizardStep

[line 1546]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TView
            |
            --TWizardStep
               |
               --TCompleteWizardStep
Location: /Web/UI/WebControls/TWizard.php

Remarks

TCompleteWizardStep class.

TCompleteWizardStep represents a wizard step of type TWizardStepType::Complete.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TWizardStep

  • TWizardStep::getAllowReturn()
  • TWizardStep::getStepType()
  • TWizardStep::getTitle()
  • TWizardStep::getWizard()
  • TWizardStep::setAllowReturn()
  • TWizardStep::setStepType()
  • TWizardStep::setTitle()
  • TWizardStep::setWizard()
    Sets the wizard owning this step.

Inherited From Class TView

  • TView::getActive()
  • TView::getVisible()
  • TView::onActivate()
    Raises OnActivate event.
  • TView::onDeactivate()
    Raises OnDeactivate event.
  • TView::setActive()
  • TView::setVisible()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCompleteWizardStep::getStepType

    getStepType( );

    Overrides TWizardStep::getStepType() (parent method not documented)

    Returns

    the wizard step type. Always TWizardStepType::Complete.

    access

    public

    [ Top ]

    TCompleteWizardStep::setStepType

    setStepType( string $value );

    Overrides TWizardStep::setStepType() (parent method not documented)

    Parameters

    $value

    the wizard step type.

    throws

    TInvalidOperationException whenever this method is invoked.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:48 +0200 by phpDocumentor 1.4.3


Docs For Class TTemplatedWizardStep

Class TTemplatedWizardStep

[line 1581]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TView
            |
            --TWizardStep
               |
               --TTemplatedWizardStep
Location: /Web/UI/WebControls/TWizard.php

Remarks

TTemplatedWizardStep class.

TTemplatedWizardStep represents a wizard step whose content and navigation can be customized using templates. To customize the step content, specify ContentTemplate. To customize navigation specific to the step, specify NavigationTemplate. Note, if the navigation template is not specified, default navigation will be used.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TWizardStep

  • TWizardStep::getAllowReturn()
  • TWizardStep::getStepType()
  • TWizardStep::getTitle()
  • TWizardStep::getWizard()
  • TWizardStep::setAllowReturn()
  • TWizardStep::setStepType()
  • TWizardStep::setTitle()
  • TWizardStep::setWizard()
    Sets the wizard owning this step.

Inherited From Class TView

  • TView::getActive()
  • TView::getVisible()
  • TView::onActivate()
    Raises OnActivate event.
  • TView::onDeactivate()
    Raises OnDeactivate event.
  • TView::setActive()
  • TView::setVisible()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTemplatedWizardStep::createChildControls

    createChildControls( );

    Overrides TControl::createChildControls() (Creates child controls.)

    Remarks

    Creates child controls.

    This method mainly instantiates the content template, if any.

    access

    public

    [ Top ]

    TTemplatedWizardStep::getContentTemplate

    getContentTemplate( );

    Returns

    the template for the content of the wizard step.

    access

    public

    [ Top ]

    TTemplatedWizardStep::getNavigationContainer

    getNavigationContainer( );

    Returns

    the control containing the navigation. It could be null if no navigation template is specified.

    access

    public

    [ Top ]

    TTemplatedWizardStep::getNavigationTemplate

    getNavigationTemplate( );

    Returns

    the template for displaying the navigation UI of a wizard step. Defaults to null.

    access

    public

    [ Top ]

    TTemplatedWizardStep::instantiateNavigationTemplate

    instantiateNavigationTemplate( );

    Remarks

    Instantiates the navigation template if any

    access

    public

    [ Top ]

    TTemplatedWizardStep::onInit

    onInit( mixed $param );

    Overrides TControl::onInit() (This method is invoked when the control enters 'OnInit' stage.)

    Parameters

    $param

    event parameter

    Remarks

    Ensures child controls are created.

    access

    public

    [ Top ]

    TTemplatedWizardStep::setContentTemplate

    setContentTemplate( ITemplate $value );

    Parameters

    $value

    the template for the content of the wizard step.

    access

    public

    [ Top ]

    TTemplatedWizardStep::setNavigationTemplate

    setNavigationTemplate( ITemplate $value );

    Parameters

    $value

    the template for displaying the navigation UI of a wizard step.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:49 +0200 by phpDocumentor 1.4.3


Docs For Class TWizard

Class TWizard

[line 84]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TWizard
Location: /Web/UI/WebControls/TWizard.php

Remarks

Class TWizard.

TWizard splits a large form and presents the user with a series of smaller forms to complete. TWizard is analogous to the installation wizard commonly used to install software in Windows.

The smaller forms are called wizard steps (TWizardStep, which can be accessed via WizardSteps. In template, wizard steps can be added into a wizard using the following syntax,

  •    <com:TWizard>
    •

  •       <com:TWizardStep Title="step 1">
    •

  •           content in step 1, may contain other controls
    •

  •       </com:TWizardStep>
    •

  •       <com:TWizardStep Title="step 2">
    •

  •           content in step 2, may contain other controls
    •

  •       </com:TWizardStep>
    •

  •    </com:TWizard>
    •

    Each wizard step can be one of the following types:

    • Start : the first step in the wizard.
    • Step : the internal steps in the wizard.
    • Finish : the last step that allows user interaction.
    • Complete : the step that shows a summary to user (no interaction is allowed).
    • Auto : the step type is determined by wizard automatically.
    At any time, only one step is visible to end-users, which can be obtained by ActiveStep. Its index in the step collection is given by ActiveStepIndex.

    Wizard content can be customized in many ways.

    The layout of a wizard consists of four parts: header, step content, navigation and side bar. Their content are affected by the following properties, respectively,

    • header: HeaderText and HeaderTemplate. If both are present, the latter takes precedence.
    • step: WizardSteps.
    • navigation: StartNavigationTemplate, StepNavigationTemplate, FinishNavigationTemplate. Default templates will be used if above templates are not set.
    • side bar: SideBarTemplate. A default template will be used if this template is not set. Its visibility is toggled by ShowSideBar.
    The style of these wizard layout components can be customized via the following style properties,
    • header: HeaderStyle.
    • step: StepStyle.
    • navigation: NavigationStyle, StartNextButtonStyle, StepNextButtonStyle, StepPreviousButtonStyle, FinishPreviousButtonStyle, FinishCompleteButtonStyle, CancelButtonStyle.
    • side bar: SideBarStyle and SideBarButtonStyle.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    • CMD_CANCEL = 'Cancel'
    • CMD_COMPLETE = 'Complete'
    • CMD_MOVETO = 'MoveTo'
    • CMD_NEXT = 'NextStep'
    • CMD_PREVIOUS = 'PreviousStep'
      Navigation commands.
    • ID_SIDEBAR_BUTTON = 'SideBarButton'
      Side bar button ID
    • ID_SIDEBAR_LIST = 'SideBarList'
      Side bar data list
    • ST_AUTO = 'Auto'
      Wizard step types.
    • ST_COMPLETE = 'Complete'
    • ST_FINISH = 'Finish'
    • ST_START = 'Start'
    • ST_STEP = 'Step'

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TWizard::addedWizardStep

      addedWizardStep( TWizardStep $step );

      Parameters

      $step

      wizard step to be added into multiview.

      Remarks

      Adds a wizard step to the multiview.

      This method should only be used by control developers. It is invoked when a step is added into the step collection of the wizard.

      access

      public

      [ Top ]

      TWizard::addParsedObject

      addParsedObject( mixed $object );

      Overrides TControl::addParsedObject() (Adds the object instantiated on a template to the child control collection.)

      Parameters

      $object

      object instantiated in template

      Remarks

      Adds TWizardStep objects into step collection.

      This method overrides the parent implementation and is invoked when template is being instantiated.

      access

      public

      [ Top ]

      TWizard::allowNavigationToPreviousStep

      allowNavigationToPreviousStep( );

      Returns

      whether navigation to the previous step is allowed

      access

      protected

      [ Top ]

      TWizard::allowNavigationToStep

      allowNavigationToStep( integer $index );

      Parameters

      $index

      index of the step

      Returns

      whether navigation to the specified step is allowed

      access

      protected

      [ Top ]

      TWizard::applyControlProperties

      applyControlProperties( );

      Remarks

      Applies various properties to the components of wizard

      access

      protected

      [ Top ]

      TWizard::applyHeaderProperties

      applyHeaderProperties( );

      Remarks

      Applies properties to the wizard header

      access

      protected

      [ Top ]

      TWizard::applyNavigationProperties

      applyNavigationProperties( );

      Remarks

      Apply properties to various navigation panels.

      access

      protected

      [ Top ]

      TWizard::applySideBarProperties

      applySideBarProperties( );

      Remarks

      Applies properties to the wizard sidebar

      access

      protected

      [ Top ]

      TWizard::applyStepContentProperties

      applyStepContentProperties( );

      Remarks

      Applies properties to the wizard step content

      access

      protected

      [ Top ]

      TWizard::bubbleEvent

      bubbleEvent( mixed $sender, TEventParameter $param );

      Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

      Parameters

      $sender

      sender of the original command event

      $param

      event parameter

      Remarks

      Handles bubbled events.

      This method mainly translate certain command events into wizard-specific events.

      throws

      TInvalidDataValueException if a navigation command is associated with an invalid parameter

      access

      public

      [ Top ]

      TWizard::createChildControls

      createChildControls( );

      Overrides TControl::createChildControls() (Creates child controls.)

      Remarks

      Creates child controls within the wizard

      access

      public

      [ Top ]

      TWizard::createFinishNavigation

      createFinishNavigation( );

      Remarks

      Creates finish navigation panel.

      access

      protected

      [ Top ]

      TWizard::createHeader

      createHeader( );

      Remarks

      Creates the wizard header.

      access

      protected

      [ Top ]

      TWizard::createNavigation

      createNavigation( );

      Remarks

      Creates navigation panel.

      access

      protected

      [ Top ]

      TWizard::createSideBar

      createSideBar( );

      Remarks

      Creates the wizard side bar

      access

      protected

      [ Top ]

      TWizard::createStartNavigation

      createStartNavigation( );

      Remarks

      Creates start navigation panel.

      access

      protected

      [ Top ]

      TWizard::createStepContent

      createStepContent( );

      Remarks

      Creates wizard step content.

      access

      protected

      [ Top ]

      TWizard::createStepNavigation

      createStepNavigation( );

      Remarks

      Creates step navigation panel.

      access

      protected

      [ Top ]

      TWizard::dataListItemCommand

      dataListItemCommand( mixed $sender, TDataListCommandEventParameter $param );

      Parameters

      $sender

      sender of the event

      $param

      Remarks

      Event handler for sidebar datalist's OnItemCommand event.

      This method is used internally by wizard. It mainly sets the active step index according to the button clicked in the sidebar.

      access

      public

      [ Top ]

      TWizard::dataListItemDataBound

      dataListItemDataBound( mixed $sender, TDataListItemEventParameter $param );

      Parameters

      $sender

      sender of the event

      $param

      Remarks

      Event handler for sidebar datalist's OnItemDataBound event.

      This method is used internally by wizard. It mainly configures the buttons in the sidebar datalist.

      access

      public

      [ Top ]

      TWizard::getActiveStep

      getActiveStep( );

      Returns

      the currently active wizard step

      access

      public

      [ Top ]

      TWizard::getActiveStepIndex

      getActiveStepIndex( );

      Returns

      the zero-based index of the active wizard step

      access

      public

      [ Top ]

      TWizard::getCancelButtonStyle

      getCancelButtonStyle( );

      Returns

      the style for the cancel button

      access

      public

      [ Top ]

      TWizard::getCancelDestinationUrl

      getCancelDestinationUrl( );

      Returns

      the URL that the browser will be redirected to if the cancel button in the wizard is clicked. Defaults to ''.

      access

      public

      [ Top ]

      TWizard::getFinishCompleteButtonStyle

      getFinishCompleteButtonStyle( );

      Returns

      the style for the complete button in the finish wizard step.

      access

      public

      [ Top ]

      TWizard::getFinishDestinationUrl

      getFinishDestinationUrl( );

      Returns

      the URL that the browser will be redirected to if the wizard finishes. Defaults to ''.

      access

      public

      [ Top ]

      TWizard::getFinishNavigation

      getFinishNavigation( );

      Returns

      container of the finish navigation

      access

      public

      [ Top ]

      TWizard::getFinishNavigationTemplate

      getFinishNavigationTemplate( );

      Returns

      navigation template for the finish step. Defaults to null.

      access

      public

      [ Top ]

      TWizard::getFinishPreviousButtonStyle

      getFinishPreviousButtonStyle( );

      Returns

      the style for the previous button in the start wizard step.

      access

      public

      [ Top ]

      TWizard::getHeader

      getHeader( );

      Returns

      container of the wizard header

      access

      public

      [ Top ]

      TWizard::getHeaderStyle

      getHeaderStyle( );

      Returns

      the style for the header.

      access

      public

      [ Top ]

      TWizard::getHeaderTemplate

      getHeaderTemplate( );

      Returns

      template for wizard header. Defaults to null.

      access

      public

      [ Top ]

      TWizard::getHeaderText

      getHeaderText( );

      Returns

      header text. Defaults to ''.

      access

      public

      [ Top ]

      TWizard::getHistory

      getHistory( );

      Returns

      history containing step indexes that were navigated before

      access

      protected

      [ Top ]

      TWizard::getMultiView

      getMultiView( );

      Returns

      the multiview holding wizard steps

      Remarks

      Returns the multiview that holds the wizard steps.

      This method should only be used by control developers.

      access

      public

      [ Top ]

      TWizard::getNavigationButtonStyle

      getNavigationButtonStyle( );

      Returns

      the style common for all navigation buttons.

      access

      public

      [ Top ]

      TWizard::getNavigationStyle

      getNavigationStyle( );

      Returns

      the style for the navigation panel.

      access

      public

      [ Top ]

      TWizard::getPreviousStepIndex

      getPreviousStepIndex( boolean $popStack );

      Parameters

      $popStack

      whether the first item in the history stack should be popped up after calling this method.

      Remarks

      Determines the index of the previous step based on history.

      access

      protected

      [ Top ]

      TWizard::getShowCancelButton

      getShowCancelButton( );

      Returns

      whether to display a cancel button in each wizard step. Defaults to false.

      access

      public

      [ Top ]

      TWizard::getShowSideBar

      getShowSideBar( );

      Returns

      whether to display a side bar that contains links to wizard steps. Defaults to true.

      access

      public

      [ Top ]

      TWizard::getSideBar

      getSideBar( );

      Returns

      container of the wizard side bar

      access

      public

      [ Top ]

      TWizard::getSideBarButtonStyle

      getSideBarButtonStyle( );

      Returns

      the style for the buttons displayed in the side bar.

      access

      public

      [ Top ]

      TWizard::getSideBarStyle

      getSideBarStyle( );

      Returns

      the style for the side bar.

      access

      public

      [ Top ]

      TWizard::getSideBarTemplate

      getSideBarTemplate( );

      Returns

      template for the side bar. Defaults to null.

      access

      public

      [ Top ]

      TWizard::getStartNavigation

      getStartNavigation( );

      Returns

      container of the start navigation

      access

      public

      [ Top ]

      TWizard::getStartNavigationTemplate

      getStartNavigationTemplate( );

      Returns

      navigation template for the start step. Defaults to null.

      access

      public

      [ Top ]

      TWizard::getStartNextButtonStyle

      getStartNextButtonStyle( );

      Returns

      the style for the next button in the start wizard step.

      access

      public

      [ Top ]

      TWizard::getStepContent

      getStepContent( );

      Returns

      container of the wizard step content

      access

      public

      [ Top ]

      TWizard::getStepNavigation

      getStepNavigation( );

      Returns

      container of the step navigation

      access

      public

      [ Top ]

      TWizard::getStepNavigationTemplate

      getStepNavigationTemplate( );

      Returns

      navigation template for internal steps. Defaults to null.

      access

      public

      [ Top ]

      TWizard::getStepNextButtonStyle

      getStepNextButtonStyle( );

      Returns

      the style for the next button in each internal wizard step.

      access

      public

      [ Top ]

      TWizard::getStepPreviousButtonStyle

      getStepPreviousButtonStyle( );

      Returns

      the style for the previous button in the start wizard step.

      access

      public

      [ Top ]

      TWizard::getStepStyle

      getStepStyle( );

      Returns

      the style for each internal wizard step.

      access

      public

      [ Top ]

      TWizard::getStepType

      getStepType( TWizardStep $wizardStep );

      Parameters

      $wizardStep

      Returns

      type of the step

      Remarks

      Determines the type of the specified wizard step.

      access

      protected

      [ Top ]

      TWizard::getTagName

      getTagName( );

      Overrides TWebControl::getTagName() (Returns the tag name used for this control.)

      Returns

      tag name for the wizard

      access

      protected

      [ Top ]

      TWizard::getUseDefaultLayout

      getUseDefaultLayout( );

      Returns

      whether to use default layout to arrange side bar and the rest wizard components. Defaults to true.

      access

      public

      [ Top ]

      TWizard::getWizardSteps

      getWizardSteps( );

      Returns

      collection of wizard steps

      access

      public

      [ Top ]

      TWizard::onActiveStepChanged

      onActiveStepChanged( TEventParameter $param );

      Parameters

      $param

      event parameter

      Remarks

      Raises OnActiveStepChanged event.

      This event is raised when the current visible step is changed in the wizard.

      access

      public

      [ Top ]

      TWizard::onCancelButtonClick

      onCancelButtonClick( TEventParameter $param );

      Parameters

      $param

      event parameter

      Remarks

      Raises OnCancelButtonClick event.

      This event is raised when a cancel navigation button is clicked in the current active step.

      access

      public

      [ Top ]

      TWizard::onCompleteButtonClick

      onCompleteButtonClick( TWizardNavigationEventParameter $param );

      Parameters

      $param

      event parameter

      Remarks

      Raises OnCompleteButtonClick event.

      This event is raised when a finish navigation button is clicked in the current active step.

      access

      public

      [ Top ]

      TWizard::onInit

      onInit( TEventParameter $param );

      Overrides TControl::onInit() (This method is invoked when the control enters 'OnInit' stage.)

      Parameters

      $param

      event parameter

      Remarks

      Creates the child controls of the wizard.

      This method overrides the parent implementation.

      access

      public

      [ Top ]

      TWizard::onNextButtonClick

      onNextButtonClick( TWizardNavigationEventParameter $param );

      Parameters

      $param

      event parameter

      Remarks

      Raises OnNextButtonClick event.

      This event is raised when a next navigation button is clicked in the current active step.

      access

      public

      [ Top ]

      TWizard::onPreviousButtonClick

      onPreviousButtonClick( TWizardNavigationEventParameter $param );

      Parameters

      $param

      event parameter

      Remarks

      Raises OnPreviousButtonClick event.

      This event is raised when a previous navigation button is clicked in the current active step.

      access

      public

      [ Top ]

      TWizard::onSideBarButtonClick

      onSideBarButtonClick( TWizardNavigationEventParameter $param );

      Parameters

      $param

      event parameter

      Remarks

      Raises OnSideBarButtonClick event.

      This event is raised when a link button in the side bar is clicked.

      access

      public

      [ Top ]

      TWizard::removedWizardStep

      removedWizardStep( TWizardStep $step );

      Parameters

      $step

      wizard step to be removed from multiview.

      Remarks

      Removes a wizard step from the multiview.

      This method should only be used by control developers. It is invoked when a step is removed from the step collection of the wizard.

      access

      public

      [ Top ]

      TWizard::render

      render( THtmlWriter $writer );

      Overrides TWebControl::render() (Renders the control.)

      Parameters

      $writer

      Remarks

      Renders the wizard.

      access

      public

      [ Top ]

      TWizard::requiresControlsRecreation

      requiresControlsRecreation( );

      Remarks

      Indicates the wizard needs to recreate all child controls.

      access

      protected

      [ Top ]

      TWizard::reset

      reset( );

      Remarks

      Clears up everything within the wizard.

      access

      protected

      [ Top ]

      TWizard::saveState

      saveState( );

      Overrides TControl::saveState() (This method is invoked when control state is to be saved.)

      Remarks

      Saves the current active step index into history.

      This method is invoked by the framework when the control state is being saved.

      access

      public

      [ Top ]

      TWizard::setActiveStep

      setActiveStep( TWizardStep $step );

      Parameters

      $step

      step to be activated

      throws

      TInvalidOperationException if the step is not in the wizard step collection

      access

      public

      [ Top ]

      TWizard::setActiveStepIndex

      setActiveStepIndex( integer $value );

      Parameters

      $value

      the zero-based index of the wizard step to be activated

      access

      public

      [ Top ]

      TWizard::setCancelDestinationUrl

      setCancelDestinationUrl( string $value );

      Parameters

      $value

      the URL that the browser will be redirected to if the cancel button in the wizard is clicked.

      access

      public

      [ Top ]

      TWizard::setFinishDestinationUrl

      setFinishDestinationUrl( string $value );

      Parameters

      $value

      the URL that the browser will be redirected to if the wizard finishes.

      access

      public

      [ Top ]

      TWizard::setFinishNavigationTemplate

      setFinishNavigationTemplate( ITemplate $value );

      Parameters

      $value

      navigation template for the finish step.

      access

      public

      [ Top ]

      TWizard::setHeaderTemplate

      setHeaderTemplate( ITemplate $value );

      Parameters

      $value

      template for wizard header.

      access

      public

      [ Top ]

      TWizard::setHeaderText

      setHeaderText( string $value );

      Parameters

      $value

      header text.

      access

      public

      [ Top ]

      TWizard::setShowCancelButton

      setShowCancelButton( boolean $value );

      Parameters

      $value

      whether to display a cancel button in each wizard step.

      access

      public

      [ Top ]

      TWizard::setShowSideBar

      setShowSideBar( boolean $value );

      Parameters

      $value

      whether to display a side bar that contains links to wizard steps.

      access

      public

      [ Top ]

      TWizard::setSideBarTemplate

      setSideBarTemplate( ITemplate $value );

      Parameters

      $value

      template for the side bar.

      access

      public

      [ Top ]

      TWizard::setStartNavigationTemplate

      setStartNavigationTemplate( ITemplate $value );

      Parameters

      $value

      navigation template for the start step.

      access

      public

      [ Top ]

      TWizard::setStepNavigationTemplate

      setStepNavigationTemplate( ITemplate $value );

      Parameters

      $value

      navigation template for internal steps.

      access

      public

      [ Top ]

      TWizard::setUseDefaultLayout

      setUseDefaultLayout( boolean $value );

      Parameters

      $value

      whether to use default layout to arrange side bar and the rest wizard components. If true, an HTML table will be used which places the side bar in the left cell while the rest components in the right cell.

      access

      public

      [ Top ]

      TWizard::wizardStepsChanged

      wizardStepsChanged( );

      Remarks

      Updates the sidebar datalist if any.

      This method is invoked when any wizard step is changed.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • CMD_CANCEL = 'Cancel' [line 100]

    • CMD_COMPLETE = 'Complete' [line 101]

    • CMD_MOVETO = 'MoveTo' [line 102]

    • CMD_NEXT = 'NextStep' [line 99]

    • CMD_PREVIOUS = 'PreviousStep' [line 98]

      • Remarks

      Navigation commands.

    • ID_SIDEBAR_BUTTON = 'SideBarButton' [line 106]

      • Remarks

      Side bar button ID

    • ID_SIDEBAR_LIST = 'SideBarList' [line 110]

      • Remarks

      Side bar data list

    • ST_AUTO = 'Auto' [line 90]

      • Remarks

      Wizard step types.

      deprecated

      deprecated since version 3.0.4 (use TWizardStepType constants instead)

    • ST_COMPLETE = 'Complete' [line 94]

    • ST_FINISH = 'Finish' [line 93]

    • ST_START = 'Start' [line 91]

    • ST_STEP = 'Step' [line 92]

    Documentation generated on Mon, 25 Jun 2012 14:45:49 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardFinishNavigationTemplate

Class TWizardFinishNavigationTemplate

[line 2054]
TComponent
   |
   --TWizardNavigationTemplate
      |
      --TWizardFinishNavigationTemplate
Location: /Web/UI/WebControls/TWizard.php

Remarks

TWizardFinishNavigationTemplate class.

TWizardFinishNavigationTemplate is the template used as default wizard finish navigation panel. It consists of three buttons, Previous, Complete and Cancel.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TWizardNavigationTemplate

  • TWizardNavigationTemplate::__construct()
    Constructor.
  • TWizardNavigationTemplate::createNavigationButton()
    Creates a navigation button.
  • TWizardNavigationTemplate::getWizard()
  • TWizardNavigationTemplate::instantiateIn()
    Instantiates the template.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWizardFinishNavigationTemplate::instantiateIn

    instantiateIn( TControl $parent );

    Overrides TWizardNavigationTemplate::instantiateIn() (Instantiates the template.)

    Parameters

    $parent

    parent to hold the content within the template

    Remarks

    Instantiates the template.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:50 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardNavigationButtonType

Class TWizardNavigationButtonType

[line 2129]
TEnumerable
   |
   --TWizardNavigationButtonType
Location: /Web/UI/WebControls/TWizard.php

Remarks

TWizardNavigationButtonType class.

TWizardNavigationButtonType defines the enumerable type for the possible types of buttons that can be used in the navigation part of a TWizard.

The following enumerable values are defined:

  • Button: a regular click button
  • Image: an image button
  • Link: a hyperlink button

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Button = 'Button'
  • Image = 'Image'
  • Link = 'Link'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Button = 'Button' [line 2131]

  • Image = 'Image' [line 2132]

  • Link = 'Link' [line 2133]

Documentation generated on Mon, 25 Jun 2012 14:45:50 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardNavigationContainer

Class TWizardNavigationContainer

[line 1747]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWizardNavigationContainer
Location: /Web/UI/WebControls/TWizard.php

Remarks

TWizardNavigationContainer class.

TWizardNavigationContainer represents a control containing a wizard navigation. The navigation may contain a few buttons, including PreviousButton, NextButton, CancelButton, CompleteButton.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWizardNavigationContainer::getCancelButton

    getCancelButton( );

    Returns

    the cancel button

    access

    public

    [ Top ]

    TWizardNavigationContainer::getCompleteButton

    getCompleteButton( );

    Returns

    the complete button

    access

    public

    [ Top ]

    TWizardNavigationContainer::getNextButton

    getNextButton( );

    Returns

    the next button

    access

    public

    [ Top ]

    TWizardNavigationContainer::getPreviousButton

    getPreviousButton( );

    Returns

    the previous button

    access

    public

    [ Top ]

    TWizardNavigationContainer::setCancelButton

    setCancelButton( mixed $value );

    Parameters

    $value

    the cancel button

    access

    public

    [ Top ]

    TWizardNavigationContainer::setCompleteButton

    setCompleteButton( mixed $value );

    Parameters

    $value

    the complete button

    access

    public

    [ Top ]

    TWizardNavigationContainer::setNextButton

    setNextButton( mixed $value );

    Parameters

    $value

    the next button

    access

    public

    [ Top ]

    TWizardNavigationContainer::setPreviousButton

    setPreviousButton( mixed $value );

    Parameters

    $value

    the previous button

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:50 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardNavigationEventParameter

Class TWizardNavigationEventParameter

[line 1839]
TComponent
   |
   --TEventParameter
      |
      --TWizardNavigationEventParameter
Location: /Web/UI/WebControls/TWizard.php

Remarks

TWizardNavigationEventParameter class.

TWizardNavigationEventParameter represents the parameter for TWizard's navigation events.

The index of the currently active step can be obtained from CurrentStepIndex, while the index of the candidate new step is in NextStepIndex. By modifying NextStepIndex, the new step can be changed to another one. If there is anything wrong with the navigation and it is not wanted, set CancelNavigation to true.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWizardNavigationEventParameter::__construct

    __construct( integer $currentStep );

    Parameters

    $currentStep

    current step index

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TWizardNavigationEventParameter::getCancelNavigation

    getCancelNavigation( );

    Returns

    whether navigation to the next step should be canceled. Default to false.

    access

    public

    [ Top ]

    TWizardNavigationEventParameter::getCurrentStepIndex

    getCurrentStepIndex( );

    Returns

    the zero-based index of the currently active step.

    access

    public

    [ Top ]

    TWizardNavigationEventParameter::getNextStepIndex

    getNextStepIndex( );

    Returns

    the zero-based index of the next step. Default to CurrentStepIndex.

    access

    public

    [ Top ]

    TWizardNavigationEventParameter::setCancelNavigation

    setCancelNavigation( boolean $value );

    Parameters

    $value

    whether navigation to the next step should be canceled.

    access

    public

    [ Top ]

    TWizardNavigationEventParameter::setNextStepIndex

    setNextStepIndex( integer $index );

    Parameters

    $index

    the zero-based index of the next step.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:51 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardNavigationTemplate

Class TWizardNavigationTemplate

[line 1952]
TComponent
   |
   --TWizardNavigationTemplate
Classes extended from TWizardNavigationTemplate:
TWizardStartNavigationTemplate
TWizardStartNavigationTemplate class.
TWizardFinishNavigationTemplate
TWizardFinishNavigationTemplate class.
TWizardStepNavigationTemplate
TWizardStepNavigationTemplate class.

Location: /Web/UI/WebControls/TWizard.php

Remarks

TWizardNavigationTemplate class.

TWizardNavigationTemplate is the base class for various navigation templates.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWizardNavigationTemplate::__construct

    __construct( TWizard $wizard );

    Parameters

    $wizard

    the wizard owning this template

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TWizardNavigationTemplate::createNavigationButton

    createNavigationButton( TWizardNavigationButtonStyle $buttonStyle, boolean $causesValidation, string $commandName );

    Parameters

    $buttonStyle

    button style

    $causesValidation

    whether the button should cause validation

    $commandName

    command name for the button's OnCommand event

    Remarks

    Creates a navigation button.

    It creates a TButton, TLinkButton, or TImageButton, depending on the given parameters.

    throws

    TInvalidDataValueException if the button type is not recognized

    access

    protected

    [ Top ]

    TWizardNavigationTemplate::getWizard

    getWizard( );

    Returns

    the wizard owning this template

    access

    public

    [ Top ]

    TWizardNavigationTemplate::instantiateIn

    instantiateIn( TControl $parent );

    Overridden in child classes as:

    TWizardStartNavigationTemplate::instantiateIn()
    Instantiates the template.
    TWizardFinishNavigationTemplate::instantiateIn()
    Instantiates the template.
    TWizardStepNavigationTemplate::instantiateIn()
    Instantiates the template.

    Parameters

    $parent

    parent to hold the content within the template

    Remarks

    Instantiates the template.

    Derived classes should override this method.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:51 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardSideBarListItemTemplate

Class TWizardSideBarListItemTemplate

[line 1929]
TComponent
   |
   --TWizardSideBarListItemTemplate
Location: /Web/UI/WebControls/TWizard.php

Remarks

TWizardSideBarListItemTemplate class.

TWizardSideBarListItemTemplate is the default template for each item in the sidebar datalist.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWizardSideBarListItemTemplate::instantiateIn

    instantiateIn( TControl $parent );

    Parameters

    $parent

    parent to hold the content within the template

    Remarks

    Instantiates the template.

    It creates a TLinkButton.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:51 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardSideBarTemplate

Class TWizardSideBarTemplate

[line 1904]
TComponent
   |
   --TWizardSideBarTemplate
Location: /Web/UI/WebControls/TWizard.php

Remarks

TWizardSideBarTemplate class.

TWizardSideBarTemplate is the default template for wizard sidebar.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWizardSideBarTemplate::instantiateIn

    instantiateIn( TControl $parent );

    Parameters

    $parent

    parent to hold the content within the template

    Remarks

    Instantiates the template.

    It creates a TDataList control.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:51 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardStartNavigationTemplate

Class TWizardStartNavigationTemplate

[line 2024]
TComponent
   |
   --TWizardNavigationTemplate
      |
      --TWizardStartNavigationTemplate
Location: /Web/UI/WebControls/TWizard.php

Remarks

TWizardStartNavigationTemplate class.

TWizardStartNavigationTemplate is the template used as default wizard start navigation panel. It consists of two buttons, Next and Cancel.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TWizardNavigationTemplate

  • TWizardNavigationTemplate::__construct()
    Constructor.
  • TWizardNavigationTemplate::createNavigationButton()
    Creates a navigation button.
  • TWizardNavigationTemplate::getWizard()
  • TWizardNavigationTemplate::instantiateIn()
    Instantiates the template.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWizardStartNavigationTemplate::instantiateIn

    instantiateIn( TControl $parent );

    Overrides TWizardNavigationTemplate::instantiateIn() (Instantiates the template.)

    Parameters

    $parent

    parent to hold the content within the template

    Remarks

    Instantiates the template.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:51 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardStep

Class TWizardStep

[line 1456]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TView
            |
            --TWizardStep
Classes extended from TWizardStep:
TCompleteWizardStep
TCompleteWizardStep class.
TTemplatedWizardStep
TTemplatedWizardStep class.

Location: /Web/UI/WebControls/TWizard.php

Remarks

TWizardStep class.

TWizardStep represents a wizard step. The wizard owning the step can be obtained by Wizard. To specify the type of the step, set StepType; For step title, set Title. If a step can be re-visited, set AllowReturn to true.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TView

  • TView::getActive()
  • TView::getVisible()
  • TView::onActivate()
    Raises OnActivate event.
  • TView::onDeactivate()
    Raises OnDeactivate event.
  • TView::setActive()
  • TView::setVisible()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWizardStep::getAllowReturn

    getAllowReturn( );

    Returns

    whether this step can be re-visited. Default to true.

    access

    public

    [ Top ]

    TWizardStep::getStepType

    getStepType( );

    Overridden in child classes as:

    TCompleteWizardStep::getStepType()

    Returns

    the wizard step type. Defaults to TWizardStepType::Auto.

    access

    public

    [ Top ]

    TWizardStep::getTitle

    getTitle( );

    Returns

    the title for this step.

    access

    public

    [ Top ]

    TWizardStep::getWizard

    getWizard( );

    Returns

    the wizard owning this step

    access

    public

    [ Top ]

    TWizardStep::setAllowReturn

    setAllowReturn( boolean $value );

    Parameters

    $value

    whether this step can be re-visited.

    access

    public

    [ Top ]

    TWizardStep::setStepType

    setStepType( TWizardStepType $type );

    Overridden in child classes as:

    TCompleteWizardStep::setStepType()

    Parameters

    $type

    the wizard step type.

    access

    public

    [ Top ]

    TWizardStep::setTitle

    setTitle( string $value );

    Parameters

    $value

    the title for this step.

    access

    public

    [ Top ]

    TWizardStep::setWizard

    setWizard( TWizard $wizard );

    Parameters

    $wizard

    the wizard owning this step

    Remarks

    Sets the wizard owning this step.

    This method is used internally by TWizard.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:51 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardStepCollection

Class TWizardStepCollection

[line 1683]
TComponent
   |
   --TList
      |
      --TWizardStepCollection
Location: /Web/UI/WebControls/TWizard.php

Remarks

TWizardStepCollection class.

TWizardStepCollection represents the collection of wizard steps owned by a TWizard.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWizardStepCollection::__construct

    __construct( TWizard $wizard );

    Overrides TList::__construct() (Constructor.)

    Parameters

    $wizard

    wizard that owns this collection

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TWizardStepCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TList::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This method overrides the parent implementation by checking if the item being added is a TWizardStep.

    throws

    TInvalidDataTypeException if the item being added is not TWizardStep.

    access

    public

    [ Top ]

    TWizardStepCollection::removeAt

    removeAt( integer $index );

    Overrides TList::removeAt() (Removes an item at the specified position.)

    Parameters

    $index

    the index of the item to be removed.

    Returns

    the removed item.

    Remarks

    Removes an item at the specified position.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:52 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardStepNavigationTemplate

Class TWizardStepNavigationTemplate

[line 2088]
TComponent
   |
   --TWizardNavigationTemplate
      |
      --TWizardStepNavigationTemplate
Location: /Web/UI/WebControls/TWizard.php

Remarks

TWizardStepNavigationTemplate class.

TWizardStepNavigationTemplate is the template used as default wizard step navigation panel. It consists of three buttons, Previous, Next and Cancel.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TWizardNavigationTemplate

  • TWizardNavigationTemplate::__construct()
    Constructor.
  • TWizardNavigationTemplate::createNavigationButton()
    Creates a navigation button.
  • TWizardNavigationTemplate::getWizard()
  • TWizardNavigationTemplate::instantiateIn()
    Instantiates the template.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWizardStepNavigationTemplate::instantiateIn

    instantiateIn( TControl $parent );

    Overrides TWizardNavigationTemplate::instantiateIn() (Instantiates the template.)

    Parameters

    $parent

    parent to hold the content within the template

    Remarks

    Instantiates the template.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:52 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardStepType

Class TWizardStepType

[line 2153]
TEnumerable
   |
   --TWizardStepType
Location: /Web/UI/WebControls/TWizard.php

Remarks

TWizardStepType class.

TWizardStepType defines the enumerable type for the possible types of wizard steps.

The following enumerable values are defined:

  • Auto: the type is automatically determined based on the location of the wizard step in the whole step collection.
  • Complete: the step is the last summary step.
  • Start: the step is the first step
  • Step: the step is between the begin and the end steps.
  • Finish: the last step before the Complete step.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizard.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Auto = 'Auto'
  • Complete = 'Complete'
  • Finish = 'Finish'
  • Start = 'Start'
  • Step = 'Step'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Auto = 'Auto' [line 2155]

  • Complete = 'Complete' [line 2156]

  • Finish = 'Finish' [line 2159]

  • Start = 'Start' [line 2157]

  • Step = 'Step' [line 2158]

Documentation generated on Mon, 25 Jun 2012 14:45:52 +0200 by phpDocumentor 1.4.3


Docs For Class TWizardNavigationButtonStyle

Class TWizardNavigationButtonStyle

[line 32]
TComponent
   |
   --TStyle
      |
      --TWizardNavigationButtonStyle
Location: /Web/UI/WebControls/TWizardNavigationButtonStyle.php

Remarks

TWizardNavigationButtonStyle class.

TWizardNavigationButtonStyle defines the style applied to a wizard navigation button. The button type can be specified via ButtonType, which can be 'Button', 'Image' or 'Link'. If the button is an image button, ImageUrl will be used to load the image for the button. Otherwise, ButtonText will be displayed as the button caption.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TWizardNavigationButtonStyle.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TStyle

  • TStyle::__construct()
    Constructor.
  • TStyle::addAttributesToRender()
    Adds attributes related to CSS styles to renderer.
  • TStyle::clearStyleField()
    Clears a single style field value;
  • TStyle::copyFrom()
    Copies the fields in a new style to this style.
  • TStyle::getBackColor()
  • TStyle::getBorderColor()
  • TStyle::getBorderStyle()
  • TStyle::getBorderWidth()
  • TStyle::getCssClass()
  • TStyle::getCustomStyle()
  • TStyle::getDisplayStyle()
  • TStyle::getFont()
  • TStyle::getForeColor()
  • TStyle::getHeight()
  • TStyle::getStyleField()
  • TStyle::getStyleFields()
  • TStyle::getWidth()
  • TStyle::hasCssClass()
  • TStyle::hasFont()
  • TStyle::hasStyleField()
  • TStyle::mergeWith()
    Merges the style with a new one.
  • TStyle::reset()
    Resets the style to the original empty state.
  • TStyle::setBackColor()
  • TStyle::setBorderColor()
  • TStyle::setBorderStyle()
    Sets the border style of the control.
  • TStyle::setBorderWidth()
  • TStyle::setCssClass()
  • TStyle::setCustomStyle()
    Sets custom style fields from a string.
  • TStyle::setDisplayStyle()
  • TStyle::setForeColor()
  • TStyle::setHeight()
  • TStyle::setStyleField()
    Sets a single style field value.
  • TStyle::setWidth()
  • TStyle::__clone()
    Need to clone the font object.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TWizardNavigationButtonStyle::apply

    apply( mixed $button );

    Parameters

    $button

    button to be applied with this style

    Remarks

    Applies this style to the specified button

    access

    public

    [ Top ]

    TWizardNavigationButtonStyle::copyFrom

    copyFrom( TStyle $style );

    Overrides TStyle::copyFrom() (Copies the fields in a new style to this style.)

    Parameters

    $style

    the new style

    Remarks

    Copies the fields in a new style to this style.

    If a style field is set in the new style, the corresponding field in this style will be overwritten.

    access

    public

    [ Top ]

    TWizardNavigationButtonStyle::getButtonText

    getButtonText( );

    Returns

    button caption

    access

    public

    [ Top ]

    TWizardNavigationButtonStyle::getButtonType

    getButtonType( );

    Returns

    button type. Default to TWizardNavigationButtonType::Button.

    access

    public

    [ Top ]

    TWizardNavigationButtonStyle::getImageUrl

    getImageUrl( );

    Returns

    image URL for the image button

    access

    public

    [ Top ]

    TWizardNavigationButtonStyle::mergeWith

    mergeWith( TStyle $style );

    Overrides TStyle::mergeWith() (Merges the style with a new one.)

    Parameters

    $style

    the new style

    Remarks

    Merges the style with a new one.

    If a style field is not set in this style, it will be overwritten by the new one.

    access

    public

    [ Top ]

    TWizardNavigationButtonStyle::reset

    reset( );

    Overrides TStyle::reset() (Resets the style to the original empty state.)

    Remarks

    Sets the style attributes to default values.

    This method overrides the parent implementation by resetting additional TWizardNavigationButtonStyle specific attributes.

    access

    public

    [ Top ]

    TWizardNavigationButtonStyle::setButtonText

    setButtonText( string $value );

    Parameters

    $value

    button caption

    access

    public

    [ Top ]

    TWizardNavigationButtonStyle::setButtonType

    setButtonType( TWizardNavigationButtonType $value );

    Parameters

    $value

    button type.

    access

    public

    [ Top ]

    TWizardNavigationButtonStyle::setImageUrl

    setImageUrl( string $value );

    Parameters

    $value

    image URL for the image button

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:52 +0200 by phpDocumentor 1.4.3


Docs For Class TXmlTransform

Class TXmlTransform

[line 37]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TXmlTransform
Location: /Web/UI/WebControls/TXmlTransform.php

Remarks

TXmlTransform class

TXmlTransform uses the PHP's XSL extension to perform XSL transformations using the libxslt library.

To associate an XML style sheet with TXmlTransform set the TransformPath property to the namespace or path to the style sheet or set the TransformContent property to the XML style sheet data as a string.

To associate the XML data to be transformed set the DocumentPath property to the namespace or path to the XML document or set the DocumentContent property to the XML data as a string.

To add additional parameters to the transformation process you can use the Parameters property.

author

Qiang Xue <qiang.xue@gmail.com>

author

Knut Urdalen <knut.urdalen@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

  • EXT_XML_FILE =  '.xml'
  • EXT_XSL_FILE =  '.xsl'

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TXmlTransform::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Constructor

    Initializes the TXmlTransform object and ensure that the XSL extension is available

    throws

    TConfigurationException If XSL extension is not available

    access

    public

    [ Top ]

    TXmlTransform::getDocumentContent

    getDocumentContent( );

    Returns

    XML data

    access

    public

    [ Top ]

    TXmlTransform::getDocumentPath

    getDocumentPath( );

    Returns

    The path to the XML document. It must be in namespace format.

    access

    public

    [ Top ]

    TXmlTransform::getParameters

    getParameters( );

    Returns

    the list of custom parameters

    Remarks

    Returns the list of parameters to be applied to the transform.

    access

    public

    [ Top ]

    TXmlTransform::getTransformContent

    getTransformContent( );

    Returns

    XML style sheet as string

    access

    public

    [ Top ]

    TXmlTransform::getTransformPath

    getTransformPath( );

    Returns

    The path to the XML style sheet.

    access

    public

    [ Top ]

    TXmlTransform::render

    render( THtmlWriter $writer );

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    The writer used for the rendering purpose

    Remarks

    Performs XSL transformation and render the output.

    access

    public

    [ Top ]

    TXmlTransform::setDocumentContent

    setDocumentContent( string $value );

    Parameters

    $value

    XML data. If not empty, it takes precedence over DocumentPath.

    access

    public

    [ Top ]

    TXmlTransform::setDocumentPath

    setDocumentPath( string $value );

    Parameters

    $value

    Namespace or path to XML document

    throws

    TInvalidDataValueException

    access

    public

    [ Top ]

    TXmlTransform::setTransformContent

    setTransformContent( string $value );

    Parameters

    $value

    XML style sheet as string

    access

    public

    [ Top ]

    TXmlTransform::setTransformPath

    setTransformPath( string $value );

    Parameters

    $value

    The path to the XML style sheet. It must be in namespace format.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • EXT_XML_FILE =  '.xml' [line 39]

  • EXT_XSL_FILE =  '.xsl' [line 40]

Documentation generated on Mon, 25 Jun 2012 14:45:54 +0200 by phpDocumentor 1.4.3


Package System.Web.UI.ActiveControls Element Index

Element index for package System.Web.UI.ActiveControls

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a b c d e f g h i l n o p r s t u v _
top
_
$_new | in file TActiveControlAdapter.php, variable TViewStateDiff::$_new
$_null | in file TActiveControlAdapter.php, variable TViewStateDiff::$_null
$_old | in file TActiveControlAdapter.php, variable TViewStateDiff::$_old
__construct in file TActiveTableCell.php, method TActiveTableCell::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter.
__construct in file TActiveTableCell.php, method TActiveTableCellEventParameter::__construct()
Creates a new TActiveTableRowEventParameter.
__construct in file TActiveTableRow.php, method TActiveTableRow::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter.
__construct in file TActiveTableRow.php, method TActiveTableRowEventParameter::__construct()
Creates a new TActiveTableRowEventParameter.
__construct in file TActiveRepeater.php, method TActiveRepeater::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter.
__construct in file TActiveRadioButton.php, method TActiveRadioButton::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveRatingList.php, method TActiveRatingList::__construct()
Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActivePanel.php, method TActivePanel::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveTextBox.php, method TActiveTextBox::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveRadioButtonList.php, method TActiveRadioButtonList::__construct()
Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TBaseActiveControl.php, method TBaseActiveControl::__construct()
Constructor. Attach a base active control to an active control instance.
__construct in file TCallbackResponseAdapter.php, method TCallbackResponseWriter::__construct()
Constructor. Generates unique boundary ID using microtime.
__construct in file TDropContainer.php, method TDropContainer::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct | in file TDropContainer.php, method TDropContainerEventParameter::__construct()
__construct in file TInPlaceTextBox.php, method TInPlaceTextBox::__construct()
Sets the auto post back to true by default.
__construct in file TCallbackEventParameter.php, method TCallbackEventParameter::__construct()
Creates a new TCallbackEventParameter.
__construct in file TCallbackClientScript.php, method TCallbackClientScript::__construct()
Constructor.
__construct | in file TAutoComplete.php, method TAutoCompleteTemplate::__construct()
__construct in file TActivePager.php, method TActivePager::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TCallback.php, method TCallback::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, call this constructor.
__construct in file TAutoComplete.php, method TAutoCompleteEventParameter::__construct()
Creates a new TCallbackEventParameter.
__construct in file TActiveMultiView.php, method TActiveMultiView::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter.
__construct in file TActiveCustomValidator.php, method TActiveCustomValidator::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveDataGrid.php, method TActiveDataGrid::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter.
__construct in file TActiveDataList.php, method TActiveDataList::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter.
__construct in file TActiveDatePicker.php, method TActiveDatePicker::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveControlAdapter.php, method TViewStateDiff::__construct()
Constructor.
__construct in file TActiveControlAdapter.php, method TCallbackPageStateTracker::__construct()
Constructor. Add a set of default states to track.
__construct in file TActiveCheckBox.php, method TActiveCheckBox::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveCheckBoxList.php, method TActiveCheckBoxList::__construct()
Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveControlAdapter.php, method TActiveControlAdapter::__construct()
Constructor.
__construct in file TActiveDropDownList.php, method TActiveDropDownList::__construct()
Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveFileUpload.php, method TActiveFileUpload::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveLinkButton.php, method TActiveLinkButton::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveListBox.php, method TActiveListBox::__construct()
Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveButton.php, method TActiveButton::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveLabel.php, method TActiveLabel::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveImageButton.php, method TActiveImageButton::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveHiddenField.php, method TActiveHiddenField::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveHyperLink.php, method TActiveHyperLink::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActiveImage.php, method TActiveImage::__construct()
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
__construct in file TActivePageAdapter.php, method TActivePageAdapter::__construct()
Constructor, trap errors and exception to let the callback response handle them.
top
a
addAttributesToRender in file TActiveTableRow.php, method TActiveTableRow::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control if the event handler for the onRowSelected event is set.
addAttributesToRender in file TActiveTableCell.php, method TActiveTableCell::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control if the event handler for the onCellSelected event is set.
addAttributesToRender in file TActiveButton.php, method TActiveButton::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveTextBox.php, method TActiveTextBox::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TDraggable.php, method TDraggable::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TInPlaceTextBox.php, method TInPlaceTextBox::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TDropContainer.php, method TDropContainer::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveListBox.php, method TActiveListBox::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActivePanel.php, method TActivePanel::addAttributesToRender()
Adds attribute id to the renderer.
addAttributesToRender in file TActiveLinkButton.php, method TActiveLinkButton::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveCustomValidator.php, method TActiveCustomValidator::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveFileUpload.php, method TActiveFileUpload::addAttributesToRender()
Adds ID attribute, and renders the javascript for active component.
addAttributesToRender in file TActiveHiddenField.php, method TActiveHiddenField::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveImageButton.php, method TActiveImageButton::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveDropDownList.php, method TActiveDropDownList::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveLabel.php, method TActiveLabel::addAttributesToRender()
Adds attribute id to the renderer.
addCssClass in file TCallbackClientScript.php, method TCallbackClientScript::addCssClass()
Add a Css class name to the element.
addPostDataLoader | in file TCallbackClientScript.php, method TCallbackClientScript::addPostDataLoader()
addStatesToTrack in file TActiveControlAdapter.php, method TCallbackPageStateTracker::addStatesToTrack()
Add a list of view states to track. Each state is added to the StatesToTrack property with the view state name as key.
appear in file TCallbackClientScript.php, method TCallbackClientScript::appear()
Visual Effect: Gradually make the element appear.
appendContent in file TCallbackClientScript.php, method TCallbackClientScript::appendContent()
Append a HTML fragement to the element.
appendScriptBlock in file TCallbackClientScript.php, method TCallbackClientScript::appendScriptBlock()
Appends a block of inline javascript enclosed in a boundary.
top
b
blindDown in file TCallbackClientScript.php, method TCallbackClientScript::blindDown()
Visual Effect: Blind down.
blindUp in file TCallbackClientScript.php, method TCallbackClientScript::blindUp()
Visual Effect: Blind up.
bubbleEvent in file TActiveTableRow.php, method TActiveTableRow::bubbleEvent()
This method overrides parent's implementation and raises the control's callback event. This will fire the onRowSelected event if an appropriate event handler is implemented.
buildListPager in file TActivePager.php, method TActivePager::buildListPager()
Builds a dropdown list pager Override parent implementation to build Active dropdown lists.
top
c
CALLBACK_ACTION_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_ACTION_HEADER
Callback response client-side action header name.
CALLBACK_DATA_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_DATA_HEADER
Callback response data header name.
CALLBACK_ERROR_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_ERROR_HEADER
Callback error header name.
CALLBACK_HIDDENFIELDLIST_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_HIDDENFIELDLIST_HEADER
Hidden field list header name.
CALLBACK_PAGESTATE_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_PAGESTATE_HEADER
Callback page state header name.
CALLBACK_REDIRECT in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_REDIRECT
Callback redirect url header name.
CALLBACK_SCRIPTLIST_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_SCRIPTLIST_HEADER
Script list header name.
CALLBACK_STYLESHEETLIST_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_STYLESHEETLIST_HEADER
Stylesheet list header name.
callClientFunction in file TCallbackClientScript.php, method TCallbackClientScript::callClientFunction()
Executes a client-side statement.
callClientFunction in file TInPlaceTextBox.php, method TInPlaceTextBox::callClientFunction()
Calls the client-side static method for this control class.
callClientFunction in file TActiveRatingList.php, method TActiveRatingList::callClientFunction()
Calls the client-side static method for this control class.
canCauseValidation | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::canCauseValidation()
canUpdateClientSide in file TBaseActiveControl.php, method TBaseActiveControl::canUpdateClientSide()
Returns true if callback response is allowed to update the browser contents.
canUpdateClientSide | in file TActiveListControlAdapter.php, method TActiveListItemCollection::canUpdateClientSide()
canUpdateClientSide | in file TActiveListControlAdapter.php, method TActiveListControlAdapter::canUpdateClientSide()
check in file TCallbackClientScript.php, method TCallbackClientScript::check()
Client script to check or uncheck a checkbox or radio button.
clearSelection in file TActiveListControlAdapter.php, method TActiveListControlAdapter::clearSelection()
Clears all existing selections on the client side.
clearSelection in file TListControl.php, method IListControlAdapter::clearSelection()
Clears all existing selections on the client side.
click in file TCallbackClientScript.php, method TCallbackClientScript::click()
Client script to click on an element. This client-side function is unpredictable.
client | in file TActiveControlAdapter.php, method TCallbackPageStateTracker::client()
createButton | in file TActiveDataGrid.php, method TActiveEditCommandColumn::createButton()
createChildControls | in file TActiveFileUpload.php, method TActiveFileUpload::createChildControls()
createChildControls in file TDropContainer.php, method TDropContainer::createChildControls()
Creates child control Override parent implementation to create a container which will contain all child controls. This container will be a TActivePanel, in order to allow user to update its content on callback.
createClientSide | in file TCallbackOptions.php, method TCallbackOptions::createClientSide()
createClientSide | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::createClientSide()
createListItemCollection in file TActiveListBox.php, method TActiveListBox::createListItemCollection()
Creates a collection object to hold list items. A specialized TActiveListItemCollection is created to allow the drop down list options to be added.
createListItemCollection in file TActiveDropDownList.php, method TActiveDropDownList::createListItemCollection()
Creates a collection object to hold list items. A specialized TActiveListItemCollection is created to allow the drop down list options to be added.
createNewHtmlWriter in file TCallbackResponseAdapter.php, method TCallbackResponseAdapter::createNewHtmlWriter()
Returns a new instance of THtmlWriter.
createPagerButton in file TActivePager.php, method TActivePager::createPagerButton()
Creates a pager button.
createPagerButton in file TActiveDataGrid.php, method TActiveDataGrid::createPagerButton()
Creates a pager button.
createRepeatedControl in file TActiveRadioButtonList.php, method TActiveRadioButtonList::createRepeatedControl()
Creates a control used for repetition (used as a template).
createRepeatedControl in file TActiveCheckBoxList.php, method TActiveCheckBoxList::createRepeatedControl()
Creates a control used for repetition (used as a template).
createRepeater | in file TAutoComplete.php, method TAutoComplete::createRepeater()
createResultPanel | in file TAutoComplete.php, method TAutoComplete::createResultPanel()
top
d
dataBind in file TAutoComplete.php, method TAutoComplete::dataBind()
Overrides parent implementation. Callback renderSuggestions() when page's IsCallback property is true.
displayException in file TActivePageAdapter.php, method TCallbackErrorHandler::displayException()
Displays the exceptions to the client-side TJavascriptLogger.
dropOut in file TCallbackClientScript.php, method TCallbackClientScript::dropOut()
Visual Effect: Drop out.
top
e
$errorCode | in file TActiveFileUpload.php, variable TActiveFileUploadCallbackParams::$errorCode
ensureFunction in file TCallbackClientSide.php, method TCallbackClientSide::ensureFunction()
Returns javascript statement enclosed within a javascript function.
evaluateScript in file TCallbackClientScript.php, method TCallbackClientScript::evaluateScript()
Evaluate a block of javascript enclosed in a boundary.
top
f
$fileName | in file TActiveFileUpload.php, variable TActiveFileUploadCallbackParams::$fileName
$fileSize | in file TActiveFileUpload.php, variable TActiveFileUploadCallbackParams::$fileSize
$fileType | in file TActiveFileUpload.php, variable TActiveFileUploadCallbackParams::$fileType
fade in file TCallbackClientScript.php, method TCallbackClientScript::fade()
Visual Effect: Gradually fade the element.
Failure | in file TDraggable.php, class constant TDraggableRevertOptions::Failure
flush in file TCallbackResponseAdapter.php, method TCallbackResponseWriter::flush()
Returns the text content wrapped within a HTML comment with boundary identifier as its comment content.
flushContent in file TCallbackResponseAdapter.php, method TCallbackResponseAdapter::flushContent()
Flushes the contents in the writers.
focus in file TCallbackClientScript.php, method TCallbackClientScript::focus()
Focus on a particular element.
fold in file TCallbackClientScript.php, method TCallbackClientScript::fold()
Visual Effect: Fold.
top
g
geOffsetY | in file TDropContainer.php, method TDropContainerEventParameter::geOffsetY()
getAcceptCssClass in file TDropContainer.php, method TDropContainer::getAcceptCssClass()
Gets the Css class name that this container can accept.
getActiveControl | in file TActiveDataGrid.php, method TActiveDataGrid::getActiveControl()
getActiveControl | in file TActiveDataList.php, method TActiveDataList::getActiveControl()
getActiveControl | in file TActiveRadioButton.php, method TActiveRadioButton::getActiveControl()
getActiveControl | in file TActiveDatePicker.php, method TActiveDatePicker::getActiveControl()
getActiveControl | in file TActiveRadioButtonList.php, method TActiveRadioButtonList::getActiveControl()
getActiveControl | in file TActiveRatingList.php, method TActiveRatingList::getActiveControl()
getActiveControl | in file TActiveTableRow.php, method TActiveTableRow::getActiveControl()
getActiveControl | in file TActiveTableCell.php, method TActiveTableCell::getActiveControl()
getActiveControl | in file TActiveImageButton.php, method TActiveImageButton::getActiveControl()
getActiveControl | in file TActivePanel.php, method TActivePanel::getActiveControl()
getActiveControl | in file TActiveDropDownList.php, method TActiveDropDownList::getActiveControl()
getActiveControl | in file TActiveHiddenField.php, method TActiveHiddenField::getActiveControl()
getActiveControl | in file TActiveLabel.php, method TActiveLabel::getActiveControl()
getActiveControl | in file TActiveHyperLink.php, method TActiveHyperLink::getActiveControl()
getActiveControl | in file TActiveImage.php, method TActiveImage::getActiveControl()
getActiveControl | in file TActiveLinkButton.php, method TActiveLinkButton::getActiveControl()
getActiveControl | in file TActiveListBox.php, method TActiveListBox::getActiveControl()
getActiveControl | in file TActiveButton.php, method TActiveButton::getActiveControl()
getActiveControl | in file TActiveFileUpload.php, method TActiveFileUpload::getActiveControl()
getActiveControl | in file TActiveMultiView.php, method TActiveMultiView::getActiveControl()
getActiveControl | in file TActivePager.php, method TActivePager::getActiveControl()
getActiveControl | in file TActiveRepeater.php, method TActiveRepeater::getActiveControl()
getActiveControl | in file TActiveCustomValidator.php, method TActiveCustomValidator::getActiveControl()
getActiveControl | in file TCallback.php, method TCallback::getActiveControl()
getActiveControl | in file TDropContainer.php, method TDropContainer::getActiveControl()
getActiveControl | in file TActiveCheckBoxList.php, method TActiveCheckBoxList::getActiveControl()
getActiveControl | in file TActiveCheckBox.php, method TActiveCheckBox::getActiveControl()
getActiveControl | in file TActiveTextBox.php, method TActiveTextBox::getActiveControl()
getAltKey | in file TDropContainer.php, method TDropContainerEventParameter::getAltKey()
getAssetUrl | in file TActiveFileUpload.php, method TActiveFileUpload::getAssetUrl()
getAutoGenerateColumnName | in file TActiveDataGrid.php, method TActiveDataGrid::getAutoGenerateColumnName()
getAutoHideTextBox | in file TInPlaceTextBox.php, method TInPlaceTextBox::getAutoHideTextBox()
getAutoPostBack | in file TActiveDatePicker.php, method TActiveDatePicker::getAutoPostBack()
getAutoPostBack | in file TActiveFileUpload.php, method TActiveFileUpload::getAutoPostBack()
getBaseActiveControl | in file TActiveControlAdapter.php, method TActiveControlAdapter::getBaseActiveControl()
getBoundary | in file TCallbackResponseAdapter.php, method TCallbackResponseWriter::getBoundary()
getBusyImage | in file TActiveFileUpload.php, method TActiveFileUpload::getBusyImage()
getCallbackClientHandler in file TActivePageAdapter.php, method TActivePageAdapter::getCallbackClientHandler()
Gets the callback client script handler. It handlers the javascript functions to be executed during the callback response.
getCallbackEventParameter in file TActivePageAdapter.php, method TActivePageAdapter::getCallbackEventParameter()
Gets callback parameter. JSON encoding is assumed.
getCallbackEventTarget | in file TActivePageAdapter.php, method TActivePageAdapter::getCallbackEventTarget()
getCallbackJavascript | in file TActiveFileUpload.php, method TActiveFileUpload::getCallbackJavascript()
getCallbackOptions | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getCallbackOptions()
getCallbackParameter | in file TCallbackEventParameter.php, method TCallbackEventParameter::getCallbackParameter()
getCallbackParameter | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getCallbackParameter()
getCausesValidation | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getCausesValidation()
getCellIndex in file TActiveTableCell.php, method TActiveTableCell::getCellIndex()
Returns the zero-based index of the TActiveTableCell within the TTableCellCollection of the parent TTableRow control. Raises a TConfigurationException if the cell is no member of the cell collection.
getChanges | in file TActiveControlAdapter.php, method TCallbackPageStateTracker::getChanges()
getClientClassName in file TDropContainer.php, method TDropContainer::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName | in file TActiveTableCell.php, method TActiveTableCell::getClientClassName()
getClientClassName | in file TActiveTableRow.php, method TActiveTableRow::getClientClassName()
getClientClassName in file TDraggable.php, method TDraggable::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName | in file TActiveImageButton.php, method TActiveImageButton::getClientClassName()
getClientClassName in file TActiveListBox.php, method TActiveListBox::getClientClassName()
Javascript client class for this control.
getClientClassName | in file TActiveRadioButton.php, method TActiveRadioButton::getClientClassName()
getClientClassName | in file TEventTriggeredCallback.php, method TEventTriggeredCallback::getClientClassName()
getClientClassName | in file TInPlaceTextBox.php, method TInPlaceTextBox::getClientClassName()
getClientClassName | in file TAutoComplete.php, method TAutoComplete::getClientClassName()
getClientClassName in file TActiveTextBox.php, method TActiveTextBox::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName | in file TActiveLinkButton.php, method TActiveLinkButton::getClientClassName()
getClientClassName in file TActiveRatingList.php, method TActiveRatingList::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName | in file TValueTriggeredCallback.php, method TValueTriggeredCallback::getClientClassName()
getClientClassName | in file TActiveButton.php, method TActiveButton::getClientClassName()
getClientClassName | in file TActiveCheckBox.php, method TActiveCheckBox::getClientClassName()
getClientClassName | in file TActiveFileUpload.php, method TActiveFileUpload::getClientClassName()
getClientClassName in file TActiveDropDownList.php, method TActiveDropDownList::getClientClassName()
No client class for this control.
getClientClassName | in file TActiveCustomValidator.php, method TActiveCustomValidator::getClientClassName()
getClientClassName in file TActiveHiddenField.php, method TActiveHiddenField::getClientClassName()
Gets the name of the javascript class responsible for performing postback for this control.
getClientClassName | in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::getClientClassName()
getClientFunctionsToExecute | in file TCallbackClientScript.php, method TCallbackClientScript::getClientFunctionsToExecute()
getClientOptions in file TActiveFileUpload.php, method TActiveFileUpload::getClientOptions()
Gets the client side options for this control.
getClientScriptOptions in file TActiveCustomValidator.php, method TActiveCustomValidator::getClientScriptOptions()
Returns an array of javascript validator options.
getClientSide in file TCallbackOptions.php, method TCallbackOptions::getClientSide()
Callback client-side options can be set by setting the properties of the ClientSide property. E.g. <com:TCallbackOptions ClientSide.OnSuccess="..." /> See TCallbackClientSide for details on the properties of ClientSide.
getClientSide | in file TActiveRadioButtonList.php, method TActiveRadioButtonList::getClientSide()
getClientSide | in file TCallback.php, method TCallback::getClientSide()
getClientSide | in file TActiveHiddenField.php, method TActiveHiddenField::getClientSide()
getClientSide | in file TActiveTableRow.php, method TActiveTableRow::getClientSide()
getClientSide | in file TActiveTableCell.php, method TActiveTableCell::getClientSide()
getClientSide | in file TActiveTextBox.php, method TActiveTextBox::getClientSide()
getClientSide | in file TActiveRadioButton.php, method TActiveRadioButton::getClientSide()
getClientSide | in file TActiveRatingList.php, method TActiveRatingList::getClientSide()
getClientSide in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getClientSide()
Callback client-side options can be set by setting the properties of the ClientSide property. E.g. <com:TCallback ActiveControl.ClientSide.OnSuccess="..." /> See TCallbackClientSide for details on the properties of ClientSide.
getClientSide | in file TActivePager.php, method TActivePager::getClientSide()
getClientSide | in file TActiveListBox.php, method TActiveListBox::getClientSide()
getClientSide | in file TActiveButton.php, method TActiveButton::getClientSide()
getClientSide | in file TActiveFileUpload.php, method TActiveFileUpload::getClientSide()
getClientSide | in file TActiveLinkButton.php, method TActiveLinkButton::getClientSide()
getClientSide | in file TActiveImageButton.php, method TActiveImageButton::getClientSide()
getClientSide | in file TActiveCheckBoxList.php, method TActiveCheckBoxList::getClientSide()
getClientSide | in file TDropContainer.php, method TDropContainer::getClientSide()
getClientSide | in file TActiveDatePicker.php, method TActiveDatePicker::getClientSide()
getClientSide | in file TActiveDropDownList.php, method TActiveDropDownList::getClientSide()
getClientSide | in file TActiveCustomValidator.php, method TActiveCustomValidator::getClientSide()
getClientSide | in file TActiveCheckBox.php, method TActiveCheckBox::getClientSide()
getClientSideOptions | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getClientSideOptions()
getClientX | in file TDropContainer.php, method TDropContainerEventParameter::getClientX()
getClientY | in file TDropContainer.php, method TDropContainerEventParameter::getClientY()
getCombinedStyle | in file TActiveControlAdapter.php, method TStyleDiff::getCombinedStyle()
getConstraint in file TDraggable.php, method TDraggable::getConstraint()
Determine if the element should be constrainted in one direction or not
getContainerID in file TActiveMultiView.php, method TActiveMultiView::getContainerID()
Returns the id of the surrounding container (span).
getContainerID in file TActiveDataList.php, method TActiveDataList::getContainerID()
Returns the id of the surrounding container (span).
getControl | in file TActiveListControlAdapter.php, method TActiveListItemCollection::getControl()
getControl | in file TBaseActiveControl.php, method TBaseActiveControl::getControl()
getControlID | in file TTriggeredCallback.php, method TTriggeredCallback::getControlID()
getControls in file TDropContainer.php, method TDropContainer::getControls()
Override parent implementation to return the container control collection.
getCssClassDiff | in file TActiveControlAdapter.php, method TStyleDiff::getCssClassDiff()
getCtrlKey | in file TDropContainer.php, method TDropContainerEventParameter::getCtrlKey()
getDatePickerOptions in file TActiveDatePicker.php, method TActiveDatePicker::getDatePickerOptions()
Get javascript date picker options.
getDecayRate in file TValueTriggeredCallback.php, method TValueTriggeredCallback::getDecayRate()
Gets the decay rate between callbacks. Default is 0;
getDefaultClientSideOptions in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getDefaultClientSideOptions()
Returns an array of default callback client-side options. The default options are obtained from the client-side options of a TCallbackOptions control with ID specified by setCallbackOptions.
getDefaultLabelID | in file TActiveRadioButton.php, method TActiveRadioButton::getDefaultLabelID()
getDefaultLabelID | in file TActiveCheckBox.php, method TActiveCheckBox::getDefaultLabelID()
getDifference | in file TActiveControlAdapter.php, method TStyleDiff::getDifference()
getDifference | in file TActiveControlAdapter.php, method TMapCollectionDiff::getDifference()
getDifference | in file TActiveControlAdapter.php, method TViewStateDiff::getDifference()
getDifference | in file TActiveControlAdapter.php, method TScalarDiff::getDifference()
getDisplayTextBox | in file TInPlaceTextBox.php, method TInPlaceTextBox::getDisplayTextBox()
getDragElementId | in file TDropContainer.php, method TDropContainerEventParameter::getDragElementId()
getDroppedControl in file TDropContainer.php, method TDropContainerEventParameter::getDroppedControl()
GetDroppedControl
getEditTriggerControlID | in file TInPlaceTextBox.php, method TInPlaceTextBox::getEditTriggerControlID()
getEnableClientScript in file TActiveCustomValidator.php, method TActiveCustomValidator::getEnableClientScript()
It's mandatory for the EnableClientScript to be activated or the TActiveCustomValidator won't work.
getEnablePageStateUpdate | in file TCallbackClientSide.php, method TCallbackClientSide::getEnablePageStateUpdate()
getEnableUpdate | in file TBaseActiveControl.php, method TBaseActiveControl::getEnableUpdate()
getErrorImage | in file TActiveFileUpload.php, method TActiveFileUpload::getErrorImage()
getEventName | in file TEventTriggeredCallback.php, method TEventTriggeredCallback::getEventName()
getExternalControlID | in file TInPlaceTextBox.php, method TInPlaceTextBox::getExternalControlID()
getFrequency | in file TAutoComplete.php, method TAutoComplete::getFrequency()
getGhosting in file TDraggable.php, method TDraggable::getGhosting()
Determine if the element should be cloned when dragged If true, Clones the element and drags the clone, leaving the original in place until the clone is dropped.
getHandle in file TDraggable.php, method TDraggable::getHandle()
Get the handle id or css class
getHasPriority | in file TCallbackClientSide.php, method TCallbackClientSide::getHasPriority()
getHoverCssClass in file TDropContainer.php, method TDropContainer::getHoverCssClass()
Gets the Css class name used when a draggble element is hovering over this container.
getInterval | in file TValueTriggeredCallback.php, method TValueTriggeredCallback::getInterval()
getInterval | in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::getInterval()
getIsCallback | in file TActiveCustomValidator.php, method TActiveCustomValidator::getIsCallback()
getIsTrackingPageState | in file TActiveControlAdapter.php, method TActiveControlAdapter::getIsTrackingPageState()
getJavascript in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getJavascript()
Returns the javascript callback request instance. To invoke a callback
getJsCallbackOptions | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getJsCallbackOptions()
getLabelAttributes in file TActiveCheckBox.php, method TActiveCheckBox::getLabelAttributes()
Overrides parent implementation to ensure label has ID.
getLabelAttributes in file TActiveRadioButton.php, method TActiveRadioButton::getLabelAttributes()
Overrides parent implementation to ensure label has ID.
getLabelClientID | in file TInPlaceTextBox.php, method TInPlaceTextBox::getLabelClientID()
getListHasChanged | in file TActiveListControlAdapter.php, method TActiveListItemCollection::getListHasChanged()
getMinChars | in file TAutoComplete.php, method TAutoComplete::getMinChars()
getNewWriter | in file TCallbackEventParameter.php, method TCallbackEventParameter::getNewWriter()
getObserveChanges | in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::getObserveChanges()
getOffsetX | in file TDropContainer.php, method TDropContainerEventParameter::getOffsetX()
getOnComplete | in file TCallbackClientSide.php, method TCallbackClientSide::getOnComplete()
getOnException | in file TCallbackClientSide.php, method TCallbackClientSide::getOnException()
getOnFailure | in file TCallbackClientSide.php, method TCallbackClientSide::getOnFailure()
getOnInteractive | in file TCallbackClientSide.php, method TCallbackClientSide::getOnInteractive()
getOnLoaded | in file TCallbackClientSide.php, method TCallbackClientSide::getOnLoaded()
getOnLoading | in file TCallbackClientSide.php, method TCallbackClientSide::getOnLoading()
getOnPreDispatch | in file TCallbackClientSide.php, method TCallbackClientSide::getOnPreDispatch()
getOnSuccess | in file TCallbackClientSide.php, method TCallbackClientSide::getOnSuccess()
getOnUninitialized | in file TCallbackClientSide.php, method TCallbackClientSide::getOnUninitialized()
getOnValidate | in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::getOnValidate()
getOnValidationError | in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::getOnValidationError()
getOnValidationSuccess | in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::getOnValidationSuccess()
getOption in file TBaseActiveControl.php, method TBaseActiveControl::getOption()
Gets an option named value. Options are used to store and retrive named values for the base active controls.
getOptions | in file TBaseActiveControl.php, method TBaseActiveControl::getOptions()
getPage | in file TBaseActiveControl.php, method TBaseActiveControl::getPage()
getPostBackOptions | in file TInPlaceTextBox.php, method TInPlaceTextBox::getPostBackOptions()
getPostBackOptions in file TDraggable.php, method TDraggable::getPostBackOptions()
Gets the post back options for this textbox.
getPostBackOptions | in file TAutoComplete.php, method TAutoComplete::getPostBackOptions()
getPostBackOptions in file TDropContainer.php, method TDropContainer::getPostBackOptions()
Gets the post back options for this textbox.
getPostBackOptions in file TActiveTableRow.php, method TActiveTableRow::getPostBackOptions()
Returns postback specifications for the table row.
getPostBackOptions in file TActiveTableCell.php, method TActiveTableCell::getPostBackOptions()
Returns postback specifications for the table cell.
getPostBackParameter | in file TCallbackClientSide.php, method TCallbackClientSide::getPostBackParameter()
getPostBackTarget | in file TCallbackClientSide.php, method TCallbackClientSide::getPostBackTarget()
getPostState | in file TCallbackClientSide.php, method TCallbackClientSide::getPostState()
getPreventDefaultAction | in file TEventTriggeredCallback.php, method TEventTriggeredCallback::getPreventDefaultAction()
getPropertyName | in file TValueTriggeredCallback.php, method TValueTriggeredCallback::getPropertyName()
getRedirectedUrl | in file TCallbackResponseAdapter.php, method TCallbackResponseAdapter::getRedirectedUrl()
getRequestTimeOut | in file TCallbackClientSide.php, method TCallbackClientSide::getRequestTimeOut()
getResponseData | in file TCallbackEventParameter.php, method TCallbackEventParameter::getResponseData()
getResponseData | in file TCallbackResponseAdapter.php, method TCallbackResponseAdapter::getResponseData()
getResultPanel | in file TAutoComplete.php, method TAutoComplete::getResultPanel()
getRevert in file TDraggable.php, method TDraggable::getRevert()
Determine if draggable element should revert to it orginal position upon release in an non-droppable container.
getRow in file TActiveTableCell.php, method TActiveTableCell::getRow()
Returns the parent TTableRow control by looping through all parents until a TTableRow is found. Raises a TConfigurationException if no row control is found.
getRowIndex in file TActiveTableRow.php, method TActiveTableRow::getRowIndex()
Returns the zero-based index of the TActiveTableRow within the TTableRowCollection of the parent TTable control. Raises a TConfigurationException if the row is no member of the row collection.
getScreenX | in file TDropContainer.php, method TDropContainerEventParameter::getScreenX()
getScreenY | in file TDropContainer.php, method TDropContainerEventParameter::getScreenY()
getSelectedCellIndex in file TActiveTableCell.php, method TActiveTableCellEventParameter::getSelectedCellIndex()
Returns the zero-based index of the TActiveTableCell within the TTableCellCollection of the parent TTableRow control.
getSelectedIndex | in file TAutoComplete.php, method TAutoCompleteEventParameter::getSelectedIndex()
getSelectedRowIndex in file TActiveTableRow.php, method TActiveTableRowEventParameter::getSelectedRowIndex()
Returns the zero-based index of the TActiveTableRow within the TTableRowCollection of the parent TTable control.
getSeparator | in file TAutoComplete.php, method TAutoComplete::getSeparator()
getShiftKey | in file TDropContainer.php, method TDropContainerEventParameter::getShiftKey()
getStartTimerOnLoad | in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::getStartTimerOnLoad()
getStatesToTrack | in file TActiveControlAdapter.php, method TCallbackPageStateTracker::getStatesToTrack()
getStateTracker | in file TActiveControlAdapter.php, method TActiveControlAdapter::getStateTracker()
getStyleDiff | in file TActiveControlAdapter.php, method TStyleDiff::getStyleDiff()
getStyleFromString | in file TActiveControlAdapter.php, method TStyleDiff::getStyleFromString()
getSuccessImage | in file TActiveFileUpload.php, method TActiveFileUpload::getSuccessImage()
getSuggestions | in file TAutoComplete.php, method TAutoComplete::getSuggestions()
getSurroundingTagId in file TActiveDataGrid.php, method TActiveDataGrid::getSurroundingTagId()
Returns the id of the surrounding container (div).
getSurroundingTagID in file TActiveRepeater.php, method TActiveRepeater::getSurroundingTagID()
Returns the id of the surrounding container (span).
getTable in file TActiveTableRow.php, method TActiveTableRow::getTable()
Returns the parent TTable control by looping through all parents until a TTable is found. Raises a TConfigurationException if no table control is found.
getTagName | in file TInPlaceTextBox.php, method TInPlaceTextBox::getTagName()
getTargetControl | in file TTriggeredCallback.php, method TTriggeredCallback::getTargetControl()
getTempPath | in file TActiveFileUpload.php, method TActiveFileUpload::getTempPath()
getTextCssClass | in file TAutoComplete.php, method TAutoComplete::getTextCssClass()
getToken | in file TAutoComplete.php, method TAutoCompleteEventParameter::getToken()
getTriggerOptions | in file TEventTriggeredCallback.php, method TEventTriggeredCallback::getTriggerOptions()
getTriggerOptions | in file TValueTriggeredCallback.php, method TValueTriggeredCallback::getTriggerOptions()
getTriggerOptions | in file TTriggeredCallback.php, method TTriggeredCallback::getTriggerOptions()
getTriggerOptions | in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::getTriggerOptions()
getValidationGroup | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getValidationGroup()
Ghosting | in file TDraggable.php, class constant TDraggableGhostingOptions::Ghosting
grow in file TCallbackClientScript.php, method TCallbackClientScript::grow()
Visual Effect: Gradually make an element grow to a predetermined size.
top
h
handleCallback in file TActivePager.php, method TActivePager::handleCallback()
Event handler to the OnCallback active buttons or active dropdownlist.
hide in file TCallbackClientScript.php, method TCallbackClientScript::hide()
Hides an element by changing its CSS display style to "none".
highlight in file TCallbackClientScript.php, method TCallbackClientScript::highlight()
Visual Effect: High light the element for about 2 seconds.
Horizontal | in file TDraggable.php, class constant TDraggableConstraint::Horizontal
httpRedirect in file TCallbackResponseAdapter.php, method TCallbackResponseAdapter::httpRedirect()
Delay the redirect until we process the rest of the page.
top
i
IListControlAdapter in file TListControl.php, class IListControlAdapter
IListControlAdapter interface
initializeCell in file TActiveDataGrid.php, method TActiveCheckBoxColumn::initializeCell()
Initializes the specified cell to its initial values.
initializeCell | in file TActiveDataGrid.php, method TActiveButtonColumn::initializeCell()
initializeHeaderCell | in file TActiveDataGrid.php, method TActiveTemplateColumn::initializeHeaderCell()
initializeHeaderCell | in file TActiveDataGrid.php, method TActiveBoundColumn::initializeHeaderCell()
initializeHeaderCell | in file TActiveDataGrid.php, method TActiveLiteralColumn::initializeHeaderCell()
initializeHeaderCell | in file TActiveDataGrid.php, method TActiveCheckBoxColumn::initializeHeaderCell()
initializeHeaderCell | in file TActiveDataGrid.php, method TActiveDropDownListColumn::initializeHeaderCell()
initializeHeaderCell | in file TActiveDataGrid.php, method TActiveHyperLinkColumn::initializeHeaderCell()
insertAt in file TActiveListControlAdapter.php, method TActiveListItemCollection::insertAt()
Inserts an item into the collection.
insertContentAfter in file TCallbackClientScript.php, method TCallbackClientScript::insertContentAfter()
Insert a HTML fragement after the element.
insertContentBefore in file TCallbackClientScript.php, method TCallbackClientScript::insertContentBefore()
Insert a HTML fragement in before the element.
instantiateIn in file TAutoComplete.php, method TAutoCompleteTemplate::instantiateIn()
Instantiates the template.
top
l
$localName | in file TActiveFileUpload.php, variable TActiveFileUploadCallbackParams::$localName
top
n
None | in file TDraggable.php, class constant TDraggableRevertOptions::None
None | in file TDraggable.php, class constant TDraggableGhostingOptions::None
None | in file TDraggable.php, class constant TDraggableConstraint::None
top
o
onCallback in file TActivePager.php, method TActivePager::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveRadioButton.php, method TActiveRadioButton::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveButton.php, method TActiveButton::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveLinkButton.php, method TActiveLinkButton::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveImageButton.php, method TActiveImageButton::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveRadioButtonList.php, method TActiveRadioButtonList::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveRatingList.php, method TActiveRatingList::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TInPlaceTextBox.php, method TInPlaceTextBox::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TDropContainer.php, method TDropContainer::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TCallback.php, method TCallback::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveTextBox.php, method TActiveTextBox::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveHiddenField.php, method TActiveHiddenField::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveListBox.php, method TActiveListBox::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveDatePicker.php, method TActiveDatePicker::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveCheckBox.php, method TActiveCheckBox::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveCheckBoxList.php, method TActiveCheckBoxList::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveDropDownList.php, method TActiveDropDownList::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCallback in file TActiveCustomValidator.php, method TActiveCustomValidator::onCallback()
This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onCellSelected in file TActiveTableCell.php, method TActiveTableCell::onCellSelected()
This method is invoked when a callback is requested. The method raises 'OnCellSelected' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onDrop in file TDropContainer.php, method TDropContainer::onDrop()
Raises the onDrop event.
onFileUpload in file TActiveFileUpload.php, method TActiveFileUpload::onFileUpload()
This method is invoked when a file is uploaded.
onInit | in file TActiveFileUpload.php, method TActiveFileUpload::onInit()
onLoad in file TActiveControlAdapter.php, method TActiveControlAdapter::onLoad()
Starts viewstate tracking if necessary after when controls has been loaded
onLoadingText in file TInPlaceTextBox.php, method TInPlaceTextBox::onLoadingText()
Raised when editing the content is requsted to be loaded from the server side.
onPreRender in file TActiveFileUpload.php, method TActiveFileUpload::onPreRender()
Publish the javascript
onPreRender in file TActiveImageButton.php, method TActiveImageButton::onPreRender()
Register the x and y hidden input names of the position clicked.
onPreRender in file TDraggable.php, method TDraggable::onPreRender()
Registers clientscripts
onPreRender in file TInPlaceTextBox.php, method TInPlaceTextBox::onPreRender()
Registers CSS and JS.
onPreRender in file TActiveDropDownList.php, method TActiveDropDownList::onPreRender()
Updates the client-side options if the item list has changed after the OnLoad event.
onPreRender in file TDropContainer.php, method TDropContainer::onPreRender()
Registers clientscripts
onPreRender in file TActiveListBox.php, method TActiveListBox::onPreRender()
Updates the client-side options if the item list has changed after the OnLoad event.
onPreRender in file TActiveControlAdapter.php, method TActiveControlAdapter::onPreRender()
Publish the ajax script
onRowSelected in file TActiveTableRow.php, method TActiveTableRow::onRowSelected()
This method is invoked when a callback is requested. The method raises 'OnRowSelected' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
onSuggest in file TAutoComplete.php, method TAutoComplete::onSuggest()
This method is invoked when an autocomplete suggestion is requested.
onSuggestionSelected in file TAutoComplete.php, method TAutoComplete::onSuggestionSelected()
This method is invoked when an autocomplete suggestion is selected.
onUnload in file TActiveFileUpload.php, method TActiveFileUpload::onUnload()
Removes localfile on ending of the callback.
top
p
popParamsByToken | in file TActiveFileUpload.php, method TActiveFileUpload::popParamsByToken()
prependContent in file TCallbackClientScript.php, method TCallbackClientScript::prependContent()
Prepend a HTML fragement to the element.
processCallbackEvent in file TActivePageAdapter.php, method TActivePageAdapter::processCallbackEvent()
Process the callback request.
puff in file TCallbackClientScript.php, method TCallbackClientScript::puff()
Visual Effect: Gradually grow and fade the element.
pulsate in file TCallbackClientScript.php, method TCallbackClientScript::pulsate()
Visual Effect: Pulsate.
pushParamsAndGetToken | in file TActiveFileUpload.php, method TActiveFileUpload::pushParamsAndGetToken()
top
r
raiseCallbackEvent in file TDropContainer.php, method TDropContainer::raiseCallbackEvent()
Raises callback event. This method is required bu ICallbackEventHandler interface.
raiseCallbackEvent in file TActiveButton.php, method TActiveButton::raiseCallbackEvent()
Raises the callback event. This method is required by
raiseCallbackEvent in file TActiveCustomValidator.php, method TActiveCustomValidator::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface. The onServerValidate event is raised first and then the onCallback event.
raiseCallbackEvent in file TActivePager.php, method TActivePager::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface.
raiseCallbackEvent in file TActiveDatePicker.php, method TActiveDatePicker::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface.
raiseCallbackEvent in file TActiveListBox.php, method TActiveListBox::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface.
raiseCallbackEvent in file TActiveFileUpload.php, method TActiveFileUpload::raiseCallbackEvent()
Raises OnFileUpload event.
raiseCallbackEvent in file TActiveImageButton.php, method TActiveImageButton::raiseCallbackEvent()
Raises the callback event. This method is required by
raiseCallbackEvent in file TActiveDropDownList.php, method TActiveDropDownList::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface.
raiseCallbackEvent in file TActiveLinkButton.php, method TActiveLinkButton::raiseCallbackEvent()
Raises the callback event. This method is required by
raiseCallbackEvent in file TActiveHiddenField.php, method TActiveHiddenField::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface.
raiseCallbackEvent in file TActiveRadioButton.php, method TActiveRadioButton::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface.
raiseCallbackEvent in file TAutoComplete.php, method TAutoComplete::raiseCallbackEvent()
Raises the callback event. This method is overrides the parent implementation.
raiseCallbackEvent in file TCallback.php, method TCallback::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface. If getCausesValidation is true, it will invoke the page's TPage::validate method first.
raiseCallbackEvent in file TActiveCheckBox.php, method TActiveCheckBox::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface.
raiseCallbackEvent in file TActiveRadioButtonList.php, method TActiveRadioButtonList::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface.
raiseCallbackEvent in file TActiveTextBox.php, method TActiveTextBox::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface.
raiseCallbackEvent in file TActiveRatingList.php, method TActiveRatingList::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface.
raiseCallbackEvent in file TActiveCheckBoxList.php, method TActiveCheckBoxList::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface.
raiseCallbackEvent in file TActiveTableCell.php, method TActiveTableCell::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface. It will raise onCellSelected event with a TActiveTableCellEventParameter containing the zero-based index of the TActiveTableCell.
raiseCallbackEvent in file TActiveTableRow.php, method TActiveTableRow::raiseCallbackEvent()
Raises the callback event. This method is required by ICallbackEventHandler interface. It will raise onRowSelected event with a TActiveTableRowEventParameter containing the zero-based index of the TActiveTableRow.
raiseClientEvent in file TCallbackClientScript.php, method TCallbackClientScript::raiseClientEvent()
Raise the client side event (given by $eventName) on a particular element.
raisePostDataChangedEvent in file TActiveFileUpload.php, method TActiveFileUpload::raisePostDataChangedEvent()
Raises postdata changed event.
redirect in file TActivePageAdapter.php, method TActivePageAdapter::redirect()
Redirect url on the client-side using javascript.
registerCalendarClientScriptPost | in file TActiveDatePicker.php, method TActiveDatePicker::registerCalendarClientScriptPost()
registerCalendarClientScriptPre in file TActiveDatePicker.php, method TActiveDatePicker::registerCalendarClientScriptPre()
Registers the javascript code to initialize the date picker.
registerCallbackClientScript in file TBaseActiveControl.php, method TBaseActiveCallbackControl::registerCallbackClientScript()
Registers the callback control javascript code. Client-side options are
registerClientScript in file TInPlaceTextBox.php, method TInPlaceTextBox::registerClientScript()
Registers the relevant JavaScript.
registerControlToRender in file TActivePageAdapter.php, method TActivePageAdapter::registerControlToRender()
Register a control for defered render() call.
remove in file TCallbackClientScript.php, method TCallbackClientScript::remove()
Removes an element from the HTML page.
removeAt in file TActiveListControlAdapter.php, method TActiveListItemCollection::removeAt()
Removes an item from at specified index.
removeCssClass in file TCallbackClientScript.php, method TCallbackClientScript::removeCssClass()
Remove a Css class name from the element.
render in file TActiveTableCell.php, method TActiveTableCell::render()
Renders and replaces the cell's content on the client-side. When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.
render in file TActivePanel.php, method TActivePanel::render()
Renders and replaces the panel's content on the client-side.
render in file TActiveRepeater.php, method TActiveRepeater::render()
Renders the repeater.
render in file TActiveControlAdapter.php, method TActiveControlAdapter::render()
Renders the callback client scripts.
render | in file TActivePager.php, method TActivePager::render()
render in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::render()
Registers the javascript code for initializing the active control.
render in file TActiveDataGrid.php, method TActiveDataGrid::render()
Renders the datagrid.
render in file TActiveMultiView.php, method TActiveMultiView::render()
Renders the TActiveMultiView.
render in file TEventTriggeredCallback.php, method TEventTriggeredCallback::render()
Registers the javascript code for initializing the active control.
render in file TDropContainer.php, method TDropContainer::render()
Renders and replaces the panel's content on the client-side.
render in file TValueTriggeredCallback.php, method TValueTriggeredCallback::render()
Registers the javascript code for initializing the active control.
render in file TActiveDataList.php, method TActiveDataList::render()
Renders the repeater.
render in file TActiveTableRow.php, method TActiveTableRow::render()
Renders and replaces the row's content on the client-side. When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.
renderCallback in file TAutoComplete.php, method TAutoComplete::renderCallback()
Renders the suggestions during a callback respones.
renderCallbackClientScripts in file TActiveControlAdapter.php, method TActiveControlAdapter::renderCallbackClientScripts()
Register the callback clientscripts and sets the post loader IDs.
renderCallbackResponse in file TActivePageAdapter.php, method TActivePageAdapter::renderCallbackResponse()
Render the callback response.
renderClientControlScript in file TActiveTextBox.php, method TActiveTextBox::renderClientControlScript()
Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
renderClientControlScript in file TAutoComplete.php, method TAutoComplete::renderClientControlScript()
Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
renderClientControlScript in file TActiveCheckBox.php, method TActiveCheckBox::renderClientControlScript()
Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
renderClientControlScript in file TActiveButton.php, method TActiveButton::renderClientControlScript()
Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
renderClientControlScript in file TActiveRadioButtonList.php, method TActiveRadioButtonList::renderClientControlScript()
Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
renderClientControlScript in file TActiveListBox.php, method TActiveListBox::renderClientControlScript()
Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
renderClientControlScript in file TActiveHiddenField.php, method TActiveHiddenField::renderClientControlScript()
Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
renderClientControlScript in file TActiveLinkButton.php, method TActiveLinkButton::renderClientControlScript()
Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
renderClientControlScript in file TActiveImageButton.php, method TActiveImageButton::renderClientControlScript()
Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
renderClientControlScript in file TActiveCheckBoxList.php, method TActiveCheckBoxList::renderClientControlScript()
Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
renderClientControlScript in file TActiveDropDownList.php, method TActiveDropDownList::renderClientControlScript()
Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
renderClientControlScript in file TActiveRadioButton.php, method TActiveRadioButton::renderClientControlScript()
Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
renderContents in file TInPlaceTextBox.php, method TInPlaceTextBox::renderContents()
Renders the body content of the label.
renderCustomScript in file TActiveClientScript.php, method TActiveClientScript::renderCustomScript()
Registers the body content as javascript.
renderCustomScriptFile in file TActiveClientScript.php, method TActiveClientScript::renderCustomScriptFile()
Renders the custom script file.
renderEndTag in file TAutoComplete.php, method TAutoComplete::renderEndTag()
Renders the end tag and registers javascript effects library.
renderInputTag in file TActiveCheckBox.php, method TActiveCheckBox::renderInputTag()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
renderInputTag in file TActiveRadioButton.php, method TActiveRadioButton::renderInputTag()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
renderLabel in file TActiveRadioButton.php, method TActiveRadioButton::renderLabel()
Renders a label beside the radio button.
renderLabel in file TActiveCheckBox.php, method TActiveCheckBox::renderLabel()
Renders a label beside the checkbox.
renderMultiView in file TActiveMultiView.php, method TActiveMultiView::renderMultiView()
Renders the TActiveMultiView by writing a span tag with the container id obtained from getContainerID() which will be called by the replacement method of the client script to update it's content.
renderResponse in file TActivePageAdapter.php, method TActivePageAdapter::renderResponse()
Renders the callback response by adding additional callback data and javascript actions in the header and page state if required.
renderResultPanel in file TAutoComplete.php, method TAutoComplete::renderResultPanel()
Renders the result panel.
renderSuggestions in file TAutoComplete.php, method TAutoComplete::renderSuggestions()
Renders the suggestions repeater.
replace in file TCallbackClientScript.php, method TCallbackClientScript::replace()
Replace the content of an element with new content. The new content can be a string or a TControl component. If the <tt>content</tt> parameter is a TControl component, its rendered method will be called and its contents will be used for replacement.
replaceContent in file TCallbackClientScript.php, method TCallbackClientScript::replaceContent()
Replace the content of an element with new content contained in writer.
respondToChanges in file TActiveControlAdapter.php, method TCallbackPageStateTracker::respondToChanges()
For each of the changes call the corresponding change handlers.
Revert | in file TDraggable.php, class constant TDraggableRevertOptions::Revert
top
s
saveAs in file TActiveFileUpload.php, method TActiveFileUpload::saveAs()
Saves the uploaded file.
saveState in file TActiveControlAdapter.php, method TActiveControlAdapter::saveState()
Saves additional persistent control state. Respond to viewstate changes if necessary.
SCRIPT_PATH | in file TActiveFileUpload.php, class constant TActiveFileUpload::SCRIPT_PATH
scrollTo in file TCallbackClientScript.php, method TCallbackClientScript::scrollTo()
Scroll the top of the browser viewing area to the location of the element.
select in file TCallbackClientScript.php, method TCallbackClientScript::select()
Client script to select/clear/check a drop down list, check box list, or radio button list.
setAcceptCssClass in file TDropContainer.php, method TDropContainer::setAcceptCssClass()
Sets the Css class name that this container can accept.
setActiveView | in file TActiveMultiView.php, method TActiveMultiView::setActiveView()
setActiveViewIndex | in file TActiveMultiView.php, method TActiveMultiView::setActiveViewIndex()
setAlternateText in file TActiveImageButton.php, method TActiveImageButton::setAlternateText()
Sets the alternative text to be displayed in the TImage when the image is unavailable.
setAlternateText in file TActiveImage.php, method TActiveImage::setAlternateText()
Sets the alternative text to be displayed in the TImage when the image is unavailable.
setAttribute in file TCallbackClientScript.php, method TCallbackClientScript::setAttribute()
Sets the attribute of a particular control.
setAutoHideTextBox | in file TInPlaceTextBox.php, method TInPlaceTextBox::setAutoHideTextBox()
setAutoPostBack in file TActiveDatePicker.php, method TActiveDatePicker::setAutoPostBack()
Sets the value indicating if postback automatically.
setAutoPostBack | in file TActiveFileUpload.php, method TActiveFileUpload::setAutoPostBack()
setBaseActiveControl | in file TActiveControlAdapter.php, method TActiveControlAdapter::setBaseActiveControl()
setBaseControlClass | in file TActiveControlAdapter.php, method TActiveControlAdapter::setBaseControlClass()
setBoundary | in file TCallbackResponseAdapter.php, method TCallbackResponseWriter::setBoundary()
setCallbackEventParameter | in file TActivePageAdapter.php, method TActivePageAdapter::setCallbackEventParameter()
setCallbackEventTarget in file TActivePageAdapter.php, method TActivePageAdapter::setCallbackEventTarget()
Registers a control to raise callback event in the current request.
setCallbackOptions in file TBaseActiveControl.php, method TBaseActiveCallbackControl::setCallbackOptions()
Sets default callback options. Takes the ID of a TCallbackOptions component to duplicate the client-side options for this control. The getClientSide subproperties takes precedence over the CallbackOptions property.
setCallbackParameter | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::setCallbackParameter()
setCaption | in file TActiveRatingList.php, method TActiveRatingList::setCaption()
setCausesValidation | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::setCausesValidation()
setChecked in file TActiveCheckBox.php, method TActiveCheckBox::setChecked()
Sets a value indicating whether the checkbox is to be checked or not.
setChecked in file TActiveRadioButton.php, method TActiveRadioButton::setChecked()
Checks the radio button.
setClientSide in file TBaseActiveControl.php, method TBaseActiveCallbackControl::setClientSide()
Sets the client side options. Can only be set when client side is null.
setClientValidationFunction in file TActiveCustomValidator.php, method TActiveCustomValidator::setClientValidationFunction()
Client validation function is NOT supported.
setConstraint in file TDraggable.php, method TDraggable::setConstraint()
Set wether the element should be constrainted in one direction
setControl | in file TActiveListControlAdapter.php, method TActiveListItemCollection::setControl()
setControlID | in file TTriggeredCallback.php, method TTriggeredCallback::setControlID()
setDataSource | in file TAutoComplete.php, method TAutoComplete::setDataSource()
setDataSource in file TActiveDataGrid.php, method TActiveDataGrid::setDataSource()
Sets the data source object associated with the datagrid control.
setDataSource in file TActiveDataList.php, method TActiveDataList::setDataSource()
Sets the data source object associated with the repeater control.
setDataSource in file TActiveRepeater.php, method TActiveRepeater::setDataSource()
Sets the data source object associated with the repeater control.
setDecayRate in file TValueTriggeredCallback.php, method TValueTriggeredCallback::setDecayRate()
Sets the decay rate between callback. Default is 0;
setDescriptionUrl | in file TActiveImageButton.php, method TActiveImageButton::setDescriptionUrl()
setDescriptionUrl | in file TActiveImage.php, method TActiveImage::setDescriptionUrl()
setDisplayTextBox | in file TInPlaceTextBox.php, method TInPlaceTextBox::setDisplayTextBox()
setEditTriggerControlID | in file TInPlaceTextBox.php, method TInPlaceTextBox::setEditTriggerControlID()
setEnablePageStateUpdate in file TCallbackClientSide.php, method TCallbackClientSide::setEnablePageStateUpdate()
Set to true to enable the callback response to enable the viewstate update. This will automatically set HasPrority to true.
setEnableUpdate | in file TBaseActiveControl.php, method TBaseActiveControl::setEnableUpdate()
setErrorMessage in file TActiveCustomValidator.php, method TActiveCustomValidator::setErrorMessage()
Sets the text for the error message. Updates client-side erorr message.
setEventName in file TEventTriggeredCallback.php, method TEventTriggeredCallback::setEventName()
Sets the client-side event name that fires the callback request.
setForControl in file TActiveLabel.php, method TActiveLabel::setForControl()
Sets the ID of the control that the label is associated with.
setFrequency | in file TAutoComplete.php, method TAutoComplete::setFrequency()
setGhosting in file TDraggable.php, method TDraggable::setGhosting()
Sets wether the element should be cloned when dragged If true, Clones the element and drags the clone, leaving the original in place until the clone is dropped.
setHandle in file TDraggable.php, method TDraggable::setHandle()
Set the handle id or css class
setHasPriority | in file TCallbackClientSide.php, method TCallbackClientSide::setHasPriority()
setHoverCssClass in file TDropContainer.php, method TDropContainer::setHoverCssClass()
Sets the Css class name used when a draggble element is hovering over this container.
setImageAlign in file TActiveImage.php, method TActiveImage::setImageAlign()
Sets the alignment of the image with respective to other elements on the page.
setImageAlign in file TActiveImageButton.php, method TActiveImageButton::setImageAlign()
Sets the alignment of the image with respective to other elements on the page.
setImageUrl | in file TActiveImage.php, method TActiveImage::setImageUrl()
setImageUrl | in file TActiveImageButton.php, method TActiveImageButton::setImageUrl()
setImageUrl in file TActiveHyperLink.php, method TActiveHyperLink::setImageUrl()
Sets the location of image file of the THyperLink.
setInterval in file TValueTriggeredCallback.php, method TValueTriggeredCallback::setInterval()
Sets the polling interval in seconds to observe property changes.
setInterval | in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::setInterval()
setIsValid | in file TActiveCustomValidator.php, method TActiveCustomValidator::setIsValid()
setListItems in file TCallbackClientScript.php, method TCallbackClientScript::setListItems()
Sets the options of a select input element.
setMinChars | in file TAutoComplete.php, method TAutoComplete::setMinChars()
setNavigateUrl in file TActiveHyperLink.php, method TActiveHyperLink::setNavigateUrl()
Sets the URL to link to when the THyperLink component is clicked.
setObserveChanges | in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::setObserveChanges()
setOnComplete | in file TCallbackClientSide.php, method TCallbackClientSide::setOnComplete()
setOnException | in file TCallbackClientSide.php, method TCallbackClientSide::setOnException()
setOnFailure | in file TCallbackClientSide.php, method TCallbackClientSide::setOnFailure()
setOnInteractive | in file TCallbackClientSide.php, method TCallbackClientSide::setOnInteractive()
setOnLoaded | in file TCallbackClientSide.php, method TCallbackClientSide::setOnLoaded()
setOnLoading | in file TCallbackClientSide.php, method TCallbackClientSide::setOnLoading()
setOnPreDispatch | in file TCallbackClientSide.php, method TCallbackClientSide::setOnPreDispatch()
setOnSuccess | in file TCallbackClientSide.php, method TCallbackClientSide::setOnSuccess()
setOnUninitialized | in file TCallbackClientSide.php, method TCallbackClientSide::setOnUninitialized()
setOnValidate in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::setOnValidate()
Client-side OnValidate validator event is raise before the validators validation functions are called.
setOnValidationError in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::setOnValidationError()
Client-side OnError event is raised after validation failure.
setOnValidationSuccess in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::setOnValidationSuccess()
Client-side OnSuccess event is raise after validation is successfull.
setOpacity in file TCallbackClientScript.php, method TCallbackClientScript::setOpacity()
Set the opacity on a html element or control.
setOption in file TBaseActiveControl.php, method TBaseActiveControl::setOption()
Sets a named options with a value. Options are used to store and retrive named values for the base active controls.
setPostBackParameter | in file TCallbackClientSide.php, method TCallbackClientSide::setPostBackParameter()
setPostBackTarget | in file TCallbackClientSide.php, method TCallbackClientSide::setPostBackTarget()
setPostState | in file TCallbackClientSide.php, method TCallbackClientSide::setPostState()
setPreventDefaultAction | in file TEventTriggeredCallback.php, method TEventTriggeredCallback::setPreventDefaultAction()
setPropertyName in file TValueTriggeredCallback.php, method TValueTriggeredCallback::setPropertyName()
Sets the control property name to observe value changes that fires the callback request.
setRating | in file TActiveRatingList.php, method TActiveRatingList::setRating()
setReadOnly | in file TActiveRatingList.php, method TActiveRatingList::setReadOnly()
setReadOnly in file TInPlaceTextBox.php, method TInPlaceTextBox::setReadOnly()
Update ClientSide Readonly property
setRequestTimeOut | in file TCallbackClientSide.php, method TCallbackClientSide::setRequestTimeOut()
setResponseData | in file TCallbackResponseAdapter.php, method TCallbackResponseAdapter::setResponseData()
setResponseData | in file TCallbackEventParameter.php, method TCallbackEventParameter::setResponseData()
setRevert in file TDraggable.php, method TDraggable::setRevert()
Sets whether the draggable element should revert to it orginal position upon release in an non-droppable container.
setSelectedIndex in file TListControl.php, method IListControlAdapter::setSelectedIndex()
Selects an item based on zero-base index on the client side.
setSelectedIndex in file TActiveListControlAdapter.php, method TActiveListControlAdapter::setSelectedIndex()
Selects an item based on zero-base index on the client side.
setSelectedIndices in file TListControl.php, method IListControlAdapter::setSelectedIndices()
Selects a list of item based on zero-base indices on the client side.
setSelectedIndices in file TActiveListControlAdapter.php, method TActiveListControlAdapter::setSelectedIndices()
Selects a list of item based on zero-base indices on the client side.
setSelectedValue in file TListControl.php, method IListControlAdapter::setSelectedValue()
Sets selection by item value on the client side.
setSelectedValue in file TActiveListControlAdapter.php, method TActiveListControlAdapter::setSelectedValue()
Sets selection by item value on the client side.
setSelectedValues in file TActiveListControlAdapter.php, method TActiveListControlAdapter::setSelectedValues()
Sets selection by a list of item values on the client side.
setSelectedValues in file TListControl.php, method IListControlAdapter::setSelectedValues()
Sets selection by a list of item values on the client side.
setSelectionMode in file TActiveListBox.php, method TActiveListBox::setSelectionMode()
Sets the selection mode of the list control (Single, Multiple) on the client-side if the setEnableUpdate property is set to true.
setSeparator | in file TAutoComplete.php, method TAutoComplete::setSeparator()
setStartTimerOnLoad | in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::setStartTimerOnLoad()
setStyle in file TCallbackClientScript.php, method TCallbackClientScript::setStyle()
Sets the style of element. The style must be a key-value array where the key is the style property and the value is the style value.
setTarget in file TActiveHyperLink.php, method TActiveHyperLink::setTarget()
Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.
setTempPath | in file TActiveFileUpload.php, method TActiveFileUpload::setTempPath()
setText in file TActiveDatePicker.php, method TActiveDatePicker::setText()
Client-side Text property can only be updated after the OnLoad stage.
setText in file TActiveHyperLink.php, method TActiveHyperLink::setText()
On callback response, the inner HTMl of the label is updated.
setText in file TActiveRadioButton.php, method TActiveRadioButton::setText()
Updates the button text on the client-side if the setEnableUpdate property is set to true.
setText in file TActiveLabel.php, method TActiveLabel::setText()
On callback response, the inner HTML of the label is updated.
setText in file TActiveLinkButton.php, method TActiveLinkButton::setText()
Updates the link text on the client-side if the setEnableUpdate property is set to true.
setText in file TActiveCheckBox.php, method TActiveCheckBox::setText()
Updates the button text on the client-side if the setEnableUpdate property is set to true.
setText in file TActiveTextBox.php, method TActiveTextBox::setText()
Client-side Text property can only be updated after the OnLoad stage.
setText in file TInPlaceTextBox.php, method TInPlaceTextBox::setText()
On callback response, the inner HTMl of the label and the
setText in file TActiveButton.php, method TActiveButton::setText()
Updates the button text on the client-side if the setEnableUpdate property is set to true.
setTextCssClass | in file TAutoComplete.php, method TAutoComplete::setTextCssClass()
setValidationGroup | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::setValidationGroup()
setValue in file TCallbackClientScript.php, method TCallbackClientScript::setValue()
Client script to set the value of a particular input element.
setValue in file TActiveHiddenField.php, method TActiveHiddenField::setValue()
Client-side Value property can only be updated after the OnLoad stage.
shake in file TCallbackClientScript.php, method TCallbackClientScript::shake()
Visual Effect: Shake the element.
show in file TCallbackClientScript.php, method TCallbackClientScript::show()
Shows an element by changing its CSS display style as empty.
shrink in file TCallbackClientScript.php, method TCallbackClientScript::shrink()
Visual Effect: Shrink the element.
slideDown in file TCallbackClientScript.php, method TCallbackClientScript::slideDown()
Visual Effect: Slide down.
slideUp in file TCallbackClientScript.php, method TCallbackClientScript::slideUp()
Visual Effect: Side up.
squish in file TCallbackClientScript.php, method TCallbackClientScript::squish()
Visual Effect: Squish the element.
startTimer in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::startTimer()
Registers the javascript code to start the timer.
stopTimer in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::stopTimer()
Registers the javascript code to stop the timer.
SuperGhosting | in file TDraggable.php, class constant TDraggableGhostingOptions::SuperGhosting
switchOff in file TCallbackClientScript.php, method TCallbackClientScript::switchOff()
Visual Effect: Switch Off effect.
top
t
TActiveBoundColumn in file TActiveDataGrid.php, class TActiveBoundColumn
TActiveBoundColumn class
TActiveButton in file TActiveButton.php, class TActiveButton
TActiveButton is the active control counter part to TButton.
TActiveButtonColumn in file TActiveDataGrid.php, class TActiveButtonColumn
TActiveButtonColumn class
TActiveCheckBox in file TActiveCheckBox.php, class TActiveCheckBox
TActiveCheckBox class.
TActiveCheckBoxColumn in file TActiveDataGrid.php, class TActiveCheckBoxColumn
TActiveCheckBoxColumn class
TActiveCheckBoxList in file TActiveCheckBoxList.php, class TActiveCheckBoxList
TActiveCheckBoxList class.
TActiveClientScript in file TActiveClientScript.php, class TActiveClientScript
TActiveClientScript class
TActiveControlAdapter in file TActiveControlAdapter.php, class TActiveControlAdapter
TActiveControlAdapter class.
TActiveCustomValidator in file TActiveCustomValidator.php, class TActiveCustomValidator
TActiveCustomValidator Class
TActiveCustomValidatorClientSide in file TActiveCustomValidator.php, class TActiveCustomValidatorClientSide
Custom Validator callback client side options class.
TActiveDataGrid in file TActiveDataGrid.php, class TActiveDataGrid
TActiveDataGrid class
TActiveDataList in file TActiveDataList.php, class TActiveDataList
TActiveDataList class
TActiveDatePicker in file TActiveDatePicker.php, class TActiveDatePicker
TActiveDatePicker class
TActiveDropDownList in file TActiveDropDownList.php, class TActiveDropDownList
TActiveDropDownList class.
TActiveDropDownListColumn in file TActiveDataGrid.php, class TActiveDropDownListColumn
TActiveDropDownListColumn class
TActiveEditCommandColumn in file TActiveDataGrid.php, class TActiveEditCommandColumn
TActiveEditCommandColumn class
TActiveFileUpload in file TActiveFileUpload.php, class TActiveFileUpload
TActiveFileUpload
TActiveFileUploadCallbackParams in file TActiveFileUpload.php, class TActiveFileUploadCallbackParams
TActiveFileUploadCallbackParams is an internal class used by TActiveFileUpload.
TActiveHiddenField in file TActiveHiddenField.php, class TActiveHiddenField
TActiveHiddenField class
TActiveHyperLink in file TActiveHyperLink.php, class TActiveHyperLink
TActiveHyperLink class.
TActiveHyperLinkColumn in file TActiveDataGrid.php, class TActiveHyperLinkColumn
TActiveHyperLinkColumn class
TActiveImage in file TActiveImage.php, class TActiveImage
TActiveImage class.
TActiveImageButton in file TActiveImageButton.php, class TActiveImageButton
TActiveImageButton class.
TActiveLabel in file TActiveLabel.php, class TActiveLabel
TActiveLabel class
TActiveLinkButton in file TActiveLinkButton.php, class TActiveLinkButton
TActiveLinkButton is the active control counter part to TLinkButton.
TActiveListBox in file TActiveListBox.php, class TActiveListBox
TActiveListBox class.
TActiveListControlAdapter in file TActiveListControlAdapter.php, class TActiveListControlAdapter
TActiveListControlAdapter class.
TActiveListItemCollection in file TActiveListControlAdapter.php, class TActiveListItemCollection
TActiveListItemCollection class.
TActiveLiteralColumn in file TActiveDataGrid.php, class TActiveLiteralColumn
TActiveLiteralColumn class
TActiveMultiView in file TActiveMultiView.php, class TActiveMultiView
TActiveMultiView class.
TActivePageAdapter in file TActivePageAdapter.php, class TActivePageAdapter
TActivePageAdapter class.
TActivePager in file TActivePager.php, class TActivePager
TActivePager is the active control counter part of TPager.
TActivePanel in file TActivePanel.php, class TActivePanel
TActivePanel is the TPanel active control counterpart.
TActiveRadioButton in file TActiveRadioButton.php, class TActiveRadioButton
TActiveRadioButton class.
TActiveRadioButtonList in file TActiveRadioButtonList.php, class TActiveRadioButtonList
TActiveRadioButtonList class.
TActiveRatingList in file TActiveRatingList.php, class TActiveRatingList
TActiveRatingList Class
TActiveRepeater in file TActiveRepeater.php, class TActiveRepeater
TActiveRepeater class
TActiveTableCell in file TActiveTableCell.php, class TActiveTableCell
TActiveTableCell class.
TActiveTableCellEventParameter in file TActiveTableCell.php, class TActiveTableCellEventParameter
TActiveTableCellEventParameter class.
TActiveTableRow in file TActiveTableRow.php, class TActiveTableRow
TActiveTableRow class.
TActiveTableRowEventParameter in file TActiveTableRow.php, class TActiveTableRowEventParameter
TActiveTableRowEventParameter class.
TActiveTemplateColumn in file TActiveDataGrid.php, class TActiveTemplateColumn
TActiveTemplateColumn class
TActiveTextBox in file TActiveTextBox.php, class TActiveTextBox
TActiveTextBox class.
TAutoComplete in file TAutoComplete.php, class TAutoComplete
TAutoComplete class.
TAutoCompleteEventParameter in file TAutoComplete.php, class TAutoCompleteEventParameter
TAutCompleteEventParameter contains the getToken requested by the user for a partial match of the suggestions.
TAutoCompleteTemplate in file TAutoComplete.php, class TAutoCompleteTemplate
TAutoCompleteTemplate class.
TBaseActiveCallbackControl in file TBaseActiveControl.php, class TBaseActiveCallbackControl
TBaseActiveCallbackControl is a common set of options and functionality for active controls that can perform callback requests.
TBaseActiveControl in file TBaseActiveControl.php, class TBaseActiveControl
TBaseActiveControl class provided additional basic property for every active control. An instance of TBaseActiveControl or its decendent TBaseActiveCallbackControl is created by TActiveControlAdapter::getBaseActiveControl() method.
TCallback in file TCallback.php, class TCallback
TCallback component class.
TCallbackClientScript in file TCallbackClientScript.php, class TCallbackClientScript
TCallbackClientScript class.
TCallbackClientSide in file TCallbackClientSide.php, class TCallbackClientSide
TCallbackClientSide class.
TCallbackErrorHandler in file TActivePageAdapter.php, class TCallbackErrorHandler
TCallbackErrorHandler class.
TCallbackEventParameter in file TCallbackEventParameter.php, class TCallbackEventParameter
TCallbackEventParameter class.
TCallbackOptions in file TCallbackOptions.php, class TCallbackOptions
TCallbackOptions class.
TCallbackPageStateTracker in file TActiveControlAdapter.php, class TCallbackPageStateTracker
TCallbackPageStateTracker class.
TCallbackResponseAdapter in file TCallbackResponseAdapter.php, class TCallbackResponseAdapter
TCallbackResponseAdapter alters the THttpResponse's outputs.
TCallbackResponseWriter in file TCallbackResponseAdapter.php, class TCallbackResponseWriter
TCallbackResponseWriter class.
TDraggable in file TDraggable.php, class TDraggable
TDraggable is a control which can be dragged
TDraggableConstraint | in file TDraggable.php, class TDraggableConstraint
TDraggableGhostingOptions | in file TDraggable.php, class TDraggableGhostingOptions
TDraggableRevertOptions | in file TDraggable.php, class TDraggableRevertOptions
TDropContainer in file TDropContainer.php, class TDropContainer
TDropContainer is a panel where TDraggable controls can be dropped.
TDropContainerEventParameter in file TDropContainer.php, class TDropContainerEventParameter
TDropContainerEventParameter class
TEventTriggeredCallback in file TEventTriggeredCallback.php, class TEventTriggeredCallback
TEventTriggeredCallback Class
TInPlaceTextBox in file TInPlaceTextBox.php, class TInPlaceTextBox
TInPlaceTextBox Class
TInvalidCallbackException in file TActivePageAdapter.php, class TInvalidCallbackException
TInvalidCallbackException class.
TMapCollectionDiff in file TActiveControlAdapter.php, class TMapCollectionDiff
TAttributesDiff class.
toggle in file TCallbackClientScript.php, method TCallbackClientScript::toggle()
Toggles the visibility of the element.
trackChanges in file TActiveControlAdapter.php, method TCallbackPageStateTracker::trackChanges()
Start tracking view state changes. The clone function on objects are called for those viewstate having an object as value.
trapCallbackErrorsExceptions in file TActivePageAdapter.php, method TActivePageAdapter::trapCallbackErrorsExceptions()
Trap errors and exceptions to be handled by TCallbackErrorHandler.
TScalarDiff in file TActiveControlAdapter.php, class TScalarDiff
TScalarDiff class.
TStyleDiff in file TActiveControlAdapter.php, class TStyleDiff
TStyleDiff class.
TTimeTriggeredCallback in file TTimeTriggeredCallback.php, class TTimeTriggeredCallback
TTimeTriggeredCallback class.
TTriggeredCallback in file TTriggeredCallback.php, class TTriggeredCallback
TTriggeredCallback abstract Class
TValueTriggeredCallback in file TValueTriggeredCallback.php, class TValueTriggeredCallback
TValueTriggeredCallback Class
TViewStateDiff in file TActiveControlAdapter.php, class TViewStateDiff
Calculates the viewstate changes during the request.
TActiveButton.php | procedural page TActiveButton.php
TActiveCheckBox.php | procedural page TActiveCheckBox.php
TActiveCheckBoxList.php | procedural page TActiveCheckBoxList.php
TActiveClientScript.php | procedural page TActiveClientScript.php
TActiveControlAdapter.php | procedural page TActiveControlAdapter.php
TActiveCustomValidator.php | procedural page TActiveCustomValidator.php
TActiveDataGrid.php | procedural page TActiveDataGrid.php
TActiveDataList.php | procedural page TActiveDataList.php
TActiveDatePicker.php | procedural page TActiveDatePicker.php
TActiveDropDownList.php | procedural page TActiveDropDownList.php
TActiveFileUpload.php | procedural page TActiveFileUpload.php
TActiveHiddenField.php | procedural page TActiveHiddenField.php
TActiveHyperLink.php | procedural page TActiveHyperLink.php
TActiveImage.php | procedural page TActiveImage.php
TActiveImageButton.php | procedural page TActiveImageButton.php
TActiveLabel.php | procedural page TActiveLabel.php
TActiveLinkButton.php | procedural page TActiveLinkButton.php
TActiveListBox.php | procedural page TActiveListBox.php
TActiveListControlAdapter.php | procedural page TActiveListControlAdapter.php
TActiveMultiView.php | procedural page TActiveMultiView.php
TActivePageAdapter.php | procedural page TActivePageAdapter.php
TActivePager.php | procedural page TActivePager.php
TActivePanel.php | procedural page TActivePanel.php
TActiveRadioButton.php | procedural page TActiveRadioButton.php
TActiveRadioButtonList.php | procedural page TActiveRadioButtonList.php
TActiveRatingList.php | procedural page TActiveRatingList.php
TActiveRepeater.php | procedural page TActiveRepeater.php
TActiveTableCell.php | procedural page TActiveTableCell.php
TActiveTableRow.php | procedural page TActiveTableRow.php
TActiveTextBox.php | procedural page TActiveTextBox.php
TAutoComplete.php | procedural page TAutoComplete.php
TBaseActiveControl.php | procedural page TBaseActiveControl.php
TCallback.php | procedural page TCallback.php
TCallbackClientScript.php | procedural page TCallbackClientScript.php
TCallbackClientSide.php | procedural page TCallbackClientSide.php
TCallbackEventParameter.php | procedural page TCallbackEventParameter.php
TCallbackOptions.php | procedural page TCallbackOptions.php
TCallbackResponseAdapter.php | procedural page TCallbackResponseAdapter.php
TDraggable.php | procedural page TDraggable.php
TDropContainer.php | procedural page TDropContainer.php
TEventTriggeredCallback.php | procedural page TEventTriggeredCallback.php
TInPlaceTextBox.php | procedural page TInPlaceTextBox.php
TTimeTriggeredCallback.php | procedural page TTimeTriggeredCallback.php
TTriggeredCallback.php | procedural page TTriggeredCallback.php
TValueTriggeredCallback.php | procedural page TValueTriggeredCallback.php
top
u
update in file TCallbackClientScript.php, method TCallbackClientScript::update()
Update the element's innerHTML with new content.
updateAccessKey in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateAccessKey()
Updates the modifier access key
updateAttributes in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateAttributes()
Updates/adds a list of attributes on the control.
updateClientSide in file TActiveListControlAdapter.php, method TActiveListItemCollection::updateClientSide()
Update client-side list items.
updateEnabled in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateEnabled()
Enables or Disables the control on the client-side.
updateListItems in file TActiveListControlAdapter.php, method TActiveListControlAdapter::updateListItems()
Update the client-side list options.
updateStyle in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateStyle()
Updates the CSS style on the control on the client-side.
updateTabIndex in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateTabIndex()
Updates the tab index.
updateToolTip in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateToolTip()
Updates the tooltip.
updateVisible in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateVisible()
Hides or shows the control on the client-side. The control must be already rendered on the client-side.
top
v
Vertical | in file TDraggable.php, class constant TDraggableConstraint::Vertical
visualEffect in file TCallbackClientScript.php, method TCallbackClientScript::visualEffect()
Add a visual effect the element.


Class Trees for Package System.Web.UI.ActiveControls

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TActiveButton.php

File: /Web/UI/ActiveControls/TActiveButton.php

Remarks

TActiveButton class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveButton
TActiveButton is the active control counter part to TButton.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:01 +0200 by phpDocumentor 1.4.3


Docs for page TActiveCheckBox.php

File: /Web/UI/ActiveControls/TActiveCheckBox.php

Remarks

TActiveCheckBox class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveCheckBox.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveCheckBox
TActiveCheckBox class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:01 +0200 by phpDocumentor 1.4.3


Docs for page TActiveCheckBoxList.php

File: /Web/UI/ActiveControls/TActiveCheckBoxList.php

Remarks

TActiveCheckBoxList class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveCheckBoxList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveCheckBoxList
TActiveCheckBoxList class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:02 +0200 by phpDocumentor 1.4.3


Docs for page TActiveClientScript.php

File: /Web/UI/ActiveControls/TActiveClientScript.php

Remarks

TActiveClientScript class file

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveClientScript.php 3144 2012-05-19 10:07:03Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveClientScript
TActiveClientScript class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:03 +0200 by phpDocumentor 1.4.3


Docs for page TActiveControlAdapter.php

File: /Web/UI/ActiveControls/TActiveControlAdapter.php

Remarks

TActiveControlAdapter and TCallbackPageStateTracker class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveControlAdapter.php 3159 2012-06-01 18:01:40Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveControlAdapter
TActiveControlAdapter class.
TCallbackPageStateTracker
TCallbackPageStateTracker class.
TViewStateDiff
Calculates the viewstate changes during the request.
TScalarDiff
TScalarDiff class.
TStyleDiff
TStyleDiff class.
TMapCollectionDiff
TAttributesDiff class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:04 +0200 by phpDocumentor 1.4.3


Docs for page TActiveCustomValidator.php

File: /Web/UI/ActiveControls/TActiveCustomValidator.php

Remarks

TActiveCustomValidator class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveCustomValidator.php 3084 2011-12-21 15:19:37Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveCustomValidator
TActiveCustomValidator Class
TActiveCustomValidatorClientSide
Custom Validator callback client side options class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:04 +0200 by phpDocumentor 1.4.3


Docs for page TActiveDataGrid.php

File: /Web/UI/ActiveControls/TActiveDataGrid.php

Remarks

TActiveDataGrid class file

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

copyright

Copyright &copy; 2009 LANDWEHR Computer und Software GmbH

link

http://www.landwehr-software.de/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveDataGrid
TActiveDataGrid class
TActiveBoundColumn
TActiveBoundColumn class
TActiveEditCommandColumn
TActiveEditCommandColumn class
TActiveButtonColumn
TActiveButtonColumn class
TActiveTemplateColumn
TActiveTemplateColumn class
TActiveHyperLinkColumn
TActiveHyperLinkColumn class
TActiveCheckBoxColumn
TActiveCheckBoxColumn class
TActiveDropDownListColumn
TActiveDropDownListColumn class
TActiveLiteralColumn
TActiveLiteralColumn class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:05 +0200 by phpDocumentor 1.4.3


Docs for page TActiveDataList.php

File: /Web/UI/ActiveControls/TActiveDataList.php

Remarks

TActiveDataList class file

author

Marcos Aurelio Nobre <marconobre@gmail.com>

version

$Id: TActiveDataList.php 2706 2009-09-24 14:42:30Z rojaro $

copyright

Copyright &copy; 2008, PradoSoft

license

http://www.pradosoft.com/license

Classes in this file:
TActiveDataList
TActiveDataList class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:09 +0200 by phpDocumentor 1.4.3


Docs for page TActiveDatePicker.php

File: /Web/UI/ActiveControls/TActiveDatePicker.php

Remarks

TActiveDatePicker class file

author

Christophe Boulain <Christophe.Boulain@gmail.com>

author

Bradley Booms <Bradley.Booms@nsighttel.com>

version

$Id: TActiveDatePicker.php 3145 2012-05-19 11:08:20Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveDatePicker
TActiveDatePicker class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:10 +0200 by phpDocumentor 1.4.3


Docs for page TActiveDropDownList.php

File: /Web/UI/ActiveControls/TActiveDropDownList.php

Remarks

TActiveDropDownList class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveDropDownList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveDropDownList
TActiveDropDownList class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:11 +0200 by phpDocumentor 1.4.3


Docs for page TActiveFileUpload.php

File: /Web/UI/ActiveControls/TActiveFileUpload.php

Remarks

TActiveFileUpload.php

author

Bradley Booms <Bradley.Booms@nsighttel.com>

author

Christophe Boulain <Christophe.Boulain@gmail.com>

author

Gabor Berczi <gabor.berczi@devworx.hu> (issue 349 remote vulnerability fix)

version

$Id: TActiveFileUpload.php 3159 2012-06-01 18:01:40Z ctrlaltca $

Classes in this file:
TActiveFileUpload
TActiveFileUpload
TActiveFileUploadCallbackParams
TActiveFileUploadCallbackParams is an internal class used by TActiveFileUpload.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:12 +0200 by phpDocumentor 1.4.3


Docs for page TActiveHiddenField.php

File: /Web/UI/ActiveControls/TActiveHiddenField.php

Remarks

TActiveHiddenField class file.

author

Carl G. Mathisen <carlgmathisen@gmail.com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveHiddenField
TActiveHiddenField class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:13 +0200 by phpDocumentor 1.4.3


Docs for page TActiveHyperLink.php

File: /Web/UI/ActiveControls/TActiveHyperLink.php

Remarks

TActiveHyperLink class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveHyperLink.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveHyperLink
TActiveHyperLink class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:14 +0200 by phpDocumentor 1.4.3


Docs for page TActiveImage.php

File: /Web/UI/ActiveControls/TActiveImage.php

Remarks

TActiveImage class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveImage.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveImage
TActiveImage class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:15 +0200 by phpDocumentor 1.4.3


Docs for page TActiveImageButton.php

File: /Web/UI/ActiveControls/TActiveImageButton.php

Remarks

TActiveImageButton class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveImageButton.php 3160 2012-06-01 22:30:06Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveImageButton
TActiveImageButton class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:15 +0200 by phpDocumentor 1.4.3


Docs for page TActiveLabel.php

File: /Web/UI/ActiveControls/TActiveLabel.php

Remarks

TActiveLabel class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveLabel.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveLabel
TActiveLabel class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:16 +0200 by phpDocumentor 1.4.3


Docs for page TActiveLinkButton.php

File: /Web/UI/ActiveControls/TActiveLinkButton.php

Remarks

TActiveLinkButton class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveLinkButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveLinkButton
TActiveLinkButton is the active control counter part to TLinkButton.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:16 +0200 by phpDocumentor 1.4.3


Docs for page TActiveListBox.php

File: /Web/UI/ActiveControls/TActiveListBox.php

Remarks

TActiveListBox class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveListBox.php 3125 2012-04-01 20:37:12Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveListBox
TActiveListBox class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:17 +0200 by phpDocumentor 1.4.3


Docs for page TActiveListControlAdapter.php

File: /Web/UI/ActiveControls/TActiveListControlAdapter.php

Remarks

TActiveListControlAdapter class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveListControlAdapter.php 3052 2011-10-21 09:06:19Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveListControlAdapter
TActiveListControlAdapter class.
TActiveListItemCollection
TActiveListItemCollection class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:18 +0200 by phpDocumentor 1.4.3


Docs for page TActiveMultiView.php

File: /Web/UI/ActiveControls/TActiveMultiView.php

Remarks

TActiveMultiView class file

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

copyright

Copyright &copy; 2009 LANDWEHR Computer und Software GmbH

link

http://www.landwehr-software.de/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveMultiView
TActiveMultiView class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:18 +0200 by phpDocumentor 1.4.3


Docs for page TActivePageAdapter.php

File: /Web/UI/ActiveControls/TActivePageAdapter.php

Remarks

TActivePageAdapter, TCallbackErrorHandler and TInvalidCallbackException class file.

author

Gabor Berczi <gabor.berczi@devworx.hu> (lazyload additions & progressive rendering)

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActivePageAdapter.php 3010 2011-07-16 09:28:55Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActivePageAdapter
TActivePageAdapter class.
TCallbackErrorHandler
TCallbackErrorHandler class.
TInvalidCallbackException
TInvalidCallbackException class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:19 +0200 by phpDocumentor 1.4.3


Docs for page TActivePager.php

File: /Web/UI/ActiveControls/TActivePager.php

Remarks

TActivePager class file.

author

"gevik" (forum contributor) and Christophe Boulain (Christophe.Boulain@gmail.com)

version

$Id: TActivePager.php 3145 2012-05-19 11:08:20Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActivePager
TActivePager is the active control counter part of TPager.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:20 +0200 by phpDocumentor 1.4.3


Docs for page TActivePanel.php

File: /Web/UI/ActiveControls/TActivePanel.php

Remarks

TActivePanel file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActivePanel.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActivePanel
TActivePanel is the TPanel active control counterpart.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:20 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRadioButton.php

File: /Web/UI/ActiveControls/TActiveRadioButton.php

Remarks

TActiveRadioButton class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveRadioButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRadioButton
TActiveRadioButton class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:21 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRadioButtonList.php

File: /Web/UI/ActiveControls/TActiveRadioButtonList.php

Remarks

TActiveRadioButtonList class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveRadioButtonList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRadioButtonList
TActiveRadioButtonList class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:22 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRatingList.php

File: /Web/UI/ActiveControls/TActiveRatingList.php

Remarks

TActiveRatingList class file.

author

Bradley Booms <bradley[dot]booms[at]gmail[dot]com>

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRatingList
TActiveRatingList Class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:23 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRepeater.php

File: /Web/UI/ActiveControls/TActiveRepeater.php

Remarks

TActiveRepeater class file

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: TActiveRepeater.php 2707 2009-09-29 10:33:30Z Christophe.Boulain $

since

3.1.9

Classes in this file:
TActiveRepeater
TActiveRepeater class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:27 +0200 by phpDocumentor 1.4.3


Docs for page TActiveTableCell.php

File: /Web/UI/ActiveControls/TActiveTableCell.php

Remarks

TActiveTableCell class file

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id$

copyright

Copyright &copy; 2009 LANDWEHR Computer und Software GmbH

link

http://www.landwehr-software.de/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveTableCell
TActiveTableCell class.
TActiveTableCellEventParameter
TActiveTableCellEventParameter class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:28 +0200 by phpDocumentor 1.4.3


Docs for page TActiveTableRow.php

File: /Web/UI/ActiveControls/TActiveTableRow.php

Remarks

TActiveTableRow and TActiveTableRowEventParameter class file

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id$

copyright

Copyright &copy; 2009 LANDWEHR Computer und Software GmbH

link

http://www.landwehr-software.de/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveTableRow
TActiveTableRow class.
TActiveTableRowEventParameter
TActiveTableRowEventParameter class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:29 +0200 by phpDocumentor 1.4.3


Docs for page TActiveTextBox.php

File: /Web/UI/ActiveControls/TActiveTextBox.php

Remarks

TActiveTextBox class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveTextBox.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveTextBox
TActiveTextBox class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:29 +0200 by phpDocumentor 1.4.3


Docs for page TAutoComplete.php

File: /Web/UI/ActiveControls/TAutoComplete.php

Remarks

TAutoComplete class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TAutoComplete.php 3118 2012-03-24 22:52:29Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TAutoComplete
TAutoComplete class.
TAutoCompleteEventParameter
TAutCompleteEventParameter contains the getToken requested by the user for a partial match of the suggestions.
TAutoCompleteTemplate
TAutoCompleteTemplate class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:33 +0200 by phpDocumentor 1.4.3


Docs for page TBaseActiveControl.php

File: /Web/UI/ActiveControls/TBaseActiveControl.php

Remarks

TBaseActiveControl and TBaseActiveCallbackControl class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TBaseActiveControl.php 3164 2012-06-12 14:39:26Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TBaseActiveControl
TBaseActiveControl class provided additional basic property for every active control. An instance of TBaseActiveControl or its decendent TBaseActiveCallbackControl is created by TActiveControlAdapter::getBaseActiveControl() method.
TBaseActiveCallbackControl
TBaseActiveCallbackControl is a common set of options and functionality for active controls that can perform callback requests.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:34 +0200 by phpDocumentor 1.4.3


Docs for page TCallback.php

File: /Web/UI/ActiveControls/TCallback.php

Remarks

TCallback class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TCallback.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCallback
TCallback component class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:40 +0200 by phpDocumentor 1.4.3


Docs for page TCallbackClientScript.php

File: /Web/UI/ActiveControls/TCallbackClientScript.php

Remarks

TCallbackClientScript class file

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TCallbackClientScript.php 3143 2012-05-18 18:00:24Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCallbackClientScript
TCallbackClientScript class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:41 +0200 by phpDocumentor 1.4.3


Docs for page TCallbackClientSide.php

File: /Web/UI/ActiveControls/TCallbackClientSide.php

Remarks

TCallbackClientSide class file

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TCallbackClientSide.php 3116 2012-03-23 18:15:03Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCallbackClientSide
TCallbackClientSide class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:41 +0200 by phpDocumentor 1.4.3


Docs for page TCallbackEventParameter.php

File: /Web/UI/ActiveControls/TCallbackEventParameter.php

Remarks

TCallbackEventParameter class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCallbackEventParameter
TCallbackEventParameter class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:41 +0200 by phpDocumentor 1.4.3


Docs for page TCallbackOptions.php

File: /Web/UI/ActiveControls/TCallbackOptions.php

Remarks

TCallbackOptions component class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TCallbackOptions.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCallbackOptions
TCallbackOptions class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:42 +0200 by phpDocumentor 1.4.3


Docs for page TCallbackResponseAdapter.php

File: /Web/UI/ActiveControls/TCallbackResponseAdapter.php

Remarks

TCallbackResponseAdapter and TCallbackResponseWriter class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TCallbackResponseAdapter.php 3037 2011-09-06 18:13:31Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCallbackResponseAdapter
TCallbackResponseAdapter alters the THttpResponse's outputs.
TCallbackResponseWriter
TCallbackResponseWriter class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:42 +0200 by phpDocumentor 1.4.3


Docs for page TDraggable.php

File: /Web/UI/ActiveControls/TDraggable.php

Remarks

TDraggable class file

author

Christophe BOULAIN (Christophe.Boulain@gmail.com)

version

$Id: TDraggable.php 3159 2012-06-01 18:01:40Z ctrlaltca $

copyright

Copyright &copy; 2008, PradoSoft

license

http://www.pradosoft.com/license

Classes in this file:
TDraggable
TDraggable is a control which can be dragged
TDraggableConstraint
TDraggableGhostingOptions
TDraggableRevertOptions

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:14 +0200 by phpDocumentor 1.4.3


Docs for page TDropContainer.php

File: /Web/UI/ActiveControls/TDropContainer.php

Remarks

TDropContainer class file

author

Christophe BOULAIN (Christophe.Boulain@gmail.com)

version

$Id: TDropContainer.php 3159 2012-06-01 18:01:40Z ctrlaltca $

copyright

Copyright &copy; 2008, PradoSoft

license

http://www.pradosoft.com/license

Classes in this file:
TDropContainer
TDropContainer is a panel where TDraggable controls can be dropped.
TDropContainerEventParameter
TDropContainerEventParameter class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:15 +0200 by phpDocumentor 1.4.3


Docs for page TEventTriggeredCallback.php

File: /Web/UI/ActiveControls/TEventTriggeredCallback.php

Remarks

TEventTriggeredCallback class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TEventTriggeredCallback.php 3145 2012-05-19 11:08:20Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TEventTriggeredCallback
TEventTriggeredCallback Class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs for page TInPlaceTextBox.php

File: /Web/UI/ActiveControls/TInPlaceTextBox.php

Remarks

TInPlaceTextBox class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TInPlaceTextBox.php 3137 2012-05-10 21:09:10Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TInPlaceTextBox
TInPlaceTextBox Class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:37 +0200 by phpDocumentor 1.4.3


Docs for page TTimeTriggeredCallback.php

File: /Web/UI/ActiveControls/TTimeTriggeredCallback.php

Remarks

TTimeTriggeredCallback class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TTimeTriggeredCallback.php 3145 2012-05-19 11:08:20Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTimeTriggeredCallback
TTimeTriggeredCallback class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:41 +0200 by phpDocumentor 1.4.3


Docs for page TTriggeredCallback.php

File: /Web/UI/ActiveControls/TTriggeredCallback.php

Remarks

TTriggeredCallback class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TTriggeredCallback.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTriggeredCallback
TTriggeredCallback abstract Class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:43 +0200 by phpDocumentor 1.4.3


Docs for page TValueTriggeredCallback.php

File: /Web/UI/ActiveControls/TValueTriggeredCallback.php

Remarks

TValueTriggeredCallback class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TValueTriggeredCallback.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TValueTriggeredCallback
TValueTriggeredCallback Class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:46 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveButton

Class TActiveButton

[line 36]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TButton
               |
               --TActiveButton
Location: /Web/UI/ActiveControls/TActiveButton.php

Remarks

TActiveButton is the active control counter part to TButton.

When a TActiveButton is clicked, rather than a normal post back request a callback request is initiated.

The OnCallback event is raised during a callback request and it is raise after the OnClick event.

When the TBaseActiveCallbackControl::setEnableUpdate property is true, changing the Text property during callback request will update the button's caption upon callback response completion.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActiveButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TButton

  • TButton::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TButton::canCauseValidation()
  • TButton::getButtonType()
  • TButton::getCausesValidation()
  • TButton::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TButton::getCommandName()
  • TButton::getCommandParameter()
  • TButton::getData()
    Returns the caption of the button.
  • TButton::getEnableClientScript()
  • TButton::getIsDefaultButton()
  • TButton::getPostBackOptions()
    Returns postback specifications for the button.
  • TButton::getTagName()
  • TButton::getText()
  • TButton::getValidationGroup()
  • TButton::needPostBackScript()
  • TButton::onClick()
    This method is invoked when the button is clicked.
  • TButton::onCommand()
    This method is invoked when the button is clicked.
  • TButton::raisePostBackEvent()
    Raises the postback event.
  • TButton::renderClientControlScript()
    Renders the client-script code.
  • TButton::renderContents()
    Renders the body content enclosed between the control tag.
  • TButton::setButtonType()
  • TButton::setCausesValidation()
  • TButton::setCommandName()
  • TButton::setCommandParameter()
  • TButton::setData()
    Sets the caption of the button.
  • TButton::setEnableClientScript()
  • TButton::setIsDefaultButton()
  • TButton::setText()
  • TButton::setValidationGroup()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveButton::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveButton::addAttributesToRender

    addAttributesToRender( $writer );

    Overrides TButton::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    access

    protected

    [ Top ]

    TActiveButton::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveButton::getClientClassName

    getClientClassName( );

    Overrides TButton::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    corresponding javascript class name for this TActiveButton.

    access

    protected

    [ Top ]

    TActiveButton::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveButton::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveButton::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by

    ICallbackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick event first and then the OnCallback event. This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveButton::renderClientControlScript

    renderClientControlScript( $writer );

    Overrides TButton::renderClientControlScript() (Renders the client-script code.)

    Parameters

    $writer

    Remarks

    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    access

    protected

    [ Top ]

    TActiveButton::setText

    setText( string $value );

    Overrides TButton::setText() (parent method not documented)

    Parameters

    $value

    caption of the button

    Remarks

    Updates the button text on the client-side if the setEnableUpdate property is set to true.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:01 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveCheckBox

Class TActiveCheckBox

[line 33]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TCheckBox
               |
               --TActiveCheckBox
Location: /Web/UI/ActiveControls/TActiveCheckBox.php

Remarks

TActiveCheckBox class.

The active control counter part to checkbox. The AutoPostBack property is set to true by default. Thus, when the checkbox is clicked a OnCallback event is raise after OnCheckedChanged event.

The Text and Checked properties can be changed during a callback.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveCheckBox.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TCheckBox

  • TCheckBox::getAutoPostBack()
  • TCheckBox::getCausesValidation()
  • TCheckBox::getChecked()
  • TCheckBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TCheckBox::getData()
    Returns the value indicating whether the checkbox is checked.
  • TCheckBox::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TCheckBox::getEnableClientScript()
  • TCheckBox::getInputAttributes()
  • TCheckBox::getIsValid()
    Returns true if this control validated successfully.
  • TCheckBox::getLabelAttributes()
  • TCheckBox::getPostBackOptions()
    Gets the post back options for this checkbox.
  • TCheckBox::getSpanNeeded()
    Check if we need a span tag to surround this control. The span tag will be created if the Text property is set for this control.
  • TCheckBox::getSurroundingTagID()
  • TCheckBox::getTagName()
  • TCheckBox::getText()
  • TCheckBox::getTextAlign()
  • TCheckBox::getValidationGroup()
  • TCheckBox::getValidationPropertyValue()
    Returns the value of the property that needs validation.
  • TCheckBox::getValue()
  • TCheckBox::getValueAttribute()
  • TCheckBox::loadPostData()
    Loads user input data.
  • TCheckBox::onCheckedChanged()
    Raises OnCheckedChanged event when getChecked changes value during postback.
  • TCheckBox::onPreRender()
    Registers the checkbox to receive postback data during postback.
  • TCheckBox::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TCheckBox::render()
    Renders the checkbox control.
  • TCheckBox::renderClientControlScript()
    Renders the client-script code.
  • TCheckBox::renderInputTag()
    Renders a checkbox input element.
  • TCheckBox::renderLabel()
    Renders a label beside the checkbox.
  • TCheckBox::setAutoPostBack()
    Sets a value indicating whether clicking on the checkbox will post the page.
  • TCheckBox::setCausesValidation()
    Sets the value indicating whether postback event trigger by this checkbox will cause input validation.
  • TCheckBox::setChecked()
    Sets a value indicating whether the checkbox is to be checked or not.
  • TCheckBox::setData()
    Sets the value indicating whether the checkbox is to be checked or not.
  • TCheckBox::setEnableClientScript()
  • TCheckBox::setIsValid()
  • TCheckBox::setText()
    Sets the text caption of the checkbox.
  • TCheckBox::setTextAlign()
  • TCheckBox::setValidationGroup()
  • TCheckBox::setValue()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveCheckBox::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveCheckBox::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveCheckBox::getClientClassName

    getClientClassName( );

    Overrides TCheckBox::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    corresponding javascript class name for this TActiveCheckBox.

    access

    protected

    [ Top ]

    TActiveCheckBox::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveCheckBox::getDefaultLabelID

    getDefaultLabelID( );

    Returns

    checkbox label ID;

    access

    protected

    [ Top ]

    TActiveCheckBox::getLabelAttributes

    getLabelAttributes( );

    Overrides TCheckBox::getLabelAttributes() (parent method not documented)

    Returns

    list of attributes to be rendered for label beside the checkbox

    Remarks

    Overrides parent implementation to ensure label has ID.

    access

    public

    [ Top ]

    TActiveCheckBox::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveCheckBox::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by ICallbackEventHandler interface.

    This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveCheckBox::renderClientControlScript

    renderClientControlScript( $writer );

    Overrides TCheckBox::renderClientControlScript() (Renders the client-script code.)

    Parameters

    $writer

    Remarks

    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    access

    protected

    [ Top ]

    TActiveCheckBox::renderInputTag

    renderInputTag( THtmlWriter $writer, string $clientID, string $onclick );

    Overrides TCheckBox::renderInputTag() (Renders a checkbox input element.)

    Parameters

    $writer

    the writer for the rendering purpose

    $clientID

    checkbox id

    $onclick

    onclick js

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    Since 3.1.4, the javascript code is not rendered if AutoPostBack is false

    access

    protected

    [ Top ]

    TActiveCheckBox::renderLabel

    renderLabel( THtmlWriter $writer, string $clientID, string $text );

    Overrides TCheckBox::renderLabel() (Renders a label beside the checkbox.)

    Parameters

    $writer

    the writer for the rendering purpose

    $clientID

    checkbox id

    $text

    label text

    Remarks

    Renders a label beside the checkbox.

    access

    protected

    [ Top ]

    TActiveCheckBox::setChecked

    setChecked( boolean $value );

    Overrides TCheckBox::setChecked() (Sets a value indicating whether the checkbox is to be checked or not.)

    Parameters

    $value

    whether the checkbox is to be checked or not.

    Remarks

    Sets a value indicating whether the checkbox is to be checked or not.

    Updates checkbox checked state on the client-side if the setEnableUpdate property is set to true.

    access

    public

    [ Top ]

    TActiveCheckBox::setText

    setText( string $value );

    Overrides TCheckBox::setText() (Sets the text caption of the checkbox.)

    Parameters

    $value

    caption of the button

    Remarks

    Updates the button text on the client-side if the setEnableUpdate property is set to true.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:01 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveCheckBoxList

Class TActiveCheckBoxList

[line 37]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TCheckBoxList
                     |
                     --TActiveCheckBoxList
Location: /Web/UI/ActiveControls/TActiveCheckBoxList.php

Remarks

TActiveCheckBoxList class.

The active control counter part to checkbox list control. The AutoPostBack property is set to true by default. Thus, when a checkbox is clicked a OnCallback event is raised after OnSelectedIndexChanged event.

With ActiveControl.EnabledUpdate set to true (default is true), changes to the selection will be updated on the client side.

List items can not be changed dynamically during a callback request.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveCheckBoxList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TCheckBoxList

  • TCheckBoxList::__construct()
    Constructor.
  • TCheckBoxList::createRepeatedControl()
    Creates a control used for repetition (used as a template).
  • TCheckBoxList::createStyle()
    Creates a style object for the control.
  • TCheckBoxList::findControl()
    Finds a control by ID.
  • TCheckBoxList::generateItemStyle()
    Returns a style used for rendering items.
  • TCheckBoxList::getCellPadding()
  • TCheckBoxList::getCellSpacing()
  • TCheckBoxList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TCheckBoxList::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TCheckBoxList::getHasFooter()
    Returns a value indicating whether this control contains footer item.
  • TCheckBoxList::getHasHeader()
    Returns a value indicating whether this control contains header item.
  • TCheckBoxList::getHasSeparators()
    Returns a value indicating whether this control contains separator items.
  • TCheckBoxList::getIsMultiSelect()
  • TCheckBoxList::getIsValid()
    Returns true if this control validated successfully.
  • TCheckBoxList::getPostBackOptions()
    Gets the post back options for this checkbox.
  • TCheckBoxList::getRepeatColumns()
  • TCheckBoxList::getRepeatDirection()
  • TCheckBoxList::getRepeatInfo()
  • TCheckBoxList::getRepeatLayout()
  • TCheckBoxList::getSpanNeeded()
    Wether the list should be rendered inside a span or not
  • TCheckBoxList::getTextAlign()
  • TCheckBoxList::getValidationPropertyValue()
    Returns the value to be validated.
  • TCheckBoxList::loadPostData()
    Loads user input data.
  • TCheckBoxList::onPreRender()
    Registers for post data on postback.
  • TCheckBoxList::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TCheckBoxList::render()
    Renders the checkbox list control.
  • TCheckBoxList::renderItem()
    Renders an item in the list.
  • TCheckBoxList::setCellPadding()
    Sets the cellpadding for the table keeping the checkbox list.
  • TCheckBoxList::setCellSpacing()
    Sets the cellspacing for the table keeping the checkbox list.
  • TCheckBoxList::setEnabled()
  • TCheckBoxList::setIsValid()
  • TCheckBoxList::setRepeatColumns()
  • TCheckBoxList::setRepeatDirection()
  • TCheckBoxList::setRepeatLayout()
  • TCheckBoxList::setTextAlign()

Inherited From Class TListControl

  • TListControl::addAttributesToRender()
    Adds attributes to renderer.
  • TListControl::addParsedObject()
    Adds object parsed from template to the control.
  • TListControl::clearSelection()
    Clears all existing selections.
  • TListControl::createListItemCollection()
    Creates a collection object to hold list items.
  • TListControl::formatDataValue()
    Formats the text value according to a format string.
  • TListControl::getAppendDataBoundItems()
  • TListControl::getAutoPostBack()
  • TListControl::getCausesValidation()
  • TListControl::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TListControl::getData()
    Returns the value of the selected item with the lowest cardinal index.
  • TListControl::getDataGroupField()
  • TListControl::getDataTextField()
  • TListControl::getDataTextFormatString()
  • TListControl::getDataValueField()
  • TListControl::getEnableClientScript()
  • TListControl::getHasItems()
  • TListControl::getIsMultiSelect()
  • TListControl::getItemCount()
  • TListControl::getItems()
  • TListControl::getPostBackOptions()
  • TListControl::getPromptText()
  • TListControl::getPromptValue()
  • TListControl::getSelectedIndex()
  • TListControl::getSelectedIndices()
  • TListControl::getSelectedItem()
  • TListControl::getSelectedValue()
  • TListControl::getSelectedValues()
  • TListControl::getTagName()
  • TListControl::getText()
  • TListControl::getValidationGroup()
  • TListControl::loadState()
    Loads items from viewstate.
  • TListControl::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event when selection is changed.
  • TListControl::onTextChanged()
    Raises OnTextChanged event when selection is changed.
  • TListControl::performDataBinding()
    Performs databinding to populate list items from data source.
  • TListControl::renderClientControlScript()
    Renders the javascript for list control.
  • TListControl::renderContents()
    Renders body content of the list control.
  • TListControl::renderPrompt()
    Renders the prompt text, if any.
  • TListControl::saveState()
    Saves items into viewstate.
  • TListControl::setAppendDataBoundItems()
  • TListControl::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TListControl::setCausesValidation()
  • TListControl::setData()
    Selects an item by the specified value.
  • TListControl::setDataGroupField()
  • TListControl::setDataTextField()
  • TListControl::setDataTextFormatString()
    Sets data text format string.
  • TListControl::setDataValueField()
  • TListControl::setEnableClientScript()
  • TListControl::setPromptText()
  • TListControl::setPromptValue()
  • TListControl::setSelectedIndex()
  • TListControl::setSelectedIndices()
  • TListControl::setSelectedValue()
    Sets selection by item value.
  • TListControl::setSelectedValues()
  • TListControl::setText()
  • TListControl::setValidationGroup()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveCheckBoxList::__construct

    __construct( );

    Overrides TCheckBoxList::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveCheckBoxList::createRepeatedControl

    createRepeatedControl( );

    Overrides TCheckBoxList::createRepeatedControl() (Creates a control used for repetition (used as a template).)

    Returns

    the control to be repeated

    Remarks

    Creates a control used for repetition (used as a template).

    access

    protected

    [ Top ]

    TActiveCheckBoxList::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveCheckBoxList::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveCheckBoxList::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveCheckBoxList::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by ICallbackEventHandler interface.

    This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveCheckBoxList::renderClientControlScript

    renderClientControlScript( $writer );

    Overrides TListControl::renderClientControlScript() (Renders the javascript for list control.)

    Parameters

    $writer

    Remarks

    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:02 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveClientScript

Class TActiveClientScript

[line 38]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TClientScript
            |
            --TActiveClientScript
Location: /Web/UI/ActiveControls/TActiveClientScript.php

Remarks

TActiveClientScript class

This is the active counterpart of the TClientScript class.

TActiveClientScript has the ability to render itself on ajax callbacks. This means that every variable or function declared in javascript code will be available to the page.

Beware that when rendered on normal (postback) or ajax callbacks, some javascript code won't behave in the same way. When rendered as part of a normal/postback response, scripts will execute instantly where they are in the page and in a synchronous fashion. Instead, when they are rendered as part of a callback response, they will be executed when all DOM modifications are complete and any dynamic script file includes are loaded, out-of-band and practically all blocks at once, regardless of where they actually occour in the original template/markup code. This can potentially hurt compatibility and graceful fallback.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveClientScript.php 3144 2012-05-19 10:07:03Z ctrlaltca $

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TClientScript

  • TClientScript::getFlushScriptFiles()
  • TClientScript::getPradoScripts()
  • TClientScript::getScriptUrl()
  • TClientScript::onPreRender()
    Calls the client script manager to add each of the requested client script libraries.
  • TClientScript::render()
    Renders the body content as javascript block.
  • TClientScript::renderCustomScript()
    Registers the body content as javascript.
  • TClientScript::renderCustomScriptFile()
    Renders the custom script file.
  • TClientScript::setFlushScriptFiles()
  • TClientScript::setPradoScripts()
    Include javascript library to the current page. The current supported libraries are: "prado", "effects", "ajax", "validator", "logger", "datepicker", "colorpicker". Library dependencies are automatically resolved.
  • TClientScript::setScriptUrl()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveClientScript::renderCustomScript

    renderCustomScript( THtmlWriter $writer );

    Overrides TClientScript::renderCustomScript() (Registers the body content as javascript.)

    Parameters

    $writer

    the renderer

    Remarks

    Registers the body content as javascript.

    access

    protected

    [ Top ]

    TActiveClientScript::renderCustomScriptFile

    renderCustomScriptFile( THtmLWriter $writer );

    Overrides TClientScript::renderCustomScriptFile() (Renders the custom script file.)

    Parameters

    $writer

    the renderer

    Remarks

    Renders the custom script file.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:03 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveControlAdapter

Class TActiveControlAdapter

[line 36]
TComponent
   |
   --TApplicationComponent
      |
      --TControlAdapter
         |
         --TActiveControlAdapter
Classes extended from TActiveControlAdapter:
TActiveListControlAdapter
TActiveListControlAdapter class.

Location: /Web/UI/ActiveControls/TActiveControlAdapter.php

Remarks

TActiveControlAdapter class.

Customize the parent TControl class for active control classes. TActiveControlAdapter instantiates a common base active control class throught the BaseActiveControl property. The type of BaseActiveControl can be provided in the second parameter in the constructor. Default is TBaseActiveControl or TBaseActiveCallbackControl if the control adapted implements ICallbackEventHandler.

TActiveControlAdapter will tracking viewstate changes to update the corresponding client-side properties.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveControlAdapter.php 3159 2012-06-01 18:01:40Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TControlAdapter

  • TControlAdapter::$_control =

Method Summary

Inherited Method Summary

Inherited From Class TControlAdapter

  • TControlAdapter::__construct()
    Constructor.
  • TControlAdapter::createChildControls()
    Creates child controls for the attached control.
  • TControlAdapter::getControl()
  • TControlAdapter::getPage()
  • TControlAdapter::loadState()
    Loads additional persistent control state.
  • TControlAdapter::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControlAdapter::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControlAdapter::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControlAdapter::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControlAdapter::render()
    This method is invoked when the control renders itself.
  • TControlAdapter::renderChildren()
    Renders the control's children.
  • TControlAdapter::saveState()
    Saves additional persistent control state.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveControlAdapter::__construct

    __construct( $control, [string $baseCallbackClass = null] );

    Overrides TControlAdapter::__construct() (Constructor.)

    Parameters

    $control

    active control to adapt.

    $baseCallbackClass

    Base active control class name.

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TActiveControlAdapter::getBaseActiveControl

    getBaseActiveControl( );

    Returns

    Common active control options.

    access

    public

    [ Top ]

    TActiveControlAdapter::getIsTrackingPageState

    getIsTrackingPageState( );

    Returns

    true if the viewstate needs to be tracked.

    access

    protected

    [ Top ]

    TActiveControlAdapter::getStateTracker

    getStateTracker( );

    Returns

    state tracker.

    access

    public

    [ Top ]

    TActiveControlAdapter::onLoad

    onLoad( $param );

    Overrides TControlAdapter::onLoad() (This method is invoked when the control enters 'OnLoad' stage.)

    Parameters

    $param

    Remarks

    Starts viewstate tracking if necessary after when controls has been loaded

    access

    public

    [ Top ]

    TActiveControlAdapter::onPreRender

    onPreRender( $param );

    Overrides TControlAdapter::onPreRender() (This method is invoked when the control enters 'OnPreRender' stage.)

    Parameters

    $param

    Remarks

    Publish the ajax script

    access

    public

    [ Top ]

    TActiveControlAdapter::render

    render( $writer );

    Overrides TControlAdapter::render() (This method is invoked when the control renders itself.)

    Parameters

    $writer

    Remarks

    Renders the callback client scripts.

    access

    public

    [ Top ]

    TActiveControlAdapter::renderCallbackClientScripts

    renderCallbackClientScripts( );

    Remarks

    Register the callback clientscripts and sets the post loader IDs.

    access

    protected

    [ Top ]

    TActiveControlAdapter::saveState

    saveState( );

    Overrides TControlAdapter::saveState() (Saves additional persistent control state.)

    Remarks

    Saves additional persistent control state. Respond to viewstate changes if necessary.

    access

    public

    [ Top ]

    TActiveControlAdapter::setBaseActiveControl

    setBaseActiveControl( TBaseActiveControl $control );

    Parameters

    $control

    change base active control

    access

    public

    [ Top ]

    TActiveControlAdapter::setBaseControlClass

    setBaseControlClass( string $type );

    Parameters

    $type

    base active control instance

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:04 +0200 by phpDocumentor 1.4.3


Docs For Class TCallbackPageStateTracker

Class TCallbackPageStateTracker

[line 204]

Location: /Web/UI/ActiveControls/TActiveControlAdapter.php

Remarks

TCallbackPageStateTracker class.

Tracking changes to the page state during callback.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveControlAdapter.php 3159 2012-06-01 18:01:40Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TCallbackPageStateTracker::__construct

__construct(
TControl
$control );

    Parameters

    $control

    control to track.

    Remarks

    Constructor. Add a set of default states to track.

    access

    public

    [ Top ]

    TCallbackPageStateTracker::addStatesToTrack

addStatesToTrack(
 );

    Remarks

    Add a list of view states to track. Each state is added  to the StatesToTrack property with the view state name as key.

    The value should be an array with two enteries. The first entery  is the name of the class that will calculate the state differences.  The second entry is a php function/method callback that handles  the changes in the viewstate.

    access

    protected

    [ Top ]

    TCallbackPageStateTracker::client

client(
 );

    Returns

    callback client scripting

    access

    protected

    [ Top ]

    TCallbackPageStateTracker::getChanges

getChanges(
 );

    Returns

    list of viewstate and the changed data.

    access

    protected

    [ Top ]

    TCallbackPageStateTracker::getStatesToTrack

getStatesToTrack(
 );

    Returns

    list of viewstates to track.

    access

    protected

    [ Top ]

    TCallbackPageStateTracker::respondToChanges

respondToChanges(
 );

    Remarks

    For each of the changes call the corresponding change handlers.

    access

    public

    [ Top ]

    TCallbackPageStateTracker::trackChanges

trackChanges(
 );

    Remarks

    Start tracking view state changes. The clone function on objects are called  for those viewstate having an object as value.

    access

    public

    [ Top ]

    TCallbackPageStateTracker::updateAccessKey

updateAccessKey(
string
$value );

    Parameters

    $value

    access key

    Remarks

    Updates the modifier access key

    access

    protected

    [ Top ]

    TCallbackPageStateTracker::updateAttributes

updateAttributes(
array
$attributes );

    Parameters

    $attributes

    list of attribute name-value pairs.

    Remarks

    Updates/adds a list of attributes on the control.

    access

    protected

    [ Top ]

    TCallbackPageStateTracker::updateEnabled

updateEnabled(
boolean
$enable );

    Parameters

    $enable

    true to enable the control, false to disable.

    Remarks

    Enables or Disables the control on the client-side.

    access

    protected

    [ Top ]

    TCallbackPageStateTracker::updateStyle

updateStyle(
array
$style );

    Parameters

    $style

    list of new CSS style declarations.

    Remarks

    Updates the CSS style on the control on the client-side.

    access

    protected

    [ Top ]

    TCallbackPageStateTracker::updateTabIndex

updateTabIndex(
integer
$value );

    Parameters

    $value

    tab index

    Remarks

    Updates the tab index.

    access

    protected

    [ Top ]

    TCallbackPageStateTracker::updateToolTip

updateToolTip(
string
$value );

    Parameters

    $value

    new tooltip

    Remarks

    Updates the tooltip.

    access

    protected

    [ Top ]

    TCallbackPageStateTracker::updateVisible

updateVisible(
boolean
$visible );

    Parameters

    $visible

    true to show the control, false to hide.

    Remarks

    Hides or shows the control on the client-side. The control must be  already rendered on the client-side.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:04 +0200 by phpDocumentor 1.4.3


Docs For Class TMapCollectionDiff

Class TMapCollectionDiff

[line 555]
TViewStateDiff
   |
   --TMapCollectionDiff
Location: /Web/UI/ActiveControls/TActiveControlAdapter.php

Remarks

TAttributesDiff class.

Calculate the changes to attributes collection.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveControlAdapter.php 3159 2012-06-01 18:01:40Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TViewStateDiff

  • TViewStateDiff::$_new =
  • TViewStateDiff::$_null =
  • TViewStateDiff::$_old =

Method Summary

Inherited Method Summary

Inherited From Class TViewStateDiff

  • TViewStateDiff::__construct()
    Constructor.
  • TViewStateDiff::getDifference()

Method Detail

    TMapCollectionDiff::getDifference

    getDifference( );

    Overrides TViewStateDiff::getDifference() (parent method not documented)

    Returns

    updates to the attributes collection.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:04 +0200 by phpDocumentor 1.4.3


Docs For Class TScalarDiff

Class TScalarDiff

[line 438]
TViewStateDiff
   |
   --TScalarDiff
Location: /Web/UI/ActiveControls/TActiveControlAdapter.php

Remarks

TScalarDiff class.

Calculate the changes to a scalar value.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveControlAdapter.php 3159 2012-06-01 18:01:40Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TViewStateDiff

  • TViewStateDiff::$_new =
  • TViewStateDiff::$_null =
  • TViewStateDiff::$_old =

Method Summary

Inherited Method Summary

Inherited From Class TViewStateDiff

  • TViewStateDiff::__construct()
    Constructor.
  • TViewStateDiff::getDifference()

Method Detail

    TScalarDiff::getDifference

    getDifference( );

    Overrides TViewStateDiff::getDifference() (parent method not documented)

    Returns

    update viewstate value.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:04 +0200 by phpDocumentor 1.4.3


Docs For Class TStyleDiff

Class TStyleDiff

[line 463]
TViewStateDiff
   |
   --TStyleDiff
Location: /Web/UI/ActiveControls/TActiveControlAdapter.php

Remarks

TStyleDiff class.

Calculates the changes to the Style properties.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveControlAdapter.php 3159 2012-06-01 18:01:40Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TViewStateDiff

  • TViewStateDiff::$_new =
  • TViewStateDiff::$_null =
  • TViewStateDiff::$_old =

Method Summary

Inherited Method Summary

Inherited From Class TViewStateDiff

  • TViewStateDiff::__construct()
    Constructor.
  • TViewStateDiff::getDifference()

Method Detail

    TStyleDiff::getCombinedStyle

    getCombinedStyle( TStyle $obj );

    Parameters

    $obj

    control style

    Returns

    all the style properties combined.

    access

    protected

    [ Top ]

    TStyleDiff::getCssClassDiff

    getCssClassDiff( );

    Returns

    changes to the CSS class name.

    access

    protected

    [ Top ]

    TStyleDiff::getDifference

    getDifference( );

    Overrides TViewStateDiff::getDifference() (parent method not documented)

    Returns

    list of changes to the control style and CSS class name.

    access

    public

    [ Top ]

    TStyleDiff::getStyleDiff

    getStyleDiff( );

    Returns

    list of changes to the control style.

    access

    protected

    [ Top ]

    TStyleDiff::getStyleFromString

    getStyleFromString( string $string, array 1 );

    Parameters

    1

    CSS style as name-value array.

    $string

    CSS custom style string.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:04 +0200 by phpDocumentor 1.4.3


Docs For Class TViewStateDiff

Class TViewStateDiff

[line 394]

Classes extended from TViewStateDiff:

TScalarDiff

TScalarDiff class.

TStyleDiff

TStyleDiff class.

TMapCollectionDiff

TAttributesDiff class.

Location: /Web/UI/ActiveControls/TActiveControlAdapter.php

Remarks

Calculates the viewstate changes during the request.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveControlAdapter.php 3159 2012-06-01 18:01:40Z ctrlaltca $

abstract

since

3.1

Class Variable Summary

  • $_new =

  • $_null =

  • $_old =

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TViewStateDiff::__construct

__construct(
mixed
$new, mixed
$old, object representing
$null );

    Parameters

    $new

    updated viewstate value.

    $old

    viewstate value at the begining of the request.

    $null

    the null value.

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TViewStateDiff::getDifference

getDifference(
 );

    Overridden in child classes as:

    TScalarDiff::getDifference()

    TStyleDiff::getDifference()

    TMapCollectionDiff::getDifference()

    Returns

    view state changes, nullObject if no difference.

    abstract

    access

    public

    [ Top ]

Variable Detail

  • $_new =  [line 399]
    •

  • Data type: mixed
    •

    var

    updated viewstate

    access

    protected

  • $_null =  [line 407]
    •

  • Data type: object null
    •

    var

    value.

    access

    protected

  • $_old =  [line 403]
    •

  • Data type: mixed
    •

    var

    viewstate value at the begining of the request.

    access

    protected

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:04 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveCustomValidator

Class TActiveCustomValidator

[line 35]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TCustomValidator
                     |
                     --TActiveCustomValidator
Location: /Web/UI/ActiveControls/TActiveCustomValidator.php

Remarks

TActiveCustomValidator Class

Performs custom validation using only server-side onServerValidate validation event. The client-side uses callbacks to raise the onServerValidate event.

Beware that the onServerValidate may be raised when the control to validate on the client side changes value, that is, the server validation may be called many times.

After the callback or postback, the onServerValidate is raised once more. The IsCallback property will be true when validation is made during a callback request.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveCustomValidator.php 3084 2011-12-21 15:19:37Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TCustomValidator

  • TCustomValidator::evaluateIsValid()
    This method overrides the parent's implementation.
  • TCustomValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
  • TCustomValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
  • TCustomValidator::getClientValidationFunction()
  • TCustomValidator::getValidationTarget()
  • TCustomValidator::onServerValidate()
    This method is invoked when the server side validation happens.
  • TCustomValidator::registerClientScriptValidator()
    Only register the client-side validator if setClientValidationFunction is set.
  • TCustomValidator::setClientValidationFunction()
    Sets the name of the custom client-side script function used for validation.

Inherited From Class TBaseValidator

  • TBaseValidator::__construct()
    Constructor.
  • TBaseValidator::addAttributesToRender()
    Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
  • TBaseValidator::createClientSide()
  • TBaseValidator::evaluateIsValid()
    This is the major method for validation.
  • TBaseValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
  • TBaseValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
  • TBaseValidator::getClientSide()
    Gets the TValidatorClientSide that allows modification of the client- side validator events.
  • TBaseValidator::getControlCssClass()
  • TBaseValidator::getControlToValidate()
  • TBaseValidator::getDisplay()
  • TBaseValidator::getEnableClientScript()
  • TBaseValidator::getErrorMessage()
  • TBaseValidator::getFocusElementID()
    Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::getFocusOnError()
  • TBaseValidator::getIsValid()
  • TBaseValidator::getValidationGroup()
  • TBaseValidator::getValidationTarget()
  • TBaseValidator::getValidationValue()
    Retrieves the property value of the control being validated.
  • TBaseValidator::onInit()
    Registers the validator with page.
  • TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
  • TBaseValidator::onUnload()
    Unregisters the validator from page.
  • TBaseValidator::onValidate()
    This event is raised right before the validator starts to perform validation.
  • TBaseValidator::onValidationError()
    This event is raised when the validator fails in validation.
  • TBaseValidator::onValidationSuccess()
    This event is raised when the validator succeeds in validation.
  • TBaseValidator::registerClientScriptValidator()
    Registers the individual validator client-side javascript code.
  • TBaseValidator::renderClientControlScript()
    Renders the javascript code to the end script.
  • TBaseValidator::renderContents()
    Renders the validator control.
  • TBaseValidator::setControlCssClass()
  • TBaseValidator::setControlToValidate()
    Sets the ID path of the input control to validate.
  • TBaseValidator::setDisplay()
  • TBaseValidator::setEnableClientScript()
  • TBaseValidator::setEnabled()
    This method overrides parent's implementation by setting setIsValid to true if disabled.
  • TBaseValidator::setErrorMessage()
    Sets the text for the error message.
  • TBaseValidator::setFocusElementID()
    Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
  • TBaseValidator::setFocusOnError()
  • TBaseValidator::setForControl()
    This method overrides the parent implementation to forbid setting ForControl.
  • TBaseValidator::setIsValid()
    Sets the value indicating whether the validation succeeds
  • TBaseValidator::setValidationGroup()
  • TBaseValidator::updateControlCssClass()
    Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
  • TBaseValidator::validate()
    Validates the specified control.

Inherited From Class TLabel

  • TLabel::addAttributesToRender()
    Adds attributes to renderer.
  • TLabel::getData()
    Returns the text value of the label.
  • TLabel::getForControl()
  • TLabel::getTagName()
  • TLabel::getText()
  • TLabel::render()
    Renders the label.
  • TLabel::renderContents()
    Renders the body content of the label.
  • TLabel::setData()
    Sets the text value of the label.
  • TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
  • TLabel::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveCustomValidator::__construct

    __construct( );

    Overrides TBaseValidator::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveCustomValidator::addAttributesToRender

    addAttributesToRender( $writer );

    Overrides TBaseValidator::addAttributesToRender() (Adds attributes to renderer. Calls parent implementation and renders the client control scripts.)

    Parameters

    $writer

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    access

    protected

    [ Top ]

    TActiveCustomValidator::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveCustomValidator::getClientClassName

    getClientClassName( );

    Overrides TCustomValidator::getClientClassName() (Gets the name of the javascript class responsible for performing validation for this control.)

    Returns

    corresponding javascript class name for this this.

    access

    protected

    [ Top ]

    TActiveCustomValidator::getClientScriptOptions

    getClientScriptOptions( );

    Overrides TCustomValidator::getClientScriptOptions() (Returns an array of javascript validator options.)

    Returns

    javascript validator options.

    Remarks

    Returns an array of javascript validator options.

    access

    protected

    [ Top ]

    TActiveCustomValidator::getClientSide

    getClientSide( );

    Overrides TBaseValidator::getClientSide() (Gets the TValidatorClientSide that allows modification of the client- side validator events.)

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveCustomValidator::getEnableClientScript

    getEnableClientScript( );

    Overrides TBaseValidator::getEnableClientScript() (parent method not documented)

    Returns

    whether client-side validation is enabled.

    Remarks

    It's mandatory for the EnableClientScript to be activated or the TActiveCustomValidator won't work.

    access

    public

    [ Top ]

    TActiveCustomValidator::getIsCallback

    getIsCallback( );

    Returns

    true if validation is made during a callback request.

    access

    public

    [ Top ]

    TActiveCustomValidator::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveCustomValidator::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by ICallbackEventHandler interface. The onServerValidate event is raised first and then the onCallback event.

    This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveCustomValidator::setClientValidationFunction

    setClientValidationFunction( $value );

    Overrides TCustomValidator::setClientValidationFunction() (Sets the name of the custom client-side script function used for validation.)

    Parameters

    $value

    Remarks

    Client validation function is NOT supported.

    access

    public

    [ Top ]

    TActiveCustomValidator::setErrorMessage

    setErrorMessage( string $value );

    Overrides TBaseValidator::setErrorMessage() (Sets the text for the error message.)

    Parameters

    $value

    the error message

    Remarks

    Sets the text for the error message. Updates client-side erorr message.

    access

    public

    [ Top ]

    TActiveCustomValidator::setIsValid

    setIsValid( boolean $value );

    Overrides TBaseValidator::setIsValid() (Sets the value indicating whether the validation succeeds)

    Parameters

    $value

    whether the value is valid; this method will trigger a clientside update if needed

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:04 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveCustomValidatorClientSide

Class TActiveCustomValidatorClientSide

[line 193]
TComponent
   |
   --TClientSideOptions
      |
      --TCallbackClientSide
         |
         --TActiveCustomValidatorClientSide
Location: /Web/UI/ActiveControls/TActiveCustomValidator.php

Remarks

Custom Validator callback client side options class.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveCustomValidator.php 3084 2011-12-21 15:19:37Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TCallbackClientSide

  • TCallbackClientSide::ensureFunction()
    Returns javascript statement enclosed within a javascript function.
  • TCallbackClientSide::getEnablePageStateUpdate()
  • TCallbackClientSide::getHasPriority()
  • TCallbackClientSide::getOnComplete()
  • TCallbackClientSide::getOnException()
  • TCallbackClientSide::getOnFailure()
  • TCallbackClientSide::getOnInteractive()
  • TCallbackClientSide::getOnLoaded()
  • TCallbackClientSide::getOnLoading()
  • TCallbackClientSide::getOnPreDispatch()
  • TCallbackClientSide::getOnSuccess()
  • TCallbackClientSide::getOnUninitialized()
  • TCallbackClientSide::getPostBackParameter()
  • TCallbackClientSide::getPostBackTarget()
  • TCallbackClientSide::getPostState()
  • TCallbackClientSide::getRequestTimeOut()
  • TCallbackClientSide::setEnablePageStateUpdate()
    Set to true to enable the callback response to enable the viewstate update. This will automatically set HasPrority to true.
  • TCallbackClientSide::setHasPriority()
  • TCallbackClientSide::setOnComplete()
  • TCallbackClientSide::setOnException()
  • TCallbackClientSide::setOnFailure()
  • TCallbackClientSide::setOnInteractive()
  • TCallbackClientSide::setOnLoaded()
  • TCallbackClientSide::setOnLoading()
  • TCallbackClientSide::setOnPreDispatch()
  • TCallbackClientSide::setOnSuccess()
  • TCallbackClientSide::setOnUninitialized()
  • TCallbackClientSide::setPostBackParameter()
  • TCallbackClientSide::setPostBackTarget()
  • TCallbackClientSide::setPostState()
  • TCallbackClientSide::setRequestTimeOut()

Inherited From Class TClientSideOptions

  • TClientSideOptions::__construct()
    Constructor, initialize the options list.
  • TClientSideOptions::ensureFunction()
    Ensure that the javascript statements are wrapped in a javascript function block as
  • function(sender, parameter){ //code }
    •
    .
  • TClientSideOptions::getOption()
  • TClientSideOptions::getOptions()
  • TClientSideOptions::setFunction()
    Adds on client-side event handler by wrapping the code within a javascript function block. If the code begins with "javascript:", the code is assumed to be a javascript function block rather than arbiturary javascript statements.
  • TClientSideOptions::setOption()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveCustomValidatorClientSide::getObserveChanges

    getObserveChanges( );

    Returns

    true to observe changes.

    access

    public

    [ Top ]

    TActiveCustomValidatorClientSide::getOnValidate

    getOnValidate( );

    Returns

    javascript code for client-side OnValidate event.

    access

    public

    [ Top ]

    TActiveCustomValidatorClientSide::getOnValidationError

    getOnValidationError( );

    Returns

    javascript code for client-side OnError event.

    access

    public

    [ Top ]

    TActiveCustomValidatorClientSide::getOnValidationSuccess

    getOnValidationSuccess( );

    Returns

    javascript code for client-side OnSuccess event.

    access

    public

    [ Top ]

    TActiveCustomValidatorClientSide::setObserveChanges

    setObserveChanges( boolean $value );

    Parameters

    $value

    true to revalidate when the control to validate changes value.

    access

    public

    [ Top ]

    TActiveCustomValidatorClientSide::setOnValidate

    setOnValidate( string $javascript );

    Parameters

    $javascript

    javascript code for client-side OnValidate event.

    Remarks

    Client-side OnValidate validator event is raise before the validators validation functions are called.

    access

    public

    [ Top ]

    TActiveCustomValidatorClientSide::setOnValidationError

    setOnValidationError( string $javascript );

    Parameters

    $javascript

    javascript code for client-side OnError event.

    Remarks

    Client-side OnError event is raised after validation failure.

    This will override the default client-side validator behaviour.

    access

    public

    [ Top ]

    TActiveCustomValidatorClientSide::setOnValidationSuccess

    setOnValidationSuccess( string $javascript );

    Parameters

    $javascript

    javascript code for client-side OnSuccess event.

    Remarks

    Client-side OnSuccess event is raise after validation is successfull.

    This will override the default client-side validator behaviour.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:05 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveBoundColumn

Class TActiveBoundColumn

[line 199]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TBoundColumn
            |
            --TActiveBoundColumn
Location: /Web/UI/ActiveControls/TActiveDataGrid.php

Remarks

TActiveBoundColumn class

TActiveBoundColumn represents a column that is bound to a field in a data source. The cells in the column will be displayed using the data indexed by DataField. You can customize the display by setting DataFormatString.

This is the active counterpart to the TBoundColumn control. For that purpose, if sorting is allowed, the header links/buttons are replaced by active controls.

Please refer to the original documentation of the TBoundColumn for usage.

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: TBoundColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.9

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TBoundColumn

  • TBoundColumn::dataBindColumn()
    Databinds a cell in the column.
  • TBoundColumn::getDataField()
  • TBoundColumn::getDataFormatString()
  • TBoundColumn::getEditItemRenderer()
  • TBoundColumn::getItemRenderer()
  • TBoundColumn::getReadOnly()
  • TBoundColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TBoundColumn::setDataField()
  • TBoundColumn::setDataFormatString()
  • TBoundColumn::setEditItemRenderer()
    Sets the edit item cell renderer class.
  • TBoundColumn::setItemRenderer()
    Sets the item cell renderer class.
  • TBoundColumn::setReadOnly()

Inherited From Class TDataGridColumn

  • TDataGridColumn::formatDataValue()
    Formats the text value according to a format string.
  • TDataGridColumn::getAllowSorting()
    Returns a value indicating whether this column allows sorting.
  • TDataGridColumn::getDataFieldValue()
    Fetches the value of the data at the specified field.
  • TDataGridColumn::getEnableCellGrouping()
  • TDataGridColumn::getFooterRenderer()
  • TDataGridColumn::getFooterStyle()
  • TDataGridColumn::getFooterText()
  • TDataGridColumn::getHeaderImageUrl()
  • TDataGridColumn::getHeaderRenderer()
  • TDataGridColumn::getHeaderStyle()
  • TDataGridColumn::getHeaderText()
  • TDataGridColumn::getID()
  • TDataGridColumn::getItemStyle()
  • TDataGridColumn::getOwner()
  • TDataGridColumn::getSortExpression()
  • TDataGridColumn::getViewState()
    Returns a viewstate value.
  • TDataGridColumn::getVisible()
  • TDataGridColumn::initialize()
    Initializes the column.
  • TDataGridColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TDataGridColumn::initializeFooterCell()
    Initializes the footer cell.
  • TDataGridColumn::initializeHeaderCell()
    Initializes the header cell.
  • TDataGridColumn::loadState()
    Loads persistent state values.
  • TDataGridColumn::saveState()
    Saves persistent state values.
  • TDataGridColumn::setEnableCellGrouping()
  • TDataGridColumn::setFooterRenderer()
    Sets the column footer cell renderer class.
  • TDataGridColumn::setFooterText()
  • TDataGridColumn::setHeaderImageUrl()
  • TDataGridColumn::setHeaderRenderer()
    Sets the column header cell renderer class.
  • TDataGridColumn::setHeaderText()
  • TDataGridColumn::setID()
    Sets the ID of the column.
  • TDataGridColumn::setOwner()
  • TDataGridColumn::setSortExpression()
  • TDataGridColumn::setViewState()
    Sets a viewstate value.
  • TDataGridColumn::setVisible()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveBoundColumn::initializeHeaderCell

    initializeHeaderCell( $cell, $columnIndex );

    Overrides TDataGridColumn::initializeHeaderCell() (Initializes the header cell.)

    Parameters

    $cell

    $columnIndex

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:05 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveButtonColumn

Class TActiveButtonColumn

[line 320]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TButtonColumn
            |
            --TActiveButtonColumn
Location: /Web/UI/ActiveControls/TActiveDataGrid.php

Remarks

TActiveButtonColumn class

TActiveButtonColumn contains a user-defined command button, such as Add or Remove, that corresponds with each row in the column.

This is the active counterpart to the TButtonColumn control where the button is replaced by the appropriate active button control.

Please refer to the original documentation of the TButtonColumn for usage.

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: TButtonColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.9

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TButtonColumn

  • TButtonColumn::dataBindColumn()
    Databinds a cell in the column.
  • TButtonColumn::getButtonType()
  • TButtonColumn::getCausesValidation()
  • TButtonColumn::getCommandName()
  • TButtonColumn::getDataImageUrlField()
  • TButtonColumn::getDataImageUrlFormatString()
  • TButtonColumn::getDataTextField()
  • TButtonColumn::getDataTextFormatString()
  • TButtonColumn::getImageUrl()
  • TButtonColumn::getText()
  • TButtonColumn::getValidationGroup()
  • TButtonColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TButtonColumn::setButtonType()
  • TButtonColumn::setCausesValidation()
  • TButtonColumn::setCommandName()
    Sets the command name associated with the Command event.
  • TButtonColumn::setDataImageUrlField()
  • TButtonColumn::setDataImageUrlFormatString()
  • TButtonColumn::setDataTextField()
  • TButtonColumn::setDataTextFormatString()
  • TButtonColumn::setImageUrl()
  • TButtonColumn::setText()
    Sets the text caption of the button.
  • TButtonColumn::setValidationGroup()

Inherited From Class TDataGridColumn

  • TDataGridColumn::formatDataValue()
    Formats the text value according to a format string.
  • TDataGridColumn::getAllowSorting()
    Returns a value indicating whether this column allows sorting.
  • TDataGridColumn::getDataFieldValue()
    Fetches the value of the data at the specified field.
  • TDataGridColumn::getEnableCellGrouping()
  • TDataGridColumn::getFooterRenderer()
  • TDataGridColumn::getFooterStyle()
  • TDataGridColumn::getFooterText()
  • TDataGridColumn::getHeaderImageUrl()
  • TDataGridColumn::getHeaderRenderer()
  • TDataGridColumn::getHeaderStyle()
  • TDataGridColumn::getHeaderText()
  • TDataGridColumn::getID()
  • TDataGridColumn::getItemStyle()
  • TDataGridColumn::getOwner()
  • TDataGridColumn::getSortExpression()
  • TDataGridColumn::getViewState()
    Returns a viewstate value.
  • TDataGridColumn::getVisible()
  • TDataGridColumn::initialize()
    Initializes the column.
  • TDataGridColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TDataGridColumn::initializeFooterCell()
    Initializes the footer cell.
  • TDataGridColumn::initializeHeaderCell()
    Initializes the header cell.
  • TDataGridColumn::loadState()
    Loads persistent state values.
  • TDataGridColumn::saveState()
    Saves persistent state values.
  • TDataGridColumn::setEnableCellGrouping()
  • TDataGridColumn::setFooterRenderer()
    Sets the column footer cell renderer class.
  • TDataGridColumn::setFooterText()
  • TDataGridColumn::setHeaderImageUrl()
  • TDataGridColumn::setHeaderRenderer()
    Sets the column header cell renderer class.
  • TDataGridColumn::setHeaderText()
  • TDataGridColumn::setID()
    Sets the ID of the column.
  • TDataGridColumn::setOwner()
  • TDataGridColumn::setSortExpression()
  • TDataGridColumn::setViewState()
    Sets a viewstate value.
  • TDataGridColumn::setVisible()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveButtonColumn::initializeCell

    initializeCell( $cell, $columnIndex, $itemType );

    Overrides TButtonColumn::initializeCell() (Initializes the specified cell to its initial values.)

    Parameters

    $cell

    $columnIndex

    $itemType

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:06 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveCheckBoxColumn

Class TActiveCheckBoxColumn

[line 516]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TCheckBoxColumn
            |
            --TActiveCheckBoxColumn
Location: /Web/UI/ActiveControls/TActiveDataGrid.php

Remarks

TActiveCheckBoxColumn class

TActiveCheckBoxColumn represents a checkbox column that is bound to a field in a data source.

This is the active counterpart to the TCheckBoxColumn control. For that purpose, if sorting is allowed, the header links/buttons are replaced by active controls.

Please refer to the original documentation of the TCheckBoxColumn for usage.

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: TCheckBoxColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.9

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TCheckBoxColumn

  • TCheckBoxColumn::dataBindColumn()
    Databinds a cell in the column.
  • TCheckBoxColumn::getDataField()
  • TCheckBoxColumn::getReadOnly()
  • TCheckBoxColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TCheckBoxColumn::setDataField()
  • TCheckBoxColumn::setReadOnly()

Inherited From Class TDataGridColumn

  • TDataGridColumn::formatDataValue()
    Formats the text value according to a format string.
  • TDataGridColumn::getAllowSorting()
    Returns a value indicating whether this column allows sorting.
  • TDataGridColumn::getDataFieldValue()
    Fetches the value of the data at the specified field.
  • TDataGridColumn::getEnableCellGrouping()
  • TDataGridColumn::getFooterRenderer()
  • TDataGridColumn::getFooterStyle()
  • TDataGridColumn::getFooterText()
  • TDataGridColumn::getHeaderImageUrl()
  • TDataGridColumn::getHeaderRenderer()
  • TDataGridColumn::getHeaderStyle()
  • TDataGridColumn::getHeaderText()
  • TDataGridColumn::getID()
  • TDataGridColumn::getItemStyle()
  • TDataGridColumn::getOwner()
  • TDataGridColumn::getSortExpression()
  • TDataGridColumn::getViewState()
    Returns a viewstate value.
  • TDataGridColumn::getVisible()
  • TDataGridColumn::initialize()
    Initializes the column.
  • TDataGridColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TDataGridColumn::initializeFooterCell()
    Initializes the footer cell.
  • TDataGridColumn::initializeHeaderCell()
    Initializes the header cell.
  • TDataGridColumn::loadState()
    Loads persistent state values.
  • TDataGridColumn::saveState()
    Saves persistent state values.
  • TDataGridColumn::setEnableCellGrouping()
  • TDataGridColumn::setFooterRenderer()
    Sets the column footer cell renderer class.
  • TDataGridColumn::setFooterText()
  • TDataGridColumn::setHeaderImageUrl()
  • TDataGridColumn::setHeaderRenderer()
    Sets the column header cell renderer class.
  • TDataGridColumn::setHeaderText()
  • TDataGridColumn::setID()
    Sets the ID of the column.
  • TDataGridColumn::setOwner()
  • TDataGridColumn::setSortExpression()
  • TDataGridColumn::setViewState()
    Sets a viewstate value.
  • TDataGridColumn::setVisible()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveCheckBoxColumn::initializeCell

    initializeCell( TTableCell $cell, integer $columnIndex, string $itemType );

    Overrides TCheckBoxColumn::initializeCell() (Initializes the specified cell to its initial values.)

    Parameters

    $cell

    the cell to be initialized.

    $columnIndex

    the index to the Columns property that the cell resides in.

    $itemType

    the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)

    Remarks

    Initializes the specified cell to its initial values.

    This method overrides the parent implementation. It creates a checkbox inside the cell. If the column is read-only or if the item is not in edit mode, the checkbox will be set disabled.

    access

    public

    [ Top ]

    TActiveCheckBoxColumn::initializeHeaderCell

    initializeHeaderCell( $cell, $columnIndex );

    Overrides TDataGridColumn::initializeHeaderCell() (Initializes the header cell.)

    Parameters

    $cell

    $columnIndex

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:06 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveDataGrid

Class TActiveDataGrid

[line 54]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TBaseDataList
                  |
                  --TDataGrid
                     |
                     --TActiveDataGrid
Location: /Web/UI/ActiveControls/TActiveDataGrid.php

Remarks

TActiveDataGrid class

TActiveDataGrid represents a data bound and updatable grid control which is the active counterpart to the original TDataGrid control.

This component can be used in the same way as the regular datagrid, the only difference is that the active datagrid uses callbacks instead of postbacks for interaction.

There are also active datagrid columns to work with the TActiveDataGrid, which are

  • TActiveBoundColumn, the active counterpart to TBoundColumn.
  • TActiveLiteralColumn, the active counterpart to TLiteralColumn.
  • TActiveCheckBoxColumn, the active counterpart to TCheckBoxColumn.
  • TActiveDropDownListColumn, the active counterpart to TDropDownListColumn.
  • TActiveHyperLinkColumn, the active counterpart to THyperLinkColumn.
  • TActiveEditCommandColumn, the active counterpart to TEditCommandColumn.
  • TActiveButtonColumn, the active counterpart to TButtonColumn.
  • TActiveTemplateColumn, the active counterpart to TTemplateColumn.
Please refer to the original documentation of the regular counterparts for usage.

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: TDataGrid.php 3057 2011-11-09 12:35:57Z ctrlaltca@gmail.com $

since

3.1.9

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TDataGrid

  • TDataGrid::CMD_CANCEL = 'Cancel'
  • TDataGrid::CMD_DELETE = 'Delete'
  • TDataGrid::CMD_EDIT = 'Edit'
  • TDataGrid::CMD_PAGE = 'Page'
  • TDataGrid::CMD_PAGE_FIRST = 'First'
  • TDataGrid::CMD_PAGE_LAST = 'Last'
  • TDataGrid::CMD_PAGE_NEXT = 'Next'
  • TDataGrid::CMD_PAGE_PREV = 'Previous'
  • TDataGrid::CMD_SELECT = 'Select'
    Command name that TDataGrid understands.
  • TDataGrid::CMD_SORT = 'Sort'
  • TDataGrid::CMD_UPDATE = 'Update'
  • TDataGrid::IT_ALTERNATINGITEM = 'AlternatingItem'
  • TDataGrid::IT_EDITITEM = 'EditItem'
  • TDataGrid::IT_FOOTER = 'Footer'
  • TDataGrid::IT_HEADER = 'Header'
    datagrid item types
  • TDataGrid::IT_ITEM = 'Item'
  • TDataGrid::IT_PAGER = 'Pager'
  • TDataGrid::IT_SELECTEDITEM = 'SelectedItem'
  • TDataGrid::IT_SEPARATOR = 'Separator'

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TDataGrid

  • TDataGrid::addParsedObject()
    Adds objects parsed in template to datagrid.
  • TDataGrid::applyItemStyles()
    Applies styles to items, header, footer and separators.
  • TDataGrid::bubbleEvent()
    This method overrides parent's implementation to handle onItemCommand event which is bubbled from TDataGridItem child controls.
  • TDataGrid::buildNextPrevPager()
    Builds a next-prev pager
  • TDataGrid::buildNumericPager()
    Builds a numeric pager
  • TDataGrid::buildPager()
    Builds the pager content based on pager style.
  • TDataGrid::createAutoColumns()
    Automatically generates datagrid columns based on datasource schema
  • TDataGrid::createItem()
    Creates a datagrid item instance based on the item type and index.
  • TDataGrid::createPagerButton()
    Creates a pager button.
  • TDataGrid::createStyle()
    Creates a style object for the control.
  • TDataGrid::getAllowSorting()
  • TDataGrid::getAlternatingItemStyle()
  • TDataGrid::getAutoColumns()
  • TDataGrid::getAutoGenerateColumnName()
  • TDataGrid::getAutoGenerateColumns()
  • TDataGrid::getBackImageUrl()
  • TDataGrid::getBottomPager()
  • TDataGrid::getCaption()
  • TDataGrid::getCaptionAlign()
  • TDataGrid::getColumns()
  • TDataGrid::getEditItem()
  • TDataGrid::getEditItemIndex()
  • TDataGrid::getEditItemStyle()
  • TDataGrid::getEmptyTemplate()
  • TDataGrid::getFooter()
  • TDataGrid::getFooterStyle()
  • TDataGrid::getHeader()
  • TDataGrid::getHeaderStyle()
  • TDataGrid::getItemCount()
  • TDataGrid::getItems()
  • TDataGrid::getItemStyle()
  • TDataGrid::getPagerStyle()
  • TDataGrid::getSelectedItem()
  • TDataGrid::getSelectedItemIndex()
  • TDataGrid::getSelectedItemStyle()
  • TDataGrid::getShowFooter()
  • TDataGrid::getShowHeader()
  • TDataGrid::getTableBodyStyle()
  • TDataGrid::getTableFootStyle()
  • TDataGrid::getTableHeadStyle()
  • TDataGrid::getTagName()
  • TDataGrid::getTopPager()
  • TDataGrid::initializeItem()
    Initializes a datagrid item and cells inside it
  • TDataGrid::loadState()
    Loads item count information from viewstate.
  • TDataGrid::onCancelCommand()
    Raises OnCancelCommand event.
  • TDataGrid::onDeleteCommand()
    Raises OnDeleteCommand event.
  • TDataGrid::onEditCommand()
    Raises OnEditCommand event.
  • TDataGrid::onItemCommand()
    Raises OnItemCommand event.
  • TDataGrid::onItemCreated()
    Raises OnItemCreated event.
  • TDataGrid::onItemDataBound()
    Raises OnItemDataBound event.
  • TDataGrid::onPageIndexChanged()
    Raises OnPageIndexChanged event.
  • TDataGrid::onPagerCreated()
    Raises OnPagerCreated event.
  • TDataGrid::onSortCommand()
    Raises OnSortCommand event.
  • TDataGrid::onUpdateCommand()
    Raises OnUpdateCommand event.
  • TDataGrid::performDataBinding()
    Performs databinding to populate datagrid items from data source.
  • TDataGrid::render()
    Renders the datagrid.
  • TDataGrid::renderBeginTag()
    Renders the openning tag for the datagrid control which will render table caption if present.
  • TDataGrid::renderTable()
    Renders the tabular data.
  • TDataGrid::reset()
    Clears up all items in the datagrid.
  • TDataGrid::restoreGridFromViewState()
    Restores datagrid content from viewstate.
  • TDataGrid::saveState()
    Saves item count in viewstate.
  • TDataGrid::setAllowSorting()
  • TDataGrid::setAutoGenerateColumns()
  • TDataGrid::setBackImageUrl()
  • TDataGrid::setCaption()
  • TDataGrid::setCaptionAlign()
  • TDataGrid::setEditItemIndex()
    Edits an item by its index in getItems.
  • TDataGrid::setEmptyTemplate()
  • TDataGrid::setSelectedItemIndex()
    Selects an item by its index in getItems.
  • TDataGrid::setShowFooter()
  • TDataGrid::setShowHeader()

Inherited From Class TBaseDataList

  • TBaseDataList::createStyle()
    Creates a style object for the control.
  • TBaseDataList::getCellPadding()
  • TBaseDataList::getCellSpacing()
  • TBaseDataList::getDataFieldValue()
    Returns the value of the data at the specified field.
  • TBaseDataList::getDataKeyField()
  • TBaseDataList::getDataKeys()
  • TBaseDataList::getGridLines()
  • TBaseDataList::getHorizontalAlign()
  • TBaseDataList::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event.
  • TBaseDataList::setCellPadding()
  • TBaseDataList::setCellSpacing()
  • TBaseDataList::setDataKeyField()
  • TBaseDataList::setGridLines()
    Sets the grid line style of the table layout.
  • TBaseDataList::setHorizontalAlign()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveDataGrid::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter.

    access

    public

    [ Top ]

    TActiveDataGrid::createPagerButton

    createPagerButton( string $buttonType, boolean $enabled, string $text, string $commandName, string $commandParameter );

    Overrides TDataGrid::createPagerButton() (Creates a pager button.)

    Parameters

    $buttonType

    button type, either LinkButton or PushButton

    $enabled

    whether the button should be enabled

    $text

    caption of the button

    $commandName

    CommandName corresponding to the OnCommand event of the button

    $commandParameter

    CommandParameter corresponding to the OnCommand event of the button

    Returns

    the button instance

    Remarks

    Creates a pager button.

    Depending on the button type, a TActiveLinkButton or a TActiveButton may be created. If it is enabled (clickable), its command name and parameter will also be set. It overrides the datagrid's original method to create active controls instead, thus the pager will do callbacks instead of the regular postbacks.

    access

    protected

    [ Top ]

    TActiveDataGrid::getActiveControl

    getActiveControl( );

    Returns

    standard active control options.

    access

    public

    [ Top ]

    TActiveDataGrid::getAutoGenerateColumnName

    getAutoGenerateColumnName( );

    Overrides TDataGrid::getAutoGenerateColumnName() (parent method not documented)

    Returns

    Name of the class used in AutoGenerateColumns mode

    access

    protected

    [ Top ]

    TActiveDataGrid::getSurroundingTagId

    getSurroundingTagId( );

    Returns

    container id

    Remarks

    Returns the id of the surrounding container (div).

    access

    public

    [ Top ]

    TActiveDataGrid::render

    render( THtmlWriter $writer );

    Overrides TDataGrid::render() (Renders the datagrid.)

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the datagrid.

    If the datagrid did not pass the prerender phase yet, it will register itself for rendering later. Else it will call the renderDataGrid() method which will do the rendering of the datagrid.

    access

    public

    [ Top ]

    TActiveDataGrid::setDataSource

    setDataSource( Traversable|array|string $value );

    Overrides TDataBoundControl::setDataSource() (Sets the data source object associated with the databound control.)

    Parameters

    $value

    data source object

    Remarks

    Sets the data source object associated with the datagrid control.

    In addition, the render method of all connected pagers is called so they get updated when the data source is changed. Also the datagrid registers itself for rendering in order to get it's content replaced on client side.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:06 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveDropDownListColumn

Class TActiveDropDownListColumn

[line 622]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TDropDownListColumn
            |
            --TActiveDropDownListColumn
Location: /Web/UI/ActiveControls/TActiveDataGrid.php

Remarks

TActiveDropDownListColumn class

TActiveDropDownListColumn represents a column that is bound to a field in a data source.

This is the active counterpart to the TDropDownListColumn control. For that purpose, if sorting is allowed, the header links/buttons are replaced by active controls.

Please refer to the original documentation of the TDropDownListColumn for usage.

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: TDropDownListColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.9

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDropDownListColumn

  • TDropDownListColumn::__construct()
  • TDropDownListColumn::addParsedObject()
    Adds object parsed from template to the control.
  • TDropDownListColumn::dataBindColumn()
    Databinds a cell in the column.
  • TDropDownListColumn::getDataTextField()
  • TDropDownListColumn::getDataTextFormatString()
  • TDropDownListColumn::getDataValueField()
  • TDropDownListColumn::getListDataSource()
  • TDropDownListColumn::getListTextField()
  • TDropDownListColumn::getListTextFormatString()
  • TDropDownListColumn::getListValueField()
  • TDropDownListColumn::getReadOnly()
  • TDropDownListColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TDropDownListColumn::loadState()
    Loads items from viewstate.
  • TDropDownListColumn::saveState()
    Saves items into viewstate.
  • TDropDownListColumn::setDataTextField()
    Sets the field of the data source that provides the text content of the column.
  • TDropDownListColumn::setDataTextFormatString()
  • TDropDownListColumn::setDataValueField()
    Sets the field of the data source that provides the key selecting an item in dropdown list.
  • TDropDownListColumn::setListDataSource()
  • TDropDownListColumn::setListTextField()
  • TDropDownListColumn::setListTextFormatString()
  • TDropDownListColumn::setListValueField()
  • TDropDownListColumn::setReadOnly()

Inherited From Class TDataGridColumn

  • TDataGridColumn::formatDataValue()
    Formats the text value according to a format string.
  • TDataGridColumn::getAllowSorting()
    Returns a value indicating whether this column allows sorting.
  • TDataGridColumn::getDataFieldValue()
    Fetches the value of the data at the specified field.
  • TDataGridColumn::getEnableCellGrouping()
  • TDataGridColumn::getFooterRenderer()
  • TDataGridColumn::getFooterStyle()
  • TDataGridColumn::getFooterText()
  • TDataGridColumn::getHeaderImageUrl()
  • TDataGridColumn::getHeaderRenderer()
  • TDataGridColumn::getHeaderStyle()
  • TDataGridColumn::getHeaderText()
  • TDataGridColumn::getID()
  • TDataGridColumn::getItemStyle()
  • TDataGridColumn::getOwner()
  • TDataGridColumn::getSortExpression()
  • TDataGridColumn::getViewState()
    Returns a viewstate value.
  • TDataGridColumn::getVisible()
  • TDataGridColumn::initialize()
    Initializes the column.
  • TDataGridColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TDataGridColumn::initializeFooterCell()
    Initializes the footer cell.
  • TDataGridColumn::initializeHeaderCell()
    Initializes the header cell.
  • TDataGridColumn::loadState()
    Loads persistent state values.
  • TDataGridColumn::saveState()
    Saves persistent state values.
  • TDataGridColumn::setEnableCellGrouping()
  • TDataGridColumn::setFooterRenderer()
    Sets the column footer cell renderer class.
  • TDataGridColumn::setFooterText()
  • TDataGridColumn::setHeaderImageUrl()
  • TDataGridColumn::setHeaderRenderer()
    Sets the column header cell renderer class.
  • TDataGridColumn::setHeaderText()
  • TDataGridColumn::setID()
    Sets the ID of the column.
  • TDataGridColumn::setOwner()
  • TDataGridColumn::setSortExpression()
  • TDataGridColumn::setViewState()
    Sets a viewstate value.
  • TDataGridColumn::setVisible()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveDropDownListColumn::initializeHeaderCell

    initializeHeaderCell( $cell, $columnIndex );

    Overrides TDataGridColumn::initializeHeaderCell() (Initializes the header cell.)

    Parameters

    $cell

    $columnIndex

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:08 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveEditCommandColumn

Class TActiveEditCommandColumn

[line 278]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TEditCommandColumn
            |
            --TActiveEditCommandColumn
Location: /Web/UI/ActiveControls/TActiveDataGrid.php

Remarks

TActiveEditCommandColumn class

TActiveEditCommandColumn contains the Edit command buttons for editing data items in each row.

TActiveEditCommandColumn will create an edit button if a cell is not in edit mode. Otherwise an update button and a cancel button will be created within the cell. The button captions are specified using EditText, UpdateText, and CancelText.

This is the active counterpart to the TEditCommandColumn control. The buttons for interaction are replaced by active buttons.

Please refer to the original documentation of the TEditCommandColumn for usage.

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: TEditCommandColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.9

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEditCommandColumn

  • TEditCommandColumn::createButton()
    Creates a button and initializes its properties.
  • TEditCommandColumn::getButtonType()
  • TEditCommandColumn::getCancelImageUrl()
  • TEditCommandColumn::getCancelText()
  • TEditCommandColumn::getCausesValidation()
  • TEditCommandColumn::getEditImageUrl()
  • TEditCommandColumn::getEditText()
  • TEditCommandColumn::getUpdateImageUrl()
  • TEditCommandColumn::getUpdateText()
  • TEditCommandColumn::getValidationGroup()
  • TEditCommandColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TEditCommandColumn::setButtonType()
  • TEditCommandColumn::setCancelImageUrl()
  • TEditCommandColumn::setCancelText()
  • TEditCommandColumn::setCausesValidation()
  • TEditCommandColumn::setEditImageUrl()
  • TEditCommandColumn::setEditText()
  • TEditCommandColumn::setUpdateImageUrl()
  • TEditCommandColumn::setUpdateText()
  • TEditCommandColumn::setValidationGroup()

Inherited From Class TDataGridColumn

  • TDataGridColumn::formatDataValue()
    Formats the text value according to a format string.
  • TDataGridColumn::getAllowSorting()
    Returns a value indicating whether this column allows sorting.
  • TDataGridColumn::getDataFieldValue()
    Fetches the value of the data at the specified field.
  • TDataGridColumn::getEnableCellGrouping()
  • TDataGridColumn::getFooterRenderer()
  • TDataGridColumn::getFooterStyle()
  • TDataGridColumn::getFooterText()
  • TDataGridColumn::getHeaderImageUrl()
  • TDataGridColumn::getHeaderRenderer()
  • TDataGridColumn::getHeaderStyle()
  • TDataGridColumn::getHeaderText()
  • TDataGridColumn::getID()
  • TDataGridColumn::getItemStyle()
  • TDataGridColumn::getOwner()
  • TDataGridColumn::getSortExpression()
  • TDataGridColumn::getViewState()
    Returns a viewstate value.
  • TDataGridColumn::getVisible()
  • TDataGridColumn::initialize()
    Initializes the column.
  • TDataGridColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TDataGridColumn::initializeFooterCell()
    Initializes the footer cell.
  • TDataGridColumn::initializeHeaderCell()
    Initializes the header cell.
  • TDataGridColumn::loadState()
    Loads persistent state values.
  • TDataGridColumn::saveState()
    Saves persistent state values.
  • TDataGridColumn::setEnableCellGrouping()
  • TDataGridColumn::setFooterRenderer()
    Sets the column footer cell renderer class.
  • TDataGridColumn::setFooterText()
  • TDataGridColumn::setHeaderImageUrl()
  • TDataGridColumn::setHeaderRenderer()
    Sets the column header cell renderer class.
  • TDataGridColumn::setHeaderText()
  • TDataGridColumn::setID()
    Sets the ID of the column.
  • TDataGridColumn::setOwner()
  • TDataGridColumn::setSortExpression()
  • TDataGridColumn::setViewState()
    Sets a viewstate value.
  • TDataGridColumn::setVisible()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveEditCommandColumn::createButton

    createButton( $commandName, $text, $causesValidation, $validationGroup );

    Overrides TEditCommandColumn::createButton() (Creates a button and initializes its properties.)

    Parameters

    $commandName

    $text

    $causesValidation

    $validationGroup

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:08 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveHyperLinkColumn

Class TActiveHyperLinkColumn

[line 436]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --THyperLinkColumn
            |
            --TActiveHyperLinkColumn
Location: /Web/UI/ActiveControls/TActiveDataGrid.php

Remarks

TActiveHyperLinkColumn class

TActiveHyperLinkColumn contains a hyperlink for each item in the column.

This is the active counterpart to the THyperLinkColumn control. For that purpose, if sorting is allowed, the header links/buttons are replaced by active controls.

Please refer to the original documentation of the THyperLinkColumn for usage.

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: THyperLinkColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.9

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class THyperLinkColumn

  • THyperLinkColumn::dataBindColumn()
    Databinds a cell in the column.
  • THyperLinkColumn::getDataNavigateUrlField()
  • THyperLinkColumn::getDataNavigateUrlFormatString()
  • THyperLinkColumn::getDataTextField()
  • THyperLinkColumn::getDataTextFormatString()
  • THyperLinkColumn::getImageHeight()
  • THyperLinkColumn::getImageUrl()
  • THyperLinkColumn::getImageWidth()
  • THyperLinkColumn::getNavigateUrl()
  • THyperLinkColumn::getTarget()
  • THyperLinkColumn::getText()
  • THyperLinkColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • THyperLinkColumn::setDataNavigateUrlField()
  • THyperLinkColumn::setDataNavigateUrlFormatString()
  • THyperLinkColumn::setDataTextField()
  • THyperLinkColumn::setDataTextFormatString()
  • THyperLinkColumn::setImageHeight()
  • THyperLinkColumn::setImageUrl()
  • THyperLinkColumn::setImageWidth()
  • THyperLinkColumn::setNavigateUrl()
    Sets the URL to link to when the hyperlink is clicked.
  • THyperLinkColumn::setTarget()
    Sets the target window or frame to display the Web page content linked to when the hyperlink is clicked.
  • THyperLinkColumn::setText()
    Sets the text caption of the hyperlink.

Inherited From Class TDataGridColumn

  • TDataGridColumn::formatDataValue()
    Formats the text value according to a format string.
  • TDataGridColumn::getAllowSorting()
    Returns a value indicating whether this column allows sorting.
  • TDataGridColumn::getDataFieldValue()
    Fetches the value of the data at the specified field.
  • TDataGridColumn::getEnableCellGrouping()
  • TDataGridColumn::getFooterRenderer()
  • TDataGridColumn::getFooterStyle()
  • TDataGridColumn::getFooterText()
  • TDataGridColumn::getHeaderImageUrl()
  • TDataGridColumn::getHeaderRenderer()
  • TDataGridColumn::getHeaderStyle()
  • TDataGridColumn::getHeaderText()
  • TDataGridColumn::getID()
  • TDataGridColumn::getItemStyle()
  • TDataGridColumn::getOwner()
  • TDataGridColumn::getSortExpression()
  • TDataGridColumn::getViewState()
    Returns a viewstate value.
  • TDataGridColumn::getVisible()
  • TDataGridColumn::initialize()
    Initializes the column.
  • TDataGridColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TDataGridColumn::initializeFooterCell()
    Initializes the footer cell.
  • TDataGridColumn::initializeHeaderCell()
    Initializes the header cell.
  • TDataGridColumn::loadState()
    Loads persistent state values.
  • TDataGridColumn::saveState()
    Saves persistent state values.
  • TDataGridColumn::setEnableCellGrouping()
  • TDataGridColumn::setFooterRenderer()
    Sets the column footer cell renderer class.
  • TDataGridColumn::setFooterText()
  • TDataGridColumn::setHeaderImageUrl()
  • TDataGridColumn::setHeaderRenderer()
    Sets the column header cell renderer class.
  • TDataGridColumn::setHeaderText()
  • TDataGridColumn::setID()
    Sets the ID of the column.
  • TDataGridColumn::setOwner()
  • TDataGridColumn::setSortExpression()
  • TDataGridColumn::setViewState()
    Sets a viewstate value.
  • TDataGridColumn::setVisible()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveHyperLinkColumn::initializeHeaderCell

    initializeHeaderCell( $cell, $columnIndex );

    Overrides TDataGridColumn::initializeHeaderCell() (Initializes the header cell.)

    Parameters

    $cell

    $columnIndex

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:08 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveLiteralColumn

Class TActiveLiteralColumn

[line 710]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TLiteralColumn
            |
            --TActiveLiteralColumn
Location: /Web/UI/ActiveControls/TActiveDataGrid.php

Remarks

TActiveLiteralColumn class

TActiveLiteralColumn represents a static text column that is bound to a field in a data source. The cells in the column will be displayed with static texts using the data indexed by DataField. You can customize the display by setting DataFormatString.

If DataField is not specified, the cells will be filled with Text.

If Encode is true, the static texts will be HTML-encoded.

This is the active counterpart to the TLiteralColumn control. For that purpose, if sorting is allowed, the header links/buttons are replaced by active controls.

Please refer to the original documentation of the TLiteralColumn for usage.

author

Fabio Bas <ctrlaltca@gmail.com>

version

$Id: TLiteralColumn.php 1397 2006-09-07 07:55:53Z wei $

since

3.1.9

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TLiteralColumn

  • TLiteralColumn::dataBindColumn()
    Databinds a cell in the column.
  • TLiteralColumn::getDataField()
  • TLiteralColumn::getDataFormatString()
  • TLiteralColumn::getEncode()
  • TLiteralColumn::getText()
  • TLiteralColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TLiteralColumn::setDataField()
  • TLiteralColumn::setDataFormatString()
  • TLiteralColumn::setEncode()
  • TLiteralColumn::setText()

Inherited From Class TDataGridColumn

  • TDataGridColumn::formatDataValue()
    Formats the text value according to a format string.
  • TDataGridColumn::getAllowSorting()
    Returns a value indicating whether this column allows sorting.
  • TDataGridColumn::getDataFieldValue()
    Fetches the value of the data at the specified field.
  • TDataGridColumn::getEnableCellGrouping()
  • TDataGridColumn::getFooterRenderer()
  • TDataGridColumn::getFooterStyle()
  • TDataGridColumn::getFooterText()
  • TDataGridColumn::getHeaderImageUrl()
  • TDataGridColumn::getHeaderRenderer()
  • TDataGridColumn::getHeaderStyle()
  • TDataGridColumn::getHeaderText()
  • TDataGridColumn::getID()
  • TDataGridColumn::getItemStyle()
  • TDataGridColumn::getOwner()
  • TDataGridColumn::getSortExpression()
  • TDataGridColumn::getViewState()
    Returns a viewstate value.
  • TDataGridColumn::getVisible()
  • TDataGridColumn::initialize()
    Initializes the column.
  • TDataGridColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TDataGridColumn::initializeFooterCell()
    Initializes the footer cell.
  • TDataGridColumn::initializeHeaderCell()
    Initializes the header cell.
  • TDataGridColumn::loadState()
    Loads persistent state values.
  • TDataGridColumn::saveState()
    Saves persistent state values.
  • TDataGridColumn::setEnableCellGrouping()
  • TDataGridColumn::setFooterRenderer()
    Sets the column footer cell renderer class.
  • TDataGridColumn::setFooterText()
  • TDataGridColumn::setHeaderImageUrl()
  • TDataGridColumn::setHeaderRenderer()
    Sets the column header cell renderer class.
  • TDataGridColumn::setHeaderText()
  • TDataGridColumn::setID()
    Sets the ID of the column.
  • TDataGridColumn::setOwner()
  • TDataGridColumn::setSortExpression()
  • TDataGridColumn::setViewState()
    Sets a viewstate value.
  • TDataGridColumn::setVisible()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveLiteralColumn::initializeHeaderCell

    initializeHeaderCell( $cell, $columnIndex );

    Overrides TDataGridColumn::initializeHeaderCell() (Initializes the header cell.)

    Parameters

    $cell

    $columnIndex

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:09 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveTemplateColumn

Class TActiveTemplateColumn

[line 367]
TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TTemplateColumn
            |
            --TActiveTemplateColumn
Location: /Web/UI/ActiveControls/TActiveDataGrid.php

Remarks

TActiveTemplateColumn class

TActiveTemplateColumn customizes the layout of controls in the column with templates. In particular, you can specify ItemTemplate, EditItemTemplate, HeaderTemplate and FooterTemplate to customize specific type of cells in the column.

This is the active counterpart to the TTemplateColumn control. For that purpose, if sorting is allowed, the header links/buttons are replaced by active controls.

Please refer to the original documentation of the TTemplateColumn for usage.

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: TTemplateColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.9

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TTemplateColumn

  • TTemplateColumn::dataBindColumn()
    Databinds a cell in the column.
  • TTemplateColumn::getEditItemRenderer()
  • TTemplateColumn::getEditItemTemplate()
  • TTemplateColumn::getFooterTemplate()
  • TTemplateColumn::getHeaderTemplate()
  • TTemplateColumn::getItemRenderer()
  • TTemplateColumn::getItemTemplate()
  • TTemplateColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TTemplateColumn::setEditItemRenderer()
    Sets the edit item cell renderer class.
  • TTemplateColumn::setEditItemTemplate()
  • TTemplateColumn::setFooterTemplate()
  • TTemplateColumn::setHeaderTemplate()
  • TTemplateColumn::setItemRenderer()
    Sets the item cell renderer class.
  • TTemplateColumn::setItemTemplate()

Inherited From Class TDataGridColumn

  • TDataGridColumn::formatDataValue()
    Formats the text value according to a format string.
  • TDataGridColumn::getAllowSorting()
    Returns a value indicating whether this column allows sorting.
  • TDataGridColumn::getDataFieldValue()
    Fetches the value of the data at the specified field.
  • TDataGridColumn::getEnableCellGrouping()
  • TDataGridColumn::getFooterRenderer()
  • TDataGridColumn::getFooterStyle()
  • TDataGridColumn::getFooterText()
  • TDataGridColumn::getHeaderImageUrl()
  • TDataGridColumn::getHeaderRenderer()
  • TDataGridColumn::getHeaderStyle()
  • TDataGridColumn::getHeaderText()
  • TDataGridColumn::getID()
  • TDataGridColumn::getItemStyle()
  • TDataGridColumn::getOwner()
  • TDataGridColumn::getSortExpression()
  • TDataGridColumn::getViewState()
    Returns a viewstate value.
  • TDataGridColumn::getVisible()
  • TDataGridColumn::initialize()
    Initializes the column.
  • TDataGridColumn::initializeCell()
    Initializes the specified cell to its initial values.
  • TDataGridColumn::initializeFooterCell()
    Initializes the footer cell.
  • TDataGridColumn::initializeHeaderCell()
    Initializes the header cell.
  • TDataGridColumn::loadState()
    Loads persistent state values.
  • TDataGridColumn::saveState()
    Saves persistent state values.
  • TDataGridColumn::setEnableCellGrouping()
  • TDataGridColumn::setFooterRenderer()
    Sets the column footer cell renderer class.
  • TDataGridColumn::setFooterText()
  • TDataGridColumn::setHeaderImageUrl()
  • TDataGridColumn::setHeaderRenderer()
    Sets the column header cell renderer class.
  • TDataGridColumn::setHeaderText()
  • TDataGridColumn::setID()
    Sets the ID of the column.
  • TDataGridColumn::setOwner()
  • TDataGridColumn::setSortExpression()
  • TDataGridColumn::setViewState()
    Sets a viewstate value.
  • TDataGridColumn::setVisible()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveTemplateColumn::initializeHeaderCell

    initializeHeaderCell( $cell, $columnIndex );

    Overrides TDataGridColumn::initializeHeaderCell() (Initializes the header cell.)

    Parameters

    $cell

    $columnIndex

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:09 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveDataList

Class TActiveDataList

[line 27]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TBaseDataList
                  |
                  --TDataList
                     |
                     --TActiveDataList
Location: /Web/UI/ActiveControls/TActiveDataList.php

Remarks

TActiveDataList class

TActiveDataList represents a data bound and updatable grid control which is the active counterpart to the original TDataList control.

This component can be used in the same way as the regular datalist, the only difference is that the active datalist uses callbacks instead of postbacks for interaction.

Please refer to the original documentation of the regular counterparts for usage.

author

Marcos Aurelio Nobre <marconobre@gmail.com>

version

$Id: TDataList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TDataList

  • TDataList::CMD_CANCEL = 'Cancel'
  • TDataList::CMD_DELETE = 'Delete'
  • TDataList::CMD_EDIT = 'Edit'
  • TDataList::CMD_SELECT = 'Select'
    Command name that TDataList understands. They are case-insensitive.
  • TDataList::CMD_UPDATE = 'Update'

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TDataList

  • TDataList::applyItemStyles()
    Applies styles to items, header, footer and separators.
  • TDataList::bubbleEvent()
    This method overrides parent's implementation to handle onItemCommand event which is bubbled from datalist items and their child controls.
  • TDataList::createEmptyContent()
    Creates empty datalist content.
  • TDataList::createItem()
    Creates a datalist item instance based on the item type and index.
  • TDataList::generateItemStyle()
    Returns a style used for rendering items.
  • TDataList::getAlternatingItemRenderer()
  • TDataList::getAlternatingItemStyle()
  • TDataList::getAlternatingItemTemplate()
  • TDataList::getCaption()
  • TDataList::getCaptionAlign()
  • TDataList::getEditItem()
  • TDataList::getEditItemIndex()
  • TDataList::getEditItemRenderer()
  • TDataList::getEditItemStyle()
  • TDataList::getEditItemTemplate()
  • TDataList::getEmptyRenderer()
  • TDataList::getEmptyTemplate()
  • TDataList::getFooter()
  • TDataList::getFooterRenderer()
  • TDataList::getFooterStyle()
  • TDataList::getFooterTemplate()
  • TDataList::getHasFooter()
    Returns a value indicating whether this control contains footer item.
  • TDataList::getHasHeader()
    Returns a value indicating whether this control contains header item.
  • TDataList::getHasSeparators()
    Returns a value indicating whether this control contains separator items.
  • TDataList::getHeader()
  • TDataList::getHeaderRenderer()
  • TDataList::getHeaderStyle()
  • TDataList::getHeaderTemplate()
  • TDataList::getItemCount()
  • TDataList::getItemRenderer()
  • TDataList::getItems()
  • TDataList::getItemStyle()
  • TDataList::getItemTemplate()
  • TDataList::getRepeatColumns()
  • TDataList::getRepeatDirection()
  • TDataList::getRepeatInfo()
  • TDataList::getRepeatLayout()
  • TDataList::getSelectedDataKey()
  • TDataList::getSelectedItem()
  • TDataList::getSelectedItemIndex()
  • TDataList::getSelectedItemRenderer()
  • TDataList::getSelectedItemStyle()
  • TDataList::getSelectedItemTemplate()
  • TDataList::getSeparatorRenderer()
  • TDataList::getSeparatorStyle()
  • TDataList::getSeparatorTemplate()
  • TDataList::getShowFooter()
  • TDataList::getShowHeader()
  • TDataList::loadState()
    Loads item count information from viewstate.
  • TDataList::onCancelCommand()
    Raises OnCancelCommand event.
  • TDataList::onDeleteCommand()
    Raises OnDeleteCommand event.
  • TDataList::onEditCommand()
    Raises OnEditCommand event.
  • TDataList::onItemCommand()
    Raises OnItemCommand event.
  • TDataList::onItemCreated()
    Raises OnItemCreated event.
  • TDataList::onItemDataBound()
    Raises OnItemDataBound event.
  • TDataList::onUpdateCommand()
    Raises OnUpdateCommand event.
  • TDataList::performDataBinding()
    Performs databinding to populate data list items from data source.
  • TDataList::render()
    Renders the data list control.
  • TDataList::renderItem()
    Renders an item in the list.
  • TDataList::reset()
    Clears up all items in the data list.
  • TDataList::restoreItemsFromViewState()
    Creates data list items based on viewstate information.
  • TDataList::saveState()
    Saves item count in viewstate.
  • TDataList::setAlternatingItemRenderer()
    Sets the alternative item renderer class.
  • TDataList::setAlternatingItemTemplate()
  • TDataList::setCaption()
  • TDataList::setCaptionAlign()
  • TDataList::setEditItemIndex()
    Edits an item by its index in getItems.
  • TDataList::setEditItemRenderer()
    Sets the renderer class for the datalist item being editted.
  • TDataList::setEditItemTemplate()
  • TDataList::setEmptyRenderer()
    Sets the datalist empty renderer class.
  • TDataList::setEmptyTemplate()
  • TDataList::setFooterRenderer()
    Sets the datalist footer renderer class.
  • TDataList::setFooterTemplate()
  • TDataList::setHeaderRenderer()
    Sets the datalist header renderer class.
  • TDataList::setHeaderTemplate()
  • TDataList::setItemRenderer()
    Sets the item renderer class.
  • TDataList::setItemTemplate()
  • TDataList::setRepeatColumns()
  • TDataList::setRepeatDirection()
  • TDataList::setRepeatLayout()
  • TDataList::setSelectedItemIndex()
    Selects an item by its index in getItems.
  • TDataList::setSelectedItemRenderer()
    Sets the renderer class for the datalist item being selected.
  • TDataList::setSelectedItemTemplate()
  • TDataList::setSeparatorRenderer()
    Sets the datalist item separator renderer class.
  • TDataList::setSeparatorTemplate()
  • TDataList::setShowFooter()
  • TDataList::setShowHeader()

Inherited From Class TBaseDataList

  • TBaseDataList::createStyle()
    Creates a style object for the control.
  • TBaseDataList::getCellPadding()
  • TBaseDataList::getCellSpacing()
  • TBaseDataList::getDataFieldValue()
    Returns the value of the data at the specified field.
  • TBaseDataList::getDataKeyField()
  • TBaseDataList::getDataKeys()
  • TBaseDataList::getGridLines()
  • TBaseDataList::getHorizontalAlign()
  • TBaseDataList::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event.
  • TBaseDataList::setCellPadding()
  • TBaseDataList::setCellSpacing()
  • TBaseDataList::setDataKeyField()
  • TBaseDataList::setGridLines()
    Sets the grid line style of the table layout.
  • TBaseDataList::setHorizontalAlign()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveDataList::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter.

    access

    public

    [ Top ]

    TActiveDataList::getActiveControl

    getActiveControl( );

    Returns

    standard active control options.

    access

    public

    [ Top ]

    TActiveDataList::getContainerID

    getContainerID( );

    Returns

    container id

    Remarks

    Returns the id of the surrounding container (span).

    access

    protected

    [ Top ]

    TActiveDataList::render

    render( THtmlWriter $writer );

    Overrides TDataList::render() (Renders the data list control.)

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the repeater.

    If the repeater did not pass the prerender phase yet, it will register itself for rendering later. Else it will call the renderRepeater() method which will do the rendering of the repeater.

    access

    public

    [ Top ]

    TActiveDataList::setDataSource

    setDataSource( Traversable|array|string $value );

    Overrides TDataBoundControl::setDataSource() (Sets the data source object associated with the databound control.)

    Parameters

    $value

    data source object

    Remarks

    Sets the data source object associated with the repeater control.

    In addition, the render method of all connected pagers is called so they get updated when the data source is changed. Also the repeater registers itself for rendering in order to get it's content replaced on client side.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:09 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveDatePicker

Class TActiveDatePicker

[line 32]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --TDatePicker
                  |
                  --TActiveDatePicker
Location: /Web/UI/ActiveControls/TActiveDatePicker.php

Remarks

TActiveDatePicker class

The active control counter part to date picker control. When the date selection is changed, the OnCallback event is raised.

author

Christophe Boulain <Christophe.Boulain@gmail.com>

author

Bradley Booms <Bradley.Booms@nsighttel.com>

version

$Id: TActiveDatePicker.php 3145 2012-05-19 11:08:20Z ctrlaltca $

since

3.1.3

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TDatePicker

  • TDatePicker::SCRIPT_PATH = 'prado/datepicker'
    Script path relative to the TClientScriptManager::SCRIPT_PATH

Inherited From Class TTextBox

  • TTextBox::DEFAULT_COLUMNS = 20
    Default number of columns (for MultiLine text box)
  • TTextBox::DEFAULT_ROWS = 4
    Default number of rows (for MultiLine text box)

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TDatePicker

  • TDatePicker::addAttributesToRender()
    Add the client id to the input textbox, and register the client scripts.
  • TDatePicker::createClientScript()
  • TDatePicker::getAssetUrl()
  • TDatePicker::getButtonImageUrl()
  • TDatePicker::getButtonText()
  • TDatePicker::getCalendarStyle()
  • TDatePicker::getClientSide()
    Gets the TDatePickerClientScript to set the TDatePicker event handlers.
  • TDatePicker::getCulturalOptions()
    Get javascript localization options, e.g. month and weekday names.
  • TDatePicker::getCulture()
    Gets the current culture.
  • TDatePicker::getCurrentCulture()
  • TDatePicker::getData()
    Returns the timestamp selected by the user.
  • TDatePicker::getDate()
  • TDatePicker::getDateFormat()
  • TDatePicker::getDateFromPostData()
    Loads date from drop down list data.
  • TDatePicker::getDatePickerButtonID()
    Gets the ID for the date picker trigger button.
  • TDatePicker::getDatePickerOptions()
    Get javascript date picker options.
  • TDatePicker::getDropDownDayOptions()
  • TDatePicker::getFirstDayOfWeek()
  • TDatePicker::getFromYear()
  • TDatePicker::getInputMode()
  • TDatePicker::getLocalizedCalendarInfo()
  • TDatePicker::getLocalizedMonthNames()
    Returns the localized month names that depends on the month format pattern.
  • TDatePicker::getMode()
  • TDatePicker::getPositionMode()
  • TDatePicker::getShowCalendar()
  • TDatePicker::getTimeStamp()
  • TDatePicker::getTimeStampFromText()
    Gets the date from the text input using TSimpleDateFormatter
  • TDatePicker::getUpToYear()
  • TDatePicker::getValidationPropertyValue()
    Returns the value to be validated.
  • TDatePicker::hasDayPattern()
  • TDatePicker::loadPostData()
    Loads user input data. Override parent implementation, when InputMode is DropDownList call getDateFromPostData to get date data.
  • TDatePicker::onPreRender()
    Publish the date picker Css asset files.
  • TDatePicker::publishCalendarStyle()
    Publish the calendar style Css asset file.
  • TDatePicker::registerCalendarClientScriptPost()
  • TDatePicker::registerCalendarClientScriptPre()
    Registers the javascript code to initialize the date picker.
  • TDatePicker::render()
    Renders body content.
  • TDatePicker::renderButtonDatePicker()
    Adds an additional button such that when clicked it shows the date picker.
  • TDatePicker::renderCalendarDayOptions()
    Renders the day drop down list options.
  • TDatePicker::renderCalendarMonthOptions()
    Renders the month drop down list options.
  • TDatePicker::renderCalendarSelections()
    Renders the calendar drop down list depending on the DateFormat pattern.
  • TDatePicker::renderCalendarYearOptions()
    Renders the year drop down list options.
  • TDatePicker::renderDatePickerButtons()
    Renders the date picker popup buttons.
  • TDatePicker::renderDropDownListCalendar()
    Renders the drop down list date picker.
  • TDatePicker::renderImageButtonDatePicker()
    Adds an additional image button such that when clicked it shows the date picker.
  • TDatePicker::setAutoPostBack()
    AutoPostBack is not supported.
  • TDatePicker::setButtonImageUrl()
  • TDatePicker::setButtonText()
  • TDatePicker::setCalendarStyle()
  • TDatePicker::setCulture()
    Sets the culture/language for the date picker.
  • TDatePicker::setData()
    Sets the timestamp represented by this control.
  • TDatePicker::setDate()
  • TDatePicker::setDateFormat()
    Sets the format of the date string.
  • TDatePicker::setFirstDayOfWeek()
    Set the first day of week, with 0 as Sunday, 1 as Monday, etc.
  • TDatePicker::setFromYear()
  • TDatePicker::setInputMode()
  • TDatePicker::setMode()
  • TDatePicker::setPositionMode()
  • TDatePicker::setShowCalendar()
    Sets whether to pop up the calendar window when the control receives focus
  • TDatePicker::setTimeStamp()
    Sets the date for the date picker using timestamp.
  • TDatePicker::setUpToYear()

Inherited From Class TTextBox

  • TTextBox::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TTextBox::getAutoCompleteType()
  • TTextBox::getAutoPostBack()
  • TTextBox::getAutoTrim()
  • TTextBox::getCausesValidation()
  • TTextBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TTextBox::getColumns()
  • TTextBox::getData()
    Returns the text content of the TTextBox control.
  • TTextBox::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TTextBox::getEnableClientScript()
  • TTextBox::getIsValid()
    Returns true if this control validated successfully.
  • TTextBox::getMaxLength()
  • TTextBox::getPersistPassword()
  • TTextBox::getPostBackOptions()
    Gets the post back options for this textbox.
  • TTextBox::getReadOnly()
  • TTextBox::getRows()
  • TTextBox::getSafeText()
  • TTextBox::getSafeTextParser()
  • TTextBox::getTagName()
  • TTextBox::getText()
  • TTextBox::getTextMode()
  • TTextBox::getValidationGroup()
  • TTextBox::getValidationPropertyValue()
    Returns the value to be validated.
  • TTextBox::getWrap()
  • TTextBox::loadPostData()
    Loads user input data.
  • TTextBox::onTextChanged()
    Raises OnTextChanged event.
  • TTextBox::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TTextBox::renderBeginTag()
    Renders an additional line-break after the opening tag when it is in MultiLine text mode.
  • TTextBox::renderClientControlScript()
    Renders the javascript for textbox.
  • TTextBox::renderContents()
    Renders the body content of the textbox when it is in MultiLine text mode.
  • TTextBox::setAutoCompleteType()
  • TTextBox::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TTextBox::setAutoTrim()
    Sets the value indicating if the input text should be trimmed spaces
  • TTextBox::setCausesValidation()
  • TTextBox::setColumns()
    Sets the display width of the text box in characters.
  • TTextBox::setData()
    Sets the text content of the TTextBox control.
  • TTextBox::setEnableClientScript()
  • TTextBox::setIsValid()
  • TTextBox::setMaxLength()
    Sets the maximum number of characters allowed in the text box.
  • TTextBox::setPersistPassword()
  • TTextBox::setReadOnly()
  • TTextBox::setRows()
    Sets the number of rows displayed in a multiline text box.
  • TTextBox::setText()
    Sets the text content of the TTextBox control.
  • TTextBox::setTextMode()
    Sets the behavior mode of the TTextBox component.
  • TTextBox::setValidationGroup()
  • TTextBox::setWrap()
    Sets the value indicating whether the text content wraps within a multiline text box.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveDatePicker::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveDatePicker::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveDatePicker::getAutoPostBack

    getAutoPostBack( );

    Overrides TTextBox::getAutoPostBack() (parent method not documented)

    Returns

    a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TActiveDatePicker control and then tabs out of the component. Defaults to true.

    access

    public

    [ Top ]

    TActiveDatePicker::getClientSide

    getClientSide( );

    Overrides TDatePicker::getClientSide() (Gets the TDatePickerClientScript to set the TDatePicker event handlers.)

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveDatePicker::getDatePickerOptions

    getDatePickerOptions( );

    Overrides TDatePicker::getDatePickerOptions() (Get javascript date picker options.)

    Returns

    date picker client-side options

    Remarks

    Get javascript date picker options.

    access

    protected

    [ Top ]

    TActiveDatePicker::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveDatePicker::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by ICallbackEventHandler interface.

    This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveDatePicker::registerCalendarClientScriptPost

    registerCalendarClientScriptPost( );

    Overrides TDatePicker::registerCalendarClientScriptPost() (parent method not documented)

    access

    protected

    [ Top ]

    TActiveDatePicker::registerCalendarClientScriptPre

    registerCalendarClientScriptPre( );

    Overrides TDatePicker::registerCalendarClientScriptPre() (Registers the javascript code to initialize the date picker.)

    Remarks

    Registers the javascript code to initialize the date picker.

    access

    protected

    [ Top ]

    TActiveDatePicker::setAutoPostBack

    setAutoPostBack( boolean $value );

    Overrides TDatePicker::setAutoPostBack() (AutoPostBack is not supported.)

    Parameters

    $value

    the value indicating if postback automatically

    Remarks

    Sets the value indicating if postback automatically.

    An automatic postback to the server will occur whenever the user modifies the text in the TActiveDatePicker control and then tabs out of the component.

    access

    public

    [ Top ]

    TActiveDatePicker::setText

    setText( string $value );

    Overrides TTextBox::setText() (Sets the text content of the TTextBox control.)

    Parameters

    $value

    text content for the textbox

    Remarks

    Client-side Text property can only be updated after the OnLoad stage.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:10 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveDropDownList

Class TActiveDropDownList

[line 38]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TDropDownList
                     |
                     --TActiveDropDownList
Location: /Web/UI/ActiveControls/TActiveDropDownList.php

Remarks

TActiveDropDownList class.

The active control counter part to drop down list control. The AutoPostBack property is set to true by default. Thus, when the drop down list selection is changed the OnCallback event is raised after OnSelectedIndexChanged event.

With ActiveControl.EnabledUpdate set to true (default is true), changes to the selection, after OnLoad event has been raised, will be updated. on the client side.

List items can be changed dynamically during a callback request.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveDropDownList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TDropDownList

  • TDropDownList::addAttributesToRender()
    Adds attributes to renderer.
  • TDropDownList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TDropDownList::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TDropDownList::getIsValid()
    Returns true if this control validated successfully.
  • TDropDownList::getValidationPropertyValue()
    Returns the value to be validated.
  • TDropDownList::loadPostData()
    Loads user input data.
  • TDropDownList::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TDropDownList::setIsValid()
  • TDropDownList::setSelectedIndices()

Inherited From Class TListControl

  • TListControl::addAttributesToRender()
    Adds attributes to renderer.
  • TListControl::addParsedObject()
    Adds object parsed from template to the control.
  • TListControl::clearSelection()
    Clears all existing selections.
  • TListControl::createListItemCollection()
    Creates a collection object to hold list items.
  • TListControl::formatDataValue()
    Formats the text value according to a format string.
  • TListControl::getAppendDataBoundItems()
  • TListControl::getAutoPostBack()
  • TListControl::getCausesValidation()
  • TListControl::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TListControl::getData()
    Returns the value of the selected item with the lowest cardinal index.
  • TListControl::getDataGroupField()
  • TListControl::getDataTextField()
  • TListControl::getDataTextFormatString()
  • TListControl::getDataValueField()
  • TListControl::getEnableClientScript()
  • TListControl::getHasItems()
  • TListControl::getIsMultiSelect()
  • TListControl::getItemCount()
  • TListControl::getItems()
  • TListControl::getPostBackOptions()
  • TListControl::getPromptText()
  • TListControl::getPromptValue()
  • TListControl::getSelectedIndex()
  • TListControl::getSelectedIndices()
  • TListControl::getSelectedItem()
  • TListControl::getSelectedValue()
  • TListControl::getSelectedValues()
  • TListControl::getTagName()
  • TListControl::getText()
  • TListControl::getValidationGroup()
  • TListControl::loadState()
    Loads items from viewstate.
  • TListControl::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event when selection is changed.
  • TListControl::onTextChanged()
    Raises OnTextChanged event when selection is changed.
  • TListControl::performDataBinding()
    Performs databinding to populate list items from data source.
  • TListControl::renderClientControlScript()
    Renders the javascript for list control.
  • TListControl::renderContents()
    Renders body content of the list control.
  • TListControl::renderPrompt()
    Renders the prompt text, if any.
  • TListControl::saveState()
    Saves items into viewstate.
  • TListControl::setAppendDataBoundItems()
  • TListControl::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TListControl::setCausesValidation()
  • TListControl::setData()
    Selects an item by the specified value.
  • TListControl::setDataGroupField()
  • TListControl::setDataTextField()
  • TListControl::setDataTextFormatString()
    Sets data text format string.
  • TListControl::setDataValueField()
  • TListControl::setEnableClientScript()
  • TListControl::setPromptText()
  • TListControl::setPromptValue()
  • TListControl::setSelectedIndex()
  • TListControl::setSelectedIndices()
  • TListControl::setSelectedValue()
    Sets selection by item value.
  • TListControl::setSelectedValues()
  • TListControl::setText()
  • TListControl::setValidationGroup()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveDropDownList::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveDropDownList::addAttributesToRender

    addAttributesToRender( $writer );

    Overrides TDropDownList::addAttributesToRender() (Adds attributes to renderer.)

    Parameters

    $writer

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    access

    protected

    [ Top ]

    TActiveDropDownList::createListItemCollection

    createListItemCollection( );

    Overrides TListControl::createListItemCollection() (Creates a collection object to hold list items.)

    Returns

    the collection object

    Remarks

    Creates a collection object to hold list items. A specialized TActiveListItemCollection is created to allow the drop down list options to be added.

    This method may be overriden to create a customized collection.

    access

    protected

    [ Top ]

    TActiveDropDownList::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveDropDownList::getClientClassName

    getClientClassName( );

    Overrides TDropDownList::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    no javascript class name.

    Remarks

    No client class for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TActiveDropDownList::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveDropDownList::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveDropDownList::onPreRender

    onPreRender( $param );

    Overrides TDataBoundControl::onPreRender() (Ensures any pending databind is performed.)

    Parameters

    $param

    Remarks

    Updates the client-side options if the item list has changed after the OnLoad event.

    access

    public

    [ Top ]

    TActiveDropDownList::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by ICallbackEventHandler interface.

    This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveDropDownList::renderClientControlScript

    renderClientControlScript( $writer );

    Overrides TListControl::renderClientControlScript() (Renders the javascript for list control.)

    Parameters

    $writer

    Remarks

    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:11 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveFileUpload

Class TActiveFileUpload

[line 45]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TFileUpload
               |
               --TActiveFileUpload
Location: /Web/UI/ActiveControls/TActiveFileUpload.php

Remarks

TActiveFileUpload

TActiveFileUpload displays a file upload field on a page. Upon postback, the text entered into the field will be treated as the name of the file that will be uploaded to the server. The property HasFile indicates whether the file upload is successful. If successful, the file may be obtained by calling saveAs to save it at a specified place. You can use FileName, FileType, FileSize to get the original client-side file name, the file mime type, and the file size information. If the upload is not successful, ErrorCode contains the error code describing the cause of failure.

TActiveFileUpload raises OnFileUpload event if a file is uploaded (whether it succeeds or not).

TActiveFileUpload actually does a postback in a hidden IFrame, and then does a callback. This callback then raises the OnFileUpload event. After the postback a status icon is displayed; either a green checkmark if the upload is successful, or a red x if there was an error.

author

Christophe Boulain <Christophe.Boulain@gmail.com>

author

Bradley Booms <Bradley.Booms@nsighttel.com>

version

$Id: TActiveFileUpload.php 3159 2012-06-01 18:01:40Z ctrlaltca $

Class Variable Summary

Class Constant Summary

  • SCRIPT_PATH =  'prado/activefileupload'

Inherited Class Constant Summary

Inherited From Class TFileUpload

  • TFileUpload::MAX_FILE_SIZE = 1048576
    Maximum file size (in bytes) allowed to be uploaded, defaults to 1MB.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TFileUpload

  • TFileUpload::$_errorCode = UPLOAD_ERR_NO_FILE

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TFileUpload

  • TFileUpload::addAttributesToRender()
    Sets name attribute to the unique ID of the control.
  • TFileUpload::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TFileUpload::getErrorCode()
    Returns an error code describing the status of this file uploading.
  • TFileUpload::getFileName()
  • TFileUpload::getFileSize()
  • TFileUpload::getFileType()
  • TFileUpload::getHasFile()
  • TFileUpload::getIsValid()
    Returns true if this control validated successfully.
  • TFileUpload::getLocalName()
  • TFileUpload::getMaxFileSize()
  • TFileUpload::getTagName()
  • TFileUpload::getValidationPropertyValue()
    Returns the original file name as the property value to be validated.
  • TFileUpload::loadPostData()
    Loads user input data.
  • TFileUpload::onFileUpload()
    This method is invoked when a file is uploaded during a postback.
  • TFileUpload::onPreRender()
    Sets Enctype of the form on the page.
  • TFileUpload::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TFileUpload::saveAs()
    Saves the uploaded file.
  • TFileUpload::setIsValid()
  • TFileUpload::setMaxFileSize()
    Sets the maximum size that a file can be uploaded.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveFileUpload::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveFileUpload::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overrides TFileUpload::addAttributesToRender() (Sets name attribute to the unique ID of the control.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds ID attribute, and renders the javascript for active component.

    access

    public

    [ Top ]

    TActiveFileUpload::createChildControls

    createChildControls( );

    Overrides TControl::createChildControls() (Creates child controls.)

    access

    public

    [ Top ]

    TActiveFileUpload::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveFileUpload::getAssetUrl

    getAssetUrl( [string $file = ''] );

    Parameters

    $file

    asset file in the self::SCRIPT_PATH directory.

    Returns

    asset file url.

    access

    protected

    [ Top ]

    TActiveFileUpload::getAutoPostBack

    getAutoPostBack( );

    Returns

    a value indicating whether an automatic callback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. Defaults to true. Note: When set to false, you will need to trigger the callback yourself.

    access

    public

    [ Top ]

    TActiveFileUpload::getBusyImage

    getBusyImage( );

    Returns

    the image displayed when an upload is in progress.

    access

    public

    [ Top ]

    TActiveFileUpload::getCallbackJavascript

    getCallbackJavascript( );

    Returns

    A chuck of javascript that will need to be called if {AutoPostBack is set to false}

    access

    public

    [ Top ]

    TActiveFileUpload::getClientClassName

    getClientClassName( );

    Returns

    corresponding javascript class name for this control.

    access

    protected

    [ Top ]

    TActiveFileUpload::getClientOptions

    getClientOptions( );

    Returns

    ( inputID => input client ID, flagID => flag client ID, targetName => target unique ID, formID => form client ID, indicatorID => upload indicator client ID, completeID => complete client ID, errorID => error client ID)

    Remarks

    Gets the client side options for this control.

    access

    protected

    [ Top ]

    TActiveFileUpload::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveFileUpload::getErrorImage

    getErrorImage( );

    Returns

    the image displayed when an upload does not complete successfully.

    access

    public

    [ Top ]

    TActiveFileUpload::getSuccessImage

    getSuccessImage( );

    Returns

    the image displayed when an upload completes successfully.

    access

    public

    [ Top ]

    TActiveFileUpload::getTempPath

    getTempPath( );

    Returns

    the path where the uploaded file will be stored temporarily, in namespace format default "Application.runtime.*"

    access

    public

    [ Top ]

    TActiveFileUpload::onFileUpload

    onFileUpload( TEventParameter $param );

    Overrides TFileUpload::onFileUpload() (This method is invoked when a file is uploaded during a postback.)

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a file is uploaded.

    If you override this method, be sure to call the parent implementation to ensure the invocation of the attached event handlers.

    access

    public

    [ Top ]

    TActiveFileUpload::onInit

    onInit( $sender );

    Overrides TControl::onInit() (This method is invoked when the control enters 'OnInit' stage.)

    Parameters

    $sender

    throws

    TInvalidDataValueException if the TempPath is not writable.

    access

    public

    [ Top ]

    TActiveFileUpload::onPreRender

    onPreRender( $param );

    Overrides TFileUpload::onPreRender() (Sets Enctype of the form on the page.)

    Parameters

    $param

    Remarks

    Publish the javascript

    access

    public

    [ Top ]

    TActiveFileUpload::onUnload

    onUnload( $param );

    Overrides TControl::onUnload() (This method is invoked when the control enters 'OnUnload' stage.)

    Parameters

    $param

    Remarks

    Removes localfile on ending of the callback.

    access

    public

    [ Top ]

    TActiveFileUpload::popParamsByToken

    popParamsByToken( $token );

    Parameters

    $token

    access

    protected

    [ Top ]

    TActiveFileUpload::pushParamsAndGetToken

    pushParamsAndGetToken( TActiveFileUploadCallbackParams $params );

    Parameters

    $params

    access

    protected

    [ Top ]

    TActiveFileUpload::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises OnFileUpload event.

    This method is required by ICallbackEventHandler interface. This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveFileUpload::raisePostDataChangedEvent

    raisePostDataChangedEvent( );

    Overrides TFileUpload::raisePostDataChangedEvent() (Raises postdata changed event.)

    Remarks

    Raises postdata changed event.

    This method calls onFileUpload method This method is primarily used by framework developers.

    access

    public

    [ Top ]

    TActiveFileUpload::saveAs

    saveAs( string $fileName, [boolean $deleteTempFile = true] );

    Overrides TFileUpload::saveAs() (Saves the uploaded file.)

    Parameters

    $fileName

    the file name used to save the uploaded file

    $deleteTempFile

    whether to delete the temporary file after saving. If true, you will not be able to save the uploaded file again.

    Returns

    true if the file saving is successful

    Remarks

    Saves the uploaded file.

    access

    public

    [ Top ]

    TActiveFileUpload::setAutoPostBack

    setAutoPostBack( boolean $value );

    Parameters

    $value

    a value indicating whether an automatic callback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. Defaults to true. Note: When set to false, you will need to trigger the callback yourself.

    access

    public

    [ Top ]

    TActiveFileUpload::setTempPath

    setTempPath( string $value );

    Parameters

    $value

    the path where the uploaded file will be stored temporarily in namespace format default "Application.runtime.*"

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • SCRIPT_PATH =  'prado/activefileupload' [line 48]

Documentation generated on Mon, 25 Jun 2012 14:43:12 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveFileUploadCallbackParams

Class TActiveFileUploadCallbackParams

[line 460]

Location: /Web/UI/ActiveControls/TActiveFileUpload.php

Remarks

TActiveFileUploadCallbackParams is an internal class used by TActiveFileUpload.

author

Christophe Boulain <Christophe.Boulain@gmail.com>

author

Bradley Booms <Bradley.Booms@nsighttel.com>

version

$Id: TActiveFileUpload.php 3159 2012-06-01 18:01:40Z ctrlaltca $

Class Variable Summary

  • $errorCode =

  • $fileName =

  • $fileSize =

  • $fileType =

  • $localName =

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

Variable Detail

  • $errorCode =  [line 466]
    •

  • Data type: mixed
    •

    access

    public

  • $fileName =  [line 463]
    •

  • Data type: mixed
    •

    access

    public

  • $fileSize =  [line 464]
    •

  • Data type: mixed
    •

    access

    public

  • $fileType =  [line 465]
    •

  • Data type: mixed
    •

    access

    public

  • $localName =  [line 462]
    •

  • Data type: mixed
    •

    access

    public

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:13 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveHiddenField

Class TActiveHiddenField

[line 23]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --THiddenField
            |
            --TActiveHiddenField
Location: /Web/UI/ActiveControls/TActiveHiddenField.php

Remarks

TActiveHiddenField class

TActiveHiddenField displays a hidden input field on a Web page. The value of the input field can be accessed via Value property.

author

Carl G. Mathisen <carlgmathisen@gmail.com>

version

$Id: THiddenField.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class THiddenField

  • THiddenField::focus()
    Sets focus to this control.
  • THiddenField::getData()
    Returns the value of the hidden field.
  • THiddenField::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • THiddenField::getEnableTheming()
  • THiddenField::getIsValid()
    Returns true if this control validated successfully.
  • THiddenField::getTagName()
  • THiddenField::getValidationPropertyValue()
    Returns the value to be validated.
  • THiddenField::getValue()
  • THiddenField::loadPostData()
    Loads hidden field data.
  • THiddenField::onValueChanged()
    This method is invoked when the value of the getValue property changes between posts to the server.
  • THiddenField::raisePostDataChangedEvent()
    Raises postdata changed event.
  • THiddenField::render()
    Renders the control.
  • THiddenField::setData()
    Sets the value of the hidden field.
  • THiddenField::setEnableTheming()
  • THiddenField::setIsValid()
  • THiddenField::setSkinID()
  • THiddenField::setValue()
    Sets the value of the THiddenField

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveHiddenField::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveHiddenField::addAttributesToRender

    addAttributesToRender( $writer );

    Parameters

    $writer

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    access

    protected

    [ Top ]

    TActiveHiddenField::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveHiddenField::getClientClassName

    getClientClassName( );

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TActiveHiddenField::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveHiddenField::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveHiddenField::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by ICallbackEventHandler interface.

    This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveHiddenField::renderClientControlScript

    renderClientControlScript( $writer );

    Parameters

    $writer

    Remarks

    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    access

    protected

    [ Top ]

    TActiveHiddenField::setValue

    setValue( string $value );

    Overrides THiddenField::setValue() (Sets the value of the THiddenField)

    Parameters

    $value

    text content for the hidden field

    Remarks

    Client-side Value property can only be updated after the OnLoad stage.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:13 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveHyperLink

Class TActiveHyperLink

[line 28]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --THyperLink
               |
               --TActiveHyperLink
Location: /Web/UI/ActiveControls/TActiveHyperLink.php

Remarks

TActiveHyperLink class.

The active control counterpart of THyperLink component. When TBaseActiveControl::setEnableUpdate property is true the during a callback request, setting Text property will also set the text of the label on the client upon callback completion. Similarly, for other properties such as ImageUrl, NavigateUrl and Target.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveHyperLink.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class THyperLink

  • THyperLink::addAttributesToRender()
    Adds attributes related to a hyperlink element to renderer.
  • THyperLink::createImage()
    Gets the TImage for rendering the ImageUrl property. This is not for creating dynamic images.
  • THyperLink::getData()
    Returns the URL to link to when the THyperLink component is clicked.
  • THyperLink::getImageHeight()
  • THyperLink::getImageUrl()
  • THyperLink::getImageWidth()
  • THyperLink::getNavigateUrl()
  • THyperLink::getTagName()
  • THyperLink::getTarget()
  • THyperLink::getText()
  • THyperLink::renderContents()
    Renders the body content of the hyperlink.
  • THyperLink::setData()
    Sets the URL to link to when the THyperLink component is clicked.
  • THyperLink::setImageHeight()
    Sets the height of the image in the THyperLink
  • THyperLink::setImageUrl()
    Sets the location of image file of the THyperLink.
  • THyperLink::setImageWidth()
    Sets the width of the image in the THyperLink
  • THyperLink::setNavigateUrl()
    Sets the URL to link to when the THyperLink component is clicked.
  • THyperLink::setTarget()
    Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.
  • THyperLink::setText()
    Sets the text caption of the THyperLink.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveHyperLink::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveHyperLink::getActiveControl

    getActiveControl( );

    Returns

    basic active control options.

    access

    public

    [ Top ]

    TActiveHyperLink::setImageUrl

    setImageUrl( string $value );

    Overrides THyperLink::setImageUrl() (Sets the location of image file of the THyperLink.)

    Parameters

    $value

    the image file location

    Remarks

    Sets the location of image file of the THyperLink.

    access

    public

    [ Top ]

    TActiveHyperLink::setNavigateUrl

    setNavigateUrl( string $value );

    Overrides THyperLink::setNavigateUrl() (Sets the URL to link to when the THyperLink component is clicked.)

    Parameters

    $value

    the URL

    Remarks

    Sets the URL to link to when the THyperLink component is clicked.

    access

    public

    [ Top ]

    TActiveHyperLink::setTarget

    setTarget( string $value );

    Overrides THyperLink::setTarget() (Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.)

    Parameters

    $value

    the target window, valid values include '_blank', '_parent', '_self', '_top' and empty string.

    Remarks

    Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.

    access

    public

    [ Top ]

    TActiveHyperLink::setText

    setText( string $value );

    Overrides THyperLink::setText() (Sets the text caption of the THyperLink.)

    Parameters

    $value

    the text value of the label

    Remarks

    On callback response, the inner HTMl of the label is updated.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:14 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveImage

Class TActiveImage

[line 26]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TImage
               |
               --TActiveImage
Location: /Web/UI/ActiveControls/TActiveImage.php

Remarks

TActiveImage class.

TActiveImage allows the AlternateText, ImageAlign, ImageUrl, and DescriptionUrl to be updated during a callback request.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveImage.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TImage

  • TImage::addAttributesToRender()
    Adds attributes related to an HTML image element to renderer.
  • TImage::getAlternateText()
  • TImage::getData()
    Returns the URL of the image file.
  • TImage::getDescriptionUrl()
  • TImage::getImageAlign()
  • TImage::getImageUrl()
  • TImage::getTagName()
  • TImage::renderContents()
    Renders the body content of the image.
  • TImage::setAlternateText()
    Sets the alternative text to be displayed in the TImage when the image is unavailable.
  • TImage::setData()
    Sets the URL of the image.
  • TImage::setDescriptionUrl()
  • TImage::setImageAlign()
    Sets the alignment of the image with respective to other elements on the page.
  • TImage::setImageUrl()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveImage::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveImage::getActiveControl

    getActiveControl( );

    Returns

    basic active control options.

    access

    public

    [ Top ]

    TActiveImage::setAlternateText

    setAlternateText( string $value );

    Overrides TImage::setAlternateText() (Sets the alternative text to be displayed in the TImage when the image is unavailable.)

    Parameters

    $value

    the alternative text

    Remarks

    Sets the alternative text to be displayed in the TImage when the image is unavailable.

    access

    public

    [ Top ]

    TActiveImage::setDescriptionUrl

    setDescriptionUrl( string $value );

    Overrides TImage::setDescriptionUrl() (parent method not documented)

    Parameters

    $value

    the URL to the long description of the image.

    access

    public

    [ Top ]

    TActiveImage::setImageAlign

    setImageAlign( string $value );

    Overrides TImage::setImageAlign() (Sets the alignment of the image with respective to other elements on the page.)

    Parameters

    $value

    the alignment of the image

    Remarks

    Sets the alignment of the image with respective to other elements on the page.

    Possible values include: absbottom, absmiddle, baseline, bottom, left, middle, right, texttop, and top. If an empty string is passed in, imagealign attribute will not be rendered.

    access

    public

    [ Top ]

    TActiveImage::setImageUrl

    setImageUrl( string $value );

    Overrides TImage::setImageUrl() (parent method not documented)

    Parameters

    $value

    the URL of the image file

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:15 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveImageButton

Class TActiveImageButton

[line 28]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TImage
               |
               --TImageButton
                  |
                  --TActiveImageButton
Location: /Web/UI/ActiveControls/TActiveImageButton.php

Remarks

TActiveImageButton class.

TActiveImageButton is the active control counter part to TImageButton. When a TActiveImageButton is clicked, rather than a normal post back request a callback request is initiated.

The OnCallback event is raised during a callback request and it is raise after the OnClick event.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveImageButton.php 3160 2012-06-01 22:30:06Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TImageButton

  • TImageButton::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TImageButton::canCauseValidation()
  • TImageButton::getCausesValidation()
  • TImageButton::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TImageButton::getCommandName()
  • TImageButton::getCommandParameter()
  • TImageButton::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TImageButton::getEnableClientScript()
  • TImageButton::getIsDefaultButton()
  • TImageButton::getPostBackOptions()
    Returns postback specifications for the button.
  • TImageButton::getTagName()
  • TImageButton::getText()
  • TImageButton::getValidationGroup()
  • TImageButton::loadPostData()
    This method checks if the TImageButton is clicked and loads the coordinates of the clicking position.
  • TImageButton::needPostBackScript()
  • TImageButton::onClick()
    This method is invoked when the button is clicked.
  • TImageButton::onCommand()
    This method is invoked when the button is clicked.
  • TImageButton::onPreRender()
    Registers the image button to receive postback data during postback.
  • TImageButton::raisePostBackEvent()
    Raises the postback event.
  • TImageButton::raisePostDataChangedEvent()
    A dummy implementation for the IPostBackDataHandler interface.
  • TImageButton::renderClientControlScript()
    Renders the client-script code.
  • TImageButton::renderContents()
    Renders the body content enclosed between the control tag.
  • TImageButton::setCausesValidation()
  • TImageButton::setCommandName()
  • TImageButton::setCommandParameter()
  • TImageButton::setEnableClientScript()
  • TImageButton::setIsDefaultButton()
  • TImageButton::setText()
  • TImageButton::setValidationGroup()

Inherited From Class TImage

  • TImage::addAttributesToRender()
    Adds attributes related to an HTML image element to renderer.
  • TImage::getAlternateText()
  • TImage::getData()
    Returns the URL of the image file.
  • TImage::getDescriptionUrl()
  • TImage::getImageAlign()
  • TImage::getImageUrl()
  • TImage::getTagName()
  • TImage::renderContents()
    Renders the body content of the image.
  • TImage::setAlternateText()
    Sets the alternative text to be displayed in the TImage when the image is unavailable.
  • TImage::setData()
    Sets the URL of the image.
  • TImage::setDescriptionUrl()
  • TImage::setImageAlign()
    Sets the alignment of the image with respective to other elements on the page.
  • TImage::setImageUrl()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveImageButton::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveImageButton::addAttributesToRender

    addAttributesToRender( $writer );

    Overrides TImageButton::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    access

    protected

    [ Top ]

    TActiveImageButton::getActiveControl

    getActiveControl( );

    Returns

    basic active control options.

    access

    public

    [ Top ]

    TActiveImageButton::getClientClassName

    getClientClassName( );

    Overrides TImageButton::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    corresponding javascript class name for this TActiveLinkButton.

    access

    protected

    [ Top ]

    TActiveImageButton::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveImageButton::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveImageButton::onPreRender

    onPreRender( THtmlWriter $writer );

    Overrides TImageButton::onPreRender() (Registers the image button to receive postback data during postback.)

    Parameters

    $writer

    the renderer.

    Remarks

    Register the x and y hidden input names of the position clicked.

    access

    public

    [ Top ]

    TActiveImageButton::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by

    ICallbackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick event first and then the OnCallback event. This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveImageButton::renderClientControlScript

    renderClientControlScript( $writer );

    Overrides TImageButton::renderClientControlScript() (Renders the client-script code.)

    Parameters

    $writer

    Remarks

    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    access

    protected

    [ Top ]

    TActiveImageButton::setAlternateText

    setAlternateText( string $value );

    Overrides TImage::setAlternateText() (Sets the alternative text to be displayed in the TImage when the image is unavailable.)

    Parameters

    $value

    the alternative text

    Remarks

    Sets the alternative text to be displayed in the TImage when the image is unavailable.

    access

    public

    [ Top ]

    TActiveImageButton::setDescriptionUrl

    setDescriptionUrl( string $value );

    Overrides TImage::setDescriptionUrl() (parent method not documented)

    Parameters

    $value

    the URL to the long description of the image.

    access

    public

    [ Top ]

    TActiveImageButton::setImageAlign

    setImageAlign( string $value );

    Overrides TImage::setImageAlign() (Sets the alignment of the image with respective to other elements on the page.)

    Parameters

    $value

    the alignment of the image

    Remarks

    Sets the alignment of the image with respective to other elements on the page.

    Possible values include: absbottom, absmiddle, baseline, bottom, left, middle, right, texttop, and top. If an empty string is passed in, imagealign attribute will not be rendered.

    access

    public

    [ Top ]

    TActiveImageButton::setImageUrl

    setImageUrl( string $value );

    Overrides TImage::setImageUrl() (parent method not documented)

    Parameters

    $value

    the URL of the image file

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:15 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveLabel

Class TActiveLabel

[line 33]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TActiveLabel
Location: /Web/UI/ActiveControls/TActiveLabel.php

Remarks

TActiveLabel class

The active control counterpart of TLabel component. When TBaseActiveControl::setEnableUpdate property is true the during a callback request, setting Text property will also set the text of the label on the client upon callback completion. Similarly, setting ForControl will also set the client-side "for" attribute on the label.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveLabel.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TLabel

  • TLabel::addAttributesToRender()
    Adds attributes to renderer.
  • TLabel::getData()
    Returns the text value of the label.
  • TLabel::getForControl()
  • TLabel::getTagName()
  • TLabel::getText()
  • TLabel::render()
    Renders the label.
  • TLabel::renderContents()
    Renders the body content of the label.
  • TLabel::setData()
    Sets the text value of the label.
  • TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
  • TLabel::setText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveLabel::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveLabel::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Overrides TLabel::addAttributesToRender() (Adds attributes to renderer.)

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Adds attribute id to the renderer.

    access

    protected

    [ Top ]

    TActiveLabel::getActiveControl

    getActiveControl( );

    Returns

    basic active control options.

    access

    public

    [ Top ]

    TActiveLabel::setForControl

    setForControl( string $value );

    Overrides TLabel::setForControl() (Sets the ID of the control that the label is associated with.)

    Parameters

    $value

    the associated control ID

    Remarks

    Sets the ID of the control that the label is associated with.

    The control must be locatable via TControl::findControl using the ID. On callback response, the For attribute of the label is updated.

    access

    public

    [ Top ]

    TActiveLabel::setText

    setText( string $value );

    Overrides TLabel::setText() (parent method not documented)

    Parameters

    $value

    the text value of the label

    Remarks

    On callback response, the inner HTML of the label is updated.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:16 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveLinkButton

Class TActiveLinkButton

[line 36]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLinkButton
               |
               --TActiveLinkButton
Location: /Web/UI/ActiveControls/TActiveLinkButton.php

Remarks

TActiveLinkButton is the active control counter part to TLinkButton.

When a TActiveLinkButton is clicked, rather than a normal post back request a callback request is initiated.

The OnCallback event is raised during a callback request and it is raise after the OnClick event.

When the TBaseActiveCallbackControl::setEnableUpdate property is true, changing the Text property during callback request will update the link text upon callback response completion.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveLinkButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TLinkButton

  • TLinkButton::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TLinkButton::getCausesValidation()
  • TLinkButton::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TLinkButton::getCommandName()
  • TLinkButton::getCommandParameter()
  • TLinkButton::getData()
    Returns the caption of the button.
  • TLinkButton::getEnableClientScript()
  • TLinkButton::getIsDefaultButton()
  • TLinkButton::getPostBackOptions()
    Returns postback specifications for the button.
  • TLinkButton::getTagName()
  • TLinkButton::getText()
  • TLinkButton::getValidationGroup()
  • TLinkButton::onClick()
    This method is invoked when the button is clicked.
  • TLinkButton::onCommand()
    This method is invoked when the button is clicked.
  • TLinkButton::raisePostBackEvent()
    Raises the postback event.
  • TLinkButton::renderClientControlScript()
    Renders the client-script code.
  • TLinkButton::renderContents()
    Renders the body content enclosed between the control tag.
  • TLinkButton::renderLinkButtonHref()
    Renders the Href for link button.
  • TLinkButton::setCausesValidation()
    Sets the value indicating whether postback event trigger by this button will cause input validation.
  • TLinkButton::setCommandName()
  • TLinkButton::setCommandParameter()
  • TLinkButton::setData()
    Sets the caption of the button.
  • TLinkButton::setEnableClientScript()
  • TLinkButton::setIsDefaultButton()
  • TLinkButton::setText()
  • TLinkButton::setValidationGroup()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveLinkButton::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveLinkButton::addAttributesToRender

    addAttributesToRender( $writer );

    Overrides TLinkButton::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    access

    protected

    [ Top ]

    TActiveLinkButton::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveLinkButton::getClientClassName

    getClientClassName( );

    Overrides TLinkButton::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    corresponding javascript class name for this TActiveLinkButton.

    access

    protected

    [ Top ]

    TActiveLinkButton::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveLinkButton::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveLinkButton::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by

    ICallbackEventHandlerICallbackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick event first and then the OnCallback event. This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveLinkButton::renderClientControlScript

    renderClientControlScript( $writer );

    Overrides TLinkButton::renderClientControlScript() (Renders the client-script code.)

    Parameters

    $writer

    Remarks

    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    access

    protected

    [ Top ]

    TActiveLinkButton::setText

    setText( string $value );

    Overrides TLinkButton::setText() (parent method not documented)

    Parameters

    $value

    caption of the button

    Remarks

    Updates the link text on the client-side if the setEnableUpdate property is set to true.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:16 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveListBox

Class TActiveListBox

[line 28]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TListBox
                     |
                     --TActiveListBox
Location: /Web/UI/ActiveControls/TActiveListBox.php

Remarks

TActiveListBox class.

List items can be added dynamically during a callback request.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveListBox.php 3125 2012-04-01 20:37:12Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TListBox

  • TListBox::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TListBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TListBox::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TListBox::getIsMultiSelect()
  • TListBox::getIsValid()
    Returns true if this control validated successfully.
  • TListBox::getRows()
  • TListBox::getSelectionMode()
  • TListBox::getValidationPropertyValue()
    Returns the value to be validated.
  • TListBox::loadPostData()
    Loads user input data.
  • TListBox::onPreRender()
    Registers the list control to load post data on postback.
  • TListBox::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TListBox::setIsValid()
  • TListBox::setRows()
  • TListBox::setSelectionMode()

Inherited From Class TListControl

  • TListControl::addAttributesToRender()
    Adds attributes to renderer.
  • TListControl::addParsedObject()
    Adds object parsed from template to the control.
  • TListControl::clearSelection()
    Clears all existing selections.
  • TListControl::createListItemCollection()
    Creates a collection object to hold list items.
  • TListControl::formatDataValue()
    Formats the text value according to a format string.
  • TListControl::getAppendDataBoundItems()
  • TListControl::getAutoPostBack()
  • TListControl::getCausesValidation()
  • TListControl::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TListControl::getData()
    Returns the value of the selected item with the lowest cardinal index.
  • TListControl::getDataGroupField()
  • TListControl::getDataTextField()
  • TListControl::getDataTextFormatString()
  • TListControl::getDataValueField()
  • TListControl::getEnableClientScript()
  • TListControl::getHasItems()
  • TListControl::getIsMultiSelect()
  • TListControl::getItemCount()
  • TListControl::getItems()
  • TListControl::getPostBackOptions()
  • TListControl::getPromptText()
  • TListControl::getPromptValue()
  • TListControl::getSelectedIndex()
  • TListControl::getSelectedIndices()
  • TListControl::getSelectedItem()
  • TListControl::getSelectedValue()
  • TListControl::getSelectedValues()
  • TListControl::getTagName()
  • TListControl::getText()
  • TListControl::getValidationGroup()
  • TListControl::loadState()
    Loads items from viewstate.
  • TListControl::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event when selection is changed.
  • TListControl::onTextChanged()
    Raises OnTextChanged event when selection is changed.
  • TListControl::performDataBinding()
    Performs databinding to populate list items from data source.
  • TListControl::renderClientControlScript()
    Renders the javascript for list control.
  • TListControl::renderContents()
    Renders body content of the list control.
  • TListControl::renderPrompt()
    Renders the prompt text, if any.
  • TListControl::saveState()
    Saves items into viewstate.
  • TListControl::setAppendDataBoundItems()
  • TListControl::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TListControl::setCausesValidation()
  • TListControl::setData()
    Selects an item by the specified value.
  • TListControl::setDataGroupField()
  • TListControl::setDataTextField()
  • TListControl::setDataTextFormatString()
    Sets data text format string.
  • TListControl::setDataValueField()
  • TListControl::setEnableClientScript()
  • TListControl::setPromptText()
  • TListControl::setPromptValue()
  • TListControl::setSelectedIndex()
  • TListControl::setSelectedIndices()
  • TListControl::setSelectedValue()
    Sets selection by item value.
  • TListControl::setSelectedValues()
  • TListControl::setText()
  • TListControl::setValidationGroup()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveListBox::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveListBox::addAttributesToRender

    addAttributesToRender( $writer );

    Overrides TListBox::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    access

    protected

    [ Top ]

    TActiveListBox::createListItemCollection

    createListItemCollection( );

    Overrides TListControl::createListItemCollection() (Creates a collection object to hold list items.)

    Returns

    the collection object

    Remarks

    Creates a collection object to hold list items. A specialized TActiveListItemCollection is created to allow the drop down list options to be added.

    This method may be overriden to create a customized collection.

    access

    protected

    [ Top ]

    TActiveListBox::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveListBox::getClientClassName

    getClientClassName( );

    Overrides TListBox::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    no javascript class name.

    Remarks

    Javascript client class for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TActiveListBox::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveListBox::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveListBox::onPreRender

    onPreRender( $param );

    Overrides TListBox::onPreRender() (Registers the list control to load post data on postback.)

    Parameters

    $param

    Remarks

    Updates the client-side options if the item list has changed after the OnLoad event.

    access

    public

    [ Top ]

    TActiveListBox::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by ICallbackEventHandler interface.

    This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveListBox::renderClientControlScript

    renderClientControlScript( $writer );

    Overrides TListControl::renderClientControlScript() (Renders the javascript for list control.)

    Parameters

    $writer

    Remarks

    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    access

    protected

    [ Top ]

    TActiveListBox::setSelectionMode

    setSelectionMode( string $value );

    Overrides TListBox::setSelectionMode() (parent method not documented)

    Parameters

    $value

    the selection mode

    Remarks

    Sets the selection mode of the list control (Single, Multiple) on the client-side if the setEnableUpdate property is set to true.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:17 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveListControlAdapter

Class TActiveListControlAdapter

[line 30]
TComponent
   |
   --TApplicationComponent
      |
      --TControlAdapter
         |
         --TActiveControlAdapter
            |
            --TActiveListControlAdapter
Location: /Web/UI/ActiveControls/TActiveListControlAdapter.php

Remarks

TActiveListControlAdapter class.

Adapte the list controls to allows the selections on the client-side to be altered during callback response.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveListControlAdapter.php 3052 2011-10-21 09:06:19Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TControlAdapter

  • TControlAdapter::$_control =

Method Summary

Inherited Method Summary

Inherited From Class TActiveControlAdapter

  • TActiveControlAdapter::__construct()
    Constructor.
  • TActiveControlAdapter::getBaseActiveControl()
  • TActiveControlAdapter::getIsTrackingPageState()
  • TActiveControlAdapter::getStateTracker()
  • TActiveControlAdapter::onLoad()
    Starts viewstate tracking if necessary after when controls has been loaded
  • TActiveControlAdapter::onPreRender()
    Publish the ajax script
  • TActiveControlAdapter::render()
    Renders the callback client scripts.
  • TActiveControlAdapter::renderCallbackClientScripts()
    Register the callback clientscripts and sets the post loader IDs.
  • TActiveControlAdapter::saveState()
    Saves additional persistent control state. Respond to viewstate changes if necessary.
  • TActiveControlAdapter::setBaseActiveControl()
  • TActiveControlAdapter::setBaseControlClass()

Inherited From Class TControlAdapter

  • TControlAdapter::__construct()
    Constructor.
  • TControlAdapter::createChildControls()
    Creates child controls for the attached control.
  • TControlAdapter::getControl()
  • TControlAdapter::getPage()
  • TControlAdapter::loadState()
    Loads additional persistent control state.
  • TControlAdapter::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControlAdapter::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControlAdapter::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControlAdapter::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControlAdapter::render()
    This method is invoked when the control renders itself.
  • TControlAdapter::renderChildren()
    Renders the control's children.
  • TControlAdapter::saveState()
    Saves additional persistent control state.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveListControlAdapter::canUpdateClientSide

    canUpdateClientSide( );

    Returns

    true if can update client-side attributes.

    access

    protected

    [ Top ]

    TActiveListControlAdapter::clearSelection

    clearSelection( );

    Implementation of:
    IListControlAdapter::clearSelection()
    Clears all existing selections on the client side.

    Remarks

    Clears all existing selections on the client side.

    access

    public

    [ Top ]

    TActiveListControlAdapter::setSelectedIndex

    setSelectedIndex( integer $index );

    Implementation of:
    IListControlAdapter::setSelectedIndex()
    Selects an item based on zero-base index on the client side.

    Parameters

    $index

    the index (zero-based) of the item to be selected

    Remarks

    Selects an item based on zero-base index on the client side.

    access

    public

    [ Top ]

    TActiveListControlAdapter::setSelectedIndices

    setSelectedIndices( array $indices );

    Implementation of:
    IListControlAdapter::setSelectedIndices()
    Selects a list of item based on zero-base indices on the client side.

    Parameters

    $indices

    list of index of items to be selected

    Remarks

    Selects a list of item based on zero-base indices on the client side.

    access

    public

    [ Top ]

    TActiveListControlAdapter::setSelectedValue

    setSelectedValue( string $value );

    Implementation of:
    IListControlAdapter::setSelectedValue()
    Sets selection by item value on the client side.

    Parameters

    $value

    the value of the item to be selected.

    Remarks

    Sets selection by item value on the client side.

    access

    public

    [ Top ]

    TActiveListControlAdapter::setSelectedValues

    setSelectedValues( array $values );

    Implementation of:
    IListControlAdapter::setSelectedValues()
    Sets selection by a list of item values on the client side.

    Parameters

    $values

    list of the selected item values

    Remarks

    Sets selection by a list of item values on the client side.

    access

    public

    [ Top ]

    TActiveListControlAdapter::updateListItems

    updateListItems( );

    Remarks

    Update the client-side list options.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:18 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveListItemCollection

Class TActiveListItemCollection

[line 177]
TComponent
   |
   --TList
      |
      --TListItemCollection
         |
         --TActiveListItemCollection
Location: /Web/UI/ActiveControls/TActiveListControlAdapter.php

Remarks

TActiveListItemCollection class.

Allows TActiveDropDownList and TActiveListBox to add new options during callback response. New options can only be added after the TControl::onLoad event.

The ListHasChanged property is true when the list items has changed. The control responsible for the list needs to repopulate the client-side options.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveListControlAdapter.php 3052 2011-10-21 09:06:19Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TListItemCollection

  • TListItemCollection::createListItem()
    Creates a list item object.
  • TListItemCollection::createNewListItem()
  • TListItemCollection::findIndexByText()
    Finds the lowest cardinal index of the item whose text is the one being looked for.
  • TListItemCollection::findIndexByValue()
    Finds the lowest cardinal index of the item whose value is the one being looked for.
  • TListItemCollection::findItemByText()
    Finds the item whose text is the one being looked for.
  • TListItemCollection::findItemByValue()
    Finds the item whose value is the one being looked for.
  • TListItemCollection::insertAt()
    Inserts an item into the collection.
  • TListItemCollection::loadState()
    Loads state into every item in the collection.
  • TListItemCollection::saveState()
    Saves state of items.

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveListItemCollection::canUpdateClientSide

    canUpdateClientSide( );

    Returns

    true if active controls can update client-side and the onLoad event has already been raised.

    access

    protected

    [ Top ]

    TActiveListItemCollection::getControl

    getControl( );

    Returns

    active control using the collection.

    access

    public

    [ Top ]

    TActiveListItemCollection::getListHasChanged

    getListHasChanged( );

    Returns

    true if the list has changed after onLoad event.

    access

    public

    [ Top ]

    TActiveListItemCollection::insertAt

    insertAt( integer $index, TListItem $value );

    Overrides TListItemCollection::insertAt() (Inserts an item into the collection.)

    Parameters

    $index

    the location where the item will be inserted. The current item at the place and the following ones will be moved backward.

    $value

    the item to be inserted.

    Remarks

    Inserts an item into the collection.

    The new option is added on the client-side during callback.

    throws

    TInvalidDataTypeException if the item being inserted is neither a string nor TListItem

    access

    public

    [ Top ]

    TActiveListItemCollection::removeAt

    removeAt( int $index );

    Overrides TList::removeAt() (Removes an item at the specified position.)

    Parameters

    $index

    zero based index.

    Remarks

    Removes an item from at specified index.

    access

    public

    [ Top ]

    TActiveListItemCollection::setControl

    setControl( $control );

    Parameters

    $control

    a active list control.

    access

    public

    [ Top ]

    TActiveListItemCollection::updateClientSide

    updateClientSide( );

    Remarks

    Update client-side list items.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:18 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveMultiView

Class TActiveMultiView

[line 30]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TMultiView
            |
            --TActiveMultiView
Location: /Web/UI/ActiveControls/TActiveMultiView.php

Remarks

TActiveMultiView class.

TActiveMultiView is the active counterpart to the original TMultiView control. It re-renders on Callback when ActiveView or ActiveViewIndex is called.

Please refer to the original documentation of the regular counterpart for usage.

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: TMultiView.php 3055 2011-10-31 08:20:28Z ctrlaltca@gmail.com $

since

3.1.6

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TMultiView

  • TMultiView::CMD_NEXTVIEW = 'NextView'
  • TMultiView::CMD_PREVIOUSVIEW = 'PreviousView'
  • TMultiView::CMD_SWITCHVIEWID = 'SwitchViewID'
  • TMultiView::CMD_SWITCHVIEWINDEX = 'SwitchViewIndex'

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TMultiView

  • TMultiView::activateView()
    Activates the specified view.
  • TMultiView::addParsedObject()
    Processes an object that is created during parsing template.
  • TMultiView::bubbleEvent()
    Processes the events bubbled from child controls.
  • TMultiView::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TMultiView::getActiveView()
  • TMultiView::getActiveViewIndex()
  • TMultiView::getViews()
  • TMultiView::ignoreBubbleEvents()
    Makes the multiview ignore all bubbled events.
  • TMultiView::loadState()
    Loads state into the wizard.
  • TMultiView::onActiveViewChanged()
    Raises OnActiveViewChanged event.
  • TMultiView::onInit()
    Initializes the active view if any.
  • TMultiView::render()
    Renders the currently active view.
  • TMultiView::setActiveView()
  • TMultiView::setActiveViewIndex()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveMultiView::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter.

    access

    public

    [ Top ]

    TActiveMultiView::getActiveControl

    getActiveControl( );

    Returns

    standard active control options.

    access

    public

    [ Top ]

    TActiveMultiView::getContainerID

    getContainerID( );

    Returns

    container id

    Remarks

    Returns the id of the surrounding container (span).

    access

    protected

    [ Top ]

    TActiveMultiView::render

    render( THtmlWriter $writer );

    Overrides TMultiView::render() (Renders the currently active view.)

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the TActiveMultiView.

    If the MutliView did not pass the prerender phase yet, it will register itself for rendering later. Else it will call the renderMultiView() method which will do the rendering of the MultiView.

    access

    public

    [ Top ]

    TActiveMultiView::renderMultiView

    renderMultiView( $writer $writer );

    Parameters

    $writer

    THtmlWriter writer for the rendering purpose

    Remarks

    Renders the TActiveMultiView by writing a span tag with the container id obtained from getContainerID() which will be called by the replacement method of the client script to update it's content.

    access

    protected

    [ Top ]

    TActiveMultiView::setActiveView

    setActiveView( TView $value );

    Overrides TMultiView::setActiveView() (parent method not documented)

    Parameters

    $value

    the view to be activated

    throws

    TInvalidOperationException if the view is not in the view collection

    access

    public

    [ Top ]

    TActiveMultiView::setActiveViewIndex

    setActiveViewIndex( integer $value );

    Overrides TMultiView::setActiveViewIndex() (parent method not documented)

    Parameters

    $value

    the zero-based index of the current view in the view collection. -1 if no active view.

    throws

    TInvalidDataValueException if the view index is invalid

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:18 +0200 by phpDocumentor 1.4.3


Docs For Class TActivePageAdapter

Class TActivePageAdapter

[line 32]
TComponent
   |
   --TApplicationComponent
      |
      --TControlAdapter
         |
         --TActivePageAdapter
Location: /Web/UI/ActiveControls/TActivePageAdapter.php

Remarks

TActivePageAdapter class.

Callback request handler.

author

Gabor Berczi <gabor.berczi@devworx.hu> (lazyload additions & progressive rendering)

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActivePageAdapter.php 3010 2011-07-16 09:28:55Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

  • CALLBACK_ACTION_HEADER =  'X-PRADO-ACTIONS'
    Callback response client-side action header name.
  • CALLBACK_DATA_HEADER =  'X-PRADO-DATA'
    Callback response data header name.
  • CALLBACK_ERROR_HEADER =  'X-PRADO-ERROR'
    Callback error header name.
  • CALLBACK_HIDDENFIELDLIST_HEADER =  'X-PRADO-HIDDENFIELDLIST'
    Hidden field list header name.
  • CALLBACK_PAGESTATE_HEADER =  'X-PRADO-PAGESTATE'
    Callback page state header name.
  • CALLBACK_REDIRECT =  'X-PRADO-REDIRECT'
    Callback redirect url header name.
  • CALLBACK_SCRIPTLIST_HEADER =  'X-PRADO-SCRIPTLIST'
    Script list header name.
  • CALLBACK_STYLESHEETLIST_HEADER =  'X-PRADO-STYLESHEETLIST'
    Stylesheet list header name.

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TControlAdapter

  • TControlAdapter::$_control =

Method Summary

Inherited Method Summary

Inherited From Class TControlAdapter

  • TControlAdapter::__construct()
    Constructor.
  • TControlAdapter::createChildControls()
    Creates child controls for the attached control.
  • TControlAdapter::getControl()
  • TControlAdapter::getPage()
  • TControlAdapter::loadState()
    Loads additional persistent control state.
  • TControlAdapter::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControlAdapter::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControlAdapter::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControlAdapter::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControlAdapter::render()
    This method is invoked when the control renders itself.
  • TControlAdapter::renderChildren()
    Renders the control's children.
  • TControlAdapter::saveState()
    Saves additional persistent control state.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActivePageAdapter::__construct

    __construct( $control );

    Overrides TControlAdapter::__construct() (Constructor.)

    Parameters

    $control

    Remarks

    Constructor, trap errors and exception to let the callback response handle them.

    access

    public

    [ Top ]

    TActivePageAdapter::getCallbackClientHandler

    getCallbackClientHandler( );

    Returns

    callback client handler.

    Remarks

    Gets the callback client script handler. It handlers the javascript functions to be executed during the callback response.

    access

    public

    [ Top ]

    TActivePageAdapter::getCallbackEventParameter

    getCallbackEventParameter( );

    Returns

    postback event parameter

    Remarks

    Gets callback parameter. JSON encoding is assumed.

    access

    public

    [ Top ]

    TActivePageAdapter::getCallbackEventTarget

    getCallbackEventTarget( );

    Returns

    the control responsible for the current callback event, null if nonexistent

    access

    public

    [ Top ]

    TActivePageAdapter::processCallbackEvent

    processCallbackEvent( THtmlWriter $writer );

    Parameters

    $writer

    html content writer.

    Remarks

    Process the callback request.

    access

    public

    [ Top ]

    TActivePageAdapter::redirect

    redirect( string $url );

    Parameters

    $url

    new url to load.

    Remarks

    Redirect url on the client-side using javascript.

    access

    protected

    [ Top ]

    TActivePageAdapter::registerControlToRender

    registerControlToRender( TControl $control, THtmlWriter $writer );

    Parameters

    $control

    control for defered rendering

    $writer

    the renderer

    Remarks

    Register a control for defered render() call.

    access

    public

    [ Top ]

    TActivePageAdapter::renderCallbackResponse

    renderCallbackResponse( THtmlWriter $writer );

    Parameters

    $writer

    html content writer.

    Remarks

    Render the callback response.

    access

    public

    [ Top ]

    TActivePageAdapter::renderResponse

    renderResponse( THtmlWriter $writer );

    Parameters

    $writer

    html content writer.

    Remarks

    Renders the callback response by adding additional callback data and javascript actions in the header and page state if required.

    access

    protected

    [ Top ]

    TActivePageAdapter::setCallbackEventParameter

    setCallbackEventParameter( mixed $value );

    Parameters

    $value

    postback event parameter

    access

    public

    [ Top ]

    TActivePageAdapter::setCallbackEventTarget

    setCallbackEventTarget( $control );

    Parameters

    $control

    control registered to raise callback event.

    Remarks

    Registers a control to raise callback event in the current request.

    access

    public

    [ Top ]

    TActivePageAdapter::trapCallbackErrorsExceptions

    trapCallbackErrorsExceptions( );

    Remarks

    Trap errors and exceptions to be handled by TCallbackErrorHandler.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

  • CALLBACK_ACTION_HEADER =  'X-PRADO-ACTIONS' [line 41]

    • Remarks

    Callback response client-side action header name.

  • CALLBACK_DATA_HEADER =  'X-PRADO-DATA' [line 37]

    • Remarks

    Callback response data header name.

  • CALLBACK_ERROR_HEADER =  'X-PRADO-ERROR' [line 45]

    • Remarks

    Callback error header name.

  • CALLBACK_HIDDENFIELDLIST_HEADER =  'X-PRADO-HIDDENFIELDLIST' [line 61]

    • Remarks

    Hidden field list header name.

  • CALLBACK_PAGESTATE_HEADER =  'X-PRADO-PAGESTATE' [line 49]

    • Remarks

    Callback page state header name.

  • CALLBACK_REDIRECT =  'X-PRADO-REDIRECT' [line 66]

    • Remarks

    Callback redirect url header name.

  • CALLBACK_SCRIPTLIST_HEADER =  'X-PRADO-SCRIPTLIST' [line 53]

    • Remarks

    Script list header name.

  • CALLBACK_STYLESHEETLIST_HEADER =  'X-PRADO-STYLESHEETLIST' [line 57]

    • Remarks

    Stylesheet list header name.

Documentation generated on Mon, 25 Jun 2012 14:43:19 +0200 by phpDocumentor 1.4.3


Docs For Class TCallbackErrorHandler

Class TCallbackErrorHandler

[line 338]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TErrorHandler
            |
            --TCallbackErrorHandler
Location: /Web/UI/ActiveControls/TActivePageAdapter.php

Remarks

TCallbackErrorHandler class.

Captures errors and exceptions and send them back during callback response. When the application is in debug mode, the error and exception stack trace are shown. A TJavascriptLogger must be present on the client-side to view the error stack trace.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActivePageAdapter.php 3010 2011-07-16 09:28:55Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TErrorHandler

  • TErrorHandler::ERROR_FILE_NAME = 'error'
    error template file basename
  • TErrorHandler::EXCEPTION_FILE_NAME = 'exception'
    exception template file basename
  • TErrorHandler::SOURCE_LINES = 12
    number of lines before and after the error line to be displayed in case of an exception

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TErrorHandler

  • TErrorHandler::displayException()
    Displays exception information.
  • TErrorHandler::getErrorTemplate()
    Retrieves the template used for displaying external exceptions.
  • TErrorHandler::getErrorTemplatePath()
  • TErrorHandler::getExceptionTemplate()
    Retrieves the template used for displaying internal exceptions.
  • TErrorHandler::handleError()
    Handles PHP user errors and exceptions.
  • TErrorHandler::handleExternalError()
    Displays error to the client user.
  • TErrorHandler::handleRecursiveError()
    Handles error occurs during error handling (called recursive error).
  • TErrorHandler::hideSecurityRelated()
  • TErrorHandler::init()
    Initializes the module.
  • TErrorHandler::setErrorTemplatePath()
    Sets the path storing all error and exception template files.

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCallbackErrorHandler::displayException

    displayException( Exception $exception );

    Overrides TErrorHandler::displayException() (Displays exception information.)

    Parameters

    $exception

    exception details.

    Remarks

    Displays the exceptions to the client-side TJavascriptLogger.

    A HTTP 500 status code is sent and the stack trace is sent as JSON encoded.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:19 +0200 by phpDocumentor 1.4.3


Docs For Class TInvalidCallbackException

Class TInvalidCallbackException

[line 398]
Exception
   |
   --TException
      |
      --TInvalidCallbackException
Location: /Web/UI/ActiveControls/TActivePageAdapter.php

Remarks

TInvalidCallbackException class.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActivePageAdapter.php 3010 2011-07-16 09:28:55Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:19 +0200 by phpDocumentor 1.4.3


Docs For Class TActivePager

Class TActivePager

[line 32]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPager
               |
               --TActivePager
Location: /Web/UI/ActiveControls/TActivePager.php

Remarks

TActivePager is the active control counter part of TPager.

When a page change is requested, TActivePager raises a callback instead of the traditional postback.

The OnCallback event is raised during a callback request and it is raise after the OnPageIndexChanged event.

author

"gevik" (forum contributor) and Christophe Boulain (Christophe.Boulain@gmail.com)

version

$Id: TActivePager.php 3145 2012-05-19 11:08:20Z ctrlaltca $

since

3.1.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TPager

  • TPager::CMD_PAGE = 'Page'
    Command name that TPager understands.
  • TPager::CMD_PAGE_FIRST = 'First'
  • TPager::CMD_PAGE_LAST = 'Last'
  • TPager::CMD_PAGE_NEXT = 'Next'
  • TPager::CMD_PAGE_PREV = 'Previous'

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TPager

  • TPager::bubbleEvent()
    Processes a bubbled event.
  • TPager::buildListPager()
    Builds a dropdown list pager
  • TPager::buildNextPrevPager()
    Builds a next-prev pager
  • TPager::buildNumericPager()
    Builds a numeric pager
  • TPager::buildPager()
    Builds the pager content based on the pager mode.
  • TPager::createPagerButton()
    Creates a pager button.
  • TPager::getButtonType()
  • TPager::getControlToPaginate()
  • TPager::getCurrentPageIndex()
  • TPager::getFirstPageImageUrl()
  • TPager::getFirstPageText()
  • TPager::getIsFirstPage()
  • TPager::getIsLastPage()
  • TPager::getLastPageImageUrl()
  • TPager::getLastPageText()
  • TPager::getMode()
  • TPager::getNextPageImageUrl()
  • TPager::getNextPageText()
  • TPager::getNumericPageImageUrl()
  • TPager::getPageButtonCount()
  • TPager::getPageCount()
  • TPager::getPageImageUrl()
  • TPager::getPrevPageImageUrl()
  • TPager::getPrevPageText()
  • TPager::listIndexChanged()
    Event handler to the OnSelectedIndexChanged event of the dropdown list.
  • TPager::loadState()
    Restores the pager state.
  • TPager::onPageIndexChanged()
    This event is raised when page index is changed due to a page button click.
  • TPager::onPreRender()
    Performs databinding to populate data items from data source.
  • TPager::render()
    Renders the control.
  • TPager::setButtonType()
  • TPager::setControlToPaginate()
    Sets the ID path of the control whose content would be paginated.
  • TPager::setCurrentPageIndex()
  • TPager::setFirstPageImageUrl()
  • TPager::setFirstPageText()
  • TPager::setLastPageImageUrl()
  • TPager::setLastPageText()
  • TPager::setMode()
  • TPager::setNextPageImageUrl()
  • TPager::setNextPageText()
  • TPager::setNumericPageImageUrl()
    Sets the image URL for the numeric page buttons.
  • TPager::setPageButtonCount()
  • TPager::setPageCount()
  • TPager::setPrevPageImageUrl()
  • TPager::setPrevPageText()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActivePager::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActivePager::buildListPager

    buildListPager( );

    Overrides TPager::buildListPager() (Builds a dropdown list pager)

    Remarks

    Builds a dropdown list pager Override parent implementation to build Active dropdown lists.

    access

    protected

    [ Top ]

    TActivePager::createPagerButton

    createPagerButton( string $buttonType, boolean $enabled, string $text, string $commandName, string $commandParameter );

    Overrides TPager::createPagerButton() (Creates a pager button.)

    Parameters

    $buttonType

    button type, either LinkButton or PushButton

    $enabled

    whether the button should be enabled

    $text

    caption of the button

    $commandName

    CommandName corresponding to the OnCommand event of the button

    $commandParameter

    CommandParameter corresponding to the OnCommand event of the button

    Returns

    the button instance

    Remarks

    Creates a pager button.

    Override parent implementation to create, depending on the button type, a TActiveLinkButton, a TActiveButton or a TActiveImageButton may be created.

    access

    protected

    [ Top ]

    TActivePager::getActiveControl

    getActiveControl( );

    Returns

    standard active control options.

    access

    public

    [ Top ]

    TActivePager::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActivePager::handleCallback

    handleCallback( mixed $sender, TCallbackEventParameter $param );

    Parameters

    $sender

    $param

    Remarks

    Event handler to the OnCallback active buttons or active dropdownlist.

    This handler will raise the OnCallback event

    access

    public

    [ Top ]

    TActivePager::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActivePager::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by ICallbackEventHandler interface.

    This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActivePager::render

    render( $writer );

    Overrides TPager::render() (Renders the control.)

    Parameters

    $writer

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:20 +0200 by phpDocumentor 1.4.3


Docs For Class TActivePanel

Class TActivePanel

[line 39]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPanel
               |
               --TActivePanel
Location: /Web/UI/ActiveControls/TActivePanel.php

Remarks

TActivePanel is the TPanel active control counterpart.

TActivePanel allows the client-side panel contents to be updated during a callback response using the render method.

Example: Assume $param is an instance of TCallbackEventParameter attached to the OnCallback event of a TCallback with ID "callback1", and "panel1" is the ID of a TActivePanel.

  •  function callback1_requested($sender, $param)
    •

  •  {
    •

  •         $this->panel1->render($param->getNewWriter());
    •

  •  }
    •

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: TActivePanel.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TPanel

    • TPanel::addAttributesToRender()
      Adds attributes to renderer.
    • TPanel::createStyle()
      Creates a style object to be used by the control.
    • TPanel::getBackImageUrl()
    • TPanel::getDefaultButton()
    • TPanel::getDirection()
    • TPanel::getGroupingText()
    • TPanel::getHorizontalAlign()
    • TPanel::getScrollBars()
    • TPanel::getTagName()
    • TPanel::getWrap()
    • TPanel::render()
    • TPanel::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TPanel::renderEndTag()
      Renders the closing tag for the control
    • TPanel::setBackImageUrl()
      Sets the URL of the background image for the panel component.
    • TPanel::setDefaultButton()
      Specifies the default button for the panel.
    • TPanel::setDirection()
    • TPanel::setGroupingText()
    • TPanel::setHorizontalAlign()
      Sets the horizontal alignment of the contents within the panel.
    • TPanel::setScrollBars()
    • TPanel::setWrap()
      Sets the value indicating whether the content wraps within the panel.

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TActivePanel::__construct

      __construct( );

      Overrides TControl::__construct() (Constructor.)

      Remarks

      Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

      access

      public

      [ Top ]

      TActivePanel::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overrides TPanel::addAttributesToRender() (Adds attributes to renderer.)

      Parameters

      $writer

      the writer used for the rendering purpose

      Remarks

      Adds attribute id to the renderer.

      access

      protected

      [ Top ]

      TActivePanel::getActiveControl

      getActiveControl( );

      Returns

      standard active control options.

      access

      public

      [ Top ]

      TActivePanel::render

      render( THtmlWriter $writer );

      Overrides TPanel::render() (parent method not documented)

      Parameters

      $writer

      html writer

      Remarks

      Renders and replaces the panel's content on the client-side.

      When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:20 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRadioButton

Class TActiveRadioButton

[line 32]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TCheckBox
               |
               --TRadioButton
                  |
                  --TActiveRadioButton
Location: /Web/UI/ActiveControls/TActiveRadioButton.php

Remarks

TActiveRadioButton class.

The active control counter part to radio button. The AutoPostBack property is set to true by default. Thus, when the radio button is clicked a OnCallback event is raise after OnCheckedChanged event.

The Text and Checked properties can be changed during a callback.

The GroupName property may NOT be changed during callback because the client-side <tt>name</tt> attribute is read-only and can not be changed using javascript.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveRadioButton.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TRadioButton

  • TRadioButton::__construct()
    Constructor.
  • TRadioButton::addToPostDataLoader()
    Add the group name as post data loader if group name is set.
  • TRadioButton::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TRadioButton::getEnableClientScript()
  • TRadioButton::getGroupName()
  • TRadioButton::getRadioButtonsInGroup()
    Gets an array of radiobuttons whose group name is the same as this radiobutton's.
  • TRadioButton::getUniqueGroupName()
  • TRadioButton::getValueAttribute()
  • TRadioButton::loadPostData()
    Loads user input data.
  • TRadioButton::onInit()
    Registers the radio button groupings. If overriding onInit method, ensure to call parent implemenation.
  • TRadioButton::onUnLoad()
    Unregisters the radio button groupings. If overriding onInit method, ensure to call parent implemenation.
  • TRadioButton::renderClientControlScript()
    Renders the client-script code.
  • TRadioButton::renderInputTag()
    Renders a radiobutton input element.
  • TRadioButton::setEnableClientScript()
  • TRadioButton::setGroupName()
    Sets the name of the group that the radio button belongs to.
  • TRadioButton::setUniqueGroupName()
    Sets the unique group name that the radio button belongs to.

Inherited From Class TCheckBox

  • TCheckBox::getAutoPostBack()
  • TCheckBox::getCausesValidation()
  • TCheckBox::getChecked()
  • TCheckBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TCheckBox::getData()
    Returns the value indicating whether the checkbox is checked.
  • TCheckBox::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TCheckBox::getEnableClientScript()
  • TCheckBox::getInputAttributes()
  • TCheckBox::getIsValid()
    Returns true if this control validated successfully.
  • TCheckBox::getLabelAttributes()
  • TCheckBox::getPostBackOptions()
    Gets the post back options for this checkbox.
  • TCheckBox::getSpanNeeded()
    Check if we need a span tag to surround this control. The span tag will be created if the Text property is set for this control.
  • TCheckBox::getSurroundingTagID()
  • TCheckBox::getTagName()
  • TCheckBox::getText()
  • TCheckBox::getTextAlign()
  • TCheckBox::getValidationGroup()
  • TCheckBox::getValidationPropertyValue()
    Returns the value of the property that needs validation.
  • TCheckBox::getValue()
  • TCheckBox::getValueAttribute()
  • TCheckBox::loadPostData()
    Loads user input data.
  • TCheckBox::onCheckedChanged()
    Raises OnCheckedChanged event when getChecked changes value during postback.
  • TCheckBox::onPreRender()
    Registers the checkbox to receive postback data during postback.
  • TCheckBox::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TCheckBox::render()
    Renders the checkbox control.
  • TCheckBox::renderClientControlScript()
    Renders the client-script code.
  • TCheckBox::renderInputTag()
    Renders a checkbox input element.
  • TCheckBox::renderLabel()
    Renders a label beside the checkbox.
  • TCheckBox::setAutoPostBack()
    Sets a value indicating whether clicking on the checkbox will post the page.
  • TCheckBox::setCausesValidation()
    Sets the value indicating whether postback event trigger by this checkbox will cause input validation.
  • TCheckBox::setChecked()
    Sets a value indicating whether the checkbox is to be checked or not.
  • TCheckBox::setData()
    Sets the value indicating whether the checkbox is to be checked or not.
  • TCheckBox::setEnableClientScript()
  • TCheckBox::setIsValid()
  • TCheckBox::setText()
    Sets the text caption of the checkbox.
  • TCheckBox::setTextAlign()
  • TCheckBox::setValidationGroup()
  • TCheckBox::setValue()

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveRadioButton::__construct

    __construct( );

    Overrides TRadioButton::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveRadioButton::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveRadioButton::getClientClassName

    getClientClassName( );

    Overrides TRadioButton::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    corresponding javascript class name for this TActiveRadioButton.

    access

    protected

    [ Top ]

    TActiveRadioButton::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveRadioButton::getDefaultLabelID

    getDefaultLabelID( );

    Returns

    radio button label ID;

    access

    protected

    [ Top ]

    TActiveRadioButton::getLabelAttributes

    getLabelAttributes( );

    Overrides TCheckBox::getLabelAttributes() (parent method not documented)

    Returns

    list of attributes to be rendered for label beside the radio button

    Remarks

    Overrides parent implementation to ensure label has ID.

    access

    public

    [ Top ]

    TActiveRadioButton::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveRadioButton::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by ICallbackEventHandler interface.

    This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveRadioButton::renderClientControlScript

    renderClientControlScript( $writer );

    Overrides TRadioButton::renderClientControlScript() (Renders the client-script code.)

    Parameters

    $writer

    Remarks

    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    access

    protected

    [ Top ]

    TActiveRadioButton::renderInputTag

    renderInputTag( $writer, $clientID, $onclick );

    Overrides TRadioButton::renderInputTag() (Renders a radiobutton input element.)

    Parameters

    $writer

    $clientID

    $onclick

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    Since 3.1.4, the javascript code is not rendered if AutoPostBack is false

    access

    protected

    [ Top ]

    TActiveRadioButton::renderLabel

    renderLabel( THtmlWriter $writer, string $clientID, string $text );

    Overrides TCheckBox::renderLabel() (Renders a label beside the checkbox.)

    Parameters

    $writer

    the writer for the rendering purpose

    $clientID

    radio button id

    $text

    label text

    Remarks

    Renders a label beside the radio button.

    access

    protected

    [ Top ]

    TActiveRadioButton::setChecked

    setChecked( boolean $value );

    Overrides TCheckBox::setChecked() (Sets a value indicating whether the checkbox is to be checked or not.)

    Parameters

    $value

    whether the radio button is to be checked or not.

    Remarks

    Checks the radio button.

    Updates radio button checked state on the client-side if the setEnableUpdate property is set to true.

    access

    public

    [ Top ]

    TActiveRadioButton::setText

    setText( string $value );

    Overrides TCheckBox::setText() (Sets the text caption of the checkbox.)

    Parameters

    $value

    caption of the button

    Remarks

    Updates the button text on the client-side if the setEnableUpdate property is set to true.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:21 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRadioButtonList

Class TActiveRadioButtonList

[line 38]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TCheckBoxList
                     |
                     --TRadioButtonList
                        |
                        --TActiveRadioButtonList
Location: /Web/UI/ActiveControls/TActiveRadioButtonList.php

Remarks

TActiveRadioButtonList class.

The active control counter part to radio button list control. The AutoPostBack property is set to true by default. Thus, when a radio button is clicked a OnCallback event is raised after OnSelectedIndexChanged event.

With ActiveControl.EnabledUpdate set to true (default is true), changes to the selection will be updated on the client side.

List items can not be changed dynamically during a callback request.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveRadioButtonList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TRadioButtonList

  • TRadioButtonList::createRepeatedControl()
    Creates a control used for repetition (used as a template).
  • TRadioButtonList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TRadioButtonList::getIsMultiSelect()
  • TRadioButtonList::loadPostData()
    Loads user input data.
  • TRadioButtonList::setSelectedIndices()

Inherited From Class TCheckBoxList

  • TCheckBoxList::__construct()
    Constructor.
  • TCheckBoxList::createRepeatedControl()
    Creates a control used for repetition (used as a template).
  • TCheckBoxList::createStyle()
    Creates a style object for the control.
  • TCheckBoxList::findControl()
    Finds a control by ID.
  • TCheckBoxList::generateItemStyle()
    Returns a style used for rendering items.
  • TCheckBoxList::getCellPadding()
  • TCheckBoxList::getCellSpacing()
  • TCheckBoxList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TCheckBoxList::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TCheckBoxList::getHasFooter()
    Returns a value indicating whether this control contains footer item.
  • TCheckBoxList::getHasHeader()
    Returns a value indicating whether this control contains header item.
  • TCheckBoxList::getHasSeparators()
    Returns a value indicating whether this control contains separator items.
  • TCheckBoxList::getIsMultiSelect()
  • TCheckBoxList::getIsValid()
    Returns true if this control validated successfully.
  • TCheckBoxList::getPostBackOptions()
    Gets the post back options for this checkbox.
  • TCheckBoxList::getRepeatColumns()
  • TCheckBoxList::getRepeatDirection()
  • TCheckBoxList::getRepeatInfo()
  • TCheckBoxList::getRepeatLayout()
  • TCheckBoxList::getSpanNeeded()
    Wether the list should be rendered inside a span or not
  • TCheckBoxList::getTextAlign()
  • TCheckBoxList::getValidationPropertyValue()
    Returns the value to be validated.
  • TCheckBoxList::loadPostData()
    Loads user input data.
  • TCheckBoxList::onPreRender()
    Registers for post data on postback.
  • TCheckBoxList::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TCheckBoxList::render()
    Renders the checkbox list control.
  • TCheckBoxList::renderItem()
    Renders an item in the list.
  • TCheckBoxList::setCellPadding()
    Sets the cellpadding for the table keeping the checkbox list.
  • TCheckBoxList::setCellSpacing()
    Sets the cellspacing for the table keeping the checkbox list.
  • TCheckBoxList::setEnabled()
  • TCheckBoxList::setIsValid()
  • TCheckBoxList::setRepeatColumns()
  • TCheckBoxList::setRepeatDirection()
  • TCheckBoxList::setRepeatLayout()
  • TCheckBoxList::setTextAlign()

Inherited From Class TListControl

  • TListControl::addAttributesToRender()
    Adds attributes to renderer.
  • TListControl::addParsedObject()
    Adds object parsed from template to the control.
  • TListControl::clearSelection()
    Clears all existing selections.
  • TListControl::createListItemCollection()
    Creates a collection object to hold list items.
  • TListControl::formatDataValue()
    Formats the text value according to a format string.
  • TListControl::getAppendDataBoundItems()
  • TListControl::getAutoPostBack()
  • TListControl::getCausesValidation()
  • TListControl::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TListControl::getData()
    Returns the value of the selected item with the lowest cardinal index.
  • TListControl::getDataGroupField()
  • TListControl::getDataTextField()
  • TListControl::getDataTextFormatString()
  • TListControl::getDataValueField()
  • TListControl::getEnableClientScript()
  • TListControl::getHasItems()
  • TListControl::getIsMultiSelect()
  • TListControl::getItemCount()
  • TListControl::getItems()
  • TListControl::getPostBackOptions()
  • TListControl::getPromptText()
  • TListControl::getPromptValue()
  • TListControl::getSelectedIndex()
  • TListControl::getSelectedIndices()
  • TListControl::getSelectedItem()
  • TListControl::getSelectedValue()
  • TListControl::getSelectedValues()
  • TListControl::getTagName()
  • TListControl::getText()
  • TListControl::getValidationGroup()
  • TListControl::loadState()
    Loads items from viewstate.
  • TListControl::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event when selection is changed.
  • TListControl::onTextChanged()
    Raises OnTextChanged event when selection is changed.
  • TListControl::performDataBinding()
    Performs databinding to populate list items from data source.
  • TListControl::renderClientControlScript()
    Renders the javascript for list control.
  • TListControl::renderContents()
    Renders body content of the list control.
  • TListControl::renderPrompt()
    Renders the prompt text, if any.
  • TListControl::saveState()
    Saves items into viewstate.
  • TListControl::setAppendDataBoundItems()
  • TListControl::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TListControl::setCausesValidation()
  • TListControl::setData()
    Selects an item by the specified value.
  • TListControl::setDataGroupField()
  • TListControl::setDataTextField()
  • TListControl::setDataTextFormatString()
    Sets data text format string.
  • TListControl::setDataValueField()
  • TListControl::setEnableClientScript()
  • TListControl::setPromptText()
  • TListControl::setPromptValue()
  • TListControl::setSelectedIndex()
  • TListControl::setSelectedIndices()
  • TListControl::setSelectedValue()
    Sets selection by item value.
  • TListControl::setSelectedValues()
  • TListControl::setText()
  • TListControl::setValidationGroup()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveRadioButtonList::__construct

    __construct( );

    Overrides TCheckBoxList::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveRadioButtonList::createRepeatedControl

    createRepeatedControl( );

    Overrides TRadioButtonList::createRepeatedControl() (Creates a control used for repetition (used as a template).)

    Returns

    the control to be repeated

    Remarks

    Creates a control used for repetition (used as a template).

    access

    protected

    [ Top ]

    TActiveRadioButtonList::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveRadioButtonList::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveRadioButtonList::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveRadioButtonList::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by ICallbackEventHandler interface.

    This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveRadioButtonList::renderClientControlScript

    renderClientControlScript( $writer );

    Overrides TListControl::renderClientControlScript() (Renders the javascript for list control.)

    Parameters

    $writer

    Remarks

    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:22 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRatingList

Class TActiveRatingList

[line 25]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TCheckBoxList
                     |
                     --TRadioButtonList
                        |
                        --TRatingList
                           |
                           --TActiveRatingList
Location: /Web/UI/ActiveControls/TActiveRatingList.php

Remarks

TActiveRatingList Class

Displays clickable images that represent a TRadioButtonList

author

Bradley Booms <bradley[dot]booms[at]gmail[dot]com>

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TRatingList

  • TRatingList::SCRIPT_PATH = 'prado/ratings'
    Script path relative to the TClientScriptManager::SCRIPT_PATH

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TRatingList

  • TRatingList::__construct()
    Sets the default repeat direction to horizontal.
  • TRatingList::getAllowInput()
    Wrapper for setReadOnly property.
  • TRatingList::getAssetUrl()
  • TRatingList::getCaption()
  • TRatingList::getCaptionControl()
  • TRatingList::getCaptionControlID()
  • TRatingList::getCaptionID()
  • TRatingList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TRatingList::getHalfRatingInterval()
  • TRatingList::getPostBackOptions()
  • TRatingList::getRating()
  • TRatingList::getRatingIndex()
  • TRatingList::getRatingStyle()
  • TRatingList::getRatingStyleCssClass()
  • TRatingList::getReadOnly()
  • TRatingList::onPreRender()
    Publish the the rating style css file and rating image files.
  • TRatingList::onSelectedIndexChanged()
  • TRatingList::publishImages()
  • TRatingList::publishStyle()
  • TRatingList::registerClientScript()
    Registers the relevant JavaScript.
  • TRatingList::render()
    Add rating style class name to the class attribute when setReadOnly property is true and when the setCssClass property is empty.
  • TRatingList::setAllowInput()
    Wrapper for setReadOnly property.
  • TRatingList::setCaption()
  • TRatingList::setCaptionID()
  • TRatingList::setEnabled()
    Wrapper for setReadOnly property.
  • TRatingList::setHalfRatingInterval()
    Sets the interval such that those rating values within the interval will be considered as a half star rating.
  • TRatingList::setRating()
  • TRatingList::setRatingStyle()
  • TRatingList::setReadOnly()
  • TRatingList::setRepeatLayout()
    The repeat layout must be Table.
  • TRatingList::setSelectedIndex()

Inherited From Class TRadioButtonList

  • TRadioButtonList::createRepeatedControl()
    Creates a control used for repetition (used as a template).
  • TRadioButtonList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TRadioButtonList::getIsMultiSelect()
  • TRadioButtonList::loadPostData()
    Loads user input data.
  • TRadioButtonList::setSelectedIndices()

Inherited From Class TCheckBoxList

  • TCheckBoxList::__construct()
    Constructor.
  • TCheckBoxList::createRepeatedControl()
    Creates a control used for repetition (used as a template).
  • TCheckBoxList::createStyle()
    Creates a style object for the control.
  • TCheckBoxList::findControl()
    Finds a control by ID.
  • TCheckBoxList::generateItemStyle()
    Returns a style used for rendering items.
  • TCheckBoxList::getCellPadding()
  • TCheckBoxList::getCellSpacing()
  • TCheckBoxList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TCheckBoxList::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TCheckBoxList::getHasFooter()
    Returns a value indicating whether this control contains footer item.
  • TCheckBoxList::getHasHeader()
    Returns a value indicating whether this control contains header item.
  • TCheckBoxList::getHasSeparators()
    Returns a value indicating whether this control contains separator items.
  • TCheckBoxList::getIsMultiSelect()
  • TCheckBoxList::getIsValid()
    Returns true if this control validated successfully.
  • TCheckBoxList::getPostBackOptions()
    Gets the post back options for this checkbox.
  • TCheckBoxList::getRepeatColumns()
  • TCheckBoxList::getRepeatDirection()
  • TCheckBoxList::getRepeatInfo()
  • TCheckBoxList::getRepeatLayout()
  • TCheckBoxList::getSpanNeeded()
    Wether the list should be rendered inside a span or not
  • TCheckBoxList::getTextAlign()
  • TCheckBoxList::getValidationPropertyValue()
    Returns the value to be validated.
  • TCheckBoxList::loadPostData()
    Loads user input data.
  • TCheckBoxList::onPreRender()
    Registers for post data on postback.
  • TCheckBoxList::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TCheckBoxList::render()
    Renders the checkbox list control.
  • TCheckBoxList::renderItem()
    Renders an item in the list.
  • TCheckBoxList::setCellPadding()
    Sets the cellpadding for the table keeping the checkbox list.
  • TCheckBoxList::setCellSpacing()
    Sets the cellspacing for the table keeping the checkbox list.
  • TCheckBoxList::setEnabled()
  • TCheckBoxList::setIsValid()
  • TCheckBoxList::setRepeatColumns()
  • TCheckBoxList::setRepeatDirection()
  • TCheckBoxList::setRepeatLayout()
  • TCheckBoxList::setTextAlign()

Inherited From Class TListControl

  • TListControl::addAttributesToRender()
    Adds attributes to renderer.
  • TListControl::addParsedObject()
    Adds object parsed from template to the control.
  • TListControl::clearSelection()
    Clears all existing selections.
  • TListControl::createListItemCollection()
    Creates a collection object to hold list items.
  • TListControl::formatDataValue()
    Formats the text value according to a format string.
  • TListControl::getAppendDataBoundItems()
  • TListControl::getAutoPostBack()
  • TListControl::getCausesValidation()
  • TListControl::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TListControl::getData()
    Returns the value of the selected item with the lowest cardinal index.
  • TListControl::getDataGroupField()
  • TListControl::getDataTextField()
  • TListControl::getDataTextFormatString()
  • TListControl::getDataValueField()
  • TListControl::getEnableClientScript()
  • TListControl::getHasItems()
  • TListControl::getIsMultiSelect()
  • TListControl::getItemCount()
  • TListControl::getItems()
  • TListControl::getPostBackOptions()
  • TListControl::getPromptText()
  • TListControl::getPromptValue()
  • TListControl::getSelectedIndex()
  • TListControl::getSelectedIndices()
  • TListControl::getSelectedItem()
  • TListControl::getSelectedValue()
  • TListControl::getSelectedValues()
  • TListControl::getTagName()
  • TListControl::getText()
  • TListControl::getValidationGroup()
  • TListControl::loadState()
    Loads items from viewstate.
  • TListControl::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event when selection is changed.
  • TListControl::onTextChanged()
    Raises OnTextChanged event when selection is changed.
  • TListControl::performDataBinding()
    Performs databinding to populate list items from data source.
  • TListControl::renderClientControlScript()
    Renders the javascript for list control.
  • TListControl::renderContents()
    Renders body content of the list control.
  • TListControl::renderPrompt()
    Renders the prompt text, if any.
  • TListControl::saveState()
    Saves items into viewstate.
  • TListControl::setAppendDataBoundItems()
  • TListControl::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TListControl::setCausesValidation()
  • TListControl::setData()
    Selects an item by the specified value.
  • TListControl::setDataGroupField()
  • TListControl::setDataTextField()
  • TListControl::setDataTextFormatString()
    Sets data text format string.
  • TListControl::setDataValueField()
  • TListControl::setEnableClientScript()
  • TListControl::setPromptText()
  • TListControl::setPromptValue()
  • TListControl::setSelectedIndex()
  • TListControl::setSelectedIndices()
  • TListControl::setSelectedValue()
    Sets selection by item value.
  • TListControl::setSelectedValues()
  • TListControl::setText()
  • TListControl::setValidationGroup()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveRatingList::__construct

    __construct( );

    Overrides TRatingList::__construct() (Sets the default repeat direction to horizontal.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveRatingList::callClientFunction

    callClientFunction( string $func, mixed $value );

    Parameters

    $func

    static method name

    $value

    method parmaeter

    Remarks

    Calls the client-side static method for this control class.

    access

    protected

    [ Top ]

    TActiveRatingList::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveRatingList::getClientClassName

    getClientClassName( );

    Overrides TRatingList::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TActiveRatingList::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveRatingList::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveRatingList::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by ICallbackEventHandler interface.

    This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveRatingList::setCaption

    setCaption( string $value );

    Overrides TRatingList::setCaption() (parent method not documented)

    Parameters

    $value

    caption text

    access

    public

    [ Top ]

    TActiveRatingList::setRating

    setRating( float $value );

    Overrides TRatingList::setRating() (parent method not documented)

    Parameters

    $value

    rating value, also sets the selected Index

    access

    public

    [ Top ]

    TActiveRatingList::setReadOnly

    setReadOnly( boolean $value );

    Overrides TRatingList::setReadOnly() (parent method not documented)

    Parameters

    $value

    whether the items in the column can be edited

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:23 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRepeater

Class TActiveRepeater

[line 27]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TRepeater
                  |
                  --TActiveRepeater
Location: /Web/UI/ActiveControls/TActiveRepeater.php

Remarks

TActiveRepeater class

TActiveRepeater represents a data bound and updatable grid control which is the active counterpart to the original TRepeater control.

This component can be used in the same way as the regular datagrid, the only difference is that the active repeater uses callbacks instead of postbacks for interaction.

Please refer to the original documentation of the regular counterparts for usage.

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: TRepeater.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.9

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TRepeater

  • TRepeater::IT_ALTERNATINGITEM = 'AlternatingItem'
  • TRepeater::IT_FOOTER = 'Footer'
  • TRepeater::IT_HEADER = 'Header'
    Repeater item types
  • TRepeater::IT_ITEM = 'Item'
  • TRepeater::IT_SEPARATOR = 'Separator'

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TRepeater

  • TRepeater::bubbleEvent()
    This method overrides parent's implementation to handle onItemCommand event which is bubbled from repeater items and their child controls.
  • TRepeater::createEmptyContent()
    Creates empty repeater content.
  • TRepeater::createItem()
    Creates a repeater item instance based on the item type and index.
  • TRepeater::getAlternatingItemRenderer()
  • TRepeater::getAlternatingItemTemplate()
  • TRepeater::getDataFieldValue()
    Returns the value of the data at the specified field.
  • TRepeater::getDataKeyField()
  • TRepeater::getDataKeys()
  • TRepeater::getEmptyRenderer()
  • TRepeater::getEmptyTemplate()
  • TRepeater::getFooter()
  • TRepeater::getFooterRenderer()
  • TRepeater::getFooterTemplate()
  • TRepeater::getHeader()
  • TRepeater::getHeaderRenderer()
  • TRepeater::getHeaderTemplate()
  • TRepeater::getItemRenderer()
  • TRepeater::getItems()
  • TRepeater::getItemTemplate()
  • TRepeater::getSeparatorRenderer()
  • TRepeater::getSeparatorTemplate()
  • TRepeater::loadState()
    Loads item count information from viewstate.
  • TRepeater::onItemCommand()
    Raises OnItemCommand event.
  • TRepeater::onItemCreated()
    Raises OnItemCreated event.
  • TRepeater::onItemDataBound()
    Raises OnItemDataBound event.
  • TRepeater::performDataBinding()
    Performs databinding to populate repeater items from data source.
  • TRepeater::render()
    Renders the repeater.
  • TRepeater::reset()
    Clears up all items in the repeater.
  • TRepeater::restoreItemsFromViewState()
    Creates repeater items based on viewstate information.
  • TRepeater::saveState()
    Saves item count in viewstate.
  • TRepeater::setAlternatingItemRenderer()
    Sets the alternative item renderer class.
  • TRepeater::setAlternatingItemTemplate()
  • TRepeater::setDataKeyField()
  • TRepeater::setEmptyRenderer()
    Sets the repeater empty renderer class.
  • TRepeater::setEmptyTemplate()
  • TRepeater::setFooterRenderer()
    Sets the repeater footer renderer class.
  • TRepeater::setFooterTemplate()
  • TRepeater::setHeaderRenderer()
    Sets the repeater header renderer class.
  • TRepeater::setHeaderTemplate()
  • TRepeater::setItemRenderer()
    Sets the item renderer class.
  • TRepeater::setItemTemplate()
  • TRepeater::setSeparatorRenderer()
    Sets the repeater item separator renderer class.
  • TRepeater::setSeparatorTemplate()

Inherited From Class TDataBoundControl

  • TDataBoundControl::createPagedDataSource()
  • TDataBoundControl::dataBind()
    Performs databinding.
  • TDataBoundControl::dataSourceViewChanged()
  • TDataBoundControl::determineDataSource()
  • TDataBoundControl::ensureDataBound()
    Ensures any pending dataBind is called.
  • TDataBoundControl::getAllowCustomPaging()
  • TDataBoundControl::getAllowPaging()
  • TDataBoundControl::getCurrentPageIndex()
  • TDataBoundControl::getDataMember()
  • TDataBoundControl::getDataSource()
  • TDataBoundControl::getDataSourceID()
  • TDataBoundControl::getDataSourceView()
  • TDataBoundControl::getInitialized()
  • TDataBoundControl::getIsDataBound()
  • TDataBoundControl::getPageCount()
  • TDataBoundControl::getPageSize()
  • TDataBoundControl::getRequiresDataBinding()
  • TDataBoundControl::getSelectParameters()
  • TDataBoundControl::getUsingDataSourceID()
  • TDataBoundControl::getVirtualItemCount()
  • TDataBoundControl::onDataBound()
    Raises OnDataBound event.
  • TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
  • TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
  • TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
  • TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
  • TDataBoundControl::performDataBinding()
  • TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
  • TDataBoundControl::setAllowPaging()
  • TDataBoundControl::setCurrentPageIndex()
  • TDataBoundControl::setDataMember()
  • TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
  • TDataBoundControl::setDataSourceID()
  • TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
  • TDataBoundControl::setIsDataBound()
  • TDataBoundControl::setPageSize()
  • TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
  • TDataBoundControl::setVirtualItemCount()
  • TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveRepeater::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter.

    access

    public

    [ Top ]

    TActiveRepeater::getActiveControl

    getActiveControl( );

    Returns

    standard active control options.

    access

    public

    [ Top ]

    TActiveRepeater::getSurroundingTagID

    getSurroundingTagID( );

    Returns

    container id

    Remarks

    Returns the id of the surrounding container (span).

    access

    public

    [ Top ]

    TActiveRepeater::render

    render( THtmlWriter $writer );

    Overrides TRepeater::render() (Renders the repeater.)

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the repeater.

    If the repeater did not pass the prerender phase yet, it will register itself for rendering later. Else it will call the renderRepeater() method which will do the rendering of the repeater.

    access

    public

    [ Top ]

    TActiveRepeater::setDataSource

    setDataSource( Traversable|array|string $value );

    Overrides TDataBoundControl::setDataSource() (Sets the data source object associated with the databound control.)

    Parameters

    $value

    data source object

    Remarks

    Sets the data source object associated with the repeater control.

    In addition, the render method of all connected pagers is called so they get updated when the data source is changed. Also the repeater registers itself for rendering in order to get it's content replaced on client side.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:27 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveTableCell

Class TActiveTableCell

[line 52]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableCell
               |
               --TActiveTableCell
Location: /Web/UI/ActiveControls/TActiveTableCell.php

Remarks

TActiveTableCell class.

TActiveTableCell is the active counterpart to the original TTableCell control and displays a table cell. The horizontal and vertical alignments of the cell are specified via HorizontalAlign and VerticalAlign properties, respectively.

TActiveTableCell allows the contents of the table cell to be changed during callback. When CellSelected property is set, selecting (clicking on) the cell will perform a callback request causing OnCellSelected event to be fired.

It will also bubble the OnCellSelected event up to it's parent TActiveTableRow control which will fire up the event handlers if implemented.

TActiveTableCell allows the client-side cell contents to be updated during a callback response by getting a new writer, invoking the render method and flushing the output, similar to a TActivePanel control.

  •  function callback_request($sender, $param)
    •

  •  {
    •

  •      $this->active_cell->render($param->getNewWriter());
    •

  •  }
    •

    Please refer to the original documentation of the regular counterpart for usage.

    author

    LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

    version

    $Id$

    since

    3.1.9

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TTableCell

    • TTableCell::addAttributesToRender()
      Adds attributes to renderer.
    • TTableCell::createStyle()
      Creates a style object for the control.
    • TTableCell::getColumnSpan()
    • TTableCell::getData()
      Returns the text content of the table cell.
    • TTableCell::getHorizontalAlign()
    • TTableCell::getRowSpan()
    • TTableCell::getTagName()
    • TTableCell::getText()
    • TTableCell::getVerticalAlign()
    • TTableCell::getWrap()
    • TTableCell::renderContents()
      Renders body contents of the table cell.
    • TTableCell::setColumnSpan()
      Sets the columnspan for the table cell.
    • TTableCell::setData()
      Sets the text content of the table cell.
    • TTableCell::setHorizontalAlign()
      Sets the horizontal alignment of the contents within the table item.
    • TTableCell::setRowSpan()
      Sets the rowspan for the table cell.
    • TTableCell::setText()
      Sets the text content of the table cell.
    • TTableCell::setVerticalAlign()
      Sets the vertical alignment of the contents within the table item.
    • TTableCell::setWrap()
      Sets the value indicating whether the text content wraps within a table cell.

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TActiveTableCell::__construct

      __construct( );

      Overrides TControl::__construct() (Constructor.)

      Remarks

      Creates a new callback control, sets the adapter to TActiveControlAdapter.

      access

      public

      [ Top ]

      TActiveTableCell::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overrides TTableCell::addAttributesToRender() (Adds attributes to renderer.)

      Parameters

      $writer

      the writer responsible for rendering

      Remarks

      Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control if the event handler for the onCellSelected event is set.

      access

      protected

      [ Top ]

      TActiveTableCell::getActiveControl

      getActiveControl( );

      Returns

      standard callback control options.

      access

      public

      [ Top ]

      TActiveTableCell::getCellIndex

      getCellIndex( );

      Returns

      the zero-based index of the cell

      Remarks

      Returns the zero-based index of the TActiveTableCell within the TTableCellCollection of the parent TTableRow control. Raises a TConfigurationException if the cell is no member of the cell collection.

      access

      public

      [ Top ]

      TActiveTableCell::getClientClassName

      getClientClassName( );

      Returns

      corresponding javascript class name for this TActiveTableCell.

      access

      protected

      [ Top ]

      TActiveTableCell::getClientSide

      getClientSide( );

      Returns

      client side request options.

      access

      public

      [ Top ]

      TActiveTableCell::getPostBackOptions

      getPostBackOptions( );

      Returns

      parameters about how the row defines its postback behavior.

      Remarks

      Returns postback specifications for the table cell.

      This method is used by framework and control developers.

      access

      protected

      [ Top ]

      TActiveTableCell::getRow

      getRow( );

      Returns

      the parent row control

      Remarks

      Returns the parent TTableRow control by looping through all parents until a TTableRow is found. Raises a TConfigurationException if no row control is found.

      access

      public

      [ Top ]

      TActiveTableCell::onCellSelected

      onCellSelected( TActiveTableCellEventParameter $param );

      Parameters

      $param

      event parameter to be passed to the event handlers

      Remarks

      This method is invoked when a callback is requested. The method raises 'OnCellSelected' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

      access

      public

      [ Top ]

      TActiveTableCell::raiseCallbackEvent

      raiseCallbackEvent( TCallbackEventParameter $param );

      Parameters

      $param

      the event parameter

      Remarks

      Raises the callback event. This method is required by ICallbackEventHandler interface. It will raise onCellSelected event with a TActiveTableCellEventParameter containing the zero-based index of the TActiveTableCell.

      This method is mainly used by framework and control developers.

      access

      public

      [ Top ]

      TActiveTableCell::render

      render( THtmlWriter $writer );

      Overrides TWebControl::render() (Renders the control.)

      Parameters

      $writer

      html writer

      Remarks

      Renders and replaces the cell's content on the client-side. When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:28 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveTableCellEventParameter

Class TActiveTableCellEventParameter

[line 225]
TComponent
   |
   --TEventParameter
      |
      --TCallbackEventParameter
         |
         --TActiveTableCellEventParameter
Location: /Web/UI/ActiveControls/TActiveTableCell.php

Remarks

TActiveTableCellEventParameter class.

The TActiveTableCellEventParameter provides the parameter passed during the callback requestion in the CallbackParameter property. The callback response content (e.g. new HTML content) must be rendered using an THtmlWriter obtained from the NewWriter property, which returns a NEW instance of TCallbackResponseWriter.

The SelectedCellIndex is a zero-based index of the TActiveTableCell , -1 if the cell is not part of the cell collection (this shouldn't happen though since an exception is thrown before).

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: TActivePageAdapter.php 1648 2007-01-24 05:52:22Z wei $

since

3.1.9

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TCallbackEventParameter

  • TCallbackEventParameter::__construct()
    Creates a new TCallbackEventParameter.
  • TCallbackEventParameter::getCallbackParameter()
  • TCallbackEventParameter::getNewWriter()
  • TCallbackEventParameter::getResponseData()
  • TCallbackEventParameter::setResponseData()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveTableCellEventParameter::__construct

    __construct( $response, $parameter, [ $index = -1] );

    Overrides TCallbackEventParameter::__construct() (Creates a new TCallbackEventParameter.)

    Parameters

    $response

    $parameter

    $index

    Remarks

    Creates a new TActiveTableRowEventParameter.

    access

    public

    [ Top ]

    TActiveTableCellEventParameter::getSelectedCellIndex

    getSelectedCellIndex( );

    Returns

    the zero-based index of the cell.

    Remarks

    Returns the zero-based index of the TActiveTableCell within the TTableCellCollection of the parent TTableRow control.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:29 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveTableRow

Class TActiveTableRow

[line 53]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableRow
               |
               --TActiveTableRow
Location: /Web/UI/ActiveControls/TActiveTableRow.php

Remarks

TActiveTableRow class.

TActiveTableRow is the active counterpart to the original TTableRow control and displays a table row. The table cells in the row can be accessed via Cells. The horizontal and vertical alignments of the row are specified via HorizontalAlign and VerticalAlign properties, respectively.

TActiveTableRow allows the contents of the table row to be changed during callback. When RowSelected property is set, selecting (clicking on) the row will perform a callback request causing OnRowSelected event to be fired.

It will also respond to a bubbled onCellSelected event of a TActiveTableCell child control and fire a OnRowSelected event.

TActiveTableRow allows the client-side row contents to be updated during a callback response by getting a new writer, invoking the render method and flushing the output, similar to a TActivePanel control.

  •  function callback_request($sender, $param)
    •

  •  {
    •

  •      $this->active_row->render($param->getNewWriter());
    •

  •  }
    •

    Please refer to the original documentation of the regular counterpart for usage.

    author

    LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

    version

    $Id$

    since

    3.1.9

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TTableRow

    • TTableRow::addParsedObject()
      Adds object parsed from template to the control.
    • TTableRow::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TTableRow::createStyle()
      Creates a style object for the control.
    • TTableRow::getCells()
    • TTableRow::getHorizontalAlign()
    • TTableRow::getTableSection()
    • TTableRow::getTagName()
    • TTableRow::getVerticalAlign()
    • TTableRow::renderContents()
      Renders body contents of the table row
    • TTableRow::setHorizontalAlign()
      Sets the horizontal alignment of the contents within the table item.
    • TTableRow::setTableSection()
    • TTableRow::setVerticalAlign()
      Sets the vertical alignment of the contents within the table item.

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TActiveTableRow::__construct

      __construct( );

      Overrides TControl::__construct() (Constructor.)

      Remarks

      Creates a new callback control, sets the adapter to TActiveControlAdapter.

      access

      public

      [ Top ]

      TActiveTableRow::addAttributesToRender

      addAttributesToRender( THtmlWriter $writer );

      Overrides TWebControl::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

      Parameters

      $writer

      the writer responsible for rendering

      Remarks

      Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control if the event handler for the onRowSelected event is set.

      access

      protected

      [ Top ]

      TActiveTableRow::bubbleEvent

      bubbleEvent( TControl $sender, TEventParameter $param );

      Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

      Parameters

      $sender

      the sender of the event

      $param

      event parameter

      Returns

      whether the event bubbling should stop here.

      Remarks

      This method overrides parent's implementation and raises the control's callback event. This will fire the onRowSelected event if an appropriate event handler is implemented.

      access

      public

      [ Top ]

      TActiveTableRow::getActiveControl

      getActiveControl( );

      Returns

      standard callback control options.

      access

      public

      [ Top ]

      TActiveTableRow::getClientClassName

      getClientClassName( );

      Returns

      corresponding javascript class name for this TActiveTableRow.

      access

      protected

      [ Top ]

      TActiveTableRow::getClientSide

      getClientSide( );

      Returns

      client side request options.

      access

      public

      [ Top ]

      TActiveTableRow::getPostBackOptions

      getPostBackOptions( );

      Returns

      parameters about how the row defines its postback behavior.

      Remarks

      Returns postback specifications for the table row.

      This method is used by framework and control developers.

      access

      protected

      [ Top ]

      TActiveTableRow::getRowIndex

      getRowIndex( );

      Returns

      the zero-based index of the row

      Remarks

      Returns the zero-based index of the TActiveTableRow within the TTableRowCollection of the parent TTable control. Raises a TConfigurationException if the row is no member of the row collection.

      access

      public

      [ Top ]

      TActiveTableRow::getTable

      getTable( );

      Returns

      the parent table control

      Remarks

      Returns the parent TTable control by looping through all parents until a TTable is found. Raises a TConfigurationException if no table control is found.

      access

      public

      [ Top ]

      TActiveTableRow::onRowSelected

      onRowSelected( TActiveTableRowEventParameter $param );

      Parameters

      $param

      event parameter to be passed to the event handlers

      Remarks

      This method is invoked when a callback is requested. The method raises 'OnRowSelected' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

      access

      public

      [ Top ]

      TActiveTableRow::raiseCallbackEvent

      raiseCallbackEvent( TCallbackEventParameter $param );

      Parameters

      $param

      the event parameter

      Remarks

      Raises the callback event. This method is required by ICallbackEventHandler interface. It will raise onRowSelected event with a TActiveTableRowEventParameter containing the zero-based index of the TActiveTableRow.

      This method is mainly used by framework and control developers.

      access

      public

      [ Top ]

      TActiveTableRow::render

      render( THtmlWriter $writer );

      Overrides TWebControl::render() (Renders the control.)

      Parameters

      $writer

      html writer

      Remarks

      Renders and replaces the row's content on the client-side. When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:29 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveTableRowEventParameter

Class TActiveTableRowEventParameter

[line 244]
TComponent
   |
   --TEventParameter
      |
      --TCallbackEventParameter
         |
         --TActiveTableRowEventParameter
Location: /Web/UI/ActiveControls/TActiveTableRow.php

Remarks

TActiveTableRowEventParameter class.

The TActiveTableRowEventParameter provides the parameter passed during the callback requestion in the CallbackParameter property. The callback response content (e.g. new HTML content) must be rendered using an THtmlWriter obtained from the NewWriter property, which returns a NEW instance of TCallbackResponseWriter.

The SelectedRowIndex is a zero-based index of the TActiveTableRow , -1 if the row is not part of the row collection (this shouldn't happen though since an exception is thrown before).

author

LANDWEHR Computer und Software GmbH <programmierung@landwehr-software.de>

version

$Id: TActivePageAdapter.php 1648 2007-01-24 05:52:22Z wei $

since

3.1.9

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TCallbackEventParameter

  • TCallbackEventParameter::__construct()
    Creates a new TCallbackEventParameter.
  • TCallbackEventParameter::getCallbackParameter()
  • TCallbackEventParameter::getNewWriter()
  • TCallbackEventParameter::getResponseData()
  • TCallbackEventParameter::setResponseData()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveTableRowEventParameter::__construct

    __construct( $response, $parameter, [ $index = -1] );

    Overrides TCallbackEventParameter::__construct() (Creates a new TCallbackEventParameter.)

    Parameters

    $response

    $parameter

    $index

    Remarks

    Creates a new TActiveTableRowEventParameter.

    access

    public

    [ Top ]

    TActiveTableRowEventParameter::getSelectedRowIndex

    getSelectedRowIndex( );

    Returns

    the zero-based index of the row.

    Remarks

    Returns the zero-based index of the TActiveTableRow within the TTableRowCollection of the parent TTable control.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:29 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveTextBox

Class TActiveTextBox

[line 32]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --TActiveTextBox
Classes extended from TActiveTextBox:
TAutoComplete
TAutoComplete class.
TInPlaceTextBox
TInPlaceTextBox Class

Location: /Web/UI/ActiveControls/TActiveTextBox.php

Remarks

TActiveTextBox class.

TActiveTextBox allows the Text property of the textbox to be changed during callback. When AutoPostBack property is true, changes to the textbox contents will perform a callback request causing OnTextChanged to be fired first followed by OnCallback event.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveTextBox.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTextBox

  • TTextBox::DEFAULT_COLUMNS = 20
    Default number of columns (for MultiLine text box)
  • TTextBox::DEFAULT_ROWS = 4
    Default number of rows (for MultiLine text box)

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TTextBox

  • TTextBox::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TTextBox::getAutoCompleteType()
  • TTextBox::getAutoPostBack()
  • TTextBox::getAutoTrim()
  • TTextBox::getCausesValidation()
  • TTextBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TTextBox::getColumns()
  • TTextBox::getData()
    Returns the text content of the TTextBox control.
  • TTextBox::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TTextBox::getEnableClientScript()
  • TTextBox::getIsValid()
    Returns true if this control validated successfully.
  • TTextBox::getMaxLength()
  • TTextBox::getPersistPassword()
  • TTextBox::getPostBackOptions()
    Gets the post back options for this textbox.
  • TTextBox::getReadOnly()
  • TTextBox::getRows()
  • TTextBox::getSafeText()
  • TTextBox::getSafeTextParser()
  • TTextBox::getTagName()
  • TTextBox::getText()
  • TTextBox::getTextMode()
  • TTextBox::getValidationGroup()
  • TTextBox::getValidationPropertyValue()
    Returns the value to be validated.
  • TTextBox::getWrap()
  • TTextBox::loadPostData()
    Loads user input data.
  • TTextBox::onTextChanged()
    Raises OnTextChanged event.
  • TTextBox::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TTextBox::renderBeginTag()
    Renders an additional line-break after the opening tag when it is in MultiLine text mode.
  • TTextBox::renderClientControlScript()
    Renders the javascript for textbox.
  • TTextBox::renderContents()
    Renders the body content of the textbox when it is in MultiLine text mode.
  • TTextBox::setAutoCompleteType()
  • TTextBox::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TTextBox::setAutoTrim()
    Sets the value indicating if the input text should be trimmed spaces
  • TTextBox::setCausesValidation()
  • TTextBox::setColumns()
    Sets the display width of the text box in characters.
  • TTextBox::setData()
    Sets the text content of the TTextBox control.
  • TTextBox::setEnableClientScript()
  • TTextBox::setIsValid()
  • TTextBox::setMaxLength()
    Sets the maximum number of characters allowed in the text box.
  • TTextBox::setPersistPassword()
  • TTextBox::setReadOnly()
  • TTextBox::setRows()
    Sets the number of rows displayed in a multiline text box.
  • TTextBox::setText()
    Sets the text content of the TTextBox control.
  • TTextBox::setTextMode()
    Sets the behavior mode of the TTextBox component.
  • TTextBox::setValidationGroup()
  • TTextBox::setWrap()
    Sets the value indicating whether the text content wraps within a multiline text box.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveTextBox::__construct

    __construct( );

    Overridden in child classes as:

    TInPlaceTextBox::__construct()
    Sets the auto post back to true by default.

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TActiveTextBox::addAttributesToRender

    addAttributesToRender( $writer );

    Overridden in child classes as:

    TInPlaceTextBox::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    Overrides TTextBox::addAttributesToRender() (Adds attribute name-value pairs to renderer.)

    Parameters

    $writer

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    access

    protected

    [ Top ]

    TActiveTextBox::getActiveControl

    getActiveControl( );

    Returns

    standard callback control options.

    access

    public

    [ Top ]

    TActiveTextBox::getClientClassName

    getClientClassName( );

    Overridden in child classes as:

    TAutoComplete::getClientClassName()
    TInPlaceTextBox::getClientClassName()

    Overrides TTextBox::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TActiveTextBox::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TActiveTextBox::onCallback

    onCallback( TCallbackEventParameter $param );

    Overridden in child classes as:

    TInPlaceTextBox::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TActiveTextBox::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Overridden in child classes as:

    TAutoComplete::raiseCallbackEvent()
    Raises the callback event. This method is overrides the parent implementation.

    Parameters

    $param

    the event parameter

    Remarks

    Raises the callback event. This method is required by ICallbackEventHandler interface.

    This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TActiveTextBox::renderClientControlScript

    renderClientControlScript( $writer );

    Overridden in child classes as:

    TAutoComplete::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    Overrides TTextBox::renderClientControlScript() (Renders the javascript for textbox.)

    Parameters

    $writer

    Remarks

    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

    access

    protected

    [ Top ]

    TActiveTextBox::setText

    setText( string $value );

    Overridden in child classes as:

    TInPlaceTextBox::setText()
    On callback response, the inner HTMl of the label and the

    Overrides TTextBox::setText() (Sets the text content of the TTextBox control.)

    Parameters

    $value

    text content for the textbox

    Remarks

    Client-side Text property can only be updated after the OnLoad stage.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:29 +0200 by phpDocumentor 1.4.3


Docs For Class TAutoComplete

Class TAutoComplete

[line 84]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --TActiveTextBox
                  |
                  --TAutoComplete
Location: /Web/UI/ActiveControls/TAutoComplete.php

Remarks

TAutoComplete class.

TAutoComplete is a textbox that provides a list of suggestion on the current partial word typed in the textbox. The suggestions are requested using callbacks, and raises the onSuggestion event. The events of the TActiveText (from which TAutoComplete is extended from) and onSuggestion are mutually exculsive. That is, if onTextChange and/or OnCallback events are raise, then onSuggestion will not be raise, and vice versa.

The list of suggestions should be set in the onSuggestion event handler. The partial word to match the suggestion is in the TCallbackEventParameter::getCallbackParameter property. The datasource of the TAutoComplete must be set using setDataSource method. This sets the datasource for the suggestions repeater, available through the Suggestions property. Header, footer templates and other properties of the repeater can be access via the Suggestions property and its sub-properties.

The TextCssClass property if set is used to find the element within the Suggestions.ItemTemplate and Suggestions.AlternatingItemTemplate that contains the actual text for the suggestion selected. That is, only text inside elements with CSS class name equal to TextCssClass will be used as suggestions.

To return the list of suggestions back to the browser, supply a non-empty data source and call databind. For example,

  •  function autocomplete_suggestion($sender, $param)
    •

  •  {
    •

  •    $token = $param->getToken(); //the partial word to match
    •

  •    $sender->setDataSource($this->getSuggestionsFor($token)); //set suggestions
    •

  •    $sender->dataBind();
    •

  •  }
    •

    The suggestion will be rendered when the dataBind() method is called <strong>during a callback request</strong>.

    When an suggestion is selected, that is, when the use has clicked, pressed the "Enter" key, or pressed the "Tab" key, the OnSuggestionSelected event is raised. The TCallbackEventParameter::getCallbackParameter property contains the index of the selected suggestion.

    TAutoComplete allows multiple suggestions within one textbox with each word or phrase separated by any characters specified in the Separator property. The Frequency and MinChars properties sets the delay and minimum number of characters typed, respectively, before requesting for sugggestions.

    Use onTextChange and/or OnCallback events to handle post backs due to AutoPostBack.

    In the Suggestions TRepater item template, all HTML text elements are considered as text for the suggestion. Text within HTML elements with CSS class name "informal" are ignored as text for suggestions.

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: TAutoComplete.php 3118 2012-03-24 22:52:29Z ctrlaltca@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TTextBox

    • TTextBox::DEFAULT_COLUMNS = 20
      Default number of columns (for MultiLine text box)
    • TTextBox::DEFAULT_ROWS = 4
      Default number of rows (for MultiLine text box)

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Inherited From Class TWebControl

    • TWebControl::$_decorator =

    Method Summary

    Inherited Method Summary

    Inherited From Class TActiveTextBox

    • TActiveTextBox::__construct()
      Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    • TActiveTextBox::addAttributesToRender()
      Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    • TActiveTextBox::getActiveControl()
    • TActiveTextBox::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
    • TActiveTextBox::getClientSide()
    • TActiveTextBox::onCallback()
      This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    • TActiveTextBox::raiseCallbackEvent()
      Raises the callback event. This method is required by ICallbackEventHandler interface.
    • TActiveTextBox::renderClientControlScript()
      Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    • TActiveTextBox::setText()
      Client-side Text property can only be updated after the OnLoad stage.

    Inherited From Class TTextBox

    • TTextBox::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TTextBox::getAutoCompleteType()
    • TTextBox::getAutoPostBack()
    • TTextBox::getAutoTrim()
    • TTextBox::getCausesValidation()
    • TTextBox::getClientClassName()
      Gets the name of the javascript class responsible for performing postback for this control.
    • TTextBox::getColumns()
    • TTextBox::getData()
      Returns the text content of the TTextBox control.
    • TTextBox::getDataChanged()
      Returns a value indicating whether postback has caused the control data change.
    • TTextBox::getEnableClientScript()
    • TTextBox::getIsValid()
      Returns true if this control validated successfully.
    • TTextBox::getMaxLength()
    • TTextBox::getPersistPassword()
    • TTextBox::getPostBackOptions()
      Gets the post back options for this textbox.
    • TTextBox::getReadOnly()
    • TTextBox::getRows()
    • TTextBox::getSafeText()
    • TTextBox::getSafeTextParser()
    • TTextBox::getTagName()
    • TTextBox::getText()
    • TTextBox::getTextMode()
    • TTextBox::getValidationGroup()
    • TTextBox::getValidationPropertyValue()
      Returns the value to be validated.
    • TTextBox::getWrap()
    • TTextBox::loadPostData()
      Loads user input data.
    • TTextBox::onTextChanged()
      Raises OnTextChanged event.
    • TTextBox::raisePostDataChangedEvent()
      Raises postdata changed event.
    • TTextBox::renderBeginTag()
      Renders an additional line-break after the opening tag when it is in MultiLine text mode.
    • TTextBox::renderClientControlScript()
      Renders the javascript for textbox.
    • TTextBox::renderContents()
      Renders the body content of the textbox when it is in MultiLine text mode.
    • TTextBox::setAutoCompleteType()
    • TTextBox::setAutoPostBack()
      Sets the value indicating if postback automatically.
    • TTextBox::setAutoTrim()
      Sets the value indicating if the input text should be trimmed spaces
    • TTextBox::setCausesValidation()
    • TTextBox::setColumns()
      Sets the display width of the text box in characters.
    • TTextBox::setData()
      Sets the text content of the TTextBox control.
    • TTextBox::setEnableClientScript()
    • TTextBox::setIsValid()
    • TTextBox::setMaxLength()
      Sets the maximum number of characters allowed in the text box.
    • TTextBox::setPersistPassword()
    • TTextBox::setReadOnly()
    • TTextBox::setRows()
      Sets the number of rows displayed in a multiline text box.
    • TTextBox::setText()
      Sets the text content of the TTextBox control.
    • TTextBox::setTextMode()
      Sets the behavior mode of the TTextBox component.
    • TTextBox::setValidationGroup()
    • TTextBox::setWrap()
      Sets the value indicating whether the text content wraps within a multiline text box.

    Inherited From Class TWebControl

    • TWebControl::addAttributesToRender()
      Adds attribute name-value pairs to renderer.
    • TWebControl::clearStyle()
      Removes all style data.
    • TWebControl::copyBaseAttributes()
      Copies basic control attributes from another control.
    • TWebControl::createStyle()
      Creates a style object to be used by the control.
    • TWebControl::getAccessKey()
    • TWebControl::getBackColor()
    • TWebControl::getBorderColor()
    • TWebControl::getBorderStyle()
    • TWebControl::getBorderWidth()
    • TWebControl::getCssClass()
    • TWebControl::getDecorator()
    • TWebControl::getDisplay()
    • TWebControl::getEnsureId()
    • TWebControl::getFont()
    • TWebControl::getForeColor()
    • TWebControl::getHasStyle()
    • TWebControl::getHeight()
    • TWebControl::getStyle()
    • TWebControl::getTabIndex()
    • TWebControl::getTagName()
      Returns the tag name used for this control.
    • TWebControl::getToolTip()
    • TWebControl::getWidth()
    • TWebControl::onPreRender()
      If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    • TWebControl::render()
      Renders the control.
    • TWebControl::renderBeginTag()
      Renders the openning tag for the control (including attributes)
    • TWebControl::renderContents()
      Renders the body content enclosed between the control tag.
    • TWebControl::renderEndTag()
      Renders the closing tag for the control
    • TWebControl::setAccessKey()
      Sets the access key of the control.
    • TWebControl::setBackColor()
    • TWebControl::setBorderColor()
    • TWebControl::setBorderStyle()
    • TWebControl::setBorderWidth()
    • TWebControl::setCssClass()
    • TWebControl::setDisplay()
    • TWebControl::setEnsureId()
      Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    • TWebControl::setForeColor()
    • TWebControl::setHeight()
    • TWebControl::setStyle()
      Sets the css style string of the control.
    • TWebControl::setTabIndex()
      Sets the tab index of the control.
    • TWebControl::setToolTip()
      Sets the tooltip of the control.
    • TWebControl::setWidth()

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TAutoComplete::createRepeater

      createRepeater( );

      Returns

      new instance of TRepater to render the list of suggestions.

      access

      protected

      [ Top ]

      TAutoComplete::createResultPanel

      createResultPanel( );

      Returns

      new instance of result panel. Default uses TPanel.

      access

      protected

      [ Top ]

      TAutoComplete::dataBind

      dataBind( );

      Overrides TControl::dataBind() (Performs the databinding for this control.)

      Remarks

      Overrides parent implementation. Callback renderSuggestions() when page's IsCallback property is true.

      access

      public

      [ Top ]

      TAutoComplete::getClientClassName

      getClientClassName( );

      Overrides TActiveTextBox::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

      Returns

      corresponding javascript class name for this TActiveButton.

      access

      protected

      [ Top ]

      TAutoComplete::getFrequency

      getFrequency( );

      Returns

      maximum delay (in seconds) before requesting a suggestion.

      access

      public

      [ Top ]

      TAutoComplete::getMinChars

      getMinChars( );

      Returns

      minimum number of characters before requesting a suggestion.

      access

      public

      [ Top ]

      TAutoComplete::getPostBackOptions

      getPostBackOptions( );

      Overrides TTextBox::getPostBackOptions() (Gets the post back options for this textbox.)

      Returns

      list of callback options.

      access

      protected

      [ Top ]

      TAutoComplete::getResultPanel

      getResultPanel( );

      Returns

      suggestion results panel.

      access

      public

      [ Top ]

      TAutoComplete::getSeparator

      getSeparator( );

      Returns

      word or token separators (delimiters).

      access

      public

      [ Top ]

      TAutoComplete::getSuggestions

      getSuggestions( );

      Returns

      suggestion list repeater

      access

      public

      [ Top ]

      TAutoComplete::getTextCssClass

      getTextCssClass( );

      Returns

      Css class name of the element to use for suggestion.

      access

      public

      [ Top ]

      TAutoComplete::onSuggest

      onSuggest( TCallbackEventParameter $param );

      Parameters

      $param

      event parameter to be passed to the event handlers

      Remarks

      This method is invoked when an autocomplete suggestion is requested.

      The method raises 'OnSuggest' event. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

      access

      public

      [ Top ]

      TAutoComplete::onSuggestionSelected

      onSuggestionSelected( TCallbackEventParameter $param );

      Parameters

      $param

      event parameter to be passed to the event handlers

      Remarks

      This method is invoked when an autocomplete suggestion is selected.

      The method raises 'OnSuggestionSelected' event. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

      access

      public

      [ Top ]

      TAutoComplete::raiseCallbackEvent

      raiseCallbackEvent( TCallbackEventParameter $param );

      Overrides TActiveTextBox::raiseCallbackEvent() (Raises the callback event. This method is required by ICallbackEventHandler interface.)

      Parameters

      $param

      the event parameter

      Remarks

      Raises the callback event. This method is overrides the parent implementation.

      If AutoPostBack is enabled it will raise OnTextChanged event event and then the OnCallback event. The OnSuggest event is raise if the request is to find sugggestions, the OnTextChanged and OnCallback events are NOT raised. This method is mainly used by framework and control developers.

      access

      public

      [ Top ]

      TAutoComplete::renderCallback

      renderCallback( THtmlWriter $writer );

      Parameters

      $writer

      the renderer.

      Remarks

      Renders the suggestions during a callback respones.

      access

      public

      [ Top ]

      TAutoComplete::renderClientControlScript

      renderClientControlScript( $writer );

      Overrides TActiveTextBox::renderClientControlScript() (Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.)

      Parameters

      $writer

      Remarks

      Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

      access

      protected

      [ Top ]

      TAutoComplete::renderEndTag

      renderEndTag( $writer );

      Overrides TWebControl::renderEndTag() (Renders the closing tag for the control)

      Parameters

      $writer

      Remarks

      Renders the end tag and registers javascript effects library.

      access

      public

      [ Top ]

      TAutoComplete::renderResultPanel

      renderResultPanel( THtmlWriter $writer );

      Parameters

      $writer

      the renderer.

      Remarks

      Renders the result panel.

      access

      protected

      [ Top ]

      TAutoComplete::renderSuggestions

      renderSuggestions( THtmlWriter $writer );

      Parameters

      $writer

      the renderer.

      Remarks

      Renders the suggestions repeater.

      access

      public

      [ Top ]

      TAutoComplete::setDataSource

      setDataSource( array $data );

      Parameters

      $data

      data source for suggestions.

      access

      public

      [ Top ]

      TAutoComplete::setFrequency

      setFrequency( float $value );

      Parameters

      $value

      maximum delay (in seconds) before requesting a suggestion. Default is 0.4.

      access

      public

      [ Top ]

      TAutoComplete::setMinChars

      setMinChars( integer $value );

      Parameters

      $value

      minimum number of characters before requesting a suggestion.

      access

      public

      [ Top ]

      TAutoComplete::setSeparator

      setSeparator( $value );

      Parameters

      $value

      Returns

      word or token separators (delimiters).

      access

      public

      [ Top ]

      TAutoComplete::setTextCssClass

      setTextCssClass( string $value );

      Parameters

      $value

      Css class name of the element to use for suggestion.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:33 +0200 by phpDocumentor 1.4.3


Docs For Class TAutoCompleteEventParameter

Class TAutoCompleteEventParameter

[line 381]
TComponent
   |
   --TEventParameter
      |
      --TCallbackEventParameter
         |
         --TAutoCompleteEventParameter
Location: /Web/UI/ActiveControls/TAutoComplete.php

Remarks

TAutCompleteEventParameter contains the getToken requested by the user for a partial match of the suggestions.

The SelectedIndex is a zero-based index of the suggestion selected by the user, -1 if not suggestion is selected.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TAutoComplete.php 3118 2012-03-24 22:52:29Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TCallbackEventParameter

  • TCallbackEventParameter::__construct()
    Creates a new TCallbackEventParameter.
  • TCallbackEventParameter::getCallbackParameter()
  • TCallbackEventParameter::getNewWriter()
  • TCallbackEventParameter::getResponseData()
  • TCallbackEventParameter::setResponseData()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TAutoCompleteEventParameter::__construct

    __construct( $response, $parameter, [ $index = -1] );

    Overrides TCallbackEventParameter::__construct() (Creates a new TCallbackEventParameter.)

    Parameters

    $response

    $parameter

    $index

    Remarks

    Creates a new TCallbackEventParameter.

    access

    public

    [ Top ]

    TAutoCompleteEventParameter::getSelectedIndex

    getSelectedIndex( );

    Returns

    selected suggestion zero-based index, -1 if not selected.

    access

    public

    [ Top ]

    TAutoCompleteEventParameter::getToken

    getToken( );

    Returns

    token for matching a list of suggestions.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:34 +0200 by phpDocumentor 1.4.3


Docs For Class TAutoCompleteTemplate

Class TAutoCompleteTemplate

[line 422]
TComponent
   |
   --TAutoCompleteTemplate
Location: /Web/UI/ActiveControls/TAutoComplete.php

Remarks

TAutoCompleteTemplate class.

TAutoCompleteTemplate is the default template for TAutoCompleteTemplate item template.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TAutoComplete.php 3118 2012-03-24 22:52:29Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TAutoCompleteTemplate::__construct

    __construct( $template );

    Parameters

    $template

    access

    public

    [ Top ]

    TAutoCompleteTemplate::instantiateIn

    instantiateIn( TControl $parent );

    Parameters

    $parent

    parent to hold the content within the template

    Remarks

    Instantiates the template.

    It creates a TDataList control.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:34 +0200 by phpDocumentor 1.4.3


Docs For Class TBaseActiveCallbackControl

Class TBaseActiveCallbackControl

[line 162]
TComponent
   |
   --TBaseActiveControl
      |
      --TBaseActiveCallbackControl
Location: /Web/UI/ActiveControls/TBaseActiveControl.php

Remarks

TBaseActiveCallbackControl is a common set of options and functionality for active controls that can perform callback requests.

The properties of TBaseActiveCallbackControl can be accessed and changed from each individual active controls' getActiveControl property.

The following example sets the validation group property of a TCallback component.

  •      <com:TCallback ActiveControl.ValidationGroup="group1" ... />
    •

    Additional client-side options and events can be set using the ClientSide property. The following example shows an alert box when a TCallback component response returns successfully.

  •      <com:TCallback ActiveControl.ClientSide.OnSuccess="alert('ok!')" ... />
    •

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: TBaseActiveControl.php 3164 2012-06-12 14:39:26Z ctrlaltca $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TBaseActiveControl

    • TBaseActiveControl::__construct()
      Constructor. Attach a base active control to an active control instance.
    • TBaseActiveControl::canUpdateClientSide()
      Returns true if callback response is allowed to update the browser contents.
    • TBaseActiveControl::getControl()
    • TBaseActiveControl::getEnableUpdate()
    • TBaseActiveControl::getOption()
      Gets an option named value. Options are used to store and retrive named values for the base active controls.
    • TBaseActiveControl::getOptions()
    • TBaseActiveControl::getPage()
    • TBaseActiveControl::setEnableUpdate()
    • TBaseActiveControl::setOption()
      Sets a named options with a value. Options are used to store and retrive named values for the base active controls.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TBaseActiveCallbackControl::canCauseValidation

      canCauseValidation( );

      Returns

      whether to perform validation if the callback is requested.

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::createClientSide

      createClientSide( );

      Returns

      callback client-side options.

      access

      protected

      [ Top ]

      TBaseActiveCallbackControl::getCallbackOptions

      getCallbackOptions( );

      Returns

      ID of a TCallbackOptions control from which ClientSide options are duplicated.

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::getCallbackParameter

      getCallbackParameter( );

      Returns

      callback parameter value.

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::getCausesValidation

      getCausesValidation( );

      Returns

      whether callback event trigger by this button will cause input validation, default is true

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::getClientSide

      getClientSide( );

      Returns

      client-side callback options.

      Remarks

      Callback client-side options can be set by setting the properties of the ClientSide property. E.g. <com:TCallback ActiveControl.ClientSide.OnSuccess="..." /> See TCallbackClientSide for details on the properties of ClientSide.

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::getClientSideOptions

      getClientSideOptions( );

      Returns

      list of callback javascript options.

      access

      protected

      [ Top ]

      TBaseActiveCallbackControl::getDefaultClientSideOptions

      getDefaultClientSideOptions( );

      Returns

      list of default callback client-side options.

      Remarks

      Returns an array of default callback client-side options. The default options are obtained from the client-side options of a TCallbackOptions control with ID specified by setCallbackOptions.

      access

      protected

      [ Top ]

      TBaseActiveCallbackControl::getJavascript

      getJavascript( );

      Returns

      javascript client-side callback request object (javascript code)

      Remarks

      Returns the javascript callback request instance. To invoke a callback

      request for this control call the <tt>dispatch()</tt> method on the request instance. Example code in javascript

    •    var request = <%= $this->mycallback->ActiveControl->Javascript %>;
      •

    •    request.setParameter('hello');
      •

    •    request.dispatch(); //make the callback request.
      •

      Alternatively,

    •  //dispatches immediately
      •

    •  Prado.Callback("<%= $this->mycallback->UniqueID %>",
      •

    •     $this->mycallback->ActiveControl->JsCallbackOptions);
      •

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::getJsCallbackOptions

      getJsCallbackOptions( string 0 );

      Parameters

      0

      callback requestion options as javascript code.

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::getValidationGroup

      getValidationGroup( );

      Returns

      the group of validators which the button causes validation upon callback

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::registerCallbackClientScript

      registerCallbackClientScript( string $class, [array $options = null] );

      Parameters

      $class

      client side javascript class name.

      $options

      additional callback options.

      Remarks

      Registers the callback control javascript code. Client-side options are

      merged and passed to the javascript code. This method should be called by Active component developers wanting to register the javascript to initialize the active component with additional options offered by the ClientSide property.

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::setCallbackOptions

      setCallbackOptions( string $value );

      Parameters

      $value

      ID of a TCallbackOptions control from which ClientSide options are cloned.

      Remarks

      Sets default callback options. Takes the ID of a TCallbackOptions component to duplicate the client-side options for this control. The getClientSide subproperties takes precedence over the CallbackOptions property.

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::setCallbackParameter

      setCallbackParameter( mixed $value );

      Parameters

      $value

      callback parameter value.

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::setCausesValidation

      setCausesValidation( boolean $value );

      Parameters

      $value

      whether callback event trigger by this button will cause input validation

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::setClientSide

      setClientSide( TCallbackClientSide $client );

      Parameters

      $client

      client side options.

      Remarks

      Sets the client side options. Can only be set when client side is null.

      access

      public

      [ Top ]

      TBaseActiveCallbackControl::setValidationGroup

      setValidationGroup( string $value );

      Parameters

      $value

      the group of validators which the button causes validation upon callback

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:34 +0200 by phpDocumentor 1.4.3


Docs For Class TBaseActiveControl

Class TBaseActiveControl

[line 30]
TComponent
   |
   --TBaseActiveControl
Classes extended from TBaseActiveControl:
TBaseActiveCallbackControl
TBaseActiveCallbackControl is a common set of options and functionality for active controls that can perform callback requests.

Location: /Web/UI/ActiveControls/TBaseActiveControl.php

Remarks

TBaseActiveControl class provided additional basic property for every active control. An instance of TBaseActiveControl or its decendent TBaseActiveCallbackControl is created by TActiveControlAdapter::getBaseActiveControl() method.

The EnableUpdate property determines wether the active control is allowed to update the contents of the client-side when the callback response returns.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TBaseActiveControl.php 3164 2012-06-12 14:39:26Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TBaseActiveControl::__construct

    __construct( TControl $control );

    Parameters

    $control

    active control

    Remarks

    Constructor. Attach a base active control to an active control instance.

    access

    public

    [ Top ]

    TBaseActiveControl::canUpdateClientSide

    canUpdateClientSide( [ $bDontRequireVisibility = false] );

    Parameters

    $bDontRequireVisibility

    Returns

    true if the callback response is allowed update client-side contents.

    Remarks

    Returns true if callback response is allowed to update the browser contents.

    Is is true if the control is initilized, and is a callback request and the EnabledUpdate property is true and the page is not loading post data.

    access

    public

    [ Top ]

    TBaseActiveControl::getControl

    getControl( );

    Returns

    the attached control.

    access

    protected

    [ Top ]

    TBaseActiveControl::getEnableUpdate

    getEnableUpdate( );

    Returns

    true to allow fine grain callback updates.

    access

    public

    [ Top ]

    TBaseActiveControl::getOption

    getOption( string $name, [mixed $default = null] );

    Parameters

    $name

    option name.

    $default

    default value.

    Returns

    options value.

    Remarks

    Gets an option named value. Options are used to store and retrive named values for the base active controls.

    access

    protected

    [ Top ]

    TBaseActiveControl::getOptions

    getOptions( );

    Returns

    active control options

    access

    protected

    [ Top ]

    TBaseActiveControl::getPage

    getPage( );

    Returns

    the page containing the attached control.

    access

    protected

    [ Top ]

    TBaseActiveControl::setEnableUpdate

    setEnableUpdate( boolean $value );

    Parameters

    $value

    true to allow fine grain callback updates.

    access

    public

    [ Top ]

    TBaseActiveControl::setOption

    setOption( string $name, mixed $value, [mixed $default = null] );

    Parameters

    $name

    option name.

    $value

    new value.

    $default

    default value.

    Returns

    options value.

    Remarks

    Sets a named options with a value. Options are used to store and retrive named values for the base active controls.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:34 +0200 by phpDocumentor 1.4.3


Docs For Class TCallback

Class TCallback

[line 44]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCallback
Classes extended from TCallback:
TTimeTriggeredCallback
TTimeTriggeredCallback class.
TTriggeredCallback
TTriggeredCallback abstract Class

Location: /Web/UI/ActiveControls/TCallback.php

Remarks

TCallback component class.

The TCallback provides a basic callback handler that can be invoked from the client side by running the javascript code obtained from the TBaseActiveCallbackControl::getJavascript property. The event OnCallback is raised when a callback is requested made.

Example usage:

  •      <com:TCallback ID="callback1" OnCallback="callback1_Requested" />
    •

  •   <script type="text/javascript">
    •

  •          function do_callback1()
    •

  •       {
    •

  •            var request = <%= $this->callback1->ActiveControl->Javascript %>;
    •

  •              request.dispatch();
    •

  •       }
    •

  •   </script>
    •

  •   <div onclick="do_callback1()">Click Me!</div>
    •

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: TCallback.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TCallback::__construct

      __construct( );

      Overrides TControl::__construct() (Constructor.)

      Remarks

      Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, call this constructor.

      access

      public

      [ Top ]

      TCallback::getActiveControl

      getActiveControl( );

      Returns

      standard callback options.

      access

      public

      [ Top ]

      TCallback::getClientSide

      getClientSide( );

      Returns

      client side request options.

      access

      public

      [ Top ]

      TCallback::onCallback

      onCallback( TCallbackEventParameter $param );

      Parameters

      $param

      event parameter to be passed to the event handlers

      Remarks

      This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

      access

      public

      [ Top ]

      TCallback::raiseCallbackEvent

      raiseCallbackEvent( TCallbackEventParameter $param );

      Parameters

      $param

      the event parameter

      Remarks

      Raises the callback event. This method is required by ICallbackEventHandler interface. If getCausesValidation is true, it will invoke the page's TPage::validate method first.

      It will raise OnCallback event. This method is mainly used by framework and control developers.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:40 +0200 by phpDocumentor 1.4.3


Docs For Class TCallbackClientScript

Class TCallbackClientScript

[line 35]
TComponent
   |
   --TApplicationComponent
      |
      --TCallbackClientScript
Location: /Web/UI/ActiveControls/TCallbackClientScript.php

Remarks

TCallbackClientScript class.

The TCallbackClientScript class provides corresponding methods that can be executed on the client-side (i.e. the browser client that is viewing the page) during a callback response.

The avaiable methods includes setting/clicking input elements, changing Css styles, hiding/showing elements, and adding visual effects to elements on the page. The client-side methods can be access through the CallbackClient property available in TPage.

For example, to hide "$myTextBox" element during callback response, do

  •  $this->getPage()->getCallbackClient()->hide($myTextBox);
    •

    author

    Wei Zhuo <weizhuo[at]gamil[dot]com>

    version

    $Id: TCallbackClientScript.php 3143 2012-05-18 18:00:24Z ctrlaltca $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TCallbackClientScript::__construct

      __construct( );

      Remarks

      Constructor.

      access

      public

      [ Top ]

      TCallbackClientScript::addCssClass

      addCssClass( TControl $element, string $cssClass );

      Parameters

      $element

      control element or element id

      $cssClass

      CssClass name to add.

      Remarks

      Add a Css class name to the element.

      access

      public

      [ Top ]

      TCallbackClientScript::addPostDataLoader

      addPostDataLoader( $name );

      Parameters

      $name

      access

      public

      [ Top ]

      TCallbackClientScript::appear

      appear( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Gradually make the element appear.

      access

      public

      [ Top ]

      TCallbackClientScript::appendContent

      appendContent( TControl $element, string $content );

      Parameters

      $element

      control element or element id

      $content

      HTML fragement or the control to be rendered

      Remarks

      Append a HTML fragement to the element.

      access

      public

      [ Top ]

      TCallbackClientScript::appendScriptBlock

      appendScriptBlock( THtmlWriter $content );

      Parameters

      $content

      writer for the content.

      Remarks

      Appends a block of inline javascript enclosed in a boundary.

      Similar to to evaluateScript(), but functions declared in the inline block will be available to page elements.

      access

      public

      [ Top ]

      TCallbackClientScript::blindDown

      blindDown( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Blind down.

      access

      public

      [ Top ]

      TCallbackClientScript::blindUp

      blindUp( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Blind up.

      access

      public

      [ Top ]

      TCallbackClientScript::callClientFunction

      callClientFunction( string $function, [array $params = null] );

      Parameters

      $function

      javascript function name

      $params

      list of arguments for the function

      Remarks

      Executes a client-side statement.

      access

      public

      [ Top ]

      TCallbackClientScript::check

      check( TControl $checkbox, [boolean $checked = true] );

      Parameters

      $checkbox

      control element or element id

      $checked

      check or uncheck the checkbox or radio button.

      Remarks

      Client script to check or uncheck a checkbox or radio button.

      access

      public

      [ Top ]

      TCallbackClientScript::click

      click( TControl $control );

      Parameters

      $control

      control element or element id

      Remarks

      Client script to click on an element. This client-side function is unpredictable.

      access

      public

      [ Top ]

      TCallbackClientScript::dropOut

      dropOut( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Drop out.

      access

      public

      [ Top ]

      TCallbackClientScript::evaluateScript

      evaluateScript( THtmlWriter $writer );

      Parameters

      $writer

      writer for the content.

      Remarks

      Evaluate a block of javascript enclosed in a boundary.

      access

      public

      [ Top ]

      TCallbackClientScript::fade

      fade( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Gradually fade the element.

      access

      public

      [ Top ]

      TCallbackClientScript::focus

      focus( TControl $element );

      Parameters

      $element

      control element or element id.

      Remarks

      Focus on a particular element.

      access

      public

      [ Top ]

      TCallbackClientScript::fold

      fold( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Fold.

      access

      public

      [ Top ]

      TCallbackClientScript::getClientFunctionsToExecute

      getClientFunctionsToExecute( );

      Returns

      list of client function to be executed during callback response.

      access

      public

      [ Top ]

      TCallbackClientScript::grow

      grow( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Gradually make an element grow to a predetermined size.

      access

      public

      [ Top ]

      TCallbackClientScript::hide

      hide( TControl $element );

      Parameters

      $element

      control element or element id

      Remarks

      Hides an element by changing its CSS display style to "none".

      access

      public

      [ Top ]

      TCallbackClientScript::highlight

      highlight( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: High light the element for about 2 seconds.

      access

      public

      [ Top ]

      TCallbackClientScript::insertContentAfter

      insertContentAfter( TControl $element, string $content );

      Parameters

      $element

      control element or element id

      $content

      HTML fragement or the control to be rendered

      Remarks

      Insert a HTML fragement after the element.

      access

      public

      [ Top ]

      TCallbackClientScript::insertContentBefore

      insertContentBefore( TControl $element, string $content );

      Parameters

      $element

      control element or element id

      $content

      HTML fragement or the control to be rendered

      Remarks

      Insert a HTML fragement in before the element.

      access

      public

      [ Top ]

      TCallbackClientScript::prependContent

      prependContent( TControl $element, string $content );

      Parameters

      $element

      control element or element id

      $content

      HTML fragement or the control to be rendered

      Remarks

      Prepend a HTML fragement to the element.

      access

      public

      [ Top ]

      TCallbackClientScript::puff

      puff( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Gradually grow and fade the element.

      access

      public

      [ Top ]

      TCallbackClientScript::pulsate

      pulsate( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Pulsate.

      access

      public

      [ Top ]

      TCallbackClientScript::raiseClientEvent

      raiseClientEvent( TControl $control, string $eventName );

      Parameters

      $control

      control element or element id

      $eventName

      Event name, e.g. "click"

      Remarks

      Raise the client side event (given by $eventName) on a particular element.

      access

      public

      [ Top ]

      TCallbackClientScript::remove

      remove( TControl $element );

      Parameters

      $element

      control element or element id

      Remarks

      Removes an element from the HTML page.

      access

      public

      [ Top ]

      TCallbackClientScript::removeCssClass

      removeCssClass( TControl $element, string $cssClass );

      Parameters

      $element

      control element or element id

      $cssClass

      CssClass name to remove.

      Remarks

      Remove a Css class name from the element.

      access

      public

      [ Top ]

      TCallbackClientScript::replace

      replace( TControl $element, string $content, [string $method = "Element.replace"], [string $boundary = null] );

      Parameters

      $element

      control element or HTML element id.

      $content

      HTML fragement or the control to be rendered

      $method

      replacement method, default is to replace the outter html content.

      $boundary

      provide a custom boundary.

      Remarks

      Replace the content of an element with new content. The new content can be a string or a TControl component. If the <tt>content</tt> parameter is a TControl component, its rendered method will be called and its contents will be used for replacement.

      see

      insertAfter

      see

      insertAbout

      see

      insertBefore

      see

      insertBelow

      access

      protected

      [ Top ]

      TCallbackClientScript::replaceContent

      replaceContent( TControl $element, string $content );

      Parameters

      $element

      control element or HTML element id.

      $content

      HTML fragement or the control to be rendered

      Remarks

      Replace the content of an element with new content contained in writer.

      access

      public

      [ Top ]

      TCallbackClientScript::scrollTo

      scrollTo( TControl $element );

      Parameters

      $element

      control element or element id

      Remarks

      Scroll the top of the browser viewing area to the location of the element.

      access

      public

      [ Top ]

      TCallbackClientScript::select

      select( TControl $control, [string $method = 'Value'], [string|int $value = null], [string $type = null] );

      Parameters

      $control

      list control

      $method

      selection method

      $value

      the value or index to select/check.

      $type

      selection control type, either 'check' or 'select'

      Remarks

      Client script to select/clear/check a drop down list, check box list, or radio button list.

      The second parameter determines the selection method. Valid methods are

      • Value, select or check by value
      • Values, select or check by a list of values
      • Index, select or check by index (zero based index)
      • Indices, select or check by a list of index (zero based index)
      • Clear, clears or selections or checks in the list
      • All, select all
      • Invert, invert the selection.

      access

      public

      [ Top ]

      TCallbackClientScript::setAttribute

      setAttribute( TControl $control, string $name, string $value );

      Parameters

      $control

      control element or element id

      $name

      attribute name

      $value

      attribute value

      Remarks

      Sets the attribute of a particular control.

      access

      public

      [ Top ]

      TCallbackClientScript::setListItems

      setListItems( TControl $control, TCollection $items );

      Parameters

      $control

      control element or element id

      $items

      a list of new options

      Remarks

      Sets the options of a select input element.

      access

      public

      [ Top ]

      TCallbackClientScript::setOpacity

      setOpacity( TControl $element, float $value );

      Parameters

      $element

      control element or element id

      $value

      opacity value between 1 and 0

      Remarks

      Set the opacity on a html element or control.

      access

      public

      [ Top ]

      TCallbackClientScript::setStyle

      setStyle( TControl $element, array $styles );

      Parameters

      $element

      control element or element id

      $styles

      list of key-value pairs as style property and style value.

      Remarks

      Sets the style of element. The style must be a key-value array where the key is the style property and the value is the style value.

      access

      public

      [ Top ]

      TCallbackClientScript::setValue

      setValue( TControl $input, string $text );

      Parameters

      $input

      control element to set the new value

      $text

      new value

      Remarks

      Client script to set the value of a particular input element.

      access

      public

      [ Top ]

      TCallbackClientScript::shake

      shake( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Shake the element.

      access

      public

      [ Top ]

      TCallbackClientScript::show

      show( TControl $element );

      Parameters

      $element

      control element or element id

      Remarks

      Shows an element by changing its CSS display style as empty.

      access

      public

      [ Top ]

      TCallbackClientScript::shrink

      shrink( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Shrink the element.

      access

      public

      [ Top ]

      TCallbackClientScript::slideDown

      slideDown( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Slide down.

      access

      public

      [ Top ]

      TCallbackClientScript::slideUp

      slideUp( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Side up.

      access

      public

      [ Top ]

      TCallbackClientScript::squish

      squish( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Squish the element.

      access

      public

      [ Top ]

      TCallbackClientScript::switchOff

      switchOff( TControl $element, [array $options = null] );

      Parameters

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Visual Effect: Switch Off effect.

      access

      public

      [ Top ]

      TCallbackClientScript::toggle

      toggle( TControl $element, [string $effect = null], [array $options = array()] );

      Parameters

      $element

      control element or element id

      $effect

      visual effect, such as, 'appear' or 'slide' or 'blind'.

      $options

      additional options.

      Remarks

      Toggles the visibility of the element.

      access

      public

      [ Top ]

      TCallbackClientScript::update

      update( TControl $element, TControl $content );

      Parameters

      $element

      control element or element id

      $content

      new HTML content, if content is of a TControl, the controls render method is called.

      Remarks

      Update the element's innerHTML with new content.

      access

      public

      [ Top ]

      TCallbackClientScript::visualEffect

      visualEffect( string $type, TControl $element, [array $options = null] );

      Parameters

      $type

      visual effect function name.

      $element

      control element or element id

      $options

      visual effect key-value pair options.

      Remarks

      Add a visual effect the element.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:41 +0200 by phpDocumentor 1.4.3


Docs For Class TCallbackClientSide

Class TCallbackClientSide

[line 53]
TComponent
   |
   --TClientSideOptions
      |
      --TCallbackClientSide
Classes extended from TCallbackClientSide:
TActiveCustomValidatorClientSide
Custom Validator callback client side options class.

Location: /Web/UI/ActiveControls/TCallbackClientSide.php

Remarks

TCallbackClientSide class.

The following client side events are executing in order if the callback request and response are send and received successfuly.

  • onPreDispatch executed before a request is dispatched.
  • onUninitialized executed when callback request is uninitialized.
  • onLoading* executed when callback request is initiated
  • onLoaded* executed when callback request begins.
  • onInteractive executed when callback request is in progress.
  • onCompleteexecuted when callback response returns.
  • onSuccess executed when callback request returns and is successful.
  • onFailure executed when callback request returns and fails.
  • onException raised when callback request fails due to request/response errors.
* Note that theses 2 events are not fired correctly by Opera. To make them work in this browser, Prado will fire them just after onPreDispatch.

In a general way, onUninitialized, onLoading, onLoaded and onInteractive events are not implemented consistently in all browsers.When cross browser compatibility is needed, it is best to avoid use them

The OnSuccess and OnFailure events are raised when the response is returned. A successful request/response will raise OnSuccess event otherwise OnFailure will be raised.

  • PostState true to collect the form inputs and post them during callback, default is true.
  • RequestTimeOut The request timeout in milliseconds.
  • HasPriority true to ensure that the callback request will be sent immediately and will abort existing prioritized requests. It does not affect callbacks that are not prioritized.
  • EnablePageStateUpdate enable the callback response to enable the viewstate update. This will automatically set HasPriority to true when enabled.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TCallbackClientSide.php 3116 2012-03-23 18:15:03Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TClientSideOptions

  • TClientSideOptions::__construct()
    Constructor, initialize the options list.
  • TClientSideOptions::ensureFunction()
    Ensure that the javascript statements are wrapped in a javascript function block as
  • function(sender, parameter){ //code }
    •
    .
  • TClientSideOptions::getOption()
  • TClientSideOptions::getOptions()
  • TClientSideOptions::setFunction()
    Adds on client-side event handler by wrapping the code within a javascript function block. If the code begins with "javascript:", the code is assumed to be a javascript function block rather than arbiturary javascript statements.
  • TClientSideOptions::setOption()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCallbackClientSide::ensureFunction

    ensureFunction( string $javascript );

    Overrides TClientSideOptions::ensureFunction() (Ensure that the javascript statements are wrapped in a javascript function block as

  • function(sender, parameter){ //code }
    •
    .)

    Parameters

    $javascript

    javascript statement

    Returns

    javascript statement wrapped in a javascript function

    Remarks

    Returns javascript statement enclosed within a javascript function.

    access

    protected

    [ Top ]

    TCallbackClientSide::getEnablePageStateUpdate

    getEnablePageStateUpdate( );

    Returns

    client-side viewstate will be updated on callback response if true. Default is true.

    access

    public

    [ Top ]

    TCallbackClientSide::getHasPriority

    getHasPriority( );

    Returns

    true if the callback request has priority and will abort existing prioritized request in order to send immediately. It does not affect callbacks that are not prioritized. Default is true.

    access

    public

    [ Top ]

    TCallbackClientSide::getOnComplete

    getOnComplete( );

    Returns

    javascript code for client-side onComplete event

    access

    public

    [ Top ]

    TCallbackClientSide::getOnException

    getOnException( );

    Returns

    javascript code for client-side onException event

    access

    public

    [ Top ]

    TCallbackClientSide::getOnFailure

    getOnFailure( );

    Returns

    javascript code for client-side onFailure event

    access

    public

    [ Top ]

    TCallbackClientSide::getOnInteractive

    getOnInteractive( );

    Returns

    javascript code for client-side onInteractive event

    access

    public

    [ Top ]

    TCallbackClientSide::getOnLoaded

    getOnLoaded( );

    Returns

    javascript code for client-side onLoaded event

    access

    public

    [ Top ]

    TCallbackClientSide::getOnLoading

    getOnLoading( );

    Returns

    javascript code for client-side onLoading event

    access

    public

    [ Top ]

    TCallbackClientSide::getOnPreDispatch

    getOnPreDispatch( );

    Returns

    javascript code to be executed before a request is dispatched.

    access

    public

    [ Top ]

    TCallbackClientSide::getOnSuccess

    getOnSuccess( );

    Returns

    javascript code for client-side onSuccess event

    access

    public

    [ Top ]

    TCallbackClientSide::getOnUninitialized

    getOnUninitialized( );

    Returns

    javascript code for client-side onUninitialized event

    access

    public

    [ Top ]

    TCallbackClientSide::getPostBackParameter

    getPostBackParameter( );

    Returns

    post back event parameter.

    access

    public

    [ Top ]

    TCallbackClientSide::getPostBackTarget

    getPostBackTarget( );

    Returns

    post back target ID

    access

    public

    [ Top ]

    TCallbackClientSide::getPostState

    getPostState( );

    Returns

    true to post the inputs of the form on callback, default is post the inputs on callback.

    access

    public

    [ Top ]

    TCallbackClientSide::getRequestTimeOut

    getRequestTimeOut( );

    Returns

    callback request timeout.

    access

    public

    [ Top ]

    TCallbackClientSide::setEnablePageStateUpdate

    setEnablePageStateUpdate( boolean $value );

    Parameters

    $value

    true enables the callback response to update the viewstate.

    Remarks

    Set to true to enable the callback response to enable the viewstate update. This will automatically set HasPrority to true.

    access

    public

    [ Top ]

    TCallbackClientSide::setHasPriority

    setHasPriority( boolean $value );

    Parameters

    $value

    true to ensure that the callback request will be sent immediately and will abort existing prioritized requests. It does not affect callbacks that are not prioritized.

    access

    public

    [ Top ]

    TCallbackClientSide::setOnComplete

    setOnComplete( string $javascript );

    Parameters

    $javascript

    javascript code for client-side onComplete event.

    access

    public

    [ Top ]

    TCallbackClientSide::setOnException

    setOnException( string $javascript );

    Parameters

    $javascript

    javascript code for client-side onException event.

    access

    public

    [ Top ]

    TCallbackClientSide::setOnFailure

    setOnFailure( string $javascript );

    Parameters

    $javascript

    javascript code for client-side onFailure event.

    access

    public

    [ Top ]

    TCallbackClientSide::setOnInteractive

    setOnInteractive( string $javascript );

    Parameters

    $javascript

    javascript code for client-side onInteractive event.

    access

    public

    [ Top ]

    TCallbackClientSide::setOnLoaded

    setOnLoaded( string $javascript );

    Parameters

    $javascript

    javascript code for client-side onLoaded event.

    access

    public

    [ Top ]

    TCallbackClientSide::setOnLoading

    setOnLoading( string $javascript );

    Parameters

    $javascript

    javascript code for client-side onLoading event.

    access

    public

    [ Top ]

    TCallbackClientSide::setOnPreDispatch

    setOnPreDispatch( string $javascript );

    Parameters

    $javascript

    javascript code to be executed before a request is dispatched.

    access

    public

    [ Top ]

    TCallbackClientSide::setOnSuccess

    setOnSuccess( string $javascript );

    Parameters

    $javascript

    javascript code for client-side onSuccess event.

    access

    public

    [ Top ]

    TCallbackClientSide::setOnUninitialized

    setOnUninitialized( string $javascript );

    Parameters

    $javascript

    javascript code for client-side onUninitialized event.

    access

    public

    [ Top ]

    TCallbackClientSide::setPostBackParameter

    setPostBackParameter( string $value );

    Parameters

    $value

    post back event parameter.

    access

    public

    [ Top ]

    TCallbackClientSide::setPostBackTarget

    setPostBackTarget( string $value );

    Parameters

    $value

    post back target ID

    access

    public

    [ Top ]

    TCallbackClientSide::setPostState

    setPostState( boolean $value );

    Parameters

    $value

    true to post the inputs of the form with callback requests. Default is to post the inputs.

    access

    public

    [ Top ]

    TCallbackClientSide::setRequestTimeOut

    setRequestTimeOut( integer $value );

    Parameters

    $value

    callback request timeout

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:41 +0200 by phpDocumentor 1.4.3


Docs For Class TCallbackEventParameter

Class TCallbackEventParameter

[line 35]
TComponent
   |
   --TEventParameter
      |
      --TCallbackEventParameter
Classes extended from TCallbackEventParameter:
TActiveTableCellEventParameter
TActiveTableCellEventParameter class.
TActiveTableRowEventParameter
TActiveTableRowEventParameter class.
TAutoCompleteEventParameter
TAutCompleteEventParameter contains the getToken requested by the user for a partial match of the suggestions.

Location: /Web/UI/ActiveControls/TCallbackEventParameter.php

Remarks

TCallbackEventParameter class.

The TCallbackEventParameter provides the parameter passed during the callback request in the CallbackParameter property. The callback response content (e.g. new HTML content) must be rendered using an THtmlWriter obtained from the NewWriter property, which returns a NEW instance of TCallbackResponseWriter.

Each instance TCallbackResponseWriter is associated with a unique boundary delimited. By default each panel only renders its own content. To replace the content of ONE panel with that of rendered from multiple panels use the same writer instance for the panels to be rendered.

The response data (i.e., passing results back to the client-side callback handler function) can be set using ResponseData property.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TActivePageAdapter.php 1648 2007-01-24 05:52:22Z wei $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCallbackEventParameter::__construct

    __construct( $response, $parameter );

    Overridden in child classes as:

    TActiveTableCellEventParameter::__construct()
    Creates a new TActiveTableRowEventParameter.
    TActiveTableRowEventParameter::__construct()
    Creates a new TActiveTableRowEventParameter.
    TAutoCompleteEventParameter::__construct()
    Creates a new TCallbackEventParameter.

    Parameters

    $response

    $parameter

    Remarks

    Creates a new TCallbackEventParameter.

    access

    public

    [ Top ]

    TCallbackEventParameter::getCallbackParameter

    getCallbackParameter( );

    Returns

    callback request parameter.

    access

    public

    [ Top ]

    TCallbackEventParameter::getNewWriter

    getNewWriter( );

    Returns

    holds the response content.

    access

    public

    [ Top ]

    TCallbackEventParameter::getResponseData

    getResponseData( );

    Returns

    callback response data.

    access

    public

    [ Top ]

    TCallbackEventParameter::setResponseData

    setResponseData( mixed $value );

    Parameters

    $value

    callback response data.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:41 +0200 by phpDocumentor 1.4.3


Docs For Class TCallbackOptions

Class TCallbackOptions

[line 24]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCallbackOptions
Location: /Web/UI/ActiveControls/TCallbackOptions.php

Remarks

TCallbackOptions class.

TCallbackOptions allows common set of callback client-side options to be attached to other active controls.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TCallbackOptions.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCallbackOptions::createClientSide

    createClientSide( );

    Returns

    callback client-side options.

    access

    protected

    [ Top ]

    TCallbackOptions::getClientSide

    getClientSide( );

    Returns

    client-side callback options.

    Remarks

    Callback client-side options can be set by setting the properties of the ClientSide property. E.g. <com:TCallbackOptions ClientSide.OnSuccess="..." /> See TCallbackClientSide for details on the properties of ClientSide.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:42 +0200 by phpDocumentor 1.4.3


Docs For Class TCallbackResponseAdapter

Class TCallbackResponseAdapter

[line 29]
TComponent
   |
   --TApplicationComponent
      |
      --THttpResponseAdapter
         |
         --TCallbackResponseAdapter
Location: /Web/UI/ActiveControls/TCallbackResponseAdapter.php

Remarks

TCallbackResponseAdapter alters the THttpResponse's outputs.

A TCallbackResponseWriter is used instead of the TTextWrite when createHtmlWriter is called. Each call to createHtmlWriter will create a new TCallbackResponseWriter. When flushContent() is called each instance of TCallbackResponseWriter's content is flushed.

The callback response data can be set using the ResponseData property.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TCallbackResponseAdapter.php 3037 2011-09-06 18:13:31Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class THttpResponseAdapter

  • THttpResponseAdapter::__construct()
    Constructor. Attach a response to be adapted.
  • THttpResponseAdapter::createNewHtmlWriter()
    This method is invoked when a new HtmlWriter needs to be created.
  • THttpResponseAdapter::flushContent()
    This method is invoked when the response flushes the content and headers.
  • THttpResponseAdapter::getResponse()
  • THttpResponseAdapter::httpRedirect()
    This method is invoked when the response is to redirect to another page.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCallbackResponseAdapter::createNewHtmlWriter

    createNewHtmlWriter( string $type, THttpResponse $response );

    Overrides THttpResponseAdapter::createNewHtmlWriter() (This method is invoked when a new HtmlWriter needs to be created.)

    Parameters

    $type

    writer class name.

    $response

    http response handler.

    Remarks

    Returns a new instance of THtmlWriter.

    An instance of TCallbackResponseWriter is created to hold the content.

    access

    public

    [ Top ]

    TCallbackResponseAdapter::flushContent

    flushContent( );

    Overrides THttpResponseAdapter::flushContent() (This method is invoked when the response flushes the content and headers.)

    Remarks

    Flushes the contents in the writers.

    access

    public

    [ Top ]

    TCallbackResponseAdapter::getRedirectedUrl

    getRedirectedUrl( );

    Returns

    new url for callback response to redirect to.

    access

    public

    [ Top ]

    TCallbackResponseAdapter::getResponseData

    getResponseData( );

    Returns

    callback response data.

    access

    public

    [ Top ]

    TCallbackResponseAdapter::httpRedirect

    httpRedirect( string $url );

    Overrides THttpResponseAdapter::httpRedirect() (This method is invoked when the response is to redirect to another page.)

    Parameters

    $url

    new url to redirect to.

    Remarks

    Delay the redirect until we process the rest of the page.

    access

    public

    [ Top ]

    TCallbackResponseAdapter::setResponseData

    setResponseData( mixed $data );

    Parameters

    $data

    callback response data.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:42 +0200 by phpDocumentor 1.4.3


Docs For Class TCallbackResponseWriter

Class TCallbackResponseWriter

[line 117]
TComponent
   |
   --TTextWriter
      |
      --TCallbackResponseWriter
Location: /Web/UI/ActiveControls/TCallbackResponseAdapter.php

Remarks

TCallbackResponseWriter class.

TCallbackResponseWriter class enclosed a chunck of content within a html comment boundary. This allows multiple chuncks of content to return in the callback response and update multiple HTML elements.

The Boundary property sets boundary identifier in the HTML comment that forms the boundary. By default, the boundary identifier is generated using microtime.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TCallbackResponseAdapter.php 3037 2011-09-06 18:13:31Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TTextWriter

  • TTextWriter::flush()
    Flushes the content that has been written.
  • TTextWriter::write()
    Writes a string.
  • TTextWriter::writeLine()
    Writers a string and terminates it with a newline.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCallbackResponseWriter::__construct

    __construct( );

    Remarks

    Constructor. Generates unique boundary ID using microtime.

    access

    public

    [ Top ]

    TCallbackResponseWriter::flush

    flush( );

    Overrides TTextWriter::flush() (Flushes the content that has been written.)

    Returns

    text content chunck.

    Remarks

    Returns the text content wrapped within a HTML comment with boundary identifier as its comment content.

    access

    public

    [ Top ]

    TCallbackResponseWriter::getBoundary

    getBoundary( );

    Returns

    boundary identifier.

    access

    public

    [ Top ]

    TCallbackResponseWriter::setBoundary

    setBoundary( string $value );

    Parameters

    $value

    boundary identifier.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:42 +0200 by phpDocumentor 1.4.3


Docs For Class TDraggable

Class TDraggable

[line 31]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPanel
               |
               --TDraggable
Location: /Web/UI/ActiveControls/TDraggable.php

Remarks

TDraggable is a control which can be dragged

This control will make "draggable" control. Properties :

Ghosting : If set to "Ghosting" or "True", the dragged element will be cloned, and the clone will be dragged. If set to "SuperGhosting", the element will be cloned, and attached to body, so it can be dragged outside of its parent. If set to "None" of "False" (default), the element itself is dragged Revert: Set to True if you want your dragged element to revert to its initial position if not dropped on a valid area. Constraint: Set this to Horizontal or Vertical if you want to constraint your move in one direction. Handle:

author

Christophe BOULAIN (Christophe.Boulain@gmail.com)

version

$Id: TDraggable.php 3159 2012-06-01 18:01:40Z ctrlaltca $

copyright

Copyright &copy; 2008, PradoSoft

license

http://www.pradosoft.com/license

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TPanel

  • TPanel::addAttributesToRender()
    Adds attributes to renderer.
  • TPanel::createStyle()
    Creates a style object to be used by the control.
  • TPanel::getBackImageUrl()
  • TPanel::getDefaultButton()
  • TPanel::getDirection()
  • TPanel::getGroupingText()
  • TPanel::getHorizontalAlign()
  • TPanel::getScrollBars()
  • TPanel::getTagName()
  • TPanel::getWrap()
  • TPanel::render()
  • TPanel::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TPanel::renderEndTag()
    Renders the closing tag for the control
  • TPanel::setBackImageUrl()
    Sets the URL of the background image for the panel component.
  • TPanel::setDefaultButton()
    Specifies the default button for the panel.
  • TPanel::setDirection()
  • TPanel::setGroupingText()
  • TPanel::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the panel.
  • TPanel::setScrollBars()
  • TPanel::setWrap()
    Sets the value indicating whether the content wraps within the panel.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDraggable::addAttributesToRender

    addAttributesToRender( $writer );

    Overrides TPanel::addAttributesToRender() (Adds attributes to renderer.)

    Parameters

    $writer

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    access

    protected

    [ Top ]

    TDraggable::getClientClassName

    getClientClassName( );

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TDraggable::getConstraint

    getConstraint( );

    Remarks

    Determine if the element should be constrainted in one direction or not

    access

    public

    [ Top ]

    TDraggable::getGhosting

    getGhosting( );

    Returns

    to clone the element

    Remarks

    Determine if the element should be cloned when dragged If true, Clones the element and drags the clone, leaving the original in place until the clone is dropped.

    Defaults to false Since 3.2, Ghosting can be set to one of the value of TDraggableGhostingOptions enumeration.

    • "True" or "Ghosting" means standard pre-3.2 ghosting mechanism
    • "SuperGhosting" use the Superghosting patch by Christopher Williams, which allow elements to be dragged from an scrollable list
    • "False" or "None" means no Ghosting options

    access

    public

    [ Top ]

    TDraggable::getHandle

    getHandle( );

    Remarks

    Get the handle id or css class

    access

    public

    [ Top ]

    TDraggable::getPostBackOptions

    getPostBackOptions( );

    Remarks

    Gets the post back options for this textbox.

    access

    protected

    [ Top ]

    TDraggable::getRevert

    getRevert( );

    Returns

    true to revert

    Remarks

    Determine if draggable element should revert to it orginal position upon release in an non-droppable container.

    Since 3.2, Revert property can be set to one of the value of TDraggableRevertOption enumeration.

    • 'True' or 'Revert' : The draggable will revert to it's original position
    • 'False' or 'None' : The draggable won't revert to it's original position
    • 'Failure' : The draggable will only revert if it's dropped on a non droppable area

    access

    public

    [ Top ]

    TDraggable::onPreRender

    onPreRender( mixed $param );

    Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

    Parameters

    $param

    event parameter

    Remarks

    Registers clientscripts

    This method overrides the parent implementation and is invoked before render.

    access

    public

    [ Top ]

    TDraggable::setConstraint

    setConstraint( CDraggableConstraint $value );

    Parameters

    $value

    Remarks

    Set wether the element should be constrainted in one direction

    access

    public

    [ Top ]

    TDraggable::setGhosting

    setGhosting( $value );

    Parameters

    $value

    Remarks

    Sets wether the element should be cloned when dragged If true, Clones the element and drags the clone, leaving the original in place until the clone is dropped.

    Defaults to false

    Since 3.2, Ghosting can be set to one of the value of TDraggableGhostingOptions enumeration.

    • "True" or "Ghosting" means standard pre-3.2 ghosting mechanism
    • "SuperGhosting" use the Superghosting patch by Christopher Williams, which allow elements to be dragged from an scrollable list
    • "False" or "None" means no Ghosting options

    access

    public

    [ Top ]

    TDraggable::setHandle

    setHandle( string $value );

    Parameters

    $value

    Remarks

    Set the handle id or css class

    access

    public

    [ Top ]

    TDraggable::setRevert

    setRevert( boolean $value );

    Parameters

    $value

    true to revert

    Remarks

    Sets whether the draggable element should revert to it orginal position upon release in an non-droppable container.

    Since 3.2, Revert property can be set to one of the value of TDraggableRevertOption enumeration.

    • 'True' or 'Revert' : The draggable will revert to it's original position
    • 'False' or 'None' : The draggable won't revert to it's original position
    • 'Failure' : The draggable will only revert if it's dropped on a non droppable area

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:14 +0200 by phpDocumentor 1.4.3


Docs For Class TDraggableConstraint

Class TDraggableConstraint

[line 218]
TEnumerable
   |
   --TDraggableConstraint
Location: /Web/UI/ActiveControls/TDraggable.php

author

Christophe BOULAIN (Christophe.Boulain@gmail.com)

version

$Id: TDraggable.php 3159 2012-06-01 18:01:40Z ctrlaltca $

copyright

Copyright &copy; 2008, PradoSoft

license

http://www.pradosoft.com/license

Class Variable Summary

Class Constant Summary

  • Horizontal = 'Horizontal'
  • None = 'None'
  • Vertical = 'Vertical'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Horizontal = 'Horizontal' [line 221]

  • None = 'None' [line 220]

  • Vertical = 'Vertical' [line 222]

Documentation generated on Mon, 25 Jun 2012 14:44:15 +0200 by phpDocumentor 1.4.3


Docs For Class TDraggableGhostingOptions

Class TDraggableGhostingOptions

[line 232]
TEnumerable
   |
   --TDraggableGhostingOptions
Location: /Web/UI/ActiveControls/TDraggable.php

author

Christophe BOULAIN (Christophe.Boulain@gmail.com)

version

$Id: TDraggable.php 3159 2012-06-01 18:01:40Z ctrlaltca $

copyright

Copyright &copy; 2008, PradoSoft

license

http://www.pradosoft.com/license

Class Variable Summary

Class Constant Summary

  • Ghosting = 'Ghosting'
  • None = 'None'
  • SuperGhosting = 'SuperGhosting'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Ghosting = 'Ghosting' [line 235]

  • None = 'None' [line 234]

  • SuperGhosting = 'SuperGhosting' [line 236]

Documentation generated on Mon, 25 Jun 2012 14:44:15 +0200 by phpDocumentor 1.4.3


Docs For Class TDraggableRevertOptions

Class TDraggableRevertOptions

[line 246]
TEnumerable
   |
   --TDraggableRevertOptions
Location: /Web/UI/ActiveControls/TDraggable.php

author

Christophe BOULAIN (Christophe.Boulain@gmail.com)

version

$Id: TDraggable.php 3159 2012-06-01 18:01:40Z ctrlaltca $

copyright

Copyright &copy; 2008, PradoSoft

license

http://www.pradosoft.com/license

Class Variable Summary

Class Constant Summary

  • Failure = 'Failure'
  • None = 'None'
  • Revert = 'Revert'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Failure = 'Failure' [line 250]

  • None = 'None' [line 248]

  • Revert = 'Revert' [line 249]

Documentation generated on Mon, 25 Jun 2012 14:44:15 +0200 by phpDocumentor 1.4.3


Docs For Class TDropContainer

Class TDropContainer

[line 44]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPanel
               |
               --TDropContainer
Location: /Web/UI/ActiveControls/TDropContainer.php

Remarks

TDropContainer is a panel where TDraggable controls can be dropped.

When a TDraggable component is dropped into a TDropContainer, the OnDrop event is raised. The TDropContainerEventParameter param will contain the dropped control.

Properties :

AcceptCssClass : a coma delimited classname of elements that the drop container can accept. HoverCssClass: CSS classname of the container when a draggable element hovers over the container.

Events:

OnDrop : raised when a TDraggable control is dropped. The dropped control id is encapsulated in the event parameter, as well as mouse coordinates and key modifiers status

author

Christophe BOULAIN (Christophe.Boulain@gmail.com)

version

$Id: TDropContainer.php 3159 2012-06-01 18:01:40Z ctrlaltca $

copyright

Copyright &copy; 2008, PradoSoft

license

http://www.pradosoft.com/license

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TPanel

  • TPanel::addAttributesToRender()
    Adds attributes to renderer.
  • TPanel::createStyle()
    Creates a style object to be used by the control.
  • TPanel::getBackImageUrl()
  • TPanel::getDefaultButton()
  • TPanel::getDirection()
  • TPanel::getGroupingText()
  • TPanel::getHorizontalAlign()
  • TPanel::getScrollBars()
  • TPanel::getTagName()
  • TPanel::getWrap()
  • TPanel::render()
  • TPanel::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TPanel::renderEndTag()
    Renders the closing tag for the control
  • TPanel::setBackImageUrl()
    Sets the URL of the background image for the panel component.
  • TPanel::setDefaultButton()
    Specifies the default button for the panel.
  • TPanel::setDirection()
  • TPanel::setGroupingText()
  • TPanel::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the panel.
  • TPanel::setScrollBars()
  • TPanel::setWrap()
    Sets the value indicating whether the content wraps within the panel.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDropContainer::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.

    access

    public

    [ Top ]

    TDropContainer::addAttributesToRender

    addAttributesToRender( $writer );

    Overrides TPanel::addAttributesToRender() (Adds attributes to renderer.)

    Parameters

    $writer

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    access

    protected

    [ Top ]

    TDropContainer::createChildControls

    createChildControls( );

    Overrides TControl::createChildControls() (Creates child controls.)

    Remarks

    Creates child control Override parent implementation to create a container which will contain all child controls. This container will be a TActivePanel, in order to allow user to update its content on callback.

    access

    public

    [ Top ]

    TDropContainer::getAcceptCssClass

    getAcceptCssClass( );

    Remarks

    Gets the Css class name that this container can accept.

    access

    public

    [ Top ]

    TDropContainer::getActiveControl

    getActiveControl( );

    Returns

    standard active control options.

    access

    public

    [ Top ]

    TDropContainer::getClientClassName

    getClientClassName( );

    Returns

    the javascript class name

    Remarks

    Gets the name of the javascript class responsible for performing postback for this control.

    This method overrides the parent implementation.

    access

    protected

    [ Top ]

    TDropContainer::getClientSide

    getClientSide( );

    Returns

    client side request options.

    access

    public

    [ Top ]

    TDropContainer::getControls

    getControls( );

    Overrides TControl::getControls() (parent method not documented)

    Remarks

    Override parent implementation to return the container control collection.

    access

    public

    [ Top ]

    TDropContainer::getHoverCssClass

    getHoverCssClass( );

    Returns

    css class name during draggable hover.

    Remarks

    Gets the Css class name used when a draggble element is hovering over this container.

    access

    public

    [ Top ]

    TDropContainer::getPostBackOptions

    getPostBackOptions( );

    Remarks

    Gets the post back options for this textbox.

    access

    protected

    [ Top ]

    TDropContainer::onCallback

    onCallback( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TDropContainer::onDrop

    onDrop( $dropParams, object $dropControlId );

    Parameters

    $dropControlId

    $dropParams

    Remarks

    Raises the onDrop event.

    The drop parameters are encapsulated into a TDropContainerEventParameter

    access

    public

    [ Top ]

    TDropContainer::onPreRender

    onPreRender( mixed $param );

    Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

    Parameters

    $param

    event parameter

    Remarks

    Registers clientscripts

    This method overrides the parent implementation and is invoked before render.

    access

    public

    [ Top ]

    TDropContainer::raiseCallbackEvent

    raiseCallbackEvent( TCallbackEventParameter $param );

    Parameters

    $param

    the parameter associated with the callback event

    Remarks

    Raises callback event. This method is required bu ICallbackEventHandler interface.

    It raises the OnDrop event, then, the OnCallback event This method is mainly used by framework and control developers.

    access

    public

    [ Top ]

    TDropContainer::render

    render( THtmlWriter $writer );

    Overrides TPanel::render() (parent method not documented)

    Parameters

    $writer

    html writer

    Remarks

    Renders and replaces the panel's content on the client-side.

    When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.

    access

    public

    [ Top ]

    TDropContainer::setAcceptCssClass

    setAcceptCssClass( string $value );

    Parameters

    $value

    comma delimited css class names.

    Remarks

    Sets the Css class name that this container can accept.

    access

    public

    [ Top ]

    TDropContainer::setHoverCssClass

    setHoverCssClass( string $value );

    Parameters

    $value

    css class name during draggable hover.

    Remarks

    Sets the Css class name used when a draggble element is hovering over this container.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:15 +0200 by phpDocumentor 1.4.3


Docs For Class TDropContainerEventParameter

Class TDropContainerEventParameter

[line 262]
TComponent
   |
   --TEventParameter
      |
      --TDropContainerEventParameter
Location: /Web/UI/ActiveControls/TDropContainer.php

Remarks

TDropContainerEventParameter class

TDropContainerEventParameter encapsulate the parameter data for OnDrop event of TDropContainer components

author

Christophe BOULAIN (Christophe.Boulain@ceram.fr)

version

$Id: TDropContainer.php 3159 2012-06-01 18:01:40Z ctrlaltca $

copyright

Copyright &copy; 2008, PradoSoft

license

http://www.pradosoft.com/license

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDropContainerEventParameter::__construct

    __construct( $dropParams );

    Parameters

    $dropParams

    access

    public

    [ Top ]

    TDropContainerEventParameter::geOffsetY

    geOffsetY( );

    access

    public

    [ Top ]

    TDropContainerEventParameter::getAltKey

    getAltKey( );

    access

    public

    [ Top ]

    TDropContainerEventParameter::getClientX

    getClientX( );

    access

    public

    [ Top ]

    TDropContainerEventParameter::getClientY

    getClientY( );

    access

    public

    [ Top ]

    TDropContainerEventParameter::getCtrlKey

    getCtrlKey( );

    access

    public

    [ Top ]

    TDropContainerEventParameter::getDragElementId

    getDragElementId( );

    access

    public

    [ Top ]

    TDropContainerEventParameter::getDroppedControl

    getDroppedControl( );

    Returns

    dropped control, or null if not found

    Remarks

    GetDroppedControl

    Compatibility method to get the dropped control

    access

    public

    [ Top ]

    TDropContainerEventParameter::getOffsetX

    getOffsetX( );

    access

    public

    [ Top ]

    TDropContainerEventParameter::getScreenX

    getScreenX( );

    access

    public

    [ Top ]

    TDropContainerEventParameter::getScreenY

    getScreenY( );

    access

    public

    [ Top ]

    TDropContainerEventParameter::getShiftKey

    getShiftKey( );

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:16 +0200 by phpDocumentor 1.4.3


Docs For Class TEventTriggeredCallback

Class TEventTriggeredCallback

[line 29]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCallback
            |
            --TTriggeredCallback
               |
               --TEventTriggeredCallback
Location: /Web/UI/ActiveControls/TEventTriggeredCallback.php

Remarks

TEventTriggeredCallback Class

Triggers a new callback request when a particular EventName on a control with ID given by ControlID is raised.

The default action of the event on the client-side can be prevented when PreventDefaultAction is set to true.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TEventTriggeredCallback.php 3145 2012-05-19 11:08:20Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TTriggeredCallback

  • TTriggeredCallback::getControlID()
  • TTriggeredCallback::getTargetControl()
  • TTriggeredCallback::getTriggerOptions()
  • TTriggeredCallback::setControlID()

Inherited From Class TCallback

  • TCallback::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, call this constructor.
  • TCallback::getActiveControl()
  • TCallback::getClientSide()
  • TCallback::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
  • TCallback::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface. If getCausesValidation is true, it will invoke the page's TPage::validate method first.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TEventTriggeredCallback::getClientClassName

    getClientClassName( );

    Returns

    corresponding javascript class name for TEventTriggeredCallback.

    access

    protected

    [ Top ]

    TEventTriggeredCallback::getEventName

    getEventName( );

    Returns

    The client-side event name the trigger listens to.

    access

    public

    [ Top ]

    TEventTriggeredCallback::getPreventDefaultAction

    getPreventDefaultAction( );

    Returns

    true to prevent/stop default event action.

    access

    public

    [ Top ]

    TEventTriggeredCallback::getTriggerOptions

    getTriggerOptions( );

    Overrides TTriggeredCallback::getTriggerOptions() (parent method not documented)

    Returns

    list of timer options for client-side.

    access

    protected

    [ Top ]

    TEventTriggeredCallback::render

    render( THtmlWriter $writer );

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    the renderer.

    Remarks

    Registers the javascript code for initializing the active control.

    access

    public

    [ Top ]

    TEventTriggeredCallback::setEventName

    setEventName( string $value );

    Parameters

    $value

    The client-side event name the trigger listens to.

    Remarks

    Sets the client-side event name that fires the callback request.

    access

    public

    [ Top ]

    TEventTriggeredCallback::setPreventDefaultAction

    setPreventDefaultAction( boolean $value );

    Parameters

    $value

    true to prevent/stop default event action.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class TInPlaceTextBox

Class TInPlaceTextBox

[line 47]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --TActiveTextBox
                  |
                  --TInPlaceTextBox
Location: /Web/UI/ActiveControls/TInPlaceTextBox.php

Remarks

TInPlaceTextBox Class

* TInPlaceTextBox is a component rendered as a label and allows its contents to be edited by changing the label to a textbox when the label is clicked or when another control or html element with ID given by EditTriggerControlID is clicked.

If the OnLoadingText event is handled, a callback request is made when the label is clicked, while the request is being made the textbox is disabled from editing. The OnLoadingText event allows you to update the content of the textbox before the client is allowed to edit the content. After the callback request returns successfully, the textbox is enabled and the contents is then allowed to be edited.

Once the textbox loses focus, if AutoPostBack is true and the textbox content has changed, a callback request is made and the OnTextChanged event is raised like that of the TActiveTextBox. During the request, the textbox is disabled.

After the callback request returns sucessfully, the textbox is enabled. If the AutoHideTextBox property is true, then the textbox will be hidden and the label is then shown.

Since 3.1.2, you can set the ReadOnly property to make the control not editable. This property can be also changed on callback

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TInPlaceTextBox.php 3137 2012-05-10 21:09:10Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTextBox

  • TTextBox::DEFAULT_COLUMNS = 20
    Default number of columns (for MultiLine text box)
  • TTextBox::DEFAULT_ROWS = 4
    Default number of rows (for MultiLine text box)

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TActiveTextBox

  • TActiveTextBox::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
  • TActiveTextBox::addAttributesToRender()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
  • TActiveTextBox::getActiveControl()
  • TActiveTextBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TActiveTextBox::getClientSide()
  • TActiveTextBox::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
  • TActiveTextBox::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface.
  • TActiveTextBox::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
  • TActiveTextBox::setText()
    Client-side Text property can only be updated after the OnLoad stage.

Inherited From Class TTextBox

  • TTextBox::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TTextBox::getAutoCompleteType()
  • TTextBox::getAutoPostBack()
  • TTextBox::getAutoTrim()
  • TTextBox::getCausesValidation()
  • TTextBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
  • TTextBox::getColumns()
  • TTextBox::getData()
    Returns the text content of the TTextBox control.
  • TTextBox::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
  • TTextBox::getEnableClientScript()
  • TTextBox::getIsValid()
    Returns true if this control validated successfully.
  • TTextBox::getMaxLength()
  • TTextBox::getPersistPassword()
  • TTextBox::getPostBackOptions()
    Gets the post back options for this textbox.
  • TTextBox::getReadOnly()
  • TTextBox::getRows()
  • TTextBox::getSafeText()
  • TTextBox::getSafeTextParser()
  • TTextBox::getTagName()
  • TTextBox::getText()
  • TTextBox::getTextMode()
  • TTextBox::getValidationGroup()
  • TTextBox::getValidationPropertyValue()
    Returns the value to be validated.
  • TTextBox::getWrap()
  • TTextBox::loadPostData()
    Loads user input data.
  • TTextBox::onTextChanged()
    Raises OnTextChanged event.
  • TTextBox::raisePostDataChangedEvent()
    Raises postdata changed event.
  • TTextBox::renderBeginTag()
    Renders an additional line-break after the opening tag when it is in MultiLine text mode.
  • TTextBox::renderClientControlScript()
    Renders the javascript for textbox.
  • TTextBox::renderContents()
    Renders the body content of the textbox when it is in MultiLine text mode.
  • TTextBox::setAutoCompleteType()
  • TTextBox::setAutoPostBack()
    Sets the value indicating if postback automatically.
  • TTextBox::setAutoTrim()
    Sets the value indicating if the input text should be trimmed spaces
  • TTextBox::setCausesValidation()
  • TTextBox::setColumns()
    Sets the display width of the text box in characters.
  • TTextBox::setData()
    Sets the text content of the TTextBox control.
  • TTextBox::setEnableClientScript()
  • TTextBox::setIsValid()
  • TTextBox::setMaxLength()
    Sets the maximum number of characters allowed in the text box.
  • TTextBox::setPersistPassword()
  • TTextBox::setReadOnly()
  • TTextBox::setRows()
    Sets the number of rows displayed in a multiline text box.
  • TTextBox::setText()
    Sets the text content of the TTextBox control.
  • TTextBox::setTextMode()
    Sets the behavior mode of the TTextBox component.
  • TTextBox::setValidationGroup()
  • TTextBox::setWrap()
    Sets the value indicating whether the text content wraps within a multiline text box.

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TInPlaceTextBox::__construct

    __construct( );

    Overrides TActiveTextBox::__construct() (Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.)

    Remarks

    Sets the auto post back to true by default.

    access

    public

    [ Top ]

    TInPlaceTextBox::addAttributesToRender

    addAttributesToRender( $writer );

    Overrides TActiveTextBox::addAttributesToRender() (Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.)

    Parameters

    $writer

    Remarks

    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

    access

    protected

    [ Top ]

    TInPlaceTextBox::callClientFunction

    callClientFunction( string $func, mixed $value );

    Parameters

    $func

    static method name

    $value

    method parmaeter

    Remarks

    Calls the client-side static method for this control class.

    access

    protected

    [ Top ]

    TInPlaceTextBox::getAutoHideTextBox

    getAutoHideTextBox( );

    Returns

    true will hide the textbox after losing focus.

    access

    public

    [ Top ]

    TInPlaceTextBox::getClientClassName

    getClientClassName( );

    Overrides TActiveTextBox::getClientClassName() (Gets the name of the javascript class responsible for performing postback for this control.)

    Returns

    corresponding javascript class name for this TInPlaceTextBox

    access

    protected

    [ Top ]

    TInPlaceTextBox::getDisplayTextBox

    getDisplayTextBox( );

    Returns

    true to display the edit textbox

    access

    public

    [ Top ]

    TInPlaceTextBox::getEditTriggerControlID

    getEditTriggerControlID( );

    Returns

    ID of the control that can trigger to edit the textbox

    access

    public

    [ Top ]

    TInPlaceTextBox::getExternalControlID

    getExternalControlID( );

    Returns

    edit trigger control client ID.

    access

    protected

    [ Top ]

    TInPlaceTextBox::getLabelClientID

    getLabelClientID( );

    Returns

    label client ID

    access

    protected

    [ Top ]

    TInPlaceTextBox::getPostBackOptions

    getPostBackOptions( );

    Overrides TTextBox::getPostBackOptions() (Gets the post back options for this textbox.)

    Returns

    callback options.

    access

    protected

    [ Top ]

    TInPlaceTextBox::getTagName

    getTagName( );

    Overrides TTextBox::getTagName() (parent method not documented)

    Returns

    tag name of the label.

    access

    protected

    [ Top ]

    TInPlaceTextBox::onCallback

    onCallback( TCallbackEventParameter $param );

    Overrides TActiveTextBox::onCallback() (This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.)

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

    access

    public

    [ Top ]

    TInPlaceTextBox::onLoadingText

    onLoadingText( TCallbackEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    Raised when editing the content is requsted to be loaded from the server side.

    access

    public

    [ Top ]

    TInPlaceTextBox::onPreRender

    onPreRender( mixed $param );

    Overrides TWebControl::onPreRender() (If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.)

    Parameters

    $param

    event parameter

    Remarks

    Registers CSS and JS.

    This method is invoked right before the control rendering, if the control is visible.

    access

    public

    [ Top ]

    TInPlaceTextBox::registerClientScript

    registerClientScript( );

    Remarks

    Registers the relevant JavaScript.

    access

    protected

    [ Top ]

    TInPlaceTextBox::renderContents

    renderContents( THtmlWriter $writer );

    Overrides TTextBox::renderContents() (Renders the body content of the textbox when it is in MultiLine text mode.)

    Parameters

    $writer

    the writer for rendering

    Remarks

    Renders the body content of the label.

    access

    public

    [ Top ]

    TInPlaceTextBox::setAutoHideTextBox

    setAutoHideTextBox( boolean $value );

    Parameters

    $value

    true to hide the textbox after losing focus.

    access

    public

    [ Top ]

    TInPlaceTextBox::setDisplayTextBox

    setDisplayTextBox( boolean $value );

    Parameters

    $value

    true to display the edit textbox

    access

    public

    [ Top ]

    TInPlaceTextBox::setEditTriggerControlID

    setEditTriggerControlID( string $value );

    Parameters

    $value

    ID of the control that can trigger to edit the textbox

    access

    public

    [ Top ]

    TInPlaceTextBox::setReadOnly

    setReadOnly( boolean $value );

    Overrides TTextBox::setReadOnly() (parent method not documented)

    Parameters

    $value

    value

    Remarks

    Update ClientSide Readonly property

    since

    3.1.2

    access

    public

    [ Top ]

    TInPlaceTextBox::setText

    setText( string $value );

    Overrides TActiveTextBox::setText() (Client-side Text property can only be updated after the OnLoad stage.)

    Parameters

    $value

    the text value of the label

    Remarks

    On callback response, the inner HTMl of the label and the

    value of the textbox is updated

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:37 +0200 by phpDocumentor 1.4.3


Docs For Class IListControlAdapter

Interface IListControlAdapter

[line 891]

Location: /Web/UI/WebControls/TListControl.php

Remarks

IListControlAdapter interface

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Revision: $  Sun Jun 25 04:53:43 EST 2006 $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IListControlAdapter::clearSelection

clearSelection(
 );

    Remarks

    Clears all existing selections on the client side.

    access

    public

    [ Top ]

    IListControlAdapter::setSelectedIndex

setSelectedIndex(
integer
$index );

    Parameters

    $index

    the index (zero-based) of the item to be selected

    Remarks

    Selects an item based on zero-base index on the client side.

    access

    public

    [ Top ]

    IListControlAdapter::setSelectedIndices

setSelectedIndices(
array
$indices );

    Parameters

    $indices

    list of index of items to be selected

    Remarks

    Selects a list of item based on zero-base indices on the client side.

    access

    public

    [ Top ]

    IListControlAdapter::setSelectedValue

setSelectedValue(
string
$value );

    Parameters

    $value

    the value of the item to be selected.

    Remarks

    Sets selection by item value on the client side.

    access

    public

    [ Top ]

    IListControlAdapter::setSelectedValues

setSelectedValues(
array
$values );

    Parameters

    $values

    list of the selected item values

    Remarks

    Sets selection by a list of item values on the client side.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:43 +0200 by phpDocumentor 1.4.3


Docs For Class TTimeTriggeredCallback

Class TTimeTriggeredCallback

[line 33]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCallback
            |
            --TTimeTriggeredCallback
Location: /Web/UI/ActiveControls/TTimeTriggeredCallback.php

Remarks

TTimeTriggeredCallback class.

TTimeTriggeredCallback sends callback request every Interval seconds. Upon each callback request, the OnCallback event is raised.

The timer can be started by calling startTimer() and stopped using stopTimer(). The timer can be automatically started when StartTimerOnLoad is true.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TTimeTriggeredCallback.php 3145 2012-05-19 11:08:20Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TCallback

  • TCallback::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, call this constructor.
  • TCallback::getActiveControl()
  • TCallback::getClientSide()
  • TCallback::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
  • TCallback::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface. If getCausesValidation is true, it will invoke the page's TPage::validate method first.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTimeTriggeredCallback::getClientClassName

    getClientClassName( );

    Returns

    corresponding javascript class name for TTimeTriggeredCallback.

    access

    protected

    [ Top ]

    TTimeTriggeredCallback::getInterval

    getInterval( );

    Returns

    seconds between callback requests. Default is 1 second.

    access

    public

    [ Top ]

    TTimeTriggeredCallback::getStartTimerOnLoad

    getStartTimerOnLoad( );

    Returns

    true to start the timer when page loads.

    access

    public

    [ Top ]

    TTimeTriggeredCallback::getTriggerOptions

    getTriggerOptions( );

    Returns

    list of timer options for client-side.

    access

    protected

    [ Top ]

    TTimeTriggeredCallback::render

    render( THtmlWriter $writer );

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    the renderer.

    Remarks

    Registers the javascript code for initializing the active control.

    access

    public

    [ Top ]

    TTimeTriggeredCallback::setInterval

    setInterval( float $value );

    Parameters

    $value

    seconds between callback requests, must be a positive number, default is 1 second.

    access

    public

    [ Top ]

    TTimeTriggeredCallback::setStartTimerOnLoad

    setStartTimerOnLoad( boolean $value );

    Parameters

    $value

    true to start the timer when page loads.

    access

    public

    [ Top ]

    TTimeTriggeredCallback::startTimer

    startTimer( );

    Remarks

    Registers the javascript code to start the timer.

    access

    public

    [ Top ]

    TTimeTriggeredCallback::stopTimer

    stopTimer( );

    Remarks

    Registers the javascript code to stop the timer.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:41 +0200 by phpDocumentor 1.4.3


Docs For Class TTriggeredCallback

Class TTriggeredCallback

[line 25]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCallback
            |
            --TTriggeredCallback
Classes extended from TTriggeredCallback:
TEventTriggeredCallback
TEventTriggeredCallback Class
TValueTriggeredCallback
TValueTriggeredCallback Class

Location: /Web/UI/ActiveControls/TTriggeredCallback.php

Remarks

TTriggeredCallback abstract Class

Base class for triggered callback controls. The ControlID property sets the control ID to observe the trigger.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TTriggeredCallback.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TCallback

  • TCallback::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, call this constructor.
  • TCallback::getActiveControl()
  • TCallback::getClientSide()
  • TCallback::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
  • TCallback::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface. If getCausesValidation is true, it will invoke the page's TPage::validate method first.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTriggeredCallback::getControlID

    getControlID( );

    Returns

    The ID of the server control the trigger is bounded to.

    access

    public

    [ Top ]

    TTriggeredCallback::getTargetControl

    getTargetControl( );

    Returns

    target control client ID or html element ID if control is not found in hierarchy.

    access

    protected

    [ Top ]

    TTriggeredCallback::getTriggerOptions

    getTriggerOptions( );

    Overridden in child classes as:

    TEventTriggeredCallback::getTriggerOptions()
    TValueTriggeredCallback::getTriggerOptions()

    Returns

    list of trigger callback options.

    access

    protected

    [ Top ]

    TTriggeredCallback::setControlID

    setControlID( string $value );

    Parameters

    $value

    The ID of the server control the trigger is bounded to.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:43 +0200 by phpDocumentor 1.4.3


Docs For Class TValueTriggeredCallback

Class TValueTriggeredCallback

[line 32]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCallback
            |
            --TTriggeredCallback
               |
               --TValueTriggeredCallback
Location: /Web/UI/ActiveControls/TValueTriggeredCallback.php

Remarks

TValueTriggeredCallback Class

Observes the value with PropertyName of a control with ControlID. Changes to the observed property value will trigger a new callback request. The property value is checked for changes everyInterval seconds.

A DecayRate can be set to increase the polling interval linearly if no changes are observed. Once a change is observed, the polling interval is reset to the original value.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TValueTriggeredCallback.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TTriggeredCallback

  • TTriggeredCallback::getControlID()
  • TTriggeredCallback::getTargetControl()
  • TTriggeredCallback::getTriggerOptions()
  • TTriggeredCallback::setControlID()

Inherited From Class TCallback

  • TCallback::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, call this constructor.
  • TCallback::getActiveControl()
  • TCallback::getClientSide()
  • TCallback::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
  • TCallback::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface. If getCausesValidation is true, it will invoke the page's TPage::validate method first.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TValueTriggeredCallback::getClientClassName

    getClientClassName( );

    Returns

    corresponding javascript class name for TEventTriggeredCallback.

    access

    protected

    [ Top ]

    TValueTriggeredCallback::getDecayRate

    getDecayRate( );

    Returns

    decay rate between callbacks.

    Remarks

    Gets the decay rate between callbacks. Default is 0;

    access

    public

    [ Top ]

    TValueTriggeredCallback::getInterval

    getInterval( );

    Returns

    polling interval, 1 second default.

    access

    public

    [ Top ]

    TValueTriggeredCallback::getPropertyName

    getPropertyName( );

    Returns

    The control property name to observe value changes.

    access

    public

    [ Top ]

    TValueTriggeredCallback::getTriggerOptions

    getTriggerOptions( );

    Overrides TTriggeredCallback::getTriggerOptions() (parent method not documented)

    Returns

    list of timer options for client-side.

    access

    protected

    [ Top ]

    TValueTriggeredCallback::render

    render( THtmlWriter $writer );

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    the renderer.

    Remarks

    Registers the javascript code for initializing the active control.

    access

    public

    [ Top ]

    TValueTriggeredCallback::setDecayRate

    setDecayRate( float $value );

    Parameters

    $value

    decay rate between callbacks.

    Remarks

    Sets the decay rate between callback. Default is 0;

    access

    public

    [ Top ]

    TValueTriggeredCallback::setInterval

    setInterval( float $value );

    Parameters

    $value

    polling interval in seconds.

    Remarks

    Sets the polling interval in seconds to observe property changes.

    Default is 1 second.

    access

    public

    [ Top ]

    TValueTriggeredCallback::setPropertyName

    setPropertyName( string $value );

    Parameters

    $value

    The control property name to observe value changes.

    Remarks

    Sets the control property name to observe value changes that fires the callback request.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:46 +0200 by phpDocumentor 1.4.3


Package System.Data.ActiveRecord Element Index

Element index for package System.Data.ActiveRecord

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
b c d e f g h i m n o p r s t u _
top
_
$_connection | in file TActiveRecord.php, variable TActiveRecord::$_connection
$_invalidFinderResult in file TActiveRecord.php, variable TActiveRecord::$_invalidFinderResult
Defaults to 'null'
$_recordState | in file TActiveRecord.php, variable TActiveRecord::$_recordState
__call in file TActiveRecord.php, method TActiveRecord::__call()
Dynamic find method using parts of method name as search criteria.
__construct in file TActiveRecordGateway.php, method TActiveRecordGateway::__construct()
Record gateway constructor.
__construct in file TActiveRecord.php, method TActiveRecord::__construct()
Create a new instance of an active record with given $data. The record can be saved to the database specified by the $connection object.
__get in file TActiveRecord.php, method TActiveRecord::__get()
Magic method for reading properties.
__set in file TActiveRecord.php, method TActiveRecord::__set()
Magic method for writing properties.
__sleep in file TActiveRecord.php, method TActiveRecord::__sleep()
Prevent __call() method creating __sleep() when serializing.
__wakeup in file TActiveRecord.php, method TActiveRecord::__wakeup()
Prevent __call() method creating __wakeup() when unserializing.
top
b
BELONGS_TO | in file TActiveRecord.php, class constant TActiveRecord::BELONGS_TO
top
c
$COLUMN_MAPPING in file TActiveRecord.php, variable TActiveRecord::$COLUMN_MAPPING
This static variable defines the column mapping.
copyFrom in file TActiveRecord.php, method TActiveRecord::copyFrom()
Copies data from an array or another object.
count in file TActiveRecord.php, method TActiveRecord::count()
Find the number of records.
countRecords in file TActiveRecordGateway.php, method TActiveRecordGateway::countRecords()
Returns the number of records that match the given criteria.
createRecord in file TActiveRecord.php, method TActiveRecord::createRecord()
Create an AR instance specified by the AR class name and initial data.
createRecordGateway | in file TActiveRecordManager.php, method TActiveRecordManager::createRecordGateway()
createRelationContext in file TActiveRecord.php, method TActiveRecord::createRelationContext()
Gets a static copy of the relationship context for given property (a key in $RELATIONS), returns null if invalid relationship. Keeps a null reference to all invalid relations called.
top
d
DEFAULT_GATEWAY_CLASS | in file TActiveRecordManager.php, class constant TActiveRecordManager::DEFAULT_GATEWAY_CLASS
DEFAULT_GATEWAY_CLASS | in file TActiveRecordConfig.php, class constant TActiveRecordConfig::DEFAULT_GATEWAY_CLASS
DEFAULT_MANAGER_CLASS | in file TActiveRecordConfig.php, class constant TActiveRecordConfig::DEFAULT_MANAGER_CLASS
delete in file TActiveRecord.php, method TActiveRecord::delete()
Deletes the current record from the database. Once deleted, this object can not be saved again in the same instance.
delete in file TActiveRecordGateway.php, method TActiveRecordGateway::delete()
Delete the record.
deleteAll in file TActiveRecord.php, method TActiveRecord::deleteAll()
Delete multiple records using a criteria.
deleteAllByPks in file TActiveRecord.php, method TActiveRecord::deleteAllByPks()
Alias for deleteByPk()
deleteByPk in file TActiveRecord.php, method TActiveRecord::deleteByPk()
Delete records by primary key. Usage:
deleteRecordsByCriteria in file TActiveRecordGateway.php, method TActiveRecordGateway::deleteRecordsByCriteria()
Delete multiple records by criteria.
deleteRecordsByPk in file TActiveRecordGateway.php, method TActiveRecordGateway::deleteRecordsByPk()
Delete multiple records using primary keys.
top
e
equals in file TActiveRecord.php, method TActiveRecord::equals()
Compare two records using their primary key values (all column values if table does not defined primary keys). The default uses simple == for comparison of their values. Set $strict=true for identity comparison (===).
Exception | in file TActiveRecord.php, class constant TActiveRecordInvalidFinderResult::Exception
top
f
fetchResultsFor in file TActiveRecord.php, method TActiveRecord::fetchResultsFor()
Tries to load the relationship results for the given property. The $property value should correspond to an entry key in the $RELATION array.
find in file TActiveRecord.php, method TActiveRecord::find()
Find one single record that matches the criteria.
findAll in file TActiveRecord.php, method TActiveRecord::findAll()
Same as find() but returns an array of objects.
findAllByIndex in file TActiveRecord.php, method TActiveRecord::findAllByIndex()
Fetches records using the sql clause "(fields) IN (values)", where fields is an array of column names and values is an array of values that the columns must have.
findAllByPks in file TActiveRecord.php, method TActiveRecord::findAllByPks()
Find multiple records matching a list of primary or composite keys.
findAllBySql in file TActiveRecord.php, method TActiveRecord::findAllBySql()
Find records using full SQL, returns corresponding record object.
findByPk in file TActiveRecord.php, method TActiveRecord::findByPk()
Find one record using only the primary key or composite primary keys. Usage:
findBySql in file TActiveRecord.php, method TActiveRecord::findBySql()
Find records using full SQL, returns corresponding record object.
finder in file TActiveRecord.php, method TActiveRecord::finder()
Returns the instance of a active record finder for a particular class.
findRecordByPK in file TActiveRecordGateway.php, method TActiveRecordGateway::findRecordByPK()
Returns record data matching the given primary key(s). If the table uses composite key, specify the name value pairs as an array.
findRecordBySql in file TActiveRecordGateway.php, method TActiveRecordGateway::findRecordBySql()
Return record data from sql query.
findRecordsByCriteria in file TActiveRecordGateway.php, method TActiveRecordGateway::findRecordsByCriteria()
Returns record data matching the given critera. If $iterator is true, it will return multiple rows as TDbDataReader otherwise it returns the first row data.
findRecordsByIndex | in file TActiveRecordGateway.php, method TActiveRecordGateway::findRecordsByIndex()
findRecordsByPks in file TActiveRecordGateway.php, method TActiveRecordGateway::findRecordsByPks()
Returns records matching the list of given primary keys.
findRecordsBySql in file TActiveRecordGateway.php, method TActiveRecordGateway::findRecordsBySql()
Return record data from sql query.
top
g
getActiveDbConnection | in file TActiveRecord.php, method TActiveRecord::getActiveDbConnection()
getCache | in file TActiveRecordManager.php, method TActiveRecordManager::getCache()
getColumnValue in file TActiveRecord.php, method TActiveRecord::getColumnValue()
Retrieves the column value according to column name.
getCommand | in file TActiveRecordGateway.php, method TActiveRecordGateway::getCommand()
getDbConnection in file TActiveRecord.php, method TActiveRecord::getDbConnection()
Gets the current Db connection, the connection object is obtained from the TActiveRecordManager if connection is currently null.
getDbConnection | in file TActiveRecordManager.php, method TActiveRecordManager::getDbConnection()
getEnableCache | in file TActiveRecordConfig.php, method TActiveRecordConfig::getEnableCache()
getErrorMessageFile | in file TActiveRecordException.php, method TActiveRecordException::getErrorMessageFile()
getGatewayClass | in file TActiveRecordConfig.php, method TActiveRecordConfig::getGatewayClass()
getGatewayClass | in file TActiveRecordManager.php, method TActiveRecordManager::getGatewayClass()
getInsertValues | in file TActiveRecordGateway.php, method TActiveRecordGateway::getInsertValues()
getInstance | in file TActiveRecordManager.php, method TActiveRecordManager::getInstance()
getInvalidFinderResult | in file TActiveRecordConfig.php, method TActiveRecordConfig::getInvalidFinderResult()
getInvalidFinderResult | in file TActiveRecordManager.php, method TActiveRecordManager::getInvalidFinderResult()
getInvalidFinderResult | in file TActiveRecord.php, method TActiveRecord::getInvalidFinderResult()
getIsValid | in file TActiveRecord.php, method TActiveRecordChangeEventParameter::getIsValid()
getManager | in file TActiveRecordGateway.php, method TActiveRecordGateway::getManager()
getManager | in file TActiveRecordConfig.php, method TActiveRecordConfig::getManager()
getManagerClass | in file TActiveRecordConfig.php, method TActiveRecordConfig::getManagerClass()
getPrimaryKeyValues | in file TActiveRecordGateway.php, method TActiveRecordGateway::getPrimaryKeyValues()
getRecordCriteria in file TActiveRecord.php, method TActiveRecord::getRecordCriteria()
Create a new TSqlCriteria object from a string $criteria. The $args are additional parameters and are used in place of the $parameters if $parameters is not an array and $args is an arrary.
getRecordGateway | in file TActiveRecord.php, method TActiveRecord::getRecordGateway()
getRecordGateway | in file TActiveRecordManager.php, method TActiveRecordManager::getRecordGateway()
getRecordManager in file TActiveRecord.php, method TActiveRecord::getRecordManager()
Gets the record manager for this object, the default is to call TActiveRecordManager::getInstance().
getRecordRelation | in file TActiveRecord.php, method TActiveRecord::getRecordRelation()
getRecordRelations | in file TActiveRecord.php, method TActiveRecord::getRecordRelations()
getRecordTableInfo in file TActiveRecordGateway.php, method TActiveRecordGateway::getRecordTableInfo()
Returns table information, trys the application cache first.
getRecordTableInfo | in file TActiveRecord.php, method TActiveRecord::getRecordTableInfo()
getRecordTableName in file TActiveRecordGateway.php, method TActiveRecordGateway::getRecordTableName()
Gets the table name from the 'TABLE' constant of the active record class if defined, otherwise use the class name as table name.
getRelationHandler in file TActiveRecord.php, method TActiveRecord::getRelationHandler()
Returns the active record relationship handler for $RELATION with key value equal to the $property value.
getTableInfo in file TActiveRecordGateway.php, method TActiveRecordGateway::getTableInfo()
Returns table information for table in the database connection.
getUpdateValues | in file TActiveRecordGateway.php, method TActiveRecordGateway::getUpdateValues()
top
h
hasRecordRelation | in file TActiveRecord.php, method TActiveRecord::hasRecordRelation()
HAS_MANY | in file TActiveRecord.php, class constant TActiveRecord::HAS_MANY
HAS_ONE | in file TActiveRecord.php, class constant TActiveRecord::HAS_ONE
top
i
init in file TActiveRecordConfig.php, method TActiveRecordConfig::init()
Initialize the active record manager.
insert in file TActiveRecordGateway.php, method TActiveRecordGateway::insert()
Insert a new record.
top
m
MANY_TO_MANY | in file TActiveRecord.php, class constant TActiveRecord::MANY_TO_MANY
top
n
Null | in file TActiveRecord.php, class constant TActiveRecordInvalidFinderResult::Null
top
o
onCreateCommand in file TActiveRecord.php, method TActiveRecord::onCreateCommand()
Raised when a command is prepared and parameter binding is completed.
onCreateCommand in file TActiveRecordGateway.php, method TActiveRecordGateway::onCreateCommand()
Raised when a command is prepared and parameter binding is completed.
onDelete in file TActiveRecord.php, method TActiveRecord::onDelete()
Raised before the record attempt to delete its data from the database.
onExecuteCommand in file TActiveRecordGateway.php, method TActiveRecordGateway::onExecuteCommand()
Raised when a command is executed and the result from the database was returned.
onExecuteCommand in file TActiveRecord.php, method TActiveRecord::onExecuteCommand()
Raised when a command is executed and the result from the database was returned.
onInsert in file TActiveRecord.php, method TActiveRecord::onInsert()
Raised before the record attempt to insert its data into the database.
onUpdate in file TActiveRecord.php, method TActiveRecord::onUpdate()
Raised before the record attempt to update its data in the database.
top
p
populateObject in file TActiveRecord.php, method TActiveRecord::populateObject()
Populates a new record with the query result.
populateObjects | in file TActiveRecord.php, method TActiveRecord::populateObjects()
top
r
$RELATIONS in file TActiveRecord.php, variable TActiveRecord::$RELATIONS
This static variable defines the relationships.
raiseCommandEvent in file TActiveRecordGateway.php, method TActiveRecordGateway::raiseCommandEvent()
Raise the corresponding command event, insert, update, delete or select.
top
s
save in file TActiveRecord.php, method TActiveRecord::save()
Saves the current record to the database, insert or update is automatically determined.
setCache | in file TActiveRecordManager.php, method TActiveRecordManager::setCache()
setColumnValue in file TActiveRecord.php, method TActiveRecord::setColumnValue()
Sets the column value according to column name.
setDbConnection | in file TActiveRecord.php, method TActiveRecord::setDbConnection()
setDbConnection | in file TActiveRecordManager.php, method TActiveRecordManager::setDbConnection()
setEnableCache in file TActiveRecordConfig.php, method TActiveRecordConfig::setEnableCache()
Set true to cache the table meta data.
setGatewayClass in file TActiveRecordConfig.php, method TActiveRecordConfig::setGatewayClass()
Set implementation class of ActiveRecordGateway
setGatewayClass in file TActiveRecordManager.php, method TActiveRecordManager::setGatewayClass()
Set implementation class of ActiveRecordGateway
setInvalidFinderResult in file TActiveRecordConfig.php, method TActiveRecordConfig::setInvalidFinderResult()
Define the way an active record finder react if an invalid magic-finder invoked
setInvalidFinderResult in file TActiveRecord.php, method TActiveRecord::setInvalidFinderResult()
Define the way an active record finder react if an invalid magic-finder invoked
setInvalidFinderResult in file TActiveRecordManager.php, method TActiveRecordManager::setInvalidFinderResult()
Define the way an active record finder react if an invalid magic-finder invoked
setIsValid | in file TActiveRecord.php, method TActiveRecordChangeEventParameter::setIsValid()
setManagerClass in file TActiveRecordConfig.php, method TActiveRecordConfig::setManagerClass()
Set implementation class of ActiveRecordManager
STATE_DELETED | in file TActiveRecord.php, class constant TActiveRecord::STATE_DELETED
STATE_LOADED | in file TActiveRecord.php, class constant TActiveRecord::STATE_LOADED
STATE_NEW | in file TActiveRecord.php, class constant TActiveRecord::STATE_NEW
top
t
TActiveRecordException.php | procedural page TActiveRecordException.php
TActiveRecord.php | procedural page TActiveRecord.php
TActiveRecordConfig.php | procedural page TActiveRecordConfig.php
TActiveRecordCriteria.php | procedural page TActiveRecordCriteria.php
TActiveRecordGateway.php | procedural page TActiveRecordGateway.php
TActiveRecordManager.php | procedural page TActiveRecordManager.php
TABLE_CONST in file TActiveRecordGateway.php, class constant TActiveRecordGateway::TABLE_CONST
Constant name for specifying optional table name in TActiveRecord.
TABLE_METHOD in file TActiveRecordGateway.php, class constant TActiveRecordGateway::TABLE_METHOD
Method name for returning optional table name in in TActiveRecord
TActiveRecord in file TActiveRecord.php, class TActiveRecord
Base class for active records.
TActiveRecordChangeEventParameter in file TActiveRecord.php, class TActiveRecordChangeEventParameter
TActiveRecordChangeEventParameter class
TActiveRecordConfig in file TActiveRecordConfig.php, class TActiveRecordConfig
TActiveRecordConfig module configuration class.
TActiveRecordConfigurationException in file TActiveRecordException.php, class TActiveRecordConfigurationException
TActiveRecordConfigurationException class.
TActiveRecordCriteria in file TActiveRecordCriteria.php, class TActiveRecordCriteria
Search criteria for Active Record.
TActiveRecordException in file TActiveRecordException.php, class TActiveRecordException
Base exception class for Active Records.
TActiveRecordGateway in file TActiveRecordGateway.php, class TActiveRecordGateway
TActiveRecordGateway excutes the SQL command queries and returns the data record as arrays (for most finder methods).
TActiveRecordInvalidFinderResult in file TActiveRecord.php, class TActiveRecordInvalidFinderResult
TActiveRecordInvalidFinderResult class.
TActiveRecordManager in file TActiveRecordManager.php, class TActiveRecordManager
TActiveRecordManager provides the default DB connection, default active record gateway, and table meta data inspector.
top
u
update in file TActiveRecordGateway.php, method TActiveRecordGateway::update()
Update the record.
updateAssociatedRecords | in file TActiveRecordGateway.php, method TActiveRecordGateway::updateAssociatedRecords()
updatePostInsert in file TActiveRecordGateway.php, method TActiveRecordGateway::updatePostInsert()
Sets the last insert ID to the corresponding property of the record if available.


Class Trees for Package System.Data.ActiveRecord

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRecord.php

File: /Data/ActiveRecord/TActiveRecord.php

Remarks

TActiveRecord, TActiveRecordEventParameter, TActiveRecordInvalidFinderResult class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveRecord.php 3004 2011-06-26 09:56:56Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRecord
Base class for active records.
TActiveRecordChangeEventParameter
TActiveRecordChangeEventParameter class
TActiveRecordInvalidFinderResult
TActiveRecordInvalidFinderResult class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:24 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRecordConfig.php

File: /Data/ActiveRecord/TActiveRecordConfig.php

Remarks

TActiveRecordConfig class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveRecordConfig.php 3030 2011-08-28 05:51:36Z GODZilla0480@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRecordConfig
TActiveRecordConfig module configuration class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:25 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRecordCriteria.php

File: /Data/ActiveRecord/TActiveRecordCriteria.php

Remarks

TActiveRecordCriteria class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveRecordCriteria.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRecordCriteria
Search criteria for Active Record.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:26 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRecordException.php

File: /Data/ActiveRecord/Exceptions/TActiveRecordException.php

Remarks

TActiveRecordException class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveRecordException.php 3098 2012-01-28 17:49:48Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRecordException
Base exception class for Active Records.
TActiveRecordConfigurationException
TActiveRecordConfigurationException class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:26 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRecordGateway.php

File: /Data/ActiveRecord/TActiveRecordGateway.php

Remarks

TActiveRecordGateway, TActiveRecordStatementType, TActiveRecordEventParameter classes file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveRecordGateway.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRecordGateway
TActiveRecordGateway excutes the SQL command queries and returns the data record as arrays (for most finder methods).

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:26 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRecordManager.php

File: /Data/ActiveRecord/TActiveRecordManager.php

Remarks

TActiveRecordManager class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TActiveRecordManager.php 3030 2011-08-28 05:51:36Z GODZilla0480@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRecordManager
TActiveRecordManager provides the default DB connection, default active record gateway, and table meta data inspector.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:27 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecord

Class TActiveRecord

[line 149]
TComponent
   |
   --TActiveRecord
Location: /Data/ActiveRecord/TActiveRecord.php

Remarks

Base class for active records.

An active record creates an object that wraps a row in a database table or view, encapsulates the database access, and adds domain logic on that data.

Active record objects are stateful, this is main difference between the TActiveRecord implementation and the TTableGateway implementation.

The essence of an Active Record is an object model of the domain (e.g. products, items) that incorporates both behavior and data in which the classes match very closely the record structure of an underlying database. Each Active Record is responsible for saving and loading to the database and also for any domain logic that acts on the data.

The Active Record provides methods that do the following:

  1. Construct an instance of the Active Record from a SQL result set row.
  2. Construct a new instance for later insertion into the table.
  3. Finder methods to wrap commonly used SQL queries and return Active Record objects.
  4. Update the database and insert into it the data in the Active Record.
Example:
  •  class UserRecord extends TActiveRecord
    •

  •  {
    •

  •      const TABLE='users'; //optional table name.
    •

  •
    •

  •      public $username; //corresponds to the fieldname in the table
    •

  •      public $email;
    •

  •
    •

  •      //returns active record finder instance
    •

  •      public static function finder($className=__CLASS__)
    •

  •      {
    •

  •          return parent::finder($className);
    •

  •      }
    •

  •  }
    •

  •
    •

  •  //create a connection and give it to the ActiveRecord manager.
    •

  •  $dsn = 'pgsql:host=localhost;dbname=test';
    •

  •  $conn = new TDbConnection($dsn, 'dbuser','dbpass');
    •

  •  TActiveRecordManager::getInstance()->setDbConnection($conn);
    •

  •
    •

  •  //load the user record with username (primary key) 'admin'.
    •

  •  $user = UserRecord::finder()->findByPk('admin');
    •

  •  $user->email = 'admin@example.org';
    •

  •  $user->save(); //update the 'admin' record.
    •

    Since v3.1.1, TActiveRecord starts to support column mapping. The physical column names (defined in database) can be mapped to logical column names (defined in active classes as public properties.) To use this feature, declare a static class variable COLUMN_MAPPING like the following:

  •  class UserRecord extends TActiveRecord
    •

  •  {
    •

  •      const TABLE='users';
    •

  •      public static $COLUMN_MAPPING=array
    •

  •      (
    •

  •          'user_id'=>'username',
    •

  •          'email_address'=>'email',
    •

  •      );
    •

  •      public $username;
    •

  •      public $email;
    •

  •  }
    •
    In the above, the 'users' table consists of 'user_id' and 'email_address' columns, while the UserRecord class declares 'username' and 'email' properties. By using column mapping, we can regularize the naming convention of column names in active record.

    Since v3.1.2, TActiveRecord enhanced its support to access of foreign objects. By declaring a public static variable RELATIONS like the following, one can access the corresponding foreign objects easily:

  •  class UserRecord extends TActiveRecord
    •

  •  {
    •

  •      const TABLE='users';
    •

  •      public static $RELATIONS=array
    •

  •      (
    •

  •          'department'=>array(self::BELONGS_TO, 'DepartmentRecord', 'department_id'),
    •

  •          'contacts'=>array(self::HAS_MANY, 'ContactRecord', 'user_id'),
    •

  •      );
    •

  •  }
    •
    In the above, the users table is related with departments table (represented by DepartmentRecord) and contacts table (represented by ContactRecord). Now, given a UserRecord instance $user, one can access its department and contacts simply by: $user->department and $user->contacts. No explicit data fetching is needed. Internally, the foreign objects are fetched in a lazy way, which avoids unnecessary overhead if the foreign objects are not accessed at all.

    Since v3.1.2, new events OnInsert, OnUpdate and OnDelete are available. The event OnInsert, OnUpdate and OnDelete methods are executed before inserting, updating, and deleting the current record, respectively. You may override these methods; a TActiveRecordChangeEventParameter parameter is passed to these methods. The property TActiveRecordChangeEventParameter::setIsValid of the parameter can be set to false to prevent the change action to be executed. This can be used, for example, to validate the record before the action is executed. For example, in the following the password property is hashed before a new record is inserted.

  •  class UserRecord extends TActiveRecord
    •

  •  {
    •

  •       function OnInsert($param)
    •

  •       {
    •

  •           //parent method should be called to raise the event
    •

  •           parent::OnInsert($param);
    •

  •           $this->nounce = md5(time());
    •

  •           $this->password = md5($this->password.$this->nounce);
    •

  •       }
    •

  •  }
    •

    Since v3.1.3 you can also define a method that returns the table name.

  •  class UserRecord extends TActiveRecord
    •

  •  {
    •

  •      public function table()
    •

  •      {
    •

  •           return 'users';
    •

  •      }
    •

  •
    •

  •  }
    •

    author

    Wei Zhuo <weizho[at]gmail[dot]com>

    version

    $Id: TActiveRecord.php 3004 2011-06-26 09:56:56Z ctrlaltca@gmail.com $

    abstract

    since

    3.1

    Class Variable Summary

    • static $COLUMN_MAPPING = array()
      This static variable defines the column mapping.
    • static $RELATIONS = array()
      This static variable defines the relationships.
    • $_connection =
    • $_invalidFinderResult =  null
      Defaults to 'null'
    • $_recordState = 0

    Class Constant Summary

    • BELONGS_TO = 'BELONGS_TO'
    • HAS_MANY = 'HAS_MANY'
    • HAS_ONE = 'HAS_ONE'
    • MANY_TO_MANY = 'MANY_TO_MANY'
    • STATE_DELETED = 2
    • STATE_LOADED = 1
    • STATE_NEW = 0

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    • static TActiveRecord createRecord()
      Create an AR instance specified by the AR class name and initial data.
    • static TActiveRecord finder()
      Returns the instance of a active record finder for a particular class.
    • static void getActiveDbConnection()
    • static TActiveRecordManager getRecordManager()
      Gets the record manager for this object, the default is to call TActiveRecordManager::getInstance().
    • TActiveRecord createRecord()
      Create an AR instance specified by the AR class name and initial data.
    • TActiveRecord finder()
      Returns the instance of a active record finder for a particular class.
    • void getActiveDbConnection()
    • TActiveRecordManager getRecordManager()
      Gets the record manager for this object, the default is to call TActiveRecordManager::getInstance().

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      static TActiveRecord::createRecord

      static createRecord( string $type, array $data );

      Parameters

      $type

      the AR class name

      $data

      initial data to be populated into the AR object.

      Returns

      the initialized AR object. Null if the initial data is empty.

      Remarks

      Create an AR instance specified by the AR class name and initial data.

      If the initial data is empty, the AR object will not be created and null will be returned. (You should use the "new" operator to create the AR instance in that case.)

      since

      3.1.2

      access

      public

      [ Top ]

      static TActiveRecord::finder

      static finder( [string $className = __CLASS__] );

      Parameters

      $className

      active record class name.

      Returns

      active record finder instance.

      Remarks

      Returns the instance of a active record finder for a particular class.

      The finder objects are static instances for each ActiveRecord class. This means that event handlers bound to these finder instances are class wide. Create a new instance of the ActiveRecord class if you wish to bound the event handlers to object instance.

      access

      public

      [ Top ]

      static TActiveRecord::getActiveDbConnection

      static getActiveDbConnection( );

      access

      public

      [ Top ]

      static TActiveRecord::getRecordManager

      static getRecordManager( );

      Returns

      default active record manager.

      Remarks

      Gets the record manager for this object, the default is to call TActiveRecordManager::getInstance().

      access

      public

      [ Top ]

      TActiveRecord::__construct

      __construct( [array $data = array()], [TDbConnection $connection = null] );

      Parameters

      $data

      optional name value pair record data.

      $connection

      optional database connection this object record use.

      Remarks

      Create a new instance of an active record with given $data. The record can be saved to the database specified by the $connection object.

      access

      public

      [ Top ]

      TActiveRecord::copyFrom

      copyFrom( $data );

      Parameters

      $data

      Remarks

      Copies data from an array or another object.

      throws

      TActiveRecordException if data is not array or not object.

      access

      public

      [ Top ]

      TActiveRecord::count

      count( [string|TActiveRecordCriteria $criteria = null], [mixed $parameters = array()] );

      Parameters

      $criteria

      SQL condition or criteria object.

      $parameters

      parameter values.

      Returns

      number of records.

      Remarks

      Find the number of records.

      access

      public

      [ Top ]

      TActiveRecord::createRelationContext

      createRelationContext( string $name );

      Parameters

      $name

      relationship/property name corresponding to keys in $RELATION array.

      Returns

      object containing information on the active record relationships for given property, null if invalid relationship

      Remarks

      Gets a static copy of the relationship context for given property (a key in $RELATIONS), returns null if invalid relationship. Keeps a null reference to all invalid relations called.

      since

      3.1.2

      access

      protected

      [ Top ]

      TActiveRecord::delete

      delete( );

      Returns

      true if the record was deleted successfully, false otherwise.

      Remarks

      Deletes the current record from the database. Once deleted, this object can not be saved again in the same instance.

      access

      public

      [ Top ]

      TActiveRecord::deleteAll

      deleteAll( [string|TActiveRecordCriteria $criteria = null], [mixed $parameters = array()] );

      Parameters

      $criteria

      SQL condition or criteria object.

      $parameters

      parameter values.

      Returns

      number of records deleted.

      Remarks

      Delete multiple records using a criteria.

      access

      public

      [ Top ]

      TActiveRecord::deleteAllByPks

      deleteAllByPks( $keys );

      Parameters

      $keys

      Remarks

      Alias for deleteByPk()

      access

      public

      [ Top ]

      TActiveRecord::deleteByPk

      deleteByPk( mixed $keys );

      Parameters

      $keys

      primary key values.

      Returns

      number of records deleted.

      Remarks

      Delete records by primary key. Usage:

    •  $finder->deleteByPk($primaryKey); //delete 1 record
      •

    •  $finder->deleteByPk($key1,$key2,...); //delete multiple records
      •

    •  $finder->deleteByPk(array($key1,$key2,...)); //delete multiple records
      •

      For composite primary keys (determined from the table definitions):

    •  $finder->deleteByPk(array($key1,$key2)); //delete 1 record
      •

    •
      •

    •  //delete multiple records
      •

    •  $finder->deleteByPk(array($key1,$key2), array($key3,$key4),...);
      •

    •
      •

    •  //delete multiple records
      •

    •  $finder->deleteByPk(array( array($key1,$key2), array($key3,$key4), .. ));
      •

      access

      public

      [ Top ]

      TActiveRecord::equals

      equals( TActiveRecord $record, [boolean $strict = false] );

      Parameters

      $record

      another record to compare with.

      $strict

      true to perform strict identity comparison

      Returns

      true if $record equals, false otherwise.

      Remarks

      Compare two records using their primary key values (all column values if table does not defined primary keys). The default uses simple == for comparison of their values. Set $strict=true for identity comparison (===).

      access

      public

      [ Top ]

      TActiveRecord::fetchResultsFor

      fetchResultsFor( string $property );

      Parameters

      $property

      relationship/property name corresponding to keys in $RELATION array.

      Returns

      true if relationship exists, false otherwise.

      Remarks

      Tries to load the relationship results for the given property. The $property value should correspond to an entry key in the $RELATION array.

      This method can be used to lazy load relationships.

    •  class TeamRecord extends TActiveRecord
      •

    •  {
      •

    •      ...
      •

    •
      •

    •      private $_players;
      •

    •      public static $RELATION=array
      •

    •      (
      •

    •          'players' => array(self::HAS_MANY, 'PlayerRecord'),
      •

    •      );
      •

    •
      •

    •      public function setPlayers($array)
      •

    •      {
      •

    •          $this->_players=$array;
      •

    •      }
      •

    •
      •

    •      public function getPlayers()
      •

    •      {
      •

    •          if($this->_players===null)
      •

    •              $this->fetchResultsFor('players');
      •

    •          return $this->_players;
      •

    •      }
      •

    •  }
      •

    •  Usage example:
      •

    •  $team = TeamRecord::finder()->findByPk(1);
      •

    •  var_dump($team->players); //uses lazy load to fetch 'players' relation
      •

      since

      3.1.2

      access

      protected

      [ Top ]

      TActiveRecord::find

      find( string|TActiveRecordCriteria $criteria, [mixed $parameters = array()] );

      Parameters

      $criteria

      SQL condition or criteria object.

      $parameters

      parameter values.

      Returns

      matching record object. Null if no result is found.

      Remarks

      Find one single record that matches the criteria.

      Usage:

    •  $finder->find('username = :name AND password = :pass',
      •

    •                      array(':name'=>$name, ':pass'=>$pass));
      •

    •  $finder->find('username = ? AND password = ?', array($name, $pass));
      •

    •  $finder->find('username = ? AND password = ?', $name, $pass);
      •

    •  //$criteria is of TActiveRecordCriteria
      •

    •  $finder->find($criteria); //the 2nd parameter for find() is ignored.
      •

      access

      public

      [ Top ]

      TActiveRecord::findAll

      findAll( [string|TActiveRecordCriteria $criteria = null], [mixed $parameters = array()] );

      Parameters

      $criteria

      SQL condition or criteria object.

      $parameters

      parameter values.

      Returns

      matching record objects. Empty array if no result is found.

      Remarks

      Same as find() but returns an array of objects.

      access

      public

      [ Top ]

      TActiveRecord::findAllByIndex

      findAllByIndex( TActiveRecordCriteria $criteria, array $fields, array $values );

      Parameters

      $criteria

      additional criteria

      $fields

      field names to match with "(fields) IN (values)" sql clause.

      $values

      matching field values.

      Returns

      matching active records. Empty array is returned if no result is found.

      Remarks

      Fetches records using the sql clause "(fields) IN (values)", where fields is an array of column names and values is an array of values that the columns must have.

      This method is to be used by the relationship handler.

      access

      public

      [ Top ]

      TActiveRecord::findAllByPks

      findAllByPks( mixed $keys );

      Parameters

      $keys

      primary keys

      Returns

      matching ActiveRecords. Empty array is returned if no result is found.

      Remarks

      Find multiple records matching a list of primary or composite keys.

      For scalar primary keys:

    •  $finder->findAllByPk($key1, $key2, ...);
      •

    •  $finder->findAllByPk(array($key1, $key2, ...));
      •

      For composite keys:

    •  $finder->findAllByPk(array($key1, $key2), array($key3, $key4), ...);
      •

    •  $finder->findAllByPk(array(array($key1, $key2), array($key3, $key4), ...));
      •

      access

      public

      [ Top ]

      TActiveRecord::findAllBySql

      findAllBySql( string $sql, [array $parameters = array()] );

      Parameters

      $parameters

      $sql

      select SQL

      Returns

      matching active records. Empty array is returned if no result is found.

      Remarks

      Find records using full SQL, returns corresponding record object.

      The names of the column retrieved must be defined in your Active Record class.

      access

      public

      [ Top ]

      TActiveRecord::findByPk

      findByPk( mixed $keys );

      Parameters

      $keys

      primary keys

      Returns

      Null if no result is found.

      Remarks

      Find one record using only the primary key or composite primary keys. Usage:

    •  $finder->findByPk($primaryKey);
      •

    •  $finder->findByPk($key1, $key2, ...);
      •

    •  $finder->findByPk(array($key1,$key2,...));
      •

      access

      public

      [ Top ]

      TActiveRecord::findBySql

      findBySql( string $sql, [array $parameters = array()] );

      Parameters

      $parameters

      $sql

      select SQL

      Returns

      null if no result is returned.

      Remarks

      Find records using full SQL, returns corresponding record object.

      The names of the column retrieved must be defined in your Active Record class.

      access

      public

      [ Top ]

      TActiveRecord::getColumnValue

      getColumnValue( string $columnName );

      Parameters

      $columnName

      the column name (as defined in database schema)

      Returns

      the corresponding column value

      Remarks

      Retrieves the column value according to column name.

      This method is used internally.

      since

      3.1.1

      access

      public

      [ Top ]

      TActiveRecord::getDbConnection

      getDbConnection( );

      Returns

      current db connection for this object.

      Remarks

      Gets the current Db connection, the connection object is obtained from the TActiveRecordManager if connection is currently null.

      access

      public

      [ Top ]

      TActiveRecord::getInvalidFinderResult

      getInvalidFinderResult( );

      Returns

      Defaults to 'Null'.

      see

      TActiveRecordManager::getInvalidFinderResult

      since

      3.1.5

      access

      public

      [ Top ]

      TActiveRecord::getRecordCriteria

      getRecordCriteria( string|TSqlCriteria $criteria, mixed $parameters, [array $args = array()] );

      Parameters

      $criteria

      sql criteria

      $parameters

      parameters passed by the user.

      $args

      additional parameters obtained from function_get_args().

      Returns

      criteria object.

      Remarks

      Create a new TSqlCriteria object from a string $criteria. The $args are additional parameters and are used in place of the $parameters if $parameters is not an array and $args is an arrary.

      access

      protected

      [ Top ]

      TActiveRecord::getRecordGateway

      getRecordGateway( );

      Returns

      record table gateway.

      access

      public

      [ Top ]

      TActiveRecord::getRecordRelation

      getRecordRelation( string $property );

      Parameters

      $property

      relation property name

      Returns

      relation definition for the specified property

      since

      3.1.2

      access

      public

      [ Top ]

      TActiveRecord::getRecordRelations

      getRecordRelations( );

      Returns

      all relation definitions declared in the AR class

      since

      3.1.2

      access

      public

      [ Top ]

      TActiveRecord::getRecordTableInfo

      getRecordTableInfo( );

      Returns

      the meta information of the table associated with this AR class.

      access

      public

      [ Top ]

      TActiveRecord::getRelationHandler

      getRelationHandler( string $name, [array $args = array()] );

      Parameters

      $name

      relationship/property name corresponding to keys in $RELATION array.

      $args

      method call arguments.

      Returns

      null if the context or the handler doesn't exist

      Remarks

      Returns the active record relationship handler for $RELATION with key value equal to the $property value.

      access

      protected

      [ Top ]

      TActiveRecord::hasRecordRelation

      hasRecordRelation( string $property );

      Parameters

      $property

      AR property name

      Returns

      whether a relation is declared for the specified AR property

      since

      3.1.2

      access

      public

      [ Top ]

      TActiveRecord::onCreateCommand

      onCreateCommand( TDataGatewayEventParameter $param );

      Parameters

      $param

      Remarks

      Raised when a command is prepared and parameter binding is completed.

      The parameter object is TDataGatewayEventParameter of which the TDataGatewayEventParameter::getCommand property can be inspected to obtain the sql query to be executed.

      Note well that the finder objects obtained from ActiveRecord::finder() method are static objects. This means that the event handlers are bound to a static finder object and not to each distinct active record object.

      access

      public

      [ Top ]

      TActiveRecord::onDelete

      onDelete( TActiveRecordChangeEventParameter $param );

      Parameters

      $param

      event parameter to be passed to the event handlers

      Remarks

      Raised before the record attempt to delete its data from the database.

      To prevent the delete operation, set the TActiveRecordChangeEventParameter::IsValid parameter to false.

      access

      public

      [ Top ]

      TActiveRecord::onExecuteCommand

      onExecuteCommand( TDataGatewayResultEventParameter $param );

      Parameters

      $param

      Remarks

      Raised when a command is executed and the result from the database was returned.

      The parameter object is TDataGatewayResultEventParameter of which the TDataGatewayEventParameter::getResult property contains the data return from the database. The data returned can be changed by setting the TDataGatewayEventParameter::setResult property.

      Note well that the finder objects obtained from ActiveRecord::finder() method are static objects. This means that the event handlers are bound to a static finder object and not to each distinct active record object.

      access

      public

      [ Top ]

      TActiveRecord::onInsert

      onInsert( TActiveRecordChangeEventParameter $param );

      Parameters

      $param

      event parameter to be passed to the event handlers

      Remarks

      Raised before the record attempt to insert its data into the database.

      To prevent the insert operation, set the TActiveRecordChangeEventParameter::IsValid parameter to false.

      access

      public

      [ Top ]

      TActiveRecord::onUpdate

      onUpdate( TActiveRecordChangeEventParameter $param );

      Parameters

      $param

      event parameter to be passed to the event handlers

      Remarks

      Raised before the record attempt to update its data in the database.

      To prevent the update operation, set the TActiveRecordChangeEventParameter::IsValid parameter to false.

      access

      public

      [ Top ]

      TActiveRecord::populateObject

      populateObject( array $data );

      Parameters

      $data

      name value pair of record data

      Returns

      object record, null if data is empty.

      Remarks

      Populates a new record with the query result.

      This is a wrapper of createRecord.

      access

      protected

      [ Top ]

      TActiveRecord::populateObjects

      populateObjects( TDbDataReader $reader );

      Parameters

      $reader

      data reader

      Returns

      the AR objects populated by the query result

      since

      3.1.2

      access

      protected

      [ Top ]

      TActiveRecord::save

      save( );

      Returns

      true if record was saved successfully, false otherwise.

      Remarks

      Saves the current record to the database, insert or update is automatically determined.

      access

      public

      [ Top ]

      TActiveRecord::setColumnValue

      setColumnValue( string $columnName, mixed $value );

      Parameters

      $columnName

      the column name (as defined in database schema)

      $value

      the corresponding column value

      Remarks

      Sets the column value according to column name.

      This method is used internally.

      since

      3.1.1

      access

      public

      [ Top ]

      TActiveRecord::setDbConnection

      setDbConnection( TDbConnection $connection );

      Parameters

      $connection

      db connection object for this record.

      access

      public

      [ Top ]

      TActiveRecord::setInvalidFinderResult

      setInvalidFinderResult( TActiveRecordInvalidFinderResult|null $value );

      Parameters

      $value

      Remarks

      Define the way an active record finder react if an invalid magic-finder invoked

      see

      TActiveRecordManager::setInvalidFinderResult

      since

      3.1.5

      access

      public

      [ Top ]

      TActiveRecord::__call

      __call( $method, $args );

      Overrides TComponent::__call() (Calls a method.)

      Parameters

      $method

      $args

      Returns

      single record if method name starts with "findBy", 0 or more records if method name starts with "findAllBy"

      Remarks

      Dynamic find method using parts of method name as search criteria.

      Method name starting with "findBy" only returns 1 record. Method name starting with "findAllBy" returns 0 or more records. Method name starting with "deleteBy" deletes records by the trail criteria. The condition is taken as part of the method name after "findBy", "findAllBy" or "deleteBy".

      The following are equivalent:

    •  $finder->findByName($name)
      •

    •  $finder->find('Name = ?', $name);
      •

    •  $finder->findByUsernameAndPassword($name,$pass); // OR may be used
      •

    •  $finder->findBy_Username_And_Password($name,$pass); // _OR_ may be used
      •

    •  $finder->find('Username = ? AND Password = ?', $name, $pass);
      •

    •  $finder->findAllByAge($age);
      •

    •  $finder->findAll('Age = ?', $age);
      •

    •  $finder->deleteAll('Name = ?', $name);
      •

    •  $finder->deleteByName($name);
      •

      access

      public

      [ Top ]

      TActiveRecord::__get

      __get( string $name );

      Overrides TComponent::__get() (Returns a property value or an event handler list by property or event name.)

      Parameters

      $name

      property name

      Returns

      property value.

      Remarks

      Magic method for reading properties.

      This method is overriden to provide read access to the foreign objects via the key names declared in the RELATIONS array.

      since

      3.1.2

      access

      public

      [ Top ]

      TActiveRecord::__set

      __set( string $name, mixed $value );

      Overrides TComponent::__set() (Sets value of a component property.)

      Parameters

      $name

      property name

      $value

      property value.

      Remarks

      Magic method for writing properties.

      This method is overriden to provide write access to the foreign objects via the key names declared in the RELATIONS array.

      since

      3.1.2

      access

      public

      [ Top ]

      TActiveRecord::__sleep

      __sleep( );

      Overrides TComponent::__sleep() (Returns an array with the names of all variables of that object that should be serialized.)

      Remarks

      Prevent __call() method creating __sleep() when serializing.

      access

      public

      [ Top ]

      TActiveRecord::__wakeup

      __wakeup( );

      Overrides TComponent::__wakeup() (Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.)

      Remarks

      Prevent __call() method creating __wakeup() when unserializing.

      access

      public

      [ Top ]

    Variable Detail

    • static $COLUMN_MAPPING = array() [line 174]
    • Data type: array

      • Remarks

      This static variable defines the column mapping.

      The keys are physical column names as defined in database, and the values are logical column names as defined as public variable/property names for the corresponding active record class.

      var

      column mapping. Keys: physical column names, values: logical column names.

      since

      3.1.1

      access

      public

    • static $RELATIONS = array() [line 184]
    • Data type: array

      • Remarks

      This static variable defines the relationships.

      The keys are public variable/property names defined in the AR class. Each value is an array, e.g. array(self::HAS_MANY, 'PlayerRecord').

      var

      relationship.

      since

      3.1.1

      access

      public

    • $_connection = [line 190]
    • Data type: TDbConnection

      • var

      database connection object.

      access

      protected

    • $_invalidFinderResult =  null [line 199]
    • Data type: TActiveRecordInvalidFinderResult

      • Remarks

      Defaults to 'null'

      since

      3.1.5

      access

      protected

    • $_recordState = 0 [line 164]
    • Data type: integer

      • var

      record state: 0 = new, 1 = loaded, 2 = deleted.

      since

      3.1.2

      access

      protected

    Class Constant Detail

    • BELONGS_TO = 'BELONGS_TO' [line 151]

    • HAS_MANY = 'HAS_MANY' [line 153]

    • HAS_ONE = 'HAS_ONE' [line 152]

    • MANY_TO_MANY = 'MANY_TO_MANY' [line 154]

    • STATE_DELETED = 2 [line 158]

    • STATE_LOADED = 1 [line 157]

    • STATE_NEW = 0 [line 156]

    Documentation generated on Mon, 25 Jun 2012 14:43:24 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordChangeEventParameter

Class TActiveRecordChangeEventParameter

[line 1044]
TComponent
   |
   --TEventParameter
      |
      --TActiveRecordChangeEventParameter
Location: /Data/ActiveRecord/TActiveRecord.php

Remarks

TActiveRecordChangeEventParameter class

TActiveRecordChangeEventParameter encapsulates the parameter data for ActiveRecord change commit events that are broadcasted. The following change events may be raise: TActiveRecord::OnInsert, TActiveRecord::OnUpdate and TActiveRecord::OnDelete. The IsValid parameter can be set to false to prevent the requested change event to be performed.

author

Wei Zhuo<weizhuo@gmail.com>

version

$Id: TActiveRecord.php 3004 2011-06-26 09:56:56Z ctrlaltca@gmail.com $

since

3.1.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveRecordChangeEventParameter::getIsValid

    getIsValid( );

    Returns

    whether the event should be performed.

    access

    public

    [ Top ]

    TActiveRecordChangeEventParameter::setIsValid

    setIsValid( boolean $value );

    Parameters

    $value

    set to false to prevent the event.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:25 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordInvalidFinderResult

Class TActiveRecordInvalidFinderResult

[line 1082]
TEnumerable
   |
   --TActiveRecordInvalidFinderResult
Location: /Data/ActiveRecord/TActiveRecord.php

Remarks

TActiveRecordInvalidFinderResult class.

TActiveRecordInvalidFinderResult defines the enumerable type for possible results if an invalid TActiveRecord::__call invoked.

The following enumerable values are defined:

  • Null: return null (default)
  • Exception: throws a TActiveRecordException

author

Yves Berkholz <godzilla80@gmx.net>

version

$Id: TActiveRecord.php 3004 2011-06-26 09:56:56Z ctrlaltca@gmail.com $

see

TActiveRecord::setInvalidFinderResult

see

TActiveRecordManager::setInvalidFinderResult

see

TActiveRecordConfig::setInvalidFinderResult

since

3.1.5

Class Variable Summary

Class Constant Summary

  • Exception =  'Exception'
  • Null =  'Null'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Exception =  'Exception' [line 1085]

  • Null =  'Null' [line 1084]

Documentation generated on Mon, 25 Jun 2012 14:43:25 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordConfig

Class TActiveRecordConfig

[line 73]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TDataSourceConfig
            |
            --TActiveRecordConfig
Location: /Data/ActiveRecord/TActiveRecordConfig.php

Remarks

TActiveRecordConfig module configuration class.

Database configuration for the default ActiveRecord manager instance.

Example: application.xml configuration

  •  <modules>
    •

  •      <module class="System.Data.ActiveRecord.TActiveRecordConfig" EnableCache="true">
    •

  •          <database ConnectionString="mysql:host=localhost;dbname=test"
    •

  •              Username="dbuser" Password="dbpass" />
    •

  •      </module>
    •

  •  </modules>
    •

    MySQL database definition:

  •  CREATE TABLE `blogs` (
    •

  •   `blog_id` int(10) unsigned NOT NULL auto_increment,
    •

  •   `blog_name` varchar(255) NOT NULL,
    •

  •   `blog_author` varchar(255) NOT NULL,
    •

  •   PRIMARY KEY  (`blog_id`)
    •

  •  ) ENGINE=InnoDB DEFAULT CHARSET=utf8;
    •

    Record php class:

  •  class Blogs extends TActiveRecord
    •

  •  {
    •

  •      public $blog_id;
    •

  •     public $blog_name;
    •

  •     public $blog_author;
    •

  •
    •

  •     public static function finder($className=__CLASS__)
    •

  •     {
    •

  •         return parent::finder($className);
    •

  •     }
    •

  •  }
    •

    Usage example:

  •  class Home extends TPage
    •

  •  {
    •

  •      function onLoad($param)
    •

  •      {
    •

  •          $blogs = Blogs::finder()->findAll();
    •

  •       print_r($blogs);
    •

  •      }
    •

  •  }
    •

    author

    Wei Zhuo <weizho[at]gmail[dot]com>

    version

    $Id: TActiveRecordConfig.php 3030 2011-08-28 05:51:36Z GODZilla0480@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    • DEFAULT_GATEWAY_CLASS =  'System.Data.ActiveRecord.TActiveRecordGateway'
    • DEFAULT_MANAGER_CLASS =  'System.Data.ActiveRecord.TActiveRecordManager'

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TDataSourceConfig

    • TDataSourceConfig::findConnectionByID()
      Finds the database connection instance from the Application modules.
    • TDataSourceConfig::getConnectionClass()
    • TDataSourceConfig::getConnectionID()
    • TDataSourceConfig::getDatabase()
      Alias for getDbConnection().
    • TDataSourceConfig::getDbConnection()
      Gets the TDbConnection from another module if setConnectionID is supplied and valid. Otherwise, a connection of type given by setConnectionClass is created.
    • TDataSourceConfig::init()
      Initalize the database connection properties from attributes in <database> tag.
    • TDataSourceConfig::setConnectionClass()
      The database connection class name to be created when getDbConnection
    • TDataSourceConfig::setConnectionID()
      The module ID of another TDataSourceConfig. The getDbConnection property of this configuration will equal to getDbConnection of the given TDataSourceConfig module.

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TActiveRecordConfig::getEnableCache

      getEnableCache( );

      Returns

      true if table meta data should be cached, false otherwise.

      access

      public

      [ Top ]

      TActiveRecordConfig::getGatewayClass

      getGatewayClass( );

      Returns

      the implementation class of ActiveRecordGateway. Defaults to DEFAULT_GATEWAY_CLASS

      access

      public

      [ Top ]

      TActiveRecordConfig::getInvalidFinderResult

      getInvalidFinderResult( );

      Returns

      Defaults to 'Null'.

      see

      TActiveRecordConfig::setInvalidFinderResult()

      since

      3.1.5

      access

      public

      [ Top ]

      TActiveRecordConfig::getManager

      getManager( );

      access

      public

      [ Top ]

      TActiveRecordConfig::getManagerClass

      getManagerClass( );

      Returns

      the implementation class of ActiveRecordManager. Defaults to DEFAULT_MANAGER_CLASS

      access

      public

      [ Top ]

      TActiveRecordConfig::init

      init( TXmlDocument $xml );

      Overrides TDataSourceConfig::init() (Initalize the database connection properties from attributes in <database> tag.)

      Parameters

      $xml

      xml configuration.

      Remarks

      Initialize the active record manager.

      access

      public

      [ Top ]

      TActiveRecordConfig::setEnableCache

      setEnableCache( boolean $value );

      Parameters

      $value

      true to cache sqlmap instance.

      Remarks

      Set true to cache the table meta data.

      access

      public

      [ Top ]

      TActiveRecordConfig::setGatewayClass

      setGatewayClass( string $value );

      Parameters

      $value

      Remarks

      Set implementation class of ActiveRecordGateway

      access

      public

      [ Top ]

      TActiveRecordConfig::setInvalidFinderResult

      setInvalidFinderResult( TActiveRecordInvalidFinderResult $value );

      Parameters

      $value

      Remarks

      Define the way an active record finder react if an invalid magic-finder invoked

      see

      TActiveRecordConfig::getInvalidFinderResult()

      since

      3.1.5

      access

      public

      [ Top ]

      TActiveRecordConfig::setManagerClass

      setManagerClass( string $value );

      Parameters

      $value

      Remarks

      Set implementation class of ActiveRecordManager

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • DEFAULT_GATEWAY_CLASS =  'System.Data.ActiveRecord.TActiveRecordGateway' [line 76]

    • DEFAULT_MANAGER_CLASS =  'System.Data.ActiveRecord.TActiveRecordManager' [line 75]

    Documentation generated on Mon, 25 Jun 2012 14:43:25 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordCriteria

Class TActiveRecordCriteria

[line 35]
TComponent
   |
   --TSqlCriteria
      |
      --TActiveRecordCriteria
Location: /Data/ActiveRecord/TActiveRecordCriteria.php

Remarks

Search criteria for Active Record.

Criteria object for active record finder methods. Usage:

  •  $criteria = new TActiveRecordCriteria;
    •

  •  $criteria->Condition = 'username = :name AND password = :pass';
    •

  •  $criteria->Parameters[':name'] = 'admin';
    •

  •  $criteria->Parameters[':pass'] = 'prado';
    •

  •  $criteria->OrdersBy['level'] = 'desc';
    •

  •  $criteria->OrdersBy['name'] = 'asc';
    •

  •  $criteria->Limit = 10;
    •

  •  $criteria->Offset = 20;
    •

    author

    Wei Zhuo <weizho[at]gmail[dot]com>

    version

    $Id: TActiveRecordCriteria.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TSqlCriteria

    • TSqlCriteria::__construct()
      Creates a new criteria with given condition;
    • TSqlCriteria::getCondition()
    • TSqlCriteria::getIsNamedParameters()
    • TSqlCriteria::getLimit()
    • TSqlCriteria::getOffset()
    • TSqlCriteria::getOrdersBy()
    • TSqlCriteria::getParameters()
    • TSqlCriteria::getSelect()
      Gets the field list to be placed after the SELECT in the SQL. Default to '*'
    • TSqlCriteria::setCondition()
      Sets the search conditions to be placed after the WHERE clause in the SQL.
    • TSqlCriteria::setLimit()
    • TSqlCriteria::setOffset()
    • TSqlCriteria::setOrdersBy()
    • TSqlCriteria::setParameters()
    • TSqlCriteria::setSelect()
      Sets the field list to be placed after the SELECT in the SQL.
    • TSqlCriteria::__toString()

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:26 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordConfigurationException

Class TActiveRecordConfigurationException

[line 45]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --TDbException
            |
            --TActiveRecordException
               |
               --TActiveRecordConfigurationException
Location: /Data/ActiveRecord/Exceptions/TActiveRecordException.php

Remarks

TActiveRecordConfigurationException class.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TActiveRecordException.php 3098 2012-01-28 17:49:48Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TActiveRecordException

  • TActiveRecordException::getErrorMessageFile()

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:26 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordException

Class TActiveRecordException

[line 21]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --TDbException
            |
            --TActiveRecordException
Classes extended from TActiveRecordException:
TActiveRecordConfigurationException
TActiveRecordConfigurationException class.

Location: /Data/ActiveRecord/Exceptions/TActiveRecordException.php

Remarks

Base exception class for Active Records.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TActiveRecordException.php 3098 2012-01-28 17:49:48Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

    TActiveRecordException::getErrorMessageFile

    getErrorMessageFile( );

    Overrides TException::getErrorMessageFile() (parent method not documented)

    Returns

    path to the error message file

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:26 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordGateway

Class TActiveRecordGateway

[line 22]
TComponent
   |
   --TActiveRecordGateway
Location: /Data/ActiveRecord/TActiveRecordGateway.php

Remarks

TActiveRecordGateway excutes the SQL command queries and returns the data record as arrays (for most finder methods).

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TActiveRecordGateway.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

  • TABLE_CONST = 'TABLE'
    Constant name for specifying optional table name in TActiveRecord.
  • TABLE_METHOD = 'table'
    Method name for returning optional table name in in TActiveRecord

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TActiveRecordGateway::__construct

    __construct( TActiveRecordManager $manager );

    Parameters

    $manager

    Remarks

    Record gateway constructor.

    access

    public

    [ Top ]

    TActiveRecordGateway::countRecords

    countRecords( TActiveRecord $record, TActiveRecordCriteria $criteria );

    Parameters

    $record

    active record finder instance.

    $criteria

    search criteria

    Returns

    number of records.

    Remarks

    Returns the number of records that match the given criteria.

    access

    public

    [ Top ]

    TActiveRecordGateway::delete

    delete( TActiveRecord $record );

    Parameters

    $record

    record to be deleted.

    Returns

    number of rows affected.

    Remarks

    Delete the record.

    access

    public

    [ Top ]

    TActiveRecordGateway::deleteRecordsByCriteria

    deleteRecordsByCriteria( TActiveRecord $record, TActiveRecordCriteria $criteria );

    Parameters

    $record

    active record finder instance.

    $criteria

    search criteria

    Returns

    number of records.

    Remarks

    Delete multiple records by criteria.

    access

    public

    [ Top ]

    TActiveRecordGateway::deleteRecordsByPk

    deleteRecordsByPk( TActiveRecord $record, $keys );

    Parameters

    $record

    finder instance.

    $keys

    Returns

    number of rows deleted.

    Remarks

    Delete multiple records using primary keys.

    access

    public

    [ Top ]

    TActiveRecordGateway::findRecordByPK

    findRecordByPK( TActiveRecord $record, array $keys );

    Parameters

    $record

    active record instance.

    $keys

    primary name value pairs

    Returns

    record data

    Remarks

    Returns record data matching the given primary key(s). If the table uses composite key, specify the name value pairs as an array.

    access

    public

    [ Top ]

    TActiveRecordGateway::findRecordBySql

    findRecordBySql( TActiveRecord $record, TActiveRecordCriteria $criteria );

    Parameters

    $record

    active record finder instance.

    $criteria

    sql query

    Returns

    result.

    Remarks

    Return record data from sql query.

    access

    public

    [ Top ]

    TActiveRecordGateway::findRecordsByCriteria

    findRecordsByCriteria( TActiveRecord $record, TActiveRecordCriteria $criteria, [boolean $iterator = false] );

    Parameters

    $record

    active record finder instance.

    $criteria

    search criteria.

    $iterator

    true to return multiple rows as iterator, false returns first row.

    Returns

    matching data.

    Remarks

    Returns record data matching the given critera. If $iterator is true, it will return multiple rows as TDbDataReader otherwise it returns the first row data.

    access

    public

    [ Top ]

    TActiveRecordGateway::findRecordsByIndex

    findRecordsByIndex( TActiveRecord $record, $criteria, $fields, $values );

    Parameters

    $record

    $criteria

    $fields

    $values

    access

    public

    [ Top ]

    TActiveRecordGateway::findRecordsByPks

    findRecordsByPks( TActiveRecord $record, array $keys );

    Parameters

    $record

    active record instance.

    $keys

    list of primary name value pairs

    Returns

    matching data.

    Remarks

    Returns records matching the list of given primary keys.

    access

    public

    [ Top ]

    TActiveRecordGateway::findRecordsBySql

    findRecordsBySql( TActiveRecord $record, TActiveRecordCriteria $criteria );

    Parameters

    $record

    active record finder instance.

    $criteria

    sql query

    Returns

    result iterator.

    Remarks

    Return record data from sql query.

    access

    public

    [ Top ]

    TActiveRecordGateway::getCommand

    getCommand( TActiveRecord $record );

    Parameters

    $record

    access

    public

    [ Top ]

    TActiveRecordGateway::getInsertValues

    getInsertValues( TActiveRecord $record );

    Parameters

    $record

    record

    Returns

    insert values.

    access

    protected

    [ Top ]

    TActiveRecordGateway::getManager

    getManager( );

    Returns

    record manager.

    access

    protected

    [ Top ]

    TActiveRecordGateway::getPrimaryKeyValues

    getPrimaryKeyValues( TActiveRecord $record );

    Parameters

    $record

    access

    protected

    [ Top ]

    TActiveRecordGateway::getRecordTableInfo

    getRecordTableInfo( TActiveRecord $record );

    Parameters

    $record

    Returns

    table information.

    Remarks

    Returns table information, trys the application cache first.

    access

    public

    [ Top ]

    TActiveRecordGateway::getRecordTableName

    getRecordTableName( TActiveRecord $record );

    Parameters

    $record

    active record instance

    Returns

    table name for the given record class.

    Remarks

    Gets the table name from the 'TABLE' constant of the active record class if defined, otherwise use the class name as table name.

    access

    protected

    [ Top ]

    TActiveRecordGateway::getTableInfo

    getTableInfo( $connection, string $tableName );

    Parameters

    $connection

    database connection

    $tableName

    table name

    Returns

    table details.

    Remarks

    Returns table information for table in the database connection.

    access

    public

    [ Top ]

    TActiveRecordGateway::getUpdateValues

    getUpdateValues( TActiveRecord $record );

    Parameters

    $record

    access

    protected

    [ Top ]

    TActiveRecordGateway::insert

    insert( TActiveRecord $record );

    Parameters

    $record

    new record.

    Returns

    number of rows affected.

    Remarks

    Insert a new record.

    access

    public

    [ Top ]

    TActiveRecordGateway::onCreateCommand

    onCreateCommand( TDataGatewayCommand $sender, TDataGatewayEventParameter $param );

    Parameters

    $sender

    originator $sender

    $param

    Remarks

    Raised when a command is prepared and parameter binding is completed.

    The parameter object is TDataGatewayEventParameter of which the TDataGatewayEventParameter::getCommand property can be inspected to obtain the sql query to be executed. This method also raises the OnCreateCommand event on the ActiveRecord object calling this gateway.

    access

    public

    [ Top ]

    TActiveRecordGateway::onExecuteCommand

    onExecuteCommand( TDataGatewayCommand $sender, TDataGatewayResultEventParameter $param );

    Parameters

    $sender

    originator $sender

    $param

    Remarks

    Raised when a command is executed and the result from the database was returned.

    The parameter object is TDataGatewayResultEventParameter of which the TDataGatewayEventParameter::getResult property contains the data return from the database. The data returned can be changed by setting the TDataGatewayEventParameter::setResult property. This method also raises the OnCreateCommand event on the ActiveRecord object calling this gateway.

    access

    public

    [ Top ]

    TActiveRecordGateway::raiseCommandEvent

    raiseCommandEvent( string $event, TDbCommand $command, TActiveRecord $record, TActiveRecordCriteria $criteria );

    Parameters

    $event

    command type

    $command

    sql command to be executed.

    $record

    active record

    $criteria

    data for the command.

    Remarks

    Raise the corresponding command event, insert, update, delete or select.

    access

    protected

    [ Top ]

    TActiveRecordGateway::update

    update( TActiveRecord $record );

    Parameters

    $record

    dirty record.

    Returns

    number of rows affected.

    Remarks

    Update the record.

    access

    public

    [ Top ]

    TActiveRecordGateway::updateAssociatedRecords

    updateAssociatedRecords( TActiveRecord $record, [ $updateBelongsTo = false] );

    Parameters

    $record

    $updateBelongsTo

    access

    protected

    [ Top ]

    TActiveRecordGateway::updatePostInsert

    updatePostInsert( TActiveRecord $record );

    Parameters

    $record

    record for insertion

    Remarks

    Sets the last insert ID to the corresponding property of the record if available.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

  • TABLE_CONST = 'TABLE' [line 33]

    • Remarks

    Constant name for specifying optional table name in TActiveRecord.

  • TABLE_METHOD = 'table' [line 37]

    • Remarks

    Method name for returning optional table name in in TActiveRecord

Documentation generated on Mon, 25 Jun 2012 14:43:26 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordManager

Class TActiveRecordManager

[line 38]
TComponent
   |
   --TActiveRecordManager
Location: /Data/ActiveRecord/TActiveRecordManager.php

Remarks

TActiveRecordManager provides the default DB connection, default active record gateway, and table meta data inspector.

The default connection can be set as follows:

  •  TActiveRecordManager::getInstance()->setDbConnection($conn);
    •
    All new active record created after setting the DbConnection will use that connection unless the custom ActiveRecord class overrides the ActiveRecord::getDbConnection().

    Set the Cache property to an ICache object to allow the active record gateway to cache the table meta data information.

    author

    Wei Zhuo <weizho[at]gmail[dot]com>

    version

    $Id: TActiveRecordManager.php 3030 2011-08-28 05:51:36Z GODZilla0480@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    • DEFAULT_GATEWAY_CLASS =  'System.Data.ActiveRecord.TActiveRecordGateway'

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    • static TActiveRecordManager getInstance()
    • TActiveRecordManager getInstance()

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      static TActiveRecordManager::getInstance

      static getInstance( [ $self = null] );

      Parameters

      $self

      Returns

      static instance of record manager.

      access

      public

      [ Top ]

      TActiveRecordManager::createRecordGateway

      createRecordGateway( );

      Returns

      default record gateway.

      access

      protected

      [ Top ]

      TActiveRecordManager::getCache

      getCache( );

      Returns

      application cache.

      access

      public

      [ Top ]

      TActiveRecordManager::getDbConnection

      getDbConnection( );

      Returns

      default database connection

      access

      public

      [ Top ]

      TActiveRecordManager::getGatewayClass

      getGatewayClass( );

      Returns

      the implementation class of ActiveRecordGateway. Defaults to DEFAULT_GATEWAY_CLASS

      access

      public

      [ Top ]

      TActiveRecordManager::getInvalidFinderResult

      getInvalidFinderResult( );

      Returns

      Defaults to 'Null'.

      see

      TActiveRecordManager::setInvalidFinderResult()

      since

      3.1.5

      access

      public

      [ Top ]

      TActiveRecordManager::getRecordGateway

      getRecordGateway( );

      Returns

      record gateway.

      access

      public

      [ Top ]

      TActiveRecordManager::setCache

      setCache( ICache $value );

      Parameters

      $value

      application cache

      access

      public

      [ Top ]

      TActiveRecordManager::setDbConnection

      setDbConnection( TDbConnection $conn );

      Parameters

      $conn

      default database connection

      access

      public

      [ Top ]

      TActiveRecordManager::setGatewayClass

      setGatewayClass( string $value );

      Parameters

      $value

      Remarks

      Set implementation class of ActiveRecordGateway

      access

      public

      [ Top ]

      TActiveRecordManager::setInvalidFinderResult

      setInvalidFinderResult( TActiveRecordInvalidFinderResult $value );

      Parameters

      $value

      Remarks

      Define the way an active record finder react if an invalid magic-finder invoked

      see

      TActiveRecordManager::getInvalidFinderResult()

      since

      3.1.5

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • DEFAULT_GATEWAY_CLASS =  'System.Data.ActiveRecord.TActiveRecordGateway' [line 40]

    Documentation generated on Mon, 25 Jun 2012 14:43:27 +0200 by phpDocumentor 1.4.3


Package System.Data.ActiveRecord.Relations Element Index

Element index for package System.Data.ActiveRecord.Relations

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
c f g h i p s t u _
top
_
__call in file TActiveRecordRelation.php, method TActiveRecordRelation::__call()
Dispatch the method calls to the source record finder object. When an instance of TActiveRecord or an array of TActiveRecord is returned the corresponding foreign objects are also fetched and assigned.
__construct | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::__construct()
__construct | in file TActiveRecordRelation.php, method TActiveRecordRelation::__construct()
top
c
collectForeignObjects | in file TActiveRecordRelation.php, method TActiveRecordRelation::collectForeignObjects()
collectForeignObjects in file TActiveRecordBelongsTo.php, method TActiveRecordBelongsTo::collectForeignObjects()
Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
collectForeignObjects in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::collectForeignObjects()
Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects using association table.
collectForeignObjects in file TActiveRecordHasMany.php, method TActiveRecordHasMany::collectForeignObjects()
Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
collectForeignObjects in file TActiveRecordHasOne.php, method TActiveRecordHasOne::collectForeignObjects()
Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
createCommand | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::createCommand()
createFkObject | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::createFkObject()
top
f
fetchForeignObjects in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::fetchForeignObjects()
Fetches the foreign objects using TActiveRecord::findAllByIndex()
fetchResultsInto in file TActiveRecordRelation.php, method TActiveRecordRelation::fetchResultsInto()
Fetch results for current relationship.
findForeignKeys in file TActiveRecordRelation.php, method TActiveRecordRelation::findForeignKeys()
Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value.
findForeignObjects in file TActiveRecordRelation.php, method TActiveRecordRelation::findForeignObjects()
Fetches the foreign objects using TActiveRecord::findAllByIndex()
top
g
getAssociationJoin in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getAssociationJoin()
SQL inner join for M-N relationship via association table.
getAssociationTable | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getAssociationTable()
getAssociationTable | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getAssociationTable()
getAssociationTableCommandBuilder | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getAssociationTableCommandBuilder()
getCommandBuilder | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getCommandBuilder()
getCondition | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getCondition()
getContext | in file TActiveRecordRelation.php, method TActiveRecordRelation::getContext()
getCriteria | in file TActiveRecordRelation.php, method TActiveRecordRelation::getCriteria()
getFkField | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getFkField()
getForeignCommandBuilder | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getForeignCommandBuilder()
getForeignRecordClass | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getForeignRecordClass()
getForeignRecordFinder | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getForeignRecordFinder()
getForeignTable | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getForeignTable()
getIndexValues in file TActiveRecordRelation.php, method TActiveRecordRelation::getIndexValues()
Obtain the foreign key index values from the results.
getObjectHash | in file TActiveRecordRelation.php, method TActiveRecordRelation::getObjectHash()
getParameters | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getParameters()
getProperty | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getProperty()
getPropertyValue | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getPropertyValue()
getRelationForeignKeys | in file TActiveRecordHasMany.php, method TActiveRecordHasMany::getRelationForeignKeys()
getRelationForeignKeys | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getRelationForeignKeys()
getRelationForeignKeys | in file TActiveRecordBelongsTo.php, method TActiveRecordBelongsTo::getRelationForeignKeys()
getRelationForeignKeys | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getRelationForeignKeys()
getRelationForeignKeys | in file TActiveRecordRelation.php, method TActiveRecordRelation::getRelationForeignKeys()
getRelationForeignKeys | in file TActiveRecordHasOne.php, method TActiveRecordHasOne::getRelationForeignKeys()
getRelationHandler in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getRelationHandler()
Creates and return the TActiveRecordRelation handler for specific relationships.
getRelationType | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getRelationType()
getSourceColumns | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getSourceColumns()
getSourceRecord | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getSourceRecord()
getSourceRecord | in file TActiveRecordRelation.php, method TActiveRecordRelation::getSourceRecord()
getSourceTable | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getSourceTable()
top
h
hasAssociationTable | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::hasAssociationTable()
hasFkField | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::hasFkField()
hasRecordRelation | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::hasRecordRelation()
top
i
isEmptyFkObject | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::isEmptyFkObject()
top
p
populateResult in file TActiveRecordRelation.php, method TActiveRecordRelation::populateResult()
Populate the results with the foreign objects found.
top
s
setObjectProperty in file TActiveRecordRelation.php, method TActiveRecordRelation::setObjectProperty()
Sets the foreign objects to the given property on the source object.
setObjectProperty in file TActiveRecordHasOne.php, method TActiveRecordHasOne::setObjectProperty()
Sets the foreign objects to the given property on the source object.
setObjectProperty in file TActiveRecordBelongsTo.php, method TActiveRecordBelongsTo::setObjectProperty()
Sets the foreign objects to the given property on the source object.
setResultCollection in file TActiveRecordRelation.php, method TActiveRecordRelation::setResultCollection()
Populates the result array with foreign objects (matched using foreign key hashed property values).
top
t
TActiveRecordBelongsTo.php | procedural page TActiveRecordBelongsTo.php
TActiveRecordHasMany.php | procedural page TActiveRecordHasMany.php
TActiveRecordHasManyAssociation.php | procedural page TActiveRecordHasManyAssociation.php
TActiveRecordHasOne.php | procedural page TActiveRecordHasOne.php
TActiveRecordRelation.php | procedural page TActiveRecordRelation.php
TActiveRecordRelationContext.php | procedural page TActiveRecordRelationContext.php
TActiveRecordBelongsTo in file TActiveRecordBelongsTo.php, class TActiveRecordBelongsTo
Implements the foreign key relationship (TActiveRecord::BELONGS_TO) between the source objects and the related foreign object. Consider the entity relationship between a Team and a Player.
TActiveRecordHasMany in file TActiveRecordHasMany.php, class TActiveRecordHasMany
Implements TActiveRecord::HAS_MANY relationship between the source object having zero or more foreign objects. Consider the entity relationship between a Team and a Player.
TActiveRecordHasManyAssociation in file TActiveRecordHasManyAssociation.php, class TActiveRecordHasManyAssociation
Implements the M-N (many to many) relationship via association table.
TActiveRecordHasOne in file TActiveRecordHasOne.php, class TActiveRecordHasOne
TActiveRecordHasOne models the object relationship that a record (the source object) property is an instance of foreign record object having a foreign key related to the source object. The HAS_ONE relation is very similar to the HAS_MANY relationship (in fact, it is equivalent in the entities relationship point of view).
TActiveRecordRelation in file TActiveRecordRelation.php, class TActiveRecordRelation
Base class for active record relationships.
TActiveRecordRelationContext in file TActiveRecordRelationContext.php, class TActiveRecordRelationContext
TActiveRecordRelationContext holds information regarding record relationships such as record relation property name, query criteria and foreign object record class names.
top
u
updateAssociatedRecords | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::updateAssociatedRecords()
updateAssociatedRecords in file TActiveRecordHasOne.php, method TActiveRecordHasOne::updateAssociatedRecords()
Updates the associated foreign objects.
updateAssociatedRecords in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::updateAssociatedRecords()
Updates the associated foreign objects.
updateAssociatedRecords in file TActiveRecordHasMany.php, method TActiveRecordHasMany::updateAssociatedRecords()
Updates the associated foreign objects.
updateAssociatedRecords in file TActiveRecordBelongsTo.php, method TActiveRecordBelongsTo::updateAssociatedRecords()
Updates the source object first.


Class Trees for Package System.Data.ActiveRecord.Relations

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRecordBelongsTo.php

File: /Data/ActiveRecord/Relations/TActiveRecordBelongsTo.php

Remarks

TActiveRecordBelongsTo class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRecordBelongsTo
Implements the foreign key relationship (TActiveRecord::BELONGS_TO) between the source objects and the related foreign object. Consider the entity relationship between a Team and a Player.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:25 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRecordHasMany.php

File: /Data/ActiveRecord/Relations/TActiveRecordHasMany.php

Remarks

TActiveRecordHasMany class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRecordHasMany
Implements TActiveRecord::HAS_MANY relationship between the source object having zero or more foreign objects. Consider the entity relationship between a Team and a Player.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:26 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRecordHasManyAssociation.php

File: /Data/ActiveRecord/Relations/TActiveRecordHasManyAssociation.php

Remarks

TActiveRecordHasManyAssociation class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRecordHasManyAssociation
Implements the M-N (many to many) relationship via association table.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:26 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRecordHasOne.php

File: /Data/ActiveRecord/Relations/TActiveRecordHasOne.php

Remarks

TActiveRecordHasOne class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRecordHasOne
TActiveRecordHasOne models the object relationship that a record (the source object) property is an instance of foreign record object having a foreign key related to the source object. The HAS_ONE relation is very similar to the HAS_MANY relationship (in fact, it is equivalent in the entities relationship point of view).

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:27 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRecordRelation.php

File: /Data/ActiveRecord/Relations/TActiveRecordRelation.php

Remarks

TActiveRecordRelation class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRecordRelation
Base class for active record relationships.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:27 +0200 by phpDocumentor 1.4.3


Docs for page TActiveRecordRelationContext.php

File: /Data/ActiveRecord/Relations/TActiveRecordRelationContext.php

Remarks

TActiveRecordRelationContext class.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TActiveRecordRelationContext
TActiveRecordRelationContext holds information regarding record relationships such as record relation property name, query criteria and foreign object record class names.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:27 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordBelongsTo

Class TActiveRecordBelongsTo

[line 71]
TActiveRecordRelation
   |
   --TActiveRecordBelongsTo
Location: /Data/ActiveRecord/Relations/TActiveRecordBelongsTo.php

Remarks

Implements the foreign key relationship (TActiveRecord::BELONGS_TO) between the source objects and the related foreign object. Consider the entity relationship between a Team and a Player.

  •  +------+            +--------+
    •

  •  | Team | 1 <----- * | Player |
    •

  •  +------+            +--------+
    •
    Where one team may have 0 or more players and each player belongs to only one team. We may model Team-Player object relationship as active record as follows.
  •  class TeamRecord extends TActiveRecord
    •

  •  {
    •

  •      // see TActiveRecordHasMany for detailed definition.
    •

  •  }
    •

  •  class PlayerRecord extends TActiveRecord
    •

  •  {
    •

  •      const TABLE='player';
    •

  •      public $player_id; //primary key
    •

  •      public $team_name; //foreign key player.team_name <-> team.name
    •

  •         public $age;
    •

  •      public $team; //foreign object TeamRecord
    •

  •
    •

  •      public static $RELATIONS = array
    •

  •      (
    •

  •             'team' => array(self::BELONGS_TO, 'TeamRecord')
    •

  •      );
    •

  •
    •

  •        public static function finder($className=__CLASS__)
    •

  •        {
    •

  •            return parent::finder($className);
    •

  •        }
    •

  •  }
    •
    The static <tt>$RELATIONS</tt> property of PlayerRecord defines that the property <tt>$team</tt> belongs to a <tt>TeamRecord</tt>.

    The team object may be fetched as follows.

  •  $players = PlayerRecord::finder()->with_team()->findAll();
    •
    The method <tt>with_xxx()</tt> (where <tt>xxx</tt> is the relationship property name, in this case, <tt>team</tt>) fetchs the corresponding TeamRecords using a second query (not by using a join). The <tt>with_xxx()</tt> accepts the same arguments as other finder methods of TActiveRecord, e.g. <tt>with_team('location = ?', 'Madrid')</tt>.

    author

    Wei Zhuo <weizho[at]gmail[dot]com>

    version

    $Id$

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TActiveRecordRelation

    • TActiveRecordRelation::__construct()
    • TActiveRecordRelation::collectForeignObjects()
    • TActiveRecordRelation::fetchResultsInto()
      Fetch results for current relationship.
    • TActiveRecordRelation::findForeignKeys()
      Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value.
    • TActiveRecordRelation::findForeignObjects()
      Fetches the foreign objects using TActiveRecord::findAllByIndex()
    • TActiveRecordRelation::getContext()
    • TActiveRecordRelation::getCriteria()
    • TActiveRecordRelation::getIndexValues()
      Obtain the foreign key index values from the results.
    • TActiveRecordRelation::getObjectHash()
    • TActiveRecordRelation::getRelationForeignKeys()
    • TActiveRecordRelation::getSourceRecord()
    • TActiveRecordRelation::populateResult()
      Populate the results with the foreign objects found.
    • TActiveRecordRelation::setObjectProperty()
      Sets the foreign objects to the given property on the source object.
    • TActiveRecordRelation::setResultCollection()
      Populates the result array with foreign objects (matched using foreign key hashed property values).
    • TActiveRecordRelation::__call()
      Dispatch the method calls to the source record finder object. When an instance of TActiveRecord or an array of TActiveRecord is returned the corresponding foreign objects are also fetched and assigned.

    Method Detail

      TActiveRecordBelongsTo::collectForeignObjects

      collectForeignObjects( array &$results );

      Overrides TActiveRecordRelation::collectForeignObjects() (parent method not documented)

      Parameters

      &$results

      original results.

      Remarks

      Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.

      access

      protected

      [ Top ]

      TActiveRecordBelongsTo::getRelationForeignKeys

      getRelationForeignKeys( );

      Overrides TActiveRecordRelation::getRelationForeignKeys() (parent method not documented)

      Returns

      foreign key field names as key and object properties as value.

      since

      3.1.2

      access

      public

      [ Top ]

      TActiveRecordBelongsTo::setObjectProperty

      setObjectProperty( TActiveRecord $source, array $properties, &$collections );

      Overrides TActiveRecordRelation::setObjectProperty() (Sets the foreign objects to the given property on the source object.)

      Parameters

      $source

      source object.

      $properties

      foreign objects.

      &$collections

      Remarks

      Sets the foreign objects to the given property on the source object.

      access

      protected

      [ Top ]

      TActiveRecordBelongsTo::updateAssociatedRecords

      updateAssociatedRecords( );

      Returns

      true if all update are success (including if no update was required), false otherwise .

      Remarks

      Updates the source object first.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:25 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordHasMany

Class TActiveRecordHasMany

[line 69]
TActiveRecordRelation
   |
   --TActiveRecordHasMany
Location: /Data/ActiveRecord/Relations/TActiveRecordHasMany.php

Remarks

Implements TActiveRecord::HAS_MANY relationship between the source object having zero or more foreign objects. Consider the entity relationship between a Team and a Player.

  •  +------+            +--------+
    •

  •  | Team | 1 <----- * | Player |
    •

  •  +------+            +--------+
    •
    Where one team may have 0 or more players and each player belongs to only one team. We may model Team-Player object relationship as active record as follows.
  •  class TeamRecord extends TActiveRecord
    •

  •  {
    •

  •      const TABLE='team';
    •

  •      public $name; //primary key
    •

  •      public $location;
    •

  •
    •

  •      public $players=array(); //list of players
    •

  •
    •

  •      public static $RELATIONS=array
    •

  •      (
    •

  •          'players' => array(self::HAS_MANY, 'PlayerRecord')
    •

  •      );
    •

  •
    •

  •        public static function finder($className=__CLASS__)
    •

  •        {
    •

  •            return parent::finder($className);
    •

  •        }
    •

  •  }
    •

  •  class PlayerRecord extends TActiveRecord
    •

  •  {
    •

  •      // see TActiveRecordBelongsTo for detailed definition
    •

  •  }
    •
    The static <tt>$RELATIONS</tt> property of TeamRecord defines that the property <tt>$players</tt> has many <tt>PlayerRecord</tt>s.

    The players list may be fetched as follows.

  •  $team = TeamRecord::finder()->with_players()->findAll();
    •
    The method <tt>with_xxx()</tt> (where <tt>xxx</tt> is the relationship property name, in this case, <tt>players</tt>) fetchs the corresponding PlayerRecords using a second query (not by using a join). The <tt>with_xxx()</tt> accepts the same arguments as other finder methods of TActiveRecord, e.g. <tt>with_players('age < ?', 35)</tt>.

    author

    Wei Zhuo <weizho[at]gmail[dot]com>

    version

    $Id$

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TActiveRecordRelation

    • TActiveRecordRelation::__construct()
    • TActiveRecordRelation::collectForeignObjects()
    • TActiveRecordRelation::fetchResultsInto()
      Fetch results for current relationship.
    • TActiveRecordRelation::findForeignKeys()
      Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value.
    • TActiveRecordRelation::findForeignObjects()
      Fetches the foreign objects using TActiveRecord::findAllByIndex()
    • TActiveRecordRelation::getContext()
    • TActiveRecordRelation::getCriteria()
    • TActiveRecordRelation::getIndexValues()
      Obtain the foreign key index values from the results.
    • TActiveRecordRelation::getObjectHash()
    • TActiveRecordRelation::getRelationForeignKeys()
    • TActiveRecordRelation::getSourceRecord()
    • TActiveRecordRelation::populateResult()
      Populate the results with the foreign objects found.
    • TActiveRecordRelation::setObjectProperty()
      Sets the foreign objects to the given property on the source object.
    • TActiveRecordRelation::setResultCollection()
      Populates the result array with foreign objects (matched using foreign key hashed property values).
    • TActiveRecordRelation::__call()
      Dispatch the method calls to the source record finder object. When an instance of TActiveRecord or an array of TActiveRecord is returned the corresponding foreign objects are also fetched and assigned.

    Method Detail

      TActiveRecordHasMany::collectForeignObjects

      collectForeignObjects( array &$results );

      Overrides TActiveRecordRelation::collectForeignObjects() (parent method not documented)

      Parameters

      &$results

      original results.

      Remarks

      Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.

      access

      protected

      [ Top ]

      TActiveRecordHasMany::getRelationForeignKeys

      getRelationForeignKeys( );

      Overrides TActiveRecordRelation::getRelationForeignKeys() (parent method not documented)

      Returns

      foreign key field names as key and object properties as value.

      since

      3.1.2

      access

      public

      [ Top ]

      TActiveRecordHasMany::updateAssociatedRecords

      updateAssociatedRecords( );

      Returns

      true if all update are success (including if no update was required), false otherwise .

      Remarks

      Updates the associated foreign objects.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:26 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordHasManyAssociation

Class TActiveRecordHasManyAssociation

[line 85]
TActiveRecordRelation
   |
   --TActiveRecordHasManyAssociation
Location: /Data/ActiveRecord/Relations/TActiveRecordHasManyAssociation.php

Remarks

Implements the M-N (many to many) relationship via association table.

Consider the entity relationship between Articles and Categories via the association table <tt>Article_Category</tt>.

  •  +---------+            +------------------+            +----------+
    •

  •  | Article | * -----> * | Article_Category | * <----- * | Category |
    •

  •  +---------+            +------------------+            +----------+
    •
    Where one article may have 0 or more categories and each category may have 0 or more articles. We may model Article-Category object relationship as active record as follows.
  •  class ArticleRecord
    •

  •  {
    •

  •      const TABLE='Article';
    •

  •      public $article_id;
    •

  •
    •

  •      public $Categories=array(); //foreign object collection.
    •

  •
    •

  •      public static $RELATIONS = array
    •

  •      (
    •

  •          'Categories' => array(self::MANY_TO_MANY, 'CategoryRecord', 'Article_Category')
    •

  •      );
    •

  •
    •

  •      public static function finder($className=__CLASS__)
    •

  •      {
    •

  •          return parent::finder($className);
    •

  •      }
    •

  •  }
    •

  •  class CategoryRecord
    •

  •  {
    •

  •      const TABLE='Category';
    •

  •      public $category_id;
    •

  •
    •

  •      public $Articles=array();
    •

  •
    •

  •      public static $RELATIONS = array
    •

  •      (
    •

  •          'Articles' => array(self::MANY_TO_MANY, 'ArticleRecord', 'Article_Category')
    •

  •      );
    •

  •
    •

  •      public static function finder($className=__CLASS__)
    •

  •      {
    •

  •          return parent::finder($className);
    •

  •      }
    •

  •  }
    •

    The static <tt>$RELATIONS</tt> property of ArticleRecord defines that the property <tt>$Categories</tt> has many <tt>CategoryRecord</tt>s. Similar, the static <tt>$RELATIONS</tt> property of CategoryRecord defines many ArticleRecords.

    The articles with categories list may be fetched as follows.

  •  $articles = TeamRecord::finder()->withCategories()->findAll();
    •
    The method <tt>with_xxx()</tt> (where <tt>xxx</tt> is the relationship property name, in this case, <tt>Categories</tt>) fetchs the corresponding CategoryRecords using a second query (not by using a join). The <tt>with_xxx()</tt> accepts the same arguments as other finder methods of TActiveRecord.

    author

    Wei Zhuo <weizho[at]gmail[dot]com>

    version

    $Id$

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TActiveRecordRelation

    • TActiveRecordRelation::__construct()
    • TActiveRecordRelation::collectForeignObjects()
    • TActiveRecordRelation::fetchResultsInto()
      Fetch results for current relationship.
    • TActiveRecordRelation::findForeignKeys()
      Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value.
    • TActiveRecordRelation::findForeignObjects()
      Fetches the foreign objects using TActiveRecord::findAllByIndex()
    • TActiveRecordRelation::getContext()
    • TActiveRecordRelation::getCriteria()
    • TActiveRecordRelation::getIndexValues()
      Obtain the foreign key index values from the results.
    • TActiveRecordRelation::getObjectHash()
    • TActiveRecordRelation::getRelationForeignKeys()
    • TActiveRecordRelation::getSourceRecord()
    • TActiveRecordRelation::populateResult()
      Populate the results with the foreign objects found.
    • TActiveRecordRelation::setObjectProperty()
      Sets the foreign objects to the given property on the source object.
    • TActiveRecordRelation::setResultCollection()
      Populates the result array with foreign objects (matched using foreign key hashed property values).
    • TActiveRecordRelation::__call()
      Dispatch the method calls to the source record finder object. When an instance of TActiveRecord or an array of TActiveRecord is returned the corresponding foreign objects are also fetched and assigned.

    Method Detail

      TActiveRecordHasManyAssociation::collectForeignObjects

      collectForeignObjects( array &$results );

      Overrides TActiveRecordRelation::collectForeignObjects() (parent method not documented)

      Parameters

      &$results

      original results.

      Remarks

      Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects using association table.

      access

      protected

      [ Top ]

      TActiveRecordHasManyAssociation::createCommand

      createCommand( TSqlCriteria $criteria, TTableInfo $foreignKeys, array $indexValues, array $sourceKeys );

      Parameters

      $criteria

      $foreignKeys

      association table info

      $indexValues

      field names

      $sourceKeys

      field values

      access

      public

      [ Top ]

      TActiveRecordHasManyAssociation::createFkObject

      createFkObject( string $type, array $row, array $foreignKeys );

      Parameters

      $type

      active record class name.

      $row

      row data

      $foreignKeys

      foreign key column names

      access

      protected

      [ Top ]

      TActiveRecordHasManyAssociation::fetchForeignObjects

      fetchForeignObjects( array &$results, array $foreignKeys, $indexValues, $sourceKeys );

      Parameters

      &$results

      field names

      $foreignKeys

      foreign key index values.

      $indexValues

      $sourceKeys

      Remarks

      Fetches the foreign objects using TActiveRecord::findAllByIndex()

      access

      protected

      [ Top ]

      TActiveRecordHasManyAssociation::getAssociationJoin

      getAssociationJoin( array $foreignKeys, array $indexValues, array $sourceKeys );

      Parameters

      $foreignKeys

      foreign table column key names.

      $indexValues

      source table index values.

      $sourceKeys

      source table column names.

      Returns

      inner join condition for M-N relationship via association table.

      Remarks

      SQL inner join for M-N relationship via association table.

      access

      protected

      [ Top ]

      TActiveRecordHasManyAssociation::getAssociationTable

      getAssociationTable( );

      Returns

      association table information.

      access

      protected

      [ Top ]

      TActiveRecordHasManyAssociation::getAssociationTableCommandBuilder

      getAssociationTableCommandBuilder( );

      access

      protected

      [ Top ]

      TActiveRecordHasManyAssociation::getCommandBuilder

      getCommandBuilder( );

      access

      protected

      [ Top ]

      TActiveRecordHasManyAssociation::getForeignCommandBuilder

      getForeignCommandBuilder( );

      access

      protected

      [ Top ]

      TActiveRecordHasManyAssociation::getForeignTable

      getForeignTable( );

      Returns

      foreign table information.

      access

      protected

      [ Top ]

      TActiveRecordHasManyAssociation::getRelationForeignKeys

      getRelationForeignKeys( );

      Overrides TActiveRecordRelation::getRelationForeignKeys() (parent method not documented)

      Returns

      2 arrays of source keys and foreign keys from the association table.

      access

      public

      [ Top ]

      TActiveRecordHasManyAssociation::getSourceColumns

      getSourceColumns( array $sourceKeys );

      Parameters

      $sourceKeys

      source table column names.

      Returns

      comma separated source column names.

      access

      protected

      [ Top ]

      TActiveRecordHasManyAssociation::getSourceTable

      getSourceTable( );

      Returns

      source table information.

      access

      protected

      [ Top ]

      TActiveRecordHasManyAssociation::updateAssociatedRecords

      updateAssociatedRecords( );

      Returns

      true if all update are success (including if no update was required), false otherwise .

      Remarks

      Updates the associated foreign objects.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:26 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordHasOne

Class TActiveRecordHasOne

[line 86]
TActiveRecordRelation
   |
   --TActiveRecordHasOne
Location: /Data/ActiveRecord/Relations/TActiveRecordHasOne.php

Remarks

TActiveRecordHasOne models the object relationship that a record (the source object) property is an instance of foreign record object having a foreign key related to the source object. The HAS_ONE relation is very similar to the HAS_MANY relationship (in fact, it is equivalent in the entities relationship point of view).

The difference of HAS_ONE from HAS_MANY is that the foreign object is singular. That is, HAS_MANY will return a collection of records while HAS_ONE returns the corresponding record.

Consider the entity relationship between a Car and a Engine.

  •  +-----+            +--------+
    •

  •  | Car | 1 <----- 1 | Engine |
    •

  •  +-----+            +--------+
    •
    Where each engine belongs to only one car, that is, the Engine entity has a foreign key to the Car's primary key. We may model Engine-Car object relationship as active record as follows.
  •  class CarRecord extends TActiveRecord
    •

  •  {
    •

  •      const TABLE='car';
    •

  •      public $car_id; //primary key
    •

  •      public $colour;
    •

  •
    •

  •      public $engine; //engine foreign object
    •

  •
    •

  •      public static $RELATIONS=array
    •

  •      (
    •

  •          'engine' => array(self::HAS_ONE, 'EngineRecord')
    •

  •      );
    •

  •
    •

  •        public static function finder($className=__CLASS__)
    •

  •        {
    •

  •            return parent::finder($className);
    •

  •        }
    •

  •  }
    •

  •  class EngineRecord extends TActiveRecord
    •

  •  {
    •

  •      const TABLE='engine';
    •

  •      public $engine_id;
    •

  •      public $capacity;
    •

  •      public $car_id; //foreign key to cars
    •

  •
    •

  •        public static function finder($className=__CLASS__)
    •

  •        {
    •

  •            return parent::finder($className);
    •

  •        }
    •

  •  }
    •
    The static <tt>$RELATIONS</tt> property of CarRecord defines that the property <tt>$engine</tt> that will reference an <tt>EngineRecord</tt> instance.

    The car record with engine property list may be fetched as follows.

  •  $cars = CarRecord::finder()->with_engine()->findAll();
    •
    The method <tt>with_xxx()</tt> (where <tt>xxx</tt> is the relationship property name, in this case, <tt>engine</tt>) fetchs the corresponding EngineRecords using a second query (not by using a join). The <tt>with_xxx()</tt> accepts the same arguments as other finder methods of TActiveRecord, e.g. <tt>with_engine('capacity < ?', 3.8)</tt>.

    author

    Wei Zhuo <weizho[at]gmail[dot]com>

    version

    $Id$

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TActiveRecordRelation

    • TActiveRecordRelation::__construct()
    • TActiveRecordRelation::collectForeignObjects()
    • TActiveRecordRelation::fetchResultsInto()
      Fetch results for current relationship.
    • TActiveRecordRelation::findForeignKeys()
      Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value.
    • TActiveRecordRelation::findForeignObjects()
      Fetches the foreign objects using TActiveRecord::findAllByIndex()
    • TActiveRecordRelation::getContext()
    • TActiveRecordRelation::getCriteria()
    • TActiveRecordRelation::getIndexValues()
      Obtain the foreign key index values from the results.
    • TActiveRecordRelation::getObjectHash()
    • TActiveRecordRelation::getRelationForeignKeys()
    • TActiveRecordRelation::getSourceRecord()
    • TActiveRecordRelation::populateResult()
      Populate the results with the foreign objects found.
    • TActiveRecordRelation::setObjectProperty()
      Sets the foreign objects to the given property on the source object.
    • TActiveRecordRelation::setResultCollection()
      Populates the result array with foreign objects (matched using foreign key hashed property values).
    • TActiveRecordRelation::__call()
      Dispatch the method calls to the source record finder object. When an instance of TActiveRecord or an array of TActiveRecord is returned the corresponding foreign objects are also fetched and assigned.

    Method Detail

      TActiveRecordHasOne::collectForeignObjects

      collectForeignObjects( array &$results );

      Overrides TActiveRecordRelation::collectForeignObjects() (parent method not documented)

      Parameters

      &$results

      original results.

      Remarks

      Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.

      access

      protected

      [ Top ]

      TActiveRecordHasOne::getRelationForeignKeys

      getRelationForeignKeys( );

      Overrides TActiveRecordRelation::getRelationForeignKeys() (parent method not documented)

      Returns

      foreign key field names as key and object properties as value.

      since

      3.1.2

      access

      public

      [ Top ]

      TActiveRecordHasOne::setObjectProperty

      setObjectProperty( TActiveRecord $source, array $properties, &$collections );

      Overrides TActiveRecordRelation::setObjectProperty() (Sets the foreign objects to the given property on the source object.)

      Parameters

      $source

      source object.

      $properties

      foreign objects.

      &$collections

      Remarks

      Sets the foreign objects to the given property on the source object.

      access

      protected

      [ Top ]

      TActiveRecordHasOne::updateAssociatedRecords

      updateAssociatedRecords( );

      Returns

      true if all update are success (including if no update was required), false otherwise .

      Remarks

      Updates the associated foreign objects.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:27 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordRelation

Class TActiveRecordRelation

[line 26]

Classes extended from TActiveRecordRelation:

TActiveRecordBelongsTo

Implements the foreign key relationship (TActiveRecord::BELONGS_TO) between  the source objects and the related foreign object. Consider the  entity relationship between a Team and a Player.

TActiveRecordHasMany

Implements TActiveRecord::HAS_MANY relationship between the source object having zero or  more foreign objects. Consider the entity relationship between a Team and a Player.

TActiveRecordHasManyAssociation

Implements the M-N (many to many) relationship via association table.

TActiveRecordHasOne

TActiveRecordHasOne models the object relationship that a record (the source object)  property is an instance of foreign record object having a foreign key  related to the source object. The HAS_ONE relation is very similar to the  HAS_MANY relationship (in fact, it is equivalent in the entities relationship point of view).

Location: /Data/ActiveRecord/Relations/TActiveRecordRelation.php

Remarks

Base class for active record relationships.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id$

abstract

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TActiveRecordRelation::__construct

__construct(
TActiveRecordRelationContext
$context,
$criteria );

    Parameters

    $context

    $criteria

    access

    public

    [ Top ]

    TActiveRecordRelation::collectForeignObjects

collectForeignObjects(

&$results );

    Overridden in child classes as:

    TActiveRecordBelongsTo::collectForeignObjects()

    Get the foreign key index values from the results and make calls to the  database to find the corresponding foreign objects.

    TActiveRecordHasMany::collectForeignObjects()

    Get the foreign key index values from the results and make calls to the  database to find the corresponding foreign objects.

    TActiveRecordHasManyAssociation::collectForeignObjects()

    Get the foreign key index values from the results and make calls to the  database to find the corresponding foreign objects using association table.

    TActiveRecordHasOne::collectForeignObjects()

    Get the foreign key index values from the results and make calls to the  database to find the corresponding foreign objects.

    Parameters

    &$results

    abstract

    access

    protected

    [ Top ]

    TActiveRecordRelation::fetchResultsInto

fetchResultsInto(

$obj );

    Parameters

    $obj

    Returns

    always true.

    Remarks

    Fetch results for current relationship.

    access

    public

    [ Top ]

    TActiveRecordRelation::findForeignKeys

findForeignKeys(

$from, TActiveRecord
$matchesRecord, [
$loose = false], TActiveRecord
$fromRecord );

    Parameters

    $fromRecord

    $matchesRecord

    $from

    $loose

    Returns

    foreign keys with source column names as key and foreign column names as value.

    Remarks

    Returns foreign keys in $fromRecord with source column names as key  and foreign column names in the corresponding $matchesRecord as value.

    The method returns the first matching foreign key between these 2 records.

    access

    protected

    [ Top ]

    TActiveRecordRelation::findForeignObjects

findForeignObjects(
array
$fields, array
$indexValues );

    Parameters

    $fields

    field names

    $indexValues

    foreign key index values.

    Returns

    foreign objects.

    Remarks

    Fetches the foreign objects using TActiveRecord::findAllByIndex()

    access

    protected

    [ Top ]

    TActiveRecordRelation::getContext

getContext(
 );

    access

    protected

    [ Top ]

    TActiveRecordRelation::getCriteria

getCriteria(
 );

    access

    protected

    [ Top ]

    TActiveRecordRelation::getIndexValues

getIndexValues(
array
$keys, array
$results );

    Parameters

    $keys

    property names

    $results

    TActiveRecord results

    Returns

    foreign key index values.

    Remarks

    Obtain the foreign key index values from the results.

    access

    protected

    [ Top ]

    TActiveRecordRelation::getObjectHash

getObjectHash(
mixed
$obj, array
$properties );

    Parameters

    $obj

    object or array to be hashed

    $properties

    name of property for hashing the properties.

    Returns

    object hash using crc32 and serialize.

    access

    protected

    [ Top ]

    TActiveRecordRelation::getRelationForeignKeys

getRelationForeignKeys(
 );

    Overridden in child classes as:

    TActiveRecordBelongsTo::getRelationForeignKeys()

    TActiveRecordHasMany::getRelationForeignKeys()

    TActiveRecordHasManyAssociation::getRelationForeignKeys()

    TActiveRecordHasOne::getRelationForeignKeys()

    Returns

    foreign key field names as key and object properties as value.

    abstract

    since

    3.1.2

    access

    public

    [ Top ]

    TActiveRecordRelation::getSourceRecord

getSourceRecord(
 );

    access

    protected

    [ Top ]

    TActiveRecordRelation::populateResult

populateResult(
array
&$results, array
$properties, array
&$fkObjects, array
$fields );

    Parameters

    &$results

    source results

    $properties

    source property names

    &$fkObjects

    foreign objects

    $fields

    foreign object field names.

    Remarks

    Populate the results with the foreign objects found.

    access

    protected

    [ Top ]

    TActiveRecordRelation::setObjectProperty

setObjectProperty(
TActiveRecord
$source, array
$properties, array
&$collections );

    Overridden in child classes as:

    TActiveRecordBelongsTo::setObjectProperty()

    Sets the foreign objects to the given property on the source object.

    TActiveRecordHasOne::setObjectProperty()

    Sets the foreign objects to the given property on the source object.

    Parameters

    $source

    source object.

    $properties

    source properties

    &$collections

    foreign objects.

    Remarks

    Sets the foreign objects to the given property on the source object.

    access

    protected

    [ Top ]

    TActiveRecordRelation::setResultCollection

setResultCollection(

&$results,
&$collections, array
$properties, array
$results, array
$collections );

    Parameters

    $results

    $collections

    $properties

    property names

    &$results

    &$collections

    Remarks

    Populates the result array with foreign objects (matched using foreign key hashed property values).

    access

    protected

    [ Top ]

    TActiveRecordRelation::__call

__call(
string
$method, array
$args );

    Parameters

    $method

    method name called

    $args

    method arguments

    Returns

    TActiveRecord or array of TActiveRecord results depending on the method called.

    Remarks

    Dispatch the method calls to the source record finder object. When  an instance of TActiveRecord or an array of TActiveRecord is returned  the corresponding foreign objects are also fetched and assigned.

    Multiple relationship calls can be chain together.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:27 +0200 by phpDocumentor 1.4.3


Docs For Class TActiveRecordRelationContext

Class TActiveRecordRelationContext

[line 26]

Location: /Data/ActiveRecord/Relations/TActiveRecordRelationContext.php

Remarks

TActiveRecordRelationContext holds information regarding record relationships  such as record relation property name, query criteria and foreign object record  class names.

This class is use internally by passing a context to the TActiveRecordRelation  constructor.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id$

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TActiveRecordRelationContext::__construct

__construct(

$record, [
$property = null], [
$relation = null] );

    Parameters

    $record

    $property

    $relation

    access

    public

    [ Top ]

    TActiveRecordRelationContext::getAssociationTable

getAssociationTable(
 );

    Returns

    the M-N relationship association table name.

    access

    public

    [ Top ]

    TActiveRecordRelationContext::getCondition

getCondition(
 );

    Returns

    the query condition for the relation as specified in RELATIONS

    since

    3.1.2

    access

    public

    [ Top ]

    TActiveRecordRelationContext::getFkField

getFkField(
 );

    Returns

    foreign key field names, comma delimited.

    since

    3.1.2

    access

    public

    [ Top ]

    TActiveRecordRelationContext::getForeignRecordClass

getForeignRecordClass(
 );

    Returns

    foreign record class name.

    access

    public

    [ Top ]

    TActiveRecordRelationContext::getForeignRecordFinder

getForeignRecordFinder(
 );

    Returns

    corresponding relationship foreign object finder instance.

    access

    public

    [ Top ]

    TActiveRecordRelationContext::getParameters

getParameters(
 );

    Returns

    the query parameters for the relation as specified in RELATIONS

    since

    3.1.2

    access

    public

    [ Top ]

    TActiveRecordRelationContext::getProperty

getProperty(
 );

    Returns

    name of the record property that the relationship results will be assigned to.

    access

    public

    [ Top ]

    TActiveRecordRelationContext::getPropertyValue

getPropertyValue(
 );

    access

    public

    [ Top ]

    TActiveRecordRelationContext::getRelationForeignKeys

getRelationForeignKeys(
 );

    Returns

    foreign key of this relations, the keys is dependent on the  relationship type.

    since

    3.1.2

    access

    public

    [ Top ]

    TActiveRecordRelationContext::getRelationHandler

getRelationHandler(
[TActiveRecordCriteria
$criteria = null] );

    Parameters

    $criteria

    search criteria

    Returns

    record relationship handler instnace.

    Remarks

    Creates and return the TActiveRecordRelation handler for specific relationships.

    An instance of TActiveRecordHasOne, TActiveRecordBelongsTo, TActiveRecordHasMany,  or TActiveRecordHasManyAssocation will be returned.

    throws

    TActiveRecordException if property is not defined or missing.

    access

    public

    [ Top ]

    TActiveRecordRelationContext::getRelationType

getRelationType(
 );

    Returns

    HAS_MANY, HAS_ONE, or BELONGS_TO

    access

    public

    [ Top ]

    TActiveRecordRelationContext::getSourceRecord

getSourceRecord(
 );

    Returns

    the active record instance that queried for its related records.

    access

    public

    [ Top ]

    TActiveRecordRelationContext::hasAssociationTable

hasAssociationTable(
 );

    Returns

    true if the relationship is HAS_MANY and requires an association table.

    access

    public

    [ Top ]

    TActiveRecordRelationContext::hasFkField

hasFkField(
 );

    Returns

    true if the 3rd element of an TActiveRecord::$RELATION entry is set.

    since

    3.1.2

    access

    public

    [ Top ]

    TActiveRecordRelationContext::hasRecordRelation

hasRecordRelation(
 );

    Returns

    true if the relation is defined in TActiveRecord::$RELATIONS

    since

    3.1.2

    access

    public

    [ Top ]

    TActiveRecordRelationContext::isEmptyFkObject

isEmptyFkObject(

$obj );

    Parameters

    $obj

    access

    protected

    [ Top ]

    TActiveRecordRelationContext::updateAssociatedRecords

updateAssociatedRecords(
[
$updateBelongsTo = false] );

    Parameters

    $updateBelongsTo

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:27 +0200 by phpDocumentor 1.4.3


Package System.Caching Element Index

Element index for package System.Caching

Indexes by package:
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a c d f g i o s t v _
top
_
__construct in file TCache.php, method TDirectoryCacheDependency::__construct()
Constructor.
__construct in file TCache.php, method TGlobalStateCacheDependency::__construct()
Constructor.
__construct in file TCache.php, method TFileCacheDependency::__construct()
Constructor.
__destruct in file TSqliteCache.php, method TSqliteCache::__destruct()
Destructor.
__destruct in file TDbCache.php, method TDbCache::__destruct()
Destructor.
__destruct in file TMemCache.php, method TMemCache::__destruct()
Destructor.
top
a
add in file TCache.php, method TCache::add()
Stores a value identified by a key into cache if the cache does not contain this key.
addValue in file TSqliteCache.php, method TSqliteCache::addValue()
Stores a value identified by a key into cache if the cache does not contain this key.
addValue in file TXCache.php, method TXCache::addValue()
Stores a value identified by a key into cache if the cache does not contain this key.
addValue in file TMemCache.php, method TMemCache::addValue()
Stores a value identified by a key into cache if the cache does not contain this key.
addValue in file TDbCache.php, method TDbCache::addValue()
Stores a value identified by a key into cache if the cache does not contain this key.
addValue in file TCache.php, method TCache::addValue()
Stores a value identified by a key into cache if the cache does not contain this key.
addValue in file TAPCCache.php, method TAPCCache::addValue()
Stores a value identified by a key into cache if the cache does not contain this key.
top
c
CACHE_TABLE in file TSqliteCache.php, class constant TSqliteCache::CACHE_TABLE
name of the table storing cache data
createDbConnection in file TDbCache.php, method TDbCache::createDbConnection()
Creates the DB connection.
top
d
DB_FILE_EXT in file TSqliteCache.php, class constant TSqliteCache::DB_FILE_EXT
extension of the db file name
delete in file TCache.php, method TCache::delete()
Deletes a value with the specified key from cache
deleteValue in file TMemCache.php, method TMemCache::deleteValue()
Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
deleteValue in file TXCache.php, method TXCache::deleteValue()
Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
deleteValue in file TDbCache.php, method TDbCache::deleteValue()
Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
deleteValue in file TCache.php, method TCache::deleteValue()
Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.
deleteValue in file TSqliteCache.php, method TSqliteCache::deleteValue()
Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
deleteValue in file TAPCCache.php, method TAPCCache::deleteValue()
Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
doFlushCacheExpired in file TDbCache.php, method TDbCache::doFlushCacheExpired()
Event listener for TApplication.OnSaveState
doInitializeCache in file TDbCache.php, method TDbCache::doInitializeCache()
Event listener for TApplication.OnLoadStateComplete
top
f
flush in file TMemCache.php, method TMemCache::flush()
Deletes all values from cache.
flush in file TSqliteCache.php, method TSqliteCache::flush()
Deletes all values from cache.
flush in file TAPCCache.php, method TAPCCache::flush()
Deletes all values from cache.
flush in file TDbCache.php, method TDbCache::flush()
Deletes all values from cache.
flush in file TCache.php, method TCache::flush()
Deletes all values from cache.
flush in file TXCache.php, method TXCache::flush()
Deletes all values from cache.
flushCacheExpired in file TDbCache.php, method TDbCache::flushCacheExpired()
Flush expired values from cache depending on setFlushInterval
top
g
generateTimestamps in file TCache.php, method TDirectoryCacheDependency::generateTimestamps()
Determines the last modification time for files under the directory.
generateUniqueKey | in file TCache.php, method TCache::generateUniqueKey()
get in file TCache.php, method TCache::get()
Retrieves a value from cache with a specified key.
getAutoCreateCacheTable | in file TDbCache.php, method TDbCache::getAutoCreateCacheTable()
getCacheTableName | in file TDbCache.php, method TDbCache::getCacheTableName()
getConnectionID | in file TDbCache.php, method TDbCache::getConnectionID()
getConnectionString | in file TDbCache.php, method TDbCache::getConnectionString()
getDbConnection | in file TDbCache.php, method TDbCache::getDbConnection()
getDbFile | in file TSqliteCache.php, method TSqliteCache::getDbFile()
getDependencies | in file TCache.php, method TChainedCacheDependency::getDependencies()
getDirectory | in file TCache.php, method TDirectoryCacheDependency::getDirectory()
getFileName | in file TCache.php, method TFileCacheDependency::getFileName()
getFlushInterval | in file TDbCache.php, method TDbCache::getFlushInterval()
getHasChanged in file TCache.php, method TFileCacheDependency::getHasChanged()
Performs the actual dependency checking.
getHasChanged in file TCache.php, method TGlobalStateCacheDependency::getHasChanged()
Performs the actual dependency checking.
getHasChanged in file TCache.php, method TDirectoryCacheDependency::getHasChanged()
Performs the actual dependency checking.
getHasChanged in file TCache.php, method TChainedCacheDependency::getHasChanged()
Performs the actual dependency checking.
getHasChanged in file TCache.php, method TApplicationStateCacheDependency::getHasChanged()
Performs the actual dependency checking.
getHost | in file TMemCache.php, method TMemCache::getHost()
getKeyPrefix | in file TCache.php, method TCache::getKeyPrefix()
getMinSavings | in file TMemCache.php, method TMemCache::getMinSavings()
getPassword | in file TDbCache.php, method TDbCache::getPassword()
getPort | in file TMemCache.php, method TMemCache::getPort()
getPrimaryCache | in file TCache.php, method TCache::getPrimaryCache()
getRecursiveCheck | in file TCache.php, method TDirectoryCacheDependency::getRecursiveCheck()
getRecursiveLevel | in file TCache.php, method TDirectoryCacheDependency::getRecursiveLevel()
getStateName | in file TCache.php, method TGlobalStateCacheDependency::getStateName()
getThreshold | in file TMemCache.php, method TMemCache::getThreshold()
getTimestamp | in file TCache.php, method TFileCacheDependency::getTimestamp()
getUsername | in file TDbCache.php, method TDbCache::getUsername()
getValue in file TSqliteCache.php, method TSqliteCache::getValue()
Retrieves a value from cache with a specified key.
getValue in file TXCache.php, method TXCache::getValue()
Retrieves a value from cache with a specified key.
getValue in file TDbCache.php, method TDbCache::getValue()
Retrieves a value from cache with a specified key.
getValue in file TAPCCache.php, method TAPCCache::getValue()
Retrieves a value from cache with a specified key.
getValue in file TCache.php, method TCache::getValue()
Retrieves a value from cache with a specified key.
getValue in file TMemCache.php, method TMemCache::getValue()
Retrieves a value from cache with a specified key.
top
i
init in file TSqliteCache.php, method TSqliteCache::init()
Initializes this module.
init in file TXCache.php, method TXCache::init()
Initializes this module.
init in file TMemCache.php, method TMemCache::init()
Initializes this module.
init in file TDbCache.php, method TDbCache::init()
Initializes this module.
init in file TCache.php, method TCache::init()
Initializes the cache module.
init in file TAPCCache.php, method TAPCCache::init()
Initializes this module.
initializeCache in file TDbCache.php, method TDbCache::initializeCache()
Initialize TDbCache
insertAt in file TCache.php, method TCacheDependencyList::insertAt()
Inserts an item at the specified position.
top
o
offsetExists in file TCache.php, method TCache::offsetExists()
Returns whether there is a cache entry with a specified key.
offsetGet in file TCache.php, method TCache::offsetGet()
Retrieves the value from cache with a specified key.
offsetSet in file TCache.php, method TCache::offsetSet()
Stores the value identified by a key into cache.
offsetUnset in file TCache.php, method TCache::offsetUnset()
Deletes the value with the specified key from cache This method is required by the interface ArrayAccess.
top
s
set in file TCache.php, method TCache::set()
Stores a value identified by a key into cache.
setAutoCreateCacheTable | in file TDbCache.php, method TDbCache::setAutoCreateCacheTable()
setCacheTableName in file TDbCache.php, method TDbCache::setCacheTableName()
Sets the name of the DB table to store cache content.
setConnectionID in file TDbCache.php, method TDbCache::setConnectionID()
Sets the ID of a TDataSourceConfig module.
setConnectionString | in file TDbCache.php, method TDbCache::setConnectionString()
setDbFile | in file TSqliteCache.php, method TSqliteCache::setDbFile()
setDirectory | in file TCache.php, method TDirectoryCacheDependency::setDirectory()
setFileName | in file TCache.php, method TFileCacheDependency::setFileName()
setFlushInterval in file TDbCache.php, method TDbCache::setFlushInterval()
Sets interval expired items will be removed from cache
setHost | in file TMemCache.php, method TMemCache::setHost()
setKeyPrefix | in file TCache.php, method TCache::setKeyPrefix()
setMinSavings | in file TMemCache.php, method TMemCache::setMinSavings()
setPassword | in file TDbCache.php, method TDbCache::setPassword()
setPort | in file TMemCache.php, method TMemCache::setPort()
setPrimaryCache | in file TCache.php, method TCache::setPrimaryCache()
setRecursiveCheck | in file TCache.php, method TDirectoryCacheDependency::setRecursiveCheck()
setRecursiveLevel in file TCache.php, method TDirectoryCacheDependency::setRecursiveLevel()
Sets a value indicating the depth of the subdirectories to be checked.
setStateName | in file TCache.php, method TGlobalStateCacheDependency::setStateName()
setThreshold | in file TMemCache.php, method TMemCache::setThreshold()
setUsername | in file TDbCache.php, method TDbCache::setUsername()
setValue in file TXCache.php, method TXCache::setValue()
Stores a value identified by a key in cache.
setValue in file TSqliteCache.php, method TSqliteCache::setValue()
Stores a value identified by a key in cache.
setValue in file TDbCache.php, method TDbCache::setValue()
Stores a value identified by a key in cache.
setValue in file TAPCCache.php, method TAPCCache::setValue()
Stores a value identified by a key in cache.
setValue in file TCache.php, method TCache::setValue()
Stores a value identified by a key in cache.
setValue in file TMemCache.php, method TMemCache::setValue()
Stores a value identified by a key in cache.
top
t
TAPCCache.php | procedural page TAPCCache.php
TCache.php | procedural page TCache.php
TDbCache.php | procedural page TDbCache.php
TMemCache.php | procedural page TMemCache.php
TSqliteCache.php | procedural page TSqliteCache.php
TXCache.php | procedural page TXCache.php
TAPCCache in file TAPCCache.php, class TAPCCache
TAPCCache class
TApplicationStateCacheDependency in file TCache.php, class TApplicationStateCacheDependency
TApplicationStateCacheDependency class.
TCache in file TCache.php, class TCache
TCache class
TCacheDependency in file TCache.php, class TCacheDependency
TCacheDependency class.
TCacheDependencyList in file TCache.php, class TCacheDependencyList
TCacheDependencyList class.
TChainedCacheDependency in file TCache.php, class TChainedCacheDependency
TChainedCacheDependency class.
TDbCache in file TDbCache.php, class TDbCache
TDbCache class
TDirectoryCacheDependency in file TCache.php, class TDirectoryCacheDependency
TDirectoryCacheDependency class.
TFileCacheDependency in file TCache.php, class TFileCacheDependency
TFileCacheDependency class.
TGlobalStateCacheDependency in file TCache.php, class TGlobalStateCacheDependency
TGlobalStateCacheDependency class.
TMemCache in file TMemCache.php, class TMemCache
TMemCache class
TSqliteCache in file TSqliteCache.php, class TSqliteCache
TSqliteCache class
TXCache in file TXCache.php, class TXCache
TXCache class
top
v
validateDirectory in file TCache.php, method TDirectoryCacheDependency::validateDirectory()
Checks to see if the specified subdirectory should be checked for dependency.
validateFile in file TCache.php, method TDirectoryCacheDependency::validateFile()
Checks to see if the file should be checked for dependency.


Class Trees for Package System.Caching

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TAPCCache.php

File: /Caching/TAPCCache.php

Remarks

TAPCCache class file

author

Alban Hanry <compte_messagerie@hotmail.com>

version

$Id: TAPCCache.php 3018 2011-07-16 22:37:30Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TAPCCache
TAPCCache class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:30 +0200 by phpDocumentor 1.4.3


Docs for page TCache.php

File: /Caching/TCache.php

Remarks

TCache and cache dependency classes.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCache.php 3018 2011-07-16 22:37:30Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCache
TCache class
TCacheDependency
TCacheDependency class.
TFileCacheDependency
TFileCacheDependency class.
TDirectoryCacheDependency
TDirectoryCacheDependency class.
TGlobalStateCacheDependency
TGlobalStateCacheDependency class.
TChainedCacheDependency
TChainedCacheDependency class.
TApplicationStateCacheDependency
TApplicationStateCacheDependency class.
TCacheDependencyList
TCacheDependencyList class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:38 +0200 by phpDocumentor 1.4.3


Docs for page TDbCache.php

File: /Caching/TDbCache.php

Remarks

TDbCache class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDbCache.php 3060 2011-11-10 21:04:13Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDbCache
TDbCache class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:10 +0200 by phpDocumentor 1.4.3


Docs for page TMemCache.php

File: /Caching/TMemCache.php

Remarks

TMemCache class file

author

Carl G. Mathisen <carlgmathisen@gmail.com>

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TMemCache.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMemCache
TMemCache class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:50 +0200 by phpDocumentor 1.4.3


Docs for page TSqliteCache.php

File: /Caching/TSqliteCache.php

Remarks

TSqliteCache class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TSqliteCache.php 3058 2011-11-09 22:12:14Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqliteCache
TSqliteCache class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:23 +0200 by phpDocumentor 1.4.3


Docs for page TXCache.php

File: /Caching/TXCache.php

Remarks

TXCache class file

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TXCache.php 1994 2007-06-11 16:02:28Z knut $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TXCache
TXCache class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:52 +0200 by phpDocumentor 1.4.3


Docs For Class TAPCCache

Class TAPCCache

[line 48]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TCache
            |
            --TAPCCache
Location: /Caching/TAPCCache.php

Remarks

TAPCCache class

TAPCCache implements a cache application module based on APC.

By definition, cache does not ensure the existence of a value even if it never expires. Cache is not meant to be an persistent storage.

To use this module, the APC PHP extension must be loaded and set in the php.ini file the following:

  •  apc.cache_by_default=0
    •

    Some usage examples of TAPCCache are as follows,

  •  $cache=new TAPCCache;  // TAPCCache may also be loaded as a Prado application module
    •

  •  $cache->init(null);
    •

  •  $cache->add('object',$object);
    •

  •  $object2=$cache->get('object');
    •

    If loaded, TAPCCache will register itself with TApplication as the cache module. It can be accessed via TApplication::getCache().

    TAPCCache may be configured in application configuration file as follows

  •  <module id="cache" class="System.Caching.TAPCCache" />
    •

    author

    Knut Urdalen <knut.urdalen@gmail.com>

    author

    Alban Hanry <compte_messagerie@hotmail.com>

    version

    $Id: TAPCCache.php 3018 2011-07-16 22:37:30Z ctrlaltca@gmail.com $

    since

    3.0b

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TCache

    • TCache::add()
      Stores a value identified by a key into cache if the cache does not contain this key.
    • TCache::addValue()
      Stores a value identified by a key into cache if the cache does not contain this key.
    • TCache::delete()
      Deletes a value with the specified key from cache
    • TCache::deleteValue()
      Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.
    • TCache::flush()
      Deletes all values from cache.
    • TCache::generateUniqueKey()
    • TCache::get()
      Retrieves a value from cache with a specified key.
    • TCache::getKeyPrefix()
    • TCache::getPrimaryCache()
    • TCache::getValue()
      Retrieves a value from cache with a specified key.
    • TCache::init()
      Initializes the cache module.
    • TCache::offsetExists()
      Returns whether there is a cache entry with a specified key.
    • TCache::offsetGet()
      Retrieves the value from cache with a specified key.
    • TCache::offsetSet()
      Stores the value identified by a key into cache.
    • TCache::offsetUnset()
      Deletes the value with the specified key from cache This method is required by the interface ArrayAccess.
    • TCache::set()
      Stores a value identified by a key into cache.
    • TCache::setKeyPrefix()
    • TCache::setPrimaryCache()
    • TCache::setValue()
      Stores a value identified by a key in cache.

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TAPCCache::addValue

      addValue( string $key, string $value, integer $expire );

      Overrides TCache::addValue() (Stores a value identified by a key into cache if the cache does not contain this key.)

      Parameters

      $key

      the key identifying the value to be cached

      $value

      the value to be cached

      $expire

      the number of seconds in which the cached value will expire. 0 means never expire.

      Returns

      true if the value is successfully stored into cache, false otherwise

      Remarks

      Stores a value identified by a key into cache if the cache does not contain this key.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TAPCCache::deleteValue

      deleteValue( string $key );

      Overrides TCache::deleteValue() (Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.)

      Parameters

      $key

      the key of the value to be deleted

      Returns

      if no error happens during deletion

      Remarks

      Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TAPCCache::flush

      flush( );

      Overrides TCache::flush() (Deletes all values from cache.)

      Remarks

      Deletes all values from cache.

      Be careful of performing this operation if the cache is shared by multiple applications.

      access

      public

      [ Top ]

      TAPCCache::getValue

      getValue( string $key );

      Overrides TCache::getValue() (Retrieves a value from cache with a specified key.)

      Parameters

      $key

      a unique key identifying the cached value

      Returns

      the value stored in cache, false if the value is not in the cache or expired.

      Remarks

      Retrieves a value from cache with a specified key.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TAPCCache::init

      init( TXmlElement $config );

      Overrides TCache::init() (Initializes the cache module.)

      Parameters

      $config

      configuration for this module, can be null

      Remarks

      Initializes this module.

      This method is required by the IModule interface.

      throws

      TConfigurationException if apc extension is not installed or not started, check your php.ini

      access

      public

      [ Top ]

      TAPCCache::setValue

      setValue( string $key, string $value, integer $expire );

      Overrides TCache::setValue() (Stores a value identified by a key in cache.)

      Parameters

      $key

      the key identifying the value to be cached

      $value

      the value to be cached

      $expire

      the number of seconds in which the cached value will expire. 0 means never expire.

      Returns

      true if the value is successfully stored into cache, false otherwise

      Remarks

      Stores a value identified by a key in cache.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:30 +0200 by phpDocumentor 1.4.3


Docs For Class TApplicationStateCacheDependency

Class TApplicationStateCacheDependency

[line 674]
TComponent
   |
   --TCacheDependency
      |
      --TApplicationStateCacheDependency
Location: /Caching/TCache.php

Remarks

TApplicationStateCacheDependency class.

TApplicationStateCacheDependency performs dependency checking based on the mode of the currently running PRADO application. The dependency is reportedly as unchanged if and only if the application is running in performance mode.

You may chain this dependency together with other dependencies so that only when the application is not in performance mode the other dependencies will be checked.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCache.php 3018 2011-07-16 22:37:30Z ctrlaltca@gmail.com $

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TApplicationStateCacheDependency::getHasChanged

    getHasChanged( );

    Returns

    whether the dependency is changed or not.

    Remarks

    Performs the actual dependency checking.

    This method returns true if the currently running application is not in performance mode.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:38 +0200 by phpDocumentor 1.4.3


Docs For Class TCache

Class TCache

[line 49]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TCache
Classes extended from TCache:
TAPCCache
TAPCCache class
TDbCache
TDbCache class
TMemCache
TMemCache class
TSqliteCache
TSqliteCache class
TXCache
TXCache class

Location: /Caching/TCache.php

Remarks

TCache class

TCache is the base class for cache classes with different cache storage implementation.

TCache implements the interface ICache with the following methods,

  • get : retrieve the value with a key (if any) from cache
  • set : store the value with a key into cache
  • add : store the value only if cache does not have this key
  • delete : delete the value with the specified key from cache
  • flush : delete all values from cache
Each value is associated with an expiration time. The get operation ensures that any expired value will not be returned. The expiration time by the number of seconds. A expiration time 0 represents never expire.

By definition, cache does not ensure the existence of a value even if it never expires. Cache is not meant to be an persistent storage.

Child classes must implement the following methods:

  • getValue
  • setValue
  • addValue
  • deleteValue
and optionally flush

Since version 3.1.2, TCache implements the ArrayAccess interface such that the cache acts as an array.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCache.php 3018 2011-07-16 22:37:30Z ctrlaltca@gmail.com $

abstract

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCache::add

    add( string $id, mixed $value, [integer $expire = 0], [ICacheDependency $dependency = null] );

    Parameters

    $id

    the key identifying the value to be cached

    $value

    the value to be cached

    $expire

    the number of seconds in which the cached value will expire. 0 means never expire.

    $dependency

    dependency of the cached item. If the dependency changes, the item is labeled invalid.

    Returns

    true if the value is successfully stored into cache, false otherwise

    Remarks

    Stores a value identified by a key into cache if the cache does not contain this key.

    Nothing will be done if the cache already contains the key or if value is empty.

    access

    public

    [ Top ]

    TCache::addValue

    addValue( string $key, string $value, integer $expire );

    Overridden in child classes as:

    TAPCCache::addValue()
    Stores a value identified by a key into cache if the cache does not contain this key.
    TDbCache::addValue()
    Stores a value identified by a key into cache if the cache does not contain this key.
    TMemCache::addValue()
    Stores a value identified by a key into cache if the cache does not contain this key.
    TSqliteCache::addValue()
    Stores a value identified by a key into cache if the cache does not contain this key.
    TXCache::addValue()
    Stores a value identified by a key into cache if the cache does not contain this key.

    Parameters

    $key

    the key identifying the value to be cached

    $value

    the value to be cached

    $expire

    the number of seconds in which the cached value will expire. 0 means never expire.

    Returns

    true if the value is successfully stored into cache, false otherwise

    Remarks

    Stores a value identified by a key into cache if the cache does not contain this key.

    This method should be implemented by child classes to store the data in specific cache storage. The uniqueness and dependency are handled in add() already. So only the implementation of data storage is needed.

    abstract

    access

    protected

    [ Top ]

    TCache::delete

    delete( string $id );

    Parameters

    $id

    the key of the value to be deleted

    Returns

    if no error happens during deletion

    Remarks

    Deletes a value with the specified key from cache

    access

    public

    [ Top ]

    TCache::deleteValue

    deleteValue( string $key );

    Overridden in child classes as:

    TAPCCache::deleteValue()
    Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
    TDbCache::deleteValue()
    Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
    TMemCache::deleteValue()
    Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
    TSqliteCache::deleteValue()
    Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
    TXCache::deleteValue()
    Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.

    Parameters

    $key

    the key of the value to be deleted

    Returns

    if no error happens during deletion

    Remarks

    Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.

    abstract

    access

    protected

    [ Top ]

    TCache::flush

    flush( );

    Overridden in child classes as:

    TAPCCache::flush()
    Deletes all values from cache.
    TDbCache::flush()
    Deletes all values from cache.
    TMemCache::flush()
    Deletes all values from cache.
    TSqliteCache::flush()
    Deletes all values from cache.
    TXCache::flush()
    Deletes all values from cache.

    Remarks

    Deletes all values from cache.

    Be careful of performing this operation if the cache is shared by multiple applications. Child classes may implement this method to realize the flush operation.

    throws

    TNotSupportedException if this method is not overridden by child classes

    access

    public

    [ Top ]

    TCache::generateUniqueKey

    generateUniqueKey( string $key );

    Parameters

    $key

    a key identifying a value to be cached

    Returns

    a key generated from the provided key which ensures the uniqueness across applications

    access

    protected

    [ Top ]

    TCache::get

    get( string $id );

    Parameters

    $id

    a key identifying the cached value

    Returns

    the value stored in cache, false if the value is not in the cache or expired.

    Remarks

    Retrieves a value from cache with a specified key.

    access

    public

    [ Top ]

    TCache::getKeyPrefix

    getKeyPrefix( );

    Returns

    a unique prefix for the keys of cached values. If it is not explicitly set, it will take the value of TApplication::getUniqueID.

    access

    public

    [ Top ]

    TCache::getPrimaryCache

    getPrimaryCache( );

    Returns

    whether this cache module is used as primary/system cache. A primary cache is used by PRADO core framework to cache data such as parsed templates, themes, etc.

    access

    public

    [ Top ]

    TCache::getValue

    getValue( string $key );

    Overridden in child classes as:

    TAPCCache::getValue()
    Retrieves a value from cache with a specified key.
    TDbCache::getValue()
    Retrieves a value from cache with a specified key.
    TMemCache::getValue()
    Retrieves a value from cache with a specified key.
    TSqliteCache::getValue()
    Retrieves a value from cache with a specified key.
    TXCache::getValue()
    Retrieves a value from cache with a specified key.

    Parameters

    $key

    a unique key identifying the cached value

    Returns

    the value stored in cache, false if the value is not in the cache or expired.

    Remarks

    Retrieves a value from cache with a specified key.

    This method should be implemented by child classes to store the data in specific cache storage. The uniqueness and dependency are handled in get() already. So only the implementation of data retrieval is needed.

    abstract

    access

    protected

    [ Top ]

    TCache::init

    init( TXmlElement $config );

    Overridden in child classes as:

    TAPCCache::init()
    Initializes this module.
    TDbCache::init()
    Initializes this module.
    TMemCache::init()
    Initializes this module.
    TSqliteCache::init()
    Initializes this module.
    TXCache::init()
    Initializes this module.

    Overrides TModule::init() (Initializes the module.)

    Parameters

    $config

    the module configuration

    Remarks

    Initializes the cache module.

    This method initializes the cache key prefix and registers the cache module with the application if the cache is primary.

    access

    public

    [ Top ]

    TCache::offsetExists

    offsetExists( string $id );

    Implementation of:
    ArrayAccess::offsetExists

    Parameters

    $id

    a key identifying the cached value

    Remarks

    Returns whether there is a cache entry with a specified key.

    This method is required by the interface ArrayAccess.

    access

    public

    [ Top ]

    TCache::offsetGet

    offsetGet( string $id );

    Implementation of:
    ArrayAccess::offsetGet

    Parameters

    $id

    a key identifying the cached value

    Returns

    the value stored in cache, false if the value is not in the cache or expired.

    Remarks

    Retrieves the value from cache with a specified key.

    This method is required by the interface ArrayAccess.

    access

    public

    [ Top ]

    TCache::offsetSet

    offsetSet( string $id, mixed $value );

    Implementation of:
    ArrayAccess::offsetSet

    Parameters

    $id

    the key identifying the value to be cached

    $value

    the value to be cached

    Remarks

    Stores the value identified by a key into cache.

    If the cache already contains such a key, the existing value will be replaced with the new ones. To add expiration and dependencies, use the set() method. This method is required by the interface ArrayAccess.

    access

    public

    [ Top ]

    TCache::offsetUnset

    offsetUnset( string $id );

    Implementation of:
    ArrayAccess::offsetUnset

    Parameters

    $id

    the key of the value to be deleted

    Returns

    if no error happens during deletion

    Remarks

    Deletes the value with the specified key from cache This method is required by the interface ArrayAccess.

    access

    public

    [ Top ]

    TCache::set

    set( string $id, mixed $value, [integer $expire = 0], [ICacheDependency $dependency = null] );

    Parameters

    $id

    the key identifying the value to be cached

    $value

    the value to be cached

    $expire

    the number of seconds in which the cached value will expire. 0 means never expire.

    $dependency

    dependency of the cached item. If the dependency changes, the item is labeled invalid.

    Returns

    true if the value is successfully stored into cache, false otherwise

    Remarks

    Stores a value identified by a key into cache.

    If the cache already contains such a key, the existing value and expiration time will be replaced with the new ones. If the value is empty, the cache key will be deleted.

    access

    public

    [ Top ]

    TCache::setKeyPrefix

    setKeyPrefix( string $value );

    Parameters

    $value

    a unique prefix for the keys of cached values

    access

    public

    [ Top ]

    TCache::setPrimaryCache

    setPrimaryCache( boolean $value );

    Parameters

    $value

    whether this cache module is used as primary/system cache. Defaults to false.

    see

    TCache::getPrimaryCache()

    access

    public

    [ Top ]

    TCache::setValue

    setValue( string $key, string $value, integer $expire );

    Overridden in child classes as:

    TAPCCache::setValue()
    Stores a value identified by a key in cache.
    TDbCache::setValue()
    Stores a value identified by a key in cache.
    TMemCache::setValue()
    Stores a value identified by a key in cache.
    TSqliteCache::setValue()
    Stores a value identified by a key in cache.
    TXCache::setValue()
    Stores a value identified by a key in cache.

    Parameters

    $key

    the key identifying the value to be cached

    $value

    the value to be cached

    $expire

    the number of seconds in which the cached value will expire. 0 means never expire.

    Returns

    true if the value is successfully stored into cache, false otherwise

    Remarks

    Stores a value identified by a key in cache.

    This method should be implemented by child classes to store the data in specific cache storage. The uniqueness and dependency are handled in set() already. So only the implementation of data storage is needed.

    abstract

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:38 +0200 by phpDocumentor 1.4.3


Docs For Class TCacheDependency

Class TCacheDependency

[line 320]
TComponent
   |
   --TCacheDependency
Classes extended from TCacheDependency:
TFileCacheDependency
TFileCacheDependency class.
TDirectoryCacheDependency
TDirectoryCacheDependency class.
TGlobalStateCacheDependency
TGlobalStateCacheDependency class.
TChainedCacheDependency
TChainedCacheDependency class.
TApplicationStateCacheDependency
TApplicationStateCacheDependency class.

Location: /Caching/TCache.php

Remarks

TCacheDependency class.

TCacheDependency is the base class implementing ICacheDependency interface. Descendant classes must implement getHasChanged() to provide actual dependency checking logic.

The property value of getHasChanged tells whether the dependency is changed or not.

You may disable the dependency checking by setting setEnabled to false.

Note, since the dependency objects often need to be serialized so that they can persist across requests, you may need to implement __sleep() and __wakeup() if the dependency objects contain resource handles which are not serializable.

Currently, the following dependency classes are provided in the PRADO release:

  • TFileCacheDependency: checks whether a file is changed or not
  • TDirectoryCacheDependency: checks whether a directory is changed or not
  • TGlobalStateCacheDependency: checks whether a global state is changed or not
  • TChainedCacheDependency: checks whether any of a list of dependencies is changed or not

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCache.php 3018 2011-07-16 22:37:30Z ctrlaltca@gmail.com $

abstract

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:39 +0200 by phpDocumentor 1.4.3


Docs For Class TCacheDependencyList

Class TCacheDependencyList

[line 701]
TComponent
   |
   --TList
      |
      --TCacheDependencyList
Location: /Caching/TCache.php

Remarks

TCacheDependencyList class.

TCacheDependencyList represents a list of cache dependency objects. Only objects implementing ICacheDependency can be added into this list.

TCacheDependencyList can be used like an array. See TList for more details.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCache.php 3018 2011-07-16 22:37:30Z ctrlaltca@gmail.com $

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCacheDependencyList::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TList::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the specified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by performing additional type checking for each newly added item.

    throws

    TInvalidDataTypeException if the item to be inserted is not a dependency instance

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:39 +0200 by phpDocumentor 1.4.3


Docs For Class TChainedCacheDependency

Class TChainedCacheDependency

[line 624]
TComponent
   |
   --TCacheDependency
      |
      --TChainedCacheDependency
Location: /Caching/TCache.php

Remarks

TChainedCacheDependency class.

TChainedCacheDependency represents a list of cache dependency objects and performs the dependency checking based on the checking results of these objects. If any of them reports a dependency change, TChainedCacheDependency will return true for the checking.

To add dependencies to TChainedCacheDependency, use Dependencies which gives a TCacheDependencyList instance and can be used like an array (see TList for more details}).

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCache.php 3018 2011-07-16 22:37:30Z ctrlaltca@gmail.com $

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TChainedCacheDependency::getDependencies

    getDependencies( );

    Returns

    list of dependency objects

    access

    public

    [ Top ]

    TChainedCacheDependency::getHasChanged

    getHasChanged( );

    Returns

    whether the dependency is changed or not.

    Remarks

    Performs the actual dependency checking.

    This method returns true if any of the dependency objects reports a dependency change.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:39 +0200 by phpDocumentor 1.4.3


Docs For Class TDirectoryCacheDependency

Class TDirectoryCacheDependency

[line 407]
TComponent
   |
   --TCacheDependency
      |
      --TDirectoryCacheDependency
Location: /Caching/TCache.php

Remarks

TDirectoryCacheDependency class.

TDirectoryCacheDependency performs dependency checking based on the modification time of the files contained in the specified directory. The directory being checked is specified via Directory.

By default, all files under the specified directory and subdirectories will be checked. If the last modification time of any of them is changed or if different number of files are contained in a directory, the dependency is reported as changed. By specifying RecursiveCheck and RecursiveLevel, one can limit the checking to a certain depth of the subdirectories.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCache.php 3018 2011-07-16 22:37:30Z ctrlaltca@gmail.com $

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDirectoryCacheDependency::__construct

    __construct( string $directory );

    Parameters

    $directory

    the directory to be checked

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDirectoryCacheDependency::generateTimestamps

    generateTimestamps( string $directory, [int $level = 0] );

    Parameters

    $directory

    the directory name

    $level

    level of the recursion

    Returns

    list of file modification time indexed by the file path

    Remarks

    Determines the last modification time for files under the directory.

    This method may go recursively into subdirectories if RecursiveCheck is set true.

    access

    protected

    [ Top ]

    TDirectoryCacheDependency::getDirectory

    getDirectory( );

    Returns

    the directory to be checked

    access

    public

    [ Top ]

    TDirectoryCacheDependency::getHasChanged

    getHasChanged( );

    Returns

    whether the dependency is changed or not.

    Remarks

    Performs the actual dependency checking.

    This method returns true if the directory is changed.

    access

    public

    [ Top ]

    TDirectoryCacheDependency::getRecursiveCheck

    getRecursiveCheck( );

    Returns

    whether the subdirectories of the directory will also be checked. It defaults to true.

    access

    public

    [ Top ]

    TDirectoryCacheDependency::getRecursiveLevel

    getRecursiveLevel( );

    Returns

    the depth of the subdirectories to be checked. It defaults to -1, meaning unlimited depth.

    access

    public

    [ Top ]

    TDirectoryCacheDependency::setDirectory

    setDirectory( string $directory );

    Parameters

    $directory

    the directory to be checked

    throws

    TInvalidDataValueException if the directory does not exist

    access

    public

    [ Top ]

    TDirectoryCacheDependency::setRecursiveCheck

    setRecursiveCheck( boolean $value );

    Parameters

    $value

    whether the subdirectories of the directory will also be checked.

    access

    public

    [ Top ]

    TDirectoryCacheDependency::setRecursiveLevel

    setRecursiveLevel( int $value );

    Parameters

    $value

    the depth of the subdirectories to be checked. If the value is less than 0, it means unlimited depth. If the value is 0, it means checking the files directly under the specified directory.

    Remarks

    Sets a value indicating the depth of the subdirectories to be checked.

    This is meaningful only when RecursiveCheck is true.

    access

    public

    [ Top ]

    TDirectoryCacheDependency::validateDirectory

    validateDirectory( string $directory );

    Parameters

    $directory

    the name of the subdirectory that may be checked for dependency.

    Returns

    whether this subdirectory should be checked.

    Remarks

    Checks to see if the specified subdirectory should be checked for dependency.

    This method is invoked when dependency of the whole directory is being checked. By default, it always returns true, meaning the subdirectory should be checked. You may override this method to check only certain subdirectories.

    access

    protected

    [ Top ]

    TDirectoryCacheDependency::validateFile

    validateFile( string $fileName );

    Parameters

    $fileName

    the name of the file that may be checked for dependency.

    Returns

    whether this file should be checked.

    Remarks

    Checks to see if the file should be checked for dependency.

    This method is invoked when dependency of the whole directory is being checked. By default, it always returns true, meaning the file should be checked. You may override this method to check only certain files.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:39 +0200 by phpDocumentor 1.4.3


Docs For Class TFileCacheDependency

Class TFileCacheDependency

[line 338]
TComponent
   |
   --TCacheDependency
      |
      --TFileCacheDependency
Location: /Caching/TCache.php

Remarks

TFileCacheDependency class.

TFileCacheDependency performs dependency checking based on the last modification time of the file specified via FileName. The dependency is reported as unchanged if and only if the file's last modification time remains unchanged.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCache.php 3018 2011-07-16 22:37:30Z ctrlaltca@gmail.com $

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TFileCacheDependency::__construct

    __construct( string $fileName );

    Parameters

    $fileName

    name of the file whose change is to be checked.

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TFileCacheDependency::getFileName

    getFileName( );

    Returns

    the name of the file whose change is to be checked

    access

    public

    [ Top ]

    TFileCacheDependency::getHasChanged

    getHasChanged( );

    Returns

    whether the dependency is changed or not.

    Remarks

    Performs the actual dependency checking.

    This method returns true if the last modification time of the file is changed.

    access

    public

    [ Top ]

    TFileCacheDependency::getTimestamp

    getTimestamp( );

    Returns

    the last modification time of the file

    access

    public

    [ Top ]

    TFileCacheDependency::setFileName

    setFileName( string $value );

    Parameters

    $value

    the name of the file whose change is to be checked

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:40 +0200 by phpDocumentor 1.4.3


Docs For Class TGlobalStateCacheDependency

Class TGlobalStateCacheDependency

[line 563]
TComponent
   |
   --TCacheDependency
      |
      --TGlobalStateCacheDependency
Location: /Caching/TCache.php

Remarks

TGlobalStateCacheDependency class.

TGlobalStateCacheDependency checks if a global state is changed or not. If the global state is changed, the dependency is reported as changed. To specify which global state this dependency should check with, set StateName to the name of the global state.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCache.php 3018 2011-07-16 22:37:30Z ctrlaltca@gmail.com $

since

3.1.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TGlobalStateCacheDependency::__construct

    __construct( string $name );

    Parameters

    $name

    the name of the global state

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TGlobalStateCacheDependency::getHasChanged

    getHasChanged( );

    Returns

    whether the dependency is changed or not.

    Remarks

    Performs the actual dependency checking.

    This method returns true if the specified global state is changed.

    access

    public

    [ Top ]

    TGlobalStateCacheDependency::getStateName

    getStateName( );

    Returns

    the name of the global state

    access

    public

    [ Top ]

    TGlobalStateCacheDependency::setStateName

    setStateName( string $value );

    Parameters

    $value

    the name of the global state

    see

    TApplication::setGlobalState

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:40 +0200 by phpDocumentor 1.4.3


Docs For Class TDbCache

Class TDbCache

[line 89]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TCache
            |
            --TDbCache
Location: /Caching/TDbCache.php

Remarks

TDbCache class

TDbCache implements a cache application module by storing cached data in a database.

TDbCache relies on PDO to retrieve data from databases. In order to use TDbCache, you need to enable the PDO extension as well as the corresponding PDO DB driver. For example, to use SQLite database to store cached data, you need both php_pdo and php_pdo_sqlite extensions.

By default, TDbCache creates and uses an SQLite database under the application runtime directory. You may change this default setting by specifying the following properties:

  • ConnectionID or
  • ConnectionString, Username and Pasword.
The cached data is stored in a table in the specified database. By default, the name of the table is called 'pradocache'. If the table does not exist in the database, it will be automatically created with the following structure:
  •  CREATE TABLE pradocache (itemkey CHAR(128), value BLOB, expire INT)
    •

  •  CREATE INDEX IX_itemkey ON pradocache (itemkey)
    •

  •  CREATE INDEX IX_expire ON pradocache (expire)
    •

    Note, some DBMS might not support BLOB type. In this case, replace 'BLOB' with a suitable binary data type (e.g. LONGBLOB in MySQL, BYTEA in PostgreSQL.)

    Important: Make sure that the indices are non-unique!

    If you want to change the cache table name, or if you want to create the table by yourself, you may set CacheTableName and AutoCreateCacheTableName properties.

    FlushInterval control how often expired items will be removed from cache. If you prefer to remove expired items manualy e.g. via cronjob you can disable automatic deletion by setting FlushInterval to '0'.

    The following basic cache operations are implemented:

    • get : retrieve the value with a key (if any) from cache
    • set : store the value with a key into cache
    • add : store the value only if cache does not have this key
    • delete : delete the value with the specified key from cache
    • flush : delete all values from cache
    Each value is associated with an expiration time. The get operation ensures that any expired value will not be returned. The expiration time by the number of seconds. A expiration time 0 represents never expire.

    By definition, cache does not ensure the existence of a value even if it never expires. Cache is not meant to be an persistent storage.

    Do not use the same database file for multiple applications using TDbCache. Also note, cache is shared by all user sessions of an application.

    Some usage examples of TDbCache are as follows,

  •  $cache=new TDbCache;  // TDbCache may also be loaded as a Prado application module
    •

  •  $cache->init(null);
    •

  •  $cache->add('object',$object);
    •

  •  $object2=$cache->get('object');
    •

    If loaded, TDbCache will register itself with TApplication as the cache module. It can be accessed via TApplication::getCache().

    TDbCache may be configured in application configuration file as follows

  •  <module id="cache" class="System.Caching.TDbCache" />
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TDbCache.php 3060 2011-11-10 21:04:13Z ctrlaltca@gmail.com $

    since

    3.1.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TCache

    • TCache::add()
      Stores a value identified by a key into cache if the cache does not contain this key.
    • TCache::addValue()
      Stores a value identified by a key into cache if the cache does not contain this key.
    • TCache::delete()
      Deletes a value with the specified key from cache
    • TCache::deleteValue()
      Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.
    • TCache::flush()
      Deletes all values from cache.
    • TCache::generateUniqueKey()
    • TCache::get()
      Retrieves a value from cache with a specified key.
    • TCache::getKeyPrefix()
    • TCache::getPrimaryCache()
    • TCache::getValue()
      Retrieves a value from cache with a specified key.
    • TCache::init()
      Initializes the cache module.
    • TCache::offsetExists()
      Returns whether there is a cache entry with a specified key.
    • TCache::offsetGet()
      Retrieves the value from cache with a specified key.
    • TCache::offsetSet()
      Stores the value identified by a key into cache.
    • TCache::offsetUnset()
      Deletes the value with the specified key from cache This method is required by the interface ArrayAccess.
    • TCache::set()
      Stores a value identified by a key into cache.
    • TCache::setKeyPrefix()
    • TCache::setPrimaryCache()
    • TCache::setValue()
      Stores a value identified by a key in cache.

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TDbCache::__destruct

      __destruct( );

      Remarks

      Destructor.

      Disconnect the db connection.

      access

      public

      [ Top ]

      TDbCache::addValue

      addValue( string $key, string $value, integer $expire );

      Overrides TCache::addValue() (Stores a value identified by a key into cache if the cache does not contain this key.)

      Parameters

      $key

      the key identifying the value to be cached

      $value

      the value to be cached

      $expire

      the number of seconds in which the cached value will expire. 0 means never expire.

      Returns

      true if the value is successfully stored into cache, false otherwise

      Remarks

      Stores a value identified by a key into cache if the cache does not contain this key.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TDbCache::createDbConnection

      createDbConnection( string 0 );

      Parameters

      0

      the module ID for TDataSourceConfig

      Returns

      the created DB connection

      Remarks

      Creates the DB connection.

      throws

      TConfigurationException if module ID is invalid or empty

      access

      protected

      [ Top ]

      TDbCache::deleteValue

      deleteValue( string $key );

      Overrides TCache::deleteValue() (Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.)

      Parameters

      $key

      the key of the value to be deleted

      Returns

      if no error happens during deletion

      Remarks

      Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TDbCache::doFlushCacheExpired

      doFlushCacheExpired( );

      Remarks

      Event listener for TApplication.OnSaveState

      see

      TDbCache::flushCacheExpired()

      since

      3.1.5

      access

      public

      [ Top ]

      TDbCache::doInitializeCache

      doInitializeCache( );

      Remarks

      Event listener for TApplication.OnLoadStateComplete

      see

      TDbCache::initializeCache()

      since

      3.1.5

      access

      public

      [ Top ]

      TDbCache::flush

      flush( );

      Overrides TCache::flush() (Deletes all values from cache.)

      Remarks

      Deletes all values from cache.

      Be careful of performing this operation if the cache is shared by multiple applications.

      access

      public

      [ Top ]

      TDbCache::flushCacheExpired

      flushCacheExpired( [boolean $force = false] );

      Parameters

      $force

      override FlushInterval and force deletion of expired items

      Remarks

      Flush expired values from cache depending on setFlushInterval

      since

      3.1.5

      access

      public

      [ Top ]

      TDbCache::getAutoCreateCacheTable

      getAutoCreateCacheTable( );

      Returns

      whether the cache DB table should be automatically created if not exists. Defaults to true.

      see

      TDbCache::setAutoCreateCacheTable()

      access

      public

      [ Top ]

      TDbCache::getCacheTableName

      getCacheTableName( );

      Returns

      the name of the DB table to store cache content. Defaults to 'pradocache'.

      see

      TDbCache::setAutoCreateCacheTable()

      access

      public

      [ Top ]

      TDbCache::getConnectionID

      getConnectionID( );

      Returns

      the ID of a TDataSourceConfig module. Defaults to empty string, meaning not set.

      since

      3.1.1

      access

      public

      [ Top ]

      TDbCache::getConnectionString

      getConnectionString( );

      Returns

      The Data Source Name, or DSN, contains the information required to connect to the database.

      access

      public

      [ Top ]

      TDbCache::getDbConnection

      getDbConnection( );

      Returns

      the DB connection instance

      access

      public

      [ Top ]

      TDbCache::getFlushInterval

      getFlushInterval( );

      Returns

      Interval in sec expired items will be removed from cache. Default to 60

      since

      3.1.5

      access

      public

      [ Top ]

      TDbCache::getPassword

      getPassword( );

      Returns

      the password for establishing DB connection. Defaults to empty string.

      access

      public

      [ Top ]

      TDbCache::getUsername

      getUsername( );

      Returns

      the username for establishing DB connection. Defaults to empty string.

      access

      public

      [ Top ]

      TDbCache::getValue

      getValue( string $key );

      Overrides TCache::getValue() (Retrieves a value from cache with a specified key.)

      Parameters

      $key

      a unique key identifying the cached value

      Returns

      the value stored in cache, false if the value is not in the cache or expired.

      Remarks

      Retrieves a value from cache with a specified key.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TDbCache::init

      init( TXmlElement $config );

      Overrides TCache::init() (Initializes the cache module.)

      Parameters

      $config

      configuration for this module, can be null

      Remarks

      Initializes this module.

      This method is required by the IModule interface. attach doInitializeCache to TApplication.OnLoadStateComplete event attach doFlushCacheExpired to TApplication.OnSaveState event

      access

      public

      [ Top ]

      TDbCache::initializeCache

      initializeCache( [boolean $force = false] );

      Parameters

      $force

      Force override global state check

      Remarks

      Initialize TDbCache

      If AutoCreateCacheTableName is 'true' check existence of cache table and create table if does not exist.

      throws

      TConfigurationException if any error happens during creating database or cache table.

      since

      3.1.5

      access

      protected

      [ Top ]

      TDbCache::setAutoCreateCacheTable

      setAutoCreateCacheTable( boolean $value );

      Parameters

      $value

      whether the cache DB table should be automatically created if not exists.

      see

      TDbCache::setCacheTableName()

      access

      public

      [ Top ]

      TDbCache::setCacheTableName

      setCacheTableName( string $value );

      Parameters

      $value

      the name of the DB table to store cache content

      Remarks

      Sets the name of the DB table to store cache content.

      Note, if AutoCreateCacheTable is false and you want to create the DB table manually by yourself, you need to make sure the DB table is of the following structure:

    •  CREATE TABLE pradocache (itemkey CHAR(128), value BLOB, expire INT)
      •

    •  CREATE INDEX IX_itemkey ON pradocache (itemkey)
      •

    •  CREATE INDEX IX_expire ON pradocache (expire)
      •

      Note, some DBMS might not support BLOB type. In this case, replace 'BLOB' with a suitable binary data type (e.g. LONGBLOB in MySQL, BYTEA in PostgreSQL.)

      Important: Make sure that the indices are non-unique!

      see

      TDbCache::setAutoCreateCacheTable()

      access

      public

      [ Top ]

      TDbCache::setConnectionID

      setConnectionID( string $value );

      Parameters

      $value

      ID of the TDataSourceConfig module

      Remarks

      Sets the ID of a TDataSourceConfig module.

      The datasource module will be used to establish the DB connection for this cache module. The database connection can also be specified via ConnectionString. When both ConnectionID and ConnectionString are specified, the former takes precedence.

      since

      3.1.1

      access

      public

      [ Top ]

      TDbCache::setConnectionString

      setConnectionString( string $value );

      Parameters

      $value

      The Data Source Name, or DSN, contains the information required to connect to the database.

      see

      http://www.php.net/manual/en/function.pdo-construct.php

      access

      public

      [ Top ]

      TDbCache::setFlushInterval

      setFlushInterval( integer $value );

      Parameters

      $value

      Interval in sec

      Remarks

      Sets interval expired items will be removed from cache

      To disable automatic deletion of expired items, e.g. for external flushing via cron you can set value to '0'

      since

      3.1.5

      access

      public

      [ Top ]

      TDbCache::setPassword

      setPassword( string $value );

      Parameters

      $value

      the password for establishing DB connection

      access

      public

      [ Top ]

      TDbCache::setUsername

      setUsername( string $value );

      Parameters

      $value

      the username for establishing DB connection

      access

      public

      [ Top ]

      TDbCache::setValue

      setValue( string $key, string $value, integer $expire );

      Overrides TCache::setValue() (Stores a value identified by a key in cache.)

      Parameters

      $key

      the key identifying the value to be cached

      $value

      the value to be cached

      $expire

      the number of seconds in which the cached value will expire. 0 means never expire.

      Returns

      true if the value is successfully stored into cache, false otherwise

      Remarks

      Stores a value identified by a key in cache.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:10 +0200 by phpDocumentor 1.4.3


Docs For Class TMemCache

Class TMemCache

[line 84]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TCache
            |
            --TMemCache
Location: /Caching/TMemCache.php

Remarks

TMemCache class

TMemCache implements a cache application module based on memcached.

TMemCache can be configured with the Host and Port properties, which specify the host and port of the memcache server to be used. By default, they take the value 'localhost' and 11211, respectively. These properties must be set before init is invoked.

The following basic cache operations are implemented:

  • get : retrieve the value with a key (if any) from cache
  • set : store the value with a key into cache
  • add : store the value only if cache does not have this key
  • delete : delete the value with the specified key from cache
  • flush : delete all values from cache
Each value is associated with an expiration time. The get operation ensures that any expired value will not be returned. The expiration time can be specified by the number of seconds (maximum 60*60*24*30) or a UNIX timestamp. A expiration time 0 represents never expire.

By definition, cache does not ensure the existence of a value even if it never expires. Cache is not meant to be an persistent storage.

Also note, there is no security measure to protected data in memcache. All data in memcache can be accessed by any process running in the system.

To use this module, the memcache PHP extension must be loaded.

Some usage examples of TMemCache are as follows,

  •  $cache=new TMemCache;  // TMemCache may also be loaded as a Prado application module
    •

  •  $cache->init(null);
    •

  •  $cache->add('object',$object);
    •

  •  $object2=$cache->get('object');
    •

    You can configure TMemCache two different ways. If you only need one memcache server you may use the method as follows.

  •  <module id="cache" class="System.Caching.TMemCache" Host="localhost" Port="11211" />
    •

    If you want a more complex configuration, you may use the method as follows.

  •  <module id="cache" classs="System.Caching.TMemCache">
    •

  •      <server Host="localhost" Port="11211" Weight="1" Timeout="300" RetryInterval="15" />
    •

  •      <server Host="anotherhost" Port="11211" Weight="1" Timeout="300" RetryInterval="15" />
    •

  •  </module>
    •

    If loaded, TMemCache will register itself with TApplication as the cache module. It can be accessed via TApplication::getCache().

    TMemCache may be configured in application configuration file as follows

  •  <module id="cache" class="System.Caching.TMemCache" Host="localhost" Port="11211" />
    •
    where Host and Port are configurable properties of TMemCache.

    Automatic compression of values may be used (using zlib extension) by setting Threshold and MinSavings properties. NB : MemCache server(s) must be restarted to apply settings. Require (PECL memcache >= 2.0.0).

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TMemCache.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TCache

    • TCache::add()
      Stores a value identified by a key into cache if the cache does not contain this key.
    • TCache::addValue()
      Stores a value identified by a key into cache if the cache does not contain this key.
    • TCache::delete()
      Deletes a value with the specified key from cache
    • TCache::deleteValue()
      Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.
    • TCache::flush()
      Deletes all values from cache.
    • TCache::generateUniqueKey()
    • TCache::get()
      Retrieves a value from cache with a specified key.
    • TCache::getKeyPrefix()
    • TCache::getPrimaryCache()
    • TCache::getValue()
      Retrieves a value from cache with a specified key.
    • TCache::init()
      Initializes the cache module.
    • TCache::offsetExists()
      Returns whether there is a cache entry with a specified key.
    • TCache::offsetGet()
      Retrieves the value from cache with a specified key.
    • TCache::offsetSet()
      Stores the value identified by a key into cache.
    • TCache::offsetUnset()
      Deletes the value with the specified key from cache This method is required by the interface ArrayAccess.
    • TCache::set()
      Stores a value identified by a key into cache.
    • TCache::setKeyPrefix()
    • TCache::setPrimaryCache()
    • TCache::setValue()
      Stores a value identified by a key in cache.

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TMemCache::__destruct

      __destruct( );

      Remarks

      Destructor.

      Disconnect the memcache server.

      access

      public

      [ Top ]

      TMemCache::addValue

      addValue( string $key, string $value, integer $expire );

      Overrides TCache::addValue() (Stores a value identified by a key into cache if the cache does not contain this key.)

      Parameters

      $key

      the key identifying the value to be cached

      $value

      the value to be cached

      $expire

      the number of seconds in which the cached value will expire. 0 means never expire.

      Returns

      true if the value is successfully stored into cache, false otherwise

      Remarks

      Stores a value identified by a key into cache if the cache does not contain this key.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TMemCache::deleteValue

      deleteValue( string $key );

      Overrides TCache::deleteValue() (Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.)

      Parameters

      $key

      the key of the value to be deleted

      Returns

      if no error happens during deletion

      Remarks

      Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TMemCache::flush

      flush( );

      Overrides TCache::flush() (Deletes all values from cache.)

      Remarks

      Deletes all values from cache.

      Be careful of performing this operation if the cache is shared by multiple applications.

      access

      public

      [ Top ]

      TMemCache::getHost

      getHost( );

      Returns

      host name of the memcache server

      access

      public

      [ Top ]

      TMemCache::getMinSavings

      getMinSavings( );

      Returns

      minimum amount of savings to actually store the value compressed

      access

      public

      [ Top ]

      TMemCache::getPort

      getPort( );

      Returns

      port number of the memcache server

      access

      public

      [ Top ]

      TMemCache::getThreshold

      getThreshold( );

      Returns

      minimum value length before attempting to compress

      access

      public

      [ Top ]

      TMemCache::getValue

      getValue( string $key );

      Overrides TCache::getValue() (Retrieves a value from cache with a specified key.)

      Parameters

      $key

      a unique key identifying the cached value

      Returns

      the value stored in cache, false if the value is not in the cache or expired.

      Remarks

      Retrieves a value from cache with a specified key.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TMemCache::init

      init( TApplication $config, TXmlElement 1 );

      Overrides TCache::init() (Initializes the cache module.)

      Parameters

      1

      configuration for this module, can be null

      $config

      Prado application, can be null

      Remarks

      Initializes this module.

      This method is required by the IModule interface. It makes sure that UniquePrefix has been set, creates a Memcache instance and connects to the memcache server.

      throws

      TConfigurationException if memcache extension is not installed or memcache sever connection fails

      access

      public

      [ Top ]

      TMemCache::setHost

      setHost( string $value );

      Parameters

      $value

      host name of the memcache server

      throws

      TInvalidOperationException if the module is already initialized

      access

      public

      [ Top ]

      TMemCache::setMinSavings

      setMinSavings( float $value );

      Parameters

      $value

      minimum amount of savings to actually store the value compressed

      throws

      TInvalidOperationException if the module is already initialized

      access

      public

      [ Top ]

      TMemCache::setPort

      setPort( integer $value );

      Parameters

      $value

      port number of the memcache server

      throws

      TInvalidOperationException if the module is already initialized

      access

      public

      [ Top ]

      TMemCache::setThreshold

      setThreshold( integer $value );

      Parameters

      $value

      minimum value length before attempting to compress

      throws

      TInvalidOperationException if the module is already initialized

      access

      public

      [ Top ]

      TMemCache::setValue

      setValue( string $key, string $value, integer $expire );

      Overrides TCache::setValue() (Stores a value identified by a key in cache.)

      Parameters

      $key

      the key identifying the value to be cached

      $value

      the value to be cached

      $expire

      the number of seconds in which the cached value will expire. 0 means never expire.

      Returns

      true if the value is successfully stored into cache, false otherwise

      Remarks

      Stores a value identified by a key in cache.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:50 +0200 by phpDocumentor 1.4.3


Docs For Class TSqliteCache

Class TSqliteCache

[line 74]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TCache
            |
            --TSqliteCache
Location: /Caching/TSqliteCache.php

Remarks

TSqliteCache class

TSqliteCache implements a cache application module based on SQLite database.

THIS CLASS IS DEPRECATED since it relies on the sqlite PHP extension, that is no longer loaded by default since PHP 5.1. You are discouraged from using it: use TDbCache instead.

Since PRADO v3.1.0, a new DB-based cache module called TDbCache is provided. If you have PDO extension installed, you may consider using the new cache module instead as it allows you to use different database to store the cached data.

The database file is specified by the DbFile property. If not set, the database file will be created under the system state path. If the specified database file does not exist, it will be created automatically. Make sure the directory containing the specified DB file and the file itself is writable by the Web server process.

The following basic cache operations are implemented:

  • get : retrieve the value with a key (if any) from cache
  • set : store the value with a key into cache
  • add : store the value only if cache does not have this key
  • delete : delete the value with the specified key from cache
  • flush : delete all values from cache
Each value is associated with an expiration time. The get operation ensures that any expired value will not be returned. The expiration time by the number of seconds. A expiration time 0 represents never expire.

By definition, cache does not ensure the existence of a value even if it never expires. Cache is not meant to be an persistent storage.

Do not use the same database file for multiple applications using TSqliteCache. Also note, cache is shared by all user sessions of an application.

Some usage examples of TSqliteCache are as follows,

  •  $cache=new TSqliteCache;  // TSqliteCache may also be loaded as a Prado application module
    •

  •  $cache->setDbFile($dbFilePath);
    •

  •  $cache->init(null);
    •

  •  $cache->add('object',$object);
    •

  •  $object2=$cache->get('object');
    •

    If loaded, TSqliteCache will register itself with TApplication as the cache module. It can be accessed via TApplication::getCache().

    TSqliteCache may be configured in application configuration file as follows

  •  <module id="cache" class="System.Caching.TSqliteCache" DbFile="Application.Data.site" />
    •
    where DbFile is a property specifying the location of the SQLite DB file (in the namespace format).

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TSqliteCache.php 3058 2011-11-09 22:12:14Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    • CACHE_TABLE = 'cache'
      name of the table storing cache data
    • DB_FILE_EXT = '.db'
      extension of the db file name

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TCache

    • TCache::add()
      Stores a value identified by a key into cache if the cache does not contain this key.
    • TCache::addValue()
      Stores a value identified by a key into cache if the cache does not contain this key.
    • TCache::delete()
      Deletes a value with the specified key from cache
    • TCache::deleteValue()
      Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.
    • TCache::flush()
      Deletes all values from cache.
    • TCache::generateUniqueKey()
    • TCache::get()
      Retrieves a value from cache with a specified key.
    • TCache::getKeyPrefix()
    • TCache::getPrimaryCache()
    • TCache::getValue()
      Retrieves a value from cache with a specified key.
    • TCache::init()
      Initializes the cache module.
    • TCache::offsetExists()
      Returns whether there is a cache entry with a specified key.
    • TCache::offsetGet()
      Retrieves the value from cache with a specified key.
    • TCache::offsetSet()
      Stores the value identified by a key into cache.
    • TCache::offsetUnset()
      Deletes the value with the specified key from cache This method is required by the interface ArrayAccess.
    • TCache::set()
      Stores a value identified by a key into cache.
    • TCache::setKeyPrefix()
    • TCache::setPrimaryCache()
    • TCache::setValue()
      Stores a value identified by a key in cache.

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TSqliteCache::__destruct

      __destruct( );

      Remarks

      Destructor.

      Disconnect the db connection.

      access

      public

      [ Top ]

      TSqliteCache::addValue

      addValue( string $key, string $value, integer $expire );

      Overrides TCache::addValue() (Stores a value identified by a key into cache if the cache does not contain this key.)

      Parameters

      $key

      the key identifying the value to be cached

      $value

      the value to be cached

      $expire

      the number of seconds in which the cached value will expire. 0 means never expire.

      Returns

      true if the value is successfully stored into cache, false otherwise

      Remarks

      Stores a value identified by a key into cache if the cache does not contain this key.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TSqliteCache::deleteValue

      deleteValue( string $key );

      Overrides TCache::deleteValue() (Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.)

      Parameters

      $key

      the key of the value to be deleted

      Returns

      if no error happens during deletion

      Remarks

      Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TSqliteCache::flush

      flush( );

      Overrides TCache::flush() (Deletes all values from cache.)

      Remarks

      Deletes all values from cache.

      Be careful of performing this operation if the cache is shared by multiple applications.

      access

      public

      [ Top ]

      TSqliteCache::getDbFile

      getDbFile( );

      Returns

      database file path (in namespace form)

      access

      public

      [ Top ]

      TSqliteCache::getValue

      getValue( string $key );

      Overrides TCache::getValue() (Retrieves a value from cache with a specified key.)

      Parameters

      $key

      a unique key identifying the cached value

      Returns

      the value stored in cache, false if the value is not in the cache or expired.

      Remarks

      Retrieves a value from cache with a specified key.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TSqliteCache::init

      init( TXmlElement $config );

      Overrides TCache::init() (Initializes the cache module.)

      Parameters

      $config

      configuration for this module, can be null

      Remarks

      Initializes this module.

      This method is required by the IModule interface. It checks if the DbFile property is set, and creates a SQLiteDatabase instance for it. The database or the cache table does not exist, they will be created. Expired values are also deleted.

      throws

      TConfigurationException if sqlite extension is not installed, DbFile is set invalid, or any error happens during creating database or cache table.

      access

      public

      [ Top ]

      TSqliteCache::setDbFile

      setDbFile( string $value );

      Parameters

      $value

      database file path (in namespace form)

      throws

      TConfigurationException if the file is not in proper namespace format

      throws

      TInvalidOperationException if the module is already initialized

      access

      public

      [ Top ]

      TSqliteCache::setValue

      setValue( string $key, string $value, integer $expire );

      Overrides TCache::setValue() (Stores a value identified by a key in cache.)

      Parameters

      $key

      the key identifying the value to be cached

      $value

      the value to be cached

      $expire

      the number of seconds in which the cached value will expire. 0 means never expire.

      Returns

      true if the value is successfully stored into cache, false otherwise

      Remarks

      Stores a value identified by a key in cache.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

    Variable Detail

    Class Constant Detail

    • CACHE_TABLE = 'cache' [line 79]

      • Remarks

      name of the table storing cache data

    • DB_FILE_EXT = '.db' [line 83]

      • Remarks

      extension of the db file name

    Documentation generated on Mon, 25 Jun 2012 14:45:23 +0200 by phpDocumentor 1.4.3


Docs For Class TXCache

Class TXCache

[line 44]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TCache
            |
            --TXCache
Location: /Caching/TXCache.php

Remarks

TXCache class

TXCache implements a cache application module based on xcache.

By definition, cache does not ensure the existence of a value even if it never expires. Cache is not meant to be an persistent storage.

To use this module, the xcache PHP extension must be loaded and configured in the php.ini.

Some usage examples of TXCache are as follows,

  •  $cache=new TXCache;  // TXCache may also be loaded as a Prado application module
    •

  •  $cache->init(null);
    •

  •  $cache->add('object',$object);
    •

  •  $object2=$cache->get('object');
    •

    If loaded, TXCache will register itself with TApplication as the cache module. It can be accessed via TApplication::getCache().

    TXCache may be configured in application configuration file as follows

  •  <module id="cache" class="System.Caching.TXCache" />
    •

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: TXCache.php 1994 2007-06-11 16:02:28Z knut $

    since

    3.1.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TCache

    • TCache::add()
      Stores a value identified by a key into cache if the cache does not contain this key.
    • TCache::addValue()
      Stores a value identified by a key into cache if the cache does not contain this key.
    • TCache::delete()
      Deletes a value with the specified key from cache
    • TCache::deleteValue()
      Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.
    • TCache::flush()
      Deletes all values from cache.
    • TCache::generateUniqueKey()
    • TCache::get()
      Retrieves a value from cache with a specified key.
    • TCache::getKeyPrefix()
    • TCache::getPrimaryCache()
    • TCache::getValue()
      Retrieves a value from cache with a specified key.
    • TCache::init()
      Initializes the cache module.
    • TCache::offsetExists()
      Returns whether there is a cache entry with a specified key.
    • TCache::offsetGet()
      Retrieves the value from cache with a specified key.
    • TCache::offsetSet()
      Stores the value identified by a key into cache.
    • TCache::offsetUnset()
      Deletes the value with the specified key from cache This method is required by the interface ArrayAccess.
    • TCache::set()
      Stores a value identified by a key into cache.
    • TCache::setKeyPrefix()
    • TCache::setPrimaryCache()
    • TCache::setValue()
      Stores a value identified by a key in cache.

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TXCache::addValue

      addValue( string $key, string $value, integer $expire );

      Overrides TCache::addValue() (Stores a value identified by a key into cache if the cache does not contain this key.)

      Parameters

      $key

      the key identifying the value to be cached

      $value

      the value to be cached

      $expire

      the number of seconds in which the cached value will expire. 0 means never expire.

      Returns

      true if the value is successfully stored into cache, false otherwise

      Remarks

      Stores a value identified by a key into cache if the cache does not contain this key.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TXCache::deleteValue

      deleteValue( string $key );

      Overrides TCache::deleteValue() (Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.)

      Parameters

      $key

      the key of the value to be deleted

      Returns

      if no error happens during deletion

      Remarks

      Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TXCache::flush

      flush( );

      Overrides TCache::flush() (Deletes all values from cache.)

      Remarks

      Deletes all values from cache.

      Be careful of performing this operation if the cache is shared by multiple applications.

      access

      public

      [ Top ]

      TXCache::getValue

      getValue( string $key );

      Overrides TCache::getValue() (Retrieves a value from cache with a specified key.)

      Parameters

      $key

      a unique key identifying the cached value

      Returns

      the value stored in cache, false if the value is not in the cache or expired.

      Remarks

      Retrieves a value from cache with a specified key.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

      TXCache::init

      init( TXmlElement $config );

      Overrides TCache::init() (Initializes the cache module.)

      Parameters

      $config

      configuration for this module, can be null

      Remarks

      Initializes this module.

      This method is required by the IModule interface.

      throws

      TConfigurationException if xcache extension is not installed or not started, check your php.ini

      access

      public

      [ Top ]

      TXCache::setValue

      setValue( string $key, string $value, integer $expire );

      Overrides TCache::setValue() (Stores a value identified by a key in cache.)

      Parameters

      $key

      the key identifying the value to be cached

      $value

      the value to be cached

      $expire

      the number of seconds in which the cached value will expire. 0 means never expire.

      Returns

      true if the value is successfully stored into cache, false otherwise

      Remarks

      Stores a value identified by a key in cache.

      This is the implementation of the method declared in the parent class.

      access

      protected

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:52 +0200 by phpDocumentor 1.4.3


Package System.Web Element Index

Element index for package System.Web

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a c d e f g h i k l n o p r s t v w _
top
_
$_constructRules | in file TUrlMapping.php, variable TUrlMapping::$_constructRules
$_patterns | in file TUrlMapping.php, variable TUrlMapping::$_patterns
_close in file THttpSession.php, method THttpSession::_close()
Session close handler.
_destroy in file THttpSession.php, method THttpSession::_destroy()
Session destroy handler.
_destroy in file TCacheHttpSession.php, method TCacheHttpSession::_destroy()
Session destroy handler.
_gc in file THttpSession.php, method THttpSession::_gc()
Session GC (garbage collection) handler.
_open in file THttpSession.php, method THttpSession::_open()
Session open handler.
_read in file TCacheHttpSession.php, method TCacheHttpSession::_read()
Session read handler.
_read in file THttpSession.php, method THttpSession::_read()
Session read handler.
_write in file TCacheHttpSession.php, method TCacheHttpSession::_write()
Session write handler.
_write in file THttpSession.php, method THttpSession::_write()
Session write handler.
__construct in file THttpRequest.php, method TUri::__construct()
Constructor.
__construct in file TUrlMapping.php, method TUrlMappingPattern::__construct()
Constructor.
__construct in file THttpRequest.php, method THttpCookie::__construct()
Constructor.
__construct in file THttpSession.php, method TSessionIterator::__construct()
Constructor.
__construct in file THttpResponseAdapter.php, method THttpResponseAdapter::__construct()
Constructor. Attach a response to be adapted.
__construct in file THttpRequest.php, method THttpCookieCollection::__construct()
Constructor.
__destruct in file THttpResponse.php, method THttpResponse::__destruct()
Destructor.
top
a
add in file THttpSession.php, method THttpSession::add()
Adds a session variable.
add in file THttpRequest.php, method THttpRequest::add()
Adds an item into the request.
addCookie in file THttpResponse.php, method THttpResponse::addCookie()
Sends a cookie.
Allow | in file THttpSession.php, class constant THttpSessionCookieMode::Allow
appendHeader in file THttpResponse.php, method THttpResponse::appendHeader()
Sends a header.
appendLog in file THttpResponse.php, method THttpResponse::appendLog()
Writes a log message into error log.
applySecureConnectionPrefix in file TUrlMapping.php, method TUrlMappingPattern::applySecureConnectionPrefix()
Apply behavior of SecureConnection property by conditionaly prefixing URL with THttpRequest::getBaseUrl()
Automatic in file TUrlMapping.php, class constant TUrlMappingPatternSecureConnection::Automatic
Keep current SecureConnection status
top
c
calculateKey | in file TCacheHttpSession.php, method TCacheHttpSession::calculateKey()
CGIFIX__PATH_INFO | in file THttpRequest.php, class constant THttpRequest::CGIFIX__PATH_INFO
CGIFIX__SCRIPT_NAME | in file THttpRequest.php, class constant THttpRequest::CGIFIX__SCRIPT_NAME
clear in file THttpResponse.php, method THttpResponse::clear()
Clears any existing buffered content.
clear in file THttpSession.php, method THttpSession::clear()
Removes all session variables
clear in file THttpRequest.php, method THttpRequest::clear()
Removes all items in the request.
close in file THttpSession.php, method THttpSession::close()
Ends the current session and store session data.
constructUrl in file TUrlMapping.php, method TUrlMappingPattern::constructUrl()
Constructs a URL using this pattern.
constructUrl in file TUrlMapping.php, method TUrlMapping::constructUrl()
Constructs a URL that can be recognized by PRADO.
constructUrl in file TUrlManager.php, method TUrlManager::constructUrl()
Constructs a URL that can be recognized by PRADO.
constructUrl in file THttpRequest.php, method THttpRequest::constructUrl()
Constructs a URL that can be recognized by PRADO.
contains | in file THttpSession.php, method THttpSession::contains()
contains | in file THttpRequest.php, method THttpRequest::contains()
copyDirectory in file TAssetManager.php, method TAssetManager::copyDirectory()
Copies a directory recursively as another.
copyFile in file TAssetManager.php, method TAssetManager::copyFile()
Copies a file to a directory.
count in file THttpSession.php, method THttpSession::count()
Returns the number of items in the session.
count in file THttpRequest.php, method THttpRequest::count()
Returns the number of items in the request.
createHtmlWriter in file THttpResponse.php, method THttpResponse::createHtmlWriter()
Creates a new instance of HTML writer.
createNewHtmlWriter in file THttpResponse.php, method THttpResponse::createNewHtmlWriter()
Create a new html writer instance.
createNewHtmlWriter in file THttpResponseAdapter.php, method THttpResponseAdapter::createNewHtmlWriter()
This method is invoked when a new HtmlWriter needs to be created.
current in file THttpSession.php, method TSessionIterator::current()
Returns the current array element.
top
d
DEFAULT_BASEPATH in file TAssetManager.php, class constant TAssetManager::DEFAULT_BASEPATH
Default web accessible base path for storing private files
DEFAULT_CHARSET | in file THttpResponse.php, class constant THttpResponse::DEFAULT_CHARSET
DEFAULT_CONTENTTYPE | in file THttpResponse.php, class constant THttpResponse::DEFAULT_CONTENTTYPE
deployTarFile in file TAssetManager.php, method TAssetManager::deployTarFile()
Extracts the tar file to the destination directory.
destroy in file THttpSession.php, method THttpSession::destroy()
Destroys all data registered to a session.
Disable in file TUrlMapping.php, class constant TUrlMappingPatternSecureConnection::Disable
Force use unsecured connection
DisableIfSecure in file TUrlMapping.php, class constant TUrlMappingPatternSecureConnection::DisableIfSecure
Force use unsecured connection, if in secured mode
top
e
Enable in file TUrlMapping.php, class constant TUrlMappingPatternSecureConnection::Enable
Force use secured connection
EnableIfNotSecure in file TUrlMapping.php, class constant TUrlMappingPatternSecureConnection::EnableIfNotSecure
Force use secured connection, if in unsecured mode
ensureContentTypeHeaderSent in file THttpResponse.php, method THttpResponse::ensureContentTypeHeaderSent()
Ensures that the HTTP header with the status code and status reason are sent
ensureHeadersSent in file THttpResponse.php, method THttpResponse::ensureHeadersSent()
Ensures that HTTP response and content-type headers are sent
ensureHttpHeaderSent in file THttpResponse.php, method THttpResponse::ensureHttpHeaderSent()
Ensures that the HTTP header with the status code and status reason are sent
top
f
findCookieByName in file THttpRequest.php, method THttpCookieCollection::findCookieByName()
Finds the cookie with the specified name.
flush in file THttpResponse.php, method THttpResponse::flush()
Flush the response contents and headers.
flushContent in file THttpResponseAdapter.php, method THttpResponseAdapter::flushContent()
This method is invoked when the response flushes the content and headers.
flushContent in file THttpResponse.php, method THttpResponse::flushContent()
Outputs the buffered content, sends content-type and charset header.
top
g
Get | in file THttpRequest.php, class constant THttpRequestUrlFormat::Get
getAbsoluteApplicationUrl | in file THttpRequest.php, method THttpRequest::getAbsoluteApplicationUrl()
getAcceptTypes | in file THttpRequest.php, method THttpRequest::getAcceptTypes()
getAdapter | in file THttpResponse.php, method THttpResponse::getAdapter()
getApplicationFilePath | in file THttpRequest.php, method THttpRequest::getApplicationFilePath()
getApplicationUrl | in file THttpRequest.php, method THttpRequest::getApplicationUrl()
getAutoStart | in file THttpSession.php, method THttpSession::getAutoStart()
getBasePath | in file TAssetManager.php, method TAssetManager::getBasePath()
getBaseUrl | in file TAssetManager.php, method TAssetManager::getBaseUrl()
getBaseUrl | in file THttpRequest.php, method THttpRequest::getBaseUrl()
getBrowser | in file THttpRequest.php, method THttpRequest::getBrowser()
getBufferOutput | in file THttpResponse.php, method THttpResponse::getBufferOutput()
getCache | in file TCacheHttpSession.php, method TCacheHttpSession::getCache()
getCacheControl | in file THttpResponse.php, method THttpResponse::getCacheControl()
getCacheExpire | in file THttpResponse.php, method THttpResponse::getCacheExpire()
getCacheModuleID | in file TCacheHttpSession.php, method TCacheHttpSession::getCacheModuleID()
getCaseSensitive | in file TUrlMapping.php, method TUrlMappingPattern::getCaseSensitive()
getCgiFix | in file THttpRequest.php, method THttpRequest::getCgiFix()
getCharset | in file THttpResponse.php, method THttpResponse::getCharset()
getConfigFile | in file TUrlMapping.php, method TUrlMapping::getConfigFile()
getContents in file THttpResponse.php, method THttpResponse::getContents()
Returns the content in the output buffer.
getContentType | in file THttpRequest.php, method THttpRequest::getContentType()
getContentType | in file THttpResponse.php, method THttpResponse::getContentType()
getCookie | in file THttpSession.php, method THttpSession::getCookie()
getCookieMode | in file THttpSession.php, method THttpSession::getCookieMode()
getCookies | in file THttpResponse.php, method THttpResponse::getCookies()
getCookies | in file THttpRequest.php, method THttpRequest::getCookies()
getCount | in file THttpSession.php, method THttpSession::getCount()
getCount | in file THttpRequest.php, method THttpRequest::getCount()
getDefaultMappingClass | in file TUrlMapping.php, method TUrlMapping::getDefaultMappingClass()
getDomain | in file THttpRequest.php, method THttpCookie::getDomain()
getEnableCookieValidation | in file THttpRequest.php, method THttpRequest::getEnableCookieValidation()
getEnableCustomUrl in file TUrlMapping.php, method TUrlMapping::getEnableCustomUrl()
Returns a value indicating whether to enable custom constructUrl.
getEnableCustomUrl in file TUrlMapping.php, method TUrlMappingPattern::getEnableCustomUrl()
Returns a value indicating whether to use this pattern to construct URL.
getEnvironmentVariables | in file THttpRequest.php, method THttpRequest::getEnvironmentVariables()
getExpire | in file THttpRequest.php, method THttpCookie::getExpire()
getFragment | in file THttpRequest.php, method TUri::getFragment()
getGCProbability | in file THttpSession.php, method THttpSession::getGCProbability()
getHasAdapter | in file THttpResponse.php, method THttpResponse::getHasAdapter()
getHeaders | in file THttpRequest.php, method THttpRequest::getHeaders()
getHeaders | in file THttpResponse.php, method THttpResponse::getHeaders()
getHost | in file THttpRequest.php, method TUri::getHost()
getHtmlWriterType | in file THttpResponse.php, method THttpResponse::getHtmlWriterType()
getHttpOnly | in file THttpRequest.php, method THttpCookie::getHttpOnly()
getHttpProtocolVersion | in file THttpRequest.php, method THttpRequest::getHttpProtocolVersion()
getID | in file THttpSession.php, method THttpSession::getID()
getID | in file THttpRequest.php, method THttpRequest::getID()
getIsSecureConnection | in file THttpRequest.php, method THttpRequest::getIsSecureConnection()
getIsStarted | in file THttpSession.php, method THttpSession::getIsStarted()
getIsWildCardPattern | in file TUrlMapping.php, method TUrlMappingPattern::getIsWildCardPattern()
getIterator in file THttpRequest.php, method THttpRequest::getIterator()
Returns an iterator for traversing the items in the list.
getIterator in file THttpSession.php, method THttpSession::getIterator()
Returns an iterator for traversing the session variables.
getKeyPrefix | in file TCacheHttpSession.php, method TCacheHttpSession::getKeyPrefix()
getKeys | in file THttpSession.php, method THttpSession::getKeys()
getKeys | in file THttpRequest.php, method THttpRequest::getKeys()
getManager | in file TUrlMapping.php, method TUrlMappingPattern::getManager()
getMatchingPattern | in file TUrlMapping.php, method TUrlMapping::getMatchingPattern()
getName | in file THttpRequest.php, method THttpCookie::getName()
getParameterizedPattern in file TUrlMapping.php, method TUrlMappingPattern::getParameterizedPattern()
Substitute the parameter key value pairs as named groupings in the regular expression matching pattern.
getParameters | in file TUrlMapping.php, method TUrlMappingPattern::getParameters()
getPassword | in file THttpRequest.php, method TUri::getPassword()
getPath | in file THttpRequest.php, method TUri::getPath()
getPath | in file THttpRequest.php, method THttpCookie::getPath()
getPathInfo | in file THttpRequest.php, method THttpRequest::getPathInfo()
getPattern | in file TUrlMapping.php, method TUrlMappingPattern::getPattern()
getPatternMatches in file TUrlMapping.php, method TUrlMappingPattern::getPatternMatches()
Uses URL pattern (or full regular expression if available) to match the given url path.
getPort | in file THttpRequest.php, method TUri::getPort()
getPublished | in file TAssetManager.php, method TAssetManager::getPublished()
getPublishedPath in file TAssetManager.php, method TAssetManager::getPublishedPath()
Returns the published path of a file path.
getPublishedUrl in file TAssetManager.php, method TAssetManager::getPublishedUrl()
Returns the URL of a published file path.
getQuery | in file THttpRequest.php, method TUri::getQuery()
getQueryString | in file THttpRequest.php, method THttpRequest::getQueryString()
getRegularExpression | in file TUrlMapping.php, method TUrlMappingPattern::getRegularExpression()
getRequestResolved | in file THttpRequest.php, method THttpRequest::getRequestResolved()
getRequestType | in file THttpRequest.php, method THttpRequest::getRequestType()
getRequestUri | in file THttpRequest.php, method THttpRequest::getRequestUri()
getResponse | in file THttpResponseAdapter.php, method THttpResponseAdapter::getResponse()
getSavePath | in file THttpSession.php, method THttpSession::getSavePath()
getScheme | in file THttpRequest.php, method TUri::getScheme()
getSecure | in file THttpRequest.php, method THttpCookie::getSecure()
getSecureConnection | in file TUrlMapping.php, method TUrlMappingPattern::getSecureConnection()
getServerName | in file THttpRequest.php, method THttpRequest::getServerName()
getServerPort | in file THttpRequest.php, method THttpRequest::getServerPort()
getServerVariables | in file THttpRequest.php, method THttpRequest::getServerVariables()
getServiceID | in file TUrlMapping.php, method TUrlMappingPattern::getServiceID()
getServiceID | in file THttpRequest.php, method THttpRequest::getServiceID()
getServiceParameter | in file TUrlMapping.php, method TUrlMappingPattern::getServiceParameter()
getServiceParameter | in file THttpRequest.php, method THttpRequest::getServiceParameter()
getSessionID | in file THttpSession.php, method THttpSession::getSessionID()
getSessionName | in file THttpSession.php, method THttpSession::getSessionName()
getStatusCode | in file THttpResponse.php, method THttpResponse::getStatusCode()
getStatusReason | in file THttpResponse.php, method THttpResponse::getStatusReason()
getTimeout | in file THttpSession.php, method THttpSession::getTimeout()
getUploadedFiles | in file THttpRequest.php, method THttpRequest::getUploadedFiles()
getUri | in file THttpRequest.php, method TUri::getUri()
getUrl | in file THttpRequest.php, method THttpRequest::getUrl()
getUrlFormat | in file THttpRequest.php, method THttpRequest::getUrlFormat()
getUrlFormat | in file TUrlMapping.php, method TUrlMappingPattern::getUrlFormat()
getUrlManager | in file THttpRequest.php, method THttpRequest::getUrlManager()
getUrlManagerModule | in file THttpRequest.php, method THttpRequest::getUrlManagerModule()
getUrlParamSeparator | in file THttpRequest.php, method THttpRequest::getUrlParamSeparator()
getUrlParamSeparator | in file TUrlMapping.php, method TUrlMappingPattern::getUrlParamSeparator()
getUrlPrefix | in file TUrlMapping.php, method TUrlMapping::getUrlPrefix()
getUrlReferrer | in file THttpRequest.php, method THttpRequest::getUrlReferrer()
getUseCustomStorage | in file THttpSession.php, method THttpSession::getUseCustomStorage()
getUser | in file THttpRequest.php, method TUri::getUser()
getUserAgent | in file THttpRequest.php, method THttpRequest::getUserAgent()
getUserHost | in file THttpRequest.php, method THttpRequest::getUserHost()
getUserHostAddress | in file THttpRequest.php, method THttpRequest::getUserHostAddress()
getUserLanguages in file THttpRequest.php, method THttpRequest::getUserLanguages()
Returns a list of user preferred languages.
getUseTransparentSessionID | in file THttpSession.php, method THttpSession::getUseTransparentSessionID()
getValue | in file THttpRequest.php, method THttpCookie::getValue()
top
h
hash in file TAssetManager.php, method TAssetManager::hash()
Generate a CRC32 hash for the directory path. Collisions are higher than MD5 but generates a much smaller hash string.
htmlDecode in file THttpUtility.php, method THttpUtility::htmlDecode()
HTML-decodes a string.
htmlEncode in file THttpUtility.php, method THttpUtility::htmlEncode()
HTML-encodes a string.
htmlStrip in file THttpUtility.php, method THttpUtility::htmlStrip()
This method strips the following characters from a string:
httpRedirect in file THttpResponseAdapter.php, method THttpResponseAdapter::httpRedirect()
This method is invoked when the response is to redirect to another page.
httpRedirect in file THttpResponse.php, method THttpResponse::httpRedirect()
Redirect the browser to another URL and exists the current application.
top
i
init in file TAssetManager.php, method TAssetManager::init()
Initializes the module.
init in file THttpResponse.php, method THttpResponse::init()
Initializes the module.
init in file THttpSession.php, method THttpSession::init()
Initializes the module.
init in file THttpRequest.php, method THttpRequest::init()
Initializes the module.
init in file TUrlMapping.php, method TUrlMappingPattern::init()
Initializes the pattern.
init in file TUrlMapping.php, method TUrlMapping::init()
Initializes this module.
init in file TCacheHttpSession.php, method TCacheHttpSession::init()
Initializes the module.
insertAt in file THttpRequest.php, method THttpCookieCollection::insertAt()
Inserts an item at the specified position.
itemAt in file THttpRequest.php, method THttpRequest::itemAt()
Returns the item with the specified key.
itemAt | in file THttpRequest.php, method THttpCookieCollection::itemAt()
itemAt in file THttpSession.php, method THttpSession::itemAt()
Returns the session variable value with the session variable name.
top
k
key in file THttpSession.php, method TSessionIterator::key()
Returns the key of the current array element.
top
l
loadConfigFile in file TUrlMapping.php, method TUrlMapping::loadConfigFile()
Initialize the module from configuration file.
loadUrlMappings in file TUrlMapping.php, method TUrlMapping::loadUrlMappings()
Load and configure each url mapping pattern.
top
n
next in file THttpSession.php, method TSessionIterator::next()
Moves the internal pointer to the next array element.
None | in file THttpSession.php, class constant THttpSessionCookieMode::None
top
o
offsetExists in file THttpRequest.php, method THttpRequest::offsetExists()
Returns whether there is an element at the specified offset.
offsetExists in file THttpSession.php, method THttpSession::offsetExists()
This method is required by the interface ArrayAccess.
offsetGet in file THttpRequest.php, method THttpRequest::offsetGet()
Returns the element at the specified offset.
offsetGet in file THttpSession.php, method THttpSession::offsetGet()
This method is required by the interface ArrayAccess.
offsetSet in file THttpRequest.php, method THttpRequest::offsetSet()
Sets the element at the specified offset.
offsetSet in file THttpSession.php, method THttpSession::offsetSet()
This method is required by the interface ArrayAccess.
offsetUnset in file THttpRequest.php, method THttpRequest::offsetUnset()
Unsets the element at the specified offset.
offsetUnset in file THttpSession.php, method THttpSession::offsetUnset()
This method is required by the interface ArrayAccess.
Only | in file THttpSession.php, class constant THttpSessionCookieMode::Only
open in file THttpSession.php, method THttpSession::open()
Starts the session if it has not started yet.
top
p
parseUrl in file TUrlMapping.php, method TUrlMapping::parseUrl()
Parses the request URL and returns an array of input parameters.
parseUrl in file TUrlManager.php, method TUrlManager::parseUrl()
Parses the request URL and returns an array of input parameters.
parseUrl in file THttpRequest.php, method THttpRequest::parseUrl()
Parses the request URL and returns an array of input parameters (excluding GET variables).
Path | in file THttpRequest.php, class constant THttpRequestUrlFormat::Path
publishFilePath in file TAssetManager.php, method TAssetManager::publishFilePath()
Publishes a file or a directory (recursively).
publishTarFile in file TAssetManager.php, method TAssetManager::publishTarFile()
Publish a tar file by extracting its contents to the assets directory.
top
r
redirect in file THttpResponse.php, method THttpResponse::redirect()
Redirects the browser to the specified URL.
regenerate in file THttpSession.php, method THttpSession::regenerate()
Update the current session id with a newly generated one
reload in file THttpResponse.php, method THttpResponse::reload()
Reloads the current page.
remove in file THttpRequest.php, method THttpRequest::remove()
Removes an item from the request by its key.
remove in file THttpSession.php, method THttpSession::remove()
Removes a session variable.
removeAt in file THttpRequest.php, method THttpCookieCollection::removeAt()
Removes an item at the specified position.
removeCookie in file THttpResponse.php, method THttpResponse::removeCookie()
Deletes a cookie.
resolveRequest in file THttpRequest.php, method THttpRequest::resolveRequest()
Resolves the requested service.
rewind in file THttpSession.php, method TSessionIterator::rewind()
Rewinds internal array pointer.
top
s
sendContentTypeHeader in file THttpResponse.php, method THttpResponse::sendContentTypeHeader()
Sends content type header with optional charset.
sendHttpHeader in file THttpResponse.php, method THttpResponse::sendHttpHeader()
Send the HTTP header with the status code (defaults to 200) and status reason (defaults to OK)
setAdapter | in file THttpResponse.php, method THttpResponse::setAdapter()
setAutoStart | in file THttpSession.php, method THttpSession::setAutoStart()
setBasePath in file TAssetManager.php, method TAssetManager::setBasePath()
Sets the root directory storing published asset files.
setBaseUrl | in file TAssetManager.php, method TAssetManager::setBaseUrl()
setBufferOutput | in file THttpResponse.php, method THttpResponse::setBufferOutput()
setCacheControl | in file THttpResponse.php, method THttpResponse::setCacheControl()
setCacheExpire | in file THttpResponse.php, method THttpResponse::setCacheExpire()
setCacheModuleID | in file TCacheHttpSession.php, method TCacheHttpSession::setCacheModuleID()
setCaseSensitive | in file TUrlMapping.php, method TUrlMappingPattern::setCaseSensitive()
setCgiFix in file THttpRequest.php, method THttpRequest::setCgiFix()
Enable this, if you're using PHP via CGI with php.ini setting "cgi.fix_pathinfo=1"
setCharset | in file THttpResponse.php, method THttpResponse::setCharset()
setConfigFile | in file TUrlMapping.php, method TUrlMapping::setConfigFile()
setContentType | in file THttpResponse.php, method THttpResponse::setContentType()
setCookieMode | in file THttpSession.php, method THttpSession::setCookieMode()
setDefaultMappingClass in file TUrlMapping.php, method TUrlMapping::setDefaultMappingClass()
Sets the default class of URL mapping patterns.
setDomain | in file THttpRequest.php, method THttpCookie::setDomain()
setEnableCookieValidation | in file THttpRequest.php, method THttpRequest::setEnableCookieValidation()
setEnableCustomUrl in file TUrlMapping.php, method TUrlMappingPattern::setEnableCustomUrl()
Sets a value indicating whether to enable custom constructUrl using this pattern
setEnableCustomUrl in file TUrlMapping.php, method TUrlMapping::setEnableCustomUrl()
Sets a value indicating whether to enable custom constructUrl.
setExpire | in file THttpRequest.php, method THttpCookie::setExpire()
setGCProbability | in file THttpSession.php, method THttpSession::setGCProbability()
setHtmlWriterType | in file THttpResponse.php, method THttpResponse::setHtmlWriterType()
setHttpOnly | in file THttpRequest.php, method THttpCookie::setHttpOnly()
setID | in file THttpSession.php, method THttpSession::setID()
setID | in file THttpRequest.php, method THttpRequest::setID()
setKeyPrefix | in file TCacheHttpSession.php, method TCacheHttpSession::setKeyPrefix()
setName | in file THttpRequest.php, method THttpCookie::setName()
setParameters | in file TUrlMapping.php, method TUrlMappingPattern::setParameters()
setPath | in file THttpRequest.php, method THttpCookie::setPath()
setPattern | in file TUrlMapping.php, method TUrlMappingPattern::setPattern()
setPublished | in file TAssetManager.php, method TAssetManager::setPublished()
setRegularExpression | in file TUrlMapping.php, method TUrlMappingPattern::setRegularExpression()
setSavePath | in file THttpSession.php, method THttpSession::setSavePath()
setSecure | in file THttpRequest.php, method THttpCookie::setSecure()
setSecureConnection | in file TUrlMapping.php, method TUrlMappingPattern::setSecureConnection()
setServiceID | in file TUrlMapping.php, method TUrlMappingPattern::setServiceID()
setServiceID in file THttpRequest.php, method THttpRequest::setServiceID()
Sets the requested service ID.
setServiceParameter in file THttpRequest.php, method THttpRequest::setServiceParameter()
Sets the requested service parameter.
setServiceParameter | in file TUrlMapping.php, method TUrlMappingPattern::setServiceParameter()
setSessionID | in file THttpSession.php, method THttpSession::setSessionID()
setSessionName | in file THttpSession.php, method THttpSession::setSessionName()
setStatusCode in file THttpResponse.php, method THttpResponse::setStatusCode()
Set the HTTP status code for the response.
setTimeout | in file THttpSession.php, method THttpSession::setTimeout()
setUrlFormat in file THttpRequest.php, method THttpRequest::setUrlFormat()
Sets the format of URLs constructed and interpretted by the request module.
setUrlFormat in file TUrlMapping.php, method TUrlMappingPattern::setUrlFormat()
Sets the format of URLs constructed and interpreted by this pattern.
setUrlManager in file THttpRequest.php, method THttpRequest::setUrlManager()
Sets the URL manager module.
setUrlParamSeparator | in file TUrlMapping.php, method TUrlMappingPattern::setUrlParamSeparator()
setUrlParamSeparator | in file THttpRequest.php, method THttpRequest::setUrlParamSeparator()
setUrlPrefix | in file TUrlMapping.php, method TUrlMapping::setUrlPrefix()
setUseCustomStorage | in file THttpSession.php, method THttpSession::setUseCustomStorage()
setUseTransparentSessionID | in file THttpSession.php, method THttpSession::setUseTransparentSessionID()
setValue | in file THttpRequest.php, method THttpCookie::setValue()
stripSlashes in file THttpRequest.php, method THttpRequest::stripSlashes()
Strips slashes from input data.
supportCustomUrl | in file TUrlMapping.php, method TUrlMappingPattern::supportCustomUrl()
top
t
TAssetManager in file TAssetManager.php, class TAssetManager
TAssetManager class
TCacheHttpSession in file TCacheHttpSession.php, class TCacheHttpSession
TCacheHttpSession class
THttpCookie in file THttpRequest.php, class THttpCookie
THttpCookie class.
THttpCookieCollection in file THttpRequest.php, class THttpCookieCollection
THttpCookieCollection class.
THttpRequest in file THttpRequest.php, class THttpRequest
THttpRequest class
THttpRequestUrlFormat in file THttpRequest.php, class THttpRequestUrlFormat
THttpRequestUrlFormat class.
THttpResponse in file THttpResponse.php, class THttpResponse
THttpResponse class
THttpResponseAdapter in file THttpResponseAdapter.php, class THttpResponseAdapter
THttpResponseAdapter class.
THttpSession in file THttpSession.php, class THttpSession
THttpSession class
THttpSessionCookieMode in file THttpSession.php, class THttpSessionCookieMode
THttpSessionCookieMode class.
THttpUtility in file THttpUtility.php, class THttpUtility
THttpUtility class
toArray | in file THttpRequest.php, method THttpRequest::toArray()
toArray | in file THttpSession.php, method THttpSession::toArray()
TSessionIterator in file THttpSession.php, class TSessionIterator
TSessionIterator class
TUri in file THttpRequest.php, class TUri
TUri class
TUrlManager in file TUrlManager.php, class TUrlManager
TUrlManager class
TUrlMapping in file TUrlMapping.php, class TUrlMapping
TUrlMapping Class
TUrlMappingPattern in file TUrlMapping.php, class TUrlMappingPattern
TUrlMappingPattern class.
TUrlMappingPatternSecureConnection in file TUrlMapping.php, class TUrlMappingPatternSecureConnection
TUrlMappingPatternSecureConnection class
TAssetManager.php | procedural page TAssetManager.php
TCacheHttpSession.php | procedural page TCacheHttpSession.php
THttpRequest.php | procedural page THttpRequest.php
THttpResponse.php | procedural page THttpResponse.php
THttpResponseAdapter.php | procedural page THttpResponseAdapter.php
THttpSession.php | procedural page THttpSession.php
THttpUtility.php | procedural page THttpUtility.php
TUrlManager.php | procedural page TUrlManager.php
TUrlMapping.php | procedural page TUrlMapping.php
top
v
valid in file THttpSession.php, method TSessionIterator::valid()
Returns whether there is an element at current position.
top
w
write in file THttpResponse.php, method THttpResponse::write()
Outputs a string.
writeFile in file THttpResponse.php, method THttpResponse::writeFile()
Sends a file back to user.


Class Trees for Package System.Web

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TAssetManager.php

File: /Web/TAssetManager.php

Remarks

TAssetManager class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TAssetManager.php 3010 2011-07-16 09:28:55Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TAssetManager
TAssetManager class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:31 +0200 by phpDocumentor 1.4.3


Docs for page TCacheHttpSession.php

File: /Web/TCacheHttpSession.php

Remarks

TCacheHttpSession class

author

Qiang Xue <qiang.xue@gmail.com>

author

Carl G. Mathisen <carlgmathisen@gmail.com>

version

$Id: TCacheHttpSession.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

since

3.1.1

license

http://www.pradosoft.com/license/

Classes in this file:
TCacheHttpSession
TCacheHttpSession class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:40 +0200 by phpDocumentor 1.4.3


Docs for page THttpRequest.php

File: /Web/THttpRequest.php

Remarks

THttpRequest, THttpCookie, THttpCookieCollection, TUri class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THttpRequest.php 3099 2012-01-29 11:48:14Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THttpRequest
THttpRequest class
THttpCookieCollection
THttpCookieCollection class.
THttpCookie
THttpCookie class.
TUri
TUri class
THttpRequestUrlFormat
THttpRequestUrlFormat class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:29 +0200 by phpDocumentor 1.4.3


Docs for page THttpResponse.php

File: /Web/THttpResponse.php

Remarks

THttpResponse class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THttpResponse.php 3119 2012-03-24 23:13:29Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THttpResponse
THttpResponse class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:30 +0200 by phpDocumentor 1.4.3


Docs for page THttpResponseAdapter.php

File: /Web/THttpResponseAdapter.php

Remarks

THttpResponseAdatper class

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THttpResponseAdapter
THttpResponseAdapter class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:30 +0200 by phpDocumentor 1.4.3


Docs for page THttpSession.php

File: /Web/THttpSession.php

Remarks

THttpSession class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THttpSession.php 3114 2012-02-28 09:52:47Z GODZilla0480@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THttpSession
THttpSession class
TSessionIterator
TSessionIterator class
THttpSessionCookieMode
THttpSessionCookieMode class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:30 +0200 by phpDocumentor 1.4.3


Docs for page THttpUtility.php

File: /Web/THttpUtility.php

Remarks

THttpUtility class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THttpUtility.php 3005 2011-06-26 21:58:28Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THttpUtility
THttpUtility class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:31 +0200 by phpDocumentor 1.4.3


Docs for page TUrlManager.php

File: /Web/TUrlManager.php

Remarks

TUrlManager class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TUrlManager
TUrlManager class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:44 +0200 by phpDocumentor 1.4.3


Docs for page TUrlMapping.php

File: /Web/TUrlMapping.php

Remarks

TUrlMapping, TUrlMappingPattern and TUrlMappingPatternSecureConnection class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TUrlMapping.php 3051 2011-10-17 07:36:47Z GODZilla0480@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TUrlMapping
TUrlMapping Class
TUrlMappingPattern
TUrlMappingPattern class.
TUrlMappingPatternSecureConnection
TUrlMappingPatternSecureConnection class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:44 +0200 by phpDocumentor 1.4.3


Docs For Class TAssetManager

Class TAssetManager

[line 45]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TAssetManager
Location: /Web/TAssetManager.php

Remarks

TAssetManager class

TAssetManager provides a scheme to allow web clients visiting private files that are normally web-inaccessible.

TAssetManager will copy the file to be published into a web-accessible directory. The default base directory for storing the file is "assets", which should be under the application directory. This can be changed by setting the BasePath property together with the BaseUrl property that refers to the URL for accessing the base path.

By default, TAssetManager will not publish a file or directory if it already exists in the publishing directory and has an older modification time. If the application mode is set as 'Performance', the modification time check will be skipped. You can explicitly require a modification time check with the function publishFilePath. This is usually very useful during development.

TAssetManager may be configured in application configuration file as follows,

  •  <module id="asset" BasePath="Application.assets" BaseUrl="/assets" />
    •
    where BasePath and BaseUrl are configurable properties of TAssetManager. Make sure that BasePath is a namespace pointing to a valid directory writable by the Web server process.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TAssetManager.php 3010 2011-07-16 09:28:55Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    • DEFAULT_BASEPATH = 'assets'
      Default web accessible base path for storing private files

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TAssetManager::copyDirectory

      copyDirectory( string $src, string $dst );

      Parameters

      $src

      the source directory

      $dst

      the destination directory

      Remarks

      Copies a directory recursively as another.

      If the destination directory does not exist, it will be created. File modification time is used to ensure the copied files are latest.

      todo

      a generic solution to ignore certain directories and files

      access

      public

      [ Top ]

      TAssetManager::copyFile

      copyFile( string $src, string $dst );

      Parameters

      $src

      source file path

      $dst

      destination directory (if not exists, it will be created)

      Remarks

      Copies a file to a directory.

      Copying is done only when the destination file does not exist or has an older file modification time.

      access

      protected

      [ Top ]

      TAssetManager::deployTarFile

      deployTarFile( string $path, string $destination );

      Parameters

      $path

      tar file

      $destination

      path where the contents of tar file are to be extracted

      Returns

      true if extract successful, false otherwise.

      Remarks

      Extracts the tar file to the destination directory.

      N.B Tar file must not be compressed.

      access

      protected

      [ Top ]

      TAssetManager::getBasePath

      getBasePath( );

      Returns

      the root directory storing published asset files

      access

      public

      [ Top ]

      TAssetManager::getBaseUrl

      getBaseUrl( );

      Returns

      the base url that the published asset files can be accessed

      access

      public

      [ Top ]

      TAssetManager::getPublished

      getPublished( );

      Returns

      List of published assets

      since

      3.1.6

      access

      public

      [ Top ]

      TAssetManager::getPublishedPath

      getPublishedPath( string $path );

      Parameters

      $path

      directory or file path being published

      Returns

      the published file path

      Remarks

      Returns the published path of a file path.

      This method does not perform any publishing. It merely tells you if the file path is published, where it will go.

      access

      public

      [ Top ]

      TAssetManager::getPublishedUrl

      getPublishedUrl( string $path );

      Parameters

      $path

      directory or file path being published

      Returns

      the published URL for the file path

      Remarks

      Returns the URL of a published file path.

      This method does not perform any publishing. It merely tells you if the file path is published, what the URL will be to access it.

      access

      public

      [ Top ]

      TAssetManager::hash

      hash( string $dir );

      Parameters

      $dir

      string to be hashed.

      Returns

      hashed string.

      Remarks

      Generate a CRC32 hash for the directory path. Collisions are higher than MD5 but generates a much smaller hash string.

      access

      protected

      [ Top ]

      TAssetManager::init

      init( TXmlElement $config );

      Overrides TModule::init() (Initializes the module.)

      Parameters

      $config

      module configuration

      Remarks

      Initializes the module.

      This method is required by IModule and is invoked by application.

      access

      public

      [ Top ]

      TAssetManager::publishFilePath

      publishFilePath( string $path, [boolean $checkTimestamp = false] );

      Overrides TApplicationComponent::publishFilePath() (Publishes a file or directory and returns its URL.)

      Parameters

      $path

      the path to be published

      $checkTimestamp

      If true, file modification time will be checked even if the application is in performance mode.

      Returns

      an absolute URL to the published directory

      Remarks

      Publishes a file or a directory (recursively).

      This method will copy the content in a directory (recursively) to a web accessible directory and returns the URL for the directory. If the application is not in performance mode, the file modification time will be used to make sure the published file is latest or not. If not, a file copy will be performed.

      throws

      TInvalidDataValueException if the file path to be published is invalid

      access

      public

      [ Top ]

      TAssetManager::publishTarFile

      publishTarFile( string $tarfile, string $md5sum, [boolean $checkTimestamp = false] );

      Parameters

      $tarfile

      tar filename

      $md5sum

      MD5 checksum for the corresponding tar file.

      $checkTimestamp

      Wether or not to check the time stamp of the file for publishing. Defaults to false.

      Returns

      URL path to the directory where the tar file was extracted.

      Remarks

      Publish a tar file by extracting its contents to the assets directory.

      Each tar file must be accomplished with its own MD5 check sum file. The MD5 file is published when the tar contents are successfully extracted to the assets directory. The presence of the MD5 file as published asset assumes that the tar file has already been extracted.

      access

      public

      [ Top ]

      TAssetManager::setBasePath

      setBasePath( string $value );

      Parameters

      $value

      the root directory storing published asset files

      Remarks

      Sets the root directory storing published asset files.

      The directory must be in namespace format.

      throws

      TInvalidOperationException if the module is initialized already

      access

      public

      [ Top ]

      TAssetManager::setBaseUrl

      setBaseUrl( string $value );

      Parameters

      $value

      the base url that the published asset files can be accessed

      throws

      TInvalidOperationException if the module is initialized already

      access

      public

      [ Top ]

      TAssetManager::setPublished

      setPublished( [$values $values = array()] );

      Parameters

      $values

      List of published assets

      since

      3.1.6

      access

      protected

      [ Top ]

    Variable Detail

    Class Constant Detail

    • DEFAULT_BASEPATH = 'assets' [line 50]

      • Remarks

      Default web accessible base path for storing private files

    Documentation generated on Mon, 25 Jun 2012 14:43:31 +0200 by phpDocumentor 1.4.3


Docs For Class TCacheHttpSession

Class TCacheHttpSession

[line 43]
TComponent
   |
   --TApplicationComponent
      |
      --THttpSession
         |
         --TCacheHttpSession
Location: /Web/TCacheHttpSession.php

Remarks

TCacheHttpSession class

TCacheHttpSession provides access for storing session data using a cache module (e.g. TMemCache, TDbCache). To specify the cache module for data storage, set the CacheModuleID property which should refer to a valid cache module configured in the application configuration.

The following example shows how we configure TCacheHttpSession:

  •   <modules>
    •

  •     <module id="cache" class="System.Caching.TMemCache" Host="localhost" Port="11211" />
    •

  •     <module id="session" class="System.Web.TCacheHttpSession"
    •

  •          CacheModuleID="cache" SessionName="SSID"
    •

  •          CookieMode="Allow" AutoStart="true" GCProbability="1"
    •

  •          UseTransparentSessionID="true" TimeOut="3600" />
    •

  •   </modules>
    •

    Beware, by definition cache storage are volatile, which means the data stored on them may be swapped out and get lost. This may not be the case for certain cache storage, such as database. So make sure you manage your cache properly to avoid loss of session data.

    author

    Qiang Xue <qiang.xue@gmail.com>

    author

    Carl G. Mathisen <carlgmathisen@gmail.com>

    version

    $Id: TCacheHttpSession.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.1.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class THttpSession

    • THttpSession::add()
      Adds a session variable.
    • THttpSession::clear()
      Removes all session variables
    • THttpSession::close()
      Ends the current session and store session data.
    • THttpSession::contains()
    • THttpSession::count()
      Returns the number of items in the session.
    • THttpSession::destroy()
      Destroys all data registered to a session.
    • THttpSession::getAutoStart()
    • THttpSession::getCookie()
    • THttpSession::getCookieMode()
    • THttpSession::getCount()
    • THttpSession::getGCProbability()
    • THttpSession::getID()
    • THttpSession::getIsStarted()
    • THttpSession::getIterator()
      Returns an iterator for traversing the session variables.
    • THttpSession::getKeys()
    • THttpSession::getSavePath()
    • THttpSession::getSessionID()
    • THttpSession::getSessionName()
    • THttpSession::getTimeout()
    • THttpSession::getUseCustomStorage()
    • THttpSession::getUseTransparentSessionID()
    • THttpSession::init()
      Initializes the module.
    • THttpSession::itemAt()
      Returns the session variable value with the session variable name.
    • THttpSession::offsetExists()
      This method is required by the interface ArrayAccess.
    • THttpSession::offsetGet()
      This method is required by the interface ArrayAccess.
    • THttpSession::offsetSet()
      This method is required by the interface ArrayAccess.
    • THttpSession::offsetUnset()
      This method is required by the interface ArrayAccess.
    • THttpSession::open()
      Starts the session if it has not started yet.
    • THttpSession::regenerate()
      Update the current session id with a newly generated one
    • THttpSession::remove()
      Removes a session variable.
    • THttpSession::setAutoStart()
    • THttpSession::setCookieMode()
    • THttpSession::setGCProbability()
    • THttpSession::setID()
    • THttpSession::setSavePath()
    • THttpSession::setSessionID()
    • THttpSession::setSessionName()
    • THttpSession::setTimeout()
    • THttpSession::setUseCustomStorage()
    • THttpSession::setUseTransparentSessionID()
    • THttpSession::toArray()
    • THttpSession::_close()
      Session close handler.
    • THttpSession::_destroy()
      Session destroy handler.
    • THttpSession::_gc()
      Session GC (garbage collection) handler.
    • THttpSession::_open()
      Session open handler.
    • THttpSession::_read()
      Session read handler.
    • THttpSession::_write()
      Session write handler.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TCacheHttpSession::calculateKey

      calculateKey( string $id );

      Parameters

      $id

      session variable name

      Returns

      a safe cache key associated with the session variable name

      access

      protected

      [ Top ]

      TCacheHttpSession::getCache

      getCache( );

      Returns

      the cache module being used for data storage

      access

      public

      [ Top ]

      TCacheHttpSession::getCacheModuleID

      getCacheModuleID( );

      Returns

      the ID of the cache module.

      access

      public

      [ Top ]

      TCacheHttpSession::getKeyPrefix

      getKeyPrefix( );

      Returns

      prefix of session variable name to avoid conflict with other cache data. Defaults to 'session'.

      access

      public

      [ Top ]

      TCacheHttpSession::init

      init( TXmlElement $config );

      Overrides THttpSession::init() (Initializes the module.)

      Parameters

      $config

      module configuration

      Remarks

      Initializes the module.

      This method is required by IModule. It reads the CacheModule property.

      access

      public

      [ Top ]

      TCacheHttpSession::setCacheModuleID

      setCacheModuleID( string $value );

      Parameters

      $value

      the ID of the cache module.

      access

      public

      [ Top ]

      TCacheHttpSession::setKeyPrefix

      setKeyPrefix( string $value );

      Parameters

      $value

      prefix of session variable name to avoid conflict with other cache data

      access

      public

      [ Top ]

      TCacheHttpSession::_destroy

      _destroy( string $id );

      Overrides THttpSession::_destroy() (Session destroy handler.)

      Parameters

      $id

      session ID

      Returns

      whether session is destroyed successfully

      Remarks

      Session destroy handler.

      This method should be overriden if UseCustomStorage is set true.

      access

      public

      [ Top ]

      TCacheHttpSession::_read

      _read( string $id );

      Overrides THttpSession::_read() (Session read handler.)

      Parameters

      $id

      session ID

      Returns

      the session data

      Remarks

      Session read handler.

      access

      public

      [ Top ]

      TCacheHttpSession::_write

      _write( string $id, string $data );

      Overrides THttpSession::_write() (Session write handler.)

      Parameters

      $id

      session ID

      $data

      session data

      Returns

      whether session write is successful

      Remarks

      Session write handler.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:40 +0200 by phpDocumentor 1.4.3


Docs For Class THttpCookie

Class THttpCookie

[line 988]
TComponent
   |
   --THttpCookie
Location: /Web/THttpRequest.php

Remarks

THttpCookie class.

A THttpCookie instance stores a single cookie, including the cookie name, value, domain, path, expire, and secure.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THttpRequest.php 3099 2012-01-29 11:48:14Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THttpCookie::__construct

    __construct( string $name, string $value );

    Parameters

    $name

    name of this cookie

    $value

    value of this cookie

    Remarks

    Constructor.

    access

    public

    [ Top ]

    THttpCookie::getDomain

    getDomain( );

    Returns

    the domain to associate the cookie with

    access

    public

    [ Top ]

    THttpCookie::getExpire

    getExpire( );

    Returns

    the time the cookie expires. This is a Unix timestamp so is in number of seconds since the epoch.

    access

    public

    [ Top ]

    THttpCookie::getHttpOnly

    getHttpOnly( );

    Returns

    if true the cookie value will be unavailable to JavaScript

    access

    public

    [ Top ]

    THttpCookie::getName

    getName( );

    Returns

    the name of the cookie

    access

    public

    [ Top ]

    THttpCookie::getPath

    getPath( );

    Returns

    the path on the server in which the cookie will be available on, default is '/'

    access

    public

    [ Top ]

    THttpCookie::getSecure

    getSecure( );

    Returns

    whether the cookie should only be transmitted over a secure HTTPS connection

    access

    public

    [ Top ]

    THttpCookie::getValue

    getValue( );

    Returns

    the value of the cookie

    access

    public

    [ Top ]

    THttpCookie::setDomain

    setDomain( string $value );

    Parameters

    $value

    the domain to associate the cookie with

    access

    public

    [ Top ]

    THttpCookie::setExpire

    setExpire( integer $value );

    Parameters

    $value

    the time the cookie expires. This is a Unix timestamp so is in number of seconds since the epoch.

    access

    public

    [ Top ]

    THttpCookie::setHttpOnly

    setHttpOnly( boolean $value );

    Parameters

    $value

    if true the cookie value will be unavailable to JavaScript

    access

    public

    [ Top ]

    THttpCookie::setName

    setName( string $value );

    Parameters

    $value

    the name of the cookie

    access

    public

    [ Top ]

    THttpCookie::setPath

    setPath( string $value );

    Parameters

    $value

    the path on the server in which the cookie will be available on

    access

    public

    [ Top ]

    THttpCookie::setSecure

    setSecure( boolean $value );

    Parameters

    $value

    ether the cookie should only be transmitted over a secure HTTPS connection

    access

    public

    [ Top ]

    THttpCookie::setValue

    setValue( string $value );

    Parameters

    $value

    the value of the cookie

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:29 +0200 by phpDocumentor 1.4.3


Docs For Class THttpCookieCollection

Class THttpCookieCollection

[line 900]
TComponent
   |
   --TList
      |
      --THttpCookieCollection
Location: /Web/THttpRequest.php

Remarks

THttpCookieCollection class.

THttpCookieCollection implements a collection class to store cookies. Besides using all functionalities from TList, you can also retrieve a cookie by its name using either findCookieByName or simply:

  •    $cookie=$collection[$cookieName];
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: THttpRequest.php 3099 2012-01-29 11:48:14Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TList

    • TList::__construct()
      Constructor.
    • TList::add()
      Appends an item at the end of the list.
    • TList::clear()
      Removes all items in the list.
    • TList::contains()
    • TList::copyFrom()
      Copies iterable data into the list.
    • TList::count()
      Returns the number of items in the list.
    • TList::getCount()
    • TList::getIterator()
      Returns an iterator for traversing the items in the list.
    • TList::getReadOnly()
    • TList::indexOf()
    • TList::insertAfter()
      Finds the base item. If found, the item is inserted after it.
    • TList::insertAt()
      Inserts an item at the specified position.
    • TList::insertBefore()
      Finds the base item. If found, the item is inserted before it.
    • TList::itemAt()
      Returns the item at the specified offset.
    • TList::mergeWith()
      Merges iterable data into the map.
    • TList::offsetExists()
      Returns whether there is an item at the specified offset.
    • TList::offsetGet()
      Returns the item at the specified offset.
    • TList::offsetSet()
      Sets the item at the specified offset.
    • TList::offsetUnset()
      Unsets the item at the specified offset.
    • TList::remove()
      Removes an item from the list.
    • TList::removeAt()
      Removes an item at the specified position.
    • TList::setReadOnly()
    • TList::toArray()

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      THttpCookieCollection::__construct

      __construct( [mixed $owner = null] );

      Overrides TList::__construct() (Constructor.)

      Parameters

      $owner

      owner of this collection.

      Remarks

      Constructor.

      access

      public

      [ Top ]

      THttpCookieCollection::findCookieByName

      findCookieByName( string $name );

      Parameters

      $name

      the name of the cookie to be looked for

      Returns

      the cookie, null if not found

      Remarks

      Finds the cookie with the specified name.

      access

      public

      [ Top ]

      THttpCookieCollection::insertAt

      insertAt( integer $index, mixed $item );

      Overrides TList::insertAt() (Inserts an item at the specified position.)

      Parameters

      $index

      the specified position.

      $item

      new item

      Remarks

      Inserts an item at the specified position.

      This overrides the parent implementation by performing additional operations for each newly added THttpCookie object.

      throws

      TInvalidDataTypeException if the item to be inserted is not a THttpCookie object.

      access

      public

      [ Top ]

      THttpCookieCollection::itemAt

      itemAt( integer|string $index );

      Overrides TList::itemAt() (Returns the item at the specified offset.)

      Parameters

      $index

      index of the cookie in the collection or the cookie's name

      Returns

      the cookie found

      access

      public

      [ Top ]

      THttpCookieCollection::removeAt

      removeAt( integer $index );

      Overrides TList::removeAt() (Removes an item at the specified position.)

      Parameters

      $index

      the index of the item to be removed.

      Returns

      the removed item.

      Remarks

      Removes an item at the specified position.

      This overrides the parent implementation by performing additional cleanup work when removing a TCookie object.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:29 +0200 by phpDocumentor 1.4.3


Docs For Class THttpRequest

Class THttpRequest

[line 71]
TComponent
   |
   --TApplicationComponent
      |
      --THttpRequest
Location: /Web/THttpRequest.php

Remarks

THttpRequest class

THttpRequest provides storage and access scheme for user request sent via HTTP. It also encapsulates a uniform way to parse and construct URLs.

User post data can be retrieved from THttpRequest by using it like an associative array. For example, to test if a user supplies a variable named 'param1', you can use,

  •    if(isset($request['param1'])) ...
    •

  •    // equivalent to:
    •

  •    // if($request->contains('param1')) ...
    •
    To get the value of 'param1', use,
  •    $value=$request['param1'];
    •

  •    // equivalent to:
    •

  •    //   $value=$request->itemAt('param1');
    •
    To traverse the user post data, use
  •    foreach($request as $name=>$value) ...
    •
    Note, POST and GET variables are merged together in THttpRequest. If a variable name appears in both POST and GET data, then POST data takes precedence.

    To construct a URL that can be recognized by Prado, use constructUrl(). The format of the recognizable URLs is determined according to UrlManager. By default, the following two formats are recognized:

  •  /index.php?ServiceID=ServiceParameter&Name1=Value1&Name2=Value2
    •

  •  /index.php/ServiceID,ServiceParameter/Name1,Value1/Name2,Value2
    •
    The first format is called 'Get' while the second 'Path', which is specified via UrlFormat. For advanced users who want to use their own URL formats, they can write customized URL management modules and install the managers as application modules and set UrlManager.

    The ServiceID in the above URLs is as defined in the application configuration (e.g. the default page service's service ID is 'page'). As a consequence, your GET variable names should not conflict with the service IDs that your application supports.

    THttpRequest also provides the cookies sent by the user, user information such as his browser capabilities, accepted languages, etc.

    By default, THttpRequest is registered with TApplication as the request module. It can be accessed via TApplication::getRequest().

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: THttpRequest.php 3099 2012-01-29 11:48:14Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    • CGIFIX__PATH_INFO =  1
    • CGIFIX__SCRIPT_NAME =  2

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      THttpRequest::add

      add( mixed $key, mixed $value );

      Parameters

      $key

      key

      $value

      value

      Remarks

      Adds an item into the request.

      Note, if the specified key already exists, the old value will be overwritten.

      access

      public

      [ Top ]

      THttpRequest::clear

      clear( );

      Remarks

      Removes all items in the request.

      access

      public

      [ Top ]

      THttpRequest::constructUrl

      constructUrl( string $serviceID, string $serviceParam, [array $getItems = null], [boolean $encodeAmpersand = true], [boolean $encodeGetItems = true] );

      Parameters

      $serviceID

      service ID

      $serviceParam

      service parameter

      $getItems

      GET parameters, null if not needed

      $encodeAmpersand

      whether to encode the ampersand in URL, defaults to true.

      $encodeGetItems

      whether to encode the GET parameters (their names and values), defaults to false.

      Returns

      URL

      Remarks

      Constructs a URL that can be recognized by PRADO.

      The actual construction work is done by the URL manager module. This method may append session information to the generated URL if needed. You may provide your own URL manager module by setting UrlManager to provide your own URL scheme.

      Note, the constructed URL does not contain the protocol and hostname part. You may obtain an absolute URL by prepending the constructed URL with BaseUrl.

      see

      TUrlManager::constructUrl

      access

      public

      [ Top ]

      THttpRequest::contains

      contains( mixed $key );

      Parameters

      $key

      the key

      Returns

      whether the request contains an item with the specified key

      access

      public

      [ Top ]

      THttpRequest::count

      count( );

      Implementation of:
      Countable::count

      Returns

      number of items in the request.

      Remarks

      Returns the number of items in the request.

      This method is required by Countable interface.

      access

      public

      [ Top ]

      THttpRequest::getAbsoluteApplicationUrl

      getAbsoluteApplicationUrl( [boolean|null $forceSecureConnection = null] );

      Parameters

      $forceSecureConnection

      whether to use HTTPS instead of HTTP even if the current request is sent via HTTP or vice versa null - keep current schema true - force https false - force http

      Returns

      entry script URL (w/ host part)

      access

      public

      [ Top ]

      THttpRequest::getAcceptTypes

      getAcceptTypes( );

      Returns

      user browser accept types

      access

      public

      [ Top ]

      THttpRequest::getApplicationFilePath

      getApplicationFilePath( );

      Returns

      application entry script file path (processed w/ realpath())

      access

      public

      [ Top ]

      THttpRequest::getApplicationUrl

      getApplicationUrl( );

      Returns

      entry script URL (w/o host part)

      access

      public

      [ Top ]

      THttpRequest::getBaseUrl

      getBaseUrl( [boolean|null $forceSecureConnection = null] );

      Parameters

      $forceSecureConnection

      whether to use HTTPS instead of HTTP even if the current request is sent via HTTP or vice versa null - keep current schema true - force https false - force http

      Returns

      schema and hostname of the requested URL

      access

      public

      [ Top ]

      THttpRequest::getBrowser

      getBrowser( );

      Returns

      user browser capabilities

      see

      get_browser

      access

      public

      [ Top ]

      THttpRequest::getCgiFix

      getCgiFix( );

      Returns

      whether to use ORIG_PATH_INFO and/or ORIG_SCRIPT_NAME. Defaults to 0.

      see

      THttpRequest::CGIFIX__PATH_INFO, THttpRequest::CGIFIX__SCRIPT_NAME

      access

      public

      [ Top ]

      THttpRequest::getContentType

      getContentType( [boolean $mimetypeOnly = true] );

      Parameters

      $mimetypeOnly

      whether to return only the mimetype (default: true)

      Returns

      content type (e.g. 'application/json' or 'text/html; encoding=gzip') or null if not specified

      access

      public

      [ Top ]

      THttpRequest::getCookies

      getCookies( );

      Returns

      list of cookies to be sent

      access

      public

      [ Top ]

      THttpRequest::getCount

      getCount( );

      Returns

      the number of items in the request

      access

      public

      [ Top ]

      THttpRequest::getEnableCookieValidation

      getEnableCookieValidation( );

      Returns

      whether cookies should be validated. Defaults to false.

      access

      public

      [ Top ]

      THttpRequest::getEnvironmentVariables

      getEnvironmentVariables( );

      Returns

      list of environment variables.

      access

      public

      [ Top ]

      THttpRequest::getHeaders

      getHeaders( [integer|null $case = null] );

      Parameters

      $case

      Either CASE_UPPER or CASE_LOWER or as is null (default)

      access

      public

      [ Top ]

      THttpRequest::getHttpProtocolVersion

      getHttpProtocolVersion( );

      Returns

      the requested http procolol. Blank string if not defined.

      access

      public

      [ Top ]

      THttpRequest::getID

      getID( );

      Returns

      id of this module

      access

      public

      [ Top ]

      THttpRequest::getIsSecureConnection

      getIsSecureConnection( );

      Returns

      if the request is sent via secure channel (https)

      access

      public

      [ Top ]

      THttpRequest::getIterator

      getIterator( );

      Implementation of:
      IteratorAggregate::getIterator

      Returns

      an iterator for traversing the items in the list.

      Remarks

      Returns an iterator for traversing the items in the list.

      This method is required by the interface IteratorAggregate.

      access

      public

      [ Top ]

      THttpRequest::getKeys

      getKeys( );

      Returns

      the key list

      access

      public

      [ Top ]

      THttpRequest::getPathInfo

      getPathInfo( );

      Returns

      part of the request URL after script name and before question mark.

      access

      public

      [ Top ]

      THttpRequest::getQueryString

      getQueryString( );

      Returns

      part of that request URL after the question mark

      access

      public

      [ Top ]

      THttpRequest::getRequestResolved

      getRequestResolved( );

      Returns

      true if request is already resolved, false otherwise.

      access

      public

      [ Top ]

      THttpRequest::getRequestType

      getRequestType( );

      Returns

      request type, can be GET, POST, HEAD, or PUT

      access

      public

      [ Top ]

      THttpRequest::getRequestUri

      getRequestUri( );

      Returns

      part of that request URL after the host info (including pathinfo and query string)

      access

      public

      [ Top ]

      THttpRequest::getServerName

      getServerName( );

      Returns

      server name

      access

      public

      [ Top ]

      THttpRequest::getServerPort

      getServerPort( );

      Returns

      server port number

      access

      public

      [ Top ]

      THttpRequest::getServerVariables

      getServerVariables( );

      Returns

      list of server variables.

      access

      public

      [ Top ]

      THttpRequest::getServiceID

      getServiceID( );

      Returns

      requested service ID

      access

      public

      [ Top ]

      THttpRequest::getServiceParameter

      getServiceParameter( );

      Returns

      requested service parameter

      access

      public

      [ Top ]

      THttpRequest::getUploadedFiles

      getUploadedFiles( );

      Returns

      list of uploaded files.

      access

      public

      [ Top ]

      THttpRequest::getUrl

      getUrl( );

      Returns

      the request URL

      access

      public

      [ Top ]

      THttpRequest::getUrlFormat

      getUrlFormat( );

      Returns

      the format of URLs. Defaults to THttpRequestUrlFormat::Get.

      access

      public

      [ Top ]

      THttpRequest::getUrlManager

      getUrlManager( );

      Returns

      the ID of the URL manager module

      access

      public

      [ Top ]

      THttpRequest::getUrlManagerModule

      getUrlManagerModule( );

      Returns

      the URL manager module

      access

      public

      [ Top ]

      THttpRequest::getUrlParamSeparator

      getUrlParamSeparator( );

      Returns

      separator used to separate GET variable name and value when URL format is Path. Defaults to comma ','.

      access

      public

      [ Top ]

      THttpRequest::getUrlReferrer

      getUrlReferrer( );

      Returns

      URL referrer, null if not present

      access

      public

      [ Top ]

      THttpRequest::getUserAgent

      getUserAgent( );

      Returns

      user agent

      access

      public

      [ Top ]

      THttpRequest::getUserHost

      getUserHost( );

      Returns

      user host name, null if cannot be determined

      access

      public

      [ Top ]

      THttpRequest::getUserHostAddress

      getUserHostAddress( );

      Returns

      user IP address

      access

      public

      [ Top ]

      THttpRequest::getUserLanguages

      getUserLanguages( );

      Returns

      list of user preferred languages.

      Remarks

      Returns a list of user preferred languages.

      The languages are returned as an array. Each array element represents a single language preference. The languages are ordered according to user preferences. The first language is the most preferred.

      access

      public

      [ Top ]

      THttpRequest::init

      init( TXmlElement $config );

      Parameters

      $config

      module configuration

      Remarks

      Initializes the module.

      This method is required by IModule and is invoked by application.

      access

      public

      [ Top ]

      THttpRequest::itemAt

      itemAt( mixed $key );

      Parameters

      $key

      the key

      Returns

      the element at the offset, null if no element is found at the offset

      Remarks

      Returns the item with the specified key.

      This method is exactly the same as offsetGet.

      access

      public

      [ Top ]

      THttpRequest::offsetExists

      offsetExists( mixed $offset );

      Implementation of:
      ArrayAccess::offsetExists

      Parameters

      $offset

      the offset to check on

      Remarks

      Returns whether there is an element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      THttpRequest::offsetGet

      offsetGet( integer $offset );

      Implementation of:
      ArrayAccess::offsetGet

      Parameters

      $offset

      the offset to retrieve element.

      Returns

      the element at the offset, null if no element is found at the offset

      Remarks

      Returns the element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      THttpRequest::offsetSet

      offsetSet( integer $offset, mixed $item );

      Implementation of:
      ArrayAccess::offsetSet

      Parameters

      $offset

      the offset to set element

      $item

      the element value

      Remarks

      Sets the element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      THttpRequest::offsetUnset

      offsetUnset( mixed $offset );

      Implementation of:
      ArrayAccess::offsetUnset

      Parameters

      $offset

      the offset to unset element

      Remarks

      Unsets the element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      THttpRequest::parseUrl

      parseUrl( );

      Returns

      list of input parameters, indexed by parameter names

      Remarks

      Parses the request URL and returns an array of input parameters (excluding GET variables).

      You may override this method to support customized URL format.

      see

      TUrlManager::parseUrl

      access

      protected

      [ Top ]

      THttpRequest::remove

      remove( mixed $key );

      Parameters

      $key

      the key of the item to be removed

      Returns

      the removed value, null if no such key exists.

      Remarks

      Removes an item from the request by its key.

      throws

      TInvalidOperationException if the item cannot be removed

      access

      public

      [ Top ]

      THttpRequest::resolveRequest

      resolveRequest( array $serviceIDs );

      Parameters

      $serviceIDs

      list of valid service IDs

      Returns

      the currently requested service ID, null if no service ID is found

      Remarks

      Resolves the requested service.

      This method implements a URL-based service resolution. A URL in the format of /index.php?sp=serviceID.serviceParameter will be resolved with the serviceID and the serviceParameter. You may override this method to provide your own way of service resolution.

      see

      THttpRequest::constructUrl()

      access

      public

      [ Top ]

      THttpRequest::setCgiFix

      setCgiFix( integer $value );

      Parameters

      $value

      enable bitwise to use ORIG_PATH_INFO and/or ORIG_SCRIPT_NAME.

      Remarks

      Enable this, if you're using PHP via CGI with php.ini setting "cgi.fix_pathinfo=1"

      and have trouble with friendly URL feature. Enable this only if you really know what you are doing!

      see

      THttpRequest::CGIFIX__PATH_INFO, THttpRequest::CGIFIX__SCRIPT_NAME

      access

      public

      [ Top ]

      THttpRequest::setEnableCookieValidation

      setEnableCookieValidation( boolean $value );

      Parameters

      $value

      whether cookies should be validated.

      access

      public

      [ Top ]

      THttpRequest::setID

      setID( string $value );

      Parameters

      $value

      id of this module

      access

      public

      [ Top ]

      THttpRequest::setServiceID

      setServiceID( string $value );

      Parameters

      $value

      requested service ID

      Remarks

      Sets the requested service ID.

      access

      public

      [ Top ]

      THttpRequest::setServiceParameter

      setServiceParameter( string $value );

      Parameters

      $value

      requested service parameter

      Remarks

      Sets the requested service parameter.

      access

      public

      [ Top ]

      THttpRequest::setUrlFormat

      setUrlFormat( THttpRequestUrlFormat $value );

      Parameters

      $value

      the format of URLs.

      Remarks

      Sets the format of URLs constructed and interpretted by the request module.

      A Get URL format is like index.php?name1=value1&name2=value2 while a Path URL format is like index.php/name1,value1/name2,value. Changing the UrlFormat will affect constructUrl and how GET variables are parsed.

      access

      public

      [ Top ]

      THttpRequest::setUrlManager

      setUrlManager( string $value );

      Parameters

      $value

      the ID of the URL manager module

      Remarks

      Sets the URL manager module.

      By default, TUrlManager is used for managing URLs. You may specify a different module for URL managing tasks by loading it as an application module and setting this property with the module ID.

      access

      public

      [ Top ]

      THttpRequest::setUrlParamSeparator

      setUrlParamSeparator( string $value );

      Parameters

      $value

      separator used to separate GET variable name and value when URL format is Path.

      throws

      TInvalidDataValueException if the separator is not a single character

      access

      public

      [ Top ]

      THttpRequest::stripSlashes

      stripSlashes( mixed &$data );

      Parameters

      &$data

      input data to be processed

      Returns

      processed data

      Remarks

      Strips slashes from input data.

      This method is applied when magic quotes is enabled.

      access

      public

      [ Top ]

      THttpRequest::toArray

      toArray( );

      Returns

      the list of items in array

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • CGIFIX__PATH_INFO =  1 [line 73]

    • CGIFIX__SCRIPT_NAME =  2 [line 74]

    Documentation generated on Mon, 25 Jun 2012 14:44:29 +0200 by phpDocumentor 1.4.3


Docs For Class THttpRequestUrlFormat

Class THttpRequestUrlFormat

[line 1329]
TEnumerable
   |
   --THttpRequestUrlFormat
Location: /Web/THttpRequest.php

Remarks

THttpRequestUrlFormat class.

THttpRequestUrlFormat defines the enumerable type for the possible URL formats that can be recognized by THttpRequest.

The following enumerable values are defined:

  • Get: the URL format is like /path/to/index.php?name1=value1&name2=value2...
  • Path: the URL format is like /path/to/index.php/name1,value1/name2,value2...

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THttpRequest.php 3099 2012-01-29 11:48:14Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Get = 'Get'
  • Path = 'Path'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Get = 'Get' [line 1331]

  • Path = 'Path' [line 1332]

Documentation generated on Mon, 25 Jun 2012 14:44:30 +0200 by phpDocumentor 1.4.3


Docs For Class TUri

Class TUri

[line 1163]
TComponent
   |
   --TUri
Location: /Web/THttpRequest.php

Remarks

TUri class

TUri represents a URI. Given a URI http://joe:whatever@example.com:8080/path/to/script.php?param=value#anchor it will be decomposed as follows,

  • scheme: http
  • host: example.com
  • port: 8080
  • user: joe
  • password: whatever
  • path: /path/to/script.php
  • query: param=value
  • fragment: anchor

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THttpRequest.php 3099 2012-01-29 11:48:14Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TUri::__construct

    __construct( string $uri );

    Parameters

    $uri

    URI to be represented

    Remarks

    Constructor.

    Decomposes the specified URI into parts.

    throws

    TInvalidDataValueException if URI is of bad format

    access

    public

    [ Top ]

    TUri::getFragment

    getFragment( );

    Returns

    fragment of the URI

    access

    public

    [ Top ]

    TUri::getHost

    getHost( );

    Returns

    hostname of the URI

    access

    public

    [ Top ]

    TUri::getPassword

    getPassword( );

    Returns

    password of the URI

    access

    public

    [ Top ]

    TUri::getPath

    getPath( );

    Returns

    path of the URI

    access

    public

    [ Top ]

    TUri::getPort

    getPort( );

    Returns

    port number of the URI

    access

    public

    [ Top ]

    TUri::getQuery

    getQuery( );

    Returns

    query string of the URI

    access

    public

    [ Top ]

    TUri::getScheme

    getScheme( );

    Returns

    scheme of the URI, such as 'http', 'https', 'ftp', etc.

    access

    public

    [ Top ]

    TUri::getUri

    getUri( );

    Returns

    URI

    access

    public

    [ Top ]

    TUri::getUser

    getUser( );

    Returns

    username of the URI

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:30 +0200 by phpDocumentor 1.4.3


Docs For Class THttpResponse

Class THttpResponse

[line 67]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --THttpResponse
Location: /Web/THttpResponse.php

Remarks

THttpResponse class

THttpResponse implements the mechanism for sending output to client users.

To output a string to client, use write(). By default, the output is buffered until flush() is called or the application ends. The output in the buffer can also be cleaned by clear(). To disable output buffering, set BufferOutput property to false.

To send cookies to client, use getCookies(). To redirect client browser to a new URL, use redirect(). To send a file to client, use writeFile().

By default, THttpResponse is registered with TApplication as the response module. It can be accessed via TApplication::getResponse().

THttpResponse may be configured in application configuration file as follows

<module id="response" class="System.Web.THttpResponse" CacheExpire="20" CacheControl="nocache" BufferOutput="true" />

where CacheExpire, CacheControl and BufferOutput are optional properties of THttpResponse.

THttpResponse sends charset header if either Charset or TGlobalization.Charset is set.

Since 3.1.2, HTTP status code can be set with the StatusCode property.

Note: Some HTTP Status codes can require additional header or body information. So, if you use StatusCode in your application, be sure to add theses informations. E.g : to make an http authentication :

  •   public function clickAuth ($sender, $param)
    •

  •   {
    •

  •      $response=$this->getResponse();
    •

  •      $response->setStatusCode(401);
    •

  •      $response->appendHeader('WWW-Authenticate: Basic realm="Test"');
    •

  •   }
    •

    This event handler will sent the 401 status code (Unauthorized) to the browser, with the WWW-Authenticate header field. This will force the browser to ask for a username and a password.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: THttpResponse.php 3119 2012-03-24 23:13:29Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    • DEFAULT_CHARSET =  'UTF-8'
    • DEFAULT_CONTENTTYPE =  'text/html'

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      THttpResponse::addCookie

      addCookie( THttpCookie $cookie );

      Parameters

      $cookie

      cook to be sent

      Remarks

      Sends a cookie.

      Do not call this method directly. Operate with the result of getCookies instead.

      access

      public

      [ Top ]

      THttpResponse::appendHeader

      appendHeader( string $value, [boolean $replace = true] );

      Parameters

      $value

      header

      $replace

      whether the header should replace a previous similar header, or add a second header of the same type

      Remarks

      Sends a header.

      access

      public

      [ Top ]

      THttpResponse::appendLog

      appendLog( string $message, [integer $messageType = 0], [string $destination = ''], [string $extraHeaders = ''] );

      Parameters

      $message

      The error message that should be logged

      $messageType

      where the error should go

      $destination

      The destination. Its meaning depends on the message parameter as described above

      $extraHeaders

      The extra headers. It's used when the message parameter is set to 1. This message type uses the same internal function as mail() does.

      Remarks

      Writes a log message into error log.

      This method is simple wrapper of PHP function error_log.

      see

      http://us2.php.net/manual/en/function.error-log.php

      access

      public

      [ Top ]

      THttpResponse::clear

      clear( );

      Remarks

      Clears any existing buffered content.

      access

      public

      [ Top ]

      THttpResponse::createHtmlWriter

      createHtmlWriter( [string $type = null] );

      Parameters

      $type

      type of the HTML writer to be created. If null, HtmlWriterType will be assumed.

      Remarks

      Creates a new instance of HTML writer.

      If the type of the HTML writer is not supplied, HtmlWriterType will be assumed.

      access

      public

      [ Top ]

      THttpResponse::createNewHtmlWriter

      createNewHtmlWriter( string $type, ITextWriter $writer );

      Parameters

      $type

      type of HTML writer to be created.

      $writer

      text writer holding the contents.

      Remarks

      Create a new html writer instance.

      This method is used internally. Please use createHtmlWriter instead.

      access

      public

      [ Top ]

      THttpResponse::__destruct

      __destruct( );

      Remarks

      Destructor.

      Flushes any existing content in buffer.

      access

      public

      [ Top ]

      THttpResponse::ensureContentTypeHeaderSent

      ensureContentTypeHeaderSent( );

      Remarks

      Ensures that the HTTP header with the status code and status reason are sent

      access

      protected

      [ Top ]

      THttpResponse::ensureHeadersSent

      ensureHeadersSent( );

      Remarks

      Ensures that HTTP response and content-type headers are sent

      access

      public

      [ Top ]

      THttpResponse::ensureHttpHeaderSent

      ensureHttpHeaderSent( );

      Remarks

      Ensures that the HTTP header with the status code and status reason are sent

      access

      protected

      [ Top ]

      THttpResponse::flush

      flush( [ $continueBuffering = true] );

      Parameters

      $continueBuffering

      Remarks

      Flush the response contents and headers.

      access

      public

      [ Top ]

      THttpResponse::flushContent

      flushContent( [boolean $continueBuffering = true] );

      Parameters

      $continueBuffering

      whether to continue buffering after flush if buffering was active

      Remarks

      Outputs the buffered content, sends content-type and charset header.

      This method is used internally. Please use flush instead.

      access

      public

      [ Top ]

      THttpResponse::getAdapter

      getAdapter( );

      Returns

      response adapter, null if not exist.

      access

      public

      [ Top ]

      THttpResponse::getBufferOutput

      getBufferOutput( );

      Returns

      whether to enable output buffer

      access

      public

      [ Top ]

      THttpResponse::getCacheControl

      getCacheControl( );

      Returns

      cache control method to use for session pages

      access

      public

      [ Top ]

      THttpResponse::getCacheExpire

      getCacheExpire( );

      Returns

      time-to-live for cached session pages in minutes, this has no effect for nocache limiter. Defaults to 180.

      access

      public

      [ Top ]

      THttpResponse::getCharset

      getCharset( );

      Returns

      output charset.

      access

      public

      [ Top ]

      THttpResponse::getContents

      getContents( );

      Returns

      output that is in the buffer.

      Remarks

      Returns the content in the output buffer.

      The buffer will NOT be cleared after calling this method. Use clear() is you want to clear the buffer.

      access

      public

      [ Top ]

      THttpResponse::getContentType

      getContentType( );

      Returns

      current content type

      access

      public

      [ Top ]

      THttpResponse::getCookies

      getCookies( );

      Returns

      list of output cookies

      access

      public

      [ Top ]

      THttpResponse::getHasAdapter

      getHasAdapter( );

      Returns

      true if adapter exists, false otherwise.

      access

      public

      [ Top ]

      THttpResponse::getHeaders

      getHeaders( [integer|null $case = null] );

      Parameters

      $case

      Either CASE_UPPER or CASE_LOWER or as is null (default)

      access

      public

      [ Top ]

      THttpResponse::getHtmlWriterType

      getHtmlWriterType( );

      Returns

      the type of HTML writer to be used, defaults to THtmlWriter

      access

      public

      [ Top ]

      THttpResponse::getStatusCode

      getStatusCode( );

      Returns

      HTTP status code, defaults to 200

      access

      public

      [ Top ]

      THttpResponse::getStatusReason

      getStatusReason( string 0 );

      Parameters

      0

      HTTP status reason

      access

      public

      [ Top ]

      THttpResponse::httpRedirect

      httpRedirect( string $url );

      Parameters

      $url

      URL to be redirected to. If the URL is a relative one, the base URL of the current request will be inserted at the beginning.

      Remarks

      Redirect the browser to another URL and exists the current application.

      This method is used internally. Please use redirect instead.

      since

      3.1.5 You can set the set StatusCode to a value between 300 and 399 before calling this function to change the type of redirection. If not specified, StatusCode will be 302 (Found) by default

      access

      public

      [ Top ]

      THttpResponse::init

      init( TXmlElement $config );

      Overrides TModule::init() (Initializes the module.)

      Parameters

      $config

      module configuration

      Remarks

      Initializes the module.

      This method is required by IModule and is invoked by application. It starts output buffer if it is enabled.

      access

      public

      [ Top ]

      THttpResponse::redirect

      redirect( string $url );

      Parameters

      $url

      URL to be redirected to. If the URL is a relative one, the base URL of the current request will be inserted at the beginning.

      Remarks

      Redirects the browser to the specified URL.

      The current application will be terminated after this method is invoked.

      access

      public

      [ Top ]

      THttpResponse::reload

      reload( );

      Remarks

      Reloads the current page.

      The effect of this method call is the same as user pressing the refresh button on his browser (without post data).

      access

      public

      [ Top ]

      THttpResponse::removeCookie

      removeCookie( THttpCookie $cookie );

      Parameters

      $cookie

      cook to be deleted

      Remarks

      Deletes a cookie.

      Do not call this method directly. Operate with the result of getCookies instead.

      access

      public

      [ Top ]

      THttpResponse::sendContentTypeHeader

      sendContentTypeHeader( );

      Remarks

      Sends content type header with optional charset.

      access

      protected

      [ Top ]

      THttpResponse::sendHttpHeader

      sendHttpHeader( );

      Remarks

      Send the HTTP header with the status code (defaults to 200) and status reason (defaults to OK)

      access

      protected

      [ Top ]

      THttpResponse::setAdapter

      setAdapter( THttpResponseAdapter $adapter );

      Parameters

      $adapter

      response adapter

      access

      public

      [ Top ]

      THttpResponse::setBufferOutput

      setBufferOutput( boolean $value );

      Parameters

      $value

      whether to enable output buffer

      throws

      TInvalidOperationException if session is started already

      access

      public

      [ Top ]

      THttpResponse::setCacheControl

      setCacheControl( string $value );

      Parameters

      $value

      cache control method to use for session pages. Valid values include none/nocache/private/private_no_expire/public

      access

      public

      [ Top ]

      THttpResponse::setCacheExpire

      setCacheExpire( integer $value );

      Parameters

      $value

      time-to-live for cached session pages in minutes, this has no effect for nocache limiter.

      access

      public

      [ Top ]

      THttpResponse::setCharset

      setCharset( string|boolean $charset );

      Parameters

      $charset

      output charset.

      access

      public

      [ Top ]

      THttpResponse::setContentType

      setContentType( $type );

      Parameters

      $type

      Returns

      content type, default is text/html

      access

      public

      [ Top ]

      THttpResponse::setHtmlWriterType

      setHtmlWriterType( string $value );

      Parameters

      $value

      the type of HTML writer to be used, may be the class name or the namespace

      access

      public

      [ Top ]

      THttpResponse::setStatusCode

      setStatusCode( integer $status, [string $reason = null] );

      Parameters

      $status

      HTTP status code

      $reason

      HTTP status reason, defaults to standard HTTP reasons

      Remarks

      Set the HTTP status code for the response.

      The code and its reason will be sent to client using the currently requested http protocol version (see THttpRequest::getHttpProtocolVersion) Keep in mind that HTTP/1.0 clients might not understand all status codes from HTTP/1.1

      access

      public

      [ Top ]

      THttpResponse::write

      write( string $str );

      Parameters

      $str

      string to be output

      Remarks

      Outputs a string.

      It may not be sent back to user immediately if output buffer is enabled.

      access

      public

      [ Top ]

      THttpResponse::writeFile

      writeFile(
string
$fileName, [string
$content = null], [string
$mimeType = null], [array
$headers = null], [boolean
$forceDownload = true], [string
$clientFileName = null], [integer
$fileSize = null] );

      Parameters

      $fileName

      file name

      $content

      content to be set. If null, the content will be read from the server file pointed to by $fileName.

      $mimeType

      mime type of the content.

      $headers

      list of headers to be sent. Each array element represents a header string (e.g. 'Content-Type: text/plain').

      $forceDownload

      force download of file, even if browser able to display inline. Defaults to 'true'.

      $clientFileName

      force a specific file name on client side. Defaults to 'null' means auto-detect.

      $fileSize

      size of file or content in bytes if already known. Defaults to 'null' means auto-detect.

      Remarks

      Sends a file back to user.

      Make sure not to output anything else after calling this method.

      throws

      TInvalidDataValueException if the file cannot be found

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • DEFAULT_CHARSET =  'UTF-8' [line 70]

    • DEFAULT_CONTENTTYPE =  'text/html' [line 69]

    Documentation generated on Mon, 25 Jun 2012 14:44:30 +0200 by phpDocumentor 1.4.3


Docs For Class THttpResponseAdapter

Class THttpResponseAdapter

[line 24]
TComponent
   |
   --TApplicationComponent
      |
      --THttpResponseAdapter
Classes extended from THttpResponseAdapter:
TCallbackResponseAdapter
TCallbackResponseAdapter alters the THttpResponse's outputs.

Location: /Web/THttpResponseAdapter.php

Remarks

THttpResponseAdapter class.

THttpResponseAdapter allows the base http response class to change behavior without change the class hierarchy.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    THttpResponseAdapter::__construct

    __construct( THttpResponse $response );

    Parameters

    $response

    the response object the adapter is to attach to.

    Remarks

    Constructor. Attach a response to be adapted.

    access

    public

    [ Top ]

    THttpResponseAdapter::createNewHtmlWriter

    createNewHtmlWriter( string $type, ITextWriter $writer );

    Overridden in child classes as:

    TCallbackResponseAdapter::createNewHtmlWriter()
    Returns a new instance of THtmlWriter.

    Parameters

    $type

    type of the HTML writer to be created.

    $writer

    the writer responsible for holding the content.

    Remarks

    This method is invoked when a new HtmlWriter needs to be created.

    Default implementation calls the attached response createNewHtmlWriter method.

    access

    public

    [ Top ]

    THttpResponseAdapter::flushContent

    flushContent( );

    Overridden in child classes as:

    TCallbackResponseAdapter::flushContent()
    Flushes the contents in the writers.

    Remarks

    This method is invoked when the response flushes the content and headers.

    Default implementation calls the attached response flushContent method.

    access

    public

    [ Top ]

    THttpResponseAdapter::getResponse

    getResponse( );

    Overrides TApplicationComponent::getResponse() (parent method not documented)

    Returns

    the response object adapted.

    access

    public

    [ Top ]

    THttpResponseAdapter::httpRedirect

    httpRedirect( string $url );

    Overridden in child classes as:

    TCallbackResponseAdapter::httpRedirect()
    Delay the redirect until we process the rest of the page.

    Parameters

    $url

    new url to redirect to.

    Remarks

    This method is invoked when the response is to redirect to another page.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:30 +0200 by phpDocumentor 1.4.3


Docs For Class THttpSession

Class THttpSession

[line 64]
TComponent
   |
   --TApplicationComponent
      |
      --THttpSession
Classes extended from THttpSession:
TCacheHttpSession
TCacheHttpSession class

Location: /Web/THttpSession.php

Remarks

THttpSession class

THttpSession provides session-level data management and the related configurations. To start the session, call open; to complete and send out session data, call close; to destroy the session, call destroy. If AutoStart is true, then the session will be started once the session module is loaded and initialized.

To access data stored in session, use THttpSession like an associative array. For example,

  •    $session=new THttpSession;
    •

  •    $session->open();
    •

  •    $value1=$session['name1'];  // get session variable 'name1'
    •

  •    $value2=$session['name2'];  // get session variable 'name2'
    •

  •    foreach($session as $name=>$value) // traverse all session variables
    •

  •    $session['name3']=$value3;  // set session variable 'name3'
    •

    The following configurations are available for session: AutoStart, CookieMode, SavePath, UseCustomStorage, GCProbability, Timeout. See the corresponding setter and getter documentation for more information. Note, these properties must be set before the session is started.

    THttpSession can be inherited with customized session storage method. Override _open, _close, _read, _write, _destroy and _gc and set UseCustomStorage to true. Then, the session data will be stored using the above methods.

    By default, THttpSession is registered with TApplication as the request module. It can be accessed via TApplication::getSession().

    THttpSession may be configured in application configuration file as follows,

  •  <module id="session" class="THttpSession" SessionName="SSID" SavePath="/tmp"
    •

  •          CookieMode="Allow" UseCustomStorage="false" AutoStart="true" GCProbability="1"
    •

  •          UseTransparentSessionID="true" TimeOut="3600" />
    •
    where SessionName, SavePath, CookieMode, UseCustomStorage, AutoStart, GCProbability, UseTransparentSessionID and TimeOut are configurable properties of THttpSession.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: THttpSession.php 3114 2012-02-28 09:52:47Z GODZilla0480@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      THttpSession::add

      add( mixed $key, mixed $value );

      Parameters

      $key

      session variable name

      $value

      session variable value

      Remarks

      Adds a session variable.

      Note, if the specified name already exists, the old value will be removed first.

      access

      public

      [ Top ]

      THttpSession::clear

      clear( );

      Remarks

      Removes all session variables

      access

      public

      [ Top ]

      THttpSession::close

      close( );

      Remarks

      Ends the current session and store session data.

      access

      public

      [ Top ]

      THttpSession::contains

      contains( mixed $key );

      Parameters

      $key

      session variable name

      Returns

      whether there is the named session variable

      access

      public

      [ Top ]

      THttpSession::count

      count( );

      Implementation of:
      Countable::count

      Returns

      number of items in the session.

      Remarks

      Returns the number of items in the session.

      This method is required by Countable interface.

      access

      public

      [ Top ]

      THttpSession::destroy

      destroy( );

      Remarks

      Destroys all data registered to a session.

      access

      public

      [ Top ]

      THttpSession::getAutoStart

      getAutoStart( );

      Returns

      whether the session should be automatically started when the session module is initialized, defaults to false.

      access

      public

      [ Top ]

      THttpSession::getCookie

      getCookie( );

      Returns

      cookie that will be used to store session ID

      access

      public

      [ Top ]

      THttpSession::getCookieMode

      getCookieMode( );

      Returns

      how to use cookie to store session ID. Defaults to THttpSessionCookieMode::Allow.

      access

      public

      [ Top ]

      THttpSession::getCount

      getCount( );

      Returns

      the number of session variables

      access

      public

      [ Top ]

      THttpSession::getGCProbability

      getGCProbability( );

      Returns

      the probability (percentage) that the gc (garbage collection) process is started on every session initialization, defaults to 1 meaning 1% chance.

      access

      public

      [ Top ]

      THttpSession::getID

      getID( );

      Returns

      id of this module

      access

      public

      [ Top ]

      THttpSession::getIsStarted

      getIsStarted( );

      Returns

      whether the session has started

      access

      public

      [ Top ]

      THttpSession::getIterator

      getIterator( );

      Implementation of:
      IteratorAggregate::getIterator

      Returns

      an iterator for traversing the session variables.

      Remarks

      Returns an iterator for traversing the session variables.

      This method is required by the interface IteratorAggregate.

      access

      public

      [ Top ]

      THttpSession::getKeys

      getKeys( );

      Returns

      the list of session variable names

      access

      public

      [ Top ]

      THttpSession::getSavePath

      getSavePath( );

      Returns

      the current session save path, defaults to '/tmp'.

      access

      public

      [ Top ]

      THttpSession::getSessionID

      getSessionID( );

      Returns

      the current session ID

      access

      public

      [ Top ]

      THttpSession::getSessionName

      getSessionName( );

      Returns

      the current session name

      access

      public

      [ Top ]

      THttpSession::getTimeout

      getTimeout( );

      Returns

      the number of seconds after which data will be seen as 'garbage' and cleaned up, defaults to 1440 seconds.

      access

      public

      [ Top ]

      THttpSession::getUseCustomStorage

      getUseCustomStorage( );

      Returns

      whether to use user-specified handlers to store session data. Defaults to false.

      access

      public

      [ Top ]

      THttpSession::getUseTransparentSessionID

      getUseTransparentSessionID( );

      Returns

      whether transparent sid support is enabled or not, defaults to false.

      access

      public

      [ Top ]

      THttpSession::init

      init( TXmlElement $config );

      Overridden in child classes as:

      TCacheHttpSession::init()
      Initializes the module.

      Parameters

      $config

      module configuration

      Remarks

      Initializes the module.

      This method is required by IModule. If AutoStart is true, the session will be started.

      access

      public

      [ Top ]

      THttpSession::itemAt

      itemAt( mixed $key );

      Parameters

      $key

      the session variable name

      Returns

      the session variable value, null if no such variable exists

      Remarks

      Returns the session variable value with the session variable name.

      This method is exactly the same as offsetGet.

      access

      public

      [ Top ]

      THttpSession::offsetExists

      offsetExists( mixed $offset );

      Implementation of:
      ArrayAccess::offsetExists

      Parameters

      $offset

      the offset to check on

      Remarks

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      THttpSession::offsetGet

      offsetGet( integer $offset );

      Implementation of:
      ArrayAccess::offsetGet

      Parameters

      $offset

      the offset to retrieve element.

      Returns

      the element at the offset, null if no element is found at the offset

      Remarks

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      THttpSession::offsetSet

      offsetSet( integer $offset, mixed $item );

      Implementation of:
      ArrayAccess::offsetSet

      Parameters

      $offset

      the offset to set element

      $item

      the element value

      Remarks

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      THttpSession::offsetUnset

      offsetUnset( mixed $offset );

      Implementation of:
      ArrayAccess::offsetUnset

      Parameters

      $offset

      the offset to unset element

      Remarks

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      THttpSession::open

      open( );

      Remarks

      Starts the session if it has not started yet.

      access

      public

      [ Top ]

      THttpSession::regenerate

      regenerate( [boolean $deleteOld = false] );

      Parameters

      $deleteOld

      Whether to delete the old associated session or not.

      Returns

      old session id

      Remarks

      Update the current session id with a newly generated one

      link

      http://php.net/manual/en/function.session-regenerate-id.php

      access

      public

      [ Top ]

      THttpSession::remove

      remove( mixed $key );

      Parameters

      $key

      the name of the session variable to be removed

      Returns

      the removed value, null if no such session variable.

      Remarks

      Removes a session variable.

      access

      public

      [ Top ]

      THttpSession::setAutoStart

      setAutoStart( boolean $value );

      Parameters

      $value

      whether the session should be automatically started when the session module is initialized, defaults to false.

      throws

      TInvalidOperationException if session is started already

      access

      public

      [ Top ]

      THttpSession::setCookieMode

      setCookieMode( THttpSessionCookieMode $value );

      Parameters

      $value

      how to use cookie to store session ID

      throws

      TInvalidOperationException if session is started already

      access

      public

      [ Top ]

      THttpSession::setGCProbability

      setGCProbability( integer $value );

      Parameters

      $value

      the probability (percentage) that the gc (garbage collection) process is started on every session initialization.

      throws

      TInvalidDataValueException if the value is beyond [0,100].

      throws

      TInvalidOperationException if session is started already

      access

      public

      [ Top ]

      THttpSession::setID

      setID( string $value );

      Parameters

      $value

      id of this module

      access

      public

      [ Top ]

      THttpSession::setSavePath

      setSavePath( string $value );

      Parameters

      $value

      the current session save path

      throws

      TInvalidOperationException if session is started already

      access

      public

      [ Top ]

      THttpSession::setSessionID

      setSessionID( string $value );

      Parameters

      $value

      the session ID for the current session

      throws

      TInvalidOperationException if session is started already

      access

      public

      [ Top ]

      THttpSession::setSessionName

      setSessionName( string $value );

      Parameters

      $value

      the session name for the current session, must be an alphanumeric string, defaults to PHPSESSID

      throws

      TInvalidOperationException if session is started already

      access

      public

      [ Top ]

      THttpSession::setTimeout

      setTimeout( integer $value );

      Parameters

      $value

      the number of seconds after which data will be seen as 'garbage' and cleaned up

      throws

      TInvalidOperationException if session is started already

      access

      public

      [ Top ]

      THttpSession::setUseCustomStorage

      setUseCustomStorage( boolean $value );

      Parameters

      $value

      whether to use user-specified handlers to store session data. If true, make sure the methods _open, _close, _read, _write, _destroy, and _gc are overridden in child class, because they will be used as the callback handlers.

      access

      public

      [ Top ]

      THttpSession::setUseTransparentSessionID

      setUseTransparentSessionID( boolean $value );

      Parameters

      $value

      whether transparent sid support is enabled or not.

      access

      public

      [ Top ]

      THttpSession::toArray

      toArray( );

      Returns

      the list of all session variables in array

      access

      public

      [ Top ]

      THttpSession::_close

      _close( );

      Returns

      whether session is closed successfully

      Remarks

      Session close handler.

      This method should be overridden if UseCustomStorage is set true.

      access

      public

      [ Top ]

      THttpSession::_destroy

      _destroy( string $id );

      Overridden in child classes as:

      TCacheHttpSession::_destroy()
      Session destroy handler.

      Parameters

      $id

      session ID

      Returns

      whether session is destroyed successfully

      Remarks

      Session destroy handler.

      This method should be overridden if UseCustomStorage is set true.

      access

      public

      [ Top ]

      THttpSession::_gc

      _gc( integer $maxLifetime );

      Parameters

      $maxLifetime

      the number of seconds after which data will be seen as 'garbage' and cleaned up.

      Returns

      whether session is GCed successfully

      Remarks

      Session GC (garbage collection) handler.

      This method should be overridden if UseCustomStorage is set true.

      access

      public

      [ Top ]

      THttpSession::_open

      _open( string $savePath, string $sessionName );

      Parameters

      $savePath

      session save path

      $sessionName

      session name

      Returns

      whether session is opened successfully

      Remarks

      Session open handler.

      This method should be overridden if UseCustomStorage is set true.

      access

      public

      [ Top ]

      THttpSession::_read

      _read( string $id );

      Overridden in child classes as:

      TCacheHttpSession::_read()
      Session read handler.

      Parameters

      $id

      session ID

      Returns

      the session data

      Remarks

      Session read handler.

      This method should be overridden if UseCustomStorage is set true.

      access

      public

      [ Top ]

      THttpSession::_write

      _write( string $id, string $data );

      Overridden in child classes as:

      TCacheHttpSession::_write()
      Session write handler.

      Parameters

      $id

      session ID

      $data

      session data

      Returns

      whether session write is successful

      Remarks

      Session write handler.

      This method should be overridden if UseCustomStorage is set true.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:30 +0200 by phpDocumentor 1.4.3


Docs For Class THttpSessionCookieMode

Class THttpSessionCookieMode

[line 724]
TEnumerable
   |
   --THttpSessionCookieMode
Location: /Web/THttpSession.php

Remarks

THttpSessionCookieMode class.

THttpSessionCookieMode defines the enumerable type for the possible methods of using cookies to store session ID.

The following enumerable values are defined:

  • None: not using cookie.
  • Allow: using cookie.
  • Only: using cookie only.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THttpSession.php 3114 2012-02-28 09:52:47Z GODZilla0480@gmail.com $

since

3.0.4

Class Variable Summary

Class Constant Summary

  • Allow = 'Allow'
  • None = 'None'
  • Only = 'Only'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Allow = 'Allow' [line 727]

  • None = 'None' [line 726]

  • Only = 'Only' [line 728]

Documentation generated on Mon, 25 Jun 2012 14:44:31 +0200 by phpDocumentor 1.4.3


Docs For Class TSessionIterator

Class TSessionIterator

[line 635]

Location: /Web/THttpSession.php

Remarks

TSessionIterator class

TSessionIterator implements Iterator interface.
TSessionIterator is used by THttpSession. It allows THttpSession to return a new iterator  for traversing the session variables.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THttpSession.php 3114 2012-02-28 09:52:47Z GODZilla0480@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TSessionIterator::__construct

__construct(
array
0 );

    Parameters

    0

    the data to be iterated through

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TSessionIterator::current

current(
 );

    Implementation of:

    Iterator::current

    Returns

    the current array element

    Remarks

    Returns the current array element.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TSessionIterator::key

key(
 );

    Implementation of:

    Iterator::key

    Returns

    the key of the current array element

    Remarks

    Returns the key of the current array element.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TSessionIterator::next

next(
 );

    Implementation of:

    Iterator::next

    Remarks

    Moves the internal pointer to the next array element.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TSessionIterator::rewind

rewind(
 );

    Implementation of:

    Iterator::rewind

    Remarks

    Rewinds internal array pointer.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TSessionIterator::valid

valid(
 );

    Implementation of:

    Iterator::valid

    Remarks

    Returns whether there is an element at current position.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:31 +0200 by phpDocumentor 1.4.3


Docs For Class THttpUtility

Class THttpUtility

[line 21]

Location: /Web/THttpUtility.php

Remarks

THttpUtility class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THttpUtility.php 3005 2011-06-26 21:58:28Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static string htmlDecode()

    HTML-decodes a string.

  • static string htmlEncode()

    HTML-encodes a string.

  • static string htmlStrip()

    This method strips the following characters from a string:

  • string htmlDecode()

    HTML-decodes a string.

  • string htmlEncode()

    HTML-encodes a string.

  • string htmlStrip()

    This method strips the following characters from a string:

Inherited Method Summary

Method Detail

    static THttpUtility::htmlDecode

static htmlDecode(
string
$s );

    Parameters

    $s

    string to be decoded

    Returns

    decoded string

    Remarks

    HTML-decodes a string.

    It is the inverse of htmlEncode.

    access

    public

    [ Top ]

    static THttpUtility::htmlEncode

static htmlEncode(
string
$s );

    Parameters

    $s

    string to be encoded

    Returns

    encoded string

    Remarks

    HTML-encodes a string.

    This method translates the following characters to their corresponding  HTML entities: <, >, "  Note, unlike http://www.php.net/htmlspecialchars, & is not translated.

    access

    public

    [ Top ]

    static THttpUtility::htmlStrip

static htmlStrip(
string
$s );

    Parameters

    $s

    string to be encoded

    Returns

    encoded string

    Remarks

    This method strips the following characters from a string:

    HTML entities: <, >, "

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:31 +0200 by phpDocumentor 1.4.3


Docs For Class TUrlManager

Class TUrlManager

[line 33]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TUrlManager
Classes extended from TUrlManager:
TUrlMapping
TUrlMapping Class

Location: /Web/TUrlManager.php

Remarks

TUrlManager class

TUrlManager is the base class for managing URLs that can be recognized by PRADO applications. It provides the default implementation for parsing and constructing URLs.

Derived classes may override constructUrl and parseUrl to provide customized URL schemes.

By default, THttpRequest uses TUrlManager as its URL manager. If you want to use your customized URL manager, load your manager class as an application module and set THttpRequest::setUrlManager with the ID of your URL manager module.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id $

since

3.0.6

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TUrlManager::constructUrl

    constructUrl( string $serviceID, string $serviceParam, array $getItems, boolean $encodeAmpersand, boolean $encodeGetItems );

    Overridden in child classes as:

    TUrlMapping::constructUrl()
    Constructs a URL that can be recognized by PRADO.

    Parameters

    $serviceID

    service ID

    $serviceParam

    service parameter

    $getItems

    GET parameters, null if not provided

    $encodeAmpersand

    whether to encode the ampersand in URL

    $encodeGetItems

    whether to encode the GET parameters (their names and values)

    Returns

    URL

    Remarks

    Constructs a URL that can be recognized by PRADO.

    This method provides the actual implementation used by THttpRequest::constructUrl. Override this method if you want to provide your own way of URL formatting. If you do so, you may also need to override parseUrl so that the URL can be properly parsed.

    The URL is constructed as the following format: /entryscript.php?serviceID=serviceParameter&get1=value1&... If THttpRequest::setUrlFormat is 'Path', the following format is used instead: /entryscript.php/serviceID/serviceParameter/get1,value1/get2,value2...

    see

    TUrlManager::parseUrl()

    access

    public

    [ Top ]

    TUrlManager::parseUrl

    parseUrl( );

    Overridden in child classes as:

    TUrlMapping::parseUrl()
    Parses the request URL and returns an array of input parameters.

    Returns

    list of input parameters, indexed by parameter names

    Remarks

    Parses the request URL and returns an array of input parameters.

    This method is automatically invoked by THttpRequest when handling a user request.

    In general, this method should parse the path info part of the requesting URL and generate an array of name-value pairs according to some scheme. The current implementation deals with both 'Get' and 'Path' URL formats.

    You may override this method to support customized URL format.

    see

    TUrlManager::constructUrl()

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:44 +0200 by phpDocumentor 1.4.3


Docs For Class TUrlMapping

Class TUrlMapping

[line 70]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TUrlManager
            |
            --TUrlMapping
Location: /Web/TUrlMapping.php

Remarks

TUrlMapping Class

The TUrlMapping module allows PRADO to construct and recognize URLs based on specific patterns.

TUrlMapping consists of a list of URL patterns which are used to match against the currently requested URL. The first matching pattern will then be used to decompose the URL into request parameters (accessible through

  • $this->Request['paramname']
    •
    ).

    The patterns can also be used to construct customized URLs. In this case, the parameters in an applied pattern will be replaced with the corresponding GET variable values.

    Since it is derived from TUrlManager, it should be configured globally in the application configuration like the following,

  •   <module id="request" class="THttpRequest" UrlManager="friendly-url" />
    •

  •   <module id="friendly-url" class="System.Web.TUrlMapping" EnableCustomUrl="true">
    •

  •     <url ServiceParameter="Posts.ViewPost" pattern="post/{id}/" parameters.id="\d+" />
    •

  •     <url ServiceParameter="Posts.ListPost" pattern="archive/{time}/" parameters.time="\d{6}" />
    •

  •     <url ServiceParameter="Posts.ListPost" pattern="category/{cat}/" parameters.cat="\d+" />
    •

  •   </module>
    •

    In the above, each <tt>&lt;url&gt;</tt> element specifies a URL pattern represented as a TUrlMappingPattern internally. You may create your own pattern classes by extending TUrlMappingPattern and specifying the <tt>&lt;class&gt;</tt> attribute in the element.

    The patterns can be also be specified in an external file using the ConfigFile property.

    The URL mapping are evaluated in order, only the first mapping that matches the URL will be used. Cascaded mapping can be achieved by placing the URL mappings in particular order. For example, placing the most specific mappings first.

    Only the PATH_INFO part of the URL is used to match the available patterns. The matching is strict in the sense that the whole pattern must match the whole PATH_INFO of the URL.

    From PRADO v3.1.1, TUrlMapping also provides support for constructing URLs according to the specified pattern. You may enable this functionality by setting EnableCustomUrl to true. When you call THttpRequest::constructUrl() (or via TPageService::constructUrl()), TUrlMapping will examine the available URL mapping patterns using their TUrlMappingPattern::getServiceParameter and TUrlMappingPattern::getPattern properties. A pattern is applied if its TUrlMappingPattern::getServiceParameter matches the service parameter passed to constructUrl() and every parameter in the getPattern is found in the GET variables.

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: TUrlMapping.php 3051 2011-10-17 07:36:47Z GODZilla0480@gmail.com $

    since

    3.0.5

    Class Variable Summary

    • $_constructRules = array()
    • $_patterns = array()

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TUrlManager

    • TUrlManager::constructUrl()
      Constructs a URL that can be recognized by PRADO.
    • TUrlManager::parseUrl()
      Parses the request URL and returns an array of input parameters.

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TUrlMapping::constructUrl

      constructUrl( string $serviceID, string $serviceParam, array $getItems, boolean $encodeAmpersand, boolean $encodeGetItems );

      Overrides TUrlManager::constructUrl() (Constructs a URL that can be recognized by PRADO.)

      Parameters

      $serviceID

      service ID

      $serviceParam

      service parameter

      $getItems

      GET parameters, null if not provided

      $encodeAmpersand

      whether to encode the ampersand in URL

      $encodeGetItems

      whether to encode the GET parameters (their names and values)

      Returns

      URL

      Remarks

      Constructs a URL that can be recognized by PRADO.

      This method provides the actual implementation used by THttpRequest::constructUrl. Override this method if you want to provide your own way of URL formatting. If you do so, you may also need to override parseUrl so that the URL can be properly parsed.

      The URL is constructed as the following format: /entryscript.php?serviceID=serviceParameter&get1=value1&... If THttpRequest::setUrlFormat is 'Path', the following format is used instead: /entryscript.php/serviceID/serviceParameter/get1,value1/get2,value2...

      see

      TUrlMapping::parseUrl()

      since

      3.1.1

      access

      public

      [ Top ]

      TUrlMapping::getConfigFile

      getConfigFile( );

      Returns

      external configuration file. Defaults to null.

      access

      public

      [ Top ]

      TUrlMapping::getDefaultMappingClass

      getDefaultMappingClass( );

      Returns

      the default class of URL mapping patterns. Defaults to TUrlMappingPattern.

      since

      3.1.1

      access

      public

      [ Top ]

      TUrlMapping::getEnableCustomUrl

      getEnableCustomUrl( );

      Returns

      whether to enable custom constructUrl. Defaults to false.

      Remarks

      Returns a value indicating whether to enable custom constructUrl.

      If true, constructUrl() will make use of the URL mapping rules to construct valid URLs.

      since

      3.1.1

      access

      public

      [ Top ]

      TUrlMapping::getMatchingPattern

      getMatchingPattern( );

      Returns

      the matched pattern, null if not found.

      access

      public

      [ Top ]

      TUrlMapping::getUrlPrefix

      getUrlPrefix( );

      Returns

      the part that will be prefixed to the constructed URLs. Defaults to the requested script path (e.g. /path/to/index.php for a URL http://hostname/path/to/index.php)

      since

      3.1.1

      access

      public

      [ Top ]

      TUrlMapping::init

      init( mixed $config );

      Overrides TModule::init() (Initializes the module.)

      Parameters

      $config

      configuration for this module, can be null

      Remarks

      Initializes this module.

      This method is required by the IModule interface.

      throws

      TConfigurationException if module is configured in the global scope.

      access

      public

      [ Top ]

      TUrlMapping::loadConfigFile

      loadConfigFile( );

      Remarks

      Initialize the module from configuration file.

      throws

      TConfigurationException if ConfigFile is invalid.

      access

      protected

      [ Top ]

      TUrlMapping::loadUrlMappings

      loadUrlMappings( mixed $config );

      Parameters

      $config

      configuration node

      Remarks

      Load and configure each url mapping pattern.

      throws

      TConfigurationException if specific pattern class is invalid

      access

      protected

      [ Top ]

      TUrlMapping::parseUrl

      parseUrl( );

      Overrides TUrlManager::parseUrl() (Parses the request URL and returns an array of input parameters.)

      Returns

      list of input parameters

      Remarks

      Parses the request URL and returns an array of input parameters.

      This method overrides the parent implementation. The input parameters do not include GET and POST variables. This method uses the request URL path to find the first matching pattern. If found the matched pattern parameters are used to return as the input parameters.

      access

      public

      [ Top ]

      TUrlMapping::setConfigFile

      setConfigFile( string $value );

      Parameters

      $value

      external configuration file in namespace format. The file must be suffixed with '.xml'.

      throws

      TInvalidDataValueException if the file is invalid.

      access

      public

      [ Top ]

      TUrlMapping::setDefaultMappingClass

      setDefaultMappingClass( string $value );

      Parameters

      $value

      the default class of URL mapping patterns.

      Remarks

      Sets the default class of URL mapping patterns.

      When a URL matching pattern does not specify "class" attribute, it will default to the class specified by this property. You may use either a class name or a namespace format of class (if the class needs to be included first.)

      since

      3.1.1

      access

      public

      [ Top ]

      TUrlMapping::setEnableCustomUrl

      setEnableCustomUrl( boolean $value );

      Parameters

      $value

      whether to enable custom constructUrl.

      Remarks

      Sets a value indicating whether to enable custom constructUrl.

      If true, constructUrl() will make use of the URL mapping rules to construct valid URLs.

      since

      3.1.1

      access

      public

      [ Top ]

      TUrlMapping::setUrlPrefix

      setUrlPrefix( string $value );

      Parameters

      $value

      the part that will be prefixed to the constructed URLs. This is used by constructUrl() when EnableCustomUrl is set true.

      see

      TUrlMapping::getUrlPrefix()

      since

      3.1.1

      access

      public

      [ Top ]

    Variable Detail

    • $_constructRules = array() [line 91]
    • Data type: array

      • var

      rules for constructing URLs

      access

      protected

    • $_patterns = array() [line 75]
    • Data type: TUrlMappingPattern[]

      • var

      list of patterns.

      access

      protected

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:44 +0200 by phpDocumentor 1.4.3


Docs For Class TUrlMappingPattern

Class TUrlMappingPattern

[line 473]
TComponent
   |
   --TUrlMappingPattern
Location: /Web/TUrlMapping.php

Remarks

TUrlMappingPattern class.

TUrlMappingPattern represents a pattern used to parse and construct URLs. If the currently requested URL matches the pattern, it will alter the THttpRequest parameters. If a constructUrl() call matches the pattern parameters, the pattern will generate a valid URL. In both case, only the PATH_INFO part of a URL is parsed/constructed using the pattern.

To specify the pattern, set the Pattern property. Pattern takes a string expression with parameter names enclosed between a left brace '{' and a right brace '}'. The patterns for each parameter can be set using Parameters attribute collection. For example

  •  <url ... pattern="articles/{year}/{month}/{day}"
    •

  •           parameters.year="\d{4}" parameters.month="\d{2}" parameters.day="\d+" />
    •

    In the above example, the pattern contains 3 parameters named "year", "month" and "day". The pattern for these parameters are, respectively, "\d{4}" (4 digits), "\d{2}" (2 digits) and "\d+" (1 or more digits). Essentially, the <tt>Parameters</tt> attribute name and values are used as substrings in replacing the placeholders in the <tt>Pattern</tt> string to form a complete regular expression string.

    For more complicated patterns, one may specify the pattern using a regular expression by RegularExpression. For example, the above pattern is equivalent to the following regular expression-based pattern:

  •  #^articles/(?P<year>\d{4})/(?P<month>\d{2})\/(?P<day>\d+)$#u
    •
    The above regular expression used the "named group" feature available in PHP. If you intended to use the <tt>RegularExpression</tt> property or regular expressions in CDATA sections, notice that you need to escape the slash, if you are using the slash as regular expressions delimiter.

    Thus, only an url that matches the pattern will be valid. For example, a URL <tt>http://example.com/index.php/articles/2006/07/21</tt> will match the above pattern, while <tt>http://example.com/index.php/articles/2006/07/hello</tt> will not since the "day" parameter pattern is not satisfied.

    The parameter values are available through the <tt>THttpRequest</tt> instance (e.g. <tt>$this->Request['year']</tt>).

    The ServiceParameter and ServiceID (the default ID is 'page') set the service parameter and service id respectively.

    Since 3.1.4 you can also use simplyfied wildcard patterns to match multiple ServiceParameters with a single rule. The pattern must contain the placeholder {*} for the ServiceParameter. For example

    <url ServiceParameter="adminpages.*" pattern="admin/{*}" />

    This rule will match an URL like <tt>http://example.com/index.php/admin/edituser</tt> and resolve it to the page Application.pages.admin.edituser. The wildcard matching is non-recursive. That means you have to add a rule for every subdirectory you want to access pages in:

    <url ServiceParameter="adminpages.users.*" pattern="useradmin/{*}" />

    It is still possible to define an explicit rule for a page in the wildcard path. This rule has to preceed the wildcard rule.

    You can also use parameters with wildcard patterns. The parameters are then available with every matching page:

    <url ServiceParameter="adminpages.*" pattern="admin/{*}/{id}" parameters.id="\d+" />

    To enable automatic parameter encoding in a path format fro wildcard patterns you can set {@setUrlFormat UrlFormat} to 'Path':

    <url ServiceParameter="adminpages.*" pattern="admin/{*}" UrlFormat="Path" />

    This will create and parse URLs of the form <tt>.../index.php/admin/listuser/param1/value1/param2/value2</tt>.

    Use {@setUrlParamSeparator} to define another separator character between parameter name and value. Parameter/value pairs are always separated by a '/'.

    <url ServiceParameter="adminpages.*" pattern="admin/{*}" UrlFormat="Path" UrlParamSeparator="-" />

    <tt>.../index.php/admin/listuser/param1-value1/param2-value2</tt>.

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: TUrlMapping.php 3051 2011-10-17 07:36:47Z GODZilla0480@gmail.com $

    since

    3.0.5

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TUrlMappingPattern::__construct

      __construct( TUrlManager $manager );

      Parameters

      $manager

      the URL manager instance

      Remarks

      Constructor.

      access

      public

      [ Top ]

      TUrlMappingPattern::applySecureConnectionPrefix

      applySecureConnectionPrefix( string $url );

      Parameters

      $url

      Remarks

      Apply behavior of SecureConnection property by conditionaly prefixing URL with THttpRequest::getBaseUrl()

      since

      3.2

      access

      protected

      [ Top ]

      TUrlMappingPattern::constructUrl

      constructUrl( array $getItems, boolean $encodeAmpersand, boolean $encodeGetItems );

      Parameters

      $getItems

      list of GET variables

      $encodeAmpersand

      whether the ampersand should be encoded in the constructed URL

      $encodeGetItems

      whether the GET variables should be encoded in the constructed URL

      Returns

      the constructed URL

      Remarks

      Constructs a URL using this pattern.

      since

      3.1.1

      access

      public

      [ Top ]

      TUrlMappingPattern::getCaseSensitive

      getCaseSensitive( );

      Returns

      whether the Pattern should be treated as case sensititve. Defaults to true.

      access

      public

      [ Top ]

      TUrlMappingPattern::getEnableCustomUrl

      getEnableCustomUrl( );

      Returns

      whether to enable custom constructUrl. Defaults to true.

      Remarks

      Returns a value indicating whether to use this pattern to construct URL.

      since

      3.1.1

      access

      public

      [ Top ]

      TUrlMappingPattern::getIsWildCardPattern

      getIsWildCardPattern( );

      Returns

      whether this pattern is a wildcard pattern

      since

      3.1.4

      access

      public

      [ Top ]

      TUrlMappingPattern::getManager

      getManager( );

      Returns

      the URL manager instance

      access

      public

      [ Top ]

      TUrlMappingPattern::getParameterizedPattern

      getParameterizedPattern( );

      Returns

      regular expression pattern with parameter subsitution

      Remarks

      Substitute the parameter key value pairs as named groupings in the regular expression matching pattern.

      access

      protected

      [ Top ]

      TUrlMappingPattern::getParameters

      getParameters( );

      Returns

      parameter key value pairs.

      access

      public

      [ Top ]

      TUrlMappingPattern::getPattern

      getPattern( );

      Returns

      url pattern to match. Defaults to ''.

      access

      public

      [ Top ]

      TUrlMappingPattern::getPatternMatches

      getPatternMatches( THttpRequest $request );

      Parameters

      $request

      the request module

      Returns

      matched parameters, empty if no matches.

      Remarks

      Uses URL pattern (or full regular expression if available) to match the given url path.

      access

      public

      [ Top ]

      TUrlMappingPattern::getRegularExpression

      getRegularExpression( );

      Returns

      full regular expression mapping pattern

      access

      public

      [ Top ]

      TUrlMappingPattern::getSecureConnection

      getSecureConnection( );

      Returns

      the SecureConnection behavior. Defaults to Automatic

      since

      3.2

      access

      public

      [ Top ]

      TUrlMappingPattern::getServiceID

      getServiceID( );

      Returns

      service id.

      access

      public

      [ Top ]

      TUrlMappingPattern::getServiceParameter

      getServiceParameter( );

      Returns

      service parameter, such as page class name.

      access

      public

      [ Top ]

      TUrlMappingPattern::getUrlFormat

      getUrlFormat( );

      Returns

      the format of URLs. Defaults to THttpRequestUrlFormat::Get.

      access

      public

      [ Top ]

      TUrlMappingPattern::getUrlParamSeparator

      getUrlParamSeparator( );

      Returns

      separator used to separate GET variable name and value when URL format is Path. Defaults to slash '/'.

      access

      public

      [ Top ]

      TUrlMappingPattern::init

      init( TXmlElement $config );

      Parameters

      $config

      configuration for this module.

      Remarks

      Initializes the pattern.

      throws

      TConfigurationException if service parameter is not specified

      access

      public

      [ Top ]

      TUrlMappingPattern::setCaseSensitive

      setCaseSensitive( boolean $value );

      Parameters

      $value

      whether the Pattern should be treated as case sensititve.

      access

      public

      [ Top ]

      TUrlMappingPattern::setEnableCustomUrl

      setEnableCustomUrl( boolean $value );

      Parameters

      $value

      whether to enable custom constructUrl.

      Remarks

      Sets a value indicating whether to enable custom constructUrl using this pattern

      access

      public

      [ Top ]

      TUrlMappingPattern::setParameters

      setParameters( TAttributeCollection $value );

      Parameters

      $value

      new parameter key value pairs.

      access

      public

      [ Top ]

      TUrlMappingPattern::setPattern

      setPattern( string $value );

      Parameters

      $value

      url pattern to match.

      access

      public

      [ Top ]

      TUrlMappingPattern::setRegularExpression

      setRegularExpression( string $value );

      Parameters

      $value

      full regular expression mapping pattern.

      access

      public

      [ Top ]

      TUrlMappingPattern::setSecureConnection

      setSecureConnection( TUrlMappingPatternSecureConnection $value );

      Parameters

      $value

      the SecureConnection behavior.

      since

      3.2

      access

      public

      [ Top ]

      TUrlMappingPattern::setServiceID

      setServiceID( string $value );

      Parameters

      $value

      service id to handle.

      access

      public

      [ Top ]

      TUrlMappingPattern::setServiceParameter

      setServiceParameter( string $value );

      Parameters

      $value

      service parameter, such as page class name.

      access

      public

      [ Top ]

      TUrlMappingPattern::setUrlFormat

      setUrlFormat( THttpRequestUrlFormat $value, since 1 );

      Parameters

      1

      3.1.4

      $value

      the format of URLs.

      Remarks

      Sets the format of URLs constructed and interpreted by this pattern.

      A Get URL format is like index.php?name1=value1&name2=value2 while a Path URL format is like index.php/name1/value1/name2/value. The separating character between name and value can be configured with setUrlParamSeparator and defaults to '/'. Changing the UrlFormat will affect constructUrl and how GET variables are parsed.

      access

      public

      [ Top ]

      TUrlMappingPattern::setUrlParamSeparator

      setUrlParamSeparator( string $value );

      Parameters

      $value

      separator used to separate GET variable name and value when URL format is Path.

      throws

      TInvalidDataValueException if the separator is not a single character

      access

      public

      [ Top ]

      TUrlMappingPattern::supportCustomUrl

      supportCustomUrl( array $getItems );

      Parameters

      $getItems

      list of GET items to be put in the constructed URL

      Returns

      whether this pattern IS the one for constructing the URL with the specified GET items.

      since

      3.1.1

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:44 +0200 by phpDocumentor 1.4.3


Docs For Class TUrlMappingPatternSecureConnection

Class TUrlMappingPatternSecureConnection

[line 937]
TEnumerable
   |
   --TUrlMappingPatternSecureConnection
Location: /Web/TUrlMapping.php

Remarks

TUrlMappingPatternSecureConnection class

TUrlMappingPatternSecureConnection defines the enumerable type for the possible SecureConnection URL prefix behavior that can be used by TUrlMappingPattern::constructUrl().

author

Yves Berkholz <godzilla80[at]gmx[dot]net>

version

$Id: TUrlMapping.php 3051 2011-10-17 07:36:47Z GODZilla0480@gmail.com $

since

3.2

Class Variable Summary

Class Constant Summary

  • Automatic =  'Automatic'
    Keep current SecureConnection status
  • Disable =  'Disable'
    Force use unsecured connection
  • DisableIfSecure =  'DisableIfSecure'
    Force use unsecured connection, if in secured mode
  • Enable =  'Enable'
    Force use secured connection
  • EnableIfNotSecure =  'EnableIfNotSecure'
    Force use secured connection, if in unsecured mode

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Automatic =  'Automatic' [line 943]

    • Remarks

    Keep current SecureConnection status

    means no prefixing

  • Disable =  'Disable' [line 955]

    • Remarks

    Force use unsecured connection

    always prefixing with http://example.com/path/to/app

  • DisableIfSecure =  'DisableIfSecure' [line 967]

    • Remarks

    Force use unsecured connection, if in secured mode

    prefixing with https://example.com/path/to/app

  • Enable =  'Enable' [line 949]

    • Remarks

    Force use secured connection

    always prefixing with https://example.com/path/to/app

  • EnableIfNotSecure =  'EnableIfNotSecure' [line 961]

    • Remarks

    Force use secured connection, if in unsecured mode

    prefixing with https://example.com/path/to/app

Documentation generated on Mon, 25 Jun 2012 14:45:45 +0200 by phpDocumentor 1.4.3


Package System.Collections Element Index

Element index for package System.Collections

Indexes by package:
System.Caching
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a c d e f g h i k l m n o p r s t v _
top
_
__construct in file TPriorityList.php, method TPriorityList::__construct()
Constructor.
__construct in file TPagedList.php, method TPagedListPageChangedEventParameter::__construct()
Constructor.
__construct in file TPagedList.php, method TPagedListFetchDataEventParameter::__construct()
Constructor.
__construct in file TPriorityMap.php, method TPriorityMap::__construct()
Constructor.
__construct in file TQueue.php, method TQueue::__construct()
Constructor.
__construct in file TStack.php, method TStackIterator::__construct()
Constructor.
__construct in file TStack.php, method TStack::__construct()
Constructor.
__construct in file TQueue.php, method TQueueIterator::__construct()
Constructor.
__construct in file TPagedList.php, method TPagedList::__construct()
Constructor.
__construct in file TPagedDataSource.php, method TPagedMapIterator::__construct()
Constructor.
__construct in file TDummyDataSource.php, method TDummyDataSourceIterator::__construct()
Constructor.
__construct in file TDummyDataSource.php, method TDummyDataSource::__construct()
Constructor.
__construct in file TList.php, method TList::__construct()
Constructor.
__construct in file TList.php, method TListIterator::__construct()
Constructor.
__construct in file TPagedDataSource.php, method TPagedListIterator::__construct()
Constructor.
__construct in file TMap.php, method TMapIterator::__construct()
Constructor.
__construct in file TMap.php, method TMap::__construct()
Constructor.
__get in file TAttributeCollection.php, method TAttributeCollection::__get()
Returns a property value or an event handler list by property or event name.
__set in file TAttributeCollection.php, method TAttributeCollection::__set()
Sets value of a component property.
top
a
add in file TPriorityMap.php, method TPriorityMap::add()
Adds an item into the map. A third parameter may be used to set the priority of the item within the map. Priority is primarily used during when flattening the map into an array where order may be and important factor of the key-value pairs within the array.
add in file TPriorityList.php, method TPriorityList::add()
Appends an item into the list at the end of the specified priority. The position of the added item may not be at the end of the list.
add in file TMap.php, method TMap::add()
Adds an item into the map.
add in file TList.php, method TList::add()
Appends an item at the end of the list.
add in file TAttributeCollection.php, method TAttributeCollection::add()
Adds an item into the map.
top
c
canGetProperty in file TAttributeCollection.php, method TAttributeCollection::canGetProperty()
Determines whether a property can be read.
canSetProperty in file TAttributeCollection.php, method TAttributeCollection::canSetProperty()
Determines whether a property can be set.
clear in file TMap.php, method TMap::clear()
Removes all items in the map.
clear in file TPriorityMap.php, method TPriorityMap::clear()
Removes all items in the map. remove is called on all items.
clear in file TStack.php, method TStack::clear()
Removes all items in the stack.
clear in file TQueue.php, method TQueue::clear()
Removes all items in the queue.
clear in file TPriorityList.php, method TPriorityList::clear()
Removes all items in the priority list by calling removeAtIndexInPriority from the last item to the first.
clear in file TList.php, method TList::clear()
Removes all items in the list.
contains | in file TMap.php, method TMap::contains()
contains in file TAttributeCollection.php, method TAttributeCollection::contains()
Returns whether the specified is in the map.
contains | in file TPriorityList.php, method TPriorityList::contains()
contains | in file TPriorityMap.php, method TPriorityMap::contains()
contains | in file TList.php, method TList::contains()
contains | in file TStack.php, method TStack::contains()
contains | in file TQueue.php, method TQueue::contains()
copyFrom in file TPriorityList.php, method TPriorityList::copyFrom()
Copies iterable data into the priority list.
copyFrom in file TPriorityMap.php, method TPriorityMap::copyFrom()
Copies iterable data into the map.
copyFrom in file TQueue.php, method TQueue::copyFrom()
Copies iterable data into the queue.
copyFrom in file TList.php, method TList::copyFrom()
Copies iterable data into the list.
copyFrom in file TStack.php, method TStack::copyFrom()
Copies iterable data into the stack.
copyFrom in file TMap.php, method TMap::copyFrom()
Copies iterable data into the map.
count in file TQueue.php, method TQueue::count()
Returns the number of items in the queue.
count in file TPriorityMap.php, method TPriorityMap::count()
Returns the number of items in the map.
count in file TMap.php, method TMap::count()
Returns the number of items in the map.
count in file TStack.php, method TStack::count()
Returns the number of items in the stack.
count in file TPriorityList.php, method TPriorityList::count()
Returns the number of items in the list.
count in file TDummyDataSource.php, method TDummyDataSource::count()
Returns the number of (virtual) items in the data source.
count in file TPagedDataSource.php, method TPagedDataSource::count()
Returns the number of items in the current page.
count in file TList.php, method TList::count()
Returns the number of items in the list.
createListItem in file TListItemCollection.php, method TListItemCollection::createListItem()
Creates a list item object.
createNewListItem | in file TListItemCollection.php, method TListItemCollection::createNewListItem()
current in file TStack.php, method TStackIterator::current()
Returns the current array item.
current in file TPagedDataSource.php, method TPagedListIterator::current()
Returns the current array item.
current in file TDummyDataSource.php, method TDummyDataSourceIterator::current()
Returns the current array item.
current in file TList.php, method TListIterator::current()
Returns the current array item.
current in file TMap.php, method TMapIterator::current()
Returns the current array element.
current in file TPagedDataSource.php, method TPagedMapIterator::current()
Returns the current array item.
current in file TQueue.php, method TQueueIterator::current()
Returns the current array item.
top
d
dequeue in file TQueue.php, method TQueue::dequeue()
Removes and returns the object at the beginning of the queue.
top
e
enqueue in file TQueue.php, method TQueue::enqueue()
Adds an object to the end of the queue.
top
f
findIndexByText in file TListItemCollection.php, method TListItemCollection::findIndexByText()
Finds the lowest cardinal index of the item whose text is the one being looked for.
findIndexByValue in file TListItemCollection.php, method TListItemCollection::findIndexByValue()
Finds the lowest cardinal index of the item whose value is the one being looked for.
findItemByText in file TListItemCollection.php, method TListItemCollection::findItemByText()
Finds the item whose text is the one being looked for.
findItemByValue in file TListItemCollection.php, method TListItemCollection::findItemByValue()
Finds the item whose value is the one being looked for.
flattenPriorities in file TPriorityMap.php, method TPriorityMap::flattenPriorities()
This flattens the priority map into a flat array [0,...,n-1]
flattenPriorities in file TPriorityList.php, method TPriorityList::flattenPriorities()
This flattens the priority list into a flat array [0,...,n-1]
top
g
getAllowCustomPaging | in file TPagedDataSource.php, method TPagedDataSource::getAllowCustomPaging()
getAllowPaging | in file TPagedDataSource.php, method TPagedDataSource::getAllowPaging()
getCaseSensitive | in file TAttributeCollection.php, method TAttributeCollection::getCaseSensitive()
getCount | in file TDummyDataSource.php, method TDummyDataSource::getCount()
getCount | in file TPagedList.php, method TPagedList::getCount()
getCount | in file TStack.php, method TStack::getCount()
getCount in file TPriorityList.php, method TPriorityList::getCount()
Returns the total number of items in the list
getCount | in file TPagedDataSource.php, method TPagedDataSource::getCount()
getCount | in file TList.php, method TList::getCount()
getCount | in file TMap.php, method TMap::getCount()
getCount | in file TQueue.php, method TQueue::getCount()
getCount | in file TPriorityMap.php, method TPriorityMap::getCount()
getCurrentPageIndex | in file TPagedList.php, method TPagedList::getCurrentPageIndex()
getCurrentPageIndex | in file TPagedDataSource.php, method TPagedDataSource::getCurrentPageIndex()
getCustomPaging | in file TPagedList.php, method TPagedList::getCustomPaging()
getData | in file TPagedList.php, method TPagedListFetchDataEventParameter::getData()
getDataSource | in file TPagedDataSource.php, method TPagedDataSource::getDataSource()
getDataSourceCount | in file TPagedDataSource.php, method TPagedDataSource::getDataSourceCount()
getDefaultPriority | in file TPriorityList.php, method TPriorityList::getDefaultPriority()
getDefaultPriority | in file TPriorityMap.php, method TPriorityMap::getDefaultPriority()
getFirstIndexInPage | in file TPagedDataSource.php, method TPagedDataSource::getFirstIndexInPage()
getIsFirstPage | in file TPagedList.php, method TPagedList::getIsFirstPage()
getIsFirstPage | in file TPagedDataSource.php, method TPagedDataSource::getIsFirstPage()
getIsLastPage | in file TPagedList.php, method TPagedList::getIsLastPage()
getIsLastPage | in file TPagedDataSource.php, method TPagedDataSource::getIsLastPage()
getIterator in file TList.php, method TList::getIterator()
Returns an iterator for traversing the items in the list.
getIterator in file TPriorityMap.php, method TPriorityMap::getIterator()
Returns an iterator for traversing the items in the map.
getIterator in file TPriorityList.php, method TPriorityList::getIterator()
Returns an iterator for traversing the items in the list.
getIterator in file TMap.php, method TMap::getIterator()
Returns an iterator for traversing the items in the list.
getIterator in file TQueue.php, method TQueue::getIterator()
Returns an iterator for traversing the items in the queue.
getIterator in file TStack.php, method TStack::getIterator()
Returns an iterator for traversing the items in the stack.
getIterator | in file TDummyDataSource.php, method TDummyDataSource::getIterator()
getIterator | in file TPagedDataSource.php, method TPagedDataSource::getIterator()
getIterator | in file TPagedList.php, method TPagedList::getIterator()
getKeys in file TPriorityMap.php, method TPriorityMap::getKeys()
Returns the keys within the map ordered through the priority of each key-value pair
getKeys | in file TMap.php, method TMap::getKeys()
getLimit | in file TPagedList.php, method TPagedListFetchDataEventParameter::getLimit()
getNewPageIndex | in file TPagedList.php, method TPagedListFetchDataEventParameter::getNewPageIndex()
getOffset | in file TPagedList.php, method TPagedListFetchDataEventParameter::getOffset()
getOldPageIndex | in file TPagedList.php, method TPagedListPageChangedEventParameter::getOldPageIndex()
getPageCount | in file TPagedList.php, method TPagedList::getPageCount()
getPageCount | in file TPagedDataSource.php, method TPagedDataSource::getPageCount()
getPageSize | in file TPagedList.php, method TPagedList::getPageSize()
getPageSize | in file TPagedDataSource.php, method TPagedDataSource::getPageSize()
getPrecision | in file TPriorityList.php, method TPriorityList::getPrecision()
getPrecision | in file TPriorityMap.php, method TPriorityMap::getPrecision()
getPriorities in file TPriorityList.php, method TPriorityList::getPriorities()
This returns a list of the priorities within this list, ordered lowest to highest.
getPriorities in file TPriorityMap.php, method TPriorityMap::getPriorities()
This returns a list of the priorities within this map, ordered lowest to highest.
getPriorityCount in file TPriorityMap.php, method TPriorityMap::getPriorityCount()
Gets the number of items at a priority within the map.
getPriorityCount in file TPriorityList.php, method TPriorityList::getPriorityCount()
Gets the number of items at a priority within the list
getReadOnly | in file TPriorityMap.php, method TPriorityMap::getReadOnly()
getReadOnly | in file TList.php, method TList::getReadOnly()
getReadOnly | in file TMap.php, method TMap::getReadOnly()
getVirtualCount | in file TPagedList.php, method TPagedList::getVirtualCount()
getVirtualItemCount | in file TPagedDataSource.php, method TPagedDataSource::getVirtualItemCount()
gotoPage in file TPagedList.php, method TPagedList::gotoPage()
Changes to a page with the specified page index.
top
h
hasProperty in file TAttributeCollection.php, method TAttributeCollection::hasProperty()
Determines whether a property is defined.
top
i
indexOf | in file TPriorityList.php, method TPriorityList::indexOf()
indexOf | in file TPagedList.php, method TPagedList::indexOf()
indexOf | in file TList.php, method TList::indexOf()
insertAfter in file TPriorityList.php, method TPriorityList::insertAfter()
This inserts an item after another item within the list. It uses the same priority as the found index item and places the new item after it.
insertAfter in file TList.php, method TList::insertAfter()
Finds the base item. If found, the item is inserted after it.
insertAt in file TPriorityList.php, method TPriorityList::insertAt()
Inserts an item at an index. It reads the priority of the item at index within the flattened list and then inserts the item at that priority-index.
insertAt in file TListItemCollection.php, method TListItemCollection::insertAt()
Inserts an item into the collection.
insertAt in file TList.php, method TList::insertAt()
Inserts an item at the specified position.
insertAtIndexInPriority in file TPriorityList.php, method TPriorityList::insertAtIndexInPriority()
Inserts an item at the specified index within a priority. Override and call this method to insert your own functionality.
insertBefore in file TList.php, method TList::insertBefore()
Finds the base item. If found, the item is inserted before it.
insertBefore in file TPriorityList.php, method TPriorityList::insertBefore()
This inserts an item before another item within the list. It uses the same priority as the found index item and places the new item before it.
itemAt in file TPriorityList.php, method TPriorityList::itemAt()
Returns the item at the index of a flattened priority list.
itemAt in file TPriorityMap.php, method TPriorityMap::itemAt()
Returns the item with the specified key. If a priority is specified, only items
itemAt in file TPagedList.php, method TPagedList::itemAt()
Returns the item at the specified offset.
itemAt in file TAttributeCollection.php, method TAttributeCollection::itemAt()
Returns the item with the specified key.
itemAt in file TMap.php, method TMap::itemAt()
Returns the item with the specified key.
itemAt in file TList.php, method TList::itemAt()
Returns the item at the specified offset.
itemAtIndexInPriority in file TPriorityList.php, method TPriorityList::itemAtIndexInPriority()
Returns the item at an index within a priority
itemsAtPriority in file TPriorityMap.php, method TPriorityMap::itemsAtPriority()
Gets all the items at a specific priority.
itemsAtPriority in file TPriorityList.php, method TPriorityList::itemsAtPriority()
Gets all the items at a specific priority.
top
k
key in file TQueue.php, method TQueueIterator::key()
Returns the key of the current array item.
key in file TStack.php, method TStackIterator::key()
Returns the key of the current array item.
key in file TPagedDataSource.php, method TPagedMapIterator::key()
Returns the key of the current array item.
key in file TPagedDataSource.php, method TPagedListIterator::key()
Returns the key of the current array item.
key in file TList.php, method TListIterator::key()
Returns the key of the current array item.
key in file TMap.php, method TMapIterator::key()
Returns the key of the current array element.
key in file TDummyDataSource.php, method TDummyDataSourceIterator::key()
Returns the key of the current array item.
top
l
loadState in file TListItemCollection.php, method TListItemCollection::loadState()
Loads state into every item in the collection.
top
m
mergeWith in file TPriorityMap.php, method TPriorityMap::mergeWith()
Merges iterable data into the map.
mergeWith in file TPriorityList.php, method TPriorityList::mergeWith()
Merges iterable data into the priority list.
mergeWith in file TMap.php, method TMap::mergeWith()
Merges iterable data into the map.
mergeWith in file TList.php, method TList::mergeWith()
Merges iterable data into the map.
top
n
next in file TQueue.php, method TQueueIterator::next()
Moves the internal pointer to the next array item.
next in file TStack.php, method TStackIterator::next()
Moves the internal pointer to the next array item.
next in file TPagedDataSource.php, method TPagedMapIterator::next()
Moves the internal pointer to the next array item.
next in file TPagedDataSource.php, method TPagedListIterator::next()
Moves the internal pointer to the next array item.
next in file TMap.php, method TMapIterator::next()
Moves the internal pointer to the next array element.
next in file TDummyDataSource.php, method TDummyDataSourceIterator::next()
Moves the internal pointer to the next array item.
next in file TList.php, method TListIterator::next()
Moves the internal pointer to the next array item.
nextPage in file TPagedList.php, method TPagedList::nextPage()
Switches to the next page.
top
o
offsetExists in file TMap.php, method TMap::offsetExists()
Returns whether there is an element at the specified offset.
offsetExists in file TPagedList.php, method TPagedList::offsetExists()
Returns whether there is an item at the specified offset.
offsetExists in file TPriorityMap.php, method TPriorityMap::offsetExists()
Returns whether there is an element at the specified offset.
offsetExists in file TList.php, method TList::offsetExists()
Returns whether there is an item at the specified offset.
offsetExists in file TPriorityList.php, method TPriorityList::offsetExists()
Returns whether there is an element at the specified offset.
offsetGet in file TPriorityList.php, method TPriorityList::offsetGet()
Returns the element at the specified offset.
offsetGet in file TPriorityMap.php, method TPriorityMap::offsetGet()
Returns the element at the specified offset.
offsetGet in file TPagedList.php, method TPagedList::offsetGet()
Returns the item at the specified offset.
offsetGet in file TMap.php, method TMap::offsetGet()
Returns the element at the specified offset.
offsetGet in file TList.php, method TList::offsetGet()
Returns the item at the specified offset.
offsetSet in file TPriorityList.php, method TPriorityList::offsetSet()
Sets the element at the specified offset. This method is required by the interface ArrayAccess.
offsetSet in file TPriorityMap.php, method TPriorityMap::offsetSet()
Sets the element at the specified offset.
offsetSet in file TList.php, method TList::offsetSet()
Sets the item at the specified offset.
offsetSet in file TMap.php, method TMap::offsetSet()
Sets the element at the specified offset.
offsetUnset in file TPriorityMap.php, method TPriorityMap::offsetUnset()
Unsets the element at the specified offset.
offsetUnset in file TList.php, method TList::offsetUnset()
Unsets the item at the specified offset.
offsetUnset in file TPriorityList.php, method TPriorityList::offsetUnset()
Unsets the element at the specified offset.
offsetUnset in file TMap.php, method TMap::offsetUnset()
Unsets the element at the specified offset.
onFetchData in file TPagedList.php, method TPagedList::onFetchData()
Raises OnFetchData event.
onPageIndexChanged in file TPagedList.php, method TPagedList::onPageIndexChanged()
Raises OnPageIndexChanged event.
top
p
peek in file TQueue.php, method TQueue::peek()
Returns the first item at the front of the queue.
peek in file TStack.php, method TStack::peek()
Returns the item at the top of the stack.
pop in file TStack.php, method TStack::pop()
Pops up the item at the top of the stack.
previousPage in file TPagedList.php, method TPagedList::previousPage()
Switches to the previous page.
priorityAt in file TPriorityList.php, method TPriorityList::priorityAt()
Retutrns the priority of an item at a particular flattened index.
priorityAt in file TPriorityMap.php, method TPriorityMap::priorityAt()
Retutrns the priority of an item at a particular flattened index.
priorityOf in file TPriorityMap.php, method TPriorityMap::priorityOf()
Returns the priority of a particular item within the map. This searches the map for the item.
priorityOf in file TPriorityList.php, method TPriorityList::priorityOf()
Returns the priority of a particular item
push in file TStack.php, method TStack::push()
Pushes an item into the stack.
top
r
remove in file TPriorityMap.php, method TPriorityMap::remove()
Removes an item from the map by its key. If no priority, or false, is specified
remove in file TAttributeCollection.php, method TAttributeCollection::remove()
Removes an item from the map by its key.
remove in file TList.php, method TList::remove()
Removes an item from the list.
remove in file TPriorityList.php, method TPriorityList::remove()
Removes an item from the priority list.
remove in file TMap.php, method TMap::remove()
Removes an item from the map by its key.
removeAt in file TList.php, method TList::removeAt()
Removes an item at the specified position.
removeAt in file TPriorityList.php, method TPriorityList::removeAt()
Removes an item at the specified index in the flattened list.
removeAtIndexInPriority in file TPriorityList.php, method TPriorityList::removeAtIndexInPriority()
Removes the item at a specific index within a priority. Override and call this method to insert your own functionality.
rewind in file TQueue.php, method TQueueIterator::rewind()
Rewinds internal array pointer.
rewind in file TStack.php, method TStackIterator::rewind()
Rewinds internal array pointer.
rewind in file TPagedDataSource.php, method TPagedListIterator::rewind()
Rewinds internal array pointer.
rewind in file TDummyDataSource.php, method TDummyDataSourceIterator::rewind()
Rewinds internal array pointer.
rewind in file TList.php, method TListIterator::rewind()
Rewinds internal array pointer.
rewind in file TMap.php, method TMapIterator::rewind()
Rewinds internal array pointer.
rewind in file TPagedDataSource.php, method TPagedMapIterator::rewind()
Rewinds internal array pointer.
top
s
saveState in file TListItemCollection.php, method TListItemCollection::saveState()
Saves state of items.
setAllowCustomPaging | in file TPagedDataSource.php, method TPagedDataSource::setAllowCustomPaging()
setAllowPaging | in file TPagedDataSource.php, method TPagedDataSource::setAllowPaging()
setCaseSensitive | in file TAttributeCollection.php, method TAttributeCollection::setCaseSensitive()
setCurrentPageIndex | in file TPagedList.php, method TPagedList::setCurrentPageIndex()
setCurrentPageIndex | in file TPagedDataSource.php, method TPagedDataSource::setCurrentPageIndex()
setCustomPaging | in file TPagedList.php, method TPagedList::setCustomPaging()
setData | in file TPagedList.php, method TPagedListFetchDataEventParameter::setData()
setDataSource | in file TPagedDataSource.php, method TPagedDataSource::setDataSource()
setDefaultPriority in file TPriorityMap.php, method TPriorityMap::setDefaultPriority()
This must be called internally or when instantiated.
setDefaultPriority in file TPriorityList.php, method TPriorityList::setDefaultPriority()
This must be called internally or when instantiated.
setPageSize | in file TPagedDataSource.php, method TPagedDataSource::setPageSize()
setPageSize | in file TPagedList.php, method TPagedList::setPageSize()
setPrecision in file TPriorityMap.php, method TPriorityMap::setPrecision()
This must be called internally or when instantiated.
setPrecision in file TPriorityList.php, method TPriorityList::setPrecision()
This must be called internally or when instantiated.
setPriorityAt in file TPriorityMap.php, method TPriorityMap::setPriorityAt()
This changes an item's priority. Specify the item and the new priority.
setReadOnly | in file TMap.php, method TMap::setReadOnly()
setReadOnly | in file TPriorityMap.php, method TPriorityMap::setReadOnly()
setReadOnly | in file TList.php, method TList::setReadOnly()
setVirtualCount | in file TPagedList.php, method TPagedList::setVirtualCount()
setVirtualItemCount | in file TPagedDataSource.php, method TPagedDataSource::setVirtualItemCount()
sortPriorities in file TPriorityMap.php, method TPriorityMap::sortPriorities()
Orders the priority list internally.
sortPriorities in file TPriorityList.php, method TPriorityList::sortPriorities()
This orders the priority list internally.
top
t
TAttributeCollection.php | procedural page TAttributeCollection.php
TDummyDataSource.php | procedural page TDummyDataSource.php
TList.php | procedural page TList.php
TListItemCollection.php | procedural page TListItemCollection.php
TMap.php | procedural page TMap.php
TPagedDataSource.php | procedural page TPagedDataSource.php
TPagedList.php | procedural page TPagedList.php
TPriorityList.php | procedural page TPriorityList.php
TPriorityMap.php | procedural page TPriorityMap.php
TQueue.php | procedural page TQueue.php
TStack.php | procedural page TStack.php
TAttributeCollection in file TAttributeCollection.php, class TAttributeCollection
TAttributeCollection class
TDummyDataSource in file TDummyDataSource.php, class TDummyDataSource
TDummyDataSource class
TDummyDataSourceIterator in file TDummyDataSource.php, class TDummyDataSourceIterator
TDummyDataSourceIterator class
TList in file TList.php, class TList
TList class
TListItemCollection in file TListItemCollection.php, class TListItemCollection
TListItemCollection class.
TListIterator in file TList.php, class TListIterator
TListIterator class
TMap in file TMap.php, class TMap
TMap class
TMapIterator in file TMap.php, class TMapIterator
TMapIterator class
toArray | in file TPriorityList.php, method TPriorityList::toArray()
toArray | in file TQueue.php, method TQueue::toArray()
toArray in file TPriorityMap.php, method TPriorityMap::toArray()
When the map is flattened into an array, the priorities are taken into account and elements of the map are ordered in the array according to their priority.
toArray | in file TStack.php, method TStack::toArray()
toArray | in file TPagedList.php, method TPagedList::toArray()
toArray | in file TMap.php, method TMap::toArray()
toArray | in file TList.php, method TList::toArray()
toArrayAbovePriority in file TPriorityList.php, method TPriorityList::toArrayAbovePriority()
Combines the map elements which have a priority above the parameter value
toArrayAbovePriority in file TPriorityMap.php, method TPriorityMap::toArrayAbovePriority()
Combines the map elements which have a priority above the parameter value
toArrayBelowPriority in file TPriorityList.php, method TPriorityList::toArrayBelowPriority()
Combines the map elements which have a priority below the parameter value
toArrayBelowPriority in file TPriorityMap.php, method TPriorityMap::toArrayBelowPriority()
Combines the map elements which have a priority below the parameter value
toPriorityArray | in file TPriorityList.php, method TPriorityList::toPriorityArray()
TPagedDataSource in file TPagedDataSource.php, class TPagedDataSource
TPagedDataSource class
TPagedList in file TPagedList.php, class TPagedList
TPagedList class
TPagedListFetchDataEventParameter in file TPagedList.php, class TPagedListFetchDataEventParameter
TPagedListFetchDataEventParameter class.
TPagedListIterator in file TPagedDataSource.php, class TPagedListIterator
TPagedListIterator class
TPagedListPageChangedEventParameter in file TPagedList.php, class TPagedListPageChangedEventParameter
TPagedListPageChangedEventParameter class.
TPagedMapIterator in file TPagedDataSource.php, class TPagedMapIterator
TPagedMapIterator class
TPriorityList in file TPriorityList.php, class TPriorityList
TPriorityList class
TPriorityMap in file TPriorityMap.php, class TPriorityMap
TPriorityMap class
TQueue in file TQueue.php, class TQueue
TQueue class
TQueueIterator in file TQueue.php, class TQueueIterator
TQueueIterator class
TStack in file TStack.php, class TStack
TStack class
TStackIterator in file TStack.php, class TStackIterator
TStackIterator class
top
v
valid in file TQueue.php, method TQueueIterator::valid()
Returns whether there is an item at current position.
valid in file TStack.php, method TStackIterator::valid()
Returns whether there is an item at current position.
valid in file TPagedDataSource.php, method TPagedMapIterator::valid()
Returns whether there is an item at current position.
valid in file TPagedDataSource.php, method TPagedListIterator::valid()
Returns whether there is an item at current position.
valid in file TList.php, method TListIterator::valid()
Returns whether there is an item at current position.
valid in file TMap.php, method TMapIterator::valid()
Returns whether there is an element at current position.
valid in file TDummyDataSource.php, method TDummyDataSourceIterator::valid()
Returns whether there is an item at current position.


Class Trees for Package System.Collections

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TAttributeCollection.php

File: /Collections/TAttributeCollection.php

Remarks

TAttributeCollection classes

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TAttributeCollection.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TAttributeCollection
TAttributeCollection class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:32 +0200 by phpDocumentor 1.4.3


Docs for page TDummyDataSource.php

File: /Collections/TDummyDataSource.php

Remarks

TDummyDataSource, TDummyDataSourceIterator classes

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDummyDataSource.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDummyDataSource
TDummyDataSource class
TDummyDataSourceIterator
TDummyDataSourceIterator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:17 +0200 by phpDocumentor 1.4.3


Docs for page TList.php

File: /Collections/TList.php

Remarks

TList, TListIterator classes

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TList
TList class
TListIterator
TListIterator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:41 +0200 by phpDocumentor 1.4.3


Docs for page TListItemCollection.php

File: /Collections/TListItemCollection.php

Remarks

TListItemCollection class file

author

Qiang Xue <qiang.xue@gmail.com>

author

Robin J. Rogge <rojaro@gmail.com>

version

$Id: TListControl.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TListItemCollection
TListItemCollection class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:45 +0200 by phpDocumentor 1.4.3


Docs for page TMap.php

File: /Collections/TMap.php

Remarks

TMap, TMapIterator classes

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMap
TMap class
TMapIterator
TMapIterator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:48 +0200 by phpDocumentor 1.4.3


Docs for page TPagedDataSource.php

File: /Collections/TPagedDataSource.php

Remarks

TPagedDataSource, TPagedListIterator, TPagedMapIterator classes

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPagedDataSource.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPagedDataSource
TPagedDataSource class
TPagedListIterator
TPagedListIterator class
TPagedMapIterator
TPagedMapIterator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:58 +0200 by phpDocumentor 1.4.3


Docs for page TPagedList.php

File: /Collections/TPagedList.php

Remarks

TPagedList, TPagedListFetchDataEventParameter, TPagedListPageChangedEventParameter class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPagedList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPagedList
TPagedList class
TPagedListPageChangedEventParameter
TPagedListPageChangedEventParameter class.
TPagedListFetchDataEventParameter
TPagedListFetchDataEventParameter class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:58 +0200 by phpDocumentor 1.4.3


Docs for page TPriorityList.php

File: /Collections/TPriorityList.php

Remarks

TPriorityList, TPriorityListIterator classes

author

Brad Anderson <javalizard@gmail.com>

version

$Id: TPriorityList.php 2541 2008-10-21 15:05:13Z javalizard $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPriorityList
TPriorityList class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:03 +0200 by phpDocumentor 1.4.3


Docs for page TPriorityMap.php

File: /Collections/TPriorityMap.php

Remarks

TPriorityMap, TPriorityMapIterator classes

author

Brad Anderson <javalizard@mac.com>

version

$Id: TPriorityMap.php 2817 2010-04-18 04:25:03Z javalizard $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPriorityMap
TPriorityMap class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:04 +0200 by phpDocumentor 1.4.3


Docs for page TQueue.php

File: /Collections/TQueue.php

Remarks

TQueue, TQueueIterator classes

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TQueue
TQueue class
TQueueIterator
TQueueIterator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:05 +0200 by phpDocumentor 1.4.3


Docs for page TStack.php

File: /Collections/TStack.php

Remarks

TStack, TStackIterator classes

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TStack.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TStack
TStack class
TStackIterator
TStackIterator class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:28 +0200 by phpDocumentor 1.4.3


Docs For Class TAttributeCollection

Class TAttributeCollection

[line 45]
TComponent
   |
   --TMap
      |
      --TAttributeCollection
Location: /Collections/TAttributeCollection.php

Remarks

TAttributeCollection class

TAttributeCollection implements a collection for storing attribute names and values.

Besides all functionalities provided by TMap, TAttributeCollection allows you to get and set attribute values like getting and setting properties. For example, the following usages are all valid for a TAttributeCollection object:

  •  $collection->Text='text';
    •

  •  echo $collection->Text;
    •
    They are equivalent to the following:
  •  $collection->add('Text','text');
    •

  •  echo $collection->itemAt('Text');
    •

    Note, attribute names are case-insensitive. They are converted to lower-case in the collection storage.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TAttributeCollection.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TMap

    • TMap::__construct()
      Constructor.
    • TMap::add()
      Adds an item into the map.
    • TMap::clear()
      Removes all items in the map.
    • TMap::contains()
    • TMap::copyFrom()
      Copies iterable data into the map.
    • TMap::count()
      Returns the number of items in the map.
    • TMap::getCount()
    • TMap::getIterator()
      Returns an iterator for traversing the items in the list.
    • TMap::getKeys()
    • TMap::getReadOnly()
    • TMap::itemAt()
      Returns the item with the specified key.
    • TMap::mergeWith()
      Merges iterable data into the map.
    • TMap::offsetExists()
      Returns whether there is an element at the specified offset.
    • TMap::offsetGet()
      Returns the element at the specified offset.
    • TMap::offsetSet()
      Sets the element at the specified offset.
    • TMap::offsetUnset()
      Unsets the element at the specified offset.
    • TMap::remove()
      Removes an item from the map by its key.
    • TMap::setReadOnly()
    • TMap::toArray()

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TAttributeCollection::add

      add( mixed $key, mixed $value );

      Overrides TMap::add() (Adds an item into the map.)

      Parameters

      $key

      key

      $value

      value

      Remarks

      Adds an item into the map.

      This overrides the parent implementation by converting the key to lower case first if CaseSensitive is false.

      access

      public

      [ Top ]

      TAttributeCollection::canGetProperty

      canGetProperty( string $name );

      Overrides TComponent::canGetProperty() (Determines whether a property can be read.)

      Parameters

      $name

      the property name

      Returns

      whether the property can be read

      Remarks

      Determines whether a property can be read.

      This method overrides parent implementation by returning true if the collection contains the named key.

      access

      public

      [ Top ]

      TAttributeCollection::canSetProperty

      canSetProperty( string $name );

      Overrides TComponent::canSetProperty() (Determines whether a property can be set.)

      Parameters

      $name

      the property name

      Returns

      true

      Remarks

      Determines whether a property can be set.

      This method overrides parent implementation by always returning true because you can always add a new value to the collection.

      access

      public

      [ Top ]

      TAttributeCollection::contains

      contains( mixed $key );

      Overrides TMap::contains() (parent method not documented)

      Parameters

      $key

      the key

      Returns

      whether the map contains an item with the specified key

      Remarks

      Returns whether the specified is in the map.

      This overrides the parent implementation by converting the key to lower case first if CaseSensitive is false.

      access

      public

      [ Top ]

      TAttributeCollection::getCaseSensitive

      getCaseSensitive( );

      Returns

      whether the keys are case-sensitive. Defaults to false.

      access

      public

      [ Top ]

      TAttributeCollection::hasProperty

      hasProperty( string $name );

      Overrides TComponent::hasProperty() (Determines whether a property is defined.)

      Parameters

      $name

      the property name

      Returns

      whether the property is defined

      Remarks

      Determines whether a property is defined.

      This method overrides parent implementation by returning true if the collection contains the named key.

      access

      public

      [ Top ]

      TAttributeCollection::itemAt

      itemAt( mixed $key );

      Overrides TMap::itemAt() (Returns the item with the specified key.)

      Parameters

      $key

      the key

      Returns

      the element at the offset, null if no element is found at the offset

      Remarks

      Returns the item with the specified key.

      This overrides the parent implementation by converting the key to lower case first if CaseSensitive is false.

      access

      public

      [ Top ]

      TAttributeCollection::remove

      remove( mixed $key );

      Overrides TMap::remove() (Removes an item from the map by its key.)

      Parameters

      $key

      the key of the item to be removed

      Returns

      the removed value, null if no such key exists.

      Remarks

      Removes an item from the map by its key.

      This overrides the parent implementation by converting the key to lower case first if CaseSensitive is false.

      access

      public

      [ Top ]

      TAttributeCollection::setCaseSensitive

      setCaseSensitive( boolean $value );

      Parameters

      $value

      whether the keys are case-sensitive.

      access

      public

      [ Top ]

      TAttributeCollection::__get

      __get( string $name );

      Overrides TComponent::__get() (Returns a property value or an event handler list by property or event name.)

      Parameters

      $name

      the property name or the event name

      Returns

      the property value or the event handler list

      Remarks

      Returns a property value or an event handler list by property or event name.

      This method overrides the parent implementation by returning a key value if the key exists in the collection.

      throws

      TInvalidOperationException if the property/event is not defined.

      access

      public

      [ Top ]

      TAttributeCollection::__set

      __set( string $name, mixed $value );

      Overrides TComponent::__set() (Sets value of a component property.)

      Parameters

      $name

      the property name or event name

      $value

      the property value or event handler

      Remarks

      Sets value of a component property.

      This method overrides the parent implementation by adding a new key value to the collection.

      throws

      TInvalidOperationException If the property is not defined or read-only.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:32 +0200 by phpDocumentor 1.4.3


Docs For Class TDummyDataSource

Class TDummyDataSource

[line 29]
TComponent
   |
   --TDummyDataSource
Location: /Collections/TDummyDataSource.php

Remarks

TDummyDataSource class

TDummyDataSource implements a dummy data collection with a specified number of dummy data items. The number of virtual items can be set via setCount property. You can traverse it using foreach PHP statement like the following,

  •  foreach($dummyDataSource as $dataItem)
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TDummyDataSource.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TDummyDataSource::__construct

      __construct( integer $count );

      Parameters

      $count

      number of (virtual) items in the data source.

      Remarks

      Constructor.

      access

      public

      [ Top ]

      TDummyDataSource::count

      count( );

      Implementation of:
      Countable::count

      Returns

      number of (virtual) items in the data source.

      Remarks

      Returns the number of (virtual) items in the data source.

      This method is required by Countable interface.

      access

      public

      [ Top ]

      TDummyDataSource::getCount

      getCount( );

      Returns

      number of (virtual) items in the data source.

      access

      public

      [ Top ]

      TDummyDataSource::getIterator

      getIterator( );

      Implementation of:
      IteratorAggregate::getIterator

      Returns

      iterator

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:17 +0200 by phpDocumentor 1.4.3


Docs For Class TDummyDataSourceIterator

Class TDummyDataSourceIterator

[line 83]

Location: /Collections/TDummyDataSource.php

Remarks

TDummyDataSourceIterator class

TDummyDataSourceIterator implements Iterator interface.
TDummyDataSourceIterator is used by TDummyDataSource.  It allows TDummyDataSource to return a new iterator  for traversing its dummy items.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDummyDataSource.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TDummyDataSourceIterator::__construct

__construct(
integer
$count );

    Parameters

    $count

    number of (virtual) items in the data source.

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDummyDataSourceIterator::current

current(
 );

    Implementation of:

    Iterator::current

    Returns

    the current array item

    Remarks

    Returns the current array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TDummyDataSourceIterator::key

key(
 );

    Implementation of:

    Iterator::key

    Returns

    the key of the current array item

    Remarks

    Returns the key of the current array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TDummyDataSourceIterator::next

next(
 );

    Implementation of:

    Iterator::next

    Remarks

    Moves the internal pointer to the next array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TDummyDataSourceIterator::rewind

rewind(
 );

    Implementation of:

    Iterator::rewind

    Remarks

    Rewinds internal array pointer.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TDummyDataSourceIterator::valid

valid(
 );

    Implementation of:

    Iterator::valid

    Remarks

    Returns whether there is an item at current position.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:17 +0200 by phpDocumentor 1.4.3


Docs For Class TList

Class TList

[line 39]
TComponent
   |
   --TList
Classes extended from TList:
TCacheDependencyList
TCacheDependencyList class.
TListItemCollection
TListItemCollection class.
TPagedList
TPagedList class
TPriorityList
TPriorityList class
TAuthorizationRuleCollection
TAuthorizationRuleCollection class.
THttpCookieCollection
THttpCookieCollection class.
TControlCollection
TControlCollection class
TDataGridItemCollection
TDataGridItemCollection class.
TDataGridColumnCollection
TDataGridColumnCollection class.
TDataListItemCollection
TDataListItemCollection class.
TMetaTagCollection
TMetaTagCollection class
THotSpotCollection
THotSpotCollection class.
TRepeaterItemCollection
TRepeaterItemCollection class.
TWizardStepCollection
TWizardStepCollection class.
TXmlElementList
TXmlElementList class.

Location: /Collections/TList.php

Remarks

TList class

TList implements an integer-indexed collection class.

You can access, append, insert, remove an item by using itemAt, add, insertAt, remove, and removeAt. To get the number of the items in the list, use getCount. TList can also be used like a regular array as follows,

  •  $list[]=$item;  // append at the end
    •

  •  $list[$index]=$item; // $index must be between 0 and $list->Count
    •

  •  unset($list[$index]); // remove the item at $index
    •

  •  if(isset($list[$index])) // if the list has an item at $index
    •

  •  foreach($list as $index=>$item) // traverse each item in the list
    •

  •  $n=count($list); // returns the number of items in the list
    •

    To extend TList by doing additional operations with each addition or removal operation, override insertAt(), and removeAt().

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TList::__construct

      __construct( [array|Iterator $data = null], [boolean $readOnly = false] );

      Overridden in child classes as:

      TPagedList::__construct()
      Constructor.
      TSqlMapPagedList::__construct()
      Create a new SqlMap paged list.
      TPriorityList::__construct()
      Constructor.
      THttpCookieCollection::__construct()
      Constructor.
      TControlCollection::__construct()
      Constructor.
      TEmptyControlCollection::__construct()
      Constructor.
      TDataGridColumnCollection::__construct()
      Constructor.
      TWizardStepCollection::__construct()
      Constructor.
      TXmlElementList::__construct()
      Constructor.

      Parameters

      $data

      the initial data. Default is null, meaning no initialization.

      $readOnly

      whether the list is read-only

      Remarks

      Constructor.

      Initializes the list with an array or an iterable object.

      throws

      TInvalidDataTypeException If data is not null and neither an array nor an iterator.

      access

      public

      [ Top ]

      TList::add

      add( mixed $item );

      Overridden in child classes as:

      TPriorityList::add()
      Appends an item into the list at the end of the specified priority. The position of the added item may not be at the end of the list.

      Parameters

      $item

      new item

      Returns

      the zero-based index at which the item is added

      Remarks

      Appends an item at the end of the list.

      throws

      TInvalidOperationException if the list is read-only

      access

      public

      [ Top ]

      TList::clear

      clear( );

      Overridden in child classes as:

      TPriorityList::clear()
      Removes all items in the priority list by calling removeAtIndexInPriority from the last item to the first.
      TControlCollection::clear()
      Overrides the parent implementation by invoking TControl::clearNamingContainer

      Remarks

      Removes all items in the list.

      throws

      TInvalidOperationException if the list is read-only

      access

      public

      [ Top ]

      TList::contains

      contains( mixed $item );

      Overridden in child classes as:

      TPriorityList::contains()

      Parameters

      $item

      the item

      Returns

      whether the list contains the item

      access

      public

      [ Top ]

      TList::copyFrom

      copyFrom( mixed $data );

      Overridden in child classes as:

      TPriorityList::copyFrom()
      Copies iterable data into the priority list.

      Parameters

      $data

      the data to be copied from, must be an array or object implementing Traversable

      Remarks

      Copies iterable data into the list.

      Note, existing data in the list will be cleared first.

      throws

      TInvalidDataTypeException If data is neither an array nor a Traversable.

      access

      public

      [ Top ]

      TList::count

      count( );

      Overridden in child classes as:

      TPriorityList::count()
      Returns the number of items in the list.

      Implementation of:
      Countable::count

      Returns

      number of items in the list.

      Remarks

      Returns the number of items in the list.

      This method is required by Countable interface.

      access

      public

      [ Top ]

      TList::getCount

      getCount( );

      Overridden in child classes as:

      TPagedList::getCount()
      TPriorityList::getCount()
      Returns the total number of items in the list

      Returns

      the number of items in the list

      access

      public

      [ Top ]

      TList::getIterator

      getIterator( );

      Overridden in child classes as:

      TPagedList::getIterator()
      TPriorityList::getIterator()
      Returns an iterator for traversing the items in the list.

      Implementation of:
      IteratorAggregate::getIterator

      Returns

      an iterator for traversing the items in the list.

      Remarks

      Returns an iterator for traversing the items in the list.

      This method is required by the interface IteratorAggregate.

      access

      public

      [ Top ]

      TList::getReadOnly

      getReadOnly( );

      Returns

      whether this list is read-only or not. Defaults to false.

      access

      public

      [ Top ]

      TList::indexOf

      indexOf( mixed $item );

      Overridden in child classes as:

      TPagedList::indexOf()
      TPriorityList::indexOf()

      Parameters

      $item

      the item

      Returns

      the index of the item in the list (0 based), -1 if not found.

      access

      public

      [ Top ]

      TList::insertAfter

      insertAfter( mixed $baseitem, mixed $item );

      Overridden in child classes as:

      TPriorityList::insertAfter()
      This inserts an item after another item within the list. It uses the same priority as the found index item and places the new item after it.

      Parameters

      $baseitem

      the base item which comes before the second parameter when added to the list

      $item

      the item

      Returns

      the index where the item is inserted

      Remarks

      Finds the base item. If found, the item is inserted after it.

      since

      3.2a

      throws

      TInvalidDataValueException if the base item is not within this list

      throws

      TInvalidOperationException if the list is read-only

      access

      public

      [ Top ]

      TList::insertAt

      insertAt( integer $index, mixed $item );

      Overridden in child classes as:

      TCacheDependencyList::insertAt()
      Inserts an item at the specified position.
      TListItemCollection::insertAt()
      Inserts an item into the collection.
      TActiveListItemCollection::insertAt()
      Inserts an item into the collection.
      TPriorityList::insertAt()
      Inserts an item at an index. It reads the priority of the item at index within the flattened list and then inserts the item at that priority-index.
      TAuthorizationRuleCollection::insertAt()
      Inserts an item at the specified position.
      THttpCookieCollection::insertAt()
      Inserts an item at the specified position.
      TControlCollection::insertAt()
      Inserts an item at the specified position.
      TEmptyControlCollection::insertAt()
      Inserts an item at the specified position.
      TAccordionViewCollection::insertAt()
      Inserts an item at the specified position.
      TViewCollection::insertAt()
      Inserts an item at the specified position.
      TTableRowCollection::insertAt()
      Inserts an item at the specified position.
      TTableCellCollection::insertAt()
      Inserts an item at the specified position.
      TTabViewCollection::insertAt()
      Inserts an item at the specified position.
      TDataGridItemCollection::insertAt()
      Inserts an item at the specified position.
      TDataGridColumnCollection::insertAt()
      Inserts an item at the specified position.
      TDataListItemCollection::insertAt()
      Inserts an item at the specified position.
      TMetaTagCollection::insertAt()
      Inserts an item at the specified position.
      THotSpotCollection::insertAt()
      Inserts an item at the specified position.
      TRepeaterItemCollection::insertAt()
      Inserts an item at the specified position.
      TWizardStepCollection::insertAt()
      Inserts an item at the specified position.
      TXmlElementList::insertAt()
      Inserts an item at the specified position.

      Parameters

      $index

      the specified position.

      $item

      new item

      Remarks

      Inserts an item at the specified position.

      Original item at the position and the next items will be moved one step towards the end.

      throws

      TInvalidOperationException if the list is read-only

      throws

      TInvalidDataValueException If the index specified exceeds the bound

      access

      public

      [ Top ]

      TList::insertBefore

      insertBefore( mixed $baseitem, mixed $item );

      Overridden in child classes as:

      TPriorityList::insertBefore()
      This inserts an item before another item within the list. It uses the same priority as the found index item and places the new item before it.

      Parameters

      $baseitem

      the base item which will be pushed back by the second parameter

      $item

      the item

      Returns

      the index where the item is inserted

      Remarks

      Finds the base item. If found, the item is inserted before it.

      since

      3.2a

      throws

      TInvalidDataValueException if the base item is not within this list

      throws

      TInvalidOperationException if the list is read-only

      access

      public

      [ Top ]

      TList::itemAt

      itemAt( integer $index );

      Overridden in child classes as:

      TPagedList::itemAt()
      Returns the item at the specified offset.
      TPriorityList::itemAt()
      Returns the item at the index of a flattened priority list.
      THttpCookieCollection::itemAt()

      Parameters

      $index

      the index of the item

      Returns

      the item at the index

      Remarks

      Returns the item at the specified offset.

      This method is exactly the same as offsetGet.

      throws

      TInvalidDataValueException if the index is out of the range

      access

      public

      [ Top ]

      TList::mergeWith

      mergeWith( mixed $data );

      Overridden in child classes as:

      TPriorityList::mergeWith()
      Merges iterable data into the priority list.

      Parameters

      $data

      the data to be merged with, must be an array or object implementing Traversable

      Remarks

      Merges iterable data into the map.

      New data will be appended to the end of the existing data.

      throws

      TInvalidDataTypeException If data is neither an array nor an iterator.

      access

      public

      [ Top ]

      TList::offsetExists

      offsetExists( integer $offset );

      Overridden in child classes as:

      TPagedList::offsetExists()
      Returns whether there is an item at the specified offset.
      TPriorityList::offsetExists()
      Returns whether there is an element at the specified offset.

      Implementation of:
      ArrayAccess::offsetExists

      Parameters

      $offset

      the offset to check on

      Remarks

      Returns whether there is an item at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TList::offsetGet

      offsetGet( integer $offset );

      Overridden in child classes as:

      TPagedList::offsetGet()
      Returns the item at the specified offset.
      TPriorityList::offsetGet()
      Returns the element at the specified offset.

      Implementation of:
      ArrayAccess::offsetGet

      Parameters

      $offset

      the offset to retrieve item.

      Returns

      the item at the offset

      Remarks

      Returns the item at the specified offset.

      This method is required by the interface ArrayAccess.

      throws

      TInvalidDataValueException if the offset is invalid

      access

      public

      [ Top ]

      TList::offsetSet

      offsetSet( integer $offset, mixed $item );

      Overridden in child classes as:

      TPriorityList::offsetSet()
      Sets the element at the specified offset. This method is required by the interface ArrayAccess.

      Implementation of:
      ArrayAccess::offsetSet

      Parameters

      $offset

      the offset to set item

      $item

      the item value

      Remarks

      Sets the item at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TList::offsetUnset

      offsetUnset( integer $offset );

      Overridden in child classes as:

      TPriorityList::offsetUnset()
      Unsets the element at the specified offset.

      Implementation of:
      ArrayAccess::offsetUnset

      Parameters

      $offset

      the offset to unset item

      Remarks

      Unsets the item at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TList::remove

      remove( mixed $item );

      Overridden in child classes as:

      TPriorityList::remove()
      Removes an item from the priority list.

      Parameters

      $item

      the item to be removed.

      Returns

      the index at which the item is being removed

      Remarks

      Removes an item from the list.

      The list will first search for the item. The first item found will be removed from the list.

      throws

      TInvalidOperationException if the list is read-only

      throws

      TInvalidDataValueException If the item does not exist

      access

      public

      [ Top ]

      TList::removeAt

      removeAt( integer $index );

      Overridden in child classes as:

      TActiveListItemCollection::removeAt()
      Removes an item from at specified index.
      TPriorityList::removeAt()
      Removes an item at the specified index in the flattened list.
      THttpCookieCollection::removeAt()
      Removes an item at the specified position.
      TControlCollection::removeAt()
      Removes an item at the specified position.
      TWizardStepCollection::removeAt()
      Removes an item at the specified position.
      TXmlElementList::removeAt()
      Removes an item at the specified position.

      Parameters

      $index

      the index of the item to be removed.

      Returns

      the removed item.

      Remarks

      Removes an item at the specified position.

      throws

      TInvalidOperationException if the list is read-only

      throws

      TInvalidDataValueException If the index specified exceeds the bound

      access

      public

      [ Top ]

      TList::setReadOnly

      setReadOnly( boolean $value );

      Parameters

      $value

      whether this list is read-only or not

      access

      protected

      [ Top ]

      TList::toArray

      toArray( );

      Overridden in child classes as:

      TPagedList::toArray()
      TPriorityList::toArray()

      Returns

      the list of items in array

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:41 +0200 by phpDocumentor 1.4.3


Docs For Class TListIterator

Class TListIterator

[line 412]

Location: /Collections/TList.php

Remarks

TListIterator class

TListIterator implements Iterator interface.
TListIterator is used by TList. It allows TList to return a new iterator  for traversing the items in the list.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

deprecated

Issue 264 : ArrayIterator should be used instead

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TListIterator::__construct

__construct(
array
&$data );

    Parameters

    &$data

    the data to be iterated through

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TListIterator::current

current(
 );

    Implementation of:

    Iterator::current

    Returns

    the current array item

    Remarks

    Returns the current array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TListIterator::key

key(
 );

    Implementation of:

    Iterator::key

    Returns

    the key of the current array item

    Remarks

    Returns the key of the current array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TListIterator::next

next(
 );

    Implementation of:

    Iterator::next

    Remarks

    Moves the internal pointer to the next array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TListIterator::rewind

rewind(
 );

    Implementation of:

    Iterator::rewind

    Remarks

    Rewinds internal array pointer.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TListIterator::valid

valid(
 );

    Implementation of:

    Iterator::valid

    Remarks

    Returns whether there is an item at current position.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:42 +0200 by phpDocumentor 1.4.3


Docs For Class TListItemCollection

Class TListItemCollection

[line 31]
TComponent
   |
   --TList
      |
      --TListItemCollection
Classes extended from TListItemCollection:
TActiveListItemCollection
TActiveListItemCollection class.

Location: /Collections/TListItemCollection.php

Remarks

TListItemCollection class.

TListItemCollection maintains a list of TListItem for TListControl.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TListControl.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TListItemCollection::createListItem

    createListItem( [integer $index = -1] );

    Parameters

    $index

    index where the newly created item is to be inserted at. If -1, the item will be appended to the end.

    Returns

    list item object

    Remarks

    Creates a list item object.

    This method may be overriden to provide a customized list item object.

    access

    public

    [ Top ]

    TListItemCollection::createNewListItem

    createNewListItem( [ $text = null] );

    Parameters

    $text

    Returns

    new item.

    access

    protected

    [ Top ]

    TListItemCollection::findIndexByText

    findIndexByText( string $text, [boolean $includeDisabled = true] );

    Parameters

    $text

    the text to be looked for

    $includeDisabled

    whether to look for disabled items also

    Returns

    the index of the item found, -1 if not found.

    Remarks

    Finds the lowest cardinal index of the item whose text is the one being looked for.

    access

    public

    [ Top ]

    TListItemCollection::findIndexByValue

    findIndexByValue( string $value, [boolean $includeDisabled = true] );

    Parameters

    $value

    the value to be looked for

    $includeDisabled

    whether to look for disabled items also

    Returns

    the index of the item found, -1 if not found.

    Remarks

    Finds the lowest cardinal index of the item whose value is the one being looked for.

    access

    public

    [ Top ]

    TListItemCollection::findItemByText

    findItemByText( string $text, [boolean $includeDisabled = true] );

    Parameters

    $text

    the text to be looked for

    $includeDisabled

    whether to look for disabled items also

    Returns

    the item found, null if not found.

    Remarks

    Finds the item whose text is the one being looked for.

    access

    public

    [ Top ]

    TListItemCollection::findItemByValue

    findItemByValue( string $value, [boolean $includeDisabled = true] );

    Parameters

    $value

    the value to be looked for

    $includeDisabled

    whether to look for disabled items also

    Returns

    the item found, null if not found.

    Remarks

    Finds the item whose value is the one being looked for.

    access

    public

    [ Top ]

    TListItemCollection::insertAt

    insertAt( integer $index, TListItem $item );

    Overridden in child classes as:

    TActiveListItemCollection::insertAt()
    Inserts an item into the collection.

    Overrides TList::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the location where the item will be inserted. The current item at the place and the following ones will be moved backward.

    $item

    the item to be inserted.

    Remarks

    Inserts an item into the collection.

    throws

    TInvalidDataTypeException if the item being inserted is neither a string nor TListItem

    access

    public

    [ Top ]

    TListItemCollection::loadState

    loadState( array|null $state );

    Parameters

    $state

    state to be loaded.

    Remarks

    Loads state into every item in the collection.

    This method should only be used by framework and control developers.

    access

    public

    [ Top ]

    TListItemCollection::saveState

    saveState( );

    Returns

    the saved state

    Remarks

    Saves state of items.

    This method should only be used by framework and control developers.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:45 +0200 by phpDocumentor 1.4.3


Docs For Class TMap

Class TMap

[line 35]
TComponent
   |
   --TMap
Classes extended from TMap:
TAttributeCollection
TAttributeCollection class
TPriorityMap
TPriorityMap class

Location: /Collections/TMap.php

Remarks

TMap class

TMap implements a collection that takes key-value pairs.

You can access, add or remove an item with a key by using itemAt, add, and remove. To get the number of the items in the map, use getCount. TMap can also be used like a regular array as follows,

  •  $map[$key]=$value; // add a key-value pair
    •

  •  unset($map[$key]); // remove the value with the specified key
    •

  •  if(isset($map[$key])) // if the map contains the key
    •

  •  foreach($map as $key=>$value) // traverse the items in the map
    •

  •  $n=count($map);  // returns the number of items in the map
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TMap::__construct

      __construct( [array|Iterator $data = null], [boolean $readOnly = false] );

      Overridden in child classes as:

      TPriorityMap::__construct()
      Constructor.

      Parameters

      $data

      the intial data. Default is null, meaning no initialization.

      $readOnly

      whether the list is read-only

      Remarks

      Constructor.

      Initializes the list with an array or an iterable object.

      throws

      TInvalidDataTypeException If data is not null and neither an array nor an iterator.

      access

      public

      [ Top ]

      TMap::add

      add( mixed $key, mixed $value );

      Overridden in child classes as:

      TAttributeCollection::add()
      Adds an item into the map.
      TPriorityMap::add()
      Adds an item into the map. A third parameter may be used to set the priority of the item within the map. Priority is primarily used during when flattening the map into an array where order may be and important factor of the key-value pairs within the array.

      Parameters

      $key

      key

      $value

      value

      Remarks

      Adds an item into the map.

      Note, if the specified key already exists, the old value will be overwritten.

      throws

      TInvalidOperationException if the map is read-only

      access

      public

      [ Top ]

      TMap::clear

      clear( );

      Overridden in child classes as:

      TPriorityMap::clear()
      Removes all items in the map. remove is called on all items.

      Remarks

      Removes all items in the map.

      access

      public

      [ Top ]

      TMap::contains

      contains( mixed $key );

      Overridden in child classes as:

      TAttributeCollection::contains()
      Returns whether the specified is in the map.
      TPriorityMap::contains()

      Parameters

      $key

      the key

      Returns

      whether the map contains an item with the specified key

      access

      public

      [ Top ]

      TMap::copyFrom

      copyFrom( mixed $data );

      Overridden in child classes as:

      TPriorityMap::copyFrom()
      Copies iterable data into the map.

      Parameters

      $data

      the data to be copied from, must be an array or object implementing Traversable

      Remarks

      Copies iterable data into the map.

      Note, existing data in the map will be cleared first.

      throws

      TInvalidDataTypeException If data is neither an array nor an iterator.

      access

      public

      [ Top ]

      TMap::count

      count( );

      Overridden in child classes as:

      TPriorityMap::count()
      Returns the number of items in the map.

      Implementation of:
      Countable::count

      Returns

      number of items in the map.

      Remarks

      Returns the number of items in the map.

      This method is required by Countable interface.

      access

      public

      [ Top ]

      TMap::getCount

      getCount( );

      Overridden in child classes as:

      TPriorityMap::getCount()

      Returns

      the number of items in the map

      access

      public

      [ Top ]

      TMap::getIterator

      getIterator( );

      Overridden in child classes as:

      TPriorityMap::getIterator()
      Returns an iterator for traversing the items in the map.

      Implementation of:
      IteratorAggregate::getIterator

      Returns

      an iterator for traversing the items in the list.

      Remarks

      Returns an iterator for traversing the items in the list.

      This method is required by the interface IteratorAggregate.

      access

      public

      [ Top ]

      TMap::getKeys

      getKeys( );

      Overridden in child classes as:

      TPriorityMap::getKeys()
      Returns the keys within the map ordered through the priority of each key-value pair

      Returns

      the key list

      access

      public

      [ Top ]

      TMap::getReadOnly

      getReadOnly( );

      Overridden in child classes as:

      TPriorityMap::getReadOnly()

      Returns

      whether this map is read-only or not. Defaults to false.

      access

      public

      [ Top ]

      TMap::itemAt

      itemAt( mixed $key );

      Overridden in child classes as:

      TAttributeCollection::itemAt()
      Returns the item with the specified key.
      TPriorityMap::itemAt()
      Returns the item with the specified key. If a priority is specified, only items

      Parameters

      $key

      the key

      Returns

      the element at the offset, null if no element is found at the offset

      Remarks

      Returns the item with the specified key.

      This method is exactly the same as offsetGet.

      access

      public

      [ Top ]

      TMap::mergeWith

      mergeWith( mixed $data );

      Overridden in child classes as:

      TPriorityMap::mergeWith()
      Merges iterable data into the map.

      Parameters

      $data

      the data to be merged with, must be an array or object implementing Traversable

      Remarks

      Merges iterable data into the map.

      Existing data in the map will be kept and overwritten if the keys are the same.

      throws

      TInvalidDataTypeException If data is neither an array nor an iterator.

      access

      public

      [ Top ]

      TMap::offsetExists

      offsetExists( mixed $offset );

      Overridden in child classes as:

      TPriorityMap::offsetExists()
      Returns whether there is an element at the specified offset.

      Implementation of:
      ArrayAccess::offsetExists

      Parameters

      $offset

      the offset to check on

      Remarks

      Returns whether there is an element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TMap::offsetGet

      offsetGet( integer $offset );

      Overridden in child classes as:

      TPriorityMap::offsetGet()
      Returns the element at the specified offset.

      Implementation of:
      ArrayAccess::offsetGet

      Parameters

      $offset

      the offset to retrieve element.

      Returns

      the element at the offset, null if no element is found at the offset

      Remarks

      Returns the element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TMap::offsetSet

      offsetSet( integer $offset, mixed $item );

      Overridden in child classes as:

      TPriorityMap::offsetSet()
      Sets the element at the specified offset.

      Implementation of:
      ArrayAccess::offsetSet

      Parameters

      $offset

      the offset to set element

      $item

      the element value

      Remarks

      Sets the element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TMap::offsetUnset

      offsetUnset( mixed $offset );

      Overridden in child classes as:

      TPriorityMap::offsetUnset()
      Unsets the element at the specified offset.

      Implementation of:
      ArrayAccess::offsetUnset

      Parameters

      $offset

      the offset to unset element

      Remarks

      Unsets the element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TMap::remove

      remove( mixed $key );

      Overridden in child classes as:

      TAttributeCollection::remove()
      Removes an item from the map by its key.
      TPriorityMap::remove()
      Removes an item from the map by its key. If no priority, or false, is specified

      Parameters

      $key

      the key of the item to be removed

      Returns

      the removed value, null if no such key exists.

      Remarks

      Removes an item from the map by its key.

      throws

      TInvalidOperationException if the map is read-only

      access

      public

      [ Top ]

      TMap::setReadOnly

      setReadOnly( boolean $value );

      Overridden in child classes as:

      TPriorityMap::setReadOnly()

      Parameters

      $value

      whether this list is read-only or not

      access

      protected

      [ Top ]

      TMap::toArray

      toArray( );

      Overridden in child classes as:

      TPriorityMap::toArray()
      When the map is flattened into an array, the priorities are taken into account and elements of the map are ordered in the array according to their priority.

      Returns

      the list of items in array

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:48 +0200 by phpDocumentor 1.4.3


Docs For Class TMapIterator

Class TMapIterator

[line 281]

Location: /Collections/TMap.php

Remarks

TMapIterator class

TMapIterator implements Iterator interface.
TMapIterator is used by TMap. It allows TMap to return a new iterator  for traversing the items in the map.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

deprecated

Issue 264 : ArrayIterator should be used instead

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TMapIterator::__construct

__construct(
array
&$data );

    Parameters

    &$data

    the data to be iterated through

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TMapIterator::current

current(
 );

    Implementation of:

    Iterator::current

    Returns

    the current array element

    Remarks

    Returns the current array element.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TMapIterator::key

key(
 );

    Implementation of:

    Iterator::key

    Returns

    the key of the current array element

    Remarks

    Returns the key of the current array element.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TMapIterator::next

next(
 );

    Implementation of:

    Iterator::next

    Remarks

    Moves the internal pointer to the next array element.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TMapIterator::rewind

rewind(
 );

    Implementation of:

    Iterator::rewind

    Remarks

    Rewinds internal array pointer.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TMapIterator::valid

valid(
 );

    Implementation of:

    Iterator::valid

    Remarks

    Returns whether there is an element at current position.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:48 +0200 by phpDocumentor 1.4.3


Docs For Class TPagedDataSource

Class TPagedDataSource

[line 31]
TComponent
   |
   --TPagedDataSource
Location: /Collections/TPagedDataSource.php

Remarks

TPagedDataSource class

TPagedDataSource implements an integer-indexed collection class with paging functionality.

Data items in TPagedDataSource can be traversed using foreach PHP statement like the following,

  •  foreach($pagedDataSource as $dataItem)
    •
    The data are fetched from DataSource. Only the items within the specified page will be returned and traversed.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TPagedDataSource.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TPagedDataSource::count

      count( );

      Implementation of:
      Countable::count

      Returns

      number of items in the current page.

      Remarks

      Returns the number of items in the current page.

      This method is required by Countable interface.

      access

      public

      [ Top ]

      TPagedDataSource::getAllowCustomPaging

      getAllowCustomPaging( );

      Returns

      whether to allow custom paging. Defaults to false.

      access

      public

      [ Top ]

      TPagedDataSource::getAllowPaging

      getAllowPaging( );

      Returns

      whether to allow paging. Defaults to false.

      access

      public

      [ Top ]

      TPagedDataSource::getCount

      getCount( );

      Returns

      number of items in current page

      access

      public

      [ Top ]

      TPagedDataSource::getCurrentPageIndex

      getCurrentPageIndex( );

      Returns

      current page index. Defaults to 0.

      access

      public

      [ Top ]

      TPagedDataSource::getDataSource

      getDataSource( );

      Returns

      original data source. Defaults to null.

      access

      public

      [ Top ]

      TPagedDataSource::getDataSourceCount

      getDataSourceCount( );

      Returns

      number of items in data source, if available

      access

      public

      [ Top ]

      TPagedDataSource::getFirstIndexInPage

      getFirstIndexInPage( );

      Returns

      the index of the item in data source, where the item is the first in current page

      access

      public

      [ Top ]

      TPagedDataSource::getIsFirstPage

      getIsFirstPage( );

      Returns

      whether the current page is the first page Defaults to false.

      access

      public

      [ Top ]

      TPagedDataSource::getIsLastPage

      getIsLastPage( );

      Returns

      whether the current page is the last page

      access

      public

      [ Top ]

      TPagedDataSource::getIterator

      getIterator( );

      Implementation of:
      IteratorAggregate::getIterator

      Returns

      iterator

      access

      public

      [ Top ]

      TPagedDataSource::getPageCount

      getPageCount( );

      Returns

      number of pages

      access

      public

      [ Top ]

      TPagedDataSource::getPageSize

      getPageSize( );

      Returns

      number of items in each page. Defaults to 10.

      access

      public

      [ Top ]

      TPagedDataSource::getVirtualItemCount

      getVirtualItemCount( );

      Returns

      user-assigned number of items in data source Defaults to 0.

      access

      public

      [ Top ]

      TPagedDataSource::setAllowCustomPaging

      setAllowCustomPaging( boolean $value );

      Parameters

      $value

      whether to allow custom paging

      access

      public

      [ Top ]

      TPagedDataSource::setAllowPaging

      setAllowPaging( boolean $value );

      Parameters

      $value

      whether to allow paging

      access

      public

      [ Top ]

      TPagedDataSource::setCurrentPageIndex

      setCurrentPageIndex( integer $value );

      Parameters

      $value

      current page index

      access

      public

      [ Top ]

      TPagedDataSource::setDataSource

      setDataSource( mixed $value );

      Parameters

      $value

      original data source

      access

      public

      [ Top ]

      TPagedDataSource::setPageSize

      setPageSize( integer $value );

      Parameters

      $value

      number of items in each page

      access

      public

      [ Top ]

      TPagedDataSource::setVirtualItemCount

      setVirtualItemCount( integer $value );

      Parameters

      $value

      user-assigned number of items in data source

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:58 +0200 by phpDocumentor 1.4.3


Docs For Class TPagedListIterator

Class TPagedListIterator

[line 284]

Location: /Collections/TPagedDataSource.php

Remarks

TPagedListIterator class

TPagedListIterator implements Iterator interface.
TPagedListIterator is used by TPagedDataSource. It allows TPagedDataSource  to return a new iterator for traversing the items in a TList object.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPagedDataSource.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TPagedListIterator::__construct

__construct(
TList
$list, integer
$startIndex, integer
$count );

    Parameters

    $list

    the data to be iterated through

    $startIndex

    start index

    $count

    number of items to be iterated through

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TPagedListIterator::current

current(
 );

    Implementation of:

    Iterator::current

    Returns

    the current array item

    Remarks

    Returns the current array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TPagedListIterator::key

key(
 );

    Implementation of:

    Iterator::key

    Returns

    the key of the current array item

    Remarks

    Returns the key of the current array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TPagedListIterator::next

next(
 );

    Implementation of:

    Iterator::next

    Remarks

    Moves the internal pointer to the next array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TPagedListIterator::rewind

rewind(
 );

    Implementation of:

    Iterator::rewind

    Remarks

    Rewinds internal array pointer.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TPagedListIterator::valid

valid(
 );

    Implementation of:

    Iterator::valid

    Remarks

    Returns whether there is an item at current position.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:58 +0200 by phpDocumentor 1.4.3


Docs For Class TPagedMapIterator

Class TPagedMapIterator

[line 370]

Location: /Collections/TPagedDataSource.php

Remarks

TPagedMapIterator class

TPagedMapIterator implements Iterator interface.
TPagedMapIterator is used by TPagedDataSource. It allows TPagedDataSource  to return a new iterator for traversing the items in a TMap object.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPagedDataSource.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TPagedMapIterator::__construct

__construct(
TMap
$map,
$startIndex,
$count );

    Parameters

    $map

    the data to be iterated through

    $startIndex

    $count

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TPagedMapIterator::current

current(
 );

    Implementation of:

    Iterator::current

    Returns

    the current array item

    Remarks

    Returns the current array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TPagedMapIterator::key

key(
 );

    Implementation of:

    Iterator::key

    Returns

    the key of the current array item

    Remarks

    Returns the key of the current array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TPagedMapIterator::next

next(
 );

    Implementation of:

    Iterator::next

    Remarks

    Moves the internal pointer to the next array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TPagedMapIterator::rewind

rewind(
 );

    Implementation of:

    Iterator::rewind

    Remarks

    Rewinds internal array pointer.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TPagedMapIterator::valid

valid(
 );

    Implementation of:

    Iterator::valid

    Remarks

    Returns whether there is an item at current position.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:58 +0200 by phpDocumentor 1.4.3


Docs For Class TPagedList

Class TPagedList

[line 58]
TComponent
   |
   --TList
      |
      --TPagedList
Classes extended from TPagedList:
TSqlMapPagedList
TSqlMapPagedList implements a list with paging functionality that retrieves data from a SqlMap statement.

Location: /Collections/TPagedList.php

Remarks

TPagedList class

TPagedList implements a list with paging functionality.

TPagedList works in one of two modes, managed paging or customized paging, specified by CustomPaging.

  • Managed paging (CustomPaging=false) : the list is assumed to contain all data and it will manage which page of data are available to user.
  • Customized paging (CustomPaging=true) : the list is assumed to contain only one page of data. An OnFetchData event will be raised if the list changes to a different page. Developers can attach a handler to the event and supply the needed data. The event handler can be written as follows,
  •   public function fetchData($sender,$param)
    •

  •   {
    •

  •     $offset=$param->Offset; // beginning index of the data needed
    •

  •     $limit=$param->Limit;   // maximum number of data items needed
    •

  •     // get data according to the above two parameters
    •

  •     $param->Data=$data;
    •

  •   }
    •
Data in TPagedList can be accessed like an integer-indexed array and can be traversed using foreach. For example,
  •  $count=$list->Count;
    •

  •  for($index=0;$index<$count;++$index)
    •

  •      echo $list[$index];
    •

  •  foreach($list as $index=>$item) // traverse each item in the list
    •

    The PageSize property specifies the number of items in each page. To access different page of data in the list, set CurrentPageIndex or call nextPage(), previousPage(), or gotoPage(). The total number of pages can be obtained by PageCount.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TPagedList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TList

    • TList::__construct()
      Constructor.
    • TList::add()
      Appends an item at the end of the list.
    • TList::clear()
      Removes all items in the list.
    • TList::contains()
    • TList::copyFrom()
      Copies iterable data into the list.
    • TList::count()
      Returns the number of items in the list.
    • TList::getCount()
    • TList::getIterator()
      Returns an iterator for traversing the items in the list.
    • TList::getReadOnly()
    • TList::indexOf()
    • TList::insertAfter()
      Finds the base item. If found, the item is inserted after it.
    • TList::insertAt()
      Inserts an item at the specified position.
    • TList::insertBefore()
      Finds the base item. If found, the item is inserted before it.
    • TList::itemAt()
      Returns the item at the specified offset.
    • TList::mergeWith()
      Merges iterable data into the map.
    • TList::offsetExists()
      Returns whether there is an item at the specified offset.
    • TList::offsetGet()
      Returns the item at the specified offset.
    • TList::offsetSet()
      Sets the item at the specified offset.
    • TList::offsetUnset()
      Unsets the item at the specified offset.
    • TList::remove()
      Removes an item from the list.
    • TList::removeAt()
      Removes an item at the specified position.
    • TList::setReadOnly()
    • TList::toArray()

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TPagedList::__construct

      __construct( [array|Iterator $data = null], [boolean $readOnly = false] );

      Overridden in child classes as:

      TSqlMapPagedList::__construct()
      Create a new SqlMap paged list.

      Overrides TList::__construct() (Constructor.)

      Parameters

      $data

      the initial data. Default is null, meaning no initialization.

      $readOnly

      whether the list is read-only. Always true for paged list.

      Remarks

      Constructor.

      access

      public

      [ Top ]

      TPagedList::getCount

      getCount( );

      Overrides TList::getCount() (parent method not documented)

      Returns

      the number of items in current page

      access

      public

      [ Top ]

      TPagedList::getCurrentPageIndex

      getCurrentPageIndex( );

      Returns

      current page index. Defaults to 0.

      access

      public

      [ Top ]

      TPagedList::getCustomPaging

      getCustomPaging( );

      Returns

      whether to use custom paging. Defaults to false.

      access

      public

      [ Top ]

      TPagedList::getIsFirstPage

      getIsFirstPage( );

      Returns

      whether the current page is the first page

      access

      public

      [ Top ]

      TPagedList::getIsLastPage

      getIsLastPage( );

      Overridden in child classes as:

      TSqlMapPagedList::getIsLastPage()

      Returns

      whether the current page is the last page

      access

      public

      [ Top ]

      TPagedList::getIterator

      getIterator( );

      Overrides TList::getIterator() (Returns an iterator for traversing the items in the list.)

      Returns

      iterator

      access

      public

      [ Top ]

      TPagedList::getPageCount

      getPageCount( );

      Returns

      number of pages, -1 if under custom paging mode and VirtualCount is not set.

      access

      public

      [ Top ]

      TPagedList::getPageSize

      getPageSize( );

      Returns

      number of items in each page. Defaults to 10.

      access

      public

      [ Top ]

      TPagedList::getVirtualCount

      getVirtualCount( );

      Returns

      user-assigned number of items in data source. Defaults to 0.

      access

      public

      [ Top ]

      TPagedList::gotoPage

      gotoPage( integer $pageIndex );

      Parameters

      $pageIndex

      page index

      Returns

      the new page index, false if page index is out of range.

      Remarks

      Changes to a page with the specified page index.

      access

      public

      [ Top ]

      TPagedList::indexOf

      indexOf( mixed $item );

      Overrides TList::indexOf() (parent method not documented)

      Parameters

      $item

      the item

      Returns

      the index of the item in the list (0 based), -1 if not found.

      access

      public

      [ Top ]

      TPagedList::itemAt

      itemAt( integer $index );

      Overrides TList::itemAt() (Returns the item at the specified offset.)

      Parameters

      $index

      the index of the item

      Returns

      the item at the index

      Remarks

      Returns the item at the specified offset.

      This method is exactly the same as offsetGet.

      throws

      TInvalidDataValueException if the index is out of the range

      access

      public

      [ Top ]

      TPagedList::nextPage

      nextPage( );

      Overridden in child classes as:

      TSqlMapPagedList::nextPage()
      Switches to the next page.

      Returns

      the new page index, false if next page is not available.

      Remarks

      Switches to the next page.

      access

      public

      [ Top ]

      TPagedList::offsetExists

      offsetExists( integer $offset );

      Overrides TList::offsetExists() (Returns whether there is an item at the specified offset.)

      Parameters

      $offset

      the offset to check on

      Remarks

      Returns whether there is an item at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TPagedList::offsetGet

      offsetGet( integer $offset );

      Overrides TList::offsetGet() (Returns the item at the specified offset.)

      Parameters

      $offset

      the offset to retrieve item.

      Returns

      the item at the offset

      Remarks

      Returns the item at the specified offset.

      This method is required by the interface ArrayAccess.

      throws

      TInvalidDataValueException if the offset is invalid

      access

      public

      [ Top ]

      TPagedList::onFetchData

      onFetchData( TPagedListFetchDataEventParameter $param );

      Parameters

      $param

      event parameter

      Remarks

      Raises OnFetchData event.

      This event is raised each time when the list changes to a different page and needs the new page of data. This event can only be raised when CustomPaging is true.

      access

      public

      [ Top ]

      TPagedList::onPageIndexChanged

      onPageIndexChanged( TPagedListPageChangedEventParameter $param );

      Parameters

      $param

      event parameter

      Remarks

      Raises OnPageIndexChanged event.

      This event is raised each time when the list changes to a different page.

      access

      public

      [ Top ]

      TPagedList::previousPage

      previousPage( );

      Overridden in child classes as:

      TSqlMapPagedList::previousPage()
      Switches to the previous page.

      Returns

      the new page index, false if previous page is not available.

      Remarks

      Switches to the previous page.

      access

      public

      [ Top ]

      TPagedList::setCurrentPageIndex

      setCurrentPageIndex( integer $value );

      Parameters

      $value

      current page index

      throws

      TInvalidDataValueException if the page index is out of range

      access

      public

      [ Top ]

      TPagedList::setCustomPaging

      setCustomPaging( boolean $value );

      Overridden in child classes as:

      TSqlMapPagedList::setCustomPaging()

      Parameters

      $value

      whether to allow custom paging

      access

      public

      [ Top ]

      TPagedList::setPageSize

      setPageSize( integer $value );

      Parameters

      $value

      number of items in each page

      access

      public

      [ Top ]

      TPagedList::setVirtualCount

      setVirtualCount( integer $value );

      Parameters

      $value

      user-assigned number of items in data source

      access

      public

      [ Top ]

      TPagedList::toArray

      toArray( );

      Overrides TList::toArray() (parent method not documented)

      Returns

      the list of items in array

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:58 +0200 by phpDocumentor 1.4.3


Docs For Class TPagedListFetchDataEventParameter

Class TPagedListFetchDataEventParameter

[line 417]
TComponent
   |
   --TEventParameter
      |
      --TPagedListFetchDataEventParameter
Location: /Collections/TPagedList.php

Remarks

TPagedListFetchDataEventParameter class.

TPagedListFetchDataEventParameter is used as the parameter for TPagedList::onFetchData event. To obtain the new page index, use NewPageIndex. The Offset property refers to the index of the first item in the new page, while Limit specifies how many items are requested for the page. Newly fetched data should be saved in Data property.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPagedList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPagedListFetchDataEventParameter::__construct

    __construct( integer $pageIndex, integer $offset, integer $limit );

    Parameters

    $pageIndex

    new page index

    $offset

    offset of the first item in the new page

    $limit

    number of items in the new page desired

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TPagedListFetchDataEventParameter::getData

    getData( );

    Returns

    new page data

    access

    public

    [ Top ]

    TPagedListFetchDataEventParameter::getLimit

    getLimit( );

    Returns

    number of items in the new page

    access

    public

    [ Top ]

    TPagedListFetchDataEventParameter::getNewPageIndex

    getNewPageIndex( );

    Returns

    the zero-based index of the new page

    access

    public

    [ Top ]

    TPagedListFetchDataEventParameter::getOffset

    getOffset( );

    Returns

    offset of the first item in the new page

    access

    public

    [ Top ]

    TPagedListFetchDataEventParameter::setData

    setData( mixed $value );

    Parameters

    $value

    new page data

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:58 +0200 by phpDocumentor 1.4.3


Docs For Class TPagedListPageChangedEventParameter

Class TPagedListPageChangedEventParameter

[line 379]
TComponent
   |
   --TEventParameter
      |
      --TPagedListPageChangedEventParameter
Location: /Collections/TPagedList.php

Remarks

TPagedListPageChangedEventParameter class.

TPagedListPageChangedEventParameter is used as the parameter for TPagedList::onPageChanged event. To obtain the page index before it was changed, use OldPageIndex.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPagedList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPagedListPageChangedEventParameter::__construct

    __construct( integer $oldPage );

    Parameters

    $oldPage

    old page index

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TPagedListPageChangedEventParameter::getOldPageIndex

    getOldPageIndex( );

    Returns

    the index of the page before the list changed to the new page

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:58 +0200 by phpDocumentor 1.4.3


Docs For Class TPriorityList

Class TPriorityList

[line 50]
TComponent
   |
   --TList
      |
      --TPriorityList
Location: /Collections/TPriorityList.php

Remarks

TPriorityList class

TPriorityList implements a priority ordered list collection class. It allows you to specify any numeric for priorities down to a specific precision. The lower the numeric, the high the priority of the item in the list. Thus -10 has a higher priority than -5, 0, 10 (the default), 18, 10005, etc. Per http://www.php.net/round, precision may be negative and thus rounding can go by 10, 100, 1000, etc, instead of just .1, .01, .001, etc. The default precision allows for 8 decimal places. There is also a default priority of 10, if no different default priority is specified or no item specific priority is indicated. If you replace TList with this class it will work exactly the same with items inserted set to the default priority, until you start using different priorities than the default priority.

As you access the PHP array features of this class, it flattens and caches the results. If at all possible, this will keep the cache fresh even when manipulated. If this is not possible the cache is cleared. When an array of items are needed and the cache is outdated, the cache is recreated from the items and their priorities

You can access, append, insert, remove an item by using itemAt, add, insertAt, and remove. To get the number of the items in the list, use getCount. TPriorityList can also be used like a regular array as follows,

  •  $list[]=$item;  // append with the default priority.  It may not be the last item if other items in the list are prioritized after the default priority
    •

  •  $list[$index]=$item; // $index must be between 0 and $list->Count-1.  This sets the element regardless of priority.  Priority stays the same.
    •

  •  $list[$index]=$item; // $index is $list->Count.  This appends the item to the end of the list with the same priority as the last item in the list.
    •

  •  unset($list[$index]); // remove the item at $index
    •

  •  if(isset($list[$index])) // if the list has an item at $index
    •

  •  foreach($list as $index=>$item) // traverse each item in the list in proper priority order and add/insert order
    •

  •  $n=count($list); // returns the number of items in the list
    •

    To extend TPriorityList for doing your own operations with each addition or removal, override insertAtIndexInPriority() and removeAtIndexInPriority() and then call the parent.

    author

    Brad Anderson <javalizard@gmail.com>

    version

    $Id: TPriorityList.php 2541 2008-10-21 15:05:13Z javalizard $

    since

    3.2a

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TList

    • TList::__construct()
      Constructor.
    • TList::add()
      Appends an item at the end of the list.
    • TList::clear()
      Removes all items in the list.
    • TList::contains()
    • TList::copyFrom()
      Copies iterable data into the list.
    • TList::count()
      Returns the number of items in the list.
    • TList::getCount()
    • TList::getIterator()
      Returns an iterator for traversing the items in the list.
    • TList::getReadOnly()
    • TList::indexOf()
    • TList::insertAfter()
      Finds the base item. If found, the item is inserted after it.
    • TList::insertAt()
      Inserts an item at the specified position.
    • TList::insertBefore()
      Finds the base item. If found, the item is inserted before it.
    • TList::itemAt()
      Returns the item at the specified offset.
    • TList::mergeWith()
      Merges iterable data into the map.
    • TList::offsetExists()
      Returns whether there is an item at the specified offset.
    • TList::offsetGet()
      Returns the item at the specified offset.
    • TList::offsetSet()
      Sets the item at the specified offset.
    • TList::offsetUnset()
      Unsets the item at the specified offset.
    • TList::remove()
      Removes an item from the list.
    • TList::removeAt()
      Removes an item at the specified position.
    • TList::setReadOnly()
    • TList::toArray()

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TPriorityList::__construct

      __construct(
[array|Iterator
$data = null], [boolean
$readOnly = false], [numeric
$defaultPriority = 10], [integer
$precision = 8] );

      Overrides TList::__construct() (Constructor.)

      Parameters

      $data

      the intial data. Default is null, meaning no initial data.

      $readOnly

      whether the list is read-only

      $defaultPriority

      the default priority of items without specified priorities.

      $precision

      the precision of the numeric priorities

      Remarks

      Constructor.

      Initializes the list with an array or an iterable object.

      throws

      TInvalidDataTypeException If data is not null and is neither an array nor an iterator.

      access

      public

      [ Top ]

      TPriorityList::add

      add( mixed $item, [numeric $priority = null] );

      Overrides TList::add() (Appends an item at the end of the list.)

      Parameters

      $item

      item to add into the list at priority

      $priority

      priority blank or null for the default priority

      Returns

      the index within the flattened array

      Remarks

      Appends an item into the list at the end of the specified priority. The position of the added item may not be at the end of the list.

      throws

      TInvalidOperationException if the map is read-only

      access

      public

      [ Top ]

      TPriorityList::clear

      clear( );

      Overrides TList::clear() (Removes all items in the list.)

      Remarks

      Removes all items in the priority list by calling removeAtIndexInPriority from the last item to the first.

      access

      public

      [ Top ]

      TPriorityList::contains

      contains( mixed $item );

      Overrides TList::contains() (parent method not documented)

      Parameters

      $item

      item

      Returns

      whether the list contains the item

      access

      public

      [ Top ]

      TPriorityList::copyFrom

      copyFrom( mixed $data );

      Overrides TList::copyFrom() (Copies iterable data into the list.)

      Parameters

      $data

      the data to be copied from, must be an array or object implementing Traversable

      Remarks

      Copies iterable data into the priority list.

      Note, existing data in the map will be cleared first.

      throws

      TInvalidDataTypeException If data is neither an array nor an iterator.

      access

      public

      [ Top ]

      TPriorityList::count

      count( );

      Overrides TList::count() (Returns the number of items in the list.)

      Returns

      number of items in the list.

      Remarks

      Returns the number of items in the list.

      This method is required by Countable interface.

      access

      public

      [ Top ]

      TPriorityList::flattenPriorities

      flattenPriorities( );

      Returns

      array of items in the list in priority and index order

      Remarks

      This flattens the priority list into a flat array [0,...,n-1]

      access

      protected

      [ Top ]

      TPriorityList::getCount

      getCount( );

      Overrides TList::getCount() (parent method not documented)

      Returns

      the number of items in the list

      Remarks

      Returns the total number of items in the list

      access

      public

      [ Top ]

      TPriorityList::getDefaultPriority

      getDefaultPriority( );

      Returns

      gets the default priority of inserted items without a specified priority

      access

      public

      [ Top ]

      TPriorityList::getIterator

      getIterator( );

      Overrides TList::getIterator() (Returns an iterator for traversing the items in the list.)

      Returns

      an iterator for traversing the items in the list.

      Remarks

      Returns an iterator for traversing the items in the list.

      This method is required by the interface IteratorAggregate.

      access

      public

      [ Top ]

      TPriorityList::getPrecision

      getPrecision( );

      Returns

      The precision of numeric priorities, defaults to 8

      access

      public

      [ Top ]

      TPriorityList::getPriorities

      getPriorities( );

      Returns

      the array of priority numerics in decreasing priority order

      Remarks

      This returns a list of the priorities within this list, ordered lowest to highest.

      access

      public

      [ Top ]

      TPriorityList::getPriorityCount

      getPriorityCount( [numeric $priority = null] );

      Parameters

      $priority

      optional priority at which to count items. if no parameter, it will be set to the default getDefaultPriority

      Returns

      the number of items in the list at the specified priority

      Remarks

      Gets the number of items at a priority within the list

      access

      public

      [ Top ]

      TPriorityList::indexOf

      indexOf( mixed $item );

      Overrides TList::indexOf() (parent method not documented)

      Parameters

      $item

      item

      Returns

      the index of the item in the flattened list (0 based), -1 if not found.

      access

      public

      [ Top ]

      TPriorityList::insertAfter

      insertAfter( mixed $indexitem, mixed $item );

      Overrides TList::insertAfter() (Finds the base item. If found, the item is inserted after it.)

      Parameters

      $indexitem

      indexitem the item to index

      $item

      the item to add after indexitem

      Returns

      where the item has been inserted in the flattened list

      Remarks

      This inserts an item after another item within the list. It uses the same priority as the found index item and places the new item after it.

      throws

      TInvalidDataValueException If the item does not exist

      access

      public

      [ Top ]

      TPriorityList::insertAt

      insertAt( integer $index, mixed $item );

      Overrides TList::insertAt() (Inserts an item at the specified position.)

      Parameters

      $index

      the specified position in the flattened list.

      $item

      new item to add

      Remarks

      Inserts an item at an index. It reads the priority of the item at index within the flattened list and then inserts the item at that priority-index.

      throws

      TInvalidOperationException if the list is read-only

      throws

      TInvalidDataValueException If the index specified exceeds the bound

      access

      public

      [ Top ]

      TPriorityList::insertAtIndexInPriority

      insertAtIndexInPriority( mixed $item, [integer $index = false], [numeric $priority = null], [boolean $preserveCache = false] );

      Parameters

      $item

      item to add within the list.

      $index

      index within the priority to add the item, defaults to false which appends the item at the priority

      $priority

      priority priority of the item. defaults to null, which sets it to the default priority

      $preserveCache

      preserveCache specifies if this is a special quick function or not. This defaults to false.

      Remarks

      Inserts an item at the specified index within a priority. Override and call this method to insert your own functionality.

      throws

      TInvalidOperationException if the list is read-only

      throws

      TInvalidDataValueException If the index specified exceeds the bound

      access

      public

      [ Top ]

      TPriorityList::insertBefore

      insertBefore( mixed $indexitem, mixed $item );

      Overrides TList::insertBefore() (Finds the base item. If found, the item is inserted before it.)

      Parameters

      $indexitem

      indexitem the item to index

      $item

      the item to add before indexitem

      Returns

      where the item has been inserted in the flattened list

      Remarks

      This inserts an item before another item within the list. It uses the same priority as the found index item and places the new item before it.

      throws

      TInvalidDataValueException If the item does not exist

      access

      public

      [ Top ]

      TPriorityList::itemAt

      itemAt( integer $index );

      Overrides TList::itemAt() (Returns the item at the specified offset.)

      Parameters

      $index

      the index of the item to get

      Returns

      the element at the offset

      Remarks

      Returns the item at the index of a flattened priority list.

      offsetGet calls this method.

      throws

      TInvalidDataValueException Issued when the index is invalid

      access

      public

      [ Top ]

      TPriorityList::itemAtIndexInPriority

      itemAtIndexInPriority( integer $index, [numeric $priority = null] );

      Parameters

      $index

      the index into the list of items at priority

      $priority

      the priority which to index. no parameter or null will result in the default priority

      Returns

      the element at the offset, false if no element is found at the offset

      Remarks

      Returns the item at an index within a priority

      access

      public

      [ Top ]

      TPriorityList::itemsAtPriority

      itemsAtPriority( [numeric $priority = null] );

      Parameters

      $priority

      priority of the items to get. Defaults to null, filled in with the default priority, if left blank.

      Returns

      all items at priority in index order, null if there are no items at that priority

      Remarks

      Gets all the items at a specific priority.

      access

      public

      [ Top ]

      TPriorityList::mergeWith

      mergeWith( mixed $data );

      Overrides TList::mergeWith() (Merges iterable data into the map.)

      Parameters

      $data

      the data to be merged with, must be an array or object implementing Traversable

      Remarks

      Merges iterable data into the priority list.

      New data will be appended to the end of the existing data. If another TPriorityList is merged, the incoming parameter items will be appended at the priorities they are present. These items will be added to the end of the existing items with equal priorities, if there are any.

      throws

      TInvalidDataTypeException If data is neither an array nor an iterator.

      access

      public

      [ Top ]

      TPriorityList::offsetExists

      offsetExists( mixed $offset );

      Overrides TList::offsetExists() (Returns whether there is an item at the specified offset.)

      Parameters

      $offset

      the offset to check on

      Remarks

      Returns whether there is an element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TPriorityList::offsetGet

      offsetGet( integer $offset );

      Overrides TList::offsetGet() (Returns the item at the specified offset.)

      Parameters

      $offset

      the offset to retrieve element.

      Returns

      the element at the offset, null if no element is found at the offset

      Remarks

      Returns the element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TPriorityList::offsetSet

      offsetSet( integer $offset, mixed $item );

      Overrides TList::offsetSet() (Sets the item at the specified offset.)

      Parameters

      $offset

      the offset to set element

      $item

      the element value

      Remarks

      Sets the element at the specified offset. This method is required by the interface ArrayAccess.

      Setting elements in a priority list is not straight forword when appending and setting at the end boundary. When appending without an offset (a null offset), the item will be added at the default priority. The item may not be the last item in the list. When appending with an offset equal to the count of the list, the item will get be appended with the last items priority.

      All together, when setting the location of an item, the item stays in that location, but appending an item into a priority list doesn't mean the item is at the end of the list.

      access

      public

      [ Top ]

      TPriorityList::offsetUnset

      offsetUnset( mixed $offset );

      Overrides TList::offsetUnset() (Unsets the item at the specified offset.)

      Parameters

      $offset

      the offset to unset element

      Remarks

      Unsets the element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TPriorityList::priorityAt

      priorityAt( integer $index, [boolean $withindex = false] );

      Parameters

      $index

      index of the item within the list

      $withindex

      withindex this specifies if the full positional data of the item within the list is returned. This defaults to false, if no parameter is provided, so only provides the priority number of the item by default.

      Returns

      the priority of the item in the list, false if not found. if withindex is true, an array is returned of [0 => $priority, 1 => $priorityIndex, 2 => flattenedIndex, 'priority' => $priority, 'index' => $priorityIndex, 'absindex' => flattenedIndex]

      Remarks

      Retutrns the priority of an item at a particular flattened index.

      access

      public

      [ Top ]

      TPriorityList::priorityOf

      priorityOf( mixed $item, [boolean $withindex = false] );

      Parameters

      $item

      the item to look for within the list

      $withindex

      withindex this specifies if the full positional data of the item within the list is returned. This defaults to false, if no parameter is provided, so only provides the priority number of the item by default.

      Returns

      the priority of the item in the list, false if not found. if withindex is true, an array is returned of [0 => $priority, 1 => $priorityIndex, 2 => flattenedIndex, 'priority' => $priority, 'index' => $priorityIndex, 'absindex' => flattenedIndex]

      Remarks

      Returns the priority of a particular item

      access

      public

      [ Top ]

      TPriorityList::remove

      remove( mixed $item, [numeric $priority = false] );

      Overrides TList::remove() (Removes an item from the list.)

      Parameters

      $item

      item the item to be removed.

      $priority

      priority of item to remove. without this parameter it defaults to false. A value of false means any priority. null will be filled in with the default priority.

      Returns

      index within the flattened list at which the item is being removed

      Remarks

      Removes an item from the priority list.

      The list will search for the item. The first matching item found will be removed from the list.

      throws

      TInvalidDataValueException If the item does not exist

      access

      public

      [ Top ]

      TPriorityList::removeAt

      removeAt( integer $index );

      Overrides TList::removeAt() (Removes an item at the specified position.)

      Parameters

      $index

      index of the item to be removed.

      Returns

      the removed item.

      Remarks

      Removes an item at the specified index in the flattened list.

      throws

      TInvalidOperationException if the list is read-only

      throws

      TInvalidDataValueException If the index specified exceeds the bound

      access

      public

      [ Top ]

      TPriorityList::removeAtIndexInPriority

      removeAtIndexInPriority( integer $index, [numeric $priority = null] );

      Parameters

      $index

      index of item to remove within the priority.

      $priority

      priority of the item to remove, defaults to null, or left blank, it is then set to the default priority

      Returns

      the removed item.

      Remarks

      Removes the item at a specific index within a priority. Override and call this method to insert your own functionality.

      throws

      TInvalidDataValueException If the item does not exist

      access

      public

      [ Top ]

      TPriorityList::setDefaultPriority

      setDefaultPriority( numeric $value );

      Parameters

      $value

      sets the default priority of inserted items without a specified priority

      Remarks

      This must be called internally or when instantiated.

      access

      protected

      [ Top ]

      TPriorityList::setPrecision

      setPrecision( integer $value );

      Parameters

      $value

      The precision of numeric priorities.

      Remarks

      This must be called internally or when instantiated.

      access

      protected

      [ Top ]

      TPriorityList::sortPriorities

      sortPriorities( );

      Remarks

      This orders the priority list internally.

      access

      protected

      [ Top ]

      TPriorityList::toArray

      toArray( );

      Overrides TList::toArray() (parent method not documented)

      Returns

      the priority list of items in array

      access

      public

      [ Top ]

      TPriorityList::toArrayAbovePriority

      toArrayAbovePriority( numeric $priority, [boolean $inclusive = true] );

      Parameters

      $priority

      the cut-off priority. All items of priority greater than this are returned.

      $inclusive

      whether or not the input cut-off priority is inclusive. Default: true, inclusive.

      Returns

      the array of priorities keys with values of arrays of items that are above a specified priority. The priorities are sorted so important priorities, lower numerics, are first.

      Remarks

      Combines the map elements which have a priority above the parameter value

      access

      public

      [ Top ]

      TPriorityList::toArrayBelowPriority

      toArrayBelowPriority( numeric $priority, [boolean $inclusive = false] );

      Parameters

      $priority

      the cut-off priority. All items of priority less than this are returned.

      $inclusive

      whether or not the input cut-off priority is inclusive. Default: false, not inclusive.

      Returns

      the array of priorities keys with values of arrays of items that are below a specified priority. The priorities are sorted so important priorities, lower numerics, are first.

      Remarks

      Combines the map elements which have a priority below the parameter value

      access

      public

      [ Top ]

      TPriorityList::toPriorityArray

      toPriorityArray( );

      Returns

      the array of priorities keys with values of arrays of items. The priorities are sorted so important priorities, lower numerics, are first.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:03 +0200 by phpDocumentor 1.4.3


Docs For Class TPriorityMap

Class TPriorityMap

[line 60]
TComponent
   |
   --TMap
      |
      --TPriorityMap
Location: /Collections/TPriorityMap.php

Remarks

TPriorityMap class

TPriorityMap implements a collection that takes key-value pairs with a priority to allow key-value pairs to be ordered. This ordering is important when flattening the map. When flattening the map, if some key-value pairs are required to be before or after others, use this class to keep order to your map.

You can access, add or remove an item with a key by using itemAt, add, and remove. These functions can optionally take a priority parameter to allow access to specific priorities. TPriorityMap is functionally backward compatible with TMap.

To get the number of the items in the map, use getCount. TPriorityMap can also be used like a regular array as follows,

  •  $map[$key]=$value; // add a key-value pair
    •

  •  unset($map[$key]); // remove the value with the specified key
    •

  •  if(isset($map[$key])) // if the map contains the key
    •

  •  foreach($map as $key=>$value) // traverse the items in the map
    •

  •  $n=count($map);  // returns the number of items in the map
    •
    Using standard array access method like these will always use the default priority.

    An item that doesn't specify a priority will receive the default priority. The default priority is set during the instantiation of a new TPriorityMap. If no custom default priority is specified, the standard default priority of 10 is used.

    Priorities with significant digits below precision will be rounded.

    A priority may also be a numeric with decimals. This is set during the instantiation of a new TPriorityMap. The default is 8 decimal places for a priority. If a negative number is used, rounding occurs into the integer space rather than in the decimal space. See http://www.php.net/round.

    author

    Brad Anderson <javalizard@mac.com>

    version

    $Id: TPriorityMap.php 2817 2010-04-18 04:25:03Z javalizard $

    since

    3.2a

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TMap

    • TMap::__construct()
      Constructor.
    • TMap::add()
      Adds an item into the map.
    • TMap::clear()
      Removes all items in the map.
    • TMap::contains()
    • TMap::copyFrom()
      Copies iterable data into the map.
    • TMap::count()
      Returns the number of items in the map.
    • TMap::getCount()
    • TMap::getIterator()
      Returns an iterator for traversing the items in the list.
    • TMap::getKeys()
    • TMap::getReadOnly()
    • TMap::itemAt()
      Returns the item with the specified key.
    • TMap::mergeWith()
      Merges iterable data into the map.
    • TMap::offsetExists()
      Returns whether there is an element at the specified offset.
    • TMap::offsetGet()
      Returns the element at the specified offset.
    • TMap::offsetSet()
      Sets the element at the specified offset.
    • TMap::offsetUnset()
      Unsets the element at the specified offset.
    • TMap::remove()
      Removes an item from the map by its key.
    • TMap::setReadOnly()
    • TMap::toArray()

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TPriorityMap::__construct

      __construct(
[map|array|Iterator|TPriorityMap
$data = null], [boolean
$readOnly = false], [numeric
$defaultPriority = 10], [integer
$precision = 8] );

      Overrides TMap::__construct() (Constructor.)

      Parameters

      $data

      the intial data. Default is null, meaning no initialization.

      $readOnly

      whether the list is read-only

      $defaultPriority

      the default priority of items without specified priorities.

      $precision

      the precision of the numeric priorities

      Remarks

      Constructor.

      Initializes the array with an array or an iterable object.

      throws

      TInvalidDataTypeException If data is not null and neither an array nor an iterator.

      access

      public

      [ Top ]

      TPriorityMap::add

      add( mixed $key, mixed $value, [numeric|null $priority = null] );

      Overrides TMap::add() (Adds an item into the map.)

      Parameters

      $key

      key

      $value

      value

      $priority

      priority, default: null, filled in with default priority

      Returns

      priority at which the pair was added

      Remarks

      Adds an item into the map. A third parameter may be used to set the priority of the item within the map. Priority is primarily used during when flattening the map into an array where order may be and important factor of the key-value pairs within the array.

      Note, if the specified key already exists, the old value will be overwritten. No duplicate keys are allowed regardless of priority.

      throws

      TInvalidOperationException if the map is read-only

      access

      public

      [ Top ]

      TPriorityMap::clear

      clear( );

      Overrides TMap::clear() (Removes all items in the map.)

      Remarks

      Removes all items in the map. remove is called on all items.

      access

      public

      [ Top ]

      TPriorityMap::contains

      contains( mixed $key );

      Overrides TMap::contains() (parent method not documented)

      Parameters

      $key

      the key

      Returns

      whether the map contains an item with the specified key

      access

      public

      [ Top ]

      TPriorityMap::copyFrom

      copyFrom( mixed $data );

      Overrides TMap::copyFrom() (Copies iterable data into the map.)

      Parameters

      $data

      the data to be copied from, must be an array, object implementing Traversable, or a TPriorityMap

      Remarks

      Copies iterable data into the map.

      Note, existing data in the map will be cleared first.

      throws

      TInvalidDataTypeException If data is neither an array nor an iterator.

      access

      public

      [ Top ]

      TPriorityMap::count

      count( );

      Overrides TMap::count() (Returns the number of items in the map.)

      Returns

      number of items in the map.

      Remarks

      Returns the number of items in the map.

      This method is required by Countable interface.

      access

      public

      [ Top ]

      TPriorityMap::flattenPriorities

      flattenPriorities( );

      Returns

      array of items in the list in priority and index order

      Remarks

      This flattens the priority map into a flat array [0,...,n-1]

      access

      protected

      [ Top ]

      TPriorityMap::getCount

      getCount( );

      Overrides TMap::getCount() (parent method not documented)

      Returns

      the number of items in the map

      access

      public

      [ Top ]

      TPriorityMap::getDefaultPriority

      getDefaultPriority( );

      Returns

      gets the default priority of inserted items without a specified priority

      access

      public

      [ Top ]

      TPriorityMap::getIterator

      getIterator( );

      Overrides TMap::getIterator() (Returns an iterator for traversing the items in the list.)

      Returns

      an iterator for traversing the items in the map.

      Remarks

      Returns an iterator for traversing the items in the map.

      This method is required by the interface IteratorAggregate.

      access

      public

      [ Top ]

      TPriorityMap::getKeys

      getKeys( );

      Overrides TMap::getKeys() (parent method not documented)

      Returns

      the key list

      Remarks

      Returns the keys within the map ordered through the priority of each key-value pair

      access

      public

      [ Top ]

      TPriorityMap::getPrecision

      getPrecision( );

      Returns

      The precision of numeric priorities, defaults to 8

      access

      public

      [ Top ]

      TPriorityMap::getPriorities

      getPriorities( );

      Returns

      the array of priority numerics in decreasing priority order

      Remarks

      This returns a list of the priorities within this map, ordered lowest to highest.

      access

      public

      [ Top ]

      TPriorityMap::getPriorityCount

      getPriorityCount( [numeric $priority = null] );

      Parameters

      $priority

      optional priority at which to count items. if no parameter, it will be set to the default getDefaultPriority

      Returns

      the number of items in the map at the specified priority

      Remarks

      Gets the number of items at a priority within the map.

      access

      public

      [ Top ]

      TPriorityMap::getReadOnly

      getReadOnly( );

      Overrides TMap::getReadOnly() (parent method not documented)

      Returns

      whether this map is read-only or not. Defaults to false.

      access

      public

      [ Top ]

      TPriorityMap::itemAt

      itemAt( mixed $key, [mixed $priority = false] );

      Overrides TMap::itemAt() (Returns the item with the specified key.)

      Parameters

      $key

      the key

      $priority

      the priority. null is the default priority, false is any priority, and numeric is a specific priority. default: false, any priority.

      Returns

      the element at the offset, null if no element is found at the offset

      Remarks

      Returns the item with the specified key. If a priority is specified, only items

      within that specific priority will be selected

      access

      public

      [ Top ]

      TPriorityMap::itemsAtPriority

      itemsAtPriority( [numeric $priority = null] );

      Parameters

      $priority

      priority of the items to get. Defaults to null, filled in with the default priority, if left blank.

      Returns

      all items at priority in index order, null if there are no items at that priority

      Remarks

      Gets all the items at a specific priority.

      access

      public

      [ Top ]

      TPriorityMap::mergeWith

      mergeWith( mixed $data );

      Overrides TMap::mergeWith() (Merges iterable data into the map.)

      Parameters

      $data

      the data to be merged with, must be an array, object implementing Traversable, or a TPriorityMap

      Remarks

      Merges iterable data into the map.

      Existing data in the map will be kept and overwritten if the keys are the same.

      throws

      TInvalidDataTypeException If data is neither an array nor an iterator.

      access

      public

      [ Top ]

      TPriorityMap::offsetExists

      offsetExists( mixed $offset );

      Overrides TMap::offsetExists() (Returns whether there is an element at the specified offset.)

      Parameters

      $offset

      the offset to check on

      Remarks

      Returns whether there is an element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TPriorityMap::offsetGet

      offsetGet( integer $offset );

      Overrides TMap::offsetGet() (Returns the element at the specified offset.)

      Parameters

      $offset

      the offset to retrieve element.

      Returns

      the element at the offset, null if no element is found at the offset

      Remarks

      Returns the element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TPriorityMap::offsetSet

      offsetSet( integer $offset, mixed $item );

      Overrides TMap::offsetSet() (Sets the element at the specified offset.)

      Parameters

      $offset

      the offset to set element

      $item

      the element value

      Remarks

      Sets the element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TPriorityMap::offsetUnset

      offsetUnset( mixed $offset );

      Overrides TMap::offsetUnset() (Unsets the element at the specified offset.)

      Parameters

      $offset

      the offset to unset element

      Remarks

      Unsets the element at the specified offset.

      This method is required by the interface ArrayAccess.

      access

      public

      [ Top ]

      TPriorityMap::priorityAt

      priorityAt( integer $key );

      Parameters

      $key

      index of the item within the map

      Returns

      priority of the item in the map

      Remarks

      Retutrns the priority of an item at a particular flattened index.

      access

      public

      [ Top ]

      TPriorityMap::priorityOf

      priorityOf( mixed $item );

      Parameters

      $item

      item to look for within the map

      Returns

      priority of the item in the map

      Remarks

      Returns the priority of a particular item within the map. This searches the map for the item.

      access

      public

      [ Top ]

      TPriorityMap::remove

      remove( mixed $key, [numeric|false|null $priority = false] );

      Overrides TMap::remove() (Removes an item from the map by its key.)

      Parameters

      $key

      the key of the item to be removed

      $priority

      priority. False is any priority, null is the default priority, and numeric is a specific priority

      Returns

      the removed value, null if no such key exists.

      Remarks

      Removes an item from the map by its key. If no priority, or false, is specified

      then priority is irrelevant. If null is used as a parameter for priority, then the priority will be the default priority. If a priority is specified, or the default priority is specified, only key-value pairs in that priority will be affected.

      throws

      TInvalidOperationException if the map is read-only

      access

      public

      [ Top ]

      TPriorityMap::setDefaultPriority

      setDefaultPriority( numeric $value );

      Parameters

      $value

      sets the default priority of inserted items without a specified priority

      Remarks

      This must be called internally or when instantiated.

      access

      protected

      [ Top ]

      TPriorityMap::setPrecision

      setPrecision( integer $value );

      Parameters

      $value

      The precision of numeric priorities.

      Remarks

      This must be called internally or when instantiated.

      access

      protected

      [ Top ]

      TPriorityMap::setPriorityAt

      setPriorityAt( mixed $key, [numeric|null $priority = null] );

      Parameters

      $key

      the key

      $priority

      the priority. default: null, filled in with the default priority numeric.

      Returns

      old priority of the item

      Remarks

      This changes an item's priority. Specify the item and the new priority.

      This method is exactly the same as offsetGet.

      access

      public

      [ Top ]

      TPriorityMap::setReadOnly

      setReadOnly( boolean $value );

      Overrides TMap::setReadOnly() (parent method not documented)

      Parameters

      $value

      whether this list is read-only or not

      access

      protected

      [ Top ]

      TPriorityMap::sortPriorities

      sortPriorities( );

      Remarks

      Orders the priority list internally.

      access

      protected

      [ Top ]

      TPriorityMap::toArray

      toArray( );

      Overrides TMap::toArray() (parent method not documented)

      Returns

      the list of items in array

      Remarks

      When the map is flattened into an array, the priorities are taken into account and elements of the map are ordered in the array according to their priority.

      access

      public

      [ Top ]

      TPriorityMap::toArrayAbovePriority

      toArrayAbovePriority( numeric $priority, [boolean $inclusive = true] );

      Parameters

      $priority

      the cut-off priority. All items of priority greater than this are returned.

      $inclusive

      whether or not the input cut-off priority is inclusive. Default: true, inclusive.

      Returns

      the array of priorities keys with values of arrays of items that are above a specified priority. The priorities are sorted so important priorities, lower numerics, are first.

      Remarks

      Combines the map elements which have a priority above the parameter value

      access

      public

      [ Top ]

      TPriorityMap::toArrayBelowPriority

      toArrayBelowPriority( numeric $priority, [boolean $inclusive = false] );

      Parameters

      $priority

      the cut-off priority. All items of priority less than this are returned.

      $inclusive

      whether or not the input cut-off priority is inclusive. Default: false, not inclusive.

      Returns

      the array of priorities keys with values of arrays of items that are below a specified priority. The priorities are sorted so important priorities, lower numerics, are first.

      Remarks

      Combines the map elements which have a priority below the parameter value

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:04 +0200 by phpDocumentor 1.4.3


Docs For Class TQueue

Class TQueue

[line 35]
TComponent
   |
   --TQueue
Location: /Collections/TQueue.php

Remarks

TQueue class

TQueue implements a queue.

The typical queue operations are implemented, which include enqueue(), dequeue() and peek(). In addition, contains() can be used to check if an item is contained in the queue. To obtain the number of the items in the queue, check the Count property.

Items in the queue may be traversed using foreach as follows,

  •  foreach($queue as $item) ...
    •

    author

    Knut Urdalen <knut.urdalen@gmail.com>

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id$

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TQueue::__construct

      __construct( [array|Iterator $data = null] );

      Parameters

      $data

      the intial data. Default is null, meaning no initialization.

      Remarks

      Constructor.

      Initializes the queue with an array or an iterable object.

      throws

      TInvalidDataTypeException If data is not null and neither an array nor an iterator.

      access

      public

      [ Top ]

      TQueue::clear

      clear( );

      Remarks

      Removes all items in the queue.

      access

      public

      [ Top ]

      TQueue::contains

      contains( mixed $item );

      Parameters

      $item

      the item

      Returns

      whether the queue contains the item

      access

      public

      [ Top ]

      TQueue::copyFrom

      copyFrom( mixed $data );

      Parameters

      $data

      the data to be copied from, must be an array or object implementing Traversable

      Remarks

      Copies iterable data into the queue.

      Note, existing data in the list will be cleared first.

      throws

      TInvalidDataTypeException If data is neither an array nor a Traversable.

      access

      public

      [ Top ]

      TQueue::count

      count( );

      Implementation of:
      Countable::count

      Returns

      number of items in the queue.

      Remarks

      Returns the number of items in the queue.

      This method is required by Countable interface.

      access

      public

      [ Top ]

      TQueue::dequeue

      dequeue( );

      Returns

      the item at the beginning of the queue

      Remarks

      Removes and returns the object at the beginning of the queue.

      throws

      TInvalidOperationException if the queue is empty

      access

      public

      [ Top ]

      TQueue::enqueue

      enqueue( mixed $item );

      Parameters

      $item

      the item to be appended into the queue

      Remarks

      Adds an object to the end of the queue.

      access

      public

      [ Top ]

      TQueue::getCount

      getCount( );

      Returns

      the number of items in the queue

      access

      public

      [ Top ]

      TQueue::getIterator

      getIterator( );

      Implementation of:
      IteratorAggregate::getIterator

      Returns

      an iterator for traversing the items in the queue.

      Remarks

      Returns an iterator for traversing the items in the queue.

      This method is required by the interface IteratorAggregate.

      access

      public

      [ Top ]

      TQueue::peek

      peek( );

      Returns

      item at the top of the queue

      Remarks

      Returns the first item at the front of the queue.

      Unlike dequeue(), this method does not remove the item from the queue.

      throws

      TInvalidOperationException if the queue is empty

      access

      public

      [ Top ]

      TQueue::toArray

      toArray( );

      Returns

      the list of items in queue

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:05 +0200 by phpDocumentor 1.4.3


Docs For Class TQueueIterator

Class TQueueIterator

[line 189]

Location: /Collections/TQueue.php

Remarks

TQueueIterator class

TQueueIterator implements Iterator interface.
TQueueIterator is used by TQueue. It allows TQueue to return a new iterator  for traversing the items in the queue.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id$

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TQueueIterator::__construct

__construct(
array
&$data );

    Parameters

    &$data

    the data to be iterated through

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TQueueIterator::current

current(
 );

    Implementation of:

    Iterator::current

    Returns

    the current array item

    Remarks

    Returns the current array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TQueueIterator::key

key(
 );

    Implementation of:

    Iterator::key

    Returns

    the key of the current array item

    Remarks

    Returns the key of the current array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TQueueIterator::next

next(
 );

    Implementation of:

    Iterator::next

    Remarks

    Moves the internal pointer to the next array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TQueueIterator::rewind

rewind(
 );

    Implementation of:

    Iterator::rewind

    Remarks

    Rewinds internal array pointer.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TQueueIterator::valid

valid(
 );

    Implementation of:

    Iterator::valid

    Remarks

    Returns whether there is an item at current position.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:05 +0200 by phpDocumentor 1.4.3


Docs For Class TStack

Class TStack

[line 34]
TComponent
   |
   --TStack
Location: /Collections/TStack.php

Remarks

TStack class

TStack implements a stack.

The typical stack operations are implemented, which include push(), pop() and peek(). In addition, contains() can be used to check if an item is contained in the stack. To obtain the number of the items in the stack, check the Count property.

Items in the stack may be traversed using foreach as follows,

  •  foreach($stack as $item) ...
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TStack.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TStack::__construct

      __construct( [array|Iterator $data = null] );

      Parameters

      $data

      the initial data. Default is null, meaning no initialization.

      Remarks

      Constructor.

      Initializes the stack with an array or an iterable object.

      throws

      TInvalidDataTypeException If data is not null and neither an array nor an iterator.

      access

      public

      [ Top ]

      TStack::clear

      clear( );

      Remarks

      Removes all items in the stack.

      access

      public

      [ Top ]

      TStack::contains

      contains( mixed $item );

      Parameters

      $item

      the item

      Returns

      whether the stack contains the item

      access

      public

      [ Top ]

      TStack::copyFrom

      copyFrom( mixed $data );

      Parameters

      $data

      the data to be copied from, must be an array or object implementing Traversable

      Remarks

      Copies iterable data into the stack.

      Note, existing data in the list will be cleared first.

      throws

      TInvalidDataTypeException If data is neither an array nor a Traversable.

      access

      public

      [ Top ]

      TStack::count

      count( );

      Implementation of:
      Countable::count

      Returns

      number of items in the stack.

      Remarks

      Returns the number of items in the stack.

      This method is required by Countable interface.

      access

      public

      [ Top ]

      TStack::getCount

      getCount( );

      Returns

      the number of items in the stack

      access

      public

      [ Top ]

      TStack::getIterator

      getIterator( );

      Implementation of:
      IteratorAggregate::getIterator

      Returns

      an iterator for traversing the items in the stack.

      Remarks

      Returns an iterator for traversing the items in the stack.

      This method is required by the interface IteratorAggregate.

      access

      public

      [ Top ]

      TStack::peek

      peek( );

      Returns

      item at the top of the stack

      Remarks

      Returns the item at the top of the stack.

      Unlike pop(), this method does not remove the item from the stack.

      throws

      TInvalidOperationException if the stack is empty

      access

      public

      [ Top ]

      TStack::pop

      pop( );

      Returns

      the item at the top of the stack

      Remarks

      Pops up the item at the top of the stack.

      throws

      TInvalidOperationException if the stack is empty

      access

      public

      [ Top ]

      TStack::push

      push( mixed $item );

      Parameters

      $item

      the item to be pushed into the stack

      Remarks

      Pushes an item into the stack.

      access

      public

      [ Top ]

      TStack::toArray

      toArray( );

      Returns

      the list of items in stack

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:28 +0200 by phpDocumentor 1.4.3


Docs For Class TStackIterator

Class TStackIterator

[line 189]

Location: /Collections/TStack.php

Remarks

TStackIterator class

TStackIterator implements Iterator interface.
TStackIterator is used by TStack. It allows TStack to return a new iterator  for traversing the items in the list.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TStack.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

deprecated

Issue 264 : ArrayIterator should be used instead

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TStackIterator::__construct

__construct(
array
&$data );

    Parameters

    &$data

    the data to be iterated through

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TStackIterator::current

current(
 );

    Implementation of:

    Iterator::current

    Returns

    the current array item

    Remarks

    Returns the current array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TStackIterator::key

key(
 );

    Implementation of:

    Iterator::key

    Returns

    the key of the current array item

    Remarks

    Returns the key of the current array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TStackIterator::next

next(
 );

    Implementation of:

    Iterator::next

    Remarks

    Moves the internal pointer to the next array item.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TStackIterator::rewind

rewind(
 );

    Implementation of:

    Iterator::rewind

    Remarks

    Rewinds internal array pointer.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

    TStackIterator::valid

valid(
 );

    Implementation of:

    Iterator::valid

    Remarks

    Returns whether there is an item at current position.

    This method is required by the interface Iterator.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:28 +0200 by phpDocumentor 1.4.3


Package System.Web.UI Element Index

Element index for package System.Web.UI

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI.WebControls
System.Xml

Index of all elements
a b c d e f g h i l m o p q r s t u v w _
top
_
$_control | in file TControlAdapter.php, variable TControlAdapter::$_control
$_controlsPostDataChanged | in file TPage.php, variable TPage::$_controlsPostDataChanged
$_controlsRegisteredForPostData | in file TPage.php, variable TPage::$_controlsRegisteredForPostData
$_controlsRequiringPostData | in file TPage.php, variable TPage::$_controlsRequiringPostData
$_formRendered | in file TPage.php, variable TPage::$_formRendered
$_inFormRender | in file TPage.php, variable TPage::$_inFormRender
$_isLoadingPostData | in file TPage.php, variable TPage::$_isLoadingPostData
$_postData | in file TPage.php, variable TPage::$_postData
$_postDataLoaders | in file TPage.php, variable TPage::$_postDataLoaders
$_restPostData | in file TPage.php, variable TPage::$_restPostData
__construct in file TThemeManager.php, method TTheme::__construct()
Constructor.
__construct in file TPage.php, method TPage::__construct()
Constructor.
__construct in file TTemplateManager.php, method TTemplate::__construct()
Constructor.
__construct in file THtmlWriter.php, method THtmlWriter::__construct()
Constructor.
__construct in file TControl.php, method TCompositeLiteral::__construct()
Constructor.
__construct in file TControl.php, method TCommandEventParameter::__construct()
Constructor.
__construct in file TControl.php, method TBroadcastEventParameter::__construct()
Constructor.
__construct in file TControl.php, method TControl::__construct()
Constructor.
__construct in file TClientScriptManager.php, method TClientScriptManager::__construct()
Constructor.
__construct in file TControlAdapter.php, method TControlAdapter::__construct()
Constructor.
__construct in file TControl.php, method TEmptyControlCollection::__construct()
Constructor.
__construct in file TControl.php, method TControlCollection::__construct()
Constructor.
__construct in file TClientScriptManager.php, method TClientSideOptions::__construct()
Constructor, initialize the options list.
__get in file TControl.php, method TControl::__get()
Returns a property value by name or a control by ID.
top
a
addAttribute in file THtmlWriter.php, method THtmlWriter::addAttribute()
Adds an attribute to be rendered.
addAttributes in file THtmlWriter.php, method THtmlWriter::addAttributes()
Adds a list of attributes to be rendered.
addAttributesToRender in file TForm.php, method TForm::addAttributesToRender()
Adds form specific attributes to renderer.
addedControl in file TControl.php, method TControl::addedControl()
Adds a control into the child collection of the control.
addParsedObject in file TTextProcessor.php, method TTextProcessor::addParsedObject()
HTML-decodes static text.
addParsedObject in file THead.php, method THead::addParsedObject()
Processes an object that is created during parsing template.
addParsedObject in file TControl.php, method TControl::addParsedObject()
Adds the object instantiated on a template to the child control collection.
addStyleAttribute in file THtmlWriter.php, method THtmlWriter::addStyleAttribute()
Adds a stylesheet attribute to be rendered
addStyleAttributes in file THtmlWriter.php, method THtmlWriter::addStyleAttributes()
Adds a list of stylesheet attributes to be rendered.
addToPostDataLoader in file TControl.php, method TControl::addToPostDataLoader()
Add controls implementing IPostBackDataHandler to post data loaders.
applyControlSkin in file TPage.php, method TPage::applyControlSkin()
Applies a skin in the current theme to a control.
applyControlStyleSheet in file TPage.php, method TPage::applyControlStyleSheet()
Applies a stylesheet skin in the current theme to a control.
applySkin in file TControl.php, method ITheme::applySkin()
Applies this theme to the specified control.
applySkin in file TThemeManager.php, method TTheme::applySkin()
Applies the theme to a particular control.
applyStyleSheetSkin in file TControl.php, method TControl::applyStyleSheetSkin()
Applies a stylesheet skin to a control.
autoBindProperty in file TControl.php, method TControl::autoBindProperty()
Sets up the binding between a property (or property path) and an expression.
autoDataBindProperties in file TControl.php, method TControl::autoDataBindProperties()
Auto databinding properties of the control.
AUTOMATIC_ID_PREFIX in file TControl.php, class constant TControl::AUTOMATIC_ID_PREFIX
prefix to an ID automatically generated
top
b
beginFormRender | in file TPage.php, method TPage::beginFormRender()
bindProperty in file TControl.php, method TControl::bindProperty()
Sets up the binding between a property (or property path) and an expression.
broadcastEvent in file TControl.php, method TControl::broadcastEvent()
Broadcasts an event.
broadcastEventReceived in file TControl.php, method IBroadcastEventReceiver::broadcastEventReceived()
Handles broadcast event.
bubbleEvent in file TControl.php, method TControl::bubbleEvent()
This method responds to a bubbled event.
top
c
calculateKey | in file TCachePageStatePersister.php, method TCachePageStatePersister::calculateKey()
checkIfNotInRender in file TClientScriptManager.php, method TClientScriptManager::checkIfNotInRender()
Checks whether page rendering has not begun yet
clear in file TControl.php, method TControlCollection::clear()
Overrides the parent implementation by invoking TControl::clearNamingContainer
clearChildState in file TControl.php, method TControl::clearChildState()
Clears up the child state data.
clearControlState in file TControl.php, method TControl::clearControlState()
Clears a controlstate value.
clearNamingContainer in file TControl.php, method TControl::clearNamingContainer()
Resets the control as a naming container.
clearViewState in file TControl.php, method TControl::clearViewState()
Clears a viewstate value.
CLIENT_ID_SEPARATOR in file TControl.php, class constant TControl::CLIENT_ID_SEPARATOR
separator char between IDs in a ClientID
configureComponent in file TTemplateManager.php, method TTemplate::configureComponent()
Configures a property of a non-control component.
configureControl in file TTemplateManager.php, method TTemplate::configureControl()
Configures a property/event of a control.
configureEvent in file TTemplateManager.php, method TTemplate::configureEvent()
Configures an event for a control.
configureProperty in file TTemplateManager.php, method TTemplate::configureProperty()
Configures a simple property for a component.
configureSubProperty in file TTemplateManager.php, method TTemplate::configureSubProperty()
Configures a subproperty for a component.
CONFIG_ASSET | in file TTemplateManager.php, class constant TTemplate::CONFIG_ASSET
CONFIG_DATABIND in file TTemplateManager.php, class constant TTemplate::CONFIG_DATABIND
Different configurations of component property/event/attribute
CONFIG_EXPRESSION | in file TTemplateManager.php, class constant TTemplate::CONFIG_EXPRESSION
CONFIG_LOCALIZATION | in file TTemplateManager.php, class constant TTemplate::CONFIG_LOCALIZATION
CONFIG_PARAMETER | in file TTemplateManager.php, class constant TTemplate::CONFIG_PARAMETER
CONFIG_TEMPLATE | in file TTemplateManager.php, class constant TTemplate::CONFIG_TEMPLATE
convertUniqueIdToClientId in file TControl.php, method TControl::convertUniqueIdToClientId()
Converts a unique ID to a client ID.
createChildControls in file TTemplateControl.php, method TTemplateControl::createChildControls()
Creates child controls.
createChildControls in file TControl.php, method TControl::createChildControls()
Creates child controls.
createChildControls in file TTemplateControlInheritable.php, method TTemplateControlInheritable::createChildControls()
Creates child controls.
createChildControls in file TControlAdapter.php, method TControlAdapter::createChildControls()
Creates child controls for the attached control.
createControlCollection in file TControl.php, method TControl::createControlCollection()
Creates a control collection object that is to be used to hold child controls
CS_CHILD_INITIALIZED | in file TControl.php, class constant TControl::CS_CHILD_INITIALIZED
CS_CONSTRUCTED in file TControl.php, class constant TControl::CS_CONSTRUCTED
the stage of lifecycles that the control is currently at
CS_INITIALIZED | in file TControl.php, class constant TControl::CS_INITIALIZED
CS_LOADED | in file TControl.php, class constant TControl::CS_LOADED
CS_PRERENDERED | in file TControl.php, class constant TControl::CS_PRERENDERED
CS_STATE_LOADED | in file TControl.php, class constant TControl::CS_STATE_LOADED
top
d
dataBind in file TControl.php, method TCompositeLiteral::dataBind()
Performs databindings.
dataBind in file TControl.php, method TControl::dataBind()
Performs the databinding for this control.
dataBindChildren in file TControl.php, method TControl::dataBindChildren()
Databinding child controls.
dataBindProperties in file TControl.php, method TControl::dataBindProperties()
Databinding properties of the control.
decodeUTF8 | in file TPage.php, method TPage::decodeUTF8()
DEFAULT_BASEPATH in file TThemeManager.php, class constant TThemeManager::DEFAULT_BASEPATH
default themes base path
DEFAULT_THEMECLASS in file TThemeManager.php, class constant TThemeManager::DEFAULT_THEMECLASS
default theme class
doCreateChildControlsFor in file TTemplateControlInheritable.php, method TTemplateControlInheritable::doCreateChildControlsFor()
This method creates the cild controls for the given class
doTemplateForClass in file TTemplateControlInheritable.php, method TTemplateControlInheritable::doTemplateForClass()
This method creates the template object for the given class
top
e
endFormRender | in file TPage.php, method TPage::endFormRender()
ensureChildControls in file TControl.php, method TControl::ensureChildControls()
Ensures child controls are created.
ensureFunction in file TClientScriptManager.php, method TClientSideOptions::ensureFunction()
Ensure that the javascript statements are wrapped in a javascript function block as
  • function(sender, parameter){ //code }
    •
    .
    ensureRenderInForm in file TPage.php, method TPage::ensureRenderInForm()
    Ensures the control is rendered within a form.
    evaluateDynamicContent in file TControl.php, method TCompositeLiteral::evaluateDynamicContent()
    Evaluates the expressions and/or statements in the component.
    EXT_TEMPLATE in file TTemplateControl.php, class constant TTemplateControl::EXT_TEMPLATE
    template file extension.
    top
    f
    FIELD_CALLBACK_PARAMETER | in file TPage.php, class constant TPage::FIELD_CALLBACK_PARAMETER
    FIELD_CALLBACK_TARGET | in file TPage.php, class constant TPage::FIELD_CALLBACK_TARGET
    FIELD_LASTFOCUS | in file TPage.php, class constant TPage::FIELD_LASTFOCUS
    FIELD_PAGESTATE | in file TPage.php, class constant TPage::FIELD_PAGESTATE
    FIELD_POSTBACK_PARAMETER | in file TPage.php, class constant TPage::FIELD_POSTBACK_PARAMETER
    FIELD_POSTBACK_TARGET in file TPage.php, class constant TPage::FIELD_POSTBACK_TARGET
    system post fields
    findControl in file TControl.php, method TControl::findControl()
    Finds a control by ID path within the current naming container.
    findControlsByID in file TControl.php, method TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
    findControlsByType in file TControl.php, method TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
    flush in file THtmlWriter.php, method THtmlWriter::flush()
    Flushes the rendering result.
    flushScriptFiles in file TClientScriptManager.php, method TClientScriptManager::flushScriptFiles()
    Flushes all pending script registrations
    flushWriter in file TPage.php, method TPage::flushWriter()
    Flushes output
    focus in file TControl.php, method TControl::focus()
    Sets input focus to this control.
    top
    g
    getAdapter | in file TControl.php, method TControl::getAdapter()
    getAllowChildControls | in file TControl.php, method TControl::getAllowChildControls()
    getAttribute | in file TControl.php, method TControl::getAttribute()
    getAttributes in file TControl.php, method TControl::getAttributes()
    Returns the list of custom attributes.
    getAvailableThemes | in file TThemeManager.php, method TThemeManager::getAvailableThemes()
    getBasePath | in file TThemeManager.php, method TTheme::getBasePath()
    getBasePath | in file TThemeManager.php, method TThemeManager::getBasePath()
    getBaseUrl | in file THead.php, method THead::getBaseUrl()
    getBaseUrl | in file TThemeManager.php, method TTheme::getBaseUrl()
    getBaseUrl | in file TThemeManager.php, method TThemeManager::getBaseUrl()
    getCache | in file TCachePageStatePersister.php, method TCachePageStatePersister::getCache()
    getCacheModuleID | in file TCachePageStatePersister.php, method TCachePageStatePersister::getCacheModuleID()
    getCacheTimeout | in file TCachePageStatePersister.php, method TCachePageStatePersister::getCacheTimeout()
    getCachingStack | in file TPage.php, method TPage::getCachingStack()
    getCallbackClient in file TPage.php, method TPage::getCallbackClient()
    Gets the callback client script handler that allows javascript functions to be executed during the callback response.
    getCallbackEventParameter in file TPage.php, method TPage::getCallbackEventParameter()
    Callback parameter is decoded assuming JSON encoding.
    getCallbackEventTarget | in file TPage.php, method TPage::getCallbackEventTarget()
    getCallbackReference in file TClientScriptManager.php, method TClientScriptManager::getCallbackReference()
    Returns javascript statement that create a new callback request object.
    getCausesValidation | in file TControl.php, method IButtonControl::getCausesValidation()
    getChildControlsCreated | in file TControl.php, method TControl::getChildControlsCreated()
    getClientID in file TControl.php, method TControl::getClientID()
    Returns the client ID of the control.
    getClientScript | in file TPage.php, method TPage::getClientScript()
    getClientState in file TPage.php, method TPage::getClientState()
    Returns the state to be stored on the client side.
    getClientSupportsJavaScript | in file TPage.php, method TPage::getClientSupportsJavaScript()
    getCommandName | in file TControl.php, method TCommandEventParameter::getCommandName()
    getCommandName | in file TControl.php, method IButtonControl::getCommandName()
    getCommandParameter | in file TControl.php, method IButtonControl::getCommandParameter()
    getCommandParameter | in file TControl.php, method TCommandEventParameter::getCommandParameter()
    getContainer | in file TControl.php, method TCompositeLiteral::getContainer()
    getContextPath | in file TTemplateManager.php, method TTemplate::getContextPath()
    getControl | in file TControlAdapter.php, method TControlAdapter::getControl()
    getControls | in file TControl.php, method TControl::getControls()
    getControlStage in file TControl.php, method TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
    getControlState in file TControl.php, method TControl::getControlState()
    Returns a controlstate value.
    getCustomData in file TControl.php, method TControl::getCustomData()
    Returns custom data associated with this control.
    getDataChanged | in file TControl.php, method IPostBackDataHandler::getDataChanged()
    getDefaultButton | in file TForm.php, method TForm::getDefaultButton()
    getDefaultButtonOptions | in file TClientScriptManager.php, method TClientScriptManager::getDefaultButtonOptions()
    getDirective | in file TTemplateManager.php, method TTemplate::getDirective()
    getEnabled in file TControl.php, method TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
    getEnableStateCompression | in file TPage.php, method TPage::getEnableStateCompression()
    getEnableStateEncryption | in file TPage.php, method TPage::getEnableStateEncryption()
    getEnableStateValidation | in file TPage.php, method TPage::getEnableStateValidation()
    getEnableTheming | in file TControl.php, method TControl::getEnableTheming()
    getEnableViewState | in file TControl.php, method TControl::getEnableViewState()
    getEnctype | in file TForm.php, method TForm::getEnctype()
    getErrorMessage | in file TControl.php, method IValidator::getErrorMessage()
    getForm | in file TPage.php, method TPage::getForm()
    getHasAdapter | in file TControl.php, method TControl::getHasAdapter()
    getHasAttributes | in file TControl.php, method TControl::getHasAttributes()
    getHasChildInitialized | in file TControl.php, method TControl::getHasChildInitialized()
    getHasControls | in file TControl.php, method TControl::getHasControls()
    getHashCode | in file TTemplateManager.php, method TTemplate::getHashCode()
    getHasInitialized | in file TControl.php, method TControl::getHasInitialized()
    getHasLoaded | in file TControl.php, method TControl::getHasLoaded()
    getHasLoadedPostData | in file TControl.php, method TControl::getHasLoadedPostData()
    getHasPreRendered | in file TControl.php, method TControl::getHasPreRendered()
    getHead | in file TPage.php, method TPage::getHead()
    getHiddenFields | in file TClientScriptManager.php, method TClientScriptManager::getHiddenFields()
    getHistorySize | in file TSessionPageStatePersister.php, method TSessionPageStatePersister::getHistorySize()
    getID in file TControl.php, method TControl::getID()
    Returns the id of the control.
    getIncludedFiles | in file TTemplateManager.php, method TTemplate::getIncludedFiles()
    getInFormRender | in file TPage.php, method TPage::getInFormRender()
    getIsCallback | in file TPage.php, method TPage::getIsCallback()
    getIsDefaultButton | in file TControl.php, method IButtonControl::getIsDefaultButton()
    getIsLoadingPostData | in file TPage.php, method TPage::getIsLoadingPostData()
    getIsPostBack | in file TPage.php, method TPage::getIsPostBack()
    getIsSkinApplied | in file TControl.php, method TControl::getIsSkinApplied()
    getIsSourceTemplate | in file TTemplateManager.php, method TTemplate::getIsSourceTemplate()
    getIsSourceTemplateControl in file TTemplateControlInheritable.php, method TTemplateControlInheritable::getIsSourceTemplateControl()
    A source template control loads its template from external storage, such as file, db, rather than from within another template.
    getIsSourceTemplateControl | in file TTemplateControl.php, method TTemplateControl::getIsSourceTemplateControl()
    getIsValid | in file TControl.php, method IValidatable::getIsValid()
    getIsValid in file TPage.php, method TPage::getIsValid()
    Returns whether user input is valid or not.
    getIsValid | in file TControl.php, method IValidator::getIsValid()
    getItems | in file TTemplateManager.php, method TTemplate::getItems()
    getJavaScriptFiles | in file TThemeManager.php, method TTheme::getJavaScriptFiles()
    getKeyPrefix | in file TCachePageStatePersister.php, method TCachePageStatePersister::getKeyPrefix()
    getLocalizedTemplate in file TTemplateManager.php, method TTemplateManager::getLocalizedTemplate()
    Finds a localized template file.
    getMaster | in file TTemplateControl.php, method TTemplateControl::getMaster()
    getMasterClass | in file TTemplateControl.php, method TTemplateControl::getMasterClass()
    getMetaTags | in file THead.php, method THead::getMetaTags()
    getMethod | in file TForm.php, method TForm::getMethod()
    getName | in file TForm.php, method TForm::getName()
    getName | in file TThemeManager.php, method TTheme::getName()
    getName | in file TControl.php, method TBroadcastEventParameter::getName()
    getNamingContainer | in file TControl.php, method TControl::getNamingContainer()
    getOption | in file TClientScriptManager.php, method TClientSideOptions::getOption()
    getOptions | in file TClientScriptManager.php, method TClientSideOptions::getOptions()
    getOwner | in file TControl.php, method TControlCollection::getOwner()
    getPackagePathUrl | in file TClientScriptManager.php, method TClientScriptManager::getPackagePathUrl()
    getPage | in file TPageStatePersister.php, method TPageStatePersister::getPage()
    getPage | in file TControl.php, method TControl::getPage()
    getPage | in file TSessionPageStatePersister.php, method TSessionPageStatePersister::getPage()
    getPage | in file TControlAdapter.php, method TControlAdapter::getPage()
    getPage | in file TCachePageStatePersister.php, method TCachePageStatePersister::getPage()
    getPage | in file TPage.php, method IPageStatePersister::getPage()
    getPagePath | in file TPage.php, method TPage::getPagePath()
    getParameter | in file TControl.php, method TBroadcastEventParameter::getParameter()
    getParent | in file TControl.php, method TControl::getParent()
    getPostBackEventParameter | in file TPage.php, method TPage::getPostBackEventParameter()
    getPostBackEventTarget | in file TPage.php, method TPage::getPostBackEventTarget()
    getPostDataLoaders in file TPage.php, method TPage::getPostDataLoaders()
    Get a list of IDs of controls that are enabled and require post data.
    getPradoPackages | in file TClientScriptManager.php, method TClientScriptManager::getPradoPackages()
    getPradoScriptAssetUrl | in file TClientScriptManager.php, method TClientScriptManager::getPradoScriptAssetUrl()
    getPradoScripts | in file TClientScriptManager.php, method TClientScriptManager::getPradoScripts()
    getRegisteredObject in file TControl.php, method TControl::getRegisteredObject()
    Returns the named registered object.
    getRenderedScriptFiles | in file TClientScriptManager.php, method TClientScriptManager::getRenderedScriptFiles()
    getRequestClientState | in file TPage.php, method TPage::getRequestClientState()
    getRequiresHead | in file TClientScriptManager.php, method TClientScriptManager::getRequiresHead()
    getScriptUrls in file TClientScriptManager.php, method TClientScriptManager::getScriptUrls()
    Returns the URLs of all script files referenced on the page
    getShortcutIcon | in file THead.php, method THead::getShortcutIcon()
    getSkinID | in file TControl.php, method TControl::getSkinID()
    getSkins | in file TThemeManager.php, method TTheme::getSkins()
    getSourceTemplateControl | in file TControl.php, method TControl::getSourceTemplateControl()
    getStatePersister | in file TPage.php, method TPage::getStatePersister()
    getStatePersisterClass | in file TPage.php, method TPage::getStatePersisterClass()
    getStyleSheetFiles | in file TThemeManager.php, method TTheme::getStyleSheetFiles()
    getStyleSheetTheme | in file TPage.php, method TPage::getStyleSheetTheme()
    getStyleSheetUrls in file TClientScriptManager.php, method TClientScriptManager::getStyleSheetUrls()
    Returns the URLs of all stylesheet files referenced on the page
    getSurroundingTagID | in file TControl.php, method ISurroundable::getSurroundingTagID()
    getTemplate in file TTemplateControl.php, method TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
    getTemplateByClassName in file TTemplateManager.php, method TTemplateManager::getTemplateByClassName()
    Loads the template corresponding to the specified class name.
    getTemplateByFileName in file TTemplateManager.php, method TTemplateManager::getTemplateByFileName()
    Loads the template from the specified file.
    getTemplateControl | in file TControl.php, method TControl::getTemplateControl()
    getTemplateDirectory | in file TTemplateControl.php, method TTemplateControl::getTemplateDirectory()
    getTemplateFile | in file TTemplateManager.php, method TTemplate::getTemplateFile()
    getText | in file TControl.php, method IButtonControl::getText()
    getText | in file TTextProcessor.php, method TTextProcessor::getText()
    getTheme | in file TPage.php, method TPage::getTheme()
    getTheme | in file TThemeManager.php, method TThemeManager::getTheme()
    getThemeClass | in file TThemeManager.php, method TThemeManager::getThemeClass()
    getTitle | in file TPage.php, method TPage::getTitle()
    getTitle | in file THead.php, method THead::getTitle()
    getUniqueID in file TControl.php, method TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
    getValidationGroup | in file TControl.php, method IButtonControl::getValidationGroup()
    getValidationPropertyValue | in file TControl.php, method IValidatable::getValidationPropertyValue()
    getValidators in file TPage.php, method TPage::getValidators()
    Returns a list of registered validators.
    getViewState in file TControl.php, method TControl::getViewState()
    Returns a viewstate value.
    getVisible in file TControl.php, method TControl::getVisible()
    Checks if a control is visible.
    getWriter | in file THtmlWriter.php, method THtmlWriter::getWriter()
    top
    h
    handleException in file TTemplateManager.php, method TTemplate::handleException()
    Handles template parsing exception.
    hasAttribute | in file TControl.php, method TControl::hasAttribute()
    hasBeginScripts | in file TClientScriptManager.php, method TClientScriptManager::hasBeginScripts()
    hasEndScripts | in file TClientScriptManager.php, method TClientScriptManager::hasEndScripts()
    top
    i
    IBroadcastEventReceiver in file TControl.php, class IBroadcastEventReceiver
    IBroadcastEventReceiver interface
    IButtonControl in file TControl.php, class IButtonControl
    IButtonControl interface
    ID_FORMAT in file TControl.php, class constant TControl::ID_FORMAT
    format of control ID
    ID_SEPARATOR in file TControl.php, class constant TControl::ID_SEPARATOR
    separator char between IDs in a UniqueID
    INamingContainer in file TControl.php, class INamingContainer
    INamingContainer interface.
    init in file TTemplateManager.php, method TTemplateManager::init()
    Initializes the module.
    init in file TThemeManager.php, method TThemeManager::init()
    Initializes the module.
    initRecursive in file TTemplateControl.php, method TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
    initRecursive in file TControl.php, method TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
    initRecursive in file TCompositeControl.php, method TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
    injectContent in file TTemplateControl.php, method TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
    insertAt in file TControl.php, method TEmptyControlCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TControl.php, method TControlCollection::insertAt()
    Inserts an item at the specified position.
    instantiateIn in file TTemplateManager.php, method TTemplate::instantiateIn()
    Instantiates the template.
    instantiateIn in file TControl.php, method ITemplate::instantiateIn()
    Instantiates the template.
    IPageStatePersister in file TPage.php, class IPageStatePersister
    IPageStatePersister interface.
    IPostBackDataHandler in file TControl.php, class IPostBackDataHandler
    IPostBackDataHandler interface
    IPostBackEventHandler in file TControl.php, class IPostBackEventHandler
    IPostBackEventHandler interface
    isBeginScriptRegistered | in file TClientScriptManager.php, method TClientScriptManager::isBeginScriptRegistered()
    isDescendentOf | in file TControl.php, method TControl::isDescendentOf()
    isEndScriptRegistered | in file TClientScriptManager.php, method TClientScriptManager::isEndScriptRegistered()
    isHeadScriptFileRegistered | in file TClientScriptManager.php, method TClientScriptManager::isHeadScriptFileRegistered()
    isHeadScriptRegistered | in file TClientScriptManager.php, method TClientScriptManager::isHeadScriptRegistered()
    isHiddenFieldRegistered | in file TClientScriptManager.php, method TClientScriptManager::isHiddenFieldRegistered()
    isObjectRegistered | in file TControl.php, method TControl::isObjectRegistered()
    isScriptFileRegistered | in file TClientScriptManager.php, method TClientScriptManager::isScriptFileRegistered()
    isStyleSheetFileRegistered | in file TClientScriptManager.php, method TClientScriptManager::isStyleSheetFileRegistered()
    isStyleSheetRegistered | in file TClientScriptManager.php, method TClientScriptManager::isStyleSheetRegistered()
    isSystemPostField | in file TPage.php, method TPage::isSystemPostField()
    ISurroundable in file TControl.php, class ISurroundable
    ISurroundable interface
    IS_CHILD_CREATED | in file TControl.php, class constant TControl::IS_CHILD_CREATED
    IS_CREATING_CHILD | in file TControl.php, class constant TControl::IS_CREATING_CHILD
    IS_DISABLE_THEMING | in file TControl.php, class constant TControl::IS_DISABLE_THEMING
    IS_DISABLE_VIEWSTATE | in file TControl.php, class constant TControl::IS_DISABLE_VIEWSTATE
    IS_ID_SET in file TControl.php, class constant TControl::IS_ID_SET
    State bits.
    IS_SKIN_APPLIED | in file TControl.php, class constant TControl::IS_SKIN_APPLIED
    IS_STYLESHEET_APPLIED | in file TControl.php, class constant TControl::IS_STYLESHEET_APPLIED
    ITemplate in file TControl.php, class ITemplate
    ITemplate interface
    ITheme in file TControl.php, class ITheme
    ITheme interface.
    IValidatable in file TControl.php, class IValidatable
    IValidatable interface
    IValidator in file TControl.php, class IValidator
    IValidator interface
    top
    l
    load in file TCachePageStatePersister.php, method TCachePageStatePersister::load()
    Loads page state from cache.
    load in file TPage.php, method IPageStatePersister::load()
    Loads page state from persistent storage
    load in file TPageStatePersister.php, method TPageStatePersister::load()
    Loads page state from hidden fields.
    load in file TSessionPageStatePersister.php, method TSessionPageStatePersister::load()
    Loads page state from session.
    loadPageState in file TPage.php, method TPage::loadPageState()
    Loads page state from persistent storage.
    loadPostData in file TControl.php, method IPostBackDataHandler::loadPostData()
    Loads user input data.
    loadRecursive in file TControl.php, method TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
    loadState in file TPage.php, method TPage::loadState()
    This method is invoked right after the control has loaded its state.
    loadState in file TControlAdapter.php, method TControlAdapter::loadState()
    Loads additional persistent control state.
    loadState in file TControl.php, method TControl::loadState()
    This method is invoked right after the control has loaded its state.
    loadStateRecursive in file TControl.php, method TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
    loadTemplate in file TTemplateControl.php, method TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
    top
    m
    markScriptFileAsRendered | in file TClientScriptManager.php, method TClientScriptManager::markScriptFileAsRendered()
    top
    o
    onClick in file TControl.php, method IButtonControl::onClick()
    Raises OnClick event.
    onCommand in file TControl.php, method IButtonControl::onCommand()
    Raises OnCommand event.
    onDataBinding in file TControl.php, method TControl::onDataBinding()
    Raises 'OnDataBinding' event.
    onInit in file TControlAdapter.php, method TControlAdapter::onInit()
    This method is invoked when the control enters 'OnInit' stage.
    onInit in file TForm.php, method TForm::onInit()
    Registers the form with the page.
    onInit in file THead.php, method THead::onInit()
    Registers the head control with the current page.
    onInit in file TControl.php, method TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
    onInitComplete in file TPage.php, method TPage::onInitComplete()
    Raises OnInitComplete event.
    onLoad in file TControlAdapter.php, method TControlAdapter::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
    onLoad in file TControl.php, method TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
    onLoadComplete in file TPage.php, method TPage::onLoadComplete()
    Raises OnLoadComplete event.
    onPreInit in file TPage.php, method TPage::onPreInit()
    Raises OnPreInit event.
    onPreLoad in file TPage.php, method TPage::onPreLoad()
    Raises OnPreLoad event.
    onPreRender in file TControlAdapter.php, method TControlAdapter::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
    onPreRender in file TControl.php, method TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
    onPreRenderComplete in file TPage.php, method TPage::onPreRenderComplete()
    Raises OnPreRenderComplete event.
    onSaveStateComplete in file TPage.php, method TPage::onSaveStateComplete()
    Raises OnSaveStateComplete event.
    onUnload in file TControlAdapter.php, method TControlAdapter::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
    onUnload in file TControl.php, method TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
    top
    p
    PACKAGES_FILE in file TClientScriptManager.php, class constant TClientScriptManager::PACKAGES_FILE
    file containing javascript packages and their cross dependencies
    parse in file TTemplateManager.php, method TTemplate::parse()
    Parses a template string.
    parseAttribute in file TTemplateManager.php, method TTemplate::parseAttribute()
    Parses a single attribute.
    parseAttributes in file TTemplateManager.php, method TTemplate::parseAttributes()
    Parses the attributes of a tag from a string.
    parseTemplateProperty | in file TTemplateManager.php, method TTemplate::parseTemplateProperty()
    preprocess in file TTemplateManager.php, method TTemplate::preprocess()
    Preprocesses the template string by including external templates
    preRenderRecursive in file TControl.php, method TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
    processCallbackRequest in file TPage.php, method TPage::processCallbackRequest()
    Sets Adapter to TActivePageAdapter and calls apter to process the callback request.
    processNormalRequest | in file TPage.php, method TPage::processNormalRequest()
    processPostBackRequest | in file TPage.php, method TPage::processPostBackRequest()
    processPostData in file TPage.php, method TPage::processPostData()
    Processes post data.
    processText in file TTextProcessor.php, method TTextProcessor::processText()
    Processes a text string.
    top
    q
    QUEUE_SESSION_KEY | in file TSessionPageStatePersister.php, class constant TSessionPageStatePersister::QUEUE_SESSION_KEY
    top
    r
    raiseBubbleEvent in file TControl.php, method TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
    raiseChangedEvents in file TPage.php, method TPage::raiseChangedEvents()
    Raises OnPostDataChangedEvent for controls whose data have been changed due to the postback.
    raisePostBackEvent in file TControl.php, method IPostBackEventHandler::raisePostBackEvent()
    Raises postback event.
    raisePostBackEvent in file TPage.php, method TPage::raisePostBackEvent()
    Raises PostBack event.
    raisePostDataChangedEvent in file TControl.php, method IPostBackDataHandler::raisePostDataChangedEvent()
    Raises postdata changed event.
    REGEX_RULES in file TTemplateManager.php, class constant TTemplate::REGEX_RULES
    '<!--.*?--!>' - template comments
    registerBeginScript in file TClientScriptManager.php, method TClientScriptManager::registerBeginScript()
    Registers a javascript script block at the beginning of the form
    registerCachingAction in file TPage.php, method TPage::registerCachingAction()
    Registers an action associated with the content being cached.
    registerCallbackControl in file TClientScriptManager.php, method TClientScriptManager::registerCallbackControl()
    Registers callback javascript for a control.
    registerContent in file TTemplateControl.php, method TTemplateControl::registerContent()
    Registers a content control.
    registerContentPlaceHolder in file TTemplateControl.php, method TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
    registerDefaultButton in file TClientScriptManager.php, method TClientScriptManager::registerDefaultButton()
    Register a default button to panel. When the $panel is in focus and the 'enter' key is pressed, the $button will be clicked.
    registerEndScript in file TClientScriptManager.php, method TClientScriptManager::registerEndScript()
    Registers a javascript script block at the end of the form
    registerFocusControl in file TClientScriptManager.php, method TClientScriptManager::registerFocusControl()
    Registers the control to receive default focus.
    registerHeadScript in file TClientScriptManager.php, method TClientScriptManager::registerHeadScript()
    Registers a javascript block in the page head.
    registerHeadScriptFile in file TClientScriptManager.php, method TClientScriptManager::registerHeadScriptFile()
    Registers a javascript file in the page head
    registerHiddenField in file TClientScriptManager.php, method TClientScriptManager::registerHiddenField()
    Registers a hidden field to be rendered in the form.
    registerObject in file TControl.php, method TControl::registerObject()
    Registers an object by a name.
    registerPostBackControl in file TClientScriptManager.php, method TClientScriptManager::registerPostBackControl()
    Registers postback javascript for a control. A null class parameter will prevent the javascript code registration.
    registerPostDataLoader in file TPage.php, method TPage::registerPostDataLoader()
    Register post data loaders for Callback to collect post data.
    registerPradoScript in file TClientScriptManager.php, method TClientScriptManager::registerPradoScript()
    Registers Prado javascript by library name. See "Web/Javascripts/packages.php" for library names.
    registerPradoScriptInternal in file TClientScriptManager.php, method TClientScriptManager::registerPradoScriptInternal()
    Registers a Prado javascript library to be loaded.
    registerRequiresPostData in file TPage.php, method TPage::registerRequiresPostData()
    Registers a control for loading post data in the next postback.
    registerScriptFile in file TClientScriptManager.php, method TClientScriptManager::registerScriptFile()
    Registers a javascript file to be rendered within the form
    registerStyleSheet in file TClientScriptManager.php, method TClientScriptManager::registerStyleSheet()
    Registers a CSS block to be rendered in the page head
    registerStyleSheetFile in file TClientScriptManager.php, method TClientScriptManager::registerStyleSheetFile()
    Registers a CSS file to be rendered in the page head
    removeAt in file TControl.php, method TControlCollection::removeAt()
    Removes an item at the specified position.
    removeAttribute in file TControl.php, method TControl::removeAttribute()
    Removes the named attribute.
    removeAttribute in file THtmlWriter.php, method THtmlWriter::removeAttribute()
    Removes the named attribute from rendering
    removedControl in file TControl.php, method TControl::removedControl()
    Removes a control from the child collection of the control.
    removeStyleAttribute in file THtmlWriter.php, method THtmlWriter::removeStyleAttribute()
    Removes the named stylesheet attribute from rendering
    render in file THead.php, method THead::render()
    Renders the head control.
    render in file TControl.php, method TCompositeLiteral::render()
    Renders the content stored in this component.
    render in file TControlAdapter.php, method TControlAdapter::render()
    This method is invoked when the control renders itself.
    render in file TControl.php, method TControl::render()
    Renders the control.
    render in file TForm.php, method TForm::render()
    Renders the form.
    renderAllPendingScriptFiles | in file TClientScriptManager.php, method TClientScriptManager::renderAllPendingScriptFiles()
    renderBeginScripts | in file TClientScriptManager.php, method TClientScriptManager::renderBeginScripts()
    renderBeginTag in file THtmlWriter.php, method THtmlWriter::renderBeginTag()
    Renders the openning tag.
    renderChildren in file TControlAdapter.php, method TControlAdapter::renderChildren()
    Renders the control's children.
    renderChildren in file TControl.php, method TControl::renderChildren()
    Renders the children of the control.
    renderContents in file TTextProcessor.php, method TTextProcessor::renderContents()
    Renders body content.
    renderControl in file TControl.php, method TControl::renderControl()
    Renders the control.
    renderEndScripts | in file TClientScriptManager.php, method TClientScriptManager::renderEndScripts()
    renderEndTag in file THtmlWriter.php, method THtmlWriter::renderEndTag()
    Renders the closing tag.
    renderHeadScriptFiles | in file TClientScriptManager.php, method TClientScriptManager::renderHeadScriptFiles()
    renderHeadScripts | in file TClientScriptManager.php, method TClientScriptManager::renderHeadScripts()
    renderHiddenFieldsBegin | in file TClientScriptManager.php, method TClientScriptManager::renderHiddenFieldsBegin()
    renderHiddenFieldsEnd | in file TClientScriptManager.php, method TClientScriptManager::renderHiddenFieldsEnd()
    renderHiddenFieldsInt | in file TClientScriptManager.php, method TClientScriptManager::renderHiddenFieldsInt()
    renderScriptFiles | in file TClientScriptManager.php, method TClientScriptManager::renderScriptFiles()
    renderScriptFilesBegin | in file TClientScriptManager.php, method TClientScriptManager::renderScriptFilesBegin()
    renderScriptFilesEnd | in file TClientScriptManager.php, method TClientScriptManager::renderScriptFilesEnd()
    renderStyleSheetFiles | in file TClientScriptManager.php, method TClientScriptManager::renderStyleSheetFiles()
    renderStyleSheets | in file TClientScriptManager.php, method TClientScriptManager::renderStyleSheets()
    RF_ADAPTER | in file TControl.php, class constant TControl::RF_ADAPTER
    RF_AUTO_BINDINGS | in file TControl.php, class constant TControl::RF_AUTO_BINDINGS
    RF_CHILD_STATE | in file TControl.php, class constant TControl::RF_CHILD_STATE
    RF_CONTROLS in file TControl.php, class constant TControl::RF_CONTROLS
    Indexes for the rare fields.
    RF_CONTROLSTATE | in file TControl.php, class constant TControl::RF_CONTROLSTATE
    RF_DATA_BINDINGS | in file TControl.php, class constant TControl::RF_DATA_BINDINGS
    RF_EVENTS | in file TControl.php, class constant TControl::RF_EVENTS
    RF_NAMED_CONTROLS | in file TControl.php, class constant TControl::RF_NAMED_CONTROLS
    RF_NAMED_CONTROLS_ID | in file TControl.php, class constant TControl::RF_NAMED_CONTROLS_ID
    RF_NAMED_OBJECTS | in file TControl.php, class constant TControl::RF_NAMED_OBJECTS
    RF_SKIN_ID | in file TControl.php, class constant TControl::RF_SKIN_ID
    run in file TPage.php, method TPage::run()
    Runs through the page lifecycles.
    top
    s
    save in file TPageStatePersister.php, method TPageStatePersister::save()
    Saves state in hidden fields.
    save in file TCachePageStatePersister.php, method TCachePageStatePersister::save()
    Saves state in cache.
    save in file TPage.php, method IPageStatePersister::save()
    Saves state to persistent storage.
    save in file TSessionPageStatePersister.php, method TSessionPageStatePersister::save()
    Saves state in session.
    savePageState in file TPage.php, method TPage::savePageState()
    Saves page state from persistent storage.
    saveState in file TPage.php, method TPage::saveState()
    This method is invoked when control state is to be saved.
    saveState in file TControl.php, method TControl::saveState()
    This method is invoked when control state is to be saved.
    saveState in file TControlAdapter.php, method TControlAdapter::saveState()
    Saves additional persistent control state.
    saveStateRecursive in file TControl.php, method TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
    SCRIPT_PATH in file TClientScriptManager.php, class constant TClientScriptManager::SCRIPT_PATH
    directory containing Prado javascript files
    serialize | in file TPage.php, method TPageStateFormatter::serialize()
    setAdapter | in file TControl.php, method TControl::setAdapter()
    setAttribute in file TControl.php, method TControl::setAttribute()
    Sets a custom control attribute.
    setBasePath | in file TThemeManager.php, method TThemeManager::setBasePath()
    setBasePath | in file TThemeManager.php, method TTheme::setBasePath()
    setBaseUrl | in file TThemeManager.php, method TThemeManager::setBaseUrl()
    setBaseUrl | in file TThemeManager.php, method TTheme::setBaseUrl()
    setBaseUrl | in file THead.php, method THead::setBaseUrl()
    setCacheModuleID | in file TCachePageStatePersister.php, method TCachePageStatePersister::setCacheModuleID()
    setCacheTimeout | in file TCachePageStatePersister.php, method TCachePageStatePersister::setCacheTimeout()
    setCallbackClient in file TPage.php, method TPage::setCallbackClient()
    Set a new callback client handler.
    setCallbackEventParameter | in file TPage.php, method TPage::setCallbackEventParameter()
    setCallbackEventTarget in file TPage.php, method TPage::setCallbackEventTarget()
    Registers a control to raise callback event in the current request.
    setCausesValidation | in file TControl.php, method IButtonControl::setCausesValidation()
    setChildControlsCreated in file TControl.php, method TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
    setClientState in file TPage.php, method TPage::setClientState()
    Sets the state to be stored on the client side.
    setClientSupportsJavaScript | in file TPage.php, method TPage::setClientSupportsJavaScript()
    setCommandName | in file TControl.php, method IButtonControl::setCommandName()
    setCommandParameter | in file TControl.php, method IButtonControl::setCommandParameter()
    setContainer | in file TControl.php, method TCompositeLiteral::setContainer()
    setControlStage in file TControl.php, method TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
    setControlState in file TControl.php, method TControl::setControlState()
    Sets a controlstate value.
    setCustomData in file TControl.php, method TControl::setCustomData()
    Associates custom data with this control.
    setDefaultButton in file TForm.php, method TForm::setDefaultButton()
    Sets a button to be default one in a form.
    setEnabled | in file TControl.php, method TControl::setEnabled()
    setEnableStateCompression | in file TPage.php, method TPage::setEnableStateCompression()
    setEnableStateEncryption | in file TPage.php, method TPage::setEnableStateEncryption()
    setEnableStateValidation | in file TPage.php, method TPage::setEnableStateValidation()
    setEnableTheming | in file TControl.php, method TControl::setEnableTheming()
    setEnableViewState | in file TControl.php, method TControl::setEnableViewState()
    setEnctype | in file TForm.php, method TForm::setEnctype()
    setErrorMessage | in file TControl.php, method IValidator::setErrorMessage()
    setFocus in file TPage.php, method TPage::setFocus()
    Sets input focus on a control after the page is rendered to users.
    setForm in file TPage.php, method TPage::setForm()
    Registers a TForm instance to the page.
    setFunction in file TClientScriptManager.php, method TClientSideOptions::setFunction()
    Adds on client-side event handler by wrapping the code within a javascript function block. If the code begins with "javascript:", the code is assumed to be a javascript function block rather than arbiturary javascript statements.
    setHead | in file TPage.php, method TPage::setHead()
    setHistorySize | in file TSessionPageStatePersister.php, method TSessionPageStatePersister::setHistorySize()
    setID | in file TControl.php, method TControl::setID()
    setIsDefaultButton | in file TControl.php, method IButtonControl::setIsDefaultButton()
    setIsValid | in file TControl.php, method IValidator::setIsValid()
    setIsValid | in file TControl.php, method IValidatable::setIsValid()
    setJavaScriptFiles | in file TThemeManager.php, method TTheme::setJavaScriptFiles()
    setKeyPrefix | in file TCachePageStatePersister.php, method TCachePageStatePersister::setKeyPrefix()
    setMasterClass | in file TTemplateControl.php, method TTemplateControl::setMasterClass()
    setMethod | in file TForm.php, method TForm::setMethod()
    setName | in file TThemeManager.php, method TTheme::setName()
    setName | in file TControl.php, method TBroadcastEventParameter::setName()
    setOption | in file TClientScriptManager.php, method TClientSideOptions::setOption()
    setPage | in file TPage.php, method IPageStatePersister::setPage()
    setPage | in file TPageStatePersister.php, method TPageStatePersister::setPage()
    setPage | in file TSessionPageStatePersister.php, method TSessionPageStatePersister::setPage()
    setPage | in file TCachePageStatePersister.php, method TCachePageStatePersister::setPage()
    setPage in file TControl.php, method TControl::setPage()
    Sets the page for a control.
    setPagePath | in file TPage.php, method TPage::setPagePath()
    setParameter | in file TControl.php, method TBroadcastEventParameter::setParameter()
    setPostBackEventParameter | in file TPage.php, method TPage::setPostBackEventParameter()
    setPostBackEventTarget in file TPage.php, method TPage::setPostBackEventTarget()
    Registers a control to raise postback event in the current request.
    setShortcutIcon | in file THead.php, method THead::setShortcutIcon()
    setSkinID | in file TControl.php, method TControl::setSkinID()
    setSkins | in file TThemeManager.php, method TTheme::setSkins()
    setStatePersisterClass | in file TPage.php, method TPage::setStatePersisterClass()
    setStyleSheetFiles | in file TThemeManager.php, method TTheme::setStyleSheetFiles()
    setStyleSheetTheme in file TPage.php, method TPage::setStyleSheetTheme()
    Sets the stylesheet theme to be used for the page.
    setTemplate in file TTemplateControl.php, method TTemplateControl::setTemplate()
    Sets the parsed template.
    setTemplateControl in file TControl.php, method TControl::setTemplateControl()
    Sets the control whose template contains this control.
    setText | in file TTextProcessor.php, method TTextProcessor::setText()
    setText | in file TControl.php, method IButtonControl::setText()
    setTheme in file TPage.php, method TPage::setTheme()
    Sets the theme to be used for the page.
    setThemeClass | in file TThemeManager.php, method TThemeManager::setThemeClass()
    setTitle in file THead.php, method THead::setTitle()
    Sets the page title.
    setTitle in file TPage.php, method TPage::setTitle()
    Sets the page title.
    setValidationGroup | in file TControl.php, method IButtonControl::setValidationGroup()
    setViewState in file TControl.php, method TControl::setViewState()
    Sets a viewstate value.
    setVisible | in file TControl.php, method TControl::setVisible()
    setWriter | in file THtmlWriter.php, method THtmlWriter::setWriter()
    SKIN_FILE_EXT in file TThemeManager.php, class constant TTheme::SKIN_FILE_EXT
    Extension name of skin files
    STATE_SESSION_KEY | in file TSessionPageStatePersister.php, class constant TSessionPageStatePersister::STATE_SESSION_KEY
    top
    t
    TBroadcastEventParameter in file TControl.php, class TBroadcastEventParameter
    TBroadcastEventParameter class
    TCachePageStatePersister in file TCachePageStatePersister.php, class TCachePageStatePersister
    TCachePageStatePersister class
    TClientScriptManager in file TClientScriptManager.php, class TClientScriptManager
    TClientScriptManager class.
    TClientSideOptions in file TClientScriptManager.php, class TClientSideOptions
    TClientSideOptions abstract class.
    TCommandEventParameter in file TControl.php, class TCommandEventParameter
    TCommandEventParameter class
    TCompositeControl in file TCompositeControl.php, class TCompositeControl
    TCompositeControl class.
    TCompositeLiteral in file TControl.php, class TCompositeLiteral
    TCompositeLiteral class
    TControl in file TControl.php, class TControl
    TControl class
    TControlAdapter in file TControlAdapter.php, class TControlAdapter
    TControlAdapter class
    TControlCollection in file TControl.php, class TControlCollection
    TControlCollection class
    TEMPLATE_CACHE_PREFIX in file TTemplateManager.php, class constant TTemplateManager::TEMPLATE_CACHE_PREFIX
    Prefix of the cache variable name for storing parsed templates
    TEMPLATE_FILE_EXT in file TTemplateManager.php, class constant TTemplateManager::TEMPLATE_FILE_EXT
    Template file extension
    TEmptyControlCollection in file TControl.php, class TEmptyControlCollection
    TEmptyControlCollection class
    TForm in file TForm.php, class TForm
    TForm class
    THead in file THead.php, class THead
    THead class
    THEME_CACHE_PREFIX in file TThemeManager.php, class constant TTheme::THEME_CACHE_PREFIX
    prefix for cache variable name used to store parsed themes
    THtmlWriter in file THtmlWriter.php, class THtmlWriter
    THtmlWriter class
    TPage in file TPage.php, class TPage
    TPage class
    TPageStateFormatter in file TPage.php, class TPageStateFormatter
    TPageStateFormatter class.
    TPageStatePersister in file TPageStatePersister.php, class TPageStatePersister
    TPageStatePersister class
    trackViewState in file TControl.php, method TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
    traverseChildControls in file TControl.php, method TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
    TSessionPageStatePersister in file TSessionPageStatePersister.php, class TSessionPageStatePersister
    TSessionPageStatePersister class
    TTemplate in file TTemplateManager.php, class TTemplate
    TTemplate implements PRADO template parsing logic.
    TTemplateControl in file TTemplateControl.php, class TTemplateControl
    TTemplateControl class.
    TTemplateControlInheritable in file TTemplateControlInheritable.php, class TTemplateControlInheritable
    TTemplateControlInheritable class.
    TTemplateManager in file TTemplateManager.php, class TTemplateManager
    TTemplateManager class
    TTextProcessor in file TTextProcessor.php, class TTextProcessor
    TTextProcessor class.
    TTheme in file TThemeManager.php, class TTheme
    TTheme class
    TThemeManager in file TThemeManager.php, class TThemeManager
    TThemeManager class
    TYPE_DATABINDING | in file TControl.php, class constant TCompositeLiteral::TYPE_DATABINDING
    TYPE_EXPRESSION | in file TControl.php, class constant TCompositeLiteral::TYPE_EXPRESSION
    TYPE_STATEMENTS | in file TControl.php, class constant TCompositeLiteral::TYPE_STATEMENTS
    TCachePageStatePersister.php | procedural page TCachePageStatePersister.php
    TClientScriptManager.php | procedural page TClientScriptManager.php
    TCompositeControl.php | procedural page TCompositeControl.php
    TControl.php | procedural page TControl.php
    TControlAdapter.php | procedural page TControlAdapter.php
    TForm.php | procedural page TForm.php
    THtmlWriter.php | procedural page THtmlWriter.php
    TPage.php | procedural page TPage.php
    TPageStatePersister.php | procedural page TPageStatePersister.php
    TSessionPageStatePersister.php | procedural page TSessionPageStatePersister.php
    TTemplateControl.php | procedural page TTemplateControl.php
    TTemplateControlInheritable.php | procedural page TTemplateControlInheritable.php
    TTemplateManager.php | procedural page TTemplateManager.php
    TThemeManager.php | procedural page TThemeManager.php
    THead.php | procedural page THead.php
    top
    u
    unbindProperty in file TControl.php, method TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
    unloadRecursive in file TControl.php, method TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
    unregisterObject in file TControl.php, method TControl::unregisterObject()
    Unregisters an object by name.
    unserialize | in file TPage.php, method TPageStateFormatter::unserialize()
    top
    v
    validate in file TControl.php, method IValidator::validate()
    Validates certain data.
    validate in file TPage.php, method TPage::validate()
    Performs input validation.
    validateAttributes | in file TTemplateManager.php, method TTemplate::validateAttributes()
    top
    w
    write in file THtmlWriter.php, method THtmlWriter::write()
    Renders a string.
    writeBreak in file THtmlWriter.php, method THtmlWriter::writeBreak()
    Renders an HTML break.
    writeLine in file THtmlWriter.php, method THtmlWriter::writeLine()
    Renders a string and appends a newline to it.


Class Trees for Package System.Web.UI

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TCachePageStatePersister.php

File: /Web/UI/TCachePageStatePersister.php

Remarks

TCachePageStatePersister class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCachePageStatePersister.php 3020 2011-07-18 09:01:53Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCachePageStatePersister
TCachePageStatePersister class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:40 +0200 by phpDocumentor 1.4.3


Docs for page TClientScriptManager.php

File: /Web/UI/TClientScriptManager.php

Remarks

TClientScriptManager and TClientSideOptions class file.

author

Gabor Berczi <gabor.berczi@devworx.hu> (lazyload additions & progressive rendering)

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TClientScriptManager.php 3167 2012-06-25 09:25:11Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TClientScriptManager
TClientScriptManager class.
TClientSideOptions
TClientSideOptions abstract class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:47 +0200 by phpDocumentor 1.4.3


Docs for page TCompositeControl.php

File: /Web/UI/TCompositeControl.php

Remarks

TCompositeControl class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCompositeControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TCompositeControl
TCompositeControl class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:50 +0200 by phpDocumentor 1.4.3


Docs for page TControl.php

File: /Web/UI/TControl.php

Remarks

TControl, TControlCollection, TEventParameter and INamingContainer class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TControl
TControl class
TControlCollection
TControlCollection class
TEmptyControlCollection
TEmptyControlCollection class
INamingContainer
INamingContainer interface.
IPostBackEventHandler
IPostBackEventHandler interface
IPostBackDataHandler
IPostBackDataHandler interface
IValidator
IValidator interface
IValidatable
IValidatable interface
IBroadcastEventReceiver
IBroadcastEventReceiver interface
ITheme
ITheme interface.
ITemplate
ITemplate interface
IButtonControl
IButtonControl interface
ISurroundable
ISurroundable interface
TBroadcastEventParameter
TBroadcastEventParameter class
TCommandEventParameter
TCommandEventParameter class
TCompositeLiteral
TCompositeLiteral class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:52 +0200 by phpDocumentor 1.4.3


Docs for page TControlAdapter.php

File: /Web/UI/TControlAdapter.php

Remarks

TControlAdapter class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControlAdapter.php 3064 2011-11-15 17:33:22Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TControlAdapter
TControlAdapter class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:55 +0200 by phpDocumentor 1.4.3


Docs for page TForm.php

File: /Web/UI/TForm.php

Remarks

TForm class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TForm.php 2998 2011-06-24 22:12:36Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TForm
TForm class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:22 +0200 by phpDocumentor 1.4.3


Docs for page THead.php

File: /Web/UI/WebControls/THead.php

Remarks

THead class file

author

Marcus Nyeholt <tanus@users.sourceforge.net> and Qiang Xue <qiang.xue@gmail.com>

version

$Id: THead.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THead
THead class
TMetaTag
TMetaTag class.
TMetaTagCollection
TMetaTagCollection class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:22 +0200 by phpDocumentor 1.4.3


Docs for page THtmlWriter.php

File: /Web/UI/THtmlWriter.php

Remarks

THtmlWriter class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: THtmlWriter.php 3005 2011-06-26 21:58:28Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
THtmlWriter
THtmlWriter class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:28 +0200 by phpDocumentor 1.4.3


Docs for page TPage.php

File: /Web/UI/TPage.php

Remarks

TPage class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPage.php 3162 2012-06-04 13:19:53Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPage
TPage class
IPageStatePersister
IPageStatePersister interface.
TPageStateFormatter
TPageStateFormatter class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:57 +0200 by phpDocumentor 1.4.3


Docs for page TPageStatePersister.php

File: /Web/UI/TPageStatePersister.php

Remarks

TPageStatePersister class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPageStatePersister.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPageStatePersister
TPageStatePersister class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:00 +0200 by phpDocumentor 1.4.3


Docs for page TSessionPageStatePersister.php

File: /Web/UI/TSessionPageStatePersister.php

Remarks

TSessionPageStatePersister class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TSessionPageStatePersister.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSessionPageStatePersister
TSessionPageStatePersister class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:21 +0200 by phpDocumentor 1.4.3


Docs for page TTemplateControl.php

File: /Web/UI/TTemplateControl.php

Remarks

TTemplateControl class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTemplateControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTemplateControl
TTemplateControl class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:37 +0200 by phpDocumentor 1.4.3


Docs for page TTemplateControlInheritable.php

File: /Web/UI/TTemplateControlInheritable.php

Remarks

TTemplateControlInheritable class file.

author

Schlaue-Kids.net <info@schlaue-kids.net>

version

$Id$

copyright

Copyright &copy; 2010 Schlaue-Kids.net

link

http://www.schlaue-kids.net/

license

http://www.pradosoft.com/license/

Classes in this file:
TTemplateControlInheritable
TTemplateControlInheritable class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:38 +0200 by phpDocumentor 1.4.3


Docs for page TTemplateManager.php

File: /Web/UI/TTemplateManager.php

Remarks

TTemplateManager and TTemplate class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTemplateManager.php 3121 2012-03-25 20:51:49Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTemplateManager
TTemplateManager class
TTemplate
TTemplate implements PRADO template parsing logic.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:38 +0200 by phpDocumentor 1.4.3


Docs for page TThemeManager.php

File: /Web/UI/TThemeManager.php

Remarks

TThemeManager class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TThemeManager.php 3035 2011-08-30 13:58:52Z GODZilla0480@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TThemeManager
TThemeManager class
TTheme
TTheme class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:41 +0200 by phpDocumentor 1.4.3


Docs For Class TCachePageStatePersister

Class TCachePageStatePersister

[line 61]
TComponent
   |
   --TCachePageStatePersister
Location: /Web/UI/TCachePageStatePersister.php

Remarks

TCachePageStatePersister class

TCachePageStatePersister implements a page state persistent method based on cache. Page state are stored in cache (e.g. memcache, DB cache, etc.), and only a small token is passed to the client side to identify the state. This greatly reduces the size of the page state that needs to be transmitted between the server and the client. Of course, this is at the cost of using server side resource.

A cache module has to be loaded in order to use TCachePageStatePersister. By default, TCachePageStatePersister will use the primary cache module. A non-primary cache module can be used by setting CacheModuleID. Any cache module, as long as it implements the interface ICache, may be used. For example, one can use TDbCache, TMemCache, TAPCCache, etc.

TCachePageStatePersister uses CacheTimeout to limit the data that stores in cache.

Since server resource is often limited, be cautious if you plan to use TCachePageStatePersister for high-traffic Web pages. You may consider using a small CacheTimeout.

There are a couple of ways to use TCachePageStatePersister. One can override the page's TPage::getStatePersister() method and create a TCachePageStatePersister instance there. Or one can configure the pages to use TCachePageStatePersister in page configurations as follows,

  •    <pages StatePersisterClass="System.Web.UI.TCachePageStatePersister"
    •

  •           StatePersister.CacheModuleID="mycache"
    •

  •           StatePersister.CacheTimeout="3600" />
    •
    Note in the above, we use StatePersister.CacheModuleID to configure the cache module ID for the TCachePageStatePersister instance.

    The above configuration will affect the pages under the directory containing this configuration and all its subdirectories. To configure individual pages to use TCachePageStatePersister, use

  •    <pages>
    •

  •      <page id="PageID" StatePersisterClass="System.Web.UI.TCachePageStatePersister" />
    •

  •    </pages>
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TCachePageStatePersister.php 3020 2011-07-18 09:01:53Z ctrlaltca@gmail.com $

    since

    3.1.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TCachePageStatePersister::calculateKey

      calculateKey( string $timestamp );

      Parameters

      $timestamp

      micro timestamp when saving state occurs

      Returns

      a key that is unique per user request

      access

      protected

      [ Top ]

      TCachePageStatePersister::getCache

      getCache( );

      Returns

      the cache module being used for data storage

      access

      public

      [ Top ]

      TCachePageStatePersister::getCacheModuleID

      getCacheModuleID( );

      Returns

      the ID of the cache module.

      access

      public

      [ Top ]

      TCachePageStatePersister::getCacheTimeout

      getCacheTimeout( );

      Returns

      the number of seconds in which the cached state will expire. Defaults to 1800.

      access

      public

      [ Top ]

      TCachePageStatePersister::getKeyPrefix

      getKeyPrefix( );

      Returns

      prefix of cache variable name to avoid conflict with other cache data. Defaults to 'statepersister'.

      access

      public

      [ Top ]

      TCachePageStatePersister::getPage

      getPage( TPage 0 );

      Implementation of:
      IPageStatePersister::getPage()

      Parameters

      0

      the page that this persister works for

      access

      public

      [ Top ]

      TCachePageStatePersister::load

      load( );

      Implementation of:
      IPageStatePersister::load()
      Loads page state from persistent storage

      Returns

      the restored state

      Remarks

      Loads page state from cache.

      throws

      THttpException if page state is corrupted

      access

      public

      [ Top ]

      TCachePageStatePersister::save

      save( mixed $data );

      Implementation of:
      IPageStatePersister::save()
      Saves state to persistent storage.

      Parameters

      $data

      state to be stored

      Remarks

      Saves state in cache.

      access

      public

      [ Top ]

      TCachePageStatePersister::setCacheModuleID

      setCacheModuleID( string $value );

      Parameters

      $value

      the ID of the cache module. If not set, the primary cache module will be used.

      access

      public

      [ Top ]

      TCachePageStatePersister::setCacheTimeout

      setCacheTimeout( integer $value );

      Parameters

      $value

      the number of seconds in which the cached state will expire. 0 means never expire.

      throws

      TInvalidDataValueException if the number is smaller than 0.

      access

      public

      [ Top ]

      TCachePageStatePersister::setKeyPrefix

      setKeyPrefix( string $value );

      Parameters

      $value

      prefix of cache variable name to avoid conflict with other cache data

      access

      public

      [ Top ]

      TCachePageStatePersister::setPage

      setPage( TPage $page );

      Implementation of:
      IPageStatePersister::setPage()

      Parameters

      $page

      the page that this persister works for.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:40 +0200 by phpDocumentor 1.4.3


Docs For Class TClientScriptManager

Class TClientScriptManager

[line 25]
TComponent
   |
   --TApplicationComponent
      |
      --TClientScriptManager
Location: /Web/UI/TClientScriptManager.php

Remarks

TClientScriptManager class.

TClientScriptManager manages javascript and CSS stylesheets for a page.

author

Gabor Berczi <gabor.berczi@devworx.hu> (lazyload additions & progressive rendering)

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TClientScriptManager.php 3167 2012-06-25 09:25:11Z ctrlaltca $

since

3.0

Class Variable Summary

Class Constant Summary

  • PACKAGES_FILE = 'Web/Javascripts/packages.php'
    file containing javascript packages and their cross dependencies
  • SCRIPT_PATH = 'Web/Javascripts/source'
    directory containing Prado javascript files

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static void getPradoPackages()
  • static void getPradoScripts()
  • void getPradoPackages()
  • void getPradoScripts()

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    static TClientScriptManager::getPradoPackages

    static getPradoPackages( );

    access

    public

    [ Top ]

    static TClientScriptManager::getPradoScripts

    static getPradoScripts( );

    access

    public

    [ Top ]

    TClientScriptManager::__construct

    __construct( TPage $owner );

    Parameters

    $owner

    page that owns this client script manager

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TClientScriptManager::checkIfNotInRender

    checkIfNotInRender( );

    Remarks

    Checks whether page rendering has not begun yet

    access

    protected

    [ Top ]

    TClientScriptManager::flushScriptFiles

    flushScriptFiles( THtmlWriter $writer, [TControl $control = null] );

    Parameters

    $writer

    writer for the rendering purpose

    $control

    the control forcing the flush (used only in error messages)

    Remarks

    Flushes all pending script registrations

    access

    public

    [ Top ]

    TClientScriptManager::getCallbackReference

    getCallbackReference( $callbackHandler, [array $options = null] );

    Parameters

    $callbackHandler

    callback response handler

    $options

    additional callback options

    Returns

    javascript statement that creates a new callback request.

    Remarks

    Returns javascript statement that create a new callback request object.

    access

    public

    [ Top ]

    TClientScriptManager::getDefaultButtonOptions

    getDefaultButtonOptions( string $panelID, string $buttonID );

    Parameters

    $panelID

    the unique ID of the container control

    $buttonID

    the unique ID of the button control

    Returns

    default button options.

    access

    protected

    [ Top ]

    TClientScriptManager::getHiddenFields

    getHiddenFields( );

    access

    public

    [ Top ]

    TClientScriptManager::getPackagePathUrl

    getPackagePathUrl( string $base );

    Parameters

    $base

    javascript package path.

    Returns

    tuple($path,$url).

    access

    protected

    [ Top ]

    TClientScriptManager::getPradoScriptAssetUrl

    getPradoScriptAssetUrl( );

    Returns

    Prado javascript library base asset url.

    access

    public

    [ Top ]

    TClientScriptManager::getRenderedScriptFiles

    getRenderedScriptFiles( );

    access

    protected

    [ Top ]

    TClientScriptManager::getRequiresHead

    getRequiresHead( );

    Returns

    whether THead is required in order to render CSS and js within head

    since

    3.1.1

    access

    public

    [ Top ]

    TClientScriptManager::getScriptUrls

    getScriptUrls( );

    Returns

    Combined list of all script urls used in the page

    Remarks

    Returns the URLs of all script files referenced on the page

    access

    public

    [ Top ]

    TClientScriptManager::getStyleSheetUrls

    getStyleSheetUrls( );

    Returns

    Combined list of all stylesheet urls used in the page

    Remarks

    Returns the URLs of all stylesheet files referenced on the page

    access

    public

    [ Top ]

    TClientScriptManager::hasBeginScripts

    hasBeginScripts( );

    Returns

    true if any begin scripts are registered.

    access

    public

    [ Top ]

    TClientScriptManager::hasEndScripts

    hasEndScripts( );

    Returns

    true if any end scripts are registered.

    access

    public

    [ Top ]

    TClientScriptManager::isBeginScriptRegistered

    isBeginScriptRegistered( string $key );

    Parameters

    $key

    a unique key

    Returns

    whether there is a beginning javascript block registered with the specified key

    access

    public

    [ Top ]

    TClientScriptManager::isEndScriptRegistered

    isEndScriptRegistered( string $key );

    Parameters

    $key

    a unique key

    Returns

    whether there is an ending javascript block registered with the specified key

    access

    public

    [ Top ]

    TClientScriptManager::isHeadScriptFileRegistered

    isHeadScriptFileRegistered( string $key );

    Parameters

    $key

    a unique key

    Returns

    whether there is a head javascript file registered with the specified key

    access

    public

    [ Top ]

    TClientScriptManager::isHeadScriptRegistered

    isHeadScriptRegistered( string $key );

    Parameters

    $key

    a unique key

    Returns

    whether there is a head javascript block registered with the specified key

    access

    public

    [ Top ]

    TClientScriptManager::isHiddenFieldRegistered

    isHiddenFieldRegistered( string $key );

    Parameters

    $key

    a unique key

    Returns

    whether there is a hidden field registered with the specified key

    access

    public

    [ Top ]

    TClientScriptManager::isScriptFileRegistered

    isScriptFileRegistered( string $key );

    Parameters

    $key

    a unique key

    Returns

    whether there is a javascript file registered with the specified key

    access

    public

    [ Top ]

    TClientScriptManager::isStyleSheetFileRegistered

    isStyleSheetFileRegistered( string $key );

    Parameters

    $key

    a unique key

    Returns

    whether there is a CSS file registered with the specified key

    access

    public

    [ Top ]

    TClientScriptManager::isStyleSheetRegistered

    isStyleSheetRegistered( string $key );

    Parameters

    $key

    a unique key

    Returns

    whether there is a CSS block registered with the specified key

    access

    public

    [ Top ]

    TClientScriptManager::markScriptFileAsRendered

    markScriptFileAsRendered( $url );

    Parameters

    $url

    access

    public

    [ Top ]

    TClientScriptManager::registerBeginScript

    registerBeginScript( string $key, string $script );

    Parameters

    $key

    a unique key identifying the script block

    $script

    javascript block

    Remarks

    Registers a javascript script block at the beginning of the form

    access

    public

    [ Top ]

    TClientScriptManager::registerCallbackControl

    registerCallbackControl( string $class, array $options );

    Parameters

    $class

    javascript class responsible for the control being registered for callback

    $options

    callback options

    Remarks

    Registers callback javascript for a control.

    access

    public

    [ Top ]

    TClientScriptManager::registerDefaultButton

    registerDefaultButton( TControl|string $panel, TControl|string $button );

    Parameters

    $panel

    panel (or its unique ID) to register the default button action

    $button

    button (or its unique ID) to trigger a postback

    Remarks

    Register a default button to panel. When the $panel is in focus and the 'enter' key is pressed, the $button will be clicked.

    access

    public

    [ Top ]

    TClientScriptManager::registerEndScript

    registerEndScript( string $key, string $script );

    Parameters

    $key

    a unique key identifying the script block

    $script

    javascript block

    Remarks

    Registers a javascript script block at the end of the form

    access

    public

    [ Top ]

    TClientScriptManager::registerFocusControl

    registerFocusControl( string $target );

    Parameters

    $target

    the client ID of the control to receive default focus

    Remarks

    Registers the control to receive default focus.

    access

    public

    [ Top ]

    TClientScriptManager::registerHeadScript

    registerHeadScript( string $key, string $script );

    Parameters

    $key

    a unique key identifying the script block

    $script

    javascript block

    Remarks

    Registers a javascript block in the page head.

    access

    public

    [ Top ]

    TClientScriptManager::registerHeadScriptFile

    registerHeadScriptFile( string $key, string $url );

    Parameters

    $key

    a unique key identifying the file

    $url

    URL to the javascript file

    Remarks

    Registers a javascript file in the page head

    access

    public

    [ Top ]

    TClientScriptManager::registerHiddenField

    registerHiddenField( string $name, string|array $value );

    Parameters

    $name

    a unique key identifying the hidden field

    $value

    hidden field value, if the value is an array, every element in the array will be rendered as a hidden field value.

    Remarks

    Registers a hidden field to be rendered in the form.

    access

    public

    [ Top ]

    TClientScriptManager::registerPostBackControl

    registerPostBackControl( string $class, array $options );

    Parameters

    $class

    javascript class responsible for the control being registered for postback

    $options

    postback options

    Remarks

    Registers postback javascript for a control. A null class parameter will prevent the javascript code registration.

    access

    public

    [ Top ]

    TClientScriptManager::registerPradoScript

    registerPradoScript( string $name );

    Parameters

    $name

    script library name.

    Remarks

    Registers Prado javascript by library name. See "Web/Javascripts/packages.php" for library names.

    access

    public

    [ Top ]

    TClientScriptManager::registerPradoScriptInternal

    registerPradoScriptInternal( $name );

    Parameters

    $name

    Remarks

    Registers a Prado javascript library to be loaded.

    access

    protected

    [ Top ]

    TClientScriptManager::registerScriptFile

    registerScriptFile( string $key, string $url );

    Parameters

    $key

    a unique key identifying the file

    $url

    URL to the javascript file to be rendered

    Remarks

    Registers a javascript file to be rendered within the form

    access

    public

    [ Top ]

    TClientScriptManager::registerStyleSheet

    registerStyleSheet( string $key, string $css, [ $media = ''] );

    Parameters

    $key

    a unique key identifying the CSS block

    $css

    CSS block

    $media

    Remarks

    Registers a CSS block to be rendered in the page head

    access

    public

    [ Top ]

    TClientScriptManager::registerStyleSheetFile

    registerStyleSheetFile( string $key, string $url, [string $media = ''] );

    Parameters

    $key

    a unique key identifying the file

    $url

    URL to the CSS file

    $media

    media type of the CSS (such as 'print', 'screen', etc.). Defaults to empty, meaning the CSS applies to all media types.

    Remarks

    Registers a CSS file to be rendered in the page head

    The CSS files in themes are registered in OnPreRenderComplete if you want to override CSS styles in themes you need to register it after this event is completed.

    Example:

  •  <?php
    •

  •  class BasePage extends TPage {
    •

  •    public function onPreRenderComplete($param) {
    •

  •      parent::onPreRenderComplete($param);
    •

  •      $url = 'path/to/your/stylesheet.css';
    •

  •      $this->Page->ClientScript->registerStyleSheetFile($url, $url);
    •

  •    }
    •

  •  }
    •

  •  ?>
    •

    access

    public

    [ Top ]

    TClientScriptManager::renderAllPendingScriptFiles

    renderAllPendingScriptFiles( THtmlWriter $writer );

    Parameters

    $writer

    writer for the rendering purpose

    access

    public

    [ Top ]

    TClientScriptManager::renderBeginScripts

    renderBeginScripts( THtmlWriter $writer );

    Parameters

    $writer

    writer for the rendering purpose

    access

    public

    [ Top ]

    TClientScriptManager::renderEndScripts

    renderEndScripts( THtmlWriter $writer );

    Parameters

    $writer

    writer for the rendering purpose

    access

    public

    [ Top ]

    TClientScriptManager::renderHeadScriptFiles

    renderHeadScriptFiles( THtmlWriter $writer );

    Parameters

    $writer

    writer for the rendering purpose

    access

    public

    [ Top ]

    TClientScriptManager::renderHeadScripts

    renderHeadScripts( THtmlWriter $writer );

    Parameters

    $writer

    writer for the rendering purpose

    access

    public

    [ Top ]

    TClientScriptManager::renderHiddenFieldsBegin

    renderHiddenFieldsBegin( $writer );

    Parameters

    $writer

    access

    public

    [ Top ]

    TClientScriptManager::renderHiddenFieldsEnd

    renderHiddenFieldsEnd( $writer );

    Parameters

    $writer

    access

    public

    [ Top ]

    TClientScriptManager::renderHiddenFieldsInt

    renderHiddenFieldsInt( THtmlWriter $writer, $initial );

    Parameters

    $writer

    writer for the rendering purpose

    $initial

    access

    protected

    [ Top ]

    TClientScriptManager::renderScriptFiles

    renderScriptFiles( $writer, $scripts );

    Parameters

    $writer

    $scripts

    access

    protected

    [ Top ]

    TClientScriptManager::renderScriptFilesBegin

    renderScriptFilesBegin( $writer );

    Parameters

    $writer

    access

    public

    [ Top ]

    TClientScriptManager::renderScriptFilesEnd

    renderScriptFilesEnd( $writer );

    Parameters

    $writer

    access

    public

    [ Top ]

    TClientScriptManager::renderStyleSheetFiles

    renderStyleSheetFiles( THtmlWriter $writer );

    Parameters

    $writer

    writer for the rendering purpose

    access

    public

    [ Top ]

    TClientScriptManager::renderStyleSheets

    renderStyleSheets( THtmlWriter $writer );

    Parameters

    $writer

    writer for the rendering purpose

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • PACKAGES_FILE = 'Web/Javascripts/packages.php' [line 34]

    • Remarks

    file containing javascript packages and their cross dependencies

  • SCRIPT_PATH = 'Web/Javascripts/source' [line 30]

    • Remarks

    directory containing Prado javascript files

Documentation generated on Mon, 25 Jun 2012 14:43:47 +0200 by phpDocumentor 1.4.3


Docs For Class TClientSideOptions

Class TClientSideOptions

[line 764]
TComponent
   |
   --TClientSideOptions
Classes extended from TClientSideOptions:
TCallbackClientSide
TCallbackClientSide class.
TValidatorClientSide
TValidatorClientSide class.
TColorPickerClientSide
TColorPickerClientSide class.
TDatePickerClientScript
TDatePickerClientScript class.
TSliderClientScript
TSliderClientScript class.
TClientSideValidationSummaryOptions
TClientSideValidationSummaryOptions class.

Location: /Web/UI/TClientScriptManager.php

Remarks

TClientSideOptions abstract class.

TClientSideOptions manages client-side options for components that have common client-side javascript behaviours and client-side events such as between ActiveControls and validators.

author

<weizhuo[at]gmail[dot]com>

version

$Id: TClientScriptManager.php 3167 2012-06-25 09:25:11Z ctrlaltca $

abstract

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TClientSideOptions::__construct

    __construct( );

    Remarks

    Constructor, initialize the options list.

    access

    public

    [ Top ]

    TClientSideOptions::ensureFunction

    ensureFunction( $javascript );

    Overridden in child classes as:

    TCallbackClientSide::ensureFunction()
    Returns javascript statement enclosed within a javascript function.
    TClientSideValidationSummaryOptions::ensureFunction()
    Ensure the string is a valid javascript function. The code block is enclosed with "function(summary, validators){ }" block.

    Parameters

    $javascript

    Remarks

    Ensure that the javascript statements are wrapped in a javascript function block as

  • function(sender, parameter){ //code }
    •
    .

    access

    protected

    [ Top ]

    TClientSideOptions::getOption

    getOption( $name );

    Parameters

    $name

    Returns

    gets a particular option, null if not set.

    access

    protected

    [ Top ]

    TClientSideOptions::getOptions

    getOptions( );

    Returns

    gets the list of options as TMap

    access

    public

    [ Top ]

    TClientSideOptions::setFunction

    setFunction( string $name, string $code );

    Parameters

    $name

    option name

    $code

    javascript statements.

    Remarks

    Adds on client-side event handler by wrapping the code within a javascript function block. If the code begins with "javascript:", the code is assumed to be a javascript function block rather than arbiturary javascript statements.

    access

    protected

    [ Top ]

    TClientSideOptions::setOption

    setOption( string $name, mixed $value );

    Parameters

    $name

    option name

    $value

    option value.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:47 +0200 by phpDocumentor 1.4.3


Docs For Class TCompositeControl

Class TCompositeControl

[line 23]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
Classes extended from TCompositeControl:
TTemplateControl
TTemplateControl class.

Location: /Web/UI/TCompositeControl.php

Remarks

TCompositeControl class.

TCompositeControl is the base class for controls that are composed by other controls.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TCompositeControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCompositeControl::initRecursive

    initRecursive( [TControl $namingContainer = null] );

    Overridden in child classes as:

    TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

    Overrides TControl::initRecursive() (Performs the Init step for the control and all its child controls.)

    Parameters

    $namingContainer

    the naming container control

    Remarks

    Performs the OnInit step for the control and all its child controls.

    This method overrides the parent implementation by ensuring child controls are created first. Only framework developers should use this method.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:50 +0200 by phpDocumentor 1.4.3


Docs For Class IBroadcastEventReceiver

Interface IBroadcastEventReceiver

[line 2029]

Location: /Web/UI/TControl.php

Remarks

IBroadcastEventReceiver interface

If a control wants to check broadcast event, it must implement this interface.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IBroadcastEventReceiver::broadcastEventReceived

broadcastEventReceived(
TControl
$sender, TBroadCastEventParameter
$param );

    Parameters

    $sender

    sender of the event

    $param

    event parameter

    Remarks

    Handles broadcast event.

    This method is invoked automatically when an event is broadcasted.  Within this method, you may check the event name given in  the event parameter to determine  whether you should respond to  this event.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:52 +0200 by phpDocumentor 1.4.3


Docs For Class IButtonControl

Interface IButtonControl

[line 2096]

Location: /Web/UI/TControl.php

Remarks

IButtonControl interface

IButtonControl specifies the common properties and events that must  be implemented by a button control, such as TButton, TLinkButton,  TImageButton.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IButtonControl::getCausesValidation

getCausesValidation(
 );

    Returns

    whether postback event trigger by this button will cause input validation

    access

    public

    [ Top ]

    IButtonControl::getCommandName

getCommandName(
 );

    Returns

    the command name associated with the OnCommand event.

    access

    public

    [ Top ]

    IButtonControl::getCommandParameter

getCommandParameter(
 );

    Returns

    the parameter associated with the OnCommand event

    access

    public

    [ Top ]

    IButtonControl::getIsDefaultButton

getIsDefaultButton(
 );

    Returns

    true if this button is registered as a default button for a panel.

    access

    public

    [ Top ]

    IButtonControl::getText

getText(
 );

    Returns

    caption of the button

    access

    public

    [ Top ]

    IButtonControl::getValidationGroup

getValidationGroup(
 );

    Returns

    the group of validators which the button causes validation upon postback

    access

    public

    [ Top ]

    IButtonControl::onClick

onClick(
TEventParameter
$param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    Raises OnClick event.

    access

    public

    [ Top ]

    IButtonControl::onCommand

onCommand(
TCommandEventParameter
$param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    Raises OnCommand event.

    access

    public

    [ Top ]

    IButtonControl::setCausesValidation

setCausesValidation(
boolean
$value );

    Parameters

    $value

    whether postback event trigger by this button will cause input validation

    access

    public

    [ Top ]

    IButtonControl::setCommandName

setCommandName(
string
$value );

    Parameters

    $value

    the command name associated with the OnCommand event.

    access

    public

    [ Top ]

    IButtonControl::setCommandParameter

setCommandParameter(
string
$value );

    Parameters

    $value

    the parameter associated with the OnCommand event.

    access

    public

    [ Top ]

    IButtonControl::setIsDefaultButton

setIsDefaultButton(
boolean
$value );

    Parameters

    $value

    set by a panel to register this button as the default button for the panel.

    access

    public

    [ Top ]

    IButtonControl::setText

setText(
string
$value );

    Parameters

    $value

    caption of the button

    access

    public

    [ Top ]

    IButtonControl::setValidationGroup

setValidationGroup(
string
$value );

    Parameters

    $value

    the group of validators which the button causes validation upon postback

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:52 +0200 by phpDocumentor 1.4.3


Docs For Class INamingContainer

Interface INamingContainer

[line 1896]

Location: /Web/UI/TControl.php

Remarks

INamingContainer interface.

INamingContainer marks a control as a naming container.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:52 +0200 by phpDocumentor 1.4.3


Docs For Class IPostBackDataHandler

Interface IPostBackDataHandler

[line 1931]

Location: /Web/UI/TControl.php

Remarks

IPostBackDataHandler interface

If a control wants to load post data, it must implement this interface.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IPostBackDataHandler::getDataChanged

getDataChanged(
 );

    Returns

    whether postback causes the data change. Defaults to false for non-postback state.

    access

    public

    [ Top ]

    IPostBackDataHandler::loadPostData

loadPostData(
string
$key, array
$values );

    Parameters

    $key

    the key that can be used to retrieve data from the input data collection

    $values

    the input data collection

    Returns

    whether the data of the control has been changed

    Remarks

    Loads user input data.

    The implementation of this function can use $values[$key] to get the user input  data that are meant for the particular control.

    access

    public

    [ Top ]

    IPostBackDataHandler::raisePostDataChangedEvent

raisePostDataChangedEvent(
 );

    Remarks

    Raises postdata changed event.

    The implementation of this function should raise appropriate event(s) (e.g. OnTextChanged)  indicating the control data is changed.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:52 +0200 by phpDocumentor 1.4.3


Docs For Class IPostBackEventHandler

Interface IPostBackEventHandler

[line 1910]

Location: /Web/UI/TControl.php

Remarks

IPostBackEventHandler interface

If a control wants to respond to postback event, it must implement this interface.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IPostBackEventHandler::raisePostBackEvent

raisePostBackEvent(
string
$param );

    Parameters

    $param

    the parameter associated with the postback event

    Remarks

    Raises postback event.

    The implementation of this function should raise appropriate event(s) (e.g. OnClick, OnCommand)  indicating the component is responsible for the postback event.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:52 +0200 by phpDocumentor 1.4.3


Docs For Class ISurroundable

Interface ISurroundable

[line 2180]

Location: /Web/UI/TControl.php

Remarks

ISurroundable interface

Identifies controls that may create an additional surrounding tag. The id of the  tag can be obtained with getSurroundingTagID.

since

3.1.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    ISurroundable::getSurroundingTagID

getSurroundingTagID(
 );

    Returns

    the id of the embedding tag of the control or the control's clientID if not surrounded

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:52 +0200 by phpDocumentor 1.4.3


Docs For Class ITemplate

Interface ITemplate

[line 2073]

Location: /Web/UI/TControl.php

Remarks

ITemplate interface

ITemplate specifies the interface for classes encapsulating  parsed template structures.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    ITemplate::instantiateIn

instantiateIn(
TControl
$parent );

    Parameters

    $parent

    the parent control

    Remarks

    Instantiates the template.

    Content in the template will be instantiated as components and text strings  and passed to the specified parent control.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:52 +0200 by phpDocumentor 1.4.3


Docs For Class ITheme

Interface ITheme

[line 2053]

Location: /Web/UI/TControl.php

Remarks

ITheme interface.

This interface must be implemented by theme.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    ITheme::applySkin

applySkin(
TControl
$control );

    Parameters

    $control

    the control to be applied with this theme

    Remarks

    Applies this theme to the specified control.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:53 +0200 by phpDocumentor 1.4.3


Docs For Class IValidatable

Interface IValidatable

[line 2003]

Location: /Web/UI/TControl.php

Remarks

IValidatable interface

If a control wants to be validated by a validator, it must implement this interface.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IValidatable::getIsValid

getIsValid(
 );

    Returns

    wether this control's validators validated successfully (must default to true)

    access

    public

    [ Top ]

    IValidatable::getValidationPropertyValue

getValidationPropertyValue(
 );

    Returns

    the value of the property to be validated.

    access

    public

    [ Top ]

    IValidatable::setIsValid

setIsValid(

$value );

    Parameters

    $value

    Returns

    wether this control's validators validated successfully

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:53 +0200 by phpDocumentor 1.4.3


Docs For Class IValidator

Interface IValidator

[line 1965]

Location: /Web/UI/TControl.php

Remarks

IValidator interface

If a control wants to validate user input, it must implement this interface.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IValidator::getErrorMessage

getErrorMessage(
 );

    Returns

    error message during last validate

    access

    public

    [ Top ]

    IValidator::getIsValid

getIsValid(
 );

    Returns

    whether the previous validate() is successful.

    access

    public

    [ Top ]

    IValidator::setErrorMessage

setErrorMessage(
string
$value );

    Parameters

    $value

    error message for the validation

    access

    public

    [ Top ]

    IValidator::setIsValid

setIsValid(
boolean
$value );

    Parameters

    $value

    whether the validator validates successfully

    access

    public

    [ Top ]

    IValidator::validate

validate(
 );

    Returns

    whether the data passes the validation

    Remarks

    Validates certain data.

    The implementation of this function should validate certain data  (e.g. data entered into TTextBox control).

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:53 +0200 by phpDocumentor 1.4.3


Docs For Class TBroadcastEventParameter

Class TBroadcastEventParameter

[line 2201]
TComponent
   |
   --TEventParameter
      |
      --TBroadcastEventParameter
Location: /Web/UI/TControl.php

Remarks

TBroadcastEventParameter class

TBroadcastEventParameter encapsulates the parameter data for events that are broadcasted. The name of of the event is specified via Name property while the event parameter is via Parameter property.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TBroadcastEventParameter::__construct

    __construct( [string $name = ''], [mixed $parameter = null] );

    Parameters

    $name

    name of the broadcast event

    $parameter

    parameter of the broadcast event

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TBroadcastEventParameter::getName

    getName( );

    Returns

    name of the broadcast event

    access

    public

    [ Top ]

    TBroadcastEventParameter::getParameter

    getParameter( );

    Returns

    parameter of the broadcast event

    access

    public

    [ Top ]

    TBroadcastEventParameter::setName

    setName( string $value );

    Parameters

    $value

    name of the broadcast event

    access

    public

    [ Top ]

    TBroadcastEventParameter::setParameter

    setParameter( mixed $value );

    Parameters

    $value

    parameter of the broadcast event

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:53 +0200 by phpDocumentor 1.4.3


Docs For Class TCommandEventParameter

Class TCommandEventParameter

[line 2263]
TComponent
   |
   --TEventParameter
      |
      --TCommandEventParameter
Classes extended from TCommandEventParameter:
TDataGridCommandEventParameter
TDataGridCommandEventParameter class
TDataListCommandEventParameter
TDataListCommandEventParameter class
TRepeaterCommandEventParameter
TRepeaterCommandEventParameter class

Location: /Web/UI/TControl.php

Remarks

TCommandEventParameter class

TCommandEventParameter encapsulates the parameter data for Command event of button controls. You can access the name of the command via CommandName property, and the parameter carried with the command via CommandParameter property.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCommandEventParameter::__construct

    __construct( [string $name = ''], [string $parameter = ''] );

    Overridden in child classes as:

    TDataGridCommandEventParameter::__construct()
    Constructor.
    TDataListCommandEventParameter::__construct()
    Constructor.
    TRepeaterCommandEventParameter::__construct()
    Constructor.

    Parameters

    $name

    name of the command

    $parameter

    parameter of the command

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TCommandEventParameter::getCommandName

    getCommandName( );

    Returns

    name of the command

    access

    public

    [ Top ]

    TCommandEventParameter::getCommandParameter

    getCommandParameter( );

    Returns

    parameter of the command

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:53 +0200 by phpDocumentor 1.4.3


Docs For Class TCompositeLiteral

Class TCompositeLiteral

[line 2308]
TComponent
   |
   --TCompositeLiteral
Location: /Web/UI/TControl.php

Remarks

TCompositeLiteral class

TCompositeLiteral is used internally by TTemplate for representing consecutive static strings, expressions and statements.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • TYPE_DATABINDING = 2
  • TYPE_EXPRESSION = 0
  • TYPE_STATEMENTS = 1

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TCompositeLiteral::__construct

    __construct( array $items );

    Parameters

    $items

    list of items to be represented by TCompositeLiteral

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TCompositeLiteral::dataBind

    dataBind( );

    Remarks

    Performs databindings.

    This method is required by IBindable

    access

    public

    [ Top ]

    TCompositeLiteral::evaluateDynamicContent

    evaluateDynamicContent( );

    Remarks

    Evaluates the expressions and/or statements in the component.

    access

    public

    [ Top ]

    TCompositeLiteral::getContainer

    getContainer( );

    Returns

    container of this component. It serves as the evaluation context of expressions and statements.

    access

    public

    [ Top ]

    TCompositeLiteral::render

    render( ITextWriter $writer );

    Parameters

    $writer

    Remarks

    Renders the content stored in this component.

    This method is required by IRenderable

    access

    public

    [ Top ]

    TCompositeLiteral::setContainer

    setContainer( $value );

    Parameters

    $value

    container of this component. It serves as the evaluation context of expressions and statements.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • TYPE_DATABINDING = 2 [line 2312]

  • TYPE_EXPRESSION = 0 [line 2310]

  • TYPE_STATEMENTS = 1 [line 2311]

Documentation generated on Mon, 25 Jun 2012 14:43:53 +0200 by phpDocumentor 1.4.3


Docs For Class TControl

Class TControl

[line 71]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
Classes extended from TControl:
TI18NControl
TI18NControl class.
TTranslateParameter
TTranslateParameter component should be used inside the TTranslate component to allow parameter substitution.
TCallback
TCallback component class.
TCallbackOptions
TCallbackOptions class.
TCompositeControl
TCompositeControl class.
TForm
TForm class
TClientScript
TClientScript class
TConditional
TConditional class.
TContent
TContent class
TContentPlaceHolder
TContentPlaceHolder class
TDataSourceControl
TDataSourceControl class
TExpression
TExpression class
TFlushOutput
TFlushOutput class.
THead
THead class
THiddenField
THiddenField class
TLiteral
TLiteral class
TMultiView
TMultiView class
TView
TView class
TOutputCache
TOutputCache class.
TPlaceHolder
TPlaceHolder class
TRepeaterItem
TRepeaterItem class
TSafeHtml
TSafeHtml class
TStatements
TStatements class
TStyleSheet
TStyleSheet class.
TWebControl
TWebControl class
TWizardNavigationContainer
TWizardNavigationContainer class.
TXmlTransform
TXmlTransform class

Location: /Web/UI/TControl.php

Remarks

TControl class

TControl is the base class for all components on a page hierarchy. It implements the following features for UI-related functionalities:

  • databinding feature
  • parent and child relationship
  • naming container and containee relationship
  • viewstate and controlstate features
  • rendering scheme
  • control lifecycles
A property can be data-bound with an expression. By calling dataBind, expressions bound to properties will be evaluated and the results will be set to the corresponding properties.

Parent and child relationship determines how the presentation of controls are enclosed within each other. A parent will determine where to place the presentation of its child controls. For example, a TPanel will enclose all its child controls' presentation within a div html tag. A control's parent can be obtained via Parent property, and its Controls property returns a list of the control's children, including controls and static texts. The property can be manipulated like an array for adding or removing a child (see TList for more details).

A naming container control implements INamingContainer and ensures that its containee controls can be differentiated by their ID property values. Naming container and containee realtionship specifies a protocol to uniquely identify an arbitrary control on a page hierarchy by an ID path (concatenation of all naming containers' IDs and the target control's ID).

Viewstate and controlstate are two approaches to preserve state across page postback requests. ViewState is mainly related with UI specific state and can be disabled if not needed. ControlState represents crucial logic state and cannot be disabled.

A control is rendered via its render() method (the method is invoked by the framework.) Descendant control classes may override this method for customized rendering. By default, render() invokes renderChildren() which is responsible for rendering of children of the control. Control's Visible property governs whether the control should be rendered or not.

Each control on a page will undergo a series of lifecycles, including control construction, Init, Load, PreRender, Render, and OnUnload. They work together with page lifecycles to process a page request.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • CS_CHILD_INITIALIZED = 1
  • CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • CS_INITIALIZED = 2
  • CS_LOADED = 4
  • CS_PRERENDERED = 5
  • CS_STATE_LOADED = 3
  • ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • IS_CHILD_CREATED = 0x20
  • IS_CREATING_CHILD = 0x40
  • IS_DISABLE_THEMING = 0x10
  • IS_DISABLE_VIEWSTATE = 0x02
  • IS_ID_SET = 0x01
    State bits.
  • IS_SKIN_APPLIED = 0x04
  • IS_STYLESHEET_APPLIED = 0x08
  • RF_ADAPTER = 9
  • RF_AUTO_BINDINGS = 10
  • RF_CHILD_STATE = 1
  • RF_CONTROLS = 0
    Indexes for the rare fields.
  • RF_CONTROLSTATE = 7
  • RF_DATA_BINDINGS = 5
  • RF_EVENTS = 6
  • RF_NAMED_CONTROLS = 2
  • RF_NAMED_CONTROLS_ID = 3
  • RF_NAMED_OBJECTS = 8
  • RF_SKIN_ID = 4

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static string convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • string convertUniqueIdToClientId()
    Converts a unique ID to a client ID.

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    static TControl::convertUniqueIdToClientId

    static convertUniqueIdToClientId( string $uniqueID );

    Parameters

    $uniqueID

    the unique ID of a control

    Returns

    the client ID of the control

    Remarks

    Converts a unique ID to a client ID.

    access

    public

    [ Top ]

    TControl::__construct

    __construct( );

    Overridden in child classes as:

    TCallback::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, call this constructor.
    TPage::__construct()
    Constructor.
    TReadOnlyDataSource::__construct()
    TFlushOutput::__construct()
    Constructor.
    TActiveHiddenField::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveMultiView::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter.
    TActiveButton::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveCheckBox::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TRadioButton::__construct()
    Constructor.
    TActiveRadioButton::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveDataGrid::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter.
    TActiveDataList::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter.
    TCheckBoxList::__construct()
    Constructor.
    TActiveCheckBoxList::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveRadioButtonList::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TRatingList::__construct()
    Sets the default repeat direction to horizontal.
    TActiveRatingList::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveDropDownList::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveListBox::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveRepeater::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter.
    TActiveFileUpload::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveHyperLink::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveImage::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveImageButton::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveLabel::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TBaseValidator::__construct()
    Constructor.
    TActiveCustomValidator::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActiveLinkButton::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActivePager::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TActivePanel::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TDropContainer::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TDataGridPager::__construct()
    Constructor.
    TActiveTableCell::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter.
    TActiveTableRow::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter.
    TDataGridItem::__construct()
    Constructor.
    TActiveTextBox::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    TInPlaceTextBox::__construct()
    Sets the auto post back to true by default.
    TActiveDatePicker::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    THtmlArea::__construct()
    Constructor.
    TValidationSummary::__construct()
    Constructor.
    TXmlTransform::__construct()
    Constructor

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TControl::addedControl

    addedControl( TControl $control );

    Parameters

    $control

    the new child control

    Remarks

    Adds a control into the child collection of the control.

    Control lifecycles will be caught up during the addition. Only framework developers should use this method.

    access

    public

    [ Top ]

    TControl::addParsedObject

    addParsedObject( string|TComponent $object );

    Overridden in child classes as:

    TConditional::addParsedObject()
    Processes an object that is created during parsing template.
    THead::addParsedObject()
    Processes an object that is created during parsing template.
    TMultiView::addParsedObject()
    Processes an object that is created during parsing template.
    TAccordion::addParsedObject()
    Adds object parsed from template to the control.
    TDataGrid::addParsedObject()
    Adds objects parsed in template to datagrid.
    TListControl::addParsedObject()
    Adds object parsed from template to the control.
    TImageMap::addParsedObject()
    Processes an object that is created during parsing template.
    TTable::addParsedObject()
    Adds object parsed from template to the control.
    TTableRow::addParsedObject()
    Adds object parsed from template to the control.
    TTabPanel::addParsedObject()
    Adds object parsed from template to the control.
    TTextProcessor::addParsedObject()
    HTML-decodes static text.
    TWizard::addParsedObject()
    Adds TWizardStep objects into step collection.

    Overrides TComponent::addParsedObject() (Processes an object that is created during parsing template.)

    Parameters

    $object

    text string or component parsed and instantiated in template

    Remarks

    Adds the object instantiated on a template to the child control collection.

    This method overrides the parent implementation. Only framework developers and control developers should use this method.

    see

    TComponent::createdOnTemplate()

    access

    public

    [ Top ]

    TControl::addToPostDataLoader

    addToPostDataLoader( );

    Overridden in child classes as:

    TRadioButton::addToPostDataLoader()
    Add the group name as post data loader if group name is set.

    Remarks

    Add controls implementing IPostBackDataHandler to post data loaders.

    access

    protected

    [ Top ]

    TControl::applyStyleSheetSkin

    applyStyleSheetSkin( TPage $page );

    Parameters

    $page

    the page containing the control

    Remarks

    Applies a stylesheet skin to a control.

    throws

    TInvalidOperationException if the stylesheet skin is applied already

    access

    public

    [ Top ]

    TControl::autoBindProperty

    autoBindProperty( string $name, string $expression );

    Parameters

    $name

    the property name, or property path

    $expression

    the expression

    Remarks

    Sets up the binding between a property (or property path) and an expression.

    Unlike regular databinding, the expression bound by this method is automatically evaluated during prerenderRecursive(). The context of the expression is the template control (or the control itself if it is a page).

    access

    public

    [ Top ]

    TControl::autoDataBindProperties

    autoDataBindProperties( );

    Remarks

    Auto databinding properties of the control.

    access

    protected

    [ Top ]

    TControl::bindProperty

    bindProperty( string $name, string $expression );

    Parameters

    $name

    the property name, or property path

    $expression

    the expression

    Remarks

    Sets up the binding between a property (or property path) and an expression.

    The context of the expression is the template control (or the control itself if it is a page).

    access

    public

    [ Top ]

    TControl::broadcastEvent

    broadcastEvent( string $name, TControl $sender, TEventParameter $param );

    Parameters

    $name

    name of the broadcast event

    $sender

    sender of this event

    $param

    event parameter

    Remarks

    Broadcasts an event.

    The event will be sent to all controls on the current page hierarchy. If a control defines the event, the event will be raised for the control. If a control implements IBroadcastEventReceiver, its IBroadcastEventReceiver::broadcastEventReceived method will be invoked which gives the control a chance to respond to the event. For example, when broadcasting event 'OnClick', all controls having 'OnClick' event will have this event raised, and all controls implementing IBroadcastEventReceiver will also have its IBroadcastEventReceiver::broadcastEventReceived invoked.

    access

    public

    [ Top ]

    TControl::bubbleEvent

    bubbleEvent( TControl $sender, TEventParameter $param );

    Overridden in child classes as:

    TScaffoldEditView::bubbleEvent()
    Bubble the command name event. Stops bubbling when the page validator false.
    TScaffoldListView::bubbleEvent()
    Continue bubbling the "edit" command, "delete" command is handled in this class.
    TScaffoldSearch::bubbleEvent()
    Sets the SearchCondition of the TScaffoldListView as the search terms given by the text of the search text box.
    TScaffoldView::bubbleEvent()
    Handle the "edit" and "new" commands by displaying the edit view.
    TDataListItemRenderer::bubbleEvent()
    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
    TRepeaterItemRenderer::bubbleEvent()
    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
    TMultiView::bubbleEvent()
    Processes the events bubbled from child controls.
    TRepeaterItem::bubbleEvent()
    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
    TDataGrid::bubbleEvent()
    This method overrides parent's implementation to handle onItemCommand event which is bubbled from TDataGridItem child controls.
    TDataList::bubbleEvent()
    This method overrides parent's implementation to handle onItemCommand event which is bubbled from datalist items and their child controls.
    TRepeater::bubbleEvent()
    This method overrides parent's implementation to handle onItemCommand event which is bubbled from repeater items and their child controls.
    TDataListItem::bubbleEvent()
    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
    TPager::bubbleEvent()
    Processes a bubbled event.
    TDataGridPager::bubbleEvent()
    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
    TActiveTableRow::bubbleEvent()
    This method overrides parent's implementation and raises the control's callback event. This will fire the onRowSelected event if an appropriate event handler is implemented.
    TDataGridItem::bubbleEvent()
    This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
    TWizard::bubbleEvent()
    Handles bubbled events.

    Parameters

    $sender

    sender of the event

    $param

    event parameters

    Returns

    true if the event bubbling is handled and no more bubbling.

    Remarks

    This method responds to a bubbled event.

    This method should be overriden to provide customized response to a bubbled event. Check the type of event parameter to determine what event is bubbled currently.

    see

    TControl::raiseBubbleEvent()

    access

    public

    [ Top ]

    TControl::clearChildState

    clearChildState( );

    Remarks

    Clears up the child state data.

    After a control loads its state, those state that do not belong to any existing child controls are stored as child state. This method will remove these state. Only frameworker developers and control developers should use this method.

    access

    protected

    [ Top ]

    TControl::clearControlState

    clearControlState( string $key );

    Parameters

    $key

    the name of the controlstate value to be cleared

    Remarks

    Clears a controlstate value.

    access

    protected

    [ Top ]

    TControl::clearNamingContainer

    clearNamingContainer( );

    Remarks

    Resets the control as a naming container.

    Only framework developers should use this method.

    access

    public

    [ Top ]

    TControl::clearViewState

    clearViewState( string $key );

    Parameters

    $key

    the name of the viewstate value to be cleared

    Remarks

    Clears a viewstate value.

    access

    public

    [ Top ]

    TControl::createChildControls

    createChildControls( );

    Overridden in child classes as:

    TTemplateControl::createChildControls()
    Creates child controls.
    TTemplateControlInheritable::createChildControls()
    Creates child controls.
    TConditional::createChildControls()
    Creates child controls.
    TTemplatedWizardStep::createChildControls()
    Creates child controls.
    TActiveFileUpload::createChildControls()
    TDropContainer::createChildControls()
    Creates child control Override parent implementation to create a container which will contain all child controls. This container will be a TActivePanel, in order to allow user to update its content on callback.
    TWizard::createChildControls()
    Creates child controls within the wizard

    Remarks

    Creates child controls.

    This method can be overriden for controls who want to have their controls. Do not call this method directly. Instead, call ensureChildControls to ensure child controls are created only once.

    access

    public

    [ Top ]

    TControl::createControlCollection

    createControlCollection( );

    Overridden in child classes as:

    TMultiView::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
    TAccordion::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
    TTable::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
    TTableRow::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
    TTabPanel::createControlCollection()
    Creates a control collection object that is to be used to hold child controls

    Returns

    control collection

    Remarks

    Creates a control collection object that is to be used to hold child controls

    see

    TControl::getControls()

    access

    protected

    [ Top ]

    TControl::dataBind

    dataBind( );

    Overridden in child classes as:

    TDataBoundControl::dataBind()
    Performs databinding.
    TAutoComplete::dataBind()
    Overrides parent implementation. Callback renderSuggestions() when page's IsCallback property is true.

    Remarks

    Performs the databinding for this control.

    access

    public

    [ Top ]

    TControl::dataBindChildren

    dataBindChildren( );

    Remarks

    Databinding child controls.

    access

    protected

    [ Top ]

    TControl::dataBindProperties

    dataBindProperties( );

    Remarks

    Databinding properties of the control.

    access

    protected

    [ Top ]

    TControl::ensureChildControls

    ensureChildControls( );

    Remarks

    Ensures child controls are created.

    If child controls are not created yet, this method will invoke createChildControls to create them.

    access

    public

    [ Top ]

    TControl::findControl

    findControl( string $id );

    Overridden in child classes as:

    TCheckBoxList::findControl()
    Finds a control by ID.

    Parameters

    $id

    ID of the control to be looked up

    Returns

    the control found, null if not found

    Remarks

    Finds a control by ID path within the current naming container.

    The current naming container is either the control itself if it implements INamingContainer or the control's naming container. The ID path is an ID sequence separated by TControl::ID_SEPARATOR. For example, 'Repeater1.Item1.Button1' looks for a control with ID 'Button1' whose naming container is 'Item1' whose naming container is 'Repeater1'.

    throws

    TInvalidDataValueException if a control's ID is found not unique within its naming container.

    access

    public

    [ Top ]

    TControl::findControlsByID

    findControlsByID( string $id );

    Parameters

    $id

    the ID being looked for

    Returns

    list of controls found

    Remarks

    Finds all child and grand-child controls with the specified ID.

    Note, this method is different from findControl in that it searches through all controls that have this control as the ancestor while findcontrol only searches through controls that have this control as the direct naming container.

    access

    public

    [ Top ]

    TControl::findControlsByType

    findControlsByType( string $type, [boolean $strict = true] );

    Parameters

    $type

    the class name

    $strict

    whether the type comparison is strict or not. If false, controls of the parent classes of the specified class will also be returned.

    Returns

    list of controls found

    Remarks

    Finds all child and grand-child controls that are of the specified type.

    access

    public

    [ Top ]

    TControl::focus

    focus( );

    Overridden in child classes as:

    TDataSourceControl::focus()
    THiddenField::focus()
    Sets focus to this control.

    Remarks

    Sets input focus to this control.

    access

    public

    [ Top ]

    TControl::getAdapter

    getAdapter( );

    Returns

    control adapter. Null if not exists.

    access

    public

    [ Top ]

    TControl::getAllowChildControls

    getAllowChildControls( );

    Overridden in child classes as:

    TOutputCache::getAllowChildControls()
    Returns a value indicating whether body contents are allowed for this control.

    Returns

    whether body contents are allowed for this control. Defaults to true.

    access

    public

    [ Top ]

    TControl::getAttribute

    getAttribute( $name );

    Parameters

    $name

    Returns

    attribute value, null if attribute does not exist

    access

    public

    [ Top ]

    TControl::getAttributes

    getAttributes( );

    Returns

    the list of custom attributes

    Remarks

    Returns the list of custom attributes.

    Custom attributes are name-value pairs that may be rendered as HTML tags' attributes.

    access

    public

    [ Top ]

    TControl::getChildControlsCreated

    getChildControlsCreated( );

    Returns

    whether child controls have been created

    access

    protected

    [ Top ]

    TControl::getClientID

    getClientID( );

    Returns

    the client ID of the control

    Remarks

    Returns the client ID of the control.

    The client ID can be used to uniquely identify the control in client-side scripts (such as JavaScript). Do not rely on the explicit format of the return ID.

    access

    public

    [ Top ]

    TControl::getControls

    getControls( );

    Overridden in child classes as:

    TDropContainer::getControls()
    Override parent implementation to return the container control collection.

    Returns

    the child control collection

    access

    public

    [ Top ]

    TControl::getControlStage

    getControlStage( );

    Returns

    the lifecycle step the control is currently at. The value can be CS_CONSTRUCTED, CS_CHILD_INITIALIZED, CS_INITIALIZED, CS_STATE_LOADED, CS_LOADED, CS_PRERENDERED.

    Remarks

    Gets the lifecycle step the control is currently at.

    This method should only be used by control developers.

    access

    protected

    [ Top ]

    TControl::getControlState

    getControlState( string $key, [mixed $defaultValue = null] );

    Parameters

    $key

    the name of the controlstate value to be returned

    $defaultValue

    the default value. If $key is not found in controlstate, $defaultValue will be returned

    Returns

    the controlstate value corresponding to $key

    Remarks

    Returns a controlstate value.

    This function is mainly used in defining getter functions for control properties that must be kept in controlstate.

    access

    protected

    [ Top ]

    TControl::getCustomData

    getCustomData( );

    Returns

    custom data associated with this control. Defaults to null.

    Remarks

    Returns custom data associated with this control.

    A control may be associated with some custom data for various purposes. For example, a button may be associated with a string to identify itself in a generic OnClick event handler.

    access

    public

    [ Top ]

    TControl::getEnabled

    getEnabled( [boolean $checkParents = false] );

    Parameters

    $checkParents

    whether the parents should also be checked enabled

    Returns

    whether the control is enabled.

    Remarks

    Returns a value indicating whether the control is enabled.

    A control is enabled if it allows client user interaction. If $checkParents is true, all parent controls will be checked, and unless they are all enabled, false will be returned. The property Enabled is mainly used for TWebControl derived controls.

    access

    public

    [ Top ]

    TControl::getEnableTheming

    getEnableTheming( );

    Overridden in child classes as:

    TDataSourceControl::getEnableTheming()
    THiddenField::getEnableTheming()

    Returns

    whether theming is enabled for this control. The theming is enabled if the control and all its parents have it enabled.

    access

    public

    [ Top ]

    TControl::getEnableViewState

    getEnableViewState( [ $checkParents = false] );

    Parameters

    $checkParents

    Returns

    whether viewstate is enabled

    access

    public

    [ Top ]

    TControl::getHasAdapter

    getHasAdapter( );

    Returns

    whether there is an adapter for this control

    access

    public

    [ Top ]

    TControl::getHasAttributes

    getHasAttributes( );

    Returns

    whether the control has custom attributes

    access

    public

    [ Top ]

    TControl::getHasChildInitialized

    getHasChildInitialized( );

    Returns

    true if the child control has been initialized.

    access

    public

    [ Top ]

    TControl::getHasControls

    getHasControls( );

    Returns

    whether the control has child controls

    access

    public

    [ Top ]

    TControl::getHasInitialized

    getHasInitialized( );

    Returns

    true if the onInit event has raised.

    access

    public

    [ Top ]

    TControl::getHasLoaded

    getHasLoaded( );

    Returns

    true if the onLoad event has raised.

    access

    public

    [ Top ]

    TControl::getHasLoadedPostData

    getHasLoadedPostData( );

    Returns

    true if the control has loaded post data.

    access

    public

    [ Top ]

    TControl::getHasPreRendered

    getHasPreRendered( );

    Returns

    true if onPreRender event has raised.

    access

    public

    [ Top ]

    TControl::getID

    getID( [boolean $hideAutoID = true] );

    Parameters

    $hideAutoID

    whether to hide automatically generated ID

    Returns

    the ID of the control

    Remarks

    Returns the id of the control.

    Control ID can be either manually set or automatically generated. If $hideAutoID is true, automatically generated ID will be returned as an empty string.

    access

    public

    [ Top ]

    TControl::getIsSkinApplied

    getIsSkinApplied( string 0 );

    Parameters

    0

    the skin ID of this control

    throws

    TInvalidOperationException if the SkinID is set in a stage later than PreInit, or if the skin is applied already.

    access

    public

    [ Top ]

    TControl::getNamingContainer

    getNamingContainer( );

    Returns

    the naming container of this control

    access

    public

    [ Top ]

    TControl::getPage

    getPage( );

    Returns

    the page that contains this control

    access

    public

    [ Top ]

    TControl::getParent

    getParent( );

    Returns

    the parent of this control

    access

    public

    [ Top ]

    TControl::getRegisteredObject

    getRegisteredObject( $name );

    Parameters

    $name

    Returns

    the named registered object. Null if object is not found.

    Remarks

    Returns the named registered object.

    A component with explicit ID on a template will be registered to the template owner. This method allows you to obtain this component with the ID.

    access

    public

    [ Top ]

    TControl::getSkinID

    getSkinID( );

    Overridden in child classes as:

    TDataSourceControl::getSkinID()

    Returns

    the skin ID of this control, '' if not set

    access

    public

    [ Top ]

    TControl::getSourceTemplateControl

    getSourceTemplateControl( );

    Returns

    the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control.

    access

    public

    [ Top ]

    TControl::getTemplateControl

    getTemplateControl( );

    Returns

    the control whose template contains this control

    access

    public

    [ Top ]

    TControl::getUniqueID

    getUniqueID( );

    Returns

    a unique ID that identifies the control in the page hierarchy

    Remarks

    Returns a unique ID that identifies the control in the page hierarchy.

    A unique ID is the contenation of all naming container controls' IDs and the control ID. These IDs are separated by '$' character. Control users should not rely on the specific format of UniqueID, however.

    access

    public

    [ Top ]

    TControl::getViewState

    getViewState( string $key, [mixed $defaultValue = null] );

    Parameters

    $key

    the name of the viewstate value to be returned

    $defaultValue

    the default value. If $key is not found in viewstate, $defaultValue will be returned

    Returns

    the viewstate value corresponding to $key

    Remarks

    Returns a viewstate value.

    This function is very useful in defining getter functions for component properties that must be kept in viewstate.

    access

    public

    [ Top ]

    TControl::getVisible

    getVisible( [boolean $checkParents = true] );

    Overridden in child classes as:

    TDataSourceControl::getVisible()
    TView::getVisible()

    Parameters

    $checkParents

    whether the parents should also be checked if visible

    Returns

    whether the control is visible (default=true).

    Remarks

    Checks if a control is visible.

    If parent check is required, then a control is visible only if the control and all its ancestors are visible.

    access

    public

    [ Top ]

    TControl::hasAttribute

    hasAttribute( $name );

    Parameters

    $name

    Returns

    whether the named attribute exists

    access

    public

    [ Top ]

    TControl::initRecursive

    initRecursive( [TControl $namingContainer = null] );

    Overridden in child classes as:

    TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
    TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
    TOutputCache::initRecursive()
    Performs the Init step for the control and all its child controls.

    Parameters

    $namingContainer

    the naming container control

    Remarks

    Performs the Init step for the control and all its child controls.

    Only framework developers should use this method.

    access

    protected

    [ Top ]

    TControl::isDescendentOf

    isDescendentOf( TControl $ancestor );

    Parameters

    $ancestor

    the potential ancestor control

    Returns

    if the control is a descendent (parent, parent of parent, etc.) of the specified control

    access

    protected

    [ Top ]

    TControl::isObjectRegistered

    isObjectRegistered( $name );

    Parameters

    $name

    Returns

    whether an object has been registered with the name

    see

    TControl::registerObject()

    access

    public

    [ Top ]

    TControl::loadRecursive

    loadRecursive( );

    Overridden in child classes as:

    TOutputCache::loadRecursive()
    Performs the Load step for the control and all its child controls.

    Remarks

    Performs the Load step for the control and all its child controls.

    Only framework developers should use this method.

    access

    protected

    [ Top ]

    TControl::loadState

    loadState( );

    Overridden in child classes as:

    TPage::loadState()
    This method is invoked right after the control has loaded its state.
    TMultiView::loadState()
    Loads state into the wizard.
    TDataGrid::loadState()
    Loads item count information from viewstate.
    TDataList::loadState()
    Loads item count information from viewstate.
    TListControl::loadState()
    Loads items from viewstate.
    TRepeater::loadState()
    Loads item count information from viewstate.
    TPager::loadState()
    Restores the pager state.

    Remarks

    This method is invoked right after the control has loaded its state.

    You can override this method to initialize data from the control state. Parent implementation must be invoked.

    access

    public

    [ Top ]

    TControl::loadStateRecursive

    loadStateRecursive( array &$state, [boolean $needViewState = true] );

    Overridden in child classes as:

    TOutputCache::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.

    Parameters

    &$state

    the collection of the state

    $needViewState

    whether the viewstate should be loaded

    Remarks

    Loads state (viewstate and controlstate) into a control and its children.

    This method should only be used by framework developers.

    access

    protected

    [ Top ]

    TControl::onDataBinding

    onDataBinding( TEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    Raises 'OnDataBinding' event.

    This method is invoked when dataBind is invoked.

    access

    public

    [ Top ]

    TControl::onInit

    onInit( TEventParameter $param );

    Overridden in child classes as:

    TForm::onInit()
    Registers the form with the page.
    THead::onInit()
    Registers the head control with the current page.
    TMultiView::onInit()
    Initializes the active view if any.
    TTemplatedWizardStep::onInit()
    Ensures child controls are created.
    TRadioButton::onInit()
    Registers the radio button groupings. If overriding onInit method, ensure to call parent implemenation.
    TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
    TActiveFileUpload::onInit()
    TBaseValidator::onInit()
    Registers the validator with page.
    TWizard::onInit()
    Creates the child controls of the wizard.

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the control enters 'OnInit' stage.

    The method raises 'OnInit' event. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

    access

    public

    [ Top ]

    TControl::onLoad

    onLoad( TEventParameter $param );

    Overridden in child classes as:

    TScaffoldEditView::onLoad()
    Initialize the editor form if it is Visible.

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the control enters 'OnLoad' stage.

    The method raises 'OnLoad' event. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

    access

    public

    [ Top ]

    TControl::onPreRender

    onPreRender( TEventParameter $param );

    Overridden in child classes as:

    TScaffoldBase::onPreRender()
    Publish the default stylesheet file.
    TScaffoldListView::onPreRender()
    Loads and display the data.
    TScaffoldView::onPreRender()
    Copy basic record details to the list/edit/search controls.
    TClientScript::onPreRender()
    Calls the client script manager to add each of the requested client script libraries.
    TStyleSheet::onPreRender()
    Registers the stylesheet file and content to be rendered.
    TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    TAccordion::onPreRender()
    Registers CSS and JS.
    TCheckBox::onPreRender()
    Registers the checkbox to receive postback data during postback.
    TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
    TCheckBoxList::onPreRender()
    Registers for post data on postback.
    TRatingList::onPreRender()
    Publish the the rating style css file and rating image files.
    TActiveDropDownList::onPreRender()
    Updates the client-side options if the item list has changed after the OnLoad event.
    TListBox::onPreRender()
    Registers the list control to load post data on postback.
    TActiveListBox::onPreRender()
    Updates the client-side options if the item list has changed after the OnLoad event.
    TFileUpload::onPreRender()
    Sets Enctype of the form on the page.
    TActiveFileUpload::onPreRender()
    Publish the javascript
    TCaptcha::onPreRender()
    Configures the image URL that shows the token.
    TImageButton::onPreRender()
    Registers the image button to receive postback data during postback.
    TActiveImageButton::onPreRender()
    Register the x and y hidden input names of the position clicked.
    TJavascriptLogger::onPreRender()
    Registers the required logger javascript.
    TKeyboard::onPreRender()
    Registers CSS and JS.
    TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
    TReCaptchaValidator::onPreRender()
    TPager::onPreRender()
    Performs databinding to populate data items from data source.
    TDraggable::onPreRender()
    Registers clientscripts
    TDropContainer::onPreRender()
    Registers clientscripts
    TReCaptcha::onPreRender()
    Checks for API keys
    TSlider::onPreRender()
    Registers CSS and JS.
    TTabPanel::onPreRender()
    Registers CSS and JS.
    TInPlaceTextBox::onPreRender()
    Registers CSS and JS.
    TColorPicker::onPreRender()
    Publish the color picker Css asset files.
    TDatePicker::onPreRender()
    Publish the date picker Css asset files.
    TTextHighlighter::onPreRender()
    Registers css style for the highlighted result.

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the control enters 'OnPreRender' stage.

    The method raises 'OnPreRender' event. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

    access

    public

    [ Top ]

    TControl::onUnload

    onUnload( TEventParameter $param );

    Overridden in child classes as:

    TActiveFileUpload::onUnload()
    Removes localfile on ending of the callback.
    TBaseValidator::onUnload()
    Unregisters the validator from page.

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the control enters 'OnUnload' stage.

    The method raises 'OnUnload' event. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

    access

    public

    [ Top ]

    TControl::preRenderRecursive

    preRenderRecursive( );

    Overridden in child classes as:

    TOutputCache::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.

    Remarks

    Performs the PreRender step for the control and all its child controls.

    Only framework developers should use this method.

    access

    protected

    [ Top ]

    TControl::raiseBubbleEvent

    raiseBubbleEvent( TControl $sender, TEventParameter $param );

    Parameters

    $sender

    sender of the event

    $param

    event parameter

    Remarks

    Invokes the parent's bubbleEvent method.

    A control who wants to bubble an event must call this method in its onEvent method.

    see

    TControl::bubbleEvent()

    access

    protected

    [ Top ]

    TControl::registerObject

    registerObject( string $name, object object $object );

    Parameters

    $name

    name of the object

    $object

    to be declared

    Remarks

    Registers an object by a name.

    A registered object can be accessed like a public member variable. This method should only be used by framework and control developers.

    see

    TControl::__get()

    access

    public

    [ Top ]

    TControl::removeAttribute

    removeAttribute( string $name );

    Parameters

    $name

    the name of the attribute to be removed.

    Returns

    attribute value removed, null if attribute does not exist.

    Remarks

    Removes the named attribute.

    access

    public

    [ Top ]

    TControl::removedControl

    removedControl( TControl $control );

    Parameters

    $control

    the child control removed

    Remarks

    Removes a control from the child collection of the control.

    Only framework developers should use this method.

    access

    public

    [ Top ]

    TControl::render

    render( THtmlWriter $writer );

    Overridden in child classes as:

    TDateFormat::render()
    TNumberFormat::render()
    TTranslate::render()
    renders the translated string.
    TTimeTriggeredCallback::render()
    Registers the javascript code for initializing the active control.
    TEventTriggeredCallback::render()
    Registers the javascript code for initializing the active control.
    TValueTriggeredCallback::render()
    Registers the javascript code for initializing the active control.
    TDataListItemRenderer::render()
    Renders the control.
    TForm::render()
    Renders the form.
    TClientScript::render()
    Renders the body content as javascript block.
    TExpression::render()
    Renders the evaluation result of the expression.
    TFlushOutput::render()
    Flushes the output of all completely rendered controls to the client.
    THead::render()
    Renders the head control.
    THiddenField::render()
    Renders the control.
    TLiteral::render()
    Renders the literal control.
    TMultiView::render()
    Renders the currently active view.
    TActiveMultiView::render()
    Renders the TActiveMultiView.
    TOutputCache::render()
    Renders the output cache control.
    TSafeHtml::render()
    Renders body content.
    TStatements::render()
    Renders the evaluation result of the statements.
    TStyleSheet::render()
    Renders the control.
    TWebControl::render()
    Renders the control.
    TAccordion::render()
    TCheckBox::render()
    Renders the checkbox control.
    TDataGrid::render()
    Renders the datagrid.
    TActiveDataGrid::render()
    Renders the datagrid.
    TDataList::render()
    Renders the data list control.
    TActiveDataList::render()
    Renders the repeater.
    TBulletedList::render()
    Renders the control.
    TCheckBoxList::render()
    Renders the checkbox list control.
    TRatingList::render()
    Add rating style class name to the class attribute when setReadOnly property is true and when the setCssClass property is empty.
    TRepeater::render()
    Renders the repeater.
    TActiveRepeater::render()
    Renders the repeater.
    TImageMap::render()
    Renders this imagemap.
    TLabel::render()
    Renders the label.
    TPager::render()
    Renders the control.
    TActivePager::render()
    TPanel::render()
    TActivePanel::render()
    Renders and replaces the panel's content on the client-side.
    TDropContainer::render()
    Renders and replaces the panel's content on the client-side.
    TActiveTableCell::render()
    Renders and replaces the cell's content on the client-side. When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.
    TActiveTableRow::render()
    Renders and replaces the row's content on the client-side. When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.
    TTabPanel::render()
    TDatePicker::render()
    Renders body content.
    TTextHighlighter::render()
    TWizard::render()
    Renders the wizard.
    TXmlTransform::render()
    Performs XSL transformation and render the output.

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the control.

    This method is invoked by renderControl when the control is visible. You can override this method to provide customized rendering of the control. By default, the control simply renders all its child contents.

    access

    public

    [ Top ]

    TControl::renderChildren

    renderChildren( THtmlWriter $writer );

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the children of the control.

    This method iterates through all child controls and static text strings and renders them in order.

    access

    public

    [ Top ]

    TControl::renderControl

    renderControl( THtmlWriter $writer );

    Parameters

    $writer

    the writer used for the rendering purpose

    Remarks

    Renders the control.

    Only when the control is visible will the control be rendered.

    access

    public

    [ Top ]

    TControl::saveState

    saveState( );

    Overridden in child classes as:

    TPage::saveState()
    This method is invoked when control state is to be saved.
    TDataGrid::saveState()
    Saves item count in viewstate.
    TDataList::saveState()
    Saves item count in viewstate.
    TListControl::saveState()
    Saves items into viewstate.
    TRepeater::saveState()
    Saves item count in viewstate.
    TWizard::saveState()
    Saves the current active step index into history.

    Remarks

    This method is invoked when control state is to be saved.

    You can override this method to do last step state saving. Parent implementation must be invoked.

    access

    public

    [ Top ]

    TControl::saveStateRecursive

    &saveStateRecursive( [boolean $needViewState = true] );

    Overridden in child classes as:

    TOutputCache::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.

    Parameters

    $needViewState

    whether the viewstate should be saved

    Returns

    the collection of the control state (including its children's state).

    Remarks

    Saves all control state (viewstate and controlstate) as a collection.

    This method should only be used by framework developers.

    access

    protected

    [ Top ]

    TControl::setAdapter

    setAdapter( TControlAdapter $adapter );

    Parameters

    $adapter

    control adapter

    access

    public

    [ Top ]

    TControl::setAttribute

    setAttribute( string $name, string $value );

    Parameters

    $name

    attribute name

    $value

    value of the attribute

    Remarks

    Sets a custom control attribute.

    access

    public

    [ Top ]

    TControl::setChildControlsCreated

    setChildControlsCreated( boolean $value );

    Parameters

    $value

    whether child controls are created

    Remarks

    Sets a value indicating whether child controls are created.

    If false, any existing child controls will be cleared up.

    access

    protected

    [ Top ]

    TControl::setControlStage

    setControlStage( integer $value );

    Parameters

    $value

    the lifecycle step the control is currently at. Valid values include CS_CONSTRUCTED, CS_CHILD_INITIALIZED, CS_INITIALIZED, CS_STATE_LOADED, CS_LOADED, CS_PRERENDERED.

    Remarks

    Sets the lifecycle step the control is currently at.

    This method should only be used by control developers.

    access

    protected

    [ Top ]

    TControl::setControlState

    setControlState( string $key, mixed $value, [mixed $defaultValue = null] );

    Parameters

    $key

    the name of the controlstate value

    $value

    the controlstate value to be set

    $defaultValue

    default value. If $value===$defaultValue, the item will be cleared from controlstate

    Remarks

    Sets a controlstate value.

    This function is very useful in defining setter functions for control properties that must be kept in controlstate. Make sure that the controlstate value must be serializable and unserializable.

    access

    protected

    [ Top ]

    TControl::setCustomData

    setCustomData( mixed $value );

    Parameters

    $value

    custom data

    Remarks

    Associates custom data with this control.

    Note, the custom data must be serializable and unserializable.

    access

    public

    [ Top ]

    TControl::setEnabled

    setEnabled( boolean $value );

    Overridden in child classes as:

    TCheckBoxList::setEnabled()
    TRatingList::setEnabled()
    Wrapper for setReadOnly property.
    TBaseValidator::setEnabled()
    This method overrides parent's implementation by setting setIsValid to true if disabled.

    Parameters

    $value

    whether the control is to be enabled.

    access

    public

    [ Top ]

    TControl::setEnableTheming

    setEnableTheming( boolean $value );

    Overridden in child classes as:

    TDataSourceControl::setEnableTheming()
    THiddenField::setEnableTheming()

    Parameters

    $value

    whether to enable theming

    throws

    TInvalidOperationException if this method is invoked after OnPreInit

    access

    public

    [ Top ]

    TControl::setEnableViewState

    setEnableViewState( boolean $value );

    Parameters

    $value

    set whether to enable viewstate

    access

    public

    [ Top ]

    TControl::setID

    setID( string $id );

    Parameters

    $id

    the new control ID. The value must consist of word characters [a-zA-Z0-9_] only

    throws

    TInvalidDataValueException if ID is in a bad format

    access

    public

    [ Top ]

    TControl::setPage

    setPage( TPage $page );

    Parameters

    $page

    the page that contains this control

    Remarks

    Sets the page for a control.

    Only framework developers should use this method.

    access

    public

    [ Top ]

    TControl::setSkinID

    setSkinID( string $value );

    Overridden in child classes as:

    TDataSourceControl::setSkinID()
    THiddenField::setSkinID()

    Parameters

    $value

    the skin ID of this control

    throws

    TInvalidOperationException if the SkinID is set in a stage later than PreInit, or if the skin is applied already.

    access

    public

    [ Top ]

    TControl::setTemplateControl

    setTemplateControl( TTemplateControl $control );

    Parameters

    $control

    the control whose template contains this control

    Remarks

    Sets the control whose template contains this control.

    Only framework developers should use this method.

    access

    public

    [ Top ]

    TControl::setViewState

    setViewState( string $key, mixed $value, [mixed $defaultValue = null] );

    Parameters

    $key

    the name of the viewstate value

    $value

    the viewstate value to be set

    $defaultValue

    default value. If $value===$defaultValue, the item will be cleared from the viewstate.

    Remarks

    Sets a viewstate value.

    This function is very useful in defining setter functions for control properties that must be kept in viewstate. Make sure that the viewstate value must be serializable and unserializable.

    access

    public

    [ Top ]

    TControl::setVisible

    setVisible( boolean $value );

    Overridden in child classes as:

    TDataSourceControl::setVisible()
    TView::setVisible()

    Parameters

    $value

    whether the control is visible

    access

    public

    [ Top ]

    TControl::trackViewState

    trackViewState( boolean $enabled );

    Parameters

    $enabled

    whether data should be persisted

    Remarks

    Sets a value indicating whether we should keep data in viewstate.

    When it is false, data saved via setViewState() will not be persisted. By default, it is true, meaning data will be persisted across postbacks.

    access

    public

    [ Top ]

    TControl::traverseChildControls

    traverseChildControls( mixed $param, [callback $preCallback = null], [callback $postCallback = null] );

    Parameters

    $param

    parameter to be passed to callbacks for each control

    $preCallback

    callback invoked before traversing child controls. If null, it is ignored.

    $postCallback

    callback invoked after traversing child controls. If null, it is ignored.

    Remarks

    Traverse the whole control hierarchy rooted at this control.

    Callback function may be invoked for each control being visited. A pre-callback is invoked before traversing child controls; A post-callback is invoked after traversing child controls. Callback functions can be global functions or class methods. They must be of the following signature:

  •  function callback_func($control,$param) {...}
    •
    where $control refers to the control being visited and $param is the parameter that is passed originally when calling this traverse function.

    access

    protected

    [ Top ]

    TControl::unbindProperty

    unbindProperty( string $name );

    Parameters

    $name

    the property name (or property path)

    Remarks

    Breaks the binding between a property (or property path) and an expression.

    access

    public

    [ Top ]

    TControl::unloadRecursive

    unloadRecursive( );

    Remarks

    Performs the Unload step for the control and all its child controls.

    Only framework developers should use this method.

    access

    protected

    [ Top ]

    TControl::unregisterObject

    unregisterObject( string $name );

    Parameters

    $name

    name of the object

    Remarks

    Unregisters an object by name.

    see

    TControl::registerObject()

    access

    public

    [ Top ]

    TControl::__get

    __get( string $name );

    Overrides TComponent::__get() (Returns a property value or an event handler list by property or event name.)

    Parameters

    $name

    the property name or control ID

    Returns

    the property value or the target control

    Remarks

    Returns a property value by name or a control by ID.

    This overrides the parent implementation by allowing accessing a control via its ID using the following syntax,

  •  $menuBar=$this->menuBar;
    •
    Note, the control must be configured in the template with explicit ID. If the name matches both a property and a control ID, the control ID will take the precedence.

    see

    TControl::registerObject()

    throws

    TInvalidOperationException if the property is not defined.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • AUTOMATIC_ID_PREFIX = 'ctl' [line 88]

    • Remarks

    prefix to an ID automatically generated

  • CLIENT_ID_SEPARATOR = '_' [line 84]

    • Remarks

    separator char between IDs in a ClientID

  • CS_CHILD_INITIALIZED = 1 [line 94]

  • CS_CONSTRUCTED = 0 [line 93]

    • Remarks

    the stage of lifecycles that the control is currently at

  • CS_INITIALIZED = 2 [line 95]

  • CS_LOADED = 4 [line 97]

  • CS_PRERENDERED = 5 [line 98]

  • CS_STATE_LOADED = 3 [line 96]

  • ID_FORMAT = '/^[a-zA-Z_]\\w*$/' [line 76]

    • Remarks

    format of control ID

  • ID_SEPARATOR = '$' [line 80]

    • Remarks

    separator char between IDs in a UniqueID

  • IS_CHILD_CREATED = 0x20 [line 108]

  • IS_CREATING_CHILD = 0x40 [line 109]

  • IS_DISABLE_THEMING = 0x10 [line 107]

  • IS_DISABLE_VIEWSTATE = 0x02 [line 104]

  • IS_ID_SET = 0x01 [line 103]

    • Remarks

    State bits.

  • IS_SKIN_APPLIED = 0x04 [line 105]

  • IS_STYLESHEET_APPLIED = 0x08 [line 106]

  • RF_ADAPTER = 9 [line 124]

  • RF_AUTO_BINDINGS = 10 [line 125]

  • RF_CHILD_STATE = 1 [line 116]

  • RF_CONTROLS = 0 [line 115]

    • Remarks

    Indexes for the rare fields.

    In order to save memory, rare fields will only be created if they are needed.

  • RF_CONTROLSTATE = 7 [line 122]

  • RF_DATA_BINDINGS = 5 [line 120]

  • RF_EVENTS = 6 [line 121]

  • RF_NAMED_CONTROLS = 2 [line 117]

  • RF_NAMED_CONTROLS_ID = 3 [line 118]

  • RF_NAMED_OBJECTS = 8 [line 123]

  • RF_SKIN_ID = 4 [line 119]

Documentation generated on Mon, 25 Jun 2012 14:43:53 +0200 by phpDocumentor 1.4.3


Docs For Class TControlCollection

Class TControlCollection

[line 1778]
TComponent
   |
   --TList
      |
      --TControlCollection
Classes extended from TControlCollection:
TEmptyControlCollection
TEmptyControlCollection class
TAccordionViewCollection
Class TAccordionViewCollection.
TViewCollection
TViewCollection class.
TTableRowCollection
TTableRowCollection class.
TTableCellCollection
TTableCellCollection class.
TTabViewCollection
TTabViewCollection class.

Location: /Web/UI/TControl.php

Remarks

TControlCollection class

TControlCollection implements a collection that enables controls to maintain a list of their child controls.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TControlCollection::__construct

    __construct( TControl $owner, [boolean $readOnly = false] );

    Overridden in child classes as:

    TEmptyControlCollection::__construct()
    Constructor.

    Overrides TList::__construct() (Constructor.)

    Parameters

    $owner

    the control that owns this collection.

    $readOnly

    whether the list is read-only

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TControlCollection::clear

    clear( );

    Overrides TList::clear() (Removes all items in the list.)

    Remarks

    Overrides the parent implementation by invoking TControl::clearNamingContainer

    access

    public

    [ Top ]

    TControlCollection::getOwner

    getOwner( );

    Returns

    the control that owns this collection.

    access

    protected

    [ Top ]

    TControlCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overridden in child classes as:

    TEmptyControlCollection::insertAt()
    Inserts an item at the specified position.
    TAccordionViewCollection::insertAt()
    Inserts an item at the specified position.
    TViewCollection::insertAt()
    Inserts an item at the specified position.
    TTableRowCollection::insertAt()
    Inserts an item at the specified position.
    TTableCellCollection::insertAt()
    Inserts an item at the specified position.
    TTabViewCollection::insertAt()
    Inserts an item at the specified position.

    Overrides TList::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by performing additional operations for each newly added child control.

    throws

    TInvalidDataTypeException if the item to be inserted is neither a string nor a TControl.

    access

    public

    [ Top ]

    TControlCollection::removeAt

    removeAt( integer $index );

    Overrides TList::removeAt() (Removes an item at the specified position.)

    Parameters

    $index

    the index of the item to be removed.

    Returns

    the removed item.

    Remarks

    Removes an item at the specified position.

    This overrides the parent implementation by performing additional cleanup work when removing a child control.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:55 +0200 by phpDocumentor 1.4.3


Docs For Class TEmptyControlCollection

Class TEmptyControlCollection

[line 1863]
TComponent
   |
   --TList
      |
      --TControlCollection
         |
         --TEmptyControlCollection
Location: /Web/UI/TControl.php

Remarks

TEmptyControlCollection class

TEmptyControlCollection implements an empty control list that prohibits adding controls to it. This is useful for controls that do not allow child controls.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControl.php 3078 2011-12-03 15:25:12Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControlCollection

  • TControlCollection::__construct()
    Constructor.
  • TControlCollection::clear()
    Overrides the parent implementation by invoking TControl::clearNamingContainer
  • TControlCollection::getOwner()
  • TControlCollection::insertAt()
    Inserts an item at the specified position.
  • TControlCollection::removeAt()
    Removes an item at the specified position.

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TEmptyControlCollection::__construct

    __construct( TControl $owner );

    Overrides TControlCollection::__construct() (Constructor.)

    Parameters

    $owner

    the control that owns this collection.

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TEmptyControlCollection::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TControlCollection::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the speicified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by ignoring new addition.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:55 +0200 by phpDocumentor 1.4.3


Docs For Class TControlAdapter

Class TControlAdapter

[line 24]
TComponent
   |
   --TApplicationComponent
      |
      --TControlAdapter
Classes extended from TControlAdapter:
TActiveControlAdapter
TActiveControlAdapter class.
TActivePageAdapter
TActivePageAdapter class.
TWebControlAdapter
TWebControlAdapter class

Location: /Web/UI/TControlAdapter.php

Remarks

TControlAdapter class

TControlAdapter is the base class for adapters that customize various behaviors for the control to which the adapter is attached.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TControlAdapter.php 3064 2011-11-15 17:33:22Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

  • $_control =

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TControlAdapter::__construct

    __construct( TControl $control );

    Overridden in child classes as:

    TActiveControlAdapter::__construct()
    Constructor.
    TActivePageAdapter::__construct()
    Constructor, trap errors and exception to let the callback response handle them.

    Parameters

    $control

    the control to which the adapter is attached

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TControlAdapter::createChildControls

    createChildControls( );

    Remarks

    Creates child controls for the attached control.

    Default implementation calls the attached control's corresponding method.

    access

    public

    [ Top ]

    TControlAdapter::getControl

    getControl( );

    Returns

    the control to which this adapter is attached

    access

    public

    [ Top ]

    TControlAdapter::getPage

    getPage( );

    Returns

    the page that contains the attached control

    access

    public

    [ Top ]

    TControlAdapter::loadState

    loadState( );

    Remarks

    Loads additional persistent control state.

    Default implementation calls the attached control's corresponding method.

    access

    public

    [ Top ]

    TControlAdapter::onInit

    onInit( TEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the control enters 'OnInit' stage.

    Default implementation calls the attached control's corresponding method.

    access

    public

    [ Top ]

    TControlAdapter::onLoad

    onLoad( TEventParameter $param );

    Overridden in child classes as:

    TActiveControlAdapter::onLoad()
    Starts viewstate tracking if necessary after when controls has been loaded

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the control enters 'OnLoad' stage.

    Default implementation calls the attached control's corresponding method.

    access

    public

    [ Top ]

    TControlAdapter::onPreRender

    onPreRender( TEventParameter $param );

    Overridden in child classes as:

    TActiveControlAdapter::onPreRender()
    Publish the ajax script

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the control enters 'OnPreRender' stage.

    Default implementation calls the attached control's corresponding method.

    access

    public

    [ Top ]

    TControlAdapter::onUnload

    onUnload( TEventParameter $param );

    Parameters

    $param

    event parameter to be passed to the event handlers

    Remarks

    This method is invoked when the control enters 'OnUnload' stage.

    Default implementation calls the attached control's corresponding method.

    access

    public

    [ Top ]

    TControlAdapter::render

    render( THtmlWriter $writer );

    Overridden in child classes as:

    TActiveControlAdapter::render()
    Renders the callback client scripts.
    TWebControlAdapter::render()
    Renders the control to which the adapter is attached.

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    This method is invoked when the control renders itself.

    Default implementation calls the attached control's corresponding method.

    access

    public

    [ Top ]

    TControlAdapter::renderChildren

    renderChildren( THtmlWriter $writer );

    Parameters

    $writer

    writer for the rendering purpose

    Remarks

    Renders the control's children.

    Default implementation calls the attached control's corresponding method.

    access

    public

    [ Top ]

    TControlAdapter::saveState

    saveState( );

    Overridden in child classes as:

    TActiveControlAdapter::saveState()
    Saves additional persistent control state. Respond to viewstate changes if necessary.

    Remarks

    Saves additional persistent control state.

    Default implementation calls the attached control's corresponding method.

    access

    public

    [ Top ]

Variable Detail

  • $_control = [line 29]
  • Data type: TControl

    • var

    the control to which the adapter is attached

    access

    protected

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:55 +0200 by phpDocumentor 1.4.3


Docs For Class TForm

Class TForm

[line 30]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TForm
Location: /Web/UI/TForm.php

Remarks

TForm class

TForm displays an HTML form. Besides regular body content, it displays hidden fields, javascript blocks and files that are registered through TClientScriptManager.

A TForm is required for a page that needs postback. Each page can contain at most one TForm. If multiple HTML forms are needed, please use regular HTML form tags for those forms that post to different URLs.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TForm.php 2998 2011-06-24 22:12:36Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TForm::addAttributesToRender

    addAttributesToRender( THtmlWriter $writer );

    Parameters

    $writer

    writer

    Remarks

    Adds form specific attributes to renderer.

    access

    protected

    [ Top ]

    TForm::getDefaultButton

    getDefaultButton( );

    Returns

    id path to the default button control.

    access

    public

    [ Top ]

    TForm::getEnctype

    getEnctype( );

    Returns

    the encoding type a browser uses to post data back to the server

    access

    public

    [ Top ]

    TForm::getMethod

    getMethod( );

    Returns

    form submission method. Defaults to 'post'.

    access

    public

    [ Top ]

    TForm::getName

    getName( );

    Returns

    form name, which is equal to UniqueID.

    access

    public

    [ Top ]

    TForm::onInit

    onInit( mixed $param );

    Overrides TControl::onInit() (This method is invoked when the control enters 'OnInit' stage.)

    Parameters

    $param

    event parameter

    Remarks

    Registers the form with the page.

    access

    public

    [ Top ]

    TForm::render

    render( THtmlWriter $writer );

    Overrides TControl::render() (Renders the control.)

    Parameters

    $writer

    writer

    Remarks

    Renders the form.

    access

    public

    [ Top ]

    TForm::setDefaultButton

    setDefaultButton( string $value );

    Parameters

    $value

    id path to the default button control.

    Remarks

    Sets a button to be default one in a form.

    A default button will be clicked if a user presses 'Enter' key within the form.

    access

    public

    [ Top ]

    TForm::setEnctype

    setEnctype( string $value );

    Parameters

    $value

    the encoding type a browser uses to post data back to the server. Commonly used types include

    • application/x-www-form-urlencoded : Form data is encoded as name/value pairs. This is the standard encoding format.
    • multipart/form-data : Form data is encoded as a message with a separate part for each control on the page.
    • text/plain : Form data is encoded in plain text, without any control or formatting characters.

    access

    public

    [ Top ]

    TForm::setMethod

    setMethod( string $value );

    Parameters

    $value

    form submission method. Valid values include 'post' and 'get'.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:22 +0200 by phpDocumentor 1.4.3


Docs For Class THead

Class THead

[line 44]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --THead
Location: /Web/UI/WebControls/THead.php

Remarks

THead class

THead displays a head element on a page. It displays the content enclosed in its body and the page title set by the Title property. In addition, stylesheets and JavaScripts registered via TClientScriptManager::registerStyleSheet, TClientScriptManager::registerStyleSheetFile TClientScriptManager::registerHeadJavaScript, and TClientScriptManager::registerHeadJavaScriptFile will also be displayed in the head. THead also manages and displays meta tags through its MetaTags property. You can add a meta object to the collection in code dynamically, or add it in template using the following syntax,

  •  <com:THead>
    •

  •    <com:TMetaTag HttpEquiv="Pragma" Content="no-cache" />
    •

  •    <com:TMetaTag Name="keywords" Content="Prado" />
    •

  •  </com:THead>
    •

    Note, TPage has a property TPage::getHead that refers to the THead control currently on the page. A page can have at most one THead control. Although not required, it is recommended to place a THead on your page. Without a THead on the page, stylesheets and javascripts in the current page theme will not be rendered.

    author

    Marcus Nyeholt <tanus@users.sourceforge.net> and Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: THead.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      THead::addParsedObject

      addParsedObject( string|TComponent $object );

      Overrides TControl::addParsedObject() (Adds the object instantiated on a template to the child control collection.)

      Parameters

      $object

      text string or component parsed and instantiated in template

      Remarks

      Processes an object that is created during parsing template.

      This method adds TMetaTag components into the MetaTags collection of the head control.

      see

      TComponent::createdOnTemplate()

      access

      public

      [ Top ]

      THead::getBaseUrl

      getBaseUrl( );

      Returns

      base URL of the page. This URL is rendered as the 'href' attribute of <base> tag. Defaults to ''.

      access

      public

      [ Top ]

      THead::getMetaTags

      getMetaTags( );

      Returns

      meta tag collection

      access

      public

      [ Top ]

      THead::getShortcutIcon

      getShortcutIcon( );

      Returns

      the URL for the shortcut icon of the page. Defaults to ''.

      access

      public

      [ Top ]

      THead::getTitle

      getTitle( );

      Returns

      the page title.

      access

      public

      [ Top ]

      THead::onInit

      onInit( TEventParameter $param );

      Overrides TControl::onInit() (This method is invoked when the control enters 'OnInit' stage.)

      Parameters

      $param

      event parameter to be passed to the event handlers

      Remarks

      Registers the head control with the current page.

      This method is invoked when the control enters 'Init' stage. The method raises 'Init' event. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

      access

      public

      [ Top ]

      THead::render

      render( THtmlWriter $writer );

      Overrides TControl::render() (Renders the control.)

      Parameters

      $writer

      the writer for rendering purpose.

      Remarks

      Renders the head control.

      access

      public

      [ Top ]

      THead::setBaseUrl

      setBaseUrl( string $url );

      Parameters

      $url

      base URL of the page. This URL is rendered as the 'href' attribute of <base> tag.

      access

      public

      [ Top ]

      THead::setShortcutIcon

      setShortcutIcon( string $url );

      Parameters

      $url

      the URL for the shortcut icon of the page.

      access

      public

      [ Top ]

      THead::setTitle

      setTitle( string $value );

      Parameters

      $value

      the page title.

      Remarks

      Sets the page title.

      This title will be rendered only if the TPage::getTitle property of the page is empty.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:22 +0200 by phpDocumentor 1.4.3


Docs For Class THtmlWriter

Class THtmlWriter

[line 39]
TComponent
   |
   --TApplicationComponent
      |
      --THtmlWriter
Location: /Web/UI/THtmlWriter.php

Remarks

THtmlWriter class

THtmlWriter is a writer that renders valid XHTML outputs. It provides functions to render tags, their attributes and stylesheet fields. Attribute and stylesheet values will be automatically HTML-encoded if they require so. For example, the 'value' attribute in an input tag will be encoded.

A common usage of THtmlWriter is as the following sequence:

  •   $writer->addAttribute($name1,$value1);
    •

  •   $writer->addAttribute($name2,$value2);
    •

  •   $writer->renderBeginTag($tagName);
    •

  •   // ... render contents enclosed within the tag here
    •

  •   $writer->renderEndTag();
    •
    Make sure each invocation of renderBeginTag is accompanied with a renderEndTag and they are properly nested, like nesting tags in HTML and XHTML.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: THtmlWriter.php 3005 2011-06-26 21:58:28Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      THtmlWriter::__construct

      __construct( ITextWriter $writer );

      Parameters

      $writer

      a writer that THtmlWriter will pass its rendering result to

      Remarks

      Constructor.

      access

      public

      [ Top ]

      THtmlWriter::addAttribute

      addAttribute( string $name, string $value );

      Parameters

      $name

      name of the attribute

      $value

      value of the attribute

      Remarks

      Adds an attribute to be rendered.

      access

      public

      [ Top ]

      THtmlWriter::addAttributes

      addAttributes( array $attrs );

      Parameters

      $attrs

      list of attributes to be rendered

      Remarks

      Adds a list of attributes to be rendered.

      access

      public

      [ Top ]

      THtmlWriter::addStyleAttribute

      addStyleAttribute( string $name, string $value );

      Parameters

      $name

      stylesheet attribute name

      $value

      stylesheet attribute value

      Remarks

      Adds a stylesheet attribute to be rendered

      access

      public

      [ Top ]

      THtmlWriter::addStyleAttributes

      addStyleAttributes( array $attrs );

      Parameters

      $attrs

      list of stylesheet attributes to be rendered

      Remarks

      Adds a list of stylesheet attributes to be rendered.

      access

      public

      [ Top ]

      THtmlWriter::flush

      flush( );

      Returns

      the content being flushed

      Remarks

      Flushes the rendering result.

      This will invoke the underlying writer's flush method.

      access

      public

      [ Top ]

      THtmlWriter::getWriter

      getWriter( );

      access

      public

      [ Top ]

      THtmlWriter::removeAttribute

      removeAttribute( string $name );

      Parameters

      $name

      name of the attribute to be removed

      Remarks

      Removes the named attribute from rendering

      access

      public

      [ Top ]

      THtmlWriter::removeStyleAttribute

      removeStyleAttribute( string $name );

      Parameters

      $name

      name of the stylesheet attribute to be removed

      Remarks

      Removes the named stylesheet attribute from rendering

      access

      public

      [ Top ]

      THtmlWriter::renderBeginTag

      renderBeginTag( string $tagName );

      Parameters

      $tagName

      tag name

      Remarks

      Renders the openning tag.

      access

      public

      [ Top ]

      THtmlWriter::renderEndTag

      renderEndTag( );

      Remarks

      Renders the closing tag.

      access

      public

      [ Top ]

      THtmlWriter::setWriter

      setWriter( $writer );

      Parameters

      $writer

      access

      public

      [ Top ]

      THtmlWriter::write

      write( string $str );

      Parameters

      $str

      string to be rendered

      Remarks

      Renders a string.

      access

      public

      [ Top ]

      THtmlWriter::writeBreak

      writeBreak( );

      Remarks

      Renders an HTML break.

      access

      public

      [ Top ]

      THtmlWriter::writeLine

      writeLine( [string $str = ''] );

      Parameters

      $str

      string to be rendered

      Remarks

      Renders a string and appends a newline to it.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:28 +0200 by phpDocumentor 1.4.3


Docs For Class IPageStatePersister

Interface IPageStatePersister

[line 1252]

Location: /Web/UI/TPage.php

Remarks

IPageStatePersister interface.

IPageStatePersister interface is required for all page state persister  classes.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPage.php 3162 2012-06-04 13:19:53Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IPageStatePersister::getPage

getPage(
TPage
0 );

    Parameters

    0

    the page that this persister works for

    access

    public

    [ Top ]

    IPageStatePersister::load

load(
 );

    Returns

    the restored state

    Remarks

    Loads page state from persistent storage

    access

    public

    [ Top ]

    IPageStatePersister::save

save(
mixed
$state );

    Parameters

    $state

    state to be stored

    Remarks

    Saves state to persistent storage.

    access

    public

    [ Top ]

    IPageStatePersister::setPage

setPage(
TPage
$page );

    Parameters

    $page

    the page that this persister works for

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:57 +0200 by phpDocumentor 1.4.3


Docs For Class TPage

Class TPage

[line 29]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TPage
Location: /Web/UI/TPage.php

Remarks

TPage class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPage.php 3162 2012-06-04 13:19:53Z ctrlaltca $

since

3.0

Class Variable Summary

  • $_controlsPostDataChanged = array()
  • $_controlsRegisteredForPostData = array()
  • $_controlsRequiringPostData = array()
  • $_formRendered = false
  • $_inFormRender = false
  • $_isLoadingPostData = false
  • $_postData =
  • $_postDataLoaders = array()
  • $_restPostData =

Class Constant Summary

  • FIELD_CALLBACK_PARAMETER = 'PRADO_CALLBACK_PARAMETER'
  • FIELD_CALLBACK_TARGET = 'PRADO_CALLBACK_TARGET'
  • FIELD_LASTFOCUS = 'PRADO_LASTFOCUS'
  • FIELD_PAGESTATE = 'PRADO_PAGESTATE'
  • FIELD_POSTBACK_PARAMETER = 'PRADO_POSTBACK_PARAMETER'
  • FIELD_POSTBACK_TARGET = 'PRADO_POSTBACK_TARGET'
    system post fields

Inherited Class Constant Summary

Inherited From Class TTemplateControl

  • TTemplateControl::EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

  • static void decodeUTF8()
  • void decodeUTF8()

Inherited Method Summary

Inherited From Class TTemplateControl

  • TTemplateControl::createChildControls()
    Creates child controls.
  • TTemplateControl::getIsSourceTemplateControl()
  • TTemplateControl::getMaster()
  • TTemplateControl::getMasterClass()
  • TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
  • TTemplateControl::getTemplateDirectory()
  • TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
  • TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
  • TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
  • TTemplateControl::registerContent()
    Registers a content control.
  • TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
  • TTemplateControl::setMasterClass()
  • TTemplateControl::setTemplate()
    Sets the parsed template.

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    static TPage::decodeUTF8

    static decodeUTF8( $data, $enc );

    Parameters

    $data

    $enc

    access

    protected

    [ Top ]

    TPage::applyControlSkin

    applyControlSkin( TControl $control );

    Parameters

    $control

    a control to be applied skin with

    Remarks

    Applies a skin in the current theme to a control.

    This method should only be used by framework developers.

    access

    public

    [ Top ]

    TPage::applyControlStyleSheet

    applyControlStyleSheet( TControl $control );

    Parameters

    $control

    a control to be applied stylesheet skin with

    Remarks

    Applies a stylesheet skin in the current theme to a control.

    This method should only be used by framework developers.

    access

    public

    [ Top ]

    TPage::beginFormRender

    beginFormRender( $writer );

    Parameters

    $writer

    access

    public

    [ Top ]

    TPage::endFormRender

    endFormRender( $writer );

    Parameters

    $writer

    access

    public

    [ Top ]

    TPage::ensureRenderInForm

    ensureRenderInForm( TControl $control );

    Parameters

    $control

    the control to be rendered

    Remarks

    Ensures the control is rendered within a form.

    throws

    TConfigurationException if the control is outside of the form

    access

    public

    [ Top ]

    TPage::__construct

    __construct( );

    Overrides TControl::__construct() (Constructor.)

    Remarks

    Constructor.

    Sets the page object to itself. Derived classes must call parent implementation.

    access

    public

    [ Top ]

    TPage::flushWriter

    flushWriter( );

    Remarks

    Flushes output

    access

    public

    [ Top ]

    TPage::getCachingStack

    getCachingStack( );

    Returns

    stack of TOutputCache objects

    access

    public

    [ Top ]

    TPage::getCallbackClient

    getCallbackClient( );

    Returns

    interface to client-side javascript code.

    Remarks

    Gets the callback client script handler that allows javascript functions to be executed during the callback response.

    access

    public

    [ Top ]

    TPage::getCallbackEventParameter

    getCallbackEventParameter( );

    Returns

    callback event parameter

    Remarks

    Callback parameter is decoded assuming JSON encoding.

    access

    public

    [ Top ]

    TPage::getCallbackEventTarget

    getCallbackEventTarget( );

    Returns

    the control responsible for the current callback event, null if nonexistent

    access

    public

    [ Top ]

    TPage::getClientScript

    getClientScript( );

    Returns

    client script manager

    access

    public

    [ Top ]

    TPage::getClientState

    getClientState( );

    Returns

    the state to be stored on the client side

    Remarks

    Returns the state to be stored on the client side.

    This method should only be used by framework and control developers.

    access

    public

    [ Top ]

    TPage::getClientSupportsJavaScript

    getClientSupportsJavaScript( );

    Returns

    whether client supports javascript. Defaults to true.

    access

    public

    [ Top ]

    TPage::getEnableStateCompression

    getEnableStateCompression( );

    Returns

    whether page state should be compressed. Defaults to true.

    since

    3.1.6

    access

    public

    [ Top ]

    TPage::getEnableStateEncryption

    getEnableStateEncryption( );

    Returns

    whether page state should be encrypted. Defaults to false.

    access

    public

    [ Top ]

    TPage::getEnableStateValidation

    getEnableStateValidation( );

    Returns

    whether page state should be HMAC validated. Defaults to true.

    access

    public

    [ Top ]

    TPage::getForm

    getForm( );

    Returns

    the form on the page

    access

    public

    [ Top ]

    TPage::getHead

    getHead( );

    Returns

    page head, null if not available

    access

    public

    [ Top ]

    TPage::getInFormRender

    getInFormRender( );

    Returns

    Whether form rendering is in progress

    access

    public

    [ Top ]

    TPage::getIsCallback

    getIsCallback( );

    Returns

    whether this is a callback request

    access

    public

    [ Top ]

    TPage::getIsLoadingPostData

    getIsLoadingPostData( );

    Returns

    true if loading post data.

    access

    public

    [ Top ]

    TPage::getIsPostBack

    getIsPostBack( );

    Returns

    whether the current page request is a postback

    access

    public

    [ Top ]

    TPage::getIsValid

    getIsValid( );

    Returns

    whether the user input is valid or not.

    Remarks

    Returns whether user input is valid or not.

    This method must be invoked after validate is called.

    throws

    TInvalidOperationException if validate is not invoked yet.

    access

    public

    [ Top ]

    TPage::getPagePath

    getPagePath( );

    Returns

    the requested page path for this page

    access

    public

    [ Top ]

    TPage::getPostBackEventParameter

    getPostBackEventParameter( );

    Returns

    postback event parameter

    access

    public

    [ Top ]

    TPage::getPostBackEventTarget

    getPostBackEventTarget( );

    Returns

    the control responsible for the current postback event, null if nonexistent

    access

    public

    [ Top ]

    TPage::getPostDataLoaders

    getPostDataLoaders( );

    Returns

    list of IDs implementing IPostBackDataHandler

    Remarks

    Get a list of IDs of controls that are enabled and require post data.

    access

    public

    [ Top ]

    TPage::getRequestClientState

    getRequestClientState( );

    Returns

    the state postback from client side

    access

    public

    [ Top ]

    TPage::getStatePersister

    getStatePersister( );

    Returns

    page state persister

    access

    public

    [ Top ]

    TPage::getStatePersisterClass

    getStatePersisterClass( );

    Returns

    class name of the page state persister. Defaults to TPageStatePersister.

    access

    public

    [ Top ]

    TPage::getStyleSheetTheme

    getStyleSheetTheme( );

    Returns

    the stylesheet theme used for the page. Defaults to null.

    access

    public

    [ Top ]

    TPage::getTheme

    getTheme( );

    Returns

    the theme used for the page. Defaults to null.

    access

    public

    [ Top ]

    TPage::getTitle

    getTitle( );

    Returns

    page title.

    access

    public

    [ Top ]

    TPage::getValidators

    getValidators( [string $validationGroup = null] );

    Parameters

    $validationGroup

    validation group

    Returns

    registered validators in the requested group. If the group is null, all validators will be returned.

    Remarks

    Returns a list of registered validators.

    If validation group is specified, only the validators in that group will be returned.

    access

    public

    [ Top ]

    TPage::isSystemPostField

    isSystemPostField( string $field );

    Parameters

    $field

    the field name

    Returns

    whether the specified field is a system field in postback data

    access

    protected

    [ Top ]

    TPage::loadPageState

    loadPageState( );

    Remarks

    Loads page state from persistent storage.

    access

    protected

    [ Top ]

    TPage::loadState

    loadState( );

    Overrides TControl::loadState() (This method is invoked right after the control has loaded its state.)

    Remarks

    This method is invoked right after the control has loaded its state.

    You can override this method to initialize data from the control state. Parent implementation must be invoked.

    access

    public

    [ Top ]

    TPage::onInitComplete

    onInitComplete( mixed $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnInitComplete event.

    This method is invoked right after OnInit stage and before OnLoad stage. You may override this method to provide additional initialization that should be done after OnInit. Remember to call the parent implementation to ensure OnInitComplete event is raised.

    access

    public

    [ Top ]

    TPage::onLoadComplete

    onLoadComplete( mixed $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnLoadComplete event.

    This method is invoked right after OnLoad stage. You may override this method to provide additional page loading logic that should be done after OnLoad. Remember to call the parent implementation to ensure OnLoadComplete event is raised.

    access

    public

    [ Top ]

    TPage::onPreInit

    onPreInit( mixed $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnPreInit event.

    This method is invoked right before OnInit stage. You may override this method to provide additional initialization that should be done before OnInit (e.g. setting Theme or StyleSheetTheme). Remember to call the parent implementation to ensure OnPreInit event is raised.

    access

    public

    [ Top ]

    TPage::onPreLoad

    onPreLoad( mixed $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnPreLoad event.

    This method is invoked right before OnLoad stage. You may override this method to provide additional page loading logic that should be done before OnLoad. Remember to call the parent implementation to ensure OnPreLoad event is raised.

    access

    public

    [ Top ]

    TPage::onPreRenderComplete

    onPreRenderComplete( mixed $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnPreRenderComplete event.

    This method is invoked right after OnPreRender stage. You may override this method to provide additional preparation for page rendering that should be done after OnPreRender. Remember to call the parent implementation to ensure OnPreRenderComplete event is raised.

    access

    public

    [ Top ]

    TPage::onSaveStateComplete

    onSaveStateComplete( mixed $param );

    Parameters

    $param

    event parameter

    Remarks

    Raises OnSaveStateComplete event.

    This method is invoked right after onSaveState stage. You may override this method to provide additional logic after page state is saved. Remember to call the parent implementation to ensure OnSaveStateComplete event is raised.

    access

    public

    [ Top ]

    TPage::processCallbackRequest

    processCallbackRequest( $writer );

    Parameters

    $writer

    Remarks

    Sets Adapter to TActivePageAdapter and calls apter to process the callback request.

    access

    protected

    [ Top ]

    TPage::processNormalRequest

    processNormalRequest( $writer );

    Parameters

    $writer

    access

    protected

    [ Top ]

    TPage::processPostBackRequest

    processPostBackRequest( $writer );

    Parameters

    $writer

    access

    protected

    [ Top ]

    TPage::processPostData

    processPostData( TMap $postData, boolean $beforeLoad );

    Parameters

    $postData

    post data to be processed

    $beforeLoad

    whether this method is invoked before OnLoad.

    Remarks

    Processes post data.

    access

    protected

    [ Top ]

    TPage::raiseChangedEvents

    raiseChangedEvents( );

    Remarks

    Raises OnPostDataChangedEvent for controls whose data have been changed due to the postback.

    access

    protected

    [ Top ]

    TPage::raisePostBackEvent

    raisePostBackEvent( );

    Remarks

    Raises PostBack event.

    access

    protected

    [ Top ]

    TPage::registerCachingAction

    registerCachingAction( string $context, string $funcName, array $funcParams );

    Parameters

    $context

    context of the action method. This is a property-path referring to the context object (e.g. Page, Page.ClientScript).

    $funcName

    method name of the context object

    $funcParams

    list of parameters to be passed to the action method

    Remarks

    Registers an action associated with the content being cached.

    The registered action will be replayed if the content stored in the cache is served to end-users.

    access

    public

    [ Top ]

    TPage::registerPostDataLoader

    registerPostDataLoader( TControl $control );

    Parameters

    $control

    control that requires post data.

    Remarks

    Register post data loaders for Callback to collect post data.

    This method should only be called by framework developers.

    see

    TControl::preRenderRecursive();

    access

    public

    [ Top ]

    TPage::registerRequiresPostData

    registerRequiresPostData( TControl $control );

    Parameters

    $control

    control registered for loading post data

    Remarks

    Registers a control for loading post data in the next postback.

    This method needs to be invoked if the control to load post data may not have a post variable in some cases. For example, a checkbox, if not checked, will not have a post value.

    access

    public

    [ Top ]

    TPage::run

    run( THtmlTextWriter $writer );

    Parameters

    $writer

    the HTML writer

    Remarks

    Runs through the page lifecycles.

    access

    public

    [ Top ]

    TPage::savePageState

    savePageState( );

    Remarks

    Saves page state from persistent storage.

    access

    protected

    [ Top ]

    TPage::saveState

    saveState( );

    Overrides TControl::saveState() (This method is invoked when control state is to be saved.)

    Remarks

    This method is invoked when control state is to be saved.

    You can override this method to do last step state saving. Parent implementation must be invoked.

    access

    public

    [ Top ]

    TPage::setCallbackClient

    setCallbackClient( TCallbackClientScript $client );

    Parameters

    $client

    new callback client script handler.

    Remarks

    Set a new callback client handler.

    access

    public

    [ Top ]

    TPage::setCallbackEventParameter

    setCallbackEventParameter( mixed $value );

    Parameters

    $value

    callback event parameter

    access

    public

    [ Top ]

    TPage::setCallbackEventTarget

    setCallbackEventTarget( TControl $control );

    Parameters

    $control

    control registered to raise callback event.

    Remarks

    Registers a control to raise callback event in the current request.

    access

    public

    [ Top ]

    TPage::setClientState

    setClientState( string $state );

    Parameters

    $state

    the state to be stored on the client side

    Remarks

    Sets the state to be stored on the client side.

    This method should only be used by framework and control developers.

    access

    public

    [ Top ]

    TPage::setClientSupportsJavaScript

    setClientSupportsJavaScript( boolean $value );

    Parameters

    $value

    whether client supports javascript. If false, javascript will not be generated for controls.

    access

    public

    [ Top ]

    TPage::setEnableStateCompression

    setEnableStateCompression( boolean $value );

    Parameters

    $value

    whether page state should be compressed.

    since

    3.1.6

    access

    public

    [ Top ]

    TPage::setEnableStateEncryption

    setEnableStateEncryption( boolean $value );

    Parameters

    $value

    whether page state should be encrypted.

    access

    public

    [ Top ]

    TPage::setEnableStateValidation

    setEnableStateValidation( boolean $value );

    Parameters

    $value

    whether page state should be HMAC validated.

    access

    public

    [ Top ]

    TPage::setFocus

    setFocus( TControl|string $value );

    Parameters

    $value

    control to receive focus, or the ID of the element on the page to receive focus

    Remarks

    Sets input focus on a control after the page is rendered to users.

    access

    public

    [ Top ]

    TPage::setForm

    setForm( TForm $form );

    Parameters

    $form

    the form on the page

    Remarks

    Registers a TForm instance to the page.

    Note, a page can contain at most one TForm instance.

    throws

    TInvalidOperationException if this method is invoked twice or more.

    access

    public

    [ Top ]

    TPage::setHead

    setHead( THead $value );

    Parameters

    $value

    page head

    throws

    TInvalidOperationException if a head already exists

    access

    public

    [ Top ]

    TPage::setPagePath

    setPagePath( string $value );

    Parameters

    $value

    the requested page path for this page

    access

    public

    [ Top ]

    TPage::setPostBackEventParameter

    setPostBackEventParameter( string $value );

    Parameters

    $value

    postback event parameter

    access

    public

    [ Top ]

    TPage::setPostBackEventTarget

    setPostBackEventTarget( TControl $control );

    Parameters

    $control

    control registered to raise postback event.

    Remarks

    Registers a control to raise postback event in the current request.

    access

    public

    [ Top ]

    TPage::setStatePersisterClass

    setStatePersisterClass( string $value );

    Parameters

    $value

    class name of the page state persister.

    access

    public

    [ Top ]

    TPage::setStyleSheetTheme

    setStyleSheetTheme( string|TTheme $value );

    Parameters

    $value

    the stylesheet theme name or the stylesheet theme object to be used for the page.

    Remarks

    Sets the stylesheet theme to be used for the page.

    access

    public

    [ Top ]

    TPage::setTheme

    setTheme( string|TTheme $value );

    Parameters

    $value

    the theme name or the theme object to be used for the page.

    Remarks

    Sets the theme to be used for the page.

    access

    public

    [ Top ]

    TPage::setTitle

    setTitle( string $value );

    Parameters

    $value

    page title. This will override the title set in Head.

    Remarks

    Sets the page title.

    Note, a THead control needs to place on the page in order that this title be rendered.

    access

    public

    [ Top ]

    TPage::validate

    validate( [string $validationGroup = null] );

    Parameters

    $validationGroup

    validation group. If null, all validators will perform validation.

    Remarks

    Performs input validation.

    This method will invoke the registered validators to perform the actual validation. If validation group is specified, only the validators in that group will be invoked.

    access

    public

    [ Top ]

Variable Detail

  • $_controlsPostDataChanged = array() [line 95]
  • Data type: array

    • var

    list of controls whose data have been changed due to the postback

    access

    protected

  • $_controlsRegisteredForPostData = array() [line 103]
  • Data type: array

    • var

    list of controls that need to load post data in the next postback

    access

    protected

  • $_controlsRequiringPostData = array() [line 99]
  • Data type: array

    • var

    list of controls that need to load post data in the current request

    access

    protected

  • $_formRendered = false [line 115]
  • Data type: boolean

    • var

    whether the form has been rendered

    access

    protected

  • $_inFormRender = false [line 119]
  • Data type: boolean

    • var

    whether the current rendering is within a form

    access

    protected

  • $_isLoadingPostData = false [line 164]
  • Data type: boolean

    • var

    true if loading post data.

    access

    protected

  • $_postData = [line 87]
  • Data type: TMap

    • var

    data post back by user

    access

    protected

  • $_postDataLoaders = array() [line 160]
  • Data type: array

    • var

    post data loader IDs.

    access

    protected

  • $_restPostData = [line 91]
  • Data type: TMap

    • var

    postback data that is not handled during first invocation of LoadPostData.

    access

    protected

Class Constant Detail

  • FIELD_CALLBACK_PARAMETER = 'PRADO_CALLBACK_PARAMETER' [line 39]

  • FIELD_CALLBACK_TARGET = 'PRADO_CALLBACK_TARGET' [line 38]

  • FIELD_LASTFOCUS = 'PRADO_LASTFOCUS' [line 36]

  • FIELD_PAGESTATE = 'PRADO_PAGESTATE' [line 37]

  • FIELD_POSTBACK_PARAMETER = 'PRADO_POSTBACK_PARAMETER' [line 35]

  • FIELD_POSTBACK_TARGET = 'PRADO_POSTBACK_TARGET' [line 34]

    • Remarks

    system post fields

Documentation generated on Mon, 25 Jun 2012 14:44:57 +0200 by phpDocumentor 1.4.3


Docs For Class TPageStateFormatter

Class TPageStateFormatter

[line 1293]

Location: /Web/UI/TPage.php

Remarks

TPageStateFormatter class.

TPageStateFormatter is a utility class to transform the page state  into and from a string that can be properly saved in persistent storage.
Depending on the EnableStateValidation  and EnableStateEncryption,  TPageStateFormatter may do HMAC validation and encryption to prevent  the state data from being tampered or viewed.  The private keys and hashing/encryption methods are determined by  SecurityManager.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Revision: $  $Date: $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static string serialize()

  • static mixed unserialize()

  • string serialize()

  • mixed unserialize()

Inherited Method Summary

Method Detail

    static TPageStateFormatter::serialize

static serialize(
TPage
$page, mixed
$data );

    Parameters

    $page

    $data

    state data

    Returns

    serialized data

    access

    public

    [ Top ]

    static TPageStateFormatter::unserialize

static unserialize(
TPage
$page, string
$data );

    Parameters

    $page

    $data

    serialized data

    Returns

    unserialized state data, null if data is corrupted

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:58 +0200 by phpDocumentor 1.4.3


Docs For Class TPageStatePersister

Class TPageStatePersister

[line 29]
TComponent
   |
   --TPageStatePersister
Location: /Web/UI/TPageStatePersister.php

Remarks

TPageStatePersister class

TPageStatePersister implements a page state persistent method based on form hidden fields.

Since page state can be very big for complex pages, consider using alternative persisters, such as TSessionPageStatePersister, which store page state on the server side and thus reduce the network traffic for transmitting bulky page state.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPageStatePersister.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPageStatePersister::getPage

    getPage( );

    Implementation of:
    IPageStatePersister::getPage()

    Returns

    the page that this persister works for

    access

    public

    [ Top ]

    TPageStatePersister::load

    load( );

    Implementation of:
    IPageStatePersister::load()
    Loads page state from persistent storage

    Returns

    the restored state

    Remarks

    Loads page state from hidden fields.

    throws

    THttpException if page state is corrupted

    access

    public

    [ Top ]

    TPageStatePersister::save

    save( mixed $state );

    Implementation of:
    IPageStatePersister::save()
    Saves state to persistent storage.

    Parameters

    $state

    state to be stored

    Remarks

    Saves state in hidden fields.

    access

    public

    [ Top ]

    TPageStatePersister::setPage

    setPage( TPage $page );

    Implementation of:
    IPageStatePersister::setPage()

    Parameters

    $page

    the page that this persister works for

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:00 +0200 by phpDocumentor 1.4.3


Docs For Class TSessionPageStatePersister

Class TSessionPageStatePersister

[line 46]
TComponent
   |
   --TSessionPageStatePersister
Location: /Web/UI/TSessionPageStatePersister.php

Remarks

TSessionPageStatePersister class

TSessionPageStatePersister implements a page state persistent method based on sessions. Page state are stored in user sessions and therefore, this persister requires session to be started and available.

TSessionPageStatePersister keeps limited number of history states in session, mainly to preserve the precious server storage. The number is specified by HistorySize, which defaults to 10.

There are a couple of ways to use TSessionPageStatePersister. One can override the page's TPage::getStatePersister() method and create a TSessionPageStatePersister instance there. Or one can configure the pages to use TSessionPageStatePersister in page configurations as follows,

  •    <pages StatePersisterClass="System.Web.UI.TSessionPageStatePersister" />
    •
    The above configuration will affect the pages under the directory containing this configuration and all its subdirectories. To configure individual pages to use TSessionPageStatePersister, use
  •    <pages>
    •

  •      <page id="PageID" StatePersisterClass="System.Web.UI.TSessionPageStatePersister" />
    •

  •    </pages>
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TSessionPageStatePersister.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    • QUEUE_SESSION_KEY = 'PRADO_SESSION_STATEQUEUE'
    • STATE_SESSION_KEY = 'PRADO_SESSION_PAGESTATE'

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TSessionPageStatePersister::getHistorySize

      getHistorySize( );

      Returns

      maximum number of page states that should be kept in session. Defaults to 10.

      access

      public

      [ Top ]

      TSessionPageStatePersister::getPage

      getPage( TPage 0 );

      Implementation of:
      IPageStatePersister::getPage()

      Parameters

      0

      the page that this persister works for

      access

      public

      [ Top ]

      TSessionPageStatePersister::load

      load( );

      Implementation of:
      IPageStatePersister::load()
      Loads page state from persistent storage

      Returns

      the restored state

      Remarks

      Loads page state from session.

      throws

      THttpException if page state is corrupted

      access

      public

      [ Top ]

      TSessionPageStatePersister::save

      save( mixed $state );

      Implementation of:
      IPageStatePersister::save()
      Saves state to persistent storage.

      Parameters

      $state

      state to be stored

      Remarks

      Saves state in session.

      access

      public

      [ Top ]

      TSessionPageStatePersister::setHistorySize

      setHistorySize( integer $value );

      Parameters

      $value

      maximum number of page states that should be kept in session

      throws

      TInvalidDataValueException if the number is smaller than 1.

      access

      public

      [ Top ]

      TSessionPageStatePersister::setPage

      setPage( TPage $page );

      Implementation of:
      IPageStatePersister::setPage()

      Parameters

      $page

      the page that this persister works for.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • QUEUE_SESSION_KEY = 'PRADO_SESSION_STATEQUEUE' [line 49]

    • STATE_SESSION_KEY = 'PRADO_SESSION_PAGESTATE' [line 48]

    Documentation generated on Mon, 25 Jun 2012 14:45:21 +0200 by phpDocumentor 1.4.3


Docs For Class TTemplateControl

Class TTemplateControl

[line 30]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
Classes extended from TTemplateControl:
TScaffoldBase
Base class for Active Record scaffold views.
TPage
TPage class
TTemplateControlInheritable
TTemplateControlInheritable class.
TDataRenderer
TDataRenderer class

Location: /Web/UI/TTemplateControl.php

Remarks

TTemplateControl class.

TTemplateControl is the base class for all controls that use templates. By default, a control template is assumed to be in a file under the same directory with the control class file. They have the same file name and different extension name. For template file, the extension name is ".tpl".

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTemplateControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTemplateControl::createChildControls

    createChildControls( );

    Overridden in child classes as:

    TTemplateControlInheritable::createChildControls()
    Creates child controls.

    Overrides TControl::createChildControls() (Creates child controls.)

    Remarks

    Creates child controls.

    This method is overridden to load and instantiate control template. This method should only be used by framework and control developers.

    access

    public

    [ Top ]

    TTemplateControl::getIsSourceTemplateControl

    getIsSourceTemplateControl( );

    Overridden in child classes as:

    TTemplateControlInheritable::getIsSourceTemplateControl()
    A source template control loads its template from external storage, such as file, db, rather than from within another template.

    Returns

    whether this control is a source template control. A source template control loads its template from external storage, such as file, db, rather than from within another template.

    access

    public

    [ Top ]

    TTemplateControl::getMaster

    getMaster( );

    Returns

    master control associated with this control, null if none

    access

    public

    [ Top ]

    TTemplateControl::getMasterClass

    getMasterClass( );

    Returns

    master class name (in namespace form)

    access

    public

    [ Top ]

    TTemplateControl::getTemplate

    getTemplate( );

    Returns

    the parsed template, null if none

    Remarks

    Returns the template object associated with this control object.

    access

    public

    [ Top ]

    TTemplateControl::getTemplateDirectory

    getTemplateDirectory( );

    Returns

    the directory containing the template. Empty if no template available.

    access

    public

    [ Top ]

    TTemplateControl::initRecursive

    initRecursive( [TControl $namingContainer = null] );

    Overrides TCompositeControl::initRecursive() (Performs the OnInit step for the control and all its child controls.)

    Parameters

    $namingContainer

    the naming container control

    Remarks

    Performs the OnInit step for the control and all its child controls.

    This method overrides the parent implementation by ensuring child controls are created first, and if master class is set, master will be applied. Only framework developers should use this method.

    access

    protected

    [ Top ]

    TTemplateControl::injectContent

    injectContent( string $id, TContent $content );

    Parameters

    $id

    ID of the content control

    $content

    the content to be injected

    Remarks

    Injects all content controls (and their children) to the corresponding content placeholders.

    This method should only be used by framework and control developers.

    access

    public

    [ Top ]

    TTemplateControl::loadTemplate

    loadTemplate( );

    Returns

    the parsed template structure

    Remarks

    Loads the template associated with this control class.

    access

    protected

    [ Top ]

    TTemplateControl::registerContent

    registerContent( string $id, $object );

    Parameters

    $id

    ID of the content

    $object

    Remarks

    Registers a content control.

    access

    public

    [ Top ]

    TTemplateControl::registerContentPlaceHolder

    registerContentPlaceHolder( string $id, $object );

    Parameters

    $id

    placeholder ID

    $object

    placeholder control

    Remarks

    Registers a content placeholder to this template control.

    This method should only be used by framework and control developers.

    access

    public

    [ Top ]

    TTemplateControl::setMasterClass

    setMasterClass( string $value );

    Parameters

    $value

    master control class name (in namespace form)

    access

    public

    [ Top ]

    TTemplateControl::setTemplate

    setTemplate( ITemplate $value );

    Parameters

    $value

    the parsed template

    Remarks

    Sets the parsed template.

    Note, the template will be applied to the whole control class. This method should only be used by framework and control developers.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • EXT_TEMPLATE = '.tpl' [line 35]

    • Remarks

    template file extension.

Documentation generated on Mon, 25 Jun 2012 14:45:37 +0200 by phpDocumentor 1.4.3


Docs For Class TTemplateControlInheritable

Class TTemplateControlInheritable

[line 31]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TTemplateControlInheritable
Location: /Web/UI/TTemplateControlInheritable.php

Remarks

TTemplateControlInheritable class.

TTemplateControlInheritable is an extension to the base class for all controls that use templates. By default, a control template is assumed to be in a file under the same directory with the control class file. They have the same file name and different extension name. For template file, the extension name is ".tpl". If a TTemplateControlInheritable is inherited it uses the base class template unless the inheriting control defines an own.

author

Kyle Caine <http://www.pradosoft.com/forum/index.php?action=profile;u=1752>

author

Schlaue-Kids.net <info@schlaue-kids.net>

version

$Id$

since

3.1.8

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTemplateControl

  • TTemplateControl::EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TTemplateControl

  • TTemplateControl::createChildControls()
    Creates child controls.
  • TTemplateControl::getIsSourceTemplateControl()
  • TTemplateControl::getMaster()
  • TTemplateControl::getMasterClass()
  • TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
  • TTemplateControl::getTemplateDirectory()
  • TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
  • TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
  • TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
  • TTemplateControl::registerContent()
    Registers a content control.
  • TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
  • TTemplateControl::setMasterClass()
  • TTemplateControl::setTemplate()
    Sets the parsed template.

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTemplateControlInheritable::createChildControls

    createChildControls( );

    Overrides TTemplateControl::createChildControls() (Creates child controls.)

    Remarks

    Creates child controls.

    This method is overridden to load and instantiate control template. This method should only be used by framework and control developers. Uses the controls template if available or the base class template otherwise.

    throws

    TConfigurationException if a template control directive is invalid

    access

    public

    [ Top ]

    TTemplateControlInheritable::doCreateChildControlsFor

    doCreateChildControlsFor( string $parentClass );

    Parameters

    $parentClass

    The class to generate the child controls for

    Remarks

    This method creates the cild controls for the given class

    access

    public

    [ Top ]

    TTemplateControlInheritable::doTemplateForClass

    doTemplateForClass( $parentClass, string $p_class );

    Parameters

    $p_class

    The class to create the template from

    $parentClass

    Remarks

    This method creates the template object for the given class

    throws

    TConfigurationException if a template control directive is invalid

    access

    public

    [ Top ]

    TTemplateControlInheritable::getIsSourceTemplateControl

    getIsSourceTemplateControl( );

    Overrides TTemplateControl::getIsSourceTemplateControl() (parent method not documented)

    Returns

    whether the current control is a source template control

    Remarks

    A source template control loads its template from external storage, such as file, db, rather than from within another template.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:38 +0200 by phpDocumentor 1.4.3


Docs For Class TTemplate

Class TTemplate

[line 169]
TComponent
   |
   --TApplicationComponent
      |
      --TTemplate
Location: /Web/UI/TTemplateManager.php

Remarks

TTemplate implements PRADO template parsing logic.

A TTemplate object represents a parsed PRADO control template. It can instantiate the template as child controls of a specified control. The template format is like HTML, with the following special tags introduced,

  • component tags: a component tag represents the configuration of a component.
The tag name is in the format of com:ComponentType, where ComponentType is the component class name. Component tags must be well-formed. Attributes of the component tag are treated as either property initial values, event handler attachment, or regular tag attributes.
  • property tags: property tags are used to set large block of attribute values.
The property tag name is in the format of <prop:AttributeName> where AttributeName can be a property name, an event name or a regular tag attribute name.
  • group subproperty tags: subproperties of a common property can be configured using
<prop:MainProperty SubProperty1="Value1" SubProperty2="Value2" .../>
  • directive: directive specifies the property values for the template owner.
It is in the format of <%@ property name-value pairs %>;
  • expressions: They are in the format of <%= PHP expression %> and <%% PHP statements %>
  • comments: There are two kinds of comments, regular HTML comments and special template comments.
The former is in the format of <!-- comments -->, which will be treated as text strings. The latter is in the format of <!-- comments --!>, which will be stripped out.

Tags other than the above are not required to be well-formed.

A TTemplate object represents a parsed PRADO template. To instantiate the template for a particular control, call instantiateIn($control), which will create and intialize all components specified in the template and set their parent as $control.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTemplateManager.php 3121 2012-03-25 20:51:49Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • CONFIG_ASSET = 2
  • CONFIG_DATABIND = 0
    Different configurations of component property/event/attribute
  • CONFIG_EXPRESSION = 1
  • CONFIG_LOCALIZATION = 4
  • CONFIG_PARAMETER = 3
  • CONFIG_TEMPLATE = 5
  • REGEX_RULES = '/<!--.*?--!>|<!---.*?--->|<\/?com:([\w\.]+)((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?"|\s*[\w\.]+\s*=\s*<%.*?%>)*)\s*\/?>|<\/?prop:([\w\.]+)\s*>|<%@\s*((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?")*)\s*%>|<%[%#~\/\\$=\\[](.*?)%>|<prop:([\w\.]+)((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?"|\s*[\w\.]+\s*=\s*<%.*?%>)*)\s*\/>/msS'
    '<!--.*?--!>' - template comments

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTemplate::configureComponent

    configureComponent( TComponent $component, string $name, mixed $value );

    Parameters

    $component

    component to be configured

    $name

    property name

    $value

    property initial value

    Remarks

    Configures a property of a non-control component.

    access

    protected

    [ Top ]

    TTemplate::configureControl

    configureControl( TControl $control, string $name, mixed $value );

    Parameters

    $control

    control to be configured

    $name

    property name

    $value

    property initial value

    Remarks

    Configures a property/event of a control.

    access

    protected

    [ Top ]

    TTemplate::configureEvent

    configureEvent( TControl $control, string $name, string $value, TControl $contextControl );

    Parameters

    $control

    control to be configured

    $name

    event name

    $value

    event handler

    $contextControl

    context control

    Remarks

    Configures an event for a control.

    access

    protected

    [ Top ]

    TTemplate::configureProperty

    configureProperty( TComponent $component, string $name, mixed $value );

    Parameters

    $component

    component to be configured

    $name

    property name

    $value

    property initial value

    Remarks

    Configures a simple property for a component.

    access

    protected

    [ Top ]

    TTemplate::configureSubProperty

    configureSubProperty( TComponent $component, string $name, mixed $value );

    Parameters

    $component

    component to be configured

    $name

    subproperty name

    $value

    subproperty initial value

    Remarks

    Configures a subproperty for a component.

    access

    protected

    [ Top ]

    TTemplate::__construct

    __construct( string $template, string $contextPath, [string $tplFile = null], [integer $startingLine = 0], [boolean $sourceTemplate = true] );

    Parameters

    $template

    the template string

    $contextPath

    the template context directory

    $tplFile

    the template file, null if no file

    $startingLine

    the line number that parsing starts from (internal use)

    $sourceTemplate

    whether this template is a source template, i.e., this template is loaded from some external storage rather than from within another template.

    Remarks

    Constructor.

    The template will be parsed after construction.

    access

    public

    [ Top ]

    TTemplate::getContextPath

    getContextPath( );

    Returns

    context directory path

    access

    public

    [ Top ]

    TTemplate::getDirective

    getDirective( );

    Returns

    name-value pairs declared in the directive

    access

    public

    [ Top ]

    TTemplate::getHashCode

    getHashCode( );

    Returns

    hash code that can be used to identify the template

    access

    public

    [ Top ]

    TTemplate::getIncludedFiles

    getIncludedFiles( );

    Returns

    list of included external template files

    access

    public

    [ Top ]

    TTemplate::getIsSourceTemplate

    getIsSourceTemplate( );

    Returns

    whether this template is a source template, i.e., this template is loaded from some external storage rather than from within another template.

    access

    public

    [ Top ]

    TTemplate::getItems

    &getItems( );

    Returns

    the parsed template

    access

    public

    [ Top ]

    TTemplate::getTemplateFile

    getTemplateFile( );

    Returns

    template file path if available, null otherwise.

    access

    public

    [ Top ]

    TTemplate::handleException

    handleException( Exception $e, int $line, [string $input = null] );

    Parameters

    $e

    template exception

    $line

    line number

    $input

    template string if no source file is used

    Remarks

    Handles template parsing exception.

    This method rethrows the exception caught during template parsing. It adjusts the error location by giving out correct error line number and source file.

    access

    protected

    [ Top ]

    TTemplate::instantiateIn

    instantiateIn( TControl $tplControl, [TControl $parentControl = null] );

    Implementation of:
    ITemplate::instantiateIn()
    Instantiates the template.

    Parameters

    $tplControl

    the control who owns the template

    $parentControl

    the control who will become the root parent of the controls on the template. If null, it uses the template control.

    Remarks

    Instantiates the template.

    Content in the template will be instantiated as components and text strings and passed to the specified parent control.

    access

    public

    [ Top ]

    TTemplate::parse

    parse( string $input );

    Parameters

    $input

    the template string

    Remarks

    Parses a template string.

    This template parser recognizes five types of data: regular string, well-formed component tags, well-formed property tags, directives, and expressions.

    The parsing result is returned as an array. Each array element can be of three types:

    • a string, 0: container index; 1: string content;
    • a component tag, 0: container index; 1: component type; 2: attributes (name=>value pairs)
    If a directive is found in the template, it will be parsed and can be retrieved via getDirective, which returns an array consisting of name-value pairs in the directive.

    Note, attribute names are treated as case-insensitive and will be turned into lower cases. Component and directive types are case-sensitive. Container index is the index to the array element that stores the container object. If an object has no container, its container index is -1.

    throws

    TConfigurationException if a parsing error is encountered

    access

    protected

    [ Top ]

    TTemplate::parseAttribute

    parseAttribute( string $value );

    Parameters

    $value

    the string to be parsed.

    Returns

    attribute initialization

    Remarks

    Parses a single attribute.

    access

    protected

    [ Top ]

    TTemplate::parseAttributes

    parseAttributes( string $str, $offset );

    Parameters

    $str

    the string to be parsed.

    $offset

    Returns

    attribute values indexed by names.

    Remarks

    Parses the attributes of a tag from a string.

    access

    protected

    [ Top ]

    TTemplate::parseTemplateProperty

    parseTemplateProperty( $content, $offset );

    Parameters

    $content

    $offset

    access

    protected

    [ Top ]

    TTemplate::preprocess

    preprocess( string $input );

    Parameters

    $input

    template string

    Returns

    expanded template string

    Remarks

    Preprocesses the template string by including external templates

    access

    protected

    [ Top ]

    TTemplate::validateAttributes

    validateAttributes( $type, $attributes );

    Parameters

    $type

    $attributes

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

  • CONFIG_ASSET = 2 [line 187]

  • CONFIG_DATABIND = 0 [line 185]

    • Remarks

    Different configurations of component property/event/attribute

  • CONFIG_EXPRESSION = 1 [line 186]

  • CONFIG_LOCALIZATION = 4 [line 189]

  • CONFIG_PARAMETER = 3 [line 188]

  • CONFIG_TEMPLATE = 5 [line 190]

  • REGEX_RULES = '/<!--.*?--!>|<!---.*?--->|<\/?com:([\w\.]+)((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?"|\s*[\w\.]+\s*=\s*<%.*?%>)*)\s*\/?>|<\/?prop:([\w\.]+)\s*>|<%@\s*((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?")*)\s*%>|<%[%#~\/\\$=\\[](.*?)%>|<prop:([\w\.]+)((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?"|\s*[\w\.]+\s*=\s*<%.*?%>)*)\s*\/>/msS' [line 180]

    • Remarks

    '<!--.*?--!>' - template comments

    '<!--.*?-->' - HTML comments '<\/?com:([\w\.]+)((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?"|\s*[\w\.]+\s*=\s*<%.*?%>)*)\s*\/?>' - component tags '<\/?prop:([\w\.]+)\s*>' - property tags '<%@\s*((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?")*)\s*%>' - directives '<%[%#~\/\\$=\\[](.*?)%>' - expressions '<prop:([\w\.]+)((?:\s*[\w\.]+=\'.*?\'|\s*[\w\.]+=".*?"|\s*[\w\.]+=<%.*?%>)*)\s*\/>' - group subproperty tags

Documentation generated on Mon, 25 Jun 2012 14:45:38 +0200 by phpDocumentor 1.4.3


Docs For Class TTemplateManager

Class TTemplateManager

[line 39]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TTemplateManager
Location: /Web/UI/TTemplateManager.php

Remarks

TTemplateManager class

TTemplateManager manages the loading and parsing of control templates.

There are two ways of loading a template, either by the associated template control class name, or the template file name. The former is via calling getTemplateByClassName, which tries to locate the corresponding template file under the directory containing the class file. The name of the template file is the class name with the extension '.tpl'. To load a template from a template file path, call getTemplateByFileName.

By default, TTemplateManager is registered with TPageService as the template manager module that can be accessed via TPageService::getTemplateManager().

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTemplateManager.php 3121 2012-03-25 20:51:49Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • TEMPLATE_CACHE_PREFIX = 'prado:template:'
    Prefix of the cache variable name for storing parsed templates
  • TEMPLATE_FILE_EXT = '.tpl'
    Template file extension

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTemplateManager::getLocalizedTemplate

    getLocalizedTemplate( string $filename );

    Parameters

    $filename

    template file.

    Returns

    a localized template file if found, null otherwise.

    Remarks

    Finds a localized template file.

    access

    protected

    [ Top ]

    TTemplateManager::getTemplateByClassName

    getTemplateByClassName( $className );

    Parameters

    $className

    Returns

    template for the class name, null if template doesn't exist.

    Remarks

    Loads the template corresponding to the specified class name.

    access

    public

    [ Top ]

    TTemplateManager::getTemplateByFileName

    getTemplateByFileName( $fileName );

    Parameters

    $fileName

    Returns

    template parsed from the specified file, null if the file doesn't exist.

    Remarks

    Loads the template from the specified file.

    access

    public

    [ Top ]

    TTemplateManager::init

    init( TXmlElement $config );

    Overrides TModule::init() (Initializes the module.)

    Parameters

    $config

    module configuration

    Remarks

    Initializes the module.

    This method is required by IModule and is invoked by application. It starts output buffer if it is enabled.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • TEMPLATE_CACHE_PREFIX = 'prado:template:' [line 48]

    • Remarks

    Prefix of the cache variable name for storing parsed templates

  • TEMPLATE_FILE_EXT = '.tpl' [line 44]

    • Remarks

    Template file extension

Documentation generated on Mon, 25 Jun 2012 14:45:39 +0200 by phpDocumentor 1.4.3


Docs For Class TTextProcessor

Class TTextProcessor

[line 30]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextProcessor
Classes extended from TTextProcessor:
TTextHighlighter
TTextHighlighter class.

Location: /Web/UI/WebControls/TTextProcessor.php

Remarks

TTextProcessor class.

TTextProcessor is the base class for classes that process or transform text content into different forms. The text content to be processed is specified by Text property. If it is not set, the body content enclosed within the processor control will be processed and rendered. The body content includes static text strings and the rendering result of child controls.

Note, all child classes must implement processText method.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTextProcessor.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.0.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Inherited From Class TWebControl

  • TWebControl::$_decorator =

Method Summary

Inherited Method Summary

Inherited From Class TWebControl

  • TWebControl::addAttributesToRender()
    Adds attribute name-value pairs to renderer.
  • TWebControl::clearStyle()
    Removes all style data.
  • TWebControl::copyBaseAttributes()
    Copies basic control attributes from another control.
  • TWebControl::createStyle()
    Creates a style object to be used by the control.
  • TWebControl::getAccessKey()
  • TWebControl::getBackColor()
  • TWebControl::getBorderColor()
  • TWebControl::getBorderStyle()
  • TWebControl::getBorderWidth()
  • TWebControl::getCssClass()
  • TWebControl::getDecorator()
  • TWebControl::getDisplay()
  • TWebControl::getEnsureId()
  • TWebControl::getFont()
  • TWebControl::getForeColor()
  • TWebControl::getHasStyle()
  • TWebControl::getHeight()
  • TWebControl::getStyle()
  • TWebControl::getTabIndex()
  • TWebControl::getTagName()
    Returns the tag name used for this control.
  • TWebControl::getToolTip()
  • TWebControl::getWidth()
  • TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
  • TWebControl::render()
    Renders the control.
  • TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
  • TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
  • TWebControl::renderEndTag()
    Renders the closing tag for the control
  • TWebControl::setAccessKey()
    Sets the access key of the control.
  • TWebControl::setBackColor()
  • TWebControl::setBorderColor()
  • TWebControl::setBorderStyle()
  • TWebControl::setBorderWidth()
  • TWebControl::setCssClass()
  • TWebControl::setDisplay()
  • TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
  • TWebControl::setForeColor()
  • TWebControl::setHeight()
  • TWebControl::setStyle()
    Sets the css style string of the control.
  • TWebControl::setTabIndex()
    Sets the tab index of the control.
  • TWebControl::setToolTip()
    Sets the tooltip of the control.
  • TWebControl::setWidth()

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTextProcessor::addParsedObject

    addParsedObject( mixed $object );

    Overrides TControl::addParsedObject() (Adds the object instantiated on a template to the child control collection.)

    Parameters

    $object

    object to be added as body content

    Remarks

    HTML-decodes static text.

    This method overrides parent implementation.

    access

    public

    [ Top ]

    TTextProcessor::getText

    getText( );

    Returns

    text to be processed

    access

    public

    [ Top ]

    TTextProcessor::processText

    processText( string $text );

    Overridden in child classes as:

    TTextHighlighter::processText()
    Processes a text string.
    TMarkdown::processText()
    Processes a text string.

    Parameters

    $text

    text string to be processed

    Returns

    the processed text result

    Remarks

    Processes a text string.

    This method must be implemented by child classes.

    abstract

    access

    public

    [ Top ]

    TTextProcessor::renderContents

    renderContents( THtmlWriter $writer );

    Overrides TWebControl::renderContents() (Renders the body content enclosed between the control tag.)

    Parameters

    $writer

    writer

    Remarks

    Renders body content.

    This method overrides the parent implementation by replacing the body content with the processed text content.

    access

    public

    [ Top ]

    TTextProcessor::setText

    setText( string $value );

    Parameters

    $value

    text to be processed

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:40 +0200 by phpDocumentor 1.4.3


Docs For Class TTheme

Class TTheme

[line 213]
TComponent
   |
   --TApplicationComponent
      |
      --TTheme
Location: /Web/UI/TThemeManager.php

Remarks

TTheme class

TTheme represents a particular theme. It is merely a collection of skins that are applicable to the corresponding controls.

Each theme is stored as a directory and files under that directory. The theme name is the directory name. When TTheme is created, the files whose name has the extension ".skin" are parsed and saved as controls skins.

A skin is essentially a list of initial property values that are to be applied to a control when the skin is applied. Each type of control can have multiple skins identified by the SkinID. If a skin does not have SkinID, it is the default skin that will be applied to controls that do not specify particular SkinID.

Whenever possible, TTheme will try to make use of available cache to save the parsing time.

To apply a theme to a particular control, call applySkin.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TThemeManager.php 3035 2011-08-30 13:58:52Z GODZilla0480@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • SKIN_FILE_EXT = '.skin'
    Extension name of skin files
  • THEME_CACHE_PREFIX = 'prado:theme:'
    prefix for cache variable name used to store parsed themes

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTheme::__construct

    __construct( string $themePath, string $themeUrl );

    Parameters

    $themePath

    theme path

    $themeUrl

    theme URL

    Remarks

    Constructor.

    throws

    TConfigurationException if theme path does not exist or any parsing error of the skin files

    access

    public

    [ Top ]

    TTheme::applySkin

    applySkin( TControl $control );

    Implementation of:
    ITheme::applySkin()
    Applies this theme to the specified control.

    Parameters

    $control

    the control to be applied with a skin

    Returns

    if a skin is successfully applied

    Remarks

    Applies the theme to a particular control.

    The control's class name and SkinID value will be used to identify which skin to be applied. If the control's SkinID is empty, the default skin will be applied.

    throws

    TConfigurationException if any error happened during the skin application

    access

    public

    [ Top ]

    TTheme::getBasePath

    getBasePath( );

    Returns

    the file path to the theme folder

    access

    public

    [ Top ]

    TTheme::getBaseUrl

    getBaseUrl( );

    Returns

    the URL to the theme folder (without ending slash)

    access

    public

    [ Top ]

    TTheme::getJavaScriptFiles

    getJavaScriptFiles( );

    Returns

    list of Javascript files (URL) in the theme

    access

    public

    [ Top ]

    TTheme::getName

    getName( );

    Returns

    theme name

    access

    public

    [ Top ]

    TTheme::getSkins

    getSkins( );

    Returns

    list of skins for the theme

    access

    public

    [ Top ]

    TTheme::getStyleSheetFiles

    getStyleSheetFiles( );

    Returns

    list of CSS files (URL) in the theme

    access

    public

    [ Top ]

    TTheme::setBasePath

    setBasePath( string $value );

    Parameters

    $value

    tthe file path to the theme folder

    access

    protected

    [ Top ]

    TTheme::setBaseUrl

    setBaseUrl( string $value );

    Parameters

    $value

    the URL to the theme folder

    access

    protected

    [ Top ]

    TTheme::setJavaScriptFiles

    setJavaScriptFiles( array $value );

    Parameters

    $value

    list of Javascript files (URL) in the theme

    access

    protected

    [ Top ]

    TTheme::setName

    setName( string $value );

    Parameters

    $value

    theme name

    access

    protected

    [ Top ]

    TTheme::setSkins

    setSkins( array $value );

    Parameters

    $value

    list of skins for the theme

    access

    protected

    [ Top ]

    TTheme::setStyleSheetFiles

    setStyleSheetFiles( array $value );

    Parameters

    $value

    list of CSS files (URL) in the theme

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

  • SKIN_FILE_EXT = '.skin' [line 222]

    • Remarks

    Extension name of skin files

  • THEME_CACHE_PREFIX = 'prado:theme:' [line 218]

    • Remarks

    prefix for cache variable name used to store parsed themes

Documentation generated on Mon, 25 Jun 2012 14:45:41 +0200 by phpDocumentor 1.4.3


Docs For Class TThemeManager

Class TThemeManager

[line 41]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TThemeManager
Location: /Web/UI/TThemeManager.php

Remarks

TThemeManager class

TThemeManager manages the themes used in a Prado application.

Themes are stored under the directory specified by the BasePath property. The themes can be accessed via URL BaseUrl. Each theme is represented by a subdirectory and all the files under that directory. The name of a theme is the name of the corresponding subdirectory. By default, the base path of all themes is a directory named "themes" under the directory containing the application entry script. To get a theme (normally you do not need to), call getTheme.

TThemeManager may be configured within page service tag in application configuration file as follows, <module id="themes" class="System.Web.UI.TThemeManager" BasePath="Application.themes" BaseUrl="/themes" /> where getCacheExpire, getCacheControl and getBufferOutput are configurable properties of THttpResponse.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TThemeManager.php 3035 2011-08-30 13:58:52Z GODZilla0480@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • DEFAULT_BASEPATH = 'themes'
    default themes base path
  • DEFAULT_THEMECLASS =  'TTheme'
    default theme class

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TThemeManager::getAvailableThemes

    getAvailableThemes( );

    Returns

    list of available theme names

    access

    public

    [ Top ]

    TThemeManager::getBasePath

    getBasePath( );

    Returns

    the base path for all themes. It is returned as an absolute path.

    throws

    TConfigurationException if base path is not set and "themes" directory does not exist.

    access

    public

    [ Top ]

    TThemeManager::getBaseUrl

    getBaseUrl( );

    Returns

    the base URL for all themes.

    throws

    TConfigurationException If base URL is not set and a correct one cannot be determined by Prado.

    access

    public

    [ Top ]

    TThemeManager::getTheme

    getTheme( string $name );

    Parameters

    $name

    name of the theme to be retrieved

    Returns

    the theme retrieved

    access

    public

    [ Top ]

    TThemeManager::getThemeClass

    getThemeClass( );

    Returns

    Theme class name in namespace format. Defaults to DEFAULT_THEMECLASS.

    access

    public

    [ Top ]

    TThemeManager::init

    init( TXmlElement $config );

    Overrides TModule::init() (Initializes the module.)

    Parameters

    $config

    module configuration

    Remarks

    Initializes the module.

    This method is required by IModule and is invoked by application.

    access

    public

    [ Top ]

    TThemeManager::setBasePath

    setBasePath( string $value );

    Parameters

    $value

    the base path for all themes. It must be in the format of a namespace.

    throws

    TInvalidDataValueException if the base path is not a proper namespace.

    access

    public

    [ Top ]

    TThemeManager::setBaseUrl

    setBaseUrl( string $value );

    Parameters

    $value

    the base URL for all themes.

    access

    public

    [ Top ]

    TThemeManager::setThemeClass

    setThemeClass( string|null $class );

    Parameters

    $class

    Theme class name in namespace format

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • DEFAULT_BASEPATH = 'themes' [line 46]

    • Remarks

    default themes base path

  • DEFAULT_THEMECLASS =  'TTheme' [line 51]

    • Remarks

    default theme class

Documentation generated on Mon, 25 Jun 2012 14:45:41 +0200 by phpDocumentor 1.4.3


Package System.I18N Element Index

Element index for package System.I18N

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
f g h i k r s t
top
f
$formatter in file TDateFormat.php, variable TDateFormat::$formatter
Default DateFormat, set to the application culture.
$formatter in file TNumberFormat.php, variable TNumberFormat::$formatter
Default NumberFormat, set to the application culture.
$formatters in file Translation.php, variable Translation::$formatters
The array of formatters. We define 1 formatter per translation catalog This is a class static variable.
formatter in file Translation.php, method Translation::formatter()
Get the static formatter from this component.
top
g
getCatalogue in file TTranslate.php, method TTranslate::getCatalogue()
Get the message catalogue.
getCharset | in file TGlobalization.php, method TGlobalization::getCharset()
getCharset in file TI18NControl.php, method TI18NControl::getCharset()
Gets the charset.
getCulture | in file TGlobalization.php, method TGlobalization::getCulture()
getCulture in file TI18NControl.php, method TI18NControl::getCulture()
Get the specific culture for this control.
getCultureVariants in file TGlobalization.php, method TGlobalization::getCultureVariants()
Gets all the variants of a specific culture. If the parameter $culture is null, the current culture is used.
getCurrency | in file TNumberFormat.php, method TNumberFormat::getCurrency()
getData in file TNumberFormat.php, method TNumberFormat::getData()
Get the numberic value for this control.
getData in file TDateFormat.php, method TDateFormat::getData()
Get the date-time value for this control.
getDefaultCharset | in file TGlobalization.php, method TGlobalization::getDefaultCharset()
getDefaultCulture | in file TGlobalization.php, method TGlobalization::getDefaultCulture()
getDefaultText in file TDateFormat.php, method TDateFormat::getDefaultText()
Get the default text value for this control.
getDefaultText in file TNumberFormat.php, method TNumberFormat::getDefaultText()
Get the default text value for this control.
getDetectedLanguage | in file TGlobalizationAutoDetect.php, method TGlobalizationAutoDetect::getDetectedLanguage()
getFormattedDate in file TDateFormat.php, method TDateFormat::getFormattedDate()
Renders the localized version of the date-time value.
getFormattedValue in file TNumberFormat.php, method TNumberFormat::getFormattedValue()
Formats the localized number, be it currency or decimal, or percentage.
getKey in file TTranslateParameter.php, method TTranslateParameter::getKey()
Get the parameter substitution key.
getKey in file TTranslate.php, method TTranslate::getKey()
Get the key for message lookup.
getLocalizedResource in file TGlobalization.php, method TGlobalization::getLocalizedResource()
Returns a list of possible localized files. Example
getParameter | in file TTranslate.php, method TTranslate::getParameter()
getParameter | in file TTranslateParameter.php, method TTranslateParameter::getParameter()
getParameters in file TTranslate.php, method TTranslate::getParameters()
Returns the list of custom parameters.
getPattern in file TNumberFormat.php, method TNumberFormat::getPattern()
Get the number formatting pattern.
getPattern in file TDateFormat.php, method TDateFormat::getPattern()
Gets the date time format pattern.
getPreset in file TDateFormat.php, method TDateFormat::getPreset()
For a given string, try and find a preset pattern.
getText | in file TTranslate.php, method TTranslate::getText()
getTranslateDefaultCulture | in file TGlobalization.php, method TGlobalization::getTranslateDefaultCulture()
getTranslationCatalogue | in file TGlobalization.php, method TGlobalization::getTranslationCatalogue()
getTranslationConfiguration | in file TGlobalization.php, method TGlobalization::getTranslationConfiguration()
getTrim in file TTranslateParameter.php, method TTranslateParameter::getTrim()
Trim the content or not.
getTrim in file TTranslate.php, method TTranslate::getTrim()
Trim the content or not.
getType in file TNumberFormat.php, method TNumberFormat::getType()
Get the formatting type for this control.
getValue | in file TTranslateParameter.php, method TTranslateParameter::getValue()
getValue | in file TChoiceFormat.php, method TChoiceFormat::getValue()
getValue in file TNumberFormat.php, method TNumberFormat::getValue()
Get the numberic value for this control.
getValue in file TDateFormat.php, method TDateFormat::getValue()
Get the date-time value for this control.
top
h
hasParameter | in file TTranslate.php, method TTranslate::hasParameter()
top
i
init in file Translation.php, method Translation::init()
Initialize the TTranslate translation components
init | in file TGlobalizationAutoDetect.php, method TGlobalizationAutoDetect::init()
init in file TGlobalization.php, method TGlobalization::init()
Initialize the Culture and Charset for this application.
top
k
$key in file TTranslateParameter.php, variable TTranslateParameter::$key
The substitution key.
top
r
removeParameter in file TTranslate.php, method TTranslate::removeParameter()
Removes the named parameter.
render in file TTranslate.php, method TTranslate::render()
renders the translated string.
render | in file TNumberFormat.php, method TNumberFormat::render()
render | in file TDateFormat.php, method TDateFormat::render()
top
s
saveMessages in file Translation.php, method Translation::saveMessages()
Save untranslated messages to the catalogue.
setCatalogue in file TTranslate.php, method TTranslate::setCatalogue()
Set the message catalogue.
setCharset | in file TGlobalization.php, method TGlobalization::setCharset()
setCharset in file TI18NControl.php, method TI18NControl::setCharset()
Sets the charset for message output
setCulture in file TI18NControl.php, method TI18NControl::setCulture()
Get the custom culture identifier.
setCulture | in file TGlobalization.php, method TGlobalization::setCulture()
setCurrency in file TNumberFormat.php, method TNumberFormat::setCurrency()
Set the 3-letter ISO 4217 code. For example, the code "USD" represents the US Dollar and "EUR" represents the Euro currency.
setData in file TDateFormat.php, method TDateFormat::setData()
Set the date-time value for this control.
setData in file TNumberFormat.php, method TNumberFormat::setData()
Set the numberic value for this control.
setDefaultCharset | in file TGlobalization.php, method TGlobalization::setDefaultCharset()
setDefaultCulture | in file TGlobalization.php, method TGlobalization::setDefaultCulture()
setDefaultText in file TNumberFormat.php, method TNumberFormat::setDefaultText()
Set the default text value for this control.
setDefaultText in file TDateFormat.php, method TDateFormat::setDefaultText()
Set the default text value for this control.
setKey in file TTranslate.php, method TTranslate::setKey()
Set the key for message lookup.
setKey in file TTranslateParameter.php, method TTranslateParameter::setKey()
Set the parameter substitution key.
setParameter | in file TTranslate.php, method TTranslate::setParameter()
setPattern in file TNumberFormat.php, method TNumberFormat::setPattern()
Set the number format pattern.
setPattern in file TDateFormat.php, method TDateFormat::setPattern()
Sets the date time formatting pattern.
setText in file TTranslate.php, method TTranslate::setText()
Sets the text for localization.
setTranslateDefaultCulture | in file TGlobalization.php, method TGlobalization::setTranslateDefaultCulture()
setTranslationCatalogue | in file TGlobalization.php, method TGlobalization::setTranslationCatalogue()
setTranslationConfiguration in file TGlobalization.php, method TGlobalization::setTranslationConfiguration()
Sets the translation configuration. Example configuration:
setTrim in file TTranslateParameter.php, method TTranslateParameter::setTrim()
Set the option to trim the contents.
setTrim in file TTranslate.php, method TTranslate::setTrim()
Set the option to trim the contents.
setType in file TNumberFormat.php, method TNumberFormat::setType()
Set the formatting type for this control.
setValue | in file TTranslateParameter.php, method TTranslateParameter::setValue()
setValue in file TDateFormat.php, method TDateFormat::setValue()
Set the date-time value for this control.
setValue in file TNumberFormat.php, method TNumberFormat::setValue()
Set the numberic value for this control.
setValue in file TChoiceFormat.php, method TChoiceFormat::setValue()
Sets the numerical choice value
top
t
$trim in file TTranslateParameter.php, variable TTranslateParameter::$trim
To trim or not to trim the contents.
TChoiceFormat.php | procedural page TChoiceFormat.php
TDateFormat.php | procedural page TDateFormat.php
TGlobalization.php | procedural page TGlobalization.php
TGlobalizationAutoDetect.php | procedural page TGlobalizationAutoDetect.php
TI18NControl.php | procedural page TI18NControl.php
TNumberFormat.php | procedural page TNumberFormat.php
Translation.php | procedural page Translation.php
TTranslate.php | procedural page TTranslate.php
TTranslateParameter.php | procedural page TTranslateParameter.php
TChoiceFormat in file TChoiceFormat.php, class TChoiceFormat
TChoiceFormat class.
TDateFormat in file TDateFormat.php, class TDateFormat
To format dates and/or time according to the current locale use
TGlobalization in file TGlobalization.php, class TGlobalization
TGlobalization contains settings for Culture, Charset and TranslationConfiguration.
TGlobalizationAutoDetect in file TGlobalizationAutoDetect.php, class TGlobalizationAutoDetect
TGlobalizationAutoDetect class will automatically try to resolve the default culture using the user browser language settings.
TI18NControl in file TI18NControl.php, class TI18NControl
TI18NControl class.
TNumberFormat in file TNumberFormat.php, class TNumberFormat
To format numbers in locale sensitive manner use
translateText in file TChoiceFormat.php, method TChoiceFormat::translateText()
Display the choosen translated string.
translateText in file TTranslate.php, method TTranslate::translateText()
Translates the text with subsititution.
Translation in file Translation.php, class Translation
Translation class.
TTranslate in file TTranslate.php, class TTranslate
TTranslate class.
TTranslateParameter in file TTranslateParameter.php, class TTranslateParameter
TTranslateParameter component should be used inside the TTranslate component to allow parameter substitution.


Class Trees for Package System.I18N

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TChoiceFormat.php

File: /I18N/TChoiceFormat.php

Remarks

TChoiceFormat, I18N choice format component.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TChoiceFormat.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TChoiceFormat
TChoiceFormat class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:46 +0200 by phpDocumentor 1.4.3


Docs for page TDateFormat.php

File: /I18N/TDateFormat.php

Remarks

TDateFromat formatting component.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDateFormat.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDateFormat
To format dates and/or time according to the current locale use

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:08 +0200 by phpDocumentor 1.4.3


Docs for page TGlobalization.php

File: /I18N/TGlobalization.php

Remarks

TGlobalization class file.

author

Wei Zhuo<weizhuo[at]gmail[dot]com>

version

$Id: TGlobalization.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TGlobalization
TGlobalization contains settings for Culture, Charset and TranslationConfiguration.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:22 +0200 by phpDocumentor 1.4.3


Docs for page TGlobalizationAutoDetect.php

File: /I18N/TGlobalizationAutoDetect.php

Remarks

TMultiView and TView class file.

author

Wei Zhuo<weizhuo[at]gmail[dot]com>

version

$Revision: 1.66 $ $Date: ${DATE} ${TIME} $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TGlobalizationAutoDetect
TGlobalizationAutoDetect class will automatically try to resolve the default culture using the user browser language settings.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:22 +0200 by phpDocumentor 1.4.3


Docs for page TI18NControl.php

File: /I18N/TI18NControl.php

Remarks

Base I18N component.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TI18NControl.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TI18NControl
TI18NControl class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:32 +0200 by phpDocumentor 1.4.3


Docs for page TNumberFormat.php

File: /I18N/TNumberFormat.php

Remarks

TNumberFromat component.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TNumberFormat.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TNumberFormat
To format numbers in locale sensitive manner use

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:54 +0200 by phpDocumentor 1.4.3


Docs for page Translation.php

File: /I18N/Translation.php

Remarks

Translation, static.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: Translation.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
Translation
Translation class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:08 +0200 by phpDocumentor 1.4.3


Docs for page TTranslate.php

File: /I18N/TTranslate.php

Remarks

TTranslate, I18N translation component.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TTranslate.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTranslate
TTranslate class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:42 +0200 by phpDocumentor 1.4.3


Docs for page TTranslateParameter.php

File: /I18N/TTranslateParameter.php

Remarks

TTranslateParameter component.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TTranslateParameter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTranslateParameter
TTranslateParameter component should be used inside the TTranslate component to allow parameter substitution.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:42 +0200 by phpDocumentor 1.4.3


Docs For Class TChoiceFormat

Class TChoiceFormat

[line 77]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TI18NControl
            |
            --TTranslate
               |
               --TChoiceFormat
Location: /I18N/TChoiceFormat.php

Remarks

TChoiceFormat class.

This component performs message/string choice translation. The translation source is set in the TGlobalization module. The following example demonstrates a simple 2 choice message translation.

  •  <com:TChoiceFormat Value="1">[1] One Apple. |[2] Two Apples</com:TChoiceFormat>
    •

    The Choice has Value "1" (one), thus the translated string is "One Apple". If the Value is "2", then it will show "Two Apples".

    The message/string choices are separated by the pipe "|" followed by a set notation of the form

    • <tt>[1,2]</tt> -- accepts values between 1 and 2, inclusive.
    • <tt>(1,2)</tt> -- accepts values between 1 and 2, excluding 1 and 2.
    • <tt>{1,2,3,4}</tt> -- only values defined in the set are accepted.
    • <tt>[-Inf,0)</tt> -- accepts value greater or equal to negative infinity and strictly less than 0
    Any non-empty combinations of the delimiters of square and round brackets are acceptable.

    The string choosen for display depends on the Value property. The Value is evaluated for each set until the Value is found to belong to a particular set.

    Properties

    • Value, float,
      Gets or sets the Value that determines which string choice to display.
    Since version 3.1.2 the following set notation is also possible.

    • <tt>{n: n % 10 > 1 && n % 10 < 5}</tt> -- matches numbers like 2, 3, 4, 22, 23, 24
    Where set is defined by the expression after <tt>n:</tt>. In particular, the expression accepts the following mathematical/logical operators to form a set of logical conditions on the value given by <tt>n</tt>:
    • <tt>&lt;</tt> -- less than.
    • <tt>&lt;=</tt> -- less than equals.
    • <tt>&gt;</tt> -- greater than.
    • <tt>&gt=</tt> -- greater than equals.
    • <tt>==</tt> -- of equal value.
    • <tt>%</tt> -- modulo, e.g., 1 % 10 equals 1, 11 % 10 equals 1.
    • <tt>-</tt> -- minus, negative.
    • <tt>+</tt> -- addition.
    • <tt>&amp;</tt> -- conditional AND.
    • <tt>&amp;&amp;</tt> -- condition AND with short circuit.
    • <tt>|</tt> -- conditional OR.
    • <tt>||</tt> -- conditional OR with short circuit.
    • <tt>!</tt> -- negation.
    Additional round brackets can also be used to perform grouping.

    author

    Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    v1.0, last update on Fri Dec 24 21:38:49 EST 2004

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TTranslate

    • TTranslate::getCatalogue()
      Get the message catalogue.
    • TTranslate::getKey()
      Get the key for message lookup.
    • TTranslate::getParameter()
    • TTranslate::getParameters()
      Returns the list of custom parameters.
    • TTranslate::getText()
    • TTranslate::getTrim()
      Trim the content or not.
    • TTranslate::hasParameter()
    • TTranslate::removeParameter()
      Removes the named parameter.
    • TTranslate::render()
      renders the translated string.
    • TTranslate::setCatalogue()
      Set the message catalogue.
    • TTranslate::setKey()
      Set the key for message lookup.
    • TTranslate::setParameter()
    • TTranslate::setText()
      Sets the text for localization.
    • TTranslate::setTrim()
      Set the option to trim the contents.
    • TTranslate::translateText()
      Translates the text with subsititution.

    Inherited From Class TI18NControl

    • TI18NControl::getCharset()
      Gets the charset.
    • TI18NControl::getCulture()
      Get the specific culture for this control.
    • TI18NControl::setCharset()
      Sets the charset for message output
    • TI18NControl::setCulture()
      Get the custom culture identifier.

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TChoiceFormat::getValue

      getValue( );

      Returns

      the numerical value.

      access

      public

      [ Top ]

      TChoiceFormat::setValue

      setValue( float $value );

      Parameters

      $value

      the choice value

      Remarks

      Sets the numerical choice value

      access

      public

      [ Top ]

      TChoiceFormat::translateText

      translateText( $text, $subs );

      Overrides TTranslate::translateText() (Translates the text with subsititution.)

      Parameters

      $text

      $subs

      Remarks

      Display the choosen translated string.

      Overrides the parent method, also calls parent's renderBody to translate.

      access

      protected

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:43:46 +0200 by phpDocumentor 1.4.3


Docs For Class TDateFormat

Class TDateFormat

[line 62]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TI18NControl
            |
            --TDateFormat
Location: /I18N/TDateFormat.php

Remarks

To format dates and/or time according to the current locale use

  •  <com:TDateFormat Pattern="dd:MMM:yyyy" Value="01/01/2001" />
    •
    The date will be formatted according to the current locale (or culture) using the format specified by 'Pattern' attribute.

    To format date and/or time for a locale (e.g. de_DE) include a Culture attribute, for example:

  •  <com:TDateFormat Culture="de_DE" Value="01/01/2001 12:00" />
    •
    The date will be formatted according to this format.

    If no Pattern was specified then the date will be formatted with the default format (both date and time). If no value for the date is specified then the current date will be used. E.g.:

  • <com:TDateFormat />
    •
    will result in the current date, formatted with default localized pattern.

    Namespace: System.I18N

    Properties

    • Value, date,
      Gets or sets the date to format. The tag content is used as Value if the Value property is not specified.
    • Pattern, string,
      Gets or sets the formatting pattern. The predefined patterns are 'fulldate', 'longdate', 'mediumdate', 'shortdate', 'fulltime',
    'longtime', 'mediumtime', and 'shorttime'. Custom patterns can specified when the Pattern property does not match the predefined patterns.
    • DefaultText, string,
      Gets or sets the default text. If Value is not set, DefaultText will be
    shown instead of todays date and time.

    author

    Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    v1.0, last update on Sat Dec 11 15:25:11 EST 2004

    Class Variable Summary

    • static $formatter =
      Default DateFormat, set to the application culture.

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TI18NControl

    • TI18NControl::getCharset()
      Gets the charset.
    • TI18NControl::getCulture()
      Get the specific culture for this control.
    • TI18NControl::setCharset()
      Sets the charset for message output
    • TI18NControl::setCulture()
      Get the custom culture identifier.

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TDateFormat::getData

      getData( );

      Returns

      date time value.

      Remarks

      Get the date-time value for this control.

      This method is required by IDataRenderer. It is the same as getValue().

      see

      TDateFormat::getValue()

      since

      3.1.2

      access

      public

      [ Top ]

      TDateFormat::getDefaultText

      getDefaultText( );

      Returns

      default text value

      Remarks

      Get the default text value for this control.

      access

      public

      [ Top ]

      TDateFormat::getFormattedDate

      getFormattedDate( );

      Remarks

      Renders the localized version of the date-time value.

      If the culture is not specified, the default application culture will be used. This method overrides parent's implementation.

      access

      protected

      [ Top ]

      TDateFormat::getPattern

      getPattern( );

      Returns

      format pattern.

      Remarks

      Gets the date time format pattern.

      access

      public

      [ Top ]

      TDateFormat::getPreset

      getPreset( string $string );

      Parameters

      $string

      the preset pattern name

      Returns

      a preset pattern if found, null otherwise.

      Remarks

      For a given string, try and find a preset pattern.

      access

      protected

      [ Top ]

      TDateFormat::getValue

      getValue( );

      Returns

      date time value.

      Remarks

      Get the date-time value for this control.

      access

      public

      [ Top ]

      TDateFormat::render

      render( $writer );

      Overrides TControl::render() (Renders the control.)

      Parameters

      $writer

      access

      public

      [ Top ]

      TDateFormat::setData

      setData( string $value );

      Parameters

      $value

      the date-time value.

      Remarks

      Set the date-time value for this control.

      This method is required by IDataRenderer. It is the same as setValue().

      see

      TDateFormat::setValue()

      since

      3.1.2

      access

      public

      [ Top ]

      TDateFormat::setDefaultText

      setDefaultText( string $value );

      Parameters

      $value

      default text value

      Remarks

      Set the default text value for this control.

      access

      public

      [ Top ]

      TDateFormat::setPattern

      setPattern( string $value );

      Parameters

      $value

      format pattern.

      Remarks

      Sets the date time formatting pattern.

      access

      public

      [ Top ]

      TDateFormat::setValue

      setValue( string $value );

      Parameters

      $value

      the date-time value.

      Remarks

      Set the date-time value for this control.

      access

      public

      [ Top ]

    Variable Detail

    • static $formatter = [line 68]
    • Data type: DateFormat

      • Remarks

      Default DateFormat, set to the application culture.

      access

      protected

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:08 +0200 by phpDocumentor 1.4.3


Docs For Class TGlobalization

Class TGlobalization

[line 27]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TGlobalization
Classes extended from TGlobalization:
TGlobalizationAutoDetect
TGlobalizationAutoDetect class will automatically try to resolve the default culture using the user browser language settings.

Location: /I18N/TGlobalization.php

Remarks

TGlobalization contains settings for Culture, Charset and TranslationConfiguration.

TGlobalization can be subclassed to change how the Culture, Charset are determined. See TGlobalizationAutoDetect for example of setting the Culture based on browser settings.

author

Wei Zhuo<weizhuo[at]gmail[dot]com>

version

$Revision: 1.66 $ $Date: ${DATE} ${TIME} $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TGlobalization::getCharset

    getCharset( );

    Returns

    localization charset

    access

    public

    [ Top ]

    TGlobalization::getCulture

    getCulture( );

    Returns

    current application culture

    access

    public

    [ Top ]

    TGlobalization::getCultureVariants

    getCultureVariants( [string $culture = null] );

    Parameters

    $culture

    the Culture string

    Returns

    variants of the culture.

    Remarks

    Gets all the variants of a specific culture. If the parameter $culture is null, the current culture is used.

    access

    public

    [ Top ]

    TGlobalization::getDefaultCharset

    getDefaultCharset( );

    Returns

    default charset set

    access

    public

    [ Top ]

    TGlobalization::getDefaultCulture

    getDefaultCulture( );

    Returns

    default culture

    access

    public

    [ Top ]

    TGlobalization::getLocalizedResource

    getLocalizedResource( string $file, [string $culture = null] );

    Parameters

    $file

    filename

    $culture

    culture string, null to use current culture

    Returns

    list of possible localized resource files.

    Remarks

    Returns a list of possible localized files. Example

  •  $files = $app->getLocalizedResource("path/to/Home.page","en_US");
    •
    will return
     array
   0 => 'path/to/en_US/Home.page'
   1 => 'path/to/en/Home.page'
   2 => 'path/to/Home.en_US.page'
   3 => 'path/to/Home.en.page'
   4 => 'path/to/Home.page'
    Note that you still need to verify the existance of these files.

    access

    public

    [ Top ]

    TGlobalization::getTranslateDefaultCulture

    getTranslateDefaultCulture( );

    Returns

    default culture

    access

    public

    [ Top ]

    TGlobalization::getTranslationCatalogue

    getTranslationCatalogue( );

    Returns

    current translation catalogue.

    access

    public

    [ Top ]

    TGlobalization::getTranslationConfiguration

    getTranslationConfiguration( );

    Returns

    translation source configuration.

    access

    public

    [ Top ]

    TGlobalization::init

    init( mixed $config );

    Overridden in child classes as:

    TGlobalizationAutoDetect::init()

    Overrides TModule::init() (Initializes the module.)

    Parameters

    $config

    application configuration

    Remarks

    Initialize the Culture and Charset for this application.

    You should override this method if you want a different way of setting the Culture and/or Charset for your application. If you override this method, call parent::init($xml) first.

    access

    public

    [ Top ]

    TGlobalization::setCharset

    setCharset( string $charset );

    Parameters

    $charset

    localization charset, e.g. <tt>UTF-8</tt>

    access

    public

    [ Top ]

    TGlobalization::setCulture

    setCulture( string $culture );

    Parameters

    $culture

    culture, e.g. <tt>en_US</tt> for American English

    access

    public

    [ Top ]

    TGlobalization::setDefaultCharset

    setDefaultCharset( string $charset );

    Parameters

    $charset

    default localization charset, e.g. <tt>UTF-8</tt>

    access

    public

    [ Top ]

    TGlobalization::setDefaultCulture

    setDefaultCulture( string $culture );

    Parameters

    $culture

    default culture, e.g. <tt>en_US</tt> for American English

    access

    public

    [ Top ]

    TGlobalization::setTranslateDefaultCulture

    setTranslateDefaultCulture( bool $value );

    Parameters

    $value

    default culture, e.g. <tt>en_US</tt> for American English

    access

    public

    [ Top ]

    TGlobalization::setTranslationCatalogue

    setTranslationCatalogue( string $value );

    Parameters

    $value

    update the translation catalogue.

    access

    public

    [ Top ]

    TGlobalization::setTranslationConfiguration

    setTranslationConfiguration( TMap|array $config );

    Parameters

    $config

    configuration options

    Remarks

    Sets the translation configuration. Example configuration:

  •  $config['type'] = 'XLIFF'; //XLIFF, gettext, Database or MySQL (deprecated)
    •

  •  $config['source'] = 'Path.to.directory'; // for types XLIFF and gettext
    •

  •  $config['source'] = 'connectionId'; // for type Database
    •

  •  $config['source'] = 'mysql://user:pw@host/db'; // for type MySQL (deprecated)
    •

  •  $config['catalogue'] = 'messages'; //default catalog
    •

  •  $config['autosave'] = 'true'; //save untranslated message
    •

  •  $config['cache'] = 'true'; //cache translated message
    •

  •  $config['marker'] = '@@'; // surround untranslated text with '@@'
    •
    Throws exception is source is not found.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:22 +0200 by phpDocumentor 1.4.3


Docs For Class TGlobalizationAutoDetect

Class TGlobalizationAutoDetect

[line 26]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TGlobalization
            |
            --TGlobalizationAutoDetect
Location: /I18N/TGlobalizationAutoDetect.php

Remarks

TGlobalizationAutoDetect class will automatically try to resolve the default culture using the user browser language settings.

author

Wei Zhuo<weizhuo[at]gmail[dot]com>

version

$Revision: 1.66 $ $Date: ${DATE} ${TIME} $

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TGlobalization

  • TGlobalization::getCharset()
  • TGlobalization::getCulture()
  • TGlobalization::getCultureVariants()
    Gets all the variants of a specific culture. If the parameter $culture is null, the current culture is used.
  • TGlobalization::getDefaultCharset()
  • TGlobalization::getDefaultCulture()
  • TGlobalization::getLocalizedResource()
    Returns a list of possible localized files. Example
  • TGlobalization::getTranslateDefaultCulture()
  • TGlobalization::getTranslationCatalogue()
  • TGlobalization::getTranslationConfiguration()
  • TGlobalization::init()
    Initialize the Culture and Charset for this application.
  • TGlobalization::setCharset()
  • TGlobalization::setCulture()
  • TGlobalization::setDefaultCharset()
  • TGlobalization::setDefaultCulture()
  • TGlobalization::setTranslateDefaultCulture()
  • TGlobalization::setTranslationCatalogue()
  • TGlobalization::setTranslationConfiguration()
    Sets the translation configuration. Example configuration:

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TGlobalizationAutoDetect::getDetectedLanguage

    getDetectedLanguage( );

    access

    public

    [ Top ]

    TGlobalizationAutoDetect::init

    init( $xml );

    Overrides TGlobalization::init() (Initialize the Culture and Charset for this application.)

    Parameters

    $xml

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:22 +0200 by phpDocumentor 1.4.3


Docs For Class TI18NControl

Class TI18NControl

[line 33]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TI18NControl
Classes extended from TI18NControl:
TDateFormat
To format dates and/or time according to the current locale use
TNumberFormat
To format numbers in locale sensitive manner use
TTranslate
TTranslate class.

Location: /I18N/TI18NControl.php

Remarks

TI18NControl class.

Base class for I18N components, providing Culture and Charset properties. Namespace: System.I18N

Properties

  • Culture, string,
    Gets or sets the culture for formatting. If the Culture property is not specified. The culture from the Application/Page is used.
  • Charset, string,
    Gets or sets the charset for both input and output. If the Charset property is not specified. The charset from the Application/Page is used. The default is UTF-8.

author

Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>

version

v1.0, last update on Sat Dec 11 15:25:11 EST 2004

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TI18NControl::getCharset

    getCharset( );

    Returns

    charset

    Remarks

    Gets the charset.

    It is evaluated in the following order: 1) application charset, 2) the default charset in globalization 3) UTF-8

    access

    public

    [ Top ]

    TI18NControl::getCulture

    getCulture( parameter 0 );

    Parameters

    0

    Returns

    culture identifier.

    Remarks

    Get the specific culture for this control.

    access

    public

    [ Top ]

    TI18NControl::setCharset

    setCharset( string $value );

    Parameters

    $value

    the charset, e.g. UTF-8

    Remarks

    Sets the charset for message output

    access

    public

    [ Top ]

    TI18NControl::setCulture

    setCulture( string $culture );

    Parameters

    $culture

    culture identifier.

    Remarks

    Get the custom culture identifier.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:32 +0200 by phpDocumentor 1.4.3


Docs For Class TNumberFormat

Class TNumberFormat

[line 67]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TI18NControl
            |
            --TNumberFormat
Location: /I18N/TNumberFormat.php

Remarks

To format numbers in locale sensitive manner use

  •  <com:TNumberFormat Pattern="0.##" value="2.0" />
    •

    Numbers can be formatted as currency, percentage, decimal or scientific numbers by specifying the Type attribute. The known types are "currency", "percentage", "decimal" and "scientific".

    If someone from US want to see sales figures from a store in Germany (say using the EURO currency), formatted using the german currency, you would need to use the attribute Culture="de_DE" to get the currency right, e.g. 100,00. The decimal and grouping separator is then also from the de_DE locale. This may lead to some confusion because people from US know the "," as thousand separator. Therefore a "Currency" attribute is available, so that the output from the following example results in 100.00.

  •  <com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" />
    •

    Namespace: System.I18N

    Properties

    • Value, number,
      Gets or sets the number to format. The tag content is used as Value if the Value property is not specified.
    • Type, string,
      Gets or sets the formatting type. The valid types are 'decimal', 'currency', 'percentage' and 'scientific'.
    • Currency, string,
      Gets or sets the currency symbol for the currency format. The default is 'USD' if the Currency property is not specified.
    • Pattern, string,
      Gets or sets the custom number formatting pattern.
    • DefaultText, string,
      Gets or sets the default text. If Value is not set, DefaultText will be
    shown instead of the default currency Value/Pattern.

    author

    Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    v1.0, last update on Sat Dec 11 17:49:56 EST 2004

    Class Variable Summary

    • static $formatter =
      Default NumberFormat, set to the application culture.

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TI18NControl

    • TI18NControl::getCharset()
      Gets the charset.
    • TI18NControl::getCulture()
      Get the specific culture for this control.
    • TI18NControl::setCharset()
      Sets the charset for message output
    • TI18NControl::setCulture()
      Get the custom culture identifier.

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TNumberFormat::getCurrency

      getCurrency( );

      Returns

      3 letter currency code. Defaults to 'USD'.

      access

      public

      [ Top ]

      TNumberFormat::getData

      getData( );

      Returns

      number

      Remarks

      Get the numberic value for this control.

      This method is required by IDataRenderer. It is the same as getValue().

      see

      TNumberFormat::getValue()

      since

      3.1.2

      access

      public

      [ Top ]

      TNumberFormat::getDefaultText

      getDefaultText( );

      Returns

      default text value

      Remarks

      Get the default text value for this control.

      access

      public

      [ Top ]

      TNumberFormat::getFormattedValue

      getFormattedValue( );

      Returns

      formatted number

      Remarks

      Formats the localized number, be it currency or decimal, or percentage.

      If the culture is not specified, the default application culture will be used.

      access

      protected

      [ Top ]

      TNumberFormat::getPattern

      getPattern( );

      Returns

      format pattern.

      Remarks

      Get the number formatting pattern.

      access

      public

      [ Top ]

      TNumberFormat::getType

      getType( );

      Returns

      formatting type.

      Remarks

      Get the formatting type for this control.

      access

      public

      [ Top ]

      TNumberFormat::getValue

      getValue( );

      Returns

      number

      Remarks

      Get the numberic value for this control.

      access

      public

      [ Top ]

      TNumberFormat::render

      render( $writer );

      Overrides TControl::render() (Renders the control.)

      Parameters

      $writer

      access

      public

      [ Top ]

      TNumberFormat::setCurrency

      setCurrency( string $currency );

      Parameters

      $currency

      currency code.

      Remarks

      Set the 3-letter ISO 4217 code. For example, the code "USD" represents the US Dollar and "EUR" represents the Euro currency.

      access

      public

      [ Top ]

      TNumberFormat::setData

      setData( string $value );

      Parameters

      $value

      the number value

      Remarks

      Set the numberic value for this control.

      This method is required by IDataRenderer. It is the same as setValue().

      see

      TNumberFormat::setValue()

      since

      3.1.2

      access

      public

      [ Top ]

      TNumberFormat::setDefaultText

      setDefaultText( string $value );

      Parameters

      $value

      default text value

      Remarks

      Set the default text value for this control.

      access

      public

      [ Top ]

      TNumberFormat::setPattern

      setPattern( string $pattern );

      Parameters

      $pattern

      format pattern.

      Remarks

      Set the number format pattern.

      access

      public

      [ Top ]

      TNumberFormat::setType

      setType( string $type );

      Parameters

      $type

      formatting type, either "decimal", "currency","percentage" or "scientific"

      Remarks

      Set the formatting type for this control.

      throws

      TPropertyTypeInvalidException

      access

      public

      [ Top ]

      TNumberFormat::setValue

      setValue( string $value );

      Parameters

      $value

      the number value

      Remarks

      Set the numberic value for this control.

      access

      public

      [ Top ]

    Variable Detail

    • static $formatter = [line 73]
    • Data type: NumberFormat

      • Remarks

      Default NumberFormat, set to the application culture.

      access

      protected

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:54 +0200 by phpDocumentor 1.4.3


Docs For Class Translation

Class Translation

[line 28]
TComponent
   |
   --Translation
Location: /I18N/Translation.php

Remarks

Translation class.

Provides translation using a static MessageFormatter.

author

Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>

version

v1.0, last update on Tue Dec 28 11:54:48 EST 2004

Class Variable Summary

  • static $formatters = array()
    The array of formatters. We define 1 formatter per translation catalog This is a class static variable.

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static MessageFormat formatter()
    Get the static formatter from this component.
  • static void init()
    Initialize the TTranslate translation components
  • static void saveMessages()
    Save untranslated messages to the catalogue.
  • MessageFormat formatter()
    Get the static formatter from this component.
  • void init()
    Initialize the TTranslate translation components
  • void saveMessages()
    Save untranslated messages to the catalogue.

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    static Translation::formatter

    static formatter( [ $catalogue = 'messages'] );

    Parameters

    $catalogue

    Returns

    formattter.

    Remarks

    Get the static formatter from this component.

    see

    localize()

    access

    public

    [ Top ]

    static Translation::init

    static init( [ $catalogue = 'messages'] );

    Parameters

    $catalogue

    Remarks

    Initialize the TTranslate translation components

    access

    public

    [ Top ]

    static Translation::saveMessages

    static saveMessages( );

    Remarks

    Save untranslated messages to the catalogue.

    access

    public

    [ Top ]

Variable Detail

  • static $formatters = array() [line 35]
  • Data type: array

    • Remarks

    The array of formatters. We define 1 formatter per translation catalog This is a class static variable.

    access

    protected

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:08 +0200 by phpDocumentor 1.4.3


Docs For Class TTranslate

Class TTranslate

[line 63]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TI18NControl
            |
            --TTranslate
Classes extended from TTranslate:
TChoiceFormat
TChoiceFormat class.

Location: /I18N/TTranslate.php

Remarks

TTranslate class.

This component performs message/string translation. The translation source is set in the TGlobalization handler. The following example demonstrated a simple message translation.

  •  <com:TTranslate Text="Goodbye" />
    •

    Depending on the culture set on the page, the phrase "Goodbye" will be translated.

    The Parameters property can be use to add name values pairs for substitution. Substrings enclosed with "{" and "}" in the translation message are consider as the parameter names during substitution lookup. The following example will substitute the substring "{time}" with the value of the parameter attribute "Parameters.time=<%= time() %>. Note that the value of the parameter named "time" is evaluated.

  •  <com:TTranslate Parameters.time=<%= time() %> >
    •

  •    The unix-time is "{time}".
    •

  •  </com:TTranslate>
    •

    More complex string substitution can be applied using the TTranslateParameter component.

    Namespace: System.I18N

    Properties

    • Text, string,
      Gets or sets the string to translate.
    • Catalogue, string,
      Gets or sets the catalogue for message translation. The default catalogue can be set by the @Page directive.
    • Key, string,
      Gets or sets the key used to message look up.
    • Trim, boolean,
      Gets or sets an option to trim the contents. Default is to trim the contents.

    author

    Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    v1.0, last update on Fri Dec 24 21:38:49 EST 2004

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TI18NControl

    • TI18NControl::getCharset()
      Gets the charset.
    • TI18NControl::getCulture()
      Get the specific culture for this control.
    • TI18NControl::setCharset()
      Sets the charset for message output
    • TI18NControl::setCulture()
      Get the custom culture identifier.

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TTranslate::getCatalogue

      getCatalogue( );

      Returns

      catalogue.

      Remarks

      Get the message catalogue.

      access

      public

      [ Top ]

      TTranslate::getKey

      getKey( );

      Returns

      key

      Remarks

      Get the key for message lookup.

      access

      public

      [ Top ]

      TTranslate::getParameter

      getParameter( $name );

      Parameters

      $name

      Returns

      parameter value, null if parameter does not exist

      access

      public

      [ Top ]

      TTranslate::getParameters

      getParameters( );

      Returns

      the list of custom parameters

      Remarks

      Returns the list of custom parameters.

      Custom parameters are name-value pairs that may subsititute translation place holders during rendering.

      access

      public

      [ Top ]

      TTranslate::getText

      getText( );

      Returns

      the text to be localized/translated.

      access

      public

      [ Top ]

      TTranslate::getTrim

      getTrim( );

      Returns

      trim or not.

      Remarks

      Trim the content or not.

      access

      public

      [ Top ]

      TTranslate::hasParameter

      hasParameter( $name );

      Parameters

      $name

      Returns

      whether the named parameter exists

      access

      public

      [ Top ]

      TTranslate::removeParameter

      removeParameter( string $name );

      Parameters

      $name

      the name of the parameter to be removed.

      Returns

      parameter value removed, null if parameter does not exist.

      Remarks

      Removes the named parameter.

      access

      public

      [ Top ]

      TTranslate::render

      render( $writer );

      Overrides TControl::render() (Renders the control.)

      Parameters

      $writer

      Remarks

      renders the translated string.

      access

      public

      [ Top ]

      TTranslate::setCatalogue

      setCatalogue( string $value );

      Parameters

      $value

      catalogue.

      Remarks

      Set the message catalogue.

      access

      public

      [ Top ]

      TTranslate::setKey

      setKey( string $value );

      Parameters

      $value

      key

      Remarks

      Set the key for message lookup.

      access

      public

      [ Top ]

      TTranslate::setParameter

      setParameter( string $name, string $value );

      Parameters

      $name

      parameter name

      $value

      value of the parameter

      access

      public

      [ Top ]

      TTranslate::setText

      setText( string $value );

      Parameters

      $value

      the text for translation.

      Remarks

      Sets the text for localization.

      access

      public

      [ Top ]

      TTranslate::setTrim

      setTrim( boolean $value );

      Parameters

      $value

      trim or not.

      Remarks

      Set the option to trim the contents.

      access

      public

      [ Top ]

      TTranslate::translateText

      translateText( string $text, array $subs );

      Overridden in child classes as:

      TChoiceFormat::translateText()
      Display the choosen translated string.

      Parameters

      $text

      text for translation

      $subs

      list of substitutions

      Returns

      translated text

      Remarks

      Translates the text with subsititution.

      access

      protected

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:42 +0200 by phpDocumentor 1.4.3


Docs For Class TTranslateParameter

Class TTranslateParameter

[line 42]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TTranslateParameter
Location: /I18N/TTranslateParameter.php

Remarks

TTranslateParameter component should be used inside the TTranslate component to allow parameter substitution.

For example, the strings "{greeting}" and "{name}" will be replace with the values of "Hello" and "World", respectively. The substitution string must be enclose with "{" and "}". The parameters can be further translated by using TTranslate.

  •  <com:TTranslate>
    •

  •    {greeting} {name}!
    •

  •    <com:TTranslateParameter Key="name">World</com:TTranslateParameter>
    •

  •    <com:TTranslateParameter Key="greeting">Hello</com:TTranslateParameter>
    •

  •  </com:TTranslate>
    •

    Namespace: System.I18N

    Properties

    • Key, string, required.
      Gets or sets the string in TTranslate to substitute.
    • Trim, boolean,
      Gets or sets an option to trim the contents of the TParam. Default is to trim the contents.

    author

    Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    v3.0, last update on Friday, 6 January 2006

    Class Variable Summary

    • $key =
      The substitution key.
    • $trim =  true
      To trim or not to trim the contents.

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited From Class TControl

    • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
      prefix to an ID automatically generated
    • TControl::CLIENT_ID_SEPARATOR = '_'
      separator char between IDs in a ClientID
    • TControl::CS_CHILD_INITIALIZED = 1
    • TControl::CS_CONSTRUCTED = 0
      the stage of lifecycles that the control is currently at
    • TControl::CS_INITIALIZED = 2
    • TControl::CS_LOADED = 4
    • TControl::CS_PRERENDERED = 5
    • TControl::CS_STATE_LOADED = 3
    • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
      format of control ID
    • TControl::ID_SEPARATOR = '$'
      separator char between IDs in a UniqueID
    • TControl::IS_CHILD_CREATED = 0x20
    • TControl::IS_CREATING_CHILD = 0x40
    • TControl::IS_DISABLE_THEMING = 0x10
    • TControl::IS_DISABLE_VIEWSTATE = 0x02
    • TControl::IS_ID_SET = 0x01
      State bits.
    • TControl::IS_SKIN_APPLIED = 0x04
    • TControl::IS_STYLESHEET_APPLIED = 0x08
    • TControl::RF_ADAPTER = 9
    • TControl::RF_AUTO_BINDINGS = 10
    • TControl::RF_CHILD_STATE = 1
    • TControl::RF_CONTROLS = 0
      Indexes for the rare fields.
    • TControl::RF_CONTROLSTATE = 7
    • TControl::RF_DATA_BINDINGS = 5
    • TControl::RF_EVENTS = 6
    • TControl::RF_NAMED_CONTROLS = 2
    • TControl::RF_NAMED_CONTROLS_ID = 3
    • TControl::RF_NAMED_OBJECTS = 8
    • TControl::RF_SKIN_ID = 4

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TControl

    • TControl::__construct()
      Constructor.
    • TControl::addedControl()
      Adds a control into the child collection of the control.
    • TControl::addParsedObject()
      Adds the object instantiated on a template to the child control collection.
    • TControl::addToPostDataLoader()
      Add controls implementing IPostBackDataHandler to post data loaders.
    • TControl::applyStyleSheetSkin()
      Applies a stylesheet skin to a control.
    • TControl::autoBindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::autoDataBindProperties()
      Auto databinding properties of the control.
    • TControl::bindProperty()
      Sets up the binding between a property (or property path) and an expression.
    • TControl::broadcastEvent()
      Broadcasts an event.
    • TControl::bubbleEvent()
      This method responds to a bubbled event.
    • TControl::clearChildState()
      Clears up the child state data.
    • TControl::clearControlState()
      Clears a controlstate value.
    • TControl::clearNamingContainer()
      Resets the control as a naming container.
    • TControl::clearViewState()
      Clears a viewstate value.
    • TControl::convertUniqueIdToClientId()
      Converts a unique ID to a client ID.
    • TControl::createChildControls()
      Creates child controls.
    • TControl::createControlCollection()
      Creates a control collection object that is to be used to hold child controls
    • TControl::dataBind()
      Performs the databinding for this control.
    • TControl::dataBindChildren()
      Databinding child controls.
    • TControl::dataBindProperties()
      Databinding properties of the control.
    • TControl::ensureChildControls()
      Ensures child controls are created.
    • TControl::findControl()
      Finds a control by ID path within the current naming container.
    • TControl::findControlsByID()
      Finds all child and grand-child controls with the specified ID.
    • TControl::findControlsByType()
      Finds all child and grand-child controls that are of the specified type.
    • TControl::focus()
      Sets input focus to this control.
    • TControl::getAdapter()
    • TControl::getAllowChildControls()
    • TControl::getAttribute()
    • TControl::getAttributes()
      Returns the list of custom attributes.
    • TControl::getChildControlsCreated()
    • TControl::getClientID()
      Returns the client ID of the control.
    • TControl::getControls()
    • TControl::getControlStage()
      Gets the lifecycle step the control is currently at.
    • TControl::getControlState()
      Returns a controlstate value.
    • TControl::getCustomData()
      Returns custom data associated with this control.
    • TControl::getEnabled()
      Returns a value indicating whether the control is enabled.
    • TControl::getEnableTheming()
    • TControl::getEnableViewState()
    • TControl::getHasAdapter()
    • TControl::getHasAttributes()
    • TControl::getHasChildInitialized()
    • TControl::getHasControls()
    • TControl::getHasInitialized()
    • TControl::getHasLoaded()
    • TControl::getHasLoadedPostData()
    • TControl::getHasPreRendered()
    • TControl::getID()
      Returns the id of the control.
    • TControl::getIsSkinApplied()
    • TControl::getNamingContainer()
    • TControl::getPage()
    • TControl::getParent()
    • TControl::getRegisteredObject()
      Returns the named registered object.
    • TControl::getSkinID()
    • TControl::getSourceTemplateControl()
    • TControl::getTemplateControl()
    • TControl::getUniqueID()
      Returns a unique ID that identifies the control in the page hierarchy.
    • TControl::getViewState()
      Returns a viewstate value.
    • TControl::getVisible()
      Checks if a control is visible.
    • TControl::hasAttribute()
    • TControl::initRecursive()
      Performs the Init step for the control and all its child controls.
    • TControl::isDescendentOf()
    • TControl::isObjectRegistered()
    • TControl::loadRecursive()
      Performs the Load step for the control and all its child controls.
    • TControl::loadState()
      This method is invoked right after the control has loaded its state.
    • TControl::loadStateRecursive()
      Loads state (viewstate and controlstate) into a control and its children.
    • TControl::onDataBinding()
      Raises 'OnDataBinding' event.
    • TControl::onInit()
      This method is invoked when the control enters 'OnInit' stage.
    • TControl::onLoad()
      This method is invoked when the control enters 'OnLoad' stage.
    • TControl::onPreRender()
      This method is invoked when the control enters 'OnPreRender' stage.
    • TControl::onUnload()
      This method is invoked when the control enters 'OnUnload' stage.
    • TControl::preRenderRecursive()
      Performs the PreRender step for the control and all its child controls.
    • TControl::raiseBubbleEvent()
      Invokes the parent's bubbleEvent method.
    • TControl::registerObject()
      Registers an object by a name.
    • TControl::removeAttribute()
      Removes the named attribute.
    • TControl::removedControl()
      Removes a control from the child collection of the control.
    • TControl::render()
      Renders the control.
    • TControl::renderChildren()
      Renders the children of the control.
    • TControl::renderControl()
      Renders the control.
    • TControl::saveState()
      This method is invoked when control state is to be saved.
    • TControl::saveStateRecursive()
      Saves all control state (viewstate and controlstate) as a collection.
    • TControl::setAdapter()
    • TControl::setAttribute()
      Sets a custom control attribute.
    • TControl::setChildControlsCreated()
      Sets a value indicating whether child controls are created.
    • TControl::setControlStage()
      Sets the lifecycle step the control is currently at.
    • TControl::setControlState()
      Sets a controlstate value.
    • TControl::setCustomData()
      Associates custom data with this control.
    • TControl::setEnabled()
    • TControl::setEnableTheming()
    • TControl::setEnableViewState()
    • TControl::setID()
    • TControl::setPage()
      Sets the page for a control.
    • TControl::setSkinID()
    • TControl::setTemplateControl()
      Sets the control whose template contains this control.
    • TControl::setViewState()
      Sets a viewstate value.
    • TControl::setVisible()
    • TControl::trackViewState()
      Sets a value indicating whether we should keep data in viewstate.
    • TControl::traverseChildControls()
      Traverse the whole control hierarchy rooted at this control.
    • TControl::unbindProperty()
      Breaks the binding between a property (or property path) and an expression.
    • TControl::unloadRecursive()
      Performs the Unload step for the control and all its child controls.
    • TControl::unregisterObject()
      Unregisters an object by name.
    • TControl::__get()
      Returns a property value by name or a control by ID.

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TTranslateParameter::getKey

      getKey( );

      Returns

      substitution key.

      Remarks

      Get the parameter substitution key.

      access

      public

      [ Top ]

      TTranslateParameter::getParameter

      getParameter( );

      Returns

      parameter contents.

      access

      public

      [ Top ]

      TTranslateParameter::getTrim

      getTrim( );

      Returns

      trim or not.

      Remarks

      Trim the content or not.

      access

      public

      [ Top ]

      TTranslateParameter::getValue

      getValue( );

      access

      public

      [ Top ]

      TTranslateParameter::setKey

      setKey( string $value );

      Parameters

      $value

      substitution key.

      Remarks

      Set the parameter substitution key.

      access

      public

      [ Top ]

      TTranslateParameter::setTrim

      setTrim( boolean $value );

      Parameters

      $value

      trim or not.

      Remarks

      Set the option to trim the contents.

      access

      public

      [ Top ]

      TTranslateParameter::setValue

      setValue( $value );

      Parameters

      $value

      access

      public

      [ Top ]

    Variable Detail

    • $key = [line 48]
    • Data type: string

      • Remarks

      The substitution key.

      access

      protected

    • $trim =  true [line 54]
    • Data type: boolean

      • Remarks

      To trim or not to trim the contents.

      access

      protected

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:42 +0200 by phpDocumentor 1.4.3


Package System.Util Element Index

Element index for package System.Util

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a c d e f g i j l n p r s t w x _
top
_
$_levelNames | in file TLogRouter.php, variable TLogRoute::$_levelNames
$_levelValues | in file TLogRouter.php, variable TLogRoute::$_levelValues
$_month_leaf | in file TDateTimeStamp.php, variable TDateTimeStamp::$_month_leaf
$_month_normal | in file TDateTimeStamp.php, variable TDateTimeStamp::$_month_normal
_getDateInternal in file TDateTimeStamp.php, method TDateTimeStamp::_getDateInternal()
Low-level function that returns the getdate() array. We have a special $fast flag, which if set to true, will return fewer array values, and is much faster as it does not calculate dow, etc.
__call | in file TRpcClient.php, method TXmlRpcClient::__call()
__call | in file TRpcClient.php, method TJsonRpcClient::__call()
__construct in file TSimpleDateFormatter.php, method TSimpleDateFormatter::__construct()
Constructor, create a new date time formatter.
__construct | in file TRpcClient.php, method TRpcClientResponseException::__construct()
__construct | in file TRpcClient.php, method TRpcClient::__construct()
__destruct in file TLogRouter.php, method TDbLogRoute::__destruct()
Destructor.
top
a
addRoute in file TLogRouter.php, method TLogRouter::addRoute()
Adds a TLogRoute instance to the log router.
ADODB_NO_NEGATIVE_TS | in file TDateTimeStamp.php, constant ADODB_NO_NEGATIVE_TS
ALERT | in file TLogger.php, class constant TLogger::ALERT
top
c
collectLogs in file TLogRouter.php, method TLogRoute::collectLogs()
Retrieves log messages from logger to log route specific destination.
collectLogs in file TLogRouter.php, method TLogRouter::collectLogs()
Collects log messages from a logger.
create in file TRpcClient.php, method TXmlRpcClient::create()
Creates an instance of TXmlRpcClient
create in file TRpcClient.php, method TRpcClient::create()
Creates an instance of the requested RPC client type
create in file TRpcClient.php, method TJsonRpcClient::create()
Creates an instance of TJsonRpcClient
createDbConnection in file TLogRouter.php, method TDbLogRoute::createDbConnection()
Creates the DB connection.
createDbTable in file TLogRouter.php, method TDbLogRoute::createDbTable()
Creates the DB table for storing log messages.
createStreamContext in file TRpcClient.php, method TRpcClient::createStreamContext()
Creates a stream context resource
top
d
DEBUG in file TLogger.php, class constant TLogger::DEBUG
Log levels.
DEFAULT_LABEL in file TLogRouter.php, class constant TFirePhpLogRoute::DEFAULT_LABEL
Default group label
DEFAULT_SUBJECT in file TLogRouter.php, class constant TEmailLogRoute::DEFAULT_SUBJECT
Default email subject.
deleteLogs in file TLogger.php, method TLogger::deleteLogs()
Deletes log messages from the queue.
digitCheck in file TDateTimeStamp.php, method TDateTimeStamp::digitCheck()
Fix 2-digit years. Works for any century.
dump in file TVarDumper.php, method TVarDumper::dump()
Converts a variable into a string representation.
top
e
EMAIL_PATTERN in file TLogRouter.php, class constant TEmailLogRoute::EMAIL_PATTERN
Regex pattern for email address.
encodeRequest | in file TRpcClient.php, method TXmlRpcClient::encodeRequest()
encodeRequest | in file TRpcClient.php, method TJsonRpcClient::encodeRequest()
ERROR | in file TLogger.php, class constant TLogger::ERROR
top
f
FATAL | in file TLogger.php, class constant TLogger::FATAL
format in file TSimpleDateFormatter.php, method TSimpleDateFormatter::format()
Format the date according to the pattern.
formatDate | in file TDateTimeStamp.php, method TDateTimeStamp::formatDate()
formatLogMessage in file TLogRouter.php, method TLogRoute::formatLogMessage()
Formats a log message given different fields.
top
g
get4DigitYear | in file TDateTimeStamp.php, method TDateTimeStamp::get4DigitYear()
getAutoCreateLogTable | in file TLogRouter.php, method TDbLogRoute::getAutoCreateLogTable()
getCategories | in file TLogRouter.php, method TLogRoute::getCategories()
getCharset | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::getCharset()
getColorLevel | in file TLogRouter.php, method TBrowserLogRoute::getColorLevel()
getConfigFile | in file TLogRouter.php, method TLogRouter::getConfigFile()
getConnectionID | in file TLogRouter.php, method TDbLogRoute::getConnectionID()
getCssClass | in file TLogRouter.php, method TBrowserLogRoute::getCssClass()
getDataFieldValue in file TDataFieldAccessor.php, method TDataFieldAccessor::getDataFieldValue()
Evaluates the data value at the specified field.
getDate | in file TDateTimeStamp.php, method TDateTimeStamp::getDate()
getDayMonthYearOrdering | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::getDayMonthYearOrdering()
getDayofWeek in file TDateTimeStamp.php, method TDateTimeStamp::getDayofWeek()
Gets day of week, 0 = Sunday,... 6=Saturday.
getDayPattern | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::getDayPattern()
getDbConnection | in file TLogRouter.php, method TDbLogRoute::getDbConnection()
getEmails | in file TLogRouter.php, method TEmailLogRoute::getEmails()
getFirebugLoggingFunction | in file TLogRouter.php, method TFirebugLogRoute::getFirebugLoggingFunction()
getGMTDiff | in file TDateTimeStamp.php, method TDateTimeStamp::getGMTDiff()
getGroupLabel | in file TLogRouter.php, method TFirePhpLogRoute::getGroupLabel()
getIsNotification | in file TRpcClient.php, method TRpcClient::getIsNotification()
getLevelName | in file TLogRouter.php, method TLogRoute::getLevelName()
getLevels | in file TLogRouter.php, method TLogRoute::getLevels()
getLevelValue | in file TLogRouter.php, method TLogRoute::getLevelValue()
getLogFile | in file TLogRouter.php, method TFileLogRoute::getLogFile()
getLogPath | in file TLogRouter.php, method TFileLogRoute::getLogPath()
getLogs in file TLogger.php, method TLogger::getLogs()
Retrieves log messages.
getLogTableName | in file TLogRouter.php, method TDbLogRoute::getLogTableName()
getMaxFileSize | in file TLogRouter.php, method TFileLogRoute::getMaxFileSize()
getMaxLogFiles | in file TLogRouter.php, method TFileLogRoute::getMaxLogFiles()
getMonthPattern | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::getMonthPattern()
getParameterFile | in file TParameterModule.php, method TParameterModule::getParameterFile()
getPattern | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::getPattern()
getSentFrom | in file TLogRouter.php, method TEmailLogRoute::getSentFrom()
getServerUrl | in file TRpcClient.php, method TRpcClient::getServerUrl()
getSubject | in file TLogRouter.php, method TEmailLogRoute::getSubject()
getTimeStamp in file TDateTimeStamp.php, method TDateTimeStamp::getTimeStamp()
Not a very fast algorithm - O(n) operation. Could be optimized to O(1).
getYearPattern | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::getYearPattern()
top
i
INFO | in file TLogger.php, class constant TLogger::INFO
init in file TLogRouter.php, method TLogRouter::init()
Initializes this module.
init in file TParameterModule.php, method TParameterModule::init()
Initializes the module by loading parameters.
init in file TLogRouter.php, method TLogRoute::init()
Initializes the route.
init in file TLogRouter.php, method TEmailLogRoute::init()
Initializes the route.
init in file TLogRouter.php, method TDbLogRoute::init()
Initializes this module.
isLeapYear in file TDateTimeStamp.php, method TDateTimeStamp::isLeapYear()
Checks for leap year, returns true if it is. No 2-digit year check. Also handles julian calendar correctly.
isValidDate | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::isValidDate()
isValidDate | in file TDateTimeStamp.php, method TDateTimeStamp::isValidDate()
top
j
JSON | in file TRpcClient.php, class constant TRpcClientTypesEnumerable::JSON
top
l
loadParameters in file TParameterModule.php, method TParameterModule::loadParameters()
Loads parameters into application.
log in file TLogger.php, method TLogger::log()
Logs a message.
top
n
NOTICE | in file TLogger.php, class constant TLogger::NOTICE
top
p
PARAM_FILE_EXT | in file TParameterModule.php, class constant TParameterModule::PARAM_FILE_EXT
parse in file TSimpleDateFormatter.php, method TSimpleDateFormatter::parse()
Parse the string according to the pattern.
performRequest in file TRpcClient.php, method TRpcClient::performRequest()
Performs the actual request
processLogs in file TLogRouter.php, method TLogRoute::processLogs()
Processes log messages and sends them to specific destination.
processLogs | in file TLogRouter.php, method TFirePhpLogRoute::processLogs()
processLogs in file TLogRouter.php, method TDbLogRoute::processLogs()
Stores log messages into database.
processLogs in file TLogRouter.php, method TEmailLogRoute::processLogs()
Sends log messages to specified email addresses.
processLogs in file TLogRouter.php, method TFileLogRoute::processLogs()
Saves log messages in files.
processLogs | in file TLogRouter.php, method TBrowserLogRoute::processLogs()
top
r
renderFooter | in file TLogRouter.php, method TFirebugLogRoute::renderFooter()
renderFooter | in file TLogRouter.php, method TBrowserLogRoute::renderFooter()
renderHeader | in file TLogRouter.php, method TBrowserLogRoute::renderHeader()
renderHeader | in file TLogRouter.php, method TFirebugLogRoute::renderHeader()
renderMessage | in file TLogRouter.php, method TBrowserLogRoute::renderMessage()
renderMessage | in file TLogRouter.php, method TFirebugLogRoute::renderMessage()
rotateFiles in file TLogRouter.php, method TFileLogRoute::rotateFiles()
Rotates log files.
top
s
setAutoCreateLogTable | in file TLogRouter.php, method TDbLogRoute::setAutoCreateLogTable()
setCategories | in file TLogRouter.php, method TLogRoute::setCategories()
setCharset | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::setCharset()
setConfigFile | in file TLogRouter.php, method TLogRouter::setConfigFile()
setConnectionID in file TLogRouter.php, method TDbLogRoute::setConnectionID()
Sets the ID of a TDataSourceConfig module.
setCssClass | in file TLogRouter.php, method TBrowserLogRoute::setCssClass()
setEmails | in file TLogRouter.php, method TEmailLogRoute::setEmails()
setGroupLabel | in file TLogRouter.php, method TFirePhpLogRoute::setGroupLabel()
setIsNotification | in file TRpcClient.php, method TRpcClient::setIsNotification()
setLevels | in file TLogRouter.php, method TLogRoute::setLevels()
setLogFile | in file TLogRouter.php, method TFileLogRoute::setLogFile()
setLogPath | in file TLogRouter.php, method TFileLogRoute::setLogPath()
setLogTableName in file TLogRouter.php, method TDbLogRoute::setLogTableName()
Sets the name of the DB table to store log content.
setMaxFileSize | in file TLogRouter.php, method TFileLogRoute::setMaxFileSize()
setMaxLogFiles | in file TLogRouter.php, method TFileLogRoute::setMaxLogFiles()
setParameterFile | in file TParameterModule.php, method TParameterModule::setParameterFile()
setPattern | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::setPattern()
setSentFrom | in file TLogRouter.php, method TEmailLogRoute::setSentFrom()
setServerUrl | in file TRpcClient.php, method TRpcClient::setServerUrl()
setSubject | in file TLogRouter.php, method TEmailLogRoute::setSubject()
top
t
TBrowserLogRoute in file TLogRouter.php, class TBrowserLogRoute
TBrowserLogRoute class.
TDataFieldAccessor in file TDataFieldAccessor.php, class TDataFieldAccessor
TDataFieldAccessor class
TDateTimeStamp in file TDateTimeStamp.php, class TDateTimeStamp
TDateTimeStamp Class
TDbLogRoute in file TLogRouter.php, class TDbLogRoute
TDbLogRoute class
TEmailLogRoute in file TLogRouter.php, class TEmailLogRoute
TEmailLogRoute class.
TFileLogRoute in file TLogRouter.php, class TFileLogRoute
TFileLogRoute class.
TFirebugLogRoute in file TLogRouter.php, class TFirebugLogRoute
TFirebugLogRoute class.
TFirePhpLogRoute in file TLogRouter.php, class TFirePhpLogRoute
TFirePhpLogRoute class.
TJsonRpcClient in file TRpcClient.php, class TJsonRpcClient
TJsonRpcClient class
TLogger in file TLogger.php, class TLogger
TLogger class.
TLogRoute in file TLogRouter.php, class TLogRoute
TLogRoute class.
TLogRouter in file TLogRouter.php, class TLogRouter
TLogRouter class.
TParameterModule in file TParameterModule.php, class TParameterModule
TParameterModule class
translateLogLevel in file TLogRouter.php, method TFirePhpLogRoute::translateLogLevel()
Translates a PRADO log level attribute into one understood by FirePHP for correct visualization
TRpcClient in file TRpcClient.php, class TRpcClient
TRpcClient class
TRpcClientRequestException in file TRpcClient.php, class TRpcClientRequestException
TRpcClientRequestException class
TRpcClientResponseException in file TRpcClient.php, class TRpcClientResponseException
TRpcClientResponseException class
TRpcClientTypesEnumerable in file TRpcClient.php, class TRpcClientTypesEnumerable
TRpcClientTypesEnumerable class
TSimpleDateFormatter in file TSimpleDateFormatter.php, class TSimpleDateFormatter
TSimpleDateFormatter class.
TVarDumper in file TVarDumper.php, class TVarDumper
TVarDumper class.
TXmlRpcClient in file TRpcClient.php, class TXmlRpcClient
TXmlRpcClient class
TDataFieldAccessor.php | procedural page TDataFieldAccessor.php
TDateTimeStamp.php | procedural page TDateTimeStamp.php
TLogger.php | procedural page TLogger.php
TLogRouter.php | procedural page TLogRouter.php
TParameterModule.php | procedural page TParameterModule.php
TRpcClient.php | procedural page TRpcClient.php
TSimpleDateFormatter.php | procedural page TSimpleDateFormatter.php
TVarDumper.php | procedural page TVarDumper.php
top
w
WARNING | in file TLogger.php, class constant TLogger::WARNING
top
x
XML | in file TRpcClient.php, class constant TRpcClientTypesEnumerable::XML


Class Trees for Package System.Util

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TDataFieldAccessor.php

File: /Util/TDataFieldAccessor.php

Remarks

TDataFieldAccessor class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataFieldAccessor.php 3054 2011-10-26 09:57:31Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDataFieldAccessor
TDataFieldAccessor class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:57 +0200 by phpDocumentor 1.4.3


Docs for page TDateTimeStamp.php

File: /Util/TDateTimeStamp.php

Remarks

TDateTimeStamp class file.

COPYRIGHT (c) 2003-2005 John Lim and released under BSD-style license except for code by jackbbs, which includes getTimeStamp, getGMTDiff, isLeapYear and originally found at http://www.php.net/manual/en/function.mktime.php

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TDateTimeStamp.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDateTimeStamp
TDateTimeStamp Class

Include Statements Summary

Global Variable Summary

Constant Summary

  • ADODB_NO_NEGATIVE_TS = 1

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

  • ADODB_NO_NEGATIVE_TS = 1 [line 32]

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:10 +0200 by phpDocumentor 1.4.3


Docs for page TLogger.php

File: /Util/TLogger.php

Remarks

TLogger class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLogger.php 3085 2011-12-21 16:03:29Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TLogger
TLogger class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:46 +0200 by phpDocumentor 1.4.3


Docs for page TLogRouter.php

File: /Util/TLogRouter.php

Remarks

TLogRouter, TLogRoute, TFileLogRoute, TEmailLogRoute class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLogRouter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TLogRouter
TLogRouter class.
TLogRoute
TLogRoute class.
TFileLogRoute
TFileLogRoute class.
TEmailLogRoute
TEmailLogRoute class.
TBrowserLogRoute
TBrowserLogRoute class.
TDbLogRoute
TDbLogRoute class
TFirebugLogRoute
TFirebugLogRoute class.
TFirePhpLogRoute
TFirePhpLogRoute class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:47 +0200 by phpDocumentor 1.4.3


Docs for page TParameterModule.php

File: /Util/TParameterModule.php

Remarks

TParameterModule class

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TParameterModule.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TParameterModule
TParameterModule class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:01 +0200 by phpDocumentor 1.4.3


Docs for page TRpcClient.php

File: /Util/TRpcClient.php

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id: TRpcClient.php 137 2010-03-27 22:13:36Z rrogge $

copyright

2010 Bigpoint GmbH

link

http://www.pradosoft.com/

since

3.2

license

http://www.pradosoft.com/license/

Classes in this file:
TRpcClient
TRpcClient class
TRpcClientTypesEnumerable
TRpcClientTypesEnumerable class
TRpcClientRequestException
TRpcClientRequestException class
TRpcClientResponseException
TRpcClientResponseException class
TJsonRpcClient
TJsonRpcClient class
TXmlRpcClient
TXmlRpcClient class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs for page TSimpleDateFormatter.php

File: /Util/TSimpleDateFormatter.php

Remarks

TSimpleDateFormatter class file

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSimpleDateFormatter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSimpleDateFormatter
TSimpleDateFormatter class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:21 +0200 by phpDocumentor 1.4.3


Docs for page TVarDumper.php

File: /Util/TVarDumper.php

Remarks

TVarDumper class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TVarDumper.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TVarDumper
TVarDumper class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:47 +0200 by phpDocumentor 1.4.3


Docs For Class TDataFieldAccessor

Class TDataFieldAccessor

[line 33]

Location: /Util/TDataFieldAccessor.php

Remarks

TDataFieldAccessor class

TDataFieldAccessor is a utility class that provides access to a field of some data.  The accessor attempts to obtain the field value in the following order:
  • If the data is an array, then the field is treated as an array index
   and the corresponding element value is returned;
  • If the data is a TMap or TList object, then the field is treated as a key
   into the map or list, and the corresponding value is returned.
  • If the data is an object, the field is treated as a property or sub-property
   defined with getter methods. For example, if the object has a method called
   getMyValue(), then field 'MyValue' will retrieve the result of this method call.
   If getMyValue() returns an object which contains a method getMySubValue(),
   then field 'MyValue.MySubValue' will return that method call result.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDataFieldAccessor.php 3054 2011-10-26 09:57:31Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static mixed getDataFieldValue()

    Evaluates the data value at the specified field.

  • mixed getDataFieldValue()

    Evaluates the data value at the specified field.

Inherited Method Summary

Method Detail

    static TDataFieldAccessor::getDataFieldValue

static getDataFieldValue(
mixed
$data, mixed
$field );

    Parameters

    $data

    data containing the field value, can be an array, TMap, TList or object.

    $field

    field value

    Returns

    value at the specified field

    Remarks

    Evaluates the data value at the specified field.

    • If the data is an array, then the field is treated as an array index
   and the corresponding element value is returned;
    • If the data is a TMap or TList object, then the field is treated as a key
   into the map or list, and the corresponding value is returned.
    • If the data is an object, the field is treated as a property or sub-property
   defined with getter methods. For example, if the object has a method called
   getMyValue(), then field 'MyValue' will retrieve the result of this method call.
   If getMyValue() returns an object which contains a method getMySubValue(),
   then field 'MyValue.MySubValue' will return that method call result.

    throws

    TInvalidDataValueException if field or data is invalid

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:43:57 +0200 by phpDocumentor 1.4.3


Docs For Class TDateTimeStamp

Class TDateTimeStamp

[line 66]

Location: /Util/TDateTimeStamp.php

Remarks

TDateTimeStamp Class

TDateTimeStamp Class is adpated from the ADOdb Date Library,  part of the ADOdb abstraction library  Download: http://phplens.com/phpeverywhere/
http://phplens.com/phpeverywhere/adodb_date_library
PHP native date functions use integer timestamps for computations.  Because of this, dates are restricted to the years 1901-2038 on Unix  and 1970-2038 on Windows due to integer overflow for dates beyond  those years. This library overcomes these limitations by replacing the  native function's signed integers (normally 32-bits) with PHP floating  point numbers (normally 64-bits).
Dates from 100 A.D. to 3000 A.D. and later have been tested. The minimum  is 100 A.D. as <100 will invoke the 2 => 4 digit year conversion.  The maximum is billions of years in the future, but this is a theoretical  limit as the computation of that year would take too long with the  current implementation of getTimeStamp.
PERFORMANCE  For high speed, this library uses the native date functions where  possible, and only switches to PHP code when the dates fall outside  the 32-bit signed integer range.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDateTimeStamp.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0.4

Class Variable Summary

  • static $_month_leaf = array("",31,29,31,30,31,30,31,31,30,31,30,31)

  • static $_month_normal = array("",31,28,31,30,31,30,31,31,30,31,30,31)

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TDateTimeStamp::digitCheck

digitCheck(

$y );

    Parameters

    $y

    Returns

    change two digit year into multiple digits

    Remarks

    Fix 2-digit years. Works for any century.

    Assumes that if 2-digit is more than 30 years in future, then previous century.

    access

    protected

    [ Top ]

    TDateTimeStamp::formatDate

formatDate(

$fmt, [
$d = false], [
$is_gmt = false] );

    Parameters

    $fmt

    $d

    $is_gmt

    Returns

    formatted date based on timestamp $d

    [ Top ]

    TDateTimeStamp::get4DigitYear

get4DigitYear(

$y );

    Parameters

    $y

    access

    public

    [ Top ]

    TDateTimeStamp::getDate

getDate(
[
$d = false], [
$fast = false] );

    Parameters

    $d

    $fast

    Returns

    an array with date info.

    [ Top ]

    TDateTimeStamp::getDayofWeek

getDayofWeek(

$year,
$month,
$day );

    Parameters

    $year

    $month

    $day

    Remarks

    Gets day of week, 0 = Sunday,... 6=Saturday.

    Algorithm from PEAR::Date_Calc

    access

    public

    [ Top ]

    TDateTimeStamp::getGMTDiff

getGMTDiff(
 );

    Returns

    get local time zone offset from GMT

    access

    public

    [ Top ]

    TDateTimeStamp::getTimeStamp

getTimeStamp(

$hr,
$min,
$sec, [
$mon = false], [
$day = false], [
$year = false], [
$is_gmt = false] );

    Parameters

    $hr

    $min

    $sec

    $mon

    $day

    $year

    $is_gmt

    Returns

    a timestamp given a local time. Originally by jackbbs.

    Remarks

    Not a very fast algorithm - O(n) operation. Could be optimized to O(1).

    [ Top ]

    TDateTimeStamp::isLeapYear

isLeapYear(
float
$year );

    Parameters

    $year

    year to check

    Returns

    true if is leap year

    Remarks

    Checks for leap year, returns true if it is. No 2-digit year check. Also  handles julian calendar correctly.

    access

    public

    [ Top ]

    TDateTimeStamp::isValidDate

isValidDate(

$y,
$m,
$d );

    Parameters

    $y

    $m

    $d

    Returns

    true if valid date, semantic check only.

    access

    public

    [ Top ]

    TDateTimeStamp::_getDateInternal

    _getDateInternal(
[float
$origd = false], [boolean
$fast = true], [boolean
$is_gmt = false] );

    Parameters

    $origd

    original date

    $fast

    false to compute the day of the week, default is true

    $is_gmt

    true to calculate the GMT dates

    Returns

    an array with date info.

    Remarks

    Low-level function that returns the getdate() array. We have a special  $fast flag, which if set to true, will return fewer array values,  and is much faster as it does not calculate dow, etc.

    access

    protected

    [ Top ]

Variable Detail

  • static $_month_leaf = array("",31,29,31,30,31,30,31,31,30,31,30,31) [line 69]
    •

  • Data type: mixed
    •

    access

    protected

  • static $_month_normal = array("",31,28,31,30,31,30,31,31,30,31,30,31) [line 68]
    •

  • Data type: mixed
    •

    access

    protected

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:10 +0200 by phpDocumentor 1.4.3


Docs For Class TLogger

Class TLogger

[line 25]
TComponent
   |
   --TLogger
Location: /Util/TLogger.php

Remarks

TLogger class.

TLogger records log messages in memory and implements the methods to retrieve the messages with filter conditions, including log levels, log categories, and by control.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLogger.php 3085 2011-12-21 16:03:29Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • ALERT = 0x20
  • DEBUG = 0x01
    Log levels.
  • ERROR = 0x10
  • FATAL = 0x40
  • INFO = 0x02
  • NOTICE = 0x04
  • WARNING = 0x08

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TLogger::deleteLogs

    deleteLogs(
[integer
$levels = null], [array
$categories = null], [array
$controls = null], [
$timestamp = null] );

    Parameters

    $levels

    level filter

    $categories

    category filter

    $controls

    control filter

    $timestamp

    Remarks

    Deletes log messages from the queue.

    Messages may be filtered by log levels and/or categories and/or control client ids and/or timestamp. A level filter is specified by an integer, whose bits indicate the levels interested. For example, (TLogger::INFO | TLogger::WARNING) specifies INFO and WARNING levels. A category filter is specified by an array of categories to filter. A message whose category name starts with any filtering category will be deleted. For example, a category filter array('System.Web','System.IO') will delete messages under categories such as 'System.Web', 'System.IO', 'System.Web.UI', 'System.Web.UI.WebControls', etc. A control client id filter is specified by an array of control client id A message whose control client id starts with any filtering naming panels will be deleted. For example, a category filter array('ctl0_body_header', 'ctl0_body_content_sidebar') will delete messages under categories such as 'ctl0_body_header', 'ctl0_body_content_sidebar', 'ctl0_body_header_title', 'ctl0_body_content_sidebar_savebutton', etc. A timestamp filter is specified as an interger or float number. A message whose registered timestamp is less or equal the filter value will be returned. Level filter, category filter, control filter and timestamp filter are combinational, i.e., only messages satisfying all filter conditions will they be returned.

    access

    public

    [ Top ]

    TLogger::getLogs

    getLogs(
[integer
$levels = null], [array
$categories = null], [array
$controls = null], [
$timestamp = null] );

    Parameters

    $levels

    level filter

    $categories

    category filter

    $controls

    control filter

    $timestamp

    Returns

    list of messages. Each array elements represents one message with the following structure: array( [0] => message [1] => level [2] => category [3] => timestamp (by microtime(), float number)); [4] => memory in bytes [5] => control client id

    Remarks

    Retrieves log messages.

    Messages may be filtered by log levels and/or categories and/or control client ids and/or timestamp. A level filter is specified by an integer, whose bits indicate the levels interested. For example, (TLogger::INFO | TLogger::WARNING) specifies INFO and WARNING levels. A category filter is specified by an array of categories to filter. A message whose category name starts with any filtering category will be returned. For example, a category filter array('System.Web','System.IO') will return messages under categories such as 'System.Web', 'System.IO', 'System.Web.UI', 'System.Web.UI.WebControls', etc. A control client id filter is specified by an array of control client id A message whose control client id starts with any filtering naming panels will be returned. For example, a category filter array('ctl0_body_header', 'ctl0_body_content_sidebar') will return messages under categories such as 'ctl0_body_header', 'ctl0_body_content_sidebar', 'ctl0_body_header_title', 'ctl0_body_content_sidebar_savebutton', etc. A timestamp filter is specified as an interger or float number. A message whose registered timestamp is less or equal the filter value will be returned. Level filter, category filter, control filter and timestamp filter are combinational, i.e., only messages satisfying all filter conditions will they be returned.

    access

    public

    [ Top ]

    TLogger::log

    log( string $message, integer $level, [string $category = 'Uncategorized'], [string|TControl $ctl = null] );

    Parameters

    $message

    message to be logged

    $level

    level of the message. Valid values include TLogger::DEBUG, TLogger::INFO, TLogger::NOTICE, TLogger::WARNING, TLogger::ERROR, TLogger::ALERT, TLogger::FATAL.

    $category

    category of the message

    $ctl

    control of the message

    Remarks

    Logs a message.

    Messages logged by this method may be retrieved via getLogs.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • ALERT = 0x20 [line 35]

  • DEBUG = 0x01 [line 30]

    • Remarks

    Log levels.

  • ERROR = 0x10 [line 34]

  • FATAL = 0x40 [line 36]

  • INFO = 0x02 [line 31]

  • NOTICE = 0x04 [line 32]

  • WARNING = 0x08 [line 33]

Documentation generated on Mon, 25 Jun 2012 14:44:46 +0200 by phpDocumentor 1.4.3


Docs For Class TBrowserLogRoute

Class TBrowserLogRoute

[line 636]
TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
         |
         --TBrowserLogRoute
Classes extended from TBrowserLogRoute:
TFirebugLogRoute
TFirebugLogRoute class.

Location: /Util/TLogRouter.php

Remarks

TBrowserLogRoute class.

TBrowserLogRoute prints selected log messages in the response.

author

Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TLogRouter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TLogRoute

  • TLogRoute::$_levelNames = array(
        TLogger::DEBUG=>'Debug',
        TLogger::INFO=>'Info',
        TLogger::NOTICE=>'Notice',
        TLogger::WARNING=>'Warning',
        TLogger::ERROR=>'Error',
        TLogger::ALERT=>'Alert',
        TLogger::FATAL=>'Fatal'
    )
  • TLogRoute::$_levelValues = array(
        'debug'=>TLogger::DEBUG,
        'info'=>TLogger::INFO,
        'notice'=>TLogger::NOTICE,
        'warning'=>TLogger::WARNING,
        'error'=>TLogger::ERROR,
        'alert'=>TLogger::ALERT,
        'fatal'=>TLogger::FATAL
    )

Method Summary

Inherited Method Summary

Inherited From Class TLogRoute

  • TLogRoute::collectLogs()
    Retrieves log messages from logger to log route specific destination.
  • TLogRoute::formatLogMessage()
    Formats a log message given different fields.
  • TLogRoute::getCategories()
  • TLogRoute::getLevelName()
  • TLogRoute::getLevels()
  • TLogRoute::getLevelValue()
  • TLogRoute::init()
    Initializes the route.
  • TLogRoute::processLogs()
    Processes log messages and sends them to specific destination.
  • TLogRoute::setCategories()
  • TLogRoute::setLevels()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TBrowserLogRoute::getColorLevel

    getColorLevel( $level );

    Parameters

    $level

    access

    protected

    [ Top ]

    TBrowserLogRoute::getCssClass

    getCssClass( );

    Returns

    the css class of the control

    access

    public

    [ Top ]

    TBrowserLogRoute::processLogs

    processLogs( $logs );

    Overrides TLogRoute::processLogs() (Processes log messages and sends them to specific destination.)

    Parameters

    $logs

    access

    public

    [ Top ]

    TBrowserLogRoute::renderFooter

    renderFooter( );

    Overridden in child classes as:

    TFirebugLogRoute::renderFooter()

    access

    protected

    [ Top ]

    TBrowserLogRoute::renderHeader

    renderHeader( );

    Overridden in child classes as:

    TFirebugLogRoute::renderHeader()

    access

    protected

    [ Top ]

    TBrowserLogRoute::renderMessage

    renderMessage( $log, $info );

    Overridden in child classes as:

    TFirebugLogRoute::renderMessage()

    Parameters

    $log

    $info

    access

    protected

    [ Top ]

    TBrowserLogRoute::setCssClass

    setCssClass( string $value );

    Parameters

    $value

    the css class of the control

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:47 +0200 by phpDocumentor 1.4.3


Docs For Class TDbLogRoute

Class TDbLogRoute

[line 823]
TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
         |
         --TDbLogRoute
Location: /Util/TLogRouter.php

Remarks

TDbLogRoute class

TDbLogRoute stores log messages in a database table. To specify the database table, set ConnectionID to be the ID of a TDataSourceConfig module and LogTableName. If they are not setting, an SQLite3 database named 'sqlite3.log' will be created and used under the runtime directory.

By default, the database table name is 'pradolog'. It has the following structure:

  •     CREATE TABLE pradolog
    •

  •   (
    •

  •         log_id INTEGER NOT NULL PRIMARY KEY,
    •

  •         level INTEGER,
    •

  •         category VARCHAR(128),
    •

  •         logtime VARCHAR(20),
    •

  •         message VARCHAR(255)
    •

  •    );
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TLogRouter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.1.2

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Inherited From Class TLogRoute

    • TLogRoute::$_levelNames = array(
        TLogger::DEBUG=>'Debug',
        TLogger::INFO=>'Info',
        TLogger::NOTICE=>'Notice',
        TLogger::WARNING=>'Warning',
        TLogger::ERROR=>'Error',
        TLogger::ALERT=>'Alert',
        TLogger::FATAL=>'Fatal'
    )
    • TLogRoute::$_levelValues = array(
        'debug'=>TLogger::DEBUG,
        'info'=>TLogger::INFO,
        'notice'=>TLogger::NOTICE,
        'warning'=>TLogger::WARNING,
        'error'=>TLogger::ERROR,
        'alert'=>TLogger::ALERT,
        'fatal'=>TLogger::FATAL
    )

    Method Summary

    Inherited Method Summary

    Inherited From Class TLogRoute

    • TLogRoute::collectLogs()
      Retrieves log messages from logger to log route specific destination.
    • TLogRoute::formatLogMessage()
      Formats a log message given different fields.
    • TLogRoute::getCategories()
    • TLogRoute::getLevelName()
    • TLogRoute::getLevels()
    • TLogRoute::getLevelValue()
    • TLogRoute::init()
      Initializes the route.
    • TLogRoute::processLogs()
      Processes log messages and sends them to specific destination.
    • TLogRoute::setCategories()
    • TLogRoute::setLevels()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TDbLogRoute::__destruct

      __destruct( );

      Remarks

      Destructor.

      Disconnect the db connection.

      access

      public

      [ Top ]

      TDbLogRoute::createDbConnection

      createDbConnection( string 0 );

      Parameters

      0

      the module ID for TDataSourceConfig

      Returns

      the created DB connection

      Remarks

      Creates the DB connection.

      throws

      TConfigurationException if module ID is invalid or empty

      access

      protected

      [ Top ]

      TDbLogRoute::createDbTable

      createDbTable( );

      Remarks

      Creates the DB table for storing log messages.

      todo

      create sequence for PostgreSQL

      access

      protected

      [ Top ]

      TDbLogRoute::getAutoCreateLogTable

      getAutoCreateLogTable( );

      Returns

      whether the log DB table should be automatically created if not exists. Defaults to true.

      see

      TDbLogRoute::setAutoCreateLogTable()

      access

      public

      [ Top ]

      TDbLogRoute::getConnectionID

      getConnectionID( );

      Returns

      the ID of a TDataSourceConfig module. Defaults to empty string, meaning not set.

      access

      public

      [ Top ]

      TDbLogRoute::getDbConnection

      getDbConnection( );

      Returns

      the DB connection instance

      access

      public

      [ Top ]

      TDbLogRoute::getLogTableName

      getLogTableName( );

      Returns

      the name of the DB table to store log content. Defaults to 'pradolog'.

      see

      TDbLogRoute::setAutoCreateLogTable()

      access

      public

      [ Top ]

      TDbLogRoute::init

      init( TXmlElement $config );

      Overrides TLogRoute::init() (Initializes the route.)

      Parameters

      $config

      configuration for this module, can be null

      Remarks

      Initializes this module.

      This method is required by the IModule interface. It initializes the database for logging purpose.

      throws

      TConfigurationException if the DB table does not exist.

      access

      public

      [ Top ]

      TDbLogRoute::processLogs

      processLogs( array $logs );

      Overrides TLogRoute::processLogs() (Processes log messages and sends them to specific destination.)

      Parameters

      $logs

      list of log messages

      Remarks

      Stores log messages into database.

      access

      protected

      [ Top ]

      TDbLogRoute::setAutoCreateLogTable

      setAutoCreateLogTable( boolean $value );

      Parameters

      $value

      whether the log DB table should be automatically created if not exists.

      see

      TDbLogRoute::setLogTableName()

      access

      public

      [ Top ]

      TDbLogRoute::setConnectionID

      setConnectionID( string $value );

      Parameters

      $value

      ID of the TDataSourceConfig module

      Remarks

      Sets the ID of a TDataSourceConfig module.

      The datasource module will be used to establish the DB connection for this log route.

      access

      public

      [ Top ]

      TDbLogRoute::setLogTableName

      setLogTableName( string $value );

      Parameters

      $value

      the name of the DB table to store log content

      Remarks

      Sets the name of the DB table to store log content.

      Note, if AutoCreateLogTable is false and you want to create the DB table manually by yourself, you need to make sure the DB table is of the following structure: (key CHAR(128) PRIMARY KEY, value BLOB, expire INT)

      see

      TDbLogRoute::setAutoCreateLogTable()

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:47 +0200 by phpDocumentor 1.4.3


Docs For Class TEmailLogRoute

Class TEmailLogRoute

[line 510]
TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
         |
         --TEmailLogRoute
Location: /Util/TLogRouter.php

Remarks

TEmailLogRoute class.

TEmailLogRoute sends selected log messages to email addresses. The target email addresses may be specified via Emails property. Optionally, you may set the email Subject and the SentFrom address.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLogRouter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • DEFAULT_SUBJECT = 'Prado Application Log'
    Default email subject.
  • EMAIL_PATTERN = '/^([0-9a-zA-Z]+[-._+&])*[0-9a-zA-Z]+@([-0-9a-zA-Z]+[.])+[a-zA-Z]{2,6}$/'
    Regex pattern for email address.

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TLogRoute

  • TLogRoute::$_levelNames = array(
        TLogger::DEBUG=>'Debug',
        TLogger::INFO=>'Info',
        TLogger::NOTICE=>'Notice',
        TLogger::WARNING=>'Warning',
        TLogger::ERROR=>'Error',
        TLogger::ALERT=>'Alert',
        TLogger::FATAL=>'Fatal'
    )
  • TLogRoute::$_levelValues = array(
        'debug'=>TLogger::DEBUG,
        'info'=>TLogger::INFO,
        'notice'=>TLogger::NOTICE,
        'warning'=>TLogger::WARNING,
        'error'=>TLogger::ERROR,
        'alert'=>TLogger::ALERT,
        'fatal'=>TLogger::FATAL
    )

Method Summary

Inherited Method Summary

Inherited From Class TLogRoute

  • TLogRoute::collectLogs()
    Retrieves log messages from logger to log route specific destination.
  • TLogRoute::formatLogMessage()
    Formats a log message given different fields.
  • TLogRoute::getCategories()
  • TLogRoute::getLevelName()
  • TLogRoute::getLevels()
  • TLogRoute::getLevelValue()
  • TLogRoute::init()
    Initializes the route.
  • TLogRoute::processLogs()
    Processes log messages and sends them to specific destination.
  • TLogRoute::setCategories()
  • TLogRoute::setLevels()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TEmailLogRoute::getEmails

    getEmails( );

    Returns

    list of destination email addresses

    access

    public

    [ Top ]

    TEmailLogRoute::getSentFrom

    getSentFrom( );

    Returns

    send from address of the email

    access

    public

    [ Top ]

    TEmailLogRoute::getSubject

    getSubject( );

    Returns

    email subject. Defaults to TEmailLogRoute::DEFAULT_SUBJECT

    access

    public

    [ Top ]

    TEmailLogRoute::init

    init( TXmlElement $config );

    Overrides TLogRoute::init() (Initializes the route.)

    Parameters

    $config

    configurations specified in TLogRouter.

    Remarks

    Initializes the route.

    throws

    TConfigurationException if SentFrom is empty and 'sendmail_from' in php.ini is also empty.

    access

    public

    [ Top ]

    TEmailLogRoute::processLogs

    processLogs( array $logs );

    Overrides TLogRoute::processLogs() (Processes log messages and sends them to specific destination.)

    Parameters

    $logs

    list of log messages

    Remarks

    Sends log messages to specified email addresses.

    access

    protected

    [ Top ]

    TEmailLogRoute::setEmails

    setEmails( $emails );

    Parameters

    $emails

    Returns

    list of destination email addresses. If the value is a string, it is assumed to be comma-separated email addresses.

    access

    public

    [ Top ]

    TEmailLogRoute::setSentFrom

    setSentFrom( string $value );

    Parameters

    $value

    send from address of the email

    access

    public

    [ Top ]

    TEmailLogRoute::setSubject

    setSubject( string $value );

    Parameters

    $value

    email subject.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • DEFAULT_SUBJECT = 'Prado Application Log' [line 519]

    • Remarks

    Default email subject.

  • EMAIL_PATTERN = '/^([0-9a-zA-Z]+[-._+&])*[0-9a-zA-Z]+@([-0-9a-zA-Z]+[.])+[a-zA-Z]{2,6}$/' [line 515]

    • Remarks

    Regex pattern for email address.

Documentation generated on Mon, 25 Jun 2012 14:44:47 +0200 by phpDocumentor 1.4.3


Docs For Class TFileLogRoute

Class TFileLogRoute

[line 370]
TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
         |
         --TFileLogRoute
Location: /Util/TLogRouter.php

Remarks

TFileLogRoute class.

TFileLogRoute records log messages in files. The log files are stored under LogPath and the file name is specified by LogFile. If the size of the log file is greater than MaxFileSize (in kilo-bytes), a rotation is performed, which renames the current log file by suffixing the file name with '.1'. All existing log files are moved backwards one place, i.e., '.2' to '.3', '.1' to '.2'. The property MaxLogFiles specifies how many files to be kept.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLogRouter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TLogRoute

  • TLogRoute::$_levelNames = array(
        TLogger::DEBUG=>'Debug',
        TLogger::INFO=>'Info',
        TLogger::NOTICE=>'Notice',
        TLogger::WARNING=>'Warning',
        TLogger::ERROR=>'Error',
        TLogger::ALERT=>'Alert',
        TLogger::FATAL=>'Fatal'
    )
  • TLogRoute::$_levelValues = array(
        'debug'=>TLogger::DEBUG,
        'info'=>TLogger::INFO,
        'notice'=>TLogger::NOTICE,
        'warning'=>TLogger::WARNING,
        'error'=>TLogger::ERROR,
        'alert'=>TLogger::ALERT,
        'fatal'=>TLogger::FATAL
    )

Method Summary

Inherited Method Summary

Inherited From Class TLogRoute

  • TLogRoute::collectLogs()
    Retrieves log messages from logger to log route specific destination.
  • TLogRoute::formatLogMessage()
    Formats a log message given different fields.
  • TLogRoute::getCategories()
  • TLogRoute::getLevelName()
  • TLogRoute::getLevels()
  • TLogRoute::getLevelValue()
  • TLogRoute::init()
    Initializes the route.
  • TLogRoute::processLogs()
    Processes log messages and sends them to specific destination.
  • TLogRoute::setCategories()
  • TLogRoute::setLevels()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TFileLogRoute::getLogFile

    getLogFile( );

    Returns

    log file name. Defaults to 'prado.log'.

    access

    public

    [ Top ]

    TFileLogRoute::getLogPath

    getLogPath( );

    Returns

    directory storing log files. Defaults to application runtime path.

    access

    public

    [ Top ]

    TFileLogRoute::getMaxFileSize

    getMaxFileSize( );

    Returns

    maximum log file size in kilo-bytes (KB). Defaults to 1024 (1MB).

    access

    public

    [ Top ]

    TFileLogRoute::getMaxLogFiles

    getMaxLogFiles( );

    Returns

    number of files used for rotation. Defaults to 2.

    access

    public

    [ Top ]

    TFileLogRoute::processLogs

    processLogs( array $logs );

    Overrides TLogRoute::processLogs() (Processes log messages and sends them to specific destination.)

    Parameters

    $logs

    list of log messages

    Remarks

    Saves log messages in files.

    access

    protected

    [ Top ]

    TFileLogRoute::rotateFiles

    rotateFiles( );

    Remarks

    Rotates log files.

    access

    protected

    [ Top ]

    TFileLogRoute::setLogFile

    setLogFile( string $value );

    Parameters

    $value

    log file name

    access

    public

    [ Top ]

    TFileLogRoute::setLogPath

    setLogPath( string $value );

    Parameters

    $value

    directory (in namespace format) storing log files.

    throws

    TConfigurationException if log path is invalid

    access

    public

    [ Top ]

    TFileLogRoute::setMaxFileSize

    setMaxFileSize( integer $value );

    Parameters

    $value

    maximum log file size in kilo-bytes (KB).

    throws

    TInvalidDataValueException if the value is smaller than 1.

    access

    public

    [ Top ]

    TFileLogRoute::setMaxLogFiles

    setMaxLogFiles( integer $value );

    Parameters

    $value

    number of files used for rotation.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:47 +0200 by phpDocumentor 1.4.3


Docs For Class TFirebugLogRoute

Class TFirebugLogRoute

[line 1029]
TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
         |
         --TBrowserLogRoute
            |
            --TFirebugLogRoute
Location: /Util/TLogRouter.php

Remarks

TFirebugLogRoute class.

TFirebugLogRoute prints selected log messages in the firebug log console.

FireBug Website

author

Enrico Stahn <mail@enricostahn.com>, Christophe Boulain <Christophe.Boulain@gmail.com>

version

$Id: TLogRouter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TLogRoute

  • TLogRoute::$_levelNames = array(
        TLogger::DEBUG=>'Debug',
        TLogger::INFO=>'Info',
        TLogger::NOTICE=>'Notice',
        TLogger::WARNING=>'Warning',
        TLogger::ERROR=>'Error',
        TLogger::ALERT=>'Alert',
        TLogger::FATAL=>'Fatal'
    )
  • TLogRoute::$_levelValues = array(
        'debug'=>TLogger::DEBUG,
        'info'=>TLogger::INFO,
        'notice'=>TLogger::NOTICE,
        'warning'=>TLogger::WARNING,
        'error'=>TLogger::ERROR,
        'alert'=>TLogger::ALERT,
        'fatal'=>TLogger::FATAL
    )

Method Summary

Inherited Method Summary

Inherited From Class TBrowserLogRoute

  • TBrowserLogRoute::getColorLevel()
  • TBrowserLogRoute::getCssClass()
  • TBrowserLogRoute::processLogs()
  • TBrowserLogRoute::renderFooter()
  • TBrowserLogRoute::renderHeader()
  • TBrowserLogRoute::renderMessage()
  • TBrowserLogRoute::setCssClass()

Inherited From Class TLogRoute

  • TLogRoute::collectLogs()
    Retrieves log messages from logger to log route specific destination.
  • TLogRoute::formatLogMessage()
    Formats a log message given different fields.
  • TLogRoute::getCategories()
  • TLogRoute::getLevelName()
  • TLogRoute::getLevels()
  • TLogRoute::getLevelValue()
  • TLogRoute::init()
    Initializes the route.
  • TLogRoute::processLogs()
    Processes log messages and sends them to specific destination.
  • TLogRoute::setCategories()
  • TLogRoute::setLevels()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TFirebugLogRoute::getFirebugLoggingFunction

    getFirebugLoggingFunction( $level );

    Parameters

    $level

    access

    protected

    [ Top ]

    TFirebugLogRoute::renderFooter

    renderFooter( );

    Overrides TBrowserLogRoute::renderFooter() (parent method not documented)

    access

    protected

    [ Top ]

    TFirebugLogRoute::renderHeader

    renderHeader( );

    Overrides TBrowserLogRoute::renderHeader() (parent method not documented)

    access

    protected

    [ Top ]

    TFirebugLogRoute::renderMessage

    renderMessage( $log, $info );

    Overrides TBrowserLogRoute::renderMessage() (parent method not documented)

    Parameters

    $log

    $info

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:47 +0200 by phpDocumentor 1.4.3


Docs For Class TFirePhpLogRoute

Class TFirePhpLogRoute

[line 1106]
TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
         |
         --TFirePhpLogRoute
Location: /Util/TLogRouter.php

Remarks

TFirePhpLogRoute class.

TFirePhpLogRoute prints log messages in the firebug log console via firephp.

FireBug Website FirePHP Website

author

Yves Berkholz <godzilla80[at]gmx[dot]net>

version

$Id: TLogRouter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1.5

Class Variable Summary

Class Constant Summary

  • DEFAULT_LABEL =  'System.Util.TLogRouter(TFirePhpLogRoute)'
    Default group label

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TLogRoute

  • TLogRoute::$_levelNames = array(
        TLogger::DEBUG=>'Debug',
        TLogger::INFO=>'Info',
        TLogger::NOTICE=>'Notice',
        TLogger::WARNING=>'Warning',
        TLogger::ERROR=>'Error',
        TLogger::ALERT=>'Alert',
        TLogger::FATAL=>'Fatal'
    )
  • TLogRoute::$_levelValues = array(
        'debug'=>TLogger::DEBUG,
        'info'=>TLogger::INFO,
        'notice'=>TLogger::NOTICE,
        'warning'=>TLogger::WARNING,
        'error'=>TLogger::ERROR,
        'alert'=>TLogger::ALERT,
        'fatal'=>TLogger::FATAL
    )

Method Summary

  • static string translateLogLevel()
    Translates a PRADO log level attribute into one understood by FirePHP for correct visualization
  • string translateLogLevel()
    Translates a PRADO log level attribute into one understood by FirePHP for correct visualization

Inherited Method Summary

Inherited From Class TLogRoute

  • TLogRoute::collectLogs()
    Retrieves log messages from logger to log route specific destination.
  • TLogRoute::formatLogMessage()
    Formats a log message given different fields.
  • TLogRoute::getCategories()
  • TLogRoute::getLevelName()
  • TLogRoute::getLevels()
  • TLogRoute::getLevelValue()
  • TLogRoute::init()
    Initializes the route.
  • TLogRoute::processLogs()
    Processes log messages and sends them to specific destination.
  • TLogRoute::setCategories()
  • TLogRoute::setLevels()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    static TFirePhpLogRoute::translateLogLevel

    static translateLogLevel( string $level );

    Parameters

    $level

    prado log level

    Returns

    FirePHP log level

    Remarks

    Translates a PRADO log level attribute into one understood by FirePHP for correct visualization

    access

    protected

    [ Top ]

    TFirePhpLogRoute::getGroupLabel

    getGroupLabel( );

    Returns

    group label. Defaults to TFirePhpLogRoute::DEFAULT_LABEL

    access

    public

    [ Top ]

    TFirePhpLogRoute::processLogs

    processLogs( $logs );

    Overrides TLogRoute::processLogs() (Processes log messages and sends them to specific destination.)

    Parameters

    $logs

    access

    public

    [ Top ]

    TFirePhpLogRoute::setGroupLabel

    setGroupLabel( string $value );

    Parameters

    $value

    group label.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • DEFAULT_LABEL =  'System.Util.TLogRouter(TFirePhpLogRoute)' [line 1111]

    • Remarks

    Default group label

Documentation generated on Mon, 25 Jun 2012 14:44:48 +0200 by phpDocumentor 1.4.3


Docs For Class TLogRoute

Class TLogRoute

[line 197]
TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
Classes extended from TLogRoute:
TFileLogRoute
TFileLogRoute class.
TEmailLogRoute
TEmailLogRoute class.
TBrowserLogRoute
TBrowserLogRoute class.
TDbLogRoute
TDbLogRoute class
TFirePhpLogRoute
TFirePhpLogRoute class.

Location: /Util/TLogRouter.php

Remarks

TLogRoute class.

TLogRoute is the base class for all log route classes. A log route object retrieves log messages from a logger and sends it somewhere, such as files, emails. The messages being retrieved may be filtered first before being sent to the destination. The filters include log level filter and log category filter.

To specify level filter, set Levels property, which takes a string of comma-separated desired level names (e.g. 'Error, Debug'). To specify category filter, set Categories property, which takes a string of comma-separated desired category names (e.g. 'System.Web, System.IO').

Level filter and category filter are combinational, i.e., only messages satisfying both filter conditions will they be returned.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TLogRouter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.0

Class Variable Summary

  • static $_levelNames = array(
          TLogger::DEBUG=>'Debug',
          TLogger::INFO=>'Info',
          TLogger::NOTICE=>'Notice',
          TLogger::WARNING=>'Warning',
          TLogger::ERROR=>'Error',
          TLogger::ALERT=>'Alert',
          TLogger::FATAL=>'Fatal'
       )
  • static $_levelValues = array(
          'debug'=>TLogger::DEBUG,
          'info'=>TLogger::INFO,
          'notice'=>TLogger::NOTICE,
          'warning'=>TLogger::WARNING,
          'error'=>TLogger::ERROR,
          'alert'=>TLogger::ALERT,
          'fatal'=>TLogger::FATAL
       )

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TLogRoute::collectLogs

    collectLogs( TLogger $logger );

    Parameters

    $logger

    logger instance

    Remarks

    Retrieves log messages from logger to log route specific destination.

    access

    public

    [ Top ]

    TLogRoute::formatLogMessage

    formatLogMessage( string $message, integer $level, string $category, integer $time );

    Parameters

    $message

    message content

    $level

    message level

    $category

    message category

    $time

    timestamp

    Returns

    formatted message

    Remarks

    Formats a log message given different fields.

    access

    protected

    [ Top ]

    TLogRoute::getCategories

    getCategories( );

    Returns

    list of categories to be looked for

    access

    public

    [ Top ]

    TLogRoute::getLevelName

    getLevelName( integer $level );

    Parameters

    $level

    level value

    Returns

    level name

    access

    protected

    [ Top ]

    TLogRoute::getLevels

    getLevels( );

    Returns

    log level filter

    access

    public

    [ Top ]

    TLogRoute::getLevelValue

    getLevelValue( string $level );

    Parameters

    $level

    level name

    Returns

    level value

    access

    protected

    [ Top ]

    TLogRoute::init

    init( TXmlElement $config );

    Overridden in child classes as:

    TEmailLogRoute::init()
    Initializes the route.
    TDbLogRoute::init()
    Initializes this module.

    Parameters

    $config

    configurations specified in TLogRouter.

    Remarks

    Initializes the route.

    access

    public

    [ Top ]

    TLogRoute::processLogs

    processLogs( array $logs );

    Overridden in child classes as:

    TFileLogRoute::processLogs()
    Saves log messages in files.
    TEmailLogRoute::processLogs()
    Sends log messages to specified email addresses.
    TBrowserLogRoute::processLogs()
    TDbLogRoute::processLogs()
    Stores log messages into database.
    TFirePhpLogRoute::processLogs()

    Parameters

    $logs

    list of messages. Each array elements represents one message with the following structure: array( [0] => message [1] => level [2] => category [3] => timestamp);

    Remarks

    Processes log messages and sends them to specific destination.

    Derived child classes must implement this method.

    abstract

    access

    protected

    [ Top ]

    TLogRoute::setCategories

    setCategories( array|string $categories );

    Parameters

    $categories

    list of categories to be looked for. If the value is a string, it is assumed to be comma-separated category names.

    access

    public

    [ Top ]

    TLogRoute::setLevels

    setLevels( integer|string $levels );

    Parameters

    $levels

    integer log level filter (in bits). If the value is a string, it is assumed to be comma-separated level names. Valid level names include 'Debug', 'Info', 'Notice', 'Warning', 'Error', 'Alert' and 'Fatal'.

    access

    public

    [ Top ]

Variable Detail

  • static $_levelNames = array(
          TLogger::DEBUG=>'Debug',
          TLogger::INFO=>'Info',
          TLogger::NOTICE=>'Notice',
          TLogger::WARNING=>'Warning',
          TLogger::ERROR=>'Error',
          TLogger::ALERT=>'Alert',
          TLogger::FATAL=>'Fatal'
       )     [line 202]
  • Data type: array

    • var

    lookup table for level names

    access

    protected

  • static $_levelValues = array(
          'debug'=>TLogger::DEBUG,
          'info'=>TLogger::INFO,
          'notice'=>TLogger::NOTICE,
          'warning'=>TLogger::WARNING,
          'error'=>TLogger::ERROR,
          'alert'=>TLogger::ALERT,
          'fatal'=>TLogger::FATAL
       )     [line 214]
  • Data type: array

    • var

    lookup table for level values

    access

    protected

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:48 +0200 by phpDocumentor 1.4.3


Docs For Class TLogRouter

Class TLogRouter

[line 43]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TLogRouter
Location: /Util/TLogRouter.php

Remarks

TLogRouter class.

TLogRouter manages routes that record log messages in different media different ways. For example, a file log route TFileLogRoute records log messages in log files. An email log route TEmailLogRoute sends log messages to email addresses.

Log routes may be configured in application or page folder configuration files or an external configuration file specified by ConfigFile. The format is as follows,

  •    <route class="TFileLogRoute" Categories="System.Web.UI" Levels="Warning" />
    •

  •    <route class="TEmailLogRoute" Categories="Application" Levels="Fatal" Emails="admin@pradosoft.com" />
    •
    PHP configuration style:
      You can specify multiple routes with different filtering conditions and different  targets, even if the routes are of the same type.

    author

    Carl G. Mathisen <carlgmathisen@gmail.com>

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TLogRouter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TModule

    • TModule::getID()

    • TModule::init()

        Initializes the module.

    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()

    • TApplicationComponent::getRequest()

    • TApplicationComponent::getResponse()

    • TApplicationComponent::getService()

    • TApplicationComponent::getSession()

    • TApplicationComponent::getUser()

    • TApplicationComponent::publishAsset()

        Publishes a private asset and gets its URL.

    • TApplicationComponent::publishFilePath()

        Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()

        Processes an object that is created during parsing template.

    • TComponent::attachEventHandler()

        Attaches an event handler to an event.

    • TComponent::canGetProperty()

        Determines whether a property can be read.

    • TComponent::canSetProperty()

        Determines whether a property can be set.

    • TComponent::createdOnTemplate()

        This method is invoked after the component is instantiated by a template.

    • TComponent::detachEventHandler()

        Detaches an existing event handler.

    • TComponent::evaluateExpression()

        Evaluates a PHP expression in the context of this control.

    • TComponent::evaluateStatements()

        Evaluates a list of PHP statements.

    • TComponent::getEventHandlers()

        Returns the list of attached event handlers for an event.

    • TComponent::getSubProperty()

        Evaluates a property path.

    • TComponent::hasEvent()

        Determines whether an event is defined.

    • TComponent::hasEventHandler()

    • TComponent::hasProperty()

        Determines whether a property is defined.

    • TComponent::raiseEvent()

        Raises an event.

    • TComponent::setSubProperty()

        Sets a value to a property path.

    • TComponent::__call()

        Calls a method.

    • TComponent::__get()

        Returns a property value or an event handler list by property or event name.

    • TComponent::__set()

        Sets value of a component property.

    • TComponent::__sleep()

        Returns an array with the names of all variables of that object that should be serialized.

    • TComponent::__wakeup()

        Do not call this method. This is a PHP magic method that will be called automatically  after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TLogRouter::addRoute

addRoute(
TLogRoute
$route );

      Parameters

      $route

      Remarks

      Adds a TLogRoute instance to the log router.

      throws

      TInvalidDataTypeException if the route object is invalid

      access

      public

      [ Top ]

      TLogRouter::collectLogs

collectLogs(
mixed
$param );

      Parameters

      $param

      event parameter

      Remarks

      Collects log messages from a logger.

      This method is an event handler to application's EndRequest event.

      access

      public

      [ Top ]

      TLogRouter::getConfigFile

getConfigFile(
 );

      Returns

      external configuration file. Defaults to null.

      access

      public

      [ Top ]

      TLogRouter::init

init(
mixed
$config );

      Overrides TModule::init() (Initializes the module.)

      Parameters

      $config

      configuration for this module, can be null

      Remarks

      Initializes this module.

      This method is required by the IModule interface.

      throws

      TConfigurationException if ConfigFile is invalid.

      access

      public

      [ Top ]

      TLogRouter::setConfigFile

setConfigFile(
string
$value );

      Parameters

      $value

      external configuration file in namespace format. The file  must be suffixed with '.xml'.

      throws

      TConfigurationException if the file is invalid.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:48 +0200 by phpDocumentor 1.4.3


Docs For Class TParameterModule

Class TParameterModule

[line 48]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TParameterModule
Location: /Util/TParameterModule.php

Remarks

TParameterModule class

TParameterModule enables loading application parameters from external storage other than the application configuration. To load parameters from an XML file, configure the module by setting its ParameterFile property. Note, the property only accepts a file path in namespace format with file extension being '.xml'. The file format is as follows, which is similar to the parameter portion in an application configuration,

  •  <parameters>
    •

  •    <parameter id="param1" value="paramValue1" />
    •

  •    <parameter id="param2" Property1="Value1" Property2="Value2" ... />
    •

  •  </parameters>
    •

    In addition, any content enclosed within the module tag is also treated as parameters, e.g.,

  •  <module class="System.Util.TParameterModule">
    •

  •    <parameter id="param1" value="paramValue1" />
    •

  •    <parameter id="param2" Property1="Value1" Property2="Value2" ... />
    •

  •  </module>
    •

    If a parameter is defined both in the external file and within the module tag, the former takes precedence.

    author

    Carl G. Mathisen <carlgmathisen@gmail.com>

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TParameterModule.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    • PARAM_FILE_EXT = '.xml'

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TParameterModule::getParameterFile

      getParameterFile( );

      Returns

      the parameter file path

      access

      public

      [ Top ]

      TParameterModule::init

      init( mixed $config );

      Overrides TModule::init() (Initializes the module.)

      Parameters

      $config

      content enclosed within the module tag

      Remarks

      Initializes the module by loading parameters.

      access

      public

      [ Top ]

      TParameterModule::loadParameters

      loadParameters( mixed $config );

      Parameters

      $config

      XML of PHP representation of the parameters

      Remarks

      Loads parameters into application.

      throws

      TConfigurationException if the parameter file format is invalid

      access

      protected

      [ Top ]

      TParameterModule::setParameterFile

      setParameterFile( string $value );

      Parameters

      $value

      the parameter file path. It must be in namespace format and the file extension is '.xml'.

      throws

      TConfigurationException if the file is invalid

      throws

      TInvalidOperationException if the module is initialized

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • PARAM_FILE_EXT = '.xml' [line 53]

      • deprecated

      since 3.2

    Documentation generated on Mon, 25 Jun 2012 14:45:01 +0200 by phpDocumentor 1.4.3


Docs For Class TJsonRpcClient

Class TJsonRpcClient

[line 229]
TComponent
   |
   --TApplicationComponent
      |
      --TRpcClient
         |
         --TJsonRpcClient
Location: /Util/TRpcClient.php

Remarks

TJsonRpcClient class

Note: When using setIsNotification(true), *every* following request is also considered to be a notification until you use setIsNotification(false).

Usage:

 $_rpcClient = new TJsonRpcClient('http://host/server');
 $_result = $_rpcClient->remoteMethod($param, $otherParam);
 // or
 $_result = TJsonRpcClient::create('http://host/server')->remoteMethod($param, $otherParam);

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static void create()
    Creates an instance of TJsonRpcClient
  • void create()
    Creates an instance of TJsonRpcClient

Inherited Method Summary

Inherited From Class TRpcClient

  • TRpcClient::__construct()
  • TRpcClient::create()
    Creates an instance of the requested RPC client type
  • TRpcClient::createStreamContext()
    Creates a stream context resource
  • TRpcClient::getIsNotification()
  • TRpcClient::getServerUrl()
  • TRpcClient::performRequest()
    Performs the actual request
  • TRpcClient::setIsNotification()
  • TRpcClient::setServerUrl()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    static TJsonRpcClient::create

    static create( string $type, boolean $serverUrl, [ $isNotification = false] );

    Overrides TRpcClient::create() (Creates an instance of the requested RPC client type)

    Parameters

    $type

    url of the rpc server

    $serverUrl

    whether the requests are considered to be notifications (completely ignoring the response) (default: false)

    $isNotification

    Remarks

    Creates an instance of TJsonRpcClient

    access

    public

    [ Top ]

    TJsonRpcClient::encodeRequest

    encodeRequest( string $method, array $parameters );

    Parameters

    $method

    method name

    $parameters

    method parameters

    access

    public

    [ Top ]

    TJsonRpcClient::__call

    __call( string $method, array $parameters );

    Overrides TComponent::__call() (Calls a method.)

    Parameters

    $method

    RPC method name

    $parameters

    RPC method parameters

    Returns

    RPC request result

    throws

    TRpcClientResponseException if the response represents an RPC fault

    throws

    TRpcClientRequestException if the client fails to connect to the server

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs For Class TRpcClient

Class TRpcClient

[line 49]
TComponent
   |
   --TApplicationComponent
      |
      --TRpcClient
Classes extended from TRpcClient:
TJsonRpcClient
TJsonRpcClient class
TXmlRpcClient
TXmlRpcClient class

Location: /Util/TRpcClient.php

Remarks

TRpcClient class

Note: When using setIsNotification(true), *every* following request is also considered to be a notification until you use setIsNotification(false).

Usage:

First, you can use the factory:

 $_rpcClient = TRpcClient::create('xml', 'http://host/server');
 $_result = $_rpcClient->remoteMethodName($param, $otherParam);

or as oneliner:

 $_result = TRpcClient::create('json', 'http://host/server')->remoteMethod($param, ...);

Second, you can also use the specific implementation directly:

 $_rpcClient = new TXmlRpcClient('http://host/server');
 $_result = $_rpcClient->remoteMethod($param, ...);

or as oneliner:

 $_result = TXmlRpcClient('http://host/server')->hello();

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static TRpcClient create()
    Creates an instance of the requested RPC client type
  • TRpcClient create()
    Creates an instance of the requested RPC client type

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    static TRpcClient::create

    static create( $type, $serverUrl, [ $isNotification = false] );

    Overridden in child classes as:

    TJsonRpcClient::create()
    Creates an instance of TJsonRpcClient
    TXmlRpcClient::create()
    Creates an instance of TXmlRpcClient

    Parameters

    $type

    $serverUrl

    $isNotification

    Returns

    instance

    Remarks

    Creates an instance of the requested RPC client type

    throws

    TApplicationException if an unsupported RPC client type was specified

    access

    public

    [ Top ]

    TRpcClient::__construct

    __construct( string $serverUrl, [boolean $isNotification = false] );

    Parameters

    $serverUrl

    url to RPC server

    $isNotification

    whether requests are considered to be notifications (completely ignoring the response) (default: false)

    access

    public

    [ Top ]

    TRpcClient::createStreamContext

    createStreamContext( mixed $content, string $contentType );

    Parameters

    $content

    $contentType

    mime type

    Remarks

    Creates a stream context resource

    access

    protected

    [ Top ]

    TRpcClient::getIsNotification

    getIsNotification( );

    Returns

    whether requests are considered to be notifications (completely ignoring the response)

    access

    public

    [ Top ]

    TRpcClient::getServerUrl

    getServerUrl( );

    Returns

    url of the RPC server

    access

    public

    [ Top ]

    TRpcClient::performRequest

    performRequest( string $serverUrl, array $payload, string $mimeType );

    Parameters

    $serverUrl

    RPC server URL

    $payload

    payload data

    $mimeType

    request mime type

    Remarks

    Performs the actual request

    access

    protected

    [ Top ]

    TRpcClient::setIsNotification

    setIsNotification( string $bool );

    Parameters

    $bool

    boolean whether the requests are considered to be notifications (completely ignoring the response) (default: false)

    access

    public

    [ Top ]

    TRpcClient::setServerUrl

    setServerUrl( string $value );

    Parameters

    $value

    url of the RPC server

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs For Class TRpcClientRequestException

Class TRpcClientRequestException

[line 180]
Exception
   |
   --TException
      |
      --TApplicationException
         |
         --TRpcClientRequestException
Location: /Util/TRpcClient.php

Remarks

TRpcClientRequestException class

This Exception is fired if the RPC request fails because of transport problems e.g. when there is no RPC server responding on the given remote host.

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs For Class TRpcClientResponseException

Class TRpcClientResponseException

[line 195]
Exception
   |
   --TException
      |
      --TApplicationException
         |
         --TRpcClientResponseException
Location: /Util/TRpcClient.php

Remarks

TRpcClientResponseException class

This Exception is fired when the

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

    TRpcClientResponseException::__construct

    __construct( string $errorMessage, [integer $errorCode = null] );

    Overrides TException::__construct() (Constructor.)

    Parameters

    $errorMessage

    error message

    $errorCode

    error code (optional)

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs For Class TRpcClientTypesEnumerable

Class TRpcClientTypesEnumerable

[line 162]
TEnumerable
   |
   --TRpcClientTypesEnumerable
Location: /Util/TRpcClient.php

Remarks

TRpcClientTypesEnumerable class

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

since

3.2

Class Variable Summary

Class Constant Summary

  • JSON =  'TJsonRpcClient'
  • XML =  'TXmlRpcClient'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • JSON =  'TJsonRpcClient' [line 164]

  • XML =  'TXmlRpcClient' [line 165]

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs For Class TXmlRpcClient

Class TXmlRpcClient

[line 307]
TComponent
   |
   --TApplicationComponent
      |
      --TRpcClient
         |
         --TXmlRpcClient
Location: /Util/TRpcClient.php

Remarks

TXmlRpcClient class

Note: When using setIsNotification(true), *every* following request is also considered to be a notification until you use setIsNotification(false).

Usage:

 $_rpcClient = new TXmlRpcClient('http://remotehost/rpcserver');
 $_rpcClient->remoteMethod($param, $otherParam);

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static void create()
    Creates an instance of TXmlRpcClient
  • void create()
    Creates an instance of TXmlRpcClient

Inherited Method Summary

Inherited From Class TRpcClient

  • TRpcClient::__construct()
  • TRpcClient::create()
    Creates an instance of the requested RPC client type
  • TRpcClient::createStreamContext()
    Creates a stream context resource
  • TRpcClient::getIsNotification()
  • TRpcClient::getServerUrl()
  • TRpcClient::performRequest()
    Performs the actual request
  • TRpcClient::setIsNotification()
  • TRpcClient::setServerUrl()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    static TXmlRpcClient::create

    static create( string $type, boolean $serverUrl, [ $isNotification = false] );

    Overrides TRpcClient::create() (Creates an instance of the requested RPC client type)

    Parameters

    $type

    url of the rpc server

    $serverUrl

    whether the requests are considered to be notifications (completely ignoring the response) (default: false)

    $isNotification

    Remarks

    Creates an instance of TXmlRpcClient

    access

    public

    [ Top ]

    TXmlRpcClient::encodeRequest

    encodeRequest( string $method, array $parameters );

    Parameters

    $method

    method name

    $parameters

    method parameters

    access

    public

    [ Top ]

    TXmlRpcClient::__call

    __call( string $method, array $parameters );

    Overrides TComponent::__call() (Calls a method.)

    Parameters

    $method

    RPC method name

    $parameters

    RPC method parameters

    Returns

    RPC request result

    throws

    TRpcClientResponseException if the response represents an RPC fault

    throws

    TRpcClientRequestException if the client fails to connect to the server

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs For Class TSimpleDateFormatter

Class TSimpleDateFormatter

[line 47]

Location: /Util/TSimpleDateFormatter.php

Remarks

TSimpleDateFormatter class.

Formats and parses dates using the SimpleDateFormat pattern.  This pattern is compatible with the I18N and java's SimpleDateFormatter.
  •  Pattern |      Description
    •

  •  ----------------------------------------------------
    •

  •  d       | Day of month 1 to 31, no padding
    •

  •  dd      | Day of monath 01 to 31, zero leading
    •

  •  M       | Month digit 1 to 12, no padding
    •

  •  MM      | Month digit 01 to 12, zero leading
    •

  •  yy      | 2 year digit, e.g., 96, 05
    •

  •  yyyy    | 4 year digit, e.g., 2005
    •

  •  ----------------------------------------------------
    •

    Usage example, to format a date
  •  $formatter = new TSimpleDateFormatter("dd/MM/yyy");
    •

  •  echo $formatter->format(time());
    •

    To parse the date string into a date timestamp.
  •  $formatter = new TSimpleDateFormatter("d-M-yyy");
    •

  •  echo $formatter->parse("24-6-2005");
    •

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: TSimpleDateFormatter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Method Detail

      TSimpleDateFormatter::__construct

__construct(
string
$pattern, [string
$charset = 'UTF-8'] );

      Parameters

      $pattern

      formatting pattern.

      $charset

      pattern and value charset

      Remarks

      Constructor, create a new date time formatter.

      access

      public

      [ Top ]

      TSimpleDateFormatter::format

format(
string|int
$value );

      Parameters

      $value

      the date to format, either integer or a string readable by strtotime.

      Returns

      formatted date.

      Remarks

      Format the date according to the pattern.

      access

      public

      [ Top ]

      TSimpleDateFormatter::getCharset

getCharset(
 );

      Returns

      formatting charset.

      access

      public

      [ Top ]

      TSimpleDateFormatter::getDayMonthYearOrdering

getDayMonthYearOrdering(
 );

      access

      public

      [ Top ]

      TSimpleDateFormatter::getDayPattern

getDayPattern(
 );

      access

      public

      [ Top ]

      TSimpleDateFormatter::getMonthPattern

getMonthPattern(
 );

      access

      public

      [ Top ]

      TSimpleDateFormatter::getPattern

getPattern(
 );

      Returns

      formatting pattern.

      access

      public

      [ Top ]

      TSimpleDateFormatter::getYearPattern

getYearPattern(
 );

      access

      public

      [ Top ]

      TSimpleDateFormatter::isValidDate

isValidDate(

$value );

      Parameters

      $value

      Returns

      true if the given value matches with the date pattern.

      access

      public

      [ Top ]

      TSimpleDateFormatter::parse

parse(
string|int
$value, [
$defaultToCurrentTime = true] );

      Parameters

      $value

      date string or integer to parse

      $defaultToCurrentTime

      Returns

      date time stamp

      Remarks

      Parse the string according to the pattern.

      throws

      TInvalidDataValueException if date string is malformed.

      access

      public

      [ Top ]

      TSimpleDateFormatter::setCharset

setCharset(
string
$charset );

      Parameters

      $charset

      formatting charset.

      access

      public

      [ Top ]

      TSimpleDateFormatter::setPattern

setPattern(
string
$pattern );

      Parameters

      $pattern

      formatting pattern.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:21 +0200 by phpDocumentor 1.4.3


Docs For Class TVarDumper

Class TVarDumper

[line 31]

Location: /Util/TVarDumper.php

Remarks

TVarDumper class.

TVarDumper is intended to replace the buggy PHP function var_dump and print_r.  It can correctly identify the recursively referenced objects in a complex  object structure. It also has a recursive depth control to avoid indefinite  recursive display of some peculiar variables.
TVarDumper can be used as follows,
  •    echo TVarDumper::dump($var);
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TVarDumper.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    • static string dump()

      Converts a variable into a string representation.

    • string dump()

      Converts a variable into a string representation.

    Inherited Method Summary

    Method Detail

      static TVarDumper::dump

static dump(
mixed
$var, [integer
$depth = 10], [
$highlight = false] );

      Parameters

      $var

      variable to be dumped

      $depth

      maximum depth that the dumper should go into the variable. Defaults to 10.

      $highlight

      Returns

      the string representation of the variable

      Remarks

      Converts a variable into a string representation.

      This method achieves the similar functionality as var_dump and print_r  but is more robust when handling complex objects such as PRADO controls.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:47 +0200 by phpDocumentor 1.4.3


Package System.Data.DataGateway Element Index

Element index for package System.Data.DataGateway

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
c d e f g i o q s t u _
top
_
__call in file TTableGateway.php, method TTableGateway::__call()
Dynamic find method using parts of method name as search criteria.
__construct in file TTableGateway.php, method TTableGateway::__construct()
Creates a new generic table gateway for a given table or view name and a database connection.
__construct | in file TDataGatewayCommand.php, method TDataGatewayCommand::__construct()
__construct in file TSqlCriteria.php, method TSqlCriteria::__construct()
Creates a new criteria with given condition;
__construct | in file TDataGatewayCommand.php, method TDataGatewayEventParameter::__construct()
__construct | in file TDataGatewayCommand.php, method TDataGatewayResultEventParameter::__construct()
__toString | in file TSqlCriteria.php, method TSqlCriteria::__toString()
top
c
count | in file TDataGatewayCommand.php, method TDataGatewayCommand::count()
count in file TTableGateway.php, method TTableGateway::count()
Find the number of records.
createCriteriaFromString | in file TDataGatewayCommand.php, method TDataGatewayCommand::createCriteriaFromString()
top
d
delete in file TDataGatewayCommand.php, method TDataGatewayCommand::delete()
Executes a delete command.
deleteAll in file TTableGateway.php, method TTableGateway::deleteAll()
Delete records from the table with condition given by $where and binding values specified by $parameter argument.
deleteAllByPks in file TTableGateway.php, method TTableGateway::deleteAllByPks()
Alias for deleteByPk()
deleteByPk in file TTableGateway.php, method TTableGateway::deleteByPk()
Delete records by primary key. Usage:
deleteByPk | in file TDataGatewayCommand.php, method TDataGatewayCommand::deleteByPk()
top
e
extractMatchingConditions in file TDataGatewayCommand.php, method TDataGatewayCommand::extractMatchingConditions()
Calculates the AND/OR condition from dynamic method substrings using table meta data, allows for any AND-OR combinations.
top
f
find in file TDataGatewayCommand.php, method TDataGatewayCommand::find()
Find one record matching the critera.
find in file TTableGateway.php, method TTableGateway::find()
Find one single record that matches the criteria.
findAll in file TDataGatewayCommand.php, method TDataGatewayCommand::findAll()
Find one or more matching records.
findAll in file TTableGateway.php, method TTableGateway::findAll()
Accepts same parameters as find(), but returns TDbDataReader instead.
findAllByIndex | in file TDataGatewayCommand.php, method TDataGatewayCommand::findAllByIndex()
findAllByPk | in file TDataGatewayCommand.php, method TDataGatewayCommand::findAllByPk()
findAllByPks in file TTableGateway.php, method TTableGateway::findAllByPks()
Similar to findByPk(), but returns TDbDataReader instead.
findAllBySql in file TDataGatewayCommand.php, method TDataGatewayCommand::findAllBySql()
Find zero or more matching records for arbituary SQL.
findAllBySql in file TTableGateway.php, method TTableGateway::findAllBySql()
Execute arbituary sql command with binding parameters.
findByPk in file TTableGateway.php, method TTableGateway::findByPk()
Find one record using only the primary key or composite primary keys. Usage:
findByPk | in file TDataGatewayCommand.php, method TDataGatewayCommand::findByPk()
findBySql in file TTableGateway.php, method TTableGateway::findBySql()
Execute arbituary sql command with binding parameters.
findBySql in file TDataGatewayCommand.php, method TDataGatewayCommand::findBySql()
Find one matching records for arbituary SQL.
top
g
getBuilder | in file TDataGatewayCommand.php, method TDataGatewayCommand::getBuilder()
getCommand | in file TDataGatewayCommand.php, method TDataGatewayResultEventParameter::getCommand()
getCommand | in file TTableGateway.php, method TTableGateway::getCommand()
getCommand in file TDataGatewayCommand.php, method TDataGatewayEventParameter::getCommand()
The database command to be executed. Do not rebind the parameters or change the sql query string.
getCompositeKeyCondition in file TDataGatewayCommand.php, method TDataGatewayCommand::getCompositeKeyCondition()
Construct a "pk IN ('key1', 'key2', ...)" criteria.
getCondition | in file TSqlCriteria.php, method TSqlCriteria::getCondition()
getCriteria in file TTableGateway.php, method TTableGateway::getCriteria()
Create a new TSqlCriteria object from a string $criteria. The $args are additional parameters and are used in place of the $parameters if $parameters is not an array and $args is an arrary.
getCriteria | in file TDataGatewayCommand.php, method TDataGatewayEventParameter::getCriteria()
getDbConnection | in file TDataGatewayCommand.php, method TDataGatewayCommand::getDbConnection()
getDbConnection | in file TTableGateway.php, method TTableGateway::getDbConnection()
getFindCommand in file TDataGatewayCommand.php, method TDataGatewayCommand::getFindCommand()
Build the find command from the criteria. Limit, Offset and Ordering are applied if applicable.
getIndexKeyCondition | in file TDataGatewayCommand.php, method TDataGatewayCommand::getIndexKeyCondition()
getIsNamedParameters | in file TSqlCriteria.php, method TSqlCriteria::getIsNamedParameters()
getLastInsertID in file TDataGatewayCommand.php, method TDataGatewayCommand::getLastInsertID()
Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
getLastInsertId | in file TTableGateway.php, method TTableGateway::getLastInsertId()
getLimit | in file TSqlCriteria.php, method TSqlCriteria::getLimit()
getOffset | in file TSqlCriteria.php, method TSqlCriteria::getOffset()
getOrdersBy | in file TSqlCriteria.php, method TSqlCriteria::getOrdersBy()
getParameters | in file TSqlCriteria.php, method TSqlCriteria::getParameters()
getPrimaryKeyCondition in file TDataGatewayCommand.php, method TDataGatewayCommand::getPrimaryKeyCondition()
Create the condition and parameters for find by primary.
getResult | in file TDataGatewayCommand.php, method TDataGatewayResultEventParameter::getResult()
getSelect in file TSqlCriteria.php, method TSqlCriteria::getSelect()
Gets the field list to be placed after the SELECT in the SQL. Default to '*'
getSqlCommand in file TDataGatewayCommand.php, method TDataGatewayCommand::getSqlCommand()
Build sql command from the criteria. Limit, Offset and Ordering are applied if applicable.
getTableInfo | in file TDataGatewayCommand.php, method TDataGatewayCommand::getTableInfo()
getTableInfo | in file TTableGateway.php, method TTableGateway::getTableInfo()
getTableName | in file TTableGateway.php, method TTableGateway::getTableName()
top
i
initCommandBuilder | in file TTableGateway.php, method TTableGateway::initCommandBuilder()
insert in file TTableGateway.php, method TTableGateway::insert()
Inserts a new record into the table. Each array key must correspond to a column name in the table unless a null value is permitted.
insert in file TDataGatewayCommand.php, method TDataGatewayCommand::insert()
Inserts a new record into the table. Each array key must correspond to a column name in the table unless a null value is permitted.
top
o
onCreateCommand in file TTableGateway.php, method TTableGateway::onCreateCommand()
Raised when a command is prepared and parameter binding is completed.
onCreateCommand in file TDataGatewayCommand.php, method TDataGatewayCommand::onCreateCommand()
Raised when a command is prepared and parameter binding is completed.
onExecuteCommand in file TTableGateway.php, method TTableGateway::onExecuteCommand()
Raised when a command is executed and the result from the database was returned.
onExecuteCommand in file TDataGatewayCommand.php, method TDataGatewayCommand::onExecuteCommand()
Raised when a command is executed and the result from the database was returned.
top
q
quoteTuple | in file TDataGatewayCommand.php, method TDataGatewayCommand::quoteTuple()
top
s
setCondition in file TSqlCriteria.php, method TSqlCriteria::setCondition()
Sets the search conditions to be placed after the WHERE clause in the SQL.
setLimit | in file TSqlCriteria.php, method TSqlCriteria::setLimit()
setOffset | in file TSqlCriteria.php, method TSqlCriteria::setOffset()
setOrdersBy | in file TSqlCriteria.php, method TSqlCriteria::setOrdersBy()
setParameters | in file TSqlCriteria.php, method TSqlCriteria::setParameters()
setResult | in file TDataGatewayCommand.php, method TDataGatewayResultEventParameter::setResult()
setSelect in file TSqlCriteria.php, method TSqlCriteria::setSelect()
Sets the field list to be placed after the SELECT in the SQL.
setTableInfo | in file TTableGateway.php, method TTableGateway::setTableInfo()
setTableName in file TTableGateway.php, method TTableGateway::setTableName()
Sets up the command builder for the given table.
top
t
TDataGatewayCommand.php | procedural page TDataGatewayCommand.php
TSqlCriteria.php | procedural page TSqlCriteria.php
TTableGateway.php | procedural page TTableGateway.php
TDataGatewayCommand in file TDataGatewayCommand.php, class TDataGatewayCommand
TDataGatewayCommand is command builder and executor class for TTableGateway and TActiveRecordGateway.
TDataGatewayEventParameter in file TDataGatewayCommand.php, class TDataGatewayEventParameter
TDataGatewayEventParameter class contains the TDbCommand to be executed as well as the criteria object.
TDataGatewayResultEventParameter in file TDataGatewayCommand.php, class TDataGatewayResultEventParameter
TDataGatewayResultEventParameter contains the TDbCommand executed and the resulting data returned from the database. The data can be changed by changing the setResult property.
TSqlCriteria in file TSqlCriteria.php, class TSqlCriteria
Search criteria for TDbDataGateway.
TTableGateway in file TTableGateway.php, class TTableGateway
TTableGateway class provides several find methods to get data from the database and update, insert, and delete methods.
top
u
update in file TDataGatewayCommand.php, method TDataGatewayCommand::update()
Updates the table with new data.
update in file TTableGateway.php, method TTableGateway::update()
Updates the table with new name-value pair $data. Each array key must correspond to a column name in the table. The update condition is specified by the $where argument and additional binding values can be specified using the $parameter argument.
updateByPk | in file TDataGatewayCommand.php, method TDataGatewayCommand::updateByPk()


Class Trees for Package System.Data.DataGateway

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TDataGatewayCommand.php

File: /Data/DataGateway/TDataGatewayCommand.php

Remarks

TDataGatewayCommand, TDataGatewayEventParameter and TDataGatewayResultEventParameter class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDataGatewayCommand
TDataGatewayCommand is command builder and executor class for TTableGateway and TActiveRecordGateway.
TDataGatewayEventParameter
TDataGatewayEventParameter class contains the TDbCommand to be executed as well as the criteria object.
TDataGatewayResultEventParameter
TDataGatewayResultEventParameter contains the TDbCommand executed and the resulting data returned from the database. The data can be changed by changing the setResult property.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:43:57 +0200 by phpDocumentor 1.4.3


Docs for page TSqlCriteria.php

File: /Data/DataGateway/TSqlCriteria.php

Remarks

TDbSqlCriteria class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDbSqlCriteria.php 1835 2007-04-03 01:38:15Z wei $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqlCriteria
Search criteria for TDbDataGateway.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:23 +0200 by phpDocumentor 1.4.3


Docs for page TTableGateway.php

File: /Data/DataGateway/TTableGateway.php

Remarks

TTableGateway class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTableGateway
TTableGateway class provides several find methods to get data from the database and update, insert, and delete methods.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:33 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGatewayCommand

Class TDataGatewayCommand

[line 37]
TComponent
   |
   --TDataGatewayCommand
Location: /Data/DataGateway/TDataGatewayCommand.php

Remarks

TDataGatewayCommand is command builder and executor class for TTableGateway and TActiveRecordGateway.

TDataGatewayCommand builds the TDbCommand for TTableGateway and TActiveRecordGateway commands such as find(), update(), insert(), etc, using the TDbCommandBuilder classes (database specific TDbCommandBuilder classes are used).

Once the command is built and the query parameters are binded, the OnCreateCommand event is raised. Event handlers for the OnCreateCommand event should not alter the Command property nor the Criteria property of the TDataGatewayEventParameter.

TDataGatewayCommand excutes the TDbCommands and returns the result obtained from the database (returned value depends on the method executed). The OnExecuteCommand event is raised after the command is executed and resulting data is set in the TDataGatewayResultEventParameter object's Result property.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id$

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGatewayCommand::__construct

    __construct( TDbCommandBuilder $builder );

    Parameters

    $builder

    database specific database command builder.

    access

    public

    [ Top ]

    TDataGatewayCommand::count

    count( TSqlCriteria $criteria );

    Parameters

    $criteria

    Returns

    number of records.

    access

    public

    [ Top ]

    TDataGatewayCommand::createCriteriaFromString

    createCriteriaFromString( string $method, string $condition, array $args );

    Parameters

    $method

    __call method name

    $condition

    criteria conditions

    $args

    method arguments

    Returns

    criteria created from the method name and its arguments.

    access

    public

    [ Top ]

    TDataGatewayCommand::delete

    delete( TSqlCriteria $criteria );

    Parameters

    $criteria

    delete conditions and parameters.

    Returns

    number of records affected.

    Remarks

    Executes a delete command.

    access

    public

    [ Top ]

    TDataGatewayCommand::deleteByPk

    deleteByPk( array $keys );

    Parameters

    $keys

    multiple primary key values or composite value arrays

    Returns

    number of rows affected.

    access

    public

    [ Top ]

    TDataGatewayCommand::extractMatchingConditions

    extractMatchingConditions( string $method, string $condition );

    Parameters

    $method

    dynamic method name

    $condition

    dynamic method search criteria

    Returns

    search condition substrings

    Remarks

    Calculates the AND/OR condition from dynamic method substrings using table meta data, allows for any AND-OR combinations.

    access

    protected

    [ Top ]

    TDataGatewayCommand::find

    find( TSqlCriteria $criteria );

    Parameters

    $criteria

    find conditions and parameters.

    Returns

    matching record.

    Remarks

    Find one record matching the critera.

    access

    public

    [ Top ]

    TDataGatewayCommand::findAll

    findAll( TSqlCriteria $criteria );

    Parameters

    $criteria

    Returns

    record reader.

    Remarks

    Find one or more matching records.

    access

    public

    [ Top ]

    TDataGatewayCommand::findAllByIndex

    findAllByIndex( $criteria, $fields, $values );

    Parameters

    $criteria

    $fields

    $values

    access

    public

    [ Top ]

    TDataGatewayCommand::findAllByPk

    findAllByPk( array $keys );

    Parameters

    $keys

    multiple primary key values or composite value arrays

    Returns

    record reader.

    access

    public

    [ Top ]

    TDataGatewayCommand::findAllBySql

    findAllBySql( TSqlCriteria $criteria );

    Parameters

    $criteria

    Returns

    record reader.

    Remarks

    Find zero or more matching records for arbituary SQL.

    access

    public

    [ Top ]

    TDataGatewayCommand::findByPk

    findByPk( mixed $keys );

    Parameters

    $keys

    primary key value, or composite key values as array.

    Returns

    matching record.

    access

    public

    [ Top ]

    TDataGatewayCommand::findBySql

    findBySql( TSqlCriteria $criteria );

    Parameters

    $criteria

    Returns

    record reader.

    Remarks

    Find one matching records for arbituary SQL.

    access

    public

    [ Top ]

    TDataGatewayCommand::getBuilder

    getBuilder( );

    access

    public

    [ Top ]

    TDataGatewayCommand::getCompositeKeyCondition

    getCompositeKeyCondition( array $values, string 1 );

    Parameters

    1

    SQL string for primary keys IN a list.

    $values

    values for IN predicate

    Remarks

    Construct a "pk IN ('key1', 'key2', ...)" criteria.

    access

    protected

    [ Top ]

    TDataGatewayCommand::getDbConnection

    getDbConnection( );

    access

    public

    [ Top ]

    TDataGatewayCommand::getFindCommand

    getFindCommand( TSqlCriteria $criteria );

    Parameters

    $criteria

    Remarks

    Build the find command from the criteria. Limit, Offset and Ordering are applied if applicable.

    access

    protected

    [ Top ]

    TDataGatewayCommand::getIndexKeyCondition

    getIndexKeyCondition( $table, $fields, $values );

    Parameters

    $table

    $fields

    $values

    access

    public

    [ Top ]

    TDataGatewayCommand::getLastInsertID

    getLastInsertID( );

    Returns

    last insert id, null if none is found.

    Remarks

    Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.

    access

    public

    [ Top ]

    TDataGatewayCommand::getPrimaryKeyCondition

    getPrimaryKeyCondition( array $values );

    Parameters

    $values

    primary key values

    Returns

    tuple($where, $parameters)

    Remarks

    Create the condition and parameters for find by primary.

    access

    protected

    [ Top ]

    TDataGatewayCommand::getSqlCommand

    getSqlCommand( TSqlCriteria $criteria );

    Parameters

    $criteria

    Returns

    command corresponding to the criteria.

    Remarks

    Build sql command from the criteria. Limit, Offset and Ordering are applied if applicable.

    access

    protected

    [ Top ]

    TDataGatewayCommand::getTableInfo

    getTableInfo( );

    access

    public

    [ Top ]

    TDataGatewayCommand::insert

    insert( array $data );

    Parameters

    $data

    new record data.

    Returns

    last insert id if one column contains a serial or sequence, otherwise true if command executes successfully and affected 1 or more rows.

    Remarks

    Inserts a new record into the table. Each array key must correspond to a column name in the table unless a null value is permitted.

    access

    public

    [ Top ]

    TDataGatewayCommand::onCreateCommand

    onCreateCommand( TDataGatewayCommand $command, TDataGatewayEventParameter $criteria );

    Parameters

    $command

    originator $sender

    $criteria

    Remarks

    Raised when a command is prepared and parameter binding is completed.

    The parameter object is TDataGatewayEventParameter of which the TDataGatewayEventParameter::getCommand property can be inspected to obtain the sql query to be executed.

    access

    public

    [ Top ]

    TDataGatewayCommand::onExecuteCommand

    onExecuteCommand( TDataGatewayCommand $command, TDataGatewayResultEventParameter $result );

    Parameters

    $command

    originator $sender

    $result

    Remarks

    Raised when a command is executed and the result from the database was returned.

    The parameter object is TDataGatewayResultEventParameter of which the TDataGatewayEventParameter::getResult property contains the data return from the database. The data returned can be changed by setting the TDataGatewayEventParameter::setResult property.

    access

    public

    [ Top ]

    TDataGatewayCommand::quoteTuple

    quoteTuple( TDbConnection $array, array 1 );

    Parameters

    1

    values

    $array

    database connection.

    Returns

    quoted recursive tuple values, e.g. "('val1', 'val2')".

    access

    protected

    [ Top ]

    TDataGatewayCommand::update

    update( array $data, TSqlCriteria $criteria );

    Parameters

    $data

    date for update.

    $criteria

    update conditions and parameters.

    Returns

    number of records affected.

    Remarks

    Updates the table with new data.

    access

    public

    [ Top ]

    TDataGatewayCommand::updateByPk

    updateByPk( array $data, array $keys );

    Parameters

    $data

    update for update

    $keys

    primary key-value name pairs.

    Returns

    number of records affected.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:57 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGatewayEventParameter

Class TDataGatewayEventParameter

[line 465]
TComponent
   |
   --TEventParameter
      |
      --TDataGatewayEventParameter
Location: /Data/DataGateway/TDataGatewayCommand.php

Remarks

TDataGatewayEventParameter class contains the TDbCommand to be executed as well as the criteria object.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id$

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGatewayEventParameter::__construct

    __construct( $command, $criteria );

    Parameters

    $command

    $criteria

    access

    public

    [ Top ]

    TDataGatewayEventParameter::getCommand

    getCommand( );

    Returns

    command to be executed.

    Remarks

    The database command to be executed. Do not rebind the parameters or change the sql query string.

    access

    public

    [ Top ]

    TDataGatewayEventParameter::getCriteria

    getCriteria( );

    Returns

    criteria used to bind the sql query parameters.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:57 +0200 by phpDocumentor 1.4.3


Docs For Class TDataGatewayResultEventParameter

Class TDataGatewayResultEventParameter

[line 505]
TComponent
   |
   --TEventParameter
      |
      --TDataGatewayResultEventParameter
Location: /Data/DataGateway/TDataGatewayCommand.php

Remarks

TDataGatewayResultEventParameter contains the TDbCommand executed and the resulting data returned from the database. The data can be changed by changing the setResult property.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id$

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDataGatewayResultEventParameter::__construct

    __construct( $command, $result );

    Parameters

    $command

    $result

    access

    public

    [ Top ]

    TDataGatewayResultEventParameter::getCommand

    getCommand( );

    Returns

    database command executed.

    access

    public

    [ Top ]

    TDataGatewayResultEventParameter::getResult

    getResult( );

    Returns

    result returned from executing the command.

    access

    public

    [ Top ]

    TDataGatewayResultEventParameter::setResult

    setResult( mixed $value );

    Parameters

    $value

    change the result returned by the gateway.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:43:58 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlCriteria

Class TSqlCriteria

[line 32]
TComponent
   |
   --TSqlCriteria
Classes extended from TSqlCriteria:
TActiveRecordCriteria
Search criteria for Active Record.

Location: /Data/DataGateway/TSqlCriteria.php

Remarks

Search criteria for TDbDataGateway.

Criteria object for data gateway finder methods. Usage:

  •  $criteria = new TSqlCriteria();
    •

  •  $criteria->Parameters[':name'] = 'admin';
    •

  •  $criteria->Parameters[':pass'] = 'prado';
    •

  •  $criteria->OrdersBy['level'] = 'desc';
    •

  •  $criteria->OrdersBy['name'] = 'asc';
    •

  •  $criteria->Limit = 10;
    •

  •  $criteria->Offset = 20;
    •

    author

    Wei Zhuo <weizho[at]gmail[dot]com>

    version

    $Id: TDbSqlCriteria.php 1835 2007-04-03 01:38:15Z wei $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TSqlCriteria::__construct

      __construct( [string $condition = null], [mixed $parameters = array()] );

      Parameters

      $condition

      sql string after the WHERE stanza

      $parameters

      named or indexed parameters, accepts as multiple arguments.

      Remarks

      Creates a new criteria with given condition;

      access

      public

      [ Top ]

      TSqlCriteria::getCondition

      getCondition( );

      Returns

      search conditions.

      access

      public

      [ Top ]

      TSqlCriteria::getIsNamedParameters

      getIsNamedParameters( );

      Returns

      true if the parameter index are string base, false otherwise.

      access

      public

      [ Top ]

      TSqlCriteria::getLimit

      getLimit( );

      Returns

      maximum number of records to return.

      access

      public

      [ Top ]

      TSqlCriteria::getOffset

      getOffset( );

      Returns

      record offset.

      access

      public

      [ Top ]

      TSqlCriteria::getOrdersBy

      getOrdersBy( );

      Returns

      ordering clause.

      access

      public

      [ Top ]

      TSqlCriteria::getParameters

      getParameters( );

      Returns

      list of named parameters and values.

      access

      public

      [ Top ]

      TSqlCriteria::getSelect

      getSelect( );

      Remarks

      Gets the field list to be placed after the SELECT in the SQL. Default to '*'

      since

      3.1.7

      access

      public

      [ Top ]

      TSqlCriteria::setCondition

      setCondition( string $value );

      Parameters

      $value

      search conditions.

      Remarks

      Sets the search conditions to be placed after the WHERE clause in the SQL.

      access

      public

      [ Top ]

      TSqlCriteria::setLimit

      setLimit( int $value );

      Parameters

      $value

      maximum number of records to return.

      access

      public

      [ Top ]

      TSqlCriteria::setOffset

      setOffset( int $value );

      Parameters

      $value

      record offset.

      access

      public

      [ Top ]

      TSqlCriteria::setOrdersBy

      setOrdersBy( mixed $value );

      Parameters

      $value

      ordering clause.

      access

      public

      [ Top ]

      TSqlCriteria::setParameters

      setParameters( ArrayAccess $value );

      Parameters

      $value

      named parameters.

      access

      public

      [ Top ]

      TSqlCriteria::setSelect

      setSelect( mixed $value );

      Parameters

      $value

      Remarks

      Sets the field list to be placed after the SELECT in the SQL.

      Different behavior depends on type of assigned value string usage without modification

      null will be expanded to full list of quoted table column names (quoting depends on database)

      array

      • Column names will be quoted if used as key or value of array
      •      array('col1', 'col2', 'col2')
        •

      •      // SELECT `col1`, `col2`, `col3` FROM...
        •
      • Column aliasing
      •  array('mycol1' => 'col1', 'mycol2' => 'COUNT(*)')
        •

      •  // SELECT `col1` AS mycol1, COUNT(*) AS mycol2 FROM...
        •
      • NULL and scalar values (strings will be quoted depending on database)
      •  array('col1' => 'my custom string', 'col2' => 1.0, 'col3' => 'NULL')
        •

      •  // SELECT "my custom string" AS `col1`, 1.0 AS `col2`, NULL AS `col3` FROM...
        •
      • If the *-wildcard char is used as key or value, add the full list of quoted table column names
      •  array('col1' => 'NULL', '*')
        •

      •  // SELECT `col1`, `col2`, `col3`, NULL AS `col1` FROM...
        •

      see

      TDbCommandBuilder::getSelectFieldList()

      since

      3.1.7

      access

      public

      [ Top ]

      TSqlCriteria::__toString

      __toString( );

      Returns

      string representation of the parameters. Useful for debugging.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:23 +0200 by phpDocumentor 1.4.3


Docs For Class TTableGateway

Class TTableGateway

[line 79]
TComponent
   |
   --TTableGateway
Location: /Data/DataGateway/TTableGateway.php

Remarks

TTableGateway class provides several find methods to get data from the database and update, insert, and delete methods.

Each method maps the input parameters into a SQL call and executes the SQL against a database connection. The TTableGateway is stateless (with respect to the data and data objects), as its role is to push data back and forth.

Example usage:

  •  //create a connection
    •

  •  $dsn = 'pgsql:host=localhost;dbname=test';
    •

  •  $conn = new TDbConnection($dsn, 'dbuser','dbpass');
    •

  •
    •

  •  //create a table gateway for table/view named 'address'
    •

  •  $table = new TTableGateway('address', $conn);
    •

  •
    •

  •  //insert a new row, returns last insert id (if applicable)
    •

  •  $id = $table->insert(array('name'=>'wei', 'phone'=>'111111'));
    •

  •
    •

  •  $record1 = $table->findByPk($id); //find inserted record
    •

  •
    •

  •  //finds all records, returns an iterator
    •

  •  $records = $table->findAll();
    •

  •  print_r($records->readAll());
    •

  •
    •

  •  //update the row
    •

  •  $table->updateByPk($record1, $id);
    •

    All methods that may return more than one row of data will return an TDbDataReader iterator.

    The OnCreateCommand event is raised when a command is prepared and parameter binding is completed. The parameter object is a TDataGatewayEventParameter of which the TDataGatewayEventParameter::getCommand property can be inspected to obtain the sql query to be executed.

    The OnExecuteCommand event is raised when a command is executed and the result from the database was returned. The parameter object is a TDataGatewayResultEventParameter of which the TDataGatewayEventParameter::getResult property contains the data return from the database. The data returned can be changed by setting the TDataGatewayEventParameter::setResult property.

  •  $table->OnCreateCommand[] = 'log_it'; //any valid PHP callback statement
    •

  •  $table->OnExecuteCommand[] = array($obj, 'method_name'); // calls 'method_name' on $obj
    •

  •
    •

  •  function log_it($sender, $param)
    •

  •  {
    •

  •      var_dump($param); //TDataGatewayEventParameter object.
    •

  •  }
    •

    author

    Wei Zhuo <weizho[at]gmail[dot]com>

    version

    $Id$

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TTableGateway::__construct

      __construct( string|TDbTableInfo $table, TDbConnection $connection );

      Parameters

      $table

      table or view name or table information.

      $connection

      database connection.

      Remarks

      Creates a new generic table gateway for a given table or view name and a database connection.

      access

      public

      [ Top ]

      TTableGateway::count

      count( [string|TSqlCriteria $criteria = null], [mixed $parameters = array()] );

      Parameters

      $criteria

      SQL condition or criteria object.

      $parameters

      parameter values.

      Returns

      number of records.

      Remarks

      Find the number of records.

      access

      public

      [ Top ]

      TTableGateway::deleteAll

      deleteAll( string $criteria, [array $parameters = array()] );

      Parameters

      $criteria

      delete condition.

      $parameters

      condition parameters.

      Returns

      number of records deleted.

      Remarks

      Delete records from the table with condition given by $where and binding values specified by $parameter argument.

      This method uses additional arguments as $parameters. E.g.

    •  $table->delete('age > ? AND location = ?', $age, $location);
      •

      access

      public

      [ Top ]

      TTableGateway::deleteAllByPks

      deleteAllByPks( $keys );

      Parameters

      $keys

      Remarks

      Alias for deleteByPk()

      access

      public

      [ Top ]

      TTableGateway::deleteByPk

      deleteByPk( mixed $keys );

      Parameters

      $keys

      primary key values.

      Returns

      number of records deleted.

      Remarks

      Delete records by primary key. Usage:

    •  $table->deleteByPk($primaryKey); //delete 1 record
      •

    •  $table->deleteByPk($key1,$key2,...); //delete multiple records
      •

    •  $table->deleteByPk(array($key1,$key2,...)); //delete multiple records
      •

      For composite primary keys (determined from the table definitions):

    •  $table->deleteByPk(array($key1,$key2)); //delete 1 record
      •

    •
      •

    •  //delete multiple records
      •

    •  $table->deleteByPk(array($key1,$key2), array($key3,$key4),...);
      •

    •
      •

    •  //delete multiple records
      •

    •  $table->deleteByPk(array( array($key1,$key2), array($key3,$key4), .. ));
      •

      access

      public

      [ Top ]

      TTableGateway::find

      find( string|TSqlCriteria $criteria, [mixed $parameters = array()] );

      Parameters

      $criteria

      SQL condition or criteria object.

      $parameters

      parameter values.

      Returns

      matching record object.

      Remarks

      Find one single record that matches the criteria.

      Usage:

    •  $table->find('username = :name AND password = :pass',
      •

    •                      array(':name'=>$name, ':pass'=>$pass));
      •

    •  $table->find('username = ? AND password = ?', array($name, $pass));
      •

    •  $table->find('username = ? AND password = ?', $name, $pass);
      •

    •  //$criteria is of TSqlCriteria
      •

    •  $table->find($criteria); //the 2nd parameter for find() is ignored.
      •

      access

      public

      [ Top ]

      TTableGateway::findAll

      findAll( [string|TSqlCriteria $criteria = null], [mixed $parameters = array()] );

      Parameters

      $criteria

      SQL condition or criteria object.

      $parameters

      parameter values.

      Returns

      matching records.

      Remarks

      Accepts same parameters as find(), but returns TDbDataReader instead.

      access

      public

      [ Top ]

      TTableGateway::findAllByPks

      findAllByPks( mixed $keys );

      Parameters

      $keys

      primary keys

      Returns

      data reader.

      Remarks

      Similar to findByPk(), but returns TDbDataReader instead.

      For scalar primary keys:

    •  $table->findAllByPk($key1, $key2, ...);
      •

    •  $table->findAllByPk(array($key1, $key2, ...));
      •

      For composite keys:

    •  $table->findAllByPk(array($key1, $key2), array($key3, $key4), ...);
      •

    •  $table->findAllByPk(array(array($key1, $key2), array($key3, $key4), ...));
      •

      access

      public

      [ Top ]

      TTableGateway::findAllBySql

      findAllBySql( string $sql, [array $parameters = array()] );

      Parameters

      $sql

      SQL query string.

      $parameters

      binding parameters, positional or named.

      Returns

      query results.

      Remarks

      Execute arbituary sql command with binding parameters.

      access

      public

      [ Top ]

      TTableGateway::findByPk

      findByPk( mixed $keys );

      Parameters

      $keys

      primary keys

      Returns

      matching record.

      Remarks

      Find one record using only the primary key or composite primary keys. Usage:

    •  $table->findByPk($primaryKey);
      •

    •  $table->findByPk($key1, $key2, ...);
      •

    •  $table->findByPk(array($key1,$key2,...));
      •

      access

      public

      [ Top ]

      TTableGateway::findBySql

      findBySql( string $sql, [array $parameters = array()] );

      Parameters

      $sql

      SQL query string.

      $parameters

      binding parameters, positional or named.

      Returns

      query results.

      Remarks

      Execute arbituary sql command with binding parameters.

      access

      public

      [ Top ]

      TTableGateway::getCommand

      getCommand( );

      Returns

      command builder and executor.

      access

      protected

      [ Top ]

      TTableGateway::getCriteria

      getCriteria( string|TSqlCriteria $criteria, mixed $parameters, array $args );

      Parameters

      $criteria

      sql criteria

      $parameters

      parameters passed by the user.

      $args

      additional parameters obtained from function_get_args().

      Returns

      criteria object.

      Remarks

      Create a new TSqlCriteria object from a string $criteria. The $args are additional parameters and are used in place of the $parameters if $parameters is not an array and $args is an arrary.

      access

      protected

      [ Top ]

      TTableGateway::getDbConnection

      getDbConnection( );

      Returns

      database connection.

      access

      public

      [ Top ]

      TTableGateway::getLastInsertId

      getLastInsertId( );

      Returns

      last insert id, null if none is found.

      access

      public

      [ Top ]

      TTableGateway::getTableInfo

      getTableInfo( );

      access

      public

      [ Top ]

      TTableGateway::getTableName

      getTableName( );

      access

      public

      [ Top ]

      TTableGateway::initCommandBuilder

      initCommandBuilder( TDbCommandBuilder $builder );

      Parameters

      $builder

      database specific command builder.

      access

      protected

      [ Top ]

      TTableGateway::insert

      insert( array $data );

      Parameters

      $data

      new record data.

      Returns

      last insert id if one column contains a serial or sequence, otherwise true if command executes successfully and affected 1 or more rows.

      Remarks

      Inserts a new record into the table. Each array key must correspond to a column name in the table unless a null value is permitted.

      access

      public

      [ Top ]

      TTableGateway::onCreateCommand

      onCreateCommand( TDataGatewayCommand $sender, TDataGatewayEventParameter $param );

      Parameters

      $sender

      originator $sender

      $param

      Remarks

      Raised when a command is prepared and parameter binding is completed.

      The parameter object is TDataGatewayEventParameter of which the TDataGatewayEventParameter::getCommand property can be inspected to obtain the sql query to be executed.

      access

      public

      [ Top ]

      TTableGateway::onExecuteCommand

      onExecuteCommand( TDataGatewayCommand $sender, TDataGatewayResultEventParameter $param );

      Parameters

      $sender

      originator $sender

      $param

      Remarks

      Raised when a command is executed and the result from the database was returned.

      The parameter object is TDataGatewayResultEventParameter of which the TDataGatewayEventParameter::getResult property contains the data return from the database. The data returned can be changed by setting the TDataGatewayEventParameter::setResult property.

      access

      public

      [ Top ]

      TTableGateway::setTableInfo

      setTableInfo( TDbTableInfo $tableInfo );

      Parameters

      $tableInfo

      table or view information.

      access

      protected

      [ Top ]

      TTableGateway::setTableName

      setTableName( string $tableName );

      Parameters

      $tableName

      table or view name.

      Remarks

      Sets up the command builder for the given table.

      access

      protected

      [ Top ]

      TTableGateway::update

      update( array $data, string $criteria, [array $parameters = array()] );

      Parameters

      $data

      new record data.

      $criteria

      update condition

      $parameters

      additional binding name-value pairs.

      Returns

      number of records updated.

      Remarks

      Updates the table with new name-value pair $data. Each array key must correspond to a column name in the table. The update condition is specified by the $where argument and additional binding values can be specified using the $parameter argument.

      This method uses additional arguments as $parameters. E.g.

    •  $gateway->update($data, 'age > ? AND location = ?', $age, $location);
      •

      access

      public

      [ Top ]

      TTableGateway::__call

      __call( $method, $args );

      Overrides TComponent::__call() (Calls a method.)

      Parameters

      $method

      $args

      Returns

      single record if method name starts with "findBy", 0 or more records if method name starts with "findAllBy"

      Remarks

      Dynamic find method using parts of method name as search criteria.

      Method name starting with "findBy" only returns 1 record. Method name starting with "findAllBy" returns 0 or more records. Method name starting with "deleteBy" deletes records by the trail criteria. The condition is taken as part of the method name after "findBy", "findAllBy" or "deleteBy".

      The following are equivalent:

    •  $table->findByName($name)
      •

    •  $table->find('Name = ?', $name);
      •

    •  $table->findByUsernameAndPassword($name,$pass); // OR may be used
      •

    •  $table->findBy_Username_And_Password($name,$pass); // _OR_ may be used
      •

    •  $table->find('Username = ? AND Password = ?', $name, $pass);
      •

    •  $table->findAllByAge($age);
      •

    •  $table->findAll('Age = ?', $age);
      •

    •  $table->deleteAll('Name = ?', $name);
      •

    •  $table->deleteByName($name);
      •

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:33 +0200 by phpDocumentor 1.4.3


Package System.Data Element Index

Element index for package System.Data

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
b c d e f g i k l n o p q r s t u v _
top
_
__construct in file TDbTransaction.php, method TDbTransaction::__construct()
Constructor.
__construct in file TDbDataReader.php, method TDbDataReader::__construct()
Constructor.
__construct in file TDbConnection.php, method TDbConnection::__construct()
Constructor.
__construct in file TDbCommand.php, method TDbCommand::__construct()
Constructor.
__sleep in file TDbCommand.php, method TDbCommand::__sleep()
Set the statement to null when serializing.
__sleep in file TDbConnection.php, method TDbConnection::__sleep()
Close the connection when serializing.
top
b
beginTransaction in file TDbConnection.php, method TDbConnection::beginTransaction()
Starts a transaction.
bindColumn in file TDbDataReader.php, method TDbDataReader::bindColumn()
Binds a column to a PHP variable.
bindParameter in file TDbCommand.php, method TDbCommand::bindParameter()
Binds a parameter to the SQL statement to be executed.
bindValue in file TDbCommand.php, method TDbCommand::bindValue()
Binds a value to a parameter.
top
c
cancel in file TDbCommand.php, method TDbCommand::cancel()
Cancels the execution of the SQL statement.
close in file TDbDataReader.php, method TDbDataReader::close()
Closes the reader.
close in file TDbConnection.php, method TDbConnection::close()
Closes the currently active DB connection.
commit in file TDbTransaction.php, method TDbTransaction::commit()
Commits a transaction.
createCommand in file TDbConnection.php, method TDbConnection::createCommand()
Creates a command for execution.
current in file TDbDataReader.php, method TDbDataReader::current()
Returns the current row.
top
d
DEFAULT_TRANSACTION_CLASS | in file TDbConnection.php, class constant TDbConnection::DEFAULT_TRANSACTION_CLASS
top
e
EmptyStringToNull in file TDbConnection.php, class constant TDbNullConversionMode::EmptyStringToNull
Empty string is converted to NULL
execute in file TDbCommand.php, method TDbCommand::execute()
Executes the SQL statement.
top
f
findConnectionByID in file TDataSourceConfig.php, method TDataSourceConfig::findConnectionByID()
Finds the database connection instance from the Application modules.
top
g
getActive | in file TDbConnection.php, method TDbConnection::getActive()
getActive | in file TDbTransaction.php, method TDbTransaction::getActive()
getAttribute in file TDbConnection.php, method TDbConnection::getAttribute()
Obtains a specific DB connection attribute information.
getAutoCommit | in file TDbConnection.php, method TDbConnection::getAutoCommit()
getAvailableDrivers | in file TDbConnection.php, method TDbConnection::getAvailableDrivers()
getCharset | in file TDbConnection.php, method TDbConnection::getCharset()
getClientVersion | in file TDbConnection.php, method TDbConnection::getClientVersion()
getColumnCase | in file TDbConnection.php, method TDbConnection::getColumnCase()
getColumnCount | in file TDbDataReader.php, method TDbDataReader::getColumnCount()
getConnection | in file TDbTransaction.php, method TDbTransaction::getConnection()
getConnection | in file TDbCommand.php, method TDbCommand::getConnection()
getConnectionClass | in file TDataSourceConfig.php, method TDataSourceConfig::getConnectionClass()
getConnectionID | in file TDataSourceConfig.php, method TDataSourceConfig::getConnectionID()
getConnectionStatus | in file TDbConnection.php, method TDbConnection::getConnectionStatus()
getConnectionString | in file TDbConnection.php, method TDbConnection::getConnectionString()
getCurrentTransaction | in file TDbConnection.php, method TDbConnection::getCurrentTransaction()
getDatabase in file TDataSourceConfig.php, method TDataSourceConfig::getDatabase()
Alias for getDbConnection().
getDbConnection in file TDataSourceConfig.php, method TDataSourceConfig::getDbConnection()
Gets the TDbConnection from another module if setConnectionID is supplied and valid. Otherwise, a connection of type given by setConnectionClass is created.
getDbMetaData | in file TDbConnection.php, method TDbConnection::getDbMetaData()
getDebugStatementText | in file TDbCommand.php, method TDbCommand::getDebugStatementText()
getDriverName | in file TDbConnection.php, method TDbConnection::getDriverName()
getIsClosed | in file TDbDataReader.php, method TDbDataReader::getIsClosed()
getLastInsertID in file TDbConnection.php, method TDbConnection::getLastInsertID()
Returns the ID of the last inserted row or sequence value.
getNullConversion | in file TDbConnection.php, method TDbConnection::getNullConversion()
getPassword | in file TDbConnection.php, method TDbConnection::getPassword()
getPdoInstance | in file TDbConnection.php, method TDbConnection::getPdoInstance()
getPdoStatement | in file TDbCommand.php, method TDbCommand::getPdoStatement()
getPersistent | in file TDbConnection.php, method TDbConnection::getPersistent()
getPrefetch | in file TDbConnection.php, method TDbConnection::getPrefetch()
getRowCount | in file TDbDataReader.php, method TDbDataReader::getRowCount()
getServerInfo | in file TDbConnection.php, method TDbConnection::getServerInfo()
getServerVersion | in file TDbConnection.php, method TDbConnection::getServerVersion()
getText | in file TDbCommand.php, method TDbCommand::getText()
getTimeout | in file TDbConnection.php, method TDbConnection::getTimeout()
getTransactionClass | in file TDbConnection.php, method TDbConnection::getTransactionClass()
getUsername | in file TDbConnection.php, method TDbConnection::getUsername()
top
i
init in file TDataSourceConfig.php, method TDataSourceConfig::init()
Initalize the database connection properties from attributes in <database> tag.
top
k
key in file TDbDataReader.php, method TDbDataReader::key()
Returns the index of the current row.
top
l
LowerCase in file TDbConnection.php, class constant TDbColumnCaseMode::LowerCase
Column names are converted to lower case
top
n
next in file TDbDataReader.php, method TDbDataReader::next()
Moves the internal pointer to the next row.
nextResult in file TDbDataReader.php, method TDbDataReader::nextResult()
Advances the reader to the next result when reading the results of a batch of statements.
NullToEmptyString in file TDbConnection.php, class constant TDbNullConversionMode::NullToEmptyString
NULL is converted to empty string
top
o
open in file TDbConnection.php, method TDbConnection::open()
Opens DB connection if it is currently not
top
p
prepare in file TDbCommand.php, method TDbCommand::prepare()
Prepares the SQL statement to be executed.
Preserved in file TDbConnection.php, class constant TDbNullConversionMode::Preserved
No conversion is performed for null and empty values.
Preserved in file TDbConnection.php, class constant TDbColumnCaseMode::Preserved
Column name cases are kept as is from the database
top
q
query in file TDbCommand.php, method TDbCommand::query()
Executes the SQL statement and returns query result.
queryColumn in file TDbCommand.php, method TDbCommand::queryColumn()
Executes the SQL statement and returns the first column of the result.
queryRow in file TDbCommand.php, method TDbCommand::queryRow()
Executes the SQL statement and returns the first row of the result.
queryScalar in file TDbCommand.php, method TDbCommand::queryScalar()
Executes the SQL statement and returns the value of the first column in the first row of data.
quoteColumnAlias in file TDbConnection.php, method TDbConnection::quoteColumnAlias()
Quotes a column alias for use in a query.
quoteColumnName in file TDbConnection.php, method TDbConnection::quoteColumnName()
Quotes a column name for use in a query.
quoteString in file TDbConnection.php, method TDbConnection::quoteString()
Quotes a string for use in a query.
quoteTableName in file TDbConnection.php, method TDbConnection::quoteTableName()
Quotes a table name for use in a query.
top
r
read in file TDbDataReader.php, method TDbDataReader::read()
Advances the reader to the next row in a result set.
readAll in file TDbDataReader.php, method TDbDataReader::readAll()
Reads the whole result set into an array.
readColumn in file TDbDataReader.php, method TDbDataReader::readColumn()
Returns a single column from the next row of a result set.
readObject in file TDbDataReader.php, method TDbDataReader::readObject()
Returns a single column from the next row of a result set.
rewind in file TDbDataReader.php, method TDbDataReader::rewind()
Resets the iterator to the initial state.
rollback in file TDbTransaction.php, method TDbTransaction::rollback()
Rolls back a transaction.
top
s
setActive in file TDbConnection.php, method TDbConnection::setActive()
Open or close the DB connection.
setActive | in file TDbTransaction.php, method TDbTransaction::setActive()
setAttribute in file TDbConnection.php, method TDbConnection::setAttribute()
Sets an attribute on the database connection.
setAutoCommit | in file TDbConnection.php, method TDbConnection::setAutoCommit()
setCharset | in file TDbConnection.php, method TDbConnection::setCharset()
setColumnCase | in file TDbConnection.php, method TDbConnection::setColumnCase()
setConnectionCharset | in file TDbConnection.php, method TDbConnection::setConnectionCharset()
setConnectionClass in file TDataSourceConfig.php, method TDataSourceConfig::setConnectionClass()
The database connection class name to be created when getDbConnection
setConnectionID in file TDataSourceConfig.php, method TDataSourceConfig::setConnectionID()
The module ID of another TDataSourceConfig. The getDbConnection property of this configuration will equal to getDbConnection of the given TDataSourceConfig module.
setConnectionString | in file TDbConnection.php, method TDbConnection::setConnectionString()
setFetchMode | in file TDbDataReader.php, method TDbDataReader::setFetchMode()
setNullConversion | in file TDbConnection.php, method TDbConnection::setNullConversion()
setPassword | in file TDbConnection.php, method TDbConnection::setPassword()
setPersistent | in file TDbConnection.php, method TDbConnection::setPersistent()
setText in file TDbCommand.php, method TDbCommand::setText()
Specifies the SQL statement to be executed.
setTransactionClass | in file TDbConnection.php, method TDbConnection::setTransactionClass()
setUsername | in file TDbConnection.php, method TDbConnection::setUsername()
top
t
TDataSourceConfig.php | procedural page TDataSourceConfig.php
TDbCommand.php | procedural page TDbCommand.php
TDbConnection.php | procedural page TDbConnection.php
TDbDataReader.php | procedural page TDbDataReader.php
TDbTransaction.php | procedural page TDbTransaction.php
TDataSourceConfig in file TDataSourceConfig.php, class TDataSourceConfig
TDataSourceConfig module class provides <module> configuration for database connections.
TDbColumnCaseMode in file TDbConnection.php, class TDbColumnCaseMode
TDbColumnCaseMode
TDbCommand in file TDbCommand.php, class TDbCommand
TDbCommand class.
TDbConnection in file TDbConnection.php, class TDbConnection
TDbConnection class
TDbDataReader in file TDbDataReader.php, class TDbDataReader
TDbDataReader class.
TDbNullConversionMode in file TDbConnection.php, class TDbNullConversionMode
TDbNullConversionMode
TDbTransaction in file TDbTransaction.php, class TDbTransaction
TDbTransaction class.
top
u
UpperCase in file TDbConnection.php, class constant TDbColumnCaseMode::UpperCase
Column names are converted to upper case
top
v
valid in file TDbDataReader.php, method TDbDataReader::valid()
Returns whether there is a row of data at current position.


Class Trees for Package System.Data

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TDataSourceConfig.php

File: /Data/TDataSourceConfig.php

Remarks

TDataSourceConfig class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDataSourceConfig.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDataSourceConfig
TDataSourceConfig module class provides <module> configuration for database connections.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:05 +0200 by phpDocumentor 1.4.3


Docs for page TDbCommand.php

File: /Data/TDbCommand.php

Remarks

TDbCommand class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDbCommand.php 3058 2011-11-09 22:12:14Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDbCommand
TDbCommand class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:11 +0200 by phpDocumentor 1.4.3


Docs for page TDbConnection.php

File: /Data/TDbConnection.php

Remarks

TDbConnection class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDbConnection.php 3031 2011-08-28 06:24:03Z GODZilla0480@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDbConnection
TDbConnection class
TDbColumnCaseMode
TDbColumnCaseMode
TDbNullConversionMode
TDbNullConversionMode

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:11 +0200 by phpDocumentor 1.4.3


Docs for page TDbDataReader.php

File: /Data/TDbDataReader.php

Remarks

TDbDataReader class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDbDataReader.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDbDataReader
TDbDataReader class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:12 +0200 by phpDocumentor 1.4.3


Docs for page TDbTransaction.php

File: /Data/TDbTransaction.php

Remarks

TDbTransaction class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDbTransaction.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDbTransaction
TDbTransaction class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:13 +0200 by phpDocumentor 1.4.3


Docs For Class TDataSourceConfig

Class TDataSourceConfig

[line 49]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TDataSourceConfig
Classes extended from TDataSourceConfig:
TActiveRecordConfig
TActiveRecordConfig module configuration class.
TSqlMapConfig
TSqlMapConfig module configuration class.

Location: /Data/TDataSourceConfig.php

Remarks

TDataSourceConfig module class provides <module> configuration for database connections.

Example usage: mysql connection

  •  <modules>
    •

  •      <module id="db1">
    •

  •          <database ConnectionString="mysqli:host=localhost;dbname=test"
    •

  •              username="dbuser" password="dbpass" />
    •

  •      </module>
    •

  •  </modules>
    •

    Usage in php:

  •  class Home extends TPage
    •

  •  {
    •

  •          function onLoad($param)
    •

  •          {
    •

  •              $db = $this->Application->Modules['db1']->DbConnection;
    •

  •              $db->createCommand('...'); //...
    •

  •          }
    •

  •  }
    •

    The properties of <connection> are those of the class TDbConnection. Set setConnectionClass attribute for a custom database connection class that extends the TDbConnection class.

    author

    Wei Zhuo <weizho[at]gmail[dot]com>

    version

    $Id: TDataSourceConfig.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TModule

    • TModule::getID()
    • TModule::init()
      Initializes the module.
    • TModule::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TDataSourceConfig::findConnectionByID

      findConnectionByID( string $id );

      Parameters

      $id

      Database connection module ID.

      Returns

      database connection.

      Remarks

      Finds the database connection instance from the Application modules.

      throws

      TConfigurationException when module is not of TDbConnection or TDataSourceConfig.

      access

      protected

      [ Top ]

      TDataSourceConfig::getConnectionClass

      getConnectionClass( string 0 );

      Parameters

      0

      Database connection class name to be created.

      access

      public

      [ Top ]

      TDataSourceConfig::getConnectionID

      getConnectionID( );

      Returns

      connection module ID.

      access

      public

      [ Top ]

      TDataSourceConfig::getDatabase

      getDatabase( );

      Returns

      database connection.

      Remarks

      Alias for getDbConnection().

      access

      public

      [ Top ]

      TDataSourceConfig::getDbConnection

      getDbConnection( );

      Returns

      database connection.

      Remarks

      Gets the TDbConnection from another module if setConnectionID is supplied and valid. Otherwise, a connection of type given by setConnectionClass is created.

      access

      public

      [ Top ]

      TDataSourceConfig::init

      init( TXmlDocument $xml );

      Overridden in child classes as:

      TActiveRecordConfig::init()
      Initialize the active record manager.

      Overrides TModule::init() (Initializes the module.)

      Parameters

      $xml

      xml configuration.

      Remarks

      Initalize the database connection properties from attributes in <database> tag.

      access

      public

      [ Top ]

      TDataSourceConfig::setConnectionClass

      setConnectionClass( string $value );

      Parameters

      $value

      Database connection class name.

      Remarks

      The database connection class name to be created when getDbConnection

      method is called and ConnectionID is null. The ConnectionClass property must be set before calling getDbConnection if you wish to create the connection using the given class name.

      throws

      TConfigurationException when database connection is already established.

      access

      public

      [ Top ]

      TDataSourceConfig::setConnectionID

      setConnectionID( string $value );

      Parameters

      $value

      module ID.

      Remarks

      The module ID of another TDataSourceConfig. The getDbConnection property of this configuration will equal to getDbConnection of the given TDataSourceConfig module.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:05 +0200 by phpDocumentor 1.4.3


Docs For Class TDbCommand

Class TDbCommand

[line 39]
TComponent
   |
   --TDbCommand
Location: /Data/TDbCommand.php

Remarks

TDbCommand class.

TDbCommand represents an SQL statement to execute against a database. It is usually created by calling TDbConnection::createCommand. The SQL statement to be executed may be set via Text.

To execute a non-query SQL (such as insert, delete, update), call execute. To execute an SQL statement that returns result data set (such as select), use query or its convenient versions queryRow and queryScalar.

If an SQL statement returns results (such as a SELECT SQL), the results can be accessed via the returned TDbDataReader.

TDbCommand supports SQL statment preparation and parameter binding. Call bindParameter to bind a PHP variable to a parameter in SQL. Call bindValue to bind a value to an SQL parameter. When binding a parameter, the SQL statement is automatically prepared. You may also call prepare to explicitly prepare an SQL statement.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDbCommand.php 3058 2011-11-09 22:12:14Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDbCommand::__construct

    __construct( TDbConnection $connection, string $text );

    Parameters

    $connection

    the database connection

    $text

    the SQL statement to be executed

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TDbCommand::bindParameter

    bindParameter( mixed $name, mixed &$value, [int $dataType = null], [int $length = null] );

    Parameters

    $name

    Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter. Unlike bindValue, the variable is bound as a reference and will only be evaluated at the time that execute or query is called.

    &$value

    Name of the PHP variable to bind to the SQL statement parameter

    $dataType

    SQL data type of the parameter

    $length

    length of the data type

    Remarks

    Binds a parameter to the SQL statement to be executed.

    see

    http://www.php.net/manual/en/function.PDOStatement-bindParam.php

    access

    public

    [ Top ]

    TDbCommand::bindValue

    bindValue( mixed $name, mixed $value, [int $dataType = null] );

    Parameters

    $name

    Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter.

    $value

    The value to bind to the parameter

    $dataType

    SQL data type of the parameter

    Remarks

    Binds a value to a parameter.

    see

    http://www.php.net/manual/en/function.PDOStatement-bindValue.php

    access

    public

    [ Top ]

    TDbCommand::cancel

    cancel( );

    Remarks

    Cancels the execution of the SQL statement.

    access

    public

    [ Top ]

    TDbCommand::execute

    execute( );

    Returns

    number of rows affected by the execution.

    Remarks

    Executes the SQL statement.

    This method is meant only for executing non-query SQL statement. No result set will be returned.

    throws

    TDbException execution failed

    access

    public

    [ Top ]

    TDbCommand::getConnection

    getConnection( );

    Returns

    the connection associated with this command

    access

    public

    [ Top ]

    TDbCommand::getDebugStatementText

    getDebugStatementText( );

    Returns

    prepared SQL text for debugging purposes.

    access

    public

    [ Top ]

    TDbCommand::getPdoStatement

    getPdoStatement( );

    Returns

    the underlying PDOStatement for this command It could be null if the statement is not prepared yet.

    access

    public

    [ Top ]

    TDbCommand::getText

    getText( );

    Returns

    the SQL statement to be executed

    access

    public

    [ Top ]

    TDbCommand::prepare

    prepare( );

    Remarks

    Prepares the SQL statement to be executed.

    For complex SQL statement that is to be executed multiple times, this may improve performance. For SQL statement with binding parameters, this method is invoked automatically.

    access

    public

    [ Top ]

    TDbCommand::query

    query( );

    Returns

    the reader object for fetching the query result

    Remarks

    Executes the SQL statement and returns query result.

    This method is for executing an SQL query that returns result set.

    throws

    TDbException execution failed

    access

    public

    [ Top ]

    TDbCommand::queryColumn

    queryColumn( );

    Returns

    the first column of the query result. Empty array if no result.

    Remarks

    Executes the SQL statement and returns the first column of the result.

    This is a convenient method of query when only the first column of data is needed. Note, the column returned will contain the first element in each row of result.

    throws

    TDbException execution failed

    since

    3.1.2

    access

    public

    [ Top ]

    TDbCommand::queryRow

    queryRow( [boolean $fetchAssociative = true] );

    Parameters

    $fetchAssociative

    whether the row should be returned as an associated array with column names as the keys or the array keys are column indexes (0-based).

    Returns

    the first row of the query result, false if no result.

    Remarks

    Executes the SQL statement and returns the first row of the result.

    This is a convenient method of query when only the first row of data is needed.

    throws

    TDbException execution failed

    access

    public

    [ Top ]

    TDbCommand::queryScalar

    queryScalar( );

    Returns

    the value of the first column in the first row of the query result. False is returned if there is no value.

    Remarks

    Executes the SQL statement and returns the value of the first column in the first row of data.

    This is a convenient method of query when only a single scalar value is needed (e.g. obtaining the count of the records).

    throws

    TDbException execution failed

    access

    public

    [ Top ]

    TDbCommand::setText

    setText( string $value );

    Parameters

    $value

    the SQL statement to be executed

    Remarks

    Specifies the SQL statement to be executed.

    Any previous execution will be terminated or cancel.

    access

    public

    [ Top ]

    TDbCommand::__sleep

    __sleep( );

    Overrides TComponent::__sleep() (Returns an array with the names of all variables of that object that should be serialized.)

    Remarks

    Set the statement to null when serializing.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:11 +0200 by phpDocumentor 1.4.3


Docs For Class TDbColumnCaseMode

Class TDbColumnCaseMode

[line 645]
TEnumerable
   |
   --TDbColumnCaseMode
Location: /Data/TDbConnection.php

Remarks

TDbColumnCaseMode

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDbConnection.php 3031 2011-08-28 06:24:03Z GODZilla0480@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • LowerCase = 'LowerCase'
    Column names are converted to lower case
  • Preserved = 'Preserved'
    Column name cases are kept as is from the database
  • UpperCase = 'UpperCase'
    Column names are converted to upper case

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • LowerCase = 'LowerCase' [line 654]

    • Remarks

    Column names are converted to lower case

  • Preserved = 'Preserved' [line 650]

    • Remarks

    Column name cases are kept as is from the database

  • UpperCase = 'UpperCase' [line 658]

    • Remarks

    Column names are converted to upper case

Documentation generated on Mon, 25 Jun 2012 14:44:11 +0200 by phpDocumentor 1.4.3


Docs For Class TDbConnection

Class TDbConnection

[line 84]
TComponent
   |
   --TDbConnection
Location: /Data/TDbConnection.php

Remarks

TDbConnection class

TDbConnection represents a connection to a database.

TDbConnection works together with TDbCommand, TDbDataReader and TDbTransaction to provide data access to various DBMS in a common set of APIs. They are a thin wrapper of the PDO PHP extension.

To establish a connection, set Active to true after specifying ConnectionString, Username and Password.

Since 3.1.2, the connection charset can be set (for MySQL and PostgreSQL databases only) using the Charset property. The value of this property is database dependant. e.g. for mysql, you can use 'latin1' for cp1252 West European, 'utf8' for unicode, ...

The following example shows how to create a TDbConnection instance and establish the actual connection:

  •  $connection=new TDbConnection($dsn,$username,$password);
    •

  •  $connection->Active=true;
    •

    After the DB connection is established, one can execute an SQL statement like the following:

  •  $command=$connection->createCommand($sqlStatement);
    •

  •  $command->execute();   // a non-query SQL statement execution
    •

  •  // or execute an SQL query and fetch the result set
    •

  •  $reader=$command->query();
    •

  •
    •

  •  // each $row is an array representing a row of data
    •

  •  foreach($reader as $row) ...
    •

    One can do prepared SQL execution and bind parameters to the prepared SQL:

  •  $command=$connection->createCommand($sqlStatement);
    •

  •  $command->bindParameter($name1,$value1);
    •

  •  $command->bindParameter($name2,$value2);
    •

  •  $command->execute();
    •

    To use transaction, do like the following:

  •  $transaction=$connection->beginTransaction();
    •

  •  try
    •

  •  {
    •

  •     $connection->createCommand($sql1)->execute();
    •

  •     $connection->createCommand($sql2)->execute();
    •

  •     //.... other SQL executions
    •

  •     $transaction->commit();
    •

  •  }
    •

  •  catch(Exception $e)
    •

  •  {
    •

  •     $transaction->rollBack();
    •

  •  }
    •

    TDbConnection provides a set of methods to support setting and querying of certain DBMS attributes, such as NullConversion.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TDbConnection.php 3031 2011-08-28 06:24:03Z GODZilla0480@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    • DEFAULT_TRANSACTION_CLASS =  'System.Data.TDbTransaction'

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    • static array getAvailableDrivers()
    • array getAvailableDrivers()

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      static TDbConnection::getAvailableDrivers

      static getAvailableDrivers( );

      Returns

      list of available PDO drivers

      see

      http://www.php.net/manual/en/function.PDO-getAvailableDrivers.php

      access

      public

      [ Top ]

      TDbConnection::__construct

      __construct(
[string
$dsn = ''], [string
$username = ''], [string
$password = ''], [string
$charset = ''] );

      Parameters

      $dsn

      The Data Source Name, or DSN, contains the information required to connect to the database.

      $username

      The user name for the DSN string.

      $password

      The password for the DSN string.

      $charset

      Charset used for DB Connection (MySql & pgsql only). If not set, will use the default charset of your database server

      Remarks

      Constructor.

      Note, the DB connection is not established when this connection instance is created. Set Active property to true to establish the connection. Since 3.1.2, you can set the charset for MySql connection

      see

      http://www.php.net/manual/en/function.PDO-construct.php

      access

      public

      [ Top ]

      TDbConnection::beginTransaction

      beginTransaction( );

      Returns

      the transaction initiated

      Remarks

      Starts a transaction.

      throws

      TDbException if the connection is not active

      access

      public

      [ Top ]

      TDbConnection::close

      close( );

      Remarks

      Closes the currently active DB connection.

      It does nothing if the connection is already closed.

      access

      protected

      [ Top ]

      TDbConnection::createCommand

      createCommand( string $sql );

      Parameters

      $sql

      SQL statement associated with the new command.

      Returns

      the DB command

      Remarks

      Creates a command for execution.

      throws

      TDbException if the connection is not active

      access

      public

      [ Top ]

      TDbConnection::getActive

      getActive( );

      Returns

      whether the DB connection is established

      access

      public

      [ Top ]

      TDbConnection::getAttribute

      getAttribute( int $name );

      Parameters

      $name

      the attribute to be queried

      Returns

      the corresponding attribute information

      Remarks

      Obtains a specific DB connection attribute information.

      see

      http://www.php.net/manual/en/function.PDO-getAttribute.php

      access

      public

      [ Top ]

      TDbConnection::getAutoCommit

      getAutoCommit( );

      Returns

      whether creating or updating a DB record will be automatically committed. Some DBMS (such as sqlite) may not support this feature.

      access

      public

      [ Top ]

      TDbConnection::getCharset

      getCharset( );

      Returns

      the charset used for database connection. Defaults to emtpy string.

      access

      public

      [ Top ]

      TDbConnection::getClientVersion

      getClientVersion( );

      Returns

      the version information of the DB driver

      access

      public

      [ Top ]

      TDbConnection::getColumnCase

      getColumnCase( );

      Returns

      the case of the column names

      access

      public

      [ Top ]

      TDbConnection::getConnectionStatus

      getConnectionStatus( );

      Returns

      the status of the connection Some DBMS (such as sqlite) may not support this feature.

      access

      public

      [ Top ]

      TDbConnection::getConnectionString

      getConnectionString( );

      Returns

      The Data Source Name, or DSN, contains the information required to connect to the database.

      access

      public

      [ Top ]

      TDbConnection::getCurrentTransaction

      getCurrentTransaction( );

      Returns

      the currently active transaction. Null if no active transaction.

      access

      public

      [ Top ]

      TDbConnection::getDbMetaData

      getDbMetaData( );

      access

      public

      [ Top ]

      TDbConnection::getDriverName

      getDriverName( );

      Returns

      name of the DB driver

      access

      public

      [ Top ]

      TDbConnection::getLastInsertID

      getLastInsertID( [string $sequenceName = ''] );

      Parameters

      $sequenceName

      name of the sequence object (required by some DBMS)

      Returns

      the row ID of the last row inserted, or the last value retrieved from the sequence object

      Remarks

      Returns the ID of the last inserted row or sequence value.

      see

      http://www.php.net/manual/en/function.PDO-lastInsertId.php

      access

      public

      [ Top ]

      TDbConnection::getNullConversion

      getNullConversion( );

      Returns

      how the null and empty strings are converted

      access

      public

      [ Top ]

      TDbConnection::getPassword

      getPassword( );

      Returns

      the password for establishing DB connection. Defaults to empty string.

      access

      public

      [ Top ]

      TDbConnection::getPdoInstance

      getPdoInstance( );

      Returns

      the PDO instance, null if the connection is not established yet

      access

      public

      [ Top ]

      TDbConnection::getPersistent

      getPersistent( );

      Returns

      whether the connection is persistent or not Some DBMS (such as sqlite) may not support this feature.

      access

      public

      [ Top ]

      TDbConnection::getPrefetch

      getPrefetch( );

      Returns

      whether the connection performs data prefetching

      access

      public

      [ Top ]

      TDbConnection::getServerInfo

      getServerInfo( );

      Returns

      the information of DBMS server

      access

      public

      [ Top ]

      TDbConnection::getServerVersion

      getServerVersion( );

      Returns

      the version information of DBMS server

      access

      public

      [ Top ]

      TDbConnection::getTimeout

      getTimeout( );

      Returns

      timeout settings for the connection

      access

      public

      [ Top ]

      TDbConnection::getTransactionClass

      getTransactionClass( );

      Returns

      Transaction class name to be created by calling TDbConnection::beginTransaction. Defaults to 'System.Data.TDbTransaction'.

      since

      3.1.7

      access

      public

      [ Top ]

      TDbConnection::getUsername

      getUsername( );

      Returns

      the username for establishing DB connection. Defaults to empty string.

      access

      public

      [ Top ]

      TDbConnection::open

      open( );

      Remarks

      Opens DB connection if it is currently not

      throws

      TDbException if connection fails

      access

      protected

      [ Top ]

      TDbConnection::quoteColumnAlias

      quoteColumnAlias( string $name );

      Parameters

      $name

      column name

      Returns

      the properly quoted column alias

      Remarks

      Quotes a column alias for use in a query.

      access

      public

      [ Top ]

      TDbConnection::quoteColumnName

      quoteColumnName( string $name );

      Parameters

      $name

      column name

      Returns

      the properly quoted column name

      Remarks

      Quotes a column name for use in a query.

      access

      public

      [ Top ]

      TDbConnection::quoteString

      quoteString( string $str );

      Parameters

      $str

      string to be quoted

      Returns

      the properly quoted string

      Remarks

      Quotes a string for use in a query.

      see

      http://www.php.net/manual/en/function.PDO-quote.php

      access

      public

      [ Top ]

      TDbConnection::quoteTableName

      quoteTableName( string $name );

      Parameters

      $name

      table name

      Returns

      the properly quoted table name

      Remarks

      Quotes a table name for use in a query.

      access

      public

      [ Top ]

      TDbConnection::setActive

      setActive( boolean $value );

      Parameters

      $value

      whether to open or close DB connection

      Remarks

      Open or close the DB connection.

      throws

      TDbException if connection fails

      access

      public

      [ Top ]

      TDbConnection::setAttribute

      setAttribute( int $name, mixed $value );

      Parameters

      $name

      the attribute to be set

      $value

      the attribute value

      Remarks

      Sets an attribute on the database connection.

      see

      http://www.php.net/manual/en/function.PDO-setAttribute.php

      access

      public

      [ Top ]

      TDbConnection::setAutoCommit

      setAutoCommit( boolean $value );

      Parameters

      $value

      whether creating or updating a DB record will be automatically committed. Some DBMS (such as sqlite) may not support this feature.

      access

      public

      [ Top ]

      TDbConnection::setCharset

      setCharset( string $value );

      Parameters

      $value

      the charset used for database connection

      access

      public

      [ Top ]

      TDbConnection::setColumnCase

      setColumnCase( TDbColumnCaseMode $value );

      Parameters

      $value

      the case of the column names

      access

      public

      [ Top ]

      TDbConnection::setConnectionCharset

      setConnectionCharset( );

      access

      protected

      [ Top ]

      TDbConnection::setConnectionString

      setConnectionString( string $value );

      Parameters

      $value

      The Data Source Name, or DSN, contains the information required to connect to the database.

      see

      http://www.php.net/manual/en/function.PDO-construct.php

      access

      public

      [ Top ]

      TDbConnection::setNullConversion

      setNullConversion( TDbNullConversionMode $value );

      Parameters

      $value

      how the null and empty strings are converted

      access

      public

      [ Top ]

      TDbConnection::setPassword

      setPassword( string $value );

      Parameters

      $value

      the password for establishing DB connection

      access

      public

      [ Top ]

      TDbConnection::setPersistent

      setPersistent( boolean $value );

      Parameters

      $value

      whether the connection is persistent or not Some DBMS (such as sqlite) may not support this feature.

      access

      public

      [ Top ]

      TDbConnection::setTransactionClass

      setTransactionClass( string $value );

      Parameters

      $value

      Transaction class name to be created by calling TDbConnection::beginTransaction.

      since

      3.1.7

      access

      public

      [ Top ]

      TDbConnection::setUsername

      setUsername( string $value );

      Parameters

      $value

      the username for establishing DB connection

      access

      public

      [ Top ]

      TDbConnection::__sleep

      __sleep( );

      Overrides TComponent::__sleep() (Returns an array with the names of all variables of that object that should be serialized.)

      Remarks

      Close the connection when serializing.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • DEFAULT_TRANSACTION_CLASS =  'System.Data.TDbTransaction' [line 90]

      • since

      3.1.7

    Documentation generated on Mon, 25 Jun 2012 14:44:12 +0200 by phpDocumentor 1.4.3


Docs For Class TDbNullConversionMode

Class TDbNullConversionMode

[line 669]
TEnumerable
   |
   --TDbNullConversionMode
Location: /Data/TDbConnection.php

Remarks

TDbNullConversionMode

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TDbConnection.php 3031 2011-08-28 06:24:03Z GODZilla0480@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • EmptyStringToNull = 'EmptyStringToNull'
    Empty string is converted to NULL
  • NullToEmptyString = 'NullToEmptyString'
    NULL is converted to empty string
  • Preserved = 'Preserved'
    No conversion is performed for null and empty values.

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • EmptyStringToNull = 'EmptyStringToNull' [line 682]

    • Remarks

    Empty string is converted to NULL

  • NullToEmptyString = 'NullToEmptyString' [line 678]

    • Remarks

    NULL is converted to empty string

  • Preserved = 'Preserved' [line 674]

    • Remarks

    No conversion is performed for null and empty values.

Documentation generated on Mon, 25 Jun 2012 14:44:12 +0200 by phpDocumentor 1.4.3


Docs For Class TDbDataReader

Class TDbDataReader

[line 37]
TComponent
   |
   --TDbDataReader
Location: /Data/TDbDataReader.php

Remarks

TDbDataReader class.

TDbDataReader represents a forward-only stream of rows from a query result set.

To read the current row of data, call read. The method readAll returns all the rows in a single array.

One can also retrieve the rows of data in TDbDataReader by using foreach:

  •  foreach($reader as $row)
    •

  •      // $row represents a row of data
    •
    Since TDbDataReader is a forward-only stream, you can only traverse it once.

    It is possible to use a specific mode of data fetching by setting FetchMode. See http://www.php.net/manual/en/function.PDOStatement-setFetchMode.php for more details.

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TDbDataReader.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TDbDataReader::__construct

      __construct( TDbCommand $command );

      Parameters

      $command

      the command generating the query result

      Remarks

      Constructor.

      access

      public

      [ Top ]

      TDbDataReader::bindColumn

      bindColumn( mixed $column, mixed &$value, [int $dataType = null] );

      Parameters

      $column

      Number of the column (1-indexed) or name of the column in the result set. If using the column name, be aware that the name should match the case of the column, as returned by the driver.

      &$value

      Name of the PHP variable to which the column will be bound.

      $dataType

      Data type of the parameter

      Remarks

      Binds a column to a PHP variable.

      When rows of data are being fetched, the corresponding column value will be set in the variable. Note, the fetch mode must include PDO::FETCH_BOUND.

      see

      http://www.php.net/manual/en/function.PDOStatement-bindColumn.php

      access

      public

      [ Top ]

      TDbDataReader::close

      close( );

      Remarks

      Closes the reader.

      Any further data reading will result in an exception.

      access

      public

      [ Top ]

      TDbDataReader::current

      current( );

      Implementation of:
      Iterator::current

      Returns

      the current row.

      Remarks

      Returns the current row.

      This method is required by the interface Iterator.

      access

      public

      [ Top ]

      TDbDataReader::getColumnCount

      getColumnCount( );

      Returns

      the number of columns in the result set. Note, even there's no row in the reader, this still gives correct column number.

      access

      public

      [ Top ]

      TDbDataReader::getIsClosed

      getIsClosed( );

      Returns

      whether the reader is closed or not.

      access

      public

      [ Top ]

      TDbDataReader::getRowCount

      getRowCount( );

      Returns

      number of rows contained in the result. Note, most DBMS may not give a meaningful count. In this case, use "SELECT COUNT(*) FROM tableName" to obtain the number of rows.

      access

      public

      [ Top ]

      TDbDataReader::key

      key( );

      Implementation of:
      Iterator::key

      Returns

      the index of the current row.

      Remarks

      Returns the index of the current row.

      This method is required by the interface Iterator.

      access

      public

      [ Top ]

      TDbDataReader::next

      next( );

      Implementation of:
      Iterator::next

      Remarks

      Moves the internal pointer to the next row.

      This method is required by the interface Iterator.

      access

      public

      [ Top ]

      TDbDataReader::nextResult

      nextResult( );

      Remarks

      Advances the reader to the next result when reading the results of a batch of statements.

      This method is only useful when there are multiple result sets returned by the query. Not all DBMS support this feature.

      access

      public

      [ Top ]

      TDbDataReader::read

      read( );

      Returns

      the current row, false if no more row available

      Remarks

      Advances the reader to the next row in a result set.

      access

      public

      [ Top ]

      TDbDataReader::readAll

      readAll( );

      Returns

      the result set (each array element represents a row of data). An empty array will be returned if the result contains no row.

      Remarks

      Reads the whole result set into an array.

      access

      public

      [ Top ]

      TDbDataReader::readColumn

      readColumn( int $columnIndex );

      Parameters

      $columnIndex

      zero-based column index

      Returns

      the column of the current row, false if no more row available

      Remarks

      Returns a single column from the next row of a result set.

      access

      public

      [ Top ]

      TDbDataReader::readObject

      readObject( string $className, array $fields );

      Parameters

      $className

      class name of the object to be created and populated

      $fields

      list of column names whose values are to be passed as parameters in the constructor of the class being created

      Returns

      the populated object, false if no more row of data available

      Remarks

      Returns a single column from the next row of a result set.

      access

      public

      [ Top ]

      TDbDataReader::rewind

      rewind( );

      Implementation of:
      Iterator::rewind

      Remarks

      Resets the iterator to the initial state.

      This method is required by the interface Iterator.

      throws

      TDbException if this method is invoked twice

      access

      public

      [ Top ]

      TDbDataReader::setFetchMode

      setFetchMode( $mode );

      Parameters

      $mode

      see

      http://www.php.net/manual/en/function.PDOStatement-setFetchMode.php

      access

      public

      [ Top ]

      TDbDataReader::valid

      valid( );

      Implementation of:
      Iterator::valid

      Returns

      whether there is a row of data at current position.

      Remarks

      Returns whether there is a row of data at current position.

      This method is required by the interface Iterator.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:12 +0200 by phpDocumentor 1.4.3


Docs For Class TDbTransaction

Class TDbTransaction

[line 42]
TComponent
   |
   --TDbTransaction
Location: /Data/TDbTransaction.php

Remarks

TDbTransaction class.

TDbTransaction represents a DB transaction. It is usually created by calling TDbConnection::beginTransaction.

The following code is a common scenario of using transactions:

  •  try
    •

  •  {
    •

  •     $transaction=$connection->beginTransaction();
    •

  •     $connection->createCommand($sql1)->execute();
    •

  •     $connection->createCommand($sql2)->execute();
    •

  •     //.... other SQL executions
    •

  •     $transaction->commit();
    •

  •  }
    •

  •  catch(Exception $e)
    •

  •  {
    •

  •     $transaction->rollBack();
    •

  •  }
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TDbTransaction.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TDbTransaction::__construct

      __construct( TDbConnection $connection );

      Parameters

      $connection

      the connection associated with this transaction

      Remarks

      Constructor.

      see

      TDbConnection::beginTransaction

      access

      public

      [ Top ]

      TDbTransaction::commit

      commit( );

      Remarks

      Commits a transaction.

      throws

      TDbException if the transaction or the DB connection is not active.

      access

      public

      [ Top ]

      TDbTransaction::getActive

      getActive( );

      Returns

      whether this transaction is active

      access

      public

      [ Top ]

      TDbTransaction::getConnection

      getConnection( );

      Returns

      the DB connection for this transaction

      access

      public

      [ Top ]

      TDbTransaction::rollback

      rollback( );

      Remarks

      Rolls back a transaction.

      throws

      TDbException if the transaction or the DB connection is not active.

      access

      public

      [ Top ]

      TDbTransaction::setActive

      setActive( boolean $value );

      Parameters

      $value

      whether this transaction is active

      access

      protected

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:13 +0200 by phpDocumentor 1.4.3


Package System.Data.Common Element Index

Element index for package System.Data.Common

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a b c d f g h i j q r s t u _
top
_
__construct in file TOracleTableInfo.php, method TOracleTableInfo::__construct()
Sets the database table meta data information.
__construct in file TDbTableInfo.php, method TDbTableInfo::__construct()
Sets the database table meta data information.
__construct in file TDbTableColumn.php, method TDbTableColumn::__construct()
Sets the table column meta data.
__construct | in file TDbMetaData.php, method TDbMetaData::__construct()
__construct | in file TDbCommandBuilder.php, method TDbCommandBuilder::__construct()
top
a
applyCriterias | in file TDbCommandBuilder.php, method TDbCommandBuilder::applyCriterias()
applyLimitOffset in file TOracleCommandBuilder.php, method TOracleCommandBuilder::applyLimitOffset()
Overrides parent implementation to use Oracle way of get paginated RecordSet instead of using LIMIT sql clause.
applyLimitOffset in file TMssqlCommandBuilder.php, method TMssqlCommandBuilder::applyLimitOffset()
Overrides parent implementation. Alters the sql to apply $limit and $offset.
applyLimitOffset in file TSqliteCommandBuilder.php, method TSqliteCommandBuilder::applyLimitOffset()
Alters the sql to apply $limit and $offset.
applyLimitOffset in file TDbCommandBuilder.php, method TDbCommandBuilder::applyLimitOffset()
Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.
applyOrdering | in file TDbCommandBuilder.php, method TDbCommandBuilder::applyOrdering()
top
b
bindArrayValues | in file TDbCommandBuilder.php, method TDbCommandBuilder::bindArrayValues()
bindColumnValues in file TDbCommandBuilder.php, method TDbCommandBuilder::bindColumnValues()
Bind the name-value pairs of $values where the array keys correspond to column names.
top
c
createCommand | in file TDbCommandBuilder.php, method TDbCommandBuilder::createCommand()
createCommandBuilder | in file TDbTableInfo.php, method TDbTableInfo::createCommandBuilder()
createCommandBuilder in file TDbMetaData.php, method TDbMetaData::createCommandBuilder()
Creates a command builder for a given table name.
createCommandBuilder | in file TOracleTableInfo.php, method TOracleTableInfo::createCommandBuilder()
createCountCommand in file TDbCommandBuilder.php, method TDbCommandBuilder::createCountCommand()
Creates a count(*) command for the table described in setTableInfo.
createDeleteCommand in file TDbCommandBuilder.php, method TDbCommandBuilder::createDeleteCommand()
Creates a delete command for the table described in setTableInfo.
createFindCommand in file TDbCommandBuilder.php, method TDbCommandBuilder::createFindCommand()
Appends the $where condition to the string "SELECT * FROM tableName WHERE ".
createInsertCommand in file TDbCommandBuilder.php, method TDbCommandBuilder::createInsertCommand()
Creates an insert command for the table described in setTableInfo for the given data.
createTableInfo in file TDbMetaData.php, method TDbMetaData::createTableInfo()
This method should be implemented by decendent classes.
createUpdateCommand in file TDbCommandBuilder.php, method TDbCommandBuilder::createUpdateCommand()
Creates an update command for the table described in setTableInfo for the given data.
top
d
$delimiterIdentifier | in file TDbMetaData.php, variable TDbMetaData::$delimiterIdentifier
top
f
findOrdering in file TMssqlCommandBuilder.php, method TMssqlCommandBuilder::findOrdering()
Base on simplified syntax http://msdn2.microsoft.com/en-us/library/aa259187(SQL.80).aspx
top
g
getAllowNull | in file TDbTableColumn.php, method TDbTableColumn::getAllowNull()
getColumn | in file TOracleTableInfo.php, method TOracleTableInfo::getColumn()
getColumn | in file TDbTableInfo.php, method TDbTableInfo::getColumn()
getColumnBindings in file TDbCommandBuilder.php, method TDbCommandBuilder::getColumnBindings()
Create a name-value or position-value if $position=true binding strings.
getColumnId | in file TDbTableColumn.php, method TDbTableColumn::getColumnId()
getColumnIndex | in file TDbTableColumn.php, method TDbTableColumn::getColumnIndex()
getColumnName | in file TDbTableColumn.php, method TDbTableColumn::getColumnName()
getColumnNames | in file TDbTableInfo.php, method TDbTableInfo::getColumnNames()
getColumnNames | in file TOracleTableInfo.php, method TOracleTableInfo::getColumnNames()
getColumns | in file TDbTableInfo.php, method TDbTableInfo::getColumns()
getColumns | in file TOracleTableInfo.php, method TOracleTableInfo::getColumns()
getColumnSize | in file TDbTableColumn.php, method TDbTableColumn::getColumnSize()
getDbConnection | in file TDbMetaData.php, method TDbMetaData::getDbConnection()
getDbConnection | in file TDbCommandBuilder.php, method TDbCommandBuilder::getDbConnection()
getDbType | in file TDbTableColumn.php, method TDbTableColumn::getDbType()
getDefaultValue | in file TDbTableColumn.php, method TDbTableColumn::getDefaultValue()
getForeignKeys | in file TOracleTableInfo.php, method TOracleTableInfo::getForeignKeys()
getForeignKeys | in file TDbTableInfo.php, method TDbTableInfo::getForeignKeys()
getInfo | in file TDbTableColumn.php, method TDbTableColumn::getInfo()
getInfo | in file TOracleTableInfo.php, method TOracleTableInfo::getInfo()
getInfo | in file TDbTableInfo.php, method TDbTableInfo::getInfo()
getInsertFieldBindings in file TDbCommandBuilder.php, method TDbCommandBuilder::getInsertFieldBindings()
Returns a list of insert field name and a list of binding names.
getInstance in file TDbMetaData.php, method TDbMetaData::getInstance()
Obtain database specific TDbMetaData class using the driver name of the database connection.
getIsExcluded | in file TDbTableColumn.php, method TDbTableColumn::getIsExcluded()
getIsForeignKey | in file TDbTableColumn.php, method TDbTableColumn::getIsForeignKey()
getIsPrimaryKey | in file TDbTableColumn.php, method TDbTableColumn::getIsPrimaryKey()
getIsView | in file TDbTableInfo.php, method TDbTableInfo::getIsView()
getIsView | in file TOracleTableInfo.php, method TOracleTableInfo::getIsView()
getLastInsertID in file TDbCommandBuilder.php, method TDbCommandBuilder::getLastInsertID()
Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
getLastInsertID in file TMssqlCommandBuilder.php, method TMssqlCommandBuilder::getLastInsertID()
Overrides parent implementation. Uses "SELECT @@Identity".
getLowerCaseColumnNames | in file TOracleTableInfo.php, method TOracleTableInfo::getLowerCaseColumnNames()
getLowerCaseColumnNames | in file TDbTableInfo.php, method TDbTableInfo::getLowerCaseColumnNames()
getMaxiumNumericConstraint | in file TDbTableColumn.php, method TDbTableColumn::getMaxiumNumericConstraint()
getNumericPrecision | in file TDbTableColumn.php, method TDbTableColumn::getNumericPrecision()
getNumericScale | in file TDbTableColumn.php, method TDbTableColumn::getNumericScale()
getPdoType | in file TDbTableColumn.php, method TDbTableColumn::getPdoType()
getPdoType | in file TDbCommandBuilder.php, method TDbCommandBuilder::getPdoType()
getPHPType in file TDbTableColumn.php, method TDbTableColumn::getPHPType()
Returns the derived PHP primitive type from the db type. Default returns 'string'.
getPrimaryKeys | in file TDbTableInfo.php, method TDbTableInfo::getPrimaryKeys()
getPrimaryKeys | in file TOracleTableInfo.php, method TOracleTableInfo::getPrimaryKeys()
getSearchCondition in file TPgsqlCommandBuilder.php, method TPgsqlCommandBuilder::getSearchCondition()
Overrides parent implementation to use PostgreSQL's ILIKE instead of LIKE (case-sensitive).
getSearchCondition | in file TDbCommandBuilder.php, method TDbCommandBuilder::getSearchCondition()
getSearchExpression in file TDbCommandBuilder.php, method TDbCommandBuilder::getSearchExpression()
Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).
getSearchExpression in file TOracleCommandBuilder.php, method TOracleCommandBuilder::getSearchExpression()
Overrides parent implementation. Only column of type text or character (and its variants) accepts the LIKE criteria.
getSearchExpression in file TPgsqlCommandBuilder.php, method TPgsqlCommandBuilder::getSearchExpression()
Overrides parent implementation. Only column of type text or character (and its variants) accepts the LIKE criteria.
getSelectFieldList in file TDbCommandBuilder.php, method TDbCommandBuilder::getSelectFieldList()
Different behavior depends on type of passed data string usage without modification
getSequenceName | in file TDbTableColumn.php, method TDbTableColumn::getSequenceName()
getTableFullName | in file TDbTableInfo.php, method TDbTableInfo::getTableFullName()
getTableFullName | in file TOracleTableInfo.php, method TOracleTableInfo::getTableFullName()
getTableInfo | in file TDbCommandBuilder.php, method TDbCommandBuilder::getTableInfo()
getTableInfo in file TDbMetaData.php, method TDbMetaData::getTableInfo()
Obtains table meta data information for the current connection and given table name.
getTableInfoClass | in file TDbMetaData.php, method TDbMetaData::getTableInfoClass()
getTableName | in file TDbTableInfo.php, method TDbTableInfo::getTableName()
getTableName | in file TOracleTableInfo.php, method TOracleTableInfo::getTableName()
top
h
hasIntegerKey | in file TDbCommandBuilder.php, method TDbCommandBuilder::hasIntegerKey()
hasSequence | in file TDbTableColumn.php, method TDbTableColumn::hasSequence()
top
i
isSearchableColumn | in file TPgsqlCommandBuilder.php, method TPgsqlCommandBuilder::isSearchableColumn()
isSearchableColumn | in file TOracleCommandBuilder.php, method TOracleCommandBuilder::isSearchableColumn()
top
j
joinOrdering | in file TMssqlCommandBuilder.php, method TMssqlCommandBuilder::joinOrdering()
top
q
quoteColumnAlias in file TDbMetaData.php, method TDbMetaData::quoteColumnAlias()
Quotes a column alias for use in a query.
quoteColumnName in file TDbMetaData.php, method TDbMetaData::quoteColumnName()
Quotes a column name for use in a query.
quoteTableName in file TDbMetaData.php, method TDbMetaData::quoteTableName()
Quotes a table name for use in a query.
top
r
reverseDirection | in file TMssqlCommandBuilder.php, method TMssqlCommandBuilder::reverseDirection()
rewriteLimitOffsetSql in file TMssqlCommandBuilder.php, method TMssqlCommandBuilder::rewriteLimitOffsetSql()
Rewrite sql to apply $limit > and $offset > 0 for MSSQL database.
top
s
setDbConnection | in file TDbCommandBuilder.php, method TDbCommandBuilder::setDbConnection()
setInfo | in file TOracleTableInfo.php, method TOracleTableInfo::setInfo()
setInfo | in file TDbTableInfo.php, method TDbTableInfo::setInfo()
setInfo | in file TDbTableColumn.php, method TDbTableColumn::setInfo()
setTableInfo | in file TDbCommandBuilder.php, method TDbCommandBuilder::setTableInfo()
top
t
TMssqlCommandBuilder.php | procedural page TMssqlCommandBuilder.php
TMysqlCommandBuilder.php | procedural page TMysqlCommandBuilder.php
TOracleCommandBuilder.php | procedural page TOracleCommandBuilder.php
TOracleTableInfo.php | procedural page TOracleTableInfo.php
TPgsqlCommandBuilder.php | procedural page TPgsqlCommandBuilder.php
TSqliteCommandBuilder.php | procedural page TSqliteCommandBuilder.php
TDbCommandBuilder.php | procedural page TDbCommandBuilder.php
TDbMetaData.php | procedural page TDbMetaData.php
TDbTableColumn.php | procedural page TDbTableColumn.php
TDbTableInfo.php | procedural page TDbTableInfo.php
TDbCommandBuilder in file TDbCommandBuilder.php, class TDbCommandBuilder
TDbCommandBuilder provides basic methods to create query commands for tables giving by setTableInfo the property.
TDbMetaData in file TDbMetaData.php, class TDbMetaData
TDbMetaData is the base class for retrieving metadata information, such as table and columns information, from a database connection.
TDbTableColumn in file TDbTableColumn.php, class TDbTableColumn
TDbTableColumn class describes the column meta data of the schema for a database table.
TDbTableInfo in file TDbTableInfo.php, class TDbTableInfo
TDbTableInfo class describes the meta data of a database table.
TMssqlCommandBuilder in file TMssqlCommandBuilder.php, class TMssqlCommandBuilder
TMssqlCommandBuilder provides specifics methods to create limit/offset query commands for MSSQL servers.
TMysqlCommandBuilder in file TMysqlCommandBuilder.php, class TMysqlCommandBuilder
TMysqlCommandBuilder implements default TDbCommandBuilder
TOracleCommandBuilder in file TOracleCommandBuilder.php, class TOracleCommandBuilder
TOracleCommandBuilder provides specifics methods to create limit/offset query commands for Oracle database.
TOracleTableInfo in file TOracleTableInfo.php, class TOracleTableInfo
TDbTableInfo class describes the meta data of a database table.
TPgsqlCommandBuilder in file TPgsqlCommandBuilder.php, class TPgsqlCommandBuilder
TPgsqlCommandBuilder provides specifics methods to create limit/offset query commands for Pgsql database.
TSqliteCommandBuilder in file TSqliteCommandBuilder.php, class TSqliteCommandBuilder
TSqliteCommandBuilder provides specifics methods to create limit/offset query commands for Sqlite database.
top
u
UNDEFINED_VALUE | in file TDbTableColumn.php, class constant TDbTableColumn::UNDEFINED_VALUE


Class Trees for Package System.Data.Common

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TDbCommandBuilder.php

File: /Data/Common/TDbCommandBuilder.php

Remarks

TDbCommandBuilder class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDbCommandBuilder.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDbCommandBuilder
TDbCommandBuilder provides basic methods to create query commands for tables giving by setTableInfo the property.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:11 +0200 by phpDocumentor 1.4.3


Docs for page TDbMetaData.php

File: /Data/Common/TDbMetaData.php

Remarks

TDbMetaData class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDbMetaData.php 3049 2011-10-16 17:25:14Z GODZilla0480@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDbMetaData
TDbMetaData is the base class for retrieving metadata information, such as table and columns information, from a database connection.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:12 +0200 by phpDocumentor 1.4.3


Docs for page TDbTableColumn.php

File: /Data/Common/TDbTableColumn.php

Remarks

TDbTableColumn class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDbTableColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDbTableColumn
TDbTableColumn class describes the column meta data of the schema for a database table.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:12 +0200 by phpDocumentor 1.4.3


Docs for page TDbTableInfo.php

File: /Data/Common/TDbTableInfo.php

Remarks

TDbTableInfo class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDbTableInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDbTableInfo
TDbTableInfo class describes the meta data of a database table.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:13 +0200 by phpDocumentor 1.4.3


Docs for page TMssqlCommandBuilder.php

File: /Data/Common/Mssql/TMssqlCommandBuilder.php

Remarks

TMsssqlCommandBuilder class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDbCommandBuilder.php 1863 2007-04-12 12:43:49Z wei $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMssqlCommandBuilder
TMssqlCommandBuilder provides specifics methods to create limit/offset query commands for MSSQL servers.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:51 +0200 by phpDocumentor 1.4.3


Docs for page TMysqlCommandBuilder.php

File: /Data/Common/Mysql/TMysqlCommandBuilder.php

Remarks

TMysqlCommandBuilder class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDbCommandBuilder.php 1863 2007-04-12 12:43:49Z wei $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMysqlCommandBuilder
TMysqlCommandBuilder implements default TDbCommandBuilder

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:53 +0200 by phpDocumentor 1.4.3


Docs for page TOracleCommandBuilder.php

File: /Data/Common/Oracle/TOracleCommandBuilder.php

Remarks

TOracleCommandBuilder class file.

author

Marcos Nobre <marconobre[at]gmail[dot]com>

version

$Id: TOracleCommandBuilder.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TOracleCommandBuilder
TOracleCommandBuilder provides specifics methods to create limit/offset query commands for Oracle database.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:55 +0200 by phpDocumentor 1.4.3


Docs for page TOracleTableInfo.php

File: /Data/Common/Oracle/TOracleTableInfo.php

Remarks

TOracleTableInfo class file.

author

Marcos Nobre <marconobre[at]gmail[dot]com>

version

$Id: TOracleTableInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TOracleTableInfo
TDbTableInfo class describes the meta data of a database table.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:56 +0200 by phpDocumentor 1.4.3


Docs for page TPgsqlCommandBuilder.php

File: /Data/Common/Pgsql/TPgsqlCommandBuilder.php

Remarks

TPgsqlCommandBuilder class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDbCommandBuilder.php 1863 2007-04-12 12:43:49Z wei $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPgsqlCommandBuilder
TPgsqlCommandBuilder provides specifics methods to create limit/offset query commands for Pgsql database.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:02 +0200 by phpDocumentor 1.4.3


Docs for page TSqliteCommandBuilder.php

File: /Data/Common/Sqlite/TSqliteCommandBuilder.php

Remarks

TSqliteCommandBuilder class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDbCommandBuilder.php 1863 2007-04-12 12:43:49Z wei $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqliteCommandBuilder
TSqliteCommandBuilder provides specifics methods to create limit/offset query commands for Sqlite database.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:24 +0200 by phpDocumentor 1.4.3


Docs For Class TDbCommandBuilder

Class TDbCommandBuilder

[line 22]
TComponent
   |
   --TDbCommandBuilder
Classes extended from TDbCommandBuilder:
TMssqlCommandBuilder
TMssqlCommandBuilder provides specifics methods to create limit/offset query commands for MSSQL servers.
TMysqlCommandBuilder
TMysqlCommandBuilder implements default TDbCommandBuilder
TOracleCommandBuilder
TOracleCommandBuilder provides specifics methods to create limit/offset query commands for Oracle database.
TPgsqlCommandBuilder
TPgsqlCommandBuilder provides specifics methods to create limit/offset query commands for Pgsql database.
TSqliteCommandBuilder
TSqliteCommandBuilder provides specifics methods to create limit/offset query commands for Sqlite database.

Location: /Data/Common/TDbCommandBuilder.php

Remarks

TDbCommandBuilder provides basic methods to create query commands for tables giving by setTableInfo the property.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TDbCommandBuilder.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static integer getPdoType()
  • integer getPdoType()

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    static TDbCommandBuilder::getPdoType

    static getPdoType( mixed $value );

    Parameters

    $value

    PHP value

    Returns

    PDO parameter types.

    access

    public

    [ Top ]

    TDbCommandBuilder::__construct

    __construct( [TDbConnection $connection = null], [TDbTableInfo $tableInfo = null] );

    Parameters

    $connection

    database connection.

    $tableInfo

    table information.

    access

    public

    [ Top ]

    TDbCommandBuilder::applyCriterias

    applyCriterias(

$sql, [
$parameters = array()], [
$ordering = array()], [
$limit = -1], [
$offset = -1] );

    Parameters

    $sql

    $parameters

    $ordering

    $limit

    $offset

    access

    public

    [ Top ]

    TDbCommandBuilder::applyLimitOffset

    applyLimitOffset( string $sql, [integer $limit = -1], [integer $offset = -1] );

    Overridden in child classes as:

    TMssqlCommandBuilder::applyLimitOffset()
    Overrides parent implementation. Alters the sql to apply $limit and $offset.
    TOracleCommandBuilder::applyLimitOffset()
    Overrides parent implementation to use Oracle way of get paginated RecordSet instead of using LIMIT sql clause.
    TSqliteCommandBuilder::applyLimitOffset()
    Alters the sql to apply $limit and $offset.

    Parameters

    $sql

    SQL query string.

    $limit

    maximum number of rows, -1 to ignore limit.

    $offset

    row offset, -1 to ignore offset.

    Returns

    SQL with limit and offset.

    Remarks

    Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.

    access

    public

    [ Top ]

    TDbCommandBuilder::applyOrdering

    applyOrdering( string $sql, array $ordering );

    Parameters

    $sql

    SQL string without existing ordering.

    $ordering

    pairs of column names as key and direction as value.

    Returns

    modified SQL applied with ORDER BY.

    access

    public

    [ Top ]

    TDbCommandBuilder::bindArrayValues

    bindArrayValues( TDbCommand $command, array $values );

    Parameters

    $command

    database command

    $values

    values for binding.

    access

    public

    [ Top ]

    TDbCommandBuilder::bindColumnValues

    bindColumnValues( TDbCommand $command, array $values );

    Parameters

    $command

    database command.

    $values

    name-value pairs.

    Remarks

    Bind the name-value pairs of $values where the array keys correspond to column names.

    access

    public

    [ Top ]

    TDbCommandBuilder::createCommand

    createCommand( string $sql );

    Parameters

    $sql

    SQL query string.

    Returns

    corresponding database command.

    access

    public

    [ Top ]

    TDbCommandBuilder::createCountCommand

    createCountCommand(
[string
$where = '1=1'], [array
$parameters = array()], [
$ordering = array()], [
$limit = -1], [
$offset = -1] );

    Parameters

    $where

    count condition.

    $parameters

    binding parameters.

    $ordering

    $limit

    $offset

    Returns

    count command.

    Remarks

    Creates a count(*) command for the table described in setTableInfo.

    access

    public

    [ Top ]

    TDbCommandBuilder::createDeleteCommand

    createDeleteCommand( string $where, [array $parameters = array()] );

    Parameters

    $where

    delete condition.

    $parameters

    delete parameters.

    Returns

    delete command.

    Remarks

    Creates a delete command for the table described in setTableInfo.

    The conditions for delete is given by the $where argument and the parameters for the condition is given by $parameters.

    access

    public

    [ Top ]

    TDbCommandBuilder::createFindCommand

    createFindCommand(
[string
$where = '1=1'], [array
$parameters = array()], [
$ordering = array()], [
$limit = -1], [
$offset = -1], [
$select = '*'] );

    Parameters

    $where

    query condition

    $parameters

    condition parameters.

    $ordering

    $limit

    $offset

    $select

    Returns

    query command.

    Remarks

    Appends the $where condition to the string "SELECT * FROM tableName WHERE ".

    The tableName is obtained from the TableInfo property.

    access

    public

    [ Top ]

    TDbCommandBuilder::createInsertCommand

    createInsertCommand( array $data );

    Parameters

    $data

    name-value pairs of new data to be inserted.

    Returns

    insert command

    Remarks

    Creates an insert command for the table described in setTableInfo for the given data.

    Each array key in the $data array must correspond to the column name of the table (if a column allows to be null, it may be omitted) to be inserted with the corresponding array value.

    access

    public

    [ Top ]

    TDbCommandBuilder::createUpdateCommand

    createUpdateCommand( array $data, string $where, [array $parameters = array()] );

    Parameters

    $data

    name-value pairs of data to be updated.

    $where

    update condition.

    $parameters

    update parameters.

    Returns

    update command.

    Remarks

    Creates an update command for the table described in setTableInfo for the given data.

    Each array key in the $data array must correspond to the column name to be updated with the corresponding array value.

    access

    public

    [ Top ]

    TDbCommandBuilder::getColumnBindings

    getColumnBindings( array $values, [boolean $position = false] );

    Parameters

    $values

    data for binding.

    $position

    true to bind as position values.

    Returns

    update column names with corresponding binding substrings.

    Remarks

    Create a name-value or position-value if $position=true binding strings.

    access

    protected

    [ Top ]

    TDbCommandBuilder::getDbConnection

    getDbConnection( );

    Returns

    database connection.

    access

    public

    [ Top ]

    TDbCommandBuilder::getInsertFieldBindings

    getInsertFieldBindings( object array $values );

    Parameters

    $values

    or object to be inserted.

    Returns

    tuple ($fields, $bindings)

    Remarks

    Returns a list of insert field name and a list of binding names.

    access

    protected

    [ Top ]

    TDbCommandBuilder::getLastInsertID

    getLastInsertID( );

    Overridden in child classes as:

    TMssqlCommandBuilder::getLastInsertID()
    Overrides parent implementation. Uses "SELECT @@Identity".

    Returns

    last insert id, null if none is found.

    Remarks

    Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.

    access

    public

    [ Top ]

    TDbCommandBuilder::getSearchCondition

    getSearchCondition( string $column, array $words );

    Overridden in child classes as:

    TPgsqlCommandBuilder::getSearchCondition()
    Overrides parent implementation to use PostgreSQL's ILIKE instead of LIKE (case-sensitive).

    Parameters

    $column

    column name.

    $words

    keywords

    Returns

    search condition for all words in one column.

    access

    protected

    [ Top ]

    TDbCommandBuilder::getSearchExpression

    getSearchExpression( array $fields, string $keywords );

    Overridden in child classes as:

    TOracleCommandBuilder::getSearchExpression()
    Overrides parent implementation. Only column of type text or character (and its variants) accepts the LIKE criteria.
    TPgsqlCommandBuilder::getSearchExpression()
    Overrides parent implementation. Only column of type text or character (and its variants) accepts the LIKE criteria.

    Parameters

    $fields

    list of column id for potential search condition.

    $keywords

    string of keywords

    Returns

    SQL search condition matching on a set of columns.

    Remarks

    Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).

    access

    public

    [ Top ]

    TDbCommandBuilder::getSelectFieldList

    getSelectFieldList( [ $data = '*'], mixed $value );

    Parameters

    $value

    $data

    Returns

    of generated fields - use implode(', ', $selectfieldlist) to collapse field list for usage

    Remarks

    Different behavior depends on type of passed data string usage without modification

    null will be expanded to full list of quoted table column names (quoting depends on database)

    array

    • Column names will be quoted if used as key or value of array
    •      array('col1', 'col2', 'col2')
      •

    •      // SELECT `col1`, `col2`, `col3` FROM...
      •
    • Column aliasing
    •  array('mycol1' => 'col1', 'mycol2' => 'COUNT(*)')
      •

    •  // SELECT `col1` AS mycol1, COUNT(*) AS mycol2 FROM...
      •
    • NULL and scalar values (strings will be quoted depending on database)
    •  array('col1' => 'my custom string', 'col2' => 1.0, 'col3' => 'NULL')
      •

    •  // SELECT "my custom string" AS `col1`, 1.0 AS `col2`, NULL AS `col3` FROM...
      •
    • If the *-wildcard char is used as key or value, add the full list of quoted table column names
    •  array('col1' => 'NULL', '*')
      •

    •  // SELECT `col1`, `col2`, `col3`, NULL AS `col1` FROM...
      •

    todo

    add support for table aliasing

    todo

    add support for quoting of column aliasing

    since

    3.1.7

    access

    public

    [ Top ]

    TDbCommandBuilder::getTableInfo

    getTableInfo( TDbTableInfo 0 );

    Parameters

    0

    table information.

    access

    public

    [ Top ]

    TDbCommandBuilder::hasIntegerKey

    hasIntegerKey( array $array );

    Parameters

    $array

    Returns

    true if any array key is an integer.

    access

    protected

    [ Top ]

    TDbCommandBuilder::setDbConnection

    setDbConnection( TDbConnection $value );

    Parameters

    $value

    database connection.

    access

    public

    [ Top ]

    TDbCommandBuilder::setTableInfo

    setTableInfo( TDbTableInfo $value );

    Parameters

    $value

    table information.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:11 +0200 by phpDocumentor 1.4.3


Docs For Class TDbMetaData

Class TDbMetaData

[line 24]
TComponent
   |
   --TDbMetaData
Classes extended from TDbMetaData:
TMssqlMetaData
TMssqlMetaData loads MSSQL database table and column information.
TMysqlMetaData
TMysqlMetaData loads Mysql version 4.1.x and 5.x database table and column information.
TOracleMetaData
TOracleMetaData loads Oracle database table and column information.
TPgsqlMetaData
TPgsqlMetaData loads PostgreSQL database table and column information.
TSqliteMetaData
TSqliteMetaData loads SQLite database table and column information.

Location: /Data/Common/TDbMetaData.php

Remarks

TDbMetaData is the base class for retrieving metadata information, such as table and columns information, from a database connection.

Use the getTableInfo method to retrieve a table information.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TDbMetaData.php 3049 2011-10-16 17:25:14Z GODZilla0480@gmail.com $

abstract

since

3.1

Class Variable Summary

  • static $delimiterIdentifier = array('[', ']', '"', '`', "'")

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static TDbMetaData getInstance()
    Obtain database specific TDbMetaData class using the driver name of the database connection.
  • TDbMetaData getInstance()
    Obtain database specific TDbMetaData class using the driver name of the database connection.

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    static TDbMetaData::getInstance

    static getInstance( TDbConnection $conn );

    Parameters

    $conn

    database connection.

    Returns

    database specific TDbMetaData.

    Remarks

    Obtain database specific TDbMetaData class using the driver name of the database connection.

    access

    public

    [ Top ]

    TDbMetaData::__construct

    __construct( TDbConnection $conn );

    Parameters

    $conn

    database connection.

    access

    public

    [ Top ]

    TDbMetaData::createCommandBuilder

    createCommandBuilder( [string $tableName = null] );

    Parameters

    $tableName

    table name.

    Returns

    command builder instance for the given table.

    Remarks

    Creates a command builder for a given table name.

    access

    public

    [ Top ]

    TDbMetaData::createTableInfo

    createTableInfo( $tableName );

    Overridden in child classes as:

    TMssqlMetaData::createTableInfo()
    Get the column definitions for given table.
    TMysqlMetaData::createTableInfo()
    Get the column definitions for given table.
    TOracleMetaData::createTableInfo()
    Get the column definitions for given table.
    TPgsqlMetaData::createTableInfo()
    Get the column definitions for given table.
    TSqliteMetaData::createTableInfo()
    Get the column definitions for given table.

    Parameters

    $tableName

    Returns

    driver dependent create builder.

    Remarks

    This method should be implemented by decendent classes.

    abstract

    access

    protected

    [ Top ]

    TDbMetaData::getDbConnection

    getDbConnection( );

    Returns

    database connection.

    access

    public

    [ Top ]

    TDbMetaData::getTableInfo

    getTableInfo( [string $tableName = null] );

    Parameters

    $tableName

    table or view name

    Returns

    table information.

    Remarks

    Obtains table meta data information for the current connection and given table name.

    access

    public

    [ Top ]

    TDbMetaData::getTableInfoClass

    getTableInfoClass( );

    Overridden in child classes as:

    TMssqlMetaData::getTableInfoClass()
    TMysqlMetaData::getTableInfoClass()
    TOracleMetaData::getTableInfoClass()
    TPgsqlMetaData::getTableInfoClass()
    TSqliteMetaData::getTableInfoClass()

    Returns

    TDbTableInfo class name.

    access

    protected

    [ Top ]

    TDbMetaData::quoteColumnAlias

    quoteColumnAlias( string $name, string $lft, string $rgt );

    Overridden in child classes as:

    TMssqlMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
    TMysqlMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
    TPgsqlMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
    TSqliteMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.

    Parameters

    $name

    column alias

    $lft

    left delimiter

    $rgt

    right delimiter

    Returns

    the properly quoted column alias

    Remarks

    Quotes a column alias for use in a query.

    access

    public

    [ Top ]

    TDbMetaData::quoteColumnName

    quoteColumnName( string $name, string $lft, string $rgt );

    Overridden in child classes as:

    TMssqlMetaData::quoteColumnName()
    Quotes a column name for use in a query.
    TMysqlMetaData::quoteColumnName()
    Quotes a column name for use in a query.
    TPgsqlMetaData::quoteColumnName()
    Quotes a column name for use in a query.
    TSqliteMetaData::quoteColumnName()
    Quotes a column name for use in a query.

    Parameters

    $name

    column name

    $lft

    left delimiter

    $rgt

    right delimiter

    Returns

    the properly quoted column name

    Remarks

    Quotes a column name for use in a query.

    access

    public

    [ Top ]

    TDbMetaData::quoteTableName

    quoteTableName( string $name, string $lft, string $rgt );

    Overridden in child classes as:

    TMssqlMetaData::quoteTableName()
    Quotes a table name for use in a query.
    TMysqlMetaData::quoteTableName()
    Quotes a table name for use in a query.
    TPgsqlMetaData::quoteTableName()
    Quotes a table name for use in a query.
    TSqliteMetaData::quoteTableName()
    Quotes a table name for use in a query.

    Parameters

    $name

    table name

    $lft

    left delimiter

    $rgt

    right delimiter

    Returns

    the properly quoted table name

    Remarks

    Quotes a table name for use in a query.

    access

    public

    [ Top ]

Variable Detail

  • static $delimiterIdentifier = array('[', ']', '"', '`', "'") [line 32]
  • Data type: array

    • access

    protected

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:12 +0200 by phpDocumentor 1.4.3


Docs For Class TDbTableColumn

Class TDbTableColumn

[line 21]
TComponent
   |
   --TDbTableColumn
Classes extended from TDbTableColumn:
TMssqlTableColumn
Describes the column metadata of the schema for a Mssql database table.
TMysqlTableColumn
Describes the column metadata of the schema for a Mysql database table.
TOracleTableColumn
Describes the column metadata of the schema for a PostgreSQL database table.
TPgsqlTableColumn
Describes the column metadata of the schema for a PostgreSQL database table.
TSqliteTableColumn
Describes the column metadata of the schema for a PostgreSQL database table.

Location: /Data/Common/TDbTableColumn.php

Remarks

TDbTableColumn class describes the column meta data of the schema for a database table.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TDbTableColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

  • UNDEFINED_VALUE =  INF

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDbTableColumn::__construct

    __construct( array $columnInfo );

    Parameters

    $columnInfo

    table column information.

    Remarks

    Sets the table column meta data.

    access

    public

    [ Top ]

    TDbTableColumn::getAllowNull

    getAllowNull( );

    Returns

    specifies whether value Null is allowed, default is false.

    access

    public

    [ Top ]

    TDbTableColumn::getColumnId

    getColumnId( );

    Returns

    name of the column with quoted identifier.

    access

    public

    [ Top ]

    TDbTableColumn::getColumnIndex

    getColumnIndex( );

    Returns

    zero-based ordinal position of the column in the table.

    access

    public

    [ Top ]

    TDbTableColumn::getColumnName

    getColumnName( );

    Returns

    name of the column in the table (identifier quoted).

    access

    public

    [ Top ]

    TDbTableColumn::getColumnSize

    getColumnSize( );

    Returns

    size of the column.

    access

    public

    [ Top ]

    TDbTableColumn::getDbType

    getDbType( );

    Returns

    column type.

    access

    public

    [ Top ]

    TDbTableColumn::getDefaultValue

    getDefaultValue( );

    Returns

    default column value if column value was null.

    access

    public

    [ Top ]

    TDbTableColumn::getInfo

    getInfo( string $name, [mixed $default = null] );

    Parameters

    $name

    information array key name

    $default

    default value if information array value is null

    Returns

    information array value.

    access

    protected

    [ Top ]

    TDbTableColumn::getIsExcluded

    getIsExcluded( );

    Overridden in child classes as:

    TMssqlTableColumn::getIsExcluded()

    Returns

    whether this column is excluded from insert and update.

    access

    public

    [ Top ]

    TDbTableColumn::getIsForeignKey

    getIsForeignKey( );

    Returns

    whether this column is a foreign key, default is false.

    access

    public

    [ Top ]

    TDbTableColumn::getIsPrimaryKey

    getIsPrimaryKey( );

    Returns

    whether this column is a primary key for the table, default is false.

    access

    public

    [ Top ]

    TDbTableColumn::getMaxiumNumericConstraint

    getMaxiumNumericConstraint( );

    access

    public

    [ Top ]

    TDbTableColumn::getNumericPrecision

    getNumericPrecision( );

    Returns

    precision of the column data, if the data is numeric.

    access

    public

    [ Top ]

    TDbTableColumn::getNumericScale

    getNumericScale( );

    Returns

    scale of the column data, if the data is numeric.

    access

    public

    [ Top ]

    TDbTableColumn::getPdoType

    getPdoType( integer 0 );

    Parameters

    0

    PDO bind param/value types, default returns string.

    access

    public

    [ Top ]

    TDbTableColumn::getPHPType

    getPHPType( );

    Overridden in child classes as:

    TMssqlTableColumn::getPHPType()
    Overrides parent implementation, returns PHP type from the db type.
    TMysqlTableColumn::getPHPType()
    Overrides parent implementation, returns PHP type from the db type.
    TOracleTableColumn::getPHPType()
    Overrides parent implementation, returns PHP type from the db type.
    TPgsqlTableColumn::getPHPType()
    Overrides parent implementation, returns PHP type from the db type.
    TSqliteTableColumn::getPHPType()
    Overrides parent implementation, returns PHP type from the db type.

    Returns

    derived PHP primitive type from the column db type.

    Remarks

    Returns the derived PHP primitive type from the db type. Default returns 'string'.

    access

    public

    [ Top ]

    TDbTableColumn::getSequenceName

    getSequenceName( string 0 );

    Parameters

    0

    sequence name, only applicable if column is a sequence

    access

    public

    [ Top ]

    TDbTableColumn::hasSequence

    hasSequence( );

    Overridden in child classes as:

    TMssqlTableColumn::hasSequence()
    TMysqlTableColumn::hasSequence()
    TSqliteTableColumn::hasSequence()

    Returns

    whether the column is a sequence.

    access

    public

    [ Top ]

    TDbTableColumn::setInfo

    setInfo( string $name, mixed $value );

    Parameters

    $name

    information array key name

    $value

    new information array value.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

  • UNDEFINED_VALUE =  INF [line 23]

Documentation generated on Mon, 25 Jun 2012 14:44:12 +0200 by phpDocumentor 1.4.3


Docs For Class TDbTableInfo

Class TDbTableInfo

[line 21]
TComponent
   |
   --TDbTableInfo
Classes extended from TDbTableInfo:
TMssqlTableInfo
TMssqlTableInfo class provides additional table information for Mssql database.
TMysqlTableInfo
TMysqlTableInfo class provides additional table information for MySQL database.
TPgsqlTableInfo
TPgsqlTableInfo class provides additional table information for PostgreSQL database.
TSqliteTableInfo
TSqliteTableInfo class provides additional table information for PostgreSQL database.

Location: /Data/Common/TDbTableInfo.php

Remarks

TDbTableInfo class describes the meta data of a database table.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TDbTableInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDbTableInfo::__construct

    __construct(
[array
$tableInfo = array()], [
$primary = array()], [
$foreign = array()] );

    Parameters

    $tableInfo

    table column information.

    $primary

    $foreign

    Remarks

    Sets the database table meta data information.

    access

    public

    [ Top ]

    TDbTableInfo::createCommandBuilder

    createCommandBuilder( TDbConnection $connection );

    Overridden in child classes as:

    TMssqlTableInfo::createCommandBuilder()
    TMysqlTableInfo::createCommandBuilder()
    TPgsqlTableInfo::createCommandBuilder()
    TSqliteTableInfo::createCommandBuilder()

    Parameters

    $connection

    database connection.

    Returns

    new command builder

    access

    public

    [ Top ]

    TDbTableInfo::getColumn

    getColumn( string $name );

    Parameters

    $name

    column id

    Returns

    column information.

    access

    public

    [ Top ]

    TDbTableInfo::getColumnNames

    getColumnNames( array 0 );

    Parameters

    0

    list of column Id, empty to get all columns.

    Returns

    table column names (identifier quoted)

    access

    public

    [ Top ]

    TDbTableInfo::getColumns

    getColumns( );

    Returns

    TDbTableColumn column meta data.

    access

    public

    [ Top ]

    TDbTableInfo::getForeignKeys

    getForeignKeys( );

    Returns

    tuples of foreign table and column name.

    access

    public

    [ Top ]

    TDbTableInfo::getInfo

    getInfo( string $name, [mixed $default = null] );

    Parameters

    $name

    information array key name

    $default

    default value if information array value is null

    Returns

    information array value.

    access

    protected

    [ Top ]

    TDbTableInfo::getIsView

    getIsView( );

    Returns

    whether the table is a view, default is false.

    access

    public

    [ Top ]

    TDbTableInfo::getLowerCaseColumnNames

    getLowerCaseColumnNames( );

    Returns

    lowercased column key names mapped to normal column ids.

    access

    public

    [ Top ]

    TDbTableInfo::getPrimaryKeys

    getPrimaryKeys( );

    Returns

    names of primary key columns.

    access

    public

    [ Top ]

    TDbTableInfo::getTableFullName

    getTableFullName( );

    Overridden in child classes as:

    TMssqlTableInfo::getTableFullName()
    TMysqlTableInfo::getTableFullName()
    TPgsqlTableInfo::getTableFullName()
    TSqliteTableInfo::getTableFullName()

    Returns

    full name of the table, database dependent.

    access

    public

    [ Top ]

    TDbTableInfo::getTableName

    getTableName( );

    Returns

    name of the table this column belongs to.

    access

    public

    [ Top ]

    TDbTableInfo::setInfo

    setInfo( string $name, mixed $value );

    Parameters

    $name

    information array key name

    $value

    new information array value.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:13 +0200 by phpDocumentor 1.4.3


Docs For Class TMssqlCommandBuilder

Class TMssqlCommandBuilder

[line 24]
TComponent
   |
   --TDbCommandBuilder
      |
      --TMssqlCommandBuilder
Location: /Data/Common/Mssql/TMssqlCommandBuilder.php

Remarks

TMssqlCommandBuilder provides specifics methods to create limit/offset query commands for MSSQL servers.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TDbCommandBuilder.php 1863 2007-04-12 12:43:49Z wei $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbCommandBuilder

  • TDbCommandBuilder::__construct()
  • TDbCommandBuilder::applyCriterias()
  • TDbCommandBuilder::applyLimitOffset()
    Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.
  • TDbCommandBuilder::applyOrdering()
  • TDbCommandBuilder::bindArrayValues()
  • TDbCommandBuilder::bindColumnValues()
    Bind the name-value pairs of $values where the array keys correspond to column names.
  • TDbCommandBuilder::createCommand()
  • TDbCommandBuilder::createCountCommand()
    Creates a count(*) command for the table described in setTableInfo.
  • TDbCommandBuilder::createDeleteCommand()
    Creates a delete command for the table described in setTableInfo.
  • TDbCommandBuilder::createFindCommand()
    Appends the $where condition to the string "SELECT * FROM tableName WHERE ".
  • TDbCommandBuilder::createInsertCommand()
    Creates an insert command for the table described in setTableInfo for the given data.
  • TDbCommandBuilder::createUpdateCommand()
    Creates an update command for the table described in setTableInfo for the given data.
  • TDbCommandBuilder::getColumnBindings()
    Create a name-value or position-value if $position=true binding strings.
  • TDbCommandBuilder::getDbConnection()
  • TDbCommandBuilder::getInsertFieldBindings()
    Returns a list of insert field name and a list of binding names.
  • TDbCommandBuilder::getLastInsertID()
    Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
  • TDbCommandBuilder::getPdoType()
  • TDbCommandBuilder::getSearchCondition()
  • TDbCommandBuilder::getSearchExpression()
    Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).
  • TDbCommandBuilder::getSelectFieldList()
    Different behavior depends on type of passed data string usage without modification
  • TDbCommandBuilder::getTableInfo()
  • TDbCommandBuilder::hasIntegerKey()
  • TDbCommandBuilder::setDbConnection()
  • TDbCommandBuilder::setTableInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TMssqlCommandBuilder::applyLimitOffset

    applyLimitOffset( string $sql, [integer $limit = -1], [integer $offset = -1] );

    Overrides TDbCommandBuilder::applyLimitOffset() (Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.)

    Parameters

    $sql

    SQL query string.

    $limit

    maximum number of rows, -1 to ignore limit.

    $offset

    row offset, -1 to ignore offset.

    Returns

    SQL with limit and offset.

    Remarks

    Overrides parent implementation. Alters the sql to apply $limit and $offset.

    The idea for limit with offset is done by modifying the sql on the fly with numerous assumptions on the structure of the sql string. The modification is done with reference to the notes from http://troels.arvin.dk/db/rdbms/#select-limit-offset

  •  SELECT * FROM (
    •

  •   SELECT TOP n * FROM (
    •

  •     SELECT TOP z columns      -- (z=n+skip)
    •

  •     FROM tablename
    •

  •     ORDER BY key ASC
    •

  •   ) AS FOO ORDER BY key DESC -- ('FOO' may be anything)
    •

  •  ) AS BAR ORDER BY key ASC    -- ('BAR' may be anything)
    •

    Regular expressions are used to alter the SQL query. The resulting SQL query may be malformed for complex queries. The following restrictions apply

    • In particular, commas should NOT be used as part of the ordering expression or identifier. Commas must only be used for separating the ordering clauses.
    • In the ORDER BY clause, the column name should NOT be be qualified with a table name or view name. Alias the column names or use column index.
    • No clauses should follow the ORDER BY clause, e.g. no COMPUTE or FOR clauses.

    access

    public

    [ Top ]

    TMssqlCommandBuilder::findOrdering

    findOrdering( string $sql );

    Parameters

    $sql

    Returns

    ordering expression as key and ordering direction as value

    Remarks

    Base on simplified syntax http://msdn2.microsoft.com/en-us/library/aa259187(SQL.80).aspx

    access

    protected

    [ Top ]

    TMssqlCommandBuilder::getLastInsertID

    getLastInsertID( );

    Overrides TDbCommandBuilder::getLastInsertID() (Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.)

    Returns

    last insert id, null if none is found.

    Remarks

    Overrides parent implementation. Uses "SELECT @@Identity".

    access

    public

    [ Top ]

    TMssqlCommandBuilder::joinOrdering

    joinOrdering( array $orders );

    Parameters

    $orders

    ordering obtained from findOrdering()

    Returns

    concat the orderings

    access

    protected

    [ Top ]

    TMssqlCommandBuilder::reverseDirection

    reverseDirection( array $orders );

    Parameters

    $orders

    original ordering

    Returns

    ordering with reversed direction.

    access

    protected

    [ Top ]

    TMssqlCommandBuilder::rewriteLimitOffsetSql

    rewriteLimitOffsetSql( string $sql, integer $limit, integer $offset );

    Parameters

    $limit

    > 0

    $offset

    > 0

    $sql

    sql query

    Returns

    modified sql query applied with limit and offset.

    Remarks

    Rewrite sql to apply $limit > and $offset > 0 for MSSQL database.

    See http://troels.arvin.dk/db/rdbms/#select-limit-offset

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:51 +0200 by phpDocumentor 1.4.3


Docs For Class TMysqlCommandBuilder

Class TMysqlCommandBuilder

[line 23]
TComponent
   |
   --TDbCommandBuilder
      |
      --TMysqlCommandBuilder
Location: /Data/Common/Mysql/TMysqlCommandBuilder.php

Remarks

TMysqlCommandBuilder implements default TDbCommandBuilder

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TDbCommandBuilder.php 1863 2007-04-12 12:43:49Z wei $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbCommandBuilder

  • TDbCommandBuilder::__construct()
  • TDbCommandBuilder::applyCriterias()
  • TDbCommandBuilder::applyLimitOffset()
    Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.
  • TDbCommandBuilder::applyOrdering()
  • TDbCommandBuilder::bindArrayValues()
  • TDbCommandBuilder::bindColumnValues()
    Bind the name-value pairs of $values where the array keys correspond to column names.
  • TDbCommandBuilder::createCommand()
  • TDbCommandBuilder::createCountCommand()
    Creates a count(*) command for the table described in setTableInfo.
  • TDbCommandBuilder::createDeleteCommand()
    Creates a delete command for the table described in setTableInfo.
  • TDbCommandBuilder::createFindCommand()
    Appends the $where condition to the string "SELECT * FROM tableName WHERE ".
  • TDbCommandBuilder::createInsertCommand()
    Creates an insert command for the table described in setTableInfo for the given data.
  • TDbCommandBuilder::createUpdateCommand()
    Creates an update command for the table described in setTableInfo for the given data.
  • TDbCommandBuilder::getColumnBindings()
    Create a name-value or position-value if $position=true binding strings.
  • TDbCommandBuilder::getDbConnection()
  • TDbCommandBuilder::getInsertFieldBindings()
    Returns a list of insert field name and a list of binding names.
  • TDbCommandBuilder::getLastInsertID()
    Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
  • TDbCommandBuilder::getPdoType()
  • TDbCommandBuilder::getSearchCondition()
  • TDbCommandBuilder::getSearchExpression()
    Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).
  • TDbCommandBuilder::getSelectFieldList()
    Different behavior depends on type of passed data string usage without modification
  • TDbCommandBuilder::getTableInfo()
  • TDbCommandBuilder::hasIntegerKey()
  • TDbCommandBuilder::setDbConnection()
  • TDbCommandBuilder::setTableInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:53 +0200 by phpDocumentor 1.4.3


Docs For Class TOracleCommandBuilder

Class TOracleCommandBuilder

[line 25]
TComponent
   |
   --TDbCommandBuilder
      |
      --TOracleCommandBuilder
Location: /Data/Common/Oracle/TOracleCommandBuilder.php

Remarks

TOracleCommandBuilder provides specifics methods to create limit/offset query commands for Oracle database.

author

Marcos Nobre <marconobre[at]gmail[dot]com>

version

$Id: TOracleCommandBuilder.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbCommandBuilder

  • TDbCommandBuilder::__construct()
  • TDbCommandBuilder::applyCriterias()
  • TDbCommandBuilder::applyLimitOffset()
    Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.
  • TDbCommandBuilder::applyOrdering()
  • TDbCommandBuilder::bindArrayValues()
  • TDbCommandBuilder::bindColumnValues()
    Bind the name-value pairs of $values where the array keys correspond to column names.
  • TDbCommandBuilder::createCommand()
  • TDbCommandBuilder::createCountCommand()
    Creates a count(*) command for the table described in setTableInfo.
  • TDbCommandBuilder::createDeleteCommand()
    Creates a delete command for the table described in setTableInfo.
  • TDbCommandBuilder::createFindCommand()
    Appends the $where condition to the string "SELECT * FROM tableName WHERE ".
  • TDbCommandBuilder::createInsertCommand()
    Creates an insert command for the table described in setTableInfo for the given data.
  • TDbCommandBuilder::createUpdateCommand()
    Creates an update command for the table described in setTableInfo for the given data.
  • TDbCommandBuilder::getColumnBindings()
    Create a name-value or position-value if $position=true binding strings.
  • TDbCommandBuilder::getDbConnection()
  • TDbCommandBuilder::getInsertFieldBindings()
    Returns a list of insert field name and a list of binding names.
  • TDbCommandBuilder::getLastInsertID()
    Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
  • TDbCommandBuilder::getPdoType()
  • TDbCommandBuilder::getSearchCondition()
  • TDbCommandBuilder::getSearchExpression()
    Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).
  • TDbCommandBuilder::getSelectFieldList()
    Different behavior depends on type of passed data string usage without modification
  • TDbCommandBuilder::getTableInfo()
  • TDbCommandBuilder::hasIntegerKey()
  • TDbCommandBuilder::setDbConnection()
  • TDbCommandBuilder::setTableInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TOracleCommandBuilder::applyLimitOffset

    applyLimitOffset( string $sql, [integer $limit = -1], [integer $offset = -1] );

    Overrides TDbCommandBuilder::applyLimitOffset() (Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.)

    Parameters

    $sql

    SQL query string.

    $limit

    maximum number of rows, -1 to ignore limit.

    $offset

    row offset, -1 to ignore offset.

    Returns

    SQL with limit and offset in Oracle way.

    Remarks

    Overrides parent implementation to use Oracle way of get paginated RecordSet instead of using LIMIT sql clause.

    access

    public

    [ Top ]

    TOracleCommandBuilder::getSearchExpression

    getSearchExpression( array $fields, string $keywords );

    Overrides TDbCommandBuilder::getSearchExpression() (Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).)

    Parameters

    $fields

    list of column id for potential search condition.

    $keywords

    string of keywords

    Returns

    SQL search condition matching on a set of columns.

    Remarks

    Overrides parent implementation. Only column of type text or character (and its variants) accepts the LIKE criteria.

    access

    public

    [ Top ]

    TOracleCommandBuilder::isSearchableColumn

    isSearchableColumn( $column );

    Parameters

    $column

    Returns

    true if column can be used for LIKE searching.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:55 +0200 by phpDocumentor 1.4.3


Docs For Class TOracleTableInfo

Class TOracleTableInfo

[line 22]
TComponent
   |
   --TOracleTableInfo
Location: /Data/Common/Oracle/TOracleTableInfo.php

Remarks

TDbTableInfo class describes the meta data of a database table.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TOracleTableInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TOracleTableInfo::__construct

    __construct(
[array
$tableInfo = array()], [
$primary = array()], [
$foreign = array()] );

    Parameters

    $tableInfo

    table column information.

    $primary

    $foreign

    Remarks

    Sets the database table meta data information.

    access

    public

    [ Top ]

    TOracleTableInfo::createCommandBuilder

    createCommandBuilder( TDbConnection $connection );

    Parameters

    $connection

    database connection.

    Returns

    new command builder

    access

    public

    [ Top ]

    TOracleTableInfo::getColumn

    getColumn( string $name );

    Parameters

    $name

    column id

    Returns

    column information.

    access

    public

    [ Top ]

    TOracleTableInfo::getColumnNames

    getColumnNames( array 0 );

    Parameters

    0

    list of column Id, empty to get all columns.

    Returns

    table column names (identifier quoted)

    access

    public

    [ Top ]

    TOracleTableInfo::getColumns

    getColumns( );

    Returns

    TDbTableColumn column meta data.

    access

    public

    [ Top ]

    TOracleTableInfo::getForeignKeys

    getForeignKeys( );

    Returns

    tuples of foreign table and column name.

    access

    public

    [ Top ]

    TOracleTableInfo::getInfo

    getInfo( string $name, [mixed $default = null] );

    Parameters

    $name

    information array key name

    $default

    default value if information array value is null

    Returns

    information array value.

    access

    public

    [ Top ]

    TOracleTableInfo::getIsView

    getIsView( );

    Returns

    whether the table is a view, default is false.

    access

    public

    [ Top ]

    TOracleTableInfo::getLowerCaseColumnNames

    getLowerCaseColumnNames( );

    Returns

    lowercased column key names mapped to normal column ids.

    access

    public

    [ Top ]

    TOracleTableInfo::getPrimaryKeys

    getPrimaryKeys( );

    Returns

    names of primary key columns.

    access

    public

    [ Top ]

    TOracleTableInfo::getTableFullName

    getTableFullName( );

    Returns

    full name of the table, database dependent.

    access

    public

    [ Top ]

    TOracleTableInfo::getTableName

    getTableName( );

    Returns

    name of the table this column belongs to.

    access

    public

    [ Top ]

    TOracleTableInfo::setInfo

    setInfo( string $name, mixed $value );

    Parameters

    $name

    information array key name

    $value

    new information array value.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:56 +0200 by phpDocumentor 1.4.3


Docs For Class TPgsqlCommandBuilder

Class TPgsqlCommandBuilder

[line 24]
TComponent
   |
   --TDbCommandBuilder
      |
      --TPgsqlCommandBuilder
Location: /Data/Common/Pgsql/TPgsqlCommandBuilder.php

Remarks

TPgsqlCommandBuilder provides specifics methods to create limit/offset query commands for Pgsql database.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TDbCommandBuilder.php 1863 2007-04-12 12:43:49Z wei $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbCommandBuilder

  • TDbCommandBuilder::__construct()
  • TDbCommandBuilder::applyCriterias()
  • TDbCommandBuilder::applyLimitOffset()
    Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.
  • TDbCommandBuilder::applyOrdering()
  • TDbCommandBuilder::bindArrayValues()
  • TDbCommandBuilder::bindColumnValues()
    Bind the name-value pairs of $values where the array keys correspond to column names.
  • TDbCommandBuilder::createCommand()
  • TDbCommandBuilder::createCountCommand()
    Creates a count(*) command for the table described in setTableInfo.
  • TDbCommandBuilder::createDeleteCommand()
    Creates a delete command for the table described in setTableInfo.
  • TDbCommandBuilder::createFindCommand()
    Appends the $where condition to the string "SELECT * FROM tableName WHERE ".
  • TDbCommandBuilder::createInsertCommand()
    Creates an insert command for the table described in setTableInfo for the given data.
  • TDbCommandBuilder::createUpdateCommand()
    Creates an update command for the table described in setTableInfo for the given data.
  • TDbCommandBuilder::getColumnBindings()
    Create a name-value or position-value if $position=true binding strings.
  • TDbCommandBuilder::getDbConnection()
  • TDbCommandBuilder::getInsertFieldBindings()
    Returns a list of insert field name and a list of binding names.
  • TDbCommandBuilder::getLastInsertID()
    Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
  • TDbCommandBuilder::getPdoType()
  • TDbCommandBuilder::getSearchCondition()
  • TDbCommandBuilder::getSearchExpression()
    Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).
  • TDbCommandBuilder::getSelectFieldList()
    Different behavior depends on type of passed data string usage without modification
  • TDbCommandBuilder::getTableInfo()
  • TDbCommandBuilder::hasIntegerKey()
  • TDbCommandBuilder::setDbConnection()
  • TDbCommandBuilder::setTableInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPgsqlCommandBuilder::getSearchCondition

    getSearchCondition( string $column, array $words );

    Overrides TDbCommandBuilder::getSearchCondition() (parent method not documented)

    Parameters

    $column

    column name.

    $words

    keywords

    Returns

    search condition for all words in one column.

    Remarks

    Overrides parent implementation to use PostgreSQL's ILIKE instead of LIKE (case-sensitive).

    access

    protected

    [ Top ]

    TPgsqlCommandBuilder::getSearchExpression

    getSearchExpression( array $fields, string $keywords );

    Overrides TDbCommandBuilder::getSearchExpression() (Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).)

    Parameters

    $fields

    list of column id for potential search condition.

    $keywords

    string of keywords

    Returns

    SQL search condition matching on a set of columns.

    Remarks

    Overrides parent implementation. Only column of type text or character (and its variants) accepts the LIKE criteria.

    access

    public

    [ Top ]

    TPgsqlCommandBuilder::isSearchableColumn

    isSearchableColumn( $column );

    Parameters

    $column

    Returns

    true if column can be used for LIKE searching.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:02 +0200 by phpDocumentor 1.4.3


Docs For Class TSqliteCommandBuilder

Class TSqliteCommandBuilder

[line 24]
TComponent
   |
   --TDbCommandBuilder
      |
      --TSqliteCommandBuilder
Location: /Data/Common/Sqlite/TSqliteCommandBuilder.php

Remarks

TSqliteCommandBuilder provides specifics methods to create limit/offset query commands for Sqlite database.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TDbCommandBuilder.php 1863 2007-04-12 12:43:49Z wei $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbCommandBuilder

  • TDbCommandBuilder::__construct()
  • TDbCommandBuilder::applyCriterias()
  • TDbCommandBuilder::applyLimitOffset()
    Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.
  • TDbCommandBuilder::applyOrdering()
  • TDbCommandBuilder::bindArrayValues()
  • TDbCommandBuilder::bindColumnValues()
    Bind the name-value pairs of $values where the array keys correspond to column names.
  • TDbCommandBuilder::createCommand()
  • TDbCommandBuilder::createCountCommand()
    Creates a count(*) command for the table described in setTableInfo.
  • TDbCommandBuilder::createDeleteCommand()
    Creates a delete command for the table described in setTableInfo.
  • TDbCommandBuilder::createFindCommand()
    Appends the $where condition to the string "SELECT * FROM tableName WHERE ".
  • TDbCommandBuilder::createInsertCommand()
    Creates an insert command for the table described in setTableInfo for the given data.
  • TDbCommandBuilder::createUpdateCommand()
    Creates an update command for the table described in setTableInfo for the given data.
  • TDbCommandBuilder::getColumnBindings()
    Create a name-value or position-value if $position=true binding strings.
  • TDbCommandBuilder::getDbConnection()
  • TDbCommandBuilder::getInsertFieldBindings()
    Returns a list of insert field name and a list of binding names.
  • TDbCommandBuilder::getLastInsertID()
    Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
  • TDbCommandBuilder::getPdoType()
  • TDbCommandBuilder::getSearchCondition()
  • TDbCommandBuilder::getSearchExpression()
    Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).
  • TDbCommandBuilder::getSelectFieldList()
    Different behavior depends on type of passed data string usage without modification
  • TDbCommandBuilder::getTableInfo()
  • TDbCommandBuilder::hasIntegerKey()
  • TDbCommandBuilder::setDbConnection()
  • TDbCommandBuilder::setTableInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqliteCommandBuilder::applyLimitOffset

    applyLimitOffset( string $sql, [integer $limit = -1], [integer $offset = -1] );

    Overrides TDbCommandBuilder::applyLimitOffset() (Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.)

    Parameters

    $sql

    SQL query string.

    $limit

    maximum number of rows, -1 to ignore limit.

    $offset

    row offset, -1 to ignore offset.

    Returns

    SQL with limit and offset.

    Remarks

    Alters the sql to apply $limit and $offset.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:24 +0200 by phpDocumentor 1.4.3


Package System.Data.SqlMap.Configuration Element Index

Element index for package System.Data.SqlMap.Configuration

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a b c d e f g i l n p r s t _
top
_
__construct in file TParameterMap.php, method TParameterMap::__construct()
Initialize the properties and property map collections.
__construct | in file TSqlMapCacheModel.php, method TSqlMapCacheKey::__construct()
__construct in file TResultProperty.php, method TResultProperty::__construct()
Gets the containing result map ID.
__construct in file TResultMap.php, method TResultMap::__construct()
Initialize the columns collection.
__construct | in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::__construct()
__construct | in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::__construct()
__sleep | in file TResultProperty.php, method TResultProperty::__sleep()
__sleep | in file TParameterProperty.php, method TParameterProperty::__sleep()
__sleep | in file TSqlMapStatement.php, method TSqlMapStatement::__sleep()
top
a
addProperty | in file TParameterMap.php, method TParameterMap::addProperty()
addResultProperty in file TResultMap.php, method TResultMap::addResultProperty()
Add a TResultProperty to result mapping.
addSubMap | in file TDiscriminator.php, method TDiscriminator::addSubMap()
applyInlineParameterMap in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::applyInlineParameterMap()
Extract inline parameter maps.
ARRAY_TYPE | in file TResultProperty.php, class constant TResultProperty::ARRAY_TYPE
attachCacheModels in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::attachCacheModels()
Set the cache for each statement having a cache model property.
top
b
Basic | in file TSqlMapCacheModel.php, class constant TSqlMapCacheTypes::Basic
top
c
configure in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::configure()
Configure an XML mapping.
configure in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::configure()
Configure the TSqlMapManager using the given xml file.
createInsertStatement in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::createInsertStatement()
Create new insert statement from xml node.
createInstanceOf in file TSqlMapStatement.php, method TSqlMapStatement::createInstanceOf()
Create a new instance of a given type.
createInstanceOfListClass | in file TSqlMapStatement.php, method TSqlMapStatement::createInstanceOfListClass()
createInstanceOfResult in file TResultMap.php, method TResultMap::createInstanceOfResult()
Create a new instance of the class of this result map.
createInstanceOfResultClass in file TSqlMapStatement.php, method TSqlMapStatement::createInstanceOfResultClass()
Create a new instance of result class.
createObjectFromNode in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfigBuilder::createObjectFromNode()
Create an instance of an object give by the attribute named 'class' in the node and set the properties on the object given by attribute names and values.
createParameterMap in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::createParameterMap()
Create a new parameter map from xml node.
createResultMap in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::createResultMap()
Create a new result map and its associated result properties, disciminiator and sub maps.
createTypeHandler in file TResultProperty.php, method TResultProperty::createTypeHandler()
Create type handler from Type or TypeHandler.
createTypeHandler in file TParameterMap.php, method TParameterMap::createTypeHandler()
Create type handler from Type or TypeHandler.
top
d
DYNAMIC_TOKEN | in file TSimpleDynamicParser.php, class constant TSimpleDynamicParser::DYNAMIC_TOKEN
top
e
ESCAPED_INLINE_SYMBOL_REGEXP | in file TSqlMapXmlConfiguration.php, class constant TSqlMapXmlMappingConfiguration::ESCAPED_INLINE_SYMBOL_REGEXP
ESCAPED_SIMPLE_MARK_REGEXP | in file TSqlMapXmlConfiguration.php, class constant TSqlMapXmlMappingConfiguration::ESCAPED_SIMPLE_MARK_REGEXP
top
f
FIFO | in file TSqlMapCacheModel.php, class constant TSqlMapCacheTypes::FIFO
flush in file TSqlMapCacheModel.php, method TSqlMapCacheModel::flush()
Clears the cache.
top
g
generateKey | in file TSqlMapCacheModel.php, method TSqlMapCacheKey::generateKey()
get | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::get()
getAbsoluteFilePath in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfigBuilder::getAbsoluteFilePath()
Gets the filename relative to the basefile.
getCache | in file TSqlMapStatement.php, method TSqlMapStatement::getCache()
getCacheModel | in file TSqlMapStatement.php, method TSqlMapStatement::getCacheModel()
getClass | in file TResultMap.php, method TResultMap::getClass()
getColumn | in file TDiscriminator.php, method TDiscriminator::getColumn()
getColumn | in file TParameterProperty.php, method TParameterProperty::getColumn()
getColumn | in file TResultProperty.php, method TResultProperty::getColumn()
getColumnIndex | in file TDiscriminator.php, method TDiscriminator::getColumnIndex()
getColumnIndex | in file TResultProperty.php, method TResultProperty::getColumnIndex()
getColumns | in file TResultMap.php, method TResultMap::getColumns()
getConfigFile | in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::getConfigFile()
getConfigFile | in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfigBuilder::getConfigFile()
getConfigFile | in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::getConfigFile()
getDbType | in file TParameterProperty.php, method TParameterProperty::getDbType()
getDiscriminator | in file TResultMap.php, method TResultMap::getDiscriminator()
getElementByIdValue in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfigBuilder::getElementByIdValue()
Get element node by ID value (try for attribute name ID as case insensitive).
getExtends | in file TResultMap.php, method TResultMap::getExtends()
getExtends | in file TParameterMap.php, method TParameterMap::getExtends()
getExtends | in file TSqlMapStatement.php, method TSqlMapStatement::getExtends()
getFlushInterval | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::getFlushInterval()
getGroupBy | in file TResultMap.php, method TResultMap::getGroupBy()
getHash | in file TSqlMapCacheModel.php, method TSqlMapCacheKey::getHash()
getHitRatio | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::getHitRatio()
getID | in file TSqlMapStatement.php, method TSqlMapStatement::getID()
getID | in file TParameterMap.php, method TParameterMap::getID()
getID | in file TResultMap.php, method TResultMap::getID()
getID | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::getID()
getImplementation | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::getImplementation()
getImplementationClass | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::getImplementationClass()
getIsAfter | in file TSqlMapStatement.php, method TSqlMapSelectKey::getIsAfter()
getLazyLoad | in file TResultProperty.php, method TResultProperty::getLazyLoad()
getListClass | in file TSqlMapStatement.php, method TSqlMapStatement::getListClass()
getManager | in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::getManager()
getMapping | in file TDiscriminator.php, method TDiscriminator::getMapping()
getNestedResultMap | in file TResultProperty.php, method TResultProperty::getNestedResultMap()
getNullValue | in file TDiscriminator.php, method TDiscriminator::getNullValue()
getNullValue | in file TResultProperty.php, method TResultProperty::getNullValue()
getNullValue | in file TParameterProperty.php, method TParameterProperty::getNullValue()
getObjectValue | in file TParameterMap.php, method TParameterMap::getObjectValue()
getParameterClass | in file TSqlMapStatement.php, method TSqlMapStatement::getParameterClass()
getParameterMap | in file TSqlMapStatement.php, method TSqlMapStatement::getParameterMap()
getProperties | in file TParameterMap.php, method TParameterMap::getProperties()
getProperty | in file TParameterProperty.php, method TParameterProperty::getProperty()
getProperty | in file TParameterMap.php, method TParameterMap::getProperty()
getProperty | in file TResultProperty.php, method TResultProperty::getProperty()
getProperty | in file TSqlMapStatement.php, method TSqlMapSelectKey::getProperty()
getPropertyNames | in file TParameterMap.php, method TParameterMap::getPropertyNames()
getPropertyValue in file TResultProperty.php, method TResultProperty::getPropertyValue()
Gets the value for the current property, converts to applicable type if necessary.
getPropertyValue in file TParameterMap.php, method TParameterMap::getPropertyValue()
Get the value of a property from the the parameter object.
getPropertyValueType in file TResultProperty.php, method TResultProperty::getPropertyValueType()
Determines if the type is an instance of ArrayAccess, TList or an array.
getResultClass | in file TSqlMapStatement.php, method TSqlMapStatement::getResultClass()
getResultMap | in file TSqlMapStatement.php, method TSqlMapStatement::getResultMap()
getResultMapping in file TDiscriminator.php, method TSubMap::getResultMapping()
The result map to use when the Value matches the discriminator column value.
getResultMapping | in file TResultProperty.php, method TResultProperty::getResultMapping()
getSelect | in file TResultProperty.php, method TResultProperty::getSelect()
getSelectKey | in file TSqlMapStatement.php, method TSqlMapInsert::getSelectKey()
getSqlText | in file TSqlMapStatement.php, method TSqlMapStatement::getSqlText()
getSubMap | in file TDiscriminator.php, method TDiscriminator::getSubMap()
getType | in file TDiscriminator.php, method TDiscriminator::getType()
getType | in file TParameterProperty.php, method TParameterProperty::getType()
getType | in file TResultProperty.php, method TResultProperty::getType()
getType | in file TSqlMapStatement.php, method TSqlMapSelectKey::getType()
getTypedValue | in file TResultProperty.php, method TResultProperty::getTypedValue()
getTypeHandler | in file TResultProperty.php, method TResultProperty::getTypeHandler()
getTypeHandler | in file TDiscriminator.php, method TDiscriminator::getTypeHandler()
getTypeHandler | in file TParameterProperty.php, method TParameterProperty::getTypeHandler()
getValue | in file TDiscriminator.php, method TSubMap::getValue()
top
i
initialize in file TDiscriminator.php, method TDiscriminator::initialize()
Set the result maps for particular sub-mapping values.
initialize in file TSqlMapCacheModel.php, method TSqlMapCacheModel::initialize()
Initialize the cache implementation, sets the actual cache contain if supplied.
initialize | in file TSqlMapStatement.php, method TSqlMapStatement::initialize()
initMapping in file TDiscriminator.php, method TDiscriminator::initMapping()
Copies the discriminator properties to a new TResultProperty.
INLINE_PLACEHOLDER | in file TSqlMapXmlConfiguration.php, class constant TSqlMapXmlMappingConfiguration::INLINE_PLACEHOLDER
INLINE_SYMBOL | in file TSqlMapXmlConfiguration.php, class constant TSqlMapXmlMappingConfiguration::INLINE_SYMBOL
insertProperty | in file TParameterMap.php, method TParameterMap::insertProperty()
instanceOfArrayType in file TResultProperty.php, method TResultProperty::instanceOfArrayType()
Returns true if the result property Type is of ArrayAccess
instanceOfListType in file TResultProperty.php, method TResultProperty::instanceOfListType()
Returns true if the result property Type is of TList type or that the actual result object is an instance of TList.
top
l
LIST_TYPE | in file TResultProperty.php, class constant TResultProperty::LIST_TYPE
loadCacheModel in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadCacheModel()
Load cache models from xml mapping.
loadDatabaseConnection in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::loadDatabaseConnection()
Load the database connection tag.
loadDeleteTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadDeleteTag()
Load delete statement from xml mapping.
loadFlushInterval in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadFlushInterval()
Load the flush interval
loadFlushOnCache in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadFlushOnCache()
Load the flush on cache properties.
loadGlobalProperty in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::loadGlobalProperty()
Load global replacement property.
loadInsertTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadInsertTag()
Load insert statement from xml mapping.
loadParameterMap in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadParameterMap()
Load parameter map from xml.
loadProcedureTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadProcedureTag()
Load procedure statement from xml mapping.
loadResultMap in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadResultMap()
Load the result maps.
loadSelectKeyTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadSelectKeyTag()
Load the selectKey statement from xml mapping.
loadSelectTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadSelectTag()
Load select statement from xml mapping.
loadSqlMappingFiles in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::loadSqlMappingFiles()
Load SqlMap mapping configuration.
loadStatementTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadStatementTag()
Load statement mapping from xml configuration file.
loadTypeHandler in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::loadTypeHandler()
Load the type handler configurations.
loadUpdateTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadUpdateTag()
Load update statement from xml mapping.
loadXmlDocument in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfigBuilder::loadXmlDocument()
Load document using simple xml.
LRU | in file TSqlMapCacheModel.php, class constant TSqlMapCacheTypes::LRU
top
n
nullifyDefaultValue in file TParameterMap.php, method TParameterMap::nullifyDefaultValue()
When the actual value matches the NullValue, set the current value to null.
top
p
parameterMap | in file TSqlMapStatement.php, method TSqlMapStatement::parameterMap()
PARAMETER_TOKEN_REGEXP in file TInlineParameterMapParser.php, class constant TInlineParameterMapParser::PARAMETER_TOKEN_REGEXP
Regular expression for parsing inline parameter maps.
PARAMETER_TOKEN_REGEXP | in file TSimpleDynamicParser.php, class constant TSimpleDynamicParser::PARAMETER_TOKEN_REGEXP
parse in file TSimpleDynamicParser.php, method TSimpleDynamicParser::parse()
Parse the sql text for dynamic place holders of the form $name$.
parse in file TInlineParameterMapParser.php, method TInlineParameterMapParser::parse()
Parse the sql text for inline parameters.
parseMapping in file TInlineParameterMapParser.php, method TInlineParameterMapParser::parseMapping()
Parse inline parameter with syntax as
prepareSql in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::prepareSql()
Prepare the sql text (may extend to dynamic sql).
processSqlStatement in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::processSqlStatement()
Load extended SQL statements if application. Replaces global properties in the sql text. Extracts inline parameter maps.
top
r
registerCacheTriggers in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::registerCacheTriggers()
Attach CacheModel to statement and register trigger statements for cache models
registerCacheType | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::registerCacheType()
registerTriggerStatement in file TSqlMapCacheModel.php, method TSqlMapCacheModel::registerTriggerStatement()
Register a mapped statement that will trigger a cache flush.
replaceProperties in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::replaceProperties()
Replace the place holders ${name} in text with properties the corresponding global property value.
resolveResultMapping in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::resolveResultMapping()
Resolve nest result mappings.
resolveSubMap in file TResultMap.php, method TResultMap::resolveSubMap()
Result sub-mappings using the discriminiator column.
resultMap | in file TSqlMapStatement.php, method TSqlMapStatement::resultMap()
top
s
set | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::set()
setCache | in file TSqlMapStatement.php, method TSqlMapStatement::setCache()
setCacheModel | in file TSqlMapStatement.php, method TSqlMapStatement::setCacheModel()
setClass | in file TResultMap.php, method TResultMap::setClass()
setColumn | in file TDiscriminator.php, method TDiscriminator::setColumn()
setColumn | in file TParameterProperty.php, method TParameterProperty::setColumn()
setColumn | in file TResultProperty.php, method TResultProperty::setColumn()
setColumnIndex | in file TResultProperty.php, method TResultProperty::setColumnIndex()
setColumnIndex in file TDiscriminator.php, method TDiscriminator::setColumnIndex()
The columnIndex attribute value is the index of the column in the ResultSet from which the value will be used to populate the object property.
setDbType | in file TParameterProperty.php, method TParameterProperty::setDbType()
setDiscriminator | in file TResultMap.php, method TResultMap::setDiscriminator()
setExtends | in file TSqlMapStatement.php, method TSqlMapSelectKey::setExtends()
setExtends | in file TParameterMap.php, method TParameterMap::setExtends()
setExtends | in file TSqlMapStatement.php, method TSqlMapStatement::setExtends()
setExtends | in file TResultMap.php, method TResultMap::setExtends()
setFlushInterval | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::setFlushInterval()
setGroupBy | in file TResultMap.php, method TResultMap::setGroupBy()
setID | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::setID()
setID | in file TParameterMap.php, method TParameterMap::setID()
setID | in file TResultMap.php, method TResultMap::setID()
setID | in file TSqlMapStatement.php, method TSqlMapStatement::setID()
setImplementation | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::setImplementation()
setInlineParameterMap | in file TSqlMapStatement.php, method TSqlMapStatement::setInlineParameterMap()
setLazyLoad | in file TResultProperty.php, method TResultProperty::setLazyLoad()
setListClass in file TSqlMapStatement.php, method TSqlMapStatement::setListClass()
An ArrayAccess class can be specified to handle the type of objects in the collection.
setNestedResultMap | in file TResultProperty.php, method TResultProperty::setNestedResultMap()
setNullValue in file TParameterProperty.php, method TParameterProperty::setNullValue()
The nullValue attribute is used to specify an outgoing null value replacement.
setNullValue | in file TDiscriminator.php, method TDiscriminator::setNullValue()
setNullValue | in file TResultProperty.php, method TResultProperty::setNullValue()
setObjectPropFromNode in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfigBuilder::setObjectPropFromNode()
For each attributes (excluding attribute named in $except) set the property of the $obj given by the name of the attribute with the value of the attribute.
setParameterClass in file TSqlMapStatement.php, method TSqlMapStatement::setParameterClass()
If a ParameterMap property is not specified, you may specify a ParameterClass instead and use inline parameters.
setParameterMap in file TSqlMapStatement.php, method TSqlMapStatement::setParameterMap()
A Parameter Map defines an ordered list of values that match up with the "?" placeholders of a standard, parameterized query statement.
setProperty | in file TSqlMapStatement.php, method TSqlMapSelectKey::setProperty()
setProperty | in file TResultProperty.php, method TResultProperty::setProperty()
setProperty | in file TParameterProperty.php, method TParameterProperty::setProperty()
setResultClass in file TSqlMapStatement.php, method TSqlMapStatement::setResultClass()
If a ResultMap is not specified, you may specify a
setResultMap in file TSqlMapStatement.php, method TSqlMapStatement::setResultMap()
A Result Map lets you control how data is extracted from the result of a query, and how the columns are mapped to object properties.
setResultMapping | in file TDiscriminator.php, method TSubMap::setResultMapping()
setResultMapping | in file TResultProperty.php, method TResultProperty::setResultMapping()
setSelect in file TResultProperty.php, method TResultProperty::setSelect()
The select property is used to describe a relationship between objects and to automatically load complex (i.e. user defined) property types.
setSelectKey | in file TSqlMapStatement.php, method TSqlMapInsert::setSelectKey()
setSqlText | in file TSqlMapStatement.php, method TSqlMapStatement::setSqlText()
setType | in file TParameterProperty.php, method TParameterProperty::setType()
setType | in file TResultProperty.php, method TResultProperty::setType()
setType in file TDiscriminator.php, method TDiscriminator::setType()
The type attribute is used to explicitly specify the property type of the parameter to be set. If the attribute type is not set and the framework cannot otherwise determine the type, the type is assumed from the default value of the property.
setType | in file TSqlMapStatement.php, method TSqlMapSelectKey::setType()
setTypeHandler | in file TDiscriminator.php, method TDiscriminator::setTypeHandler()
setTypeHandler | in file TResultProperty.php, method TResultProperty::setTypeHandler()
setTypeHandler | in file TParameterProperty.php, method TParameterProperty::setTypeHandler()
setValue | in file TDiscriminator.php, method TSubMap::setValue()
SIMPLE_MARK in file TSqlMapXmlConfiguration.php, class constant TSqlMapXmlMappingConfiguration::SIMPLE_MARK
Regular expressions for escaping simple/inline parameter symbols
SIMPLE_PLACEHOLDER | in file TSqlMapXmlConfiguration.php, class constant TSqlMapXmlMappingConfiguration::SIMPLE_PLACEHOLDER
top
t
TDiscriminator.php | procedural page TDiscriminator.php
TInlineParameterMapParser.php | procedural page TInlineParameterMapParser.php
TParameterMap.php | procedural page TParameterMap.php
TParameterProperty.php | procedural page TParameterProperty.php
TResultMap.php | procedural page TResultMap.php
TResultProperty.php | procedural page TResultProperty.php
TSimpleDynamicParser.php | procedural page TSimpleDynamicParser.php
TSqlMapCacheModel.php | procedural page TSqlMapCacheModel.php
TSqlMapStatement.php | procedural page TSqlMapStatement.php
TSqlMapXmlConfiguration.php | procedural page TSqlMapXmlConfiguration.php
TDiscriminator in file TDiscriminator.php, class TDiscriminator
The TDiscriminator corresponds to the <discriminator> tag within a <resultMap>.
TInlineParameterMapParser in file TInlineParameterMapParser.php, class TInlineParameterMapParser
TInlineParameterMapParser class.
TParameterMap in file TParameterMap.php, class TParameterMap
TParameterMap corresponds to the <parameterMap> element.
TParameterProperty in file TParameterProperty.php, class TParameterProperty
TParameterProperty corresponds to the <property> tag and defines one object property for the <parameterMap>
TResultMap in file TResultMap.php, class TResultMap
TResultMap corresponds to <resultMap> mapping tag.
TResultProperty in file TResultProperty.php, class TResultProperty
TResultProperty corresponds a <property> tags inside a <resultMap> tag.
TSimpleDynamicParser in file TSimpleDynamicParser.php, class TSimpleDynamicParser
TSimpleDynamicParser finds place holders $name$ in the sql text and replaces it with a TSimpleDynamicParser::DYNAMIC_TOKEN.
TSqlMapCacheKey in file TSqlMapCacheModel.php, class TSqlMapCacheKey
TSqlMapCacheKey class.
TSqlMapCacheModel in file TSqlMapCacheModel.php, class TSqlMapCacheModel
TSqlMapCacheModel corresponds to the <cacheModel> sql mapping configuration tag.
TSqlMapCacheTypes in file TSqlMapCacheModel.php, class TSqlMapCacheTypes
TSqlMapCacheTypes enumerable class.
TSqlMapDelete in file TSqlMapStatement.php, class TSqlMapDelete
TSqlMapDelete class corresponds to the <delete> element.
TSqlMapInsert in file TSqlMapStatement.php, class TSqlMapInsert
TSqlMapInsert class corresponds to the <insert> element.
TSqlMapSelectKey in file TSqlMapStatement.php, class TSqlMapSelectKey
TSqlMapSelect corresponds to the <selectKey> element.
TSqlMapStatement in file TSqlMapStatement.php, class TSqlMapStatement
TSqlMapStatement class corresponds to <statement> element.
TSqlMapUpdate in file TSqlMapStatement.php, class TSqlMapUpdate
TSqlMapUpdate class corresponds to <update> element.
TSqlMapXmlConfigBuilder in file TSqlMapXmlConfiguration.php, class TSqlMapXmlConfigBuilder
TSqlMapXmlConfig class file.
TSqlMapXmlConfiguration in file TSqlMapXmlConfiguration.php, class TSqlMapXmlConfiguration
TSqlMapXmlConfig class.
TSqlMapXmlMappingConfiguration in file TSqlMapXmlConfiguration.php, class TSqlMapXmlMappingConfiguration
Loads the statements, result maps, parameters maps from xml configuration.
TSubMap in file TDiscriminator.php, class TSubMap
TSubMap class defines a submapping value and the corresponding <resultMap>


Class Trees for Package System.Data.SqlMap.Configuration

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TDiscriminator.php

File: /Data/SqlMap/Configuration/TDiscriminator.php

Remarks

TDiscriminator and TSubMap classes file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TDiscriminator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TDiscriminator
The TDiscriminator corresponds to the <discriminator> tag within a <resultMap>.
TSubMap
TSubMap class defines a submapping value and the corresponding <resultMap>

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:14 +0200 by phpDocumentor 1.4.3


Docs for page TInlineParameterMapParser.php

File: /Data/SqlMap/Configuration/TInlineParameterMapParser.php

Remarks

TInlineParameterMapParser class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TInlineParameterMapParser.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TInlineParameterMapParser
TInlineParameterMapParser class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:37 +0200 by phpDocumentor 1.4.3


Docs for page TParameterMap.php

File: /Data/SqlMap/Configuration/TParameterMap.php

Remarks

TParameterMap class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TParameterMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TParameterMap
TParameterMap corresponds to the <parameterMap> element.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:01 +0200 by phpDocumentor 1.4.3


Docs for page TParameterProperty.php

File: /Data/SqlMap/Configuration/TParameterProperty.php

Remarks

TParameterPropert class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TParameterProperty.php 3004 2011-06-26 09:56:56Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TParameterProperty
TParameterProperty corresponds to the <property> tag and defines one object property for the <parameterMap>

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:01 +0200 by phpDocumentor 1.4.3


Docs for page TResultMap.php

File: /Data/SqlMap/Configuration/TResultMap.php

Remarks

TResultMap class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TResultMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TResultMap
TResultMap corresponds to <resultMap> mapping tag.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs for page TResultProperty.php

File: /Data/SqlMap/Configuration/TResultProperty.php

Remarks

TResultProperty class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TResultProperty.php 3004 2011-06-26 09:56:56Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TResultProperty
TResultProperty corresponds a <property> tags inside a <resultMap> tag.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs for page TSimpleDynamicParser.php

File: /Data/SqlMap/Configuration/TSimpleDynamicParser.php

Remarks

TSimpleDynamicParser class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSimpleDynamicParser.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSimpleDynamicParser
TSimpleDynamicParser finds place holders $name$ in the sql text and replaces it with a TSimpleDynamicParser::DYNAMIC_TOKEN.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:22 +0200 by phpDocumentor 1.4.3


Docs for page TSqlMapCacheModel.php

File: /Data/SqlMap/Configuration/TSqlMapCacheModel.php

Remarks

TSqlMapCacheModel, TSqlMapCacheTypes and TSqlMapCacheKey classes file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapCacheModel.php 3152 2012-05-29 10:01:36Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqlMapCacheModel
TSqlMapCacheModel corresponds to the <cacheModel> sql mapping configuration tag.
TSqlMapCacheTypes
TSqlMapCacheTypes enumerable class.
TSqlMapCacheKey
TSqlMapCacheKey class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs for page TSqlMapStatement.php

File: /Data/SqlMap/Configuration/TSqlMapStatement.php

Remarks

TSqlMapStatement, TSqlMapInsert, TSqlMapUpdate, TSqlMapDelete, TSqlMapSelect and TSqlMapSelectKey classes file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqlMapStatement
TSqlMapStatement class corresponds to <statement> element.
TSqlMapInsert
TSqlMapInsert class corresponds to the <insert> element.
TSqlMapUpdate
TSqlMapUpdate class corresponds to <update> element.
TSqlMapDelete
TSqlMapDelete class corresponds to the <delete> element.
TSqlMapSelectKey
TSqlMapSelect corresponds to the <selectKey> element.
TSqlMapSelect
TSqlMapSelect class file.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:26 +0200 by phpDocumentor 1.4.3


Docs for page TSqlMapXmlConfiguration.php

File: /Data/SqlMap/Configuration/TSqlMapXmlConfiguration.php

Remarks

TSqlMapXmlConfigBuilder, TSqlMapXmlConfiguration, TSqlMapXmlMappingConfiguration classes file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapXmlConfiguration.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqlMapXmlConfigBuilder
TSqlMapXmlConfig class file.
TSqlMapXmlConfiguration
TSqlMapXmlConfig class.
TSqlMapXmlMappingConfiguration
Loads the statements, result maps, parameters maps from xml configuration.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:28 +0200 by phpDocumentor 1.4.3


Docs For Class TDiscriminator

Class TDiscriminator

[line 28]
TComponent
   |
   --TDiscriminator
Location: /Data/SqlMap/Configuration/TDiscriminator.php

Remarks

The TDiscriminator corresponds to the <discriminator> tag within a <resultMap>.

TDiscriminator allows inheritance logic in SqlMap result mappings. SqlMap compares the data found in the discriminator column to the different <submap> values using the column value's string equivalence. When the string values matches a particular <submap>, SqlMap will use the <resultMap> defined by resultMapping property for loading the object data.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TDiscriminator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TDiscriminator::addSubMap

    addSubMap( TSubMap $subMap );

    Parameters

    $subMap

    add new sub mapping.

    access

    public

    [ Top ]

    TDiscriminator::getColumn

    getColumn( );

    Returns

    the name of the column in the result set from which the value will be used to populate the property.

    access

    public

    [ Top ]

    TDiscriminator::getColumnIndex

    getColumnIndex( );

    Returns

    index of the column in the ResultSet

    access

    public

    [ Top ]

    TDiscriminator::getMapping

    getMapping( );

    Returns

    result property for the discriminator column.

    access

    public

    [ Top ]

    TDiscriminator::getNullValue

    getNullValue( );

    Returns

    outgoing null value replacement.

    access

    public

    [ Top ]

    TDiscriminator::getSubMap

    getSubMap( string $value );

    Parameters

    $value

    database value

    Returns

    result mapping.

    access

    public

    [ Top ]

    TDiscriminator::getType

    getType( string 0 );

    Parameters

    0

    property type of the parameter to be set.

    access

    public

    [ Top ]

    TDiscriminator::getTypeHandler

    getTypeHandler( );

    Returns

    custom type handler class name (may use namespace).

    access

    public

    [ Top ]

    TDiscriminator::initialize

    initialize( TSqlMapManager $manager );

    Parameters

    $manager

    sql map manager instance.

    Remarks

    Set the result maps for particular sub-mapping values.

    access

    public

    [ Top ]

    TDiscriminator::initMapping

    initMapping( TResultMap $resultMap );

    Parameters

    $resultMap

    result map holding the discriminator.

    Remarks

    Copies the discriminator properties to a new TResultProperty.

    access

    public

    [ Top ]

    TDiscriminator::setColumn

    setColumn( string $value );

    Parameters

    $value

    the name of the column in the result set from which the value will be used to populate the property.

    access

    public

    [ Top ]

    TDiscriminator::setColumnIndex

    setColumnIndex( int $value );

    Parameters

    $value

    index of the column in the ResultSet

    Remarks

    The columnIndex attribute value is the index of the column in the ResultSet from which the value will be used to populate the object property.

    access

    public

    [ Top ]

    TDiscriminator::setNullValue

    setNullValue( mixed $value );

    Parameters

    $value

    outgoing null value replacement.

    access

    public

    [ Top ]

    TDiscriminator::setType

    setType( $value );

    Parameters

    $value

    Returns

    property type of the parameter to be set.

    Remarks

    The type attribute is used to explicitly specify the property type of the parameter to be set. If the attribute type is not set and the framework cannot otherwise determine the type, the type is assumed from the default value of the property.

    access

    public

    [ Top ]

    TDiscriminator::setTypeHandler

    setTypeHandler( string $value );

    Parameters

    $value

    custom type handler class name (may use namespace).

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:14 +0200 by phpDocumentor 1.4.3


Docs For Class TSubMap

Class TSubMap

[line 194]
TComponent
   |
   --TSubMap
Location: /Data/SqlMap/Configuration/TDiscriminator.php

Remarks

TSubMap class defines a submapping value and the corresponding <resultMap>

The Value property is used for comparison with the discriminator column value. When the Value matches that of the discriminator column value, the corresponding ResultMapping is used inplace of the current result map.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TDiscriminator.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSubMap::getResultMapping

    getResultMapping( );

    Returns

    ID of a result map

    Remarks

    The result map to use when the Value matches the discriminator column value.

    access

    public

    [ Top ]

    TSubMap::getValue

    getValue( );

    Returns

    value for comparison with discriminator column value.

    access

    public

    [ Top ]

    TSubMap::setResultMapping

    setResultMapping( string $value );

    Parameters

    $value

    ID of a result map

    access

    public

    [ Top ]

    TSubMap::setValue

    setValue( string $value );

    Parameters

    $value

    value for comparison with discriminator column value.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:14 +0200 by phpDocumentor 1.4.3


Docs For Class TInlineParameterMapParser

Class TInlineParameterMapParser

[line 25]

Location: /Data/SqlMap/Configuration/TInlineParameterMapParser.php

Remarks

TInlineParameterMapParser class.

The inline parameter map syntax lets you embed the property name,  the property type, the column type, and a null value replacement into a  parametrized SQL statement.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TInlineParameterMapParser.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

  • PARAMETER_TOKEN_REGEXP =  '/#([^#]+)#/'

        Regular expression for parsing inline parameter maps.

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TInlineParameterMapParser::parse

parse(
string
$sqlText, array
$scope );

    Parameters

    $sqlText

    sql text

    $scope

    file and node details for exception message.

    Returns

    'sql' and 'parameters' name value pairs.

    Remarks

    Parse the sql text for inline parameters.

    access

    public

    [ Top ]

    TInlineParameterMapParser::parseMapping

parseMapping(
string
$token, array
$scope );

    Parameters

    $token

    parameter token

    $scope

    file and node details for exception message.

    Remarks

    Parse inline parameter with syntax as

    #propertyName,type=string,dbype=Varchar,nullValue=N/A,handler=string#

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

  • PARAMETER_TOKEN_REGEXP =  '/#([^#]+)#/' [line 30]
    •

    Remarks

    Regular expression for parsing inline parameter maps.

        Documentation generated on Mon, 25 Jun 2012 14:44:37 +0200 by phpDocumentor 1.4.3


Docs For Class TParameterMap

Class TParameterMap

[line 33]
TComponent
   |
   --TParameterMap
Location: /Data/SqlMap/Configuration/TParameterMap.php

Remarks

TParameterMap corresponds to the <parameterMap> element.

TParameterMap holds one or more parameter child elements that map object properties to placeholders in a SQL statement.

A TParameterMap defines an ordered list of values that match up with the placeholders of a parameterized query statement. While the attributes specified by the map still need to be in the correct order, each parameter is named. You can populate the underlying class in any order, and the TParameterMap ensures each value is passed in the correct order.

Parameter Maps can be provided as an external element and inline. The <parameterMap> element accepts two attributes: id (required) and extends (optional).

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TParameterMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TParameterMap::__construct

    __construct( );

    Remarks

    Initialize the properties and property map collections.

    access

    public

    [ Top ]

    TParameterMap::addProperty

    addProperty( TParameterProperty $property );

    Parameters

    $property

    new parameter property

    access

    public

    [ Top ]

    TParameterMap::createTypeHandler

    createTypeHandler( TParameterProperty $property, TSqlMapTypeHandlerRegistry $registry );

    Parameters

    $property

    parameter property

    $registry

    type handler registry

    Returns

    type handler.

    Remarks

    Create type handler from Type or TypeHandler.

    access

    protected

    [ Top ]

    TParameterMap::getExtends

    getExtends( );

    Returns

    name of another <parameterMap> upon which to base this TParameterMap.

    access

    public

    [ Top ]

    TParameterMap::getID

    getID( );

    Returns

    a unique identifier for the <parameterMap>.

    access

    public

    [ Top ]

    TParameterMap::getObjectValue

    getObjectValue( mixed $object, TParameterProperty $property );

    Parameters

    $object

    object to obtain the property from.

    $property

    parameter property.

    Returns

    property value.

    throws

    TSqlMapException if property access is invalid.

    access

    protected

    [ Top ]

    TParameterMap::getProperties

    getProperties( );

    Returns

    list of properties for the parameter map.

    access

    public

    [ Top ]

    TParameterMap::getProperty

    getProperty( string $index );

    Parameters

    $index

    name of a parameter property.

    Returns

    parameter property.

    throws

    TSqlMapException if index is not string nor integer.

    access

    public

    [ Top ]

    TParameterMap::getPropertyNames

    getPropertyNames( );

    Returns

    list of property names.

    access

    public

    [ Top ]

    TParameterMap::getPropertyValue

    getPropertyValue( TSqlMapTypeHandlerRegistry $registry, TParameterProperty $property, mixed $parameterValue );

    Parameters

    $registry

    type handler registry.

    $property

    parameter proproperty.

    $parameterValue

    parameter object to get the value from.

    Remarks

    Get the value of a property from the the parameter object.

    access

    public

    [ Top ]

    TParameterMap::insertProperty

    insertProperty( int $index, TParameterProperty $property );

    Parameters

    $index

    parameter property index

    $property

    new parameter property.

    access

    public

    [ Top ]

    TParameterMap::nullifyDefaultValue

    nullifyDefaultValue( TParameterProperty $property, mixed $value );

    Parameters

    $property

    parameter property.

    $value

    current property value

    Returns

    null if NullValue matches currrent value.

    Remarks

    When the actual value matches the NullValue, set the current value to null.

    access

    protected

    [ Top ]

    TParameterMap::setExtends

    setExtends( string $value );

    Parameters

    $value

    name of another <parameterMap> upon which to base this TParameterMap.

    access

    public

    [ Top ]

    TParameterMap::setID

    setID( string $value );

    Parameters

    $value

    a unique identifier for the <parameterMap>.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:01 +0200 by phpDocumentor 1.4.3


Docs For Class TParameterProperty

Class TParameterProperty

[line 32]
TComponent
   |
   --TParameterProperty
Location: /Data/SqlMap/Configuration/TParameterProperty.php

Remarks

TParameterProperty corresponds to the <property> tag and defines one object property for the <parameterMap>

The NullValue attribute can be set to any valid value (based on property type). The NullValue attribute is used to specify an inbound null value replacement. What this means is that when the value is detected in the object property, a NULL will be written to the database (the opposite behavior of an inbound null value replacement). This allows you to use a magic null number in your application for types that do not support null values (such as int, double, float). When these types of properties contain a matching null value (for example, say, -9999), a NULL will be written to the database instead of the value.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TParameterProperty.php 3004 2011-06-26 09:56:56Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TParameterProperty::getColumn

    getColumn( );

    Returns

    name of a parameter to be used in the SQL statement.

    access

    public

    [ Top ]

    TParameterProperty::getDbType

    getDbType( );

    Returns

    the database column type of the parameter to be set by this property.

    access

    public

    [ Top ]

    TParameterProperty::getNullValue

    getNullValue( );

    Returns

    null value replacement

    access

    public

    [ Top ]

    TParameterProperty::getProperty

    getProperty( );

    Returns

    name of a property of the parameter object.

    access

    public

    [ Top ]

    TParameterProperty::getType

    getType( );

    Returns

    type of the parameter's property

    access

    public

    [ Top ]

    TParameterProperty::getTypeHandler

    getTypeHandler( );

    Returns

    class name of a custom type handler.

    access

    public

    [ Top ]

    TParameterProperty::setColumn

    setColumn( string $value );

    Parameters

    $value

    name of a parameter to be used in the SQL statement.

    access

    public

    [ Top ]

    TParameterProperty::setDbType

    setDbType( string $value );

    Parameters

    $value

    the database column type of the parameter to be set by this property.

    access

    public

    [ Top ]

    TParameterProperty::setNullValue

    setNullValue( mixed $value );

    Parameters

    $value

    null value replacement.

    Remarks

    The nullValue attribute is used to specify an outgoing null value replacement.

    access

    public

    [ Top ]

    TParameterProperty::setProperty

    setProperty( string $value );

    Parameters

    $value

    name of a property of the parameter object.

    access

    public

    [ Top ]

    TParameterProperty::setType

    setType( string $value );

    Parameters

    $value

    type of the parameter's property

    access

    public

    [ Top ]

    TParameterProperty::setTypeHandler

    setTypeHandler( string $value );

    Parameters

    $value

    class name of a custom type handler.

    access

    public

    [ Top ]

    TParameterProperty::__sleep

    __sleep( );

    Overrides TComponent::__sleep() (Returns an array with the names of all variables of that object that should be serialized.)

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:01 +0200 by phpDocumentor 1.4.3


Docs For Class TResultMap

Class TResultMap

[line 39]
TComponent
   |
   --TResultMap
Location: /Data/SqlMap/Configuration/TResultMap.php

Remarks

TResultMap corresponds to <resultMap> mapping tag.

A TResultMap lets you control how data is extracted from the result of a query, and how the columns are mapped to object properties. A TResultMap can describe the column type, a null value replacement, and complex property mappings including Collections.

The <resultMap> can contain any number of property mappings that map object properties to the columns of a result element. The property mappings are applied, and the columns are read, in the order that they are defined. Maintaining the element order ensures consistent results between different drivers and providers.

The Class property must be a PHP class object or array instance.

The optional Extends attribute can be set to the ID of another <resultMap> upon which to base this <resultMap>. All properties of the "parent" <resultMap> will be included as part of this <resultMap>, and values from the "parent" <resultMap> are set before any values specified by this <resultMap>.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TResultMap.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TResultMap::__construct

    __construct( );

    Remarks

    Initialize the columns collection.

    access

    public

    [ Top ]

    TResultMap::addResultProperty

    addResultProperty( TResultProperty $property );

    Parameters

    $property

    result property.

    Remarks

    Add a TResultProperty to result mapping.

    access

    public

    [ Top ]

    TResultMap::createInstanceOfResult

    createInstanceOfResult( TSqlMapTypeHandlerRegistry $registry );

    Parameters

    $registry

    type handler registry.

    Returns

    new result object.

    Remarks

    Create a new instance of the class of this result map.

    throws

    TSqlMapException

    access

    public

    [ Top ]

    TResultMap::getClass

    getClass( );

    Returns

    result class name.

    access

    public

    [ Top ]

    TResultMap::getColumns

    getColumns( );

    Returns

    result columns.

    access

    public

    [ Top ]

    TResultMap::getDiscriminator

    getDiscriminator( );

    Returns

    result class discriminator.

    access

    public

    [ Top ]

    TResultMap::getExtends

    getExtends( );

    Returns

    result map extends another result map.

    access

    public

    [ Top ]

    TResultMap::getGroupBy

    getGroupBy( );

    Returns

    result map groups by.

    access

    public

    [ Top ]

    TResultMap::getID

    getID( );

    Returns

    a unique identifier for the <resultMap>.

    access

    public

    [ Top ]

    TResultMap::resolveSubMap

    resolveSubMap( TSqlMapTypeHandlerRegistry $registry, array $row );

    Parameters

    $registry

    type handler registry

    $row

    row data.

    Returns

    result sub-map.

    Remarks

    Result sub-mappings using the discriminiator column.

    access

    public

    [ Top ]

    TResultMap::setClass

    setClass( string $value );

    Parameters

    $value

    result class name.

    access

    public

    [ Top ]

    TResultMap::setDiscriminator

    setDiscriminator( TDiscriminator $value );

    Parameters

    $value

    result class discriminator.

    access

    public

    [ Top ]

    TResultMap::setExtends

    setExtends( string $value );

    Parameters

    $value

    result map extends another result map.

    access

    public

    [ Top ]

    TResultMap::setGroupBy

    setGroupBy( string $value );

    Parameters

    $value

    result map group by

    access

    public

    [ Top ]

    TResultMap::setID

    setID( string $value );

    Parameters

    $value

    a unique identifier for the <resultMap>.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs For Class TResultProperty

Class TResultProperty

[line 36]
TComponent
   |
   --TResultProperty
Location: /Data/SqlMap/Configuration/TResultProperty.php

Remarks

TResultProperty corresponds a <property> tags inside a <resultMap> tag.

The NullValue attribute can be set to any valid value (based on property type). The NullValue attribute is used to specify an outgoing null value replacement. What this means is that when a null value is detected in the result, the corresponding value of the NullValue will be used instead.

The Select property is used to describe a relationship between objects and to automatically load complex (i.e. user defined) property types. The value of the Select property must be the name of another mapped statement. The value of the database Column that is defined in the same property element as this statement attribute will be passed to the related mapped statement as the parameter. The LazyLoad attribute can be specified with the Select .

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TResultProperty.php 3004 2011-06-26 09:56:56Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

  • ARRAY_TYPE =  1
  • LIST_TYPE =  0

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TResultProperty::__construct

    __construct( [TResultMap $resultMap = null] );

    Parameters

    $resultMap

    containing result map.

    Remarks

    Gets the containing result map ID.

    access

    public

    [ Top ]

    TResultProperty::createTypeHandler

    createTypeHandler( TSqlMapTypeHandlerRegistry $registry );

    Parameters

    $registry

    type handler registry

    Returns

    type handler.

    Remarks

    Create type handler from Type or TypeHandler.

    access

    protected

    [ Top ]

    TResultProperty::getColumn

    getColumn( );

    Returns

    name of the column in the result set from which the value will be used to populate the property.

    access

    public

    [ Top ]

    TResultProperty::getColumnIndex

    getColumnIndex( );

    Returns

    index of the column in the ResultSet from which the value will be used to populate the object property

    access

    public

    [ Top ]

    TResultProperty::getLazyLoad

    getLazyLoad( );

    Returns

    indicate whether or not the select statement's results should be lazy loaded

    access

    public

    [ Top ]

    TResultProperty::getNestedResultMap

    getNestedResultMap( );

    Returns

    nested result map.

    access

    public

    [ Top ]

    TResultProperty::getNullValue

    getNullValue( );

    Returns

    null value replacement.

    access

    public

    [ Top ]

    TResultProperty::getProperty

    getProperty( );

    Returns

    name of a property of the result object that will be set to.

    access

    public

    [ Top ]

    TResultProperty::getPropertyValue

    getPropertyValue( TSqlMapTypeHandlerRegistry $registry, array $row );

    Parameters

    $registry

    type handler registry

    $row

    result row

    Returns

    property value.

    Remarks

    Gets the value for the current property, converts to applicable type if necessary.

    access

    public

    [ Top ]

    TResultProperty::getPropertyValueType

    getPropertyValueType( );

    Returns

    TResultProperty::LIST_TYPE or TResultProperty::ARRAY_TYPE

    Remarks

    Determines if the type is an instance of ArrayAccess, TList or an array.

    access

    protected

    [ Top ]

    TResultProperty::getResultMapping

    getResultMapping( );

    Returns

    ID of another <resultMap> used to fill the property.

    access

    public

    [ Top ]

    TResultProperty::getSelect

    getSelect( );

    Returns

    name of another mapped statement

    access

    public

    [ Top ]

    TResultProperty::getType

    getType( );

    Returns

    property type of the object property to be set.

    access

    public

    [ Top ]

    TResultProperty::getTypedValue

    getTypedValue( TSqlMapTypeHandlerRegistry $registry, mixed $value );

    Parameters

    $registry

    type handler registry

    $value

    raw property value

    Returns

    property value casted to specific type.

    access

    protected

    [ Top ]

    TResultProperty::getTypeHandler

    getTypeHandler( );

    Returns

    custom type handler class name (may use namespace).

    access

    public

    [ Top ]

    TResultProperty::instanceOfArrayType

    instanceOfArrayType( object result $target );

    Parameters

    $target

    object

    Returns

    true if the result object is an instance of ArrayAccess or is an array.

    Remarks

    Returns true if the result property Type is of ArrayAccess

    or that the actual result object is an array or implements ArrayAccess

    access

    public

    [ Top ]

    TResultProperty::instanceOfListType

    instanceOfListType( object result $target );

    Parameters

    $target

    object

    Returns

    true if the result object is an instance of TList

    Remarks

    Returns true if the result property Type is of TList type or that the actual result object is an instance of TList.

    access

    public

    [ Top ]

    TResultProperty::setColumn

    setColumn( string $value );

    Parameters

    $value

    name of the column in the result set from which the value will be used to populate the property.

    access

    public

    [ Top ]

    TResultProperty::setColumnIndex

    setColumnIndex( int $value );

    Parameters

    $value

    index of the column in the ResultSet from which the value will be used to populate the object property

    access

    public

    [ Top ]

    TResultProperty::setLazyLoad

    setLazyLoad( boolean $value );

    Parameters

    $value

    indicate whether or not the select statement's results should be lazy loaded

    access

    public

    [ Top ]

    TResultProperty::setNestedResultMap

    setNestedResultMap( TResult $value );

    Parameters

    $value

    nested result map.

    access

    public

    [ Top ]

    TResultProperty::setNullValue

    setNullValue( mixed $value );

    Parameters

    $value

    null value replacement.

    access

    public

    [ Top ]

    TResultProperty::setProperty

    setProperty( string $value );

    Parameters

    $value

    name of a property of the result object that will be set to.

    access

    public

    [ Top ]

    TResultProperty::setResultMapping

    setResultMapping( string $value );

    Parameters

    $value

    ID of another <resultMap> used to fill the property.

    access

    public

    [ Top ]

    TResultProperty::setSelect

    setSelect( string $value );

    Parameters

    $value

    name of another mapped statement.

    Remarks

    The select property is used to describe a relationship between objects and to automatically load complex (i.e. user defined) property types.

    access

    public

    [ Top ]

    TResultProperty::setType

    setType( string $value );

    Parameters

    $value

    property type of the object property to be set.

    access

    public

    [ Top ]

    TResultProperty::setTypeHandler

    setTypeHandler( string $value );

    Parameters

    $value

    custom type handler class name (may use namespace).

    access

    public

    [ Top ]

    TResultProperty::__sleep

    __sleep( );

    Overrides TComponent::__sleep() (Returns an array with the names of all variables of that object that should be serialized.)

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • ARRAY_TYPE =  1 [line 52]

  • LIST_TYPE =  0 [line 51]

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs For Class TSimpleDynamicParser

Class TSimpleDynamicParser

[line 22]

Location: /Data/SqlMap/Configuration/TSimpleDynamicParser.php

Remarks

TSimpleDynamicParser finds place holders $name$ in the sql text and replaces  it with a TSimpleDynamicParser::DYNAMIC_TOKEN.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSimpleDynamicParser.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

  • DYNAMIC_TOKEN =  '`!`'

  • PARAMETER_TOKEN_REGEXP =  '/\$([^\$]+)\$/'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TSimpleDynamicParser::parse

parse(
string
$sqlText );

    Parameters

    $sqlText

    Sql text.

    Returns

    name value pairs 'sql' and 'parameters'.

    Remarks

    Parse the sql text for dynamic place holders of the form $name$.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • DYNAMIC_TOKEN =  '`!`' [line 25]
    •

  • PARAMETER_TOKEN_REGEXP =  '/\$([^\$]+)\$/' [line 24]
    •

        Documentation generated on Mon, 25 Jun 2012 14:45:22 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapCacheKey

Class TSqlMapCacheKey

[line 217]

Location: /Data/SqlMap/Configuration/TSqlMapCacheModel.php

Remarks

TSqlMapCacheKey class.

Provides a hash of the object to be cached.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapCacheModel.php 3152 2012-05-29 10:01:36Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TSqlMapCacheKey::__construct

__construct(
mixed
$object );

    Parameters

    $object

    object to be cached.

    access

    public

    [ Top ]

    TSqlMapCacheKey::generateKey

generateKey(
string
$string );

    Parameters

    $string

    serialized object

    Returns

    crc32 hash of the serialized object.

    access

    protected

    [ Top ]

    TSqlMapCacheKey::getHash

getHash(
 );

    Returns

    object hash.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapCacheModel

Class TSqlMapCacheModel

[line 35]
TComponent
   |
   --TSqlMapCacheModel
Location: /Data/SqlMap/Configuration/TSqlMapCacheModel.php

Remarks

TSqlMapCacheModel corresponds to the <cacheModel> sql mapping configuration tag.

The results from a query Mapped Statement can be cached simply by specifying the CacheModel property in <statement> tag. A cache model is a configured cache that is defined within the sql map configuration file. Cache models are configured using the <cacheModel> element.

The cache model uses a pluggable framework for supporting different types of caches. The choice of cache is specified by the Implementation property. The class name specified must be one of TSqlMapCacheTypes.

The cache implementations, LRU and FIFO cache below do not persist across requests. That is, once the request is complete, all cache data is lost. These caches are useful queries that results in the same repeated data during the current request.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapCacheModel.php 3152 2012-05-29 10:01:36Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static void registerCacheType()
  • void registerCacheType()

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    static TSqlMapCacheModel::registerCacheType

    static registerCacheType( $type, $className );

    Parameters

    $type

    $className

    access

    public

    [ Top ]

    TSqlMapCacheModel::flush

    flush( );

    Remarks

    Clears the cache.

    access

    public

    [ Top ]

    TSqlMapCacheModel::get

    get( TSqlMapCacheKey|string $key );

    Parameters

    $key

    cache key

    Returns

    cached value.

    access

    public

    [ Top ]

    TSqlMapCacheModel::getFlushInterval

    getFlushInterval( );

    Returns

    cache duration.

    access

    public

    [ Top ]

    TSqlMapCacheModel::getHitRatio

    getHitRatio( );

    Returns

    cache hit ratio.

    access

    public

    [ Top ]

    TSqlMapCacheModel::getID

    getID( );

    Returns

    unique cache model identifier.

    access

    public

    [ Top ]

    TSqlMapCacheModel::getImplementation

    getImplementation( );

    Returns

    cache implements of TSqlMapCacheTypes, either 'Basic', 'LRU' or 'FIFO'.

    access

    public

    [ Top ]

    TSqlMapCacheModel::getImplementationClass

    getImplementationClass( );

    Returns

    cache implementation class name.

    access

    public

    [ Top ]

    TSqlMapCacheModel::initialize

    initialize( [ISqLMapCache $cache = null] );

    Parameters

    $cache

    cache implementation instance.

    Remarks

    Initialize the cache implementation, sets the actual cache contain if supplied.

    access

    public

    [ Top ]

    TSqlMapCacheModel::registerTriggerStatement

    registerTriggerStatement( TMappedStatement $mappedStatement );

    Parameters

    $mappedStatement

    mapped statement that may flush the cache.

    Remarks

    Register a mapped statement that will trigger a cache flush.

    access

    public

    [ Top ]

    TSqlMapCacheModel::set

    set( TSqlMapCacheKey|string $key, mixed $value );

    Parameters

    $key

    cache key

    $value

    value to be cached.

    access

    public

    [ Top ]

    TSqlMapCacheModel::setFlushInterval

    setFlushInterval( integer $value );

    Parameters

    $value

    the number of seconds in which the cached value will expire. 0 means never expire.

    access

    public

    [ Top ]

    TSqlMapCacheModel::setID

    setID( string $value );

    Parameters

    $value

    unique cache model identifier.

    access

    public

    [ Top ]

    TSqlMapCacheModel::setImplementation

    setImplementation( string $value );

    Parameters

    $value

    cache implements of TSqlMapCacheTypes, either 'Basic', 'LRU' or 'FIFO'.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapCacheTypes

Class TSqlMapCacheTypes

[line 200]
TEnumerable
   |
   --TSqlMapCacheTypes
Location: /Data/SqlMap/Configuration/TSqlMapCacheModel.php

Remarks

TSqlMapCacheTypes enumerable class.

Implemented cache are 'Basic', 'FIFO' and 'LRU'.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapCacheModel.php 3152 2012-05-29 10:01:36Z ctrlaltca $

since

3.1

Class Variable Summary

Class Constant Summary

  • Basic = 'Basic'
  • FIFO = 'FIFO'
  • LRU = 'LRU'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TEnumerable

  • TEnumerable::__construct()
  • TEnumerable::current()
  • TEnumerable::key()
  • TEnumerable::next()
  • TEnumerable::rewind()
  • TEnumerable::valid()

Method Detail

Variable Detail

Class Constant Detail

  • Basic = 'Basic' [line 202]

  • FIFO = 'FIFO' [line 203]

  • LRU = 'LRU' [line 204]

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapDelete

Class TSqlMapDelete

[line 386]
TComponent
   |
   --TSqlMapStatement
      |
      --TSqlMapUpdate
         |
         --TSqlMapDelete
Location: /Data/SqlMap/Configuration/TSqlMapStatement.php

Remarks

TSqlMapDelete class corresponds to the <delete> element.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapStatement

  • TSqlMapStatement::createInstanceOf()
    Create a new instance of a given type.
  • TSqlMapStatement::createInstanceOfListClass()
  • TSqlMapStatement::createInstanceOfResultClass()
    Create a new instance of result class.
  • TSqlMapStatement::getCache()
  • TSqlMapStatement::getCacheModel()
  • TSqlMapStatement::getExtends()
  • TSqlMapStatement::getID()
  • TSqlMapStatement::getListClass()
  • TSqlMapStatement::getParameterClass()
  • TSqlMapStatement::getParameterMap()
  • TSqlMapStatement::getResultClass()
  • TSqlMapStatement::getResultMap()
  • TSqlMapStatement::getSqlText()
  • TSqlMapStatement::initialize()
  • TSqlMapStatement::parameterMap()
  • TSqlMapStatement::resultMap()
  • TSqlMapStatement::setCache()
  • TSqlMapStatement::setCacheModel()
  • TSqlMapStatement::setExtends()
  • TSqlMapStatement::setID()
  • TSqlMapStatement::setInlineParameterMap()
  • TSqlMapStatement::setListClass()
    An ArrayAccess class can be specified to handle the type of objects in the collection.
  • TSqlMapStatement::setParameterClass()
    If a ParameterMap property is not specified, you may specify a ParameterClass instead and use inline parameters.
  • TSqlMapStatement::setParameterMap()
    A Parameter Map defines an ordered list of values that match up with the "?" placeholders of a standard, parameterized query statement.
  • TSqlMapStatement::setResultClass()
    If a ResultMap is not specified, you may specify a
  • TSqlMapStatement::setResultMap()
    A Result Map lets you control how data is extracted from the result of a query, and how the columns are mapped to object properties.
  • TSqlMapStatement::setSqlText()
  • TSqlMapStatement::__sleep()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:26 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapInsert

Class TSqlMapInsert

[line 345]
TComponent
   |
   --TSqlMapStatement
      |
      --TSqlMapInsert
Location: /Data/SqlMap/Configuration/TSqlMapStatement.php

Remarks

TSqlMapInsert class corresponds to the <insert> element.

The <insert> element allows <selectKey> child elements that can be used to generate a key to be used for the insert command.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapStatement

  • TSqlMapStatement::createInstanceOf()
    Create a new instance of a given type.
  • TSqlMapStatement::createInstanceOfListClass()
  • TSqlMapStatement::createInstanceOfResultClass()
    Create a new instance of result class.
  • TSqlMapStatement::getCache()
  • TSqlMapStatement::getCacheModel()
  • TSqlMapStatement::getExtends()
  • TSqlMapStatement::getID()
  • TSqlMapStatement::getListClass()
  • TSqlMapStatement::getParameterClass()
  • TSqlMapStatement::getParameterMap()
  • TSqlMapStatement::getResultClass()
  • TSqlMapStatement::getResultMap()
  • TSqlMapStatement::getSqlText()
  • TSqlMapStatement::initialize()
  • TSqlMapStatement::parameterMap()
  • TSqlMapStatement::resultMap()
  • TSqlMapStatement::setCache()
  • TSqlMapStatement::setCacheModel()
  • TSqlMapStatement::setExtends()
  • TSqlMapStatement::setID()
  • TSqlMapStatement::setInlineParameterMap()
  • TSqlMapStatement::setListClass()
    An ArrayAccess class can be specified to handle the type of objects in the collection.
  • TSqlMapStatement::setParameterClass()
    If a ParameterMap property is not specified, you may specify a ParameterClass instead and use inline parameters.
  • TSqlMapStatement::setParameterMap()
    A Parameter Map defines an ordered list of values that match up with the "?" placeholders of a standard, parameterized query statement.
  • TSqlMapStatement::setResultClass()
    If a ResultMap is not specified, you may specify a
  • TSqlMapStatement::setResultMap()
    A Result Map lets you control how data is extracted from the result of a query, and how the columns are mapped to object properties.
  • TSqlMapStatement::setSqlText()
  • TSqlMapStatement::__sleep()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqlMapInsert::getSelectKey

    getSelectKey( );

    Returns

    select key element.

    access

    public

    [ Top ]

    TSqlMapInsert::setSelectKey

    setSelectKey( TSqlMapSelectKey $value );

    Parameters

    $value

    select key.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:27 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapSelectKey

Class TSqlMapSelectKey

[line 398]
TComponent
   |
   --TSqlMapStatement
      |
      --TSqlMapSelectKey
Location: /Data/SqlMap/Configuration/TSqlMapStatement.php

Remarks

TSqlMapSelect corresponds to the <selectKey> element.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapStatement

  • TSqlMapStatement::createInstanceOf()
    Create a new instance of a given type.
  • TSqlMapStatement::createInstanceOfListClass()
  • TSqlMapStatement::createInstanceOfResultClass()
    Create a new instance of result class.
  • TSqlMapStatement::getCache()
  • TSqlMapStatement::getCacheModel()
  • TSqlMapStatement::getExtends()
  • TSqlMapStatement::getID()
  • TSqlMapStatement::getListClass()
  • TSqlMapStatement::getParameterClass()
  • TSqlMapStatement::getParameterMap()
  • TSqlMapStatement::getResultClass()
  • TSqlMapStatement::getResultMap()
  • TSqlMapStatement::getSqlText()
  • TSqlMapStatement::initialize()
  • TSqlMapStatement::parameterMap()
  • TSqlMapStatement::resultMap()
  • TSqlMapStatement::setCache()
  • TSqlMapStatement::setCacheModel()
  • TSqlMapStatement::setExtends()
  • TSqlMapStatement::setID()
  • TSqlMapStatement::setInlineParameterMap()
  • TSqlMapStatement::setListClass()
    An ArrayAccess class can be specified to handle the type of objects in the collection.
  • TSqlMapStatement::setParameterClass()
    If a ParameterMap property is not specified, you may specify a ParameterClass instead and use inline parameters.
  • TSqlMapStatement::setParameterMap()
    A Parameter Map defines an ordered list of values that match up with the "?" placeholders of a standard, parameterized query statement.
  • TSqlMapStatement::setResultClass()
    If a ResultMap is not specified, you may specify a
  • TSqlMapStatement::setResultMap()
    A Result Map lets you control how data is extracted from the result of a query, and how the columns are mapped to object properties.
  • TSqlMapStatement::setSqlText()
  • TSqlMapStatement::__sleep()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqlMapSelectKey::getIsAfter

    getIsAfter( );

    Returns

    true if key is generated after insert command, false otherwise.

    access

    public

    [ Top ]

    TSqlMapSelectKey::getProperty

    getProperty( );

    Returns

    property name for the generated key.

    access

    public

    [ Top ]

    TSqlMapSelectKey::getType

    getType( );

    Returns

    select generated key type, 'post' or 'pre'.

    access

    public

    [ Top ]

    TSqlMapSelectKey::setExtends

    setExtends( $value );

    Overrides TSqlMapStatement::setExtends() (parent method not documented)

    Parameters

    $value

    throws

    TSqlMapConfigurationException extends is unsupported.

    access

    public

    [ Top ]

    TSqlMapSelectKey::setProperty

    setProperty( string $value );

    Parameters

    $value

    property name for the generated key.

    access

    public

    [ Top ]

    TSqlMapSelectKey::setType

    setType( string $value );

    Parameters

    $value

    select generated key type, 'post' or 'pre'.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:27 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapStatement

Class TSqlMapStatement

[line 31]
TComponent
   |
   --TSqlMapStatement
Classes extended from TSqlMapStatement:
TSqlMapSelect
TSqlMapSelect class file.
TSqlMapInsert
TSqlMapInsert class corresponds to the <insert> element.
TSqlMapUpdate
TSqlMapUpdate class corresponds to <update> element.
TSqlMapSelectKey
TSqlMapSelect corresponds to the <selectKey> element.

Location: /Data/SqlMap/Configuration/TSqlMapStatement.php

Remarks

TSqlMapStatement class corresponds to <statement> element.

Mapped Statements can hold any SQL statement and can use Parameter Maps and Result Maps for input and output.

The <statement> element is a general "catch all" element that can be used for any type of SQL statement. Generally it is a good idea to use one of the more specific statement-type elements. The more specific elements provided better error-checking and even more functionality. (For example, the insert statement can return a database-generated key.)

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqlMapStatement::createInstanceOf

    createInstanceOf( TSqlMapTypeHandlerRegistry $registry, string $type, [array $row = null] );

    Parameters

    $registry

    type handler registry

    $type

    result class name.

    $row

    result data.

    Returns

    result object.

    Remarks

    Create a new instance of a given type.

    access

    protected

    [ Top ]

    TSqlMapStatement::createInstanceOfListClass

    createInstanceOfListClass( TSqlMapTypeHandlerRegistry $registry );

    Parameters

    $registry

    type handler registry

    Returns

    new instance of list class.

    access

    public

    [ Top ]

    TSqlMapStatement::createInstanceOfResultClass

    createInstanceOfResultClass( TSqlMapTypeHandlerRegistry $registry, array $row );

    Parameters

    $registry

    type handler registry

    $row

    result data.

    Returns

    result object.

    Remarks

    Create a new instance of result class.

    access

    public

    [ Top ]

    TSqlMapStatement::getCache

    getCache( );

    Returns

    cache implementation instance for this statement.

    access

    public

    [ Top ]

    TSqlMapStatement::getCacheModel

    getCacheModel( );

    Returns

    cache mode name.

    access

    public

    [ Top ]

    TSqlMapStatement::getExtends

    getExtends( );

    Returns

    another statement element name.

    access

    public

    [ Top ]

    TSqlMapStatement::getID

    getID( );

    Returns

    name for this statement, unique to each sql map manager.

    access

    public

    [ Top ]

    TSqlMapStatement::getListClass

    getListClass( );

    Returns

    name of a PHP class that implements ArrayAccess.

    access

    public

    [ Top ]

    TSqlMapStatement::getParameterClass

    getParameterClass( );

    Returns

    parameter class name.

    access

    public

    [ Top ]

    TSqlMapStatement::getParameterMap

    getParameterMap( );

    Returns

    name of a parameter map.

    access

    public

    [ Top ]

    TSqlMapStatement::getResultClass

    getResultClass( );

    Returns

    result class name.

    access

    public

    [ Top ]

    TSqlMapStatement::getResultMap

    getResultMap( );

    Returns

    result map name.

    access

    public

    [ Top ]

    TSqlMapStatement::getSqlText

    getSqlText( );

    Returns

    sql text container.

    access

    public

    [ Top ]

    TSqlMapStatement::initialize

    initialize( TSqlMapManager $manager );

    Parameters

    $manager

    initialize the statement, sets the result and parameter maps.

    access

    public

    [ Top ]

    TSqlMapStatement::parameterMap

    parameterMap( );

    Returns

    the parameter map corresponding to the ParameterMap property.

    access

    public

    [ Top ]

    TSqlMapStatement::resultMap

    resultMap( );

    Returns

    the result map corresponding to the ResultMap property.

    access

    public

    [ Top ]

    TSqlMapStatement::setCache

    setCache( TSqlMapCacheModel $value );

    Parameters

    $value

    cache implementation instance for this statement.

    access

    public

    [ Top ]

    TSqlMapStatement::setCacheModel

    setCacheModel( string $value );

    Parameters

    $value

    cache mode name.

    access

    public

    [ Top ]

    TSqlMapStatement::setExtends

    setExtends( string $value );

    Overridden in child classes as:

    TSqlMapSelectKey::setExtends()

    Parameters

    $value

    name of another statement element to extend.

    access

    public

    [ Top ]

    TSqlMapStatement::setID

    setID( string $value );

    Parameters

    $value

    name for this statement, which must be unique for each sql map manager.

    access

    public

    [ Top ]

    TSqlMapStatement::setInlineParameterMap

    setInlineParameterMap( TInlineParameterMap $map );

    Parameters

    $map

    parameter extracted from the sql text.

    access

    public

    [ Top ]

    TSqlMapStatement::setListClass

    setListClass( string $value );

    Parameters

    $value

    name of a PHP class that implements ArrayAccess.

    Remarks

    An ArrayAccess class can be specified to handle the type of objects in the collection.

    access

    public

    [ Top ]

    TSqlMapStatement::setParameterClass

    setParameterClass( string $value );

    Parameters

    $value

    parameter class name.

    Remarks

    If a ParameterMap property is not specified, you may specify a ParameterClass instead and use inline parameters.

    The value of the parameterClass attribute can be any existing PHP class name.

    access

    public

    [ Top ]

    TSqlMapStatement::setParameterMap

    setParameterMap( string $value );

    Parameters

    $value

    parameter map name.

    Remarks

    A Parameter Map defines an ordered list of values that match up with the "?" placeholders of a standard, parameterized query statement.

    access

    public

    [ Top ]

    TSqlMapStatement::setResultClass

    setResultClass( string $value );

    Parameters

    $value

    result class name.

    Remarks

    If a ResultMap is not specified, you may specify a

    ResultClass instead. The value of the ResultClass property can be the name of a PHP class or primitives like integer, string, or array. The class specified will be automatically mapped to the columns in the result, based on the result metadata.

    access

    public

    [ Top ]

    TSqlMapStatement::setResultMap

    setResultMap( string $value );

    Parameters

    $value

    result map name.

    Remarks

    A Result Map lets you control how data is extracted from the result of a query, and how the columns are mapped to object properties.

    access

    public

    [ Top ]

    TSqlMapStatement::setSqlText

    setSqlText( TStaticSql $value );

    Parameters

    $value

    sql text container.

    access

    public

    [ Top ]

    TSqlMapStatement::__sleep

    __sleep( );

    Overrides TComponent::__sleep() (Returns an array with the names of all variables of that object that should be serialized.)

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:27 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapUpdate

Class TSqlMapUpdate

[line 374]
TComponent
   |
   --TSqlMapStatement
      |
      --TSqlMapUpdate
Classes extended from TSqlMapUpdate:
TSqlMapDelete
TSqlMapDelete class corresponds to the <delete> element.

Location: /Data/SqlMap/Configuration/TSqlMapStatement.php

Remarks

TSqlMapUpdate class corresponds to <update> element.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapStatement.php 3112 2012-02-14 08:13:27Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapStatement

  • TSqlMapStatement::createInstanceOf()
    Create a new instance of a given type.
  • TSqlMapStatement::createInstanceOfListClass()
  • TSqlMapStatement::createInstanceOfResultClass()
    Create a new instance of result class.
  • TSqlMapStatement::getCache()
  • TSqlMapStatement::getCacheModel()
  • TSqlMapStatement::getExtends()
  • TSqlMapStatement::getID()
  • TSqlMapStatement::getListClass()
  • TSqlMapStatement::getParameterClass()
  • TSqlMapStatement::getParameterMap()
  • TSqlMapStatement::getResultClass()
  • TSqlMapStatement::getResultMap()
  • TSqlMapStatement::getSqlText()
  • TSqlMapStatement::initialize()
  • TSqlMapStatement::parameterMap()
  • TSqlMapStatement::resultMap()
  • TSqlMapStatement::setCache()
  • TSqlMapStatement::setCacheModel()
  • TSqlMapStatement::setExtends()
  • TSqlMapStatement::setID()
  • TSqlMapStatement::setInlineParameterMap()
  • TSqlMapStatement::setListClass()
    An ArrayAccess class can be specified to handle the type of objects in the collection.
  • TSqlMapStatement::setParameterClass()
    If a ParameterMap property is not specified, you may specify a ParameterClass instead and use inline parameters.
  • TSqlMapStatement::setParameterMap()
    A Parameter Map defines an ordered list of values that match up with the "?" placeholders of a standard, parameterized query statement.
  • TSqlMapStatement::setResultClass()
    If a ResultMap is not specified, you may specify a
  • TSqlMapStatement::setResultMap()
    A Result Map lets you control how data is extracted from the result of a query, and how the columns are mapped to object properties.
  • TSqlMapStatement::setSqlText()
  • TSqlMapStatement::__sleep()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:27 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapXmlConfigBuilder

Class TSqlMapXmlConfigBuilder

[line 22]

Classes extended from TSqlMapXmlConfigBuilder:

TSqlMapXmlConfiguration

TSqlMapXmlConfig class.

TSqlMapXmlMappingConfiguration

Loads the statements, result maps, parameters maps from xml configuration.

Location: /Data/SqlMap/Configuration/TSqlMapXmlConfiguration.php

Remarks

TSqlMapXmlConfig class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapXmlConfiguration.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TSqlMapXmlConfigBuilder::createObjectFromNode

createObjectFromNode(
SimpleXmlNode
$node );

    Parameters

    $node

    property node

    Returns

    new instance of class with class name given by 'class' attribute value.

    Remarks

    Create an instance of an object give by the attribute named 'class' in the  node and set the properties on the object given by attribute names and values.

    access

    protected

    [ Top ]

    TSqlMapXmlConfigBuilder::getAbsoluteFilePath

getAbsoluteFilePath(
string
$basefile, string
$resource );

    Parameters

    $basefile

    base filename

    $resource

    relative filename

    Returns

    absolute filename.

    Remarks

    Gets the filename relative to the basefile.

    access

    protected

    [ Top ]

    TSqlMapXmlConfigBuilder::getConfigFile

getConfigFile(
 );

    Overridden in child classes as:

    TSqlMapXmlConfiguration::getConfigFile()

    TSqlMapXmlMappingConfiguration::getConfigFile()

    Returns

    configuration file.

    abstract

    access

    protected

    [ Top ]

    TSqlMapXmlConfigBuilder::getElementByIdValue

getElementByIdValue(
SimpleXmlDocument
$document, string
$tag, string
$value );

    Parameters

    $document

    $tag

    tag name.

    $value

    id value.

    Returns

    node if found, null otherwise.

    Remarks

    Get element node by ID value (try for attribute name ID as case insensitive).

    access

    protected

    [ Top ]

    TSqlMapXmlConfigBuilder::loadXmlDocument

loadXmlDocument(
string
$filename, TSqlMapXmlConfiguration
$config );

    Parameters

    $filename

    filename.

    $config

    Returns

    xml document.

    Remarks

    Load document using simple xml.

    access

    protected

    [ Top ]

    TSqlMapXmlConfigBuilder::setObjectPropFromNode

setObjectPropFromNode(
Object
$obj, SimpleXmlNode
$node, [array
$except = array()] );

    Parameters

    $obj

    object instance

    $node

    property node

    $except

    exception property name

    Remarks

    For each attributes (excluding attribute named in $except) set the  property of the $obj given by the name of the attribute with the value  of the attribute.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:28 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapXmlConfiguration

Class TSqlMapXmlConfiguration

[line 135]
TSqlMapXmlConfigBuilder
   |
   --TSqlMapXmlConfiguration
Location: /Data/SqlMap/Configuration/TSqlMapXmlConfiguration.php

Remarks

TSqlMapXmlConfig class.

Configures the TSqlMapManager using xml configuration file.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapXmlConfiguration.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapXmlConfigBuilder

  • TSqlMapXmlConfigBuilder::createObjectFromNode()
    Create an instance of an object give by the attribute named 'class' in the node and set the properties on the object given by attribute names and values.
  • TSqlMapXmlConfigBuilder::getAbsoluteFilePath()
    Gets the filename relative to the basefile.
  • TSqlMapXmlConfigBuilder::getConfigFile()
  • TSqlMapXmlConfigBuilder::getElementByIdValue()
    Get element node by ID value (try for attribute name ID as case insensitive).
  • TSqlMapXmlConfigBuilder::loadXmlDocument()
    Load document using simple xml.
  • TSqlMapXmlConfigBuilder::setObjectPropFromNode()
    For each attributes (excluding attribute named in $except) set the property of the $obj given by the name of the attribute with the value of the attribute.

Method Detail

    TSqlMapXmlConfiguration::__construct

    __construct( TSqlMapManager $manager );

    Parameters

    $manager

    manager instance.

    access

    public

    [ Top ]

    TSqlMapXmlConfiguration::attachCacheModels

    attachCacheModels( );

    Remarks

    Set the cache for each statement having a cache model property.

    access

    protected

    [ Top ]

    TSqlMapXmlConfiguration::configure

    configure( [string $filename = null] );

    Parameters

    $filename

    SqlMap configuration xml file.

    Remarks

    Configure the TSqlMapManager using the given xml file.

    access

    public

    [ Top ]

    TSqlMapXmlConfiguration::getConfigFile

    getConfigFile( );

    Overrides TSqlMapXmlConfigBuilder::getConfigFile() (parent method not documented)

    access

    protected

    [ Top ]

    TSqlMapXmlConfiguration::getManager

    getManager( );

    access

    public

    [ Top ]

    TSqlMapXmlConfiguration::loadDatabaseConnection

    loadDatabaseConnection( SimpleXmlElement $node );

    Parameters

    $node

    connection node.

    Remarks

    Load the database connection tag.

    access

    protected

    [ Top ]

    TSqlMapXmlConfiguration::loadGlobalProperty

    loadGlobalProperty( SimpleXmlElement $node );

    Parameters

    $node

    property node.

    Remarks

    Load global replacement property.

    access

    protected

    [ Top ]

    TSqlMapXmlConfiguration::loadSqlMappingFiles

    loadSqlMappingFiles( unknown_type $node );

    Parameters

    $node

    Remarks

    Load SqlMap mapping configuration.

    access

    protected

    [ Top ]

    TSqlMapXmlConfiguration::loadTypeHandler

    loadTypeHandler( SimpleXmlElement $node );

    Parameters

    $node

    type handler node

    Remarks

    Load the type handler configurations.

    access

    protected

    [ Top ]

    TSqlMapXmlConfiguration::replaceProperties

    replaceProperties( string $string );

    Parameters

    $string

    original string.

    Returns

    string with global property replacement.

    Remarks

    Replace the place holders ${name} in text with properties the corresponding global property value.

    access

    public

    [ Top ]

    TSqlMapXmlConfiguration::resolveResultMapping

    resolveResultMapping( );

    Remarks

    Resolve nest result mappings.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:28 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapXmlMappingConfiguration

Class TSqlMapXmlMappingConfiguration

[line 308]
TSqlMapXmlConfigBuilder
   |
   --TSqlMapXmlMappingConfiguration
Location: /Data/SqlMap/Configuration/TSqlMapXmlConfiguration.php

Remarks

Loads the statements, result maps, parameters maps from xml configuration.

description

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapXmlConfiguration.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

  • ESCAPED_INLINE_SYMBOL_REGEXP = '/\#\#/'
  • ESCAPED_SIMPLE_MARK_REGEXP = '/\$\$/'
  • INLINE_PLACEHOLDER = '`!!!`'
  • INLINE_SYMBOL = '#'
  • SIMPLE_MARK = '$'
    Regular expressions for escaping simple/inline parameter symbols
  • SIMPLE_PLACEHOLDER = '`!!`'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapXmlConfigBuilder

  • TSqlMapXmlConfigBuilder::createObjectFromNode()
    Create an instance of an object give by the attribute named 'class' in the node and set the properties on the object given by attribute names and values.
  • TSqlMapXmlConfigBuilder::getAbsoluteFilePath()
    Gets the filename relative to the basefile.
  • TSqlMapXmlConfigBuilder::getConfigFile()
  • TSqlMapXmlConfigBuilder::getElementByIdValue()
    Get element node by ID value (try for attribute name ID as case insensitive).
  • TSqlMapXmlConfigBuilder::loadXmlDocument()
    Load document using simple xml.
  • TSqlMapXmlConfigBuilder::setObjectPropFromNode()
    For each attributes (excluding attribute named in $except) set the property of the $obj given by the name of the attribute with the value of the attribute.

Method Detail

    TSqlMapXmlMappingConfiguration::__construct

    __construct( TSqlMapXmlConfiguration $xmlConfig );

    Parameters

    $xmlConfig

    parent xml configuration.

    access

    public

    [ Top ]

    TSqlMapXmlMappingConfiguration::applyInlineParameterMap

    applyInlineParameterMap( TSqlMapStatement $statement, string $sqlStatement, SimpleXmlElement $node );

    Parameters

    $statement

    statement object.

    $sqlStatement

    sql text

    $node

    statement node.

    Remarks

    Extract inline parameter maps.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::configure

    configure( string $filename );

    Parameters

    $filename

    xml mapping filename.

    Remarks

    Configure an XML mapping.

    access

    public

    [ Top ]

    TSqlMapXmlMappingConfiguration::createInsertStatement

    createInsertStatement( SimpleXmlElement $node );

    Parameters

    $node

    insert node.

    Returns

    insert statement.

    Remarks

    Create new insert statement from xml node.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::createParameterMap

    createParameterMap( SimpleXmlElement $node );

    Parameters

    $node

    parameter map node.

    Returns

    new parameter mapping.

    Remarks

    Create a new parameter map from xml node.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::createResultMap

    createResultMap( SimpleXmlElement $node );

    Parameters

    $node

    result map node

    Returns

    SqlMap result mapping.

    Remarks

    Create a new result map and its associated result properties, disciminiator and sub maps.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::getConfigFile

    getConfigFile( );

    Overrides TSqlMapXmlConfigBuilder::getConfigFile() (parent method not documented)

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::loadCacheModel

    loadCacheModel( SimpleXmlElement $node );

    Parameters

    $node

    cache node.

    Remarks

    Load cache models from xml mapping.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::loadDeleteTag

    loadDeleteTag( SimpleXmlElement $node );

    Parameters

    $node

    delete node.

    Remarks

    Load delete statement from xml mapping.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::loadFlushInterval

    loadFlushInterval( TSqlMapCacheModel $cacheModel, SimpleXmlElement $node );

    Parameters

    $cacheModel

    cache model

    $node

    cache node

    Remarks

    Load the flush interval

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::loadFlushOnCache

    loadFlushOnCache( TSqlMapCacheModel $cacheModel, SimpleXmlElement $parent, SimpleXmlElement $node );

    Parameters

    $cacheModel

    cache model

    $parent

    parent node.

    $node

    flush node.

    Remarks

    Load the flush on cache properties.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::loadInsertTag

    loadInsertTag( SimpleXmlElement $node );

    Parameters

    $node

    insert node.

    Remarks

    Load insert statement from xml mapping.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::loadParameterMap

    loadParameterMap( SimpleXmlElement $node );

    Parameters

    $node

    parameter map node.

    Remarks

    Load parameter map from xml.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::loadProcedureTag

    loadProcedureTag( SimpleXmlElement $node );

    Parameters

    $node

    procedure node

    Remarks

    Load procedure statement from xml mapping.

    todo

    Implement loading procedure

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::loadResultMap

    loadResultMap( SimpleXmlElement $node );

    Parameters

    $node

    result map node.

    Remarks

    Load the result maps.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::loadSelectKeyTag

    loadSelectKeyTag( SimpleXmlElement $insert, $node );

    Parameters

    $insert

    selectkey node

    $node

    Remarks

    Load the selectKey statement from xml mapping.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::loadSelectTag

    loadSelectTag( SimpleXmlElement $node );

    Parameters

    $node

    select node.

    Remarks

    Load select statement from xml mapping.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::loadStatementTag

    loadStatementTag( SimpleXmlElement $node );

    Parameters

    $node

    statement node.

    Remarks

    Load statement mapping from xml configuration file.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::loadUpdateTag

    loadUpdateTag( SimpleXmlElement $node );

    Parameters

    $node

    update node.

    Remarks

    Load update statement from xml mapping.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::prepareSql

    prepareSql( TSqlMapStatement $statement, string $sqlStatement, SimpleXmlElement $node );

    Parameters

    $statement

    mapped statement.

    $sqlStatement

    sql text.

    $node

    statement node.

    Remarks

    Prepare the sql text (may extend to dynamic sql).

    todo

    Extend to dynamic sql.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::processSqlStatement

    processSqlStatement( TSqlMapStatement $statement, SimpleXmlElement $node );

    Parameters

    $statement

    mapped statement.

    $node

    statement node.

    Remarks

    Load extended SQL statements if application. Replaces global properties in the sql text. Extracts inline parameter maps.

    access

    protected

    [ Top ]

    TSqlMapXmlMappingConfiguration::registerCacheTriggers

    registerCacheTriggers( );

    Remarks

    Attach CacheModel to statement and register trigger statements for cache models

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

  • ESCAPED_INLINE_SYMBOL_REGEXP = '/\#\#/' [line 324]

  • ESCAPED_SIMPLE_MARK_REGEXP = '/\$\$/' [line 323]

  • INLINE_PLACEHOLDER = '`!!!`' [line 326]

  • INLINE_SYMBOL = '#' [line 322]

  • SIMPLE_MARK = '$' [line 321]

    • Remarks

    Regular expressions for escaping simple/inline parameter symbols

  • SIMPLE_PLACEHOLDER = '`!!`' [line 325]

Documentation generated on Mon, 25 Jun 2012 14:45:28 +0200 by phpDocumentor 1.4.3


Package System.Exceptions Element Index

Element index for package System.Exceptions

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
d e g h i s t _
top
_
$_messageCache | in file TException.php, variable TException::$_messageCache
__construct in file TException.php, method TPhpErrorException::__construct()
Constructor.
__construct in file TException.php, method TException::__construct()
Constructor.
__construct in file TException.php, method THttpException::__construct()
Constructor.
top
d
displayException in file TErrorHandler.php, method TErrorHandler::displayException()
Displays exception information.
top
e
ERROR_FILE_NAME in file TErrorHandler.php, class constant TErrorHandler::ERROR_FILE_NAME
error template file basename
EXCEPTION_FILE_NAME in file TErrorHandler.php, class constant TErrorHandler::EXCEPTION_FILE_NAME
exception template file basename
top
g
getErrorCode | in file TException.php, method TException::getErrorCode()
getErrorMessage | in file TException.php, method TException::getErrorMessage()
getErrorMessageFile | in file TException.php, method TException::getErrorMessageFile()
getErrorTemplate in file TErrorHandler.php, method TErrorHandler::getErrorTemplate()
Retrieves the template used for displaying external exceptions.
getErrorTemplatePath | in file TErrorHandler.php, method TErrorHandler::getErrorTemplatePath()
getExceptionTemplate in file TErrorHandler.php, method TErrorHandler::getExceptionTemplate()
Retrieves the template used for displaying internal exceptions.
getLineNumber | in file TException.php, method TTemplateException::getLineNumber()
getStatusCode | in file TException.php, method THttpException::getStatusCode()
getTemplateFile | in file TException.php, method TTemplateException::getTemplateFile()
getTemplateSource | in file TException.php, method TTemplateException::getTemplateSource()
top
h
handleError in file TErrorHandler.php, method TErrorHandler::handleError()
Handles PHP user errors and exceptions.
handleExternalError in file TErrorHandler.php, method TErrorHandler::handleExternalError()
Displays error to the client user.
handleRecursiveError in file TErrorHandler.php, method TErrorHandler::handleRecursiveError()
Handles error occurs during error handling (called recursive error).
hideSecurityRelated | in file TErrorHandler.php, method TErrorHandler::hideSecurityRelated()
top
i
init in file TErrorHandler.php, method TErrorHandler::init()
Initializes the module.
top
s
setErrorCode | in file TException.php, method TException::setErrorCode()
setErrorMessage | in file TException.php, method TException::setErrorMessage()
setErrorTemplatePath in file TErrorHandler.php, method TErrorHandler::setErrorTemplatePath()
Sets the path storing all error and exception template files.
setLineNumber | in file TException.php, method TTemplateException::setLineNumber()
setTemplateFile | in file TException.php, method TTemplateException::setTemplateFile()
setTemplateSource | in file TException.php, method TTemplateException::setTemplateSource()
SOURCE_LINES in file TErrorHandler.php, class constant TErrorHandler::SOURCE_LINES
number of lines before and after the error line to be displayed in case of an exception
top
t
TErrorHandler.php | procedural page TErrorHandler.php
TException.php | procedural page TException.php
TApplicationException in file TException.php, class TApplicationException
TApplicationException class
TConfigurationException in file TException.php, class TConfigurationException
TConfigurationException class
TDbConnectionException in file TException.php, class TDbConnectionException
TDbConnectionException class
TDbException in file TException.php, class TDbException
TDbException class
TErrorHandler in file TErrorHandler.php, class TErrorHandler
TErrorHandler class
TException in file TException.php, class TException
TException class
THttpException in file TException.php, class THttpException
THttpException class
TInvalidDataTypeException in file TException.php, class TInvalidDataTypeException
TInvalidDataTypeException class
TInvalidDataValueException in file TException.php, class TInvalidDataValueException
TInvalidDataValueException class
TInvalidOperationException in file TException.php, class TInvalidOperationException
TInvalidOperationException class
TIOException in file TException.php, class TIOException
TIOException class
TNotSupportedException in file TException.php, class TNotSupportedException
TNotSupportedException class
TPhpErrorException in file TException.php, class TPhpErrorException
TPhpErrorException class
translateErrorMessage in file TException.php, method TException::translateErrorMessage()
Translates an error code into an error message.
TSystemException in file TException.php, class TSystemException
TSystemException class
TTemplateException in file TException.php, class TTemplateException
TTemplateException class


Class Trees for Package System.Exceptions

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TErrorHandler.php

File: /Exceptions/TErrorHandler.php

Remarks

TErrorHandler class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TErrorHandler.php 3138 2012-05-10 22:05:47Z ctrlaltca $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TErrorHandler
TErrorHandler class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:18 +0200 by phpDocumentor 1.4.3


Docs for page TException.php

File: /Exceptions/TException.php

Remarks

Exception classes file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TException
TException class
TSystemException
TSystemException class
TApplicationException
TApplicationException class
TInvalidOperationException
TInvalidOperationException class
TInvalidDataTypeException
TInvalidDataTypeException class
TInvalidDataValueException
TInvalidDataValueException class
TConfigurationException
TConfigurationException class
TTemplateException
TTemplateException class
TIOException
TIOException class
TDbException
TDbException class
TDbConnectionException
TDbConnectionException class
TNotSupportedException
TNotSupportedException class
TPhpErrorException
TPhpErrorException class
THttpException
THttpException class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class TErrorHandler

Class TErrorHandler

[line 52]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TErrorHandler
Classes extended from TErrorHandler:
TCallbackErrorHandler
TCallbackErrorHandler class.

Location: /Exceptions/TErrorHandler.php

Remarks

TErrorHandler class

TErrorHandler handles all PHP user errors and exceptions generated during servicing user requests. It displays these errors using different templates and if possible, using languages preferred by the client user. Note, PHP parsing errors cannot be caught and handled by TErrorHandler.

The templates used to format the error output are stored under System.Exceptions. You may choose to use your own templates, should you not like the templates provided by Prado. Simply set ErrorTemplatePath to the path (in namespace format) storing your own templates.

There are two sets of templates, one for errors to be displayed to client users (called external errors), one for errors to be displayed to system developers (called internal errors). The template file name for the former is error[StatusCode][-LanguageCode].html, and for the latter it is exception[-LanguageCode].html, where StatusCode refers to response status code (e.g. 404, 500) specified when THttpException is thrown, and LanguageCode is the client user preferred language code (e.g. en, zh, de). The templates error.html and exception.html are default ones that are used if no other appropriate templates are available. Note, these templates are not Prado control templates. They are simply html files with keywords (e.g. %%ErrorMessage%%, %%Version%%) to be replaced with the corresponding information.

By default, TErrorHandler is registered with TApplication as the error handler module. It can be accessed via TApplication::getErrorHandler(). You seldom need to deal with the error handler directly. It is mainly used by the application object to handle errors.

TErrorHandler may be configured in application configuration file as follows <module id="error" class="TErrorHandler" ErrorTemplatePath="System.Exceptions" />

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TErrorHandler.php 3138 2012-05-10 22:05:47Z ctrlaltca $

since

3.0

Class Variable Summary

Class Constant Summary

  • ERROR_FILE_NAME = 'error'
    error template file basename
  • EXCEPTION_FILE_NAME = 'exception'
    exception template file basename
  • SOURCE_LINES = 12
    number of lines before and after the error line to be displayed in case of an exception

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static string hideSecurityRelated()
  • string hideSecurityRelated()

Inherited Method Summary

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    static TErrorHandler::hideSecurityRelated

    static hideSecurityRelated( string $value, [Exception|null$exception $exception = null] );

    Parameters

    $value

    $exception

    since

    3.1.6

    access

    protected

    [ Top ]

    TErrorHandler::displayException

    displayException( Exception $exception );

    Overridden in child classes as:

    TCallbackErrorHandler::displayException()
    Displays the exceptions to the client-side TJavascriptLogger.

    Parameters

    $exception

    exception instance

    Remarks

    Displays exception information.

    Exceptions are displayed with rich context information, including the call stack and the context source code. This method is only invoked when application is in Debug mode.

    access

    protected

    [ Top ]

    TErrorHandler::getErrorTemplate

    getErrorTemplate( integer $statusCode, Exception $exception );

    Parameters

    $statusCode

    status code (such as 404, 500, etc.)

    $exception

    the exception to be displayed

    Returns

    the template content

    Remarks

    Retrieves the template used for displaying external exceptions.

    External exceptions are those displayed to end-users. They do not contain error source code. Therefore, you might want to override this method to provide your own error template for displaying certain external exceptions. The following tokens in the template will be replaced with corresponding content: %%StatusCode%% : the status code of the exception %%ErrorMessage%% : the error message (HTML encoded). %%ServerAdmin%% : the server admin information (retrieved from Web server configuration) %%Version%% : the version information of the Web server. %%Time%% : the time the exception occurs at

    access

    protected

    [ Top ]

    TErrorHandler::getErrorTemplatePath

    getErrorTemplatePath( );

    Returns

    the directory containing error template files.

    access

    public

    [ Top ]

    TErrorHandler::getExceptionTemplate

    getExceptionTemplate( Exception $exception );

    Parameters

    $exception

    the exception to be displayed

    Returns

    the template content

    Remarks

    Retrieves the template used for displaying internal exceptions.

    Internal exceptions will be displayed with source code causing the exception. This occurs when the application is in debug mode.

    access

    protected

    [ Top ]

    TErrorHandler::handleError

    handleError( mixed $sender, mixed $param );

    Parameters

    $sender

    sender of the event

    $param

    event parameter (if the event is raised by TApplication, it refers to the exception instance)

    Remarks

    Handles PHP user errors and exceptions.

    This is the event handler responding to the Error event raised in TApplication. The method mainly uses appropriate template to display the error/exception. It terminates the application immediately after the error is displayed.

    access

    public

    [ Top ]

    TErrorHandler::handleExternalError

    handleExternalError( integer $statusCode, Exception $exception );

    Parameters

    $statusCode

    response status code

    $exception

    exception instance

    Remarks

    Displays error to the client user.

    THttpException and errors happened when the application is in Debug mode will be displayed to the client user.

    access

    protected

    [ Top ]

    TErrorHandler::handleRecursiveError

    handleRecursiveError( Exception $exception );

    Parameters

    $exception

    exception instance

    Remarks

    Handles error occurs during error handling (called recursive error).

    THttpException and errors happened when the application is in Debug mode will be displayed to the client user. Error is displayed without using existing template to prevent further errors.

    access

    protected

    [ Top ]

    TErrorHandler::init

    init( TXmlElement $config );

    Overrides TModule::init() (Initializes the module.)

    Parameters

    $config

    module configuration

    Remarks

    Initializes the module.

    This method is required by IModule and is invoked by application.

    access

    public

    [ Top ]

    TErrorHandler::setErrorTemplatePath

    setErrorTemplatePath( string $value );

    Parameters

    $value

    template path in namespace format

    Remarks

    Sets the path storing all error and exception template files.

    The path must be in namespace format, such as System.Exceptions (which is the default).

    throws

    TConfigurationException if the template path is invalid

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • ERROR_FILE_NAME = 'error' [line 57]

    • Remarks

    error template file basename

  • EXCEPTION_FILE_NAME = 'exception' [line 61]

    • Remarks

    exception template file basename

  • SOURCE_LINES = 12 [line 65]

    • Remarks

    number of lines before and after the error line to be displayed in case of an exception

Documentation generated on Mon, 25 Jun 2012 14:44:18 +0200 by phpDocumentor 1.4.3


Docs For Class TApplicationException

Class TApplicationException

[line 153]
Exception
   |
   --TException
      |
      --TApplicationException
Classes extended from TApplicationException:
TRpcClientRequestException
TRpcClientRequestException class
TRpcClientResponseException
TRpcClientResponseException class

Location: /Exceptions/TException.php

Remarks

TApplicationException class

TApplicationException is the base class for all user application-level exceptions.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class TConfigurationException

Class TConfigurationException

[line 210]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --TConfigurationException
Classes extended from TConfigurationException:
TTemplateException
TTemplateException class

Location: /Exceptions/TException.php

Remarks

TConfigurationException class

TConfigurationException represents an exception caused by invalid configurations, such as error in an application configuration file or control template file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class TDbConnectionException

Class TDbConnectionException

[line 317]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --TDbException
            |
            --TDbConnectionException
Location: /Exceptions/TException.php

Remarks

TDbConnectionException class

TDbConnectionException represents an exception caused by DB connection failure.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class TDbException

Class TDbException

[line 303]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --TDbException
Classes extended from TDbException:
TActiveRecordException
Base exception class for Active Records.
TDbConnectionException
TDbConnectionException class

Location: /Exceptions/TException.php

Remarks

TDbException class

TDbException represents an exception related with DB operations.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class TException

Class TException

[line 35]
Exception
   |
   --TException
Classes extended from TException:
TSqlMapException
TSqlMapException is the base exception class for all SqlMap exceptions.
TSystemException
TSystemException class
TApplicationException
TApplicationException class
TRpcException
TRpcException class
TInvalidCallbackException
TInvalidCallbackException class.

Location: /Exceptions/TException.php

Remarks

TException class

TException is the base class for all PRADO exceptions.

TException provides the functionality of translating an error code into a descriptive error message in a language that is preferred by user browser. Additional parameters may be passed together with the error code so that the translated message contains more detailed information.

By default, TException looks for a message file by calling getErrorMessageFile() method, which uses the "message-xx.txt" file located under "System.Exceptions" folder, where "xx" is the code of the user preferred language. If such a file is not found, "message.txt" will be used instead.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

  • static $_messageCache = array()

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

    TException::__construct

    __construct( string $errorMessage );

    Overridden in child classes as:

    TSqlMapException::__construct()
    Constructor, similar to the parent constructor. For parameters that are of SimpleXmlElement, the tag name and its attribute names and values are expanded into a string.
    TPhpErrorException::__construct()
    Constructor.
    THttpException::__construct()
    Constructor.
    TRpcClientResponseException::__construct()
    TRpcException::__construct()

    Overrides Exception::constructor __construct ( [$message = ], [$code = ], [$previous = ] ) (parent method not documented)

    Parameters

    $errorMessage

    error message. This can be a string that is listed in the message file. If so, the message in the preferred language will be used as the error message. Any rest parameters will be used to replace placeholders ({0}, {1}, {2}, etc.) in the message.

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TException::getErrorCode

    getErrorCode( );

    Returns

    error code

    access

    public

    [ Top ]

    TException::getErrorMessage

    getErrorMessage( );

    Returns

    error message

    access

    public

    [ Top ]

    TException::getErrorMessageFile

    getErrorMessageFile( );

    Overridden in child classes as:

    TSqlMapException::getErrorMessageFile()
    TActiveRecordException::getErrorMessageFile()

    Returns

    path to the error message file

    access

    protected

    [ Top ]

    TException::setErrorCode

    setErrorCode( string $code );

    Parameters

    $code

    error code

    access

    public

    [ Top ]

    TException::setErrorMessage

    setErrorMessage( string $message );

    Parameters

    $message

    error message

    access

    protected

    [ Top ]

    TException::translateErrorMessage

    translateErrorMessage( string $key );

    Parameters

    $key

    error code that is passed in the exception constructor.

    Returns

    the translated error message

    Remarks

    Translates an error code into an error message.

    access

    protected

    [ Top ]

Variable Detail

  • static $_messageCache = array() [line 38]
  • Data type: mixed

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class THttpException

Class THttpException

[line 389]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --THttpException
Location: /Exceptions/TException.php

Remarks

THttpException class

THttpException represents an exception that is caused by invalid operations of end-users. The StatusCode gives the type of HTTP error. It is used by TErrorHandler to provide different error output to users.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

    THttpException::__construct

    __construct( integer $statusCode, string $errorMessage );

    Overrides TException::__construct() (Constructor.)

    Parameters

    $statusCode

    HTTP status code, such as 404, 500, etc.

    $errorMessage

    error message. This can be a string that is listed in the message file. If so, the message in the preferred language will be used as the error message. Any rest parameters will be used to replace placeholders ({0}, {1}, {2}, etc.) in the message.

    Remarks

    Constructor.

    access

    public

    [ Top ]

    THttpException::getStatusCode

    getStatusCode( );

    Returns

    HTTP status code, such as 404, 500, etc.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class TInvalidDataTypeException

Class TInvalidDataTypeException

[line 181]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --TInvalidDataTypeException
Location: /Exceptions/TException.php

Remarks

TInvalidDataTypeException class

TInvalidDataTypeException represents an exception caused by invalid data type.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class TInvalidDataValueException

Class TInvalidDataValueException

[line 195]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --TInvalidDataValueException
Location: /Exceptions/TException.php

Remarks

TInvalidDataValueException class

TInvalidDataValueException represents an exception caused by invalid data value.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class TInvalidOperationException

Class TInvalidOperationException

[line 167]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --TInvalidOperationException
Location: /Exceptions/TException.php

Remarks

TInvalidOperationException class

TInvalidOperationException represents an exception caused by invalid operations.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class TIOException

Class TIOException

[line 289]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --TIOException
Location: /Exceptions/TException.php

Remarks

TIOException class

TIOException represents an exception related with improper IO operations.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class TNotSupportedException

Class TNotSupportedException

[line 331]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --TNotSupportedException
Location: /Exceptions/TException.php

Remarks

TNotSupportedException class

TNotSupportedException represents an exception caused by using an unsupported PRADO feature.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:19 +0200 by phpDocumentor 1.4.3


Docs For Class TPhpErrorException

Class TPhpErrorException

[line 346]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --TPhpErrorException
Location: /Exceptions/TException.php

Remarks

TPhpErrorException class

TPhpErrorException represents an exception caused by a PHP error. This exception is mainly thrown within a PHP error handler.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

    TPhpErrorException::__construct

    __construct( integer $errno, string $errstr, string $errfile, integer $errline );

    Overrides TException::__construct() (Constructor.)

    Parameters

    $errno

    error number

    $errstr

    error string

    $errfile

    error file

    $errline

    error line number

    Remarks

    Constructor.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:20 +0200 by phpDocumentor 1.4.3


Docs For Class TSystemException

Class TSystemException

[line 139]
Exception
   |
   --TException
      |
      --TSystemException
Classes extended from TSystemException:
TInvalidOperationException
TInvalidOperationException class
TInvalidDataTypeException
TInvalidDataTypeException class
TInvalidDataValueException
TInvalidDataValueException class
TConfigurationException
TConfigurationException class
TIOException
TIOException class
TDbException
TDbException class
TNotSupportedException
TNotSupportedException class
TPhpErrorException
TPhpErrorException class
THttpException
THttpException class

Location: /Exceptions/TException.php

Remarks

TSystemException class

TSystemException is the base class for all framework-level exceptions.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:20 +0200 by phpDocumentor 1.4.3


Docs For Class TTemplateException

Class TTemplateException

[line 224]
Exception
   |
   --TException
      |
      --TSystemException
         |
         --TConfigurationException
            |
            --TTemplateException
Location: /Exceptions/TException.php

Remarks

TTemplateException class

TTemplateException represents an exception caused by invalid template syntax.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TException.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

    TTemplateException::getLineNumber

    getLineNumber( );

    Returns

    the line number at which the template has error

    access

    public

    [ Top ]

    TTemplateException::getTemplateFile

    getTemplateFile( );

    Returns

    the template file that causes the exception. This could be empty if the template is an embedded template. In this case, use TemplateSource to obtain the actual template content.

    access

    public

    [ Top ]

    TTemplateException::getTemplateSource

    getTemplateSource( );

    Returns

    the template source code that causes the exception. This is empty if TemplateFile is not empty.

    access

    public

    [ Top ]

    TTemplateException::setLineNumber

    setLineNumber( integer $value );

    Parameters

    $value

    the line number at which the template has error

    access

    public

    [ Top ]

    TTemplateException::setTemplateFile

    setTemplateFile( string $value );

    Parameters

    $value

    the template file that causes the exception

    access

    public

    [ Top ]

    TTemplateException::setTemplateSource

    setTemplateSource( string $value );

    Parameters

    $value

    the template source code that causes the exception

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:20 +0200 by phpDocumentor 1.4.3


Package System.Data.SqlMap Element Index

Element index for package System.Data.SqlMap

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a c d f g h i l n p q r s t u _
top
_
$_cache | in file TFastSqlMapApplicationCache.php, variable TFastSqlMapApplicationCache::$_cache
$_cache | in file TSqlMapCache.php, variable TSqlMapCache::$_cache
$_cacheModel | in file TFastSqlMapApplicationCache.php, variable TFastSqlMapApplicationCache::$_cacheModel
$_cacheModel | in file TSqlMapCache.php, variable TSqlMapApplicationCache::$_cacheModel
$_cacheModel | in file TSqlMapCache.php, variable TSqlMapCache::$_cacheModel
$_cacheSize | in file TSqlMapCache.php, variable TSqlMapCache::$_cacheSize
$_keyList | in file TSqlMapCache.php, variable TSqlMapCache::$_keyList
__call in file TLazyLoadList.php, method TObjectProxy::__call()
Relay the method call to the handler object (if able to be handled), otherwise it calls the proxied object's method.
__construct | in file TSqlMapGateway.php, method TSqlMapGateway::__construct()
__construct in file TSqlMapManager.php, method TSqlMapManager::__construct()
Constructor, create a new SqlMap manager.
__construct in file TSqlMapPagedList.php, method TSqlMapPagedList::__construct()
Create a new SqlMap paged list.
__construct in file TSqlMapException.php, method TSqlMapException::__construct()
Constructor, similar to the parent constructor. For parameters that are of SimpleXmlElement, the tag name and its attribute names and values are expanded into a string.
__construct | in file TLazyLoadList.php, method TObjectProxy::__construct()
__construct in file TLazyLoadList.php, method TLazyLoadList::__construct()
Create a new proxy list that will execute the mapped statement when any of the list's method are accessed for the first time.
__construct | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::__construct()
__construct in file TSqlMapCache.php, method TSqlMapApplicationCache::__construct()
Create a new cache with limited cache size.
__construct in file TSqlMapCache.php, method TSqlMapCache::__construct()
Create a new cache with limited cache size.
top
a
add | in file TSqlMapCache.php, method TSqlMapCache::add()
add | in file TSqlMapCache.php, method TSqlMapApplicationCache::add()
add | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::add()
addCacheModel in file TSqlMapManager.php, method TSqlMapManager::addCacheModel()
Adds a named cache.
addMappedStatement in file TSqlMapManager.php, method TSqlMapManager::addMappedStatement()
Adds a (named) MappedStatement.
addParameterMap | in file TSqlMapManager.php, method TSqlMapManager::addParameterMap()
addResultMap | in file TSqlMapManager.php, method TSqlMapManager::addResultMap()
top
c
cacheSqlMapManager in file TSqlMapConfig.php, method TSqlMapConfig::cacheSqlMapManager()
Saves the current SqlMap manager to cache.
clearCache in file TSqlMapConfig.php, method TSqlMapConfig::clearCache()
Deletes the configuration cache.
configureXml in file TSqlMapManager.php, method TSqlMapManager::configureXml()
Loads and parses the SqlMap configuration file.
CONFIG_FILE_EXT in file TSqlMapConfig.php, class constant TSqlMapConfig::CONFIG_FILE_EXT
File extension of external configuration file
convertToType in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandlerRegistry::convertToType()
Converts the value to given type using PHP's settype() function.
createInstanceOf in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandlerRegistry::createInstanceOf()
Creates a new instance of a particular class (for PHP primative types, their corresponding default value for given type is used).
createNewInstance in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::createNewInstance()
Casts the string representation of a value into a type recognized by
createSqlMapGateway in file TSqlMapManager.php, method TSqlMapManager::createSqlMapGateway()
Configures the current TSqlMapManager using the given xml configuration file defined in ConfigFile.
createSqlMapGateway | in file TSqlMapConfig.php, method TSqlMapConfig::createSqlMapGateway()
top
d
delete in file TSqlMapGateway.php, method TSqlMapGateway::delete()
Executes a Sql DELETE statement. Delete returns the number of rows effected.
delete | in file TSqlMapCache.php, method TSqlMapCache::delete()
delete | in file TSqlMapCache.php, method TSqlMapApplicationCache::delete()
delete | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::delete()
top
f
fetchDataFromStatement in file TSqlMapPagedList.php, method TSqlMapPagedList::fetchDataFromStatement()
Fetch data by executing the SqlMap statement.
fetchListData in file TLazyLoadList.php, method TLazyLoadList::fetchListData()
Load the data by executing the mapped statement.
flush | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::flush()
flush in file TSqlMapCache.php, method TSqlMapCache::flush()
Clears the cache.
flush in file TSqlMapCache.php, method TSqlMapApplicationCache::flush()
Deletes all items in the cache, only for data cached by sqlmap cachemodel
flushCacheModels in file TSqlMapManager.php, method TSqlMapManager::flushCacheModels()
Flushes all cached objects that belong to this SqlMap
flushCaches in file TSqlMapGateway.php, method TSqlMapGateway::flushCaches()
Flushes all cached objects that belong to this SqlMap
top
g
get in file TPropertyAccess.php, method TPropertyAccess::get()
Gets the property value.
get | in file TSqlMapCache.php, method TSqlMapApplicationCache::get()
get | in file TSqlMapCache.php, method TSqlMapLruCache::get()
get | in file TSqlMapCache.php, method TSqlMapFifoCache::get()
get | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::get()
getBaseKey | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::getBaseKey()
getBaseKeyKeyName | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::getBaseKeyKeyName()
getCache | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::getCache()
getCache | in file TSqlMapCache.php, method TSqlMapApplicationCache::getCache()
getCacheDependencies | in file TSqlMapManager.php, method TSqlMapManager::getCacheDependencies()
getCacheKey | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::getCacheKey()
getCacheModel in file TSqlMapManager.php, method TSqlMapManager::getCacheModel()
Gets a cache by name
getCacheSize | in file TSqlMapCache.php, method TSqlMapCache::getCacheSize()
getClient in file TSqlMapConfig.php, method TSqlMapConfig::getClient()
Initialize the sqlmap if necessary, returns the TSqlMapGateway instance.
getConfigFile | in file TSqlMapConfig.php, method TSqlMapConfig::getConfigFile()
getDbConnection | in file TSqlMapGateway.php, method TSqlMapGateway::getDbConnection()
getDbConnection | in file TSqlMapManager.php, method TSqlMapManager::getDbConnection()
getDbType | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::getDbType()
getDbTypeHandler | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandlerRegistry::getDbTypeHandler()
getEnableCache | in file TSqlMapConfig.php, method TSqlMapConfig::getEnableCache()
getErrorMessageFile | in file TSqlMapException.php, method TSqlMapException::getErrorMessageFile()
getIsLastPage | in file TSqlMapPagedList.php, method TSqlMapPagedList::getIsLastPage()
getIsMiddlePage | in file TSqlMapPagedList.php, method TSqlMapPagedList::getIsMiddlePage()
getIsNextPageAvailable | in file TSqlMapPagedList.php, method TSqlMapPagedList::getIsNextPageAvailable()
getIsPreviousPageAvailable | in file TSqlMapPagedList.php, method TSqlMapPagedList::getIsPreviousPageAvailable()
getKeyList in file TSqlMapCache.php, method TSqlMapApplicationCache::getKeyList()
Retreive keylist from cache or create it if it doesn't exists
getKeyListId | in file TSqlMapCache.php, method TSqlMapApplicationCache::getKeyListId()
getMappedStatement in file TSqlMapManager.php, method TSqlMapManager::getMappedStatement()
Gets a MappedStatement by name.
getMappedStatements | in file TSqlMapManager.php, method TSqlMapManager::getMappedStatements()
getOffsetAndLimit in file TSqlMapPagedList.php, method TSqlMapPagedList::getOffsetAndLimit()
Calculate the data fetch offsets and limits.
getParameter in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::getParameter()
Performs processing on a value before it is used to set the parameter of a IDbCommand.
getParameterMap | in file TSqlMapManager.php, method TSqlMapManager::getParameterMap()
getParameterMaps | in file TSqlMapManager.php, method TSqlMapManager::getParameterMaps()
getResult in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::getResult()
Performs processing on a value before after it has been retrieved
getResultMap in file TSqlMapManager.php, method TSqlMapManager::getResultMap()
Gets a named result map
getResultMaps | in file TSqlMapManager.php, method TSqlMapManager::getResultMaps()
getSqlmapGateway | in file TSqlMapManager.php, method TSqlMapManager::getSqlmapGateway()
getSqlMapManager in file TSqlMapConfig.php, method TSqlMapConfig::getSqlMapManager()
Create and configure the data mapper using sqlmap configuration file.
getSqlMapManager | in file TSqlMapGateway.php, method TSqlMapGateway::getSqlMapManager()
getType | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::getType()
getTypeHandler | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandlerRegistry::getTypeHandler()
getTypeHandlers | in file TSqlMapManager.php, method TSqlMapManager::getTypeHandlers()
top
h
has | in file TPropertyAccess.php, method TPropertyAccess::has()
hasMethod in file TLazyLoadList.php, method TLazyLoadList::hasMethod()
Try to fetch the data when any of the proxy collection method is called.
top
i
implodeNode | in file TSqlMapException.php, method TSqlMapException::implodeNode()
initialize in file TSqlMapPagedList.php, method TSqlMapPagedList::initialize()
Initialize the paged list.
insert in file TSqlMapGateway.php, method TSqlMapGateway::insert()
Executes a Sql INSERT statement.
intercept in file TLazyLoadList.php, method TLazyLoadList::intercept()
Relay the method call to the underlying collection.
top
l
loadCachedSqlMapManager in file TSqlMapConfig.php, method TSqlMapConfig::loadCachedSqlMapManager()
Loads SqlMap manager from cache.
top
n
newInstance in file TLazyLoadList.php, method TLazyLoadList::newInstance()
Create a new instance of a lazy collection.
nextPage in file TSqlMapPagedList.php, method TSqlMapPagedList::nextPage()
Switches to the next page.
top
p
populateData in file TSqlMapPagedList.php, method TSqlMapPagedList::populateData()
Populate the list with the fetched data.
previousPage in file TSqlMapPagedList.php, method TSqlMapPagedList::previousPage()
Switches to the previous page.
top
q
queryForList in file TSqlMapGateway.php, method TSqlMapGateway::queryForList()
Executes a Sql SELECT statement that returns data to populate a number of result objects.
queryForMap in file TSqlMapGateway.php, method TSqlMapGateway::queryForMap()
Executes the SQL and retuns all rows selected in a map that is keyed on
queryForMapWithRowDelegate in file TSqlMapGateway.php, method TSqlMapGateway::queryForMapWithRowDelegate()
Runs a query with a custom object that gets a chance to deal with each row as it is processed.
queryForObject in file TSqlMapGateway.php, method TSqlMapGateway::queryForObject()
Executes a Sql SELECT statement that returns that returns data to populate a single object instance.
queryForPagedList in file TSqlMapGateway.php, method TSqlMapGateway::queryForPagedList()
Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.
queryForPagedListWithRowDelegate in file TSqlMapGateway.php, method TSqlMapGateway::queryForPagedListWithRowDelegate()
Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.
queryWithRowDelegate in file TSqlMapGateway.php, method TSqlMapGateway::queryWithRowDelegate()
Runs a query for list with a custom object that gets a chance to deal with each row as it is processed.
top
r
registerTypeHandler | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandlerRegistry::registerTypeHandler()
registerTypeHandler | in file TSqlMapGateway.php, method TSqlMapGateway::registerTypeHandler()
top
s
set | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::set()
set in file TSqlMapCache.php, method TSqlMapFifoCache::set()
Stores a value identified by a key into cache.
set in file TSqlMapCache.php, method TSqlMapLruCache::set()
Stores a value identified by a key into cache.
set in file TPropertyAccess.php, method TPropertyAccess::set()
Sets the property value.
set in file TSqlMapCache.php, method TSqlMapApplicationCache::set()
Stores a value identified by a key into cache.
setCacheSize in file TSqlMapCache.php, method TSqlMapCache::setCacheSize()
Maximum number of items to cache. Default size is 100.
setConfigFile | in file TSqlMapConfig.php, method TSqlMapConfig::setConfigFile()
setCustomPaging | in file TSqlMapPagedList.php, method TSqlMapPagedList::setCustomPaging()
setDbConnection | in file TSqlMapManager.php, method TSqlMapManager::setDbConnection()
setDbType | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::setDbType()
setEnableCache in file TSqlMapConfig.php, method TSqlMapConfig::setEnableCache()
Set true to cache sqlmap instances.
setKeyList | in file TSqlMapCache.php, method TSqlMapApplicationCache::setKeyList()
setType | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::setType()
top
t
TFastSqlMapApplicationCache.php | procedural page TFastSqlMapApplicationCache.php
TLazyLoadList.php | procedural page TLazyLoadList.php
TPropertyAccess.php | procedural page TPropertyAccess.php
TSqlMapCache.php | procedural page TSqlMapCache.php
TSqlMapException.php | procedural page TSqlMapException.php
TSqlMapPagedList.php | procedural page TSqlMapPagedList.php
TSqlMapTypeHandlerRegistry.php | procedural page TSqlMapTypeHandlerRegistry.php
TSqlMapConfig.php | procedural page TSqlMapConfig.php
TSqlMapGateway.php | procedural page TSqlMapGateway.php
TSqlMapManager.php | procedural page TSqlMapManager.php
TFastSqlMapApplicationCache in file TFastSqlMapApplicationCache.php, class TFastSqlMapApplicationCache
TFastSqlMapApplicationCache class file
TInvalidPropertyException in file TSqlMapException.php, class TInvalidPropertyException
TInvalidPropertyException, raised when setting or getting an invalid property.
TLazyLoadList in file TLazyLoadList.php, class TLazyLoadList
TLazyLoadList executes mapped statements when the proxy collection is first accessed.
TObjectProxy in file TLazyLoadList.php, class TObjectProxy
TObjectProxy sets up a simple object that intercepts method calls to a particular object and relays the call to handler object.
TPropertyAccess in file TPropertyAccess.php, class TPropertyAccess
TPropertyAccess class provides dot notation stype property access and setting.
TSqlMapApplicationCache in file TSqlMapCache.php, class TSqlMapApplicationCache
TSqlMapApplicationCache uses the default Prado application cache for caching SqlMap results.
TSqlMapCache in file TSqlMapCache.php, class TSqlMapCache
Allow different implementation of caching strategy. See <tt>TSqlMapFifoCache</tt> for a first-in-first-out implementation. See <tt>TSqlMapLruCache</tt> for a least-recently-used cache implementation.
TSqlMapConfig in file TSqlMapConfig.php, class TSqlMapConfig
TSqlMapConfig module configuration class.
TSqlMapConfigurationException in file TSqlMapException.php, class TSqlMapConfigurationException
TSqlMapConfigurationException, raised during configuration file parsing.
TSqlMapDuplicateException in file TSqlMapException.php, class TSqlMapDuplicateException
TSqlMapDuplicateException, raised when a duplicate mapped statement is found.
TSqlMapException in file TSqlMapException.php, class TSqlMapException
TSqlMapException is the base exception class for all SqlMap exceptions.
TSqlMapExecutionException in file TSqlMapException.php, class TSqlMapExecutionException
TSqlMapException is the base exception class for all SqlMap exceptions.
TSqlMapFifoCache in file TSqlMapCache.php, class TSqlMapFifoCache
First-in-First-out cache implementation, removes object that was first added when the cache is full.
TSqlMapGateway in file TSqlMapGateway.php, class TSqlMapGateway
DataMapper client, a fascade to provide access the rest of the DataMapper framework. It provides three core functions:
TSqlMapLruCache in file TSqlMapCache.php, class TSqlMapLruCache
Least recently used cache implementation, removes object that was accessed last when the cache is full.
TSqlMapManager in file TSqlMapManager.php, class TSqlMapManager
TSqlMapManager class holds the sqlmap configuation result maps, statements parameter maps and a type handler factory.
TSqlMapPagedList in file TSqlMapPagedList.php, class TSqlMapPagedList
TSqlMapPagedList implements a list with paging functionality that retrieves data from a SqlMap statement.
TSqlMapTypeHandler in file TSqlMapTypeHandlerRegistry.php, class TSqlMapTypeHandler
A simple interface for implementing custom type handlers.
TSqlMapTypeHandlerRegistry in file TSqlMapTypeHandlerRegistry.php, class TSqlMapTypeHandlerRegistry
TTypeHandlerFactory provides type handler classes to convert database field type to PHP types and vice versa.
TSqlMapUndefinedException in file TSqlMapException.php, class TSqlMapUndefinedException
TSqlMapUndefinedException, raised when mapped statemented are undefined.
top
u
update in file TSqlMapGateway.php, method TSqlMapGateway::update()
Executes a Sql UPDATE statement.


Class Trees for Package System.Data.SqlMap

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TFastSqlMapApplicationCache.php

File: /Data/SqlMap/DataMapper/TFastSqlMapApplicationCache.php

Remarks

TFastSqlMapApplicationCache class file contains Fast SqlMap cache implementation.

author

Berczi Gabor <gabor.berczi@devworx.hu>

version

$Id: TFastSqlMapApplicationCache.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TFastSqlMapApplicationCache
TFastSqlMapApplicationCache class file

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:20 +0200 by phpDocumentor 1.4.3


Docs for page TLazyLoadList.php

File: /Data/SqlMap/DataMapper/TLazyLoadList.php

Remarks

TLazyLoadList, TObjectProxy classes file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TLazyLoadList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TLazyLoadList
TLazyLoadList executes mapped statements when the proxy collection is first accessed.
TObjectProxy
TObjectProxy sets up a simple object that intercepts method calls to a particular object and relays the call to handler object.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:41 +0200 by phpDocumentor 1.4.3


Docs for page TPropertyAccess.php

File: /Data/SqlMap/DataMapper/TPropertyAccess.php

Remarks

TPropertyAccess class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TPropertyAccess.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPropertyAccess
TPropertyAccess class provides dot notation stype property access and setting.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:05 +0200 by phpDocumentor 1.4.3


Docs for page TSqlMapCache.php

File: /Data/SqlMap/DataMapper/TSqlMapCache.php

Remarks

TSqlMapCache class file contains FIFO, LRU, and GLOBAL cache implementations.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapCache.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqlMapCache
Allow different implementation of caching strategy. See <tt>TSqlMapFifoCache</tt> for a first-in-first-out implementation. See <tt>TSqlMapLruCache</tt> for a least-recently-used cache implementation.
TSqlMapFifoCache
First-in-First-out cache implementation, removes object that was first added when the cache is full.
TSqlMapLruCache
Least recently used cache implementation, removes object that was accessed last when the cache is full.
TSqlMapApplicationCache
TSqlMapApplicationCache uses the default Prado application cache for caching SqlMap results.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs for page TSqlMapConfig.php

File: /Data/SqlMap/TSqlMapConfig.php

Remarks

TSqlMapConfig class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapConfig.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqlMapConfig
TSqlMapConfig module configuration class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs for page TSqlMapException.php

File: /Data/SqlMap/DataMapper/TSqlMapException.php

Classes in this file:
TSqlMapException
TSqlMapException is the base exception class for all SqlMap exceptions.
TSqlMapConfigurationException
TSqlMapConfigurationException, raised during configuration file parsing.
TSqlMapUndefinedException
TSqlMapUndefinedException, raised when mapped statemented are undefined.
TSqlMapDuplicateException
TSqlMapDuplicateException, raised when a duplicate mapped statement is found.
TInvalidPropertyException
TInvalidPropertyException, raised when setting or getting an invalid property.
TSqlMapExecutionException
TSqlMapException is the base exception class for all SqlMap exceptions.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs for page TSqlMapGateway.php

File: /Data/SqlMap/TSqlMapGateway.php

Remarks

TSqlMapGateway class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapGateway.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqlMapGateway
DataMapper client, a fascade to provide access the rest of the DataMapper framework. It provides three core functions:

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:26 +0200 by phpDocumentor 1.4.3


Docs for page TSqlMapManager.php

File: /Data/SqlMap/TSqlMapManager.php

Remarks

TSqlMapManager class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapManager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqlMapManager
TSqlMapManager class holds the sqlmap configuation result maps, statements parameter maps and a type handler factory.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:26 +0200 by phpDocumentor 1.4.3


Docs for page TSqlMapPagedList.php

File: /Data/SqlMap/DataMapper/TSqlMapPagedList.php

Remarks

TSqlMapPagedList class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapPagedList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqlMapPagedList
TSqlMapPagedList implements a list with paging functionality that retrieves data from a SqlMap statement.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:26 +0200 by phpDocumentor 1.4.3


Docs for page TSqlMapTypeHandlerRegistry.php

File: /Data/SqlMap/DataMapper/TSqlMapTypeHandlerRegistry.php

Remarks

TSqlMapTypeHandlerRegistry, and abstract TSqlMapTypeHandler classes file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapTypeHandlerRegistry.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqlMapTypeHandlerRegistry
TTypeHandlerFactory provides type handler classes to convert database field type to PHP types and vice versa.
TSqlMapTypeHandler
A simple interface for implementing custom type handlers.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:27 +0200 by phpDocumentor 1.4.3


Docs For Class TFastSqlMapApplicationCache

Class TFastSqlMapApplicationCache

[line 24]

Location: /Data/SqlMap/DataMapper/TFastSqlMapApplicationCache.php

Remarks

TFastSqlMapApplicationCache class file

Fast SqlMap result cache class with minimal-concurrency get/set and atomic flush operations

author

Berczi Gabor <gabor.berczi@devworx.hu>

version

$Id: TFastSqlMapApplicationCache.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.2

Class Variable Summary

  • $_cache = null

  • $_cacheModel = null

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TFastSqlMapApplicationCache::__construct

__construct(
[
$cacheModel = null] );

    Parameters

    $cacheModel

    access

    public

    [ Top ]

    TFastSqlMapApplicationCache::add

add(

$id,
$value, [
$expire = 0], [
$dependency = null] );

    Parameters

    $id

    $value

    $expire

    $dependency

    access

    public

    [ Top ]

    TFastSqlMapApplicationCache::delete

delete(

$key );

    Parameters

    $key

    access

    public

    [ Top ]

    TFastSqlMapApplicationCache::flush

flush(
 );

    access

    public

    [ Top ]

    TFastSqlMapApplicationCache::get

get(

$key );

    Parameters

    $key

    access

    public

    [ Top ]

    TFastSqlMapApplicationCache::getBaseKey

getBaseKey(
 );

    access

    protected

    [ Top ]

    TFastSqlMapApplicationCache::getBaseKeyKeyName

getBaseKeyKeyName(
 );

    access

    protected

    [ Top ]

    TFastSqlMapApplicationCache::getCache

getCache(
 );

    access

    protected

    [ Top ]

    TFastSqlMapApplicationCache::getCacheKey

getCacheKey(

$key );

    Parameters

    $key

    access

    protected

    [ Top ]

    TFastSqlMapApplicationCache::set

set(

$key,
$value, [
$expire = 0], [
$dependency = null] );

    Parameters

    $key

    $value

    $expire

    $dependency

    access

    public

    [ Top ]

Variable Detail

  • $_cache = null [line 27]
    •

  • Data type: mixed
    •

    access

    protected

  • $_cacheModel = null [line 26]
    •

  • Data type: mixed
    •

    access

    protected

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:20 +0200 by phpDocumentor 1.4.3


Docs For Class TLazyLoadList

Class TLazyLoadList

[line 21]

Location: /Data/SqlMap/DataMapper/TLazyLoadList.php

Remarks

TLazyLoadList executes mapped statements when the proxy collection is first accessed.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TLazyLoadList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static TObjectProxy newInstance()

    Create a new instance of a lazy collection.

  • TObjectProxy newInstance()

    Create a new instance of a lazy collection.

Inherited Method Summary

Method Detail

    static TLazyLoadList::newInstance

static newInstance(
TMappedStatement
$mappedStatement, mixed
$param, object result
$target, string
$propertyName );

    Parameters

    $mappedStatement

    statement to be executed to load the data.

    $param

    parameter value for the statement.

    $target

    object that contains the lazy collection.

    $propertyName

    property of the result object to set the loaded collection.

    Returns

    proxied collection object.

    Remarks

    Create a new instance of a lazy collection.

    access

    public

    [ Top ]

    TLazyLoadList::__construct

__construct(
TMappedStatement
$mappedStatement, mixed
$param, object result
$target, string
$propertyName );

    Parameters

    $mappedStatement

    statement to be executed to load the data.

    $param

    parameter value for the statement.

    $target

    object that contains the lazy collection.

    $propertyName

    property of the result object to set the loaded collection.

    Remarks

    Create a new proxy list that will execute the mapped statement when any  of the list's method are accessed for the first time.

    access

    protected

    [ Top ]

    TLazyLoadList::fetchListData

fetchListData(
 );

    Remarks

    Load the data by executing the mapped statement.

    access

    protected

    [ Top ]

    TLazyLoadList::hasMethod

hasMethod(
string
$method );

    Parameters

    $method

    method name.

    Returns

    true if the underlying collection has the corresponding method name.

    Remarks

    Try to fetch the data when any of the proxy collection method is called.

    access

    public

    [ Top ]

    TLazyLoadList::intercept

intercept(
string
$method, array
$arguments );

    Parameters

    $method

    method name.

    $arguments

    method parameters.

    Remarks

    Relay the method call to the underlying collection.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:41 +0200 by phpDocumentor 1.4.3


Docs For Class TObjectProxy

Class TObjectProxy

[line 114]

Location: /Data/SqlMap/DataMapper/TLazyLoadList.php

Remarks

TObjectProxy sets up a simple object that intercepts method calls to a  particular object and relays the call to handler object.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TLazyLoadList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TObjectProxy::__construct

__construct(
object handler
$handler, object the
$object );

    Parameters

    $handler

    to method calls.

    $object

    object to by proxied.

    access

    public

    [ Top ]

    TObjectProxy::__call

__call(
string
$method, array
$params );

    Parameters

    $method

    method name called

    $params

    method arguments

    Returns

    method return value.

    Remarks

    Relay the method call to the handler object (if able to be handled), otherwise  it calls the proxied object's method.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:41 +0200 by phpDocumentor 1.4.3


Docs For Class TPropertyAccess

Class TPropertyAccess

[line 44]

Location: /Data/SqlMap/DataMapper/TPropertyAccess.php

Remarks

TPropertyAccess class provides dot notation stype property access and setting.

Access object's properties (and subproperties) using dot path notation.  The following are equivalent.
  •  echo $obj->property1;
    •

  •  echo $obj->getProperty1();
    •

  •  echo $obj['property1']; //$obj may be an array or object
    •

  •  echo TPropertyAccess($obj, 'property1');
    •

    Setting a property value.
  •  $obj1->propert1 = 'hello';
    •

  •  $obj->setProperty('hello');
    •

  •  $obj['property1'] = 'hello'; //$obj may be an array or object
    •

  •  TPropertyAccess($obj, 'property1', 'hello');
    •

    Subproperties are supported using the dot notation. E.g.
  •  echo $obj->property1->property2->property3
    •

  •  echo TPropertyAccess::get($obj, 'property1.property2.property3');
    •

    author

    Wei Zhuo <weizho[at]gmail[dot]com>

    version

    $Id: TPropertyAccess.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    • static mixed get()

      Gets the property value.

    • static boolean has()

    • static void set()

      Sets the property value.

    • mixed get()

      Gets the property value.

    • boolean has()

    • void set()

      Sets the property value.

    Inherited Method Summary

    Method Detail

      static TPropertyAccess::get

static get(
mixed
$object, string
$path );

      Parameters

      $object

      object or path.

      $path

      property path.

      Returns

      property value.

      Remarks

      Gets the property value.

      throws

      TInvalidDataValueException if property path is invalid.

      access

      public

      [ Top ]

      static TPropertyAccess::has

static has(
mixed
$object, string
$path );

      Parameters

      $object

      object or array

      $path

      property path.

      Returns

      true if property path is valid

      access

      public

      [ Top ]

      static TPropertyAccess::set

static set(
mixed
&$originalObject, string
$path, mixed
$value );

      Parameters

      &$originalObject

      object or array

      $path

      property path.

      $value

      new property value.

      Remarks

      Sets the property value.

      throws

      TInvalidDataValueException if property path is invalid.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:05 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapApplicationCache

Class TSqlMapApplicationCache

[line 175]

Location: /Data/SqlMap/DataMapper/TSqlMapCache.php

Remarks

TSqlMapApplicationCache uses the default Prado application cache for  caching SqlMap results.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapCache.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

  • $_cacheModel = null

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TSqlMapApplicationCache::__construct

__construct(
[
$cacheModel = null], TSqlMapCacheModel
$cacheModel. );

    Parameters

    $cacheModel.

    $cacheModel

    Remarks

    Create a new cache with limited cache size.

    access

    public

    [ Top ]

    TSqlMapApplicationCache::add

add(

$id,
$value, [
$expire = 0], [
$dependency = null] );

    Parameters

    $id

    $value

    $expire

    $dependency

    throws

    TSqlMapException not implemented.

    access

    public

    [ Top ]

    TSqlMapApplicationCache::delete

delete(
string
$key );

    Parameters

    $key

    item to be deleted.

    access

    public

    [ Top ]

    TSqlMapApplicationCache::flush

flush(
 );

    Remarks

    Deletes all items in the cache, only for data cached by sqlmap cachemodel

    access

    public

    [ Top ]

    TSqlMapApplicationCache::get

get(

$key );

    Parameters

    $key

    Returns

    Gets a cached object with the specified key.

    access

    public

    [ Top ]

    TSqlMapApplicationCache::getCache

getCache(
 );

    Returns

    Application cache instance.

    access

    protected

    [ Top ]

    TSqlMapApplicationCache::getKeyList

getKeyList(
 );

    Remarks

    Retreive keylist from cache or create it if it doesn't exists

    access

    protected

    [ Top ]

    TSqlMapApplicationCache::getKeyListId

getKeyListId(
 );

    Returns

    a KeyListID for the cache model.

    access

    protected

    [ Top ]

    TSqlMapApplicationCache::set

set(
string
$key, mixed
$value, [
$expire = 0], [
$dependency = null] );

    Parameters

    $key

    the key identifying the value to be cached

    $value

    the value to be cached

    $expire

    $dependency

    Remarks

    Stores a value identified by a key into cache.

    access

    public

    [ Top ]

    TSqlMapApplicationCache::setKeyList

setKeyList(

$keyList );

    Parameters

    $keyList

    access

    protected

    [ Top ]

Variable Detail

  • $_cacheModel = null [line 177]
    •

  • Data type: mixed
    •

    access

    protected

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapCache

Class TSqlMapCache

[line 23]

Classes extended from TSqlMapCache:

TSqlMapFifoCache

First-in-First-out cache implementation, removes  object that was first added when the cache is full.

TSqlMapLruCache

Least recently used cache implementation, removes  object that was accessed last when the cache is full.

Location: /Data/SqlMap/DataMapper/TSqlMapCache.php

Remarks

Allow different implementation of caching strategy. See <tt>TSqlMapFifoCache</tt>  for a first-in-first-out implementation. See <tt>TSqlMapLruCache</tt> for  a least-recently-used cache implementation.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapCache.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.1

Class Variable Summary

  • $_cache =

  • $_cacheModel =  null

  • $_cacheSize =  100

  • $_keyList =

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TSqlMapCache::__construct

__construct(
[
$cacheModel = null], TSqlMapCacheModel
$cacheModel. );

    Parameters

    $cacheModel.

    $cacheModel

    Remarks

    Create a new cache with limited cache size.

    access

    public

    [ Top ]

    TSqlMapCache::add

add(

$id,
$value, [
$expire = 0], [
$dependency = null] );

    Parameters

    $id

    $value

    $expire

    $dependency

    throws

    TSqlMapException not implemented.

    access

    public

    [ Top ]

    TSqlMapCache::delete

delete(

$key );

    Parameters

    $key

    Returns

    object removed if exists, null otherwise.

    access

    public

    [ Top ]

    TSqlMapCache::flush

flush(
 );

    Remarks

    Clears the cache.

    access

    public

    [ Top ]

    TSqlMapCache::getCacheSize

getCacheSize(
 );

    Returns

    cache size.

    access

    public

    [ Top ]

    TSqlMapCache::setCacheSize

setCacheSize(
int
$value );

    Parameters

    $value

    cache size.

    Remarks

    Maximum number of items to cache. Default size is 100.

    access

    public

    [ Top ]

Variable Detail

  • $_cache =  [line 26]
    •

  • Data type: mixed
    •

    access

    protected

  • $_cacheModel =  null [line 28]
    •

  • Data type: mixed
    •

    access

    protected

  • $_cacheSize =  100 [line 27]
    •

  • Data type: mixed
    •

    access

    protected

  • $_keyList =  [line 25]
    •

  • Data type: mixed
    •

    access

    protected

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapFifoCache

Class TSqlMapFifoCache

[line 96]
TSqlMapCache
   |
   --TSqlMapFifoCache
Location: /Data/SqlMap/DataMapper/TSqlMapCache.php

Remarks

First-in-First-out cache implementation, removes object that was first added when the cache is full.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapCache.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TSqlMapCache

  • TSqlMapCache::$_cache =
  • TSqlMapCache::$_cacheModel = null
  • TSqlMapCache::$_cacheSize = 100
  • TSqlMapCache::$_keyList =

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapCache

  • TSqlMapCache::__construct()
    Create a new cache with limited cache size.
  • TSqlMapCache::add()
  • TSqlMapCache::delete()
  • TSqlMapCache::flush()
    Clears the cache.
  • TSqlMapCache::getCacheSize()
  • TSqlMapCache::setCacheSize()
    Maximum number of items to cache. Default size is 100.

Method Detail

    TSqlMapFifoCache::get

    get( $key );

    Parameters

    $key

    Returns

    Gets a cached object with the specified key.

    access

    public

    [ Top ]

    TSqlMapFifoCache::set

    set( string $key, mixed $value, [ $expire = 0], [ $dependency = null] );

    Parameters

    $key

    cache key

    $value

    value to cache.

    $expire

    $dependency

    Remarks

    Stores a value identified by a key into cache.

    The expire and dependency parameters are ignored.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapLruCache

Class TSqlMapLruCache

[line 133]
TSqlMapCache
   |
   --TSqlMapLruCache
Location: /Data/SqlMap/DataMapper/TSqlMapCache.php

Remarks

Least recently used cache implementation, removes object that was accessed last when the cache is full.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapCache.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TSqlMapCache

  • TSqlMapCache::$_cache =
  • TSqlMapCache::$_cacheModel = null
  • TSqlMapCache::$_cacheSize = 100
  • TSqlMapCache::$_keyList =

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapCache

  • TSqlMapCache::__construct()
    Create a new cache with limited cache size.
  • TSqlMapCache::add()
  • TSqlMapCache::delete()
  • TSqlMapCache::flush()
    Clears the cache.
  • TSqlMapCache::getCacheSize()
  • TSqlMapCache::setCacheSize()
    Maximum number of items to cache. Default size is 100.

Method Detail

    TSqlMapLruCache::get

    get( $key );

    Parameters

    $key

    Returns

    Gets a cached object with the specified key.

    access

    public

    [ Top ]

    TSqlMapLruCache::set

    set( string $key, mixed $value, [ $expire = 0], [ $dependency = null] );

    Parameters

    $key

    the key identifying the value to be cached

    $value

    the value to be cached

    $expire

    $dependency

    Remarks

    Stores a value identified by a key into cache.

    The expire and dependency parameters are ignored.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapConfig

Class TSqlMapConfig

[line 25]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TDataSourceConfig
            |
            --TSqlMapConfig
Location: /Data/SqlMap/TSqlMapConfig.php

Remarks

TSqlMapConfig module configuration class.

Database connection and TSqlMapManager configuration.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapConfig.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

  • CONFIG_FILE_EXT = '.xml'
    File extension of external configuration file

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDataSourceConfig

  • TDataSourceConfig::findConnectionByID()
    Finds the database connection instance from the Application modules.
  • TDataSourceConfig::getConnectionClass()
  • TDataSourceConfig::getConnectionID()
  • TDataSourceConfig::getDatabase()
    Alias for getDbConnection().
  • TDataSourceConfig::getDbConnection()
    Gets the TDbConnection from another module if setConnectionID is supplied and valid. Otherwise, a connection of type given by setConnectionClass is created.
  • TDataSourceConfig::init()
    Initalize the database connection properties from attributes in <database> tag.
  • TDataSourceConfig::setConnectionClass()
    The database connection class name to be created when getDbConnection
  • TDataSourceConfig::setConnectionID()
    The module ID of another TDataSourceConfig. The getDbConnection property of this configuration will equal to getDbConnection of the given TDataSourceConfig module.

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqlMapConfig::cacheSqlMapManager

    cacheSqlMapManager( $manager );

    Parameters

    $manager

    Returns

    true if SqlMap manager was cached, false otherwise.

    Remarks

    Saves the current SqlMap manager to cache.

    access

    protected

    [ Top ]

    TSqlMapConfig::clearCache

    clearCache( );

    Remarks

    Deletes the configuration cache.

    access

    public

    [ Top ]

    TSqlMapConfig::createSqlMapGateway

    createSqlMapGateway( );

    Returns

    SqlMap gateway instance.

    access

    protected

    [ Top ]

    TSqlMapConfig::getClient

    getClient( );

    Returns

    SqlMap gateway instance.

    Remarks

    Initialize the sqlmap if necessary, returns the TSqlMapGateway instance.

    access

    public

    [ Top ]

    TSqlMapConfig::getConfigFile

    getConfigFile( );

    Returns

    SqlMap configuration file.

    access

    public

    [ Top ]

    TSqlMapConfig::getEnableCache

    getEnableCache( );

    Returns

    true if configuration should be cached, false otherwise.

    access

    public

    [ Top ]

    TSqlMapConfig::getSqlMapManager

    getSqlMapManager( );

    Returns

    SqlMap manager instance

    Remarks

    Create and configure the data mapper using sqlmap configuration file.

    Or if cache is enabled and manager already cached load from cache. If cache is enabled, the data mapper instance is cached.

    since

    3.1.7

    access

    public

    [ Top ]

    TSqlMapConfig::loadCachedSqlMapManager

    loadCachedSqlMapManager( );

    Returns

    SqlMap manager intance if load was successful, null otherwise.

    Remarks

    Loads SqlMap manager from cache.

    access

    protected

    [ Top ]

    TSqlMapConfig::setConfigFile

    setConfigFile( string $value );

    Parameters

    $value

    external configuration file in namespace format. The file extension must be '.xml'.

    throws

    TConfigurationException if the file is invalid.

    access

    public

    [ Top ]

    TSqlMapConfig::setEnableCache

    setEnableCache( boolean $value );

    Parameters

    $value

    true to cache sqlmap instance.

    Remarks

    Set true to cache sqlmap instances.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • CONFIG_FILE_EXT = '.xml' [line 34]

    • Remarks

    File extension of external configuration file

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs For Class TInvalidPropertyException

Class TInvalidPropertyException

[line 108]
Exception
   |
   --TException
      |
      --TSqlMapException
         |
         --TInvalidPropertyException
Location: /Data/SqlMap/DataMapper/TSqlMapException.php

Remarks

TInvalidPropertyException, raised when setting or getting an invalid property.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapException.php 2541 2008-10-21 15:05:13Z qiang.xue $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapException

  • TSqlMapException::__construct()
    Constructor, similar to the parent constructor. For parameters that are of SimpleXmlElement, the tag name and its attribute names and values are expanded into a string.
  • TSqlMapException::getErrorMessageFile()
  • TSqlMapException::implodeNode()

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapConfigurationException

Class TSqlMapConfigurationException

[line 70]
Exception
   |
   --TException
      |
      --TSqlMapException
         |
         --TSqlMapConfigurationException
Location: /Data/SqlMap/DataMapper/TSqlMapException.php

Remarks

TSqlMapConfigurationException, raised during configuration file parsing.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapException.php 2541 2008-10-21 15:05:13Z qiang.xue $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapException

  • TSqlMapException::__construct()
    Constructor, similar to the parent constructor. For parameters that are of SimpleXmlElement, the tag name and its attribute names and values are expanded into a string.
  • TSqlMapException::getErrorMessageFile()
  • TSqlMapException::implodeNode()

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapDuplicateException

Class TSqlMapDuplicateException

[line 96]
Exception
   |
   --TException
      |
      --TSqlMapException
         |
         --TSqlMapDuplicateException
Location: /Data/SqlMap/DataMapper/TSqlMapException.php

Remarks

TSqlMapDuplicateException, raised when a duplicate mapped statement is found.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapException.php 2541 2008-10-21 15:05:13Z qiang.xue $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapException

  • TSqlMapException::__construct()
    Constructor, similar to the parent constructor. For parameters that are of SimpleXmlElement, the tag name and its attribute names and values are expanded into a string.
  • TSqlMapException::getErrorMessageFile()
  • TSqlMapException::implodeNode()

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:26 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapException

Class TSqlMapException

[line 11]
Exception
   |
   --TException
      |
      --TSqlMapException
Classes extended from TSqlMapException:
TSqlMapConfigurationException
TSqlMapConfigurationException, raised during configuration file parsing.
TSqlMapUndefinedException
TSqlMapUndefinedException, raised when mapped statemented are undefined.
TSqlMapDuplicateException
TSqlMapDuplicateException, raised when a duplicate mapped statement is found.
TInvalidPropertyException
TInvalidPropertyException, raised when setting or getting an invalid property.
TSqlMapExecutionException
TSqlMapException is the base exception class for all SqlMap exceptions.

Location: /Data/SqlMap/DataMapper/TSqlMapException.php

Remarks

TSqlMapException is the base exception class for all SqlMap exceptions.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapException.php 2541 2008-10-21 15:05:13Z qiang.xue $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Method Detail

    TSqlMapException::__construct

    __construct( $errorMessage );

    Overrides TException::__construct() (Constructor.)

    Parameters

    $errorMessage

    Remarks

    Constructor, similar to the parent constructor. For parameters that are of SimpleXmlElement, the tag name and its attribute names and values are expanded into a string.

    access

    public

    [ Top ]

    TSqlMapException::getErrorMessageFile

    getErrorMessageFile( );

    Overrides TException::getErrorMessageFile() (parent method not documented)

    Returns

    path to the error message file

    access

    protected

    [ Top ]

    TSqlMapException::implodeNode

    implodeNode( SimpleXmlElement $node );

    Parameters

    $node

    node

    Returns

    tag name and attribute names and values.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:26 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapExecutionException

Class TSqlMapExecutionException

[line 112]
Exception
   |
   --TException
      |
      --TSqlMapException
         |
         --TSqlMapExecutionException
Location: /Data/SqlMap/DataMapper/TSqlMapException.php

Remarks

TSqlMapException is the base exception class for all SqlMap exceptions.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapException.php 2541 2008-10-21 15:05:13Z qiang.xue $

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapException

  • TSqlMapException::__construct()
    Constructor, similar to the parent constructor. For parameters that are of SimpleXmlElement, the tag name and its attribute names and values are expanded into a string.
  • TSqlMapException::getErrorMessageFile()
  • TSqlMapException::implodeNode()

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:26 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapUndefinedException

Class TSqlMapUndefinedException

[line 83]
Exception
   |
   --TException
      |
      --TSqlMapException
         |
         --TSqlMapUndefinedException
Location: /Data/SqlMap/DataMapper/TSqlMapException.php

Remarks

TSqlMapUndefinedException, raised when mapped statemented are undefined.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapException.php 2541 2008-10-21 15:05:13Z qiang.xue $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Inherited From Class Exception (Internal Class)

  • $code =
  • $file =
  • $line =
  • $message =
  • $previous =
  • $string =
  • $trace =

Method Summary

Inherited Method Summary

Inherited From Class TSqlMapException

  • TSqlMapException::__construct()
    Constructor, similar to the parent constructor. For parameters that are of SimpleXmlElement, the tag name and its attribute names and values are expanded into a string.
  • TSqlMapException::getErrorMessageFile()
  • TSqlMapException::implodeNode()

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Inherited From Class Exception (Internal Class)

  • constructor __construct ( [$message = ], [$code = ], [$previous = ] )
  • getCode ( )
  • getFile ( )
  • getLine ( )
  • getMessage ( )
  • getPrevious ( )
  • getTrace ( )
  • getTraceAsString ( )
  • __clone ( )
  • __toString ( )

Method Detail

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:26 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapGateway

Class TSqlMapGateway

[line 30]
TComponent
   |
   --TSqlMapGateway
Location: /Data/SqlMap/TSqlMapGateway.php

Remarks

DataMapper client, a fascade to provide access the rest of the DataMapper framework. It provides three core functions:

  • execute an update query (including insert and delete).
  • execute a select query for a single object
  • execute a select query for a list of objects
This class should be instantiated from a TSqlMapManager instance.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapGateway.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqlMapGateway::__construct

    __construct( $manager );

    Parameters

    $manager

    access

    public

    [ Top ]

    TSqlMapGateway::delete

    delete( string $statementName, [mixed $parameter = null] );

    Parameters

    $statementName

    The name of the statement to execute.

    $parameter

    The parameter object.

    Returns

    The number of rows effected.

    Remarks

    Executes a Sql DELETE statement. Delete returns the number of rows effected.

    access

    public

    [ Top ]

    TSqlMapGateway::flushCaches

    flushCaches( );

    Remarks

    Flushes all cached objects that belong to this SqlMap

    access

    public

    [ Top ]

    TSqlMapGateway::getDbConnection

    getDbConnection( );

    Returns

    database connection.

    access

    public

    [ Top ]

    TSqlMapGateway::getSqlMapManager

    getSqlMapManager( );

    Returns

    sqlmap manager.

    access

    public

    [ Top ]

    TSqlMapGateway::insert

    insert( string $statementName, [string $parameter = null] );

    Parameters

    $statementName

    The name of the statement to execute.

    $parameter

    The parameter object.

    Returns

    The primary key of the newly inserted row. This might be automatically generated by the RDBMS, or selected from a sequence table or other source.

    Remarks

    Executes a Sql INSERT statement.

    Insert is a bit different from other update methods, as it provides facilities for returning the primary key of the newly inserted row (rather than the effected rows),

    The parameter object is generally used to supply the input data for the INSERT values.

    access

    public

    [ Top ]

    TSqlMapGateway::queryForList

    queryForList( string $statementName, [mixed $parameter = null], [TList $result = null], [int $skip = -1], [int $max = -1] );

    Parameters

    $statementName

    The name of the sql statement to execute.

    $parameter

    The object used to set the parameters in the SQL.

    $result

    An Ilist object used to hold the objects, pass in null if want to return a list instead.

    $skip

    The number of rows to skip over.

    $max

    The maximum number of rows to return.

    Returns

    A List of result objects.

    Remarks

    Executes a Sql SELECT statement that returns data to populate a number of result objects.

    The parameter object is generally used to supply the input data for the WHERE clause parameter(s) of the SELECT statement.

    access

    public

    [ Top ]

    TSqlMapGateway::queryForMap

    queryForMap(
string
$statementName, [mixed
$parameter = null], [string
$keyProperty = null], [string
$valueProperty = null], [
$skip = -1], [
$max = -1] );

    Parameters

    $statementName

    The name of the sql statement to execute.

    $parameter

    The object used to set the parameters in the SQL.

    $keyProperty

    The property of the result object to be used as the key.

    $valueProperty

    The property of the result object to be used as the value.

    $skip

    $max

    Returns

    Array object containing the rows keyed by keyProperty.

    Remarks

    Executes the SQL and retuns all rows selected in a map that is keyed on

    the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter. If valueProperty is null, the entire result object will be entered.

    access

    public

    [ Top ]

    TSqlMapGateway::queryForMapWithRowDelegate

    queryForMapWithRowDelegate( string $statementName, callback $delegate, [mixed $parameter = null], [string $keyProperty = null], [string $valueProperty = null], [ $skip = -1], [ $max = -1] );

    Parameters

    $statementName

    The name of the sql statement to execute.

    $delegate

    Row delegate handler, a valid callback required.

    $parameter

    The object used to set the parameters in the SQL.

    $keyProperty

    The property of the result object to be used as the key.

    $valueProperty

    The property of the result object to be used as the value.

    $skip

    $max

    Returns

    Array object containing the rows keyed by keyProperty.

    Remarks

    Runs a query with a custom object that gets a chance to deal with each row as it is processed.

    Example: $sqlmap->queryForMapWithRowDelegate('getAccounts', array($this, 'rowHandler'));

    access

    public

    [ Top ]

    TSqlMapGateway::queryForObject

    queryForObject( string $statementName, [mixed $parameter = null], [mixed $result = null] );

    Parameters

    $statementName

    The name of the sql statement to execute.

    $parameter

    The object used to set the parameters in the SQL.

    $result

    An object of the type to be returned.

    Returns

    single result object populated with the result set data.

    Remarks

    Executes a Sql SELECT statement that returns that returns data to populate a single object instance.

    The parameter object is generally used to supply the input data for the WHERE clause parameter(s) of the SELECT statement.

    access

    public

    [ Top ]

    TSqlMapGateway::queryForPagedList

    queryForPagedList( string $statementName, [mixed $parameter = null], [integer $pageSize = 10], [integer $page = 0] );

    Parameters

    $statementName

    The name of the sql statement to execute.

    $parameter

    The object used to set the parameters in the SQL.

    $pageSize

    The maximum number of objects to store in each page.

    $page

    The number of the page to initially load into the list.

    Returns

    A PaginatedList of beans containing the rows.

    Remarks

    Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.

    access

    public

    [ Top ]

    TSqlMapGateway::queryForPagedListWithRowDelegate

    queryForPagedListWithRowDelegate( string $statementName, callback $delegate, [mixed $parameter = null], [integer $pageSize = 10], [integer $page = 0] );

    Parameters

    $statementName

    The name of the sql statement to execute.

    $delegate

    Row delegate handler, a valid callback required.

    $parameter

    The object used to set the parameters in the SQL.

    $pageSize

    The maximum number of objects to store in each page.

    $page

    The number of the page to initially load into the list.

    Returns

    A PaginatedList of beans containing the rows.

    Remarks

    Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.

    Runs paged list query with row delegate Example: $sqlmap->queryForPagedListWithRowDelegate('getAccounts', array($this, 'rowHandler'));

    access

    public

    [ Top ]

    TSqlMapGateway::queryWithRowDelegate

    queryWithRowDelegate( string $statementName, callback $delegate, [mixed $parameter = null], [TList $result = null], [int $skip = -1], [int $max = -1] );

    Parameters

    $statementName

    The name of the sql statement to execute.

    $delegate

    Row delegate handler, a valid callback required.

    $parameter

    The object used to set the parameters in the SQL.

    $result

    An Ilist object used to hold the objects, pass in null if want to return a list instead.

    $skip

    The number of rows to skip over.

    $max

    The maximum number of rows to return.

    Returns

    A List of result objects.

    Remarks

    Runs a query for list with a custom object that gets a chance to deal with each row as it is processed.

    Example: $sqlmap->queryWithRowDelegate('getAccounts', array($this, 'rowHandler'));

    access

    public

    [ Top ]

    TSqlMapGateway::registerTypeHandler

    registerTypeHandler( TSqlMapTypeHandler $typeHandler );

    Parameters

    $typeHandler

    new type handler.

    access

    public

    [ Top ]

    TSqlMapGateway::update

    update( string $statementName, [mixed $parameter = null] );

    Parameters

    $statementName

    The name of the statement to execute.

    $parameter

    The parameter object.

    Returns

    The number of rows effected.

    Remarks

    Executes a Sql UPDATE statement.

    Update can also be used for any other update statement type, such as inserts and deletes. Update returns the number of rows effected.

    The parameter object is generally used to supply the input data for the UPDATE values as well as the WHERE clause parameter(s).

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:26 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapManager

Class TSqlMapManager

[line 44]
TComponent
   |
   --TSqlMapManager
Location: /Data/SqlMap/TSqlMapManager.php

Remarks

TSqlMapManager class holds the sqlmap configuation result maps, statements parameter maps and a type handler factory.

Use SqlMapGateway property to obtain the gateway instance used for querying statements defined in the SqlMap configuration files.

  •  $conn = new TDbConnection($dsn,$dbuser,$dbpass);
    •

  •  $manager = new TSqlMapManager($conn);
    •

  •  $manager->configureXml('mydb-sqlmap.xml');
    •

  •  $sqlmap = $manager->getSqlMapGateway();
    •

  •  $result = $sqlmap->queryForObject('Products');
    •

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: TSqlMapManager.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TSqlMapManager::__construct

      __construct( [TDbConnection $connection = null], string 1 );

      Parameters

      1

      configuration file.

      $connection

      database connection

      Remarks

      Constructor, create a new SqlMap manager.

      access

      public

      [ Top ]

      TSqlMapManager::addCacheModel

      addCacheModel( $cacheModel );

      Parameters

      $cacheModel

      the cache to add.

      Remarks

      Adds a named cache.

      throws

      TSqlMapConfigurationException

      access

      public

      [ Top ]

      TSqlMapManager::addMappedStatement

      addMappedStatement( $statement, IMappedStatement 1 );

      Parameters

      1

      The statement to add

      $statement

      The key name

      Remarks

      Adds a (named) MappedStatement.

      throws

      TSqlMapDuplicateException

      access

      public

      [ Top ]

      TSqlMapManager::addParameterMap

      addParameterMap( $parameter );

      Parameters

      $parameter

      add a new parameter map to this SQLMap.

      throws

      TSqlMapDuplicateException

      access

      public

      [ Top ]

      TSqlMapManager::addResultMap

      addResultMap( $result );

      Parameters

      $result

      add a new result map to this SQLMap

      throws

      TSqlMapDuplicateException

      access

      public

      [ Top ]

      TSqlMapManager::configureXml

      configureXml( string $file );

      Parameters

      $file

      xml configuration file.

      Remarks

      Loads and parses the SqlMap configuration file.

      access

      public

      [ Top ]

      TSqlMapManager::createSqlMapGateway

      createSqlMapGateway( );

      Returns

      create and configure a new TSqlMapGateway.

      Remarks

      Configures the current TSqlMapManager using the given xml configuration file defined in ConfigFile.

      access

      protected

      [ Top ]

      TSqlMapManager::flushCacheModels

      flushCacheModels( );

      Remarks

      Flushes all cached objects that belong to this SqlMap

      access

      public

      [ Top ]

      TSqlMapManager::getCacheDependencies

      getCacheDependencies( );

      since

      3.1.5

      access

      public

      [ Top ]

      TSqlMapManager::getCacheModel

      getCacheModel( string $name );

      Parameters

      $name

      the name of the cache to get.

      Returns

      the cache object.

      Remarks

      Gets a cache by name

      throws

      TSqlMapConfigurationException

      access

      public

      [ Top ]

      TSqlMapManager::getDbConnection

      getDbConnection( );

      Returns

      default database connection

      access

      public

      [ Top ]

      TSqlMapManager::getMappedStatement

      getMappedStatement( string $name );

      Parameters

      $name

      The name of the statement.

      Returns

      The MappedStatement

      Remarks

      Gets a MappedStatement by name.

      throws

      TSqlMapUndefinedException

      access

      public

      [ Top ]

      TSqlMapManager::getMappedStatements

      getMappedStatements( );

      Returns

      mapped statements collection.

      access

      public

      [ Top ]

      TSqlMapManager::getParameterMap

      getParameterMap( string $name );

      Parameters

      $name

      parameter map ID name.

      Returns

      the parameter with given ID.

      throws

      TSqlMapUndefinedException

      access

      public

      [ Top ]

      TSqlMapManager::getParameterMaps

      getParameterMaps( );

      Returns

      parameter maps collection.

      access

      public

      [ Top ]

      TSqlMapManager::getResultMap

      getResultMap( string $name );

      Parameters

      $name

      result name.

      Returns

      the result map.

      Remarks

      Gets a named result map

      throws

      TSqlMapUndefinedException

      access

      public

      [ Top ]

      TSqlMapManager::getResultMaps

      getResultMaps( );

      Returns

      result maps collection.

      access

      public

      [ Top ]

      TSqlMapManager::getSqlmapGateway

      getSqlmapGateway( );

      Returns

      SqlMap gateway.

      access

      public

      [ Top ]

      TSqlMapManager::getTypeHandlers

      getTypeHandlers( );

      Returns

      The TypeHandlerFactory

      access

      public

      [ Top ]

      TSqlMapManager::setDbConnection

      setDbConnection( TDbConnection $conn );

      Parameters

      $conn

      default database connection

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:26 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapPagedList

Class TSqlMapPagedList

[line 30]
TComponent
   |
   --TList
      |
      --TPagedList
         |
         --TSqlMapPagedList
Location: /Data/SqlMap/DataMapper/TSqlMapPagedList.php

Remarks

TSqlMapPagedList implements a list with paging functionality that retrieves data from a SqlMap statement.

The maximum number of records fetched is 3 times the page size. It fetches the current, the previous and the next page at a time. This allows the paged list to determine if the page is a the begin, the middle or the end of the list.

The paged list does not need to know about the total number of records.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqlMapPagedList.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TPagedList

  • TPagedList::__construct()
    Constructor.
  • TPagedList::getCount()
  • TPagedList::getCurrentPageIndex()
  • TPagedList::getCustomPaging()
  • TPagedList::getIsFirstPage()
  • TPagedList::getIsLastPage()
  • TPagedList::getIterator()
  • TPagedList::getPageCount()
  • TPagedList::getPageSize()
  • TPagedList::getVirtualCount()
  • TPagedList::gotoPage()
    Changes to a page with the specified page index.
  • TPagedList::indexOf()
  • TPagedList::itemAt()
    Returns the item at the specified offset.
  • TPagedList::nextPage()
    Switches to the next page.
  • TPagedList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TPagedList::offsetGet()
    Returns the item at the specified offset.
  • TPagedList::onFetchData()
    Raises OnFetchData event.
  • TPagedList::onPageIndexChanged()
    Raises OnPageIndexChanged event.
  • TPagedList::previousPage()
    Switches to the previous page.
  • TPagedList::setCurrentPageIndex()
  • TPagedList::setCustomPaging()
  • TPagedList::setPageSize()
  • TPagedList::setVirtualCount()
  • TPagedList::toArray()

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqlMapPagedList::__construct

    __construct( $statement, mixed $parameter, int $pageSize, [mixed $delegate = null], [int $page = 0] );

    Overrides TPagedList::__construct() (Constructor.)

    Parameters

    $statement

    SqlMap statement.

    $parameter

    query parameters

    $pageSize

    page size

    $delegate

    delegate for each data row retrieved.

    $page

    number of page to fetch on initialization

    Remarks

    Create a new SqlMap paged list.

    access

    public

    [ Top ]

    TSqlMapPagedList::fetchDataFromStatement

    fetchDataFromStatement( TPageList $sender, TPagedListFetchDataEventParameter $param );

    Parameters

    $sender

    current object.

    $param

    fetch parameters

    Remarks

    Fetch data by executing the SqlMap statement.

    access

    protected

    [ Top ]

    TSqlMapPagedList::getIsLastPage

    getIsLastPage( );

    Overrides TPagedList::getIsLastPage() (parent method not documented)

    Returns

    true if is the very last page, false otherwise.

    access

    public

    [ Top ]

    TSqlMapPagedList::getIsMiddlePage

    getIsMiddlePage( );

    Returns

    true if is not first nor last page, false otherwise.

    access

    public

    [ Top ]

    TSqlMapPagedList::getIsNextPageAvailable

    getIsNextPageAvailable( );

    Returns

    true if the next page is available, false otherwise.

    access

    public

    [ Top ]

    TSqlMapPagedList::getIsPreviousPageAvailable

    getIsPreviousPageAvailable( );

    Returns

    true if the previous page is available, false otherwise.

    access

    public

    [ Top ]

    TSqlMapPagedList::getOffsetAndLimit

    getOffsetAndLimit( TPagedListFetchDataEventParameter $param );

    Parameters

    $param

    fetch parameters

    Returns

    1st element is the offset, 2nd element is the limit.

    Remarks

    Calculate the data fetch offsets and limits.

    access

    protected

    [ Top ]

    TSqlMapPagedList::initialize

    initialize( IMappedStatement $statement, mixed $parameter, int $pageSize, int $page );

    Parameters

    $statement

    SqlMap statement.

    $parameter

    query parameters

    $pageSize

    page size.

    $page

    number of page.

    Remarks

    Initialize the paged list.

    access

    protected

    [ Top ]

    TSqlMapPagedList::nextPage

    nextPage( );

    Overrides TPagedList::nextPage() (Switches to the next page.)

    Returns

    the new page index, false if next page is not availabe.

    Remarks

    Switches to the next page.

    access

    public

    [ Top ]

    TSqlMapPagedList::populateData

    populateData( TPagedListFetchDataEventParameter $param, array $data );

    Parameters

    $param

    fetch parameters

    $data

    fetched data.

    Remarks

    Populate the list with the fetched data.

    access

    protected

    [ Top ]

    TSqlMapPagedList::previousPage

    previousPage( );

    Overrides TPagedList::previousPage() (Switches to the previous page.)

    Returns

    the new page index, false if previous page is not availabe.

    Remarks

    Switches to the previous page.

    access

    public

    [ Top ]

    TSqlMapPagedList::setCustomPaging

    setCustomPaging( $value );

    Overrides TPagedList::setCustomPaging() (parent method not documented)

    Parameters

    $value

    throws

    TSqlMapException custom paging must be enabled.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:26 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapTypeHandler

Class TSqlMapTypeHandler

[line 128]
TComponent
   |
   --TSqlMapTypeHandler
Location: /Data/SqlMap/DataMapper/TSqlMapTypeHandlerRegistry.php

Remarks

A simple interface for implementing custom type handlers.

Using this interface, you can implement a type handler that will perform customized processing before parameters are set on and after values are retrieved from the database. Using a custom type handler you can extend the framework to handle types that are not supported, or handle supported types in a different way. For example, you might use a custom type handler to implement proprietary BLOB support (e.g. Oracle), or you might use it to handle booleans using "Y" and "N" instead of the more typical 0/1.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapTypeHandlerRegistry.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqlMapTypeHandler::createNewInstance

    createNewInstance( [array $row = null] );

    Parameters

    $row

    result row.

    Remarks

    Casts the string representation of a value into a type recognized by

    this type handler. This method is used to translate nullValue values into types that can be appropriately compared. If your custom type handler cannot support nullValues, or if there is no reasonable string representation for this type (e.g. File type), you can simply return the String representation as it was passed in. It is not recommended to return null, unless null was passed in.

    abstract

    access

    public

    [ Top ]

    TSqlMapTypeHandler::getDbType

    getDbType( );

    Returns

    database field type.

    access

    public

    [ Top ]

    TSqlMapTypeHandler::getParameter

    getParameter( object The $object, object The 1 );

    Parameters

    1

    value to be set.

    $object

    interface for setting the value.

    Remarks

    Performs processing on a value before it is used to set the parameter of a IDbCommand.

    abstract

    access

    public

    [ Top ]

    TSqlMapTypeHandler::getResult

    getResult( object The $string );

    Parameters

    $string

    interface for getting the value.

    Returns

    The processed value.

    Remarks

    Performs processing on a value before after it has been retrieved

    from a database

    abstract

    access

    public

    [ Top ]

    TSqlMapTypeHandler::getType

    getType( );

    access

    public

    [ Top ]

    TSqlMapTypeHandler::setDbType

    setDbType( string $value );

    Parameters

    $value

    database field type.

    access

    public

    [ Top ]

    TSqlMapTypeHandler::setType

    setType( $value );

    Parameters

    $value

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:27 +0200 by phpDocumentor 1.4.3


Docs For Class TSqlMapTypeHandlerRegistry

Class TSqlMapTypeHandlerRegistry

[line 22]

Location: /Data/SqlMap/DataMapper/TSqlMapTypeHandlerRegistry.php

Remarks

TTypeHandlerFactory provides type handler classes to convert database field type  to PHP types and vice versa.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqlMapTypeHandlerRegistry.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TSqlMapTypeHandlerRegistry::convertToType

convertToType(
string
$type, mixed
$value );

    Parameters

    $type

    PHP primative type.

    $value

    value to be casted

    Returns

    type casted value.

    Remarks

    Converts the value to given type using PHP's settype() function.

    access

    public

    [ Top ]

    TSqlMapTypeHandlerRegistry::createInstanceOf

createInstanceOf(
[string
$type = ''] );

    Parameters

    $type

    PHP type name

    Returns

    default type value, if no type is specified null is returned.

    Remarks

    Creates a new instance of a particular class (for PHP primative types,  their corresponding default value for given type is used).

    throws

    TSqlMapException if class name is not found.

    access

    public

    [ Top ]

    TSqlMapTypeHandlerRegistry::getDbTypeHandler

getDbTypeHandler(
[string
$dbType = 'NULL'] );

    Parameters

    $dbType

    database field type

    Returns

    type handler for give database field type.

    access

    public

    [ Top ]

    TSqlMapTypeHandlerRegistry::getTypeHandler

getTypeHandler(
string
$class );

    Parameters

    $class

    type handler class name

    Returns

    type handler

    access

    public

    [ Top ]

    TSqlMapTypeHandlerRegistry::registerTypeHandler

registerTypeHandler(
TSqlMapTypeHandler
$handler );

    Parameters

    $handler

    registers a new type handler

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:28 +0200 by phpDocumentor 1.4.3


Package System.Web.Services Element Index

Element index for package System.Web.Services

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a b c d e f g h i l p r s t w _
top
_
__construct in file TRpcService.php, method TXmlRpcProtocol::__construct()
Constructor
__construct in file TSoapService.php, method TSoapService::__construct()
Constructor.
__construct in file TPageService.php, method TPageConfiguration::__construct()
Constructor.
__construct in file TRpcService.php, method TRpcServer::__construct()
Constructor
__construct | in file TRpcService.php, method TRpcException::__construct()
__construct | in file TRpcService.php, method TRpcApiProvider::__construct()
__destruct in file TRpcService.php, method TXmlRpcProtocol::__destruct()
Destructor
top
a
$apiProviders | in file TRpcService.php, variable TRpcService::$apiProviders
addMethod in file TRpcService.php, method TXmlRpcProtocol::addMethod()
Registers a new RPC method and handler details
addMethod in file TRpcService.php, method TRpcProtocol::addMethod()
Registers a new RPC method and handler details
addRpcMethod | in file TRpcService.php, method TRpcServer::addRpcMethod()
applyConfiguration in file TPageService.php, method TPageService::applyConfiguration()
Applies a page configuration.
top
b
BASE_API_PROVIDER in file TRpcService.php, class constant TRpcService::BASE_API_PROVIDER
const string base api provider class which every API must extend
BASE_RPC_SERVER in file TRpcService.php, class constant TRpcService::BASE_RPC_SERVER
const string base RPC server implementation
top
c
callApiMethod in file TRpcService.php, method TRpcProtocol::callApiMethod()
Calls the callback handler for the given method
callMethod in file TRpcService.php, method TXmlRpcProtocol::callMethod()
Handles the RPC request
callMethod in file TRpcService.php, method TJsonRpcProtocol::callMethod()
Handles the RPC request
callMethod | in file TRpcService.php, method TRpcProtocol::callMethod()
CONFIG_CACHE_PREFIX in file TPageService.php, class constant TPageService::CONFIG_CACHE_PREFIX
Prefix of ID used for storing parsed configuration in cache
CONFIG_FILE_PHP in file TPageService.php, class constant TPageService::CONFIG_FILE_PHP
Configuration file name
CONFIG_FILE_XML in file TPageService.php, class constant TPageService::CONFIG_FILE_XML
Configuration file name
constructUrl in file TPageService.php, method TPageService::constructUrl()
Constructs a URL with specified page path and GET parameters.
constructUrl in file TSoapService.php, method TSoapService::constructUrl()
Constructs a URL with specified page path and GET parameters.
createApiProvider in file TRpcService.php, method TRpcService::createApiProvider()
Creates the API provider instance for the current request
createErrorResponse in file TRpcService.php, method TXmlRpcProtocol::createErrorResponse()
Turns the given exception into an XML RPC fault
createErrorResponse | in file TRpcService.php, method TRpcProtocol::createErrorResponse()
createErrorResponse in file TRpcService.php, method TJsonRpcProtocol::createErrorResponse()
Turns the given exception into an JSON RPC fault
createJsonResponse in file TJsonService.php, method TJsonService::createJsonResponse()
Renders content provided by TJsonResponse::getJsonContent() as javascript in JSON format.
createPage in file TPageService.php, method TPageService::createPage()
Creates a page instance based on requested page path.
createResponseHeaders in file TRpcService.php, method TXmlRpcProtocol::createResponseHeaders()
Sets the correct response headers
createResponseHeaders in file TRpcService.php, method TJsonRpcProtocol::createResponseHeaders()
Sets the correct response headers
createResponseHeaders | in file TRpcService.php, method TRpcProtocol::createResponseHeaders()
createServer in file TSoapService.php, method TSoapService::createServer()
Creates the requested SOAP server.
createServer in file TSoapService.php, method TSoapServer::createServer()
Creates the SoapServer instance.
top
d
decode in file TRpcService.php, method TXmlRpcProtocol::decode()
Decodes XML encoded data into PHP data
decode | in file TRpcService.php, method TRpcProtocol::decode()
decode in file TRpcService.php, method TJsonRpcProtocol::decode()
Decodes JSON encoded data into PHP data
DEFAULT_BASEPATH in file TPageService.php, class constant TPageService::DEFAULT_BASEPATH
Default base path
DEFAULT_SOAP_SERVER | in file TSoapService.php, class constant TSoapService::DEFAULT_SOAP_SERVER
determineRequestedFeedPath | in file TFeedService.php, method TFeedService::determineRequestedFeedPath()
determineRequestedPagePath in file TPageService.php, method TPageService::determineRequestedPagePath()
Determines the requested page path.
top
e
encode in file TRpcService.php, method TXmlRpcProtocol::encode()
Encodes PHP data into XML data
encode | in file TRpcService.php, method TRpcProtocol::encode()
encode in file TRpcService.php, method TJsonRpcProtocol::encode()
Encodes PHP data into JSON data
top
f
FALLBACK_BASEPATH in file TPageService.php, class constant TPageService::FALLBACK_BASEPATH
Fallback base path - used to be the default up to Prado < 3.2
fault in file TSoapService.php, method TSoapServer::fault()
Generate a SOAP fault message.
top
g
getActor | in file TSoapService.php, method TSoapServer::getActor()
getApplicationConfigurations | in file TPageService.php, method TPageConfiguration::getApplicationConfigurations()
getBasePageClass | in file TPageService.php, method TPageService::getBasePageClass()
getBasePath | in file TPageService.php, method TPageService::getBasePath()
getClassMaps | in file TSoapService.php, method TSoapServer::getClassMaps()
getClientScriptManagerClass | in file TPageService.php, method TPageService::getClientScriptManagerClass()
getConfigFile | in file TSoapService.php, method TSoapService::getConfigFile()
getContentType in file TFeedService.php, method IFeedContentProvider::getContentType()
Sets the content type of the feed content to be sent.
getDefaultPage | in file TPageService.php, method TPageService::getDefaultPage()
getDefaultPageUrl | in file TPageService.php, method TPageService::getDefaultPageUrl()
getEncoding | in file TSoapService.php, method TSoapServer::getEncoding()
getExternalConfigurations | in file TPageService.php, method TPageConfiguration::getExternalConfigurations()
getFeedContent | in file TFeedService.php, method IFeedContentProvider::getFeedContent()
getID | in file TJsonService.php, method TJsonResponse::getID()
getID | in file TSoapService.php, method TSoapServer::getID()
getIsWsdlRequest | in file TSoapService.php, method TSoapService::getIsWsdlRequest()
getJsonContent | in file TJsonService.php, method TJsonResponse::getJsonContent()
getOptions | in file TSoapService.php, method TSoapServer::getOptions()
getPayload | in file TRpcService.php, method TRpcServer::getPayload()
getProperties in file TPageService.php, method TPageConfiguration::getProperties()
Returns list of page initial property values.
getProvider | in file TSoapService.php, method TSoapServer::getProvider()
getRequestedMethod in file TSoapService.php, method TSoapServer::getRequestedMethod()
Soap method guessed from the SOAP message received.
getRequestedPage | in file TPageService.php, method TPageService::getRequestedPage()
getRequestedPagePath | in file TPageService.php, method TPageService::getRequestedPagePath()
getRpcServer | in file TRpcService.php, method TRpcApiProvider::getRpcServer()
getRules in file TPageService.php, method TPageConfiguration::getRules()
Returns list of authorization rules.
getServerID | in file TSoapService.php, method TSoapService::getServerID()
getSessionPersistent | in file TSoapService.php, method TSoapServer::getSessionPersistent()
getTemplateManager | in file TPageService.php, method TPageService::getTemplateManager()
getThemeManager | in file TPageService.php, method TPageService::getThemeManager()
getUri | in file TSoapService.php, method TSoapServer::getUri()
getVersion | in file TSoapService.php, method TSoapServer::getVersion()
getWsdl in file TSoapService.php, method TSoapServer::getWsdl()
Returns the WSDL content of the SOAP server.
getWsdlUri | in file TSoapService.php, method TSoapServer::getWsdlUri()
guessMethodCallRequested in file TSoapService.php, method TSoapServer::guessMethodCallRequested()
Guess the SOAP method request from the actual SOAP message
top
h
$handler | in file TRpcService.php, variable TRpcServer::$handler
top
i
IFeedContentProvider in file TFeedService.php, class IFeedContentProvider
IFeedContentProvider interface.
init in file TPageService.php, method TPageService::init()
Initializes the service.
init in file TSoapService.php, method TSoapService::init()
Initializes this module.
init in file TRpcService.php, method TRpcService::init()
Initializes the service
init in file TJsonService.php, method TJsonService::init()
Initializes this module.
init in file TFeedService.php, method TFeedService::init()
Initializes this module.
init in file TJsonService.php, method TJsonResponse::init()
Initializes the feed.
init in file TFeedService.php, method IFeedContentProvider::init()
Initializes the feed content provider.
initPageContext in file TPageService.php, method TPageService::initPageContext()
Initializes page context.
top
l
loadApplicationConfigurationFromPhp | in file TPageService.php, method TPageConfiguration::loadApplicationConfigurationFromPhp()
loadApplicationConfigurationFromXml in file TPageService.php, method TPageConfiguration::loadApplicationConfigurationFromXml()
Loads the configuration specific for application part
loadConfig | in file TRpcService.php, method TRpcService::loadConfig()
loadFromFile in file TPageService.php, method TPageConfiguration::loadFromFile()
Loads a specific config file.
loadFromFiles in file TPageService.php, method TPageConfiguration::loadFromFiles()
Loads configuration for a page specified in a path format.
loadFromPhp | in file TPageService.php, method TPageConfiguration::loadFromPhp()
loadFromXml in file TPageService.php, method TPageConfiguration::loadFromXml()
Loads a page configuration.
loadJsonServices in file TJsonService.php, method TJsonService::loadJsonServices()
Load the service definitions.
loadPageConfig in file TPageService.php, method TPageService::loadPageConfig()
Collects configuration for a page.
loadPageConfigurationFromPhp | in file TPageService.php, method TPageConfiguration::loadPageConfigurationFromPhp()
loadPageConfigurationFromXml in file TPageService.php, method TPageConfiguration::loadPageConfigurationFromXml()
Loads the configuration specific for page service.
top
p
$protocolHandlers | in file TRpcService.php, variable TRpcService::$protocolHandlers
PAGE_FILE_EXT in file TPageService.php, class constant TPageService::PAGE_FILE_EXT
Page template file extension
processRequest | in file TRpcService.php, method TRpcApiProvider::processRequest()
processRequest | in file TRpcService.php, method TRpcServer::processRequest()
top
r
$rpcMethods | in file TRpcService.php, variable TRpcProtocol::$rpcMethods
$rpcServer | in file TRpcService.php, variable TRpcApiProvider::$rpcServer
registerMethods | in file TRpcService.php, method TRpcApiProvider::registerMethods()
resolveRequest in file TSoapService.php, method TSoapService::resolveRequest()
Resolves the request parameter.
run in file TSoapService.php, method TSoapServer::run()
Handles the SOAP request.
run in file TSoapService.php, method TSoapService::run()
Runs the service.
run in file TRpcService.php, method TRpcService::run()
Runs the service
run in file TJsonService.php, method TJsonService::run()
Runs the service.
run in file TPageService.php, method TPageService::run()
Runs the service.
run in file TFeedService.php, method TFeedService::run()
Runs the service.
runPage in file TPageService.php, method TPageService::runPage()
Executes a page.
top
s
setActor | in file TSoapService.php, method TSoapServer::setActor()
setBasePageClass in file TPageService.php, method TPageService::setBasePageClass()
Sets the base page class name (in namespace format).
setBasePath | in file TPageService.php, method TPageService::setBasePath()
setClassMaps | in file TSoapService.php, method TSoapServer::setClassMaps()
setClientScriptManagerClass in file TPageService.php, method TPageService::setClientScriptManagerClass()
Sets the clientscript manager class (in namespace format).
setConfigFile | in file TSoapService.php, method TSoapService::setConfigFile()
setDefaultPage | in file TPageService.php, method TPageService::setDefaultPage()
setEncoding | in file TSoapService.php, method TSoapServer::setEncoding()
setID | in file TSoapService.php, method TSoapServer::setID()
setID | in file TJsonService.php, method TJsonResponse::setID()
setProvider | in file TSoapService.php, method TSoapServer::setProvider()
setSessionPersistent | in file TSoapService.php, method TSoapServer::setSessionPersistent()
setTemplateManager | in file TPageService.php, method TPageService::setTemplateManager()
setThemeManager | in file TPageService.php, method TPageService::setThemeManager()
setUri | in file TSoapService.php, method TSoapServer::setUri()
setVersion | in file TSoapService.php, method TSoapServer::setVersion()
setWsdlUri | in file TSoapService.php, method TSoapServer::setWsdlUri()
top
t
TFeedService in file TFeedService.php, class TFeedService
TFeedService class
TJsonResponse in file TJsonService.php, class TJsonResponse
TJsonResponse Class
TJsonRpcProtocol in file TRpcService.php, class TJsonRpcProtocol
TJsonRpcProtocol class
TJsonService in file TJsonService.php, class TJsonService
TJsonService class provides to end-users javascript content response in JSON format.
TPageConfiguration in file TPageService.php, class TPageConfiguration
TPageConfiguration class
TPageService in file TPageService.php, class TPageService
TPageService class.
TRpcApiProvider in file TRpcService.php, class TRpcApiProvider
TRpcApiProvider class
TRpcException in file TRpcService.php, class TRpcException
TRpcException class
TRpcProtocol in file TRpcService.php, class TRpcProtocol
TRpcProtocol class
TRpcServer in file TRpcService.php, class TRpcServer
TRpcServer class
TRpcService in file TRpcService.php, class TRpcService
TRpcService class
TSoapServer in file TSoapService.php, class TSoapServer
TSoapServer class.
TSoapService in file TSoapService.php, class TSoapService
TSoapService class
TXmlRpcProtocol in file TRpcService.php, class TXmlRpcProtocol
TXmlRpcProtocol class
TFeedService.php | procedural page TFeedService.php
TJsonService.php | procedural page TJsonService.php
TPageService.php | procedural page TPageService.php
TRpcService.php | procedural page TRpcService.php
TSoapService.php | procedural page TSoapService.php
top
w
WSDL_CACHE_PREFIX | in file TSoapService.php, class constant TSoapServer::WSDL_CACHE_PREFIX


Class Trees for Package System.Web.Services

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TFeedService.php

File: /Web/Services/TFeedService.php

Remarks

TFeedService and TFeed class file

author

Knut Urdalen <knut.urdalen@gmail.com>

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com

license

http://www.pradosoft.com/license/

Classes in this file:
TFeedService
TFeedService class
IFeedContentProvider
IFeedContentProvider interface.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:20 +0200 by phpDocumentor 1.4.3


Docs for page TJsonService.php

File: /Web/Services/TJsonService.php

Remarks

TJsonService and TJsonResponse class file.

author

Wei Zhuo <weizhuo[at]gamil[dot]com>

version

$Id: TJsonService.php 3097 2012-01-25 10:07:41Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TJsonService
TJsonService class provides to end-users javascript content response in JSON format.
TJsonResponse
TJsonResponse Class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:39 +0200 by phpDocumentor 1.4.3


Docs for page TPageService.php

File: /Web/Services/TPageService.php

Remarks

TPageService class file.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPageService.php 3079 2011-12-05 16:30:49Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPageService
TPageService class.
TPageConfiguration
TPageConfiguration class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:59 +0200 by phpDocumentor 1.4.3


Docs for page TRpcService.php

File: /Web/Services/TRpcService.php

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

copyright

2010 Bigpoint GmbH

link

http://www.pradosoft.com/

since

3.2

license

http://www.pradosoft.com/license/

Classes in this file:
TRpcService
TRpcService class
TRpcServer
TRpcServer class
TRpcException
TRpcException class
TRpcApiProvider
TRpcApiProvider class
TRpcProtocol
TRpcProtocol class
TJsonRpcProtocol
TJsonRpcProtocol class
TXmlRpcProtocol
TXmlRpcProtocol class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs for page TSoapService.php

File: /Web/Services/TSoapService.php

Remarks

TSoapService and TSoapServer class file

author

Qiang Xue <qiang.xue@gmail.com>

author

Knut Urdalen <knut.urdalen@gmail.com>

version

$Id: TSoapService.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSoapService
TSoapService class
TSoapServer
TSoapServer class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:23 +0200 by phpDocumentor 1.4.3


Docs For Class IFeedContentProvider

Interface IFeedContentProvider

[line 162]

Location: /Web/Services/TFeedService.php

Remarks

IFeedContentProvider interface.

IFeedContentProvider interface must be implemented by a feed class who  provides feed content.

author

Knut Urdalen <knut.urdalen@gmail.com>

author

Qiang Xue <qiang.xue@gmail.com>

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    IFeedContentProvider::getContentType

getContentType(
 );

    Returns

    the content type for the feed content.

    Remarks

    Sets the content type of the feed content to be sent.

    Some examples are:  RSS 1.0 feed: application/rdf+xml  RSS 2.0 feed: application/rss+xml or application/xml or text/xml  ATOM feed: application/atom+xml

    since

    3.1.1

    access

    public

    [ Top ]

    IFeedContentProvider::getFeedContent

getFeedContent(
 );

    Returns

    feed content in proper XML format

    access

    public

    [ Top ]

    IFeedContentProvider::init

init(
TXmlElement
$config );

    Parameters

    $config

    configurations specified within the &lt;feed&gt; element  corresponding to this feed provider when configuring TFeedService.

    Remarks

    Initializes the feed content provider.

    This method is invoked (before getFeedContent)  when the feed provider is requested by a user.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:20 +0200 by phpDocumentor 1.4.3


Docs For Class TFeedService

Class TFeedService

[line 59]
TComponent
   |
   --TApplicationComponent
      |
      --TService
         |
         --TFeedService
Location: /Web/Services/TFeedService.php

Remarks

TFeedService class

TFeedService provides to end-users feed content.

TFeedService manages a set of feeds. The service parameter, referring to the ID of the feed, specifies which feed content to be provided to end-users.

To use TFeedService, configure it in application configuration as follows,

  •   <service id="feed" class="System.Web.Services.TFeedService">
    •

  •     <feed id="ch1" class="Path.To.FeedClass1" .../>
    •

  •     <feed id="ch2" class="Path.To.FeedClass2" .../>
    •

  •     <feed id="ch3" class="Path.To.FeedClass3" .../>
    •

  •   </service>
    •
    where each &lt;feed&gt; element specifies a feed identified by its "id" value (case-sensitive).

    PHP configuration style:

  •  array(
    •

  •    'feed' => array(
    •

  •        'ch1' => array(
    •

  •        'class' => 'Path.To.FeedClass1',
    •

  •        'properties' => array(
    •

  •           ...
    •

  •         ),
    •

  •    ),
    •

  •  )
    •

    The class attribute indicates which PHP class will provide the actual feed content. Note, the class must implement IFeedContentProvider interface. Other initial properties for the feed class may also be specified in the corresponding &lt;feed&gt; element.

    To retrieve the feed content identified by "ch2", use the URL

  • /path/to/index.php?feed=ch2
    •

    author

    Carl G. Mathisen <carlgmathisen@gmail.com>

    author

    Qiang Xue <qiang.xue@gmail.com>

    author

    Knut Urdalen <knut.urdalen@gmail.com>

    version

    $Id: TService.php 3102 2012-02-05 17:00:00Z ctrlaltca@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TService

    • TService::getEnabled()
    • TService::getID()
    • TService::init()
      Initializes the service and attaches run to the RunService event of application.
    • TService::run()
      Runs the service.
    • TService::setEnabled()
    • TService::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TFeedService::determineRequestedFeedPath

      determineRequestedFeedPath( );

      Returns

      the requested feed path

      access

      protected

      [ Top ]

      TFeedService::init

      init( mixed $config );

      Overrides TService::init() (Initializes the service and attaches run to the RunService event of application.)

      Parameters

      $config

      configuration for this module, can be null

      Remarks

      Initializes this module.

      This method is required by the IModule interface.

      access

      public

      [ Top ]

      TFeedService::run

      run( );

      Overrides TService::run() (Runs the service.)

      Remarks

      Runs the service.

      This method is invoked by application automatically.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:20 +0200 by phpDocumentor 1.4.3


Docs For Class TJsonResponse

Class TJsonResponse

[line 179]
TComponent
   |
   --TApplicationComponent
      |
      --TJsonResponse
Location: /Web/Services/TJsonService.php

Remarks

TJsonResponse Class

TJsonResponse is the base class for all JSON response provider classes.

Derived classes must implement getJsonContent() to return an object or literals to be converted to JSON format. The response will be empty if the returned content is null.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TJsonService.php 3097 2012-01-25 10:07:41Z ctrlaltca@gmail.com $

abstract

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TJsonResponse::getID

    getID( );

    Returns

    ID of this response

    access

    public

    [ Top ]

    TJsonResponse::getJsonContent

    getJsonContent( );

    Returns

    response content, null to suppress output.

    abstract

    access

    public

    [ Top ]

    TJsonResponse::init

    init( TXmlElement $config );

    Parameters

    $config

    configurations specified in TJsonService.

    Remarks

    Initializes the feed.

    access

    public

    [ Top ]

    TJsonResponse::setID

    setID( string $value );

    Parameters

    $value

    ID of this response

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:39 +0200 by phpDocumentor 1.4.3


Docs For Class TJsonService

Class TJsonService

[line 54]
TComponent
   |
   --TApplicationComponent
      |
      --TService
         |
         --TJsonService
Location: /Web/Services/TJsonService.php

Remarks

TJsonService class provides to end-users javascript content response in JSON format.

TJsonService manages a set of TJsonResponse, each representing specific response with javascript content. The service parameter, referring to the ID of the service, specifies which javascript content to be provided to end-users.

To use TJsonService, configure it in application configuration as follows,

  •   <service id="json" class="System.Web.Services.TJsonService">
    •

  •     <json id="get_article" class="Path.To.JsonResponseClass1" .../>
    •

  •     <json id="register_rating" class="Path.To.JsonResponseClass2" .../>
    •

  •   </service>
    •
    where each JSON response is specified via a &lt;json&gt; element. Initial property values can be configured in a &lt;json&gt; element.

    PHP configuration style:

  •   'services' => array(
    •

  •     'get_article' => array(
    •

  •      'class' => 'Path.To.JsonResponseClass1',
    •

  •      'properties' => array(
    •

  •        ...
    •

  •         )
    •

  •     )
    •

  •   )
    •

    To retrieve the JSON content provided by "get_article", use the URL

  • index.php?json=get_article
    •

    author

    Carl G. Mathisen <carlgmathisen@gmail.com>

    author

    Wei Zhuo <weizhuo[at]gmail[dot]com>

    version

    $Id: TJsonService.php 3097 2012-01-25 10:07:41Z ctrlaltca@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TService

    • TService::getEnabled()
    • TService::getID()
    • TService::init()
      Initializes the service and attaches run to the RunService event of application.
    • TService::run()
      Runs the service.
    • TService::setEnabled()
    • TService::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TJsonService::createJsonResponse

      createJsonResponse( $service, $properties, $config );

      Parameters

      $service

      $properties

      $config

      Remarks

      Renders content provided by TJsonResponse::getJsonContent() as javascript in JSON format.

      access

      protected

      [ Top ]

      TJsonService::init

      init( mixed $xml );

      Overrides TService::init() (Initializes the service and attaches run to the RunService event of application.)

      Parameters

      $xml

      configuration for this module, can be null

      Remarks

      Initializes this module.

      This method is required by the IModule interface.

      access

      public

      [ Top ]

      TJsonService::loadJsonServices

      loadJsonServices( mixed $config );

      Parameters

      $config

      configuration for this module, can be null

      Remarks

      Load the service definitions.

      access

      protected

      [ Top ]

      TJsonService::run

      run( );

      Overrides TService::run() (Runs the service.)

      Remarks

      Runs the service.

      This method is invoked by application automatically.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:44:39 +0200 by phpDocumentor 1.4.3


Docs For Class TPageConfiguration

Class TPageConfiguration

[line 554]
TComponent
   |
   --TPageConfiguration
Location: /Web/Services/TPageService.php

Remarks

TPageConfiguration class

TPageConfiguration represents the configuration for a page. The page is specified by a dot-connected path. Configurations along this path are merged together to be provided for the page.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPageService.php 3079 2011-12-05 16:30:49Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPageConfiguration::__construct

    __construct( string $pagePath );

    Parameters

    $pagePath

    the currently request page in the format of Path.To.PageName

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TPageConfiguration::getApplicationConfigurations

    getApplicationConfigurations( );

    Returns

    list of application configurations specified along page path

    access

    public

    [ Top ]

    TPageConfiguration::getExternalConfigurations

    getExternalConfigurations( );

    Returns

    list of external configuration files. Each element is like $filePath=>$condition

    access

    public

    [ Top ]

    TPageConfiguration::getProperties

    getProperties( );

    Returns

    list of page initial property values

    Remarks

    Returns list of page initial property values.

    Each array element represents a single property with the key being the property name and the value the initial property value.

    access

    public

    [ Top ]

    TPageConfiguration::getRules

    getRules( );

    Returns

    collection of authorization rules

    Remarks

    Returns list of authorization rules.

    The authorization rules are aggregated (bottom-up) from configuration files along the path to the specified page.

    access

    public

    [ Top ]

    TPageConfiguration::loadApplicationConfigurationFromPhp

    loadApplicationConfigurationFromPhp( $config, $configPath );

    Parameters

    $config

    $configPath

    access

    public

    [ Top ]

    TPageConfiguration::loadApplicationConfigurationFromXml

    loadApplicationConfigurationFromXml( TXmlElement $dom, string $configPath );

    Parameters

    $dom

    config xml element

    $configPath

    base path corresponding to this xml element

    Remarks

    Loads the configuration specific for application part

    access

    public

    [ Top ]

    TPageConfiguration::loadFromFile

    loadFromFile( string $fname, string $configPagePath );

    Parameters

    $fname

    config file name

    $configPagePath

    the page path that the config file is associated with. The page path doesn't include the page name.

    Remarks

    Loads a specific config file.

    access

    public

    [ Top ]

    TPageConfiguration::loadFromFiles

    loadFromFiles( string $basePath );

    Parameters

    $basePath

    root path for pages

    Remarks

    Loads configuration for a page specified in a path format.

    access

    public

    [ Top ]

    TPageConfiguration::loadFromPhp

    loadFromPhp( $config, $configPath, $configPagePath );

    Parameters

    $config

    $configPath

    $configPagePath

    access

    public

    [ Top ]

    TPageConfiguration::loadFromXml

    loadFromXml( TXmlElement $dom, string $configPath, string $configPagePath );

    Parameters

    $dom

    config xml element

    $configPath

    the directory containing this configuration

    $configPagePath

    the page path that the config XML is associated with. The page path doesn't include the page name.

    Remarks

    Loads a page configuration.

    The configuration includes information for both application and page service.

    access

    public

    [ Top ]

    TPageConfiguration::loadPageConfigurationFromPhp

    loadPageConfigurationFromPhp( $config, $configPath, $configPagePath );

    Parameters

    $config

    $configPath

    $configPagePath

    access

    public

    [ Top ]

    TPageConfiguration::loadPageConfigurationFromXml

    loadPageConfigurationFromXml( TXmlElement $dom, string $configPath, string $configPagePath );

    Parameters

    $dom

    config xml element

    $configPath

    base path corresponding to this xml element

    $configPagePath

    the page path that the config XML is associated with. The page path doesn't include the page name.

    Remarks

    Loads the configuration specific for page service.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:59 +0200 by phpDocumentor 1.4.3


Docs For Class TPageService

Class TPageService

[line 77]
TComponent
   |
   --TApplicationComponent
      |
      --TService
         |
         --TPageService
Location: /Web/Services/TPageService.php

Remarks

TPageService class.

TPageService implements the service for serving user page requests.

Pages that are available to client users are stored under a directory specified by BasePath. The directory may contain subdirectories. Pages serving for a similar goal are usually placed under the same directory. A directory may contain a configuration file config.xml whose content is similar to that of application configuration file.

A page is requested via page path, which is a dot-connected directory names appended by the page name. Assume '<BasePath>/Users/Admin' is the directory containing the page 'Update'. Then the page can be requested via 'Users.Admin.Update'. By default, the BasePath of the page service is the "pages" directory under the application base path. You may change this default by setting BasePath with a different path you prefer.

Page name refers to the file name (without extension) of the page template. In order to differentiate from the common control template files, the extension name of the page template files must be '.page'. If there is a PHP file with the same page name under the same directory as the template file, that file will be considered as the page class file and the file name is the page class name. If such a file is not found, the page class is assumed as TPage.

Modules can be configured and loaded in page directory configurations. Configuration of a module in a subdirectory will overwrite its parent directory's configuration, if both configurations refer to the same module.

By default, TPageService will automatically load two modules:

  • TTemplateManager : manages page and control templates
  • TThemeManager : manages themes used in a Prado application
In page directory configurations, static authorization rules can also be specified, which governs who and which roles can access particular pages. Refer to TAuthorizationRule for more details about authorization rules. Page authorization rules can be configured within an <authorization> tag in each page directory configuration as follows, <authorization> <deny pages="Update" users="?" /> <allow pages="Admin" roles="administrator" /> <deny pages="Admin" users="*" /> </authorization> where the 'pages' attribute may be filled with a sequence of comma-separated page IDs. If 'pages' attribute does not appear in a rule, the rule will be applied to all pages in this directory and all subdirectories (recursively). Application of authorization rules are in a bottom-up fashion, starting from the directory containing the requested page up to all parent directories. The first matching rule will be used. The last rule always allows all users accessing to any resources.

author

Carl G. Mathisen <carlgmathisen@gmail.com>

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TPageService.php 3079 2011-12-05 16:30:49Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

  • CONFIG_CACHE_PREFIX = 'prado:pageservice:'
    Prefix of ID used for storing parsed configuration in cache
  • CONFIG_FILE_PHP = 'config.php'
    Configuration file name
  • CONFIG_FILE_XML = 'config.xml'
    Configuration file name
  • DEFAULT_BASEPATH = 'Pages'
    Default base path
  • FALLBACK_BASEPATH = 'pages'
    Fallback base path - used to be the default up to Prado < 3.2
  • PAGE_FILE_EXT = '.page'
    Page template file extension

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TService

  • TService::getEnabled()
  • TService::getID()
  • TService::init()
    Initializes the service and attaches run to the RunService event of application.
  • TService::run()
    Runs the service.
  • TService::setEnabled()
  • TService::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPageService::applyConfiguration

    applyConfiguration( TPageConfiguration $config );

    Parameters

    $config

    the configuration

    Remarks

    Applies a page configuration.

    access

    protected

    [ Top ]

    TPageService::constructUrl

    constructUrl( string $pagePath, [array $getParams = null], [boolean $encodeAmpersand = true], [boolean $encodeGetItems = true] );

    Parameters

    $pagePath

    page path

    $getParams

    list of GET parameters, null if no GET parameters required

    $encodeAmpersand

    whether to encode the ampersand in URL, defaults to true.

    $encodeGetItems

    whether to encode the GET parameters (their names and values), defaults to true.

    Returns

    URL for the page and GET parameters

    Remarks

    Constructs a URL with specified page path and GET parameters.

    access

    public

    [ Top ]

    TPageService::createPage

    createPage( string $pagePath );

    Parameters

    $pagePath

    requested page path

    Returns

    the requested page instance

    Remarks

    Creates a page instance based on requested page path.

    throws

    TConfigurationException if the page class cannot be found

    throws

    THttpException if requested page path is invalid

    access

    protected

    [ Top ]

    TPageService::determineRequestedPagePath

    determineRequestedPagePath( );

    Returns

    page path requested

    Remarks

    Determines the requested page path.

    access

    protected

    [ Top ]

    TPageService::getBasePageClass

    getBasePageClass( );

    Returns

    base page class name in namespace format. Defaults to 'TPage'.

    access

    public

    [ Top ]

    TPageService::getBasePath

    getBasePath( );

    Returns

    the root directory for storing pages. Defaults to the 'pages' directory under the application base path.

    access

    public

    [ Top ]

    TPageService::getClientScriptManagerClass

    getClientScriptManagerClass( );

    Returns

    clientscript manager class in namespace format. Defaults to 'System.Web.UI.TClientScriptManager'.

    since

    3.1.7

    access

    public

    [ Top ]

    TPageService::getDefaultPage

    getDefaultPage( );

    Returns

    default page path to be served if no explicit page is request. Defaults to 'Home'.

    access

    public

    [ Top ]

    TPageService::getDefaultPageUrl

    getDefaultPageUrl( );

    Returns

    the URL for the default page

    access

    public

    [ Top ]

    TPageService::getRequestedPage

    getRequestedPage( );

    Returns

    the requested page

    access

    public

    [ Top ]

    TPageService::getRequestedPagePath

    getRequestedPagePath( );

    Returns

    the requested page path

    access

    public

    [ Top ]

    TPageService::getTemplateManager

    getTemplateManager( );

    Returns

    template manager

    access

    public

    [ Top ]

    TPageService::getThemeManager

    getThemeManager( );

    Returns

    theme manager

    access

    public

    [ Top ]

    TPageService::init

    init( TXmlElement $config );

    Overrides TService::init() (Initializes the service and attaches run to the RunService event of application.)

    Parameters

    $config

    service configuration

    Remarks

    Initializes the service.

    This method is required by IService interface and is invoked by application.

    access

    public

    [ Top ]

    TPageService::initPageContext

    initPageContext( TPageConfiguration $pageConfig );

    Parameters

    $pageConfig

    Remarks

    Initializes page context.

    Page context includes path alias settings, namespace usages, parameter initialization, module loadings, page initial properties and authorization rules.

    access

    protected

    [ Top ]

    TPageService::loadPageConfig

    loadPageConfig( TXmlElement $config );

    Parameters

    $config

    additional configuration specified in the application configuration

    Remarks

    Collects configuration for a page.

    access

    protected

    [ Top ]

    TPageService::run

    run( );

    Overrides TService::run() (Runs the service.)

    Remarks

    Runs the service.

    This will create the requested page, initializes it with the property values specified in the configuration, and executes the page.

    access

    public

    [ Top ]

    TPageService::runPage

    runPage( TPage $page, array $properties );

    Parameters

    $page

    the page instance to be run

    $properties

    list of initial page properties

    Remarks

    Executes a page.

    access

    protected

    [ Top ]

    TPageService::setBasePageClass

    setBasePageClass( string $value );

    Parameters

    $value

    class name

    Remarks

    Sets the base page class name (in namespace format).

    If a page only has a template file without page class file, this base page class will be instantiated.

    access

    public

    [ Top ]

    TPageService::setBasePath

    setBasePath( string $value );

    Parameters

    $value

    root directory (in namespace form) storing pages

    throws

    TInvalidOperationException if the service is initialized already or basepath is invalid

    access

    public

    [ Top ]

    TPageService::setClientScriptManagerClass

    setClientScriptManagerClass( string $value );

    Parameters

    $value

    class name

    Remarks

    Sets the clientscript manager class (in namespace format).

    since

    3.1.7

    access

    public

    [ Top ]

    TPageService::setDefaultPage

    setDefaultPage( string $value );

    Parameters

    $value

    default page path to be served if no explicit page is request

    throws

    TInvalidOperationException if the page service is initialized

    access

    public

    [ Top ]

    TPageService::setTemplateManager

    setTemplateManager( $value );

    Parameters

    $value

    template manager

    access

    public

    [ Top ]

    TPageService::setThemeManager

    setThemeManager( $value );

    Parameters

    $value

    theme manager

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • CONFIG_CACHE_PREFIX = 'prado:pageservice:' [line 98]

    • Remarks

    Prefix of ID used for storing parsed configuration in cache

  • CONFIG_FILE_PHP = 'config.php' [line 86]

    • Remarks

    Configuration file name

  • CONFIG_FILE_XML = 'config.xml' [line 82]

    • Remarks

    Configuration file name

  • DEFAULT_BASEPATH = 'Pages' [line 90]

    • Remarks

    Default base path

  • FALLBACK_BASEPATH = 'pages' [line 94]

    • Remarks

    Fallback base path - used to be the default up to Prado < 3.2

  • PAGE_FILE_EXT = '.page' [line 102]

    • Remarks

    Page template file extension

Documentation generated on Mon, 25 Jun 2012 14:45:00 +0200 by phpDocumentor 1.4.3


Docs For Class TJsonRpcProtocol

Class TJsonRpcProtocol

[line 328]
TRpcProtocol
   |
   --TJsonRpcProtocol
Location: /Web/Services/TRpcService.php

Remarks

TJsonRpcProtocol class

Implements the JSON RPC protocol

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TRpcProtocol

  • TRpcProtocol::$rpcMethods = array()

Method Summary

Inherited Method Summary

Inherited From Class TRpcProtocol

  • TRpcProtocol::addMethod()
    Registers a new RPC method and handler details
  • TRpcProtocol::callApiMethod()
    Calls the callback handler for the given method
  • TRpcProtocol::callMethod()
  • TRpcProtocol::createErrorResponse()
  • TRpcProtocol::createResponseHeaders()
  • TRpcProtocol::decode()
  • TRpcProtocol::encode()

Method Detail

    TJsonRpcProtocol::callMethod

    callMethod( string $requestPayload );

    Overrides TRpcProtocol::callMethod() (parent method not documented)

    Parameters

    $requestPayload

    Returns

    JSON RPC response

    Remarks

    Handles the RPC request

    access

    public

    [ Top ]

    TJsonRpcProtocol::createErrorResponse

    createErrorResponse( TRpcException $exception );

    Overrides TRpcProtocol::createErrorResponse() (parent method not documented)

    Parameters

    $exception

    Returns

    JSON RPC fault

    Remarks

    Turns the given exception into an JSON RPC fault

    access

    public

    [ Top ]

    TJsonRpcProtocol::createResponseHeaders

    createResponseHeaders( THttpResponse $response );

    Overrides TRpcProtocol::createResponseHeaders() (parent method not documented)

    Parameters

    $response

    Remarks

    Sets the correct response headers

    access

    public

    [ Top ]

    TJsonRpcProtocol::decode

    decode( string $data );

    Overrides TRpcProtocol::decode() (parent method not documented)

    Parameters

    $data

    in JSON format

    Returns

    PHP data

    Remarks

    Decodes JSON encoded data into PHP data

    access

    public

    [ Top ]

    TJsonRpcProtocol::encode

    encode( mixed $data );

    Overrides TRpcProtocol::encode() (parent method not documented)

    Parameters

    $data

    PHP data

    Returns

    JSON encoded PHP data

    Remarks

    Encodes PHP data into JSON data

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:15 +0200 by phpDocumentor 1.4.3


Docs For Class TRpcApiProvider

Class TRpcApiProvider

[line 234]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TRpcApiProvider
Location: /Web/Services/TRpcService.php

Remarks

TRpcApiProvider class

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

abstract

since

3.2

Class Variable Summary

  • $rpcServer =

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRpcApiProvider::__construct

    __construct( TRpcServer $rpcServer );

    Parameters

    $rpcServer

    access

    public

    [ Top ]

    TRpcApiProvider::getRpcServer

    getRpcServer( );

    access

    public

    [ Top ]

    TRpcApiProvider::processRequest

    processRequest( );

    access

    public

    [ Top ]

    TRpcApiProvider::registerMethods

    registerMethods( );

    abstract

    access

    public

    [ Top ]

Variable Detail

  • $rpcServer = [line 239]
  • Data type: TRpcServer

    • var

    instance

    access

    protected

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:16 +0200 by phpDocumentor 1.4.3


Docs For Class TRpcException

Class TRpcException

[line 216]
Exception
   |
   --TException
      |
      --TRpcException
Location: /Web/Services/TRpcService.php

Remarks

TRpcException class

A TRpcException represents a RPC fault i.e. an error that is caused by the input data sent from the client.

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TException

  • TException::$_messageCache = array()

Method Summary

Inherited Method Summary

Inherited From Class TException

  • TException::__construct()
    Constructor.
  • TException::getErrorCode()
  • TException::getErrorMessage()
  • TException::getErrorMessageFile()
  • TException::setErrorCode()
  • TException::setErrorMessage()
  • TException::translateErrorMessage()
    Translates an error code into an error message.

Method Detail

    TRpcException::__construct

    __construct( $message, [ $errorCode = -1] );

    Overrides TException::__construct() (Constructor.)

    Parameters

    $message

    $errorCode

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:16 +0200 by phpDocumentor 1.4.3


Docs For Class TRpcProtocol

Class TRpcProtocol

[line 276]

Classes extended from TRpcProtocol:

TJsonRpcProtocol

TJsonRpcProtocol class

TXmlRpcProtocol

TXmlRpcProtocol class

Location: /Web/Services/TRpcService.php

Remarks

TRpcProtocol class

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

abstract

since

3.2

Class Variable Summary

  • $rpcMethods = array()

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TRpcProtocol::addMethod

addMethod(
string
$methodName, array
$handlerDetails );

    Overridden in child classes as:

    TXmlRpcProtocol::addMethod()

    Registers a new RPC method and handler details

    Parameters

    $methodName

    $handlerDetails

    containing the callback handler

    Remarks

    Registers a new RPC method and handler details

    access

    public

    [ Top ]

    TRpcProtocol::callApiMethod

callApiMethod(
string
$methodName, array
$parameters );

    Parameters

    $methodName

    of the RPC

    $parameters

    for the callback handler as provided by the client

    Returns

    whatever the callback handler returns

    Remarks

    Calls the callback handler for the given method

    access

    public

    [ Top ]

    TRpcProtocol::callMethod

callMethod(

$requestPayload );

    Overridden in child classes as:

    TJsonRpcProtocol::callMethod()

    Handles the RPC request

    TXmlRpcProtocol::callMethod()

    Handles the RPC request

    Parameters

    $requestPayload

    abstract

    access

    public

    [ Top ]

    TRpcProtocol::createErrorResponse

createErrorResponse(
TRpcException
$exception );

    Overridden in child classes as:

    TJsonRpcProtocol::createErrorResponse()

    Turns the given exception into an JSON RPC fault

    TXmlRpcProtocol::createErrorResponse()

    Turns the given exception into an XML RPC fault

    Parameters

    $exception

    abstract

    access

    public

    [ Top ]

    TRpcProtocol::createResponseHeaders

createResponseHeaders(

$response );

    Overridden in child classes as:

    TJsonRpcProtocol::createResponseHeaders()

    Sets the correct response headers

    TXmlRpcProtocol::createResponseHeaders()

    Sets the correct response headers

    Parameters

    $response

    abstract

    access

    public

    [ Top ]

    TRpcProtocol::decode

decode(

$data );

    Overridden in child classes as:

    TJsonRpcProtocol::decode()

    Decodes JSON encoded data into PHP data

    TXmlRpcProtocol::decode()

    Decodes XML encoded data into PHP data

    Parameters

    $data

    abstract

    access

    public

    [ Top ]

    TRpcProtocol::encode

encode(

$data );

    Overridden in child classes as:

    TJsonRpcProtocol::encode()

    Encodes PHP data into JSON data

    TXmlRpcProtocol::encode()

    Encodes PHP data into XML data

    Parameters

    $data

    abstract

    access

    public

    [ Top ]

Variable Detail

  • $rpcMethods = array() [line 281]
    •

  • Data type: array
    •

    var

    containis the mapping from RPC method names to the actual handlers

    access

    protected

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:16 +0200 by phpDocumentor 1.4.3


Docs For Class TRpcServer

Class TRpcServer

[line 156]
TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TRpcServer
Location: /Web/Services/TRpcService.php

Remarks

TRpcServer class

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

since

3.2

Class Variable Summary

  • $handler =

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TModule

  • TModule::getID()
  • TModule::init()
    Initializes the module.
  • TModule::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRpcServer::__construct

    __construct( TRpcProtocol $protocolHandler );

    Parameters

    $protocolHandler

    instance

    Remarks

    Constructor

    access

    public

    [ Top ]

    TRpcServer::addRpcMethod

    addRpcMethod( string $methodName, array $methodDetails );

    Parameters

    $methodName

    $methodDetails

    access

    public

    [ Top ]

    TRpcServer::getPayload

    getPayload( );

    Returns

    request payload

    access

    public

    [ Top ]

    TRpcServer::processRequest

    processRequest( );

    Returns

    rpc response

    access

    public

    [ Top ]

Variable Detail

  • $handler = [line 161]
  • Data type: TRpcProtocol

    • var

    instance

    access

    protected

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:16 +0200 by phpDocumentor 1.4.3


Docs For Class TRpcService

Class TRpcService

[line 26]
TComponent
   |
   --TApplicationComponent
      |
      --TService
         |
         --TRpcService
Location: /Web/Services/TRpcService.php

Remarks

TRpcService class

Usage: <service id="rpc" class="TRpcService"> <rpcapi id="myapi" Class="MyApi" /> </service>

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

since

3.2

Class Variable Summary

  • $apiProviders = array()
  • $protocolHandlers = array(
          'application/json' => 'TJsonRpcProtocol',
          'text/xml' => 'TXmlRpcProtocol'
       )

Class Constant Summary

  • BASE_API_PROVIDER =  'TRpcApiProvider'
    const string base api provider class which every API must extend
  • BASE_RPC_SERVER =  'TRpcServer'
    const string base RPC server implementation

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TService

  • TService::getEnabled()
  • TService::getID()
  • TService::init()
    Initializes the service and attaches run to the RunService event of application.
  • TService::run()
    Runs the service.
  • TService::setEnabled()
  • TService::setID()

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TRpcService::createApiProvider

    createApiProvider( TRpcProtocol $protocolHandler, string $providerId );

    Parameters

    $protocolHandler

    instance

    $providerId

    Remarks

    Creates the API provider instance for the current request

    access

    public

    [ Top ]

    TRpcService::init

    init( TXmlElement $config );

    Overrides TService::init() (Initializes the service and attaches run to the RunService event of application.)

    Parameters

    $config

    containing the module configuration

    Remarks

    Initializes the service

    access

    public

    [ Top ]

    TRpcService::loadConfig

    loadConfig( $xml );

    Parameters

    $xml

    configuration

    access

    public

    [ Top ]

    TRpcService::run

    run( );

    Overrides TService::run() (Runs the service.)

    Remarks

    Runs the service

    access

    public

    [ Top ]

Variable Detail

  • $apiProviders = array() [line 49]
  • Data type: array

    • var

    containing API provider and their configured properties

    access

    protected

  • $protocolHandlers = array(
          'application/json' => 'TJsonRpcProtocol',
          'text/xml' => 'TXmlRpcProtocol'
       )     [line 41]
  • Data type: array

    • var

    containing mimetype to protocol handler mappings

    access

    protected

Class Constant Detail

  • BASE_API_PROVIDER =  'TRpcApiProvider' [line 31]

    • Remarks

    const string base api provider class which every API must extend

  • BASE_RPC_SERVER =  'TRpcServer' [line 36]

    • Remarks

    const string base RPC server implementation

Documentation generated on Mon, 25 Jun 2012 14:45:16 +0200 by phpDocumentor 1.4.3


Docs For Class TXmlRpcProtocol

Class TXmlRpcProtocol

[line 416]
TRpcProtocol
   |
   --TXmlRpcProtocol
Location: /Web/Services/TRpcService.php

Remarks

TXmlRpcProtocol class

Implements the XML RPC protocol

author

Robin J. Rogge <rrogge@bigpoint.net>

version

$Id$

since

3.2

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TRpcProtocol

  • TRpcProtocol::$rpcMethods = array()

Method Summary

Inherited Method Summary

Inherited From Class TRpcProtocol

  • TRpcProtocol::addMethod()
    Registers a new RPC method and handler details
  • TRpcProtocol::callApiMethod()
    Calls the callback handler for the given method
  • TRpcProtocol::callMethod()
  • TRpcProtocol::createErrorResponse()
  • TRpcProtocol::createResponseHeaders()
  • TRpcProtocol::decode()
  • TRpcProtocol::encode()

Method Detail

    TXmlRpcProtocol::__construct

    __construct( );

    Remarks

    Constructor

    access

    public

    [ Top ]

    TXmlRpcProtocol::__destruct

    __destruct( );

    Remarks

    Destructor

    access

    public

    [ Top ]

    TXmlRpcProtocol::addMethod

    addMethod( string $methodName, $methodDetails, array $handlerDetails );

    Overrides TRpcProtocol::addMethod() (Registers a new RPC method and handler details)

    Parameters

    $methodName

    $handlerDetails

    containing the callback handler

    $methodDetails

    Remarks

    Registers a new RPC method and handler details

    access

    public

    [ Top ]

    TXmlRpcProtocol::callMethod

    callMethod( string $requestPayload );

    Overrides TRpcProtocol::callMethod() (parent method not documented)

    Parameters

    $requestPayload

    Returns

    XML RPC response

    Remarks

    Handles the RPC request

    access

    public

    [ Top ]

    TXmlRpcProtocol::createErrorResponse

    createErrorResponse( TRpcException $exception );

    Overrides TRpcProtocol::createErrorResponse() (parent method not documented)

    Parameters

    $exception

    Returns

    XML RPC fault

    Remarks

    Turns the given exception into an XML RPC fault

    access

    public

    [ Top ]

    TXmlRpcProtocol::createResponseHeaders

    createResponseHeaders( THttpResponse $response );

    Overrides TRpcProtocol::createResponseHeaders() (parent method not documented)

    Parameters

    $response

    Remarks

    Sets the correct response headers

    access

    public

    [ Top ]

    TXmlRpcProtocol::decode

    decode( string $data );

    Overrides TRpcProtocol::decode() (parent method not documented)

    Parameters

    $data

    in XML format

    Returns

    PHP data

    Remarks

    Decodes XML encoded data into PHP data

    access

    public

    [ Top ]

    TXmlRpcProtocol::encode

    encode( mixed $data );

    Overrides TRpcProtocol::encode() (parent method not documented)

    Parameters

    $data

    PHP data

    Returns

    XML encoded PHP data

    Remarks

    Encodes PHP data into XML data

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:16 +0200 by phpDocumentor 1.4.3


Docs For Class TSoapServer

Class TSoapServer

[line 302]
TComponent
   |
   --TApplicationComponent
      |
      --TSoapServer
Location: /Web/Services/TSoapService.php

Remarks

TSoapServer class.

TSoapServer is a wrapper of the PHP SoapServer class. It associates a SOAP provider class to the SoapServer object. It also manages the URI for the SOAP service and WSDL.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TSoapService.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

  • WSDL_CACHE_PREFIX = 'wsdl.'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSoapServer::createServer

    createServer( );

    Remarks

    Creates the SoapServer instance.

    access

    protected

    [ Top ]

    TSoapServer::fault

    fault( string $title, [mixed $details = ''], [string $code = 'SERVER'], [string $actor = ''], [string $name = ''] );

    Parameters

    $title

    message title

    $details

    message details

    $code

    message code, defalt is 'SERVER'.

    $actor

    actors

    $name

    message name

    Remarks

    Generate a SOAP fault message.

    access

    public

    [ Top ]

    TSoapServer::getActor

    getActor( );

    Returns

    actor of the SOAP service

    access

    public

    [ Top ]

    TSoapServer::getClassMaps

    getClassMaps( );

    Returns

    comma delimit list of complex type classes.

    access

    public

    [ Top ]

    TSoapServer::getEncoding

    getEncoding( );

    Returns

    encoding of the SOAP service

    access

    public

    [ Top ]

    TSoapServer::getID

    getID( );

    Returns

    the ID of the SOAP server

    access

    public

    [ Top ]

    TSoapServer::getOptions

    getOptions( );

    Returns

    options for creating SoapServer instance

    access

    protected

    [ Top ]

    TSoapServer::getProvider

    getProvider( );

    Returns

    the SOAP provider class (in namespace format)

    access

    public

    [ Top ]

    TSoapServer::getRequestedMethod

    getRequestedMethod( );

    Returns

    soap method request, null if not found.

    Remarks

    Soap method guessed from the SOAP message received.

    access

    public

    [ Top ]

    TSoapServer::getSessionPersistent

    getSessionPersistent( );

    Returns

    whether the SOAP service is persistent within session. Defaults to false.

    access

    public

    [ Top ]

    TSoapServer::getUri

    getUri( );

    Returns

    the URI for the SOAP service

    access

    public

    [ Top ]

    TSoapServer::getVersion

    getVersion( );

    Returns

    SOAP version, defaults to empty (meaning not set).

    access

    public

    [ Top ]

    TSoapServer::getWsdl

    getWsdl( );

    Returns

    the WSDL content of the SOAP server

    Remarks

    Returns the WSDL content of the SOAP server.

    If WsdlUri is set, its content will be returned. If not, the Provider class will be investigated and the WSDL will be automatically genearted.

    access

    public

    [ Top ]

    TSoapServer::getWsdlUri

    getWsdlUri( );

    Returns

    the URI for WSDL

    access

    public

    [ Top ]

    TSoapServer::guessMethodCallRequested

    guessMethodCallRequested( string $class );

    Parameters

    $class

    current handler class.

    Remarks

    Guess the SOAP method request from the actual SOAP message

    access

    protected

    [ Top ]

    TSoapServer::run

    run( );

    Remarks

    Handles the SOAP request.

    access

    public

    [ Top ]

    TSoapServer::setActor

    setActor( string $value );

    Parameters

    $value

    actor of the SOAP service

    access

    public

    [ Top ]

    TSoapServer::setClassMaps

    setClassMaps( $classes );

    Parameters

    $classes

    Returns

    comma delimit list of class names

    access

    public

    [ Top ]

    TSoapServer::setEncoding

    setEncoding( string $value );

    Parameters

    $value

    encoding of the SOAP service

    access

    public

    [ Top ]

    TSoapServer::setID

    setID( string $id );

    Parameters

    $id

    the ID of the SOAP server

    throws

    TInvalidDataValueException if the ID ends with '.wsdl'.

    access

    public

    [ Top ]

    TSoapServer::setProvider

    setProvider( string $provider );

    Parameters

    $provider

    the SOAP provider class (in namespace format)

    access

    public

    [ Top ]

    TSoapServer::setSessionPersistent

    setSessionPersistent( boolean $value );

    Parameters

    $value

    whether the SOAP service is persistent within session.

    access

    public

    [ Top ]

    TSoapServer::setUri

    setUri( string $uri );

    Parameters

    $uri

    the URI for the SOAP service

    access

    public

    [ Top ]

    TSoapServer::setVersion

    setVersion( string $value );

    Parameters

    $value

    SOAP version, either '1.1' or '1.2'

    throws

    TInvalidDataValueException if neither '1.1' nor '1.2'

    access

    public

    [ Top ]

    TSoapServer::setWsdlUri

    setWsdlUri( string $value );

    Parameters

    $value

    the URI for WSDL

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

  • WSDL_CACHE_PREFIX = 'wsdl.' [line 304]

Documentation generated on Mon, 25 Jun 2012 14:45:23 +0200 by phpDocumentor 1.4.3


Docs For Class TSoapService

Class TSoapService

[line 90]
TComponent
   |
   --TApplicationComponent
      |
      --TService
         |
         --TSoapService
Location: /Web/Services/TSoapService.php

Remarks

TSoapService class

TSoapService processes SOAP requests for a PRADO application. TSoapService requires PHP SOAP extension to be loaded.

TSoapService manages a set of SOAP providers. Each SOAP provider is a class that implements a set of SOAP methods which are exposed to SOAP clients for remote invocation. TSoapService generates WSDL automatically for the SOAP providers by default.

To use TSoapService, configure it in the application specification like following:

  •    <services>
    •

  •      <service id="soap" class="System.Web.Services.TSoapService">
    •

  •        <soap id="stockquote" provider="MyStockQuote" />
    •

  •      </service>
    •

  •    </services>
    •
    PHP configuration style:
  •   'services' => array(
    •

  •     'soap' => array(
    •

  •      'class' => 'System.Web.Services.TSoapService'
    •

  •      'properties' => array(
    •

  •        'provider' => 'MyStockQuote'
    •

  •        )
    •

  •     )
    •

  •   )
    •

    The WSDL for the provider class "MyStockQuote" is generated based on special comment tags in the class. In particular, if a class method's comment contains the keyword "@soapmethod", it is considered to be a SOAP method and will be exposed to SOAP clients. For example,

  •    class MyStockQuote {
    •

  •       / **
    •

  •        * @param string $symbol the stock symbol
    •

  •        * @return float the stock price
    •

  •        * @soapmethod
    •

  •        * /
    •

  •       public function getQuote($symbol) {...}
    •

  •    }
    •

    With the above SOAP provider, a typical SOAP client may call the method "getQuote" remotely like the following:

  •    $client=new SoapClient("http://hostname/path/to/index.php?soap=stockquote.wsdl");
    •

  •    echo $client->getQuote("ibm");
    •

    Each <soap> element in the application specification actually configures the properties of a SOAP server which defaults to TSoapServer. Therefore, any writable property of TSoapServer may appear as an attribute in the <soap> element. For example, the "provider" attribute refers to the TSoapServer::setProvider property of TSoapServer. The following configuration specifies that the SOAP server is persistent within the user session (that means a MyStockQuote object will be stored in session)

  •    <services>
    •

  •      <service id="soap" class="System.Web.Services.TSoapService">
    •

  •        <soap id="stockquote" provider="MyStockQuote" SessionPersistent="true" />
    •

  •      </service>
    •

  •    </services>
    •

    You may also use your own SOAP server class by specifying the "class" attribute of <soap>.

    author

    Carl G. Mathisen <carlgmathisen@gmail.com>

    author

    Knut Urdalen <knut.urdalen@gmail.com>

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TService.php 3102 2012-02-05 17:00:00Z ctrlaltca@gmail.com $

    since

    3.1

    Class Variable Summary

    Class Constant Summary

    • DEFAULT_SOAP_SERVER = 'TSoapServer'

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TService

    • TService::getEnabled()
    • TService::getID()
    • TService::init()
      Initializes the service and attaches run to the RunService event of application.
    • TService::run()
      Runs the service.
    • TService::setEnabled()
    • TService::setID()

    Inherited From Class TApplicationComponent

    • TApplicationComponent::getApplication()
    • TApplicationComponent::getRequest()
    • TApplicationComponent::getResponse()
    • TApplicationComponent::getService()
    • TApplicationComponent::getSession()
    • TApplicationComponent::getUser()
    • TApplicationComponent::publishAsset()
      Publishes a private asset and gets its URL.
    • TApplicationComponent::publishFilePath()
      Publishes a file or directory and returns its URL.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TSoapService::__construct

      __construct( );

      Remarks

      Constructor.

      Sets default service ID to 'soap'.

      access

      public

      [ Top ]

      TSoapService::constructUrl

      constructUrl( string $serverID, [array $getParams = null], [boolean $encodeAmpersand = true], [boolean $encodeGetItems = true] );

      Parameters

      $serverID

      soap server ID

      $getParams

      list of GET parameters, null if no GET parameters required

      $encodeAmpersand

      whether to encode the ampersand in URL, defaults to true.

      $encodeGetItems

      whether to encode the GET parameters (their names and values), defaults to true.

      Returns

      URL for the page and GET parameters

      Remarks

      Constructs a URL with specified page path and GET parameters.

      access

      public

      [ Top ]

      TSoapService::createServer

      createServer( );

      Returns

      the SOAP server instance

      Remarks

      Creates the requested SOAP server.

      The SOAP server is initialized with the property values specified in the configuration.

      access

      protected

      [ Top ]

      TSoapService::getConfigFile

      getConfigFile( );

      Returns

      external configuration file. Defaults to null.

      access

      public

      [ Top ]

      TSoapService::getIsWsdlRequest

      getIsWsdlRequest( );

      Returns

      whether this is a request for WSDL

      access

      public

      [ Top ]

      TSoapService::getServerID

      getServerID( );

      Returns

      the SOAP server ID

      access

      public

      [ Top ]

      TSoapService::init

      init( TXmlElement $config );

      Overrides TService::init() (Initializes the service and attaches run to the RunService event of application.)

      Parameters

      $config

      configuration for this module, can be null

      Remarks

      Initializes this module.

      This method is required by the IModule interface.

      throws

      TConfigurationException if ConfigFile is invalid.

      access

      public

      [ Top ]

      TSoapService::resolveRequest

      resolveRequest( );

      Remarks

      Resolves the request parameter.

      It identifies the server ID and whether the request is for WSDL.

      see

      TSoapService::getIsWsdlRequest()

      see

      TSoapService::getServerID()

      throws

      THttpException if the server ID cannot be found

      access

      protected

      [ Top ]

      TSoapService::run

      run( );

      Overrides TService::run() (Runs the service.)

      Remarks

      Runs the service.

      If the service parameter ends with '.wsdl', it will serve a WSDL file for the specified soap server. Otherwise, it will handle the soap request using the specified server.

      access

      public

      [ Top ]

      TSoapService::setConfigFile

      setConfigFile( string $value );

      Parameters

      $value

      external configuration file in namespace format. The file must be suffixed with '.xml'.

      throws

      TInvalidDataValueException if the file is invalid.

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    • DEFAULT_SOAP_SERVER = 'TSoapServer' [line 92]

    Documentation generated on Mon, 25 Jun 2012 14:45:23 +0200 by phpDocumentor 1.4.3


Package System.Data.ActiveReecord.Scaffold.InputBuilder Element Index

Element index for package System.Data.ActiveReecord.Scaffold.InputBuilder

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
c d g l s t
top
c
createBooleanControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createBooleanControl()
createControl | in file TIbmScaffoldInput.php, method TIbmScaffoldInput::createControl()
createControl | in file TSqliteScaffoldInput.php, method TSqliteScaffoldInput::createControl()
createControl | in file TPgsqlScaffoldInput.php, method TPgsqlScaffoldInput::createControl()
createControl | in file TScaffoldInputBase.php, method TScaffoldInputBase::createControl()
createControl | in file TMssqlScaffoldInput.php, method TMssqlScaffoldInput::createControl()
createControl | in file TMysqlScaffoldInput.php, method TMysqlScaffoldInput::createControl()
createControlLabel | in file TScaffoldInputBase.php, method TScaffoldInputBase::createControlLabel()
createDateControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createDateControl()
createDateControl | in file TSqliteScaffoldInput.php, method TSqliteScaffoldInput::createDateControl()
createDateTimeControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createDateTimeControl()
createDateTimeControl | in file TSqliteScaffoldInput.php, method TSqliteScaffoldInput::createDateTimeControl()
createDefaultControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createDefaultControl()
createEnumControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createEnumControl()
createFloatControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createFloatControl()
createInputBuilder | in file TScaffoldInputBase.php, method TScaffoldInputBase::createInputBuilder()
createIntegerControl | in file TMysqlScaffoldInput.php, method TMysqlScaffoldInput::createIntegerControl()
createIntegerControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createIntegerControl()
createMultiLineControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createMultiLineControl()
createRangeValidator | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createRangeValidator()
createRequiredValidator | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createRequiredValidator()
createScaffoldInput | in file TScaffoldInputBase.php, method TScaffoldInputBase::createScaffoldInput()
createSetControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createSetControl()
createTimeControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createTimeControl()
createTypeValidator | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createTypeValidator()
createYearControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createYearControl()
top
d
DEFAULT_ID | in file TScaffoldInputBase.php, class constant TScaffoldInputBase::DEFAULT_ID
top
g
getControlValue | in file TSqliteScaffoldInput.php, method TSqliteScaffoldInput::getControlValue()
getControlValue | in file TIbmScaffoldInput.php, method TIbmScaffoldInput::getControlValue()
getControlValue | in file TPgsqlScaffoldInput.php, method TPgsqlScaffoldInput::getControlValue()
getControlValue | in file TScaffoldInputBase.php, method TScaffoldInputBase::getControlValue()
getControlValue | in file TMssqlScaffoldInput.php, method TMssqlScaffoldInput::getControlValue()
getControlValue | in file TMysqlScaffoldInput.php, method TMysqlScaffoldInput::getControlValue()
getDateTimeValue | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::getDateTimeValue()
getDateTimeValue | in file TSqliteScaffoldInput.php, method TSqliteScaffoldInput::getDateTimeValue()
getDefaultControlValue | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::getDefaultControlValue()
getEnumValue | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::getEnumValue()
getIntBooleanValue | in file TMysqlScaffoldInput.php, method TMysqlScaffoldInput::getIntBooleanValue()
getIsEnabled | in file TScaffoldInputBase.php, method TScaffoldInputBase::getIsEnabled()
getMatchingIndices | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::getMatchingIndices()
getParent | in file TScaffoldInputBase.php, method TScaffoldInputBase::getParent()
getRecordPropertyValue | in file TScaffoldInputBase.php, method TScaffoldInputBase::getRecordPropertyValue()
getSetValue | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::getSetValue()
getTimeValue | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::getTimeValue()
top
l
loadScaffoldInput | in file TScaffoldInputBase.php, method TScaffoldInputBase::loadScaffoldInput()
top
s
setDefaultProperty | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::setDefaultProperty()
setNotNullProperty | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::setNotNullProperty()
setRecordPropertyValue | in file TScaffoldInputBase.php, method TScaffoldInputBase::setRecordPropertyValue()
top
t
TIbmScaffoldInput.php | procedural page TIbmScaffoldInput.php
TMssqlScaffoldInput.php | procedural page TMssqlScaffoldInput.php
TMysqlScaffoldInput.php | procedural page TMysqlScaffoldInput.php
TPgsqlScaffoldInput.php | procedural page TPgsqlScaffoldInput.php
TScaffoldInputBase.php | procedural page TScaffoldInputBase.php
TScaffoldInputCommon.php | procedural page TScaffoldInputCommon.php
TSqliteScaffoldInput.php | procedural page TSqliteScaffoldInput.php
TIbmScaffoldInput in file TIbmScaffoldInput.php, class TIbmScaffoldInput
TIbmScaffoldInput class file.
TMssqlScaffoldInput in file TMssqlScaffoldInput.php, class TMssqlScaffoldInput
TMssqlScaffoldInput class file.
TMysqlScaffoldInput in file TMysqlScaffoldInput.php, class TMysqlScaffoldInput
TMysqlScaffoldInput class file.
TPgsqlScaffoldInput in file TPgsqlScaffoldInput.php, class TPgsqlScaffoldInput
TPgsqlScaffoldInput class file.
TScaffoldInputBase in file TScaffoldInputBase.php, class TScaffoldInputBase
TScaffoldInputBase class file.
TScaffoldInputCommon in file TScaffoldInputCommon.php, class TScaffoldInputCommon
TScaffoldInputCommon class file.
TSqliteScaffoldInput in file TSqliteScaffoldInput.php, class TSqliteScaffoldInput
TSqliteScaffoldInput class file.


Class Trees for Package System.Data.ActiveReecord.Scaffold.InputBuilder

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TIbmScaffoldInput.php

File: /Data/ActiveRecord/Scaffold/InputBuilder/TIbmScaffoldInput.php

Classes in this file:
TIbmScaffoldInput
TIbmScaffoldInput class file.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:32 +0200 by phpDocumentor 1.4.3


Docs for page TMssqlScaffoldInput.php

File: /Data/ActiveRecord/Scaffold/InputBuilder/TMssqlScaffoldInput.php

Classes in this file:
TMssqlScaffoldInput
TMssqlScaffoldInput class file.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:52 +0200 by phpDocumentor 1.4.3


Docs for page TMysqlScaffoldInput.php

File: /Data/ActiveRecord/Scaffold/InputBuilder/TMysqlScaffoldInput.php

Classes in this file:
TMysqlScaffoldInput
TMysqlScaffoldInput class file.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:54 +0200 by phpDocumentor 1.4.3


Docs for page TPgsqlScaffoldInput.php

File: /Data/ActiveRecord/Scaffold/InputBuilder/TPgsqlScaffoldInput.php

Classes in this file:
TPgsqlScaffoldInput
TPgsqlScaffoldInput class file.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:02 +0200 by phpDocumentor 1.4.3


Docs for page TScaffoldInputBase.php

File: /Data/ActiveRecord/Scaffold/InputBuilder/TScaffoldInputBase.php

Classes in this file:
TScaffoldInputBase
TScaffoldInputBase class file.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:18 +0200 by phpDocumentor 1.4.3


Docs for page TScaffoldInputCommon.php

File: /Data/ActiveRecord/Scaffold/InputBuilder/TScaffoldInputCommon.php

Classes in this file:
TScaffoldInputCommon
TScaffoldInputCommon class file.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:18 +0200 by phpDocumentor 1.4.3


Docs for page TSqliteScaffoldInput.php

File: /Data/ActiveRecord/Scaffold/InputBuilder/TSqliteScaffoldInput.php

Classes in this file:
TSqliteScaffoldInput
TSqliteScaffoldInput class file.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:24 +0200 by phpDocumentor 1.4.3


Docs For Class TIbmScaffoldInput

Class TIbmScaffoldInput

[line 13]
TScaffoldInputBase
   |
   --TScaffoldInputCommon
      |
      --TIbmScaffoldInput
Location: /Data/ActiveRecord/Scaffold/InputBuilder/TIbmScaffoldInput.php

Remarks

TIbmScaffoldInput class file.

author

Cesar Ramos <cramos[at]gmail[dot]com>

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TScaffoldInputBase

  • TScaffoldInputBase::DEFAULT_ID = 'scaffold_input'

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TScaffoldInputCommon

  • TScaffoldInputCommon::createBooleanControl()
  • TScaffoldInputCommon::createDateControl()
  • TScaffoldInputCommon::createDateTimeControl()
  • TScaffoldInputCommon::createDefaultControl()
  • TScaffoldInputCommon::createEnumControl()
  • TScaffoldInputCommon::createFloatControl()
  • TScaffoldInputCommon::createIntegerControl()
  • TScaffoldInputCommon::createMultiLineControl()
  • TScaffoldInputCommon::createRangeValidator()
  • TScaffoldInputCommon::createRequiredValidator()
  • TScaffoldInputCommon::createSetControl()
  • TScaffoldInputCommon::createTimeControl()
  • TScaffoldInputCommon::createTypeValidator()
  • TScaffoldInputCommon::createYearControl()
  • TScaffoldInputCommon::getDateTimeValue()
  • TScaffoldInputCommon::getDefaultControlValue()
  • TScaffoldInputCommon::getEnumValue()
  • TScaffoldInputCommon::getMatchingIndices()
  • TScaffoldInputCommon::getSetValue()
  • TScaffoldInputCommon::getTimeValue()
  • TScaffoldInputCommon::setDefaultProperty()
  • TScaffoldInputCommon::setNotNullProperty()

Inherited From Class TScaffoldInputBase

  • TScaffoldInputBase::createControl()
  • TScaffoldInputBase::createControlLabel()
  • TScaffoldInputBase::createInputBuilder()
  • TScaffoldInputBase::createScaffoldInput()
  • TScaffoldInputBase::getControlValue()
  • TScaffoldInputBase::getIsEnabled()
  • TScaffoldInputBase::getParent()
  • TScaffoldInputBase::getRecordPropertyValue()
  • TScaffoldInputBase::loadScaffoldInput()
  • TScaffoldInputBase::setRecordPropertyValue()

Method Detail

    TIbmScaffoldInput::createControl

    createControl( $container, $column, $record );

    Overrides TScaffoldInputBase::createControl() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TIbmScaffoldInput::getControlValue

    getControlValue( $container, $column, $record );

    Overrides TScaffoldInputBase::getControlValue() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:32 +0200 by phpDocumentor 1.4.3


Docs For Class TMssqlScaffoldInput

Class TMssqlScaffoldInput

[line 12]
TScaffoldInputBase
   |
   --TScaffoldInputCommon
      |
      --TMssqlScaffoldInput
Location: /Data/ActiveRecord/Scaffold/InputBuilder/TMssqlScaffoldInput.php

Remarks

TMssqlScaffoldInput class file.

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TScaffoldInputBase

  • TScaffoldInputBase::DEFAULT_ID = 'scaffold_input'

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TScaffoldInputCommon

  • TScaffoldInputCommon::createBooleanControl()
  • TScaffoldInputCommon::createDateControl()
  • TScaffoldInputCommon::createDateTimeControl()
  • TScaffoldInputCommon::createDefaultControl()
  • TScaffoldInputCommon::createEnumControl()
  • TScaffoldInputCommon::createFloatControl()
  • TScaffoldInputCommon::createIntegerControl()
  • TScaffoldInputCommon::createMultiLineControl()
  • TScaffoldInputCommon::createRangeValidator()
  • TScaffoldInputCommon::createRequiredValidator()
  • TScaffoldInputCommon::createSetControl()
  • TScaffoldInputCommon::createTimeControl()
  • TScaffoldInputCommon::createTypeValidator()
  • TScaffoldInputCommon::createYearControl()
  • TScaffoldInputCommon::getDateTimeValue()
  • TScaffoldInputCommon::getDefaultControlValue()
  • TScaffoldInputCommon::getEnumValue()
  • TScaffoldInputCommon::getMatchingIndices()
  • TScaffoldInputCommon::getSetValue()
  • TScaffoldInputCommon::getTimeValue()
  • TScaffoldInputCommon::setDefaultProperty()
  • TScaffoldInputCommon::setNotNullProperty()

Inherited From Class TScaffoldInputBase

  • TScaffoldInputBase::createControl()
  • TScaffoldInputBase::createControlLabel()
  • TScaffoldInputBase::createInputBuilder()
  • TScaffoldInputBase::createScaffoldInput()
  • TScaffoldInputBase::getControlValue()
  • TScaffoldInputBase::getIsEnabled()
  • TScaffoldInputBase::getParent()
  • TScaffoldInputBase::getRecordPropertyValue()
  • TScaffoldInputBase::loadScaffoldInput()
  • TScaffoldInputBase::setRecordPropertyValue()

Method Detail

    TMssqlScaffoldInput::createControl

    createControl( $container, $column, $record );

    Overrides TScaffoldInputBase::createControl() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TMssqlScaffoldInput::getControlValue

    getControlValue( $container, $column, $record );

    Overrides TScaffoldInputBase::getControlValue() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:52 +0200 by phpDocumentor 1.4.3


Docs For Class TMysqlScaffoldInput

Class TMysqlScaffoldInput

[line 12]
TScaffoldInputBase
   |
   --TScaffoldInputCommon
      |
      --TMysqlScaffoldInput
Location: /Data/ActiveRecord/Scaffold/InputBuilder/TMysqlScaffoldInput.php

Remarks

TMysqlScaffoldInput class file.

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TScaffoldInputBase

  • TScaffoldInputBase::DEFAULT_ID = 'scaffold_input'

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TScaffoldInputCommon

  • TScaffoldInputCommon::createBooleanControl()
  • TScaffoldInputCommon::createDateControl()
  • TScaffoldInputCommon::createDateTimeControl()
  • TScaffoldInputCommon::createDefaultControl()
  • TScaffoldInputCommon::createEnumControl()
  • TScaffoldInputCommon::createFloatControl()
  • TScaffoldInputCommon::createIntegerControl()
  • TScaffoldInputCommon::createMultiLineControl()
  • TScaffoldInputCommon::createRangeValidator()
  • TScaffoldInputCommon::createRequiredValidator()
  • TScaffoldInputCommon::createSetControl()
  • TScaffoldInputCommon::createTimeControl()
  • TScaffoldInputCommon::createTypeValidator()
  • TScaffoldInputCommon::createYearControl()
  • TScaffoldInputCommon::getDateTimeValue()
  • TScaffoldInputCommon::getDefaultControlValue()
  • TScaffoldInputCommon::getEnumValue()
  • TScaffoldInputCommon::getMatchingIndices()
  • TScaffoldInputCommon::getSetValue()
  • TScaffoldInputCommon::getTimeValue()
  • TScaffoldInputCommon::setDefaultProperty()
  • TScaffoldInputCommon::setNotNullProperty()

Inherited From Class TScaffoldInputBase

  • TScaffoldInputBase::createControl()
  • TScaffoldInputBase::createControlLabel()
  • TScaffoldInputBase::createInputBuilder()
  • TScaffoldInputBase::createScaffoldInput()
  • TScaffoldInputBase::getControlValue()
  • TScaffoldInputBase::getIsEnabled()
  • TScaffoldInputBase::getParent()
  • TScaffoldInputBase::getRecordPropertyValue()
  • TScaffoldInputBase::loadScaffoldInput()
  • TScaffoldInputBase::setRecordPropertyValue()

Method Detail

    TMysqlScaffoldInput::createControl

    createControl( $container, $column, $record );

    Overrides TScaffoldInputBase::createControl() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TMysqlScaffoldInput::createIntegerControl

    createIntegerControl( $container, $column, $record );

    Overrides TScaffoldInputCommon::createIntegerControl() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TMysqlScaffoldInput::getControlValue

    getControlValue( $container, $column, $record );

    Overrides TScaffoldInputBase::getControlValue() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TMysqlScaffoldInput::getIntBooleanValue

    getIntBooleanValue( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:54 +0200 by phpDocumentor 1.4.3


Docs For Class TPgsqlScaffoldInput

Class TPgsqlScaffoldInput

[line 12]
TScaffoldInputBase
   |
   --TScaffoldInputCommon
      |
      --TPgsqlScaffoldInput
Location: /Data/ActiveRecord/Scaffold/InputBuilder/TPgsqlScaffoldInput.php

Remarks

TPgsqlScaffoldInput class file.

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TScaffoldInputBase

  • TScaffoldInputBase::DEFAULT_ID = 'scaffold_input'

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TScaffoldInputCommon

  • TScaffoldInputCommon::createBooleanControl()
  • TScaffoldInputCommon::createDateControl()
  • TScaffoldInputCommon::createDateTimeControl()
  • TScaffoldInputCommon::createDefaultControl()
  • TScaffoldInputCommon::createEnumControl()
  • TScaffoldInputCommon::createFloatControl()
  • TScaffoldInputCommon::createIntegerControl()
  • TScaffoldInputCommon::createMultiLineControl()
  • TScaffoldInputCommon::createRangeValidator()
  • TScaffoldInputCommon::createRequiredValidator()
  • TScaffoldInputCommon::createSetControl()
  • TScaffoldInputCommon::createTimeControl()
  • TScaffoldInputCommon::createTypeValidator()
  • TScaffoldInputCommon::createYearControl()
  • TScaffoldInputCommon::getDateTimeValue()
  • TScaffoldInputCommon::getDefaultControlValue()
  • TScaffoldInputCommon::getEnumValue()
  • TScaffoldInputCommon::getMatchingIndices()
  • TScaffoldInputCommon::getSetValue()
  • TScaffoldInputCommon::getTimeValue()
  • TScaffoldInputCommon::setDefaultProperty()
  • TScaffoldInputCommon::setNotNullProperty()

Inherited From Class TScaffoldInputBase

  • TScaffoldInputBase::createControl()
  • TScaffoldInputBase::createControlLabel()
  • TScaffoldInputBase::createInputBuilder()
  • TScaffoldInputBase::createScaffoldInput()
  • TScaffoldInputBase::getControlValue()
  • TScaffoldInputBase::getIsEnabled()
  • TScaffoldInputBase::getParent()
  • TScaffoldInputBase::getRecordPropertyValue()
  • TScaffoldInputBase::loadScaffoldInput()
  • TScaffoldInputBase::setRecordPropertyValue()

Method Detail

    TPgsqlScaffoldInput::createControl

    createControl( $container, $column, $record );

    Overrides TScaffoldInputBase::createControl() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TPgsqlScaffoldInput::getControlValue

    getControlValue( $container, $column, $record );

    Overrides TScaffoldInputBase::getControlValue() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:02 +0200 by phpDocumentor 1.4.3


Docs For Class TScaffoldInputBase

Class TScaffoldInputBase

[line 10]

Classes extended from TScaffoldInputBase:

TScaffoldInputCommon

TScaffoldInputCommon class file.

Location: /Data/ActiveRecord/Scaffold/InputBuilder/TScaffoldInputBase.php

Remarks

TScaffoldInputBase class file.

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Class Variable Summary

Class Constant Summary

  • DEFAULT_ID =  'scaffold_input'

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static void createInputBuilder()

  • void createInputBuilder()

Inherited Method Summary

Method Detail

    static TScaffoldInputBase::createInputBuilder

static createInputBuilder(

$record );

    Parameters

    $record

    access

    public

    [ Top ]

    TScaffoldInputBase::createControl

createControl(

$container,
$column,
$record );

    Overridden in child classes as:

    TIbmScaffoldInput::createControl()

    TMssqlScaffoldInput::createControl()

    TMysqlScaffoldInput::createControl()

    TPgsqlScaffoldInput::createControl()

    TSqliteScaffoldInput::createControl()

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputBase::createControlLabel

createControlLabel(

$label,
$column,
$record );

    Parameters

    $label

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputBase::createScaffoldInput

createScaffoldInput(

$parent,
$item,
$column,
$record );

    Parameters

    $parent

    $item

    $column

    $record

    access

    public

    [ Top ]

    TScaffoldInputBase::getControlValue

getControlValue(

$container,
$column,
$record );

    Overridden in child classes as:

    TIbmScaffoldInput::getControlValue()

    TMssqlScaffoldInput::getControlValue()

    TMysqlScaffoldInput::getControlValue()

    TPgsqlScaffoldInput::getControlValue()

    TSqliteScaffoldInput::getControlValue()

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputBase::getIsEnabled

getIsEnabled(

$column,
$record );

    Parameters

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputBase::getParent

getParent(
 );

    access

    protected

    [ Top ]

    TScaffoldInputBase::getRecordPropertyValue

getRecordPropertyValue(

$column,
$record );

    Parameters

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputBase::loadScaffoldInput

loadScaffoldInput(

$parent,
$item,
$column,
$record );

    Parameters

    $parent

    $item

    $column

    $record

    access

    public

    [ Top ]

    TScaffoldInputBase::setRecordPropertyValue

setRecordPropertyValue(

$item,
$record,
$input );

    Parameters

    $item

    $record

    $input

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

  • DEFAULT_ID =  'scaffold_input' [line 12]
    •

        Documentation generated on Mon, 25 Jun 2012 14:45:18 +0200 by phpDocumentor 1.4.3


Docs For Class TScaffoldInputCommon

Class TScaffoldInputCommon

[line 12]
TScaffoldInputBase
   |
   --TScaffoldInputCommon
Classes extended from TScaffoldInputCommon:
TIbmScaffoldInput
TIbmScaffoldInput class file.
TMssqlScaffoldInput
TMssqlScaffoldInput class file.
TMysqlScaffoldInput
TMysqlScaffoldInput class file.
TPgsqlScaffoldInput
TPgsqlScaffoldInput class file.
TSqliteScaffoldInput
TSqliteScaffoldInput class file.

Location: /Data/ActiveRecord/Scaffold/InputBuilder/TScaffoldInputCommon.php

Remarks

TScaffoldInputCommon class file.

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TScaffoldInputBase

  • TScaffoldInputBase::DEFAULT_ID = 'scaffold_input'

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TScaffoldInputBase

  • TScaffoldInputBase::createControl()
  • TScaffoldInputBase::createControlLabel()
  • TScaffoldInputBase::createInputBuilder()
  • TScaffoldInputBase::createScaffoldInput()
  • TScaffoldInputBase::getControlValue()
  • TScaffoldInputBase::getIsEnabled()
  • TScaffoldInputBase::getParent()
  • TScaffoldInputBase::getRecordPropertyValue()
  • TScaffoldInputBase::loadScaffoldInput()
  • TScaffoldInputBase::setRecordPropertyValue()

Method Detail

    TScaffoldInputCommon::createBooleanControl

    createBooleanControl( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createDateControl

    createDateControl( $container, $column, $record );

    Overridden in child classes as:

    TSqliteScaffoldInput::createDateControl()

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createDateTimeControl

    createDateTimeControl( $container, $column, $record );

    Overridden in child classes as:

    TSqliteScaffoldInput::createDateTimeControl()

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createDefaultControl

    createDefaultControl( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createEnumControl

    createEnumControl( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createFloatControl

    createFloatControl( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createIntegerControl

    createIntegerControl( $container, $column, $record );

    Overridden in child classes as:

    TMysqlScaffoldInput::createIntegerControl()

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createMultiLineControl

    createMultiLineControl( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createRangeValidator

    createRangeValidator( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createRequiredValidator

    createRequiredValidator( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createSetControl

    createSetControl( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createTimeControl

    createTimeControl( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createTypeValidator

    createTypeValidator( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::createYearControl

    createYearControl( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::getDateTimeValue

    getDateTimeValue( $container, $column, $record );

    Overridden in child classes as:

    TSqliteScaffoldInput::getDateTimeValue()

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::getDefaultControlValue

    getDefaultControlValue( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::getEnumValue

    getEnumValue( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::getMatchingIndices

    getMatchingIndices( $checks, $values );

    Parameters

    $checks

    $values

    access

    protected

    [ Top ]

    TScaffoldInputCommon::getSetValue

    getSetValue( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::getTimeValue

    getTimeValue( $container, $column, $record );

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::setDefaultProperty

    setDefaultProperty( $container, $control, $column, $record );

    Parameters

    $container

    $control

    $column

    $record

    access

    protected

    [ Top ]

    TScaffoldInputCommon::setNotNullProperty

    setNotNullProperty( $container, $control, $column, $record );

    Parameters

    $container

    $control

    $column

    $record

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:18 +0200 by phpDocumentor 1.4.3


Docs For Class TSqliteScaffoldInput

Class TSqliteScaffoldInput

[line 12]
TScaffoldInputBase
   |
   --TScaffoldInputCommon
      |
      --TSqliteScaffoldInput
Location: /Data/ActiveRecord/Scaffold/InputBuilder/TSqliteScaffoldInput.php

Remarks

TSqliteScaffoldInput class file.

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TScaffoldInputBase

  • TScaffoldInputBase::DEFAULT_ID = 'scaffold_input'

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TScaffoldInputCommon

  • TScaffoldInputCommon::createBooleanControl()
  • TScaffoldInputCommon::createDateControl()
  • TScaffoldInputCommon::createDateTimeControl()
  • TScaffoldInputCommon::createDefaultControl()
  • TScaffoldInputCommon::createEnumControl()
  • TScaffoldInputCommon::createFloatControl()
  • TScaffoldInputCommon::createIntegerControl()
  • TScaffoldInputCommon::createMultiLineControl()
  • TScaffoldInputCommon::createRangeValidator()
  • TScaffoldInputCommon::createRequiredValidator()
  • TScaffoldInputCommon::createSetControl()
  • TScaffoldInputCommon::createTimeControl()
  • TScaffoldInputCommon::createTypeValidator()
  • TScaffoldInputCommon::createYearControl()
  • TScaffoldInputCommon::getDateTimeValue()
  • TScaffoldInputCommon::getDefaultControlValue()
  • TScaffoldInputCommon::getEnumValue()
  • TScaffoldInputCommon::getMatchingIndices()
  • TScaffoldInputCommon::getSetValue()
  • TScaffoldInputCommon::getTimeValue()
  • TScaffoldInputCommon::setDefaultProperty()
  • TScaffoldInputCommon::setNotNullProperty()

Inherited From Class TScaffoldInputBase

  • TScaffoldInputBase::createControl()
  • TScaffoldInputBase::createControlLabel()
  • TScaffoldInputBase::createInputBuilder()
  • TScaffoldInputBase::createScaffoldInput()
  • TScaffoldInputBase::getControlValue()
  • TScaffoldInputBase::getIsEnabled()
  • TScaffoldInputBase::getParent()
  • TScaffoldInputBase::getRecordPropertyValue()
  • TScaffoldInputBase::loadScaffoldInput()
  • TScaffoldInputBase::setRecordPropertyValue()

Method Detail

    TSqliteScaffoldInput::createControl

    createControl( $container, $column, $record );

    Overrides TScaffoldInputBase::createControl() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TSqliteScaffoldInput::createDateControl

    createDateControl( $container, $column, $record );

    Overrides TScaffoldInputCommon::createDateControl() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TSqliteScaffoldInput::createDateTimeControl

    createDateTimeControl( $container, $column, $record );

    Overrides TScaffoldInputCommon::createDateTimeControl() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TSqliteScaffoldInput::getControlValue

    getControlValue( $container, $column, $record );

    Overrides TScaffoldInputBase::getControlValue() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

    TSqliteScaffoldInput::getDateTimeValue

    getDateTimeValue( $container, $column, $record );

    Overrides TScaffoldInputCommon::getDateTimeValue() (parent method not documented)

    Parameters

    $container

    $column

    $record

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:24 +0200 by phpDocumentor 1.4.3


Package System.Web.Javascripts Element Index

Element index for package System.Web.Javascripts

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
e i j q r t
top
e
encode in file TJavaScript.php, method TJavaScript::encode()
Encodes a PHP variable into javascript representation.
top
i
isFunction in file TJavaScript.php, method TJavaScript::isFunction()
Deprecated, use isJsLiteral instead
isJsLiteral | in file TJavaScript.php, method TJavaScript::isJsLiteral()
top
j
JSMin in file TJavaScript.php, method TJavaScript::JSMin()
Minimize the size of a javascript script.
jsonDecode in file TJavaScript.php, method TJavaScript::jsonDecode()
Decodes a javascript string into PHP variable.
jsonEncode in file TJavaScript.php, method TJavaScript::jsonEncode()
Encodes a PHP variable into javascript string.
top
q
quoteFunction in file TJavaScript.php, method TJavaScript::quoteFunction()
Deprecated, use quoteJsLiteral instead
quoteJsLiteral | in file TJavaScript.php, method TJavaScript::quoteJsLiteral()
quoteString in file TJavaScript.php, method TJavaScript::quoteString()
Quotes a javascript string.
top
r
renderScriptBlock in file TJavaScript.php, method TJavaScript::renderScriptBlock()
Renders javascript block
renderScriptBlocks in file TJavaScript.php, method TJavaScript::renderScriptBlocks()
Renders a list of javascript blocks
renderScriptFile in file TJavaScript.php, method TJavaScript::renderScriptFile()
Renders a javascript file
renderScriptFiles in file TJavaScript.php, method TJavaScript::renderScriptFiles()
Renders a list of javascript files
top
t
TJavaScript in file TJavaScript.php, class TJavaScript
TJavaScript class.
TJavaScript.php | procedural page TJavaScript.php


Class Trees for Package System.Web.Javascripts

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TJavaScript.php

File: /Web/Javascripts/TJavaScript.php

Remarks

TJavaScript class file

author

Wei Zhuo<weizhuo[at]gmail[dot]com>

version

$Id: TJavaScript.php 3121 2012-03-25 20:51:49Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TJavaScript
TJavaScript class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:38 +0200 by phpDocumentor 1.4.3


Docs For Class TJavaScript

Class TJavaScript

[line 24]

Location: /Web/Javascripts/TJavaScript.php

Remarks

TJavaScript class.

TJavaScript is a utility class containing commonly-used javascript-related  functions.

author

Wei Zhuo<weizhuo[at]gmail[dot]com>

version

$Id: TJavaScript.php 3121 2012-03-25 20:51:49Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

  • static string encode()

    Encodes a PHP variable into javascript representation.

  • static void isFunction()

    Deprecated, use isJsLiteral instead

  • static boolean isJsLiteral()

  • static minimized JSMin()

    Minimize the size of a javascript script.

  • static mixed jsonDecode()

    Decodes a javascript string into PHP variable.

  • static string jsonEncode()

    Encodes a PHP variable into javascript string.

  • static void quoteFunction()

    Deprecated, use quoteJsLiteral instead

  • static Marks quoteJsLiteral()

  • static string quoteString()

    Quotes a javascript string.

  • static string renderScriptBlock()

    Renders javascript block

  • static string renderScriptBlocks()

    Renders a list of javascript blocks

  • static string renderScriptFile()

    Renders a javascript file

  • static string renderScriptFiles()

    Renders a list of javascript files

  • string encode()

    Encodes a PHP variable into javascript representation.

  • void isFunction()

    Deprecated, use isJsLiteral instead

  • boolean isJsLiteral()

  • minimized JSMin()

    Minimize the size of a javascript script.

  • mixed jsonDecode()

    Decodes a javascript string into PHP variable.

  • string jsonEncode()

    Encodes a PHP variable into javascript string.

  • void quoteFunction()

    Deprecated, use quoteJsLiteral instead

  • Marks quoteJsLiteral()

  • string quoteString()

    Quotes a javascript string.

  • string renderScriptBlock()

    Renders javascript block

  • string renderScriptBlocks()

    Renders a list of javascript blocks

  • string renderScriptFile()

    Renders a javascript file

  • string renderScriptFiles()

    Renders a list of javascript files

Inherited Method Summary

Method Detail

    static TJavaScript::encode

static encode(
mixed
$value, [boolean
$toMap = true], [boolean
$encodeEmptyStrings = false] );

    Parameters

    $value

    PHP variable to be encoded

    $toMap

    whether the output is a map or a list.

    $encodeEmptyStrings

    wether to encode empty strings too. Default to false for BC.

    Returns

    the encoded string

    Remarks

    Encodes a PHP variable into javascript representation.

    Example:
  •  $options['onLoading'] = "doit";
    •

  •  $options['onComplete'] = "more";
    •

  •  echo TJavaScript::encode($options);
    •

  •  //expects the following javascript code
    •

  •  // {'onLoading':'doit','onComplete':'more'}
    •

    For higher complexity data structures use jsonEncode and jsonDecode  to serialize and unserialize.

    since

    3.1.5

    access

    public

    [ Top ]

    static TJavaScript::isFunction

static isFunction(

$js );

    Parameters

    $js

    Remarks

    Deprecated, use isJsLiteral instead

    access

    public

    [ Top ]

    static TJavaScript::isJsLiteral

static isJsLiteral(

$js );

    Parameters

    $js

    Returns

    true if the parameter is marked as a javascript function, i.e. if it's considered as a  raw javascript function that is not supposed to be encoded by encode

    access

    public

    [ Top ]

    static TJavaScript::JSMin

static JSMin(
string
$code );

    Parameters

    $code

    code that you want to minimzie

    Returns

    version of the code

    Remarks

    Minimize the size of a javascript script.

    This method is based on Douglas Crockford's JSMin.

    access

    public

    [ Top ]

    static TJavaScript::jsonDecode

static jsonDecode(
string
$value, [bool
$assoc = false], [int
$depth = 512] );

    Parameters

    $value

    string to be decoded

    $assoc

    whether to convert returned objects to associative arrays

    $depth

    recursion depth

    Returns

    decoded variable

    Remarks

    Decodes a javascript string into PHP variable.

    This method invokes json_decode to perform the decoding.

    access

    public

    [ Top ]

    static TJavaScript::jsonEncode

static jsonEncode(
mixed
$value, [
$options = 0] );

    Parameters

    $value

    variable to be encoded

    $options

    Returns

    encoded string

    Remarks

    Encodes a PHP variable into javascript string.

    This method invokes json_encode to perform the encoding.

    access

    public

    [ Top ]

    static TJavaScript::quoteFunction

static quoteFunction(

$js );

    Parameters

    $js

    Remarks

    Deprecated, use quoteJsLiteral instead

    access

    public

    [ Top ]

    static TJavaScript::quoteJsLiteral

static quoteJsLiteral(

$js );

    Parameters

    $js

    Returns

    a string as a javascript function. Once marke, the string is considered as a  raw javascript function that is not supposed to be encoded by encode

    access

    public

    [ Top ]

    static TJavaScript::quoteString

static quoteString(
string
$js );

    Parameters

    $js

    string to be quoted

    Returns

    the quoted string

    Remarks

    Quotes a javascript string.

    After processing, the string is safely enclosed within a pair of  quotation marks and can serve as a javascript string.

    access

    public

    [ Top ]

    static TJavaScript::renderScriptBlock

static renderScriptBlock(
string
$script );

    Parameters

    $script

    javascript block

    Returns

    rendering result

    Remarks

    Renders javascript block

    access

    public

    [ Top ]

    static TJavaScript::renderScriptBlocks

static renderScriptBlocks(
array
$scripts );

    Parameters

    $scripts

    javascript blocks

    Returns

    rendering result

    Remarks

    Renders a list of javascript blocks

    access

    public

    [ Top ]

    static TJavaScript::renderScriptFile

static renderScriptFile(
string
$file );

    Parameters

    $file

    URL to the javascript file

    Returns

    rendering result

    Remarks

    Renders a javascript file

    access

    public

    [ Top ]

    static TJavaScript::renderScriptFiles

static renderScriptFiles(
array
$files );

    Parameters

    $files

    URLs to the javascript files

    Returns

    rendering result

    Remarks

    Renders a list of javascript files

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:44:38 +0200 by phpDocumentor 1.4.3


Package System.Data.Common.Mssql Element Index

Element index for package System.Data.Common.Mssql

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
c g h i p q t
top
c
createCommandBuilder | in file TMssqlTableInfo.php, method TMssqlTableInfo::createCommandBuilder()
createNewTableInfo | in file TMssqlMetaData.php, method TMssqlMetaData::createNewTableInfo()
createTableInfo in file TMssqlMetaData.php, method TMssqlMetaData::createTableInfo()
Get the column definitions for given table.
top
g
getAutoIncrement | in file TMssqlTableColumn.php, method TMssqlTableColumn::getAutoIncrement()
getCatalogName | in file TMssqlTableInfo.php, method TMssqlTableInfo::getCatalogName()
getCatalogSchemaTableName | in file TMssqlMetaData.php, method TMssqlMetaData::getCatalogSchemaTableName()
getConstraintKeys in file TMssqlMetaData.php, method TMssqlMetaData::getConstraintKeys()
Gets the primary and foreign key column details for the given table.
getForeignConstraints in file TMssqlMetaData.php, method TMssqlMetaData::getForeignConstraints()
Gets foreign relationship constraint keys and table name
getIsExcluded | in file TMssqlTableColumn.php, method TMssqlTableColumn::getIsExcluded()
getPHPType in file TMssqlTableColumn.php, method TMssqlTableColumn::getPHPType()
Overrides parent implementation, returns PHP type from the db type.
getSchemaName | in file TMssqlTableInfo.php, method TMssqlTableInfo::getSchemaName()
getTableFullName | in file TMssqlTableInfo.php, method TMssqlTableInfo::getTableFullName()
getTableInfoClass | in file TMssqlMetaData.php, method TMssqlMetaData::getTableInfoClass()
top
h
hasSequence | in file TMssqlTableColumn.php, method TMssqlTableColumn::hasSequence()
top
i
isForeignKeyColumn | in file TMssqlMetaData.php, method TMssqlMetaData::isForeignKeyColumn()
top
p
processColumn | in file TMssqlMetaData.php, method TMssqlMetaData::processColumn()
top
q
quoteColumnAlias in file TMssqlMetaData.php, method TMssqlMetaData::quoteColumnAlias()
Quotes a column alias for use in a query.
quoteColumnName in file TMssqlMetaData.php, method TMssqlMetaData::quoteColumnName()
Quotes a column name for use in a query.
quoteTableName in file TMssqlMetaData.php, method TMssqlMetaData::quoteTableName()
Quotes a table name for use in a query.
top
t
TMssqlMetaData.php | procedural page TMssqlMetaData.php
TMssqlTableColumn.php | procedural page TMssqlTableColumn.php
TMssqlTableInfo.php | procedural page TMssqlTableInfo.php
TMssqlMetaData in file TMssqlMetaData.php, class TMssqlMetaData
TMssqlMetaData loads MSSQL database table and column information.
TMssqlTableColumn in file TMssqlTableColumn.php, class TMssqlTableColumn
Describes the column metadata of the schema for a Mssql database table.
TMssqlTableInfo in file TMssqlTableInfo.php, class TMssqlTableInfo
TMssqlTableInfo class provides additional table information for Mssql database.


Class Trees for Package System.Data.Common.Mssql

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TMssqlMetaData.php

File: /Data/Common/Mssql/TMssqlMetaData.php

Remarks

TMssqlMetaData class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TPgsqlMetaData.php 1866 2007-04-14 05:02:29Z wei $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMssqlMetaData
TMssqlMetaData loads MSSQL database table and column information.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:51 +0200 by phpDocumentor 1.4.3


Docs for page TMssqlTableColumn.php

File: /Data/Common/Mssql/TMssqlTableColumn.php

Remarks

TMssqlTableColumn class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TMssqlTableColumn.php 1863 2007-04-12 12:43:49Z wei $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMssqlTableColumn
Describes the column metadata of the schema for a Mssql database table.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:52 +0200 by phpDocumentor 1.4.3


Docs for page TMssqlTableInfo.php

File: /Data/Common/Mssql/TMssqlTableInfo.php

Remarks

TMssqlTableInfo class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TMssqlTableInfo.php 1861 2007-04-12 08:05:03Z wei $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMssqlTableInfo
TMssqlTableInfo class provides additional table information for Mssql database.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:52 +0200 by phpDocumentor 1.4.3


Docs For Class TMssqlMetaData

Class TMssqlMetaData

[line 27]
TComponent
   |
   --TDbMetaData
      |
      --TMssqlMetaData
Location: /Data/Common/Mssql/TMssqlMetaData.php

Remarks

TMssqlMetaData loads MSSQL database table and column information.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TPgsqlMetaData.php 1866 2007-04-14 05:02:29Z wei $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TDbMetaData

  • TDbMetaData::$delimiterIdentifier = array('[', ']', '"', '`', "'")

Method Summary

Inherited Method Summary

Inherited From Class TDbMetaData

  • TDbMetaData::__construct()
  • TDbMetaData::createCommandBuilder()
    Creates a command builder for a given table name.
  • TDbMetaData::createTableInfo()
    This method should be implemented by decendent classes.
  • TDbMetaData::getDbConnection()
  • TDbMetaData::getInstance()
    Obtain database specific TDbMetaData class using the driver name of the database connection.
  • TDbMetaData::getTableInfo()
    Obtains table meta data information for the current connection and given table name.
  • TDbMetaData::getTableInfoClass()
  • TDbMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
  • TDbMetaData::quoteColumnName()
    Quotes a column name for use in a query.
  • TDbMetaData::quoteTableName()
    Quotes a table name for use in a query.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TMssqlMetaData::createNewTableInfo

    createNewTableInfo( string $col, string 1 );

    Parameters

    1

    table name.

    $col

    table schema name

    access

    protected

    [ Top ]

    TMssqlMetaData::createTableInfo

    createTableInfo( string $table );

    Overrides TDbMetaData::createTableInfo() (This method should be implemented by decendent classes.)

    Parameters

    $table

    table name.

    Returns

    table information.

    Remarks

    Get the column definitions for given table.

    access

    protected

    [ Top ]

    TMssqlMetaData::getCatalogSchemaTableName

    getCatalogSchemaTableName( string $table );

    Parameters

    $table

    table name

    Returns

    tuple($catalogName,$schemaName,$tableName)

    access

    protected

    [ Top ]

    TMssqlMetaData::getConstraintKeys

    getConstraintKeys( string $col, string 1 );

    Parameters

    1

    table name.

    $col

    schema name

    Returns

    tuple ($primary, $foreign)

    Remarks

    Gets the primary and foreign key column details for the given table.

    access

    protected

    [ Top ]

    TMssqlMetaData::getForeignConstraints

    getForeignConstraints( string $col, string 1 );

    Parameters

    1

    table name

    $col

    database name

    Returns

    foreign relationship table name and keys.

    Remarks

    Gets foreign relationship constraint keys and table name

    access

    protected

    [ Top ]

    TMssqlMetaData::getTableInfoClass

    getTableInfoClass( );

    Overrides TDbMetaData::getTableInfoClass() (parent method not documented)

    Returns

    TDbTableInfo class name.

    access

    protected

    [ Top ]

    TMssqlMetaData::isForeignKeyColumn

    isForeignKeyColumn( string $columnId, TPgsqlTableInfo $tableInfo );

    Parameters

    $columnId

    column name.

    $tableInfo

    table information.

    Returns

    true if column is a foreign key.

    access

    protected

    [ Top ]

    TMssqlMetaData::processColumn

    processColumn( TMssqlTableInfo $tableInfo, array $col );

    Parameters

    $tableInfo

    table information.

    $col

    column information.

    access

    protected

    [ Top ]

    TMssqlMetaData::quoteColumnAlias

    quoteColumnAlias( string $name );

    Overrides TDbMetaData::quoteColumnAlias() (Quotes a column alias for use in a query.)

    Parameters

    $name

    column alias

    Returns

    the properly quoted column alias

    Remarks

    Quotes a column alias for use in a query.

    access

    public

    [ Top ]

    TMssqlMetaData::quoteColumnName

    quoteColumnName( string $name );

    Overrides TDbMetaData::quoteColumnName() (Quotes a column name for use in a query.)

    Parameters

    $name

    column name

    Returns

    the properly quoted column name

    Remarks

    Quotes a column name for use in a query.

    access

    public

    [ Top ]

    TMssqlMetaData::quoteTableName

    quoteTableName( string $name );

    Overrides TDbMetaData::quoteTableName() (Quotes a table name for use in a query.)

    Parameters

    $name

    table name

    Returns

    the properly quoted table name

    Remarks

    Quotes a table name for use in a query.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:51 +0200 by phpDocumentor 1.4.3


Docs For Class TMssqlTableColumn

Class TMssqlTableColumn

[line 26]
TComponent
   |
   --TDbTableColumn
      |
      --TMssqlTableColumn
Location: /Data/Common/Mssql/TMssqlTableColumn.php

Remarks

Describes the column metadata of the schema for a Mssql database table.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TMssqlTableColumn.php 1863 2007-04-12 12:43:49Z wei $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TDbTableColumn

  • TDbTableColumn::UNDEFINED_VALUE = INF

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbTableColumn

  • TDbTableColumn::__construct()
    Sets the table column meta data.
  • TDbTableColumn::getAllowNull()
  • TDbTableColumn::getColumnId()
  • TDbTableColumn::getColumnIndex()
  • TDbTableColumn::getColumnName()
  • TDbTableColumn::getColumnSize()
  • TDbTableColumn::getDbType()
  • TDbTableColumn::getDefaultValue()
  • TDbTableColumn::getInfo()
  • TDbTableColumn::getIsExcluded()
  • TDbTableColumn::getIsForeignKey()
  • TDbTableColumn::getIsPrimaryKey()
  • TDbTableColumn::getMaxiumNumericConstraint()
  • TDbTableColumn::getNumericPrecision()
  • TDbTableColumn::getNumericScale()
  • TDbTableColumn::getPdoType()
  • TDbTableColumn::getPHPType()
    Returns the derived PHP primitive type from the db type. Default returns 'string'.
  • TDbTableColumn::getSequenceName()
  • TDbTableColumn::hasSequence()
  • TDbTableColumn::setInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TMssqlTableColumn::getAutoIncrement

    getAutoIncrement( );

    Returns

    true if the column has identity (auto-increment)

    access

    public

    [ Top ]

    TMssqlTableColumn::getIsExcluded

    getIsExcluded( );

    Overrides TDbTableColumn::getIsExcluded() (parent method not documented)

    Returns

    true if db type is 'timestamp'.

    access

    public

    [ Top ]

    TMssqlTableColumn::getPHPType

    getPHPType( );

    Overrides TDbTableColumn::getPHPType() (Returns the derived PHP primitive type from the db type. Default returns 'string'.)

    Returns

    derived PHP primitive type from the column db type.

    Remarks

    Overrides parent implementation, returns PHP type from the db type.

    access

    public

    [ Top ]

    TMssqlTableColumn::hasSequence

    hasSequence( );

    Overrides TDbTableColumn::hasSequence() (parent method not documented)

    Returns

    true if auto increments.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:52 +0200 by phpDocumentor 1.4.3


Docs For Class TMssqlTableInfo

Class TMssqlTableInfo

[line 27]
TComponent
   |
   --TDbTableInfo
      |
      --TMssqlTableInfo
Location: /Data/Common/Mssql/TMssqlTableInfo.php

Remarks

TMssqlTableInfo class provides additional table information for Mssql database.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TMssqlTableInfo.php 1861 2007-04-12 08:05:03Z wei $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbTableInfo

  • TDbTableInfo::__construct()
    Sets the database table meta data information.
  • TDbTableInfo::createCommandBuilder()
  • TDbTableInfo::getColumn()
  • TDbTableInfo::getColumnNames()
  • TDbTableInfo::getColumns()
  • TDbTableInfo::getForeignKeys()
  • TDbTableInfo::getInfo()
  • TDbTableInfo::getIsView()
  • TDbTableInfo::getLowerCaseColumnNames()
  • TDbTableInfo::getPrimaryKeys()
  • TDbTableInfo::getTableFullName()
  • TDbTableInfo::getTableName()
  • TDbTableInfo::setInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TMssqlTableInfo::createCommandBuilder

    createCommandBuilder( TDbConnection $connection );

    Overrides TDbTableInfo::createCommandBuilder() (parent method not documented)

    Parameters

    $connection

    database connection.

    Returns

    new command builder

    access

    public

    [ Top ]

    TMssqlTableInfo::getCatalogName

    getCatalogName( );

    Returns

    catalog name (database name)

    access

    public

    [ Top ]

    TMssqlTableInfo::getSchemaName

    getSchemaName( );

    Returns

    name of the schema this column belongs to.

    access

    public

    [ Top ]

    TMssqlTableInfo::getTableFullName

    getTableFullName( );

    Overrides TDbTableInfo::getTableFullName() (parent method not documented)

    Returns

    full name of the table, database dependent.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:52 +0200 by phpDocumentor 1.4.3


Package System.Data.Common.Mysql Element Index

Element index for package System.Data.Common.Mysql

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
c f g h i p q t
top
c
createCommandBuilder | in file TMysqlTableInfo.php, method TMysqlTableInfo::createCommandBuilder()
createNewTableInfo | in file TMysqlMetaData.php, method TMysqlMetaData::createNewTableInfo()
createTableInfo in file TMysqlMetaData.php, method TMysqlMetaData::createTableInfo()
Get the column definitions for given table.
top
f
findForeignConstraints in file TMysqlMetaData.php, method TMysqlMetaData::findForeignConstraints()
Extract foreign key constraints by extracting the contraints from SHOW CREATE TABLE result.
top
g
getAutoIncrement | in file TMysqlTableColumn.php, method TMysqlTableColumn::getAutoIncrement()
getConstraintKeys in file TMysqlMetaData.php, method TMysqlMetaData::getConstraintKeys()
Gets the primary and foreign key column details for the given table.
getDbTypeValues | in file TMysqlTableColumn.php, method TMysqlTableColumn::getDbTypeValues()
getForeignConstraints in file TMysqlMetaData.php, method TMysqlMetaData::getForeignConstraints()
Gets foreign relationship constraint keys and table name
getIsView in file TMysqlMetaData.php, method TMysqlMetaData::getIsView()
For MySQL version 5.0.1 or later we can use SHOW FULL TABLES http://dev.mysql.com/doc/refman/5.0/en/show-tables.html
getPHPType in file TMysqlTableColumn.php, method TMysqlTableColumn::getPHPType()
Overrides parent implementation, returns PHP type from the db type.
getSchemaName | in file TMysqlTableInfo.php, method TMysqlTableInfo::getSchemaName()
getSchemaTableName | in file TMysqlMetaData.php, method TMysqlMetaData::getSchemaTableName()
getServerVersion | in file TMysqlMetaData.php, method TMysqlMetaData::getServerVersion()
getShowCreateTable | in file TMysqlMetaData.php, method TMysqlMetaData::getShowCreateTable()
getTableFullName | in file TMysqlTableInfo.php, method TMysqlTableInfo::getTableFullName()
getTableInfoClass | in file TMysqlMetaData.php, method TMysqlMetaData::getTableInfoClass()
top
h
hasSequence | in file TMysqlTableColumn.php, method TMysqlTableColumn::hasSequence()
top
i
isEnumSetType | in file TMysqlMetaData.php, method TMysqlMetaData::isEnumSetType()
isForeignKeyColumn | in file TMysqlMetaData.php, method TMysqlMetaData::isForeignKeyColumn()
isPrecisionType | in file TMysqlMetaData.php, method TMysqlMetaData::isPrecisionType()
isValidIdentifier in file TMysqlMetaData.php, method TMysqlMetaData::isValidIdentifier()
http://dev.mysql.com/doc/refman/5.0/en/identifiers.html
top
p
processColumn | in file TMysqlMetaData.php, method TMysqlMetaData::processColumn()
top
q
quoteColumnAlias in file TMysqlMetaData.php, method TMysqlMetaData::quoteColumnAlias()
Quotes a column alias for use in a query.
quoteColumnName in file TMysqlMetaData.php, method TMysqlMetaData::quoteColumnName()
Quotes a column name for use in a query.
quoteTableName in file TMysqlMetaData.php, method TMysqlMetaData::quoteTableName()
Quotes a table name for use in a query.
top
t
TMysqlMetaData.php | procedural page TMysqlMetaData.php
TMysqlTableColumn.php | procedural page TMysqlTableColumn.php
TMysqlTableInfo.php | procedural page TMysqlTableInfo.php
TMysqlMetaData in file TMysqlMetaData.php, class TMysqlMetaData
TMysqlMetaData loads Mysql version 4.1.x and 5.x database table and column information.
TMysqlTableColumn in file TMysqlTableColumn.php, class TMysqlTableColumn
Describes the column metadata of the schema for a Mysql database table.
TMysqlTableInfo in file TMysqlTableInfo.php, class TMysqlTableInfo
TMysqlTableInfo class provides additional table information for MySQL database.


Class Trees for Package System.Data.Common.Mysql

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TMysqlMetaData.php

File: /Data/Common/Mysql/TMysqlMetaData.php

Remarks

TMysqlMetaData class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TMysqlMetaData.php 3062 2011-11-12 16:12:40Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMysqlMetaData
TMysqlMetaData loads Mysql version 4.1.x and 5.x database table and column information.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:53 +0200 by phpDocumentor 1.4.3


Docs for page TMysqlTableColumn.php

File: /Data/Common/Mysql/TMysqlTableColumn.php

Remarks

TMysqlTableColumn class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TMysqlTableColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMysqlTableColumn
Describes the column metadata of the schema for a Mysql database table.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:54 +0200 by phpDocumentor 1.4.3


Docs for page TMysqlTableInfo.php

File: /Data/Common/Mysql/TMysqlTableInfo.php

Remarks

TMysqlTableInfo class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TMysqlTableInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TMysqlTableInfo
TMysqlTableInfo class provides additional table information for MySQL database.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:54 +0200 by phpDocumentor 1.4.3


Docs For Class TMysqlMetaData

Class TMysqlMetaData

[line 30]
TComponent
   |
   --TDbMetaData
      |
      --TMysqlMetaData
Location: /Data/Common/Mysql/TMysqlMetaData.php

Remarks

TMysqlMetaData loads Mysql version 4.1.x and 5.x database table and column information.

For Mysql version 4.1.x, PHP 5.1.3 or later is required. See http://netevil.org/node.php?nid=795&SC=1

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TMysqlMetaData.php 3062 2011-11-12 16:12:40Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TDbMetaData

  • TDbMetaData::$delimiterIdentifier = array('[', ']', '"', '`', "'")

Method Summary

Inherited Method Summary

Inherited From Class TDbMetaData

  • TDbMetaData::__construct()
  • TDbMetaData::createCommandBuilder()
    Creates a command builder for a given table name.
  • TDbMetaData::createTableInfo()
    This method should be implemented by decendent classes.
  • TDbMetaData::getDbConnection()
  • TDbMetaData::getInstance()
    Obtain database specific TDbMetaData class using the driver name of the database connection.
  • TDbMetaData::getTableInfo()
    Obtains table meta data information for the current connection and given table name.
  • TDbMetaData::getTableInfoClass()
  • TDbMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
  • TDbMetaData::quoteColumnName()
    Quotes a column name for use in a query.
  • TDbMetaData::quoteTableName()
    Quotes a table name for use in a query.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TMysqlMetaData::createNewTableInfo

    createNewTableInfo( string $table, string 1 );

    Parameters

    1

    table name.

    $table

    table schema name

    access

    protected

    [ Top ]

    TMysqlMetaData::createTableInfo

    createTableInfo( string $table );

    Overrides TDbMetaData::createTableInfo() (This method should be implemented by decendent classes.)

    Parameters

    $table

    table name.

    Returns

    table information.

    Remarks

    Get the column definitions for given table.

    access

    protected

    [ Top ]

    TMysqlMetaData::findForeignConstraints

    findForeignConstraints( string $schemaName, string $tableName );

    Parameters

    $schemaName

    database name

    $tableName

    table name

    Returns

    foreign relationship table name and keys.

    Remarks

    Extract foreign key constraints by extracting the contraints from SHOW CREATE TABLE result.

    access

    protected

    [ Top ]

    TMysqlMetaData::getConstraintKeys

    getConstraintKeys( string $schemaName, string $tableName );

    Parameters

    $schemaName

    schema name

    $tableName

    table name.

    Returns

    tuple ($primary, $foreign)

    Remarks

    Gets the primary and foreign key column details for the given table.

    access

    protected

    [ Top ]

    TMysqlMetaData::getForeignConstraints

    getForeignConstraints( string $schemaName, string $tableName );

    Parameters

    $schemaName

    database name

    $tableName

    table name

    Returns

    foreign relationship table name and keys.

    Remarks

    Gets foreign relationship constraint keys and table name

    access

    protected

    [ Top ]

    TMysqlMetaData::getIsView

    getIsView( string $schemaName, string $tableName );

    Parameters

    $schemaName

    database name, null to use default connection database.

    $tableName

    table or view name.

    Returns

    true if is view, false otherwise.

    Remarks

    For MySQL version 5.0.1 or later we can use SHOW FULL TABLES http://dev.mysql.com/doc/refman/5.0/en/show-tables.html

    For MySQL version 5.0.1 or ealier, this always return false.

    throws

    TDbException if table or view does not exist.

    access

    protected

    [ Top ]

    TMysqlMetaData::getSchemaTableName

    getSchemaTableName( string $table );

    Parameters

    $table

    table name, may be quoted with back-ticks and may contain database name.

    Returns

    tuple ($schema,$table), $schema may be null.

    throws

    TDbException when table name contains invalid identifier bytes.

    access

    protected

    [ Top ]

    TMysqlMetaData::getServerVersion

    getServerVersion( );

    Returns

    server version.

    access

    protected

    [ Top ]

    TMysqlMetaData::getShowCreateTable

    getShowCreateTable( string $schemaName, string $tableName );

    Parameters

    $schemaName

    database name

    $tableName

    table name

    Returns

    SQL command to create the table.

    throws

    TDbException if PHP version is less than 5.1.3

    access

    protected

    [ Top ]

    TMysqlMetaData::getTableInfoClass

    getTableInfoClass( );

    Overrides TDbMetaData::getTableInfoClass() (parent method not documented)

    Returns

    TDbTableInfo class name.

    access

    protected

    [ Top ]

    TMysqlMetaData::isEnumSetType

    isEnumSetType( $type );

    Parameters

    $type

    Returns

    true if column type if "enum" or "set".

    access

    protected

    [ Top ]

    TMysqlMetaData::isForeignKeyColumn

    isForeignKeyColumn( string $columnId, TPgsqlTableInfo $tableInfo );

    Parameters

    $columnId

    column name.

    $tableInfo

    table information.

    Returns

    true if column is a foreign key.

    access

    protected

    [ Top ]

    TMysqlMetaData::isPrecisionType

    isPrecisionType( $type );

    Parameters

    $type

    Returns

    true if column type if "numeric", "interval" or begins with "time".

    access

    protected

    [ Top ]

    TMysqlMetaData::isValidIdentifier

    isValidIdentifier( string $name, boolean 1 );

    Parameters

    1

    true if valid identifier.

    $name

    identifier name

    Remarks

    http://dev.mysql.com/doc/refman/5.0/en/identifiers.html

    access

    protected

    [ Top ]

    TMysqlMetaData::processColumn

    processColumn( TMysqlTableInfo $tableInfo, array $col );

    Parameters

    $tableInfo

    table information.

    $col

    column information.

    access

    protected

    [ Top ]

    TMysqlMetaData::quoteColumnAlias

    quoteColumnAlias( string $name );

    Overrides TDbMetaData::quoteColumnAlias() (Quotes a column alias for use in a query.)

    Parameters

    $name

    column alias

    Returns

    the properly quoted column alias

    Remarks

    Quotes a column alias for use in a query.

    access

    public

    [ Top ]

    TMysqlMetaData::quoteColumnName

    quoteColumnName( string $name );

    Overrides TDbMetaData::quoteColumnName() (Quotes a column name for use in a query.)

    Parameters

    $name

    column name

    Returns

    the properly quoted column name

    Remarks

    Quotes a column name for use in a query.

    access

    public

    [ Top ]

    TMysqlMetaData::quoteTableName

    quoteTableName( string $name );

    Overrides TDbMetaData::quoteTableName() (Quotes a table name for use in a query.)

    Parameters

    $name

    table name

    Returns

    the properly quoted table name

    Remarks

    Quotes a table name for use in a query.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:53 +0200 by phpDocumentor 1.4.3


Docs For Class TMysqlTableColumn

Class TMysqlTableColumn

[line 26]
TComponent
   |
   --TDbTableColumn
      |
      --TMysqlTableColumn
Location: /Data/Common/Mysql/TMysqlTableColumn.php

Remarks

Describes the column metadata of the schema for a Mysql database table.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TMysqlTableColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TDbTableColumn

  • TDbTableColumn::UNDEFINED_VALUE = INF

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbTableColumn

  • TDbTableColumn::__construct()
    Sets the table column meta data.
  • TDbTableColumn::getAllowNull()
  • TDbTableColumn::getColumnId()
  • TDbTableColumn::getColumnIndex()
  • TDbTableColumn::getColumnName()
  • TDbTableColumn::getColumnSize()
  • TDbTableColumn::getDbType()
  • TDbTableColumn::getDefaultValue()
  • TDbTableColumn::getInfo()
  • TDbTableColumn::getIsExcluded()
  • TDbTableColumn::getIsForeignKey()
  • TDbTableColumn::getIsPrimaryKey()
  • TDbTableColumn::getMaxiumNumericConstraint()
  • TDbTableColumn::getNumericPrecision()
  • TDbTableColumn::getNumericScale()
  • TDbTableColumn::getPdoType()
  • TDbTableColumn::getPHPType()
    Returns the derived PHP primitive type from the db type. Default returns 'string'.
  • TDbTableColumn::getSequenceName()
  • TDbTableColumn::hasSequence()
  • TDbTableColumn::setInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TMysqlTableColumn::getAutoIncrement

    getAutoIncrement( );

    Returns

    true if column will auto-increment when the column value is inserted as null.

    access

    public

    [ Top ]

    TMysqlTableColumn::getDbTypeValues

    getDbTypeValues( );

    access

    public

    [ Top ]

    TMysqlTableColumn::getPHPType

    getPHPType( );

    Overrides TDbTableColumn::getPHPType() (Returns the derived PHP primitive type from the db type. Default returns 'string'.)

    Returns

    derived PHP primitive type from the column db type.

    Remarks

    Overrides parent implementation, returns PHP type from the db type.

    access

    public

    [ Top ]

    TMysqlTableColumn::hasSequence

    hasSequence( );

    Overrides TDbTableColumn::hasSequence() (parent method not documented)

    Returns

    true if auto increment is true.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:54 +0200 by phpDocumentor 1.4.3


Docs For Class TMysqlTableInfo

Class TMysqlTableInfo

[line 27]
TComponent
   |
   --TDbTableInfo
      |
      --TMysqlTableInfo
Location: /Data/Common/Mysql/TMysqlTableInfo.php

Remarks

TMysqlTableInfo class provides additional table information for MySQL database.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TMysqlTableInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbTableInfo

  • TDbTableInfo::__construct()
    Sets the database table meta data information.
  • TDbTableInfo::createCommandBuilder()
  • TDbTableInfo::getColumn()
  • TDbTableInfo::getColumnNames()
  • TDbTableInfo::getColumns()
  • TDbTableInfo::getForeignKeys()
  • TDbTableInfo::getInfo()
  • TDbTableInfo::getIsView()
  • TDbTableInfo::getLowerCaseColumnNames()
  • TDbTableInfo::getPrimaryKeys()
  • TDbTableInfo::getTableFullName()
  • TDbTableInfo::getTableName()
  • TDbTableInfo::setInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TMysqlTableInfo::createCommandBuilder

    createCommandBuilder( TDbConnection $connection );

    Overrides TDbTableInfo::createCommandBuilder() (parent method not documented)

    Parameters

    $connection

    database connection.

    Returns

    new command builder

    access

    public

    [ Top ]

    TMysqlTableInfo::getSchemaName

    getSchemaName( );

    Returns

    name of the schema this column belongs to.

    access

    public

    [ Top ]

    TMysqlTableInfo::getTableFullName

    getTableFullName( );

    Overrides TDbTableInfo::getTableFullName() (parent method not documented)

    Returns

    full name of the table, database dependent.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:54 +0200 by phpDocumentor 1.4.3


Package System.Data.Common.Oracle Element Index

Element index for package System.Data.Common.Oracle

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a c g i p s t
top
a
assertIdentifier | in file TOracleMetaData.php, method TOracleMetaData::assertIdentifier()
top
c
createNewTableInfo | in file TOracleMetaData.php, method TOracleMetaData::createNewTableInfo()
createTableInfo in file TOracleMetaData.php, method TOracleMetaData::createTableInfo()
Get the column definitions for given table.
top
g
getConstraintKeys in file TOracleMetaData.php, method TOracleMetaData::getConstraintKeys()
Gets the primary and foreign key column details for the given table.
getDefaultSchema | in file TOracleMetaData.php, method TOracleMetaData::getDefaultSchema()
getForeignKeys in file TOracleMetaData.php, method TOracleMetaData::getForeignKeys()
Gets foreign relationship constraint keys and table name
getIsView | in file TOracleMetaData.php, method TOracleMetaData::getIsView()
getPHPType in file TOracleTableColumn.php, method TOracleTableColumn::getPHPType()
Overrides parent implementation, returns PHP type from the db type.
getPrimaryKeys in file TOracleMetaData.php, method TOracleMetaData::getPrimaryKeys()
Gets the primary key field names
getSchemaTableName | in file TOracleMetaData.php, method TOracleMetaData::getSchemaTableName()
getSequenceName | in file TOracleMetaData.php, method TOracleMetaData::getSequenceName()
getTableInfoClass | in file TOracleMetaData.php, method TOracleMetaData::getTableInfoClass()
top
i
isForeignKeyColumn | in file TOracleMetaData.php, method TOracleMetaData::isForeignKeyColumn()
isPrecisionType | in file TOracleMetaData.php, method TOracleMetaData::isPrecisionType()
top
p
processColumn | in file TOracleMetaData.php, method TOracleMetaData::processColumn()
top
s
setDefaultSchema | in file TOracleMetaData.php, method TOracleMetaData::setDefaultSchema()
top
t
TOracleMetaData.php | procedural page TOracleMetaData.php
TOracleTableColumn.php | procedural page TOracleTableColumn.php
TOracleMetaData in file TOracleMetaData.php, class TOracleMetaData
TOracleMetaData loads Oracle database table and column information.
TOracleTableColumn in file TOracleTableColumn.php, class TOracleTableColumn
Describes the column metadata of the schema for a PostgreSQL database table.


Class Trees for Package System.Data.Common.Oracle

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TOracleMetaData.php

File: /Data/Common/Oracle/TOracleMetaData.php

Remarks

TOracleMetaData class file.

author

Marcos Nobre <marconobre[at]gmail[dot]com>

version

$Id: TOracleMetaData.php 3073 2011-11-19 16:58:40Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TOracleMetaData
TOracleMetaData loads Oracle database table and column information.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:55 +0200 by phpDocumentor 1.4.3


Docs for page TOracleTableColumn.php

File: /Data/Common/Oracle/TOracleTableColumn.php

Remarks

TOracleTableColumn class file.

author

Marcos Nobre <marconobre[at]gmail[dot]com>

version

$Id: TOracleTableColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TOracleTableColumn
Describes the column metadata of the schema for a PostgreSQL database table.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:44:55 +0200 by phpDocumentor 1.4.3


Docs For Class TOracleMetaData

Class TOracleMetaData

[line 28]
TComponent
   |
   --TDbMetaData
      |
      --TOracleMetaData
Location: /Data/Common/Oracle/TOracleMetaData.php

Remarks

TOracleMetaData loads Oracle database table and column information.

author

Marcos Nobre <marconobre[at]gmail[dot]com>

version

$Id: TOracleMetaData.php 3073 2011-11-19 16:58:40Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TDbMetaData

  • TDbMetaData::$delimiterIdentifier = array('[', ']', '"', '`', "'")

Method Summary

Inherited Method Summary

Inherited From Class TDbMetaData

  • TDbMetaData::__construct()
  • TDbMetaData::createCommandBuilder()
    Creates a command builder for a given table name.
  • TDbMetaData::createTableInfo()
    This method should be implemented by decendent classes.
  • TDbMetaData::getDbConnection()
  • TDbMetaData::getInstance()
    Obtain database specific TDbMetaData class using the driver name of the database connection.
  • TDbMetaData::getTableInfo()
    Obtains table meta data information for the current connection and given table name.
  • TDbMetaData::getTableInfoClass()
  • TDbMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
  • TDbMetaData::quoteColumnName()
    Quotes a column name for use in a query.
  • TDbMetaData::quoteTableName()
    Quotes a table name for use in a query.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TOracleMetaData::assertIdentifier

    assertIdentifier( string $name );

    Parameters

    $name

    table name, schema name or column name.

    Returns

    a valid identifier.

    throws

    TDbException when table name contains a double quote (").

    access

    protected

    [ Top ]

    TOracleMetaData::createNewTableInfo

    createNewTableInfo( string $schemaName, string $tableName );

    Parameters

    $schemaName

    table schema name

    $tableName

    table name.

    access

    protected

    [ Top ]

    TOracleMetaData::createTableInfo

    createTableInfo( string $table );

    Overrides TDbMetaData::createTableInfo() (This method should be implemented by decendent classes.)

    Parameters

    $table

    table name.

    Returns

    table information.

    Remarks

    Get the column definitions for given table.

    access

    protected

    [ Top ]

    TOracleMetaData::getConstraintKeys

    getConstraintKeys( string $schemaName, string $tableName );

    Parameters

    $schemaName

    schema name

    $tableName

    table name.

    Returns

    tuple ($primary, $foreign)

    Remarks

    Gets the primary and foreign key column details for the given table.

    access

    protected

    [ Top ]

    TOracleMetaData::getDefaultSchema

    getDefaultSchema( );

    Returns

    default schema.

    access

    public

    [ Top ]

    TOracleMetaData::getForeignKeys

    getForeignKeys( string $src );

    Parameters

    $src

    Oracle foreign key definition

    Returns

    foreign relationship table name and keys, null otherwise

    Remarks

    Gets foreign relationship constraint keys and table name

    access

    protected

    [ Top ]

    TOracleMetaData::getIsView

    getIsView( string $schemaName, string $tableName );

    Parameters

    $schemaName

    table schema name

    $tableName

    table name.

    Returns

    true if the table is a view.

    access

    protected

    [ Top ]

    TOracleMetaData::getPrimaryKeys

    getPrimaryKeys( string $src );

    Parameters

    $src

    Oracle primary key definition

    Returns

    primary key field names.

    Remarks

    Gets the primary key field names

    access

    protected

    [ Top ]

    TOracleMetaData::getSchemaTableName

    getSchemaTableName( string $table );

    Parameters

    $table

    table name with optional schema name prefix, uses default schema name prefix is not provided.

    Returns

    tuple as ($schemaName,$tableName)

    access

    protected

    [ Top ]

    TOracleMetaData::getSequenceName

    getSequenceName( $tableInfo, $src );

    Parameters

    $tableInfo

    $src

    Returns

    serial name if found, null otherwise.

    access

    protected

    [ Top ]

    TOracleMetaData::getTableInfoClass

    getTableInfoClass( );

    Overrides TDbMetaData::getTableInfoClass() (parent method not documented)

    Returns

    TDbTableInfo class name.

    access

    protected

    [ Top ]

    TOracleMetaData::isForeignKeyColumn

    isForeignKeyColumn( string $columnId, TOracleTableInfo $tableInfo );

    Parameters

    $columnId

    column name.

    $tableInfo

    table information.

    Returns

    true if column is a foreign key.

    access

    protected

    [ Top ]

    TOracleMetaData::isPrecisionType

    isPrecisionType( $type );

    Parameters

    $type

    Returns

    true if column type if "numeric", "interval" or begins with "time".

    access

    protected

    [ Top ]

    TOracleMetaData::processColumn

    processColumn( TOracleTableInfo $tableInfo, array $col );

    Parameters

    $tableInfo

    table information.

    $col

    column information.

    access

    protected

    [ Top ]

    TOracleMetaData::setDefaultSchema

    setDefaultSchema( string $schema );

    Parameters

    $schema

    default schema.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:55 +0200 by phpDocumentor 1.4.3


Docs For Class TOracleTableColumn

Class TOracleTableColumn

[line 26]
TComponent
   |
   --TDbTableColumn
      |
      --TOracleTableColumn
Location: /Data/Common/Oracle/TOracleTableColumn.php

Remarks

Describes the column metadata of the schema for a PostgreSQL database table.

author

Marcos Nobre <marconobre[at]gmail[dot]com>

version

$Id: TOracleTableColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TDbTableColumn

  • TDbTableColumn::UNDEFINED_VALUE = INF

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbTableColumn

  • TDbTableColumn::__construct()
    Sets the table column meta data.
  • TDbTableColumn::getAllowNull()
  • TDbTableColumn::getColumnId()
  • TDbTableColumn::getColumnIndex()
  • TDbTableColumn::getColumnName()
  • TDbTableColumn::getColumnSize()
  • TDbTableColumn::getDbType()
  • TDbTableColumn::getDefaultValue()
  • TDbTableColumn::getInfo()
  • TDbTableColumn::getIsExcluded()
  • TDbTableColumn::getIsForeignKey()
  • TDbTableColumn::getIsPrimaryKey()
  • TDbTableColumn::getMaxiumNumericConstraint()
  • TDbTableColumn::getNumericPrecision()
  • TDbTableColumn::getNumericScale()
  • TDbTableColumn::getPdoType()
  • TDbTableColumn::getPHPType()
    Returns the derived PHP primitive type from the db type. Default returns 'string'.
  • TDbTableColumn::getSequenceName()
  • TDbTableColumn::hasSequence()
  • TDbTableColumn::setInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TOracleTableColumn::getPHPType

    getPHPType( );

    Overrides TDbTableColumn::getPHPType() (Returns the derived PHP primitive type from the db type. Default returns 'string'.)

    Returns

    derived PHP primitive type from the column db type.

    Remarks

    Overrides parent implementation, returns PHP type from the db type.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:44:55 +0200 by phpDocumentor 1.4.3


Package System.Data.Common.Pgsql Element Index

Element index for package System.Data.Common.Pgsql

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
a c g i p q s t
top
a
assertIdentifier | in file TPgsqlMetaData.php, method TPgsqlMetaData::assertIdentifier()
top
c
createCommandBuilder | in file TPgsqlTableInfo.php, method TPgsqlTableInfo::createCommandBuilder()
createNewTableInfo | in file TPgsqlMetaData.php, method TPgsqlMetaData::createNewTableInfo()
createTableInfo in file TPgsqlMetaData.php, method TPgsqlMetaData::createTableInfo()
Get the column definitions for given table.
top
g
getConstraintKeys in file TPgsqlMetaData.php, method TPgsqlMetaData::getConstraintKeys()
Gets the primary and foreign key column details for the given table.
getDefaultSchema | in file TPgsqlMetaData.php, method TPgsqlMetaData::getDefaultSchema()
getForeignKeys in file TPgsqlMetaData.php, method TPgsqlMetaData::getForeignKeys()
Gets foreign relationship constraint keys and table name
getIsView | in file TPgsqlMetaData.php, method TPgsqlMetaData::getIsView()
getPHPType in file TPgsqlTableColumn.php, method TPgsqlTableColumn::getPHPType()
Overrides parent implementation, returns PHP type from the db type.
getPrimaryKeys in file TPgsqlMetaData.php, method TPgsqlMetaData::getPrimaryKeys()
Gets the primary key field names
getSchemaName | in file TPgsqlTableInfo.php, method TPgsqlTableInfo::getSchemaName()
getSchemaTableName | in file TPgsqlMetaData.php, method TPgsqlMetaData::getSchemaTableName()
getSequenceName | in file TPgsqlMetaData.php, method TPgsqlMetaData::getSequenceName()
getTableFullName | in file TPgsqlTableInfo.php, method TPgsqlTableInfo::getTableFullName()
getTableInfoClass | in file TPgsqlMetaData.php, method TPgsqlMetaData::getTableInfoClass()
top
i
isForeignKeyColumn | in file TPgsqlMetaData.php, method TPgsqlMetaData::isForeignKeyColumn()
isPrecisionType | in file TPgsqlMetaData.php, method TPgsqlMetaData::isPrecisionType()
top
p
processColumn | in file TPgsqlMetaData.php, method TPgsqlMetaData::processColumn()
top
q
quoteColumnAlias in file TPgsqlMetaData.php, method TPgsqlMetaData::quoteColumnAlias()
Quotes a column alias for use in a query.
quoteColumnName in file TPgsqlMetaData.php, method TPgsqlMetaData::quoteColumnName()
Quotes a column name for use in a query.
quoteTableName in file TPgsqlMetaData.php, method TPgsqlMetaData::quoteTableName()
Quotes a table name for use in a query.
top
s
setDefaultSchema | in file TPgsqlMetaData.php, method TPgsqlMetaData::setDefaultSchema()
top
t
TPgsqlMetaData.php | procedural page TPgsqlMetaData.php
TPgsqlTableColumn.php | procedural page TPgsqlTableColumn.php
TPgsqlTableInfo.php | procedural page TPgsqlTableInfo.php
TPgsqlMetaData in file TPgsqlMetaData.php, class TPgsqlMetaData
TPgsqlMetaData loads PostgreSQL database table and column information.
TPgsqlTableColumn in file TPgsqlTableColumn.php, class TPgsqlTableColumn
Describes the column metadata of the schema for a PostgreSQL database table.
TPgsqlTableInfo in file TPgsqlTableInfo.php, class TPgsqlTableInfo
TPgsqlTableInfo class provides additional table information for PostgreSQL database.


Class Trees for Package System.Data.Common.Pgsql

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TPgsqlMetaData.php

File: /Data/Common/Pgsql/TPgsqlMetaData.php

Remarks

TPgsqlMetaData class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TPgsqlMetaData.php 3031 2011-08-28 06:24:03Z GODZilla0480@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPgsqlMetaData
TPgsqlMetaData loads PostgreSQL database table and column information.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:02 +0200 by phpDocumentor 1.4.3


Docs for page TPgsqlTableColumn.php

File: /Data/Common/Pgsql/TPgsqlTableColumn.php

Remarks

TPgsqlTableColumn class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TPgsqlTableColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPgsqlTableColumn
Describes the column metadata of the schema for a PostgreSQL database table.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:02 +0200 by phpDocumentor 1.4.3


Docs for page TPgsqlTableInfo.php

File: /Data/Common/Pgsql/TPgsqlTableInfo.php

Remarks

TPgsqlTableInfo class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TPgsqlTableInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TPgsqlTableInfo
TPgsqlTableInfo class provides additional table information for PostgreSQL database.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:02 +0200 by phpDocumentor 1.4.3


Docs For Class TPgsqlMetaData

Class TPgsqlMetaData

[line 27]
TComponent
   |
   --TDbMetaData
      |
      --TPgsqlMetaData
Location: /Data/Common/Pgsql/TPgsqlMetaData.php

Remarks

TPgsqlMetaData loads PostgreSQL database table and column information.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TPgsqlMetaData.php 3031 2011-08-28 06:24:03Z GODZilla0480@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TDbMetaData

  • TDbMetaData::$delimiterIdentifier = array('[', ']', '"', '`', "'")

Method Summary

Inherited Method Summary

Inherited From Class TDbMetaData

  • TDbMetaData::__construct()
  • TDbMetaData::createCommandBuilder()
    Creates a command builder for a given table name.
  • TDbMetaData::createTableInfo()
    This method should be implemented by decendent classes.
  • TDbMetaData::getDbConnection()
  • TDbMetaData::getInstance()
    Obtain database specific TDbMetaData class using the driver name of the database connection.
  • TDbMetaData::getTableInfo()
    Obtains table meta data information for the current connection and given table name.
  • TDbMetaData::getTableInfoClass()
  • TDbMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
  • TDbMetaData::quoteColumnName()
    Quotes a column name for use in a query.
  • TDbMetaData::quoteTableName()
    Quotes a table name for use in a query.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPgsqlMetaData::assertIdentifier

    assertIdentifier( string $name );

    Parameters

    $name

    table name, schema name or column name.

    Returns

    a valid identifier.

    throws

    TDbException when table name contains a double quote (").

    access

    protected

    [ Top ]

    TPgsqlMetaData::createNewTableInfo

    createNewTableInfo( string $schemaName, string $tableName );

    Parameters

    $schemaName

    table schema name

    $tableName

    table name.

    access

    protected

    [ Top ]

    TPgsqlMetaData::createTableInfo

    createTableInfo( string $table );

    Overrides TDbMetaData::createTableInfo() (This method should be implemented by decendent classes.)

    Parameters

    $table

    table name.

    Returns

    table information.

    Remarks

    Get the column definitions for given table.

    access

    protected

    [ Top ]

    TPgsqlMetaData::getConstraintKeys

    getConstraintKeys( string $schemaName, string $tableName );

    Parameters

    $schemaName

    schema name

    $tableName

    table name.

    Returns

    tuple ($primary, $foreign)

    Remarks

    Gets the primary and foreign key column details for the given table.

    access

    protected

    [ Top ]

    TPgsqlMetaData::getDefaultSchema

    getDefaultSchema( );

    Returns

    default schema.

    access

    public

    [ Top ]

    TPgsqlMetaData::getForeignKeys

    getForeignKeys( string $src );

    Parameters

    $src

    pgsql foreign key definition

    Returns

    foreign relationship table name and keys, null otherwise

    Remarks

    Gets foreign relationship constraint keys and table name

    access

    protected

    [ Top ]

    TPgsqlMetaData::getIsView

    getIsView( string $schemaName, string $tableName );

    Parameters

    $schemaName

    table schema name

    $tableName

    table name.

    Returns

    true if the table is a view.

    access

    protected

    [ Top ]

    TPgsqlMetaData::getPrimaryKeys

    getPrimaryKeys( string $tableName, $schemaName, $columnIndex );

    Parameters

    $tableName

    pgsql primary key definition

    $schemaName

    $columnIndex

    Returns

    primary key field names.

    Remarks

    Gets the primary key field names

    access

    protected

    [ Top ]

    TPgsqlMetaData::getSchemaTableName

    getSchemaTableName( string $table );

    Parameters

    $table

    table name with optional schema name prefix, uses default schema name prefix is not provided.

    Returns

    tuple as ($schemaName,$tableName)

    access

    protected

    [ Top ]

    TPgsqlMetaData::getSequenceName

    getSequenceName( $tableInfo, $src );

    Parameters

    $tableInfo

    $src

    Returns

    serial name if found, null otherwise.

    access

    protected

    [ Top ]

    TPgsqlMetaData::getTableInfoClass

    getTableInfoClass( );

    Overrides TDbMetaData::getTableInfoClass() (parent method not documented)

    Returns

    TDbTableInfo class name.

    access

    protected

    [ Top ]

    TPgsqlMetaData::isForeignKeyColumn

    isForeignKeyColumn( string $columnId, TPgsqlTableInfo $tableInfo );

    Parameters

    $columnId

    column name.

    $tableInfo

    table information.

    Returns

    true if column is a foreign key.

    access

    protected

    [ Top ]

    TPgsqlMetaData::isPrecisionType

    isPrecisionType( $type );

    Parameters

    $type

    Returns

    true if column type if "numeric", "interval" or begins with "time".

    access

    protected

    [ Top ]

    TPgsqlMetaData::processColumn

    processColumn( TPgsqlTableInfo $tableInfo, array $col );

    Parameters

    $tableInfo

    table information.

    $col

    column information.

    access

    protected

    [ Top ]

    TPgsqlMetaData::quoteColumnAlias

    quoteColumnAlias( string $name );

    Overrides TDbMetaData::quoteColumnAlias() (Quotes a column alias for use in a query.)

    Parameters

    $name

    column alias

    Returns

    the properly quoted column alias

    Remarks

    Quotes a column alias for use in a query.

    access

    public

    [ Top ]

    TPgsqlMetaData::quoteColumnName

    quoteColumnName( string $name );

    Overrides TDbMetaData::quoteColumnName() (Quotes a column name for use in a query.)

    Parameters

    $name

    column name

    Returns

    the properly quoted column name

    Remarks

    Quotes a column name for use in a query.

    access

    public

    [ Top ]

    TPgsqlMetaData::quoteTableName

    quoteTableName( string $name );

    Overrides TDbMetaData::quoteTableName() (Quotes a table name for use in a query.)

    Parameters

    $name

    table name

    Returns

    the properly quoted table name

    Remarks

    Quotes a table name for use in a query.

    access

    public

    [ Top ]

    TPgsqlMetaData::setDefaultSchema

    setDefaultSchema( string $schema );

    Parameters

    $schema

    default schema.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:02 +0200 by phpDocumentor 1.4.3


Docs For Class TPgsqlTableColumn

Class TPgsqlTableColumn

[line 26]
TComponent
   |
   --TDbTableColumn
      |
      --TPgsqlTableColumn
Location: /Data/Common/Pgsql/TPgsqlTableColumn.php

Remarks

Describes the column metadata of the schema for a PostgreSQL database table.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TPgsqlTableColumn.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TDbTableColumn

  • TDbTableColumn::UNDEFINED_VALUE = INF

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbTableColumn

  • TDbTableColumn::__construct()
    Sets the table column meta data.
  • TDbTableColumn::getAllowNull()
  • TDbTableColumn::getColumnId()
  • TDbTableColumn::getColumnIndex()
  • TDbTableColumn::getColumnName()
  • TDbTableColumn::getColumnSize()
  • TDbTableColumn::getDbType()
  • TDbTableColumn::getDefaultValue()
  • TDbTableColumn::getInfo()
  • TDbTableColumn::getIsExcluded()
  • TDbTableColumn::getIsForeignKey()
  • TDbTableColumn::getIsPrimaryKey()
  • TDbTableColumn::getMaxiumNumericConstraint()
  • TDbTableColumn::getNumericPrecision()
  • TDbTableColumn::getNumericScale()
  • TDbTableColumn::getPdoType()
  • TDbTableColumn::getPHPType()
    Returns the derived PHP primitive type from the db type. Default returns 'string'.
  • TDbTableColumn::getSequenceName()
  • TDbTableColumn::hasSequence()
  • TDbTableColumn::setInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPgsqlTableColumn::getPHPType

    getPHPType( );

    Overrides TDbTableColumn::getPHPType() (Returns the derived PHP primitive type from the db type. Default returns 'string'.)

    Returns

    derived PHP primitive type from the column db type.

    Remarks

    Overrides parent implementation, returns PHP type from the db type.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:02 +0200 by phpDocumentor 1.4.3


Docs For Class TPgsqlTableInfo

Class TPgsqlTableInfo

[line 27]
TComponent
   |
   --TDbTableInfo
      |
      --TPgsqlTableInfo
Location: /Data/Common/Pgsql/TPgsqlTableInfo.php

Remarks

TPgsqlTableInfo class provides additional table information for PostgreSQL database.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TPgsqlTableInfo.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbTableInfo

  • TDbTableInfo::__construct()
    Sets the database table meta data information.
  • TDbTableInfo::createCommandBuilder()
  • TDbTableInfo::getColumn()
  • TDbTableInfo::getColumnNames()
  • TDbTableInfo::getColumns()
  • TDbTableInfo::getForeignKeys()
  • TDbTableInfo::getInfo()
  • TDbTableInfo::getIsView()
  • TDbTableInfo::getLowerCaseColumnNames()
  • TDbTableInfo::getPrimaryKeys()
  • TDbTableInfo::getTableFullName()
  • TDbTableInfo::getTableName()
  • TDbTableInfo::setInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TPgsqlTableInfo::createCommandBuilder

    createCommandBuilder( TDbConnection $connection );

    Overrides TDbTableInfo::createCommandBuilder() (parent method not documented)

    Parameters

    $connection

    database connection.

    Returns

    new command builder

    access

    public

    [ Top ]

    TPgsqlTableInfo::getSchemaName

    getSchemaName( );

    Returns

    name of the schema this column belongs to.

    access

    public

    [ Top ]

    TPgsqlTableInfo::getTableFullName

    getTableFullName( );

    Overrides TDbTableInfo::getTableFullName() (parent method not documented)

    Returns

    full name of the table, database dependent.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:02 +0200 by phpDocumentor 1.4.3


Package System.Data.ActiveRecord.Scaffold Element Index

Element index for package System.Data.ActiveRecord.Scaffold

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
b c d g i l o p s t u
top
b
bubbleEvent in file TScaffoldView.php, method TScaffoldView::bubbleEvent()
Handle the "edit" and "new" commands by displaying the edit view.
bubbleEvent in file TScaffoldSearch.php, method TScaffoldSearch::bubbleEvent()
Sets the SearchCondition of the TScaffoldListView as the search terms given by the text of the search text box.
bubbleEvent in file TScaffoldListView.php, method TScaffoldListView::bubbleEvent()
Continue bubbling the "edit" command, "delete" command is handled in this class.
bubbleEvent in file TScaffoldEditView.php, method TScaffoldEditView::bubbleEvent()
Bubble the command name event. Stops bubbling when the page validator false.
top
c
clearRecordObject in file TScaffoldBase.php, method TScaffoldBase::clearRecordObject()
Unset the current record instance and table information.
copyFrom in file TScaffoldBase.php, method TScaffoldBase::copyFrom()
Copy the view details from another scaffold view instance.
createEditRenderer in file TScaffoldEditView.php, method TScaffoldEditView::createEditRenderer()
Instantiate the external edit renderer.
createRepeaterEditItem in file TScaffoldEditView.php, method TScaffoldEditView::createRepeaterEditItem()
Initialize the default editor using the scaffold input builder.
createSearchCondition | in file TScaffoldSearch.php, method TScaffoldSearch::createSearchCondition()
top
d
deleteRecord in file TScaffoldListView.php, method TScaffoldListView::deleteRecord()
Deletes an Active Record.
doSave in file TScaffoldEditView.php, method TScaffoldEditView::doSave()
Check the validators, then tries to save the record.
top
g
getAddButton | in file TScaffoldView.php, method TScaffoldView::getAddButton()
getCancelButton | in file TScaffoldEditView.php, method TScaffoldEditView::getCancelButton()
getClearButton | in file TScaffoldEditView.php, method TScaffoldEditView::getClearButton()
getCurrentRecord | in file TScaffoldEditView.php, method TScaffoldEditView::getCurrentRecord()
getDefaultStyle | in file TScaffoldBase.php, method TScaffoldBase::getDefaultStyle()
getEditRenderer | in file TScaffoldEditView.php, method TScaffoldEditView::getEditRenderer()
getEditView | in file TScaffoldView.php, method TScaffoldView::getEditView()
getEditViewControl | in file TScaffoldListView.php, method TScaffoldListView::getEditViewControl()
getEditViewID | in file TScaffoldListView.php, method TScaffoldListView::getEditViewID()
getEnableDefaultStyle | in file TScaffoldBase.php, method TScaffoldBase::getEnableDefaultStyle()
getFields | in file TScaffoldSearch.php, method TScaffoldSearch::getFields()
getHeader | in file TScaffoldListView.php, method TScaffoldListView::getHeader()
getInputRepeater | in file TScaffoldEditView.php, method TScaffoldEditView::getInputRepeater()
getList | in file TScaffoldListView.php, method TScaffoldListView::getList()
getListView | in file TScaffoldSearch.php, method TScaffoldSearch::getListView()
getListView | in file TScaffoldView.php, method TScaffoldView::getListView()
getListViewID | in file TScaffoldSearch.php, method TScaffoldSearch::getListViewID()
getPager | in file TScaffoldListView.php, method TScaffoldListView::getPager()
getRecordClass in file TScaffoldBase.php, method TScaffoldBase::getRecordClass()
Name of the Active Record class to be viewed or scaffolded.
getRecordCriteria | in file TScaffoldListView.php, method TScaffoldListView::getRecordCriteria()
getRecordFinder | in file TScaffoldBase.php, method TScaffoldBase::getRecordFinder()
getRecordObject in file TScaffoldBase.php, method TScaffoldBase::getRecordObject()
Gets the current Active Record instance. Creates new instance if the primary key value is null otherwise the record is fetched from the db.
getRecordPk | in file TScaffoldEditView.php, method TScaffoldEditView::getRecordPk()
getRecordPkValues | in file TScaffoldBase.php, method TScaffoldBase::getRecordPkValues()
getRecordPropertyValues | in file TScaffoldBase.php, method TScaffoldBase::getRecordPropertyValues()
getSaveButton | in file TScaffoldEditView.php, method TScaffoldEditView::getSaveButton()
getScaffoldInputBuilder in file TScaffoldEditView.php, method TScaffoldEditView::getScaffoldInputBuilder()
Create the default scaffold editor control factory.
getSearchableFields | in file TScaffoldSearch.php, method TScaffoldSearch::getSearchableFields()
getSearchButton | in file TScaffoldSearch.php, method TScaffoldSearch::getSearchButton()
getSearchCondition | in file TScaffoldListView.php, method TScaffoldListView::getSearchCondition()
getSearchControl | in file TScaffoldView.php, method TScaffoldView::getSearchControl()
getSearchParameters | in file TScaffoldListView.php, method TScaffoldListView::getSearchParameters()
getSearchText | in file TScaffoldSearch.php, method TScaffoldSearch::getSearchText()
getSort | in file TScaffoldListView.php, method TScaffoldListView::getSort()
getTableInfo | in file TScaffoldBase.php, method TScaffoldBase::getTableInfo()
getValidationGroup | in file TScaffoldEditView.php, method TScaffoldEditView::getValidationGroup()
top
i
initializeEdit in file TScaffoldListView.php, method TScaffoldListView::initializeEdit()
Initialize the edit view control form when EditViewID is set.
initializeEditForm in file TScaffoldEditView.php, method TScaffoldEditView::initializeEditForm()
Initialize the editor form
initializeSort in file TScaffoldListView.php, method TScaffoldListView::initializeSort()
Initialize the sort drop down list and the column names repeater.
IScaffoldEditRenderer in file TScaffoldEditView.php, class IScaffoldEditRenderer
IScaffoldEditRenderer interface.
top
l
listItemCreated in file TScaffoldListView.php, method TScaffoldListView::listItemCreated()
Initialize the default display for each Active Record item.
loadRecordData in file TScaffoldListView.php, method TScaffoldListView::loadRecordData()
Fetch the records and data bind it to the list.
top
o
onLoad in file TScaffoldEditView.php, method TScaffoldEditView::onLoad()
Initialize the editor form if it is Visible.
onPreRender in file TScaffoldView.php, method TScaffoldView::onPreRender()
Copy basic record details to the list/edit/search controls.
onPreRender in file TScaffoldListView.php, method TScaffoldListView::onPreRender()
Loads and display the data.
onPreRender in file TScaffoldBase.php, method TScaffoldBase::onPreRender()
Publish the default stylesheet file.
top
p
pageChanged in file TScaffoldListView.php, method TScaffoldListView::pageChanged()
Updates repeater page index with the pager new index value.
populateField in file TScaffoldListView.php, method TScaffoldListView::populateField()
Sets the Record primary key to the current repeater item's CustomData.
top
s
setDefaultStyle | in file TScaffoldBase.php, method TScaffoldBase::setDefaultStyle()
setEditRenderer | in file TScaffoldEditView.php, method TScaffoldEditView::setEditRenderer()
setEditViewID | in file TScaffoldListView.php, method TScaffoldListView::setEditViewID()
setEnableDefaultStyle | in file TScaffoldBase.php, method TScaffoldBase::setEnableDefaultStyle()
setListViewID | in file TScaffoldSearch.php, method TScaffoldSearch::setListViewID()
setRecordClass in file TScaffoldBase.php, method TScaffoldBase::setRecordClass()
Name of the Active Record class to be viewed or scaffolded.
setRecordObject | in file TScaffoldBase.php, method TScaffoldBase::setRecordObject()
setRecordPk | in file TScaffoldEditView.php, method TScaffoldEditView::setRecordPk()
setSearchableFields | in file TScaffoldSearch.php, method TScaffoldSearch::setSearchableFields()
setSearchCondition | in file TScaffoldListView.php, method TScaffoldListView::setSearchCondition()
setSearchParameters | in file TScaffoldListView.php, method TScaffoldListView::setSearchParameters()
showAddView in file TScaffoldView.php, method TScaffoldView::showAddView()
Shows the add record view.
showEditView in file TScaffoldView.php, method TScaffoldView::showEditView()
Shows the edit record view.
showListView in file TScaffoldView.php, method TScaffoldView::showListView()
Shows the view for listing the records.
top
t
TScaffoldBase.php | procedural page TScaffoldBase.php
TScaffoldEditView.php | procedural page TScaffoldEditView.php
TScaffoldListView.php | procedural page TScaffoldListView.php
TScaffoldSearch.php | procedural page TScaffoldSearch.php
TScaffoldView.php | procedural page TScaffoldView.php
TScaffoldBase in file TScaffoldBase.php, class TScaffoldBase
Base class for Active Record scaffold views.
TScaffoldEditView in file TScaffoldEditView.php, class TScaffoldEditView
Template control for editing an Active Record instance.
TScaffoldListView in file TScaffoldListView.php, class TScaffoldListView
TScaffoldListView displays a list of Active Records.
TScaffoldSearch in file TScaffoldSearch.php, class TScaffoldSearch
TScaffoldSearch provide a simple textbox and a button that is used to perform search on a TScaffoldListView with ID given by setListViewID.
TScaffoldView in file TScaffoldView.php, class TScaffoldView
TScaffoldView is a composite control consisting of TScaffoldListView
top
u
updateRecord in file TScaffoldEditView.php, method IScaffoldEditRenderer::updateRecord()
This method should update the record with the user input data.


Class Trees for Package System.Data.ActiveRecord.Scaffold

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TScaffoldBase.php

File: /Data/ActiveRecord/Scaffold/TScaffoldBase.php

Remarks

TScaffoldBase class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TScaffoldBase.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TScaffoldBase
Base class for Active Record scaffold views.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:17 +0200 by phpDocumentor 1.4.3


Docs for page TScaffoldEditView.php

File: /Data/ActiveRecord/Scaffold/TScaffoldEditView.php

Remarks

TScaffoldEditView class and IScaffoldEditRenderer interface file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TScaffoldEditView.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TScaffoldEditView
Template control for editing an Active Record instance.
IScaffoldEditRenderer
IScaffoldEditRenderer interface.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:17 +0200 by phpDocumentor 1.4.3


Docs for page TScaffoldListView.php

File: /Data/ActiveRecord/Scaffold/TScaffoldListView.php

Remarks

TScaffoldListView class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TScaffoldListView.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TScaffoldListView
TScaffoldListView displays a list of Active Records.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:18 +0200 by phpDocumentor 1.4.3


Docs for page TScaffoldSearch.php

File: /Data/ActiveRecord/Scaffold/TScaffoldSearch.php

Remarks

TScaffoldSearch class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TScaffoldSearch
TScaffoldSearch provide a simple textbox and a button that is used to perform search on a TScaffoldListView with ID given by setListViewID.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:19 +0200 by phpDocumentor 1.4.3


Docs for page TScaffoldView.php

File: /Data/ActiveRecord/Scaffold/TScaffoldView.php

Remarks

TScaffoldView class.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TScaffoldView.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TScaffoldView
TScaffoldView is a composite control consisting of TScaffoldListView

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:19 +0200 by phpDocumentor 1.4.3


Docs For Class TScaffoldBase

Class TScaffoldBase

[line 33]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TScaffoldBase
Classes extended from TScaffoldBase:
TScaffoldEditView
Template control for editing an Active Record instance.
TScaffoldListView
TScaffoldListView displays a list of Active Records.
TScaffoldSearch
TScaffoldSearch provide a simple textbox and a button that is used to perform search on a TScaffoldListView with ID given by setListViewID.
TScaffoldView
TScaffoldView is a composite control consisting of TScaffoldListView

Location: /Data/ActiveRecord/Scaffold/TScaffoldBase.php

Remarks

Base class for Active Record scaffold views.

Provides common properties for all scaffold views (such as, TScaffoldListView, TScaffoldEditView, TScaffoldListView and TScaffoldView).

During the OnPrRender stage the default css style file (filename style.css) is published and registered. To override the default style, provide your own stylesheet file explicitly.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TScaffoldBase.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

abstract

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTemplateControl

  • TTemplateControl::EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TTemplateControl

  • TTemplateControl::createChildControls()
    Creates child controls.
  • TTemplateControl::getIsSourceTemplateControl()
  • TTemplateControl::getMaster()
  • TTemplateControl::getMasterClass()
  • TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
  • TTemplateControl::getTemplateDirectory()
  • TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
  • TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
  • TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
  • TTemplateControl::registerContent()
    Registers a content control.
  • TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
  • TTemplateControl::setMasterClass()
  • TTemplateControl::setTemplate()
    Sets the parsed template.

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TScaffoldBase::clearRecordObject

    clearRecordObject( );

    Remarks

    Unset the current record instance and table information.

    access

    protected

    [ Top ]

    TScaffoldBase::copyFrom

    copyFrom( TScaffoldBase $obj );

    Parameters

    $obj

    scaffold view.

    Remarks

    Copy the view details from another scaffold view instance.

    access

    protected

    [ Top ]

    TScaffoldBase::getDefaultStyle

    getDefaultStyle( );

    Returns

    default scaffold stylesheet name

    access

    public

    [ Top ]

    TScaffoldBase::getEnableDefaultStyle

    getEnableDefaultStyle( );

    Returns

    enable default stylesheet, default is true.

    access

    public

    [ Top ]

    TScaffoldBase::getRecordClass

    getRecordClass( );

    Returns

    Active Record class name.

    Remarks

    Name of the Active Record class to be viewed or scaffolded.

    access

    public

    [ Top ]

    TScaffoldBase::getRecordFinder

    getRecordFinder( );

    Returns

    Active Record finder instance

    access

    protected

    [ Top ]

    TScaffoldBase::getRecordObject

    getRecordObject( [array $pk = null] );

    Parameters

    $pk

    primary key value

    Returns

    record instance

    Remarks

    Gets the current Active Record instance. Creates new instance if the primary key value is null otherwise the record is fetched from the db.

    access

    protected

    [ Top ]

    TScaffoldBase::getRecordPkValues

    getRecordPkValues( TActiveRecord $record );

    Parameters

    $record

    record instance

    Returns

    record primary key values.

    access

    protected

    [ Top ]

    TScaffoldBase::getRecordPropertyValues

    getRecordPropertyValues( TActiveRecord $record );

    Parameters

    $record

    record instance

    Returns

    record property values

    access

    protected

    [ Top ]

    TScaffoldBase::getTableInfo

    getTableInfo( );

    Returns

    table/view information

    access

    protected

    [ Top ]

    TScaffoldBase::onPreRender

    onPreRender( $param );

    Overridden in child classes as:

    TScaffoldListView::onPreRender()
    Loads and display the data.
    TScaffoldView::onPreRender()
    Copy basic record details to the list/edit/search controls.

    Overrides TControl::onPreRender() (This method is invoked when the control enters 'OnPreRender' stage.)

    Parameters

    $param

    Remarks

    Publish the default stylesheet file.

    access

    public

    [ Top ]

    TScaffoldBase::setDefaultStyle

    setDefaultStyle( string $value );

    Parameters

    $value

    default scaffold stylesheet name

    access

    public

    [ Top ]

    TScaffoldBase::setEnableDefaultStyle

    setEnableDefaultStyle( boolean $value );

    Parameters

    $value

    enable default stylesheet, default is true.

    access

    public

    [ Top ]

    TScaffoldBase::setRecordClass

    setRecordClass( string $value );

    Parameters

    $value

    Active Record class name.

    Remarks

    Name of the Active Record class to be viewed or scaffolded.

    access

    public

    [ Top ]

    TScaffoldBase::setRecordObject

    setRecordObject( $value );

    Parameters

    $value

    Active Record instance.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:17 +0200 by phpDocumentor 1.4.3


Docs For Class IScaffoldEditRenderer

Interface IScaffoldEditRenderer

[line 301]
IDataRenderer
   |
   --IScaffoldEditRenderer
Location: /Data/ActiveRecord/Scaffold/TScaffoldEditView.php

Remarks

IScaffoldEditRenderer interface.

IScaffoldEditRenderer defines the interface that an edit renderer needs to implement. Besides the Data property, an edit renderer also needs to provide updateRecord method that is called before the save() method is called on the TActiveRecord.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TScaffoldEditView.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class IDataRenderer

  • IDataRenderer::getData()
  • IDataRenderer::setData()

Method Detail

    IScaffoldEditRenderer::updateRecord

    updateRecord( TActiveRecord $record );

    Parameters

    $record

    record to be saved.

    Remarks

    This method should update the record with the user input data.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:17 +0200 by phpDocumentor 1.4.3


Docs For Class TScaffoldEditView

Class TScaffoldEditView

[line 50]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TScaffoldBase
                  |
                  --TScaffoldEditView
Location: /Data/ActiveRecord/Scaffold/TScaffoldEditView.php

Remarks

Template control for editing an Active Record instance.

The RecordClass determines the Active Record class to be edited. A particular record can be edited by specifying the RecordPk value (may be an array for composite keys).

The default editor input controls are created based on the column types. The editor layout can be specified by a renderer by set the value of the EditRenderer property to the class name of a class that implements TScaffoldEditRenderer. A renderer is an external template control that implements IScaffoldEditRenderer.

The Data of the IScaffoldEditRenderer will be set as the current Active Record to be edited. The UpdateRecord() method of IScaffoldEditRenderer is called when request to save the record is requested.

Validators in the custom external editor template should have the TBaseValidator::setValidationGroup property set to the value of the getValidationGroup of the TScaffoldEditView instance (the edit view instance is the Parent of the IScaffoldEditRenderer in most cases.

Cosmetic changes to the default editor should be done using Cascading Stylesheets. For example, a particular field/property can be hidden by specifying "display:none" for the corresponding style (each field/property has unique Css class name as "property_xxx", where xxx is the property name).

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TScaffoldEditView.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTemplateControl

  • TTemplateControl::EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TScaffoldBase

  • TScaffoldBase::clearRecordObject()
    Unset the current record instance and table information.
  • TScaffoldBase::copyFrom()
    Copy the view details from another scaffold view instance.
  • TScaffoldBase::getDefaultStyle()
  • TScaffoldBase::getEnableDefaultStyle()
  • TScaffoldBase::getRecordClass()
    Name of the Active Record class to be viewed or scaffolded.
  • TScaffoldBase::getRecordFinder()
  • TScaffoldBase::getRecordObject()
    Gets the current Active Record instance. Creates new instance if the primary key value is null otherwise the record is fetched from the db.
  • TScaffoldBase::getRecordPkValues()
  • TScaffoldBase::getRecordPropertyValues()
  • TScaffoldBase::getTableInfo()
  • TScaffoldBase::onPreRender()
    Publish the default stylesheet file.
  • TScaffoldBase::setDefaultStyle()
  • TScaffoldBase::setEnableDefaultStyle()
  • TScaffoldBase::setRecordClass()
    Name of the Active Record class to be viewed or scaffolded.
  • TScaffoldBase::setRecordObject()

Inherited From Class TTemplateControl

  • TTemplateControl::createChildControls()
    Creates child controls.
  • TTemplateControl::getIsSourceTemplateControl()
  • TTemplateControl::getMaster()
  • TTemplateControl::getMasterClass()
  • TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
  • TTemplateControl::getTemplateDirectory()
  • TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
  • TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
  • TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
  • TTemplateControl::registerContent()
    Registers a content control.
  • TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
  • TTemplateControl::setMasterClass()
  • TTemplateControl::setTemplate()
    Sets the parsed template.

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TScaffoldEditView::bubbleEvent

    bubbleEvent( $sender, $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    $param

    Remarks

    Bubble the command name event. Stops bubbling when the page validator false.

    Otherwise, the bubble event is continued.

    access

    public

    [ Top ]

    TScaffoldEditView::createEditRenderer

    createEditRenderer( TActiveRecord $record, string $classPath );

    Parameters

    $record

    record to be edited

    $classPath

    external edit renderer class name.

    Remarks

    Instantiate the external edit renderer.

    throws

    TConfigurationException raised when renderer is not an instance of IScaffoldEditRenderer.

    access

    protected

    [ Top ]

    TScaffoldEditView::createRepeaterEditItem

    createRepeaterEditItem( $sender, $param );

    Parameters

    $sender

    $param

    Remarks

    Initialize the default editor using the scaffold input builder.

    access

    protected

    [ Top ]

    TScaffoldEditView::doSave

    doSave( );

    Returns

    true if the validators are true, false otherwise.

    Remarks

    Check the validators, then tries to save the record.

    access

    protected

    [ Top ]

    TScaffoldEditView::getCancelButton

    getCancelButton( );

    Returns

    Button to cancel the edit action (e.g. hide the edit view).

    access

    public

    [ Top ]

    TScaffoldEditView::getClearButton

    getClearButton( );

    Returns

    Button to clear the editor inputs.

    access

    public

    [ Top ]

    TScaffoldEditView::getCurrentRecord

    getCurrentRecord( );

    Returns

    current Active Record instance

    access

    protected

    [ Top ]

    TScaffoldEditView::getEditRenderer

    getEditRenderer( );

    Returns

    the class name for scaffold editor. Defaults to empty, meaning not set.

    access

    public

    [ Top ]

    TScaffoldEditView::getInputRepeater

    getInputRepeater( );

    Returns

    default editor input controls repeater

    access

    protected

    [ Top ]

    TScaffoldEditView::getRecordPk

    getRecordPk( );

    Returns

    Active Record primary key value.

    access

    public

    [ Top ]

    TScaffoldEditView::getSaveButton

    getSaveButton( );

    Returns

    Button triggered to save the Active Record.

    access

    public

    [ Top ]

    TScaffoldEditView::getScaffoldInputBuilder

    getScaffoldInputBuilder( TActiveRecord $record );

    Parameters

    $record

    record instance.

    Returns

    scaffold editor control factory.

    Remarks

    Create the default scaffold editor control factory.

    access

    protected

    [ Top ]

    TScaffoldEditView::getValidationGroup

    getValidationGroup( );

    Returns

    editor validation group name.

    access

    public

    [ Top ]

    TScaffoldEditView::initializeEditForm

    initializeEditForm( );

    Remarks

    Initialize the editor form

    access

    public

    [ Top ]

    TScaffoldEditView::onLoad

    onLoad( $param );

    Overrides TControl::onLoad() (This method is invoked when the control enters 'OnLoad' stage.)

    Parameters

    $param

    Remarks

    Initialize the editor form if it is Visible.

    access

    public

    [ Top ]

    TScaffoldEditView::setEditRenderer

    setEditRenderer( string $value );

    Parameters

    $value

    the class name for scaffold editor. Defaults to empty, meaning not set.

    access

    public

    [ Top ]

    TScaffoldEditView::setRecordPk

    setRecordPk( array $value );

    Parameters

    $value

    Active Record primary key value to be edited.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:17 +0200 by phpDocumentor 1.4.3


Docs For Class TScaffoldListView

Class TScaffoldListView

[line 51]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TScaffoldBase
                  |
                  --TScaffoldListView
Location: /Data/ActiveRecord/Scaffold/TScaffoldListView.php

Remarks

TScaffoldListView displays a list of Active Records.

The Header property is a TRepeater displaying the Active Record property/field names. The Sort property is a drop down list displaying the combination of properties and its possible ordering. The Pager property is a TPager control displaying the links and/or buttons that navigate to different pages in the Active Record data. The List property is a TRepeater that renders a row of Active Record data.

Custom rendering of the each Active Record can be achieved by specifying the ItemTemplate or AlternatingItemTemplate property of the main {@linnk getList List} repeater.

The TScaffoldListView will listen for two command events named "delete" and "edit". A "delete" command will delete a the record for the row where the "delete" command is originates. An "edit" command will push the record data to be edited by a TScaffoldEditView with ID specified by the EditViewID.

Additional SearchCondition and SearchParameters (takes array values) can be specified to customize the records to be shown. The SearchCondition will be used as the Condition property of TActiveRecordCriteria, and similarly the SearchParameters will be the corresponding Parameters property of TActiveRecordCriteria.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TScaffoldListView.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTemplateControl

  • TTemplateControl::EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TScaffoldBase

  • TScaffoldBase::clearRecordObject()
    Unset the current record instance and table information.
  • TScaffoldBase::copyFrom()
    Copy the view details from another scaffold view instance.
  • TScaffoldBase::getDefaultStyle()
  • TScaffoldBase::getEnableDefaultStyle()
  • TScaffoldBase::getRecordClass()
    Name of the Active Record class to be viewed or scaffolded.
  • TScaffoldBase::getRecordFinder()
  • TScaffoldBase::getRecordObject()
    Gets the current Active Record instance. Creates new instance if the primary key value is null otherwise the record is fetched from the db.
  • TScaffoldBase::getRecordPkValues()
  • TScaffoldBase::getRecordPropertyValues()
  • TScaffoldBase::getTableInfo()
  • TScaffoldBase::onPreRender()
    Publish the default stylesheet file.
  • TScaffoldBase::setDefaultStyle()
  • TScaffoldBase::setEnableDefaultStyle()
  • TScaffoldBase::setRecordClass()
    Name of the Active Record class to be viewed or scaffolded.
  • TScaffoldBase::setRecordObject()

Inherited From Class TTemplateControl

  • TTemplateControl::createChildControls()
    Creates child controls.
  • TTemplateControl::getIsSourceTemplateControl()
  • TTemplateControl::getMaster()
  • TTemplateControl::getMasterClass()
  • TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
  • TTemplateControl::getTemplateDirectory()
  • TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
  • TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
  • TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
  • TTemplateControl::registerContent()
    Registers a content control.
  • TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
  • TTemplateControl::setMasterClass()
  • TTemplateControl::setTemplate()
    Sets the parsed template.

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TScaffoldListView::bubbleEvent

    bubbleEvent( $sender, $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    $param

    Remarks

    Continue bubbling the "edit" command, "delete" command is handled in this class.

    access

    public

    [ Top ]

    TScaffoldListView::deleteRecord

    deleteRecord( $sender, $param );

    Parameters

    $sender

    $param

    Remarks

    Deletes an Active Record.

    access

    protected

    [ Top ]

    TScaffoldListView::getEditViewControl

    getEditViewControl( );

    Returns

    control for editing selected Active Record, null if EditViewID is not set.

    access

    protected

    [ Top ]

    TScaffoldListView::getEditViewID

    getEditViewID( );

    Returns

    TScaffoldEditView control ID for editing selected Active Record.

    access

    public

    [ Top ]

    TScaffoldListView::getHeader

    getHeader( );

    Returns

    Repeater control for record property names.

    access

    public

    [ Top ]

    TScaffoldListView::getList

    getList( );

    Returns

    Repeater control for Active Record instances.

    access

    public

    [ Top ]

    TScaffoldListView::getPager

    getPager( );

    Returns

    List pager control.

    access

    public

    [ Top ]

    TScaffoldListView::getRecordCriteria

    getRecordCriteria( );

    Returns

    sort/search/paging criteria

    access

    protected

    [ Top ]

    TScaffoldListView::getSearchCondition

    getSearchCondition( string 0 );

    Parameters

    0

    SQL search condition for list display.

    access

    public

    [ Top ]

    TScaffoldListView::getSearchParameters

    getSearchParameters( );

    Returns

    search parameters

    access

    public

    [ Top ]

    TScaffoldListView::getSort

    getSort( );

    Returns

    Control that displays and controls the record ordering.

    access

    public

    [ Top ]

    TScaffoldListView::initializeEdit

    initializeEdit( $sender, $param );

    Parameters

    $sender

    $param

    Remarks

    Initialize the edit view control form when EditViewID is set.

    access

    protected

    [ Top ]

    TScaffoldListView::initializeSort

    initializeSort( );

    Remarks

    Initialize the sort drop down list and the column names repeater.

    access

    protected

    [ Top ]

    TScaffoldListView::listItemCreated

    listItemCreated( $sender, $param );

    Parameters

    $sender

    $param

    Remarks

    Initialize the default display for each Active Record item.

    access

    protected

    [ Top ]

    TScaffoldListView::loadRecordData

    loadRecordData( );

    Remarks

    Fetch the records and data bind it to the list.

    access

    protected

    [ Top ]

    TScaffoldListView::onPreRender

    onPreRender( $param );

    Overrides TScaffoldBase::onPreRender() (Publish the default stylesheet file.)

    Parameters

    $param

    Remarks

    Loads and display the data.

    access

    public

    [ Top ]

    TScaffoldListView::pageChanged

    pageChanged( $sender, $param );

    Parameters

    $sender

    $param

    Remarks

    Updates repeater page index with the pager new index value.

    access

    protected

    [ Top ]

    TScaffoldListView::populateField

    populateField( $sender, $param );

    Parameters

    $sender

    $param

    Remarks

    Sets the Record primary key to the current repeater item's CustomData.

    Binds the inner repeater with properties of the current Active Record.

    access

    protected

    [ Top ]

    TScaffoldListView::setEditViewID

    setEditViewID( string $value );

    Parameters

    $value

    TScaffoldEditView control ID for editing selected Active Record.

    access

    public

    [ Top ]

    TScaffoldListView::setSearchCondition

    setSearchCondition( string $value );

    Parameters

    $value

    search condition, the SQL string after the WHERE clause.

    access

    public

    [ Top ]

    TScaffoldListView::setSearchParameters

    setSearchParameters( array $value );

    Parameters

    $value

    search parameters

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:18 +0200 by phpDocumentor 1.4.3


Docs For Class TScaffoldSearch

Class TScaffoldSearch

[line 36]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TScaffoldBase
                  |
                  --TScaffoldSearch
Location: /Data/ActiveRecord/Scaffold/TScaffoldSearch.php

Remarks

TScaffoldSearch provide a simple textbox and a button that is used to perform search on a TScaffoldListView with ID given by setListViewID.

The SearchText property is a TTextBox and the SearchButton property is a TButton with label value "Search".

Searchable fields of the Active Record can be restricted by specifying a comma delimited string of allowable fields in the SearchableFields property. The default is null, meaning that most text type fields are searched (the default searchable fields are database dependent).

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id$

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTemplateControl

  • TTemplateControl::EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TScaffoldBase

  • TScaffoldBase::clearRecordObject()
    Unset the current record instance and table information.
  • TScaffoldBase::copyFrom()
    Copy the view details from another scaffold view instance.
  • TScaffoldBase::getDefaultStyle()
  • TScaffoldBase::getEnableDefaultStyle()
  • TScaffoldBase::getRecordClass()
    Name of the Active Record class to be viewed or scaffolded.
  • TScaffoldBase::getRecordFinder()
  • TScaffoldBase::getRecordObject()
    Gets the current Active Record instance. Creates new instance if the primary key value is null otherwise the record is fetched from the db.
  • TScaffoldBase::getRecordPkValues()
  • TScaffoldBase::getRecordPropertyValues()
  • TScaffoldBase::getTableInfo()
  • TScaffoldBase::onPreRender()
    Publish the default stylesheet file.
  • TScaffoldBase::setDefaultStyle()
  • TScaffoldBase::setEnableDefaultStyle()
  • TScaffoldBase::setRecordClass()
    Name of the Active Record class to be viewed or scaffolded.
  • TScaffoldBase::setRecordObject()

Inherited From Class TTemplateControl

  • TTemplateControl::createChildControls()
    Creates child controls.
  • TTemplateControl::getIsSourceTemplateControl()
  • TTemplateControl::getMaster()
  • TTemplateControl::getMasterClass()
  • TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
  • TTemplateControl::getTemplateDirectory()
  • TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
  • TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
  • TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
  • TTemplateControl::registerContent()
    Registers a content control.
  • TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
  • TTemplateControl::setMasterClass()
  • TTemplateControl::setTemplate()
    Sets the parsed template.

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TScaffoldSearch::bubbleEvent

    bubbleEvent( $sender, $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    $param

    Remarks

    Sets the SearchCondition of the TScaffoldListView as the search terms given by the text of the search text box.

    access

    public

    [ Top ]

    TScaffoldSearch::createSearchCondition

    createSearchCondition( );

    Returns

    the search criteria for the search terms in the search text box.

    access

    protected

    [ Top ]

    TScaffoldSearch::getFields

    getFields( );

    Returns

    list of fields to be searched.

    access

    protected

    [ Top ]

    TScaffoldSearch::getListView

    getListView( );

    Returns

    the scaffold list view this search box belongs to.

    access

    protected

    [ Top ]

    TScaffoldSearch::getListViewID

    getListViewID( );

    Returns

    ID of the TScaffoldListView this search control belongs to.

    access

    public

    [ Top ]

    TScaffoldSearch::getSearchableFields

    getSearchableFields( );

    Returns

    comma delimited list of fields that may be searched.

    access

    public

    [ Top ]

    TScaffoldSearch::getSearchButton

    getSearchButton( );

    Returns

    button with default label "Search".

    access

    public

    [ Top ]

    TScaffoldSearch::getSearchText

    getSearchText( );

    Returns

    search text box.

    access

    public

    [ Top ]

    TScaffoldSearch::setListViewID

    setListViewID( string $value );

    Parameters

    $value

    ID of the TScaffoldListView this search control belongs to.

    access

    public

    [ Top ]

    TScaffoldSearch::setSearchableFields

    setSearchableFields( string $value );

    Parameters

    $value

    comma delimited list of fields that may be searched.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:19 +0200 by phpDocumentor 1.4.3


Docs For Class TScaffoldView

Class TScaffoldView

[line 42]
TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TScaffoldBase
                  |
                  --TScaffoldView
Location: /Data/ActiveRecord/Scaffold/TScaffoldView.php

Remarks

TScaffoldView is a composite control consisting of TScaffoldListView

with a TScaffoldSearch. In addition, it will display a TScaffoldEditView when an "edit" command is raised from the TScaffoldListView (when the edit button is clicked). Futher more, the "add" button can be clicked that shows an empty data TScaffoldListView for creating new records.

The ListView property gives a TScaffoldListView for display the record data. The EditView is the TScaffoldEditView that renders the inputs for editing and adding records. The SearchControl is a TScaffoldSearch responsible to the search user interface.

Set the RecordClass property to the name of the Active Record class to be displayed/edited/added.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TScaffoldView.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TTemplateControl

  • TTemplateControl::EXT_TEMPLATE = '.tpl'
    template file extension.

Inherited From Class TControl

  • TControl::AUTOMATIC_ID_PREFIX = 'ctl'
    prefix to an ID automatically generated
  • TControl::CLIENT_ID_SEPARATOR = '_'
    separator char between IDs in a ClientID
  • TControl::CS_CHILD_INITIALIZED = 1
  • TControl::CS_CONSTRUCTED = 0
    the stage of lifecycles that the control is currently at
  • TControl::CS_INITIALIZED = 2
  • TControl::CS_LOADED = 4
  • TControl::CS_PRERENDERED = 5
  • TControl::CS_STATE_LOADED = 3
  • TControl::ID_FORMAT = '/^[a-zA-Z_]\\w*$/'
    format of control ID
  • TControl::ID_SEPARATOR = '$'
    separator char between IDs in a UniqueID
  • TControl::IS_CHILD_CREATED = 0x20
  • TControl::IS_CREATING_CHILD = 0x40
  • TControl::IS_DISABLE_THEMING = 0x10
  • TControl::IS_DISABLE_VIEWSTATE = 0x02
  • TControl::IS_ID_SET = 0x01
    State bits.
  • TControl::IS_SKIN_APPLIED = 0x04
  • TControl::IS_STYLESHEET_APPLIED = 0x08
  • TControl::RF_ADAPTER = 9
  • TControl::RF_AUTO_BINDINGS = 10
  • TControl::RF_CHILD_STATE = 1
  • TControl::RF_CONTROLS = 0
    Indexes for the rare fields.
  • TControl::RF_CONTROLSTATE = 7
  • TControl::RF_DATA_BINDINGS = 5
  • TControl::RF_EVENTS = 6
  • TControl::RF_NAMED_CONTROLS = 2
  • TControl::RF_NAMED_CONTROLS_ID = 3
  • TControl::RF_NAMED_OBJECTS = 8
  • TControl::RF_SKIN_ID = 4

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TScaffoldBase

  • TScaffoldBase::clearRecordObject()
    Unset the current record instance and table information.
  • TScaffoldBase::copyFrom()
    Copy the view details from another scaffold view instance.
  • TScaffoldBase::getDefaultStyle()
  • TScaffoldBase::getEnableDefaultStyle()
  • TScaffoldBase::getRecordClass()
    Name of the Active Record class to be viewed or scaffolded.
  • TScaffoldBase::getRecordFinder()
  • TScaffoldBase::getRecordObject()
    Gets the current Active Record instance. Creates new instance if the primary key value is null otherwise the record is fetched from the db.
  • TScaffoldBase::getRecordPkValues()
  • TScaffoldBase::getRecordPropertyValues()
  • TScaffoldBase::getTableInfo()
  • TScaffoldBase::onPreRender()
    Publish the default stylesheet file.
  • TScaffoldBase::setDefaultStyle()
  • TScaffoldBase::setEnableDefaultStyle()
  • TScaffoldBase::setRecordClass()
    Name of the Active Record class to be viewed or scaffolded.
  • TScaffoldBase::setRecordObject()

Inherited From Class TTemplateControl

  • TTemplateControl::createChildControls()
    Creates child controls.
  • TTemplateControl::getIsSourceTemplateControl()
  • TTemplateControl::getMaster()
  • TTemplateControl::getMasterClass()
  • TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
  • TTemplateControl::getTemplateDirectory()
  • TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
  • TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
  • TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
  • TTemplateControl::registerContent()
    Registers a content control.
  • TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
  • TTemplateControl::setMasterClass()
  • TTemplateControl::setTemplate()
    Sets the parsed template.

Inherited From Class TCompositeControl

  • TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.

Inherited From Class TControl

  • TControl::__construct()
    Constructor.
  • TControl::addedControl()
    Adds a control into the child collection of the control.
  • TControl::addParsedObject()
    Adds the object instantiated on a template to the child control collection.
  • TControl::addToPostDataLoader()
    Add controls implementing IPostBackDataHandler to post data loaders.
  • TControl::applyStyleSheetSkin()
    Applies a stylesheet skin to a control.
  • TControl::autoBindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::autoDataBindProperties()
    Auto databinding properties of the control.
  • TControl::bindProperty()
    Sets up the binding between a property (or property path) and an expression.
  • TControl::broadcastEvent()
    Broadcasts an event.
  • TControl::bubbleEvent()
    This method responds to a bubbled event.
  • TControl::clearChildState()
    Clears up the child state data.
  • TControl::clearControlState()
    Clears a controlstate value.
  • TControl::clearNamingContainer()
    Resets the control as a naming container.
  • TControl::clearViewState()
    Clears a viewstate value.
  • TControl::convertUniqueIdToClientId()
    Converts a unique ID to a client ID.
  • TControl::createChildControls()
    Creates child controls.
  • TControl::createControlCollection()
    Creates a control collection object that is to be used to hold child controls
  • TControl::dataBind()
    Performs the databinding for this control.
  • TControl::dataBindChildren()
    Databinding child controls.
  • TControl::dataBindProperties()
    Databinding properties of the control.
  • TControl::ensureChildControls()
    Ensures child controls are created.
  • TControl::findControl()
    Finds a control by ID path within the current naming container.
  • TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
  • TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
  • TControl::focus()
    Sets input focus to this control.
  • TControl::getAdapter()
  • TControl::getAllowChildControls()
  • TControl::getAttribute()
  • TControl::getAttributes()
    Returns the list of custom attributes.
  • TControl::getChildControlsCreated()
  • TControl::getClientID()
    Returns the client ID of the control.
  • TControl::getControls()
  • TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
  • TControl::getControlState()
    Returns a controlstate value.
  • TControl::getCustomData()
    Returns custom data associated with this control.
  • TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
  • TControl::getEnableTheming()
  • TControl::getEnableViewState()
  • TControl::getHasAdapter()
  • TControl::getHasAttributes()
  • TControl::getHasChildInitialized()
  • TControl::getHasControls()
  • TControl::getHasInitialized()
  • TControl::getHasLoaded()
  • TControl::getHasLoadedPostData()
  • TControl::getHasPreRendered()
  • TControl::getID()
    Returns the id of the control.
  • TControl::getIsSkinApplied()
  • TControl::getNamingContainer()
  • TControl::getPage()
  • TControl::getParent()
  • TControl::getRegisteredObject()
    Returns the named registered object.
  • TControl::getSkinID()
  • TControl::getSourceTemplateControl()
  • TControl::getTemplateControl()
  • TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
  • TControl::getViewState()
    Returns a viewstate value.
  • TControl::getVisible()
    Checks if a control is visible.
  • TControl::hasAttribute()
  • TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
  • TControl::isDescendentOf()
  • TControl::isObjectRegistered()
  • TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
  • TControl::loadState()
    This method is invoked right after the control has loaded its state.
  • TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
  • TControl::onDataBinding()
    Raises 'OnDataBinding' event.
  • TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
  • TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
  • TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
  • TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
  • TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
  • TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
  • TControl::registerObject()
    Registers an object by a name.
  • TControl::removeAttribute()
    Removes the named attribute.
  • TControl::removedControl()
    Removes a control from the child collection of the control.
  • TControl::render()
    Renders the control.
  • TControl::renderChildren()
    Renders the children of the control.
  • TControl::renderControl()
    Renders the control.
  • TControl::saveState()
    This method is invoked when control state is to be saved.
  • TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
  • TControl::setAdapter()
  • TControl::setAttribute()
    Sets a custom control attribute.
  • TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
  • TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
  • TControl::setControlState()
    Sets a controlstate value.
  • TControl::setCustomData()
    Associates custom data with this control.
  • TControl::setEnabled()
  • TControl::setEnableTheming()
  • TControl::setEnableViewState()
  • TControl::setID()
  • TControl::setPage()
    Sets the page for a control.
  • TControl::setSkinID()
  • TControl::setTemplateControl()
    Sets the control whose template contains this control.
  • TControl::setViewState()
    Sets a viewstate value.
  • TControl::setVisible()
  • TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
  • TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
  • TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
  • TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
  • TControl::unregisterObject()
    Unregisters an object by name.
  • TControl::__get()
    Returns a property value by name or a control by ID.

Inherited From Class TApplicationComponent

  • TApplicationComponent::getApplication()
  • TApplicationComponent::getRequest()
  • TApplicationComponent::getResponse()
  • TApplicationComponent::getService()
  • TApplicationComponent::getSession()
  • TApplicationComponent::getUser()
  • TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
  • TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TScaffoldView::bubbleEvent

    bubbleEvent( $sender, $param );

    Overrides TControl::bubbleEvent() (This method responds to a bubbled event.)

    Parameters

    $sender

    $param

    Remarks

    Handle the "edit" and "new" commands by displaying the edit view.

    Default command shows the list view.

    access

    public

    [ Top ]

    TScaffoldView::getAddButton

    getAddButton( );

    Returns

    "Add new record" button.

    access

    public

    [ Top ]

    TScaffoldView::getEditView

    getEditView( );

    Returns

    scaffold edit view.

    access

    public

    [ Top ]

    TScaffoldView::getListView

    getListView( );

    Returns

    scaffold list view.

    access

    public

    [ Top ]

    TScaffoldView::getSearchControl

    getSearchControl( );

    Returns

    scaffold search textbox and button.

    access

    public

    [ Top ]

    TScaffoldView::onPreRender

    onPreRender( $param );

    Overrides TScaffoldBase::onPreRender() (Publish the default stylesheet file.)

    Parameters

    $param

    Remarks

    Copy basic record details to the list/edit/search controls.

    access

    public

    [ Top ]

    TScaffoldView::showAddView

    showAddView( $sender, $param );

    Parameters

    $sender

    $param

    Remarks

    Shows the add record view.

    access

    protected

    [ Top ]

    TScaffoldView::showEditView

    showEditView( $sender, $param );

    Parameters

    $sender

    $param

    Remarks

    Shows the edit record view.

    access

    protected

    [ Top ]

    TScaffoldView::showListView

    showListView( $sender, $param );

    Parameters

    $sender

    $param

    Remarks

    Shows the view for listing the records.

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:19 +0200 by phpDocumentor 1.4.3


Package System.Data.Common.Sqlite Element Index

Element index for package System.Data.Common.Sqlite

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
c g h t
top
c
createCommandBuilder | in file TSqliteTableInfo.php, method TSqliteTableInfo::createCommandBuilder()
top
g
getAutoIncrement | in file TSqliteTableColumn.php, method TSqliteTableColumn::getAutoIncrement()
getPHPType in file TSqliteTableColumn.php, method TSqliteTableColumn::getPHPType()
Overrides parent implementation, returns PHP type from the db type.
getTableFullName | in file TSqliteTableInfo.php, method TSqliteTableInfo::getTableFullName()
top
h
hasSequence | in file TSqliteTableColumn.php, method TSqliteTableColumn::hasSequence()
top
t
TSqliteMetaData.php | procedural page TSqliteMetaData.php
TSqliteTableColumn.php | procedural page TSqliteTableColumn.php
TSqliteTableInfo.php | procedural page TSqliteTableInfo.php
TSqliteTableColumn in file TSqliteTableColumn.php, class TSqliteTableColumn
Describes the column metadata of the schema for a PostgreSQL database table.
TSqliteTableInfo in file TSqliteTableInfo.php, class TSqliteTableInfo
TSqliteTableInfo class provides additional table information for PostgreSQL database.


Class Trees for Package System.Data.Common.Sqlite

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TSqliteMetaData.php

File: /Data/Common/Sqlite/TSqliteMetaData.php

Remarks

TSqliteMetaData class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqliteMetaData.php 1861 2007-04-12 08:05:03Z wei $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqliteMetaData
TSqliteMetaData loads SQLite database table and column information.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:24 +0200 by phpDocumentor 1.4.3


Docs for page TSqliteTableColumn.php

File: /Data/Common/Sqlite/TSqliteTableColumn.php

Remarks

TSqliteTableColumn class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqliteTableColumn.php 1861 2007-04-12 08:05:03Z wei $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqliteTableColumn
Describes the column metadata of the schema for a PostgreSQL database table.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs for page TSqliteTableInfo.php

File: /Data/Common/Sqlite/TSqliteTableInfo.php

Remarks

TSqliteTableInfo class file.

author

Wei Zhuo <weizhuo[at]gmail[dot]com>

version

$Id: TSqliteTableInfo.php 1861 2007-04-12 08:05:03Z wei $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TSqliteTableInfo
TSqliteTableInfo class provides additional table information for PostgreSQL database.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs For Class TSqliteTableColumn

Class TSqliteTableColumn

[line 26]
TComponent
   |
   --TDbTableColumn
      |
      --TSqliteTableColumn
Location: /Data/Common/Sqlite/TSqliteTableColumn.php

Remarks

Describes the column metadata of the schema for a PostgreSQL database table.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqliteTableColumn.php 1861 2007-04-12 08:05:03Z wei $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited From Class TDbTableColumn

  • TDbTableColumn::UNDEFINED_VALUE = INF

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbTableColumn

  • TDbTableColumn::__construct()
    Sets the table column meta data.
  • TDbTableColumn::getAllowNull()
  • TDbTableColumn::getColumnId()
  • TDbTableColumn::getColumnIndex()
  • TDbTableColumn::getColumnName()
  • TDbTableColumn::getColumnSize()
  • TDbTableColumn::getDbType()
  • TDbTableColumn::getDefaultValue()
  • TDbTableColumn::getInfo()
  • TDbTableColumn::getIsExcluded()
  • TDbTableColumn::getIsForeignKey()
  • TDbTableColumn::getIsPrimaryKey()
  • TDbTableColumn::getMaxiumNumericConstraint()
  • TDbTableColumn::getNumericPrecision()
  • TDbTableColumn::getNumericScale()
  • TDbTableColumn::getPdoType()
  • TDbTableColumn::getPHPType()
    Returns the derived PHP primitive type from the db type. Default returns 'string'.
  • TDbTableColumn::getSequenceName()
  • TDbTableColumn::hasSequence()
  • TDbTableColumn::setInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqliteTableColumn::getAutoIncrement

    getAutoIncrement( );

    Returns

    true if column will auto-increment when the column value is inserted as null.

    access

    public

    [ Top ]

    TSqliteTableColumn::getPHPType

    getPHPType( );

    Overrides TDbTableColumn::getPHPType() (Returns the derived PHP primitive type from the db type. Default returns 'string'.)

    Returns

    derived PHP primitive type from the column db type.

    Remarks

    Overrides parent implementation, returns PHP type from the db type.

    access

    public

    [ Top ]

    TSqliteTableColumn::hasSequence

    hasSequence( );

    Overrides TDbTableColumn::hasSequence() (parent method not documented)

    Returns

    true if auto increment is true.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Docs For Class TSqliteTableInfo

Class TSqliteTableInfo

[line 27]
TComponent
   |
   --TDbTableInfo
      |
      --TSqliteTableInfo
Location: /Data/Common/Sqlite/TSqliteTableInfo.php

Remarks

TSqliteTableInfo class provides additional table information for PostgreSQL database.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqliteTableInfo.php 1861 2007-04-12 08:05:03Z wei $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TDbTableInfo

  • TDbTableInfo::__construct()
    Sets the database table meta data information.
  • TDbTableInfo::createCommandBuilder()
  • TDbTableInfo::getColumn()
  • TDbTableInfo::getColumnNames()
  • TDbTableInfo::getColumns()
  • TDbTableInfo::getForeignKeys()
  • TDbTableInfo::getInfo()
  • TDbTableInfo::getIsView()
  • TDbTableInfo::getLowerCaseColumnNames()
  • TDbTableInfo::getPrimaryKeys()
  • TDbTableInfo::getTableFullName()
  • TDbTableInfo::getTableName()
  • TDbTableInfo::setInfo()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqliteTableInfo::createCommandBuilder

    createCommandBuilder( TDbConnection $connection );

    Overrides TDbTableInfo::createCommandBuilder() (parent method not documented)

    Parameters

    $connection

    database connection.

    Returns

    new command builder

    access

    public

    [ Top ]

    TSqliteTableInfo::getTableFullName

    getTableFullName( );

    Overrides TDbTableInfo::getTableFullName() (parent method not documented)

    Returns

    full name of the table, database dependent.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:25 +0200 by phpDocumentor 1.4.3


Package System.Data.Commom.Sqlite Element Index

Element index for package System.Data.Commom.Sqlite

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
c g i p q t
top
c
createTableInfo in file TSqliteMetaData.php, method TSqliteMetaData::createTableInfo()
Get the column definitions for given table.
top
g
getForeignKeys | in file TSqliteMetaData.php, method TSqliteMetaData::getForeignKeys()
getIsView | in file TSqliteMetaData.php, method TSqliteMetaData::getIsView()
getTableInfoClass | in file TSqliteMetaData.php, method TSqliteMetaData::getTableInfoClass()
top
i
isForeignKeyColumn | in file TSqliteMetaData.php, method TSqliteMetaData::isForeignKeyColumn()
top
p
processColumn | in file TSqliteMetaData.php, method TSqliteMetaData::processColumn()
top
q
quoteColumnAlias in file TSqliteMetaData.php, method TSqliteMetaData::quoteColumnAlias()
Quotes a column alias for use in a query.
quoteColumnName in file TSqliteMetaData.php, method TSqliteMetaData::quoteColumnName()
Quotes a column name for use in a query.
quoteTableName in file TSqliteMetaData.php, method TSqliteMetaData::quoteTableName()
Quotes a table name for use in a query.
top
t
TSqliteMetaData in file TSqliteMetaData.php, class TSqliteMetaData
TSqliteMetaData loads SQLite database table and column information.


Class Trees for Package System.Data.Commom.Sqlite

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs For Class TSqliteMetaData

Class TSqliteMetaData

[line 27]
TComponent
   |
   --TDbMetaData
      |
      --TSqliteMetaData
Location: /Data/Common/Sqlite/TSqliteMetaData.php

Remarks

TSqliteMetaData loads SQLite database table and column information.

author

Wei Zhuo <weizho[at]gmail[dot]com>

version

$Id: TSqliteMetaData.php 1861 2007-04-12 08:05:03Z wei $

since

3.1

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Inherited From Class TDbMetaData

  • TDbMetaData::$delimiterIdentifier = array('[', ']', '"', '`', "'")

Method Summary

Inherited Method Summary

Inherited From Class TDbMetaData

  • TDbMetaData::__construct()
  • TDbMetaData::createCommandBuilder()
    Creates a command builder for a given table name.
  • TDbMetaData::createTableInfo()
    This method should be implemented by decendent classes.
  • TDbMetaData::getDbConnection()
  • TDbMetaData::getInstance()
    Obtain database specific TDbMetaData class using the driver name of the database connection.
  • TDbMetaData::getTableInfo()
    Obtains table meta data information for the current connection and given table name.
  • TDbMetaData::getTableInfoClass()
  • TDbMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
  • TDbMetaData::quoteColumnName()
    Quotes a column name for use in a query.
  • TDbMetaData::quoteTableName()
    Quotes a table name for use in a query.

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TSqliteMetaData::createTableInfo

    createTableInfo( string $tableName );

    Overrides TDbMetaData::createTableInfo() (This method should be implemented by decendent classes.)

    Parameters

    $tableName

    table name.

    Returns

    table information.

    Remarks

    Get the column definitions for given table.

    access

    protected

    [ Top ]

    TSqliteMetaData::getForeignKeys

    getForeignKeys( string $table );

    Parameters

    $table

    quoted table name.

    Returns

    foreign key details.

    access

    protected

    [ Top ]

    TSqliteMetaData::getIsView

    getIsView( string $tableName );

    Parameters

    $tableName

    table name.

    Returns

    true if the table is a view.

    access

    protected

    [ Top ]

    TSqliteMetaData::getTableInfoClass

    getTableInfoClass( );

    Overrides TDbMetaData::getTableInfoClass() (parent method not documented)

    Returns

    TDbTableInfo class name.

    access

    protected

    [ Top ]

    TSqliteMetaData::isForeignKeyColumn

    isForeignKeyColumn( string $columnId, array $foreign );

    Parameters

    $columnId

    column name.

    $foreign

    foreign key column names.

    Returns

    true if column is a foreign key.

    access

    protected

    [ Top ]

    TSqliteMetaData::processColumn

    processColumn( array $col, array $foreign );

    Parameters

    $col

    column information.

    $foreign

    foreign key details.

    Returns

    column details.

    access

    protected

    [ Top ]

    TSqliteMetaData::quoteColumnAlias

    quoteColumnAlias( string $name );

    Overrides TDbMetaData::quoteColumnAlias() (Quotes a column alias for use in a query.)

    Parameters

    $name

    column alias

    Returns

    the properly quoted column alias

    Remarks

    Quotes a column alias for use in a query.

    access

    public

    [ Top ]

    TSqliteMetaData::quoteColumnName

    quoteColumnName( string $name );

    Overrides TDbMetaData::quoteColumnName() (Quotes a column name for use in a query.)

    Parameters

    $name

    column name

    Returns

    the properly quoted column name

    Remarks

    Quotes a column name for use in a query.

    access

    public

    [ Top ]

    TSqliteMetaData::quoteTableName

    quoteTableName( string $name );

    Overrides TDbMetaData::quoteTableName() (Quotes a table name for use in a query.)

    Parameters

    $name

    table name

    Returns

    the properly quoted table name

    Remarks

    Quotes a table name for use in a query.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:24 +0200 by phpDocumentor 1.4.3


Package System.IO Element Index

Element index for package System.IO

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

Index of all elements
e f t w _
top
_
_dirCheck in file TTarFileExtractor.php, method TTarFileExtractor::_dirCheck()
Check if a directory exists and create it (including parent dirs) if not.
_error | in file TTarFileExtractor.php, method TTarFileExtractor::_error()
_extractList | in file TTarFileExtractor.php, method TTarFileExtractor::_extractList()
_translateWinPath | in file TTarFileExtractor.php, method TTarFileExtractor::_translateWinPath()
__construct in file TTarFileExtractor.php, method TTarFileExtractor::__construct()
Archive_Tar Class constructor. This flavour of the constructor only declare a new Archive_Tar object, identifying it by the name of the tar file.
__destruct | in file TTarFileExtractor.php, method TTarFileExtractor::__destruct()
top
e
extract | in file TTarFileExtractor.php, method TTarFileExtractor::extract()
extractModify in file TTarFileExtractor.php, method TTarFileExtractor::extractModify()
This method extract all the content of the archive in the directory indicated by $p_path. When relevant the memorized path of the files/dir can be modified by removing the $p_remove_path path at the beginning of the file/dir path.
top
f
flush in file TTextWriter.php, method TTextWriter::flush()
Flushes the content that has been written.
top
t
TTarFileExtractor.php | procedural page TTarFileExtractor.php
TTextWriter.php | procedural page TTextWriter.php
TTarFileExtractor in file TTarFileExtractor.php, class TTarFileExtractor
TTarFileExtractor class
TTextWriter in file TTextWriter.php, class TTextWriter
TTextWriter class.
top
w
write in file TTextWriter.php, method TTextWriter::write()
Writes a string.
writeLine in file TTextWriter.php, method TTextWriter::writeLine()
Writers a string and terminates it with a newline.


Class Trees for Package System.IO

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TTarFileExtractor.php

File: /IO/TTarFileExtractor.php

Remarks

TTarFileExtractor class file

author

Vincent Blavet <vincent@phpconcept.net>

version

$Id: TTarFileExtractor.php 1637 2007-01-17 22:26:53Z xue $

copyright

Copyright &copy; 1997-2003 The PHP Group

Classes in this file:
TTarFileExtractor
TTarFileExtractor class

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:37 +0200 by phpDocumentor 1.4.3


Docs for page TTextWriter.php

File: /IO/TTextWriter.php

Remarks

TTextWriter class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTextWriter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TTextWriter
TTextWriter class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:41 +0200 by phpDocumentor 1.4.3


Docs For Class TTarFileExtractor

Class TTarFileExtractor

[line 38]

Location: /IO/TTarFileExtractor.php

Remarks

TTarFileExtractor class

author

Vincent Blavet <vincent@phpconcept.net>

version

$Id: TTarFileExtractor.php 1637 2007-01-17 22:26:53Z xue $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Method Detail

    TTarFileExtractor::__construct

__construct(
string
$p_tarname );

    Parameters

    $p_tarname

    The name of the tar archive to create

    Remarks

    Archive_Tar Class constructor. This flavour of the constructor only  declare a new Archive_Tar object, identifying it by the name of the  tar file.

    access

    public

    [ Top ]

    TTarFileExtractor::__destruct

__destruct(
 );

    access

    public

    [ Top ]

    TTarFileExtractor::extract

extract(
[
$p_path = ''] );

    Parameters

    $p_path

    access

    public

    [ Top ]

    TTarFileExtractor::extractModify

extractModify(
string
$p_path, string
$p_remove_path );

    Parameters

    $p_path

    The path of the directory where the                                files/dir need to by extracted.

    $p_remove_path

    Part of the memorized path that can be                                removed if present at the beginning of                                the file/dir path.

    Returns

    true on success, false on error.

    Remarks

    This method extract all the content of the archive in the directory  indicated by $p_path. When relevant the memorized path of the  files/dir can be modified by removing the $p_remove_path path at the  beginning of the file/dir path.

    While extracting a file, if the directory path does not exists it is  created.  While extracting a file, if the file already exists it is replaced  without looking for last modification date.  While extracting a file, if the file already exists and is write  protected, the extraction is aborted.  While extracting a file, if a directory with the same name already  exists, the extraction is aborted.  While extracting a directory, if a file with the same name already  exists, the extraction is aborted.  While extracting a file/directory if the destination directory exist  and is write protected, or does not exist but can not be created,  the extraction is aborted.  If after extraction an extracted file does not show the correct  stored file size, the extraction is aborted.  When the extraction is aborted, a PEAR error text is set and false  is returned. However the result can be a partial extraction that may  need to be manually cleaned.

    access

    protected

    [ Top ]

    TTarFileExtractor::_dirCheck

_dirCheck(
string
$p_dir );

    Parameters

    $p_dir

    directory to check

    Returns

    true if the directory exists or was created

    Remarks

    Check if a directory exists and create it (including parent  dirs) if not.

    access

    protected

    [ Top ]

    TTarFileExtractor::_error

_error(

$p_message );

    Parameters

    $p_message

    access

    protected

    [ Top ]

    TTarFileExtractor::_extractList

_extractList(

$p_path,
&$p_list_detail,
$p_mode,
$p_file_list,
$p_remove_path );

    Parameters

    $p_path

    &$p_list_detail

    $p_mode

    $p_file_list

    $p_remove_path

    access

    protected

    [ Top ]

    TTarFileExtractor::_translateWinPath

_translateWinPath(

$p_path, [
$p_remove_disk_letter = true] );

    Parameters

    $p_path

    $p_remove_disk_letter

    access

    protected

    [ Top ]

Variable Detail

Class Constant Detail

        Documentation generated on Mon, 25 Jun 2012 14:45:37 +0200 by phpDocumentor 1.4.3


Docs For Class TTextWriter

Class TTextWriter

[line 25]
TComponent
   |
   --TTextWriter
Classes extended from TTextWriter:
TCallbackResponseWriter
TCallbackResponseWriter class.
TOutputCacheTextWriterMulti
TTextWriter class.

Location: /IO/TTextWriter.php

Remarks

TTextWriter class.

TTextWriter implements a memory-based text writer. Content written by TTextWriter are stored in memory and can be obtained by calling flush().

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TTextWriter.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TTextWriter::flush

    flush( );

    Overridden in child classes as:

    TCallbackResponseWriter::flush()
    Returns the text content wrapped within a HTML comment with boundary identifier as its comment content.
    TOutputCacheTextWriterMulti::flush()

    Returns

    the content being flushed

    Remarks

    Flushes the content that has been written.

    access

    public

    [ Top ]

    TTextWriter::write

    write( string $str );

    Overridden in child classes as:

    TOutputCacheTextWriterMulti::write()

    Parameters

    $str

    string to be written

    Remarks

    Writes a string.

    access

    public

    [ Top ]

    TTextWriter::writeLine

    writeLine( [string $str = ''] );

    Parameters

    $str

    content to be written

    Remarks

    Writers a string and terminates it with a newline.

    see

    TTextWriter::write()

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:41 +0200 by phpDocumentor 1.4.3


Package System.Xml Element Index

Element index for package System.Xml

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls

Index of all elements
g i l r s t _
top
_
__construct in file TXmlDocument.php, method TXmlElementList::__construct()
Constructor.
__construct in file TXmlDocument.php, method TXmlDocument::__construct()
Constructor.
__construct in file TXmlDocument.php, method TXmlElement::__construct()
Constructor.
__toString in file TXmlDocument.php, method TXmlDocument::__toString()
Magic-method override. Called whenever this document is used as a string.
__toString in file TXmlDocument.php, method TXmlElement::__toString()
Magic-method override. Called whenever this element is used as a string.
top
g
getAttribute | in file TXmlDocument.php, method TXmlElement::getAttribute()
getAttributes | in file TXmlDocument.php, method TXmlElement::getAttributes()
getElementByTagName | in file TXmlDocument.php, method TXmlElement::getElementByTagName()
getElements | in file TXmlDocument.php, method TXmlElement::getElements()
getElementsByTagName | in file TXmlDocument.php, method TXmlElement::getElementsByTagName()
getEncoding | in file TXmlDocument.php, method TXmlDocument::getEncoding()
getHasAttribute | in file TXmlDocument.php, method TXmlElement::getHasAttribute()
getHasElement | in file TXmlDocument.php, method TXmlElement::getHasElement()
getOwner | in file TXmlDocument.php, method TXmlElementList::getOwner()
getParent | in file TXmlDocument.php, method TXmlElement::getParent()
getTagName | in file TXmlDocument.php, method TXmlElement::getTagName()
getValue | in file TXmlDocument.php, method TXmlElement::getValue()
getVersion | in file TXmlDocument.php, method TXmlDocument::getVersion()
top
i
insertAt in file TXmlDocument.php, method TXmlElementList::insertAt()
Inserts an item at the specified position.
top
l
loadFromFile in file TXmlDocument.php, method TXmlDocument::loadFromFile()
Loads and parses an XML document.
loadFromString in file TXmlDocument.php, method TXmlDocument::loadFromString()
Loads and parses an XML string.
top
r
removeAt in file TXmlDocument.php, method TXmlElementList::removeAt()
Removes an item at the specified position.
top
s
saveToFile in file TXmlDocument.php, method TXmlDocument::saveToFile()
Saves this XML document as an XML file.
saveToString in file TXmlDocument.php, method TXmlDocument::saveToString()
Saves this XML document as an XML string
setAttribute | in file TXmlDocument.php, method TXmlElement::setAttribute()
setEncoding | in file TXmlDocument.php, method TXmlDocument::setEncoding()
setParent | in file TXmlDocument.php, method TXmlElement::setParent()
setTagName | in file TXmlDocument.php, method TXmlElement::setTagName()
setValue | in file TXmlDocument.php, method TXmlElement::setValue()
setVersion | in file TXmlDocument.php, method TXmlDocument::setVersion()
top
t
toString | in file TXmlDocument.php, method TXmlElement::toString()
TXmlDocument in file TXmlDocument.php, class TXmlDocument
TXmlDocument class.
TXmlElement in file TXmlDocument.php, class TXmlElement
TXmlElement class.
TXmlElementList in file TXmlDocument.php, class TXmlElementList
TXmlElementList class.
TXmlDocument.php | procedural page TXmlDocument.php


Class Trees for Package System.Xml

Documentation generated on Mon, 25 Jun 2012 14:42:58 +0200 by phpDocumentor 1.4.3


Docs for page TXmlDocument.php

File: /Xml/TXmlDocument.php

Remarks

TXmlElement, TXmlDocument, TXmlElementList class file

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TXmlDocument.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

copyright

Copyright &copy; 2005-2011 PradoSoft

link

http://www.pradosoft.com/

license

http://www.pradosoft.com/license/

Classes in this file:
TXmlElement
TXmlElement class.
TXmlDocument
TXmlDocument class.
TXmlElementList
TXmlElementList class.

Include Statements Summary

Global Variable Summary

Constant Summary

Function Summary

Include Statements Detail

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Mon, 25 Jun 2012 14:45:53 +0200 by phpDocumentor 1.4.3


Docs For Class TXmlDocument

Class TXmlDocument

[line 307]
TComponent
   |
   --TXmlElement
      |
      --TXmlDocument
Location: /Xml/TXmlDocument.php

Remarks

TXmlDocument class.

TXmlDocument represents a DOM representation of an XML file. Besides all properties and methods inherited from TXmlElement, you can load an XML file or string by loadFromFile or loadFromString. You can also get the version and encoding of the XML document by the Version and Encoding properties.

To construct an XML string, you may do the following:

  •  $doc=new TXmlDocument('1.0','utf-8');
    •

  •  $doc->TagName='Root';
    •

  •
    •

  •  $proc=new TXmlElement('Proc');
    •

  •  $proc->setAttribute('Name','xxxx');
    •

  •  $doc->Elements[]=$proc;
    •

  •
    •

  •  $query=new TXmlElement('Query');
    •

  •  $query->setAttribute('ID','xxxx');
    •

  •  $proc->Elements[]=$query;
    •

  •
    •

  •  $attr=new TXmlElement('Attr');
    •

  •  $attr->setAttribute('Name','aaa');
    •

  •  $attr->Value='1';
    •

  •  $query->Elements[]=$attr;
    •

  •
    •

  •  $attr=new TXmlElement('Attr');
    •

  •  $attr->setAttribute('Name','bbb');
    •

  •  $attr->Value='1';
    •

  •  $query->Elements[]=$attr;
    •
    The above code represents the following XML string:
  •  <?xml version="1.0" encoding="utf-8"?>
    •

  •  <Root>
    •

  •    <Proc Name="xxxx">
    •

  •      <Query ID="xxxx">
    •

  •        <Attr Name="aaa">1</Attr>
    •

  •        <Attr Name="bbb">1</Attr>
    •

  •      </Query>
    •

  •    </Proc>
    •

  •  </Root>
    •

    author

    Qiang Xue <qiang.xue@gmail.com>

    version

    $Id: TXmlDocument.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

    since

    3.0

    Class Variable Summary

    Class Constant Summary

    Inherited Class Constant Summary

    Inherited Class Variable Summary

    Method Summary

    Inherited Method Summary

    Inherited From Class TXmlElement

    • TXmlElement::__construct()
      Constructor.
    • TXmlElement::getAttribute()
    • TXmlElement::getAttributes()
    • TXmlElement::getElementByTagName()
    • TXmlElement::getElements()
    • TXmlElement::getElementsByTagName()
    • TXmlElement::getHasAttribute()
    • TXmlElement::getHasElement()
    • TXmlElement::getParent()
    • TXmlElement::getTagName()
    • TXmlElement::getValue()
    • TXmlElement::setAttribute()
    • TXmlElement::setParent()
    • TXmlElement::setTagName()
    • TXmlElement::setValue()
    • TXmlElement::toString()
    • TXmlElement::__toString()
      Magic-method override. Called whenever this element is used as a string.

    Inherited From Class TComponent

    • TComponent::addParsedObject()
      Processes an object that is created during parsing template.
    • TComponent::attachEventHandler()
      Attaches an event handler to an event.
    • TComponent::canGetProperty()
      Determines whether a property can be read.
    • TComponent::canSetProperty()
      Determines whether a property can be set.
    • TComponent::createdOnTemplate()
      This method is invoked after the component is instantiated by a template.
    • TComponent::detachEventHandler()
      Detaches an existing event handler.
    • TComponent::evaluateExpression()
      Evaluates a PHP expression in the context of this control.
    • TComponent::evaluateStatements()
      Evaluates a list of PHP statements.
    • TComponent::getEventHandlers()
      Returns the list of attached event handlers for an event.
    • TComponent::getSubProperty()
      Evaluates a property path.
    • TComponent::hasEvent()
      Determines whether an event is defined.
    • TComponent::hasEventHandler()
    • TComponent::hasProperty()
      Determines whether a property is defined.
    • TComponent::raiseEvent()
      Raises an event.
    • TComponent::setSubProperty()
      Sets a value to a property path.
    • TComponent::__call()
      Calls a method.
    • TComponent::__get()
      Returns a property value or an event handler list by property or event name.
    • TComponent::__set()
      Sets value of a component property.
    • TComponent::__sleep()
      Returns an array with the names of all variables of that object that should be serialized.
    • TComponent::__wakeup()
      Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

    Method Detail

      TXmlDocument::__construct

      __construct( [string $version = '1.0'], [string $encoding = ''] );

      Overrides TXmlElement::__construct() (Constructor.)

      Parameters

      $version

      version of this XML document

      $encoding

      encoding of this XML document

      Remarks

      Constructor.

      access

      public

      [ Top ]

      TXmlDocument::getEncoding

      getEncoding( );

      Returns

      encoding of this XML document

      access

      public

      [ Top ]

      TXmlDocument::getVersion

      getVersion( );

      Returns

      version of this XML document

      access

      public

      [ Top ]

      TXmlDocument::loadFromFile

      loadFromFile( string $file );

      Parameters

      $file

      the XML file path

      Returns

      whether the XML file is parsed successfully

      Remarks

      Loads and parses an XML document.

      throws

      TIOException if the file fails to be opened.

      access

      public

      [ Top ]

      TXmlDocument::loadFromString

      loadFromString( string $string );

      Parameters

      $string

      the XML string

      Returns

      whether the XML string is parsed successfully

      Remarks

      Loads and parses an XML string.

      The version and encoding will be determined based on the parsing result.

      access

      public

      [ Top ]

      TXmlDocument::saveToFile

      saveToFile( string $file );

      Parameters

      $file

      the name of the file to be stored with XML output

      Remarks

      Saves this XML document as an XML file.

      throws

      TIOException if the file cannot be written

      access

      public

      [ Top ]

      TXmlDocument::saveToString

      saveToString( );

      Returns

      the XML string of this XML document

      Remarks

      Saves this XML document as an XML string

      access

      public

      [ Top ]

      TXmlDocument::setEncoding

      setEncoding( string $encoding );

      Parameters

      $encoding

      encoding of this XML document

      access

      public

      [ Top ]

      TXmlDocument::setVersion

      setVersion( string $version );

      Parameters

      $version

      version of this XML document

      access

      public

      [ Top ]

      TXmlDocument::__toString

      __toString( );

      Overrides TXmlElement::__toString() (Magic-method override. Called whenever this element is used as a string.)

      Returns

      string representation of this document

      Remarks

      Magic-method override. Called whenever this document is used as a string.

    •  $document = new TXmlDocument();
      •

    •  $document->TagName = 'root';
      •

    •  echo $document;
      •
      or
    •  $document = new TXmlDocument();
      •

    •  $document->TagName = 'root';
      •

    •  $xml = (string)$document;
      •

      access

      public

      [ Top ]

    Variable Detail

    Class Constant Detail

    Documentation generated on Mon, 25 Jun 2012 14:45:53 +0200 by phpDocumentor 1.4.3


Docs For Class TXmlElement

Class TXmlElement

[line 29]
TComponent
   |
   --TXmlElement
Classes extended from TXmlElement:
TXmlDocument
TXmlDocument class.

Location: /Xml/TXmlDocument.php

Remarks

TXmlElement class.

TXmlElement represents an XML element node. You can obtain its tag-name, attributes, text between the opening and closing tags via the TagName, Attributes, and Value properties, respectively. You can also retrieve its parent and child elements by Parent and Elements properties, respectively.

TBD: xpath

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TXmlDocument.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TXmlElement::__construct

    __construct( string $tagName );

    Overridden in child classes as:

    TXmlDocument::__construct()
    Constructor.

    Parameters

    $tagName

    tag-name for this element

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TXmlElement::getAttribute

    getAttribute( $name );

    Parameters

    $name

    Returns

    the attribute specified by the name, null if no such attribute

    access

    public

    [ Top ]

    TXmlElement::getAttributes

    getAttributes( );

    Returns

    list of attributes

    access

    public

    [ Top ]

    TXmlElement::getElementByTagName

    getElementByTagName( $tagName );

    Parameters

    $tagName

    Returns

    the first child element that has the specified tag-name, null if not found

    access

    public

    [ Top ]

    TXmlElement::getElements

    getElements( );

    Returns

    list of child elements

    access

    public

    [ Top ]

    TXmlElement::getElementsByTagName

    getElementsByTagName( $tagName );

    Parameters

    $tagName

    Returns

    list of all child elements that have the specified tag-name

    access

    public

    [ Top ]

    TXmlElement::getHasAttribute

    getHasAttribute( );

    Returns

    true if this element has attributes

    access

    public

    [ Top ]

    TXmlElement::getHasElement

    getHasElement( );

    Returns

    true if this element has child elements

    access

    public

    [ Top ]

    TXmlElement::getParent

    getParent( );

    Returns

    parent element of this element

    access

    public

    [ Top ]

    TXmlElement::getTagName

    getTagName( );

    Returns

    tag-name of this element

    access

    public

    [ Top ]

    TXmlElement::getValue

    getValue( );

    Returns

    text enclosed between opening and closing tag of this element

    access

    public

    [ Top ]

    TXmlElement::setAttribute

    setAttribute( string $name, string $value );

    Parameters

    $name

    attribute name

    $value

    attribute value

    access

    public

    [ Top ]

    TXmlElement::setParent

    setParent( TXmlElement $parent );

    Parameters

    $parent

    parent element of this element

    access

    public

    [ Top ]

    TXmlElement::setTagName

    setTagName( string $tagName );

    Parameters

    $tagName

    tag-name of this element

    access

    public

    [ Top ]

    TXmlElement::setValue

    setValue( string $value );

    Parameters

    $value

    text enclosed between opening and closing tag of this element

    access

    public

    [ Top ]

    TXmlElement::toString

    toString( [ $indent = 0] );

    Parameters

    $indent

    Returns

    string representation of this element

    access

    public

    [ Top ]

    TXmlElement::__toString

    __toString( );

    Overridden in child classes as:

    TXmlDocument::__toString()
    Magic-method override. Called whenever this document is used as a string.

    Returns

    string representation of this element

    Remarks

    Magic-method override. Called whenever this element is used as a string.

  •  $element = new TXmlElement('tag');
    •

  •  echo $element;
    •
    or
  •  $element = new TXmlElement('tag');
    •

  •  $xml = (string)$element;
    •

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:53 +0200 by phpDocumentor 1.4.3


Docs For Class TXmlElementList

Class TXmlElementList

[line 509]
TComponent
   |
   --TList
      |
      --TXmlElementList
Location: /Xml/TXmlDocument.php

Remarks

TXmlElementList class.

TXmlElementList represents a collection of TXmlElement. You may manipulate the collection with the operations defined in TList.

author

Qiang Xue <qiang.xue@gmail.com>

version

$Id: TXmlDocument.php 2996 2011-06-20 15:24:57Z ctrlaltca@gmail.com $

since

3.0

Class Variable Summary

Class Constant Summary

Inherited Class Constant Summary

Inherited Class Variable Summary

Method Summary

Inherited Method Summary

Inherited From Class TList

  • TList::__construct()
    Constructor.
  • TList::add()
    Appends an item at the end of the list.
  • TList::clear()
    Removes all items in the list.
  • TList::contains()
  • TList::copyFrom()
    Copies iterable data into the list.
  • TList::count()
    Returns the number of items in the list.
  • TList::getCount()
  • TList::getIterator()
    Returns an iterator for traversing the items in the list.
  • TList::getReadOnly()
  • TList::indexOf()
  • TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
  • TList::insertAt()
    Inserts an item at the specified position.
  • TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
  • TList::itemAt()
    Returns the item at the specified offset.
  • TList::mergeWith()
    Merges iterable data into the map.
  • TList::offsetExists()
    Returns whether there is an item at the specified offset.
  • TList::offsetGet()
    Returns the item at the specified offset.
  • TList::offsetSet()
    Sets the item at the specified offset.
  • TList::offsetUnset()
    Unsets the item at the specified offset.
  • TList::remove()
    Removes an item from the list.
  • TList::removeAt()
    Removes an item at the specified position.
  • TList::setReadOnly()
  • TList::toArray()

Inherited From Class TComponent

  • TComponent::addParsedObject()
    Processes an object that is created during parsing template.
  • TComponent::attachEventHandler()
    Attaches an event handler to an event.
  • TComponent::canGetProperty()
    Determines whether a property can be read.
  • TComponent::canSetProperty()
    Determines whether a property can be set.
  • TComponent::createdOnTemplate()
    This method is invoked after the component is instantiated by a template.
  • TComponent::detachEventHandler()
    Detaches an existing event handler.
  • TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
  • TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
  • TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
  • TComponent::getSubProperty()
    Evaluates a property path.
  • TComponent::hasEvent()
    Determines whether an event is defined.
  • TComponent::hasEventHandler()
  • TComponent::hasProperty()
    Determines whether a property is defined.
  • TComponent::raiseEvent()
    Raises an event.
  • TComponent::setSubProperty()
    Sets a value to a property path.
  • TComponent::__call()
    Calls a method.
  • TComponent::__get()
    Returns a property value or an event handler list by property or event name.
  • TComponent::__set()
    Sets value of a component property.
  • TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
  • TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.

Method Detail

    TXmlElementList::__construct

    __construct( TXmlElement $owner );

    Overrides TList::__construct() (Constructor.)

    Parameters

    $owner

    owner of this list

    Remarks

    Constructor.

    access

    public

    [ Top ]

    TXmlElementList::getOwner

    getOwner( );

    Returns

    owner of this list

    access

    protected

    [ Top ]

    TXmlElementList::insertAt

    insertAt( integer $index, mixed $item );

    Overrides TList::insertAt() (Inserts an item at the specified position.)

    Parameters

    $index

    the specified position.

    $item

    new item

    Remarks

    Inserts an item at the specified position.

    This overrides the parent implementation by performing additional operations for each newly added TXmlElement object.

    throws

    TInvalidDataTypeException if the item to be inserted is not a TXmlElement object.

    access

    public

    [ Top ]

    TXmlElementList::removeAt

    removeAt( integer $index );

    Overrides TList::removeAt() (Removes an item at the specified position.)

    Parameters

    $index

    the index of the item to be removed.

    Returns

    the removed item.

    Remarks

    Removes an item at the specified position.

    This overrides the parent implementation by performing additional cleanup work when removing a TXmlElement object.

    access

    public

    [ Top ]

Variable Detail

Class Constant Detail

Documentation generated on Mon, 25 Jun 2012 14:45:53 +0200 by phpDocumentor 1.4.3


Element Index

Index of All Elements

Indexes by package:
System.Caching
System.Collections
System.Data.ActiveRecord
System.Data.ActiveRecord.Relations
System.Data.ActiveReecord.Scaffold.InputBuilder
System.Data.ActiveRecord.Scaffold
System.Data.Common
System.Data.Common.Mssql
System.Data.Common.Mysql
System.Data.Common.Oracle
System.Data.Common.Pgsql
System.Data.Common.Sqlite
System.Data.Commom.Sqlite
System.Data.DataGateway
System.Data.SqlMap.Configuration
System.Data.SqlMap.Statements
System.Data.SqlMap
System.Data
System.Exceptions
System.I18N
System
System.IO
System.Security
System.Util
System.Web.Javascripts
System.Web.Services
System.Web
System.Web.UI.ActiveControls
System.Web.UI
System.Web.UI.WebControls
System.Xml

a b c d e f g h i j k l m n o p q r s t u v w x _
top
a
$apiProviders | in file TRpcService.php, variable TRpcService::$apiProviders
activateView in file TMultiView.php, method TMultiView::activateView()
Activates the specified view.
activateView in file TTabPanel.php, method TTabPanel::activateView()
Activates the specified view.
activateView in file TAccordion.php, method TAccordion::activateView()
Activates the specified view.
add in file TAttributeCollection.php, method TAttributeCollection::add()
Adds an item into the map.
add in file TPriorityList.php, method TPriorityList::add()
Appends an item into the list at the end of the specified priority. The position of the added item may not be at the end of the list.
add in file TPriorityMap.php, method TPriorityMap::add()
Adds an item into the map. A third parameter may be used to set the priority of the item within the map. Priority is primarily used during when flattening the map into an array where order may be and important factor of the key-value pairs within the array.
add | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::add()
add in file TCache.php, method TCache::add()
Stores a value identified by a key into cache if the cache does not contain this key.
add in file TMap.php, method TMap::add()
Adds an item into the map.
add in file THttpSession.php, method THttpSession::add()
Adds a session variable.
add in file interfaces.php, method ICache::add()
Stores a value identified by a key into cache if the cache does not contain this key.
add in file TList.php, method TList::add()
Appends an item at the end of the list.
add | in file TSqlMapCache.php, method TSqlMapApplicationCache::add()
add in file THttpRequest.php, method THttpRequest::add()
Adds an item into the request.
add in file TMappedStatement.php, method TSqlMapObjectCollectionTree::add()
Add a new node to the object tree graph.
add | in file TSqlMapCache.php, method TSqlMapCache::add()
addAttribute in file THtmlWriter.php, method THtmlWriter::addAttribute()
Adds an attribute to be rendered.
addAttributes in file THtmlWriter.php, method THtmlWriter::addAttributes()
Adds a list of attributes to be rendered.
addAttributesToRender in file TTextBox.php, method TTextBox::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender | in file TValidationSummary.php, method TValidationSummary::addAttributesToRender()
addAttributesToRender in file THyperLink.php, method THyperLink::addAttributesToRender()
Adds attributes related to a hyperlink element to renderer.
addAttributesToRender in file TImageMap.php, method TImageMap::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TTabPanel.php, method TTabView::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TInlineFrame.php, method TInlineFrame::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TImage.php, method TImage::addAttributesToRender()
Adds attributes related to an HTML image element to renderer.
addAttributesToRender in file THtmlArea.php, method THtmlArea::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TDropDownList.php, method TDropDownList::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TDropContainer.php, method TDropContainer::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TWebControl.php, method TWebControl::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TFileUpload.php, method TFileUpload::addAttributesToRender()
Sets name attribute to the unique ID of the control.
addAttributesToRender in file TForm.php, method TForm::addAttributesToRender()
Adds form specific attributes to renderer.
addAttributesToRender in file TFont.php, method TFont::addAttributesToRender()
Adds attributes related to CSS styles to renderer.
addAttributesToRender in file TInPlaceTextBox.php, method TInPlaceTextBox::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TKeyboard.php, method TKeyboard::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TStyle.php, method TTableStyle::addAttributesToRender()
Adds attributes related to CSS styles to renderer.
addAttributesToRender in file TPanel.php, method TPanel::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TTable.php, method TTable::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TPanelStyle.php, method TPanelStyle::addAttributesToRender()
Adds attributes related to CSS styles to renderer.
addAttributesToRender in file TStyle.php, method TTableItemStyle::addAttributesToRender()
Adds attributes related to CSS styles to renderer.
addAttributesToRender | in file TReCaptcha.php, method TReCaptcha::addAttributesToRender()
addAttributesToRender in file TStyle.php, method TStyle::addAttributesToRender()
Adds attributes related to CSS styles to renderer.
addAttributesToRender in file TDraggable.php, method TDraggable::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TTableCell.php, method TTableCell::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TLinkButton.php, method TLinkButton::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TLabel.php, method TLabel::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TTabPanel.php, method TTabPanel::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TListBox.php, method TListBox::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TTableHeaderCell.php, method TTableHeaderCell::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TListControl.php, method TListControl::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TSlider.php, method TSlider::addAttributesToRender()
Add the specified css classes to the track
addAttributesToRender in file TImageButton.php, method TImageButton::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TActiveLabel.php, method TActiveLabel::addAttributesToRender()
Adds attribute id to the renderer.
addAttributesToRender in file TAccordion.php, method TAccordion::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TActiveListBox.php, method TActiveListBox::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveDropDownList.php, method TActiveDropDownList::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveLinkButton.php, method TActiveLinkButton::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActivePanel.php, method TActivePanel::addAttributesToRender()
Adds attribute id to the renderer.
addAttributesToRender in file TBulletedList.php, method TBulletedList::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TActiveTableCell.php, method TActiveTableCell::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control if the event handler for the onCellSelected event is set.
addAttributesToRender in file TAccordion.php, method TAccordionView::addAttributesToRender()
Adds attributes to renderer.
addAttributesToRender in file TButton.php, method TButton::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TActiveButton.php, method TActiveButton::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TBaseValidator.php, method TBaseValidator::addAttributesToRender()
Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
addAttributesToRender in file TActiveCustomValidator.php, method TActiveCustomValidator::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveImageButton.php, method TActiveImageButton::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveFileUpload.php, method TActiveFileUpload::addAttributesToRender()
Adds ID attribute, and renders the javascript for active component.
addAttributesToRender in file TActiveHiddenField.php, method TActiveHiddenField::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveTextBox.php, method TActiveTextBox::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
addAttributesToRender in file TActiveTableRow.php, method TActiveTableRow::addAttributesToRender()
Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control if the event handler for the onRowSelected event is set.
addAttributesToRender in file TDataListItemRenderer.php, method TDataListItemRenderer::addAttributesToRender()
Adds attribute name-value pairs to renderer.
addAttributesToRender in file TDatePicker.php, method TDatePicker::addAttributesToRender()
Add the client id to the input textbox, and register the client scripts.
addCacheModel in file TSqlMapManager.php, method TSqlMapManager::addCacheModel()
Adds a named cache.
addCookie in file THttpResponse.php, method THttpResponse::addCookie()
Sends a cookie.
addCssClass in file TCallbackClientScript.php, method TCallbackClientScript::addCssClass()
Add a Css class name to the element.
addedControl in file TControl.php, method TControl::addedControl()
Adds a control into the child collection of the control.
addedWizardStep in file TWizard.php, method TWizard::addedWizardStep()
Adds a wizard step to the multiview.
addMappedStatement in file TSqlMapManager.php, method TSqlMapManager::addMappedStatement()
Adds a (named) MappedStatement.
addMethod in file TRpcService.php, method TRpcProtocol::addMethod()
Registers a new RPC method and handler details
addMethod in file TRpcService.php, method TXmlRpcProtocol::addMethod()
Registers a new RPC method and handler details
addNode in file TMappedStatement.php, method TSqlMapObjectCollectionTree::addNode()
Find the parent node and add the new node as its child.
addParameterMap | in file TSqlMapManager.php, method TSqlMapManager::addParameterMap()
addParsedObject in file TListControl.php, method TListControl::addParsedObject()
Adds object parsed from template to the control.
addParsedObject in file TMultiView.php, method TMultiView::addParsedObject()
Processes an object that is created during parsing template.
addParsedObject in file TTableRow.php, method TTableRow::addParsedObject()
Adds object parsed from template to the control.
addParsedObject in file TTable.php, method TTable::addParsedObject()
Adds object parsed from template to the control.
addParsedObject in file TTabPanel.php, method TTabPanel::addParsedObject()
Adds object parsed from template to the control.
addParsedObject in file TComponent.php, method TComponent::addParsedObject()
Processes an object that is created during parsing template.
addParsedObject in file TImageMap.php, method TImageMap::addParsedObject()
Processes an object that is created during parsing template.
addParsedObject in file TAccordion.php, method TAccordion::addParsedObject()
Adds object parsed from template to the control.
addParsedObject in file TTextProcessor.php, method TTextProcessor::addParsedObject()
HTML-decodes static text.
addParsedObject in file TControl.php, method TControl::addParsedObject()
Adds the object instantiated on a template to the child control collection.
addParsedObject in file TDataGrid.php, method TDataGrid::addParsedObject()
Adds objects parsed in template to datagrid.
addParsedObject in file TWizard.php, method TWizard::addParsedObject()
Adds TWizardStep objects into step collection.
addParsedObject in file THead.php, method THead::addParsedObject()
Processes an object that is created during parsing template.
addParsedObject in file TConditional.php, method TConditional::addParsedObject()
Processes an object that is created during parsing template.
addParsedObject in file TDropDownListColumn.php, method TDropDownListColumn::addParsedObject()
Adds object parsed from template to the control.
addPostDataLoader | in file TCallbackClientScript.php, method TCallbackClientScript::addPostDataLoader()
addProperty | in file TParameterMap.php, method TParameterMap::addProperty()
addResultMap | in file TSqlMapManager.php, method TSqlMapManager::addResultMap()
addResultMapGroupBy in file TMappedStatement.php, method TMappedStatement::addResultMapGroupBy()
ResultMap with GroupBy property. Save object collection graph in a tree and collect the result later.
addResultProperty in file TResultMap.php, method TResultMap::addResultProperty()
Add a TResultProperty to result mapping.
addRoute in file TLogRouter.php, method TLogRouter::addRoute()
Adds a TLogRoute instance to the log router.
addRpcMethod | in file TRpcService.php, method TRpcServer::addRpcMethod()
addStatesToTrack in file TActiveControlAdapter.php, method TCallbackPageStateTracker::addStatesToTrack()
Add a list of view states to track. Each state is added to the StatesToTrack property with the view state name as key.
addStyleAttribute in file THtmlWriter.php, method THtmlWriter::addStyleAttribute()
Adds a stylesheet attribute to be rendered
addStyleAttributes in file THtmlWriter.php, method THtmlWriter::addStyleAttributes()
Adds a list of stylesheet attributes to be rendered.
addSubMap | in file TDiscriminator.php, method TDiscriminator::addSubMap()
addToPostDataLoader in file TControl.php, method TControl::addToPostDataLoader()
Add controls implementing IPostBackDataHandler to post data loaders.
addToPostDataLoader in file TRadioButton.php, method TRadioButton::addToPostDataLoader()
Add the group name as post data loader if group name is set.
addValue in file TDbCache.php, method TDbCache::addValue()
Stores a value identified by a key into cache if the cache does not contain this key.
addValue in file TAPCCache.php, method TAPCCache::addValue()
Stores a value identified by a key into cache if the cache does not contain this key.
addValue in file TMemCache.php, method TMemCache::addValue()
Stores a value identified by a key into cache if the cache does not contain this key.
addValue in file TXCache.php, method TXCache::addValue()
Stores a value identified by a key into cache if the cache does not contain this key.
addValue in file TSqliteCache.php, method TSqliteCache::addValue()
Stores a value identified by a key into cache if the cache does not contain this key.
addValue in file TCache.php, method TCache::addValue()
Stores a value identified by a key into cache if the cache does not contain this key.
ADODB_NO_NEGATIVE_TS | in file TDateTimeStamp.php, constant ADODB_NO_NEGATIVE_TS
ALERT | in file TLogger.php, class constant TLogger::ALERT
Allow | in file THttpSession.php, class constant THttpSessionCookieMode::Allow
allowNavigationToPreviousStep | in file TWizard.php, method TWizard::allowNavigationToPreviousStep()
allowNavigationToStep | in file TWizard.php, method TWizard::allowNavigationToStep()
AlternatingItem | in file TDataBoundControl.php, class constant TListItemType::AlternatingItem
appear in file TCallbackClientScript.php, method TCallbackClientScript::appear()
Visual Effect: Gradually make the element appear.
appendContent in file TCallbackClientScript.php, method TCallbackClientScript::appendContent()
Append a HTML fragement to the element.
appendHeader in file THttpResponse.php, method THttpResponse::appendHeader()
Sends a header.
appendLog in file THttpResponse.php, method THttpResponse::appendLog()
Writes a log message into error log.
appendScriptBlock in file TCallbackClientScript.php, method TCallbackClientScript::appendScriptBlock()
Appends a block of inline javascript enclosed in a boundary.
apply in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::apply()
Applies this style to the specified button
applyConfiguration in file TApplication.php, method TApplication::applyConfiguration()
Applies an application configuration.
applyConfiguration in file TPageService.php, method TPageService::applyConfiguration()
Applies a page configuration.
applyControlProperties in file TWizard.php, method TWizard::applyControlProperties()
Applies various properties to the components of wizard
applyControlSkin in file TPage.php, method TPage::applyControlSkin()
Applies a skin in the current theme to a control.
applyControlStyleSheet in file TPage.php, method TPage::applyControlStyleSheet()
Applies a stylesheet skin in the current theme to a control.
applyCriterias | in file TDbCommandBuilder.php, method TDbCommandBuilder::applyCriterias()
applyHeaderProperties in file TWizard.php, method TWizard::applyHeaderProperties()
Applies properties to the wizard header
applyInlineParameterMap in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::applyInlineParameterMap()
Extract inline parameter maps.
applyItemStyles in file TDataGrid.php, method TDataGrid::applyItemStyles()
Applies styles to items, header, footer and separators.
applyItemStyles in file TDataList.php, method TDataList::applyItemStyles()
Applies styles to items, header, footer and separators.
applyLimitOffset in file TMssqlCommandBuilder.php, method TMssqlCommandBuilder::applyLimitOffset()
Overrides parent implementation. Alters the sql to apply $limit and $offset.
applyLimitOffset in file TOracleCommandBuilder.php, method TOracleCommandBuilder::applyLimitOffset()
Overrides parent implementation to use Oracle way of get paginated RecordSet instead of using LIMIT sql clause.
applyLimitOffset in file TSqliteCommandBuilder.php, method TSqliteCommandBuilder::applyLimitOffset()
Alters the sql to apply $limit and $offset.
applyLimitOffset in file TDbCommandBuilder.php, method TDbCommandBuilder::applyLimitOffset()
Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.
applyNavigationProperties in file TWizard.php, method TWizard::applyNavigationProperties()
Apply properties to various navigation panels.
applyOrdering | in file TDbCommandBuilder.php, method TDbCommandBuilder::applyOrdering()
applyParameterMap | in file TPreparedCommand.php, method TPreparedCommand::applyParameterMap()
applyResultMap in file TMappedStatement.php, method TMappedStatement::applyResultMap()
Apply result mapping.
applySecureConnectionPrefix in file TUrlMapping.php, method TUrlMappingPattern::applySecureConnectionPrefix()
Apply behavior of SecureConnection property by conditionaly prefixing URL with THttpRequest::getBaseUrl()
applySideBarProperties in file TWizard.php, method TWizard::applySideBarProperties()
Applies properties to the wizard sidebar
applySkin in file TThemeManager.php, method TTheme::applySkin()
Applies the theme to a particular control.
applySkin in file TControl.php, method ITheme::applySkin()
Applies this theme to the specified control.
applyStepContentProperties in file TWizard.php, method TWizard::applyStepContentProperties()
Applies properties to the wizard step content
applyStyleSheetSkin in file TControl.php, method TControl::applyStyleSheetSkin()
Applies a stylesheet skin to a control.
ARRAY_TYPE | in file TResultProperty.php, class constant TResultProperty::ARRAY_TYPE
assertIdentifier | in file TPgsqlMetaData.php, method TPgsqlMetaData::assertIdentifier()
assertIdentifier | in file TOracleMetaData.php, method TOracleMetaData::assertIdentifier()
attachCacheModels in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::attachCacheModels()
Set the cache for each statement having a cache model property.
attachEventHandler in file TComponent.php, method TComponent::attachEventHandler()
Attaches an event handler to an event.
Auto | in file TWizard.php, class constant TWizardStepType::Auto
Auto | in file TInlineFrame.php, class constant TInlineFrameScrollBars::Auto
Auto | in file TPanelStyle.php, class constant TScrollBars::Auto
autoBindProperty in file TControl.php, method TControl::autoBindProperty()
Sets up the binding between a property (or property path) and an expression.
autoDataBindProperties in file TControl.php, method TControl::autoDataBindProperties()
Auto databinding properties of the control.
autoload in file PradoBase.php, method PradoBase::autoload()
Class autoload loader.
Automatic in file TUrlMapping.php, class constant TUrlMappingPatternSecureConnection::Automatic
Keep current SecureConnection status
AUTOMATIC_ID_PREFIX in file TControl.php, class constant TControl::AUTOMATIC_ID_PREFIX
prefix to an ID automatically generated
top
b
BASE_API_PROVIDER in file TRpcService.php, class constant TRpcService::BASE_API_PROVIDER
const string base api provider class which every API must extend
BASE_RPC_SERVER in file TRpcService.php, class constant TRpcService::BASE_RPC_SERVER
const string base RPC server implementation
Basic | in file TSqlMapCacheModel.php, class constant TSqlMapCacheTypes::Basic
Basic | in file TDatePicker.php, class constant TDatePickerMode::Basic
Basic | in file TColorPicker.php, class constant TColorPickerMode::Basic
beginFormRender | in file TPage.php, method TPage::beginFormRender()
beginTransaction in file TDbConnection.php, method TDbConnection::beginTransaction()
Starts a transaction.
BELONGS_TO | in file TActiveRecord.php, class constant TActiveRecord::BELONGS_TO
bindArrayValues | in file TDbCommandBuilder.php, method TDbCommandBuilder::bindArrayValues()
bindColumn in file TDbDataReader.php, method TDbDataReader::bindColumn()
Binds a column to a PHP variable.
bindColumnValues in file TDbCommandBuilder.php, method TDbCommandBuilder::bindColumnValues()
Bind the name-value pairs of $values where the array keys correspond to column names.
bindParameter in file TDbCommand.php, method TDbCommand::bindParameter()
Binds a parameter to the SQL statement to be executed.
bindProperty in file TControl.php, method TControl::bindProperty()
Sets up the binding between a property (or property path) and an expression.
bindValue in file TDbCommand.php, method TDbCommand::bindValue()
Binds a value to a parameter.
blindDown in file TCallbackClientScript.php, method TCallbackClientScript::blindDown()
Visual Effect: Blind down.
blindUp in file TCallbackClientScript.php, method TCallbackClientScript::blindUp()
Visual Effect: Blind up.
Body | in file TTableRow.php, class constant TTableRowSection::Body
Both | in file TInlineFrame.php, class constant TInlineFrameScrollBars::Both
Both | in file TStyle.php, class constant TTableGridLines::Both
Both | in file TPanelStyle.php, class constant TScrollBars::Both
Bottom | in file TInlineFrame.php, class constant TInlineFrameAlign::Bottom
Bottom | in file TDatePicker.php, class constant TDatePickerPositionMode::Bottom
Bottom | in file TDataGrid.php, class constant TDataGridPagerPosition::Bottom
Bottom | in file TTable.php, class constant TTableCaptionAlign::Bottom
Bottom | in file TStyle.php, class constant TVerticalAlign::Bottom
broadcastEvent in file TControl.php, method TControl::broadcastEvent()
Broadcasts an event.
broadcastEventReceived in file TControl.php, method IBroadcastEventReceiver::broadcastEventReceived()
Handles broadcast event.
bubbleEvent in file TRepeater.php, method TRepeaterItem::bubbleEvent()
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
bubbleEvent in file TWizard.php, method TWizard::bubbleEvent()
Handles bubbled events.
bubbleEvent in file TRepeater.php, method TRepeater::bubbleEvent()
This method overrides parent's implementation to handle onItemCommand event which is bubbled from repeater items and their child controls.
bubbleEvent in file TScaffoldEditView.php, method TScaffoldEditView::bubbleEvent()
Bubble the command name event. Stops bubbling when the page validator false.
bubbleEvent in file TScaffoldSearch.php, method TScaffoldSearch::bubbleEvent()
Sets the SearchCondition of the TScaffoldListView as the search terms given by the text of the search text box.
bubbleEvent in file TScaffoldView.php, method TScaffoldView::bubbleEvent()
Handle the "edit" and "new" commands by displaying the edit view.
bubbleEvent in file TRepeaterItemRenderer.php, method TRepeaterItemRenderer::bubbleEvent()
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
bubbleEvent in file TScaffoldListView.php, method TScaffoldListView::bubbleEvent()
Continue bubbling the "edit" command, "delete" command is handled in this class.
bubbleEvent in file TMultiView.php, method TMultiView::bubbleEvent()
Processes the events bubbled from child controls.
bubbleEvent in file TDataList.php, method TDataList::bubbleEvent()
This method overrides parent's implementation to handle onItemCommand event which is bubbled from datalist items and their child controls.
bubbleEvent in file TControl.php, method TControl::bubbleEvent()
This method responds to a bubbled event.
bubbleEvent in file TDataGrid.php, method TDataGridPager::bubbleEvent()
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
bubbleEvent in file TDataGrid.php, method TDataGridItem::bubbleEvent()
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
bubbleEvent in file TDataGrid.php, method TDataGrid::bubbleEvent()
This method overrides parent's implementation to handle onItemCommand event which is bubbled from TDataGridItem child controls.
bubbleEvent in file TDataListItemRenderer.php, method TDataListItemRenderer::bubbleEvent()
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
bubbleEvent in file TDataList.php, method TDataListItem::bubbleEvent()
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
bubbleEvent in file TActiveTableRow.php, method TActiveTableRow::bubbleEvent()
This method overrides parent's implementation and raises the control's callback event. This will fire the onRowSelected event if an appropriate event handler is implemented.
bubbleEvent in file TPager.php, method TPager::bubbleEvent()
Processes a bubbled event.
buildListPager in file TPager.php, method TPager::buildListPager()
Builds a dropdown list pager
buildListPager in file TActivePager.php, method TActivePager::buildListPager()
Builds a dropdown list pager Override parent implementation to build Active dropdown lists.
buildNextPrevPager in file TDataGrid.php, method TDataGrid::buildNextPrevPager()
Builds a next-prev pager
buildNextPrevPager in file TPager.php, method TPager::buildNextPrevPager()
Builds a next-prev pager
buildNumericPager in file TPager.php, method TPager::buildNumericPager()
Builds a numeric pager
buildNumericPager in file TDataGrid.php, method TDataGrid::buildNumericPager()
Builds a numeric pager
buildPager in file TPager.php, method TPager::buildPager()
Builds the pager content based on the pager mode.
buildPager in file TDataGrid.php, method TDataGrid::buildPager()
Builds the pager content based on pager style.
buildPreparedStatement | in file TStaticSql.php, method TStaticSql::buildPreparedStatement()
BulletList | in file TValidationSummary.php, class constant TValidationSummaryDisplayMode::BulletList
BusinessCity | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessCity
BusinessCountryRegion | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessCountryRegion
BusinessFax | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessFax
BusinessPhone | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessPhone
BusinessState | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessState
BusinessStreetAddress | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessStreetAddress
BusinessUrl | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessUrl
BusinessZipCode | in file TTextBox.php, class constant TTextBoxAutoCompleteType::BusinessZipCode
Button | in file TWizard.php, class constant TWizardNavigationButtonType::Button
Button | in file TDatePicker.php, class constant TDatePickerMode::Button
Button | in file TButton.php, class constant TButtonType::Button
top
c
$classExists | in file PradoBase.php, variable PradoBase::$classExists
$COLUMN_MAPPING in file TActiveRecord.php, variable TActiveRecord::$COLUMN_MAPPING
This static variable defines the column mapping.
cacheSqlMapManager in file TSqlMapConfig.php, method TSqlMapConfig::cacheSqlMapManager()
Saves the current SqlMap manager to cache.
CACHE_ID_PREFIX | in file TOutputCache.php, class constant TOutputCache::CACHE_ID_PREFIX
CACHE_NAME in file TApplication.php, class constant TApplicationStatePersister::CACHE_NAME
Name of the value stored in cache
CACHE_TABLE in file TSqliteCache.php, class constant TSqliteCache::CACHE_TABLE
name of the table storing cache data
calculateCacheKey in file TOutputCache.php, method TOutputCache::calculateCacheKey()
Calculates the cache key.
calculateKey | in file TCacheHttpSession.php, method TCacheHttpSession::calculateKey()
calculateKey | in file TCachePageStatePersister.php, method TCachePageStatePersister::calculateKey()
callApiMethod in file TRpcService.php, method TRpcProtocol::callApiMethod()
Calls the callback handler for the given method
CALLBACK_ACTION_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_ACTION_HEADER
Callback response client-side action header name.
CALLBACK_DATA_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_DATA_HEADER
Callback response data header name.
CALLBACK_ERROR_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_ERROR_HEADER
Callback error header name.
CALLBACK_HIDDENFIELDLIST_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_HIDDENFIELDLIST_HEADER
Hidden field list header name.
CALLBACK_PAGESTATE_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_PAGESTATE_HEADER
Callback page state header name.
CALLBACK_REDIRECT in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_REDIRECT
Callback redirect url header name.
CALLBACK_SCRIPTLIST_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_SCRIPTLIST_HEADER
Script list header name.
CALLBACK_STYLESHEETLIST_HEADER in file TActivePageAdapter.php, class constant TActivePageAdapter::CALLBACK_STYLESHEETLIST_HEADER
Stylesheet list header name.
callClientFunction in file TActiveRatingList.php, method TActiveRatingList::callClientFunction()
Calls the client-side static method for this control class.
callClientFunction in file TInPlaceTextBox.php, method TInPlaceTextBox::callClientFunction()
Calls the client-side static method for this control class.
callClientFunction in file TCallbackClientScript.php, method TCallbackClientScript::callClientFunction()
Executes a client-side statement.
callMethod | in file TRpcService.php, method TRpcProtocol::callMethod()
callMethod in file TRpcService.php, method TXmlRpcProtocol::callMethod()
Handles the RPC request
callMethod in file TRpcService.php, method TJsonRpcProtocol::callMethod()
Handles the RPC request
canCauseValidation | in file TImageButton.php, method TImageButton::canCauseValidation()
canCauseValidation | in file TBulletedList.php, method TBulletedList::canCauseValidation()
canCauseValidation | in file TButton.php, method TButton::canCauseValidation()
canCauseValidation | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::canCauseValidation()
cancel in file TDbCommand.php, method TDbCommand::cancel()
Cancels the execution of the SQL statement.
canGetProperty in file TComponent.php, method TComponent::canGetProperty()
Determines whether a property can be read.
canGetProperty in file TAttributeCollection.php, method TAttributeCollection::canGetProperty()
Determines whether a property can be read.
canSetProperty in file TAttributeCollection.php, method TAttributeCollection::canSetProperty()
Determines whether a property can be set.
canSetProperty in file TComponent.php, method TComponent::canSetProperty()
Determines whether a property can be set.
canUpdateClientSide in file TBaseActiveControl.php, method TBaseActiveControl::canUpdateClientSide()
Returns true if callback response is allowed to update the browser contents.
canUpdateClientSide | in file TActiveListControlAdapter.php, method TActiveListControlAdapter::canUpdateClientSide()
canUpdateClientSide | in file TActiveListControlAdapter.php, method TActiveListItemCollection::canUpdateClientSide()
Cellular | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Cellular
Center | in file TStyle.php, class constant THorizontalAlign::Center
CGIFIX__PATH_INFO | in file THttpRequest.php, class constant THttpRequest::CGIFIX__PATH_INFO
CGIFIX__SCRIPT_NAME | in file THttpRequest.php, class constant THttpRequest::CGIFIX__SCRIPT_NAME
ChallengeFieldName | in file TReCaptcha.php, class constant TReCaptcha::ChallengeFieldName
check in file TCallbackClientScript.php, method TCallbackClientScript::check()
Client script to check or uncheck a checkbox or radio button.
checkIfNotInRender in file TClientScriptManager.php, method TClientScriptManager::checkIfNotInRender()
Checks whether page rendering has not begun yet
checkRequirements in file TCaptcha.php, method TCaptcha::checkRequirements()
Checks the requirements needed for generating CAPTCHA images.
Circle | in file TBulletedList.php, class constant TBulletStyle::Circle
CLASS_FILE_EXT in file PradoBase.php, class constant PradoBase::CLASS_FILE_EXT
File extension for Prado class files.
clear in file TPriorityMap.php, method TPriorityMap::clear()
Removes all items in the map. remove is called on all items.
clear in file TQueue.php, method TQueue::clear()
Removes all items in the queue.
clear in file TStack.php, method TStack::clear()
Removes all items in the stack.
Clear | in file TUserManager.php, class constant TUserManagerPasswordMode::Clear
clear in file TPriorityList.php, method TPriorityList::clear()
Removes all items in the priority list by calling removeAtIndexInPriority from the last item to the first.
clear in file TList.php, method TList::clear()
Removes all items in the list.
clear in file THttpRequest.php, method THttpRequest::clear()
Removes all items in the request.
clear in file THttpResponse.php, method THttpResponse::clear()
Clears any existing buffered content.
clear in file THttpSession.php, method THttpSession::clear()
Removes all session variables
clear in file TControl.php, method TControlCollection::clear()
Overrides the parent implementation by invoking TControl::clearNamingContainer
clear in file TMap.php, method TMap::clear()
Removes all items in the map.
clearCache in file TSqlMapConfig.php, method TSqlMapConfig::clearCache()
Deletes the configuration cache.
clearChildState in file TControl.php, method TControl::clearChildState()
Clears up the child state data.
clearControlState in file TControl.php, method TControl::clearControlState()
Clears a controlstate value.
clearGlobalState in file TApplication.php, method TApplication::clearGlobalState()
Clears a global value.
clearNamingContainer in file TControl.php, method TControl::clearNamingContainer()
Resets the control as a naming container.
clearRecordObject in file TScaffoldBase.php, method TScaffoldBase::clearRecordObject()
Unset the current record instance and table information.
clearSelection in file TListControl.php, method TListControl::clearSelection()
Clears all existing selections.
clearSelection in file TListControl.php, method IListControlAdapter::clearSelection()
Clears all existing selections on the client side.
clearSelection in file TActiveListControlAdapter.php, method TActiveListControlAdapter::clearSelection()
Clears all existing selections on the client side.
clearStyle in file interfaces.php, method IStyleable::clearStyle()
Removes all styles associated with the object
clearStyle in file TDataListItemRenderer.php, method TDataListItemRenderer::clearStyle()
Removes all style data.
clearStyle in file TWebControl.php, method TWebControl::clearStyle()
Removes all style data.
clearStyleField in file TStyle.php, method TStyle::clearStyleField()
Clears a single style field value;
clearViewState in file TControl.php, method TControl::clearViewState()
Clears a viewstate value.
click in file TCallbackClientScript.php, method TCallbackClientScript::click()
Client script to click on an element. This client-side function is unpredictable.
Clickable | in file TDatePicker.php, class constant TDatePickerMode::Clickable
client | in file TActiveControlAdapter.php, method TCallbackPageStateTracker::client()
CLIENT_ID_SEPARATOR in file TControl.php, class constant TControl::CLIENT_ID_SEPARATOR
separator char between IDs in a ClientID
close in file THttpSession.php, method THttpSession::close()
Ends the current session and store session data.
close in file TDbDataReader.php, method TDbDataReader::close()
Closes the reader.
close in file TDbConnection.php, method TDbConnection::close()
Closes the currently active DB connection.
CMD_CANCEL | in file TDataList.php, class constant TDataList::CMD_CANCEL
CMD_CANCEL | in file TWizard.php, class constant TWizard::CMD_CANCEL
CMD_CANCEL | in file TDataGrid.php, class constant TDataGrid::CMD_CANCEL
CMD_COMPLETE | in file TWizard.php, class constant TWizard::CMD_COMPLETE
CMD_DELETE | in file TDataList.php, class constant TDataList::CMD_DELETE
CMD_DELETE | in file TDataGrid.php, class constant TDataGrid::CMD_DELETE
CMD_EDIT | in file TDataGrid.php, class constant TDataGrid::CMD_EDIT
CMD_EDIT | in file TDataList.php, class constant TDataList::CMD_EDIT
CMD_MOVETO | in file TWizard.php, class constant TWizard::CMD_MOVETO
CMD_NEXT | in file TWizard.php, class constant TWizard::CMD_NEXT
CMD_NEXTVIEW | in file TMultiView.php, class constant TMultiView::CMD_NEXTVIEW
CMD_PAGE | in file TDataGrid.php, class constant TDataGrid::CMD_PAGE
CMD_PAGE in file TPager.php, class constant TPager::CMD_PAGE
Command name that TPager understands.
CMD_PAGE_FIRST | in file TDataGrid.php, class constant TDataGrid::CMD_PAGE_FIRST
CMD_PAGE_FIRST | in file TPager.php, class constant TPager::CMD_PAGE_FIRST
CMD_PAGE_LAST | in file TDataGrid.php, class constant TDataGrid::CMD_PAGE_LAST
CMD_PAGE_LAST | in file TPager.php, class constant TPager::CMD_PAGE_LAST
CMD_PAGE_NEXT | in file TPager.php, class constant TPager::CMD_PAGE_NEXT
CMD_PAGE_NEXT | in file TDataGrid.php, class constant TDataGrid::CMD_PAGE_NEXT
CMD_PAGE_PREV | in file TPager.php, class constant TPager::CMD_PAGE_PREV
CMD_PAGE_PREV | in file TDataGrid.php, class constant TDataGrid::CMD_PAGE_PREV
CMD_PREVIOUS in file TWizard.php, class constant TWizard::CMD_PREVIOUS
Navigation commands.
CMD_PREVIOUSVIEW | in file TMultiView.php, class constant TMultiView::CMD_PREVIOUSVIEW
CMD_SELECT in file TDataGrid.php, class constant TDataGrid::CMD_SELECT
Command name that TDataGrid understands.
CMD_SELECT in file TDataList.php, class constant TDataList::CMD_SELECT
Command name that TDataList understands. They are case-insensitive.
CMD_SORT | in file TDataGrid.php, class constant TDataGrid::CMD_SORT
CMD_SWITCHVIEWID | in file TMultiView.php, class constant TMultiView::CMD_SWITCHVIEWID
CMD_SWITCHVIEWINDEX | in file TMultiView.php, class constant TMultiView::CMD_SWITCHVIEWINDEX
CMD_UPDATE | in file TDataGrid.php, class constant TDataGrid::CMD_UPDATE
CMD_UPDATE | in file TDataList.php, class constant TDataList::CMD_UPDATE
collect | in file TMappedStatement.php, method TSqlMapObjectCollectionTree::collect()
collectChildren in file TMappedStatement.php, method TSqlMapObjectCollectionTree::collectChildren()
Visit all the child nodes and collect them by removing.
collectForeignObjects | in file TActiveRecordRelation.php, method TActiveRecordRelation::collectForeignObjects()
collectForeignObjects in file TActiveRecordHasMany.php, method TActiveRecordHasMany::collectForeignObjects()
Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
collectForeignObjects in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::collectForeignObjects()
Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects using association table.
collectForeignObjects in file TActiveRecordHasOne.php, method TActiveRecordHasOne::collectForeignObjects()
Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
collectForeignObjects in file TActiveRecordBelongsTo.php, method TActiveRecordBelongsTo::collectForeignObjects()
Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
collectLogs in file TLogRouter.php, method TLogRouter::collectLogs()
Collects log messages from a logger.
collectLogs in file TLogRouter.php, method TLogRoute::collectLogs()
Retrieves log messages from logger to log route specific destination.
Column | in file TTableHeaderCell.php, class constant TTableHeaderScope::Column
commit in file TDbTransaction.php, method TDbTransaction::commit()
Commits a transaction.
Company | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Company
Complete | in file TWizard.php, class constant TWizardStepType::Complete
completeRequest in file TApplication.php, method TApplication::completeRequest()
Completes current request processing.
computeHMAC in file TSecurityManager.php, method TSecurityManager::computeHMAC()
Computes the HMAC for the data with getValidationKey.
CONFIGCACHE_FILE in file TApplication.php, class constant TApplication::CONFIGCACHE_FILE
Config cache file
configure in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::configure()
Configure an XML mapping.
configure in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::configure()
Configure the TSqlMapManager using the given xml file.
configureComponent in file TTemplateManager.php, method TTemplate::configureComponent()
Configures a property of a non-control component.
configureControl in file TTemplateManager.php, method TTemplate::configureControl()
Configures a property/event of a control.
configureEvent in file TTemplateManager.php, method TTemplate::configureEvent()
Configures an event for a control.
configureProperty in file TTemplateManager.php, method TTemplate::configureProperty()
Configures a simple property for a component.
configureSubProperty in file TTemplateManager.php, method TTemplate::configureSubProperty()
Configures a subproperty for a component.
configureXml in file TSqlMapManager.php, method TSqlMapManager::configureXml()
Loads and parses the SqlMap configuration file.
CONFIG_ASSET | in file TTemplateManager.php, class constant TTemplate::CONFIG_ASSET
CONFIG_CACHE_PREFIX in file TPageService.php, class constant TPageService::CONFIG_CACHE_PREFIX
Prefix of ID used for storing parsed configuration in cache
CONFIG_DATABIND in file TTemplateManager.php, class constant TTemplate::CONFIG_DATABIND
Different configurations of component property/event/attribute
CONFIG_EXPRESSION | in file TTemplateManager.php, class constant TTemplate::CONFIG_EXPRESSION
CONFIG_FILE_EXT in file TSqlMapConfig.php, class constant TSqlMapConfig::CONFIG_FILE_EXT
File extension of external configuration file
CONFIG_FILE_EXT_PHP in file TApplication.php, class constant TApplication::CONFIG_FILE_EXT_PHP
File extension for external config files
CONFIG_FILE_EXT_XML in file TApplication.php, class constant TApplication::CONFIG_FILE_EXT_XML
File extension for external config files
CONFIG_FILE_PHP in file TApplication.php, class constant TApplication::CONFIG_FILE_PHP
Application configuration file name
CONFIG_FILE_PHP in file TPageService.php, class constant TPageService::CONFIG_FILE_PHP
Configuration file name
CONFIG_FILE_XML in file TPageService.php, class constant TPageService::CONFIG_FILE_XML
Configuration file name
CONFIG_FILE_XML in file TApplication.php, class constant TApplication::CONFIG_FILE_XML
Application configuration file name
CONFIG_LOCALIZATION | in file TTemplateManager.php, class constant TTemplate::CONFIG_LOCALIZATION
CONFIG_PARAMETER | in file TTemplateManager.php, class constant TTemplate::CONFIG_PARAMETER
CONFIG_TEMPLATE | in file TTemplateManager.php, class constant TTemplate::CONFIG_TEMPLATE
CONFIG_TYPE_PHP in file TApplication.php, class constant TApplication::CONFIG_TYPE_PHP
Configuration file type, application.php and config.php
CONFIG_TYPE_XML in file TApplication.php, class constant TApplication::CONFIG_TYPE_XML
Configuration file type, application.xml and config.xml
constructUrl in file TUrlManager.php, method TUrlManager::constructUrl()
Constructs a URL that can be recognized by PRADO.
constructUrl in file THttpRequest.php, method THttpRequest::constructUrl()
Constructs a URL that can be recognized by PRADO.
constructUrl in file TPageService.php, method TPageService::constructUrl()
Constructs a URL with specified page path and GET parameters.
constructUrl in file TSoapService.php, method TSoapService::constructUrl()
Constructs a URL with specified page path and GET parameters.
constructUrl in file TUrlMapping.php, method TUrlMapping::constructUrl()
Constructs a URL that can be recognized by PRADO.
constructUrl in file TUrlMapping.php, method TUrlMappingPattern::constructUrl()
Constructs a URL using this pattern.
contains | in file TQueue.php, method TQueue::contains()
contains | in file TStack.php, method TStack::contains()
contains | in file TList.php, method TList::contains()
contains | in file THttpRequest.php, method THttpRequest::contains()
contains | in file TPriorityMap.php, method TPriorityMap::contains()
contains | in file THttpSession.php, method THttpSession::contains()
contains | in file TPriorityList.php, method TPriorityList::contains()
contains in file TAttributeCollection.php, method TAttributeCollection::contains()
Returns whether the specified is in the map.
contains | in file TMap.php, method TMap::contains()
convertToType in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandlerRegistry::convertToType()
Converts the value to given type using PHP's settype() function.
convertUniqueIdToClientId in file TControl.php, method TControl::convertUniqueIdToClientId()
Converts a unique ID to a client ID.
copyBaseAttributes in file TWebControl.php, method TWebControl::copyBaseAttributes()
Copies basic control attributes from another control.
copyCustomPlugins | in file THtmlArea.php, method THtmlArea::copyCustomPlugins()
copyDirectory in file TAssetManager.php, method TAssetManager::copyDirectory()
Copies a directory recursively as another.
copyFile in file TAssetManager.php, method TAssetManager::copyFile()
Copies a file to a directory.
copyFrom in file TList.php, method TList::copyFrom()
Copies iterable data into the list.
copyFrom in file TMap.php, method TMap::copyFrom()
Copies iterable data into the map.
copyFrom in file TActiveRecord.php, method TActiveRecord::copyFrom()
Copies data from an array or another object.
copyFrom in file TPriorityMap.php, method TPriorityMap::copyFrom()
Copies iterable data into the map.
copyFrom in file TPriorityList.php, method TPriorityList::copyFrom()
Copies iterable data into the priority list.
copyFrom in file TQueue.php, method TQueue::copyFrom()
Copies iterable data into the queue.
copyFrom in file TScaffoldBase.php, method TScaffoldBase::copyFrom()
Copy the view details from another scaffold view instance.
copyFrom in file TPanelStyle.php, method TPanelStyle::copyFrom()
Copies the fields in a new style to this style.
copyFrom in file TStyle.php, method TTableStyle::copyFrom()
Copies the fields in a new style to this style.
copyFrom in file TDataGridPagerStyle.php, method TDataGridPagerStyle::copyFrom()
Copies the fields in a new style to this style.
copyFrom in file TStyle.php, method TStyle::copyFrom()
Copies the fields in a new style to this style.
copyFrom in file TFont.php, method TFont::copyFrom()
Copies the fields in a new font to this font.
copyFrom in file TStack.php, method TStack::copyFrom()
Copies iterable data into the stack.
copyFrom in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::copyFrom()
Copies the fields in a new style to this style.
copyFrom in file TStyle.php, method TTableItemStyle::copyFrom()
Copies the fields in a new style to this style.
count in file TStack.php, method TStack::count()
Returns the number of items in the stack.
count in file TMap.php, method TMap::count()
Returns the number of items in the map.
count in file TQueue.php, method TQueue::count()
Returns the number of items in the queue.
count in file TTableGateway.php, method TTableGateway::count()
Find the number of records.
count | in file TDataGatewayCommand.php, method TDataGatewayCommand::count()
count in file TPriorityMap.php, method TPriorityMap::count()
Returns the number of items in the map.
count in file THttpSession.php, method THttpSession::count()
Returns the number of items in the session.
count in file TList.php, method TList::count()
Returns the number of items in the list.
count in file TPagedDataSource.php, method TPagedDataSource::count()
Returns the number of items in the current page.
count in file TDummyDataSource.php, method TDummyDataSource::count()
Returns the number of (virtual) items in the data source.
count in file THttpRequest.php, method THttpRequest::count()
Returns the number of items in the request.
count in file TPriorityList.php, method TPriorityList::count()
Returns the number of items in the list.
count in file TActiveRecord.php, method TActiveRecord::count()
Find the number of records.
countRecords in file TActiveRecordGateway.php, method TActiveRecordGateway::countRecords()
Returns the number of records that match the given criteria.
create | in file TPreparedCommand.php, method TPreparedCommand::create()
create in file TRpcClient.php, method TJsonRpcClient::create()
Creates an instance of TJsonRpcClient
create in file TRpcClient.php, method TRpcClient::create()
Creates an instance of the requested RPC client type
create in file TRpcClient.php, method TXmlRpcClient::create()
Creates an instance of TXmlRpcClient
createApiProvider in file TRpcService.php, method TRpcService::createApiProvider()
Creates the API provider instance for the current request
createAutoColumns in file TDataGrid.php, method TDataGrid::createAutoColumns()
Automatically generates datagrid columns based on datasource schema
createBooleanControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createBooleanControl()
createButton | in file TActiveDataGrid.php, method TActiveEditCommandColumn::createButton()
createButton in file TEditCommandColumn.php, method TEditCommandColumn::createButton()
Creates a button and initializes its properties.
createChildControls in file TWizard.php, method TWizard::createChildControls()
Creates child controls within the wizard
createChildControls in file TControl.php, method TControl::createChildControls()
Creates child controls.
createChildControls in file TWizard.php, method TTemplatedWizardStep::createChildControls()
Creates child controls.
createChildControls in file TConditional.php, method TConditional::createChildControls()
Creates child controls.
createChildControls in file TTemplateControl.php, method TTemplateControl::createChildControls()
Creates child controls.
createChildControls in file TDropContainer.php, method TDropContainer::createChildControls()
Creates child control Override parent implementation to create a container which will contain all child controls. This container will be a TActivePanel, in order to allow user to update its content on callback.
createChildControls in file TControlAdapter.php, method TControlAdapter::createChildControls()
Creates child controls for the attached control.
createChildControls | in file TActiveFileUpload.php, method TActiveFileUpload::createChildControls()
createChildControls in file TTemplateControlInheritable.php, method TTemplateControlInheritable::createChildControls()
Creates child controls.
createClientScript | in file TSlider.php, method TSlider::createClientScript()
createClientScript | in file TDatePicker.php, method TDatePicker::createClientScript()
createClientScript | in file TValidationSummary.php, method TValidationSummary::createClientScript()
createClientSide | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::createClientSide()
createClientSide | in file TBaseValidator.php, method TBaseValidator::createClientSide()
createClientSide | in file TColorPicker.php, method TColorPicker::createClientSide()
createClientSide | in file TCallbackOptions.php, method TCallbackOptions::createClientSide()
createCommand in file TDbConnection.php, method TDbConnection::createCommand()
Creates a command for execution.
createCommand | in file TCachingStatement.php, method TCachingStatement::createCommand()
createCommand | in file TDbCommandBuilder.php, method TDbCommandBuilder::createCommand()
createCommand | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::createCommand()
createCommandBuilder | in file TSqliteTableInfo.php, method TSqliteTableInfo::createCommandBuilder()
createCommandBuilder | in file TPgsqlTableInfo.php, method TPgsqlTableInfo::createCommandBuilder()
createCommandBuilder | in file TOracleTableInfo.php, method TOracleTableInfo::createCommandBuilder()
createCommandBuilder | in file TMssqlTableInfo.php, method TMssqlTableInfo::createCommandBuilder()
createCommandBuilder in file TDbMetaData.php, method TDbMetaData::createCommandBuilder()
Creates a command builder for a given table name.
createCommandBuilder | in file TMysqlTableInfo.php, method TMysqlTableInfo::createCommandBuilder()
createCommandBuilder | in file TDbTableInfo.php, method TDbTableInfo::createCommandBuilder()
createComponent in file PradoBase.php, method PradoBase::createComponent()
Creates a component with the specified type.
createControl | in file TMysqlScaffoldInput.php, method TMysqlScaffoldInput::createControl()
createControl | in file TScaffoldInputBase.php, method TScaffoldInputBase::createControl()
createControl | in file TIbmScaffoldInput.php, method TIbmScaffoldInput::createControl()
createControl | in file TSqliteScaffoldInput.php, method TSqliteScaffoldInput::createControl()
createControl | in file TMssqlScaffoldInput.php, method TMssqlScaffoldInput::createControl()
createControl | in file TPgsqlScaffoldInput.php, method TPgsqlScaffoldInput::createControl()
createControlCollection in file TAccordion.php, method TAccordion::createControlCollection()
Creates a control collection object that is to be used to hold child controls
createControlCollection in file TMultiView.php, method TMultiView::createControlCollection()
Creates a control collection object that is to be used to hold child controls
createControlCollection in file TTableRow.php, method TTableRow::createControlCollection()
Creates a control collection object that is to be used to hold child controls
createControlCollection in file TTable.php, method TTable::createControlCollection()
Creates a control collection object that is to be used to hold child controls
createControlCollection in file TTabPanel.php, method TTabPanel::createControlCollection()
Creates a control collection object that is to be used to hold child controls
createControlCollection in file TControl.php, method TControl::createControlCollection()
Creates a control collection object that is to be used to hold child controls
createControlLabel | in file TScaffoldInputBase.php, method TScaffoldInputBase::createControlLabel()
createCountCommand in file TDbCommandBuilder.php, method TDbCommandBuilder::createCountCommand()
Creates a count(*) command for the table described in setTableInfo.
createCriteriaFromString | in file TDataGatewayCommand.php, method TDataGatewayCommand::createCriteriaFromString()
createDateControl | in file TSqliteScaffoldInput.php, method TSqliteScaffoldInput::createDateControl()
createDateControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createDateControl()
createDateTimeControl | in file TSqliteScaffoldInput.php, method TSqliteScaffoldInput::createDateTimeControl()
createDateTimeControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createDateTimeControl()
createDbConnection in file TDbCache.php, method TDbCache::createDbConnection()
Creates the DB connection.
createDbConnection in file TLogRouter.php, method TDbLogRoute::createDbConnection()
Creates the DB connection.
createDbConnection in file TDbUserManager.php, method TDbUserManager::createDbConnection()
Creates the DB connection.
createDbTable in file TLogRouter.php, method TDbLogRoute::createDbTable()
Creates the DB table for storing log messages.
createDefaultControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createDefaultControl()
createDeleteCommand in file TDbCommandBuilder.php, method TDbCommandBuilder::createDeleteCommand()
Creates a delete command for the table described in setTableInfo.
createdOnTemplate in file TContent.php, method TContent::createdOnTemplate()
This method is invoked after the control is instantiated on a template.
createdOnTemplate in file TContentPlaceHolder.php, method TContentPlaceHolder::createdOnTemplate()
This method is invoked after the control is instantiated on a template.
createdOnTemplate in file TComponent.php, method TComponent::createdOnTemplate()
This method is invoked after the component is instantiated by a template.
createEditRenderer in file TScaffoldEditView.php, method TScaffoldEditView::createEditRenderer()
Instantiate the external edit renderer.
createEmptyContent in file TRepeater.php, method TRepeater::createEmptyContent()
Creates empty repeater content.
createEmptyContent in file TDataList.php, method TDataList::createEmptyContent()
Creates empty datalist content.
createEnumControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createEnumControl()
createErrorResponse | in file TRpcService.php, method TRpcProtocol::createErrorResponse()
createErrorResponse in file TRpcService.php, method TJsonRpcProtocol::createErrorResponse()
Turns the given exception into an JSON RPC fault
createErrorResponse in file TRpcService.php, method TXmlRpcProtocol::createErrorResponse()
Turns the given exception into an XML RPC fault
createFindCommand in file TDbCommandBuilder.php, method TDbCommandBuilder::createFindCommand()
Appends the $where condition to the string "SELECT * FROM tableName WHERE ".
createFinishNavigation in file TWizard.php, method TWizard::createFinishNavigation()
Creates finish navigation panel.
createFkObject | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::createFkObject()
createFloatControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createFloatControl()
createHeader in file TWizard.php, method TWizard::createHeader()
Creates the wizard header.
createHtmlWriter in file THttpResponse.php, method THttpResponse::createHtmlWriter()
Creates a new instance of HTML writer.
createImage in file THyperLink.php, method THyperLink::createImage()
Gets the TImage for rendering the ImageUrl property. This is not for creating dynamic images.
createInputBuilder | in file TScaffoldInputBase.php, method TScaffoldInputBase::createInputBuilder()
createInsertCommand in file TDbCommandBuilder.php, method TDbCommandBuilder::createInsertCommand()
Creates an insert command for the table described in setTableInfo for the given data.
createInsertStatement in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::createInsertStatement()
Create new insert statement from xml node.
createInstanceOf in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandlerRegistry::createInstanceOf()
Creates a new instance of a particular class (for PHP primative types, their corresponding default value for given type is used).
createInstanceOf in file TSqlMapStatement.php, method TSqlMapStatement::createInstanceOf()
Create a new instance of a given type.
createInstanceOfListClass | in file TSqlMapStatement.php, method TSqlMapStatement::createInstanceOfListClass()
createInstanceOfResult in file TResultMap.php, method TResultMap::createInstanceOfResult()
Create a new instance of the class of this result map.
createInstanceOfResultClass in file TSqlMapStatement.php, method TSqlMapStatement::createInstanceOfResultClass()
Create a new instance of result class.
createIntegerControl | in file TMysqlScaffoldInput.php, method TMysqlScaffoldInput::createIntegerControl()
createIntegerControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createIntegerControl()
createItem in file TDataGrid.php, method TDataGrid::createItem()
Creates a datagrid item instance based on the item type and index.
createItem in file TRepeater.php, method TRepeater::createItem()
Creates a repeater item instance based on the item type and index.
createItem in file TDataList.php, method TDataList::createItem()
Creates a datalist item instance based on the item type and index.
createJsonResponse in file TJsonService.php, method TJsonService::createJsonResponse()
Renders content provided by TJsonResponse::getJsonContent() as javascript in JSON format.
createListItem in file TListItemCollection.php, method TListItemCollection::createListItem()
Creates a list item object.
createListItemCollection in file TActiveListBox.php, method TActiveListBox::createListItemCollection()
Creates a collection object to hold list items. A specialized TActiveListItemCollection is created to allow the drop down list options to be added.
createListItemCollection in file TActiveDropDownList.php, method TActiveDropDownList::createListItemCollection()
Creates a collection object to hold list items. A specialized TActiveListItemCollection is created to allow the drop down list options to be added.
createListItemCollection in file TListControl.php, method TListControl::createListItemCollection()
Creates a collection object to hold list items.
createMultiLineControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createMultiLineControl()
createNavigation in file TWizard.php, method TWizard::createNavigation()
Creates navigation panel.
createNavigationButton in file TWizard.php, method TWizardNavigationTemplate::createNavigationButton()
Creates a navigation button.
createNewHtmlWriter in file THttpResponseAdapter.php, method THttpResponseAdapter::createNewHtmlWriter()
This method is invoked when a new HtmlWriter needs to be created.
createNewHtmlWriter in file THttpResponse.php, method THttpResponse::createNewHtmlWriter()
Create a new html writer instance.
createNewHtmlWriter in file TCallbackResponseAdapter.php, method TCallbackResponseAdapter::createNewHtmlWriter()
Returns a new instance of THtmlWriter.
createNewInstance in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::createNewInstance()
Casts the string representation of a value into a type recognized by
createNewListItem | in file TListItemCollection.php, method TListItemCollection::createNewListItem()
createNewTableInfo | in file TMssqlMetaData.php, method TMssqlMetaData::createNewTableInfo()
createNewTableInfo | in file TMysqlMetaData.php, method TMysqlMetaData::createNewTableInfo()
createNewTableInfo | in file TOracleMetaData.php, method TOracleMetaData::createNewTableInfo()
createNewTableInfo | in file TPgsqlMetaData.php, method TPgsqlMetaData::createNewTableInfo()
createObjectFromNode in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfigBuilder::createObjectFromNode()
Create an instance of an object give by the attribute named 'class' in the node and set the properties on the object given by attribute names and values.
createPage in file TPageService.php, method TPageService::createPage()
Creates a page instance based on requested page path.
createPagedDataSource | in file TDataBoundControl.php, method TDataBoundControl::createPagedDataSource()
createPagerButton in file TActiveDataGrid.php, method TActiveDataGrid::createPagerButton()
Creates a pager button.
createPagerButton in file TPager.php, method TPager::createPagerButton()
Creates a pager button.
createPagerButton in file TActivePager.php, method TActivePager::createPagerButton()
Creates a pager button.
createPagerButton in file TDataGrid.php, method TDataGrid::createPagerButton()
Creates a pager button.
createParameterMap in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::createParameterMap()
Create a new parameter map from xml node.
createParametersForTextCommand | in file TPreparedStatementFactory.php, method TPreparedStatementFactory::createParametersForTextCommand()
createRangeValidator | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createRangeValidator()
createRecord in file TActiveRecord.php, method TActiveRecord::createRecord()
Create an AR instance specified by the AR class name and initial data.
createRecordGateway | in file TActiveRecordManager.php, method TActiveRecordManager::createRecordGateway()
createRelationContext in file TActiveRecord.php, method TActiveRecord::createRelationContext()
Gets a static copy of the relationship context for given property (a key in $RELATIONS), returns null if invalid relationship. Keeps a null reference to all invalid relations called.
createRepeatedControl in file TActiveRadioButtonList.php, method TActiveRadioButtonList::createRepeatedControl()
Creates a control used for repetition (used as a template).
createRepeatedControl in file TActiveCheckBoxList.php, method TActiveCheckBoxList::createRepeatedControl()
Creates a control used for repetition (used as a template).
createRepeatedControl in file TCheckBoxList.php, method TCheckBoxList::createRepeatedControl()
Creates a control used for repetition (used as a template).
createRepeatedControl in file TRadioButtonList.php, method TRadioButtonList::createRepeatedControl()
Creates a control used for repetition (used as a template).
createRepeater | in file TAutoComplete.php, method TAutoComplete::createRepeater()
createRepeaterEditItem in file TScaffoldEditView.php, method TScaffoldEditView::createRepeaterEditItem()
Initialize the default editor using the scaffold input builder.
createRequiredValidator | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createRequiredValidator()
createResponseHeaders in file TRpcService.php, method TXmlRpcProtocol::createResponseHeaders()
Sets the correct response headers
createResponseHeaders | in file TRpcService.php, method TRpcProtocol::createResponseHeaders()
createResponseHeaders in file TRpcService.php, method TJsonRpcProtocol::createResponseHeaders()
Sets the correct response headers
createResultMap in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::createResultMap()
Create a new result map and its associated result properties, disciminiator and sub maps.
createResultPanel | in file TAutoComplete.php, method TAutoComplete::createResultPanel()
createScaffoldInput | in file TScaffoldInputBase.php, method TScaffoldInputBase::createScaffoldInput()
createSearchCondition | in file TScaffoldSearch.php, method TScaffoldSearch::createSearchCondition()
createServer in file TSoapService.php, method TSoapServer::createServer()
Creates the SoapServer instance.
createServer in file TSoapService.php, method TSoapService::createServer()
Creates the requested SOAP server.
createSetControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createSetControl()
createSideBar in file TWizard.php, method TWizard::createSideBar()
Creates the wizard side bar
createSqlMapGateway | in file TSqlMapConfig.php, method TSqlMapConfig::createSqlMapGateway()
createSqlMapGateway in file TSqlMapManager.php, method TSqlMapManager::createSqlMapGateway()
Configures the current TSqlMapManager using the given xml configuration file defined in ConfigFile.
createStartNavigation in file TWizard.php, method TWizard::createStartNavigation()
Creates start navigation panel.
createStepContent in file TWizard.php, method TWizard::createStepContent()
Creates wizard step content.
createStepNavigation in file TWizard.php, method TWizard::createStepNavigation()
Creates step navigation panel.
createStreamContext in file TRpcClient.php, method TRpcClient::createStreamContext()
Creates a stream context resource
createStyle in file TWebControl.php, method TWebControl::createStyle()
Creates a style object to be used by the control.
createStyle in file TBaseDataList.php, method TBaseDataList::createStyle()
Creates a style object for the control.
createStyle in file TDataGrid.php, method TDataGrid::createStyle()
Creates a style object for the control.
createStyle in file TDataList.php, method TDataListItem::createStyle()
Creates a style object for the control.
createStyle in file TDataListItemRenderer.php, method TDataListItemRenderer::createStyle()
Creates a style object to be used by the control.
createStyle in file TTableCell.php, method TTableCell::createStyle()
Creates a style object for the control.
createStyle in file TTableRow.php, method TTableRow::createStyle()
Creates a style object for the control.
createStyle in file TTable.php, method TTable::createStyle()
Creates a style object for the control.
createStyle in file TCheckBoxList.php, method TCheckBoxList::createStyle()
Creates a style object for the control.
createStyle in file TPanel.php, method TPanel::createStyle()
Creates a style object to be used by the control.
createTableInfo in file TPgsqlMetaData.php, method TPgsqlMetaData::createTableInfo()
Get the column definitions for given table.
createTableInfo in file TOracleMetaData.php, method TOracleMetaData::createTableInfo()
Get the column definitions for given table.
createTableInfo in file TMssqlMetaData.php, method TMssqlMetaData::createTableInfo()
Get the column definitions for given table.
createTableInfo in file TMysqlMetaData.php, method TMysqlMetaData::createTableInfo()
Get the column definitions for given table.
createTableInfo in file TDbMetaData.php, method TDbMetaData::createTableInfo()
This method should be implemented by decendent classes.
createTableInfo in file TSqliteMetaData.php, method TSqliteMetaData::createTableInfo()
Get the column definitions for given table.
createTimeControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createTimeControl()
createTypeHandler in file TResultProperty.php, method TResultProperty::createTypeHandler()
Create type handler from Type or TypeHandler.
createTypeHandler in file TParameterMap.php, method TParameterMap::createTypeHandler()
Create type handler from Type or TypeHandler.
createTypeValidator | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createTypeValidator()
createUpdateCommand in file TDbCommandBuilder.php, method TDbCommandBuilder::createUpdateCommand()
Creates an update command for the table described in setTableInfo for the given data.
createUser in file TDbUserManager.php, method TDbUser::createUser()
Creates a new user instance given the username.
createUserFromCookie in file TDbUserManager.php, method TDbUser::createUserFromCookie()
Creates a new user instance given the cookie containing auth data.
createYearControl | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::createYearControl()
CS_CHILD_INITIALIZED | in file TControl.php, class constant TControl::CS_CHILD_INITIALIZED
CS_CONSTRUCTED in file TControl.php, class constant TControl::CS_CONSTRUCTED
the stage of lifecycles that the control is currently at
CS_INITIALIZED | in file TControl.php, class constant TControl::CS_INITIALIZED
CS_LOADED | in file TControl.php, class constant TControl::CS_LOADED
CS_PRERENDERED | in file TControl.php, class constant TControl::CS_PRERENDERED
CS_STATE_LOADED | in file TControl.php, class constant TControl::CS_STATE_LOADED
current in file TPagedDataSource.php, method TPagedMapIterator::current()
Returns the current array item.
current in file TDummyDataSource.php, method TDummyDataSourceIterator::current()
Returns the current array item.
current in file TDbDataReader.php, method TDbDataReader::current()
Returns the current row.
current | in file TComponent.php, method TEnumerable::current()
current in file THttpSession.php, method TSessionIterator::current()
Returns the current array element.
current in file TList.php, method TListIterator::current()
Returns the current array item.
current in file TQueue.php, method TQueueIterator::current()
Returns the current array item.
current in file TStack.php, method TStackIterator::current()
Returns the current array item.
current in file TPagedDataSource.php, method TPagedListIterator::current()
Returns the current array item.
current in file TMap.php, method TMapIterator::current()
Returns the current array element.
CustomImage | in file TBulletedList.php, class constant TBulletStyle::CustomImage
top
d
$delimiterIdentifier | in file TDbMetaData.php, variable TDbMetaData::$delimiterIdentifier
dataBind in file TAutoComplete.php, method TAutoComplete::dataBind()
Overrides parent implementation. Callback renderSuggestions() when page's IsCallback property is true.
dataBind in file TDataBoundControl.php, method TDataBoundControl::dataBind()
Performs databinding.
dataBind in file TControl.php, method TCompositeLiteral::dataBind()
Performs databindings.
dataBind in file interfaces.php, method IBindable::dataBind()
Performs databinding.
dataBind in file TControl.php, method TControl::dataBind()
Performs the databinding for this control.
dataBindChildren in file TControl.php, method TControl::dataBindChildren()
Databinding child controls.
dataBindColumn in file TCheckBoxColumn.php, method TCheckBoxColumn::dataBindColumn()
Databinds a cell in the column.
dataBindColumn in file TButtonColumn.php, method TButtonColumn::dataBindColumn()
Databinds a cell in the column.
dataBindColumn in file TLiteralColumn.php, method TLiteralColumn::dataBindColumn()
Databinds a cell in the column.
dataBindColumn in file TDropDownListColumn.php, method TDropDownListColumn::dataBindColumn()
Databinds a cell in the column.
dataBindColumn in file THyperLinkColumn.php, method THyperLinkColumn::dataBindColumn()
Databinds a cell in the column.
dataBindColumn in file TBoundColumn.php, method TBoundColumn::dataBindColumn()
Databinds a cell in the column.
dataBindColumn in file TTemplateColumn.php, method TTemplateColumn::dataBindColumn()
Databinds a cell in the column.
dataBindProperties in file TControl.php, method TControl::dataBindProperties()
Databinding properties of the control.
dataListItemCommand in file TWizard.php, method TWizard::dataListItemCommand()
Event handler for sidebar datalist's OnItemCommand event.
dataListItemDataBound in file TWizard.php, method TWizard::dataListItemDataBound()
Event handler for sidebar datalist's OnItemDataBound event.
dataSourceViewChanged | in file TDataBoundControl.php, method TDataBoundControl::dataSourceViewChanged()
Date | in file TBaseValidator.php, class constant TValidationDataType::Date
DB_FILE_EXT in file TSqliteCache.php, class constant TSqliteCache::DB_FILE_EXT
extension of the db file name
DEBUG in file TLogger.php, class constant TLogger::DEBUG
Log levels.
Debug | in file TApplication.php, class constant TApplicationMode::Debug
decode in file TRpcService.php, method TJsonRpcProtocol::decode()
Decodes JSON encoded data into PHP data
decode in file TRpcService.php, method TXmlRpcProtocol::decode()
Decodes XML encoded data into PHP data
decode | in file TRpcService.php, method TRpcProtocol::decode()
decodeUTF8 | in file TPage.php, method TPage::decodeUTF8()
decrypt in file TSecurityManager.php, method TSecurityManager::decrypt()
Decrypts data with getEncryptionKey.
DEFAULT_BASEPATH in file TThemeManager.php, class constant TThemeManager::DEFAULT_BASEPATH
default themes base path
DEFAULT_BASEPATH in file TAssetManager.php, class constant TAssetManager::DEFAULT_BASEPATH
Default web accessible base path for storing private files
DEFAULT_BASEPATH in file TPageService.php, class constant TPageService::DEFAULT_BASEPATH
Default base path
DEFAULT_CHARSET | in file THttpResponse.php, class constant THttpResponse::DEFAULT_CHARSET
DEFAULT_COLUMNS in file TTextBox.php, class constant TTextBox::DEFAULT_COLUMNS
Default number of columns (for MultiLine text box)
DEFAULT_CONTENTTYPE | in file THttpResponse.php, class constant THttpResponse::DEFAULT_CONTENTTYPE
DEFAULT_GATEWAY_CLASS | in file TActiveRecordManager.php, class constant TActiveRecordManager::DEFAULT_GATEWAY_CLASS
DEFAULT_GATEWAY_CLASS | in file TActiveRecordConfig.php, class constant TActiveRecordConfig::DEFAULT_GATEWAY_CLASS
DEFAULT_ID | in file TScaffoldInputBase.php, class constant TScaffoldInputBase::DEFAULT_ID
DEFAULT_LABEL in file TLogRouter.php, class constant TFirePhpLogRoute::DEFAULT_LABEL
Default group label
DEFAULT_MANAGER_CLASS | in file TActiveRecordConfig.php, class constant TActiveRecordConfig::DEFAULT_MANAGER_CLASS
DEFAULT_ROWS in file TTextBox.php, class constant TTextBox::DEFAULT_ROWS
Default number of rows (for MultiLine text box)
DEFAULT_SOAP_SERVER | in file TSoapService.php, class constant TSoapService::DEFAULT_SOAP_SERVER
DEFAULT_SUBJECT in file TLogRouter.php, class constant TEmailLogRoute::DEFAULT_SUBJECT
Default email subject.
DEFAULT_THEMECLASS in file TThemeManager.php, class constant TThemeManager::DEFAULT_THEMECLASS
default theme class
DEFAULT_TRANSACTION_CLASS | in file TDbConnection.php, class constant TDbConnection::DEFAULT_TRANSACTION_CLASS
delete in file TSqlMapGateway.php, method TSqlMapGateway::delete()
Executes a Sql DELETE statement. Delete returns the number of rows effected.
delete | in file TSqlMapCache.php, method TSqlMapCache::delete()
delete | in file TSqlMapCache.php, method TSqlMapApplicationCache::delete()
delete | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::delete()
delete in file TActiveRecord.php, method TActiveRecord::delete()
Deletes the current record from the database. Once deleted, this object can not be saved again in the same instance.
delete in file TDataSourceView.php, method TDataSourceView::delete()
Deletes DB row(s) with the specified keys.
delete in file TDataGatewayCommand.php, method TDataGatewayCommand::delete()
Executes a delete command.
delete in file TCache.php, method TCache::delete()
Deletes a value with the specified key from cache
delete in file interfaces.php, method ICache::delete()
Deletes a value with the specified key from cache
delete in file TActiveRecordGateway.php, method TActiveRecordGateway::delete()
Delete the record.
deleteAll in file TActiveRecord.php, method TActiveRecord::deleteAll()
Delete multiple records using a criteria.
deleteAll in file TTableGateway.php, method TTableGateway::deleteAll()
Delete records from the table with condition given by $where and binding values specified by $parameter argument.
deleteAllByPks in file TTableGateway.php, method TTableGateway::deleteAllByPks()
Alias for deleteByPk()
deleteAllByPks in file TActiveRecord.php, method TActiveRecord::deleteAllByPks()
Alias for deleteByPk()
deleteByPk | in file TDataGatewayCommand.php, method TDataGatewayCommand::deleteByPk()
deleteByPk in file TActiveRecord.php, method TActiveRecord::deleteByPk()
Delete records by primary key. Usage:
deleteByPk in file TTableGateway.php, method TTableGateway::deleteByPk()
Delete records by primary key. Usage:
deleteLogs in file TLogger.php, method TLogger::deleteLogs()
Deletes log messages from the queue.
deleteRecord in file TScaffoldListView.php, method TScaffoldListView::deleteRecord()
Deletes an Active Record.
deleteRecordsByCriteria in file TActiveRecordGateway.php, method TActiveRecordGateway::deleteRecordsByCriteria()
Delete multiple records by criteria.
deleteRecordsByPk in file TActiveRecordGateway.php, method TActiveRecordGateway::deleteRecordsByPk()
Delete multiple records using primary keys.
deleteValue in file TXCache.php, method TXCache::deleteValue()
Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
deleteValue in file TAPCCache.php, method TAPCCache::deleteValue()
Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
deleteValue in file TSqliteCache.php, method TSqliteCache::deleteValue()
Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
deleteValue in file TCache.php, method TCache::deleteValue()
Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.
deleteValue in file TDbCache.php, method TDbCache::deleteValue()
Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
deleteValue in file TMemCache.php, method TMemCache::deleteValue()
Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
Department | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Department
deployTarFile in file TAssetManager.php, method TAssetManager::deployTarFile()
Extracts the tar file to the destination directory.
dequeue in file TQueue.php, method TQueue::dequeue()
Removes and returns the object at the beginning of the queue.
destroy in file THttpSession.php, method THttpSession::destroy()
Destroys all data registered to a session.
detachEventHandler in file TComponent.php, method TComponent::detachEventHandler()
Detaches an existing event handler.
determineDataSource | in file TDataBoundControl.php, method TDataBoundControl::determineDataSource()
determinePropertyType in file TComponent.php, method TComponentReflection::determinePropertyType()
Determines the property type.
determineRequestedFeedPath | in file TFeedService.php, method TFeedService::determineRequestedFeedPath()
determineRequestedPagePath in file TPageService.php, method TPageService::determineRequestedPagePath()
Determines the requested page path.
digitCheck in file TDateTimeStamp.php, method TDateTimeStamp::digitCheck()
Fix 2-digit years. Works for any century.
Disable in file TUrlMapping.php, class constant TUrlMappingPatternSecureConnection::Disable
Force use unsecured connection
Disabled | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Disabled
DisableIfSecure in file TUrlMapping.php, class constant TUrlMappingPatternSecureConnection::DisableIfSecure
Force use unsecured connection, if in secured mode
Disc | in file TBulletedList.php, class constant TBulletStyle::Disc
displayException in file TErrorHandler.php, method TErrorHandler::displayException()
Displays exception information.
displayException in file TActivePageAdapter.php, method TCallbackErrorHandler::displayException()
Displays the exceptions to the client-side TJavascriptLogger.
DisplayName | in file TTextBox.php, class constant TTextBoxAutoCompleteType::DisplayName
doAuthentication in file TAuthManager.php, method TAuthManager::doAuthentication()
Performs authentication.
doAuthorization in file TAuthManager.php, method TAuthManager::doAuthorization()
Performs authorization.
doCreateChildControlsFor in file TTemplateControlInheritable.php, method TTemplateControlInheritable::doCreateChildControlsFor()
This method creates the cild controls for the given class
doFlushCacheExpired in file TDbCache.php, method TDbCache::doFlushCacheExpired()
Event listener for TApplication.OnSaveState
doInitializeCache in file TDbCache.php, method TDbCache::doInitializeCache()
Event listener for TApplication.OnLoadStateComplete
doSave in file TScaffoldEditView.php, method TScaffoldEditView::doSave()
Check the validators, then tries to save the record.
doTemplateForClass in file TTemplateControlInheritable.php, method TTemplateControlInheritable::doTemplateForClass()
This method creates the template object for the given class
DropDownList | in file TDatePicker.php, class constant TDatePickerInputMode::DropDownList
DropDownList | in file TPager.php, class constant TPagerMode::DropDownList
dropOut in file TCallbackClientScript.php, method TCallbackClientScript::dropOut()
Visual Effect: Drop out.
dump in file TVarDumper.php, method TVarDumper::dump()
Converts a variable into a string representation.
Dynamic | in file TStyle.php, class constant TDisplayStyle::Dynamic
Dynamic | in file TValidationSummary.php, class constant TValidationSummaryDisplayStyle::Dynamic
Dynamic | in file TBaseValidator.php, class constant TValidatorDisplayStyle::Dynamic
DYNAMIC_TOKEN | in file TSimpleDynamicParser.php, class constant TSimpleDynamicParser::DYNAMIC_TOKEN
top
e
$errorCode | in file TActiveFileUpload.php, variable TActiveFileUploadCallbackParams::$errorCode
EditItem | in file TDataBoundControl.php, class constant TListItemType::EditItem
Email | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Email
EMAIL_PATTERN in file TLogRouter.php, class constant TEmailLogRoute::EMAIL_PATTERN
Regex pattern for email address.
EMAIL_REGEXP in file TEmailAddressValidator.php, class constant TEmailAddressValidator::EMAIL_REGEXP
Regular expression used to validate the email address
EmptyStringToNull in file TDbConnection.php, class constant TDbNullConversionMode::EmptyStringToNull
Empty string is converted to NULL
Enable in file TUrlMapping.php, class constant TUrlMappingPatternSecureConnection::Enable
Force use secured connection
EnableIfNotSecure in file TUrlMapping.php, class constant TUrlMappingPatternSecureConnection::EnableIfNotSecure
Force use secured connection, if in unsecured mode
encode in file TRpcService.php, method TJsonRpcProtocol::encode()
Encodes PHP data into JSON data
encode in file TJavaScript.php, method TJavaScript::encode()
Encodes a PHP variable into javascript representation.
encode in file TRpcService.php, method TXmlRpcProtocol::encode()
Encodes PHP data into XML data
encode | in file TRpcService.php, method TRpcProtocol::encode()
encodeRequest | in file TRpcClient.php, method TJsonRpcClient::encodeRequest()
encodeRequest | in file TRpcClient.php, method TXmlRpcClient::encodeRequest()
encrypt in file TSecurityManager.php, method TSecurityManager::encrypt()
Encrypts data with getEncryptionKey.
endFormRender | in file TPage.php, method TPage::endFormRender()
enquequePostSelect in file TMappedStatement.php, method TMappedStatement::enquequePostSelect()
Add nested result property to post select queue.
enqueue in file TQueue.php, method TQueue::enqueue()
Adds an object to the end of the queue.
ensureArray in file TComponent.php, method TPropertyValue::ensureArray()
Converts a value to array type. If the value is a string and it is
ensureBoolean in file TComponent.php, method TPropertyValue::ensureBoolean()
Converts a value to boolean type.
ensureChildControls in file TControl.php, method TControl::ensureChildControls()
Ensures child controls are created.
ensureContentTypeHeaderSent in file THttpResponse.php, method THttpResponse::ensureContentTypeHeaderSent()
Ensures that the HTTP header with the status code and status reason are sent
ensureDataBound in file TDataBoundControl.php, method TDataBoundControl::ensureDataBound()
Ensures any pending dataBind is called.
ensureEnum in file TComponent.php, method TPropertyValue::ensureEnum()
Converts a value to enum type.
ensureFloat in file TComponent.php, method TPropertyValue::ensureFloat()
Converts a value to float type.
ensureFunction in file TCallbackClientSide.php, method TCallbackClientSide::ensureFunction()
Returns javascript statement enclosed within a javascript function.
ensureFunction in file TValidationSummary.php, method TClientSideValidationSummaryOptions::ensureFunction()
Ensure the string is a valid javascript function. The code block is enclosed with "function(summary, validators){ }" block.
ensureFunction in file TClientScriptManager.php, method TClientSideOptions::ensureFunction()
Ensure that the javascript statements are wrapped in a javascript function block as
  • function(sender, parameter){ //code }
    •
    .
    ensureHeadersSent in file THttpResponse.php, method THttpResponse::ensureHeadersSent()
    Ensures that HTTP response and content-type headers are sent
    ensureHttpHeaderSent in file THttpResponse.php, method THttpResponse::ensureHttpHeaderSent()
    Ensures that the HTTP header with the status code and status reason are sent
    ensureInteger in file TComponent.php, method TPropertyValue::ensureInteger()
    Converts a value to integer type.
    ensureNullIfEmpty in file TComponent.php, method TPropertyValue::ensureNullIfEmpty()
    Converts the value to 'null' if the given value is empty
    ensureObject in file TComponent.php, method TPropertyValue::ensureObject()
    Converts a value to object type.
    ensureRenderInForm in file TPage.php, method TPage::ensureRenderInForm()
    Ensures the control is rendered within a form.
    ensureString in file TComponent.php, method TPropertyValue::ensureString()
    Converts a value to string type.
    ensureTemplateDecoration in file TWebControlDecorator.php, method TWebControlDecorator::ensureTemplateDecoration()
    This method places the templates around the open and close tag. This takes a parameter which is
    Equal | in file TCompareValidator.php, class constant TValidationCompareOperator::Equal
    equals in file TActiveRecord.php, method TActiveRecord::equals()
    Compare two records using their primary key values (all column values if table does not defined primary keys). The default uses simple == for comparison of their values. Set $strict=true for identity comparison (===).
    ERROR | in file TLogger.php, class constant TLogger::ERROR
    ERROR_FILE_NAME in file TErrorHandler.php, class constant TErrorHandler::ERROR_FILE_NAME
    error template file basename
    ESCAPED_INLINE_SYMBOL_REGEXP | in file TSqlMapXmlConfiguration.php, class constant TSqlMapXmlMappingConfiguration::ESCAPED_INLINE_SYMBOL_REGEXP
    ESCAPED_SIMPLE_MARK_REGEXP | in file TSqlMapXmlConfiguration.php, class constant TSqlMapXmlMappingConfiguration::ESCAPED_SIMPLE_MARK_REGEXP
    evaluateDataTypeCheck in file TDataTypeValidator.php, method TDataTypeValidator::evaluateDataTypeCheck()
    Determine if the given value is of a particular type using RegExp.
    evaluateDynamicContent in file TControl.php, method TCompositeLiteral::evaluateDynamicContent()
    Evaluates the expressions and/or statements in the component.
    evaluateExpression in file TComponent.php, method TComponent::evaluateExpression()
    Evaluates a PHP expression in the context of this control.
    evaluateIsValid in file TListControlValidator.php, method TListControlValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    evaluateIsValid in file TReCaptchaValidator.php, method TReCaptchaValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    evaluateIsValid in file TCustomValidator.php, method TCustomValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    evaluateIsValid in file TRangeValidator.php, method TRangeValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    evaluateIsValid in file TEmailAddressValidator.php, method TEmailAddressValidator::evaluateIsValid()
    Returns an array of javascript validator options.
    evaluateIsValid in file TRequiredFieldValidator.php, method TRequiredFieldValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    evaluateIsValid in file TCaptchaValidator.php, method TCaptchaValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    evaluateIsValid in file TDataTypeValidator.php, method TDataTypeValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    evaluateIsValid in file TRegularExpressionValidator.php, method TRegularExpressionValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    evaluateIsValid in file TBaseValidator.php, method TBaseValidator::evaluateIsValid()
    This is the major method for validation.
    evaluateIsValid in file TCompareValidator.php, method TCompareValidator::evaluateIsValid()
    This method overrides the parent's implementation.
    evaluateScript in file TCallbackClientScript.php, method TCallbackClientScript::evaluateScript()
    Evaluate a block of javascript enclosed in a boundary.
    evaluateStatements in file TComponent.php, method TComponent::evaluateStatements()
    Evaluates a list of PHP statements.
    Exception | in file TActiveRecord.php, class constant TActiveRecordInvalidFinderResult::Exception
    exceptionHandler in file PradoBase.php, method PradoBase::exceptionHandler()
    Default exception handler.
    EXCEPTION_FILE_NAME in file TErrorHandler.php, class constant TErrorHandler::EXCEPTION_FILE_NAME
    exception template file basename
    execute in file TDbCommand.php, method TDbCommand::execute()
    Executes the SQL statement.
    executeInsert | in file TSelectMappedStatement.php, method TSelectMappedStatement::executeInsert()
    executeInsert | in file TUpdateMappedStatement.php, method TUpdateMappedStatement::executeInsert()
    executeInsert | in file TCachingStatement.php, method TCachingStatement::executeInsert()
    executeInsert in file TMappedStatement.php, method TMappedStatement::executeInsert()
    Execute an insert statement. Fill the parameter object with the ouput parameters if any, also could return the insert generated key.
    executePostSelect in file TMappedStatement.php, method TMappedStatement::executePostSelect()
    Process 'select' result properties
    executeQueryForList | in file TUpdateMappedStatement.php, method TUpdateMappedStatement::executeQueryForList()
    executeQueryForList | in file TInsertMappedStatement.php, method TInsertMappedStatement::executeQueryForList()
    executeQueryForList | in file TCachingStatement.php, method TCachingStatement::executeQueryForList()
    executeQueryForList in file TMappedStatement.php, method TMappedStatement::executeQueryForList()
    Executes the SQL and retuns a List of result objects.
    executeQueryForList in file IMappedStatement.php, method IMappedStatement::executeQueryForList()
    Executes the SQL and retuns a subset of the rows selected.
    executeQueryForMap | in file TInsertMappedStatement.php, method TInsertMappedStatement::executeQueryForMap()
    executeQueryForMap in file IMappedStatement.php, method IMappedStatement::executeQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on
    executeQueryForMap in file TMappedStatement.php, method TMappedStatement::executeQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
    executeQueryForMap | in file TUpdateMappedStatement.php, method TUpdateMappedStatement::executeQueryForMap()
    executeQueryForMap | in file TCachingStatement.php, method TCachingStatement::executeQueryForMap()
    executeQueryForObject in file IMappedStatement.php, method IMappedStatement::executeQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
    executeQueryForObject | in file TInsertMappedStatement.php, method TInsertMappedStatement::executeQueryForObject()
    executeQueryForObject | in file TCachingStatement.php, method TCachingStatement::executeQueryForObject()
    executeQueryForObject in file TMappedStatement.php, method TMappedStatement::executeQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
    executeQueryForObject | in file TUpdateMappedStatement.php, method TUpdateMappedStatement::executeQueryForObject()
    executeSelectKey in file TMappedStatement.php, method TMappedStatement::executeSelectKey()
    Execute the select key statement, used to obtain last insert ID.
    executeSQLQueryLimit in file TMappedStatement.php, method TMappedStatement::executeSQLQueryLimit()
    Execute SQL Query with limits.
    executeUpdate | in file TSelectMappedStatement.php, method TSelectMappedStatement::executeUpdate()
    executeUpdate | in file TInsertMappedStatement.php, method TInsertMappedStatement::executeUpdate()
    executeUpdate in file TMappedStatement.php, method TMappedStatement::executeUpdate()
    Execute an update statement. Also used for delete statement.
    executeUpdate in file IMappedStatement.php, method IMappedStatement::executeUpdate()
    Execute an update statement. Also used for delete statement. Return the number of row effected.
    executeUpdate | in file TCachingStatement.php, method TCachingStatement::executeUpdate()
    extract | in file TTarFileExtractor.php, method TTarFileExtractor::extract()
    extractMatchingConditions in file TDataGatewayCommand.php, method TDataGatewayCommand::extractMatchingConditions()
    Calculates the AND/OR condition from dynamic method substrings using table meta data, allows for any AND-OR combinations.
    extractModify in file TTarFileExtractor.php, method TTarFileExtractor::extractModify()
    This method extract all the content of the archive in the directory indicated by $p_path. When relevant the memorized path of the files/dir can be modified by removing the $p_remove_path path at the beginning of the file/dir path.
    EXT_TEMPLATE in file TTemplateControl.php, class constant TTemplateControl::EXT_TEMPLATE
    template file extension.
    EXT_XML_FILE | in file TXmlTransform.php, class constant TXmlTransform::EXT_XML_FILE
    EXT_XSL_FILE | in file TXmlTransform.php, class constant TXmlTransform::EXT_XSL_FILE
    top
    f
    $fileName | in file TActiveFileUpload.php, variable TActiveFileUploadCallbackParams::$fileName
    $fileSize | in file TActiveFileUpload.php, variable TActiveFileUploadCallbackParams::$fileSize
    $fileType | in file TActiveFileUpload.php, variable TActiveFileUploadCallbackParams::$fileType
    $formatter in file TDateFormat.php, variable TDateFormat::$formatter
    Default DateFormat, set to the application culture.
    $formatter in file TNumberFormat.php, variable TNumberFormat::$formatter
    Default NumberFormat, set to the application culture.
    $formatters in file Translation.php, variable Translation::$formatters
    The array of formatters. We define 1 formatter per translation catalog This is a class static variable.
    fade in file TCallbackClientScript.php, method TCallbackClientScript::fade()
    Visual Effect: Gradually fade the element.
    Failure | in file TDraggable.php, class constant TDraggableRevertOptions::Failure
    FALLBACK_BASEPATH in file TPageService.php, class constant TPageService::FALLBACK_BASEPATH
    Fallback base path - used to be the default up to Prado < 3.2
    FATAL | in file TLogger.php, class constant TLogger::FATAL
    fatalError in file PradoBase.php, method PradoBase::fatalError()
    Fatal error handler.
    fault in file TSoapService.php, method TSoapServer::fault()
    Generate a SOAP fault message.
    fetchDataFromStatement in file TSqlMapPagedList.php, method TSqlMapPagedList::fetchDataFromStatement()
    Fetch data by executing the SqlMap statement.
    fetchForeignObjects in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::fetchForeignObjects()
    Fetches the foreign objects using TActiveRecord::findAllByIndex()
    fetchListData in file TLazyLoadList.php, method TLazyLoadList::fetchListData()
    Load the data by executing the mapped statement.
    fetchResultsFor in file TActiveRecord.php, method TActiveRecord::fetchResultsFor()
    Tries to load the relationship results for the given property. The $property value should correspond to an entry key in the $RELATION array.
    fetchResultsInto in file TActiveRecordRelation.php, method TActiveRecordRelation::fetchResultsInto()
    Fetch results for current relationship.
    FIELD_CALLBACK_PARAMETER | in file TPage.php, class constant TPage::FIELD_CALLBACK_PARAMETER
    FIELD_CALLBACK_TARGET | in file TPage.php, class constant TPage::FIELD_CALLBACK_TARGET
    FIELD_LASTFOCUS | in file TPage.php, class constant TPage::FIELD_LASTFOCUS
    FIELD_PAGESTATE | in file TPage.php, class constant TPage::FIELD_PAGESTATE
    FIELD_POSTBACK_PARAMETER | in file TPage.php, class constant TPage::FIELD_POSTBACK_PARAMETER
    FIELD_POSTBACK_TARGET in file TPage.php, class constant TPage::FIELD_POSTBACK_TARGET
    system post fields
    FIFO | in file TSqlMapCacheModel.php, class constant TSqlMapCacheTypes::FIFO
    fillArrayResultMap in file TMappedStatement.php, method TMappedStatement::fillArrayResultMap()
    Retrieve the result map as an array.
    fillDefaultResultMap in file TMappedStatement.php, method TMappedStatement::fillDefaultResultMap()
    Fill the result map using default settings. If <tt>$resultMap</tt> is null the result object returned will be guessed from <tt>$resultObject</tt>.
    fillPropertyWithResultMap in file TMappedStatement.php, method TMappedStatement::fillPropertyWithResultMap()
    Fills the property with result mapping results.
    fillResultArrayList in file TMappedStatement.php, method TMappedStatement::fillResultArrayList()
    Apply the result to a TList or an array.
    fillResultClass in file TMappedStatement.php, method TMappedStatement::fillResultClass()
    Fill the result using ResultClass, will creates new result object if required.
    fillResultMap in file TMappedStatement.php, method TMappedStatement::fillResultMap()
    Fills the result object according to result mappings.
    fillResultObjectProperty in file TMappedStatement.php, method TMappedStatement::fillResultObjectProperty()
    Apply the result to an object.
    find in file TTableGateway.php, method TTableGateway::find()
    Find one single record that matches the criteria.
    find in file TActiveRecord.php, method TActiveRecord::find()
    Find one single record that matches the criteria.
    find in file TDataGatewayCommand.php, method TDataGatewayCommand::find()
    Find one record matching the critera.
    findAll in file TActiveRecord.php, method TActiveRecord::findAll()
    Same as find() but returns an array of objects.
    findAll in file TTableGateway.php, method TTableGateway::findAll()
    Accepts same parameters as find(), but returns TDbDataReader instead.
    findAll in file TDataGatewayCommand.php, method TDataGatewayCommand::findAll()
    Find one or more matching records.
    findAllByIndex | in file TDataGatewayCommand.php, method TDataGatewayCommand::findAllByIndex()
    findAllByIndex in file TActiveRecord.php, method TActiveRecord::findAllByIndex()
    Fetches records using the sql clause "(fields) IN (values)", where fields is an array of column names and values is an array of values that the columns must have.
    findAllByPk | in file TDataGatewayCommand.php, method TDataGatewayCommand::findAllByPk()
    findAllByPks in file TActiveRecord.php, method TActiveRecord::findAllByPks()
    Find multiple records matching a list of primary or composite keys.
    findAllByPks in file TTableGateway.php, method TTableGateway::findAllByPks()
    Similar to findByPk(), but returns TDbDataReader instead.
    findAllBySql in file TActiveRecord.php, method TActiveRecord::findAllBySql()
    Find records using full SQL, returns corresponding record object.
    findAllBySql in file TTableGateway.php, method TTableGateway::findAllBySql()
    Execute arbituary sql command with binding parameters.
    findAllBySql in file TDataGatewayCommand.php, method TDataGatewayCommand::findAllBySql()
    Find zero or more matching records for arbituary SQL.
    findByPk in file TTableGateway.php, method TTableGateway::findByPk()
    Find one record using only the primary key or composite primary keys. Usage:
    findByPk in file TActiveRecord.php, method TActiveRecord::findByPk()
    Find one record using only the primary key or composite primary keys. Usage:
    findByPk | in file TDataGatewayCommand.php, method TDataGatewayCommand::findByPk()
    findBySql in file TTableGateway.php, method TTableGateway::findBySql()
    Execute arbituary sql command with binding parameters.
    findBySql in file TDataGatewayCommand.php, method TDataGatewayCommand::findBySql()
    Find one matching records for arbituary SQL.
    findBySql in file TActiveRecord.php, method TActiveRecord::findBySql()
    Find records using full SQL, returns corresponding record object.
    findCaptchaControl | in file TCaptchaValidator.php, method TCaptchaValidator::findCaptchaControl()
    findConnectionByID in file TDataSourceConfig.php, method TDataSourceConfig::findConnectionByID()
    Finds the database connection instance from the Application modules.
    findControl in file TControl.php, method TControl::findControl()
    Finds a control by ID path within the current naming container.
    findControl in file TCheckBoxList.php, method TCheckBoxList::findControl()
    Finds a control by ID.
    findControlsByID in file TControl.php, method TControl::findControlsByID()
    Finds all child and grand-child controls with the specified ID.
    findControlsByType in file TControl.php, method TControl::findControlsByType()
    Finds all child and grand-child controls that are of the specified type.
    findCookieByName in file THttpRequest.php, method THttpCookieCollection::findCookieByName()
    Finds the cookie with the specified name.
    finder in file TActiveRecord.php, method TActiveRecord::finder()
    Returns the instance of a active record finder for a particular class.
    findForeignConstraints in file TMysqlMetaData.php, method TMysqlMetaData::findForeignConstraints()
    Extract foreign key constraints by extracting the contraints from SHOW CREATE TABLE result.
    findForeignKeys in file TActiveRecordRelation.php, method TActiveRecordRelation::findForeignKeys()
    Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value.
    findForeignObjects in file TActiveRecordRelation.php, method TActiveRecordRelation::findForeignObjects()
    Fetches the foreign objects using TActiveRecord::findAllByIndex()
    findIndexByID in file TAccordion.php, method TAccordionViewCollection::findIndexByID()
    Finds the index of the accordion view whose ID is the same as the one being looked for.
    findIndexByID in file TTabPanel.php, method TTabViewCollection::findIndexByID()
    Finds the index of the tab view whose ID is the same as the one being looked for.
    findIndexByID in file THead.php, method TMetaTagCollection::findIndexByID()
    Finds the lowest cardinal index of the meta tag whose id is the one being looked for.
    findIndexByText in file TListItemCollection.php, method TListItemCollection::findIndexByText()
    Finds the lowest cardinal index of the item whose text is the one being looked for.
    findIndexByValue in file TListItemCollection.php, method TListItemCollection::findIndexByValue()
    Finds the lowest cardinal index of the item whose value is the one being looked for.
    findItemByText in file TListItemCollection.php, method TListItemCollection::findItemByText()
    Finds the item whose text is the one being looked for.
    findItemByValue in file TListItemCollection.php, method TListItemCollection::findItemByValue()
    Finds the item whose value is the one being looked for.
    findMetaTagByID in file THead.php, method TMetaTagCollection::findMetaTagByID()
    Finds the item whose value is the one being looked for.
    findOrdering in file TMssqlCommandBuilder.php, method TMssqlCommandBuilder::findOrdering()
    Base on simplified syntax http://msdn2.microsoft.com/en-us/library/aa259187(SQL.80).aspx
    findRecordByPK in file TActiveRecordGateway.php, method TActiveRecordGateway::findRecordByPK()
    Returns record data matching the given primary key(s). If the table uses composite key, specify the name value pairs as an array.
    findRecordBySql in file TActiveRecordGateway.php, method TActiveRecordGateway::findRecordBySql()
    Return record data from sql query.
    findRecordsByCriteria in file TActiveRecordGateway.php, method TActiveRecordGateway::findRecordsByCriteria()
    Returns record data matching the given critera. If $iterator is true, it will return multiple rows as TDbDataReader otherwise it returns the first row data.
    findRecordsByIndex | in file TActiveRecordGateway.php, method TActiveRecordGateway::findRecordsByIndex()
    findRecordsByPks in file TActiveRecordGateway.php, method TActiveRecordGateway::findRecordsByPks()
    Returns records matching the list of given primary keys.
    findRecordsBySql in file TActiveRecordGateway.php, method TActiveRecordGateway::findRecordsBySql()
    Return record data from sql query.
    Finish | in file TWizard.php, class constant TWizardStepType::Finish
    FirstName | in file TTextBox.php, class constant TTextBoxAutoCompleteType::FirstName
    Fixed | in file TBaseValidator.php, class constant TValidatorDisplayStyle::Fixed
    Fixed | in file TStyle.php, class constant TDisplayStyle::Fixed
    Fixed | in file TValidationSummary.php, class constant TValidationSummaryDisplayStyle::Fixed
    flattenPriorities in file TPriorityMap.php, method TPriorityMap::flattenPriorities()
    This flattens the priority map into a flat array [0,...,n-1]
    flattenPriorities in file TPriorityList.php, method TPriorityList::flattenPriorities()
    This flattens the priority list into a flat array [0,...,n-1]
    Float | in file TBaseValidator.php, class constant TValidationDataType::Float
    Flow | in file TRepeatInfo.php, class constant TRepeatLayout::Flow
    flush in file TAPCCache.php, method TAPCCache::flush()
    Deletes all values from cache.
    flush in file TSqlMapCacheModel.php, method TSqlMapCacheModel::flush()
    Clears the cache.
    flush in file TSqlMapCache.php, method TSqlMapApplicationCache::flush()
    Deletes all items in the cache, only for data cached by sqlmap cachemodel
    flush in file TMemCache.php, method TMemCache::flush()
    Deletes all values from cache.
    flush in file TDbCache.php, method TDbCache::flush()
    Deletes all values from cache.
    flush in file TSqlMapCache.php, method TSqlMapCache::flush()
    Clears the cache.
    flush | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::flush()
    flush in file TTextWriter.php, method TTextWriter::flush()
    Flushes the content that has been written.
    flush in file TXCache.php, method TXCache::flush()
    Deletes all values from cache.
    flush in file THttpResponse.php, method THttpResponse::flush()
    Flush the response contents and headers.
    flush in file interfaces.php, method ITextWriter::flush()
    Flushes the content that has been written.
    flush in file THtmlWriter.php, method THtmlWriter::flush()
    Flushes the rendering result.
    flush in file interfaces.php, method ICache::flush()
    Deletes all values from cache.
    flush in file TSqliteCache.php, method TSqliteCache::flush()
    Deletes all values from cache.
    flush in file TCache.php, method TCache::flush()
    Deletes all values from cache.
    flush in file TCallbackResponseAdapter.php, method TCallbackResponseWriter::flush()
    Returns the text content wrapped within a HTML comment with boundary identifier as its comment content.
    flush | in file TOutputCache.php, method TOutputCacheTextWriterMulti::flush()
    flushCacheExpired in file TDbCache.php, method TDbCache::flushCacheExpired()
    Flush expired values from cache depending on setFlushInterval
    flushCacheModels in file TSqlMapManager.php, method TSqlMapManager::flushCacheModels()
    Flushes all cached objects that belong to this SqlMap
    flushCaches in file TSqlMapGateway.php, method TSqlMapGateway::flushCaches()
    Flushes all cached objects that belong to this SqlMap
    flushContent in file THttpResponseAdapter.php, method THttpResponseAdapter::flushContent()
    This method is invoked when the response flushes the content and headers.
    flushContent in file THttpResponse.php, method THttpResponse::flushContent()
    Outputs the buffered content, sends content-type and charset header.
    flushContent in file TCallbackResponseAdapter.php, method TCallbackResponseAdapter::flushContent()
    Flushes the contents in the writers.
    flushOutput in file TApplication.php, method TApplication::flushOutput()
    Flushes output to client side.
    flushScriptFiles in file TClientScriptManager.php, method TClientScriptManager::flushScriptFiles()
    Flushes all pending script registrations
    flushWriter in file TPage.php, method TPage::flushWriter()
    Flushes output
    focus | in file TDataSourceControl.php, method TDataSourceControl::focus()
    focus in file TControl.php, method TControl::focus()
    Sets input focus to this control.
    focus in file THiddenField.php, method THiddenField::focus()
    Sets focus to this control.
    focus in file TCallbackClientScript.php, method TCallbackClientScript::focus()
    Focus on a particular element.
    fold in file TCallbackClientScript.php, method TCallbackClientScript::fold()
    Visual Effect: Fold.
    Footer | in file TDataBoundControl.php, class constant TListItemType::Footer
    Footer | in file TTableRow.php, class constant TTableRowSection::Footer
    format in file TSimpleDateFormatter.php, method TSimpleDateFormatter::format()
    Format the date according to the pattern.
    formatDataValue in file TDataGridColumn.php, method TDataGridColumn::formatDataValue()
    Formats the text value according to a format string.
    formatDataValue in file TListControl.php, method TListControl::formatDataValue()
    Formats the text value according to a format string.
    formatDate | in file TDateTimeStamp.php, method TDateTimeStamp::formatDate()
    formatLogMessage in file TLogRouter.php, method TLogRoute::formatLogMessage()
    Formats a log message given different fields.
    formatter in file Translation.php, method Translation::formatter()
    Get the static formatter from this component.
    Full | in file TColorPicker.php, class constant TColorPickerMode::Full
    top
    g
    Gender | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Gender
    generateItemStyle | in file TRepeatInfo.php, method IRepeatInfoUser::generateItemStyle()
    generateItemStyle in file TCheckBoxList.php, method TCheckBoxList::generateItemStyle()
    Returns a style used for rendering items.
    generateItemStyle in file TDataList.php, method TDataList::generateItemStyle()
    Returns a style used for rendering items.
    generateKey | in file TSqlMapCacheModel.php, method TSqlMapCacheKey::generateKey()
    generatePrivateKeyFile in file TCaptcha.php, method TCaptcha::generatePrivateKeyFile()
    Generates a file with a randomly generated private key.
    generateRandomKey in file TSecurityManager.php, method TSecurityManager::generateRandomKey()
    Generates a random key.
    generateRandomKey | in file TCaptcha.php, method TCaptcha::generateRandomKey()
    generateTimestamps in file TCache.php, method TDirectoryCacheDependency::generateTimestamps()
    Determines the last modification time for files under the directory.
    generateToken in file TCaptcha.php, method TCaptcha::generateToken()
    Generates the token.
    generateUniqueKey | in file TCache.php, method TCache::generateUniqueKey()
    generateUserKey | in file TAuthManager.php, method TAuthManager::generateUserKey()
    geOffsetY | in file TDropContainer.php, method TDropContainerEventParameter::geOffsetY()
    get in file TPropertyAccess.php, method TPropertyAccess::get()
    Gets the property value.
    get | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::get()
    Get | in file THttpRequest.php, class constant THttpRequestUrlFormat::Get
    get in file TCache.php, method TCache::get()
    Retrieves a value from cache with a specified key.
    get | in file TSqlMapCache.php, method TSqlMapFifoCache::get()
    get | in file TSqlMapCache.php, method TSqlMapApplicationCache::get()
    get | in file TSqlMapCache.php, method TSqlMapLruCache::get()
    get in file interfaces.php, method ICache::get()
    Retrieves a value from cache with a specified key.
    get | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::get()
    get4DigitYear | in file TDateTimeStamp.php, method TDateTimeStamp::get4DigitYear()
    getAbbreviatedText | in file TTableHeaderCell.php, method TTableHeaderCell::getAbbreviatedText()
    getAbsoluteApplicationUrl | in file THttpRequest.php, method THttpRequest::getAbsoluteApplicationUrl()
    getAbsoluteFilePath in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfigBuilder::getAbsoluteFilePath()
    Gets the filename relative to the basefile.
    getAcceptCssClass in file TDropContainer.php, method TDropContainer::getAcceptCssClass()
    Gets the Css class name that this container can accept.
    getAcceptTypes | in file THttpRequest.php, method THttpRequest::getAcceptTypes()
    getAccessKey | in file TImageMap.php, method THotSpot::getAccessKey()
    getAccessKey | in file TWebControl.php, method TWebControl::getAccessKey()
    getAction | in file TAuthorizationRule.php, method TAuthorizationRule::getAction()
    getActive | in file TDbConnection.php, method TDbConnection::getActive()
    getActive | in file TTabPanel.php, method TTabView::getActive()
    getActive | in file TDbTransaction.php, method TDbTransaction::getActive()
    getActive | in file TAccordion.php, method TAccordionView::getActive()
    getActive | in file TMultiView.php, method TView::getActive()
    getActiveControl | in file TActiveHiddenField.php, method TActiveHiddenField::getActiveControl()
    getActiveControl | in file TActiveHyperLink.php, method TActiveHyperLink::getActiveControl()
    getActiveControl | in file TActiveImage.php, method TActiveImage::getActiveControl()
    getActiveControl | in file TActiveFileUpload.php, method TActiveFileUpload::getActiveControl()
    getActiveControl | in file TActiveDataGrid.php, method TActiveDataGrid::getActiveControl()
    getActiveControl | in file TActiveCustomValidator.php, method TActiveCustomValidator::getActiveControl()
    getActiveControl | in file TActiveDataList.php, method TActiveDataList::getActiveControl()
    getActiveControl | in file TActiveDatePicker.php, method TActiveDatePicker::getActiveControl()
    getActiveControl | in file TActiveDropDownList.php, method TActiveDropDownList::getActiveControl()
    getActiveControl | in file TActiveTableCell.php, method TActiveTableCell::getActiveControl()
    getActiveControl | in file TActiveRatingList.php, method TActiveRatingList::getActiveControl()
    getActiveControl | in file TActiveRadioButtonList.php, method TActiveRadioButtonList::getActiveControl()
    getActiveControl | in file TActiveRepeater.php, method TActiveRepeater::getActiveControl()
    getActiveControl | in file TActiveTableRow.php, method TActiveTableRow::getActiveControl()
    getActiveControl | in file TCallback.php, method TCallback::getActiveControl()
    getActiveControl | in file TDropContainer.php, method TDropContainer::getActiveControl()
    getActiveControl | in file TActiveRadioButton.php, method TActiveRadioButton::getActiveControl()
    getActiveControl | in file TActivePanel.php, method TActivePanel::getActiveControl()
    getActiveControl | in file TActiveLinkButton.php, method TActiveLinkButton::getActiveControl()
    getActiveControl | in file TActiveLabel.php, method TActiveLabel::getActiveControl()
    getActiveControl | in file TActiveListBox.php, method TActiveListBox::getActiveControl()
    getActiveControl | in file TActiveMultiView.php, method TActiveMultiView::getActiveControl()
    getActiveControl | in file TActivePager.php, method TActivePager::getActiveControl()
    getActiveControl | in file TActiveImageButton.php, method TActiveImageButton::getActiveControl()
    getActiveControl | in file TActiveTextBox.php, method TActiveTextBox::getActiveControl()
    getActiveControl | in file TActiveButton.php, method TActiveButton::getActiveControl()
    getActiveControl | in file TActiveCheckBox.php, method TActiveCheckBox::getActiveControl()
    getActiveControl | in file TActiveCheckBoxList.php, method TActiveCheckBoxList::getActiveControl()
    getActiveControl | in file interfaces.php, method IActiveControl::getActiveControl()
    getActiveDbConnection | in file TActiveRecord.php, method TActiveRecord::getActiveDbConnection()
    getActiveHeaderCssClass | in file TAccordion.php, method TAccordion::getActiveHeaderCssClass()
    getActiveHeaderStyle | in file TAccordion.php, method TAccordion::getActiveHeaderStyle()
    getActiveStep | in file TWizard.php, method TWizard::getActiveStep()
    getActiveStepIndex | in file TWizard.php, method TWizard::getActiveStepIndex()
    getActiveTabCssClass | in file TTabPanel.php, method TTabPanel::getActiveTabCssClass()
    getActiveTabStyle | in file TTabPanel.php, method TTabPanel::getActiveTabStyle()
    getActiveView | in file TMultiView.php, method TMultiView::getActiveView()
    getActiveView in file TAccordion.php, method TAccordion::getActiveView()
    Returns the currently active view.
    getActiveView in file TTabPanel.php, method TTabPanel::getActiveView()
    Returns the currently active view.
    getActiveViewID in file TTabPanel.php, method TTabPanel::getActiveViewID()
    Returns the ID of the active tab view.
    getActiveViewID in file TAccordion.php, method TAccordion::getActiveViewID()
    Returns the ID of the active accordion view.
    getActiveViewIndex in file TTabPanel.php, method TTabPanel::getActiveViewIndex()
    Returns the index of the active tab view.
    getActiveViewIndex | in file TMultiView.php, method TMultiView::getActiveViewIndex()
    getActiveViewIndex in file TAccordion.php, method TAccordion::getActiveViewIndex()
    Returns the index of the active accordion view.
    getActor | in file TSoapService.php, method TSoapServer::getActor()
    getAdapter | in file TControl.php, method TControl::getAdapter()
    getAdapter | in file THttpResponse.php, method THttpResponse::getAdapter()
    getAddButton | in file TScaffoldView.php, method TScaffoldView::getAddButton()
    getAliases in file TApplication.php, method TApplicationConfiguration::getAliases()
    Returns list of path alias definitions.
    getAlign | in file TInlineFrame.php, method TInlineFrame::getAlign()
    getAllowAutoLogin | in file TAuthManager.php, method TAuthManager::getAllowAutoLogin()
    getAllowChildControls in file TOutputCache.php, method TOutputCache::getAllowChildControls()
    Returns a value indicating whether body contents are allowed for this control.
    getAllowChildControls | in file TControl.php, method TControl::getAllowChildControls()
    getAllowCustomPaging | in file TPagedDataSource.php, method TPagedDataSource::getAllowCustomPaging()
    getAllowCustomPaging | in file TDataBoundControl.php, method TDataBoundControl::getAllowCustomPaging()
    getAllowInput in file TRatingList.php, method TRatingList::getAllowInput()
    Wrapper for setReadOnly property.
    getAllowNull | in file TDbTableColumn.php, method TDbTableColumn::getAllowNull()
    getAllowPaging | in file TDataBoundControl.php, method TDataBoundControl::getAllowPaging()
    getAllowPaging | in file TPagedDataSource.php, method TPagedDataSource::getAllowPaging()
    getAllowReturn | in file TWizard.php, method TWizardStep::getAllowReturn()
    getAllowSorting | in file TDataGrid.php, method TDataGrid::getAllowSorting()
    getAllowSorting in file TDataGridColumn.php, method TDataGridColumn::getAllowSorting()
    Returns a value indicating whether this column allows sorting.
    getAlternateText | in file TImageMap.php, method THotSpot::getAlternateText()
    getAlternateText | in file TImage.php, method TImage::getAlternateText()
    getAlternatingItemRenderer | in file TRepeater.php, method TRepeater::getAlternatingItemRenderer()
    getAlternatingItemRenderer | in file TDataList.php, method TDataList::getAlternatingItemRenderer()
    getAlternatingItemStyle | in file TDataList.php, method TDataList::getAlternatingItemStyle()
    getAlternatingItemStyle | in file TDataGrid.php, method TDataGrid::getAlternatingItemStyle()
    getAlternatingItemTemplate | in file TRepeater.php, method TRepeater::getAlternatingItemTemplate()
    getAlternatingItemTemplate | in file TDataList.php, method TDataList::getAlternatingItemTemplate()
    getAltKey | in file TDropContainer.php, method TDropContainerEventParameter::getAltKey()
    getAnimationDuration | in file TAccordion.php, method TAccordion::getAnimationDuration()
    getAppendDataBoundItems | in file TListControl.php, method TListControl::getAppendDataBoundItems()
    getApplication | in file TApplicationComponent.php, method TApplicationComponent::getApplication()
    getApplication | in file PradoBase.php, method PradoBase::getApplication()
    getApplicationConfigurationClass | in file TApplication.php, method TApplication::getApplicationConfigurationClass()
    getApplicationConfigurations | in file TPageService.php, method TPageConfiguration::getApplicationConfigurations()
    getApplicationFilePath | in file THttpRequest.php, method THttpRequest::getApplicationFilePath()
    getApplicationStatePersister | in file TApplication.php, method TApplication::getApplicationStatePersister()
    getApplicationUrl | in file THttpRequest.php, method THttpRequest::getApplicationUrl()
    getAssetManager | in file TApplication.php, method TApplication::getAssetManager()
    getAssetUrl | in file TRatingList.php, method TRatingList::getAssetUrl()
    getAssetUrl | in file TColorPicker.php, method TColorPicker::getAssetUrl()
    getAssetUrl | in file TDatePicker.php, method TDatePicker::getAssetUrl()
    getAssetUrl | in file TActiveFileUpload.php, method TActiveFileUpload::getAssetUrl()
    getAssociationJoin in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getAssociationJoin()
    SQL inner join for M-N relationship via association table.
    getAssociationTable | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getAssociationTable()
    getAssociationTable | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getAssociationTable()
    getAssociationTableCommandBuilder | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getAssociationTableCommandBuilder()
    getAttribute | in file TImageMap.php, method THotSpot::getAttribute()
    getAttribute | in file TListItem.php, method TListItem::getAttribute()
    getAttribute in file TDbConnection.php, method TDbConnection::getAttribute()
    Obtains a specific DB connection attribute information.
    getAttribute | in file TXmlDocument.php, method TXmlElement::getAttribute()
    getAttribute | in file TControl.php, method TControl::getAttribute()
    getAttributes in file TControl.php, method TControl::getAttributes()
    Returns the list of custom attributes.
    getAttributes in file TImageMap.php, method THotSpot::getAttributes()
    Returns the list of custom attributes.
    getAttributes | in file TXmlDocument.php, method TXmlElement::getAttributes()
    getAttributes | in file TListItem.php, method TListItem::getAttributes()
    getAuthenticatedApplied | in file TAuthorizationRule.php, method TAuthorizationRule::getAuthenticatedApplied()
    getAuthExpire | in file TAuthManager.php, method TAuthManager::getAuthExpire()
    getAuthorizationRules | in file TApplication.php, method TApplication::getAuthorizationRules()
    getAutoColumns | in file TDataGrid.php, method TDataGrid::getAutoColumns()
    getAutoCommit | in file TDbConnection.php, method TDbConnection::getAutoCommit()
    getAutoCompleteType | in file TTextBox.php, method TTextBox::getAutoCompleteType()
    getAutoCreateCacheTable | in file TDbCache.php, method TDbCache::getAutoCreateCacheTable()
    getAutoCreateLogTable | in file TLogRouter.php, method TDbLogRoute::getAutoCreateLogTable()
    getAutoGenerateColumnName | in file TActiveDataGrid.php, method TActiveDataGrid::getAutoGenerateColumnName()
    getAutoGenerateColumnName | in file TDataGrid.php, method TDataGrid::getAutoGenerateColumnName()
    getAutoGenerateColumns | in file TDataGrid.php, method TDataGrid::getAutoGenerateColumns()
    getAutoHide | in file TKeyboard.php, method TKeyboard::getAutoHide()
    getAutoHideTextBox | in file TInPlaceTextBox.php, method TInPlaceTextBox::getAutoHideTextBox()
    getAutoIncrement | in file TSqliteTableColumn.php, method TSqliteTableColumn::getAutoIncrement()
    getAutoIncrement | in file TMssqlTableColumn.php, method TMssqlTableColumn::getAutoIncrement()
    getAutoIncrement | in file TMysqlTableColumn.php, method TMysqlTableColumn::getAutoIncrement()
    getAutoPostBack | in file TCheckBox.php, method TCheckBox::getAutoPostBack()
    getAutoPostBack | in file TListControl.php, method TListControl::getAutoPostBack()
    getAutoPostBack | in file TActiveFileUpload.php, method TActiveFileUpload::getAutoPostBack()
    getAutoPostBack | in file TSlider.php, method TSlider::getAutoPostBack()
    getAutoPostBack | in file THtmlArea.php, method THtmlArea::getAutoPostBack()
    getAutoPostBack | in file TActiveDatePicker.php, method TActiveDatePicker::getAutoPostBack()
    getAutoPostBack | in file TTextBox.php, method TTextBox::getAutoPostBack()
    getAutoStart | in file THttpSession.php, method THttpSession::getAutoStart()
    getAutoSwitch | in file TTabPanel.php, method TTabPanel::getAutoSwitch()
    getAutoTrim | in file TTextBox.php, method TTextBox::getAutoTrim()
    getAutoUpdate in file TValidationSummary.php, method TValidationSummary::getAutoUpdate()
    Gets the auto-update for this summary.
    getAvailableDrivers | in file TDbConnection.php, method TDbConnection::getAvailableDrivers()
    getAvailablePlugins in file THtmlArea.php, method THtmlArea::getAvailablePlugins()
    Returns a list of plugins to be loaded.
    getAvailableThemes | in file TThemeManager.php, method TThemeManager::getAvailableThemes()
    getAvailableThemes | in file THtmlArea.php, method THtmlArea::getAvailableThemes()
    getBackColor | in file TWebControl.php, method TWebControl::getBackColor()
    getBackColor | in file TStyle.php, method TStyle::getBackColor()
    getBackImageUrl | in file TDataGrid.php, method TDataGrid::getBackImageUrl()
    getBackImageUrl | in file TTable.php, method TTable::getBackImageUrl()
    getBackImageUrl | in file TPanel.php, method TPanel::getBackImageUrl()
    getBackImageUrl | in file TPanelStyle.php, method TPanelStyle::getBackImageUrl()
    getBackImageUrl | in file TStyle.php, method TTableStyle::getBackImageUrl()
    getBaseActiveControl | in file TActiveControlAdapter.php, method TActiveControlAdapter::getBaseActiveControl()
    getBaseCacheKey | in file TOutputCache.php, method TOutputCache::getBaseCacheKey()
    getBaseKey | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::getBaseKey()
    getBaseKeyKeyName | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::getBaseKeyKeyName()
    getBasePageClass | in file TPageService.php, method TPageService::getBasePageClass()
    getBasePath | in file TAssetManager.php, method TAssetManager::getBasePath()
    getBasePath | in file TThemeManager.php, method TTheme::getBasePath()
    getBasePath | in file TApplication.php, method TApplication::getBasePath()
    getBasePath | in file TThemeManager.php, method TThemeManager::getBasePath()
    getBasePath | in file TPageService.php, method TPageService::getBasePath()
    getBaseUrl | in file TAssetManager.php, method TAssetManager::getBaseUrl()
    getBaseUrl | in file THead.php, method THead::getBaseUrl()
    getBaseUrl | in file THttpRequest.php, method THttpRequest::getBaseUrl()
    getBaseUrl | in file TThemeManager.php, method TTheme::getBaseUrl()
    getBaseUrl | in file TThemeManager.php, method TThemeManager::getBaseUrl()
    getBold | in file TFont.php, method TFont::getBold()
    getBorderCollapse | in file TStyle.php, method TTableStyle::getBorderCollapse()
    getBorderColor | in file TWebControl.php, method TWebControl::getBorderColor()
    getBorderColor | in file TStyle.php, method TStyle::getBorderColor()
    getBorderStyle | in file TStyle.php, method TStyle::getBorderStyle()
    getBorderStyle | in file TWebControl.php, method TWebControl::getBorderStyle()
    getBorderWidth | in file TWebControl.php, method TWebControl::getBorderWidth()
    getBorderWidth | in file TStyle.php, method TStyle::getBorderWidth()
    getBottom | in file TImageMap.php, method TRectangleHotSpot::getBottom()
    getBottomPager | in file TDataGrid.php, method TDataGrid::getBottomPager()
    getBoundary | in file TCallbackResponseAdapter.php, method TCallbackResponseWriter::getBoundary()
    getBrowser | in file THttpRequest.php, method THttpRequest::getBrowser()
    getBufferOutput | in file THttpResponse.php, method THttpResponse::getBufferOutput()
    getBuilder | in file TDataGatewayCommand.php, method TDataGatewayCommand::getBuilder()
    getBulletImageUrl | in file TBulletedList.php, method TBulletedList::getBulletImageUrl()
    getBulletStyle | in file TBulletedList.php, method TBulletedList::getBulletStyle()
    getBusyImage | in file TActiveFileUpload.php, method TActiveFileUpload::getBusyImage()
    getButtonImageUrl | in file TDatePicker.php, method TDatePicker::getButtonImageUrl()
    getButtonText | in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::getButtonText()
    getButtonText | in file TDatePicker.php, method TDatePicker::getButtonText()
    getButtonType | in file TButton.php, method TButton::getButtonType()
    getButtonType | in file TEditCommandColumn.php, method TEditCommandColumn::getButtonType()
    getButtonType | in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::getButtonType()
    getButtonType | in file TPager.php, method TPager::getButtonType()
    getButtonType | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getButtonType()
    getButtonType | in file TButtonColumn.php, method TButtonColumn::getButtonType()
    getCache | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::getCache()
    getCache | in file TActiveRecordManager.php, method TActiveRecordManager::getCache()
    getCache | in file TApplication.php, method TApplication::getCache()
    getCache | in file TCachePageStatePersister.php, method TCachePageStatePersister::getCache()
    getCache | in file TCacheHttpSession.php, method TCacheHttpSession::getCache()
    getCache | in file TSqlMapStatement.php, method TSqlMapStatement::getCache()
    getCache | in file TSqlMapCache.php, method TSqlMapApplicationCache::getCache()
    getCacheControl | in file THttpResponse.php, method THttpResponse::getCacheControl()
    getCacheDependencies | in file TSqlMapManager.php, method TSqlMapManager::getCacheDependencies()
    getCacheDependency in file TOutputCache.php, method TOutputCache::getCacheDependency()
    Returns the dependency of the data to be cached.
    getCacheExpire | in file THttpResponse.php, method THttpResponse::getCacheExpire()
    getCacheKey | in file TOutputCache.php, method TOutputCacheCalculateKeyEventParameter::getCacheKey()
    getCacheKey | in file TOutputCache.php, method TOutputCache::getCacheKey()
    getCacheKey | in file TCachingStatement.php, method TCachingStatement::getCacheKey()
    getCacheKey | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::getCacheKey()
    getCacheModel | in file TSqlMapStatement.php, method TSqlMapStatement::getCacheModel()
    getCacheModel in file TSqlMapManager.php, method TSqlMapManager::getCacheModel()
    Gets a cache by name
    getCacheModuleID | in file TCacheHttpSession.php, method TCacheHttpSession::getCacheModuleID()
    getCacheModuleID | in file TOutputCache.php, method TOutputCache::getCacheModuleID()
    getCacheModuleID | in file TCachePageStatePersister.php, method TCachePageStatePersister::getCacheModuleID()
    getCacheSize | in file TSqlMapCache.php, method TSqlMapCache::getCacheSize()
    getCacheTableName | in file TDbCache.php, method TDbCache::getCacheTableName()
    getCacheTime | in file TOutputCache.php, method TOutputCache::getCacheTime()
    getCacheTime | in file TOutputCache.php, method TOutputCacheCheckDependencyEventParameter::getCacheTime()
    getCacheTimeout | in file TCachePageStatePersister.php, method TCachePageStatePersister::getCacheTimeout()
    getCachingPostBack | in file TOutputCache.php, method TOutputCache::getCachingPostBack()
    getCachingStack | in file TPage.php, method TPage::getCachingStack()
    getCalendarStyle | in file TDatePicker.php, method TDatePicker::getCalendarStyle()
    getCallbackClient in file TPage.php, method TPage::getCallbackClient()
    Gets the callback client script handler that allows javascript functions to be executed during the callback response.
    getCallbackClientHandler in file TActivePageAdapter.php, method TActivePageAdapter::getCallbackClientHandler()
    Gets the callback client script handler. It handlers the javascript functions to be executed during the callback response.
    getCallbackEventParameter in file TActivePageAdapter.php, method TActivePageAdapter::getCallbackEventParameter()
    Gets callback parameter. JSON encoding is assumed.
    getCallbackEventParameter in file TPage.php, method TPage::getCallbackEventParameter()
    Callback parameter is decoded assuming JSON encoding.
    getCallbackEventTarget | in file TPage.php, method TPage::getCallbackEventTarget()
    getCallbackEventTarget | in file TActivePageAdapter.php, method TActivePageAdapter::getCallbackEventTarget()
    getCallbackJavascript | in file TActiveFileUpload.php, method TActiveFileUpload::getCallbackJavascript()
    getCallbackOptions | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getCallbackOptions()
    getCallbackParameter | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getCallbackParameter()
    getCallbackParameter | in file TCallbackEventParameter.php, method TCallbackEventParameter::getCallbackParameter()
    getCallbackReference in file TClientScriptManager.php, method TClientScriptManager::getCallbackReference()
    Returns javascript statement that create a new callback request object.
    getCancelButton | in file TScaffoldEditView.php, method TScaffoldEditView::getCancelButton()
    getCancelButton | in file TWizard.php, method TWizardNavigationContainer::getCancelButton()
    getCancelButtonStyle | in file TWizard.php, method TWizard::getCancelButtonStyle()
    getCancelButtonText | in file TColorPicker.php, method TColorPicker::getCancelButtonText()
    getCancelDestinationUrl | in file TWizard.php, method TWizard::getCancelDestinationUrl()
    getCancelImageUrl | in file TEditCommandColumn.php, method TEditCommandColumn::getCancelImageUrl()
    getCancelNavigation | in file TWizard.php, method TWizardNavigationEventParameter::getCancelNavigation()
    getCancelText | in file TEditCommandColumn.php, method TEditCommandColumn::getCancelText()
    getCanDelete | in file TDataSourceView.php, method TDataSourceView::getCanDelete()
    getCanGetRowCount | in file TDataSourceView.php, method TDataSourceView::getCanGetRowCount()
    getCanInsert | in file TDataSourceView.php, method TDataSourceView::getCanInsert()
    getCanPage | in file TDataSourceView.php, method TDataSourceView::getCanPage()
    getCanSort | in file TDataSourceView.php, method TDataSourceView::getCanSort()
    getCanUpdate | in file TDataSourceView.php, method TDataSourceView::getCanUpdate()
    getCaptchaControl | in file TReCaptchaValidator.php, method TReCaptchaValidator::getCaptchaControl()
    getCaptchaControl | in file TCaptchaValidator.php, method TCaptchaValidator::getCaptchaControl()
    getCaptchaScriptFile | in file TCaptcha.php, method TCaptcha::getCaptchaScriptFile()
    getCaption | in file TTabPanel.php, method TTabView::getCaption()
    getCaption | in file TRepeatInfo.php, method TRepeatInfo::getCaption()
    getCaption | in file TDataGrid.php, method TDataGrid::getCaption()
    getCaption | in file TRatingList.php, method TRatingList::getCaption()
    getCaption | in file TTable.php, method TTable::getCaption()
    getCaption | in file TDataList.php, method TDataList::getCaption()
    getCaption | in file TAccordion.php, method TAccordionView::getCaption()
    getCaptionAlign | in file TDataGrid.php, method TDataGrid::getCaptionAlign()
    getCaptionAlign | in file TTable.php, method TTable::getCaptionAlign()
    getCaptionAlign | in file TRepeatInfo.php, method TRepeatInfo::getCaptionAlign()
    getCaptionAlign | in file TDataList.php, method TDataList::getCaptionAlign()
    getCaptionControl | in file TRatingList.php, method TRatingList::getCaptionControl()
    getCaptionControlID | in file TRatingList.php, method TRatingList::getCaptionControlID()
    getCaptionID | in file TRatingList.php, method TRatingList::getCaptionID()
    getCaseSensitive | in file TCaptcha.php, method TCaptcha::getCaseSensitive()
    getCaseSensitive | in file TAttributeCollection.php, method TAttributeCollection::getCaseSensitive()
    getCaseSensitive | in file TUrlMapping.php, method TUrlMappingPattern::getCaseSensitive()
    getCatalogName | in file TMssqlTableInfo.php, method TMssqlTableInfo::getCatalogName()
    getCatalogSchemaTableName | in file TMssqlMetaData.php, method TMssqlMetaData::getCatalogSchemaTableName()
    getCatalogue in file TTranslate.php, method TTranslate::getCatalogue()
    Get the message catalogue.
    getCategories | in file TLogRouter.php, method TLogRoute::getCategories()
    getCategoryText | in file TTableHeaderCell.php, method TTableHeaderCell::getCategoryText()
    getCausesValidation | in file TImageMap.php, method THotSpot::getCausesValidation()
    getCausesValidation | in file TEditCommandColumn.php, method TEditCommandColumn::getCausesValidation()
    getCausesValidation | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getCausesValidation()
    getCausesValidation | in file TImageButton.php, method TImageButton::getCausesValidation()
    getCausesValidation | in file TCheckBox.php, method TCheckBox::getCausesValidation()
    getCausesValidation | in file TButtonColumn.php, method TButtonColumn::getCausesValidation()
    getCausesValidation | in file TListControl.php, method TListControl::getCausesValidation()
    getCausesValidation | in file TTextBox.php, method TTextBox::getCausesValidation()
    getCausesValidation | in file TControl.php, method IButtonControl::getCausesValidation()
    getCausesValidation | in file TButton.php, method TButton::getCausesValidation()
    getCausesValidation | in file TLinkButton.php, method TLinkButton::getCausesValidation()
    getCellIndex in file TActiveTableCell.php, method TActiveTableCell::getCellIndex()
    Returns the zero-based index of the TActiveTableCell within the TTableCellCollection of the parent TTableRow control. Raises a TConfigurationException if the cell is no member of the cell collection.
    getCellPadding | in file TCheckBoxList.php, method TCheckBoxList::getCellPadding()
    getCellPadding | in file TTable.php, method TTable::getCellPadding()
    getCellPadding | in file TStyle.php, method TTableStyle::getCellPadding()
    getCellPadding | in file TBaseDataList.php, method TBaseDataList::getCellPadding()
    getCells | in file TTableRow.php, method TTableRow::getCells()
    getCellSpacing | in file TTable.php, method TTable::getCellSpacing()
    getCellSpacing | in file TCheckBoxList.php, method TCheckBoxList::getCellSpacing()
    getCellSpacing | in file TStyle.php, method TTableStyle::getCellSpacing()
    getCellSpacing | in file TBaseDataList.php, method TBaseDataList::getCellSpacing()
    getCgiFix | in file THttpRequest.php, method THttpRequest::getCgiFix()
    getChallengeFieldName | in file TReCaptcha.php, method TReCaptcha::getChallengeFieldName()
    getChanges | in file TActiveControlAdapter.php, method TCallbackPageStateTracker::getChanges()
    getChangingTokenBackground | in file TCaptcha.php, method TCaptcha::getChangingTokenBackground()
    getCharset | in file TDbConnection.php, method TDbConnection::getCharset()
    getCharset in file TI18NControl.php, method TI18NControl::getCharset()
    Gets the charset.
    getCharset | in file THttpResponse.php, method THttpResponse::getCharset()
    getCharset | in file TRangeValidator.php, method TRangeValidator::getCharset()
    getCharset | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::getCharset()
    getCharset | in file TGlobalization.php, method TGlobalization::getCharset()
    getChecked | in file TCheckBox.php, method TCheckBox::getChecked()
    getCheckMXRecord | in file TEmailAddressValidator.php, method TEmailAddressValidator::getCheckMXRecord()
    getChildControlsCreated | in file TControl.php, method TControl::getChildControlsCreated()
    getClass | in file TResultMap.php, method TResultMap::getClass()
    getClassMaps | in file TSoapService.php, method TSoapServer::getClassMaps()
    getClassName | in file TComponent.php, method TComponentReflection::getClassName()
    getClearButton | in file TScaffoldEditView.php, method TScaffoldEditView::getClearButton()
    getClient in file TSqlMapConfig.php, method TSqlMapConfig::getClient()
    Initialize the sqlmap if necessary, returns the TSqlMapGateway instance.
    getClientClassName in file TRatingList.php, method TRatingList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TTextBox.php, method TTextBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TButton.php, method TButton::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TDataTypeValidator.php, method TDataTypeValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    getClientClassName in file TActiveListBox.php, method TActiveListBox::getClientClassName()
    Javascript client class for this control.
    getClientClassName in file TReCaptchaValidator.php, method TReCaptchaValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    getClientClassName in file TColorPicker.php, method TColorPicker::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName | in file TActiveRadioButton.php, method TActiveRadioButton::getClientClassName()
    getClientClassName in file TTabPanel.php, method TTabPanel::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TActiveRatingList.php, method TActiveRatingList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TDropDownList.php, method TDropDownList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TActiveDropDownList.php, method TActiveDropDownList::getClientClassName()
    No client class for this control.
    getClientClassName in file TEmailAddressValidator.php, method TEmailAddressValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    getClientClassName | in file TEventTriggeredCallback.php, method TEventTriggeredCallback::getClientClassName()
    getClientClassName in file TRequiredFieldValidator.php, method TRequiredFieldValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    getClientClassName in file TAccordion.php, method TAccordion::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TDropContainer.php, method TDropContainer::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName | in file TActiveButton.php, method TActiveButton::getClientClassName()
    getClientClassName in file TSlider.php, method TSlider::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TRegularExpressionValidator.php, method TRegularExpressionValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    getClientClassName | in file TActiveLinkButton.php, method TActiveLinkButton::getClientClassName()
    getClientClassName in file TImageButton.php, method TImageButton::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TCheckBoxList.php, method TCheckBoxList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TListControlValidator.php, method TListControlValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    getClientClassName in file TCustomValidator.php, method TCustomValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    getClientClassName in file TBaseValidator.php, method TBaseValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    getClientClassName in file THtmlArea.php, method THtmlArea::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TActiveHiddenField.php, method TActiveHiddenField::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TImageMap.php, method TImageMap::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName | in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::getClientClassName()
    getClientClassName | in file TAutoComplete.php, method TAutoComplete::getClientClassName()
    getClientClassName | in file TKeyboard.php, method TKeyboard::getClientClassName()
    getClientClassName in file TLinkButton.php, method TLinkButton::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName | in file TInPlaceTextBox.php, method TInPlaceTextBox::getClientClassName()
    getClientClassName in file TListBox.php, method TListBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName | in file TActiveFileUpload.php, method TActiveFileUpload::getClientClassName()
    getClientClassName in file TListControl.php, method TListControl::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName | in file TActiveCustomValidator.php, method TActiveCustomValidator::getClientClassName()
    getClientClassName in file TCaptchaValidator.php, method TCaptchaValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    getClientClassName in file TDraggable.php, method TDraggable::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TRangeValidator.php, method TRangeValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    getClientClassName in file TRadioButtonList.php, method TRadioButtonList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName | in file TActiveTableCell.php, method TActiveTableCell::getClientClassName()
    getClientClassName | in file TActiveCheckBox.php, method TActiveCheckBox::getClientClassName()
    getClientClassName in file TRadioButton.php, method TRadioButton::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TBulletedList.php, method TBulletedList::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName in file TCheckBox.php, method TCheckBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName | in file TActiveTableRow.php, method TActiveTableRow::getClientClassName()
    getClientClassName in file TActiveTextBox.php, method TActiveTextBox::getClientClassName()
    Gets the name of the javascript class responsible for performing postback for this control.
    getClientClassName | in file TActiveImageButton.php, method TActiveImageButton::getClientClassName()
    getClientClassName | in file TValueTriggeredCallback.php, method TValueTriggeredCallback::getClientClassName()
    getClientClassName in file TCompareValidator.php, method TCompareValidator::getClientClassName()
    Gets the name of the javascript class responsible for performing validation for this control.
    getClientFunctionsToExecute | in file TCallbackClientScript.php, method TCallbackClientScript::getClientFunctionsToExecute()
    getClientID in file TControl.php, method TControl::getClientID()
    Returns the client ID of the control.
    getClientOptions in file TActiveFileUpload.php, method TActiveFileUpload::getClientOptions()
    Gets the client side options for this control.
    getClientOptions | in file TTabPanel.php, method TTabPanel::getClientOptions()
    getClientOptions | in file TAccordion.php, method TAccordion::getClientOptions()
    getClientOptions | in file TKeyboard.php, method TKeyboard::getClientOptions()
    getClientScript | in file TPage.php, method TPage::getClientScript()
    getClientScriptManagerClass | in file TPageService.php, method TPageService::getClientScriptManagerClass()
    getClientScriptOptions in file TCaptchaValidator.php, method TCaptchaValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    getClientScriptOptions | in file TReCaptchaValidator.php, method TReCaptchaValidator::getClientScriptOptions()
    getClientScriptOptions in file TRequiredFieldValidator.php, method TRequiredFieldValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    getClientScriptOptions in file TCompareValidator.php, method TCompareValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    getClientScriptOptions in file TRegularExpressionValidator.php, method TRegularExpressionValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    getClientScriptOptions in file TRangeValidator.php, method TRangeValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    getClientScriptOptions in file TBaseValidator.php, method TBaseValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    getClientScriptOptions in file TActiveCustomValidator.php, method TActiveCustomValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    getClientScriptOptions in file TValidationSummary.php, method TValidationSummary::getClientScriptOptions()
    Get a list of options for the client-side javascript validation summary.
    getClientScriptOptions in file TDataTypeValidator.php, method TDataTypeValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    getClientScriptOptions in file TCustomValidator.php, method TCustomValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    getClientScriptOptions in file TListControlValidator.php, method TListControlValidator::getClientScriptOptions()
    Returns an array of javascript validator options.
    getClientSide | in file TActiveCheckBox.php, method TActiveCheckBox::getClientSide()
    getClientSide | in file TActiveCustomValidator.php, method TActiveCustomValidator::getClientSide()
    getClientSide in file TBaseValidator.php, method TBaseValidator::getClientSide()
    Gets the TValidatorClientSide that allows modification of the client- side validator events.
    getClientSide | in file TActiveHiddenField.php, method TActiveHiddenField::getClientSide()
    getClientSide | in file TActiveDatePicker.php, method TActiveDatePicker::getClientSide()
    getClientSide in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getClientSide()
    Callback client-side options can be set by setting the properties of the ClientSide property. E.g. <com:TCallback ActiveControl.ClientSide.OnSuccess="..." /> See TCallbackClientSide for details on the properties of ClientSide.
    getClientSide | in file TActiveDropDownList.php, method TActiveDropDownList::getClientSide()
    getClientSide | in file TActiveCheckBoxList.php, method TActiveCheckBoxList::getClientSide()
    getClientSide in file TCallbackOptions.php, method TCallbackOptions::getClientSide()
    Callback client-side options can be set by setting the properties of the ClientSide property. E.g. <com:TCallbackOptions ClientSide.OnSuccess="..." /> See TCallbackClientSide for details on the properties of ClientSide.
    getClientSide | in file TActiveTextBox.php, method TActiveTextBox::getClientSide()
    getClientSide | in file TActiveFileUpload.php, method TActiveFileUpload::getClientSide()
    getClientSide in file TSlider.php, method TSlider::getClientSide()
    Gets the TSliderClientScript to set the TSlider event handlers.
    getClientSide in file TDatePicker.php, method TDatePicker::getClientSide()
    Gets the TDatePickerClientScript to set the TDatePicker event handlers.
    getClientSide | in file TActiveButton.php, method TActiveButton::getClientSide()
    getClientSide | in file TDropContainer.php, method TDropContainer::getClientSide()
    getClientSide | in file TColorPicker.php, method TColorPicker::getClientSide()
    getClientSide | in file TActivePager.php, method TActivePager::getClientSide()
    getClientSide | in file TActiveRadioButton.php, method TActiveRadioButton::getClientSide()
    getClientSide | in file TActiveRatingList.php, method TActiveRatingList::getClientSide()
    getClientSide | in file TValidationSummary.php, method TValidationSummary::getClientSide()
    getClientSide | in file TActiveListBox.php, method TActiveListBox::getClientSide()
    getClientSide | in file TActiveRadioButtonList.php, method TActiveRadioButtonList::getClientSide()
    getClientSide | in file TActiveImageButton.php, method TActiveImageButton::getClientSide()
    getClientSide | in file TActiveTableCell.php, method TActiveTableCell::getClientSide()
    getClientSide | in file TActiveLinkButton.php, method TActiveLinkButton::getClientSide()
    getClientSide | in file TCallback.php, method TCallback::getClientSide()
    getClientSide | in file TActiveTableRow.php, method TActiveTableRow::getClientSide()
    getClientSideOptions | in file TReCaptcha.php, method TReCaptcha::getClientSideOptions()
    getClientSideOptions | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getClientSideOptions()
    getClientSidePatternModifiers | in file TRegularExpressionValidator.php, method TRegularExpressionValidator::getClientSidePatternModifiers()
    getClientState in file TPage.php, method TPage::getClientState()
    Returns the state to be stored on the client side.
    getClientSupportsJavaScript | in file TPage.php, method TPage::getClientSupportsJavaScript()
    getClientValidationFunction | in file TCustomValidator.php, method TCustomValidator::getClientValidationFunction()
    getClientVersion | in file TDbConnection.php, method TDbConnection::getClientVersion()
    getClientX | in file TDropContainer.php, method TDropContainerEventParameter::getClientX()
    getClientY | in file TDropContainer.php, method TDropContainerEventParameter::getClientY()
    getCollection | in file TMappedStatement.php, method TSqlMapObjectCollectionTree::getCollection()
    getColorLevel | in file TLogRouter.php, method TBrowserLogRoute::getColorLevel()
    getColorPickerStyle | in file TColorPicker.php, method TColorPicker::getColorPickerStyle()
    getColumn | in file TDiscriminator.php, method TDiscriminator::getColumn()
    getColumn | in file TParameterProperty.php, method TParameterProperty::getColumn()
    getColumn | in file TResultProperty.php, method TResultProperty::getColumn()
    getColumn | in file TDbTableInfo.php, method TDbTableInfo::getColumn()
    getColumn | in file TOracleTableInfo.php, method TOracleTableInfo::getColumn()
    getColumnBindings in file TDbCommandBuilder.php, method TDbCommandBuilder::getColumnBindings()
    Create a name-value or position-value if $position=true binding strings.
    getColumnCase | in file TDbConnection.php, method TDbConnection::getColumnCase()
    getColumnCount | in file TDbDataReader.php, method TDbDataReader::getColumnCount()
    getColumnId | in file TDbTableColumn.php, method TDbTableColumn::getColumnId()
    getColumnIndex | in file TDbTableColumn.php, method TDbTableColumn::getColumnIndex()
    getColumnIndex | in file TResultProperty.php, method TResultProperty::getColumnIndex()
    getColumnIndex | in file TDiscriminator.php, method TDiscriminator::getColumnIndex()
    getColumnName | in file TDbTableColumn.php, method TDbTableColumn::getColumnName()
    getColumnNames | in file TOracleTableInfo.php, method TOracleTableInfo::getColumnNames()
    getColumnNames | in file TDbTableInfo.php, method TDbTableInfo::getColumnNames()
    getColumns | in file TResultMap.php, method TResultMap::getColumns()
    getColumns | in file TDbTableInfo.php, method TDbTableInfo::getColumns()
    getColumns | in file TDataGrid.php, method TDataGrid::getColumns()
    getColumns | in file TOracleTableInfo.php, method TOracleTableInfo::getColumns()
    getColumns | in file TTextBox.php, method TTextBox::getColumns()
    getColumnSize | in file TDbTableColumn.php, method TDbTableColumn::getColumnSize()
    getColumnSpan | in file TTableCell.php, method TTableCell::getColumnSpan()
    getColumnValue in file TActiveRecord.php, method TActiveRecord::getColumnValue()
    Retrieves the column value according to column name.
    getCombinedStyle | in file TActiveControlAdapter.php, method TStyleDiff::getCombinedStyle()
    getCommand | in file TMappedStatement.php, method TMappedStatement::getCommand()
    getCommand | in file TTableGateway.php, method TTableGateway::getCommand()
    getCommand in file TDataGatewayCommand.php, method TDataGatewayEventParameter::getCommand()
    The database command to be executed. Do not rebind the parameters or change the sql query string.
    getCommand | in file TDataGatewayCommand.php, method TDataGatewayResultEventParameter::getCommand()
    getCommand | in file TActiveRecordGateway.php, method TActiveRecordGateway::getCommand()
    getCommandBuilder | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getCommandBuilder()
    getCommandName | in file TButton.php, method TButton::getCommandName()
    getCommandName | in file TLinkButton.php, method TLinkButton::getCommandName()
    getCommandName | in file TControl.php, method TCommandEventParameter::getCommandName()
    getCommandName | in file TControl.php, method IButtonControl::getCommandName()
    getCommandName | in file TButtonColumn.php, method TButtonColumn::getCommandName()
    getCommandName | in file TImageButton.php, method TImageButton::getCommandName()
    getCommandParameter | in file TControl.php, method IButtonControl::getCommandParameter()
    getCommandParameter | in file TImageButton.php, method TImageButton::getCommandParameter()
    getCommandParameter | in file TButton.php, method TButton::getCommandParameter()
    getCommandParameter | in file TLinkButton.php, method TLinkButton::getCommandParameter()
    getCommandParameter | in file TControl.php, method TCommandEventParameter::getCommandParameter()
    getCommandSource | in file TDataGrid.php, method TDataGridSortCommandEventParameter::getCommandSource()
    getCommandSource | in file TRepeater.php, method TRepeaterCommandEventParameter::getCommandSource()
    getCommandSource | in file TPager.php, method TPagerPageChangedEventParameter::getCommandSource()
    getCommandSource | in file TDataGrid.php, method TDataGridCommandEventParameter::getCommandSource()
    getCommandSource | in file TDataGrid.php, method TDataGridPageChangedEventParameter::getCommandSource()
    getCommandSource | in file TDataList.php, method TDataListCommandEventParameter::getCommandSource()
    getComparisonValues in file TCompareValidator.php, method TCompareValidator::getComparisonValues()
    Parse the pair of values into the appropriate value type.
    getCompleteButton | in file TWizard.php, method TWizardNavigationContainer::getCompleteButton()
    getCompositeKeyCondition in file TDataGatewayCommand.php, method TDataGatewayCommand::getCompositeKeyCondition()
    Construct a "pk IN ('key1', 'key2', ...)" criteria.
    getCompressionOptions | in file THtmlArea.php, method THtmlArea::getCompressionOptions()
    getCondition | in file TSqlCriteria.php, method TSqlCriteria::getCondition()
    getCondition | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getCondition()
    getCondition | in file TConditional.php, method TConditional::getCondition()
    getConfigFile | in file TSqlMapConfig.php, method TSqlMapConfig::getConfigFile()
    getConfigFile | in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::getConfigFile()
    getConfigFile | in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::getConfigFile()
    getConfigFile | in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfigBuilder::getConfigFile()
    getConfigFile | in file TSoapService.php, method TSoapService::getConfigFile()
    getConfigFile | in file TUrlMapping.php, method TUrlMapping::getConfigFile()
    getConfigFile | in file TLogRouter.php, method TLogRouter::getConfigFile()
    getConfigurationFile | in file TApplication.php, method TApplication::getConfigurationFile()
    getConfigurationFileExt | in file TApplication.php, method TApplication::getConfigurationFileExt()
    getConfigurationFileName | in file TApplication.php, method TApplication::getConfigurationFileName()
    getConfigurationType | in file TApplication.php, method TApplication::getConfigurationType()
    getConnection | in file TDbCommand.php, method TDbCommand::getConnection()
    getConnection | in file TDbTransaction.php, method TDbTransaction::getConnection()
    getConnectionClass | in file TDataSourceConfig.php, method TDataSourceConfig::getConnectionClass()
    getConnectionID | in file TLogRouter.php, method TDbLogRoute::getConnectionID()
    getConnectionID | in file TDbUserManager.php, method TDbUserManager::getConnectionID()
    getConnectionID | in file TDbCache.php, method TDbCache::getConnectionID()
    getConnectionID | in file TDataSourceConfig.php, method TDataSourceConfig::getConnectionID()
    getConnectionStatus | in file TDbConnection.php, method TDbConnection::getConnectionStatus()
    getConnectionString | in file TDbCache.php, method TDbCache::getConnectionString()
    getConnectionString | in file TDbConnection.php, method TDbConnection::getConnectionString()
    getConstraint in file TDraggable.php, method TDraggable::getConstraint()
    Determine if the element should be constrainted in one direction or not
    getConstraintKeys in file TMssqlMetaData.php, method TMssqlMetaData::getConstraintKeys()
    Gets the primary and foreign key column details for the given table.
    getConstraintKeys in file TPgsqlMetaData.php, method TPgsqlMetaData::getConstraintKeys()
    Gets the primary and foreign key column details for the given table.
    getConstraintKeys in file TMysqlMetaData.php, method TMysqlMetaData::getConstraintKeys()
    Gets the primary and foreign key column details for the given table.
    getConstraintKeys in file TOracleMetaData.php, method TOracleMetaData::getConstraintKeys()
    Gets the primary and foreign key column details for the given table.
    getContainer | in file TControl.php, method TCompositeLiteral::getContainer()
    getContainerID in file TActiveDataList.php, method TActiveDataList::getContainerID()
    Returns the id of the surrounding container (span).
    getContainerID in file TActiveMultiView.php, method TActiveMultiView::getContainerID()
    Returns the id of the surrounding container (span).
    getContent | in file THead.php, method TMetaTag::getContent()
    getContentCached | in file TOutputCache.php, method TOutputCache::getContentCached()
    getContents in file THttpResponse.php, method THttpResponse::getContents()
    Returns the content in the output buffer.
    getContentTemplate | in file TWizard.php, method TTemplatedWizardStep::getContentTemplate()
    getContentType | in file THttpRequest.php, method THttpRequest::getContentType()
    getContentType | in file THttpResponse.php, method THttpResponse::getContentType()
    getContentType in file TFeedService.php, method IFeedContentProvider::getContentType()
    Sets the content type of the feed content to be sent.
    getContext | in file TActiveRecordRelation.php, method TActiveRecordRelation::getContext()
    getContextPath | in file TTemplateManager.php, method TTemplate::getContextPath()
    getContinueBuffering | in file TFlushOutput.php, method TFlushOutput::getContinueBuffering()
    getControl | in file TControlAdapter.php, method TControlAdapter::getControl()
    getControl | in file TActiveListControlAdapter.php, method TActiveListItemCollection::getControl()
    getControl | in file TBaseActiveControl.php, method TBaseActiveControl::getControl()
    getControlCssClass | in file TBaseValidator.php, method TBaseValidator::getControlCssClass()
    getControlID | in file TTriggeredCallback.php, method TTriggeredCallback::getControlID()
    getControls in file TDropContainer.php, method TDropContainer::getControls()
    Override parent implementation to return the container control collection.
    getControls | in file TControl.php, method TControl::getControls()
    getControlStage in file TControl.php, method TControl::getControlStage()
    Gets the lifecycle step the control is currently at.
    getControlState in file TControl.php, method TControl::getControlState()
    Returns a controlstate value.
    getControlToCompare | in file TCompareValidator.php, method TCompareValidator::getControlToCompare()
    getControlToPaginate | in file TPager.php, method TPager::getControlToPaginate()
    getControlToValidate | in file TBaseValidator.php, method TBaseValidator::getControlToValidate()
    getControlValue | in file TScaffoldInputBase.php, method TScaffoldInputBase::getControlValue()
    getControlValue | in file TMssqlScaffoldInput.php, method TMssqlScaffoldInput::getControlValue()
    getControlValue | in file TIbmScaffoldInput.php, method TIbmScaffoldInput::getControlValue()
    getControlValue | in file TSqliteScaffoldInput.php, method TSqliteScaffoldInput::getControlValue()
    getControlValue | in file TPgsqlScaffoldInput.php, method TPgsqlScaffoldInput::getControlValue()
    getControlValue | in file TMysqlScaffoldInput.php, method TMysqlScaffoldInput::getControlValue()
    getCookie | in file THttpSession.php, method THttpSession::getCookie()
    getCookieMode | in file THttpSession.php, method THttpSession::getCookieMode()
    getCookies | in file THttpResponse.php, method THttpResponse::getCookies()
    getCookies | in file THttpRequest.php, method THttpRequest::getCookies()
    getCoordinates | in file TImageMap.php, method THotSpot::getCoordinates()
    getCoordinates | in file TImageMap.php, method TCircleHotSpot::getCoordinates()
    getCoordinates | in file TImageMap.php, method TPolygonHotSpot::getCoordinates()
    getCoordinates | in file TImageMap.php, method TRectangleHotSpot::getCoordinates()
    getCount | in file TDummyDataSource.php, method TDummyDataSource::getCount()
    getCount | in file TPagedList.php, method TPagedList::getCount()
    getCount | in file TPagedDataSource.php, method TPagedDataSource::getCount()
    getCount | in file TStack.php, method TStack::getCount()
    getCount | in file TQueue.php, method TQueue::getCount()
    getCount | in file THttpRequest.php, method THttpRequest::getCount()
    getCount | in file TList.php, method TList::getCount()
    getCount | in file THttpSession.php, method THttpSession::getCount()
    getCount | in file TMap.php, method TMap::getCount()
    getCount | in file TPriorityMap.php, method TPriorityMap::getCount()
    getCount in file TPriorityList.php, method TPriorityList::getCount()
    Returns the total number of items in the list
    getCriteria in file TTableGateway.php, method TTableGateway::getCriteria()
    Create a new TSqlCriteria object from a string $criteria. The $args are additional parameters and are used in place of the $parameters if $parameters is not an array and $args is an arrary.
    getCriteria | in file TActiveRecordRelation.php, method TActiveRecordRelation::getCriteria()
    getCriteria | in file TDataGatewayCommand.php, method TDataGatewayEventParameter::getCriteria()
    getCssClass | in file TWebControl.php, method TWebControl::getCssClass()
    getCssClass | in file TAccordion.php, method TAccordion::getCssClass()
    getCssClass | in file TTabPanel.php, method TTabPanel::getCssClass()
    getCssClass | in file TStyle.php, method TStyle::getCssClass()
    getCssClass | in file TLogRouter.php, method TBrowserLogRoute::getCssClass()
    getCssClassDiff | in file TActiveControlAdapter.php, method TStyleDiff::getCssClassDiff()
    getCssUrl | in file TKeyboard.php, method TKeyboard::getCssUrl()
    getCssUrl | in file TAccordion.php, method TAccordion::getCssUrl()
    getCssUrl | in file TTabPanel.php, method TTabPanel::getCssUrl()
    getCssUrl | in file TSlider.php, method TSlider::getCssUrl()
    getCtrlKey | in file TDropContainer.php, method TDropContainerEventParameter::getCtrlKey()
    getCulturalOptions in file TDatePicker.php, method TDatePicker::getCulturalOptions()
    Get javascript localization options, e.g. month and weekday names.
    getCulture in file TI18NControl.php, method TI18NControl::getCulture()
    Get the specific culture for this control.
    getCulture in file THtmlArea.php, method THtmlArea::getCulture()
    Gets the current culture.
    getCulture | in file TGlobalization.php, method TGlobalization::getCulture()
    getCulture in file TDatePicker.php, method TDatePicker::getCulture()
    Gets the current culture.
    getCultureVariants in file TGlobalization.php, method TGlobalization::getCultureVariants()
    Gets all the variants of a specific culture. If the parameter $culture is null, the current culture is used.
    getCurrency | in file TNumberFormat.php, method TNumberFormat::getCurrency()
    getCurrentCulture | in file TDatePicker.php, method TDatePicker::getCurrentCulture()
    getCurrentPageIndex | in file TPagedList.php, method TPagedList::getCurrentPageIndex()
    getCurrentPageIndex | in file TPagedDataSource.php, method TPagedDataSource::getCurrentPageIndex()
    getCurrentPageIndex | in file TDataBoundControl.php, method TDataBoundControl::getCurrentPageIndex()
    getCurrentPageIndex | in file TPager.php, method TPager::getCurrentPageIndex()
    getCurrentRecord | in file TScaffoldEditView.php, method TScaffoldEditView::getCurrentRecord()
    getCurrentStepIndex | in file TWizard.php, method TWizardNavigationEventParameter::getCurrentStepIndex()
    getCurrentTransaction | in file TDbConnection.php, method TDbConnection::getCurrentTransaction()
    getCustomData in file TControl.php, method TControl::getCustomData()
    Returns custom data associated with this control.
    getCustomPaging | in file TPagedList.php, method TPagedList::getCustomPaging()
    getCustomPluginPath | in file THtmlArea.php, method THtmlArea::getCustomPluginPath()
    getCustomStyle | in file TStyle.php, method TStyle::getCustomStyle()
    getCustomTranslations | in file TReCaptcha.php, method TReCaptcha::getCustomTranslations()
    getData | in file TDataGrid.php, method TDataGridItem::getData()
    getData in file TInlineFrame.php, method TInlineFrame::getData()
    Returns the URL that this iframe will load content from This method is required by IDataRenderer.
    getData | in file TPagedList.php, method TPagedListFetchDataEventParameter::getData()
    getData in file TImage.php, method TImage::getData()
    Returns the URL of the image file.
    getData in file TListControl.php, method TListControl::getData()
    Returns the value of the selected item with the lowest cardinal index.
    getData in file THyperLink.php, method THyperLink::getData()
    Returns the URL to link to when the THyperLink component is clicked.
    getData in file TButton.php, method TButton::getData()
    Returns the caption of the button.
    getData | in file TRepeater.php, method TRepeaterItem::getData()
    getData | in file interfaces.php, method IDataRenderer::getData()
    getData in file TTextBox.php, method TTextBox::getData()
    Returns the text content of the TTextBox control.
    getData in file TCheckBox.php, method TCheckBox::getData()
    Returns the value indicating whether the checkbox is checked.
    getData | in file TDataRenderer.php, method TDataRenderer::getData()
    getData in file TNumberFormat.php, method TNumberFormat::getData()
    Get the numberic value for this control.
    getData in file TDateFormat.php, method TDateFormat::getData()
    Get the date-time value for this control.
    getData | in file TDataList.php, method TDataListItem::getData()
    getData in file TLiteral.php, method TLiteral::getData()
    Returns the static text of the TLiteral.
    getData in file THiddenField.php, method THiddenField::getData()
    Returns the value of the hidden field.
    getData in file TSlider.php, method TSlider::getData()
    Returns the value of the TSlider control.
    getData in file TLabel.php, method TLabel::getData()
    Returns the text value of the label.
    getData in file TDatePicker.php, method TDatePicker::getData()
    Returns the timestamp selected by the user.
    getData in file TLinkButton.php, method TLinkButton::getData()
    Returns the caption of the button.
    getData in file TTableCell.php, method TTableCell::getData()
    Returns the text content of the table cell.
    getDatabase in file TDataSourceConfig.php, method TDataSourceConfig::getDatabase()
    Alias for getDbConnection().
    getDataChanged in file TAccordion.php, method TAccordion::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
    getDataChanged in file TDropDownList.php, method TDropDownList::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
    getDataChanged in file TTabPanel.php, method TTabPanel::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
    getDataChanged in file TListBox.php, method TListBox::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
    getDataChanged in file TFileUpload.php, method TFileUpload::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
    getDataChanged in file TImageButton.php, method TImageButton::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
    getDataChanged | in file TControl.php, method IPostBackDataHandler::getDataChanged()
    getDataChanged in file THiddenField.php, method THiddenField::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
    getDataChanged in file TCheckBoxList.php, method TCheckBoxList::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
    getDataChanged in file TTextBox.php, method TTextBox::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
    getDataChanged in file TCheckBox.php, method TCheckBox::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
    getDataChanged in file TSlider.php, method TSlider::getDataChanged()
    Returns a value indicating whether postback has caused the control data change.
    getDataField | in file TCheckBoxColumn.php, method TCheckBoxColumn::getDataField()
    getDataField | in file TBoundColumn.php, method TBoundColumn::getDataField()
    getDataField | in file TLiteralColumn.php, method TLiteralColumn::getDataField()
    getDataFieldValue in file TBaseDataList.php, method TBaseDataList::getDataFieldValue()
    Returns the value of the data at the specified field.
    getDataFieldValue in file TDataFieldAccessor.php, method TDataFieldAccessor::getDataFieldValue()
    Evaluates the data value at the specified field.
    getDataFieldValue in file TDataGridColumn.php, method TDataGridColumn::getDataFieldValue()
    Fetches the value of the data at the specified field.
    getDataFieldValue in file TRepeater.php, method TRepeater::getDataFieldValue()
    Returns the value of the data at the specified field.
    getDataFormatString | in file TLiteralColumn.php, method TLiteralColumn::getDataFormatString()
    getDataFormatString | in file TBoundColumn.php, method TBoundColumn::getDataFormatString()
    getDataGrid | in file TDataGrid.php, method TDataGridPager::getDataGrid()
    getDataGroupField | in file TListControl.php, method TListControl::getDataGroupField()
    getDataImageUrlField | in file TButtonColumn.php, method TButtonColumn::getDataImageUrlField()
    getDataImageUrlFormatString | in file TButtonColumn.php, method TButtonColumn::getDataImageUrlFormatString()
    getDataItem in file TRepeater.php, method TRepeaterItem::getDataItem()
    This property is deprecated since v3.1.0.
    getDataItem in file TDataList.php, method TDataListItem::getDataItem()
    This property is deprecated since v3.1.0.
    getDataItem in file TDataGrid.php, method TDataGridItem::getDataItem()
    This property is deprecated since v3.1.0.
    getDataKeyField | in file TRepeater.php, method TRepeater::getDataKeyField()
    getDataKeyField | in file TBaseDataList.php, method TBaseDataList::getDataKeyField()
    getDataKeys | in file TRepeater.php, method TRepeater::getDataKeys()
    getDataKeys | in file TBaseDataList.php, method TBaseDataList::getDataKeys()
    getDataMember | in file TDataBoundControl.php, method TDataBoundControl::getDataMember()
    getDataNavigateUrlField | in file THyperLinkColumn.php, method THyperLinkColumn::getDataNavigateUrlField()
    getDataNavigateUrlFormatString | in file THyperLinkColumn.php, method THyperLinkColumn::getDataNavigateUrlFormatString()
    getDataSource | in file TDataSourceView.php, method TDataSourceView::getDataSource()
    getDataSource | in file TPagedDataSource.php, method TPagedDataSource::getDataSource()
    getDataSource | in file TDataBoundControl.php, method TDataBoundControl::getDataSource()
    getDataSourceCount | in file TPagedDataSource.php, method TPagedDataSource::getDataSourceCount()
    getDataSourceID | in file TDataBoundControl.php, method TDataBoundControl::getDataSourceID()
    getDataSourceIndex | in file TDataGrid.php, method TDataGridItem::getDataSourceIndex()
    getDataSourceView | in file TDataBoundControl.php, method TDataBoundControl::getDataSourceView()
    getDataTextField | in file THyperLinkColumn.php, method THyperLinkColumn::getDataTextField()
    getDataTextField | in file TListControl.php, method TListControl::getDataTextField()
    getDataTextField | in file TDropDownListColumn.php, method TDropDownListColumn::getDataTextField()
    getDataTextField | in file TButtonColumn.php, method TButtonColumn::getDataTextField()
    getDataTextFormatString | in file TListControl.php, method TListControl::getDataTextFormatString()
    getDataTextFormatString | in file THyperLinkColumn.php, method THyperLinkColumn::getDataTextFormatString()
    getDataTextFormatString | in file TDropDownListColumn.php, method TDropDownListColumn::getDataTextFormatString()
    getDataTextFormatString | in file TButtonColumn.php, method TButtonColumn::getDataTextFormatString()
    getDataType | in file TCompareValidator.php, method TCompareValidator::getDataType()
    getDataType | in file TDataTypeValidator.php, method TDataTypeValidator::getDataType()
    getDataType | in file TRangeValidator.php, method TRangeValidator::getDataType()
    getDataValueField | in file TListControl.php, method TListControl::getDataValueField()
    getDataValueField | in file TDropDownListColumn.php, method TDropDownListColumn::getDataValueField()
    getDate | in file TDateTimeStamp.php, method TDateTimeStamp::getDate()
    getDate | in file TDatePicker.php, method TDatePicker::getDate()
    getDateFormat | in file TCompareValidator.php, method TCompareValidator::getDateFormat()
    getDateFormat | in file TDatePicker.php, method TDatePicker::getDateFormat()
    getDateFormat | in file TDataTypeValidator.php, method TDataTypeValidator::getDateFormat()
    getDateFormat | in file TRangeValidator.php, method TRangeValidator::getDateFormat()
    getDateFromPostData in file TDatePicker.php, method TDatePicker::getDateFromPostData()
    Loads date from drop down list data.
    getDatePickerButtonID in file TDatePicker.php, method TDatePicker::getDatePickerButtonID()
    Gets the ID for the date picker trigger button.
    getDatePickerOptions in file TActiveDatePicker.php, method TActiveDatePicker::getDatePickerOptions()
    Get javascript date picker options.
    getDatePickerOptions in file TDatePicker.php, method TDatePicker::getDatePickerOptions()
    Get javascript date picker options.
    getDateTimeValue | in file TSqliteScaffoldInput.php, method TSqliteScaffoldInput::getDateTimeValue()
    getDateTimeValue | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::getDateTimeValue()
    getDayMonthYearOrdering | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::getDayMonthYearOrdering()
    getDayofWeek in file TDateTimeStamp.php, method TDateTimeStamp::getDayofWeek()
    Gets day of week, 0 = Sunday,... 6=Saturday.
    getDayPattern | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::getDayPattern()
    getDbConnection in file TActiveRecord.php, method TActiveRecord::getDbConnection()
    Gets the current Db connection, the connection object is obtained from the TActiveRecordManager if connection is currently null.
    getDbConnection | in file TLogRouter.php, method TDbLogRoute::getDbConnection()
    getDbConnection in file TDbUserManager.php, method TDbUser::getDbConnection()
    Returns a database connection that may be used to retrieve data from database.
    getDbConnection | in file TDbCommandBuilder.php, method TDbCommandBuilder::getDbConnection()
    getDbConnection | in file TDbCache.php, method TDbCache::getDbConnection()
    getDbConnection | in file TDataGatewayCommand.php, method TDataGatewayCommand::getDbConnection()
    getDbConnection | in file TDbUserManager.php, method TDbUserManager::getDbConnection()
    getDbConnection | in file TSqlMapManager.php, method TSqlMapManager::getDbConnection()
    getDbConnection | in file TActiveRecordManager.php, method TActiveRecordManager::getDbConnection()
    getDbConnection | in file TDbMetaData.php, method TDbMetaData::getDbConnection()
    getDbConnection | in file TSqlMapGateway.php, method TSqlMapGateway::getDbConnection()
    getDbConnection in file TDataSourceConfig.php, method TDataSourceConfig::getDbConnection()
    Gets the TDbConnection from another module if setConnectionID is supplied and valid. Otherwise, a connection of type given by setConnectionClass is created.
    getDbConnection | in file TTableGateway.php, method TTableGateway::getDbConnection()
    getDbFile | in file TSqliteCache.php, method TSqliteCache::getDbFile()
    getDbMetaData | in file TDbConnection.php, method TDbConnection::getDbMetaData()
    getDbType | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::getDbType()
    getDbType | in file TParameterProperty.php, method TParameterProperty::getDbType()
    getDbType | in file TDbTableColumn.php, method TDbTableColumn::getDbType()
    getDbTypeHandler | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandlerRegistry::getDbTypeHandler()
    getDbTypeValues | in file TMysqlTableColumn.php, method TMysqlTableColumn::getDbTypeValues()
    getDebugStatementText | in file TDbCommand.php, method TDbCommand::getDebugStatementText()
    getDecayRate in file TValueTriggeredCallback.php, method TValueTriggeredCallback::getDecayRate()
    Gets the decay rate between callbacks. Default is 0;
    getDecorator | in file TWebControl.php, method TWebControl::getDecorator()
    getDefaultButton | in file TForm.php, method TForm::getDefaultButton()
    getDefaultButton | in file TPanel.php, method TPanel::getDefaultButton()
    getDefaultButtonOptions | in file TClientScriptManager.php, method TClientScriptManager::getDefaultButtonOptions()
    getDefaultCharset | in file TGlobalization.php, method TGlobalization::getDefaultCharset()
    getDefaultClientSideOptions in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getDefaultClientSideOptions()
    Returns an array of default callback client-side options. The default options are obtained from the client-side options of a TCallbackOptions control with ID specified by setCallbackOptions.
    getDefaultControlValue | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::getDefaultControlValue()
    getDefaultCulture | in file TGlobalization.php, method TGlobalization::getDefaultCulture()
    getDefaultLabelID | in file TActiveRadioButton.php, method TActiveRadioButton::getDefaultLabelID()
    getDefaultLabelID | in file TActiveCheckBox.php, method TActiveCheckBox::getDefaultLabelID()
    getDefaultMappingClass | in file TUrlMapping.php, method TUrlMapping::getDefaultMappingClass()
    getDefaultPage | in file TPageService.php, method TPageService::getDefaultPage()
    getDefaultPageUrl | in file TPageService.php, method TPageService::getDefaultPageUrl()
    getDefaultPriority | in file TPriorityList.php, method TPriorityList::getDefaultPriority()
    getDefaultPriority | in file TPriorityMap.php, method TPriorityMap::getDefaultPriority()
    getDefaultSchema | in file TPgsqlMetaData.php, method TPgsqlMetaData::getDefaultSchema()
    getDefaultSchema | in file TOracleMetaData.php, method TOracleMetaData::getDefaultSchema()
    getDefaultStyle | in file TScaffoldBase.php, method TScaffoldBase::getDefaultStyle()
    getDefaultTagName | in file THeader5.php, method THeader5::getDefaultTagName()
    getDefaultTagName in file THtmlElement.php, method THtmlElement::getDefaultTagName()
    This is the default tag when no other is specified
    getDefaultTagName | in file THeader4.php, method THeader4::getDefaultTagName()
    getDefaultTagName | in file THeader2.php, method THeader2::getDefaultTagName()
    getDefaultTagName | in file THeader3.php, method THeader3::getDefaultTagName()
    getDefaultTagName | in file THeader6.php, method THeader6::getDefaultTagName()
    getDefaultTagName | in file THeader1.php, method THeader1::getDefaultTagName()
    getDefaultText in file TNumberFormat.php, method TNumberFormat::getDefaultText()
    Get the default text value for this control.
    getDefaultText in file TDateFormat.php, method TDateFormat::getDefaultText()
    Get the default text value for this control.
    getDefaultValue | in file TDbTableColumn.php, method TDbTableColumn::getDefaultValue()
    getDependencies | in file TCache.php, method TChainedCacheDependency::getDependencies()
    getDescriptionUrl | in file TImage.php, method TImage::getDescriptionUrl()
    getDescriptionUrl | in file TInlineFrame.php, method TInlineFrame::getDescriptionUrl()
    getDetectedLanguage | in file TGlobalizationAutoDetect.php, method TGlobalizationAutoDetect::getDetectedLanguage()
    getDifference | in file TActiveControlAdapter.php, method TViewStateDiff::getDifference()
    getDifference | in file TActiveControlAdapter.php, method TStyleDiff::getDifference()
    getDifference | in file TActiveControlAdapter.php, method TScalarDiff::getDifference()
    getDifference | in file TActiveControlAdapter.php, method TMapCollectionDiff::getDifference()
    getDirection | in file TSlider.php, method TSlider::getDirection()
    getDirection | in file TPanelStyle.php, method TPanelStyle::getDirection()
    getDirection | in file TPanel.php, method TPanel::getDirection()
    getDirective | in file TTemplateManager.php, method TTemplate::getDirective()
    getDirectory | in file TCache.php, method TDirectoryCacheDependency::getDirectory()
    getDiscriminator | in file TResultMap.php, method TResultMap::getDiscriminator()
    getDisplay | in file TBaseValidator.php, method TBaseValidator::getDisplay()
    getDisplay | in file TValidationSummary.php, method TValidationSummary::getDisplay()
    getDisplay | in file TWebControl.php, method TWebControl::getDisplay()
    getDisplayMode | in file TValidationSummary.php, method TValidationSummary::getDisplayMode()
    getDisplayMode | in file TBulletedList.php, method TBulletedList::getDisplayMode()
    getDisplayStyle | in file TStyle.php, method TStyle::getDisplayStyle()
    getDisplayTextBox | in file TInPlaceTextBox.php, method TInPlaceTextBox::getDisplayTextBox()
    getDocumentContent | in file TXmlTransform.php, method TXmlTransform::getDocumentContent()
    getDocumentPath | in file TXmlTransform.php, method TXmlTransform::getDocumentPath()
    getDomain | in file THttpRequest.php, method THttpCookie::getDomain()
    getDragElementId | in file TDropContainer.php, method TDropContainerEventParameter::getDragElementId()
    getDriverName | in file TDbConnection.php, method TDbConnection::getDriverName()
    getDropDownDayOptions | in file TDatePicker.php, method TDatePicker::getDropDownDayOptions()
    getDroppedControl in file TDropContainer.php, method TDropContainerEventParameter::getDroppedControl()
    GetDroppedControl
    getDuration | in file TOutputCache.php, method TOutputCache::getDuration()
    getEditImageUrl | in file TEditCommandColumn.php, method TEditCommandColumn::getEditImageUrl()
    getEditItem | in file TDataList.php, method TDataList::getEditItem()
    getEditItem | in file TDataGrid.php, method TDataGrid::getEditItem()
    getEditItemIndex | in file TDataGrid.php, method TDataGrid::getEditItemIndex()
    getEditItemIndex | in file TDataList.php, method TDataList::getEditItemIndex()
    getEditItemRenderer | in file TTemplateColumn.php, method TTemplateColumn::getEditItemRenderer()
    getEditItemRenderer | in file TDataList.php, method TDataList::getEditItemRenderer()
    getEditItemRenderer | in file TBoundColumn.php, method TBoundColumn::getEditItemRenderer()
    getEditItemStyle | in file TDataGrid.php, method TDataGrid::getEditItemStyle()
    getEditItemStyle | in file TDataList.php, method TDataList::getEditItemStyle()
    getEditItemTemplate | in file TDataList.php, method TDataList::getEditItemTemplate()
    getEditItemTemplate | in file TTemplateColumn.php, method TTemplateColumn::getEditItemTemplate()
    getEditorOptions in file THtmlArea.php, method THtmlArea::getEditorOptions()
    Default editor options gives basic tool bar only.
    getEditRenderer | in file TScaffoldEditView.php, method TScaffoldEditView::getEditRenderer()
    getEditText | in file TEditCommandColumn.php, method TEditCommandColumn::getEditText()
    getEditTriggerControlID | in file TInPlaceTextBox.php, method TInPlaceTextBox::getEditTriggerControlID()
    getEditView | in file TScaffoldView.php, method TScaffoldView::getEditView()
    getEditViewControl | in file TScaffoldListView.php, method TScaffoldListView::getEditViewControl()
    getEditViewID | in file TScaffoldListView.php, method TScaffoldListView::getEditViewID()
    getElementByIdValue in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfigBuilder::getElementByIdValue()
    Get element node by ID value (try for attribute name ID as case insensitive).
    getElementByTagName | in file TXmlDocument.php, method TXmlElement::getElementByTagName()
    getElements | in file TXmlDocument.php, method TXmlElement::getElements()
    getElementsByTagName | in file TXmlDocument.php, method TXmlElement::getElementsByTagName()
    getEmails | in file TLogRouter.php, method TEmailLogRoute::getEmails()
    getEmptyRenderer | in file TRepeater.php, method TRepeater::getEmptyRenderer()
    getEmptyRenderer | in file TDataList.php, method TDataList::getEmptyRenderer()
    getEmptyTemplate | in file TRepeater.php, method TRepeater::getEmptyTemplate()
    getEmptyTemplate | in file TDataList.php, method TDataList::getEmptyTemplate()
    getEmptyTemplate | in file TDataGrid.php, method TDataGrid::getEmptyTemplate()
    getEnableCache | in file TActiveRecordConfig.php, method TActiveRecordConfig::getEnableCache()
    getEnableCache | in file TSqlMapConfig.php, method TSqlMapConfig::getEnableCache()
    getEnableCellGrouping | in file TDataGridColumn.php, method TDataGridColumn::getEnableCellGrouping()
    getEnableClientScript in file TActiveCustomValidator.php, method TActiveCustomValidator::getEnableClientScript()
    It's mandatory for the EnableClientScript to be activated or the TActiveCustomValidator won't work.
    getEnableClientScript | in file TLinkButton.php, method TLinkButton::getEnableClientScript()
    getEnableClientScript | in file TButton.php, method TButton::getEnableClientScript()
    getEnableClientScript | in file TBaseValidator.php, method TBaseValidator::getEnableClientScript()
    getEnableClientScript | in file TImageButton.php, method TImageButton::getEnableClientScript()
    getEnableClientScript | in file TTextBox.php, method TTextBox::getEnableClientScript()
    getEnableClientScript | in file TValidationSummary.php, method TValidationSummary::getEnableClientScript()
    getEnableClientScript | in file TRadioButton.php, method TRadioButton::getEnableClientScript()
    getEnableClientScript | in file TListControl.php, method TListControl::getEnableClientScript()
    getEnableClientScript | in file TReCaptchaValidator.php, method TReCaptchaValidator::getEnableClientScript()
    getEnableClientScript | in file TCheckBox.php, method TCheckBox::getEnableClientScript()
    getEnableCompression | in file THtmlArea.php, method THtmlArea::getEnableCompression()
    getEnableCookieValidation | in file THttpRequest.php, method THttpRequest::getEnableCookieValidation()
    getEnableCopyCode | in file TTextHighlighter.php, method TTextHighlighter::getEnableCopyCode()
    getEnableCustomUrl in file TUrlMapping.php, method TUrlMappingPattern::getEnableCustomUrl()
    Returns a value indicating whether to use this pattern to construct URL.
    getEnableCustomUrl in file TUrlMapping.php, method TUrlMapping::getEnableCustomUrl()
    Returns a value indicating whether to enable custom constructUrl.
    getEnabled | in file TService.php, method TService::getEnabled()
    getEnabled | in file TListItem.php, method TListItem::getEnabled()
    getEnabled | in file interfaces.php, method IService::getEnabled()
    getEnabled in file TControl.php, method TControl::getEnabled()
    Returns a value indicating whether the control is enabled.
    getEnableDefaultStyle | in file TScaffoldBase.php, method TScaffoldBase::getEnableDefaultStyle()
    getEnablePageStateUpdate | in file TCallbackClientSide.php, method TCallbackClientSide::getEnablePageStateUpdate()
    getEnableStateCompression | in file TPage.php, method TPage::getEnableStateCompression()
    getEnableStateEncryption | in file TPage.php, method TPage::getEnableStateEncryption()
    getEnableStateValidation | in file TPage.php, method TPage::getEnableStateValidation()
    getEnableTheming | in file TDataSourceControl.php, method TDataSourceControl::getEnableTheming()
    getEnableTheming | in file TControl.php, method TControl::getEnableTheming()
    getEnableTheming | in file THiddenField.php, method THiddenField::getEnableTheming()
    getEnableUpdate | in file TBaseActiveControl.php, method TBaseActiveControl::getEnableUpdate()
    getEnableViewState | in file TControl.php, method TControl::getEnableViewState()
    getEnableVisualEdit | in file THtmlArea.php, method THtmlArea::getEnableVisualEdit()
    getEncode | in file TLiteralColumn.php, method TLiteralColumn::getEncode()
    getEncode | in file TLiteral.php, method TLiteral::getEncode()
    getEncoding | in file TSoapService.php, method TSoapServer::getEncoding()
    getEncoding | in file TXmlDocument.php, method TXmlDocument::getEncoding()
    getEncryption | in file TSecurityManager.php, method TSecurityManager::getEncryption()
    getEncryptionKey | in file TSecurityManager.php, method TSecurityManager::getEncryptionKey()
    getEnctype | in file TForm.php, method TForm::getEnctype()
    getEnsureId | in file TWebControl.php, method TWebControl::getEnsureId()
    getEnumValue | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::getEnumValue()
    getEnvironmentVariables | in file THttpRequest.php, method THttpRequest::getEnvironmentVariables()
    getErrorCode in file TFileUpload.php, method TFileUpload::getErrorCode()
    Returns an error code describing the status of this file uploading.
    getErrorCode | in file TException.php, method TException::getErrorCode()
    getErrorHandler | in file TApplication.php, method TApplication::getErrorHandler()
    getErrorImage | in file TActiveFileUpload.php, method TActiveFileUpload::getErrorImage()
    getErrorMessage | in file TBaseValidator.php, method TBaseValidator::getErrorMessage()
    getErrorMessage | in file TException.php, method TException::getErrorMessage()
    getErrorMessage | in file TControl.php, method IValidator::getErrorMessage()
    getErrorMessageFile | in file TActiveRecordException.php, method TActiveRecordException::getErrorMessageFile()
    getErrorMessageFile | in file TSqlMapException.php, method TSqlMapException::getErrorMessageFile()
    getErrorMessageFile | in file TException.php, method TException::getErrorMessageFile()
    getErrorMessages in file TValidationSummary.php, method TValidationSummary::getErrorMessages()
    Get the list of validation error messages.
    getErrorTemplate in file TErrorHandler.php, method TErrorHandler::getErrorTemplate()
    Retrieves the template used for displaying external exceptions.
    getErrorTemplatePath | in file TErrorHandler.php, method TErrorHandler::getErrorTemplatePath()
    getEventHandlers in file TComponent.php, method TComponent::getEventHandlers()
    Returns the list of attached event handlers for an event.
    getEventName | in file TEventTriggeredCallback.php, method TEventTriggeredCallback::getEventName()
    getEvents | in file TComponent.php, method TComponentReflection::getEvents()
    getEveryoneApplied | in file TAuthorizationRule.php, method TAuthorizationRule::getEveryoneApplied()
    getExceptionTemplate in file TErrorHandler.php, method TErrorHandler::getExceptionTemplate()
    Retrieves the template used for displaying internal exceptions.
    getExpire | in file THttpRequest.php, method THttpCookie::getExpire()
    getExpression | in file TExpression.php, method TExpression::getExpression()
    getExtends | in file TResultMap.php, method TResultMap::getExtends()
    getExtends | in file TSqlMapStatement.php, method TSqlMapStatement::getExtends()
    getExtends | in file TParameterMap.php, method TParameterMap::getExtends()
    getExternalConfigurations | in file TApplication.php, method TApplicationConfiguration::getExternalConfigurations()
    getExternalConfigurations | in file TPageService.php, method TPageConfiguration::getExternalConfigurations()
    getExternalControlID | in file TInPlaceTextBox.php, method TInPlaceTextBox::getExternalControlID()
    getFalseTemplate | in file TConditional.php, method TConditional::getFalseTemplate()
    getFeedContent | in file TFeedService.php, method IFeedContentProvider::getFeedContent()
    getFields | in file TScaffoldSearch.php, method TScaffoldSearch::getFields()
    getFileName | in file TFileUpload.php, method TFileUpload::getFileName()
    getFileName | in file TCache.php, method TFileCacheDependency::getFileName()
    getFileSize | in file TFileUpload.php, method TFileUpload::getFileSize()
    getFileType | in file TFileUpload.php, method TFileUpload::getFileType()
    getFindCommand in file TDataGatewayCommand.php, method TDataGatewayCommand::getFindCommand()
    Build the find command from the criteria. Limit, Offset and Ordering are applied if applicable.
    getFinishCompleteButtonStyle | in file TWizard.php, method TWizard::getFinishCompleteButtonStyle()
    getFinishDestinationUrl | in file TWizard.php, method TWizard::getFinishDestinationUrl()
    getFinishNavigation | in file TWizard.php, method TWizard::getFinishNavigation()
    getFinishNavigationTemplate | in file TWizard.php, method TWizard::getFinishNavigationTemplate()
    getFinishPreviousButtonStyle | in file TWizard.php, method TWizard::getFinishPreviousButtonStyle()
    getFirebugLoggingFunction | in file TLogRouter.php, method TFirebugLogRoute::getFirebugLoggingFunction()
    getFirstBulletNumber | in file TBulletedList.php, method TBulletedList::getFirstBulletNumber()
    getFirstDayOfWeek | in file TDatePicker.php, method TDatePicker::getFirstDayOfWeek()
    getFirstIndexInPage | in file TPagedDataSource.php, method TPagedDataSource::getFirstIndexInPage()
    getFirstPageImageUrl | in file TPager.php, method TPager::getFirstPageImageUrl()
    getFirstPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getFirstPageText()
    getFirstPageText | in file TPager.php, method TPager::getFirstPageText()
    getFkField | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getFkField()
    getFlushInterval | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::getFlushInterval()
    getFlushInterval | in file TDbCache.php, method TDbCache::getFlushInterval()
    getFlushScriptFiles | in file TClientScript.php, method TClientScript::getFlushScriptFiles()
    getFocusElementID in file TBaseValidator.php, method TBaseValidator::getFocusElementID()
    Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
    getFocusOnError | in file TBaseValidator.php, method TBaseValidator::getFocusOnError()
    getFont | in file TWebControl.php, method TWebControl::getFont()
    getFont | in file TStyle.php, method TStyle::getFont()
    getFontFile | in file TCaptcha.php, method TCaptcha::getFontFile()
    getFooter | in file TDataList.php, method TDataList::getFooter()
    getFooter | in file TDataGrid.php, method TDataGrid::getFooter()
    getFooter | in file TRepeater.php, method TRepeater::getFooter()
    getFooterRenderer | in file TRepeater.php, method TRepeater::getFooterRenderer()
    getFooterRenderer | in file TDataGridColumn.php, method TDataGridColumn::getFooterRenderer()
    getFooterRenderer | in file TDataList.php, method TDataList::getFooterRenderer()
    getFooterStyle | in file TDataList.php, method TDataList::getFooterStyle()
    getFooterStyle | in file TDataGridColumn.php, method TDataGridColumn::getFooterStyle()
    getFooterStyle | in file TDataGrid.php, method TDataGrid::getFooterStyle()
    getFooterTemplate | in file TDataList.php, method TDataList::getFooterTemplate()
    getFooterTemplate | in file TTemplateColumn.php, method TTemplateColumn::getFooterTemplate()
    getFooterTemplate | in file TRepeater.php, method TRepeater::getFooterTemplate()
    getFooterText | in file TDataGridColumn.php, method TDataGridColumn::getFooterText()
    getForControl | in file TKeyboard.php, method TKeyboard::getForControl()
    getForControl | in file TLabel.php, method TLabel::getForControl()
    getForeColor | in file TStyle.php, method TStyle::getForeColor()
    getForeColor | in file TWebControl.php, method TWebControl::getForeColor()
    getForeignCommandBuilder | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getForeignCommandBuilder()
    getForeignConstraints in file TMssqlMetaData.php, method TMssqlMetaData::getForeignConstraints()
    Gets foreign relationship constraint keys and table name
    getForeignConstraints in file TMysqlMetaData.php, method TMysqlMetaData::getForeignConstraints()
    Gets foreign relationship constraint keys and table name
    getForeignKeys | in file TOracleTableInfo.php, method TOracleTableInfo::getForeignKeys()
    getForeignKeys in file TOracleMetaData.php, method TOracleMetaData::getForeignKeys()
    Gets foreign relationship constraint keys and table name
    getForeignKeys | in file TDbTableInfo.php, method TDbTableInfo::getForeignKeys()
    getForeignKeys | in file TSqliteMetaData.php, method TSqliteMetaData::getForeignKeys()
    getForeignKeys in file TPgsqlMetaData.php, method TPgsqlMetaData::getForeignKeys()
    Gets foreign relationship constraint keys and table name
    getForeignRecordClass | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getForeignRecordClass()
    getForeignRecordFinder | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getForeignRecordFinder()
    getForeignTable | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getForeignTable()
    getForm | in file TPage.php, method TPage::getForm()
    getFormattedDate in file TDateFormat.php, method TDateFormat::getFormattedDate()
    Renders the localized version of the date-time value.
    getFormattedValue in file TNumberFormat.php, method TNumberFormat::getFormattedValue()
    Formats the localized number, be it currency or decimal, or percentage.
    getFragment | in file THttpRequest.php, method TUri::getFragment()
    getFrameUrl | in file TInlineFrame.php, method TInlineFrame::getFrameUrl()
    getFrameworkPath | in file PradoBase.php, method PradoBase::getFrameworkPath()
    getFrequency | in file TAutoComplete.php, method TAutoComplete::getFrequency()
    getFromYear | in file TDatePicker.php, method TDatePicker::getFromYear()
    getGatewayClass | in file TActiveRecordConfig.php, method TActiveRecordConfig::getGatewayClass()
    getGatewayClass | in file TActiveRecordManager.php, method TActiveRecordManager::getGatewayClass()
    getGCProbability | in file THttpSession.php, method THttpSession::getGCProbability()
    getGenerate | in file TSqlMapStatement.php, method TSqlMapSelect::getGenerate()
    getGhosting in file TDraggable.php, method TDraggable::getGhosting()
    Determine if the element should be cloned when dragged If true, Clones the element and drags the clone, leaving the original in place until the clone is dropped.
    getGlobalization | in file TApplication.php, method TApplication::getGlobalization()
    getGlobalState in file TApplication.php, method TApplication::getGlobalState()
    Returns a global value.
    getGMTDiff | in file TDateTimeStamp.php, method TDateTimeStamp::getGMTDiff()
    getGridLines | in file TBaseDataList.php, method TBaseDataList::getGridLines()
    getGridLines | in file TStyle.php, method TTableStyle::getGridLines()
    getGridLines | in file TTable.php, method TTable::getGridLines()
    getGroupBy | in file TResultMap.php, method TResultMap::getGroupBy()
    getGroupingText | in file TPanel.php, method TPanel::getGroupingText()
    getGroupLabel | in file TLogRouter.php, method TFirePhpLogRoute::getGroupLabel()
    getGroupName | in file TRadioButton.php, method TRadioButton::getGroupName()
    getGuestApplied | in file TAuthorizationRule.php, method TAuthorizationRule::getGuestApplied()
    getGuestName | in file IUserManager.php, method IUserManager::getGuestName()
    getGuestName | in file TDbUserManager.php, method TDbUserManager::getGuestName()
    getGuestName | in file TUserManager.php, method TUserManager::getGuestName()
    getHalfRatingInterval | in file TRatingList.php, method TRatingList::getHalfRatingInterval()
    getHandle in file TDraggable.php, method TDraggable::getHandle()
    Get the handle id or css class
    getHasAdapter | in file TControl.php, method TControl::getHasAdapter()
    getHasAdapter | in file THttpResponse.php, method THttpResponse::getHasAdapter()
    getHasAttribute | in file TXmlDocument.php, method TXmlElement::getHasAttribute()
    getHasAttributes | in file TImageMap.php, method THotSpot::getHasAttributes()
    getHasAttributes | in file TListItem.php, method TListItem::getHasAttributes()
    getHasAttributes | in file TControl.php, method TControl::getHasAttributes()
    getHasChanged in file TCache.php, method TApplicationStateCacheDependency::getHasChanged()
    Performs the actual dependency checking.
    getHasChanged in file TCache.php, method TChainedCacheDependency::getHasChanged()
    Performs the actual dependency checking.
    getHasChanged in file TCache.php, method TDirectoryCacheDependency::getHasChanged()
    Performs the actual dependency checking.
    getHasChanged in file TCache.php, method TFileCacheDependency::getHasChanged()
    Performs the actual dependency checking.
    getHasChanged in file TCache.php, method TGlobalStateCacheDependency::getHasChanged()
    Performs the actual dependency checking.
    getHasChanged | in file interfaces.php, method ICacheDependency::getHasChanged()
    getHasChildInitialized | in file TControl.php, method TControl::getHasChildInitialized()
    getHasControls | in file TControl.php, method TControl::getHasControls()
    getHasElement | in file TXmlDocument.php, method TXmlElement::getHasElement()
    getHasFile | in file TFileUpload.php, method TFileUpload::getHasFile()
    getHasFooter in file TCheckBoxList.php, method TCheckBoxList::getHasFooter()
    Returns a value indicating whether this control contains footer item.
    getHasFooter | in file TRepeatInfo.php, method IRepeatInfoUser::getHasFooter()
    getHasFooter in file TDataList.php, method TDataList::getHasFooter()
    Returns a value indicating whether this control contains footer item.
    getHash | in file TSqlMapCacheModel.php, method TSqlMapCacheKey::getHash()
    getHashCode | in file TTemplateManager.php, method TTemplate::getHashCode()
    getHasHeader in file TCheckBoxList.php, method TCheckBoxList::getHasHeader()
    Returns a value indicating whether this control contains header item.
    getHasHeader | in file TRepeatInfo.php, method IRepeatInfoUser::getHasHeader()
    getHasHeader in file TDataList.php, method TDataList::getHasHeader()
    Returns a value indicating whether this control contains header item.
    getHasInitialized | in file TControl.php, method TControl::getHasInitialized()
    getHasItems | in file TListControl.php, method TListControl::getHasItems()
    getHasLoaded | in file TControl.php, method TControl::getHasLoaded()
    getHasLoadedPostData | in file TControl.php, method TControl::getHasLoadedPostData()
    getHasPreRendered | in file TControl.php, method TControl::getHasPreRendered()
    getHasPriority | in file TCallbackClientSide.php, method TCallbackClientSide::getHasPriority()
    getHasSeparators in file TCheckBoxList.php, method TCheckBoxList::getHasSeparators()
    Returns a value indicating whether this control contains separator items.
    getHasSeparators | in file TRepeatInfo.php, method IRepeatInfoUser::getHasSeparators()
    getHasSeparators in file TDataList.php, method TDataList::getHasSeparators()
    Returns a value indicating whether this control contains separator items.
    getHasStyle | in file TWebControl.php, method TWebControl::getHasStyle()
    getHasStyle | in file interfaces.php, method IStyleable::getHasStyle()
    getHasStyle | in file TDataListItemRenderer.php, method TDataListItemRenderer::getHasStyle()
    getHead | in file TPage.php, method TPage::getHead()
    getHeader | in file TDataGrid.php, method TDataGrid::getHeader()
    getHeader | in file TScaffoldListView.php, method TScaffoldListView::getHeader()
    getHeader | in file TDataList.php, method TDataList::getHeader()
    getHeader | in file TWizard.php, method TWizard::getHeader()
    getHeader | in file TRepeater.php, method TRepeater::getHeader()
    getHeaderCssClass | in file TAccordion.php, method TAccordion::getHeaderCssClass()
    getHeaderImageUrl | in file TDataGridColumn.php, method TDataGridColumn::getHeaderImageUrl()
    getHeaderRenderer | in file TDataList.php, method TDataList::getHeaderRenderer()
    getHeaderRenderer | in file TRepeater.php, method TRepeater::getHeaderRenderer()
    getHeaderRenderer | in file TDataGridColumn.php, method TDataGridColumn::getHeaderRenderer()
    getHeaders | in file THttpRequest.php, method THttpRequest::getHeaders()
    getHeaders | in file THttpResponse.php, method THttpResponse::getHeaders()
    getHeaderStyle | in file TWizard.php, method TWizard::getHeaderStyle()
    getHeaderStyle | in file TDataGridColumn.php, method TDataGridColumn::getHeaderStyle()
    getHeaderStyle | in file TAccordion.php, method TAccordion::getHeaderStyle()
    getHeaderStyle | in file TDataList.php, method TDataList::getHeaderStyle()
    getHeaderStyle | in file TDataGrid.php, method TDataGrid::getHeaderStyle()
    getHeaderTemplate | in file TRepeater.php, method TRepeater::getHeaderTemplate()
    getHeaderTemplate | in file TTextHighlighter.php, method TTextHighlighter::getHeaderTemplate()
    getHeaderTemplate | in file TWizard.php, method TWizard::getHeaderTemplate()
    getHeaderTemplate | in file TDataList.php, method TDataList::getHeaderTemplate()
    getHeaderTemplate | in file TTemplateColumn.php, method TTemplateColumn::getHeaderTemplate()
    getHeaderText | in file TDataGridColumn.php, method TDataGridColumn::getHeaderText()
    getHeaderText | in file TValidationSummary.php, method TValidationSummary::getHeaderText()
    getHeaderText | in file TWizard.php, method TWizard::getHeaderText()
    getHeight | in file TStyle.php, method TStyle::getHeight()
    getHeight | in file TWebControl.php, method TWebControl::getHeight()
    getHiddenFields | in file TClientScriptManager.php, method TClientScriptManager::getHiddenFields()
    getHistory | in file TWizard.php, method TWizard::getHistory()
    getHistorySize | in file TSessionPageStatePersister.php, method TSessionPageStatePersister::getHistorySize()
    getHitRatio | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::getHitRatio()
    getHorizontalAlign | in file TBaseDataList.php, method TBaseDataList::getHorizontalAlign()
    getHorizontalAlign | in file TStyle.php, method TTableStyle::getHorizontalAlign()
    getHorizontalAlign | in file TTable.php, method TTable::getHorizontalAlign()
    getHorizontalAlign | in file TStyle.php, method TTableItemStyle::getHorizontalAlign()
    getHorizontalAlign | in file TTableRow.php, method TTableRow::getHorizontalAlign()
    getHorizontalAlign | in file TPanel.php, method TPanel::getHorizontalAlign()
    getHorizontalAlign | in file TPanelStyle.php, method TPanelStyle::getHorizontalAlign()
    getHorizontalAlign | in file TTableCell.php, method TTableCell::getHorizontalAlign()
    getHost | in file TMemCache.php, method TMemCache::getHost()
    getHost | in file THttpRequest.php, method TUri::getHost()
    getHotSpotMode | in file TImageMap.php, method TImageMap::getHotSpotMode()
    getHotSpotMode | in file TImageMap.php, method THotSpot::getHotSpotMode()
    getHotSpots | in file TImageMap.php, method TImageMap::getHotSpots()
    getHoverCssClass in file TDropContainer.php, method TDropContainer::getHoverCssClass()
    Gets the Css class name used when a draggble element is hovering over this container.
    getHtmlWriterType | in file THttpResponse.php, method THttpResponse::getHtmlWriterType()
    getHttpEquiv | in file THead.php, method TMetaTag::getHttpEquiv()
    getHttpOnly | in file THttpRequest.php, method THttpCookie::getHttpOnly()
    getHttpProtocolVersion | in file THttpRequest.php, method THttpRequest::getHttpProtocolVersion()
    getID | in file THttpRequest.php, method THttpRequest::getID()
    getID | in file TModule.php, method TModule::getID()
    getID | in file TApplication.php, method TApplication::getID()
    getID | in file TService.php, method TService::getID()
    getID | in file TCachingStatement.php, method TCachingStatement::getID()
    getID | in file TMappedStatement.php, method TMappedStatement::getID()
    getID | in file TSqlMapStatement.php, method TSqlMapStatement::getID()
    getID | in file TParameterMap.php, method TParameterMap::getID()
    getID | in file TJsonService.php, method TJsonResponse::getID()
    getID | in file TSoapService.php, method TSoapServer::getID()
    getID | in file IMappedStatement.php, method IMappedStatement::getID()
    getID | in file THead.php, method TMetaTag::getID()
    getID | in file interfaces.php, method IModule::getID()
    getID | in file TDataGridColumn.php, method TDataGridColumn::getID()
    getID | in file TResultMap.php, method TResultMap::getID()
    getID | in file interfaces.php, method IService::getID()
    getID | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::getID()
    getID in file TControl.php, method TControl::getID()
    Returns the id of the control.
    getID | in file THttpSession.php, method THttpSession::getID()
    getImageAlign | in file TImage.php, method TImage::getImageAlign()
    getImageHeight | in file THyperLinkColumn.php, method THyperLinkColumn::getImageHeight()
    getImageHeight | in file THyperLink.php, method THyperLink::getImageHeight()
    getImageUrl | in file TImage.php, method TImage::getImageUrl()
    getImageUrl | in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::getImageUrl()
    getImageUrl | in file THyperLink.php, method THyperLink::getImageUrl()
    getImageUrl | in file THyperLinkColumn.php, method THyperLinkColumn::getImageUrl()
    getImageUrl | in file TButtonColumn.php, method TButtonColumn::getImageUrl()
    getImageWidth | in file THyperLink.php, method THyperLink::getImageWidth()
    getImageWidth | in file THyperLinkColumn.php, method THyperLinkColumn::getImageWidth()
    getImplementation | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::getImplementation()
    getImplementationClass | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::getImplementationClass()
    getIncludedFiles | in file TTemplateManager.php, method TTemplate::getIncludedFiles()
    getIndex | in file TBulletedList.php, method TBulletedListEventParameter::getIndex()
    getIndexKeyCondition | in file TDataGatewayCommand.php, method TDataGatewayCommand::getIndexKeyCondition()
    getIndexValues in file TActiveRecordRelation.php, method TActiveRecordRelation::getIndexValues()
    Obtain the foreign key index values from the results.
    getInfo | in file TDbTableInfo.php, method TDbTableInfo::getInfo()
    getInfo | in file TDbTableColumn.php, method TDbTableColumn::getInfo()
    getInfo | in file TOracleTableInfo.php, method TOracleTableInfo::getInfo()
    getInFormRender | in file TPage.php, method TPage::getInFormRender()
    getInitialized | in file TDataBoundControl.php, method TDataBoundControl::getInitialized()
    getInitialValue | in file TRequiredFieldValidator.php, method TRequiredFieldValidator::getInitialValue()
    getInputAttributes | in file TCheckBox.php, method TCheckBox::getInputAttributes()
    getInputMode | in file TDatePicker.php, method TDatePicker::getInputMode()
    getInputRepeater | in file TScaffoldEditView.php, method TScaffoldEditView::getInputRepeater()
    getInsertFieldBindings in file TDbCommandBuilder.php, method TDbCommandBuilder::getInsertFieldBindings()
    Returns a list of insert field name and a list of binding names.
    getInsertValues | in file TActiveRecordGateway.php, method TActiveRecordGateway::getInsertValues()
    getInstance in file TDbMetaData.php, method TDbMetaData::getInstance()
    Obtain database specific TDbMetaData class using the driver name of the database connection.
    getInstance | in file TActiveRecordManager.php, method TActiveRecordManager::getInstance()
    getIntBooleanValue | in file TMysqlScaffoldInput.php, method TMysqlScaffoldInput::getIntBooleanValue()
    getInterval | in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::getInterval()
    getInterval | in file TValueTriggeredCallback.php, method TValueTriggeredCallback::getInterval()
    getInvalidFinderResult | in file TActiveRecord.php, method TActiveRecord::getInvalidFinderResult()
    getInvalidFinderResult | in file TActiveRecordManager.php, method TActiveRecordManager::getInvalidFinderResult()
    getInvalidFinderResult | in file TActiveRecordConfig.php, method TActiveRecordConfig::getInvalidFinderResult()
    getIPRules | in file TAuthorizationRule.php, method TAuthorizationRule::getIPRules()
    getIsAfter | in file TSqlMapStatement.php, method TSqlMapSelectKey::getIsAfter()
    getIsCallback | in file TActiveCustomValidator.php, method TActiveCustomValidator::getIsCallback()
    getIsCallback | in file TPage.php, method TPage::getIsCallback()
    getIsClosed | in file TDbDataReader.php, method TDbDataReader::getIsClosed()
    getIsDataBound | in file TDataBoundControl.php, method TDataBoundControl::getIsDataBound()
    getIsDefaultButton | in file TImageButton.php, method TImageButton::getIsDefaultButton()
    getIsDefaultButton | in file TControl.php, method IButtonControl::getIsDefaultButton()
    getIsDefaultButton | in file TLinkButton.php, method TLinkButton::getIsDefaultButton()
    getIsDefaultButton | in file TButton.php, method TButton::getIsDefaultButton()
    getIsEmpty | in file TApplication.php, method TApplicationConfiguration::getIsEmpty()
    getIsEmpty | in file TFont.php, method TFont::getIsEmpty()
    getIsEnabled | in file TScaffoldInputBase.php, method TScaffoldInputBase::getIsEnabled()
    getIsExcluded | in file TDbTableColumn.php, method TDbTableColumn::getIsExcluded()
    getIsExcluded | in file TMssqlTableColumn.php, method TMssqlTableColumn::getIsExcluded()
    getIsFirstPage | in file TPagedList.php, method TPagedList::getIsFirstPage()
    getIsFirstPage | in file TPager.php, method TPager::getIsFirstPage()
    getIsFirstPage | in file TPagedDataSource.php, method TPagedDataSource::getIsFirstPage()
    getIsForeignKey | in file TDbTableColumn.php, method TDbTableColumn::getIsForeignKey()
    getIsGuest | in file TUser.php, method TUser::getIsGuest()
    getIsGuest | in file interfaces.php, method IUser::getIsGuest()
    getIsLastPage | in file TPager.php, method TPager::getIsLastPage()
    getIsLastPage | in file TSqlMapPagedList.php, method TSqlMapPagedList::getIsLastPage()
    getIsLastPage | in file TPagedList.php, method TPagedList::getIsLastPage()
    getIsLastPage | in file TPagedDataSource.php, method TPagedDataSource::getIsLastPage()
    getIsLoadingPostData | in file TPage.php, method TPage::getIsLoadingPostData()
    getIsMiddlePage | in file TSqlMapPagedList.php, method TSqlMapPagedList::getIsMiddlePage()
    getIsMultiSelect | in file TRadioButtonList.php, method TRadioButtonList::getIsMultiSelect()
    getIsMultiSelect | in file TListControl.php, method TListControl::getIsMultiSelect()
    getIsMultiSelect | in file TCheckBoxList.php, method TCheckBoxList::getIsMultiSelect()
    getIsMultiSelect | in file TListBox.php, method TListBox::getIsMultiSelect()
    getIsMutated in file THtmlElement.php, method THtmlElement::getIsMutated()
    This tells you if this TagName has deviated from the original
    getIsNamedParameters | in file TSqlCriteria.php, method TSqlCriteria::getIsNamedParameters()
    getIsNextPageAvailable | in file TSqlMapPagedList.php, method TSqlMapPagedList::getIsNextPageAvailable()
    getIsNotification | in file TRpcClient.php, method TRpcClient::getIsNotification()
    getIsPostBack | in file TPage.php, method TPage::getIsPostBack()
    getIsPreviousPageAvailable | in file TSqlMapPagedList.php, method TSqlMapPagedList::getIsPreviousPageAvailable()
    getIsPrimaryKey | in file TDbTableColumn.php, method TDbTableColumn::getIsPrimaryKey()
    getIsSecureConnection | in file THttpRequest.php, method THttpRequest::getIsSecureConnection()
    getIsSkinApplied | in file TControl.php, method TControl::getIsSkinApplied()
    getIsSourceTemplate | in file TTemplateManager.php, method TTemplate::getIsSourceTemplate()
    getIsSourceTemplateControl | in file TTemplateControl.php, method TTemplateControl::getIsSourceTemplateControl()
    getIsSourceTemplateControl in file TTemplateControlInheritable.php, method TTemplateControlInheritable::getIsSourceTemplateControl()
    A source template control loads its template from external storage, such as file, db, rather than from within another template.
    getIsStarted | in file THttpSession.php, method THttpSession::getIsStarted()
    getIsTokenExpired | in file TCaptcha.php, method TCaptcha::getIsTokenExpired()
    getIsTrackingPageState | in file TActiveControlAdapter.php, method TActiveControlAdapter::getIsTrackingPageState()
    getIsValid in file TTextBox.php, method TTextBox::getIsValid()
    Returns true if this control validated successfully.
    getIsValid | in file TBaseValidator.php, method TBaseValidator::getIsValid()
    getIsValid in file TCheckBox.php, method TCheckBox::getIsValid()
    Returns true if this control validated successfully.
    getIsValid in file TFileUpload.php, method TFileUpload::getIsValid()
    Returns true if this control validated successfully.
    getIsValid | in file TCustomValidator.php, method TServerValidateEventParameter::getIsValid()
    getIsValid in file TCheckBoxList.php, method TCheckBoxList::getIsValid()
    Returns true if this control validated successfully.
    getIsValid in file TPage.php, method TPage::getIsValid()
    Returns whether user input is valid or not.
    getIsValid | in file TActiveRecord.php, method TActiveRecordChangeEventParameter::getIsValid()
    getIsValid | in file TControl.php, method IValidator::getIsValid()
    getIsValid in file TDropDownList.php, method TDropDownList::getIsValid()
    Returns true if this control validated successfully.
    getIsValid in file THiddenField.php, method THiddenField::getIsValid()
    Returns true if this control validated successfully.
    getIsValid | in file TOutputCache.php, method TOutputCacheCheckDependencyEventParameter::getIsValid()
    getIsValid | in file TControl.php, method IValidatable::getIsValid()
    getIsValid in file TReCaptcha.php, method TReCaptcha::getIsValid()
    Returns true if this control validated successfully.
    getIsValid in file TListBox.php, method TListBox::getIsValid()
    Returns true if this control validated successfully.
    getIsView | in file TOracleTableInfo.php, method TOracleTableInfo::getIsView()
    getIsView | in file TSqliteMetaData.php, method TSqliteMetaData::getIsView()
    getIsView in file TMysqlMetaData.php, method TMysqlMetaData::getIsView()
    For MySQL version 5.0.1 or later we can use SHOW FULL TABLES http://dev.mysql.com/doc/refman/5.0/en/show-tables.html
    getIsView | in file TPgsqlMetaData.php, method TPgsqlMetaData::getIsView()
    getIsView | in file TDbTableInfo.php, method TDbTableInfo::getIsView()
    getIsView | in file TOracleMetaData.php, method TOracleMetaData::getIsView()
    getIsWildCardPattern | in file TUrlMapping.php, method TUrlMappingPattern::getIsWildCardPattern()
    getIsWsdlRequest | in file TSoapService.php, method TSoapService::getIsWsdlRequest()
    getItalic | in file TFont.php, method TFont::getItalic()
    getItem | in file TDataList.php, method TDataListItemEventParameter::getItem()
    getItem | in file TRepeater.php, method TRepeaterItemEventParameter::getItem()
    getItem | in file TDataGrid.php, method TDataGridItemEventParameter::getItem()
    getItem | in file TDataList.php, method TDataListCommandEventParameter::getItem()
    getItem | in file TDataGrid.php, method TDataGridCommandEventParameter::getItem()
    getItem | in file TRepeater.php, method TRepeaterCommandEventParameter::getItem()
    getItemCount | in file TListControl.php, method TListControl::getItemCount()
    getItemCount | in file TRepeatInfo.php, method IRepeatInfoUser::getItemCount()
    getItemCount | in file TDataGrid.php, method TDataGrid::getItemCount()
    getItemCount | in file TDataList.php, method TDataList::getItemCount()
    getItemIndex in file TItemDataRenderer.php, method TItemDataRenderer::getItemIndex()
    Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
    getItemIndex | in file TDataList.php, method TDataListItem::getItemIndex()
    getItemIndex in file TRepeater.php, method TRepeaterItem::getItemIndex()
    Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
    getItemIndex | in file TDataGrid.php, method TDataGridItem::getItemIndex()
    getItemIndex in file TDataBoundControl.php, method IItemDataRenderer::getItemIndex()
    Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
    getItemRenderer | in file TBoundColumn.php, method TBoundColumn::getItemRenderer()
    getItemRenderer | in file TTemplateColumn.php, method TTemplateColumn::getItemRenderer()
    getItemRenderer | in file TDataList.php, method TDataList::getItemRenderer()
    getItemRenderer | in file TRepeater.php, method TRepeater::getItemRenderer()
    getItems | in file TDataGrid.php, method TDataGrid::getItems()
    getItems | in file TRepeater.php, method TRepeater::getItems()
    getItems | in file TDataList.php, method TDataList::getItems()
    getItems | in file TTemplateManager.php, method TTemplate::getItems()
    getItems | in file TListControl.php, method TListControl::getItems()
    getItemStyle | in file TDataList.php, method TDataList::getItemStyle()
    getItemStyle | in file TDataGrid.php, method TDataGrid::getItemStyle()
    getItemStyle | in file TDataGridColumn.php, method TDataGridColumn::getItemStyle()
    getItemTemplate | in file TRepeater.php, method TRepeater::getItemTemplate()
    getItemTemplate | in file TTemplateColumn.php, method TTemplateColumn::getItemTemplate()
    getItemTemplate | in file TDataList.php, method TDataList::getItemTemplate()
    getItemType | in file TRepeater.php, method TRepeaterItem::getItemType()
    getItemType | in file TDataGrid.php, method TDataGridItem::getItemType()
    getItemType | in file TDataGrid.php, method TDataGridPager::getItemType()
    getItemType | in file TDataList.php, method TDataListItem::getItemType()
    getItemType | in file TDataBoundControl.php, method IItemDataRenderer::getItemType()
    getItemType | in file TItemDataRenderer.php, method TItemDataRenderer::getItemType()
    getIterator | in file TPagedList.php, method TPagedList::getIterator()
    getIterator in file TPriorityMap.php, method TPriorityMap::getIterator()
    Returns an iterator for traversing the items in the map.
    getIterator in file TQueue.php, method TQueue::getIterator()
    Returns an iterator for traversing the items in the queue.
    getIterator in file TPriorityList.php, method TPriorityList::getIterator()
    Returns an iterator for traversing the items in the list.
    getIterator | in file TPagedDataSource.php, method TPagedDataSource::getIterator()
    getIterator in file TMap.php, method TMap::getIterator()
    Returns an iterator for traversing the items in the list.
    getIterator in file TStack.php, method TStack::getIterator()
    Returns an iterator for traversing the items in the stack.
    getIterator in file TList.php, method TList::getIterator()
    Returns an iterator for traversing the items in the list.
    getIterator in file THttpRequest.php, method THttpRequest::getIterator()
    Returns an iterator for traversing the items in the list.
    getIterator | in file TDummyDataSource.php, method TDummyDataSource::getIterator()
    getIterator in file THttpSession.php, method THttpSession::getIterator()
    Returns an iterator for traversing the session variables.
    getJavascript in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getJavascript()
    Returns the javascript callback request instance. To invoke a callback
    getJavaScriptFiles | in file TThemeManager.php, method TTheme::getJavaScriptFiles()
    getJsCallbackOptions | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getJsCallbackOptions()
    getJsonContent | in file TJsonService.php, method TJsonResponse::getJsonContent()
    getKey | in file TMappedStatement.php, method TResultSetMapItemParameter::getKey()
    getKey in file TTranslate.php, method TTranslate::getKey()
    Get the key for message lookup.
    getKey in file TTranslateParameter.php, method TTranslateParameter::getKey()
    Get the parameter substitution key.
    getKeyboardCssClass | in file TKeyboard.php, method TKeyboard::getKeyboardCssClass()
    getKeyList in file TSqlMapCache.php, method TSqlMapApplicationCache::getKeyList()
    Retreive keylist from cache or create it if it doesn't exists
    getKeyListId | in file TSqlMapCache.php, method TSqlMapApplicationCache::getKeyListId()
    getKeyPrefix | in file TCache.php, method TCache::getKeyPrefix()
    getKeyPrefix | in file TCacheHttpSession.php, method TCacheHttpSession::getKeyPrefix()
    getKeyPrefix | in file TCachePageStatePersister.php, method TCachePageStatePersister::getKeyPrefix()
    getKeys | in file TMappedStatement.php, method TPostSelectBinding::getKeys()
    getKeys | in file THttpRequest.php, method THttpRequest::getKeys()
    getKeys | in file THttpSession.php, method THttpSession::getKeys()
    getKeys | in file TMap.php, method TMap::getKeys()
    getKeys in file TPriorityMap.php, method TPriorityMap::getKeys()
    Returns the keys within the map ordered through the priority of each key-value pair
    getLabelAttributes in file TActiveRadioButton.php, method TActiveRadioButton::getLabelAttributes()
    Overrides parent implementation to ensure label has ID.
    getLabelAttributes | in file TCheckBox.php, method TCheckBox::getLabelAttributes()
    getLabelAttributes in file TActiveCheckBox.php, method TActiveCheckBox::getLabelAttributes()
    Overrides parent implementation to ensure label has ID.
    getLabelClientID | in file TInPlaceTextBox.php, method TInPlaceTextBox::getLabelClientID()
    getLanguage | in file TReCaptcha.php, method TReCaptcha::getLanguage()
    getLanguage | in file TTextHighlighter.php, method TTextHighlighter::getLanguage()
    getLanguageSuffix | in file THtmlArea.php, method THtmlArea::getLanguageSuffix()
    getLastInsertID in file TDataGatewayCommand.php, method TDataGatewayCommand::getLastInsertID()
    Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
    getLastInsertID in file TDbConnection.php, method TDbConnection::getLastInsertID()
    Returns the ID of the last inserted row or sequence value.
    getLastInsertID in file TMssqlCommandBuilder.php, method TMssqlCommandBuilder::getLastInsertID()
    Overrides parent implementation. Uses "SELECT @@Identity".
    getLastInsertID in file TDbCommandBuilder.php, method TDbCommandBuilder::getLastInsertID()
    Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
    getLastInsertId | in file TTableGateway.php, method TTableGateway::getLastInsertId()
    getLastPageImageUrl | in file TPager.php, method TPager::getLastPageImageUrl()
    getLastPageText | in file TPager.php, method TPager::getLastPageText()
    getLastPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getLastPageText()
    getLazyLoad | in file TResultProperty.php, method TResultProperty::getLazyLoad()
    getLeft | in file TImageMap.php, method TRectangleHotSpot::getLeft()
    getLevelName | in file TLogRouter.php, method TLogRoute::getLevelName()
    getLevels | in file TLogRouter.php, method TLogRoute::getLevels()
    getLevelValue | in file TLogRouter.php, method TLogRoute::getLevelValue()
    getLimit | in file TPagedList.php, method TPagedListFetchDataEventParameter::getLimit()
    getLimit | in file TSqlCriteria.php, method TSqlCriteria::getLimit()
    getLineNumber | in file TException.php, method TTemplateException::getLineNumber()
    getLineNumberStyle | in file TTextHighlighter.php, method TTextHighlighter::getLineNumberStyle()
    getList | in file TMappedStatement.php, method TResultSetListItemParameter::getList()
    getList | in file TScaffoldListView.php, method TScaffoldListView::getList()
    getListClass | in file TSqlMapStatement.php, method TSqlMapStatement::getListClass()
    getListDataSource | in file TDropDownListColumn.php, method TDropDownListColumn::getListDataSource()
    getListHasChanged | in file TActiveListControlAdapter.php, method TActiveListItemCollection::getListHasChanged()
    getListTextField | in file TDropDownListColumn.php, method TDropDownListColumn::getListTextField()
    getListTextFormatString | in file TDropDownListColumn.php, method TDropDownListColumn::getListTextFormatString()
    getListValueField | in file TDropDownListColumn.php, method TDropDownListColumn::getListValueField()
    getListView | in file TScaffoldView.php, method TScaffoldView::getListView()
    getListView | in file TScaffoldSearch.php, method TScaffoldSearch::getListView()
    getListViewID | in file TScaffoldSearch.php, method TScaffoldSearch::getListViewID()
    getLocalizedCalendarInfo | in file TDatePicker.php, method TDatePicker::getLocalizedCalendarInfo()
    getLocalizedMonthNames in file TDatePicker.php, method TDatePicker::getLocalizedMonthNames()
    Returns the localized month names that depends on the month format pattern.
    getLocalizedResource in file TGlobalization.php, method TGlobalization::getLocalizedResource()
    Returns a list of possible localized files. Example
    getLocalizedTemplate in file TTemplateManager.php, method TTemplateManager::getLocalizedTemplate()
    Finds a localized template file.
    getLocalName | in file TFileUpload.php, method TFileUpload::getLocalName()
    getLogFile | in file TLogRouter.php, method TFileLogRoute::getLogFile()
    getLogger | in file PradoBase.php, method PradoBase::getLogger()
    getLoginPage | in file TAuthManager.php, method TAuthManager::getLoginPage()
    getLogPath | in file TLogRouter.php, method TFileLogRoute::getLogPath()
    getLogs in file TLogger.php, method TLogger::getLogs()
    Retrieves log messages.
    getLogTableName | in file TLogRouter.php, method TDbLogRoute::getLogTableName()
    getLowerCaseColumnNames | in file TOracleTableInfo.php, method TOracleTableInfo::getLowerCaseColumnNames()
    getLowerCaseColumnNames | in file TDbTableInfo.php, method TDbTableInfo::getLowerCaseColumnNames()
    getManager | in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::getManager()
    getManager | in file TMappedStatement.php, method TMappedStatement::getManager()
    getManager | in file TActiveRecordConfig.php, method TActiveRecordConfig::getManager()
    getManager | in file TActiveRecordGateway.php, method TActiveRecordGateway::getManager()
    getManager | in file TUrlMapping.php, method TUrlMappingPattern::getManager()
    getManager | in file TUser.php, method TUser::getManager()
    getManager | in file TCachingStatement.php, method TCachingStatement::getManager()
    getManager | in file IMappedStatement.php, method IMappedStatement::getManager()
    getManagerClass | in file TActiveRecordConfig.php, method TActiveRecordConfig::getManagerClass()
    getMap | in file TMappedStatement.php, method TResultSetMapItemParameter::getMap()
    getMappedStatement in file TSqlMapManager.php, method TSqlMapManager::getMappedStatement()
    Gets a MappedStatement by name.
    getMappedStatements | in file TSqlMapManager.php, method TSqlMapManager::getMappedStatements()
    getMapping | in file TDiscriminator.php, method TDiscriminator::getMapping()
    getMarginHeight | in file TInlineFrame.php, method TInlineFrame::getMarginHeight()
    getMarginWidth | in file TInlineFrame.php, method TInlineFrame::getMarginWidth()
    getMaster | in file TTemplateControl.php, method TTemplateControl::getMaster()
    getMasterClass | in file TTemplateControl.php, method TTemplateControl::getMasterClass()
    getMatchingIndices | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::getMatchingIndices()
    getMatchingPattern | in file TUrlMapping.php, method TUrlMapping::getMatchingPattern()
    getMaxFileSize | in file TLogRouter.php, method TFileLogRoute::getMaxFileSize()
    getMaxFileSize | in file TFileUpload.php, method TFileUpload::getMaxFileSize()
    getMaximumRows | in file TDataSourceView.php, method TDataSourceSelectParameters::getMaximumRows()
    getMaxiumNumericConstraint | in file TDbTableColumn.php, method TDbTableColumn::getMaxiumNumericConstraint()
    getMaxLength | in file TTextBox.php, method TTextBox::getMaxLength()
    getMaxLogFiles | in file TLogRouter.php, method TFileLogRoute::getMaxLogFiles()
    getMaxSelection | in file TListControlValidator.php, method TListControlValidator::getMaxSelection()
    getMaxTokenLength | in file TCaptcha.php, method TCaptcha::getMaxTokenLength()
    getMaxValue | in file TRangeValidator.php, method TRangeValidator::getMaxValue()
    getMaxValue | in file TSlider.php, method TSlider::getMaxValue()
    getMediaType | in file TStyleSheet.php, method TStyleSheet::getMediaType()
    getMetaTags | in file THead.php, method THead::getMetaTags()
    getMethod | in file TMappedStatement.php, method TPostSelectBinding::getMethod()
    getMethod | in file TForm.php, method TForm::getMethod()
    getMethods | in file TComponent.php, method TComponentReflection::getMethods()
    getMinChars | in file TAutoComplete.php, method TAutoComplete::getMinChars()
    getMinSavings | in file TMemCache.php, method TMemCache::getMinSavings()
    getMinSelection | in file TListControlValidator.php, method TListControlValidator::getMinSelection()
    getMinTokenLength | in file TCaptcha.php, method TCaptcha::getMinTokenLength()
    getMinValue | in file TSlider.php, method TSlider::getMinValue()
    getMinValue | in file TRangeValidator.php, method TRangeValidator::getMinValue()
    getMode | in file TApplication.php, method TApplication::getMode()
    getMode | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getMode()
    getMode | in file TDatePicker.php, method TDatePicker::getMode()
    getMode | in file TColorPicker.php, method TColorPicker::getMode()
    getMode | in file TPager.php, method TPager::getMode()
    getModule | in file TApplication.php, method TApplication::getModule()
    getModules in file TApplication.php, method TApplicationConfiguration::getModules()
    Returns list of module configurations.
    getModules | in file TApplication.php, method TApplication::getModules()
    getMonthPattern | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::getMonthPattern()
    getMultiView in file TWizard.php, method TWizard::getMultiView()
    Returns the multiview that holds the wizard steps.
    getName | in file THead.php, method TMetaTag::getName()
    getName | in file TThemeManager.php, method TTheme::getName()
    getName | in file TForm.php, method TForm::getName()
    getName | in file TFont.php, method TFont::getName()
    getName | in file TControl.php, method TBroadcastEventParameter::getName()
    getName | in file TDataSourceView.php, method TDataSourceView::getName()
    getName | in file THttpRequest.php, method THttpCookie::getName()
    getName | in file TUser.php, method TUser::getName()
    getName | in file interfaces.php, method IUser::getName()
    getNamingContainer | in file TControl.php, method TControl::getNamingContainer()
    getNavigateUrl | in file THyperLinkColumn.php, method THyperLinkColumn::getNavigateUrl()
    getNavigateUrl | in file THyperLink.php, method THyperLink::getNavigateUrl()
    getNavigateUrl | in file TImageMap.php, method THotSpot::getNavigateUrl()
    getNavigateUrl | in file TTabPanel.php, method TTabView::getNavigateUrl()
    getNavigateUrl | in file TAccordion.php, method TAccordionView::getNavigateUrl()
    getNavigationButtonStyle | in file TWizard.php, method TWizard::getNavigationButtonStyle()
    getNavigationContainer | in file TWizard.php, method TTemplatedWizardStep::getNavigationContainer()
    getNavigationStyle | in file TWizard.php, method TWizard::getNavigationStyle()
    getNavigationTemplate | in file TWizard.php, method TTemplatedWizardStep::getNavigationTemplate()
    getNestedResultMap | in file TResultProperty.php, method TResultProperty::getNestedResultMap()
    getNewPageIndex | in file TPager.php, method TPagerPageChangedEventParameter::getNewPageIndex()
    getNewPageIndex | in file TPagedList.php, method TPagedListFetchDataEventParameter::getNewPageIndex()
    getNewPageIndex | in file TDataGrid.php, method TDataGridPageChangedEventParameter::getNewPageIndex()
    getNewWriter | in file TCallbackEventParameter.php, method TCallbackEventParameter::getNewWriter()
    getNextButton | in file TWizard.php, method TWizardNavigationContainer::getNextButton()
    getNextPageImageUrl | in file TPager.php, method TPager::getNextPageImageUrl()
    getNextPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getNextPageText()
    getNextPageText | in file TPager.php, method TPager::getNextPageText()
    getNextStepIndex | in file TWizard.php, method TWizardNavigationEventParameter::getNextStepIndex()
    getNullConversion | in file TDbConnection.php, method TDbConnection::getNullConversion()
    getNullValue | in file TResultProperty.php, method TResultProperty::getNullValue()
    getNullValue | in file TParameterProperty.php, method TParameterProperty::getNullValue()
    getNullValue | in file TDiscriminator.php, method TDiscriminator::getNullValue()
    getNumericPageImageUrl | in file TPager.php, method TPager::getNumericPageImageUrl()
    getNumericPrecision | in file TDbTableColumn.php, method TDbTableColumn::getNumericPrecision()
    getNumericScale | in file TDbTableColumn.php, method TDbTableColumn::getNumericScale()
    getObjectHash | in file TActiveRecordRelation.php, method TActiveRecordRelation::getObjectHash()
    getObjectValue | in file TParameterMap.php, method TParameterMap::getObjectValue()
    getObserveChanges | in file TBaseValidator.php, method TValidatorClientSide::getObserveChanges()
    getObserveChanges | in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::getObserveChanges()
    getOffset | in file TSqlCriteria.php, method TSqlCriteria::getOffset()
    getOffset | in file TPagedList.php, method TPagedListFetchDataEventParameter::getOffset()
    getOffsetAndLimit in file TSqlMapPagedList.php, method TSqlMapPagedList::getOffsetAndLimit()
    Calculate the data fetch offsets and limits.
    getOffsetX | in file TDropContainer.php, method TDropContainerEventParameter::getOffsetX()
    getOKButtonText | in file TColorPicker.php, method TColorPicker::getOKButtonText()
    getOldPageIndex | in file TPagedList.php, method TPagedListPageChangedEventParameter::getOldPageIndex()
    getOnChange | in file TSlider.php, method TSliderClientScript::getOnChange()
    getOnColorSelected | in file TColorPicker.php, method TColorPickerClientSide::getOnColorSelected()
    getOnComplete | in file TCallbackClientSide.php, method TCallbackClientSide::getOnComplete()
    getOnDateChanged | in file TDatePicker.php, method TDatePickerClientScript::getOnDateChanged()
    getOnException | in file TCallbackClientSide.php, method TCallbackClientSide::getOnException()
    getOnFailure | in file TCallbackClientSide.php, method TCallbackClientSide::getOnFailure()
    getOnHideSummary | in file TValidationSummary.php, method TClientSideValidationSummaryOptions::getOnHideSummary()
    getOnInteractive | in file TCallbackClientSide.php, method TCallbackClientSide::getOnInteractive()
    getOnLoaded | in file TCallbackClientSide.php, method TCallbackClientSide::getOnLoaded()
    getOnLoading | in file TCallbackClientSide.php, method TCallbackClientSide::getOnLoading()
    getOnPreDispatch | in file TCallbackClientSide.php, method TCallbackClientSide::getOnPreDispatch()
    getOnShowSummary | in file TValidationSummary.php, method TClientSideValidationSummaryOptions::getOnShowSummary()
    getOnSlide | in file TSlider.php, method TSliderClientScript::getOnSlide()
    getOnSuccess | in file TCallbackClientSide.php, method TCallbackClientSide::getOnSuccess()
    getOnUninitialized | in file TCallbackClientSide.php, method TCallbackClientSide::getOnUninitialized()
    getOnValidate | in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::getOnValidate()
    getOnValidate | in file TBaseValidator.php, method TValidatorClientSide::getOnValidate()
    getOnValidationError | in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::getOnValidationError()
    getOnValidationError | in file TBaseValidator.php, method TValidatorClientSide::getOnValidationError()
    getOnValidationSuccess | in file TBaseValidator.php, method TValidatorClientSide::getOnValidationSuccess()
    getOnValidationSuccess | in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::getOnValidationSuccess()
    getOperator | in file TCompareValidator.php, method TCompareValidator::getOperator()
    getOption | in file TClientScriptManager.php, method TClientSideOptions::getOption()
    getOption in file TBaseActiveControl.php, method TBaseActiveControl::getOption()
    Gets an option named value. Options are used to store and retrive named values for the base active controls.
    getOptions | in file TBaseActiveControl.php, method TBaseActiveControl::getOptions()
    getOptions | in file TSoapService.php, method TSoapServer::getOptions()
    getOptions in file THtmlArea.php, method THtmlArea::getOptions()
    Gets the list of options for the WYSIWYG (TinyMCE) editor
    getOptions | in file TClientScriptManager.php, method TClientSideOptions::getOptions()
    getOrdersBy | in file TSqlCriteria.php, method TSqlCriteria::getOrdersBy()
    getOverline | in file TFont.php, method TFont::getOverline()
    getOwner | in file TControl.php, method TControlCollection::getOwner()
    getOwner | in file TDataGridColumn.php, method TDataGridColumn::getOwner()
    getOwner | in file TDataGrid.php, method TDataGridColumnCollection::getOwner()
    getOwner | in file TXmlDocument.php, method TXmlElementList::getOwner()
    getPackagePathUrl | in file TClientScriptManager.php, method TClientScriptManager::getPackagePathUrl()
    getPage | in file TControl.php, method TControl::getPage()
    getPage | in file TBaseActiveControl.php, method TBaseActiveControl::getPage()
    getPage | in file TControlAdapter.php, method TControlAdapter::getPage()
    getPage | in file TPageStatePersister.php, method TPageStatePersister::getPage()
    getPage | in file TCachePageStatePersister.php, method TCachePageStatePersister::getPage()
    getPage | in file TPage.php, method IPageStatePersister::getPage()
    getPage | in file TSessionPageStatePersister.php, method TSessionPageStatePersister::getPage()
    getPageButtonCount | in file TPager.php, method TPager::getPageButtonCount()
    getPageButtonCount | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getPageButtonCount()
    getPageCount | in file TPagedDataSource.php, method TPagedDataSource::getPageCount()
    getPageCount | in file TPagedList.php, method TPagedList::getPageCount()
    getPageCount | in file TPager.php, method TPager::getPageCount()
    getPageCount | in file TDataBoundControl.php, method TDataBoundControl::getPageCount()
    getPageImageUrl | in file TPager.php, method TPager::getPageImageUrl()
    getPagePath | in file TPage.php, method TPage::getPagePath()
    getPager | in file TDataGrid.php, method TDataGridPagerEventParameter::getPager()
    getPager | in file TScaffoldListView.php, method TScaffoldListView::getPager()
    getPagerStyle | in file TDataGrid.php, method TDataGrid::getPagerStyle()
    getPageServiceID | in file TApplication.php, method TApplication::getPageServiceID()
    getPageSize | in file TPagedList.php, method TPagedList::getPageSize()
    getPageSize | in file TPagedDataSource.php, method TPagedDataSource::getPageSize()
    getPageSize | in file TDataBoundControl.php, method TDataBoundControl::getPageSize()
    getParameter | in file TControl.php, method TBroadcastEventParameter::getParameter()
    getParameter | in file TTranslateParameter.php, method TTranslateParameter::getParameter()
    getParameter | in file TMappedStatement.php, method TResultSetListItemParameter::getParameter()
    getParameter in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::getParameter()
    Performs processing on a value before it is used to set the parameter of a IDbCommand.
    getParameter | in file TTranslate.php, method TTranslate::getParameter()
    getParameter | in file TMappedStatement.php, method TResultSetMapItemParameter::getParameter()
    getParameterClass | in file TSqlMapStatement.php, method TSqlMapStatement::getParameterClass()
    getParameterFile | in file TParameterModule.php, method TParameterModule::getParameterFile()
    getParameterizedPattern in file TUrlMapping.php, method TUrlMappingPattern::getParameterizedPattern()
    Substitute the parameter key value pairs as named groupings in the regular expression matching pattern.
    getParameterMap | in file TSqlMapStatement.php, method TSqlMapStatement::getParameterMap()
    getParameterMap | in file TSqlMapManager.php, method TSqlMapManager::getParameterMap()
    getParameterMaps | in file TSqlMapManager.php, method TSqlMapManager::getParameterMaps()
    getParameterNames | in file TPreparedStatement.php, method TPreparedStatement::getParameterNames()
    getParameters | in file TUrlMapping.php, method TUrlMappingPattern::getParameters()
    getParameters in file TApplication.php, method TApplicationConfiguration::getParameters()
    Returns list of parameter definitions.
    getParameters in file TXmlTransform.php, method TXmlTransform::getParameters()
    Returns the list of parameters to be applied to the transform.
    getParameters in file TApplication.php, method TApplication::getParameters()
    Returns the list of application parameters.
    getParameters | in file TSqlCriteria.php, method TSqlCriteria::getParameters()
    getParameters in file TTranslate.php, method TTranslate::getParameters()
    Returns the list of custom parameters.
    getParameters | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getParameters()
    getParameterValues | in file TPreparedStatement.php, method TPreparedStatement::getParameterValues()
    getParent | in file TXmlDocument.php, method TXmlElement::getParent()
    getParent | in file TScaffoldInputBase.php, method TScaffoldInputBase::getParent()
    getParent | in file TControl.php, method TControl::getParent()
    getPassword | in file TDbConnection.php, method TDbConnection::getPassword()
    getPassword | in file THttpRequest.php, method TUri::getPassword()
    getPassword | in file TDbCache.php, method TDbCache::getPassword()
    getPasswordMode | in file TUserManager.php, method TUserManager::getPasswordMode()
    getPath | in file THttpRequest.php, method TUri::getPath()
    getPath | in file THttpRequest.php, method THttpCookie::getPath()
    getPathAliases | in file PradoBase.php, method PradoBase::getPathAliases()
    getPathInfo | in file THttpRequest.php, method THttpRequest::getPathInfo()
    getPathOfAlias | in file PradoBase.php, method PradoBase::getPathOfAlias()
    getPathOfNamespace in file PradoBase.php, method PradoBase::getPathOfNamespace()
    Translates a namespace into a file path.
    getPattern | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::getPattern()
    getPattern | in file TUrlMapping.php, method TUrlMappingPattern::getPattern()
    getPattern in file TNumberFormat.php, method TNumberFormat::getPattern()
    Get the number formatting pattern.
    getPattern in file TDateFormat.php, method TDateFormat::getPattern()
    Gets the date time format pattern.
    getPatternMatches in file TUrlMapping.php, method TUrlMappingPattern::getPatternMatches()
    Uses URL pattern (or full regular expression if available) to match the given url path.
    getPatternModifiers | in file TRegularExpressionValidator.php, method TRegularExpressionValidator::getPatternModifiers()
    getPayload | in file TRpcService.php, method TRpcServer::getPayload()
    getPdoInstance | in file TDbConnection.php, method TDbConnection::getPdoInstance()
    getPdoStatement | in file TDbCommand.php, method TDbCommand::getPdoStatement()
    getPdoType | in file TDbTableColumn.php, method TDbTableColumn::getPdoType()
    getPdoType | in file TDbCommandBuilder.php, method TDbCommandBuilder::getPdoType()
    getPersistent | in file TDbConnection.php, method TDbConnection::getPersistent()
    getPersistPassword | in file TTextBox.php, method TTextBox::getPersistPassword()
    getPHPType in file TDbTableColumn.php, method TDbTableColumn::getPHPType()
    Returns the derived PHP primitive type from the db type. Default returns 'string'.
    getPHPType in file TPgsqlTableColumn.php, method TPgsqlTableColumn::getPHPType()
    Overrides parent implementation, returns PHP type from the db type.
    getPHPType in file TMysqlTableColumn.php, method TMysqlTableColumn::getPHPType()
    Overrides parent implementation, returns PHP type from the db type.
    getPHPType in file TSqliteTableColumn.php, method TSqliteTableColumn::getPHPType()
    Overrides parent implementation, returns PHP type from the db type.
    getPHPType in file TOracleTableColumn.php, method TOracleTableColumn::getPHPType()
    Overrides parent implementation, returns PHP type from the db type.
    getPHPType in file TMssqlTableColumn.php, method TMssqlTableColumn::getPHPType()
    Overrides parent implementation, returns PHP type from the db type.
    getPort | in file TMemCache.php, method TMemCache::getPort()
    getPort | in file THttpRequest.php, method TUri::getPort()
    getPosition | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getPosition()
    getPositionMode | in file TDatePicker.php, method TDatePicker::getPositionMode()
    getPostBackEventParameter | in file TPage.php, method TPage::getPostBackEventParameter()
    getPostBackEventTarget | in file TPage.php, method TPage::getPostBackEventTarget()
    getPostBackOptions in file TCheckBox.php, method TCheckBox::getPostBackOptions()
    Gets the post back options for this checkbox.
    getPostBackOptions in file TCheckBoxList.php, method TCheckBoxList::getPostBackOptions()
    Gets the post back options for this checkbox.
    getPostBackOptions in file TDraggable.php, method TDraggable::getPostBackOptions()
    Gets the post back options for this textbox.
    getPostBackOptions in file TDropContainer.php, method TDropContainer::getPostBackOptions()
    Gets the post back options for this textbox.
    getPostBackOptions | in file TBulletedList.php, method TBulletedList::getPostBackOptions()
    getPostBackOptions | in file TRatingList.php, method TRatingList::getPostBackOptions()
    getPostBackOptions | in file TListControl.php, method TListControl::getPostBackOptions()
    getPostBackOptions | in file TAutoComplete.php, method TAutoComplete::getPostBackOptions()
    getPostBackOptions in file TActiveTableCell.php, method TActiveTableCell::getPostBackOptions()
    Returns postback specifications for the table cell.
    getPostBackOptions | in file TInPlaceTextBox.php, method TInPlaceTextBox::getPostBackOptions()
    getPostBackOptions in file TTextBox.php, method TTextBox::getPostBackOptions()
    Gets the post back options for this textbox.
    getPostBackOptions in file TColorPicker.php, method TColorPicker::getPostBackOptions()
    Get javascript color picker options.
    getPostBackOptions in file TActiveTableRow.php, method TActiveTableRow::getPostBackOptions()
    Returns postback specifications for the table row.
    getPostBackOptions in file TButton.php, method TButton::getPostBackOptions()
    Returns postback specifications for the button.
    getPostBackOptions in file TLinkButton.php, method TLinkButton::getPostBackOptions()
    Returns postback specifications for the button.
    getPostBackOptions in file TImageButton.php, method TImageButton::getPostBackOptions()
    Returns postback specifications for the button.
    getPostBackParameter | in file TCallbackClientSide.php, method TCallbackClientSide::getPostBackParameter()
    getPostBackTarget | in file TCallbackClientSide.php, method TCallbackClientSide::getPostBackTarget()
    getPostBackValue | in file TImageMap.php, method THotSpot::getPostBackValue()
    getPostBackValue | in file TImageMap.php, method TImageMapEventParameter::getPostBackValue()
    getPostContentsTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::getPostContentsTemplate()
    getPostContentsText | in file TWebControlDecorator.php, method TWebControlDecorator::getPostContentsText()
    getPostDataLoaders in file TPage.php, method TPage::getPostDataLoaders()
    Get a list of IDs of controls that are enabled and require post data.
    getPostGeneratedSelectKey in file TMappedStatement.php, method TMappedStatement::getPostGeneratedSelectKey()
    Gets the inserted row ID after executing an insert statement.
    getPostSelectKeys in file TMappedStatement.php, method TMappedStatement::getPostSelectKeys()
    Finds in the post select property the SQL statement primary selection keys.
    getPostState | in file TCallbackClientSide.php, method TCallbackClientSide::getPostState()
    getPostTagTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::getPostTagTemplate()
    getPostTagText | in file TWebControlDecorator.php, method TWebControlDecorator::getPostTagText()
    getPradoPackages | in file TClientScriptManager.php, method TClientScriptManager::getPradoPackages()
    getPradoScriptAssetUrl | in file TClientScriptManager.php, method TClientScriptManager::getPradoScriptAssetUrl()
    getPradoScripts | in file TClientScriptManager.php, method TClientScriptManager::getPradoScripts()
    getPradoScripts | in file TClientScript.php, method TClientScript::getPradoScripts()
    getPrecision | in file TPriorityMap.php, method TPriorityMap::getPrecision()
    getPrecision | in file TPriorityList.php, method TPriorityList::getPrecision()
    getPreContentsTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::getPreContentsTemplate()
    getPreContentsText | in file TWebControlDecorator.php, method TWebControlDecorator::getPreContentsText()
    getPreferredLanguage in file PradoBase.php, method PradoBase::getPreferredLanguage()
    Returns the most preferred language by the client user.
    getPrefetch | in file TDbConnection.php, method TDbConnection::getPrefetch()
    getPreGeneratedSelectKey in file TMappedStatement.php, method TMappedStatement::getPreGeneratedSelectKey()
    Gets the insert generated ID before executing an insert statement.
    getPreparedSql | in file TPreparedStatement.php, method TPreparedStatement::getPreparedSql()
    getPreparedStatement | in file TStaticSql.php, method TStaticSql::getPreparedStatement()
    getPreset in file TDateFormat.php, method TDateFormat::getPreset()
    For a given string, try and find a preset pattern.
    getPreTagTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::getPreTagTemplate()
    getPreTagText | in file TWebControlDecorator.php, method TWebControlDecorator::getPreTagText()
    getPreventDefaultAction | in file TEventTriggeredCallback.php, method TEventTriggeredCallback::getPreventDefaultAction()
    getPreviousButton | in file TWizard.php, method TWizardNavigationContainer::getPreviousButton()
    getPreviousStepIndex in file TWizard.php, method TWizard::getPreviousStepIndex()
    Determines the index of the previous step based on history.
    getPrevPageImageUrl | in file TPager.php, method TPager::getPrevPageImageUrl()
    getPrevPageText | in file TPager.php, method TPager::getPrevPageText()
    getPrevPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getPrevPageText()
    getPrimaryCache | in file TCache.php, method TCache::getPrimaryCache()
    getPrimaryKeyCondition in file TDataGatewayCommand.php, method TDataGatewayCommand::getPrimaryKeyCondition()
    Create the condition and parameters for find by primary.
    getPrimaryKeys | in file TDbTableInfo.php, method TDbTableInfo::getPrimaryKeys()
    getPrimaryKeys in file TPgsqlMetaData.php, method TPgsqlMetaData::getPrimaryKeys()
    Gets the primary key field names
    getPrimaryKeys in file TOracleMetaData.php, method TOracleMetaData::getPrimaryKeys()
    Gets the primary key field names
    getPrimaryKeys | in file TOracleTableInfo.php, method TOracleTableInfo::getPrimaryKeys()
    getPrimaryKeyValues | in file TActiveRecordGateway.php, method TActiveRecordGateway::getPrimaryKeyValues()
    getPriorities in file TPriorityList.php, method TPriorityList::getPriorities()
    This returns a list of the priorities within this list, ordered lowest to highest.
    getPriorities in file TPriorityMap.php, method TPriorityMap::getPriorities()
    This returns a list of the priorities within this map, ordered lowest to highest.
    getPriorityCount in file TPriorityList.php, method TPriorityList::getPriorityCount()
    Gets the number of items at a priority within the list
    getPriorityCount in file TPriorityMap.php, method TPriorityMap::getPriorityCount()
    Gets the number of items at a priority within the map.
    getPrivateKey | in file TCaptcha.php, method TCaptcha::getPrivateKey()
    getPrivateKey | in file TReCaptcha.php, method TReCaptcha::getPrivateKey()
    getProgressIndicator | in file TSlider.php, method TSlider::getProgressIndicator()
    getPromptText | in file TListControl.php, method TListControl::getPromptText()
    getPromptValue | in file TListControl.php, method TListControl::getPromptValue()
    getProperties | in file TComponent.php, method TComponentReflection::getProperties()
    getProperties in file TPageService.php, method TPageConfiguration::getProperties()
    Returns list of page initial property values.
    getProperties in file TApplication.php, method TApplicationConfiguration::getProperties()
    Returns list of page initial property values.
    getProperties | in file TParameterMap.php, method TParameterMap::getProperties()
    getProperty | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getProperty()
    getProperty | in file TParameterProperty.php, method TParameterProperty::getProperty()
    getProperty | in file TResultProperty.php, method TResultProperty::getProperty()
    getProperty | in file TParameterMap.php, method TParameterMap::getProperty()
    getProperty | in file TSqlMapStatement.php, method TSqlMapSelectKey::getProperty()
    getPropertyName | in file TValueTriggeredCallback.php, method TValueTriggeredCallback::getPropertyName()
    getPropertyNames | in file TParameterMap.php, method TParameterMap::getPropertyNames()
    getPropertyValue in file TResultProperty.php, method TResultProperty::getPropertyValue()
    Gets the value for the current property, converts to applicable type if necessary.
    getPropertyValue in file TParameterMap.php, method TParameterMap::getPropertyValue()
    Get the value of a property from the the parameter object.
    getPropertyValue | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getPropertyValue()
    getPropertyValueType in file TResultProperty.php, method TResultProperty::getPropertyValueType()
    Determines if the type is an instance of ArrayAccess, TList or an array.
    getProvider | in file TSoapService.php, method TSoapServer::getProvider()
    getPublicKey | in file TCaptcha.php, method TCaptcha::getPublicKey()
    getPublicKey | in file TReCaptcha.php, method TReCaptcha::getPublicKey()
    getPublished | in file TAssetManager.php, method TAssetManager::getPublished()
    getPublishedPath in file TAssetManager.php, method TAssetManager::getPublishedPath()
    Returns the published path of a file path.
    getPublishedUrl in file TAssetManager.php, method TAssetManager::getPublishedUrl()
    Returns the URL of a published file path.
    getQuery | in file THttpRequest.php, method TUri::getQuery()
    getQueryString | in file THttpRequest.php, method THttpRequest::getQueryString()
    getRadioButtonsInGroup in file TRadioButton.php, method TRadioButton::getRadioButtonsInGroup()
    Gets an array of radiobuttons whose group name is the same as this radiobutton's.
    getRadius | in file TImageMap.php, method TCircleHotSpot::getRadius()
    getRating | in file TRatingList.php, method TRatingList::getRating()
    getRatingIndex | in file TRatingList.php, method TRatingList::getRatingIndex()
    getRatingStyle | in file TRatingList.php, method TRatingList::getRatingStyle()
    getRatingStyleCssClass | in file TRatingList.php, method TRatingList::getRatingStyleCssClass()
    getReadOnly | in file TMap.php, method TMap::getReadOnly()
    getReadOnly | in file TBoundColumn.php, method TBoundColumn::getReadOnly()
    getReadOnly | in file TTextBox.php, method TTextBox::getReadOnly()
    getReadOnly | in file TList.php, method TList::getReadOnly()
    getReadOnly | in file TPriorityMap.php, method TPriorityMap::getReadOnly()
    getReadOnly | in file TCheckBoxColumn.php, method TCheckBoxColumn::getReadOnly()
    getReadOnly | in file TDropDownListColumn.php, method TDropDownListColumn::getReadOnly()
    getReadOnly | in file TRatingList.php, method TRatingList::getReadOnly()
    getRecordClass in file TScaffoldBase.php, method TScaffoldBase::getRecordClass()
    Name of the Active Record class to be viewed or scaffolded.
    getRecordCriteria in file TActiveRecord.php, method TActiveRecord::getRecordCriteria()
    Create a new TSqlCriteria object from a string $criteria. The $args are additional parameters and are used in place of the $parameters if $parameters is not an array and $args is an arrary.
    getRecordCriteria | in file TScaffoldListView.php, method TScaffoldListView::getRecordCriteria()
    getRecordFinder | in file TScaffoldBase.php, method TScaffoldBase::getRecordFinder()
    getRecordGateway | in file TActiveRecord.php, method TActiveRecord::getRecordGateway()
    getRecordGateway | in file TActiveRecordManager.php, method TActiveRecordManager::getRecordGateway()
    getRecordManager in file TActiveRecord.php, method TActiveRecord::getRecordManager()
    Gets the record manager for this object, the default is to call TActiveRecordManager::getInstance().
    getRecordObject in file TScaffoldBase.php, method TScaffoldBase::getRecordObject()
    Gets the current Active Record instance. Creates new instance if the primary key value is null otherwise the record is fetched from the db.
    getRecordPk | in file TScaffoldEditView.php, method TScaffoldEditView::getRecordPk()
    getRecordPkValues | in file TScaffoldBase.php, method TScaffoldBase::getRecordPkValues()
    getRecordPropertyValue | in file TScaffoldInputBase.php, method TScaffoldInputBase::getRecordPropertyValue()
    getRecordPropertyValues | in file TScaffoldBase.php, method TScaffoldBase::getRecordPropertyValues()
    getRecordRelation | in file TActiveRecord.php, method TActiveRecord::getRecordRelation()
    getRecordRelations | in file TActiveRecord.php, method TActiveRecord::getRecordRelations()
    getRecordTableInfo in file TActiveRecordGateway.php, method TActiveRecordGateway::getRecordTableInfo()
    Returns table information, trys the application cache first.
    getRecordTableInfo | in file TActiveRecord.php, method TActiveRecord::getRecordTableInfo()
    getRecordTableName in file TActiveRecordGateway.php, method TActiveRecordGateway::getRecordTableName()
    Gets the table name from the 'TABLE' constant of the active record class if defined, otherwise use the class name as table name.
    getRecursiveCheck | in file TCache.php, method TDirectoryCacheDependency::getRecursiveCheck()
    getRecursiveLevel | in file TCache.php, method TDirectoryCacheDependency::getRecursiveLevel()
    getRedirectedUrl | in file TCallbackResponseAdapter.php, method TCallbackResponseAdapter::getRedirectedUrl()
    getRegisteredObject in file TControl.php, method TControl::getRegisteredObject()
    Returns the named registered object.
    getRegularExpression | in file TRegularExpressionValidator.php, method TRegularExpressionValidator::getRegularExpression()
    getRegularExpression | in file TEmailAddressValidator.php, method TEmailAddressValidator::getRegularExpression()
    getRegularExpression | in file TUrlMapping.php, method TUrlMappingPattern::getRegularExpression()
    getRelationForeignKeys | in file TActiveRecordRelation.php, method TActiveRecordRelation::getRelationForeignKeys()
    getRelationForeignKeys | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getRelationForeignKeys()
    getRelationForeignKeys | in file TActiveRecordHasMany.php, method TActiveRecordHasMany::getRelationForeignKeys()
    getRelationForeignKeys | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getRelationForeignKeys()
    getRelationForeignKeys | in file TActiveRecordBelongsTo.php, method TActiveRecordBelongsTo::getRelationForeignKeys()
    getRelationForeignKeys | in file TActiveRecordHasOne.php, method TActiveRecordHasOne::getRelationForeignKeys()
    getRelationHandler in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getRelationHandler()
    Creates and return the TActiveRecordRelation handler for specific relationships.
    getRelationHandler in file TActiveRecord.php, method TActiveRecord::getRelationHandler()
    Returns the active record relationship handler for $RELATION with key value equal to the $property value.
    getRelationType | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getRelationType()
    getRenderedScriptFiles | in file TClientScriptManager.php, method TClientScriptManager::getRenderedScriptFiles()
    getRepackUTF7 | in file TSafeHtml.php, method TSafeHtml::getRepackUTF7()
    getRepeatColumns | in file TDataList.php, method TDataList::getRepeatColumns()
    getRepeatColumns | in file TRepeatInfo.php, method TRepeatInfo::getRepeatColumns()
    getRepeatColumns | in file TCheckBoxList.php, method TCheckBoxList::getRepeatColumns()
    getRepeatDirection | in file TRepeatInfo.php, method TRepeatInfo::getRepeatDirection()
    getRepeatDirection | in file TCheckBoxList.php, method TCheckBoxList::getRepeatDirection()
    getRepeatDirection | in file TDataList.php, method TDataList::getRepeatDirection()
    getRepeatInfo | in file TCheckBoxList.php, method TCheckBoxList::getRepeatInfo()
    getRepeatInfo | in file TDataList.php, method TDataList::getRepeatInfo()
    getRepeatLayout | in file TDataList.php, method TDataList::getRepeatLayout()
    getRepeatLayout | in file TCheckBoxList.php, method TCheckBoxList::getRepeatLayout()
    getRepeatLayout | in file TRepeatInfo.php, method TRepeatInfo::getRepeatLayout()
    getRequest | in file TApplication.php, method TApplication::getRequest()
    getRequest | in file TApplicationComponent.php, method TApplicationComponent::getRequest()
    getRequestClientState | in file TPage.php, method TPage::getRequestClientState()
    getRequestCompleted | in file TApplication.php, method TApplication::getRequestCompleted()
    getRequestedMethod in file TSoapService.php, method TSoapServer::getRequestedMethod()
    Soap method guessed from the SOAP message received.
    getRequestedPage | in file TPageService.php, method TPageService::getRequestedPage()
    getRequestedPagePath | in file TPageService.php, method TPageService::getRequestedPagePath()
    getRequestResolved | in file THttpRequest.php, method THttpRequest::getRequestResolved()
    getRequestTimeOut | in file TCallbackClientSide.php, method TCallbackClientSide::getRequestTimeOut()
    getRequestType | in file THttpRequest.php, method THttpRequest::getRequestType()
    getRequestUri | in file THttpRequest.php, method THttpRequest::getRequestUri()
    getRequiredSelections in file TListControlValidator.php, method TListControlValidator::getRequiredSelections()
    Get a comma separated list of required selected values.
    getRequiredValues | in file TListControlValidator.php, method TListControlValidator::getRequiredValues()
    getRequiresDataBinding | in file TDataBoundControl.php, method TDataBoundControl::getRequiresDataBinding()
    getRequiresHead | in file TClientScriptManager.php, method TClientScriptManager::getRequiresHead()
    getResponse | in file THttpResponseAdapter.php, method THttpResponseAdapter::getResponse()
    getResponse | in file TApplicationComponent.php, method TApplicationComponent::getResponse()
    getResponse | in file TApplication.php, method TApplication::getResponse()
    getResponseData | in file TCallbackEventParameter.php, method TCallbackEventParameter::getResponseData()
    getResponseData | in file TCallbackResponseAdapter.php, method TCallbackResponseAdapter::getResponseData()
    getResponseFieldName | in file TReCaptcha.php, method TReCaptcha::getResponseFieldName()
    getResult in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::getResult()
    Performs processing on a value before after it has been retrieved
    getResult | in file TMappedStatement.php, method TResultSetListItemParameter::getResult()
    getResult | in file TDataGatewayCommand.php, method TDataGatewayResultEventParameter::getResult()
    getResultClass | in file TSqlMapStatement.php, method TSqlMapStatement::getResultClass()
    getResultMap in file TSqlMapManager.php, method TSqlMapManager::getResultMap()
    Gets a named result map
    getResultMap | in file TSqlMapStatement.php, method TSqlMapStatement::getResultMap()
    getResultMapGroupKey in file TMappedStatement.php, method TMappedStatement::getResultMapGroupKey()
    Gets the result 'group by' groupping key for each row.
    getResultMapping in file TDiscriminator.php, method TSubMap::getResultMapping()
    The result map to use when the Value matches the discriminator column value.
    getResultMapping | in file TResultProperty.php, method TResultProperty::getResultMapping()
    getResultMaps | in file TSqlMapManager.php, method TSqlMapManager::getResultMaps()
    getResultObject | in file TMappedStatement.php, method TPostSelectBinding::getResultObject()
    getResultPanel | in file TAutoComplete.php, method TAutoComplete::getResultPanel()
    getResultProperty | in file TMappedStatement.php, method TPostSelectBinding::getResultProperty()
    getRetrieveTotalRowCount | in file TDataSourceView.php, method TDataSourceSelectParameters::getRetrieveTotalRowCount()
    getReturnUrl | in file TAuthManager.php, method TAuthManager::getReturnUrl()
    getReturnUrlVarName | in file TAuthManager.php, method TAuthManager::getReturnUrlVarName()
    getRevert in file TDraggable.php, method TDraggable::getRevert()
    Determine if draggable element should revert to it orginal position upon release in an non-droppable container.
    getRight | in file TImageMap.php, method TRectangleHotSpot::getRight()
    getRoles | in file TAuthorizationRule.php, method TAuthorizationRule::getRoles()
    getRoles | in file interfaces.php, method IUser::getRoles()
    getRoles in file TUserManager.php, method TUserManager::getRoles()
    Returns an array of user role information.
    getRoles | in file TUser.php, method TUser::getRoles()
    getRow in file TActiveTableCell.php, method TActiveTableCell::getRow()
    Returns the parent TTableRow control by looping through all parents until a TTableRow is found. Raises a TConfigurationException if no row control is found.
    getRowCount | in file TDbDataReader.php, method TDbDataReader::getRowCount()
    getRowIndex in file TActiveTableRow.php, method TActiveTableRow::getRowIndex()
    Returns the zero-based index of the TActiveTableRow within the TTableRowCollection of the parent TTable control. Raises a TConfigurationException if the row is no member of the row collection.
    getRows | in file TTextBox.php, method TTextBox::getRows()
    getRows | in file TTable.php, method TTable::getRows()
    getRows | in file TListBox.php, method TListBox::getRows()
    getRowSpan | in file TTableCell.php, method TTableCell::getRowSpan()
    getRpcServer | in file TRpcService.php, method TRpcApiProvider::getRpcServer()
    getRules in file TPageService.php, method TPageConfiguration::getRules()
    Returns list of authorization rules.
    getRuntimePath | in file TApplication.php, method TApplication::getRuntimePath()
    getSafeText | in file TTextBox.php, method TTextBox::getSafeText()
    getSafeTextParser | in file TTextBox.php, method TTextBox::getSafeTextParser()
    getSaveButton | in file TScaffoldEditView.php, method TScaffoldEditView::getSaveButton()
    getSavePath | in file THttpSession.php, method THttpSession::getSavePath()
    getScaffoldInputBuilder in file TScaffoldEditView.php, method TScaffoldEditView::getScaffoldInputBuilder()
    Create the default scaffold editor control factory.
    getScalarResult in file TMappedStatement.php, method TMappedStatement::getScalarResult()
    Converts the first array value to scalar value of given type.
    getSchemaName | in file TMysqlTableInfo.php, method TMysqlTableInfo::getSchemaName()
    getSchemaName | in file TPgsqlTableInfo.php, method TPgsqlTableInfo::getSchemaName()
    getSchemaName | in file TMssqlTableInfo.php, method TMssqlTableInfo::getSchemaName()
    getSchemaTableName | in file TMysqlMetaData.php, method TMysqlMetaData::getSchemaTableName()
    getSchemaTableName | in file TPgsqlMetaData.php, method TPgsqlMetaData::getSchemaTableName()
    getSchemaTableName | in file TOracleMetaData.php, method TOracleMetaData::getSchemaTableName()
    getScheme | in file THttpRequest.php, method TUri::getScheme()
    getScheme | in file THead.php, method TMetaTag::getScheme()
    getScope | in file TTableHeaderCell.php, method TTableHeaderCell::getScope()
    getScreenX | in file TDropContainer.php, method TDropContainerEventParameter::getScreenX()
    getScreenY | in file TDropContainer.php, method TDropContainerEventParameter::getScreenY()
    getScriptDeploymentPath in file THtmlArea.php, method THtmlArea::getScriptDeploymentPath()
    Gets the editor script base URL by publishing the tarred source via TTarAssetManager.
    getScriptUrl | in file TClientScript.php, method TClientScript::getScriptUrl()
    getScriptUrl | in file THtmlArea.php, method THtmlArea::getScriptUrl()
    getScriptUrls in file TClientScriptManager.php, method TClientScriptManager::getScriptUrls()
    Returns the URLs of all script files referenced on the page
    getScrollBars | in file TInlineFrame.php, method TInlineFrame::getScrollBars()
    getScrollBars | in file TPanelStyle.php, method TPanelStyle::getScrollBars()
    getScrollBars | in file TPanel.php, method TPanel::getScrollBars()
    getScrollToSummary | in file TValidationSummary.php, method TValidationSummary::getScrollToSummary()
    getSearchableFields | in file TScaffoldSearch.php, method TScaffoldSearch::getSearchableFields()
    getSearchButton | in file TScaffoldSearch.php, method TScaffoldSearch::getSearchButton()
    getSearchCondition | in file TDbCommandBuilder.php, method TDbCommandBuilder::getSearchCondition()
    getSearchCondition in file TPgsqlCommandBuilder.php, method TPgsqlCommandBuilder::getSearchCondition()
    Overrides parent implementation to use PostgreSQL's ILIKE instead of LIKE (case-sensitive).
    getSearchCondition | in file TScaffoldListView.php, method TScaffoldListView::getSearchCondition()
    getSearchControl | in file TScaffoldView.php, method TScaffoldView::getSearchControl()
    getSearchExpression in file TDbCommandBuilder.php, method TDbCommandBuilder::getSearchExpression()
    Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).
    getSearchExpression in file TPgsqlCommandBuilder.php, method TPgsqlCommandBuilder::getSearchExpression()
    Overrides parent implementation. Only column of type text or character (and its variants) accepts the LIKE criteria.
    getSearchExpression in file TOracleCommandBuilder.php, method TOracleCommandBuilder::getSearchExpression()
    Overrides parent implementation. Only column of type text or character (and its variants) accepts the LIKE criteria.
    getSearchParameters | in file TScaffoldListView.php, method TScaffoldListView::getSearchParameters()
    getSearchText | in file TScaffoldSearch.php, method TScaffoldSearch::getSearchText()
    getSecure | in file THttpRequest.php, method THttpCookie::getSecure()
    getSecureConnection | in file TUrlMapping.php, method TUrlMappingPattern::getSecureConnection()
    getSecurityManager | in file TApplication.php, method TApplication::getSecurityManager()
    getSelect | in file TResultProperty.php, method TResultProperty::getSelect()
    getSelect in file TSqlCriteria.php, method TSqlCriteria::getSelect()
    Gets the field list to be placed after the SELECT in the SQL. Default to '*'
    getSelected | in file TListItem.php, method TListItem::getSelected()
    getSelectedCellIndex in file TActiveTableCell.php, method TActiveTableCellEventParameter::getSelectedCellIndex()
    Returns the zero-based index of the TActiveTableCell within the TTableCellCollection of the parent TTableRow control.
    getSelectedDataKey | in file TDataList.php, method TDataList::getSelectedDataKey()
    getSelectedIndex | in file TListControl.php, method TListControl::getSelectedIndex()
    getSelectedIndex | in file TAutoComplete.php, method TAutoCompleteEventParameter::getSelectedIndex()
    getSelectedIndices | in file TListControl.php, method TListControl::getSelectedIndices()
    getSelectedItem | in file TListControl.php, method TListControl::getSelectedItem()
    getSelectedItem | in file TDataGrid.php, method TDataGrid::getSelectedItem()
    getSelectedItem | in file TDataList.php, method TDataList::getSelectedItem()
    getSelectedItemIndex | in file TDataGrid.php, method TDataGrid::getSelectedItemIndex()
    getSelectedItemIndex | in file TDataList.php, method TDataList::getSelectedItemIndex()
    getSelectedItemRenderer | in file TDataList.php, method TDataList::getSelectedItemRenderer()
    getSelectedItemStyle | in file TDataList.php, method TDataList::getSelectedItemStyle()
    getSelectedItemStyle | in file TDataGrid.php, method TDataGrid::getSelectedItemStyle()
    getSelectedItemTemplate | in file TDataList.php, method TDataList::getSelectedItemTemplate()
    getSelectedRowIndex in file TActiveTableRow.php, method TActiveTableRowEventParameter::getSelectedRowIndex()
    Returns the zero-based index of the TActiveTableRow within the TTableRowCollection of the parent TTable control.
    getSelectedValue | in file TListControl.php, method TListControl::getSelectedValue()
    getSelectedValues | in file TListControl.php, method TListControl::getSelectedValues()
    getSelectFieldList in file TDbCommandBuilder.php, method TDbCommandBuilder::getSelectFieldList()
    Different behavior depends on type of passed data string usage without modification
    getSelection | in file TListControlValidator.php, method TListControlValidator::getSelection()
    getSelectionMode | in file TListBox.php, method TListBox::getSelectionMode()
    getSelectKey | in file TSqlMapStatement.php, method TSqlMapInsert::getSelectKey()
    getSelectParameters | in file TDataBoundControl.php, method TDataBoundControl::getSelectParameters()
    getSentFrom | in file TLogRouter.php, method TEmailLogRoute::getSentFrom()
    getSeparator | in file TAutoComplete.php, method TAutoComplete::getSeparator()
    getSeparatorRenderer | in file TDataList.php, method TDataList::getSeparatorRenderer()
    getSeparatorRenderer | in file TRepeater.php, method TRepeater::getSeparatorRenderer()
    getSeparatorStyle | in file TDataList.php, method TDataList::getSeparatorStyle()
    getSeparatorTemplate | in file TDataList.php, method TDataList::getSeparatorTemplate()
    getSeparatorTemplate | in file TRepeater.php, method TRepeater::getSeparatorTemplate()
    getSequenceName | in file TDbTableColumn.php, method TDbTableColumn::getSequenceName()
    getSequenceName | in file TPgsqlMetaData.php, method TPgsqlMetaData::getSequenceName()
    getSequenceName | in file TOracleMetaData.php, method TOracleMetaData::getSequenceName()
    getServerID | in file TSoapService.php, method TSoapService::getServerID()
    getServerInfo | in file TDbConnection.php, method TDbConnection::getServerInfo()
    getServerName | in file THttpRequest.php, method THttpRequest::getServerName()
    getServerPort | in file THttpRequest.php, method THttpRequest::getServerPort()
    getServerUrl | in file TRpcClient.php, method TRpcClient::getServerUrl()
    getServerVariables | in file THttpRequest.php, method THttpRequest::getServerVariables()
    getServerVersion | in file TMysqlMetaData.php, method TMysqlMetaData::getServerVersion()
    getServerVersion | in file TDbConnection.php, method TDbConnection::getServerVersion()
    getService | in file TApplicationComponent.php, method TApplicationComponent::getService()
    getService | in file TApplication.php, method TApplication::getService()
    getServiceID | in file TUrlMapping.php, method TUrlMappingPattern::getServiceID()
    getServiceID | in file THttpRequest.php, method THttpRequest::getServiceID()
    getServiceParameter | in file THttpRequest.php, method THttpRequest::getServiceParameter()
    getServiceParameter | in file TUrlMapping.php, method TUrlMappingPattern::getServiceParameter()
    getServices | in file TApplication.php, method TApplicationConfiguration::getServices()
    getSession | in file TApplicationComponent.php, method TApplicationComponent::getSession()
    getSession | in file TApplication.php, method TApplication::getSession()
    getSessionID | in file THttpSession.php, method THttpSession::getSessionID()
    getSessionName | in file THttpSession.php, method THttpSession::getSessionName()
    getSessionPersistent | in file TSoapService.php, method TSoapServer::getSessionPersistent()
    getSetValue | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::getSetValue()
    getShape | in file TImageMap.php, method THotSpot::getShape()
    getShape | in file TImageMap.php, method TPolygonHotSpot::getShape()
    getShape | in file TImageMap.php, method TRectangleHotSpot::getShape()
    getShape | in file TImageMap.php, method TCircleHotSpot::getShape()
    getShiftKey | in file TDropContainer.php, method TDropContainerEventParameter::getShiftKey()
    getShortcutIcon | in file THead.php, method THead::getShortcutIcon()
    getShowAnchor | in file TValidationSummary.php, method TValidationSummary::getShowAnchor()
    getShowBorder | in file TInlineFrame.php, method TInlineFrame::getShowBorder()
    getShowCalendar | in file TDatePicker.php, method TDatePicker::getShowCalendar()
    getShowCancelButton | in file TWizard.php, method TWizard::getShowCancelButton()
    getShowColorPicker | in file TColorPicker.php, method TColorPicker::getShowColorPicker()
    getShowCreateTable | in file TMysqlMetaData.php, method TMysqlMetaData::getShowCreateTable()
    getShowFooter | in file TDataList.php, method TDataList::getShowFooter()
    getShowFooter | in file TDataGrid.php, method TDataGrid::getShowFooter()
    getShowHeader | in file TDataList.php, method TDataList::getShowHeader()
    getShowHeader | in file TDataGrid.php, method TDataGrid::getShowHeader()
    getShowLineNumbers | in file TTextHighlighter.php, method TTextHighlighter::getShowLineNumbers()
    getShowMessageBox | in file TValidationSummary.php, method TValidationSummary::getShowMessageBox()
    getShowSideBar | in file TWizard.php, method TWizard::getShowSideBar()
    getShowSummary | in file TValidationSummary.php, method TValidationSummary::getShowSummary()
    getSideBar | in file TWizard.php, method TWizard::getSideBar()
    getSideBarButtonStyle | in file TWizard.php, method TWizard::getSideBarButtonStyle()
    getSideBarStyle | in file TWizard.php, method TWizard::getSideBarStyle()
    getSideBarTemplate | in file TWizard.php, method TWizard::getSideBarTemplate()
    getSize | in file TFont.php, method TFont::getSize()
    getSkinID | in file TDataSourceControl.php, method TDataSourceControl::getSkinID()
    getSkinID | in file TControl.php, method TControl::getSkinID()
    getSkins | in file TThemeManager.php, method TTheme::getSkins()
    getSliderOptions in file TSlider.php, method TSlider::getSliderOptions()
    Get javascript sliderr options.
    getSort | in file TScaffoldListView.php, method TScaffoldListView::getSort()
    getSortExpression | in file TDataGridColumn.php, method TDataGridColumn::getSortExpression()
    getSortExpression | in file TDataGrid.php, method TDataGridSortCommandEventParameter::getSortExpression()
    getSourceColumns | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getSourceColumns()
    getSourceRecord | in file TActiveRecordRelation.php, method TActiveRecordRelation::getSourceRecord()
    getSourceRecord | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::getSourceRecord()
    getSourceTable | in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::getSourceTable()
    getSourceTemplateControl | in file TControl.php, method TControl::getSourceTemplateControl()
    getSpanNeeded in file TCheckBox.php, method TCheckBox::getSpanNeeded()
    Check if we need a span tag to surround this control. The span tag will be created if the Text property is set for this control.
    getSpanNeeded in file TCheckBoxList.php, method TCheckBoxList::getSpanNeeded()
    Wether the list should be rendered inside a span or not
    getSqlCommand in file TDataGatewayCommand.php, method TDataGatewayCommand::getSqlCommand()
    Build sql command from the criteria. Limit, Offset and Ordering are applied if applicable.
    getSqlmapGateway | in file TSqlMapManager.php, method TSqlMapManager::getSqlmapGateway()
    getSqlMapManager | in file TSqlMapGateway.php, method TSqlMapGateway::getSqlMapManager()
    getSqlMapManager in file TSqlMapConfig.php, method TSqlMapConfig::getSqlMapManager()
    Create and configure the data mapper using sqlmap configuration file.
    getSqlString | in file TMappedStatement.php, method TMappedStatement::getSqlString()
    getSqlText | in file TSqlMapStatement.php, method TSqlMapStatement::getSqlText()
    getStartNavigation | in file TWizard.php, method TWizard::getStartNavigation()
    getStartNavigationTemplate | in file TWizard.php, method TWizard::getStartNavigationTemplate()
    getStartNextButtonStyle | in file TWizard.php, method TWizard::getStartNextButtonStyle()
    getStartRowIndex | in file TDataSourceView.php, method TDataSourceSelectParameters::getStartRowIndex()
    getStartTimerOnLoad | in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::getStartTimerOnLoad()
    getState in file TUser.php, method TUser::getState()
    Returns the value of a variable that is stored in user session.
    getStateChanged | in file TUser.php, method TUser::getStateChanged()
    getStateFilePath | in file TApplication.php, method TApplicationStatePersister::getStateFilePath()
    getStatement | in file IMappedStatement.php, method IMappedStatement::getStatement()
    getStatement | in file TCachingStatement.php, method TCachingStatement::getStatement()
    getStatement | in file TMappedStatement.php, method TMappedStatement::getStatement()
    getStatement | in file TMappedStatement.php, method TPostSelectBinding::getStatement()
    getStatements | in file TStatements.php, method TStatements::getStatements()
    getStateName | in file TCache.php, method TGlobalStateCacheDependency::getStateName()
    getStatePersister | in file TPage.php, method TPage::getStatePersister()
    getStatePersisterClass | in file TPage.php, method TPage::getStatePersisterClass()
    getStatesToTrack | in file TActiveControlAdapter.php, method TCallbackPageStateTracker::getStatesToTrack()
    getStateTracker | in file TActiveControlAdapter.php, method TActiveControlAdapter::getStateTracker()
    getStatusCode | in file THttpResponse.php, method THttpResponse::getStatusCode()
    getStatusCode | in file TException.php, method THttpException::getStatusCode()
    getStatusReason | in file THttpResponse.php, method THttpResponse::getStatusReason()
    getStepContent | in file TWizard.php, method TWizard::getStepContent()
    getStepNavigation | in file TWizard.php, method TWizard::getStepNavigation()
    getStepNavigationTemplate | in file TWizard.php, method TWizard::getStepNavigationTemplate()
    getStepNextButtonStyle | in file TWizard.php, method TWizard::getStepNextButtonStyle()
    getStepPreviousButtonStyle | in file TWizard.php, method TWizard::getStepPreviousButtonStyle()
    getStepSize | in file TSlider.php, method TSlider::getStepSize()
    getStepStyle | in file TWizard.php, method TWizard::getStepStyle()
    getStepType | in file TWizard.php, method TWizardStep::getStepType()
    getStepType in file TWizard.php, method TWizard::getStepType()
    Determines the type of the specified wizard step.
    getStepType | in file TWizard.php, method TCompleteWizardStep::getStepType()
    getStrictComparison | in file TRangeValidator.php, method TRangeValidator::getStrictComparison()
    getStrikeout | in file TFont.php, method TFont::getStrikeout()
    getStyle | in file interfaces.php, method IStyleable::getStyle()
    getStyle | in file TWebControl.php, method TWebControl::getStyle()
    getStyle | in file TDataListItemRenderer.php, method TDataListItemRenderer::getStyle()
    getStyleDiff | in file TActiveControlAdapter.php, method TStyleDiff::getStyleDiff()
    getStyleField | in file TStyle.php, method TStyle::getStyleField()
    getStyleFields | in file TStyle.php, method TStyle::getStyleFields()
    getStyleFromString | in file TActiveControlAdapter.php, method TStyleDiff::getStyleFromString()
    getStyleSheetFiles | in file TThemeManager.php, method TTheme::getStyleSheetFiles()
    getStyleSheetTheme | in file TPage.php, method TPage::getStyleSheetTheme()
    getStyleSheetUrl | in file TStyleSheet.php, method TStyleSheet::getStyleSheetUrl()
    getStyleSheetUrls in file TClientScriptManager.php, method TClientScriptManager::getStyleSheetUrls()
    Returns the URLs of all stylesheet files referenced on the page
    getSubject | in file TLogRouter.php, method TEmailLogRoute::getSubject()
    getSubMap | in file TDiscriminator.php, method TDiscriminator::getSubMap()
    getSubProperty in file TComponent.php, method TComponent::getSubProperty()
    Evaluates a property path.
    getSuccessImage | in file TActiveFileUpload.php, method TActiveFileUpload::getSuccessImage()
    getSuggestions | in file TAutoComplete.php, method TAutoComplete::getSuggestions()
    getSurroundingTagId in file TActiveDataGrid.php, method TActiveDataGrid::getSurroundingTagId()
    Returns the id of the surrounding container (div).
    getSurroundingTagID | in file TControl.php, method ISurroundable::getSurroundingTagID()
    getSurroundingTagID in file TActiveRepeater.php, method TActiveRepeater::getSurroundingTagID()
    Returns the id of the surrounding container (span).
    getSurroundingTagID | in file TCheckBox.php, method TCheckBox::getSurroundingTagID()
    getTabCssClass | in file TTabPanel.php, method TTabPanel::getTabCssClass()
    getTabIndex | in file TImageMap.php, method THotSpot::getTabIndex()
    getTabIndex | in file TWebControl.php, method TWebControl::getTabIndex()
    getTable in file TActiveTableRow.php, method TActiveTableRow::getTable()
    Returns the parent TTable control by looping through all parents until a TTable is found. Raises a TConfigurationException if no table control is found.
    getTableBodyStyle | in file TDataGrid.php, method TDataGrid::getTableBodyStyle()
    getTableFootStyle | in file TDataGrid.php, method TDataGrid::getTableFootStyle()
    getTableFullName | in file TMssqlTableInfo.php, method TMssqlTableInfo::getTableFullName()
    getTableFullName | in file TMysqlTableInfo.php, method TMysqlTableInfo::getTableFullName()
    getTableFullName | in file TOracleTableInfo.php, method TOracleTableInfo::getTableFullName()
    getTableFullName | in file TPgsqlTableInfo.php, method TPgsqlTableInfo::getTableFullName()
    getTableFullName | in file TSqliteTableInfo.php, method TSqliteTableInfo::getTableFullName()
    getTableFullName | in file TDbTableInfo.php, method TDbTableInfo::getTableFullName()
    getTableHeadStyle | in file TDataGrid.php, method TDataGrid::getTableHeadStyle()
    getTableInfo | in file TDataGatewayCommand.php, method TDataGatewayCommand::getTableInfo()
    getTableInfo in file TActiveRecordGateway.php, method TActiveRecordGateway::getTableInfo()
    Returns table information for table in the database connection.
    getTableInfo | in file TTableGateway.php, method TTableGateway::getTableInfo()
    getTableInfo in file TDbMetaData.php, method TDbMetaData::getTableInfo()
    Obtains table meta data information for the current connection and given table name.
    getTableInfo | in file TScaffoldBase.php, method TScaffoldBase::getTableInfo()
    getTableInfo | in file TDbCommandBuilder.php, method TDbCommandBuilder::getTableInfo()
    getTableInfoClass | in file TDbMetaData.php, method TDbMetaData::getTableInfoClass()
    getTableInfoClass | in file TMssqlMetaData.php, method TMssqlMetaData::getTableInfoClass()
    getTableInfoClass | in file TPgsqlMetaData.php, method TPgsqlMetaData::getTableInfoClass()
    getTableInfoClass | in file TSqliteMetaData.php, method TSqliteMetaData::getTableInfoClass()
    getTableInfoClass | in file TOracleMetaData.php, method TOracleMetaData::getTableInfoClass()
    getTableInfoClass | in file TMysqlMetaData.php, method TMysqlMetaData::getTableInfoClass()
    getTableName | in file TDbTableInfo.php, method TDbTableInfo::getTableName()
    getTableName | in file TTableGateway.php, method TTableGateway::getTableName()
    getTableName | in file TOracleTableInfo.php, method TOracleTableInfo::getTableName()
    getTableSection | in file TTableHeaderRow.php, method TTableHeaderRow::getTableSection()
    getTableSection | in file TTableFooterRow.php, method TTableFooterRow::getTableSection()
    getTableSection | in file TTableRow.php, method TTableRow::getTableSection()
    getTabSize | in file TTextHighlighter.php, method TTextHighlighter::getTabSize()
    getTabStyle | in file TTabPanel.php, method TTabPanel::getTabStyle()
    getTagName | in file TLinkButton.php, method TLinkButton::getTagName()
    getTagName | in file TTableHeaderCell.php, method TTableHeaderCell::getTagName()
    getTagName | in file THyperLink.php, method THyperLink::getTagName()
    getTagName | in file TTabPanel.php, method TTabView::getTagName()
    getTagName | in file TInPlaceTextBox.php, method TInPlaceTextBox::getTagName()
    getTagName | in file TInlineFrame.php, method TInlineFrame::getTagName()
    getTagName | in file TFileUpload.php, method TFileUpload::getTagName()
    getTagName | in file TTextHighlighter.php, method TTextHighlighter::getTagName()
    getTagName | in file TImageButton.php, method TImageButton::getTagName()
    getTagName | in file TJavascriptLogger.php, method TJavascriptLogger::getTagName()
    getTagName | in file TLabel.php, method TLabel::getTagName()
    getTagName | in file TCheckBox.php, method TCheckBox::getTagName()
    getTagName | in file TTabPanel.php, method TTabPanel::getTagName()
    getTagName | in file TImage.php, method TImage::getTagName()
    getTagName | in file TTableRow.php, method TTableRow::getTagName()
    getTagName | in file TTableCell.php, method TTableCell::getTagName()
    getTagName | in file TTextBox.php, method TTextBox::getTagName()
    getTagName | in file TAccordion.php, method TAccordion::getTagName()
    getTagName in file TDataList.php, method TDataListItem::getTagName()
    Returns the tag name used for this control.
    getTagName | in file TDataGrid.php, method TDataGrid::getTagName()
    getTagName | in file TPanel.php, method TPanel::getTagName()
    getTagName | in file TAccordion.php, method TAccordionView::getTagName()
    getTagName | in file TReCaptcha.php, method TReCaptcha::getTagName()
    getTagName in file TDataListItemRenderer.php, method TDataListItemRenderer::getTagName()
    Returns the tag name used for this control.
    getTagName | in file TXmlDocument.php, method TXmlElement::getTagName()
    getTagName in file TWebControl.php, method TWebControl::getTagName()
    Returns the tag name used for this control.
    getTagName | in file TBulletedList.php, method TBulletedList::getTagName()
    getTagName | in file THtmlElement.php, method THtmlElement::getTagName()
    getTagName | in file TListControl.php, method TListControl::getTagName()
    getTagName | in file TSlider.php, method TSlider::getTagName()
    getTagName | in file TButton.php, method TButton::getTagName()
    getTagName | in file TTable.php, method TTable::getTagName()
    getTagName | in file TWizard.php, method TWizard::getTagName()
    getTagName | in file THiddenField.php, method THiddenField::getTagName()
    getTarget | in file TImageMap.php, method TImageMap::getTarget()
    getTarget | in file TImageMap.php, method THotSpot::getTarget()
    getTarget | in file TBulletedList.php, method TBulletedList::getTarget()
    getTarget | in file THyperLinkColumn.php, method THyperLinkColumn::getTarget()
    getTarget | in file THyperLink.php, method THyperLink::getTarget()
    getTargetControl | in file TTriggeredCallback.php, method TTriggeredCallback::getTargetControl()
    getTemplate in file TTemplateControl.php, method TTemplateControl::getTemplate()
    Returns the template object associated with this control object.
    getTemplateByClassName in file TTemplateManager.php, method TTemplateManager::getTemplateByClassName()
    Loads the template corresponding to the specified class name.
    getTemplateByFileName in file TTemplateManager.php, method TTemplateManager::getTemplateByFileName()
    Loads the template from the specified file.
    getTemplateControl | in file TControl.php, method TControl::getTemplateControl()
    getTemplateDirectory | in file TTemplateControl.php, method TTemplateControl::getTemplateDirectory()
    getTemplateFile | in file TException.php, method TTemplateException::getTemplateFile()
    getTemplateFile | in file TTemplateManager.php, method TTemplate::getTemplateFile()
    getTemplateManager | in file TPageService.php, method TPageService::getTemplateManager()
    getTemplateSource | in file TException.php, method TTemplateException::getTemplateSource()
    getTempPath | in file TActiveFileUpload.php, method TActiveFileUpload::getTempPath()
    getTestLimit | in file TCaptcha.php, method TCaptcha::getTestLimit()
    getText | in file TTextBox.php, method TTextBox::getText()
    getText | in file TLiteral.php, method TLiteral::getText()
    getText | in file TLiteralColumn.php, method TLiteralColumn::getText()
    getText | in file TListItem.php, method TListItem::getText()
    getText | in file TControl.php, method IButtonControl::getText()
    getText | in file TImageButton.php, method TImageButton::getText()
    getText | in file TDbCommand.php, method TDbCommand::getText()
    getText | in file TListControl.php, method TListControl::getText()
    getText | in file TButton.php, method TButton::getText()
    getText | in file TTabPanel.php, method TTabView::getText()
    getText | in file TLabel.php, method TLabel::getText()
    getText | in file THyperLinkColumn.php, method THyperLinkColumn::getText()
    getText | in file TButtonColumn.php, method TButtonColumn::getText()
    getText | in file TTranslate.php, method TTranslate::getText()
    getText | in file TLinkButton.php, method TLinkButton::getText()
    getText | in file TTableCell.php, method TTableCell::getText()
    getText | in file TTextProcessor.php, method TTextProcessor::getText()
    getText | in file THyperLink.php, method THyperLink::getText()
    getText | in file TCheckBox.php, method TCheckBox::getText()
    getText | in file TAccordion.php, method TAccordionView::getText()
    getTextAlign | in file TCheckBox.php, method TCheckBox::getTextAlign()
    getTextAlign | in file TCheckBoxList.php, method TCheckBoxList::getTextAlign()
    getTextCssClass | in file TAutoComplete.php, method TAutoComplete::getTextCssClass()
    getTextMode | in file TTextBox.php, method TTextBox::getTextMode()
    getTextMode in file THtmlArea.php, method THtmlArea::getTextMode()
    Overrides the parent implementation.
    getTheme | in file TPage.php, method TPage::getTheme()
    getTheme | in file TThemeManager.php, method TThemeManager::getTheme()
    getThemeClass | in file TThemeManager.php, method TThemeManager::getThemeClass()
    getThemeManager | in file TPageService.php, method TPageService::getThemeManager()
    getThemeName | in file TReCaptcha.php, method TReCaptcha::getThemeName()
    getThreshold | in file TMemCache.php, method TMemCache::getThreshold()
    getTimeout | in file TDbConnection.php, method TDbConnection::getTimeout()
    getTimeout | in file THttpSession.php, method THttpSession::getTimeout()
    getTimeStamp | in file TDatePicker.php, method TDatePicker::getTimeStamp()
    getTimeStamp in file TDateTimeStamp.php, method TDateTimeStamp::getTimeStamp()
    Not a very fast algorithm - O(n) operation. Could be optimized to O(1).
    getTimestamp | in file TCache.php, method TFileCacheDependency::getTimestamp()
    getTimeStampFromText in file TDatePicker.php, method TDatePicker::getTimeStampFromText()
    Gets the date from the text input using TSimpleDateFormatter
    getTimeValue | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::getTimeValue()
    getTitle | in file THead.php, method THead::getTitle()
    getTitle | in file TWizard.php, method TWizardStep::getTitle()
    getTitle | in file TPage.php, method TPage::getTitle()
    getToggleKey | in file TJavascriptLogger.php, method TJavascriptLogger::getToggleKey()
    getToken | in file TCaptcha.php, method TCaptcha::getToken()
    getToken | in file TAutoComplete.php, method TAutoCompleteEventParameter::getToken()
    getTokenAlphabet | in file TCaptcha.php, method TCaptcha::getTokenAlphabet()
    getTokenExpiry | in file TCaptcha.php, method TCaptcha::getTokenExpiry()
    getTokenFontSize | in file TCaptcha.php, method TCaptcha::getTokenFontSize()
    getTokenImageOptions | in file TCaptcha.php, method TCaptcha::getTokenImageOptions()
    getTokenImageTheme | in file TCaptcha.php, method TCaptcha::getTokenImageTheme()
    getTokenLength | in file TCaptcha.php, method TCaptcha::getTokenLength()
    getToolTip | in file TWebControl.php, method TWebControl::getToolTip()
    getTop | in file TImageMap.php, method TRectangleHotSpot::getTop()
    getTopPager | in file TDataGrid.php, method TDataGrid::getTopPager()
    getTotalRowCount | in file TDataSourceView.php, method TDataSourceSelectParameters::getTotalRowCount()
    getTransactionClass | in file TDbConnection.php, method TDbConnection::getTransactionClass()
    getTransformContent | in file TXmlTransform.php, method TXmlTransform::getTransformContent()
    getTransformPath | in file TXmlTransform.php, method TXmlTransform::getTransformPath()
    getTranslateDefaultCulture | in file TGlobalization.php, method TGlobalization::getTranslateDefaultCulture()
    getTranslationCatalogue | in file TGlobalization.php, method TGlobalization::getTranslationCatalogue()
    getTranslationConfiguration | in file TGlobalization.php, method TGlobalization::getTranslationConfiguration()
    getTriggerOptions | in file TValueTriggeredCallback.php, method TValueTriggeredCallback::getTriggerOptions()
    getTriggerOptions | in file TEventTriggeredCallback.php, method TEventTriggeredCallback::getTriggerOptions()
    getTriggerOptions | in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::getTriggerOptions()
    getTriggerOptions | in file TTriggeredCallback.php, method TTriggeredCallback::getTriggerOptions()
    getTrim in file TTranslate.php, method TTranslate::getTrim()
    Trim the content or not.
    getTrim in file TTranslateParameter.php, method TTranslateParameter::getTrim()
    Trim the content or not.
    getTrueTemplate | in file TConditional.php, method TConditional::getTrueTemplate()
    getType | in file TSqlMapStatement.php, method TSqlMapSelectKey::getType()
    getType | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::getType()
    getType in file TNumberFormat.php, method TNumberFormat::getType()
    Get the formatting type for this control.
    getType | in file TParameterProperty.php, method TParameterProperty::getType()
    getType | in file TResultProperty.php, method TResultProperty::getType()
    getType | in file TDiscriminator.php, method TDiscriminator::getType()
    getTypedValue | in file TResultProperty.php, method TResultProperty::getTypedValue()
    getTypeHandler | in file TResultProperty.php, method TResultProperty::getTypeHandler()
    getTypeHandler | in file TParameterProperty.php, method TParameterProperty::getTypeHandler()
    getTypeHandler | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandlerRegistry::getTypeHandler()
    getTypeHandler | in file TDiscriminator.php, method TDiscriminator::getTypeHandler()
    getTypeHandlers | in file TSqlMapManager.php, method TSqlMapManager::getTypeHandlers()
    getUnderline | in file TFont.php, method TFont::getUnderline()
    getUniqueGroupName | in file TRadioButton.php, method TRadioButton::getUniqueGroupName()
    getUniqueID in file TControl.php, method TControl::getUniqueID()
    Returns a unique ID that identifies the control in the page hierarchy.
    getUniqueID | in file TApplication.php, method TApplication::getUniqueID()
    getUpdateImageUrl | in file TEditCommandColumn.php, method TEditCommandColumn::getUpdateImageUrl()
    getUpdateText | in file TEditCommandColumn.php, method TEditCommandColumn::getUpdateText()
    getUpdateValues | in file TActiveRecordGateway.php, method TActiveRecordGateway::getUpdateValues()
    getUploadedFiles | in file THttpRequest.php, method THttpRequest::getUploadedFiles()
    getUpToYear | in file TDatePicker.php, method TDatePicker::getUpToYear()
    getUri | in file TSoapService.php, method TSoapServer::getUri()
    getUri | in file THttpRequest.php, method TUri::getUri()
    getUrl | in file THttpRequest.php, method THttpRequest::getUrl()
    getUrlFormat | in file TUrlMapping.php, method TUrlMappingPattern::getUrlFormat()
    getUrlFormat | in file THttpRequest.php, method THttpRequest::getUrlFormat()
    getUrlManager | in file THttpRequest.php, method THttpRequest::getUrlManager()
    getUrlManagerModule | in file THttpRequest.php, method THttpRequest::getUrlManagerModule()
    getUrlParamSeparator | in file TUrlMapping.php, method TUrlMappingPattern::getUrlParamSeparator()
    getUrlParamSeparator | in file THttpRequest.php, method THttpRequest::getUrlParamSeparator()
    getUrlPrefix | in file TUrlMapping.php, method TUrlMapping::getUrlPrefix()
    getUrlReferrer | in file THttpRequest.php, method THttpRequest::getUrlReferrer()
    getUseCustomStorage | in file THttpSession.php, method THttpSession::getUseCustomStorage()
    getUseDefaultLayout | in file TWizard.php, method TWizard::getUseDefaultLayout()
    getUser | in file THttpRequest.php, method TUri::getUser()
    getUser in file TUserManager.php, method TUserManager::getUser()
    Returns a user instance given the user name.
    getUser | in file TApplicationComponent.php, method TApplicationComponent::getUser()
    getUser in file IUserManager.php, method IUserManager::getUser()
    Returns a user instance given the user name.
    getUser | in file TApplication.php, method TApplication::getUser()
    getUser in file TDbUserManager.php, method TDbUserManager::getUser()
    Returns a user instance given the user name.
    getUserAgent | in file THttpRequest.php, method THttpRequest::getUserAgent()
    getUserClass | in file TDbUserManager.php, method TDbUserManager::getUserClass()
    getUserFile | in file TUserManager.php, method TUserManager::getUserFile()
    getUserFromCookie in file TDbUserManager.php, method TDbUserManager::getUserFromCookie()
    Returns a user instance according to auth data stored in a cookie.
    getUserFromCookie in file TUserManager.php, method TUserManager::getUserFromCookie()
    Returns a user instance according to auth data stored in a cookie.
    getUserFromCookie in file IUserManager.php, method IUserManager::getUserFromCookie()
    Returns a user instance according to auth data stored in a cookie.
    getUserHost | in file THttpRequest.php, method THttpRequest::getUserHost()
    getUserHostAddress | in file THttpRequest.php, method THttpRequest::getUserHostAddress()
    getUserKey | in file TAuthManager.php, method TAuthManager::getUserKey()
    getUserLanguages in file THttpRequest.php, method THttpRequest::getUserLanguages()
    Returns a list of user preferred languages.
    getUserLanguages in file PradoBase.php, method PradoBase::getUserLanguages()
    Returns a list of user preferred languages.
    getUserManager | in file TAuthManager.php, method TAuthManager::getUserManager()
    getUsername | in file TDbConnection.php, method TDbConnection::getUsername()
    getUsername | in file TDbCache.php, method TDbCache::getUsername()
    getUsers in file TUserManager.php, method TUserManager::getUsers()
    Returns an array of all users.
    getUsers | in file TAuthorizationRule.php, method TAuthorizationRule::getUsers()
    getUseState | in file TWebControlDecorator.php, method TWebControlDecorator::getUseState()
    getUseTransparentSessionID | in file THttpSession.php, method THttpSession::getUseTransparentSessionID()
    getUsingDataSourceID | in file TDataBoundControl.php, method TDataBoundControl::getUsingDataSourceID()
    getUsings in file TApplication.php, method TApplicationConfiguration::getUsings()
    Returns list of namespaces to be used.
    getValidation | in file TSecurityManager.php, method TSecurityManager::getValidation()
    getValidationGroup | in file TImageButton.php, method TImageButton::getValidationGroup()
    getValidationGroup | in file TImageMap.php, method THotSpot::getValidationGroup()
    getValidationGroup | in file TLinkButton.php, method TLinkButton::getValidationGroup()
    getValidationGroup | in file TListControl.php, method TListControl::getValidationGroup()
    getValidationGroup | in file TControl.php, method IButtonControl::getValidationGroup()
    getValidationGroup | in file TButtonColumn.php, method TButtonColumn::getValidationGroup()
    getValidationGroup | in file TScaffoldEditView.php, method TScaffoldEditView::getValidationGroup()
    getValidationGroup | in file TBaseValidator.php, method TBaseValidator::getValidationGroup()
    getValidationGroup | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::getValidationGroup()
    getValidationGroup | in file TCheckBox.php, method TCheckBox::getValidationGroup()
    getValidationGroup | in file TEditCommandColumn.php, method TEditCommandColumn::getValidationGroup()
    getValidationGroup | in file TValidationSummary.php, method TValidationSummary::getValidationGroup()
    getValidationGroup | in file TButton.php, method TButton::getValidationGroup()
    getValidationGroup | in file TTextBox.php, method TTextBox::getValidationGroup()
    getValidationKey | in file TSecurityManager.php, method TSecurityManager::getValidationKey()
    getValidationPropertyValue in file THiddenField.php, method THiddenField::getValidationPropertyValue()
    Returns the value to be validated.
    getValidationPropertyValue in file TDatePicker.php, method TDatePicker::getValidationPropertyValue()
    Returns the value to be validated.
    getValidationPropertyValue in file TDropDownList.php, method TDropDownList::getValidationPropertyValue()
    Returns the value to be validated.
    getValidationPropertyValue in file TTextBox.php, method TTextBox::getValidationPropertyValue()
    Returns the value to be validated.
    getValidationPropertyValue in file TFileUpload.php, method TFileUpload::getValidationPropertyValue()
    Returns the original file name as the property value to be validated.
    getValidationPropertyValue in file TCheckBoxList.php, method TCheckBoxList::getValidationPropertyValue()
    Returns the value to be validated.
    getValidationPropertyValue in file TCheckBox.php, method TCheckBox::getValidationPropertyValue()
    Returns the value of the property that needs validation.
    getValidationPropertyValue in file TListBox.php, method TListBox::getValidationPropertyValue()
    Returns the value to be validated.
    getValidationPropertyValue | in file TReCaptcha.php, method TReCaptcha::getValidationPropertyValue()
    getValidationPropertyValue | in file TControl.php, method IValidatable::getValidationPropertyValue()
    getValidationTarget | in file TBaseValidator.php, method TBaseValidator::getValidationTarget()
    getValidationTarget | in file TCustomValidator.php, method TCustomValidator::getValidationTarget()
    getValidationValue in file TBaseValidator.php, method TBaseValidator::getValidationValue()
    Retrieves the property value of the control being validated.
    getValidators in file TPage.php, method TPage::getValidators()
    Returns a list of registered validators.
    getValue in file TXCache.php, method TXCache::getValue()
    Retrieves a value from cache with a specified key.
    getValue in file TAPCCache.php, method TAPCCache::getValue()
    Retrieves a value from cache with a specified key.
    getValue | in file TDiscriminator.php, method TSubMap::getValue()
    getValue | in file TCheckBox.php, method TCheckBox::getValue()
    getValue in file TDbCache.php, method TDbCache::getValue()
    Retrieves a value from cache with a specified key.
    getValue | in file TCustomValidator.php, method TServerValidateEventParameter::getValue()
    getValue | in file TChoiceFormat.php, method TChoiceFormat::getValue()
    getValue in file TDateFormat.php, method TDateFormat::getValue()
    Get the date-time value for this control.
    getValue | in file TTranslateParameter.php, method TTranslateParameter::getValue()
    getValue in file TCache.php, method TCache::getValue()
    Retrieves a value from cache with a specified key.
    getValue | in file THiddenField.php, method THiddenField::getValue()
    getValue | in file TListItem.php, method TListItem::getValue()
    getValue | in file TXmlDocument.php, method TXmlElement::getValue()
    getValue | in file TMappedStatement.php, method TResultSetMapItemParameter::getValue()
    getValue in file TSqliteCache.php, method TSqliteCache::getValue()
    Retrieves a value from cache with a specified key.
    getValue in file TMemCache.php, method TMemCache::getValue()
    Retrieves a value from cache with a specified key.
    getValue in file TNumberFormat.php, method TNumberFormat::getValue()
    Get the numberic value for this control.
    getValue | in file TSlider.php, method TSlider::getValue()
    getValue | in file THttpRequest.php, method THttpCookie::getValue()
    getValueAttribute | in file TCheckBox.php, method TCheckBox::getValueAttribute()
    getValueAttribute | in file TRadioButton.php, method TRadioButton::getValueAttribute()
    getValues | in file TSlider.php, method TSlider::getValues()
    getValueToCompare | in file TCompareValidator.php, method TCompareValidator::getValueToCompare()
    getVaryByParam | in file TOutputCache.php, method TOutputCache::getVaryByParam()
    getVaryBySession | in file TOutputCache.php, method TOutputCache::getVaryBySession()
    getVerb | in file TAuthorizationRule.php, method TAuthorizationRule::getVerb()
    getVersion | in file TSoapService.php, method TSoapServer::getVersion()
    getVersion | in file TXmlDocument.php, method TXmlDocument::getVersion()
    getVersion | in file PradoBase.php, method PradoBase::getVersion()
    getVerticalAlign | in file TStyle.php, method TTableItemStyle::getVerticalAlign()
    getVerticalAlign | in file TTableRow.php, method TTableRow::getVerticalAlign()
    getVerticalAlign | in file TTableCell.php, method TTableCell::getVerticalAlign()
    getView | in file TDataSourceControl.php, method TDataSourceControl::getView()
    getView | in file TDataSourceControl.php, method IDataSource::getView()
    getView | in file TDataSourceControl.php, method TReadOnlyDataSource::getView()
    getViewCssClass | in file TAccordion.php, method TAccordion::getViewCssClass()
    getViewCssClass | in file TTabPanel.php, method TTabPanel::getViewCssClass()
    getViewHeight | in file TAccordion.php, method TAccordion::getViewHeight()
    getViewNames | in file TDataSourceControl.php, method TDataSourceControl::getViewNames()
    getViewNames | in file TDataSourceControl.php, method IDataSource::getViewNames()
    getViews | in file TTabPanel.php, method TTabPanel::getViews()
    getViews | in file TAccordion.php, method TAccordion::getViews()
    getViews | in file TMultiView.php, method TMultiView::getViews()
    getViewState in file TImageMap.php, method THotSpot::getViewState()
    Returns a viewstate value.
    getViewState in file TControl.php, method TControl::getViewState()
    Returns a viewstate value.
    getViewState in file TDataGridColumn.php, method TDataGridColumn::getViewState()
    Returns a viewstate value.
    getViewStyle | in file TAccordion.php, method TAccordion::getViewStyle()
    getViewStyle | in file TTabPanel.php, method TTabPanel::getViewStyle()
    getVirtualCount | in file TPagedList.php, method TPagedList::getVirtualCount()
    getVirtualItemCount | in file TPagedDataSource.php, method TPagedDataSource::getVirtualItemCount()
    getVirtualItemCount | in file TDataBoundControl.php, method TDataBoundControl::getVirtualItemCount()
    getVisible in file TControl.php, method TControl::getVisible()
    Checks if a control is visible.
    getVisible | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::getVisible()
    getVisible | in file TMultiView.php, method TView::getVisible()
    getVisible | in file TDataGridColumn.php, method TDataGridColumn::getVisible()
    getVisible | in file TDataSourceControl.php, method TDataSourceControl::getVisible()
    getWidth | in file TStyle.php, method TStyle::getWidth()
    getWidth | in file TWebControl.php, method TWebControl::getWidth()
    getWizard | in file TWizard.php, method TWizardNavigationTemplate::getWizard()
    getWizard | in file TWizard.php, method TWizardStep::getWizard()
    getWizardSteps | in file TWizard.php, method TWizard::getWizardSteps()
    getWrap | in file TTextBox.php, method TTextBox::getWrap()
    getWrap | in file TTableCell.php, method TTableCell::getWrap()
    getWrap | in file TPanel.php, method TPanel::getWrap()
    getWrap | in file TPanelStyle.php, method TPanelStyle::getWrap()
    getWrap | in file TStyle.php, method TTableItemStyle::getWrap()
    getWriter | in file THtmlWriter.php, method THtmlWriter::getWriter()
    getWsdl in file TSoapService.php, method TSoapServer::getWsdl()
    Returns the WSDL content of the SOAP server.
    getWsdlUri | in file TSoapService.php, method TSoapServer::getWsdlUri()
    getX | in file TImageMap.php, method TCircleHotSpot::getX()
    getX | in file TImageButton.php, method TImageClickEventParameter::getX()
    getY | in file TImageMap.php, method TCircleHotSpot::getY()
    getY | in file TImageButton.php, method TImageClickEventParameter::getY()
    getYearPattern | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::getYearPattern()
    Ghosting | in file TDraggable.php, class constant TDraggableGhostingOptions::Ghosting
    GLOBAL_FILE in file TApplication.php, class constant TApplication::GLOBAL_FILE
    Global data file
    gotoPage in file TPagedList.php, method TPagedList::gotoPage()
    Changes to a page with the specified page index.
    GreaterThan | in file TCompareValidator.php, class constant TValidationCompareOperator::GreaterThan
    GreaterThanEqual | in file TCompareValidator.php, class constant TValidationCompareOperator::GreaterThanEqual
    grow in file TCallbackClientScript.php, method TCallbackClientScript::grow()
    Visual Effect: Gradually make an element grow to a predetermined size.
    guessMethodCallRequested in file TSoapService.php, method TSoapServer::guessMethodCallRequested()
    Guess the SOAP method request from the actual SOAP message
    top
    h
    $handler | in file TRpcService.php, variable TRpcServer::$handler
    handleCallback in file TActivePager.php, method TActivePager::handleCallback()
    Event handler to the OnCallback active buttons or active dropdownlist.
    handleError in file TErrorHandler.php, method TErrorHandler::handleError()
    Handles PHP user errors and exceptions.
    handleException in file TTemplateManager.php, method TTemplate::handleException()
    Handles template parsing exception.
    handleExternalError in file TErrorHandler.php, method TErrorHandler::handleExternalError()
    Displays error to the client user.
    handleRecursiveError in file TErrorHandler.php, method TErrorHandler::handleRecursiveError()
    Handles error occurs during error handling (called recursive error).
    has | in file TPropertyAccess.php, method TPropertyAccess::has()
    hasAssociationTable | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::hasAssociationTable()
    hasAttribute | in file TListItem.php, method TListItem::hasAttribute()
    hasAttribute | in file TControl.php, method TControl::hasAttribute()
    hasAttribute | in file TImageMap.php, method THotSpot::hasAttribute()
    hasBeginScripts | in file TClientScriptManager.php, method TClientScriptManager::hasBeginScripts()
    hasChildren | in file TMappedStatement.php, method TSqlMapObjectCollectionTree::hasChildren()
    hasCssClass | in file TStyle.php, method TStyle::hasCssClass()
    hasDayPattern | in file TDatePicker.php, method TDatePicker::hasDayPattern()
    hasEndScripts | in file TClientScriptManager.php, method TClientScriptManager::hasEndScripts()
    hasEvent in file TComponent.php, method TComponent::hasEvent()
    Determines whether an event is defined.
    hasEventHandler | in file TComponent.php, method TComponent::hasEventHandler()
    hasFkField | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::hasFkField()
    hasFont | in file TStyle.php, method TStyle::hasFont()
    hash in file TAssetManager.php, method TAssetManager::hash()
    Generate a CRC32 hash for the directory path. Collisions are higher than MD5 but generates a much smaller hash string.
    hash2string in file TCaptcha.php, method TCaptcha::hash2string()
    Converts a hash string into a string with characters consisting of alphanumeric characters.
    hashData in file TSecurityManager.php, method TSecurityManager::hashData()
    Prefixes data with an HMAC.
    hasIntegerKey | in file TDbCommandBuilder.php, method TDbCommandBuilder::hasIntegerKey()
    hasMethod in file TLazyLoadList.php, method TLazyLoadList::hasMethod()
    Try to fetch the data when any of the proxy collection method is called.
    hasParameter | in file TTranslate.php, method TTranslate::hasParameter()
    hasProperty in file TComponent.php, method TComponent::hasProperty()
    Determines whether a property is defined.
    hasProperty in file TAttributeCollection.php, method TAttributeCollection::hasProperty()
    Determines whether a property is defined.
    hasRecordRelation | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::hasRecordRelation()
    hasRecordRelation | in file TActiveRecord.php, method TActiveRecord::hasRecordRelation()
    hasSequence | in file TMysqlTableColumn.php, method TMysqlTableColumn::hasSequence()
    hasSequence | in file TMssqlTableColumn.php, method TMssqlTableColumn::hasSequence()
    hasSequence | in file TDbTableColumn.php, method TDbTableColumn::hasSequence()
    hasSequence | in file TSqliteTableColumn.php, method TSqliteTableColumn::hasSequence()
    hasStyleField | in file TStyle.php, method TStyle::hasStyleField()
    HAS_MANY | in file TActiveRecord.php, class constant TActiveRecord::HAS_MANY
    HAS_ONE | in file TActiveRecord.php, class constant TActiveRecord::HAS_ONE
    Header | in file TDataBoundControl.php, class constant TListItemType::Header
    Header | in file TTableRow.php, class constant TTableRowSection::Header
    HeaderOnly | in file TValidationSummary.php, class constant TValidationSummaryDisplayMode::HeaderOnly
    Hidden | in file TStyle.php, class constant TDisplayStyle::Hidden
    hide in file TCallbackClientScript.php, method TCallbackClientScript::hide()
    Hides an element by changing its CSS display style to "none".
    hideSecurityRelated | in file TErrorHandler.php, method TErrorHandler::hideSecurityRelated()
    highlight in file TCallbackClientScript.php, method TCallbackClientScript::highlight()
    Visual Effect: High light the element for about 2 seconds.
    highlightCode in file TMarkdown.php, method TMarkdown::highlightCode()
    Highlights source code using TTextHighlighter
    HomeCity | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomeCity
    HomeCountryRegion | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomeCountryRegion
    HomeFax | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomeFax
    Homepage | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Homepage
    HomePhone | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomePhone
    HomeState | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomeState
    HomeStreetAddress | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomeStreetAddress
    HomeZipCode | in file TTextBox.php, class constant TTextBoxAutoCompleteType::HomeZipCode
    Horizontal | in file TDraggable.php, class constant TDraggableConstraint::Horizontal
    Horizontal | in file TPanelStyle.php, class constant TScrollBars::Horizontal
    Horizontal | in file TRepeatInfo.php, class constant TRepeatDirection::Horizontal
    Horizontal | in file TStyle.php, class constant TTableGridLines::Horizontal
    Horizontal | in file TSlider.php, class constant TSliderDirection::Horizontal
    htmlDecode in file THttpUtility.php, method THttpUtility::htmlDecode()
    HTML-decodes a string.
    htmlEncode in file THttpUtility.php, method THttpUtility::htmlEncode()
    HTML-encodes a string.
    htmlStrip in file THttpUtility.php, method THttpUtility::htmlStrip()
    This method strips the following characters from a string:
    httpRedirect in file TCallbackResponseAdapter.php, method TCallbackResponseAdapter::httpRedirect()
    Delay the redirect until we process the rest of the page.
    httpRedirect in file THttpResponse.php, method THttpResponse::httpRedirect()
    Redirect the browser to another URL and exists the current application.
    httpRedirect in file THttpResponseAdapter.php, method THttpResponseAdapter::httpRedirect()
    This method is invoked when the response is to redirect to another page.
    HyperLink | in file TBulletedList.php, class constant TBulletedListDisplayMode::HyperLink
    top
    i
    IMappedStatement.php | procedural page IMappedStatement.php
    IActiveControl in file interfaces.php, class IActiveControl
    IActiveControl interface.
    IBindable in file interfaces.php, class IBindable
    IBindable interface.
    IBroadcastEventReceiver in file TControl.php, class IBroadcastEventReceiver
    IBroadcastEventReceiver interface
    IButtonControl in file TControl.php, class IButtonControl
    IButtonControl interface
    ICache in file interfaces.php, class ICache
    ICache interface.
    ICacheDependency in file interfaces.php, class ICacheDependency
    ICacheDependency interface.
    ICallbackEventHandler in file interfaces.php, class ICallbackEventHandler
    ICallbackEventHandler interface.
    IDataRenderer in file interfaces.php, class IDataRenderer
    IDataRenderer interface.
    IDataSource in file TDataSourceControl.php, class IDataSource
    IDataSource class
    ID_FORMAT in file TControl.php, class constant TControl::ID_FORMAT
    format of control ID
    ID_SEPARATOR in file TControl.php, class constant TControl::ID_SEPARATOR
    separator char between IDs in a UniqueID
    ID_SIDEBAR_BUTTON in file TWizard.php, class constant TWizard::ID_SIDEBAR_BUTTON
    Side bar button ID
    ID_SIDEBAR_LIST in file TWizard.php, class constant TWizard::ID_SIDEBAR_LIST
    Side bar data list
    IFeedContentProvider in file TFeedService.php, class IFeedContentProvider
    IFeedContentProvider interface.
    ignoreBubbleEvents in file TMultiView.php, method TMultiView::ignoreBubbleEvents()
    Makes the multiview ignore all bubbled events.
    IItemDataRenderer in file TDataBoundControl.php, class IItemDataRenderer
    IItemDataRenderer interface.
    IListControlAdapter in file TListControl.php, class IListControlAdapter
    IListControlAdapter interface
    Image | in file TWizard.php, class constant TWizardNavigationButtonType::Image
    ImageButton | in file TPager.php, class constant TPagerButtonType::ImageButton
    ImageButton | in file TDatePicker.php, class constant TDatePickerMode::ImageButton
    ImageButton | in file TDataGridColumn.php, class constant TButtonColumnType::ImageButton
    IMappedStatement in file IMappedStatement.php, class IMappedStatement
    Interface for all mapping statements.
    IModule in file interfaces.php, class IModule
    IModule interface.
    implodeNode | in file TSqlMapException.php, method TSqlMapException::implodeNode()
    Inactive | in file TImageMap.php, class constant THotSpotMode::Inactive
    INamingContainer in file TControl.php, class INamingContainer
    INamingContainer interface.
    indexOf | in file TList.php, method TList::indexOf()
    indexOf | in file TPriorityList.php, method TPriorityList::indexOf()
    indexOf | in file TPagedList.php, method TPagedList::indexOf()
    INFO | in file TLogger.php, class constant TLogger::INFO
    init | in file TGlobalizationAutoDetect.php, method TGlobalizationAutoDetect::init()
    init in file TGlobalization.php, method TGlobalization::init()
    Initialize the Culture and Charset for this application.
    init in file THttpRequest.php, method THttpRequest::init()
    Initializes the module.
    init in file THttpResponse.php, method THttpResponse::init()
    Initializes the module.
    init in file TUserManager.php, method TUserManager::init()
    Initializes the module.
    init in file TCacheHttpSession.php, method TCacheHttpSession::init()
    Initializes the module.
    init in file TErrorHandler.php, method TErrorHandler::init()
    Initializes the module.
    init in file TThemeManager.php, method TThemeManager::init()
    Initializes the module.
    init in file TDbCache.php, method TDbCache::init()
    Initializes this module.
    init in file TTemplateManager.php, method TTemplateManager::init()
    Initializes the module.
    init in file THttpSession.php, method THttpSession::init()
    Initializes the module.
    init in file TUrlMapping.php, method TUrlMapping::init()
    Initializes this module.
    init in file TSoapService.php, method TSoapService::init()
    Initializes this module.
    init in file TFeedService.php, method IFeedContentProvider::init()
    Initializes the feed content provider.
    init in file TUrlMapping.php, method TUrlMappingPattern::init()
    Initializes the pattern.
    init in file TDataSourceConfig.php, method TDataSourceConfig::init()
    Initalize the database connection properties from attributes in <database> tag.
    init in file TDbUserManager.php, method TDbUserManager::init()
    Initializes the module.
    init in file TFeedService.php, method TFeedService::init()
    Initializes this module.
    init in file TAuthManager.php, method TAuthManager::init()
    Initializes this module.
    init in file Translation.php, method Translation::init()
    Initialize the TTranslate translation components
    init in file TXCache.php, method TXCache::init()
    Initializes this module.
    init in file TParameterModule.php, method TParameterModule::init()
    Initializes the module by loading parameters.
    init in file TPageService.php, method TPageService::init()
    Initializes the service.
    init in file TCache.php, method TCache::init()
    Initializes the cache module.
    init in file TSqliteCache.php, method TSqliteCache::init()
    Initializes this module.
    init in file interfaces.php, method IService::init()
    Initializes the service.
    init in file TService.php, method TService::init()
    Initializes the service and attaches run to the RunService event of application.
    init in file interfaces.php, method IModule::init()
    Initializes the module.
    init in file TSecurityManager.php, method TSecurityManager::init()
    Initializes the module.
    init in file TRpcService.php, method TRpcService::init()
    Initializes the service
    init in file TMemCache.php, method TMemCache::init()
    Initializes this module.
    init in file TModule.php, method TModule::init()
    Initializes the module.
    init in file TJsonService.php, method TJsonService::init()
    Initializes this module.
    init in file TLogRouter.php, method TDbLogRoute::init()
    Initializes this module.
    init in file TApplication.php, method TApplicationStatePersister::init()
    Initializes module.
    init in file TAPCCache.php, method TAPCCache::init()
    Initializes this module.
    init in file TAssetManager.php, method TAssetManager::init()
    Initializes the module.
    init in file TLogRouter.php, method TLogRoute::init()
    Initializes the route.
    init in file TActiveRecordConfig.php, method TActiveRecordConfig::init()
    Initialize the active record manager.
    init in file TLogRouter.php, method TLogRouter::init()
    Initializes this module.
    init in file TLogRouter.php, method TEmailLogRoute::init()
    Initializes the route.
    init in file TJsonService.php, method TJsonResponse::init()
    Initializes the feed.
    initApplication in file TApplication.php, method TApplication::initApplication()
    Loads configuration and initializes application.
    initCommandBuilder | in file TTableGateway.php, method TTableGateway::initCommandBuilder()
    initErrorHandlers in file PradoBase.php, method PradoBase::initErrorHandlers()
    Initializes error handlers.
    initialGroupByResults in file TMappedStatement.php, method TMappedStatement::initialGroupByResults()
    Empty the group by results cache.
    initialize in file TSqlMapPagedList.php, method TSqlMapPagedList::initialize()
    Initialize the paged list.
    initialize in file TDiscriminator.php, method TDiscriminator::initialize()
    Set the result maps for particular sub-mapping values.
    initialize in file TDataGridColumn.php, method TDataGridColumn::initialize()
    Initializes the column.
    initialize | in file TSqlMapStatement.php, method TSqlMapStatement::initialize()
    initialize in file TSqlMapCacheModel.php, method TSqlMapCacheModel::initialize()
    Initialize the cache implementation, sets the actual cache contain if supplied.
    initializeCache in file TDbCache.php, method TDbCache::initializeCache()
    Initialize TDbCache
    initializeCell in file TLiteralColumn.php, method TLiteralColumn::initializeCell()
    Initializes the specified cell to its initial values.
    initializeCell in file TEditCommandColumn.php, method TEditCommandColumn::initializeCell()
    Initializes the specified cell to its initial values.
    initializeCell | in file TActiveDataGrid.php, method TActiveButtonColumn::initializeCell()
    initializeCell in file TActiveDataGrid.php, method TActiveCheckBoxColumn::initializeCell()
    Initializes the specified cell to its initial values.
    initializeCell in file TDataGridColumn.php, method TDataGridColumn::initializeCell()
    Initializes the specified cell to its initial values.
    initializeCell in file TButtonColumn.php, method TButtonColumn::initializeCell()
    Initializes the specified cell to its initial values.
    initializeCell in file TBoundColumn.php, method TBoundColumn::initializeCell()
    Initializes the specified cell to its initial values.
    initializeCell in file THyperLinkColumn.php, method THyperLinkColumn::initializeCell()
    Initializes the specified cell to its initial values.
    initializeCell in file TDropDownListColumn.php, method TDropDownListColumn::initializeCell()
    Initializes the specified cell to its initial values.
    initializeCell in file TCheckBoxColumn.php, method TCheckBoxColumn::initializeCell()
    Initializes the specified cell to its initial values.
    initializeCell in file TTemplateColumn.php, method TTemplateColumn::initializeCell()
    Initializes the specified cell to its initial values.
    initializeEdit in file TScaffoldListView.php, method TScaffoldListView::initializeEdit()
    Initialize the edit view control form when EditViewID is set.
    initializeEditForm in file TScaffoldEditView.php, method TScaffoldEditView::initializeEditForm()
    Initialize the editor form
    initializeFooterCell in file TDataGridColumn.php, method TDataGridColumn::initializeFooterCell()
    Initializes the footer cell.
    initializeHeaderCell | in file TActiveDataGrid.php, method TActiveLiteralColumn::initializeHeaderCell()
    initializeHeaderCell | in file TActiveDataGrid.php, method TActiveTemplateColumn::initializeHeaderCell()
    initializeHeaderCell in file TDataGridColumn.php, method TDataGridColumn::initializeHeaderCell()
    Initializes the header cell.
    initializeHeaderCell | in file TActiveDataGrid.php, method TActiveHyperLinkColumn::initializeHeaderCell()
    initializeHeaderCell | in file TActiveDataGrid.php, method TActiveBoundColumn::initializeHeaderCell()
    initializeHeaderCell | in file TActiveDataGrid.php, method TActiveDropDownListColumn::initializeHeaderCell()
    initializeHeaderCell | in file TActiveDataGrid.php, method TActiveCheckBoxColumn::initializeHeaderCell()
    initializeItem in file TDataGrid.php, method TDataGrid::initializeItem()
    Initializes a datagrid item and cells inside it
    initializeSort in file TScaffoldListView.php, method TScaffoldListView::initializeSort()
    Initialize the sort drop down list and the column names repeater.
    initMapping in file TDiscriminator.php, method TDiscriminator::initMapping()
    Copies the discriminator properties to a new TResultProperty.
    initPageContext in file TPageService.php, method TPageService::initPageContext()
    Initializes page context.
    initRecursive in file TCompositeControl.php, method TCompositeControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
    initRecursive in file TOutputCache.php, method TOutputCache::initRecursive()
    Performs the Init step for the control and all its child controls.
    initRecursive in file TTemplateControl.php, method TTemplateControl::initRecursive()
    Performs the OnInit step for the control and all its child controls.
    initRecursive in file TControl.php, method TControl::initRecursive()
    Performs the Init step for the control and all its child controls.
    injectContent in file TTemplateControl.php, method TTemplateControl::injectContent()
    Injects all content controls (and their children) to the corresponding content placeholders.
    INLINE_PLACEHOLDER | in file TSqlMapXmlConfiguration.php, class constant TSqlMapXmlMappingConfiguration::INLINE_PLACEHOLDER
    INLINE_SYMBOL | in file TSqlMapXmlConfiguration.php, class constant TSqlMapXmlMappingConfiguration::INLINE_SYMBOL
    insert in file TActiveRecordGateway.php, method TActiveRecordGateway::insert()
    Insert a new record.
    insert in file TDataGatewayCommand.php, method TDataGatewayCommand::insert()
    Inserts a new record into the table. Each array key must correspond to a column name in the table unless a null value is permitted.
    insert in file TSqlMapGateway.php, method TSqlMapGateway::insert()
    Executes a Sql INSERT statement.
    insert in file TTableGateway.php, method TTableGateway::insert()
    Inserts a new record into the table. Each array key must correspond to a column name in the table unless a null value is permitted.
    insertAfter in file TPriorityList.php, method TPriorityList::insertAfter()
    This inserts an item after another item within the list. It uses the same priority as the found index item and places the new item after it.
    insertAfter in file TList.php, method TList::insertAfter()
    Finds the base item. If found, the item is inserted after it.
    insertAt in file TListItemCollection.php, method TListItemCollection::insertAt()
    Inserts an item into the collection.
    insertAt in file TAuthorizationRule.php, method TAuthorizationRuleCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TDataList.php, method TDataListItemCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TActiveListControlAdapter.php, method TActiveListItemCollection::insertAt()
    Inserts an item into the collection.
    insertAt in file TTableRow.php, method TTableCellCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TList.php, method TList::insertAt()
    Inserts an item at the specified position.
    insertAt in file TTabPanel.php, method TTabViewCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TImageMap.php, method THotSpotCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TDataSourceView.php, method TDataSourceView::insertAt()
    Inserts a DB record.
    insertAt in file TDataGrid.php, method TDataGridItemCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TDataGrid.php, method TDataGridColumnCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TXmlDocument.php, method TXmlElementList::insertAt()
    Inserts an item at the specified position.
    insertAt in file TRepeater.php, method TRepeaterItemCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TControl.php, method TControlCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TControl.php, method TEmptyControlCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TWizard.php, method TWizardStepCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TAccordion.php, method TAccordionViewCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TPriorityList.php, method TPriorityList::insertAt()
    Inserts an item at an index. It reads the priority of the item at index within the flattened list and then inserts the item at that priority-index.
    insertAt in file TTable.php, method TTableRowCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file TCache.php, method TCacheDependencyList::insertAt()
    Inserts an item at the specified position.
    insertAt in file TMultiView.php, method TViewCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file THead.php, method TMetaTagCollection::insertAt()
    Inserts an item at the specified position.
    insertAt in file THttpRequest.php, method THttpCookieCollection::insertAt()
    Inserts an item at the specified position.
    insertAtIndexInPriority in file TPriorityList.php, method TPriorityList::insertAtIndexInPriority()
    Inserts an item at the specified index within a priority. Override and call this method to insert your own functionality.
    insertBefore in file TList.php, method TList::insertBefore()
    Finds the base item. If found, the item is inserted before it.
    insertBefore in file TPriorityList.php, method TPriorityList::insertBefore()
    This inserts an item before another item within the list. It uses the same priority as the found index item and places the new item before it.
    insertContentAfter in file TCallbackClientScript.php, method TCallbackClientScript::insertContentAfter()
    Insert a HTML fragement after the element.
    insertContentBefore in file TCallbackClientScript.php, method TCallbackClientScript::insertContentBefore()
    Insert a HTML fragement in before the element.
    insertProperty | in file TParameterMap.php, method TParameterMap::insertProperty()
    instanceOfArrayType in file TResultProperty.php, method TResultProperty::instanceOfArrayType()
    Returns true if the result property Type is of ArrayAccess
    instanceOfListType in file TResultProperty.php, method TResultProperty::instanceOfListType()
    Returns true if the result property Type is of TList type or that the actual result object is an instance of TList.
    instantiate in file TWebControlDecorator.php, method TWebControlDecorator::instantiate()
    this is a framework call. The Text decoration can't influence the object hierarchy because they are rendered into into the writer directly.
    instantiateIn in file TWizard.php, method TWizardFinishNavigationTemplate::instantiateIn()
    Instantiates the template.
    instantiateIn in file TWizard.php, method TWizardStartNavigationTemplate::instantiateIn()
    Instantiates the template.
    instantiateIn in file TWizard.php, method TWizardSideBarTemplate::instantiateIn()
    Instantiates the template.
    instantiateIn in file TWizard.php, method TWizardSideBarListItemTemplate::instantiateIn()
    Instantiates the template.
    instantiateIn in file TWizard.php, method TWizardStepNavigationTemplate::instantiateIn()
    Instantiates the template.
    instantiateIn in file TTemplateManager.php, method TTemplate::instantiateIn()
    Instantiates the template.
    instantiateIn in file TControl.php, method ITemplate::instantiateIn()
    Instantiates the template.
    instantiateIn in file TWizard.php, method TWizardNavigationTemplate::instantiateIn()
    Instantiates the template.
    instantiateIn in file TAutoComplete.php, method TAutoCompleteTemplate::instantiateIn()
    Instantiates the template.
    instantiateNavigationTemplate in file TWizard.php, method TTemplatedWizardStep::instantiateNavigationTemplate()
    Instantiates the navigation template if any
    Integer | in file TBaseValidator.php, class constant TValidationDataType::Integer
    intercept in file TLazyLoadList.php, method TLazyLoadList::intercept()
    Relay the method call to the underlying collection.
    interfaces.php | procedural page interfaces.php
    IPageStatePersister in file TPage.php, class IPageStatePersister
    IPageStatePersister interface.
    IPostBackDataHandler in file TControl.php, class IPostBackDataHandler
    IPostBackDataHandler interface
    IPostBackEventHandler in file TControl.php, class IPostBackEventHandler
    IPostBackEventHandler interface
    IRenderable in file interfaces.php, class IRenderable
    IRenderable interface.
    IRepeatInfoUser in file TRepeatInfo.php, class IRepeatInfoUser
    IRepeatInfoUser interface.
    isBeginScriptRegistered | in file TClientScriptManager.php, method TClientScriptManager::isBeginScriptRegistered()
    IScaffoldEditRenderer in file TScaffoldEditView.php, class IScaffoldEditRenderer
    IScaffoldEditRenderer interface.
    isDescendentOf | in file TControl.php, method TControl::isDescendentOf()
    isEmpty | in file TMappedStatement.php, method TSqlMapObjectCollectionTree::isEmpty()
    isEmptyFkObject | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::isEmptyFkObject()
    isEndScriptRegistered | in file TClientScriptManager.php, method TClientScriptManager::isEndScriptRegistered()
    isEnumSetType | in file TMysqlMetaData.php, method TMysqlMetaData::isEnumSetType()
    IService in file interfaces.php, class IService
    IService interface.
    isForeignKeyColumn | in file TOracleMetaData.php, method TOracleMetaData::isForeignKeyColumn()
    isForeignKeyColumn | in file TPgsqlMetaData.php, method TPgsqlMetaData::isForeignKeyColumn()
    isForeignKeyColumn | in file TMysqlMetaData.php, method TMysqlMetaData::isForeignKeyColumn()
    isForeignKeyColumn | in file TSqliteMetaData.php, method TSqliteMetaData::isForeignKeyColumn()
    isForeignKeyColumn | in file TMssqlMetaData.php, method TMssqlMetaData::isForeignKeyColumn()
    isFunction in file TJavaScript.php, method TJavaScript::isFunction()
    Deprecated, use isJsLiteral instead
    isGreaterThan | in file TRangeValidator.php, method TRangeValidator::isGreaterThan()
    isHeadScriptFileRegistered | in file TClientScriptManager.php, method TClientScriptManager::isHeadScriptFileRegistered()
    isHeadScriptRegistered | in file TClientScriptManager.php, method TClientScriptManager::isHeadScriptRegistered()
    isHiddenFieldRegistered | in file TClientScriptManager.php, method TClientScriptManager::isHiddenFieldRegistered()
    isInRole | in file interfaces.php, method IUser::isInRole()
    isInRole | in file TUser.php, method TUser::isInRole()
    isJsLiteral | in file TJavaScript.php, method TJavaScript::isJsLiteral()
    isLeapYear in file TDateTimeStamp.php, method TDateTimeStamp::isLeapYear()
    Checks for leap year, returns true if it is. No 2-digit year check. Also handles julian calendar correctly.
    isLessThan | in file TRangeValidator.php, method TRangeValidator::isLessThan()
    isObjectRegistered | in file TControl.php, method TControl::isObjectRegistered()
    isPrecisionType | in file TPgsqlMetaData.php, method TPgsqlMetaData::isPrecisionType()
    isPrecisionType | in file TMysqlMetaData.php, method TMysqlMetaData::isPrecisionType()
    isPrecisionType | in file TOracleMetaData.php, method TOracleMetaData::isPrecisionType()
    isScriptFileRegistered | in file TClientScriptManager.php, method TClientScriptManager::isScriptFileRegistered()
    isSearchableColumn | in file TOracleCommandBuilder.php, method TOracleCommandBuilder::isSearchableColumn()
    isSearchableColumn | in file TPgsqlCommandBuilder.php, method TPgsqlCommandBuilder::isSearchableColumn()
    isStyleSheetFileRegistered | in file TClientScriptManager.php, method TClientScriptManager::isStyleSheetFileRegistered()
    isStyleSheetRegistered | in file TClientScriptManager.php, method TClientScriptManager::isStyleSheetRegistered()
    isSystemPostField | in file TPage.php, method TPage::isSystemPostField()
    IStatePersister in file interfaces.php, class IStatePersister
    IStatePersister class.
    IStyleable in file interfaces.php, class IStyleable
    IStyleable interface.
    ISurroundable in file TControl.php, class ISurroundable
    ISurroundable interface
    isUserAllowed | in file TAuthorizationRule.php, method TAuthorizationRuleCollection::isUserAllowed()
    isUserAllowed | in file TAuthorizationRule.php, method TAuthorizationRule::isUserAllowed()
    isValidDate | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::isValidDate()
    isValidDate | in file TDateTimeStamp.php, method TDateTimeStamp::isValidDate()
    isValidDate in file TRangeValidator.php, method TRangeValidator::isValidDate()
    Determine if the date is within the specified range.
    isValidFloat in file TRangeValidator.php, method TRangeValidator::isValidFloat()
    Determine if the value is within the specified float range.
    isValidIdentifier in file TMysqlMetaData.php, method TMysqlMetaData::isValidIdentifier()
    http://dev.mysql.com/doc/refman/5.0/en/identifiers.html
    isValidInteger in file TRangeValidator.php, method TRangeValidator::isValidInteger()
    Determine if the value is within the integer range.
    isValidString in file TRangeValidator.php, method TRangeValidator::isValidString()
    Compare the string with a minimum and a maxiumum value.
    isValidStringLength | in file TRangeValidator.php, method TRangeValidator::isValidStringLength()
    IS_BOLD in file TFont.php, class constant TFont::IS_BOLD
    Bits indicating the font states.
    IS_CHILD_CREATED | in file TControl.php, class constant TControl::IS_CHILD_CREATED
    IS_CREATING_CHILD | in file TControl.php, class constant TControl::IS_CREATING_CHILD
    IS_DISABLE_THEMING | in file TControl.php, class constant TControl::IS_DISABLE_THEMING
    IS_DISABLE_VIEWSTATE | in file TControl.php, class constant TControl::IS_DISABLE_VIEWSTATE
    IS_ID_SET in file TControl.php, class constant TControl::IS_ID_SET
    State bits.
    IS_ITALIC | in file TFont.php, class constant TFont::IS_ITALIC
    IS_OVERLINE | in file TFont.php, class constant TFont::IS_OVERLINE
    IS_SET_BOLD in file TFont.php, class constant TFont::IS_SET_BOLD
    Bits indicating whether particular font states are changed.
    IS_SET_ITALIC | in file TFont.php, class constant TFont::IS_SET_ITALIC
    IS_SET_NAME | in file TFont.php, class constant TFont::IS_SET_NAME
    IS_SET_OVERLINE | in file TFont.php, class constant TFont::IS_SET_OVERLINE
    IS_SET_SIZE | in file TFont.php, class constant TFont::IS_SET_SIZE
    IS_SET_STRIKEOUT | in file TFont.php, class constant TFont::IS_SET_STRIKEOUT
    IS_SET_UNDERLINE | in file TFont.php, class constant TFont::IS_SET_UNDERLINE
    IS_SKIN_APPLIED | in file TControl.php, class constant TControl::IS_SKIN_APPLIED
    IS_STRIKEOUT | in file TFont.php, class constant TFont::IS_STRIKEOUT
    IS_STYLESHEET_APPLIED | in file TControl.php, class constant TControl::IS_STYLESHEET_APPLIED
    IS_UNDERLINE | in file TFont.php, class constant TFont::IS_UNDERLINE
    Item | in file TDataBoundControl.php, class constant TListItemType::Item
    itemAt in file TList.php, method TList::itemAt()
    Returns the item at the specified offset.
    itemAt in file THttpSession.php, method THttpSession::itemAt()
    Returns the session variable value with the session variable name.
    itemAt in file THttpRequest.php, method THttpRequest::itemAt()
    Returns the item with the specified key.
    itemAt in file TAttributeCollection.php, method TAttributeCollection::itemAt()
    Returns the item with the specified key.
    itemAt in file TMap.php, method TMap::itemAt()
    Returns the item with the specified key.
    itemAt | in file THttpRequest.php, method THttpCookieCollection::itemAt()
    itemAt in file TPagedList.php, method TPagedList::itemAt()
    Returns the item at the specified offset.
    itemAt in file TPriorityList.php, method TPriorityList::itemAt()
    Returns the item at the index of a flattened priority list.
    itemAt in file TPriorityMap.php, method TPriorityMap::itemAt()
    Returns the item with the specified key. If a priority is specified, only items
    itemAtIndexInPriority in file TPriorityList.php, method TPriorityList::itemAtIndexInPriority()
    Returns the item at an index within a priority
    ITemplate in file TControl.php, class ITemplate
    ITemplate interface
    itemsAtPriority in file TPriorityMap.php, method TPriorityMap::itemsAtPriority()
    Gets all the items at a specific priority.
    itemsAtPriority in file TPriorityList.php, method TPriorityList::itemsAtPriority()
    Gets all the items at a specific priority.
    ITextWriter in file interfaces.php, class ITextWriter
    ITextWriter interface.
    ITheme in file TControl.php, class ITheme
    ITheme interface.
    IT_ALTERNATINGITEM | in file TRepeater.php, class constant TRepeater::IT_ALTERNATINGITEM
    IT_ALTERNATINGITEM | in file TDataGrid.php, class constant TDataGrid::IT_ALTERNATINGITEM
    IT_EDITITEM | in file TDataGrid.php, class constant TDataGrid::IT_EDITITEM
    IT_FOOTER | in file TRepeater.php, class constant TRepeater::IT_FOOTER
    IT_FOOTER | in file TDataGrid.php, class constant TDataGrid::IT_FOOTER
    IT_HEADER in file TRepeater.php, class constant TRepeater::IT_HEADER
    Repeater item types
    IT_HEADER in file TDataGrid.php, class constant TDataGrid::IT_HEADER
    datagrid item types
    IT_ITEM | in file TRepeater.php, class constant TRepeater::IT_ITEM
    IT_ITEM | in file TDataGrid.php, class constant TDataGrid::IT_ITEM
    IT_PAGER | in file TDataGrid.php, class constant TDataGrid::IT_PAGER
    IT_SELECTEDITEM | in file TDataGrid.php, class constant TDataGrid::IT_SELECTEDITEM
    IT_SEPARATOR | in file TDataGrid.php, class constant TDataGrid::IT_SEPARATOR
    IT_SEPARATOR | in file TRepeater.php, class constant TRepeater::IT_SEPARATOR
    IUser in file interfaces.php, class IUser
    IUser interface.
    IUserManager in file IUserManager.php, class IUserManager
    IUserManager interface
    IValidatable in file TControl.php, class IValidatable
    IValidatable interface
    IValidator in file TControl.php, class IValidator
    IValidator interface
    IUserManager.php | procedural page IUserManager.php
    top
    j
    JobTitle | in file TTextBox.php, class constant TTextBoxAutoCompleteType::JobTitle
    joinOrdering | in file TMssqlCommandBuilder.php, method TMssqlCommandBuilder::joinOrdering()
    JSMin in file TJavaScript.php, method TJavaScript::JSMin()
    Minimize the size of a javascript script.
    JSON | in file TRpcClient.php, class constant TRpcClientTypesEnumerable::JSON
    jsonDecode in file TJavaScript.php, method TJavaScript::jsonDecode()
    Decodes a javascript string into PHP variable.
    jsonEncode in file TJavaScript.php, method TJavaScript::jsonEncode()
    Encodes a PHP variable into javascript string.
    Justify | in file TStyle.php, class constant THorizontalAlign::Justify
    top
    k
    $key in file TTranslateParameter.php, variable TTranslateParameter::$key
    The substitution key.
    key in file TPagedDataSource.php, method TPagedMapIterator::key()
    Returns the key of the current array item.
    key in file TQueue.php, method TQueueIterator::key()
    Returns the key of the current array item.
    key in file TStack.php, method TStackIterator::key()
    Returns the key of the current array item.
    key in file TPagedDataSource.php, method TPagedListIterator::key()
    Returns the key of the current array item.
    key in file TMap.php, method TMapIterator::key()
    Returns the key of the current array element.
    key in file TDbDataReader.php, method TDbDataReader::key()
    Returns the index of the current row.
    key in file TDummyDataSource.php, method TDummyDataSourceIterator::key()
    Returns the key of the current array item.
    key in file THttpSession.php, method TSessionIterator::key()
    Returns the key of the current array element.
    key in file TList.php, method TListIterator::key()
    Returns the key of the current array item.
    key | in file TComponent.php, method TEnumerable::key()
    top
    l
    $localName | in file TActiveFileUpload.php, variable TActiveFileUploadCallbackParams::$localName
    LastName | in file TTextBox.php, class constant TTextBoxAutoCompleteType::LastName
    leave in file TAuthManager.php, method TAuthManager::leave()
    Performs login redirect if authorization fails.
    Left | in file TCheckBox.php, class constant TTextAlign::Left
    Left | in file TTable.php, class constant TTableCaptionAlign::Left
    Left | in file TStyle.php, class constant THorizontalAlign::Left
    Left | in file TInlineFrame.php, class constant TInlineFrameAlign::Left
    LeftToRight | in file TPanelStyle.php, class constant TContentDirection::LeftToRight
    LessThan | in file TCompareValidator.php, class constant TValidationCompareOperator::LessThan
    LessThanEqual | in file TCompareValidator.php, class constant TValidationCompareOperator::LessThanEqual
    Li | in file TTextHighlighter.php, class constant TTextHighlighterLineNumberStyle::Li
    Link | in file TWizard.php, class constant TWizardNavigationButtonType::Link
    LinkButton | in file TBulletedList.php, class constant TBulletedListDisplayMode::LinkButton
    LinkButton | in file TPager.php, class constant TPagerButtonType::LinkButton
    LinkButton | in file TDataGridColumn.php, class constant TButtonColumnType::LinkButton
    LinkButton | in file TDataGrid.php, class constant TDataGridPagerButtonType::LinkButton
    listIndexChanged in file TPager.php, method TPager::listIndexChanged()
    Event handler to the OnSelectedIndexChanged event of the dropdown list.
    listItemCreated in file TScaffoldListView.php, method TScaffoldListView::listItemCreated()
    Initialize the default display for each Active Record item.
    LIST_TYPE | in file TResultProperty.php, class constant TResultProperty::LIST_TYPE
    load in file TPageStatePersister.php, method TPageStatePersister::load()
    Loads page state from hidden fields.
    load in file TSessionPageStatePersister.php, method TSessionPageStatePersister::load()
    Loads page state from session.
    load in file interfaces.php, method IStatePersister::load()
    Loads state from a persistent storage.
    load in file TCachePageStatePersister.php, method TCachePageStatePersister::load()
    Loads page state from cache.
    load in file TApplication.php, method TApplicationStatePersister::load()
    Loads application state from persistent storage.
    load in file TPage.php, method IPageStatePersister::load()
    Loads page state from persistent storage
    loadApplicationConfigurationFromPhp | in file TPageService.php, method TPageConfiguration::loadApplicationConfigurationFromPhp()
    loadApplicationConfigurationFromXml in file TPageService.php, method TPageConfiguration::loadApplicationConfigurationFromXml()
    Loads the configuration specific for application part
    loadCachedSqlMapManager in file TSqlMapConfig.php, method TSqlMapConfig::loadCachedSqlMapManager()
    Loads SqlMap manager from cache.
    loadCacheModel in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadCacheModel()
    Load cache models from xml mapping.
    loadConfig | in file TRpcService.php, method TRpcService::loadConfig()
    loadConfigFile in file TUrlMapping.php, method TUrlMapping::loadConfigFile()
    Initialize the module from configuration file.
    loadDatabaseConnection in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::loadDatabaseConnection()
    Load the database connection tag.
    loadDeleteTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadDeleteTag()
    Load delete statement from xml mapping.
    loadExternalPhp in file TApplication.php, method TApplicationConfiguration::loadExternalPhp()
    Loads the external PHP array.
    loadExternalXml in file TApplication.php, method TApplicationConfiguration::loadExternalXml()
    Loads the external XML configurations.
    loadFlushInterval in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadFlushInterval()
    Load the flush interval
    loadFlushOnCache in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadFlushOnCache()
    Load the flush on cache properties.
    loadFromFile in file TApplication.php, method TApplicationConfiguration::loadFromFile()
    Parses the application configuration file.
    loadFromFile in file TPageService.php, method TPageConfiguration::loadFromFile()
    Loads a specific config file.
    loadFromFile in file TXmlDocument.php, method TXmlDocument::loadFromFile()
    Loads and parses an XML document.
    loadFromFiles in file TPageService.php, method TPageConfiguration::loadFromFiles()
    Loads configuration for a page specified in a path format.
    loadFromPhp in file TApplication.php, method TApplicationConfiguration::loadFromPhp()
    Parses the application configuration given in terms of a PHP array.
    loadFromPhp | in file TPageService.php, method TPageConfiguration::loadFromPhp()
    loadFromString | in file TUser.php, method TUser::loadFromString()
    loadFromString in file TXmlDocument.php, method TXmlDocument::loadFromString()
    Loads and parses an XML string.
    loadFromString | in file interfaces.php, method IUser::loadFromString()
    loadFromXml in file TApplication.php, method TApplicationConfiguration::loadFromXml()
    Parses the application configuration given in terms of a TXmlElement.
    loadFromXml in file TPageService.php, method TPageConfiguration::loadFromXml()
    Loads a page configuration.
    loadGlobalProperty in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::loadGlobalProperty()
    Load global replacement property.
    loadGlobals in file TApplication.php, method TApplication::loadGlobals()
    Loads global values from persistent storage.
    loadInsertTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadInsertTag()
    Load insert statement from xml mapping.
    loadJavascriptLibrary | in file THtmlArea.php, method THtmlArea::loadJavascriptLibrary()
    loadJsonServices in file TJsonService.php, method TJsonService::loadJsonServices()
    Load the service definitions.
    loadModulesPhp in file TApplication.php, method TApplicationConfiguration::loadModulesPhp()
    Loads the modules PHP array.
    loadModulesXml in file TApplication.php, method TApplicationConfiguration::loadModulesXml()
    Loads the modules XML node.
    loadPageConfig in file TPageService.php, method TPageService::loadPageConfig()
    Collects configuration for a page.
    loadPageConfigurationFromPhp | in file TPageService.php, method TPageConfiguration::loadPageConfigurationFromPhp()
    loadPageConfigurationFromXml in file TPageService.php, method TPageConfiguration::loadPageConfigurationFromXml()
    Loads the configuration specific for page service.
    loadPageState in file TPage.php, method TPage::loadPageState()
    Loads page state from persistent storage.
    loadParameterMap in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadParameterMap()
    Load parameter map from xml.
    loadParameters in file TParameterModule.php, method TParameterModule::loadParameters()
    Loads parameters into application.
    loadParametersPhp in file TApplication.php, method TApplicationConfiguration::loadParametersPhp()
    Loads the parameters PHP array.
    loadParametersXml in file TApplication.php, method TApplicationConfiguration::loadParametersXml()
    Loads the parameters XML node.
    loadPathsPhp in file TApplication.php, method TApplicationConfiguration::loadPathsPhp()
    Loads the paths PHP array
    loadPathsXml in file TApplication.php, method TApplicationConfiguration::loadPathsXml()
    Loads the paths XML node.
    loadPostData in file TRadioButtonList.php, method TRadioButtonList::loadPostData()
    Loads user input data.
    loadPostData in file TRadioButton.php, method TRadioButton::loadPostData()
    Loads user input data.
    loadPostData in file TSlider.php, method TSlider::loadPostData()
    Loads user input data.
    loadPostData in file THiddenField.php, method THiddenField::loadPostData()
    Loads hidden field data.
    loadPostData in file TDropDownList.php, method TDropDownList::loadPostData()
    Loads user input data.
    loadPostData in file TTextBox.php, method TTextBox::loadPostData()
    Loads user input data.
    loadPostData in file TDatePicker.php, method TDatePicker::loadPostData()
    Loads user input data. Override parent implementation, when InputMode is DropDownList call getDateFromPostData to get date data.
    loadPostData in file TCheckBoxList.php, method TCheckBoxList::loadPostData()
    Loads user input data.
    loadPostData in file TFileUpload.php, method TFileUpload::loadPostData()
    Loads user input data.
    loadPostData in file TImageButton.php, method TImageButton::loadPostData()
    This method checks if the TImageButton is clicked and loads the coordinates of the clicking position.
    loadPostData in file TCheckBox.php, method TCheckBox::loadPostData()
    Loads user input data.
    loadPostData in file TTabPanel.php, method TTabPanel::loadPostData()
    Loads user input data.
    loadPostData in file TListBox.php, method TListBox::loadPostData()
    Loads user input data.
    loadPostData in file TAccordion.php, method TAccordion::loadPostData()
    Loads user input data.
    loadPostData in file TControl.php, method IPostBackDataHandler::loadPostData()
    Loads user input data.
    loadProcedureTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadProcedureTag()
    Load procedure statement from xml mapping.
    loadRecordData in file TScaffoldListView.php, method TScaffoldListView::loadRecordData()
    Fetch the records and data bind it to the list.
    loadRecursive in file TOutputCache.php, method TOutputCache::loadRecursive()
    Performs the Load step for the control and all its child controls.
    loadRecursive in file TControl.php, method TControl::loadRecursive()
    Performs the Load step for the control and all its child controls.
    loadResultMap in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadResultMap()
    Load the result maps.
    loadScaffoldInput | in file TScaffoldInputBase.php, method TScaffoldInputBase::loadScaffoldInput()
    loadSelectKeyTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadSelectKeyTag()
    Load the selectKey statement from xml mapping.
    loadSelectTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadSelectTag()
    Load select statement from xml mapping.
    loadServicesPhp in file TApplication.php, method TApplicationConfiguration::loadServicesPhp()
    Loads the services PHP array.
    loadServicesXml in file TApplication.php, method TApplicationConfiguration::loadServicesXml()
    Loads the services XML node.
    loadSqlMappingFiles in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::loadSqlMappingFiles()
    Load SqlMap mapping configuration.
    loadState in file TListItemCollection.php, method TListItemCollection::loadState()
    Loads state into every item in the collection.
    loadState in file TDataGridColumn.php, method TDataGridColumn::loadState()
    Loads persistent state values.
    loadState in file TDataList.php, method TDataList::loadState()
    Loads item count information from viewstate.
    loadState in file TDataGrid.php, method TDataGrid::loadState()
    Loads item count information from viewstate.
    loadState in file TControlAdapter.php, method TControlAdapter::loadState()
    Loads additional persistent control state.
    loadState in file TControl.php, method TControl::loadState()
    This method is invoked right after the control has loaded its state.
    loadState in file TDropDownListColumn.php, method TDropDownListColumn::loadState()
    Loads items from viewstate.
    loadState in file TListControl.php, method TListControl::loadState()
    Loads items from viewstate.
    loadState in file TPager.php, method TPager::loadState()
    Restores the pager state.
    loadState in file TRepeater.php, method TRepeater::loadState()
    Loads item count information from viewstate.
    loadState in file TPage.php, method TPage::loadState()
    This method is invoked right after the control has loaded its state.
    loadState in file TMultiView.php, method TMultiView::loadState()
    Loads state into the wizard.
    loadStatementTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadStatementTag()
    Load statement mapping from xml configuration file.
    loadStateRecursive in file TOutputCache.php, method TOutputCache::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
    loadStateRecursive in file TControl.php, method TControl::loadStateRecursive()
    Loads state (viewstate and controlstate) into a control and its children.
    loadTemplate in file TTemplateControl.php, method TTemplateControl::loadTemplate()
    Loads the template associated with this control class.
    loadTypeHandler in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::loadTypeHandler()
    Load the type handler configurations.
    loadUpdateTag in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::loadUpdateTag()
    Load update statement from xml mapping.
    loadUrlMappings in file TUrlMapping.php, method TUrlMapping::loadUrlMappings()
    Load and configure each url mapping pattern.
    loadXmlDocument in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfigBuilder::loadXmlDocument()
    Load document using simple xml.
    localize in file PradoBase.php, method PradoBase::localize()
    Localize a text to the locale/culture specified in the globalization handler.
    log in file PradoBase.php, method PradoBase::log()
    Logs a message.
    log in file TLogger.php, method TLogger::log()
    Logs a message.
    login in file TAuthManager.php, method TAuthManager::login()
    Logs in a user with username and password.
    logout in file TAuthManager.php, method TAuthManager::logout()
    Logs out a user.
    LowerAlpha | in file TBulletedList.php, class constant TBulletStyle::LowerAlpha
    LowerCase in file TDbConnection.php, class constant TDbColumnCaseMode::LowerCase
    Column names are converted to lower case
    LowerRoman | in file TBulletedList.php, class constant TBulletStyle::LowerRoman
    LRU | in file TSqlMapCacheModel.php, class constant TSqlMapCacheTypes::LRU
    top
    m
    MANY_TO_MANY | in file TActiveRecord.php, class constant TActiveRecord::MANY_TO_MANY
    MAP_NAME_PREFIX | in file TImageMap.php, class constant TImageMap::MAP_NAME_PREFIX
    markScriptFileAsRendered | in file TClientScriptManager.php, method TClientScriptManager::markScriptFileAsRendered()
    MAX_FILE_SIZE in file TFileUpload.php, class constant TFileUpload::MAX_FILE_SIZE
    Maximum file size (in bytes) allowed to be uploaded, defaults to 1MB.
    MAX_STEPS | in file TSlider.php, class constant TSlider::MAX_STEPS
    MAX_TOKEN_LENGTH | in file TCaptcha.php, class constant TCaptcha::MAX_TOKEN_LENGTH
    MD5 | in file TUserManager.php, class constant TUserManagerPasswordMode::MD5
    MD5 | in file TSecurityManager.php, class constant TSecurityManagerValidationMode::MD5
    mergeWith in file TStyle.php, method TStyle::mergeWith()
    Merges the style with a new one.
    mergeWith in file TStyle.php, method TTableStyle::mergeWith()
    Merges the style with a new one.
    mergeWith in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::mergeWith()
    Merges the style with a new one.
    mergeWith in file TPriorityMap.php, method TPriorityMap::mergeWith()
    Merges iterable data into the map.
    mergeWith in file TStyle.php, method TTableItemStyle::mergeWith()
    Merges the style with a new one.
    mergeWith in file TPanelStyle.php, method TPanelStyle::mergeWith()
    Merges the style with a new one.
    mergeWith in file TPriorityList.php, method TPriorityList::mergeWith()
    Merges iterable data into the priority list.
    mergeWith in file TDataGridPagerStyle.php, method TDataGridPagerStyle::mergeWith()
    Merges the style with a new one.
    mergeWith in file TList.php, method TList::mergeWith()
    Merges iterable data into the map.
    mergeWith in file TFont.php, method TFont::mergeWith()
    Merges the font with a new one.
    mergeWith in file TMap.php, method TMap::mergeWith()
    Merges iterable data into the map.
    Middle | in file TStyle.php, class constant TVerticalAlign::Middle
    Middle | in file TInlineFrame.php, class constant TInlineFrameAlign::Middle
    MiddleName | in file TTextBox.php, class constant TTextBoxAutoCompleteType::MiddleName
    MIN_TOKEN_LENGTH | in file TCaptcha.php, class constant TCaptcha::MIN_TOKEN_LENGTH
    MultiLine | in file TTextBox.php, class constant TTextBoxMode::MultiLine
    Multiple | in file TListBox.php, class constant TListSelectionMode::Multiple
    top
    n
    Navigate | in file TImageMap.php, class constant THotSpotMode::Navigate
    needPostBackScript | in file TButton.php, method TButton::needPostBackScript()
    needPostBackScript | in file TImageButton.php, method TImageButton::needPostBackScript()
    newInstance in file TLazyLoadList.php, method TLazyLoadList::newInstance()
    Create a new instance of a lazy collection.
    next in file TQueue.php, method TQueueIterator::next()
    Moves the internal pointer to the next array item.
    next in file TDummyDataSource.php, method TDummyDataSourceIterator::next()
    Moves the internal pointer to the next array item.
    next in file TDbDataReader.php, method TDbDataReader::next()
    Moves the internal pointer to the next row.
    next in file THttpSession.php, method TSessionIterator::next()
    Moves the internal pointer to the next array element.
    next in file TPagedDataSource.php, method TPagedListIterator::next()
    Moves the internal pointer to the next array item.
    next in file TPagedDataSource.php, method TPagedMapIterator::next()
    Moves the internal pointer to the next array item.
    next in file TList.php, method TListIterator::next()
    Moves the internal pointer to the next array item.
    next in file TMap.php, method TMapIterator::next()
    Moves the internal pointer to the next array element.
    next in file TStack.php, method TStackIterator::next()
    Moves the internal pointer to the next array item.
    next | in file TComponent.php, method TEnumerable::next()
    nextPage in file TPagedList.php, method TPagedList::nextPage()
    Switches to the next page.
    nextPage in file TSqlMapPagedList.php, method TSqlMapPagedList::nextPage()
    Switches to the next page.
    NextPrev | in file TDataGrid.php, class constant TDataGridPagerMode::NextPrev
    NextPrev | in file TPager.php, class constant TPagerMode::NextPrev
    nextResult in file TDbDataReader.php, method TDbDataReader::nextResult()
    Advances the reader to the next result when reading the results of a batch of statements.
    None | in file TPanelStyle.php, class constant TScrollBars::None
    None | in file TValidationSummary.php, class constant TValidationSummaryDisplayStyle::None
    None | in file TTextBox.php, class constant TTextBoxAutoCompleteType::None
    None | in file TStyle.php, class constant TTableGridLines::None
    None | in file TStyle.php, class constant TDisplayStyle::None
    None | in file TInlineFrame.php, class constant TInlineFrameScrollBars::None
    None | in file TDraggable.php, class constant TDraggableRevertOptions::None
    None | in file TDraggable.php, class constant TDraggableConstraint::None
    None | in file TBaseValidator.php, class constant TValidatorDisplayStyle::None
    None | in file THttpSession.php, class constant THttpSessionCookieMode::None
    None | in file TDraggable.php, class constant TDraggableGhostingOptions::None
    None | in file TBulletedList.php, class constant TBulletStyle::None
    Normal | in file TApplication.php, class constant TApplicationMode::Normal
    NotEqual | in file TCompareValidator.php, class constant TValidationCompareOperator::NotEqual
    Notes | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Notes
    NOTICE | in file TLogger.php, class constant TLogger::NOTICE
    NotSet | in file TStyle.php, class constant TVerticalAlign::NotSet
    NotSet | in file TStyle.php, class constant THorizontalAlign::NotSet
    NotSet | in file TTableHeaderCell.php, class constant TTableHeaderScope::NotSet
    NotSet | in file TBulletedList.php, class constant TBulletStyle::NotSet
    NotSet | in file TPanelStyle.php, class constant TContentDirection::NotSet
    NotSet | in file TInlineFrame.php, class constant TInlineFrameAlign::NotSet
    NotSet | in file TImageMap.php, class constant THotSpotMode::NotSet
    NotSet | in file TTable.php, class constant TTableCaptionAlign::NotSet
    Null | in file TActiveRecord.php, class constant TActiveRecordInvalidFinderResult::Null
    nullifyDefaultValue in file TParameterMap.php, method TParameterMap::nullifyDefaultValue()
    When the actual value matches the NullValue, set the current value to null.
    NullToEmptyString in file TDbConnection.php, class constant TDbNullConversionMode::NullToEmptyString
    NULL is converted to empty string
    Numbered | in file TBulletedList.php, class constant TBulletStyle::Numbered
    Numeric | in file TPager.php, class constant TPagerMode::Numeric
    Numeric | in file TDataGrid.php, class constant TDataGridPagerMode::Numeric
    top
    o
    Off | in file TApplication.php, class constant TApplicationMode::Off
    Office | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Office
    offsetExists in file TCache.php, method TCache::offsetExists()
    Returns whether there is a cache entry with a specified key.
    offsetExists in file THttpSession.php, method THttpSession::offsetExists()
    This method is required by the interface ArrayAccess.
    offsetExists in file TPagedList.php, method TPagedList::offsetExists()
    Returns whether there is an item at the specified offset.
    offsetExists in file TPriorityList.php, method TPriorityList::offsetExists()
    Returns whether there is an element at the specified offset.
    offsetExists in file TMap.php, method TMap::offsetExists()
    Returns whether there is an element at the specified offset.
    offsetExists in file TList.php, method TList::offsetExists()
    Returns whether there is an item at the specified offset.
    offsetExists in file TPriorityMap.php, method TPriorityMap::offsetExists()
    Returns whether there is an element at the specified offset.
    offsetExists in file THttpRequest.php, method THttpRequest::offsetExists()
    Returns whether there is an element at the specified offset.
    offsetGet in file TPagedList.php, method TPagedList::offsetGet()
    Returns the item at the specified offset.
    offsetGet in file TMap.php, method TMap::offsetGet()
    Returns the element at the specified offset.
    offsetGet in file TList.php, method TList::offsetGet()
    Returns the item at the specified offset.
    offsetGet in file TPriorityList.php, method TPriorityList::offsetGet()
    Returns the element at the specified offset.
    offsetGet in file TPriorityMap.php, method TPriorityMap::offsetGet()
    Returns the element at the specified offset.
    offsetGet in file THttpSession.php, method THttpSession::offsetGet()
    This method is required by the interface ArrayAccess.
    offsetGet in file THttpRequest.php, method THttpRequest::offsetGet()
    Returns the element at the specified offset.
    offsetGet in file TCache.php, method TCache::offsetGet()
    Retrieves the value from cache with a specified key.
    offsetSet in file THttpSession.php, method THttpSession::offsetSet()
    This method is required by the interface ArrayAccess.
    offsetSet in file TList.php, method TList::offsetSet()
    Sets the item at the specified offset.
    offsetSet in file TMap.php, method TMap::offsetSet()
    Sets the element at the specified offset.
    offsetSet in file TPriorityList.php, method TPriorityList::offsetSet()
    Sets the element at the specified offset. This method is required by the interface ArrayAccess.
    offsetSet in file TCache.php, method TCache::offsetSet()
    Stores the value identified by a key into cache.
    offsetSet in file TPriorityMap.php, method TPriorityMap::offsetSet()
    Sets the element at the specified offset.
    offsetSet in file THttpRequest.php, method THttpRequest::offsetSet()
    Sets the element at the specified offset.
    offsetUnset in file TList.php, method TList::offsetUnset()
    Unsets the item at the specified offset.
    offsetUnset in file TCache.php, method TCache::offsetUnset()
    Deletes the value with the specified key from cache This method is required by the interface ArrayAccess.
    offsetUnset in file TPriorityMap.php, method TPriorityMap::offsetUnset()
    Unsets the element at the specified offset.
    offsetUnset in file TPriorityList.php, method TPriorityList::offsetUnset()
    Unsets the element at the specified offset.
    offsetUnset in file TMap.php, method TMap::offsetUnset()
    Unsets the element at the specified offset.
    offsetUnset in file THttpRequest.php, method THttpRequest::offsetUnset()
    Unsets the element at the specified offset.
    offsetUnset in file THttpSession.php, method THttpSession::offsetUnset()
    This method is required by the interface ArrayAccess.
    onActivate in file TMultiView.php, method TView::onActivate()
    Raises OnActivate event.
    onActiveStepChanged in file TWizard.php, method TWizard::onActiveStepChanged()
    Raises OnActiveStepChanged event.
    onActiveViewChanged in file TMultiView.php, method TMultiView::onActiveViewChanged()
    Raises OnActiveViewChanged event.
    onAuthenticate in file TAuthManager.php, method TAuthManager::onAuthenticate()
    Performs the real authentication work.
    onAuthentication in file TApplication.php, method TApplication::onAuthentication()
    Raises OnAuthentication event.
    onAuthenticationComplete in file TApplication.php, method TApplication::onAuthenticationComplete()
    Raises OnAuthenticationComplete event.
    onAuthExpire in file TAuthManager.php, method TAuthManager::onAuthExpire()
    Performs user logout on authentication expiration.
    onAuthorization in file TApplication.php, method TApplication::onAuthorization()
    Raises OnAuthorization event.
    onAuthorizationComplete in file TApplication.php, method TApplication::onAuthorizationComplete()
    Raises OnAuthorizationComplete event.
    onAuthorize in file TAuthManager.php, method TAuthManager::onAuthorize()
    Performs the real authorization work.
    onBeginRequest in file TApplication.php, method TApplication::onBeginRequest()
    Raises OnBeginRequest event.
    onCalculateKey in file TOutputCache.php, method TOutputCache::onCalculateKey()
    This event is raised when the output cache is calculating cache key.
    onCallback in file TActiveLinkButton.php, method TActiveLinkButton::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveImageButton.php, method TActiveImageButton::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TDropContainer.php, method TDropContainer::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveHiddenField.php, method TActiveHiddenField::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveDropDownList.php, method TActiveDropDownList::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveCustomValidator.php, method TActiveCustomValidator::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveButton.php, method TActiveButton::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveCheckBox.php, method TActiveCheckBox::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TCallback.php, method TCallback::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveCheckBoxList.php, method TActiveCheckBoxList::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveDatePicker.php, method TActiveDatePicker::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveListBox.php, method TActiveListBox::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveTextBox.php, method TActiveTextBox::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TInPlaceTextBox.php, method TInPlaceTextBox::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActivePager.php, method TActivePager::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveRatingList.php, method TActiveRatingList::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveRadioButton.php, method TActiveRadioButton::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCallback in file TActiveRadioButtonList.php, method TActiveRadioButtonList::onCallback()
    This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCancelButtonClick in file TWizard.php, method TWizard::onCancelButtonClick()
    Raises OnCancelButtonClick event.
    onCancelCommand in file TDataGrid.php, method TDataGrid::onCancelCommand()
    Raises OnCancelCommand event.
    onCancelCommand in file TDataList.php, method TDataList::onCancelCommand()
    Raises OnCancelCommand event.
    onCellSelected in file TActiveTableCell.php, method TActiveTableCell::onCellSelected()
    This method is invoked when a callback is requested. The method raises 'OnCellSelected' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onCheckDependency in file TOutputCache.php, method TOutputCache::onCheckDependency()
    This event is raised when the output cache is checking cache dependency.
    onCheckedChanged in file TCheckBox.php, method TCheckBox::onCheckedChanged()
    Raises OnCheckedChanged event when getChecked changes value during postback.
    onChildNodesVisited in file TMappedStatement.php, method TSqlMapObjectCollectionTree::onChildNodesVisited()
    Set the object properties for all the child nodes visited.
    onClick in file TImageButton.php, method TImageButton::onClick()
    This method is invoked when the button is clicked.
    onClick in file TControl.php, method IButtonControl::onClick()
    Raises OnClick event.
    onClick in file TImageMap.php, method TImageMap::onClick()
    Raises OnClick event.
    onClick in file TLinkButton.php, method TLinkButton::onClick()
    This method is invoked when the button is clicked.
    onClick in file TButton.php, method TButton::onClick()
    This method is invoked when the button is clicked.
    onClick in file TBulletedList.php, method TBulletedList::onClick()
    Raises 'OnClick' event.
    onCommand in file TLinkButton.php, method TLinkButton::onCommand()
    This method is invoked when the button is clicked.
    onCommand in file TButton.php, method TButton::onCommand()
    This method is invoked when the button is clicked.
    onCommand in file TImageButton.php, method TImageButton::onCommand()
    This method is invoked when the button is clicked.
    onCommand in file TControl.php, method IButtonControl::onCommand()
    Raises OnCommand event.
    onCompleteButtonClick in file TWizard.php, method TWizard::onCompleteButtonClick()
    Raises OnCompleteButtonClick event.
    onCreateCommand in file TTableGateway.php, method TTableGateway::onCreateCommand()
    Raised when a command is prepared and parameter binding is completed.
    onCreateCommand in file TActiveRecordGateway.php, method TActiveRecordGateway::onCreateCommand()
    Raised when a command is prepared and parameter binding is completed.
    onCreateCommand in file TDataGatewayCommand.php, method TDataGatewayCommand::onCreateCommand()
    Raised when a command is prepared and parameter binding is completed.
    onCreateCommand in file TActiveRecord.php, method TActiveRecord::onCreateCommand()
    Raised when a command is prepared and parameter binding is completed.
    onDataBinding in file TControl.php, method TControl::onDataBinding()
    Raises 'OnDataBinding' event.
    onDataBound in file TDataBoundControl.php, method TDataBoundControl::onDataBound()
    Raises OnDataBound event.
    onDataSourceChanged | in file TDataSourceControl.php, method IDataSource::onDataSourceChanged()
    onDataSourceChanged in file TDataBoundControl.php, method TDataBoundControl::onDataSourceChanged()
    Sets setRequiresDataBinding as true if the control is initialized.
    onDataSourceChanged | in file TDataSourceControl.php, method TDataSourceControl::onDataSourceChanged()
    onDataSourceViewChanged | in file TDataSourceView.php, method TDataSourceView::onDataSourceViewChanged()
    onDeactivate in file TMultiView.php, method TView::onDeactivate()
    Raises OnDeactivate event.
    onDelete in file TActiveRecord.php, method TActiveRecord::onDelete()
    Raised before the record attempt to delete its data from the database.
    onDeleteCommand in file TDataGrid.php, method TDataGrid::onDeleteCommand()
    Raises OnDeleteCommand event.
    onDeleteCommand in file TDataList.php, method TDataList::onDeleteCommand()
    Raises OnDeleteCommand event.
    onDrop in file TDropContainer.php, method TDropContainer::onDrop()
    Raises the onDrop event.
    onEditCommand in file TDataGrid.php, method TDataGrid::onEditCommand()
    Raises OnEditCommand event.
    onEditCommand in file TDataList.php, method TDataList::onEditCommand()
    Raises OnEditCommand event.
    onEndRequest in file TApplication.php, method TApplication::onEndRequest()
    Raises OnEndRequest event.
    onError in file TApplication.php, method TApplication::onError()
    Raises OnError event.
    onExecuteCommand in file TActiveRecord.php, method TActiveRecord::onExecuteCommand()
    Raised when a command is executed and the result from the database was returned.
    onExecuteCommand in file TDataGatewayCommand.php, method TDataGatewayCommand::onExecuteCommand()
    Raised when a command is executed and the result from the database was returned.
    onExecuteCommand in file TActiveRecordGateway.php, method TActiveRecordGateway::onExecuteCommand()
    Raised when a command is executed and the result from the database was returned.
    onExecuteCommand in file TTableGateway.php, method TTableGateway::onExecuteCommand()
    Raised when a command is executed and the result from the database was returned.
    onExecuteQuery in file TMappedStatement.php, method TMappedStatement::onExecuteQuery()
    Raise the execute query event.
    onFetchData in file TPagedList.php, method TPagedList::onFetchData()
    Raises OnFetchData event.
    onFileUpload in file TActiveFileUpload.php, method TActiveFileUpload::onFileUpload()
    This method is invoked when a file is uploaded.
    onFileUpload in file TFileUpload.php, method TFileUpload::onFileUpload()
    This method is invoked when a file is uploaded during a postback.
    onInit in file THead.php, method THead::onInit()
    Registers the head control with the current page.
    onInit | in file TActiveFileUpload.php, method TActiveFileUpload::onInit()
    onInit in file TWizard.php, method TTemplatedWizardStep::onInit()
    Ensures child controls are created.
    onInit in file TForm.php, method TForm::onInit()
    Registers the form with the page.
    onInit in file TMultiView.php, method TMultiView::onInit()
    Initializes the active view if any.
    onInit in file TBaseValidator.php, method TBaseValidator::onInit()
    Registers the validator with page.
    onInit in file TControlAdapter.php, method TControlAdapter::onInit()
    This method is invoked when the control enters 'OnInit' stage.
    onInit in file TControl.php, method TControl::onInit()
    This method is invoked when the control enters 'OnInit' stage.
    onInit in file TDataBoundControl.php, method TDataBoundControl::onInit()
    Sets page's OnPreLoad event handler as pagePreLoad.
    onInit in file TRadioButton.php, method TRadioButton::onInit()
    Registers the radio button groupings. If overriding onInit method, ensure to call parent implemenation.
    onInit in file TWizard.php, method TWizard::onInit()
    Creates the child controls of the wizard.
    onInitComplete in file TPage.php, method TPage::onInitComplete()
    Raises OnInitComplete event.
    onInsert in file TActiveRecord.php, method TActiveRecord::onInsert()
    Raised before the record attempt to insert its data into the database.
    onItemCommand in file TDataList.php, method TDataList::onItemCommand()
    Raises OnItemCommand event.
    onItemCommand in file TDataGrid.php, method TDataGrid::onItemCommand()
    Raises OnItemCommand event.
    onItemCommand in file TRepeater.php, method TRepeater::onItemCommand()
    Raises OnItemCommand event.
    onItemCreated in file TRepeater.php, method TRepeater::onItemCreated()
    Raises OnItemCreated event.
    onItemCreated in file TDataList.php, method TDataList::onItemCreated()
    Raises OnItemCreated event.
    onItemCreated in file TDataGrid.php, method TDataGrid::onItemCreated()
    Raises OnItemCreated event.
    onItemDataBound in file TDataGrid.php, method TDataGrid::onItemDataBound()
    Raises OnItemDataBound event.
    onItemDataBound in file TDataList.php, method TDataList::onItemDataBound()
    Raises OnItemDataBound event.
    onItemDataBound in file TRepeater.php, method TRepeater::onItemDataBound()
    Raises OnItemDataBound event.
    onLoad in file TControl.php, method TControl::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
    onLoad in file TScaffoldEditView.php, method TScaffoldEditView::onLoad()
    Initialize the editor form if it is Visible.
    onLoad in file TControlAdapter.php, method TControlAdapter::onLoad()
    This method is invoked when the control enters 'OnLoad' stage.
    onLoad in file TActiveControlAdapter.php, method TActiveControlAdapter::onLoad()
    Starts viewstate tracking if necessary after when controls has been loaded
    onLoadComplete in file TPage.php, method TPage::onLoadComplete()
    Raises OnLoadComplete event.
    onLoadingText in file TInPlaceTextBox.php, method TInPlaceTextBox::onLoadingText()
    Raised when editing the content is requsted to be loaded from the server side.
    onLoadState in file TApplication.php, method TApplication::onLoadState()
    Raises OnLoadState event.
    onLoadStateComplete in file TApplication.php, method TApplication::onLoadStateComplete()
    Raises OnLoadStateComplete event.
    Only | in file THttpSession.php, class constant THttpSessionCookieMode::Only
    onNextButtonClick in file TWizard.php, method TWizard::onNextButtonClick()
    Raises OnNextButtonClick event.
    onPageIndexChanged in file TPagedList.php, method TPagedList::onPageIndexChanged()
    Raises OnPageIndexChanged event.
    onPageIndexChanged in file TDataGrid.php, method TDataGrid::onPageIndexChanged()
    Raises OnPageIndexChanged event.
    onPageIndexChanged in file TPager.php, method TPager::onPageIndexChanged()
    This event is raised when page index is changed due to a page button click.
    onPagerCreated in file TDataGrid.php, method TDataGrid::onPagerCreated()
    Raises OnPagerCreated event.
    onPreFlushOutput in file TApplication.php, method TApplication::onPreFlushOutput()
    Raises OnPreFlushOutput event.
    onPreInit in file TPage.php, method TPage::onPreInit()
    Raises OnPreInit event.
    onPreLoad in file TPage.php, method TPage::onPreLoad()
    Raises OnPreLoad event.
    onPreRender in file TStyleSheet.php, method TStyleSheet::onPreRender()
    Registers the stylesheet file and content to be rendered.
    onPreRender in file TActiveControlAdapter.php, method TActiveControlAdapter::onPreRender()
    Publish the ajax script
    onPreRender in file TSlider.php, method TSlider::onPreRender()
    Registers CSS and JS.
    onPreRender in file TImageButton.php, method TImageButton::onPreRender()
    Registers the image button to receive postback data during postback.
    onPreRender | in file TReCaptchaValidator.php, method TReCaptchaValidator::onPreRender()
    onPreRender in file TAccordion.php, method TAccordion::onPreRender()
    Registers CSS and JS.
    onPreRender in file TActiveDropDownList.php, method TActiveDropDownList::onPreRender()
    Updates the client-side options if the item list has changed after the OnLoad event.
    onPreRender in file TDraggable.php, method TDraggable::onPreRender()
    Registers clientscripts
    onPreRender in file TReCaptcha.php, method TReCaptcha::onPreRender()
    Checks for API keys
    onPreRender in file TPager.php, method TPager::onPreRender()
    Performs databinding to populate data items from data source.
    onPreRender in file TRatingList.php, method TRatingList::onPreRender()
    Publish the the rating style css file and rating image files.
    onPreRender in file TDropContainer.php, method TDropContainer::onPreRender()
    Registers clientscripts
    onPreRender in file TScaffoldBase.php, method TScaffoldBase::onPreRender()
    Publish the default stylesheet file.
    onPreRender in file TFileUpload.php, method TFileUpload::onPreRender()
    Sets Enctype of the form on the page.
    onPreRender in file TScaffoldListView.php, method TScaffoldListView::onPreRender()
    Loads and display the data.
    onPreRender in file TBaseValidator.php, method TBaseValidator::onPreRender()
    Override parent implementation to update the control CSS Class before
    onPreRender in file TScaffoldView.php, method TScaffoldView::onPreRender()
    Copy basic record details to the list/edit/search controls.
    onPreRender in file TActiveListBox.php, method TActiveListBox::onPreRender()
    Updates the client-side options if the item list has changed after the OnLoad event.
    onPreRender in file TInPlaceTextBox.php, method TInPlaceTextBox::onPreRender()
    Registers CSS and JS.
    onPreRender in file TTextHighlighter.php, method TTextHighlighter::onPreRender()
    Registers css style for the highlighted result.
    onPreRender in file TActiveImageButton.php, method TActiveImageButton::onPreRender()
    Register the x and y hidden input names of the position clicked.
    onPreRender in file TControlAdapter.php, method TControlAdapter::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
    onPreRender in file TWebControl.php, method TWebControl::onPreRender()
    If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
    onPreRender in file TActiveFileUpload.php, method TActiveFileUpload::onPreRender()
    Publish the javascript
    onPreRender in file TDataBoundControl.php, method TDataBoundControl::onPreRender()
    Ensures any pending databind is performed.
    onPreRender in file TListBox.php, method TListBox::onPreRender()
    Registers the list control to load post data on postback.
    onPreRender in file TKeyboard.php, method TKeyboard::onPreRender()
    Registers CSS and JS.
    onPreRender in file TTabPanel.php, method TTabPanel::onPreRender()
    Registers CSS and JS.
    onPreRender in file TCheckBoxList.php, method TCheckBoxList::onPreRender()
    Registers for post data on postback.
    onPreRender in file TCheckBox.php, method TCheckBox::onPreRender()
    Registers the checkbox to receive postback data during postback.
    onPreRender in file TCaptcha.php, method TCaptcha::onPreRender()
    Configures the image URL that shows the token.
    onPreRender in file TClientScript.php, method TClientScript::onPreRender()
    Calls the client script manager to add each of the requested client script libraries.
    onPreRender in file TColorPicker.php, method TColorPicker::onPreRender()
    Publish the color picker Css asset files.
    onPreRender in file TControl.php, method TControl::onPreRender()
    This method is invoked when the control enters 'OnPreRender' stage.
    onPreRender in file TJavascriptLogger.php, method TJavascriptLogger::onPreRender()
    Registers the required logger javascript.
    onPreRender in file TDatePicker.php, method TDatePicker::onPreRender()
    Publish the date picker Css asset files.
    onPreRenderComplete in file TPage.php, method TPage::onPreRenderComplete()
    Raises OnPreRenderComplete event.
    onPreRunService in file TApplication.php, method TApplication::onPreRunService()
    Raises OnPreRunService event.
    onPreviousButtonClick in file TWizard.php, method TWizard::onPreviousButtonClick()
    Raises OnPreviousButtonClick event.
    onRowSelected in file TActiveTableRow.php, method TActiveTableRow::onRowSelected()
    This method is invoked when a callback is requested. The method raises 'OnRowSelected' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
    onSaveState in file TApplication.php, method TApplication::onSaveState()
    Raises OnSaveState event.
    onSaveStateComplete in file TPage.php, method TPage::onSaveStateComplete()
    Raises OnSaveStateComplete event.
    onSaveStateComplete in file TApplication.php, method TApplication::onSaveStateComplete()
    Raises OnSaveStateComplete event.
    onSelectedIndexChanged in file TBaseDataList.php, method TBaseDataList::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event.
    onSelectedIndexChanged in file TListControl.php, method TListControl::onSelectedIndexChanged()
    Raises OnSelectedIndexChanged event when selection is changed.
    onSelectedIndexChanged | in file TRatingList.php, method TRatingList::onSelectedIndexChanged()
    onServerValidate in file TCustomValidator.php, method TCustomValidator::onServerValidate()
    This method is invoked when the server side validation happens.
    onSideBarButtonClick in file TWizard.php, method TWizard::onSideBarButtonClick()
    Raises OnSideBarButtonClick event.
    onSortCommand in file TDataGrid.php, method TDataGrid::onSortCommand()
    Raises OnSortCommand event.
    onSuggest in file TAutoComplete.php, method TAutoComplete::onSuggest()
    This method is invoked when an autocomplete suggestion is requested.
    onSuggestionSelected in file TAutoComplete.php, method TAutoComplete::onSuggestionSelected()
    This method is invoked when an autocomplete suggestion is selected.
    onTextChanged in file TTextBox.php, method TTextBox::onTextChanged()
    Raises OnTextChanged event.
    onTextChanged in file TListControl.php, method TListControl::onTextChanged()
    Raises OnTextChanged event when selection is changed.
    onUnload in file TControlAdapter.php, method TControlAdapter::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
    onUnload in file TControl.php, method TControl::onUnload()
    This method is invoked when the control enters 'OnUnload' stage.
    onUnload in file TBaseValidator.php, method TBaseValidator::onUnload()
    Unregisters the validator from page.
    onUnload in file TActiveFileUpload.php, method TActiveFileUpload::onUnload()
    Removes localfile on ending of the callback.
    onUnLoad in file TRadioButton.php, method TRadioButton::onUnLoad()
    Unregisters the radio button groupings. If overriding onInit method, ensure to call parent implemenation.
    onUpdate in file TActiveRecord.php, method TActiveRecord::onUpdate()
    Raised before the record attempt to update its data in the database.
    onUpdateCommand in file TDataList.php, method TDataList::onUpdateCommand()
    Raises OnUpdateCommand event.
    onUpdateCommand in file TDataGrid.php, method TDataGrid::onUpdateCommand()
    Raises OnUpdateCommand event.
    onValidate in file TBaseValidator.php, method TBaseValidator::onValidate()
    This event is raised right before the validator starts to perform validation.
    onValidationError in file TBaseValidator.php, method TBaseValidator::onValidationError()
    This event is raised when the validator fails in validation.
    onValidationSuccess in file TBaseValidator.php, method TBaseValidator::onValidationSuccess()
    This event is raised when the validator succeeds in validation.
    onValueChanged in file THiddenField.php, method THiddenField::onValueChanged()
    This method is invoked when the value of the getValue property changes between posts to the server.
    onValueChanged in file TSlider.php, method TSlider::onValueChanged()
    Raises OnValueChanged event.
    open in file TDbConnection.php, method TDbConnection::open()
    Opens DB connection if it is currently not
    open in file THttpSession.php, method THttpSession::open()
    Starts the session if it has not started yet.
    top
    p
    $protocolHandlers | in file TRpcService.php, variable TRpcService::$protocolHandlers
    PACKAGES_FILE in file TClientScriptManager.php, class constant TClientScriptManager::PACKAGES_FILE
    file containing javascript packages and their cross dependencies
    pageChanged in file TScaffoldListView.php, method TScaffoldListView::pageChanged()
    Updates repeater page index with the pager new index value.
    pagePreLoad in file TDataBoundControl.php, method TDataBoundControl::pagePreLoad()
    Sets getInitialized as true.
    Pager | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Pager
    Pager | in file TDataBoundControl.php, class constant TListItemType::Pager
    PAGE_FILE_EXT in file TPageService.php, class constant TPageService::PAGE_FILE_EXT
    Page template file extension
    PAGE_SERVICE_ID in file TApplication.php, class constant TApplication::PAGE_SERVICE_ID
    Page service ID
    parameterMap | in file TSqlMapStatement.php, method TSqlMapStatement::parameterMap()
    PARAMETER_TOKEN_REGEXP in file TInlineParameterMapParser.php, class constant TInlineParameterMapParser::PARAMETER_TOKEN_REGEXP
    Regular expression for parsing inline parameter maps.
    PARAMETER_TOKEN_REGEXP | in file TSimpleDynamicParser.php, class constant TSimpleDynamicParser::PARAMETER_TOKEN_REGEXP
    PARAM_FILE_EXT | in file TParameterModule.php, class constant TParameterModule::PARAM_FILE_EXT
    parse in file TInlineParameterMapParser.php, method TInlineParameterMapParser::parse()
    Parse the sql text for inline parameters.
    parse in file TSimpleDynamicParser.php, method TSimpleDynamicParser::parse()
    Parse the sql text for dynamic place holders of the form $name$.
    parse in file TTemplateManager.php, method TTemplate::parse()
    Parses a template string.
    parse in file TSimpleDateFormatter.php, method TSimpleDateFormatter::parse()
    Parse the string according to the pattern.
    parseAttribute in file TTemplateManager.php, method TTemplate::parseAttribute()
    Parses a single attribute.
    parseAttributes in file TTemplateManager.php, method TTemplate::parseAttributes()
    Parses the attributes of a tag from a string.
    parseEditorOptions in file THtmlArea.php, method THtmlArea::parseEditorOptions()
    Parse additional options set in the Options property.
    parseMapping in file TInlineParameterMapParser.php, method TInlineParameterMapParser::parseMapping()
    Parse inline parameter with syntax as
    parseSafeHtml in file TSafeHtml.php, method TSafeHtml::parseSafeHtml()
    Use SafeHTML to remove malicous javascript from the HTML content.
    parseTemplateProperty | in file TTemplateManager.php, method TTemplate::parseTemplateProperty()
    parseUrl in file TUrlManager.php, method TUrlManager::parseUrl()
    Parses the request URL and returns an array of input parameters.
    parseUrl in file TUrlMapping.php, method TUrlMapping::parseUrl()
    Parses the request URL and returns an array of input parameters.
    parseUrl in file THttpRequest.php, method THttpRequest::parseUrl()
    Parses the request URL and returns an array of input parameters (excluding GET variables).
    Password | in file TTextBox.php, class constant TTextBoxMode::Password
    Path | in file THttpRequest.php, class constant THttpRequestUrlFormat::Path
    peek in file TQueue.php, method TQueue::peek()
    Returns the first item at the front of the queue.
    peek in file TStack.php, method TStack::peek()
    Returns the item at the top of the stack.
    Performance | in file TApplication.php, class constant TApplicationMode::Performance
    performDataBinding in file TRepeater.php, method TRepeater::performDataBinding()
    Performs databinding to populate repeater items from data source.
    performDataBinding in file TDataList.php, method TDataList::performDataBinding()
    Performs databinding to populate data list items from data source.
    performDataBinding in file TListControl.php, method TListControl::performDataBinding()
    Performs databinding to populate list items from data source.
    performDataBinding | in file TDataBoundControl.php, method TDataBoundControl::performDataBinding()
    performDataBinding in file TDataGrid.php, method TDataGrid::performDataBinding()
    Performs databinding to populate datagrid items from data source.
    performRequest in file TRpcClient.php, method TRpcClient::performRequest()
    Performs the actual request
    phpErrorHandler in file PradoBase.php, method PradoBase::phpErrorHandler()
    PHP error handler.
    pop in file TStack.php, method TStack::pop()
    Pops up the item at the top of the stack.
    popParamsByToken | in file TActiveFileUpload.php, method TActiveFileUpload::popParamsByToken()
    populateData in file TSqlMapPagedList.php, method TSqlMapPagedList::populateData()
    Populate the list with the fetched data.
    populateField in file TScaffoldListView.php, method TScaffoldListView::populateField()
    Sets the Record primary key to the current repeater item's CustomData.
    populateObject in file TActiveRecord.php, method TActiveRecord::populateObject()
    Populates a new record with the query result.
    populateObjects | in file TActiveRecord.php, method TActiveRecord::populateObjects()
    populateResult in file TActiveRecordRelation.php, method TActiveRecordRelation::populateResult()
    Populate the results with the foreign objects found.
    PostBack | in file TImageMap.php, class constant THotSpotMode::PostBack
    poweredByPrado | in file PradoBase.php, method PradoBase::poweredByPrado()
    Prado in file prado.php, class Prado
    Prado class.
    prado.php | procedural page prado.php
    PradoBase in file PradoBase.php, class PradoBase
    PradoBase class.
    PradoBase.php | procedural page PradoBase.php
    PRADO_CHMOD in file PradoBase.php, constant PRADO_CHMOD
    Defines the default permission for writable directories and files
    PRADO_DIR in file PradoBase.php, constant PRADO_DIR
    Defines the PRADO framework installation path.
    prepare in file TDbCommand.php, method TDbCommand::prepare()
    Prepares the SQL statement to be executed.
    prepare | in file TPreparedStatementFactory.php, method TPreparedStatementFactory::prepare()
    prepareSql in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::prepareSql()
    Prepare the sql text (may extend to dynamic sql).
    prependContent in file TCallbackClientScript.php, method TCallbackClientScript::prependContent()
    Prepend a HTML fragement to the element.
    preprocess in file TTemplateManager.php, method TTemplate::preprocess()
    Preprocesses the template string by including external templates
    preRenderRecursive in file TControl.php, method TControl::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
    preRenderRecursive in file TOutputCache.php, method TOutputCache::preRenderRecursive()
    Performs the PreRender step for the control and all its child controls.
    Preserved in file TDbConnection.php, class constant TDbNullConversionMode::Preserved
    No conversion is performed for null and empty values.
    Preserved in file TDbConnection.php, class constant TDbColumnCaseMode::Preserved
    Column name cases are kept as is from the database
    previousPage in file TPagedList.php, method TPagedList::previousPage()
    Switches to the previous page.
    previousPage in file TSqlMapPagedList.php, method TSqlMapPagedList::previousPage()
    Switches to the previous page.
    priorityAt in file TPriorityList.php, method TPriorityList::priorityAt()
    Retutrns the priority of an item at a particular flattened index.
    priorityAt in file TPriorityMap.php, method TPriorityMap::priorityAt()
    Retutrns the priority of an item at a particular flattened index.
    priorityOf in file TPriorityList.php, method TPriorityList::priorityOf()
    Returns the priority of a particular item
    priorityOf in file TPriorityMap.php, method TPriorityMap::priorityOf()
    Returns the priority of a particular item within the map. This searches the map for the item.
    processCallbackEvent in file TActivePageAdapter.php, method TActivePageAdapter::processCallbackEvent()
    Process the callback request.
    processCallbackRequest in file TPage.php, method TPage::processCallbackRequest()
    Sets Adapter to TActivePageAdapter and calls apter to process the callback request.
    processColumn | in file TSqliteMetaData.php, method TSqliteMetaData::processColumn()
    processColumn | in file TMysqlMetaData.php, method TMysqlMetaData::processColumn()
    processColumn | in file TPgsqlMetaData.php, method TPgsqlMetaData::processColumn()
    processColumn | in file TOracleMetaData.php, method TOracleMetaData::processColumn()
    processColumn | in file TMssqlMetaData.php, method TMssqlMetaData::processColumn()
    processLogs in file TLogRouter.php, method TFileLogRoute::processLogs()
    Saves log messages in files.
    processLogs in file TLogRouter.php, method TEmailLogRoute::processLogs()
    Sends log messages to specified email addresses.
    processLogs in file TLogRouter.php, method TDbLogRoute::processLogs()
    Stores log messages into database.
    processLogs | in file TLogRouter.php, method TBrowserLogRoute::processLogs()
    processLogs | in file TLogRouter.php, method TFirePhpLogRoute::processLogs()
    processLogs in file TLogRouter.php, method TLogRoute::processLogs()
    Processes log messages and sends them to specific destination.
    processNormalRequest | in file TPage.php, method TPage::processNormalRequest()
    processPostBackRequest | in file TPage.php, method TPage::processPostBackRequest()
    processPostData in file TPage.php, method TPage::processPostData()
    Processes post data.
    processRequest | in file TRpcService.php, method TRpcApiProvider::processRequest()
    processRequest | in file TRpcService.php, method TRpcServer::processRequest()
    processSqlStatement in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::processSqlStatement()
    Load extended SQL statements if application. Replaces global properties in the sql text. Extracts inline parameter maps.
    processText in file TTextHighlighter.php, method TTextHighlighter::processText()
    Processes a text string.
    processText in file TTextProcessor.php, method TTextProcessor::processText()
    Processes a text string.
    processText in file TMarkdown.php, method TMarkdown::processText()
    Processes a text string.
    publishAsset in file TApplicationComponent.php, method TApplicationComponent::publishAsset()
    Publishes a private asset and gets its URL.
    publishCalendarStyle in file TDatePicker.php, method TDatePicker::publishCalendarStyle()
    Publish the calendar style Css asset file.
    publishColorPickerAssets in file TColorPicker.php, method TColorPicker::publishColorPickerAssets()
    Publish the color picker assets.
    publishFilePath in file TAssetManager.php, method TAssetManager::publishFilePath()
    Publishes a file or a directory (recursively).
    publishFilePath in file TApplicationComponent.php, method TApplicationComponent::publishFilePath()
    Publishes a file or directory and returns its URL.
    publishImages | in file TRatingList.php, method TRatingList::publishImages()
    publishStyle | in file TRatingList.php, method TRatingList::publishStyle()
    publishTarFile in file TAssetManager.php, method TAssetManager::publishTarFile()
    Publish a tar file by extracting its contents to the assets directory.
    puff in file TCallbackClientScript.php, method TCallbackClientScript::puff()
    Visual Effect: Gradually grow and fade the element.
    pulsate in file TCallbackClientScript.php, method TCallbackClientScript::pulsate()
    Visual Effect: Pulsate.
    push in file TStack.php, method TStack::push()
    Pushes an item into the stack.
    PushButton | in file TPager.php, class constant TPagerButtonType::PushButton
    PushButton | in file TDataGridColumn.php, class constant TButtonColumnType::PushButton
    PushButton | in file TDataGrid.php, class constant TDataGridPagerButtonType::PushButton
    pushParamsAndGetToken | in file TActiveFileUpload.php, method TActiveFileUpload::pushParamsAndGetToken()
    top
    q
    query in file TDbCommand.php, method TDbCommand::query()
    Executes the SQL statement and returns query result.
    queryColumn in file TDbCommand.php, method TDbCommand::queryColumn()
    Executes the SQL statement and returns the first column of the result.
    queryForList in file TSqlMapGateway.php, method TSqlMapGateway::queryForList()
    Executes a Sql SELECT statement that returns data to populate a number of result objects.
    queryForMap in file TSqlMapGateway.php, method TSqlMapGateway::queryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on
    queryForMapWithRowDelegate in file TSqlMapGateway.php, method TSqlMapGateway::queryForMapWithRowDelegate()
    Runs a query with a custom object that gets a chance to deal with each row as it is processed.
    queryForObject in file TSqlMapGateway.php, method TSqlMapGateway::queryForObject()
    Executes a Sql SELECT statement that returns that returns data to populate a single object instance.
    queryForPagedList in file TSqlMapGateway.php, method TSqlMapGateway::queryForPagedList()
    Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.
    queryForPagedListWithRowDelegate in file TSqlMapGateway.php, method TSqlMapGateway::queryForPagedListWithRowDelegate()
    Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.
    queryRow in file TDbCommand.php, method TDbCommand::queryRow()
    Executes the SQL statement and returns the first row of the result.
    queryScalar in file TDbCommand.php, method TDbCommand::queryScalar()
    Executes the SQL statement and returns the value of the first column in the first row of data.
    queryWithRowDelegate in file TSqlMapGateway.php, method TSqlMapGateway::queryWithRowDelegate()
    Runs a query for list with a custom object that gets a chance to deal with each row as it is processed.
    QUERY_FOR_ARRAY | in file TMappedStatement.php, class constant TMappedStatement::QUERY_FOR_ARRAY
    QUERY_FOR_LIST | in file TMappedStatement.php, class constant TMappedStatement::QUERY_FOR_LIST
    QUERY_FOR_OBJECT | in file TMappedStatement.php, class constant TMappedStatement::QUERY_FOR_OBJECT
    QUEUE_SESSION_KEY | in file TSessionPageStatePersister.php, class constant TSessionPageStatePersister::QUEUE_SESSION_KEY
    quoteColumnAlias in file TMysqlMetaData.php, method TMysqlMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
    quoteColumnAlias in file TSqliteMetaData.php, method TSqliteMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
    quoteColumnAlias in file TPgsqlMetaData.php, method TPgsqlMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
    quoteColumnAlias in file TMssqlMetaData.php, method TMssqlMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
    quoteColumnAlias in file TDbMetaData.php, method TDbMetaData::quoteColumnAlias()
    Quotes a column alias for use in a query.
    quoteColumnAlias in file TDbConnection.php, method TDbConnection::quoteColumnAlias()
    Quotes a column alias for use in a query.
    quoteColumnName in file TPgsqlMetaData.php, method TPgsqlMetaData::quoteColumnName()
    Quotes a column name for use in a query.
    quoteColumnName in file TSqliteMetaData.php, method TSqliteMetaData::quoteColumnName()
    Quotes a column name for use in a query.
    quoteColumnName in file TDbMetaData.php, method TDbMetaData::quoteColumnName()
    Quotes a column name for use in a query.
    quoteColumnName in file TMysqlMetaData.php, method TMysqlMetaData::quoteColumnName()
    Quotes a column name for use in a query.
    quoteColumnName in file TDbConnection.php, method TDbConnection::quoteColumnName()
    Quotes a column name for use in a query.
    quoteColumnName in file TMssqlMetaData.php, method TMssqlMetaData::quoteColumnName()
    Quotes a column name for use in a query.
    quoteFunction in file TJavaScript.php, method TJavaScript::quoteFunction()
    Deprecated, use quoteJsLiteral instead
    quoteJsLiteral | in file TJavaScript.php, method TJavaScript::quoteJsLiteral()
    quoteString in file TDbConnection.php, method TDbConnection::quoteString()
    Quotes a string for use in a query.
    quoteString in file TJavaScript.php, method TJavaScript::quoteString()
    Quotes a javascript string.
    quoteTableName in file TPgsqlMetaData.php, method TPgsqlMetaData::quoteTableName()
    Quotes a table name for use in a query.
    quoteTableName in file TMssqlMetaData.php, method TMssqlMetaData::quoteTableName()
    Quotes a table name for use in a query.
    quoteTableName in file TDbMetaData.php, method TDbMetaData::quoteTableName()
    Quotes a table name for use in a query.
    quoteTableName in file TDbConnection.php, method TDbConnection::quoteTableName()
    Quotes a table name for use in a query.
    quoteTableName in file TMysqlMetaData.php, method TMysqlMetaData::quoteTableName()
    Quotes a table name for use in a query.
    quoteTableName in file TSqliteMetaData.php, method TSqliteMetaData::quoteTableName()
    Quotes a table name for use in a query.
    quoteTuple | in file TDataGatewayCommand.php, method TDataGatewayCommand::quoteTuple()
    top
    r
    $RELATIONS in file TActiveRecord.php, variable TActiveRecord::$RELATIONS
    This static variable defines the relationships.
    $rpcMethods | in file TRpcService.php, variable TRpcProtocol::$rpcMethods
    $rpcServer | in file TRpcService.php, variable TRpcApiProvider::$rpcServer
    raiseBubbleEvent in file TControl.php, method TControl::raiseBubbleEvent()
    Invokes the parent's bubbleEvent method.
    raiseCallbackEvent in file TActiveLinkButton.php, method TActiveLinkButton::raiseCallbackEvent()
    Raises the callback event. This method is required by
    raiseCallbackEvent in file TActiveListBox.php, method TActiveListBox::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface.
    raiseCallbackEvent in file TActivePager.php, method TActivePager::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface.
    raiseCallbackEvent in file TActiveImageButton.php, method TActiveImageButton::raiseCallbackEvent()
    Raises the callback event. This method is required by
    raiseCallbackEvent in file TActiveFileUpload.php, method TActiveFileUpload::raiseCallbackEvent()
    Raises OnFileUpload event.
    raiseCallbackEvent in file TActiveDatePicker.php, method TActiveDatePicker::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface.
    raiseCallbackEvent in file TActiveDropDownList.php, method TActiveDropDownList::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface.
    raiseCallbackEvent in file TActiveRadioButton.php, method TActiveRadioButton::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface.
    raiseCallbackEvent in file TActiveHiddenField.php, method TActiveHiddenField::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface.
    raiseCallbackEvent in file TActiveRatingList.php, method TActiveRatingList::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface.
    raiseCallbackEvent in file TAutoComplete.php, method TAutoComplete::raiseCallbackEvent()
    Raises the callback event. This method is overrides the parent implementation.
    raiseCallbackEvent in file TCallback.php, method TCallback::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface. If getCausesValidation is true, it will invoke the page's TPage::validate method first.
    raiseCallbackEvent in file interfaces.php, method ICallbackEventHandler::raiseCallbackEvent()
    Raises callback event. The implementation of this function should raise appropriate event(s) (e.g. OnClick, OnCommand) indicating the component is responsible for the callback event.
    raiseCallbackEvent in file TActiveTextBox.php, method TActiveTextBox::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface.
    raiseCallbackEvent in file TActiveTableRow.php, method TActiveTableRow::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface. It will raise onRowSelected event with a TActiveTableRowEventParameter containing the zero-based index of the TActiveTableRow.
    raiseCallbackEvent in file TActiveCustomValidator.php, method TActiveCustomValidator::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface. The onServerValidate event is raised first and then the onCallback event.
    raiseCallbackEvent in file TActiveTableCell.php, method TActiveTableCell::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface. It will raise onCellSelected event with a TActiveTableCellEventParameter containing the zero-based index of the TActiveTableCell.
    raiseCallbackEvent in file TActiveRadioButtonList.php, method TActiveRadioButtonList::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface.
    raiseCallbackEvent in file TDropContainer.php, method TDropContainer::raiseCallbackEvent()
    Raises callback event. This method is required bu ICallbackEventHandler interface.
    raiseCallbackEvent in file TActiveButton.php, method TActiveButton::raiseCallbackEvent()
    Raises the callback event. This method is required by
    raiseCallbackEvent in file TActiveCheckBoxList.php, method TActiveCheckBoxList::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface.
    raiseCallbackEvent in file TActiveCheckBox.php, method TActiveCheckBox::raiseCallbackEvent()
    Raises the callback event. This method is required by ICallbackEventHandler interface.
    raiseChangedEvents in file TPage.php, method TPage::raiseChangedEvents()
    Raises OnPostDataChangedEvent for controls whose data have been changed due to the postback.
    raiseClientEvent in file TCallbackClientScript.php, method TCallbackClientScript::raiseClientEvent()
    Raise the client side event (given by $eventName) on a particular element.
    raiseCommandEvent in file TActiveRecordGateway.php, method TActiveRecordGateway::raiseCommandEvent()
    Raise the corresponding command event, insert, update, delete or select.
    raiseEvent in file TComponent.php, method TComponent::raiseEvent()
    Raises an event.
    raisePostBackEvent in file TBulletedList.php, method TBulletedList::raisePostBackEvent()
    Raises the postback event.
    raisePostBackEvent in file TControl.php, method IPostBackEventHandler::raisePostBackEvent()
    Raises postback event.
    raisePostBackEvent in file TImageButton.php, method TImageButton::raisePostBackEvent()
    Raises the postback event.
    raisePostBackEvent in file TPage.php, method TPage::raisePostBackEvent()
    Raises PostBack event.
    raisePostBackEvent in file TButton.php, method TButton::raisePostBackEvent()
    Raises the postback event.
    raisePostBackEvent in file TImageMap.php, method TImageMap::raisePostBackEvent()
    Raises the postback event.
    raisePostBackEvent in file TLinkButton.php, method TLinkButton::raisePostBackEvent()
    Raises the postback event.
    raisePostDataChangedEvent in file TListBox.php, method TListBox::raisePostDataChangedEvent()
    Raises postdata changed event.
    raisePostDataChangedEvent in file THiddenField.php, method THiddenField::raisePostDataChangedEvent()
    Raises postdata changed event.
    raisePostDataChangedEvent in file TSlider.php, method TSlider::raisePostDataChangedEvent()
    Raises postdata changed event.
    raisePostDataChangedEvent in file TCheckBox.php, method TCheckBox::raisePostDataChangedEvent()
    Raises postdata changed event.
    raisePostDataChangedEvent in file TTabPanel.php, method TTabPanel::raisePostDataChangedEvent()
    Raises postdata changed event.
    raisePostDataChangedEvent in file TCheckBoxList.php, method TCheckBoxList::raisePostDataChangedEvent()
    Raises postdata changed event.
    raisePostDataChangedEvent in file TTextBox.php, method TTextBox::raisePostDataChangedEvent()
    Raises postdata changed event.
    raisePostDataChangedEvent in file TActiveFileUpload.php, method TActiveFileUpload::raisePostDataChangedEvent()
    Raises postdata changed event.
    raisePostDataChangedEvent in file TFileUpload.php, method TFileUpload::raisePostDataChangedEvent()
    Raises postdata changed event.
    raisePostDataChangedEvent in file TDropDownList.php, method TDropDownList::raisePostDataChangedEvent()
    Raises postdata changed event.
    raisePostDataChangedEvent in file TImageButton.php, method TImageButton::raisePostDataChangedEvent()
    A dummy implementation for the IPostBackDataHandler interface.
    raisePostDataChangedEvent in file TControl.php, method IPostBackDataHandler::raisePostDataChangedEvent()
    Raises postdata changed event.
    raisePostDataChangedEvent in file TAccordion.php, method TAccordion::raisePostDataChangedEvent()
    Raises postdata changed event.
    raiseRowDelegate in file TMappedStatement.php, method TMappedStatement::raiseRowDelegate()
    Raises delegate handler.
    Raw | in file TRepeatInfo.php, class constant TRepeatLayout::Raw
    read in file TDbDataReader.php, method TDbDataReader::read()
    Advances the reader to the next row in a result set.
    readAll in file TDbDataReader.php, method TDbDataReader::readAll()
    Reads the whole result set into an array.
    readColumn in file TDbDataReader.php, method TDbDataReader::readColumn()
    Returns a single column from the next row of a result set.
    readObject in file TDbDataReader.php, method TDbDataReader::readObject()
    Returns a single column from the next row of a result set.
    redirect in file THttpResponse.php, method THttpResponse::redirect()
    Redirects the browser to the specified URL.
    redirect in file TActivePageAdapter.php, method TActivePageAdapter::redirect()
    Redirect url on the client-side using javascript.
    regenerate in file THttpSession.php, method THttpSession::regenerate()
    Update the current session id with a newly generated one
    regenerateToken | in file TReCaptcha.php, method TReCaptcha::regenerateToken()
    regenerateToken in file TCaptcha.php, method TCaptcha::regenerateToken()
    Regenerates the token to be displayed.
    REGEX_RULES in file TTemplateManager.php, class constant TTemplate::REGEX_RULES
    '<!--.*?--!>' - template comments
    registerAction in file TOutputCache.php, method TOutputCache::registerAction()
    Registers an action associated with the content being cached.
    registerBeginScript in file TClientScriptManager.php, method TClientScriptManager::registerBeginScript()
    Registers a javascript script block at the beginning of the form
    registerCacheTriggers in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::registerCacheTriggers()
    Attach CacheModel to statement and register trigger statements for cache models
    registerCacheType | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::registerCacheType()
    registerCachingAction in file TPage.php, method TPage::registerCachingAction()
    Registers an action associated with the content being cached.
    registerCalendarClientScriptPost | in file TDatePicker.php, method TDatePicker::registerCalendarClientScriptPost()
    registerCalendarClientScriptPost | in file TActiveDatePicker.php, method TActiveDatePicker::registerCalendarClientScriptPost()
    registerCalendarClientScriptPre in file TActiveDatePicker.php, method TActiveDatePicker::registerCalendarClientScriptPre()
    Registers the javascript code to initialize the date picker.
    registerCalendarClientScriptPre in file TDatePicker.php, method TDatePicker::registerCalendarClientScriptPre()
    Registers the javascript code to initialize the date picker.
    registerCallbackClientScript in file TBaseActiveControl.php, method TBaseActiveCallbackControl::registerCallbackClientScript()
    Registers the callback control javascript code. Client-side options are
    registerCallbackControl in file TClientScriptManager.php, method TClientScriptManager::registerCallbackControl()
    Registers callback javascript for a control.
    registerClientScript in file TInPlaceTextBox.php, method TInPlaceTextBox::registerClientScript()
    Registers the relevant JavaScript.
    registerClientScript in file TKeyboard.php, method TKeyboard::registerClientScript()
    Registers the relevant JavaScript.
    registerClientScript in file TRatingList.php, method TRatingList::registerClientScript()
    Registers the relevant JavaScript.
    registerClientScript in file TTabPanel.php, method TTabPanel::registerClientScript()
    Registers the relevant JavaScript.
    registerClientScript in file TAccordion.php, method TAccordion::registerClientScript()
    Registers the relevant JavaScript.
    registerClientScriptValidator in file TBaseValidator.php, method TBaseValidator::registerClientScriptValidator()
    Registers the individual validator client-side javascript code.
    registerClientScriptValidator in file TCustomValidator.php, method TCustomValidator::registerClientScriptValidator()
    Only register the client-side validator if setClientValidationFunction is set.
    registerContent in file TTemplateControl.php, method TTemplateControl::registerContent()
    Registers a content control.
    registerContentPlaceHolder in file TTemplateControl.php, method TTemplateControl::registerContentPlaceHolder()
    Registers a content placeholder to this template control.
    registerControlToRender in file TActivePageAdapter.php, method TActivePageAdapter::registerControlToRender()
    Register a control for defered render() call.
    registerDefaultButton in file TClientScriptManager.php, method TClientScriptManager::registerDefaultButton()
    Register a default button to panel. When the $panel is in focus and the 'enter' key is pressed, the $button will be clicked.
    registerEditorClientScript in file THtmlArea.php, method THtmlArea::registerEditorClientScript()
    Registers the editor javascript file and code to initialize the editor.
    registerEndScript in file TClientScriptManager.php, method TClientScriptManager::registerEndScript()
    Registers a javascript script block at the end of the form
    registerFocusControl in file TClientScriptManager.php, method TClientScriptManager::registerFocusControl()
    Registers the control to receive default focus.
    registerHeadScript in file TClientScriptManager.php, method TClientScriptManager::registerHeadScript()
    Registers a javascript block in the page head.
    registerHeadScriptFile in file TClientScriptManager.php, method TClientScriptManager::registerHeadScriptFile()
    Registers a javascript file in the page head
    registerHiddenField in file TClientScriptManager.php, method TClientScriptManager::registerHiddenField()
    Registers a hidden field to be rendered in the form.
    registerMethods | in file TRpcService.php, method TRpcApiProvider::registerMethods()
    registerObject in file TControl.php, method TControl::registerObject()
    Registers an object by a name.
    registerPostBackControl in file TClientScriptManager.php, method TClientScriptManager::registerPostBackControl()
    Registers postback javascript for a control. A null class parameter will prevent the javascript code registration.
    registerPostDataLoader in file TPage.php, method TPage::registerPostDataLoader()
    Register post data loaders for Callback to collect post data.
    registerPradoScript in file TClientScriptManager.php, method TClientScriptManager::registerPradoScript()
    Registers Prado javascript by library name. See "Web/Javascripts/packages.php" for library names.
    registerPradoScriptInternal in file TClientScriptManager.php, method TClientScriptManager::registerPradoScriptInternal()
    Registers a Prado javascript library to be loaded.
    registerRequiresPostData in file TPage.php, method TPage::registerRequiresPostData()
    Registers a control for loading post data in the next postback.
    registerScriptFile in file TClientScriptManager.php, method TClientScriptManager::registerScriptFile()
    Registers a javascript file to be rendered within the form
    registerSliderClientScript in file TSlider.php, method TSlider::registerSliderClientScript()
    Registers the javascript code to initialize the slider.
    registerStyleSheet in file TKeyboard.php, method TKeyboard::registerStyleSheet()
    Registers the CSS relevant to the TKeyboard.
    registerStyleSheet in file TAccordion.php, method TAccordion::registerStyleSheet()
    Registers the CSS relevant to the TAccordion.
    registerStyleSheet in file TSlider.php, method TSlider::registerStyleSheet()
    Registers the CSS relevant to the TSlider.
    registerStyleSheet in file TTabPanel.php, method TTabPanel::registerStyleSheet()
    Registers the CSS relevant to the TTabControl.
    registerStyleSheet in file TTextHighlighter.php, method TTextHighlighter::registerStyleSheet()
    Registers the stylesheet for presentation.
    registerStyleSheet in file TClientScriptManager.php, method TClientScriptManager::registerStyleSheet()
    Registers a CSS block to be rendered in the page head
    registerStyleSheetFile in file TClientScriptManager.php, method TClientScriptManager::registerStyleSheetFile()
    Registers a CSS file to be rendered in the page head
    registerTriggerStatement in file TSqlMapCacheModel.php, method TSqlMapCacheModel::registerTriggerStatement()
    Register a mapped statement that will trigger a cache flush.
    registerTypeHandler | in file TSqlMapGateway.php, method TSqlMapGateway::registerTypeHandler()
    registerTypeHandler | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandlerRegistry::registerTypeHandler()
    reload in file THttpResponse.php, method THttpResponse::reload()
    Reloads the current page.
    remove in file THttpSession.php, method THttpSession::remove()
    Removes a session variable.
    remove in file THttpRequest.php, method THttpRequest::remove()
    Removes an item from the request by its key.
    remove in file TMap.php, method TMap::remove()
    Removes an item from the map by its key.
    remove in file TPriorityMap.php, method TPriorityMap::remove()
    Removes an item from the map by its key. If no priority, or false, is specified
    remove in file TAttributeCollection.php, method TAttributeCollection::remove()
    Removes an item from the map by its key.
    remove in file TCallbackClientScript.php, method TCallbackClientScript::remove()
    Removes an element from the HTML page.
    remove in file TPriorityList.php, method TPriorityList::remove()
    Removes an item from the priority list.
    remove in file TList.php, method TList::remove()
    Removes an item from the list.
    removeAt in file THttpRequest.php, method THttpCookieCollection::removeAt()
    Removes an item at the specified position.
    removeAt in file TControl.php, method TControlCollection::removeAt()
    Removes an item at the specified position.
    removeAt in file TWizard.php, method TWizardStepCollection::removeAt()
    Removes an item at the specified position.
    removeAt in file TActiveListControlAdapter.php, method TActiveListItemCollection::removeAt()
    Removes an item from at specified index.
    removeAt in file TList.php, method TList::removeAt()
    Removes an item at the specified position.
    removeAt in file TPriorityList.php, method TPriorityList::removeAt()
    Removes an item at the specified index in the flattened list.
    removeAt in file TXmlDocument.php, method TXmlElementList::removeAt()
    Removes an item at the specified position.
    removeAtIndexInPriority in file TPriorityList.php, method TPriorityList::removeAtIndexInPriority()
    Removes the item at a specific index within a priority. Override and call this method to insert your own functionality.
    removeAttribute in file TControl.php, method TControl::removeAttribute()
    Removes the named attribute.
    removeAttribute in file THtmlWriter.php, method THtmlWriter::removeAttribute()
    Removes the named attribute from rendering
    removeAttribute in file TImageMap.php, method THotSpot::removeAttribute()
    Removes the named attribute.
    removeAttribute in file TListItem.php, method TListItem::removeAttribute()
    Removes the named attribute.
    removeCookie in file THttpResponse.php, method THttpResponse::removeCookie()
    Deletes a cookie.
    removeCssClass in file TCallbackClientScript.php, method TCallbackClientScript::removeCssClass()
    Remove a Css class name from the element.
    removedControl in file TControl.php, method TControl::removedControl()
    Removes a control from the child collection of the control.
    removedWizardStep in file TWizard.php, method TWizard::removedWizardStep()
    Removes a wizard step from the multiview.
    removeParameter in file TTranslate.php, method TTranslate::removeParameter()
    Removes the named parameter.
    removeStyleAttribute in file THtmlWriter.php, method THtmlWriter::removeStyleAttribute()
    Removes the named stylesheet attribute from rendering
    render in file TWebControlAdapter.php, method TWebControlAdapter::render()
    Renders the control to which the adapter is attached.
    render in file TOutputCache.php, method TOutputCache::render()
    Renders the output cache control.
    render in file TWizard.php, method TWizard::render()
    Renders the wizard.
    render in file TDropContainer.php, method TDropContainer::render()
    Renders and replaces the panel's content on the client-side.
    render in file TWebControl.php, method TWebControl::render()
    Renders the control.
    render in file TValueTriggeredCallback.php, method TValueTriggeredCallback::render()
    Registers the javascript code for initializing the active control.
    render in file TExpression.php, method TExpression::render()
    Renders the evaluation result of the expression.
    render in file TEventTriggeredCallback.php, method TEventTriggeredCallback::render()
    Registers the javascript code for initializing the active control.
    render in file TPager.php, method TPager::render()
    Renders the control.
    render in file TDatePicker.php, method TDatePicker::render()
    Renders body content.
    render in file TImageMap.php, method TImageMap::render()
    Renders this imagemap.
    render in file TDataList.php, method TDataList::render()
    Renders the data list control.
    render in file TDataGrid.php, method TDataGrid::render()
    Renders the datagrid.
    render in file TDataListItemRenderer.php, method TDataListItemRenderer::render()
    Renders the control.
    render | in file TDateFormat.php, method TDateFormat::render()
    render in file TImageMap.php, method THotSpot::render()
    Renders this hotspot.
    render in file TXmlTransform.php, method TXmlTransform::render()
    Performs XSL transformation and render the output.
    render | in file TNumberFormat.php, method TNumberFormat::render()
    render in file TMultiView.php, method TMultiView::render()
    Renders the currently active view.
    render in file TLiteral.php, method TLiteral::render()
    Renders the literal control.
    render in file TLabel.php, method TLabel::render()
    Renders the label.
    render | in file TTabPanel.php, method TTabPanel::render()
    render in file TStyleSheet.php, method TStyleSheet::render()
    Renders the control.
    render in file TStatements.php, method TStatements::render()
    Renders the evaluation result of the statements.
    render in file TRepeater.php, method TRepeater::render()
    Renders the repeater.
    render in file TSafeHtml.php, method TSafeHtml::render()
    Renders body content.
    render in file THiddenField.php, method THiddenField::render()
    Renders the control.
    render in file TRatingList.php, method TRatingList::render()
    Add rating style class name to the class attribute when setReadOnly property is true and when the setCssClass property is empty.
    render in file TForm.php, method TForm::render()
    Renders the form.
    render in file TFlushOutput.php, method TFlushOutput::render()
    Flushes the output of all completely rendered controls to the client.
    render in file TTranslate.php, method TTranslate::render()
    renders the translated string.
    render | in file TPanel.php, method TPanel::render()
    render in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::render()
    Registers the javascript code for initializing the active control.
    render | in file TTextHighlighter.php, method TTextHighlighter::render()
    render in file THead.php, method THead::render()
    Renders the head control.
    render in file interfaces.php, method IRenderable::render()
    Renders the component to end-users.
    render in file THead.php, method TMetaTag::render()
    Renders the meta tag.
    render in file TActiveTableCell.php, method TActiveTableCell::render()
    Renders and replaces the cell's content on the client-side. When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.
    render in file TActiveTableRow.php, method TActiveTableRow::render()
    Renders and replaces the row's content on the client-side. When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.
    render | in file TAccordion.php, method TAccordion::render()
    render in file TActiveRepeater.php, method TActiveRepeater::render()
    Renders the repeater.
    render in file TActivePanel.php, method TActivePanel::render()
    Renders and replaces the panel's content on the client-side.
    render in file TControl.php, method TControl::render()
    Renders the control.
    render in file TControl.php, method TCompositeLiteral::render()
    Renders the content stored in this component.
    render in file TClientScript.php, method TClientScript::render()
    Renders the body content as javascript block.
    render in file TCheckBoxList.php, method TCheckBoxList::render()
    Renders the checkbox list control.
    render in file TCheckBox.php, method TCheckBox::render()
    Renders the checkbox control.
    render in file TBulletedList.php, method TBulletedList::render()
    Renders the control.
    render in file TActiveMultiView.php, method TActiveMultiView::render()
    Renders the TActiveMultiView.
    render | in file TActivePager.php, method TActivePager::render()
    render in file TControlAdapter.php, method TControlAdapter::render()
    This method is invoked when the control renders itself.
    render in file TActiveDataList.php, method TActiveDataList::render()
    Renders the repeater.
    render in file TActiveControlAdapter.php, method TActiveControlAdapter::render()
    Renders the callback client scripts.
    render in file TActiveDataGrid.php, method TActiveDataGrid::render()
    Renders the datagrid.
    renderAllPendingScriptFiles | in file TClientScriptManager.php, method TClientScriptManager::renderAllPendingScriptFiles()
    renderBeginScripts | in file TClientScriptManager.php, method TClientScriptManager::renderBeginScripts()
    renderBeginTag in file TDataListItemRenderer.php, method TDataListItemRenderer::renderBeginTag()
    Renders the openning tag for the control (including attributes) This method is invoked when getTagName is not empty.
    renderBeginTag in file TTable.php, method TTable::renderBeginTag()
    Renders the openning tag for the table control which will render table caption if present.
    renderBeginTag in file TWebControlAdapter.php, method TWebControlAdapter::renderBeginTag()
    Renders the openning tag for the attached control.
    renderBeginTag in file TPanel.php, method TPanel::renderBeginTag()
    Renders the openning tag for the control (including attributes)
    renderBeginTag in file THtmlWriter.php, method THtmlWriter::renderBeginTag()
    Renders the openning tag.
    renderBeginTag in file TDataGrid.php, method TDataGrid::renderBeginTag()
    Renders the openning tag for the datagrid control which will render table caption if present.
    renderBeginTag in file TWebControl.php, method TWebControl::renderBeginTag()
    Renders the openning tag for the control (including attributes)
    renderBeginTag in file TTextBox.php, method TTextBox::renderBeginTag()
    Renders an additional line-break after the opening tag when it is in MultiLine text mode.
    renderBulletList in file TValidationSummary.php, method TValidationSummary::renderBulletList()
    Render the validation summary as a bullet list.
    renderBulletText in file TBulletedList.php, method TBulletedList::renderBulletText()
    Renders each item
    renderButtonDatePicker in file TDatePicker.php, method TDatePicker::renderButtonDatePicker()
    Adds an additional button such that when clicked it shows the date picker.
    renderCalendarDayOptions in file TDatePicker.php, method TDatePicker::renderCalendarDayOptions()
    Renders the day drop down list options.
    renderCalendarMonthOptions in file TDatePicker.php, method TDatePicker::renderCalendarMonthOptions()
    Renders the month drop down list options.
    renderCalendarSelections in file TDatePicker.php, method TDatePicker::renderCalendarSelections()
    Renders the calendar drop down list depending on the DateFormat pattern.
    renderCalendarYearOptions in file TDatePicker.php, method TDatePicker::renderCalendarYearOptions()
    Renders the year drop down list options.
    renderCallback in file TAutoComplete.php, method TAutoComplete::renderCallback()
    Renders the suggestions during a callback respones.
    renderCallbackClientScripts in file TActiveControlAdapter.php, method TActiveControlAdapter::renderCallbackClientScripts()
    Register the callback clientscripts and sets the post loader IDs.
    renderCallbackResponse in file TActivePageAdapter.php, method TActivePageAdapter::renderCallbackResponse()
    Render the callback response.
    renderChildren in file TControl.php, method TControl::renderChildren()
    Renders the children of the control.
    renderChildren in file TControlAdapter.php, method TControlAdapter::renderChildren()
    Renders the control's children.
    renderClientControlScript in file TListControl.php, method TListControl::renderClientControlScript()
    Renders the javascript for list control.
    renderClientControlScript in file TLinkButton.php, method TLinkButton::renderClientControlScript()
    Renders the client-script code.
    renderClientControlScript in file TTextBox.php, method TTextBox::renderClientControlScript()
    Renders the javascript for textbox.
    renderClientControlScript in file TActiveCheckBox.php, method TActiveCheckBox::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    renderClientControlScript in file TImageButton.php, method TImageButton::renderClientControlScript()
    Renders the client-script code.
    renderClientControlScript in file TActiveImageButton.php, method TActiveImageButton::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    renderClientControlScript in file TButton.php, method TButton::renderClientControlScript()
    Renders the client-script code.
    renderClientControlScript in file TCheckBox.php, method TCheckBox::renderClientControlScript()
    Renders the client-script code.
    renderClientControlScript in file TActiveButton.php, method TActiveButton::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    renderClientControlScript in file TActiveDropDownList.php, method TActiveDropDownList::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    renderClientControlScript in file TRadioButton.php, method TRadioButton::renderClientControlScript()
    Renders the client-script code.
    renderClientControlScript in file TActiveTextBox.php, method TActiveTextBox::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    renderClientControlScript in file TActiveCheckBoxList.php, method TActiveCheckBoxList::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    renderClientControlScript in file TActiveRadioButtonList.php, method TActiveRadioButtonList::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    renderClientControlScript in file TAutoComplete.php, method TAutoComplete::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    renderClientControlScript in file TActiveHiddenField.php, method TActiveHiddenField::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    renderClientControlScript in file TActiveLinkButton.php, method TActiveLinkButton::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    renderClientControlScript in file TActiveRadioButton.php, method TActiveRadioButton::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    renderClientControlScript in file TActiveListBox.php, method TActiveListBox::renderClientControlScript()
    Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
    renderClientControlScript in file TBaseValidator.php, method TBaseValidator::renderClientControlScript()
    Renders the javascript code to the end script.
    renderContents in file TLabel.php, method TLabel::renderContents()
    Renders the body content of the label.
    renderContents in file TTable.php, method TTable::renderContents()
    Renders body contents of the table.
    renderContents in file TLinkButton.php, method TLinkButton::renderContents()
    Renders the body content enclosed between the control tag.
    renderContents in file TTableCell.php, method TTableCell::renderContents()
    Renders body contents of the table cell.
    renderContents in file TTableRow.php, method TTableRow::renderContents()
    Renders body contents of the table row
    renderContents in file TTabPanel.php, method TTabView::renderContents()
    Renders body contents of the tab view.
    renderContents in file TTabPanel.php, method TTabPanel::renderContents()
    Renders body contents of the tab control.
    renderContents in file TSlider.php, method TSlider::renderContents()
    Render the body content
    renderContents in file TAccordion.php, method TAccordionView::renderContents()
    Renders body contents of the accordion view.
    renderContents in file TBulletedList.php, method TBulletedList::renderContents()
    Renders the body contents.
    renderContents in file TButton.php, method TButton::renderContents()
    Renders the body content enclosed between the control tag.
    renderContents in file TBaseValidator.php, method TBaseValidator::renderContents()
    Renders the validator control.
    renderContents in file TListControl.php, method TListControl::renderContents()
    Renders body content of the list control.
    renderContents in file TAccordion.php, method TAccordion::renderContents()
    Renders body contents of the accordion control.
    renderContents | in file TReCaptcha.php, method TReCaptcha::renderContents()
    renderContents in file TTextBox.php, method TTextBox::renderContents()
    Renders the body content of the textbox when it is in MultiLine text mode.
    renderContents in file TJavascriptLogger.php, method TJavascriptLogger::renderContents()
    Register the required javascript libraries and display some general usage information.
    renderContents in file TTextProcessor.php, method TTextProcessor::renderContents()
    Renders body content.
    renderContents in file TWebControl.php, method TWebControl::renderContents()
    Renders the body content enclosed between the control tag.
    renderContents in file TWebControlAdapter.php, method TWebControlAdapter::renderContents()
    Renders the body contents within the attached control tag.
    renderContents in file TImage.php, method TImage::renderContents()
    Renders the body content of the image.
    renderContents in file THyperLink.php, method THyperLink::renderContents()
    Renders the body content of the hyperlink.
    renderContents in file TValidationSummary.php, method TValidationSummary::renderContents()
    Overrides parent implementation by rendering TValidationSummary-specific presentation.
    renderContents in file TImageButton.php, method TImageButton::renderContents()
    Renders the body content enclosed between the control tag.
    renderContents in file TDataListItemRenderer.php, method TDataListItemRenderer::renderContents()
    Renders the body content enclosed between the control tag.
    renderContents in file TInPlaceTextBox.php, method TInPlaceTextBox::renderContents()
    Renders the body content of the label.
    renderControl in file TControl.php, method TControl::renderControl()
    Renders the control.
    renderCustomScript in file TClientScript.php, method TClientScript::renderCustomScript()
    Registers the body content as javascript.
    renderCustomScript in file TActiveClientScript.php, method TActiveClientScript::renderCustomScript()
    Registers the body content as javascript.
    renderCustomScriptFile in file TClientScript.php, method TClientScript::renderCustomScriptFile()
    Renders the custom script file.
    renderCustomScriptFile in file TActiveClientScript.php, method TActiveClientScript::renderCustomScriptFile()
    Renders the custom script file.
    renderDatePickerButtons in file TDatePicker.php, method TDatePicker::renderDatePickerButtons()
    Renders the date picker popup buttons.
    renderDropDownListCalendar in file TDatePicker.php, method TDatePicker::renderDropDownListCalendar()
    Renders the drop down list date picker.
    renderEndScripts | in file TClientScriptManager.php, method TClientScriptManager::renderEndScripts()
    renderEndTag in file TColorPicker.php, method TColorPicker::renderEndTag()
    Renders additional body content.
    renderEndTag in file TAutoComplete.php, method TAutoComplete::renderEndTag()
    Renders the end tag and registers javascript effects library.
    renderEndTag in file TPanel.php, method TPanel::renderEndTag()
    Renders the closing tag for the control
    renderEndTag in file TWebControl.php, method TWebControl::renderEndTag()
    Renders the closing tag for the control
    renderEndTag in file THtmlWriter.php, method THtmlWriter::renderEndTag()
    Renders the closing tag.
    renderEndTag in file TDataListItemRenderer.php, method TDataListItemRenderer::renderEndTag()
    Renders the closing tag for the control This method is invoked when getTagName is not empty.
    renderEndTag in file TWebControlAdapter.php, method TWebControlAdapter::renderEndTag()
    Renders the closing tag for the attached control.
    renderFooter | in file TLogRouter.php, method TFirebugLogRoute::renderFooter()
    renderFooter in file TRepeatInfo.php, method TRepeatInfo::renderFooter()
    Renders footer.
    renderFooter | in file TLogRouter.php, method TBrowserLogRoute::renderFooter()
    renderHeader in file TAccordion.php, method TAccordionView::renderHeader()
    Renders the header associated with the accordion view.
    renderHeader | in file TLogRouter.php, method TBrowserLogRoute::renderHeader()
    renderHeader in file TRepeatInfo.php, method TRepeatInfo::renderHeader()
    Renders header.
    renderHeader | in file TLogRouter.php, method TFirebugLogRoute::renderHeader()
    renderHeaderContent in file TAccordion.php, method TAccordionView::renderHeaderContent()
    Renders the content in the header.
    renderHeaderOnly in file TValidationSummary.php, method TValidationSummary::renderHeaderOnly()
    Render the validation summary header text only.
    renderHeadScriptFiles | in file TClientScriptManager.php, method TClientScriptManager::renderHeadScriptFiles()
    renderHeadScripts | in file TClientScriptManager.php, method TClientScriptManager::renderHeadScripts()
    renderHiddenFieldsBegin | in file TClientScriptManager.php, method TClientScriptManager::renderHiddenFieldsBegin()
    renderHiddenFieldsEnd | in file TClientScriptManager.php, method TClientScriptManager::renderHiddenFieldsEnd()
    renderHiddenFieldsInt | in file TClientScriptManager.php, method TClientScriptManager::renderHiddenFieldsInt()
    renderHorizontalContents in file TRepeatInfo.php, method TRepeatInfo::renderHorizontalContents()
    Renders contents in horizontal repeat direction.
    renderHyperLinkItem | in file TBulletedList.php, method TBulletedList::renderHyperLinkItem()
    renderImageButtonDatePicker in file TDatePicker.php, method TDatePicker::renderImageButtonDatePicker()
    Adds an additional image button such that when clicked it shows the date picker.
    renderInputTag in file TCheckBox.php, method TCheckBox::renderInputTag()
    Renders a checkbox input element.
    renderInputTag in file TActiveRadioButton.php, method TActiveRadioButton::renderInputTag()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    renderInputTag in file TRadioButton.php, method TRadioButton::renderInputTag()
    Renders a radiobutton input element.
    renderInputTag in file TActiveCheckBox.php, method TActiveCheckBox::renderInputTag()
    Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
    renderItem in file TRepeatInfo.php, method IRepeatInfoUser::renderItem()
    Renders an item.
    renderItem in file TCheckBoxList.php, method TCheckBoxList::renderItem()
    Renders an item in the list.
    renderItem in file TDataList.php, method TDataList::renderItem()
    Renders an item in the list.
    renderJsSummary in file TValidationSummary.php, method TValidationSummary::renderJsSummary()
    Render the javascript for validation summary.
    renderLabel in file TActiveRadioButton.php, method TActiveRadioButton::renderLabel()
    Renders a label beside the radio button.
    renderLabel in file TCheckBox.php, method TCheckBox::renderLabel()
    Renders a label beside the checkbox.
    renderLabel in file TActiveCheckBox.php, method TActiveCheckBox::renderLabel()
    Renders a label beside the checkbox.
    renderLinkButtonHref in file TLinkButton.php, method TLinkButton::renderLinkButtonHref()
    Renders the Href for link button.
    renderLinkButtonItem | in file TBulletedList.php, method TBulletedList::renderLinkButtonItem()
    renderList in file TValidationSummary.php, method TValidationSummary::renderList()
    Render the validation summary as a simple list.
    renderMessage | in file TLogRouter.php, method TFirebugLogRoute::renderMessage()
    renderMessage | in file TLogRouter.php, method TBrowserLogRoute::renderMessage()
    renderMultiView in file TActiveMultiView.php, method TActiveMultiView::renderMultiView()
    Renders the TActiveMultiView by writing a span tag with the container id obtained from getContainerID() which will be called by the replacement method of the client script to update it's content.
    renderPostContentsText in file TWebControlDecorator.php, method TWebControlDecorator::renderPostContentsText()
    This method places the post contents text into the TTextWriter
    renderPostTagText in file TWebControlDecorator.php, method TWebControlDecorator::renderPostTagText()
    This method places the post tag text into the TTextWriter
    renderPreContentsText in file TWebControlDecorator.php, method TWebControlDecorator::renderPreContentsText()
    This method places the pre contents text into the TTextWriter
    renderPreTagText in file TWebControlDecorator.php, method TWebControlDecorator::renderPreTagText()
    This method places the pre tag text into the TTextWriter
    renderPrompt in file TListControl.php, method TListControl::renderPrompt()
    Renders the prompt text, if any.
    renderRawContents in file TRepeatInfo.php, method TRepeatInfo::renderRawContents()
    Renders contents in raw format.
    renderRepeater in file TRepeatInfo.php, method TRepeatInfo::renderRepeater()
    Renders the repeated items.
    renderResponse in file TActivePageAdapter.php, method TActivePageAdapter::renderResponse()
    Renders the callback response by adding additional callback data and javascript actions in the header and page state if required.
    renderResultPanel in file TAutoComplete.php, method TAutoComplete::renderResultPanel()
    Renders the result panel.
    renderScriptBlock in file TJavaScript.php, method TJavaScript::renderScriptBlock()
    Renders javascript block
    renderScriptBlocks in file TJavaScript.php, method TJavaScript::renderScriptBlocks()
    Renders a list of javascript blocks
    renderScriptFile in file TJavaScript.php, method TJavaScript::renderScriptFile()
    Renders a javascript file
    renderScriptFiles | in file TClientScriptManager.php, method TClientScriptManager::renderScriptFiles()
    renderScriptFiles in file TJavaScript.php, method TJavaScript::renderScriptFiles()
    Renders a list of javascript files
    renderScriptFilesBegin | in file TClientScriptManager.php, method TClientScriptManager::renderScriptFilesBegin()
    renderScriptFilesEnd | in file TClientScriptManager.php, method TClientScriptManager::renderScriptFilesEnd()
    renderSingleParagraph in file TValidationSummary.php, method TValidationSummary::renderSingleParagraph()
    Render the validation summary as a paragraph.
    renderStyleSheetFiles | in file TClientScriptManager.php, method TClientScriptManager::renderStyleSheetFiles()
    renderStyleSheets | in file TClientScriptManager.php, method TClientScriptManager::renderStyleSheets()
    renderSuggestions in file TAutoComplete.php, method TAutoComplete::renderSuggestions()
    Renders the suggestions repeater.
    renderTab in file TTabPanel.php, method TTabView::renderTab()
    Renders the tab associated with the tab view.
    renderTabContent in file TTabPanel.php, method TTabView::renderTabContent()
    Renders the content in the tab.
    renderTable in file TDataGrid.php, method TDataGrid::renderTable()
    Renders the tabular data.
    renderTextItem | in file TBulletedList.php, method TBulletedList::renderTextItem()
    renderVerticalContents in file TRepeatInfo.php, method TRepeatInfo::renderVerticalContents()
    Renders contents in veritcal repeat direction.
    replace in file TCallbackClientScript.php, method TCallbackClientScript::replace()
    Replace the content of an element with new content. The new content can be a string or a TControl component. If the <tt>content</tt> parameter is a TControl component, its rendered method will be called and its contents will be used for replacement.
    replaceContent in file TCallbackClientScript.php, method TCallbackClientScript::replaceContent()
    Replace the content of an element with new content contained in writer.
    replaceDynamicParameter | in file TSimpleDynamicSql.php, method TSimpleDynamicSql::replaceDynamicParameter()
    replaceProperties in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::replaceProperties()
    Replace the place holders ${name} in text with properties the corresponding global property value.
    requiresControlsRecreation in file TWizard.php, method TWizard::requiresControlsRecreation()
    Indicates the wizard needs to recreate all child controls.
    reset in file TStyle.php, method TTableItemStyle::reset()
    Sets the style attributes to default values.
    reset in file TWizard.php, method TWizard::reset()
    Clears up everything within the wizard.
    Reset | in file TButton.php, class constant TButtonType::Reset
    reset in file TDataGrid.php, method TDataGrid::reset()
    Clears up all items in the datagrid.
    reset in file TStyle.php, method TStyle::reset()
    Resets the style to the original empty state.
    reset in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::reset()
    Sets the style attributes to default values.
    reset in file TDataList.php, method TDataList::reset()
    Clears up all items in the data list.
    reset in file TFont.php, method TFont::reset()
    Clears up the font.
    reset in file TStyle.php, method TTableStyle::reset()
    Sets the style attributes to default values.
    reset in file TPanelStyle.php, method TPanelStyle::reset()
    Sets the style attributes to default values.
    reset in file TRepeater.php, method TRepeater::reset()
    Clears up all items in the repeater.
    reset in file TDataGridPagerStyle.php, method TDataGridPagerStyle::reset()
    Resets the style to the original empty state.
    resolvePaths in file TApplication.php, method TApplication::resolvePaths()
    Resolves application-relevant paths.
    resolveRequest in file TSoapService.php, method TSoapService::resolveRequest()
    Resolves the request parameter.
    resolveRequest in file THttpRequest.php, method THttpRequest::resolveRequest()
    Resolves the requested service.
    resolveResultMapping in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::resolveResultMapping()
    Resolve nest result mappings.
    resolveSubMap in file TResultMap.php, method TResultMap::resolveSubMap()
    Result sub-mappings using the discriminiator column.
    respondToChanges in file TActiveControlAdapter.php, method TCallbackPageStateTracker::respondToChanges()
    For each of the changes call the corresponding change handlers.
    ResponseFieldName | in file TReCaptcha.php, class constant TReCaptcha::ResponseFieldName
    restoreGridFromViewState in file TDataGrid.php, method TDataGrid::restoreGridFromViewState()
    Restores datagrid content from viewstate.
    restoreItemsFromViewState in file TRepeater.php, method TRepeater::restoreItemsFromViewState()
    Creates repeater items based on viewstate information.
    restoreItemsFromViewState in file TDataList.php, method TDataList::restoreItemsFromViewState()
    Creates data list items based on viewstate information.
    resultMap | in file TSqlMapStatement.php, method TSqlMapStatement::resultMap()
    RETURN_URL_VAR in file TAuthManager.php, class constant TAuthManager::RETURN_URL_VAR
    GET variable name for return url
    reverseDirection | in file TMssqlCommandBuilder.php, method TMssqlCommandBuilder::reverseDirection()
    Revert | in file TDraggable.php, class constant TDraggableRevertOptions::Revert
    rewind in file TPagedDataSource.php, method TPagedListIterator::rewind()
    Rewinds internal array pointer.
    rewind in file TPagedDataSource.php, method TPagedMapIterator::rewind()
    Rewinds internal array pointer.
    rewind in file TDbDataReader.php, method TDbDataReader::rewind()
    Resets the iterator to the initial state.
    rewind in file TDummyDataSource.php, method TDummyDataSourceIterator::rewind()
    Rewinds internal array pointer.
    rewind in file TMap.php, method TMapIterator::rewind()
    Rewinds internal array pointer.
    rewind in file TList.php, method TListIterator::rewind()
    Rewinds internal array pointer.
    rewind in file THttpSession.php, method TSessionIterator::rewind()
    Rewinds internal array pointer.
    rewind | in file TComponent.php, method TEnumerable::rewind()
    rewind in file TStack.php, method TStackIterator::rewind()
    Rewinds internal array pointer.
    rewind in file TQueue.php, method TQueueIterator::rewind()
    Rewinds internal array pointer.
    rewriteLimitOffsetSql in file TMssqlCommandBuilder.php, method TMssqlCommandBuilder::rewriteLimitOffsetSql()
    Rewrite sql to apply $limit > and $offset > 0 for MSSQL database.
    RF_ADAPTER | in file TControl.php, class constant TControl::RF_ADAPTER
    RF_AUTO_BINDINGS | in file TControl.php, class constant TControl::RF_AUTO_BINDINGS
    RF_CHILD_STATE | in file TControl.php, class constant TControl::RF_CHILD_STATE
    RF_CONTROLS in file TControl.php, class constant TControl::RF_CONTROLS
    Indexes for the rare fields.
    RF_CONTROLSTATE | in file TControl.php, class constant TControl::RF_CONTROLSTATE
    RF_DATA_BINDINGS | in file TControl.php, class constant TControl::RF_DATA_BINDINGS
    RF_EVENTS | in file TControl.php, class constant TControl::RF_EVENTS
    RF_NAMED_CONTROLS | in file TControl.php, class constant TControl::RF_NAMED_CONTROLS
    RF_NAMED_CONTROLS_ID | in file TControl.php, class constant TControl::RF_NAMED_CONTROLS_ID
    RF_NAMED_OBJECTS | in file TControl.php, class constant TControl::RF_NAMED_OBJECTS
    RF_SKIN_ID | in file TControl.php, class constant TControl::RF_SKIN_ID
    Right | in file TStyle.php, class constant THorizontalAlign::Right
    Right | in file TTable.php, class constant TTableCaptionAlign::Right
    Right | in file TCheckBox.php, class constant TTextAlign::Right
    Right | in file TInlineFrame.php, class constant TInlineFrameAlign::Right
    RightToLeft | in file TPanelStyle.php, class constant TContentDirection::RightToLeft
    rollback in file TDbTransaction.php, method TDbTransaction::rollback()
    Rolls back a transaction.
    rotateFiles in file TLogRouter.php, method TFileLogRoute::rotateFiles()
    Rotates log files.
    Row | in file TTableHeaderCell.php, class constant TTableHeaderScope::Row
    run in file TSoapService.php, method TSoapService::run()
    Runs the service.
    run in file TJsonService.php, method TJsonService::run()
    Runs the service.
    run in file TFeedService.php, method TFeedService::run()
    Runs the service.
    run in file TPageService.php, method TPageService::run()
    Runs the service.
    run in file TPage.php, method TPage::run()
    Runs through the page lifecycles.
    run in file interfaces.php, method IService::run()
    Runs the service.
    run in file TApplication.php, method TApplication::run()
    Executes the lifecycles of the application.
    run in file TSoapService.php, method TSoapServer::run()
    Handles the SOAP request.
    run in file TShellApplication.php, method TShellApplication::run()
    Runs the application.
    run in file TService.php, method TService::run()
    Runs the service.
    run in file TRpcService.php, method TRpcService::run()
    Runs the service
    runPage in file TPageService.php, method TPageService::runPage()
    Executes a page.
    runQueryForList in file TMappedStatement.php, method TMappedStatement::runQueryForList()
    Executes the SQL and retuns a List of result objects.
    runQueryForMap in file TMappedStatement.php, method TMappedStatement::runQueryForMap()
    Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
    runQueryForObject in file TMappedStatement.php, method TMappedStatement::runQueryForObject()
    Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
    runService in file TApplication.php, method TApplication::runService()
    Runs the requested service.
    RUNTIME_PATH in file TApplication.php, class constant TApplication::RUNTIME_PATH
    Runtime directory name
    top
    s
    save in file TSessionPageStatePersister.php, method TSessionPageStatePersister::save()
    Saves state in session.
    save in file TPageStatePersister.php, method TPageStatePersister::save()
    Saves state in hidden fields.
    save in file TCachePageStatePersister.php, method TCachePageStatePersister::save()
    Saves state in cache.
    save in file TPage.php, method IPageStatePersister::save()
    Saves state to persistent storage.
    save in file interfaces.php, method IStatePersister::save()
    Saves state into a persistent storage.
    save in file TApplication.php, method TApplicationStatePersister::save()
    Saves application state in persistent storage.
    save in file TActiveRecord.php, method TActiveRecord::save()
    Saves the current record to the database, insert or update is automatically determined.
    saveAs in file TActiveFileUpload.php, method TActiveFileUpload::saveAs()
    Saves the uploaded file.
    saveAs in file TFileUpload.php, method TFileUpload::saveAs()
    Saves the uploaded file.
    saveGlobals in file TApplication.php, method TApplication::saveGlobals()
    Saves global values into persistent storage.
    saveMessages in file Translation.php, method Translation::saveMessages()
    Save untranslated messages to the catalogue.
    savePageState in file TPage.php, method TPage::savePageState()
    Saves page state from persistent storage.
    saveState in file TWizard.php, method TWizard::saveState()
    Saves the current active step index into history.
    saveState in file TDropDownListColumn.php, method TDropDownListColumn::saveState()
    Saves items into viewstate.
    saveState in file TControlAdapter.php, method TControlAdapter::saveState()
    Saves additional persistent control state.
    saveState in file TListControl.php, method TListControl::saveState()
    Saves items into viewstate.
    saveState in file TControl.php, method TControl::saveState()
    This method is invoked when control state is to be saved.
    saveState in file TListItemCollection.php, method TListItemCollection::saveState()
    Saves state of items.
    saveState in file TActiveControlAdapter.php, method TActiveControlAdapter::saveState()
    Saves additional persistent control state. Respond to viewstate changes if necessary.
    saveState in file TPage.php, method TPage::saveState()
    This method is invoked when control state is to be saved.
    saveState in file TRepeater.php, method TRepeater::saveState()
    Saves item count in viewstate.
    saveState in file TDataGrid.php, method TDataGrid::saveState()
    Saves item count in viewstate.
    saveState in file TDataList.php, method TDataList::saveState()
    Saves item count in viewstate.
    saveState in file TDataGridColumn.php, method TDataGridColumn::saveState()
    Saves persistent state values.
    saveStateRecursive in file TControl.php, method TControl::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
    saveStateRecursive in file TOutputCache.php, method TOutputCache::saveStateRecursive()
    Saves all control state (viewstate and controlstate) as a collection.
    saveToFile in file TXmlDocument.php, method TXmlDocument::saveToFile()
    Saves this XML document as an XML file.
    saveToString | in file interfaces.php, method IUser::saveToString()
    saveToString | in file TUser.php, method TUser::saveToString()
    saveToString in file TXmlDocument.php, method TXmlDocument::saveToString()
    Saves this XML document as an XML string
    saveUserToCookie in file TUserManager.php, method TUserManager::saveUserToCookie()
    Saves user auth data into a cookie.
    saveUserToCookie in file TDbUserManager.php, method TDbUser::saveUserToCookie()
    Saves necessary auth data into a cookie.
    saveUserToCookie in file TDbUserManager.php, method TDbUserManager::saveUserToCookie()
    Saves user auth data into a cookie.
    saveUserToCookie in file IUserManager.php, method IUserManager::saveUserToCookie()
    Saves user auth data into a cookie.
    SCRIPT_PATH in file TRatingList.php, class constant TRatingList::SCRIPT_PATH
    Script path relative to the TClientScriptManager::SCRIPT_PATH
    SCRIPT_PATH | in file TColorPicker.php, class constant TColorPicker::SCRIPT_PATH
    SCRIPT_PATH in file TDatePicker.php, class constant TDatePicker::SCRIPT_PATH
    Script path relative to the TClientScriptManager::SCRIPT_PATH
    SCRIPT_PATH | in file TActiveFileUpload.php, class constant TActiveFileUpload::SCRIPT_PATH
    SCRIPT_PATH in file TClientScriptManager.php, class constant TClientScriptManager::SCRIPT_PATH
    directory containing Prado javascript files
    scrollTo in file TCallbackClientScript.php, method TCallbackClientScript::scrollTo()
    Scroll the top of the browser viewing area to the location of the element.
    Search | in file TTextBox.php, class constant TTextBoxAutoCompleteType::Search
    select in file TDataSourceView.php, method TDataSourceView::select()
    Performs DB selection based on specified parameters.
    select | in file TDataSourceView.php, method TReadOnlyDataSourceView::select()
    select in file TCallbackClientScript.php, method TCallbackClientScript::select()
    Client script to select/clear/check a drop down list, check box list, or radio button list.
    SelectedItem | in file TDataBoundControl.php, class constant TListItemType::SelectedItem
    sendContentTypeHeader in file THttpResponse.php, method THttpResponse::sendContentTypeHeader()
    Sends content type header with optional charset.
    sendHttpHeader in file THttpResponse.php, method THttpResponse::sendHttpHeader()
    Send the HTTP header with the status code (defaults to 200) and status reason (defaults to OK)
    Separator | in file TDataBoundControl.php, class constant TListItemType::Separator
    serialize | in file TPage.php, method TPageStateFormatter::serialize()
    serialize in file PradoBase.php, method PradoBase::serialize()
    Serializes a data.
    set in file TPropertyAccess.php, method TPropertyAccess::set()
    Sets the property value.
    set in file interfaces.php, method ICache::set()
    Stores a value identified by a key into cache.
    set in file TSqlMapCache.php, method TSqlMapLruCache::set()
    Stores a value identified by a key into cache.
    set in file TCache.php, method TCache::set()
    Stores a value identified by a key into cache.
    set in file TSqlMapCache.php, method TSqlMapFifoCache::set()
    Stores a value identified by a key into cache.
    set | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::set()
    set | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::set()
    set in file TSqlMapCache.php, method TSqlMapApplicationCache::set()
    Stores a value identified by a key into cache.
    setAbbreviatedText | in file TTableHeaderCell.php, method TTableHeaderCell::setAbbreviatedText()
    setAcceptCssClass in file TDropContainer.php, method TDropContainer::setAcceptCssClass()
    Sets the Css class name that this container can accept.
    setAccessKey in file TWebControl.php, method TWebControl::setAccessKey()
    Sets the access key of the control.
    setAccessKey | in file TImageMap.php, method THotSpot::setAccessKey()
    setActive in file TDbConnection.php, method TDbConnection::setActive()
    Open or close the DB connection.
    setActive | in file TTabPanel.php, method TTabView::setActive()
    setActive | in file TAccordion.php, method TAccordionView::setActive()
    setActive | in file TDbTransaction.php, method TDbTransaction::setActive()
    setActive | in file TMultiView.php, method TView::setActive()
    setActiveHeaderCssClass | in file TAccordion.php, method TAccordion::setActiveHeaderCssClass()
    setActiveStep | in file TWizard.php, method TWizard::setActiveStep()
    setActiveStepIndex | in file TWizard.php, method TWizard::setActiveStepIndex()
    setActiveTabCssClass | in file TTabPanel.php, method TTabPanel::setActiveTabCssClass()
    setActiveView | in file TMultiView.php, method TMultiView::setActiveView()
    setActiveView | in file TAccordion.php, method TAccordion::setActiveView()
    setActiveView | in file TTabPanel.php, method TTabPanel::setActiveView()
    setActiveView | in file TActiveMultiView.php, method TActiveMultiView::setActiveView()
    setActiveViewID | in file TTabPanel.php, method TTabPanel::setActiveViewID()
    setActiveViewID | in file TAccordion.php, method TAccordion::setActiveViewID()
    setActiveViewIndex | in file TMultiView.php, method TMultiView::setActiveViewIndex()
    setActiveViewIndex | in file TTabPanel.php, method TTabPanel::setActiveViewIndex()
    setActiveViewIndex | in file TActiveMultiView.php, method TActiveMultiView::setActiveViewIndex()
    setActiveViewIndex | in file TAccordion.php, method TAccordion::setActiveViewIndex()
    setActor | in file TSoapService.php, method TSoapServer::setActor()
    setAdapter | in file THttpResponse.php, method THttpResponse::setAdapter()
    setAdapter | in file TControl.php, method TControl::setAdapter()
    setAlign | in file TInlineFrame.php, method TInlineFrame::setAlign()
    setAllowAutoLogin | in file TAuthManager.php, method TAuthManager::setAllowAutoLogin()
    setAllowCustomPaging | in file TPagedDataSource.php, method TPagedDataSource::setAllowCustomPaging()
    setAllowCustomPaging in file TDataBoundControl.php, method TDataBoundControl::setAllowCustomPaging()
    Sets a value indicating whether the custom paging should be enabled.
    setAllowInput in file TRatingList.php, method TRatingList::setAllowInput()
    Wrapper for setReadOnly property.
    setAllowPaging | in file TDataBoundControl.php, method TDataBoundControl::setAllowPaging()
    setAllowPaging | in file TPagedDataSource.php, method TPagedDataSource::setAllowPaging()
    setAllowReturn | in file TWizard.php, method TWizardStep::setAllowReturn()
    setAllowSorting | in file TDataGrid.php, method TDataGrid::setAllowSorting()
    setAlternateText in file TActiveImage.php, method TActiveImage::setAlternateText()
    Sets the alternative text to be displayed in the TImage when the image is unavailable.
    setAlternateText in file TActiveImageButton.php, method TActiveImageButton::setAlternateText()
    Sets the alternative text to be displayed in the TImage when the image is unavailable.
    setAlternateText | in file TImageMap.php, method THotSpot::setAlternateText()
    setAlternateText in file TImage.php, method TImage::setAlternateText()
    Sets the alternative text to be displayed in the TImage when the image is unavailable.
    setAlternatingItemRenderer in file TDataList.php, method TDataList::setAlternatingItemRenderer()
    Sets the alternative item renderer class.
    setAlternatingItemRenderer in file TRepeater.php, method TRepeater::setAlternatingItemRenderer()
    Sets the alternative item renderer class.
    setAlternatingItemTemplate | in file TRepeater.php, method TRepeater::setAlternatingItemTemplate()
    setAlternatingItemTemplate | in file TDataList.php, method TDataList::setAlternatingItemTemplate()
    setAnimationDuration | in file TAccordion.php, method TAccordion::setAnimationDuration()
    setAppendDataBoundItems | in file TListControl.php, method TListControl::setAppendDataBoundItems()
    setApplication in file PradoBase.php, method PradoBase::setApplication()
    Stores the application instance in the class static member.
    setApplicationStatePersister | in file TApplication.php, method TApplication::setApplicationStatePersister()
    setAssetManager | in file TApplication.php, method TApplication::setAssetManager()
    setAttribute in file TImageMap.php, method THotSpot::setAttribute()
    Sets a custom hotspot attribute.
    setAttribute | in file TXmlDocument.php, method TXmlElement::setAttribute()
    setAttribute | in file TListItem.php, method TListItem::setAttribute()
    setAttribute in file TControl.php, method TControl::setAttribute()
    Sets a custom control attribute.
    setAttribute in file TCallbackClientScript.php, method TCallbackClientScript::setAttribute()
    Sets the attribute of a particular control.
    setAttribute in file TDbConnection.php, method TDbConnection::setAttribute()
    Sets an attribute on the database connection.
    setAuthExpire | in file TAuthManager.php, method TAuthManager::setAuthExpire()
    setAutoCommit | in file TDbConnection.php, method TDbConnection::setAutoCommit()
    setAutoCompleteType | in file TTextBox.php, method TTextBox::setAutoCompleteType()
    setAutoCreateCacheTable | in file TDbCache.php, method TDbCache::setAutoCreateCacheTable()
    setAutoCreateLogTable | in file TLogRouter.php, method TDbLogRoute::setAutoCreateLogTable()
    setAutoGenerateColumns | in file TDataGrid.php, method TDataGrid::setAutoGenerateColumns()
    setAutoHide | in file TKeyboard.php, method TKeyboard::setAutoHide()
    setAutoHideTextBox | in file TInPlaceTextBox.php, method TInPlaceTextBox::setAutoHideTextBox()
    setAutoPostBack in file TTextBox.php, method TTextBox::setAutoPostBack()
    Sets the value indicating if postback automatically.
    setAutoPostBack | in file TBulletedList.php, method TBulletedList::setAutoPostBack()
    setAutoPostBack | in file TActiveFileUpload.php, method TActiveFileUpload::setAutoPostBack()
    setAutoPostBack in file TActiveDatePicker.php, method TActiveDatePicker::setAutoPostBack()
    Sets the value indicating if postback automatically.
    setAutoPostBack in file TSlider.php, method TSlider::setAutoPostBack()
    Sets the value indicating if postback automatically.
    setAutoPostBack in file TListControl.php, method TListControl::setAutoPostBack()
    Sets the value indicating if postback automatically.
    setAutoPostBack in file TCheckBox.php, method TCheckBox::setAutoPostBack()
    Sets a value indicating whether clicking on the checkbox will post the page.
    setAutoPostBack in file TDatePicker.php, method TDatePicker::setAutoPostBack()
    AutoPostBack is not supported.
    setAutoStart | in file THttpSession.php, method THttpSession::setAutoStart()
    setAutoSwitch | in file TTabPanel.php, method TTabPanel::setAutoSwitch()
    setAutoTrim in file TTextBox.php, method TTextBox::setAutoTrim()
    Sets the value indicating if the input text should be trimmed spaces
    setAutoUpdate in file TValidationSummary.php, method TValidationSummary::setAutoUpdate()
    Sets the summary to auto-update on the client-side
    setBackColor | in file TWebControl.php, method TWebControl::setBackColor()
    setBackColor | in file TStyle.php, method TStyle::setBackColor()
    setBackImageUrl in file TStyle.php, method TTableStyle::setBackImageUrl()
    Sets the URL of the background image for the table
    setBackImageUrl | in file TDataGrid.php, method TDataGrid::setBackImageUrl()
    setBackImageUrl in file TPanelStyle.php, method TPanelStyle::setBackImageUrl()
    Sets the URL of the background image for the panel component.
    setBackImageUrl in file TTable.php, method TTable::setBackImageUrl()
    Sets the URL of the background image for the table
    setBackImageUrl in file TPanel.php, method TPanel::setBackImageUrl()
    Sets the URL of the background image for the panel component.
    setBaseActiveControl | in file TActiveControlAdapter.php, method TActiveControlAdapter::setBaseActiveControl()
    setBaseControlClass | in file TActiveControlAdapter.php, method TActiveControlAdapter::setBaseControlClass()
    setBasePageClass in file TPageService.php, method TPageService::setBasePageClass()
    Sets the base page class name (in namespace format).
    setBasePath | in file TThemeManager.php, method TTheme::setBasePath()
    setBasePath | in file TThemeManager.php, method TThemeManager::setBasePath()
    setBasePath in file TAssetManager.php, method TAssetManager::setBasePath()
    Sets the root directory storing published asset files.
    setBasePath | in file TPageService.php, method TPageService::setBasePath()
    setBasePath | in file TApplication.php, method TApplication::setBasePath()
    setBaseUrl | in file TThemeManager.php, method TThemeManager::setBaseUrl()
    setBaseUrl | in file THead.php, method THead::setBaseUrl()
    setBaseUrl | in file TAssetManager.php, method TAssetManager::setBaseUrl()
    setBaseUrl | in file TThemeManager.php, method TTheme::setBaseUrl()
    setBold | in file TFont.php, method TFont::setBold()
    setBorderCollapse | in file TStyle.php, method TTableStyle::setBorderCollapse()
    setBorderColor | in file TStyle.php, method TStyle::setBorderColor()
    setBorderColor | in file TWebControl.php, method TWebControl::setBorderColor()
    setBorderStyle | in file TWebControl.php, method TWebControl::setBorderStyle()
    setBorderStyle in file TStyle.php, method TStyle::setBorderStyle()
    Sets the border style of the control.
    setBorderWidth | in file TStyle.php, method TStyle::setBorderWidth()
    setBorderWidth | in file TWebControl.php, method TWebControl::setBorderWidth()
    setBottom | in file TImageMap.php, method TRectangleHotSpot::setBottom()
    setBoundary | in file TCallbackResponseAdapter.php, method TCallbackResponseWriter::setBoundary()
    setBufferOutput | in file THttpResponse.php, method THttpResponse::setBufferOutput()
    setBulletImageUrl | in file TBulletedList.php, method TBulletedList::setBulletImageUrl()
    setBulletStyle | in file TBulletedList.php, method TBulletedList::setBulletStyle()
    setButtonImageUrl | in file TDatePicker.php, method TDatePicker::setButtonImageUrl()
    setButtonText | in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::setButtonText()
    setButtonText | in file TDatePicker.php, method TDatePicker::setButtonText()
    setButtonType | in file TEditCommandColumn.php, method TEditCommandColumn::setButtonType()
    setButtonType | in file TButton.php, method TButton::setButtonType()
    setButtonType | in file TButtonColumn.php, method TButtonColumn::setButtonType()
    setButtonType | in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::setButtonType()
    setButtonType | in file TPager.php, method TPager::setButtonType()
    setButtonType | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setButtonType()
    setCache | in file TActiveRecordManager.php, method TActiveRecordManager::setCache()
    setCache | in file TApplication.php, method TApplication::setCache()
    setCache | in file TSqlMapStatement.php, method TSqlMapStatement::setCache()
    setCacheControl | in file THttpResponse.php, method THttpResponse::setCacheControl()
    setCacheExpire | in file THttpResponse.php, method THttpResponse::setCacheExpire()
    setCacheKey | in file TOutputCache.php, method TOutputCacheCalculateKeyEventParameter::setCacheKey()
    setCacheKeyPrefix in file TOutputCache.php, method TOutputCache::setCacheKeyPrefix()
    Sets the prefix of the cache key.
    setCacheModel | in file TSqlMapStatement.php, method TSqlMapStatement::setCacheModel()
    setCacheModuleID | in file TOutputCache.php, method TOutputCache::setCacheModuleID()
    setCacheModuleID | in file TCachePageStatePersister.php, method TCachePageStatePersister::setCacheModuleID()
    setCacheModuleID | in file TCacheHttpSession.php, method TCacheHttpSession::setCacheModuleID()
    setCacheSize in file TSqlMapCache.php, method TSqlMapCache::setCacheSize()
    Maximum number of items to cache. Default size is 100.
    setCacheTableName in file TDbCache.php, method TDbCache::setCacheTableName()
    Sets the name of the DB table to store cache content.
    setCacheTime | in file TOutputCache.php, method TOutputCacheCheckDependencyEventParameter::setCacheTime()
    setCacheTimeout | in file TCachePageStatePersister.php, method TCachePageStatePersister::setCacheTimeout()
    setCachingPostBack in file TOutputCache.php, method TOutputCache::setCachingPostBack()
    Sets a value indicating whether cached output will be used on postback requests.
    setCalendarStyle | in file TDatePicker.php, method TDatePicker::setCalendarStyle()
    setCallbackClient in file TPage.php, method TPage::setCallbackClient()
    Set a new callback client handler.
    setCallbackEventParameter | in file TActivePageAdapter.php, method TActivePageAdapter::setCallbackEventParameter()
    setCallbackEventParameter | in file TPage.php, method TPage::setCallbackEventParameter()
    setCallbackEventTarget in file TPage.php, method TPage::setCallbackEventTarget()
    Registers a control to raise callback event in the current request.
    setCallbackEventTarget in file TActivePageAdapter.php, method TActivePageAdapter::setCallbackEventTarget()
    Registers a control to raise callback event in the current request.
    setCallbackOptions in file TBaseActiveControl.php, method TBaseActiveCallbackControl::setCallbackOptions()
    Sets default callback options. Takes the ID of a TCallbackOptions component to duplicate the client-side options for this control. The getClientSide subproperties takes precedence over the CallbackOptions property.
    setCallbackParameter | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::setCallbackParameter()
    setCancelButton | in file TWizard.php, method TWizardNavigationContainer::setCancelButton()
    setCancelButtonText | in file TColorPicker.php, method TColorPicker::setCancelButtonText()
    setCancelDestinationUrl | in file TWizard.php, method TWizard::setCancelDestinationUrl()
    setCancelImageUrl | in file TEditCommandColumn.php, method TEditCommandColumn::setCancelImageUrl()
    setCancelNavigation | in file TWizard.php, method TWizardNavigationEventParameter::setCancelNavigation()
    setCancelText | in file TEditCommandColumn.php, method TEditCommandColumn::setCancelText()
    setCaptchaControl in file TCaptchaValidator.php, method TCaptchaValidator::setCaptchaControl()
    Sets the ID path of the CAPTCHA control to validate.
    setCaption | in file TRatingList.php, method TRatingList::setCaption()
    setCaption | in file TDataList.php, method TDataList::setCaption()
    setCaption | in file TAccordion.php, method TAccordionView::setCaption()
    setCaption | in file TTabPanel.php, method TTabView::setCaption()
    setCaption | in file TActiveRatingList.php, method TActiveRatingList::setCaption()
    setCaption | in file TDataGrid.php, method TDataGrid::setCaption()
    setCaption | in file TRepeatInfo.php, method TRepeatInfo::setCaption()
    setCaption | in file TTable.php, method TTable::setCaption()
    setCaptionAlign | in file TDataGrid.php, method TDataGrid::setCaptionAlign()
    setCaptionAlign | in file TTable.php, method TTable::setCaptionAlign()
    setCaptionAlign | in file TRepeatInfo.php, method TRepeatInfo::setCaptionAlign()
    setCaptionAlign | in file TDataList.php, method TDataList::setCaptionAlign()
    setCaptionID | in file TRatingList.php, method TRatingList::setCaptionID()
    setCaseSensitive | in file TUrlMapping.php, method TUrlMappingPattern::setCaseSensitive()
    setCaseSensitive | in file TAttributeCollection.php, method TAttributeCollection::setCaseSensitive()
    setCaseSensitive | in file TCaptcha.php, method TCaptcha::setCaseSensitive()
    setCatalogue in file TTranslate.php, method TTranslate::setCatalogue()
    Set the message catalogue.
    setCategories | in file TLogRouter.php, method TLogRoute::setCategories()
    setCategoryText | in file TTableHeaderCell.php, method TTableHeaderCell::setCategoryText()
    setCausesValidation | in file TTextBox.php, method TTextBox::setCausesValidation()
    setCausesValidation | in file TImageMap.php, method THotSpot::setCausesValidation()
    setCausesValidation in file TLinkButton.php, method TLinkButton::setCausesValidation()
    Sets the value indicating whether postback event trigger by this button will cause input validation.
    setCausesValidation in file TCheckBox.php, method TCheckBox::setCausesValidation()
    Sets the value indicating whether postback event trigger by this checkbox will cause input validation.
    setCausesValidation | in file TButton.php, method TButton::setCausesValidation()
    setCausesValidation | in file TImageButton.php, method TImageButton::setCausesValidation()
    setCausesValidation | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::setCausesValidation()
    setCausesValidation | in file TButtonColumn.php, method TButtonColumn::setCausesValidation()
    setCausesValidation | in file TListControl.php, method TListControl::setCausesValidation()
    setCausesValidation | in file TControl.php, method IButtonControl::setCausesValidation()
    setCausesValidation | in file TEditCommandColumn.php, method TEditCommandColumn::setCausesValidation()
    setCellPadding | in file TBaseDataList.php, method TBaseDataList::setCellPadding()
    setCellPadding | in file TStyle.php, method TTableStyle::setCellPadding()
    setCellPadding in file TCheckBoxList.php, method TCheckBoxList::setCellPadding()
    Sets the cellpadding for the table keeping the checkbox list.
    setCellPadding | in file TTable.php, method TTable::setCellPadding()
    setCellSpacing in file TCheckBoxList.php, method TCheckBoxList::setCellSpacing()
    Sets the cellspacing for the table keeping the checkbox list.
    setCellSpacing | in file TStyle.php, method TTableStyle::setCellSpacing()
    setCellSpacing | in file TTable.php, method TTable::setCellSpacing()
    setCellSpacing | in file TBaseDataList.php, method TBaseDataList::setCellSpacing()
    setCgiFix in file THttpRequest.php, method THttpRequest::setCgiFix()
    Enable this, if you're using PHP via CGI with php.ini setting "cgi.fix_pathinfo=1"
    setChangingTokenBackground | in file TCaptcha.php, method TCaptcha::setChangingTokenBackground()
    setCharset | in file TDbConnection.php, method TDbConnection::setCharset()
    setCharset in file TI18NControl.php, method TI18NControl::setCharset()
    Sets the charset for message output
    setCharset | in file TRangeValidator.php, method TRangeValidator::setCharset()
    setCharset | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::setCharset()
    setCharset | in file THttpResponse.php, method THttpResponse::setCharset()
    setCharset | in file TGlobalization.php, method TGlobalization::setCharset()
    setChecked in file TCheckBox.php, method TCheckBox::setChecked()
    Sets a value indicating whether the checkbox is to be checked or not.
    setChecked in file TActiveRadioButton.php, method TActiveRadioButton::setChecked()
    Checks the radio button.
    setChecked in file TActiveCheckBox.php, method TActiveCheckBox::setChecked()
    Sets a value indicating whether the checkbox is to be checked or not.
    setCheckMXRecord | in file TEmailAddressValidator.php, method TEmailAddressValidator::setCheckMXRecord()
    setChildControlsCreated in file TControl.php, method TControl::setChildControlsCreated()
    Sets a value indicating whether child controls are created.
    setClass | in file TResultMap.php, method TResultMap::setClass()
    setClassMaps | in file TSoapService.php, method TSoapServer::setClassMaps()
    setClientScriptManagerClass in file TPageService.php, method TPageService::setClientScriptManagerClass()
    Sets the clientscript manager class (in namespace format).
    setClientSide in file TBaseActiveControl.php, method TBaseActiveCallbackControl::setClientSide()
    Sets the client side options. Can only be set when client side is null.
    setClientSidePatternModifiers | in file TRegularExpressionValidator.php, method TRegularExpressionValidator::setClientSidePatternModifiers()
    setClientState in file TPage.php, method TPage::setClientState()
    Sets the state to be stored on the client side.
    setClientSupportsJavaScript | in file TPage.php, method TPage::setClientSupportsJavaScript()
    setClientValidationFunction in file TActiveCustomValidator.php, method TActiveCustomValidator::setClientValidationFunction()
    Client validation function is NOT supported.
    setClientValidationFunction in file TCustomValidator.php, method TCustomValidator::setClientValidationFunction()
    Sets the name of the custom client-side script function used for validation.
    setColorPickerStyle | in file TColorPicker.php, method TColorPicker::setColorPickerStyle()
    setColumn | in file TResultProperty.php, method TResultProperty::setColumn()
    setColumn | in file TParameterProperty.php, method TParameterProperty::setColumn()
    setColumn | in file TDiscriminator.php, method TDiscriminator::setColumn()
    setColumnCase | in file TDbConnection.php, method TDbConnection::setColumnCase()
    setColumnIndex | in file TResultProperty.php, method TResultProperty::setColumnIndex()
    setColumnIndex in file TDiscriminator.php, method TDiscriminator::setColumnIndex()
    The columnIndex attribute value is the index of the column in the ResultSet from which the value will be used to populate the object property.
    setColumns in file TTextBox.php, method TTextBox::setColumns()
    Sets the display width of the text box in characters.
    setColumnSpan in file TTableCell.php, method TTableCell::setColumnSpan()
    Sets the columnspan for the table cell.
    setColumnValue in file TActiveRecord.php, method TActiveRecord::setColumnValue()
    Sets the column value according to column name.
    setCommandName in file TButtonColumn.php, method TButtonColumn::setCommandName()
    Sets the command name associated with the Command event.
    setCommandName | in file TLinkButton.php, method TLinkButton::setCommandName()
    setCommandName | in file TImageButton.php, method TImageButton::setCommandName()
    setCommandName | in file TControl.php, method IButtonControl::setCommandName()
    setCommandName | in file TButton.php, method TButton::setCommandName()
    setCommandParameter | in file TControl.php, method IButtonControl::setCommandParameter()
    setCommandParameter | in file TLinkButton.php, method TLinkButton::setCommandParameter()
    setCommandParameter | in file TImageButton.php, method TImageButton::setCommandParameter()
    setCommandParameter | in file TButton.php, method TButton::setCommandParameter()
    setCompleteButton | in file TWizard.php, method TWizardNavigationContainer::setCompleteButton()
    setCondition in file TSqlCriteria.php, method TSqlCriteria::setCondition()
    Sets the search conditions to be placed after the WHERE clause in the SQL.
    setCondition in file TConditional.php, method TConditional::setCondition()
    Sets the PHP expression to be evaluated for conditionally displaying content.
    setConfigFile | in file TUrlMapping.php, method TUrlMapping::setConfigFile()
    setConfigFile | in file TSoapService.php, method TSoapService::setConfigFile()
    setConfigFile | in file TLogRouter.php, method TLogRouter::setConfigFile()
    setConfigFile | in file TSqlMapConfig.php, method TSqlMapConfig::setConfigFile()
    setConfigurationFile | in file TApplication.php, method TApplication::setConfigurationFile()
    setConfigurationType | in file TApplication.php, method TApplication::setConfigurationType()
    setConnectionCharset | in file TDbConnection.php, method TDbConnection::setConnectionCharset()
    setConnectionClass in file TDataSourceConfig.php, method TDataSourceConfig::setConnectionClass()
    The database connection class name to be created when getDbConnection
    setConnectionID in file TDbUserManager.php, method TDbUserManager::setConnectionID()
    Sets the ID of a TDataSourceConfig module.
    setConnectionID in file TLogRouter.php, method TDbLogRoute::setConnectionID()
    Sets the ID of a TDataSourceConfig module.
    setConnectionID in file TDbCache.php, method TDbCache::setConnectionID()
    Sets the ID of a TDataSourceConfig module.
    setConnectionID in file TDataSourceConfig.php, method TDataSourceConfig::setConnectionID()
    The module ID of another TDataSourceConfig. The getDbConnection property of this configuration will equal to getDbConnection of the given TDataSourceConfig module.
    setConnectionString | in file TDbCache.php, method TDbCache::setConnectionString()
    setConnectionString | in file TDbConnection.php, method TDbConnection::setConnectionString()
    setConstraint in file TDraggable.php, method TDraggable::setConstraint()
    Set wether the element should be constrainted in one direction
    setContainer | in file TControl.php, method TCompositeLiteral::setContainer()
    setContent | in file THead.php, method TMetaTag::setContent()
    setContentTemplate | in file TWizard.php, method TTemplatedWizardStep::setContentTemplate()
    setContentType | in file THttpResponse.php, method THttpResponse::setContentType()
    setContinueBuffering | in file TFlushOutput.php, method TFlushOutput::setContinueBuffering()
    setControl | in file TActiveListControlAdapter.php, method TActiveListItemCollection::setControl()
    setControlCssClass | in file TBaseValidator.php, method TBaseValidator::setControlCssClass()
    setControlID | in file TTriggeredCallback.php, method TTriggeredCallback::setControlID()
    setControlStage in file TControl.php, method TControl::setControlStage()
    Sets the lifecycle step the control is currently at.
    setControlState in file TControl.php, method TControl::setControlState()
    Sets a controlstate value.
    setControlToCompare in file TCompareValidator.php, method TCompareValidator::setControlToCompare()
    Sets the input component to compare with the input control being validated.
    setControlToPaginate in file TPager.php, method TPager::setControlToPaginate()
    Sets the ID path of the control whose content would be paginated.
    setControlToValidate in file TBaseValidator.php, method TBaseValidator::setControlToValidate()
    Sets the ID path of the input control to validate.
    setCookieMode | in file THttpSession.php, method THttpSession::setCookieMode()
    setCoordinates | in file TImageMap.php, method TPolygonHotSpot::setCoordinates()
    setCssClass | in file TWebControl.php, method TWebControl::setCssClass()
    setCssClass | in file TStyle.php, method TStyle::setCssClass()
    setCssClass | in file TLogRouter.php, method TBrowserLogRoute::setCssClass()
    setCssUrl | in file TKeyboard.php, method TKeyboard::setCssUrl()
    setCssUrl | in file TAccordion.php, method TAccordion::setCssUrl()
    setCssUrl | in file TTabPanel.php, method TTabPanel::setCssUrl()
    setCssUrl | in file TSlider.php, method TSlider::setCssUrl()
    setCulture in file THtmlArea.php, method THtmlArea::setCulture()
    Sets the culture/language for the html area
    setCulture | in file TGlobalization.php, method TGlobalization::setCulture()
    setCulture in file TI18NControl.php, method TI18NControl::setCulture()
    Get the custom culture identifier.
    setCulture in file TDatePicker.php, method TDatePicker::setCulture()
    Sets the culture/language for the date picker.
    setCurrency in file TNumberFormat.php, method TNumberFormat::setCurrency()
    Set the 3-letter ISO 4217 code. For example, the code "USD" represents the US Dollar and "EUR" represents the Euro currency.
    setCurrentPageIndex | in file TPagedDataSource.php, method TPagedDataSource::setCurrentPageIndex()
    setCurrentPageIndex | in file TPager.php, method TPager::setCurrentPageIndex()
    setCurrentPageIndex | in file TPagedList.php, method TPagedList::setCurrentPageIndex()
    setCurrentPageIndex | in file TDataBoundControl.php, method TDataBoundControl::setCurrentPageIndex()
    setCustomData in file TControl.php, method TControl::setCustomData()
    Associates custom data with this control.
    setCustomPaging | in file TPagedList.php, method TPagedList::setCustomPaging()
    setCustomPaging | in file TSqlMapPagedList.php, method TSqlMapPagedList::setCustomPaging()
    setCustomPluginPath | in file THtmlArea.php, method THtmlArea::setCustomPluginPath()
    setCustomStyle in file TStyle.php, method TStyle::setCustomStyle()
    Sets custom style fields from a string.
    setCustomTranslations | in file TReCaptcha.php, method TReCaptcha::setCustomTranslations()
    setData | in file TDataRenderer.php, method TDataRenderer::setData()
    setData in file TTextBox.php, method TTextBox::setData()
    Sets the text content of the TTextBox control.
    setData in file TTableCell.php, method TTableCell::setData()
    Sets the text content of the table cell.
    setData in file TDatePicker.php, method TDatePicker::setData()
    Sets the timestamp represented by this control.
    setData in file TLiteral.php, method TLiteral::setData()
    Sets the static text of the TLiteral.
    setData | in file interfaces.php, method IDataRenderer::setData()
    setData in file TLabel.php, method TLabel::setData()
    Sets the text value of the label.
    setData in file TLinkButton.php, method TLinkButton::setData()
    Sets the caption of the button.
    setData in file TListControl.php, method TListControl::setData()
    Selects an item by the specified value.
    setData in file THyperLink.php, method THyperLink::setData()
    Sets the URL to link to when the THyperLink component is clicked.
    setData | in file TDataList.php, method TDataListItem::setData()
    setData in file TDateFormat.php, method TDateFormat::setData()
    Set the date-time value for this control.
    setData | in file TDataGrid.php, method TDataGridItem::setData()
    setData in file TInlineFrame.php, method TInlineFrame::setData()
    Sets the URL that this iframe will load content from.
    setData | in file TRepeater.php, method TRepeaterItem::setData()
    setData in file TCheckBox.php, method TCheckBox::setData()
    Sets the value indicating whether the checkbox is to be checked or not.
    setData in file TButton.php, method TButton::setData()
    Sets the caption of the button.
    setData in file TImage.php, method TImage::setData()
    Sets the URL of the image.
    setData in file TSlider.php, method TSlider::setData()
    Sets the value of the TSlider control.
    setData | in file TPagedList.php, method TPagedListFetchDataEventParameter::setData()
    setData in file TNumberFormat.php, method TNumberFormat::setData()
    Set the numberic value for this control.
    setData in file THiddenField.php, method THiddenField::setData()
    Sets the value of the hidden field.
    setDataField | in file TBoundColumn.php, method TBoundColumn::setDataField()
    setDataField | in file TLiteralColumn.php, method TLiteralColumn::setDataField()
    setDataField | in file TCheckBoxColumn.php, method TCheckBoxColumn::setDataField()
    setDataFormatString | in file TLiteralColumn.php, method TLiteralColumn::setDataFormatString()
    setDataFormatString | in file TBoundColumn.php, method TBoundColumn::setDataFormatString()
    setDataGroupField | in file TListControl.php, method TListControl::setDataGroupField()
    setDataImageUrlField | in file TButtonColumn.php, method TButtonColumn::setDataImageUrlField()
    setDataImageUrlFormatString | in file TButtonColumn.php, method TButtonColumn::setDataImageUrlFormatString()
    setDataItem in file TRepeater.php, method TRepeaterItem::setDataItem()
    This property is deprecated since v3.1.0.
    setDataItem in file TDataGrid.php, method TDataGridItem::setDataItem()
    This property is deprecated since v3.1.0.
    setDataItem in file TDataList.php, method TDataListItem::setDataItem()
    This property is deprecated since v3.1.0.
    setDataKeyField | in file TRepeater.php, method TRepeater::setDataKeyField()
    setDataKeyField | in file TBaseDataList.php, method TBaseDataList::setDataKeyField()
    setDataMember | in file TDataBoundControl.php, method TDataBoundControl::setDataMember()
    setDataNavigateUrlField | in file THyperLinkColumn.php, method THyperLinkColumn::setDataNavigateUrlField()
    setDataNavigateUrlFormatString | in file THyperLinkColumn.php, method THyperLinkColumn::setDataNavigateUrlFormatString()
    setDataSource in file TDataBoundControl.php, method TDataBoundControl::setDataSource()
    Sets the data source object associated with the databound control.
    setDataSource | in file TPagedDataSource.php, method TPagedDataSource::setDataSource()
    setDataSource in file TActiveDataGrid.php, method TActiveDataGrid::setDataSource()
    Sets the data source object associated with the datagrid control.
    setDataSource in file TActiveRepeater.php, method TActiveRepeater::setDataSource()
    Sets the data source object associated with the repeater control.
    setDataSource | in file TAutoComplete.php, method TAutoComplete::setDataSource()
    setDataSource in file TActiveDataList.php, method TActiveDataList::setDataSource()
    Sets the data source object associated with the repeater control.
    setDataSourceID | in file TDataBoundControl.php, method TDataBoundControl::setDataSourceID()
    setDataTextField | in file TButtonColumn.php, method TButtonColumn::setDataTextField()
    setDataTextField in file TDropDownListColumn.php, method TDropDownListColumn::setDataTextField()
    Sets the field of the data source that provides the text content of the column.
    setDataTextField | in file THyperLinkColumn.php, method THyperLinkColumn::setDataTextField()
    setDataTextField | in file TListControl.php, method TListControl::setDataTextField()
    setDataTextFormatString | in file TDropDownListColumn.php, method TDropDownListColumn::setDataTextFormatString()
    setDataTextFormatString | in file TButtonColumn.php, method TButtonColumn::setDataTextFormatString()
    setDataTextFormatString in file TListControl.php, method TListControl::setDataTextFormatString()
    Sets data text format string.
    setDataTextFormatString | in file THyperLinkColumn.php, method THyperLinkColumn::setDataTextFormatString()
    setDataType in file TRangeValidator.php, method TRangeValidator::setDataType()
    Sets the data type that the values being compared are converted to before the comparison is made.
    setDataType in file TCompareValidator.php, method TCompareValidator::setDataType()
    Sets the data type that the values being compared are converted to before the comparison is made.
    setDataType in file TDataTypeValidator.php, method TDataTypeValidator::setDataType()
    Sets the data type that the values being compared are converted to before the comparison is made.
    setDataValueField in file TDropDownListColumn.php, method TDropDownListColumn::setDataValueField()
    Sets the field of the data source that provides the key selecting an item in dropdown list.
    setDataValueField | in file TListControl.php, method TListControl::setDataValueField()
    setDate | in file TDatePicker.php, method TDatePicker::setDate()
    setDateFormat in file TDataTypeValidator.php, method TDataTypeValidator::setDateFormat()
    Sets the date format for a date validation
    setDateFormat in file TDatePicker.php, method TDatePicker::setDateFormat()
    Sets the format of the date string.
    setDateFormat in file TCompareValidator.php, method TCompareValidator::setDateFormat()
    Sets the date format for a date validation
    setDateFormat in file TRangeValidator.php, method TRangeValidator::setDateFormat()
    Sets the date format for a date validation
    setDbConnection | in file TSqlMapManager.php, method TSqlMapManager::setDbConnection()
    setDbConnection | in file TActiveRecord.php, method TActiveRecord::setDbConnection()
    setDbConnection | in file TActiveRecordManager.php, method TActiveRecordManager::setDbConnection()
    setDbConnection | in file TDbCommandBuilder.php, method TDbCommandBuilder::setDbConnection()
    setDbFile | in file TSqliteCache.php, method TSqliteCache::setDbFile()
    setDbType | in file TParameterProperty.php, method TParameterProperty::setDbType()
    setDbType | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::setDbType()
    setDecayRate in file TValueTriggeredCallback.php, method TValueTriggeredCallback::setDecayRate()
    Sets the decay rate between callback. Default is 0;
    setDefaultButton in file TForm.php, method TForm::setDefaultButton()
    Sets a button to be default one in a form.
    setDefaultButton in file TPanel.php, method TPanel::setDefaultButton()
    Specifies the default button for the panel.
    setDefaultCharset | in file TGlobalization.php, method TGlobalization::setDefaultCharset()
    setDefaultCulture | in file TGlobalization.php, method TGlobalization::setDefaultCulture()
    setDefaultMappingClass in file TUrlMapping.php, method TUrlMapping::setDefaultMappingClass()
    Sets the default class of URL mapping patterns.
    setDefaultPage | in file TPageService.php, method TPageService::setDefaultPage()
    setDefaultPriority in file TPriorityMap.php, method TPriorityMap::setDefaultPriority()
    This must be called internally or when instantiated.
    setDefaultPriority in file TPriorityList.php, method TPriorityList::setDefaultPriority()
    This must be called internally or when instantiated.
    setDefaultProperty | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::setDefaultProperty()
    setDefaultSchema | in file TPgsqlMetaData.php, method TPgsqlMetaData::setDefaultSchema()
    setDefaultSchema | in file TOracleMetaData.php, method TOracleMetaData::setDefaultSchema()
    setDefaultStyle | in file TScaffoldBase.php, method TScaffoldBase::setDefaultStyle()
    setDefaultText in file TNumberFormat.php, method TNumberFormat::setDefaultText()
    Set the default text value for this control.
    setDefaultText in file TDateFormat.php, method TDateFormat::setDefaultText()
    Set the default text value for this control.
    setDescriptionUrl | in file TActiveImage.php, method TActiveImage::setDescriptionUrl()
    setDescriptionUrl | in file TInlineFrame.php, method TInlineFrame::setDescriptionUrl()
    setDescriptionUrl | in file TActiveImageButton.php, method TActiveImageButton::setDescriptionUrl()
    setDescriptionUrl | in file TImage.php, method TImage::setDescriptionUrl()
    setDirection | in file TPanel.php, method TPanel::setDirection()
    setDirection | in file TPanelStyle.php, method TPanelStyle::setDirection()
    setDirection | in file TSlider.php, method TSlider::setDirection()
    setDirectory | in file TCache.php, method TDirectoryCacheDependency::setDirectory()
    setDiscriminator | in file TResultMap.php, method TResultMap::setDiscriminator()
    setDisplay | in file TWebControl.php, method TWebControl::setDisplay()
    setDisplay | in file TBaseValidator.php, method TBaseValidator::setDisplay()
    setDisplay | in file TValidationSummary.php, method TValidationSummary::setDisplay()
    setDisplayMode | in file TBulletedList.php, method TBulletedList::setDisplayMode()
    setDisplayMode | in file TValidationSummary.php, method TValidationSummary::setDisplayMode()
    setDisplayStyle | in file TStyle.php, method TStyle::setDisplayStyle()
    setDisplayTextBox | in file TInPlaceTextBox.php, method TInPlaceTextBox::setDisplayTextBox()
    setDocumentContent | in file TXmlTransform.php, method TXmlTransform::setDocumentContent()
    setDocumentPath | in file TXmlTransform.php, method TXmlTransform::setDocumentPath()
    setDomain | in file THttpRequest.php, method THttpCookie::setDomain()
    setDuration | in file TOutputCache.php, method TOutputCache::setDuration()
    setEditImageUrl | in file TEditCommandColumn.php, method TEditCommandColumn::setEditImageUrl()
    setEditItemIndex in file TDataList.php, method TDataList::setEditItemIndex()
    Edits an item by its index in getItems.
    setEditItemIndex in file TDataGrid.php, method TDataGrid::setEditItemIndex()
    Edits an item by its index in getItems.
    setEditItemRenderer in file TBoundColumn.php, method TBoundColumn::setEditItemRenderer()
    Sets the edit item cell renderer class.
    setEditItemRenderer in file TDataList.php, method TDataList::setEditItemRenderer()
    Sets the renderer class for the datalist item being editted.
    setEditItemRenderer in file TTemplateColumn.php, method TTemplateColumn::setEditItemRenderer()
    Sets the edit item cell renderer class.
    setEditItemTemplate | in file TDataList.php, method TDataList::setEditItemTemplate()
    setEditItemTemplate | in file TTemplateColumn.php, method TTemplateColumn::setEditItemTemplate()
    setEditRenderer | in file TScaffoldEditView.php, method TScaffoldEditView::setEditRenderer()
    setEditText | in file TEditCommandColumn.php, method TEditCommandColumn::setEditText()
    setEditTriggerControlID | in file TInPlaceTextBox.php, method TInPlaceTextBox::setEditTriggerControlID()
    setEditViewID | in file TScaffoldListView.php, method TScaffoldListView::setEditViewID()
    setEmails | in file TLogRouter.php, method TEmailLogRoute::setEmails()
    setEmptyRenderer in file TDataList.php, method TDataList::setEmptyRenderer()
    Sets the datalist empty renderer class.
    setEmptyRenderer in file TRepeater.php, method TRepeater::setEmptyRenderer()
    Sets the repeater empty renderer class.
    setEmptyTemplate | in file TRepeater.php, method TRepeater::setEmptyTemplate()
    setEmptyTemplate | in file TDataList.php, method TDataList::setEmptyTemplate()
    setEmptyTemplate | in file TDataGrid.php, method TDataGrid::setEmptyTemplate()
    setEnableCache in file TSqlMapConfig.php, method TSqlMapConfig::setEnableCache()
    Set true to cache sqlmap instances.
    setEnableCache in file TActiveRecordConfig.php, method TActiveRecordConfig::setEnableCache()
    Set true to cache the table meta data.
    setEnableCellGrouping | in file TDataGridColumn.php, method TDataGridColumn::setEnableCellGrouping()
    setEnableClientScript | in file TImageButton.php, method TImageButton::setEnableClientScript()
    setEnableClientScript | in file TLinkButton.php, method TLinkButton::setEnableClientScript()
    setEnableClientScript | in file TListControl.php, method TListControl::setEnableClientScript()
    setEnableClientScript | in file TBaseValidator.php, method TBaseValidator::setEnableClientScript()
    setEnableClientScript | in file TRadioButton.php, method TRadioButton::setEnableClientScript()
    setEnableClientScript | in file TCheckBox.php, method TCheckBox::setEnableClientScript()
    setEnableClientScript | in file TButton.php, method TButton::setEnableClientScript()
    setEnableClientScript | in file TTextBox.php, method TTextBox::setEnableClientScript()
    setEnableClientScript | in file TValidationSummary.php, method TValidationSummary::setEnableClientScript()
    setEnableCompression | in file THtmlArea.php, method THtmlArea::setEnableCompression()
    setEnableCookieValidation | in file THttpRequest.php, method THttpRequest::setEnableCookieValidation()
    setEnableCopyCode | in file TTextHighlighter.php, method TTextHighlighter::setEnableCopyCode()
    setEnableCustomUrl in file TUrlMapping.php, method TUrlMappingPattern::setEnableCustomUrl()
    Sets a value indicating whether to enable custom constructUrl using this pattern
    setEnableCustomUrl in file TUrlMapping.php, method TUrlMapping::setEnableCustomUrl()
    Sets a value indicating whether to enable custom constructUrl.
    setEnabled | in file TListItem.php, method TListItem::setEnabled()
    setEnabled in file TRatingList.php, method TRatingList::setEnabled()
    Wrapper for setReadOnly property.
    setEnabled | in file TControl.php, method TControl::setEnabled()
    setEnabled | in file TCheckBoxList.php, method TCheckBoxList::setEnabled()
    setEnabled | in file interfaces.php, method IService::setEnabled()
    setEnabled | in file TService.php, method TService::setEnabled()
    setEnabled in file TBaseValidator.php, method TBaseValidator::setEnabled()
    This method overrides parent's implementation by setting setIsValid to true if disabled.
    setEnableDefaultStyle | in file TScaffoldBase.php, method TScaffoldBase::setEnableDefaultStyle()
    setEnablePageStateUpdate in file TCallbackClientSide.php, method TCallbackClientSide::setEnablePageStateUpdate()
    Set to true to enable the callback response to enable the viewstate update. This will automatically set HasPrority to true.
    setEnableStateCompression | in file TPage.php, method TPage::setEnableStateCompression()
    setEnableStateEncryption | in file TPage.php, method TPage::setEnableStateEncryption()
    setEnableStateValidation | in file TPage.php, method TPage::setEnableStateValidation()
    setEnableTheming | in file TControl.php, method TControl::setEnableTheming()
    setEnableTheming | in file THiddenField.php, method THiddenField::setEnableTheming()
    setEnableTheming | in file TDataSourceControl.php, method TDataSourceControl::setEnableTheming()
    setEnableUpdate | in file TBaseActiveControl.php, method TBaseActiveControl::setEnableUpdate()
    setEnableViewState | in file TControl.php, method TControl::setEnableViewState()
    setEnableVisualEdit in file THtmlArea.php, method THtmlArea::setEnableVisualEdit()
    Sets whether to show WYSIWYG text editor.
    setEncode | in file TLiteral.php, method TLiteral::setEncode()
    setEncode | in file TLiteralColumn.php, method TLiteralColumn::setEncode()
    setEncoding | in file TSoapService.php, method TSoapServer::setEncoding()
    setEncoding | in file TXmlDocument.php, method TXmlDocument::setEncoding()
    setEncryption | in file TSecurityManager.php, method TSecurityManager::setEncryption()
    setEncryptionKey | in file TSecurityManager.php, method TSecurityManager::setEncryptionKey()
    setEnctype | in file TForm.php, method TForm::setEnctype()
    setEnsureId in file TWebControl.php, method TWebControl::setEnsureId()
    Subclasses can override getEnsureId or just set this property. eg. If your subclass control does work with javascript and your class wants to flag that it requires an id to operate properly. Once set to true, it stays that way.
    setErrorCode | in file TException.php, method TException::setErrorCode()
    setErrorHandler | in file TApplication.php, method TApplication::setErrorHandler()
    setErrorMessage | in file TControl.php, method IValidator::setErrorMessage()
    setErrorMessage in file TBaseValidator.php, method TBaseValidator::setErrorMessage()
    Sets the text for the error message.
    setErrorMessage | in file TException.php, method TException::setErrorMessage()
    setErrorMessage in file TActiveCustomValidator.php, method TActiveCustomValidator::setErrorMessage()
    Sets the text for the error message. Updates client-side erorr message.
    setErrorTemplatePath in file TErrorHandler.php, method TErrorHandler::setErrorTemplatePath()
    Sets the path storing all error and exception template files.
    setEventName in file TEventTriggeredCallback.php, method TEventTriggeredCallback::setEventName()
    Sets the client-side event name that fires the callback request.
    setExpire | in file THttpRequest.php, method THttpCookie::setExpire()
    setExpression | in file TExpression.php, method TExpression::setExpression()
    setExtends | in file TParameterMap.php, method TParameterMap::setExtends()
    setExtends | in file TSqlMapStatement.php, method TSqlMapStatement::setExtends()
    setExtends | in file TSqlMapStatement.php, method TSqlMapSelectKey::setExtends()
    setExtends | in file TResultMap.php, method TResultMap::setExtends()
    setFalseTemplate | in file TConditional.php, method TConditional::setFalseTemplate()
    setFetchMode | in file TDbDataReader.php, method TDbDataReader::setFetchMode()
    setFileName | in file TCache.php, method TFileCacheDependency::setFileName()
    setFinishDestinationUrl | in file TWizard.php, method TWizard::setFinishDestinationUrl()
    setFinishNavigationTemplate | in file TWizard.php, method TWizard::setFinishNavigationTemplate()
    setFirstBulletNumber | in file TBulletedList.php, method TBulletedList::setFirstBulletNumber()
    setFirstDayOfWeek in file TDatePicker.php, method TDatePicker::setFirstDayOfWeek()
    Set the first day of week, with 0 as Sunday, 1 as Monday, etc.
    setFirstPageImageUrl | in file TPager.php, method TPager::setFirstPageImageUrl()
    setFirstPageText | in file TPager.php, method TPager::setFirstPageText()
    setFirstPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setFirstPageText()
    setFlushInterval in file TDbCache.php, method TDbCache::setFlushInterval()
    Sets interval expired items will be removed from cache
    setFlushInterval | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::setFlushInterval()
    setFlushScriptFiles | in file TClientScript.php, method TClientScript::setFlushScriptFiles()
    setFocus in file TPage.php, method TPage::setFocus()
    Sets input focus on a control after the page is rendered to users.
    setFocusElementID in file TBaseValidator.php, method TBaseValidator::setFocusElementID()
    Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
    setFocusOnError | in file TBaseValidator.php, method TBaseValidator::setFocusOnError()
    setFooterRenderer in file TDataList.php, method TDataList::setFooterRenderer()
    Sets the datalist footer renderer class.
    setFooterRenderer in file TRepeater.php, method TRepeater::setFooterRenderer()
    Sets the repeater footer renderer class.
    setFooterRenderer in file TDataGridColumn.php, method TDataGridColumn::setFooterRenderer()
    Sets the column footer cell renderer class.
    setFooterTemplate | in file TRepeater.php, method TRepeater::setFooterTemplate()
    setFooterTemplate | in file TDataList.php, method TDataList::setFooterTemplate()
    setFooterTemplate | in file TTemplateColumn.php, method TTemplateColumn::setFooterTemplate()
    setFooterText | in file TDataGridColumn.php, method TDataGridColumn::setFooterText()
    setForControl in file TActiveLabel.php, method TActiveLabel::setForControl()
    Sets the ID of the control that the label is associated with.
    setForControl in file TBaseValidator.php, method TBaseValidator::setForControl()
    This method overrides the parent implementation to forbid setting ForControl.
    setForControl in file TKeyboard.php, method TKeyboard::setForControl()
    Sets the ID path of the TTextBox control.
    setForControl in file TLabel.php, method TLabel::setForControl()
    Sets the ID of the control that the label is associated with.
    setForeColor | in file TWebControl.php, method TWebControl::setForeColor()
    setForeColor | in file TStyle.php, method TStyle::setForeColor()
    setForm in file TPage.php, method TPage::setForm()
    Registers a TForm instance to the page.
    setFrameUrl | in file TInlineFrame.php, method TInlineFrame::setFrameUrl()
    setFrequency | in file TAutoComplete.php, method TAutoComplete::setFrequency()
    setFromYear | in file TDatePicker.php, method TDatePicker::setFromYear()
    setFunction in file TClientScriptManager.php, method TClientSideOptions::setFunction()
    Adds on client-side event handler by wrapping the code within a javascript function block. If the code begins with "javascript:", the code is assumed to be a javascript function block rather than arbiturary javascript statements.
    setGatewayClass in file TActiveRecordManager.php, method TActiveRecordManager::setGatewayClass()
    Set implementation class of ActiveRecordGateway
    setGatewayClass in file TActiveRecordConfig.php, method TActiveRecordConfig::setGatewayClass()
    Set implementation class of ActiveRecordGateway
    setGCProbability | in file THttpSession.php, method THttpSession::setGCProbability()
    setGenerate | in file TSqlMapStatement.php, method TSqlMapSelect::setGenerate()
    setGhosting in file TDraggable.php, method TDraggable::setGhosting()
    Sets wether the element should be cloned when dragged If true, Clones the element and drags the clone, leaving the original in place until the clone is dropped.
    setGlobalization | in file TApplication.php, method TApplication::setGlobalization()
    setGlobalState in file TApplication.php, method TApplication::setGlobalState()
    Sets a global value.
    setGridLines in file TStyle.php, method TTableStyle::setGridLines()
    Sets the grid line style of the table.
    setGridLines | in file TTable.php, method TTable::setGridLines()
    setGridLines in file TBaseDataList.php, method TBaseDataList::setGridLines()
    Sets the grid line style of the table layout.
    setGroupBy | in file TResultMap.php, method TResultMap::setGroupBy()
    setGroupingText | in file TPanel.php, method TPanel::setGroupingText()
    setGroupLabel | in file TLogRouter.php, method TFirePhpLogRoute::setGroupLabel()
    setGroupName in file TRadioButton.php, method TRadioButton::setGroupName()
    Sets the name of the group that the radio button belongs to.
    setGuestName | in file TDbUserManager.php, method TDbUserManager::setGuestName()
    setGuestName | in file TUserManager.php, method TUserManager::setGuestName()
    setHalfRatingInterval in file TRatingList.php, method TRatingList::setHalfRatingInterval()
    Sets the interval such that those rating values within the interval will be considered as a half star rating.
    setHandle in file TDraggable.php, method TDraggable::setHandle()
    Set the handle id or css class
    setHasPriority | in file TCallbackClientSide.php, method TCallbackClientSide::setHasPriority()
    setHead | in file TPage.php, method TPage::setHead()
    setHeaderCssClass | in file TAccordion.php, method TAccordion::setHeaderCssClass()
    setHeaderImageUrl | in file TDataGridColumn.php, method TDataGridColumn::setHeaderImageUrl()
    setHeaderRenderer in file TDataGridColumn.php, method TDataGridColumn::setHeaderRenderer()
    Sets the column header cell renderer class.
    setHeaderRenderer in file TRepeater.php, method TRepeater::setHeaderRenderer()
    Sets the repeater header renderer class.
    setHeaderRenderer in file TDataList.php, method TDataList::setHeaderRenderer()
    Sets the datalist header renderer class.
    setHeaderTemplate | in file TTemplateColumn.php, method TTemplateColumn::setHeaderTemplate()
    setHeaderTemplate | in file TWizard.php, method TWizard::setHeaderTemplate()
    setHeaderTemplate | in file TDataList.php, method TDataList::setHeaderTemplate()
    setHeaderTemplate | in file TRepeater.php, method TRepeater::setHeaderTemplate()
    setHeaderText | in file TWizard.php, method TWizard::setHeaderText()
    setHeaderText in file TValidationSummary.php, method TValidationSummary::setHeaderText()
    Sets the header text to be displayed at the top of the summary
    setHeaderText | in file TDataGridColumn.php, method TDataGridColumn::setHeaderText()
    setHeight | in file TWebControl.php, method TWebControl::setHeight()
    setHeight | in file TStyle.php, method TStyle::setHeight()
    setHistorySize | in file TSessionPageStatePersister.php, method TSessionPageStatePersister::setHistorySize()
    setHorizontalAlign | in file TTable.php, method TTable::setHorizontalAlign()
    setHorizontalAlign in file TTableCell.php, method TTableCell::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the table item.
    setHorizontalAlign in file TPanel.php, method TPanel::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the panel.
    setHorizontalAlign in file TPanelStyle.php, method TPanelStyle::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the panel.
    setHorizontalAlign in file TTableRow.php, method TTableRow::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the table item.
    setHorizontalAlign in file TStyle.php, method TTableStyle::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the table.
    setHorizontalAlign in file TStyle.php, method TTableItemStyle::setHorizontalAlign()
    Sets the horizontal alignment of the contents within the table item.
    setHorizontalAlign | in file TBaseDataList.php, method TBaseDataList::setHorizontalAlign()
    setHost | in file TMemCache.php, method TMemCache::setHost()
    setHotSpotMode | in file TImageMap.php, method THotSpot::setHotSpotMode()
    setHotSpotMode in file TImageMap.php, method TImageMap::setHotSpotMode()
    Sets the behavior of hotspot regions in this imagemap when they are clicked.
    setHoverCssClass in file TDropContainer.php, method TDropContainer::setHoverCssClass()
    Sets the Css class name used when a draggble element is hovering over this container.
    setHtmlWriterType | in file THttpResponse.php, method THttpResponse::setHtmlWriterType()
    setHttpEquiv | in file THead.php, method TMetaTag::setHttpEquiv()
    setHttpOnly | in file THttpRequest.php, method THttpCookie::setHttpOnly()
    setID | in file TApplication.php, method TApplication::setID()
    setID | in file THead.php, method TMetaTag::setID()
    setID | in file TResultMap.php, method TResultMap::setID()
    setID | in file interfaces.php, method IService::setID()
    setID | in file THttpSession.php, method THttpSession::setID()
    setID | in file interfaces.php, method IModule::setID()
    setID | in file TModule.php, method TModule::setID()
    setID | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::setID()
    setID | in file TSqlMapStatement.php, method TSqlMapStatement::setID()
    setID | in file TControl.php, method TControl::setID()
    setID | in file TParameterMap.php, method TParameterMap::setID()
    setID | in file THttpRequest.php, method THttpRequest::setID()
    setID | in file TSoapService.php, method TSoapServer::setID()
    setID | in file TService.php, method TService::setID()
    setID in file TDataGridColumn.php, method TDataGridColumn::setID()
    Sets the ID of the column.
    setID | in file TJsonService.php, method TJsonResponse::setID()
    setImageAlign in file TActiveImage.php, method TActiveImage::setImageAlign()
    Sets the alignment of the image with respective to other elements on the page.
    setImageAlign in file TActiveImageButton.php, method TActiveImageButton::setImageAlign()
    Sets the alignment of the image with respective to other elements on the page.
    setImageAlign in file TImage.php, method TImage::setImageAlign()
    Sets the alignment of the image with respective to other elements on the page.
    setImageHeight in file THyperLink.php, method THyperLink::setImageHeight()
    Sets the height of the image in the THyperLink
    setImageHeight | in file THyperLinkColumn.php, method THyperLinkColumn::setImageHeight()
    setImageUrl | in file THyperLinkColumn.php, method THyperLinkColumn::setImageUrl()
    setImageUrl | in file TActiveImage.php, method TActiveImage::setImageUrl()
    setImageUrl in file TActiveHyperLink.php, method TActiveHyperLink::setImageUrl()
    Sets the location of image file of the THyperLink.
    setImageUrl | in file TWizardNavigationButtonStyle.php, method TWizardNavigationButtonStyle::setImageUrl()
    setImageUrl | in file TButtonColumn.php, method TButtonColumn::setImageUrl()
    setImageUrl in file THyperLink.php, method THyperLink::setImageUrl()
    Sets the location of image file of the THyperLink.
    setImageUrl | in file TImage.php, method TImage::setImageUrl()
    setImageUrl | in file TActiveImageButton.php, method TActiveImageButton::setImageUrl()
    setImageWidth | in file THyperLinkColumn.php, method THyperLinkColumn::setImageWidth()
    setImageWidth in file THyperLink.php, method THyperLink::setImageWidth()
    Sets the width of the image in the THyperLink
    setImplementation | in file TSqlMapCacheModel.php, method TSqlMapCacheModel::setImplementation()
    setInfo | in file TDbTableInfo.php, method TDbTableInfo::setInfo()
    setInfo | in file TDbTableColumn.php, method TDbTableColumn::setInfo()
    setInfo | in file TOracleTableInfo.php, method TOracleTableInfo::setInfo()
    setInitialized in file TDataBoundControl.php, method TDataBoundControl::setInitialized()
    Sets a value indicating whether the databound control is initialized.
    setInitialValue | in file TRequiredFieldValidator.php, method TRequiredFieldValidator::setInitialValue()
    setInlineParameterMap | in file TSqlMapStatement.php, method TSqlMapStatement::setInlineParameterMap()
    setInputMode | in file TDatePicker.php, method TDatePicker::setInputMode()
    setInterval | in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::setInterval()
    setInterval in file TValueTriggeredCallback.php, method TValueTriggeredCallback::setInterval()
    Sets the polling interval in seconds to observe property changes.
    setInvalidFinderResult in file TActiveRecordConfig.php, method TActiveRecordConfig::setInvalidFinderResult()
    Define the way an active record finder react if an invalid magic-finder invoked
    setInvalidFinderResult in file TActiveRecord.php, method TActiveRecord::setInvalidFinderResult()
    Define the way an active record finder react if an invalid magic-finder invoked
    setInvalidFinderResult in file TActiveRecordManager.php, method TActiveRecordManager::setInvalidFinderResult()
    Define the way an active record finder react if an invalid magic-finder invoked
    setIsDataBound | in file TDataBoundControl.php, method TDataBoundControl::setIsDataBound()
    setIsDefaultButton | in file TControl.php, method IButtonControl::setIsDefaultButton()
    setIsDefaultButton | in file TImageButton.php, method TImageButton::setIsDefaultButton()
    setIsDefaultButton | in file TLinkButton.php, method TLinkButton::setIsDefaultButton()
    setIsDefaultButton | in file TButton.php, method TButton::setIsDefaultButton()
    setIsGuest | in file TUser.php, method TUser::setIsGuest()
    setIsGuest | in file interfaces.php, method IUser::setIsGuest()
    setIsNotification | in file TRpcClient.php, method TRpcClient::setIsNotification()
    setIsValid | in file TControl.php, method IValidatable::setIsValid()
    setIsValid | in file TCheckBoxList.php, method TCheckBoxList::setIsValid()
    setIsValid | in file THiddenField.php, method THiddenField::setIsValid()
    setIsValid | in file TReCaptcha.php, method TReCaptcha::setIsValid()
    setIsValid | in file TControl.php, method IValidator::setIsValid()
    setIsValid in file TBaseValidator.php, method TBaseValidator::setIsValid()
    Sets the value indicating whether the validation succeeds
    setIsValid | in file TCheckBox.php, method TCheckBox::setIsValid()
    setIsValid | in file TActiveCustomValidator.php, method TActiveCustomValidator::setIsValid()
    setIsValid | in file TOutputCache.php, method TOutputCacheCheckDependencyEventParameter::setIsValid()
    setIsValid | in file TListBox.php, method TListBox::setIsValid()
    setIsValid | in file TActiveRecord.php, method TActiveRecordChangeEventParameter::setIsValid()
    setIsValid | in file TTextBox.php, method TTextBox::setIsValid()
    setIsValid | in file TCustomValidator.php, method TServerValidateEventParameter::setIsValid()
    setIsValid | in file TFileUpload.php, method TFileUpload::setIsValid()
    setIsValid | in file TDropDownList.php, method TDropDownList::setIsValid()
    setItalic | in file TFont.php, method TFont::setItalic()
    setItemIndex in file TDataBoundControl.php, method IItemDataRenderer::setItemIndex()
    Sets the zero-based index for the item.
    setItemIndex in file TItemDataRenderer.php, method TItemDataRenderer::setItemIndex()
    Sets the zero-based index for the item.
    setItemIndex in file TDataList.php, method TDataListItem::setItemIndex()
    Sets the zero-based index for the item.
    setItemIndex in file TRepeater.php, method TRepeaterItem::setItemIndex()
    Sets the zero-based index for the item.
    setItemRenderer in file TDataList.php, method TDataList::setItemRenderer()
    Sets the item renderer class.
    setItemRenderer in file TRepeater.php, method TRepeater::setItemRenderer()
    Sets the item renderer class.
    setItemRenderer in file TBoundColumn.php, method TBoundColumn::setItemRenderer()
    Sets the item cell renderer class.
    setItemRenderer in file TTemplateColumn.php, method TTemplateColumn::setItemRenderer()
    Sets the item cell renderer class.
    setItemTemplate | in file TRepeater.php, method TRepeater::setItemTemplate()
    setItemTemplate | in file TTemplateColumn.php, method TTemplateColumn::setItemTemplate()
    setItemTemplate | in file TDataList.php, method TDataList::setItemTemplate()
    setItemType | in file TDataGrid.php, method TDataGridItem::setItemType()
    setItemType | in file TDataBoundControl.php, method IItemDataRenderer::setItemType()
    setItemType | in file TDataList.php, method TDataListItem::setItemType()
    setItemType | in file TItemDataRenderer.php, method TItemDataRenderer::setItemType()
    setItemType | in file TRepeater.php, method TRepeaterItem::setItemType()
    setJavaScriptFiles | in file TThemeManager.php, method TTheme::setJavaScriptFiles()
    setKey in file TTranslateParameter.php, method TTranslateParameter::setKey()
    Set the parameter substitution key.
    setKey in file TTranslate.php, method TTranslate::setKey()
    Set the key for message lookup.
    setKeyboardCssClass in file TKeyboard.php, method TKeyboard::setKeyboardCssClass()
    Sets a value indicating the CSS class name for the keyboard <div> element.
    setKeyList | in file TSqlMapCache.php, method TSqlMapApplicationCache::setKeyList()
    setKeyPrefix | in file TCachePageStatePersister.php, method TCachePageStatePersister::setKeyPrefix()
    setKeyPrefix | in file TCache.php, method TCache::setKeyPrefix()
    setKeyPrefix | in file TCacheHttpSession.php, method TCacheHttpSession::setKeyPrefix()
    setKeys | in file TMappedStatement.php, method TPostSelectBinding::setKeys()
    setLanguage | in file TTextHighlighter.php, method TTextHighlighter::setLanguage()
    setLanguage | in file TReCaptcha.php, method TReCaptcha::setLanguage()
    setLastPageImageUrl | in file TPager.php, method TPager::setLastPageImageUrl()
    setLastPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setLastPageText()
    setLastPageText | in file TPager.php, method TPager::setLastPageText()
    setLazyLoad | in file TResultProperty.php, method TResultProperty::setLazyLoad()
    setLeft | in file TImageMap.php, method TRectangleHotSpot::setLeft()
    setLevels | in file TLogRouter.php, method TLogRoute::setLevels()
    setLimit | in file TSqlCriteria.php, method TSqlCriteria::setLimit()
    setLineNumber | in file TException.php, method TTemplateException::setLineNumber()
    setLineNumberStyle | in file TTextHighlighter.php, method TTextHighlighter::setLineNumberStyle()
    setListClass in file TSqlMapStatement.php, method TSqlMapStatement::setListClass()
    An ArrayAccess class can be specified to handle the type of objects in the collection.
    setListDataSource | in file TDropDownListColumn.php, method TDropDownListColumn::setListDataSource()
    setListItems in file TCallbackClientScript.php, method TCallbackClientScript::setListItems()
    Sets the options of a select input element.
    setListTextField | in file TDropDownListColumn.php, method TDropDownListColumn::setListTextField()
    setListTextFormatString | in file TDropDownListColumn.php, method TDropDownListColumn::setListTextFormatString()
    setListValueField | in file TDropDownListColumn.php, method TDropDownListColumn::setListValueField()
    setListViewID | in file TScaffoldSearch.php, method TScaffoldSearch::setListViewID()
    setLogFile | in file TLogRouter.php, method TFileLogRoute::setLogFile()
    setLoginPage in file TAuthManager.php, method TAuthManager::setLoginPage()
    Sets the login page that the client browser will be redirected to if login is needed.
    setLogPath | in file TLogRouter.php, method TFileLogRoute::setLogPath()
    setLogTableName in file TLogRouter.php, method TDbLogRoute::setLogTableName()
    Sets the name of the DB table to store log content.
    setManagerClass in file TActiveRecordConfig.php, method TActiveRecordConfig::setManagerClass()
    Set implementation class of ActiveRecordManager
    setMarginHeight | in file TInlineFrame.php, method TInlineFrame::setMarginHeight()
    setMarginWidth | in file TInlineFrame.php, method TInlineFrame::setMarginWidth()
    setMasterClass | in file TTemplateControl.php, method TTemplateControl::setMasterClass()
    setMaxFileSize | in file TLogRouter.php, method TFileLogRoute::setMaxFileSize()
    setMaxFileSize in file TFileUpload.php, method TFileUpload::setMaxFileSize()
    Sets the maximum size that a file can be uploaded.
    setMaximumRows | in file TDataSourceView.php, method TDataSourceSelectParameters::setMaximumRows()
    setMaxLength in file TTextBox.php, method TTextBox::setMaxLength()
    Sets the maximum number of characters allowed in the text box.
    setMaxLogFiles | in file TLogRouter.php, method TFileLogRoute::setMaxLogFiles()
    setMaxSelection | in file TListControlValidator.php, method TListControlValidator::setMaxSelection()
    setMaxTokenLength | in file TCaptcha.php, method TCaptcha::setMaxTokenLength()
    setMaxValue in file TRangeValidator.php, method TRangeValidator::setMaxValue()
    Sets the maximum value of the validation range.
    setMaxValue | in file TSlider.php, method TSlider::setMaxValue()
    setMediaType | in file TStyleSheet.php, method TStyleSheet::setMediaType()
    setMethod | in file TForm.php, method TForm::setMethod()
    setMethod | in file TMappedStatement.php, method TPostSelectBinding::setMethod()
    setMinChars | in file TAutoComplete.php, method TAutoComplete::setMinChars()
    setMinSavings | in file TMemCache.php, method TMemCache::setMinSavings()
    setMinSelection | in file TListControlValidator.php, method TListControlValidator::setMinSelection()
    setMinTokenLength | in file TCaptcha.php, method TCaptcha::setMinTokenLength()
    setMinValue | in file TSlider.php, method TSlider::setMinValue()
    setMinValue in file TRangeValidator.php, method TRangeValidator::setMinValue()
    Sets the minimum value of the validation range.
    setMode | in file TDatePicker.php, method TDatePicker::setMode()
    setMode | in file TPager.php, method TPager::setMode()
    setMode | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setMode()
    setMode | in file TApplication.php, method TApplication::setMode()
    setMode | in file TColorPicker.php, method TColorPicker::setMode()
    setModule in file TApplication.php, method TApplication::setModule()
    Adds a module to application.
    setName | in file TThemeManager.php, method TTheme::setName()
    setName | in file TUser.php, method TUser::setName()
    setName | in file THead.php, method TMetaTag::setName()
    setName | in file TFont.php, method TFont::setName()
    setName | in file THttpRequest.php, method THttpCookie::setName()
    setName | in file interfaces.php, method IUser::setName()
    setName | in file TControl.php, method TBroadcastEventParameter::setName()
    setNavigateUrl in file THyperLink.php, method THyperLink::setNavigateUrl()
    Sets the URL to link to when the THyperLink component is clicked.
    setNavigateUrl in file TActiveHyperLink.php, method TActiveHyperLink::setNavigateUrl()
    Sets the URL to link to when the THyperLink component is clicked.
    setNavigateUrl in file TTabPanel.php, method TTabView::setNavigateUrl()
    Sets the URL of the target page.
    setNavigateUrl in file TAccordion.php, method TAccordionView::setNavigateUrl()
    Sets the URL of the target page.
    setNavigateUrl | in file TImageMap.php, method THotSpot::setNavigateUrl()
    setNavigateUrl in file THyperLinkColumn.php, method THyperLinkColumn::setNavigateUrl()
    Sets the URL to link to when the hyperlink is clicked.
    setNavigationTemplate | in file TWizard.php, method TTemplatedWizardStep::setNavigationTemplate()
    setNestedResultMap | in file TResultProperty.php, method TResultProperty::setNestedResultMap()
    setNextButton | in file TWizard.php, method TWizardNavigationContainer::setNextButton()
    setNextPageImageUrl | in file TPager.php, method TPager::setNextPageImageUrl()
    setNextPageText | in file TPager.php, method TPager::setNextPageText()
    setNextPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setNextPageText()
    setNextStepIndex | in file TWizard.php, method TWizardNavigationEventParameter::setNextStepIndex()
    setNotNullProperty | in file TScaffoldInputCommon.php, method TScaffoldInputCommon::setNotNullProperty()
    setNullConversion | in file TDbConnection.php, method TDbConnection::setNullConversion()
    setNullValue in file TParameterProperty.php, method TParameterProperty::setNullValue()
    The nullValue attribute is used to specify an outgoing null value replacement.
    setNullValue | in file TDiscriminator.php, method TDiscriminator::setNullValue()
    setNullValue | in file TResultProperty.php, method TResultProperty::setNullValue()
    setNumericPageImageUrl in file TPager.php, method TPager::setNumericPageImageUrl()
    Sets the image URL for the numeric page buttons.
    setObjectProperty in file TActiveRecordHasOne.php, method TActiveRecordHasOne::setObjectProperty()
    Sets the foreign objects to the given property on the source object.
    setObjectProperty in file TMappedStatement.php, method TMappedStatement::setObjectProperty()
    Set a property of the result object with appropriate value.
    setObjectProperty in file TActiveRecordRelation.php, method TActiveRecordRelation::setObjectProperty()
    Sets the foreign objects to the given property on the source object.
    setObjectProperty in file TActiveRecordBelongsTo.php, method TActiveRecordBelongsTo::setObjectProperty()
    Sets the foreign objects to the given property on the source object.
    setObjectPropFromNode in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfigBuilder::setObjectPropFromNode()
    For each attributes (excluding attribute named in $except) set the property of the $obj given by the name of the attribute with the value of the attribute.
    setObserveChanges | in file TBaseValidator.php, method TValidatorClientSide::setObserveChanges()
    setObserveChanges | in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::setObserveChanges()
    setOffset | in file TSqlCriteria.php, method TSqlCriteria::setOffset()
    setOKButtonText | in file TColorPicker.php, method TColorPicker::setOKButtonText()
    setOnChange in file TSlider.php, method TSliderClientScript::setOnChange()
    Javascript code to execute when the slider value is changed.
    setOnColorSelected | in file TColorPicker.php, method TColorPickerClientSide::setOnColorSelected()
    setOnComplete | in file TCallbackClientSide.php, method TCallbackClientSide::setOnComplete()
    setOnDateChanged in file TDatePicker.php, method TDatePickerClientScript::setOnDateChanged()
    Javascript code to execute when the date picker's date is changed.
    setOnException | in file TCallbackClientSide.php, method TCallbackClientSide::setOnException()
    setOnFailure | in file TCallbackClientSide.php, method TCallbackClientSide::setOnFailure()
    setOnHideSummary in file TValidationSummary.php, method TClientSideValidationSummaryOptions::setOnHideSummary()
    Client-side OnHideSummary validation summary event is raise when all the validators are valid. This will override the default client-side validation summary behaviour.
    setOnInteractive | in file TCallbackClientSide.php, method TCallbackClientSide::setOnInteractive()
    setOnLoaded | in file TCallbackClientSide.php, method TCallbackClientSide::setOnLoaded()
    setOnLoading | in file TCallbackClientSide.php, method TCallbackClientSide::setOnLoading()
    setOnPreDispatch | in file TCallbackClientSide.php, method TCallbackClientSide::setOnPreDispatch()
    setOnShowSummary in file TValidationSummary.php, method TClientSideValidationSummaryOptions::setOnShowSummary()
    Client-side OnShowSummary event is raise when one or more validators are not valid. This will override the default client-side validation summary behaviour.
    setOnSlide | in file TSlider.php, method TSliderClientScript::setOnSlide()
    setOnSuccess | in file TCallbackClientSide.php, method TCallbackClientSide::setOnSuccess()
    setOnUninitialized | in file TCallbackClientSide.php, method TCallbackClientSide::setOnUninitialized()
    setOnValidate in file TBaseValidator.php, method TValidatorClientSide::setOnValidate()
    Client-side OnValidate validator event is raise before the validators validation functions are called.
    setOnValidate in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::setOnValidate()
    Client-side OnValidate validator event is raise before the validators validation functions are called.
    setOnValidationError in file TBaseValidator.php, method TValidatorClientSide::setOnValidationError()
    Client-side OnError event is raised after validation failure.
    setOnValidationError in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::setOnValidationError()
    Client-side OnError event is raised after validation failure.
    setOnValidationSuccess in file TBaseValidator.php, method TValidatorClientSide::setOnValidationSuccess()
    Client-side OnSuccess event is raise after validation is successfull.
    setOnValidationSuccess in file TActiveCustomValidator.php, method TActiveCustomValidatorClientSide::setOnValidationSuccess()
    Client-side OnSuccess event is raise after validation is successfull.
    setOpacity in file TCallbackClientScript.php, method TCallbackClientScript::setOpacity()
    Set the opacity on a html element or control.
    setOperator in file TCompareValidator.php, method TCompareValidator::setOperator()
    Sets the comparison operation to perform
    setOption in file TBaseActiveControl.php, method TBaseActiveControl::setOption()
    Sets a named options with a value. Options are used to store and retrive named values for the base active controls.
    setOption | in file TClientScriptManager.php, method TClientSideOptions::setOption()
    setOptions in file THtmlArea.php, method THtmlArea::setOptions()
    Sets the list of options for the WYSIWYG (TinyMCE) editor
    setOrdersBy | in file TSqlCriteria.php, method TSqlCriteria::setOrdersBy()
    setOverline | in file TFont.php, method TFont::setOverline()
    setOwner | in file TDataGridColumn.php, method TDataGridColumn::setOwner()
    setPage | in file TSessionPageStatePersister.php, method TSessionPageStatePersister::setPage()
    setPage in file TControl.php, method TControl::setPage()
    Sets the page for a control.
    setPage | in file TPageStatePersister.php, method TPageStatePersister::setPage()
    setPage | in file TCachePageStatePersister.php, method TCachePageStatePersister::setPage()
    setPage | in file TPage.php, method IPageStatePersister::setPage()
    setPageButtonCount | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setPageButtonCount()
    setPageButtonCount | in file TPager.php, method TPager::setPageButtonCount()
    setPageCount | in file TPager.php, method TPager::setPageCount()
    setPagePath | in file TPage.php, method TPage::setPagePath()
    setPageServiceID | in file TApplication.php, method TApplication::setPageServiceID()
    setPageSize | in file TPagedDataSource.php, method TPagedDataSource::setPageSize()
    setPageSize | in file TPagedList.php, method TPagedList::setPageSize()
    setPageSize | in file TDataBoundControl.php, method TDataBoundControl::setPageSize()
    setParameter | in file TTranslate.php, method TTranslate::setParameter()
    setParameter | in file TControl.php, method TBroadcastEventParameter::setParameter()
    setParameterClass in file TSqlMapStatement.php, method TSqlMapStatement::setParameterClass()
    If a ParameterMap property is not specified, you may specify a ParameterClass instead and use inline parameters.
    setParameterFile | in file TParameterModule.php, method TParameterModule::setParameterFile()
    setParameterMap in file TSqlMapStatement.php, method TSqlMapStatement::setParameterMap()
    A Parameter Map defines an ordered list of values that match up with the "?" placeholders of a standard, parameterized query statement.
    setParameterNames | in file TPreparedStatement.php, method TPreparedStatement::setParameterNames()
    setParameters | in file TUrlMapping.php, method TUrlMappingPattern::setParameters()
    setParameters | in file TSqlCriteria.php, method TSqlCriteria::setParameters()
    setParameterValues | in file TPreparedStatement.php, method TPreparedStatement::setParameterValues()
    setParent | in file TXmlDocument.php, method TXmlElement::setParent()
    setPassword | in file TDbCache.php, method TDbCache::setPassword()
    setPassword | in file TDbConnection.php, method TDbConnection::setPassword()
    setPasswordMode | in file TUserManager.php, method TUserManager::setPasswordMode()
    setPath | in file THttpRequest.php, method THttpCookie::setPath()
    setPathOfAlias | in file PradoBase.php, method PradoBase::setPathOfAlias()
    setPattern | in file TSimpleDateFormatter.php, method TSimpleDateFormatter::setPattern()
    setPattern in file TNumberFormat.php, method TNumberFormat::setPattern()
    Set the number format pattern.
    setPattern | in file TUrlMapping.php, method TUrlMappingPattern::setPattern()
    setPattern in file TDateFormat.php, method TDateFormat::setPattern()
    Sets the date time formatting pattern.
    setPatternModifiers | in file TRegularExpressionValidator.php, method TRegularExpressionValidator::setPatternModifiers()
    setPersistent | in file TDbConnection.php, method TDbConnection::setPersistent()
    setPersistPassword | in file TTextBox.php, method TTextBox::setPersistPassword()
    setPort | in file TMemCache.php, method TMemCache::setPort()
    setPosition | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setPosition()
    setPositionMode | in file TDatePicker.php, method TDatePicker::setPositionMode()
    setPostBackEventParameter | in file TPage.php, method TPage::setPostBackEventParameter()
    setPostBackEventTarget in file TPage.php, method TPage::setPostBackEventTarget()
    Registers a control to raise postback event in the current request.
    setPostBackParameter | in file TCallbackClientSide.php, method TCallbackClientSide::setPostBackParameter()
    setPostBackTarget | in file TCallbackClientSide.php, method TCallbackClientSide::setPostBackTarget()
    setPostBackValue | in file TImageMap.php, method THotSpot::setPostBackValue()
    setPostContentsTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::setPostContentsTemplate()
    setPostContentsText | in file TWebControlDecorator.php, method TWebControlDecorator::setPostContentsText()
    setPostState | in file TCallbackClientSide.php, method TCallbackClientSide::setPostState()
    setPostTagTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::setPostTagTemplate()
    setPostTagText | in file TWebControlDecorator.php, method TWebControlDecorator::setPostTagText()
    setPradoScripts in file TClientScript.php, method TClientScript::setPradoScripts()
    Include javascript library to the current page. The current supported libraries are: "prado", "effects", "ajax", "validator", "logger", "datepicker", "colorpicker". Library dependencies are automatically resolved.
    setPrecision in file TPriorityList.php, method TPriorityList::setPrecision()
    This must be called internally or when instantiated.
    setPrecision in file TPriorityMap.php, method TPriorityMap::setPrecision()
    This must be called internally or when instantiated.
    setPreContentsTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::setPreContentsTemplate()
    setPreContentsText | in file TWebControlDecorator.php, method TWebControlDecorator::setPreContentsText()
    setPreparedSql | in file TPreparedStatement.php, method TPreparedStatement::setPreparedSql()
    setPreTagTemplate | in file TWebControlDecorator.php, method TWebControlDecorator::setPreTagTemplate()
    setPreTagText | in file TWebControlDecorator.php, method TWebControlDecorator::setPreTagText()
    setPreventDefaultAction | in file TEventTriggeredCallback.php, method TEventTriggeredCallback::setPreventDefaultAction()
    setPreviousButton | in file TWizard.php, method TWizardNavigationContainer::setPreviousButton()
    setPrevPageImageUrl | in file TPager.php, method TPager::setPrevPageImageUrl()
    setPrevPageText | in file TPager.php, method TPager::setPrevPageText()
    setPrevPageText | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setPrevPageText()
    setPrimaryCache | in file TCache.php, method TCache::setPrimaryCache()
    setPriorityAt in file TPriorityMap.php, method TPriorityMap::setPriorityAt()
    This changes an item's priority. Specify the item and the new priority.
    setPrivateKey | in file TReCaptcha.php, method TReCaptcha::setPrivateKey()
    setProgressIndicator | in file TSlider.php, method TSlider::setProgressIndicator()
    setPromptText | in file TListControl.php, method TListControl::setPromptText()
    setPromptValue | in file TListControl.php, method TListControl::setPromptValue()
    setProperty | in file TResultProperty.php, method TResultProperty::setProperty()
    setProperty | in file TParameterProperty.php, method TParameterProperty::setProperty()
    setProperty | in file TSqlMapStatement.php, method TSqlMapSelectKey::setProperty()
    setPropertyName in file TValueTriggeredCallback.php, method TValueTriggeredCallback::setPropertyName()
    Sets the control property name to observe value changes that fires the callback request.
    setProvider | in file TSoapService.php, method TSoapServer::setProvider()
    setPublicKey | in file TCaptcha.php, method TCaptcha::setPublicKey()
    setPublicKey | in file TReCaptcha.php, method TReCaptcha::setPublicKey()
    setPublished | in file TAssetManager.php, method TAssetManager::setPublished()
    setRadius | in file TImageMap.php, method TCircleHotSpot::setRadius()
    setRating | in file TActiveRatingList.php, method TActiveRatingList::setRating()
    setRating | in file TRatingList.php, method TRatingList::setRating()
    setRatingStyle | in file TRatingList.php, method TRatingList::setRatingStyle()
    setReadOnly | in file TActiveRatingList.php, method TActiveRatingList::setReadOnly()
    setReadOnly | in file TDropDownListColumn.php, method TDropDownListColumn::setReadOnly()
    setReadOnly | in file TBoundColumn.php, method TBoundColumn::setReadOnly()
    setReadOnly | in file TRatingList.php, method TRatingList::setReadOnly()
    setReadOnly | in file TTextBox.php, method TTextBox::setReadOnly()
    setReadOnly | in file TCheckBoxColumn.php, method TCheckBoxColumn::setReadOnly()
    setReadOnly | in file TMap.php, method TMap::setReadOnly()
    setReadOnly in file TInPlaceTextBox.php, method TInPlaceTextBox::setReadOnly()
    Update ClientSide Readonly property
    setReadOnly | in file TList.php, method TList::setReadOnly()
    setReadOnly | in file TPriorityMap.php, method TPriorityMap::setReadOnly()
    setRecordClass in file TScaffoldBase.php, method TScaffoldBase::setRecordClass()
    Name of the Active Record class to be viewed or scaffolded.
    setRecordObject | in file TScaffoldBase.php, method TScaffoldBase::setRecordObject()
    setRecordPk | in file TScaffoldEditView.php, method TScaffoldEditView::setRecordPk()
    setRecordPropertyValue | in file TScaffoldInputBase.php, method TScaffoldInputBase::setRecordPropertyValue()
    setRecursiveCheck | in file TCache.php, method TDirectoryCacheDependency::setRecursiveCheck()
    setRecursiveLevel in file TCache.php, method TDirectoryCacheDependency::setRecursiveLevel()
    Sets a value indicating the depth of the subdirectories to be checked.
    setRegularExpression | in file TRegularExpressionValidator.php, method TRegularExpressionValidator::setRegularExpression()
    setRegularExpression | in file TUrlMapping.php, method TUrlMappingPattern::setRegularExpression()
    setRepackUTF7 in file TSafeHtml.php, method TSafeHtml::setRepackUTF7()
    Sets whether to parse the contents as UTF-7. This property enables a routine that repacks the content as UTF-7 before parsing it. Defaults to false.
    setRepeatColumns | in file TCheckBoxList.php, method TCheckBoxList::setRepeatColumns()
    setRepeatColumns | in file TRepeatInfo.php, method TRepeatInfo::setRepeatColumns()
    setRepeatColumns | in file TDataList.php, method TDataList::setRepeatColumns()
    setRepeatDirection | in file TCheckBoxList.php, method TCheckBoxList::setRepeatDirection()
    setRepeatDirection | in file TRepeatInfo.php, method TRepeatInfo::setRepeatDirection()
    setRepeatDirection | in file TDataList.php, method TDataList::setRepeatDirection()
    setRepeatLayout | in file TRepeatInfo.php, method TRepeatInfo::setRepeatLayout()
    setRepeatLayout in file TRatingList.php, method TRatingList::setRepeatLayout()
    The repeat layout must be Table.
    setRepeatLayout | in file TCheckBoxList.php, method TCheckBoxList::setRepeatLayout()
    setRepeatLayout | in file TDataList.php, method TDataList::setRepeatLayout()
    setRequest | in file TApplication.php, method TApplication::setRequest()
    setRequestTimeOut | in file TCallbackClientSide.php, method TCallbackClientSide::setRequestTimeOut()
    setRequiredSelections in file TListControlValidator.php, method TListControlValidator::setRequiredSelections()
    Set the list of required values, using aa comma separated list.
    setRequiresDataBinding in file TDataBoundControl.php, method TDataBoundControl::setRequiresDataBinding()
    Sets a value indicating whether a databind call is required by the data bound control.
    setResponse | in file TApplication.php, method TApplication::setResponse()
    setResponseData | in file TCallbackResponseAdapter.php, method TCallbackResponseAdapter::setResponseData()
    setResponseData | in file TCallbackEventParameter.php, method TCallbackEventParameter::setResponseData()
    setResult | in file TDataGatewayCommand.php, method TDataGatewayResultEventParameter::setResult()
    setResultClass in file TSqlMapStatement.php, method TSqlMapStatement::setResultClass()
    If a ResultMap is not specified, you may specify a
    setResultCollection in file TActiveRecordRelation.php, method TActiveRecordRelation::setResultCollection()
    Populates the result array with foreign objects (matched using foreign key hashed property values).
    setResultMap in file TSqlMapStatement.php, method TSqlMapStatement::setResultMap()
    A Result Map lets you control how data is extracted from the result of a query, and how the columns are mapped to object properties.
    setResultMapping | in file TResultProperty.php, method TResultProperty::setResultMapping()
    setResultMapping | in file TDiscriminator.php, method TSubMap::setResultMapping()
    setResultObject | in file TMappedStatement.php, method TPostSelectBinding::setResultObject()
    setResultProperty | in file TMappedStatement.php, method TPostSelectBinding::setResultProperty()
    setRetrieveTotalRowCount | in file TDataSourceView.php, method TDataSourceSelectParameters::setRetrieveTotalRowCount()
    setReturnUrl in file TAuthManager.php, method TAuthManager::setReturnUrl()
    Sets the URL that the browser should be redirected to when login succeeds.
    setReturnUrlVarName | in file TAuthManager.php, method TAuthManager::setReturnUrlVarName()
    setRevert in file TDraggable.php, method TDraggable::setRevert()
    Sets whether the draggable element should revert to it orginal position upon release in an non-droppable container.
    setRight | in file TImageMap.php, method TRectangleHotSpot::setRight()
    setRoles | in file interfaces.php, method IUser::setRoles()
    setRoles | in file TUser.php, method TUser::setRoles()
    setRows | in file TListBox.php, method TListBox::setRows()
    setRows in file TTextBox.php, method TTextBox::setRows()
    Sets the number of rows displayed in a multiline text box.
    setRowSpan in file TTableCell.php, method TTableCell::setRowSpan()
    Sets the rowspan for the table cell.
    setRuntimePath | in file TApplication.php, method TApplication::setRuntimePath()
    setSavePath | in file THttpSession.php, method THttpSession::setSavePath()
    setScheme | in file THead.php, method TMetaTag::setScheme()
    setScope | in file TTableHeaderCell.php, method TTableHeaderCell::setScope()
    setScriptUrl | in file TClientScript.php, method TClientScript::setScriptUrl()
    setScrollBars | in file TPanel.php, method TPanel::setScrollBars()
    setScrollBars | in file TPanelStyle.php, method TPanelStyle::setScrollBars()
    setScrollBars | in file TInlineFrame.php, method TInlineFrame::setScrollBars()
    setScrollToSummary | in file TValidationSummary.php, method TValidationSummary::setScrollToSummary()
    setSearchableFields | in file TScaffoldSearch.php, method TScaffoldSearch::setSearchableFields()
    setSearchCondition | in file TScaffoldListView.php, method TScaffoldListView::setSearchCondition()
    setSearchParameters | in file TScaffoldListView.php, method TScaffoldListView::setSearchParameters()
    setSecure | in file THttpRequest.php, method THttpCookie::setSecure()
    setSecureConnection | in file TUrlMapping.php, method TUrlMappingPattern::setSecureConnection()
    setSecurityManager | in file TApplication.php, method TApplication::setSecurityManager()
    setSelect in file TSqlCriteria.php, method TSqlCriteria::setSelect()
    Sets the field list to be placed after the SELECT in the SQL.
    setSelect in file TResultProperty.php, method TResultProperty::setSelect()
    The select property is used to describe a relationship between objects and to automatically load complex (i.e. user defined) property types.
    setSelected | in file TListItem.php, method TListItem::setSelected()
    setSelectedIndex | in file TListControl.php, method TListControl::setSelectedIndex()
    setSelectedIndex | in file TBulletedList.php, method TBulletedList::setSelectedIndex()
    setSelectedIndex in file TListControl.php, method IListControlAdapter::setSelectedIndex()
    Selects an item based on zero-base index on the client side.
    setSelectedIndex | in file TRatingList.php, method TRatingList::setSelectedIndex()
    setSelectedIndex in file TActiveListControlAdapter.php, method TActiveListControlAdapter::setSelectedIndex()
    Selects an item based on zero-base index on the client side.
    setSelectedIndices | in file TListControl.php, method TListControl::setSelectedIndices()
    setSelectedIndices in file TListControl.php, method IListControlAdapter::setSelectedIndices()
    Selects a list of item based on zero-base indices on the client side.
    setSelectedIndices | in file TRadioButtonList.php, method TRadioButtonList::setSelectedIndices()
    setSelectedIndices in file TActiveListControlAdapter.php, method TActiveListControlAdapter::setSelectedIndices()
    Selects a list of item based on zero-base indices on the client side.
    setSelectedIndices | in file TDropDownList.php, method TDropDownList::setSelectedIndices()
    setSelectedIndices | in file TBulletedList.php, method TBulletedList::setSelectedIndices()
    setSelectedItemIndex in file TDataGrid.php, method TDataGrid::setSelectedItemIndex()
    Selects an item by its index in getItems.
    setSelectedItemIndex in file TDataList.php, method TDataList::setSelectedItemIndex()
    Selects an item by its index in getItems.
    setSelectedItemRenderer in file TDataList.php, method TDataList::setSelectedItemRenderer()
    Sets the renderer class for the datalist item being selected.
    setSelectedItemTemplate | in file TDataList.php, method TDataList::setSelectedItemTemplate()
    setSelectedValue in file TActiveListControlAdapter.php, method TActiveListControlAdapter::setSelectedValue()
    Sets selection by item value on the client side.
    setSelectedValue | in file TBulletedList.php, method TBulletedList::setSelectedValue()
    setSelectedValue in file TListControl.php, method TListControl::setSelectedValue()
    Sets selection by item value.
    setSelectedValue in file TListControl.php, method IListControlAdapter::setSelectedValue()
    Sets selection by item value on the client side.
    setSelectedValues in file TListControl.php, method IListControlAdapter::setSelectedValues()
    Sets selection by a list of item values on the client side.
    setSelectedValues | in file TBulletedList.php, method TBulletedList::setSelectedValues()
    setSelectedValues in file TActiveListControlAdapter.php, method TActiveListControlAdapter::setSelectedValues()
    Sets selection by a list of item values on the client side.
    setSelectedValues | in file TListControl.php, method TListControl::setSelectedValues()
    setSelectionMode in file TActiveListBox.php, method TActiveListBox::setSelectionMode()
    Sets the selection mode of the list control (Single, Multiple) on the client-side if the setEnableUpdate property is set to true.
    setSelectionMode | in file TListBox.php, method TListBox::setSelectionMode()
    setSelectKey | in file TSqlMapStatement.php, method TSqlMapInsert::setSelectKey()
    setSentFrom | in file TLogRouter.php, method TEmailLogRoute::setSentFrom()
    setSeparator | in file TAutoComplete.php, method TAutoComplete::setSeparator()
    setSeparatorRenderer in file TRepeater.php, method TRepeater::setSeparatorRenderer()
    Sets the repeater item separator renderer class.
    setSeparatorRenderer in file TDataList.php, method TDataList::setSeparatorRenderer()
    Sets the datalist item separator renderer class.
    setSeparatorTemplate | in file TDataList.php, method TDataList::setSeparatorTemplate()
    setSeparatorTemplate | in file TRepeater.php, method TRepeater::setSeparatorTemplate()
    setServerUrl | in file TRpcClient.php, method TRpcClient::setServerUrl()
    setService | in file TApplication.php, method TApplication::setService()
    setServiceID in file THttpRequest.php, method THttpRequest::setServiceID()
    Sets the requested service ID.
    setServiceID | in file TUrlMapping.php, method TUrlMappingPattern::setServiceID()
    setServiceParameter | in file TUrlMapping.php, method TUrlMappingPattern::setServiceParameter()
    setServiceParameter in file THttpRequest.php, method THttpRequest::setServiceParameter()
    Sets the requested service parameter.
    setSession | in file TApplication.php, method TApplication::setSession()
    setSessionID | in file THttpSession.php, method THttpSession::setSessionID()
    setSessionName | in file THttpSession.php, method THttpSession::setSessionName()
    setSessionPersistent | in file TSoapService.php, method TSoapServer::setSessionPersistent()
    setShortcutIcon | in file THead.php, method THead::setShortcutIcon()
    setShowAnchor | in file TValidationSummary.php, method TValidationSummary::setShowAnchor()
    setShowBorder | in file TInlineFrame.php, method TInlineFrame::setShowBorder()
    setShowCalendar in file TDatePicker.php, method TDatePicker::setShowCalendar()
    Sets whether to pop up the calendar window when the control receives focus
    setShowCancelButton | in file TWizard.php, method TWizard::setShowCancelButton()
    setShowColorPicker in file TColorPicker.php, method TColorPicker::setShowColorPicker()
    Sets whether to pop up the color picker when the button is clicked.
    setShowFooter | in file TDataList.php, method TDataList::setShowFooter()
    setShowFooter | in file TDataGrid.php, method TDataGrid::setShowFooter()
    setShowHeader | in file TDataList.php, method TDataList::setShowHeader()
    setShowHeader | in file TDataGrid.php, method TDataGrid::setShowHeader()
    setShowLineNumbers | in file TTextHighlighter.php, method TTextHighlighter::setShowLineNumbers()
    setShowMessageBox | in file TValidationSummary.php, method TValidationSummary::setShowMessageBox()
    setShowSideBar | in file TWizard.php, method TWizard::setShowSideBar()
    setShowSummary | in file TValidationSummary.php, method TValidationSummary::setShowSummary()
    setSideBarTemplate | in file TWizard.php, method TWizard::setSideBarTemplate()
    setSize | in file TFont.php, method TFont::setSize()
    setSkinID | in file TControl.php, method TControl::setSkinID()
    setSkinID | in file THiddenField.php, method THiddenField::setSkinID()
    setSkinID | in file TDataSourceControl.php, method TDataSourceControl::setSkinID()
    setSkins | in file TThemeManager.php, method TTheme::setSkins()
    setSortExpression | in file TDataGridColumn.php, method TDataGridColumn::setSortExpression()
    setSqlText | in file TSqlMapStatement.php, method TSqlMapStatement::setSqlText()
    setStartNavigationTemplate | in file TWizard.php, method TWizard::setStartNavigationTemplate()
    setStartRowIndex | in file TDataSourceView.php, method TDataSourceSelectParameters::setStartRowIndex()
    setStartTimerOnLoad | in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::setStartTimerOnLoad()
    setState in file TUser.php, method TUser::setState()
    Stores a variable in user session.
    setStateChanged | in file TUser.php, method TUser::setStateChanged()
    setStatement | in file TMappedStatement.php, method TPostSelectBinding::setStatement()
    setStatements | in file TStatements.php, method TStatements::setStatements()
    setStateName | in file TCache.php, method TGlobalStateCacheDependency::setStateName()
    setStatePersisterClass | in file TPage.php, method TPage::setStatePersisterClass()
    setStatusCode in file THttpResponse.php, method THttpResponse::setStatusCode()
    Set the HTTP status code for the response.
    setStepNavigationTemplate | in file TWizard.php, method TWizard::setStepNavigationTemplate()
    setStepSize in file TSlider.php, method TSlider::setStepSize()
    Sets the step size used to determine the places where the slider handle can stop at.
    setStepType | in file TWizard.php, method TCompleteWizardStep::setStepType()
    setStepType | in file TWizard.php, method TWizardStep::setStepType()
    setStrictComparison | in file TRangeValidator.php, method TRangeValidator::setStrictComparison()
    setStrikeout | in file TFont.php, method TFont::setStrikeout()
    setStyle in file TWebControl.php, method TWebControl::setStyle()
    Sets the css style string of the control.
    setStyle in file TCallbackClientScript.php, method TCallbackClientScript::setStyle()
    Sets the style of element. The style must be a key-value array where the key is the style property and the value is the style value.
    setStyleField in file TStyle.php, method TStyle::setStyleField()
    Sets a single style field value.
    setStyleSheetFiles | in file TThemeManager.php, method TTheme::setStyleSheetFiles()
    setStyleSheetTheme in file TPage.php, method TPage::setStyleSheetTheme()
    Sets the stylesheet theme to be used for the page.
    setStyleSheetUrl | in file TStyleSheet.php, method TStyleSheet::setStyleSheetUrl()
    setSubject | in file TLogRouter.php, method TEmailLogRoute::setSubject()
    setSubProperty in file TComponent.php, method TComponent::setSubProperty()
    Sets a value to a property path.
    setTabCssClass | in file TTabPanel.php, method TTabPanel::setTabCssClass()
    setTabIndex | in file TImageMap.php, method THotSpot::setTabIndex()
    setTabIndex in file TWebControl.php, method TWebControl::setTabIndex()
    Sets the tab index of the control.
    setTableInfo | in file TTableGateway.php, method TTableGateway::setTableInfo()
    setTableInfo | in file TDbCommandBuilder.php, method TDbCommandBuilder::setTableInfo()
    setTableName in file TTableGateway.php, method TTableGateway::setTableName()
    Sets up the command builder for the given table.
    setTableSection | in file TTableRow.php, method TTableRow::setTableSection()
    setTableSection | in file TTableFooterRow.php, method TTableFooterRow::setTableSection()
    setTableSection | in file TTableHeaderRow.php, method TTableHeaderRow::setTableSection()
    setTabSize | in file TTextHighlighter.php, method TTextHighlighter::setTabSize()
    setTagName | in file TXmlDocument.php, method TXmlElement::setTagName()
    setTagName | in file TDataList.php, method TDataListItem::setTagName()
    setTagName | in file THtmlElement.php, method THtmlElement::setTagName()
    setTarget in file THyperLinkColumn.php, method THyperLinkColumn::setTarget()
    Sets the target window or frame to display the Web page content linked to when the hyperlink is clicked.
    setTarget | in file TBulletedList.php, method TBulletedList::setTarget()
    setTarget | in file TImageMap.php, method TImageMap::setTarget()
    setTarget | in file TImageMap.php, method THotSpot::setTarget()
    setTarget in file THyperLink.php, method THyperLink::setTarget()
    Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.
    setTarget in file TActiveHyperLink.php, method TActiveHyperLink::setTarget()
    Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.
    setTemplate in file TTemplateControl.php, method TTemplateControl::setTemplate()
    Sets the parsed template.
    setTemplateControl in file TControl.php, method TControl::setTemplateControl()
    Sets the control whose template contains this control.
    setTemplateFile | in file TException.php, method TTemplateException::setTemplateFile()
    setTemplateManager | in file TPageService.php, method TPageService::setTemplateManager()
    setTemplateSource | in file TException.php, method TTemplateException::setTemplateSource()
    setTempPath | in file TActiveFileUpload.php, method TActiveFileUpload::setTempPath()
    setTestLimit | in file TCaptcha.php, method TCaptcha::setTestLimit()
    setText | in file TListControl.php, method TListControl::setText()
    setText in file TActiveLabel.php, method TActiveLabel::setText()
    On callback response, the inner HTML of the label is updated.
    setText in file TInPlaceTextBox.php, method TInPlaceTextBox::setText()
    On callback response, the inner HTMl of the label and the
    setText in file TActiveButton.php, method TActiveButton::setText()
    Updates the button text on the client-side if the setEnableUpdate property is set to true.
    setText | in file TLinkButton.php, method TLinkButton::setText()
    setText in file TActiveLinkButton.php, method TActiveLinkButton::setText()
    Updates the link text on the client-side if the setEnableUpdate property is set to true.
    setText in file TTranslate.php, method TTranslate::setText()
    Sets the text for localization.
    setText in file TActiveCheckBox.php, method TActiveCheckBox::setText()
    Updates the button text on the client-side if the setEnableUpdate property is set to true.
    setText | in file TControl.php, method IButtonControl::setText()
    setText in file TAccordion.php, method TAccordionView::setText()
    Sets the text content to be displayed on this view.
    setText | in file TLabel.php, method TLabel::setText()
    setText in file TDbCommand.php, method TDbCommand::setText()
    Specifies the SQL statement to be executed.
    setText | in file TListItem.php, method TListItem::setText()
    setText | in file TLiteralColumn.php, method TLiteralColumn::setText()
    setText in file TTextBox.php, method TTextBox::setText()
    Sets the text content of the TTextBox control.
    setText in file TActiveDatePicker.php, method TActiveDatePicker::setText()
    Client-side Text property can only be updated after the OnLoad stage.
    setText in file TTabPanel.php, method TTabView::setText()
    Sets the text content to be displayed on this view.
    setText in file TCheckBox.php, method TCheckBox::setText()
    Sets the text caption of the checkbox.
    setText in file TActiveHyperLink.php, method TActiveHyperLink::setText()
    On callback response, the inner HTMl of the label is updated.
    setText in file TLiteral.php, method TLiteral::setText()
    Sets the static text of the TLiteral
    setText | in file TTextProcessor.php, method TTextProcessor::setText()
    setText in file THyperLink.php, method THyperLink::setText()
    Sets the text caption of the THyperLink.
    setText in file TActiveTextBox.php, method TActiveTextBox::setText()
    Client-side Text property can only be updated after the OnLoad stage.
    setText | in file TImageButton.php, method TImageButton::setText()
    setText in file TButtonColumn.php, method TButtonColumn::setText()
    Sets the text caption of the button.
    setText in file THyperLinkColumn.php, method THyperLinkColumn::setText()
    Sets the text caption of the hyperlink.
    setText | in file TButton.php, method TButton::setText()
    setText in file TTableCell.php, method TTableCell::setText()
    Sets the text content of the table cell.
    setText in file TActiveRadioButton.php, method TActiveRadioButton::setText()
    Updates the button text on the client-side if the setEnableUpdate property is set to true.
    setTextAlign | in file TCheckBoxList.php, method TCheckBoxList::setTextAlign()
    setTextAlign | in file TCheckBox.php, method TCheckBox::setTextAlign()
    setTextCssClass | in file TAutoComplete.php, method TAutoComplete::setTextCssClass()
    setTextMode in file TTextBox.php, method TTextBox::setTextMode()
    Sets the behavior mode of the TTextBox component.
    setTextMode in file THtmlArea.php, method THtmlArea::setTextMode()
    Overrides the parent implementation.
    setTheme in file TPage.php, method TPage::setTheme()
    Sets the theme to be used for the page.
    setThemeClass | in file TThemeManager.php, method TThemeManager::setThemeClass()
    setThemeManager | in file TPageService.php, method TPageService::setThemeManager()
    setThemeName | in file TReCaptcha.php, method TReCaptcha::setThemeName()
    setThreshold | in file TMemCache.php, method TMemCache::setThreshold()
    setTimeout | in file THttpSession.php, method THttpSession::setTimeout()
    setTimeStamp in file TDatePicker.php, method TDatePicker::setTimeStamp()
    Sets the date for the date picker using timestamp.
    setTitle in file THead.php, method THead::setTitle()
    Sets the page title.
    setTitle | in file TWizard.php, method TWizardStep::setTitle()
    setTitle in file TPage.php, method TPage::setTitle()
    Sets the page title.
    setToggleKey | in file TJavascriptLogger.php, method TJavascriptLogger::setToggleKey()
    setTokenAlphabet | in file TCaptcha.php, method TCaptcha::setTokenAlphabet()
    setTokenExpiry | in file TCaptcha.php, method TCaptcha::setTokenExpiry()
    setTokenFontSize in file TCaptcha.php, method TCaptcha::setTokenFontSize()
    Sets the font size used for displaying the token in an image.
    setTokenImageTheme in file TCaptcha.php, method TCaptcha::setTokenImageTheme()
    Sets the theme of the token image.
    setToolTip in file TWebControl.php, method TWebControl::setToolTip()
    Sets the tooltip of the control.
    setTop | in file TImageMap.php, method TRectangleHotSpot::setTop()
    setTotalRowCount | in file TDataSourceView.php, method TDataSourceSelectParameters::setTotalRowCount()
    setTransactionClass | in file TDbConnection.php, method TDbConnection::setTransactionClass()
    setTransformContent | in file TXmlTransform.php, method TXmlTransform::setTransformContent()
    setTransformPath | in file TXmlTransform.php, method TXmlTransform::setTransformPath()
    setTranslateDefaultCulture | in file TGlobalization.php, method TGlobalization::setTranslateDefaultCulture()
    setTranslationCatalogue | in file TGlobalization.php, method TGlobalization::setTranslationCatalogue()
    setTranslationConfiguration in file TGlobalization.php, method TGlobalization::setTranslationConfiguration()
    Sets the translation configuration. Example configuration:
    setTrim in file TTranslateParameter.php, method TTranslateParameter::setTrim()
    Set the option to trim the contents.
    setTrim in file TTranslate.php, method TTranslate::setTrim()
    Set the option to trim the contents.
    setTrueTemplate | in file TConditional.php, method TConditional::setTrueTemplate()
    setType in file TDiscriminator.php, method TDiscriminator::setType()
    The type attribute is used to explicitly specify the property type of the parameter to be set. If the attribute type is not set and the framework cannot otherwise determine the type, the type is assumed from the default value of the property.
    setType | in file TSqlMapStatement.php, method TSqlMapSelectKey::setType()
    setType in file TNumberFormat.php, method TNumberFormat::setType()
    Set the formatting type for this control.
    setType | in file TResultProperty.php, method TResultProperty::setType()
    setType | in file TParameterProperty.php, method TParameterProperty::setType()
    setType | in file TSqlMapTypeHandlerRegistry.php, method TSqlMapTypeHandler::setType()
    setTypeHandler | in file TResultProperty.php, method TResultProperty::setTypeHandler()
    setTypeHandler | in file TParameterProperty.php, method TParameterProperty::setTypeHandler()
    setTypeHandler | in file TDiscriminator.php, method TDiscriminator::setTypeHandler()
    setUnderline | in file TFont.php, method TFont::setUnderline()
    setUniqueGroupName in file TRadioButton.php, method TRadioButton::setUniqueGroupName()
    Sets the unique group name that the radio button belongs to.
    setUpdateImageUrl | in file TEditCommandColumn.php, method TEditCommandColumn::setUpdateImageUrl()
    setUpdateText | in file TEditCommandColumn.php, method TEditCommandColumn::setUpdateText()
    setUpToYear | in file TDatePicker.php, method TDatePicker::setUpToYear()
    setUri | in file TSoapService.php, method TSoapServer::setUri()
    setUrlFormat in file THttpRequest.php, method THttpRequest::setUrlFormat()
    Sets the format of URLs constructed and interpretted by the request module.
    setUrlFormat in file TUrlMapping.php, method TUrlMappingPattern::setUrlFormat()
    Sets the format of URLs constructed and interpreted by this pattern.
    setUrlManager in file THttpRequest.php, method THttpRequest::setUrlManager()
    Sets the URL manager module.
    setUrlParamSeparator | in file TUrlMapping.php, method TUrlMappingPattern::setUrlParamSeparator()
    setUrlParamSeparator | in file THttpRequest.php, method THttpRequest::setUrlParamSeparator()
    setUrlPrefix | in file TUrlMapping.php, method TUrlMapping::setUrlPrefix()
    setUseCustomStorage | in file THttpSession.php, method THttpSession::setUseCustomStorage()
    setUseDefaultLayout | in file TWizard.php, method TWizard::setUseDefaultLayout()
    setUser | in file TApplication.php, method TApplication::setUser()
    setUserClass | in file TDbUserManager.php, method TDbUserManager::setUserClass()
    setUserFile | in file TUserManager.php, method TUserManager::setUserFile()
    setUserManager | in file TAuthManager.php, method TAuthManager::setUserManager()
    setUsername | in file TDbConnection.php, method TDbConnection::setUsername()
    setUsername | in file TDbCache.php, method TDbCache::setUsername()
    setUseState | in file TWebControlDecorator.php, method TWebControlDecorator::setUseState()
    setUseTransparentSessionID | in file THttpSession.php, method THttpSession::setUseTransparentSessionID()
    setValidation | in file TSecurityManager.php, method TSecurityManager::setValidation()
    setValidationGroup | in file TTextBox.php, method TTextBox::setValidationGroup()
    setValidationGroup | in file TEditCommandColumn.php, method TEditCommandColumn::setValidationGroup()
    setValidationGroup | in file TValidationSummary.php, method TValidationSummary::setValidationGroup()
    setValidationGroup | in file TLinkButton.php, method TLinkButton::setValidationGroup()
    setValidationGroup | in file TBaseValidator.php, method TBaseValidator::setValidationGroup()
    setValidationGroup | in file TImageMap.php, method THotSpot::setValidationGroup()
    setValidationGroup | in file TButton.php, method TButton::setValidationGroup()
    setValidationGroup | in file TCheckBox.php, method TCheckBox::setValidationGroup()
    setValidationGroup | in file TListControl.php, method TListControl::setValidationGroup()
    setValidationGroup | in file TButtonColumn.php, method TButtonColumn::setValidationGroup()
    setValidationGroup | in file TControl.php, method IButtonControl::setValidationGroup()
    setValidationGroup | in file TImageButton.php, method TImageButton::setValidationGroup()
    setValidationGroup | in file TBaseActiveControl.php, method TBaseActiveCallbackControl::setValidationGroup()
    setValidationKey | in file TSecurityManager.php, method TSecurityManager::setValidationKey()
    setValue | in file TListItem.php, method TListItem::setValue()
    setValue | in file TXmlDocument.php, method TXmlElement::setValue()
    setValue | in file TSlider.php, method TSlider::setValue()
    setValue in file TCache.php, method TCache::setValue()
    Stores a value identified by a key in cache.
    setValue in file TMemCache.php, method TMemCache::setValue()
    Stores a value identified by a key in cache.
    setValue | in file TCheckBox.php, method TCheckBox::setValue()
    setValue | in file TDiscriminator.php, method TSubMap::setValue()
    setValue in file TAPCCache.php, method TAPCCache::setValue()
    Stores a value identified by a key in cache.
    setValue | in file THttpRequest.php, method THttpCookie::setValue()
    setValue in file TCallbackClientScript.php, method TCallbackClientScript::setValue()
    Client script to set the value of a particular input element.
    setValue in file TXCache.php, method TXCache::setValue()
    Stores a value identified by a key in cache.
    setValue in file TNumberFormat.php, method TNumberFormat::setValue()
    Set the numberic value for this control.
    setValue in file TChoiceFormat.php, method TChoiceFormat::setValue()
    Sets the numerical choice value
    setValue in file TDateFormat.php, method TDateFormat::setValue()
    Set the date-time value for this control.
    setValue in file TSqliteCache.php, method TSqliteCache::setValue()
    Stores a value identified by a key in cache.
    setValue in file TActiveHiddenField.php, method TActiveHiddenField::setValue()
    Client-side Value property can only be updated after the OnLoad stage.
    setValue in file THiddenField.php, method THiddenField::setValue()
    Sets the value of the THiddenField
    setValue | in file TTranslateParameter.php, method TTranslateParameter::setValue()
    setValue in file TDbCache.php, method TDbCache::setValue()
    Stores a value identified by a key in cache.
    setValues in file TSlider.php, method TSlider::setValues()
    Sets the possible values that the slider can take.
    setValueToCompare in file TCompareValidator.php, method TCompareValidator::setValueToCompare()
    Sets the constant value to compare with the value entered by the user into the input component being validated.
    setVaryByParam in file TOutputCache.php, method TOutputCache::setVaryByParam()
    Sets the names of the request parameters that should be used in calculating the cache key.
    setVaryBySession | in file TOutputCache.php, method TOutputCache::setVaryBySession()
    setVersion | in file TXmlDocument.php, method TXmlDocument::setVersion()
    setVersion | in file TSoapService.php, method TSoapServer::setVersion()
    setVerticalAlign in file TTableCell.php, method TTableCell::setVerticalAlign()
    Sets the vertical alignment of the contents within the table item.
    setVerticalAlign in file TStyle.php, method TTableItemStyle::setVerticalAlign()
    Sets the vertical alignment of the contents within the table item.
    setVerticalAlign in file TTableRow.php, method TTableRow::setVerticalAlign()
    Sets the vertical alignment of the contents within the table item.
    setViewCssClass | in file TAccordion.php, method TAccordion::setViewCssClass()
    setViewCssClass | in file TTabPanel.php, method TTabPanel::setViewCssClass()
    setViewHeight | in file TAccordion.php, method TAccordion::setViewHeight()
    setViewState in file TDataGridColumn.php, method TDataGridColumn::setViewState()
    Sets a viewstate value.
    setViewState in file TControl.php, method TControl::setViewState()
    Sets a viewstate value.
    setViewState in file TImageMap.php, method THotSpot::setViewState()
    Sets a viewstate value.
    setVirtualCount | in file TPagedList.php, method TPagedList::setVirtualCount()
    setVirtualItemCount | in file TPagedDataSource.php, method TPagedDataSource::setVirtualItemCount()
    setVirtualItemCount | in file TDataBoundControl.php, method TDataBoundControl::setVirtualItemCount()
    setVisible | in file TDataGridColumn.php, method TDataGridColumn::setVisible()
    setVisible | in file TDataSourceControl.php, method TDataSourceControl::setVisible()
    setVisible | in file TControl.php, method TControl::setVisible()
    setVisible | in file TMultiView.php, method TView::setVisible()
    setVisible | in file TDataGridPagerStyle.php, method TDataGridPagerStyle::setVisible()
    setWidth | in file TWebControl.php, method TWebControl::setWidth()
    setWidth | in file TStyle.php, method TStyle::setWidth()
    setWizard in file TWizard.php, method TWizardStep::setWizard()
    Sets the wizard owning this step.
    setWrap in file TPanelStyle.php, method TPanelStyle::setWrap()
    Sets the value indicating whether the content wraps within the panel.
    setWrap in file TTextBox.php, method TTextBox::setWrap()
    Sets the value indicating whether the text content wraps within a multiline text box.
    setWrap in file TTableCell.php, method TTableCell::setWrap()
    Sets the value indicating whether the text content wraps within a table cell.
    setWrap in file TStyle.php, method TTableItemStyle::setWrap()
    Sets the value indicating whether the content wraps within the table item.
    setWrap in file TPanel.php, method TPanel::setWrap()
    Sets the value indicating whether the content wraps within the panel.
    setWriter | in file THtmlWriter.php, method THtmlWriter::setWriter()
    setWsdlUri | in file TSoapService.php, method TSoapServer::setWsdlUri()
    setX | in file TImageMap.php, method TCircleHotSpot::setX()
    setX | in file TImageButton.php, method TImageClickEventParameter::setX()
    setY | in file TImageButton.php, method TImageClickEventParameter::setY()
    setY | in file TImageMap.php, method TCircleHotSpot::setY()
    SHA1 | in file TSecurityManager.php, class constant TSecurityManagerValidationMode::SHA1
    SHA1 | in file TUserManager.php, class constant TUserManagerPasswordMode::SHA1
    shake in file TCallbackClientScript.php, method TCallbackClientScript::shake()
    Visual Effect: Shake the element.
    show in file TCallbackClientScript.php, method TCallbackClientScript::show()
    Shows an element by changing its CSS display style as empty.
    showAddView in file TScaffoldView.php, method TScaffoldView::showAddView()
    Shows the add record view.
    showEditView in file TScaffoldView.php, method TScaffoldView::showEditView()
    Shows the edit record view.
    showListView in file TScaffoldView.php, method TScaffoldView::showListView()
    Shows the view for listing the records.
    shrink in file TCallbackClientScript.php, method TCallbackClientScript::shrink()
    Visual Effect: Shrink the element.
    Simple | in file TColorPicker.php, class constant TColorPickerMode::Simple
    SimpleList | in file TValidationSummary.php, class constant TValidationSummaryDisplayMode::SimpleList
    SIMPLE_MARK in file TSqlMapXmlConfiguration.php, class constant TSqlMapXmlMappingConfiguration::SIMPLE_MARK
    Regular expressions for escaping simple/inline parameter symbols
    SIMPLE_PLACEHOLDER | in file TSqlMapXmlConfiguration.php, class constant TSqlMapXmlMappingConfiguration::SIMPLE_PLACEHOLDER
    Single | in file TListBox.php, class constant TListSelectionMode::Single
    SingleLine | in file TTextBox.php, class constant TTextBoxMode::SingleLine
    SingleParagraph | in file TValidationSummary.php, class constant TValidationSummaryDisplayMode::SingleParagraph
    SKIN_FILE_EXT in file TThemeManager.php, class constant TTheme::SKIN_FILE_EXT
    Extension name of skin files
    slideDown in file TCallbackClientScript.php, method TCallbackClientScript::slideDown()
    Visual Effect: Slide down.
    slideUp in file TCallbackClientScript.php, method TCallbackClientScript::slideUp()
    Visual Effect: Side up.
    sortPriorities in file TPriorityMap.php, method TPriorityMap::sortPriorities()
    Orders the priority list internally.
    sortPriorities in file TPriorityList.php, method TPriorityList::sortPriorities()
    This orders the priority list internally.
    SOURCE_LINES in file TErrorHandler.php, class constant TErrorHandler::SOURCE_LINES
    number of lines before and after the error line to be displayed in case of an exception
    Square | in file TBulletedList.php, class constant TBulletStyle::Square
    squish in file TCallbackClientScript.php, method TCallbackClientScript::squish()
    Visual Effect: Squish the element.
    Start | in file TWizard.php, class constant TWizardStepType::Start
    startService in file TApplication.php, method TApplication::startService()
    Starts the specified service.
    startTimer in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::startTimer()
    Registers the javascript code to start the timer.
    STATE_DEBUG | in file TApplication.php, class constant TApplication::STATE_DEBUG
    STATE_DELETED | in file TActiveRecord.php, class constant TActiveRecord::STATE_DELETED
    STATE_ENCRYPTION_KEY | in file TSecurityManager.php, class constant TSecurityManager::STATE_ENCRYPTION_KEY
    STATE_LOADED | in file TActiveRecord.php, class constant TActiveRecord::STATE_LOADED
    STATE_NEW | in file TActiveRecord.php, class constant TActiveRecord::STATE_NEW
    STATE_NORMAL | in file TApplication.php, class constant TApplication::STATE_NORMAL
    STATE_OFF in file TApplication.php, class constant TApplication::STATE_OFF
    possible application mode.
    STATE_PERFORMANCE | in file TApplication.php, class constant TApplication::STATE_PERFORMANCE
    STATE_SESSION_KEY | in file TSessionPageStatePersister.php, class constant TSessionPageStatePersister::STATE_SESSION_KEY
    STATE_VALIDATION_KEY | in file TSecurityManager.php, class constant TSecurityManager::STATE_VALIDATION_KEY
    Step | in file TWizard.php, class constant TWizardStepType::Step
    stopTimer in file TTimeTriggeredCallback.php, method TTimeTriggeredCallback::stopTimer()
    Registers the javascript code to stop the timer.
    String | in file TBaseValidator.php, class constant TValidationDataType::String
    StringLength | in file TRangeValidator.php, class constant TRangeValidationDataType::StringLength
    stripSlashes in file THttpRequest.php, method THttpRequest::stripSlashes()
    Strips slashes from input data.
    ST_AUTO in file TWizard.php, class constant TWizard::ST_AUTO
    Wizard step types.
    ST_COMPLETE | in file TWizard.php, class constant TWizard::ST_COMPLETE
    ST_FINISH | in file TWizard.php, class constant TWizard::ST_FINISH
    ST_START | in file TWizard.php, class constant TWizard::ST_START
    ST_STEP | in file TWizard.php, class constant TWizard::ST_STEP
    Submit | in file TButton.php, class constant TButtonType::Submit
    SuperGhosting | in file TDraggable.php, class constant TDraggableGhostingOptions::SuperGhosting
    supportCustomUrl | in file TUrlMapping.php, method TUrlMappingPattern::supportCustomUrl()
    switchOff in file TCallbackClientScript.php, method TCallbackClientScript::switchOff()
    Visual Effect: Switch Off effect.
    switchToGuest in file TUserManager.php, method TUserManager::switchToGuest()
    Sets a user as a guest.
    switchUser in file TAuthManager.php, method TAuthManager::switchUser()
    Switches to a new user.
    top
    t
    $trim in file TTranslateParameter.php, variable TTranslateParameter::$trim
    To trim or not to trim the contents.
    TAPCCache.php | procedural page TAPCCache.php
    TCache.php | procedural page TCache.php
    TDbCache.php | procedural page TDbCache.php
    TMemCache.php | procedural page TMemCache.php
    TSqliteCache.php | procedural page TSqliteCache.php
    TXCache.php | procedural page TXCache.php
    TAttributeCollection.php | procedural page TAttributeCollection.php
    TDummyDataSource.php | procedural page TDummyDataSource.php
    TList.php | procedural page TList.php
    TListItemCollection.php | procedural page TListItemCollection.php
    TMap.php | procedural page TMap.php
    TPagedDataSource.php | procedural page TPagedDataSource.php
    TPagedList.php | procedural page TPagedList.php
    TPriorityList.php | procedural page TPriorityList.php
    TPriorityMap.php | procedural page TPriorityMap.php
    TQueue.php | procedural page TQueue.php
    TStack.php | procedural page TStack.php
    TActiveRecordException.php | procedural page TActiveRecordException.php
    TActiveRecordBelongsTo.php | procedural page TActiveRecordBelongsTo.php
    TActiveRecordHasMany.php | procedural page TActiveRecordHasMany.php
    TActiveRecordHasManyAssociation.php | procedural page TActiveRecordHasManyAssociation.php
    TActiveRecordHasOne.php | procedural page TActiveRecordHasOne.php
    TActiveRecordRelation.php | procedural page TActiveRecordRelation.php
    TActiveRecordRelationContext.php | procedural page TActiveRecordRelationContext.php
    TIbmScaffoldInput.php | procedural page TIbmScaffoldInput.php
    TMssqlScaffoldInput.php | procedural page TMssqlScaffoldInput.php
    TMysqlScaffoldInput.php | procedural page TMysqlScaffoldInput.php
    TPgsqlScaffoldInput.php | procedural page TPgsqlScaffoldInput.php
    TScaffoldInputBase.php | procedural page TScaffoldInputBase.php
    TScaffoldInputCommon.php | procedural page TScaffoldInputCommon.php
    TSqliteScaffoldInput.php | procedural page TSqliteScaffoldInput.php
    TScaffoldBase.php | procedural page TScaffoldBase.php
    TScaffoldEditView.php | procedural page TScaffoldEditView.php
    TScaffoldListView.php | procedural page TScaffoldListView.php
    TScaffoldSearch.php | procedural page TScaffoldSearch.php
    TScaffoldView.php | procedural page TScaffoldView.php
    TActiveRecord.php | procedural page TActiveRecord.php
    TActiveRecordConfig.php | procedural page TActiveRecordConfig.php
    TActiveRecordCriteria.php | procedural page TActiveRecordCriteria.php
    TActiveRecordGateway.php | procedural page TActiveRecordGateway.php
    TActiveRecordManager.php | procedural page TActiveRecordManager.php
    TMssqlCommandBuilder.php | procedural page TMssqlCommandBuilder.php
    TMssqlMetaData.php | procedural page TMssqlMetaData.php
    TMssqlTableColumn.php | procedural page TMssqlTableColumn.php
    TMssqlTableInfo.php | procedural page TMssqlTableInfo.php
    TMysqlCommandBuilder.php | procedural page TMysqlCommandBuilder.php
    TMysqlMetaData.php | procedural page TMysqlMetaData.php
    TMysqlTableColumn.php | procedural page TMysqlTableColumn.php
    TMysqlTableInfo.php | procedural page TMysqlTableInfo.php
    TOracleCommandBuilder.php | procedural page TOracleCommandBuilder.php
    TOracleMetaData.php | procedural page TOracleMetaData.php
    TOracleTableColumn.php | procedural page TOracleTableColumn.php
    TOracleTableInfo.php | procedural page TOracleTableInfo.php
    TPgsqlCommandBuilder.php | procedural page TPgsqlCommandBuilder.php
    TPgsqlMetaData.php | procedural page TPgsqlMetaData.php
    TPgsqlTableColumn.php | procedural page TPgsqlTableColumn.php
    TPgsqlTableInfo.php | procedural page TPgsqlTableInfo.php
    TSqliteCommandBuilder.php | procedural page TSqliteCommandBuilder.php
    TSqliteMetaData.php | procedural page TSqliteMetaData.php
    TSqliteTableColumn.php | procedural page TSqliteTableColumn.php
    TSqliteTableInfo.php | procedural page TSqliteTableInfo.php
    TDbCommandBuilder.php | procedural page TDbCommandBuilder.php
    TDbMetaData.php | procedural page TDbMetaData.php
    TDbTableColumn.php | procedural page TDbTableColumn.php
    TDbTableInfo.php | procedural page TDbTableInfo.php
    TDataGatewayCommand.php | procedural page TDataGatewayCommand.php
    TSqlCriteria.php | procedural page TSqlCriteria.php
    TTableGateway.php | procedural page TTableGateway.php
    TDiscriminator.php | procedural page TDiscriminator.php
    TInlineParameterMapParser.php | procedural page TInlineParameterMapParser.php
    TParameterMap.php | procedural page TParameterMap.php
    TParameterProperty.php | procedural page TParameterProperty.php
    TResultMap.php | procedural page TResultMap.php
    TResultProperty.php | procedural page TResultProperty.php
    TSimpleDynamicParser.php | procedural page TSimpleDynamicParser.php
    TSqlMapCacheModel.php | procedural page TSqlMapCacheModel.php
    TSqlMapStatement.php | procedural page TSqlMapStatement.php
    TSqlMapXmlConfiguration.php | procedural page TSqlMapXmlConfiguration.php
    TFastSqlMapApplicationCache.php | procedural page TFastSqlMapApplicationCache.php
    TLazyLoadList.php | procedural page TLazyLoadList.php
    TPropertyAccess.php | procedural page TPropertyAccess.php
    TSqlMapCache.php | procedural page TSqlMapCache.php
    TSqlMapException.php | procedural page TSqlMapException.php
    TSqlMapPagedList.php | procedural page TSqlMapPagedList.php
    TSqlMapTypeHandlerRegistry.php | procedural page TSqlMapTypeHandlerRegistry.php
    TCachingStatement.php | procedural page TCachingStatement.php
    TDeleteMappedStatement.php | procedural page TDeleteMappedStatement.php
    TInsertMappedStatement.php | procedural page TInsertMappedStatement.php
    TMappedStatement.php | procedural page TMappedStatement.php
    TPreparedCommand.php | procedural page TPreparedCommand.php
    TPreparedStatement.php | procedural page TPreparedStatement.php
    TPreparedStatementFactory.php | procedural page TPreparedStatementFactory.php
    TSelectMappedStatement.php | procedural page TSelectMappedStatement.php
    TSimpleDynamicSql.php | procedural page TSimpleDynamicSql.php
    TStaticSql.php | procedural page TStaticSql.php
    TUpdateMappedStatement.php | procedural page TUpdateMappedStatement.php
    TSqlMapConfig.php | procedural page TSqlMapConfig.php
    TSqlMapGateway.php | procedural page TSqlMapGateway.php
    TSqlMapManager.php | procedural page TSqlMapManager.php
    TDataSourceConfig.php | procedural page TDataSourceConfig.php
    TDbCommand.php | procedural page TDbCommand.php
    TDbConnection.php | procedural page TDbConnection.php
    TDbDataReader.php | procedural page TDbDataReader.php
    TDbTransaction.php | procedural page TDbTransaction.php
    TErrorHandler.php | procedural page TErrorHandler.php
    TException.php | procedural page TException.php
    TChoiceFormat.php | procedural page TChoiceFormat.php
    TDateFormat.php | procedural page TDateFormat.php
    TGlobalization.php | procedural page TGlobalization.php
    TGlobalizationAutoDetect.php | procedural page TGlobalizationAutoDetect.php
    TI18NControl.php | procedural page TI18NControl.php
    TNumberFormat.php | procedural page TNumberFormat.php
    Translation.php | procedural page Translation.php
    TTranslate.php | procedural page TTranslate.php
    TTranslateParameter.php | procedural page TTranslateParameter.php
    TTarFileExtractor.php | procedural page TTarFileExtractor.php
    TTextWriter.php | procedural page TTextWriter.php
    TAuthManager.php | procedural page TAuthManager.php
    TAuthorizationRule.php | procedural page TAuthorizationRule.php
    TDbUserManager.php | procedural page TDbUserManager.php
    TSecurityManager.php | procedural page TSecurityManager.php
    TUser.php | procedural page TUser.php
    TUserManager.php | procedural page TUserManager.php
    Table | in file TTextHighlighter.php, class constant TTextHighlighterLineNumberStyle::Table
    Table | in file TRepeatInfo.php, class constant TRepeatLayout::Table
    TABLE_CONST in file TActiveRecordGateway.php, class constant TActiveRecordGateway::TABLE_CONST
    Constant name for specifying optional table name in TActiveRecord.
    TABLE_METHOD in file TActiveRecordGateway.php, class constant TActiveRecordGateway::TABLE_METHOD
    Method name for returning optional table name in in TActiveRecord
    TAccordion in file TAccordion.php, class TAccordion
    Class TAccordion.
    TAccordionView in file TAccordion.php, class TAccordionView
    Class TAccordionView.
    TAccordionViewCollection in file TAccordion.php, class TAccordionViewCollection
    Class TAccordionViewCollection.
    TActiveBoundColumn in file TActiveDataGrid.php, class TActiveBoundColumn
    TActiveBoundColumn class
    TActiveButton in file TActiveButton.php, class TActiveButton
    TActiveButton is the active control counter part to TButton.
    TActiveButtonColumn in file TActiveDataGrid.php, class TActiveButtonColumn
    TActiveButtonColumn class
    TActiveCheckBox in file TActiveCheckBox.php, class TActiveCheckBox
    TActiveCheckBox class.
    TActiveCheckBoxColumn in file TActiveDataGrid.php, class TActiveCheckBoxColumn
    TActiveCheckBoxColumn class
    TActiveCheckBoxList in file TActiveCheckBoxList.php, class TActiveCheckBoxList
    TActiveCheckBoxList class.
    TActiveClientScript in file TActiveClientScript.php, class TActiveClientScript
    TActiveClientScript class
    TActiveControlAdapter in file TActiveControlAdapter.php, class TActiveControlAdapter
    TActiveControlAdapter class.
    TActiveCustomValidator in file TActiveCustomValidator.php, class TActiveCustomValidator
    TActiveCustomValidator Class
    TActiveCustomValidatorClientSide in file TActiveCustomValidator.php, class TActiveCustomValidatorClientSide
    Custom Validator callback client side options class.
    TActiveDataGrid in file TActiveDataGrid.php, class TActiveDataGrid
    TActiveDataGrid class
    TActiveDataList in file TActiveDataList.php, class TActiveDataList
    TActiveDataList class
    TActiveDatePicker in file TActiveDatePicker.php, class TActiveDatePicker
    TActiveDatePicker class
    TActiveDropDownList in file TActiveDropDownList.php, class TActiveDropDownList
    TActiveDropDownList class.
    TActiveDropDownListColumn in file TActiveDataGrid.php, class TActiveDropDownListColumn
    TActiveDropDownListColumn class
    TActiveEditCommandColumn in file TActiveDataGrid.php, class TActiveEditCommandColumn
    TActiveEditCommandColumn class
    TActiveFileUpload in file TActiveFileUpload.php, class TActiveFileUpload
    TActiveFileUpload
    TActiveFileUploadCallbackParams in file TActiveFileUpload.php, class TActiveFileUploadCallbackParams
    TActiveFileUploadCallbackParams is an internal class used by TActiveFileUpload.
    TActiveHiddenField in file TActiveHiddenField.php, class TActiveHiddenField
    TActiveHiddenField class
    TActiveHyperLink in file TActiveHyperLink.php, class TActiveHyperLink
    TActiveHyperLink class.
    TActiveHyperLinkColumn in file TActiveDataGrid.php, class TActiveHyperLinkColumn
    TActiveHyperLinkColumn class
    TActiveImage in file TActiveImage.php, class TActiveImage
    TActiveImage class.
    TActiveImageButton in file TActiveImageButton.php, class TActiveImageButton
    TActiveImageButton class.
    TActiveLabel in file TActiveLabel.php, class TActiveLabel
    TActiveLabel class
    TActiveLinkButton in file TActiveLinkButton.php, class TActiveLinkButton
    TActiveLinkButton is the active control counter part to TLinkButton.
    TActiveListBox in file TActiveListBox.php, class TActiveListBox
    TActiveListBox class.
    TActiveListControlAdapter in file TActiveListControlAdapter.php, class TActiveListControlAdapter
    TActiveListControlAdapter class.
    TActiveListItemCollection in file TActiveListControlAdapter.php, class TActiveListItemCollection
    TActiveListItemCollection class.
    TActiveLiteralColumn in file TActiveDataGrid.php, class TActiveLiteralColumn
    TActiveLiteralColumn class
    TActiveMultiView in file TActiveMultiView.php, class TActiveMultiView
    TActiveMultiView class.
    TActivePageAdapter in file TActivePageAdapter.php, class TActivePageAdapter
    TActivePageAdapter class.
    TActivePager in file TActivePager.php, class TActivePager
    TActivePager is the active control counter part of TPager.
    TActivePanel in file TActivePanel.php, class TActivePanel
    TActivePanel is the TPanel active control counterpart.
    TActiveRadioButton in file TActiveRadioButton.php, class TActiveRadioButton
    TActiveRadioButton class.
    TActiveRadioButtonList in file TActiveRadioButtonList.php, class TActiveRadioButtonList
    TActiveRadioButtonList class.
    TActiveRatingList in file TActiveRatingList.php, class TActiveRatingList
    TActiveRatingList Class
    TActiveRecord in file TActiveRecord.php, class TActiveRecord
    Base class for active records.
    TActiveRecordBelongsTo in file TActiveRecordBelongsTo.php, class TActiveRecordBelongsTo
    Implements the foreign key relationship (TActiveRecord::BELONGS_TO) between the source objects and the related foreign object. Consider the entity relationship between a Team and a Player.
    TActiveRecordChangeEventParameter in file TActiveRecord.php, class TActiveRecordChangeEventParameter
    TActiveRecordChangeEventParameter class
    TActiveRecordConfig in file TActiveRecordConfig.php, class TActiveRecordConfig
    TActiveRecordConfig module configuration class.
    TActiveRecordConfigurationException in file TActiveRecordException.php, class TActiveRecordConfigurationException
    TActiveRecordConfigurationException class.
    TActiveRecordCriteria in file TActiveRecordCriteria.php, class TActiveRecordCriteria
    Search criteria for Active Record.
    TActiveRecordException in file TActiveRecordException.php, class TActiveRecordException
    Base exception class for Active Records.
    TActiveRecordGateway in file TActiveRecordGateway.php, class TActiveRecordGateway
    TActiveRecordGateway excutes the SQL command queries and returns the data record as arrays (for most finder methods).
    TActiveRecordHasMany in file TActiveRecordHasMany.php, class TActiveRecordHasMany
    Implements TActiveRecord::HAS_MANY relationship between the source object having zero or more foreign objects. Consider the entity relationship between a Team and a Player.
    TActiveRecordHasManyAssociation in file TActiveRecordHasManyAssociation.php, class TActiveRecordHasManyAssociation
    Implements the M-N (many to many) relationship via association table.
    TActiveRecordHasOne in file TActiveRecordHasOne.php, class TActiveRecordHasOne
    TActiveRecordHasOne models the object relationship that a record (the source object) property is an instance of foreign record object having a foreign key related to the source object. The HAS_ONE relation is very similar to the HAS_MANY relationship (in fact, it is equivalent in the entities relationship point of view).
    TActiveRecordInvalidFinderResult in file TActiveRecord.php, class TActiveRecordInvalidFinderResult
    TActiveRecordInvalidFinderResult class.
    TActiveRecordManager in file TActiveRecordManager.php, class TActiveRecordManager
    TActiveRecordManager provides the default DB connection, default active record gateway, and table meta data inspector.
    TActiveRecordRelation in file TActiveRecordRelation.php, class TActiveRecordRelation
    Base class for active record relationships.
    TActiveRecordRelationContext in file TActiveRecordRelationContext.php, class TActiveRecordRelationContext
    TActiveRecordRelationContext holds information regarding record relationships such as record relation property name, query criteria and foreign object record class names.
    TActiveRepeater in file TActiveRepeater.php, class TActiveRepeater
    TActiveRepeater class
    TActiveTableCell in file TActiveTableCell.php, class TActiveTableCell
    TActiveTableCell class.
    TActiveTableCellEventParameter in file TActiveTableCell.php, class TActiveTableCellEventParameter
    TActiveTableCellEventParameter class.
    TActiveTableRow in file TActiveTableRow.php, class TActiveTableRow
    TActiveTableRow class.
    TActiveTableRowEventParameter in file TActiveTableRow.php, class TActiveTableRowEventParameter
    TActiveTableRowEventParameter class.
    TActiveTemplateColumn in file TActiveDataGrid.php, class TActiveTemplateColumn
    TActiveTemplateColumn class
    TActiveTextBox in file TActiveTextBox.php, class TActiveTextBox
    TActiveTextBox class.
    TAPCCache in file TAPCCache.php, class TAPCCache
    TAPCCache class
    TApplication in file TApplication.php, class TApplication
    TApplication class.
    TApplication.php | procedural page TApplication.php
    TApplicationComponent in file TApplicationComponent.php, class TApplicationComponent
    TApplicationComponent class
    TApplicationComponent.php | procedural page TApplicationComponent.php
    TApplicationConfiguration in file TApplication.php, class TApplicationConfiguration
    TApplicationConfiguration class.
    TApplicationException in file TException.php, class TApplicationException
    TApplicationException class
    TApplicationMode in file TApplication.php, class TApplicationMode
    TApplicationMode class.
    TApplicationStateCacheDependency in file TCache.php, class TApplicationStateCacheDependency
    TApplicationStateCacheDependency class.
    TApplicationStatePersister in file TApplication.php, class TApplicationStatePersister
    TApplicationStatePersister class.
    TAssetManager in file TAssetManager.php, class TAssetManager
    TAssetManager class
    TAttributeCollection in file TAttributeCollection.php, class TAttributeCollection
    TAttributeCollection class
    TAuthManager in file TAuthManager.php, class TAuthManager
    TAuthManager class
    TAuthorizationRule in file TAuthorizationRule.php, class TAuthorizationRule
    TAuthorizationRule class
    TAuthorizationRuleCollection in file TAuthorizationRule.php, class TAuthorizationRuleCollection
    TAuthorizationRuleCollection class.
    TAutoComplete in file TAutoComplete.php, class TAutoComplete
    TAutoComplete class.
    TAutoCompleteEventParameter in file TAutoComplete.php, class TAutoCompleteEventParameter
    TAutCompleteEventParameter contains the getToken requested by the user for a partial match of the suggestions.
    TAutoCompleteTemplate in file TAutoComplete.php, class TAutoCompleteTemplate
    TAutoCompleteTemplate class.
    TBaseActiveCallbackControl in file TBaseActiveControl.php, class TBaseActiveCallbackControl
    TBaseActiveCallbackControl is a common set of options and functionality for active controls that can perform callback requests.
    TBaseActiveControl in file TBaseActiveControl.php, class TBaseActiveControl
    TBaseActiveControl class provided additional basic property for every active control. An instance of TBaseActiveControl or its decendent TBaseActiveCallbackControl is created by TActiveControlAdapter::getBaseActiveControl() method.
    TBaseDataList in file TBaseDataList.php, class TBaseDataList
    TBaseDataList class
    TBaseValidator in file TBaseValidator.php, class TBaseValidator
    TBaseValidator class
    TBoundColumn in file TBoundColumn.php, class TBoundColumn
    TBoundColumn class
    TBroadcastEventParameter in file TControl.php, class TBroadcastEventParameter
    TBroadcastEventParameter class
    TBrowserLogRoute in file TLogRouter.php, class TBrowserLogRoute
    TBrowserLogRoute class.
    TBulletedList in file TBulletedList.php, class TBulletedList
    TBulletedList class
    TBulletedListDisplayMode in file TBulletedList.php, class TBulletedListDisplayMode
    TBulletedListDisplayMode class.
    TBulletedListEventParameter in file TBulletedList.php, class TBulletedListEventParameter
    TBulletedListEventParameter Event parameter for TBulletedList::onClick event of the bulleted list. The getIndex gives the zero-based index of the item that is currently being clicked.
    TBulletStyle in file TBulletedList.php, class TBulletStyle
    TBulletStyle class.
    TButton in file TButton.php, class TButton
    TButton class
    TButtonColumn in file TButtonColumn.php, class TButtonColumn
    TButtonColumn class
    TButtonColumnType in file TDataGridColumn.php, class TButtonColumnType
    TButtonColumnType class.
    TButtonType in file TButton.php, class TButtonType
    TButtonType class.
    TCache in file TCache.php, class TCache
    TCache class
    TCacheDependency in file TCache.php, class TCacheDependency
    TCacheDependency class.
    TCacheDependencyList in file TCache.php, class TCacheDependencyList
    TCacheDependencyList class.
    TCacheHttpSession in file TCacheHttpSession.php, class TCacheHttpSession
    TCacheHttpSession class
    TCachePageStatePersister in file TCachePageStatePersister.php, class TCachePageStatePersister
    TCachePageStatePersister class
    TCachingStatement in file TCachingStatement.php, class TCachingStatement
    TCacheingStatement class.
    TCallback in file TCallback.php, class TCallback
    TCallback component class.
    TCallbackClientScript in file TCallbackClientScript.php, class TCallbackClientScript
    TCallbackClientScript class.
    TCallbackClientSide in file TCallbackClientSide.php, class TCallbackClientSide
    TCallbackClientSide class.
    TCallbackErrorHandler in file TActivePageAdapter.php, class TCallbackErrorHandler
    TCallbackErrorHandler class.
    TCallbackEventParameter in file TCallbackEventParameter.php, class TCallbackEventParameter
    TCallbackEventParameter class.
    TCallbackOptions in file TCallbackOptions.php, class TCallbackOptions
    TCallbackOptions class.
    TCallbackPageStateTracker in file TActiveControlAdapter.php, class TCallbackPageStateTracker
    TCallbackPageStateTracker class.
    TCallbackResponseAdapter in file TCallbackResponseAdapter.php, class TCallbackResponseAdapter
    TCallbackResponseAdapter alters the THttpResponse's outputs.
    TCallbackResponseWriter in file TCallbackResponseAdapter.php, class TCallbackResponseWriter
    TCallbackResponseWriter class.
    TCaptcha in file TCaptcha.php, class TCaptcha
    TCaptcha class.
    TCaptchaValidator in file TCaptchaValidator.php, class TCaptchaValidator
    TCaptchaValidator class
    TChainedCacheDependency in file TCache.php, class TChainedCacheDependency
    TChainedCacheDependency class.
    TCheckBox in file TCheckBox.php, class TCheckBox
    TCheckBox class
    TCheckBoxColumn in file TCheckBoxColumn.php, class TCheckBoxColumn
    TCheckBoxColumn class
    TCheckBoxList in file TCheckBoxList.php, class TCheckBoxList
    TCheckBoxList class
    TChoiceFormat in file TChoiceFormat.php, class TChoiceFormat
    TChoiceFormat class.
    TCircleHotSpot in file TImageMap.php, class TCircleHotSpot
    Class TCircleHotSpot.
    TClientScript in file TClientScript.php, class TClientScript
    TClientScript class
    TClientScriptManager in file TClientScriptManager.php, class TClientScriptManager
    TClientScriptManager class.
    TClientSideOptions in file TClientScriptManager.php, class TClientSideOptions
    TClientSideOptions abstract class.
    TClientSideValidationSummaryOptions in file TValidationSummary.php, class TClientSideValidationSummaryOptions
    TClientSideValidationSummaryOptions class.
    TColorPicker in file TColorPicker.php, class TColorPicker
    TColorPicker class.
    TColorPickerClientSide in file TColorPicker.php, class TColorPickerClientSide
    TColorPickerClientSide class.
    TColorPickerMode in file TColorPicker.php, class TColorPickerMode
    TColorPickerMode class.
    TCommandEventParameter in file TControl.php, class TCommandEventParameter
    TCommandEventParameter class
    TCompareValidator in file TCompareValidator.php, class TCompareValidator
    TCompareValidator class
    TCompleteWizardStep in file TWizard.php, class TCompleteWizardStep
    TCompleteWizardStep class.
    TComponent in file TComponent.php, class TComponent
    TComponent class
    TComponent.php | procedural page TComponent.php
    TComponentReflection in file TComponent.php, class TComponentReflection
    TComponentReflection class.
    TCompositeControl in file TCompositeControl.php, class TCompositeControl
    TCompositeControl class.
    TCompositeLiteral in file TControl.php, class TCompositeLiteral
    TCompositeLiteral class
    TConditional in file TConditional.php, class TConditional
    TConditional class.
    TConfigurationException in file TException.php, class TConfigurationException
    TConfigurationException class
    TContent in file TContent.php, class TContent
    TContent class
    TContentDirection in file TPanelStyle.php, class TContentDirection
    TContentDirection class.
    TContentPlaceHolder in file TContentPlaceHolder.php, class TContentPlaceHolder
    TContentPlaceHolder class
    TControl in file TControl.php, class TControl
    TControl class
    TControlAdapter in file TControlAdapter.php, class TControlAdapter
    TControlAdapter class
    TControlCollection in file TControl.php, class TControlCollection
    TControlCollection class
    TCustomValidator in file TCustomValidator.php, class TCustomValidator
    TCustomValidator class
    TDataBoundControl in file TDataBoundControl.php, class TDataBoundControl
    TDataBoundControl class.
    TDataFieldAccessor in file TDataFieldAccessor.php, class TDataFieldAccessor
    TDataFieldAccessor class
    TDataGatewayCommand in file TDataGatewayCommand.php, class TDataGatewayCommand
    TDataGatewayCommand is command builder and executor class for TTableGateway and TActiveRecordGateway.
    TDataGatewayEventParameter in file TDataGatewayCommand.php, class TDataGatewayEventParameter
    TDataGatewayEventParameter class contains the TDbCommand to be executed as well as the criteria object.
    TDataGatewayResultEventParameter in file TDataGatewayCommand.php, class TDataGatewayResultEventParameter
    TDataGatewayResultEventParameter contains the TDbCommand executed and the resulting data returned from the database. The data can be changed by changing the setResult property.
    TDataGrid in file TDataGrid.php, class TDataGrid
    TDataGrid class
    TDataGridColumn in file TDataGridColumn.php, class TDataGridColumn
    TDataGridColumn class
    TDataGridColumnCollection in file TDataGrid.php, class TDataGridColumnCollection
    TDataGridColumnCollection class.
    TDataGridCommandEventParameter in file TDataGrid.php, class TDataGridCommandEventParameter
    TDataGridCommandEventParameter class
    TDataGridItem in file TDataGrid.php, class TDataGridItem
    TDataGridItem class
    TDataGridItemCollection in file TDataGrid.php, class TDataGridItemCollection
    TDataGridItemCollection class.
    TDataGridItemEventParameter in file TDataGrid.php, class TDataGridItemEventParameter
    TDataGridItemEventParameter class
    TDataGridItemRenderer in file TDataGridItemRenderer.php, class TDataGridItemRenderer
    TDataGridItemRenderer class
    TDataGridPageChangedEventParameter in file TDataGrid.php, class TDataGridPageChangedEventParameter
    TDataGridPageChangedEventParameter class
    TDataGridPager in file TDataGrid.php, class TDataGridPager
    TDataGridPager class.
    TDataGridPagerButtonType in file TDataGrid.php, class TDataGridPagerButtonType
    TDataGridPagerButtonType class.
    TDataGridPagerEventParameter in file TDataGrid.php, class TDataGridPagerEventParameter
    TDataGridPagerEventParameter class
    TDataGridPagerMode in file TDataGrid.php, class TDataGridPagerMode
    TDataGridPagerMode class.
    TDataGridPagerPosition in file TDataGrid.php, class TDataGridPagerPosition
    TDataGridPagerPosition class.
    TDataGridPagerStyle in file TDataGridPagerStyle.php, class TDataGridPagerStyle
    TDataGridPagerStyle class.
    TDataGridSortCommandEventParameter in file TDataGrid.php, class TDataGridSortCommandEventParameter
    TDataGridSortCommandEventParameter class
    TDataList in file TDataList.php, class TDataList
    TDataList class
    TDataListCommandEventParameter in file TDataList.php, class TDataListCommandEventParameter
    TDataListCommandEventParameter class
    TDataListItem in file TDataList.php, class TDataListItem
    TDataListItem class
    TDataListItemCollection in file TDataList.php, class TDataListItemCollection
    TDataListItemCollection class.
    TDataListItemEventParameter in file TDataList.php, class TDataListItemEventParameter
    TDataListItemEventParameter class
    TDataListItemRenderer in file TDataListItemRenderer.php, class TDataListItemRenderer
    TDataListItemRenderer class
    TDataRenderer in file TDataRenderer.php, class TDataRenderer
    TDataRenderer class
    TDataSourceConfig in file TDataSourceConfig.php, class TDataSourceConfig
    TDataSourceConfig module class provides <module> configuration for database connections.
    TDataSourceControl in file TDataSourceControl.php, class TDataSourceControl
    TDataSourceControl class
    TDataSourceSelectParameters in file TDataSourceView.php, class TDataSourceSelectParameters
    TDataSourceSelectParameters class
    TDataSourceView in file TDataSourceView.php, class TDataSourceView
    TDataSourceView class
    TDataTypeValidator in file TDataTypeValidator.php, class TDataTypeValidator
    TDataTypeValidator class
    TDateFormat in file TDateFormat.php, class TDateFormat
    To format dates and/or time according to the current locale use
    TDatePicker in file TDatePicker.php, class TDatePicker
    TDatePicker class.
    TDatePickerClientScript in file TDatePicker.php, class TDatePickerClientScript
    TDatePickerClientScript class.
    TDatePickerInputMode in file TDatePicker.php, class TDatePickerInputMode
    TDatePickerInputMode class.
    TDatePickerMode in file TDatePicker.php, class TDatePickerMode
    TDatePickerMode class.
    TDatePickerPositionMode in file TDatePicker.php, class TDatePickerPositionMode
    TDatePickerPositionMode class.
    TDateTimeStamp in file TDateTimeStamp.php, class TDateTimeStamp
    TDateTimeStamp Class
    TDbCache in file TDbCache.php, class TDbCache
    TDbCache class
    TDbColumnCaseMode in file TDbConnection.php, class TDbColumnCaseMode
    TDbColumnCaseMode
    TDbCommand in file TDbCommand.php, class TDbCommand
    TDbCommand class.
    TDbCommandBuilder in file TDbCommandBuilder.php, class TDbCommandBuilder
    TDbCommandBuilder provides basic methods to create query commands for tables giving by setTableInfo the property.
    TDbConnection in file TDbConnection.php, class TDbConnection
    TDbConnection class
    TDbConnectionException in file TException.php, class TDbConnectionException
    TDbConnectionException class
    TDbDataReader in file TDbDataReader.php, class TDbDataReader
    TDbDataReader class.
    TDbException in file TException.php, class TDbException
    TDbException class
    TDbLogRoute in file TLogRouter.php, class TDbLogRoute
    TDbLogRoute class
    TDbMetaData in file TDbMetaData.php, class TDbMetaData
    TDbMetaData is the base class for retrieving metadata information, such as table and columns information, from a database connection.
    TDbNullConversionMode in file TDbConnection.php, class TDbNullConversionMode
    TDbNullConversionMode
    TDbTableColumn in file TDbTableColumn.php, class TDbTableColumn
    TDbTableColumn class describes the column meta data of the schema for a database table.
    TDbTableInfo in file TDbTableInfo.php, class TDbTableInfo
    TDbTableInfo class describes the meta data of a database table.
    TDbTransaction in file TDbTransaction.php, class TDbTransaction
    TDbTransaction class.
    TDbUser in file TDbUserManager.php, class TDbUser
    TDbUser class
    TDbUserManager in file TDbUserManager.php, class TDbUserManager
    TDbUserManager class
    TDeleteMappedStatement in file TDeleteMappedStatement.php, class TDeleteMappedStatement
    TDeleteMappedStatement class.
    TDirectoryCacheDependency in file TCache.php, class TDirectoryCacheDependency
    TDirectoryCacheDependency class.
    TDiscriminator in file TDiscriminator.php, class TDiscriminator
    The TDiscriminator corresponds to the <discriminator> tag within a <resultMap>.
    TDisplayStyle in file TStyle.php, class TDisplayStyle
    TDisplayStyle defines the enumerable type for the possible styles that a web control can display.
    TDraggable in file TDraggable.php, class TDraggable
    TDraggable is a control which can be dragged
    TDraggableConstraint | in file TDraggable.php, class TDraggableConstraint
    TDraggableGhostingOptions | in file TDraggable.php, class TDraggableGhostingOptions
    TDraggableRevertOptions | in file TDraggable.php, class TDraggableRevertOptions
    TDropContainer in file TDropContainer.php, class TDropContainer
    TDropContainer is a panel where TDraggable controls can be dropped.
    TDropContainerEventParameter in file TDropContainer.php, class TDropContainerEventParameter
    TDropContainerEventParameter class
    TDropDownList in file TDropDownList.php, class TDropDownList
    TDropDownList class
    TDropDownListColumn in file TDropDownListColumn.php, class TDropDownListColumn
    TDropDownListColumn class
    TDummyDataSource in file TDummyDataSource.php, class TDummyDataSource
    TDummyDataSource class
    TDummyDataSourceIterator in file TDummyDataSource.php, class TDummyDataSourceIterator
    TDummyDataSourceIterator class
    TEditCommandColumn in file TEditCommandColumn.php, class TEditCommandColumn
    TEditCommandColumn class
    TEmailAddressValidator in file TEmailAddressValidator.php, class TEmailAddressValidator
    TEmailAddressValidator class
    TEmailLogRoute in file TLogRouter.php, class TEmailLogRoute
    TEmailLogRoute class.
    TEMPLATE_CACHE_PREFIX in file TTemplateManager.php, class constant TTemplateManager::TEMPLATE_CACHE_PREFIX
    Prefix of the cache variable name for storing parsed templates
    TEMPLATE_FILE_EXT in file TTemplateManager.php, class constant TTemplateManager::TEMPLATE_FILE_EXT
    Template file extension
    TEmptyControlCollection in file TControl.php, class TEmptyControlCollection
    TEmptyControlCollection class
    TEnumerable in file TComponent.php, class TEnumerable
    TEnumerable class.
    TErrorHandler in file TErrorHandler.php, class TErrorHandler
    TErrorHandler class
    TEventParameter in file TComponent.php, class TEventParameter
    TEventParameter class.
    TEventTriggeredCallback in file TEventTriggeredCallback.php, class TEventTriggeredCallback
    TEventTriggeredCallback Class
    TException in file TException.php, class TException
    TException class
    TExpression in file TExpression.php, class TExpression
    TExpression class
    Text | in file TBulletedList.php, class constant TBulletedListDisplayMode::Text
    TextBox | in file TDatePicker.php, class constant TDatePickerInputMode::TextBox
    TFastSqlMapApplicationCache in file TFastSqlMapApplicationCache.php, class TFastSqlMapApplicationCache
    TFastSqlMapApplicationCache class file
    TFeedService in file TFeedService.php, class TFeedService
    TFeedService class
    TFileCacheDependency in file TCache.php, class TFileCacheDependency
    TFileCacheDependency class.
    TFileLogRoute in file TLogRouter.php, class TFileLogRoute
    TFileLogRoute class.
    TFileUpload in file TFileUpload.php, class TFileUpload
    TFileUpload class
    TFirebugLogRoute in file TLogRouter.php, class TFirebugLogRoute
    TFirebugLogRoute class.
    TFirePhpLogRoute in file TLogRouter.php, class TFirePhpLogRoute
    TFirePhpLogRoute class.
    TFlushOutput in file TFlushOutput.php, class TFlushOutput
    TFlushOutput class.
    TFont in file TFont.php, class TFont
    TFont class
    TForm in file TForm.php, class TForm
    TForm class
    TGlobalization in file TGlobalization.php, class TGlobalization
    TGlobalization contains settings for Culture, Charset and TranslationConfiguration.
    TGlobalizationAutoDetect in file TGlobalizationAutoDetect.php, class TGlobalizationAutoDetect
    TGlobalizationAutoDetect class will automatically try to resolve the default culture using the user browser language settings.
    TGlobalStateCacheDependency in file TCache.php, class TGlobalStateCacheDependency
    TGlobalStateCacheDependency class.
    THead in file THead.php, class THead
    THead class
    THeader1 in file THeader1.php, class THeader1
    THeader1 class
    THeader2 in file THeader2.php, class THeader2
    THeader2 class
    THeader3 in file THeader3.php, class THeader3
    THeader3 class
    THeader4 in file THeader4.php, class THeader4
    THeader4 class
    THeader5 in file THeader5.php, class THeader5
    THeader5 class
    THeader6 in file THeader6.php, class THeader6
    THeader6 class
    THEME_CACHE_PREFIX in file TThemeManager.php, class constant TTheme::THEME_CACHE_PREFIX
    prefix for cache variable name used to store parsed themes
    THiddenField in file THiddenField.php, class THiddenField
    THiddenField class
    THorizontalAlign in file TStyle.php, class THorizontalAlign
    THorizontalAlign class.
    THotSpot in file TImageMap.php, class THotSpot
    THotSpot class.
    THotSpotCollection in file TImageMap.php, class THotSpotCollection
    THotSpotCollection class.
    THotSpotMode in file TImageMap.php, class THotSpotMode
    THotSpotMode class.
    THtmlArea in file THtmlArea.php, class THtmlArea
    THtmlArea class
    THtmlElement in file THtmlElement.php, class THtmlElement
    THtmlElement class.
    THtmlWriter in file THtmlWriter.php, class THtmlWriter
    THtmlWriter class
    THttpCookie in file THttpRequest.php, class THttpCookie
    THttpCookie class.
    THttpCookieCollection in file THttpRequest.php, class THttpCookieCollection
    THttpCookieCollection class.
    THttpException in file TException.php, class THttpException
    THttpException class
    THttpRequest in file THttpRequest.php, class THttpRequest
    THttpRequest class
    THttpRequestUrlFormat in file THttpRequest.php, class THttpRequestUrlFormat
    THttpRequestUrlFormat class.
    THttpResponse in file THttpResponse.php, class THttpResponse
    THttpResponse class
    THttpResponseAdapter in file THttpResponseAdapter.php, class THttpResponseAdapter
    THttpResponseAdapter class.
    THttpSession in file THttpSession.php, class THttpSession
    THttpSession class
    THttpSessionCookieMode in file THttpSession.php, class THttpSessionCookieMode
    THttpSessionCookieMode class.
    THttpUtility in file THttpUtility.php, class THttpUtility
    THttpUtility class
    THyperLink in file THyperLink.php, class THyperLink
    THyperLink class
    THyperLinkColumn in file THyperLinkColumn.php, class THyperLinkColumn
    THyperLinkColumn class
    TI18NControl in file TI18NControl.php, class TI18NControl
    TI18NControl class.
    TIbmScaffoldInput in file TIbmScaffoldInput.php, class TIbmScaffoldInput
    TIbmScaffoldInput class file.
    TImage in file TImage.php, class TImage
    TImage class
    TImageButton in file TImageButton.php, class TImageButton
    TImageButton class
    TImageClickEventParameter in file TImageButton.php, class TImageClickEventParameter
    TImageClickEventParameter class
    TImageMap in file TImageMap.php, class TImageMap
    TImageMap class
    TImageMapEventParameter in file TImageMap.php, class TImageMapEventParameter
    TImageMapEventParameter class.
    TInlineFrame in file TInlineFrame.php, class TInlineFrame
    TInlineFrame class
    TInlineFrameAlign in file TInlineFrame.php, class TInlineFrameAlign
    TInlineFrameAlign class.
    TInlineFrameScrollBars in file TInlineFrame.php, class TInlineFrameScrollBars
    TInlineFrameScrollBars class.
    TInlineParameterMapParser in file TInlineParameterMapParser.php, class TInlineParameterMapParser
    TInlineParameterMapParser class.
    TInPlaceTextBox in file TInPlaceTextBox.php, class TInPlaceTextBox
    TInPlaceTextBox Class
    TInsertMappedStatement in file TInsertMappedStatement.php, class TInsertMappedStatement
    TInsertMappedStatement class.
    TInvalidCallbackException in file TActivePageAdapter.php, class TInvalidCallbackException
    TInvalidCallbackException class.
    TInvalidDataTypeException in file TException.php, class TInvalidDataTypeException
    TInvalidDataTypeException class
    TInvalidDataValueException in file TException.php, class TInvalidDataValueException
    TInvalidDataValueException class
    TInvalidOperationException in file TException.php, class TInvalidOperationException
    TInvalidOperationException class
    TInvalidPropertyException in file TSqlMapException.php, class TInvalidPropertyException
    TInvalidPropertyException, raised when setting or getting an invalid property.
    TIOException in file TException.php, class TIOException
    TIOException class
    TItemDataRenderer in file TItemDataRenderer.php, class TItemDataRenderer
    TItemDataRenderer class
    TJavaScript in file TJavaScript.php, class TJavaScript
    TJavaScript class.
    TJavaScriptLiteral in file TComponent.php, class TJavaScriptLiteral
    TJavaScriptLiteral class that encloses string literals that are not supposed to be escaped by TJavaScript::encode()
    TJavascriptLogger in file TJavascriptLogger.php, class TJavascriptLogger
    TJavascriptLogger class.
    TJavaScriptString in file TComponent.php, class TJavaScriptString
    TJavaScriptString class is an internal class that marks strings that will be forcibly encoded when rendered inside a javascript block
    TJsonResponse in file TJsonService.php, class TJsonResponse
    TJsonResponse Class
    TJsonRpcClient in file TRpcClient.php, class TJsonRpcClient
    TJsonRpcClient class
    TJsonRpcProtocol in file TRpcService.php, class TJsonRpcProtocol
    TJsonRpcProtocol class
    TJsonService in file TJsonService.php, class TJsonService
    TJsonService class provides to end-users javascript content response in JSON format.
    TKeyboard in file TKeyboard.php, class TKeyboard
    Class TKeyboard.
    TLabel in file TLabel.php, class TLabel
    TLabel class
    TLazyLoadList in file TLazyLoadList.php, class TLazyLoadList
    TLazyLoadList executes mapped statements when the proxy collection is first accessed.
    TLinkButton in file TLinkButton.php, class TLinkButton
    TLinkButton class
    TList in file TList.php, class TList
    TList class
    TListBox in file TListBox.php, class TListBox
    TListBox class
    TListControl in file TListControl.php, class TListControl
    TListControl class
    TListControlValidator in file TListControlValidator.php, class TListControlValidator
    TListControlValidator class.
    TListItem in file TListItem.php, class TListItem
    TListItem class.
    TListItemCollection in file TListItemCollection.php, class TListItemCollection
    TListItemCollection class.
    TListItemType in file TDataBoundControl.php, class TListItemType
    TListItemType class.
    TListIterator in file TList.php, class TListIterator
    TListIterator class
    TListSelectionMode in file TListBox.php, class TListSelectionMode
    TListSelectionMode class.
    TLiteral in file TLiteral.php, class TLiteral
    TLiteral class
    TLiteralColumn in file TLiteralColumn.php, class TLiteralColumn
    TLiteralColumn class
    TLogger in file TLogger.php, class TLogger
    TLogger class.
    TLogRoute in file TLogRouter.php, class TLogRoute
    TLogRoute class.
    TLogRouter in file TLogRouter.php, class TLogRouter
    TLogRouter class.
    TMap in file TMap.php, class TMap
    TMap class
    TMapCollectionDiff in file TActiveControlAdapter.php, class TMapCollectionDiff
    TAttributesDiff class.
    TMapIterator in file TMap.php, class TMapIterator
    TMapIterator class
    TMappedStatement in file TMappedStatement.php, class TMappedStatement
    TMappedStatement class executes SQL mapped statements. Mapped Statements can hold any SQL statement and use Parameter Maps and Result Maps for input and output.
    TMarkdown in file TMarkdown.php, class TMarkdown
    TMarkdown class
    TMemCache in file TMemCache.php, class TMemCache
    TMemCache class
    TMetaTag in file THead.php, class TMetaTag
    TMetaTag class.
    TMetaTagCollection in file THead.php, class TMetaTagCollection
    TMetaTagCollection class
    TModule in file TModule.php, class TModule
    TModule class.
    TModule.php | procedural page TModule.php
    TMssqlCommandBuilder in file TMssqlCommandBuilder.php, class TMssqlCommandBuilder
    TMssqlCommandBuilder provides specifics methods to create limit/offset query commands for MSSQL servers.
    TMssqlMetaData in file TMssqlMetaData.php, class TMssqlMetaData
    TMssqlMetaData loads MSSQL database table and column information.
    TMssqlScaffoldInput in file TMssqlScaffoldInput.php, class TMssqlScaffoldInput
    TMssqlScaffoldInput class file.
    TMssqlTableColumn in file TMssqlTableColumn.php, class TMssqlTableColumn
    Describes the column metadata of the schema for a Mssql database table.
    TMssqlTableInfo in file TMssqlTableInfo.php, class TMssqlTableInfo
    TMssqlTableInfo class provides additional table information for Mssql database.
    TMultiView in file TMultiView.php, class TMultiView
    TMultiView class
    TMysqlCommandBuilder in file TMysqlCommandBuilder.php, class TMysqlCommandBuilder
    TMysqlCommandBuilder implements default TDbCommandBuilder
    TMysqlMetaData in file TMysqlMetaData.php, class TMysqlMetaData
    TMysqlMetaData loads Mysql version 4.1.x and 5.x database table and column information.
    TMysqlScaffoldInput in file TMysqlScaffoldInput.php, class TMysqlScaffoldInput
    TMysqlScaffoldInput class file.
    TMysqlTableColumn in file TMysqlTableColumn.php, class TMysqlTableColumn
    Describes the column metadata of the schema for a Mysql database table.
    TMysqlTableInfo in file TMysqlTableInfo.php, class TMysqlTableInfo
    TMysqlTableInfo class provides additional table information for MySQL database.
    TNotSupportedException in file TException.php, class TNotSupportedException
    TNotSupportedException class
    TNumberFormat in file TNumberFormat.php, class TNumberFormat
    To format numbers in locale sensitive manner use
    toArray | in file THttpSession.php, method THttpSession::toArray()
    toArray | in file TList.php, method TList::toArray()
    toArray | in file TStack.php, method TStack::toArray()
    toArray | in file TPriorityList.php, method TPriorityList::toArray()
    toArray | in file TPagedList.php, method TPagedList::toArray()
    toArray | in file THttpRequest.php, method THttpRequest::toArray()
    toArray in file TPriorityMap.php, method TPriorityMap::toArray()
    When the map is flattened into an array, the priorities are taken into account and elements of the map are ordered in the array according to their priority.
    toArray | in file TMap.php, method TMap::toArray()
    toArray | in file TQueue.php, method TQueue::toArray()
    toArrayAbovePriority in file TPriorityList.php, method TPriorityList::toArrayAbovePriority()
    Combines the map elements which have a priority above the parameter value
    toArrayAbovePriority in file TPriorityMap.php, method TPriorityMap::toArrayAbovePriority()
    Combines the map elements which have a priority above the parameter value
    toArrayBelowPriority in file TPriorityMap.php, method TPriorityMap::toArrayBelowPriority()
    Combines the map elements which have a priority below the parameter value
    toArrayBelowPriority in file TPriorityList.php, method TPriorityList::toArrayBelowPriority()
    Combines the map elements which have a priority below the parameter value
    TObjectProxy in file TLazyLoadList.php, class TObjectProxy
    TObjectProxy sets up a simple object that intercepts method calls to a particular object and relays the call to handler object.
    toggle in file TCallbackClientScript.php, method TCallbackClientScript::toggle()
    Toggles the visibility of the element.
    toJavaScriptLiteral | in file TComponent.php, method TJavaScriptString::toJavaScriptLiteral()
    toJavaScriptLiteral | in file TComponent.php, method TJavaScriptLiteral::toJavaScriptLiteral()
    Top | in file TInlineFrame.php, class constant TInlineFrameAlign::Top
    Top | in file TDataGrid.php, class constant TDataGridPagerPosition::Top
    Top | in file TDatePicker.php, class constant TDatePickerPositionMode::Top
    Top | in file TStyle.php, class constant TVerticalAlign::Top
    Top | in file TTable.php, class constant TTableCaptionAlign::Top
    TopAndBottom | in file TDataGrid.php, class constant TDataGridPagerPosition::TopAndBottom
    toPriorityArray | in file TPriorityList.php, method TPriorityList::toPriorityArray()
    TOracleCommandBuilder in file TOracleCommandBuilder.php, class TOracleCommandBuilder
    TOracleCommandBuilder provides specifics methods to create limit/offset query commands for Oracle database.
    TOracleMetaData in file TOracleMetaData.php, class TOracleMetaData
    TOracleMetaData loads Oracle database table and column information.
    TOracleTableColumn in file TOracleTableColumn.php, class TOracleTableColumn
    Describes the column metadata of the schema for a PostgreSQL database table.
    TOracleTableInfo in file TOracleTableInfo.php, class TOracleTableInfo
    TDbTableInfo class describes the meta data of a database table.
    toString | in file TFont.php, method TFont::toString()
    toString | in file TXmlDocument.php, method TXmlElement::toString()
    TOutputCache in file TOutputCache.php, class TOutputCache
    TOutputCache class.
    TOutputCacheCalculateKeyEventParameter in file TOutputCache.php, class TOutputCacheCalculateKeyEventParameter
    TOutputCacheCalculateKeyEventParameter class
    TOutputCacheCheckDependencyEventParameter in file TOutputCache.php, class TOutputCacheCheckDependencyEventParameter
    TOutputCacheCheckDependencyEventParameter class
    TOutputCacheTextWriterMulti in file TOutputCache.php, class TOutputCacheTextWriterMulti
    TTextWriter class.
    TPage in file TPage.php, class TPage
    TPage class
    TPageConfiguration in file TPageService.php, class TPageConfiguration
    TPageConfiguration class
    TPagedDataSource in file TPagedDataSource.php, class TPagedDataSource
    TPagedDataSource class
    TPagedList in file TPagedList.php, class TPagedList
    TPagedList class
    TPagedListFetchDataEventParameter in file TPagedList.php, class TPagedListFetchDataEventParameter
    TPagedListFetchDataEventParameter class.
    TPagedListIterator in file TPagedDataSource.php, class TPagedListIterator
    TPagedListIterator class
    TPagedListPageChangedEventParameter in file TPagedList.php, class TPagedListPageChangedEventParameter
    TPagedListPageChangedEventParameter class.
    TPagedMapIterator in file TPagedDataSource.php, class TPagedMapIterator
    TPagedMapIterator class
    TPager in file TPager.php, class TPager
    TPager class.
    TPagerButtonType in file TPager.php, class TPagerButtonType
    TPagerButtonType class.
    TPagerMode in file TPager.php, class TPagerMode
    TPagerMode class.
    TPagerPageChangedEventParameter in file TPager.php, class TPagerPageChangedEventParameter
    TPagerPageChangedEventParameter class
    TPageService in file TPageService.php, class TPageService
    TPageService class.
    TPageStateFormatter in file TPage.php, class TPageStateFormatter
    TPageStateFormatter class.
    TPageStatePersister in file TPageStatePersister.php, class TPageStatePersister
    TPageStatePersister class
    TPanel in file TPanel.php, class TPanel
    TPanel class
    TPanelStyle in file TPanelStyle.php, class TPanelStyle
    TPanelStyle class.
    TParameterMap in file TParameterMap.php, class TParameterMap
    TParameterMap corresponds to the <parameterMap> element.
    TParameterModule in file TParameterModule.php, class TParameterModule
    TParameterModule class
    TParameterProperty in file TParameterProperty.php, class TParameterProperty
    TParameterProperty corresponds to the <property> tag and defines one object property for the <parameterMap>
    TPgsqlCommandBuilder in file TPgsqlCommandBuilder.php, class TPgsqlCommandBuilder
    TPgsqlCommandBuilder provides specifics methods to create limit/offset query commands for Pgsql database.
    TPgsqlMetaData in file TPgsqlMetaData.php, class TPgsqlMetaData
    TPgsqlMetaData loads PostgreSQL database table and column information.
    TPgsqlScaffoldInput in file TPgsqlScaffoldInput.php, class TPgsqlScaffoldInput
    TPgsqlScaffoldInput class file.
    TPgsqlTableColumn in file TPgsqlTableColumn.php, class TPgsqlTableColumn
    Describes the column metadata of the schema for a PostgreSQL database table.
    TPgsqlTableInfo in file TPgsqlTableInfo.php, class TPgsqlTableInfo
    TPgsqlTableInfo class provides additional table information for PostgreSQL database.
    TPhpErrorException in file TException.php, class TPhpErrorException
    TPhpErrorException class
    TPlaceHolder in file TPlaceHolder.php, class TPlaceHolder
    TPlaceHolder class
    TPolygonHotSpot in file TImageMap.php, class TPolygonHotSpot
    Class TPolygonHotSpot.
    TPostSelectBinding in file TMappedStatement.php, class TPostSelectBinding
    TPostSelectBinding class.
    TPreparedCommand in file TPreparedCommand.php, class TPreparedCommand
    TPreparedCommand class.
    TPreparedStatement in file TPreparedStatement.php, class TPreparedStatement
    TpreparedStatement class.
    TPreparedStatementFactory in file TPreparedStatementFactory.php, class TPreparedStatementFactory
    TPreparedStatementFactory class.
    TPriorityList in file TPriorityList.php, class TPriorityList
    TPriorityList class
    TPriorityMap in file TPriorityMap.php, class TPriorityMap
    TPriorityMap class
    TPropertyAccess in file TPropertyAccess.php, class TPropertyAccess
    TPropertyAccess class provides dot notation stype property access and setting.
    TPropertyValue in file TComponent.php, class TPropertyValue
    TPropertyValue class
    TQueue in file TQueue.php, class TQueue
    TQueue class
    TQueueIterator in file TQueue.php, class TQueueIterator
    TQueueIterator class
    trace in file PradoBase.php, method PradoBase::trace()
    Writes a log message.
    trackChanges in file TActiveControlAdapter.php, method TCallbackPageStateTracker::trackChanges()
    Start tracking view state changes. The clone function on objects are called for those viewstate having an object as value.
    trackViewState in file TControl.php, method TControl::trackViewState()
    Sets a value indicating whether we should keep data in viewstate.
    TRadioButton in file TRadioButton.php, class TRadioButton
    TRadioButton class
    TRadioButtonList in file TRadioButtonList.php, class TRadioButtonList
    TRadioButtonList class
    TRangeValidationDataType in file TRangeValidator.php, class TRangeValidationDataType
    TRangeValidationDataType class.
    TRangeValidator in file TRangeValidator.php, class TRangeValidator
    TRangeValidator class
    translateErrorMessage in file TException.php, method TException::translateErrorMessage()
    Translates an error code into an error message.
    translateLogLevel in file TLogRouter.php, method TFirePhpLogRoute::translateLogLevel()
    Translates a PRADO log level attribute into one understood by FirePHP for correct visualization
    translateText in file TTranslate.php, method TTranslate::translateText()
    Translates the text with subsititution.
    translateText in file TChoiceFormat.php, method TChoiceFormat::translateText()
    Display the choosen translated string.
    Translation in file Translation.php, class Translation
    Translation class.
    trapCallbackErrorsExceptions in file TActivePageAdapter.php, method TActivePageAdapter::trapCallbackErrorsExceptions()
    Trap errors and exceptions to be handled by TCallbackErrorHandler.
    TRatingList in file TRatingList.php, class TRatingList
    TRatingList class.
    traverseChildControls in file TControl.php, method TControl::traverseChildControls()
    Traverse the whole control hierarchy rooted at this control.
    TReadOnlyDataSource in file TDataSourceControl.php, class TReadOnlyDataSource
    TDataSourceControl class
    TReadOnlyDataSourceView in file TDataSourceView.php, class TReadOnlyDataSourceView
    TReadOnlyDataSourceView class
    TReCaptcha in file TReCaptcha.php, class TReCaptcha
    TReCaptcha class.
    TReCaptchaValidator in file TReCaptchaValidator.php, class TReCaptchaValidator
    TReCaptchaValidator class
    TRectangleHotSpot in file TImageMap.php, class TRectangleHotSpot
    Class TRectangleHotSpot.
    TRegularExpressionValidator in file TRegularExpressionValidator.php, class TRegularExpressionValidator
    TRegularExpressionValidator class
    TRepeatDirection in file TRepeatInfo.php, class TRepeatDirection
    TRepeatDirection class.
    TRepeater in file TRepeater.php, class TRepeater
    TRepeater class.
    TRepeaterCommandEventParameter in file TRepeater.php, class TRepeaterCommandEventParameter
    TRepeaterCommandEventParameter class
    TRepeaterItem in file TRepeater.php, class TRepeaterItem
    TRepeaterItem class
    TRepeaterItemCollection in file TRepeater.php, class TRepeaterItemCollection
    TRepeaterItemCollection class.
    TRepeaterItemEventParameter in file TRepeater.php, class TRepeaterItemEventParameter
    TRepeaterItemEventParameter class
    TRepeaterItemRenderer in file TRepeaterItemRenderer.php, class TRepeaterItemRenderer
    TRepeaterItemRenderer class
    TRepeatInfo in file TRepeatInfo.php, class TRepeatInfo
    TRepeatInfo class.
    TRepeatLayout in file TRepeatInfo.php, class TRepeatLayout
    TRepeatLayout class.
    TRequiredFieldValidator in file TRequiredFieldValidator.php, class TRequiredFieldValidator
    TRequiredFieldValidator class
    TResultMap in file TResultMap.php, class TResultMap
    TResultMap corresponds to <resultMap> mapping tag.
    TResultProperty in file TResultProperty.php, class TResultProperty
    TResultProperty corresponds a <property> tags inside a <resultMap> tag.
    TResultSetListItemParameter in file TMappedStatement.php, class TResultSetListItemParameter
    TResultSetListItemParameter class
    TResultSetMapItemParameter in file TMappedStatement.php, class TResultSetMapItemParameter
    TResultSetMapItemParameter class.
    TRpcApiProvider in file TRpcService.php, class TRpcApiProvider
    TRpcApiProvider class
    TRpcClient in file TRpcClient.php, class TRpcClient
    TRpcClient class
    TRpcClientRequestException in file TRpcClient.php, class TRpcClientRequestException
    TRpcClientRequestException class
    TRpcClientResponseException in file TRpcClient.php, class TRpcClientResponseException
    TRpcClientResponseException class
    TRpcClientTypesEnumerable in file TRpcClient.php, class TRpcClientTypesEnumerable
    TRpcClientTypesEnumerable class
    TRpcException in file TRpcService.php, class TRpcException
    TRpcException class
    TRpcProtocol in file TRpcService.php, class TRpcProtocol
    TRpcProtocol class
    TRpcServer in file TRpcService.php, class TRpcServer
    TRpcServer class
    TRpcService in file TRpcService.php, class TRpcService
    TRpcService class
    TSafeHtml in file TSafeHtml.php, class TSafeHtml
    TSafeHtml class
    TScaffoldBase in file TScaffoldBase.php, class TScaffoldBase
    Base class for Active Record scaffold views.
    TScaffoldEditView in file TScaffoldEditView.php, class TScaffoldEditView
    Template control for editing an Active Record instance.
    TScaffoldInputBase in file TScaffoldInputBase.php, class TScaffoldInputBase
    TScaffoldInputBase class file.
    TScaffoldInputCommon in file TScaffoldInputCommon.php, class TScaffoldInputCommon
    TScaffoldInputCommon class file.
    TScaffoldListView in file TScaffoldListView.php, class TScaffoldListView
    TScaffoldListView displays a list of Active Records.
    TScaffoldSearch in file TScaffoldSearch.php, class TScaffoldSearch
    TScaffoldSearch provide a simple textbox and a button that is used to perform search on a TScaffoldListView with ID given by setListViewID.
    TScaffoldView in file TScaffoldView.php, class TScaffoldView
    TScaffoldView is a composite control consisting of TScaffoldListView
    TScalarDiff in file TActiveControlAdapter.php, class TScalarDiff
    TScalarDiff class.
    TScrollBars in file TPanelStyle.php, class TScrollBars
    TScrollBars class.
    TSecurityManager in file TSecurityManager.php, class TSecurityManager
    TSecurityManager class
    TSecurityManagerValidationMode in file TSecurityManager.php, class TSecurityManagerValidationMode
    TSecurityManagerValidationMode class.
    TSelectMappedStatement in file TSelectMappedStatement.php, class TSelectMappedStatement
    TSelectMappedStatment class.
    TServerValidateEventParameter in file TCustomValidator.php, class TServerValidateEventParameter
    TServerValidateEventParameter class
    TService in file TService.php, class TService
    TService class.
    TService.php | procedural page TService.php
    TSessionIterator in file THttpSession.php, class TSessionIterator
    TSessionIterator class
    TSessionPageStatePersister in file TSessionPageStatePersister.php, class TSessionPageStatePersister
    TSessionPageStatePersister class
    TShellApplication in file TShellApplication.php, class TShellApplication
    TShellApplication class.
    TShellApplication.php | procedural page TShellApplication.php
    TSimpleDateFormatter in file TSimpleDateFormatter.php, class TSimpleDateFormatter
    TSimpleDateFormatter class.
    TSimpleDynamicParser in file TSimpleDynamicParser.php, class TSimpleDynamicParser
    TSimpleDynamicParser finds place holders $name$ in the sql text and replaces it with a TSimpleDynamicParser::DYNAMIC_TOKEN.
    TSimpleDynamicSql in file TSimpleDynamicSql.php, class TSimpleDynamicSql
    TSimpleDynamicSql class.
    TSlider in file TSlider.php, class TSlider
    TSlider class
    TSliderClientScript in file TSlider.php, class TSliderClientScript
    TSliderClientScript class.
    TSliderDirection in file TSlider.php, class TSliderDirection
    TSliderDirection class.
    TSoapServer in file TSoapService.php, class TSoapServer
    TSoapServer class.
    TSoapService in file TSoapService.php, class TSoapService
    TSoapService class
    TSqlCriteria in file TSqlCriteria.php, class TSqlCriteria
    Search criteria for TDbDataGateway.
    TSqliteCache in file TSqliteCache.php, class TSqliteCache
    TSqliteCache class
    TSqliteCommandBuilder in file TSqliteCommandBuilder.php, class TSqliteCommandBuilder
    TSqliteCommandBuilder provides specifics methods to create limit/offset query commands for Sqlite database.
    TSqliteMetaData in file TSqliteMetaData.php, class TSqliteMetaData
    TSqliteMetaData loads SQLite database table and column information.
    TSqliteScaffoldInput in file TSqliteScaffoldInput.php, class TSqliteScaffoldInput
    TSqliteScaffoldInput class file.
    TSqliteTableColumn in file TSqliteTableColumn.php, class TSqliteTableColumn
    Describes the column metadata of the schema for a PostgreSQL database table.
    TSqliteTableInfo in file TSqliteTableInfo.php, class TSqliteTableInfo
    TSqliteTableInfo class provides additional table information for PostgreSQL database.
    TSqlMapApplicationCache in file TSqlMapCache.php, class TSqlMapApplicationCache
    TSqlMapApplicationCache uses the default Prado application cache for caching SqlMap results.
    TSqlMapCache in file TSqlMapCache.php, class TSqlMapCache
    Allow different implementation of caching strategy. See <tt>TSqlMapFifoCache</tt> for a first-in-first-out implementation. See <tt>TSqlMapLruCache</tt> for a least-recently-used cache implementation.
    TSqlMapCacheKey in file TSqlMapCacheModel.php, class TSqlMapCacheKey
    TSqlMapCacheKey class.
    TSqlMapCacheModel in file TSqlMapCacheModel.php, class TSqlMapCacheModel
    TSqlMapCacheModel corresponds to the <cacheModel> sql mapping configuration tag.
    TSqlMapCacheTypes in file TSqlMapCacheModel.php, class TSqlMapCacheTypes
    TSqlMapCacheTypes enumerable class.
    TSqlMapConfig in file TSqlMapConfig.php, class TSqlMapConfig
    TSqlMapConfig module configuration class.
    TSqlMapConfigurationException in file TSqlMapException.php, class TSqlMapConfigurationException
    TSqlMapConfigurationException, raised during configuration file parsing.
    TSqlMapDelete in file TSqlMapStatement.php, class TSqlMapDelete
    TSqlMapDelete class corresponds to the <delete> element.
    TSqlMapDuplicateException in file TSqlMapException.php, class TSqlMapDuplicateException
    TSqlMapDuplicateException, raised when a duplicate mapped statement is found.
    TSqlMapException in file TSqlMapException.php, class TSqlMapException
    TSqlMapException is the base exception class for all SqlMap exceptions.
    TSqlMapExecutionException in file TSqlMapException.php, class TSqlMapExecutionException
    TSqlMapException is the base exception class for all SqlMap exceptions.
    TSqlMapFifoCache in file TSqlMapCache.php, class TSqlMapFifoCache
    First-in-First-out cache implementation, removes object that was first added when the cache is full.
    TSqlMapGateway in file TSqlMapGateway.php, class TSqlMapGateway
    DataMapper client, a fascade to provide access the rest of the DataMapper framework. It provides three core functions:
    TSqlMapInsert in file TSqlMapStatement.php, class TSqlMapInsert
    TSqlMapInsert class corresponds to the <insert> element.
    TSqlMapLruCache in file TSqlMapCache.php, class TSqlMapLruCache
    Least recently used cache implementation, removes object that was accessed last when the cache is full.
    TSqlMapManager in file TSqlMapManager.php, class TSqlMapManager
    TSqlMapManager class holds the sqlmap configuation result maps, statements parameter maps and a type handler factory.
    TSqlMapObjectCollectionTree in file TMappedStatement.php, class TSqlMapObjectCollectionTree
    TSQLMapObjectCollectionTree class.
    TSqlMapPagedList in file TSqlMapPagedList.php, class TSqlMapPagedList
    TSqlMapPagedList implements a list with paging functionality that retrieves data from a SqlMap statement.
    TSqlMapSelect in file TSqlMapStatement.php, class TSqlMapSelect
    TSqlMapSelect class file.
    TSqlMapSelectKey in file TSqlMapStatement.php, class TSqlMapSelectKey
    TSqlMapSelect corresponds to the <selectKey> element.
    TSqlMapStatement in file TSqlMapStatement.php, class TSqlMapStatement
    TSqlMapStatement class corresponds to <statement> element.
    TSqlMapTypeHandler in file TSqlMapTypeHandlerRegistry.php, class TSqlMapTypeHandler
    A simple interface for implementing custom type handlers.
    TSqlMapTypeHandlerRegistry in file TSqlMapTypeHandlerRegistry.php, class TSqlMapTypeHandlerRegistry
    TTypeHandlerFactory provides type handler classes to convert database field type to PHP types and vice versa.
    TSqlMapUndefinedException in file TSqlMapException.php, class TSqlMapUndefinedException
    TSqlMapUndefinedException, raised when mapped statemented are undefined.
    TSqlMapUpdate in file TSqlMapStatement.php, class TSqlMapUpdate
    TSqlMapUpdate class corresponds to <update> element.
    TSqlMapXmlConfigBuilder in file TSqlMapXmlConfiguration.php, class TSqlMapXmlConfigBuilder
    TSqlMapXmlConfig class file.
    TSqlMapXmlConfiguration in file TSqlMapXmlConfiguration.php, class TSqlMapXmlConfiguration
    TSqlMapXmlConfig class.
    TSqlMapXmlMappingConfiguration in file TSqlMapXmlConfiguration.php, class TSqlMapXmlMappingConfiguration
    Loads the statements, result maps, parameters maps from xml configuration.
    TStack in file TStack.php, class TStack
    TStack class
    TStackIterator in file TStack.php, class TStackIterator
    TStackIterator class
    TStatements in file TStatements.php, class TStatements
    TStatements class
    TStaticSql in file TStaticSql.php, class TStaticSql
    TStaticSql class.
    TStyle in file TStyle.php, class TStyle
    TStyle class
    TStyleDiff in file TActiveControlAdapter.php, class TStyleDiff
    TStyleDiff class.
    TStyleSheet in file TStyleSheet.php, class TStyleSheet
    TStyleSheet class.
    TSubMap in file TDiscriminator.php, class TSubMap
    TSubMap class defines a submapping value and the corresponding <resultMap>
    TSystemException in file TException.php, class TSystemException
    TSystemException class
    TTable in file TTable.php, class TTable
    TTable class
    TTableCaptionAlign in file TTable.php, class TTableCaptionAlign
    TTableCaptionAlign class.
    TTableCell in file TTableCell.php, class TTableCell
    TTableCell class.
    TTableCellCollection in file TTableRow.php, class TTableCellCollection
    TTableCellCollection class.
    TTableFooterRow in file TTableFooterRow.php, class TTableFooterRow
    TTableFooterRow class.
    TTableGateway in file TTableGateway.php, class TTableGateway
    TTableGateway class provides several find methods to get data from the database and update, insert, and delete methods.
    TTableGridLines in file TStyle.php, class TTableGridLines
    TTableGridLines class.
    TTableHeaderCell in file TTableHeaderCell.php, class TTableHeaderCell
    TTableHeaderCell class.
    TTableHeaderRow in file TTableHeaderRow.php, class TTableHeaderRow
    TTableHeaderRow class.
    TTableHeaderScope in file TTableHeaderCell.php, class TTableHeaderScope
    TTableHeaderScope class.
    TTableItemStyle in file TStyle.php, class TTableItemStyle
    TTableItemStyle class.
    TTableRow in file TTableRow.php, class TTableRow
    TTableRow class.
    TTableRowCollection in file TTable.php, class TTableRowCollection
    TTableRowCollection class.
    TTableRowSection in file TTableRow.php, class TTableRowSection
    TTableRowSection class.
    TTableStyle in file TStyle.php, class TTableStyle
    TTableStyle class.
    TTabPanel in file TTabPanel.php, class TTabPanel
    Class TTabPanel.
    TTabView in file TTabPanel.php, class TTabView
    TTabView class.
    TTabViewCollection in file TTabPanel.php, class TTabViewCollection
    TTabViewCollection class.
    TTarFileExtractor in file TTarFileExtractor.php, class TTarFileExtractor
    TTarFileExtractor class
    TTemplate in file TTemplateManager.php, class TTemplate
    TTemplate implements PRADO template parsing logic.
    TTemplateColumn in file TTemplateColumn.php, class TTemplateColumn
    TTemplateColumn class
    TTemplateControl in file TTemplateControl.php, class TTemplateControl
    TTemplateControl class.
    TTemplateControlInheritable in file TTemplateControlInheritable.php, class TTemplateControlInheritable
    TTemplateControlInheritable class.
    TTemplatedWizardStep in file TWizard.php, class TTemplatedWizardStep
    TTemplatedWizardStep class.
    TTemplateException in file TException.php, class TTemplateException
    TTemplateException class
    TTemplateManager in file TTemplateManager.php, class TTemplateManager
    TTemplateManager class
    TTextAlign in file TCheckBox.php, class TTextAlign
    TTextAlign class.
    TTextBox in file TTextBox.php, class TTextBox
    TTextBox class
    TTextBoxAutoCompleteType in file TTextBox.php, class TTextBoxAutoCompleteType
    TTextBoxAutoCompleteType class.
    TTextBoxMode in file TTextBox.php, class TTextBoxMode
    TTextBoxMode class.
    TTextHighlighter in file TTextHighlighter.php, class TTextHighlighter
    TTextHighlighter class.
    TTextHighlighterLineNumberStyle | in file TTextHighlighter.php, class TTextHighlighterLineNumberStyle
    TTextProcessor in file TTextProcessor.php, class TTextProcessor
    TTextProcessor class.
    TTextWriter in file TTextWriter.php, class TTextWriter
    TTextWriter class.
    TTheme in file TThemeManager.php, class TTheme
    TTheme class
    TThemeManager in file TThemeManager.php, class TThemeManager
    TThemeManager class
    TTimeTriggeredCallback in file TTimeTriggeredCallback.php, class TTimeTriggeredCallback
    TTimeTriggeredCallback class.
    TTranslate in file TTranslate.php, class TTranslate
    TTranslate class.
    TTranslateParameter in file TTranslateParameter.php, class TTranslateParameter
    TTranslateParameter component should be used inside the TTranslate component to allow parameter substitution.
    TTriggeredCallback in file TTriggeredCallback.php, class TTriggeredCallback
    TTriggeredCallback abstract Class
    TUpdateMappedStatement in file TUpdateMappedStatement.php, class TUpdateMappedStatement
    TUpdateMappedStatement class.
    TUri in file THttpRequest.php, class TUri
    TUri class
    TUrlManager in file TUrlManager.php, class TUrlManager
    TUrlManager class
    TUrlMapping in file TUrlMapping.php, class TUrlMapping
    TUrlMapping Class
    TUrlMappingPattern in file TUrlMapping.php, class TUrlMappingPattern
    TUrlMappingPattern class.
    TUrlMappingPatternSecureConnection in file TUrlMapping.php, class TUrlMappingPatternSecureConnection
    TUrlMappingPatternSecureConnection class
    TUser in file TUser.php, class TUser
    TUser class
    TUserManager in file TUserManager.php, class TUserManager
    TUserManager class
    TUserManagerPasswordMode in file TUserManager.php, class TUserManagerPasswordMode
    TUserManagerPasswordMode class.
    TValidationCompareOperator in file TCompareValidator.php, class TValidationCompareOperator
    TValidationCompareOperator class.
    TValidationDataType in file TBaseValidator.php, class TValidationDataType
    TValidationDataType class.
    TValidationSummary in file TValidationSummary.php, class TValidationSummary
    TValidationSummary class
    TValidationSummaryDisplayMode in file TValidationSummary.php, class TValidationSummaryDisplayMode
    TValidationSummaryDisplayMode class.
    TValidationSummaryDisplayStyle in file TValidationSummary.php, class TValidationSummaryDisplayStyle
    TValidationSummaryDisplay class.
    TValidatorClientSide in file TBaseValidator.php, class TValidatorClientSide
    TValidatorClientSide class.
    TValidatorDisplayStyle in file TBaseValidator.php, class TValidatorDisplayStyle
    TValidatorDisplayStyle class.
    TValueTriggeredCallback in file TValueTriggeredCallback.php, class TValueTriggeredCallback
    TValueTriggeredCallback Class
    TVarDumper in file TVarDumper.php, class TVarDumper
    TVarDumper class.
    TVerticalAlign in file TStyle.php, class TVerticalAlign
    TVerticalAlign class.
    TView in file TMultiView.php, class TView
    TView class
    TViewCollection in file TMultiView.php, class TViewCollection
    TViewCollection class.
    TViewStateDiff in file TActiveControlAdapter.php, class TViewStateDiff
    Calculates the viewstate changes during the request.
    TWebControl in file TWebControl.php, class TWebControl
    TWebControl class
    TWebControlAdapter in file TWebControlAdapter.php, class TWebControlAdapter
    TWebControlAdapter class
    TWebControlDecorator in file TWebControlDecorator.php, class TWebControlDecorator
    TWebControlDecorator class
    TWizard in file TWizard.php, class TWizard
    Class TWizard.
    TWizardFinishNavigationTemplate in file TWizard.php, class TWizardFinishNavigationTemplate
    TWizardFinishNavigationTemplate class.
    TWizardNavigationButtonStyle in file TWizardNavigationButtonStyle.php, class TWizardNavigationButtonStyle
    TWizardNavigationButtonStyle class.
    TWizardNavigationButtonType in file TWizard.php, class TWizardNavigationButtonType
    TWizardNavigationButtonType class.
    TWizardNavigationContainer in file TWizard.php, class TWizardNavigationContainer
    TWizardNavigationContainer class.
    TWizardNavigationEventParameter in file TWizard.php, class TWizardNavigationEventParameter
    TWizardNavigationEventParameter class.
    TWizardNavigationTemplate in file TWizard.php, class TWizardNavigationTemplate
    TWizardNavigationTemplate class.
    TWizardSideBarListItemTemplate in file TWizard.php, class TWizardSideBarListItemTemplate
    TWizardSideBarListItemTemplate class.
    TWizardSideBarTemplate in file TWizard.php, class TWizardSideBarTemplate
    TWizardSideBarTemplate class.
    TWizardStartNavigationTemplate in file TWizard.php, class TWizardStartNavigationTemplate
    TWizardStartNavigationTemplate class.
    TWizardStep in file TWizard.php, class TWizardStep
    TWizardStep class.
    TWizardStepCollection in file TWizard.php, class TWizardStepCollection
    TWizardStepCollection class.
    TWizardStepNavigationTemplate in file TWizard.php, class TWizardStepNavigationTemplate
    TWizardStepNavigationTemplate class.
    TWizardStepType in file TWizard.php, class TWizardStepType
    TWizardStepType class.
    TXCache in file TXCache.php, class TXCache
    TXCache class
    TXmlDocument in file TXmlDocument.php, class TXmlDocument
    TXmlDocument class.
    TXmlElement in file TXmlDocument.php, class TXmlElement
    TXmlElement class.
    TXmlElementList in file TXmlDocument.php, class TXmlElementList
    TXmlElementList class.
    TXmlRpcClient in file TRpcClient.php, class TXmlRpcClient
    TXmlRpcClient class
    TXmlRpcProtocol in file TRpcService.php, class TXmlRpcProtocol
    TXmlRpcProtocol class
    TXmlTransform in file TXmlTransform.php, class TXmlTransform
    TXmlTransform class
    TYPE_DATABINDING | in file TControl.php, class constant TCompositeLiteral::TYPE_DATABINDING
    TYPE_EXPRESSION | in file TControl.php, class constant TCompositeLiteral::TYPE_EXPRESSION
    TYPE_STATEMENTS | in file TControl.php, class constant TCompositeLiteral::TYPE_STATEMENTS
    TDataFieldAccessor.php | procedural page TDataFieldAccessor.php
    TDateTimeStamp.php | procedural page TDateTimeStamp.php
    TLogger.php | procedural page TLogger.php
    TLogRouter.php | procedural page TLogRouter.php
    TParameterModule.php | procedural page TParameterModule.php
    TRpcClient.php | procedural page TRpcClient.php
    TSimpleDateFormatter.php | procedural page TSimpleDateFormatter.php
    TVarDumper.php | procedural page TVarDumper.php
    TJavaScript.php | procedural page TJavaScript.php
    TFeedService.php | procedural page TFeedService.php
    TJsonService.php | procedural page TJsonService.php
    TPageService.php | procedural page TPageService.php
    TRpcService.php | procedural page TRpcService.php
    TSoapService.php | procedural page TSoapService.php
    TAssetManager.php | procedural page TAssetManager.php
    TCacheHttpSession.php | procedural page TCacheHttpSession.php
    THttpRequest.php | procedural page THttpRequest.php
    THttpResponse.php | procedural page THttpResponse.php
    THttpResponseAdapter.php | procedural page THttpResponseAdapter.php
    THttpSession.php | procedural page THttpSession.php
    THttpUtility.php | procedural page THttpUtility.php
    TUrlManager.php | procedural page TUrlManager.php
    TUrlMapping.php | procedural page TUrlMapping.php
    TActiveButton.php | procedural page TActiveButton.php
    TActiveCheckBox.php | procedural page TActiveCheckBox.php
    TActiveCheckBoxList.php | procedural page TActiveCheckBoxList.php
    TActiveClientScript.php | procedural page TActiveClientScript.php
    TActiveControlAdapter.php | procedural page TActiveControlAdapter.php
    TActiveCustomValidator.php | procedural page TActiveCustomValidator.php
    TActiveDataGrid.php | procedural page TActiveDataGrid.php
    TActiveDataList.php | procedural page TActiveDataList.php
    TActiveDatePicker.php | procedural page TActiveDatePicker.php
    TActiveDropDownList.php | procedural page TActiveDropDownList.php
    TActiveFileUpload.php | procedural page TActiveFileUpload.php
    TActiveHiddenField.php | procedural page TActiveHiddenField.php
    TActiveHyperLink.php | procedural page TActiveHyperLink.php
    TActiveImage.php | procedural page TActiveImage.php
    TActiveImageButton.php | procedural page TActiveImageButton.php
    TActiveLabel.php | procedural page TActiveLabel.php
    TActiveLinkButton.php | procedural page TActiveLinkButton.php
    TActiveListBox.php | procedural page TActiveListBox.php
    TActiveListControlAdapter.php | procedural page TActiveListControlAdapter.php
    TActiveMultiView.php | procedural page TActiveMultiView.php
    TActivePageAdapter.php | procedural page TActivePageAdapter.php
    TActivePager.php | procedural page TActivePager.php
    TActivePanel.php | procedural page TActivePanel.php
    TActiveRadioButton.php | procedural page TActiveRadioButton.php
    TActiveRadioButtonList.php | procedural page TActiveRadioButtonList.php
    TActiveRatingList.php | procedural page TActiveRatingList.php
    TActiveRepeater.php | procedural page TActiveRepeater.php
    TActiveTableCell.php | procedural page TActiveTableCell.php
    TActiveTableRow.php | procedural page TActiveTableRow.php
    TActiveTextBox.php | procedural page TActiveTextBox.php
    TAutoComplete.php | procedural page TAutoComplete.php
    TBaseActiveControl.php | procedural page TBaseActiveControl.php
    TCallback.php | procedural page TCallback.php
    TCallbackClientScript.php | procedural page TCallbackClientScript.php
    TCallbackClientSide.php | procedural page TCallbackClientSide.php
    TCallbackEventParameter.php | procedural page TCallbackEventParameter.php
    TCallbackOptions.php | procedural page TCallbackOptions.php
    TCallbackResponseAdapter.php | procedural page TCallbackResponseAdapter.php
    TDraggable.php | procedural page TDraggable.php
    TDropContainer.php | procedural page TDropContainer.php
    TEventTriggeredCallback.php | procedural page TEventTriggeredCallback.php
    TInPlaceTextBox.php | procedural page TInPlaceTextBox.php
    TTimeTriggeredCallback.php | procedural page TTimeTriggeredCallback.php
    TTriggeredCallback.php | procedural page TTriggeredCallback.php
    TValueTriggeredCallback.php | procedural page TValueTriggeredCallback.php
    TCachePageStatePersister.php | procedural page TCachePageStatePersister.php
    TClientScriptManager.php | procedural page TClientScriptManager.php
    TCompositeControl.php | procedural page TCompositeControl.php
    TControl.php | procedural page TControl.php
    TControlAdapter.php | procedural page TControlAdapter.php
    TForm.php | procedural page TForm.php
    THtmlWriter.php | procedural page THtmlWriter.php
    TPage.php | procedural page TPage.php
    TPageStatePersister.php | procedural page TPageStatePersister.php
    TSessionPageStatePersister.php | procedural page TSessionPageStatePersister.php
    TTemplateControl.php | procedural page TTemplateControl.php
    TTemplateControlInheritable.php | procedural page TTemplateControlInheritable.php
    TTemplateManager.php | procedural page TTemplateManager.php
    TThemeManager.php | procedural page TThemeManager.php
    TAccordion.php | procedural page TAccordion.php
    TBaseDataList.php | procedural page TBaseDataList.php
    TBaseValidator.php | procedural page TBaseValidator.php
    TBoundColumn.php | procedural page TBoundColumn.php
    TBulletedList.php | procedural page TBulletedList.php
    TButton.php | procedural page TButton.php
    TButtonColumn.php | procedural page TButtonColumn.php
    TCaptcha.php | procedural page TCaptcha.php
    TCaptchaValidator.php | procedural page TCaptchaValidator.php
    TCheckBox.php | procedural page TCheckBox.php
    TCheckBoxColumn.php | procedural page TCheckBoxColumn.php
    TCheckBoxList.php | procedural page TCheckBoxList.php
    TClientScript.php | procedural page TClientScript.php
    TColorPicker.php | procedural page TColorPicker.php
    TCompareValidator.php | procedural page TCompareValidator.php
    TConditional.php | procedural page TConditional.php
    TContent.php | procedural page TContent.php
    TContentPlaceHolder.php | procedural page TContentPlaceHolder.php
    TCustomValidator.php | procedural page TCustomValidator.php
    TDataBoundControl.php | procedural page TDataBoundControl.php
    TDataGrid.php | procedural page TDataGrid.php
    TDataGridColumn.php | procedural page TDataGridColumn.php
    TDataGridItemRenderer.php | procedural page TDataGridItemRenderer.php
    TDataGridPagerStyle.php | procedural page TDataGridPagerStyle.php
    TDataList.php | procedural page TDataList.php
    TDataListItemRenderer.php | procedural page TDataListItemRenderer.php
    TDataRenderer.php | procedural page TDataRenderer.php
    TDataSourceControl.php | procedural page TDataSourceControl.php
    TDataSourceView.php | procedural page TDataSourceView.php
    TDataTypeValidator.php | procedural page TDataTypeValidator.php
    TDatePicker.php | procedural page TDatePicker.php
    TDropDownList.php | procedural page TDropDownList.php
    TDropDownListColumn.php | procedural page TDropDownListColumn.php
    TEditCommandColumn.php | procedural page TEditCommandColumn.php
    TEmailAddressValidator.php | procedural page TEmailAddressValidator.php
    TExpression.php | procedural page TExpression.php
    TFileUpload.php | procedural page TFileUpload.php
    TFlushOutput.php | procedural page TFlushOutput.php
    TFont.php | procedural page TFont.php
    THead.php | procedural page THead.php
    THeader1.php | procedural page THeader1.php
    THeader2.php | procedural page THeader2.php
    THeader3.php | procedural page THeader3.php
    THeader4.php | procedural page THeader4.php
    THeader5.php | procedural page THeader5.php
    THeader6.php | procedural page THeader6.php
    THiddenField.php | procedural page THiddenField.php
    THtmlArea.php | procedural page THtmlArea.php
    THtmlElement.php | procedural page THtmlElement.php
    THyperLink.php | procedural page THyperLink.php
    THyperLinkColumn.php | procedural page THyperLinkColumn.php
    TImage.php | procedural page TImage.php
    TImageButton.php | procedural page TImageButton.php
    TImageMap.php | procedural page TImageMap.php
    TInlineFrame.php | procedural page TInlineFrame.php
    TItemDataRenderer.php | procedural page TItemDataRenderer.php
    TJavascriptLogger.php | procedural page TJavascriptLogger.php
    TKeyboard.php | procedural page TKeyboard.php
    TLabel.php | procedural page TLabel.php
    TLinkButton.php | procedural page TLinkButton.php
    TListBox.php | procedural page TListBox.php
    TListControl.php | procedural page TListControl.php
    TListControlValidator.php | procedural page TListControlValidator.php
    TListItem.php | procedural page TListItem.php
    TLiteral.php | procedural page TLiteral.php
    TLiteralColumn.php | procedural page TLiteralColumn.php
    TMarkdown.php | procedural page TMarkdown.php
    TMultiView.php | procedural page TMultiView.php
    TOutputCache.php | procedural page TOutputCache.php
    TPager.php | procedural page TPager.php
    TPanel.php | procedural page TPanel.php
    TPanelStyle.php | procedural page TPanelStyle.php
    TPlaceHolder.php | procedural page TPlaceHolder.php
    TRadioButton.php | procedural page TRadioButton.php
    TRadioButtonList.php | procedural page TRadioButtonList.php
    TRangeValidator.php | procedural page TRangeValidator.php
    TRatingList.php | procedural page TRatingList.php
    TReCaptcha.php | procedural page TReCaptcha.php
    TReCaptchaValidator.php | procedural page TReCaptchaValidator.php
    TRegularExpressionValidator.php | procedural page TRegularExpressionValidator.php
    TRepeater.php | procedural page TRepeater.php
    TRepeaterItemRenderer.php | procedural page TRepeaterItemRenderer.php
    TRepeatInfo.php | procedural page TRepeatInfo.php
    TRequiredFieldValidator.php | procedural page TRequiredFieldValidator.php
    TSafeHtml.php | procedural page TSafeHtml.php
    TSlider.php | procedural page TSlider.php
    TStatements.php | procedural page TStatements.php
    TStyle.php | procedural page TStyle.php
    TStyleSheet.php | procedural page TStyleSheet.php
    TTable.php | procedural page TTable.php
    TTableCell.php | procedural page TTableCell.php
    TTableFooterRow.php | procedural page TTableFooterRow.php
    TTableHeaderCell.php | procedural page TTableHeaderCell.php
    TTableHeaderRow.php | procedural page TTableHeaderRow.php
    TTableRow.php | procedural page TTableRow.php
    TTabPanel.php | procedural page TTabPanel.php
    TTemplateColumn.php | procedural page TTemplateColumn.php
    TTextBox.php | procedural page TTextBox.php
    TTextHighlighter.php | procedural page TTextHighlighter.php
    TTextProcessor.php | procedural page TTextProcessor.php
    TValidationSummary.php | procedural page TValidationSummary.php
    TWebControl.php | procedural page TWebControl.php
    TWebControlAdapter.php | procedural page TWebControlAdapter.php
    TWebControlDecorator.php | procedural page TWebControlDecorator.php
    TWizard.php | procedural page TWizard.php
    TWizardNavigationButtonStyle.php | procedural page TWizardNavigationButtonStyle.php
    TXmlTransform.php | procedural page TXmlTransform.php
    TXmlDocument.php | procedural page TXmlDocument.php
    top
    u
    unbindProperty in file TControl.php, method TControl::unbindProperty()
    Breaks the binding between a property (or property path) and an expression.
    UNDEFINED_VALUE | in file TDbTableColumn.php, class constant TDbTableColumn::UNDEFINED_VALUE
    unloadRecursive in file TControl.php, method TControl::unloadRecursive()
    Performs the Unload step for the control and all its child controls.
    unregisterObject in file TControl.php, method TControl::unregisterObject()
    Unregisters an object by name.
    unserialize in file PradoBase.php, method PradoBase::unserialize()
    Unserializes a data.
    unserialize | in file TPage.php, method TPageStateFormatter::unserialize()
    update in file TCallbackClientScript.php, method TCallbackClientScript::update()
    Update the element's innerHTML with new content.
    update in file TActiveRecordGateway.php, method TActiveRecordGateway::update()
    Update the record.
    update in file TDataGatewayCommand.php, method TDataGatewayCommand::update()
    Updates the table with new data.
    update in file TTableGateway.php, method TTableGateway::update()
    Updates the table with new name-value pair $data. Each array key must correspond to a column name in the table. The update condition is specified by the $where argument and additional binding values can be specified using the $parameter argument.
    update in file TSqlMapGateway.php, method TSqlMapGateway::update()
    Executes a Sql UPDATE statement.
    update in file TDataSourceView.php, method TDataSourceView::update()
    Updates DB record(s) with the specified keys and new values
    updateAccessKey in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateAccessKey()
    Updates the modifier access key
    updateAssociatedRecords in file TActiveRecordHasOne.php, method TActiveRecordHasOne::updateAssociatedRecords()
    Updates the associated foreign objects.
    updateAssociatedRecords in file TActiveRecordHasManyAssociation.php, method TActiveRecordHasManyAssociation::updateAssociatedRecords()
    Updates the associated foreign objects.
    updateAssociatedRecords | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::updateAssociatedRecords()
    updateAssociatedRecords in file TActiveRecordHasMany.php, method TActiveRecordHasMany::updateAssociatedRecords()
    Updates the associated foreign objects.
    updateAssociatedRecords | in file TActiveRecordGateway.php, method TActiveRecordGateway::updateAssociatedRecords()
    updateAssociatedRecords in file TActiveRecordBelongsTo.php, method TActiveRecordBelongsTo::updateAssociatedRecords()
    Updates the source object first.
    updateAttributes in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateAttributes()
    Updates/adds a list of attributes on the control.
    updateByPk | in file TDataGatewayCommand.php, method TDataGatewayCommand::updateByPk()
    updateClientSide in file TActiveListControlAdapter.php, method TActiveListItemCollection::updateClientSide()
    Update client-side list items.
    updateControlCssClass in file TBaseValidator.php, method TBaseValidator::updateControlCssClass()
    Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
    updateEnabled in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateEnabled()
    Enables or Disables the control on the client-side.
    updateListItems in file TActiveListControlAdapter.php, method TActiveListControlAdapter::updateListItems()
    Update the client-side list options.
    updatePostInsert in file TActiveRecordGateway.php, method TActiveRecordGateway::updatePostInsert()
    Sets the last insert ID to the corresponding property of the record if available.
    updateRecord in file TScaffoldEditView.php, method IScaffoldEditRenderer::updateRecord()
    This method should update the record with the user input data.
    updateSessionUser in file TAuthManager.php, method TAuthManager::updateSessionUser()
    Updates the user data stored in session.
    updateStyle in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateStyle()
    Updates the CSS style on the control on the client-side.
    updateTabIndex in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateTabIndex()
    Updates the tab index.
    updateToolTip in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateToolTip()
    Updates the tooltip.
    updateVisible in file TActiveControlAdapter.php, method TCallbackPageStateTracker::updateVisible()
    Hides or shows the control on the client-side. The control must be already rendered on the client-side.
    UpperAlpha | in file TBulletedList.php, class constant TBulletStyle::UpperAlpha
    UpperCase in file TDbConnection.php, class constant TDbColumnCaseMode::UpperCase
    Column names are converted to upper case
    UpperRoman | in file TBulletedList.php, class constant TBulletStyle::UpperRoman
    USER_FILE_EXT in file TUserManager.php, class constant TUserManager::USER_FILE_EXT
    extension name to the user file
    using in file PradoBase.php, method PradoBase::using()
    Uses a namespace.
    top
    v
    valid in file TMap.php, method TMapIterator::valid()
    Returns whether there is an element at current position.
    valid in file TList.php, method TListIterator::valid()
    Returns whether there is an item at current position.
    valid in file TDummyDataSource.php, method TDummyDataSourceIterator::valid()
    Returns whether there is an item at current position.
    valid in file TPagedDataSource.php, method TPagedListIterator::valid()
    Returns whether there is an item at current position.
    valid in file TPagedDataSource.php, method TPagedMapIterator::valid()
    Returns whether there is an item at current position.
    valid in file TStack.php, method TStackIterator::valid()
    Returns whether there is an item at current position.
    valid in file TQueue.php, method TQueueIterator::valid()
    Returns whether there is an item at current position.
    valid in file TDbDataReader.php, method TDbDataReader::valid()
    Returns whether there is a row of data at current position.
    valid in file THttpSession.php, method TSessionIterator::valid()
    Returns whether there is an element at current position.
    valid | in file TComponent.php, method TEnumerable::valid()
    validate in file TBaseValidator.php, method TBaseValidator::validate()
    Validates the specified control.
    validate in file TPage.php, method TPage::validate()
    Performs input validation.
    validate in file TCaptcha.php, method TCaptcha::validate()
    Validates a user input with the token.
    validate | in file TReCaptcha.php, method TReCaptcha::validate()
    validate in file TControl.php, method IValidator::validate()
    Validates certain data.
    validateAttributes | in file TTemplateManager.php, method TTemplate::validateAttributes()
    validateData in file TSecurityManager.php, method TSecurityManager::validateData()
    Validates if data is tampered.
    validateDataSource in file TDataBoundControl.php, method TDataBoundControl::validateDataSource()
    Validates if the parameter is a valid data source.
    validateDirectory in file TCache.php, method TDirectoryCacheDependency::validateDirectory()
    Checks to see if the specified subdirectory should be checked for dependency.
    validateFile in file TCache.php, method TDirectoryCacheDependency::validateFile()
    Checks to see if the file should be checked for dependency.
    validateUser in file TUserManager.php, method TUserManager::validateUser()
    Validates if the username and password are correct.
    validateUser in file TDbUserManager.php, method TDbUser::validateUser()
    Validates if username and password are correct entries.
    validateUser in file TDbUserManager.php, method TDbUserManager::validateUser()
    Validates if the username and password are correct.
    validateUser in file IUserManager.php, method IUserManager::validateUser()
    Validates if the username and password are correct.
    varDump in file PradoBase.php, method PradoBase::varDump()
    Converts a variable into a string representation.
    Vertical | in file TStyle.php, class constant TTableGridLines::Vertical
    Vertical | in file TPanelStyle.php, class constant TScrollBars::Vertical
    Vertical | in file TSlider.php, class constant TSliderDirection::Vertical
    Vertical | in file TDraggable.php, class constant TDraggableConstraint::Vertical
    Vertical | in file TRepeatInfo.php, class constant TRepeatDirection::Vertical
    visualEffect in file TCallbackClientScript.php, method TCallbackClientScript::visualEffect()
    Add a visual effect the element.
    top
    w
    WARNING | in file TLogger.php, class constant TLogger::WARNING
    wizardStepsChanged in file TWizard.php, method TWizard::wizardStepsChanged()
    Updates the sidebar datalist if any.
    write in file THtmlWriter.php, method THtmlWriter::write()
    Renders a string.
    write | in file TOutputCache.php, method TOutputCacheTextWriterMulti::write()
    write in file interfaces.php, method ITextWriter::write()
    Writes a string.
    write in file THttpResponse.php, method THttpResponse::write()
    Outputs a string.
    write in file TTextWriter.php, method TTextWriter::write()
    Writes a string.
    writeBreak in file THtmlWriter.php, method THtmlWriter::writeBreak()
    Renders an HTML break.
    writeFile in file THttpResponse.php, method THttpResponse::writeFile()
    Sends a file back to user.
    writeLine in file THtmlWriter.php, method THtmlWriter::writeLine()
    Renders a string and appends a newline to it.
    writeLine in file TTextWriter.php, method TTextWriter::writeLine()
    Writers a string and terminates it with a newline.
    WSDL_CACHE_PREFIX | in file TSoapService.php, class constant TSoapServer::WSDL_CACHE_PREFIX
    top
    x
    XML | in file TRpcClient.php, class constant TRpcClientTypesEnumerable::XML
    top
    _
    $_cache | in file TSqlMapCache.php, variable TSqlMapCache::$_cache
    $_cache | in file TFastSqlMapApplicationCache.php, variable TFastSqlMapApplicationCache::$_cache
    $_cacheModel | in file TSqlMapCache.php, variable TSqlMapCache::$_cacheModel
    $_cacheModel | in file TFastSqlMapApplicationCache.php, variable TFastSqlMapApplicationCache::$_cacheModel
    $_cacheModel | in file TSqlMapCache.php, variable TSqlMapApplicationCache::$_cacheModel
    $_cacheSize | in file TSqlMapCache.php, variable TSqlMapCache::$_cacheSize
    $_connection | in file TActiveRecord.php, variable TActiveRecord::$_connection
    $_constructRules | in file TUrlMapping.php, variable TUrlMapping::$_constructRules
    $_control | in file TControlAdapter.php, variable TControlAdapter::$_control
    $_controlsPostDataChanged | in file TPage.php, variable TPage::$_controlsPostDataChanged
    $_controlsRegisteredForPostData | in file TPage.php, variable TPage::$_controlsRegisteredForPostData
    $_controlsRequiringPostData | in file TPage.php, variable TPage::$_controlsRequiringPostData
    $_decorator | in file TWebControl.php, variable TWebControl::$_decorator
    $_errorCode | in file TFileUpload.php, variable TFileUpload::$_errorCode
    $_formRendered | in file TPage.php, variable TPage::$_formRendered
    $_inFormRender | in file TPage.php, variable TPage::$_inFormRender
    $_invalidFinderResult in file TActiveRecord.php, variable TActiveRecord::$_invalidFinderResult
    Defaults to 'null'
    $_isLoadingPostData | in file TPage.php, variable TPage::$_isLoadingPostData
    $_isvalid | in file TReCaptchaValidator.php, variable TReCaptchaValidator::$_isvalid
    $_keyList | in file TSqlMapCache.php, variable TSqlMapCache::$_keyList
    $_levelNames | in file TLogRouter.php, variable TLogRoute::$_levelNames
    $_levelValues | in file TLogRouter.php, variable TLogRoute::$_levelValues
    $_messageCache | in file TException.php, variable TException::$_messageCache
    $_month_leaf | in file TDateTimeStamp.php, variable TDateTimeStamp::$_month_leaf
    $_month_normal | in file TDateTimeStamp.php, variable TDateTimeStamp::$_month_normal
    $_new | in file TActiveControlAdapter.php, variable TViewStateDiff::$_new
    $_null | in file TActiveControlAdapter.php, variable TViewStateDiff::$_null
    $_old | in file TActiveControlAdapter.php, variable TViewStateDiff::$_old
    $_patterns | in file TUrlMapping.php, variable TUrlMapping::$_patterns
    $_postData | in file TPage.php, variable TPage::$_postData
    $_postDataLoaders | in file TPage.php, variable TPage::$_postDataLoaders
    $_recordState | in file TActiveRecord.php, variable TActiveRecord::$_recordState
    $_restPostData | in file TPage.php, variable TPage::$_restPostData
    $_s | in file TComponent.php, variable TJavaScriptLiteral::$_s
    $_writers | in file TOutputCache.php, variable TOutputCacheTextWriterMulti::$_writers
    _close in file THttpSession.php, method THttpSession::_close()
    Session close handler.
    _destroy in file TCacheHttpSession.php, method TCacheHttpSession::_destroy()
    Session destroy handler.
    _destroy in file THttpSession.php, method THttpSession::_destroy()
    Session destroy handler.
    _dirCheck in file TTarFileExtractor.php, method TTarFileExtractor::_dirCheck()
    Check if a directory exists and create it (including parent dirs) if not.
    _error | in file TTarFileExtractor.php, method TTarFileExtractor::_error()
    _extractList | in file TTarFileExtractor.php, method TTarFileExtractor::_extractList()
    _gc in file THttpSession.php, method THttpSession::_gc()
    Session GC (garbage collection) handler.
    _getDateInternal in file TDateTimeStamp.php, method TDateTimeStamp::_getDateInternal()
    Low-level function that returns the getdate() array. We have a special $fast flag, which if set to true, will return fewer array values, and is much faster as it does not calculate dow, etc.
    _open in file THttpSession.php, method THttpSession::_open()
    Session open handler.
    _read in file THttpSession.php, method THttpSession::_read()
    Session read handler.
    _read in file TCacheHttpSession.php, method TCacheHttpSession::_read()
    Session read handler.
    _translateWinPath | in file TTarFileExtractor.php, method TTarFileExtractor::_translateWinPath()
    _write in file TCacheHttpSession.php, method TCacheHttpSession::_write()
    Session write handler.
    _write in file THttpSession.php, method THttpSession::_write()
    Session write handler.
    __call in file TTableGateway.php, method TTableGateway::__call()
    Dynamic find method using parts of method name as search criteria.
    __call in file TComponent.php, method TComponent::__call()
    Calls a method.
    __call | in file TRpcClient.php, method TXmlRpcClient::__call()
    __call in file TActiveRecordRelation.php, method TActiveRecordRelation::__call()
    Dispatch the method calls to the source record finder object. When an instance of TActiveRecord or an array of TActiveRecord is returned the corresponding foreign objects are also fetched and assigned.
    __call | in file TRpcClient.php, method TJsonRpcClient::__call()
    __call in file TActiveRecord.php, method TActiveRecord::__call()
    Dynamic find method using parts of method name as search criteria.
    __call in file TLazyLoadList.php, method TObjectProxy::__call()
    Relay the method call to the handler object (if able to be handled), otherwise it calls the proxied object's method.
    __clone in file TStyle.php, method TStyle::__clone()
    Need to clone the font object.
    __construct in file TFlushOutput.php, method TFlushOutput::__construct()
    Constructor.
    __construct in file THtmlArea.php, method THtmlArea::__construct()
    Constructor.
    __construct in file TActiveButton.php, method TActiveButton::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct | in file TMappedStatement.php, method TResultSetMapItemParameter::__construct()
    __construct in file TOracleTableInfo.php, method TOracleTableInfo::__construct()
    Sets the database table meta data information.
    __construct in file TActiveCustomValidator.php, method TActiveCustomValidator::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct | in file TOutputCache.php, method TOutputCacheTextWriterMulti::__construct()
    __construct | in file TMappedStatement.php, method TResultSetListItemParameter::__construct()
    __construct in file TList.php, method TListIterator::__construct()
    Constructor.
    __construct in file TInPlaceTextBox.php, method TInPlaceTextBox::__construct()
    Sets the auto post back to true by default.
    __construct in file TLazyLoadList.php, method TLazyLoadList::__construct()
    Create a new proxy list that will execute the mapped statement when any of the list's method are accessed for the first time.
    __construct in file TActiveControlAdapter.php, method TViewStateDiff::__construct()
    Constructor.
    __construct in file TImageMap.php, method TImageMapEventParameter::__construct()
    Constructor.
    __construct in file TImageButton.php, method TImageClickEventParameter::__construct()
    Constructor.
    __construct in file THttpResponseAdapter.php, method THttpResponseAdapter::__construct()
    Constructor. Attach a response to be adapted.
    __construct in file THttpRequest.php, method TUri::__construct()
    Constructor.
    __construct in file THttpSession.php, method TSessionIterator::__construct()
    Constructor.
    __construct | in file TLazyLoadList.php, method TObjectProxy::__construct()
    __construct in file TList.php, method TList::__construct()
    Constructor.
    __construct in file THtmlWriter.php, method THtmlWriter::__construct()
    Constructor.
    __construct in file TMap.php, method TMap::__construct()
    Constructor.
    __construct in file TMap.php, method TMapIterator::__construct()
    Constructor.
    __construct in file THttpRequest.php, method THttpCookie::__construct()
    Constructor.
    __construct in file TTemplateManager.php, method TTemplate::__construct()
    Constructor.
    __construct in file THttpRequest.php, method THttpCookieCollection::__construct()
    Constructor.
    __construct in file TActiveFileUpload.php, method TActiveFileUpload::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TListItem.php, method TListItem::__construct()
    Constructor.
    __construct in file TMappedStatement.php, method TMappedStatement::__construct()
    Creates a new mapped statement.
    __construct in file TPagedList.php, method TPagedListFetchDataEventParameter::__construct()
    Constructor.
    __construct | in file TSimpleDynamicSql.php, method TSimpleDynamicSql::__construct()
    __construct in file TSoapService.php, method TSoapService::__construct()
    Constructor.
    __construct in file TSqlCriteria.php, method TSqlCriteria::__construct()
    Creates a new criteria with given condition;
    __construct in file TStyle.php, method TStyle::__construct()
    Constructor.
    __construct in file TSimpleDateFormatter.php, method TSimpleDateFormatter::__construct()
    Constructor, create a new date time formatter.
    __construct in file TRpcService.php, method TXmlRpcProtocol::__construct()
    Constructor
    __construct | in file TRpcClient.php, method TRpcClientResponseException::__construct()
    __construct | in file TRpcService.php, method TRpcApiProvider::__construct()
    __construct | in file TRpcService.php, method TRpcException::__construct()
    __construct in file TRpcService.php, method TRpcServer::__construct()
    Constructor
    __construct in file TStack.php, method TStackIterator::__construct()
    Constructor.
    __construct in file TSqlMapCache.php, method TSqlMapApplicationCache::__construct()
    Create a new cache with limited cache size.
    __construct in file TSqlMapManager.php, method TSqlMapManager::__construct()
    Constructor, create a new SqlMap manager.
    __construct in file TSqlMapPagedList.php, method TSqlMapPagedList::__construct()
    Create a new SqlMap paged list.
    __construct in file TStack.php, method TStack::__construct()
    Constructor.
    __construct | in file TSqlMapXmlConfiguration.php, method TSqlMapXmlConfiguration::__construct()
    __construct | in file TSqlMapGateway.php, method TSqlMapGateway::__construct()
    __construct in file TSqlMapException.php, method TSqlMapException::__construct()
    Constructor, similar to the parent constructor. For parameters that are of SimpleXmlElement, the tag name and its attribute names and values are expanded into a string.
    __construct in file TActiveControlAdapter.php, method TCallbackPageStateTracker::__construct()
    Constructor. Add a set of default states to track.
    __construct in file TActiveControlAdapter.php, method TActiveControlAdapter::__construct()
    Constructor.
    __construct in file TSqlMapCache.php, method TSqlMapCache::__construct()
    Create a new cache with limited cache size.
    __construct | in file TSqlMapCacheModel.php, method TSqlMapCacheKey::__construct()
    __construct | in file TRpcClient.php, method TRpcClient::__construct()
    __construct in file TTableGateway.php, method TTableGateway::__construct()
    Creates a new generic table gateway for a given table or view name and a database connection.
    __construct in file TPageService.php, method TPageConfiguration::__construct()
    Constructor.
    __construct in file TParameterMap.php, method TParameterMap::__construct()
    Initialize the properties and property map collections.
    __construct | in file TPreparedStatement.php, method TPreparedStatement::__construct()
    __construct in file TTarFileExtractor.php, method TTarFileExtractor::__construct()
    Archive_Tar Class constructor. This flavour of the constructor only declare a new Archive_Tar object, identifying it by the name of the tar file.
    __construct in file TPager.php, method TPagerPageChangedEventParameter::__construct()
    Constructor.
    __construct in file TPagedList.php, method TPagedListPageChangedEventParameter::__construct()
    Constructor.
    __construct in file TPagedDataSource.php, method TPagedListIterator::__construct()
    Constructor.
    __construct in file TPagedDataSource.php, method TPagedMapIterator::__construct()
    Constructor.
    __construct in file TPagedList.php, method TPagedList::__construct()
    Constructor.
    __construct | in file TFastSqlMapApplicationCache.php, method TFastSqlMapApplicationCache::__construct()
    __construct | in file TPreparedStatementFactory.php, method TPreparedStatementFactory::__construct()
    __construct in file TPriorityList.php, method TPriorityList::__construct()
    Constructor.
    __construct in file TRepeater.php, method TRepeaterCommandEventParameter::__construct()
    Constructor.
    __construct in file TRepeater.php, method TRepeaterItemEventParameter::__construct()
    Constructor.
    __construct in file TResultMap.php, method TResultMap::__construct()
    Initialize the columns collection.
    __construct in file TResultProperty.php, method TResultProperty::__construct()
    Gets the containing result map ID.
    __construct in file TRatingList.php, method TRatingList::__construct()
    Sets the default repeat direction to horizontal.
    __construct in file TRadioButton.php, method TRadioButton::__construct()
    Constructor.
    __construct in file TPriorityMap.php, method TPriorityMap::__construct()
    Constructor.
    __construct in file TQueue.php, method TQueue::__construct()
    Constructor.
    __construct in file TQueue.php, method TQueueIterator::__construct()
    Constructor.
    __construct in file TPage.php, method TPage::__construct()
    Constructor.
    __construct in file TDummyDataSource.php, method TDummyDataSourceIterator::__construct()
    Constructor.
    __construct in file TAutoComplete.php, method TAutoCompleteEventParameter::__construct()
    Creates a new TCallbackEventParameter.
    __construct in file TAuthorizationRule.php, method TAuthorizationRule::__construct()
    Constructor.
    __construct | in file TAutoComplete.php, method TAutoCompleteTemplate::__construct()
    __construct in file TBaseActiveControl.php, method TBaseActiveControl::__construct()
    Constructor. Attach a base active control to an active control instance.
    __construct in file TBaseValidator.php, method TBaseValidator::__construct()
    Constructor.
    __construct in file TWizard.php, method TWizardNavigationTemplate::__construct()
    Constructor.
    __construct in file TWizard.php, method TWizardStepCollection::__construct()
    Constructor.
    __construct in file TActiveTableRow.php, method TActiveTableRow::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter.
    __construct in file TActiveTableRow.php, method TActiveTableRowEventParameter::__construct()
    Creates a new TActiveTableRowEventParameter.
    __construct in file TActiveTextBox.php, method TActiveTextBox::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TApplication.php, method TApplication::__construct()
    Constructor.
    __construct in file TBulletedList.php, method TBulletedListEventParameter::__construct()
    Constructor.
    __construct in file TCache.php, method TDirectoryCacheDependency::__construct()
    Constructor.
    __construct in file TCheckBoxList.php, method TCheckBoxList::__construct()
    Constructor.
    __construct in file TCallbackResponseAdapter.php, method TCallbackResponseWriter::__construct()
    Constructor. Generates unique boundary ID using microtime.
    __construct in file TClientScriptManager.php, method TClientScriptManager::__construct()
    Constructor.
    __construct in file TClientScriptManager.php, method TClientSideOptions::__construct()
    Constructor, initialize the options list.
    __construct in file TWizard.php, method TWizardNavigationEventParameter::__construct()
    Constructor.
    __construct in file TCallbackEventParameter.php, method TCallbackEventParameter::__construct()
    Creates a new TCallbackEventParameter.
    __construct in file TCallbackClientScript.php, method TCallbackClientScript::__construct()
    Constructor.
    __construct in file TCache.php, method TFileCacheDependency::__construct()
    Constructor.
    __construct in file TCache.php, method TGlobalStateCacheDependency::__construct()
    Constructor.
    __construct | in file TCachingStatement.php, method TCachingStatement::__construct()
    __construct in file TCallback.php, method TCallback::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, call this constructor.
    __construct in file TActiveTableCell.php, method TActiveTableCellEventParameter::__construct()
    Creates a new TActiveTableRowEventParameter.
    __construct in file TActiveTableCell.php, method TActiveTableCell::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter.
    __construct in file TActiveMultiView.php, method TActiveMultiView::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter.
    __construct in file TActiveListBox.php, method TActiveListBox::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActivePageAdapter.php, method TActivePageAdapter::__construct()
    Constructor, trap errors and exception to let the callback response handle them.
    __construct in file TActivePager.php, method TActivePager::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActivePanel.php, method TActivePanel::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActiveLinkButton.php, method TActiveLinkButton::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActiveLabel.php, method TActiveLabel::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActiveHiddenField.php, method TActiveHiddenField::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActiveHyperLink.php, method TActiveHyperLink::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActiveImage.php, method TActiveImage::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActiveImageButton.php, method TActiveImageButton::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActiveRadioButton.php, method TActiveRadioButton::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActiveRadioButtonList.php, method TActiveRadioButtonList::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActiveRecordGateway.php, method TActiveRecordGateway::__construct()
    Record gateway constructor.
    __construct in file TXmlDocument.php, method TXmlDocument::__construct()
    Constructor.
    __construct | in file TActiveRecordRelation.php, method TActiveRecordRelation::__construct()
    __construct | in file TActiveRecordRelationContext.php, method TActiveRecordRelationContext::__construct()
    __construct in file TActiveRepeater.php, method TActiveRepeater::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter.
    __construct in file TXmlDocument.php, method TXmlElement::__construct()
    Constructor.
    __construct in file TXmlDocument.php, method TXmlElementList::__construct()
    Constructor.
    __construct in file TActiveRatingList.php, method TActiveRatingList::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActiveDropDownList.php, method TActiveDropDownList::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TActiveRecord.php, method TActiveRecord::__construct()
    Create a new instance of an active record with given $data. The record can be saved to the database specified by the $connection object.
    __construct in file TXmlTransform.php, method TXmlTransform::__construct()
    Constructor
    __construct in file TWebControlDecorator.php, method TWebControlDecorator::__construct()
    Constructor.
    __construct in file TActiveCheckBox.php, method TActiveCheckBox::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct | in file TDbCommandBuilder.php, method TDbCommandBuilder::__construct()
    __construct in file TActiveCheckBoxList.php, method TActiveCheckBoxList::__construct()
    Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct in file TDbConnection.php, method TDbConnection::__construct()
    Constructor.
    __construct in file TThemeManager.php, method TTheme::__construct()
    Constructor.
    __construct in file TDbDataReader.php, method TDbDataReader::__construct()
    Constructor.
    __construct in file TDbCommand.php, method TDbCommand::__construct()
    Constructor.
    __construct | in file TDataSourceView.php, method TReadOnlyDataSourceView::__construct()
    __construct in file TDataList.php, method TDataListCommandEventParameter::__construct()
    Constructor.
    __construct in file TDataGrid.php, method TDataGridSortCommandEventParameter::__construct()
    Constructor.
    __construct in file TDataList.php, method TDataListItemEventParameter::__construct()
    Constructor.
    __construct | in file TDataSourceControl.php, method TReadOnlyDataSource::__construct()
    __construct | in file TDataSourceView.php, method TDataSourceView::__construct()
    __construct | in file TDbMetaData.php, method TDbMetaData::__construct()
    __construct in file TDbTableColumn.php, method TDbTableColumn::__construct()
    Sets the table column meta data.
    __construct in file TException.php, method TException::__construct()
    Constructor.
    __construct | in file TSqlMapXmlConfiguration.php, method TSqlMapXmlMappingConfiguration::__construct()
    __construct in file TException.php, method THttpException::__construct()
    Constructor.
    __construct in file TException.php, method TPhpErrorException::__construct()
    Constructor.
    __construct in file TActiveDataList.php, method TActiveDataList::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter.
    __construct in file TDummyDataSource.php, method TDummyDataSource::__construct()
    Constructor.
    __construct | in file TDropDownListColumn.php, method TDropDownListColumn::__construct()
    __construct in file TDbTableInfo.php, method TDbTableInfo::__construct()
    Sets the database table meta data information.
    __construct in file TDbTransaction.php, method TDbTransaction::__construct()
    Constructor.
    __construct in file TDropContainer.php, method TDropContainer::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __construct | in file TDropContainer.php, method TDropContainerEventParameter::__construct()
    __construct in file TDataGrid.php, method TDataGridPagerEventParameter::__construct()
    Constructor.
    __construct in file TDataGrid.php, method TDataGridPager::__construct()
    Constructor.
    __construct in file TControl.php, method TCompositeLiteral::__construct()
    Constructor.
    __construct in file TControl.php, method TCommandEventParameter::__construct()
    Constructor.
    __construct in file TControl.php, method TControl::__construct()
    Constructor.
    __construct in file TUrlMapping.php, method TUrlMappingPattern::__construct()
    Constructor.
    __construct in file TControl.php, method TControlCollection::__construct()
    Constructor.
    __construct in file TControl.php, method TBroadcastEventParameter::__construct()
    Constructor.
    __construct in file TUser.php, method TUser::__construct()
    Constructor.
    __construct in file TValidationSummary.php, method TValidationSummary::__construct()
    Constructor.
    __construct in file TComponent.php, method TComponentReflection::__construct()
    Constructor.
    __construct | in file TComponent.php, method TEnumerable::__construct()
    __construct | in file TComponent.php, method TJavaScriptLiteral::__construct()
    __construct in file TActiveDataGrid.php, method TActiveDataGrid::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter.
    __construct in file TControl.php, method TEmptyControlCollection::__construct()
    Constructor.
    __construct in file TDataGrid.php, method TDataGridCommandEventParameter::__construct()
    Constructor.
    __construct in file TDataGrid.php, method TDataGridItem::__construct()
    Constructor.
    __construct in file TDataGrid.php, method TDataGridItemEventParameter::__construct()
    Constructor.
    __construct in file TDataGrid.php, method TDataGridPageChangedEventParameter::__construct()
    Constructor.
    __construct in file TDataGrid.php, method TDataGridColumnCollection::__construct()
    Constructor.
    __construct | in file TDataGatewayCommand.php, method TDataGatewayResultEventParameter::__construct()
    __construct in file TCustomValidator.php, method TServerValidateEventParameter::__construct()
    Constructor.
    __construct in file TControlAdapter.php, method TControlAdapter::__construct()
    Constructor.
    __construct | in file TDataGatewayCommand.php, method TDataGatewayCommand::__construct()
    __construct | in file TDataGatewayCommand.php, method TDataGatewayEventParameter::__construct()
    __construct in file TActiveDatePicker.php, method TActiveDatePicker::__construct()
    Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
    __destruct | in file TTarFileExtractor.php, method TTarFileExtractor::__destruct()
    __destruct in file THttpResponse.php, method THttpResponse::__destruct()
    Destructor.
    __destruct in file TLogRouter.php, method TDbLogRoute::__destruct()
    Destructor.
    __destruct in file TDbCache.php, method TDbCache::__destruct()
    Destructor.
    __destruct in file TMemCache.php, method TMemCache::__destruct()
    Destructor.
    __destruct in file TRpcService.php, method TXmlRpcProtocol::__destruct()
    Destructor
    __destruct in file TSqliteCache.php, method TSqliteCache::__destruct()
    Destructor.
    __get in file TComponent.php, method TComponent::__get()
    Returns a property value or an event handler list by property or event name.
    __get in file TControl.php, method TControl::__get()
    Returns a property value by name or a control by ID.
    __get in file TAttributeCollection.php, method TAttributeCollection::__get()
    Returns a property value or an event handler list by property or event name.
    __get in file TActiveRecord.php, method TActiveRecord::__get()
    Magic method for reading properties.
    __set in file TActiveRecord.php, method TActiveRecord::__set()
    Magic method for writing properties.
    __set in file TComponent.php, method TComponent::__set()
    Sets value of a component property.
    __set in file TAttributeCollection.php, method TAttributeCollection::__set()
    Sets value of a component property.
    __sleep in file TActiveRecord.php, method TActiveRecord::__sleep()
    Prevent __call() method creating __sleep() when serializing.
    __sleep in file TComponent.php, method TComponent::__sleep()
    Returns an array with the names of all variables of that object that should be serialized.
    __sleep in file TDbCommand.php, method TDbCommand::__sleep()
    Set the statement to null when serializing.
    __sleep | in file TSqlMapStatement.php, method TSqlMapStatement::__sleep()
    __sleep | in file TPreparedStatement.php, method TPreparedStatement::__sleep()
    __sleep | in file TResultProperty.php, method TResultProperty::__sleep()
    __sleep | in file TMappedStatement.php, method TSqlMapObjectCollectionTree::__sleep()
    __sleep | in file TParameterProperty.php, method TParameterProperty::__sleep()
    __sleep in file TDbConnection.php, method TDbConnection::__sleep()
    Close the connection when serializing.
    __sleep | in file TMappedStatement.php, method TMappedStatement::__sleep()
    __toString in file TXmlDocument.php, method TXmlDocument::__toString()
    Magic-method override. Called whenever this document is used as a string.
    __toString | in file TSqlCriteria.php, method TSqlCriteria::__toString()
    __toString in file TXmlDocument.php, method TXmlElement::__toString()
    Magic-method override. Called whenever this element is used as a string.
    __toString | in file TComponent.php, method TJavaScriptLiteral::__toString()
    __wakeup in file TActiveRecord.php, method TActiveRecord::__wakeup()
    Prevent __call() method creating __wakeup() when unserializing.
    __wakeup in file TComponent.php, method TComponent::__wakeup()
    Do not call this method. This is a PHP magic method that will be called automatically after any unserialization; it can perform reinitialization tasks on the object.
    __wakeup | in file TMappedStatement.php, method TMappedStatement::__wakeup()
    __wakeup | in file TPreparedStatement.php, method TPreparedStatement::__wakeup()


PRADO v3.2.0 API Manual

Welcome to default!

This documentation was generated by phpDocumentor v1.4.3


Todo List

System.Web

TAssetManager::copyDirectory()

  • a generic solution to ignore certain directories and files

System.Data.Common

TDbCommandBuilder::getSelectFieldList()

  • add support for quoting of column aliasing
  • add support for table aliasing

System.Util

TDbLogRoute::createDbTable()

  • create sequence for PostgreSQL

System.Data.SqlMap.Configuration

TSqlMapXmlMappingConfiguration::loadProcedureTag()

  • Implement loading procedure

TSqlMapXmlMappingConfiguration::prepareSql()

  • Extend to dynamic sql.
Documentation generated on Mon, 25 Jun 2012 14:45:54 +0200 by phpDocumentor 1.4.3


PRADO - Documentation of JSMin

Namespace: JSMin
JSMin
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | action | .
P | get | .
P | isAlphaNum | .
P | min | .
S | minify | .
P | next | .
P | peek | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of JSMinException

Namespace: JSMin
JSMinException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
getCode | . (inherited from Exception)
getFile | . (inherited from Exception)
getLine | . (inherited from Exception)
getMessage | . (inherited from Exception)
getPrevious | . (inherited from Exception)
getTrace | . (inherited from Exception)
getTraceAsString | . (inherited from Exception)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of Prado

Namespace: System
Inheritance: PradoBase »
Prado
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | autoload | Class autoload loader. (inherited from PradoBase)
S | createComponent | Creates a component with the specified type. (inherited from PradoBase)
S | exceptionHandler | Default exception handler. (inherited from PradoBase)
S | fatalError | Fatal error handler. (inherited from PradoBase)
S | getApplication | the application singleton, null if the singleton has not be created yet. (inherited from PradoBase)
S | getFrameworkPath | the path of the framework. (inherited from PradoBase)
S | getLogger | message logger. (inherited from PradoBase)
SP | getPathAliases | . (inherited from PradoBase)
S | getPathOfAlias | the path corresponding to the alias, null if alias not defined. (inherited from PradoBase)
S | getPathOfNamespace | Translates a namespace into a file path. (inherited from PradoBase)
S | getPreferredLanguage | Returns the most preferred language by the client user. (inherited from PradoBase)
S | getUserLanguages | Returns a list of user preferred languages. (inherited from PradoBase)
S | getVersion | the version of Prado framework. (inherited from PradoBase)
S | initErrorHandlers | Initializes error handlers. (inherited from PradoBase)
S | localize | Localize a text to the locale/culture specified in the globalization handler. (inherited from PradoBase)
S | log | Logs a message. (inherited from PradoBase)
S | phpErrorHandler | PHP error handler. (inherited from PradoBase)
S | poweredByPrado | a string that can be displayed on your Web page showing powered-by-PRADO information. (inherited from PradoBase)
S | serialize | Serializes a data. (inherited from PradoBase)
S | setApplication | Stores the application instance in the class static member. (inherited from PradoBase)
S | setPathOfAlias | . (inherited from PradoBase)
S | trace | Writes a log message. (inherited from PradoBase)
S | unserialize | Unserializes a data. (inherited from PradoBase)
S | using | Uses a namespace. (inherited from PradoBase)
S | varDump | Converts a variable into a string representation. (inherited from PradoBase)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of PradoBase

Namespace: System
PradoBase
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | autoload | Class autoload loader.
S | createComponent | Creates a component with the specified type.
S | exceptionHandler | Default exception handler.
S | fatalError | Fatal error handler.
S | getApplication | the application singleton, null if the singleton has not be created yet.
S | getFrameworkPath | the path of the framework.
S | getLogger | message logger.
SP | getPathAliases | .
S | getPathOfAlias | the path corresponding to the alias, null if alias not defined.
S | getPathOfNamespace | Translates a namespace into a file path.
S | getPreferredLanguage | Returns the most preferred language by the client user.
S | getUserLanguages | Returns a list of user preferred languages.
S | getVersion | the version of Prado framework.
S | initErrorHandlers | Initializes error handlers.
S | localize | Localize a text to the locale/culture specified in the globalization handler.
S | log | Logs a message.
S | phpErrorHandler | PHP error handler.
S | poweredByPrado | a string that can be displayed on your Web page showing powered-by-PRADO information.
S | serialize | Serializes a data.
S | setApplication | Stores the application instance in the class static member.
S | setPathOfAlias | .
S | trace | Writes a log message.
S | unserialize | Unserializes a data.
S | using | Uses a namespace.
S | varDump | Converts a variable into a string representation.
Derived classes
  • Prado
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAPCCache

Namespace: System.Caching
Inheritance: TComponent » TApplicationComponent » TModule » TCache »
TAPCCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
 | KeyPrefix | string | a unique prefix for the keys of cached values. (inherited from TCache)
 | PrimaryCache | boolean | whether this cache module is used as primary/system cache. (inherited from TCache)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | add | Stores a value identified by a key into cache if the cache does not contain this key. (inherited from TCache)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addValue | Stores a value identified by a key into cache if the cache does not contain this key.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes a value with the specified key from cache . (inherited from TCache)
P | deleteValue | Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Deletes all values from cache.
P | generateUniqueKey | a key generated from the provided key which ensures the uniqueness across applications. (inherited from TCache)
 | get | Retrieves a value from cache with a specified key. (inherited from TCache)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValue | Retrieves a value from cache with a specified key.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | offsetExists | Returns whether there is a cache entry with a specified key. (inherited from TCache)
 | offsetGet | Retrieves the value from cache with a specified key. (inherited from TCache)
 | offsetSet | Stores the value identified by a key into cache. (inherited from TCache)
 | offsetUnset | Deletes the value with the specified key from cache This method is required by the interface ArrayAccess. (inherited from TCache)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | set | Stores a value identified by a key into cache. (inherited from TCache)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setValue | Stores a value identified by a key in cache.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAccordion

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TAccordion
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | ActiveHeaderCssClass | string | Extra CSS class for the active header.
R | ActiveHeaderStyle | TStyle | the style for the active header div.
 | ActiveView | TAccordionView | Returns the currently active view.
 | ActiveViewID | string | Returns the ID of the active accordion view.
 | ActiveViewIndex | integer | Returns the index of the active accordion view.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AnimationDuration | string | CSS class for the currently displayed view div.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientOptions | array | the options for JavaScript.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | CSS class for the whole accordion control div.
 | CssUrl | string | URL for the CSS file including all relevant CSS class definitions.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | HeaderCssClass | string | CSS class for view headers.
R | HeaderStyle | TStyle | the style for all the inactive header div.
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name for the control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ViewCssClass | string | CSS class for the currently displayed view div.
 | ViewHeight | integer | Maximum height for the accordion views.
R | ViewStyle | TStyle | the style for all the view div.
R | Views | TAccordionViewCollection | list of TAccordionView controls.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers CSS and JS.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | activateView | Activates the specified view.
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds object parsed from template to the control.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls .
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
P | registerClientScript | Registers the relevant JavaScript.
 | registerObject | Registers an object by a name. (inherited from TControl)
P | registerStyleSheet | Registers the CSS relevant to the TAccordion.
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | .
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the accordion control.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAccordionView

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TAccordionView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Active | boolean | whether this accordion view is active.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Caption | string | the caption displayed on this header.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NavigateUrl | string | the URL of the target page.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | the | tag name for the view element.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content displayed on this view.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the accordion view.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderHeader | Renders the header associated with the accordion view.
P | renderHeaderContent | Renders the content in the header.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAccordionViewCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList » TControlCollection »
TAccordionViewCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection. (inherited from TControlCollection)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer. (inherited from TControlCollection)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
findIndexByID | Finds the index of the accordion view whose ID is the same as the one being looked for.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TControlCollection)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveBoundColumn

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn » TBoundColumn »
TActiveBoundColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataField | string | the field name from the data source to bind to the column. (inherited from TBoundColumn)
 | DataFormatString | string | the formatting string used to control how the bound data will be displayed. (inherited from TBoundColumn)
 | EditItemRenderer | string | the class name for the edit item cell renderer. (inherited from TBoundColumn)
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
 | ItemRenderer | string | the class name for the item cell renderer. (inherited from TBoundColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
 | ReadOnly | boolean | whether the items in the column can be edited. (inherited from TBoundColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column. (inherited from TBoundColumn)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values. (inherited from TBoundColumn)
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | .
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveButton

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TButton »
TActiveButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | ButtonType | TButtonType | the type of the button. (inherited from TButton)
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation, default is true. (inherited from TButton)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveButton.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
 | CommandName | string | the command name associated with the OnCommand event. (inherited from TButton)
 | CommandParameter | string | the parameter associated with the OnCommand event. (inherited from TButton)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the caption of the button. (inherited from TButton)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TButton)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsDefaultButton | boolean | true if this button is registered as a default button for a panel. (inherited from TButton)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the button. (inherited from TButton)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button. (inherited from TButton)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | caption of the button. (inherited from TButton)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback. (inherited from TButton)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnClick | This method is invoked when the button is clicked. (inherited from TButton)
OnCommand | This method is invoked when the button is clicked. (inherited from TButton)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | canCauseValidation | whether to perform validation if the button is clicked. (inherited from TButton)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | needPostBackScript | whether the button needs javascript to do postback. (inherited from TButton)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event. (inherited from TButton)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TButton)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveButtonColumn

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn » TButtonColumn »
TActiveButtonColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ButtonType | TButtonColumnType | the type of command button. (inherited from TButtonColumn)
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation, default is true. (inherited from TButtonColumn)
 | CommandName | string | the command name associated with the OnCommand event. (inherited from TButtonColumn)
 | DataImageUrlField | string | the field name from the data source to bind to the button image url. (inherited from TButtonColumn)
 | DataImageUrlFormatString | string | the formatting string used to control how the button image url will be displayed. (inherited from TButtonColumn)
 | DataTextField | string | the field name from the data source to bind to the button caption. (inherited from TButtonColumn)
 | DataTextFormatString | string | the formatting string used to control how the button caption will be displayed. (inherited from TButtonColumn)
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
 | ImageUrl | string | the URL of the image file for image buttons. (inherited from TButtonColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
 | Text | string | the text caption of the button. (inherited from TButtonColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback. (inherited from TButtonColumn)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column. (inherited from TButtonColumn)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | .
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveCheckBox

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TCheckBox »
TActiveCheckBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | whether clicking on the checkbox will post the page. (inherited from TCheckBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event triggered by this checkbox will cause input validation, default is true. (inherited from TCheckBox)
 | Checked | boolean | whether the checkbox is checked. (inherited from TCheckBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveCheckBox.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | boolean | Returns the value indicating whether the checkbox is checked. (inherited from TCheckBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBox)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
RP | DefaultLabelID | string | checkbox label ID;.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TCheckBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | InputAttributes | TMap | list of attributes to be rendered for the checkbox. (inherited from TCheckBox)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBox)
R | LabelAttributes | TMap | Overrides parent implementation to ensure label has ID.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox. (inherited from TCheckBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | bool | Check if we need a span tag to surround this control. (inherited from TCheckBox)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | SurroundingTagID | string | the id of the surrounding tag or this clientID if no such tag needed. (inherited from TCheckBox)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button. (inherited from TCheckBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the checkbox. (inherited from TCheckBox)
 | TextAlign | TTextAlign | the alignment (Left or Right) of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the checkbox causes validation upon postback. (inherited from TCheckBox)
R | ValidationPropertyValue | mixed | Returns the value of the property that needs validation. (inherited from TCheckBox)
 | Value | string | the value of the checkbox. (inherited from TCheckBox)
RP | ValueAttribute | string | the value attribute to be rendered. (inherited from TCheckBox)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnCheckedChanged | Raises OnCheckedChanged event when Checked changes value during postback. (inherited from TCheckBox)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the checkbox to receive postback data during postback. (inherited from TCheckBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TCheckBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox control. (inherited from TCheckBox)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderInputTag | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
P | renderLabel | Renders a label beside the checkbox.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveCheckBoxColumn

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn » TCheckBoxColumn »
TActiveCheckBoxColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataField | string | the field name from the data source to bind to the column. (inherited from TCheckBoxColumn)
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
 | ReadOnly | boolean | whether the items in the column can be edited. (inherited from TCheckBoxColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column. (inherited from TCheckBoxColumn)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | .
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveCheckBoxList

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TCheckBoxList »
TActiveCheckBoxList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
 | CellPadding | integer | the cellpadding for the table keeping the checkbox list. (inherited from TCheckBoxList)
 | CellSpacing | integer | the cellspacing for the table keeping the checkbox list. (inherited from TCheckBoxList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control. (inherited from TCheckBoxList)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBoxList)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item. (inherited from TCheckBoxList)
R | HasHeader | boolean | Returns a value indicating whether this control contains header item. (inherited from TCheckBoxList)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items. (inherited from TCheckBoxList)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control supports multiple selection. (inherited from TCheckBoxList)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBoxList)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox. (inherited from TCheckBoxList)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
 | RepeatColumns | integer | the number of columns that the list should be displayed with. (inherited from TCheckBoxList)
 | RepeatDirection | string | the direction of traversing the list, defaults to 'Vertical'. (inherited from TCheckBoxList)
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers). (inherited from TCheckBoxList)
 | RepeatLayout | string | how the list should be displayed, using table or using line breaks. (inherited from TCheckBoxList)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | boolean | Wether the list should be rendered inside a span or not . (inherited from TCheckBoxList)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | TextAlign | TTextAlign | the alignment of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBoxList)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TCheckBoxList)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers for post data on postback. (inherited from TCheckBoxList)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TListControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createRepeatedControl | Creates a control used for repetition (used as a template).
P | createStyle | Creates a style object for the control. (inherited from TCheckBoxList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID. (inherited from TCheckBoxList)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | generateItemStyle | Returns a style used for rendering items. (inherited from TCheckBoxList)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TCheckBoxList)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBoxList)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox list control. (inherited from TCheckBoxList)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list. (inherited from TCheckBoxList)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveClientScript

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TClientScript »
TActiveClientScript
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | FlushScriptFiles | bool | whether to flush script files using TClientScriptManager::flushScriptFiles() before rendering the script block. (inherited from TClientScript)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PradoScripts | string | comma delimited list of javascript libraries to included on the page. (inherited from TClientScript)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScriptUrl | string | custom javascript file url. (inherited from TClientScript)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Calls the client script manager to add each of the requested client script libraries. (inherited from TClientScript)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the body content as javascript block. (inherited from TClientScript)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
P | renderCustomScript | Registers the body content as javascript.
P | renderCustomScriptFile | Renders the custom script file.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveControlAdapter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControlAdapter »
TActiveControlAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | BaseActiveControl | TBaseActiveControl | Common active control options.
R | Control | TControl | the control to which this adapter is attached. (inherited from TControlAdapter)
RP | IsTrackingPageState | boolean | true if the viewstate needs to be tracked.
R | Page | TPage | the page that contains the attached control. (inherited from TControlAdapter)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | StateTracker | TCallbackPageStateTracker | state tracker.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Name | Description
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControlAdapter)
OnLoad | Starts viewstate tracking if necessary after when controls has been loaded.
OnPreRender | Publish the ajax script.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControlAdapter)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createChildControls | Creates child controls for the attached control. (inherited from TControlAdapter)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | loadState | Loads additional persistent control state. (inherited from TControlAdapter)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | render | Renders the callback client scripts.
P | renderCallbackClientScripts | Register the callback clientscripts and sets the post loader IDs.
 | renderChildren | Renders the control's children. (inherited from TControlAdapter)
 | saveState | Saves additional persistent control state.
P | setBaseControlClass | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveListControlAdapter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveCustomValidator

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator » TCustomValidator »
TActiveCustomValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this this.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TCallbackClientSide | client side request options.
 | ClientValidationFunction | string | the name of the custom client-side script function used for validation. (inherited from TCustomValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | It's mandatory for the EnableClientScript to be activated or the TActiveCustomValidator won't work.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsCallback | boolean | true if validation is made during a callback request.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TCustomValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnServerValidate | This method is invoked when the server side validation happens. (inherited from TCustomValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateIsValid | This method overrides the parent's implementation. (inherited from TCustomValidator)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Only register the client-side validator if ClientValidationFunction is set. (inherited from TCustomValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveCustomValidatorClientSide

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TClientSideOptions » TCallbackClientSide »
TActiveCustomValidatorClientSide
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | EnablePageStateUpdate | boolean | client-side viewstate will be updated on callback response if true. (inherited from TCallbackClientSide)
 | HasPriority | boolean | true if the callback request has priority and will abort existing prioritized request in order to send immediately. (inherited from TCallbackClientSide)
 | ObserveChanges | boolean | true to observe changes.
 | OnComplete | string | javascript code for client-side onComplete event. (inherited from TCallbackClientSide)
 | OnException | string | javascript code for client-side onException event. (inherited from TCallbackClientSide)
 | OnFailure | string | javascript code for client-side onFailure event. (inherited from TCallbackClientSide)
 | OnInteractive | string | javascript code for client-side onInteractive event. (inherited from TCallbackClientSide)
 | OnLoaded | string | javascript code for client-side onLoaded event. (inherited from TCallbackClientSide)
 | OnLoading | string | javascript code for client-side onLoading event. (inherited from TCallbackClientSide)
 | OnPreDispatch | string | javascript code to be executed before a request is dispatched. (inherited from TCallbackClientSide)
 | OnSuccess | string | javascript code for client-side onSuccess event. (inherited from TCallbackClientSide)
 | OnUninitialized | string | javascript code for client-side onUninitialized event. (inherited from TCallbackClientSide)
 | OnValidate | string | javascript code for client-side OnValidate event.
 | OnValidationError | string | javascript code for client-side OnError event.
 | OnValidationSuccess | string | javascript code for client-side OnSuccess event.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
 | PostBackParameter | string | post back event parameter. (inherited from TCallbackClientSide)
 | PostBackTarget | string | post back target ID. (inherited from TCallbackClientSide)
 | PostState | boolean | true to post the inputs of the form on callback, default is post the inputs on callback. (inherited from TCallbackClientSide)
 | RequestTimeOut | integer | callback request timeout. (inherited from TCallbackClientSide)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Returns javascript statement enclosed within a javascript function. (inherited from TCallbackClientSide)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveDataGrid

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TBaseDataList » TDataGrid »
TActiveDataGrid
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | standard active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AllowSorting | boolean | whether sorting is enabled. (inherited from TDataGrid)
R | AlternatingItemStyle | TTableItemStyle | the style for each alternating item. (inherited from TDataGrid)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
R | AutoColumns | TDataGridColumnCollection | automatically generated datagrid columns. (inherited from TDataGrid)
RP | AutoGenerateColumnName | string | Name of the class used in AutoGenerateColumns mode.
 | AutoGenerateColumns | boolean | whether datagrid columns should be automatically generated. (inherited from TDataGrid)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the datagrid. (inherited from TDataGrid)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | BottomPager | TDataGridPager | the pager displayed at the bottom of datagrid. (inherited from TDataGrid)
 | Caption | string | caption for the datagrid. (inherited from TDataGrid)
 | CaptionAlign | TTableCaptionAlign | datagrid caption alignment. (inherited from TDataGrid)
 | CellPadding | integer | the cellpadding for the table layout. (inherited from TBaseDataList)
 | CellSpacing | integer | the cellspacing for the table layout. (inherited from TBaseDataList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | Columns | TDataGridColumnCollection | manually specified datagrid columns. (inherited from TDataGrid)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataKeyField | string | the field of the data source that provides the keys of the list items. (inherited from TBaseDataList)
R | DataKeys | TList | the keys used in the data listing control. (inherited from TBaseDataList)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
R | EditItem | TDataGridItem | the edit item. (inherited from TDataGrid)
 | EditItemIndex | integer | the zero-based index of the edit item in Items. (inherited from TDataGrid)
R | EditItemStyle | TTableItemStyle | the style for edit item. (inherited from TDataGrid)
 | EmptyTemplate | ITemplate | the template applied when no data is bound to the datagrid. (inherited from TDataGrid)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
R | Footer | TDataGridItem | the footer item. (inherited from TDataGrid)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGrid)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GridLines | TTableGridLines | the grid line setting of the table layout. (inherited from TBaseDataList)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
R | Header | TDataGridItem | the header item. (inherited from TDataGrid)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGrid)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the table content. (inherited from TBaseDataList)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | ItemCount | integer | number of items. (inherited from TDataGrid)
R | ItemStyle | TTableItemStyle | the style for every item. (inherited from TDataGrid)
R | Items | TDataGridItemCollection | datagrid item collection. (inherited from TDataGrid)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | PagerStyle | TDataGridPagerStyle | the style for pager. (inherited from TDataGrid)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
R | SelectedItem | TDataGridItem | the selected item, null if no item is selected. (inherited from TDataGrid)
 | SelectedItemIndex | integer | the zero-based index of the selected item in Items. (inherited from TDataGrid)
R | SelectedItemStyle | TTableItemStyle | the style for selected item. (inherited from TDataGrid)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowFooter | boolean | whether the footer should be displayed. (inherited from TDataGrid)
 | ShowHeader | boolean | whether the header should be displayed. (inherited from TDataGrid)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | SurroundingTagId | string | Returns the id of the surrounding container (div).
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
R | TableBodyStyle | TStyle | the style for tbody element, if any @since 3. (inherited from TDataGrid)
R | TableFootStyle | TStyle | the style for tfoot element, if any @since 3. (inherited from TDataGrid)
R | TableHeadStyle | TStyle | the style for thead element, if any @since 3. (inherited from TDataGrid)
RP | TagName | string | tag name (table) of the datagrid. (inherited from TDataGrid)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | TopPager | TDataGridPager | the pager displayed at the top of datagrid. (inherited from TDataGrid)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCancelCommand | Raises OnCancelCommand event. (inherited from TDataGrid)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnDeleteCommand | Raises OnDeleteCommand event. (inherited from TDataGrid)
OnEditCommand | Raises OnEditCommand event. (inherited from TDataGrid)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnItemCommand | Raises OnItemCommand event. (inherited from TDataGrid)
OnItemCreated | Raises OnItemCreated event. (inherited from TDataGrid)
OnItemDataBound | Raises OnItemDataBound event. (inherited from TDataGrid)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPageIndexChanged | Raises OnPageIndexChanged event. (inherited from TDataGrid)
OnPagerCreated | Raises OnPagerCreated event. (inherited from TDataGrid)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event. (inherited from TBaseDataList)
OnSortCommand | Raises OnSortCommand event. (inherited from TDataGrid)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
OnUpdateCommand | Raises OnUpdateCommand event. (inherited from TDataGrid)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds objects parsed in template to datagrid. (inherited from TDataGrid)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
P | applyItemStyles | Applies styles to items, header, footer and separators. (inherited from TDataGrid)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation to handle OnItemCommand event which is bubbled from TDataGridItem child controls. (inherited from TDataGrid)
P | buildNextPrevPager | Builds a next-prev pager . (inherited from TDataGrid)
P | buildNumericPager | Builds a numeric pager . (inherited from TDataGrid)
P | buildPager | Builds the pager content based on pager style. (inherited from TDataGrid)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
P | createAutoColumns | Automatically generates datagrid columns based on datasource schema . (inherited from TDataGrid)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createItem | Creates a datagrid item instance based on the item type and index. (inherited from TDataGrid)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createPagerButton | Creates a pager button.
P | createStyle | Creates a style object for the control. (inherited from TDataGrid)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDataFieldValue | Returns the value of the data at the specified field. (inherited from TBaseDataList)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | initializeItem | Initializes a datagrid item and cells inside it . (inherited from TDataGrid)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads item count information from viewstate. (inherited from TDataGrid)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate datagrid items from data source. (inherited from TDataGrid)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the datagrid.
 | renderBeginTag | Renders the openning tag for the datagrid control which will render table caption if present. (inherited from TDataGrid)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderTable | Renders the tabular data. (inherited from TDataGrid)
 | reset | Clears up all items in the datagrid. (inherited from TDataGrid)
P | restoreGridFromViewState | Restores datagrid content from viewstate. (inherited from TDataGrid)
 | saveState | Saves item count in viewstate. (inherited from TDataGrid)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveDataList

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TBaseDataList » TDataList »
TActiveDataList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | standard active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AlternatingItemRenderer | string | the class name for alternative datalist items. (inherited from TDataList)
R | AlternatingItemStyle | TTableItemStyle | the style for each alternating item. (inherited from TDataList)
 | AlternatingItemTemplate | ITemplate | the template for each alternating item. (inherited from TDataList)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Caption | string | caption of the table layout. (inherited from TDataList)
 | CaptionAlign | TTableCaptionAlign | alignment of the caption of the table layout. (inherited from TDataList)
 | CellPadding | integer | the cellpadding for the table layout. (inherited from TBaseDataList)
 | CellSpacing | integer | the cellspacing for the table layout. (inherited from TBaseDataList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ContainerID | string | Returns the id of the surrounding container (span).
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataKeyField | string | the field of the data source that provides the keys of the list items. (inherited from TBaseDataList)
R | DataKeys | TList | the keys used in the data listing control. (inherited from TBaseDataList)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
R | EditItem | TControl | the edit item. (inherited from TDataList)
 | EditItemIndex | integer | the zero-based index of the edit item in Items. (inherited from TDataList)
 | EditItemRenderer | string | the class name for the datalist item being editted. (inherited from TDataList)
R | EditItemStyle | TTableItemStyle | the style for edit item. (inherited from TDataList)
 | EditItemTemplate | ITemplate | the edit item template. (inherited from TDataList)
 | EmptyRenderer | string | the class name for empty datalist item. (inherited from TDataList)
 | EmptyTemplate | ITemplate | the template applied when no data is bound to the datalist. (inherited from TDataList)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
R | Footer | TControl | the footer item. (inherited from TDataList)
 | FooterRenderer | string | the class name for datalist footer item. (inherited from TDataList)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataList)
 | FooterTemplate | ITemplate | the footer template. (inherited from TDataList)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GridLines | TTableGridLines | the grid line setting of the table layout. (inherited from TBaseDataList)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item. (inherited from TDataList)
R | HasHeader | boolean | Returns a value indicating whether this control contains header item. (inherited from TDataList)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items. (inherited from TDataList)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
R | Header | TControl | the header item. (inherited from TDataList)
 | HeaderRenderer | string | the class name for datalist header item. (inherited from TDataList)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataList)
 | HeaderTemplate | ITemplate | the header template. (inherited from TDataList)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the table content. (inherited from TBaseDataList)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | ItemCount | integer | number of items. (inherited from TDataList)
 | ItemRenderer | string | the class name for datalist items. (inherited from TDataList)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataList)
 | ItemTemplate | ITemplate | the template for item. (inherited from TDataList)
R | Items | TDataListItemCollection | item list. (inherited from TDataList)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RepeatColumns | integer | the number of columns that the list should be displayed with. (inherited from TDataList)
 | RepeatDirection | TRepeatDirection | the direction of traversing the list, defaults to TRepeatDirection::Vertical. (inherited from TDataList)
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers). (inherited from TDataList)
 | RepeatLayout | TRepeatLayout | how the list should be displayed, using table or using line breaks. (inherited from TDataList)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
R | SelectedDataKey | mixed | the key value of the currently selected item @throws TInvalidOperationException if DataKeyField is empty. (inherited from TDataList)
R | SelectedItem | TControl | the selected item, null if no item is selected. (inherited from TDataList)
 | SelectedItemIndex | integer | the zero-based index of the selected item in Items. (inherited from TDataList)
 | SelectedItemRenderer | string | the class name for the datalist item being selected. (inherited from TDataList)
R | SelectedItemStyle | TTableItemStyle | the style for selected item. (inherited from TDataList)
 | SelectedItemTemplate | ITemplate | the selected item template. (inherited from TDataList)
 | SeparatorRenderer | string | the class name for datalist item separators. (inherited from TDataList)
R | SeparatorStyle | TTableItemStyle | the style for separator. (inherited from TDataList)
 | SeparatorTemplate | ITemplate | the separator template. (inherited from TDataList)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowFooter | boolean | whether the footer should be shown. (inherited from TDataList)
 | ShowHeader | boolean | whether the header should be shown. (inherited from TDataList)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCancelCommand | Raises OnCancelCommand event. (inherited from TDataList)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnDeleteCommand | Raises OnDeleteCommand event. (inherited from TDataList)
OnEditCommand | Raises OnEditCommand event. (inherited from TDataList)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnItemCommand | Raises OnItemCommand event. (inherited from TDataList)
OnItemCreated | Raises OnItemCreated event. (inherited from TDataList)
OnItemDataBound | Raises OnItemDataBound event. (inherited from TDataList)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event. (inherited from TBaseDataList)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
OnUpdateCommand | Raises OnUpdateCommand event. (inherited from TDataList)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
P | applyItemStyles | Applies styles to items, header, footer and separators. (inherited from TDataList)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation to handle OnItemCommand event which is bubbled from datalist items and their child controls. (inherited from TDataList)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createEmptyContent | Creates empty datalist content. (inherited from TDataList)
P | createItem | Creates a datalist item instance based on the item type and index. (inherited from TDataList)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object for the control. (inherited from TBaseDataList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | generateItemStyle | Returns a style used for rendering items. (inherited from TDataList)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDataFieldValue | Returns the value of the data at the specified field. (inherited from TBaseDataList)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads item count information from viewstate. (inherited from TDataList)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate data list items from data source. (inherited from TDataList)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the repeater.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list. (inherited from TDataList)
 | reset | Clears up all items in the data list. (inherited from TDataList)
P | restoreItemsFromViewState | Creates data list items based on viewstate information. (inherited from TDataList)
 | saveState | Saves item count in viewstate. (inherited from TDataList)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveDatePicker

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox » TDatePicker »
TActiveDatePicker
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
RP | AssetUrl | string | date picker asset url. (inherited from TDatePicker)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TActiveDatePicker control and then tabs out of the component.
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | ButtonImageUrl | string | the image url for "Image" UI mode. (inherited from TDatePicker)
 | ButtonText | string | text for the date picker button. (inherited from TDatePicker)
 | CalendarStyle | string | current calendar style. (inherited from TDatePicker)
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control. (inherited from TTextBox)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
RP | CulturalOptions | array | Get javascript localization options, e. (inherited from TDatePicker)
 | Culture | string | Gets the current culture. (inherited from TDatePicker)
RP | CurrentCulture | string | the current culture, falls back to application if culture is not set. (inherited from TDatePicker)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | integer | Returns the timestamp selected by the user. (inherited from TDatePicker)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
 | Date | string | the date string. (inherited from TDatePicker)
 | DateFormat | string | the format of the date string. (inherited from TDatePicker)
RP | DatePickerButtonID | string | Gets the ID for the date picker trigger button. (inherited from TDatePicker)
RP | DatePickerOptions | array | Get javascript date picker options.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
RP | DropDownDayOptions | array | list of day options for a drop down list. (inherited from TDatePicker)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | FirstDayOfWeek | integer | first day of the week. (inherited from TDatePicker)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | FromYear | integer | date picker starting year, default is -5 years. (inherited from TDatePicker)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | InputMode | TDatePickerInputMode | input method of date values. (inherited from TDatePicker)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
RP | LocalizedCalendarInfo | DateTimeFormatInfo | date time format information for the current culture. (inherited from TDatePicker)
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
 | Mode | TDatePickerMode | current calendar UI mode. (inherited from TDatePicker)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
 | PositionMode | TDatePickerPositionMode | current calendar UI position. (inherited from TDatePicker)
RP | PostBackOptions | array | Gets the post back options for this textbox. (inherited from TTextBox)
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowCalendar | boolean | whether the calendar window should pop up when the control receives focus. (inherited from TDatePicker)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox. (inherited from TTextBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component. (inherited from TTextBox)
 | TimeStamp | integer | current selected date from the date picker as timestamp, NULL if timestamp is not set previously. (inherited from TDatePicker)
RP | TimeStampFromText | integer | Gets the date from the text input using TSimpleDateFormatter . (inherited from TDatePicker)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
 | UpToYear | integer | date picker ending year, default +10 years. (inherited from TDatePicker)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | integer | Returns the value to be validated. (inherited from TDatePicker)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the date picker Css asset files. (inherited from TDatePicker)
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Add the client id to the input textbox, and register the client scripts. (inherited from TDatePicker)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientScript | javascript validator event options. (inherited from TDatePicker)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDateFromPostData | Loads date from drop down list data. (inherited from TDatePicker)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLocalizedMonthNames | Returns the localized month names that depends on the month format pattern. (inherited from TDatePicker)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
P | hasDayPattern | . (inherited from TDatePicker)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TDatePicker)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
P | publishCalendarStyle | Publish the calendar style Css asset file. (inherited from TDatePicker)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
P | registerCalendarClientScriptPost | .
P | registerCalendarClientScriptPre | Registers the javascript code to initialize the date picker.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders body content. (inherited from TDatePicker)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
P | renderButtonDatePicker | Adds an additional button such that when clicked it shows the date picker. (inherited from TDatePicker)
P | renderCalendarDayOptions | Renders the day drop down list options. (inherited from TDatePicker)
P | renderCalendarMonthOptions | Renders the month drop down list options. (inherited from TDatePicker)
P | renderCalendarSelections | Renders the calendar drop down list depending on the DateFormat pattern. (inherited from TDatePicker)
P | renderCalendarYearOptions | Renders the year drop down list options. (inherited from TDatePicker)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for textbox. (inherited from TTextBox)
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode. (inherited from TTextBox)
 | renderControl | Renders the control. (inherited from TControl)
P | renderDatePickerButtons | Renders the date picker popup buttons. (inherited from TDatePicker)
P | renderDropDownListCalendar | Renders the drop down list date picker. (inherited from TDatePicker)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderImageButtonDatePicker | Adds an additional image button such that when clicked it shows the date picker. (inherited from TDatePicker)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveDropDownList

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TDropDownList »
TActiveDropDownList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | null | No client class for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TDropDownList)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this is a multiselect control. (inherited from TListControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TDropDownList)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | postback options for JS postback code. (inherited from TListControl)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TDropDownList)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Updates the client-side options if the item list has changed after the OnLoad event.
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items.
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TDropDownList)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TDropDownList)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveDropDownListColumn

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn » TDropDownListColumn »
TActiveDropDownListColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataTextField | string | the field of the data source that provides the text content of the column. (inherited from TDropDownListColumn)
 | DataTextFormatString | string | the formatting string used to control how the bound data will be displayed. (inherited from TDropDownListColumn)
 | DataValueField | string | the field of the data source that provides the key selecting an item in dropdown list. (inherited from TDropDownListColumn)
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | ListDataSource | Traversable | data source to be bound to the dropdown list boxes. (inherited from TDropDownListColumn)
 | ListTextField | string | the data field used to populate the texts of the dropdown list items. (inherited from TDropDownListColumn)
 | ListTextFormatString | string | the formatting string used to control how the list item texts will be displayed. (inherited from TDropDownListColumn)
 | ListValueField | string | the data field used to populate the values of the dropdown list items. (inherited from TDropDownListColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
 | ReadOnly | boolean | whether the items in the column can be edited. (inherited from TDropDownListColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Adds object parsed from template to the control. (inherited from TDropDownListColumn)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column. (inherited from TDropDownListColumn)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values. (inherited from TDropDownListColumn)
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | .
 | loadState | Loads items from viewstate. (inherited from TDropDownListColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves items into viewstate. (inherited from TDropDownListColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveEditCommandColumn

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn » TEditCommandColumn »
TActiveEditCommandColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ButtonType | TButtonColumnType | the type of command button. (inherited from TEditCommandColumn)
 | CancelImageUrl | string | the URL of the image file for cancel image buttons. (inherited from TEditCommandColumn)
 | CancelText | string | the caption of the cancel button. (inherited from TEditCommandColumn)
 | CausesValidation | boolean | whether postback event trigger by edit or update button will cause input validation, default is true. (inherited from TEditCommandColumn)
 | EditImageUrl | string | the URL of the image file for edit image buttons. (inherited from TEditCommandColumn)
 | EditText | string | the caption of the edit button. (inherited from TEditCommandColumn)
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
 | UpdateImageUrl | string | the URL of the image file for update image buttons. (inherited from TEditCommandColumn)
 | UpdateText | string | the caption of the update button. (inherited from TEditCommandColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the edit or update button causes validation upon postback. (inherited from TEditCommandColumn)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createButton | .
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values. (inherited from TEditCommandColumn)
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveFileUpload

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TFileUpload »
TActiveFileUpload
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
RP | AssetUrl | string | asset file url.
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic callback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | BusyImage | TImage | the image displayed when an upload is in progress.
R | CallbackJavascript | string | A chuck of javascript that will need to be called if {AutoPostBack is set to false}.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientOptions | array | Gets the client side options for this control.
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TFileUpload)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | ErrorCode | integer | Returns an error code describing the status of this file uploading. (inherited from TFileUpload)
R | ErrorImage | TImage | the image displayed when an upload does not complete successfully.
R | FileName | string | the original full path name of the file on the client machine. (inherited from TFileUpload)
R | FileSize | integer | the actual size of the uploaded file in bytes. (inherited from TFileUpload)
R | FileType | string | the MIME-type of the uploaded file (such as "image/gif"). (inherited from TFileUpload)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFile | boolean | whether the file is uploaded successfully. (inherited from TFileUpload)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TFileUpload)
R | LocalName | string | the local name of the file (where it is after being uploaded). (inherited from TFileUpload)
 | MaxFileSize | integer | the maximum file size, defaults to 1MB (1048576 bytes). (inherited from TFileUpload)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | SuccessImage | TImage | the image displayed when an upload completes successfully.
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the file upload control. (inherited from TFileUpload)
 | TempPath | string | the path where the uploaded file will be stored temporarily, in namespace format default "Application.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ValidationPropertyValue | mixed | Returns the original file name as the property value to be validated. (inherited from TFileUpload)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnFileUpload | This method is invoked when a file is uploaded.
OnInit | .
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the javascript.
OnUnload | Removes localfile on ending of the callback.
Methods
 | Name | Description
 | addAttributesToRender | Adds ID attribute, and renders the javascript for active component.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | .
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TFileUpload)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | popParamsByToken | .
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | pushParamsAndGetToken | .
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises OnFileUpload event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveAs | Saves the uploaded file.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveFileUploadCallbackParams

Namespace: System.Web.UI.ActiveControls
TActiveFileUploadCallbackParams
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveHiddenField

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » THiddenField »
TActiveHiddenField
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the hidden field. (inherited from THiddenField)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from THiddenField)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from THiddenField)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from THiddenField)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TagName | string | tag name of the hidden field. (inherited from THiddenField)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from THiddenField)
 | Value | string | the value of the THiddenField. (inherited from THiddenField)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
OnValueChanged | This method is invoked when the value of the Value property changes between posts to the server. (inherited from THiddenField)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets focus to this control. (inherited from THiddenField)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads hidden field data. (inherited from THiddenField)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from THiddenField)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from THiddenField)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveHyperLink

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » THyperLink »
TActiveHyperLink
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | basic active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL to link to when the THyperLink component is clicked. (inherited from THyperLink)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageHeight | string | height of the image in the THyperLink. (inherited from THyperLink)
 | ImageUrl | string | the location of the image file for the THyperLink. (inherited from THyperLink)
 | ImageWidth | string | width of the image in the THyperLink. (inherited from THyperLink)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NavigateUrl | string | the URL to link to when the THyperLink component is clicked. (inherited from THyperLink)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the hyperlink. (inherited from THyperLink)
 | Target | string | the target window or frame to display the Web page content linked to when the THyperLink component is clicked. (inherited from THyperLink)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the THyperLink. (inherited from THyperLink)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes related to a hyperlink element to renderer. (inherited from THyperLink)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createImage | Gets the TImage for rendering the ImageUrl property. (inherited from THyperLink)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the hyperlink. (inherited from THyperLink)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveHyperLinkColumn

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn » THyperLinkColumn »
TActiveHyperLinkColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataNavigateUrlField | string | the field name from the data source to bind to the navigate url of hyperlink. (inherited from THyperLinkColumn)
 | DataNavigateUrlFormatString | string | the formatting string used to control how the navigate url of hyperlink will be displayed. (inherited from THyperLinkColumn)
 | DataTextField | string | the field name from the data source to bind to the hyperlink caption. (inherited from THyperLinkColumn)
 | DataTextFormatString | string | the formatting string used to control how the hyperlink caption will be displayed. (inherited from THyperLinkColumn)
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
 | ImageHeight | string | height of the image in the THyperLink. (inherited from THyperLinkColumn)
 | ImageUrl | string | url of the image in the THyperLink. (inherited from THyperLinkColumn)
 | ImageWidth | string | width of the image in the THyperLink. (inherited from THyperLinkColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | NavigateUrl | string | the URL to link to when the hyperlink is clicked. (inherited from THyperLinkColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
 | Target | string | the target window or frame to display the Web page content linked to when the hyperlink is clicked. (inherited from THyperLinkColumn)
 | Text | string | the text caption of the hyperlink. (inherited from THyperLinkColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column. (inherited from THyperLinkColumn)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values. (inherited from THyperLinkColumn)
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | .
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveImage

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TImage »
TActiveImage
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | basic active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AlternateText | string | the alternative text displayed in the TImage component when the image is unavailable. (inherited from TImage)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL of the image file. (inherited from TImage)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | DescriptionUrl | string | the URL to long description. (inherited from TImage)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageAlign | string | the alignment of the image with respective to other elements on the page, defaults to empty. (inherited from TImage)
 | ImageUrl | string | the URL of the image file. (inherited from TImage)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of image control. (inherited from TImage)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes related to an HTML image element to renderer. (inherited from TImage)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the image. (inherited from TImage)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveImageButton

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TImage » TImageButton »
TActiveImageButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | basic active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AlternateText | string | the alternative text displayed in the TImage component when the image is unavailable. (inherited from TImage)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation, default is true. (inherited from TImageButton)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveLinkButton.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
 | CommandName | string | the command name associated with the OnCommand event. (inherited from TImageButton)
 | CommandParameter | string | the parameter associated with the OnCommand event. (inherited from TImageButton)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL of the image file. (inherited from TImage)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TImageButton)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | DescriptionUrl | string | the URL to long description. (inherited from TImage)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TImageButton)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageAlign | string | the alignment of the image with respective to other elements on the page, defaults to empty. (inherited from TImage)
 | ImageUrl | string | the URL of the image file. (inherited from TImage)
 | IsDefaultButton | boolean | true if this button is registered as a default button for a panel. (inherited from TImageButton)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the button. (inherited from TImageButton)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button. (inherited from TImageButton)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | caption of the button. (inherited from TImageButton)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback. (inherited from TImageButton)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnClick | This method is invoked when the button is clicked. (inherited from TImageButton)
OnCommand | This method is invoked when the button is clicked. (inherited from TImageButton)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Register the x and y hidden input names of the position clicked.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | canCauseValidation | whether to perform validation if the button is clicked. (inherited from TImageButton)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | This method checks if the TImageButton is clicked and loads the coordinates of the clicking position. (inherited from TImageButton)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | needPostBackScript | whether the button needs javascript to do postback. (inherited from TImageButton)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event. (inherited from TImageButton)
 | raisePostDataChangedEvent | A dummy implementation for the IPostBackDataHandler interface. (inherited from TImageButton)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TImageButton)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveLabel

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel »
TActiveLabel
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | basic active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute id to the renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the label. (inherited from TLabel)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveLinkButton

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLinkButton »
TActiveLinkButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation. (inherited from TLinkButton)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveLinkButton.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
 | CommandName | string | the command name associated with the OnCommand event. (inherited from TLinkButton)
 | CommandParameter | string | the parameter associated with the OnCommand event. (inherited from TLinkButton)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the caption of the button. (inherited from TLinkButton)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TLinkButton)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsDefaultButton | boolean | true if this button is registered as a default button for a panel. (inherited from TLinkButton)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the button. (inherited from TLinkButton)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button. (inherited from TLinkButton)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the button. (inherited from TLinkButton)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback. (inherited from TLinkButton)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnClick | This method is invoked when the button is clicked. (inherited from TLinkButton)
OnCommand | This method is invoked when the button is clicked. (inherited from TLinkButton)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event. (inherited from TLinkButton)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TLinkButton)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderLinkButtonHref | Renders the Href for link button. (inherited from TLinkButton)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveListBox

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TListBox »
TActiveListBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | null | Javascript client class for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TListBox)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control allows multiple selection. (inherited from TListBox)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TListBox)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | postback options for JS postback code. (inherited from TListControl)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows to be displayed in the list control. (inherited from TListBox)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
 | SelectionMode | TListSelectionMode | the selection mode (Single, Multiple). (inherited from TListBox)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TListBox)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Updates the client-side options if the item list has changed after the OnLoad event.
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items.
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TListBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TListBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveListControlAdapter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControlAdapter » TActiveControlAdapter »
TActiveListControlAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | BaseActiveControl | TBaseActiveControl | Common active control options. (inherited from TActiveControlAdapter)
R | Control | TControl | the control to which this adapter is attached. (inherited from TControlAdapter)
RP | IsTrackingPageState | boolean | true if the viewstate needs to be tracked. (inherited from TActiveControlAdapter)
R | Page | TPage | the page that contains the attached control. (inherited from TControlAdapter)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | StateTracker | TCallbackPageStateTracker | state tracker. (inherited from TActiveControlAdapter)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Name | Description
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControlAdapter)
OnLoad | Starts viewstate tracking if necessary after when controls has been loaded. (inherited from TActiveControlAdapter)
OnPreRender | Publish the ajax script. (inherited from TActiveControlAdapter)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControlAdapter)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | canUpdateClientSide | true if can update client-side attributes.
 | clearSelection | Clears all existing selections on the client side.
 | createChildControls | Creates child controls for the attached control. (inherited from TControlAdapter)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | loadState | Loads additional persistent control state. (inherited from TControlAdapter)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | render | Renders the callback client scripts. (inherited from TActiveControlAdapter)
P | renderCallbackClientScripts | Register the callback clientscripts and sets the post loader IDs. (inherited from TActiveControlAdapter)
 | renderChildren | Renders the control's children. (inherited from TControlAdapter)
 | saveState | Saves additional persistent control state. (inherited from TActiveControlAdapter)
P | setBaseControlClass | . (inherited from TActiveControlAdapter)
 | setSelectedIndex | Selects an item based on zero-base index on the client side.
 | setSelectedIndices | Selects a list of item based on zero-base indices on the client side.
 | setSelectedValue | Sets selection by item value on the client side.
 | setSelectedValues | Sets selection by a list of item values on the client side.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | updateListItems | Update the client-side list options.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveListItemCollection

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TList » TListItemCollection »
TActiveListItemCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Control | IActiveControl | active control using the collection.
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
R | ListHasChanged | boolean | true if the list has changed after onLoad event.
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
 | Name | Description
 | add | Appends an item at the end of the list. (inherited from TList)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | canUpdateClientSide | true if active controls can update client-side and the onLoad event has already been raised.
 | clear | Removes all items in the list. (inherited from TList)
 | contains | whether the list contains the item. (inherited from TList)
 | copyFrom | Copies iterable data into the list. (inherited from TList)
 | count | Returns the number of items in the list. (inherited from TList)
 | createListItem | Creates a list item object. (inherited from TListItemCollection)
P | createNewListItem | new item. (inherited from TListItemCollection)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findIndexByText | Finds the lowest cardinal index of the item whose text is the one being looked for. (inherited from TListItemCollection)
 | findIndexByValue | Finds the lowest cardinal index of the item whose value is the one being looked for. (inherited from TListItemCollection)
 | findItemByText | Finds the item whose text is the one being looked for. (inherited from TListItemCollection)
 | findItemByValue | Finds the item whose value is the one being looked for. (inherited from TListItemCollection)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
 | insertAfter | Finds the base item. (inherited from TList)
 | insertAt | Inserts an item into the collection.
 | insertBefore | Finds the base item. (inherited from TList)
 | itemAt | Returns the item at the specified offset. (inherited from TList)
 | loadState | Loads state into every item in the collection. (inherited from TListItemCollection)
 | mergeWith | Merges iterable data into the map. (inherited from TList)
 | offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
 | offsetGet | Returns the item at the specified offset. (inherited from TList)
 | offsetSet | Sets the item at the specified offset. (inherited from TList)
 | offsetUnset | Unsets the item at the specified offset. (inherited from TList)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes an item from the list. (inherited from TList)
 | removeAt | Removes an item from at specified index.
 | saveState | Saves state of items. (inherited from TListItemCollection)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | toArray | the list of items in array. (inherited from TList)
 | updateClientSide | Update client-side list items.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveLiteralColumn

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn » TLiteralColumn »
TActiveLiteralColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataField | string | the field name from the data source to bind to the column. (inherited from TLiteralColumn)
 | DataFormatString | string | the formatting string used to control how the bound data will be displayed. (inherited from TLiteralColumn)
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | Encode | boolean | whether the rendered text should be HTML-encoded. (inherited from TLiteralColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
 | Text | string | static text to be displayed in the column. (inherited from TLiteralColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column. (inherited from TLiteralColumn)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values. (inherited from TLiteralColumn)
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | .
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveMultiView

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TMultiView »
TActiveMultiView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveControl | standard active control options.
 | ActiveView | TView | the currently active view, null if no active view @throws TInvalidDataValueException if the current active view index is invalid. (inherited from TMultiView)
 | ActiveViewIndex | integer | the zero-based index of the current view in the view collection. (inherited from TMultiView)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ContainerID | string | Returns the id of the surrounding container (span).
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | Views | TViewCollection | the view collection. (inherited from TMultiView)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnActiveViewChanged | Raises OnActiveViewChanged event. (inherited from TMultiView)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Initializes the active view if any. (inherited from TMultiView)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | activateView | Activates the specified view. (inherited from TMultiView)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TMultiView)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Processes the events bubbled from child controls. (inherited from TMultiView)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TMultiView)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | ignoreBubbleEvents | Makes the multiview ignore all bubbled events. (inherited from TMultiView)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads state into the wizard. (inherited from TMultiView)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the TActiveMultiView.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
P | renderMultiView | Renders the TActiveMultiView by writing a span tag with the container id obtained from getContainerID() which will be called by the replacement method of the client script to update it's content.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActivePageAdapter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControlAdapter »
TActivePageAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | CallbackClientHandler | TCallbackClientScript | Gets the callback client script handler.
 | CallbackEventParameter | string | Gets callback parameter.
 | CallbackEventTarget | TControl | the control responsible for the current callback event, null if nonexistent.
R | Control | TControl | the control to which this adapter is attached. (inherited from TControlAdapter)
R | Page | TPage | the page that contains the attached control. (inherited from TControlAdapter)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Name | Description
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControlAdapter)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControlAdapter)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControlAdapter)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControlAdapter)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createChildControls | Creates child controls for the attached control. (inherited from TControlAdapter)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | loadState | Loads additional persistent control state. (inherited from TControlAdapter)
 | processCallbackEvent | Process the callback request.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | redirect | Redirect url on the client-side using javascript.
 | registerControlToRender | Register a control for defered render() call.
 | render | This method is invoked when the control renders itself. (inherited from TControlAdapter)
 | renderCallbackResponse | Render the callback response.
 | renderChildren | Renders the control's children. (inherited from TControlAdapter)
P | renderResponse | Renders the callback response by adding additional callback data and javascript actions in the header and page state if required.
 | saveState | Saves additional persistent control state. (inherited from TControlAdapter)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | trapCallbackErrorsExceptions | Trap errors and exceptions to be handled by TCallbackErrorHandler.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActivePager

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TPager »
TActivePager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | standard active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | ButtonType | TPagerButtonType | the type of command button for paging. (inherited from TPager)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToPaginate | string | the ID path of the control whose content would be paginated. (inherited from TPager)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TPager)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | FirstPageImageUrl | string | the image URL for the first page button. (inherited from TPager)
 | FirstPageText | string | text for the first page button. (inherited from TPager)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsFirstPage | boolean | whether the current page is the first page Defaults to false. (inherited from TPager)
R | IsLastPage | boolean | whether the current page is the last page. (inherited from TPager)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | LastPageImageUrl | string | the image URL for the last page button. (inherited from TPager)
 | LastPageText | string | text for the last page button. (inherited from TPager)
 | Mode | TPagerMode | pager mode. (inherited from TPager)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NextPageImageUrl | string | the image URL for the next page button. (inherited from TPager)
 | NextPageText | string | text for the next page button. (inherited from TPager)
 | NumericPageImageUrl | string | the image URL for the numeric page buttons. (inherited from TPager)
 | Page | TPage | the page that contains this control. (inherited from TControl)
 | PageButtonCount | integer | maximum number of pager buttons to be displayed. (inherited from TPager)
 | PageCount | integer | number of pages of data items available. (inherited from TPager)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PrevPageImageUrl | string | the image URL for the previous page button. (inherited from TPager)
 | PrevPageText | string | text for the previous page button. (inherited from TPager)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPageIndexChanged | This event is raised when page index is changed due to a page button click. (inherited from TPager)
OnPreRender | Performs databinding to populate data items from data source. (inherited from TPager)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Processes a bubbled event. (inherited from TPager)
P | buildListPager | Builds a dropdown list pager Override parent implementation to build Active dropdown lists.
P | buildNextPrevPager | Builds a next-prev pager. (inherited from TPager)
P | buildNumericPager | Builds a numeric pager. (inherited from TPager)
P | buildPager | Builds the pager content based on the pager mode. (inherited from TPager)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createPagerButton | Creates a pager button.
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPageImageUrl | . (inherited from TPager)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | handleCallback | Event handler to the OnCallback active buttons or active dropdownlist.
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | listIndexChanged | Event handler to the OnSelectedIndexChanged event of the dropdown list. (inherited from TPager)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Restores the pager state. (inherited from TPager)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | .
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActivePanel

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TPanel »
TActivePanel
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | standard active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the panel component. (inherited from TPanel)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | DefaultButton | string | the ID path to the default button. (inherited from TPanel)
 | Direction | string | alignment of the content in the panel. (inherited from TPanel)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GroupingText | string | the legend text when the panel is used as a fieldset. (inherited from TPanel)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the panel, defaults to 'NotSet'. (inherited from TPanel)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScrollBars | string | the visibility and position of scroll bars in a panel control, defaults to None. (inherited from TPanel)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the panel. (inherited from TPanel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the content wraps within the panel. (inherited from TPanel)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute id to the renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TPanel)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders and replaces the panel's content on the client-side.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TPanel)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TPanel)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRadioButton

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TCheckBox » TRadioButton »
TActiveRadioButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | whether clicking on the checkbox will post the page. (inherited from TCheckBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event triggered by this checkbox will cause input validation, default is true. (inherited from TCheckBox)
 | Checked | boolean | whether the checkbox is checked. (inherited from TCheckBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveRadioButton.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | boolean | Returns the value indicating whether the checkbox is checked. (inherited from TCheckBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBox)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
RP | DefaultLabelID | string | radio button label ID;.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TRadioButton)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GroupName | string | the name of the group that the radio button belongs to. (inherited from TRadioButton)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | InputAttributes | TMap | list of attributes to be rendered for the checkbox. (inherited from TCheckBox)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBox)
R | LabelAttributes | TMap | Overrides parent implementation to ensure label has ID.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox. (inherited from TCheckBox)
R | RadioButtonsInGroup | array | Gets an array of radiobuttons whose group name is the same as this radiobutton's. (inherited from TRadioButton)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | bool | Check if we need a span tag to surround this control. (inherited from TCheckBox)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | SurroundingTagID | string | the id of the surrounding tag or this clientID if no such tag needed. (inherited from TCheckBox)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button. (inherited from TCheckBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the checkbox. (inherited from TCheckBox)
 | TextAlign | TTextAlign | the alignment (Left or Right) of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
 | UniqueGroupName | string | the name used to fetch radiobutton post data. (inherited from TRadioButton)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the checkbox causes validation upon postback. (inherited from TCheckBox)
R | ValidationPropertyValue | mixed | Returns the value of the property that needs validation. (inherited from TCheckBox)
 | Value | string | the value of the checkbox. (inherited from TCheckBox)
RP | ValueAttribute | string | the value attribute to be rendered. (inherited from TRadioButton)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnCheckedChanged | Raises OnCheckedChanged event when Checked changes value during postback. (inherited from TCheckBox)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the radio button groupings. (inherited from TRadioButton)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the checkbox to receive postback data during postback. (inherited from TCheckBox)
OnUnLoad | Unregisters the radio button groupings. (inherited from TRadioButton)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add the group name as post data loader if group name is set. (inherited from TRadioButton)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TRadioButton)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox control. (inherited from TCheckBox)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderInputTag | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
P | renderLabel | Renders a label beside the radio button.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRadioButtonList

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TCheckBoxList » TRadioButtonList »
TActiveRadioButtonList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
 | CellPadding | integer | the cellpadding for the table keeping the checkbox list. (inherited from TCheckBoxList)
 | CellSpacing | integer | the cellspacing for the table keeping the checkbox list. (inherited from TCheckBoxList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control. (inherited from TRadioButtonList)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBoxList)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item. (inherited from TCheckBoxList)
R | HasHeader | boolean | Returns a value indicating whether this control contains header item. (inherited from TCheckBoxList)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items. (inherited from TCheckBoxList)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control supports multiple selection. (inherited from TRadioButtonList)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBoxList)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox. (inherited from TCheckBoxList)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
 | RepeatColumns | integer | the number of columns that the list should be displayed with. (inherited from TCheckBoxList)
 | RepeatDirection | string | the direction of traversing the list, defaults to 'Vertical'. (inherited from TCheckBoxList)
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers). (inherited from TCheckBoxList)
 | RepeatLayout | string | how the list should be displayed, using table or using line breaks. (inherited from TCheckBoxList)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | boolean | Wether the list should be rendered inside a span or not . (inherited from TCheckBoxList)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | TextAlign | TTextAlign | the alignment of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBoxList)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TCheckBoxList)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers for post data on postback. (inherited from TCheckBoxList)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TListControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createRepeatedControl | Creates a control used for repetition (used as a template).
P | createStyle | Creates a style object for the control. (inherited from TCheckBoxList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID. (inherited from TCheckBoxList)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | generateItemStyle | Returns a style used for rendering items. (inherited from TCheckBoxList)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TRadioButtonList)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBoxList)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox list control. (inherited from TCheckBoxList)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list. (inherited from TCheckBoxList)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRatingList

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TCheckBoxList » TRadioButtonList » TRatingList »
TActiveRatingList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowInput | boolean | Wrapper for ReadOnly property. (inherited from TRatingList)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
RP | AssetUrl | string | asset file url. (inherited from TRatingList)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Caption | string | caption text. (inherited from TRatingList)
RP | CaptionControl | {unknown} | . (inherited from TRatingList)
RP | CaptionControlID | string | find the client ID of the caption control. (inherited from TRatingList)
 | CaptionID | string | control or html element ID for displaying a caption. (inherited from TRatingList)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
 | CellPadding | integer | the cellpadding for the table keeping the checkbox list. (inherited from TCheckBoxList)
 | CellSpacing | integer | the cellspacing for the table keeping the checkbox list. (inherited from TCheckBoxList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBoxList)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | HalfRatingInterval | array | rating display half value interval, default is array(0. (inherited from TRatingList)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item. (inherited from TCheckBoxList)
R | HasHeader | boolean | Returns a value indicating whether this control contains header item. (inherited from TCheckBoxList)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items. (inherited from TCheckBoxList)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control supports multiple selection. (inherited from TRadioButtonList)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBoxList)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | list of post back options. (inherited from TRatingList)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
 | Rating | float | rating value. (inherited from TRatingList)
 | RatingStyle | TRatingListStyle | current rating style. (inherited from TRatingList)
RP | RatingStyleCssClass | string | rating style css class name. (inherited from TRatingList)
 | ReadOnly | boolean | whether the items in the column can be edited. (inherited from TRatingList)
 | RepeatColumns | integer | the number of columns that the list should be displayed with. (inherited from TCheckBoxList)
 | RepeatDirection | string | the direction of traversing the list, defaults to 'Vertical'. (inherited from TCheckBoxList)
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers). (inherited from TCheckBoxList)
 | RepeatLayout | string | how the list should be displayed, using table or using line breaks. (inherited from TCheckBoxList)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | boolean | Wether the list should be rendered inside a span or not . (inherited from TCheckBoxList)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | TextAlign | TTextAlign | the alignment of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBoxList)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TCheckBoxList)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the the rating style css file and rating image files. (inherited from TRatingList)
OnSelectedIndexChanged | . (inherited from TRatingList)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TListControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | callClientFunction | Calls the client-side static method for this control class.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createRepeatedControl | Creates a control used for repetition (used as a template). (inherited from TRadioButtonList)
P | createStyle | Creates a style object for the control. (inherited from TCheckBoxList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID. (inherited from TCheckBoxList)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | generateItemStyle | Returns a style used for rendering items. (inherited from TCheckBoxList)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRatingIndex | rating as integer. (inherited from TRatingList)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TRadioButtonList)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | publishImages | URL of publish the rating images. (inherited from TRatingList)
P | publishStyle | URL of the css style file. (inherited from TRatingList)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBoxList)
P | registerClientScript | Registers the relevant JavaScript. (inherited from TRatingList)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Add rating style class name to the class attribute when ReadOnly property is true and when the CssClass property is empty. (inherited from TRatingList)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list. (inherited from TCheckBoxList)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecord

Namespace: System.Data.ActiveRecord
Inheritance: TComponent »
TActiveRecord
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | Gets the current Db connection, the connection object is obtained from the TActiveRecordManager if connection is currently null.
 | InvalidFinderResult | TActiveRecordInvalidFinderResult | Defaults to 'Null'.
R | RecordGateway | TActiveRecordGateway | record table gateway.
R | RecordRelations | array | all relation definitions declared in the AR class @since 3.
R | RecordTableInfo | TDbTableInfo | the meta information of the table associated with this AR class.
Events
Name | Description
OnCreateCommand | Raised when a command is prepared and parameter binding is completed.
OnDelete | Raised before the record attempt to delete its data from the database.
OnExecuteCommand | Raised when a command is executed and the result from the database was returned.
OnInsert | Raised before the record attempt to insert its data into the database.
OnUpdate | Raised before the record attempt to update its data in the database.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | copyFrom | Copies data from an array or another object.
 | count | Find the number of records.
S | createRecord | Create an AR instance specified by the AR class name and initial data.
P | createRelationContext | Gets a static copy of the relationship context for given property (a key in $RELATIONS), returns null if invalid relationship.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes the current record from the database.
 | deleteAll | Delete multiple records using a criteria.
 | deleteAllByPks | Alias for deleteByPk().
 | deleteByPk | Delete records by primary key.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | equals | Compare two records using their primary key values (all column values if table does not defined primary keys).
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | fetchResultsFor | Tries to load the relationship results for the given property.
 | find | Find one single record that matches the criteria.
 | findAll | Same as find() but returns an array of objects.
 | findAllByIndex | Fetches records using the sql clause "(fields) IN (values)", where fields is an array of column names and values is an array of values that the columns must have.
 | findAllByPks | Find multiple records matching a list of primary or composite keys.
 | findAllBySql | Find records using full SQL, returns corresponding record object.
 | findByPk | Find one record using only the primary key or composite primary keys.
 | findBySql | Find records using full SQL, returns corresponding record object.
S | finder | Returns the instance of a active record finder for a particular class.
S | getActiveDbConnection | .
 | getColumnValue | Retrieves the column value according to column name.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRecordCriteria | Create a new TSqlCriteria object from a string $criteria.
S | getRecordManager | Gets the record manager for this object, the default is to call TActiveRecordManager::getInstance().
 | getRecordRelation | relation definition for the specified property @since 3.
P | getRelationHandler | Returns the active record relationship handler for $RELATION with key value equal to the $property value.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasRecordRelation | whether a relation is declared for the specified AR property @since 3.
P | populateObject | Populates a new record with the query result.
P | populateObjects | the AR objects populated by the query result @since 3.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | save | Saves the current record to the database, insert or update is automatically determined.
 | setColumnValue | Sets the column value according to column name.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordBelongsTo

Namespace: System.Data.ActiveRecord.Relations
Inheritance: TActiveRecordRelation »
TActiveRecordBelongsTo
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | collectForeignObjects | Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
 | fetchResultsInto | Fetch results for current relationship. (inherited from TActiveRecordRelation)
P | findForeignKeys | Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value. (inherited from TActiveRecordRelation)
P | findForeignObjects | Fetches the foreign objects using TActiveRecord::findAllByIndex() . (inherited from TActiveRecordRelation)
P | getContext | . (inherited from TActiveRecordRelation)
P | getCriteria | . (inherited from TActiveRecordRelation)
P | getIndexValues | Obtain the foreign key index values from the results. (inherited from TActiveRecordRelation)
P | getObjectHash | object hash using crc32 and serialize. (inherited from TActiveRecordRelation)
 | getRelationForeignKeys | foreign key field names as key and object properties as value.
P | getSourceRecord | . (inherited from TActiveRecordRelation)
P | populateResult | Populate the results with the foreign objects found. (inherited from TActiveRecordRelation)
P | setObjectProperty | Sets the foreign objects to the given property on the source object.
P | setResultCollection | Populates the result array with foreign objects (matched using foreign key hashed property values). (inherited from TActiveRecordRelation)
 | updateAssociatedRecords | Updates the source object first.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordChangeEventParameter

Namespace: System.Data.ActiveRecord
Inheritance: TComponent » TEventParameter »
TActiveRecordChangeEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
IsValid | boolean | whether the event should be performed.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordConfig

Namespace: System.Data.ActiveRecord
Inheritance: TComponent » TApplicationComponent » TModule » TDataSourceConfig »
TActiveRecordConfig
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ConnectionClass | {unknown} | . (inherited from TDataSourceConfig)
 | ConnectionID | string | connection module ID. (inherited from TDataSourceConfig)
R | Database | TDbConnection | Alias for getDbConnection(). (inherited from TDataSourceConfig)
R | DbConnection | TDbConnection | Gets the TDbConnection from another module if ConnectionID is supplied and valid. (inherited from TDataSourceConfig)
 | EnableCache | boolean | true if table meta data should be cached, false otherwise.
 | GatewayClass | string | the implementation class of ActiveRecordGateway.
 | ID | string | id of this module. (inherited from TModule)
 | InvalidFinderResult | TActiveRecordInvalidFinderResult | Defaults to 'Null'.
R | Manager | TActiveRecordManager | .
 | ManagerClass | string | the implementation class of ActiveRecordManager.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | findConnectionByID | Finds the database connection instance from the Application modules. (inherited from TDataSourceConfig)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initialize the active record manager.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordConfigurationException

Namespace: System.Data.ActiveRecord
Inheritance: TException » TSystemException » TDbException » TActiveRecordException »
TActiveRecordConfigurationException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TActiveRecordException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordCriteria

Namespace: System.Data.ActiveRecord
Inheritance: TComponent » TSqlCriteria »
TActiveRecordCriteria
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Condition | string | search conditions. (inherited from TSqlCriteria)
R | IsNamedParameters | boolean | true if the parameter index are string base, false otherwise. (inherited from TSqlCriteria)
 | Limit | int | maximum number of records to return. (inherited from TSqlCriteria)
 | Offset | int | record offset. (inherited from TSqlCriteria)
 | OrdersBy | TAttributeCollection | ordering clause. (inherited from TSqlCriteria)
 | Parameters | TAttributeCollection | list of named parameters and values. (inherited from TSqlCriteria)
 | Select | mixed | Gets the field list to be placed after the SELECT in the SQL. (inherited from TSqlCriteria)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordException

Namespace: System.Data.ActiveRecord
Inheritance: TException » TSystemException » TDbException »
TActiveRecordException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file.
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
  • TActiveRecordConfigurationException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordGateway

Namespace: System.Data.ActiveRecord
Inheritance: TComponent »
TActiveRecordGateway
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
RP | Manager | TActiveRecordManager | record manager.
Events
Name | Description
OnCreateCommand | Raised when a command is prepared and parameter binding is completed.
OnExecuteCommand | Raised when a command is executed and the result from the database was returned.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | countRecords | Returns the number of records that match the given criteria.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Delete the record.
 | deleteRecordsByCriteria | Delete multiple records by criteria.
 | deleteRecordsByPk | Delete multiple records using primary keys.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findRecordByPK | Returns record data matching the given primary key(s).
 | findRecordBySql | Return record data from sql query.
 | findRecordsByCriteria | Returns record data matching the given critera.
 | findRecordsByIndex | .
 | findRecordsByPks | Returns records matching the list of given primary keys.
 | findRecordsBySql | Return record data from sql query.
 | getCommand | .
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertValues | insert values.
P | getPrimaryKeyValues | .
 | getRecordTableInfo | Returns table information, trys the application cache first.
P | getRecordTableName | Gets the table name from the 'TABLE' constant of the active record class if defined, otherwise use the class name as table name.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getTableInfo | Returns table information for table in the database connection.
P | getUpdateValues | .
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | insert | Insert a new record.
P | raiseCommandEvent | Raise the corresponding command event, insert, update, delete or select.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | update | Update the record.
P | updateAssociatedRecords | .
P | updatePostInsert | Sets the last insert ID to the corresponding property of the record if available.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordHasMany

Namespace: System.Data.ActiveRecord.Relations
Inheritance: TActiveRecordRelation »
TActiveRecordHasMany
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | collectForeignObjects | Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
 | fetchResultsInto | Fetch results for current relationship. (inherited from TActiveRecordRelation)
P | findForeignKeys | Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value. (inherited from TActiveRecordRelation)
P | findForeignObjects | Fetches the foreign objects using TActiveRecord::findAllByIndex() . (inherited from TActiveRecordRelation)
P | getContext | . (inherited from TActiveRecordRelation)
P | getCriteria | . (inherited from TActiveRecordRelation)
P | getIndexValues | Obtain the foreign key index values from the results. (inherited from TActiveRecordRelation)
P | getObjectHash | object hash using crc32 and serialize. (inherited from TActiveRecordRelation)
 | getRelationForeignKeys | foreign key field names as key and object properties as value.
P | getSourceRecord | . (inherited from TActiveRecordRelation)
P | populateResult | Populate the results with the foreign objects found. (inherited from TActiveRecordRelation)
P | setObjectProperty | Sets the foreign objects to the given property on the source object. (inherited from TActiveRecordRelation)
P | setResultCollection | Populates the result array with foreign objects (matched using foreign key hashed property values). (inherited from TActiveRecordRelation)
 | updateAssociatedRecords | Updates the associated foreign objects.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordHasManyAssociation

Namespace: System.Data.ActiveRecord.Relations
Inheritance: TActiveRecordRelation »
TActiveRecordHasManyAssociation
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | collectForeignObjects | Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects using association table.
 | createCommand | .
P | createFkObject | .
P | fetchForeignObjects | Fetches the foreign objects using TActiveRecord::findAllByIndex() .
 | fetchResultsInto | Fetch results for current relationship. (inherited from TActiveRecordRelation)
P | findForeignKeys | Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value. (inherited from TActiveRecordRelation)
P | findForeignObjects | Fetches the foreign objects using TActiveRecord::findAllByIndex() . (inherited from TActiveRecordRelation)
P | getAssociationJoin | SQL inner join for M-N relationship via association table.
P | getAssociationTable | association table information.
P | getAssociationTableCommandBuilder | .
P | getCommandBuilder | .
P | getContext | . (inherited from TActiveRecordRelation)
P | getCriteria | . (inherited from TActiveRecordRelation)
P | getForeignCommandBuilder | .
P | getForeignTable | foreign table information.
P | getIndexValues | Obtain the foreign key index values from the results. (inherited from TActiveRecordRelation)
P | getObjectHash | object hash using crc32 and serialize. (inherited from TActiveRecordRelation)
 | getRelationForeignKeys | 2 arrays of source keys and foreign keys from the association table.
P | getSourceColumns | comma separated source column names.
P | getSourceRecord | . (inherited from TActiveRecordRelation)
P | getSourceTable | source table information.
P | populateResult | Populate the results with the foreign objects found. (inherited from TActiveRecordRelation)
P | setObjectProperty | Sets the foreign objects to the given property on the source object. (inherited from TActiveRecordRelation)
P | setResultCollection | Populates the result array with foreign objects (matched using foreign key hashed property values). (inherited from TActiveRecordRelation)
 | updateAssociatedRecords | Updates the associated foreign objects.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordHasOne

Namespace: System.Data.ActiveRecord.Relations
Inheritance: TActiveRecordRelation »
TActiveRecordHasOne
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | collectForeignObjects | Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
 | fetchResultsInto | Fetch results for current relationship. (inherited from TActiveRecordRelation)
P | findForeignKeys | Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value. (inherited from TActiveRecordRelation)
P | findForeignObjects | Fetches the foreign objects using TActiveRecord::findAllByIndex() . (inherited from TActiveRecordRelation)
P | getContext | . (inherited from TActiveRecordRelation)
P | getCriteria | . (inherited from TActiveRecordRelation)
P | getIndexValues | Obtain the foreign key index values from the results. (inherited from TActiveRecordRelation)
P | getObjectHash | object hash using crc32 and serialize. (inherited from TActiveRecordRelation)
 | getRelationForeignKeys | foreign key field names as key and object properties as value.
P | getSourceRecord | . (inherited from TActiveRecordRelation)
P | populateResult | Populate the results with the foreign objects found. (inherited from TActiveRecordRelation)
P | setObjectProperty | Sets the foreign objects to the given property on the source object.
P | setResultCollection | Populates the result array with foreign objects (matched using foreign key hashed property values). (inherited from TActiveRecordRelation)
 | updateAssociatedRecords | Updates the associated foreign objects.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordInvalidFinderResult

Namespace: System.Data.ActiveRecord
Inheritance: TEnumerable »
TActiveRecordInvalidFinderResult
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordManager

Namespace: System.Data.ActiveRecord
Inheritance: TComponent »
TActiveRecordManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Cache | ICache | application cache.
 | DbConnection | TDbConnection | default database connection.
 | GatewayClass | string | the implementation class of ActiveRecordGateway.
 | InvalidFinderResult | TActiveRecordInvalidFinderResult | Defaults to 'Null'.
R | RecordGateway | TActiveRecordGateway | record gateway.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createRecordGateway | default record gateway.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
S | getInstance | static instance of record manager.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordRelation

Namespace: System.Data.ActiveRecord.Relations
TActiveRecordRelation
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | collectForeignObjects | .
 | fetchResultsInto | Fetch results for current relationship.
P | findForeignKeys | Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value.
P | findForeignObjects | Fetches the foreign objects using TActiveRecord::findAllByIndex() .
P | getContext | .
P | getCriteria | .
P | getIndexValues | Obtain the foreign key index values from the results.
P | getObjectHash | object hash using crc32 and serialize.
 | getRelationForeignKeys | foreign key field names as key and object properties as value.
P | getSourceRecord | .
P | populateResult | Populate the results with the foreign objects found.
P | setObjectProperty | Sets the foreign objects to the given property on the source object.
P | setResultCollection | Populates the result array with foreign objects (matched using foreign key hashed property values).
Derived classes
  • TActiveRecordBelongsTo
  • TActiveRecordHasMany
  • TActiveRecordHasManyAssociation
  • TActiveRecordHasOne
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordRelationContext

Namespace: System.Data.ActiveRecord.Relations
TActiveRecordRelationContext
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getAssociationTable | the M-N relationship association table name.
 | getCondition | the query condition for the relation as specified in RELATIONS @since 3.
 | getFkField | foreign key field names, comma delimited.
 | getForeignRecordClass | foreign record class name.
 | getForeignRecordFinder | corresponding relationship foreign object finder instance.
 | getParameters | the query parameters for the relation as specified in RELATIONS @since 3.
 | getProperty | name of the record property that the relationship results will be assigned to.
 | getPropertyValue | .
 | getRelationForeignKeys | foreign key of this relations, the keys is dependent on the relationship type.
 | getRelationHandler | Creates and return the TActiveRecordRelation handler for specific relationships.
 | getRelationType | HAS_MANY, HAS_ONE, or BELONGS_TO.
 | getSourceRecord | the active record instance that queried for its related records.
 | hasAssociationTable | true if the relationship is HAS_MANY and requires an association table.
 | hasFkField | true if the 3rd element of an TActiveRecord::$RELATION entry is set.
 | hasRecordRelation | true if the relation is defined in TActiveRecord::$RELATIONS @since 3.
P | isEmptyFkObject | .
 | updateAssociatedRecords | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRepeater

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TRepeater »
TActiveRepeater
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | standard active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AlternatingItemRenderer | string | the class name for alternative repeater items. (inherited from TRepeater)
 | AlternatingItemTemplate | ITemplate | the alternative template string for the item. (inherited from TRepeater)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataKeyField | string | the field of the data source that provides the keys of the list items. (inherited from TRepeater)
R | DataKeys | TList | the keys used in the data listing control. (inherited from TRepeater)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EmptyRenderer | string | the class name for empty repeater item. (inherited from TRepeater)
 | EmptyTemplate | ITemplate | the template applied when no data is bound to the repeater. (inherited from TRepeater)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
R | Footer | TControl | the footer item. (inherited from TRepeater)
 | FooterRenderer | string | the class name for repeater footer item. (inherited from TRepeater)
 | FooterTemplate | ITemplate | the footer template. (inherited from TRepeater)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
R | Header | TControl | the header item. (inherited from TRepeater)
 | HeaderRenderer | string | the class name for repeater header item. (inherited from TRepeater)
 | HeaderTemplate | ITemplate | the header template. (inherited from TRepeater)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | ItemRenderer | string | the class name for repeater items. (inherited from TRepeater)
 | ItemTemplate | ITemplate | the template for repeater items. (inherited from TRepeater)
R | Items | TRepeaterItemCollection | list of repeater item controls. (inherited from TRepeater)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SeparatorRenderer | string | the class name for repeater item separators. (inherited from TRepeater)
 | SeparatorTemplate | ITemplate | the separator template. (inherited from TRepeater)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | SurroundingTagID | string | Returns the id of the surrounding container (span).
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnItemCommand | Raises OnItemCommand event. (inherited from TRepeater)
OnItemCreated | Raises OnItemCreated event. (inherited from TRepeater)
OnItemDataBound | Raises OnItemDataBound event. (inherited from TRepeater)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation to handle OnItemCommand event which is bubbled from repeater items and their child controls. (inherited from TRepeater)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createEmptyContent | Creates empty repeater content. (inherited from TRepeater)
P | createItem | Creates a repeater item instance based on the item type and index. (inherited from TRepeater)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDataFieldValue | Returns the value of the data at the specified field. (inherited from TRepeater)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads item count information from viewstate. (inherited from TRepeater)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate repeater items from data source. (inherited from TRepeater)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the repeater.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | reset | Clears up all items in the repeater. (inherited from TRepeater)
P | restoreItemsFromViewState | Creates repeater items based on viewstate information. (inherited from TRepeater)
 | saveState | Saves item count in viewstate. (inherited from TRepeater)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveTableCell

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTableCell »
TActiveTableCell
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | CellIndex | integer | Returns the zero-based index of the TActiveTableCell within the TTableCellCollection of the parent TTableRow control.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveTableCell.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
 | ColumnSpan | integer | the columnspan for the table cell, 0 if not set. (inherited from TTableCell)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the table cell. (inherited from TTableCell)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableCell)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the table cell.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Row | TTableRow | Returns the parent TTableRow control by looping through all parents until a TTableRow is found.
 | RowSpan | integer | the rowspan for the table cell, 0 if not set. (inherited from TTableCell)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name for the table cell. (inherited from TTableCell)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the table cell. (inherited from TTableCell)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableCell)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a table cell. (inherited from TTableCell)
Events
Name | Description
OnCellSelected | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control if the event handler for the OnCellSelected event is set.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object for the control. (inherited from TTableCell)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders and replaces the cell's content on the client-side.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table cell. (inherited from TTableCell)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveTableCellEventParameter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TEventParameter » TCallbackEventParameter »
TActiveTableCellEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CallbackParameter | mixed | callback request parameter. (inherited from TCallbackEventParameter)
R | NewWriter | TCallbackResponseWriter | holds the response content. (inherited from TCallbackEventParameter)
 | ResponseData | mixed | callback response data. (inherited from TCallbackEventParameter)
R | SelectedCellIndex | integer | Returns the zero-based index of the TActiveTableCell within the TTableCellCollection of the parent TTableRow control.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveTableRow

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTableRow »
TActiveTableRow
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | Cells | TTableCellCollection | list of TTableCell controls. (inherited from TTableRow)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveTableRow.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the table row.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | RowIndex | integer | Returns the zero-based index of the TActiveTableRow within the TTableRowCollection of the parent TTable control.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
R | Table | TTable | Returns the parent TTable control by looping through all parents until a TTable is found.
 | TableSection | TTableRowSection | location of a row in a table. (inherited from TTableRow)
RP | TagName | string | tag name for the table. (inherited from TTableRow)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnRowSelected | This method is invoked when a callback is requested.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control if the event handler for the OnRowSelected event is set.
 | addParsedObject | Adds object parsed from template to the control. (inherited from TTableRow)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation and raises the control's callback event.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TTableRow)
P | createStyle | Creates a style object for the control. (inherited from TTableRow)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders and replaces the row's content on the client-side.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table row . (inherited from TTableRow)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveTableRowEventParameter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TEventParameter » TCallbackEventParameter »
TActiveTableRowEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CallbackParameter | mixed | callback request parameter. (inherited from TCallbackEventParameter)
R | NewWriter | TCallbackResponseWriter | holds the response content. (inherited from TCallbackEventParameter)
 | ResponseData | mixed | callback response data. (inherited from TCallbackEventParameter)
R | SelectedRowIndex | integer | Returns the zero-based index of the TActiveTableRow within the TTableRowCollection of the parent TTable control.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveTemplateColumn

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn » TTemplateColumn »
TActiveTemplateColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | EditItemRenderer | string | the class name for the edit item cell renderer. (inherited from TTemplateColumn)
 | EditItemTemplate | ITemplate | the edit item template. (inherited from TTemplateColumn)
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterTemplate | ITemplate | the footer template. (inherited from TTemplateColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderTemplate | ITemplate | the header template. (inherited from TTemplateColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
 | ItemRenderer | string | the class name for the item cell renderer. (inherited from TTemplateColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | ItemTemplate | ITemplate | the item template. (inherited from TTemplateColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column. (inherited from TTemplateColumn)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values. (inherited from TTemplateColumn)
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | .
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveTextBox

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox »
TActiveTextBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. (inherited from TTextBox)
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the TTextBox control. (inherited from TTextBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
RP | PostBackOptions | array | Gets the post back options for this textbox. (inherited from TTextBox)
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox. (inherited from TTextBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component. (inherited from TTextBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TTextBox)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TTextBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode. (inherited from TTextBox)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TAutoComplete
  • TInPlaceTextBox
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplication

Namespace: System
Inheritance: TComponent »
TApplication
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
RP | ApplicationConfigurationClass | {unknown} | .
 | ApplicationStatePersister | IStatePersister | application state persister.
 | AssetManager | TAssetManager | asset manager.
R | AuthorizationRules | TAuthorizationRuleCollection | list of authorization rules for the current request.
 | BasePath | string | the directory containing the application configuration file (absolute path).
 | Cache | ICache | the cache module, null if cache module is not installed.
 | ConfigurationFile | string | the application configuration file (absolute path).
R | ConfigurationFileExt | string | the applictaion configuration type.
R | ConfigurationFileName | string | the default configuration file name.
 | ConfigurationType | string | the application configuration file (absolute path).
 | ErrorHandler | TErrorHandler | the error handler module.
 | Globalization | TGlobalization | globalization module.
 | ID | string | application ID.
 | Mode | TApplicationMode | application mode.
R | Modules | array | list of loaded application modules, indexed by module IDs.
 | PageServiceID | string | page service ID.
R | Parameters | TMap | Returns the list of application parameters.
 | Request | THttpRequest | the request module.
R | RequestCompleted | boolean | whether the current request is processed.
 | Response | THttpResponse | the response module.
 | RuntimePath | string | the directory storing cache data and application-level persistent data.
 | SecurityManager | TSecurityManager | the security manager module.
 | Service | IService | the currently requested service.
 | Session | THttpSession | the session module, null if session module is not installed.
R | UniqueID | string | an ID that uniquely identifies this Prado application from the others.
 | User | IUser | the application user.
Events
Name | Description
OnAuthentication | Raises OnAuthentication event.
OnAuthenticationComplete | Raises OnAuthenticationComplete event.
OnAuthorization | Raises OnAuthorization event.
OnAuthorizationComplete | Raises OnAuthorizationComplete event.
OnBeginRequest | Raises OnBeginRequest event.
OnEndRequest | Raises OnEndRequest event.
OnError | Raises OnError event.
OnLoadState | Raises OnLoadState event.
OnLoadStateComplete | Raises OnLoadStateComplete event.
OnPreFlushOutput | Raises OnPreFlushOutput event.
OnPreRunService | Raises OnPreRunService event.
OnSaveState | Raises OnSaveState event.
OnSaveStateComplete | Raises OnSaveStateComplete event.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyConfiguration | Applies an application configuration.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clearGlobalState | Clears a global value.
 | completeRequest | Completes current request processing.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flushOutput | Flushes output to client side.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getGlobalState | Returns a global value.
 | getModule | the module with the specified ID, null if not found.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initApplication | Loads configuration and initializes application.
P | loadGlobals | Loads global values from persistent storage.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | resolvePaths | Resolves application-relevant paths.
 | run | Executes the lifecycles of the application.
 | runService | Runs the requested service.
P | saveGlobals | Saves global values into persistent storage.
 | setGlobalState | Sets a global value.
 | setModule | Adds a module to application.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | startService | Starts the specified service.
Derived classes
  • TShellApplication
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplicationComponent

Namespace: System
Inheritance: TComponent »
TApplicationComponent
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance.
R | Request | THttpRequest | the current user request.
R | Response | THttpResponse | the response.
R | Service | IService | the current service.
R | Session | THttpSession | user session.
R | User | IUser | information about the current user.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
publishAsset | Publishes a private asset and gets its URL.
publishFilePath | Publishes a file or directory and returns its URL.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TCallbackClientScript
  • TClientScriptManager
  • TControl
  • TControlAdapter
  • TDataGridColumn
  • THtmlWriter
  • THttpRequest
  • THttpResponseAdapter
  • THttpSession
  • TJsonResponse
  • TLogRoute
  • TModule
  • TRpcClient
  • TService
  • TSoapServer
  • TTemplate
  • TTheme
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplicationConfiguration

Namespace: System
Inheritance: TComponent »
TApplicationConfiguration
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Aliases | array | Returns list of path alias definitions.
R | ExternalConfigurations | array | list of external configuration files.
R | IsEmpty | boolean | whether this configuration contains actual stuff.
R | Modules | array | Returns list of module configurations.
R | Parameters | array | Returns list of parameter definitions.
R | Properties | array | Returns list of page initial property values.
R | Services | array | list of service configurations.
R | Usings | array | Returns list of namespaces to be used.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | loadExternalPhp | Loads the external PHP array.
P | loadExternalXml | Loads the external XML configurations.
 | loadFromFile | Parses the application configuration file.
 | loadFromPhp | Parses the application configuration given in terms of a PHP array.
 | loadFromXml | Parses the application configuration given in terms of a TXmlElement.
P | loadModulesPhp | Loads the modules PHP array.
P | loadModulesXml | Loads the modules XML node.
P | loadParametersPhp | Loads the parameters PHP array.
P | loadParametersXml | Loads the parameters XML node.
P | loadPathsPhp | Loads the paths PHP array .
P | loadPathsXml | Loads the paths XML node.
P | loadServicesPhp | Loads the services PHP array.
P | loadServicesXml | Loads the services XML node.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplicationException

Namespace: System.Exceptions
Inheritance: TException »
TApplicationException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
  • TRpcClientRequestException
  • TRpcClientResponseException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplicationMode

Namespace: System
Inheritance: TEnumerable »
TApplicationMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplicationStateCacheDependency

Namespace: System.Caching
Inheritance: TComponent » TCacheDependency »
TApplicationStateCacheDependency
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | HasChanged | boolean | Performs the actual dependency checking.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplicationStatePersister

Namespace: System
Inheritance: TComponent » TApplicationComponent » TModule »
TApplicationStatePersister
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
RP | StateFilePath | string | the file path storing the application state.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes module.
load | Loads application state from persistent storage.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
save | Saves application state in persistent storage.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAssetManager

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent » TModule »
TAssetManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | BasePath | string | the root directory storing published asset files.
 | BaseUrl | string | the base url that the published asset files can be accessed.
 | ID | string | id of this module. (inherited from TModule)
 | Published | array | List of published assets @since 3.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | copyDirectory | Copies a directory recursively as another.
P | copyFile | Copies a file to a directory.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
P | deployTarFile | Extracts the tar file to the destination directory.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getPublishedPath | Returns the published path of a file path.
 | getPublishedUrl | Returns the URL of a published file path.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | hash | Generate a CRC32 hash for the directory path.
 | init | Initializes the module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or a directory (recursively).
 | publishTarFile | Publish a tar file by extracting its contents to the assets directory.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAttributeCollection

Namespace: System.Collections
Inheritance: TComponent » TMap »
TAttributeCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | CaseSensitive | boolean | whether the keys are case-sensitive.
R | Count | integer | the number of items in the map. (inherited from TMap)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TMap)
R | Keys | array | the key list. (inherited from TMap)
 | ReadOnly | boolean | whether this map is read-only or not. (inherited from TMap)
Events
Methods
Name | Description
add | Adds an item into the map.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read.
canSetProperty | Determines whether a property can be set.
clear | Removes all items in the map. (inherited from TMap)
contains | Returns whether the specified is in the map.
copyFrom | Copies iterable data into the map. (inherited from TMap)
count | Returns the number of items in the map. (inherited from TMap)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined.
itemAt | Returns the item with the specified key.
mergeWith | Merges iterable data into the map. (inherited from TMap)
offsetExists | Returns whether there is an element at the specified offset. (inherited from TMap)
offsetGet | Returns the element at the specified offset. (inherited from TMap)
offsetSet | Sets the element at the specified offset. (inherited from TMap)
offsetUnset | Unsets the element at the specified offset. (inherited from TMap)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the map by its key.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TMap)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAuthManager

Namespace: System.Security
Inheritance: TComponent » TApplicationComponent » TModule »
TAuthManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AllowAutoLogin | boolean | whether to allow remembering login so that the user logs on automatically next time.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | AuthExpire | integer | authentication expiration time in seconds.
 | ID | string | id of this module. (inherited from TModule)
 | LoginPage | string | path of login page should login is required.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ReturnUrl | string | URL that the browser should be redirected to when login succeeds.
 | ReturnUrlVarName | string | the name of the session variable storing return URL.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | UserKey | string | a unique variable name for storing user session/cookie data @since 3.
 | UserManager | IUserManager | user manager instance.
Events
Name | Description
OnAuthExpire | Performs user logout on authentication expiration.
OnAuthenticate | Performs the real authentication work.
OnAuthorize | Performs the real authorization work.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | doAuthentication | Performs authentication.
 | doAuthorization | Performs authorization.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | generateUserKey | a key used to store user information in session @since 3.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | leave | Performs login redirect if authorization fails.
 | login | Logs in a user with username and password.
 | logout | Logs out a user.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | switchUser | Switches to a new user.
 | updateSessionUser | Updates the user data stored in session.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAuthorizationRule

Namespace: System.Security
Inheritance: TComponent »
TAuthorizationRule
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Action | string | action, either 'allow' or 'deny'.
R | AuthenticatedApplied | boolean | if this rule applies to authenticated users.
R | EveryoneApplied | boolean | if this rule applies to everyone.
R | GuestApplied | boolean | if this rule applies to everyone.
R | IPRules | array | list of IP rules.
R | Roles | array | list of roles.
R | Users | array | list of user IDs.
R | Verb | string | verb, may be empty, 'get', or 'post'.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
isUserAllowed | 1 if the user is allowed, -1 if the user is denied, 0 if the rule does not apply to the user.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAuthorizationRuleCollection

Namespace: System.Security
Inheritance: TComponent » TList »
TAuthorizationRuleCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
isUserAllowed | whether the user is allowed.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAutoComplete

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox » TActiveTextBox »
TAutoComplete
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options. (inherited from TActiveTextBox)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. (inherited from TTextBox)
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveButton.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options. (inherited from TActiveTextBox)
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the TTextBox control. (inherited from TTextBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | Frequency | float | maximum delay (in seconds) before requesting a suggestion.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
 | MinChars | integer | minimum number of characters before requesting a suggestion.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
RP | PostBackOptions | array | list of callback options.
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | ResultPanel | TPanel | suggestion results panel.
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
 | Separator | string | word or token separators (delimiters).
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | Suggestions | TRepeater | suggestion list repeater.
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox. (inherited from TTextBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextCssClass | string | Css class name of the element to use for suggestion.
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component. (inherited from TTextBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TTextBox)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested. (inherited from TActiveTextBox)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnSuggest | This method is invoked when an autocomplete suggestion is requested.
OnSuggestionSelected | This method is invoked when an autocomplete suggestion is selected.
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control. (inherited from TActiveTextBox)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createRepeater | new instance of TRepater to render the list of suggestions.
P | createResultPanel | new instance of result panel.
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Overrides parent implementation.
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TTextBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
 | renderCallback | Renders the suggestions during a callback respones.
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode. (inherited from TTextBox)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the end tag and registers javascript effects library.
P | renderResultPanel | Renders the result panel.
 | renderSuggestions | Renders the suggestions repeater.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setDataSource | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAutoCompleteEventParameter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TEventParameter » TCallbackEventParameter »
TAutoCompleteEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CallbackParameter | mixed | callback request parameter. (inherited from TCallbackEventParameter)
R | NewWriter | TCallbackResponseWriter | holds the response content. (inherited from TCallbackEventParameter)
 | ResponseData | mixed | callback response data. (inherited from TCallbackEventParameter)
R | SelectedIndex | int | selected suggestion zero-based index, -1 if not selected.
R | Token | string | token for matching a list of suggestions.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAutoCompleteTemplate

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent »
TAutoCompleteTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
instantiateIn | Instantiates the template.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBaseActiveCallbackControl

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TBaseActiveControl »
TBaseActiveCallbackControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | CallbackOptions | string | ID of a TCallbackOptions control from which ClientSide options are duplicated.
 | CallbackParameter | mixed | callback parameter value.
 | CausesValidation | boolean | whether callback event trigger by this button will cause input validation, default is true.
 | ClientSide | TCallbackClientSide | Callback client-side options can be set by setting the properties of the ClientSide property.
RP | ClientSideOptions | array | list of callback javascript options.
RP | Control | TControl | the attached control. (inherited from TBaseActiveControl)
RP | DefaultClientSideOptions | array | Returns an array of default callback client-side options.
 | EnableUpdate | boolean | true to allow fine grain callback updates. (inherited from TBaseActiveControl)
R | Javascript | string | Returns the javascript callback request instance.
R | JsCallbackOptions | {unknown} | .
RP | Options | TMap | active control options. (inherited from TBaseActiveControl)
RP | Page | TPage | the page containing the attached control. (inherited from TBaseActiveControl)
 | ValidationGroup | string | the group of validators which the button causes validation upon callback.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canCauseValidation | whether to perform validation if the callback is requested.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | canUpdateClientSide | Returns true if callback response is allowed to update the browser contents. (inherited from TBaseActiveControl)
P | createClientSide | callback client-side options.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | Gets an option named value. (inherited from TBaseActiveControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerCallbackClientScript | Registers the callback control javascript code.
P | setOption | Sets a named options with a value. (inherited from TBaseActiveControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBaseActiveControl

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent »
TBaseActiveControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
RP | Control | TControl | the attached control.
 | EnableUpdate | boolean | true to allow fine grain callback updates.
RP | Options | TMap | active control options.
RP | Page | TPage | the page containing the attached control.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | canUpdateClientSide | Returns true if callback response is allowed to update the browser contents.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | Gets an option named value.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setOption | Sets a named options with a value.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TBaseActiveCallbackControl
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBaseDataList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl »
TBaseDataList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CellPadding | integer | the cellpadding for the table layout.
 | CellSpacing | integer | the cellspacing for the table layout.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataKeyField | string | the field of the data source that provides the keys of the list items.
R | DataKeys | TList | the keys used in the data listing control.
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GridLines | TTableGridLines | the grid line setting of the table layout.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the table content.
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDataFieldValue | Returns the value of the data at the specified field.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | . (inherited from TDataBoundControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TDataGrid
  • TDataList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBaseValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel »
TBaseValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events.
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate.
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidatorDisplayStyle | the style of displaying the error message.
 | EnableClientScript | boolean | whether client-side validation is enabled.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | ErrorMessage | string | the text for the error message.
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true.
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to.
R | ValidationTarget | TControl | control to be validated.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered.
OnUnload | Unregisters the validator from page.
OnValidate | This event is raised right before the validator starts to perform validation.
OnValidationError | This event is raised when the validator fails in validation.
OnValidationSuccess | This event is raised when the validator succeeds in validation.
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
P | evaluateIsValid | This is the major method for validation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated.
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script.
 | renderContents | Renders the validator control.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
 | validate | Validates the specified control.
Derived classes
  • TCaptchaValidator
  • TCompareValidator
  • TCustomValidator
  • TDataTypeValidator
  • TListControlValidator
  • TRangeValidator
  • TReCaptchaValidator
  • TRegularExpressionValidator
  • TRequiredFieldValidator
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBoundColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TBoundColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataField | string | the field name from the data source to bind to the column.
 | DataFormatString | string | the formatting string used to control how the bound data will be displayed.
 | EditItemRenderer | string | the class name for the edit item cell renderer.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
 | ItemRenderer | string | the class name for the item cell renderer.
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
 | ReadOnly | boolean | whether the items in the column can be edited.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
  • TActiveBoundColumn
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBroadcastEventParameter

Namespace: System.Web.UI
Inheritance: TComponent » TEventParameter »
TBroadcastEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Name | string | name of the broadcast event.
Parameter | mixed | parameter of the broadcast event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBrowserLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TLogRoute »
TBrowserLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Categories | array | list of categories to be looked for. (inherited from TLogRoute)
 | CssClass | string | the css class of the control.
 | Levels | integer | log level filter. (inherited from TLogRoute)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination. (inherited from TLogRoute)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields. (inherited from TLogRoute)
P | getColorLevel | .
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLevelName | level name. (inherited from TLogRoute)
P | getLevelValue | level value. (inherited from TLogRoute)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the route. (inherited from TLogRoute)
 | processLogs | .
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | renderFooter | .
P | renderHeader | .
P | renderMessage | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TFirebugLogRoute
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBulletStyle

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TBulletStyle
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBulletedList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl »
TBulletedList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | BulletImageUrl | string | image URL used for bullets when BulletStyle is 'CustomImage'.
 | BulletStyle | TBulletStyle | style of bullets.
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | DisplayMode | TBulletedListDisplayMode | display mode of the list.
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | FirstBulletNumber | integer | starting index when BulletStyle is one of the following: 'Numbered', 'LowerAlpha', 'UpperAlpha', 'LowerRoman', 'UpperRoman'.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this is a multiselect control. (inherited from TListControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | postback options used for linkbuttons.
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the bulleted list.
 | Target | string | the target window or frame to display the Web page content linked to when DisplayMode is 'HyperLink' and one of the hyperlinks is clicked.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnClick | Raises 'OnClick' event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | canCauseValidation | .
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
P | renderBulletText | Renders each item .
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders the body contents.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderHyperLinkItem | .
P | renderLinkButtonItem | .
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
P | renderTextItem | .
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBulletedListDisplayMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TBulletedListDisplayMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBulletedListEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TBulletedListEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Index | integer | zero-based index of the item (rendered as a link button) that is clicked.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TButton

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | ButtonType | TButtonType | the type of the button.
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation, default is true.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | CommandName | string | the command name associated with the OnCommand event.
 | CommandParameter | string | the parameter associated with the OnCommand event.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the caption of the button.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsDefaultButton | boolean | true if this button is registered as a default button for a panel.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the button.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | caption of the button.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnClick | This method is invoked when the button is clicked.
OnCommand | This method is invoked when the button is clicked.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | canCauseValidation | whether to perform validation if the button is clicked.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | needPostBackScript | whether the button needs javascript to do postback.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the client-script code.
 | renderContents | Renders the body content enclosed between the control tag.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveButton
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TButtonColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TButtonColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ButtonType | TButtonColumnType | the type of command button.
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation, default is true.
 | CommandName | string | the command name associated with the OnCommand event.
 | DataImageUrlField | string | the field name from the data source to bind to the button image url.
 | DataImageUrlFormatString | string | the formatting string used to control how the button image url will be displayed.
 | DataTextField | string | the field name from the data source to bind to the button caption.
 | DataTextFormatString | string | the formatting string used to control how the button caption will be displayed.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
 | ImageUrl | string | the URL of the image file for image buttons.
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
 | Text | string | the text caption of the button.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback.
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
  • TActiveButtonColumn
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TButtonColumnType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TButtonColumnType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TButtonType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TButtonType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCache

Namespace: System.Caching
Inheritance: TComponent » TApplicationComponent » TModule »
TCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
 | KeyPrefix | string | a unique prefix for the keys of cached values.
 | PrimaryCache | boolean | whether this cache module is used as primary/system cache.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | add | Stores a value identified by a key into cache if the cache does not contain this key.
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addValue | Stores a value identified by a key into cache if the cache does not contain this key.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes a value with the specified key from cache .
P | deleteValue | Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Deletes all values from cache.
P | generateUniqueKey | a key generated from the provided key which ensures the uniqueness across applications.
 | get | Retrieves a value from cache with a specified key.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValue | Retrieves a value from cache with a specified key.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the cache module.
 | offsetExists | Returns whether there is a cache entry with a specified key.
 | offsetGet | Retrieves the value from cache with a specified key.
 | offsetSet | Stores the value identified by a key into cache.
 | offsetUnset | Deletes the value with the specified key from cache This method is required by the interface ArrayAccess.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | set | Stores a value identified by a key into cache.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setValue | Stores a value identified by a key in cache.
Derived classes
  • TAPCCache
  • TDbCache
  • TMemCache
  • TSqliteCache
  • TXCache
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCacheDependency

Namespace: System.Caching
Inheritance: TComponent »
TCacheDependency
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | HasChanged | boolean | whether the dependency has changed. (inherited from ICacheDependency)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TApplicationStateCacheDependency
  • TChainedCacheDependency
  • TDirectoryCacheDependency
  • TFileCacheDependency
  • TGlobalStateCacheDependency
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCacheDependencyList

Namespace: System.Caching
Inheritance: TComponent » TList »
TCacheDependencyList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCacheHttpSession

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent » THttpSession »
TCacheHttpSession
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | AutoStart | boolean | whether the session should be automatically started when the session module is initialized, defaults to false. (inherited from THttpSession)
R | Cache | ICache | the cache module being used for data storage.
 | CacheModuleID | string | the ID of the cache module.
R | Cookie | THttpCookie | cookie that will be used to store session ID. (inherited from THttpSession)
 | CookieMode | THttpSessionCookieMode | how to use cookie to store session ID. (inherited from THttpSession)
R | Count | integer | the number of session variables. (inherited from THttpSession)
 | GCProbability | integer | the probability (percentage) that the gc (garbage collection) process is started on every session initialization, defaults to 1 meaning 1% chance. (inherited from THttpSession)
 | ID | string | id of this module. (inherited from THttpSession)
R | IsStarted | boolean | whether the session has started. (inherited from THttpSession)
R | Iterator | TSessionIterator | Returns an iterator for traversing the session variables. (inherited from THttpSession)
 | KeyPrefix | string | prefix of session variable name to avoid conflict with other cache data.
R | Keys | array | the list of session variable names. (inherited from THttpSession)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | SavePath | string | the current session save path, defaults to '/tmp'. (inherited from THttpSession)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SessionID | string | the current session ID. (inherited from THttpSession)
 | SessionName | string | the current session name. (inherited from THttpSession)
 | Timeout | integer | the number of seconds after which data will be seen as 'garbage' and cleaned up, defaults to 1440 seconds. (inherited from THttpSession)
 | UseCustomStorage | boolean | whether to use user-specified handlers to store session data. (inherited from THttpSession)
 | UseTransparentSessionID | boolean | whether transparent sid support is enabled or not, defaults to false. (inherited from THttpSession)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | _close | Session close handler. (inherited from THttpSession)
 | _destroy | Session destroy handler.
 | _gc | Session GC (garbage collection) handler. (inherited from THttpSession)
 | _open | Session open handler. (inherited from THttpSession)
 | _read | Session read handler.
 | _write | Session write handler.
 | add | Adds a session variable. (inherited from THttpSession)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
P | calculateKey | a safe cache key associated with the session variable name.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clear | Removes all session variables. (inherited from THttpSession)
 | close | Ends the current session and store session data. (inherited from THttpSession)
 | contains | whether there is the named session variable. (inherited from THttpSession)
 | count | Returns the number of items in the session. (inherited from THttpSession)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | destroy | Destroys all data registered to a session. (inherited from THttpSession)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the module.
 | itemAt | Returns the session variable value with the session variable name. (inherited from THttpSession)
 | offsetExists | This method is required by the interface ArrayAccess. (inherited from THttpSession)
 | offsetGet | This method is required by the interface ArrayAccess. (inherited from THttpSession)
 | offsetSet | This method is required by the interface ArrayAccess. (inherited from THttpSession)
 | offsetUnset | This method is required by the interface ArrayAccess. (inherited from THttpSession)
 | open | Starts the session if it has not started yet. (inherited from THttpSession)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | regenerate | Update the current session id with a newly generated one . (inherited from THttpSession)
 | remove | Removes a session variable. (inherited from THttpSession)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | toArray | the list of all session variables in array. (inherited from THttpSession)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCachePageStatePersister

Namespace: System.Web.UI
Inheritance: TComponent »
TCachePageStatePersister
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Cache | ICache | the cache module being used for data storage.
 | CacheModuleID | string | the ID of the cache module.
 | CacheTimeout | integer | the number of seconds in which the cached state will expire.
 | KeyPrefix | string | prefix of cache variable name to avoid conflict with other cache data.
 | Page | {unknown} | .
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
P | calculateKey | a key that is unique per user request.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | load | Loads page state from cache.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | save | Saves state in cache.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCachingStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent »
TCachingStatement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ID | {unknown} | .
R | Manager | {unknown} | .
R | Statement | {unknown} | .
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createCommand | .
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | executeInsert | .
 | executeQueryForList | .
 | executeQueryForMap | .
 | executeQueryForObject | .
 | executeUpdate | .
P | getCacheKey | .
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallback

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl »
TCallback
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveCallbackControl | standard callback options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TTimeTriggeredCallback
  • TTriggeredCallback
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackClientScript

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent »
TCallbackClientScript
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | ClientFunctionsToExecute | array | list of client function to be executed during callback response.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addCssClass | Add a Css class name to the element.
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | addPostDataLoader | .
 | appear | Visual Effect: Gradually make the element appear.
 | appendContent | Append a HTML fragement to the element.
 | appendScriptBlock | Appends a block of inline javascript enclosed in a boundary.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | blindDown | Visual Effect: Blind down.
 | blindUp | Visual Effect: Blind up.
 | callClientFunction | Executes a client-side statement.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | check | Client script to check or uncheck a checkbox or radio button.
 | click | Client script to click on an element.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | dropOut | Visual Effect: Drop out.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateScript | Evaluate a block of javascript enclosed in a boundary.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | fade | Visual Effect: Gradually fade the element.
 | focus | Focus on a particular element.
 | fold | Visual Effect: Fold.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | grow | Visual Effect: Gradually make an element grow to a predetermined size.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hide | Hides an element by changing its CSS display style to "none".
 | highlight | Visual Effect: High light the element for about 2 seconds.
 | insertContentAfter | Insert a HTML fragement after the element.
 | insertContentBefore | Insert a HTML fragement in before the element.
 | prependContent | Prepend a HTML fragement to the element.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | puff | Visual Effect: Gradually grow and fade the element.
 | pulsate | Visual Effect: Pulsate.
 | raiseClientEvent | Raise the client side event (given by $eventName) on a particular element.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes an element from the HTML page.
 | removeCssClass | Remove a Css class name from the element.
P | replace | Replace the content of an element with new content.
 | replaceContent | Replace the content of an element with new content contained in writer.
 | scrollTo | Scroll the top of the browser viewing area to the location of the element.
 | select | Client script to select/clear/check a drop down list, check box list, or radio button list.
 | setAttribute | Sets the attribute of a particular control.
 | setListItems | Sets the options of a select input element.
 | setOpacity | Set the opacity on a html element or control.
 | setStyle | Sets the style of element.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setValue | Client script to set the value of a particular input element.
 | shake | Visual Effect: Shake the element.
 | show | Shows an element by changing its CSS display style as empty.
 | shrink | Visual Effect: Shrink the element.
 | slideDown | Visual Effect: Slide down.
 | slideUp | Visual Effect: Side up.
 | squish | Visual Effect: Squish the element.
 | switchOff | Visual Effect: Switch Off effect.
 | toggle | Toggles the visibility of the element.
 | update | Update the element's innerHTML with new content.
 | visualEffect | Add a visual effect the element.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackClientSide

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TClientSideOptions »
TCallbackClientSide
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | EnablePageStateUpdate | boolean | client-side viewstate will be updated on callback response if true.
 | HasPriority | boolean | true if the callback request has priority and will abort existing prioritized request in order to send immediately.
 | OnComplete | string | javascript code for client-side onComplete event.
 | OnException | string | javascript code for client-side onException event.
 | OnFailure | string | javascript code for client-side onFailure event.
 | OnInteractive | string | javascript code for client-side onInteractive event.
 | OnLoaded | string | javascript code for client-side onLoaded event.
 | OnLoading | string | javascript code for client-side onLoading event.
 | OnPreDispatch | string | javascript code to be executed before a request is dispatched.
 | OnSuccess | string | javascript code for client-side onSuccess event.
 | OnUninitialized | string | javascript code for client-side onUninitialized event.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
 | PostBackParameter | string | post back event parameter.
 | PostBackTarget | string | post back target ID.
 | PostState | boolean | true to post the inputs of the form on callback, default is post the inputs on callback.
 | RequestTimeOut | integer | callback request timeout.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Returns javascript statement enclosed within a javascript function.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveCustomValidatorClientSide
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackErrorHandler

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TModule » TErrorHandler »
TCallbackErrorHandler
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ErrorTemplatePath | string | the directory containing error template files. (inherited from TErrorHandler)
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | displayException | Displays the exceptions to the client-side TJavascriptLogger.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getErrorTemplate | Retrieves the template used for displaying external exceptions. (inherited from TErrorHandler)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getExceptionTemplate | Retrieves the template used for displaying internal exceptions. (inherited from TErrorHandler)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | handleError | Handles PHP user errors and exceptions. (inherited from TErrorHandler)
P | handleExternalError | Displays error to the client user. (inherited from TErrorHandler)
P | handleRecursiveError | Handles error occurs during error handling (called recursive error). (inherited from TErrorHandler)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
SP | hideSecurityRelated | @since 3. (inherited from TErrorHandler)
 | init | Initializes the module. (inherited from TErrorHandler)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackEventParameter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TEventParameter »
TCallbackEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CallbackParameter | mixed | callback request parameter.
R | NewWriter | TCallbackResponseWriter | holds the response content.
 | ResponseData | mixed | callback response data.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveTableCellEventParameter
  • TActiveTableRowEventParameter
  • TAutoCompleteEventParameter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackOptions

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl »
TCallbackOptions
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | Callback client-side options can be set by setting the properties of the ClientSide property.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | callback client-side options.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackPageStateTracker

Namespace: System.Web.UI.ActiveControls
TCallbackPageStateTracker
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | addStatesToTrack | Add a list of view states to track.
P | client | callback client scripting.
P | getChanges | list of viewstate and the changed data.
P | getStatesToTrack | list of viewstates to track.
 | respondToChanges | For each of the changes call the corresponding change handlers.
 | trackChanges | Start tracking view state changes.
P | updateAccessKey | Updates the modifier access key .
P | updateAttributes | Updates/adds a list of attributes on the control.
P | updateEnabled | Enables or Disables the control on the client-side.
P | updateStyle | Updates the CSS style on the control on the client-side.
P | updateTabIndex | Updates the tab index.
P | updateToolTip | Updates the tooltip.
P | updateVisible | Hides or shows the control on the client-side.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackResponseAdapter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » THttpResponseAdapter »
TCallbackResponseAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | RedirectedUrl | string | new url for callback response to redirect to.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response object adapted. (inherited from THttpResponseAdapter)
 | ResponseData | mixed | callback response data.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createNewHtmlWriter | Returns a new instance of THtmlWriter.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flushContent | Flushes the contents in the writers.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
httpRedirect | Delay the redirect until we process the rest of the page.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackResponseWriter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TTextWriter »
TCallbackResponseWriter
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Boundary | string | boundary identifier.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flush | Returns the text content wrapped within a HTML comment with boundary identifier as its comment content.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
write | Writes a string. (inherited from TTextWriter)
writeLine | Writers a string and terminates it with a newline. (inherited from TTextWriter)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCaptcha

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TImage »
TCaptcha
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AlternateText | string | the alternative text displayed in the TImage component when the image is unavailable. (inherited from TImage)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
RP | CaptchaScriptFile | string | the file path of the PHP script generating the token image.
 | CaseSensitive | boolean | whether the token should be treated as case-sensitive.
 | ChangingTokenBackground | boolean | whether the background of the token image should be variated during postbacks.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL of the image file. (inherited from TImage)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | DescriptionUrl | string | the URL to long description. (inherited from TImage)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
RP | FontFile | {unknown} | .
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageAlign | string | the alignment of the image with respective to other elements on the page, defaults to empty. (inherited from TImage)
 | ImageUrl | string | the URL of the image file. (inherited from TImage)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsTokenExpired | boolean | whether the currently generated token has expired.
 | MaxTokenLength | integer | the maximum length of the token.
 | MinTokenLength | integer | the minimum length of the token.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | PrivateKey | string | the private key used for generating the token.
 | PublicKey | string | the public key used for generating the token.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of image control. (inherited from TImage)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | TestLimit | integer | how many times a generated token can be tested.
R | Token | string | the token that will be displayed.
 | TokenAlphabet | string | the characters that may appear in the token.
 | TokenExpiry | integer | the number of seconds that a generated token will remain valid.
 | TokenFontSize | integer | the font size used for displaying the token in an image.
RP | TokenImageOptions | string | the options to be passed to the token image generator.
 | TokenImageTheme | integer | the theme of the token image.
RP | TokenLength | integer | the length of the token to be generated.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Configures the image URL that shows the token.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes related to an HTML image element to renderer. (inherited from TImage)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
S | checkRequirements | Checks the requirements needed for generating CAPTCHA images.
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | generatePrivateKeyFile | Generates a file with a randomly generated private key.
P | generateRandomKey | a randomly generated key.
P | generateToken | Generates the token.
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | hash2string | Converts a hash string into a string with characters consisting of alphanumeric characters.
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | regenerateToken | Regenerates the token to be displayed.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the image. (inherited from TImage)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
 | validate | Validates a user input with the token.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCaptchaValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TCaptchaValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CaptchaControl | string | the ID path of the CAPTCHA control to validate.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
P | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | findCaptchaControl | the CAPTCHA control to be validated against @throws TConfigurationException if the CAPTCHA cannot be found according to CaptchaControl.
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TChainedCacheDependency

Namespace: System.Caching
Inheritance: TComponent » TCacheDependency »
TChainedCacheDependency
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Dependencies | TCacheDependencyList | list of dependency objects.
R | HasChanged | boolean | Performs the actual dependency checking.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCheckBox

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TCheckBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | whether clicking on the checkbox will post the page.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event triggered by this checkbox will cause input validation, default is true.
 | Checked | boolean | whether the checkbox is checked.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | boolean | Returns the value indicating whether the checkbox is checked.
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | InputAttributes | TMap | list of attributes to be rendered for the checkbox.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully.
R | LabelAttributes | TMap | list of attributes to be rendered for label beside the checkbox.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | bool | Check if we need a span tag to surround this control.
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | SurroundingTagID | string | the id of the surrounding tag or this clientID if no such tag needed.
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the checkbox.
 | TextAlign | TTextAlign | the alignment (Left or Right) of the text caption, defaults to TTextAlign::Right.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the checkbox causes validation upon postback.
R | ValidationPropertyValue | mixed | Returns the value of the property that needs validation.
 | Value | string | the value of the checkbox.
RP | ValueAttribute | string | the value attribute to be rendered.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCheckedChanged | Raises OnCheckedChanged event when Checked changes value during postback.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the checkbox to receive postback data during postback.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the client-script code.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderInputTag | Renders a checkbox input element.
P | renderLabel | Renders a label beside the checkbox.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveCheckBox
  • TRadioButton
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCheckBoxColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TCheckBoxColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataField | string | the field name from the data source to bind to the column.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
 | ReadOnly | boolean | whether the items in the column can be edited.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
  • TActiveCheckBoxColumn
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCheckBoxList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl »
TCheckBoxList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
 | CellPadding | integer | the cellpadding for the table keeping the checkbox list.
 | CellSpacing | integer | the cellspacing for the table keeping the checkbox list.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item.
R | HasHeader | boolean | Returns a value indicating whether this control contains header item.
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items.
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control supports multiple selection.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully.
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox.
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
 | RepeatColumns | integer | the number of columns that the list should be displayed with.
 | RepeatDirection | string | the direction of traversing the list, defaults to 'Vertical'.
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers).
 | RepeatLayout | string | how the list should be displayed, using table or using line breaks.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | boolean | Wether the list should be rendered inside a span or not .
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | TextAlign | TTextAlign | the alignment of the text caption, defaults to TTextAlign::Right.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated.
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers for post data on postback.
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TListControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createRepeatedControl | Creates a control used for repetition (used as a template).
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID.
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | generateItemStyle | Returns a style used for rendering items.
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox list control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list.
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveCheckBoxList
  • TRadioButtonList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TChoiceFormat

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TControl » TI18NControl » TTranslate »
TChoiceFormat
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | Catalogue | string | Get the message catalogue. (inherited from TTranslate)
 | Charset | string | Gets the charset. (inherited from TI18NControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | Culture | string | Get the specific culture for this control. (inherited from TI18NControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | Key | string | Get the key for message lookup. (inherited from TTranslate)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parameters | TAttributeCollection | Returns the list of custom parameters. (inherited from TTranslate)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text to be localized/translated. (inherited from TTranslate)
 | Trim | boolean | Trim the content or not. (inherited from TTranslate)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Value | float | the numerical value.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getParameter | parameter value, null if parameter does not exist. (inherited from TTranslate)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasParameter | whether the named parameter exists. (inherited from TTranslate)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removeParameter | Removes the named parameter. (inherited from TTranslate)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | renders the translated string. (inherited from TTranslate)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setParameter | . (inherited from TTranslate)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | translateText | Display the choosen translated string.
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCircleHotSpot

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » THotSpot »
TCircleHotSpot
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key that allows you to quickly navigate to the HotSpot region. (inherited from THotSpot)
 | AlternateText | string | the alternate text to display for a HotSpot object. (inherited from THotSpot)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from THotSpot)
 | CausesValidation | boolean | whether postback event trigger by this hotspot will cause input validation, default is true. (inherited from THotSpot)
R | Coordinates | string | coordinates defining this hotspot shape.
R | HasAttributes | boolean | whether the hotspot has custom attributes. (inherited from THotSpot)
 | HotSpotMode | THotSpotMode | the behavior of a HotSpot object when it is clicked. (inherited from THotSpot)
 | NavigateUrl | string | the URL to navigate to when a HotSpot object is clicked. (inherited from THotSpot)
 | PostBackValue | string | a value that is post back when the HotSpot is clicked. (inherited from THotSpot)
 | Radius | integer | radius of the circular HotSpot region.
R | Shape | string | shape of this hotspot.
 | TabIndex | integer | the tab index of the HotSpot region. (inherited from THotSpot)
 | Target | string | the target window or frame to display the new page when the HotSpot region is clicked. (inherited from THotSpot)
 | ValidationGroup | string | the group of validators which the hotspot causes validation upon postback. (inherited from THotSpot)
 | X | integer | the X coordinate of the center of the circular HotSpot region.
 | Y | integer | the Y coordinate of the center of the circular HotSpot region.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from THotSpot)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from THotSpot)
 | hasAttribute | whether the named attribute exists. (inherited from THotSpot)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | removeAttribute | Removes the named attribute. (inherited from THotSpot)
 | render | Renders this hotspot. (inherited from THotSpot)
 | setAttribute | Sets a custom hotspot attribute. (inherited from THotSpot)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from THotSpot)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TClientScript

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TClientScript
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | FlushScriptFiles | bool | whether to flush script files using TClientScriptManager::flushScriptFiles() before rendering the script block.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PradoScripts | string | comma delimited list of javascript libraries to included on the page.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScriptUrl | string | custom javascript file url.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Calls the client script manager to add each of the requested client script libraries.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the body content as javascript block.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
P | renderCustomScript | Registers the body content as javascript.
P | renderCustomScriptFile | Renders the custom script file.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveClientScript
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TClientScriptManager

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent »
TClientScriptManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | HiddenFields | {unknown} | .
R | PradoScriptAssetUrl | string | Prado javascript library base asset url.
RP | RenderedScriptFiles | {unknown} | .
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | RequiresHead | boolean | whether THead is required in order to render CSS and js within head @since 3.
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | ScriptUrls | array | Returns the URLs of all script files referenced on the page .
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | StyleSheetUrls | array | Returns the URLs of all stylesheet files referenced on the page .
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | checkIfNotInRender | Checks whether page rendering has not begun yet.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flushScriptFiles | Flushes all pending script registrations .
 | getCallbackReference | Returns javascript statement that create a new callback request object.
P | getDefaultButtonOptions | default button options.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPackagePathUrl | tuple($path,$url).
S | getPradoPackages | .
S | getPradoScripts | .
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasBeginScripts | true if any begin scripts are registered.
 | hasEndScripts | true if any end scripts are registered.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | isBeginScriptRegistered | whether there is a beginning javascript block registered with the specified key.
 | isEndScriptRegistered | whether there is an ending javascript block registered with the specified key.
 | isHeadScriptFileRegistered | whether there is a head javascript file registered with the specified key.
 | isHeadScriptRegistered | whether there is a head javascript block registered with the specified key.
 | isHiddenFieldRegistered | whether there is a hidden field registered with the specified key.
 | isScriptFileRegistered | whether there is a javascript file registered with the specified key.
 | isStyleSheetFileRegistered | whether there is a CSS file registered with the specified key.
 | isStyleSheetRegistered | whether there is a CSS block registered with the specified key.
 | markScriptFileAsRendered | .
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerBeginScript | Registers a javascript script block at the beginning of the form .
 | registerCallbackControl | Registers callback javascript for a control.
 | registerDefaultButton | Register a default button to panel.
 | registerEndScript | Registers a javascript script block at the end of the form .
 | registerFocusControl | Registers the control to receive default focus.
 | registerHeadScript | Registers a javascript block in the page head.
 | registerHeadScriptFile | Registers a javascript file in the page head .
 | registerHiddenField | Registers a hidden field to be rendered in the form.
 | registerPostBackControl | Registers postback javascript for a control.
 | registerPradoScript | Registers Prado javascript by library name.
P | registerPradoScriptInternal | Registers a Prado javascript library to be loaded.
 | registerScriptFile | Registers a javascript file to be rendered within the form .
 | registerStyleSheet | Registers a CSS block to be rendered in the page head .
 | registerStyleSheetFile | Registers a CSS file to be rendered in the page head The CSS files in themes are registered in onPreRenderComplete if you want to override CSS styles in themes you need to register it after this event is completed.
 | renderAllPendingScriptFiles | .
 | renderBeginScripts | .
 | renderEndScripts | .
 | renderHeadScriptFiles | .
 | renderHeadScripts | .
 | renderHiddenFieldsBegin | .
 | renderHiddenFieldsEnd | .
P | renderHiddenFieldsInt | .
P | renderScriptFiles | .
 | renderScriptFilesBegin | .
 | renderScriptFilesEnd | .
 | renderStyleSheetFiles | .
 | renderStyleSheets | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TClientSideOptions

Namespace: System.Web.UI
Inheritance: TComponent »
TClientSideOptions
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Options | TMap | gets the list of options as TMap.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Ensure that the javascript statements are wrapped in a javascript function block as function(sender, parameter){ //code }.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block.
P | setOption | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TCallbackClientSide
  • TClientSideValidationSummaryOptions
  • TColorPickerClientSide
  • TDatePickerClientScript
  • TSliderClientScript
  • TValidatorClientSide
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TClientSideValidationSummaryOptions

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TClientSideOptions »
TClientSideValidationSummaryOptions
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | OnHideSummary | string | javascript code for client-side OnHideSummary event.
 | OnShowSummary | string | javascript code for client-side OnShowSummary event.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Ensure the string is a valid javascript function.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TColorPicker

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox »
TColorPicker
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
RP | AssetUrl | string | asset file url.
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. (inherited from TTextBox)
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CancelButtonText | string | text for the color picker Cancel button.
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TColorPickerClientSide | javascript event options.
 | ColorPickerStyle | string | current color picker style.
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the TTextBox control. (inherited from TTextBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
 | Mode | TColorPickerMode | current color picker UI mode.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | OKButtonText | string | text for the color picker OK button.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
RP | PostBackOptions | array | Get javascript color picker options.
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowColorPicker | boolean | whether the color picker should pop up when the button is clicked.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox. (inherited from TTextBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component. (inherited from TTextBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TTextBox)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the color picker Css asset files.
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TTextBox)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TTextBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
P | publishColorPickerAssets | Publish the color picker assets.
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for textbox. (inherited from TTextBox)
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode. (inherited from TTextBox)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders additional body content.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TColorPickerClientSide

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TClientSideOptions »
TColorPickerClientSide
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | OnColorSelected | string | javascript code for when a color is selected.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Ensure that the javascript statements are wrapped in a javascript function block as function(sender, parameter){ //code }. (inherited from TClientSideOptions)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TColorPickerMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TColorPickerMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCommandEventParameter

Namespace: System.Web.UI
Inheritance: TComponent » TEventParameter »
TCommandEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandName | string | name of the command.
R | CommandParameter | string | parameter of the command.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TDataGridCommandEventParameter
  • TDataListCommandEventParameter
  • TRepeaterCommandEventParameter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCompareValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TCompareValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToCompare | string | the input component to compare with the input control being validated.
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | DataType | TValidationDataType | the data type that the values being compared are converted to before the comparison is made.
 | DateFormat | string | the date validation date format if any.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Operator | TValidationCompareOperator | the comparison operation to perform.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | ValueToCompare | string | the constant value to compare with the value entered by the user into the input component being validated.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getComparisonValues | Parse the pair of values into the appropriate value type.
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCompleteWizardStep

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TView » TWizardStep »
TCompleteWizardStep
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Active | boolean | whether this view is active. (inherited from TView)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowReturn | boolean | whether this step can be re-visited. (inherited from TWizardStep)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StepType | TWizardStepType | the wizard step type.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Title | string | the title for this step. (inherited from TWizardStep)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether this view is visible. (inherited from TView)
 | Wizard | TWizard | the wizard owning this step. (inherited from TWizardStep)
Events
Name | Description
OnActivate | Raises OnActivate event. (inherited from TView)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDeactivate | Raises OnDeactivate event. (inherited from TView)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TComponent

Namespace: System
TComponent
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template.
attachEventHandler | Attaches an event handler to an event.
canGetProperty | Determines whether a property can be read.
canSetProperty | Determines whether a property can be set.
createdOnTemplate | This method is invoked after the component is instantiated by a template.
detachEventHandler | Detaches an existing event handler.
evaluateExpression | Evaluates a PHP expression in the context of this control.
evaluateStatements | Evaluates a list of PHP statements.
getEventHandlers | Returns the list of attached event handlers for an event.
getSubProperty | Evaluates a property path.
hasEvent | Determines whether an event is defined.
hasEventHandler | whether an event has been attached one or several handlers.
hasProperty | Determines whether a property is defined.
raiseEvent | Raises an event.
setSubProperty | Sets a value to a property path.
Derived classes
  • TActiveRecord
  • TActiveRecordGateway
  • TActiveRecordManager
  • TApplication
  • TApplicationComponent
  • TApplicationConfiguration
  • TAuthorizationRule
  • TAutoCompleteTemplate
  • TBaseActiveControl
  • TCacheDependency
  • TCachePageStatePersister
  • TCachingStatement
  • TClientSideOptions
  • TComponentReflection
  • TCompositeLiteral
  • TDataGatewayCommand
  • TDataSourceSelectParameters
  • TDataSourceView
  • TDbCommand
  • TDbCommandBuilder
  • TDbConnection
  • TDbDataReader
  • TDbMetaData
  • TDbTableColumn
  • TDbTableInfo
  • TDbTransaction
  • TDiscriminator
  • TDummyDataSource
  • TEventParameter
  • TFont
  • THotSpot
  • THttpCookie
  • TList
  • TListItem
  • TLogger
  • TMap
  • TMappedStatement
  • TMetaTag
  • TOracleTableInfo
  • TPageConfiguration
  • TPageStatePersister
  • TPagedDataSource
  • TParameterMap
  • TParameterProperty
  • TPreparedStatement
  • TQueue
  • TRepeatInfo
  • TResultMap
  • TResultProperty
  • TResultSetListItemParameter
  • TResultSetMapItemParameter
  • TSessionPageStatePersister
  • TSqlCriteria
  • TSqlMapCacheModel
  • TSqlMapGateway
  • TSqlMapManager
  • TSqlMapObjectCollectionTree
  • TSqlMapStatement
  • TSqlMapTypeHandler
  • TStack
  • TStaticSql
  • TStyle
  • TSubMap
  • TTableGateway
  • TTextWriter
  • TUri
  • TUrlMappingPattern
  • TUser
  • TWebControlDecorator
  • TWizardNavigationTemplate
  • TWizardSideBarListItemTemplate
  • TWizardSideBarTemplate
  • TXmlElement
  • Translation
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TComponentReflection

Namespace: System
Inheritance: TComponent »
TComponentReflection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ClassName | string | class name of the component.
R | Events | array | list of component events.
R | Methods | array | list of public/protected methods.
R | Properties | array | list of component properties.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determinePropertyType | Determines the property type.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCompositeControl

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TControl »
TCompositeControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls.
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TTemplateControl
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCompositeLiteral

Namespace: System.Web.UI
Inheritance: TComponent »
TCompositeLiteral
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Container | TComponent | container of this component.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
dataBind | Performs databindings.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateDynamicContent | Evaluates the expressions and/or statements in the component.
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
render | Renders the content stored in this component.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TConditional

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TConditional
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | Condition | string | the PHP expression used for determining which template to use.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | FalseTemplate | ITemplate | the template applied when Condition is false.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | TrueTemplate | ITemplate | the template applied when Condition is true.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TConfigurationException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TConfigurationException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
  • TTemplateException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TContent

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TContent
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the control is instantiated on a template.
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TContentDirection

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TContentDirection
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TContentPlaceHolder

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TContentPlaceHolder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the control is instantiated on a template.
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TControl

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent »
TControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter.
R | AllowChildControls | boolean | whether body contents are allowed for this control.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes.
P | ChildControlsCreated | boolean | whether child controls have been created.
R | ClientID | string | Returns the client ID of the control.
P | ControlStage | integer | Gets the lifecycle step the control is currently at.
R | Controls | TControlCollection | the child control collection.
 | CustomData | mixed | Returns custom data associated with this control.
 | EnableTheming | boolean | whether theming is enabled for this control.
 | EnableViewState | boolean | whether viewstate is enabled.
 | Enabled | boolean | Returns a value indicating whether the control is enabled.
R | HasAdapter | boolean | whether there is an adapter for this control.
R | HasAttributes | boolean | whether the control has custom attributes.
R | HasChildInitialized | boolean | true if the child control has been initialized.
R | HasControls | boolean | whether the control has child controls.
R | HasInitialized | boolean | true if the onInit event has raised.
R | HasLoaded | boolean | true if the onLoad event has raised.
R | HasLoadedPostData | boolean | true if the control has loaded post data.
R | HasPreRendered | boolean | true if onPreRender event has raised.
 | ID | string | Returns the id of the control.
R | IsSkinApplied | {unknown} | .
R | NamingContainer | TControl | the naming container of this control.
 | Page | TPage | the page that contains this control.
R | Parent | TControl | the parent of this control.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set.
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control.
 | TemplateControl | TTemplateControl | the control whose template contains this control.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible.
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event.
OnInit | This method is invoked when the control enters 'OnInit' stage.
OnLoad | This method is invoked when the control enters 'OnLoad' stage.
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage.
OnUnload | This method is invoked when the control enters 'OnUnload' stage.
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders.
 | addedControl | Adds a control into the child collection of the control.
 | applyStyleSheetSkin | Applies a stylesheet skin to a control.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression.
P | autoDataBindProperties | Auto databinding properties of the control.
 | bindProperty | Sets up the binding between a property (or property path) and an expression.
 | broadcastEvent | Broadcasts an event.
 | bubbleEvent | This method responds to a bubbled event.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data.
P | clearControlState | Clears a controlstate value.
 | clearNamingContainer | Resets the control as a naming container.
 | clearViewState | Clears a viewstate value.
S | convertUniqueIdToClientId | Converts a unique ID to a client ID.
 | createChildControls | Creates child controls.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls .
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control.
P | dataBindChildren | Databinding child controls.
P | dataBindProperties | Databinding properties of the control.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container.
 | findControlsByID | Finds all child and grand-child controls with the specified ID.
 | findControlsByType | Finds all child and grand-child controls that are of the specified type.
 | focus | Sets input focus to this control.
 | getAttribute | attribute value, null if attribute does not exist.
P | getControlState | Returns a controlstate value.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value.
 | hasAttribute | whether the named attribute exists.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls.
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc.
 | isObjectRegistered | whether an object has been registered with the name @see registerObject.
P | loadRecursive | Performs the Load step for the control and all its child controls.
 | loadState | This method is invoked right after the control has loaded its state.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name.
 | removeAttribute | Removes the named attribute.
 | removedControl | Removes a control from the child collection of the control.
 | render | Renders the control.
 | renderChildren | Renders the children of the control.
 | renderControl | Renders the control.
 | saveState | This method is invoked when control state is to be saved.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection.
 | setAttribute | Sets a custom control attribute.
P | setControlState | Sets a controlstate value.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value.
 | trackViewState | Sets a value indicating whether we should keep data in viewstate.
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control.
 | unbindProperty | Breaks the binding between a property (or property path) and an expression.
P | unloadRecursive | Performs the Unload step for the control and all its child controls.
 | unregisterObject | Unregisters an object by name.
Derived classes
  • TCallback
  • TCallbackOptions
  • TClientScript
  • TCompositeControl
  • TConditional
  • TContent
  • TContentPlaceHolder
  • TDataSourceControl
  • TExpression
  • TFlushOutput
  • TForm
  • THead
  • THiddenField
  • TI18NControl
  • TLiteral
  • TMultiView
  • TOutputCache
  • TPlaceHolder
  • TRepeaterItem
  • TSafeHtml
  • TStatements
  • TStyleSheet
  • TTranslateParameter
  • TView
  • TWebControl
  • TWizardNavigationContainer
  • TXmlTransform
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TControlAdapter

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent »
TControlAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Control | TControl | the control to which this adapter is attached.
R | Page | TPage | the page that contains the attached control.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Name | Description
OnInit | This method is invoked when the control enters 'OnInit' stage.
OnLoad | This method is invoked when the control enters 'OnLoad' stage.
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage.
OnUnload | This method is invoked when the control enters 'OnUnload' stage.
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createChildControls | Creates child controls for the attached control.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
loadState | Loads additional persistent control state.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
render | This method is invoked when the control renders itself.
renderChildren | Renders the control's children.
saveState | Saves additional persistent control state.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveControlAdapter
  • TActivePageAdapter
  • TWebControlAdapter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TControlCollection

Namespace: System.Web.UI
Inheritance: TComponent » TList »
TControlCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection.
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer.
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
  • TAccordionViewCollection
  • TEmptyControlCollection
  • TTabViewCollection
  • TTableCellCollection
  • TTableRowCollection
  • TViewCollection
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCustomValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TCustomValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ClientValidationFunction | string | the name of the custom client-side script function used for validation.
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnServerValidate | This method is invoked when the server side validation happens.
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Only register the client-side validator if ClientValidationFunction is set.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
  • TActiveCustomValidator
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataBoundControl

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TDataBoundControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled.
 | AllowPaging | boolean | whether paging is enabled.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataMember | {unknown} | .
 | DataSource | Traversable | data source object, defaults to null.
 | DataSourceID | string | ID path to the data source control.
RP | DataSourceView | {unknown} | .
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized.
P | IsDataBound | boolean | whether databind has been invoked in the previous page request.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available.
 | PageSize | integer | the number of data items on each page.
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control).
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | .
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource.
 | VirtualItemCount | integer | virtual number of data items in the data source.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event.
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized.
OnInit | Sets page's OnPreLoad event handler as pagePreLoad.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createPagedDataSource | creates a paged data source.
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding.
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | .
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | .
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true.
P | performDataBinding | .
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source.
Derived classes
  • TBaseDataList
  • TListControl
  • TRepeater
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataFieldAccessor

Namespace: System.Util
TDataFieldAccessor
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | getDataFieldValue | Evaluates the data value at the specified field.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGatewayCommand

Namespace: System.Data.DataGateway
Inheritance: TComponent »
TDataGatewayCommand
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Builder | TDbCommandBuilder | .
R | DbConnection | TDbConnection | .
R | LastInsertID | mixed | Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
R | TableInfo | TDbTableInfo | .
Events
Name | Description
OnCreateCommand | Raised when a command is prepared and parameter binding is completed.
OnExecuteCommand | Raised when a command is executed and the result from the database was returned.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | count | number of records.
 | createCriteriaFromString | criteria created from the method name and its arguments.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Executes a delete command.
 | deleteByPk | number of rows affected.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | extractMatchingConditions | Calculates the AND/OR condition from dynamic method substrings using table meta data, allows for any AND-OR combinations.
 | find | Find one record matching the critera.
 | findAll | Find one or more matching records.
 | findAllByIndex | .
 | findAllByPk | record reader.
 | findAllBySql | Find zero or more matching records for arbituary SQL.
 | findByPk | matching record.
 | findBySql | Find one matching records for arbituary SQL.
P | getCompositeKeyCondition | Construct a "pk IN ('key1', 'key2', .
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getFindCommand | Build the find command from the criteria.
 | getIndexKeyCondition | .
P | getPrimaryKeyCondition | Create the condition and parameters for find by primary.
P | getSqlCommand | Build sql command from the criteria.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | insert | Inserts a new record into the table.
P | quoteTuple | quoted recursive tuple values, e.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | update | Updates the table with new data.
 | updateByPk | number of records affected.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGatewayEventParameter

Namespace: System.Data.DataGateway
Inheritance: TComponent » TEventParameter »
TDataGatewayEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TDbCommand | The database command to be executed.
R | Criteria | TSqlCriteria | criteria used to bind the sql query parameters.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGatewayResultEventParameter

Namespace: System.Data.DataGateway
Inheritance: TComponent » TEventParameter »
TDataGatewayResultEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TDbCommand | database command executed.
 | Result | mixed | result returned from executing the command.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGrid

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TBaseDataList »
TDataGrid
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AllowSorting | boolean | whether sorting is enabled.
R | AlternatingItemStyle | TTableItemStyle | the style for each alternating item.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
R | AutoColumns | TDataGridColumnCollection | automatically generated datagrid columns.
RP | AutoGenerateColumnName | string | Name of the class used in AutoGenerateColumns mode.
 | AutoGenerateColumns | boolean | whether datagrid columns should be automatically generated.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the datagrid.
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | BottomPager | TDataGridPager | the pager displayed at the bottom of datagrid.
 | Caption | string | caption for the datagrid.
 | CaptionAlign | TTableCaptionAlign | datagrid caption alignment.
 | CellPadding | integer | the cellpadding for the table layout. (inherited from TBaseDataList)
 | CellSpacing | integer | the cellspacing for the table layout. (inherited from TBaseDataList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | Columns | TDataGridColumnCollection | manually specified datagrid columns.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataKeyField | string | the field of the data source that provides the keys of the list items. (inherited from TBaseDataList)
R | DataKeys | TList | the keys used in the data listing control. (inherited from TBaseDataList)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
R | EditItem | TDataGridItem | the edit item.
 | EditItemIndex | integer | the zero-based index of the edit item in Items.
R | EditItemStyle | TTableItemStyle | the style for edit item.
 | EmptyTemplate | ITemplate | the template applied when no data is bound to the datagrid.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
R | Footer | TDataGridItem | the footer item.
R | FooterStyle | TTableItemStyle | the style for footer.
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GridLines | TTableGridLines | the grid line setting of the table layout. (inherited from TBaseDataList)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
R | Header | TDataGridItem | the header item.
R | HeaderStyle | TTableItemStyle | the style for header.
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the table content. (inherited from TBaseDataList)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | ItemCount | integer | number of items.
R | ItemStyle | TTableItemStyle | the style for every item.
R | Items | TDataGridItemCollection | datagrid item collection.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | PagerStyle | TDataGridPagerStyle | the style for pager.
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
R | SelectedItem | TDataGridItem | the selected item, null if no item is selected.
 | SelectedItemIndex | integer | the zero-based index of the selected item in Items.
R | SelectedItemStyle | TTableItemStyle | the style for selected item.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowFooter | boolean | whether the footer should be displayed.
 | ShowHeader | boolean | whether the header should be displayed.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
R | TableBodyStyle | TStyle | the style for tbody element, if any @since 3.
R | TableFootStyle | TStyle | the style for tfoot element, if any @since 3.
R | TableHeadStyle | TStyle | the style for thead element, if any @since 3.
RP | TagName | string | tag name (table) of the datagrid.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | TopPager | TDataGridPager | the pager displayed at the top of datagrid.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCancelCommand | Raises OnCancelCommand event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnDeleteCommand | Raises OnDeleteCommand event.
OnEditCommand | Raises OnEditCommand event.
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnItemCommand | Raises OnItemCommand event.
OnItemCreated | Raises OnItemCreated event.
OnItemDataBound | Raises OnItemDataBound event.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPageIndexChanged | Raises OnPageIndexChanged event.
OnPagerCreated | Raises OnPagerCreated event.
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event. (inherited from TBaseDataList)
OnSortCommand | Raises OnSortCommand event.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
OnUpdateCommand | Raises OnUpdateCommand event.
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds objects parsed in template to datagrid.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
P | applyItemStyles | Applies styles to items, header, footer and separators.
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation to handle OnItemCommand event which is bubbled from TDataGridItem child controls.
P | buildNextPrevPager | Builds a next-prev pager .
P | buildNumericPager | Builds a numeric pager .
P | buildPager | Builds the pager content based on pager style.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
P | createAutoColumns | Automatically generates datagrid columns based on datasource schema .
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createItem | Creates a datagrid item instance based on the item type and index.
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createPagerButton | Creates a pager button.
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDataFieldValue | Returns the value of the data at the specified field. (inherited from TBaseDataList)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | initializeItem | Initializes a datagrid item and cells inside it .
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads item count information from viewstate.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate datagrid items from data source.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the datagrid.
 | renderBeginTag | Renders the openning tag for the datagrid control which will render table caption if present.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderTable | Renders the tabular data.
 | reset | Clears up all items in the datagrid.
P | restoreGridFromViewState | Restores datagrid content from viewstate.
 | saveState | Saves item count in viewstate.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveDataGrid
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent »
TDataGridColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together.
 | FooterRenderer | string | the class name for the column footer cell renderer.
R | FooterStyle | TTableItemStyle | the style for footer.
 | FooterText | string | the text to be displayed in the footer of this column.
 | HeaderImageUrl | string | the url of the image to be displayed in header.
 | HeaderRenderer | string | the class name for the column header cell renderer.
R | HeaderStyle | TTableItemStyle | the style for header.
 | HeaderText | string | the text to be displayed in the header of this column.
 | ID | string | the ID of the column.
R | ItemStyle | TTableItemStyle | the style for item.
 | Owner | TDataGrid | datagrid that owns this column.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string.
P | getDataFieldValue | Fetches the value of the data at the specified field.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column.
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell.
P | initializeHeaderCell | Initializes the header cell.
 | loadState | Loads persistent state values.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value.
Derived classes
  • TBoundColumn
  • TButtonColumn
  • TCheckBoxColumn
  • TDropDownListColumn
  • TEditCommandColumn
  • THyperLinkColumn
  • TLiteralColumn
  • TTemplateColumn
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridColumnCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
TDataGridColumnCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TDataGrid | the control that owns this collection.
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridCommandEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter » TCommandEventParameter »
TDataGridCommandEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandName | string | name of the command. (inherited from TCommandEventParameter)
R | CommandParameter | string | parameter of the command. (inherited from TCommandEventParameter)
R | CommandSource | TControl | the control originally raises the Command event.
R | Item | TDataGridItem | the TDataGridItem control responsible for the event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridItem

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTableRow »
TDataGridItem
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | Cells | TTableCellCollection | list of TTableCell controls. (inherited from TTableRow)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item @since 3.
 | DataItem | mixed | This property is deprecated since v3.
R | DataSourceIndex | integer | the index of the datagrid item from the bound data source.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | ItemIndex | integer | zero-based index of the item in the item collection of datagrid.
 | ItemType | TListItemType | item type.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TableSection | TTableRowSection | location of a row in a table. (inherited from TTableRow)
RP | TagName | string | tag name for the table. (inherited from TTableRow)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TTableRow)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TTableRow)
P | createStyle | Creates a style object for the control. (inherited from TTableRow)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table row . (inherited from TTableRow)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridItemCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
TDataGridItemCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridItemEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TDataGridItemEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Item | TDataGridItem | datagrid item related with the corresponding event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridItemRenderer

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TDataRenderer » TItemDataRenderer »
TDataGridItemRenderer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item. (inherited from TDataRenderer)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
 | ItemIndex | integer | Returns a value indicating the zero-based index of the item in the corresponding data control's item collection. (inherited from TItemDataRenderer)
 | ItemType | TListItemType | item type. (inherited from TItemDataRenderer)
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPageChangedEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TDataGridPageChangedEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandSource | TControl | the control originally raises the OnCommand event.
R | NewPageIndex | integer | new page index.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPager

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TPanel »
TDataGridPager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the panel component. (inherited from TPanel)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | DataGrid | TDataGrid | the datagrid owning this pager.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | DefaultButton | string | the ID path to the default button. (inherited from TPanel)
 | Direction | string | alignment of the content in the panel. (inherited from TPanel)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GroupingText | string | the legend text when the panel is used as a fieldset. (inherited from TPanel)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the panel, defaults to 'NotSet'. (inherited from TPanel)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | ItemType | string | item type.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScrollBars | string | the visibility and position of scroll bars in a panel control, defaults to None. (inherited from TPanel)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the panel. (inherited from TPanel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the content wraps within the panel. (inherited from TPanel)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TPanel)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TPanel)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | . (inherited from TPanel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TPanel)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TPanel)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPagerButtonType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDataGridPagerButtonType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPagerEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TDataGridPagerEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Pager | TDataGridPager | datagrid pager related with the corresponding event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPagerMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDataGridPagerMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPagerPosition

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDataGridPagerPosition
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPagerStyle

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TStyle » TPanelStyle »
TDataGridPagerStyle
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | BackColor | string | the background color of the control. (inherited from TStyle)
 | BackImageUrl | string | the URL of the background image for the panel component. (inherited from TPanelStyle)
 | BorderColor | string | the border color of the control. (inherited from TStyle)
 | BorderStyle | string | the border style of the control. (inherited from TStyle)
 | BorderWidth | string | the border width of the control. (inherited from TStyle)
 | ButtonType | TDataGridPagerButtonType | the type of command button.
 | CssClass | string | the CSS class of the control. (inherited from TStyle)
 | CustomStyle | string | the custom style of the control. (inherited from TStyle)
 | Direction | TContentDirection | alignment of the content in the panel. (inherited from TPanelStyle)
 | DisplayStyle | TDisplayStyle | display style. (inherited from TStyle)
 | FirstPageText | string | text for the first page button.
R | Font | TFont | the font of the control. (inherited from TStyle)
 | ForeColor | string | the foreground color of the control. (inherited from TStyle)
 | Height | string | the height of the control. (inherited from TStyle)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the contents within the panel, defaults to THorizontalAlign::NotSet. (inherited from TPanelStyle)
 | LastPageText | string | text for the last page button.
 | Mode | TDataGridPagerMode | pager mode.
 | NextPageText | string | text for the next page button.
 | PageButtonCount | integer | maximum number of pager buttons to be displayed.
 | Position | TDataGridPagerPosition | where the pager is to be displayed.
 | PrevPageText | string | text for the previous page button.
 | ScrollBars | TScrollBars | the visibility and position of scroll bars in a panel control, defaults to TScrollBars::None. (inherited from TPanelStyle)
R | StyleFields | array | list of style fields. (inherited from TStyle)
 | Visible | boolean | whether the pager is visible.
 | Width | string | the width of the control. (inherited from TStyle)
 | Wrap | boolean | whether the content wraps within the panel. (inherited from TPanelStyle)
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer. (inherited from TPanelStyle)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clearStyleField | Clears a single style field value; . (inherited from TStyle)
copyFrom | Copies the fields in a new style to this style.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getStyleField | a single style field value set via setStyleField. (inherited from TStyle)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasCssClass | true if CSS is set or empty. (inherited from TStyle)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasFont | true if font is set. (inherited from TStyle)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
hasStyleField | whether a style field has been defined by setStyleField. (inherited from TStyle)
mergeWith | Merges the style with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Resets the style to the original empty state.
setStyleField | Sets a single style field value. (inherited from TStyle)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridSortCommandEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TDataGridSortCommandEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandSource | TControl | the control originally raises the OnCommand event.
R | SortExpression | string | sort expression.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TBaseDataList »
TDataList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AlternatingItemRenderer | string | the class name for alternative datalist items.
R | AlternatingItemStyle | TTableItemStyle | the style for each alternating item.
 | AlternatingItemTemplate | ITemplate | the template for each alternating item.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Caption | string | caption of the table layout.
 | CaptionAlign | TTableCaptionAlign | alignment of the caption of the table layout.
 | CellPadding | integer | the cellpadding for the table layout. (inherited from TBaseDataList)
 | CellSpacing | integer | the cellspacing for the table layout. (inherited from TBaseDataList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataKeyField | string | the field of the data source that provides the keys of the list items. (inherited from TBaseDataList)
R | DataKeys | TList | the keys used in the data listing control. (inherited from TBaseDataList)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
R | EditItem | TControl | the edit item.
 | EditItemIndex | integer | the zero-based index of the edit item in Items.
 | EditItemRenderer | string | the class name for the datalist item being editted.
R | EditItemStyle | TTableItemStyle | the style for edit item.
 | EditItemTemplate | ITemplate | the edit item template.
 | EmptyRenderer | string | the class name for empty datalist item.
 | EmptyTemplate | ITemplate | the template applied when no data is bound to the datalist.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
R | Footer | TControl | the footer item.
 | FooterRenderer | string | the class name for datalist footer item.
R | FooterStyle | TTableItemStyle | the style for footer.
 | FooterTemplate | ITemplate | the footer template.
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GridLines | TTableGridLines | the grid line setting of the table layout. (inherited from TBaseDataList)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item.
R | HasHeader | boolean | Returns a value indicating whether this control contains header item.
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items.
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
R | Header | TControl | the header item.
 | HeaderRenderer | string | the class name for datalist header item.
R | HeaderStyle | TTableItemStyle | the style for header.
 | HeaderTemplate | ITemplate | the header template.
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the table content. (inherited from TBaseDataList)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | ItemCount | integer | number of items.
 | ItemRenderer | string | the class name for datalist items.
R | ItemStyle | TTableItemStyle | the style for item.
 | ItemTemplate | ITemplate | the template for item.
R | Items | TDataListItemCollection | item list.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RepeatColumns | integer | the number of columns that the list should be displayed with.
 | RepeatDirection | TRepeatDirection | the direction of traversing the list, defaults to TRepeatDirection::Vertical.
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers).
 | RepeatLayout | TRepeatLayout | how the list should be displayed, using table or using line breaks.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
R | SelectedDataKey | mixed | the key value of the currently selected item @throws TInvalidOperationException if DataKeyField is empty.
R | SelectedItem | TControl | the selected item, null if no item is selected.
 | SelectedItemIndex | integer | the zero-based index of the selected item in Items.
 | SelectedItemRenderer | string | the class name for the datalist item being selected.
R | SelectedItemStyle | TTableItemStyle | the style for selected item.
 | SelectedItemTemplate | ITemplate | the selected item template.
 | SeparatorRenderer | string | the class name for datalist item separators.
R | SeparatorStyle | TTableItemStyle | the style for separator.
 | SeparatorTemplate | ITemplate | the separator template.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowFooter | boolean | whether the footer should be shown.
 | ShowHeader | boolean | whether the header should be shown.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCancelCommand | Raises OnCancelCommand event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnDeleteCommand | Raises OnDeleteCommand event.
OnEditCommand | Raises OnEditCommand event.
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnItemCommand | Raises OnItemCommand event.
OnItemCreated | Raises OnItemCreated event.
OnItemDataBound | Raises OnItemDataBound event.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event. (inherited from TBaseDataList)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
OnUpdateCommand | Raises OnUpdateCommand event.
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
P | applyItemStyles | Applies styles to items, header, footer and separators.
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation to handle OnItemCommand event which is bubbled from datalist items and their child controls.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createEmptyContent | Creates empty datalist content.
P | createItem | Creates a datalist item instance based on the item type and index.
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object for the control. (inherited from TBaseDataList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | generateItemStyle | Returns a style used for rendering items.
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDataFieldValue | Returns the value of the data at the specified field. (inherited from TBaseDataList)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads item count information from viewstate.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate data list items from data source.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the data list control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list.
 | reset | Clears up all items in the data list.
P | restoreItemsFromViewState | Creates data list items based on viewstate information.
 | saveState | Saves item count in viewstate.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveDataList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataListCommandEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter » TCommandEventParameter »
TDataListCommandEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandName | string | name of the command. (inherited from TCommandEventParameter)
R | CommandParameter | string | parameter of the command. (inherited from TCommandEventParameter)
R | CommandSource | TControl | the control originally raises the OnCommand event.
R | Item | TControl | the datalist item control responsible for the event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataListItem

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TDataListItem
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item @since 3.
 | DataItem | mixed | This property is deprecated since v3.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | ItemIndex | integer | zero-based index of the item in the item collection of datalist.
 | ItemType | TListItemType | item type.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
P | TagName | string | Returns the tag name used for this control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataListItemCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
TDataListItemCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataListItemEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TDataListItemEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Item | TControl | datalist item related with the corresponding event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataListItemRenderer

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TDataRenderer » TItemDataRenderer »
TDataListItemRenderer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item. (inherited from TDataRenderer)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
 | ItemIndex | integer | Returns a value indicating the zero-based index of the item in the corresponding data control's item collection. (inherited from TItemDataRenderer)
 | ItemType | TListItemType | item type. (inherited from TItemDataRenderer)
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
R | Style | TStyle | the object representing the css style of the control.
RP | TagName | string | Returns the tag name used for this control.
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data.
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) This method is invoked when TagName is not empty.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control This method is invoked when TagName is not empty.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataRenderer

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl »
TDataRenderer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TItemDataRenderer
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataSourceConfig

Namespace: System.Data
Inheritance: TComponent » TApplicationComponent » TModule »
TDataSourceConfig
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ConnectionClass | {unknown} | .
 | ConnectionID | string | connection module ID.
R | Database | TDbConnection | Alias for getDbConnection().
R | DbConnection | TDbConnection | Gets the TDbConnection from another module if ConnectionID is supplied and valid.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | findConnectionByID | Finds the database connection instance from the Application modules.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initalize the database connection properties from attributes in tag.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveRecordConfig
  • TSqlMapConfig
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataSourceControl

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TDataSourceControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | {unknown} | .
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | {unknown} | .
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ViewNames | {unknown} | .
 | Visible | {unknown} | .
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataSourceChanged | .
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | .
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getView | .
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TReadOnlyDataSource
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataSourceSelectParameters

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TDataSourceSelectParameters
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
MaximumRows | {unknown} | .
RetrieveTotalRowCount | {unknown} | .
StartRowIndex | {unknown} | .
TotalRowCount | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataSourceView

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TDataSourceView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CanDelete | {unknown} | .
R | CanGetRowCount | {unknown} | .
R | CanInsert | {unknown} | .
R | CanPage | {unknown} | .
R | CanSort | {unknown} | .
R | CanUpdate | {unknown} | .
R | DataSource | {unknown} | .
R | Name | {unknown} | .
Events
Name | Description
OnDataSourceViewChanged | .
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
delete | Deletes DB row(s) with the specified keys.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
insertAt | Inserts a DB record.
raiseEvent | Raises an event. (inherited from TComponent)
select | Performs DB selection based on specified parameters.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
update | Updates DB record(s) with the specified keys and new values .
Derived classes
  • TReadOnlyDataSourceView
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataTypeValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TDataTypeValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | DataType | TValidationDataType | the data type that the values being compared are converted to before the comparison is made.
 | DateFormat | string | the date validation date format if any.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | evaluateDataTypeCheck | Determine if the given value is of a particular type using RegExp.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDateFormat

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TControl » TI18NControl »
TDateFormat
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | Charset | string | Gets the charset. (inherited from TI18NControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | Culture | string | Get the specific culture for this control. (inherited from TI18NControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Get the date-time value for this control.
 | DefaultText | string | Get the default text value for this control.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
RP | FormattedDate | {unknown} | Renders the localized version of the date-time value.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | Pattern | string | Gets the date time format pattern.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Value | string | Get the date-time value for this control.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPreset | For a given string, try and find a preset pattern.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | .
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDatePicker

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox »
TDatePicker
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
RP | AssetUrl | string | date picker asset url.
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. (inherited from TTextBox)
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | ButtonImageUrl | string | the image url for "Image" UI mode.
 | ButtonText | string | text for the date picker button.
 | CalendarStyle | string | current calendar style.
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control. (inherited from TTextBox)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TDatePickerClientScript | Gets the TDatePickerClientScript to set the TDatePicker event handlers.
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
RP | CulturalOptions | array | Get javascript localization options, e.
 | Culture | string | Gets the current culture.
RP | CurrentCulture | string | the current culture, falls back to application if culture is not set.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | integer | Returns the timestamp selected by the user.
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
 | Date | string | the date string.
 | DateFormat | string | the format of the date string.
RP | DatePickerButtonID | string | Gets the ID for the date picker trigger button.
RP | DatePickerOptions | array | Get javascript date picker options.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
RP | DropDownDayOptions | array | list of day options for a drop down list.
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | FirstDayOfWeek | integer | first day of the week.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | FromYear | integer | date picker starting year, default is -5 years.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | InputMode | TDatePickerInputMode | input method of date values.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
RP | LocalizedCalendarInfo | DateTimeFormatInfo | date time format information for the current culture.
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
 | Mode | TDatePickerMode | current calendar UI mode.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
 | PositionMode | TDatePickerPositionMode | current calendar UI position.
RP | PostBackOptions | array | Gets the post back options for this textbox. (inherited from TTextBox)
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowCalendar | boolean | whether the calendar window should pop up when the control receives focus.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox. (inherited from TTextBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component. (inherited from TTextBox)
 | TimeStamp | integer | current selected date from the date picker as timestamp, NULL if timestamp is not set previously.
RP | TimeStampFromText | integer | Gets the date from the text input using TSimpleDateFormatter .
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
 | UpToYear | integer | date picker ending year, default +10 years.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | integer | Returns the value to be validated.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the date picker Css asset files.
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Add the client id to the input textbox, and register the client scripts.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientScript | javascript validator event options.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDateFromPostData | Loads date from drop down list data.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLocalizedMonthNames | Returns the localized month names that depends on the month format pattern.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
P | hasDayPattern | .
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
P | publishCalendarStyle | Publish the calendar style Css asset file.
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
P | registerCalendarClientScriptPost | .
P | registerCalendarClientScriptPre | Registers the javascript code to initialize the date picker.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders body content.
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
P | renderButtonDatePicker | Adds an additional button such that when clicked it shows the date picker.
P | renderCalendarDayOptions | Renders the day drop down list options.
P | renderCalendarMonthOptions | Renders the month drop down list options.
P | renderCalendarSelections | Renders the calendar drop down list depending on the DateFormat pattern.
P | renderCalendarYearOptions | Renders the year drop down list options.
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for textbox. (inherited from TTextBox)
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode. (inherited from TTextBox)
 | renderControl | Renders the control. (inherited from TControl)
P | renderDatePickerButtons | Renders the date picker popup buttons.
P | renderDropDownListCalendar | Renders the drop down list date picker.
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderImageButtonDatePicker | Adds an additional image button such that when clicked it shows the date picker.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveDatePicker
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDatePickerClientScript

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TClientSideOptions »
TDatePickerClientScript
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | OnDateChanged | string | javascript code to execute when the date picker's date is changed.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Ensure that the javascript statements are wrapped in a javascript function block as function(sender, parameter){ //code }. (inherited from TClientSideOptions)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDatePickerInputMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDatePickerInputMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDatePickerMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDatePickerMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDatePickerPositionMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDatePickerPositionMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDateTimeStamp

Namespace: System.Util
TDateTimeStamp
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | _getDateInternal | Low-level function that returns the getdate() array.
P | digitCheck | Fix 2-digit years.
 | formatDate | formatted date based on timestamp $d.
 | get4DigitYear | .
 | getDate | an array with date info.
 | getDayofWeek | Gets day of week, 0 = Sunday,.
 | getGMTDiff | get local time zone offset from GMT.
 | getTimeStamp | Not a very fast algorithm - O(n) operation.
 | isLeapYear | Checks for leap year, returns true if it is.
 | isValidDate | true if valid date, semantic check only.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbCache

Namespace: System.Caching
Inheritance: TComponent » TApplicationComponent » TModule » TCache »
TDbCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | AutoCreateCacheTable | boolean | whether the cache DB table should be automatically created if not exists.
 | CacheTableName | string | the name of the DB table to store cache content.
 | ConnectionID | string | the ID of a TDataSourceConfig module.
 | ConnectionString | string | The Data Source Name, or DSN, contains the information required to connect to the database.
R | DbConnection | TDbConnection | the DB connection instance.
 | FlushInterval | integer | Interval in sec expired items will be removed from cache.
 | ID | string | id of this module. (inherited from TModule)
 | KeyPrefix | string | a unique prefix for the keys of cached values. (inherited from TCache)
 | Password | string | the password for establishing DB connection.
 | PrimaryCache | boolean | whether this cache module is used as primary/system cache. (inherited from TCache)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Username | string | the username for establishing DB connection.
Events
Methods
 | Name | Description
 | add | Stores a value identified by a key into cache if the cache does not contain this key. (inherited from TCache)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addValue | Stores a value identified by a key into cache if the cache does not contain this key.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createDbConnection | Creates the DB connection.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes a value with the specified key from cache . (inherited from TCache)
P | deleteValue | Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | doFlushCacheExpired | Event listener for TApplication.
 | doInitializeCache | Event listener for TApplication.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Deletes all values from cache.
 | flushCacheExpired | Flush expired values from cache depending on FlushInterval .
P | generateUniqueKey | a key generated from the provided key which ensures the uniqueness across applications. (inherited from TCache)
 | get | Retrieves a value from cache with a specified key. (inherited from TCache)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValue | Retrieves a value from cache with a specified key.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
P | initializeCache | Initialize TDbCache If AutoCreateCacheTableName is 'true' check existence of cache table and create table if does not exist.
 | offsetExists | Returns whether there is a cache entry with a specified key. (inherited from TCache)
 | offsetGet | Retrieves the value from cache with a specified key. (inherited from TCache)
 | offsetSet | Stores the value identified by a key into cache. (inherited from TCache)
 | offsetUnset | Deletes the value with the specified key from cache This method is required by the interface ArrayAccess. (inherited from TCache)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | set | Stores a value identified by a key into cache. (inherited from TCache)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setValue | Stores a value identified by a key in cache.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbColumnCaseMode

Namespace: System.Data
Inheritance: TEnumerable »
TDbColumnCaseMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbCommand

Namespace: System.Data
Inheritance: TComponent »
TDbCommand
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Connection | TDbConnection | the connection associated with this command.
R | DebugStatementText | String | prepared SQL text for debugging purposes.
R | PdoStatement | PDOStatement | the underlying PDOStatement for this command It could be null if the statement is not prepared yet.
 | Text | string | the SQL statement to be executed.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
bindParameter | Binds a parameter to the SQL statement to be executed.
bindValue | Binds a value to a parameter.
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
cancel | Cancels the execution of the SQL statement.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
execute | Executes the SQL statement.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
prepare | Prepares the SQL statement to be executed.
query | Executes the SQL statement and returns query result.
queryColumn | Executes the SQL statement and returns the first column of the result.
queryRow | Executes the SQL statement and returns the first row of the result.
queryScalar | Executes the SQL statement and returns the value of the first column in the first row of data.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbCommandBuilder

Namespace: System.Data.Common
Inheritance: TComponent »
TDbCommandBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | database connection.
R | LastInsertID | mixed | Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
R | SelectFieldList | array | Different behavior depends on type of passed data string usage without modification null will be expanded to full list of quoted table column names (quoting depends on database) array - Column names will be quoted if used as key or value of array array('col1', 'col2', 'col2') // SELECT `col1`, `col2`, `col3` FROM.
 | TableInfo | {unknown} | .
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyCriterias | .
 | applyLimitOffset | Alters the sql to apply $limit and $offset.
 | applyOrdering | modified SQL applied with ORDER BY.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | bindArrayValues | .
 | bindColumnValues | Bind the name-value pairs of $values where the array keys correspond to column names.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommand | corresponding database command.
 | createCountCommand | Creates a count(*) command for the table described in TableInfo.
 | createDeleteCommand | Creates a delete command for the table described in TableInfo.
 | createFindCommand | Appends the $where condition to the string "SELECT * FROM tableName WHERE ".
 | createInsertCommand | Creates an insert command for the table described in TableInfo for the given data.
 | createUpdateCommand | Creates an update command for the table described in TableInfo for the given data.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getColumnBindings | Create a name-value or position-value if $position=true binding strings.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertFieldBindings | Returns a list of insert field name and a list of binding names.
S | getPdoType | PDO parameter types.
P | getSearchCondition | search condition for all words in one column.
 | getSearchExpression | Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
P | hasIntegerKey | true if any array key is an integer.
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TMssqlCommandBuilder
  • TMysqlCommandBuilder
  • TOracleCommandBuilder
  • TPgsqlCommandBuilder
  • TSqliteCommandBuilder
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbConnection

Namespace: System.Data
Inheritance: TComponent »
TDbConnection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Active | boolean | whether the DB connection is established.
 | AutoCommit | boolean | whether creating or updating a DB record will be automatically committed.
 | Charset | string | the charset used for database connection.
R | ClientVersion | string | the version information of the DB driver.
 | ColumnCase | TDbColumnCaseMode | the case of the column names.
R | ConnectionStatus | string | the status of the connection Some DBMS (such as sqlite) may not support this feature.
 | ConnectionString | string | The Data Source Name, or DSN, contains the information required to connect to the database.
R | CurrentTransaction | TDbTransaction | the currently active transaction.
R | DbMetaData | TDbMetaData | .
R | DriverName | string | name of the DB driver.
R | LastInsertID | string | Returns the ID of the last inserted row or sequence value.
 | NullConversion | TDbNullConversionMode | how the null and empty strings are converted.
 | Password | string | the password for establishing DB connection.
R | PdoInstance | PDO | the PDO instance, null if the connection is not established yet.
 | Persistent | boolean | whether the connection is persistent or not Some DBMS (such as sqlite) may not support this feature.
R | Prefetch | boolean | whether the connection performs data prefetching.
R | ServerInfo | string | the information of DBMS server.
R | ServerVersion | string | the version information of DBMS server.
R | Timeout | int | timeout settings for the connection.
 | TransactionClass | string | Transaction class name to be created by calling beginTransaction.
 | Username | string | the username for establishing DB connection.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | beginTransaction | Starts a transaction.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | close | Closes the currently active DB connection.
 | createCommand | Creates a command for execution.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getAttribute | Obtains a specific DB connection attribute information.
S | getAvailableDrivers | list of available PDO drivers @see http://www.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | open | Opens DB connection if it is currently not .
 | quoteColumnAlias | Quotes a column alias for use in a query.
 | quoteColumnName | Quotes a column name for use in a query.
 | quoteString | Quotes a string for use in a query.
 | quoteTableName | Quotes a table name for use in a query.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setAttribute | Sets an attribute on the database connection.
P | setConnectionCharset | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbConnectionException

Namespace: System.Exceptions
Inheritance: TException » TSystemException » TDbException »
TDbConnectionException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbDataReader

Namespace: System.Data
Inheritance: TComponent »
TDbDataReader
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ColumnCount | int | the number of columns in the result set.
R | IsClosed | boolean | whether the reader is closed or not.
R | RowCount | int | number of rows contained in the result.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
bindColumn | Binds a column to a PHP variable.
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
close | Closes the reader.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
current | Returns the current row.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
key | Returns the index of the current row.
next | Moves the internal pointer to the next row.
nextResult | Advances the reader to the next result when reading the results of a batch of statements.
raiseEvent | Raises an event. (inherited from TComponent)
read | Advances the reader to the next row in a result set.
readAll | Reads the whole result set into an array.
readColumn | Returns a single column from the next row of a result set.
readObject | Returns a single column from the next row of a result set.
rewind | Resets the iterator to the initial state.
setFetchMode | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
valid | Returns whether there is a row of data at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TDbException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
  • TActiveRecordException
  • TDbConnectionException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TLogRoute »
TDbLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | AutoCreateLogTable | boolean | whether the log DB table should be automatically created if not exists.
 | Categories | array | list of categories to be looked for. (inherited from TLogRoute)
 | ConnectionID | string | the ID of a TDataSourceConfig module.
R | DbConnection | TDbConnection | the DB connection instance.
 | Levels | integer | log level filter. (inherited from TLogRoute)
 | LogTableName | string | the name of the DB table to store log content.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination. (inherited from TLogRoute)
P | createDbConnection | Creates the DB connection.
P | createDbTable | Creates the DB table for storing log messages.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields. (inherited from TLogRoute)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLevelName | level name. (inherited from TLogRoute)
P | getLevelValue | level value. (inherited from TLogRoute)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
P | processLogs | Stores log messages into database.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbMetaData

Namespace: System.Data.Common
Inheritance: TComponent »
TDbMetaData
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection.
R | TableInfo | TDbTableInfo | Obtains table meta data information for the current connection and given table name.
RP | TableInfoClass | string | TDbTableInfo class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | Creates a command builder for a given table name.
P | createTableInfo | This method should be implemented by decendent classes.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
S | getInstance | Obtain database specific TDbMetaData class using the driver name of the database connection.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | quoteColumnAlias | Quotes a column alias for use in a query.
 | quoteColumnName | Quotes a column name for use in a query.
 | quoteTableName | Quotes a table name for use in a query.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TMssqlMetaData
  • TMysqlMetaData
  • TOracleMetaData
  • TPgsqlMetaData
  • TSqliteMetaData
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbNullConversionMode

Namespace: System.Data
Inheritance: TEnumerable »
TDbNullConversionMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbTableColumn

Namespace: System.Data.Common
Inheritance: TComponent »
TDbTableColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowNull | boolean | specifies whether value Null is allowed, default is false.
R | ColumnId | string | name of the column with quoted identifier.
R | ColumnIndex | integer | zero-based ordinal position of the column in the table.
R | ColumnName | string | name of the column in the table (identifier quoted).
R | ColumnSize | string | size of the column.
R | DbType | string | column type.
R | DefaultValue | mixed | default column value if column value was null.
R | IsExcluded | boolean | whether this column is excluded from insert and update.
R | IsForeignKey | boolean | whether this column is a foreign key, default is false.
R | IsPrimaryKey | boolean | whether this column is a primary key for the table, default is false.
R | MaxiumNumericConstraint | {unknown} | .
R | NumericPrecision | string | precision of the column data, if the data is numeric.
R | NumericScale | string | scale of the column data, if the data is numeric.
R | PHPType | string | Returns the derived PHP primitive type from the db type.
R | PdoType | {unknown} | .
R | SequenceName | {unknown} | .
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasSequence | whether the column is a sequence.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TMssqlTableColumn
  • TMysqlTableColumn
  • TOracleTableColumn
  • TPgsqlTableColumn
  • TSqliteTableColumn
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbTableInfo

Namespace: System.Data.Common
Inheritance: TComponent »
TDbTableInfo
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ColumnNames | array | table column names (identifier quoted).
R | Columns | TMap | TDbTableColumn column meta data.
R | ForeignKeys | array | tuples of foreign table and column name.
R | IsView | boolean | whether the table is a view, default is false.
R | LowerCaseColumnNames | array | lowercased column key names mapped to normal column ids.
R | PrimaryKeys | string[] | .
R | TableFullName | string | full name of the table, database dependent.
R | TableName | string | name of the table this column belongs to.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | new command builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getColumn | column information.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TMssqlTableInfo
  • TMysqlTableInfo
  • TPgsqlTableInfo
  • TSqliteTableInfo
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbTransaction

Namespace: System.Data
Inheritance: TComponent »
TDbTransaction
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Active | boolean | whether this transaction is active.
R | Connection | TDbConnection | the DB connection for this transaction.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
commit | Commits a transaction.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
rollback | Rolls back a transaction.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbUser

Namespace: System.Security
Inheritance: TComponent » TUser »
TDbUser
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | Returns a database connection that may be used to retrieve data from database.
 | IsGuest | boolean | if the user is a guest, defaults to true. (inherited from TUser)
R | Manager | IUserManager | user manager. (inherited from TUser)
 | Name | string | username, defaults to empty string. (inherited from TUser)
 | Roles | array | list of roles that the user is of. (inherited from TUser)
 | StateChanged | boolean | whether user session state is changed (i. (inherited from TUser)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createUser | Creates a new user instance given the username.
 | createUserFromCookie | Creates a new user instance given the cookie containing auth data.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getState | Returns the value of a variable that is stored in user session. (inherited from TUser)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | isInRole | whether the user is of this role. (inherited from TUser)
 | loadFromString | the user object. (inherited from TUser)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveToString | user data that is serialized and will be stored in session. (inherited from TUser)
 | saveUserToCookie | Saves necessary auth data into a cookie.
P | setState | Stores a variable in user session. (inherited from TUser)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | validateUser | Validates if username and password are correct entries.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbUserManager

Namespace: System.Security
Inheritance: TComponent » TApplicationComponent » TModule »
TDbUserManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ConnectionID | string | the ID of a TDataSourceConfig module.
R | DbConnection | TDbConnection | the database connection that may be used to retrieve user data.
 | GuestName | string | guest name, defaults to 'Guest'.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | TUser | Returns a user instance given the user name.
 | UserClass | string | the user class name in namespace format.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createDbConnection | Creates the DB connection.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getUserFromCookie | Returns a user instance according to auth data stored in a cookie.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveUserToCookie | Saves user auth data into a cookie.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | validateUser | Validates if the username and password are correct.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDeleteMappedStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent » TMappedStatement » TUpdateMappedStatement »
TDeleteMappedStatement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TPreparedCommand | command to prepare SQL statements. (inherited from TMappedStatement)
R | ID | string | Name used to identify the TMappedStatement amongst the others. (inherited from TMappedStatement)
R | Manager | TSqlMapper | The SqlMap used by this MappedStatement. (inherited from TMappedStatement)
R | SqlString | {unknown} | . (inherited from TMappedStatement)
R | Statement | TSqlMapStatement | The SQL statment used by this MappedStatement. (inherited from TMappedStatement)
Events
Name | Description
OnExecuteQuery | Raise the execute query event. (inherited from TMappedStatement)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addResultMapGroupBy | ResultMap with GroupBy property. (inherited from TMappedStatement)
P | applyResultMap | Apply result mapping. (inherited from TMappedStatement)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | enquequePostSelect | Add nested result property to post select queue. (inherited from TMappedStatement)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | executeInsert | . (inherited from TUpdateMappedStatement)
P | executePostSelect | Process 'select' result properties . (inherited from TMappedStatement)
 | executeQueryForList | . (inherited from TUpdateMappedStatement)
 | executeQueryForMap | . (inherited from TUpdateMappedStatement)
 | executeQueryForObject | . (inherited from TUpdateMappedStatement)
P | executeSQLQueryLimit | Execute SQL Query with limits. (inherited from TMappedStatement)
P | executeSelectKey | Execute the select key statement, used to obtain last insert ID. (inherited from TMappedStatement)
 | executeUpdate | Execute an update statement. (inherited from TMappedStatement)
P | fillArrayResultMap | Retrieve the result map as an array. (inherited from TMappedStatement)
P | fillDefaultResultMap | Fill the result map using default settings. (inherited from TMappedStatement)
P | fillPropertyWithResultMap | Fills the property with result mapping results. (inherited from TMappedStatement)
P | fillResultArrayList | Apply the result to a TList or an array. (inherited from TMappedStatement)
P | fillResultClass | Fill the result using ResultClass, will creates new result object if required. (inherited from TMappedStatement)
P | fillResultMap | Fills the result object according to result mappings. (inherited from TMappedStatement)
P | fillResultObjectProperty | Apply the result to an object. (inherited from TMappedStatement)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPostGeneratedSelectKey | Gets the inserted row ID after executing an insert statement. (inherited from TMappedStatement)
P | getPostSelectKeys | Finds in the post select property the SQL statement primary selection keys. (inherited from TMappedStatement)
P | getPreGeneratedSelectKey | Gets the insert generated ID before executing an insert statement. (inherited from TMappedStatement)
P | getResultMapGroupKey | Gets the result 'group by' groupping key for each row. (inherited from TMappedStatement)
P | getScalarResult | Converts the first array value to scalar value of given type. (inherited from TMappedStatement)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initialGroupByResults | Empty the group by results cache. (inherited from TMappedStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | raiseRowDelegate | Raises delegate handler. (inherited from TMappedStatement)
 | runQueryForList | Executes the SQL and retuns a List of result objects. (inherited from TMappedStatement)
 | runQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. (inherited from TMappedStatement)
 | runQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter. (inherited from TMappedStatement)
P | setObjectProperty | Set a property of the result object with appropriate value. (inherited from TMappedStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDirectoryCacheDependency

Namespace: System.Caching
Inheritance: TComponent » TCacheDependency »
TDirectoryCacheDependency
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Directory | string | the directory to be checked.
R | HasChanged | boolean | Performs the actual dependency checking.
 | RecursiveCheck | boolean | whether the subdirectories of the directory will also be checked.
 | RecursiveLevel | int | the depth of the subdirectories to be checked.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | generateTimestamps | Determines the last modification time for files under the directory.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | validateDirectory | Checks to see if the specified subdirectory should be checked for dependency.
P | validateFile | Checks to see if the file should be checked for dependency.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDiscriminator

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TDiscriminator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Column | string | the name of the column in the result set from which the value will be used to populate the property.
 | ColumnIndex | int | index of the column in the ResultSet.
R | Mapping | TResultProperty | result property for the discriminator column.
 | NullValue | mixed | outgoing null value replacement.
 | Type | {unknown} | .
 | TypeHandler | string | custom type handler class name (may use namespace).
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
addSubMap | .
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubMap | result mapping.
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
initMapping | Copies the discriminator properties to a new TResultProperty.
initialize | Set the result maps for particular sub-mapping values.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDisplayStyle

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDisplayStyle
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDraggable

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TPanel »
TDraggable
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the panel component. (inherited from TPanel)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | Constraint | CDraggableConstraint | Determine if the element should be constrainted in one direction or not .
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | DefaultButton | string | the ID path to the default button. (inherited from TPanel)
 | Direction | string | alignment of the content in the panel. (inherited from TPanel)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | Ghosting | TDraggableGhostingOption | Determine if the element should be cloned when dragged If true, Clones the element and drags the clone, leaving the original in place until the clone is dropped.
 | GroupingText | string | the legend text when the panel is used as a fieldset. (inherited from TPanel)
 | Handle | string | Get the handle id or css class .
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the panel, defaults to 'NotSet'. (inherited from TPanel)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this textbox.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Revert | TDraggableRevertOption | Determine if draggable element should revert to it orginal position upon release in an non-droppable container.
 | ScrollBars | string | the visibility and position of scroll bars in a panel control, defaults to None. (inherited from TPanel)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the panel. (inherited from TPanel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the content wraps within the panel. (inherited from TPanel)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers clientscripts This method overrides the parent implementation and is invoked before render.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TPanel)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | . (inherited from TPanel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TPanel)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TPanel)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDraggableConstraint

Namespace: System.Web.UI.ActiveControls
Inheritance: TEnumerable »
TDraggableConstraint
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDraggableGhostingOptions

Namespace: System.Web.UI.ActiveControls
Inheritance: TEnumerable »
TDraggableGhostingOptions
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDraggableRevertOptions

Namespace: System.Web.UI.ActiveControls
Inheritance: TEnumerable »
TDraggableRevertOptions
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDropContainer

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TPanel »
TDropContainer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AcceptCssClass | string | Gets the Css class name that this container can accept.
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | standard active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the panel component. (inherited from TPanel)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | Override parent implementation to return the container control collection.
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | DefaultButton | string | the ID path to the default button. (inherited from TPanel)
 | Direction | string | alignment of the content in the panel. (inherited from TPanel)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GroupingText | string | the legend text when the panel is used as a fieldset. (inherited from TPanel)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the panel, defaults to 'NotSet'. (inherited from TPanel)
 | HoverCssClass | string | Gets the Css class name used when a draggble element is hovering over this container.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this textbox.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScrollBars | string | the visibility and position of scroll bars in a panel control, defaults to None. (inherited from TPanel)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the panel. (inherited from TPanel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the content wraps within the panel. (inherited from TPanel)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDrop | Raises the onDrop event.
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers clientscripts This method overrides the parent implementation and is invoked before render.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child control Override parent implementation to create a container which will contain all child controls.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TPanel)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders and replaces the panel's content on the client-side.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TPanel)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TPanel)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDropContainerEventParameter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TEventParameter »
TDropContainerEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AltKey | {unknown} | .
R | ClientX | {unknown} | .
R | ClientY | {unknown} | .
R | CtrlKey | {unknown} | .
R | DragElementId | {unknown} | .
R | DroppedControl | TControl | GetDroppedControl Compatibility method to get the dropped control .
R | OffsetX | {unknown} | .
R | ScreenX | {unknown} | .
R | ScreenY | {unknown} | .
R | ShiftKey | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
geOffsetY | .
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDropDownList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl »
TDropDownList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this is a multiselect control. (inherited from TListControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully.
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | postback options for JS postback code. (inherited from TListControl)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated.
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveDropDownList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDropDownListColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TDropDownListColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataTextField | string | the field of the data source that provides the text content of the column.
 | DataTextFormatString | string | the formatting string used to control how the bound data will be displayed.
 | DataValueField | string | the field of the data source that provides the key selecting an item in dropdown list.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | ListDataSource | Traversable | data source to be bound to the dropdown list boxes.
 | ListTextField | string | the data field used to populate the texts of the dropdown list items.
 | ListTextFormatString | string | the formatting string used to control how the list item texts will be displayed.
 | ListValueField | string | the data field used to populate the values of the dropdown list items.
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
 | ReadOnly | boolean | whether the items in the column can be edited.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Adds object parsed from template to the control.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads items from viewstate.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves items into viewstate.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
  • TActiveDropDownListColumn
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDummyDataSource

Namespace: System.Collections
Inheritance: TComponent »
TDummyDataSource
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | number of (virtual) items in the data source.
R | Iterator | Iterator | iterator.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
count | Returns the number of (virtual) items in the data source.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDummyDataSourceIterator

Namespace: System.Collections
TDummyDataSourceIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array item.
key | Returns the key of the current array item.
next | Moves the internal pointer to the next array item.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an item at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEditCommandColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TEditCommandColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ButtonType | TButtonColumnType | the type of command button.
 | CancelImageUrl | string | the URL of the image file for cancel image buttons.
 | CancelText | string | the caption of the cancel button.
 | CausesValidation | boolean | whether postback event trigger by edit or update button will cause input validation, default is true.
 | EditImageUrl | string | the URL of the image file for edit image buttons.
 | EditText | string | the caption of the edit button.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
 | UpdateImageUrl | string | the URL of the image file for update image buttons.
 | UpdateText | string | the caption of the update button.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the edit or update button causes validation upon postback.
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createButton | Creates a button and initializes its properties.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
  • TActiveEditCommandColumn
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEmailAddressValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator » TRegularExpressionValidator »
TEmailAddressValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CheckMXRecord | boolean | whether to check MX record for the email address being validated.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options. (inherited from TRegularExpressionValidator)
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ClientSidePatternModifiers | string | clientside pattern modifiers, no modifiers by default. (inherited from TRegularExpressionValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PatternModifiers | string | pattern modifiers, no modifiers by default. (inherited from TRegularExpressionValidator)
 | RegularExpression | string | the regular expression that determines the pattern used to validate a field.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateIsValid | Returns an array of javascript validator options.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEmailLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TLogRoute »
TEmailLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Categories | array | list of categories to be looked for. (inherited from TLogRoute)
 | Emails | array | list of destination email addresses.
 | Levels | integer | log level filter. (inherited from TLogRoute)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | SentFrom | string | send from address of the email.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | Subject | string | email subject.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination. (inherited from TLogRoute)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields. (inherited from TLogRoute)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLevelName | level name. (inherited from TLogRoute)
P | getLevelValue | level value. (inherited from TLogRoute)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the route.
P | processLogs | Sends log messages to specified email addresses.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEmptyControlCollection

Namespace: System.Web.UI
Inheritance: TComponent » TList » TControlCollection »
TEmptyControlCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection. (inherited from TControlCollection)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer. (inherited from TControlCollection)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TControlCollection)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEnumerable

Namespace: System
TEnumerable
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | .
key | .
next | .
rewind | .
valid | .
Derived classes
  • TActiveRecordInvalidFinderResult
  • TApplicationMode
  • TBulletStyle
  • TBulletedListDisplayMode
  • TButtonColumnType
  • TButtonType
  • TColorPickerMode
  • TContentDirection
  • TDataGridPagerButtonType
  • TDataGridPagerMode
  • TDataGridPagerPosition
  • TDatePickerInputMode
  • TDatePickerMode
  • TDatePickerPositionMode
  • TDbColumnCaseMode
  • TDbNullConversionMode
  • TDisplayStyle
  • TDraggableConstraint
  • TDraggableGhostingOptions
  • TDraggableRevertOptions
  • THorizontalAlign
  • THotSpotMode
  • THttpRequestUrlFormat
  • THttpSessionCookieMode
  • TInlineFrameAlign
  • TInlineFrameScrollBars
  • TListItemType
  • TListSelectionMode
  • TPagerButtonType
  • TPagerMode
  • TRepeatDirection
  • TRepeatLayout
  • TRpcClientTypesEnumerable
  • TScrollBars
  • TSecurityManagerValidationMode
  • TSliderDirection
  • TSqlMapCacheTypes
  • TTableCaptionAlign
  • TTableGridLines
  • TTableHeaderScope
  • TTableRowSection
  • TTextAlign
  • TTextBoxAutoCompleteType
  • TTextBoxMode
  • TTextHighlighterLineNumberStyle
  • TUrlMappingPatternSecureConnection
  • TUserManagerPasswordMode
  • TValidationCompareOperator
  • TValidationDataType
  • TValidationSummaryDisplayMode
  • TValidationSummaryDisplayStyle
  • TValidatorDisplayStyle
  • TVerticalAlign
  • TWizardNavigationButtonType
  • TWizardStepType
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TErrorHandler

Namespace: System.Exceptions
Inheritance: TComponent » TApplicationComponent » TModule »
TErrorHandler
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ErrorTemplatePath | string | the directory containing error template files.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | displayException | Displays exception information.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getErrorTemplate | Retrieves the template used for displaying external exceptions.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getExceptionTemplate | Retrieves the template used for displaying internal exceptions.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | handleError | Handles PHP user errors and exceptions.
P | handleExternalError | Displays error to the client user.
P | handleRecursiveError | Handles error occurs during error handling (called recursive error).
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
SP | hideSecurityRelated | @since 3.
 | init | Initializes the module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TCallbackErrorHandler
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEventParameter

Namespace: System
Inheritance: TComponent »
TEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveRecordChangeEventParameter
  • TBroadcastEventParameter
  • TBulletedListEventParameter
  • TCallbackEventParameter
  • TCommandEventParameter
  • TDataGatewayEventParameter
  • TDataGatewayResultEventParameter
  • TDataGridItemEventParameter
  • TDataGridPageChangedEventParameter
  • TDataGridPagerEventParameter
  • TDataGridSortCommandEventParameter
  • TDataListItemEventParameter
  • TDropContainerEventParameter
  • TImageClickEventParameter
  • TImageMapEventParameter
  • TOutputCacheCalculateKeyEventParameter
  • TOutputCacheCheckDependencyEventParameter
  • TPagedListFetchDataEventParameter
  • TPagedListPageChangedEventParameter
  • TPagerPageChangedEventParameter
  • TRepeaterItemEventParameter
  • TServerValidateEventParameter
  • TWizardNavigationEventParameter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEventTriggeredCallback

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TCallback » TTriggeredCallback »
TEventTriggeredCallback
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveCallbackControl | standard callback options. (inherited from TCallback)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for TEventTriggeredCallback.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options. (inherited from TCallback)
 | ControlID | string | The ID of the server control the trigger is bounded to. (inherited from TTriggeredCallback)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EventName | string | The client-side event name the trigger listens to.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PreventDefaultAction | boolean | true to prevent/stop default event action.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TargetControl | string | target control client ID or html element ID if control is not found in hierarchy. (inherited from TTriggeredCallback)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
RP | TriggerOptions | array | list of timer options for client-side.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested. (inherited from TCallback)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event. (inherited from TCallback)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Registers the javascript code for initializing the active control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TException

Namespace: System.Exceptions
TException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code.
 | getErrorMessage | error message.
P | getErrorMessageFile | path to the error message file.
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | .
P | setErrorMessage | .
P | translateErrorMessage | Translates an error code into an error message.
Derived classes
  • TApplicationException
  • TInvalidCallbackException
  • TRpcException
  • TSqlMapException
  • TSystemException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TExpression

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TExpression
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | Expression | string | the expression to be evaluated.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the evaluation result of the expression.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFastSqlMapApplicationCache

Namespace: System.Data.SqlMap
TFastSqlMapApplicationCache
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | add | .
 | delete | .
 | flush | .
 | get | .
P | getBaseKey | .
P | getBaseKeyKeyName | .
P | getCache | .
P | getCacheKey | .
 | set | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFeedService

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent » TService »
TFeedService
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Enabled | boolean | whether the service is enabled. (inherited from TService)
 | ID | string | id of this service. (inherited from TService)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineRequestedFeedPath | the requested feed path.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | run | Runs the service.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFileCacheDependency

Namespace: System.Caching
Inheritance: TComponent » TCacheDependency »
TFileCacheDependency
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | FileName | string | the name of the file whose change is to be checked.
R | HasChanged | boolean | Performs the actual dependency checking.
R | Timestamp | int | the last modification time of the file.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFileLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TLogRoute »
TFileLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Categories | array | list of categories to be looked for. (inherited from TLogRoute)
 | Levels | integer | log level filter. (inherited from TLogRoute)
 | LogFile | string | log file name.
 | LogPath | string | directory storing log files.
 | MaxFileSize | integer | maximum log file size in kilo-bytes (KB).
 | MaxLogFiles | integer | number of files used for rotation.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination. (inherited from TLogRoute)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields. (inherited from TLogRoute)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLevelName | level name. (inherited from TLogRoute)
P | getLevelValue | level value. (inherited from TLogRoute)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the route. (inherited from TLogRoute)
P | processLogs | Saves log messages in files.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | rotateFiles | Rotates log files.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFileUpload

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TFileUpload
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | ErrorCode | integer | Returns an error code describing the status of this file uploading.
R | FileName | string | the original full path name of the file on the client machine.
R | FileSize | integer | the actual size of the uploaded file in bytes.
R | FileType | string | the MIME-type of the uploaded file (such as "image/gif").
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFile | boolean | whether the file is uploaded successfully.
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully.
R | LocalName | string | the local name of the file (where it is after being uploaded).
 | MaxFileSize | integer | the maximum file size, defaults to 1MB (1048576 bytes).
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the file upload control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ValidationPropertyValue | mixed | Returns the original file name as the property value to be validated.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnFileUpload | This method is invoked when a file is uploaded during a postback.
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Sets Enctype of the form on the page.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Sets name attribute to the unique ID of the control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveAs | Saves the uploaded file.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveFileUpload
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFirePhpLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TLogRoute »
TFirePhpLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Categories | array | list of categories to be looked for. (inherited from TLogRoute)
 | GroupLabel | string | group label.
 | Levels | integer | log level filter. (inherited from TLogRoute)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination. (inherited from TLogRoute)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields. (inherited from TLogRoute)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLevelName | level name. (inherited from TLogRoute)
P | getLevelValue | level value. (inherited from TLogRoute)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the route. (inherited from TLogRoute)
 | processLogs | .
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
SP | translateLogLevel | Translates a PRADO log level attribute into one understood by FirePHP for correct visualization .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFirebugLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TLogRoute » TBrowserLogRoute »
TFirebugLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Categories | array | list of categories to be looked for. (inherited from TLogRoute)
 | CssClass | string | the css class of the control. (inherited from TBrowserLogRoute)
 | Levels | integer | log level filter. (inherited from TLogRoute)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination. (inherited from TLogRoute)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields. (inherited from TLogRoute)
P | getColorLevel | . (inherited from TBrowserLogRoute)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getFirebugLoggingFunction | .
P | getLevelName | level name. (inherited from TLogRoute)
P | getLevelValue | level value. (inherited from TLogRoute)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the route. (inherited from TLogRoute)
 | processLogs | . (inherited from TBrowserLogRoute)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | renderFooter | .
P | renderHeader | .
P | renderMessage | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFlushOutput

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TFlushOutput
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | ContinueBuffering | Tells | whether buffering of output can continue after this point.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Flushes the output of all completely rendered controls to the client.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFont

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TFont
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Bold | boolean | whether the font is in bold face.
R | IsEmpty | boolean | whether the font is empty.
 | Italic | boolean | whether the font is in italic face.
 | Name | string | the font name (family).
 | Overline | boolean | whether the font is overlined.
 | Size | string | the font size.
 | Strikeout | boolean | whether the font is strikeout.
 | Underline | boolean | whether the font is underlined.
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
copyFrom | Copies the fields in a new font to this font.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
mergeWith | Merges the font with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Clears up the font.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toString | the font in a css style string representation.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TForm

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TControl »
TForm
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultButton | string | id path to the default button control.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | Enctype | string | the encoding type a browser uses to post data back to the server.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | Method | string | form submission method.
R | Name | string | form name, which is equal to UniqueID.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the form with the page.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds form specific attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the form.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TGlobalStateCacheDependency

Namespace: System.Caching
Inheritance: TComponent » TCacheDependency »
TGlobalStateCacheDependency
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | HasChanged | boolean | Performs the actual dependency checking.
 | StateName | string | the name of the global state.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TGlobalization

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TModule »
TGlobalization
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Charset | string | localization charset.
 | Culture | string | current application culture.
R | CultureVariants | array | Gets all the variants of a specific culture.
 | DefaultCharset | string | default charset set.
 | DefaultCulture | string | default culture.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | TranslateDefaultCulture | string | default culture.
 | TranslationCatalogue | string | current translation catalogue.
 | TranslationConfiguration | TMap | translation source configuration.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getLocalizedResource | Returns a list of possible localized files.
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initialize the Culture and Charset for this application.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TGlobalizationAutoDetect
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TGlobalizationAutoDetect

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TModule » TGlobalization »
TGlobalizationAutoDetect
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Charset | string | localization charset. (inherited from TGlobalization)
 | Culture | string | current application culture. (inherited from TGlobalization)
R | CultureVariants | array | Gets all the variants of a specific culture. (inherited from TGlobalization)
 | DefaultCharset | string | default charset set. (inherited from TGlobalization)
 | DefaultCulture | string | default culture. (inherited from TGlobalization)
R | DetectedLanguage | {unknown} | .
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | TranslateDefaultCulture | string | default culture. (inherited from TGlobalization)
 | TranslationCatalogue | string | current translation catalogue. (inherited from TGlobalization)
 | TranslationConfiguration | TMap | translation source configuration. (inherited from TGlobalization)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getLocalizedResource | Returns a list of possible localized files. (inherited from TGlobalization)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | .
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THead

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TControl »
THead
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BaseUrl | string | base URL of the page.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | MetaTags | TMetaTagCollection | meta tag collection.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShortcutIcon | string | the URL for the shortcut icon of the page.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Title | string | the page title.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the head control with the current page.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the head control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THeader1

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » THtmlElement »
THeader1
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
R | DefaultTagName | string | tag name.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsMutated | boolean | This tells you if this TagName has deviated from the original . (inherited from THtmlElement)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TagName | string | the tag name of this control. (inherited from THtmlElement)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THeader2

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » THtmlElement »
THeader2
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
R | DefaultTagName | string | tag name.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsMutated | boolean | This tells you if this TagName has deviated from the original . (inherited from THtmlElement)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TagName | string | the tag name of this control. (inherited from THtmlElement)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THeader3

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » THtmlElement »
THeader3
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
R | DefaultTagName | string | tag name.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsMutated | boolean | This tells you if this TagName has deviated from the original . (inherited from THtmlElement)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TagName | string | the tag name of this control. (inherited from THtmlElement)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THeader4

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » THtmlElement »
THeader4
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
R | DefaultTagName | string | tag name.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsMutated | boolean | This tells you if this TagName has deviated from the original . (inherited from THtmlElement)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TagName | string | the tag name of this control. (inherited from THtmlElement)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THeader5

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » THtmlElement »
THeader5
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
R | DefaultTagName | string | tag name.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsMutated | boolean | This tells you if this TagName has deviated from the original . (inherited from THtmlElement)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TagName | string | the tag name of this control. (inherited from THtmlElement)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THeader6

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » THtmlElement »
THeader6
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
R | DefaultTagName | string | tag name.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsMutated | boolean | This tells you if this TagName has deviated from the original . (inherited from THtmlElement)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TagName | string | the tag name of this control. (inherited from THtmlElement)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THiddenField

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
THiddenField
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the hidden field.
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | EnableTheming | boolean | whether theming is enabled for this control.
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TagName | string | tag name of the hidden field.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ValidationPropertyValue | mixed | Returns the value to be validated.
 | Value | string | the value of the THiddenField.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
OnValueChanged | This method is invoked when the value of the Value property changes between posts to the server.
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets focus to this control.
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads hidden field data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveHiddenField
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THorizontalAlign

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
THorizontalAlign
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THotSpot

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
THotSpot
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key that allows you to quickly navigate to the HotSpot region.
 | AlternateText | string | the alternate text to display for a HotSpot object.
R | Attributes | TAttributeCollection | Returns the list of custom attributes.
 | CausesValidation | boolean | whether postback event trigger by this hotspot will cause input validation, default is true.
R | Coordinates | string | coordinates defining the hotspot shape.
R | HasAttributes | boolean | whether the hotspot has custom attributes.
 | HotSpotMode | THotSpotMode | the behavior of a HotSpot object when it is clicked.
 | NavigateUrl | string | the URL to navigate to when a HotSpot object is clicked.
 | PostBackValue | string | a value that is post back when the HotSpot is clicked.
R | Shape | string | shape of the hotspot, can be 'circle', 'rect', 'poly', etc.
 | TabIndex | integer | the tab index of the HotSpot region.
 | Target | string | the target window or frame to display the new page when the HotSpot region is clicked.
 | ValidationGroup | string | the group of validators which the hotspot causes validation upon postback.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getAttribute | attribute value, null if attribute does not exist.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value.
 | hasAttribute | whether the named attribute exists.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | removeAttribute | Removes the named attribute.
 | render | Renders this hotspot.
 | setAttribute | Sets a custom hotspot attribute.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value.
Derived classes
  • TCircleHotSpot
  • TPolygonHotSpot
  • TRectangleHotSpot
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THotSpotCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
THotSpotCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THotSpotMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
THotSpotMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THtmlArea

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox »
THtmlArea
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoPostBack | boolean | whether change of the content should cause postback.
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
R | AvailablePlugins | array | Returns a list of plugins to be loaded.
R | AvailableThemes | array | list of available themese.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
RP | CompressionOptions | {unknown} | .
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | Culture | string | Gets the current culture.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | CustomPluginPath | string | path to custom plugins to be copied.
 | Data | string | Returns the text content of the TTextBox control. (inherited from TTextBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
RP | EditorOptions | array | Default editor options gives basic tool bar only.
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableCompression | boolean | enable compression of the javascript files, default is true.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | EnableVisualEdit | boolean | whether to show WYSIWYG text editor.
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Options | string | Gets the list of options for the WYSIWYG (TinyMCE) editor .
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
RP | PostBackOptions | array | Gets the post back options for this textbox. (inherited from TTextBox)
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
RP | ScriptDeploymentPath | string | Gets the editor script base URL by publishing the tarred source via TTarAssetManager.
RP | ScriptUrl | string | editor script URL.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox. (inherited from TTextBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextMode | string | Overrides the parent implementation.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TTextBox)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
P | copyCustomPlugins | .
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLanguageSuffix | localized editor interface language extension.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadJavascriptLibrary | .
 | loadPostData | Loads user input data. (inherited from TTextBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | parseEditorOptions | Parse additional options set in the Options property.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
P | registerEditorClientScript | Registers the editor javascript file and code to initialize the editor.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for textbox. (inherited from TTextBox)
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode. (inherited from TTextBox)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THtmlElement

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
THtmlElement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
R | DefaultTagName | string | This is the default tag when no other is specified .
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsMutated | boolean | This tells you if this TagName has deviated from the original .
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TagName | string | the tag name of this control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • THeader1
  • THeader2
  • THeader3
  • THeader4
  • THeader5
  • THeader6
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THtmlWriter

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent »
THtmlWriter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Writer | {unknown} | .
Events
Methods
Name | Description
addAttribute | Adds an attribute to be rendered.
addAttributes | Adds a list of attributes to be rendered.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
addStyleAttribute | Adds a stylesheet attribute to be rendered .
addStyleAttributes | Adds a list of stylesheet attributes to be rendered.
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flush | Flushes the rendering result.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
removeAttribute | Removes the named attribute from rendering .
removeStyleAttribute | Removes the named stylesheet attribute from rendering .
renderBeginTag | Renders the openning tag.
renderEndTag | Renders the closing tag.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
write | Renders a string.
writeBreak | Renders an HTML break.
writeLine | Renders a string and appends a newline to it.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpCookie

Namespace: System.Web
Inheritance: TComponent »
THttpCookie
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Domain | string | the domain to associate the cookie with.
Expire | integer | the time the cookie expires.
HttpOnly | boolean | if true the cookie value will be unavailable to JavaScript.
Name | string | the name of the cookie.
Path | string | the path on the server in which the cookie will be available on, default is '/'.
Secure | boolean | whether the cookie should only be transmitted over a secure HTTPS connection.
Value | string | the value of the cookie.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpCookieCollection

Namespace: System.Web
Inheritance: TComponent » TList »
THttpCookieCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
findCookieByName | Finds the cookie with the specified name.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | the cookie found.
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
THttpException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getStatusCode | HTTP status code, such as 404, 500, etc.
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpRequest

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent »
THttpRequest
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AbsoluteApplicationUrl | string | entry script URL (w/ host part).
R | AcceptTypes | string | user browser accept types.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | ApplicationFilePath | string | application entry script file path (processed w/ realpath()).
R | ApplicationUrl | string | entry script URL (w/o host part).
R | BaseUrl | string | schema and hostname of the requested URL.
R | Browser | array | user browser capabilities @see get_browser.
 | CgiFix | integer | whether to use ORIG_PATH_INFO and/or ORIG_SCRIPT_NAME.
R | ContentType | string | content type (e.
R | Cookies | THttpCookieCollection | list of cookies to be sent.
R | Count | integer | the number of items in the request.
 | EnableCookieValidation | boolean | whether cookies should be validated.
R | EnvironmentVariables | array | list of environment variables.
R | Headers | array | .
R | HttpProtocolVersion | string | the requested http procolol.
 | ID | string | id of this module.
R | IsSecureConnection | boolean | if the request is sent via secure channel (https).
R | Iterator | Iterator | Returns an iterator for traversing the items in the list.
R | Keys | array | the key list.
R | PathInfo | string | part of the request URL after script name and before question mark.
R | QueryString | string | part of that request URL after the question mark.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | RequestResolved | boolean | true if request is already resolved, false otherwise.
R | RequestType | string | request type, can be GET, POST, HEAD, or PUT.
R | RequestUri | string | part of that request URL after the host info (including pathinfo and query string).
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | ServerName | string | server name.
R | ServerPort | integer | server port number.
R | ServerVariables | array | list of server variables.
R | Service | IService | the current service. (inherited from TApplicationComponent)
 | ServiceID | string | requested service ID.
 | ServiceParameter | string | requested service parameter.
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | UploadedFiles | array | list of uploaded files.
R | Url | TUri | the request URL.
 | UrlFormat | THttpRequestUrlFormat | the format of URLs.
 | UrlManager | string | the ID of the URL manager module.
R | UrlManagerModule | TUrlManager | the URL manager module.
 | UrlParamSeparator | string | separator used to separate GET variable name and value when URL format is Path.
R | UrlReferrer | string | URL referrer, null if not present.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | UserAgent | string | user agent.
R | UserHost | string | user host name, null if cannot be determined.
R | UserHostAddress | string | user IP address.
R | UserLanguages | array | Returns a list of user preferred languages.
Events
Methods
 | Name | Description
 | add | Adds an item into the request.
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clear | Removes all items in the request.
 | constructUrl | Constructs a URL that can be recognized by PRADO.
 | contains | whether the request contains an item with the specified key.
 | count | Returns the number of items in the request.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the module.
 | itemAt | Returns the item with the specified key.
 | offsetExists | Returns whether there is an element at the specified offset.
 | offsetGet | Returns the element at the specified offset.
 | offsetSet | Sets the element at the specified offset.
 | offsetUnset | Unsets the element at the specified offset.
P | parseUrl | Parses the request URL and returns an array of input parameters (excluding GET variables).
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes an item from the request by its key.
 | resolveRequest | Resolves the requested service.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | stripSlashes | Strips slashes from input data.
 | toArray | the list of items in array.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpRequestUrlFormat

Namespace: System.Web
Inheritance: TEnumerable »
THttpRequestUrlFormat
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpResponse

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent » TModule »
THttpResponse
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | THttpResponseAdapter | response adapter, null if not exist.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | BufferOutput | boolean | whether to enable output buffer.
 | CacheControl | string | cache control method to use for session pages.
 | CacheExpire | integer | time-to-live for cached session pages in minutes, this has no effect for nocache limiter.
 | Charset | string|boolean | output charset.
 | ContentType | string | current content type.
R | Contents | string | Returns the content in the output buffer.
R | Cookies | THttpCookieCollection | list of output cookies.
R | HasAdapter | boolean | true if adapter exists, false otherwise.
R | Headers | array | .
 | HtmlWriterType | string | the type of HTML writer to be used, defaults to THtmlWriter.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | StatusCode | integer | HTTP status code, defaults to 200.
R | StatusReason | {unknown} | .
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addCookie | Sends a cookie.
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | appendHeader | Sends a header.
 | appendLog | Writes a log message into error log.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clear | Clears any existing buffered content.
 | createHtmlWriter | Creates a new instance of HTML writer.
 | createNewHtmlWriter | Create a new html writer instance.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureContentTypeHeaderSent | Ensures that the HTTP header with the status code and status reason are sent.
 | ensureHeadersSent | Ensures that HTTP response and content-type headers are sent.
P | ensureHttpHeaderSent | Ensures that the HTTP header with the status code and status reason are sent.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Flush the response contents and headers.
 | flushContent | Outputs the buffered content, sends content-type and charset header.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | httpRedirect | Redirect the browser to another URL and exists the current application.
 | init | Initializes the module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | redirect | Redirects the browser to the specified URL.
 | reload | Reloads the current page.
 | removeCookie | Deletes a cookie.
P | sendContentTypeHeader | Sends content type header with optional charset.
P | sendHttpHeader | Send the HTTP header with the status code (defaults to 200) and status reason (defaults to OK).
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | write | Outputs a string.
 | writeFile | Sends a file back to user.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpResponseAdapter

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent »
THttpResponseAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response object adapted.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createNewHtmlWriter | This method is invoked when a new HtmlWriter needs to be created.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flushContent | This method is invoked when the response flushes the content and headers.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
httpRedirect | This method is invoked when the response is to redirect to another page.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TCallbackResponseAdapter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpSession

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent »
THttpSession
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | AutoStart | boolean | whether the session should be automatically started when the session module is initialized, defaults to false.
R | Cookie | THttpCookie | cookie that will be used to store session ID.
 | CookieMode | THttpSessionCookieMode | how to use cookie to store session ID.
R | Count | integer | the number of session variables.
 | GCProbability | integer | the probability (percentage) that the gc (garbage collection) process is started on every session initialization, defaults to 1 meaning 1% chance.
 | ID | string | id of this module.
R | IsStarted | boolean | whether the session has started.
R | Iterator | TSessionIterator | Returns an iterator for traversing the session variables.
R | Keys | array | the list of session variable names.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | SavePath | string | the current session save path, defaults to '/tmp'.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SessionID | string | the current session ID.
 | SessionName | string | the current session name.
 | Timeout | integer | the number of seconds after which data will be seen as 'garbage' and cleaned up, defaults to 1440 seconds.
 | UseCustomStorage | boolean | whether to use user-specified handlers to store session data.
 | UseTransparentSessionID | boolean | whether transparent sid support is enabled or not, defaults to false.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
_close | Session close handler.
_destroy | Session destroy handler.
_gc | Session GC (garbage collection) handler.
_open | Session open handler.
_read | Session read handler.
_write | Session write handler.
add | Adds a session variable.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all session variables.
close | Ends the current session and store session data.
contains | whether there is the named session variable.
count | Returns the number of items in the session.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
destroy | Destroys all data registered to a session.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the module.
itemAt | Returns the session variable value with the session variable name.
offsetExists | This method is required by the interface ArrayAccess.
offsetGet | This method is required by the interface ArrayAccess.
offsetSet | This method is required by the interface ArrayAccess.
offsetUnset | This method is required by the interface ArrayAccess.
open | Starts the session if it has not started yet.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
regenerate | Update the current session id with a newly generated one .
remove | Removes a session variable.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of all session variables in array.
Derived classes
  • TCacheHttpSession
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpSessionCookieMode

Namespace: System.Web
Inheritance: TEnumerable »
THttpSessionCookieMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpUtility

Namespace: System.Web
THttpUtility
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | htmlDecode | HTML-decodes a string.
S | htmlEncode | HTML-encodes a string.
S | htmlStrip | This method strips the following characters from a string: HTML entities: <, >, " .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THyperLink

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
THyperLink
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL to link to when the THyperLink component is clicked.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageHeight | string | height of the image in the THyperLink.
 | ImageUrl | string | the location of the image file for the THyperLink.
 | ImageWidth | string | width of the image in the THyperLink.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NavigateUrl | string | the URL to link to when the THyperLink component is clicked.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the hyperlink.
 | Target | string | the target window or frame to display the Web page content linked to when the THyperLink component is clicked.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the THyperLink.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes related to a hyperlink element to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createImage | Gets the TImage for rendering the ImageUrl property.
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the hyperlink.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveHyperLink
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THyperLinkColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
THyperLinkColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataNavigateUrlField | string | the field name from the data source to bind to the navigate url of hyperlink.
 | DataNavigateUrlFormatString | string | the formatting string used to control how the navigate url of hyperlink will be displayed.
 | DataTextField | string | the field name from the data source to bind to the hyperlink caption.
 | DataTextFormatString | string | the formatting string used to control how the hyperlink caption will be displayed.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
 | ImageHeight | string | height of the image in the THyperLink.
 | ImageUrl | string | url of the image in the THyperLink.
 | ImageWidth | string | width of the image in the THyperLink.
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | NavigateUrl | string | the URL to link to when the hyperlink is clicked.
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
 | Target | string | the target window or frame to display the Web page content linked to when the hyperlink is clicked.
 | Text | string | the text caption of the hyperlink.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
  • TActiveHyperLinkColumn
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TI18NControl

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TControl »
TI18NControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | Charset | string | Gets the charset.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | Culture | string | Get the specific culture for this control.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TDateFormat
  • TNumberFormat
  • TTranslate
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TIOException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TIOException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TIbmScaffoldInput

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
Inheritance: TScaffoldInputBase » TScaffoldInputCommon »
TIbmScaffoldInput
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createBooleanControl | . (inherited from TScaffoldInputCommon)
P | createControl | .
P | createControlLabel | . (inherited from TScaffoldInputBase)
P | createDateControl | . (inherited from TScaffoldInputCommon)
P | createDateTimeControl | . (inherited from TScaffoldInputCommon)
P | createDefaultControl | . (inherited from TScaffoldInputCommon)
P | createEnumControl | . (inherited from TScaffoldInputCommon)
P | createFloatControl | . (inherited from TScaffoldInputCommon)
S | createInputBuilder | . (inherited from TScaffoldInputBase)
P | createIntegerControl | . (inherited from TScaffoldInputCommon)
P | createMultiLineControl | . (inherited from TScaffoldInputCommon)
P | createRangeValidator | . (inherited from TScaffoldInputCommon)
P | createRequiredValidator | . (inherited from TScaffoldInputCommon)
 | createScaffoldInput | . (inherited from TScaffoldInputBase)
P | createSetControl | . (inherited from TScaffoldInputCommon)
P | createTimeControl | . (inherited from TScaffoldInputCommon)
P | createTypeValidator | . (inherited from TScaffoldInputCommon)
P | createYearControl | . (inherited from TScaffoldInputCommon)
P | getControlValue | .
P | getDateTimeValue | . (inherited from TScaffoldInputCommon)
P | getDefaultControlValue | . (inherited from TScaffoldInputCommon)
P | getEnumValue | . (inherited from TScaffoldInputCommon)
P | getIsEnabled | . (inherited from TScaffoldInputBase)
P | getMatchingIndices | . (inherited from TScaffoldInputCommon)
P | getParent | . (inherited from TScaffoldInputBase)
P | getRecordPropertyValue | . (inherited from TScaffoldInputBase)
P | getSetValue | . (inherited from TScaffoldInputCommon)
P | getTimeValue | . (inherited from TScaffoldInputCommon)
 | loadScaffoldInput | . (inherited from TScaffoldInputBase)
P | setDefaultProperty | . (inherited from TScaffoldInputCommon)
P | setNotNullProperty | . (inherited from TScaffoldInputCommon)
P | setRecordPropertyValue | . (inherited from TScaffoldInputBase)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TImage

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TImage
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AlternateText | string | the alternative text displayed in the TImage component when the image is unavailable.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL of the image file.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | DescriptionUrl | string | the URL to long description.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageAlign | string | the alignment of the image with respective to other elements on the page, defaults to empty.
 | ImageUrl | string | the URL of the image file.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of image control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes related to an HTML image element to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the image.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveImage
  • TCaptcha
  • TImageButton
  • TImageMap
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TImageButton

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TImage »
TImageButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AlternateText | string | the alternative text displayed in the TImage component when the image is unavailable. (inherited from TImage)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation, default is true.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | CommandName | string | the command name associated with the OnCommand event.
 | CommandParameter | string | the parameter associated with the OnCommand event.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL of the image file. (inherited from TImage)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | DescriptionUrl | string | the URL to long description. (inherited from TImage)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageAlign | string | the alignment of the image with respective to other elements on the page, defaults to empty. (inherited from TImage)
 | ImageUrl | string | the URL of the image file. (inherited from TImage)
 | IsDefaultButton | boolean | true if this button is registered as a default button for a panel.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the button.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | caption of the button.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnClick | This method is invoked when the button is clicked.
OnCommand | This method is invoked when the button is clicked.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the image button to receive postback data during postback.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | canCauseValidation | whether to perform validation if the button is clicked.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | This method checks if the TImageButton is clicked and loads the coordinates of the clicking position.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | needPostBackScript | whether the button needs javascript to do postback.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event.
 | raisePostDataChangedEvent | A dummy implementation for the IPostBackDataHandler interface.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the client-script code.
 | renderContents | Renders the body content enclosed between the control tag.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveImageButton
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TImageClickEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TImageClickEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
X | integer | X coordinate of the clicking point, defaults to 0.
Y | integer | Y coordinate of the clicking point, defaults to 0.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TImageMap

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TImage »
TImageMap
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AlternateText | string | the alternative text displayed in the TImage component when the image is unavailable. (inherited from TImage)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL of the image file. (inherited from TImage)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | DescriptionUrl | string | the URL to long description. (inherited from TImage)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HotSpotMode | THotSpotMode | the behavior of hotspot regions in this imagemap when they are clicked.
R | HotSpots | THotSpotCollection | collection of hotspots defined in this imagemap.
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageAlign | string | the alignment of the image with respective to other elements on the page, defaults to empty. (inherited from TImage)
 | ImageUrl | string | the URL of the image file. (inherited from TImage)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of image control. (inherited from TImage)
 | Target | string | the target window or frame to display the new page when a hotspot region is clicked within the imagemap.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnClick | Raises OnClick event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Processes an object that is created during parsing template.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders this imagemap.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the image. (inherited from TImage)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TImageMapEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TImageMapEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | PostBackValue | string | post back value associated with the hotspot clicked.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInPlaceTextBox

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox » TActiveTextBox »
TInPlaceTextBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options. (inherited from TActiveTextBox)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoHideTextBox | boolean | true will hide the textbox after losing focus.
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. (inherited from TTextBox)
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TInPlaceTextBox.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options. (inherited from TActiveTextBox)
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the TTextBox control. (inherited from TTextBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | DisplayTextBox | boolean | true to display the edit textbox.
 | EditTriggerControlID | string | ID of the control that can trigger to edit the textbox.
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
RP | ExternalControlID | string | edit trigger control client ID.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
RP | LabelClientID | string | label client ID.
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
RP | PostBackOptions | array | callback options.
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component. (inherited from TTextBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TTextBox)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnLoadingText | Raised when editing the content is requsted to be loaded from the server side.
OnPreRender | Registers CSS and JS.
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | callClientFunction | Calls the client-side static method for this control class.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TTextBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event. (inherited from TActiveTextBox)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
P | registerClientScript | Registers the relevant JavaScript.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender. (inherited from TActiveTextBox)
 | renderContents | Renders the body content of the label.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInlineFrame

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TInlineFrame
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
 | Align | TInlineFrameAlign | alignment of the iframe.
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL that this iframe will load content from This method is required by IDataRenderer.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | DescriptionUrl | string | the URL to long description.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | FrameUrl | string | URL that this iframe will load content from.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | MarginHeight | integer | the amount of space, in pixels, that should be left between the frame's contents and the top and bottom margins.
 | MarginWidth | integer | the amount of space, in pixels, that should be left between the frame's contents and the left and right margins.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScrollBars | TInlineFrameScrollBars | the visibility and position of scroll bars in an iframe.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowBorder | boolean | whether there should be a visual separator between the frames.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the iframe.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInlineFrameAlign

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TInlineFrameAlign
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInlineFrameScrollBars

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TInlineFrameScrollBars
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInlineParameterMapParser

Namespace: System.Data.SqlMap.Configuration
TInlineParameterMapParser
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | parse | Parse the sql text for inline parameters.
P | parseMapping | Parse inline parameter with syntax as #propertyName,type=string,dbype=Varchar,nullValue=N/A,handler=string# .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInsertMappedStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent » TMappedStatement »
TInsertMappedStatement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TPreparedCommand | command to prepare SQL statements. (inherited from TMappedStatement)
R | ID | string | Name used to identify the TMappedStatement amongst the others. (inherited from TMappedStatement)
R | Manager | TSqlMapper | The SqlMap used by this MappedStatement. (inherited from TMappedStatement)
R | SqlString | {unknown} | . (inherited from TMappedStatement)
R | Statement | TSqlMapStatement | The SQL statment used by this MappedStatement. (inherited from TMappedStatement)
Events
Name | Description
OnExecuteQuery | Raise the execute query event. (inherited from TMappedStatement)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addResultMapGroupBy | ResultMap with GroupBy property. (inherited from TMappedStatement)
P | applyResultMap | Apply result mapping. (inherited from TMappedStatement)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | enquequePostSelect | Add nested result property to post select queue. (inherited from TMappedStatement)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | executeInsert | Execute an insert statement. (inherited from TMappedStatement)
P | executePostSelect | Process 'select' result properties . (inherited from TMappedStatement)
 | executeQueryForList | .
 | executeQueryForMap | .
 | executeQueryForObject | .
P | executeSQLQueryLimit | Execute SQL Query with limits. (inherited from TMappedStatement)
P | executeSelectKey | Execute the select key statement, used to obtain last insert ID. (inherited from TMappedStatement)
 | executeUpdate | .
P | fillArrayResultMap | Retrieve the result map as an array. (inherited from TMappedStatement)
P | fillDefaultResultMap | Fill the result map using default settings. (inherited from TMappedStatement)
P | fillPropertyWithResultMap | Fills the property with result mapping results. (inherited from TMappedStatement)
P | fillResultArrayList | Apply the result to a TList or an array. (inherited from TMappedStatement)
P | fillResultClass | Fill the result using ResultClass, will creates new result object if required. (inherited from TMappedStatement)
P | fillResultMap | Fills the result object according to result mappings. (inherited from TMappedStatement)
P | fillResultObjectProperty | Apply the result to an object. (inherited from TMappedStatement)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPostGeneratedSelectKey | Gets the inserted row ID after executing an insert statement. (inherited from TMappedStatement)
P | getPostSelectKeys | Finds in the post select property the SQL statement primary selection keys. (inherited from TMappedStatement)
P | getPreGeneratedSelectKey | Gets the insert generated ID before executing an insert statement. (inherited from TMappedStatement)
P | getResultMapGroupKey | Gets the result 'group by' groupping key for each row. (inherited from TMappedStatement)
P | getScalarResult | Converts the first array value to scalar value of given type. (inherited from TMappedStatement)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initialGroupByResults | Empty the group by results cache. (inherited from TMappedStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | raiseRowDelegate | Raises delegate handler. (inherited from TMappedStatement)
 | runQueryForList | Executes the SQL and retuns a List of result objects. (inherited from TMappedStatement)
 | runQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. (inherited from TMappedStatement)
 | runQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter. (inherited from TMappedStatement)
P | setObjectProperty | Set a property of the result object with appropriate value. (inherited from TMappedStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInvalidCallbackException

Namespace: System.Web.UI.ActiveControls
Inheritance: TException »
TInvalidCallbackException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInvalidDataTypeException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TInvalidDataTypeException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInvalidDataValueException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TInvalidDataValueException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInvalidOperationException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TInvalidOperationException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInvalidPropertyException

Namespace: System.Data.SqlMap
Inheritance: TException » TSqlMapException »
TInvalidPropertyException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TSqlMapException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
P | implodeNode | tag name and attribute names and values. (inherited from TSqlMapException)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TItemDataRenderer

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TDataRenderer »
TItemDataRenderer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item. (inherited from TDataRenderer)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
 | ItemIndex | integer | Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
 | ItemType | TListItemType | item type.
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TDataGridItemRenderer
  • TDataListItemRenderer
  • TRepeaterItemRenderer
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJavaScript

Namespace: System.Web.Javascripts
TJavaScript
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | JSMin | Minimize the size of a javascript script.
S | encode | Encodes a PHP variable into javascript representation.
S | isFunction | Deprecated, use isJsLiteral instead.
S | isJsLiteral | true if the parameter is marked as a javascript function, i.
S | jsonDecode | Decodes a javascript string into PHP variable.
S | jsonEncode | Encodes a PHP variable into javascript string.
S | quoteFunction | Deprecated, use quoteJsLiteral instead.
S | quoteJsLiteral | a string as a javascript function.
S | quoteString | Quotes a javascript string.
S | renderScriptBlock | Renders javascript block .
S | renderScriptBlocks | Renders a list of javascript blocks .
S | renderScriptFile | Renders a javascript file .
S | renderScriptFiles | Renders a list of javascript files .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJavaScriptLiteral

Namespace: System
TJavaScriptLiteral
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
toJavaScriptLiteral | .
Derived classes
  • TJavaScriptString
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJavaScriptString

Namespace: System
Inheritance: TJavaScriptLiteral »
TJavaScriptString
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
toJavaScriptLiteral | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJavascriptLogger

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TJavascriptLogger
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the panel.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToggleKey | string | keyboard key for toggling the console.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the required logger javascript.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Register the required javascript libraries and display some general usage information.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJsonResponse

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent »
TJsonResponse
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | ID of this response.
R | JsonContent | object | json response content, null to suppress output.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the feed.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJsonRpcClient

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TRpcClient »
TJsonRpcClient
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | IsNotification | boolean | whether requests are considered to be notifications (completely ignoring the response). (inherited from TRpcClient)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ServerUrl | string | url of the RPC server. (inherited from TRpcClient)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
S | create | Creates an instance of TJsonRpcClient .
P | createStreamContext | Creates a stream context resource . (inherited from TRpcClient)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | encodeRequest | .
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | performRequest | Performs the actual request . (inherited from TRpcClient)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJsonRpcProtocol

Namespace: System.Web.Services
Inheritance: TRpcProtocol »
TJsonRpcProtocol
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addMethod | Registers a new RPC method and handler details . (inherited from TRpcProtocol)
callApiMethod | Calls the callback handler for the given method . (inherited from TRpcProtocol)
callMethod | Handles the RPC request .
createErrorResponse | Turns the given exception into an JSON RPC fault .
createResponseHeaders | Sets the correct response headers .
decode | Decodes JSON encoded data into PHP data .
encode | Encodes PHP data into JSON data .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJsonService

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent » TService »
TJsonService
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Enabled | boolean | whether the service is enabled. (inherited from TService)
 | ID | string | id of this service. (inherited from TService)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createJsonResponse | Renders content provided by TJsonResponse::getJsonContent() as javascript in JSON format.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
P | loadJsonServices | Load the service definitions.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | run | Runs the service.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TKeyboard

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TKeyboard
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoHide | boolean | whether the keyboard should be hidden when the textbox is not in focus.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | the Javascript class name for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientOptions | array | the JavaScript options for this control.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CssUrl | string | the URL for the CSS file to customize the appearance of the keyboard.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the ID path of the TTextBox control.
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | KeyboardCssClass | string | the CSS class name for the keyboard element.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers CSS and JS.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScript | Registers the relevant JavaScript.
 | registerObject | Registers an object by a name. (inherited from TControl)
P | registerStyleSheet | Registers the CSS relevant to the TKeyboard.
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLabel

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TLabel
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID.
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the label.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveLabel
  • TBaseValidator
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLazyLoadList

Namespace: System.Data.SqlMap
TLazyLoadList
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | fetchListData | Load the data by executing the mapped statement.
 | hasMethod | Try to fetch the data when any of the proxy collection method is called.
 | intercept | Relay the method call to the underlying collection.
S | newInstance | Create a new instance of a lazy collection.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLinkButton

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TLinkButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | CommandName | string | the command name associated with the OnCommand event.
 | CommandParameter | string | the parameter associated with the OnCommand event.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the caption of the button.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsDefaultButton | boolean | true if this button is registered as a default button for a panel.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the button.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the button.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnClick | This method is invoked when the button is clicked.
OnCommand | This method is invoked when the button is clicked.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the client-script code.
 | renderContents | Renders the body content enclosed between the control tag.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderLinkButtonHref | Renders the Href for link button.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveLinkButton
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TList

Namespace: System.Collections
Inheritance: TComponent »
TList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list.
R | Iterator | Iterator | Returns an iterator for traversing the items in the list.
 | ReadOnly | boolean | whether this list is read-only or not.
Events
Methods
Name | Description
add | Appends an item at the end of the list.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list.
contains | whether the list contains the item.
copyFrom | Copies iterable data into the list.
count | Returns the number of items in the list.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found.
insertAfter | Finds the base item.
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item.
itemAt | Returns the item at the specified offset.
mergeWith | Merges iterable data into the map.
offsetExists | Returns whether there is an item at the specified offset.
offsetGet | Returns the item at the specified offset.
offsetSet | Sets the item at the specified offset.
offsetUnset | Unsets the item at the specified offset.
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list.
removeAt | Removes an item at the specified position.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array.
Derived classes
  • TAuthorizationRuleCollection
  • TCacheDependencyList
  • TControlCollection
  • TDataGridColumnCollection
  • TDataGridItemCollection
  • TDataListItemCollection
  • THotSpotCollection
  • THttpCookieCollection
  • TListItemCollection
  • TMetaTagCollection
  • TPagedList
  • TPriorityList
  • TRepeaterItemCollection
  • TWizardStepCollection
  • TXmlElementList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListBox

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl »
TListBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control allows multiple selection.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully.
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | postback options for JS postback code. (inherited from TListControl)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows to be displayed in the list control.
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
 | SelectionMode | TListSelectionMode | the selection mode (Single, Multiple).
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated.
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the list control to load post data on postback.
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveListBox
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListControl

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl »
TListControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index.
 | DataGroupField | string | the field of the data source that provides the label of the list item groups.
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items.
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed.
 | DataValueField | string | the field of the data source that provides the value of each list item.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items.
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this is a multiselect control.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | ItemCount | integer | the number of items in the list control.
R | Items | TListItemCollection | the item collection.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | postback options for JS postback code.
 | PromptText | string | the prompt text which is to be displayed as the first list item.
 | PromptValue | string | the prompt selection value.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected.
 | SelectedIndices | array | list of index of items that are selected.
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected.
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection.
 | SelectedValues | array | list of the selected item values (strings).
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback.
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed.
OnTextChanged | Raises OnTextChanged event when selection is changed.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds object parsed from template to the control.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections.
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items.
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string.
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control.
 | renderContents | Renders body content of the list control.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderPrompt | Renders the prompt text, if any.
 | saveState | Saves items into viewstate.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TBulletedList
  • TCheckBoxList
  • TDropDownList
  • TListBox
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListControlValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TListControlValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
 | MaxSelection | integer | max number of selections.
 | MinSelection | integer | min number of selections.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
 | RequiredSelections | string | Get a comma separated list of required selected values.
RP | RequiredValues | array | list of required values.
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
P | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
P | getSelection | number of selected values and its values.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListItem

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TListItem
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Attributes | TAttributeCollection | custom attributes.
 | Enabled | boolean | whether the item is enabled.
R | HasAttributes | boolean | whether the item has any custom attribute.
 | Selected | boolean | whether the item is selected.
 | Text | string | text of the item.
 | Value | string | value of the item.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getAttribute | the named attribute value, null if attribute does not exist.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasAttribute | whether the named attribute exists.
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
removeAttribute | Removes the named attribute.
setAttribute | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListItemCollection

Namespace: System.Collections
Inheritance: TComponent » TList »
TListItemCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
 | Name | Description
 | add | Appends an item at the end of the list. (inherited from TList)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clear | Removes all items in the list. (inherited from TList)
 | contains | whether the list contains the item. (inherited from TList)
 | copyFrom | Copies iterable data into the list. (inherited from TList)
 | count | Returns the number of items in the list. (inherited from TList)
 | createListItem | Creates a list item object.
P | createNewListItem | new item.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findIndexByText | Finds the lowest cardinal index of the item whose text is the one being looked for.
 | findIndexByValue | Finds the lowest cardinal index of the item whose value is the one being looked for.
 | findItemByText | Finds the item whose text is the one being looked for.
 | findItemByValue | Finds the item whose value is the one being looked for.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
 | insertAfter | Finds the base item. (inherited from TList)
 | insertAt | Inserts an item into the collection.
 | insertBefore | Finds the base item. (inherited from TList)
 | itemAt | Returns the item at the specified offset. (inherited from TList)
 | loadState | Loads state into every item in the collection.
 | mergeWith | Merges iterable data into the map. (inherited from TList)
 | offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
 | offsetGet | Returns the item at the specified offset. (inherited from TList)
 | offsetSet | Sets the item at the specified offset. (inherited from TList)
 | offsetUnset | Unsets the item at the specified offset. (inherited from TList)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes an item from the list. (inherited from TList)
 | removeAt | Removes an item at the specified position. (inherited from TList)
 | saveState | Saves state of items.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | toArray | the list of items in array. (inherited from TList)
Derived classes
  • TActiveListItemCollection
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListItemType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TListItemType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListIterator

Namespace: System.Collections
TListIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array item.
key | Returns the key of the current array item.
next | Moves the internal pointer to the next array item.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an item at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListSelectionMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TListSelectionMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLiteral

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TLiteral
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the static text of the TLiteral.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | Encode | boolean | whether the rendered text should be HTML-encoded.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the static text of the TLiteral.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the literal control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLiteralColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TLiteralColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataField | string | the field name from the data source to bind to the column.
 | DataFormatString | string | the formatting string used to control how the bound data will be displayed.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | Encode | boolean | whether the rendered text should be HTML-encoded.
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
 | Text | string | static text to be displayed in the column.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
  • TActiveLiteralColumn
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent »
TLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Categories | array | list of categories to be looked for.
 | Levels | integer | log level filter.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLevelName | level name.
P | getLevelValue | level value.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the route.
P | processLogs | Processes log messages and sends them to specific destination.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TBrowserLogRoute
  • TDbLogRoute
  • TEmailLogRoute
  • TFileLogRoute
  • TFirePhpLogRoute
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLogRouter

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TModule »
TLogRouter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ConfigFile | string | external configuration file.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
addRoute | Adds a TLogRoute instance to the log router.
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
collectLogs | Collects log messages from a logger.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes this module.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLogger

Namespace: System.Util
Inheritance: TComponent »
TLogger
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Logs | array | Retrieves log messages.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
deleteLogs | Deletes log messages from the queue.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
log | Logs a message.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMap

Namespace: System.Collections
Inheritance: TComponent »
TMap
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the map.
R | Iterator | Iterator | Returns an iterator for traversing the items in the list.
R | Keys | array | the key list.
 | ReadOnly | boolean | whether this map is read-only or not.
Events
Methods
Name | Description
add | Adds an item into the map.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the map.
contains | whether the map contains an item with the specified key.
copyFrom | Copies iterable data into the map.
count | Returns the number of items in the map.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
itemAt | Returns the item with the specified key.
mergeWith | Merges iterable data into the map.
offsetExists | Returns whether there is an element at the specified offset.
offsetGet | Returns the element at the specified offset.
offsetSet | Sets the element at the specified offset.
offsetUnset | Unsets the element at the specified offset.
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the map by its key.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array.
Derived classes
  • TAttributeCollection
  • TPriorityMap
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMapCollectionDiff

Namespace: System.Web.UI.ActiveControls
Inheritance: TViewStateDiff »
TMapCollectionDiff
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
getDifference | updates to the attributes collection.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMapIterator

Namespace: System.Collections
TMapIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array element.
key | Returns the key of the current array element.
next | Moves the internal pointer to the next array element.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an element at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMappedStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent »
TMappedStatement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TPreparedCommand | command to prepare SQL statements.
R | ID | string | Name used to identify the TMappedStatement amongst the others.
R | Manager | TSqlMapper | The SqlMap used by this MappedStatement.
R | SqlString | {unknown} | .
R | Statement | TSqlMapStatement | The SQL statment used by this MappedStatement.
Events
Name | Description
OnExecuteQuery | Raise the execute query event.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addResultMapGroupBy | ResultMap with GroupBy property.
P | applyResultMap | Apply result mapping.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | enquequePostSelect | Add nested result property to post select queue.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | executeInsert | Execute an insert statement.
P | executePostSelect | Process 'select' result properties .
 | executeQueryForList | Executes the SQL and retuns a List of result objects.
 | executeQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter.
 | executeQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter.
P | executeSQLQueryLimit | Execute SQL Query with limits.
P | executeSelectKey | Execute the select key statement, used to obtain last insert ID.
 | executeUpdate | Execute an update statement.
P | fillArrayResultMap | Retrieve the result map as an array.
P | fillDefaultResultMap | Fill the result map using default settings.
P | fillPropertyWithResultMap | Fills the property with result mapping results.
P | fillResultArrayList | Apply the result to a TList or an array.
P | fillResultClass | Fill the result using ResultClass, will creates new result object if required.
P | fillResultMap | Fills the result object according to result mappings.
P | fillResultObjectProperty | Apply the result to an object.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPostGeneratedSelectKey | Gets the inserted row ID after executing an insert statement.
P | getPostSelectKeys | Finds in the post select property the SQL statement primary selection keys.
P | getPreGeneratedSelectKey | Gets the insert generated ID before executing an insert statement.
P | getResultMapGroupKey | Gets the result 'group by' groupping key for each row.
P | getScalarResult | Converts the first array value to scalar value of given type.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initialGroupByResults | Empty the group by results cache.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | raiseRowDelegate | Raises delegate handler.
 | runQueryForList | Executes the SQL and retuns a List of result objects.
 | runQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter.
 | runQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter.
P | setObjectProperty | Set a property of the result object with appropriate value.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TInsertMappedStatement
  • TSelectMappedStatement
  • TUpdateMappedStatement
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMarkdown

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextProcessor » TTextHighlighter »
TMarkdown
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableCopyCode | boolean | true will show "Copy Code" link. (inherited from TTextHighlighter)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
RP | HeaderTemplate | string | header template with "Copy code" link. (inherited from TTextHighlighter)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | Language | string | language whose syntax is to be used for highlighting. (inherited from TTextHighlighter)
 | LineNumberStyle | TTextHighlighterLineNumberStyle | style of row number, Table by default. (inherited from TTextHighlighter)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowLineNumbers | boolean | whether to show line numbers in the highlighted result. (inherited from TTextHighlighter)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TabSize | integer | tab size. (inherited from TTextHighlighter)
RP | TagName | string | tag name of the panel. (inherited from TTextHighlighter)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | text to be processed. (inherited from TTextProcessor)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers css style for the highlighted result. (inherited from TTextHighlighter)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | HTML-decodes static text. (inherited from TTextProcessor)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | highlightCode | Highlights source code using TTextHighlighter .
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | processText | Processes a text string.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
P | registerStyleSheet | Registers the stylesheet for presentation. (inherited from TTextHighlighter)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | . (inherited from TTextHighlighter)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body content. (inherited from TTextProcessor)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMemCache

Namespace: System.Caching
Inheritance: TComponent » TApplicationComponent » TModule » TCache »
TMemCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Host | string | host name of the memcache server.
 | ID | string | id of this module. (inherited from TModule)
 | KeyPrefix | string | a unique prefix for the keys of cached values. (inherited from TCache)
 | MinSavings | float | minimum amount of savings to actually store the value compressed.
 | Port | integer | port number of the memcache server.
 | PrimaryCache | boolean | whether this cache module is used as primary/system cache. (inherited from TCache)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | Threshold | integer | minimum value length before attempting to compress.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | add | Stores a value identified by a key into cache if the cache does not contain this key. (inherited from TCache)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addValue | Stores a value identified by a key into cache if the cache does not contain this key.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes a value with the specified key from cache . (inherited from TCache)
P | deleteValue | Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Deletes all values from cache.
P | generateUniqueKey | a key generated from the provided key which ensures the uniqueness across applications. (inherited from TCache)
 | get | Retrieves a value from cache with a specified key. (inherited from TCache)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValue | Retrieves a value from cache with a specified key.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | offsetExists | Returns whether there is a cache entry with a specified key. (inherited from TCache)
 | offsetGet | Retrieves the value from cache with a specified key. (inherited from TCache)
 | offsetSet | Stores the value identified by a key into cache. (inherited from TCache)
 | offsetUnset | Deletes the value with the specified key from cache This method is required by the interface ArrayAccess. (inherited from TCache)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | set | Stores a value identified by a key into cache. (inherited from TCache)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setValue | Stores a value identified by a key in cache.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMetaTag

Namespace: System.Web.UI
Inheritance: TComponent »
TMetaTag
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Content | string | content attribute of the meta tag.
HttpEquiv | string | http-equiv attribute of the meta tag.
ID | string | id of the meta tag.
Name | string | name attribute of the meta tag.
Scheme | string | scheme attribute of the meta tag.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
render | Renders the meta tag.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMetaTagCollection

Namespace: System.Web.UI
Inheritance: TComponent » TList »
TMetaTagCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
findIndexByID | Finds the lowest cardinal index of the meta tag whose id is the one being looked for.
findMetaTagByID | Finds the item whose value is the one being looked for.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TModule

Namespace: System
Inheritance: TComponent » TApplicationComponent »
TModule
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the module.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TApplicationStatePersister
  • TAssetManager
  • TAuthManager
  • TCache
  • TDataSourceConfig
  • TDbUserManager
  • TErrorHandler
  • TGlobalization
  • THttpResponse
  • TLogRouter
  • TParameterModule
  • TRpcApiProvider
  • TRpcServer
  • TSecurityManager
  • TTemplateManager
  • TThemeManager
  • TUrlManager
  • TUserManager
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMssqlCommandBuilder

Namespace: System.Data.Common
Inheritance: TComponent » TDbCommandBuilder »
TMssqlCommandBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | database connection. (inherited from TDbCommandBuilder)
R | LastInsertID | integer | Overrides parent implementation.
R | SelectFieldList | array | Different behavior depends on type of passed data string usage without modification null will be expanded to full list of quoted table column names (quoting depends on database) array - Column names will be quoted if used as key or value of array array('col1', 'col2', 'col2') // SELECT `col1`, `col2`, `col3` FROM. (inherited from TDbCommandBuilder)
 | TableInfo | {unknown} | . (inherited from TDbCommandBuilder)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyCriterias | . (inherited from TDbCommandBuilder)
 | applyLimitOffset | Overrides parent implementation.
 | applyOrdering | modified SQL applied with ORDER BY. (inherited from TDbCommandBuilder)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | bindArrayValues | . (inherited from TDbCommandBuilder)
 | bindColumnValues | Bind the name-value pairs of $values where the array keys correspond to column names. (inherited from TDbCommandBuilder)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommand | corresponding database command. (inherited from TDbCommandBuilder)
 | createCountCommand | Creates a count(*) command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createDeleteCommand | Creates a delete command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createFindCommand | Appends the $where condition to the string "SELECT * FROM tableName WHERE ". (inherited from TDbCommandBuilder)
 | createInsertCommand | Creates an insert command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createUpdateCommand | Creates an update command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | findOrdering | Base on simplified syntax http://msdn2.
P | getColumnBindings | Create a name-value or position-value if $position=true binding strings. (inherited from TDbCommandBuilder)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertFieldBindings | Returns a list of insert field name and a list of binding names. (inherited from TDbCommandBuilder)
S | getPdoType | PDO parameter types. (inherited from TDbCommandBuilder)
P | getSearchCondition | search condition for all words in one column. (inherited from TDbCommandBuilder)
 | getSearchExpression | Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords). (inherited from TDbCommandBuilder)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
P | hasIntegerKey | true if any array key is an integer. (inherited from TDbCommandBuilder)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | joinOrdering | concat the orderings.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | reverseDirection | ordering with reversed direction.
P | rewriteLimitOffsetSql | Rewrite sql to apply $limit > and $offset > 0 for MSSQL database.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMssqlMetaData

Namespace: System.Data.Common.Mssql
Inheritance: TComponent » TDbMetaData »
TMssqlMetaData
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection. (inherited from TDbMetaData)
R | TableInfo | TDbTableInfo | Obtains table meta data information for the current connection and given table name. (inherited from TDbMetaData)
RP | TableInfoClass | string | TDbTableInfo class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | Creates a command builder for a given table name. (inherited from TDbMetaData)
P | createNewTableInfo | .
P | createTableInfo | Get the column definitions for given table.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getCatalogSchemaTableName | tuple($catalogName,$schemaName,$tableName).
P | getConstraintKeys | Gets the primary and foreign key column details for the given table.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getForeignConstraints | Gets foreign relationship constraint keys and table name .
S | getInstance | Obtain database specific TDbMetaData class using the driver name of the database connection. (inherited from TDbMetaData)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isForeignKeyColumn | true if column is a foreign key.
P | processColumn | .
 | quoteColumnAlias | Quotes a column alias for use in a query.
 | quoteColumnName | Quotes a column name for use in a query.
 | quoteTableName | Quotes a table name for use in a query.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMssqlScaffoldInput

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
Inheritance: TScaffoldInputBase » TScaffoldInputCommon »
TMssqlScaffoldInput
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createBooleanControl | . (inherited from TScaffoldInputCommon)
P | createControl | .
P | createControlLabel | . (inherited from TScaffoldInputBase)
P | createDateControl | . (inherited from TScaffoldInputCommon)
P | createDateTimeControl | . (inherited from TScaffoldInputCommon)
P | createDefaultControl | . (inherited from TScaffoldInputCommon)
P | createEnumControl | . (inherited from TScaffoldInputCommon)
P | createFloatControl | . (inherited from TScaffoldInputCommon)
S | createInputBuilder | . (inherited from TScaffoldInputBase)
P | createIntegerControl | . (inherited from TScaffoldInputCommon)
P | createMultiLineControl | . (inherited from TScaffoldInputCommon)
P | createRangeValidator | . (inherited from TScaffoldInputCommon)
P | createRequiredValidator | . (inherited from TScaffoldInputCommon)
 | createScaffoldInput | . (inherited from TScaffoldInputBase)
P | createSetControl | . (inherited from TScaffoldInputCommon)
P | createTimeControl | . (inherited from TScaffoldInputCommon)
P | createTypeValidator | . (inherited from TScaffoldInputCommon)
P | createYearControl | . (inherited from TScaffoldInputCommon)
P | getControlValue | .
P | getDateTimeValue | . (inherited from TScaffoldInputCommon)
P | getDefaultControlValue | . (inherited from TScaffoldInputCommon)
P | getEnumValue | . (inherited from TScaffoldInputCommon)
P | getIsEnabled | . (inherited from TScaffoldInputBase)
P | getMatchingIndices | . (inherited from TScaffoldInputCommon)
P | getParent | . (inherited from TScaffoldInputBase)
P | getRecordPropertyValue | . (inherited from TScaffoldInputBase)
P | getSetValue | . (inherited from TScaffoldInputCommon)
P | getTimeValue | . (inherited from TScaffoldInputCommon)
 | loadScaffoldInput | . (inherited from TScaffoldInputBase)
P | setDefaultProperty | . (inherited from TScaffoldInputCommon)
P | setNotNullProperty | . (inherited from TScaffoldInputCommon)
P | setRecordPropertyValue | . (inherited from TScaffoldInputBase)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMssqlTableColumn

Namespace: System.Data.Common.Mssql
Inheritance: TComponent » TDbTableColumn »
TMssqlTableColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowNull | boolean | specifies whether value Null is allowed, default is false. (inherited from TDbTableColumn)
R | AutoIncrement | boolean | true if the column has identity (auto-increment).
R | ColumnId | string | name of the column with quoted identifier. (inherited from TDbTableColumn)
R | ColumnIndex | integer | zero-based ordinal position of the column in the table. (inherited from TDbTableColumn)
R | ColumnName | string | name of the column in the table (identifier quoted). (inherited from TDbTableColumn)
R | ColumnSize | string | size of the column. (inherited from TDbTableColumn)
R | DbType | string | column type. (inherited from TDbTableColumn)
R | DefaultValue | mixed | default column value if column value was null. (inherited from TDbTableColumn)
R | IsExcluded | boolean | true if db type is 'timestamp'.
R | IsForeignKey | boolean | whether this column is a foreign key, default is false. (inherited from TDbTableColumn)
R | IsPrimaryKey | boolean | whether this column is a primary key for the table, default is false. (inherited from TDbTableColumn)
R | MaxiumNumericConstraint | {unknown} | . (inherited from TDbTableColumn)
R | NumericPrecision | string | precision of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | NumericScale | string | scale of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | PHPType | boolean | Overrides parent implementation, returns PHP type from the db type.
R | PdoType | {unknown} | . (inherited from TDbTableColumn)
R | SequenceName | {unknown} | . (inherited from TDbTableColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableColumn)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasSequence | true if auto increments.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMssqlTableInfo

Namespace: System.Data.Common.Mssql
Inheritance: TComponent » TDbTableInfo »
TMssqlTableInfo
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CatalogName | string | catalog name (database name).
R | ColumnNames | array | table column names (identifier quoted). (inherited from TDbTableInfo)
R | Columns | TMap | TDbTableColumn column meta data. (inherited from TDbTableInfo)
R | ForeignKeys | array | tuples of foreign table and column name. (inherited from TDbTableInfo)
R | IsView | boolean | whether the table is a view, default is false. (inherited from TDbTableInfo)
R | LowerCaseColumnNames | array | lowercased column key names mapped to normal column ids. (inherited from TDbTableInfo)
R | PrimaryKeys | string[] | . (inherited from TDbTableInfo)
R | SchemaName | string | name of the schema this column belongs to.
R | TableFullName | string | full name of the table, database dependent.
R | TableName | string | name of the table this column belongs to. (inherited from TDbTableInfo)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | new command builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getColumn | column information. (inherited from TDbTableInfo)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableInfo)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableInfo)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMultiView

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TMultiView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | ActiveView | TView | the currently active view, null if no active view @throws TInvalidDataValueException if the current active view index is invalid.
 | ActiveViewIndex | integer | the zero-based index of the current view in the view collection.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | Views | TViewCollection | the view collection.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnActiveViewChanged | Raises OnActiveViewChanged event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Initializes the active view if any.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | activateView | Activates the specified view.
 | addParsedObject | Processes an object that is created during parsing template.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Processes the events bubbled from child controls.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls .
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | ignoreBubbleEvents | Makes the multiview ignore all bubbled events.
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads state into the wizard.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the currently active view.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveMultiView
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMysqlCommandBuilder

Namespace: System.Data.Common
Inheritance: TComponent » TDbCommandBuilder »
TMysqlCommandBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | database connection. (inherited from TDbCommandBuilder)
R | LastInsertID | mixed | Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial. (inherited from TDbCommandBuilder)
R | SelectFieldList | array | Different behavior depends on type of passed data string usage without modification null will be expanded to full list of quoted table column names (quoting depends on database) array - Column names will be quoted if used as key or value of array array('col1', 'col2', 'col2') // SELECT `col1`, `col2`, `col3` FROM. (inherited from TDbCommandBuilder)
 | TableInfo | {unknown} | . (inherited from TDbCommandBuilder)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyCriterias | . (inherited from TDbCommandBuilder)
 | applyLimitOffset | Alters the sql to apply $limit and $offset. (inherited from TDbCommandBuilder)
 | applyOrdering | modified SQL applied with ORDER BY. (inherited from TDbCommandBuilder)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | bindArrayValues | . (inherited from TDbCommandBuilder)
 | bindColumnValues | Bind the name-value pairs of $values where the array keys correspond to column names. (inherited from TDbCommandBuilder)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommand | corresponding database command. (inherited from TDbCommandBuilder)
 | createCountCommand | Creates a count(*) command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createDeleteCommand | Creates a delete command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createFindCommand | Appends the $where condition to the string "SELECT * FROM tableName WHERE ". (inherited from TDbCommandBuilder)
 | createInsertCommand | Creates an insert command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createUpdateCommand | Creates an update command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getColumnBindings | Create a name-value or position-value if $position=true binding strings. (inherited from TDbCommandBuilder)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertFieldBindings | Returns a list of insert field name and a list of binding names. (inherited from TDbCommandBuilder)
S | getPdoType | PDO parameter types. (inherited from TDbCommandBuilder)
P | getSearchCondition | search condition for all words in one column. (inherited from TDbCommandBuilder)
 | getSearchExpression | Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords). (inherited from TDbCommandBuilder)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
P | hasIntegerKey | true if any array key is an integer. (inherited from TDbCommandBuilder)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMysqlMetaData

Namespace: System.Data.Common.Mysql
Inheritance: TComponent » TDbMetaData »
TMysqlMetaData
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection. (inherited from TDbMetaData)
RP | ServerVersion | float | server version.
R | TableInfo | TDbTableInfo | Obtains table meta data information for the current connection and given table name. (inherited from TDbMetaData)
RP | TableInfoClass | string | TDbTableInfo class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | Creates a command builder for a given table name. (inherited from TDbMetaData)
P | createNewTableInfo | .
P | createTableInfo | Get the column definitions for given table.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | findForeignConstraints | Extract foreign key constraints by extracting the contraints from SHOW CREATE TABLE result.
P | getConstraintKeys | Gets the primary and foreign key column details for the given table.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getForeignConstraints | Gets foreign relationship constraint keys and table name .
S | getInstance | Obtain database specific TDbMetaData class using the driver name of the database connection. (inherited from TDbMetaData)
P | getIsView | For MySQL version 5.
P | getSchemaTableName | tuple ($schema,$table), $schema may be null.
P | getShowCreateTable | SQL command to create the table.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isEnumSetType | true if column type if "enum" or "set".
P | isForeignKeyColumn | true if column is a foreign key.
P | isPrecisionType | true if column type if "numeric", "interval" or begins with "time".
P | isValidIdentifier | http://dev.
P | processColumn | .
 | quoteColumnAlias | Quotes a column alias for use in a query.
 | quoteColumnName | Quotes a column name for use in a query.
 | quoteTableName | Quotes a table name for use in a query.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMysqlScaffoldInput

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
Inheritance: TScaffoldInputBase » TScaffoldInputCommon »
TMysqlScaffoldInput
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createBooleanControl | . (inherited from TScaffoldInputCommon)
P | createControl | .
P | createControlLabel | . (inherited from TScaffoldInputBase)
P | createDateControl | . (inherited from TScaffoldInputCommon)
P | createDateTimeControl | . (inherited from TScaffoldInputCommon)
P | createDefaultControl | . (inherited from TScaffoldInputCommon)
P | createEnumControl | . (inherited from TScaffoldInputCommon)
P | createFloatControl | . (inherited from TScaffoldInputCommon)
S | createInputBuilder | . (inherited from TScaffoldInputBase)
P | createIntegerControl | .
P | createMultiLineControl | . (inherited from TScaffoldInputCommon)
P | createRangeValidator | . (inherited from TScaffoldInputCommon)
P | createRequiredValidator | . (inherited from TScaffoldInputCommon)
 | createScaffoldInput | . (inherited from TScaffoldInputBase)
P | createSetControl | . (inherited from TScaffoldInputCommon)
P | createTimeControl | . (inherited from TScaffoldInputCommon)
P | createTypeValidator | . (inherited from TScaffoldInputCommon)
P | createYearControl | . (inherited from TScaffoldInputCommon)
P | getControlValue | .
P | getDateTimeValue | . (inherited from TScaffoldInputCommon)
P | getDefaultControlValue | . (inherited from TScaffoldInputCommon)
P | getEnumValue | . (inherited from TScaffoldInputCommon)
P | getIntBooleanValue | .
P | getIsEnabled | . (inherited from TScaffoldInputBase)
P | getMatchingIndices | . (inherited from TScaffoldInputCommon)
P | getParent | . (inherited from TScaffoldInputBase)
P | getRecordPropertyValue | . (inherited from TScaffoldInputBase)
P | getSetValue | . (inherited from TScaffoldInputCommon)
P | getTimeValue | . (inherited from TScaffoldInputCommon)
 | loadScaffoldInput | . (inherited from TScaffoldInputBase)
P | setDefaultProperty | . (inherited from TScaffoldInputCommon)
P | setNotNullProperty | . (inherited from TScaffoldInputCommon)
P | setRecordPropertyValue | . (inherited from TScaffoldInputBase)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMysqlTableColumn

Namespace: System.Data.Common.Mysql
Inheritance: TComponent » TDbTableColumn »
TMysqlTableColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowNull | boolean | specifies whether value Null is allowed, default is false. (inherited from TDbTableColumn)
R | AutoIncrement | boolean | true if column will auto-increment when the column value is inserted as null.
R | ColumnId | string | name of the column with quoted identifier. (inherited from TDbTableColumn)
R | ColumnIndex | integer | zero-based ordinal position of the column in the table. (inherited from TDbTableColumn)
R | ColumnName | string | name of the column in the table (identifier quoted). (inherited from TDbTableColumn)
R | ColumnSize | string | size of the column. (inherited from TDbTableColumn)
R | DbType | string | column type. (inherited from TDbTableColumn)
R | DbTypeValues | {unknown} | .
R | DefaultValue | mixed | default column value if column value was null. (inherited from TDbTableColumn)
R | IsExcluded | boolean | whether this column is excluded from insert and update. (inherited from TDbTableColumn)
R | IsForeignKey | boolean | whether this column is a foreign key, default is false. (inherited from TDbTableColumn)
R | IsPrimaryKey | boolean | whether this column is a primary key for the table, default is false. (inherited from TDbTableColumn)
R | MaxiumNumericConstraint | {unknown} | . (inherited from TDbTableColumn)
R | NumericPrecision | string | precision of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | NumericScale | string | scale of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | PHPType | boolean | Overrides parent implementation, returns PHP type from the db type.
R | PdoType | {unknown} | . (inherited from TDbTableColumn)
R | SequenceName | {unknown} | . (inherited from TDbTableColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableColumn)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasSequence | true if auto increment is true.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMysqlTableInfo

Namespace: System.Data.Common.Mysql
Inheritance: TComponent » TDbTableInfo »
TMysqlTableInfo
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ColumnNames | array | table column names (identifier quoted). (inherited from TDbTableInfo)
R | Columns | TMap | TDbTableColumn column meta data. (inherited from TDbTableInfo)
R | ForeignKeys | array | tuples of foreign table and column name. (inherited from TDbTableInfo)
R | IsView | boolean | whether the table is a view, default is false. (inherited from TDbTableInfo)
R | LowerCaseColumnNames | array | lowercased column key names mapped to normal column ids. (inherited from TDbTableInfo)
R | PrimaryKeys | string[] | . (inherited from TDbTableInfo)
R | SchemaName | string | name of the schema this column belongs to.
R | TableFullName | string | full name of the table, database dependent.
R | TableName | string | name of the table this column belongs to. (inherited from TDbTableInfo)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | new command builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getColumn | column information. (inherited from TDbTableInfo)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableInfo)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableInfo)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TNotSupportedException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TNotSupportedException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TNumberFormat

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TControl » TI18NControl »
TNumberFormat
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | Charset | string | Gets the charset. (inherited from TI18NControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | Culture | string | Get the specific culture for this control. (inherited from TI18NControl)
 | Currency | string | 3 letter currency code.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Get the numberic value for this control.
 | DefaultText | string | Get the default text value for this control.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
RP | FormattedValue | string | Formats the localized number, be it currency or decimal, or percentage.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | Pattern | string | Get the number formatting pattern.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Type | string | Get the formatting type for this control.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Value | string | Get the numberic value for this control.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | .
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TObjectProxy

Namespace: System.Data.SqlMap
TObjectProxy
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOracleCommandBuilder

Namespace: System.Data.Common
Inheritance: TComponent » TDbCommandBuilder »
TOracleCommandBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | database connection. (inherited from TDbCommandBuilder)
R | LastInsertID | mixed | Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial. (inherited from TDbCommandBuilder)
R | SelectFieldList | array | Different behavior depends on type of passed data string usage without modification null will be expanded to full list of quoted table column names (quoting depends on database) array - Column names will be quoted if used as key or value of array array('col1', 'col2', 'col2') // SELECT `col1`, `col2`, `col3` FROM. (inherited from TDbCommandBuilder)
 | TableInfo | {unknown} | . (inherited from TDbCommandBuilder)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyCriterias | . (inherited from TDbCommandBuilder)
 | applyLimitOffset | Overrides parent implementation to use Oracle way of get paginated RecordSet instead of using LIMIT sql clause.
 | applyOrdering | modified SQL applied with ORDER BY. (inherited from TDbCommandBuilder)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | bindArrayValues | . (inherited from TDbCommandBuilder)
 | bindColumnValues | Bind the name-value pairs of $values where the array keys correspond to column names. (inherited from TDbCommandBuilder)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommand | corresponding database command. (inherited from TDbCommandBuilder)
 | createCountCommand | Creates a count(*) command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createDeleteCommand | Creates a delete command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createFindCommand | Appends the $where condition to the string "SELECT * FROM tableName WHERE ". (inherited from TDbCommandBuilder)
 | createInsertCommand | Creates an insert command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createUpdateCommand | Creates an update command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getColumnBindings | Create a name-value or position-value if $position=true binding strings. (inherited from TDbCommandBuilder)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertFieldBindings | Returns a list of insert field name and a list of binding names. (inherited from TDbCommandBuilder)
S | getPdoType | PDO parameter types. (inherited from TDbCommandBuilder)
P | getSearchCondition | search condition for all words in one column. (inherited from TDbCommandBuilder)
 | getSearchExpression | Overrides parent implementation.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
P | hasIntegerKey | true if any array key is an integer. (inherited from TDbCommandBuilder)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isSearchableColumn | true if column can be used for LIKE searching.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOracleMetaData

Namespace: System.Data.Common.Oracle
Inheritance: TComponent » TDbMetaData »
TOracleMetaData
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection. (inherited from TDbMetaData)
 | DefaultSchema | string | default schema.
R | TableInfo | TDbTableInfo | Obtains table meta data information for the current connection and given table name. (inherited from TDbMetaData)
RP | TableInfoClass | string | TDbTableInfo class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | assertIdentifier | a valid identifier.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | Creates a command builder for a given table name. (inherited from TDbMetaData)
P | createNewTableInfo | .
P | createTableInfo | Get the column definitions for given table.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getConstraintKeys | Gets the primary and foreign key column details for the given table.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getForeignKeys | Gets foreign relationship constraint keys and table name .
S | getInstance | Obtain database specific TDbMetaData class using the driver name of the database connection. (inherited from TDbMetaData)
P | getIsView | true if the table is a view.
P | getPrimaryKeys | Gets the primary key field names .
P | getSchemaTableName | tuple as ($schemaName,$tableName).
P | getSequenceName | serial name if found, null otherwise.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isForeignKeyColumn | true if column is a foreign key.
P | isPrecisionType | true if column type if "numeric", "interval" or begins with "time".
P | processColumn | .
 | quoteColumnAlias | Quotes a column alias for use in a query. (inherited from TDbMetaData)
 | quoteColumnName | Quotes a column name for use in a query. (inherited from TDbMetaData)
 | quoteTableName | Quotes a table name for use in a query. (inherited from TDbMetaData)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOracleTableColumn

Namespace: System.Data.Common.Oracle
Inheritance: TComponent » TDbTableColumn »
TOracleTableColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowNull | boolean | specifies whether value Null is allowed, default is false. (inherited from TDbTableColumn)
R | ColumnId | string | name of the column with quoted identifier. (inherited from TDbTableColumn)
R | ColumnIndex | integer | zero-based ordinal position of the column in the table. (inherited from TDbTableColumn)
R | ColumnName | string | name of the column in the table (identifier quoted). (inherited from TDbTableColumn)
R | ColumnSize | string | size of the column. (inherited from TDbTableColumn)
R | DbType | string | column type. (inherited from TDbTableColumn)
R | DefaultValue | mixed | default column value if column value was null. (inherited from TDbTableColumn)
R | IsExcluded | boolean | whether this column is excluded from insert and update. (inherited from TDbTableColumn)
R | IsForeignKey | boolean | whether this column is a foreign key, default is false. (inherited from TDbTableColumn)
R | IsPrimaryKey | boolean | whether this column is a primary key for the table, default is false. (inherited from TDbTableColumn)
R | MaxiumNumericConstraint | {unknown} | . (inherited from TDbTableColumn)
R | NumericPrecision | string | precision of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | NumericScale | string | scale of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | PHPType | boolean | Overrides parent implementation, returns PHP type from the db type.
R | PdoType | {unknown} | . (inherited from TDbTableColumn)
R | SequenceName | {unknown} | . (inherited from TDbTableColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableColumn)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasSequence | whether the column is a sequence. (inherited from TDbTableColumn)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOracleTableInfo

Namespace: System.Data.Common
Inheritance: TComponent »
TOracleTableInfo
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ColumnNames | array | table column names (identifier quoted).
R | Columns | TMap | TDbTableColumn column meta data.
R | ForeignKeys | array | tuples of foreign table and column name.
R | IsView | boolean | whether the table is a view, default is false.
R | LowerCaseColumnNames | array | lowercased column key names mapped to normal column ids.
R | PrimaryKeys | string[] | .
R | TableFullName | string | full name of the table, database dependent.
R | TableName | string | name of the table this column belongs to.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | new command builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getColumn | column information.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getInfo | information array value.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOutputCache

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TOutputCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | {unknown} | Returns a value indicating whether body contents are allowed for this control.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
RP | BaseCacheKey | string | basic cache key without variations.
RP | CacheDependency | ICacheDependency | Returns the dependency of the data to be cached.
R | CacheKey | {unknown} | .
 | CacheModuleID | string | the ID of the cache module.
R | CacheTime | integer | the timestamp of the cached content.
 | CachingPostBack | boolean | whether cached output will be used on postback requests.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ContentCached | boolean | whether content enclosed is cached or not.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Duration | integer | number of seconds that the data can remain in cache.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VaryByParam | string | a semicolon-separated list of strings used to vary the output cache.
 | VaryBySession | boolean | whether the content being cached should be differentiated according to user sessions.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCalculateKey | This event is raised when the output cache is calculating cache key.
OnCheckDependency | This event is raised when the output cache is checking cache dependency.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | calculateCacheKey | Calculates the cache key.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls.
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls.
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerAction | Registers an action associated with the content being cached.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the output cache control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection.
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
 | setCacheKeyPrefix | Sets the prefix of the cache key.
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOutputCacheCalculateKeyEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TOutputCacheCalculateKeyEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
CacheKey | string | cache key to be appended to the default calculation scheme.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOutputCacheCheckDependencyEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TOutputCacheCheckDependencyEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
CacheTime | integer | the timestamp of the cached result.
IsValid | boolean | whether the dependency remains valid.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOutputCacheTextWriterMulti

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TTextWriter »
TOutputCacheTextWriterMulti
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flush | .
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
write | .
writeLine | Writers a string and terminates it with a newline. (inherited from TTextWriter)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPage

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl »
TPage
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
R | CachingStack | TStack | stack of TOutputCache objects.
 | CallbackClient | TCallbackClientScript | Gets the callback client script handler that allows javascript functions to be executed during the callback response.
 | CallbackEventParameter | string | Callback parameter is decoded assuming JSON encoding.
 | CallbackEventTarget | TControl | the control responsible for the current callback event, null if nonexistent.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientScript | TClientScriptManager | client script manager.
 | ClientState | string | Returns the state to be stored on the client side.
 | ClientSupportsJavaScript | boolean | whether client supports javascript.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableStateCompression | boolean | whether page state should be compressed.
 | EnableStateEncryption | boolean | whether page state should be encrypted.
 | EnableStateValidation | boolean | whether page state should be HMAC validated.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | Form | TForm | the form on the page.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | Head | THead | page head, null if not available.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | InFormRender | boolean | Whether form rendering is in progress.
R | IsCallback | boolean | whether this is a callback request.
R | IsLoadingPostData | boolean | true if loading post data.
R | IsPostBack | boolean | whether the current page request is a postback.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
R | IsValid | boolean | Returns whether user input is valid or not.
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
 | PagePath | string | the requested page path for this page.
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PostBackEventParameter | string | postback event parameter.
 | PostBackEventTarget | TControl | the control responsible for the current postback event, null if nonexistent.
R | PostDataLoaders | array | Get a list of IDs of controls that are enabled and require post data.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | RequestClientState | string | the state postback from client side.
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
R | StatePersister | IPageStatePersister | page state persister.
 | StatePersisterClass | string | class name of the page state persister.
 | StyleSheetTheme | TTheme | the stylesheet theme used for the page.
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
 | Theme | TTheme | the theme used for the page.
 | Title | string | page title.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | Validators | TList | Returns a list of registered validators.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnInitComplete | Raises OnInitComplete event.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnLoadComplete | Raises OnLoadComplete event.
OnPreInit | Raises OnPreInit event.
OnPreLoad | Raises OnPreLoad event.
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnPreRenderComplete | Raises OnPreRenderComplete event.
OnSaveStateComplete | Raises OnSaveStateComplete event.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyControlSkin | Applies a skin in the current theme to a control.
 | applyControlStyleSheet | Applies a stylesheet skin in the current theme to a control.
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | beginFormRender | .
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
SP | decodeUTF8 | .
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | endFormRender | .
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | ensureRenderInForm | Ensures the control is rendered within a form.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | flushWriter | Flushes output.
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | isSystemPostField | whether the specified field is a system field in postback data.
P | loadPageState | Loads page state from persistent storage.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
P | processCallbackRequest | Sets Adapter to TActivePageAdapter and calls apter to process the callback request.
P | processNormalRequest | .
P | processPostBackRequest | .
P | processPostData | Processes post data.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
P | raiseChangedEvents | Raises OnPostDataChangedEvent for controls whose data have been changed due to the postback.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | raisePostBackEvent | Raises PostBack event.
 | registerCachingAction | Registers an action associated with the content being cached.
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | registerPostDataLoader | Register post data loaders for Callback to collect post data.
 | registerRequiresPostData | Registers a control for loading post data in the next postback.
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | run | Runs through the page lifecycles.
P | savePageState | Saves page state from persistent storage.
 | saveState | This method is invoked when control state is to be saved.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setFocus | Sets input focus on a control after the page is rendered to users.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
 | validate | Performs input validation.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPageConfiguration

Namespace: System.Web.Services
Inheritance: TComponent »
TPageConfiguration
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ApplicationConfigurations | array | list of application configurations specified along page path.
R | ExternalConfigurations | array | list of external configuration files.
R | Properties | array | Returns list of page initial property values.
R | Rules | TAuthorizationRuleCollection | Returns list of authorization rules.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
loadApplicationConfigurationFromPhp | .
loadApplicationConfigurationFromXml | Loads the configuration specific for application part .
loadFromFile | Loads a specific config file.
loadFromFiles | Loads configuration for a page specified in a path format.
loadFromPhp | .
loadFromXml | Loads a page configuration.
loadPageConfigurationFromPhp | .
loadPageConfigurationFromXml | Loads the configuration specific for page service.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPageService

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent » TService »
TPageService
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | BasePageClass | string | base page class name in namespace format.
 | BasePath | string | the root directory for storing pages.
 | ClientScriptManagerClass | string | clientscript manager class in namespace format.
 | DefaultPage | string | default page path to be served if no explicit page is request.
R | DefaultPageUrl | string | the URL for the default page.
 | Enabled | boolean | whether the service is enabled. (inherited from TService)
 | ID | string | id of this service. (inherited from TService)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | RequestedPage | TPage | the requested page.
R | RequestedPagePath | string | the requested page path.
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | TemplateManager | TTemplateManager | template manager.
 | ThemeManager | TThemeManager | theme manager.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | applyConfiguration | Applies a page configuration.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | constructUrl | Constructs a URL with specified page path and GET parameters.
P | createPage | Creates a page instance based on requested page path.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineRequestedPagePath | Determines the requested page path.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the service.
P | initPageContext | Initializes page context.
P | loadPageConfig | Collects configuration for a page.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | run | Runs the service.
P | runPage | Executes a page.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPageStateFormatter

Namespace: System.Web.UI
TPageStateFormatter
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | serialize | serialized data.
S | unserialize | unserialized state data, null if data is corrupted.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPageStatePersister

Namespace: System.Web.UI
Inheritance: TComponent »
TPageStatePersister
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Page | TPage | the page that this persister works for.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
load | Loads page state from hidden fields.
raiseEvent | Raises an event. (inherited from TComponent)
save | Saves state in hidden fields.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagedDataSource

Namespace: System.Collections
Inheritance: TComponent »
TPagedDataSource
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AllowCustomPaging | boolean | whether to allow custom paging.
 | AllowPaging | boolean | whether to allow paging.
R | Count | integer | number of items in current page.
 | CurrentPageIndex | integer | current page index.
 | DataSource | mixed | original data source.
R | DataSourceCount | integer | number of items in data source, if available.
R | FirstIndexInPage | integer | the index of the item in data source, where the item is the first in current page.
R | IsFirstPage | boolean | whether the current page is the first page Defaults to false.
R | IsLastPage | boolean | whether the current page is the last page.
R | Iterator | Iterator | iterator.
R | PageCount | integer | number of pages.
 | PageSize | integer | number of items in each page.
 | VirtualItemCount | integer | user-assigned number of items in data source Defaults to 0.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
count | Returns the number of items in the current page.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagedList

Namespace: System.Collections
Inheritance: TComponent » TList »
TPagedList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in current page.
 | CurrentPageIndex | integer | current page index.
 | CustomPaging | boolean | whether to use custom paging.
R | IsFirstPage | boolean | whether the current page is the first page.
R | IsLastPage | boolean | whether the current page is the last page.
R | Iterator | Iterator | iterator.
R | PageCount | integer | number of pages, -1 if under custom paging mode and VirtualCount is not set.
 | PageSize | integer | number of items in each page.
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
 | VirtualCount | integer | user-assigned number of items in data source.
Events
Name | Description
OnFetchData | Raises OnFetchData event.
OnPageIndexChanged | Raises OnPageIndexChanged event.
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
gotoPage | Changes to a page with the specified page index.
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found.
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position. (inherited from TList)
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset.
mergeWith | Merges iterable data into the map. (inherited from TList)
nextPage | Switches to the next page.
offsetExists | Returns whether there is an item at the specified offset.
offsetGet | Returns the item at the specified offset.
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
previousPage | Switches to the previous page.
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array.
Derived classes
  • TSqlMapPagedList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagedListFetchDataEventParameter

Namespace: System.Collections
Inheritance: TComponent » TEventParameter »
TPagedListFetchDataEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Data | mixed | new page data.
R | Limit | integer | number of items in the new page.
R | NewPageIndex | integer | the zero-based index of the new page.
R | Offset | integer | offset of the first item in the new page.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagedListIterator

Namespace: System.Collections
TPagedListIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array item.
key | Returns the key of the current array item.
next | Moves the internal pointer to the next array item.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an item at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagedListPageChangedEventParameter

Namespace: System.Collections
Inheritance: TComponent » TEventParameter »
TPagedListPageChangedEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | OldPageIndex | integer | the index of the page before the list changed to the new page.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagedMapIterator

Namespace: System.Collections
TPagedMapIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array item.
key | Returns the key of the current array item.
next | Moves the internal pointer to the next array item.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an item at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPager

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TPager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | ButtonType | TPagerButtonType | the type of command button for paging.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToPaginate | string | the ID path of the control whose content would be paginated.
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | FirstPageImageUrl | string | the image URL for the first page button.
 | FirstPageText | string | text for the first page button.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsFirstPage | boolean | whether the current page is the first page Defaults to false.
R | IsLastPage | boolean | whether the current page is the last page.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | LastPageImageUrl | string | the image URL for the last page button.
 | LastPageText | string | text for the last page button.
 | Mode | TPagerMode | pager mode.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NextPageImageUrl | string | the image URL for the next page button.
 | NextPageText | string | text for the next page button.
 | NumericPageImageUrl | string | the image URL for the numeric page buttons.
 | Page | TPage | the page that contains this control. (inherited from TControl)
 | PageButtonCount | integer | maximum number of pager buttons to be displayed.
 | PageCount | integer | number of pages of data items available.
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PrevPageImageUrl | string | the image URL for the previous page button.
 | PrevPageText | string | text for the previous page button.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPageIndexChanged | This event is raised when page index is changed due to a page button click.
OnPreRender | Performs databinding to populate data items from data source.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Processes a bubbled event.
P | buildListPager | Builds a dropdown list pager.
P | buildNextPrevPager | Builds a next-prev pager.
P | buildNumericPager | Builds a numeric pager.
P | buildPager | Builds the pager content based on the pager mode.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createPagerButton | Creates a pager button.
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPageImageUrl | .
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | listIndexChanged | Event handler to the OnSelectedIndexChanged event of the dropdown list.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Restores the pager state.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActivePager
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagerButtonType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TPagerButtonType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagerMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TPagerMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagerPageChangedEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TPagerPageChangedEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandSource | TControl | the control originally raises the OnCommand event.
R | NewPageIndex | integer | new page index.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPanel

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TPanel
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the panel component.
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | DefaultButton | string | the ID path to the default button.
 | Direction | string | alignment of the content in the panel.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GroupingText | string | the legend text when the panel is used as a fieldset.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the panel, defaults to 'NotSet'.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScrollBars | string | the visibility and position of scroll bars in a panel control, defaults to None.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the panel.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the content wraps within the panel.
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | .
 | renderBeginTag | Renders the openning tag for the control (including attributes) .
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control .
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActivePanel
  • TDataGridPager
  • TDraggable
  • TDropContainer
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPanelStyle

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TStyle »
TPanelStyle
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | BackColor | string | the background color of the control. (inherited from TStyle)
 | BackImageUrl | string | the URL of the background image for the panel component.
 | BorderColor | string | the border color of the control. (inherited from TStyle)
 | BorderStyle | string | the border style of the control. (inherited from TStyle)
 | BorderWidth | string | the border width of the control. (inherited from TStyle)
 | CssClass | string | the CSS class of the control. (inherited from TStyle)
 | CustomStyle | string | the custom style of the control. (inherited from TStyle)
 | Direction | TContentDirection | alignment of the content in the panel.
 | DisplayStyle | TDisplayStyle | display style. (inherited from TStyle)
R | Font | TFont | the font of the control. (inherited from TStyle)
 | ForeColor | string | the foreground color of the control. (inherited from TStyle)
 | Height | string | the height of the control. (inherited from TStyle)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the contents within the panel, defaults to THorizontalAlign::NotSet.
 | ScrollBars | TScrollBars | the visibility and position of scroll bars in a panel control, defaults to TScrollBars::None.
R | StyleFields | array | list of style fields. (inherited from TStyle)
 | Width | string | the width of the control. (inherited from TStyle)
 | Wrap | boolean | whether the content wraps within the panel.
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clearStyleField | Clears a single style field value; . (inherited from TStyle)
copyFrom | Copies the fields in a new style to this style.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getStyleField | a single style field value set via setStyleField. (inherited from TStyle)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasCssClass | true if CSS is set or empty. (inherited from TStyle)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasFont | true if font is set. (inherited from TStyle)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
hasStyleField | whether a style field has been defined by setStyleField. (inherited from TStyle)
mergeWith | Merges the style with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Sets the style attributes to default values.
setStyleField | Sets a single style field value. (inherited from TStyle)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TDataGridPagerStyle
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TParameterMap

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TParameterMap
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Extends | string | name of another upon which to base this TParameterMap.
 | ID | string | a unique identifier for the .
R | Properties | TParameterProperty[] | .
R | PropertyNames | array | list of property names.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | addProperty | .
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createTypeHandler | Create type handler from setType() or setTypeHandler.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getObjectValue | property value.
 | getProperty | parameter property.
 | getPropertyValue | Get the value of a property from the the parameter object.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | insertProperty | .
P | nullifyDefaultValue | When the actual value matches the setNullValue(), set the current value to null.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TParameterModule

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TModule »
TParameterModule
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
 | ParameterFile | string | the parameter file path.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the module by loading parameters.
P | loadParameters | Loads parameters into application.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TParameterProperty

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TParameterProperty
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Column | string | name of a parameter to be used in the SQL statement.
DbType | string | the database column type of the parameter to be set by this property.
NullValue | mixed | null value replacement.
Property | string | name of a property of the parameter object.
Type | string | type of the parameter's property.
TypeHandler | string | class name of a custom type handler.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPgsqlCommandBuilder

Namespace: System.Data.Common
Inheritance: TComponent » TDbCommandBuilder »
TPgsqlCommandBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | database connection. (inherited from TDbCommandBuilder)
R | LastInsertID | mixed | Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial. (inherited from TDbCommandBuilder)
R | SelectFieldList | array | Different behavior depends on type of passed data string usage without modification null will be expanded to full list of quoted table column names (quoting depends on database) array - Column names will be quoted if used as key or value of array array('col1', 'col2', 'col2') // SELECT `col1`, `col2`, `col3` FROM. (inherited from TDbCommandBuilder)
 | TableInfo | {unknown} | . (inherited from TDbCommandBuilder)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyCriterias | . (inherited from TDbCommandBuilder)
 | applyLimitOffset | Alters the sql to apply $limit and $offset. (inherited from TDbCommandBuilder)
 | applyOrdering | modified SQL applied with ORDER BY. (inherited from TDbCommandBuilder)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | bindArrayValues | . (inherited from TDbCommandBuilder)
 | bindColumnValues | Bind the name-value pairs of $values where the array keys correspond to column names. (inherited from TDbCommandBuilder)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommand | corresponding database command. (inherited from TDbCommandBuilder)
 | createCountCommand | Creates a count(*) command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createDeleteCommand | Creates a delete command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createFindCommand | Appends the $where condition to the string "SELECT * FROM tableName WHERE ". (inherited from TDbCommandBuilder)
 | createInsertCommand | Creates an insert command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createUpdateCommand | Creates an update command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getColumnBindings | Create a name-value or position-value if $position=true binding strings. (inherited from TDbCommandBuilder)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertFieldBindings | Returns a list of insert field name and a list of binding names. (inherited from TDbCommandBuilder)
S | getPdoType | PDO parameter types. (inherited from TDbCommandBuilder)
P | getSearchCondition | Overrides parent implementation to use PostgreSQL's ILIKE instead of LIKE (case-sensitive).
 | getSearchExpression | Overrides parent implementation.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
P | hasIntegerKey | true if any array key is an integer. (inherited from TDbCommandBuilder)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isSearchableColumn | true if column can be used for LIKE searching.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPgsqlMetaData

Namespace: System.Data.Common.Pgsql
Inheritance: TComponent » TDbMetaData »
TPgsqlMetaData
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection. (inherited from TDbMetaData)
 | DefaultSchema | string | default schema.
R | TableInfo | TDbTableInfo | Obtains table meta data information for the current connection and given table name. (inherited from TDbMetaData)
RP | TableInfoClass | string | TDbTableInfo class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | assertIdentifier | a valid identifier.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | Creates a command builder for a given table name. (inherited from TDbMetaData)
P | createNewTableInfo | .
P | createTableInfo | Get the column definitions for given table.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getConstraintKeys | Gets the primary and foreign key column details for the given table.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getForeignKeys | Gets foreign relationship constraint keys and table name .
S | getInstance | Obtain database specific TDbMetaData class using the driver name of the database connection. (inherited from TDbMetaData)
P | getIsView | true if the table is a view.
P | getPrimaryKeys | Gets the primary key field names .
P | getSchemaTableName | tuple as ($schemaName,$tableName).
P | getSequenceName | serial name if found, null otherwise.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isForeignKeyColumn | true if column is a foreign key.
P | isPrecisionType | true if column type if "numeric", "interval" or begins with "time".
P | processColumn | .
 | quoteColumnAlias | Quotes a column alias for use in a query.
 | quoteColumnName | Quotes a column name for use in a query.
 | quoteTableName | Quotes a table name for use in a query.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPgsqlScaffoldInput

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
Inheritance: TScaffoldInputBase » TScaffoldInputCommon »
TPgsqlScaffoldInput
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createBooleanControl | . (inherited from TScaffoldInputCommon)
P | createControl | .
P | createControlLabel | . (inherited from TScaffoldInputBase)
P | createDateControl | . (inherited from TScaffoldInputCommon)
P | createDateTimeControl | . (inherited from TScaffoldInputCommon)
P | createDefaultControl | . (inherited from TScaffoldInputCommon)
P | createEnumControl | . (inherited from TScaffoldInputCommon)
P | createFloatControl | . (inherited from TScaffoldInputCommon)
S | createInputBuilder | . (inherited from TScaffoldInputBase)
P | createIntegerControl | . (inherited from TScaffoldInputCommon)
P | createMultiLineControl | . (inherited from TScaffoldInputCommon)
P | createRangeValidator | . (inherited from TScaffoldInputCommon)
P | createRequiredValidator | . (inherited from TScaffoldInputCommon)
 | createScaffoldInput | . (inherited from TScaffoldInputBase)
P | createSetControl | . (inherited from TScaffoldInputCommon)
P | createTimeControl | . (inherited from TScaffoldInputCommon)
P | createTypeValidator | . (inherited from TScaffoldInputCommon)
P | createYearControl | . (inherited from TScaffoldInputCommon)
P | getControlValue | .
P | getDateTimeValue | . (inherited from TScaffoldInputCommon)
P | getDefaultControlValue | . (inherited from TScaffoldInputCommon)
P | getEnumValue | . (inherited from TScaffoldInputCommon)
P | getIsEnabled | . (inherited from TScaffoldInputBase)
P | getMatchingIndices | . (inherited from TScaffoldInputCommon)
P | getParent | . (inherited from TScaffoldInputBase)
P | getRecordPropertyValue | . (inherited from TScaffoldInputBase)
P | getSetValue | . (inherited from TScaffoldInputCommon)
P | getTimeValue | . (inherited from TScaffoldInputCommon)
 | loadScaffoldInput | . (inherited from TScaffoldInputBase)
P | setDefaultProperty | . (inherited from TScaffoldInputCommon)
P | setNotNullProperty | . (inherited from TScaffoldInputCommon)
P | setRecordPropertyValue | . (inherited from TScaffoldInputBase)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPgsqlTableColumn

Namespace: System.Data.Common.Pgsql
Inheritance: TComponent » TDbTableColumn »
TPgsqlTableColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowNull | boolean | specifies whether value Null is allowed, default is false. (inherited from TDbTableColumn)
R | ColumnId | string | name of the column with quoted identifier. (inherited from TDbTableColumn)
R | ColumnIndex | integer | zero-based ordinal position of the column in the table. (inherited from TDbTableColumn)
R | ColumnName | string | name of the column in the table (identifier quoted). (inherited from TDbTableColumn)
R | ColumnSize | string | size of the column. (inherited from TDbTableColumn)
R | DbType | string | column type. (inherited from TDbTableColumn)
R | DefaultValue | mixed | default column value if column value was null. (inherited from TDbTableColumn)
R | IsExcluded | boolean | whether this column is excluded from insert and update. (inherited from TDbTableColumn)
R | IsForeignKey | boolean | whether this column is a foreign key, default is false. (inherited from TDbTableColumn)
R | IsPrimaryKey | boolean | whether this column is a primary key for the table, default is false. (inherited from TDbTableColumn)
R | MaxiumNumericConstraint | {unknown} | . (inherited from TDbTableColumn)
R | NumericPrecision | string | precision of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | NumericScale | string | scale of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | PHPType | boolean | Overrides parent implementation, returns PHP type from the db type.
R | PdoType | {unknown} | . (inherited from TDbTableColumn)
R | SequenceName | {unknown} | . (inherited from TDbTableColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableColumn)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasSequence | whether the column is a sequence. (inherited from TDbTableColumn)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPgsqlTableInfo

Namespace: System.Data.Common.Pgsql
Inheritance: TComponent » TDbTableInfo »
TPgsqlTableInfo
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ColumnNames | array | table column names (identifier quoted). (inherited from TDbTableInfo)
R | Columns | TMap | TDbTableColumn column meta data. (inherited from TDbTableInfo)
R | ForeignKeys | array | tuples of foreign table and column name. (inherited from TDbTableInfo)
R | IsView | boolean | whether the table is a view, default is false. (inherited from TDbTableInfo)
R | LowerCaseColumnNames | array | lowercased column key names mapped to normal column ids. (inherited from TDbTableInfo)
R | PrimaryKeys | string[] | . (inherited from TDbTableInfo)
R | SchemaName | string | name of the schema this column belongs to.
R | TableFullName | string | full name of the table, database dependent.
R | TableName | string | name of the table this column belongs to. (inherited from TDbTableInfo)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | new command builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getColumn | column information. (inherited from TDbTableInfo)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableInfo)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableInfo)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPhpErrorException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TPhpErrorException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPlaceHolder

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TPlaceHolder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPolygonHotSpot

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » THotSpot »
TPolygonHotSpot
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key that allows you to quickly navigate to the HotSpot region. (inherited from THotSpot)
 | AlternateText | string | the alternate text to display for a HotSpot object. (inherited from THotSpot)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from THotSpot)
 | CausesValidation | boolean | whether postback event trigger by this hotspot will cause input validation, default is true. (inherited from THotSpot)
 | Coordinates | string | coordinates of the vertices defining the polygon.
R | HasAttributes | boolean | whether the hotspot has custom attributes. (inherited from THotSpot)
 | HotSpotMode | THotSpotMode | the behavior of a HotSpot object when it is clicked. (inherited from THotSpot)
 | NavigateUrl | string | the URL to navigate to when a HotSpot object is clicked. (inherited from THotSpot)
 | PostBackValue | string | a value that is post back when the HotSpot is clicked. (inherited from THotSpot)
R | Shape | string | shape of this hotspot.
 | TabIndex | integer | the tab index of the HotSpot region. (inherited from THotSpot)
 | Target | string | the target window or frame to display the new page when the HotSpot region is clicked. (inherited from THotSpot)
 | ValidationGroup | string | the group of validators which the hotspot causes validation upon postback. (inherited from THotSpot)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from THotSpot)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from THotSpot)
 | hasAttribute | whether the named attribute exists. (inherited from THotSpot)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | removeAttribute | Removes the named attribute. (inherited from THotSpot)
 | render | Renders this hotspot. (inherited from THotSpot)
 | setAttribute | Sets a custom hotspot attribute. (inherited from THotSpot)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from THotSpot)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPostSelectBinding

Namespace: System.Data.SqlMap.Statements
TPostSelectBinding
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
getKeys | .
getMethod | .
getResultObject | .
getResultProperty | .
getStatement | .
setKeys | .
setMethod | .
setResultObject | .
setResultProperty | .
setStatement | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPreparedCommand

Namespace: System.Data.SqlMap.Statements
TPreparedCommand
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | applyParameterMap | .
 | create | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPreparedStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent »
TPreparedStatement
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
ParameterNames | {unknown} | .
ParameterValues | {unknown} | .
PreparedSql | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPreparedStatementFactory

Namespace: System.Data.SqlMap.Statements
TPreparedStatementFactory
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createParametersForTextCommand | .
 | prepare | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPriorityList

Namespace: System.Collections
Inheritance: TComponent » TList »
TPriorityList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | Returns the total number of items in the list .
 | DefaultPriority | numeric | gets the default priority of inserted items without a specified priority.
R | Iterator | Iterator | Returns an iterator for traversing the items in the list.
 | Precision | integer | The precision of numeric priorities, defaults to 8.
R | Priorities | array | This returns a list of the priorities within this list, ordered lowest to highest.
R | PriorityCount | integer | Gets the number of items at a priority within the list .
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
 | Name | Description
 | add | Appends an item into the list at the end of the specified priority.
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clear | Removes all items in the priority list by calling removeAtIndexInPriority from the last item to the first.
 | contains | whether the list contains the item.
 | copyFrom | Copies iterable data into the priority list.
 | count | Returns the number of items in the list.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | flattenPriorities | This flattens the priority list into a flat array [0,.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | indexOf | the index of the item in the flattened list (0 based), -1 if not found.
 | insertAfter | This inserts an item after another item within the list.
 | insertAt | Inserts an item at an index.
 | insertAtIndexInPriority | Inserts an item at the specified index within a priority.
 | insertBefore | This inserts an item before another item within the list.
 | itemAt | Returns the item at the index of a flattened priority list.
 | itemAtIndexInPriority | Returns the item at an index within a priority .
 | itemsAtPriority | Gets all the items at a specific priority.
 | mergeWith | Merges iterable data into the priority list.
 | offsetExists | Returns whether there is an element at the specified offset.
 | offsetGet | Returns the element at the specified offset.
 | offsetSet | Sets the element at the specified offset.
 | offsetUnset | Unsets the element at the specified offset.
 | priorityAt | Retutrns the priority of an item at a particular flattened index.
 | priorityOf | Returns the priority of a particular item .
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes an item from the priority list.
 | removeAt | Removes an item at the specified index in the flattened list.
 | removeAtIndexInPriority | Removes the item at a specific index within a priority.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | sortPriorities | This orders the priority list internally.
 | toArray | the priority list of items in array.
 | toArrayAbovePriority | Combines the map elements which have a priority above the parameter value .
 | toArrayBelowPriority | Combines the map elements which have a priority below the parameter value .
 | toPriorityArray | the array of priorities keys with values of arrays of items.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPriorityMap

Namespace: System.Collections
Inheritance: TComponent » TMap »
TPriorityMap
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the map.
 | DefaultPriority | numeric | gets the default priority of inserted items without a specified priority.
R | Iterator | Iterator | Returns an iterator for traversing the items in the map.
R | Keys | array | Returns the keys within the map ordered through the priority of each key-value pair .
 | Precision | integer | The precision of numeric priorities, defaults to 8.
R | Priorities | array | This returns a list of the priorities within this map, ordered lowest to highest.
R | PriorityCount | integer | Gets the number of items at a priority within the map.
 | ReadOnly | boolean | whether this map is read-only or not.
Events
Methods
 | Name | Description
 | add | Adds an item into the map.
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clear | Removes all items in the map.
 | contains | whether the map contains an item with the specified key.
 | copyFrom | Copies iterable data into the map.
 | count | Returns the number of items in the map.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | flattenPriorities | This flattens the priority map into a flat array [0,.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | itemAt | Returns the item with the specified key.
 | itemsAtPriority | Gets all the items at a specific priority.
 | mergeWith | Merges iterable data into the map.
 | offsetExists | Returns whether there is an element at the specified offset.
 | offsetGet | Returns the element at the specified offset.
 | offsetSet | Sets the element at the specified offset.
 | offsetUnset | Unsets the element at the specified offset.
 | priorityAt | Retutrns the priority of an item at a particular flattened index.
 | priorityOf | Returns the priority of a particular item within the map.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes an item from the map by its key.
 | setPriorityAt | This changes an item's priority.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | sortPriorities | Orders the priority list internally.
 | toArray | When the map is flattened into an array, the priorities are taken into account and elements of the map are ordered in the array according to their priority.
 | toArrayAbovePriority | Combines the map elements which have a priority above the parameter value .
 | toArrayBelowPriority | Combines the map elements which have a priority below the parameter value .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPropertyAccess

Namespace: System.Data.SqlMap
TPropertyAccess
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | get | Gets the property value.
S | has | true if property path is valid.
S | set | Sets the property value.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPropertyValue

Namespace: System
TPropertyValue
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | ensureArray | Converts a value to array type.
S | ensureBoolean | Converts a value to boolean type.
S | ensureEnum | Converts a value to enum type.
S | ensureFloat | Converts a value to float type.
S | ensureInteger | Converts a value to integer type.
S | ensureNullIfEmpty | Converts the value to 'null' if the given value is empty .
S | ensureObject | Converts a value to object type.
S | ensureString | Converts a value to string type.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TQueue

Namespace: System.Collections
Inheritance: TComponent »
TQueue
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the queue.
R | Iterator | Iterator | Returns an iterator for traversing the items in the queue.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the queue.
contains | whether the queue contains the item.
copyFrom | Copies iterable data into the queue.
count | Returns the number of items in the queue.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
dequeue | Removes and returns the object at the beginning of the queue.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
enqueue | Adds an object to the end of the queue.
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
peek | Returns the first item at the front of the queue.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in queue.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TQueueIterator

Namespace: System.Collections
TQueueIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array item.
key | Returns the key of the current array item.
next | Moves the internal pointer to the next array item.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an item at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRadioButton

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TCheckBox »
TRadioButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | whether clicking on the checkbox will post the page. (inherited from TCheckBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event triggered by this checkbox will cause input validation, default is true. (inherited from TCheckBox)
 | Checked | boolean | whether the checkbox is checked. (inherited from TCheckBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | boolean | Returns the value indicating whether the checkbox is checked. (inherited from TCheckBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBox)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GroupName | string | the name of the group that the radio button belongs to.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | InputAttributes | TMap | list of attributes to be rendered for the checkbox. (inherited from TCheckBox)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBox)
R | LabelAttributes | TMap | list of attributes to be rendered for label beside the checkbox. (inherited from TCheckBox)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox. (inherited from TCheckBox)
R | RadioButtonsInGroup | array | Gets an array of radiobuttons whose group name is the same as this radiobutton's.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | bool | Check if we need a span tag to surround this control. (inherited from TCheckBox)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | SurroundingTagID | string | the id of the surrounding tag or this clientID if no such tag needed. (inherited from TCheckBox)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button. (inherited from TCheckBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the checkbox. (inherited from TCheckBox)
 | TextAlign | TTextAlign | the alignment (Left or Right) of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
 | UniqueGroupName | string | the name used to fetch radiobutton post data.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the checkbox causes validation upon postback. (inherited from TCheckBox)
R | ValidationPropertyValue | mixed | Returns the value of the property that needs validation. (inherited from TCheckBox)
 | Value | string | the value of the checkbox. (inherited from TCheckBox)
RP | ValueAttribute | string | the value attribute to be rendered.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCheckedChanged | Raises OnCheckedChanged event when Checked changes value during postback. (inherited from TCheckBox)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the radio button groupings.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the checkbox to receive postback data during postback. (inherited from TCheckBox)
OnUnLoad | Unregisters the radio button groupings.
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add the group name as post data loader if group name is set.
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox control. (inherited from TCheckBox)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the client-script code.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderInputTag | Renders a radiobutton input element.
P | renderLabel | Renders a label beside the checkbox. (inherited from TCheckBox)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveRadioButton
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRadioButtonList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TCheckBoxList »
TRadioButtonList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
 | CellPadding | integer | the cellpadding for the table keeping the checkbox list. (inherited from TCheckBoxList)
 | CellSpacing | integer | the cellspacing for the table keeping the checkbox list. (inherited from TCheckBoxList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBoxList)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item. (inherited from TCheckBoxList)
R | HasHeader | boolean | Returns a value indicating whether this control contains header item. (inherited from TCheckBoxList)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items. (inherited from TCheckBoxList)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control supports multiple selection.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBoxList)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox. (inherited from TCheckBoxList)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
 | RepeatColumns | integer | the number of columns that the list should be displayed with. (inherited from TCheckBoxList)
 | RepeatDirection | string | the direction of traversing the list, defaults to 'Vertical'. (inherited from TCheckBoxList)
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers). (inherited from TCheckBoxList)
 | RepeatLayout | string | how the list should be displayed, using table or using line breaks. (inherited from TCheckBoxList)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | boolean | Wether the list should be rendered inside a span or not . (inherited from TCheckBoxList)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | TextAlign | TTextAlign | the alignment of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBoxList)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TCheckBoxList)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers for post data on postback. (inherited from TCheckBoxList)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TListControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createRepeatedControl | Creates a control used for repetition (used as a template).
P | createStyle | Creates a style object for the control. (inherited from TCheckBoxList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID. (inherited from TCheckBoxList)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | generateItemStyle | Returns a style used for rendering items. (inherited from TCheckBoxList)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBoxList)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox list control. (inherited from TCheckBoxList)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list. (inherited from TCheckBoxList)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveRadioButtonList
  • TRatingList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRangeValidationDataType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable » TValidationDataType »
TRangeValidationDataType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRangeValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TRangeValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Charset | string | charset for string length comparison.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | DataType | TRangeValidationDataType | the data type that the values being compared are converted to before the comparison is made.
 | DateFormat | string | the date validation date format if any.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
 | MaxValue | string | the maximum value of the validation range.
 | MinValue | string | the minimum value of the validation range.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StrictComparison | boolean | true to perform strict comparison.
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
P | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
P | isGreaterThan | .
P | isLessThan | .
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | isValidDate | Determine if the date is within the specified range.
P | isValidFloat | Determine if the value is within the specified float range.
P | isValidInteger | Determine if the value is within the integer range.
P | isValidString | Compare the string with a minimum and a maxiumum value.
P | isValidStringLength | true if min and max string length are satisfied.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRatingList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TCheckBoxList » TRadioButtonList »
TRatingList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowInput | boolean | Wrapper for ReadOnly property.
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
RP | AssetUrl | string | asset file url.
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Caption | string | caption text.
RP | CaptionControl | {unknown} | .
RP | CaptionControlID | string | find the client ID of the caption control.
 | CaptionID | string | control or html element ID for displaying a caption.
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
 | CellPadding | integer | the cellpadding for the table keeping the checkbox list. (inherited from TCheckBoxList)
 | CellSpacing | integer | the cellspacing for the table keeping the checkbox list. (inherited from TCheckBoxList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBoxList)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | HalfRatingInterval | array | rating display half value interval, default is array(0.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item. (inherited from TCheckBoxList)
R | HasHeader | boolean | Returns a value indicating whether this control contains header item. (inherited from TCheckBoxList)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items. (inherited from TCheckBoxList)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control supports multiple selection. (inherited from TRadioButtonList)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBoxList)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | list of post back options.
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
 | Rating | float | rating value.
 | RatingStyle | TRatingListStyle | current rating style.
RP | RatingStyleCssClass | string | rating style css class name.
 | ReadOnly | boolean | whether the items in the column can be edited.
 | RepeatColumns | integer | the number of columns that the list should be displayed with. (inherited from TCheckBoxList)
 | RepeatDirection | string | the direction of traversing the list, defaults to 'Vertical'. (inherited from TCheckBoxList)
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers). (inherited from TCheckBoxList)
 | RepeatLayout | string | how the list should be displayed, using table or using line breaks. (inherited from TCheckBoxList)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | boolean | Wether the list should be rendered inside a span or not . (inherited from TCheckBoxList)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | TextAlign | TTextAlign | the alignment of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBoxList)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TCheckBoxList)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the the rating style css file and rating image files.
OnSelectedIndexChanged | .
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TListControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createRepeatedControl | Creates a control used for repetition (used as a template). (inherited from TRadioButtonList)
P | createStyle | Creates a style object for the control. (inherited from TCheckBoxList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID. (inherited from TCheckBoxList)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | generateItemStyle | Returns a style used for rendering items. (inherited from TCheckBoxList)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRatingIndex | rating as integer.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TRadioButtonList)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | publishImages | URL of publish the rating images.
P | publishStyle | URL of the css style file.
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBoxList)
P | registerClientScript | Registers the relevant JavaScript.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Add rating style class name to the class attribute when ReadOnly property is true and when the CssClass property is empty.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list. (inherited from TCheckBoxList)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveRatingList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TReCaptcha

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TReCaptcha
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
RP | ChallengeFieldName | {unknown} | .
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSideOptions | {unknown} | .
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | CustomTranslations | {unknown} | .
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully.
 | Language | {unknown} | .
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PrivateKey | {unknown} | .
 | PublicKey | {unknown} | .
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | ResponseFieldName | {unknown} | .
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
R | TagName | {unknown} | .
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ThemeName | {unknown} | .
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ValidationPropertyValue | {unknown} | .
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Checks for API keys .
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | .
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | regenerateToken | .
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | .
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
 | validate | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TReCaptchaValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TReCaptchaValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
RP | CaptchaControl | {unknown} | .
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientScriptOptions | {unknown} | .
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | {unknown} | .
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | .
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
P | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TReadOnlyDataSource

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TDataSourceControl »
TReadOnlyDataSource
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | {unknown} | . (inherited from TDataSourceControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | {unknown} | . (inherited from TDataSourceControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ViewNames | {unknown} | . (inherited from TDataSourceControl)
 | Visible | {unknown} | . (inherited from TDataSourceControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataSourceChanged | . (inherited from TDataSourceControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | . (inherited from TDataSourceControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getView | .
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TReadOnlyDataSourceView

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TDataSourceView »
TReadOnlyDataSourceView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CanDelete | {unknown} | . (inherited from TDataSourceView)
R | CanGetRowCount | {unknown} | . (inherited from TDataSourceView)
R | CanInsert | {unknown} | . (inherited from TDataSourceView)
R | CanPage | {unknown} | . (inherited from TDataSourceView)
R | CanSort | {unknown} | . (inherited from TDataSourceView)
R | CanUpdate | {unknown} | . (inherited from TDataSourceView)
R | DataSource | {unknown} | . (inherited from TDataSourceView)
R | Name | {unknown} | . (inherited from TDataSourceView)
Events
Name | Description
OnDataSourceViewChanged | . (inherited from TDataSourceView)
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
delete | Deletes DB row(s) with the specified keys. (inherited from TDataSourceView)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
insertAt | Inserts a DB record. (inherited from TDataSourceView)
raiseEvent | Raises an event. (inherited from TComponent)
select | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
update | Updates DB record(s) with the specified keys and new values . (inherited from TDataSourceView)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRectangleHotSpot

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » THotSpot »
TRectangleHotSpot
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key that allows you to quickly navigate to the HotSpot region. (inherited from THotSpot)
 | AlternateText | string | the alternate text to display for a HotSpot object. (inherited from THotSpot)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from THotSpot)
 | Bottom | integer | the Y coordinate of the bottom side of the rectangle HotSpot region.
 | CausesValidation | boolean | whether postback event trigger by this hotspot will cause input validation, default is true. (inherited from THotSpot)
R | Coordinates | string | coordinates defining this hotspot shape.
R | HasAttributes | boolean | whether the hotspot has custom attributes. (inherited from THotSpot)
 | HotSpotMode | THotSpotMode | the behavior of a HotSpot object when it is clicked. (inherited from THotSpot)
 | Left | integer | the X coordinate of the right side of the rectangle HotSpot region.
 | NavigateUrl | string | the URL to navigate to when a HotSpot object is clicked. (inherited from THotSpot)
 | PostBackValue | string | a value that is post back when the HotSpot is clicked. (inherited from THotSpot)
 | Right | integer | the X coordinate of the right side of the rectangle HotSpot region.
R | Shape | string | shape of this hotspot.
 | TabIndex | integer | the tab index of the HotSpot region. (inherited from THotSpot)
 | Target | string | the target window or frame to display the new page when the HotSpot region is clicked. (inherited from THotSpot)
 | Top | integer | the Y coordinate of the top side of the rectangle HotSpot region.
 | ValidationGroup | string | the group of validators which the hotspot causes validation upon postback. (inherited from THotSpot)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from THotSpot)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from THotSpot)
 | hasAttribute | whether the named attribute exists. (inherited from THotSpot)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | removeAttribute | Removes the named attribute. (inherited from THotSpot)
 | render | Renders this hotspot. (inherited from THotSpot)
 | setAttribute | Sets a custom hotspot attribute. (inherited from THotSpot)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from THotSpot)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRegularExpressionValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TRegularExpressionValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ClientSidePatternModifiers | string | clientside pattern modifiers, no modifiers by default.
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PatternModifiers | string | pattern modifiers, no modifiers by default.
 | RegularExpression | string | the regular expression that determines the pattern used to validate a field.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
  • TEmailAddressValidator
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeatDirection

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TRepeatDirection
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeatInfo

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TRepeatInfo
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Caption | string | caption of the table layout.
CaptionAlign | TTableCaptionAlign | alignment of the caption of the table layout.
RepeatColumns | integer | the number of columns that the repeated items should be displayed in.
RepeatDirection | TRepeatDirection | the direction of traversing the repeated items, defaults to TRepeatDirection::Vertical.
RepeatLayout | TRepeatLayout | how the repeated items should be displayed, using table or using line breaks.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | renderFooter | Renders footer.
P | renderHeader | Renders header.
P | renderHorizontalContents | Renders contents in horizontal repeat direction.
P | renderRawContents | Renders contents in raw format.
 | renderRepeater | Renders the repeated items.
P | renderVerticalContents | Renders contents in veritcal repeat direction.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeatLayout

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TRepeatLayout
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeater

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl »
TRepeater
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AlternatingItemRenderer | string | the class name for alternative repeater items.
 | AlternatingItemTemplate | ITemplate | the alternative template string for the item.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataKeyField | string | the field of the data source that provides the keys of the list items.
R | DataKeys | TList | the keys used in the data listing control.
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EmptyRenderer | string | the class name for empty repeater item.
 | EmptyTemplate | ITemplate | the template applied when no data is bound to the repeater.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
R | Footer | TControl | the footer item.
 | FooterRenderer | string | the class name for repeater footer item.
 | FooterTemplate | ITemplate | the footer template.
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
R | Header | TControl | the header item.
 | HeaderRenderer | string | the class name for repeater header item.
 | HeaderTemplate | ITemplate | the header template.
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | ItemRenderer | string | the class name for repeater items.
 | ItemTemplate | ITemplate | the template for repeater items.
R | Items | TRepeaterItemCollection | list of repeater item controls.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SeparatorRenderer | string | the class name for repeater item separators.
 | SeparatorTemplate | ITemplate | the separator template.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnItemCommand | Raises OnItemCommand event.
OnItemCreated | Raises OnItemCreated event.
OnItemDataBound | Raises OnItemDataBound event.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation to handle OnItemCommand event which is bubbled from repeater items and their child controls.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createEmptyContent | Creates empty repeater content.
P | createItem | Creates a repeater item instance based on the item type and index.
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDataFieldValue | Returns the value of the data at the specified field.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads item count information from viewstate.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate repeater items from data source.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the repeater.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | reset | Clears up all items in the repeater.
P | restoreItemsFromViewState | Creates repeater items based on viewstate information.
 | saveState | Saves item count in viewstate.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveRepeater
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeaterCommandEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter » TCommandEventParameter »
TRepeaterCommandEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandName | string | name of the command. (inherited from TCommandEventParameter)
R | CommandParameter | string | parameter of the command. (inherited from TCommandEventParameter)
R | CommandSource | TControl | the control originally raises the OnCommand event.
R | Item | TControl | the repeater item control responsible for the event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeaterItem

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TRepeaterItem
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item @since 3.
 | DataItem | mixed | This property is deprecated since v3.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | ItemIndex | integer | Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
 | ItemType | TListItemType | item type.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeaterItemCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
TRepeaterItemCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeaterItemEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TRepeaterItemEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Item | TControl | repeater item related with the corresponding event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeaterItemRenderer

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TDataRenderer » TItemDataRenderer »
TRepeaterItemRenderer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item. (inherited from TDataRenderer)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
 | ItemIndex | integer | Returns a value indicating the zero-based index of the item in the corresponding data control's item collection. (inherited from TItemDataRenderer)
 | ItemType | TListItemType | item type. (inherited from TItemDataRenderer)
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRequiredFieldValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TRequiredFieldValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | InitialValue | string | the initial value of the associated input control.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
P | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TResultMap

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TResultMap
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Class | string | result class name.
R | Columns | TMap | result columns.
 | Discriminator | TDiscriminator | result class discriminator.
 | Extends | string | result map extends another result map.
 | GroupBy | string | result map groups by.
 | ID | string | a unique identifier for the .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
addResultProperty | Add a TResultProperty to result mapping.
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createInstanceOfResult | Create a new instance of the class of this result map.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
resolveSubMap | Result sub-mappings using the discriminiator column.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TResultProperty

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TResultProperty
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Column | string | name of the column in the result set from which the value will be used to populate the property.
 | ColumnIndex | int | index of the column in the ResultSet from which the value will be used to populate the object property.
 | LazyLoad | boolean | indicate whether or not the select statement's results should be lazy loaded.
 | NestedResultMap | TResultMap | nested result map.
 | NullValue | mixed | null value replacement.
 | Property | string | name of a property of the result object that will be set to.
RP | PropertyValueType | int | Determines if the type is an instance of ArrayAccess, TList or an array.
 | ResultMapping | string | ID of another used to fill the property.
 | Select | string | name of another mapped statement.
 | Type | string | property type of the object property to be set.
 | TypeHandler | string | custom type handler class name (may use namespace).
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createTypeHandler | Create type handler from setType() or setTypeHandler.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getPropertyValue | Gets the value for the current property, converts to applicable type if necessary.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getTypedValue | property value casted to specific type.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | instanceOfArrayType | Returns true if the result property getType() is of ArrayAccess or that the actual result object is an array or implements ArrayAccess .
 | instanceOfListType | Returns true if the result property getType() is of TList type or that the actual result object is an instance of TList.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TResultSetListItemParameter

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent »
TResultSetListItemParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | List | {unknown} | .
R | Parameter | {unknown} | .
R | Result | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TResultSetMapItemParameter

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent »
TResultSetMapItemParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Key | {unknown} | .
R | Map | {unknown} | .
R | Parameter | {unknown} | .
R | Value | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRpcApiProvider

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent » TModule »
TRpcApiProvider
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | RpcServer | {unknown} | .
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the module. (inherited from TModule)
processRequest | .
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
registerMethods | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRpcClient

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent »
TRpcClient
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | IsNotification | boolean | whether requests are considered to be notifications (completely ignoring the response).
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ServerUrl | string | url of the RPC server.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
S | create | Creates an instance of the requested RPC client type .
P | createStreamContext | Creates a stream context resource .
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | performRequest | Performs the actual request .
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TJsonRpcClient
  • TXmlRpcClient
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRpcClientRequestException

Namespace: System.Util
Inheritance: TException » TApplicationException »
TRpcClientRequestException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRpcClientResponseException

Namespace: System.Util
Inheritance: TException » TApplicationException »
TRpcClientResponseException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRpcClientTypesEnumerable

Namespace: System.Util
Inheritance: TEnumerable »
TRpcClientTypesEnumerable
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRpcException

Namespace: System.Web.Services
Inheritance: TException »
TRpcException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRpcProtocol

Namespace: System.Web.Services
TRpcProtocol
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addMethod | Registers a new RPC method and handler details .
callApiMethod | Calls the callback handler for the given method .
callMethod | .
createErrorResponse | .
createResponseHeaders | .
decode | .
encode | .
Derived classes
  • TJsonRpcProtocol
  • TXmlRpcProtocol
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRpcServer

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent » TModule »
TRpcServer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
R | Payload | string | request payload.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
addRpcMethod | .
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the module. (inherited from TModule)
processRequest | rpc response.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRpcService

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent » TService »
TRpcService
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Enabled | boolean | whether the service is enabled. (inherited from TService)
 | ID | string | id of this service. (inherited from TService)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createApiProvider | Creates the API provider instance for the current request .
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the service .
loadConfig | .
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
run | Runs the service.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSafeHtml

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TSafeHtml
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RepackUTF7 | boolean | whether to parse the contents as UTF-7.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | parseSafeHtml | Use SafeHTML to remove malicous javascript from the HTML content.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders body content.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldBase

Namespace: System.Data.ActiveRecord.Scaffold
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl »
TScaffoldBase
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultStyle | string | default scaffold stylesheet name.
 | EnableDefaultStyle | boolean | enable default stylesheet, default is true.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RecordClass | string | Name of the Active Record class to be viewed or scaffolded.
RP | RecordFinder | TActiveRecord | Active Record finder instance.
P | RecordObject | TActiveRecord | Gets the current Active Record instance.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TableInfo | TDbMetaData | table/view information.
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the default stylesheet file.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
P | clearRecordObject | Unset the current record instance and table information.
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
P | copyFrom | Copy the view details from another scaffold view instance.
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRecordPkValues | record primary key values.
P | getRecordPropertyValues | record property values.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TScaffoldEditView
  • TScaffoldListView
  • TScaffoldSearch
  • TScaffoldView
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldEditView

Namespace: System.Data.ActiveRecord.Scaffold
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TScaffoldBase »
TScaffoldEditView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
R | CancelButton | TButton | Button to cancel the edit action (e.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClearButton | TButton | Button to clear the editor inputs.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
RP | CurrentRecord | TActiveRecord | current Active Record instance.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultStyle | string | default scaffold stylesheet name. (inherited from TScaffoldBase)
 | EditRenderer | string | the class name for scaffold editor.
 | EnableDefaultStyle | boolean | enable default stylesheet, default is true. (inherited from TScaffoldBase)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
RP | InputRepeater | TRepeater | default editor input controls repeater.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RecordClass | string | Name of the Active Record class to be viewed or scaffolded. (inherited from TScaffoldBase)
RP | RecordFinder | TActiveRecord | Active Record finder instance. (inherited from TScaffoldBase)
P | RecordObject | TActiveRecord | Gets the current Active Record instance. (inherited from TScaffoldBase)
 | RecordPk | array | Active Record primary key value.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SaveButton | TButton | Button triggered to save the Active Record.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TableInfo | TDbMetaData | table/view information. (inherited from TScaffoldBase)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ValidationGroup | string | editor validation group name.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | Initialize the editor form if it is Visible.
OnPreRender | Publish the default stylesheet file. (inherited from TScaffoldBase)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Bubble the command name event.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
P | clearRecordObject | Unset the current record instance and table information. (inherited from TScaffoldBase)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
P | copyFrom | Copy the view details from another scaffold view instance. (inherited from TScaffoldBase)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createEditRenderer | Instantiate the external edit renderer.
P | createRepeaterEditItem | Initialize the default editor using the scaffold input builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | doSave | Check the validators, then tries to save the record.
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRecordPkValues | record primary key values. (inherited from TScaffoldBase)
P | getRecordPropertyValues | record property values. (inherited from TScaffoldBase)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
P | getScaffoldInputBuilder | Create the default scaffold editor control factory.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | initializeEditForm | Initialize the editor form.
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldInputBase

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
TScaffoldInputBase
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createControl | .
P | createControlLabel | .
S | createInputBuilder | .
 | createScaffoldInput | .
P | getControlValue | .
P | getIsEnabled | .
P | getParent | .
P | getRecordPropertyValue | .
 | loadScaffoldInput | .
P | setRecordPropertyValue | .
Derived classes
  • TScaffoldInputCommon
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldInputCommon

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
Inheritance: TScaffoldInputBase »
TScaffoldInputCommon
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createBooleanControl | .
P | createControl | . (inherited from TScaffoldInputBase)
P | createControlLabel | . (inherited from TScaffoldInputBase)
P | createDateControl | .
P | createDateTimeControl | .
P | createDefaultControl | .
P | createEnumControl | .
P | createFloatControl | .
S | createInputBuilder | . (inherited from TScaffoldInputBase)
P | createIntegerControl | .
P | createMultiLineControl | .
P | createRangeValidator | .
P | createRequiredValidator | .
 | createScaffoldInput | . (inherited from TScaffoldInputBase)
P | createSetControl | .
P | createTimeControl | .
P | createTypeValidator | .
P | createYearControl | .
P | getControlValue | . (inherited from TScaffoldInputBase)
P | getDateTimeValue | .
P | getDefaultControlValue | .
P | getEnumValue | .
P | getIsEnabled | . (inherited from TScaffoldInputBase)
P | getMatchingIndices | .
P | getParent | . (inherited from TScaffoldInputBase)
P | getRecordPropertyValue | . (inherited from TScaffoldInputBase)
P | getSetValue | .
P | getTimeValue | .
 | loadScaffoldInput | . (inherited from TScaffoldInputBase)
P | setDefaultProperty | .
P | setNotNullProperty | .
P | setRecordPropertyValue | . (inherited from TScaffoldInputBase)
Derived classes
  • TIbmScaffoldInput
  • TMssqlScaffoldInput
  • TMysqlScaffoldInput
  • TPgsqlScaffoldInput
  • TSqliteScaffoldInput
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldListView

Namespace: System.Data.ActiveRecord.Scaffold
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TScaffoldBase »
TScaffoldListView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultStyle | string | default scaffold stylesheet name. (inherited from TScaffoldBase)
RP | EditViewControl | TScaffoldEditView | control for editing selected Active Record, null if EditViewID is not set.
 | EditViewID | string | TScaffoldEditView control ID for editing selected Active Record.
 | EnableDefaultStyle | boolean | enable default stylesheet, default is true. (inherited from TScaffoldBase)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | Header | TRepeater | Repeater control for record property names.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
R | List | TRepeater | Repeater control for Active Record instances.
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Pager | TPager | List pager control.
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RecordClass | string | Name of the Active Record class to be viewed or scaffolded. (inherited from TScaffoldBase)
RP | RecordCriteria | TActiveRecordCriteria | sort/search/paging criteria.
RP | RecordFinder | TActiveRecord | Active Record finder instance. (inherited from TScaffoldBase)
P | RecordObject | TActiveRecord | Gets the current Active Record instance. (inherited from TScaffoldBase)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | SearchCondition | {unknown} | .
 | SearchParameters | array | search parameters.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | Sort | TDropDownList | Control that displays and controls the record ordering.
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TableInfo | TDbMetaData | table/view information. (inherited from TScaffoldBase)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Loads and display the data.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Continue bubbling the "edit" command, "delete" command is handled in this class.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
P | clearRecordObject | Unset the current record instance and table information. (inherited from TScaffoldBase)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
P | copyFrom | Copy the view details from another scaffold view instance. (inherited from TScaffoldBase)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
P | deleteRecord | Deletes an Active Record.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRecordPkValues | record primary key values. (inherited from TScaffoldBase)
P | getRecordPropertyValues | record property values. (inherited from TScaffoldBase)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
P | initializeEdit | Initialize the edit view control form when EditViewID is set.
P | initializeSort | Initialize the sort drop down list and the column names repeater.
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | listItemCreated | Initialize the default display for each Active Record item.
P | loadRecordData | Fetch the records and data bind it to the list.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | pageChanged | Updates repeater page index with the pager new index value.
P | populateField | Sets the Record primary key to the current repeater item's CustomData.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldSearch

Namespace: System.Data.ActiveRecord.Scaffold
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TScaffoldBase »
TScaffoldSearch
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultStyle | string | default scaffold stylesheet name. (inherited from TScaffoldBase)
 | EnableDefaultStyle | boolean | enable default stylesheet, default is true. (inherited from TScaffoldBase)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
RP | Fields | array | list of fields to be searched.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
RP | ListView | TScaffoldListView | the scaffold list view this search box belongs to.
 | ListViewID | string | ID of the TScaffoldListView this search control belongs to.
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RecordClass | string | Name of the Active Record class to be viewed or scaffolded. (inherited from TScaffoldBase)
RP | RecordFinder | TActiveRecord | Active Record finder instance. (inherited from TScaffoldBase)
P | RecordObject | TActiveRecord | Gets the current Active Record instance. (inherited from TScaffoldBase)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SearchButton | TButton | button with default label "Search".
R | SearchText | TTextBox | search text box.
 | SearchableFields | string | comma delimited list of fields that may be searched.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TableInfo | TDbMetaData | table/view information. (inherited from TScaffoldBase)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the default stylesheet file. (inherited from TScaffoldBase)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Sets the SearchCondition of the TScaffoldListView as the search terms given by the text of the search text box.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
P | clearRecordObject | Unset the current record instance and table information. (inherited from TScaffoldBase)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
P | copyFrom | Copy the view details from another scaffold view instance. (inherited from TScaffoldBase)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createSearchCondition | the search criteria for the search terms in the search text box.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRecordPkValues | record primary key values. (inherited from TScaffoldBase)
P | getRecordPropertyValues | record property values. (inherited from TScaffoldBase)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldView

Namespace: System.Data.ActiveRecord.Scaffold
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TScaffoldBase »
TScaffoldView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AddButton | TButton | "Add new record" button.
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultStyle | string | default scaffold stylesheet name. (inherited from TScaffoldBase)
R | EditView | TScaffoldEditView | scaffold edit view.
 | EnableDefaultStyle | boolean | enable default stylesheet, default is true. (inherited from TScaffoldBase)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
R | ListView | TScaffoldListView | scaffold list view.
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RecordClass | string | Name of the Active Record class to be viewed or scaffolded. (inherited from TScaffoldBase)
RP | RecordFinder | TActiveRecord | Active Record finder instance. (inherited from TScaffoldBase)
P | RecordObject | TActiveRecord | Gets the current Active Record instance. (inherited from TScaffoldBase)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SearchControl | TScaffoldSearch | scaffold search textbox and button.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TableInfo | TDbMetaData | table/view information. (inherited from TScaffoldBase)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Copy basic record details to the list/edit/search controls.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Handle the "edit" and "new" commands by displaying the edit view.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
P | clearRecordObject | Unset the current record instance and table information. (inherited from TScaffoldBase)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
P | copyFrom | Copy the view details from another scaffold view instance. (inherited from TScaffoldBase)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRecordPkValues | record primary key values. (inherited from TScaffoldBase)
P | getRecordPropertyValues | record property values. (inherited from TScaffoldBase)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
P | showAddView | Shows the add record view.
P | showEditView | Shows the edit record view.
P | showListView | Shows the view for listing the records.
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScalarDiff

Namespace: System.Web.UI.ActiveControls
Inheritance: TViewStateDiff »
TScalarDiff
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
getDifference | update viewstate value.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScrollBars

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TScrollBars
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSecurityManager

Namespace: System.Security
Inheritance: TComponent » TApplicationComponent » TModule »
TSecurityManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Encryption | string | the algorithm used to encrypt/decrypt data.
 | EncryptionKey | string | the private key used to encrypt/decrypt data.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Validation | TSecurityManagerValidationMode | hashing algorithm used to generate HMAC.
 | ValidationKey | string | the private key used to generate HMAC.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | computeHMAC | Computes the HMAC for the data with ValidationKey.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | decrypt | Decrypts data with EncryptionKey.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | encrypt | Encrypts data with EncryptionKey.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | generateRandomKey | Generates a random key.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hashData | Prefixes data with an HMAC.
 | init | Initializes the module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | validateData | Validates if data is tampered.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSecurityManagerValidationMode

Namespace: System.Security
Inheritance: TEnumerable »
TSecurityManagerValidationMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSelectMappedStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent » TMappedStatement »
TSelectMappedStatement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TPreparedCommand | command to prepare SQL statements. (inherited from TMappedStatement)
R | ID | string | Name used to identify the TMappedStatement amongst the others. (inherited from TMappedStatement)
R | Manager | TSqlMapper | The SqlMap used by this MappedStatement. (inherited from TMappedStatement)
R | SqlString | {unknown} | . (inherited from TMappedStatement)
R | Statement | TSqlMapStatement | The SQL statment used by this MappedStatement. (inherited from TMappedStatement)
Events
Name | Description
OnExecuteQuery | Raise the execute query event. (inherited from TMappedStatement)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addResultMapGroupBy | ResultMap with GroupBy property. (inherited from TMappedStatement)
P | applyResultMap | Apply result mapping. (inherited from TMappedStatement)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | enquequePostSelect | Add nested result property to post select queue. (inherited from TMappedStatement)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | executeInsert | .
P | executePostSelect | Process 'select' result properties . (inherited from TMappedStatement)
 | executeQueryForList | Executes the SQL and retuns a List of result objects. (inherited from TMappedStatement)
 | executeQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. (inherited from TMappedStatement)
 | executeQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter. (inherited from TMappedStatement)
P | executeSQLQueryLimit | Execute SQL Query with limits. (inherited from TMappedStatement)
P | executeSelectKey | Execute the select key statement, used to obtain last insert ID. (inherited from TMappedStatement)
 | executeUpdate | .
P | fillArrayResultMap | Retrieve the result map as an array. (inherited from TMappedStatement)
P | fillDefaultResultMap | Fill the result map using default settings. (inherited from TMappedStatement)
P | fillPropertyWithResultMap | Fills the property with result mapping results. (inherited from TMappedStatement)
P | fillResultArrayList | Apply the result to a TList or an array. (inherited from TMappedStatement)
P | fillResultClass | Fill the result using ResultClass, will creates new result object if required. (inherited from TMappedStatement)
P | fillResultMap | Fills the result object according to result mappings. (inherited from TMappedStatement)
P | fillResultObjectProperty | Apply the result to an object. (inherited from TMappedStatement)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPostGeneratedSelectKey | Gets the inserted row ID after executing an insert statement. (inherited from TMappedStatement)
P | getPostSelectKeys | Finds in the post select property the SQL statement primary selection keys. (inherited from TMappedStatement)
P | getPreGeneratedSelectKey | Gets the insert generated ID before executing an insert statement. (inherited from TMappedStatement)
P | getResultMapGroupKey | Gets the result 'group by' groupping key for each row. (inherited from TMappedStatement)
P | getScalarResult | Converts the first array value to scalar value of given type. (inherited from TMappedStatement)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initialGroupByResults | Empty the group by results cache. (inherited from TMappedStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | raiseRowDelegate | Raises delegate handler. (inherited from TMappedStatement)
 | runQueryForList | Executes the SQL and retuns a List of result objects. (inherited from TMappedStatement)
 | runQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. (inherited from TMappedStatement)
 | runQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter. (inherited from TMappedStatement)
P | setObjectProperty | Set a property of the result object with appropriate value. (inherited from TMappedStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TServerValidateEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TServerValidateEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | IsValid | boolean | whether the value is valid.
R | Value | string | value to be validated.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TService

Namespace: System
Inheritance: TComponent » TApplicationComponent »
TService
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Enabled | boolean | whether the service is enabled.
 | ID | string | id of this service.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the service and attaches run to the RunService event of application.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
run | Runs the service.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TFeedService
  • TJsonService
  • TPageService
  • TRpcService
  • TSoapService
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSessionIterator

Namespace: System.Web
TSessionIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array element.
key | Returns the key of the current array element.
next | Moves the internal pointer to the next array element.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an element at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSessionPageStatePersister

Namespace: System.Web.UI
Inheritance: TComponent »
TSessionPageStatePersister
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
HistorySize | integer | maximum number of page states that should be kept in session.
Page | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
load | Loads page state from session.
raiseEvent | Raises an event. (inherited from TComponent)
save | Saves state in session.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TShellApplication

Namespace: System
Inheritance: TComponent » TApplication »
TShellApplication
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
RP | ApplicationConfigurationClass | {unknown} | . (inherited from TApplication)
 | ApplicationStatePersister | IStatePersister | application state persister. (inherited from TApplication)
 | AssetManager | TAssetManager | asset manager. (inherited from TApplication)
R | AuthorizationRules | TAuthorizationRuleCollection | list of authorization rules for the current request. (inherited from TApplication)
 | BasePath | string | the directory containing the application configuration file (absolute path). (inherited from TApplication)
 | Cache | ICache | the cache module, null if cache module is not installed. (inherited from TApplication)
 | ConfigurationFile | string | the application configuration file (absolute path). (inherited from TApplication)
R | ConfigurationFileExt | string | the applictaion configuration type. (inherited from TApplication)
R | ConfigurationFileName | string | the default configuration file name. (inherited from TApplication)
 | ConfigurationType | string | the application configuration file (absolute path). (inherited from TApplication)
 | ErrorHandler | TErrorHandler | the error handler module. (inherited from TApplication)
 | Globalization | TGlobalization | globalization module. (inherited from TApplication)
 | ID | string | application ID. (inherited from TApplication)
 | Mode | TApplicationMode | application mode. (inherited from TApplication)
R | Modules | array | list of loaded application modules, indexed by module IDs. (inherited from TApplication)
 | PageServiceID | string | page service ID. (inherited from TApplication)
R | Parameters | TMap | Returns the list of application parameters. (inherited from TApplication)
 | Request | THttpRequest | the request module. (inherited from TApplication)
R | RequestCompleted | boolean | whether the current request is processed. (inherited from TApplication)
 | Response | THttpResponse | the response module. (inherited from TApplication)
 | RuntimePath | string | the directory storing cache data and application-level persistent data. (inherited from TApplication)
 | SecurityManager | TSecurityManager | the security manager module. (inherited from TApplication)
 | Service | IService | the currently requested service. (inherited from TApplication)
 | Session | THttpSession | the session module, null if session module is not installed. (inherited from TApplication)
R | UniqueID | string | an ID that uniquely identifies this Prado application from the others. (inherited from TApplication)
 | User | IUser | the application user. (inherited from TApplication)
Events
Name | Description
OnAuthentication | Raises OnAuthentication event. (inherited from TApplication)
OnAuthenticationComplete | Raises OnAuthenticationComplete event. (inherited from TApplication)
OnAuthorization | Raises OnAuthorization event. (inherited from TApplication)
OnAuthorizationComplete | Raises OnAuthorizationComplete event. (inherited from TApplication)
OnBeginRequest | Raises OnBeginRequest event. (inherited from TApplication)
OnEndRequest | Raises OnEndRequest event. (inherited from TApplication)
OnError | Raises OnError event. (inherited from TApplication)
OnLoadState | Raises OnLoadState event. (inherited from TApplication)
OnLoadStateComplete | Raises OnLoadStateComplete event. (inherited from TApplication)
OnPreFlushOutput | Raises OnPreFlushOutput event. (inherited from TApplication)
OnPreRunService | Raises OnPreRunService event. (inherited from TApplication)
OnSaveState | Raises OnSaveState event. (inherited from TApplication)
OnSaveStateComplete | Raises OnSaveStateComplete event. (inherited from TApplication)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyConfiguration | Applies an application configuration. (inherited from TApplication)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clearGlobalState | Clears a global value. (inherited from TApplication)
 | completeRequest | Completes current request processing. (inherited from TApplication)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flushOutput | Flushes output to client side. (inherited from TApplication)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getGlobalState | Returns a global value. (inherited from TApplication)
 | getModule | the module with the specified ID, null if not found. (inherited from TApplication)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initApplication | Loads configuration and initializes application. (inherited from TApplication)
P | loadGlobals | Loads global values from persistent storage. (inherited from TApplication)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | resolvePaths | Resolves application-relevant paths. (inherited from TApplication)
 | run | Runs the application.
 | runService | Runs the requested service. (inherited from TApplication)
P | saveGlobals | Saves global values into persistent storage. (inherited from TApplication)
 | setGlobalState | Sets a global value. (inherited from TApplication)
 | setModule | Adds a module to application. (inherited from TApplication)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | startService | Starts the specified service. (inherited from TApplication)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSimpleDateFormatter

Namespace: System.Util
TSimpleDateFormatter
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
format | Format the date according to the pattern.
getCharset | formatting charset.
getDayMonthYearOrdering | .
getDayPattern | .
getMonthPattern | .
getPattern | formatting pattern.
getYearPattern | .
isValidDate | true if the given value matches with the date pattern.
parse | Parse the string according to the pattern.
setCharset | .
setPattern | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSimpleDynamicParser

Namespace: System.Data.SqlMap.Configuration
TSimpleDynamicParser
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
parse | Parse the sql text for dynamic place holders of the form $name$.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSimpleDynamicSql

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent » TStaticSql »
TSimpleDynamicSql
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | PreparedStatement | {unknown} | . (inherited from TStaticSql)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
buildPreparedStatement | . (inherited from TStaticSql)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
replaceDynamicParameter | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSlider

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TSlider
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the slider value.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TSliderClientScript | Gets the TSliderClientScript to set the TSlider event handlers.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CssUrl | string | URL for the CSS file including all relevant CSS class definitions.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the TSlider control.
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Direction | TSliderDirection | Direction of slider (Horizontal or Vertical).
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | MaxValue | float | Maximum value for the slider.
 | MinValue | float | Minimum value for slider.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | ProgressIndicator | boolean | wether to display a progress indicator or not.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
RP | SliderOptions | array | Get javascript sliderr options.
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StepSize | float | Step size.
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
R | TagName | string | the HTML tag name for slider.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Value | float | current value of slider.
 | Values | array | list of allowed values the slider can take.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers CSS and JS.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
OnValueChanged | Raises OnValueChanged event.
Methods
 | Name | Description
P | addAttributesToRender | Add the specified css classes to the track .
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientScript | javascript event options.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
P | registerSliderClientScript | Registers the javascript code to initialize the slider.
P | registerStyleSheet | Registers the CSS relevant to the TSlider.
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Render the body content.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSliderClientScript

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TClientSideOptions »
TSliderClientScript
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | OnChange | string | javascript code to execute when the slider value is changed.
 | OnSlide | string | javascript code to execute when the slider moves.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Ensure that the javascript statements are wrapped in a javascript function block as function(sender, parameter){ //code }. (inherited from TClientSideOptions)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSliderDirection

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TSliderDirection
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSoapServer

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent »
TSoapServer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Actor | string | actor of the SOAP service.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ClassMaps | string | comma delimit list of complex type classes.
 | Encoding | string | encoding of the SOAP service.
 | ID | string | the ID of the SOAP server.
RP | Options | array | options for creating SoapServer instance.
 | Provider | string | the SOAP provider class (in namespace format).
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | RequestedMethod | string | Soap method guessed from the SOAP message received.
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SessionPersistent | boolean | whether the SOAP service is persistent within session.
 | Uri | string | the URI for the SOAP service.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Version | string | SOAP version, defaults to empty (meaning not set).
R | Wsdl | string | Returns the WSDL content of the SOAP server.
 | WsdlUri | string | the URI for WSDL.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createServer | Creates the SoapServer instance.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | fault | Generate a SOAP fault message.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | guessMethodCallRequested | Guess the SOAP method request from the actual SOAP message .
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | run | Handles the SOAP request.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSoapService

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent » TService »
TSoapService
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ConfigFile | string | external configuration file.
 | Enabled | boolean | whether the service is enabled. (inherited from TService)
 | ID | string | id of this service. (inherited from TService)
R | IsWsdlRequest | boolean | whether this is a request for WSDL.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | ServerID | string | the SOAP server ID.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | constructUrl | Constructs a URL with specified page path and GET parameters.
P | createServer | Creates the requested SOAP server.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | resolveRequest | Resolves the request parameter.
 | run | Runs the service.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlCriteria

Namespace: System.Data.DataGateway
Inheritance: TComponent »
TSqlCriteria
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Condition | string | search conditions.
R | IsNamedParameters | boolean | true if the parameter index are string base, false otherwise.
 | Limit | int | maximum number of records to return.
 | Offset | int | record offset.
 | OrdersBy | TAttributeCollection | ordering clause.
 | Parameters | TAttributeCollection | list of named parameters and values.
 | Select | mixed | Gets the field list to be placed after the SELECT in the SQL.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveRecordCriteria
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapApplicationCache

Namespace: System.Data.SqlMap
TSqlMapApplicationCache
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | add | .
 | delete | .
 | flush | Deletes all items in the cache, only for data cached by sqlmap cachemodel.
 | get | Gets a cached object with the specified key.
P | getCache | Application cache instance.
P | getKeyList | Retreive keylist from cache or create it if it doesn't exists .
P | getKeyListId | a KeyListID for the cache model.
 | set | Stores a value identified by a key into cache.
P | setKeyList | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapCache

Namespace: System.Data.SqlMap
TSqlMapCache
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
add | .
delete | the object removed if exists, null otherwise.
flush | Clears the cache.
get | Retrieves a value from cache with a specified key. (inherited from ICache)
getCacheSize | cache size.
set | Stores a value identified by a key into cache. (inherited from ICache)
setCacheSize | Maximum number of items to cache.
Derived classes
  • TSqlMapFifoCache
  • TSqlMapLruCache
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapCacheKey

Namespace: System.Data.SqlMap.Configuration
TSqlMapCacheKey
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | generateKey | crc32 hash of the serialized object.
 | getHash | object hash.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapCacheModel

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TSqlMapCacheModel
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | FlushInterval | integer | cache duration.
R | HitRatio | float | cache hit ratio.
 | ID | string | unique cache model identifier.
 | Implementation | string | cache implements of TSqlMapCacheTypes, either 'Basic', 'LRU' or 'FIFO'.
R | ImplementationClass | string | cache implementation class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Clears the cache.
 | get | cached value.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initialize the cache implementation, sets the actual cache contain if supplied.
 | raiseEvent | Raises an event. (inherited from TComponent)
S | registerCacheType | .
 | registerTriggerStatement | Register a mapped statement that will trigger a cache flush.
 | set | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapCacheTypes

Namespace: System.Data.SqlMap.Configuration
Inheritance: TEnumerable »
TSqlMapCacheTypes
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapConfig

Namespace: System.Data.SqlMap
Inheritance: TComponent » TApplicationComponent » TModule » TDataSourceConfig »
TSqlMapConfig
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Client | TSqlMapGateway | Initialize the sqlmap if necessary, returns the TSqlMapGateway instance.
 | ConfigFile | string | SqlMap configuration file.
 | ConnectionClass | {unknown} | . (inherited from TDataSourceConfig)
 | ConnectionID | string | connection module ID. (inherited from TDataSourceConfig)
R | Database | TDbConnection | Alias for getDbConnection(). (inherited from TDataSourceConfig)
R | DbConnection | TDbConnection | Gets the TDbConnection from another module if ConnectionID is supplied and valid. (inherited from TDataSourceConfig)
 | EnableCache | boolean | true if configuration should be cached, false otherwise.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | SqlMapManager | TSqlMapManager | Create and configure the data mapper using sqlmap configuration file.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
P | cacheSqlMapManager | Saves the current SqlMap manager to cache.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clearCache | Deletes the configuration cache.
P | createSqlMapGateway | SqlMap gateway instance.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | findConnectionByID | Finds the database connection instance from the Application modules. (inherited from TDataSourceConfig)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initalize the database connection properties from attributes in tag. (inherited from TDataSourceConfig)
P | loadCachedSqlMapManager | Loads SqlMap manager from cache.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapConfigurationException

Namespace: System.Data.SqlMap
Inheritance: TException » TSqlMapException »
TSqlMapConfigurationException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TSqlMapException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
P | implodeNode | tag name and attribute names and values. (inherited from TSqlMapException)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapDelete

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent » TSqlMapStatement » TSqlMapUpdate »
TSqlMapDelete
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Cache | TSqlMapCacheModel | cache implementation instance for this statement. (inherited from TSqlMapStatement)
CacheModel | string | cache mode name. (inherited from TSqlMapStatement)
Extends | string | another statement element name. (inherited from TSqlMapStatement)
ID | string | name for this statement, unique to each sql map manager. (inherited from TSqlMapStatement)
ListClass | string | name of a PHP class that implements ArrayAccess. (inherited from TSqlMapStatement)
ParameterClass | string | parameter class name. (inherited from TSqlMapStatement)
ParameterMap | string | name of a parameter map. (inherited from TSqlMapStatement)
ResultClass | string | result class name. (inherited from TSqlMapStatement)
ResultMap | string | result map name. (inherited from TSqlMapStatement)
SqlText | TStaticSql | sql text container. (inherited from TSqlMapStatement)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createInstanceOf | Create a new instance of a given type. (inherited from TSqlMapStatement)
 | createInstanceOfListClass | new instance of list class. (inherited from TSqlMapStatement)
 | createInstanceOfResultClass | Create a new instance of result class. (inherited from TSqlMapStatement)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | . (inherited from TSqlMapStatement)
 | parameterMap | the parameter map corresponding to the getParameterMap() property. (inherited from TSqlMapStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | resultMap | the result map corresponding to the getResultMap() property. (inherited from TSqlMapStatement)
 | setInlineParameterMap | . (inherited from TSqlMapStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapDuplicateException

Namespace: System.Data.SqlMap
Inheritance: TException » TSqlMapException »
TSqlMapDuplicateException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TSqlMapException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
P | implodeNode | tag name and attribute names and values. (inherited from TSqlMapException)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapException

Namespace: System.Data.SqlMap
Inheritance: TException »
TSqlMapException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file.
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
P | implodeNode | tag name and attribute names and values.
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
  • TInvalidPropertyException
  • TSqlMapConfigurationException
  • TSqlMapDuplicateException
  • TSqlMapExecutionException
  • TSqlMapUndefinedException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapExecutionException

Namespace: System.Data.SqlMap
Inheritance: TException » TSqlMapException »
TSqlMapExecutionException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TSqlMapException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
P | implodeNode | tag name and attribute names and values. (inherited from TSqlMapException)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapFifoCache

Namespace: System.Data.SqlMap
Inheritance: TSqlMapCache »
TSqlMapFifoCache
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
add | . (inherited from TSqlMapCache)
delete | the object removed if exists, null otherwise. (inherited from TSqlMapCache)
flush | Clears the cache. (inherited from TSqlMapCache)
get | Gets a cached object with the specified key.
getCacheSize | cache size. (inherited from TSqlMapCache)
set | Stores a value identified by a key into cache.
setCacheSize | Maximum number of items to cache. (inherited from TSqlMapCache)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapGateway

Namespace: System.Data.SqlMap
Inheritance: TComponent »
TSqlMapGateway
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection.
R | SqlMapManager | TSqlMapManager | sqlmap manager.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
delete | Executes a Sql DELETE statement.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flushCaches | Flushes all cached objects that belong to this SqlMap.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
insert | Executes a Sql INSERT statement.
queryForList | Executes a Sql SELECT statement that returns data to populate a number of result objects.
queryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter.
queryForMapWithRowDelegate | Runs a query with a custom object that gets a chance to deal with each row as it is processed.
queryForObject | Executes a Sql SELECT statement that returns that returns data to populate a single object instance.
queryForPagedList | Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.
queryForPagedListWithRowDelegate | Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.
queryWithRowDelegate | Runs a query for list with a custom object that gets a chance to deal with each row as it is processed.
raiseEvent | Raises an event. (inherited from TComponent)
registerTypeHandler | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
update | Executes a Sql UPDATE statement.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapInsert

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent » TSqlMapStatement »
TSqlMapInsert
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Cache | TSqlMapCacheModel | cache implementation instance for this statement. (inherited from TSqlMapStatement)
CacheModel | string | cache mode name. (inherited from TSqlMapStatement)
Extends | string | another statement element name. (inherited from TSqlMapStatement)
ID | string | name for this statement, unique to each sql map manager. (inherited from TSqlMapStatement)
ListClass | string | name of a PHP class that implements ArrayAccess. (inherited from TSqlMapStatement)
ParameterClass | string | parameter class name. (inherited from TSqlMapStatement)
ParameterMap | string | name of a parameter map. (inherited from TSqlMapStatement)
ResultClass | string | result class name. (inherited from TSqlMapStatement)
ResultMap | string | result map name. (inherited from TSqlMapStatement)
SelectKey | TSqlMapSelectKey | select key element.
SqlText | TStaticSql | sql text container. (inherited from TSqlMapStatement)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createInstanceOf | Create a new instance of a given type. (inherited from TSqlMapStatement)
 | createInstanceOfListClass | new instance of list class. (inherited from TSqlMapStatement)
 | createInstanceOfResultClass | Create a new instance of result class. (inherited from TSqlMapStatement)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | . (inherited from TSqlMapStatement)
 | parameterMap | the parameter map corresponding to the getParameterMap() property. (inherited from TSqlMapStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | resultMap | the result map corresponding to the getResultMap() property. (inherited from TSqlMapStatement)
 | setInlineParameterMap | . (inherited from TSqlMapStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapLruCache

Namespace: System.Data.SqlMap
Inheritance: TSqlMapCache »
TSqlMapLruCache
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
add | . (inherited from TSqlMapCache)
delete | the object removed if exists, null otherwise. (inherited from TSqlMapCache)
flush | Clears the cache. (inherited from TSqlMapCache)
get | Gets a cached object with the specified key.
getCacheSize | cache size. (inherited from TSqlMapCache)
set | Stores a value identified by a key into cache.
setCacheSize | Maximum number of items to cache. (inherited from TSqlMapCache)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapManager

Namespace: System.Data.SqlMap
Inheritance: TComponent »
TSqlMapManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CacheDependencies | TChainedCacheDependency | @since 3.
 | DbConnection | TDbConnection | default database connection.
R | MappedStatements | TMap | mapped statements collection.
R | ParameterMaps | TMap | parameter maps collection.
R | ResultMaps | TMap | result maps collection.
R | SqlmapGateway | TSqlMapGateway | SqlMap gateway.
R | TypeHandlers | TTypeHandlerFactory | The TypeHandlerFactory.
Events
Methods
 | Name | Description
 | addCacheModel | Adds a named cache.
 | addMappedStatement | Adds a (named) MappedStatement.
 | addParameterMap | .
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | addResultMap | .
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | configureXml | Loads and parses the SqlMap configuration file.
P | createSqlMapGateway | Configures the current TSqlMapManager using the given xml configuration file defined in setConfigFile().
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flushCacheModels | Flushes all cached objects that belong to this SqlMap.
 | getCacheModel | Gets a cache by name .
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getMappedStatement | Gets a MappedStatement by name.
 | getParameterMap | the parameter with given ID.
 | getResultMap | Gets a named result map .
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapObjectCollectionTree

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent »
TSqlMapObjectCollectionTree
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
RP | Collection | array | object collection.
Events
Name | Description
OnChildNodesVisited | Set the object properties for all the child nodes visited.
Methods
 | Name | Description
 | add | Add a new node to the object tree graph.
P | addNode | Find the parent node and add the new node as its child.
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collect | object collection.
P | collectChildren | Visit all the child nodes and collect them by removing.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | hasChildren | true if all nodes are leaf nodes, false otherwise.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | isEmpty | true if the graph is empty.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapPagedList

Namespace: System.Data.SqlMap
Inheritance: TComponent » TList » TPagedList »
TSqlMapPagedList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in current page. (inherited from TPagedList)
 | CurrentPageIndex | integer | current page index. (inherited from TPagedList)
 | CustomPaging | boolean | whether to use custom paging. (inherited from TPagedList)
R | IsFirstPage | boolean | whether the current page is the first page. (inherited from TPagedList)
R | IsLastPage | boolean | true if is the very last page, false otherwise.
R | IsMiddlePage | boolean | true if is not first nor last page, false otherwise.
R | IsNextPageAvailable | boolean | true if the next page is available, false otherwise.
R | IsPreviousPageAvailable | boolean | true if the previous page is available, false otherwise.
R | Iterator | Iterator | iterator. (inherited from TPagedList)
R | PageCount | integer | number of pages, -1 if under custom paging mode and VirtualCount is not set. (inherited from TPagedList)
 | PageSize | integer | number of items in each page. (inherited from TPagedList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
 | VirtualCount | integer | user-assigned number of items in data source. (inherited from TPagedList)
Events
Name | Description
OnFetchData | Raises OnFetchData event. (inherited from TPagedList)
OnPageIndexChanged | Raises OnPageIndexChanged event. (inherited from TPagedList)
Methods
 | Name | Description
 | add | Appends an item at the end of the list. (inherited from TList)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clear | Removes all items in the list. (inherited from TList)
 | contains | whether the list contains the item. (inherited from TList)
 | copyFrom | Copies iterable data into the list. (inherited from TList)
 | count | Returns the number of items in the list. (inherited from TList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | fetchDataFromStatement | Fetch data by executing the SqlMap statement.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOffsetAndLimit | Calculate the data fetch offsets and limits.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | gotoPage | Changes to a page with the specified page index. (inherited from TPagedList)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TPagedList)
P | initialize | Initialize the paged list.
 | insertAfter | Finds the base item. (inherited from TList)
 | insertAt | Inserts an item at the specified position. (inherited from TList)
 | insertBefore | Finds the base item. (inherited from TList)
 | itemAt | Returns the item at the specified offset. (inherited from TPagedList)
 | mergeWith | Merges iterable data into the map. (inherited from TList)
 | nextPage | Switches to the next page.
 | offsetExists | Returns whether there is an item at the specified offset. (inherited from TPagedList)
 | offsetGet | Returns the item at the specified offset. (inherited from TPagedList)
 | offsetSet | Sets the item at the specified offset. (inherited from TList)
 | offsetUnset | Unsets the item at the specified offset. (inherited from TList)
P | populateData | Populate the list with the fetched data.
 | previousPage | Switches to the previous page.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes an item from the list. (inherited from TList)
 | removeAt | Removes an item at the specified position. (inherited from TList)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | toArray | the list of items in array. (inherited from TPagedList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapSelect

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent » TSqlMapStatement »
TSqlMapSelect
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Cache | TSqlMapCacheModel | cache implementation instance for this statement. (inherited from TSqlMapStatement)
CacheModel | string | cache mode name. (inherited from TSqlMapStatement)
Extends | string | another statement element name. (inherited from TSqlMapStatement)
Generate | {unknown} | .
ID | string | name for this statement, unique to each sql map manager. (inherited from TSqlMapStatement)
ListClass | string | name of a PHP class that implements ArrayAccess. (inherited from TSqlMapStatement)
ParameterClass | string | parameter class name. (inherited from TSqlMapStatement)
ParameterMap | string | name of a parameter map. (inherited from TSqlMapStatement)
ResultClass | string | result class name. (inherited from TSqlMapStatement)
ResultMap | string | result map name. (inherited from TSqlMapStatement)
SqlText | TStaticSql | sql text container. (inherited from TSqlMapStatement)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createInstanceOf | Create a new instance of a given type. (inherited from TSqlMapStatement)
 | createInstanceOfListClass | new instance of list class. (inherited from TSqlMapStatement)
 | createInstanceOfResultClass | Create a new instance of result class. (inherited from TSqlMapStatement)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | . (inherited from TSqlMapStatement)
 | parameterMap | the parameter map corresponding to the getParameterMap() property. (inherited from TSqlMapStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | resultMap | the result map corresponding to the getResultMap() property. (inherited from TSqlMapStatement)
 | setInlineParameterMap | . (inherited from TSqlMapStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapSelectKey

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent » TSqlMapStatement »
TSqlMapSelectKey
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Cache | TSqlMapCacheModel | cache implementation instance for this statement. (inherited from TSqlMapStatement)
 | CacheModel | string | cache mode name. (inherited from TSqlMapStatement)
 | Extends | string | another statement element name. (inherited from TSqlMapStatement)
 | ID | string | name for this statement, unique to each sql map manager. (inherited from TSqlMapStatement)
R | IsAfter | boolean | true if key is generated after insert command, false otherwise.
 | ListClass | string | name of a PHP class that implements ArrayAccess. (inherited from TSqlMapStatement)
 | ParameterClass | string | parameter class name. (inherited from TSqlMapStatement)
 | ParameterMap | string | name of a parameter map. (inherited from TSqlMapStatement)
 | Property | string | property name for the generated key.
 | ResultClass | string | result class name. (inherited from TSqlMapStatement)
 | ResultMap | string | result map name. (inherited from TSqlMapStatement)
 | SqlText | TStaticSql | sql text container. (inherited from TSqlMapStatement)
 | Type | string | select generated key type, 'post' or 'pre'.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createInstanceOf | Create a new instance of a given type. (inherited from TSqlMapStatement)
 | createInstanceOfListClass | new instance of list class. (inherited from TSqlMapStatement)
 | createInstanceOfResultClass | Create a new instance of result class. (inherited from TSqlMapStatement)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | . (inherited from TSqlMapStatement)
 | parameterMap | the parameter map corresponding to the getParameterMap() property. (inherited from TSqlMapStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | resultMap | the result map corresponding to the getResultMap() property. (inherited from TSqlMapStatement)
 | setInlineParameterMap | . (inherited from TSqlMapStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapStatement

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TSqlMapStatement
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Cache | TSqlMapCacheModel | cache implementation instance for this statement.
CacheModel | string | cache mode name.
Extends | string | another statement element name.
ID | string | name for this statement, unique to each sql map manager.
ListClass | string | name of a PHP class that implements ArrayAccess.
ParameterClass | string | parameter class name.
ParameterMap | string | name of a parameter map.
ResultClass | string | result class name.
ResultMap | string | result map name.
SqlText | TStaticSql | sql text container.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createInstanceOf | Create a new instance of a given type.
 | createInstanceOfListClass | new instance of list class.
 | createInstanceOfResultClass | Create a new instance of result class.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | .
 | parameterMap | the parameter map corresponding to the getParameterMap() property.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | resultMap | the result map corresponding to the getResultMap() property.
 | setInlineParameterMap | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TSqlMapInsert
  • TSqlMapSelect
  • TSqlMapSelectKey
  • TSqlMapUpdate
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapTypeHandler

Namespace: System.Data.SqlMap
Inheritance: TComponent »
TSqlMapTypeHandler
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
DbType | string | database field type.
Type | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createNewInstance | Casts the string representation of a value into a type recognized by this type handler.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getParameter | Performs processing on a value before it is used to set the parameter of a IDbCommand.
getResult | Performs processing on a value before after it has been retrieved from a database .
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapTypeHandlerRegistry

Namespace: System.Data.SqlMap
TSqlMapTypeHandlerRegistry
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
convertToType | Converts the value to given type using PHP's settype() function.
createInstanceOf | Creates a new instance of a particular class (for PHP primative types, their corresponding default value for given type is used).
getDbTypeHandler | type handler for give database field type.
getTypeHandler | type handler.
registerTypeHandler | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapUndefinedException

Namespace: System.Data.SqlMap
Inheritance: TException » TSqlMapException »
TSqlMapUndefinedException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TSqlMapException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
P | implodeNode | tag name and attribute names and values. (inherited from TSqlMapException)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapUpdate

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent » TSqlMapStatement »
TSqlMapUpdate
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Cache | TSqlMapCacheModel | cache implementation instance for this statement. (inherited from TSqlMapStatement)
CacheModel | string | cache mode name. (inherited from TSqlMapStatement)
Extends | string | another statement element name. (inherited from TSqlMapStatement)
ID | string | name for this statement, unique to each sql map manager. (inherited from TSqlMapStatement)
ListClass | string | name of a PHP class that implements ArrayAccess. (inherited from TSqlMapStatement)
ParameterClass | string | parameter class name. (inherited from TSqlMapStatement)
ParameterMap | string | name of a parameter map. (inherited from TSqlMapStatement)
ResultClass | string | result class name. (inherited from TSqlMapStatement)
ResultMap | string | result map name. (inherited from TSqlMapStatement)
SqlText | TStaticSql | sql text container. (inherited from TSqlMapStatement)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createInstanceOf | Create a new instance of a given type. (inherited from TSqlMapStatement)
 | createInstanceOfListClass | new instance of list class. (inherited from TSqlMapStatement)
 | createInstanceOfResultClass | Create a new instance of result class. (inherited from TSqlMapStatement)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | . (inherited from TSqlMapStatement)
 | parameterMap | the parameter map corresponding to the getParameterMap() property. (inherited from TSqlMapStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | resultMap | the result map corresponding to the getResultMap() property. (inherited from TSqlMapStatement)
 | setInlineParameterMap | . (inherited from TSqlMapStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TSqlMapDelete
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapXmlConfigBuilder

Namespace: System.Data.SqlMap.Configuration
TSqlMapXmlConfigBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createObjectFromNode | Create an instance of an object give by the attribute named 'class' in the node and set the properties on the object given by attribute names and values.
P | getAbsoluteFilePath | Gets the filename relative to the basefile.
P | getConfigFile | configuration file.
P | getElementByIdValue | Get element node by ID value (try for attribute name ID as case insensitive).
P | loadXmlDocument | Load document using simple xml.
P | setObjectPropFromNode | For each attributes (excluding attribute named in $except) set the property of the $obj given by the name of the attribute with the value of the attribute.
Derived classes
  • TSqlMapXmlConfiguration
  • TSqlMapXmlMappingConfiguration
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapXmlConfiguration

Namespace: System.Data.SqlMap.Configuration
Inheritance: TSqlMapXmlConfigBuilder »
TSqlMapXmlConfiguration
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | attachCacheModels | Set the cache for each statement having a cache model property.
 | configure | Configure the TSqlMapManager using the given xml file.
P | createObjectFromNode | Create an instance of an object give by the attribute named 'class' in the node and set the properties on the object given by attribute names and values. (inherited from TSqlMapXmlConfigBuilder)
P | getAbsoluteFilePath | Gets the filename relative to the basefile. (inherited from TSqlMapXmlConfigBuilder)
P | getConfigFile | .
P | getElementByIdValue | Get element node by ID value (try for attribute name ID as case insensitive). (inherited from TSqlMapXmlConfigBuilder)
 | getManager | .
P | loadDatabaseConnection | Load the database connection tag.
P | loadGlobalProperty | Load global replacement property.
P | loadSqlMappingFiles | Load SqlMap mapping configuration.
P | loadTypeHandler | Load the type handler configurations.
P | loadXmlDocument | Load document using simple xml. (inherited from TSqlMapXmlConfigBuilder)
 | replaceProperties | Replace the place holders ${name} in text with properties the corresponding global property value.
P | resolveResultMapping | Resolve nest result mappings.
P | setObjectPropFromNode | For each attributes (excluding attribute named in $except) set the property of the $obj given by the name of the attribute with the value of the attribute. (inherited from TSqlMapXmlConfigBuilder)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapXmlMappingConfiguration

Namespace: System.Data.SqlMap.Configuration
Inheritance: TSqlMapXmlConfigBuilder »
TSqlMapXmlMappingConfiguration
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | applyInlineParameterMap | Extract inline parameter maps.
 | configure | Configure an XML mapping.
P | createInsertStatement | Create new insert statement from xml node.
P | createObjectFromNode | Create an instance of an object give by the attribute named 'class' in the node and set the properties on the object given by attribute names and values. (inherited from TSqlMapXmlConfigBuilder)
P | createParameterMap | Create a new parameter map from xml node.
P | createResultMap | Create a new result map and its associated result properties, disciminiator and sub maps.
P | getAbsoluteFilePath | Gets the filename relative to the basefile. (inherited from TSqlMapXmlConfigBuilder)
P | getConfigFile | .
P | getElementByIdValue | Get element node by ID value (try for attribute name ID as case insensitive). (inherited from TSqlMapXmlConfigBuilder)
P | loadCacheModel | Load cache models from xml mapping.
P | loadDeleteTag | Load delete statement from xml mapping.
P | loadFlushInterval | Load the flush interval .
P | loadFlushOnCache | Load the flush on cache properties.
P | loadInsertTag | Load insert statement from xml mapping.
P | loadParameterMap | Load parameter map from xml.
P | loadProcedureTag | Load procedure statement from xml mapping.
P | loadResultMap | Load the result maps.
P | loadSelectKeyTag | Load the selectKey statement from xml mapping.
P | loadSelectTag | Load select statement from xml mapping.
P | loadStatementTag | Load statement mapping from xml configuration file.
P | loadUpdateTag | Load update statement from xml mapping.
P | loadXmlDocument | Load document using simple xml. (inherited from TSqlMapXmlConfigBuilder)
P | prepareSql | Prepare the sql text (may extend to dynamic sql).
P | processSqlStatement | Load extended SQL statements if application.
P | registerCacheTriggers | Attach CacheModel to statement and register trigger statements for cache models.
P | setObjectPropFromNode | For each attributes (excluding attribute named in $except) set the property of the $obj given by the name of the attribute with the value of the attribute. (inherited from TSqlMapXmlConfigBuilder)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqliteCache

Namespace: System.Caching
Inheritance: TComponent » TApplicationComponent » TModule » TCache »
TSqliteCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DbFile | string | database file path (in namespace form).
 | ID | string | id of this module. (inherited from TModule)
 | KeyPrefix | string | a unique prefix for the keys of cached values. (inherited from TCache)
 | PrimaryCache | boolean | whether this cache module is used as primary/system cache. (inherited from TCache)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | add | Stores a value identified by a key into cache if the cache does not contain this key. (inherited from TCache)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addValue | Stores a value identified by a key into cache if the cache does not contain this key.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes a value with the specified key from cache . (inherited from TCache)
P | deleteValue | Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Deletes all values from cache.
P | generateUniqueKey | a key generated from the provided key which ensures the uniqueness across applications. (inherited from TCache)
 | get | Retrieves a value from cache with a specified key. (inherited from TCache)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValue | Retrieves a value from cache with a specified key.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | offsetExists | Returns whether there is a cache entry with a specified key. (inherited from TCache)
 | offsetGet | Retrieves the value from cache with a specified key. (inherited from TCache)
 | offsetSet | Stores the value identified by a key into cache. (inherited from TCache)
 | offsetUnset | Deletes the value with the specified key from cache This method is required by the interface ArrayAccess. (inherited from TCache)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | set | Stores a value identified by a key into cache. (inherited from TCache)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setValue | Stores a value identified by a key in cache.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqliteCommandBuilder

Namespace: System.Data.Common
Inheritance: TComponent » TDbCommandBuilder »
TSqliteCommandBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | database connection. (inherited from TDbCommandBuilder)
R | LastInsertID | mixed | Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial. (inherited from TDbCommandBuilder)
R | SelectFieldList | array | Different behavior depends on type of passed data string usage without modification null will be expanded to full list of quoted table column names (quoting depends on database) array - Column names will be quoted if used as key or value of array array('col1', 'col2', 'col2') // SELECT `col1`, `col2`, `col3` FROM. (inherited from TDbCommandBuilder)
 | TableInfo | {unknown} | . (inherited from TDbCommandBuilder)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyCriterias | . (inherited from TDbCommandBuilder)
 | applyLimitOffset | Alters the sql to apply $limit and $offset.
 | applyOrdering | modified SQL applied with ORDER BY. (inherited from TDbCommandBuilder)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | bindArrayValues | . (inherited from TDbCommandBuilder)
 | bindColumnValues | Bind the name-value pairs of $values where the array keys correspond to column names. (inherited from TDbCommandBuilder)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommand | corresponding database command. (inherited from TDbCommandBuilder)
 | createCountCommand | Creates a count(*) command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createDeleteCommand | Creates a delete command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createFindCommand | Appends the $where condition to the string "SELECT * FROM tableName WHERE ". (inherited from TDbCommandBuilder)
 | createInsertCommand | Creates an insert command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createUpdateCommand | Creates an update command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getColumnBindings | Create a name-value or position-value if $position=true binding strings. (inherited from TDbCommandBuilder)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertFieldBindings | Returns a list of insert field name and a list of binding names. (inherited from TDbCommandBuilder)
S | getPdoType | PDO parameter types. (inherited from TDbCommandBuilder)
P | getSearchCondition | search condition for all words in one column. (inherited from TDbCommandBuilder)
 | getSearchExpression | Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords). (inherited from TDbCommandBuilder)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
P | hasIntegerKey | true if any array key is an integer. (inherited from TDbCommandBuilder)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqliteMetaData

Namespace: System.Data.Common.Sqlite
Inheritance: TComponent » TDbMetaData »
TSqliteMetaData
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection. (inherited from TDbMetaData)
R | TableInfo | TDbTableInfo | Obtains table meta data information for the current connection and given table name. (inherited from TDbMetaData)
RP | TableInfoClass | string | TDbTableInfo class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | Creates a command builder for a given table name. (inherited from TDbMetaData)
P | createTableInfo | Get the column definitions for given table.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getForeignKeys | foreign key details.
S | getInstance | Obtain database specific TDbMetaData class using the driver name of the database connection. (inherited from TDbMetaData)
P | getIsView | true if the table is a view.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isForeignKeyColumn | true if column is a foreign key.
P | processColumn | column details.
 | quoteColumnAlias | Quotes a column alias for use in a query.
 | quoteColumnName | Quotes a column name for use in a query.
 | quoteTableName | Quotes a table name for use in a query.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqliteScaffoldInput

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
Inheritance: TScaffoldInputBase » TScaffoldInputCommon »
TSqliteScaffoldInput
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createBooleanControl | . (inherited from TScaffoldInputCommon)
P | createControl | .
P | createControlLabel | . (inherited from TScaffoldInputBase)
P | createDateControl | .
P | createDateTimeControl | .
P | createDefaultControl | . (inherited from TScaffoldInputCommon)
P | createEnumControl | . (inherited from TScaffoldInputCommon)
P | createFloatControl | . (inherited from TScaffoldInputCommon)
S | createInputBuilder | . (inherited from TScaffoldInputBase)
P | createIntegerControl | . (inherited from TScaffoldInputCommon)
P | createMultiLineControl | . (inherited from TScaffoldInputCommon)
P | createRangeValidator | . (inherited from TScaffoldInputCommon)
P | createRequiredValidator | . (inherited from TScaffoldInputCommon)
 | createScaffoldInput | . (inherited from TScaffoldInputBase)
P | createSetControl | . (inherited from TScaffoldInputCommon)
P | createTimeControl | . (inherited from TScaffoldInputCommon)
P | createTypeValidator | . (inherited from TScaffoldInputCommon)
P | createYearControl | . (inherited from TScaffoldInputCommon)
P | getControlValue | .
P | getDateTimeValue | .
P | getDefaultControlValue | . (inherited from TScaffoldInputCommon)
P | getEnumValue | . (inherited from TScaffoldInputCommon)
P | getIsEnabled | . (inherited from TScaffoldInputBase)
P | getMatchingIndices | . (inherited from TScaffoldInputCommon)
P | getParent | . (inherited from TScaffoldInputBase)
P | getRecordPropertyValue | . (inherited from TScaffoldInputBase)
P | getSetValue | . (inherited from TScaffoldInputCommon)
P | getTimeValue | . (inherited from TScaffoldInputCommon)
 | loadScaffoldInput | . (inherited from TScaffoldInputBase)
P | setDefaultProperty | . (inherited from TScaffoldInputCommon)
P | setNotNullProperty | . (inherited from TScaffoldInputCommon)
P | setRecordPropertyValue | . (inherited from TScaffoldInputBase)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqliteTableColumn

Namespace: System.Data.Common.Sqlite
Inheritance: TComponent » TDbTableColumn »
TSqliteTableColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowNull | boolean | specifies whether value Null is allowed, default is false. (inherited from TDbTableColumn)
R | AutoIncrement | boolean | true if column will auto-increment when the column value is inserted as null.
R | ColumnId | string | name of the column with quoted identifier. (inherited from TDbTableColumn)
R | ColumnIndex | integer | zero-based ordinal position of the column in the table. (inherited from TDbTableColumn)
R | ColumnName | string | name of the column in the table (identifier quoted). (inherited from TDbTableColumn)
R | ColumnSize | string | size of the column. (inherited from TDbTableColumn)
R | DbType | string | column type. (inherited from TDbTableColumn)
R | DefaultValue | mixed | default column value if column value was null. (inherited from TDbTableColumn)
R | IsExcluded | boolean | whether this column is excluded from insert and update. (inherited from TDbTableColumn)
R | IsForeignKey | boolean | whether this column is a foreign key, default is false. (inherited from TDbTableColumn)
R | IsPrimaryKey | boolean | whether this column is a primary key for the table, default is false. (inherited from TDbTableColumn)
R | MaxiumNumericConstraint | {unknown} | . (inherited from TDbTableColumn)
R | NumericPrecision | string | precision of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | NumericScale | string | scale of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | PHPType | boolean | Overrides parent implementation, returns PHP type from the db type.
R | PdoType | {unknown} | . (inherited from TDbTableColumn)
R | SequenceName | {unknown} | . (inherited from TDbTableColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableColumn)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasSequence | true if auto increment is true.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqliteTableInfo

Namespace: System.Data.Common.Sqlite
Inheritance: TComponent » TDbTableInfo »
TSqliteTableInfo
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ColumnNames | array | table column names (identifier quoted). (inherited from TDbTableInfo)
R | Columns | TMap | TDbTableColumn column meta data. (inherited from TDbTableInfo)
R | ForeignKeys | array | tuples of foreign table and column name. (inherited from TDbTableInfo)
R | IsView | boolean | whether the table is a view, default is false. (inherited from TDbTableInfo)
R | LowerCaseColumnNames | array | lowercased column key names mapped to normal column ids. (inherited from TDbTableInfo)
R | PrimaryKeys | string[] | . (inherited from TDbTableInfo)
R | TableFullName | string | full name of the table, database dependent.
R | TableName | string | name of the table this column belongs to. (inherited from TDbTableInfo)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | new command builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getColumn | column information. (inherited from TDbTableInfo)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableInfo)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableInfo)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStack

Namespace: System.Collections
Inheritance: TComponent »
TStack
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the stack.
R | Iterator | Iterator | Returns an iterator for traversing the items in the stack.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the stack.
contains | whether the stack contains the item.
copyFrom | Copies iterable data into the stack.
count | Returns the number of items in the stack.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
peek | Returns the item at the top of the stack.
pop | Pops up the item at the top of the stack.
push | Pushes an item into the stack.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in stack.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStackIterator

Namespace: System.Collections
TStackIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array item.
key | Returns the key of the current array item.
next | Moves the internal pointer to the next array item.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an item at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStatements

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TStatements
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Statements | string | the statements to be executed.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the evaluation result of the statements.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStaticSql

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent »
TStaticSql
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | PreparedStatement | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
buildPreparedStatement | .
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TSimpleDynamicSql
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStyle

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TStyle
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | BackColor | string | the background color of the control.
 | BorderColor | string | the border color of the control.
 | BorderStyle | string | the border style of the control.
 | BorderWidth | string | the border width of the control.
 | CssClass | string | the CSS class of the control.
 | CustomStyle | string | the custom style of the control.
 | DisplayStyle | TDisplayStyle | display style.
R | Font | TFont | the font of the control.
 | ForeColor | string | the foreground color of the control.
 | Height | string | the height of the control.
R | StyleFields | array | list of style fields.
 | Width | string | the width of the control.
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clearStyleField | Clears a single style field value; .
copyFrom | Copies the fields in a new style to this style.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getStyleField | a single style field value set via setStyleField.
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasCssClass | true if CSS is set or empty.
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasFont | true if font is set.
hasProperty | Determines whether a property is defined. (inherited from TComponent)
hasStyleField | whether a style field has been defined by setStyleField.
mergeWith | Merges the style with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Resets the style to the original empty state.
setStyleField | Sets a single style field value.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TPanelStyle
  • TTableItemStyle
  • TTableStyle
  • TWizardNavigationButtonStyle
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStyleDiff

Namespace: System.Web.UI.ActiveControls
Inheritance: TViewStateDiff »
TStyleDiff
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | getCombinedStyle | all the style properties combined.
P | getCssClassDiff | changes to the CSS class name.
 | getDifference | list of changes to the control style and CSS class name.
P | getStyleDiff | list of changes to the control style.
P | getStyleFromString | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStyleSheet

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TStyleSheet
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | MediaType | string | media type of the CSS (such as 'print', 'screen', etc.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StyleSheetUrl | string | URL to the stylesheet file.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the stylesheet file and content to be rendered.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSubMap

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TSubMap
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
ResultMapping | string | The result map to use when the Value matches the discriminator column value.
Value | string | value for comparison with discriminator column value.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSystemException

Namespace: System.Exceptions
Inheritance: TException »
TSystemException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
  • TConfigurationException
  • TDbException
  • THttpException
  • TIOException
  • TInvalidDataTypeException
  • TInvalidDataValueException
  • TInvalidOperationException
  • TNotSupportedException
  • TPhpErrorException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTabPanel

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTabPanel
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | ActiveTabCssClass | string | CSS class for the active tab.
R | ActiveTabStyle | TStyle | the style for the active tab div.
 | ActiveView | TTabView | Returns the currently active view.
 | ActiveViewID | string | Returns the ID of the active tab view.
 | ActiveViewIndex | integer | Returns the index of the active tab view.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoSwitch | bool | status of automatic tab switch on hover.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientOptions | array | the options for JavaScript.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | CSS class for the whole tab control div.
 | CssUrl | string | URL for the CSS file including all relevant CSS class definitions.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabCssClass | string | CSS class for non-active tabs.
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
R | TabStyle | TStyle | the style for all the inactive tab div.
RP | TagName | string | tag name for the control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ViewCssClass | string | CSS class for the currently displayed view div.
R | ViewStyle | TStyle | the style for all the view div.
R | Views | TTabViewCollection | list of TTabView controls.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers CSS and JS.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | activateView | Activates the specified view.
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds object parsed from template to the control.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls .
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
P | registerClientScript | Registers the relevant JavaScript.
 | registerObject | Registers an object by a name. (inherited from TControl)
P | registerStyleSheet | Registers the CSS relevant to the TTabControl.
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | .
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the tab control.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTabView

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTabView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Active | boolean | whether this tab view is active.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Caption | string | the caption displayed on this tab.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NavigateUrl | string | the URL of the target page.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | the | tag name for the view element.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content displayed on this view.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the tab view.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderTab | Renders the tab associated with the tab view.
P | renderTabContent | Renders the content in the tab.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTabViewCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList » TControlCollection »
TTabViewCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection. (inherited from TControlCollection)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer. (inherited from TControlCollection)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
findIndexByID | Finds the index of the tab view whose ID is the same as the one being looked for.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TControlCollection)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTable

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTable
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the table.
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Caption | string | table caption.
 | CaptionAlign | TTableCaptionAlign | table caption alignment.
 | CellPadding | integer | the cellpadding for the table.
 | CellSpacing | integer | the cellspacing for the table.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GridLines | TTableGridLines | the grid line setting of the table.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the table content.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Rows | TTableRowCollection | list of TTableRow controls.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name for the table.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds object parsed from template to the control.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls .
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the table control which will render table caption if present.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableCaptionAlign

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTableCaptionAlign
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableCell

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTableCell
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | ColumnSpan | integer | the columnspan for the table cell, 0 if not set.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the table cell.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | RowSpan | integer | the rowspan for the table cell, 0 if not set.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name for the table cell.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the table cell.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a table cell.
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table cell.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveTableCell
  • TTableHeaderCell
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableCellCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList » TControlCollection »
TTableCellCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection. (inherited from TControlCollection)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer. (inherited from TControlCollection)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TControlCollection)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableFooterRow

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTableRow »
TTableFooterRow
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | Cells | TTableCellCollection | list of TTableCell controls. (inherited from TTableRow)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TableSection | string | location of a row in a table.
RP | TagName | string | tag name for the table. (inherited from TTableRow)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TTableRow)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TTableRow)
P | createStyle | Creates a style object for the control. (inherited from TTableRow)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table row . (inherited from TTableRow)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableGateway

Namespace: System.Data.DataGateway
Inheritance: TComponent »
TTableGateway
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
RP | Command | TDataGatewayCommand | command builder and executor.
R | DbConnection | TDbConnection | database connection.
R | LastInsertId | mixed | last insert id, null if none is found.
 | TableInfo | {unknown} | .
 | TableName | {unknown} | .
Events
Name | Description
OnCreateCommand | Raised when a command is prepared and parameter binding is completed.
OnExecuteCommand | Raised when a command is executed and the result from the database was returned.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | count | Find the number of records.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | deleteAll | Delete records from the table with condition given by $where and binding values specified by $parameter argument.
 | deleteAllByPks | Alias for deleteByPk().
 | deleteByPk | Delete records by primary key.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | find | Find one single record that matches the criteria.
 | findAll | Accepts same parameters as find(), but returns TDbDataReader instead.
 | findAllByPks | Similar to findByPk(), but returns TDbDataReader instead.
 | findAllBySql | Execute arbituary sql command with binding parameters.
 | findByPk | Find one record using only the primary key or composite primary keys.
 | findBySql | Execute arbituary sql command with binding parameters.
P | getCriteria | Create a new TSqlCriteria object from a string $criteria.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initCommandBuilder | .
 | insert | Inserts a new record into the table.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | update | Updates the table with new name-value pair $data.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableGridLines

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTableGridLines
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableHeaderCell

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTableCell »
TTableHeaderCell
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AbbreviatedText | string | the abbr attribute of the HTML th element.
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CategoryText | string | the axis attribute of the HTML th element.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | ColumnSpan | integer | the columnspan for the table cell, 0 if not set. (inherited from TTableCell)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the table cell. (inherited from TTableCell)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableCell)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | RowSpan | integer | the rowspan for the table cell, 0 if not set. (inherited from TTableCell)
 | Scope | TTableHeaderScope | the scope of the cells that the header cell applies to.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name for the table header cell.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the table cell. (inherited from TTableCell)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableCell)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a table cell. (inherited from TTableCell)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object for the control. (inherited from TTableCell)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table cell. (inherited from TTableCell)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableHeaderRow

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTableRow »
TTableHeaderRow
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | Cells | TTableCellCollection | list of TTableCell controls. (inherited from TTableRow)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TableSection | string | location of a row in a table.
RP | TagName | string | tag name for the table. (inherited from TTableRow)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TTableRow)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TTableRow)
P | createStyle | Creates a style object for the control. (inherited from TTableRow)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table row . (inherited from TTableRow)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableHeaderScope

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTableHeaderScope
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableItemStyle

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TStyle »
TTableItemStyle
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | BackColor | string | the background color of the control. (inherited from TStyle)
 | BorderColor | string | the border color of the control. (inherited from TStyle)
 | BorderStyle | string | the border style of the control. (inherited from TStyle)
 | BorderWidth | string | the border width of the control. (inherited from TStyle)
 | CssClass | string | the CSS class of the control. (inherited from TStyle)
 | CustomStyle | string | the custom style of the control. (inherited from TStyle)
 | DisplayStyle | TDisplayStyle | display style. (inherited from TStyle)
R | Font | TFont | the font of the control. (inherited from TStyle)
 | ForeColor | string | the foreground color of the control. (inherited from TStyle)
 | Height | string | the height of the control. (inherited from TStyle)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the contents within the table item, defaults to THorizontalAlign::NotSet.
R | StyleFields | array | list of style fields. (inherited from TStyle)
 | VerticalAlign | TVerticalAlign | the vertical alignment of the contents within the table item, defaults to TVerticalAlign::NotSet.
 | Width | string | the width of the control. (inherited from TStyle)
 | Wrap | boolean | whether the content wraps within the table item.
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clearStyleField | Clears a single style field value; . (inherited from TStyle)
copyFrom | Copies the fields in a new style to this style.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getStyleField | a single style field value set via setStyleField. (inherited from TStyle)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasCssClass | true if CSS is set or empty. (inherited from TStyle)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasFont | true if font is set. (inherited from TStyle)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
hasStyleField | whether a style field has been defined by setStyleField. (inherited from TStyle)
mergeWith | Merges the style with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Sets the style attributes to default values.
setStyleField | Sets a single style field value. (inherited from TStyle)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableRow

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTableRow
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | Cells | TTableCellCollection | list of TTableCell controls.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TableSection | TTableRowSection | location of a row in a table.
RP | TagName | string | tag name for the table.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds object parsed from template to the control.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls .
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table row .
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveTableRow
  • TDataGridItem
  • TTableFooterRow
  • TTableHeaderRow
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableRowCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList » TControlCollection »
TTableRowCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection. (inherited from TControlCollection)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer. (inherited from TControlCollection)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TControlCollection)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableRowSection

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTableRowSection
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableStyle

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TStyle »
TTableStyle
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | BackColor | string | the background color of the control. (inherited from TStyle)
 | BackImageUrl | string | the URL of the background image for the table.
 | BorderCollapse | boolean | whether the table borders should be collapsed.
 | BorderColor | string | the border color of the control. (inherited from TStyle)
 | BorderStyle | string | the border style of the control. (inherited from TStyle)
 | BorderWidth | string | the border width of the control. (inherited from TStyle)
 | CellPadding | integer | cellpadding of the table.
 | CellSpacing | integer | cellspacing of the table.
 | CssClass | string | the CSS class of the control. (inherited from TStyle)
 | CustomStyle | string | the custom style of the control. (inherited from TStyle)
 | DisplayStyle | TDisplayStyle | display style. (inherited from TStyle)
R | Font | TFont | the font of the control. (inherited from TStyle)
 | ForeColor | string | the foreground color of the control. (inherited from TStyle)
 | GridLines | TTableGridLines | the grid line setting of the table.
 | Height | string | the height of the control. (inherited from TStyle)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the contents within the table, defaults to THorizontalAlign::NotSet.
R | StyleFields | array | list of style fields. (inherited from TStyle)
 | Width | string | the width of the control. (inherited from TStyle)
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clearStyleField | Clears a single style field value; . (inherited from TStyle)
copyFrom | Copies the fields in a new style to this style.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getStyleField | a single style field value set via setStyleField. (inherited from TStyle)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasCssClass | true if CSS is set or empty. (inherited from TStyle)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasFont | true if font is set. (inherited from TStyle)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
hasStyleField | whether a style field has been defined by setStyleField. (inherited from TStyle)
mergeWith | Merges the style with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Sets the style attributes to default values.
setStyleField | Sets a single style field value. (inherited from TStyle)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTarFileExtractor

Namespace: System.IO
TTarFileExtractor
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | _dirCheck | Check if a directory exists and create it (including parent dirs) if not.
P | _error | .
P | _extractList | .
P | _translateWinPath | .
 | extract | .
P | extractModify | This method extract all the content of the archive in the directory indicated by $p_path.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplate

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent »
TTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | ContextPath | string | context directory path.
R | Directive | array | name-value pairs declared in the directive.
R | HashCode | string | hash code that can be used to identify the template.
R | IncludedFiles | array | list of included external template files.
R | IsSourceTemplate | boolean | whether this template is a source template, i.
R | Items | array | the parsed template.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | TemplateFile | string | template file path if available, null otherwise.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | configureComponent | Configures a property of a non-control component.
P | configureControl | Configures a property/event of a control.
P | configureEvent | Configures an event for a control.
P | configureProperty | Configures a simple property for a component.
P | configureSubProperty | Configures a subproperty for a component.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | handleException | Handles template parsing exception.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | instantiateIn | Instantiates the template.
P | parse | Parses a template string.
P | parseAttribute | Parses a single attribute.
P | parseAttributes | Parses the attributes of a tag from a string.
P | parseTemplateProperty | .
P | preprocess | Preprocesses the template string by including external templates .
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | validateAttributes | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplateColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TTemplateColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | EditItemRenderer | string | the class name for the edit item cell renderer.
 | EditItemTemplate | ITemplate | the edit item template.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterTemplate | ITemplate | the footer template.
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderTemplate | ITemplate | the header template.
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
 | ItemRenderer | string | the class name for the item cell renderer.
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | ItemTemplate | ITemplate | the item template.
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
  • TActiveTemplateColumn
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplateControl

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl »
TTemplateControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control.
R | Master | TTemplateControl|null | master control associated with this control, null if none.
 | MasterClass | string | master class name (in namespace form).
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Template | ITemplate|null | Returns the template object associated with this control object.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls.
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders.
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control.
 | registerContentPlaceHolder | Registers a content placeholder to this template control.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TDataRenderer
  • TPage
  • TScaffoldBase
  • TTemplateControlInheritable
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplateControlInheritable

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl »
TTemplateControlInheritable
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | IsSourceTemplateControl | boolean | A source template control loads its template from external storage, such as file, db, rather than from within another template.
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | doCreateChildControlsFor | This method creates the cild controls for the given class .
 | doTemplateForClass | This method creates the template object for the given class .
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplateException

Namespace: System.Exceptions
Inheritance: TException » TSystemException » TConfigurationException »
TTemplateException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getLineNumber | the line number at which the template has error.
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTemplateFile | the template file that causes the exception.
 | getTemplateSource | the template source code that causes the exception.
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
 | setLineNumber | .
 | setTemplateFile | .
 | setTemplateSource | .
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplateManager

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TModule »
TTemplateManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLocalizedTemplate | Finds a localized template file.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getTemplateByClassName | Loads the template corresponding to the specified class name.
 | getTemplateByFileName | Loads the template from the specified file.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplatedWizardStep

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TView » TWizardStep »
TTemplatedWizardStep
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Active | boolean | whether this view is active. (inherited from TView)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowReturn | boolean | whether this step can be re-visited. (inherited from TWizardStep)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | ContentTemplate | ITemplate | the template for the content of the wizard step.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
R | NavigationContainer | TWizardNavigationContainer | the control containing the navigation.
 | NavigationTemplate | ITemplate | the template for displaying the navigation UI of a wizard step.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StepType | TWizardStepType | the wizard step type. (inherited from TWizardStep)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Title | string | the title for this step. (inherited from TWizardStep)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether this view is visible. (inherited from TView)
 | Wizard | TWizard | the wizard owning this step. (inherited from TWizardStep)
Events
Name | Description
OnActivate | Raises OnActivate event. (inherited from TView)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDeactivate | Raises OnDeactivate event. (inherited from TView)
OnInit | Ensures child controls are created.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
 | instantiateNavigationTemplate | Instantiates the navigation template if any.
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextAlign

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTextAlign
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextBox

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTextBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox.
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component.
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the TTextBox control.
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully.
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback.
RP | PostBackOptions | array | Gets the post back options for this textbox.
 | ReadOnly | boolean | whether the textbox is read only, default is false.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4.
R | SafeText | string | safe text content with javascript stripped off.
RP | SafeTextParser | mixed | safe text parser.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control.
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback.
R | ValidationPropertyValue | mixed | Returns the value to be validated.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box.
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnTextChanged | Raises OnTextChanged event.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode.
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for textbox.
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveTextBox
  • TColorPicker
  • TDatePicker
  • THtmlArea
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextBoxAutoCompleteType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTextBoxAutoCompleteType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextBoxMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTextBoxMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextHighlighter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextProcessor »
TTextHighlighter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableCopyCode | boolean | true will show "Copy Code" link.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
RP | HeaderTemplate | string | header template with "Copy code" link.
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | Language | string | language whose syntax is to be used for highlighting.
 | LineNumberStyle | TTextHighlighterLineNumberStyle | style of row number, Table by default.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowLineNumbers | boolean | whether to show line numbers in the highlighted result.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TabSize | integer | tab size.
RP | TagName | string | tag name of the panel.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | text to be processed. (inherited from TTextProcessor)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers css style for the highlighted result.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | HTML-decodes static text. (inherited from TTextProcessor)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | processText | Processes a text string.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
P | registerStyleSheet | Registers the stylesheet for presentation.
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | .
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body content. (inherited from TTextProcessor)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TMarkdown
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextHighlighterLineNumberStyle

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTextHighlighterLineNumberStyle
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextProcessor

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTextProcessor
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | text to be processed.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | HTML-decodes static text.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | processText | Processes a text string.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body content.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TTextHighlighter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextWriter

Namespace: System.IO
Inheritance: TComponent »
TTextWriter
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flush | Flushes the content that has been written.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
write | Writes a string.
writeLine | Writers a string and terminates it with a newline.
Derived classes
  • TCallbackResponseWriter
  • TOutputCacheTextWriterMulti
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTheme

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent »
TTheme
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | BasePath | string | the file path to the theme folder.
 | BaseUrl | string | the URL to the theme folder (without ending slash).
 | JavaScriptFiles | array | list of Javascript files (URL) in the theme.
 | Name | string | theme name.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | Skins | array | list of skins for the theme.
 | StyleSheetFiles | array | list of CSS files (URL) in the theme.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
applySkin | Applies the theme to a particular control.
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TThemeManager

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TModule »
TThemeManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | AvailableThemes | array | list of available theme names.
 | BasePath | string | the base path for all themes.
 | BaseUrl | string | the base URL for all themes.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ThemeClass | string | Theme class name in namespace format.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
getTheme | the theme retrieved.
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the module.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTimeTriggeredCallback

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TCallback »
TTimeTriggeredCallback
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveCallbackControl | standard callback options. (inherited from TCallback)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for TTimeTriggeredCallback.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options. (inherited from TCallback)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | Interval | float | seconds between callback requests.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StartTimerOnLoad | boolean | true to start the timer when page loads.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
RP | TriggerOptions | array | list of timer options for client-side.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested. (inherited from TCallback)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event. (inherited from TCallback)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Registers the javascript code for initializing the active control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | startTimer | Registers the javascript code to start the timer.
 | stopTimer | Registers the javascript code to stop the timer.
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTranslate

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TControl » TI18NControl »
TTranslate
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | Catalogue | string | Get the message catalogue.
 | Charset | string | Gets the charset. (inherited from TI18NControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | Culture | string | Get the specific culture for this control. (inherited from TI18NControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | Key | string | Get the key for message lookup.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parameters | TAttributeCollection | Returns the list of custom parameters.
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text to be localized/translated.
 | Trim | boolean | Trim the content or not.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getParameter | parameter value, null if parameter does not exist.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasParameter | whether the named parameter exists.
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removeParameter | Removes the named parameter.
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | renders the translated string.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setParameter | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | translateText | Translates the text with subsititution.
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TChoiceFormat
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTranslateParameter

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TControl »
TTranslateParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
 | Key | string | Get the parameter substitution key.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parameter | string | parameter contents.
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Trim | boolean | Trim the content or not.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Value | {unknown} | .
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTriggeredCallback

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TCallback »
TTriggeredCallback
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveCallbackControl | standard callback options. (inherited from TCallback)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options. (inherited from TCallback)
 | ControlID | string | The ID of the server control the trigger is bounded to.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TargetControl | string | target control client ID or html element ID if control is not found in hierarchy.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
RP | TriggerOptions | array | list of trigger callback options.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested. (inherited from TCallback)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event. (inherited from TCallback)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TEventTriggeredCallback
  • TValueTriggeredCallback
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUpdateMappedStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent » TMappedStatement »
TUpdateMappedStatement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TPreparedCommand | command to prepare SQL statements. (inherited from TMappedStatement)
R | ID | string | Name used to identify the TMappedStatement amongst the others. (inherited from TMappedStatement)
R | Manager | TSqlMapper | The SqlMap used by this MappedStatement. (inherited from TMappedStatement)
R | SqlString | {unknown} | . (inherited from TMappedStatement)
R | Statement | TSqlMapStatement | The SQL statment used by this MappedStatement. (inherited from TMappedStatement)
Events
Name | Description
OnExecuteQuery | Raise the execute query event. (inherited from TMappedStatement)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addResultMapGroupBy | ResultMap with GroupBy property. (inherited from TMappedStatement)
P | applyResultMap | Apply result mapping. (inherited from TMappedStatement)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | enquequePostSelect | Add nested result property to post select queue. (inherited from TMappedStatement)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | executeInsert | .
P | executePostSelect | Process 'select' result properties . (inherited from TMappedStatement)
 | executeQueryForList | .
 | executeQueryForMap | .
 | executeQueryForObject | .
P | executeSQLQueryLimit | Execute SQL Query with limits. (inherited from TMappedStatement)
P | executeSelectKey | Execute the select key statement, used to obtain last insert ID. (inherited from TMappedStatement)
 | executeUpdate | Execute an update statement. (inherited from TMappedStatement)
P | fillArrayResultMap | Retrieve the result map as an array. (inherited from TMappedStatement)
P | fillDefaultResultMap | Fill the result map using default settings. (inherited from TMappedStatement)
P | fillPropertyWithResultMap | Fills the property with result mapping results. (inherited from TMappedStatement)
P | fillResultArrayList | Apply the result to a TList or an array. (inherited from TMappedStatement)
P | fillResultClass | Fill the result using ResultClass, will creates new result object if required. (inherited from TMappedStatement)
P | fillResultMap | Fills the result object according to result mappings. (inherited from TMappedStatement)
P | fillResultObjectProperty | Apply the result to an object. (inherited from TMappedStatement)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPostGeneratedSelectKey | Gets the inserted row ID after executing an insert statement. (inherited from TMappedStatement)
P | getPostSelectKeys | Finds in the post select property the SQL statement primary selection keys. (inherited from TMappedStatement)
P | getPreGeneratedSelectKey | Gets the insert generated ID before executing an insert statement. (inherited from TMappedStatement)
P | getResultMapGroupKey | Gets the result 'group by' groupping key for each row. (inherited from TMappedStatement)
P | getScalarResult | Converts the first array value to scalar value of given type. (inherited from TMappedStatement)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initialGroupByResults | Empty the group by results cache. (inherited from TMappedStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | raiseRowDelegate | Raises delegate handler. (inherited from TMappedStatement)
 | runQueryForList | Executes the SQL and retuns a List of result objects. (inherited from TMappedStatement)
 | runQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. (inherited from TMappedStatement)
 | runQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter. (inherited from TMappedStatement)
P | setObjectProperty | Set a property of the result object with appropriate value. (inherited from TMappedStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TDeleteMappedStatement
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUri

Namespace: System.Web
Inheritance: TComponent »
TUri
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Fragment | string | fragment of the URI.
R | Host | string | hostname of the URI.
R | Password | string | password of the URI.
R | Path | string | path of the URI.
R | Port | integer | port number of the URI.
R | Query | string | query string of the URI.
R | Scheme | string | scheme of the URI, such as 'http', 'https', 'ftp', etc.
R | Uri | string | URI.
R | User | string | username of the URI.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUrlManager

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent » TModule »
TUrlManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
constructUrl | Constructs a URL that can be recognized by PRADO.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the module. (inherited from TModule)
parseUrl | Parses the request URL and returns an array of input parameters.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TUrlMapping
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUrlMapping

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent » TModule » TUrlManager »
TUrlMapping
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ConfigFile | string | external configuration file.
 | DefaultMappingClass | string | the default class of URL mapping patterns.
 | EnableCustomUrl | boolean | Returns a value indicating whether to enable custom constructUrl.
 | ID | string | id of this module. (inherited from TModule)
R | MatchingPattern | TUrlMappingPattern | the matched pattern, null if not found.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | UrlPrefix | string | the part that will be prefixed to the constructed URLs.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | constructUrl | Constructs a URL that can be recognized by PRADO.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
P | loadConfigFile | Initialize the module from configuration file.
P | loadUrlMappings | Load and configure each url mapping pattern.
 | parseUrl | Parses the request URL and returns an array of input parameters.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUrlMappingPattern

Namespace: System.Web
Inheritance: TComponent »
TUrlMappingPattern
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | CaseSensitive | boolean | whether the Pattern should be treated as case sensititve.
 | EnableCustomUrl | boolean | Returns a value indicating whether to use this pattern to construct URL.
R | IsWildCardPattern | boolean | whether this pattern is a wildcard pattern @since 3.
R | Manager | TUrlManager | the URL manager instance.
RP | ParameterizedPattern | string | Substitute the parameter key value pairs as named groupings in the regular expression matching pattern.
 | Parameters | TAttributeCollection | parameter key value pairs.
 | Pattern | string | url pattern to match.
 | RegularExpression | string | full regular expression mapping pattern.
 | SecureConnection | TUrlMappingPatternSecureConnection | the SecureConnection behavior.
 | ServiceID | string | service id.
 | ServiceParameter | string | service parameter, such as page class name.
 | UrlFormat | THttpRequestUrlFormat | the format of URLs.
 | UrlParamSeparator | string | separator used to separate GET variable name and value when URL format is Path.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | applySecureConnectionPrefix | Apply behavior of SecureConnection property by conditionaly prefixing URL with getBaseUrl() .
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | constructUrl | Constructs a URL using this pattern.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getPatternMatches | Uses URL pattern (or full regular expression if available) to match the given url path.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the pattern.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | supportCustomUrl | whether this pattern IS the one for constructing the URL with the specified GET items.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUrlMappingPatternSecureConnection

Namespace: System.Web
Inheritance: TEnumerable »
TUrlMappingPatternSecureConnection
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUser

Namespace: System.Security
Inheritance: TComponent »
TUser
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | IsGuest | boolean | if the user is a guest, defaults to true.
R | Manager | IUserManager | user manager.
 | Name | string | username, defaults to empty string.
 | Roles | array | list of roles that the user is of.
 | StateChanged | boolean | whether user session state is changed (i.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getState | Returns the value of a variable that is stored in user session.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | isInRole | whether the user is of this role.
 | loadFromString | the user object.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveToString | user data that is serialized and will be stored in session.
P | setState | Stores a variable in user session.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TDbUser
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUserManager

Namespace: System.Security
Inheritance: TComponent » TApplicationComponent » TModule »
TUserManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | GuestName | string | guest name, defaults to 'Guest'.
 | ID | string | id of this module. (inherited from TModule)
 | PasswordMode | TUserManagerPasswordMode | how password is stored, clear text, or MD5 or SHA1 hashed.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Roles | array | Returns an array of user role information.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | TUser | Returns a user instance given the user name.
 | UserFile | string | the full path to the file storing user/role information.
R | Users | array | Returns an array of all users.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
getUserFromCookie | Returns a user instance according to auth data stored in a cookie.
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the module.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
saveUserToCookie | Saves user auth data into a cookie.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
switchToGuest | Sets a user as a guest.
validateUser | Validates if the username and password are correct.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUserManagerPasswordMode

Namespace: System.Security
Inheritance: TEnumerable »
TUserManagerPasswordMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidationCompareOperator

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TValidationCompareOperator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidationDataType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TValidationDataType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
  • TRangeValidationDataType
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidationSummary

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TValidationSummary
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoUpdate | boolean | Gets the auto-update for this summary.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Get a list of options for the client-side javascript validation summary.
R | ClientSide | TClientSideValidationSummaryOptions | client-side validation summary event options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TValidationSummaryDisplayStyle | the style of displaying the error messages.
 | DisplayMode | TValidationSummaryDisplayMode | the mode of displaying error messages.
 | EnableClientScript | boolean | whether the TValidationSummary component updates itself using client-side script.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
RP | ErrorMessages | array | Get the list of validation error messages.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | HeaderText | string | the header text displayed at the top of the summary.
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScrollToSummary | boolean | whether scroll summary into viewport or not.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowAnchor | boolean | whether the validation summary should be anchored.
 | ShowMessageBox | boolean | whether the validation summary is displayed in a message box.
 | ShowSummary | boolean | whether the validation summary is displayed inline.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | .
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientScript | javascript validation summary event options.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
P | renderBulletList | Render the validation summary as a bullet list.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Overrides parent implementation by rendering TValidationSummary-specific presentation.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderHeaderOnly | Render the validation summary header text only.
P | renderJsSummary | Render the javascript for validation summary.
P | renderList | Render the validation summary as a simple list.
P | renderSingleParagraph | Render the validation summary as a paragraph.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidationSummaryDisplayMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TValidationSummaryDisplayMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidationSummaryDisplayStyle

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TValidationSummaryDisplayStyle
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidatorClientSide

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TClientSideOptions »
TValidatorClientSide
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | ObserveChanges | boolean | true to observe changes.
 | OnValidate | string | javascript code for client-side OnValidate event.
 | OnValidationError | string | javascript code for client-side OnError event.
 | OnValidationSuccess | string | javascript code for client-side OnSuccess event.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Ensure that the javascript statements are wrapped in a javascript function block as function(sender, parameter){ //code }. (inherited from TClientSideOptions)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidatorDisplayStyle

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TValidatorDisplayStyle
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValueTriggeredCallback

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TCallback » TTriggeredCallback »
TValueTriggeredCallback
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveCallbackControl | standard callback options. (inherited from TCallback)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for TEventTriggeredCallback.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options. (inherited from TCallback)
 | ControlID | string | The ID of the server control the trigger is bounded to. (inherited from TTriggeredCallback)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DecayRate | float | Gets the decay rate between callbacks.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | Interval | float | polling interval, 1 second default.
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PropertyName | string | The control property name to observe value changes.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TargetControl | string | target control client ID or html element ID if control is not found in hierarchy. (inherited from TTriggeredCallback)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
RP | TriggerOptions | array | list of timer options for client-side.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested. (inherited from TCallback)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event. (inherited from TCallback)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Registers the javascript code for initializing the active control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TVarDumper

Namespace: System.Util
TVarDumper
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | dump | Converts a variable into a string representation.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TVerticalAlign

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TVerticalAlign
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TView

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Active | boolean | whether this view is active.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether this view is visible.
Events
Name | Description
OnActivate | Raises OnActivate event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDeactivate | Raises OnDeactivate event.
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TWizardStep
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TViewCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList » TControlCollection »
TViewCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection. (inherited from TControlCollection)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer. (inherited from TControlCollection)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TControlCollection)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TViewStateDiff

Namespace: System.Web.UI.ActiveControls
TViewStateDiff
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
getDifference | view state changes, nullObject if no difference.
Derived classes
  • TMapCollectionDiff
  • TScalarDiff
  • TStyleDiff
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWebControl

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TWebControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control.
 | BorderColor | string | the border color of the control.
 | BorderStyle | string | the border style of the control.
 | BorderWidth | string | the border width of the control.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | .
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id.
R | Font | TFont | the font of the control.
 | ForeColor | string | the foreground color of the control.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information.
 | Height | string | the height of the control.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control.
 | TabIndex | integer | the tab index of the control.
RP | TagName | string | Returns the tag name used for this control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control.
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data.
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control.
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) .
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control .
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TAccordion
  • TAccordionView
  • TButton
  • TCheckBox
  • TDataBoundControl
  • TDataListItem
  • TFileUpload
  • THtmlElement
  • THyperLink
  • TImage
  • TInlineFrame
  • TJavascriptLogger
  • TKeyboard
  • TLabel
  • TLinkButton
  • TPager
  • TPanel
  • TReCaptcha
  • TSlider
  • TTabPanel
  • TTabView
  • TTable
  • TTableCell
  • TTableRow
  • TTextBox
  • TTextProcessor
  • TValidationSummary
  • TWizard
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWebControlAdapter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControlAdapter »
TWebControlAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Control | TControl | the control to which this adapter is attached. (inherited from TControlAdapter)
R | Page | TPage | the page that contains the attached control. (inherited from TControlAdapter)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Name | Description
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControlAdapter)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControlAdapter)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControlAdapter)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControlAdapter)
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createChildControls | Creates child controls for the attached control. (inherited from TControlAdapter)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
loadState | Loads additional persistent control state. (inherited from TControlAdapter)
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
render | Renders the control to which the adapter is attached.
renderBeginTag | Renders the openning tag for the attached control.
renderChildren | Renders the control's children. (inherited from TControlAdapter)
renderContents | Renders the body contents within the attached control tag.
renderEndTag | Renders the closing tag for the attached control.
saveState | Saves additional persistent control state. (inherited from TControlAdapter)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWebControlDecorator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TWebControlDecorator
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
PostContentsTemplate | TTemplate|null | the template before the close tag in the TWebControl.
PostContentsText | string | the text before the close tag in the TWebControl.
PostTagTemplate | TTemplate|null | the template after the close tag in the TWebControl.
PostTagText | string | the text before the close tag in the TWebControl.
PreContentsTemplate | TTemplate|null | the template after the open tag in the TWebControl.
PreContentsText | string | the text after the open tag in the TWebControl.
PreTagTemplate | TTemplate|null | the template before the open tag in the TWebControl.
PreTagText | string | gets the text before the open tag in the TWebControl.
UseState | boolean | if the templates in this decoration need state.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
ensureTemplateDecoration | This method places the templates around the open and close tag.
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
instantiate | this is a framework call.
raiseEvent | Raises an event. (inherited from TComponent)
renderPostContentsText | This method places the post contents text into the TTextWriter .
renderPostTagText | This method places the post tag text into the TTextWriter .
renderPreContentsText | This method places the pre contents text into the TTextWriter .
renderPreTagText | This method places the pre tag text into the TTextWriter .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizard

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TWizard
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | ActiveStep | TWizardStep | the currently active wizard step.
 | ActiveStepIndex | integer | the zero-based index of the active wizard step.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | CancelButtonStyle | TWizardNavigationButtonStyle | the style for the cancel button.
 | CancelDestinationUrl | string | the URL that the browser will be redirected to if the cancel button in the wizard is clicked.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | Decorator | TWebControlDecorator | . (inherited from TWebControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EnsureId | whether | this web control must have an id. (inherited from TWebControl)
R | FinishCompleteButtonStyle | TWizardNavigationButtonStyle | the style for the complete button in the finish wizard step.
 | FinishDestinationUrl | string | the URL that the browser will be redirected to if the wizard finishes.
R | FinishNavigation | TWizardNavigationContainer | container of the finish navigation.
 | FinishNavigationTemplate | ITemplate | navigation template for the finish step.
R | FinishPreviousButtonStyle | TWizardNavigationButtonStyle | the style for the previous button in the start wizard step.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
R | Header | TPanel | container of the wizard header.
R | HeaderStyle | TPanelStyle | the style for the header.
 | HeaderTemplate | ITemplate | template for wizard header.
 | HeaderText | string | header text.
 | Height | string | the height of the control. (inherited from TWebControl)
RP | History | TStack | history containing step indexes that were navigated before.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | MultiView | TMultiView | Returns the multiview that holds the wizard steps.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
R | NavigationButtonStyle | TStyle | the style common for all navigation buttons.
R | NavigationStyle | TPanelStyle | the style for the navigation panel.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowCancelButton | boolean | whether to display a cancel button in each wizard step.
 | ShowSideBar | boolean | whether to display a side bar that contains links to wizard steps.
R | SideBar | TPanel | container of the wizard side bar.
R | SideBarButtonStyle | TStyle | the style for the buttons displayed in the side bar.
R | SideBarStyle | TPanelStyle | the style for the side bar.
 | SideBarTemplate | ITemplate | template for the side bar.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
R | StartNavigation | TWizardNavigationContainer | container of the start navigation.
 | StartNavigationTemplate | ITemplate | navigation template for the start step.
R | StartNextButtonStyle | TWizardNavigationButtonStyle | the style for the next button in the start wizard step.
R | StepContent | TPanel | container of the wizard step content.
R | StepNavigation | TWizardNavigationContainer | container of the step navigation.
 | StepNavigationTemplate | ITemplate | navigation template for internal steps.
R | StepNextButtonStyle | TWizardNavigationButtonStyle | the style for the next button in each internal wizard step.
R | StepPreviousButtonStyle | TWizardNavigationButtonStyle | the style for the previous button in the start wizard step.
R | StepStyle | TPanelStyle | the style for each internal wizard step.
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name for the wizard.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
 | UseDefaultLayout | boolean | whether to use default layout to arrange side bar and the rest wizard components.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
R | WizardSteps | TWizardStepCollection | collection of wizard steps.
Events
Name | Description
OnActiveStepChanged | Raises OnActiveStepChanged event.
OnCancelButtonClick | Raises OnCancelButtonClick event.
OnCompleteButtonClick | Raises OnCompleteButtonClick event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Creates the child controls of the wizard.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnNextButtonClick | Raises OnNextButtonClick event.
OnPreRender | If your subclass overrides the onPreRender method be sure to call this method through parent::onPreRender($param); so your sub-class can be decorated, among other things. (inherited from TWebControl)
OnPreviousButtonClick | Raises OnPreviousButtonClick event.
OnSideBarButtonClick | Raises OnSideBarButtonClick event.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds TWizardStep objects into step collection.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | addedWizardStep | Adds a wizard step to the multiview.
P | allowNavigationToPreviousStep | whether navigation to the previous step is allowed.
P | allowNavigationToStep | whether navigation to the specified step is allowed.
P | applyControlProperties | Applies various properties to the components of wizard.
P | applyHeaderProperties | Applies properties to the wizard header.
P | applyNavigationProperties | Apply properties to various navigation panels.
P | applySideBarProperties | Applies properties to the wizard sidebar.
P | applyStepContentProperties | Applies properties to the wizard step content.
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Handles bubbled events.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls within the wizard.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createFinishNavigation | Creates finish navigation panel.
P | createHeader | Creates the wizard header.
P | createNavigation | Creates navigation panel.
P | createSideBar | Creates the wizard side bar.
P | createStartNavigation | Creates start navigation panel.
P | createStepContent | Creates wizard step content.
P | createStepNavigation | Creates step navigation panel.
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataListItemCommand | Event handler for sidebar datalist's OnItemCommand event.
 | dataListItemDataBound | Event handler for sidebar datalist's OnItemDataBound event.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPreviousStepIndex | Determines the index of the previous step based on history.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
P | getStepType | Determines the type of the specified wizard step.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | removedWizardStep | Removes a wizard step from the multiview.
 | render | Renders the wizard.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | requiresControlsRecreation | Indicates the wizard needs to recreate all child controls.
P | reset | Clears up everything within the wizard.
 | saveState | Saves the current active step index into history.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
 | wizardStepsChanged | Updates the sidebar datalist if any.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardFinishNavigationTemplate

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TWizardNavigationTemplate »
TWizardFinishNavigationTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Wizard | TWizard | the wizard owning this template. (inherited from TWizardNavigationTemplate)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createNavigationButton | Creates a navigation button. (inherited from TWizardNavigationTemplate)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | instantiateIn | Instantiates the template.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardNavigationButtonStyle

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TStyle »
TWizardNavigationButtonStyle
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | BackColor | string | the background color of the control. (inherited from TStyle)
 | BorderColor | string | the border color of the control. (inherited from TStyle)
 | BorderStyle | string | the border style of the control. (inherited from TStyle)
 | BorderWidth | string | the border width of the control. (inherited from TStyle)
 | ButtonText | string | button caption.
 | ButtonType | TWizardNavigationButtonType | button type.
 | CssClass | string | the CSS class of the control. (inherited from TStyle)
 | CustomStyle | string | the custom style of the control. (inherited from TStyle)
 | DisplayStyle | TDisplayStyle | display style. (inherited from TStyle)
R | Font | TFont | the font of the control. (inherited from TStyle)
 | ForeColor | string | the foreground color of the control. (inherited from TStyle)
 | Height | string | the height of the control. (inherited from TStyle)
 | ImageUrl | string | image URL for the image button.
R | StyleFields | array | list of style fields. (inherited from TStyle)
 | Width | string | the width of the control. (inherited from TStyle)
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer. (inherited from TStyle)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
apply | Applies this style to the specified button .
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clearStyleField | Clears a single style field value; . (inherited from TStyle)
copyFrom | Copies the fields in a new style to this style.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getStyleField | a single style field value set via setStyleField. (inherited from TStyle)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasCssClass | true if CSS is set or empty. (inherited from TStyle)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasFont | true if font is set. (inherited from TStyle)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
hasStyleField | whether a style field has been defined by setStyleField. (inherited from TStyle)
mergeWith | Merges the style with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Sets the style attributes to default values.
setStyleField | Sets a single style field value. (inherited from TStyle)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardNavigationButtonType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TWizardNavigationButtonType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardNavigationContainer

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TWizardNavigationContainer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | CancelButton | mixed | the cancel button.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | CompleteButton | mixed | the complete button.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NextButton | mixed | the next button.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PreviousButton | mixed | the previous button.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardNavigationEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TWizardNavigationEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | CancelNavigation | boolean | whether navigation to the next step should be canceled.
R | CurrentStepIndex | integer | the zero-based index of the currently active step.
 | NextStepIndex | integer | the zero-based index of the next step.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardNavigationTemplate

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TWizardNavigationTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Wizard | TWizard | the wizard owning this template.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createNavigationButton | Creates a navigation button.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | instantiateIn | Instantiates the template.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TWizardFinishNavigationTemplate
  • TWizardStartNavigationTemplate
  • TWizardStepNavigationTemplate
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardSideBarListItemTemplate

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TWizardSideBarListItemTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
instantiateIn | Instantiates the template.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardSideBarTemplate

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TWizardSideBarTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
instantiateIn | Instantiates the template.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardStartNavigationTemplate

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TWizardNavigationTemplate »
TWizardStartNavigationTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Wizard | TWizard | the wizard owning this template. (inherited from TWizardNavigationTemplate)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createNavigationButton | Creates a navigation button. (inherited from TWizardNavigationTemplate)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | instantiateIn | Instantiates the template.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardStep

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TView »
TWizardStep
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Active | boolean | whether this view is active. (inherited from TView)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowReturn | boolean | whether this step can be re-visited.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StepType | TWizardStepType | the wizard step type.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Title | string | the title for this step.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether this view is visible. (inherited from TView)
 | Wizard | TWizard | the wizard owning this step.
Events
Name | Description
OnActivate | Raises OnActivate event. (inherited from TView)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDeactivate | Raises OnDeactivate event. (inherited from TView)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TCompleteWizardStep
  • TTemplatedWizardStep
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardStepCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
TWizardStepCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardStepNavigationTemplate

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TWizardNavigationTemplate »
TWizardStepNavigationTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Wizard | TWizard | the wizard owning this template. (inherited from TWizardNavigationTemplate)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createNavigationButton | Creates a navigation button. (inherited from TWizardNavigationTemplate)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | instantiateIn | Instantiates the template.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardStepType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TWizardStepType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | . (inherited from TEnumerable)
key | . (inherited from TEnumerable)
next | . (inherited from TEnumerable)
rewind | . (inherited from TEnumerable)
valid | . (inherited from TEnumerable)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TXCache

Namespace: System.Caching
Inheritance: TComponent » TApplicationComponent » TModule » TCache »
TXCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
 | KeyPrefix | string | a unique prefix for the keys of cached values. (inherited from TCache)
 | PrimaryCache | boolean | whether this cache module is used as primary/system cache. (inherited from TCache)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | add | Stores a value identified by a key into cache if the cache does not contain this key. (inherited from TCache)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addValue | Stores a value identified by a key into cache if the cache does not contain this key.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes a value with the specified key from cache . (inherited from TCache)
P | deleteValue | Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Deletes all values from cache.
P | generateUniqueKey | a key generated from the provided key which ensures the uniqueness across applications. (inherited from TCache)
 | get | Retrieves a value from cache with a specified key. (inherited from TCache)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValue | Retrieves a value from cache with a specified key.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | offsetExists | Returns whether there is a cache entry with a specified key. (inherited from TCache)
 | offsetGet | Retrieves the value from cache with a specified key. (inherited from TCache)
 | offsetSet | Stores the value identified by a key into cache. (inherited from TCache)
 | offsetUnset | Deletes the value with the specified key from cache This method is required by the interface ArrayAccess. (inherited from TCache)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | set | Stores a value identified by a key into cache. (inherited from TCache)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setValue | Stores a value identified by a key in cache.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TXmlDocument

Namespace: System.Xml
Inheritance: TComponent » TXmlElement »
TXmlDocument
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Attributes | TMap | list of attributes. (inherited from TXmlElement)
R | Elements | TXmlElementList | list of child elements. (inherited from TXmlElement)
 | Encoding | string | encoding of this XML document.
R | HasAttribute | boolean | true if this element has attributes. (inherited from TXmlElement)
R | HasElement | boolean | true if this element has child elements. (inherited from TXmlElement)
 | Parent | TXmlElement | parent element of this element. (inherited from TXmlElement)
 | TagName | string | tag-name of this element. (inherited from TXmlElement)
 | Value | string | text enclosed between opening and closing tag of this element. (inherited from TXmlElement)
 | Version | string | version of this XML document.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getAttribute | the attribute specified by the name, null if no such attribute. (inherited from TXmlElement)
getElementByTagName | the first child element that has the specified tag-name, null if not found. (inherited from TXmlElement)
getElementsByTagName | list of all child elements that have the specified tag-name. (inherited from TXmlElement)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
loadFromFile | Loads and parses an XML document.
loadFromString | Loads and parses an XML string.
raiseEvent | Raises an event. (inherited from TComponent)
saveToFile | Saves this XML document as an XML file.
saveToString | Saves this XML document as an XML string .
setAttribute | . (inherited from TXmlElement)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toString | string representation of this element. (inherited from TXmlElement)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TXmlElement

Namespace: System.Xml
Inheritance: TComponent »
TXmlElement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Attributes | TMap | list of attributes.
R | Elements | TXmlElementList | list of child elements.
R | HasAttribute | boolean | true if this element has attributes.
R | HasElement | boolean | true if this element has child elements.
 | Parent | TXmlElement | parent element of this element.
 | TagName | string | tag-name of this element.
 | Value | string | text enclosed between opening and closing tag of this element.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getAttribute | the attribute specified by the name, null if no such attribute.
getElementByTagName | the first child element that has the specified tag-name, null if not found.
getElementsByTagName | list of all child elements that have the specified tag-name.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setAttribute | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toString | string representation of this element.
Derived classes
  • TXmlDocument
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TXmlElementList

Namespace: System.Xml
Inheritance: TComponent » TList »
TXmlElementList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TXmlElement | owner of this list.
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAfter | Finds the base item. (inherited from TList)
insertAt | Inserts an item at the specified position.
insertBefore | Finds the base item. (inherited from TList)
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TXmlRpcClient

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TRpcClient »
TXmlRpcClient
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | IsNotification | boolean | whether requests are considered to be notifications (completely ignoring the response). (inherited from TRpcClient)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ServerUrl | string | url of the RPC server. (inherited from TRpcClient)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
S | create | Creates an instance of TXmlRpcClient .
P | createStreamContext | Creates a stream context resource . (inherited from TRpcClient)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | encodeRequest | .
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | performRequest | Performs the actual request . (inherited from TRpcClient)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TXmlRpcProtocol

Namespace: System.Web.Services
Inheritance: TRpcProtocol »
TXmlRpcProtocol
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addMethod | Registers a new RPC method and handler details .
callApiMethod | Calls the callback handler for the given method . (inherited from TRpcProtocol)
callMethod | Handles the RPC request .
createErrorResponse | Turns the given exception into an XML RPC fault .
createResponseHeaders | Sets the correct response headers .
decode | Decodes XML encoded data into PHP data .
encode | Encodes PHP data into XML data .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TXmlTransform

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TXmlTransform
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DocumentContent | string | XML data.
 | DocumentPath | string | The path to the XML document.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSkinApplied | {unknown} | . (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parameters | TAttributeCollection | Returns the list of parameters to be applied to the transform.
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | TransformContent | string | XML style sheet as string.
 | TransformPath | string | The path to the XML style sheet.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Performs XSL transformation and render the output.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of Translation

Namespace: System.I18N
Inheritance: TComponent »
Translation
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
S | formatter | Get the static formatter from this component.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
S | init | Initialize the TTranslate translation components.
 | raiseEvent | Raises an event. (inherited from TComponent)
S | saveMessages | Save untranslated messages to the catalogue.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/DragDrop/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90

<com:TContent id="body">
<style>
.cart {
    border: 1px solid #E8A400;
    background-color: white;
    padding: 8px;
    width: 500px;
    height: 150px;
}

.cart-hover {
    background-color: #E8A400;
}

.cart-items {
    width: 30px;
    height: 30px;
}

.products {
    float: left;
    width: 100px;
    height: 100px;
    margin-right: 10px;
}

.draggable {
    cursor: move
}

.removable {
}

.trash {
    width: 50px;
    height: 50px;
    border: 1px solid black;
}

.trash-hover {
    background-image: url(<%~ images/trash.png%>);
}

</style>
<h1>Drag &amp; Drop demo !</h1>

<h2>Product List :</h2>

<div style="margin-bottom: 20px; height: 120px">

<com:TRepeater Id="ProductList" DataKeyField="ProductId">
    <prop:ItemTemplate>
        <com:TDraggable CssClass="products draggable" >
        <com:TImage ImageUrl=<%#$this->Data['ProductImageUrl']%> />
        </com:TDraggable>
    </prop:ItemTemplate>
</com:TRepeater>
</div>
<h2>Your shopping cart :</h2>
<com:TDropContainer CssClass="cart" Id="cart"
    AcceptCssClass="draggable"
    HoverCssClass="cart-hover"
    OnDrop="addItemToCart"
    OnCallback="redrawCart"
    >
    <com:TRepeater id="ShoppingList" DataKeyField="ProductId">
        <prop:EmptyTemplate>
            Your shopping cart is empty, please add some items !
        </prop:EmptyTemplate>
        <prop:ItemTemplate>
            <com:TDraggable CssClass="removable"
                Revert="true"
                Handle="<%=$this->itemImage->ClientId%>"
                Ghosting=<%#($this->Data['ProductCount'] > 1)%>
                >
            <com:TImage id="itemImage" CssClass="cart-items" Style="cursor:move" ImageUrl=<%#$this->Data['ProductImageUrl']%>/>
            <com:TLabel id="itemTitle" Text=<%#$this->Data['ProductTitle']%>/>
            <com:TLabel id="itemCount" Text="(<%#$this->Data['ProductCount']%>)" />
            </com:TDraggable>
        </prop:ItemTemplate>
    </com:TRepeater>
</com:TDropContainer>
<h2>Remove Items from cart by dropping them here</h2>
<com:TDropContainer CssClass="trash" id="trash"
    AcceptCssClass="removable"
    OnDrop="removeItemFromCart"
    OnCallback="redrawCart"
    HoverCssClass="trash-hover"
/>
</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/DragDrop/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112

<?php

prado::using ('System.Web.UI.ActiveControls.*');

class Home extends TPage
{
    public function onInit ($param)
    {
        parent::onInit($param);
        if (!$this->getIsPostBack() && !$this->getIsCallBack())
        {

            $this->populateProductList();
            $this->populateShoppingList();
        }
    }

    private function getProductData ()
    {
        return array (
            array (
                'ProductId' => 'Product1',
                'ProductImageUrl' => $this->publishAsset('images/product1.png'),
                'ProductTitle' => 'Cup'
            ),
            array (
                'ProductId' => 'Product2',
                'ProductImageUrl' => $this->publishAsset('images/product2.png'),
                'ProductTitle' => 'T-Shirt'
            )
        );
    }

    private function getProduct ($key)
    {
        foreach ($this->getProductData() as $product)
            if ($product['ProductId']==$key) return $product;
        return null;
    }

    protected function populateProductList ()
    {
        $this->ProductList->DataSource=$this->getProductData();
        $this->ProductList->Databind();
    }

    protected function populateShoppingList ()
    {
        $this->ShoppingList->DataSource=$this->getShoppingListData();
        $this->ShoppingList->Databind();

    }

    public function getShoppingListData ()
    {
        return $this->getViewState('ShoppingList', array ());
    }

    public function setShoppingListData ($value)
    {
        $this->setViewState('ShoppingList', TPropertyValue::ensureArray($value), array ());
    }

    public function addItemToCart ($sender, $param)
    {
        $control=$param->getDroppedControl();
        // Get the Key from the repeater item
        $item=$control->getNamingContainer();
        $key=$this->ProductList->getDataKeys()->itemAt($item->getItemIndex());
        $product=$this->getProduct($key);
        $shoppingList=$this->getShoppingListData();
        if (isset ($shoppingList[$key]))
        {
            // Already an item of this type, increment counter
            $shoppingList[$key]['ProductCount']++;
        }
        else
        {
            // Add an item to the shopping list
            $shoppingList[$key]=$product;
            $shoppingList[$key]['ProductCount']=1;
        }
        $this->setShoppingListData($shoppingList);

    }

    public function removeItemFromCart ($sender, $param)
    {
        $control=$param->getDroppedControl();
        $item=$control->getNamingContainer();
        $key=$this->ShoppingList->getDataKeys()->itemAt($item->getItemIndex());
        $shoppingList=$this->getShoppingListData();
        if (isset($shoppingList[$key]))
        {
            if ($shoppingList[$key]['ProductCount'] > 1)
                $shoppingList[$key]['ProductCount'] --;
            else
                unset($shoppingList[$key]);
        }
        $this->setShoppingListData($shoppingList);

    }

    public function redrawCart ($sender, $param)
    {
        $this->populateShoppingList();
        $this->cart->render($param->NewWriter);

    }
}
?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47

<com:TContent ID="body">
<h1>TActiveButton Samples (AJAX)</h1>

<table class="sampletable">

<tr><td class="samplenote">
A click button with <tt>OnClick</tt> event handler:
</td><td class="sampleaction">
<com:TActiveButton
    Text="click me"
    OnClick="buttonClicked" />
</td></tr>

<tr><td class="samplenote">
A command button with <tt>OnCallback</tt>:
</td><td class="sampleaction">
<com:TActiveButton
    Text="click me"
    OnCommand="buttonClicked"
    CommandName="test"
    ActiveControl.CallbackParameter="value"
    CommandParameter="value"
    OnCallback="buttonCallback"
    />
</td></tr>

<tr><td class="samplenote">
A button causing validation with <tt>OnCallback</tt>:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TActiveButton
    Text="submit"
    OnClick="buttonClicked"
    OnCallback="buttonCallback"
    ValidationGroup="Group" />
</td></tr>

</table>

<com:TJavascriptLogger />
</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

<?php

// $Id: Home.php 1405 2006-09-10 01:03:56Z wei $
class Home extends TPage
{
    public function buttonClicked($sender, $param)
    {
        if($param instanceof TCommandEventParameter)
            $sender->Text="Name: {$param->CommandName}, Param: {$param->CommandParameter}";
        else
            $sender->Text="I'm clicked";
    }

    public function buttonCallback($sender, $param)
    {
        $sender->Text .= ' using callback';
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveCheckBox/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76

<com:TContent ID="body">
<h1>TActiveCheckBox Samples (AJAX)</h1>

<table class="sampletable">

<tr><td class="samplenote">
An active checkbox with <tt>OnCallback</tt>:
</td><td class="sampleaction">
<com:TActiveCheckBox
    AutoPostBack="true"
    Text="click me"
    OnCheckedChanged="checkboxClicked"
    OnCallback="checkboxCallback"
    />
</td></tr>

<tr><td class="samplenote">
A checkbox causing validation on a textbox:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TActiveCheckBox
    Text="submit"
    ValidationGroup="Group"
    OnCheckedChanged="checkboxClicked"
    OnCallback="checkboxCallback"
    />
</td></tr>

<tr><td class="samplenote">
A checkbox validated by a required field validator:
</td><td class="sampleaction">
<com:TActiveCheckBox
    ID="CheckBox"
    Text="Consent"
    AutoPostBack="false"
    OnCheckedChanged="checkboxClicked"
    ValidationGroup="Group2"
    />
<com:TActiveButton Text="Submit" ValidationGroup="Group2" />
<com:TRequiredFieldValidator
    ControlToValidate="CheckBox"
    Display="Dynamic"
    ErrorMessage="You must consent."
    ValidationGroup="Group2"
    />
</td></tr>

<tr><td class="samplenote">
A checkbox validated by a required field validator:
</td><td class="sampleaction">
<com:TActiveCheckBox
    ID="CheckBox2"
    Text="Agree"
    Checked="true"
    OnCheckedChanged="checkboxClicked"
    ValidationGroup="Group3"
    />
<com:TRequiredFieldValidator
    ControlToValidate="CheckBox2"
    Display="Dynamic"
    ErrorMessage="You must agree."
    ValidationGroup="Group3"
    />
</td></tr>

</table>

<com:TJavascriptLogger />

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveCheckBox/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<?php
// $Id: Home.php 1405 2006-09-10 01:03:56Z wei $
class Home extends TPage
{
    public function checkboxClicked($sender,$param)
    {
        $sender->Text= $sender->ClientID . " clicked";
    }

    public function checkboxCallback($sender, $param)
    {
        $sender->Text .= ' using callback';
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveCheckBoxList/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66

<com:TContent ID="body">

<h1>TActiveCheckBoxList Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Check box list with default settings:
</td>
<td class="sampleaction">
<com:TActiveCheckBoxList>
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TActiveCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list's behavior upon callback:
</td>
<td class="sampleaction">
<com:TActiveCheckBoxList ID="CheckBoxList" OnCallback="selectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Enabled="false" />
  <com:TListItem Value="value 5" Text="item 5" Selected="true" />
</com:TActiveCheckBoxList>
<br/>
<com:TActiveLabel ID="SelectionResult" ForeColor="red" />
</td>
</tr>

</table>

<h2>CheckBox List with Validation</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
CheckBox list causing validation:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    ErrorMessage="You must enter a value"
    Display="Dynamic"
    ValidationGroup="Group2"
    />
<com:TActiveCheckBoxList ValidationGroup="Group2">
  <com:TListItem Text="Agree" />
  <com:TListItem Text="Disagree" />
</com:TActiveCheckBoxList>
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveCheckBoxList/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

<?php

class Home extends TPage
{
    protected function collectSelectionResult($input,$output)
    {
        $indices=$input->SelectedIndices;
        $result='';
        foreach($indices as $index)
        {
            $item=$input->Items[$index];
            $result.="(Index: $index, Value: $item->Value, Text: $item->Text)";
        }
        if($result==='')
            $output->Text='Your selection is empty.';
        else
            $output->Text='Your selection is: '.$result;
    }

    public function selectionChanged($sender,$param)
    {
        $this->collectSelectionResult($this->CheckBoxList,$this->SelectionResult);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveCustomValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<com:TContent ID="body">
<h1>TActiveCustomValidator Samples (AJAX)</h1>

<table class="sampletable">

<tr><td class="samplenote">
Custom validator using callbacks:
</td><td class="sampleaction">
<com:TTextBox ID="textbox1" />
<com:TActiveCustomValidator
    ID="validator1"
    ControlToValidate="textbox1"
    ErrorMessage="Please enter 'Prado'"
    OnServerValidate="validator1_onvalidate" />
<com:TActiveButton ID="button1" Text="Submit!" />
</td></tr>
</table>

<com:TJavascriptLogger />

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveCustomValidator/Home.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Home extends TPage
{
    public function validator1_onvalidate($sender, $param)
    {
        $param->IsValid = $this->textbox1->Text == 'Prado';
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/ActiveControls/Samples/TActiveDataGrid/Sample1.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<com:TContent ID="body">

<h1>TActiveDataGrid Sample 1</h1>
<h2>Using Automatically Generated Columns</h2>

<com:TActiveButton ID="button1" Text="click me" OnCallback="buttonClicked" />
<com:TActiveDataGrid
    ID="DataGrid"
    EnableViewState="false"
    CellPadding="2"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    />

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/ActiveControls/Samples/TActiveDataGrid/Sample1.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37

<?php

class Sample1 extends TPage
{
    protected function getData()
    {
        return array(
            array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
            array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>false),
            array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>true),
            array('id'=>'ITN008','name'=>'CDRW drive','quantity'=>1,'price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','quantity'=>2,'price'=>10.00,'imported'=>false),
            array('id'=>'ITN010','name'=>'Video camera','quantity'=>20,'price'=>30.00,'imported'=>true),
            array('id'=>'ITN011','name'=>'Card reader','quantity'=>10,'price'=>24.00,'imported'=>true),
            array('id'=>'ITN012','name'=>'Floppy drive','quantity'=>50,'price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','quantity'=>25,'price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','quantity'=>15,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','quantity'=>50,'price'=>5.00,'imported'=>false),
            array('id'=>'ITN016','name'=>'Network cable','quantity'=>40,'price'=>8.00,'imported'=>true),
            array('id'=>'ITN017','name'=>'Case','quantity'=>8,'price'=>65.00,'imported'=>false),
            array('id'=>'ITN018','name'=>'Surge protector','quantity'=>45,'price'=>15.00,'imported'=>false),
            array('id'=>'ITN019','name'=>'Speaker','quantity'=>35,'price'=>65.00,'imported'=>false),
        );
    }

    public function buttonClicked($sender, $param)
    {
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/ActiveControls/Samples/TActiveDataGrid/Sample2.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64

<com:TContent ID="body">

<h1>TActiveDataGrid Sample 2</h1>
<h2>Using Manually Specified Columns</h2>

<com:TActiveDataGrid
    Width="700px"
    CellPadding="2"
    ID="DataGrid"
    AutoGenerateColumns="false"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF">

    <com:TActiveHyperLinkColumn
        HeaderText="Book Title"
        DataTextField="title"
        DataNavigateUrlField="ISBN"
        DataNavigateUrlFormatString="http://www.amazon.com/gp/product/%s"
        Target="_blank"
        />
    <com:TActiveBoundColumn
        HeaderText="Publisher"
        DataField="publisher"
        />
    <com:TActiveBoundColumn
        ItemStyle.HorizontalAlign="Right"
        ItemStyle.Wrap="false"
        ItemStyle.Font.Italic="false"
        ItemStyle.ForeColor="green"
        HeaderText="Price"
        DataField="price"
        DataFormatString="$%.2f"
        />
    <com:TActiveCheckBoxColumn
        HeaderText="In-stock"
        HeaderStyle.Wrap="false"
        DataField="instock"
        />
    <com:TActiveTemplateColumn>
        <prop:HeaderTemplate>Rating</prop:HeaderTemplate>
        <prop:ItemTemplate>
        <img src="images/star<%#$this->Parent->DataItem['rating']%>.gif" alt="" />
        </prop:ItemTemplate>
    </com:TActiveTemplateColumn>
</com:TActiveDataGrid>

<com:TPanel GroupingText="Column Visibility" Width="200px">

<com:TActiveCheckBoxList
     AutoPostBack="true"
     OnSelectedIndexChanged="toggleColumnVisibility">
    <com:TListItem Text="Book Title" Selected="true" />
    <com:TListItem Text="Publisher" Selected="true" />
    <com:TListItem Text="Price" Selected="true" />
    <com:TListItem Text="In-stock" Selected="true" />
    <com:TListItem Text="Rating" Selected="true" />
</com:TActiveCheckBoxList>

</com:TPanel>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/ActiveControls/Samples/TActiveDataGrid/Sample2.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86

<?php

class Sample2 extends TPage
{
    protected function getData()
    {
        return array(
            array(
                'ISBN'=>'0596007124',
                'title'=>'Head First Design Patterns',
                'publisher'=>'O\'Reilly Media, Inc.',
                'price'=>29.67,
                'instock'=>true,
                'rating'=>4,
            ),
            array(
                'ISBN'=>'0201633612',
                'title'=>'Design Patterns: Elements of Reusable Object-Oriented Software',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>47.04,
                'instock'=>true,
                'rating'=>5,
            ),
            array(
                'ISBN'=>'0321247140',
                'title'=>'Design Patterns Explained : A New Perspective on Object-Oriented Design',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>37.49,
                'instock'=>true,
                'rating'=>4,
            ),
            array(
                'ISBN'=>'0201485672',
                'title'=>'Refactoring: Improving the Design of Existing Code',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>47.14,
                'instock'=>true,
                'rating'=>3,
            ),
            array(
                'ISBN'=>'0321213351',
                'title'=>'Refactoring to Patterns',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>38.49,
                'instock'=>true,
                'rating'=>2,
            ),
            array(
                'ISBN'=>'0735619670',
                'title'=>'Code Complete',
                'publisher'=>'Microsoft Press',
                'price'=>32.99,
                'instock'=>false,
                'rating'=>4,
            ),
            array(
                'ISBN'=>'0321278658',
                'title'=>'Extreme Programming Explained : Embrace Change',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>34.99,
                'instock'=>true,
                'rating'=>3,
            ),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack && !$this->IsCallBack)
        {
            $this->DataGrid->DataSource=$this->Data;
            $this->DataGrid->dataBind();
        }
    }

    public function toggleColumnVisibility($sender,$param)
    {
        foreach($this->DataGrid->Columns as $index=>$column)
            $column->Visible=$sender->Items[$index]->Selected;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/ActiveControls/Samples/TActiveDataGrid/Sample3.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83

<com:TContent ID="body">

<h1>TActiveDataGrid Sample 3</h1>
<h2>Interacting with TActiveDataGrid</h2>

<com:TActiveDataGrid
    Width="800px"
    CellPadding="2"
    ID="DataGrid"
    DataKeyField="ISBN"
    AutoGenerateColumns="false"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    EditItemStyle.BackColor="lightyellow"
    OnItemCreated="itemCreated"
    OnEditCommand="editItem"
    OnUpdateCommand="saveItem"
    OnCancelCommand="cancelItem"
    OnDeleteCommand="deleteItem"
    >

    <com:TActiveBoundColumn
        ID="BookTitleColumn"
        HeaderText="Book Title"
        HeaderStyle.Width="400px"
        DataField="title"
        />
    <com:TActiveBoundColumn
        ID="PublisherColumn"
        HeaderText="Publisher"
        HeaderStyle.Width="150px"
        DataField="publisher"
        />
    <com:TActiveBoundColumn
        ID="PriceColumn"
        ItemStyle.HorizontalAlign="Right"
        ItemStyle.Wrap="false"
        ItemStyle.Font.Italic="false"
        ItemStyle.ForeColor="green"
        HeaderText="Price"
        HeaderStyle.Width="70px"
        DataField="price"
        DataFormatString="$%.2f"
        />
    <com:TActiveCheckBoxColumn
        ID="InStockColumn"
        HeaderText="In-stock"
        DataField="instock"
        />
    <com:TActiveDropDownListColumn
        ID="RatingColumn"
        HeaderText="Rating"
        DataTextField="rating"
        >
        <prop:DataTextFormatString><img src="images/star%s.gif" alt="" /></prop:DataTextFormatString>
        <com:TListItem Value="1" />
        <com:TListItem Value="2" />
        <com:TListItem Value="3" />
        <com:TListItem Value="4" />
        <com:TListItem Value="5" />
    </com:TActiveDropDownListColumn>
    <com:TActiveEditCommandColumn
        HeaderText="Edit"
        HeaderStyle.Width="100px"
        UpdateText="Save"
        ItemStyle.HorizontalAlign="Center"
        ItemStyle.Font.Italic="false"
        />
    <com:TActiveButtonColumn
        ID="DeleteColumn"
        HeaderText="Delete"
        HeaderStyle.Width="50px"
        ItemStyle.HorizontalAlign="Center"
        ItemStyle.Font.Italic="false"
        Text="Delete"
        CommandName="delete"
        />
</com:TActiveDataGrid>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/ActiveControls/Samples/TActiveDataGrid/Sample3.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190

<?php

class Sample3 extends TPage
{
    private $_data=null;

    protected function getData()
    {
        if($this->_data===null)
            $this->loadData();
        return $this->_data;
    }

    protected function loadData()
    {
        // We use viewstate keep track of data.
        // In real applications, data should come from database using an SQL SELECT statement.
        // In the following tabular data, field 'ISBN' is the primary key.
        // All update and delete operations should come with an 'id' value in order to go through.
        if(($this->_data=$this->getViewState('Data',null))===null)
        {
            $this->_data=array(
                array(
                    'ISBN'=>'0596007124',
                    'title'=>'Head First Design Patterns',
                    'publisher'=>'O\'Reilly Media, Inc.',
                    'price'=>29.67,
                    'instock'=>true,
                    'rating'=>4,
                ),
                array(
                    'ISBN'=>'0201633612',
                    'title'=>'Design Patterns: Elements of Reusable Object-Oriented Software',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>47.04,
                    'instock'=>true,
                    'rating'=>5,
                ),
                array(
                    'ISBN'=>'0321247140',
                    'title'=>'Design Patterns Explained : A New Perspective on Object-Oriented Design',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>37.49,
                    'instock'=>true,
                    'rating'=>4,
                ),
                array(
                    'ISBN'=>'0201485672',
                    'title'=>'Refactoring: Improving the Design of Existing Code',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>47.14,
                    'instock'=>true,
                    'rating'=>3,
                ),
                array(
                    'ISBN'=>'0321213351',
                    'title'=>'Refactoring to Patterns',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>38.49,
                    'instock'=>true,
                    'rating'=>2,
                ),
                array(
                    'ISBN'=>'0735619670',
                    'title'=>'Code Complete',
                    'publisher'=>'Microsoft Press',
                    'price'=>32.99,
                    'instock'=>false,
                    'rating'=>4,
                ),
                array(
                    'ISBN'=>'0321278658 ',
                    'title'=>'Extreme Programming Explained : Embrace Change',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>34.99,
                    'instock'=>true,
                    'rating'=>3,
                ),
            );
            $this->saveData();
        }
    }

    protected function saveData()
    {
        $this->setViewState('Data',$this->_data);
    }

    protected function updateBook($isbn,$title,$publisher,$price,$instock,$rating)
    {
        // In real applications, data should be saved to database using an SQL UPDATE statement
        if($this->_data===null)
            $this->loadData();
        $updateRow=null;
        foreach($this->_data as $index=>$row)
            if($row['ISBN']===$isbn)
                $updateRow=&$this->_data[$index];
        if($updateRow!==null)
        {
            $updateRow['title']=$title;
            $updateRow['publisher']=$publisher;
            $updateRow['price']=TPropertyValue::ensureFloat(ltrim($price,'$'));
            $updateRow['instock']=TPropertyValue::ensureBoolean($instock);
            $updateRow['rating']=TPropertyValue::ensureInteger($rating);
            $this->saveData();
        }
    }

    protected function deleteBook($isbn)
    {
        // In real applications, data should be saved to database using an SQL DELETE statement
        if($this->_data===null)
            $this->loadData();
        $deleteIndex=-1;
        foreach($this->_data as $index=>$row)
            if($row['ISBN']===$isbn)
                $deleteIndex=$index;
        if($deleteIndex>=0)
        {
            unset($this->_data[$deleteIndex]);
            $this->saveData();
        }
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack && !$this->IsCallBack)
        {
            $this->DataGrid->DataSource=$this->Data;
            $this->DataGrid->dataBind();
        }
    }

    public function itemCreated($sender,$param)
    {
        $item=$param->Item;
        if($item->ItemType==='EditItem')
        {
            // set column width of textboxes
            $item->BookTitleColumn->TextBox->Columns=40;
            $item->PriceColumn->TextBox->Columns=5;
        }
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem' || $item->ItemType==='EditItem')
        {
            // add an aleart dialog to delete buttons
            $item->DeleteColumn->Button->Attributes->onclick='if(!confirm(\'Are you sure?\')) return false;';
        }
    }

    public function editItem($sender,$param)
    {
        $this->DataGrid->EditItemIndex=$param->Item->ItemIndex;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function saveItem($sender,$param)
    {
        $item=$param->Item;
        $this->updateBook(
            $this->DataGrid->DataKeys[$item->ItemIndex],    // ISBN
            $item->BookTitleColumn->TextBox->Text,            // title
            $item->PublisherColumn->TextBox->Text,            // publisher
            $item->PriceColumn->TextBox->Text,                // price
            $item->InStockColumn->CheckBox->Checked,        // instock
            $item->RatingColumn->DropDownList->SelectedValue        // rating
            );
        $this->DataGrid->EditItemIndex=-1;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function cancelItem($sender,$param)
    {
        $this->DataGrid->EditItemIndex=-1;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function deleteItem($sender,$param)
    {
        $this->deleteBook($this->DataGrid->DataKeys[$param->Item->ItemIndex]);
        $this->DataGrid->EditItemIndex=-1;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/ActiveControls/Samples/TActiveDataGrid/Sample4.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55

<com:TContent ID="body">

<h1>TActiveDataGrid Sample 4</h1>
<h2>Sorting with TActiveDataGrid</h2>

<com:TActiveDataGrid
    Width="700px"
    CellPadding="2"
    ID="DataGrid"
    AutoGenerateColumns="false"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    AllowSorting="true"
    OnSortCommand="sortDataGrid">

    <com:TActiveHyperLinkColumn
        SortExpression="title"
        HeaderText="Book Title"
        DataTextField="title"
        DataNavigateUrlField="ISBN"
        DataNavigateUrlFormatString="http://www.amazon.com/gp/product/%s"
        Target="_blank"
        />
    <com:TActiveBoundColumn
        SortExpression="publisher"
        HeaderText="Publisher"
        DataField="publisher"
        />
    <com:TActiveBoundColumn
        SortExpression="price"
        ItemStyle.HorizontalAlign="Right"
        ItemStyle.Wrap="false"
        ItemStyle.Font.Italic="false"
        ItemStyle.ForeColor="green"
        HeaderText="Price"
        DataField="price"
        DataFormatString="$%.2f"
        />
    <com:TActiveCheckBoxColumn
        SortExpression="instock"
        HeaderText="In-stock"
        HeaderStyle.Wrap="false"
        DataField="instock"
        />
    <com:TActiveTemplateColumn HeaderText="Rating" SortExpression="rating">
        <prop:ItemTemplate>
        <img src="images/star<%#$this->NamingContainer->DataItem['rating']%>.gif" alt="" />
        </prop:ItemTemplate>
    </com:TActiveTemplateColumn>
</com:TActiveDataGrid>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/ActiveControls/Samples/TActiveDataGrid/Sample4.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<?php

Prado::using('Application.pages.ActiveControls.Samples.TActiveDataGrid.Sample2');

class Sample4 extends Sample2
{
    protected function sortData($data,$key)
    {
        $compare = create_function('$a,$b','if ($a["'.$key.'"] == $b["'.$key.'"]) {return 0;}else {return ($a["'.$key.'"] > $b["'.$key.'"]) ? 1 : -1;}');
        usort($data,$compare) ;
        return $data ;
    }

    public function sortDataGrid($sender,$param)
    {
        $this->DataGrid->DataSource=$this->sortData($this->Data,$param->SortExpression);
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/ActiveControls/Samples/TActiveDataGrid/Sample5.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25

<com:TContent ID="body">

<h1>TActiveDataGrid Sample 5</h1>
<h2>Paging</h2>

<div style="width:500px">
<com:TActiveDataGrid
    ID="DataGrid"
    AllowPaging="true"
    PageSize="5"
    PagerStyle.Mode="Numeric"
    PagerStyle.HorizontalAlign="Right"
    Width="100%"
    CellPadding="2"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    OnPageIndexChanged="changePage"
    OnPagerCreated="pagerCreated"
    />
</div>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/ActiveControls/Samples/TActiveDataGrid/Sample5.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79

<?php

Prado::using('Application.pages.ActiveControls.Samples.TActiveDataGrid.Sample1');

class Sample5 extends Sample1
{

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostback && ! $this->IsCallback)
        {
            $this->DataGrid->DataSource=$this->Data;
            $this->DataGrid->dataBind();
        }
    }

    public function changePage($sender,$param)
    {
        $this->DataGrid->CurrentPageIndex=$param->NewPageIndex;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function pagerCreated($sender,$param)
    {
        $param->Pager->Controls->insertAt(0,'Page: ');
    }

    public function changePagerPosition($sender,$param)
    {
        $top=$sender->Items[0]->Selected;
        $bottom=$sender->Items[1]->Selected;
        if($top && $bottom)
            $position='TopAndBottom';
        else if($top)
            $position='Top';
        else if($bottom)
            $position='Bottom';
        else
            $position='';
        if($position==='')
            $this->DataGrid->PagerStyle->Visible=false;
        else
        {
            $this->DataGrid->PagerStyle->Position=$position;
            $this->DataGrid->PagerStyle->Visible=true;
        }
    }

    public function useNumericPager($sender,$param)
    {
        $this->DataGrid->PagerStyle->Mode='Numeric';
        $this->DataGrid->PagerStyle->NextPageText=$this->NextPageText->Text;
        $this->DataGrid->PagerStyle->PrevPageText=$this->PrevPageText->Text;
        $this->DataGrid->PagerStyle->PageButtonCount=$this->PageButtonCount->Text;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function useNextPrevPager($sender,$param)
    {
        $this->DataGrid->PagerStyle->Mode='NextPrev';
        $this->DataGrid->PagerStyle->NextPageText=$this->NextPageText->Text;
        $this->DataGrid->PagerStyle->PrevPageText=$this->PrevPageText->Text;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function changePageSize($sender,$param)
    {
        $this->DataGrid->PageSize=TPropertyValue::ensureInteger($this->PageSize->Text);
        $this->DataGrid->CurrentPageIndex=0;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveDataList/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125

<com:TContent ID="body">

<h1>TActiveDataList Sample</h1>

<com:TActiveDataList
     ID="DataList"
     DataKeyField="id"
     OnEditCommand="editItem"
     OnCancelCommand="cancelItem"
     OnUpdateCommand="updateItem"
     OnDeleteCommand="deleteItem"
     OnSelectedIndexChanged="selectItem"
     HeaderStyle.BackColor="black"
     HeaderStyle.ForeColor="white"
     ItemStyle.BackColor="#BFCFFF"
     AlternatingItemStyle.BackColor="#E6ECFF"
     EditItemStyle.BackColor="lightgreen"
     SelectedItemStyle.BackColor="lightyellow">

<prop:HeaderTemplate>
<div style="font-weight:bold; text-align:center;">Computer Parts</div>
</prop:HeaderTemplate>

<prop:ItemTemplate>
<table border="0" width="100%">
<tr>
  <td>
  <com:TActiveLinkButton
       Text=<%#$this->DataItem['id']%>
       CommandName="select"
       />
  <%#$this->DataItem['name']%>
  </td>
  <td align="right">
  <com:TActiveLinkButton
       Text="Edit"
       CommandName="edit"
       />
  <com:TActiveLinkButton
       Text="Delete"
       CommandName="delete"
       Attributes.onclick="if(!confirm('Are you sure?')) return false;"
       />
  </td>
</tr>
</table>
</prop:ItemTemplate>

<prop:SelectedItemTemplate>
<table border="1" width="100%">
<tr>
  <th>ID</th><th>Name</th><th>Quantity</th><th>Price</th>
</tr>
<tr>
  <td align="right"><%#$this->DataItem['id'] %></td>
  <td align="right"><%#$this->DataItem['name'] %></td>
  <td align="right"><%#$this->DataItem['quantity'] %></td>
  <td align="right">$<%#$this->DataItem['price'] %></td>
</tr>
<tr>
  <td colspan="4" align="right">
  <com:TActiveLinkButton
       Text="Edit"
       CommandName="edit"
       />
  <com:TActiveLinkButton
       Text="Delete"
       CommandName="delete"
       Attributes.onclick="if(!confirm('Are you sure?')) return false;"
       />
  </td>
</tr>
</table>
</prop:SelectedItemTemplate>

<prop:EditItemTemplate>
<table border="0" width="100%">
<tr>
  <td align="right">ID</td>
  <td><b><%#$this->DataItem['id']%></b></td>
</tr>
<tr>
  <td align="right">Name</td>
  <td><com:TTextBox
           ID="ProductName"
           Text=<%#$this->DataItem['name'] %>
           />
  </td>
</tr>
<tr>
  <td align="right">Quantity</td>
  <td><com:TTextBox
           ID="ProductQuantity"
           Text=<%#$this->DataItem['quantity'] %>
           />
  </td>
</tr>
<tr>
  <td align="right">Price</td>
  <td><com:TTextBox
           ID="ProductPrice"
           Text=<%#$this->DataItem['price'] %>
           />
  </td>
</tr>
<tr>
  <td align="right">Imported</td>
  <td><com:TCheckBox
           ID="ProductImported"
           Checked=<%#$this->DataItem['imported'] %>
           />
  </td>
</tr>
<tr>
  <td colspan="2" align="right">
    <com:TActiveLinkButton Text="Save" CommandName="update" />
    <com:TActiveLinkButton Text="Cancel" CommandName="cancel" />
  </td>
</tr>
</table>
</prop:EditItemTemplate>

</com:TActiveDataList>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveDataList/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132

<?php

class Home extends TPage
{
    private $_data=null;

    protected function getData()
    {
        if($this->_data===null)
            $this->loadData();
        return $this->_data;
    }

    protected function loadData()
    {
        // We use viewstate keep track of data.
        // In real applications, data should come from database using an SQL SELECT statement.
        // In the following tabular data, field 'id' is the primary key.
        // All update and delete operations should come with an 'id' value in order to go through.
        if(($this->_data=$this->getViewState('Data',null))===null)
        {
            $this->_data=array(
                array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
                array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
                array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>false),
                array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
                array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
                array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>true),
                array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>false),
            );
            $this->saveData();
        }
    }

    protected function saveData()
    {
        $this->setViewState('Data',$this->_data);
    }

    protected function updateProduct($id,$name,$quantity,$price,$imported)
    {
        // In real applications, data should be saved to database using an SQL UPDATE statement
        if($this->_data===null)
            $this->loadData();
        $updateRow=null;
        foreach($this->_data as $index=>$row)
            if($row['id']===$id)
                $updateRow=&$this->_data[$index];
        if($updateRow!==null)
        {
            $updateRow['name']=$name;
            $updateRow['quantity']=TPropertyValue::ensureInteger($quantity);
            $updateRow['price']=TPropertyValue::ensureFloat($price);
            $updateRow['imported']=TPropertyValue::ensureBoolean($imported);
            $this->saveData();
        }
    }

    protected function deleteProduct($id)
    {
        // In real applications, data should be saved to database using an SQL DELETE statement
        if($this->_data===null)
            $this->loadData();
        $deleteIndex=-1;
        foreach($this->_data as $index=>$row)
            if($row['id']===$id)
                $deleteIndex=$index;
        if($deleteIndex>=0)
        {
            unset($this->_data[$deleteIndex]);
            $this->saveData();
        }
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataList->DataSource=$this->Data;
            $this->DataList->dataBind();
        }
    }

    public function editItem($sender,$param)
    {
        $this->DataList->SelectedItemIndex=-1;
        $this->DataList->EditItemIndex=$param->Item->ItemIndex;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }

    public function cancelItem($sender,$param)
    {
        $this->DataList->SelectedItemIndex=-1;
        $this->DataList->EditItemIndex=-1;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }

    public function updateItem($sender,$param)
    {
        $item=$param->Item;
        $this->updateProduct(
            $this->DataList->DataKeys[$item->ItemIndex],
            $item->ProductName->Text,
            $item->ProductQuantity->Text,
            $item->ProductPrice->Text,
            $item->ProductImported->Checked);
        $this->DataList->EditItemIndex=-1;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }

    public function deleteItem($sender,$param)
    {
        $this->deleteProduct($this->DataList->DataKeys[$param->Item->ItemIndex]);
        $this->DataList->SelectedItemIndex=-1;
        $this->DataList->EditItemIndex=-1;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }

    public function selectItem($sender,$param)
    {
        $this->DataList->EditItemIndex=-1;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveDatePicker/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<com:TContent ID="body">

<h1>TActiveDatePicker Samples</h1>

<table class="sampletable">

<tr>
    <td class="samplenote">Default TActiveDatePicker triggering a callback to a label</td>
    <td class="sampleaction">
        <com:TActiveDatePicker ID="date1" OnCallback="dateChanged"/>
        <com:TActiveLabel ID="label1" />
    </td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveDatePicker/Home.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Home extends TPage
{
    public function dateChanged($sender, $param)
    {
        $this->label1->Text = date("r", $this->date1->TimeStamp);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveDropDownList/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108

<com:TContent ID="body">

<h1>TActiveDropDownList Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Callback dropdown list:
</td>
<td class="sampleaction">
<com:TActiveDropDownList
    OnSelectedIndexChanged="selectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TActiveDropDownList>
<com:TActiveLabel ID="SelectionResult" ForeColor="red" />
</td>
</tr>

</table>

<h2>Changing items to DropDown Lists on callback</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
Adding an item on every callback:
  </td>
  <td class="sampleaction">
    <com:TActiveDropDownList ID="ddl1" />
    <com:TActiveButton ID="button1" Text="add a new item" OnCallback="buttonClicked" />
    <com:TActiveLabel ID="label1" ForeColor="red" />
  </td>
</tr>

</table>

<table class="sampletable">

<tr>
<td class="samplenote">
Clearing / restoring the dropdownlist on callback:
  </td>
  <td class="sampleaction">
    <com:TActiveDropDownList ID="ddl2" />
    <com:TActiveButton ID="button2" Text="clear" OnCallback="clearClicked" />
    <com:TActiveButton ID="button3" Text="reset" OnCallback="resetClicked" />
    <com:TActiveLabel ID="label2" ForeColor="red" />
  </td>
</tr>

</table>

<h2>List Boxes with Validation</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
Dropdown list is being validated:
</td>
<td class="sampleaction">
<com:TActiveDropDownList ID="VDropDownList1">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TActiveDropDownList>
<com:TRequiredFieldValidator
    ControlToValidate="VDropDownList1"
    ErrorMessage="You must make a selection other than the first option"
    InitialValue="value 1"
    Display="Dynamic"
    ValidationGroup="Group1"
    />
<com:TActiveButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Dropdown list causing validation:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    ErrorMessage="You must enter a value"
    Display="Dynamic"
    ValidationGroup="Group2"
    />
<com:TActiveDropDownList
    ID="VDropDownList2"
    ValidationGroup="Group2">
  <com:TListItem Text="Agree" />
  <com:TListItem Text="Disagree" />
</com:TActiveDropDownList>
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveDropDownList/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack && !$this->IsCallback)
        {
            $this->resetClicked(null,null);
        }
    }

    protected function collectSelectionResult($input,$output)
    {
        $indices=$input->SelectedIndices;
        $result='';
        foreach($indices as $index)
        {
            $item=$input->Items[$index];
            $result.="(Index: $index, Value: $item->Value, Text: $item->Text)";
        }
        if($result==='')
            $output->Text='Your selection is empty.';
        else
            $output->Text='Your selection is: '.$result;
    }

    public function selectionChanged($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->SelectionResult);
    }

    public function buttonClicked($sender, $param)
    {
        $data=array();
        for($i = 0; $i <= $this->ddl1->Items->Count; $i++)
            $data[$i]="Item number #".$i;
        $this->ddl1->DataSource=$data;
        $this->ddl1->dataBind();
        $this->label1->Text="Total ".count($data)." items";
    }

    public function resetClicked($sender, $param)
    {
        $data=array('item 1','item 2','item 3','item 4');
        $this->ddl2->DataSource=$data;
        $this->ddl2->dataBind();
        $this->label2->Text="DropDownList has been reset";
    }

    public function clearClicked($sender, $param)
    {
        $this->ddl2->DataSource=array();
        $this->ddl2->dataBind();
        $this->label2->Text="DropDownList cleared";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveFileUpload/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

<com:TContent ID="body">

<h1>TActiveFileUpload Sample</h1>

<p>
Please choose a file to upload:
</p>

<com:TActiveFileUpload OnFileUpload="fileUploaded" />

<br/>

<com:TActiveLabel ID="Result" />

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveFileUpload/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<?php

class Home extends TPage
{
    public function fileUploaded($sender,$param)
    {
        if($sender->HasFile)
        {
            $this->Result->Text="
                You just uploaded a file:
                <br/>
                Name: {$sender->FileName}
                <br/>
                Size: {$sender->FileSize}
                <br/>
                Type: {$sender->FileType}";
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveHyperLink/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70

<com:TContent ID="body">

<h1>TActiveHyperLink Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A regular hyperlink:
</td><td class="sampleaction">
Welcome to
<com:TActiveHyperLink
    ID="link1"
    NavigateUrl="http://www.pradosoft.com/"
    Text="PradoSoft.com"
    Target="_blank" />.
</td>
<td class="sampleaction">
<com:TActiveButton ID="button1" Text="Change to Navigate Url" OnClick="button1_clicked" />
</td>
</tr>

<tr><td class="samplenote">
A text hyperlink with css style:
</td><td class="sampleaction">
Welcome to
<com:TActiveHyperLink
    ID="link2"
    NavigateUrl="http://www.pradosoft.com/"
    Text="PradoSoft.com"
    Target="_blank"
    BackColor="silver"
    Font.Italic="true" />.
</td>
<td class="sampleaction">
<com:TActiveButton ID="button2" Text="Change to Target" OnClick="button2_clicked" />
</td>
</tr>

<tr><td class="samplenote">
An image hyperlink:
</td><td class="sampleaction">
<com:TActiveHyperLink
    ID="link3"
    NavigateUrl="http://www.pradosoft.com/"
    ImageUrl=<%~hello_world.gif%>
    Text="Hello World" />.
</td>
<td class="sampleaction">
<com:TActiveButton ID="button3" Text="Change to Text" OnClick="button3_clicked" />
</td>
</tr>

<tr><td class="samplenote">
A hyerplink with body contents as link text:
</td><td class="sampleaction">
<com:TActiveHyperLink
    ID="link4"
    NavigateUrl="http://www.pradosoft.com/"
    Target="_blank">
Body contents
</com:TActiveHyperLink>
</td>
<td class="sampleaction">
<com:TActiveButton ID="button4" Text="Change to Image" OnClick="button4_clicked" />
</td>
</tr>

</table>
<com:TJavascriptLogger />
</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveHyperLink/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

<?php

class Home extends TPage
{
    function button1_clicked($sender, $param)
    {
        $this->link1->NavigateUrl = 'http://www.google.com';
    }

    function button2_clicked($sender, $param)
    {
        $this->link2->Target = '_self';
    }

    function button3_clicked($sender, $param)
    {
        $this->link3->Text = 'PradoSoft.com';
    }

    function button4_clicked($sender, $param)
    {
        $img = $this->publishFilePath(dirname(__FILE__).'/hello_world.gif');
        $this->link4->ImageUrl = $img;
    }
}
?>


PRADO QuickStart Source View

Class file: | HelloWorld.html
Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveImage/HelloWorld.html

1
2
3
4
5
6
7
8

<html>
<head>
<title>Hello World!</title>
</head>
<body>
This is Hello World long description file!
</body>
</html>


PRADO QuickStart Source View

Class file: | HelloWorld.html
Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveImage/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

<com:TContent ID="body">

<h1>TActiveImage Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
<tt>ImageUrl</tt> being changed on callback request:
</td><td class="sampleaction">
<com:TActiveImage
    ID="imageTest"
    ImageUrl=<%~hello_world.gif%>
    AlternateText="Hello World!"/>
<com:TActiveButton OnCallback="buttonClicked" Text="First hello world image"/>
<com:TActiveButton OnCallback="buttonClicked2" Text="Second hello world image"/>
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Class file: | HelloWorld.html
Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveImage/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<?php

// $Id: Home.php 1405 2006-09-10 01:03:56Z wei $
class Home extends TPage
{
    public function buttonClicked($sender, $param)
    {
        $this->imageTest->ImageUrl=$this->publishAsset("hello_world.gif");
    }

    public function buttonClicked2($sender, $param)
    {
        $this->imageTest->ImageUrl=$this->publishAsset("hello_world2.gif");
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveImageButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49

<com:TContent ID="body">

<h1>TActiveImageButton Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A click image button showing the click location:
</td><td class="sampleaction">
<com:TActiveImageButton
    ImageUrl=<%~ hello_world.gif %>
    Text="hello world"
    OnClick="buttonClicked"
    />
<com:TActiveLabel ID="Result" />
</td></tr>

<tr><td class="samplenote">
A callback image button:
</td><td class="sampleaction">
<com:TActiveImageButton
    ImageUrl=<%~ hello_world.gif %>
    Text="hello world"
    OnCallback="buttonClicked"
    ActiveControl.CallbackParameter="value"
    />
<com:TActiveLabel ID="Result2" />
</td></tr>

<tr><td class="samplenote">
An image button causing validation:
</td><td class="sampleaction">
<com:TActiveTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TActiveImageButton
    ImageUrl=<%~ hello_world.gif %>
    Text="hello world"
    ValidationGroup="Group"
    />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveImageButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        if($param instanceof TCallbackEventParameter)
        {
            $this->Result2->Text="Callback parameter: $param->CallbackParameter";
        }
        else
        {
            $this->Result->Text="You clicked at ($param->X,$param->Y)";
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveLabel/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34

<com:TContent ID="body">

<h1>TActiveLabel Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
An active label text being set as the result of a callback:
</td><td class="sampleaction">
<com:TActiveLabel Text="This is a label" ID="label1"
/>

<com:TActiveButton
    Text="click me"
    OnClick="buttonClicked"
/>
</td></tr>

<tr><td class="samplenote">
Upon button click, the textbox contents will be set on the label. Note that text needs to be properly escaped to avoid html injections:
</td><td class="sampleaction">
<com:TActiveTextBox ID="txt2"
/>
<com:TActiveButton
    Text="=>"
    OnClick="buttonClicked2"
/>
<com:TActiveLabel Text="" ID="label2"
/>
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveLabel/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $this->label1->Text="You clicked the button, didn't you?";
    }

    public function buttonClicked2($sender,$param)
    {
        $this->label2->Text=THttpUtility::htmlEncode($this->txt2->Text);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveLinkButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46

<com:TContent ID="body">

<h1>TActiveLinkButton Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Link button with only body content:
</td><td class="sampleaction">
<com:TActiveLinkButton>
body content
</com:TActiveLinkButton>
</td></tr>

<tr><td class="samplenote">
A click link button:
</td><td class="sampleaction">
<com:TActiveLinkButton Text="click me" OnClick="buttonClicked" />
</td></tr>

<tr><td class="samplenote">
A callback link button:
</td><td class="sampleaction">
<com:TActiveLinkButton
    Text="click me"
    OnCallback="buttonClicked"
    ActiveControl.CallbackParameter="value"
    />
</td></tr>

<tr><td class="samplenote">
A button causing validation:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TActiveLinkButton Text="submit" ValidationGroup="Group" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveLinkButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        if($param instanceof TCallbackEventParameter)
            $sender->Text="Callback Parameter: {$param->CallbackParameter}";
        else
            $sender->Text="I'm clicked";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveListBox/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108

<com:TContent ID="body">

<h1>TActiveListBox Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Callback listbox:
</td>
<td class="sampleaction">
<com:TActiveListBox
    OnSelectedIndexChanged="selectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TActiveListBox>
<com:TActiveLabel ID="SelectionResult" ForeColor="red" />
</td>
</tr>

</table>

<h2>Changing items to a Listbox on callback</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
Adding an item on every callback:
  </td>
  <td class="sampleaction">
    <com:TActiveListBox ID="box1" />
    <com:TActiveButton ID="button1" Text="add a new item" OnCallback="buttonClicked" />
    <com:TActiveLabel ID="label1" ForeColor="red" />
  </td>
</tr>

</table>

<table class="sampletable">

<tr>
<td class="samplenote">
Clearing / restoring the listbox on callback:
  </td>
  <td class="sampleaction">
    <com:TActiveListBox ID="box2" />
    <com:TActiveButton ID="button2" Text="clear" OnCallback="clearClicked" />
    <com:TActiveButton ID="button3" Text="reset" OnCallback="resetClicked" />
    <com:TActiveLabel ID="label2" ForeColor="red" />
  </td>
</tr>

</table>

<h2>List Boxes with Validation</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
Listbox is being validated:
</td>
<td class="sampleaction">
<com:TActiveListBox ID="VDropDownList1">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TActiveListBox>
<com:TRequiredFieldValidator
    ControlToValidate="VDropDownList1"
    ErrorMessage="You must make a selection other than the first option"
    InitialValue="value 1"
    Display="Dynamic"
    ValidationGroup="Group1"
    />
<com:TActiveButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Listbox causing validation:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    ErrorMessage="You must enter a value"
    Display="Dynamic"
    ValidationGroup="Group2"
    />
<com:TActiveListBox
    ID="VDropDownList2"
    ValidationGroup="Group2">
  <com:TListItem Text="Agree" />
  <com:TListItem Text="Disagree" />
</com:TActiveListBox>
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveListBox/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack && !$this->IsCallback)
        {
            $this->resetClicked(null,null);
        }
    }

    protected function collectSelectionResult($input,$output)
    {
        $indices=$input->SelectedIndices;
        $result='';
        foreach($indices as $index)
        {
            $item=$input->Items[$index];
            $result.="(Index: $index, Value: $item->Value, Text: $item->Text)";
        }
        if($result==='')
            $output->Text='Your selection is empty.';
        else
            $output->Text='Your selection is: '.$result;
    }

    public function selectionChanged($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->SelectionResult);
    }

    public function buttonClicked($sender, $param)
    {
        $data=array();
        for($i = 0; $i <= $this->box1->Items->Count; $i++)
            $data[$i]="Item number #".$i;
        $this->box1->DataSource=$data;
        $this->box1->dataBind();
        $this->label1->Text="Total ".count($data)." items";
    }

    public function resetClicked($sender, $param)
    {
        $data=array('item 1','item 2','item 3','item 4');
        $this->box2->DataSource=$data;
        $this->box2->dataBind();
        $this->label2->Text="ListBox has been reset";
    }

    public function clearClicked($sender, $param)
    {
        $this->box2->DataSource=array();
        $this->box2->dataBind();
        $this->label2->Text="ListBox cleared";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveMultiView/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37

<com:TContent ID="body">

<h1>TActiveMultiView Samples</h1>

<com:TActiveMultiView ID="MultiView" ActiveViewIndex="0" OnActiveViewChanged="viewChanged">
  <com:TView ID="View1">
    <h2>View 1</h2>
    <p>Please enter a memo:</p>
    <com:TActiveTextBox ID="Memo" />
    <hr/>
    <com:TActiveButton Text="View 2" CommandName="NextView" />
    <com:TActiveButton Text="View 3" CommandName="SwitchViewIndex" CommandParameter="2" />
  </com:TView>
  <com:TView>
    <h2>View 2</h2>
    <p>Please choose a color:</p>
    <com:TActiveDropDownList ID="DropDownList">
      <com:TListItem Value="Red" />
      <com:TListItem Value="Blue" />
      <com:TListItem Value="Green" />
    </com:TActiveDropDownList>
    <hr/>
    <com:TActiveButton Text="View 1" CommandName="PreviousView" />
    <com:TActiveButton Text="View 3" CommandName="NextView" />
  </com:TView>
  <com:TView>
    <h2>View 3</h2>
    <com:TActiveLabel ID="Result1" />
    <br/>
    <com:TActiveLabel ID="Result2" />
    <hr/>
    <com:TActiveButton Text="View 1" CommandName="SwitchViewID" CommandParameter="View1" />
    <com:TActiveButton Text="View 2" CommandName="PreviousView" />
  </com:TView>
</com:TActiveMultiView>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveMultiView/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

<?php

class Home extends TPage
{
    public function viewChanged($sender,$param)
    {
        if($this->MultiView->ActiveViewIndex===2)
        {
            $this->Result1->Text="Your text input is: ".$this->Memo->Text;
            $this->Result2->Text="Your color choice is: ".$this->DropDownList->SelectedValue;
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActivePager/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103

<com:TContent ID="body">

<h1>TActivePager Sample</h1>
<p>
The following sample displays three different pagers associated with a single TDataList control. The datalist control is enabled with custom paging, which allows it to read only one page of data each time. This is typical in DB-driven applications.
</p>

<div>
Go to page:
<com:TActivePager ID="Pager"
    ControlToPaginate="DataList"
    PageButtonCount="3"
    Mode="Numeric"
    OnPageIndexChanged="pageChanged"
    OnCallBack="RenderCallback"
    >
        <prop:ClientSide.OnLoading>
            Element.show('wait')
        </prop:ClientSide.OnLoading>
        <prop:ClientSide.OnComplete>
            Element.hide('wait')
        </prop:ClientSide.OnComplete>
</com:TActivePager>
<span id="wait" style="display: none;color: red">Please Wait...</span>
</div>
<com:TActivePanel id="TActivePanel" ActiveControl.EnableUpdate="true">
<com:TDataList
     ID="DataList"
     AllowPaging="true"
     AllowCustomPaging="true"
     PageSize="2"
     EnableViewState="true"
     RepeatColumns="2"
     RepeatDirection="Vertical"
     ItemStyle.Font.Italic="true"
     ItemStyle.BackColor="#BFCFFF"
     HeaderStyle.BackColor="black"
     HeaderStyle.ForeColor="white"
     FooterStyle.BackColor="gray"
     AlternatingItemStyle.BackColor="#E6ECFF">

<prop:HeaderTemplate>
<div style="font-weight:bold; text-align:center;">Computer Parts</div>
</prop:HeaderTemplate>

<prop:FooterTemplate>
<div style="font-weight:bold; text-align:center;">
Total <%# $this->Parent->PageCount %> pages.
</div>
</prop:FooterTemplate>

<prop:ItemTemplate>
<table border="0" width="300">
<tr>
  <th>ID</th><th>Name</th><th>Quantity</th><th>Price</th>
</tr>
<tr>
  <td align="right"><com:TLiteral Text=<%#$this->DataItem['id'] %> /></td>
  <td align="right"><com:TLiteral Text=<%#$this->DataItem['name'] %> /></td>
  <td align="right"><com:TLiteral Text=<%#$this->DataItem['quantity'] %> /></td>
  <td align="right">$<com:TLiteral Text=<%#$this->DataItem['price'] %> /></td>
</tr>
</table>
</prop:ItemTemplate>

</com:TDataList>
</com:TActivePanel>

<com:TActivePager ID="Pager2"
    ControlToPaginate="DataList"
    FirstPageText="9"
    LastPageText=":"
    Mode="NextPrev"
    NextPageText="4"
    PrevPageText="3"
    Font.Name="Webdings"
    OnPageIndexChanged="pageChanged"
    OnCallBack="RenderCallback"
>
<prop:ClientSide.OnLoading>
            Element.show('wait')
        </prop:ClientSide.OnLoading>
        <prop:ClientSide.OnComplete>
            Element.hide('wait')
        </prop:ClientSide.OnComplete>
</com:TActivePager>
<br/>
Choose page:
<com:TActivePager ID="Pager3"
    ControlToPaginate="DataList"
    Mode="DropDownList"
    OnPageIndexChanged="pageChanged"
    OnCallBack="RenderCallback"
>
<prop:ClientSide.OnLoading>
            Element.show('wait')
        </prop:ClientSide.OnLoading>
        <prop:ClientSide.OnComplete>
            Element.hide('wait')
        </prop:ClientSide.OnComplete>
</com:TActivePager>
<com:TJavascriptLogger/>
</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActivePager/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92

<?php

class Home extends TPage
{

    /**
     * function to render callback and refresh the TActivePanel content
     */

    public function RenderCallback($sender, $param)
    {
        $this->TActivePanel->render($param->NewWriter);
    }

    /**
     * Returns total number of data items.
     * In DB-driven applications, this typically requires
     * execution of an SQL statement with COUNT function.
     * Here we simply return a constant number.
     */
    protected function getDataItemCount()
    {
        return 19;
    }

    /**
     * Fetches a page of data.
     * In DB-driven applications, this can be achieved by executing
     * an SQL query with LIMIT clause.
     */
    protected function getData($offset,$limit)
    {
        $data=array(
            array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
            array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>false),
            array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>true),
            array('id'=>'ITN008','name'=>'CDRW drive','quantity'=>1,'price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','quantity'=>2,'price'=>10.00,'imported'=>false),
            array('id'=>'ITN010','name'=>'Video camera','quantity'=>20,'price'=>30.00,'imported'=>true),
            array('id'=>'ITN011','name'=>'Card reader','quantity'=>10,'price'=>24.00,'imported'=>true),
            array('id'=>'ITN012','name'=>'Floppy drive','quantity'=>50,'price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','quantity'=>25,'price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','quantity'=>15,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','quantity'=>50,'price'=>5.00,'imported'=>false),
            array('id'=>'ITN016','name'=>'Network cable','quantity'=>40,'price'=>8.00,'imported'=>true),
            array('id'=>'ITN017','name'=>'Case','quantity'=>8,'price'=>65.00,'imported'=>false),
            array('id'=>'ITN018','name'=>'Surge protector','quantity'=>45,'price'=>15.00,'imported'=>false),
            array('id'=>'ITN019','name'=>'Speaker','quantity'=>35,'price'=>65.00,'imported'=>false),
        );
        return array_slice($data,$offset,$limit);
    }

    /**
     * Determines which page of data to be displayed and
     * populates the datalist with the fetched data.
     */
    protected function populateData()
    {
        $offset=$this->DataList->CurrentPageIndex*$this->DataList->PageSize;
        $limit=$this->DataList->PageSize;
        if($offset+$limit>$this->DataList->VirtualItemCount)
            $limit=$this->DataList->VirtualItemCount-$offset;
        $data=$this->getData($offset,$limit);
        $this->DataList->DataSource=$data;
        $this->DataList->dataBind();
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataList->VirtualItemCount=$this->DataItemCount;
            $this->populateData();
        }
    }

    /**
     * Event handler to the OnPageIndexChanged event of pagers.
     */
    public function pageChanged($sender,$param)
    {
        $this->DataList->CurrentPageIndex=$param->NewPageIndex;
        $this->populateData();
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActivePanel/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

<com:TContent ID="body">

<h1>TActivePanel Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Active panel updated on callback:
</td><td class="sampleaction">
<com:TActivePanel ID="panel1" BackColor="#CCFFCC" DefaultButton="button1" Width="400px">
This is panel content
<br/>a checkbox: <com:TCheckBox ID="check1"/>
<br/>a textbox: <com:TTextBox ID="txt1"/>
<br/>a label: <com:TLabel ID="label1"/>
<br/><com:TActiveButton ID="button1" Text="click me" OnCallback="buttonClicked" />
<br/>
When you press the button, the panel contents will change. Note that out of the
panel and the button, all the other controls are not active but gets updated
anyway since they are placed inside the active panel.
</com:TActivePanel>
</td></tr>
</table>
<com:TJavascriptLogger />
</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActivePanel/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $this->check1->Checked = !$this->check1->Checked;
        if($this->txt1->Text=="")
            $this->txt1->Text="changes happens";
        else
            $this->txt1->Text="";
        if($this->label1->Text=="")
            $this->label1->Text="label has changed, too";
        else
            $this->label1->Text="";

        $this->panel1->render($param->NewWriter);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveRadioButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82

<com:TContent ID="body">

<h1>TActiveRadioButton Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A  callback radiobutton:
</td><td class="sampleaction">
<com:TActiveRadioButton
    Text="click me"
    OnCheckedChanged="radiobuttonClicked"
    />
</td></tr>

<tr><td class="samplenote">
A radiobutton causing validation on a textbox:
</td><td class="sampleaction">
<com:TActiveTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TActiveRadioButton
    Text="submit"
    AutoPostBack="true"
    ValidationGroup="Group"
    />
</td></tr>

<tr><td class="samplenote">
A radiobutton validated by a required field validator:
</td><td class="sampleaction">
<com:TActiveRadioButton
    ID="RadioButton"
    Text="Consent"
    ValidationGroup="Group2"
    />
<com:TActiveButton Text="Submit" ValidationGroup="Group2" />
<com:TRequiredFieldValidator
    ControlToValidate="RadioButton"
    Display="Dynamic"
    ErrorMessage="You must consent."
    ValidationGroup="Group2"
    />
</td></tr>

<tr><td class="samplenote">
A radiobutton group:
</td><td class="sampleaction">
<com:TActiveRadioButton
    ID="Radio1"
    GroupName="RadioGroup"
    Text="Option 1"
    OnCallback="selectRadioButton"
    />
<com:TActiveRadioButton
    ID="Radio2"
    GroupName="RadioGroup"
    Text="Option 2"
    OnCallback="selectRadioButton"
    />
<com:TActiveRadioButton
    ID="Radio3"
    GroupName="RadioGroup"
    Text="Option 3"
    OnCallback="selectRadioButton"
    />
<com:TActiveRadioButton
    ID="Radio4"
    Text="Option 4 (in a different group)"
    OnCallback="selectRadioButton"
    />
<br/>
<com:TActiveLabel ID="Result" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveRadioButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<?php

class Home extends TPage
{
    public function radiobuttonClicked($sender,$param)
    {
        $sender->Text="I'm clicked";
    }

    public function selectRadioButton($sender,$param)
    {
        $selection='';
        if($this->Radio1->Checked)
            $selection.='1';
        if($this->Radio2->Checked)
            $selection.='2';
        if($this->Radio3->Checked)
            $selection.='3';
        if($this->Radio4->Checked)
            $selection.='4';
        if($selection==='')
            $selection='empty';
        $this->Result->Text='Your selection is '.$selection;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveRadioButtonList/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65

<com:TContent ID="body">

<h1>TActiveRadioButtonList Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Check box list with default settings:
</td>
<td class="sampleaction">
<com:TActiveRadioButtonList>
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TActiveRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list's behavior upon callback:
</td>
<td class="sampleaction">
<com:TActiveRadioButtonList ID="RadioButtonList" OnCallback="selectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Enabled="false" />
  <com:TListItem Value="value 5" Text="item 5" Selected="true" />
</com:TActiveRadioButtonList>
<br/>
<com:TActiveLabel ID="SelectionResult" ForeColor="red" />
</td>
</tr>

</table>

<h2>RadioButton List with Validation</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
RadioButton list causing validation:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    ErrorMessage="You must enter a value"
    Display="Dynamic"
    ValidationGroup="Group2"
    />
<com:TActiveRadioButtonList ValidationGroup="Group2">
  <com:TListItem Text="Agree" />
  <com:TListItem Text="Disagree" />
</com:TActiveRadioButtonList>
</td>
</tr>

</table>
</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveRadioButtonList/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

<?php

class Home extends TPage
{
    protected function collectSelectionResult($input,$output)
    {
        $indices=$input->SelectedIndices;
        $result='';
        foreach($indices as $index)
        {
            $item=$input->Items[$index];
            $result.="(Index: $index, Value: $item->Value, Text: $item->Text)";
        }
        if($result==='')
            $output->Text='Your selection is empty.';
        else
            $output->Text='Your selection is: '.$result;
    }

    public function selectionChanged($sender,$param)
    {
        $this->collectSelectionResult($this->RadioButtonList,$this->SelectionResult);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveRepeater/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92

<com:TContent ID="body">

<h1>TActiveRepeater Sample</h1>

<p>
The following example allows users to modify the existing tabular data using a <tt>TActiveRepeater</tt>. Two validators are used in the repeater to ensure the validity of user inputs. One is to ensure product names are not empty, the other ensures product prices are valid numeric format. After clicking on the <tt>save</tt> button, the input data is displayed in a table at the bottom of the page.
</p>

<table>
<tr>
  <th>Name</th>
  <th>Category</th>
  <th>Price</th>
  <th>Imported</th>
</tr>
<com:TActiveRepeater ID="Repeater" OnItemDataBound="repeaterDataBound">
<prop:ItemTemplate>
<tr>
  <td>
  <com:TTextBox
       ID="ProductName"
       Text=<%#$this->Data['name']%> />
  </td>
  <td>
  <com:TDropDownList
       ID="ProductCategory" />
  </td>
  <td>
  <com:TTextBox
       ID="ProductPrice"
       Columns="7"
       Text=<%#$this->Data['price']%> />
  </td>
  <td>
  <com:TCheckBox
       ID="ProductImported"
       Checked=<%#$this->Data['imported']%> />
  <com:TRequiredFieldValidator
       ControlToValidate="ProductName"
       ErrorMessage="Product name cannot be empty."
       Display="Dynamic" />
  <com:TRegularExpressionValidator
       ControlToValidate="ProductPrice"
       RegularExpression="\d+(\.\d{1,2})?"
       ErrorMessage="Product price must be in the format of ddd.dd"
       Display="Dynamic" />
  </td>
</tr>
</prop:ItemTemplate>
</com:TActiveRepeater>
</table>

<div>
<com:TActiveButton Text="Save" OnClick="saveInput"/>
</div>

<com:TSafeHtml>
<com:TActiveRepeater ID="Repeater2" EnableViewState="false">

<prop:HeaderTemplate>
<table cellpadding="2">
<tr style="color:white;background-color:black">
  <th>ID</th>
  <th>Name</th>
  <th>Category</th>
  <th>Price</th>
  <th>Imported</th>
</tr>
</prop:HeaderTemplate>

<prop:ItemTemplate>
<tr style="<%# 'background-color:' . ($this->ItemIndex%2 ? '#BFCFFF' : '#E6ECFF') %>">
<td><%#$this->Data['id']%></td>
<td><%#$this->Data['name']%></td>
<td><%#$this->Data['category']%></td>
<td><%#$this->Data['price']%></td>
<td><%#$this->Data['imported']?'Yes':'No'%></td>
</tr>
</prop:ItemTemplate>

<prop:FooterTemplate>
<tr style="color:white;background-color:black;text-align:center;">
<td colspan="5">Computer Parts Inventory</td>
</tr>
</table>
</prop:FooterTemplate>

</com:TActiveRepeater>

</com:TSafeHtml>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveRepeater/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79

<?php

class Home extends TPage
{
    protected function getProducts()
    {
        return array(
            array('id'=>'ITN001','name'=>'Motherboard','category'=>'CAT004','price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','category'=>'CAT004','price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','category'=>'CAT003','price'=>80.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','category'=>'CAT002','price'=>20.00,'imported'=>false),
            array('id'=>'ITN008','name'=>'CDRW drive','category'=>'CAT003','price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','category'=>'CAT001','price'=>10.00,'imported'=>false),
            array('id'=>'ITN012','name'=>'Floppy drive','category'=>'CAT003','price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','category'=>'CAT003','price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','category'=>'CAT003','price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','category'=>'CAT001','price'=>5.00,'imported'=>false),
        );
    }

    protected function getCategories()
    {
        return array(
            array('id'=>'CAT001','name'=>'Accessories'),
            array('id'=>'CAT002','name'=>'Input Devices'),
            array('id'=>'CAT003','name'=>'Drives'),
            array('id'=>'CAT004','name'=>'Barebone'),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->Repeater->DataSource=$this->Products;
            $this->Repeater->dataBind();
        }
    }

    public function repeaterDataBound($sender,$param)
    {
        $item=$param->Item;
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem')
        {
            $item->ProductCategory->DataSource=$this->Categories;
            $item->ProductCategory->DataTextField='name';
            $item->ProductCategory->DataValueField='id';
            $item->ProductCategory->dataBind();
            $item->ProductCategory->SelectedValue=$item->DataItem['category'];
        }
    }

    public function saveInput($sender,$param)
    {
        if($this->IsValid)
        {
            $index=0;
            $products=$this->Products;
            $data=array();
            foreach($this->Repeater->Items as $item)
            {
                $item=array(
                    'id'=>$products[$index]['id'],
                    'name'=>$item->ProductName->Text,
                    'category'=>$item->ProductCategory->SelectedItem->Text,
                    'price'=>TPropertyValue::ensureFloat($item->ProductPrice->Text),
                    'imported'=>$item->ProductImported->Checked,
                );
                $data[]=$item;
                $index++;
            }
            $this->Repeater2->DataSource=$data;
            $this->Repeater2->dataBind();
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveTextBox/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

<com:TContent ID="body">

<h1>TActiveTextBox Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
An active textbox being set as the result of a callback:
</td><td class="sampleaction">
<com:TActiveTextBox Text="Sample content" ID="txt1"
/>

<com:TActiveButton
    Text="click me"
    OnClick="buttonClicked"
/>
</td></tr>

<tr><td class="samplenote">
An active textbox with AutoPostBack="true"; Pressing Enter/Return, the textbox contents will be set on the label.
Note that text needs to be properly escaped to avoid html injections:
</td><td class="sampleaction">
<com:TActiveTextBox ID="txt2" AutoPostBack="true" OnTextChanged="textChanged"
/>
<com:TActiveLabel Text="" ID="label2"
/>
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveTextBox/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $this->txt1->Text="You clicked the button, didn't you?";
    }

    public function textChanged($sender,$param)
    {
        $this->label2->Text=THttpUtility::htmlEncode($this->txt2->Text);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TAutoComplete/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56

<com:TContent ID="body">

<style type="text/css">
<!--
.acomplete { position: relative; z-index: 5; background-color: #EDF5FF; border: 1px solid #243356; }
.acomplete ul, .acomplete li { margin: 0px; padding: 0px; list-style: none; color: #333; }
.acomplete li { padding: 4px; border-top: 1px solid #ccc; }
.acomplete .selected { background-color: #ffc; }
-->
</style>

<h1>TAutoComplete Sample (AJAX)</h1>

<table class="sampletable">

<tr><td class="samplenote">
Simple Autocompleter:
</td><td class="sampleaction">
<com:TAutoComplete
    ID="AutoComplete"
    OnSuggest="suggestNames"
    OnSuggestionSelected="suggestionSelected1"
    ResultPanel.CssClass="acomplete"
    Suggestions.DataKeyField="id" >

    <prop:Suggestions.ItemTemplate>
    <li><%# $this->Data['name'] %></li>
    </prop:Suggestions.ItemTemplate>
</com:TAutoComplete>
<com:TActiveLabel ID="Selection1" />
</td></tr>

<tr><td class="samplenote">
Autocompleter with multiple selection:
</td><td class="sampleaction">
<com:TAutoComplete
    ID="AutoComplete2"
    OnSuggest="suggestNames"
    OnSuggestionSelected="suggestionSelected2"
    Separator=","
    ResultPanel.CssClass="acomplete"
    Suggestions.DataKeyField="id" >

    <prop:Suggestions.ItemTemplate>
    <li><%# $this->Data['name'] %></li>
    </prop:Suggestions.ItemTemplate>
</com:TAutoComplete>
(Use ',' to separate the selected suggestions)
<com:TActiveLabel ID="Selection2" />
</td></tr>

</table>

<com:TJavascriptLogger />

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TAutoComplete/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34

<?php
// $Id: Home.php 2474 2008-07-03 17:28:20Z mikl $
class Home extends TPage
{
    public function suggestNames($sender,$param) {
        // Get the token
        $token=$param->getToken();
        // Sender is the Suggestions repeater
        $sender->DataSource=$this->getDummyData($token);
        $sender->dataBind();
    }

    public function suggestionSelected1($sender,$param) {
        $id=$sender->Suggestions->DataKeys[ $param->selectedIndex ];
        $this->Selection1->Text='Selected ID: '.$id;
    }

    public function suggestionSelected2($sender,$param) {
        $id=$sender->Suggestions->DataKeys[ $param->selectedIndex ];
        $this->Selection2->Text='Selected ID: '.$id;
    }

    public function getDummyData($token) {
        // You would look for matches to the given token here
        return array(
            array('id'=>1, 'name'=>'John'),
            array('id'=>2, 'name'=>'Paul'),
            array('id'=>3, 'name'=>'George'),
            array('id'=>4, 'name'=>'Ringo')
        );
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TCallback/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57

<com:TContent ID="body">

<h1>TCallback Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
An active label text being set as the result of a callback:
</td><td class="sampleaction">

<com:TCallback ID="callback1" OnCallback="callback1_Requested" />
<script type="text/javascript">
  function do_callback1()
  {
    var request = <%= $this->callback1->ActiveControl->Javascript %>;
    request.dispatch();
  }
</script>
<div onclick="do_callback1()" style="background-color:red;border: 1px solid black">Click Me!</div>
<br/><com:TActiveLabel Text="This is a label" ID="label1"
/>

<br/><com:TActiveButton
    Text="reset example"
    OnClick="buttonClicked"
/>
</td></tr>

<tr><td class="samplenote">
A TCallback with a 3-items array as parameter.
The first parameter is defined in the onclick() attribute of the red div;
The second parameter is defined in the body of the javascript function;
The third parameter is taken from the textbox;
</td><td class="sampleaction">

<com:TCallback ID="callback2" OnCallback="callback2_Requested" />
<script type="text/javascript">
  function do_callback2(param1)
  {
    var request = <%= $this->callback2->ActiveControl->Javascript %>;
    var param2 = 'value 2';
    var param3 = $('<%= $this->txt1->ClientID %>').value;
    request.setCallbackParameter({'Param1':param1, 'Param2':param2, 'Param3':param3});
    request.dispatch();
  }
</script>
TextBox for third parameter: <com:TTextBox ID="txt1" text="value 3"/>
<div onclick="do_callback2('value 1')" style="background-color:red;border: 1px solid black">Click Me!</div>
<br/>Parameter 1 is <com:TActiveLabel Text="" ID="labelParam1" />
<br/>Parameter 2 is <com:TActiveLabel Text="" ID="labelParam2" />
<br/>Parameter 3 is <com:TActiveLabel Text="" ID="labelParam3" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TCallback/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

<?php

class Home extends TPage
{
    public function callback1_Requested($sender,$param)
    {
        $this->label1->Text="You clicked the div, didn't you?";
    }

    public function buttonClicked($sender,$param)
    {
        $this->label1->Text="This is a label";
    }

    public function callback2_Requested($sender,$param)
    {
        $parameters=$param->CallbackParameter;
        $this->labelParam1->Text = THttpUtility::htmlEncode($parameters->Param1);
        $this->labelParam2->Text = THttpUtility::htmlEncode($parameters->Param2);
        $this->labelParam3->Text = THttpUtility::htmlEncode($parameters->Param3);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TCallbackClientScript/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39

<com:TContent ID="body">
<h1>TCallbackClientScript Samples</h1>

<p>
  Choose an action from the list and click the button; the server-side php code will get the selected value and
  force the execution of some clientside js code in the callback response.
</p>

<h2>Actions</h2>
<com:TRadioButtonList ID="radio1">
  <com:TListItem Value="1" Text="alert() me of something" />
  <com:TListItem Value="2" Text="toggle Checkbox 1" />
  <com:TListItem Value="3" Text="hide Label 1" />
  <com:TListItem Value="4" Text="show Label 1" />
  <com:TListItem Value="5" Text="focus TextBox 1" />
</com:TRadioButtonList>

<br/><com:TActiveButton ID="button1" OnCallback="buttonCallback" Text="callback!" />

<h2>Results</h2>

<table>
  <tr>
    <td>Checkbox 1:</td>
    <td><com:TCheckBox ID="check1" Text="Checkbox 1" /></td>
  </tr>
  <tr>
    <td>Label 1:</td>
    <td><com:TLabel ID="label1" ForeColor="Red" Text="Text of Label 1" /></td>
  </tr>
  <tr>
    <td>TextBox 1:</td>
    <td><com:TTextBox ID="txt1" Text="Sample text" /></td>
  </tr>
</table>

<com:TJavascriptLogger />

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TCallbackClientScript/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<?php

// $Id: Home.php -1   $
class Home extends TPage
{
    public function buttonCallback ($sender, $param)
    {
        switch($this->radio1->SelectedValue)
        {
            case 1:
                $this->getCallbackClient()->evaluateScript("<script> alert('something'); </script>");
                break;
            case 2:
                $this->getCallbackClient()->check($this->check1, !$this->check1->Checked);
                break;
            case 3:
                $this->getCallbackClient()->hide($this->label1);
                break;
            case 4:
                $this->getCallbackClient()->show($this->label1);
                break;
            case 5:
                $this->getCallbackClient()->focus($this->txt1);
                break;
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TCallbackClientSide/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73

<com:TContent ID="body">
<h1>TCallbackClientSide Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A callback button with attached client side options:
</td><td class="sampleaction">
<com:TActiveButton
    Text="click me"
    OnCallback="buttonCallback"
>
    <prop:ClientSide
      OnLoading="$('callback_status2').hide(); new Effect.BlindDown('callback_status', { duration: 1 });"
      OnComplete="new Effect.BlindUp('callback_status', { duration: 1 }); $('callback_status2').show();"
    />
</com:TActiveButton>
<div id="callback_status" style="display:none;">please wait 5 seconds for the callback to complete...</div>
<div id="callback_status2" style="display:none;">callback completed!</div>
</td></tr>

<tr><td class="samplenote">
A callback button logging all callback events (5 seconds delay):
</td><td class="sampleaction">
<com:TActiveButton
    Text="click me"
    OnCallback="buttonCallback"
>
    <prop:ClientSide
        onPreDispatch   = "new Insertion.Bottom('<%= $this->label1->ClientID %>', '<br/>onPreDispatch');"
        onUninitialized = "new Insertion.Bottom('<%= $this->label1->ClientID %>', '<br/>onUninitialized');"
        onLoading       = "new Insertion.Bottom('<%= $this->label1->ClientID %>', '<br/>onLoading');"
        onLoaded        = "new Insertion.Bottom('<%= $this->label1->ClientID %>', '<br/>onLoaded');"
        onInteractive   = "new Insertion.Bottom('<%= $this->label1->ClientID %>', '<br/>onInteractive');"
        onComplete      = "new Insertion.Bottom('<%= $this->label1->ClientID %>', '<br/>onComplete');"
        onSuccess       = "new Insertion.Bottom('<%= $this->label1->ClientID %>', '<br/>onSuccess');"
        onFailure       = "new Insertion.Bottom('<%= $this->label1->ClientID %>', '<br/>onFailure');"
        onException     = "new Insertion.Bottom('<%= $this->label1->ClientID %>', '<br/>onException');"
    />
</com:TActiveButton>
<br/><com:TLabel ID="label1" ForeColor="Red" Text="waiting for button click.." />
</td></tr>

<tr><td class="samplenote">
A callback with RequestTimeout="3000" (3 seconds). Since the callback will take 5 seconds to complete, the clientside will timeout.
This will cause a "missing page state" error; note that the callback is not considered failed, since no
connection error has occured.
</td><td class="sampleaction">
<com:TActiveButton
    Text="click me"
    OnCallback="buttonCallback"
>
    <prop:ClientSide
        onPreDispatch   = "new Insertion.Bottom('<%= $this->label2->ClientID %>', '<br/>onPreDispatch');"
        onUninitialized = "new Insertion.Bottom('<%= $this->label2->ClientID %>', '<br/>onUninitialized');"
        onLoading       = "new Insertion.Bottom('<%= $this->label2->ClientID %>', '<br/>onLoading');"
        onLoaded        = "new Insertion.Bottom('<%= $this->label2->ClientID %>', '<br/>onLoaded');"
        onInteractive   = "new Insertion.Bottom('<%= $this->label2->ClientID %>', '<br/>onInteractive');"
        onComplete      = "new Insertion.Bottom('<%= $this->label2->ClientID %>', '<br/>onComplete');"
        onSuccess       = "new Insertion.Bottom('<%= $this->label2->ClientID %>', '<br/>onSuccess');"
        onFailure       = "new Insertion.Bottom('<%= $this->label2->ClientID %>', '<br/>onFailure');"
        onException     = "new Insertion.Bottom('<%= $this->label2->ClientID %>', '<br/>onException');"
        RequestTimeOut  = "3000"
    />
</com:TActiveButton>
<br/><com:TLabel ID="label2" ForeColor="Red" Text="waiting for button click.." />
</td></tr>

</table>

<com:TJavascriptLogger />

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TCallbackClientSide/Home.php

1
2
3
4
5
6
7
8
9
10
11
12

<?php

// $Id: Home.php -1   $
class Home extends TPage
{
    public function buttonCallback ($sender, $param)
    {
        sleep(5);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TCallbackOptions/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77

<com:TContent ID="body">
<h1>TCallbackOptions Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A callback button with attached client side options:
</td><td class="sampleaction">
<com:TActiveButton
    Text="click me"
    OnCallback="buttonCallback"
    ActiveControl.CallbackOptions="options"
/>
<com:TCallbackOptions
    ID="options"
    ClientSide.OnLoading="$('callback_status2').hide(); new Effect.BlindDown('callback_status', { duration: 1 });"
    ClientSide.OnComplete="new Effect.BlindUp('callback_status', { duration: 1 }); $('callback_status2').show();"
/>
<div id="callback_status" style="display:none;">please wait 5 seconds for the callback to complete...</div>
<div id="callback_status2" style="display:none;">callback completed!</div>
</td></tr>

<tr><td class="samplenote">
Same example as before, but this time interacting with another Prado control:
</td><td class="sampleaction">
<com:TActiveButton
    Text="click me"
    OnCallback="buttonCallback"
    ActiveControl.CallbackOptions="options2"
/>
<com:TCallbackOptions
    ID="options2"
    ClientSide.OnLoading="$('<%= $this->label1->ClientID %>').innerHTML='please wait 5 seconds for the callback to complete....';"
    ClientSide.OnComplete="$('<%= $this->label1->ClientID %>').innerHTML='callback completed!';"
/>
<br/><com:TLabel ID="label1" ForeColor="Red" Text="waiting for button click.." />
</td></tr>

<tr><td class="samplenote">
The same TCallbackOptions can be shared among different controls, even of different types:
</td><td class="sampleaction">
<com:TActiveButton
    Text="simple button"
    OnCallback="buttonCallback"
    ActiveControl.CallbackOptions="options3"
/>

<br/><com:TActiveCheckBox
    Text="simple checkbox"
    OnCallback="buttonCallback"
    ActiveControl.CallbackOptions="options3"
/>

<br/><com:TActiveDropDownList
    OnCallback="buttonCallback"
    ActiveControl.CallbackOptions="options3"
>
    <com:TListItem Value="value 1" Text="item 1" />
    <com:TListItem Value="value 2" Text="item 2" Selected="true" />
    <com:TListItem Value="value 3" Text="item 3" />
    <com:TListItem Value="value 4" Text="item 4" />
</com:TActiveDropDownList>

<br/><com:TLabel ID="label2" ForeColor="Red" Text="waiting for any control to callback.." />

<com:TCallbackOptions
    ID="options3"
    ClientSide.OnLoading="$('<%= $this->label2->ClientID %>').innerHTML='please wait 5 seconds for the callback to complete....';"
    ClientSide.OnComplete="$('<%= $this->label2->ClientID %>').innerHTML='callback completed!';"
/>

</td></tr>
</table>

<com:TJavascriptLogger />

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TCallbackOptions/Home.php

1
2
3
4
5
6
7
8
9
10
11
12

<?php

// $Id: Home.php 2959 2011-06-02 16:06:37Z ctrlaltca@gmail.com $
class Home extends TPage
{
    public function buttonCallback ($sender, $param)
    {
        sleep(5);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TEventTriggeredCallback/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<com:TContent ID="body">

<h1>TEventTriggeredCallback Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
  A callback will be executed when the textbox receives and loses focus
</td><td class="sampleaction">
  <com:TTextBox ID="txt1" />
  <com:TEventTriggeredCallback ControlID="txt1" EventName="focus" OnCallback="txtFocused" />
  <com:TEventTriggeredCallback ControlID="txt1" EventName="blur" OnCallback="txtBlurred" />
  <com:TActiveLabel ID="label1" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TEventTriggeredCallback/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<?php

class Home extends TPage
{
    public function txtFocused($sender,$param)
    {
        $this->label1->Text="Textbox focused";
    }

    public function txtBlurred($sender,$param)
    {
        $this->label1->Text="Textbox lost focus";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TInPlaceTextBox/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<com:TContent ID="body">

<h1>TInPlaceTextBox Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
An in-place textbox text updating a label when its text changes:
</td><td class="sampleaction">
<com:TInPlaceTextBox ID="txt1" Text="This is an in-place textbox" OnTextChanged="textChanged" />
<br/><com:TActiveLabel Text="This is a label" ID="label1"
/>
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TInPlaceTextBox/Home.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Home extends TPage
{
    public function textChanged($sender,$param)
    {
        $this->label1->Text=$this->txt1->Text;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TTimeTriggeredCallback/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

<com:TContent ID="body">

<h1>TTimeTriggeredCallback Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A timer updating a label with the current time every 5 seconds:
</td><td class="sampleaction">
<com:TTimeTriggeredCallback ID="time1" Interval="5" OnCallback="timercallback" />
<com:TActiveButton
    Text="start timer"
    OnClick="startClicked"
/>
<com:TActiveButton
    Text="stop timer"
    OnClick="stopClicked"
/>
<com:TActiveLabel ID="label1" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TTimeTriggeredCallback/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22

<?php

class Home extends TPage
{
    public function startClicked($sender,$param)
    {
        $this->time1->startTimer();
    }

    public function stopClicked($sender,$param)
    {
        $this->time1->stopTimer();
    }

    public function timerCallback($sender,$param)
    {
        $this->label1->Text="Current time is ".date('H:i:s');
    }

}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TValueTriggeredCallback/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<com:TContent ID="body">

<h1>TValueTriggeredCallback Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
  A callback will be executed when the textbox text changes
</td><td class="sampleaction">
  <com:TTextBox ID="txt1" />
  <com:TValueTriggeredCallback ControlID="txt1" PropertyName="value" OnCallback="checkTxtValue" />
  <com:TActiveLabel ID="label1" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TValueTriggeredCallback/Home.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Home extends TPage
{
    public function checkTxtValue($sender,$param)
    {
        $this->label1->Text=date("[H:i:s]")." Textbox changed";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.de.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152

<%@ Title="Internationalisierung in PRADO "
    Page.Application.Globalization.TranslationCatalogue="index" %>
<com:TContent ID="body">
<h1>Internationalisierung in PRADO </h1>
<p>Diese Demo zeigt die grundlegenden Bestandteile, die in PRADO für den Prozess der Internationalisierung und regionalen Anpassung von Web-Anwendungen vorhanden sind. Das Beispiel verwendet mehrere sprachlich (bzw. kulturell) angepasste Templates, um eine lokalisierte Seite anzuzeigen. Um eine anderssprachige Version anzusehen, ändern Sie bitte die Spracheinstellungen in Ihrem Webbrowser.</p>

<p>
 Ihre aktuelle Kultur ist
<%= $this->Page->CurrentCulture %>.
<div class="links">
 Vorhandene Sprachversionen:
    <com:LanguageList />
</div>
</p>

<p>
Weiter mit dem Thema kulturell angepasster Templates. Text kann unter Zuhilfenahme vieler unterschiedlicher Übersetzungsquellen lokalisiert werden. PRADO stellt gettext-, XML-, SQLite- und MySQL-Container für die Speicherung von Nachrichtenübersetzungen zur Verfügung. Das Beispiel im folgenden Link zeigt, wie Text mit der TTranslate-Komponente lokalisiert werden kann.
<hr />
<h2>Einleitung </h2>
<p> Entwicklung und Wartung mehrsprachiger Sites ist ein weitverbreitetes Problem fÜr Web-Entwickler.</p>
<dl>
<dt><strong>Internationalisierung (I18N)</strong></dt>
<dd> Prozess der Entwicklung eines Produktes, so dass es mit Daten in unterschiedlichen Sprachen funktioniert und an verschiedene Zielmärkte ohne Technikänderungen angepasst werden kann. </dd>
<dt><strong>Lokalisation (L10N)</strong></dt>
<dd>Nachfolgender Prozess der Übersetzung und Anpassung eines Produktes an die kulturellen Konventionen eines gegebenen Marktes.</dd>
</dl>
<p> Die folgenden Merkmale werden von PRADO unterstützt: </p>
<ul id="u1" class="block-content">
  <li>Textübersetzung </li>
  <li>Attributübersetzung (noch zu implementieren) </li>
  <li>Parameteraustausch (falls erforderlich mit Übersetzung) </li>
  <li>Datums-, Zahlen- und Währungsformatierung</li>
  </ul>
<h2>Beispiele </h2>
<h3>Datum: volles Muster, Kultur en_GB</h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/> <br />
<hr />

<h3>Datum: kurzes Muster</h3>
<h4>Beispiel:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time2" Pattern="short" /&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TDateFormat ID="Time2" Pattern="short" /> <br />
<hr />

<h3>Datum: Standardmuster von <%= $this->Page->CurrentCulture %> </h3>
<h4>Beispiel:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time3" Value="2004/12/06" /&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TDateFormat ID="Time3" Value="2004/12/06" /> <br />
<hr />

<h3>Währung Standardformat </h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Value="12.4" /&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TNumberFormat Type="currency" Value="12.4" /> <br />

<hr />

<h3>Währung, Kultur de_DE mit Euro </h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/> <br />

<hr />

<h3>Währung, US-Format mit Euro </h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /> <br />
<hr />

<h3>Übersetzungsbeispiele </h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;Hello&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TTranslate>Hello</com:TTranslate> <br />
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" /&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TTranslate Text="Goodbye" /> <br />

<hr />
<h3>Using localization tag</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;%[ Goodbye ]%&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<%[ Goodbye ]%>
<br />

<hr />
<h3>Übersetzung mit Verwendung eines anderen Kataloges</h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" Catalogue="tests" /&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TTranslate Text="Goodbye" Catalogue="tests" />
<br />

<hr />
<h3>Übersetzung mit Parameteraustausch </h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;
    {greeting} {name}!, The unix-time is "{time}".
    &lt;com:TTranslateParameter Key="name"&gt;
        &lt;com:TTranslate Catalogue="tests" Text="World" /&gt;
    &lt;/com:TTranslateParameter&gt;
    &lt;com:TTranslateParameter Key="greeting" Value="Hello" /&gt;
    &lt;com:TTranslateParameter Key="time" Value="&lt;%= Time() %&gt;" /&gt;
&lt;/com:TTranslate&gt;
</com:TTextHighlighter>

<h4>Resultat: </h4>

<com:TTranslate>
    {greeting} {name}!, The unix-time is "{time}".
    <com:TTranslateParameter Key="name">
        <com:TTranslate Catalogue="tests" Text="World" />
    </com:TTranslateParameter>
    <com:TTranslateParameter Key="greeting" Value="Hello" />
    <com:TTranslateParameter Key="time" Value="<%= Time() %>" />
</com:TTranslate>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.es.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150

<%@ Title="Internationlization en PRADO "
    Page.Application.Globalization.TranslationCatalogue="index" %>
<com:TContent ID="body">
<h1>Internationlization en PRADO </h1>
<p> Esta versión parcial de programa muestra los componentes básicos disponibles en PRADO para el proceso de internacionalizar y de localizar aplicaciones del Web. Esta paginación utiliza modelos enterados múltiples del locale (o cultura) para mostrar la paginación localizada apropiada. Para visión una diversa versión localizada, cambie por favor sus configuraciones del lenguaje en su browser. </p>

<p>
 Su cultura actual es
<%= $this->Page->CurrentCulture %>.
<div class="links">
 Versiones localizadas disponibles:
    <com:LanguageList />
</div>
</p>

<p>
 Además de modelo enterado de la cultura. El texto se puede localizar usando muchas diversas fuentes de la traducción. PRADO proporciona al gettext, al envase de XML, de SQLite, y de MySQL para salvar traducciones del mensaje. El ejemplo en la conexión siguiente demuestra cómo el texto se puede localizar usando el componente de TTranslate.
<hr />
<h2>Introducción </h2>
<p> Que desarrolla y que los mantiene el multi-lenguaje sitios es un problema común para los reveladores del Web.</p>
<dl>
<dt><strong>Internacionalización (I18N)</strong></dt>
<dd> Proceso de desarrollar un producto de una manera tal que trabaje con datos en diversos lenguajes y pueda ser adaptado a los varios mercados de blanco sin cambios de ingeniería. </dd>
<dt><strong>Localización (L10N)</strong></dt>
<dd> Proceso subsecuente de traducir y de adaptar un producto a las convenciones culturales de un mercado dado. </dd>
</dl>
<p> Las características siguientes son utilizadas por PRADO: </p>
<ul id="u1" class="block-content">
  <li>Traducción del texto </li>
  <li>Traducción del atributo (todo) </li>
  <li>Substitución de parámetro (con la traducción si es necesario) </li>
  <li>Fecha, número y formato de la modernidad </li>
  </ul>
<h2>Ejemplos </h2>
<h3>Fecha: modelo completo, cultura del en_GB </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/> <br />
<hr />

<h3>Fecha: modelo corto </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time2" Pattern="short" /&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TDateFormat ID="Time2" Pattern="short" /> <br />
<hr />

<h3>Modelo del valor por defecto de la fecha del <%= $this->Page->CurrentCulture %> </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time3" Value="2004/12/06" /&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TDateFormat ID="Time3" Value="2004/12/06" /> <br />
<hr />

<h3>Formato del valor por defecto de la modernidad </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Value="12.4" /&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TNumberFormat Type="currency" Value="12.4" /> <br />
<hr />
<h3>Modernidad, cultura del de_DE con el Euro </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/> <br />

<hr />

<h3>Modernidad, formato de los E.E.U.U. con el Euro </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /> <br />
<hr />

<h3>Ejemplos de la traducción </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;Hello&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TTranslate>Hello</com:TTranslate> <br />
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" /&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TTranslate Text="Goodbye" /> <br />

<hr />
<h3>Using localization tag</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;%[ Goodbye ]%&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<%[ Goodbye ]%>
<br />

<hr />
<h3>Traducción usando un diverso catálogo </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" Catalogue="tests" /&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TTranslate Text="Goodbye" Catalogue="tests" />
<br />

<hr />
<h3>Traducción con la substitución de parámetro </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;
    {greeting} {name}!, The unix-time is "{time}".
    &lt;com:TTranslateParameter Key="name"&gt;
        &lt;com:TTranslate Catalogue="tests" Text="World" /&gt;
    &lt;/com:TTranslateParameter&gt;
    &lt;com:TTranslateParameter Key="greeting" Value="Hello" /&gt;
    &lt;com:TTranslateParameter Key="time" Value="&lt;%= Time() %&gt;" /&gt;
&lt;/com:TTranslate&gt;
</com:TTextHighlighter>

<h4>Resultado: </h4>

<com:TTranslate>
    {greeting} {name}!, The unix-time is "{time}".
    <com:TTranslateParameter Key="name">
        <com:TTranslate Catalogue="tests" Text="World" />
    </com:TTranslateParameter>
    <com:TTranslateParameter Key="greeting" Value="Hello" />
    <com:TTranslateParameter Key="time" Value="<%= Time() %>" />
</com:TTranslate>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.fr.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202

<%@ Title="Internationalisation dans PRADO"
    Page.Application.Globalization.TranslationCatalogue="index" %>
<com:TContent ID="body">
            <h1>Internationalisation&nbsp;avec PRADO
            </h1>
            <p>
                Cette démonstration présente&nbsp;les composants de base&nbsp;fournis
                par&nbsp;PRADO pour le processus d'internationalisation et de localisation des
                applications Web. Cette page utilise plusieurs gabarits en fonction de la
                localisation (ou de la culture) pour afficher le contenu&nbsp;approprié. Pour
                afficher une version localisée différente, veuillez changer la configuration
                des langues dans votre navigateur.
            </p>
            <p>
                Votre culture actuelle est <%= $this->Page->CurrentCulture %>.
                <div class="links">
                    Versions localisées disponibles :
                    <com:LanguageList />
                </div>
            <P></P>
            <p>
                En plus du support de la culture dans les gabarits, le&nbsp;contenu peut être
                localisé en utilisant différentes sources de traduction. PRADO permet
                d'utiliser gettext, XML, SQLite et MySQL pour enregistrer les traductions des
                messages. L'exemple suivant montre comment le texte peut être localisé en
                utilisant le composant TTranslate.
            <hr>
            <h2>Introduction
            </h2>
            <p>
                Développer et mettre à jour un site multi-langues est un problème classique
                pour les développeurs de sites Web.</p>
            <dl>
                <dt><strong>Internationalisation (I18N)</strong>
                    <dd>
                        Processus de développement d'un produit de telle manière qu'il fonctionne avec
                        des données dans différentes langues et puisse être adapté à
                        diverses&nbsp;cibles culturelles sans changement technique. <dt><strong>Localisation
                                (L10N)</strong>
                            <dd>
                                Processus ultérieur de traduction et d'adaptation d'un produit aux conventions
                                culturelles d'un marché donné.
                            </dd>
            </dl>
            <p>
                PRADO offrent les fonctionnalités suivantes&nbsp; :
            </p>
            <ul id="u1" class="block-content">
                <li>
                Traduction de contenu
                <li>
                Traduction des attributs (à faire)
                <li>
                Substitution des paramètres (avec traduction si nécessaire)
                <li>
                    Date, nombre et formatage des devises
                </li>
            </ul>
            <h2>Exemples</h2>
            <h3>Date : format long, culture en_GB</h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
            <com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB" />
            <br>
            <hr>
            <h3>Date : format court
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time2" Pattern="short" /&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
            <com:TDateFormat ID="Time2" Pattern="short" />
            <br>
            <hr>
            <h3>Format par défaut d'une date pour la culture
                <%= $this->Page->CurrentCulture %>
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time3" Value="2004/12/06" /&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
<com:TDateFormat ID="Time3" Value="2004/12/06" /> <br />
            <br>
            <hr>
            <h3>Format par défaut d'une devise
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Value="12.4" /&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
<com:TNumberFormat Type="currency" Value="12.4" /> <br />
            <br>
            <hr>
            <h3>Devise :&nbsp;culture de_DE avec devise Euro
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
            <com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR" />
            <br>
            <hr>
            <h3>Devise :&nbsp;culture en_US avec devise Euro
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /&gt;
</com:TTextHighlighter>
            <h4>Résultat
            </h4>
            <com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" />
            <br>
            <hr>
            <h3>Exemples de traduction
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;Hello&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
            <com:TTranslate>Hello</com:TTranslate>
            <br>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" /&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
            <com:TTranslate Text="Goodbye" />
            <br>

<hr />
<h3>Using localization tag</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;%[ Goodbye ]%&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<%[ Goodbye ]%>
<br />

            <hr>
            <h3>Traduction en utilisant un catalogue différent</h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" Catalogue="tests" /&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
<com:TTranslate Text="Goodbye" Catalogue="tests" />
            <br>
            <hr>
            <h3>Traduction avec substitution de paramètres
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;
    {greeting} {name}!, The unix-time is "{time}".
    &lt;com:TTranslateParameter Key="name"&gt;
        &lt;com:TTranslate Catalogue="tests" Text="World" /&gt;
    &lt;/com:TTranslateParameter&gt;
    &lt;com:TTranslateParameter Key="greeting" Value="Hello" /&gt;
    &lt;com:TTranslateParameter Key="time" Value="&lt;%= Time() %&gt;" /&gt;
&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
<com:TTranslate>
    {greeting} {name}!, The unix-time is "{time}".
    <com:TTranslateParameter Key="name">
        <com:TTranslate Catalogue="tests" Text="World" />
    </com:TTranslateParameter>
    <com:TTranslateParameter Key="greeting" Value="Hello" />
    <com:TTranslateParameter Key="time" Value="<%= Time() %>" />
</com:TTranslate>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161

<%@ Title="Internationlization  in PRADO"
    Page.Application.Globalization.TranslationCatalogue="index" %>
<com:TContent ID="body">

<h1>Internationlization  in PRADO</h1>
<p>This demo shows the basic components available in PRADO for the process of Internationalizing and Localizing web applications. This page utilize multiple locale (or culture) aware templates to show the appropriate localized page. To view a different localized version, please change your language settings in your browser.</p>

<p>
Your current culture is <%= $this->Page->CurrentCulture %>.
<div class="links">
    Available localized versions:
    <com:LanguageList />
</div>
</p>

<p>
    In addition to culture aware template. Text can be localized using many different translation sources. PRADO provides gettext, XML, SQLite, and MySQL container for storing message translations. The example in the following link demonstrates how text can be localized using the TTranslate component.
</p>
<hr />
<h2>Introduction</h2>
<p> Developing and maintaining multi-language sites is a common problem for web developers. </p>
<dl>
<dt><strong>Internationalization (I18N)</strong></dt>
<dd>Process of developing a product in such a way that it works with data in different languages and can be adapted to various target markets without engineering changes. </dd>
<dt><strong>Localization (L10N)</strong></dt>
<dd>Subsequent process of translating and adapting a product to a given market's cultural conventions.</dd>
</dl>
<p>The following features are supported by PRADO: </p>
<ul id="u1" class="block-content">
  <li>Text translation</li>
  <li>Attribute translation</li>
  <li>Parameter substitution (with translation if needed) </li>
  <li>Date, number and currency formatting </li>
</ul>
<h2>Examples</h2>
<h3>Date: full pattern, en_GB culture</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/&gt;
</com:TTextHighlighter>
<h4>Result:</h4>
<com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/> <br />
<hr />

<h3>Date: short pattern</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time2" Pattern="short" /&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TDateFormat ID="Time2" Pattern="short" /> <br />
<hr />

<h3>Date default pattern of <%= $this->Page->CurrentCulture %> </h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time3" Value="2004/12/06" /&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TDateFormat ID="Time3" Value="2004/12/06" /> <br />
<hr />

<h3>Currency default format</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Value="12.4" /&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TNumberFormat Type="currency" Value="12.4" /> <br />
<hr />
<h3>Currency, de_DE culture with Euro</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/> <br />

<hr />

<h3>Currency, US format with Euro</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /&gt;
</com:TTextHighlighter>

<h4>Result</h4>
<com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /> <br />
<hr />

<h3>Translation examples</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;Hello&lt;/com:TTranslate&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TTranslate>Hello</com:TTranslate> <br />
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" /&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TTranslate Text="Goodbye" /> <br />

<hr />
<h3>Using localization tag</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;%[ Goodbye ]%&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<%[ Goodbye ]%>
<br />

<hr />
<h3>Translation using a different catalogue </h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" Catalogue="tests" /&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TTranslate Text="Goodbye" Catalogue="tests" />
<br />

<hr />
<h3>Translation with parameter substitution</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;
    {greeting} {name}!, The unix-time is "{time}".
    &lt;com:TTranslateParameter Key="name"&gt;
        &lt;com:TTranslate Catalogue="tests" Text="World" /&gt;
    &lt;/com:TTranslateParameter&gt;
    &lt;com:TTranslateParameter Key="greeting" Value="Hello" /&gt;
    &lt;com:TTranslateParameter Key="time" Value="&lt;%= Time() %&gt;" /&gt;
&lt;/com:TTranslate&gt;
</com:TTextHighlighter>

<h4>Result:</h4>

<com:TTranslate>
    {greeting} {name}!, The unix-time is "{time}".
    <com:TTranslateParameter Key="name">
        <com:TTranslate Catalogue="tests" Text="World" />
    </com:TTranslateParameter>
    <com:TTranslateParameter Key="greeting" Value="Hello" />
    <com:TTranslateParameter Key="time" Value="<%= Time() %>" />
</com:TTranslate>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45

<?php

class Home extends TPage
{
    /**
     * Change the globalization culture using value from request "lang" parameter.
     */
    public function __construct()
    {
        parent::__construct();
        $lang = $this->Request['lang'];
        $info = new CultureInfo();
        if($info->validCulture($lang)) //only valid lang is permitted
            $this->getApplication()->getGlobalization()->setCulture($lang);
    }

    /**
     * Initialize the page with some arbituary data.
     * @param TEventParameter event parameter.
     */
    public function onLoad($param)
    {
        parent::onLoad($param);
        $time1 = $this->Time1;
        $time1->Value = time();

        $number2 = $this->Number2;
        $number2->Value = 46412.416;

        $this->dataBind();
    }

    /**
     * Get the localized current culture name.
     * @return string localized curreny culture name.
     */
    public function getCurrentCulture()
    {
        $culture = $this->getApplication()->getGlobalization()->getCulture();
        $cultureInfo = new CultureInfo($culture);
        return $cultureInfo->getNativeName();
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.pl.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149

<%@ Title="Internacjonalizacja w PRADO"
    Page.Application.Globalization.TranslationCatalogue="index" %>
<com:TContent ID="body">
<h1>Internacjonalizacja w PRADO</h1>
<p>Ten przykład pokazuje podstawowe komponenty PRADO używane w procesach Internacjonalizacji i Lokalizacji aplikacji webowych. Ta strona używa wielu zlokalizowanych, pod względem językowo-kulturowym, szablonów aby wyświetlić właściwe tłumaczenie. Aby zobaczyć inne lokalizacje, musisz zmienić ustawienia językowe w swojej przeglądarce.
</p>

<p>
Twoim obecnym językiem jest: <%= $this->Page->CurrentCulture %>.
<div class="links">
    Dostępne lokalizacje:
    <com:LanguageList />
</div>
</p>

<p>
    Nawiązanie do szablonów kulturowo-językowych. Tekst może zostać zlokalizowany przy użyciu wielu źródeł tłumaczeń. PRADO umożliwia przechowywanie tłumaczeń przy pomocy następujących modułów: gettext, XML, SQLite oraz MySQL. Przykład do którego prowadzi poniższy odnośnik pokazuje jak można zlokalizować treść używając kontrolki TTranslate.
<hr />
<h2>Wstęp</h2>
<p> Tworzenie i utrzymywanie wielojęzykowych serwisów to problem który trapi wielu programistów. </p>
<dl>
<dt><strong>Internacjonalizacja (I18N)</strong></dt>
<dd> To proces takiego przygotowania produktu aby mógł operować na danych w różnych językach, na wielu rynkach bez konieczności zmian w nim samym. </dd>
<dt><strong>Lokalizacja (L10N)</strong></dt>
<dd> To kolejny etap, jest to proces tłumaczenia i dostosowywania produktu do konkretnych wymagań językowo-kulturowych.</dd>
</dl>
<p>PRADO obsługuje następujące mechanizmy: </p>
<ul id="u1" class="block-content">
  <li>Tłumaczenie tekstu </li>
  <li>Tłumaczenie atrybutów (todo) </li>
  <li>Podstawianie parametrów (wraz z koniecznym tłumaczeniem) </li>
  <li>Formatowanie dat, liczb i walut </li>
</ul>
<h2>Przykłady</h2>
<h3>Data: pełny format językowo-kulturowy: en_GB</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/> <br />
<hr />

<h3>Data: format krótki</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time2" Pattern="short" /&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TDateFormat ID="Time2" Pattern="short" /> <br />
<hr />

<h3>Domyślny format daty dla języka: <%= $this->Page->CurrentCulture %> </h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time3" Value="2004/12/06" /&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TDateFormat ID="Time3" Value="2004/12/06" /> <br />
<hr />

<h3>Domyślny format waluty</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Value="12.4" /&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TNumberFormat Type="currency" Value="12.4" /> <br />
<hr />
<h3>Waluty, format językowo-kulturowy de_DE w Euro</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/> <br />

<hr />

<h3>Waluty, format Amerykański w Euro</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /&gt;
</com:TTextHighlighter>
<h4>Wynik</h4>
<com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /> <br />
<hr />

<h3>Tłumaczenia</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;Hello&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TTranslate>Hello</com:TTranslate> <br />
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" /&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TTranslate Text="Goodbye" /> <br />

<hr />
<h3>Using localization tag</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;%[ Goodbye ]%&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<%[ Goodbye ]%>
<br />

<hr />
<h3>Tłumaczenie z wykorzystaniem innego katalogu </h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" Catalogue="tests" /&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TTranslate Text="Goodbye" Catalogue="tests" />
<br />

<hr />
<h3>Tłumaczenie z wykorzystanie podstawiania parametru</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;
    {greeting} {name}!, The unix-time is "{time}".
    &lt;com:TTranslateParameter Key="name"&gt;
        &lt;com:TTranslate Catalogue="tests" Text="World" /&gt;
    &lt;/com:TTranslateParameter&gt;
    &lt;com:TTranslateParameter Key="greeting" Value="Hello" /&gt;
    &lt;com:TTranslateParameter Key="time" Value="&lt;%= Time() %&gt;" /&gt;
&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>

<com:TTranslate>
    {greeting} {name}!, The unix-time is "{time}".
    <com:TTranslateParameter Key="name">
        <com:TTranslate Catalogue="tests" Text="World" />
    </com:TTranslateParameter>
    <com:TTranslateParameter Key="greeting" Value="Hello" />
    <com:TTranslateParameter Key="time" Value="<%= Time() %>" />
</com:TTranslate>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.zh.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156

<%@ Title="PRADO 国际化"
    Page.Application.Globalization.TranslationCatalogue="index" %>
<com:TContent ID="body">

<h1>PRADO 国际化</h1>
<p>本演示将介绍如何用PRADO中的一些部件对您的Web应用进行国际化和本地化。
本网页的显示是根据您的当地设置从多个不同语言的模板中选择进行的。
如果你想查看其它语言版本，请更改浏览器的语言设置。</p>

<p>
您目前的语言设置是
<%= $this->Page->CurrentCulture %>.
<div class="links">
可查看的语言版本包括：
    <com:LanguageList />
</div>
</p>

<p>
除了能自动侦知语言设置的模板外，文本也可以使用不同的翻译源进行本地化。
PRADO提供了gettext，XML，SQLite以及MySQL等手段用于存放消息的各种翻译。
下面连接所指向的例子展示了如何使用TTranslate部件对文本进行本地化。
<hr />
<h2>简介</h2>
<p>开发和维护多语言的站点对Web开发者而言是一个很常见的问题。</p>
<dl>
<dt><strong>国际化（I18N）</strong></dt>
<dd>产品开发的一个步骤，它使得产品能接受不同语言的数据，并且在没有更改设计
的情况下使产品能用于不同的市场。</dd>
<dt><strong>L本地化（L10N）</strong></dt>
<dd>国际化的一个细节步骤，它针对某个特定的市场文化对产品进行翻译和调整。</dd>
</dl>
<p>PRADO支持以下功能：</p>
<ul id="u1" class="block-content">
  <li>文本翻译</li>
  <li>属性翻译（尚未完成）</li>
  <li>参数替换（如需要可进行翻译）</li>
  <li>日期，数字和货币的格式化</li>
  </ul>
<h2>例子</h2>
<h3>日期：完整格式，en_GB语言设置</h3>
<h4>例: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/&gt;
</com:TTextHighlighter>
<h4>结果: </h4>
<com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/> <br />
<hr />

<h3>日期：短格式</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time2" Pattern="short" /&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TDateFormat ID="Time2" Pattern="short" /> <br />
<hr />

<h3>日期：<%= $this->Page->CurrentCulture %>的缺省模式</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time3" Value="2004/12/06" /&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TDateFormat ID="Time3" Value="2004/12/06" /> <br />
<hr />

<h3>货币，缺省格式</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Value="12.4" /&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TNumberFormat Type="currency" Value="12.4" /> <br />
<hr />
<h3>货币，de_DE语言以及欧币</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/> <br />

<hr />

<h3>货币, 美国格式以及欧币</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /> <br />
<hr />

<h3>翻译实例</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;Hello&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TTranslate>Hello</com:TTranslate> <br />
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" /&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TTranslate Text="Goodbye" /> <br />

<hr />
<h3>Using localization tag</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;%[ Goodbye ]%&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<%[ Goodbye ]%>
<br />

<hr />
<h3>用不同目录进行翻译</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" Catalogue="tests" /&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TTranslate Text="Goodbye" Catalogue="tests" />
<br />

<hr />
<h3>用参数替换进行翻译</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;
    {greeting} {name}!, The unix-time is "{time}".
    &lt;com:TTranslateParameter Key="name"&gt;
        &lt;com:TTranslate Catalogue="tests" Text="World" /&gt;
    &lt;/com:TTranslateParameter&gt;
    &lt;com:TTranslateParameter Key="greeting" Value="Hello" /&gt;
    &lt;com:TTranslateParameter Key="time" Value="&lt;%= Time() %&gt;" /&gt;
&lt;/com:TTranslate&gt;
</com:TTextHighlighter>

<h4>结果：</h4>

<com:TTranslate>
    {greeting} {name}!, The unix-time is "{time}".
    <com:TTranslateParameter Key="name">
        <com:TTranslate Catalogue="tests" Text="World" />
    </com:TTranslateParameter>
    <com:TTranslateParameter Key="greeting" Value="Hello" />
    <com:TTranslateParameter Key="time" Value="<%= Time() %>" />
</com:TTranslate>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/LanguageList.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

<?php
/**
 * Language List
 * @author $Author: weizhuo $
 * @version $Id: LanguageList.php 1398 2006-09-08 19:31:03Z xue $
 * @package prado.examples
 */

/**
 *
 * @author $Author: weizhuo $
 * @version $Id: LanguageList.php 1398 2006-09-08 19:31:03Z xue $
 */
class LanguageList extends TTemplateControl
{

}

?>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/LanguageList.tpl

1
2
3
4
5
6
7
8
9
10

<ul>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=en">English</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=zh">中文简体</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=zh_TW">中文繁體</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=de">Deutsch</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=es">Español</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=fr">Français</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=id">Bahasa Indonesia</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=pl">Polska</a></li>
    </ul>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php
Template file: | LabeledTextBox.tpl

/Controls/Samples/LabeledTextBox1/Home.page

1
2
3
4
5
6
7
8
9
10
11

<com:TContent ID="body" >
<com:LabeledTextBox
    ID="Input"
    Label.Text="Username" />
<com:TButton
    Text="Submit"
    OnClick="buttonClicked" />
<com:TRequiredFieldValidator
    ControlToValidate="Input.TextBox"
    ErrorMessage="You must enter a value"/>
</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php
Template file: | LabeledTextBox.tpl

/Controls/Samples/LabeledTextBox1/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13

<?php

Prado::using('Application.pages.Controls.Samples.LabeledTextBox1.LabeledTextBox');

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $sender->Text=$this->Input->TextBox->Text;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php
Template file: | LabeledTextBox.tpl

/Controls/Samples/LabeledTextBox1/LabeledTextBox.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<?php

class LabeledTextBox extends TTemplateControl
{
    public function getLabel()
    {
        $this->ensureChildControls();
        return $this->getRegisteredObject('Label');
    }

    public function getTextBox()
    {
        $this->ensureChildControls();
        return $this->getRegisteredObject('TextBox');
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php
Template file: | LabeledTextBox.tpl

/Controls/Samples/LabeledTextBox1/LabeledTextBox.tpl

1
2

<com:TLabel ID="Label" ForControl="TextBox" />
<com:TTextBox ID="TextBox" />


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php

/Controls/Samples/LabeledTextBox2/Home.page

1
2
3
4
5
6
7
8
9
10
11

<com:TContent ID="body" >
<com:LabeledTextBox
    ID="Input"
    Label.Text="Username" />
<com:TButton
    Text="Submit"
    OnClick="buttonClicked" />
<com:TRequiredFieldValidator
    ControlToValidate="Input.TextBox"
    ErrorMessage="You must enter a value"/>
</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php

/Controls/Samples/LabeledTextBox2/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13

<?php

Prado::using('Application.pages.Controls.Samples.LabeledTextBox2.LabeledTextBox');

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $sender->Text=$this->Input->TextBox->Text;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php

/Controls/Samples/LabeledTextBox2/LabeledTextBox.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33

<?php

class LabeledTextBox extends TCompositeControl
{
    private $_label;
    private $_textbox;

    public function createChildControls()
    {
        $this->_label=new TLabel;
        $this->_label->setID('Label');
        $this->getControls()->add($this->_label);
        $this->getControls()->add('&nbsp;');
        $this->_textbox=new TTextBox;
        $this->_textbox->setID('TextBox');
        $this->_label->setForControl('TextBox');
        $this->getControls()->add($this->_textbox);
    }

    public function getLabel()
    {
        $this->ensureChildControls();
        return $this->_label;
    }

    public function getTextBox()
    {
        $this->ensureChildControls();
        return $this->_textbox;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/ResetValidation/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25

<com:TContent ID="body">

<h1>Reset Validation using Javascript</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" />
<com:TRequiredFieldValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    Text="Field required." />
<com:TButton Text="Submit" ValidationGroup="Group1" />

<a href="javascript: Prado.Validation.reset('Group1')">Reset Validation</a>
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/ResetValidation/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TBulletedList/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83

<com:TContent ID="body">

<h1>TBulletedList Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Bulleted list with default settings:
</td>
<td class="sampleaction">
<com:TBulletedList>
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TBulletedList>
</td>
</tr>

<tr>
<td class="samplenote">
Bulleted list with customized color, font, bullet style:
</td>
<td class="sampleaction">
<com:TBulletedList
    BulletStyle="UpperRoman"
    FirstBulletNumber="5"
    BackColor="silver"
    Font.Size="12pt">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TBulletedList>
</td>
</tr>

<tr>
<td class="samplenote">
Bulleted list with image bullets:
</td>
<td class="sampleaction">
<com:TBulletedList BulletStyle="CustomImage" BulletImageUrl=<%~bullet.gif%> >
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TBulletedList>
</td>
</tr>

<tr>
<td class="samplenote">
Bulleted list of hyperlinks:
</td>
<td class="sampleaction">
<com:TBulletedList DisplayMode="HyperLink" Target="_blank">
  <com:TListItem Value="http://www.google.com/" Text="google" />
  <com:TListItem Value="http://www.yahoo.com/" Text="yahoo" />
  <com:TListItem Value="http://www.amazon.com/" Text="amazon" />
</com:TBulletedList>
</td>

<tr>
<td class="samplenote">
Bulleted list of link buttons (click on them to see the result):
</td>
<td class="sampleaction">
<com:TBulletedList DisplayMode="LinkButton" OnClick="buttonClicked">
  <com:TListItem Value="http://www.google.com/" Text="google" />
  <com:TListItem Value="http://www.yahoo.com/" Text="yahoo" />
  <com:TListItem Value="http://www.amazon.com/" Text="amazon" />
</com:TBulletedList>
<com:TLabel ID="Result" ForeColor="red" />
</td>

</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TBulletedList/Home.php

1
2
3
4
5
6
7
8
9
10
11
12

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $item=$sender->Items[$param->Index];
        $this->Result->Text="You clicked $item->Text : $item->Value.";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51

<com:TContent ID="body">

<h1>TButton Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Button with customized color, font and width:
</td><td class="sampleaction">
<com:TButton
    Text="text"
    Width="200px"
    ForeColor="silver"
    BackColor="black"
    Font.Size="14pt"
/>
</td></tr>

<tr><td class="samplenote">
A click button:
</td><td class="sampleaction">
<com:TButton Text="click me" OnClick="buttonClicked" />
</td></tr>

<tr><td class="samplenote">
A command button:
</td><td class="sampleaction">
<com:TButton
    Text="click me"
    OnCommand="buttonClicked"
    CommandName="test"
    CommandParameter="value"
    />
</td></tr>

<tr><td class="samplenote">
A button causing validation:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TButton Text="submit" ValidationGroup="Group" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        if($param instanceof TCommandEventParameter)
            $sender->Text="Name: {$param->CommandName}, Param: {$param->CommandParameter}";
        else
            $sender->Text="I'm clicked";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCaptcha/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

<com:TContent ID="body">
<h1>TCaptcha Samples</h1>

<h2>Validating CAPTCHA</h2>
<com:TCaptcha ID="Captcha" TokenImageTheme="5" />
<com:TTextBox ID="Input" />
<com:TButton Text="Regenerate" OnClick="regenerateToken" CausesValidation="false" />
<com:TButton Id="SubmitButton" Text="Submit" OnClick="buttonClicked" />
<com:TCaptchaValidator CaptchaControl="Captcha" ControlToValidate="Input" Text="You are challenged!" />

<h2>Different Themes of TCaptcha</h2>

<table border="1">
<tr>
<th>Theme</th><th>Image</th>
</tr>
<com:TRepeater ID="CaptchaList">
  <prop:ItemTemplate>
<tr>
  <td>
  <com:TLiteral Text="<%# $this->Data %>" />
  </td>
  <td>
  <com:TCaptcha TokenImageTheme="<%# $this->Data %>" MaxTokenLength="5"/>
  </td>
</tr>
  </prop:ItemTemplate>
</com:TRepeater>
</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCaptcha/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<?php

class Home extends TPage
{
    public function onInit($param)
    {
        if(!$this->IsPostBack)
        {
            $this->CaptchaList->DataSource=range(0,63);
            $this->CaptchaList->dataBind();
        }
    }

    public function regenerateToken($sender,$param)
    {
        $this->Captcha->regenerateToken();
        $this->SubmitButton->Text="Submit";
    }

    public function buttonClicked($sender,$param)
    {
        if($this->IsValid)
            $sender->Text="You passed!";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCheckBox/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93

<com:TContent ID="body">

<h1>TCheckBox Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A checkbox with customized text alignment, color and font:
</td><td class="sampleaction">
<com:TCheckBox
    Text="checkbox"
    TextAlign="Left"
    ForeColor="silver"
    BackColor="green"
    Font.Size="14pt"
/>
</td></tr>

<tr><td class="samplenote">
A checkbox with label and input attributes:
</td><td class="sampleaction">
<com:TCheckBox
    Text="click me"
    InputAttributes.value="value"
    LabelAttributes.style="color:red"
/>
</td></tr>

<tr><td class="samplenote">
An auto postback checkbox:
</td><td class="sampleaction">
<com:TCheckBox
    AutoPostBack="true"
    Text="click me"
    OnCheckedChanged="checkboxClicked"
    />
</td></tr>

<tr><td class="samplenote">
A checkbox causing validation on a textbox:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TCheckBox
    Text="submit"
    AutoPostBack="true"
    ValidationGroup="Group"
    />
</td></tr>

<tr><td class="samplenote">
A checkbox validated by a required field validator:
</td><td class="sampleaction">
<com:TCheckBox
    ID="CheckBox"
    Text="Consent"
    ValidationGroup="Group2"
    />
<com:TButton Text="Submit" ValidationGroup="Group2" />
<com:TRequiredFieldValidator
    ControlToValidate="CheckBox"
    Display="Dynamic"
    ErrorMessage="You must consent."
    ValidationGroup="Group2"
    />
</td></tr>

<tr><td class="samplenote">
A checkbox validated by a required field validator using AutoPostBack:
</td><td class="sampleaction">
<com:TCheckBox
    ID="CheckBox2"
    Text="Agree"
    Checked="true"
    AutoPostBack="true"
    ValidationGroup="Group3"
    />
<com:TRequiredFieldValidator
    ControlToValidate="CheckBox2"
    Display="Dynamic"
    ErrorMessage="You must agree."
    ValidationGroup="Group3"
    />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCheckBox/Home.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Home extends TPage
{
    public function checkboxClicked($sender,$param)
    {
        $sender->Text="I'm clicked";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCheckBoxList/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208

<com:TContent ID="body">

<h1>TCheckBoxList Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Check box list with default settings:
</td>
<td class="sampleaction">
<com:TCheckBoxList>
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list with customized cellpadding, cellspacing, color and text alignment:
</td>
<td class="sampleaction">
<com:TCheckBoxList
    CellPadding="5"
    CellSpacing="1"
    BackColor="silver"
    TextAlign="Left">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list with vertical (default) repeat direction:
</td>
<td class="sampleaction">
<com:TCheckBoxList RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list with horizontal repeat direction:
</td>
<td class="sampleaction">
<com:TCheckBoxList RepeatDirection="Horizontal"    RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list with flow layout and vertical (default) repeat direction:
</td>
<td class="sampleaction">
<com:TCheckBoxList RepeatLayout="Flow" RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list with flow layout and horizontal repeat direction:
</td>
<td class="sampleaction">
<com:TCheckBoxList
    RepeatLayout="Flow"
    RepeatDirection="Horizontal"
    RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list's behavior upon postback:
</td>
<td class="sampleaction">
<com:TCheckBoxList ID="CheckBoxList">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Enabled="false" />
  <com:TListItem Value="value 5" Text="item 5" Selected="true" />
</com:TCheckBoxList>
<com:TButton Text="Submit" OnClick="buttonClicked" />
<br/>
<com:TLabel ID="SelectionResult" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Auto postback check box list:
</td>
<td class="sampleaction">
<com:TCheckBoxList
    AutoPostBack="true"
    OnSelectedIndexChanged="selectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Enabled="false" />
  <com:TListItem Value="value 5" Text="item 5" Selected="true" />
</com:TCheckBoxList>
<com:TLabel ID="SelectionResult2" ForeColor="red" />
</td>
</tr>

</table>

<h2>Checkbox Lists with DataBinding</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
Databind to an integer-indexed array:
</td>
<td class="sampleaction">
<com:TCheckBoxList ID="DBCheckBoxList1"
    AutoPostBack="true"
    OnSelectedIndexChanged="DBCheckBoxList1Changed" />
<com:TLabel ID="DBCheckBoxList1Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind to an associative array:
</td>
<td class="sampleaction">
<com:TCheckBoxList ID="DBCheckBoxList2"
    AutoPostBack="true"
    OnSelectedIndexChanged="DBCheckBoxList2Changed" />
<com:TLabel ID="DBCheckBoxList2Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind with DataTextField and DataValueField specified:
</td>
<td class="sampleaction">
<com:TCheckBoxList ID="DBCheckBoxList3"
    AutoPostBack="true"
    DataTextField="name"
    DataValueField="id"
    OnSelectedIndexChanged="DBCheckBoxList3Changed" />
<com:TLabel ID="DBCheckBoxList3Result" ForeColor="red" />
</td>
</tr>

</table>

<h2>CheckBox List with Validation</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
CheckBox list causing validation:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    ErrorMessage="You must enter a value"
    Display="Dynamic"
    ValidationGroup="Group2"
    />
<com:TCheckBoxList AutoPostBack="true" ValidationGroup="Group2">
  <com:TListItem Text="Agree" />
  <com:TListItem Text="Disagree" />
</com:TCheckBoxList>
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCheckBoxList/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $data=array('item 1','item 2','item 3','item 4');
            $this->DBCheckBoxList1->DataSource=$data;
            $this->DBCheckBoxList1->dataBind();

            $data=array('key 1'=>'item 1','key 2'=>'item 2',
                        'key 3'=>'item 3','key 4'=>'item 4');
            $this->DBCheckBoxList2->DataSource=$data;
            $this->DBCheckBoxList2->dataBind();

            $data=array(
                array('id'=>'001','name'=>'John','age'=>31),
                array('id'=>'002','name'=>'Mary','age'=>30),
                array('id'=>'003','name'=>'Cary','age'=>20));
            $this->DBCheckBoxList3->DataSource=$data;
            $this->DBCheckBoxList3->dataBind();
        }
    }

    protected function collectSelectionResult($input,$output)
    {
        $indices=$input->SelectedIndices;
        $result='';
        foreach($indices as $index)
        {
            $item=$input->Items[$index];
            $result.="(Index: $index, Value: $item->Value, Text: $item->Text)";
        }
        if($result==='')
            $output->Text='Your selection is empty.';
        else
            $output->Text='Your selection is: '.$result;
    }

    public function buttonClicked($sender,$param)
    {
        $this->collectSelectionResult($this->CheckBoxList,$this->SelectionResult);
    }

    public function selectionChanged($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->SelectionResult2);
    }

    public function DBCheckBoxList1Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBCheckBoxList1Result);
    }

    public function DBCheckBoxList2Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBCheckBoxList2Result);
    }

    public function DBCheckBoxList3Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBCheckBoxList3Result);
    }

}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TClientSideValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36

<com:TContent ID="body">
<h1>Conditional Validation (client-side + server side)</h1>

<table class="sampletable">
<tr>
<td class="samplenote">
Validator with default settings:<br />
Check "optional" to validate both textboxes
</td>
<td class="sampleaction">
        <com:TTextBox ID="text1" />
        <com:TRequiredFieldValidator
            ID="validator1"
            ControlToValidate="text1"
            ErrorMessage="*"
            ControlCssClass="required"/>
        <com:TTextBox ID="text2" />
        <com:TRequiredFieldValidator
            ID="validator2"
            ControlToValidate="text2"
            OnValidate="check_validate"
            ErrorMessage="*"
            ControlCssClass="required">
        <prop:ClientSide.OnValidate>
            sender.enabled = $('<%= $this->check1->ClientID %>').checked;
        </prop:ClientSide.OnValidate>

        </com:TRequiredFieldValidator>
        <com:TCheckBox ID="check1" Text="Optional" />
    <com:TButton ID="submit1" Text="Submit" />
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TClientSideValidator/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<?php

class Home extends TPage
{
    function check_validate($sender, $params)
    {
        $sender->enabled = $this->check1->checked;
    }

    function onPreRender($param)
    {
        //always re-enable the validator2 so as to display the client-side validator
        $this->validator2->enabled=true;
    }
}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TColorPicker/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37

<com:TContent ID="body">

<h1>TColorPicker Samples</h1>

<table class="sampletable">

<tr>
    <td class="samplenote">Default TColorPicker, Mode="Basic"</td>
    <td class="sampleaction">
        <com:TColorPicker />
    </td>
</tr>

<tr>
    <td class="samplenote">Mode="Simple"<br />pre-selected red color</td>
    <td class="sampleaction">
        <com:TColorPicker Mode="Simple" Text="#FF0000"/>
    </td>
</tr>

<tr>
    <td class="samplenote">Mode="Full"</td>
    <td class="sampleaction">
        <com:TColorPicker Mode="Full"/>
    </td>
</tr>

<tr>
    <td class="samplenote">Disabled color picker panel: ShowColorPicker="false"</td>
    <td class="sampleaction">
        <com:TColorPicker ShowColorPicker="false"/>
    </td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCompareValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76

<com:TContent ID="body">

<h1>TCompareValidator Samples</h1>
<p><strong>Note:</strong> TCompareValidator will start
to validate only if both inputs are not empty.</p>

<table class="sampletable">

<tr>
<td class="samplenote">
Compare validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" Text="a1" />
<com:TTextBox ID="TextBox11" Text="a2"/>
<com:TCompareValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    ControlToCompare="TextBox11"
    Text="The two textboxes must have the same value." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Compare validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" Text="b1"/>
<com:TTextBox ID="TextBox22" Text="b2" />
<com:TCompareValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    ControlToCompare="TextBox22"
    Text="The two textboxes must have the same value." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

<tr>
<td class="samplenote">
Comparing with a constant value:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox3" Text="a" />
<com:TCompareValidator
    ValidationGroup="Group3"
    ControlToValidate="TextBox3"
    ValueToCompare="test"
    Text="You must enter 'test'." />
<com:TButton Text="Submit" ValidationGroup="Group3" />
</td>
</tr>

<tr>
<td class="samplenote">
Comparing with an integer:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox4" Text="0" />
<com:TCompareValidator
    ValidationGroup="Group4"
    ControlToValidate="TextBox4"
    ValueToCompare="100"
    DataType="Integer"
    Operator="GreaterThan"
    Text="You must enter an integer greater than 100." />
<com:TButton Text="Submit" ValidationGroup="Group4" />
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCompareValidator/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TConditional/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13

<com:TContent ID="body">
<h1>TConditional Samples</h1>

<com:TConditional Condition="Prado::getVersion()==='3.1.1'">
<prop:TrueTemplate>
  <com:TLabel Text="You are using PRADO 3.1.1" />
</prop:TrueTemplate>
<prop:FalseTemplate>
  <com:TLabel Text="You are using PRADO <%= Prado::getVersion() %>" />
</prop:FalseTemplate>
</com:TConditional>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TConditional/Home.php

1
2
3
4
5
6
7

<?php

class Home extends TPage
{
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCustomValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83

<com:TContent ID="body">

<script type="text/javascript"><!--
function myValidationFunction(sender, parameter)
{
    if(parameter == 'test')
        return true;
    else
        return false;
}
--></script>

<h1>TCustomValidator Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Custom validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" />
<com:TCustomValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    ClientValidationFunction="myValidationFunction"
    OnServerValidate="serverValidate"
    Text="You must enter 'test'." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Custom validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" />
<com:TCustomValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    ClientValidationFunction="myValidationFunction"
    OnServerValidate="serverValidate"
    Text="You must enter 'test'." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

<tr>
<td class="samplenote">
Custom validator with focus-on-error enabled and dynamic display:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox3" />
<com:TCustomValidator
    ValidationGroup="Group3"
    ControlToValidate="TextBox3"
    ClientValidationFunction="myValidationFunction"
    OnServerValidate="serverValidate"
    FocusOnError="true"
    Text="You must enter 'test'." />
<com:TButton Text="Submit" ValidationGroup="Group3" />
</td>
</tr>

<tr>
<td class="samplenote">
Custom validator without ControlToValidate:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox4" />
<com:TCustomValidator
    ValidationGroup="Group4"
    OnServerValidate="serverValidateNoControl"
    Text="You must enter 'test'." />
<com:TButton Text="Submit" ValidationGroup="Group4" />
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCustomValidator/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<?php

class Home extends TPage
{
    public function serverValidate($sender,$param)
    {
        if($param->Value!=='test')
            $param->IsValid=false;
    }

    public function serverValidateNoControl($sender,$param)
    {
        if($this->TextBox4->Text!=='test')
            $param->IsValid=false;
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample1.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<com:TContent ID="body">

<h1>TDataGrid Sample 1</h1>
<h2>Using Automatically Generated Columns</h2>

<com:TDataGrid
    ID="DataGrid"
    EnableViewState="false"
    CellPadding="2"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    />

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample1.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

<?php

class Sample1 extends TPage
{
    protected function getData()
    {
        return array(
            array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
            array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>false),
            array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>true),
            array('id'=>'ITN008','name'=>'CDRW drive','quantity'=>1,'price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','quantity'=>2,'price'=>10.00,'imported'=>false),
            array('id'=>'ITN010','name'=>'Video camera','quantity'=>20,'price'=>30.00,'imported'=>true),
            array('id'=>'ITN011','name'=>'Card reader','quantity'=>10,'price'=>24.00,'imported'=>true),
            array('id'=>'ITN012','name'=>'Floppy drive','quantity'=>50,'price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','quantity'=>25,'price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','quantity'=>15,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','quantity'=>50,'price'=>5.00,'imported'=>false),
            array('id'=>'ITN016','name'=>'Network cable','quantity'=>40,'price'=>8.00,'imported'=>true),
            array('id'=>'ITN017','name'=>'Case','quantity'=>8,'price'=>65.00,'imported'=>false),
            array('id'=>'ITN018','name'=>'Surge protector','quantity'=>45,'price'=>15.00,'imported'=>false),
            array('id'=>'ITN019','name'=>'Speaker','quantity'=>35,'price'=>65.00,'imported'=>false),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataGrid->DataSource=$this->Data;
            $this->DataGrid->dataBind();
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample2.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64

<com:TContent ID="body">

<h1>TDataGrid Sample 2</h1>
<h2>Using Manually Specified Columns</h2>

<com:TDataGrid
    Width="700px"
    CellPadding="2"
    ID="DataGrid"
    AutoGenerateColumns="false"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF">

    <com:THyperLinkColumn
        HeaderText="Book Title"
        DataTextField="title"
        DataNavigateUrlField="ISBN"
        DataNavigateUrlFormatString="http://www.amazon.com/gp/product/%s"
        Target="_blank"
        />
    <com:TBoundColumn
        HeaderText="Publisher"
        DataField="publisher"
        />
    <com:TBoundColumn
        ItemStyle.HorizontalAlign="Right"
        ItemStyle.Wrap="false"
        ItemStyle.Font.Italic="false"
        ItemStyle.ForeColor="green"
        HeaderText="Price"
        DataField="price"
        DataFormatString="$%.2f"
        />
    <com:TCheckBoxColumn
        HeaderText="In-stock"
        HeaderStyle.Wrap="false"
        DataField="instock"
        />
    <com:TTemplateColumn>
        <prop:HeaderTemplate>Rating</prop:HeaderTemplate>
        <prop:ItemTemplate>
        <img src="images/star<%#$this->Parent->DataItem['rating']%>.gif" alt="" />
        </prop:ItemTemplate>
    </com:TTemplateColumn>
</com:TDataGrid>

<com:TPanel GroupingText="Column Visibility" Width="200px">

<com:TCheckBoxList
     AutoPostBack="true"
     OnSelectedIndexChanged="toggleColumnVisibility">
    <com:TListItem Text="Book Title" Selected="true" />
    <com:TListItem Text="Publisher" Selected="true" />
    <com:TListItem Text="Price" Selected="true" />
    <com:TListItem Text="In-stock" Selected="true" />
    <com:TListItem Text="Rating" Selected="true" />
</com:TCheckBoxList>

</com:TPanel>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample2.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86

<?php

class Sample2 extends TPage
{
    protected function getData()
    {
        return array(
            array(
                'ISBN'=>'0596007124',
                'title'=>'Head First Design Patterns',
                'publisher'=>'O\'Reilly Media, Inc.',
                'price'=>29.67,
                'instock'=>true,
                'rating'=>4,
            ),
            array(
                'ISBN'=>'0201633612',
                'title'=>'Design Patterns: Elements of Reusable Object-Oriented Software',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>47.04,
                'instock'=>true,
                'rating'=>5,
            ),
            array(
                'ISBN'=>'0321247140',
                'title'=>'Design Patterns Explained : A New Perspective on Object-Oriented Design',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>37.49,
                'instock'=>true,
                'rating'=>4,
            ),
            array(
                'ISBN'=>'0201485672',
                'title'=>'Refactoring: Improving the Design of Existing Code',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>47.14,
                'instock'=>true,
                'rating'=>3,
            ),
            array(
                'ISBN'=>'0321213351',
                'title'=>'Refactoring to Patterns',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>38.49,
                'instock'=>true,
                'rating'=>2,
            ),
            array(
                'ISBN'=>'0735619670',
                'title'=>'Code Complete',
                'publisher'=>'Microsoft Press',
                'price'=>32.99,
                'instock'=>false,
                'rating'=>4,
            ),
            array(
                'ISBN'=>'0321278658',
                'title'=>'Extreme Programming Explained : Embrace Change',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>34.99,
                'instock'=>true,
                'rating'=>3,
            ),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataGrid->DataSource=$this->Data;
            $this->DataGrid->dataBind();
        }
    }

    public function toggleColumnVisibility($sender,$param)
    {
        foreach($this->DataGrid->Columns as $index=>$column)
            $column->Visible=$sender->Items[$index]->Selected;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample3.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83

<com:TContent ID="body">

<h1>TDataGrid Sample 3</h1>
<h2>Interacting with TDataGrid</h2>

<com:TDataGrid
    Width="800px"
    CellPadding="2"
    ID="DataGrid"
    DataKeyField="ISBN"
    AutoGenerateColumns="false"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    EditItemStyle.BackColor="lightyellow"
    OnItemCreated="itemCreated"
    OnEditCommand="editItem"
    OnUpdateCommand="saveItem"
    OnCancelCommand="cancelItem"
    OnDeleteCommand="deleteItem"
    >

    <com:TBoundColumn
        ID="BookTitleColumn"
        HeaderText="Book Title"
        HeaderStyle.Width="400px"
        DataField="title"
        />
    <com:TBoundColumn
        ID="PublisherColumn"
        HeaderText="Publisher"
        HeaderStyle.Width="150px"
        DataField="publisher"
        />
    <com:TBoundColumn
        ID="PriceColumn"
        ItemStyle.HorizontalAlign="Right"
        ItemStyle.Wrap="false"
        ItemStyle.Font.Italic="false"
        ItemStyle.ForeColor="green"
        HeaderText="Price"
        HeaderStyle.Width="70px"
        DataField="price"
        DataFormatString="$%.2f"
        />
    <com:TCheckBoxColumn
        ID="InStockColumn"
        HeaderText="In-stock"
        DataField="instock"
        />
    <com:TDropDownListColumn
        ID="RatingColumn"
        HeaderText="Rating"
        DataTextField="rating"
        >
        <prop:DataTextFormatString><img src="images/star%s.gif" alt="" /></prop:DataTextFormatString>
        <com:TListItem Value="1" />
        <com:TListItem Value="2" />
        <com:TListItem Value="3" />
        <com:TListItem Value="4" />
        <com:TListItem Value="5" />
    </com:TDropDownListColumn>
    <com:TEditCommandColumn
        HeaderText="Edit"
        HeaderStyle.Width="100px"
        UpdateText="Save"
        ItemStyle.HorizontalAlign="Center"
        ItemStyle.Font.Italic="false"
        />
    <com:TButtonColumn
        ID="DeleteColumn"
        HeaderText="Delete"
        HeaderStyle.Width="50px"
        ItemStyle.HorizontalAlign="Center"
        ItemStyle.Font.Italic="false"
        Text="Delete"
        CommandName="delete"
        />
</com:TDataGrid>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample3.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190

<?php

class Sample3 extends TPage
{
    private $_data=null;

    protected function getData()
    {
        if($this->_data===null)
            $this->loadData();
        return $this->_data;
    }

    protected function loadData()
    {
        // We use viewstate keep track of data.
        // In real applications, data should come from database using an SQL SELECT statement.
        // In the following tabular data, field 'ISBN' is the primary key.
        // All update and delete operations should come with an 'id' value in order to go through.
        if(($this->_data=$this->getViewState('Data',null))===null)
        {
            $this->_data=array(
                array(
                    'ISBN'=>'0596007124',
                    'title'=>'Head First Design Patterns',
                    'publisher'=>'O\'Reilly Media, Inc.',
                    'price'=>29.67,
                    'instock'=>true,
                    'rating'=>4,
                ),
                array(
                    'ISBN'=>'0201633612',
                    'title'=>'Design Patterns: Elements of Reusable Object-Oriented Software',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>47.04,
                    'instock'=>true,
                    'rating'=>5,
                ),
                array(
                    'ISBN'=>'0321247140',
                    'title'=>'Design Patterns Explained : A New Perspective on Object-Oriented Design',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>37.49,
                    'instock'=>true,
                    'rating'=>4,
                ),
                array(
                    'ISBN'=>'0201485672',
                    'title'=>'Refactoring: Improving the Design of Existing Code',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>47.14,
                    'instock'=>true,
                    'rating'=>3,
                ),
                array(
                    'ISBN'=>'0321213351',
                    'title'=>'Refactoring to Patterns',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>38.49,
                    'instock'=>true,
                    'rating'=>2,
                ),
                array(
                    'ISBN'=>'0735619670',
                    'title'=>'Code Complete',
                    'publisher'=>'Microsoft Press',
                    'price'=>32.99,
                    'instock'=>false,
                    'rating'=>4,
                ),
                array(
                    'ISBN'=>'0321278658 ',
                    'title'=>'Extreme Programming Explained : Embrace Change',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>34.99,
                    'instock'=>true,
                    'rating'=>3,
                ),
            );
            $this->saveData();
        }
    }

    protected function saveData()
    {
        $this->setViewState('Data',$this->_data);
    }

    protected function updateBook($isbn,$title,$publisher,$price,$instock,$rating)
    {
        // In real applications, data should be saved to database using an SQL UPDATE statement
        if($this->_data===null)
            $this->loadData();
        $updateRow=null;
        foreach($this->_data as $index=>$row)
            if($row['ISBN']===$isbn)
                $updateRow=&$this->_data[$index];
        if($updateRow!==null)
        {
            $updateRow['title']=$title;
            $updateRow['publisher']=$publisher;
            $updateRow['price']=TPropertyValue::ensureFloat(ltrim($price,'$'));
            $updateRow['instock']=TPropertyValue::ensureBoolean($instock);
            $updateRow['rating']=TPropertyValue::ensureInteger($rating);
            $this->saveData();
        }
    }

    protected function deleteBook($isbn)
    {
        // In real applications, data should be saved to database using an SQL DELETE statement
        if($this->_data===null)
            $this->loadData();
        $deleteIndex=-1;
        foreach($this->_data as $index=>$row)
            if($row['ISBN']===$isbn)
                $deleteIndex=$index;
        if($deleteIndex>=0)
        {
            unset($this->_data[$deleteIndex]);
            $this->saveData();
        }
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataGrid->DataSource=$this->Data;
            $this->DataGrid->dataBind();
        }
    }

    public function itemCreated($sender,$param)
    {
        $item=$param->Item;
        if($item->ItemType==='EditItem')
        {
            // set column width of textboxes
            $item->BookTitleColumn->TextBox->Columns=40;
            $item->PriceColumn->TextBox->Columns=5;
        }
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem' || $item->ItemType==='EditItem')
        {
            // add an aleart dialog to delete buttons
            $item->DeleteColumn->Button->Attributes->onclick='if(!confirm(\'Are you sure?\')) return false;';
        }
    }

    public function editItem($sender,$param)
    {
        $this->DataGrid->EditItemIndex=$param->Item->ItemIndex;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function saveItem($sender,$param)
    {
        $item=$param->Item;
        $this->updateBook(
            $this->DataGrid->DataKeys[$item->ItemIndex],    // ISBN
            $item->BookTitleColumn->TextBox->Text,            // title
            $item->PublisherColumn->TextBox->Text,            // publisher
            $item->PriceColumn->TextBox->Text,                // price
            $item->InStockColumn->CheckBox->Checked,        // instock
            $item->RatingColumn->DropDownList->SelectedValue        // rating
            );
        $this->DataGrid->EditItemIndex=-1;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function cancelItem($sender,$param)
    {
        $this->DataGrid->EditItemIndex=-1;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function deleteItem($sender,$param)
    {
        $this->deleteBook($this->DataGrid->DataKeys[$param->Item->ItemIndex]);
        $this->DataGrid->EditItemIndex=-1;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample4.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55

<com:TContent ID="body">

<h1>TDataGrid Sample 4</h1>
<h2>Sorting with TDataGrid</h2>

<com:TDataGrid
    Width="700px"
    CellPadding="2"
    ID="DataGrid"
    AutoGenerateColumns="false"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    AllowSorting="true"
    OnSortCommand="sortDataGrid">

    <com:THyperLinkColumn
        SortExpression="title"
        HeaderText="Book Title"
        DataTextField="title"
        DataNavigateUrlField="ISBN"
        DataNavigateUrlFormatString="http://www.amazon.com/gp/product/%s"
        Target="_blank"
        />
    <com:TBoundColumn
        SortExpression="publisher"
        HeaderText="Publisher"
        DataField="publisher"
        />
    <com:TBoundColumn
        SortExpression="price"
        ItemStyle.HorizontalAlign="Right"
        ItemStyle.Wrap="false"
        ItemStyle.Font.Italic="false"
        ItemStyle.ForeColor="green"
        HeaderText="Price"
        DataField="price"
        DataFormatString="$%.2f"
        />
    <com:TCheckBoxColumn
        SortExpression="instock"
        HeaderText="In-stock"
        HeaderStyle.Wrap="false"
        DataField="instock"
        />
    <com:TTemplateColumn HeaderText="Rating" SortExpression="rating">
        <prop:ItemTemplate>
        <img src="images/star<%#$this->NamingContainer->DataItem['rating']%>.gif" alt="" />
        </prop:ItemTemplate>
    </com:TTemplateColumn>
</com:TDataGrid>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample4.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<?php

Prado::using('Application.pages.Controls.Samples.TDataGrid.Sample2');

class Sample4 extends Sample2
{
    protected function sortData($data,$key)
    {
        $compare = create_function('$a,$b','if ($a["'.$key.'"] == $b["'.$key.'"]) {return 0;}else {return ($a["'.$key.'"] > $b["'.$key.'"]) ? 1 : -1;}');
        usort($data,$compare) ;
        return $data ;
    }

    public function sortDataGrid($sender,$param)
    {
        $this->DataGrid->DataSource=$this->sortData($this->Data,$param->SortExpression);
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample5.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62

<com:TContent ID="body">

<h1>TDataGrid Sample 5</h1>
<h2>Paging</h2>

<div style="width:500px">
<com:TDataGrid
    ID="DataGrid"
    AllowPaging="true"
    PageSize="5"
    PagerStyle.Mode="Numeric"
    PagerStyle.HorizontalAlign="Right"
    Width="100%"
    CellPadding="2"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    OnPageIndexChanged="changePage"
    OnPagerCreated="pagerCreated"
    />
</div>

<com:TPanel GroupingText="Pager Visibility" Width="300px">

<com:TCheckBoxList
     AutoPostBack="true"
     RepeatColumns="2"
     OnSelectedIndexChanged="changePagerPosition">
    <com:TListItem Text="Top" />
    <com:TListItem Text="Bottom"  Selected="true" />
</com:TCheckBoxList>

</com:TPanel>

<com:TPanel GroupingText="Pager Mode" Width="300px">

<com:TPanel GroupingText="NextPrev Pager" Width="300px">

Next Page Text:
<com:TTextBox ID="NextPageText" Text="Next" /><br/>
Prev Page Text:
<com:TTextBox ID="PrevPageText" Text="Prev" /><br/>
<com:TButton Text="Submit" OnClick="useNextPrevPager" />
</com:TPanel>

<com:TPanel GroupingText="Numeric Pager" Width="300px">

Page Button Count:
<com:TTextBox ID="PageButtonCount" Text="5" /><br/>
<com:TButton Text="Submit" OnClick="useNumericPager" />
</com:TPanel>

<com:TPanel GroupingText="Page Size" Width="300px">
<com:TTextBox ID="PageSize" Text="5" /><br/>
<com:TButton Text="Submit" OnClick="changePageSize" />
</com:TPanel>

</com:TPanel>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample5.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68

<?php

Prado::using('Application.pages.Controls.Samples.TDataGrid.Sample1');

class Sample5 extends Sample1
{
    public function changePage($sender,$param)
    {
        $this->DataGrid->CurrentPageIndex=$param->NewPageIndex;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function pagerCreated($sender,$param)
    {
        $param->Pager->Controls->insertAt(0,'Page: ');
    }

    public function changePagerPosition($sender,$param)
    {
        $top=$sender->Items[0]->Selected;
        $bottom=$sender->Items[1]->Selected;
        if($top && $bottom)
            $position='TopAndBottom';
        else if($top)
            $position='Top';
        else if($bottom)
            $position='Bottom';
        else
            $position='';
        if($position==='')
            $this->DataGrid->PagerStyle->Visible=false;
        else
        {
            $this->DataGrid->PagerStyle->Position=$position;
            $this->DataGrid->PagerStyle->Visible=true;
        }
    }

    public function useNumericPager($sender,$param)
    {
        $this->DataGrid->PagerStyle->Mode='Numeric';
        $this->DataGrid->PagerStyle->NextPageText=$this->NextPageText->Text;
        $this->DataGrid->PagerStyle->PrevPageText=$this->PrevPageText->Text;
        $this->DataGrid->PagerStyle->PageButtonCount=$this->PageButtonCount->Text;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function useNextPrevPager($sender,$param)
    {
        $this->DataGrid->PagerStyle->Mode='NextPrev';
        $this->DataGrid->PagerStyle->NextPageText=$this->NextPageText->Text;
        $this->DataGrid->PagerStyle->PrevPageText=$this->PrevPageText->Text;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function changePageSize($sender,$param)
    {
        $this->DataGrid->PageSize=TPropertyValue::ensureInteger($this->PageSize->Text);
        $this->DataGrid->CurrentPageIndex=0;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample6.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

<com:TContent ID="body">

<h1>TDataGrid Sample 6</h1>
<h2>Custom Paging</h2>

<div style="width:500px">
<com:TDataGrid
    ID="DataGrid"
    Width="100%"
    AllowPaging="true"
    AllowCustomPaging="true"
    VirtualItemCount="19"
    PageSize="5"
    PagerStyle.Mode="Numeric"
    PagerStyle.HorizontalAlign="Right"
    CellPadding="2"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    OnPageIndexChanged="changePage"
    />
</div>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample6.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56

<?php

Prado::using('Application.pages.Controls.Samples.TDataGrid.Sample1');

class Sample6 extends Sample1
{
    /**
     * Returns a subset of data.
     * In MySQL database, this can be replaced by LIMIT clause
     * in an SQL select statement.
     * @param integer the starting index of the row
     * @param integer number of rows to be returned
     * @return array subset of data
     */
    protected function getDataRows($offset,$rows)
    {
        $data=$this->getData();
        $page=array();
        for($i=0;$i<$rows;++$i)
        {
            if($offset+$i<$this->getRowCount())
                $page[$i]=$data[$offset+$i];
        }
        return $page;
    }

    /**
     * Returns total number of data rows.
     * In real DB applications, this may be replaced by an SQL select
     * query with count().
     * @return integer total number of data rows
     */
    protected function getRowCount()
    {
        return 19;
    }

    public function onLoad($param)
    {
        if(!$this->IsPostBack)
        {
            $this->DataGrid->DataSource=$this->getDataRows(0,$this->DataGrid->PageSize);
            $this->DataGrid->dataBind();
        }
    }

    public function changePage($sender,$param)
    {
        $this->DataGrid->CurrentPageIndex=$param->NewPageIndex;
        $offset=$param->NewPageIndex*$this->DataGrid->PageSize;
        $this->DataGrid->DataSource=$this->getDataRows($offset,$this->DataGrid->PageSize);
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php

/Controls/Samples/TDataList/Sample1.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49

<com:TContent ID="body">

<h1>TDataList Sample 1</h1>
<p>
TDataList is good at displaying tabular data in a non-tabular format. The following example displays a list of computer product information in 3 columns.
</p>
<p>
Since the page is mainly for display and does not require user interactions, the viewstate of TDataList is disabled to reduce page size.
</p>

<com:TDataList
     ID="DataList"
     EnableViewState="false"
     RepeatColumns="3"
     RepeatDirection="Horizontal"
     ItemStyle.Font.Italic="true"
     ItemStyle.BackColor="#BFCFFF"
     HeaderStyle.BackColor="black"
     HeaderStyle.ForeColor="white"
     FooterStyle.BackColor="gray"
     AlternatingItemStyle.BackColor="#E6ECFF">

<prop:HeaderTemplate>
<div style="font-weight:bold; text-align:center;">Computer Parts</div>
</prop:HeaderTemplate>

<prop:FooterTemplate>
<div style="font-weight:bold; text-align:center;">
Total <%# $this->Parent->ItemCount %> products.
</div>
</prop:FooterTemplate>

<prop:ItemTemplate>
<table border="0" width="100%">
<tr>
  <th>ID</th><th>Name</th><th>Quantity</th><th>Price</th>
</tr>
<tr>
  <td align="right"><%#$this->DataItem['id'] %></td>
  <td align="right"><%#$this->DataItem['name'] %></td>
  <td align="right"><%#$this->DataItem['quantity'] %></td>
  <td align="right">$<%#$this->DataItem['price'] %></td>
</tr>
</table>
</prop:ItemTemplate>

</com:TDataList>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php

/Controls/Samples/TDataList/Sample1.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

<?php

class Sample1 extends TPage
{
    protected function getData()
    {
        return array(
            array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
            array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>false),
            array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>true),
            array('id'=>'ITN008','name'=>'CDRW drive','quantity'=>1,'price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','quantity'=>2,'price'=>10.00,'imported'=>false),
            array('id'=>'ITN010','name'=>'Video camera','quantity'=>20,'price'=>30.00,'imported'=>true),
            array('id'=>'ITN011','name'=>'Card reader','quantity'=>10,'price'=>24.00,'imported'=>true),
            array('id'=>'ITN012','name'=>'Floppy drive','quantity'=>50,'price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','quantity'=>25,'price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','quantity'=>15,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','quantity'=>50,'price'=>5.00,'imported'=>false),
            array('id'=>'ITN016','name'=>'Network cable','quantity'=>40,'price'=>8.00,'imported'=>true),
            array('id'=>'ITN017','name'=>'Case','quantity'=>8,'price'=>65.00,'imported'=>false),
            array('id'=>'ITN018','name'=>'Surge protector','quantity'=>45,'price'=>15.00,'imported'=>false),
            array('id'=>'ITN019','name'=>'Speaker','quantity'=>35,'price'=>65.00,'imported'=>false),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataList->DataSource=$this->Data;
            $this->DataList->dataBind();
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php

/Controls/Samples/TDataList/Sample2.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125

<com:TContent ID="body">

<h1>TDataList Sample 2</h1>

<com:TDataList
     ID="DataList"
     DataKeyField="id"
     OnEditCommand="editItem"
     OnCancelCommand="cancelItem"
     OnUpdateCommand="updateItem"
     OnDeleteCommand="deleteItem"
     OnSelectedIndexChanged="selectItem"
     HeaderStyle.BackColor="black"
     HeaderStyle.ForeColor="white"
     ItemStyle.BackColor="#BFCFFF"
     AlternatingItemStyle.BackColor="#E6ECFF"
     EditItemStyle.BackColor="lightgreen"
     SelectedItemStyle.BackColor="lightyellow">

<prop:HeaderTemplate>
<div style="font-weight:bold; text-align:center;">Computer Parts</div>
</prop:HeaderTemplate>

<prop:ItemTemplate>
<table border="0" width="100%">
<tr>
  <td>
  <com:TLinkButton
       Text=<%#$this->DataItem['id']%>
       CommandName="select"
       />
  <%#$this->DataItem['name']%>
  </td>
  <td align="right">
  <com:TLinkButton
       Text="Edit"
       CommandName="edit"
       />
  <com:TLinkButton
       Text="Delete"
       CommandName="delete"
       Attributes.onclick="if(!confirm('Are you sure?')) return false;"
       />
  </td>
</tr>
</table>
</prop:ItemTemplate>

<prop:SelectedItemTemplate>
<table border="1" width="100%">
<tr>
  <th>ID</th><th>Name</th><th>Quantity</th><th>Price</th>
</tr>
<tr>
  <td align="right"><%#$this->DataItem['id'] %></td>
  <td align="right"><%#$this->DataItem['name'] %></td>
  <td align="right"><%#$this->DataItem['quantity'] %></td>
  <td align="right">$<%#$this->DataItem['price'] %></td>
</tr>
<tr>
  <td colspan="4" align="right">
  <com:TLinkButton
       Text="Edit"
       CommandName="edit"
       />
  <com:TLinkButton
       Text="Delete"
       CommandName="delete"
       Attributes.onclick="if(!confirm('Are you sure?')) return false;"
       />
  </td>
</tr>
</table>
</prop:SelectedItemTemplate>

<prop:EditItemTemplate>
<table border="0" width="100%">
<tr>
  <td align="right">ID</td>
  <td><b><%#$this->DataItem['id']%></b></td>
</tr>
<tr>
  <td align="right">Name</td>
  <td><com:TTextBox
           ID="ProductName"
           Text=<%#$this->DataItem['name'] %>
           />
  </td>
</tr>
<tr>
  <td align="right">Quantity</td>
  <td><com:TTextBox
           ID="ProductQuantity"
           Text=<%#$this->DataItem['quantity'] %>
           />
  </td>
</tr>
<tr>
  <td align="right">Price</td>
  <td><com:TTextBox
           ID="ProductPrice"
           Text=<%#$this->DataItem['price'] %>
           />
  </td>
</tr>
<tr>
  <td align="right">Imported</td>
  <td><com:TCheckBox
           ID="ProductImported"
           Checked=<%#$this->DataItem['imported'] %>
           />
  </td>
</tr>
<tr>
  <td colspan="2" align="right">
    <com:TLinkButton Text="Save" CommandName="update" />
    <com:TLinkButton Text="Cancel" CommandName="cancel" />
  </td>
</tr>
</table>
</prop:EditItemTemplate>

</com:TDataList>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php

/Controls/Samples/TDataList/Sample2.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132

<?php

class Sample2 extends TPage
{
    private $_data=null;

    protected function getData()
    {
        if($this->_data===null)
            $this->loadData();
        return $this->_data;
    }

    protected function loadData()
    {
        // We use viewstate keep track of data.
        // In real applications, data should come from database using an SQL SELECT statement.
        // In the following tabular data, field 'id' is the primary key.
        // All update and delete operations should come with an 'id' value in order to go through.
        if(($this->_data=$this->getViewState('Data',null))===null)
        {
            $this->_data=array(
                array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
                array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
                array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>false),
                array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
                array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
                array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>true),
                array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>false),
            );
            $this->saveData();
        }
    }

    protected function saveData()
    {
        $this->setViewState('Data',$this->_data);
    }

    protected function updateProduct($id,$name,$quantity,$price,$imported)
    {
        // In real applications, data should be saved to database using an SQL UPDATE statement
        if($this->_data===null)
            $this->loadData();
        $updateRow=null;
        foreach($this->_data as $index=>$row)
            if($row['id']===$id)
                $updateRow=&$this->_data[$index];
        if($updateRow!==null)
        {
            $updateRow['name']=$name;
            $updateRow['quantity']=TPropertyValue::ensureInteger($quantity);
            $updateRow['price']=TPropertyValue::ensureFloat($price);
            $updateRow['imported']=TPropertyValue::ensureBoolean($imported);
            $this->saveData();
        }
    }

    protected function deleteProduct($id)
    {
        // In real applications, data should be saved to database using an SQL DELETE statement
        if($this->_data===null)
            $this->loadData();
        $deleteIndex=-1;
        foreach($this->_data as $index=>$row)
            if($row['id']===$id)
                $deleteIndex=$index;
        if($deleteIndex>=0)
        {
            unset($this->_data[$deleteIndex]);
            $this->saveData();
        }
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataList->DataSource=$this->Data;
            $this->DataList->dataBind();
        }
    }

    public function editItem($sender,$param)
    {
        $this->DataList->SelectedItemIndex=-1;
        $this->DataList->EditItemIndex=$param->Item->ItemIndex;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }

    public function cancelItem($sender,$param)
    {
        $this->DataList->SelectedItemIndex=-1;
        $this->DataList->EditItemIndex=-1;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }

    public function updateItem($sender,$param)
    {
        $item=$param->Item;
        $this->updateProduct(
            $this->DataList->DataKeys[$item->ItemIndex],
            $item->ProductName->Text,
            $item->ProductQuantity->Text,
            $item->ProductPrice->Text,
            $item->ProductImported->Checked);
        $this->DataList->EditItemIndex=-1;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }

    public function deleteItem($sender,$param)
    {
        $this->deleteProduct($this->DataList->DataKeys[$param->Item->ItemIndex]);
        $this->DataList->SelectedItemIndex=-1;
        $this->DataList->EditItemIndex=-1;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }

    public function selectItem($sender,$param)
    {
        $this->DataList->EditItemIndex=-1;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TDataTypeValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58

<com:TContent ID="body">

<h1>TDataTypeValidator Samples</h1>
<p><strong>Note:</strong> TDataTypeValidator will start
to validate only if both inputs are not empty.</p>

<table class="sampletable">

<tr>
<td class="samplenote">
Data type validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" Text="a" />
<com:TDataTypeValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    DataType="Float"
    Text="You must enter a floating number." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Data type validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" Text="a"/>
<com:TDataTypeValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    DataType="Integer"
    Text="You must enter an integer." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

<tr>
<td class="samplenote">
Validating a date input:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox3" Text="a" />
<com:TDataTypeValidator
    ValidationGroup="Group3"
    ControlToValidate="TextBox3"
    DataType="Date"
    DateFormat="d/M/yyyy"
    Text="You must enter a valid date (d/M/yyyy)." />
<com:TButton Text="Submit" ValidationGroup="Group3" />
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TDataTypeValidator/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TDatePicker/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68

<com:TContent ID="body">

<h1>TDatePicker Samples</h1>

<table class="sampletable">

<tr>
    <td class="samplenote">Default TDatePicker</td>
    <td class="sampleaction">
        <com:TDatePicker />
    </td>
</tr>

<tr>
    <td class="samplenote">Clickable mode</td>
    <td class="sampleaction">
        <com:TDatePicker Mode="Clickable"/>
    </td>
</tr>

<tr>
    <td class="samplenote">Button Mode, <br />pre-selected date 20-10-2005</td>
    <td class="sampleaction">
        <com:TDatePicker Mode="Button" Date="20-10-2005"/>
    </td>
</tr>

<tr>
    <td class="samplenote">InputMode="DropDownList", <br />custom DateFormat="yyyy/MMM"</td>
    <td class="sampleaction">
        <com:TDatePicker DateFormat="yyyy/MMM" InputMode="DropDownList"/>
    </td>
</tr>

<tr>
    <td class="samplenote">InputMode="DropDownList", <br/>custom DateFormat="MMM/yyyy", <br/>Culture="fr"</td>
    <td class="sampleaction">
        <com:TDatePicker DateFormat="MMM/yyyy" Culture="fr" InputMode="DropDownList"/>
    </td>
</tr>

<tr>
    <td class="samplenote">Custom DateFormat="日期：yyyy年M月d日", <br/>culture="zh_CN", <br />ImageButton mode, <br />pre-selected using Timestamp=&lt;%= @strtotime("-1 year") %&gt;</td>
    <td class="sampleaction">
        <com:TDatePicker Mode="ImageButton" Culture="zh_CN"
            DateFormat="日期：yyyy年M月d日"
            Timestamp=<%= @strtotime("-1 year") %>/>
    </td>
</tr>

<tr>
    <td class="samplenote">Custom DateFormat="yyyy/MMMM/dd", <br />DropDownList, <br />pre-selected Date="2005/05/15"</td>
    <td class="sampleaction">
        <com:TDatePicker DateFormat="yyyy/MMMM/dd" Date="2005/05/15" InputMode="DropDownList"/>
    </td>
</tr>

<tr>
    <td class="samplenote">DropDownList, <br />pre-selected date Timestamp=&lt;%= @strtotime("-1 month") %&gt;</td>
    <td class="sampleaction">
        <com:TDatePicker InputMode="DropDownList" Timestamp=<%= @strtotime("-1 month") %>/>
    </td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TDropDownList/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203

<com:TContent ID="body">

<h1>TDropDownList Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Dropdown list with default settings:
</td>
<td class="sampleaction">
<com:TDropDownList />
</td>
</tr>

<tr>
<td class="samplenote">
Dropdown list with initial items:
</td>
<td class="sampleaction">
<com:TDropDownList>
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TDropDownList>
</td>
</tr>

<tr>
<td class="samplenote">
List box with customized row number, color and font:
</td>
<td class="sampleaction">
<com:TDropDownList ForeColor="blue" Font.Size="14pt">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TDropDownList>
</td>
</tr>

<tr>
<td class="samplenote">
Disabled dropdown list:
</td>
<td class="sampleaction">
<com:TDropDownList Enabled="false">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TDropDownList>
</td>
</tr>

<tr>
<td class="samplenote">
Auto postback dropdown list:
</td>
<td class="sampleaction">
<com:TDropDownList
    AutoPostBack="true"
    OnSelectedIndexChanged="selectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TDropDownList>
<com:TLabel ID="SelectionResult" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Dropdown list's behavior upon postback:
</td>
<td class="sampleaction">
<com:TDropDownList ID="DropDownList1">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TDropDownList>
<com:TButton Text="Submit" OnClick="buttonClicked"/>
<com:TLabel ID="SelectionResult2" ForeColor="red" />
</td>
</tr>

</table>

<h2>DropDown Lists with DataBinding</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
Databind to an integer-indexed array:
</td>
<td class="sampleaction">
<com:TDropDownList ID="DBDropDownList1"
    AutoPostBack="true"
    OnSelectedIndexChanged="DBDropDownList1Changed" />
<com:TLabel ID="DBDropDownList1Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind to an associative array:
</td>
<td class="sampleaction">
<com:TDropDownList ID="DBDropDownList2"
    AutoPostBack="true"
    OnSelectedIndexChanged="DBDropDownList2Changed" />
<com:TLabel ID="DBDropDownList2Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind with DataTextField and DataValueField specified:
</td>
<td class="sampleaction">
<com:TDropDownList ID="DBDropDownList3"
    AutoPostBack="true"
    DataTextField="name"
    DataValueField="id"
    OnSelectedIndexChanged="DBDropDownList3Changed" />
<com:TLabel ID="DBDropDownList3Result" ForeColor="red" />
</td>
</tr>

</table>

<h2>List Boxes with Validation</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
Dropdown list is being validated:
</td>
<td class="sampleaction">
<com:TDropDownList ID="VDropDownList1">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TDropDownList>
<com:TRequiredFieldValidator
    ControlToValidate="VDropDownList1"
    ErrorMessage="You must make a selection other than the first option"
    InitialValue="value 1"
    Display="Dynamic"
    ValidationGroup="Group1"
    />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Dropdown list causing validation:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    ErrorMessage="You must enter a value"
    Display="Dynamic"
    ValidationGroup="Group2"
    />
<com:TDropDownList
    ID="VDropDownList2"
    AutoPostBack="true"
    ValidationGroup="Group2">
  <com:TListItem Text="Agree" />
  <com:TListItem Text="Disagree" />
</com:TDropDownList>
</td>
</tr>

<tr>
<td class="samplenote">
Dropdown list with option groups:
</td>
<td class="sampleaction">
<com:TDropDownList>
  <com:TListItem Value="value 1" Text="item 1" Attributes.Group="group 1"/>
  <com:TListItem Value="value 2" Text="item 2" Attributes.Group="group 1"/>
  <com:TListItem Value="value 3" Text="item 3" Attributes.Group="group 2"/>
  <com:TListItem Value="value 4" Text="item 4" Attributes.Group="group 2"/>
</com:TDropDownList>
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TDropDownList/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $data=array('item 1','item 2','item 3','item 4');
            $this->DBDropDownList1->DataSource=$data;
            $this->DBDropDownList1->dataBind();

            $data=array('key 1'=>'item 1','key 2'=>'item 2',
                        'key 3'=>'item 3','key 4'=>'item 4');
            $this->DBDropDownList2->DataSource=$data;
            $this->DBDropDownList2->dataBind();

            $data=array(
                array('id'=>'001','name'=>'John','age'=>31),
                array('id'=>'002','name'=>'Mary','age'=>30),
                array('id'=>'003','name'=>'Cary','age'=>20));
            $this->DBDropDownList3->DataSource=$data;
            $this->DBDropDownList3->dataBind();
        }
    }

    protected function collectSelectionResult($input,$output)
    {
        $indices=$input->SelectedIndices;
        $result='';
        foreach($indices as $index)
        {
            $item=$input->Items[$index];
            $result.="(Index: $index, Value: $item->Value, Text: $item->Text)";
        }
        if($result==='')
            $output->Text='Your selection is empty.';
        else
            $output->Text='Your selection is: '.$result;
    }

    public function DBDropDownList1Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBDropDownList1Result);
    }

    public function DBDropDownList2Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBDropDownList2Result);
    }

    public function DBDropDownList3Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBDropDownList3Result);
    }

    public function selectionChanged($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->SelectionResult);
    }

    public function buttonClicked($sender,$param)
    {
        $this->collectSelectionResult($this->DropDownList1,$this->SelectionResult2);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TEmailAddressValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57

<com:TContent ID="body">

<h1>TEmailAddressValidator Samples</h1>
<p><strong>Note:</strong> TEmailAddressValidator will start
to validate only if the input is not empty.</p>

<table class="sampletable">

<tr>
<td class="samplenote">
Email address validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" Text="a"/>
<com:TEmailAddressValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    Text="Invalid email address." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Email address validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" Text="b"/>
<com:TEmailAddressValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    Text="Invalid email address." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

<tr>
<td class="samplenote">
Email address validator with focus-on-error enabled and dynamic display:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox3" Text="c"/>
<com:TEmailAddressValidator
    ValidationGroup="Group3"
    ControlToValidate="TextBox3"
    FocusOnError="true"
    Display="Dynamic"
    Text="Invalid email address." />
<com:TButton Text="Submit" ValidationGroup="Group3" />
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TEmailAddressValidator/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TExpression/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

<com:TContent ID="body">

<h1>TExpression Sample</h1>

<table class="sampletable">

<tr><td class="samplenote">
Using expression component tag:
</td><td class="sampleaction">
<com:TExpression Expression="$this->Page->Head->Title" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TFileUpload/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<com:TContent ID="body">

<h1>TFileUpload Sample</h1>

<p>
Please choose a file to upload:
</p>

<com:TFileUpload OnFileUpload="fileUploaded" />

<com:TButton Text="Upload" />

<br/>

<com:TLabel ID="Result" />

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TFileUpload/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<?php

class Home extends TPage
{
    public function fileUploaded($sender,$param)
    {
        if($sender->HasFile)
        {
            $this->Result->Text="
                You just uploaded a file:
                <br/>
                Name: {$sender->FileName}
                <br/>
                Size: {$sender->FileSize}
                <br/>
                Type: {$sender->FileType}";
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/THtmlArea/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43

<com:TContent ID="body">

<h1>THtmlArea Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
THtmlArea with default settings:
</td><td class="sampleaction">
<com:THtmlArea ID="HtmlArea1" />
<com:TButton Text="Submit" OnClick="button1Clicked" />
<br/>
<com:TLiteral Encode="true" ID="Result1" />
</td></tr>

<tr><td class="samplenote">
THtmlArea with manually set options
</td><td class="sampleaction">
<com:THtmlArea ID="HtmlArea2" Width="670px" Height="300px">
  <prop:Options>
        theme : "advanced",
        theme_advanced_resize_horizontal : false,
        theme_advanced_resizing : true
  </prop:Options>
</com:THtmlArea>
<com:TButton Text="Submit" OnClick="button2Clicked" />
<br/>
<com:TLiteral Encode="true" ID="Result2" />
</td></tr>

<tr><td class="samplenote">
THtmlArea with visual editting disabled:
</td><td class="sampleaction">
<com:THtmlArea ID="HtmlArea3" EnableVisualEdit="false" />
<br/>
<com:TButton Text="Submit" OnClick="button3Clicked" />
<br/>
<com:TLiteral Encode="true" ID="Result3" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/THtmlArea/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<?php

class Home extends TPage
{
    public function button1Clicked($sender,$param)
    {
        $this->Result1->Text="You have entered: ".$this->HtmlArea1->Text;
    }

    public function button2Clicked($sender,$param)
    {
        $this->Result2->Text="You have entered: ".$this->HtmlArea2->Text;
    }

    public function button3Clicked($sender,$param)
    {
        $this->Result3->Text="You have entered: ".$this->HtmlArea3->Text;
    }
}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/THyperLink/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50

<com:TContent ID="body">

<h1>THyperLink Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A regular hyperlink:
</td><td class="sampleaction">
Welcome to
<com:THyperLink
    NavigateUrl="http://www.pradosoft.com/"
    Text="PradoSoft.com"
    Target="_blank" />.
</td></tr>

<tr><td class="samplenote">
A text hyperlink with css style:
</td><td class="sampleaction">
Welcome to
<com:THyperLink
    NavigateUrl="http://www.pradosoft.com/"
    Text="PradoSoft.com"
    Target="_blank"
    BackColor="silver"
    Font.Italic="true" />.
</td></tr>

<tr><td class="samplenote">
An image hyperlink:
</td><td class="sampleaction">
<com:THyperLink
    NavigateUrl="http://www.pradosoft.com/"
    ImageUrl=<%~hello_world.gif%>
    Text="Hello World" />.
</td></tr>

<tr><td class="samplenote">
A hyerplink with body contents as link text:
</td><td class="sampleaction">
<com:THyperLink
    NavigateUrl="http://www.pradosoft.com/"
    Target="_blank">
Body contents
</com:THyperLink>
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Class file: | HelloWorld.html
Template file: | Home.page

/Controls/Samples/TImage/HelloWorld.html

1
2
3
4
5
6
7
8

<html>
<head>
<title>Hello World!</title>
</head>
<body>
This is Hello World long description file!
</body>
</html>


PRADO QuickStart Source View

Class file: | HelloWorld.html
Template file: | Home.page

/Controls/Samples/TImage/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

<com:TContent ID="body">

<h1>TImage Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Image with only <tt>ImageUrl</tt> being set:
</td><td class="sampleaction">
<com:TImage ImageUrl=<%~hello_world.gif%> />
</td></tr>

<tr><td class="samplenote">
Image with <tt>AlterantiveText</tt> being set:
</td><td class="sampleaction">
<com:TImage
    ImageUrl=<%~hello_world.gif%>
    AlternateText="Hello World!"/>
</td></tr>

<tr><td class="samplenote">
Image with <tt>baseline</tt> alignment:
</td><td class="sampleaction">
Hello World! Hello World! Hello World! Hello World! Hello World! Hello World!
Hello World! Hello World! Hello World! Hello World! Hello World! Hello World!
Hello World! Hello World! Hello World! Hello World! Hello World! Hello World!
Hello World! Hello World! Hello World! Hello World! Hello World! Hello World!
<com:TImage ImageUrl=<%~hello_world.gif%> ImageAlign="baseline" />
</td></tr>

<tr><td class="samplenote">
Image with <tt>DescriptionUrl</tt>:
</td><td class="sampleaction">
<com:TImage
    ImageUrl=<%~hello_world.gif%>
    DescriptionUrl=<%~HelloWorld.html%> />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TImageButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50

<com:TContent ID="body">

<h1>TImageButton Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A click image button showing the click location:
</td><td class="sampleaction">
<com:TImageButton
    ImageUrl=<%~ hello_world.gif %>
    Text="hello world"
    OnClick="buttonClicked"
    />
<com:TLabel ID="Result" />
</td></tr>

<tr><td class="samplenote">
A command image button:
</td><td class="sampleaction">
<com:TImageButton
    ImageUrl=<%~ hello_world.gif %>
    Text="hello world"
    OnCommand="buttonClicked"
    CommandName="test"
    CommandParameter="value"
    />
<com:TLabel ID="Result2" />
</td></tr>

<tr><td class="samplenote">
An image button causing validation:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TImageButton
    ImageUrl=<%~ hello_world.gif %>
    Text="hello world"
    ValidationGroup="Group"
    />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TImageButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        if($param instanceof TCommandEventParameter)
        {
            $this->Result2->Text="Command name: $param->CommandName, Command parameter: $param->CommandParameter";
        }
        else
        {
            $this->Result->Text="You clicked at ($param->X,$param->Y)";
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TImageMap/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40

<com:TContent ID="body">

<h1>TImageMap Sample</h1>

<com:TImageMap
        ImageUrl=<%~hotspots.gif%>
        AlternateText="navigate buttons"
        OnClick="buttonClicked" >

<com:TCircleHotSpot
    HotspotMode="Navigate"
    NavigateUrl="http://www.pradosoft.com"
    AlternateText="Navigate to pradosoft.com"
    Target="_blank"
    X="80"
    Y="80"
    Radius="55" />

<com:TPolygonHotSpot
    HotspotMode="Inactive"
    AlternateText="Inactive area"
    Coordinates="200,137,255,95,313,137,291,204,219,204"
    />

<com:TRectangleHotSpot
    HotspotMode="PostBack"
    PostBackValue="Welcome!"
    AlternateText="Postback button"
    Top="52"
    Left="172"
    Bottom="259"
    Right="339" />

</com:TImageMap>

<br/>

<com:TLabel ID="Result" />

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TImageMap/Home.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $this->Result->Text="Your post value is : ".$param->PostBackValue;
    }
}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TInlineFrame/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34

<com:TContent ID="body">

<h1>TInlineFrame Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Inline frame with default settings:
</td><td class="sampleaction">
<com:TInlineFrame FrameUrl="http://www.google.com/" />
</td></tr>

<tr><td class="samplenote">
Inline frame customized with margins and align:
</td><td class="sampleaction">
<com:TInlineFrame
    MarginWidth="100"
    MarginHeight="100"
    Align="Right"
    FrameUrl="http://www.google.com/" />
</td></tr>

<tr><td class="samplenote">
Inline frame without scrollbars and border:
</td><td class="sampleaction">
<com:TInlineFrame
    ScrollBars="None"
    ShowBorder="false"
    FrameUrl="http://www.google.com/" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TKeyboard/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14

<com:TContent ID="body">
<h1>TKeyboard Samples</h1>

<div>
<com:TTextBox ID="PasswordInput" />
<com:TButton Text="Submit" OnClick="buttonClicked" />
<com:TLiteral ID="Result" />
</div>
<div>
<com:TKeyboard ForControl="PasswordInput" AutoHide="true" />
</div>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TKeyboard/Home.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $this->Result->Text='You have entered "'.$this->PasswordInput->Text.'".';
    }
}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TLabel/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46

<com:TContent ID="body">

<h1>TLabel Samples</h1>

<div class="samplepanel">

<com:TLabel
    Text="This is a label with customized color and font."
    ForeColor="yellow"
    BackColor="blue"
    Font.Name="Arial"
    Font.Size="14pt"
/>

</div>

<div class="samplepanel">

<com:TLabel ID="Label1"
    Text="This is a form label associated with the TTextBox control below."
    ForControl="test"
/>

<br/><com:TTextBox ID="test" />

</div>

<div class="samplepanel">

<com:TLabel ForeColor="blue" Style="color:red;">
This is a label with empty Text property and <b>nonempty body</b>.
</com:TLabel>

</div>

<div class="samplepanel">

<com:TLabel
    Text="This is a disabled label."
    Enabled="false"
    ID="Label2"
/>

</div>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TLinkButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58

<com:TContent ID="body">

<h1>TLinkButton Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Link button with customized color and font:
</td><td class="sampleaction">
<com:TLinkButton
    Text="link button"
    ForeColor="silver"
    BackColor="black"
    Font.Size="14pt"
/>
</td></tr>

<tr><td class="samplenote">
Link button with only body content:
</td><td class="sampleaction">
<com:TLinkButton>
body content
</com:TLinkButton>
</td></tr>

<tr><td class="samplenote">
A click link button:
</td><td class="sampleaction">
<com:TLinkButton Text="click me" OnClick="buttonClicked" />
</td></tr>

<tr><td class="samplenote">
A command link button:
</td><td class="sampleaction">
<com:TLinkButton
    Text="click me"
    OnCommand="buttonClicked"
    CommandName="test"
    CommandParameter="value"
    />
</td></tr>

<tr><td class="samplenote">
A button causing validation:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TLinkButton Text="submit" ValidationGroup="Group" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TLinkButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        if($param instanceof TCommandEventParameter)
            $sender->Text="Name: {$param->CommandName}, Param: {$param->CommandParameter}";
        else
            $sender->Text="I'm clicked";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TListBox/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274

<com:TContent ID="body">

<h1>TListBox Samples</h1>

<h2>List Boxes in Single Selection Mode</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
List box with default settings:
</td>
<td class="sampleaction">
<com:TListBox />
</td>
</tr>

<tr>
<td class="samplenote">
List box with initial items:
</td>
<td class="sampleaction">
<com:TListBox>
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TListBox>
</td>
</tr>

<tr>
<td class="samplenote">
List box with customized row number, color and font:
</td>
<td class="sampleaction">
<com:TListBox Rows="3" ForeColor="blue" Font.Size="14pt">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TListBox>
</td>
</tr>

<tr>
<td class="samplenote">
Disabled list box:
</td>
<td class="sampleaction">
<com:TListBox Enabled="false">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TListBox>
</td>
</tr>

<tr>
<td class="samplenote">
Auto postback list box:
</td>
<td class="sampleaction">
<com:TListBox
    AutoPostBack="true"
    OnSelectedIndexChanged="selectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TListBox>
<com:TLabel ID="SelectionResult" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
List box's behavior upon postback:
</td>
<td class="sampleaction">
<com:TListBox ID="ListBox1">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TListBox>
<com:TButton Text="Submit" OnClick="buttonClicked"/>
<com:TLabel ID="SelectionResult2" ForeColor="red" />
</td>
</tr>

</table>

<h2>List Boxes in Multiple Selection Mode</h2>
<i>Use Ctrl + Mouse Click to change selection</i>
<br/>

<table class="sampletable">

<tr>
<td class="samplenote">
List box with default settings:
</td>
<td class="sampleaction">
<com:TListBox SelectionMode="Multiple" />
</td>
</tr>

<tr>
<td class="samplenote">
List box with initial items:
</td>
<td class="sampleaction">
<com:TListBox SelectionMode="Multiple">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TListBox>
</td>
</tr>

<tr>
<td class="samplenote">
List box's behavior upon postback:
</td>
<td class="sampleaction">
<com:TListBox ID="ListBox2" SelectionMode="Multiple">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TListBox>
<com:TButton Text="Submit" OnClick="buttonClicked2" />
<br/>
<com:TLabel ID="MultiSelectionResult2" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Auto postback list box:
</td>
<td class="sampleaction">
<com:TListBox AutoPostBack="true"
    SelectionMode="Multiple"
    OnSelectedIndexChanged="multiSelectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TListBox>
<com:TLabel ID="MultiSelectionResult" ForeColor="red" />
</td>
</tr>

</table>

<h2>List Boxes with DataBinding</h2>
<i>Use Ctrl + Mouse Click to change selection</i>
<br/>

<table class="sampletable">

<tr>
<td class="samplenote">
Databind to an integer-indexed array:
</td>
<td class="sampleaction">
<com:TListBox ID="DBListBox1"
    AutoPostBack="true"
    SelectionMode="Multiple"
    OnSelectedIndexChanged="DBListBox1Changed" />
<com:TLabel ID="DBListBox1Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind to an associative array:
</td>
<td class="sampleaction">
<com:TListBox ID="DBListBox2"
    AutoPostBack="true"
    SelectionMode="Multiple"
    OnSelectedIndexChanged="DBListBox2Changed" />
<com:TLabel ID="DBListBox2Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind with DataTextField and DataValueField specified:
</td>
<td class="sampleaction">
<com:TListBox ID="DBListBox3"
    AutoPostBack="true"
    SelectionMode="Multiple"
    DataTextField="name"
    DataValueField="id"
    OnSelectedIndexChanged="DBListBox3Changed" />
<com:TLabel ID="DBListBox3Result" ForeColor="red" />
</td>
</tr>

</table>

<h2>List Boxes with Validation</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
List box is being validated:
</td>
<td class="sampleaction">
<com:TListBox ID="VListBox1">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TListBox>
<com:TRequiredFieldValidator
    ControlToValidate="VListBox1"
    ErrorMessage="You must make a selection"
    Display="Dynamic"
    ValidationGroup="Group1"
    />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
List box causing validation:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    ErrorMessage="You must enter a value"
    Display="Dynamic"
    ValidationGroup="Group2"
    />
<com:TListBox
    ID="VListBox2"
    AutoPostBack="true"
    ValidationGroup="Group2">
  <com:TListItem Text="Agree" />
  <com:TListItem Text="Disagree" />
</com:TListBox>
</td>
</tr>

<tr>
<td class="samplenote">
List box with option groups:
</td>
<td class="sampleaction">
<com:TListBox>
  <com:TListItem Value="value 1" Text="item 1" Attributes.Group="group 1"/>
  <com:TListItem Value="value 2" Text="item 2" Attributes.Group="group 1"/>
  <com:TListItem Value="value 3" Text="item 3" Attributes.Group="group 2"/>
  <com:TListItem Value="value 4" Text="item 4" Attributes.Group="group 2"/>
</com:TListBox>
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TListBox/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $data=array('item 1','item 2','item 3','item 4');
            $this->DBListBox1->DataSource=$data;
            $this->DBListBox1->dataBind();

            $data=array('key 1'=>'item 1','key 2'=>'item 2',
                        'key 3'=>'item 3','key 4'=>'item 4');
            $this->DBListBox2->DataSource=$data;
            $this->DBListBox2->dataBind();

            $data=array(
                array('id'=>'001','name'=>'John','age'=>31),
                array('id'=>'002','name'=>'Mary','age'=>30),
                array('id'=>'003','name'=>'Cary','age'=>20));
            $this->DBListBox3->DataSource=$data;
            $this->DBListBox3->dataBind();
        }
    }

    public function DBListBox1Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBListBox1Result);
    }

    public function DBListBox2Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBListBox2Result);
    }

    public function DBListBox3Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBListBox3Result);
    }

    protected function collectSelectionResult($input,$output)
    {
        $indices=$input->SelectedIndices;
        $result='';
        foreach($indices as $index)
        {
            $item=$input->Items[$index];
            $result.="(Index: $index, Value: $item->Value, Text: $item->Text)";
        }
        if($result==='')
            $output->Text='Your selection is empty.';
        else
            $output->Text='Your selection is: '.$result;
    }

    public function selectionChanged($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->SelectionResult);
    }

    public function buttonClicked($sender,$param)
    {
        $this->collectSelectionResult($this->ListBox1,$this->SelectionResult2);
    }

    public function multiSelectionChanged($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->MultiSelectionResult);
    }

    public function buttonClicked2($sender,$param)
    {
        $this->collectSelectionResult($this->ListBox2,$this->MultiSelectionResult2);
    }
}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TLiteral/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13

<com:TContent ID="body">

<h1>TLiteral Sample</h1>

<p>
<com:TLiteral Text="This is a piece of unencoded text." />
</p>

<p>
<com:TLiteral Text="This is a piece of encoded <a>text</a>." Encode="true"/>
</p>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TMultiView/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37

<com:TContent ID="body">

<h1>TMultiView Samples</h1>

<com:TMultiView ID="MultiView" ActiveViewIndex="0" OnActiveViewChanged="viewChanged">
  <com:TView ID="View1">
    <h2>View 1</h2>
    <p>Please enter a memo:</p>
    <com:TTextBox ID="Memo" />
    <hr/>
    <com:TButton Text="View 2" CommandName="NextView" />
    <com:TButton Text="View 3" CommandName="SwitchViewIndex" CommandParameter="2" />
  </com:TView>
  <com:TView>
    <h2>View 2</h2>
    <p>Please choose a color:</p>
    <com:TDropDownList ID="DropDownList">
      <com:TListItem Value="Red" />
      <com:TListItem Value="Blue" />
      <com:TListItem Value="Green" />
    </com:TDropDownList>
    <hr/>
    <com:TButton Text="View 1" CommandName="PreviousView" />
    <com:TButton Text="View 3" CommandName="NextView" />
  </com:TView>
  <com:TView>
    <h2>View 3</h2>
    <com:TLabel ID="Result1" />
    <br/>
    <com:TLabel ID="Result2" />
    <hr/>
    <com:TButton Text="View 1" CommandName="SwitchViewID" CommandParameter="View1" />
    <com:TButton Text="View 2" CommandName="PreviousView" />
  </com:TView>
</com:TMultiView>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TMultiView/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

<?php

class Home extends TPage
{
    public function viewChanged($sender,$param)
    {
        if($this->MultiView->ActiveViewIndex===2)
        {
            $this->Result1->Text="Your text input is: ".$this->Memo->Text;
            $this->Result2->Text="Your color choice is: ".$this->DropDownList->SelectedValue;
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php

/Controls/Samples/TPager/Sample1.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77

<com:TContent ID="body">

<h1>TPager Sample</h1>
<p>
The following sample displays three different pagers associated with a single TDataList control. The datalist control is enabled with custom paging, which allows it to read only one page of data each time. This is typical in DB-driven applications.
</p>

<div>
Go to page:
<com:TPager ID="Pager"
    ControlToPaginate="DataList"
    PageButtonCount="3"
    Mode="Numeric"
    OnPageIndexChanged="pageChanged"
    />
</div>

<com:TDataList
     ID="DataList"
     AllowPaging="true"
     AllowCustomPaging="true"
     PageSize="2"
     EnableViewState="true"
     RepeatColumns="2"
     RepeatDirection="Vertical"
     ItemStyle.Font.Italic="true"
     ItemStyle.BackColor="#BFCFFF"
     HeaderStyle.BackColor="black"
     HeaderStyle.ForeColor="white"
     FooterStyle.BackColor="gray"
     AlternatingItemStyle.BackColor="#E6ECFF">

<prop:HeaderTemplate>
<div style="font-weight:bold; text-align:center;">Computer Parts</div>
</prop:HeaderTemplate>

<prop:FooterTemplate>
<div style="font-weight:bold; text-align:center;">
Total <%# $this->Parent->PageCount %> pages.
</div>
</prop:FooterTemplate>

<prop:ItemTemplate>
<table border="0" width="300">
<tr>
  <th>ID</th><th>Name</th><th>Quantity</th><th>Price</th>
</tr>
<tr>
  <td align="right"><com:TLiteral Text=<%#$this->DataItem['id'] %> /></td>
  <td align="right"><com:TLiteral Text=<%#$this->DataItem['name'] %> /></td>
  <td align="right"><com:TLiteral Text=<%#$this->DataItem['quantity'] %> /></td>
  <td align="right">$<com:TLiteral Text=<%#$this->DataItem['price'] %> /></td>
</tr>
</table>
</prop:ItemTemplate>

</com:TDataList>

<com:TPager ID="Pager2"
    ControlToPaginate="DataList"
    FirstPageText="9"
    LastPageText=":"
    Mode="NextPrev"
    NextPageText="4"
    PrevPageText="3"
    Font.Name="Webdings"
    OnPageIndexChanged="pageChanged"
    />
<br/>
Choose page:
<com:TPager ID="Pager3"
    ControlToPaginate="DataList"
    Mode="DropDownList"
    OnPageIndexChanged="pageChanged"
    />

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php

/Controls/Samples/TPager/Sample1.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82

<?php

class Sample1 extends TPage
{
    /**
     * Returns total number of data items.
     * In DB-driven applications, this typically requires
     * execution of an SQL statement with COUNT function.
     * Here we simply return a constant number.
     */
    protected function getDataItemCount()
    {
        return 19;
    }

    /**
     * Fetches a page of data.
     * In DB-driven applications, this can be achieved by executing
     * an SQL query with LIMIT clause.
     */
    protected function getData($offset,$limit)
    {
        $data=array(
            array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
            array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>false),
            array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>true),
            array('id'=>'ITN008','name'=>'CDRW drive','quantity'=>1,'price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','quantity'=>2,'price'=>10.00,'imported'=>false),
            array('id'=>'ITN010','name'=>'Video camera','quantity'=>20,'price'=>30.00,'imported'=>true),
            array('id'=>'ITN011','name'=>'Card reader','quantity'=>10,'price'=>24.00,'imported'=>true),
            array('id'=>'ITN012','name'=>'Floppy drive','quantity'=>50,'price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','quantity'=>25,'price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','quantity'=>15,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','quantity'=>50,'price'=>5.00,'imported'=>false),
            array('id'=>'ITN016','name'=>'Network cable','quantity'=>40,'price'=>8.00,'imported'=>true),
            array('id'=>'ITN017','name'=>'Case','quantity'=>8,'price'=>65.00,'imported'=>false),
            array('id'=>'ITN018','name'=>'Surge protector','quantity'=>45,'price'=>15.00,'imported'=>false),
            array('id'=>'ITN019','name'=>'Speaker','quantity'=>35,'price'=>65.00,'imported'=>false),
        );
        return array_slice($data,$offset,$limit);
    }

    /**
     * Determines which page of data to be displayed and
     * populates the datalist with the fetched data.
     */
    protected function populateData()
    {
        $offset=$this->DataList->CurrentPageIndex*$this->DataList->PageSize;
        $limit=$this->DataList->PageSize;
        if($offset+$limit>$this->DataList->VirtualItemCount)
            $limit=$this->DataList->VirtualItemCount-$offset;
        $data=$this->getData($offset,$limit);
        $this->DataList->DataSource=$data;
        $this->DataList->dataBind();
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataList->VirtualItemCount=$this->DataItemCount;
            $this->populateData();
        }
    }

    /**
     * Event handler to the OnPageIndexChanged event of pagers.
     */
    public function pageChanged($sender,$param)
    {
        $this->DataList->CurrentPageIndex=$param->NewPageIndex;
        $this->populateData();
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TPanel/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72

<com:TContent ID="body">

<h1>TPanel Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Panel with contents:
</td><td class="sampleaction">
<com:TPanel>
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
</com:TPanel>
</td></tr>

<tr><td class="samplenote">
Panel with customized background color, font and horizontal alignment:
</td><td class="sampleaction">
<com:TPanel
    BackColor="silver"
    Font.Size="14pt"
    HorizontalAlign="Center">
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
</com:TPanel>
</td></tr>

<tr><td class="samplenote">
Panel with customized background image, width and scroll bars:
</td><td class="sampleaction">
<com:TPanel
    BackImageUrl=<%~hello_world.gif%>
    Width="400px"
    Height="200px"
    ScrollBars="Both"
    Wrap="false">
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
</com:TPanel>
</td></tr>

<tr><td class="samplenote">
Panel with grouping text:
</td><td class="sampleaction">
<com:TPanel GroupingText="grouping text" Width="400px">
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
</com:TPanel>
</td></tr>

<tr><td class="samplenote">
Panel with a default button (hit 'enter' key to see what happened):
</td><td class="sampleaction">
<com:TPanel BackColor="#CCFFCC" DefaultButton="Button2" Width="400px">
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />
and two buttons: <br/>
<com:TCheckBox />
<com:TButton ID="Button1" Text="button1" OnClick="buttonClicked" />
<com:TButton ID="Button2" Text="button2" OnClick="buttonClicked" />
<com:TLabel ID="Result" ForeColor="red" />
<br/>
When you change focus to the panel and hit 'enter' key, <tt>button2</tt>
will be clicked because it is set as the default button of the panel.
</com:TPanel>
</td></tr>
</table>
<com:TJavascriptLogger />

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TPanel/Home.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $this->Result->Text="You have clicked on '$sender->Text'.";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TPlaceHolder/Home.page

1
2
3
4
5
6
7
8
9
10
11

<com:TContent ID="body">

<h1>TPlaceHolder Sample</h1>

<p>
This sample shows how to insert <com:TPlaceHolder ID="PlaceHolder1" />
at a place that is reserved on a template. The dynamic content can be
either static texts or controls.
</p>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TPlaceHolder/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<?php

class Home extends TPage
{
    public function onInit($param)
    {
        parent::onInit($param);
        $label=new TLabel;
        $label->Text='dynamic';
        $label->BackColor='silver';
        $this->PlaceHolder1->Controls[]=$label;
        $this->PlaceHolder1->Controls[]=' content';
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRadioButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102

<com:TContent ID="body">

<h1>TRadioButton Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A radiobutton with customized text alignment, color and font:
</td><td class="sampleaction">
<com:TRadioButton
    Text="radiobutton"
    TextAlign="Left"
    ForeColor="silver"
    BackColor="green"
    Font.Size="14pt"
/>
</td></tr>

<tr><td class="samplenote">
A radiobutton with label and input attributes:
</td><td class="sampleaction">
<com:TRadioButton
    Text="click me"
    InputAttributes.value="value"
    LabelAttributes.style="color:red"
/>
</td></tr>

<tr><td class="samplenote">
An auto postback radiobutton:
</td><td class="sampleaction">
<com:TRadioButton
    AutoPostBack="true"
    Text="click me"
    OnCheckedChanged="radiobuttonClicked"
    />
</td></tr>

<tr><td class="samplenote">
A radiobutton causing validation on a textbox:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TRadioButton
    Text="submit"
    AutoPostBack="true"
    ValidationGroup="Group"
    />
</td></tr>

<tr><td class="samplenote">
A radiobutton validated by a required field validator:
</td><td class="sampleaction">
<com:TRadioButton
    ID="RadioButton"
    Text="Consent"
    ValidationGroup="Group2"
    />
<com:TButton Text="Submit" ValidationGroup="Group2" />
<com:TRequiredFieldValidator
    ControlToValidate="RadioButton"
    Display="Dynamic"
    ErrorMessage="You must consent."
    ValidationGroup="Group2"
    />
</td></tr>

<tr><td class="samplenote">
A radiobutton group:
</td><td class="sampleaction">
<com:TRadioButton
    ID="Radio1"
    GroupName="RadioGroup"
    Text="Option 1"
    />
<com:TRadioButton
    ID="Radio2"
    GroupName="RadioGroup"
    Text="Option 2"
    />
<com:TRadioButton
    ID="Radio3"
    GroupName="RadioGroup"
    Text="Option 3"
    />
<com:TRadioButton
    ID="Radio4"
    Text="Option 4 (in a different group)"
    />
<br/>
<com:TButton Text="Submit" OnClick="selectRadioButton" />
<com:TLabel ID="Result" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRadioButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<?php

class Home extends TPage
{
    public function radiobuttonClicked($sender,$param)
    {
        $sender->Text="I'm clicked";
    }

    public function selectRadioButton($sender,$param)
    {
        $selection='';
        if($this->Radio1->Checked)
            $selection.='1';
        if($this->Radio2->Checked)
            $selection.='2';
        if($this->Radio3->Checked)
            $selection.='3';
        if($this->Radio4->Checked)
            $selection.='4';
        if($selection==='')
            $selection='empty';
        $this->Result->Text='Your selection is '.$selection;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRadioButtonList/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208

<com:TContent ID="body">

<h1>TRadioButtonList Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Radio button list with default settings:
</td>
<td class="sampleaction">
<com:TRadioButtonList>
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Radio button list with customized cellpadding, cellspacing, color and text alignment:
</td>
<td class="sampleaction">
<com:TRadioButtonList
    CellPadding="5"
    CellSpacing="1"
    BackColor="silver"
    TextAlign="Left">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Radio button list with vertical (default) repeat direction:
</td>
<td class="sampleaction">
<com:TRadioButtonList RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Radio button list with horizontal repeat direction:
</td>
<td class="sampleaction">
<com:TRadioButtonList RepeatDirection="Horizontal"    RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Radio button list with flow layout and vertical (default) repeat direction:
</td>
<td class="sampleaction">
<com:TRadioButtonList RepeatLayout="Flow" RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Radio button list with flow layout and horizontal repeat direction:
</td>
<td class="sampleaction">
<com:TRadioButtonList
    RepeatLayout="Flow"
    RepeatDirection="Horizontal"
    RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Radio button list's behavior upon postback:
</td>
<td class="sampleaction">
<com:TRadioButtonList ID="RadioButtonList">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Enabled="false" />
  <com:TListItem Value="value 5" Text="item 5" />
</com:TRadioButtonList>
<com:TButton Text="Submit" OnClick="buttonClicked" />
<br/>
<com:TLabel ID="SelectionResult" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Auto postback radio button list:
</td>
<td class="sampleaction">
<com:TRadioButtonList
    AutoPostBack="true"
    OnSelectedIndexChanged="selectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Enabled="false" />
  <com:TListItem Value="value 5" Text="item 5" />
</com:TRadioButtonList>
<com:TLabel ID="SelectionResult2" ForeColor="red" />
</td>
</tr>

</table>

<h2>Radio Button Lists with DataBinding</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
Databind to an integer-indexed array:
</td>
<td class="sampleaction">
<com:TRadioButtonList ID="DBRadioButtonList1"
    AutoPostBack="true"
    OnSelectedIndexChanged="DBRadioButtonList1Changed" />
<com:TLabel ID="DBRadioButtonList1Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind to an associative array:
</td>
<td class="sampleaction">
<com:TRadioButtonList ID="DBRadioButtonList2"
    AutoPostBack="true"
    OnSelectedIndexChanged="DBRadioButtonList2Changed" />
<com:TLabel ID="DBRadioButtonList2Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind with DataTextField and DataValueField specified:
</td>
<td class="sampleaction">
<com:TRadioButtonList ID="DBRadioButtonList3"
    AutoPostBack="true"
    DataTextField="name"
    DataValueField="id"
    OnSelectedIndexChanged="DBRadioButtonList3Changed" />
<com:TLabel ID="DBRadioButtonList3Result" ForeColor="red" />
</td>
</tr>

</table>

<h2>RadioButton List with Validation</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
RadioButton list causing validation:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    ErrorMessage="You must enter a value"
    Display="Dynamic"
    ValidationGroup="Group2"
    />
<com:TRadioButtonList AutoPostBack="true" ValidationGroup="Group2">
  <com:TListItem Text="Agree" />
  <com:TListItem Text="Disagree" />
</com:TRadioButtonList>
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRadioButtonList/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $data=array('item 1','item 2','item 3','item 4');
            $this->DBRadioButtonList1->DataSource=$data;
            $this->DBRadioButtonList1->dataBind();

            $data=array('key 1'=>'item 1','key 2'=>'item 2',
                        'key 3'=>'item 3','key 4'=>'item 4');
            $this->DBRadioButtonList2->DataSource=$data;
            $this->DBRadioButtonList2->dataBind();

            $data=array(
                array('id'=>'001','name'=>'John','age'=>31),
                array('id'=>'002','name'=>'Mary','age'=>30),
                array('id'=>'003','name'=>'Cary','age'=>20));
            $this->DBRadioButtonList3->DataSource=$data;
            $this->DBRadioButtonList3->dataBind();
        }
    }

    protected function collectSelectionResult($input,$output)
    {
        $indices=$input->SelectedIndices;
        $result='';
        foreach($indices as $index)
        {
            $item=$input->Items[$index];
            $result.="(Index: $index, Value: $item->Value, Text: $item->Text)";
        }
        if($result==='')
            $output->Text='Your selection is empty.';
        else
            $output->Text='Your selection is: '.$result;
    }

    public function buttonClicked($sender,$param)
    {
        $this->collectSelectionResult($this->RadioButtonList,$this->SelectionResult);
    }

    public function selectionChanged($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->SelectionResult2);
    }

    public function DBRadioButtonList1Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBRadioButtonList1Result);
    }

    public function DBRadioButtonList2Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBRadioButtonList2Result);
    }

    public function DBRadioButtonList3Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBRadioButtonList3Result);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRangeValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45

<com:TContent ID="body">

<h1>TRangeValidator Samples</h1>
<p><strong>Note:</strong> TRangeValidator will start
to validate only if both inputs are not empty.</p>

<table class="sampletable">

<tr>
<td class="samplenote">
Range validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" Text="a1" />
<com:TRangeValidator
    ControlToValidate="TextBox1"
    ValidationGroup="Group1"
    MinValue="aaa"
    MaxValue="zzz"
    Text="Input must be between 'aaa' and 'zzz'." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Range validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" Text="11"/>
<com:TRangeValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    DataType="Integer"
    MinValue="100"
    MaxValue="999"
    Text="Input must be between 100 and 999." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRangeValidator/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRegularExpressionValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61

<com:TContent ID="body">

<h1>TRegularExpressionValidator Samples</h1>
<p>
<strong>Note:</strong> TRegularExpressionValidator will start
to validate only if the input is not empty.
</p>

<table class="sampletable">

<tr>
<td class="samplenote">
Regular expression validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" Text="xxx-xx-xxxx"/>
<com:TRegularExpressionValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    RegularExpression="\d{3}-\d{2}-\d{4}"
    Text="SSN must be in the format of xxx-xx-xxxx." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Regular expression validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" Text="b"/>
<com:TRegularExpressionValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    RegularExpression="[\w]{6,}"
    Text="Input must consist of at least 6 characters." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

<tr>
<td class="samplenote">
Regular expression validator with focus-on-error enabled and dynamic display:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox3" Text="c"/>
<com:TRegularExpressionValidator
    ValidationGroup="Group3"
    ControlToValidate="TextBox3"
    Display="Dynamic"
    RegularExpression="\d{5}(-\d{4})?"
    Text="Invalid US ZIP code." />
<com:TButton Text="Submit" ValidationGroup="Group3" />
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRegularExpressionValidator/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/RegionDisplay.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28

<?php

class RegionDisplay extends TRepeaterItemRenderer
{
    /**
     * This method is invoked when the data is being bound
     * to the parent repeater.
     * At this time, the <b>Data</b> is available which
     * refers to the data row associated with the parent repeater item.
     */
    public function onDataBinding($param)
    {
        parent::onDataBinding($param);
        $this->Repeater->DataSource=$this->Data['detail'];
        $this->Repeater->dataBind();
    }

    public function itemCreated($sender,$param)
    {
        static $itemIndex=0;
        $item=$param->Item;
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem')
            $item->Row->BackColor=$itemIndex%2 ? "#BFCFFF" : "#E6ECFF";
        $itemIndex++;
    }
}

?>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/RegionDisplay.tpl

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34

<tr>
<com:TTableCell ID="Cell"
    ForeColor="white"
    BackColor="<%# $this->ItemIndex%2 ? '#6078BF' : '#809FFF' %>"
    Text="<%#$this->Data['name'] %>"
    />
<td>

<com:TRepeater ID="Repeater" OnItemCreated="itemCreated">
<prop:HeaderTemplate>
<table cellspacing="1">
</prop:HeaderTemplate>

<prop:ItemTemplate>
<com:TTableRow ID="Row">
  <com:TTableCell Width="70px">
    <%#$this->Data['name'] %>
  </com:TTableCell>
  <com:TTableCell Width="20">
    <%#$this->Data['age'] %>
  </com:TTableCell>
  <com:TTableCell Width="150px">
    <%#$this->Data['position'] %>
  </com:TTableCell>
</com:TTableRow>
</prop:ItemTemplate>

<prop:FooterTemplate>
</table>
</prop:FooterTemplate>
</com:TRepeater>

</td>
</tr>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample1.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47

<com:TContent ID="body">

<h1>TRepeater Sample 1</h1>

<com:TRepeater ID="Repeater" EnableViewState="false">

<prop:HeaderTemplate>
<table cellpadding="2">
<tr style="color:white;background-color:black">
  <th>ID</th>
  <th>Name</th>
  <th>Quantity</th>
  <th>Price</th>
  <th>Imported</th>
</tr>
</prop:HeaderTemplate>

<prop:ItemTemplate>
<tr style="background-color:#BFCFFF">
<td><%#$this->Data['id']%></td>
<td><%#$this->Data['name']%></td>
<td><%#$this->Data['quantity']%></td>
<td><%#$this->Data['price']%></td>
<td><%#$this->Data['imported']?'Yes':'No'%></td>
</tr>
</prop:ItemTemplate>

<prop:AlternatingItemTemplate>
<tr style="background-color:#E6ECFF">
<td><%#$this->Data['id']%></td>
<td><%#$this->Data['name']%></td>
<td><%#$this->Data['quantity']%></td>
<td><%#$this->Data['price']%></td>
<td><%#$this->Data['imported']?'Yes':'No'%></td>
</tr>
</prop:AlternatingItemTemplate>

<prop:FooterTemplate>
<tr style="color:white;background-color:black;text-align:center;">
<td colspan="5">Computer Parts Inventory</td>
</tr>
</table>
</prop:FooterTemplate>

</com:TRepeater>

</com:TContent>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample1.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

<?php

class Sample1 extends TPage
{
    protected function getData()
    {
        return array(
            array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
            array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>false),
            array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>true),
            array('id'=>'ITN008','name'=>'CDRW drive','quantity'=>1,'price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','quantity'=>2,'price'=>10.00,'imported'=>false),
            array('id'=>'ITN010','name'=>'Video camera','quantity'=>20,'price'=>30.00,'imported'=>true),
            array('id'=>'ITN011','name'=>'Card reader','quantity'=>10,'price'=>24.00,'imported'=>true),
            array('id'=>'ITN012','name'=>'Floppy drive','quantity'=>50,'price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','quantity'=>25,'price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','quantity'=>15,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','quantity'=>50,'price'=>5.00,'imported'=>false),
            array('id'=>'ITN016','name'=>'Network cable','quantity'=>40,'price'=>8.00,'imported'=>true),
            array('id'=>'ITN017','name'=>'Case','quantity'=>8,'price'=>65.00,'imported'=>false),
            array('id'=>'ITN018','name'=>'Surge protector','quantity'=>45,'price'=>15.00,'imported'=>false),
            array('id'=>'ITN019','name'=>'Speaker','quantity'=>35,'price'=>65.00,'imported'=>false),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->Repeater->DataSource=$this->getData();
            $this->Repeater->dataBind();
        }
    }
}

?>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample2.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58

<com:TContent ID="body">

<h1>TRepeater Sample 2</h1>

<com:TRepeater ID="Repeater"
    EnableViewState="false"
    OnItemDataBound="dataBindRepeater2"
    OnItemCreated="repeaterItemCreated">

<prop:HeaderTemplate>
<table cellspacing="1" style="border:1px solid silver">
</prop:HeaderTemplate>

<prop:ItemTemplate>
<tr>
<com:TTableCell ID="Cell">
  <%#$this->Data %>
</com:TTableCell>
<td>
    <com:TRepeater
         ID="Repeater2"
         EnableViewState="false"
         OnItemCreated="Page.repeater2ItemCreated">

    <prop:HeaderTemplate>
    <table cellspacing="1">
    </prop:HeaderTemplate>

    <prop:ItemTemplate>
    <com:TTableRow ID="Row">
      <com:TTableCell Width="70px">
        <%#$this->Data['name'] %>
      </com:TTableCell>
      <com:TTableCell Width="20">
        <%#$this->Data['age'] %>
      </com:TTableCell>
      <com:TTableCell Width="150px">
        <%#$this->Data['position'] %>
      </com:TTableCell>
    </com:TTableRow>
    </prop:ItemTemplate>

    <prop:FooterTemplate>
    </table>
    </prop:FooterTemplate>

    </com:TRepeater>
</td>
</tr>
</prop:ItemTemplate>

<prop:FooterTemplate>
</table>
</prop:FooterTemplate>

</com:TRepeater>

</com:TContent>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample2.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79

<?php

class Sample2 extends TPage
{
    protected function getMasterData()
    {
        return array('North','West','East','South');
    }

    protected function getDetailData($region)
    {
        static $data=array(
            'North'=>array(
                array('name'=>'John','age'=>30,'position'=>'Program Manager'),
                array('name'=>'Edward','age'=>35,'position'=>'Developer'),
                array('name'=>'Walter','age'=>28,'position'=>'Developer'),
            ),
            'West'=>array(
                array('name'=>'Cary','age'=>31,'position'=>'Senior Manager'),
                array('name'=>'Ted','age'=>25,'position'=>'Developer'),
                array('name'=>'Kevin','age'=>28,'position'=>'Developer'),
            ),
            'East'=>array(
                array('name'=>'Shawn','age'=>30,'position'=>'Sales Manager'),
                array('name'=>'Larry','age'=>28,'position'=>'Document Writer'),
            ),
            'South'=>array(
                array('name'=>'King','age'=>30,'position'=>'Program Manager'),
                array('name'=>'Carter','age'=>22,'position'=>'Developer'),
            ),
        );
        return $data[$region];
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->Repeater->DataSource=$this->getMasterData();
            $this->Repeater->dataBind();
        }
    }

    public function dataBindRepeater2($sender,$param)
    {
        $item=$param->Item;
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem')
        {
            $item->Repeater2->DataSource=$this->getDetailData($item->DataItem);
            $item->Repeater2->dataBind();
        }
    }

    public function repeaterItemCreated($sender,$param)
    {
        static $itemIndex=0;
        $item=$param->Item;
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem')
        {
            $item->Cell->BackColor=$itemIndex%2 ? "#6078BF" : "#809FFF";
            $item->Cell->ForeColor='white';
            $itemIndex++;
        }
    }

    public function repeater2ItemCreated($sender,$param)
    {
        static $itemIndex=0;
        $item=$param->Item;
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem')
        {
            $item->Row->BackColor=$itemIndex%2 ? "#BFCFFF" : "#E6ECFF";
            $itemIndex++;
        }
    }
}

?>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample3.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92

<com:TContent ID="body">

<h1>TRepeater Sample 3</h1>

<p>
The following example allows users to modify the existing tabular data using a <tt>TRepeater</tt>. Two validators are used in the repeater to ensure the validity of user inputs. One is to ensure product names are not empty, the other ensures product prices are valid numeric format. After clicking on the <tt>save</tt> button, the input data is displayed in a table at the bottom of the page.
</p>

<table>
<tr>
  <th>Name</th>
  <th>Category</th>
  <th>Price</th>
  <th>Imported</th>
</tr>
<com:TRepeater ID="Repeater" OnItemDataBound="repeaterDataBound">
<prop:ItemTemplate>
<tr>
  <td>
  <com:TTextBox
       ID="ProductName"
       Text=<%#$this->Data['name']%> />
  </td>
  <td>
  <com:TDropDownList
       ID="ProductCategory" />
  </td>
  <td>
  <com:TTextBox
       ID="ProductPrice"
       Columns="7"
       Text=<%#$this->Data['price']%> />
  </td>
  <td>
  <com:TCheckBox
       ID="ProductImported"
       Checked=<%#$this->Data['imported']%> />
  <com:TRequiredFieldValidator
       ControlToValidate="ProductName"
       ErrorMessage="Product name cannot be empty."
       Display="Dynamic" />
  <com:TRegularExpressionValidator
       ControlToValidate="ProductPrice"
       RegularExpression="\d+(\.\d{1,2})?"
       ErrorMessage="Product price must be in the format of ddd.dd"
       Display="Dynamic" />
  </td>
</tr>
</prop:ItemTemplate>
</com:TRepeater>
</table>

<div>
<com:TButton Text="Save" OnClick="saveInput"/>
</div>

<com:TSafeHtml>
<com:TRepeater ID="Repeater2" EnableViewState="false">

<prop:HeaderTemplate>
<table cellpadding="2">
<tr style="color:white;background-color:black">
  <th>ID</th>
  <th>Name</th>
  <th>Category</th>
  <th>Price</th>
  <th>Imported</th>
</tr>
</prop:HeaderTemplate>

<prop:ItemTemplate>
<tr style="<%# 'background-color:' . ($this->ItemIndex%2 ? '#BFCFFF' : '#E6ECFF') %>">
<td><%#$this->Data['id']%></td>
<td><%#$this->Data['name']%></td>
<td><%#$this->Data['category']%></td>
<td><%#$this->Data['price']%></td>
<td><%#$this->Data['imported']?'Yes':'No'%></td>
</tr>
</prop:ItemTemplate>

<prop:FooterTemplate>
<tr style="color:white;background-color:black;text-align:center;">
<td colspan="5">Computer Parts Inventory</td>
</tr>
</table>
</prop:FooterTemplate>

</com:TRepeater>

</com:TSafeHtml>

</com:TContent>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample3.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79

<?php

class Sample3 extends TPage
{
    protected function getProducts()
    {
        return array(
            array('id'=>'ITN001','name'=>'Motherboard','category'=>'CAT004','price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','category'=>'CAT004','price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','category'=>'CAT003','price'=>80.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','category'=>'CAT002','price'=>20.00,'imported'=>false),
            array('id'=>'ITN008','name'=>'CDRW drive','category'=>'CAT003','price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','category'=>'CAT001','price'=>10.00,'imported'=>false),
            array('id'=>'ITN012','name'=>'Floppy drive','category'=>'CAT003','price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','category'=>'CAT003','price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','category'=>'CAT003','price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','category'=>'CAT001','price'=>5.00,'imported'=>false),
        );
    }

    protected function getCategories()
    {
        return array(
            array('id'=>'CAT001','name'=>'Accessories'),
            array('id'=>'CAT002','name'=>'Input Devices'),
            array('id'=>'CAT003','name'=>'Drives'),
            array('id'=>'CAT004','name'=>'Barebone'),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->Repeater->DataSource=$this->Products;
            $this->Repeater->dataBind();
        }
    }

    public function repeaterDataBound($sender,$param)
    {
        $item=$param->Item;
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem')
        {
            $item->ProductCategory->DataSource=$this->Categories;
            $item->ProductCategory->DataTextField='name';
            $item->ProductCategory->DataValueField='id';
            $item->ProductCategory->dataBind();
            $item->ProductCategory->SelectedValue=$item->DataItem['category'];
        }
    }

    public function saveInput($sender,$param)
    {
        if($this->IsValid)
        {
            $index=0;
            $products=$this->Products;
            $data=array();
            foreach($this->Repeater->Items as $item)
            {
                $item=array(
                    'id'=>$products[$index]['id'],
                    'name'=>$item->ProductName->Text,
                    'category'=>$item->ProductCategory->SelectedItem->Text,
                    'price'=>TPropertyValue::ensureFloat($item->ProductPrice->Text),
                    'imported'=>$item->ProductImported->Checked,
                );
                $data[]=$item;
                $index++;
            }
            $this->Repeater2->DataSource=$data;
            $this->Repeater2->dataBind();
        }
    }
}

?>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample4.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<com:TContent ID="body">

<h1>TRepeater Sample 4</h1>

<p>Please enter the URL of your favorite websites in the following:</p>
<com:TRepeater ID="Repeater"
    OnItemCreated="itemCreated"
    ItemRenderer="TTextBox"
    />

<br/>

<com:TButton Text="Submit" OnClick="buttonClicked" />

<br/><br/>

<com:TLabel Text="You have entered the following URLs:"
    Visible="<%= $this->IsPostBack %>" />
<br/>

<com:TRepeater ID="Repeater2"
    OnItemCreated="itemCreated"
    ItemRenderer="THyperLink"
    />

</com:TContent>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample4.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37

<?php

Prado::using('System.Collections.TDummyDataSource');

class Sample4 extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            // use a dummy data source to create 3 repeater items
            $this->Repeater->DataSource=new TDummyDataSource(3);
            $this->Repeater->dataBind();
        }
    }

    public function itemCreated($sender,$param)
    {
        // $param->Item refers to the newly created repeater item
        $param->Item->Style="width:300px; margin:10px; margin-left:0px";
    }

    public function buttonClicked($sender,$param)
    {
        $links=array();
        foreach($this->Repeater->Items as $textBox)
        {
            if($textBox->Text!=='')
                $links[]=$textBox->Text;
        }
        $this->Repeater2->DataSource=$links;
        $this->Repeater2->dataBind();
    }
}

?>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample5.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<com:TContent ID="body">

<h1>TRepeater Sample 5</h1>

<com:TRepeater ID="Repeater"
    ItemRenderer="Application.pages.Controls.Samples.TRepeater.RegionDisplay">

<prop:HeaderTemplate>
<table cellspacing="1" style="border:1px solid silver">
</prop:HeaderTemplate>

<prop:FooterTemplate>
</table>
</prop:FooterTemplate>

</com:TRepeater>

</com:TContent>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample5.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52

<?php

class Sample5 extends TPage
{
    protected function getData()
    {
        return array(
            array(
                'name'=>'North',
                'detail'=>array(
                    array('name'=>'John','age'=>30,'position'=>'Program Manager'),
                    array('name'=>'Edward','age'=>35,'position'=>'Developer'),
                    array('name'=>'Walter','age'=>28,'position'=>'Developer'),
                ),
            ),
            array(
                'name'=>'West',
                'detail'=>array(
                    array('name'=>'Cary','age'=>31,'position'=>'Senior Manager'),
                    array('name'=>'Ted','age'=>25,'position'=>'Developer'),
                    array('name'=>'Kevin','age'=>28,'position'=>'Developer'),
                ),
            ),
            array(
                'name'=>'East',
                'detail'=>array(
                    array('name'=>'Shawn','age'=>30,'position'=>'Sales Manager'),
                    array('name'=>'Larry','age'=>28,'position'=>'Document Writer'),
                ),
            ),
            array(
                'name'=>'South',
                'detail'=>array(
                    array('name'=>'King','age'=>30,'position'=>'Program Manager'),
                    array('name'=>'Carter','age'=>22,'position'=>'Developer'),
                ),
            ),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->Repeater->DataSource=$this->getData();
            $this->Repeater->dataBind();
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRequiredFieldValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122

<com:TContent ID="body">

<h1>TRequiredFieldValidator Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" />
<com:TRequiredFieldValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    Text="Field required." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" />
<com:TRequiredFieldValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    Text="Field required." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

<tr>
<td class="samplenote">
Validator with focus-on-error enabled and dynamic display:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox3" />
<com:TRequiredFieldValidator
    ValidationGroup="Group3"
    Display="Dynamic"
    ControlToValidate="TextBox3"
    FocusOnError="true"
    Text="Field required." />
<com:TButton Text="Submit" ValidationGroup="Group3" />
</td>
</tr>

<tr>
<td class="samplenote">
Validating if initial value (test) is changed:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox4" Text="test" />
<com:TRequiredFieldValidator
    ValidationGroup="Group4"
    Display="Dynamic"
    ControlToValidate="TextBox4"
    InitialValue="test"
    Text="Input must not be 'test'." />
<com:TButton Text="Submit" ValidationGroup="Group4" />
</td>
</tr>

<tr>
<td class="samplenote">
Validating if checkbox is checked:
</td>
<td class="sampleaction">
<com:TCheckBox ID="CheckBox" Text="agree" />
<com:TRequiredFieldValidator
    ValidationGroup="Group5"
    Display="Dynamic"
    ControlToValidate="CheckBox"
    Text="You must agree." />
<com:TButton Text="Submit" ValidationGroup="Group5" />
</td>
</tr>

<tr>
<td class="samplenote">
Validating if a selection has been made in a dropdown list:
</td>
<td class="sampleaction">
<com:TDropDownList ID="DropDownList">
  <com:TListItem Value="value 1" Text="text 1" Selected="true" />
  <com:TListItem Value="value 2" Text="text 2" />
  <com:TListItem Value="value 3" Text="text 3" />
</com:TDropDownList>
<com:TRequiredFieldValidator
    ValidationGroup="Group6"
    ControlToValidate="DropDownList"
    InitialValue="value 1"
    Text="A selection must be made." />
<com:TButton Text="Submit" ValidationGroup="Group6" />
</td>
</tr>

<tr>
<td class="samplenote">
Validating if a selection has been made in a dropdown list:
</td>
<td class="sampleaction">
<com:TListBox ID="ListBox">
  <com:TListItem Value="value 1" Text="text 1" />
  <com:TListItem Value="value 2" Text="text 2" />
  <com:TListItem Value="value 3" Text="text 3" />
</com:TListBox>
<com:TRequiredFieldValidator
    ValidationGroup="Group7"
    ControlToValidate="ListBox"
    Text="A selection must be made." />
<com:TButton Text="Submit" ValidationGroup="Group7" />
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRequiredFieldValidator/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TSlider/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

<com:TContent id="body">
<h1>TSlider Sample</h1>

<table class="sampletable">

<tr><td class="samplenote">
Simple horizontal slider, with no progress indicator, with no events handler attached</td><td class="sampleaction">
<com:TSlider id="slider1" ProgressIndicator="false" Direction="Horizontal"/>
</td>
<td class="sampleaction">
    <com:TButton onClick="submit1" Text="Submit"/>
    <com:TLabel id="slider1Result"/>
</td></tr>
<tr><td class="samplenote">
Horizontal slider from -50 to 50,  Javascript 'onSlide' handler, ServerSide 'onSliderChanged' handler, initial value and autopostback=true
</td><td class="sampleaction">
<com:TSlider id="slider2" AutoPostBack="true"  Direction="Horizontal" Value="0" Enabled="true" MinValue="-50" MaxValue="50" OnValueChanged="slider2Changed">
    <prop:ClientSide.onSlide>
        $('slider2value').innerHTML = value;
    </prop:ClientSide.onSlide>
</com:TSlider>
Value  : <span id="slider2value"><%=$this->slider2->value%></span>
</td><td class="sampleaction">
<com:TLabel id="slider2Result"/>
</td></tr>
<tr><td class="samplenote">
Vertical slider from 0 to 1, Javascript 'onSlide' handler, ServerSide 'onSliderChanged' handler, StepSize, and no autopostback
</td><td class="sampleaction">
<com:TSlider id="slider3" AutoPostBack="false" Direction="Vertical" Enabled="true" MinValue="0" MaxValue="1" StepSize="0.1" OnValueChanged="slider3Changed">
    <prop:ClientSide.onSlide>
        $('slider3value').innerHTML = value;
    </prop:ClientSide.onSlide>
</com:TSlider>
Value  : <span id="slider3value"><%=$this->slider3->value%></span>
</td><td class="sampleaction">
<com:TButton Text="Submit"/>
<com:TLabel id="slider3Result"/>
</td></tr>
</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TSlider/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23

<?php
class Home extends TPage
{
    public function onInit ($param)
    {
        parent::onInit($param);
    }
    public function submit1 ($sender, $param)
    {
        $this->slider1Result->setText('Slider Value : '.$this->slider1->getValue());
    }

    public function slider2Changed ($sender, $param)
    {
        $this->slider2Result->setText('onSliderChanged, Value : '.$sender->getValue());
    }

    public function slider3Changed ($sender, $param)
    {
        $this->slider3Result->setText('onSliderChanged, Value : '.$sender->getValue());
    }
}
?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TStatements/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

<com:TContent ID="body">

<h1>TStatements Sample</h1>

<table class="sampletable">

<tr><td class="samplenote">
Using TStatements component tag:
</td><td class="sampleaction">
<com:TStatements>
  <prop:Statements>
  $uid=$this->UniqueID;
  echo "UniqueID is '$uid'.";
  </prop:Statements>
</com:TStatements>
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TTable/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51

<com:TContent ID="body">

<h1>TTable Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Table with default settings (looks empty):
</td><td class="sampleaction">
<com:TTable />
</td></tr>

<tr><td class="samplenote">
Table with rows and customized font, background image, etc.:
</td><td class="sampleaction">
<com:TTable
    GridLines="Both"
    CellSpacing="0"
    CellPadding="2"
    BackImageUrl=<%~backimage.gif%>
    Caption="This is table caption"
    CaptionAlign="Bottom">
  <com:TTableRow BackColor="gray" ForeColor="white">
    <com:TTableHeaderCell>header cell 1</com:TTableHeaderCell>
    <com:TTableHeaderCell>header cell 2</com:TTableHeaderCell>
    <com:TTableHeaderCell>header cell 3</com:TTableHeaderCell>
  </com:TTableRow>
  <com:TTableRow HorizontalAlign="Right">
    <com:TTableCell Text="text">cell 1</com:TTableCell>
    <com:TTableCell>cell 2</com:TTableCell>
    <com:TTableCell BackColor="red">cell 3</com:TTableCell>
  </com:TTableRow>
  <com:TTableRow>
    <com:TTableCell ForeColor="red">cell 4</com:TTableCell>
    <com:TTableCell ColumnSpan="2" HorizontalAlign="Center">
    cell 5
    </com:TTableCell>
  </com:TTableRow>
</com:TTable>
</td></tr>

<tr><td class="samplenote">
A dynamically created table:
</td><td class="sampleaction">
<com:TTable ID="Table" />
</td>
</tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TTable/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        $this->Table->GridLines='Both';

        $row=new TTableRow;
        $this->Table->Rows[]=$row;

        $cell=new TTableHeaderCell;
        $cell->Text='Header 1';
        $row->Cells[]=$cell;

        $cell=new TTableHeaderCell;
        $cell->Text='Header 2';
        $row->Cells[]=$cell;

        $row=new TTableRow;
        $this->Table->Rows[]=$row;

        $cell=new TTableCell;
        $cell->Text='Cell 1';
        $row->Cells[]=$cell;

        $cell=new TTableCell;
        $cell->Text='Cell 2';
        $row->Cells[]=$cell;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TTabPanel/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43

<com:TContent ID="body">
<h1>TTabPanel Samples</h1>

<com:TTabPanel ActiveViewID="View2">

  <com:TTabView ID="View1" Caption="View 1" Height="200px">
    <h2>View 1</h2>
    <p>
    This shows a nested tab panel. To ensure the proper display, we explicitly
    set the height of the outer view to be 200px.
    </p>
    <com:TTabPanel ActiveViewIndex="1"
            Width="50%"
            TabStyle.BorderColor="red"
            ActiveTabStyle.BorderColor="red"
            ViewStyle.BorderColor="red">
      <com:TTabView ID="View11" Caption="View 11">
       This is view 11.
      </com:TTabView>
      <com:TTabView ID="View21" Caption="View 12" Text="This is view 12" />
     </com:TTabPanel>
  </com:TTabView>

  <com:TTabView ID="View2" Caption="View 2">
    <h2>View 2</h2>
    <p>Please choose a color:</p>
    <com:TDropDownList ID="DropDownList">
      <com:TListItem Value="Red" />
      <com:TListItem Value="Blue" />
      <com:TListItem Value="Green" />
    </com:TDropDownList>
  </com:TTabView>

  <com:TTabView Caption="View 3">
    <h2>View 3</h2>
    <p>
    Click on the following button to see if we keep your input after postback.
    </p>
    <com:TButton Text="Submit" />
  </com:TTabView>
</com:TTabPanel>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TTabPanel/Home.php

1
2
3
4
5
6
7

<?php

class Home extends TPage
{
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TTextBox/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186

<com:TContent ID="body">

<h1>TTextBox Samples</h1>

<h2>SingeLine Text Boxes</h2>

<table class="sampletable">

<tr><td class="samplenote">
Text box with default settings:
</td><td class="sampleaction">
<com:TTextBox />
</td></tr>

<tr><td class="samplenote">
Text box with customized color, font, columns, maximum length:
</td><td class="sampleaction">
<com:TTextBox
    Text="text"
    ForeColor="yellow"
    BackColor="blue"
    Font.Size="14pt"
    Columns="4"
    MaxLength="6"
/>
</td></tr>

<tr><td class="samplenote">
Text box with vCard support:
</td><td class="sampleaction">
First Name: <com:TTextBox AutoCompleteType="FirstName" />
Last Name: <com:TTextBox AutoCompleteType="LastName" />
</td></tr>

<tr><td class="samplenote">
Disabled text box:
</td><td class="sampleaction">
<com:TTextBox Text="disabled" Enabled="false" />
</td></tr>

<tr><td class="samplenote">
Read-only text box:
</td><td class="sampleaction">
<com:TTextBox Text="read only" ReadOnly="true" />
</td></tr>

<tr><td class="samplenote">
Auto postback text box not causing validation:
</td><td class="sampleaction">
<com:TTextBox
    Text="change me"
    AutoPostBack="true"
    CausesValidation="false"
    OnTextChanged="textChanged" />
</td></tr>

<tr><td class="samplenote">
Auto postback text box causing validation:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox3"
    Width="300px"
    AutoPostBack="true"
    ValidationGroup="Group1"
    Text="change me to 'test' and see" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox3"
    ErrorMessage="You must enter a value not equal to 'test'."
    InitialValue="test"
    ValidationGroup="Group1" />
</td></tr>

<tr><td class="samplenote">
Text box's behavior upon postback:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox1" Text="text" />
<com:TButton
    Text="Submit"
    OnClick="submitText" />
</td></tr>

<tr><td class="samplenote">
Safety feature (cross-site scripting prevention):
</td><td class="sampleaction">
<com:TTextBox
    ID="TextBox2"
    AutoPostBack="true"
    Text="<a href=javascript:xxx>test</a>"
    Width="200px"/>
<b>SafeText:</b>
<com:TLabel ID="Output"
    BackColor="silver"
    Text=<%#$this->TextBox2->SafeText%> />
</td></tr>

</table>

<h2>Password Text Boxes</h2>

<table class="sampletable">

<tr><td class="samplenote">
Password with default setting
</td>
<td class="sampleaction">
<com:TTextBox TextMode="Password" /> <com:TButton ID="PassButton1" Text="submit" />
</td></tr>

<tr><td class="samplenote">
Password with PersistPasswor set true
</td>
<td class="sampleaction">
<com:TTextBox ID="Password2" TextMode="Password" PersistPassword="true" />
<com:TButton ID="PassButton2" Text="submit" />
</td></tr>
</table>

<h2>MultiLine Text Boxes</h2>

<table class="sampletable">

<tr><td class="samplenote">
Text box with default settings:
</td><td class="sampleaction">
<com:TTextBox TextMode="MultiLine" />
</td></tr>

<tr><td class="samplenote">
Text box with customized dimensions, font and content:
</td><td class="sampleaction">
<com:TTextBox TextMode="MultiLine" Rows="6" Columns="60" Font.Italic="true">
  <prop:Text>
This is a multiline text box.
In HTML, it is displayed as a textarea.
  </prop:Text>
</com:TTextBox>
</td></tr>

<tr><td class="samplenote">
Disabled text box:
</td><td class="sampleaction">
<com:TTextBox
    TextMode="MultiLine"
    Text="disabled"
    Enabled="false" />
</td></tr>

<tr><td class="samplenote">
Read-only text box with text-wrapping disabled:
</td><td class="sampleaction">
<com:TTextBox
    TextMode="MultiLine"
    Text="This is a read-only text box with text-wrapping disabled."
    ReadOnly="true"
    Wrap="false"/>
</td></tr>

<tr><td class="samplenote">
Auto postback text box not causing validation:
</td><td class="sampleaction">
<com:TTextBox
    TextMode="MultiLine"
    Text="change me"
    AutoPostBack="true"
    CausesValidation="false"
    OnTextChanged="textChanged" />
</td></tr>

<tr><td class="samplenote">
Auto postback text box causing validation:
</td><td class="sampleaction">
<com:TTextBox ID="MultiTextBox3"
    TextMode="MultiLine"
    AutoPostBack="true"
    ValidationGroup="Group2"
    Text="change me to 'demo' and see" />
<com:TRequiredFieldValidator
    ControlToValidate="MultiTextBox3"
    ErrorMessage="You must enter a value not equal to 'demo'."
    InitialValue="demo"
    ValidationGroup="Group2" />
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TTextBox/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        $this->Output->dataBind();
    }

    public function textChanged($sender,$param)
    {
        $sender->Text="text changed";
    }

    public function submitText($sender,$param)
    {
        $this->TextBox1->Text="You just entered '".$this->TextBox1->Text."'.";
    }
}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TTextHighlighter/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<com:TContent ID="body">

<h1>TTextHighlighter Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Highlighting PHP statements:
</td><td class="sampleaction">
<com:TTextHighlighter ShowLineNumbers="true" EnableCopyCode="true">
<?php
$str = 'one|two|three|four';
// will output an array
print_r(explode('|', $str, 2));
?>
</com:TTextHighlighter>
</td></tr>

<tr><td class="samplenote">
Highlighting control rendering results:
</td><td class="sampleaction">
<com:TTextHighlighter EnableCopyCode="false">
<com:TLabel Text="this is a label" />
</com:TTextHighlighter>
</td></tr>

</table>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TValidationSummary/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84

<com:TContent ID="body">

<h1>TValidationSummary Samples</h1>

<fieldset id="quickRegistration">
    <legend>Create New Account</legend>

<div class="username">
    Username:
    <com:TTextBox ID="Username" />
    <com:TRequiredFieldValidator
        ID="UsernameVal"
        ControlToValidate="Username"
        ValidationGroup="Group1"
        Text="*"
        ErrorMessage="a username is required." />
</div>
<div class="password">
    Password
    <com:TTextBox ID="Password" TextMode="Password" />
    <com:TRequiredFieldValidator
        ID="PasswordVal"
        ControlToValidate="Password"
        ValidationGroup="Group1"
        Text="*"
        ErrorMessage="a password is required." />
</div>

<div class="create">
    <com:TButton ID="Create" ValidationGroup="Group1" Text="Create New Account"/>
</div>

<div class="registrationSummary">
    <com:TValidationSummary
        ValidationGroup="Group1"
        Display="None"
        HeaderText="Unable to create new account because" />
</div>

</fieldset>

<fieldset id="LoginForm">
    <legend>Sign In</legend>

<div class="username">
    Login Name:
    <com:TTextBox ID="UserID" />

    <com:TRequiredFieldValidator
        ID="UserVal1"
        ControlToValidate="UserID"
        Display="None"
        ValidationGroup="Group2"
        ErrorMessage="the username or email was not provided" />
</div>

<div class="password" >
    Password:
    <com:TTextBox ID="Pass" TextMode="Password" />
    <com:TRequiredFieldValidator
        ID="loginValidator3"
        ControlToValidate="Pass"
        Display="None"
        ValidationGroup="Group2"
        ErrorMessage="the password was not provided" />
</div>

<com:TButton ID="login" ValidationGroup="Group2" CssClass="button" Text="Sign In" />

<div class="validation">
    <com:TValidationSummary
        ValidationGroup="Group2"
        AutoUpdate="false"
        Display="None"
        ShowMessageBox="true"
        HeaderText="You could not login because" />
</div>

</fieldset>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TValidationSummary/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample1.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39

<com:TContent ID="body">

<h2>A Single-Step Wizard</h2>

<com:TWizard ID="Wizard1"
        BackColor="#FFFBD6"
        Width="400px"
        SideBarStyle.Width="120px"
        HeaderText="Please let us know your preference"
        OnCompleteButtonClick="wizardCompleted" >

  <com:TWizardStep Title="Step 1">
    <h3>Wizard Step 1</h3>
    <p>
    Your favorite color:
    <com:TDropDownList ID="DropDownList1">
      <com:TListItem Value="Red" />
      <com:TListItem Value="Blue" />
      <com:TListItem Value="Green" />
      <com:TListItem Value="Purple" />
      <com:TListItem Value="Black" />
      <com:TListItem Value="Yellow" />
      <com:TListItem Value="Orange" />
      <com:TListItem Value="Pink" />
      <com:TListItem Value="Cyan" />
    </com:TDropDownList>
    </p>
  </com:TWizardStep>

  <com:TWizardStep Title="Step 2" StepType="Complete">
    <h3>Wizard Step 2</h3>
    <p>
    <com:TLabel ID="Result" />
    </p>
  </com:TWizardStep>

</com:TWizard>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample1.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Sample1 extends TPage
{
    public function wizardCompleted($sender,$param)
    {
        $this->Result->Text="Your favorite color is: " . $this->DropDownList1->SelectedValue;
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample2.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64

<com:TContent ID="body">

<h2>Wizard with Customized Styles</h2>

<com:TWizard ID="Wizard1"
        Width="400px"
        Height="100px"
        BackColor="#EFF3FB"
        BorderColor="#B5C7DE"
        BorderWidth="1px"
        BorderStyle="Solid"
        HeaderText="Please let us know your preference"
        StepStyle.HorizontalAlign="Center"
        NavigationStyle.HorizontalAlign="Center"
        SideBarButtonStyle.ForeColor="White"
        OnCompleteButtonClick="wizardCompleted" >

  <prop:SideBarStyle
        Width="100px"
        Height="100px"
        BackColor="#507CD1"
        HorizontalAlign="Center"
        />
  <prop:NavigationButtonStyle
        BackColor="White"
        BorderColor="#507CD1"
        BorderStyle="Solid"
        BorderWidth="1px"
        ForeColor="#284E98"
        />
  <prop:HeaderStyle
        BackColor="#284E98"
        Font.Bold="True"
        ForeColor="White"
        HorizontalAlign="Center"
        />

  <com:TWizardStep Title="Step 1">
    <p>
    Your favorite color:
    <com:TDropDownList ID="DropDownList1">
      <com:TListItem Value="Red" />
      <com:TListItem Value="Blue" />
      <com:TListItem Value="Green" />
      <com:TListItem Value="Purple" />
      <com:TListItem Value="Black" />
      <com:TListItem Value="Yellow" />
      <com:TListItem Value="Orange" />
      <com:TListItem Value="Pink" />
      <com:TListItem Value="Cyan" />
    </com:TDropDownList>
    </p>
  </com:TWizardStep>

  <com:TWizardStep Title="Step 2" StepType="Complete">
    <h3>Thank you for your answer!</h3>
    <p>
    <com:TLabel ID="Result" />
    </p>
  </com:TWizardStep>

</com:TWizard>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample2.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Sample2 extends TPage
{
    public function wizardCompleted($sender,$param)
    {
        $this->Result->Text="Your favorite color is: " . $this->DropDownList1->SelectedValue;
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample3.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61

<com:TContent ID="body">

<h2>Nonlinear Wizard Navigation Sample</h2>

<p>
In the following survey, if you are a college student, you will be asked which major you are in. Otherwise, the question is skipped to your favorite sport. This demo also shows unidrectional navigation.
</p>

<com:TWizard ID="Wizard3"
        BackColor="#FFFBD6"
        Width="300px"
        HeaderText="A Mini Survey"
        ShowSideBar="false"
        HeaderStyle.BackColor="PaleGoldenrod"
        HeaderStyle.HorizontalAlign="Center"
        NavigationStyle.HorizontalAlign="Center"
        OnNextButtonClick="wizard3NextStep"
        OnCompleteButtonClick="wizard3Completed" >

  <com:TWizardStep Title="Background" AllowReturn="false">
    <b><%= $this->Title %></b>
    <br/><br/>
    <com:TCheckBox ID="StudentCheckBox" Text="I am a college student." />
    <br/><br/>
  </com:TWizardStep>

  <com:TWizardStep Title="Major" AllowReturn="false">
    <b><%= $this->Title %></b>
    <br/><br/>
    My major is
      <com:TDropDownList ID="DropDownList11">
        <com:TListItem Value="Computer Science" />
        <com:TListItem Value="Chemistry" />
        <com:TListItem Value="Mathematics" />
        <com:TListItem Value="Others" />
      </com:TDropDownList>
    <br/><br/>
  </com:TWizardStep>

  <com:TWizardStep Title="Hobbies" AllowReturn="false">
    <b><%= $this->Title %></b>
    <br/><br/>
    My favorite Sport is
      <com:TDropDownList ID="DropDownList22">
        <com:TListItem Value="Baseball" />
        <com:TListItem Value="Football" />
        <com:TListItem Value="Tennis" />
      </com:TDropDownList>
    <br/><br/>
  </com:TWizardStep>

  <com:TWizardStep Title="Summary" StepType="Complete">
    <h3>Thank you for taking this survey!</h3>
    <p>
    <com:TLabel ID="Wizard3Result" />
    </p>
  </com:TWizardStep>

</com:TWizard>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample3.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25

<?php

class Sample3 extends TPage
{
    public function wizard3Completed($sender,$param)
    {
        if($this->StudentCheckBox->Checked)
        {
            $str="You are a college student.<br/>";
            $str.="You are in major: ".$this->DropDownList11->SelectedValue."<br/>";
            $str.="Your favorite sport is: ".$this->DropDownList22->SelectedValue;
        }
        else
            $str="Your favorite sport is: ".$this->DropDownList22->SelectedValue;
        $this->Wizard3Result->Text=$str;
    }

    public function wizard3NextStep($sender,$param)
    {
        if($param->CurrentStepIndex===0 && !$this->StudentCheckBox->Checked)
            $this->Wizard3->ActiveStepIndex=2;
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample4.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85

<com:TContent ID="body">

<h2>Customized Wizard Template Sample</h2>

<com:TWizard ID="Wizard1"
        BackColor="OldLace"
        Width="400px"
        SideBarStyle.Width="120px"
        StepStyle.BackColor="#FFFBD6"
        HeaderStyle.BackColor="Moccasin"
        NavigationStyle.BackColor="PaleGoldenrod"
        OnActiveStepChanged="wizardCompleted" >

        <prop:HeaderTemplate>
        <i>Header Template</i>
        <br/>
        <b>Step <%= $this->Parent->ActiveStepIndex+1 %> of 3</b>
        </prop:HeaderTemplate>

        <prop:SideBarTemplate>
        <i>SideBar Template</i>
        <br/>
        <com:TDataList ID="SideBarList">
                <prop:ItemTemplate>
                <com:TButton ID="SideBarButton" />
                </prop:ItemTemplate>
                <prop:SelectedItemTemplate>
                <com:TButton ID="SideBarButton" Font.Bold="true" />
                </prop:SelectedItemTemplate>
        </com:TDataList>
        </prop:SideBarTemplate>

        <prop:StartNavigationTemplate>
        <com:TLinkButton CommandName="NextStep" Text="Next &gt;" />
        <br/>
        <i>Start Navigation Template</i>
        </prop:StartNavigationTemplate>

        <prop:StepNavigationTemplate>
        <com:TLinkButton CausesValidation="False" CommandName="PreviousStep" Text="&lt; Previous" />
        <com:TLinkButton CommandName="NextStep" Text="Next &gt;" />
        <br/>
        <i>Step Navigation Template</i>
        </prop:StepNavigationTemplate>

        <prop:FinishNavigationTemplate>
        All navigation buttons are removed.
        <br/>
        <i>Step Navigation Template</i>
        </prop:FinishNavigationTemplate>

    <com:TWizardStep ID="WizardStep1" Title="Step 1">
    <i>Wizard Step Content</i>
    <br/><br/>
    Your favorite color:
    <com:TDropDownList ID="DropDownList1">
    <com:TListItem Value="Red" />
    <com:TListItem Value="Blue" />
    <com:TListItem Value="Green" />
    <com:TListItem Value="Purple" />
    <com:TListItem Value="Black" />
    <com:TListItem Value="Yellow" />
    <com:TListItem Value="Orange" />
    <com:TListItem Value="Pink" />
    <com:TListItem Value="Cyan" />
    </com:TDropDownList>
    <br/><br/>
    </com:TWizardStep>

    <com:TWizardStep ID="WizardStep2" Title="Step 2">
    <i>Wizard Step Content</i>
    <br/><br/>
    <com:TLabel ID="Result" />
    <br/><br/>
    </com:TWizardStep>

    <com:TWizardStep ID="WizardStep3" Title="Step 3">
    <i>Wizard Step Content</i>
    <br/><br/>
    Thank you for completing this survey.<br />
    <br/><br/>
    </com:TWizardStep>
</com:TWizard>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample4.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Sample4 extends TPage
{
    public function wizardCompleted($sender,$param)
    {
        $this->Result->Text="Your favorite color is: " . $this->DropDownList1->SelectedValue;
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample5.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51

<com:TContent ID="body">

<h2>Using Templated Wizard Steps</h2>

<com:TWizard ID="Wizard1"
        BackColor="#FFFBD6"
        Width="400px"
        SideBarStyle.Width="120px"
        HeaderText="Please let us know your preference"
        OnCompleteButtonClick="wizardCompleted" >

  <com:TWizardStep Title="Step 1">
    <p>
    Your favorite color:
    <com:TDropDownList ID="DropDownList1">
      <com:TListItem Value="Red" />
      <com:TListItem Value="Blue" />
      <com:TListItem Value="Green" />
      <com:TListItem Value="Purple" />
      <com:TListItem Value="Black" />
      <com:TListItem Value="Yellow" />
      <com:TListItem Value="Orange" />
      <com:TListItem Value="Pink" />
      <com:TListItem Value="Cyan" />
    </com:TDropDownList>
    </p>
  </com:TWizardStep>

  <com:TTemplatedWizardStep ID="Step2" Title="Templated Step">
    <prop:ContentTemplate>
      <p>
      Your favorite Sport:
      <com:TDropDownList ID="DropDownList2">
        <com:TListItem Value="Baseball" />
        <com:TListItem Value="Football" />
        <com:TListItem Value="Tennis" />
      </com:TDropDownList>
      </p>
    </prop:ContentTemplate>
  </com:TTemplatedWizardStep>

  <com:TWizardStep Title="Complete" StepType="Complete">
    <h3>Thank you for your answer!</h3>
    <p>
    <com:TLabel ID="Result1" /><br/><br/>
    <com:TLabel ID="Result2" />
    </p>
  </com:TWizardStep>
</com:TWizard>

</com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample5.php

1
2
3
4
5
6
7
8
9
10
11
12

<?php

class Sample5 extends TPage
{
    public function wizardCompleted($sender,$param)
    {
        $this->Result1->Text="Your favorite color is: " . $this->DropDownList1->SelectedValue;
        $this->Result2->Text="Your favorite sport is: " . $this->Step2->DropDownList2->SelectedValue;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Fundamentals/Samples/Hangman/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70

<%@ Title="Hangman Game" %>
<com:TContent ID="body">

<h1>Hangman Game</h1>

<com:TMultiView ID="GameMultiView">

<com:TView ID="IntroView">
<p>This is the game of Hangman. You must guess a word, a letter at a time.
If you make too many mistakes, you lose the game!</p>
<com:TRadioButtonList ID="LevelSelection">
  <com:TListItem Value="10" Text="Easy game; you are allowed 10 misses."/>
  <com:TListItem Value="5" Text="Medium game; you are allowed 5 misses."/>
  <com:TListItem Value="3" Text="Hard game; you are allowed 3 misses."/>
</com:TRadioButtonList>
<com:TButton Text="Play!" OnClick="selectLevel" />
<com:TLabel ID="LevelError" Text="You must choose a difficulty level!" ForeColor="red" Visible="false" />
</com:TView>

<com:TView ID="GuessView">
<h2>Please make a guess</h2>
<h3 style="letter-spacing: 4px;"><%= $this->Page->GuessWord %></h3>
<p>You have made <%=$this->Page->Misses %> bad guesses
out of a maximum of <%= $this->Page->Level %>.</p>
<p>Guess:
<com:TLinkButton ID="GuessA" Text="A" OnClick="guessWord" />
<com:TLinkButton ID="GuessB" Text="B" OnClick="guessWord" />
<com:TLinkButton ID="GuessC" Text="C" OnClick="guessWord" />
<com:TLinkButton ID="GuessD" Text="D" OnClick="guessWord" />
<com:TLinkButton ID="GuessE" Text="E" OnClick="guessWord" />
<com:TLinkButton ID="GuessF" Text="F" OnClick="guessWord" />
<com:TLinkButton ID="GuessG" Text="G" OnClick="guessWord" />
<com:TLinkButton ID="GuessH" Text="H" OnClick="guessWord" />
<com:TLinkButton ID="GuessI" Text="I" OnClick="guessWord" />
<com:TLinkButton ID="GuessJ" Text="J" OnClick="guessWord" />
<com:TLinkButton ID="GuessK" Text="K" OnClick="guessWord" />
<com:TLinkButton ID="GuessL" Text="L" OnClick="guessWord" />
<com:TLinkButton ID="GuessM" Text="M" OnClick="guessWord" />
<com:TLinkButton ID="GuessN" Text="N" OnClick="guessWord" />
<com:TLinkButton ID="GuessO" Text="O" OnClick="guessWord" />
<com:TLinkButton ID="GuessP" Text="P" OnClick="guessWord" />
<com:TLinkButton ID="GuessQ" Text="Q" OnClick="guessWord" />
<com:TLinkButton ID="GuessR" Text="R" OnClick="guessWord" />
<com:TLinkButton ID="GuessS" Text="S" OnClick="guessWord" />
<com:TLinkButton ID="GuessT" Text="T" OnClick="guessWord" />
<com:TLinkButton ID="GuessU" Text="U" OnClick="guessWord" />
<com:TLinkButton ID="GuessV" Text="V" OnClick="guessWord" />
<com:TLinkButton ID="GuessW" Text="W" OnClick="guessWord" />
<com:TLinkButton ID="GuessX" Text="X" OnClick="guessWord" />
<com:TLinkButton ID="GuessY" Text="Y" OnClick="guessWord" />
<com:TLinkButton ID="GuessZ" Text="Z" OnClick="guessWord" />
</p>
<p><com:TLinkButton Text="Give up?" OnClick="giveUp" /></p>
</com:TView>

<com:TView ID="WinView">
<h2>You Win!</h2>
<p>The word was: <%= $this->Page->Word %>.</p>
<p><com:TLinkButton Text="Start Again" OnClick="startAgain" /></p>
</com:TView>

<com:TView ID="LoseView">
<h2>You Lose!</h2>
<p>The word was: <%= $this->Page->Word %>.</p>
<p><com:TLinkButton Text="Start Again" OnClick="startAgain" /></p>
</com:TView>

</com:TMultiView>

</com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Fundamentals/Samples/Hangman/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121

<?php
class Home extends TPage
{
    public function onLoad($param)
    {
        if (!$this->IsPostBack)
            $this->GameMultiView->ActiveView=$this->IntroView;
    }

    public function selectLevel($sender,$param)
    {
        if(($selection=$this->LevelSelection->SelectedValue)==='')
        {
            $this->LevelError->Visible=true;
            return;
        }
        else
            $this->Level=TPropertyValue::ensureInteger($selection);
        $this->Word=$this->generateWord();
        $this->GuessWord=str_repeat('_',strlen($this->Word));
        $this->Misses=0;
        $this->GameMultiView->ActiveView=$this->GuessView;
    }

    public function guessWord($sender,$param)
    {
        $sender->Enabled=false;
        $letter=$sender->Text;
        $word=$this->Word;
        $guessWord=$this->GuessWord;
        $pos=0;
        $success=false;
        while(($pos=strpos($word,$letter,$pos))!==false)
        {
            $guessWord[$pos]=$letter;
            $success=true;
            $pos++;
        }
        if($success)
        {
            $this->GuessWord=$guessWord;
            if($guessWord===$word)
                $this->GameMultiView->ActiveView=$this->WinView;
        }
        else
        {
            $this->Misses++;
            if($this->Misses>=$this->Level)
                $this->giveUp(null,null);
        }
    }

    public function giveUp($sender,$param)
    {
        $this->GameMultiView->ActiveView=$this->LoseView;
    }

    public function startAgain($sender,$param)
    {
        $this->GameMultiView->ActiveView=$this->IntroView;
        $this->LevelError->Visible=false;
        for($letter=65;$letter<=90;++$letter)
        {
            $guessLetter='Guess'.chr($letter);
            $this->$guessLetter->Enabled=true;
        }
    }

    protected function generateWord()
    {
        $wordFile=dirname(__FILE__).'/words.txt';
        $words=preg_split("/[\s,]+/",file_get_contents($wordFile));
        do
        {
            $i=rand(0,count($words)-1);
            $word=$words[$i];
        } while(strlen($word)<5 || !preg_match('/^[a-z]*$/i',$word));
        return strtoupper($word);
    }

    public function setLevel($value)
    {
        $this->setViewState('Level',$value,0);
    }

    public function getLevel()
    {
        return $this->getViewState('Level',0);
    }

    public function setWord($value)
    {
        $this->setViewState('Word',$value,'');
    }

    public function getWord()
    {
        return $this->getViewState('Word','');
    }

    public function getGuessWord()
    {
        return $this->getViewState('GuessWord','');
    }

    public function setGuessWord($value)
    {
        $this->setViewState('GuessWord',$value,'');
    }

    public function setMisses($value)
    {
        $this->setViewState('Misses',$value,0);
    }

    public function getMisses()
    {
        return $this->getViewState('Misses',0);
    }
}
?>


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveButton

API Manual

TActiveButton is the active control counter part to TButton. When a TActiveButton is clicked, rather than a normal post back request a callback request is initiated. The OnCallback event is raised during a callback request and it is raise after the OnClick event.

When the ActiveControl.EnableUpdate property is true, changing the Text property during a callback request will update the button's caption on the client-side.

Since the OnCallback event is raised only during a callback request, the OnCallback event handler can be used to handle logic specifically related to callback requests. The OnClick event handler is raised when ever the button is clicked, even if javascript is disabled.

The following example the use of both the OnClick and OnCallback events of an TActiveButton.

Run Sample View Source

TActiveButton Class Diagram

The class diagram for TActiveButton is illustrated in the figure below. Most active control that can perform callback request have a similar structure.

TActiveButton class diagram

TActiveButton is an extension of TButton and implements two additional interfaces ICallbackEventHandler and IActiveControl. The TActiveButton contains an instance of TBaseActiveCallbackControl available through the ActiveControl property of TActiveButton. The following example set the callback parameter of the TActiveButton when a callback request is dispatched.

<com:TActiveButton
    Text="Click Me"
    OnCallback="button_callback"
    ActiveControl.CallbackParameter="value" />

In the OnCallback event handler method, the CallbackParameter is available in the $param object.

public function button_callback($sender, $param)
{
    echo $param->CallbackParameter; //outputs "value"
}

Adding Client Side Behaviour

With in the ActiveControl property is an instance of TCallbackClientSide available as a property ClientSide of TActiveButton. The ClientSide property contains sub-properties, such as RequestTimeOut, and client-side javascript event handler, such as OnLoading, that are used by the client-side when making a callback request. The following example demonstrates the toggling of a "loading" indicator when the client-side is making a callback request.

<com:TClientScript PradoScripts="effects" />
<span id="callback_status">Loading...</span>

<com:TActiveButton
    Text="Click Me"
    OnCallback="button_callback"
    ActiveControl.CallbackParameter="value" >
    <prop:ClientSide
        OnLoading="Element.show('callback_status')"
        OnComplete="Element.hide('callback_status')" />
</com:TActiveButton>

The example loads the "effects" javascript library using the TClientScript component. The ClientSide.OnLoading property value contains javascript statement that uses the "effects" library to show the "Loading..." span tag. Similarly, ClientSide.OnComplete property value contains the javascript statement that hides the "Loading..." span tag. See TCallbackClientSide for further details on client-side property details.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveCheckBox

API Manual

TActiveCheckBox is the active control counter part to TCheckbox. The AutoPostBack property of TActiveCheckBox is set to true by default. Thus, when the checkbox is clicked the OnCallback event is raise after the OnCheckedChanged event.

The Text and Checked properties of TActiveCheckBox can be changed during a callback request. The TextAlign property of TActiveCheckBox can not be changed during a callback request.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveCheckBoxList

API Manual

TActiveCheckBoxList is the active counterpart to the original TCheckBoxList control.

The AutoPostBack property is set to true by default. Thus, when a checkbox is clicked a OnCallback event is raised after OnSelectedIndexChanged event.

With ActiveControl.EnabledUpdate set to true (default is true), changes to the selection will be updated on the client side.

List items can not be changed dynamically during a callback request.

Please refer to the original documentation of TCheckBoxList for usage.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveCustomValidator

API Manual

Performs custom validation using only server-side OnServerValidate validation event. The client-side uses callbacks to raise onServerValidate event. The ClientValidationFunction property is disabled and will throw an exception if trying to set this property.

Beware that the onServerValidate may be raised when the control to validate on the client side changes value, that is, the server validation may be called many times. After the callback or postback, the {@link onServerValidate onServerValidate} is raised once more. The IsCallback property of the TPage class will be true when validation is made during a callback request.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveDataGrid

API Manual

TActiveDataGrid represents a data bound and updatable grid control which is the active counterpart to the original TDataGrid control.

This component can be used in the same way as the regular datagrid, the only difference is that the active datagrid uses callbacks instead of postbacks for interaction.

PRADO provides eight new types of active columns that can be used inside TActiveDataGrid; they are the active counterpart of TDataGrid's columns:

  • TActiveBoundColumn associates cells with a specific field of data and displays the cells according to their modes.
  • TActiveLiteralColumn associates cells with a specific field of data and displays the cells with static texts.
  • TActiveCheckBoxColumn associates cells with a specific field of data and displays in each cell a checkbox whose check state is determined by the data field value.
  • TActiveDropDownListColumn associates cells with a specific field of data and displays the cells according to their modes. If in edit mode, a cell will be displayed with a TDropDownList.
  • TActiveHyperLinkColumn displays in the cells a hyperlink whose caption and URL can be either statically specified or bound to some fields of data.
  • TActiveEditCommandColumn displays in the cells edit/update/cancel command buttons according to the state of the item that a cell resides in.
  • TActiveButtonColumn displays in the cells a command button.
  • TActiveTemplateColumn displays the cells according to different templates defined for it.

Please refer to the original documentation of TDataGrid for basic usage.

Columns

Automatically Generated Columns

TDataGrid by default will create a list of columns based on the structure of the bound data. TDataGrid will read the first row of the data, extract the field names of the row, and construct a column for each field. Each column is of type TActiveBoundColumn. All of this happens in an ajax callback.

Run Sample View Source

Manually Specified Columns

The following example uses manually specified columns to show a list of book information,

  • Book title - displayed as a hyperlink pointing to the corresponding amazon.com book page. TActiveHyperLinkColumn is used.
  • Publisher - displayed as a piece of text using TvBoundColumn.
  • Price - displayed as a piece of text using TActiveBoundColumn with output formatting string and customized styles.
  • In-stock or not - displayed as a checkbox using TActiveCheckBoxColumn.
  • Rating - displayed as an image using TActiveTemplateColumn which allows maximum freedom in specifying cell contents.

Each column can be shown or hidden in a callback.

Run Sample View Source

Interacting with TActiveDataGrid

The following example shows how to make the previous book information table an interactive one. It allows users to edit and delete book items from the table. Two additional columns are used in the example to allow users interact with the datagrid: TActiveEditCommandColumn and TActiveButtonColumn. In addition, TActiveDropDownListColumn replaces the previous TActiveTemplateColumn to allow users to select a rating from a dropdown list. Note, it is also possible to use TActiveTemplateColumn to achieve the same task. All the iteration is done using AJAX callbacks.

Run Sample View Source

Sorting

The following example turns the datagrid in Example 2 into a sortable one. Users can click on the link button displayed in the header of any column, and the data will be sorted in ascending order along that column. The grid is sorted and rendered upon a callback request.

Run Sample View Source

Paging

The following example enables the paging functionality of the datagrid shown in Example 1. In this example, you move between the datagrid pages clicking on the pager links. The grid reacts to paging rendering itself as the result of a callback request. Note that you can't change the pager style upon callback.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveDataList

API Manual

TActiveDataList represents a data bound and updatable list control which is the active counterpart to the original TDataList control.

This component can be used in the same way as the regular datalist, the only difference is that the active datalist uses callbacks instead of postbacks for interaction.

Please refer to the original documentation of TDataList for usage.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveDatePicker

API Manual

TActiveDatePicker is the active control counter part to TDatePicker control. When the date selection is changed, the OnCallback event is raised.

Please refer to the documentation of TDatePicker for further usage informations.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveDropDownList

API Manual

TActiveDropDownList is the active counterpart to the original TDropDownList control.

The AutoPostBack property is set to true by default. Thus, when the drop down list selection is changed the OnCallback event is raised after OnSelectedIndexChanged event.

With ActiveControl.EnabledUpdate set to true (default is true), changes to the selection, after OnLoad event has been raised, will be updated on the client side.

List items can be changed dynamically during a callback request.

Please refer to the original documentation of TDropDownList for usage.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveFileUpload

API Manual

TActiveFileUpload displays a file upload field on a page. Upon postback, the text entered into the field will be treated as the name of the file that will be uploaded to the server. The property HasFile indicates whether the file upload is successful. If successful, the file may be obtained by callingsaveAs to save it at a specified place. You can use FileName, FileType, FileSize to get the original client-side file name, the file mime type, and the file size information. If the upload is not successful, ErrorCode contains the error code describing the cause of failure.

TActiveFileUpload raises OnFileUpload event if a file is uploaded (whether it succeeds or not).

TActiveFileUpload actually does a postback in a hidden IFrame, and then does a callback. This callback then raises the OnFileUpload event. After the postback a status icon is displayed; either a green checkmark if the upload is successful, or a red x if there was an error.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveHiddenField

API Manual

TActiveHiddenField is the active control counterpart of THiddenField component. It displays a hidden input field on a Web page. The value of the input field can be accessed and changed on callback via the Value property.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveHyperLink

API Manual

The active control counterpart of THyperLink component. During a callback request, changes to the Text, ImageUrl, NavigateUrl and Target properties on the server side will also change the corresponding attributes and content on the client-side.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveImage

API Manual

TActiveImage is the active control counter part to TImage. TActiveImage displays an image on a page. The image is specified via the ImageUrl property which takes a relative or absolute URL to the image file. The alignment of the image displayed is set by the ImageAlign property. To set alternate text or long description of the image, use AlternateText or DescriptionUrl, respectively.

TActiveImage allows the AlternateText, ImageAlign, ImageUrl and DescriptionUrl to be updated during a callback request.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveImageButton

API Manual

TActiveImageButton is the active counterpart of TImageButton. When a TActiveImageButton is clicked, rather than a normal post back request a callback request is initiated. TheOnCallback event is raised during a callback request and it is raised after the OnClick event.

TActiveImageButton is similar to TActiveButton, except that TActiveImageButton displays the button as an image. The image is specified via ImageUrl, and the alternate text is specified by Text. In addition, it is possible to obtain the coordinate of the point where the image is clicked. The coordinate information is contained in the event parameter of the OnClick event (not OnCallback).

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveLabel

API Manual

TActiveLabel is the active control counterpart of TLabel component. When ActiveControl.EnableUpdate property is true during a callback request, setting Text property will also set the text of the label on the client upon callback completion. Similarly, setting ForControl will also set the client-side "for" attribute on the label.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveLinkButton

API Manual

TActiveLinkButton is the active control counter part to TLinkButton. When a TActiveLinkButton is clicked, rather than a normal post back request a callback request is initiated. The OnCallback event is raised during a callback request and it is raise after the OnClick event. When the ActiveControl.EnableUpdate property is true, changing the Text property during callback request will update the link text upon callback response completion.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveListBox

API Manual

TActiveListBox is the active counterpart to the original TListBox control.

The AutoPostBack property is set to true by default. Thus, when a list item is clicked a OnCallback event is raised after OnSelectedIndexChanged event.

With ActiveControl.EnabledUpdate set to true (default is true), changes to the selection will be updated on the client side.

Please refer to the original documentation of TListBox for usage.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveMultiView

API Manual

TActiveMultiView is the active counterpart to the original TMultiView control. TActiveMultiView serves as a container for a group of TView controls, which can be retrieved by the Views property. Each view contains child controls. TActiveMultiView determines which view and its child controls are visible. At any time, at most one view is visible (called active). To make a view active, set ActiveView or ActiveViewIndex. Note, by default there is no active view. TActiveMultiView is able to render itself on Callback when ActiveView or ActiveViewIndex properties are changed.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActivePager

API Manual

TActivePager creates a pager that provides UI for end-users to interactively specify which page of data to be rendered in a TDataBoundControl-derived control, such as TDataList, TRepeater, TCheckBoxList, etc. The target data-bound control is specified by the ControlToPaginate property, which must be the ID path of the target control reaching from the pager's naming container. The target-databound must be enclosed inside a TActivePanel in order to be re-rendered during callback

Note, the target data-bound control must have its AllowPaging set to true. Otherwise the pager will be invisible. Also, in case when there is only one page of data available, the pager will also be invisible.

TActivePager can display one of the following three types of user interface, specified via its Mode property:

  • NextPrev - a next page and a previous page button are rendered on each page.
  • Numeric - a list of page index buttons are rendered.
  • DropDownList - a dropdown list of page indices is rendered.

These user interfaces may be further customized by configuring the following properties

  • NextPageText and PrevPageText - the label of the next/previous page button. These properties are used when the pager Mode is NextPrev or Numeric.
  • FirstPageText and LastPageText - the label of the first/last page button. If empty, the corresponding button will not be displayed. These properties are used when the pager Mode is NextPrev or Numeric.
  • PageButtonCount - the maximum number of page index buttons on a page. This property is used when the pager Mode is Numeric.
  • ButtonType - type of page buttons, either PushButton meaning normal form submission buttons, or LinkButton meaning hyperlink buttons.

TActivePager raises an OnPageIndexChanged event when an end-user interacts with it and specifies a new page (e.g. by clicking on a next page button that would lead to the next page.) Developers may write handlers to respond to this event and obtain the desired new page index from the event parameter's property NewPageIndex. Using this new page index, one can feed a new page of data to the associated data-bound control. Additionnaly, TActivePager raises OnCallback after the OnPageIndexChanged.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActivePanel

API Manual

TActivePanel is the TPanel active control counterpart. TActivePanel allows the client-side panel contents to be updated during a callback response using the render method. Example: Assume $param is an instance of TCallbackEventParameter attached to the OnCallback event of a TCallback with ID "callback1", and "panel1" is the ID of a TActivePanel.

function callback1_requested($sender, $param)
{
       $this->panel1->render($param->getNewWriter());
}
Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TRadioButton

API Manual

TActiveRadioButton is the active control counter part to TRadioButton. The AutoPostBack property is set to true by default. Thus, when the radio button is clicked a OnCallback event is raise after OnCheckedChanged event.

The Text and Checked properties can be changed during a callback. The GroupName property may NOT be changed during callback because the client-side name attribute is read-only and can not be changed using javascript.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveRadioButtonList

API Manual

TActiveRadioButtonList is the active counterpart to the original TRadioButtonList control.

The AutoPostBack property is set to true by default. Thus, when a radio button is clicked a OnCallback event is raised after OnSelectedIndexChanged event.

With ActiveControl.EnabledUpdate set to true (default is true), changes to the selection will be updated on the client side.

List items can not be changed dynamically during a callback request.

Please refer to the original documentation of TRadioButtonList for usage.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveRepeater

API Manual

TActiveRepeater represents a data bound and updatable repeater control which is the active counterpart to the original TRepeater control.

This component can be used in the same way as the regular repeater, the only difference is that the active repeater uses callbacks instead of postbacks for interaction.

Please refer to the original documentation of TRepeater for usage.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveTextBox

API Manual

TActiveTextBox is the active control counterpart of TTextBox component. TActiveTextBox allows the Text property of the textbox to be changed during callback. When AutoPostBack property is true, changes to the textbox contents will perform a callback request causing OnTextChanged to be fired first followed by OnCallback event.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TAutoComplete

API Manual

TAutoComplete is an extended ActiveTextBox that provides a list of suggestions on the current partial word typed in the textbox. The suggestions are requested using callbacks. The Frequency and MinChars properties sets the delay and minimum number of characters typed, respectively, before requesting for sugggestions. An embedded TRepeater is used to Display the list of suggestions. It can be accessed and styled through the Suggestions property and its sub-properties.

On each request for suggestions, the OnSuggestion event will be raised. The event handler receives the entered token that can be used to build the list of suggestions and to dataBind() it to the Suggestions repeater.

When a suggestion is selected the OnSuggestionSelected event is raised, with the index of the selected suggestion contained in the parameter. Multiple selections can be performed in the same textbox. The selections must be separated by any characters specified with the Separator property.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TCallback

API Manual

TCallback provides a basic callback handler that can be invoked from the client side by using the javascript ojbect obtained from the ActiveControl.Javascript property. You can set the CallbackParameter property from javascript directly on the object returned by ActiveControl.Javascript. Once you are ready, you can call the dispatch() method on the object to execute the callback. The server-side event OnCallback is raised when a callback is requested made.

Example usage:

<com:TCallback ID="callback1" OnCallback="callback1_Requested" />
<script type="text/javascript">
  function do_callback1()
  {
    var request = <%= $this->callback1->ActiveControl->Javascript %>;
    request.dispatch();
  }
</script>
<div onclick="do_callback1()">Click Me!</div>
Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TCallbackClientScript

API Manual

The TCallbackClientScript class provides corresponding methods that can be executed on the client-side (i.e. the browser client that is viewing the page) during a callback response. For a complete list of available client side methods, consult the API Manual

The available methods includes setting/clicking input elements, changing Css styles, hiding/showing elements, and adding visual effects to elements on the page. The client-side methods can be access through the CallbackClient property available in TPage.

For example, to hide "$myTextBox" element during callback response, do:

$this->getPage()->getCallbackClient()->hide($myTextBox);
Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TCallbackClientSide

API Manual

TCallbackClientSide is used to specify client-side callback request options and client-side event handlers. Each active control that inherits from TActiveBaseCallbackControl has a ClientSide property. The ClientSide property is an instance TCallbackClientSide containing the actual options and event handlers that are used by the client-side when that control is making a callback request. The following example demonstrates the toggling of a "loading" indicator when the client-side is making a callback request.

<com:TClientScript PradoScripts="effects" />
<span id="callback_status">Loading...</span>

<com:TActiveButton
    Text="Click Me"
    OnCallback="button_callback"
    ActiveControl.CallbackParameter="value" >
    <prop:ClientSide
        OnLoading="Element.show('callback_status')"
        OnComplete="Element.hide('callback_status')" />
</com:TActiveButton>

Events

The following client side events are executing in order if the callback request and response are send and received successfuly.

  • onPreDispatch: executed before a request is dispatched;
  • onUninitialized: executed when callback request is uninitialized;
  • onLoading* : executed when callback request is initiated;
  • onLoaded* : executed when callback request begins;
  • onInteractive: executed when callback request is in progress;
  • onComplete: executed when callback response returns;
  • onSuccess executed when callback request returns and is successful;
  • onFailure executed when callback request fails (only for communication errors);
  • onException raised when callback request fails due to request/response errors.

* Note that theses 2 events are not fired correctly by Opera. To make them work in this browser, Prado will fire them just after onPreDispatch.

In a general way, onUninitialized, onLoading, onLoaded and onInteractive events are not implemented consistently in all browsers. When cross browser compatibility is needed, it is best to avoid use them.
The OnSuccess and OnFailure events are raised when the response is returned. A successful request/response will raise OnSuccess event otherwise OnFailure will be raised.

Properties

The following properties can be used to change the way the callback request is performed.

  • PostState: true to collect the form inputs and post them during callback (default: true);
  • RequestTimeOut The request timeout in milliseconds (default: 30000, i.e. 30 seconds);
  • HasPriority true to ensure that the callback request will be sent immediately and will abort existing prioritized requests. It does not affect callbacks that are not prioritized (default: true);
  • EnablePageStateUpdate enable the callback response to enable the viewstate update. This will automatically set HasPriority to true when enabled. (default: true).
Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TCallbackEventParameter

API Manual

TCallbackEventParameter provides the parameter passed during the callback request in the CallbackParameter property. The callback response content (e.g. new HTML content) must be rendered using an THtmlWriter obtained from the NewWriter property, which returns a NEW instance of TCallbackResponseWriter.

Each instance TCallbackResponseWriter is associated with a unique boundary delimited. By default each panel only renders its own content. To replace the content of ONE panel with that of rendered from multiple panels use the same writer instance for the panels to be rendered.

The response data (i.e., passing results back to the client-side callback handler function) can be set using ResponseData property.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TCallbackOptions

API Manual

TCallbackOptions allows a common set of callback client-side options to be attached to one or more active controls. This can be useful if a lot of active controls on the same page are sharing the same callback client-side options. Instead of specifying the same set of options again and again inside each control, these can be written once inside a TCallbackOptions; this TCallbackOptions can be then attached to each control using the ActiveControl.CallbackOptions property. For a full list of assignable properties, please check the TCallbackClientSide documentation.

The typical scenario of use for a TCallbackOptions is a page where a lot of active controls needs to pause the user interaction with a "Please wait" style message until callback completion. First create a single TCallbackOptions control, assign it an ID and the the needed properties:

<com:TCallbackOptions
    ID="MyOptions"
    ClientSide.OnLoading="... kindly inform the user that he should wait ..."
    ClientSide.OnComplete="... callback completed, ready to serve the user again ..."
/>

Then, share this set of options to one or more active controls; each control will follow them:

<com:TActiveButton
    Text="simple button"
    OnCallback="..."
    ActiveControl.CallbackOptions="MyOptions"
    ...
/>

<com:TActiveCheckBox
    Text="simple checkbox"
    OnCallback="..."
    ActiveControl.CallbackOptions="MyOptions"
    ...
/>
Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TDropContainer

API Manual

TDropContainer represent an area where TDraggable controls can be dropped. When a TDraggable is dropped, a callback request is initiated. The OnCallback event is raised during a callback request and it is raised after the OnDrop event.

TDraggable

API Manual

TDraggable will make its child controls 'draggable'. When a TDraggable is dropped, a callback request is initiated. The OnCallback event is raised during a callback request and it is raised after the OnDrop event.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TEventTriggeredCallback

API Manual

TEventTriggeredCallback triggers a new callback request when a particular EventName on a control with ID given by ControlID is raised. The default action of the event on the client-side can be prevented when PreventDefaultAction is set to true.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TInPlaceTextBox

API Manual

TInPlaceTextBox is a component rendered as a label and allows its contents to be edited by changing the label to a textbox when the label is clicked or when another control or html element with ID given by EditTriggerControlID is clicked.

If the OnLoadingText event is handled, a callback request is made when the label is clicked, while the request is being made the textbox is disabled from editing. The OnLoadingText event allows you to update the content of the textbox before the client is allowed to edit the content. After the callback request returns successfully, the textbox is enabled and the contents is then allowed to be edited.

Once the textbox loses focus, if AutoPostBack is true and the textbox content has changed, a callback request is made and the OnTextChanged event is raised like that of the TActiveTextBox. During the request, the textbox is disabled.

After the callback request returns sucessfully, the textbox is enabled. If the AutoHideTextBox property is true, then the textbox will be hidden and the label is then shown.

Since 3.1.2, you can set the ReadOnly property to make the control not editable. This property can be also changed on callback

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Overview of Active Controls

TODO:
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TTimeTriggeredCallback

API Manual

TTimeTriggeredCallback sends callback request every Interval seconds. Upon each callback request, the OnCallback event is raised. The timer can be started by calling startTimer() and stopped using stopTimer(). The timer can be automatically started when StartTimerOnLoad is true.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TValueTriggeredCallback

API Manual

TValueTriggeredCallback observes the value with PropertyName of a control with ControlID. Changes to the observed property value will trigger a new callback request. The property value is checked for changes every Interval seconds. A DecayRate can be set to increase the polling interval linearly if no changes are observed. Once a change is observed, the polling interval is reset to the original value.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TButton

API Manual

TButton creates a click button on a Web page. The button's caption is specified by Text property. A button is used to submit data to a page. TButton raises two server-side events, OnClick and OnCommand, when it is clicked on the client-side. The difference between OnClick and OnCommand events is that the latter event is bubbled up to the button's ancestor controls. An OnCommand event handler can use CommandName and CommandParameter associated with the event to perform specific actions.

Clicking on button can trigger form validation, if CausesValidation is true. And the validation may be restricted within a certain group of validator controls according to ValidationGroup.

Run Sample View Source
TODO: custom attributes
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TCaptcha

API Manual

TCaptcha displays a CAPTCHA that can be used to determine if the input is entered by a real user instead of some program. TCaptcha displays a token (a string consisting of alphanumeric characters) as an image and the user is expected to repeat the token in a text box. The token image is generated in a way such that it can be recognized by a human being, but not a program.

To use TCaptcha, you must enable the PHP GD2 extension with TrueType font support. Unlike other CAPTCHA scripts, TCaptcha does not need session or cookie.

The token generated by TCaptcha can be configured in several ways. To specify the length of characters in the token, set MinTokenLength and MaxTokenLength. To use case-insensitive token comparison and generate upper-case-only token, set CaseSensitive to false. More advanced users can try to set TokenAlphabet to specify which characters may appear in the generated tokens.

The validation of the token is related with two properties: TestLimit (defaults to 5 times) and TokenExpiry (defaults to 600 seconds). The former specifies how many times a token can be tested with on the server side, and the latter says when a generated token will expire. If the validation fails in any of the two scenarios, a new token will be automatically generated.

To specify the appearance of the generated token image, set TokenImageTheme to be an integer between 0 and 63. You may try the following example to see how this value affects the generated token image. The size of the generated token image is determined by TokenFontSize. In particular, the image width is proportional to the font size. You may also set Width to scale the generated image to your desired size, but the scaled image may not look good. By setting ChangingTokenBackground to true, the image background of the token will be variating even though the token is the same during postbacks.

Upon postback, user input can be validated by calling the method TCaptcha.validate(). More easily, you can use a TCaptchaValidator to automate the validation work for you. The TCaptchaValidator has the additional benefit of being able to validate the user input on the client-side. By default, a generated token will remain unchanged during postbacks. A new token can be generated by calling TCaptcha.regenerateToken() manually.

The following template shows a typical use of the TCaptcha control:

<com:TCaptcha ID="Captcha" />
<com:TTextBox ID="Input" />
<com:TCaptchaValidator CaptchaControl="Captcha"
                          ControlToValidate="Input"
                          ErrorMessage="You are challenged!" />
Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TCheckBox

API Manual

TCheckBox displays a check box on a Web page. A caption can be specified via Text and displayed beside the check box. It can appear either on the right or left of the check box, which is determined by TextAlign. You may further specify attributes applied to the text by using LabelAttributes.

To determine whether the check box is checked, test the Checked property. A CheckedChanged event is raised if the state of Checked is changed between posts to the server. If AutoPostBack is true, changing the check box state will cause postback action. And if CausesValidation is also true, upon postback validation will be performed for validators within the specified ValidationGroup.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TClientScript

API Manual

Including Bundled Javascript Libraries in Prado

TClientScript allows Javascript code to be insert or linked to the page template. PRADO is bundled with a large library of Javascript functionality including effects, AJAX, basic event handlers, and many others. The bundled Javascript libraries can be linked to the current page template using the PradoScripts property. Multiple bundled Javascript libraries can be specified using comma delimited string of the name of Javascript library to include on the page. For following example will include the "ajax" and "effects" library.

<com:TClientScript PradoScripts="ajax, effects" />

The available bundled libraries included in Prado are

  • prado : basic prado javascript framework based on Prototype
  • effects : visual effects from script.aculo.us
  • ajax : ajax and callback related based on Prototype
  • validator : validation
  • logger : javascript logger and object browser
  • datepicker : datepicker
  • colorpicker : colorpicker

Many of the libraries, such as validator and datepicker will automatically when controls that uses these libraries are visible on the page. For example, all the validators if they have their EnableClientScript set to true will include both the prado and validator javascript libraries. The dependencies for each library are automatically resolved. That is, specifying, say the "ajax", will also include the "prado" library.

Including Custom Javascript Files

Custom Javascript files can be register using the ScriptUrl property. The following example includes the Javascript file "test.js" to the page. In this case, the file "test.js" is relative the current template you are using. Since the property value is dynamic asset tag, the file "test.js" will be published automatically, that is, the file will be copied to the assets directory if necessary.

<com:TClientScript ScriptUrl=<%~ test.js %> />

You can include Javascript files from other servers by specifying the full URL string in the ScriptUrl property.

Including Custom Javascript Code Blocks

Any content within the TClientScript control tag will be considered as Javascript code and will be rendered where it is declared.
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TClientScriptLoader

API Manual

Available from Prado versions 3.1b onwards.

The TClientScriptLoader publish a collection of javascript files as assets. For example, suppose we have a directory name "mylib" in the protected/pages directory of our application.

assets/
protected/
  pages/
    mylib/
       file1.js
       file2.js
       file3.js
       file4.js
       packages.php

The PackagePath property can be an existing asset directory or a namespace path to the directory containing javascript files. For example, to publish the javascript files in the mylib directory, we can specify the PackagePath as follows. The first tag TClientScriptLoader relies on the asset template tag and assumes that the page template containing the TClientScriptLoader tag instance is in the protected/pages directory. The second TClientScriptLoader tag uses the namespace notation to specify the path.

<com:TClientScriptLoader PackagePath=<%~ mylib %> />
<com:TClientScriptLoader PackagePath="Application.pages.mylib" />

When the files in the PackagePath are published as assets, a script loader php file "clientscripts.php" is automatically copied to that asset directory. The script loader, combines multiple javascript files and serve up as gzip if possible.

Grouping Javascript Files

Allowable scripts and script dependencies can be grouped by using a "packages.php" file with the following format. This "packages.php" is optional, if absent the file names without ".js" extension are used. The "packages.php" must be in the directory given by PackagePath.

<?php
 $packages = array(
    'package1' => array('file1.js', 'file2.js'),
    'package2' => array('file3.js', 'file4.js'));

 $deps = array(
    'package1' => array('package1'),
    'package2' => array('package1', 'package2')); //package2 requires package1 first.

 return array($packages,$deps); //must return $packages and $deps in an array
?>

The first element of the array returned by the packages.php should contain an array of javascripts files relative to the packages.php that corresponds to a particular grouping. For example, in the above packages.php, the grouping 'package1' combines two javascript files, namely, 'file1.js' and 'file2.js'.

The second element of the array returned by the packages.php should contain an array of grouping dependencies ordered in the way that the groups should be combined. For example, grouping 'package1' only depends on the 'package1' grouping files (i.e. 'file1.js' and 'file2.js'). While 'package2' depends on both 'package1' and 'package2' groupings. That is, 'package2' will combine, in order, 'file1.js', 'file2.js', 'file3.js', and 'file4.js'.

Loading Javascript Packages

To load a particular javascript file or package, set the PackageScripts property with value 'package1' to load the 'package1' scripts. A maximum of 25 packages separated by commas is allowed. Dependencies of the packages are automatically resolved by the script loader php file.

<com:TClientScriptLoader PackagePath=<%~ mylib %> PackageScripts="package2" />
<script type="text/javascript">
 //javascript code utilizing javascript code loaded in 'package2' above
</script>

Each <com:TClientScriptLoader> generates an HTML <script> element to load the required javascript files.

Removing Javascript Comments

The DebugMode property when false removes comments and white spaces from the published javascript files. If the DebugMode property is not set, the debug mode is determined from the application mode.

Note: If the DebugMode is false either explicitly or when the application mode is non-debug, then cache headers are also sent to inform the browser and proxies to cache the file. Moreover, the post-processed (comments removed and zipped) are saved in the assets directory for the next requests. That is, in non-debug mode the scripts are cached in the assets directory until they are deleted.

Compressing Javascript with GZip

The EnableGzip property (default is true) enables the published javascripts to be served as zipped if the browser and php server allows it.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TColorPicker

API Manual

TColorPicker displays a text box for color input purpose. Next to the textbox there's a button filled with the current chosen color. Users can write a color name directly in the text box as an hex triplet (also known as HTML notation, eg: #FF00FF).
Alternatively, if the ShowColorPicker property is enabled (it is by default), users can click the button to have a color picker UI appear. A color chan be chosen directly by clicking on the color picker.

TColorPicker has three different color picker UI Modes:

  • Simple - Grid with 12 simple colors.
  • Basic - Grid with the most common 70 colors. This is the default mode.
  • Full - Full-featured color picker.

The CssClass property can be used to override the CSS class name for the color picker panel. The ColorStyle property changes the overall color picker style. The following ColorStyle values are available:

  • default - The default color picker style.

If the Mode property is set to Full, the color picker panel will display an "Ok" and "Cancel" buttons. You can customize the button labels setting the OKButtonText and CancelButtonText properties.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TConditional

API Manual

TConditional displays appropriate content based on the evaluation result of a PHP expression specified via Condition. If the result is true, it instantiates the template TrueTemplate; otherwise, the template FalseTemplate is instantiated. The PHP expression is evaluated right before the onInit stage of the control lifecycle.

Since TConditional evaluates Condition at a very early stage, it is recommended you set Condition in template only and the expression should not refer to objects that are available on or after the onInit lifecycle.

TConditional is very light. It instantiates either TrueTemplate FalseTemplate, but never both. And the condition is evaluated only once. A typical usage of TConditional is shown as following:

<com:TConditional Condition="$this->User->IsGuest">
    <prop:TrueTemplate>
        <a href="path/to/login">Login</a>
    </prop:TrueTemplate>
    <prop:FalseTemplate>
        <a href="path/to/logout">Logout</a>
    </prop:FalseTemplate>
</com:TConditional>
Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TDataGrid

API Manual

TDatagrid is an important control in building complex Web applications. It displays data in a tabular format with rows (also called items) and columns. A row is composed by cells, while columns govern how cells should be displayed according to their association with the columns. Data specified via DataSource or DataSourceID are bound to the rows and feed contents to cells.

TDataGrid is highly interactive. Users can sort the data along specified columns, navigate through different pages of the data, and perform actions, such as editing and deleting, on rows of the data.

Rows of TDataGrid can be accessed via its Items property. A row (item) can be in one of several modes: browsing, editing and selecting, which affects how cells in the row are displayed. To change an item's mode, modify EditItemIndex or SelectedItemIndex. Note, if an item is in edit mode, then selecting this item will have no effect.

Columns

Columns of a data grid determine how the associated cells are displayed. For example, cells associated with a TBoundColumn are displayed differently according to their modes. A cell is displayed as a static text if the cell is in browsing mode, a text box if it is in editing mode, and so on.

PRADO provides eight types of columns:

  • TBoundColumn associates cells with a specific field of data and displays the cells according to their modes.
  • TLiteralColumn associates cells with a specific field of data and displays the cells with static texts.
  • TCheckBoxColumn associates cells with a specific field of data and displays in each cell a checkbox whose check state is determined by the data field value.
  • TDropDownListColumn associates cells with a specific field of data and displays the cells according to their modes. If in edit mode, a cell will be displayed with a TDropDownList.
  • THyperLinkColumn displays in the cells a hyperlink whose caption and URL can be either statically specified or bound to some fields of data.
  • TEditCommandColumn displays in the cells edit/update/cancel command buttons according to the state of the item that a cell resides in.
  • TButtonColumn displays in the cells a command button.
  • TTemplateColumn displays the cells according to different templates defined for it.

Item Styles

TDataGrid defines different styles applied to its items. For example, AlternatingItemStyle is applied to alternating items (item 2, 4, 6, etc.) Through these properties, one can set CSS style fields or CSS classes for the items.

Item styles are applied in a hierarchical way. Styles in higher hierarchy will inherit from styles in lower hierarchy. Starting from the lowest hierarchy, the item styles include item's own style, ItemStyle, AlternatingItemStyle, SelectedItemStyle, and EditItemStyle. Therefore, if background color is set as red in ItemStyle, EditItemStyle will also have red background color, unless it is explicitly set to a different value.

Events

TDataGrid provides several events to facilitate manipulation of its items,

  • OnItemCreated - raised each time an item is newly created. When the event is raised, data and child controls are both available for the new item.
  • OnItemDataBound - raised each time an item just completes databinding. When the event is raised, data and child controls are both available for the item, and the item has finished databindings of itself and all its child controls.
  • OnItemCommand - raised when a child control of some item (such as a TButton) raises an OnCommand event.
  • command events - raised when a child control's OnCommand event has a specific command name,
    • OnSelectedIndexChanged - if the command name is select.
    • OnEditCommand - if the command name is edit.
    • OnDeleteCommand - if the command name is delete.
    • OnUpdateCommand - if the command name is update.
    • OnCancelCommand - if the command name is cancel.
    • OnSortCommand - if the command name is sort.
    • OnPageIndexChanged - if the command name is page.

Using TDataGrid

Automatically Generated Columns

TDataGrid by default will create a list of columns based on the structure of the bound data. TDataGrid will read the first row of the data, extract the field names of the row, and construct a column for each field. Each column is of type TBoundColumn.

The following example displays a list of computer product information using a TDataGrid. Columns are automatically generated. Pay attention to how item styles are specified and inherited. The data are populated into the datagrid using the following code, which is common among most datagrid applications,

public function onLoad($param) {
    parent::onLoad($param);
    if(!$this->IsPostBack) {
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }
}
Run Sample View Source

Manually Specified Columns

Using automatically generated columns gives a quick way of browsing tabular data. In real applications, however, automatically generated columns are often not sufficient because developers have no way customizing their appearance. Manually specified columns are thus more desirable.

To manually specify columns, set AutoGenerateColumns to false, and specify the columns in a template like the following,

<com:TDataGrid ...>
  <com:TBoundColumn DataField="name" .../>
  <com:TBoundColumn DataField="price" .../>
  <com:TEditCommandColumn ...>
  ...
</com:TDataGrid>

Note, if AutoGenerateColumns is true and there are manually specified columns, the automatically generated columns will be appended to the manually specified columns. Also note, the datagrid's Columns property contains only manually specified columns and no automatically generated ones.

The following example uses manually specified columns to show a list of book information,

  • Book title - displayed as a hyperlink pointing to the corresponding amazon.com book page. THyperLinkColumn is used.
  • Publisher - displayed as a piece of text using TBoundColumn.
  • Price - displayed as a piece of text using TBoundColumn with output formatting string and customized styles.
  • In-stock or not - displayed as a checkbox using TCheckBoxColumn.
  • Rating - displayed as an image using TTemplateColumn which allows maximum freedom in specifying cell contents.

Pay attention to how item (row) styles and column styles cooperate together to affect the appearance of the cells in the datagrid.

Run Sample View Source

Interacting with TDataGrid

Besides the rich data presentation functionalities as demonstrated in previous section, TDataGrid is also highly user interactive. An import usage of TDataGrid is editing or deleting rows of data. The TBoundColumn can adjust the associated cell presentation according to the mode of datagrid items. When an item is in browsing mode, the cell is displayed with a static text; when the item is in editing mode, a textbox is displayed to collect user inputs. TDataGrid provides TEditCommandColumn for switching item modes. In addition, TButtonColumn offers developers the flexibility of creating arbitrary buttons for various user interactions.

The following example shows how to make the previous book information table an interactive one. It allows users to edit and delete book items from the table. Two additional columns are used in the example to allow users interact with the datagrid: TEditCommandColumn and TButtonColumn. In addition, TDropDownListColumn replaces the previous TTemplateColumn to allow users to select a rating from a dropdown list. Note, it is also possible to use TTemplateColumn to achieve the same task.

Run Sample View Source

Sorting

TDataGrid supports sorting its items according to specific columns. To enable sorting, set AllowSorting to true. This will turn column headers into clickable buttons if their SortExpression property is not empty. When users click on the header buttons, an OnSortCommand event will be raised. Developers can write handlers to respond to the sort command and sort the data according to SortExpression which is specified in the corresponding column.

The following example turns the datagrid in Example 2 into a sortable one. Users can click on the link button displayed in the header of any column, and the data will be sorted in ascending order along that column.

Run Sample View Source

Paging

When dealing with large datasets, paging is helpful in reducing the page size and complexity. TDataGrid has an embedded pager that allows users to specify which page of data they want to see. The pager can be customized via PagerStyle. For example, PagerStyle.Visible determines whether the pager is visible or not; PagerStyle.Position indicates where the pager is displayed; and PagerStyle.Mode specifies what type of pager is displayed, a numeric one or a next-prev one.

To enable paging, set AllowPaging to true. The number of rows of data displayed in a page is specified by PageSize, while the index (zero-based) of the page currently showing to users is by CurrentPageIndex. When users click on a pager button, TDataGrid raises OnPageIndexChanged event. Typically, the event handler is written as follows,

public function pageIndexChanged($sender,$param) {
    $this->DataGrid->CurrentPageIndex=$param->NewPageIndex;
    $this->DataGrid->DataSource=$this->Data;
    $this->DataGrid->dataBind();
}

The following example enables the paging functionality of the datagrid shown in Example 1. In this example, you can set various pager styles interactively to see how they affect the pager display.

Run Sample View Source

Custom Paging

The paging functionality shown above requires loading all data into memory, even though only a portion of them is displayed in a page. For large datasets, this is inefficient and may not always be feasible. TDataGrid provides custom paging to solve this problem. Custom paging only requires the portion of the data to be displayed to end users.

To enable custom paging, set both AllowPaging and AllowCustomPaging to true. Notify TDataGrid the total number of data items (rows) available by setting VirtualItemCount. And respond to the OnPageIndexChanged event. In the event handler, use the NewPageIndex property of the event parameter to fetch the new page of data from data source. For MySQL database, this can be done by using LIMIT clause in an SQL select statement.

Run Sample View Source

Extending TDataGrid

Besides traditional class inheritance, extensibility of TDataGrid is mainly through developing new datagrid column components. For example, one may want to display an image column. He may use TTemplateColumn to accomplish this task. A better solution is to develop an image column component so that the work can be reused easily in other projects.

All datagrid column components must inherit from TDataGridColumn. The main method that needs to be overridden is initializeCell() which creates content for cells in the corresponding column. Since each cell is also in an item (row) and the item can have different types (such as Header, AltneratingItem, etc.), different content may be created according to the item type. For the image column example, one may want to create a TImage control within cells residing in items of Item and AlterantingItem types.

class ImageColumn extends TDataGridColumn {
    ...
    public function initializeCell($cell,$columnIndex,$itemType) {
        parent::initializeCell($cell,$columnIndex,$itemType);
        if($itemType==='Item' || $itemType==='AlternatingItem') {
            $image=new TImage;
            // ... customization of the image
            $cell->Controls[]=$image;
        }
    }
}

In initializeCell(), remember to call the parent implementation, as it initializes cells in items of Header and Footer types.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TDataList

API Manual

TDataList represents a data bound and updatable list control. Like TRepeater, TDataList displays its content repeatedly based on the data fetched from DataSource. The repeated contents in TDataList are called items, which are controls and can be accessed through Items. When dataBind() is invoked, TDataList creates an item for each row of data and binds the data row to the item. Optionally, a TDataList can have a header, a footer and/or separators between items.

TDataList differs from TRepeater in that it introduces the concept of item state and allows applying different styles to items in different states. In addition, TDataList supports tiling the repeated items in various ways.

The layout of the repeated contents in TDataList are specified by inline templates. TDataList items, header, footer, etc. are being instantiated with the corresponding templates when data is being bound to the repeater.

Since v3.1.0, the layout can also be by renderers. A renderer is a control class that can be instantiated as datalist items, header, etc. A renderer can thus be viewed as an external template (in fact, it can also be non-templated controls). For more details, see the explanation about renderer in the TRepeater tutorial.

The following properties are used to specify different types of template and renderer for a datalist. If a content type is defined with both a template and a renderer, the latter takes precedence.

  • ItemTemplate, ItemRenderer: for each repeated row of data
  • AlternatingItemTemplate, AlternatingItemRenderer: for each alternating row of data. If not set, ItemTemplate or ItemRenderer will be used instead.
  • HeaderTemplate, HeaderRenderer: for the datalist header.
  • FooterTemplate, FooterRenderer: for the datalist footer.
  • SeparatorTemplate, SeparatorRenderer: for content to be displayed between items.
  • EmptyTemplate, EmptyRenderer: used when data bound to the datalist is empty.
  • EditItemTemplate, EditItemRenderer: for the row being editted.
  • SelectedItemTemplate, SelectedItemRenderer: for the row being selected.

When dataBind() is called, TDataList undergoes the following lifecycles for each row of data:

  1. create item based on templates or renderers
  2. set the row of data to the item
  3. raise an OnItemCreated event
  4. add the item as a child control
  5. call dataBind() of the item
  6. raise an OnItemDataBound event

TDataList raises an OnItemCommand whenever a button control within some datalist item raises an OnCommand event. Therefore, you can handle all sorts of OnCommand event in a central place by writing an event handler for OnItemCommand. An additional event is raised if the OnCommand event has one of the following command names (case-insensitive):

  • edit - user wants to edit an item. OnEditCommand event will be raised.
  • update - user wants to save the change to an item. OnUpdateCommand event will be raised.
  • select - user selects an item. OnSelectedIndexChanged event will be raised.
  • delete - user deletes an item. OnDeleteCommand event will be raised.
  • cancel - user cancels previously editting action. OnCancelCommand event will be raised.

TDataList provides a few properties to support tiling the items. The number of columns used to display the data items is specified via RepeatColumns property, while the RepeatDirection governs the order of the items being rendered. The layout of the data items in the list is specified via RepeatLayout, which takes one of the following values:

  • Table (default) - items are organized using HTML table and cells. When using this layout, one can set CellPadding and CellSpacing to adjust the cellpadding and cellspacing of the table, and Caption and CaptionAlign to add a table caption with the specified alignment.
  • Flow - items are organized using HTML spans and breaks.
  • Raw - TDataList does not generate any HTML tags to do the tiling.

Items in TDataList can be in one of the three states: being browsed, being editted and being selected. To change the state of a particular item, set SelectedItemIndex or EditItemIndex. The former will change the indicated item to selected mode, which will cause the item to use SelectedItemTemplate or SelectedItemRenderer for presentation. The latter will change the indicated item to edit mode and to use corresponding template or renderer. Note, if an item is in edit mode, then selecting this item will have no effect.

Different styles may be applied to items in different status. The style application is performed in a hierarchical way: Style in higher hierarchy will inherit from styles in lower hierarchy. Starting from the lowest hierarchy, the item styles include:

  • item's own style
  • ItemStyle
  • AlternatingItemStyle
  • SelectedItemStyle
  • EditItemStyle

Therefore, if background color is set as red in ItemStyle, EditItemStyle will also have red background color unless it is set to a different value explicitly.

When a page containing a datalist is post back, the datalist will restore automatically all its contents, including items, header, footer and separators. However, the data row associated with each item will not be recovered and become null. To access the data, use one of the following ways:

  • Use DataKeys to obtain the data key associated with the specified repeater item and use the key to fetch the corresponding data from some persistent storage such as DB.
  • Save the whole dataset in viewstate, which will restore the dataset automatically upon postback. Be aware though, if the size of your dataset is big, your page size will become big. Some complex data may also have serializing problem if saved in viewstate.

The following example shows how to use TDataList to display tabular data, with different layout and styles.

Run Sample View Source

A common use of TDataList is for maintaining tabular data, including browsing, editing, deleting data items. This is enabled by the command events and various item templates of TDataList.

The following example displays a computer product information. Users can add new products, modify or delete existing ones. In order to locate the data item for updating or deleting, DataKeys property is used.

Be aware, for simplicity, this application does not do any input validation. In real applications, make sure user inputs are valid before saving them into databases.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TDatePicker

API Manual

TDatePicker displays a text box for date input purpose. When the text box receives focus, a calendar will pop up and users can pick up from it a date that will be automatically entered into the text box. The format of the date string displayed in the text box is determined by the DateFormat property. Valid formats are the combination of the following tokens:

Character      Format Pattern (en-US)
---------------------------------------------------------------------
 d              day digit
 dd             padded day digit e.g. 01, 02
 M              month digit
 MM             padded month digit
 MMM            localized abbreviated month names, e.g. Mar, Apr
 MMMM           localized month name, e.g. March, April
 yy             2 digit year
 yyyy           4 digit year
---------------------------------------------------------------------

The date of the date picker can be set using the Date or Timestamp properties. The Date property value must be in the same format as the pattern specified in the DateFormat property. The Timestamp property only accepts integers such as the Unix timestamp.

TDatePicker has three Mode to show the date picker popup.

  • Basic - Only shows a text input, focusing on the input shows the date picker.
  • Button - Shows a button next to the text input, clicking on the button shows the date, button text can be by the ButtonText property.
  • ImageButton - Shows an image next to the text input, clicking on the image shows the date picker, image source can be change through the ImageUrl property.

The CssClass property can be used to override the CSS class name for the date picker panel. The CalendarStyle property changes the overall calendar style. The following CalendarStyle values are available:

  • default - The default calendar style.

The InputMode property can be set to "TextBox" or "DropDownList" with default as "TextBox". In DropDownList mode, in addition to the popup date picker, three drop down list (day, month and year) are presented to select the date . When InputMode equals "DropDownList", the order and appearance of the date, month, and year will depend on the pattern specified in DateFormat property.

The popup date picker can be hidden by specifying ShowCalendar as false. Much of the text of the popup date picker can be changed to a different language using the Culture property.

The calendar picker year limit can be set using the FromYear and UpToYear properties where FromYear is the starting year and UpToYear is the last year selectable. The starting day of the week can be changed by the FirstDayOfWeek property, with 0 as Sunday, 1 as Monday, etc.

Note 1: If the InputMode is "TextBox", the DateFormat should only NOT contain MMM or MMMM patterns. The server side date parser will not be able to determine the correct date if MMM or MMMM are used. When InputMode equals "DropDownList", all patterns can be used.

Note 2: When the TDatePicker is used together with a validator, the DateFormat property of the validator must be equal to the DateFormat of the TDatePicker AND must set DataType="Date" on the validator to ensure correct validation. See TCompareValidator, TDataTypeValidator and TRangeValidator for details.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TExpression

API Manual

TExpression evaluates a PHP expression and displays the evaluation result. To specify the expression to be evaluated, set the Expression property. Note, TExpression evaluates the expression during the rendering control lifecycle.

The context of the expression in a TExpression control is the control itself. That is, $this represents the control object if it is present in the expression. For example, the following template tag will display the title of the page containing the TExpression control.

<com:TExpression Expression="$this->Page->Title" />

Be aware, since TExpression allows execution of arbitrary PHP code, in general you should not use it to evaluate expressions submitted by your application users.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TFileUpload

API Manual

TFileUpload displays a file upload field on a Web page. Upon postback, the text entered into the field will be treated as the (local) name of the file that is uploaded to the server.

TFileUpload raises an OnFileUpload event when it is post back. The property HasFile indicates whether the file upload is successful or not. If successful, the uploaded file may be saved on the server by calling saveAs() method.

The following properties give the information about the uploaded file:

  • FileName - the original client-side file name without directory information.
  • FileType - the MIME type of the uploaded file.
  • FileSize - the file size in bytes.
  • LocalName - the absolute file path of the uploaded file on the server. Note, this file will be deleted after the current page request is completed. Call saveAs() to save the uploaded file.

If the file upload is unsuccessful, the property ErrorCode gives the error code describing the cause of failure. See PHP documentation for a complete explanation of the possible error codes.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

THead

API Manual

THead displays a head element on a page. It displays the content enclosed in its body and the page title set by the Title property.

In addition, stylesheets and JavaScripts registered via

  • TClientScriptManager::registerStyleSheet,
  • TClientScriptManager::registerStyleSheetFile,
  • TClientScriptManager::registerHeadJavaScript and
  • TClientScriptManager::registerHeadJavaScriptFile
will also be displayed in the head.

THead also manages and displays meta tags through its MetaTags property. You can add a meta object to the collection in code dynamically, or add it in template using the following syntax

<com:THead>
  <com:TMetaTag HttpEquiv="Pragma" Content="no-cache" />
  <com:TMetaTag Name="keywords" Content="Prado" />
</com:THead>

Note, TPage has a property Head that refers to the THead control currently on the page. A page can have at most one THead control. Although not required, it is recommended to place a THead on your page. Without a THead on the page, stylesheets and javascripts in the current page theme will not be rendered.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

THiddenField

API Manual

THiddenField represents a hidden field on a Web page. The value of the hidden field can be accessed via its Value property.

THiddenField raises an OnValueChanged event if its value is changed during postback.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

THtmlArea

API Manual

THtmlArea displays a WYSIWYG text input field on a Web page to collect input in HTML format. The text displayed in the THtmlArea control is specified or determined by using the Text property. To adjust the size of the input region, set Width and Height properties instead of Columns and Rows because the latter has no meaning under this situation. To disable the WYSIWYG feature, set EnableVisualEdit to false.

THtmlArea provides the WYSIWYG feature by wrapping the functionalities provided by the TinyMCE project.

The default editor gives only the basic tool bar. To change or add additional tool bars, use the Options property to add additional editor options with each options on a new line. See TinyMCE website for a complete list of options. The following example displays a toolbar specific for HTML table manipulation,

<com:THtmlArea>
  <prop:Options>
    plugins : "table"
    theme_advanced_buttons3 : "tablecontrols"
  </prop:Options>
</com:THtmlArea>

The client-side visual editing capability is supported by Internet Explorer 5.0+ for Windows and Gecko-based browser. If the browser does not support the visual editing, a traditional textarea will be displayed.

                Windows XP        MacOS X 10.4
----------------------------------------------------
MSIE 6                  OK
MSIE 5.5 SP2            OK
MSIE 5.0                OK
Mozilla 1.7.x           OK              OK
Firefox 1.0.x           OK              OK
Firefox 1.5b2           OK              OK
Safari 2.0 (412)                        OK(1)
Opera 9 Preview 1       OK(1)           OK(1)
----------------------------------------------------
(1) - Partially working
----------------------------------------------------
Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

THyperLink

API Manual

THyperLink displays a hyperlink on a page. The hyperlink URL is specified via the NavigateUrl property, and link text is via the Text property. The link target is specified via the Target property. It is also possible to display an image by setting the ImageUrl property. In this case, Text is displayed as the alternate text of the image. If both ImageUrl and Text are empty, the content enclosed within the control tag will be rendered.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TImage

API Manual

TImage displays an image on a page. The image is specified via the ImageUrl property which takes a relative or absolute URL to the image file. The alignment of the image displayed is set by the ImageAlign property. To set alternate text or long description of the image, use AlternateText or DescriptionUrl, respectively.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TImageButton

API Manual

TImageButton is also similar to TButton, except that TImageButton displays the button as an image. The image is specified via ImageUrl, and the alternate text is specified by Text. In addition, it is possible to obtain the coordinate of the point where the image is clicked. The coordinate information is contained in the event parameter of the OnClick event (not OnCommand).

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TImageMap

API Manual

TImageMap represents an image on a Web page with predefined hotspot regions that can respond differently to users' clicks on them. Depending on the HotSpotMode of the hotspot region, clicking on the hotspot may trigger a postback or navigate to a specified URL.

Each hotspot is described using a THotSpot object and is maintained in the HotSpots collection in TImageMap. A hotspot can be a circle, rectangle, polygon, etc.

Hotspots can be added to TImageMap via its HotSpots property or in a template like the following,

<com:TImageMap ... >
  <com:TCircleHotSpot ... />
  <com:TRectangleHotSpot ... />
  <com:TPolygonHotSpot ... />
</com:TImageMap>
Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TInlineFrame

API Manual

TInlineFrame displays an inline frame (<iframe>) on a Web page. The location of the frame content is specified by the FrameUrl property.

The appearance of a TInlineFrame may be customized with the following properties, in addition to those inherited from TWebControl.

  • Align - the alignment of the frame.
  • DescriptionUrl - the URI of a long description of the frame's contents.
  • MarginWidth and MarginHeight - the number of pixels to use as the left/right margins and top/bottom margins, respectively.
  • ScrollBars - whether scrollbars are provided for the inline frame. By default, it is Auto, meaning the scroll bars appear as needed. Setting it as None or Both to explicitly hide or show the scroll bars.

The following samples show TInlineFrame with different property settings. The Google homepage is used as the frame content.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TJavascriptLogger

API Manual

TJavascriptLogger provides logging for client-side javascript. It is mainly a wrapper of the Javascript developed at http://gleepglop.com/javascripts/logger/.

To use TJavascriptLogger, simply place the following component tag in a page template.

<com:TJavascriptLogger />

Then, the client-side Javascript may contain the following statements. When they are executed, they will appear in the logger window.

Logger.info('something happend');
Logger.warn('A warning');
Logger.error('This is an error');
Logger.debug('debug information');

To toggle the visibility of the logger and console on the browser window, press ALT-D (or CTRL-D on OS X).

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TKeyboard

API Manual

TKeyboard displays a virtual keyboard that users can click on to enter input in an associated text box. It helps to reduce the keyboard recording hacking.

To use TKeyboard, write a template like following:

<com:TTextBox ID="PasswordInput" />
<com:TKeyboard ForControl="PasswordInput" />

A TKeyboard control is associated with a TTextBox control by specifying ForControl to be the ID of that control. When the textbox is in focus, a virtual keyboard will pop up; and when the text box is losing focus, the keyboard will hide automatically. Set AutoHide to false to keep the keyboard showing all the time.

The appearance of the keyboard can also be changed by specifying a customized CSS file via CssUrl. By default, the CSS class name for the keyboard is 'Keyboard'. This may also be changed by specifying KeyboardCssClass

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TLabel

API Manual

TLabel displays a piece of text on a Web page. The text to be displayed is set via its Text property. If Text is empty, content enclosed within the TLabel component tag will be displayed. TLabel may also be used as a form label associated with some control on the form. Since Text is not HTML-encoded when being rendered, make sure it does not contain dangerous characters that you want to avoid.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TLinkButton

API Manual

TLinkButton is similar to TButton in every aspect except that TLinkButton is displayed as a hyperlink. The link text is determined by its Text property. If the Text property is empty, then the body content of the button is displayed (therefore, you can enclose a <img> tag within the button body and get an image button.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TLiteral

API Manual

TLiteral displays a static text on a Web page. TLiteral is similar to the TLabel control, except that the TLiteral * control has no style properties, such as BackColor, Font, etc.

The text displayed by TLiteral can be programmatically controlled by setting the Text property. The text displayed may be HTML-encoded if the Encode is true (the default value is false).

TLiteral will render the contents enclosed within its component tag if Text is empty.

Be aware, if Encode is false, make sure Text does not contain unwanted characters that may bring security vulnerabilities.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TMultiView

API Manual

TMultiView serves as a container for a group of TView controls, which can be retrieved by the Views property. Each view contains child controls. TMultiView determines which view and its child controls are visible. At any time, at most one view is visible (called active). To make a view active, set ActiveView or ActiveViewIndex. Note, by default there is no active view.

To add a view to TMultiView, manipulate the Views collection or add it in template as follows,

<com:TMultiView>
   <com:TView>
      view 1 content
   </com:TView>
   <com:TView>
      view 2 content
   </com:TView>
</com:TMultiView>

TMultiView responds to the following command events to manage the visibility of its views.

  • NextView : switch to the next view (with respect to the currently active view).
  • PreviousView : switch to the previous view (with respect to the currently active view).
  • SwitchViewID : switch to a view by its ID path. The ID path is fetched from the command parameter.
  • SwitchViewIndex : switch to a view by its zero-based index in the Views collection. The index is fetched from the command parameter.

Upon postback, if the active view index is changed, TMultiView will raise an OnActiveViewChanged event.

The Hangman game is a typical use of TMultiView. The following example demonstrates another usage of TMultiView.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TOutputCache

API Manual

TOutputCache enables caching a portion of a Web page, also known as partial caching. The content being cached are HTML page source coming from static texts on a PRADO template or rendered by one or several controls on the template. When the cached content is used, controls generating the content are no longer created for the page hierarchy and thus significant savings in page processing time can be achieved. The side-effect, as you might already find out, is that the content displayed may be stale if the cached version is shown to the users.

To use TOutputCache, simply enclose the content to be cached within the TOutputCache component tag on a template (either page or non-page control template), e.g.,

<com:TOutputCache>
   content to be cached
</com:TOutputCache>

where content to be cached can be static text and/or template tags. If the latter, the rendering results of the template tags will be cached. You can place one or several TOutputCache on a single template and they can be nested.

Note: TOutputCache stores cached content via PRADO cache modules (e.g. TSqliteCache) and thus requires at least one cache module loaded when the application runs.

The validity of the cached content is determined based on two factors: the Duration and the cache dependency. The former specifies the number of seconds that the data can remain valid in cache (defaults to 60s), while the latter specifies conditions that the cached data depends on. If a dependency changes (e.g. relevant data in DB are updated), the cached data will be invalidated and discarded.

There are two ways to specify cache dependency. One may write event handlers to respond to the OnCheckDependency event and set the event parameter's IsValid property to indicate whether the cached data remains valid or not. One can also extend TOutputCache and override its getCacheDependency() method.

The content fetched from cache may be variated with respect to some parameters. TOutputCache supports variation with respect to request parameters, which is specified by VaryByParam property. If a specified request parameter is different, a different version of cached content is used. This is extremely useful if a page's content may be variated according to some GET parameters. The content being cached may also be variated with user sessions if VaryBySession is set true. To variate the cached content by other factors, override calculateCacheKey() method.

Output caches can be nested. An outer cache takes precedence over an inner cache in determining the validity of cached contents. This means, if the content cached by the inner cache expires or is invalidated, while that by the outer cache not, the outer cached content will be used.

By default, TOutputCache is effective only for non-postback page requests and when a cache module is enabled. Do not attempt to address child controls of TOutputCache when the cached content is currently being used. Use ContentCached property to determine whether the content is cached or not.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TPager

API Manual

TPager creates a pager that provides UI for end-users to interactively specify which page of data to be rendered in a TDataBoundControl-derived control, such as TDataList, TRepeater, TCheckBoxList, etc. The target data-bound control is specified by the ControlToPaginate property, which must be the ID path of the target control reaching from the pager's naming container.

Note, the target data-bound control must have its AllowPaging set to true. Otherwise the pager will be invisible. Also, in case when there is only one page of data available, the pager will also be invisible.

TPager can display one of the following three types of user interface, specified via its Mode property:

  • NextPrev - a next page and a previous page button are rendered on each page.
  • Numeric - a list of page index buttons are rendered.
  • DropDownList - a dropdown list of page indices is rendered.

These user interfaces may be further customized by configuring the following properties

  • NextPageText and PrevPageText - the label of the next/previous page button. These properties are used when the pager Mode is NextPrev or Numeric.
  • FirstPageText and LastPageText - the label of the first/last page button. If empty, the corresponding button will not be displayed. These properties are used when the pager Mode is NextPrev or Numeric.
  • PageButtonCount - the maximum number of page index buttons on a page. This property is used when the pager Mode is Numeric.
  • ButtonType - type of page buttons, either PushButton meaning normal form submission buttons, or LinkButton meaning hyperlink buttons.

TPager raises an OnPageIndexChanged event when an end-user interacts with it and specifies a new page (e.g. by clicking on a next page button that would lead to the next page.) Developers may write handlers to respond to this event and obtain the desired new page index from the event parameter's property NewPageIndex. Using this new page index, one can feed a new page of data to the associated data-bound control.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TPanel

API Manual

TPanel acts as a presentational container for other control. It displays a <div> element on a page. The property Wrap specifies whether the panel's body content should wrap or not, while HorizontalAlign governs how the content is aligned horizontally and Direction indicates the content direction (left to right or right to left). You can set BackImageUrl to give a background image to the panel, and you can set GroupingText so that the panel is displayed as a field set with a legend text. Finally, you can specify a default button to be fired when users press 'return' key within the panel by setting the DefaultButton property.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TPlaceHolder

API Manual

TPlaceHolder reserves a place on a template, where static texts or controls may be dynamically inserted.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TRadioButton

API Manual

TRadioButton is similar to TCheckBox in every aspect, except that TRadioButton displays a radio button on a Web page. The radio button can belong to a specific group specified by GroupName such that only one radio button within that group can be selected at most.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TRepeater

API Manual

TRepeater displays its content repeatedly based on the data fetched from DataSource. The repeated contents in TRepeater are called items which are controls accessible through Items property. When dataBind() is invoked, TRepeater creates an item for each row of data and binds the data row to the item. Optionally, a repeater can have a header, a footer and/or separators between items.

The layout of the repeated contents are specified by inline templates. In particular, repeater items, header, footer, etc. are being instantiated with the corresponding templates when data is being bound to the repeater.

Since v3.1.0, the layout can also be specified by renderers. A renderer is a control class that can be instantiated as repeater items, header, etc. A renderer can thus be viewed as an external template (in fact, it can also be non-templated controls). A renderer can be any control class. By using item renderers, one can avoid writing long and messy templates. Since a renderer is a class, it also helps reusing templates that previously might be embedded within other templates. If implemented with one of the following interfaces, a renderer will be initialized with additional properties relevant to the repeater items:

  • IDataRenderer - the Data property will be set as the row of the data bound to the repeater item. Many PRADO controls implement this interface, such as TLabel, TTextBox, etc.
  • IItemDataRenderer - the ItemIndex property will be set as the zero-based index of the item in the repeater item collection, and the ItemType property as the item's type (such as TListItemType::Item). As a convenient base class, TRepeaterItemRenderer implements IDataItemRenderer and can have an associated template because it extends from TTemplateControl.

The following properties are used to specify different types of template and renderer for a repeater. If an item type is defined with both a template and a renderer, the latter takes precedence.

  • ItemTemplate, ItemRenderer - for each repeated row of data.
  • AlternatingItemTemplate, AlternatingItemRenderer: for each alternating row of data. If not set, ItemTemplate or ItemRenderer will be used instead, respectively.
  • HeaderTemplate, HeaderRenderer - for the repeater header.
  • FooterTemplate, FooterRenderer - for the repeater footer.
  • SeparatorTemplate, SeparatorRenderer - for content to be displayed between items.
  • EmptyTemplate, EmptyRenderer - used when data bound to the repeater is empty.

To populate data into the repeater items, set DataSource to a valid data object, such as array, TList, TMap, or a database table, and then call dataBind() for the repeater. That is,

class MyPage extends TPage {
    public function onLoad($param) {
        parent::onLoad($param);
        if(!$this->IsPostBack) {
            $this->Repeater->DataSource=$data;
            $this->Repeater->dataBind();
        }
    }
}

When dataBind() is called, TRepeater undergoes the following lifecycles for each row of data:

  1. create item based on templates or renderers
  2. set the row of data to the item
  3. raise an OnItemCreated event
  4. add the item as a child control
  5. call dataBind() of the item
  6. raise an OnItemDataBound event

Normally, you only need to bind the data to repeater when the page containing the repeater is initially requested. When the page is post back, the repeater will restore automatically all its contents, including items, header, footer and separators. However, the data row associated with each item will not be recovered and thus become null.

To access the repeater item data in postbacks, use one of the following ways:

  • Use DataKeys to obtain the data key associated with the specified repeater item and use the key to fetch the corresponding data from some persistent storage such as DB.
  • Save the whole dataset in viewstate, which will restore the dataset automatically upon postback. Be aware though, if the size of your dataset is big, your page size will become big. Some complex data may also have serializing problem if saved in viewstate.

TRepeater raises an OnItemCommand event whenever a button control within some repeater item raises a OnCommand event. Therefore, you can handle all sorts of OnCommand event in a central place by writing an event handler for OnItemCommand.

The following example shows how to use TRepeater to display tabular data.

Run Sample View Source

TRepeater can be used in more complex situations. As an example, we show in the following how to use nested repeaters, i.e., repeater in repeater. This is commonly seen in presenting master-detail data. To use a repeater within another repeater, for an item for the outer repeater is created, we need to set the detail data source for the inner repeater. This can be achieved by responding to the OnItemDataBound event of the outer repeater. An OnItemDataBound event is raised each time an outer repeater item completes databinding. In the following example, we exploit another event of repeater called OnItemCreated, which is raised each time a repeater item (and its content) is newly created. We respond to this event by setting different background colors for repeater items to achieve alternating item background display. This saves us from writing an AlternatingItemTemplate for the repeaters.

Run Sample View Source

Besides displaying data, TRepeater can also be used to collect data from users. Validation controls can be placed in TRepeater templates to verify that user inputs are valid.

The PRADO component composer demo is a good example of such usage. It uses a repeater to collect the component property and event definitions. Users can also delete or adjust the order of the properties and events, which is implemented by responding to the OnItemCommand event of repeater.

See in the following yet another example showing how to use repeater to collect user inputs.

Run Sample View Source

This sample shows how to use "drop-in" item renderers, available since v3.1.0. These renderers come in the PRADO release. They are essentially controls implementing the IDataRenderer interface. Common Web controls, such as TTextBox, TLabel, all implement this interface. When such controls are used item renderers, their Data property is assigned with the row of the data being bound to the repeater item.

Run Sample View Source

More often, one needs to customize the layout of repeater items. The sample above relies on OnItemCreated to adjust the appearance of the renderer. Templated item renderers are perferred in this situation, as they allow us to put in more complex layout and content in a repeater item. The following sample reimplements the nested repeater sample using a templated item renderer called RegionDisplay. As we can see, the new code is much easier to understand and maintain.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TSlider

API Manual

TSlider displays a slider for numeric input purpose. A slider consists of a track which define the range of possible value, and a handle which can slide on the track, to select a value in the range. The track can be either Horizontal or Vertical, depending of the Direction property. By default, it's horizontal.

The range boundaries are defined by MinValue and MaxValue properties. The default range is from 0 to 100. The StepSize property can be used to define the step between 2 values inside the range. Notice that this step will be recomputed if there is more than 200 values between the range boundaries. You can also provide the allowed values by setting the Values array.

The handle sub-properties can be accessed by Handle property. You can also provide your own control for the handle, using HandleClass property. Note that this class must be a subclass of TSliderHandle

The TSlider control can be easily customized using CssClasses. You can provide your own css file, using the CssUrl property. The css class for TSlider can be set by the CssClass property. Defaults values are 'hslider' for an Horizontal slider, or 'vslider' for a Vertical one. The css class for the Handle can be set by the Handle.CssClass subproperty. Defaults is 'handle', which just draw a red block as a cursor. 'handle-image' css class is also provided for your convenience, which display an image as the handle.

If AutoPostBack property is true, postback is performed as soon as the value changed.

TSlider raises the onValueChanged event when the value of the slider has changed during postback.

You can also attach ClientSide javascript events handler to the slider :

  • ClientSide.onSlide is called when the handle is slided on the track. You can get the current value in the value javascript variable. You can use this event to update on client side a label with the current value
  • ClientSide.onChange is called when the slider value has changed (at the end of a move).

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TStatements

API Manual

TStatements evaluates a sequence of PHP statements and displays the content rendered by the statements. To specify the PHP statements to be evaluated, set the Statements property. For example, the following component tag displays the current time on the Web page,

<com:TStatements>
  <prop:Statements>
  setlocale(LC_ALL, 'nl_NL');
  echo strftime("%A %e %B %Y",time());
  </prop:Statements>
</com:TStatements>

Note, TStatements evaluates the PHP statements during the rendering control lifecycle. Unlike TExpression, TStatements only displays the content 'echoed' within the statements.

The context of the statements in a TStatements control is the control itself. That is, $this represents the control object if it is present in the statements. For example, the following statement tag will display the title of the page containing the TStatements control.

<com:TStatements>
  <prop:Statements>
  $page=$this->Page;
  echo $page->Title;
  </prop:Statements>
</com:TStatements>

Be aware, since TStatements allows execution of arbitrary PHP code, in general you should not use it to evaluate PHP code submitted by your application users.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TTable

API Manual

TTable displays an HTML table on a page. It is used together with TTableRow and TTableCell to allow programmatically manipulating HTML tables. The rows of the table is stored in Rows property. You may set the table cellspacing and cellpadding via the CellSpacing and CellPadding properties, respectively. The table caption can be specified via Caption whose alignment is specified by CaptionAlign. The GridLines property indicates how the table should display its borders, and the BackImageUrl allows the table to have a background image.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TTabPanel

API Manual

TTabPanel displays a tabbed panel. Users can click on the tab bar to switching among different tab views. Each tab view is an independent panel that can contain arbitrary content.

A TTabPanel control consists of one or several TTabView controls representing the possible tab views. At any time, only one tab view is visible (active), which is specified by any of the following properties:

  • ActiveViewIndex - the zero-based integer index of the view in the view collection.
  • ActiveViewID - the text ID of the visible view.
  • ActiveView - the visible view instance.

If both ActiveViewIndex and ActiveViewID are set, the latter takes precedence.

TTabPanel uses CSS to specify the appearance of the tab bar and panel. By default, an embedded CSS file will be published which contains the default CSS for TTabPanel. You may also use your own CSS file by specifying the CssUrl property. The following properties specify the CSS classes used for elements in a TTabPanel:

  • CssClass - the CSS class name for the outer-most div element (defaults to 'tab-panel');
  • TabCssClass - the CSS class name for nonactive tab div elements (defaults to 'tab-normal');
  • ActiveTabCssClass - the CSS class name for the active tab div element (defaults to 'tab-active');
  • ViewCssClass - the CSS class for the div element enclosing view content (defaults to 'tab-view');

To use TTabPanel, write a template like following:

<com:TTabPanel>
   <com:TTabView Caption="View 1">
     content for view 1
   </com:TTabView>
   <com:TTabView Caption="View 2">
     content for view 2
   </com:TTabView>
   <com:TTabView Caption="View 3">
     content for view 3
   </com:TTabView>
 </com:TTabPanel>
Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TTextBox

API Manual

TTextBox displays a text box on a Web page. The content in the text box is determined by the Text property. You can create a SingleLine, a MultiLine, or a Password text box by setting the TextMode property. The Rows and Columns properties specify their dimensions. If AutoPostBack is true, changing the content in the text box and then moving the focus out of it will cause postback action.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TTextHighlighter

API Manual

TTextHighlighter does syntax highlighting for its body content, including both static text and the rendering results of its child controls. The text being highlighted follows the syntax of the specified Language, which can be 'php' (default), 'prado', 'css', 'html', etc. Here, 'prado' stands for the syntax of PRADO control templates.

If line numbers are desired in front of each line, set ShowLineNumbers to true.

To use TTextHighlighter, simply enclose the contents to be syntax highlighted within the body of a TTextHighlighter control. The following example highlights a piece of PHP code,

<com:TTextHighlighter ShowLineNumbers="true">
<?php
$str = 'one|two|three|four';
print_r(explode('|', $str, 2)); // will output an array
?>
</com:TTextHighlighter>
Run Sample View Source
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TWizard

API Manual

Overview

TWizard is analogous to the installation wizard commonly used to install software on Windows. It splits a large form and presents the user with a series of smaller forms, called wizard steps, to complete. The following figure shows how a wizard is composed of when presented to users, where step content is the main content of a wizard step for users to complete, header refers to header content common to all steps, navigation contains buttons that allow users to navigate step by step, and side bar contains a list of hyperlinks by which users can reach to any step with one click. The visibility of the side bar can be toggled by setting ShowSideBar.

components of wizard

By default, TWizard embeds the above components in an HTML table so that the side bar is displayed on the left while the rest on the right. If UseDefaultLayout is set to false, no HTML table will be used, and developers should use pure CSS techniques to position the wizard components. Note, each component is displayed as a <div> and the wizard itself is also a <div> that encloses its components' <div>.

Wizard steps are represented by TWizardStep and are maintained in TWizard through its WizardSteps property. At any time, only one step is visible, which is determined by the ActiveStep property. The ActiveStepIndex property gives the index of the active step in the step collection. Clicking on navigation buttons can activate different wizard steps.

Wizard steps are typically added to a wizard through template as follows,

<com:TWizard>
    <com:TWizardStep Title="step 1" StepType="Start">
    content in step 1, may contain other controls
    </com:TWizardStep>

    <com:TWizardStep Title="step 2" StepType="Step">
    content in step 2, may contain other controls
    </com:TWizardStep>

    <com:TWizardStep Title="finish step" StepType="Finish">
    content in finish step, may contain other controls
    </com:TWizardStep>
</com:TWizard>

In the above, StepType refers to the type of a wizard step, which can affect how the navigation appearance and behavior of the step. A wizard step can be of one of the following types:

  • Start - the first step in the wizard.
  • Step - the internal steps in the wizard.
  • Finish - the last step that allows user interaction.
  • Complete - the step that shows a summary to user. In this step, both side bar and navigation panel are invisible. Thus, this step usually does not allow user interaction.
  • Auto - the step type is determined by wizard automatically.

Using TWizard

A Single-Step Wizard Sample

In this sample, we use wizard to collect user's preference of color. In the first step, the user is presented with a dropdown list from which he can choose his favorite color. In the second step, the complete step, his choice in the previous step is displayed. In real application, at this step the choice may be stored in database in the backend.

Run Sample View Source

Customizing Wizard Styles

TWizard defines a whole set of properties for customization of appearance of its various components as shown in the above figure. In particular, the following properties are provided for style customization:

  • Header - HeaderStyle.
  • Step - StepStyle.
  • Navigation - NavigationStyle, StartNextButtonStyle, StepNextButtonStyle, StepPreviousButtonStyle, FinishPreviousButtonStyle, FinishCompleteButtonStyle, CancelButtonStyle.
  • Side bar - SideBarStyle, SideBarButtonStyle.
Run Sample View Source

Customizing Wizard Navigation

Given a set of wizard steps, TWizard supports three different ways of navigation among them:

  • Bidirectional - Users can navigate forward and backward along a sequence of wizard steps. User input data is usually collected at the last step. This is also known as commit-at-the-end model. It is the default navigation way that TWizard supports.
  • Unidirectional - Users can navigate forward along a sequence of wizard steps. Backward move is not allowed. User input data is usually collected step by step. This is also known as command-as-you-go model. To disallow backward move to a specific step, set its AllowReturn property to false.
  • Nonlinear - User input in a step determines which step to go next. To do so, set ActiveStepIndex to the step that you want the user to go to. In this case, when a user clicks on the previous button in the navigation panel, the previous step that they visited (not the previous step in the sequential order) will become visible.
Run Sample View Source

Using Templates in Wizard

TWizard supports more concrete control of its outlook through templates. In particular, it provides the following template properties that allow complete customization of the wizard's header, navigation and side bar.

  • Header - HeaderTemplate.
  • Navigation - StartNavigationTemplate, StepNavigationTemplate, FinishNavigationTemplate.
  • Side bar - SideBarTemplate.
Run Sample View Source

Using Templated Wizard Steps

Wizard steps can also be templated. By using TTemplatedWizardStep, one can customize step content and navigation through its ContentTemplate and NavigationTemplate properties, respectively. This is useful for control developers to build specialized wizards, such as user registration, shopping carts, etc.

Run Sample View Source
Copyright © 2005-2007 PradoSoft.